Anwenden von PC-DMIS NC Gage

NC-Gage - Einführung

Lizenzierung

Konfiguration

Erste Schritte

Erstellen von Elementbefehlen

Einstellen von zusätzlichen Elementparametern

Einfügen von Bewegungsbefehlen

Arbeiten mit Messroutinen

Dateien verwalten

Verwenden von Protokollen

Bildschirmtastaturen verwenden

Werkzeuglänge festlegen - Sofort

Modus 'Direkt verbinden' (DCM)

Anhang A - Konfiguration Steuereinheit


NC-Gage - Einführung

PC-DMIS NC Gage bietet Ihnen ein leicht anwendbares Programmpaket zur Messung von Werkstücken im Online-Betrieb unter Verwendung von NC-Werkzeugmaschinen. NC Gage ist in der Lage, die Produktivität Ihrer Maschine zum Erzeugen von noch genaueren Werkstücken zu optimieren, indem es Ihnen die Möglichkeit gibt, über eine schlichte Benutzeroberfläche mühelos die benötigten Elementmessungen und andere Befehle in die Messroutine einzufügen.

Hinweis zu den Begriffen: Da viele Benutzer NC Gage mit einem Berührungsbildschirm (Touchscreen) ausführen, bedeuten die in dieser Dokumentation verwendeten Verben "auswählen" oder "drücken" für die, die das Programm auf einem Rechner bei voller Kapazität mit den zugehörigen Peripheriegeräten wie Maus und Tastatur ausführen, einfach einen "Mausklick".

In dieser Dokumentation werden folgende Hauptthemen beschrieben:

  • Lizenzierung

  • Konfiguration

  • Erste Schritte

  • Erstellen von Elementbefehlen

  • Einstellen von zusätzlichen Elementparametern

  • Einfügen von Bewegungsbefehlen

  • Arbeiten mit Messroutinen

  • Dateien verwalten

  • Verwenden von Protokollen

  • Werkzeuglänge festlegen - Sofort

  • Modus 'Direkt verbinden' (DCM)

  • Anhang A - Konfiguration Steuereinheit

Letzte Aktualisierung der Hilfedatei: 8. Januar 2016


Lizenzierung

Bevor Sie mit NC Gage arbeiten, muss diese Anwendung linzenziert werden. Dies können Sie beim ersten Programmstart der 'NC Gage'-Anwendung, nachdem die Installation erfolgreich abgeschlossen wurde, tun.

  1. Starten Sie die NCGage-Anwendung mit einer der folgenden Methoden:

    • Wählen Sie aus der Programmgruppe "PC-DMIS NC Gage" aus.

    • Klicken Sie die Windows-Schaltfläche Start, navigieren Sie zu Alle Programme und wählen Sie dann das Symbol für die 'PC-DMIS NC Gage'-Messroutine aus der definierten Programmgruppe aus.

    • Doppelklicken Sie auf das Verknüpfungssymbol "PC-DMIS NC Gage" auf Ihrem Desktop:

Wenn die Anwendung NC Gage zum ersten Mal gestartet wird, wird folgendes Fenster NC Gage - Lizenz-Fehler angezeigt:

  2. Wählen Sie die Schaltfläche Ja aus, um das Fenster NC Gage - Lizenzanfrage einzublenden:

  3. Vervollständigen Sie die Eingaben in den Feldern je nach Bedarf. Felder, die mit einem roten Sternchen (*) gekennzeichnet sind, müssen ausgefüllt werden. Sobald Sie die Eingaben in den erforderlichen Feldern abgeschlossen haben, wird die Schaltfläche Weiter verfügbar.

  4. Klicken Sie auf die Schaltfläche Weiter, um die Lizenzanfrage von NC Gage, wie weiter unten dargestellt, zu erzeugen:

  5. Klicken Sie auf die Schaltfläche Speichern unter, um die Lizenzanfrage als eine Textdatei abzuspeichern. Daraufhin öffnet sich das Fenster Speichern unter.

Navigieren Sie zu einem sicheren Verzeichnis auf dem lokalen oder Netz-Laufwerk und speichern Sie die Datei. Die Datei wird unter dem Namen NCGageLicense.request abgespeichert.

  6. Klicken Sie auf die Schaltfläche Beenden, um das Dialogfeld Lizenzanfrage von NC Gage der Anwendung zu schließen.

  7. Senden Sie die Lizenzanfrage an Ihren Vertriebsbeauftragten von Hexagon, der Ihnen beim Vorgang zum Erwerb der Lizenzdatei behilflich sein wird.

  8. Sobald die Lizenzdatei eintrifft, speichern Sie sie auf Ihrem Rechner ab. Merken Sie sich das Verzeichnis.

  9. Starten Sie die NCGage-Anwendung. Es erscheint der 'NC Gage'-Lizenzfehler.

  10. Klicken Sie auf die Schaltfläche Ja, um das erste Fenster NC Gage Lizenzanfrage anzuzeigen.

  11. Klicken Sie auf die Schaltfläche Ich habe eine Lizenz, um das Fenster NC Gage Lizenzanfrage anzuzeigen:

So importieren Sie die Lizenzangaben aus einer Lizenzanfragedatei:

  1. Wählen Sie die Option Lizenzdatei importieren im Fenster NC Gage Lizenzanfrage aus:

  2. Klicken Sie auf die Schaltfläche Suchen (...), um das Fenster Öffnen einzublenden:

  3. Navigieren Sie zur Lizenzdatei (NCGageLicense.lic) auf dem lokalen oder Netz-Laufwerk und wählen Sie diese aus.

  4. Klicken Sie auf die Schaltlfäche Öffnen, um die Lizenzdateiangaben in das Fenster NC Gage - Lizenzanfrage einzulesen:

  5. Klicken Sie auf die Schaltfläche Fortfahren, um den Lizenzvorgang abzuschließen.

Bei einer Maschine des Typs "Mazak" basiert die Lizenz auf der Seriennummer der Maschine.


Konfiguration

Bevor Sie mit NC-Gage arbeiten, muss das Programm gemäß der Einstellungen Ihrer Werkzeugmaschine konfiguriert werden. Diese Konfiguration wird normalerweise von demjenigen, der auch die Tasterhardware installiert hat, durchgeführt.

Siehe „Anhang A - Konfiguration Steuereinheit“ für eine detaillierte Beschreibung der Konfiguration der Steuereinheit.

Hinweis: Auf dem Rechner, auf dem "NC Gage" ausgeführt wird, muss ".NET 2.0" installiert sein. Sollte ".NET 2.0" bereits installiert sein, dann wird "NC Gage" installiert, wenn Sie dazu aufgefordert werden. Wenn ".NET 2.0" nicht installiert ist, dann wird der Benutzer von der Installationsroutine gefragt, ob das Programm heruntergeladen und installiert werden soll. Durch Klicken auf OK wird der Benutzer mit der Website von Microsoft vernetzt, wo er ".NET 2.0" herunterladen und installieren kann.

Anmerkungen zu den Betriebssystemen "Windows OS": Bei der Anwendung eines 'Virtuelle Maschine'-Dienstprogrammes (z. B. VMWare), um NC Gage in einer anderen Sprache als auf Englisch auszuführen, erfasst und aktualisiert Windows OS möglicherweise die Einstellungen von Sprache und Region auf den 'Virtuelle Maschine'-Client automatisch (Punkte können beispielsweise als Kommata umgeändert werden). Beim Zurückschalten auf die englische Sprache aus einer Fremdsprache müssen diese Änderungen mit Hilfe der Einstellungen für Region und Sprache manuell innerhalb der Systemsteuerung von Windows OS zurückgesetzt werden, um Messfehler zu verhindern.

Aktualisierung der Windows-Umgebung und der Spracheinstellungen

  1. Gehen Sie zur Systemsteuerung:

  2. Klicken Sie auf die Option Region und Sprache. Nehmen Sie, falls erforderlich, die Änderungen im Fenster Region und Sprache vor:

  3. Klicken Sie auf:

    • OK, um die vorgenommenen Änderungen zu akzeptieren und zur Systemsteuerung zurückzukehren

    • Abbrechen, um das Fenster ohne Speichervorgang zu schließen

    • Übernehmen, um die vorgenommenen Änderungen zu speichern, ohne das Fenster zu schließen

  4. Klicken Sie auf die Schaltfläche Zusätzliche Einstellungen.... Nehmen Sie die notwendigen Änderungen für die bestimmten Regions- und Spracheinstellungen vor:

  5. Klicken Sie auf:

    • OK, um die im Fenster Format anpassen vorgenommenen Änderungen zu speichern und zum Fenster Region und Sprache zurückzukehren

    • Abbrechen, um das Fenster ohne Speichervorgang zu schließen

    • Übernehmen, um die vorgenommenen Änderungen zu speichern, ohne das Fenster zu schließen

Gehen Sie zu "Erste Schritte".


Erste Schritte

Diese Abschnitte helfen Ihnen bei Ihren ersten Schritten mit PC-DMIS NC Gage. Vor dem Starten:

  • Ihre NC-Maschine muss eingeschaltet sein.

  • Die 'NC Gage'-Software sollte installiert und entsprechend zugelassen sein.

  • Ihr Programm sollte konfiguriert worden sein. Weitere Informationen finden Sie unter „Anhang A - Konfiguration Steuereinheit“ für weitere Informationen.

Die Schritte beinhalten:

  • Schritt 1: Software starten und verbinden

  • Schritt 2: 'NC Gage'-Parameter einstellen

  • Schritt 3: Neuen Taster erstellen

  • Schritt 4: Taster auswählen

  • Schritt 5: Kalibrierung

  • Schritt 6: Arbeitsversatz definieren

  • Schritt 7: Definieren von Toleranzrahmen

  • Schritt 8: Definieren eines Sicherheitspfades

Über Systemmeldungen

Während Sie sich durch diese Schritte durcharbeiten, beachten Sie die Informationen im Bereich Systemmeldungen im Hauptfenster von NC Gage.

Beispiel - Bereich 'Systemmeldungen'

  • Meldungen in rot kennzeichnen erforderliche Prozeduren, die noch nicht durchgeführt wurden, oder ein anderes Problem.

  • Die Warn-Meldung zeigt Ihnen die Maßnahmen an, die vor der Messung Ihres Werkstückes umgesetzt werden müssen.

  • Nachdem die erforderlichen Maßnahmen durchgeführt wurden, wird der Eintrag im Bereich Systemmeldungen blau angezeigt.

Sobald Sie die oben aufgeführten Schritte abgeschlossen haben, können Sie mit NC Gage eine Messroutine erstellen und ausführen.

Softkeys der Navigationsleiste

Die auf der Navigationsleiste des Hauptfensters verfügbaren Softkeys sind in der Tabelle unten aufgelistet. Durch Berühren eines dieser Softkeys wird ein mit dem entsprechenden Softkey verknüpftes Funktionsfenster geöffnet oder die angegebene Aktion durchgeführt.

Hinweis zu den Begriffen: Ein Softkey ist eine berührungsempfindliche Schaltfläche unten im Fenster der Steuereinheit, die verschiedenen Funktionen im jeweiligen Fenster zugeordnet ist. Einige Bildschirme besitzen mehrere "Softkey-Seiten". Sie können auf diese "Softkey-Seiten" über die Softkeys Vorwärts zugreifen.

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Einstellungen Dieser Softkey öffnet den Setup-Bildschirm, wo Sie die Einstellungen für NC Gage Messroutinen definieren können. | Symbolleiste Dieser Softkey zeigt die Softkeys für den Taster, mit denen ein Taster erstellt, ausgewählt oder kalibriert werden kann, auf der Navigationsleiste an.
Bewegen Dieser Softkey öffnet den Bildschirm Bewegen für Sicherheitspunkte und -ebenen. | Drehachsen verschieben Dieser Softkey öffnet das Fenster Drehachsen verschieben, über den Sie die Drehachse setzen können.
Arbeitsversatz auswählen - Erste Seite Mit diesem Softkey können Sie einen Arbeitsversatz vom Bildschirm Arbeitsversatz auswählen, um das NC Gage-Programm zu bestimmen. Diese Messroutine wird dann zum Programm hinzugefügt und gespeichert. | Messen Dieser Softkey öffnet den Bildschirm Messen und ermöglicht Zugriff auf alle Elementtypen, die gemessen werden können.
Messroutine ausführen Dieser Softkey öffnet das Fenster Messroutine, über das Sie die Messroutine ausführen können. | Datei-Manager Dieser Softkey öffnet den Bildschirm Datei-Manager, wo Sie mit Messroutinen arbeiten und diese speichern, laden, erstellen und löschen können.
Protokoll Dieser Softkey öffnet den Bildschirm Protokoll, wo Sie Messprotokolle für Ihre Messroutine anzeigen lassen oder diese speichern sowie drucken können. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.
Beenden Mit diesem Softkey wird NC Gage beendet. Es erscheint ein Ja/Nein-Meldungsfeld. Drücken Sie auf Messroutine beenden [image] , um das Programm zu schließen oder drücken Sie auf Zurück zum Hauptfenster [image] , um zu NC Gage zurückzukehren. | Messroutine bearbeiten Dieser Softkey öffnet den Bildschirm Messroutine bearbeiten, wo Sie Messroutinen ausführen oder bearbeiten können.
Direct Connect-Modus Mit diesem Softkey wird das Fenster Modus 'Direkt verbinden' aufgerufen. Hier können Sie eine 'NC Gage'-Messroutine direkt aus einem Schnittmakro so aufrufen, als ob die 'NC Gage'-Messroutine ein Unterprogramm wäre. | Arbeitsversatz einstellen - Zweite Seite Mit dieser Option kann der Benutzer den Arbeitsversatz auf der Steuereinheit aktualisieren, indem eine Auswahl von Elementen gemessen wird. Diese Routine wird einer Messroutine nicht hinzugefügt.
Informations-Manager - Zweite Seite Über diesen Softkey kann der Benutzer Meldungen, die die Verbindung von NC-Gage mit der Steuereinheit betreffen, sowie alle Fehlermeldungen bezüglich NC-Gage anzeigen lassen. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Werkzeugversatz setzen Dieser Softkey öffnet das Fenster Arbeitsversatz setzen, über den Sie den Arbeitsversatz setzen können. |


Software starten und verbinden

Home > Anwenden von PC-DMIS NC Gage > Erste Schritte > Schritt 1: Software starten und verbinden

Schritt 1: Software starten und verbinden

Nach der Installation und Lizensierung von NC Gage kann die Anwendung wie folgt gestartet werden:

  • Wählen Sie die Anwendung aus der Programmgruppe

  • Starten Sie Windows, klicken Sie die Windows-Schaltfläche Start, navigieren Sie zu Alle Programme und wählen Sie dann das Symbol für das 'PC-DMIS NC Gage'-Programm aus der definierten Programmgruppe aus:

Der Hauptbildschirm für "NC Gage" wird geöffnet:

Wenn Sie NC-Gage zum ersten Mal starten, versucht das Programm, eine Verbindung zum Werkzeugmaschine herzustellen. Informationen zu dieser Verbindung werden im Bereich Status angezeigt.

Wenn der Softkey Status in der Mitte der Navigationsleiste rot ist, dann konnte keine Verbindung zur Maschine hergestellt werden:

Wenn NC Gage mit der Maschine verbunden ist, werden die Tasterkoordinaten im Fenster angezeigt. Der Softkey Status in der Mitte der Navigationsleiste wird grün und zeigt im Bereich Status die Anzeige "Verbunden".

Wenn Sie NC Gage zum ersten Mal starten, sehen Sie in der Option Kalibrierung im Bereich Systemnachrichten die Anzeige "--Keine--". Ebenfalls sind die Softkeys Messen [image] und Bewegen [image] auf der Navigationsleiste deaktiviert (grau und nicht verfügbar). D.h., Sie müssen einige vorbereitende Maßnahmen durchführen, bevor Sie mit der Software eine Messroutine erstellen und ein Werkstück messen können.

Die nächste Aufgabe, die Sie erledigen müssen, wird Ihnen als 'Warnung:' im Bereich 'Systemmeldungen' angezeigt.


"NC Gage"-Parameter einstellen

Home > Anwenden von PC-DMIS NC Gage > Erste Schritte > Schritt 2: 'NC Gage'-Parameter einstellen

Schritt 2: 'NC Gage'-Parameter einstellen

Drücken Sie im Hauptfenster den Softkey Einrichten [image], um das Fenster Einrichten aufzurufen.

In diesem Fenster können Sie mehrere Mess- und Hardwareparameter zur Verwendung während des Messvorganges definieren.

So modifizieren Sie die allgemeinen 'NC-Gage'-Parameter:

  1. Bearbeiten Sie die Werte je nach Bedarf.

  2. Drücken Sie den Softkey Bestätigen [image], um alle vorgenommenen Änderungen zu speichern. Drücken Sie den Softkey Zurück [image], um dieses Fenster zu verlassen, ohne dass Änderungen gespeichert werden.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Toleranzklassen definieren Über diesen Softkey haben Sie die Möglichkeit, das Fenster für die Toleranzklassen-Definition aufzurufen. Weitere Informationen unter "Benutzerdefinierte Toleranzklassen". | Arbeitsflächen-Ausrichtung für die Maschine einrichten Dieser Softkey definiert die Arbeitsfläche für Ihre Messroutine. Weitere Informationen unter "Einrichtung der Arbeitsebene".
System-Setup Mit diesem Softkey können Sie die Einstellungen für das NC-Gage-Fenster und beim Schließen einrichten. Weitere Informationen unter "System einrichten". | Kinematik-Einstellung Im Fenster Kinematik-Einstellung können die Informationen zur Drehkonfiguration abgerufen werden. Damit können bestimmte Konfigurationseinstellungen für Drehachsen bearbeitet werden.
Passwort einrichten Das Fenster Passwort einrichten enthält eine Methode zur Aktivierung bzw. Deaktivierung des Kennwortschutzes auf allen Setup-Fenstern in NC Gage. | Positionsanzeige einrichten Im Fenster Positionsanzeige einrichten können Sie die Anzeige für Zähler in den relevanten NC Gage-Fenstern bestimmen.
Anwenden oder Änderungen bestätigen Über diesen Softkey werden vorgenommene Änderungen der Optionen, Einstellungen oder Auswahlen im aktuellen Fenster akzeptiert. In einigen Fällen fügt dieser Softkey einen Befehl in ein NC Gage Messroutine ein. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.
Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung. |

Bereich "Toleranz"

  • Plus - Gibt den standardmäßigen oberen Toleranzwert, aus denen die Werkstückmerkmale ausgewertet werden, an.

  • Minus - Gibt den standardmäßigen unteren Toleranzwert, aus denen die Werkstückmerkmale ausgewertet werden, an.

  • Die Einstellung dieser Werte erlaubt Ihnen die Festlegung der Toleranzen für die zukünftige Verwendung im Fenster Toleranz für andere Elemente, indem Sie die Liste Allgemeine Toleranzgrenzen auswählen von diesem Fenster aus verwenden. Damit können Sie schnell dieselben Toleranzwerte wiederholt auswählen und eingeben. Siehe "Benutzerdefinierte Toleranzklassen".

Bereich "Option zum Speichern des Protokolls"

  • Speicherpfad - Definiert den Speicherort des Protokolls. Die Messroutine wird unter den gleichen Pfad im Unterverzeichnis PRG gespeichert.

  • Autom. Speichern - Wenn diese Option deaktiviert ist, wird NC Gage nach Ausführung einer Messroutine die Protokolle nicht automatisch speichern, d.h, diese müssen manuell gespeichert werden. Wenn dieses Kontrollkästchen aktiviert ist, sind die Optionen Überschreiben und Zeitstempel verfügbar. Wählen Sie die gewünschte Option:

    • Überschreiben - Wenn Sie diese Option wählen, speichert NC Gage das erste Protokoll automatisch im Verzeichnis Speicherpfad. NC Gage ersetzt diesen Protokoll automatisch bei der nächsten Ausführung.

      Jedes Protokoll besitzt denselben Dateinamen. Das Format lautet: <Messroutine>.rtf, dabei ist <Messroutine> der Name der zuletzt ausgeführten Messroutine.

    • Zeitstempel - Wenn Sie diese Option wählen, speichert NC Gage jedes Protokoll automatisch im Verzeichnis Speicherpfad. NC Gage ersetzt keinen der gespeicherten Protokolle.

      Jedes Protokoll besitzt einen anderen Dateinamen. Das Format lautet: <Messroutine>_<M>-<TT>-<JJ>_<hh>-<mm>-<ss>.rtf, dabei ist:

<Messroutine> - Name der aktuell geladenen Messroutine ohne die Erweiterung ".prg"

<M> oder <MM> - Ein- oder zweistellige Angabe des Monats abhängig vom Datum Ihres Computersystems

<TT> - Zweistellige Angabe des Tages abhängig vom Datum Ihres Computersystems

<JJ> - Vierstellige Angabe des Jahres abhängig vom Datum Ihres Computersystems

<hh> - Zweistellige Angabe der Stunde (24-Stunden-Format) zu der das Protokoll gespeichert wurde. Abhängig von der Zeit Ihres Computersystems.

<mm> - Zweistellige Angabe der Minute zu der das Protokoll gespeichert wurde. Abhängig von der Zeit Ihres Computersystems.

<ss> - Zweistellige Angabe der Sekunde zu der das Protokoll gespeichert wurde. Abhängig von der Zeit Ihres Computersystems.

Beachten Sie, dass der 24-Stunden-Zeitstempel, der Zeit entspricht, an der das Protokoll gespeichert wurde (nicht der Zeit an dem die Messroutine ausgeführt wurde). Deshalb besitzt beim mehrmaligen Speichern desselben Protokolls jedes Protokoll einen anderen Dateinamen.

Hinweis: Sie können außerdem unabhängig von den gewählten Einstellungen ein Protokoll zu einer beliebigen Zeit manuell speichern. Das Format des Dateinamens für ein manuell gespeichertes Protokoll lautet: <Messroutine>_<M>-<TT>-<JJ>_<hh>-<mm>-<ss>.rtf

Bereiche "Vorschubgeschwindigkeit" und "Antast-Entfernung"

  • Quervorschub (Vorschubgeschwindigkeit) - Dieses schreibgeschützte Feld zeigt die Geschwindigkeit, mit der sich der Taster zwischen Blöcken der Messroutine fortbewegt. Die Einheiten werden in Millimetern/Minute oder Zoll/Minute angegeben, je nachdem, welche Maßeinheit gewählt wurde.

  • Suche (Vorschubgeschwindigkeit) - Bestimmt die Geschwindigkeit, bei der sich der Taster beim Entdecken von Elementen im Lernmodus fortbewegt. Die Einheiten werden in Millimetern/Minute oder Zoll/Minute angegeben, je nachdem, welche Maßeinheit gewählt wurde.

  • Drehung (Vorschubgeschwindigkeit) - Dieses schreibgeschützte Feld zeigt Bestimmt die maximal erlaubte Geschwindigkeit für die Drehungen der Achsen.

  • Anfahrweg (Antast-Entfernung) - Gibt die Entfernung zur theoretischen Messpunktlage an, zu der sich der Taster vor der Messpunktaufnahme bewegt. Diese Option wird während der Werkstückmessung verwendet. Die Einheiten werden in Millimetern oder in Zoll angegeben, je nachdem, welche Maßeinheit gewählt wurde.

  • Suche (Antast-Entfernung) - Gibt die Entfernung, über die der Taster nach der Fläche sucht, an. Wenn der Taster nicht mit der Fläche in Berührung kommt, nachdem er diese Entfernung durchquert hat, dann schlägt die Messung fehl. Die Einheiten werden in Millimetern oder in Zoll angegeben, je nachdem, welche Maßeinheit gewählt wurde.

Bereich "Dezimalstellen auf-/abrunden"

  • Merkmal-Einrastwert - NC Gage wird veranlasst, die theoretischen Ergebnisse, die vom Taster für jedes Element während des Lernprozesses gefunden werden, zu runden. Das Ergebnis wird nach zwei Kriterien gerundet. Zum ersten: Das Ergebnis wird auf die Anzahl der Dezimalstellen in diesem Feld gerundet. Zum Zweiten: Die Ergebnisse werden auf das nächste Vielfache des Wertes in diesem Feld gerundet.

    Beispiel: Wenn das Ergebnis 0.068 lautet und der Wert in diesem Feld 0.03 beträgt, wird folgender Prozess durchgeführt: Zuerst wird 0.068 auf zwei Dezimalstellen gerundet, was 0.07 ergibt. Als Nächstes wird dieser Wert auf das nächste Vielfache von "3" gerundet, damit wird 0.07 zu 0.06, da "6" ein Vielfaches von "3" ist.

  • Winkel-Einrastwert - Funktioniert wie beim "Merkmal-Einrastwert", gilt allerdings für Winkelmessungen.

Bereich "Statistik-Speicheroption"

  • Speicherpfad - Definiert den Speicherort der Statistiken (die Ergebnisse für jedes Element). Die Messroutine wird unter den gleichen Pfad im Unterverzeichnis PRG gespeichert.

  • Autom. Speichern - Wenn diese Option deaktiviert ist, wird NC Gage nach Ausführung einer Messroutine die Statistiken nicht automatisch speichern, d.h, diese müssen manuell gespeichert werden. Wenn dieses Kontrollkästchen aktiviert ist, sind die Optionen Überschreiben und Zeitstempel verfügbar. Wählen Sie die gewünschte Option:

    • Überschreiben - Wenn Sie diese Option wählen, speichert NC Gage den ersten Satz der Statistiken automatisch im Verzeichnis Speicherpfad. NC Gage ersetzt diese Statistiken automatisch bei der nächsten Ausführung.

      Jeder Satz von Statistiken besitzt denselben Dateinamen. Das Format lautet: <Messroutine>.xml, dabei ist <Messroutine> der Name der zuletzt ausgeführten Messroutine.

    • Zeitstempel - Wenn Sie diese Option wählen, speichert NC Gage jedes Protokoll automatisch im Verzeichnis Speicherpfad. NC Gage ersetzt keinen der gespeicherten Protokolle.

      Jeder Satz von Statistiken besitzt denselben Dateinamen. Das Format lautet: <Messroutine>_<M>-<TT>-<JJ>_<hh>-<mm>-<ss>.xml, dabei ist:

<Messroutine> - Name der aktuell geladenen Messroutine ohne die Erweiterung ".prg"

<M> oder <MM> - Ein- oder zweistellige Angabe des Monats abhängig vom Datum Ihres Computersystems

<TT> - Zweistellige Angabe des Tages abhängig vom Datum Ihres Computersystems

<JJ> - Vierstellige Angabe des Jahres abhängig vom Datum Ihres Computersystems

<hh> - Zweistellige Angabe der Stunde (24-Stunden-Format) zu der die Statistiken gespeichert wurden. Abhängig von der Zeit Ihres Computersystems.

<mm> - Zweistellige Angabe der Minute zu der die Statistiken gespeichert wurden. Abhängig von der Zeit Ihres Computersystems.

<ss> - Zweistellige Angabe der Sekunde zu der die Statistiken gespeichert wurden. Abhängig von der Zeit Ihres Computersystems.

Beachten Sie, dass der 24-Stunden-Zeitstempel, der Zeit entspricht, an der die Statistiken gespeichert wurden (nicht der Zeit an dem die Messroutine ausgeführt wurde). Deshalb besitzt beim mehrmaligen Speichern desselben Satzes von Statistiken jeder Satz einen anderen Dateinamen.

Hinweis: Sie können außerdem unabhängig von den gewählten Einstellungen einen Satz von Statistiken zu einer beliebigen Zeit manuell speichern. Das Format des Dateinamens für ein manuell gespeicherten Satz von Statistiken lautet: <Messroutine>_<M>-<TT>-<JJ>_<hh>-<mm>-<ss>.xml


Benutzerdefinierte Toleranzklassen

Im Fenster Benutzdef. Toleranzdiagramm können Sie Toleranzen für die spätere Verwendung im Fenster Toleranz für ein beliebiges Element angeben, indem Sie die Liste Allgemeine Toleranzgrenzen auswählen in diesem Fenster dazu verwenden. Damit können Sie schnell dieselben Toleranzwerte wiederholt auswählen und eingeben.

Benutzertoleranzen definieren:

  1. Drücken Sie im Hauptfenster den Softkey Setup [image].

  2. Drücken Sie den Softkey Toleranzklassen definieren [image], um das Fenster Benutzerdefinierte Toleranzklassen aufzurufen.

  3. Bestimmen Sie für die gewünschte Toleranzdiagrammklassen Toleranzwerte für die +Grenze oder -Grenze.

  4. Sobald Sie die Toleranzdiagrammklassen definiert haben, drücken Sie den Softkey Änderungen anwenden [image]. Sie können nun diese Toleranzdiagrammklassen im Fenster Toleranz auswählen.


Einrichtung der Arbeitsebene

Mit dem Fenster Arbeitsfläche einrichten können Sie die Ausrichtung des Softkeys Arbeitsfläche, die im gesamten Programm immer wieder auftaucht, definieren. Eine Arbeitsfläche ist die Seite des Werkstückes, die gemessen wird. Dieses Konfigurations-Fenster ist hilfreich, wenn der Computerbildschirm, auf dem NC Gage angezeigt wird, sich nicht immer an einer festen Position am Maschinenwerkzeug befindet. Mit diesem Fenster können Sie das Symbol "Arbeitsfläche" individuell konfigurieren oder die Standardkonfiguartion auswählen.

So richtet man eine Arbeitsfläche ein:

  1. Drücken Sie im Hauptfenster den Softkey Setup [image].

  2. Drücken Sie den Softkey Arbeitsflächen-Ausrichtung für die Maschine einstellen [image], um das Fenster Arbeitsfläche einstellen aufzurufen:

  3. Wählen Sie entweder die Standardkonfiguration oder definieren Sie Ihre gewünschten Einstellungen.

  4. Nachdem Sie die Arbeitsfläche bestimmt haben, drücken Sie den Softkey Bestätigen [image] . Wenn Sie daraufhin an einer anderen Stelle im Programm den Softkey Arbeitsfläche betätigen, wird die hier definierte Arbeitsfläche vom Programm verwendet.

  5. Drücken Sie den Softkey Bestätigen [image] , um alle vorgenommenen Änderungen zu speichern. Drücken Sie den Softkey Zurückkehren [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Hinweis: Die Einrichtung für Linkshänder ist zulässig. NC Gage informiert Sie, wenn Sie diese nicht-standardisierten Einstellungen verwenden.


System-Setup

Das Fenster System-Setup enthält:

  • Kontrolleinstellungen für das NC-Gage-Fenster im Bereich Fenster einrichten

  • Einstellungen zum Beenden der Anwendung NC Gage im Bereich Abschaltverhalten

So richten Sie das System ein:

  1. Drücken Sie im Hauptfenster den Softkey Setup [image] .

  2. Drücken Sie den Softkey System einrichten [image], um das Fenster System einrichten aufzurufen:

Bereich "Fenster einrichten"

Neupositionierung zulassen - Das NC-Gage-Fenster kann beliebt auf dem Bildschirm verschoben werden.

Änderung der Größe zulassen - Die Größe des NC-Gage-Fensters kann verändert werden.

Minimieren zulassen - Das NC-Gage-Fenster kann minimiert werden.

Bereich "Abschaltverhalten"

Beenden - Die Anwendung NC Gage kann nur über die 'NC Gage'-Schnittstelle beendet werden.

Ausloggen - Die Anwendung NC Gage wird über die 'NC Gage'-Schnittstelle abgemeldet, wobei auch das aktuelle Benutzerkonto des Rechners abgemeldet wird.

Herunterfahren - Die Anwendung NC Gage wird über die 'NC Gage'-Schnittstelle herunter gefahren, wobei auch der Rechner herunter gefahren wird.

Eine Datei ausführen - Die Anwendung NC Gage wird beendet, sofern sie über die 'NC Gage'-Schnittstelle gestartet wurde. Allerdings wird danach die ausgewählte Datei ausgeführt.

Drücken Sie den Softkey Bestätigen [image] , um alle vorgenommenen Änderungen zu speichern. Drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.


Passwort einrichten

Im Fenster Kennwort einrichten ist es möglich, ein Kennwort für die 'NC Gage'-Anwendung einzurichten, um unbefugte Änderungen an den Systemeinstellungen zu vermeiden.

  1. Drücken Sie im Hauptfenster den Softkey Setup [image] .

  2. Drücken Sie den Softkey Kennwort einrichten [image], um das Fenster Kennwort einrichten aufzurufen:

  3. Drücken Sie den Softkey Bestätigen [image] , um alle vorgenommenen Änderungen zu speichern. Drücken Sie den Softkey Zurückkehren [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Kennwortschutz deaktiviert - Wählen Sie diese Option aus, um den gesamten Kennwortschutz im System auszuschalten. Der Bereich Kennwort einrichten wird dadurch deaktiviert und erscheint für den Anwender abgeblendet.

Zum Ändern der Setup-Werte Kennwort erforderlich - Wählen Sie diese Option aus, um den System-Kennwortschutz zu aktivieren. Der Bereich Kennwort einrichten wird aktiviert und der Benutzer hat nun die Möglichkeit, die Kennwortangaben einzugeben.

Bereich "Kennwort einrichten"

Ein Kennwort eingeben: - Geben Sie das zu verwendende Kennwort ein, um die Systemeinstellungen vor ungewollten Änderungen zu schützen.

Kennwort verifizieren - Geben Sie das Kennwort, das Sie im Feld Kennwort eingeben eingegeben haben, zur Verifizierung erneut ein.


Kinematik-Einstellung

Das Fenster Kinematik-Einstellung bietet eine Methode zur Anzeige der Drehkonfigurationsangaben. Es kann zur Bearbeitung bestimmter Konfigurationseinstellungen der Drehachsen eingesetzt werden. Die Drehtisch- oder DSE-Angaben sollten zunächst im Konfigurationswerkzeug der Maschine definiert werden.

Die Seite Kinematik-Einstellung kann mit einem Kennwort versehen werden, um unberechtigte Änderungen zu vermeiden. Dieses Fenster ist nur dann verfügbar, wenn mindestens ein Drehtisch innerhalb des Maschinenkonfigurations-Werkzeugprogrammes für das System konfiguriert ist.

Vor dem ersten Programmstart von NC Gage muss die Schnittstelle der Maschine über die erforderlichen Steuerungsangaben verfügen. Zur Definition dieser Parameter müssen Sie das Konfigurationswerkzeug von NC Gage verwenden:

  • Achse - Definiert die Achsen X, Y, Z, A, B oder C des Systems.

  • Versatz - Definiert den Index in die Systemvariablentabellen für die Achse.

  • Achsentyp - Wählen Sie unter den Optionen "Linear", "Drehtisch" und "DSE". In einer zukünftigen Version wird die Option "Spindelachsen" enthalten sein.

  • Start- und Endgrenze - Definiert den Bereich der zulässigen Bewegung.

  • Die Achse sperren oder Sperre aufheben - Mit diesen benutzerdefinierten Zeichenfolgen werden Befehle, die zum Entsperren (oder Entklemmen) der Achse vor der Bewegung, und zum Sperren (oder Klemmen) der Achse nach der Bewegung verwendet werden, definiert. Diese Zeichenfolgen sind optional.

  • Drehtisch Stapelreihenfolge - Ist mehr als ein Drehtisch definiert, muss die Stapelreihenfolge der Drehtische vorgegeben werden. Diese Optionen sind so lange ausgeblendet, bis zwei Drehtische in der Achsentabelle definiert wurden. Die Optionen für die Auswahl der Auswahlliste wird von den beiden in der Tabelle definierten Achsen abgeleitet. NC Gage behält diese Einstellung intern bei, indem die "dominante" Achse, die als der "untere" Tisch definiert ist (Achse B in der ersten Abbildung weiter unten), abgespeichert wird.

  • Tasterrichtung (Tastspitze auf Spindel) Wenn DSE bei 0 - Wenn eine DSE definiert wird (wie es bei einer Fräs-Dreh-Werkzeugmaschine der Fall ist), muss die Richtung des DSE-Tasters (definiert von der Tastspitze zur Spindel), wenn sich die DSE bei der Position 0 (Null) befindet, vorgegeben werden. Diese Option ist so lange abgeblendet, bis in der Auswahlliste der Achsentypen eine DSE markiert wurde (Achse B in der zweiten Abbildung weiter unten).

  • Pivot-Typ - Wählen Sie zur Bestimmung des Pivot-Typs eine Option aus der Auswahlliste aus. Verfügbare Optionen sind: WristCenter (DSE-Mitte) und WristZero (DSE-Nullpunkt).

  • Pivot-Abstand - Geben Sie den Pivot-Abstand für die DSE ein.

Hinweis - Die Auswahlliste Reihenfolge Drehtisch ist nur dann auf der Registerkarte Achseneinrichtung des Konfigurations-Tools von NC Gage verfügbar, wenn zwei Drehtische definiert wurden. Wenn ein Drehtisch und eine DSE definiert wurden (wie für eine Fräs-Dreh-Werkzeugmaschine), dann wird die Auswahlliste Reihenfolge Drehtisch durch die Bereiche Tasterrichtung (Tastspitze auf Spindel) wenn DSE bei 0 und Drehpunkt ersetzt, wie in der Abbildung weiter unten veranschaulicht ist:

Wenn dies der Fall ist, dann erscheint dieser Bereich nicht. Wenn für eine Fräs-Dreh-Werkzeugmaschine eine DSE definiert wurde, dann muss die DSE auf die B-Achse und der Drehtisch auf die C-Achse gesetzt werden.

Beispiel der Registerkarte 'NC Gage Konfigurationswerkzeug Achsen-Einstellung' für zwei Drehtische

Beispiel der Registerkarte 'NC Gage Konfigurationswerkzeug Achsen-Einstellung' für Fräs-Dreh-Werkzeugmaschinen

Bei Maschinen, die über mindestens eine DSE-Achse verfügen (Fräsen-Drehen-Werkzeugmaschinen und Maschinen mit zwei Köpfen), wird die Auswahlliste Tasterrichtung (Tastspitze auf Spindel) wenn DSE bei 0 eingeblendet. Hiermit wird die Richtung, in der der Taster zeigt, wenn alle DSE-Winkel bei Null sind, festgelegt (Dies bedeutet entlang der Mittellinie des Taster nach oben oder unten - weg vom - Taster). Hiermit wird die Richtung, in der der Taster zeigt, wenn alle DSE-Winkel bei Null sind, festgelegt (Dies bedeutet entlang der Mittellinie des Taster nach oben oder unten - weg vom - Taster).

Hinweis - Das Konfigurationswerkzeug von NC Gage definiert die Einrichtung der Achsen als XYZBC, wobei B den DSE-Typ und C den Drehtisch-Typ darstellt.

So zeigen Sie die Drehkonfigurationsangaben an:

  1. Drücken Sie im Hauptfenster den Softkey Setup [image] .

  2. Drücken Sie den Softkey Kinematik-Einstellung [image] im Fenster Einrichten, um das Fenster Kinematik-Einstellung einzublenden:

Die in den Bereichen der 4.Achse und der 5. Achse verfügbaren Felder sind davon abhängig, ob zwei Drehtische oder ein Drehtisch und eine DSE definiert wurden. Das Fenster Kinematik-Einrichtung weiter oben zeigt die Optionen, die verfügbar sind, wenn NC Gage für duale Drehtische konfiguriert ist. Wurde die Konfiguration für einen DSE-Kopf durchgeführt (wie es bei Fräs-Dreh-Werkzeugmaschinen der Fall ist):

  • Die Optionen Pivot X, Pivot Y und Pivot Z für die 4. (DSE-) Achse werden im Fenster nicht eingeblendet.

  • Die Auswahlliste Tasterrichtung (Tastspitze auf Spindel) wenn DSE bei 0) ersetzt die Liste Drehtisch-Reihenfolge.

Die Seite Kinematik-Einstellung in NC Gage zeigt die Werte Achse und Achsentyp, die im Maschinenkonfigurations-Werkzeug definiert wurden. Sie können nicht innerhalb der NCGage-Schnittstelle bearbeitet werden.

Der Benutzer kann die Start- und Endbegrenzungen je nach Bedarf für das spezifische System bearbeiten.

Der Bereich oben rechts zeigt dieselben Einstellungen an, die weiter oben für das Konfigurations-Tool in NC Gage beschrieben wurden und diese hängen davon ab, ob zwei Drehtische oder aber ein Drehtisch und eine DSE definiert wurden. Änderungen können bezüglich der Drehtisch-Reihenfolge (oder an der Auswahlliste Tasterrichtung (Tastspitze auf Spindel) wenn DSE bei 0) auf diesem Formblatt oder innerhalb des Konfigurations-Tools der Maschine vorgenommen werden.

Das Fenster Kinematik-Einstellung in NC Gage gibt dem Benutzer die Möglichkeit, die Werte, die für die folgenden Kinematik-Transformationen erforderlich sind, zu definieren:

  • Drehpunkt - Dies kann ein beliebiger Punkt auf der Drehachse sein.

  • Drehachsenvektor - Definiert die Richtung der Drehachse.

  • Rotation im Uhrzeigersinn - Die Fahrtrichtung definiert die Richtung, in der sich die Tische in positiven Inkrementen schnell drehen. Bei Auswahl von Ja in der Auswahlliste erfolgt die Drehung im Uhrzeigersinn. Wählen Sie Nein, damit die Drehung entgegen dem Uhrzeigersinn erfolgt. Weiter unten finden Sie unter "Rotationsabbildungen" entsprechende Abbildungen zu diesen Definitionen.

Um den Rotationsmittelpunkt aus der Steuereinheit einzulesen, drücken Sie den Softkey Rotationsmitte aus Steuereinheit lesen [image].

Hinweis: Bestätigen Sie, dass diese Rotationsmittenwerte für diesen Arbeitsvorgang angemessen sind, vorausgesetzt der Tatsache, dass die Werte ordnungsgemäß in die Steuereinheit eingegeben wurden. Wenn die Werte auf der Steuereinheit falsch sind, ist Hexagon Metrology dafür nicht verantwortlich.

Folgen Sie den Bildschirmanweisungen und drücken Sie dann den Softkey Bestätigen [image] , um den Vorgang abzuschließen. Drücken Sie den Softkey Zurückkehren [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Rotationsabbildungen


Positionsanzeige einrichten

Im Fenster Positionsanzeige einrichten können Sie die Anzeige für Zähler in den relevanten 'NC Gage'-Fenstern bestimmen.

Die Zählersteuerungen in NC Gage zeigen normalerweise Vierer-Zahlenreihen an. Im Fenster Positionsanzeige einrichten können Sie definieren, was auf der linken und/oder rechten Seite der Steuerung angezeigt werden soll. In unterschiedlichen Fenstern stehen dafür unterschiedliche Auswahlmöglichkeiten zur Verfügung.

NC Gage bietet drei verschiedene „Ebenen“, in denen Sie die Möglichkeit haben, Zähler einzurichten:

  • Beim Lernvorgang individueller Befehle sollte der Benutzer die Anzeige als „Elementansicht“ aufrufen.

  • Wenn Sie zum Hauptfenster navigieren oder eine Messroutine ausführen, dann sollten Sie die "Messroutine-Ansicht" anzeigen, da dies eine höhere Ebene innerhalb der 'NC Gage'-Anwendung ist.

  • Die „Kalibrieransicht“ ist für die Dauer des Kalibriervorganges da.

So rufen Sie dieses Fenster auf:

  1. Drücken Sie im Hauptfenster den Softkey Setup [image] .

  2. Drücken Sie den Softkey Positionsanzeige einrichten [image] aus der ersten Seite des Fensters Einrichten zur Anzeige des Fensters Positionsanzeige einrichten:

  3. Drücken Sie den Softkey Bestätigen [image] , um alle vorgenommenen Änderungen zu speichern. Drücken Sie den Softkey Zurückkehren [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

In den meisten 'NC Gage'-Fenstern wird ein Zählerfeld angezeigt. Im Zählerfeld haben vier Zählersätze Platz. In früheren Versionen von NC Gage war die linke Seite normalerweise für Maschinenkoordinaten, und die rechte Seite für Arbeitsversatzkoordinaten bestimmt. In der Version 2.0 von NC Gage steht Ihnen nun ein neues Ausrichtungssystem zur Verfügung, das da, wo es sinnvoll erscheint, eingesetzt werden kann.

Das neue Ausrichtungssystem lautet Werkstückkoordinaten. Die Version ab 2.0 von NC Gage bietet dem Anwender mehr Flexibilität, was die Darstellung der aktuellen Tasterposition betrifft.

Fenster "Positionsanzeige einrichten"

Für die Auswahl der Positionsanzeige stehen Vier Koordinatensysteme zur Verfügung. Die Koordinatensysteme lauten:

  • Maschine - Die Zähler zeigen die aktuelle Tasterposition in Maschinenkoordinaten an.

  • Position - In diesem Zähler wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, angezeigt.

  • Puffer

  • Bleiben

Bereich Die XYZ-Werte – und BA-Werte –, die für jeden Koordinatentyp protokolliert werden, können so konfiguriert werden, dass die Art und Weise, wie die Werkzeuglänge übernommen wird, ausgewählt werden kann.

Zähler-Layout - Die Zähler werden normalerweise als zwei Koordinatensatzpaar(e) definiert. Allerdings ist auf manchen Bildschirmen nur ein Zählersatz sichtbar. NC Gage gibt Ihnen die Möglichkeit, die Ansicht in jedem Koordinatensatz beliebig zu bestimmen, indem die linke und die rechte Seite definiert werden. Sie haben die Möglichkeit, drei verschiedene Bereiche zu definieren:

  • Elementansicht - Mit dieser Einstellung wird festgelegt, welche Zähler angezeigt werden können, wenn Elementbefehle gelernt werden. Aus den oben definierten drei Koordinatensystemen kann beliebig ausgewählt werden.

  • Messroutine-Ansicht - Mit dieser Einstellung wird festgelegt, welche Zähler angezeigt werden können, wenn NC Gage ein Fenster einblendet, das auf eine gesamte Messroutine angewendet wird. Aus den oben definierten drei Koordinatensystemen kann beliebig ausgewählt werden.

  • Kalibrieransicht - Mit dieser Einstellung wird festgelegt, welche Zähler während einem Kalibriervorgang angezeigt werden können. Hier können nur die Koordinatensysteme 'Maschine' und 'Arbeitsversatz' ausgewählt werden.

Für den Punkt, der für jedes der Koordinatensysteme angezeigt wird, gibt es drei Auswahlmöglichkeiten. Sie können jedes Koordinatensystem einzeln konfigurieren. Die verfügbaren Optionen sind:

  • Keine Werkzeuglänge - Die Zähler zeigen die aktuelle Position des Messlehre- (Verbindungs-) Punktes an.

  • Werkzeuglänge - Die Zähler zeigen das Ende des Werkzeuges, indem die Werkzeuglänge aus der Werkzeugtabelle der Steuereinheit übernommen und der Messlehre-Punktposition hinzugefügt wird.

  • Tastspitzenmitte - Die Zähler zeigen die Position der Tastspitzenmitte. Der Versatz aus dem Messlehrepunkt zur Kugelspitze wird bestimmt, wenn der Taster kalibriert wird.

Werkstück-Koordinatensystem

Das Werkstückkoordinaten-System (WKS) ist das Bezugssystem für das Werkstück. Für jedes Werkstück gibt es ein WKS, das durch die Zeichnung definiert wird. Der Nullpunkt des WKS ist über einen Arbeitsversatz mit dem MKS (Maschinenkoordinaten-System) verbunden (z. B. G54). Das WKS entspricht dem Koordinatensystem, das durch einen Arbeitsversatz mit allen Drehtischachsen in deren Nullpositionen definiert wird.

G54 - Originalposition XYZ Null gesetzt an der Ecke des Werkstückes wie weiter unten abgebildet:

„Werkstückkoordinaten“ ist das Koordinatensystem, das wirksam wird, wenn der anfängliche Arbeitsversatz ausgewählt ist und alle Drehtischachsen auf Null stehen. Beachten Sie, dass, mit dieser Definition, alle Messroutinen ab NC Gage V1.2 Werkstückkoordinaten verwenden. Werkstückkoordinaten werden als ein bedeutendes, allgemeines Koordinatensystem, mit dem alle Messungen mit 4- oder 5-achsigen Systemen verbunden werden können, immer wichtiger.


Neuen Taster erstellen

Home > Anwenden von PC-DMIS NC Gage > Erste Schritte > Schritt 3: Erstellen eines neuen Tasters

Schritt 3: Erstellen eines neuen Tasters

Das Fenster Neuen Taster erstellen definiert den Tastertyp, der für die Messung Ihres Werkstückes verwendet wird.

  1. Drücken Sie im Hauptfenster den Softkey Taster [image].

  2. Drücken Sie im Fenster Taster den Softkey Einen Taster auswählen [image].

  3. Drücken Sie im Fenster Einen Taster auswählen den Softkey Einen neuen Taster erstellen [image], um das Fenster Neuen Taster erstellen einzublenden.

  4. Geben Sie alle benötigten Informationen zu Ihrem Taster in dieses Fenster ein. Geben Sie den Nenndurchmesser Ihres Tasters, die Werkzeuglänge, die Taschennummer des Tasters, den Tasternamen und etwaige besondere Anweisungen an.

  5. Drücken Sie den Softkey Bestätigen [image] , um alle vorgenommenen Änderungen zu speichern. Drücken Sie den Softkey Zurückkehren [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Definitionen

  • Taschennummer - Die Taschennummer, in der sich der Taster befindet.

  • Nenndurchmesser - Der Nenndurchmesser der Tasterspitze.

  • Werkzeuglänge - Werkzeuglänge des Tasters vom Ansatz bis zur Spitzenmitte. Die Abweichung der Werkzeuglänge darf 20 mm nicht überschreiten. Damit wird während der Kalibrierung ein Kugelmittelpunkttest durchgeführt. Der Wert wird in der Kalibrierung nicht aktualisiert. Der Tasterspitzenversatz wird währen der Kalibrierung aktualisiert.

  • Tastername - Tastername vor der Werkzeugnummer. Der Tastername und die Werkzeugnummer dienen zur Erkennung einer Tasterdatei.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Anwenden oder Änderungen bestätigen Über diesen Softkey werden vorgenommene Änderungen der Optionen, Einstellungen oder Auswahlen im aktuellen Fenster akzeptiert. In einigen Fällen fügt dieser Softkey einen Befehl in ein NC Gage Messroutine ein. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.
Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung. | Abbrechen Dieser Softkey löscht alle Informationen in den Feldern Taschennummer, Nenndurchmesser sowie Theoretische Länge.


Taster auswählen

Home > Anwenden von PC-DMIS NC Gage > Erste Schritte > Schritt 4: Taster auswählen

Schritt 4: Taster auswählen

Im Fenster Taster auswählen können Sie den Taster zum Messen Ihres Werkstücks auswählen.

  1. Drücken Sie im Hauptfenster den Softkey Taster [image].

  2. Drücken Sie den Softkey Einen Taster auswählen [image], um das Fenster Taster auswählen einzublenden.

  3. Wählen Sie den zu verwendenden Taster aus der Liste Einen Taster auswählen mit Hilfe des Softkeys Einen Taster auswählen [image] aus.

  4. Drücken Sie den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image] , um die Änderungen zu speichern. Drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

NC Gage fügt den Taster in die Baumansicht der Messroutine ein.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Neuen Taster erstellen Mit diesem Softkey können Sie im Fenster Neuen Taster erstellen einen neuen Taster erstellen. | Taster löschen Dieser Softkey löscht die aktuelle unkalibrierten Taster. Sie können mit diesem Softkey keine kalibrierten Taster löschen.
Taster bearbeiten Über diesen Softkey wird das Fenster Taster bearbeiten, in dem ein neuer Taster definiert werden kann, angezeigt. | Abbrechen Dieser Softkey ist anfänglich in diesem Bildschirm nicht aktiviert.
Anwenden oder Änderungen bestätigen Über diesen Softkey werden vorgenommene Änderungen der Optionen, Einstellungen oder Auswahlen im aktuellen Fenster akzeptiert. In einigen Fällen fügt dieser Softkey einen Befehl in ein NC Gage Messroutine ein. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.
Ausführen Dieser Softkey öffnet das Fenster Messroutine bearbeiten, wo Sie die Messroutine ausführen können. | Wählen Sie einen Taster aus Wenn der Bildschirm Taster auswählen nicht bereits angezeigt wird, ruft dieser Softkey diesen Bildschirm auf. Wenn der Bildschirm Taster auswähle bereits angezeigt wird, können Sie mit diesem Softkey jeden Taster in der Taster-Liste auswählen.
Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung. |


Kalibrierung

Home > Anwenden von PC-DMIS NC Gage > Erste Schritte > Schritt 5: Kalibrierung

Schritt 5: Kalibrierung

Die Kalibrierung ist äußerst wichtig für die Definition des Tastspitzenversatzes und des effektiven Radius' auf Ihrem System.

Die Drehtischkalibrierung kann optional durchgeführt werden, um die Genauigkeit der Messungen in den Fällen zu erhöhen, in denen die Tische als Teil einer Messreihenfolge verwendet werden.

  1. Drücken Sie im Hauptfenster auf den Softkey Taster [image], um die verfügbaren Kalibrieroptionen aufzurufen.

Die Symbolleiste Tasteroptionen enthält folgende Optionen:

  2. Drücken Sie den Softkey Einen Taster auswählen [image] zur Auswahl oder zur Definition eines neuen, zu kalibrierenden Tasters.

Es sind folgende Taster-Kalibrieroptionen verfügbar:

  • Drücken Sie den Softkey Kugelkalibrierung [image], um den Taster auf Ihrem System mit Hilfe einer Kalibrierkugel zu kalibrieren.

  • Drücken Sie den Softkey Ringkalibrierung [image], um den Taster auf Ihrem System mit Hilfe eines Kalibrierringes zu kalibrieren.

  • Drücken Sie den Softkey Tasterlänge einstellen [image] , um die Länge Ihres Tasters zu berechnen.

Es sind folgende Drehtisch-Kalibrieroptionen verfügbar:

  • Drücken Sie den Softkey Drehtisch-Kalibrierung [image], um den(ie) Drehtisch(e) auf Ihrem System zu kalibrieren.

  • Drücken Sie den Softkey Rotationskalibrierdaten in Steuerung schreiben [image], um die Kalibrierdaten des Drehtisches oder der DSE in eine Steuereinheit zu schreiben.

Die folgenden Abschnitte zur Drehfräsmaschinen-Kalibrierung sind verfügbar:

  • Betätigen Sie den Softkey DSE-Kopfkalibrierung [image], um die Drehfräsmaschineneinstellung und Prozedur zur Tasterkalibrierung zu implementieren.

  • Betätigen Sie den Softkey Zentrum für Drehfräsmaschine finden [image] im Fenster DSE-Kopf-Kalibrierung, um den Mittelpunkt der B-Achse zu bestimmen.

  • Betätigen Sie den Softkey DSE-Kalibrierwinkel setzen [image] im Fenster DSE-Kopf-Kalibrierung, um die Kalibrierpositionen der Drehfräs-B-Achse zu erstellen.

  • Sobald die Kalibrierung abgeschlossen ist, betätigen Sie den Softkey Kalibrierprotokoll anzeigen [image] im Fenster DSE-Kopf-Kalibrierung, um das Kalibrierprotokoll anzuzeigen, zu drucken und zu speichern.


Optionen zur Tasterkalibrierung

Durch die Kalibrierung des Tasters werden der Tastspitzenversatz und der effektive Radius des Tasters, der auf Ihrem System verwendet wird, festgelegt.

So rufen Sie das Fenster Taster auf:

  1. Drücken Sie im Hauptfenster den Softkey Taster [image].

  2. Wählen Sie den entsprechenden Softkey zur Tasterkalibrierung aus, um den Taster zu kalibrieren:

    • Drücken Sie den Softkey Kugelkalibrierung [image], um den Taster auf Ihrem System mit Hilfe einer Kalibrierkugel zu kalibrieren.

    • Drücken Sie den Softkey Ringkalibrierung [image], um den Taster auf Ihrem System mit Hilfe eines Kalibrierringes zu kalibrieren.

Die nachfolgenden optionalen Methoden stehen im Fenster Taster zur Verfügung:

    • Der Softkey Einen Taster auswählen [image] wird zur Auswahl oder zur Definition eines neuen, zu kalibrierenden Tasters verwendet.

    • Der Softkey Tasterlänge einstellen [image] berechnet die Länge des Tasters.

    • Der Softkey Drehtisch-Kalibrierung [image] wird zur Kalibrierung der(des) Drehtische(s) auf Ihrem System verwendet.

    • Der Softkey Rotationskalibrierdaten in Steuerung schreiben [image] wird dazu verwendet, die Kalibrierdaten des Drehtisches oder der DSE an einen Block Makro-Variablen auf der Steuereinheit zu senden.

    • Softkey DSE-Kopf-Kalibrierung [image] zur Kalibrierung eines DSE-Kopfes auf Ihrem System.


Kugelkalibrierung

  1. Drücken Sie im Hauptfenster den Softkey Taster [image].

  2. Drücken Sie den Softkey Kugelkalibrierung [image] aus dem Fenster Taster, um das Fenster Kugelkalibrierung aufzurufen.

  3. Befolgen Sie die Anweisungen unten im Fenster, um die Kugelkalibrierung abzuschließen.

Bereich "Parameter"

  • Positioniergeschwindigkeit - Legt die Geschwindigkeit, in der sich der Taster während der Tasterkalibrierung bewegt, in mm/Minute (oder bei Einstellung der Maßeinheit auf "Zoll": Zoll/Minute) fest.

  • Vorhalteabstand - Gibt den Abstand zur theoretischen Messpunktlage, zu der der Taster vor Aufnahme eines Messpunktes fährt, an. Dieser Wert wird während der Tasterkalibrierung verwendet. Er wird in Millimetern oder Zoll angegeben.

Bereich "Verschiedene Optionen"

  • Details anzeigen - Markieren Sie dieses Kontrollkästchen, um den Bereich Tastspitzenversatz des Fensters einzublenden. Der Bereich Tastspitzenversatz enthält folgende Informationen:

    • Mess-, Nenn- und Toleranzwerte für X-, Y- und Z-Achsen

    • Mess-, Nenn- und Toleranzwerte der Formfehler bezüglich der Kalibrierung der Kugel

Bereich "Taster"

  • Tastspitzendurchmesser (Messwert, Nennwert, Toleranz) - Enthält den gemessenen und den theoretischen Durchmesser der Tastspitze sowie auch den Toleranzwert der Tastspitze. Der gemessene Wert wird nach Abschluss des Kalibriervorganges aktualisiert.

Bereich "Ziel"

  • Durchmesser (Kugel) - Definiert den Durchmesser der Kalibrierkugel.

  • XYZ (Kugel/Mitte) - Gibt die Mittelpunktlage der Kalibrierkugel im Verhältnis zur Lage des Arbeitsversatzes an. Wenn die Kugel exakt am Arbeitsversatz positioniert wurde, sollte dieser Wert 0,0,0 betragen.

  • Arbeitsversatz - Gibt den Arbeitsversatz, an dem sich die Kalibrierkugel befindet, an. Wählen Sie Maschine aus, um relativ zu Maschinenkoordinaten zu fahren.

Softkeys der Navigationsleiste

Zurückkehren

Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt.

Vorwärts

Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.

Kalibrierkugel suchen

Wenn die Maschine keinen Drehtisch, Drehkopf oder DSE aufweist, wird durch klicken auf diese Schaltfläche das Fenster "2D Kalibrierkugel suchen Korrigieren für Rundlauf" eingeblendet.

Durch Auswahl dieses Softkeys wird das Programm veranlasst, Stützpunkte mit Spindelorientierung aufzunehmen, um den Mittelpunkt der Kugel zu finden, bevor diese zur Kalibrierung gemessen wird. Weitere Information hierzu finden Sie im Thema "Kalibrierkugelartefakte suchen Korrigieren für Rundlauf".

Verfügt die Maschine über eine DSE, dann wird durch drücken des Softkeys Kalibrierkugelartefakte suchen das Fenster Kalibrierkugelartefakte für Rotationsachsenkalibrierung suchen eingeblendet.

Wird der Softkey Bestätigen [image] im Fenster Kugelartefakt suchen gedrückt, dann werden die Angaben aus dem Fenster Kugelkalibrierung automatisch eingepflegt.

Details einblenden

Dieser Softkey zeigt den Tastspitzenversatz der theoretischen Position an. Dies ist identisch zur Aktivierung des Kontrollkästchens Details anzeigen. Die Versätze sind Abweichungswerte. Der Formfehler wird ebenfalls angezeigt. Der Formfehler ist das kleinste Quadrat des Besteinpassungsfehler der Punkte vor der Vektorkompensation. Die Toleranzen werden über die Schaltfläche Einstellungen Kalibriertest eingegeben.

Nullpunkt auswählen

Dieser Softkey wählt den benannten Arbeitsversatz aus der Versatzliste aus. Die wiederholte Betätigung wählt den nächsten Arbeitsversatz aus der Liste aus.

Testeinstellungen für Kalibrierwerte

Über diesen Softkey wird ein neues Fenster geöffnet, in dem der Benutzer die Nennposition des Ringes sowie die Toleranzwerte angeben kann. Sollten gemessene Werte von deren entsprechenden Nennwerten um mehr als den zugewiesenen Toleranzwert abweichen, wird eine Warnmeldung eingeblendet. Sie können nach der Bestätigung der Warnung fortfahren.

Lernen und Erstellen eines Befehls (Ausführen)

Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine.

Alle Schritte abbrechen / Abbrechen

Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.

Wählen Sie einen Taster aus

Wenn der Bildschirm Taster auswählen nicht bereits angezeigt wird, ruft dieser Softkey diesen Bildschirm auf. Wenn der Bildschirm Taster auswähle bereits angezeigt wird, können Sie mit diesem Softkey jeden Taster in der Taster-Liste auswählen.

Bestätigen / Befehl hinzufügen

Im Betrieb wird die Auswahl mit diesem Softkey bestätigt.

Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt.

Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben.

Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben.

Kalibrierprotokoll anzeigen

Wählen Sie diesen Softkey aus, um das Kalibrierprotokoll anzuzeigen.

Minimieren

Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.

Kalibrierung löschen

Dieser Softkey löscht die aktuelle Kalibrierung.

Hilfe

Dieser Softkey ruft die NC Gage Hilfedatei auf.

Kalibriervorgang

  1. Wählen Sie den für die Kalibrierung zu verwendenden Arbeitsversatz aus. Der standardmäßige Arbeitsversatz lautet Maschine.

  2. Geben Sie den Durchmesser und die Mittelpunktlage für die Kalibrierkugel ein. Der Benutzer kann die Koordinaten des Mittelpunktes unter Umständen mit Hilfe der Beschreibung am unteren Ende dieser Seite ermitteln.

  3. Geben Sie die anderen, weiter oben beschriebenen Parameter ein.

  4. Rücken Sie die Tastspitze über die Mitte der Kalibrierkugel.

  5. Drücken Sie den Softkey Ausführen [image]. NC-Gage nimmt automatisch fünf Messpunkte auf der Kalibrierkugel auf, um den Mittelpunkt der Kugel zu bestimmen. Nachdem der Mittelpunkt der Kugel näher bestimmt wurde, nimmt NC-Gage automatisch 161 Messpunkte auf der Kalibrierkugel auf, so, wie durch die Parameter für die Kugelkalibrierung definiert.

Die Messwerte werden nach dem Abschluß der Kalibrierung aktualisiert. Dann können Sie mit dem Messen von Elementen mit Hilfe des kalibrierten Tasters beginnen.

XY lokalisieren

  • Mit Spindeldrehung - Wenn die NC-Maschine Spindelausrichtung (M19Sxxx) unterstützt, dann kann die XY-Position der Kugel mit der Anwendungsfunktion 'Mitte suchen' im Fenster Kalibrierung gefunden werden. Durch diese Funktion wird die Spindel für jeden Punkt so gedreht, dass der Rundlauf der Tastspitze keine Rolle spielt.

Z lokalisieren

  • Fügen Sie ein Bezugswerkzeug mit bekannter Länge in die Spindel ein.

  • Mit einer Fühlerlehre bekannter Stärke; rücken Sie das Werkzeug über den oberen Teil der Kugel nach unten, bis die Fühlerlehre beim Einfügen auf Widerstand stößt. Verwenden Sie in der Nähe der Kugel das kleinste Inkrement.

  • Die Fläche Z der oberen Kugel entspricht dann der Maschine Z abzüglich des Stärkenwertes der Fühlerlehre abzüglich der Länge des Referenzwerkzeuges.

'NC-Gage'-spezifischer Elementpfad und logischer Aufbau

  • Lesen Sie die Tasterposition über dem oberen Teil der Kugel.

  • Messen Sie gerade nach unten; Suchabstand ist Tasterradius + zweifacher Vorhalteabstand.

  • Setzen Sie die Sicherheitsebenenhöhe = Maximum des Lesepunktes Z und Vorhalteabstand + Tasterradius über dem Kontaktpunkt.

  • Schätzen Sie die Kugelmitte, die der Kugelradius unterhalb dem Kontaktpunkt sein soll.

  • Vorhalteradius setzen = Kugelradius + Tasterradius + Vorhalteabstand.

  • Fahren Sie zur Sicherheitsebene.

  • Fahren Sie in der Sicherheitsebene zu einem Punkt, der den Vorhalteradius in Richtung +X von der Kugelmitte aus darstellt.

  • Absenken auf Höhe des geschätzten Kugeläquators.

  • Messen Sie den Äquator mit 16 Punkten; nehmen Sie je nach Bedarf zusätzliche Bewegungen zwischen den Punkten vor.

  • Fahren Sie hoch zur nächsten Ebene (9 Grad über dem Äquator).

  • Messen Sie die Ebene mit 16 Punkten.

  • Wiederholen Sie den Vorgang für alle 10 Ebenen.

  • Messen Sie einen Punkt oben auf der Kugel.

  • Kehren Sie zur Sicherheitsebene zurück.

Indentifizieren Sie die Lage der Kugelmitte

XY lokalisieren:

  • Mit Spindeldrehung - Wenn die NC-Maschine Spindelausrichtung (M19Sxxx) unterstützt, dann kann die XY-Position der Kugel mit der Anwendungsfunktion 'Mitte suchen' im Fenster Kalibrierung gefunden werden. Durch diese Funktion wird die Spindel für jeden Punkt so gedreht, dass der Rundlauf der Tastspitze keine Rolle spielt.

  • Mit einer Messuhr - Laden Sie eine Messuhr in die Spindel der NC-Maschine und richten Sie sie so aus, dass diese den ungefähren Äquator der Kalibrierung berührt. Verschieben Sie X und Y auf der NC-Maschine so, dass die Abweichung an der Messuhr bei der Drehung der Spindel minimiert ist. Der Mittelpunkt der Kugel ist die X- and Y-Position der Maschine.

Z lokalisieren:

  • Fügen Sie ein Bezugswerkzeug mit bekannter Länge in die Spindel ein.

  • Mit einer Fühlerlehre bekannter Stärke; rücken Sie das Werkzeug über den oberen Teil der Kugel nach unten, bis die Fühlerlehre beim Einfügen auf Widerstand stößt. Verwenden Sie in der Nähe der Kugel das kleinste Inkrement.

  • Die Kugel Z entspricht dann der Maschine Z abzüglich des Stärkenwertes der Fühlerlehre, des Kalibrierkugelradius und der Referenzwerkzeuglänge.

Anmerkungen:

  • Wenn ein Arbeitsversatz für den Mittelpunkt der Kugel verwendet wird, sollte derselbe Arbeitsversatz für Nullpunktpositionen in NC Gage verwendet werden.

  • Die X Y Z - Werte des Mittelpunktes im Arbeitsversatz auf der Kontrolleinheit sind die Koordinaten des Ansatzpunktes der Spindel, wenn diese an der Kugelmitte positioniert werden kann.

Beispiel eines Kalibrierkugel-Protokolls

Nachdem die Kugel kalibriert wurde, kann der Benutzer ein Kalibrierprotokoll erstellen, indem er den Softkey Kalibrierprotokoll anzeigen [image] drückt.

Sie können anschließend mit dem Softkey Drucken [image] das Protokoll zum Standarddrucker senden.


Kalibrierkugel suchen

Home > Anwenden von PC-DMIS NC Gage > Erste Schritte > Schritt 5: Kalibrierung > Optionen zur Tasterkalibrierung > Kugelkalibrierung > Kalibrierkugel suchen Korrigieren für Rundlauf

Kalibrierkugel suchen Korrigieren für Rundlauf

Lokalisieren Sie mit dem nachfolgenden Verfahren den Mittelpunkt der Kalibrierkugel, um die Kugel zu kalibrieren.

  1. Geben Sie den Durchmesser der Kalibrierkugel in das Feld Durchmesser des Bereichs Eingabewerte ein.

  2. Befolgen Sie die Bildschirmanweisungen und drücken Sie den Anweisungen zufolge auf den Softkey Ausführen [image], um den Lernvorgang zu starten.

Im Bereich Kalibrierkugel-Werkzeug werden die Ergebnisse, korrigiert für Rundlauf, automatisch eingepflegt.

  3. Drücken Sie den Softkey Bestätigen [image], um das Fenster zu schließen und zum Fenster Kugelkalibrierung zurückzukehren, das entsprechend aktualisiert wurde.

Bereich "Bewegungsparameter"

  • Vorhalteabstand - Definiert den Abstand weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchabstand - Definiert die Entfernung, die der Taster zurücklegt, während er im Lernmodus die Fläche sucht.

Bereich "Eingabewerte"

  • Durchmesser - Geben Sie den Durchmesserwert der zu kalibrierenden Kalibrierkugel manuell ein.

Bereich "Kalibrierkugel-Werkzeug"

  • Zentrum X - Blendet den Positionswert der Kalibrierkugel in der X-Achse ein.

  • Zentrum Y - Blendet den Positionswert der Kalibrierkugel in der Y-Achse ein.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Lernen und Erstellen eines Befehls (Ausführen) Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. |


Ringkalibrierung

Ringkalibrierung ist gut für Messungen in der XY-Ebene (wenn der Taster in Richtung Z zeigt).

  1. Drücken Sie im Hauptfenster den Softkey Taster [image].

  2. Drücken Sie den Softkey Ringkalibrierung [image], um das Fenster Ringkalibrierung einzublenden:

  3. Folgen Sie den Bildschirmanweisungen und drücken Sie dann den Softkey Bestätigen [image] , um den Vorgang abzuschließen, oder drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Bereich "Parameter-Definitionen"

  • Tastspitzendurchmesser (Taster/Nennwert) - Enthält den theoretischen Durchmesser der Tastspitze. Der Wert Messwert wird bei Abschluss des Kalibriervorgangs aktualisiert.

  • Durchmesser (Ring) - Definiert den Durchmesser des Kalibrierrings.

  • XYZ (Ring/Mitte) - Gibt die Mittelpunktlage der oberen Fläche des Kalibrierringes im Verhältnis zur Lage des Arbeitsversatzes an. Der Z-Wert wird dazu verwendet, den Z-Tasterversatz mit dem letzten Punkt auf der Fläche zu berechnen. Wenn der Ring am Arbeitsversatz exakt positioniert wurde, sollte dieser Wert 0,0,0 betragen.

  • Vorschubgeschwindigkeit - Legt die Geschwindigkeit, in der sich der Taster während der Tasterkalibrierung bewegt, in mm/Minute (oder bei Einstellung der Maßeinheit auf "Zoll": Zoll/Minute) fest.

  • Vorhalteabstand - Gibt den Abstand zur theoretischen Messpunktlage, zu der der Taster vor Aufnahme eines Messpunktes fährt, an. Dieser Wert wird während der Tasterkalibrierung verwendet. Er wird in Millimetern oder Zoll angegeben.

  • Arbeitsversatz - Gibt den Arbeitsversatz, an dem sich der Kalibrierring befindet, an. Wählen Sie Maschine aus, um relativ zu Maschinenkoordinaten zu fahren.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Mitte suchen Durch Auswahl dieses Softkeys wird das Programm veranlasst, Stützpunkte aufzunehmen, um den Mittelpunkt des Ringes zu finden, bevor dieser zur Kalibrierung gemessen wird. Siehe "Kalibrierring suchen Korrigieren für Rundlauf". | Testeinstellungen für Kalibrierwerte Über diesen Softkey wird ein neues Fenster geöffnet, in dem der Benutzer die Nennposition des Ringes sowie die Toleranzwerte angeben kann. Sollten gemessene Werte von deren entsprechenden Nennwerten um mehr als den zugewiesenen Toleranzwert abweichen, wird eine Warnmeldung eingeblendet. Sie können nach der Bestätigung der Warnung fortfahren.
Details einblenden Dieser Softkey zeigt den Tastspitzenversatz der theoretischen Position an. Dies ist identisch zur Aktivierung des Kontrollkästchens Details anzeigen. Die Versätze sind Abweichungswerte. Der Formfehler wird ebenfalls angezeigt. Der Formfehler ist das kleinste Quadrat des Besteinpassungsfehler der Punkte vor der Vektorkompensation. Die Toleranzen werden über die Schaltfläche Einstellungen Kalibriertest eingegeben. | Kalibrierung löschen Dieser Softkey löscht die aktuelle Kalibrierung.
Nullpunkt auswählen Dieser Softkey wählt den benannten Arbeitsversatz aus der Versatzliste aus. Die wiederholte Betätigung wählt den nächsten Arbeitsversatz aus der Liste aus. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Lernen und Erstellen eines Befehls (Ausführen) Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine. | Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben.
Wählen Sie einen Taster aus Wenn der Bildschirm Taster auswählen nicht bereits angezeigt wird, ruft dieser Softkey diesen Bildschirm auf. Wenn der Bildschirm Taster auswähle bereits angezeigt wird, können Sie mit diesem Softkey jeden Taster in der Taster-Liste auswählen. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. | Kalibrierprotokoll anzeigen Wählen Sie diesen Softkey aus, um das Kalibrierprotokoll anzuzeigen.

Kalibriervorgang

  1. Wählen Sie den für die Kalibrierung zu verwendenden Arbeitsversatz aus. Der standardmäßige Arbeitsversatz lautet Maschine.

  2. Geben Sie den Durchmesser und den Mittelpunkt für den Kalibrierring ein. Der Benutzer kann die Koordinaten des Mittelpunktes unter Umständen mit Hilfe der Beschreibung am unteren Ende dieser Seite ermitteln.

  3. Geben Sie die anderen Parameter, die weiter oben im Bereich "Parameter-Definitionen" beschrieben sind, ein.

  4. Rücken Sie den Taster zu einer Position in der Nähe der Ringmitte.

  5. Drücken Sie den Softkey Ausführen [image] . NC Gage nimmt automatisch vier Messpunkte auf dem Kalibrierring auf, um die Ringmitte zu bestimmen. Nachdem die Ringmitte näher bestimmt wurde, wird die Bohrung des Lehrringes mit 36 Messpunkten gemessen und der obere Teil des Lehrringes wird mit einem einzigen Messpunkt gemessen.

  6. Nachdem der Kalibriervorgang abgeschlossen ist, werden die gemessenen Werte aktualisiert. Drücken Sie den Softkey Details einblenden [image], um die Details des Tastspitzenversatzes anzuzeigen, oder drücken Sie den Softkey Bestätigen [image] , um die Kalibrierergebnisse zu speichern und zum Hauptbildschirm zurückzukehren. Dann können Sie mit dem Messen von Elementen mit Hilfe eines kalibrierten Tasters beginnen.

Hinweis: Sie können die Tastspitzendetails auch einblenden, indem Sie das Kontrollkästchen Details einblenden markieren.

XY lokalisieren

  • Mit Spindeldrehung - Wenn die NC-Maschine Spindelausrichtung (M19Sxxx) unterstützt, dann kann die XY-Position des Ringes mit der Anwendungsfunktion Mitte suchen im Fenster Ringkalibrierung gefunden werden. Durch diese Funktion wird die Spindel für jeden Punkt so gedreht, dass der Rundlauf der Tastspitze keine Rolle spielt.

Z lokalisieren

  • Fügen Sie ein Bezugswerkzeug mit bekannter Länge in die Spindel ein.

  • Mit einer Fühlerlehre bekannter Stärke rücken Sie das Werkzeug über den oberen Teil des Ringes nach unten, bis die Fühlerlehre beim Einfügen auf Widerstand stößt. Verwenden Sie in der Nähe des Ringes das kleinste Bewegungsinkrement.

  • Die obere Fläche Z des Ringes entspricht dann der Maschine Z abzüglich des Stärkenwertes der Fühlerlehre abzüglich der Länge des Referenzwerkzeuges.

'NC-Gage'-spezifischer Elementpfad und logischer Aufbau

  • Lesen Sie die Tasterposition in der Mitte des Ringes.

  • Ringmessungen erfolgen am Z-Wert des Lesepunktes.

  • Schätzen Sie die XY-Mitte des Ringes, deren Position gelesen werden soll.

  • Vorhalteradius setzen = Ringradius - Tasterradius - Vorhalteabstand.

  • Zielradius setzen = Ringradius + Vorhalteabstand.

  • Sichere Höhe setzen = Leseposition Z-Wert + 25mm.

  • Messen Sie den Ring mit 36 Punkten in einem Bereich von 0 bis 350 Grad.

  • Auf sichere Höhe fahren.

  • Fahren Sie auf sichere Höhe zu einem Punkt, der den Ringradius + zweifachen Tasterradius in +X-Richtung vom Mittelpunkt des Ringes darstellt.

  • Messen Sie gerade nach unten; Zielhöhe entspricht der Höhe der Ringpunkte.

  • Auf sichere Höhe zurückkehren.

Beispiel eines Ringkalibrierungs-Protokolls

Nachdem der Ring kalibriert wurde, kann der Benutzer ein Kalibrierprotokoll erstellen, indem er den Softkey Kalibrierprotokoll anzeigen [image] drückt.

Durch drücken auf den Softkey Drucken [image] wird das Protokoll zum Standarddrucker gesendet.


Kalibrierring suchen Korrigieren für Rundlauf

Lokalisieren Sie mit dem nachfolgenden Verfahren den Mittelpunkt des Kalibrierringes, um die Ringe zu kalibrieren.

  1. Geben Sie den Durchmesser des Kalibrierringes in das Feld Durchmesser des Bereichs Eingabewerte ein.

  2. Befolgen Sie die Bildschirmanweisungen und drücken Sie den Anweisungen zufolge auf den Softkey Ausführen [image], um den Lernvorgang zu starten.

Im Bereich Kalibrierring-Werkzeug werden die Ergebnisse, korrigiert für Rundlauf, automatisch eingepflegt.

  3. Drücken Sie den Softkey Bestätigen [image], um das Fenster zu schließen und zum Fenster Ringkalibrierung zurückzukehren, das entsprechend aktualisiert wurde.

Bereich "Bewegungsparameter"

  • Vorhalteabstand - Definiert den Abstand weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchabstand - Definiert die Entfernung, die der Taster zurücklegt, während er im Lernmodus die Fläche sucht.

Bereich "Eingabewerte"

  • Durchmesser - Geben Sie den Durchmesserwert des zu kalibrierenden Kalibrierringes manuell ein.

Bereich "Kalibrierring-Werkzeug"

  • Zentrum X - Blendet den Positionswert des Kalibrierringes in der X-Achse ein.

  • Zentrum Y - Blendet den Positionswert des Kalibrierringes in der Y-Achse ein.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Lernen und Erstellen eines Befehls (Ausführen) Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. |


Tasterlänge setzen

Das Fenster Tasterlänge einstellen berechnet die Länge des Tasterschaftes. Diese Funktion kann jederzeit ausgeführt werden.

  1. Drücken Sie im Hauptfenster den Softkey Taster [image].

  2. Drücken Sie den Softkey Tasterlänge einstellen [image], um das Fenster Tasterlänge einstellen aufzurufen:

  3. Wählen Sie einen Arbeitsversatz von der Liste Arbeitsversatz.

  4. Im Feld Ziel des Bereichs Parameter geben Sie den erwarteten Höhenwert der Fläche, relativ zum aktuellen Arbeitsversatz, ein.

  5. Geben Sie im Bereich Bewegungsparameter jeweils einen Wert für Vorhalteabstand und Suchabstand ein.

  6. Positionieren Sie den Taster über der Oberfläche.

  7. Drücken Sie den Softkey Tasterposition lesen [image].

  8. Drücken Sie den Softkey Ausführen [image]. Der Taster wird die Oberfläche mit dem Zielwert messen. Ausgehend von der berührten Position und der Position der Tasterspindel in dreidimensionalem Raumversatz von der Fläche, berechnet NC Gage dann die Länge des Tasters. Der gemessene Z-Wert, Tasterlänge und Z-Versatzwerte erscheinen daraufhin in den schreibgeschützten Textfeldern. Die Aktuellen Werte zeigen die Tasterlänge und die Z-Versatzwerte ohne die Änderung an. Die Neuen Werte sind die Werte von Tasterlänge und Z-Versatz, nachdem die Änderung übernommen wurde.

Hinweis: Die Tasterlängenwerte werden zum unteren Teil des Tasters gemessen. Die Z-Versatzwerte werden zur Tastermitte gemessen.

  9. Drücken Sie den Softkey Bestätigen [image] , um die Tasterlänge, die zur Kalibrierung verwendet werden soll, zu speichern, oder drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Alle anderen Einträge in diesem Bildschirm enthalten schreibgeschützte Informationen über den Taster.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Aktuelle Position lesen / Nächster Schritt Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann mit dem nächsten Schritt des Verfahrens fortgesetzt. | Zum vorherigen Schritt zurückkehren Dieser Softkey löscht die zuletzt erlernten Tasterpositionen.
Nullpunkt auswählen Dieser Softkey wählt den benannten Arbeitsversatz aus der Versatzliste aus. Die wiederholte Betätigung wählt den nächsten Arbeitsversatz aus der Liste aus. | Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben.
Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.
Arbeitsfläche auswählen Dieser Softkey bestimmt die Antastrichtung und die Lage der Sicherheitsbewegungen für das Element. Sie können diesen mehrmals betätigen, um einen andere Messoberfläche zu wählen. Verfügbare Oberflächen sind: Oben, Links, Rechts, Vorne, Hinten und Schiefe. Wenn Schiefe ausgewählt ist, dann wird das Softkeysymbol zum Schiefensymbol. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.


Optionen Drehtisch-Kalibrierung

Home > Anwenden von PC-DMIS NC Gage > Erste Schritte > Schritt 5: Kalibrierung > Optionen Drehtisch-Kalibrierung

Drehtischoptionen

Bei der Definition eines Messsystems, das Drehtische verwendet, müssen die theoretische Position und die Ausrichtung des(er) Drehtische(s) eingegeben werden.

Die Kalibrierung kann optional durchgeführt werden, um die Genauigkeit der Messungen in den Fällen zu erhöhen, in denen die Tische als Teil einer Messreihenfolge verwendet werden.

Das Drehtisch-Kalibrierelement ist im Fenster Taster verfügbar. So rufen Sie das Fenster Taster auf:

  1. Drücken Sie im Hauptfenster den Softkey Taster [image].

  2. Drücken Sie den Softkey Drehtisch-Kalibrierung [image], um den(ie) Drehtisch(e) auf Ihrem System zu kalibrieren.

Folgende optionale Verfahren finden Sie im Fenster Drehtisch-Kalibrierung:

  • Softkey Kalibrierprotokoll anzeigen [image] - Anzeige des Kalibrierprotokolls nach erfolgreicher Kalibrierung des(er) Drehtische(s).

  • Softkey Kalibrierkugel suchen [image] - Zur Definition der Kugel, die zur Kalibrierung des(er) Drehtische(s) auf Ihrem System verwendet wird.

Die nachfolgenden optionalen Methoden stehen im Fenster Taster zur Verfügung:

  • Softkey Einen Taster auswählen [image] - Auswahl oder Definition eines neuen Tasters zur Kalibrierung.

  • Softkey Kugelkalibrierung [image] - Zur Kalibrierung des Tasters auf Ihrem System mit Hilfe einer Kalibrierkugel.

  • Softkey Ringkalibrierung [image] - Zur Kalibrierung des Tasters auf Ihrem System mit Hilfe einer Kalibrierringes.

  • Softkey Tasterlängen-Verfeinerung [image] - Berechnung der Länge Ihres Tasters.


Schwenktisch-Kalibrierung

Die Drehtischkompensation ist so lange deaktiviert, bis alle Tischparameter im Konfigurations-Tool eingegeben wurden (Siehe auch "Anhang A - Konfiguration Steuereinheit" ) und das Fenster Kinematik-Einrichten.

Die Drehtischkalibrierung wird mit Hilfe der Maschinenkoordinaten durchgeführt; infolgedessen werden alle Positionsparameter unter Verwendung von Maschinenkoordinaten definiert.

Bevor ein Drehtisch kalibriert wird, muss der Benutzer darüber informiert sein, wo sich die Maschinenkoordinaten-Rotationsmittelpunkte für die Achsen befinden und diese im Fenster "Kinematik-Einstellung" eingeben. Diese Zahlen übertragen die Punkte, damit NC Gage darüber informiert ist, an welcher Stelle in etwa sich an den verschiedenen Tischpositionen die Kugel befindet. Sobald diese Werte definiert sind, kann der Benutzer mit dem Kalibriervorgang des Drehtisches fortfahren.

Hinweis: Der Taster muss vor der Kalibrierung des Drehtisches auf einer Kugel kalibriert werden. Ansonsten ist die Option Drehtischkalibrierung nicht verfügbar.

  1. Drücken Sie im Hauptfenster den Softkey Taster [image].

  2. Drücken Sie den Softkey Drehtischkalibrierung [image], um das Fenster Drehtischkalibrierung einzublenden.

  3. Folgen Sie den Bildschirmanweisungen und drücken Sie dann den Softkey Bestätigen [image] , um den Vorgang abzuschließen. Drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Bereich "Parameter"

  • Vorschubgeschwindigkeit - Legt die Geschwindigkeit von Positionsbewegungen, in der sich der Taster während der Kalibrierung bewegt, in mm/Minute (oder bei Einstellung der Maßeinheit auf "Zoll": Zoll/Minute) fest.

  • Vorhalteabstand - Gibt den Abstand zur theoretischen Messpunktlage, zu der der Taster vor Aufnahme eines Messpunktes fährt, an. Dieser Wert, angegeben in Millimeter oder Zoll, wird während der Tasterkalibrierung verwendet.

  • Sichere Rotationshöhe - Die Z-Achsenhöhe, auf die der Taster zwischen den Tischpositionsbewegungen gefahren wird. Dieser Wert ist die Höhe der Tastspitzenmitte in Maschinenkoordinaten auf der sicheren Ebene. Es ist der Z-Wert in Maschinenkoordinaten abzüglich des Z-Tasterversatzes, während sich die Tastspitzenmitte in der Sicherheitsebene befindet.

ACHTUNG: Es ist von äußerster Wichtigkeit, dass der Wert Sichere Rotationshöhe angemessen gesetzt wird, damit eine Kollision der Tastspitze mit dem Drehtisch oder dem Werkstück vermieden wird. Der Standardwert, wenn er nicht zuvor festgelegt wurde, ist für diesen Parameter 0 (Null).

Definitionsbereich Winkel

  • Anzahl der Positionen - Die Anzahl der Stellen, an denen die Kugel gemessen wird. Die Positionen werden gleichmäßig zwischen dem Start- und dem Endwinkel verteilt.

  • Startwinkel - Der erste, bei der Kalibrierung verwendete Tischwinkel.

  • Endwinkel - Der letzte, bei der Kalibrierung verwendete Tischwinkel.

Hinweis: Wenn der Startwinkel mit dem Endwinkel übereinstimmt oder sie um 360 Grad voneinander abweichen, dann werden die Positionen gleichmäßig verteilt, wobei mit dem Startwinkel begonnen wird und sich die letzte Position eine Inkrementlänge vor dem Endwinkel befindet. Im oben abgebildeten Fenster befindet sich der Endwinkel tatsächlich bei 270 Grad.

  • Punkte pro Kugel - Die Anzahl der Punkte, die zur Messung einer jeden Kugel verwendet wird.

  • Winkel untere Ebene - Normalerweise handelt es sich hierbei um einen Winkel von 0 Grad, also dem Äquator. Falls die Aufnahme von Messpunkten am Äquator nicht möglich ist, kann dieser Winkel vergrößert werden.

  • Winkel obere Ebene - Normalerweise handelt es sich hierbei um einen Winkel von 90 Grad, was bedeutet, dass der Messpunkt am 'Nordpol' aufgenommen wird. Falls sich oben auf der Kugel ein Hindernis befindet, kann dieser Winkel verkleinert werden.

Hinweis: NC Gage vermeidet den Schaft, der durch die Werkzeug-Eigenschaften der Kalibrierkugel definiert wird.

Bereich "Tischkalibrierung"

Die Nennwertspalte bestimmt die Mitte und die Werte in dieser Spalte sind die Werte, die sich vor dem Aufrufen des Drehtisch-Kalibrierfensters im Fenster Kinematik-Einstellung von NC Gage befinden. Die Messwertspalte bestimmt die Mitte und wird vom Kalibriervorgang bestimmt. Wird die Kalibrierung vom Benutzer akzeptiert, werden die gemessenen Werte in das Setup-Fenster von NC Gage geschrieben und sie werden bei der nächsten Kalibrierung zu den neuen Nennwertspalten-Werten. Sie werden dann im Fenster Kinematik-Einstellung erscheinen.

  • Achsen-ID - Der Buchstabe, der die Achse kennzeichnet - A, B oder C, je nachdem, wie viele Drehtische im System definiert sind.

  • X-, Y- und Z-Mitte - Die X-, Y- und Z-Maschinenkoordinaten, die den Mittelpunkt des Drehtisches definieren.

    • Nennwert-Spalte - Zeigt die theoretische Position an, wenn der Tisch zum ersten Mal kalibriert wird. Jedes Mal, wenn der Drehtisch kalibriert werden soll, werden die vorherigen Werte eingeblendet.

    • Messwert-Spalte - Zeigt die Position der aktuellen Kalibrierwerte an.

  • Drehtischachsen I, J, K - Die Vektorachsenwerte I, J und K definieren die Achse, auf welcher der Drehtisch gemessen wird. Die verfügbaren Optionen sind abhängig von der vorhandenen Drehtischachse auf der Maschine und der gewählten Achse in der Auswahlliste. Die Felder der Spalte "Nennwerte" werden automatisch mit Standardwerten gefüllt, die bei Bedarf manuell angepasst werden können.

    • Nennwert-Spalte - Zeigt die theoretische Richtung an, wenn der Tisch zum ersten Mal kalibriert wird. Jedes Mal, wenn der Drehtisch kalibriert werden soll, werden die vorherigen Werte eingeblendet.

    • Messwert-Spalte - Zeigt die Richtung der aktuellen Kalibrierwerte an.

Definitionsbereich "Kugelkalbriernormal"

Diese Werte definieren die Position, Größe sowie die Ausrichtung des Kalibrierkugel-Artefaktes. Sie können vom Benutzer direkt eingegeben oder gelernt werden, indem Sie den Softkey Kugelartefakt suchen [image] drücken. Eine Beschreibung des Definitionsvorganges der Kalibrierkugel wird an anderer Stelle in diesem Dokument gegeben. Wenn der Softkey Kugelartefakt suchen [image] gedrückt wird, werden Sie aufgefordert eine Kugel zu definieren. Wenn Sie den Bildschirm Kugelartefakt für Drehtischkalibrierung suchen beenden, wird aus den gelernten Werten der Bildschrim für die Kalibrierkugel erzeugt.

  • X-, Y- und Z-Mitte - Die X-, Y- und Z-Maschinenkoordinaten, die den Mittelpunkt der Kugel, die gemessen wird, definieren. Hierbei handelt es sich um die Position des Tisches bei Null.

  • Durchmesser - Der Durchmesser der gemessenen Kugel, der auch zur Kalibrierung des Tisches verwendet wird.

  • I, J und K - Die Vektorachsenwerte der Tischrotation definieren die Kugel, die gemessen wird. Dieser Vektor definiert den Schaft der Kalibriekugel. Der Vektor zeigt vom Schaft in Richtung Kugelmitte.

Bereich "Tasterinformationen"

  • Tasche - Der Index der Werkzeugtasche des Tasterwerkzeuges.

  • Durchmesser - Der Nenn- und kalibrierte Durchmesser der Tastspitze.

  • Länge - Die Länge des Tasters.

  • X-, Y- und Z-Versatz - Geben die kalibrierten X-, Y- und Z-Tastspitzen-Versatzkoordinaten des Tasters an. Diese Werte stellen die Richtung vom Messlehre-Punkt zur Mitte der Tastspitze dar.

Sobald alle Optionen gültige Werte besitzen, drücken Sie die Schaltfläche Ausführen. NC Gage führt den Kalibriervorgang aus. Wird auf keine Fehler gestoßen, wird jede Kugelposition gemessen und mit Hilfe der Kugelmittelpunkte eine Ebene berechnet. Unter Verwendung der Kugelmittelpunktwerte in der berechneten Ebene wird ein Kreis berechnet. Der Mittelpunkt dieses Kreises ist der neu gemessene Mittelpunkt der Drehtischachse. Der Normalenvektor der Ebene ist der neue IJK-Vektor der Drehtischachse.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Wählen Sie einen Taster aus Wenn der Bildschirm Taster auswählen nicht bereits angezeigt wird, ruft dieser Softkey diesen Bildschirm auf. Wenn der Bildschirm Taster auswähle bereits angezeigt wird, können Sie mit diesem Softkey jeden Taster in der Taster-Liste auswählen. | Kalibrierprotokoll anzeigen Wählen Sie diesen Softkey aus, nachdem der Kalibriervorgang erfolgreich abgeschlossen wurde, um das zugehörige Protokoll anzuzeigen.
Informationen der Kalibrierkugel definieren Zeigt ein Fenster an, in dem der Benutzer Werte zur Definition von Position, Größe sowie Ausrichtung des Kalibrierkugel-Artifaktes manuell eingeben kann. Mit Hilfe der Schaltfläche Tasterposition lesen können diese Werte vom Benutzer auch gelernt werden. | Lernen und Erstellen eines Befehls (Ausführen) Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Kalibrierung löschen Dieser Softkey löscht die aktuelle Kalibrierung. | Print Über diesen Softkey wird das aktive Kalibrierprotokoll gedruckt.

Kalibriervorgang

Bevor Sie diesen Bildschirm öffnen, müssen Sie den Rotationsmittelpunkt für die Achsen kennen und diese im Fenster Kinematik-Einstellung eingeben. Diese Zahlen übertragen die Punkte, damit NC Gage darüber informiert ist, an welcher Stelle in etwa sich an den verschiedenen Tischpositionen die Kugel befindet.

Die theoretischen Werte X, Y, Z, I, J und K werden zu den Werten im Fenster Setup initialisiert. Die gemessenen Werte X, Y, Z, I, J und K werden durch die im Fenster Kinematik-Einstellung vorhandenen Werte ersetzt, nachdem der Tisch kalibriert ist und der Kalibriervorgang vom Benutzer akzeptiert wurde.

Sie müssen vor der Kalibrierung des Drehtisches einen vorher kalibrierten Taster auswählen.

Hinweis: Die Qualität der Tasterkalibrierung ist äußerst wichtig. Die Fehler bei der Tasterkalibrierung werden unter Umständen auf die Tischkalibrierung übertragen.

Nachdem die Werte für das Fenster Kinematik-Einstellung eingetragen wurden, müssen Sie folgendermaßen vorgehen, um einen Tisch zu kalibrieren:

  1. Geben Sie die Werte Vorschubgeschwindigkeit, Anfahrweg und Sichere Ebene Tastspitzenhöhe ein.

    • Die Vorschubgeschwindigkeit wird für Bewegungen außerhalb der eigentlichen Messung eingesetzt.

    • Der Wert Sichere Ebene Tastspitzenhöhe ist äußerst wichtig. NC Gage fährt vor jeder Tischpositionsbewegung und Kugelmessung auf diese Höhe. Wenn dieser Wert nicht korrekt eingestellt wird, kann es vorkommen, dass NC Gage die Maschine ganz nach oben oder weit nach unten in den Tisch fährt. Für dieses Feld sollte ein sicherer Z-Wert definiert werden, auf den die Tastspitze gefahren wird, bevor der Tisch gedreht wird. Alle Positionen in diesem Vorgang werden in Maschinenkoordinaten angezeigt.

  2. Setzen Sie die Werte zur Kugelmessung. Geben Sie die Werte Anzahl der Positionen, Startwinkel, Endwinkel, Punkte pro Kugel, Winkel der unteren Ebene und Winkel der oberen Ebene ein.

    • Die Option Anzahl der Positionen definiert die Gesamtanzahl der Messungen, die auf der Kugel aufgenommen werden.

    • Der Startwinkel ist der erste Winkel für den Tisch, der kalibriert wird. Der Endwinkel ist der letzte Winkel. NC Gage teilt diesen Bereich gleichmäßig auf. Wird der Startwinkel beispielsweise auf 30 und der Endwinkel auf 210 gesetzt und wurden 5 Positionen definiert, dann misst NC Gage die Kugel jeweils bei 30, 75, 120, 165 und 210 Grad. In dem besonderen Fall, in dem der Startwinkel 0 und der Endwinkel 360 ist, wird der Endwinkel aufgrund der Anzahl der Positionen korrigiert. Angenommen, Sie geben 0-360 und 4 Messvorgänge ein, dann misst NC Gage bei 0, 90, 180 und 270 Grad.

    • Punkte pro Kugel ist die Anzahl der Punkte, die zur Messung auf jeder Kugel verwendet werden.

    • Über die Optionen Winkel untere Ebene und Winkel obere Ebene wird festgelegt, wieviel von der Kugel gemessen wird. 90 bedeutet den Nordpol, während mit 0 der Äquator gemeint ist. 90 ist der am häufigsten verwendete Wert für den Winkel der oberen Ebene, der nur in den seltensten Fällen abgeändert werden muss, was aber möglich ist.

      Der Winkel der unteren Ebene sollte geändert werden, um den Schaft der Kalibrierkugel zu umgehen. NC Gage enthält eine Funktion zur Schaftvermeidung. Aus diesem Grund muss dieser Wert eigentlich auch nicht korrigiert werden.

  3. Stellen Sie sicher, dass Sie den richtigen Taster zur Kalibrierung des Tisches verwenden. Die Werte Tasche, Durchmesser, Länge und Tastspitzenversatz des derzeitig aktiven Tasters finden Sie in der unteren rechten Ecke dieses Fensters. Falls erforderlich, kann der Taster gewechselt werden, indem Sie den Softkey Taster auswählen drücken [image]. Beachten Sie, dass es notwendig ist, dass der für die Tischkalibrierung verwendete Taster auf einer Kugel kalibriert wurde. Tastspitzen, die auf einem Ring kalibriert wurden, können nicht benutzt werden.

  4. Wählen Sie die betreffende Achsen-ID aus der Liste aus. Die Spalte Nennwert wird automatisch ausgefüllt.

  5. Sie müssen die bei der Kalibrierung des Drehtisches verwendete Kugel definieren. NC Gage muss die Mittenposition, den Durchmesser, den Schaftvektor und die Drehtischpositionen der Kugel kennen. Wenn diese Werte unbekannt sind, drücken Sie den Softkey Informationen zur Kalibrierkugel definieren [image], um das Fenster Kalibrierkugel suchen aufzurufen. Mit dem Softkey Taster lesen [image] kann die aktuelle Tasterposition eingelesen werden. Einige Anmerkungen zu den folgenden Werten:

    • Mitte X, Mitte Y, Mitte Z sind die Koordinaten der Kugelmitte, wenn die Tische entsprechend den Werten in diesem Formblatt (in diesem Beispiel als A und C gekennzeichnet) positioniert werden. NC Gage muss wissen, wo sich X, Y und Z befinden, wenn alle Tische bei Null befinden. Es verwendet die Informationen im Fenster Kinematik-Einstellung, um diese Werte zu berechnen. Sofern kein Grund besteht, dass die Kugel an dieser Position nicht gemessen werden kann, wird empfohlen, dass die Kugel an der Stelle in Koordinaten definiert wird, an der sich die Drehtische bei Null befinden.

    • I, J und K definieren die Richtung von der Schaftmitte durch die Mitte der Kugel. Normalerweise ist dieser Vektor (0, 0, 1), was bedeutet, dass die Kugel gerade nach oben zeigt. NC Gage verwendet diesen Vektor dazu, den Schaft bei der Kugelmessung zu umgehen.

    • Wenn der obere Tisch (in der unten stehenden Abbildung als 1 dargestellt) gemessen wird, muss der untere Tisch (in der unten stehenden Abbildung als 2 dargestellt) bei Null sein.

    • Wenn der untere Tisch (in der unten stehenden Abbildung als 2 dargestellt) kalibriert wird, dann kann der obere Tisch (in der unten stehenden Abbildung als 1 dargestellt) beliebig positioniert sein.

    Tisch C sitzt oben auf Tisch A, wie weiter unten abgebildet ist:

1. C-Achsendrehung
2. A-Achsendrehung

  6. Sind all diese Angaben eingegeben, drücken Sie den Softkey Ausführen [image], um den Tisch zu kalibrieren.

Wird auf keine Fehler gestoßen, wird jede Kugelposition gemessen und mit Hilfe der Kugelmittelpunkte eine Ebene berechnet. Unter Verwendung der Kugelmittelpunktwerte in der berechneten Ebene wird ein Kreis berechnet. Der Mittelpunkt dieses Kreises ist der neu gemessene Mittelpunkt der Drehtischachse. Der Normalenvektor der Ebene ist der neue IJK-Vektor der Drehtischachse.

Hinweise:

Der ursprüngliche Drehtischachsenpunkt wird auf die Achse, die durch den Kalibriervorgang bestimmt wurde, projiziert. Demnach sollte sich der neue Achsenpunkt nicht wesentlich vom alten unterscheiden und nicht zur Verwirrung des Benutzers beitragen.

Alle Angaben, die im Formblatt gemacht wurden, werden in eine Datei gespeichert. Die Angaben werden für jede Drehachse separat abgespeichert. Nachdem ein Kalibriervorgang ausgeführt wurde, wird die Datei neu geschrieben. Wird eine neue Kalibrierung durchgeführt, werden die aus der letzten Kalibrierung dieser Achse gespeicherten Werte im Formblatt eingefügt.

Die Kalibrierung erfolgt für jede Achse getrennt. Zuerst ist es notwendig, dass die Drehachse, die nicht kalibriert wird, auf null 'gezwungen' wird. Diese Einschränkung wird unter Umständen zu einem späteren Zeitpunkt aufgehoben.

Schwenktisch-Kalibrierprotokoll

Nachdem der Tisch kalibriert wurde, können Sie ein Kalibrierprotokoll erstellen, indem Sie den Softkey Kalibrierprotokoll anzeigen [image] drückt.

Das Protokoll enthält die folgenden Informationen:

  • Zeitpunkt der Messung, Achsen-ID sowie berechnete Tischmitte.

  • Die Verschiebungswerte an, die die Differenz zwischen der aktuellen Messung und der im Fenster Kinematik-Einstellung definierten Werte darstellen. Wenn dies der erste Kalibriervorgang ist, zeigen die Verschiebungswerte die Abweichungen von der Position, die vom Benutzer definiert wurde, an. Von den nachfolgenden Kalibrierungen wird dann der Unterschied zur vorherigen Kalibrierung angezeigt. Wird die Kalibrierung vom Benutzer akzeptiert, dann wird der Rotationsmittelpunkt im Fenster Kinematik-Einstellung geschrieben.

  • Die Drehachse zeigt "Schieflage des Tisches" an. Dies wird als ein Vektor und als ein Winkelpaar ausgedrückt. Der Abstand zwischen den Drehachsen zeigt den Abstand zwischen den Achsen der beiden Tische so weit wie möglich (näherungsweise) an.

  • Der Positionsfehler jeder Kugelmessung wird sowohl im Tisch- als auch im grafischen Format angezeigt. Die Komponenten der Positionsfehler lauten:

    • Radialer Fehler - Dies ist der Betrag, um den die Kugelposition vom berechneten Kreis in der radialen Richtung (von der Mitte des Kreises ausgehend nach außen hin) abweicht.

    • Tangentenfehler - Dies ist der Fehler der Kugelposition basierend auf deren Winkel innerhalb des Kreises und der Drehachsenposition bei der Messung der Kugel. Diese Abweichungen sind mit der Kugelposition "getaktet". Die erste Kugel hat also immer den Wert Null als Tangentenfehler; alle anderen Kugel-Tangentenfehler sind relativ zur ersten Messung. Dieser Fehler misst im Wesentlichen die Genauigkeit der Drehtischpositionierung.

Hinweis: Radial- und Tangentenfehler werden grafisch durch die leicht fehlerhafte Position der Kugel relativ zu ihrer theoretischen Position dargestellt.

    • Axialfehler - Dieser Fehler misst die Abweichung der Kugelposition von der Besteinpassungs-Ebene, die unter Verwendung aller Kugelmittelpunkte berechnet wurde. Plus-Werte bedeuten, dass sich der Fehler in Richtung "nach oben" befindet; bei Minus-Werten ist der Fehler in Richtung "nach unten". Dies wird grafisch dargestellt, indem die Fehler so skaliert werden, dass die Differenzen relativ zueinander zu erkennen sind. Positive Abweichungen erscheinen in soliden, blauen Scheiben; negative Abweichungen erscheinen in roten Ringen. Diese Darstellungsweise wurde gewählt, damit die Abweichungen auch auf einem Ausdruck auf einem einfarbigen Drucker erkennbar sind.

  • Sie können anschließend mit dem Softkey Drucken [image] das Protokoll zum Standarddrucker senden.

Protokollierung eines gestapelten Drehtisches

Wenn in NC Gage ein Drehtisch kalibriert wird, wird die Mitte dieses Tisches als der Punkt, der sich auf der berechneten Achse, die den anderen Achsen am Nächsten ist, befindet, protokolliert. Dabei werden die beiden Achsen gemeinsam betrachtet. Die Punkte, die die Position darstellen, die dem Schnittpunkt der beiden Achsen am Nächsten kommt, werden bestimmt und diese Punkte werden daraufhin zu den als Tischmittelpunkt protokollierten neuen Punkten.

NC Gage bestimmt die Position, an der die beiden Achsen dem Schnittpunkt am nächsten sind. Diese Punkte werden als die Rotationsmittelpunkte für die beiden Achsen protokolliert.

A - Obere Rotationsachse des Tisches
B - Untere Rotationsachse des Tisches

Beispiel der definierten Achse des gestapelten Drehtisches

Hinweise:

Solange der Punkt auf der Rotationsachse liegt, ist die Mathematik, die von NC Gage verwendet wird, unabhängig von der Mittelpunktwahl.

Wenn die erste Kalibrierung durchgeführt wird, benutzt NC Gage bei der Berechnung die theoretische Achse des anderen Tisches. Korrekturen werden bei der Kalibrierung des zweiten Tisches vorgenommen.

Wenn ein Tisch kalibriert wird, werden beide Tischmittelpunkte aktualisiert, da eine geringe Abweichung in der Mittenachse eines Tisches nur eine geringe Auswirkung hat.

Der Versatz, der zwischen den beiden Tischen protokolliert wird, ist die Differenz zwischen den beiden Punkten.

Der Abstand, der zwischen den beiden Tischen protokolliert wird, ist der Abstand zwischen den beiden Punkten.


Kalibrierdaten-Schwenkachsen in Steuerung schreiben.

Die Option Rotationskalibrierdaten in Steuerung schreiben wird verwendet, um die Kalibrierdaten an einen Block Makro-Variablen der Steuereinheit zu senden, nachdem der(ie) Drehtisch(e) erfolgreich kalibriert wurde(n).

  1. Drücken Sie im Hauptfenster auf den Softkey Taster [image], um das Fenster Taster aufzurufen.

  2. Drücken Sie den Softkey Rotationskalibrierdaten in Steuerung schreiben [image], um das Fenster Kalibrierdaten des Drehtisches in Steuereinheit schreiben einzublenden.

    • Für einen Drehtisch:

    • Für ein DSE:

  3. Geben Sie die erste Makro-Variablenzahl (für Mitte X des Basis-Tisches) ein. Die restlichen Makro-Variablenzahlen werden der Reihe nach automatisch zugewiesen.

  4. Drücken Sie den Softkey Bestätigen [image] , damit die Kalibrierwerte in die Steuereinheit übertragen werden. Die Makro-Variablenzahlen werden nacheinander - wie weiter unten veranschaulicht - eingepflegt. Der Benutzer kann dann entscheiden, ob diese Werte auf der Steuerungsseite entsprechend übernommen werden sollen.

Bereich "Parameter"

  • VERSCHIEBUNG - Die Abweichung vom Normalzentrum zum aktuell berechneten Zentrum. Das aktuelle Zentrum wird aus den Daten aller Winkelpositionen bei der DSE-Kalibrierung berechnet.

  • Versatz - Die Abweichung vom Normalzentrum zum aktuell berechneten Zentrum. Das aktuelle Zentrum wird aus den Daten der beiden orthogonalen Winkelpositionen (0 und 90 oder 0 und -90) berechnet. Dieser Wert ist nur gültig, wenn Sie zwei Winkel in der Kalibrierliste besitzen.


Kalibrierkugel suchen für Rotationsachsen-Kalibrierung

Der Benutzer muss die bei der Kalibrierung des Drehtisches verwendete Kugel definieren. NC Gage muss über folgende Informationen verfügen: Mittenposition, Durchmesser, Schaftvektor sowie Drehtischpositionen der Kugel. Sind die Werte unbekannt, dann können Sie im Fenster Kalibrierkugel suchen für Rotationsachsen-Kalibrierung festgelegt werden.

  1. Rufen Sie dieses Fenster über das Fenster Drehtischkalibrierung auf. Drücken Sie im Fenster Drehtischkalibrierung auf den Softkey Kalibrierkugel suchen [image], um das Fenster Kalibrierkugel für Drehachsen-Kalibrierung aufzurufen:

  2. NC Gage benötigt Informationen, die dazu beitragen, die Position des Schaftes der Kugel näher einzugrenzen. Positionieren Sie den Taster so, dass er sich (in vertretbarem Maße) genau auf der gegenüber liegenden Seite vom Kugelschaft befindet.

  3. Geben Sie im Bereich Bewegungsparameter jeweils einen Wert für Vorhalteabstand und Suchabstand ein.

  4. Drücken Sie den Softkey Tasterposition lesen [image], um diese Tasterposition einzulesen.

  5. Positionieren Sie den Taster direkt über der Kugel, sodass der obere Teil der Kugel berührt wird, wenn der Taster gerade nach unten bewegt wird.

  6. Drücken Sie den Softkey Tasterposition lesen [image], um diese Tasterposition einzulesen.

Hinweis: Die Schritte 2 - 5 können denselben Punkt verwenden, da sich der Schaft unterhalb der Kugel befindet. Mit dem Softkey Zurück zum vorherigen Schritt [image] kann, falls erforderlich, jederzeit die zuletzt gelernte Tasterposition entfernt werden.

  7. Drücken Sie den Softkey Ausführen [image]. NC Gage misst die Kugel daraufhin ungefähr, unter Verwendung eines '4 Punkte'-Suchmusters oben auf der Kugel. Die Messwerte werden eingeblendet und können vom Benutzer akzeptiert oder abgelehnt werden. Außerdem können die Werte manuell bearbeitet werden, bevor sie, je nach Bedarf, akzeptiert werden.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Arbeitsfläche auswählen Dieser Softkey bestimmt die Antastrichtung und die Lage der Sicherheitsbewegungen für das Element. Sie können diesen mehrmals betätigen, um einen andere Messoberfläche zu wählen. Verfügbare Oberflächen sind: Oben, Links, Rechts, Vorne, Hinten und Schiefe. Wenn Schiefe ausgewählt ist, dann wird das Softkeysymbol zum Schiefensymbol. | Lernen und Erstellen eines Befehls (Ausführen) Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine.
Zum vorherigen Schritt zurückkehren Dieser Softkey löscht die zuletzt erlernten Tasterpositionen. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.


Kalibrierung Fräs-Dreh-Werkzeugmaschine

Taster- und Kopf-Kalibrierung auf einer Fräs-Dreh-Werkzeugmaschine

Die Taster- und B-Achsen-Kalibrierung auf einer Fräs-Dreh-Werkzeugmaschine wird implementiert, damit eine einzige Frage beantwortet werden kann: "Wo ist der Mittelpunkt des Tasters in Bezug auf den Mittelpunkt der Drehung des Kopfes für einen vorgegebenen B-Achsenwinkel?"

Unter idealen Bedingungen kann eine Tastspitze in einer einzigen B-Achsenposition kalibriert werden und die Position der Tastspitze ist dann für alle Positionen bekannt. Unter normalen Bedingungen ist es jedoch notwendig, die Position des Drehtisches auf mehrere Arten zu ermitteln. Die gewählte Methode wird durch die Präzisionsanforderung beeinflusst.

Tasterkalibrierung auf Fräs-Dreh-Werkzeugmaschinen - Übersicht

Der erste Schritt bei der Tasterkalibrierung auf Fräs-Dreh-Werkzeugmaschinen ist der, die Lage der Kalibrierkugel zu ermitteln. Hierzu kann der Bediener traditionelle Verfahren anwenden (wie Messuhr und Endmaß). Oder aber Sie bringen die Spindelrotation zum Einsatz, um die Funktion "Mittelpunkt suchen" zweimal durchzuführen: einmal mit der B-Achse bei 0 und einmal bei 90 Grad.

Nähere Angabe für das Messverfahren finden Sie weiter unten.

Der berechnete Mittelpunkt der Kopfrotation sollte mit dem Mittelpunkt der Kalibrierkugel übereinstimmen. Abweichungen vom Mittelpunkt der Kalibrierkugel werden für jeden DSE-Winkel berechnet.

Die Sammlung von Tastspitzenversätzen wird gemeinsam analysiert, sodass der Tastspitzenversatz von einer B-Achsenposition, die nicht kalibriert ist, unter Umständen geschätzt und in einer Messroutine von NC Gage verwendet wird.

  • Beim ersten Schritt der Analyse wird die Besteinpassungsebene mit Hilfe von allen Tasterversätzen berechnet. Der Normalenvektor der Ebene ist der Rotationsvektor der B-Achse - dieser Wert sollte in etwa mit dem Wert (0, 1, 0) übereinstimmen.

  • Im nächsten Schritt der Analyse wird der Besteinpassungskreis unter Verwendung aller Tasterversätze berechnet. Der Mittelpunkt wird in der Ebene, die im ersten Schritt berechnet wurde, berechnet. Es wird erwartet, dass der Kreis fast dem Mittelpunkt der Kalibrierkugel entspricht. Jeder Fehler, der bis zu diesem Zeitpunkt gefunden wird, ist aller Wahrscheinlichkeit nach bei der Definition des Kalibrierkugel-Mittelpunkts entstanden.

Die Fehler des Mittelpunktes von jeder Kugel im Verhältnis zum berechneten Besteinpassungskreis können in drei Komponenten unterteilt werden:

  • Die erste Komponente des Fehlers ist der tangentiale oder Clocking-Fehler. Sie stellt den Fehler einer berechneten Position der Kugel im Verhältnis zur vorausberechneten Positon der Kugel als den Winkelunterschied dar.

  • Die zweite Komponente des Fehlers ist der radiale Fehler. Sie stellt den Fehler der berechneten Position der Kugel im Verhältnis zum Besteinpassungskreis als Differenz zwischen dem Radius des Besteinpassungskreises und dem Abstand vom Kugelmittelpunkt der Kreismitte dar.

  • Die dritte Komponente des Fehlers ist der axiale Fehler. Sie stellt den Abstand vom Kugelmittelpunkt zur Besteinpassungsebene dar.

NC Gage erstellt die Fehlertabelle und speichert diese als Teil der B-Achsen-/Taster-Kalibrierung ab. Wenn vom Benutzer in einem Programm ein Elementrahmen erstellt wird, sollte NC Gage eine Tastspitze aufbauen, die basierend auf dem B-Achsenwinkel eingesetzt wird. Wenn der B-Achsenwinkel eines Elementrahmens bei der Kalibrierung verwendet wurde, dann sollte NC Gage die Angaben direkt aus der Kalibriertabelle extrahieren, um den Tastspitzenversatz zu setzen. Die Vektorkompensation wird verwendet, wenn die Kalibrierung dieser B-Position genügend Punkte verwendet hat. Wenn die B-Achse nicht Teil des Kalibriervorganges gewesen ist, dann wird der Tasterversatz unter Verwendung der Besteinpassungsebene, des Mittelpunktes und der Fehlertabelle gesetzt, wobei in geeigneten Fällen interpoliert wird. Es wird bestimmt, ob die Vektorkompensationsmatrix gedreht und angewandt wird.

In der nachfolgenden Tabelle sind die neuen Informationen dargestellt, die in der Tabelle für die Fräs-Dreh-Kalibrierung abgespeichert werden:

B-Winkel | X-Versatz | Y-Versatz | Z-Versatz | Tangentialer Fehler | Radialer Fehler | Axialer Fehler | Spezifische Vektor-Komp.-Matrix
0 | - | - | - | - | - | - | -
- | - | - | - | - | - | - | -
90 | - | - | - | - | - | - | -

Hinweis:

X-, Y- and Z-Mittelpunkt stellen die Deltawerte zwischen der vom Benutzer vorgegebenen Position des Mittelpunktes der Kalibrierkugel und dem berechneten Besteinpassungs-Mittelpunkt dar. Dadurch hat NC Gage die Möglichkeit, den Tasterrundlauf zu nutzen und Sinus und Cosinus einzusetzen, um neue Positionen vorherzusagen.

NC Gage bietet die Möglichkeit, entweder eine vollständige Tastspitzen-/B-Achsen-Kalibrierung oder eine Aktualisierung der Kalibrierung durchzuführen, um einen Teil der Fehlertabelle zu aktualisieren.

Mehr

DSE-Kopf-Kalibrierung

DSE-Kalibrierwinkel setzen

Protokollierung der DSE-Kopf-Kalibrierung


DSE-Kopf-Kalibrierung

  1. Drücken Sie im Hauptfenster den Softkey Taster [image].

  2. Drücken Sie auf den Softkey DSE-Kopf-Kalibrierung [image], um das Fenster DSE-Kopf-Kalibrierung einzublenden:

  3. Folgen Sie den Bildschirmanweisungen und drücken Sie dann den Softkey Bestätigen [image] , um den Vorgang abzuschließen. Drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

  4. Drücken Sie sofort, nachdem der DSE-Kopf kalibriert wurde, auf den Softkey Kalibrierprotokoll anzeigen [image], um das Fenster Kalibrierprotokoll für den DSE-Kopf anzuzeigen.

Bereich "Parameter"

In diesem Bereich werden die Bewegungsparameter definiert.

  • Vorschubgeschwindigkeit - Legt die Geschwindigkeit von Positionsbewegungen, in der sich der Taster während der Kalibrierung bewegt, in mm/Minute (oder bei Einstellung der Maßeinheit auf "Zoll": Zoll/Minute) fest.

  • Vorhalteabstand - Gibt den Abstand zur theoretischen Messpunktlage, zu der der Taster vor Aufnahme eines Messpunktes fährt, an. Dieser Wert, angegeben in Millimeter oder Zoll, wird während der Tasterkalibrierung verwendet.

  • Sichere Rotationshöhe - Die Z-Achsenhöhe, auf die der Taster zwischen den Kopfpositionsbewegungen gefahren wird. Dieser Wert ist die Höhe der Drehpunktmitte in Maschinenkoordinaten auf der sicheren Ebene. Vor jeder DSE-Achsendrehung wird der Taster gerade in Z-Richtung nach oben gefahren, sodass sich der Drehpunkt der DSE sicher auf die vorgegebene Höhe verschiebt.

ACHTUNG: Es ist von äußerster Wichtigkeit, dass der Wert Sichere Rotationshöhe angemessen gesetzt wird, damit eine Kollision der Tastspitze mit dem Drehtisch oder dem Werkstück vermieden wird. Der Standardwert, wenn er nicht zuvor festgelegt wurde, ist für diesen Parameter 0 (Null).

Weitere Informationen zu diesem Wert finden Sie unter "Sicherheitsebenen anwenden".

Definitionsbereich Winkel

Alle Positionswinkel - Diese Werte werden in einem anderen Formblatt eingestellt, das durch klicken auf den Softkey DSE-Kalibrierwinkel einstellen [image] aufgerufen werden kann.

Hinweis: Der DSE-Achsenpositionensatz und alle anderen Parameter bleiben in der Tastspitzendatei bestehen, sodass beim nächsten Aufruf des Kalibrierfensters alle Werte erinnert werden.

Folgendes bezieht sich auf die nicht-primären Winkel:

Punkte pro Kugel - Dieser Wert definiert die Anzahl der Punkte, die zur Messung einer jeden Kugel verwendet wird.

Bereich "Kopfkalibrierung"

Die Nennwertspalte bestimmt die Mittenposition und die Werte in dieser Spalte sind die Werte, die sich vor dem Aufrufen des Fensters DSE-Kopf-Kalibrierung im Fenster Kinematik-Einstellung von NC Gage befinden.

Die Messwertspalte bestimmt die Mittenposition und wird vom Kalibriervorgang bestimmt. Wird die Kalibrierung vom Benutzer akzeptiert, werden die gemessenen Werte in das Setup-Fenster von NC Gage geschrieben und sie werden bei der nächsten Kalibrierung zu den neuen Nennwertspalten-Werten. Sie werden dann im Fenster Kinematik-Einstellung erscheinen.

Nennwert-Spalte - Zeigt die theoretische Richtung an, wenn der Tisch zum ersten Mal kalibriert wird. Jedes Mal, wenn der Drehtisch kalibriert werden soll, werden die vorherigen Werte eingeblendet.

Messwert-Spalte - Zeigt die aktuell berechneten Richtungsergebnisse der aktuellen Kalibrierung an.

  • Achsen-ID - Der Buchstabe, der die Achse kennzeichnet - A, B oder C, je nachdem, wieviele Drehtische im System definiert sind.

  • Durchschnittliche Werkzeuglänge - Die durchschnittliche Länge der Tastspitzenlänge, die während dem Kalibriervorgang festgelegt wird.

  • Drehachsen I, J, K - Die Vektorachsenwerte I, J und K. Diese Werte definieren die Richtung der Achse, um die sich die DSE dreht. Diese Werte wurden anfänglich so eingestellt, dass sie mit den Einstellungen im Fenster Kinematik-Einstellung abgestimmt waren.

Bereich "Taster"

Nennwert-Spalte - Zeigt den theoretischen Durchmesser an, wenn der Tisch zum ersten Mal kalibriert wird.

Messwert-Spalte - Zeigt den zuletzt kalibrierten Durchmesser des Tasters an.

Durchmesser - Der Durchmesser der Tastspitze.

Tasche - Blendet die Nummer der Tastertasche, die bei der Erstellung des Tasters festgelegt wurde, ein.

Name - Der Name des Tasters, der gerade verwendet wird.

Bereich "Informationen"

Hier finden Sie Angaben zum Kalibrierverfahren, einschließlich Uhrzeit- und Datumsstempel der aktuellen oder der vorigen Kalibrierung.

Definitionsbereich "Kugelkalbriernormal"

Diese Werte definieren die Position, Größe sowie die Ausrichtung des Kalibrierkugel-Artefaktes. Sie können vom Benutzer direkt eingegeben oder gelernt werden, indem Sie die Definitionsschaltfläche "Kalibrierkugel" drücken. Eine Beschreibung des Definitionsvorganges der Kalibrierkugel wird an anderer Stelle in diesem Dokument gegeben. Wenn Sie die Schaltfläche zur Kugeldefinition drücken, werden Sie aufgefordert eine Kugel zu definieren. Wenn die das Fenster "Kugeldefinition" verlassen, werden die gelernten Werte im Fenster Kugelkalibrierung angezeigt.

  • X-, Y- und Z-Mitte - Die X-, Y- und Z-Maschinenkoordinaten, die den Mittelpunkt der Kugel, die gemessen wird, definieren. Hierbei handelt es sich um die Position des Tisches bei 0 (Null).

  • Durchmesser - Der Durchmesser der gemessenen Kugel, der auch zur Kalibrierung des Tisches verwendet wird.

  • I, J, K und C - Die IJK-Vektorrichtung für den Schaft der Kalibrierkugel und die Mittenposition des Drehtisches für die Kugelmessung. Der Vektor zeigt vom Schaft in Richtung Kugelmitte.

Bereich "Arbeitsversatz"

Gibt den Arbeitsversatz an, an dem sich das Kalibrierartefakt befindet. Wählen Sie Maschine aus, um im Verhältnis zu Maschinenkoordinaten zu fahren.

Softkeys der Navigationsleiste

Zurückkehren

Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt.

Vorwärts

Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.

Kalibrierprotokoll anzeigen

Wählen Sie diesen Softkey aus, nachdem der Kalibriervorgang erfolgreich abgeschlossen wurde, um das Protokoll der DSE-Kopfkalibrierung anzuzeigen.

Wählen Sie einen Taster aus

Wenn der Bildschirm Taster auswählen nicht bereits angezeigt wird, ruft dieser Softkey diesen Bildschirm auf. Wenn der Bildschirm Taster auswähle bereits angezeigt wird, können Sie mit diesem Softkey jeden Taster in der Taster-Liste auswählen.

Kalibrierkugel suchen

Dieser Softkey zeigt das Fenster Kugelartefakt suchen für die Messung von Position, Größe sowie Ausrichtung des Kalibrierkugel-Artifaktes an.

Weitere Informationen finden Sie unter "Kalibrierkugelartefakte für Rotationsachsen-Kalibrierung suchen".

DSE-Kalibrierwinkel setzen

Dieser Softkey wird zum Setzen der Positionswinkel der DSE-Achse für die Kalibrierpositionen verwendet.

Weitere Informationen finden Sie unter "DSE-Kalibrierwinkel setzen".

Lernen und Erstellen eines Befehls (Ausführen)

Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine.

Alle Schritte abbrechen / Abbrechen

Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt.

Nullpunkt auswählen

Dieser Softkey wählt den benannten Arbeitsversatz aus der Versatzliste aus. Die wiederholte Betätigung wählt den nächsten Arbeitsversatz aus der Liste aus.

Sichere Bewegungshöhe einstellen

Diese Schaltfläche definiert die Sicherheitshöhe für Bewegungen zwischen DSE-Achsen-Bewegungen. Klicken Sie auf diese Schaltfläche, um den Wert Parameter sichere Drehhöhe automatisch zu aktualisieren.

Weitere Informationen zu dieser Schaltfläche finden Sie unter "Sicherheitsebenen anwenden".

Kalibrierung bestätigen

Drücken Sie diesen Softkey, um die Kalibrierung zu akzeptieren.

Minimieren

Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.

Hilfe

Dieser Softkey ruft die NC Gage Hilfedatei auf.

AW aufh.

Dieser Softkey löscht die gesamte Kalibrierung für den B-Achsen-Taster und Sie müssten von vorne beginnen.

Wenn Sie diesen Softkey betätigen, wird das Kontrollkästchen Alle alten Kalibrierungen löschen aktiviert. Zum Zeitpunkt der aktuellen Kalibrierung wird Ihnen die Meldung "Sind Sie sicher?" angezeigt, wenn diese Option aktiviert ist.

Wenn Sie den Softkey Löschen nicht bestätigen, werden alle Kalibrierungen mit der vorherigen zusammengeführt. "Löschen" bedeutet, dass die PRB-Datei zurückgesetzt und alle Messungen verworfen werden.


Sicherheitsebenen anwenden

Die Option Sichere Rotationshöhe (am Pivot) im Fenster DSE-Kopf-Kalibrierung zeigt die sichere Höhe für DSE, um sich in jedem beliebigen Winkel sicher drehen zu können.

Um Kollisionen bei der Drehung des DSE von einem Winkel zum nächsten Winkel vor der Kugelmessung zu verhindern, wurde eine Sicherheitsebene definiert. NC Gage fährt das Drehzentrum zuerst zu dieser Linie. NC Gage führt nun die DSE-Drehung aus, bevor es die Kugel misst.

Die Richtung der definierten Sicherheitsebene ist entlang des Normalen des Drehtisches. Die sichere Rotationshöhe (am Pivot) ist die Pivotposition in der Richtung, wenn das Pivot in dieser Ebene bewegt wird. Sie bezieht sich nicht auf den DSE-Winkel, da es sich um die Pivotposition und nicht die Spitze handelt.

Die folgende Abbildung zeigt die Sicherheitsebene als gelbe Linie. Die Höhe verläuft entlang der X-Achse (Normaltisch):

Sicherheitseben

Schaltfläche "Sichere Bewegungshöhe einstellen"

Die Schaltfläche Sichere Bewegungshöhe einstellen im Fenster DSE-Kopf-Kalibrierung hilft bei der Bestimmung der sicheren Rotationshöhe (am Pivot).

  1. Fahren Sie die Spitze (ohne Berücksichtigung der DSE-Winkelposition) über die Kugel und entlang der Richtung der Sicherheitsebene:

Richtung der Sicherheitsebene

  2. Bestätigen Sie die Schaltfläche Sichere Bewegungshöhe einstellen. NC Gage berechnet die sichere Rotationshöhe (am Pivot) und füllt das Feld Sichere Rotationshöhe (am Pivot).

Startposition

Sie sollten besonders auf eine sichere Startposition der Sicherheitseben achten und die sichere Höhe in Normalrichtung des Tisches berücksichtigen. Fahren Sie den Taster auf eine sichere Position in der YZ-Ebene, um ausreichend Platz für die DSE-Drehung zur Verfügung zu stellen und somit Kollisionen zu vermeiden. Außerdem sollte die Startposition für die Tastspitze höher als das Kugelzentrum in der X-Richtung der Sicherheitsebene liegen.

DSE-Winkel

Beachten Sie die DSE-Winkel, die für die Kalibrierung eingegeben werden und riskante Winkelpositionen abhängig von DSE-Beschränkungen, dem Freiraum der Maschine sowie dem Schaft der Kugel zu vermeiden.

Achten Sie besonders auf DSE-Winkelpositionen nahe dem Schaft und Winkelpositionen, bei denen das Pivotzentrum sich unter dem Kugelmittelpunkt in der Sicherheitsrichtung befindet. Überprüfen Sie diese Positionen sorgfältig bei der ersten Ausführung der Messroutine.


DSE-Kalibrierwinkel setzen

Durch Drücken auf den Softkey DSE-Kalibrierwinkel setzen [image] im Fenster DSE-Kopf-Kalibrierung wird das nachfolgende Fenster eingeblendet:

  1. Geben Sie in das Feld Winkel einen Winkelwert des Bereichs Vollständig kompensierter Winkel ein.

  2. Geben Sie in das Feld Startwinkel des Bereichs Folge erzeugen den Anfangswinkel ein.

  3. Geben Sie in das Feld Endwinkel des Bereichs Folge erzeugen den Endwinkel ein.

  4. Geben Sie die Gesamtpositionen, die erforderlich sind, in das Feld Anzahl der Positionen des Bereichs Folge erzeugen ein.

  5. Nachdem die Werte Startwinkel, Endwinkel und Anzahl der Positionen eingegeben sind, drücken Sie den Softkey Positionsliste erzeugen [image], um die Auflistung der Kalibrierpositionen basierend auf diesen Werte einzupflegen.

  6. Geben Sie im Bereich Einzelnen Winkel hinzufügen im Feld Winkel einen separaten Winkel ein. Drücken Sie anschließend den Softkey Einzelnen Winkel zur Positionsliste hinzufügen [image], um einen weiteren Winkel zur Liste Kalibrierpositionen hinzuzufügen.

  7. Drücken Sie den Softkey Positionsliste löschen [image], um die aktuelle Auflistung zu löschen und von vorne anzufangen.

  8. Drücken Sie, sobald die Positionen erzeugt wurden, den Softkey Ausführen [image], um die Liste der Kalibrierpositionen zu akzeptieren.

Bereich "Kalibrierpositionen"

Listet alle aktuell definierten Kalibrierpositionen auf.

Bereich "Vollständig kompensierte Winkel"

Winkel - Dieser Winkel wird als Startwinkel verwendet, wenn eine vollständige Kalibrierung notwendig ist. Er wird dazu verwendet, die Vektor-Kompensationsmatrix aufzubauen.

Bereich "Folge erzeugen"

Startwinkel - Der anfängliche Winkelwert, von dem aus der Tastkopf während des Kalibriervorganges gestartet wird (normalerweise ist dies der niedrigste Winkelwert der Tasterdrehung).

Endwinkel - Der letzte Winkelwert, an dem der Tastkopf während des Kalibriervorganges die Rotation abschließt (normalerweise ist dies der höchste Winkelwert der Tasterdrehung).

Anzahl der Positionen - Die Gesamtzahl der Winkel, bei denen der Tastkopf während des Kalibriervorganges gedreht wird (einschließlich des Start- und Endwinkels). Dieser Wert wird zur Bestimmung der tatsächlichen Winkelpositionen basierend auf den Werten Startwinkel und Endwinkel, wie sie in den weiter oben beschriebenen Schritten eingegeben wurden, verwendet.

Bereich "Einzelnen Winkel hinzufügen"

Winkel - Ein Winkelwert, der manuell in die Liste Kalibrierpositionen hinzugefügt werden kann. Geben Sie einen Winkelwert ein und drücken Sie dann den Softkey Einzelnen Winkel zur Positionsliste hinzufügen [image], um die Liste mit dem eingegebenen Winkelwert zu aktualisieren.

Hinweis: Wenn der Benutzer auf das grüne Häkchen drückt, dann wird das Fenster DSE-Kopf-Kalibrierung zurück in den Fokus gesetzt und die Winkeldefinitionen werden in die übergeordnete Form zurückgesetzt. Ist die Schaltfläche "Abbrechen" aktiviert, dann werden die Änderungen nicht zurück an die übergeordnete Form geleitet.

Hinweis: Der B-Achsenpositionensatz und alle anderen Parameter bleiben in der Tastspitzendatei bestehen, sodass beim nächsten Aufruf des Kalibrierfensters alle Werte erinnert werden.

Softkeys der Navigationsleiste für dieses Fenster

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Liste "Position löschen" Damit werden alle Einträge in der Liste Kalibrierpositionen gelöscht. | Positionsliste erzeugen Wird zur Erzeugung der Liste mit den Kalibrierpositionen basierend auf dem eingegebenen Startwinkel, dem Endwinkel und der Anzahl der Positionen, die der Liste Kalibrierpositionen hinzugefügt werden, verwendet.
Fügen Sie der Positionsliste einen einzigen Winkel hinzu Liest den Winkelwert im Bereich Einzelnen Winkel hinzufügen und fügt diesen Winkel der Liste Kalibrierpositionen hinzu. | Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.


Protokollierung der DSE-Kopf-Kalibrierung

Klicken Sie sofort, nachdem ein erfolgreicher Kalibriervorgang abgeschlossen ist, im Fenster DSE-Kopf-Kalibrierung auf den Softkey [image] Kalibrierprotokoll anzeigen.

In der Protokolldatei "DSE-Kopf-Kalibrierung" gibt es zwei Hauptbereiche:

  • Im Ersten befinden sich die Vektorangaben, die nur den primären Winkel speichern und lediglich die Vektorkompensationstabelle enthalten.

  • Im zweiten Bereich sind die DSE-Kalibrierangaben enthalten. Bei jeder Position (einschließlich der primären Tastspitze) werden dort der Tastspitzenversatz (von der Rotationsmitte) sowie die Clocking- (= Definitionspunkte erster Zahn), die radialen und die tangentialen Fehler abgespeichert. Die Datei wird folgendermaßen neu geschrieben:

    • Wenn der primäre Winkel kalibriert ist und die anderen Winkel übersprungen werden, wird nur die Vektorkompensierungstabelle in die Datei geschrieben. Die Kalibrierangaben der DSE werden nicht verändert.

    • Wenn der primäre Winkel nicht kalibriert ist (in vollem Umfang), aber die anderen Winkel kalibriert werden, dann wird die Vektorkompensationstabelle zwar nicht geändert, aber die DSE-Kalibrierangaben werden in der Datei aktualisiert.

    • Wenn sowohl der primäre Winkel als auch die anderen Winkel kalibriert werden, dann wird die gesamte Datei überschrieben.

Protokolldetails

Hinweis: Folgendes basiert auf das obige Protokoll mit konfigurierten und kalibrierten Achsen, wie in der Abbildung veranschaulicht. Sie müssen die folgenden Anweisungen je nach Bedarf mit den entsprechenden Achsen modifizieren, wenn Ihr System anders konfiguriert ist.

  • Der Mittelpunkt der Rotation des Kopfes und dessen Versatz vom Nennwert werden durch die Werte Rotationsmitte, X-Verschiebung, Z-Verschiebung und Rotationsachse definiert.

  • Die Maßeinheit der tangentialen Abweichung (Winkel) in der YZ-Ebene erfolgt in Grad. Alle anderen Maßeinheiten werden in den Abstandseinheiten, in denen NC Gage konfiguriert ist (mm im oberen Fall), dargestellt.

  • Die Durchschnittslänge ist der Durchschnitt der in der Abweichungstabelle gefundenen Längenwerte.

  • Die in der Abweichungstabelle gefundene Länge ist der Abstand von der Rotationsmitte zur Messlehrelinie.

  • Die XYZ-Versatzwerte sind der Abstand vom Nennwert für jede Achse.

Softkeys der Navigationsleiste für dieses Fenster

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Speichern Sie das Protokoll als RTF-Datei Mit diesem Softkey wird die Kalibrierdatei im RTF-Format mit dem vorgegebenen Dateinamen abgespeichert. | Print Über diesen Softkey wird das aktive, im Fenster angezeigte Kalibrierprotokoll gedruckt.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.


Nullpunkt

Home > Anwenden von PC-DMIS NC Gage > Erste Schritte > Schritt 6: Arbeitsversatz auswählen

Schritt 6: Arbeitsversatz auswählen

Eine Arbeitsversatz ist einfach eine Ausrichtung. Damit wird eine bestimmte Position in einem 3D-Raum als 0, 0, 0 (Ursprung) deines Koordinatensystems definiert.

Sie können entweder einen bereits definierten Arbeitsversatz für Ihre Messroutine auswählen oder durch die Messung bestimmter Elemente Arbeitsversätze definieren (oder setzen).

  • Nullpunkt auswählen

  • Nullpunkt setzten

Sie können den Arbeitsversatz im Fenster Arbeitsversatz aktualisieren auch automatisch am Ende einer Messroutine aktualisieren.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Nullpunkt setzten Mit diesem Softkey wird ein neues Fenster mit neuen Softkeys angezeigt, um Arbeitsversätze in unterschiedlichen Situationen zu aktualisieren. | Wählen Sie einen Nullpunkt zum Aktualisieren Dieser Softkey wählt den benannten Arbeitsversatz aus der Versatzliste zur Aktualisierung aus. Die wiederholte Betätigung wählt den nächsten Arbeitsversatz aus der Liste aus.
Eine Achse mit Punkt setzen Über diesen Softkey wird das Fenster Eine Achse einrichten aufgerufen. | Zwei Achsen mit Bohrung einstellen Über diesen Softkey wird das Fenster Zwei Achsen einrichten (Bohrung) aufgerufen.
Zwei Achsen mit Zapfen einstellen Über diesen Softkey wird das Fenster Zwei Achsen einrichten (Ausstülpung) aufgerufen. | Zwei Achsen mit innerer Ecke einstellen Über diesen Softkey wird das Fenster Zwei Achsen einrichten (Ecke Innen) aufgerufen.
Zwei Achsen mit äußerer Ecke einstellen Über diesen Softkey wird das Fenster Zwei Achsen einrichten (Ecke Außen) aufgerufen. | Drei Achsen mit Kugel einstellen Wird dazu verwendet, um eine Kugel zu messen und anschließend deren gemessene Koordinaten zur Aktualisierung eines vorgegebenen Arbeitsversatzes einzusetzen.
Eine Achse auf den Mittelpunkt einstellen Über diesen Softkey wird das Fenster Eine Achse auf den Mittelpunkt einstellen aufgerufen. | Rotationswinkel mit Gerade festlegen Über diesen Softkey wird das Fenster Rotationsachsen einstellen (Winkel) aufgerufen.
Rotationswinkel mit Ebene festlegen Über diesen Softkey wird das Fenster Rotationswinkel mit Ebene festlegen aufgerufen. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.


Nullpunkt setzten

Mit dieser Option können Sie den Arbeitsversatz auf der Steuereinheit aktualisieren, indem eine Auswahl von Elementen gemessen wird.

  1. Drücken Sie im Hauptfenster den Softkey Arbeitsversatz einstellen [image]. Die unteren Softkeys zeigen nun die verschiedenen Elemente, die Sie zum Einstellen eines Arbeitsversatzes messen können.

Softkeys für eine Drehachsenmaschine

Softkeys für eine Fräs-Dreh-Werkzeugmaschine

  2. Wählen Sie eines der nachfolgenden Messverfahren aus:

  • Eine Achse einstellen

  • Zwei Achsen (Bohrung) einstellen

  • Zwei Achsen (Bolzen) einstellen

  • Zwei Achsen (Innere Ecke) einstellen

  • Zwei Achsen (Äußere Ecke) einstellen

  • Drei Achsen mit Kugel einstellen

  • Eine Achse auf den Mittelpunkt einstellen

  • Rotationsachsenwinkel mit einer Gerade festlegen

  • Drehachsen (winkel) mit Keilnut setzen

  • Rotationswinkel mit Ebene festlegen

  • Drehachsen (winkel) mit ebener Fläche setzen

  • Drehachsen (winkel) mit Zapfen setzen

  3. Das entsprechende Fenster wird angezeigt.

Hinweis: Sie können den Arbeitsversatz auch im Bildschirm Arbeitsversatz aktualisieren ändern.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Eine Achse einstellen Über diesen Softkey wird das Fenster Eine Achse einrichten aufgerufen. | Zwei Achsen (Bohrung) einstellen Über diesen Softkey wird das Fenster Zwei Achsen einrichten (Bohrung) aufgerufen.
Zwei Achsen (Bolzen) einstellen Über diesen Softkey wird das Fenster Zwei Achsen einrichten (Ausstülpung) aufgerufen. | Zwei Achsen (Innere Ecke) einstellen Über diesen Softkey wird das Fenster Zwei Achsen einrichten (Ecke Innen) aufgerufen.
Zwei Achsen (Äußere Ecke) einstellen Über diesen Softkey wird das Fenster Zwei Achsen einrichten (Ecke Außen) aufgerufen. | Drei Achsen mit Kugel einstellen Dieser Softkey kann dazu verwendet werden, um eine Kugel zu messen und dann deren gemessene Koordinaten zur Aktualisierung eines vorgegebenen Arbeitsversatzes einzusetzen.
Eine Achse auf den Mittelpunkt einstellen Über diesen Softkey wird das Fenster Eine Achse auf den Mittelpunkt einstellen aufgerufen. | Rotationsachsenwinkel mit Gerade festlegen Dieser Softkey ruft das Fenster Rotationsachsen einstellen (Winkel) auf, in dem alle Elemente, die einen wohldefinierten Winkel in der Ebene der Rotationsebene mit einer Linie erzeugen, bestimmt und angezeigt werden.
Rotationsachsenwinkel mit Ebene festlegen Dieser Softkey ruft das Fenster Rotationwinkel mit Ebene einstellen auf, in dem alle Elemente, die einen wohldefinierten Winkel in der Ebene der Rotationsebene mit einer Ebene erzeugen, bestimmt und angezeigt werden. | Drehachsen (winkel) mit Keilnut setzen Über diesen Softkey wird das Fenster Drehachsen (winkel) mit Keilnut setzen aufgerufen.
Drehachsen (winkel) mit ebener Fläche setzen Über diesen Softkey wird das Fenster Drehachsen (winkel) mit ebener Fläche setzen aufgerufen. | Drehachsen (winkel) mit Zapfen setzen Über diesen Softkey wird das Fenster Drehachsen (winkel) mit Zapfen setzen aufgerufen.
Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.


Eine Achse einstellen

Der Softkey Eine Achse einrichten wird dazu verwendet, einen Punkt auf einem Werkstück zu messen und dann dessen Koordinaten zur Aktualisierung eines bestimmten Arbeitsversatzes einzusetzen.

  1. Drücken Sie im Hauptfenster den Softkey Arbeitsversatz einstellen [image]. Die unteren Softkeys zeigen nun die verschiedenen Elemente, die Sie zum Einstellen eines Arbeitsversatzes messen können.

  2. Drücken Sie den Softkey Eine Achse einrichten [image], um das Fenster Eine Achse einrichten aufzurufen:

  3. Folgen Sie den Bildschirmanweisungen und drücken Sie dann den Softkey Bestätigen [image] , um den Vorgang abzuschließen. Drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Bereich "Arbeitsversatz"

  • Arbeitsversatz - Gibt den Arbeitsversatz, der zur Aktualisierung gewählt wurde, an.

Bereich "Parameter"

  • Gemessener X-, Y- oder Z-Wert - Gibt die Position des Arbeitsversatzes an. Der Wert wird von einem 'Punkt-Lernprozess' erlernt. Die Achse variiert aufgrund der in der Ecke unten links im Fenster ausgewählten Richtung.

  • Versatz - Der Arbeitsversatz wird um diese Entfernung zum gemessenen Punkt versetzt.

Bereich "Antast-Parameter"

  • Vorhalteabstand - Der Vorhalteabstand gibt die Position, an der der Taster die Suche nach der Fläche beginnt, an. Hierbei handelt es sich um den Abstand weg von der theoretischen Fläche, die der Taster bei "Suchgeschwindigkeit", die im Setup-Fenster eingerichtet wurde, durchquert.

  • Suchabstand - Beim Suchabstand handelt es sich um die Entfernung, die der Taster während der Suche nach der Fläche fährt, während er sich im Lernmodus befindet. Ist der Taster beispielsweise in der Mitte eines Loches positioniert, dann bewegt er sich bei "Suchgeschwindigkeit", die im Setup-Fenster für den Suchabstand in jeder Richtung ermittelt wurde, um die Elementposition zu suchen bzw. zu lernen.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zurück zum letzten Schritt Dieser Softkey geht im aktuellen Prozess einen Schritt zurück. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Arbeitsfläche auswählen Dieser Softkey bestimmt die Antastrichtung und die Lage der Sicherheitsbewegungen für das Element. Sie können diesen mehrmals betätigen, um einen andere Messoberfläche zu wählen. Verfügbare Oberflächen sind: Oben, Links, Rechts, Vorne, Hinten und Schiefe. Wenn Schiefe ausgewählt ist, dann wird das Softkeysymbol zum Schiefensymbol. | Nullpunkt setzten Mit diesem Softkey wird ein neues Fenster mit neuen Softkeys angezeigt, um Arbeitsversätze in unterschiedlichen Situationen zu aktualisieren.
Wählen Sie einen Nullpunkt zum Aktualisieren Mit diesem Softkey wird durch die Liste der Arbeitsversätze geblättert, wobei durch jeweiliges Drücken der Softkeys einer nach dem anderen angezeigt wird. | Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben.
Wählen Sie einen Taster aus Wenn der Bildschirm Taster auswählen nicht bereits angezeigt wird, ruft dieser Softkey diesen Bildschirm auf. Wenn der Bildschirm Taster auswähle bereits angezeigt wird, können Sie mit diesem Softkey jeden Taster in der Taster-Liste auswählen. | Aktualisierung des Arbeitsversatzes bestätigen Dieser Softkey wird verfügbar, nachdem die Maschine die Elementposition erlernt hat. Es speichert den Befehl in der Messroutine.
Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. |

Prozess aktualisieren

  1. Positionieren Sie den Taster über dem Punkt.

  2. Drücken Sie den Softkey Position lesen [image]. Die Tastspitzenposition wird als die Mitte der Bohrung und Abstand von der Fläche gelesen. Drücken Sie den Softkey Zurück zum letzten Schritt [image] , um diese Position zu löschen und eine neue Position einzulesen.

  3. Drücken Sie den Softkey Ausführen [image] und NC Gage tastet automatisch einen Punkt entlang der entgegengesetzten Richtung der Arbeitsflächennormalen ab. Der Taster sucht in einer Entfernung des Tasterradius' plus den dreifachen Vorhalteabstand.

  4. Die gemessenen Werte werden nach der Abschluss der Antastung aktualisiert. Wählen Sie den Namen des Arbeitsversatzes aus der Liste aus, indem Sie den Softkey Wählen Sie einen zu aktualisierenden Arbeitsversatz aus [image] so lange drücken, bis der gewünschte Arbeitsversatz hervorgehoben wird. Parameter für jeden hervorgehobenen Arbeitsversatz werden entsprechend ihrer jeweiligen Auswahl im Fenster aktualisiert.

  5. Drücken Sie den Softkey Bestätigen [image] , um den Arbeitsversatzwert zu speichern und diese Achse zu aktualisieren. Drücken Sie den Softkey Zurücksetzen [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

'NC-Gage'-spezifischer Elementpfad und logischer Aufbau

  • Lesen Sie die Tasterposition über der Fläche.

  • Messen Sie die Fläche mit Suchabstand des Tasterradius + dreifacher Vorhalteabstand

  • Kehren Sie zur Lesepunktposition zurück.


Zwei Achsen (Bohrung) einstellen

Sie können den Softkey Zwei Achsen mit Bohrung dazu verwenden, eine Kreisbohrung (internes Kreiselement) eines Werkstücks zu messen und dann deren Mittelpunktkoordinaten zur Aktualisierung eines angegebenen Arbeitsversatzes einzusetzen.

  1. Drücken Sie den Softkey Arbeitsversatz einrichten [image] auf der zweiten Seite des Hauptfensters. Die unteren Softkeys zeigen nun die verschiedenen Elemente, die Sie zum Einstellen eines Arbeitsversatzes messen können.

  2. Drücken Sie den Softkey Zwei Achsen einstellen (Bohrung) [image], um das Fenster Zwei Achsen einstellen (Bohrung) aufzurufen:

  3. Folgen Sie den Bildschirmanweisungen, um einen Kreis zu messen, den zu aktualisierenden Arbeitsversatz auszuwählen und drücken Sie dann den Softkey Bestätigen [image] , um den Arbeitsversatz zu aktualisieren. Drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Bereich "Tasterdefinition"

Blendet die Angaben bezüglich des derzeitig geladenen Tasters ein.

Bereich "Tastspitzenversatz"

  • Tastspitzenversatz X, Y und Z - Die Position der Tastspitze relativ zur Messlehre-Geraden.

Bereich "Arbeitsversatz"

  • Arbeitsversatz - Gibt den Arbeitsversatz, der zur Aktualisierung gewählt wurde, an.

Bereich "Parameter"

  • Messwert - Gibt die Position des Arbeitsversatzes an. Der Wert wird von einem 'Kreis (Bohrung)-Lernprozess' gelernt und in Maschinenkoordinaten angezeigt.

  • Ziel - Der Arbeitsversatz wird um diese Entfernung zum gemessenen Element versetzt.

Bereich "Antast-Parameter"

  • Vorhalteabstand - Der Vorhalteabstand gibt die Position, an der der Taster die Suche nach der Fläche beginnt, an. Hierbei handelt es sich um den Abstand weg von der theoretischen Fläche, die der Taster bei "Suchgeschwindigkeit", die im Setup-Fenster eingerichtet wurde, durchquert.

  • Suchabstand - Beim Suchabstand handelt es sich um die Entfernung, die der Taster während der Suche nach der Fläche fährt, während er sich im Lernmodus befindet. Ist der Taster beispielsweise in der Mitte eines Loches positioniert, dann bewegt er sich bei "Suchgeschwindigkeit", die im Setup-Fenster für den Suchabstand in jeder Richtung ermittelt wurde, um die Elementposition zu suchen bzw. zu lernen.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zurück zum letzten Schritt Dieser Softkey geht im aktuellen Prozess einen Schritt zurück. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Wählen Sie einen Nullpunkt zum Aktualisieren Mit diesem Softkey wird durch die Liste der Arbeitsversätze geblättert, wobei durch jeweiliges Drücken der Softkeys einer nach dem anderen angezeigt wird. | Wählen Sie einen Taster aus Wenn der Bildschirm Taster auswählen nicht bereits angezeigt wird, ruft dieser Softkey diesen Bildschirm auf. Wenn der Bildschirm Taster auswähle bereits angezeigt wird, können Sie mit diesem Softkey jeden Taster in der Taster-Liste auswählen.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Aktualisierung des Arbeitsversatzes bestätigen Dieser Softkey wird verfügbar, nachdem die Maschine die Elementposition erlernt hat. Es speichert den Befehl in der Messroutine.
Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. |

Prozess aktualisieren

Hinweis: Bei Maschinen, die über DSE-Achsen im Kopf verfügen, wird der Lernprozess nur entlang der Tasterrichtung der Maschinenachse unterstützt.

  1. Positionieren Sie den Taster in die Mitte der Bohrung.

  2. Drücken Sie den Softkey Position lesen [image] . Die Tastspitzenposition wird als die Mitte der Bohrung und Abstand von der Fläche gelesen. Drücken Sie den Softkey Zurück zum letzten Schritt [image] , um diese Position zu löschen und eine neue Position einzulesen.

  3. Drücken Sie den Softkey Ausführen [image] und NC Gage fährt den Taster und sucht den Kreis (Bohrung) durch Aufnahme von vier automatischen Messpunkten. Daraus wird der Kreismittelpunkt ermittelt.

    Bild mit Angabe der manuellen Startposition, auf die der Taster gerückt wird (A) und die automatischen Antastpfade (rote Linien), die von NC-Gage bei der Messung von vier Punkten (Positionen 1-4) genommen wurden.

  4. Die gemessenen Werte werden nach der Abschluss der Antastung mit dem Kreismittelpunkt aktualisiert. Wählen Sie den Namen des Arbeitsversatzes aus der Liste aus, indem Sie den Softkey Wählen Sie einen zu aktualisierenden Arbeitsversatz aus [image] so lange drücken, bis der gewünschte Arbeitsversatz hervorgehoben wird. Parameter für jeden hervorgehobenen Arbeitsversatz werden entsprechend ihrer jeweiligen Auswahl im Fenster aktualisiert.

  5. Drücken Sie den Softkey Bestätigen [image] , um den Arbeitsversatz zu aktualisieren. Die Achsen, die nicht parallel zu den Arbeitsversatzwerten der Arbeitsflächennormalen liegen, werden aktualisiert. Drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

'NC-Gage'-spezifischer Elementpfad und logischer Aufbau

  • Lesen Sie die Tasterposition in der Mitte der Bohrung.

  • Messungen der Bohrung erfolgen am Z-Wert des Lesepunktes.

  • Schätzen Sie die XY-Mitte der Bohrung, deren Position gelesen werden soll.

  • Messen Sie den Punkt in '+X'-Richtung unter Verwendung des Suchabstandes.

  • Kehren Sie zur Mittenposition zurück.

  • Messen Sie den Punkt in '-X'-Richtung unter Verwendung des Suchabstandes.

  • Kehren Sie zur Mittenposition zurück.

  • Messen Sie den Punkt in '+Y'-Richtung unter Verwendung des Suchabstandes.

  • Kehren Sie zur Mittenposition zurück.

  • Messen Sie den Punkt in '-Y'-Richtung unter Verwendung des Suchabstandes.

  • Kehren Sie zur Mittenposition zurück.


Zwei Achsen (Bolzen) einstellen

Sie können den Softkey Zwei Achsen mit Ausstülpung einstellen dazu verwenden, die Ausstülpung eines Kreises (externes Kreiselement) auf einem Werkstück zu messen und dann deren Mittelpunktkoordinaten zur Aktualisierung eines vorgegebenen Arbeitsversatzes einzusetzen.

  1. Drücken Sie den Softkey Arbeitsversatz einrichten [image] auf der zweiten Seite des Hauptfensters. Die unteren Softkeys zeigen nun die verschiedenen Elemente, die Sie zum Einstellen eines Arbeitsversatzes messen können.

  2. Drücken Sie den Softkey Zwei Achsen mit Ausstülpung einstellen [image], um das Fenster "Zwei Achsen einstellen (Ausstülpung)" aufzurufen.

  3. Folgen Sie den Bildschirmanweisungen, um einen Kreis zu messen, den zu aktualisierenden Arbeitsversatz auszuwählen und drücken Sie dann den Softkey Bestätigen [image] , um den Arbeitsversatz zu aktualisieren. Drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Bereich "Tasterdefinition"

Blendet die Angaben bezüglich des derzeitig geladenen Tasters ein.

Bereich "Tastspitzenversatz"

  • Tastspitzenversatz X, Y und Z - Die Position der Tastspitze relativ zur Messlehre-Geraden.

Bereich "Arbeitsversatz"

  • Arbeitsversatz - Gibt den Arbeitsversatz, der zur Aktualisierung gewählt wurde, an.

Bereich "Parameter"

  • Messwert - Gibt die Position des Arbeitsversatzes an. Der Wert wird von einem 'Kreis (Ausstülpung)-Lernprozess' gelernt und in Maschinenkoordinaten angezeigt.

  • Ziel - Der Arbeitsversatz wird um diese Entfernung zum gemessenen Element versetzt.

Bereich "Antast-Parameter"

  • Vorhalteabstand - Der Vorhalteabstand gibt die Position, an der der Taster die Suche nach der Fläche beginnt, an. Hierbei handelt es sich um den Abstand weg von der theoretischen Fläche, die der Taster bei "Suchgeschwindigkeit", die im Setup-Fenster eingerichtet wurde, durchquert.

  • Suchabstand - Beim Suchabstand handelt es sich um die Entfernung, die der Taster während der Suche nach der Fläche fährt, während er sich im Lernmodus befindet. Ist der Taster beispielsweise in der Mitte eines Loches positioniert, dann bewegt er sich bei "Suchgeschwindigkeit", die im Setup-Fenster für den Suchabstand in jeder Richtung ermittelt wurde, um die Elementposition zu suchen bzw. zu lernen.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zurück zum letzten Schritt Dieser Softkey geht im aktuellen Prozess einen Schritt zurück. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Wählen Sie einen Nullpunkt zum Aktualisieren Mit diesem Softkey wird durch die Liste der Arbeitsversätze geblättert, wobei durch jeweiliges Drücken der Softkeys einer nach dem anderen angezeigt wird. | Wählen Sie einen Taster aus Wenn der Bildschirm Taster auswählen nicht bereits angezeigt wird, ruft dieser Softkey diesen Bildschirm auf. Wenn der Bildschirm Taster auswähle bereits angezeigt wird, können Sie mit diesem Softkey jeden Taster in der Taster-Liste auswählen.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Aktualisierung des Arbeitsversatzes bestätigen Dieser Softkey wird verfügbar, nachdem die Maschine die Elementposition erlernt hat. Es speichert den Befehl in der Messroutine.
Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. |

Folgen Sie den Bildschirmanweisungen, um einen Kreis zu messen, den zu aktualisierenden Arbeitsversatz auszuwählen und berühren Sie dann OK, um den Arbeitsversatz zu aktualisieren.

Prozess aktualisieren

Hinweis: Bei Maschinen, die über DSE-Achsen im Kopf verfügen, wird der Lernprozess nur entlang der Tasterrichtung der Maschinenachse unterstützt.

  1. Positionieren Sie den Taster neben die Seite der Ausstülpung, die unten als "Position A" zu sehen ist. Drücken Sie auf den Softkey Position lesen [image]. Der Abstand zur Fläche wird während des Messvorganges derselbe sein.

  2. Positionieren Sie den Taster über die Mitte der Ausstülpung (siehe "Position B" unten). Drücken Sie auf den Softkey Position lesen [image]. Die Position wird dazu verwendet, den Mittelpunkt der Ausstülpung sowie den Abstand zur Ausstülpung, der notwendig ist, um sicher von einem Messpunkt zum anderen zu gelangen, zu bestimmen. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image] , um diese Messposition abzubrechen.

  3. Drücken Sie den Softkey Ausführen [image]. NC-Gage nimmt einen Messpunkt unterhalb dieser Position auf, um die Höhe der Ausstülpung zu bestimmen. Anschließend werden Messpunkte in ähnlicher Weise, wie weiter unten veranschaulicht, dargestellt.

    Bild mit Angabe der manuellen Positionen, auf die der Taster gerückt wird (A-B) und die automatischen Antastpfade (rote Linien), die von NC-Gage bei der Messung von vier Punkten (Positionen 1-4) genommen wurden.

  4. Die gemessenen Werte werden nach der Abschluss der Antastung mit dem Kreismittelpunkt aktualisiert. Wählen Sie den Namen des Arbeitsversatzes aus der Liste aus, indem Sie den Softkey Wählen Sie einen zu aktualisierenden Arbeitsversatz aus [image] so lange drücken, bis der gewünschte Arbeitsversatz hervorgehoben wird. Parameter für jeden hervorgehobenen Arbeitsversatz werden entsprechend ihrer jeweiligen Auswahl im Fenster aktualisiert.

  5. Drücken Sie den Softkey Bestätigen [image] , um den Arbeitsversatz für die Achsen in der Arbeitsflächennormalen zu aktualisieren. Drücken Sie den Softkey Zurücksetzen [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

'NC-Gage'-spezifischer Elementpfad und logischer Aufbau

  • Tasterposition neben der Seite der Ausstülpung lesen; Z-Wert wird zur Messhöhe.

  • Lesen Sie die Tasterposition über der Mitte der Ausstülpung. XY-Werte definieren die Mitte; der Z-Wert ist die sichere Höhe.

  • Vorhalteradius = projizierter 2D-Abstand zwischen zwei Punkten 'Position lesen'.

  • Auf sichere Höhe fahren.

  • Auf sichere Höhe zu einem Punkt über Vorhaltepunkt 1, der den Vorhalteradius von der Mitte in +X darstellt, fahren.

  • Absenken bis auf Messhöhe.

  • Punkt messen, Ziel ist Mitte an Messhöhe.

  • Auf sichere Höhe fahren.

  • Auf sichere Höhe zu einem Punkt über Vorhaltepunkt 2, der den Vorhalteradius von der Mitte in -X darstellt, fahren.

  • Absenken bis auf Messhöhe.

  • Punkt messen, Ziel ist Mitte an Messhöhe.

  • Auf sichere Höhe fahren.

  • In sicherer Höhe zu einem Punkt über Vorhaltepunkt 3, der den Vorhalteradius von der Mitte in +Y darstellt, fahren.

  • Absenken bis auf Messhöhe.

  • Punkt messen, Ziel ist Mitte an Messhöhe.

  • Auf sichere Höhe fahren.

  • Auf sichere Höhe zu einem Punkt über Vorhaltepunkt 4, der den Vorhalteradius von der Mitte in -Y darstellt, fahren.

  • Absenken bis auf Messhöhe.

  • Punkt messen, Ziel ist Mitte an Messhöhe.

  • Auf sichere Höhe fahren.


Zwei Achsen (Innere Ecke) einstellen

Sie können den Softkey Zwei Achsen mit innerer Ecke einstellen dazu verwenden, eine innere Ecke eines Werkstückes zu messen und dann deren Eckkoordinaten zur Aktualisierung eines vorgegebenen Arbeitsversatzes einzusetzen.

  1. Drücken Sie den Softkey Arbeitsversatz einrichten [image] auf der zweiten Seite des Hauptfensters. Die unteren Softkeys zeigen nun die verschiedenen Elemente, die Sie zum Einstellen eines Arbeitsversatzes messen können.

  2. Drücken Sie den Softkey Zwei Achsen mit innerer Ecke einstellen [image], um das Fenster Zwei Achsen einstellen (Innere Ecke) aufzurufen.

Bereich "Tasterdefinition"

Blendet Informationen zum aktuell ausgewählten, im Werkstückprogramm verwendeten Taster ein.

Bereich "Arbeitsversatz"

  • Arbeitsversatz - Gibt den Arbeitsversatz, der zur Aktualisierung gewählt wurde, an.

Bereich "Parameter"

  • XYZ-Messwert/-Ziel - Gibt den XYZ-Messwert- und die XYZ-Zielpositionen des Arbeitsversatzes an. Die Messwerte werden von einem 'Ecken (innen)-Lernprozess' gelernt.

Bereich "Antast-Parameter"

  • Vorhalteabstand - Der Vorhalteabstand gibt die Position, an der der Taster die Suche nach der Fläche beginnt, an. Hierbei handelt es sich um den Abstand weg von der theoretischen Fläche, die der Taster bei "Suchgeschwindigkeit", die im Setup-Fenster eingerichtet wurde, durchquert.

  • Suchabstand - Beim Suchabstand handelt es sich um die Entfernung, die der Taster während der Suche nach der Fläche fährt, während er sich im Lernmodus befindet. Ist der Taster beispielsweise in der Mitte eines Loches positioniert, dann bewegt er sich bei "Suchgeschwindigkeit", die im Setup-Fenster für den Suchabstand in jeder Richtung ermittelt wurde, um die Elementposition zu suchen bzw. zu lernen.

Bereich "Lokale Sicherheitsebene"

  • Messpunkt Sicherh.-Ebene - Durch Auswahl dieser Option wird der Taster veranlasst, zwischen jedem Elementmesspunkt zu einer Sicherheitsebene zu fahren. Geben Sie in der rechten Box den Abstand zur Ebene ein. Diese Ebene ist nicht die Sicherheitsebene der Messroutine. Siehe "Messpunkt Sicherheitsebene" für weitere Informationen.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zurück zum letzten Schritt Dieser Softkey geht im aktuellen Prozess einen Schritt zurück. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Wählen Sie einen Nullpunkt zum Aktualisieren Mit diesem Softkey wird durch die Liste der Arbeitsversätze geblättert, wobei durch jeweiliges Drücken der Softkeys einer nach dem anderen angezeigt wird. | Wählen Sie einen Taster aus Wenn der Bildschirm Taster auswählen nicht bereits angezeigt wird, ruft dieser Softkey diesen Bildschirm auf. Wenn der Bildschirm Taster auswähle bereits angezeigt wird, können Sie mit diesem Softkey jeden Taster in der Taster-Liste auswählen.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Zur Aktualisierung des Arbeitsversatzes bestätigen Dieser Softkey wird verfügbar, nachdem die Maschine die Elementposition gelernt hat. Es speichert den Befehl in der Messroutine. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. |

Folgen Sie den Bildschirmanweisungen, um eine innere Ecke zu messen, den zu aktualisierenden Arbeitsversatz auszuwählen und drücken Sie dann den Softkey Bestätigen [image] , um den ausgewählten Arbeitsversatz zu aktualisieren.

Prozess aktualisieren

  1. Positionieren Sie den Taster neben eine Fläche, die die Ecke beinhaltet.

  2. Drücken Sie den Softkey Position lesen [image].

  3. Positionieren Sie den Taster neben den ersten Punkt derselben Fläche.

  4. Drücken Sie den Softkey Position lesen [image].

  5. Positionieren Sie den Taster neben eine zweite Fläche, die die Ecke beinhaltet.

  6. Drücken Sie den Softkey Position lesen [image].

  7. Positionieren Sie den Taster neben den ersten Punkt auf dieser zweiten Fläche.

  8. Drücken Sie den Softkey Position lesen [image].

  9. Drücken Sie den Softkey Ausführen [image] und NC Gage nimmt Messpunkte auf die gleiche Weise, wie weiter unten dargestellt, automatisch auf. Drücken Sie den Softkey Zurücksetzen [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Die linke Abbildung gibt die Positionen (A-D), zu denen der Taster manuell gerückt werden soll, an. Die Abbildung rechts gibt die automatischen Antastpfade (rote Linien) an, die von NC Gage bei der Messung von vier Punkten an den Positionen 1-4 genommen wurden.

  10. Die gemessenen Werte werden nach der Abschluss der Antastung mit der Position der Ecke aktualisiert. Wählen Sie den Namen des Arbeitsversatzes aus der Liste aus, indem Sie den Softkey Wählen Sie einen zu aktualisierenden Arbeitsversatz aus [image] so lange drücken, bis der gewünschte Arbeitsversatz hervorgehoben wird. Parameter für jeden hervorgehobenen Arbeitsversatz werden entsprechend ihrer jeweiligen Auswahl im Fenster aktualisiert.

  11. Drücken Sie den Softkey Bestätigen [image] , um den Arbeitsversatz zu aktualisieren. Drücken Sie den Softkey Zurücksetzen [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

'NC-Gage'-spezifischer Elementpfad und logischer Aufbau

  • Wird eine DSE-Maschine ausgeführt, drehen Sie den Taster entlang der Maschinenachse.

  • Lesen Sie die Tasterposition neben dem ersten Punkt der ersten Seite der Ecke. Alle Messungen werden auf derselben Ebene dieses Punktes aufgenommen.

Auf einer DSE-Werkzeugmaschine müssen Sie den Taster zuerst entlang einer Maschinenachse drehen. Die Messung der Eckelemente wird zur Aktualisierung der anderen beiden Achsen des Arbeitsversatzes verwendet:

    • Wenn sich der Taster entlang der Z-Achse der Maschine befindet, dann werden die Parameter der X- und Y-Achsenbereiche durch den ersten Lesepunkt aktualisiert.

    • Wenn sich der Taster entlang der X-Achse der Maschine befindet, dann werden die Parameter der Y- und Z-Achsenbereiche durch den ersten Lesepunkt aktualisiert.

    • Wenn sich der Taster entlang der Y-Achse der Maschine befindet, dann werden die Parameter der X- und Z-Achsenbereiche durch den ersten Lesepunkt aktualisiert.

  • Lesen Sie die Tasterposition neben dem zweiten Punkt der ersten Seite der Ecke.

  • Lesen Sie die Tasterposition neben dem ersten Punkt der zweiten Seite der Ecke.

  • Lesen Sie die Tasterposition neben dem zweiten Punkt der zweiten Seite der Ecke.

  • Bestimmen Sie den ersten und zweiten Richtungsvektor sowie die Normalenvektoren.

  • Kompensieren Sie Punkte.

  • Bestimmen Sie einen ungefähren Eckpunkt.

  • Positionieren Sie den Taster auf die erste Lesepunktposition.

  • Messen Sie in Richtung der ersten Seitenfläche; Suchabstand ist der vierfache Vorhalteabstand.

  • Positionieren Sie den Taster ungefähr auf den zweiten Lesepunkt.

  • Messen Sie in Richtung der ersten Seitenfläche; Suchabstand ist der vierfache Vorhalteabstand.

  • Positionieren Sie den Taster ungefähr auf den dritten Lesepunkt.

  • Messen Sie in Richtung der zweiten Seitenfläche; Suchabstand ist der vierfache Vorhalteabstand.

  • Positionieren Sie den Taster ungefähr auf den vierten Lesepunkt.

  • Messen Sie in Richtung der zweiten Seitenfläche; Suchabstand ist der vierfache Vorhalteabstand.


Zwei Achsen (Äußere Ecke) einstellen

Sie können den Softkey Zwei Achsen mit äußerer Ecke einstellen dazu verwenden, eine äußere Ecke eines Werkstückes zu messen und dann deren Eckkoordinaten zur Aktualisierung eines vorgegebenen Arbeitsversatzes einzusetzen.

  1. Drücken Sie den Softkey Arbeitsversatz einrichten [image] auf der zweiten Seite des Hauptfensters. Die unteren Softkeys zeigen nun die verschiedenen Elemente, die Sie zum Einstellen eines Arbeitsversatzes messen können.

  2. Drücken Sie den Softkey Zwei Achsen mit äußerer Ecke einstellen [image], um das Fenster Zwei Achsen einstellen (Äußere Ecke) aufzurufen:

Bereich "Tasterdefinition"

Blendet Informationen zum aktuell ausgewählten, im Werkstückprogramm verwendeten Taster ein.

Bereich "Arbeitsversatz"

  • Arbeitsversatz - Gibt den Arbeitsversatz, der zur Aktualisierung gewählt wurde, an.

Bereich "Parameter"

  • XYZ-Messwert/-Ziel - Gibt den XYZ-Messwert- und die XYZ-Zielpositionen des Arbeitsversatzes an. Die Messwerte werden von einem 'Ecken (außen)-Lernprozess' gelernt.

Bereich "Antast-Parameter"

  • Vorhalteabstand - Der Vorhalteabstand gibt die Position, an der der Taster die Suche nach der Fläche beginnt, an. Hierbei handelt es sich um den Abstand weg von der theoretischen Fläche, die der Taster bei "Suchgeschwindigkeit", die im Setup-Fenster eingerichtet wurde, durchquert.

  • Suchabstand - Beim Suchabstand handelt es sich um die Entfernung, die der Taster während der Suche nach der Fläche fährt, während er sich im Lernmodus befindet. Ist der Taster beispielsweise in der Mitte eines Loches positioniert, dann bewegt er sich bei "Suchgeschwindigkeit", die im Setup-Fenster für den Suchabstand in jeder Richtung ermittelt wurde, um die Elementposition zu suchen bzw. zu lernen.

Bereich "Lokale Sicherheitsebene"

  • Messpunkt Sicherh.-Ebene - Durch Auswahl dieser Option wird der Taster veranlasst, zwischen jedem Elementmesspunkt zu einer Sicherheitsebene zu fahren. Geben Sie in der rechten Box den Abstand zur Ebene ein. Diese Ebene ist nicht die Sicherheitsebene der Messroutine. Siehe "Messpunkt Sicherheitsebene" für weitere Informationen.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zurück zum letzten Schritt Dieser Softkey geht im aktuellen Prozess einen Schritt zurück. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Wählen Sie einen Nullpunkt zum Aktualisieren Dieser Softkey wählt den benannten Arbeitsversatz aus der Versatzliste zur Aktualisierung aus. Die wiederholte Betätigung wählt den nächsten Arbeitsversatz aus der Liste aus. | Wählen Sie einen Taster aus Wenn der Bildschirm Taster auswählen nicht bereits angezeigt wird, ruft dieser Softkey diesen Bildschirm auf. Wenn der Bildschirm Taster auswähle bereits angezeigt wird, können Sie mit diesem Softkey jeden Taster in der Taster-Liste auswählen.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Aktualisierung des Arbeitsversatzes bestätigen Diese Option wird verfügbar, nachdem die Maschine die Elementposition erlernt hat. Es speichert den Befehl in der Messroutine. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. |

Folgen Sie den Bildschirmanweisungen, um eine äußere Ecke zu messen, den zu aktualisierenden Arbeitsversatz auszuwählen und drücken Sie dann den Softkey Bestätigen [image] , um den ausgewählten Arbeitsversatz zu aktualisieren.

Prozess aktualisieren

  1. Positionieren Sie den Taster neben eine Fläche, die die Ecke beinhaltet.

  2. Drücken Sie den Softkey Position lesen [image].

  3. Positionieren Sie den Taster neben den ersten Punkt derselben Fläche.

  4. Drücken Sie den Softkey Position lesen [image].

  5. Positionieren Sie den Taster neben eine zweite Fläche, die die Ecke beinhaltet.

  6. Drücken Sie den Softkey Position lesen [image].

  7. Positionieren Sie den Taster neben den ersten Punkt auf dieser zweiten Fläche.

  8. Drücken Sie den Softkey Position lesen [image].

  9. Drücken Sie den Softkey Ausführen [image]. Daraufhin nimmt NC Gage Messpunkte auf die gleiche Weise, wie weiter unten dargestellt, automatisch auf.

Die linke Abbildung gibt die Positionen (A-E), zu denen der Taster manuell gerückt werden soll, an. Die Abbildung rechts gibt die automatischen Antastpfade (rote Linien) an, die von NC Gage bei der Messung von vier Punkten an den Positionen 1-4 genommen wurden.

  10. Die gemessenen Werte werden nach der Abschluss der Antastung mit der Position der Ecke aktualisiert. Wählen Sie den Namen des Arbeitsversatzes aus der Liste aus, indem Sie den Softkey Wählen Sie einen zu aktualisierenden Arbeitsversatz aus [image] so lange drücken, bis der gewünschte Arbeitsversatz hervorgehoben wird. Parameter für jeden hervorgehobenen Arbeitsversatz werden entsprechend ihrer jeweiligen Auswahl im Fenster aktualisiert.

  11. Drücken Sie den Softkey Bestätigen [image] , um den Arbeitsversatz zu aktualisieren. Drücken Sie den Softkey Zurücksetzen [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

'NC-Gage'-spezifischer Elementpfad und logischer Aufbau

  • Wird eine DSE-Maschine ausgeführt, drehen Sie den Taster entlang der Maschinenachse.

  • Lesen Sie die Tasterposition neben dem ersten Punkt der ersten Seite der Ecke. Alle Messungen werden auf derselben Ebene dieses Punktes aufgenommen.

Auf einer DSE-Werkzeugmaschine müssen Sie den Taster zuerst entlang einer Maschinenachse drehen. Die Messung der Eckelemente wird zur Aktualisierung der anderen beiden Achsen des Arbeitsversatzes verwendet:

    • Wenn sich der Taster entlang der Z-Achse der Maschine befindet, dann werden die Parameter der X- und Y-Achsenbereiche durch den ersten Lesepunkt aktualisiert.

    • Wenn sich der Taster entlang der X-Achse der Maschine befindet, dann werden die Parameter der Y- und Z-Achsenbereiche durch den ersten Lesepunkt aktualisiert.

    • Wenn sich der Taster entlang der Y-Achse der Maschine befindet, dann werden die Parameter der X- und Z-Achsenbereiche durch den ersten Lesepunkt aktualisiert.

  • Lesen Sie die Tasterposition neben dem zweiten Punkt der ersten Seite der Ecke.

  • Lesen Sie die Tasterposition neben dem ersten Punkt der zweiten Seite der Ecke.

  • Lesen Sie die Tasterposition neben dem zweiten Punkt der zweiten Seite der Ecke.

  • Bestimmen Sie den ersten und zweiten Richtungsvektor sowie die Normalenvektoren.

  • Kompensieren Sie Punkte.

  • Bestimmen Sie einen ungefähren Eckpunkt.

  • Überprüfen Sie die Position des Tasters. Wenn nicht eindeutig auf der Ecke, fahren Sie den Taster zum Schnittpunkt von zwei Linien, die aus vier Lernpunkten geformt werden. Führen Sie diese Bewegung als eine Zweiachsen-Bewegung aus. Wenn die Position sich über der Messhöhe befindet, verschieben Sie zuerst XY und dann Z; wenn die Position sich unter der Messhöhe befindet, verschieben Sie zuerst Z und dann ZY.

  • Positionieren Sie den Taster auf die erste Lesepunktposition.

  • Messen Sie in Richtung der ersten Seitenfläche; die Tiefe entspricht dem ersten Punkt der zweiten Seite.

  • Positionieren Sie den Taster ungefähr auf den zweiten Lesepunkt.

  • Messen Sie in Richtung der ersten Seitenfläche; die Tiefe entspricht dem ersten Punkt der zweiten Seite.

  • Fahren Sie zum Punkt jenseits der Ecke, um eine Kollision zu vermeiden.

  • Positionieren Sie den Taster ungefähr auf den dritten Lesepunkt.

  • Messen Sie in Richtung der zweiten Seitenfläche; die Tiefe entspricht dem ersten Punkt der ersten Seite.

  • Positionieren Sie den Taster ungefähr auf den vierten Lesepunkt.

  • Messen Sie in Richtung der zweiten Seitenfläche; die Tiefe entspricht dem ersten Punkt der ersten Seite.


Drei Achsen mit Kugel einstellen

Der Softkey Drei Achsen mit Kugel einstellen kann dazu verwendet werden, um eine Kugel zu messen und dann deren gemessene Koordinaten zur Aktualisierung eines vorgegebenen Arbeitsversatzes einzusetzen.

Die Anzahl der Punkte definiert die Anzahl der Punkte, die zur Messung der Kugel verwendet wird. Der Winkel der unteren Ebene, der normalerweise 0 ist (Äquator), definiert die untere, zu messende Ebene. Der Winkel der oberen Ebene, der normalerweise 90 ist (Nordpol), definiert die oberste zu messende Ebene.

  1. Drücken Sie den Softkey Arbeitsversatz einrichten [image] auf der zweiten Seite des Hauptfensters. Die unteren Softkeys zeigen nun die verschiedenen Elemente, die Sie zum Einstellen eines Arbeitsversatzes messen können.

  2. Drücken Sie den Softkey Drei Achsen mit Kugel einstellen [image], um das Fenster Drei Achsen einstellen (Kugel) aufzurufen:

  3. Folgen Sie den Bildschirmanweisungen und drücken Sie dann den Softkey Bestätigen [image] , um den Vorgang abzuschließen. Drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Bereich "Arbeitsversatz"

  • Arbeitsversatz - Gibt den Arbeitsversatz, der zur Aktualisierung gewählt wurde, an.

Bereich "Parameter"

  • Parameter X, Y und Z definieren die Kugelmitte. Die Messwert-Spalte gibt die Messwerte des Arbeitsversatzes an. Über die Spalte Ziel werden die theoretischen Werte der Kugelmitte in Arbeitsversatz-Koordinaten definiert. Die theoretischen Werte können beliebige Zahlen sein, sind aber normalerweise Nullen.

Bereich "Tastspitzenversatz"

  • Tastspitzenversatz X, Y und Z - Der Arbeitsversatz wird um diese Entfernung zum gemessenen Element versetzt.

Bereich "Antast-Parameter"

  • Vorhalteabstand - Der Vorhalteabstand gibt die Position, an der der Taster die Suche nach der Fläche beginnt, an. Hierbei handelt es sich um den Abstand weg von der theoretischen Fläche, die der Taster bei "Suchgeschwindigkeit", die im Setup-Fenster eingerichtet wurde, durchquert.

  • Suchabstand - Beim Suchabstand handelt es sich um die Entfernung, die der Taster während der Suche nach der Fläche fährt, während er sich im Lernmodus befindet. Ist der Taster beispielsweise in der Mitte eines Loches positioniert, dann bewegt er sich bei "Suchgeschwindigkeit", die im Setup-Fenster für den Suchabstand in jeder Richtung ermittelt wurde, um die Elementposition zu suchen bzw. zu lernen.

Bereich "Eigenschaften"

  • Anzahl der Punkte - Definiert die Anzahl der Punkte, die zur Messung der Kugel verwendet wird.

  • Winkel der unteren Ebene - Normalerweise 0 (Äquator). Damit wird die untere, zu messende Ebene definiert.

  • Winkel der oberen Ebene - Normalerweise 90 (Nordpol). Damit wird die obere, zu messende Ebene definiert.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zurück zum letzten Schritt Dieser Softkey geht im aktuellen Prozess einen Schritt zurück. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Arbeitsfläche auswählen Dieser Softkey bestimmt die Antastrichtung und die Lage der Sicherheitsbewegungen für das Element. Sie können diesen mehrmals betätigen, um einen andere Messoberfläche zu wählen. Verfügbare Oberflächen sind: Oben, Links, Rechts, Vorne, Hinten und Schiefe. Wenn Schiefe ausgewählt ist, dann wird das Softkeysymbol zum Schiefensymbol. | Nullpunkt setzten Mit diesem Softkey wird ein neues Fenster mit neuen Softkeys angezeigt, um Arbeitsversätze in unterschiedlichen Situationen zu aktualisieren.
Wählen Sie einen Nullpunkt zum Aktualisieren Dieser Softkey wählt den benannten Arbeitsversatz aus der Versatzliste zur Aktualisierung aus. Die wiederholte Betätigung wählt den nächsten Arbeitsversatz aus der Liste aus. | Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben.
Wählen Sie einen Taster aus Wenn der Bildschirm Taster auswählen nicht bereits angezeigt wird, ruft dieser Softkey diesen Bildschirm auf. Wenn der Bildschirm Taster auswähle bereits angezeigt wird, können Sie mit diesem Softkey jeden Taster in der Taster-Liste auswählen. | Aktualisierung des Arbeitsversatzes bestätigen Dieser Softkey wird verfügbar, nachdem die Maschine die Elementposition erlernt hat. Es speichert den Befehl in der Messroutine.
Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. |

Folgen Sie den Bildschirmanweisungen, wählen Sie den zu aktualisierenden Arbeitsversatz aus und drücken Sie dann den Softkey Bestätigen [image] , um den ausgewählten Arbeitsversatz zu aktualisieren.

Prozess aktualisieren

  1. Positionieren Sie den Taster über der Kugelmitte (in der Abbildung weiter unten als Position A dargestellt) und drücken Sie den Softkey Position lesen [image].

  2. Drücken Sie den Softkey Lernen und Erstellen eines Befehls [image].

  3. Systemmonitorprogramm starten. NC Gage nimmt Messpunkte auf ähnliche Weise, wie weiter unten dargestellt, automatisch auf.

Kugelpfad: A) Ausrichtungspositionen 1-4) automatisch gemessene Punktpositionen.

  4. Die Messwerte werden nach der Messung des Elements aktualisiert. Wählen Sie den Namen des Arbeitsversatzes aus der Liste aus, indem Sie den Softkey Wählen Sie einen zu aktualisierenden Arbeitsversatz aus [image] so lange drücken, bis der gewünschte Arbeitsversatz hervorgehoben wird. Parameter für jeden hervorgehobenen Arbeitsversatz werden entsprechend ihrer jeweiligen Auswahl im Fenster aktualisiert.

  5. Drücken Sie den Softkey Bestätigen [image] , um den Arbeitsversatz zu aktualisieren. Drücken Sie den Softkey Zurücksetzen [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

'NC-Gage'-spezifischer Elementpfad und logischer Aufbau

Elementpfad Kugel lernen

Lage und Größe der Kugel werden durch die Messung eines Punktes oben auf der Kugel und durch Antasten von 3 weiteren Punkten in der Nähe des oberen Teiles der Kugel bestimmt. Auf diese Weise wird das Kugelelement gelernt. Sobald die Position und Größe der Kugel bestimmt wurde, wird die Kugel mit der gelernten Größe und Position neu gemessen. Die Messungen werden mit den festgelegten Werten der Bewegungsparameter und Eigenschaftsfelder durchgeführt.

  • Lesen Sie die Tasterposition, die sich über dem oberen Teil der Kugel befinden sollte.

  • Messen Sie den Punkt unter Verwendung des Suchabstandes in einer Richtung, die gerade nach unten verläuft.

  • Ziehen Sie den Taster zur Leseposition zurück und fahren Sie über eine Entfernung, die den zweifachen Tasterradius ausmacht, in Richtung +X.

  • Messen Sie den Punkt unter Verwendung des Suchabstandes in einer Richtung, die gerade nach unten verläuft.

  • Ziehen Sie den Taster auf die ursprüngliche Höhe zurück und fahren Sie über eine Entfernung, die den zweifachen Tasterradius ausmacht, in die Richtung, die 120 Grad von der +X -Achse entfernt ist.

  • Messen Sie den Punkt unter Verwendung des Suchabstandes in einer Richtung, die gerade nach unten verläuft.

  • Ziehen Sie den Taster auf die ursprüngliche Höhe zurück und fahren Sie über eine Entfernung, die den zweifachen Tasterradius ausmacht, in die Richtung, die 240 Grad von der +X -Achse entfernt ist.

  • Messen Sie den Punkt unter Verwendung des Suchabstandes in einer Richtung, die gerade nach unten verläuft.

  • Ziehen Sie den Taster auf ursprüngliche Höhe zurück.

Elementpfad Kugel ausführen

  • Die Anzahl der Ebenen und Punkte für jede Ebene wird aufgrund der Eingaben definiert.

  • Wenn die aktuelle Position unterhalb der Sicherheitsebenenhöhe liegt, dann fahren Sie hoch zur Sicherheitsebene.

  • Fahren Sie zur Position über dem ersten Punkt des Vorhaltebereichs.

  • Senken Sie den Taster bis zur untersten Ebene ab und messen Sie diese Ebene. Fügen Sie je nach Bedarf zwischen jedem Punkt in einer Ebene Ausweichsbewegungen hinzu, um Kollisionen zu vermeiden.

  • Messen Sie die verbleibende(n) Ebene(n), wobei Sie die Punkte in abwechselnden Richtungen aufnehmen.

  • Messen Sie einen Punkt oben auf der Kugel (wenn der Winkel der oberen Ebene 90 Grad aufweist).

  • Fahren Sie zur Sicherheitsebenenhöhe.


Eine Achse auf den Mittelpunkt einstellen

Der Softkey Eine Achse auf den Mittelpunkt einstellen kann dazu verwendet werden, eine Achse eines Arbeitsversatzes so einzustellen, dass sie einen Wert aufweist, der sich in der Mitte von zwei parallelen Flächen befindet.

  1. Drücken Sie im Hauptfenster den Softkey Arbeitsversatz einstellen [image]. Die unteren Softkeys zeigen nun die verschiedenen Elemente, die Sie zum Einstellen eines Arbeitsversatzes messen können.

  2. Drücken Sie den Softkey Eine Achse auf den Mittelpunkt einstellen [image], um das Fenster Eine Achse auf den Mittelpunkt einstellen aufzurufen.

Bereich "Tasterdefinition"

Blendet Informationen zum aktuell ausgewählten, im Werkstückprogramm verwendeten Taster ein.

Bereich "Arbeitsversatz"

  • Arbeitsversatz - Gibt den Arbeitsversatz, der zur Aktualisierung gewählt wurde, an.

Bereich "Parameter"

  • Gemessener X-, Y- oder Z-Wert - Gibt die Position des Arbeitsversatzes an. Der Wert wird von einem 'Punkt-Lernprozess' erlernt. Die Achse variiert aufgrund der im Bereich Achse ausgewählten Richtung.

Hinweis: Die Symbolabbildung im oberen linken Teil dieses Fensters wird aufgrund der vorgenommenen Auswahl in den Bereichen Achse und Form aktualisiert.

  • Ziel - Der Arbeitsversatz wird so eingestellt, dass der gemessene Mittelpunkt mit dem Zielwert übereinstimmt, wenn die Option "Arbeitsversatz" aktiviert ist.

Bereich "Antast-Parameter"

  • Vorhalteabstand - Der Vorhalteabstand gibt die Position, an der der Taster die Suche nach der Fläche beginnt, an. Hierbei handelt es sich um den Abstand weg von der theoretischen Fläche, die der Taster bei "Suchgeschwindigkeit", die im Setup-Fenster eingerichtet wurde, durchquert.

  • Suchabstand - Beim Suchabstand handelt es sich um die Entfernung, die der Taster während der Suche nach der Fläche fährt, während er sich im Lernmodus befindet. Ist der Taster beispielsweise in der Mitte eines Loches positioniert, dann bewegt er sich bei "Suchgeschwindigkeit", die im Setup-Fenster für den Suchabstand in jeder Richtung ermittelt wurde, um die Elementposition zu suchen bzw. zu lernen.

Bereich "Achse"

  • Wählen Sie die Richtung aus, in der die beiden Flächen gemessen werden, um den Mittelpunkt zu berechnen. Der Bereich Parameter wird entsprechend aktualisiert.

Bereich "Form"

  • Wählen Sie die Form des zu messenden Elements aus, das zur Berechnung des Mittelpunkts verwendet wird.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zurück zum letzten Schritt Dieser Softkey geht im aktuellen Prozess einen Schritt zurück. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Wählen Sie einen Nullpunkt zum Aktualisieren Mit diesem Softkey wird durch die Liste der Arbeitsversätze geblättert, wobei durch jeweiliges Drücken der Softkeys einer nach dem anderen angezeigt wird. | Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben.
Wählen Sie einen Taster aus Wenn der Bildschirm Taster auswählen nicht bereits angezeigt wird, ruft dieser Softkey diesen Bildschirm auf. Wenn der Bildschirm Taster auswähle bereits angezeigt wird, können Sie mit diesem Softkey jeden Taster in der Taster-Liste auswählen. | Aktualisierung des Arbeitsversatzes bestätigen Dieser Softkey wird verfügbar, nachdem die Maschine die Elementposition erlernt hat. Es speichert den Befehl in der Messroutine.
Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. |

Lernprozess

  1. Wählen Sie die jeweilige Achse nach Bedarf im Bereich Achse des Fensters aus. Verfügbare Achsen sind die X-, Y- und Z-Achse.

  2. Wählen Sie die jeweilige Form nach Bedarf im Bereich Form des Fensters aus. Verfügbare Formen sind Steg, Tasche und Schritt. Alle drei Formen werden bei Einstellung der X- oder Y-Achse verfügbar. Für die Z-Achse steht nur die Form "Schritt" zur Verfügung.

Hinweis: Die Symbolabbildung im oberen linken Teil dieses Fensters wird aufgrund der vorgenommenen Auswahl in den Bereichen Achse und Form aktualisiert.

  3. Geben Sie einen Zielwert ein.

In der folgenden Matrix wird der Lernprozess für jede Form-/Achsenkombination beschrieben:

X-, Y- oder Z-Achse

Steg

  1. Erste Seite des Stegs.

  2. Gegenüber liegende Seite des Stegs.

  3. Definieren Sie die Sichere Höhe, um von der einen zur anderen Seite zu gelangen.

Tasche

  1. Erste Seite der Tasche.

  2. Zweite Seite des Punktes.

Weiter

  1. Neben dem Punkt an der ersten Schrittebene.

  2. Neben dem Punkt an der zweiten Schrittebene.

  3. Fahren Sie den Taster weg vom zweiten Punkt.

  4. Setzen Sie den Vorhalteabstand und den Suchabstand. Dies kann jederzeit geschehen.

  5. Wählen Sie einen Arbeitsversatz zum Aktualisieren. Dies kann jederzeit geschehen.

  6. Nach dem Lernen der Punkte zur Definition der Messung drückt der Benutzer den Softkey Ausführen [image]. NC Gage fährt mit der Messung des Werkstückes fort. Der Mittelpunktwert wird berechnet und im Fenster eingeblendet.

  7. Klicken Sie den Softkey Bestätigen [image], um das Ergebnis zu akzeptieren und zu speichern, oder drücken Sie den Softkey Abbrechen [image], um das Ergebnis abzulehnen und nicht abzuspeichern.

Formbeispiele

Schritt-Formen:

Formen 'Tasche' und 'Steg':


Rotationsachsenwinkel mit einer Gerade festlegen

Das Fenster Rotationsachsen einstellen (Winkel) wird dazu verwendet, alle Elemente, die einen wohldefinierten Winkel in der Ebene der Rotationsachse erzeugen, zu bestimmen und anzuzeigen.

Rufen Sie dieses Fenster auf, indem Sie die folgenden Schritte durchführen:

  1. Drücken Sie den Softkey Arbeitsversatz einrichten [image] auf der zweiten Seite des Hauptfensters. Die unteren Softkeys zeigen nun die verschiedenen Elemente, die Sie zum Einstellen eines Arbeitsversatzes messen können.

  2. Drücken Sie den Softkey Rotationsachsenwinkel mit Gerade festlegen [image], um das Fenster Rotationsachsen einstellen (Winkel) einzublenden:

  3. Folgen Sie den Bildschirmanweisungen und drücken Sie dann den Softkey Bestätigen [image], um den Vorgang abzuschließen. Drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Bereich "Tastspitzenversatz"

  • Tastspitzenversatz X, Y und Z - Die Position der Tastspitze relativ zur Messlehre-Geraden.

Bereich "Arbeitsversatz"

  • Arbeitsversatz - Gibt den Arbeitsversatz, der zur Aktualisierung gewählt wurde, an.

Bereich "Drehtisch"

  • Achsen-ID - Der Buchstabe, der die Achse kennzeichnet - A, B oder C, je nachdem, wie viele Drehtische im System definiert sind.

Bereich "Messung"

  • Winkel - Blendet die Mess- und Zielwerte der Drehtischwinkel ein.

Bereich "Eigenschaften"

  • Anzahl der Punkte - Definiert die Anzahl der zu messenden Punkte.

Bereich "Antast-Parameter"

  • Vorhalteabstand - Definiert den Abstand weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchabstand - Beim Suchabstand handelt es sich um die Entfernung, die der Taster während der Suche nach der Fläche fährt, während er sich im Lernmodus befindet. Ist der Taster beispielsweise in der Mitte eines Loches positioniert, dann bewegt er sich bei "Suchgeschwindigkeit", die im Setup-Fenster für den Suchabstand in jeder Richtung ermittelt wurde, um die Elementposition zu suchen bzw. zu lernen.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zurück zum letzten Schritt Dieser Softkey geht im aktuellen Prozess einen Schritt zurück. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Arbeitsfläche auswählen Dieser Softkey bestimmt die Antastrichtung und die Lage der Sicherheitsbewegungen für das Element. Sie können diesen mehrmals betätigen, um einen andere Messoberfläche zu wählen. Verfügbare Oberflächen sind: Oben, Links, Rechts, Vorne, Hinten und Schiefe. Wenn Schiefe ausgewählt ist, dann wird das Softkeysymbol zum Schiefensymbol. | Nullpunkt setzten Mit diesem Softkey wird ein neues Fenster mit neuen Softkeys angezeigt, um Arbeitsversätze in unterschiedlichen Situationen zu aktualisieren.
Wählen Sie einen Nullpunkt zum Aktualisieren Dieser Softkey wählt den benannten Arbeitsversatz aus der Versatzliste zur Aktualisierung aus. Die wiederholte Betätigung wählt den nächsten Arbeitsversatz aus der Liste aus. | Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben.
Wählen Sie einen Taster aus Wenn der Bildschirm Taster auswählen nicht bereits angezeigt wird, ruft dieser Softkey diesen Bildschirm auf. Wenn der Bildschirm Taster auswähle bereits angezeigt wird, können Sie mit diesem Softkey jeden Taster in der Taster-Liste auswählen. | Aktualisierung des Arbeitsversatzes bestätigen Dieser Softkey wird verfügbar, nachdem die Maschine die Elementposition erlernt hat. Es speichert den Befehl in der Messroutine.
Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. |

Lernprozess

Das Konzept basiert auf der Messung einer Geraden, die sich in der "Drehtischebene" befindet, damit die Rotationsachsenkomponente des Arbeitsversatzes auf dieser Geraden basierend eingestellt werden kann. Die Messung dieser Geraden bestimmt einen Winkel in der Ebene und der Rotationsachsenwinkel entspricht dem Zielwinkel bei aktivem aktualisierten Arbeitsversatz.

Es gibt zwei verschiedene Fälle zum Messen der Geraden:

  • Im ersten Fall verläuft die Normalenachse der Drehtischebene parallel (oder antiparallel) zur Spindelachse.

In der obigen Abbildung ist ein Werkstück mit einem Neigungswinkel von 30 Grad in der Achse C auf dem Tisch befestigt. Der Benutzer möchte den Nullpunkt der Drehachse C aktualisieren, damit das Arbeits-Koordinatensystem X+ mit der Geradenrichtung übereinstimmt, wenn der Nullpunkt aktiv ist.

Zuerst sollte der Benutzer den Tisch C drehen, um die Richtung der gelben Geraden in der ungefähren Nullpunktposition (X+) auszurichten. Von da ab kann NC Gage feststellen, dass der Zielwert, der aus der Geraden berechnet wird, in etwa 30 Grad, nicht jedoch 30+180=210 Grad beträgt.

Außer der Vorbedingung dieser Grobausrichtung stimmen die Lernschritte mit denen, die im Vorgang Lernen einer Geraden in NC Gage durchgeführt werden, überein.

Wie in der Abbildung weiter unten zu sehen ist, wird die Richtung der gelben Geraden auf der Vorderseite gemessen. Der Benutzer erhält Eingabeaufforderungen auf dem Bildschirm, um die Positionen der Punkte 1 und 2 zu lernen. Sobald NC Gage diese Punktpositionen vermittelt werden, verfügt das Programm über die notwendigen Informationen, um die Gerade automatisch zu messen.

In der obigen Abbildung stellt die Richtung der Geraden - hier angezeigt in Schwarz - den Messweg dar. Dies erfolgt mit Hilfe der Positionierung des Tasters an den drei eingeblendeten Positionen.

  • Im zweiten Fall verläuft die Normalenachse der Drehtischebene rechtwinklig zur Spindelachse.

In der obigen Abbildung ist ein Werkstück mit einem Neigungswinkel von 30 Grad in der Achse A auf dem Tisch befestigt. Der Benutzer möchte den Nullpunkt der Drehachse A aktualisieren, damit das Arbeits-Koordinatensystem Y+ mit der Richtung der gelben Geraden übereinstimmt, wenn der neue Nullpunkt aktiv ist.

Zuerst sollte der Benutzer den Tisch A drehen, um die Richtung der gelben Geraden in der ungefähren Nullpunktposition (X+) auszurichten. Von da ab kann NC Gage feststellen, dass der Zielwert, der aus der Geraden berechnet wird, in etwa 30 Grad, nicht jedoch 30+180=210 Grad beträgt.

In diesem Fall, außer die Vorbedingung der Grobausrichtung, benötigt das Erlernen der Gerade einen Schritt weniger. Der Grund hierfür ist, dass im ersten Fall nicht sicher ist, ob sich das Werkstück auf der "linken" oder "rechten" Seite der definierten Gerade unter Verwendung der ersten beiden Punkte befindet. Der Benutzer wird also angewiesen, einen dritten Punkt zu lernen, indem er den Taster von der Fläche "weg" bewegt.

Der zweite Fall ist anders, da die Richtung des Tasters und die der Drehtischebene nur eine Möglichkeit zulassen und der Benutzer deshalb nicht aufgefordert wird, einen dritten Punkt zu lernen.

Hier versucht der Benutzer, die Richtung der gelben Geraden zu messen, die in der Ebene liegt und durch schnelles Drehen des Tisches auf der Seite definiert wird (in der obigen Abbildung sieht dies wie ein Dübel aus).

Der Benutzer erhält Eingabeaufforderungen auf dem Bildschirm, um die Positionen der Punkte 1 und 2 zu lernen. Sobald NC Gage diese Punktpositionen vermittelt werden, verfügt das Programm über die notwendigen Informationen, um die Gerade automatisch zu messen.

Im obigen Beispiel stellt die Richtung der Geraden - hier dargestellt in Schwarz - den Messweg dar. Dies erfolgt mit Hilfe der Positionierung des Tasters an den zwei eingeblendeten Positionen.


Drehachsen (winkel) mit Keilnut setzen

Das Fenster Drehachsen (Winkel) mit Keilnut setzen wird dazu verwendet, alle Elemente, die einen wohldefinierten Winkel in der Ebene der Rotationsachse erzeugen, zu bestimmen und anzuzeigen.

So rufen Sie dieses Fenster auf:

  1. Drücken Sie den Softkey Arbeitsversatz einrichten [image] auf der zweiten Seite des Hauptfensters. Die unteren Softkeys zeigen nun die verschiedenen Elemente, die Sie zum Einstellen eines Arbeitsversatzes messen können.

  2. Drücken Sie den Softkey Drehachsen (Winkel) mit Keilnut setzen [image], um das Fenster Drehachsen (Winkel) mit Keilnut setzen zu öffnen:

  3. Folgen Sie den Bildschirmanweisungen und drücken Sie dann den Softkey Bestätigen [image], um den Vorgang abzuschließen. Drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Bereich "Tastspitzenversatz"

  • Tastspitzenversatz X, Y und Z - Die Position der Tastspitze relativ zur Messlehre-Geraden.

Bereich "Arbeitsversatz"

  • Arbeitsversatz - Gibt den Arbeitsversatz, der zur Aktualisierung gewählt wurde, an.

Bereich "Drehtisch"

  • Achsen-ID - Der Buchstabe, der die Achse kennzeichnet - A, B oder C, je nachdem, wie viele Drehtische im System definiert sind.

Bereich "Messung"

  • Winkel - Blendet die Mess- und Zielwerte der Drehtischwinkel ein.

Bereich "Antast-Parameter"

  • Vorhaltewinkel - Definiert den Winkel weg von der theoretischen Fläche, an der der Taster beginnt, sich dem Messpunkt in der Messgeschwindigkeit zu nähern.

  • Suchwinkelbereich - Definiert den Suchwinkelbereich bei der Suche und beim Lernen eines Elements.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zurück zum letzten Schritt Dieser Softkey geht im aktuellen Prozess einen Schritt zurück. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Arbeitsfläche auswählen Dieser Softkey bestimmt die Antastrichtung und die Lage der Sicherheitsbewegungen für das Element. Sie können diesen mehrmals betätigen, um einen andere Messoberfläche zu wählen. Verfügbare Oberflächen sind: Oben, Links, Rechts, Vorne, Hinten und Schiefe. Wenn Schiefe ausgewählt ist, dann wird das Softkeysymbol zum Schiefensymbol. | Nullpunkt setzten Mit diesem Softkey wird ein neues Fenster mit neuen Softkeys angezeigt, um Arbeitsversätze in unterschiedlichen Situationen zu aktualisieren.
Wählen Sie einen Nullpunkt zum Aktualisieren Dieser Softkey wählt den benannten Arbeitsversatz aus der Versatzliste zur Aktualisierung aus. Die wiederholte Betätigung wählt den nächsten Arbeitsversatz aus der Liste aus. | Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben.
Wählen Sie einen Taster aus Wenn der Bildschirm Taster auswählen nicht bereits angezeigt wird, ruft dieser Softkey diesen Bildschirm auf. Wenn der Bildschirm Taster auswähle bereits angezeigt wird, können Sie mit diesem Softkey jeden Taster in der Taster-Liste auswählen. | Aktualisierung des Arbeitsversatzes bestätigen Dieser Softkey wird verfügbar, nachdem die Maschine die Elementposition erlernt hat. Es speichert den Befehl in der Messroutine.
Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. |

Lernvorgang

Weitere Informationen finden Sie unter "Lernvorgang" im Abschnitt "Keilnut".

Vorgang ausführen

Weitere Informationen finden Sie unter "Vorgang ausführen" im Abschnitt "Keilnut".


Rotationswinkel mit Ebene festlegen

Das Fenster Rotationswinkel mit Ebene einstellen wird zur Einstellung der Nullpunktwerte für ein Drehtischpaar verwendet, um die gemessene Ebene mit der Spindelachse rechtwinklig auszurichten.

Diese Option ist nur für Systeme verfügbar, die zwei (gestapelte) Drehtische haben. Sie setzt die Nullpunktwerte für beide Drehachsen gleichzeitig, indem eine Ebene gemessen wird. NC Gage berechnet die Winkel, die zur Ausrichtung der Ebene senkrecht zum Taster notwendig sind.

Rufen Sie dieses Fenster auf, indem Sie die folgenden Schritte durchführen:

  1. Drücken Sie den Softkey Arbeitsversatz einrichten [image] auf der zweiten Seite des Hauptfensters. Die unteren Softkeys zeigen nun die verschiedenen Elemente, die Sie zum Einstellen eines Arbeitsversatzes messen können.

  2. Drücken Sie den Softkey Rotationswinkel mit Ebene festlegen [image], um das Fenster Rotationswinkel mit Ebene festlegen aufzurufen:

Bereich "Tastspitzenversatz"

  • Tastspitzenversatz X, Y und Z - Die Position der Tastspitze relativ zur Messlehre-Geraden.

Bereich "Arbeitsversatz"

  • Arbeitsversatz - Gibt den Arbeitsversatz, der zur Aktualisierung gewählt wurde, an.

Bereich "Messung"

  • Winkel - Blendet die Mess- und Zielwerte der Drehtischwinkel ein.

Bereich "Messmethode"

  • Gitter - Definiert die Messmethode, die bei der Messung der Ebene in einer Reihe von Zeilen verwendet werden soll.

  • Kreis - Definiert die Messmethode, die bei der Messung der Ebene in einem kreisförmigen Muster verwendet werden soll.

Bereich "Eigenschaften"

  • Anzahl der Reihen - Definiert die Anzahl der Reihen, die zu messen sind, wenn eine Ebene Gitter bestimmt wird.

  • Anzahl der Punkte pro Reihe - Definiert die Anzahl der Punkte in jeder zu messenden Reihe, wenn eine Ebene Gitter bestimmt wird.

  • Anzahl der Punkte - Definiert die Anzahl der zu messenden Punkte, wenn eine Ebene Kreis bestimmt wird.

Bereich "Antast-Parameter"

  • Vorhalteabstand - Der Vorhalteabstand gibt die Position, an der der Taster die Suche nach der Fläche beginnt, an. Hierbei handelt es sich um den Abstand weg von der theoretischen Fläche, die der Taster bei "Suchgeschwindigkeit", die im Setup-Fenster eingerichtet wurde, durchquert.

  • Suchabstand - Beim Suchabstand handelt es sich um die Entfernung, die der Taster während der Suche nach der Fläche fährt, während er sich im Lernmodus befindet. Ist der Taster beispielsweise in der Mitte eines Loches positioniert, dann bewegt er sich bei "Suchgeschwindigkeit", die im Setup-Fenster für den Suchabstand in jeder Richtung ermittelt wurde, um die Elementposition zu suchen bzw. zu lernen.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zurück zum letzten Schritt Dieser Softkey geht im aktuellen Prozess einen Schritt zurück. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Arbeitsfläche auswählen Dieser Softkey bestimmt die Antastrichtung und die Lage der Sicherheitsbewegungen für das Element. Sie können diesen mehrmals betätigen, um einen andere Messoberfläche zu wählen. Verfügbare Oberflächen sind: Oben, Links, Rechts, Vorne, Hinten und Schiefe. Wenn Schiefe ausgewählt ist, dann wird das Softkeysymbol zum Schiefensymbol. | Nullpunkt setzten Mit diesem Softkey wird ein neues Fenster mit neuen Softkeys angezeigt, um Arbeitsversätze in unterschiedlichen Situationen zu aktualisieren.
Wählen Sie einen Nullpunkt zum Aktualisieren Dieser Softkey wählt den benannten Arbeitsversatz aus der Versatzliste zur Aktualisierung aus. Die wiederholte Betätigung wählt den nächsten Arbeitsversatz aus der Liste aus. | Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben.
Wählen Sie einen Taster aus Wenn der Bildschirm Taster auswählen nicht bereits angezeigt wird, ruft dieser Softkey diesen Bildschirm auf. Wenn der Bildschirm Taster auswähle bereits angezeigt wird, können Sie mit diesem Softkey jeden Taster in der Taster-Liste auswählen. | Aktualisierung des Arbeitsversatzes bestätigen Dieser Softkey wird verfügbar, nachdem die Maschine die Elementposition erlernt hat. Es speichert den Befehl in der Messroutine.
Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. |

Lernprozess

Um diese Option anzuwenden, sollte der Benutzer die Tische manuell positionieren, sodass sich die Fläche rechtwinklig zum Taster befindet. Durch diese Voraussetzung werden der Lern- und Messvorgang erleichtert.

Die einzelnen Schritte des Lernvorganges der Ebene sollten mit denen des Ebenenelements übereinstimmen.

  1. Wählen Sie entweder die Messmethode Gitter oder Kreis aus. Wird die Option Gitter ausgewählt, werden die Steuerelemente Anzahl der Reihen und Punkte pro Reihe, wie im Fenster oben auf dieser Seite zu sehen ist, angezeigt. Ist die Option Kreis ausgewählt, wird das Steuerelement Anzahl der Punkte eingeblendet.

  2. Setzen Sie den Vorhalteabstand und den Suchabstand.

  3. Bestimmen Sie die Lage des Musters durch Lernen zweier Punkte zur Definition des Gitters oder einer Diagonalen des kreisförmigen Musters.

  4. Sobald die beiden Punkte definiert wurden, drücken Sie den Softkey Ausführen [image], um das Monitorprogramm zu starten. NC Gage fährt mit der Messung der Ebene fort. Nachdem die Ebene aufgenommen wurde, berechnet NC Gage die benötigten Drehungen, um die Oberfläche rechtwinklig zum Taster auszurichten. Der Benutzer sollte den richtigen Arbeitsversatz auswählen (dieser kann jederzeit angepasst werden).

  5. Drücken Sie den Softkey Bestätigen [image], um die Werte zum Setzen des ausgewählten Arbeitsversatzes zu verwenden, oder drücken Sie den Softkey Abbrechen [image], um den Vorgang abzubrechen.


Drehachsen (winkel) mit ebener Fläche setzen

Das Fenster Drehachsen (Winkel) mit ebener Fläche setzen wird dazu verwendet, alle Elemente, die einen wohldefinierten Winkel in der Ebene der Rotationsachse erzeugen, zu bestimmen und anzuzeigen.

So rufen Sie dieses Fenster auf:

  1. Drücken Sie den Softkey Arbeitsversatz einrichten [image] auf der zweiten Seite des Hauptfensters. Die unteren Softkeys zeigen nun die verschiedenen Elemente, die Sie zum Einstellen eines Arbeitsversatzes messen können.

  2. Drücken Sie den Softkey Drehachsen (Winkel) mit ebener Fläche setzen [image], um das Fenster Drehachsen (Winkel) mit ebener Fläche setzen zu öffnen:

  3. Folgen Sie den Bildschirmanweisungen und drücken Sie dann den Softkey Bestätigen [image], um den Vorgang abzuschließen. Drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Bereich "Tastspitzenversatz"

  • Tastspitzenversatz X, Y und Z - Die Position der Tastspitze relativ zur Messlehre-Geraden.

Bereich "Arbeitsversatz"

  • Arbeitsversatz - Gibt den Arbeitsversatz, der zur Aktualisierung gewählt wurde, an.

Bereich "Drehtisch"

  • Achsen-ID - Der Buchstabe, der die Achse kennzeichnet - A, B oder C, je nachdem, wie viele Drehtische im System definiert sind.

Bereich "Messung"

  • Winkel - Blendet die Mess- und Zielwerte der Drehtischwinkel ein.

Bereich "Antast-Parameter"

  • Vorhaltewinkel - Definiert den Winkel weg von der theoretischen Fläche, an der der Taster beginnt, sich dem Messpunkt in der Messgeschwindigkeit zu nähern.

  • Suchwinkelbereich - Definiert den Suchwinkelbereich bei der Suche und beim Lernen eines Elements.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zurück zum letzten Schritt Dieser Softkey geht im aktuellen Prozess einen Schritt zurück. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Arbeitsfläche auswählen Dieser Softkey bestimmt die Antastrichtung und die Lage der Sicherheitsbewegungen für das Element. Sie können diesen mehrmals betätigen, um einen andere Messoberfläche zu wählen. Verfügbare Oberflächen sind: Oben, Links, Rechts, Vorne, Hinten und Schiefe. Wenn Schiefe ausgewählt ist, dann wird das Softkeysymbol zum Schiefensymbol. | Nullpunkt setzten Mit diesem Softkey wird ein neues Fenster mit neuen Softkeys angezeigt, um Arbeitsversätze in unterschiedlichen Situationen zu aktualisieren.
Wählen Sie einen Nullpunkt zum Aktualisieren Dieser Softkey wählt den benannten Arbeitsversatz aus der Versatzliste zur Aktualisierung aus. Die wiederholte Betätigung wählt den nächsten Arbeitsversatz aus der Liste aus. | Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben.
Wählen Sie einen Taster aus Wenn der Bildschirm Taster auswählen nicht bereits angezeigt wird, ruft dieser Softkey diesen Bildschirm auf. Wenn der Bildschirm Taster auswähle bereits angezeigt wird, können Sie mit diesem Softkey jeden Taster in der Taster-Liste auswählen. | Aktualisierung des Arbeitsversatzes bestätigen Dieser Softkey wird verfügbar, nachdem die Maschine die Elementposition erlernt hat. Es speichert den Befehl in der Messroutine.
Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. |

Lernvorgang

Weitere Informationen finden Sie unter "Lernvorgang" im Abschnitt "Fläche".

Vorgang ausführen

Weitere Informationen finden Sie unter "Vorgang ausführen" im Abschnitt "Fläche".


Drehachsen (winkel) mit Zapfen setzen

Das Fenster Drehachsen (Winkel) mit Zapfen setzen wird dazu verwendet, alle Elemente, die einen wohldefinierten Winkel in der Ebene der Rotationsachse erzeugen, zu bestimmen und anzuzeigen.

So rufen Sie dieses Fenster auf:

  1. Drücken Sie den Softkey Arbeitsversatz einrichten [image] auf der zweiten Seite des Hauptfensters. Die unteren Softkeys zeigen nun die verschiedenen Elemente, die Sie zum Einstellen eines Arbeitsversatzes messen können.

  2. Drücken Sie den Softkey Drehachsen (Winkel) mit Zapfen setzen [image], um das Fenster Drehachsen (Winkel) mit Zapfen setzen zu öffnen:

  3. Folgen Sie den Bildschirmanweisungen und drücken Sie dann den Softkey Bestätigen [image], um den Vorgang abzuschließen. Drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Bereich "Tastspitzenversatz"

  • Tastspitzenversatz X, Y und Z - Die Position der Tastspitze relativ zur Messlehre-Geraden.

Bereich "Arbeitsversatz"

  • Arbeitsversatz - Gibt den Arbeitsversatz, der zur Aktualisierung gewählt wurde, an.

Bereich "Drehtisch"

  • Achsen-ID - Der Buchstabe, der die Achse kennzeichnet - A, B oder C, je nachdem, wie viele Drehtische im System definiert sind.

Bereich "Messung"

  • Winkel - Blendet die Mess- und Zielwerte der Drehtischwinkel ein.

Bereich "Antast-Parameter"

  • Vorhaltewinkel - Definiert den Winkel weg von der theoretischen Fläche, an der der Taster beginnt, sich dem Messpunkt in der Messgeschwindigkeit zu nähern.

  • Suchwinkelbereich - Definiert den Suchwinkelbereich bei der Suche und beim Lernen eines Elements.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zurück zum letzten Schritt Dieser Softkey geht im aktuellen Prozess einen Schritt zurück. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Arbeitsfläche auswählen Dieser Softkey bestimmt die Antastrichtung und die Lage der Sicherheitsbewegungen für das Element. Sie können diesen mehrmals betätigen, um einen andere Messoberfläche zu wählen. Verfügbare Oberflächen sind: Oben, Links, Rechts, Vorne, Hinten und Schiefe. Wenn Schiefe ausgewählt ist, dann wird das Softkeysymbol zum Schiefensymbol. | Nullpunkt setzten Mit diesem Softkey wird ein neues Fenster mit neuen Softkeys angezeigt, um Arbeitsversätze in unterschiedlichen Situationen zu aktualisieren.
Wählen Sie einen Nullpunkt zum Aktualisieren Dieser Softkey wählt den benannten Arbeitsversatz aus der Versatzliste zur Aktualisierung aus. Die wiederholte Betätigung wählt den nächsten Arbeitsversatz aus der Liste aus. | Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben.
Wählen Sie einen Taster aus Wenn der Bildschirm Taster auswählen nicht bereits angezeigt wird, ruft dieser Softkey diesen Bildschirm auf. Wenn der Bildschirm Taster auswähle bereits angezeigt wird, können Sie mit diesem Softkey jeden Taster in der Taster-Liste auswählen. | Aktualisierung des Arbeitsversatzes bestätigen Dieser Softkey wird verfügbar, nachdem die Maschine die Elementposition erlernt hat. Es speichert den Befehl in der Messroutine.
Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. |

Lernvorgang

  1. Positionieren Sie den Taster in Prüfhöhe an der Seite des Zapfen und drücken Sie dann den Softkey Position lesen [image].

  2. Positionieren Sie den Taster in sichere Höhe über der Mitte der Nut und drücken Sie dann den Softkey Position lesen [image].

  3. Beachten Sie die Abbildung weiter unten.

    • Der Taster fährt zur Oberseite des Zapfens.

    • Die Drehachse dreht sich zur Position des Vorhaltewinkels.

    • Der Taster fährt zur Messhöhe.

    • Die Drehachse rotiert im Uhrzeigersinn bis der Taster ausgelöst wird. Die Drehachse stoppt den Drehvorgang. Der Taster fährt bis zur Vorhalteposition zurück.

    • Der Taster fährt zur Oberseite des Zapfens.

    • Die Drehachse dreht sich zur Position des Vorhaltewinkels.

    • Der Taster fährt zur Messhöhe.

    • Die Drehachse dreht sich daraufhin so lange entgegen dem Uhrzeigersinn (nach links), bis der Taster ausgelöst wurde. Die Drehachse stoppt den Drehvorgang. Der Taster fährt bis zur Vorhalteposition zurück.

    • Der Taster fährt zur Oberseite des Zapfens.

    • Die Drehachse dreht sich zurück auf die ursprüngliche Position.

    • Der mittlere Winkel der Nut wird mittels den zwei ausgelösten Drehachsen-Positionen berechnet.

Vorgang ausführen

Weitere Informationen finden Sie unter "Vorgang ausführen" im Abschnitt "Keilnut".


Nullpunkt aktualisieren

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Vorwärts so lange, bis der Softkey Arbeitsversatz aktualisieren eingeblendet wird.

  3. Drücken Sie den Softkey Arbeitsversatz aktualisieren [image], um das Fenster Arbeitsversatz aktualisieren aufzurufen:

Bereich "Elementliste"

  • X, Y, Z, A, C - Diese Listen für die Elementauswahl 'Achse' zeigen die Elemente in der Messroutine, die zur Definition des Arbeitsversatzes verwendet werden. Die Anzeige der Listen für die Elementauswahl 'Achse' hängt davon ab, wie Ihr System während der Konfiguration Ihres 'NC Gage'-Werkzeuges definiert wurde.

Bereich "Arbeitsversatz"

Gibt den Arbeitsversatzan, der zur Aktualisierung gewählt wurde. Verwenden Sie den Softkey Arbeitsversatz auswählen [image], um innerhalb der Liste von einem Eintrag zum nächsten Eintrag umzuschalten.

Bereich "Ausgewählte Elementdetails"

  • Werkstückwerte - Diese schreibgeschützten Felder zeigen die ausgewählte Elementposition bzw. den ausgewählten Elementwinkel (XYZAC) an. Diese Werte wurden bereits in das Werkstück-Koordinatensystem übertragen.

  • Maschinenwerte - Diese schreibgeschützten Felder zeigen die ausgewählte Elementposition bzw. den ausgewählten Elementwinkel (XYZAC) an. Diese Werte wurden bereits in das Koordinatensystem der Maschine übertragen.

  • Zielwerte - Diese Felder definieren die Zusatzversatzwerte für jede Achse, verwenden aber die Maschinenkoordinaten als standardmäßige Bezugswerte. Die Eingabe wird zum gemessenen Wert, der zur Einstellung des Arbeitsversatzes verwendet wird, hinzugefügt.

Kommentar

In dieses Feld können Sie einen Kommentar für den aktualisierten Arbeitsversatz eingeben.

Ausführliches Verfahren:

Mit diesem Bildschirm können Sie am Ende einer Messroutine automatisch oder nach der Überprüfung der Elemente den Arbeitsversatz manuell aktualisieren.

Dafür müssen Sie einen Befehl zum Aktualisieren des Arbeitsversatzes in eine NC Gage-Messroutine einfügen.

  1. Überprüfen Sie die Elemente, die für die Aktualisierung des Arbeitsversatzes durch NC Gage verwendet werden.

  2. Drücken Sie den Softkey Arbeitsversatz aktualisieren [image], um das Fenster Arbeitsversatz aktualisieren, wie weiter oben beschrieben, aufzurufen.

  3. Wählen Sie die Elemente für den Arbeitsversatz im Fenster Arbeitsversatz aktualisieren aus.

  4. Drücken Sie den Softkey Bestätigen [image], um den Befehl 'Arbeitsversatz aktualisieren' zur NC Gage-Messroutine hinzuzufügen. Drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren.

Sobald die Messroutine läuft, aktualisiert sie den Arbeitsversatz.

Erlernen des Arbeitsversatzes:

  1. Wählen Sie das Element aus jeder Achsenliste, das aktualisiert werden soll. Nicht alle Achsen müssen aktualisiert werden. Die 'Werte'-Felder werden aktualisiert, um die Position der ausgewählten Elemente anzuzeigen. Sobald das 'Werte'-Feld aktualisiert ist, wird das dazugehörige Versatz-Feld aktiviert.

  2. Wenn gewünscht, können Sie im Versatz-Feld einen Versatzabstand festlegen. Der Abstand kann sowohl positiv als auch negativ sein und stellt die Position des Elements nach der Aktualisierung des Arbeitsversatzes dar.

  3. Wählen Sie den Namen des Arbeitsversatzes aus der Liste aus, indem Sie den Softkey Wählen Sie einen zu aktualisierenden Arbeitsversatz aus [image] so lange drücken, bis der gewünschte Arbeitsversatz hervorgehoben wird. Parameter für jeden hervorgehobenen Arbeitsversatz werden entsprechend ihrer jeweiligen Auswahl im Fenster aktualisiert.

  4. Sobald die Messroutine bereits ausgeführt wurde, kann NC Gage den Arbeitsversatz sofort aktualisieren. Konfigurieren Sie das Fenster entsprechend und wählen Sie den Softkey Ausführen [image] aus. Damit wird der ausgewählte Arbeitsversatz aktualisiert und der Befehl wird nicht in der Messroutine gespeichert.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Wählen Sie einen Nullpunkt zum Aktualisieren Dieser Softkey wählt den benannten Arbeitsversatz aus der Versatzliste zur Aktualisierung aus. Die wiederholte Betätigung wählt den nächsten Arbeitsversatz aus der Liste aus. | Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet.
Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen. | Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben.
Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt. | Ausführen Dieser Softkey öffnet das Fenster Messroutine ausführen, wo Sie die Messroutine ausführen können.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. | Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.


Toleranzrahmen definieren

Home > Anwenden von PC-DMIS NC Gage > Erste Schritte > Schritt 7: Definieren von Toleranzrahmen

Schritt 7: Definieren von Toleranzrahmen

Rotationsachse verschieben

Der Befehl „Drehachse verschieben“ wird zur Positionierung einer oder mehrer Drehachsen verwendet. Dieser Befehl hat keinen eigenen Nullpunkt und muss somit keinen Nullpunkt erlernen.

Mehr:

Drehachse verschieben


Rotationsachse verschieben

Nur auf Maschinen, die über mehr als drei Achsen verfügen, wie beispielsweise Maschinen mit einem Drehtisch, wird ein "Rotationsachse verschieben"-Befehl eingesetzt. Im Wesentlichen positionieren Sie den Taster an eine sichere Positon und positionieren anschließend die Rotationsachsen an die für die Verschiebung erforderlichen Positonen.

Damit Ihrer Messroutine ein "Rotationsachse verschieben"-Befehl hinzugefügt werden kann, muss NC Gage entsprechend konfiguriert werden.

Wenn ein "Rotationsachse verschieben"-Befehl erstellt wird, wird die Position, an der sich der(ie) Drehtisch(e) befindet(en), wenn dieser "Rotationsachse verschieben"-Befehl aktiv ist, gesetzt. Sollte der Benutzer versuchen, einen neuen Befehl bei aktivem "Rotationsachse verschieben"-Befehl zu lernen, und wenn sich die Tische nicht an der korrekten Position befinden, dann wird eine Warnmeldung eingeblendet und der Benutzer ist daraufhin so lange nicht mehr befugt, das Element zu lernen, bis sich der(ie) Drehtisch(e) an der(n) durch den "Rotationsachse verschieben"-Befehl bestimmten Position(en) befindet(en).

Jetzt wird beim Lernen eines neuen Befehls, um sicher zu stellen, dass die Tische sich nicht von den durch den "Rotationsachse verschieben"-Befehl definierten Positionen wegbewegt haben, von NC Gage eine Kontrollfunktion eingesetzt. Wenn sich die Tische verschoben haben, wird eine Warnmeldung eingeblendet und das Element kann so lange nicht gelernt werden, bis die Tischpositionen mit dem aktuellen "Rotationsachse verschieben"-Befehl übereinstimmen.

Die Meldung lautet:

Warnmeldung: Die aktuelle(n) Drehtischposition(en) stimmt(stimmen) nicht mit der aktuellen Rotationsachsenposition überein; bitte korrigieren Sie dies, bevor Sie fortfahren.

  1. Befolgen Sie die Anweisungen zum Einstellen eines Arbeitsversatzes.

  2. Nachdem der Arbeitsversatz definiert wurde, ändert sich der Softkey Einen Arbeitsversatz auswählen [image] und heißt nun Rotationsachse verschieben [image]. Wählen Sie den Softkey Rotationsachse verschieben [image] aus der Navigationsleiste des Hauptfensters aus. Das Fenster Rotationsachse verschieben wird eingeblendet:

  3. Geben Sie die Angaben für 'Schwenkposition' (Sicherheitsposition) und 'Rotation' in die entsprechenden Bereiche ein.

  4. Wählen Sie die Richtung der primären Achse im Bereich Primäre Richtung aus.

  5. Folgen Sie den Anweisungen auf dem Bildschirm, um die Parameter für den "Rotationsachse verschieben"-Befehl zu definieren.

Bereich "Schwenkposition"

  • Punkt X,Y,Z speichern - Bestimmt die Nullpunkt- bzw. sichere X-, Y- und Z-Koordinatenposition, an der sich der Taster vor der Ausführung der Messroutine befindet. Der Taster kehrt vor jeder Ausführung der Messroutine zu dieser Position zurück.

Bereich "Rotation"

  • Rotation A, C - Zeigt die gelernten Werte (in Grad) für jede der Systemachsen an.

Bereich "Primäre Richtung"

  • X+, Y+, Z+, X-, Y-, Z- - Definiert die primäre Richtung der Primärachse.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zum vorherigen Schritt zurückkehren Dieser Softkey löscht die zuletzt erlernten Tasterpositionen. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.


Sicherheitspfade definieren

Home > Anwenden von PC-DMIS NC Gage > Erste Schritte > Schritt 8: Definieren eines Sicherheitspfades

Schritt 8: Definieren eines Sicherheitspfades

Sicherheitspfade erlauben Ihnen einen Abstand über der gewünschten Ebene oder Zylinder zu bestimmen, in dem sich der Taster sicher bewegen kann, ohne dabei das Werkstück oder andere Hindernisse zu berühren.

Weitere Informationen zur Definition von Sicherheitspfaden finden Sie unter "Sicherheitsebene" im Abschnitt "Bewegungsbefehle einfügen".

Wenn Sie Ihre Sicherheitspfade definiert haben, können Sie damit anfangen, zu messende Elemente in Ihre Messroutine einzufügen. Siehe auch "Erstellen von Elementbefehlen".


Erstellen von Elementbefehlen

In NC-Gage gibt es zwei Verfahren zur Erstellung von Elementbefehlen und dem Hinzufügen dieser Befehle zur Messroutine, damit NC-Gage während der Ausführung messen kann.

Erstellen von Elementbefehlen durch Eingabe von Parameterwerten

Damit Sie Elementbefehle durch Eingabe von Parametern erstellen können, rufen Sie einfach das Fenster für den entsprechenden Elementbefehl auf, wählen das Kontrollkästchen Lernen mit Hilfe der Werte auf dem Bildschirm aus, geben alle Parameter und Eigenschaften ein und berühren dann den Softkey Lernen und Erstellen eines Befehls. NC-Gage fügt den Elementbefehl, so, wie Sie ihn definiert haben, in die Messroutine ein.

Erstellen von Elementbefehlen durch Lernen eines Elements

Bei der Erstellung von Elementbefehlen ist "Lernen" der Standardmodus, wenn du einen Elementbefehlbildschirm aufrufst. Sie müssen den Taster manuell bewegen und mit den Tasterlernpositionen auf dem Werkstück laut der Bildschirmanweisungen ein Element erlernen. NC Gage wird die Tasterposition interpretieren und automatisch die Parameter auf dem Elementbefehlbildschirm mit Informationen von Ihrer erlernten Position füllen. NC Gage erlaubt dem Benutzer dann den Elementbefehl nach diesem "Lernprozess" in die Messroutine einzufügen.

Hinweis: Der Taster muss vor dem Hinzufügen von Bewegungsbefehlen kalibriert worden sein (siehe auch "Kalibrierung").

Sie können den folgenden Befehl der Messroutine hinzufügen.

Gemessene Elemente

  • Punkt

  • Kreis (Bohrung)

  • Kreis (Zapfen)

  • Kreis (Schaft)

  • Steg

  • Tasche

  • Ecke (Innen)

  • Ecke (Außen)

  • Ebene

  • Gerade

  • Zylinder (Bohrung)

  • Zylinder (Ausstülpung)

  • Kegel (Innen)

  • Kegel (Außen)

  • Kugel

  • Nut

  • Keilnut

  • Fläche

Abhängige Elemente

  • Konstruierter Punkt

  • Linie konstruieren

  • Konstruierter Kreis

Merkmale

  • (Zwischen-)Winkel

  • Merkmal Abstand

Konzentrizität

  • Konzentrizität

Zusätzliche Funktionen

  • Nullpunkt aktualisieren

  • Koordinatenrotation einstellen

Softkeys

Durch das Berühren einer dieser Softkeys der Navigationsleiste können Sie das Elementfenster aufgerufen.

Softkeys für eine Drehachsen-Werkzeugmaschine

Softkeys für eine Fräs-Dreh-Werkzeugmaschine

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Punkt messen Dieser Softkey öffnet das Fenster Punkt messen . | Bohrung messen Dieser Softkey öffnet das Fenster Bohrung messen.
Ausstülpung messen Dieser Softkey öffnet das Fenster Ausstülpung messen. | Steg messen Dieser Softkey öffnet das Fenster Steg messen.
Tasche messen Dieser Softkey öffnet das Fenster Tasche messen. | Ecke außen messen Dieser Softkey öffnet das Fenster Ecke außen.
Ecke innen messen Dieser Softkey öffnet das Fenster Ecke innen. | Ebene messen Dieser Softkey öffnet das Fenster Ebene messen.
Messen Linie Dieser Softkey öffnet das Fenster Gerade messen. | Zylinder-Bohrung messen Dieser Softkey öffnet das Fenster Zylinder-Bohrung messen.
Zylinder-Ausstülpung messen Dieser Softkey öffnet das Fenster Zylinder-Ausstülpung messen. | Kegel Innen messen Dieser Softkey öffnet das Fenster Kegel (Innen) messen auf.
Kegel Außen messen Dieser Softkey öffnet das Fenster Kegel (Außen) messen. | Kugel messen Dieser Softkey öffnet das Fenster Kugel messen.
Einen Punkt konstruieren Dieser Softkey öffnet das Fenster Punkt erstellen, mit dem Sie ein Schnittpunkt-, Projektionspunkt- oder Mittelpunktelement aus zwei Geradenelemenen erzeugen können. | Linie konstruieren Dieser Softkey öffnet das Fenster Gerade erstellen.
Einen Kreis konstruieren Dieser Softkey öffnet das Fenster Kreis erstellen. | (Zwischen-)Winkel Dieser Softkey öffnet das Fenster Zwischenwinkel, mit dem der Winkel zwischen zwei Elementen bestimmt werden kann.
Abstand Dieser Softkey öffnet das Fenster Abstand, mit dem der Abstand zwischen zwei Elementen bestimmt werden kann. | Nullpunkt aktualisieren Dieser Softkey öffnet das Fenster Arbeitsversatz aktualisieren, über den Sie den Arbeitsversatz am Ende einer Messroutine aktualisieren können.
Variable schreiben Über diesen Softkey wird das Fenster Variable schreiben aufgerufen und Sie haben die Möglichkeit, Messdaten in eine Makro-Variable auf der NC-Steuereinheit zu schreiben. | Werkzeuglänge festlegen Die Werkzeuglänge kann auf zwei Arten aktualisiert werden: Werkzeuglänge aktualisieren - Sofort Wird als Setup-Befehl in einem einzigen Arbeitsgang zur Definition der Werkzeuglänge verwendet. Es handelt sich hierbei um eine unabhängige Einstellung, die nicht Teil einer Messroutine ist und dort auch nicht erscheint. Werkzeuglänge setzen - Messroutine-Steuerelement Wird zur Definition der Werkzeuglänge, die Teil einer Messroutine-Steuerung ist, verwendet.
Koordinatensystem-Rotation setzen Mit diesem Softkey wird das Fenster Koordinatensystem-Rotation setzen aufgerufen und Sie können die Rotation des Koordinatensystems verändern, wenn die Maschine nicht mit NC Gage verwendet wird. | Konzentrizität Mit diesem Softkey wird das Fenster Konzentrizität aufgerufen und Sie können die Konzentrizität von einem Element zum anderen berechnen.
Schaft messen Dieser Softkey öffnet das Fenster Kreis messen (Schaft). | Nut Dieser Softkey öffnet das Fenster Nut messen.
Keilnut Dieser Softkey öffnet das Fenster Keilnut messen. | Fläche Dieser Softkey öffnet das Fenster Fläche messen.
Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.

Allgemeine Eigenschaften:

  • Toleranz


Punkt

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie im Fenster Messen den Softkey Punkt [image], um das Fenster Punkt messen aufzurufen:

  3. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, grafisch angezeigt.

Bereich "Eigenschaften" (nur aktiviert, wenn die Option "Abgeschrägte Arbeitsfläche" ausgewählt ist)

  • Winkel auf X - Definiert den Vektorwinkel in der X-Richtung des Punktes. Hierbei handelt es sich um den Oberflächennormalenvektor des Punktes im Verhältnis zur primären Achse, in der er gemessen wird. Die Primärachse ist X in der XY-Arbeitsfläche, Y in der YZ-Arbeitsfläche und Z in der ZX-Arbeitsfläche. Der zulässige Bereich liegt zwischen 0 (Null) und -360 Grad.

  • Winkel auf Z - Definiert den ersten Vektorwinkel in der Z-Richtung des Punktes. Hierbei handelt es sich um den Oberflächennormalenvektor des Punktes im Verhältnis zur Arbeitsfläche. Der zulässige Bereich liegt zwischen -90 und +90 Grad.

Bereich "Bewegungsparameter"

  • Vorhalteabstand - Definiert den Abstand weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchabstand Definiert den Suchabstand bei der Suche und beim Lernen eines Elements. (Nicht verfügbar, wenn die im Bereich "Optionale Einstellungen" beschriebene Option Lernen unter Verwendung von Werten auf dem Bildschirm ausgewählt ist.)

Bereich "Optionale Einstellungen"

  • Messpunkt Sicherh.-Ebene - Durch Auswahl dieser Option wird der Taster veranlasst, zwischen jedem Elementmesspunkt zu einer Sicherheitsebene zu fahren. Mit dem Bearbeitungsfeld auf der rechten Seite hat der Benutzer die Möglichkeit, den Abstand zur Ebene einzugeben. Diese Ebene ist nicht die Sicherheitsebene der Messroutine. Detaillierte Informationen finden Sie unter Messpunkt Sicherheitsebene.

  • Lernen, dann messen - Durch Auswahl dieser Option wird die Maschine veranlasst, die Position des Werkstückes unter Verwendung standardmäßiger Parameter zu erlernen und dann das Element mit den im Fenster gesetzten Eigenschaften sofort neu zu messen. Wird dazu verwendet, alle eingestellten Parameter zu testen, wodurch eine genauere und verlässlichere 'Erstmusterprüfung' gewährleistet wird.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Hierdurch hat der Benutzer die Möglichkeit, die theoretischen Werte des Elements einzugeben und das Element vom Programm an dieser Position messen zu lassen. (Deaktiviert die Option Suchabstand im Bereich Bewegungsparameter, sofern dieser ausgewählt ist.)

Bereich "Punktposition"

  • Nennwert (XYZ-Nennwert) - Definiert die theoretische Position des Punktes.

  • Messwert (XYZ-Messwert) - Blendet die gemessene Position des Punktes ein.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Arbeitsfläche auswählen Dieser Softkey bestimmt die Antastrichtung und die Lage der Sicherheitsbewegungen für das Element. Sie können diesen mehrmals betätigen, um einen andere Messoberfläche zu wählen. Verfügbare Oberflächen sind: Oben, Links, Rechts, Vorne, Hinten und Schiefe. Wenn Schiefe ausgewählt ist, dann wird das Softkeysymbol zum Schiefensymbol. | Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet.
Zum vorherigen Schritt zurückkehren Dieser Softkey löscht die zuletzt erlernten Tasterpositionen. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Lernen und Erstellen eines Befehls (Ausführen) Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Bewegungspunkt einfügen Dieser Softkey liest die aktuelle Position des Tasters und fügt eine Sicherheitsbewegung in die Messroutine ein.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. |

Verfahren zum Lernen eines Punktes mit einer Arbeitsfläche, die als 'normal' definiert ist:

  1. Drücken Sie den Softkey Messöberfläche auswählen [image], um die Arbeitsfläche für den Punkt auszuwählen (Oben, Links, Rechts, Vorne, Hinten oder Schiefe).

  2. Positionieren Sie den Taster über die Fläche, an der Sie das Punktelement messen möchten.

  3. Drücken Sie den Softkey Position lesen [image] . Die Tastspitzenposition wird als Startposition eingelesen. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image] , um diese Messposition abzubrechen.

  4. Drücken Sie den Softkey Lernen und Erstellen eines Befehls [image]. NC Gage nimmt Messpunkte auf die gleiche Weise, wie weiter unten dargestellt, automatisch auf.

    Position A gibt an, an welcher Stelle der Taster positioniert werden soll. Die rote Linie stellt den Messweg dar. Position 1 gibt die gemessene Punktposition an.

  5. Nachdem das Element gemessen wurde, werden die gemessenen Werte aktualisiert. Drücken Sie den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image] , um den Elementbefehl der Messroutine hinzuzufügen.

Verfahren zum Lernen eines Punktes mit einer abgeschrägten Arbeitsfläche, die als 'normal' definiert ist:

  1. Drücken Sie den Softkey Messöberfläche auswählen [image], um die Arbeitsfläche für den Punkt auszuwählen (Oben, Links, Rechts, Vorne, Hinten oder Schiefe). Drücken Sie zur Auswahl der Option "Schiefe" so lange auf den Softkey Messoberfläche auswählen, bis das Symbol zum Symbol "Schiefe" [image] geworden ist.

  2. Positionieren Sie den Taster über die Fläche, an der Sie das Punktelement messen möchten.

  3. Drücken Sie den Softkey Position lesen [image] . Die Tastspitzenposition wird als Startposition eingelesen. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image] , um diese Messposition abzubrechen.

  4. Positionieren Sie den Taster weg von der Messpunktposition in Richtung der Oberfläche.

  5. Drücken Sie den Softkey Position lesen [image] .

  6. Drücken Sie den Softkey Lernen und Erstellen eines Befehls [image].

  7. Nachdem das Element gemessen wurde, werden die gemessenen Werte aktualisiert. Drücken Sie den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image] , um den Elementbefehl der Messroutine hinzuzufügen.

Nachfolgend handelt es sich um den 'NC-Gage'-spezifischen Elementpfad und logischen Aufbau in NC Gage:

Elementpfad Punkt lernen

  • Aktuelle Position lesen.

  • Messen Sie in Richtung aktueller Arbeitsfläche; Suchabstand ist dreifacher Vorhalteabstand.

  • Zurückziehen zur Leseposition.

Elementpfad Punkt ausführen

  • Wenn die aktuelle Position unterhalb der Sicherheitsebenenhöhe liegt, dann fahren Sie hoch zur Sicherheitsebene.

  • Fahren Sie zur Position über dem Punkt.

  • Fahren Sie runter zu einer Position über dem Punkt, der den Vorhalteabstand und Tasterradius der theoretischen Fläche darstellt.

  • Punkt messen, Ziel ist Vorhalteabstand unter Fläche.

  • Fahren Sie nach der Messung auf Sicherheitsebenenhöhe.


Kreis (Bohrung)

Home > Anwenden von PC-DMIS NC Gage > Erstellen von Elementbefehlen > Kreis (Bohrung)

Kreis Messen (Bohrung)

So erstellen Sie einen Befehl Kreis (Bohrung):

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Kreis (Bohrung) [image], um das Fenster Kreis messen (Bohrung) aufzurufen:

  3. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, grafisch angezeigt.

Bereich "Eigenschaften"

  • Anzahl der Punkte - Definiert die Anzahl der Punkte, die während der Ausführung (nicht während des Lernmodus) für den Kreis aufgenommen werden.

  • Startwinkel - Definiert den Startpunkt für einen zu messenden Kreisabschnitt. Drehung beginnt bei 0 entlang der primären Achse und wächst, so dass die Nebenachse auf 90 steht. Die Primärachse ist X in der XY-Arbeitsfläche, Y in der YZ-Arbeitsfläche und Z in der ZX-Arbeitsfläche. Die Sekundärachse ist Y in der XY-Arbeitsfläche, Z in der YZ-Arbeitsfläche und X in der ZX-Arbeitsfläche.

  • Endwinkel - Definiert das Ende der Kreissektion, die gemessen wird. Die Start- und Endwinkel werden nur dann verwendet, wenn das Element im Ausführmodus gemessen wird. Im Lernmodus werden Messpunkte automatisch in gegenüberliegenden Primär- und Sekundärachsrichtungen aufgenommen. Wenn der Kreis nicht die ganzen 360 Grad beschreibt, kann über die Option Lernen mit Hilfe der Werte auf dem Bildschirm die theoretische Position mit einem genau definierten Start- und Endwinkel eingegeben werden. NC Gage misst das Element daraufhin bei ausgewählter Option Lernen, dann messen.

  • Messhöhe - Dieser Wert definiert die richtungsweisende Höhe (relativ zum nominalen Tastervektor) der Messungen relativ zu den nominalen XYZ-Parametern. Der Wert „0“ bedeutet, dass das Element an der Position des XYZ-Punktes gemessen werden würde, der im Parameter-Gruppenfeld angegeben ist. Negative Angaben bestimmen, wie weit unter dem nominalen XYZ die Bohrung gemessen werden sollte. Positive Werte definieren, wie weit über dem nominalen XYZ die Messung erfolgen sollte.

Hinweis: Die Anzahl der Reihen und Punkte pro Reihe werden entlang des definierten Kreises gleichmäßig verteilt.

Bereich "Antast-Parameter"

  • Vorhalteabstand - Definiert den Abstand weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchabstand - Definiert die Entfernung, die der Taster zurücklegt, während er im Lernmodus die Fläche sucht. (Nicht verfügbar, wenn die im Bereich Optionale Einstellungen beschriebene Option Lernen unter Verwendung von Werten auf dem Bildschirm ausgewählt ist.)

Bereich "Optionale Einstellungen"

  • Messpunkt Sicherh.-Ebene - Durch Auswahl dieser Option wird der Taster veranlasst, zwischen jedem Elementmesspunkt zu einer Sicherheitsebene zu fahren. Geben Sie in der rechten Box den Abstand zur Ebene ein. Diese Ebene ist nicht die Sicherheitsebene der Messroutine. Detaillierte Informationen finden Sie unter "Messpunkt Sicherheitsebene".

  • Lernen, dann messen - Durch Auswahl dieser Option wird die Maschine veranlasst, die Position des Werkstückes unter Verwendung standardmäßiger Parameter zu erlernen und dann das Element mit den im Fenster gesetzten Eigenschaften sofort neu zu messen. Sie wird dazu verwendet, alle eingestellten Parameter zu testen, wodurch eine genauere und verlässlichere 'Erstmusterprüfung' gewährleistet wird.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Hierdurch hat der Benutzer die Möglichkeit, die theoretischen Werte des Elements einzugeben und das Element vom Programm an dieser Position messen zu lassen. (Deaktiviert die Option Suchabstand im Bereich Bewegungsparameter, sofern dieser ausgewählt ist.)

Bereich "Parameter"

  • XYZD-Nennwert - Definiert die theoretische Position der Kreisbohrung.

  • XYZD-Messwert - Zeigt die gemessene Position der Kreisbohrung an.

Bereich "3-Achsen-Protokollierung"

Die 3-Achsen Protokollierung kann auf 3 Arten zur Definition des XYZ-Punktes verwendet werden.

  • Auswahl eines gemessenen Punktes oder einer Ebene, um die Höhe des gemessenen Elementes zu definieren.

  • Geben Sie die zu verwendende, richtungsabhängige Ebenenhöhe ein. Diese Höhe ist relativ zum Werkstücknullpunkt und wird entlang des Tastervektors gemessen.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zum vorherigen Schritt zurückkehren Dieser Softkey löscht die zuletzt erlernten Tasterpositionen. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Lernen und Erstellen eines Befehls (Ausführen) Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Bewegungspunkt einfügen Dieser Softkey liest die aktuelle Position des Tasters und fügt eine Sicherheitsbewegung in die Messroutine ein.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.

Lernvorgang

  1. Positionieren Sie den Taster in die Mitte der Bohrung und drücken Sie den Softkey Position lesen [image]. Diese Position wird dann zur Höhenposition für alle Messpunkte. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image] , um diese Messposition abzubrechen.

  2. Positionieren Sie den Taster für die automatische Messung und drücken Sie den Softkey Lernen und Erstellen eines Befehls [image]. NC Gage nimmt in jeder positiven und negativen Richtung der Primär- und Sekundärachsen vier Messpunkte auf.

    Bild mit Angabe der manuellen Startposition, auf die der Taster gerückt wird (A) und die automatischen Antastpfade (rote Linien), die von NC-Gage bei der Messung von vier Punkten (Positionen 1-4) genommen wurden.

  • Sollte es zu einer Kollision kommen, wird der Vorgang angehalten und eine Fehlermeldung eingeblendet.

  • Wenn der Taster die Bohrung verfehlt, ändern Sie den Suchabstand und versuchen es nochmals.

  3. Nachdem das Element gemessen wurde, werden die gemessenen Werte aktualisiert.

  4. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird der Messroutine hinzugefügt.

'NC-Gage'-spezifischer Elementpfad und dessen logischer Aufbau

Nachfolgend handelt es sich um den 'NC-Gage'-spezifischen Elementpfad und logischen Aufbau:

Elementpfad Bohrung lernen

  • Lesen Sie die Tasterposition in der Mitte der Bohrung.

  • Messungen der Bohrung erfolgen am Z-Wert des Lesepunktes.

  • Schätzen Sie die XY-Mitte der Bohrung, deren Position gelesen werden soll.

  • Messen Sie den Punkt in '+X'-Richtung unter Verwendung des Suchabstandes.

  • Kehren Sie zur Mittenposition zurück.

  • Messen Sie den Punkt in '-X'-Richtung unter Verwendung des Suchabstandes.

  • Kehren Sie zur Mittenposition zurück.

  • Messen Sie den Punkt in '+Y'-Richtung unter Verwendung des Suchabstandes.

  • Kehren Sie zur Mittenposition zurück.

  • Messen Sie den Punkt in '-Y'-Richtung unter Verwendung des Suchabstandes.

  • Kehren Sie zur Mittenposition zurück.

Elementpfad Bohrung ausführen

  • Vorhalteradius definieren = Radius der Bohrung - Vorhalteabstand - Tasterradius.

  • Zielradius definieren = Radius der Bohrung + Vorhalteabstand - Tasterradius.

  • Wenn die aktuelle Position unterhalb der Sicherheitsebenenhöhe liegt, dann fahren Sie hoch zur Sicherheitsebene.

  • Fahren Sie zur Position über dem ersten Punkt des Vorhaltebereichs. Dieser Punkt liegt um die Länge des Vorhalteradius in Richtung des Startwinkels von der Mitte der Bohrung entfernt.

  • Absenken bis zur Messebene.

  • Punkt messen; Ziel ist Zielradius vom Mittelpunkt der Bohrung entlang des Winkels.

  • Zurückziehen und zum Vorhaltebereich des nächsten Punktes fahren.

  • Punkt messen; Ziel ist Zielradius vom Mittelpunkt der Bohrung entlang des Winkels.

  • Fahren Sie mit der Messung der angegebenen Anzahl von Punkten vom Startwinkel bis zum Endwinkel fort.

  • Wenn die lokale Sicherheitsebene aktiviert ist, fahren Sie zwischen jedem Punkt zur lokalen Sicherheitsebene, um zum nächsten Punkt des Vorhaltebereichs zu gelangen.

  • Nachdem der letzte Punkt gemessen ist, wird der Taster zur Sicherheitsebenenhöhe hochgefahren.


Kreis (Zapfen)

Home > Anwenden von PC-DMIS NC Gage > Erstellen von Elementbefehlen > Kreis (Zapfen)

Kreis messen (Zapfen)

So erstellen Sie einen Befehl für einen Kreis (Ausstülpung):

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Kreis (Zapfen) [image], um das Fenster Kreis messen (Zapfen) aufzurufen:

  3. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, grafisch angezeigt.

Bereich "Eigenschaften"

  • Anzahl der Punkte - Definiert die Anzahl der Punkte, die während der Ausführung (nicht während des Lernmodus) für den Kreis aufgenommen werden.

  • Startwinkel - Definiert den Startpunkt für einen zu messenden Kreisabschnitt. Drehung beginnt bei 0 entlang der primären Achse und wächst, so dass die Nebenachse auf 90 steht. Die Primärachse ist X in der XY-Arbeitsfläche, Y in der YZ-Arbeitsfläche und Z in der ZX-Arbeitsfläche. Die Sekundärachse ist Y in der XY-Arbeitsfläche, Z in der YZ-Arbeitsfläche und X in der ZX-Arbeitsfläche.

  • Endwinkel - Definiert das Ende der Kreissektion, die gemessen wird. Die Start- und Endwinkel werden nur dann verwendet, wenn das Element im Ausführmodus gemessen wird. Im Lernmodus werden Messpunkte automatisch in gegenüberliegenden Primär- und Sekundärachsrichtungen aufgenommen. Wenn der Kreis nicht die ganzen 360 Grad beschreibt, kann über die Option Lernen mit Hilfe der Werte auf dem Bildschirm die theoretische Position mit einem genau definierten Start- und Endwinkel eingegeben werden. NC Gage misst das Element daraufhin bei ausgewählter Option Lernen, dann messen.

Hinweis: Die Anzahl der Reihen und Punkte pro Reihe werden entlang des definierten Kreises gleichmäßig verteilt.

Bereich "Antast-Parameter"

  • Vorhalteabstand - Definiert den Abstand weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchabstand - Definiert die Entfernung, die der Taster zurücklegt, während er im Lernmodus die Fläche sucht. (Nicht verfügbar, wenn die im Bereich Optionale Einstellungen beschriebene Option Lernen unter Verwendung von Werten auf dem Bildschirm ausgewählt ist.)

Bereich "Optionale Einstellungen"

  • Messpunkt Sicherh.-Ebene - Durch Auswahl dieser Option wird der Taster veranlasst, zwischen jedem Elementmesspunkt zu einer Sicherheitsebene zu fahren. Mit dem Bearbeitungsfeld auf der rechten Seite hat der Benutzer die Möglichkeit, den Abstand zur Ebene einzugeben. Diese Ebene ist nicht die Sicherheitsebene der Messroutine. Detaillierte Informationen finden Sie unter Messpunkt Sicherheitsebene.

  • Lernen, dann messen - Durch Auswahl dieser Option wird die Maschine veranlasst, die Position des Werkstückes unter Verwendung standardmäßiger Parameter zu erlernen und dann das Element mit den im Fenster gesetzten Eigenschaften sofort neu zu messen. Wird dazu verwendet, alle eingestellten Parameter zu testen, wodurch eine genauere und verlässlichere 'Erstmusterprüfung' gewährleistet wird.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Hierdurch hat der Benutzer die Möglichkeit, die theoretischen Werte des Elements einzugeben und das Element vom Programm an dieser Position messen zu lassen. (Deaktiviert die Option Suchabstand im Bereich Bewegungsparameter, sofern dieser ausgewählt ist.)

Bereich "Parameter"

  • XYZD-Nennwert - Definiert die theoretische Position der KreisZapfen.

  • XYZD-Messwert - Zeigt die gemessene Position des Kreiszapfens an.

Bereich "3-Achsen-Protokollierung"

Es gibt drei Verfahren für die Bestimmung des XYZ-Punktes mit Hilfe der 3-Achsen-Protokollierung.

  • Auswahl eines gemessenen Punktes oder einer Ebene, um die Höhe des gemessenen Elementes zu definieren.

  • Geben Sie die zu verwendende, richtungsabhängige Ebenenhöhe ein. Diese Höhe ist relativ zum Werkstücknullpunkt und wird entlang des Tastervektors gemessen.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zum vorherigen Schritt zurückkehren Dieser Softkey löscht die zuletzt erlernten Tasterpositionen. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Lernen und Erstellen eines Befehls (Ausführen) Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Bewegungspunkt einfügen Dieser Softkey liest die aktuelle Position des Tasters und fügt eine Sicherheitsbewegung in die Messroutine ein.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.

Lernvorgang

  1. Positionieren Sie den Taster in die Nähe der Fläche auf der Seite der Ausstülpung und drücken Sie den Softkey Position lesen [image]. Diese Position wird dann zur Höhenposition für alle Messpunkte. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image] , um diese Messposition abzubrechen.

  2. Positionieren Sie den Taster über die Mitte der Ausstülpung und drücken Sie den Softkey Position lesen [image]. Dieser Wert wird zur Bestimmung der Ausstülpungsmitte verwendet. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image] , um diese Messposition abzubrechen.

  3. Positionieren Sie den Taster für die automatische Messung und drücken Sie den Softkey Lernen und Erstellen eines Befehls [image]. NC Gage nimmt einen Messpunkt unterhalb dieser Position auf, um die Höhe der Ausstülpung zu bestimmen. Anschließend werden Messpunkte in ähnlicher Weise, wie weiter unten veranschaulicht, dargestellt.

    Bild mit Angabe der manuellen Positionen, auf die der Taster gerückt wird (A-B) und die automatischen Antastpfade (rote Linien), die von NC-Gage bei der Messung von vier Punkten (Positionen 1-4) genommen wurden.

  4. Nachdem das Element gemessen wurde, werden die gemessenen Werte aktualisiert. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird der Messroutine hinzugefügt. Drücken Sie den Softkey Zurückkehren [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Nachfolgend handelt es sich um den 'NC-Gage'-spezifischen Elementpfad und logischen Aufbau in NC Gage:

Elementpfad der Ausstülpung lernen

  • Tasterposition neben der Seite der Ausstülpung lesen; Z-Wert wird zur Messhöhe.

  • Tasterposition über dem Mittelpunkt der Ausstülpung lesen; XY-Werte definieren Mitte; Z-Wert liegt in sicherer Höhe.

  • Vorhalteradius = projizierter 2D-Abstand zwischen zwei Punkten 'Position lesen'.

  • Auf sichere Höhe fahren.

  • Auf sichere Höhe zu einem Punkt über Vorhaltepunkt 1, der den Vorhalteradius von der Mitte in +X darstellt, fahren.

  • Absenken bis auf Messhöhe.

  • Punkt messen, Ziel ist Mitte an Messhöhe.

  • Auf sichere Höhe fahren.

  • Auf sichere Höhe zu einem Punkt über Vorhaltepunkt 2, der den Vorhalteradius von der Mitte in -X darstellt, fahren.

  • Absenken bis auf Messhöhe.

  • Punkt messen, Ziel ist Mitte an Messhöhe.

  • Auf sichere Höhe fahren.

  • In sicherer Höhe zu einem Punkt über Vorhaltepunkt 3, der den Vorhalteradius von der Mitte in +Y darstellt, fahren.

  • Absenken bis auf Messhöhe.

  • Punkt messen, Ziel ist Mitte an Messhöhe.

  • Auf sichere Höhe fahren.

  • Auf sichere Höhe zu einem Punkt über Vorhaltepunkt 4, der den Vorhalteradius von der Mitte in -Y darstellt, fahren.

  • Absenken bis auf Messhöhe.

  • Punkt messen, Ziel ist Mitte an Messhöhe.

  • Auf sichere Höhe fahren.

Elementpfad der Ausstülpung ausführen

  • Vorhalteradius definieren = Radius der Ausstülpung + Vorhalteabstand + Tasterradius.

  • Zielradius definieren = Radius der Ausstülpung - Vorhalteabstand - Tasterradius, wenn dieser < 0 ist, dann auf 0 setzen.

  • Wenn die aktuelle Position unterhalb der Sicherheitsebenenhöhe liegt, dann fahren Sie hoch zur Sicherheitsebene.

  • Fahren Sie zur Position über dem ersten Punkt des Vorhaltebereichs. Dieser Punkt liegt um die Länge des Vorhalteradius in Richtung des Startwinkels von der Mitte der Ausstülpung entfernt.

  • Absenken bis zur Messebene.

  • Punkt messen, Ziel ist Zielradius des Mittelpunkts der Ausstülpung entlang des Winkels.

  • Zurückziehen und zum Vorhaltebereich des nächsten Punktes fahren. Nehmen Sie, falls erforderlich, eine oder mehrere kleinere Bewegungen vor, um den Kontakt mit der Ausstülpung zu vermeiden.

  • Punkt messen, Ziel ist Zielradius des Mittelpunkts der Ausstülpung entlang des Winkels.

  • Fahren Sie mit der Messung der angegebenen Anzahl von Punkten vom Startwinkel bis zum Endwinkel fort.

  • Wenn die lokale Sicherheitsebene aktiviert ist, fahren Sie zwischen jedem Punkt zur lokalen Sicherheitsebene, um zum nächsten Punkt des Vorhaltebereichs zu gelangen.

  • Nachdem der letzte Punkt gemessen ist, wird der Taster zur Sicherheitsebenenhöhe hochgefahren.


Kreis (Schaft)

Home > Anwenden von PC-DMIS NC Gage > Erstellen von Elementbefehlen > Kreis (Schaft)

Kreis messen (Schaft)

So erstellen Sie einen Schaftbefehl:

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Kreis (Schaft) [image], um das Fenster Kreis messen (Schaft) aufzurufen:

  3. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, grafisch angezeigt.

Bereich "Eigenschaften"

  • Anzahl der Punkte - Definiert die Anzahl der Punkte, die während der Ausführung (nicht während des Lernmodus) für den Kreis aufgenommen werden.

  • Startwinkel - Definiert den Startpunkt für einen zu messenden Kreisabschnitt. Drehung beginnt bei 0 entlang der primären Achse und wächst, so dass die Nebenachse auf 90 steht. Die Primärachse ist X in der XY-Arbeitsfläche, Y in der YZ-Arbeitsfläche und Z in der ZX-Arbeitsfläche. Die Sekundärachse ist Y in der XY-Arbeitsfläche, Z in der YZ-Arbeitsfläche und X in der ZX-Arbeitsfläche.

  • Eingeschlossener Winkel - Definiert den Bereich für den Messvorgang mit Rotation. Die Start- und Endwinkel werden nur dann verwendet, wenn das Element im Ausführmodus gemessen wird. Im Lernmodus werden Messpunkte automatisch in gegenüberliegenden Primär- und Sekundärachsrichtungen aufgenommen. Wenn der Kreis nicht die ganzen 360 Grad beschreibt, kann über die Option Lernen mit Hilfe der Werte auf dem Bildschirm die theoretische Position mit einem genau definierten Start- und Endwinkel eingegeben werden. NC Gage misst das Element daraufhin bei ausgewählter Option Lernen, dann messen.

Hinweis: Die Anzahl der Punkte pro Reihe werden entlang des definierten Kreises gleichmäßig verteilt.

  • Schaftrotation - Wählen Sie die Option Ja, um den Schaft durch Drehung der C-Achse zu messen. Wählen Sie ansonsten die Option Nein aus.

Hinweis: Die Evaluierung des Rundlaufes für den Schaft ist nur möglich, wenn die C-Achse gedreht wird.

Bereich "Antast-Parameter"

  • Vorhalteabstand - Definiert den Abstand weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchabstand - Definiert die Entfernung, die der Taster zurücklegt, während er im Lernmodus die Fläche sucht. (Nicht verfügbar, wenn die im Bereich "Optionale Einstellungen" beschriebene Option Lernen unter Verwendung von Werten auf dem Bildschirm ausgewählt ist.)

Bereich "Optionale Einstellungen"

  • Messpunkt Sicherh.-Ebene - Durch Auswahl dieser Option wird der Taster veranlasst, zwischen jedem Elementmesspunkt zu einer Sicherheitsebene zu fahren. Mit dem Bearbeitungsfeld auf der rechten Seite hat der Benutzer die Möglichkeit, den Abstand zur Ebene einzugeben. Diese Ebene ist nicht die Sicherheitsebene der Messroutine. Detaillierte Informationen finden Sie unter "Messpunkt Sicherheitsebene".

  • Lernen, dann messen - Durch Auswahl dieser Option wird die Maschine veranlasst, die Position des Werkstückes unter Verwendung standardmäßiger Parameter zu erlernen und dann das Element mit den im Fenster gesetzten Eigenschaften sofort neu zu messen. Wird dazu verwendet, alle eingestellten Parameter zu testen, wodurch eine genauere und verlässlichere 'Erstmusterprüfung' gewährleistet wird.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Hierdurch hat der Benutzer die Möglichkeit, die theoretischen Werte des Elements einzugeben und das Element vom Programm an dieser Position messen zu lassen. (Deaktiviert die Option Suchabstand im Bereich Bewegungsparameter, sofern dieser ausgewählt ist.)

Bereich "Parameter"

  • XYZD-Nennwert - Definiert die theoretische Position des Kreisschaftes.

  • XYZD-Messwert - Zeigt die gemessene Position des Kreisschaftes an.

Bereich "3-Achsen-Protokollierung"

Die 3-Achsen Protokollierung kann auf 3 Arten zur Definition des XYZ-Punktes verwendet werden.

  • Auswahl eines gemessenen Punktes oder einer Ebene, um die Höhe des gemessenen Elementes zu definieren.

  • Geben Sie die zu verwendende, richtungsabhängige Ebenenhöhe ein. Diese Höhe ist relativ zum Werkstücknullpunkt und wird entlang des Tastervektors gemessen.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Bewegungspunkt einfügen Dieser Softkey liest die aktuelle Position des Tasters und fügt eine Sicherheitsbewegung in die Messroutine ein.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.

Lernprozess

  1. Positionieren Sie den Taster in die Nähe der Fläche auf der Seite des Schaftes und drücken Sie den Softkey Position lesen [image]. Diese Position wird dann zur Höhenposition für alle Messpunkte. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image] , um diese Messposition abzubrechen.

  2. Positionieren Sie den Taster über die Mitte der Ausstülpung und drücken Sie den Softkey Position lesen [image]. Dieser Wert wird zur Bestimmung der Schaftmitte verwendet. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image] , um diese Messposition abzubrechen.

  3. Positionieren Sie den Taster für die automatische Messung und drücken Sie den Softkey Lernen und Erstellen eines Befehls [image]. NC Gage nimmt einen Messpunkt auf dem Schaft entland der radialen Richtung auf. Die Antastrichtung erfolgt von der Schwenkposition zur Schaftmitte.

Beispiel zur Darstellung des Anfangs- und des Zielpunktes

Beachten Sie, dass nur der DSE-Winkel, in der die Tasterrichtung senkrecht zur Schaftmittellinie verläuft, kann derzeit unterstützt werden:

  4. Nachdem das Element gemessen wurde, werden die gemessenen Werte aktualisiert. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird zur Messroutine hinzugefügt. Drücken Sie den Softkey Zurückkehren [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Lernprozess ohne Schaftdrehung

Bitte beachten Sie für diesen Lernprozess die folgende Abbildung:

Lernprozess ohne Schaftdrehung

  1. Wählen Sie für die Option Schaftrotation Nein.

  2. Positionieren Sie den Taster neben die Schaftoberfläche oberhalb der Mittellinie und drücken Sie dann den Softkey Position lesen [image]. Damit wird die erste Ausrichtungsposition aufgenommen. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image], um diese Messposition abzubrechen.

  3. Positionieren Sie den Taster neben die Schaftoberfläche neben der Mittellinie und drücken Sie dann den Softkey Position lesen [image]. Damit wird die zweite Ausrichtungsposition aufgenommen. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image], um diese Messposition abzubrechen.

  4. Positionieren Sie den Taster neben die Schaftoberfläche und drücken Sie dann den Softkey Position lesen [image]. Damit wird die dritte Ausrichtungsposition aufgenommen. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image], um diese Messposition abzubrechen.

  5. Positionieren Sie den Taster für die automatische Messung und drücken Sie den Softkey Lernen und Erstellen eines Befehls [image]. NC Gage stellt Messpunkte in ähnlicher Weise, wie weiter unten abgebildet, dar:

Messpunkte bei Lernprozess ohne Schaftdrehung

Nachdem das Element gemessen wurde, werden die gemessenen Werte aktualisiert.

  6. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird zur Messroutine hinzugefügt. Drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

'NC-Gage'-spezifischer Elementpfad und dessen logischer Aufbau in diesem Programm

Elementpfad Schaft lernen

  • Positionieren Sie den Taster neben die Schaftoberfläche oberhalb der Mittellinie. Lesen Sie die Position.

  • Positionieren Sie den Taster neben die Schaftoberfläche seitlich der Mittellinie. Lesen Sie die Position.

  • Positionieren Sie den Taster neben der Oberfläche. Lesen Sie die Position.

  • Berechnen Sie mit den gemessenen Positionen den Schaftdurchmesser.

  • Messen Sie den ersten Punkt auf der Schaftoberfläche in Richtung des Antastvektors.

  • Messen Sie den zweiten Punkt auf der Schaftoberfläche in Richtung des Antastvektors.

  • Messen Sie den dritten Punkt auf der Schaftoberfläche in Richtung des Antastvektors.

  • Berechnen Sie den Durchmesser und die Mitte des Schaftes.

  • Berechnen Sie den Startwinkel und eingeschlossener Winkel.

Elementpfad Schaft ausführen

  • Vorhalteradius definieren: Schaftradius + Vorhalteabstand + Tasterradius

  • Zielradius definieren: Schaftradius - Vorhalteabstand + Tasterradius

  • Wenn die aktuelle Position unterhalb der Sicherheitsebenenhöhe liegt, dann fahren Sie hoch zur Sicherheitsebene.

  • Fahren Sie über die Vorhalteposition in der Sicherheitsebene.

  • Fahren Sie zur Vorhalteposition beim Startwinkel. Dieser Punkt liegt um die Länge des Vorhalteradius in Richtung des Startwinkels von der Mitte des Tisches entfernt.

  • Absenken bis zur Messebene.

  • Messen Sie den Punkt. Das Ziel ist der Zielradius von der Tischmitte entlang des Startwinkels.

  • Zurückziehen und zur nächsten Vorhaltepunktposition fahren. Fahren Sie so lange mit den oben beschriebenen Schritten fort, bis alle Punkte gemessen sind.

  • Nachdem der letzte Punkt gemessen ist, wird der Taster zur Sicherheitsebenenhöhe hochgefahren.

Lernprozess mit Schaftdrehung

Bitte beachten Sie für diesen Lernprozess die folgende Abbildung:

Lernprozess mit Schaftdrehung

  1. Wählen Sie für die Option Schaftrotation Ja.

  2. Positionieren Sie den Taster neben die Schaftoberfläche und drücken Sie dann den Softkey Position lesen [image]. Diese Ausrichtungsposition wird als Startposition für die Messung eingelesen. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image], um diese Messposition abzubrechen.

  3. Positionieren Sie den Taster für die automatische Messung oder drücken Sie den Softkey Zurück zum vorherigen Schritt [image], um diese Messposition abzubrechen. NC Gage nimmt automatisch einen Messpunkt auf dem Schaft entlang der radialen Richtung auf. Die Antastrichtung erfolgt von der Schwenkposition zur Schaftmitte (siehe unten):

Die Antastrichtung erfolgt von der Schwenkposition zur Schaftmitte.

Nachdem das Element gemessen wurde, werden die gemessenen Werte aktualisiert.

  4. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird zur Messroutine hinzugefügt. Drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

'NC-Gage'-spezifischer Elementpfad und dessen logischer Aufbau in diesem Programm

Elementpfad Schaft lernen

  • Positionieren Sie den Taster als Anfangsfläche in die Nähe der Schaftoberfläche.

  • Lesen Sie die Position.

  • Berechnen Sie den Antastvektor mit Position lesen und der Tischmitte.

  • Messen Sie einen Punkt auf der Schaftoberfläche in Richtung des Antastvektors.

  • Berechnen Sie den Durchmesser und die Mitte des Schaftes.

  • Berechnen Sie den Winkel des Antastvektors als den Startwinkel.

  • Kehren Sie zur Startposition zurück.

Elementpfad Schaft ausführen

  • Vorhalteradius definieren: Schaftradius + Vorhalteabstand + Tasterradius

  • Zielradius definieren: Schaftradius - Vorhalteabstand + Tasterradius

  • Wenn die aktuelle Position unterhalb der Sicherheitsebenenhöhe liegt, dann fahren Sie hoch zur Sicherheitsebene.

  • Fahren Sie über die Vorhalteposition in der Sicherheitsebene.

  • Fahren Sie zur Vorhalteposition beim Startwinkel. Dieser Punkt liegt um die Länge des Vorhalteradius in Richtung des Startwinkels von der Mitte des Tisches entfernt.

  • Absenken bis zur Messebene.

  • Messen Sie den Punkt. Das Ziel ist der Zielradius von der Tischmitte entlang des Startwinkels.

  • Zurückziehen und den Tisch auf den nächsten Winkel drehen.

  • Fahren Sie so lange mit den oben beschriebenen Schritten fort, bis alle Punkte gemessen sind.

  • Nachdem der letzte Punkt gemessen ist, wird der Taster zur Sicherheitsebenenhöhe hochgefahren.


Steg

Home > Anwenden von PC-DMIS NC Gage > Erstellen von Elementbefehlen > Steg

Steg messen

So erstellen Sie einen Befehl 'Steg':

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Steg [image] , um das Fenster Steg messen aufzurufen.

  3. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, grafisch angezeigt.

Bereich "Eigenschaften"

Hinweis: Die nachfolgenden beiden Eigenschaften sind nur dann sichtbar, wenn das Kontrollkästchen Lernen mit Hilfe von Werten auf dem Bildschirm im Bereich Optionale Einstellungen ausgewählt ist:

  • Erste Seitenlänge - Definiert den Abstand zwischen dem ersten und dem zweiten Punkt.

  • Länge der zweiten Seite - Definiert den Abstand zwischen dem Anfangspunkt - wenn dieser auf die zweite Seite projiziert wurde - und dem Punkt auf der zweiten Seite.

Bereich "Antast-Parameter"

  • Vorhalteabstand - Definiert den Abstand weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchabstand - Definiert die Entfernung, die der Taster zurücklegt, während er im Lernmodus die Fläche sucht. (Nicht verfügbar, wenn die im Bereich "Optionale Einstellungen" beschriebene Option Lernen unter Verwendung von Werten auf dem Bildschirm ausgewählt ist.)

Bereich "Optionale Einstellungen"

  • Messpunkt Sicherh.-Ebene - Durch Auswahl dieser Option wird der Taster veranlasst, zwischen jedem Elementmesspunkt zu einer Sicherheitsebene zu fahren. Mit dem Bearbeitungsfeld auf der rechten Seite hat der Benutzer die Möglichkeit, den Abstand zur Ebene einzugeben. Diese Ebene ist nicht die Sicherheitsebene der Messroutine. Detaillierte Informationen finden Sie unter Messpunkt Sicherheitsebene.

  • Lernen, dann messen - Durch Auswahl dieser Option wird die Maschine veranlasst, die Position des Werkstückes unter Verwendung standardmäßiger Parameter zu erlernen und dann das Element mit den im Fenster gesetzten Eigenschaften sofort neu zu messen. Wird dazu verwendet, alle eingestellten Parameter zu testen, wodurch eine genauere und verlässlichere 'Erstmusterprüfung' gewährleistet wird.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Hierdurch hat der Benutzer die Möglichkeit, die theoretischen Werte des Elements einzugeben und das Element vom Programm an dieser Position messen zu lassen. (Aktiviert die Optionen Erste Seitenlänge und Zweite Seitenlänge im Bereich Eigenschaften und deaktiviert die Option Suchabstand im Bereich Bewegungsparameter, sofern diese ausgewählt ist.)

Bereich "Parameter"

  • Mitte (XYZ-Nennwert) - Definiert die theoretische Position des oberen Flächenmittelpunkts des Stegs.

  • Mitte (XYZ-Messwert) - Blendet die gemessene Position des oberen Flächenmittelpunkts des Stegs ein.

  • Winkel auf X - Definiert den Vektorwinkel der Mittellinie des Stegs. Dies ist die Richtung der Geraden im Verhältnis zur X-Achse.

  • Breite (Nennwert) - Definiert die theoretische Breite des Stegs.

  • Breite (Messwert) - Blendet die gemessene Breite des Stegs ein.

Bereich "3-Achsen-Protokollierung"

Es gibt drei Verfahren für die Bestimmung des XYZ-Punktes mit Hilfe der 3-Achsen-Protokollierung.

  • Wählen Sie einen gemessenen Punkt oder eine gemessene Ebene aus, um die Höhe des gemessenen Elements zu bestimmen.

  • Geben Sie die zu verwendende, richtungsabhängige Ebenenhöhe ein. Diese Höhe ist relativ zum Werkstücknullpunkt und wird entlang des Tastervektors gemessen.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zum vorherigen Schritt zurückkehren Dieser Softkey löscht die zuletzt erlernten Tasterpositionen. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Lernen und Erstellen eines Befehls (Ausführen) Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Bewegungspunkt einfügen Dieser Softkey liest die aktuelle Position des Tasters und fügt eine Sicherheitsbewegung in die Messroutine ein.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.

Lernvorgang

  1. Positionieren Sie den Taster neben dem ersten Punkt auf der ersten Seite und drücken Sie den Softkey Tasterposition lesen [image]. Der Abstand zur Arbeitsfläche ist für alle Punkte gleich.

  2. Positionieren Sie den Taster neben den zweiten Punkt auf der ersten Seite und drücken Sie den Softkey Position lesen [image].

  3. Positionieren Sie den Taster neben den Punkt auf der zweiten Seite und drücken Sie den Softkey Position lesen [image].

  4. Drücken Sie den Softkey Lernen und Erstellen eines Befehls [image] . NC-Gage fährt zur Sicherheitsebene und nimmt Messpunkte auf die gleiche Weise, wie weiter unten dargestellt, automatisch auf.

A-C) Ausrichtungspositionen 1-3) automatisch gemessene Punktpositionen. Die roten Linien stellen den Messweg dar.

  5. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird zur Messroutine hinzugefügt. Drücken Sie den Softkey Zurücksetzen [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

'NC-Gage'-spezifischer Elementpfad und logischer Aufbau

Elementpfad Steg lernen

  • Tasterposition neben dem ersten Punkt auf der ersten Seite des Stegs lesen; Z-Wert wird zur Messhöhe aller Punkte.

  • Tasterposition neben zweitem Punkt auf der ersten Seite des Stegs lesen; die Richtung vom ersten Punkt zum zweiten Punkt definiert den Richtungsvektor des Stegs. Dieser Punkt bestimmt die ungefähre Messposition des zweiten Punkts.

  • Tasterposition neben einem Punkt auf der zweiten Seite des Stegs lesen; der Abstand von diesem Punkt zur Geraden, die durch die ersten beiden Punkte definiert wurde, legt die ungefähre Breite des Stegs fest. Dieser Punkt bestimmt die ungefähre Messposition des dritten Punkts.

  • Wenn sich der Taster links unterhalb der Sicherheitsebenenhöhe befindet, fahren Sie hoch auf Sicherheitsebenenhöhe.

  • Fahren Sie zur Position über dem ersten Lesepunkt.

  • Absenken bis auf Messhöhe.

  • Messen Sie den Punkt; Ziel ist die Projektion des ersten Punktes auf die Mittellinie des Stegs.

  • Zurückziehen und zur zweiten Lesepunktposition fahren.

  • Messen Sie den Punkt; Ziel ist die Projektion des zweiten Punktes auf der Mittellinie des Stegs.

  • Zurückziehen und hoch auf Sicherheitsebenenhöhe fahren.

  • Fahren Sie zum Punkt über dem dritten Lesepunkt.

  • Absenken bis auf Messhöhe.

  • Messen Sie den Punkt; Ziel ist die Projektion des dritten Punktes auf die Mittellinie des Stegs.

  • Zurückziehen und hoch auf Sicherheitsebenenhöhe fahren.

Elementpfad Steg ausführen

  • Wenn sich der Taster unterhalb der Sicherheitsebenenhöhe befindet, dann fahren Sie hoch auf Sicherheitsebenenhöhe.

  • Fahren Sie zur Position über dem ersten Punkt des Vorhaltebereichs.

  • Absenken bis auf Messhöhe.

  • Messen Sie den Punkt; Ziel ist die Projektion des ersten Punktes auf die Mittellinie des Stegs.

  • Zurückziehen und zur zweiten Vorhaltepunktposition fahren.

  • Messen Sie den Punkt; Ziel ist die Projektion des zweiten Punktes auf der Mittellinie des Stegs.

  • Zurückziehen und hoch auf Sicherheitsebenenhöhe fahren.

  • Fahren Sie zum Punkt über dem dritten Vorhaltepunkt.

  • Absenken bis auf Messhöhe.

  • Messen Sie den Punkt; Ziel ist die Projektion des dritten Punktes auf die Mittellinie des Stegs.

  • Wenn die lokale Sicherheitsebene aktiviert ist, fahren Sie zwischen jedem Punkt zur lokalen Sicherheitsebene, um zum nächsten Punkt des Vorhaltebereichs zu gelangen.

  • Zurückziehen und hoch auf Sicherheitsebenenhöhe fahren.


Tasche

Home > Anwenden von PC-DMIS NC Gage > Erstellen von Elementbefehlen > Tasche

Tasche messen

So erstellen Sie einen Befehl Tasche:

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Tasche [image] , um das Fenster Tasche messen anzuzeigen:

  3. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, grafisch angezeigt.

Bereich "Eigenschaften"

Hinweis: Die nachfolgenden beiden Eigenschaften sind nur dann sichtbar, wenn das Kontrollkästchen Lernen mit Hilfe von Werten auf dem Bildschirm im Bereich Optionale Einstellungen ausgewählt ist:

  • Erste Seitenlänge - Definiert den Abstand zwischen dem ersten und dem zweiten Punkt.

  • Länge der zweiten Seite - Definiert den Abstand zwischen dem Anfangspunkt - wenn dieser auf die zweite Seite projiziert wurde - und dem Punkt auf der zweiten Seite.

Bereich "Antast-Parameter"

  • Vorhalteabstand - Definiert den Abstand weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchabstand - Definiert die Entfernung, die der Taster zurücklegt, während er im Lernmodus die Fläche sucht. (Nicht verfügbar, wenn die im Bereich "Optionale Einstellungen" beschriebene Option Lernen unter Verwendung von Werten auf dem Bildschirm ausgewählt ist.)

Bereich "Optionale Einstellungen"

  • Messpunkt Sicherh.-Ebene - Durch Auswahl dieser Option wird der Taster veranlasst, zwischen jedem Elementmesspunkt zu einer Sicherheitsebene zu fahren. Geben Sie in der rechten Box den Abstand zur Ebene ein. Diese Ebene ist nicht die Sicherheitsebene der Messroutine. Detaillierte Informationen finden Sie unter Messpunkt Sicherheitsebene.

  • Lernen, dann messen - Durch Auswahl dieser Option wird die Maschine veranlasst, die Position des Werkstückes unter Verwendung standardmäßiger Parameter zu erlernen und dann das Element mit den im Fenster gesetzten Eigenschaften sofort neu zu messen. Wird dazu verwendet, alle eingestellten Parameter zu testen, wodurch eine genauere und verlässlichere 'Erstmusterprüfung' gewährleistet wird.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Hierdurch hat der Benutzer die Möglichkeit, die theoretischen Werte des Elements einzugeben und das Element vom Programm an dieser Position messen zu lassen. (Aktiviert die Optionen Erste Seitenlänge und Zweite Seitenlänge im Bereich Eigenschaften und deaktiviert die Option Suchabstand im Bereich Bewegungsparameter sofern diese ausgewählt ist.)

Bereich "Parameter"

  • Mitte (XYZ-Nennwert) - Definiert die theoretische Position des oberen Flächenmittelpunkts der Tasche.

  • Mitte (XYZ-Messwert) - Blendet die gemessene Position des oberen Flächenmittelpunkts der Tasche ein.

  • Winkel auf X - Definiert den Vektorwinkel der Tasche. Dies ist die Richtung der Geraden im Verhältnis zur X-Achse.

  • Breite (Nennwert) - Definiert die theoretische breite der tasche.

  • Breite (Messwert) - Blendet die gemessene Breite der Tasche ein.

Bereich "3-Achsen-Protokollierung"

Es gibt drei Verfahren für die Bestimmung des XYZ-Punktes mit Hilfe der 3-Achsen-Protokollierung.

  • Wählen Sie einen gemessenen Punkt oder eine gemessene Ebene aus, um die Höhe des gemessenen Elements zu bestimmen.

  • Geben Sie die zu verwendende, richtungsabhängige Ebenenhöhe ein. Diese Höhe ist relativ zum Werkstücknullpunkt und wird entlang des Tastervektors gemessen.

Softkeys der Navigationsleiste

Zurückkehren

Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt.

Vorwärts

Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.

Zum vorherigen Schritt zurückkehren

Dadurch werden die zuletzt erlernten Tasterpositionen entfernt.

Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort

Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.

Fokus umschalten zwischen

Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet.

Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen

Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Fenster Messroutine bearbeiten löschen.

Lernen und Erstellen eines Befehls

Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Sie startet die Messung des Elements durch die Maschine.

Alle Schritte abbrechen / Abbrechen

Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.

Ausführen

Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Das Element kann vor der Übergabe an die Messroutine geändert und getestet werden.

Minimieren

Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.

Toleranzeinstellungen

Mit diesem Softkey können Sie die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint.

Bewegungspunkt einfügen

Mit diesem Softkey wird die aktuelle Position des Tasters eingelesen und als eine Sicherheitsebenenbewegung in die Messroutine eingefügt.

Bestätigen / Befehl hinzufügen

Für Arbeitsgänge bestätigt dies die Auswahl.

Für Befehle wird damit der Befehl am Ende der Messroutine hinzugefügt.

Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben.

Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben.

Hilfe

Dieser Softkey ruft die NC Gage Hilfedatei auf.

Lernvorgang

  1. Positionieren Sie den Taster neben dem ersten Punkt auf der ersten Seite und drücken Sie den Softkey Tasterposition lesen [image]. Der Abstand zur Arbeitsfläche ist für alle Punkte gleich.

  2. Positionieren Sie den Taster neben den zweiten Punkt auf der ersten Seite und drücken Sie den Softkey Position lesen [image].

  3. Positionieren Sie den Taster neben den Punkt auf der zweiten Seite und drücken Sie den Softkey Position lesen [image].

  4. Drücken Sie den Softkey Lernen und Erstellen eines Befehls [image] . NC-Gage fährt zur Sicherheitsebene und nimmt Messpunkte auf die gleiche Weise, wie weiter unten dargestellt, automatisch auf. Beim Lernen durchquert der Taster einen Suchbereich, der viermal so groß ist wie der Vorhalteabstand.

Taschenpfad: A-C) Ausrichtungspositionen entlang Messpunktpositionen der Mittellinie 1-3). Die roten Linien stellen den Messweg dar.

  5. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird der Messroutine hinzugefügt. Drücken Sie den Softkey Zurückkehren [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Nachfolgend handelt es sich um den 'NC-Gage'-spezifischen Elementpfad und logischen Aufbau in NC Gage:

Elementpfad der Tasche lernen

  • Tasterposition neben dem ersten Punkt auf der ersten Seite der Tasche lesen; Z-Wert wird zur Messhöhe aller Punkte.

  • Tasterposition neben zweitem Punkt auf der ersten Seite der Tasche lesen; die Richtung des ersten Punkts zum zweiten Punkt definiert den Richtungsvektor der Tasche. Dieser Punkt bestimmt die ungefähre Messposition des zweiten Punkts.

  • Tasterposition neben einem Punkt auf der zweiten Seite der Tasche lesen; der Abstand von diesem Punkt zur Geraden, die durch die ersten beiden Punkte definiert wurde, legt die ungefähre Breite der Tasche fest. Dieser Punkt bestimmt die ungefähre Messposition des dritten Punkts.

  • Wenn sich der Taster links unterhalb der Sicherheitsebenenhöhe befindet, fahren Sie hoch auf Sicherheitsebenenhöhe.

  • Fahren Sie zur Position über dem ersten Lesepunkt.

  • Absenken bis auf Messhöhe.

  • Punkt messen; Ziel ist vierfacher Vorhalteabstand weg von der Mittellinie der Tasche.

  • Zurückziehen und zur zweiten Lesepunktposition fahren.

  • Punkt messen; Ziel ist vierfacher Vorhalteabstand weg von der Mittellinie der Tasche.

  • Zurückziehen und zur dritten Lesepunktposition fahren.

  • Punkt messen; Ziel ist vierfacher Vorhalteabstand weg von der Mittellinie der Tasche.

  • Zurückziehen und hoch auf Sicherheitsebenenhöhe fahren.

Elementpfad Tasche ausführen

  • Wenn sich der Taster unterhalb der Sicherheitsebenenhöhe befindet, dann fahren Sie hoch auf Sicherheitsebenenhöhe.

  • Fahren Sie zur Position über dem ersten Punkt des Vorhaltebereichs.

  • Absenken bis auf Messhöhe.

  • Punkt messen; Ziel ist zweifacher Vorhalteabstand weg von der Mittellinie der Tasche.

  • Zurückziehen und zur zweiten Vorhaltepunktposition fahren.

  • Punkt messen; Ziel ist zweifacher Vorhalteabstand weg von der Mittellinie der Tasche.

  • Zurückziehen und zur dritten Vorhaltepunktposition fahren.

  • Punkt messen; Ziel ist zweifacher Vorhalteabstand weg von der Mittellinie der Tasche.

  • Wenn die lokale Sicherheitsebene aktiviert ist, fahren Sie zwischen jedem Punkt zur lokalen Sicherheitsebene, um zum nächsten Punkt des Vorhaltebereichs zu gelangen.

  • Zurückziehen und hoch auf Sicherheitsebenenhöhe fahren.


Ecke (Außen)

Home > Anwenden von PC-DMIS NC Gage > Erstellen von Elementbefehlen > Ecke (Außen)

Ecke messen (Außen)

So erstellen Sie einen Befehl 'Ecke (Außen)':

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Ecke (Außen) [image], um das Fenster Ecke messen (Außen) aufzurufen.

  3. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, grafisch angezeigt.

Bereich "Eigenschaften"

Hinweis: Die nachfolgenden beiden Eigenschaften sind nur dann sichtbar, wenn das Kontrollkästchen Lernen mit Hilfe von Werten auf dem Bildschirm im Bereich Optionale Einstellungen ausgewählt ist:

  • Startseitenversätze - Definiert die Abstände des ersten und zweiten Punktes bzw. von der Nennposition der Ecke entlang der ersten Seite in Richtung des Startwinkels.

  • Endseitenversätze - Definiert die Abstände des ersten und zweiten Punktes bzw. von der Nennposition der Ecke entlang der zweiten Seite.

  • Erste Seite verläuft zur zweiten Seite hin nach rechts - Standardmäßig erwartet NC-Gage, dass sich die zweite Seite links von der ersten Seite, also entgegen dem Uhrzeigersinn, befindet. Durch Auswahl dieser Option wird erkannt, dass sich die zweite Seite rechts von der ersten Seite, also in Richtung Uhrzeigersinn, befindet.

Bereich "Antast-Parameter"

  • Vorhalteabstand - Definiert den Abstand weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchabstand - Definiert die Entfernung, die der Taster zurücklegt, während er im Lernmodus die Fläche sucht. (Nicht verfügbar, wenn die im Bereich "Optionale Einstellungen" beschriebene Option Lernen unter Verwendung von Werten auf dem Bildschirm ausgewählt ist.)

Bereich "Optionale Einstellungen"

  • Messpunkt Sicherh.-Ebene - Durch Auswahl dieser Option wird der Taster veranlasst, zwischen jedem Elementmesspunkt zu einer Sicherheitsebene zu fahren. Mit dem Bearbeitungsfeld auf der rechten Seite hat der Benutzer die Möglichkeit, den Abstand zur Ebene einzugeben. Diese Ebene ist nicht die Sicherheitsebene der Messroutine. Detaillierte Informationen finden Sie unter Messpunkt Sicherheitsebene.

  • Lernen, dann messen - Durch Auswahl dieser Option wird die Maschine veranlasst, die Position des Werkstückes unter Verwendung standardmäßiger Parameter zu erlernen und dann das Element mit den im Fenster gesetzten Eigenschaften sofort neu zu messen. Wird dazu verwendet, alle eingestellten Parameter zu testen, wodurch eine genauere und verlässlichere 'Erstmusterprüfung' gewährleistet wird.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Hierdurch hat der Benutzer die Möglichkeit, die theoretischen Werte des Elements einzugeben und das Element vom Programm an dieser Position messen zu lassen. (Durch Aktivierung sind die Optionen Startseitenversätze, Endseitenversätze und Erste Seite verläuft zur zweiten Seite hin nach rechts im Bereich Eigenschaften, aber die Option Suchabstand im Bereich Bewegungsparameter wird deaktiviert.)

Bereich "Parameter"

  • Nennwert (XY-Nennwert) - Definiert die theoretische Position der Ecke.

  • Messwert (XY-Messwert) - Blendet die gemessene Position der Ecke ein.

  • Startwinkel - Definiert den Winkel der Anfangsseite der Ecke. Dies ist die Richtung der Seite im Verhältnis zur Primärachse. Die Primärachse ist X in der XY-Arbeitsfläche, Y in der YZ-Arbeitsfläche und Z in der ZX-Arbeitsfläche.

  • Eingeschlossener Winkel - Definiert den Winkel zwischen den beiden Seiten der Ecke.

Bereich "3-Achsen-Protokollierung"

Es gibt drei Verfahren für die Bestimmung des XYZ-Punktes mit Hilfe der 3-Achsen-Protokollierung.

  • Wählen Sie einen gemessenen Punkt oder eine gemessene Ebene aus, um die Höhe des gemessenen Elements zu bestimmen.

  • Geben Sie die zu verwendende, richtungsabhängige Ebenenhöhe ein. Diese Höhe ist relativ zum Werkstücknullpunkt und wird entlang des Tastervektors gemessen.

Softkeys der Navigationsleiste

Zurückkehren

Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt.

Vorwärts

Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.

Zum vorherigen Schritt zurückkehren

Dadurch werden die zuletzt erlernten Tasterpositionen entfernt.

Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort

Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.

Fokus umschalten zwischen

Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet.

Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen

Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.

Lernen und Erstellen eines Befehls

Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Sie startet die Messung des Elements durch die Maschine.

Alle Schritte abbrechen / Abbrechen

Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.

Ausführen

Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Das Element kann vor der Übergabe an die Messroutine geändert und getestet werden.

Minimieren

Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.

Toleranzeinstellungen

Mit diesem Softkey können Sie die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint.

Bewegungspunkt einfügen

Mit diesem Softkey wird die aktuelle Position des Tasters eingelesen und als eine Sicherheitsebenenbewegung in die Messroutine eingefügt.

Bestätigen / Befehl hinzufügen

Für Arbeitsgänge bestätigt dies die Auswahl.

Für Befehle wird damit der Befehl am Ende der Messroutine hinzugefügt.

Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben.

Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben.

Hilfe

Dieser Softkey ruft die NC Gage Hilfedatei auf.

Lernvorgang

  1. Positionieren Sie den Taster neben den ersten Punkt auf der ersten Seite der Ecke und drücken Sie den Softkey Position lesen [image].

  2. Positionieren Sie den Taster neben den zweiten Punkt auf der ersten Seite der Ecke und drücken Sie den Softkey Position lesen [image].

  3. Positionieren Sie den Taster neben den ersten Punkt auf der zweiten Seite der Ecke und drücken Sie den Softkey Position lesen [image].

  4. Positionieren Sie den Taster neben den zweiten Punkt auf der zweiten Seite der Ecke und drücken Sie den Softkey Position lesen [image].

  5. Positionieren Sie den Taster zur automatischen Messung und drücken Sie dann auf Lernen und Erstellen eines Befehls [image] . NC Gage nimmt Messpunkte auf die gleiche Weise, wie weiter unten dargestellt, automatisch auf.

Pfad der Ecke (Außen): A-D) Ausrichtungspositionen 1-4) automatisch gemessene Punktpositionen. Die roten Linien stellen den Messweg dar.

  6. Nachdem das Element gemessen wurde, werden die gemessenen Werte aktualisiert. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird der Messroutine hinzugefügt. Drücken Sie den Softkey Zurückkehren [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Nachfolgend handelt es sich um den 'NC-Gage'-spezifischen Elementpfad und logischen Aufbau in NC Gage:

Elementpfad Ecke (Außen) lernen

  • Lesen Sie die Tasterposition neben dem ersten Punkt der ersten Seite der Ecke. Alle Messungen erfolgen an der Ebene dieses Punktes.

  • Lesen Sie die Tasterposition neben dem zweiten Punkt der ersten Seite der Ecke.

  • Lesen Sie die Tasterposition neben dem ersten Punkt der zweiten Seite der Ecke.

  • Lesen Sie die Tasterposition neben dem zweiten Punkt der zweiten Seite der Ecke.

  • Bestimmen Sie den ersten und zweiten Richtungsvektor sowie die Normalenvektoren.

  • Kompensieren Sie Punkte.

  • Bestimmen Sie einen ungefähren Eckpunkt.

  • Fahren Sie zur Sicherheitsebenenhöhe.

  • Positionieren Sie den Taster über der ersten Lesepunktposition.

  • Absenken bis auf Messhöhe.

  • Messen Sie in Richtung der ersten Seitenfläche; die Tiefe entspricht dem ersten Punkt der zweiten Seite.

  • Positionieren Sie den Taster ungefähr auf den zweiten Lesepunkt.

  • Messen Sie in Richtung der ersten Seitenfläche; die Tiefe entspricht dem ersten Punkt der zweiten Seite.

  • Fahren Sie zum Punkt jenseits der Ecke, um eine Kollision zu vermeiden.

  • Positionieren Sie den Taster ungefähr auf den dritten Lesepunkt.

  • Messen Sie in Richtung der zweiten Seitenfläche; die Tiefe entspricht dem ersten Punkt der ersten Seite.

  • Positionieren Sie den Taster ungefähr auf den vierten Lesepunkt.

  • Messen Sie in Richtung der zweiten Seitenfläche; die Tiefe entspricht dem ersten Punkt der ersten Seite.

Führen Sie den Elementpfad 'Ecke (Außen)' aus.

  • Wenn sich der Taster unterhalb der Sicherheitsebenenhöhe befindet, dann fahren Sie hoch auf Sicherheitsebenenhöhe.

  • Fahren Sie zur Position über dem ersten Punkt des Vorhaltebereichs.

  • Absenken bis auf Messhöhe.

  • Messen Sie in Richtung der ersten Seitenfläche; die Tiefe entspricht dem ersten Punkt der zweiten Seite.

  • Positionieren Sie den Taster auf den zweiten Punkt des Vorhaltebereichs.

  • Messen Sie in Richtung der ersten Seitenfläche; die Tiefe entspricht dem ersten Punkt der zweiten Seite.

  • Fahren Sie zum Punkt jenseits der Ecke, um eine Kollision zu vermeiden.

  • Positionieren Sie den Taster auf den dritten Punkt des Vorhaltebereichs.

  • Messen Sie in Richtung der zweiten Seitenfläche; die Tiefe entspricht dem ersten Punkt der ersten Seite.

  • Positionieren Sie den Taster auf den vierten Lesepunkt.

  • Wenn die lokale Sicherheitsebene aktiviert ist, fahren Sie zwischen jedem Punkt zur lokalen Sicherheitsebene, um zum nächsten Punkt des Vorhaltebereichs zu gelangen.

  • Messen Sie in Richtung der zweiten Seitenfläche; die Tiefe entspricht dem ersten Punkt der ersten Seite.


Ecke (Innen)

Home > Anwenden von PC-DMIS NC Gage > Erstellen von Elementbefehlen > Ecke (Innen)

Ecke messen (Innen)

So erstellen Sie einen Befehl "Ecke (Innen)":

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Ecke (Innen) [image], um das Fenster Innere Ecke messen aufzurufen:

  3. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, grafisch angezeigt.

Bereich "Eigenschaften"

Hinweis: Die nachfolgenden beiden Eigenschaften sind nur dann sichtbar, wenn das Kontrollkästchen Lernen mit Hilfe von Werten auf dem Bildschirm im Bereich Optionale Einstellungen ausgewählt ist:

  • Startseitenversätze - Hierbei handelt es sich um die Abstände des ersten und zweiten Punktes bzw. von der Nennposition der Ecke entlang der ersten Seite in Richtung des Startwinkels.

  • Endseitenversätze - Hierbei handelt es sich um die Abstände des ersten und zweiten Punktes bzw. von der Nennposition der Ecke entlang der zweiten Seite.

  • Erste Seite verläuft zur zweiten Seite hin nach rechts - Standardmäßig erwartet NC-Gage, dass sich die zweite Seite links von der ersten Seite, also entgegen dem Uhrzeigersinn, befindet. Durch Auswahl dieser Option wird erkannt, dass sich die zweite Seite rechts von der ersten Seite, also in Richtung Uhrzeigersinn, befindet.

Bereich "Antast-Parameter"

  • Vorhalteabstand - Definiert den Abstand weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchabstand - Definiert die Entfernung, die der Taster zurücklegt, während er im Lernmodus die Fläche sucht. (Nicht verfügbar, wenn die im Bereich "Optionale Einstellungen" beschriebene Option Lernen unter Verwendung von Werten auf dem Bildschirm ausgewählt ist.)

Bereich "Optionale Einstellungen"

  • Messpunkt Sicherh.-Ebene - Durch Auswahl dieser Option wird der Taster veranlasst, zwischen jedem Elementmesspunkt zu einer Sicherheitsebene zu fahren. Mit dem Bearbeitungsfeld auf der rechten Seite hat der Benutzer die Möglichkeit, den Abstand zur Ebene einzugeben. Diese Ebene ist nicht die Sicherheitsebene der Messroutine. Detaillierte Informationen finden Sie unter Messpunkt Sicherheitsebene.

  • Lernen, dann messen - Durch Auswahl dieser Option wird die Maschine veranlasst, die Position des Werkstückes unter Verwendung standardmäßiger Parameter zu erlernen und dann das Element mit den im Fenster gesetzten Eigenschaften sofort neu zu messen. Wird dazu verwendet, alle eingestellten Parameter zu testen, wodurch eine genauere und verlässlichere 'Erstmusterprüfung' gewährleistet wird.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Hierdurch haben Sie die Möglichkeit, die theoretischen Werte des Elements einzugeben und das Element vom Programm an dieser Position messen zu lassen. (Durch Aktivierung sind die Optionen Startseitenversätze, Endseitenversätze und Erste Seite verläuft zur zweiten Seite hin nach rechts im Bereich Eigenschaften, aber die Option Suchabstand im Bereich Bewegungsparameter wird deaktiviert.)

Bereich "Parameter"

  • XYZ-Nennwert - Definiert die theoretische Position der Ecke.

  • XYZ-Messwert - Blendet die gemessene Position der Ecke ein.

  • Startwinkel - Definiert den Winkel der Anfangsseite der Ecke. Dies ist die Richtung der Seite im Verhältnis zur X-Achse.

  • Eingeschlossener Winkel - Definiert den Winkel zwischen den beiden Seiten der Ecke.

Bereich "3-Achsen-Protokollierung"

Es gibt drei Verfahren für die Bestimmung des XYZ-Punktes mit Hilfe der 3-Achsen-Protokollierung.

  • Wählen Sie einen gemessenen Punkt oder eine gemessene Ebene aus, um die Höhe des gemessenen Elements zu bestimmen.

  • Geben Sie die zu verwendende, richtungsabhängige Ebenenhöhe ein. Diese Höhe ist relativ zum Werkstücknullpunkt und wird entlang des Tastervektors gemessen.

Softkeys der Navigationsleiste

Zurückkehren

Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt.

Vorwärts

Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.

Zum vorherigen Schritt zurückkehren

Dadurch werden die zuletzt erlernten Tasterpositionen entfernt.

Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort

Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.

Fokus umschalten zwischen

Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet.

Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen

Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Fenster Messroutine bearbeiten löschen.

Lernen und Erstellen eines Befehls

Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Sie startet die Messung des Elements durch die Maschine.

Alle Schritte abbrechen / Abbrechen

Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.

Ausführen

Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Das Element kann vor der Übergabe an die Messroutine geändert und getestet werden.

Minimieren

Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.

Toleranzeinstellungen

Mit diesem Softkey können Sie die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint.

Bewegungspunkt einfügen

Mit diesem Softkey wird die aktuelle Position des Tasters eingelesen und als eine Sicherheitsebenenbewegung in die Messroutine eingefügt.

Bestätigen / Befehl hinzufügen

Für Arbeitsgänge bestätigt dies die Auswahl.

Für Befehle wird damit der Befehl am Ende der Messroutine hinzugefügt.

Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben.

Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben.

Hilfe

Dieser Softkey ruft die NC Gage Hilfedatei auf.

Lernvorgang

  1. Positionieren Sie den Taster neben den ersten Punkt auf der ersten Seite der Ecke und drücken Sie den Softkey Position lesen [image].

  2. Positionieren Sie den Taster neben den zweiten Punkt auf der ersten Seite der Ecke und drücken Sie den Softkey Position lesen [image].

  3. Positionieren Sie den Taster neben den ersten Punkt auf der zweiten Seite der Ecke und drücken Sie den Softkey Position lesen [image].

  4. Positionieren Sie den Taster neben den zweiten Punkt auf der zweiten Seite der Ecke und drücken Sie den Softkey Position lesen [image].

  5. Positionieren Sie den Taster für die automatische Messung und drücken Sie den Softkey Lernen und Erstellen eines Befehls [image] . NC Gage stellt Messpunkte in ähnlicher Weise, wie weiter unten abgebildet, dar.

Pfad der Ecke (Innen): A-E): Ausrichtungspositionen 1-5) automatisch gemessene Punktpositionen. Die roten Linien stellen den Messweg dar.

  6. Nachdem das Element gemessen wurde, werden die gemessenen Werte aktualisiert. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird der Messroutine hinzugefügt.

Nachfolgend handelt es sich um den 'NC-Gage'-spezifischen Elementpfad und logischen Aufbau in NC Gage:

Elementpfad Ecke (Innen) lernen

  • Lesen Sie die Tasterposition neben dem ersten Punkt der ersten Seite der Ecke. Alle Messungen erfolgen auf der Ebene dieses Punktes.

  • Lesen Sie die Tasterposition neben dem zweiten Punkt der ersten Seite der Ecke.

  • Lesen Sie die Tasterposition neben dem ersten Punkt der zweiten Seite der Ecke.

  • Lesen Sie die Tasterposition neben dem zweiten Punkt der zweiten Seite der Ecke.

  • Bestimmen Sie den ersten und zweiten Richtungsvektor sowie die Normalenvektoren.

  • Kompensieren Sie Punkte.

  • Bestimmen Sie einen ungefähren Eckpunkt.

  • Wenn sich der Taster unterhalb der Sicherheitsebenenhöhe befindet, dann fahren Sie hoch auf Sicherheitsebenenhöhe.

  • Positionieren Sie den Taster zum Punkt über der ersten Lesepunktposition.

  • Absenken bis auf Messhöhe.

  • Messen Sie in Richtung der ersten Seitenfläche; Suchabstand ist der vierfache Vorhalteabstand.

  • Positionieren Sie den Taster ungefähr auf den zweiten Lesepunkt.

  • Messen Sie in Richtung der ersten Seitenfläche; Suchabstand ist der vierfache Vorhalteabstand.

  • Positionieren Sie den Taster ungefähr auf den dritten Lesepunkt.

  • Messen Sie in Richtung der zweiten Seitenfläche; Suchabstand ist der vierfache Vorhalteabstand.

  • Positionieren Sie den Taster ungefähr auf den vierten Lesepunkt.

  • Messen Sie in Richtung der zweiten Seitenfläche; Suchabstand ist der vierfache Vorhalteabstand.

  • Fahren Sie zur Sicherheitsebenenhöhe.

Elementpfad Ecke (Innen) ausführen

  • Wenn sich der Taster unterhalb der Sicherheitsebenenhöhe befindet, dann fahren Sie hoch auf Sicherheitsebenenhöhe.

  • Positionieren Sie den Taster zum Punkt über der ersten Vorhaltepunktposition.

  • Absenken bis auf Messhöhe.

  • Messen Sie in Richtung der ersten Seitenfläche; Suchabstand ist der zweifache Vorhalteabstand.

  • Positionieren Sie den Taster ungefähr auf den zweiten Lesepunkt.

  • Messen Sie in Richtung der ersten Seitenfläche; Suchabstand ist der zweifache Vorhalteabstand.

  • Positionieren Sie den Taster ungefähr auf den dritten Lesepunkt.

  • Messen Sie in Richtung der zweiten Seitenfläche; Suchabstand ist der zweifache Vorhalteabstand.

  • Positionieren Sie den Taster ungefähr auf den vierten Lesepunkt.

  • Messen Sie in Richtung der zweiten Seitenfläche; Suchabstand ist der zweifache Vorhalteabstand.

  • Wenn die lokale Sicherheitsebene aktiviert ist, fahren Sie zwischen jedem Punkt zur lokalen Sicherheitsebene, um zum nächsten Punkt des Vorhaltebereichs zu gelangen.

  • Fahren Sie zur Sicherheitsebenenhöhe.


Ebene

Home > Anwenden von PC-DMIS NC Gage > Erstellen von Elementbefehlen > Ebene

Ebene messen

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Vorwärts [image], um die zweite Seite der Softkeys aufzurufen.

  3. Drücken Sie den Softkey Ebene [image], um das Fenster Ebene messen einzublenden:

  4. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, grafisch angezeigt.

Bereich "Eigenschaften"

Hinweis: Die folgenden beiden Eigenschaften sind nur dann verfügbar, wenn die Option Rastermuster im Bereich Messmethod ausgewählt ist.

  • Anzahl der Reihen - Definiert die Anzahl der Reihen, die für die Ebene abgetastet werden.

  • Punkte pro Reihe - Legt die Zahl der Punkte, die in einer Reihe gemessen werden, fest.

Hinweis: Die folgende Eigenschaft ist nur dann verfügbar, wenn die Option Kreisförmiges Muster im Bereich Messmethode ausgewählt ist.

  • Anzahl der Punkte - Definiert die Anzahl der Punkte um das kreisförmige Muster herum, die für die Ebene abgetastet werden.

Hinweis: Die folgende Eigenschaft ist nur dann verfügbar, wenn das Kontrollkästchen Lernen unter Verwendung der Werte auf dem Bildschirm im Bereich Optionale Einstellungen markiert ist und wenn die Option Kreisförmiges Muster im Bereich Messmethode ausgewählt ist.

  • Durchmesser - Definiert den Durchmesser des kreisförmigen Musters für die Messmethode.

Hinweis: Die folgenden beiden Eigenschaften sind nur dann verfügbar, wenn das Kontrollkästchen Lernen unter Verwendung der Werte auf dem Bildschirm im Bereich Optionale Einstellungen markiert ist und wenn die Option Rastermuster im Bereich Messmethode ausgewählt ist.

  • Länge - Dies ist der Abstand vom ersten bis zum letzten Punkt entlang der Primärachse. Die Primärachse ist X in der XY-Arbeitsfläche, Y in der YZ-Arbeitsfläche und Z in der ZX-Arbeitsfläche.

  • Breite - Dies ist der Abstand vom ersten bis zum letzten Punkt entlang der Sekundärachse. Die Sekundärachse ist Y in der XY-Arbeitsfläche, Z in der YZ-Arbeitsfläche und X in der ZX-Arbeitsfläche.

Hinweis: Die Zahl der Reihen und Punkte pro Reihe wird entlang des definierten Ebenenbereichs gleichmäßig verteilt.

Bereich "Bewegungsparameter"

  • Vorhalteabstand - Definiert den Abstand weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchabstand - Definiert den Suchabstand bei der Suche und beim Lernen eines Elements. (Nicht verfügbar, wenn die im Bereich "Optionale Einstellungen" beschriebene Option Lernen unter Verwendung von Werten auf dem Bildschirm ausgewählt ist.)

Bereich "Optionale Einstellungen"

  • Messpunkt Sicherh.-Ebene - Durch Auswahl dieser Option wird der Taster veranlasst, zwischen jedem Elementmesspunkt zu einer Sicherheitsebene zu fahren. Geben Sie in der rechten Box den Abstand zur Ebene ein. Diese Ebene ist nicht die Sicherheitsebene der Messroutine. Detaillierte Informationen finden Sie unter Messpunkt Sicherheitsebene.

  • Lernen, dann messen - Durch Auswahl dieser Option wird die Maschine veranlasst, die Position des Werkstückes unter Verwendung standardmäßiger Parameter zu erlernen und dann das Element mit den im Fenster gesetzten Eigenschaften sofort neu zu messen. Wird dazu verwendet, alle eingestellten Parameter zu testen, wodurch eine genauere und verlässlichere 'Erstmusterprüfung' gewährleistet wird.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Hierdurch hat der Benutzer die Möglichkeit, die theoretischen Werte des Elements einzugeben und das Element vom Programm an dieser Position messen zu lassen. (Aktiviert oder deaktiviert andere Optionen im Bereich Eigenschaften und Bewegungsparameter, je nachdem, welche Option im Bereich Messmethode ausgewählt wurde.)

Bereich "Parameter"

  • Nennwert (XYZ-Nennwert) - Definiert die theoretische Position der Ebene.

  • Messwert (XYZ-Messwert) - Blendet die gemessene Position der Ebene ein.

  • Winkel auf Z - Definiert den ersten Vektorwinkel in der Z-Richtung der Ebene. Hierbei handelt es sich um den Oberflächennormalenvektor der Ebene im Verhältnis zur Arbeitsfläche. Der zulässige Bereich liegt zwischen -90 und +90 Grad.

  • Winkel auf X - Definiert den Vektorwinkel in der X-Richtung der Ebene. Hierbei handelt es sich um den Oberflächennormalenvektor der Ebene im Verhältnis zur primären Achse, in der er gemessen wird. Die Primärachse ist X in der XY-Arbeitsfläche, Y in der YZ-Arbeitsfläche und Z in der ZX-Arbeitsfläche. Der zulässige Bereich liegt zwischen 0 (Null) und -360 Grad.

Hinweis: Winkel auf Z und Winkel auf X stehen in Beziehung zueinander - ein unzulässiger Wert (90.0, 20.0) wird als (90.0, 0.0) definiert.

Bereich "Messmethode"

Hinweis: Optionen im Bereich Eigenschaften sind je nach der getroffenen Auswahl aktiviert oder deaktiviert. Nähere Angaben hierzu finden Sie im Bereich "Eigenschaften".

  • Gitter - Damit wird ein Gitter definiert, mit dem die Ebene gemessen wird.

  • Kreis - Damit wird ein Kreis definiert, mit dem die Ebene gemessen wird.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Arbeitsfläche auswählen Dieser Softkey bestimmt die Antastrichtung und die Lage der Sicherheitsbewegungen für das Element. Sie können diesen mehrmals betätigen, um einen andere Messoberfläche zu wählen. Verfügbare Oberflächen sind: Oben, Links, Rechts, Vorne, Hinten und Schiefe. Wenn Schiefe ausgewählt ist, dann wird das Softkeysymbol zum Schiefensymbol. | Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet.
Zum vorherigen Schritt zurückkehren Dieser Softkey löscht die zuletzt erlernten Tasterpositionen. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Lernen und Erstellen eines Befehls (Ausführen) Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Bewegungspunkt einfügen Dieser Softkey liest die aktuelle Position des Tasters und fügt eine Sicherheitsbewegung in die Messroutine ein.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. |

Verfahren zum Lernen einer Ebene mit einer Arbeitsfläche, die mit Hilfe der Option "Rastermuster" als 'normal' definiert ist:

  1. Wählen Sie im Bereich Messmethode des Fensters Messebene die Option Rastermuster aus.

  2. Drücken Sie den Softkey Messoberfläche auswählen [image] so lange, bis die gewünschte Arbeitsfläche für die zu definierende Ebene (Oben, Links, Rechts, Vorne, Hinten oder Schiefe) gesetzt ist. Wenn Schiefe ausgewählt ist, dann wird der Softkey Messfläche zum Schiefensymbol [image]. Verfahren zum Lernen einer Ebene mit einer abgeschrägten Arbeitsfläche, die mit Hilfe der Option "Rastermuster" als 'normal' definiert ist.

Hinweis: Die ausgewählte Arbeitsfläche muss mit der Ebenennormalen identisch sein.

  3. Zwei Punkte im Raster werden erlernt, indem der Taster zur entsprechenden Position der ausgewählten Arbeitsfläche vorrückt. Positionieren Sie den Taster über die Fläche, an der Sie die Ebene messen möchten. Dadurch wird die erste Ecke der Ebene angegeben.

  4. Drücken Sie den Softkey Tasterposition lesen [image]. Die Werte der Tastspitzenposition werden als Koordinaten für die erste Ecke des Gitters des Ebenenelements eingelesen. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image], um diese Messposition abzubrechen.

  5. Positionieren Sie den Taster über der zweiten Ecke des Gitters.

  6. Drücken Sie den Softkey Tasterposition lesen [image]. Die Tastspitzenposition X/Y wird als die Koordinaten der zweiten Ecke gelesen. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image], um diese Messposition abzubrechen. Auf der Arbeitsfläche wird ein rechteckiger Bereich mit den gelernten Punkten in Maschinenkoordinaten, die den Antastbereich definieren, aufgezeichnet.

  7. Drücken Sie den Softkey Lernen und Erstellen eines Befehls [image] und führen Sie das Überwachungsprogramm im DCC-Modus aus. In den vordefinierten Eckpositionen des Rasters werden vier Punkte automatisch aufgenommen. In der nachfolgenden Abbildung sehen Sie die ausgewählte "-Y"-Arbeitsfläche, die beiden aufgenommenen Punkte an den gelb-markierten Positionen, die mit "P1" und "P2" bezeichnet sind, sowie den Antastweg in rot:

    Definieren einer Ebene unter Verwendung von zwei Verfahrpositionen (P1, P2), nicht-schiefe Arbeitsfläche und Rastermuster

Sobald das Element erlernt und gemessen wurde, werden die Messwerte aktualisiert und die Messung erfolgt daraufhin entlang der tatsächlichen Ebenennormalen.

  8. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird der Messroutine hinzugefügt.

Verfahren zum Lernen einer Ebene mit einer abgeschrägten Arbeitsfläche, die mit Hilfe der Option "Rastermuster" als 'normal' definiert ist

  1. Wählen Sie im Bereich Messmethode des Fensters Messebene die Option Rastermuster aus.

  2. Drücken Sie so lange auf den Softkey Messoberfläche auswählen [image], bis er zum Symbol "Schiefe" [image] geworden ist.

  3. Drei Punkte im Raster werden erlernt, indem der Taster zur entsprechenden Position der ausgewählten Arbeitsfläche vorrückt. Positionieren Sie den Taster über der ersten Ecke des Gitters. Dadurch wird die erste Ecke der Ebene angegeben. Drücken Sie den Softkey Tasterposition lesen [image].

  4. Positionieren Sie den Taster über der zweiten Ecke des Rasters, geben Sie die zweite Ecke des Rasters ann und drücken Sie dann den Softkey Tasterposition lesen [image].

  5. Positionieren Sie den Taster über der gegenüber liegenden Ecke des Rasters und drücken Sie dann den Softkey Tasterposition lesen [image].

  6. Es wird ein rechteckiger Bereich auf der Fläche mit den gelernten Punkten, die den Antastbereich definieren, aufgezeichnet. Drücken Sie den Softkey Lernen und Erstellen eines Befehls [image] und führen Sie das Überwachungsprogramm im DCC-Modus aus. Vier Punkte werden automatisch in den vorher festgelegten Eckpositionen des Rasters aufgenommen, wie unter Verwendung der drei aufgenommenen Messpunkte an den gelb-markierten Positionen P1, P2 und P3 sowie des in rot dargestellten Antastweges weiter unten zu sehen ist:

Definieren einer Ebene unter Verwendung von drei Verfahrpositionen (P1, P2, P3), einer abgeschrägten Arbeitsfläche und einem Rastermuster.

Die theoretischen Werte für den Mitten-, Normalen- und den Antast-Bereich werden nach dem Antasten aktualisiert. Sobald die Ebene erlernt wurde, erfolgt die Messung entlang der tatsächlichen Ebenennormalen.

  7. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird der Messroutine hinzugefügt.

Verfahren zum Lernen einer Ebene mit einer Arbeitsfläche, die mit Hilfe der Option "Kreisförmiges Muster" als 'normal' definiert ist:

  1. Wählen Sie im Bereich Messmethode des Fensters Messebene die Option Kreisförmiges Muster aus.

  2. Drücken Sie den Softkey Messoberfläche auswählen [image] so lange, bis die gewünschte Arbeitsfläche für die zu definierende Ebene (Oben, Links, Rechts, Vorne, Hinten oder Schiefe) gesetzt ist. Wenn "Schiefe" ausgewählt ist, dann ändert sich das Softkeysymbol Messoberfläche auswählen auf den Softkey Schiefe [image]. Verfahren zum Lernen einer Ebene mit einer abgeschrägten Arbeitsfläche, die mit Hilfe der Option "Kreisförmiges Rastermuster" als 'normal' definiert ist.

Hinweis: Die ausgewählte Arbeitsfläche muss mit der Ebenennormalen identisch sein.

  3. Zwei Punkte im Kreis werden erlernt, indem der Taster zur entsprechenden Position der ausgewählten Arbeitsfläche vorrückt. Positionieren Sie den Taster über die Fläche, an der Sie den Kreis messen möchten. Dadurch wird der erste Punkt des Durchmessers des Kreises angegeben.

  4. Drücken Sie den Softkey Tasterposition lesen [image]. Die Werte der Tastspitzenposition werden als Koordinaten für die erste Seite des Kreises des Ebenenelements eingelesen. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image] , um diese Messposition abzubrechen.

  5. Positionieren Sie den Taster über den gegenüber liegenden Punkt des Kreises. Drücken Sie den Softkey Tasterposition lesen [image]. Auf der Arbeitsfläche wird ein kreisförmiger Bereich mit den gelernten Punkten in Maschinenkoordinaten, die den Antastbereich definieren, aufgezeichnet. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image], um diese Messposition abzubrechen.

  6. Drücken Sie den Softkey Lernen und Erstellen eines Befehls [image] und führen Sie das Überwachungsprogramm im DCC-Modus aus. Mit diesen zwei vordefinierten Punkten, die die Begrenzungen für das Kreiselement angeben, wird NC Gage automatisch innerhalb des Kreises Messpunkte aufnehmen, wie unter Verwendung der ausgewählten "-Y"-Arbeitsfläche und der zwei aufgenommenen Messpunkte an den gelb-markierten Positionen P1 und P2 sowie des in rot dargestellten Antastweges weiter unten zu sehen ist:

    Definieren einer Ebene unter Verwendung von zwei Verfahrpositionen (P1, P2), nicht-schiefe Arbeitsfläche und Kreismuster

Die theoretischen Werte für den Mitten-, Normalen- und den Antast-Bereich werden nach dem Antasten aktualisiert. Nachdem das Element gemessen wurde, werden die gemessenen Werte aktualisiert. Die Messung entlang der tatsächlichen Ebenennormalen wird jetzt durchgeführt.

  7. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird der Messroutine hinzugefügt.

Verfahren zum Lernen einer Ebene mit einer abgeschrägten Arbeitsfläche, die mit Hilfe der Option "Kreismuster" als 'normal' definiert ist

  1. Wählen Sie im Bereich Messmethode des Fensters Messebene die Option Kreisförmiges Muster aus.

  2. Drücken Sie so lange auf den Softkey Messoberfläche auswählen [image], bis er zum Symbol Schiefe [image] geworden ist.

  3. Drei Punkte im Kreis werden erlernt, indem der Taster zur entsprechenden Position der ausgewählten Arbeitsfläche vorrückt. Positionieren Sie den Taster über den ersten Punkt des Kreises. Drücken Sie den Softkey Tasterposition lesen [image].

  4. Positionieren Sie den Taster über den zweiten Punkt des Kreises. Drücken Sie den Softkey Tasterposition lesen [image].

  5. Positionieren Sie den Taster über den gegenüber liegenden Punkt des Kreises. Drücken Sie den Softkey Tasterposition lesen [image]. Es wird ein kreisförmiger Bereich auf der Fläche mit den gelernten Punkten in Maschinenkoordinaten, die den Antastbereich definieren, aufgezeichnet.

  6. Drücken Sie den Softkey Lernen und Erstellen eines Befehls [image] und führen Sie das Überwachungsprogramm im DCC-Modus aus. Mit diesen drei festgelegten Punkten, die die Begrenzungen für das Kreiselement angeben, wird NC Gage automatisch innerhalb des Kreises Messpunkte aufnehmen, wie unter Verwendung der drei aufgenommenen Messpunkte an den gelb-markierten Positionen P1, P2 und P3 sowie des in rot dargestellten Antastweges weiter unten zu sehen ist:

Definieren einer Ebene unter Verwendung von drei Verfahrpositionen (P1, P2, P3), einer abgeschrägten Arbeitsfläche und einem kreisförmigen Muster.

Die theoretischen Werte für den Mitten-, Normalen- und den Antast-Bereich werden nach dem Antasten aktualisiert. Sobald die Ebene erlernt wurde, erfolgt die Messung entlang der tatsächlichen Ebenennormalen.

  7. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird der Messroutine hinzugefügt.

'NC-Gage'-spezifischer Elementpfad und dessen logischer Aufbau in diesem Programm

Ebenenelementpfad erlernen (Gitter)

  • Lesen Sie die Tasterposition über der ersten Ecke des Ebenengitters. Dadurch wird die Höhe der erlernten Vorhaltepunkte definiert.

  • Lesen Sie die Tasterposition über der zweiten Ecke des Ebenengitters.

  • Wenn sich der Taster unterhalb der Sicherheitsebenenhöhe befindet, dann fahren Sie hoch auf Sicherheitsebenenhöhe.

  • Fahren Sie zum Punkt über dem ersten Lesepunkt.

  • Absenken bis zum ersten Lesepunkt.

  • Fläche messen; Suchabstand ist der vierfache Vorhalteabstand.

  • Messen Sie jeden Punkt des Gitters, indem Sie am Ende einer jeden Zeile des Gitters die Richtung wechseln

  • Fahren Sie hoch auf Sicherheitsebenenhöhe.

Ebenenelementpfad erlernen (Kreis)

  • Lesen Sie die Tasterposition über der ersten Seite des Ebenenkreises. Dadurch wird die Höhe der erlernten Vorhaltepunkte definiert.

  • Lesen Sie die Tasterposition oberhalb vom gegenüberliegenden Punkt des kreisförmigen Musters.

  • Wenn sich der Taster unterhalb der Sicherheitsebenenhöhe befindet, dann fahren Sie hoch auf Sicherheitsebenenhöhe.

  • Fahren Sie zum Punkt über dem ersten Lesepunkt.

  • Absenken bis zum ersten Lesepunkt.

  • Fläche messen; Suchabstand ist der vierfache Vorhalteabstand.

  • Messen Sie jeden Punkt auf dem Kreis.

  • Fahren Sie hoch auf Sicherheitsebenenhöhe.

Ebenenelementpfad ausführen (Gitter)

  • Wenn sich der Taster unterhalb der Sicherheitsebenenhöhe befindet, dann fahren Sie hoch auf Sicherheitsebenenhöhe.

  • Fahren Sie zum Punkt über dem ersten Gitterpunkt.

  • Absenken bis zum Vorhalteabstand über der Nennebene.

  • Fläche messen; Suchabstand ist der zweifache Vorhalteabstand.

  • Messen Sie jeden Punkt des Gitters, indem Sie am Ende einer jeden Zeile des Gitters die Richtung wechseln

  • Wenn die lokale Sicherheitsebene aktiviert ist, fahren Sie zwischen jedem Punkt zur lokalen Sicherheitsebene, um zum nächsten Punkt des Vorhaltebereichs zu gelangen.

  • Fahren Sie hoch auf Sicherheitsebenenhöhe.

Ebenenelementpfad ausführen (Kreis)

  • Wenn sich der Taster unterhalb der Sicherheitsebenenhöhe befindet, dann fahren Sie hoch auf Sicherheitsebenenhöhe.

  • Fahren Sie zum Punkt über dem ersten Kreispunkt.

  • Absenken bis zum Vorhalteabstand über der Nennebene.

  • Fläche messen; Suchabstand ist der zweifache Vorhalteabstand.

  • Messen Sie jeden Punkt auf dem Kreis gegen den Uhrzeigersinn.

  • Wenn die lokale Sicherheitsebene aktiviert ist, fahren Sie zwischen jedem Punkt zur lokalen Sicherheitsebene, um zum nächsten Punkt des Vorhaltebereichs zu gelangen.

  • Fahren Sie hoch auf Sicherheitsebenenhöhe.


Linie

Home > Anwenden von PC-DMIS NC Gage > Erstellen von Elementbefehlen > Linie

Messen Linie

So erstellen Sie einen Befehl Gerade:

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Vorwärts [image], um die zweite Seite der Softkeys aufzurufen.

  3. Drücken Sie den Softkey Gerade [image], um das Fenster Gerade messen aufzurufen:

  4. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, grafisch angezeigt.

Bereich "Eigenschaften-Definition"

  • Anzahl der Punkte - Definiert die Anzahl der Punkte, die für die Gerade während der Ausführung abgetastet werden.

Hinweis: Die nachfolgenden beiden Eigenschaften sind nur dann sichtbar, wenn das Kontrollkästchen Lernen mit Hilfe von Werten auf dem Bildschirm im Bereich Optionale Einstellungen ausgewählt ist:

  • Länge - Definiert die Länge der Zeile.

  • "Rechte” Seite messen - Bei Einstellung "Rechte" Seite messen der Geraden wird bestimmt, in welcher Richtung angetastet werden soll, indem festgelegt wird, auf welcher Seite der Geraden sich die Materialseite befindet. Wenn dieses Feld aktiviert ist, sollte sich das Material auf der "rechten” Seite der Geraden befinden, wenn vom ersten bis zum letzten gemessenen Punkt gefahren wird. Wenn sich das Material auf der "linken” Seite der Geraden befindet, während vom ersten bis zum letzten gemessenen Punkt gefahren wird, dann sollte dieses Feld deaktiviert sein.

Bereich "Bewegungsparameter"

  • Vorhalteabstand - Definiert den Abstand weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchabstand - Definiert die Entfernung, die der Taster zurücklegt, während er im Lernmodus die Fläche sucht. (Nicht verfügbar, wenn die im Bereich "Optionale Einstellungen" beschriebene Option Lernen unter Verwendung von Werten auf dem Bildschirm ausgewählt ist.)

Bereich "Optionale Einstellungen"

  • Messpunkt Sicherh.-Ebene - Durch Auswahl dieser Option wird der Taster veranlasst, zwischen jedem Elementmesspunkt zu einer Sicherheitsebene zu fahren. Geben Sie in der rechten Box den Abstand zur Ebene ein. Diese Ebene ist nicht die Sicherheitsebene der Messroutine. Detaillierte Informationen finden Sie unter Messpunkt Sicherheitsebene.

  • Lernen, dann messen - Durch Auswahl dieser Option wird die Maschine veranlasst, die Position des Werkstückes unter Verwendung standardmäßiger Parameter zu erlernen und dann das Element mit den im Fenster gesetzten Eigenschaften sofort neu zu messen. Wird dazu verwendet, alle eingestellten Parameter zu testen, wodurch eine genauere und verlässlichere 'Erstmusterprüfung' gewährleistet wird.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Hierdurch hat der Benutzer die Möglichkeit, die theoretischen Werte des Elements einzugeben und das Element vom Programm an dieser Position messen zu lassen. (Durch die Aktivierung dieser Option sind zusätzliche Funktionen im Bereich "Eigenschaften" verfügbar, aber die Option Suchabstand im Bereich "Bewegungsparameter" wird deaktiviert.)

Bereich "Parameter"

  • Nennwert (XYZ-Nennwert) - Definiert die theoretische Position des Startpunktes.

  • Messwert (XYZ-Messwert) - Blendet die gemessene Position des Startpunktes ein.

  • Winkel auf X - Definiert den Vektorwinkel der Gerade. Dies ist die Richtung der Geraden im Verhältnis zur X-Achse.

Bereich "3-Achsen-Protokollierung"

Es gibt drei Verfahren für die Bestimmung des XYZ-Punktes mit Hilfe der 3-Achsen-Protokollierung.

  • Wählen Sie einen gemessenen Punkt oder eine gemessene Ebene aus, um die Höhe des gemessenen Elements zu bestimmen.

  • Geben Sie die zu verwendende, richtungsabhängige Ebenenhöhe ein. Diese Höhe ist relativ zum Werkstücknullpunkt und wird entlang des Tastervektors gemessen.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zum vorherigen Schritt zurückkehren Dadurch werden die zuletzt erlernten Tasterpositionen entfernt. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Lernen und Erstellen eines Befehls Dieser Softkey ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Das Element kann vor der Übergabe an die Messroutine geändert und getestet werden. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Toleranzeinstellungen Mit diesem Softkey können Sie die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Bewegungspunkt einfügen Mit diesem Softkey wird die aktuelle Position des Tasters eingelesen und als eine Sicherheitsebenenbewegung in die Messroutine eingefügt.
Bestätigen / Befehl hinzufügen Für Arbeitsgänge bestätigt dies die Auswahl. Für Befehle wird damit der Befehl am Ende der Messroutine hinzugefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.

Lernvorgang

  1. Positionieren Sie den Taster neben dem ersten Punkt der Geraden, wie in der Abbildung unten unter Position A veranschaulicht.

  2. Drücken Sie den Softkey Position lesen [image] . Die Tastspitzenposition wird als Startposition eingelesen. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image] , um diese Messposition abzubrechen.

  3. Positionieren Sie den Taster neben den zweiten Punkt der Geraden, wie in der Abbildung unten unter Punkt B veranschaulicht.

  4. Drücken Sie den Softkey Position lesen [image]. Die Tastspitzenposition wird als Startposition eingelesen. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image] , um diese Messposition abzubrechen.

  5. Fahren Sie den Taster weg vom zweiten Punkt.

  6. Drücken Sie den Softkey Position lesen [image].

  7. Positionieren Sie den Taster für die automatische Messung und drücken Sie den Softkey Lernen und Erstellen eines Befehls [image] . NC Gage nimmt Messpunkte auf die gleiche Weise, wie weiter unten dargestellt, automatisch auf.

Die linke Abbildung gibt die Positionen (A-C), zu denen der Taster manuell gerückt werden soll, an. Die rechte Abbildung zeigt den automatischen Antastweg (rote Linien) und die Punktpositionen (1-2).

  8. Nachdem das Element gemessen wurde, werden die gemessenen Werte aktualisiert. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird der Messroutine hinzugefügt.

'NC-Gage'-spezifischer Elementpfad und dessen logischer Aufbau in diesem Programm

Geradenelementpfad lernen

  • Tasterposition neben erstem Punkt lesen; dadurch wird die Messhöhe definiert.

  • Tasterposition über zweitem Punkt lesen; dadurch wird die Richtung der Geraden definiert.

  • Tasterposition nach Rückzug des Tasters von der Geraden lesen; dadurch wird die Materialrichtung definiert.

  • Wenn sich der Taster unterhalb der Sicherheitsebenenhöhe befindet, dann fahren Sie hoch auf Sicherheitsebenenhöhe.

  • Fahren Sie zum Punkt über dem ersten Lesepunkt.

  • Absenken bis zum ersten Lesepunkt.

  • Fläche messen; Suchabstand ist der vierfache Vorhalteabstand.

  • Messen Sie jeden Punkt auf der Geraden auf die gleiche Weise.

  • Fahren Sie hoch auf Sicherheitsebenenhöhe.

Elementpfad Gerade ausführen

  • Wenn sich der Taster unterhalb der Sicherheitsebenenhöhe befindet, dann fahren Sie hoch auf Sicherheitsebenenhöhe.

  • Fahren Sie zum Punkt über dem ersten Vorhaltepunkt.

  • Senken Sie ab zum ersten Vorhaltepunkt.

  • Fläche messen; Suchabstand ist der zweifache Vorhalteabstand.

  • Messen Sie jeden Punkt auf der Geraden auf die gleiche Weise.

  • Wenn die lokale Sicherheitsebene aktiviert ist, fahren Sie zwischen jedem Punkt zur lokalen Sicherheitsebene, um zum nächsten Punkt des Vorhaltebereichs zu gelangen.

  • Fahren Sie hoch auf Sicherheitsebenenhöhe.


Zylinder (Bohrung)

Home > Anwenden von PC-DMIS NC Gage > Erstellen von Elementbefehlen > Zylinder (Bohrung)

Zylinder messen (Bohrung)

So erstellen Sie einen Befehl Zylinder (Bohrung):

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Vorwärts [image], um die zweite Seite der Softkeys aufzurufen.

  3. Drücken Sie den Softkey Zylinder (Bohrung) [image], um das Fenster "Zylinder messen (Bohrung)" aufzurufen:

  4. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, grafisch angezeigt.

Bereich "Eigenschaften"

  • Punkte pro Ebene - Definiert die Anzahl der Punkte pro Ebene, die für den Zylinder während der Ausführung (und nicht während des Lernmodus') abgetastet werden.

  • Anzahl der Ebenen - Definiert die Anzahl der Punkte, die in einer Ebene während der Ausführung (und nicht während des Lernmodus') abgetastet werden.

  • Startwinkel - Definiert den Startpunkt für einen zu messenden Zylinderabschnitts. Drehung beginnt bei 0 entlang der primären Achse und wächst, so dass die Nebenachse auf 90 steht. Die Primärachse ist X in der XY-Arbeitsfläche, Y in der YZ-Arbeitsfläche und Z in der ZX-Arbeitsfläche. Die Nebenachse ist Y in der XY-Arbeitsfläche, Z in der YZ-Arbeitsfläche und X in der ZX-Arbeitsfläche.

  • Endwinkel - Definiert das Ende des zu messenden Zylinderabschnitts. Die Start- und Endwinkel werden nur dann verwendet, wenn das Element im Ausführmodus gemessen wird. Im Lernmodus werden Messpunkte automatisch in gegenüberliegenden Primär- und Sekundärachsrichtungen aufgenommen. Wenn der Zylinder nicht volle 360 Grad umfasst, dann kann die Option Lernen mit Hilfe der Werte auf dem Bildschirm zur Eingabe der theoretischen Position mit einem korrekt definierten Start- und Endwinkel verwendet werden. NC Gage misst das Element daraufhin bei ausgewählter Option Lernen, dann messen.

Hinweis: Die folgenden zwei Eigenschaften sind nur verfügbar, wenn das Kontrollkästchen Lernen mit Hilfe der Werte auf dem Bildschirm im Bereich Optionale Einstellungen aktiviert ist.

  • Oberhöhe - Die Achsenposition der Messwerte auf der Oberseite der Zylindermessung. Sie bezieht sich auf den aktuellen Arbeitsversatz entlang der Achse, die der Mittellinie des Zylinders am besten entspricht.

  • Bodenhöhe - Die Achsenposition der Messerwerte auf der Unterseite der Zylindermessung. Sie bezieht sich auf den aktuellen Arbeitsversatz entlang der Achse, die der Mittellinie des Zylinders am besten entspricht.

Hinweis: Die Anzahl der Reihen und Punkte pro Reihe werden entlang des definierten Zylinders gleichmäßig verteilt.

Bereich "Bewegungsparameter"

  • Vorhalteabstand - Definiert den Abstand weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchabstand - Definiert die Entfernung, die der Taster bei der Suche nach dem Werkstück zurücklegt, während sich das Programm im Lernmodus befindet. (Nicht verfügbar, wenn die im Bereich "Optionale Einstellungen" beschriebene Option Lernen unter Verwendung von Werten auf dem Bildschirm ausgewählt ist.)

Bereich "Optionale Einstellungen"

  • Messpunkt Sicherh.-Ebene - Durch Auswahl dieser Option wird der Taster veranlasst, zwischen jedem Elementmesspunkt zu einer Sicherheitsebene zu fahren. Geben Sie in der rechten Box den Abstand zur Ebene ein. Diese Ebene ist nicht die Sicherheitsebene der Messroutine. Detaillierte Informationen finden Sie unter Messpunkt Sicherheitsebene.

  • Lernen, dann messen - Durch Auswahl dieser Option wird die Maschine veranlasst, die Position des Werkstückes unter Verwendung standardmäßiger Parameter zu erlernen und dann das Element mit den im Fenster gesetzten Eigenschaften sofort neu zu messen. Wird dazu verwendet, alle eingestellten Parameter zu testen, wodurch eine genauere und verlässlichere 'Erstmusterprüfung' gewährleistet wird.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Hierdurch hat der Benutzer die Möglichkeit, die theoretischen Werte des Elements einzugeben und das Element vom Programm an dieser Position messen zu lassen. (Durch die Aktivierung dieser Option sind zusätzliche Funktionen im Bereich Eigenschaften verfügbar, aber die Option Suchabstand im Bereich Bewegungsparameter wird deaktiviert.)

Bereich "Parameter"

  • XYZ-Nennwert - Definiert die theoretische Position des Zylinders.

  • XYZ-Messwert - Blendet die gemessene Position des Zylinders ein.

  • Durchmesser (Nennwert) - Definiert den theoretischen Durchmesser des Zylinders.

  • Durchmesser (Messwert) - Zeigt den gemessenen Durchmesser des Zylinders an.

  • Winkel zu Z - Definiert den ersten Vektorwinkel des Zylinders. Hierbei handelt es sich um die Richtung der Mittellinie des Zylinders im Verhältnis zur Arbeitsfläche. Der zulässige Bereich liegt zwischen -90 und +90 Grad.

  • Winkel zu X - Definiert den zweiten Vektorwinkel des Zylinders. Hierbei handelt es sich um die Richtung der Mittellinie des Zylinders im Verhältnis zur primären Achse, in der er gemessen wird. Die Primärachse ist X in der XY-Arbeitsfläche, Y in der YZ-Arbeitsfläche und Z in der ZX-Arbeitsfläche. Der zulässige Bereich liegt zwischen 0 (Null) und -360 Grad.

Hinweis: Winkel zu Z und Winkel zu X stehen in Beziehung zueinander - ein unzulässiger Wert (90.0, 20.0) wird als (90.0, 0.0) definiert.

Bereich "3-Achsen-Protokollierung"

Die 3-Achsen Protokollierung kann auf 3 Arten zur Definition des XYZ-Punktes verwendet werden.

  • Wählen Sie einen gemessenen Punkt oder eine gemessene Ebene aus, um die Höhe des gemessenen Elements zu bestimmen.

  • Geben Sie die richtungsweisende Höhe der zu verwendenden Ebene ein. Diese Höhe ist relativ zum Werkstücknullpunkt und wird entlang des Tastervektors gemessen.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zum vorherigen Schritt zurückkehren Dieser Softkey löscht die zuletzt erlernten Tasterpositionen. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Lernen und Erstellen eines Befehls (Ausführen) Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Bewegungspunkt einfügen Dieser Softkey liest die aktuelle Position des Tasters und fügt eine Sicherheitsbewegung in die Messroutine ein.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.

Lernvorgang

  1. Positionieren Sie den Taster in den Zylinder hinein (weg von der Arbeitsfläche) in die Mitte der unteren Ebene, so wie in der unten stehenden Abbildung unter "A" veranschaulicht.

  2. Drücken Sie den Softkey Position lesen [image].

  3. Positionieren Sie den Taster in die Mitte der oberen Ebene und drücken Sie den Softkey Position lesen [image].

  4. Drücken Sie den Softkey Lernen und Erstellen eines Befehls [image]. NC Gage nimmt Messpunkte auf die gleiche Weise, wie weiter unten dargestellt, automatisch auf.

Pfad der Zylinderbohrung: A-B) Ausrichtungspositionen 1-4) automatisch gemessene Punktpositionen. Die roten Linien stellen den Messweg dar.

  5. Nachdem das Element gemessen wurde, werden die gemessenen Werte aktualisiert. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird der Messroutine hinzugefügt.

Nachfolgend handelt es sich um den 'NC-Gage'-spezifischen Elementpfad und logischen Aufbau in NC Gage:

Elementpfad Zylinderbohrung lernen

  • Tasterposition in der Mitte der unteren Ebene der Bohrung lesen; dadurch wird die Mitte der Bohrung und die erste Ebenenhöhe für die Ausführungszeit definiert.

  • Tasterposition in der Mitte der oberen Bohrungsebene lesen; dadurch wird die letzte Ebenenhöhe für die Ausführungszeit definiert. Der Höhenwert wird zum Lernen der Zylinderbohrung verwendet.

  • Messen Sie den Punkt in '+X'-Richtung unter Verwendung des Suchabstandes.

  • Kehren Sie zur Mittenposition zurück.

  • Messen Sie den Punkt in '-X'-Richtung unter Verwendung des Suchabstandes.

  • Kehren Sie zur Mittenposition zurück.

  • Messen Sie den Punkt in '+Y'-Richtung unter Verwendung des Suchabstandes.

  • Kehren Sie zur Mittenposition zurück.

  • Messen Sie den Punkt in '-Y'-Richtung unter Verwendung des Suchabstandes.

  • Kehren Sie zur Mittenposition zurück.

Elementpfad Zylinder-Bohrung ausführen

  • Vorhalteradius definieren = Radius der Bohrung - Vorhalteabstand - Tasterradius.

  • Zielradius definieren = Radius der Bohrung + Vorhalteabstand - Tasterradius.

  • Wenn die aktuelle Position unterhalb der Sicherheitsebenenhöhe liegt, dann fahren Sie hoch zur Sicherheitsebene.

  • Fahren Sie zur Position über dem ersten Punkt des Vorhaltebereichs. Dieser Punkt liegt um die Länge des Vorhalteradius in Richtung des Startwinkels von der Mitte der Bohrung entfernt.

  • Absenken bis zur untersten Messebene.

  • Punkt messen; Ziel ist Zielradius vom Mittelpunkt der Bohrung entlang des Winkels.

  • Zurückziehen und zum Vorhaltebereich des nächsten Punktes fahren.

  • Punkt messen; Ziel ist Zielradius vom Mittelpunkt der Bohrung entlang des Winkels.

  • Fahren Sie mit der Messung der angegebenen Anzahl von Punkten vom Startwinkel bis zum Endwinkel fort.

  • Messen Sie die andere(n) Ebene(n), wobei Sie die Punkte in abwechselnden Richtungen aufnehmen.

  • Wenn die lokale Sicherheitsebene aktiviert ist, fahren Sie zwischen jedem Punkt zur lokalen Sicherheitsebene, um zum nächsten Punkt des Vorhaltebereichs zu gelangen.

  • Nachdem der letzte Punkt gemessen ist, wird der Taster zur Sicherheitsebenenhöhe hochgefahren.


Zylinder

Home > Anwenden von PC-DMIS NC Gage > Erstellen von Elementbefehlen > Zylinder

Zylinder messen (Zapfen)

So erstellen Sie einen Befehl "Zylinder (Ausstülpung)"

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Vorwärts [image], um die zweite Seite der Softkeys aufzurufen.

  3. Drücken Sie den Softkey Zylinder (Ausstülpung) [image], um das Fenster Zylinder messen (Ausstülpung) aufzurufen:

  4. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, grafisch angezeigt.

Bereich "Eigenschaften"

  • Anzahl pro Ebene - Definiert die Anzahl der Punkte pro Ebene, die für den Zylinder während der Ausführung (und nicht während des Lernmodus') abgetastet werden.

  • Anzahl der Ebenen - Definiert die Anzahl der Punkte pro Ebene die während der Ausführung (und nicht während des Lernmodus') gemessen werden.

  • Startwinkel - Definiert den Startpunkt für einen zu messenden Zylinderabschnitts. Drehung beginnt bei 0 entlang der primären Achse und wächst, so dass die Nebenachse auf 90 steht. Die Primärachse ist X in der XY-Arbeitsfläche, Y in der YZ-Arbeitsfläche und Z in der ZX-Arbeitsfläche. Die Sekundärachse ist Y in der XY-Arbeitsfläche, Z in der YZ-Arbeitsfläche und X in der ZX-Arbeitsfläche.

  • Endwinkel - Definiert das Ende des zu messenden Zylinderabschnitts. Die Start- und Endwinkel werden nur dann verwendet, wenn das Element im Ausführmodus gemessen wird. Im Lernmodus werden Messpunkte automatisch in gegenüberliegenden Primär- und Sekundärachsrichtungen aufgenommen. Wenn der Zylinder nicht volle 360 Grad umfasst, dann kann die Option Lernen mit Hilfe der Werte auf dem Bildschirm zur Eingabe der theoretischen Position mit einem korrekt definierten Start- und Endwinkel verwendet werden. NC Gage misst das Element daraufhin bei ausgewählter Option Lernen, dann messen.

Hinweis: Die folgenden zwei Eigenschaften sind nur verfügbar, wenn das Kontrollkästchen Lernen mit Hilfe der Werte auf dem Bildschirm im Bereich Optionale Einstellungen aktiviert ist.

  • Oberhöhe - Damit wird die Achsenposition der Messwerte auf der Oberseite der Zylindermessung definiert. Sie bezieht sich auf den aktuellen Arbeitsversatz entlang der Achse, die der Mittellinie des Zylinders am besten entspricht.

  • Bodenhöhe - Damit wird die Achsenposition der Messerwerte auf der Unterseite der Zylindermessung definiert. Sie bezieht sich auf den aktuellen Arbeitsversatz entlang der Achse, die der Mittellinie des Zylinders am besten entspricht.

Hinweis: Die Anzahl der Reihen und Punkte pro Reihe werden entlang des definierten Zylinders gleichmäßig verteilt.

Bereich "Bewegungsparameter"

  • Vorhalteabstand - Definiert den Abstand weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchabstand - Definiert die Entfernung, die der Taster bei der Suche nach dem Werkstück zurücklegt, während sich das Programm im Lernmodus befindet. (Nicht verfügbar, wenn die im Bereich "Optionale Einstellungen" beschriebene Option Lernen unter Verwendung von Werten auf dem Bildschirm ausgewählt ist.)

Bereich "Optionale Einstellungen"

  • Messpunkt Sicherh.-Ebene - Durch Auswahl dieser Option wird der Taster veranlasst, zwischen jedem Elementmesspunkt zu einer Sicherheitsebene zu fahren. Geben Sie in der rechten Box den Abstand zur Ebene ein. Diese Ebene ist nicht die Sicherheitsebene der Messroutine. Detaillierte Informationen finden Sie unter Messpunkt Sicherheitsebene.

  • Lernen, dann messen - Durch Auswahl dieser Option wird die Maschine veranlasst, die Position des Werkstückes unter Verwendung standardmäßiger Parameter zu erlernen und dann das Element mit den im Fenster gesetzten Eigenschaften sofort neu zu messen. Wird dazu verwendet, alle eingestellten Parameter zu testen, wodurch eine genauere und verlässlichere 'Erstmusterprüfung' gewährleistet wird.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Hierdurch können Sie die theoretischen Werte des Elements eingeben und das Element vom Programm an dieser Position messen lassen. (Durch die Aktivierung dieser Option sind zusätzliche Funktionen im Bereich "Eigenschaften" verfügbar, aber die Option Suchabstand im Bereich Bewegungsparameter wird deaktiviert.)

Bereich "Parameter"

  • XYZ-Nennwert - Definiert die theoretische Position des Zylinders.

  • XYZ-Messwert - Blendet die gemessene Position des Zylinders ein.

  • Durchmesser (Nennwert) - Definiert den theoretischen Durchmesser des Zylinders.

  • Durchmesser (Messwert) - Zeigt den gemessenen Durchmesser des Zylinders an.

  • Winkel zu Z - Definiert den ersten Vektorwinkel des Zylinders. Hierbei handelt es sich um die Richtung der Mittellinie des Zylinders im Verhältnis zur Arbeitsfläche. Der zulässige Bereich liegt zwischen -90 und +90 Grad.

  • Winkel zu X - Definiert den zweiten Vektorwinkel des Zylinders. Hierbei handelt es sich um die Richtung der Mittellinie des Zylinders im Verhältnis zur primären Achse, in der er gemessen wird. Die Primärachse ist X in der XY-Arbeitsfläche, Y in der YZ-Arbeitsfläche und Z in der ZX-Arbeitsfläche. Der zulässige Bereich liegt zwischen 0 (Null) und -360 Grad.

Hinweis: Winkel zu Z und Winkel zu X stehen in Beziehung zueinander - ein unzulässiger Wert (90.0, 20.0) wird als (90.0, 0.0) definiert.

Bereich "3-Achsen-Protokollierung"

Die 3-Achsen Protokollierung kann auf 3 Arten zur Definition des XYZ-Punktes verwendet werden.

  • Wählen Sie einen gemessenen Punkt oder eine gemessene Ebene aus, um die Höhe des gemessenen Elements zu bestimmen.

  • Geben Sie die zu verwendende, richtungsabhängige Ebenenhöhe ein. Diese Höhe ist relativ zum Werkstücknullpunkt und wird entlang des Tastervektors gemessen.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zum vorherigen Schritt zurückkehren Dadurch werden die zuletzt erlernten Tasterpositionen entfernt. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Fenster Messroutine bearbeiten löschen.
Lernen und Erstellen eines Befehls Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Sie veranlasst die Maschine, das Element zu messen. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Das Element kann vor der Übergabe an die Messroutine geändert und getestet werden. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Toleranzeinstellungen Mit diesem Softkey können Sie die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Bewegungspunkt einfügen Liest die aktuelle Position des Tasters und fügt sie als eine Sicherheitsebenenbewegung in die Messroutine ein.
Bestätigen / Befehl hinzufügen Für Arbeitsgänge bestätigt dies die Auswahl. Für Befehle wird damit der Befehl am Ende der Messroutine hinzugefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die Nominalwerte des Elements eingegeben haben. Für erstellte und Merkmalselemente wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.

Lernvorgang

  1. Positionieren Sie den Taster in die Nähe der Fläche an der unteren Ebene und drücken Sie den Softkey Position lesen [image] . Dies wird die Position für die "untere" Ebene.

  2. Positionieren Sie den Taster in die Nähe der Fläche auf der oberen Ebene und drücken Sie den Softkey Position lesen [image] . Dies wird die Position für die "obere" Ebene.

  3. Positionieren Sie den Taster in sichere Höhe über die Mitte der Ausstülpung und drücken Sie dann den Softkey Position lesen [image].

  4. Drücken Sie den Softkey Lernen und Erstellen eines Befehls [image]. NC Gage nimmt einen Messpunkt an dieser Position auf, um die Höhe der Ausstülpung zu bestimmen. Dann werden Messpunkte auf die gleiche Weise, wie weiter unten dargestellt, automatisch aufgenommen.

Pfad der Zylinderausstülpung: A-B) manuell gemessene Positionen C) Ausrichtungspositionen 1-4) automatisch gemessene Punktpositionen. Rote Linien zeigen den Pfad für die untere Ebene. Die obere Ebene wird unter Verwendung gleicher Bahngeraden gemessen.

  5. Nachdem das Element gemessen wurde, werden die gemessenen Werte aktualisiert. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird der Messroutine hinzugefügt.

Nachfolgend handelt es sich um den 'NC-Gage'-spezifischen Elementpfad und logischen Aufbau in NC Gage:

Elementpfad Zylinderausstülpung lernen

  • Tasterposition neben der Seite der Ausstülpung an unterster Ebene lesen; Z-Wert wird zur Messhöhe der ersten Ebene.

  • Tasterposition neben der Seite der Ausstülpung an höchster Ebene lesen; Z-Wert wird zur Messhöhe der letzten Ebene. Dieser Höhenwert wird auch zum Lernen des Zylinders verwendet.

  • Tasterposition über dem Mittelpunkt der Ausstülpung lesen; XY-Werte definieren Mitte; Z-Wert ist sichere Höhe.

  • Vorhalteradius = projizierter 2D-Abstand zwischen erster und dritter Lesepunktposition.

  • Auf sichere Höhe fahren.

  • Auf sichere Höhe zu einem Punkt über Vorhaltepunkt 1, der den Vorhalteradius von der Mitte in +X darstellt, fahren.

  • Absenken bis auf Messhöhe.

  • Punkt messen, Ziel ist Mitte an Messhöhe.

  • Auf sichere Höhe fahren.

  • Auf sichere Höhe zu einem Punkt über Vorhaltepunkt 2, der den Vorhalteradius von der Mitte in -X darstellt, fahren.

  • Absenken bis auf Messhöhe.

  • Punkt messen, Ziel ist Mitte an Messhöhe.

  • Auf sichere Höhe fahren.

  • In sicherer Höhe zu einem Punkt über Vorhaltepunkt 3, der den Vorhalteradius von der Mitte in +Y darstellt, fahren.

  • Absenken bis auf Messhöhe.

  • Punkt messen, Ziel ist Mitte an Messhöhe.

  • Auf sichere Höhe fahren.

  • Auf sichere Höhe zu einem Punkt über Vorhaltepunkt 4, der den Vorhalteradius von der Mitte in -Y darstellt, fahren.

  • Absenken bis auf Messhöhe.

  • Punkt messen, Ziel ist Mitte an Messhöhe.

  • Auf sichere Höhe fahren.

Elementpfad Zylinder-Ausstülpung ausführen

  • Vorhalteradius definieren = Radius der Ausstülpung + Vorhalteabstand + Tasterradius.

  • Zielradius definieren = Radius der Ausstülpung - Vorhalteabstand - Tasterradius, wenn dieser < 0 ist, dann auf 0 setzen.

  • Wenn die aktuelle Position unterhalb der Sicherheitsebenenhöhe liegt, dann fahren Sie hoch zur Sicherheitsebene.

  • Fahren Sie zur Position über dem ersten Punkt des Vorhaltebereichs. Dieser Punkt liegt um die Länge des Vorhalteradius in Richtung des Startwinkels von der Mitte der Ausstülpung entfernt.

  • Absenken bis zur Messebene.

  • Messen Sie die unterste Ebene mit dem Vorhalteradius und dem Zielradius. Führen Sie zusätzliche Bewegungen durch, um je nach Bedarf um die Ausstülpung herum zu gelangen, damit jeder Vorhaltepunkt erreicht wird. Fahren Sie damit solange fort, bis der Endwinkel erreicht ist.

  • Messen Sie die verbleibende(n) Ebene(n), wobei Sie die Punkte in abwechselnden Richtungen aufnehmen.

  • Wenn die lokale Sicherheitsebene aktiviert ist, fahren Sie zwischen jedem Punkt zur lokalen Sicherheitsebene, um zum nächsten Punkt des Vorhaltebereichs zu gelangen.

  • Nachdem der letzte Punkt gemessen ist, wird der Taster zur Sicherheitsebenenhöhe hochgefahren.


Kegel (Innen)

Home > Anwenden von PC-DMIS NC Gage > Erstellen von Elementbefehlen > Kegel (Innen)

Kegel messen (Innen)

So erstellen Sie einen Befehl 'Kegel (Innen)':

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Vorwärts [image], um die zweite Seite der Softkeys aufzurufen.

  3. Drücken Sie den Softkey Kegel (Innen) [image], um das Fenster Kegel messen (Innen) aufzurufen:

  4. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, grafisch angezeigt.

Bereich "Eigenschaften"

  • Anzahl pro Ebene - Definiert die Anzahl der Punkte pro Ebene, die der Taster für die Messung des Kegels während der Ausführung (und nicht während des Lernmodus') verwendet.

  • Anzahl der Ebenen - Definiert die Anzahl der Ebenen, die für die Messung des Kegels während der Ausführung (und nicht während des Lernmodus') verwendet werden.

  • Startwinkel - Definiert den Startpunkt für einen zu messenden Kegelabschnitt. Drehung beginnt bei 0 entlang der primären Achse und wächst, so dass die Nebenachse auf 90 steht. Die Primärachse ist X in der XY-Arbeitsfläche, Y in der YZ-Arbeitsfläche und Z in der ZX-Arbeitsfläche. Die Sekundärachse ist Y in der XY-Arbeitsfläche, Z in der YZ-Arbeitsfläche und X in der ZX-Arbeitsfläche.

  • Endwinkel - Definiert den Endpunkt für einen zu messenden Kegelabschnitt. Die Start- und Endwinkel werden nur dann verwendet, wenn das Element im Ausführmodus gemessen wird. Im Lernmodus werden Messpunkte automatisch in gegenüberliegenden Primär- und Sekundärachsrichtungen aufgenommen. Wenn der Kreis nicht die ganzen 360 Grad beschreibt, kann über die Option Lernen mit Hilfe der Werte auf dem Bildschirm die theoretische Position mit einem genau definierten Start- und Endwinkel eingegeben werden. NC Gage misst das Element daraufhin bei ausgewählter Option Lernen, dann messen.

Hinweis: Die folgenden zwei Eigenschaften sind nur verfügbar, wenn das Kontrollkästchen Lernen mit Hilfe der Werte auf dem Bildschirm im Bereich Optionale Einstellungen aktiviert ist.

  • Oberhöhe - Die Achsenposition der Messwerte auf der Oberseite der Kegelmessung. Sie bezieht sich auf den aktuellen Arbeitsversatz entlang der Achse, der der Mittellinie des Kegels am besten entspricht.

  • Bodenhöhe - Die Achsenposition der Messerwerte auf der Unterseite der Kegelmessung. Sie bezieht sich auf den aktuellen Arbeitsversatz entlang der Achse, der der Mittellinie des Kegels am besten entspricht.

Hinweis: Die Anzahl der Reihen und Punkte pro Reihe werden in gleichmäßigen Abständen entlang des vorgegebenen Kegels verteilt.

Bereich "Bewegungsparameter"

  • Vorhalteabstand - Definiert den Abstand weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchabstand - Definiert die Entfernung, die der Taster bei der Suche nach dem Werkstück zurücklegt, während sich das Programm im Lernmodus befindet. (Nicht verfügbar, wenn die im Bereich "Optionale Einstellungen" beschriebene Option Lernen unter Verwendung von Werten auf dem Bildschirm ausgewählt ist.)

Bereich "Optionale Einstellungen"

  • Messpunkt Sicherh.-Ebene - Durch Auswahl dieser Option wird der Taster veranlasst, zwischen jedem Elementmesspunkt zu einer Sicherheitsebene zu fahren. Geben Sie in der rechten Box den Abstand zur Ebene ein. Diese Ebene ist nicht die Sicherheitsebene der Messroutine. Detaillierte Informationen finden Sie unter Messpunkt Sicherheitsebene.

  • Lernen, dann messen - Durch Auswahl dieser Option wird die Maschine veranlasst, die Position des Werkstückes unter Verwendung standardmäßiger Parameter zu erlernen und dann das Element mit den im Fenster gesetzten Eigenschaften sofort neu zu messen. Wird dazu verwendet, alle eingestellten Parameter zu testen, wodurch eine genauere und verlässlichere 'Erstmusterprüfung' gewährleistet wird.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Hierdurch hat der Benutzer die Möglichkeit, die theoretischen Werte des Elements einzugeben und das Element vom Programm an dieser Position messen zu lassen. (Durch die Aktivierung dieser Option sind zusätzliche Funktionen im Bereich Eigenschaften verfügbar, aber die Option Suchabstand im Bereich Bewegungsparameter wird deaktiviert.)

Bereich "Parameter"

  • Nennwert (XYZ-Nennwert) - Definiert die theoretische Position der Kegelmitte.

  • Messwert (XYZ-Messwert) - Blendet die gemessene Position des Kegels ein.

  • Halb-Winkel - Der Winkel, der von der Kegelseite mit der Mittellinie des Kegels gebildet wird, wird angezeigt.

  • Winkel zu Z - Definiert den ersten Vektorwinkel des Kegels. Hierbei handelt es sich um die Richtung der Mittellinie des Kegels im Verhältnis zur Arbeitsfläche. Der zulässige Bereich liegt zwischen -90 und +90 Grad.

  • Winkel zu X - Definiert den zweiten Vektorwinkel des Kegels. Hierbei handelt es sich um die Richtung der Mittellinie des Kegels im Verhältnis zur primären Achse, in der er gemessen wird. Die Primärachse ist X in der XY-Arbeitsfläche, Y in der YZ-Arbeitsfläche und Z in der ZX-Arbeitsfläche. Der zulässige Bereich liegt zwischen 0 (Null) und -360 Grad.

Hinweis: Vektorwinkel 1 und Vektorwinkel 2 stehen in Beziehung zueinander - ein unzulässiger Wert (90.0, 20.0) wird als (90.0, 0.0) definiert.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zum vorherigen Schritt zurückkehren Dieser Softkey löscht die zuletzt erlernten Tasterpositionen. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Lernen und Erstellen eines Befehls (Ausführen) Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Bewegungspunkt einfügen Dieser Softkey liest die aktuelle Position des Tasters und fügt eine Sicherheitsbewegung in die Messroutine ein.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.

Lernvorgang

  1. Positionieren Sie den Taster in die Mitte der unteren Ebene und drücken Sie den Softkey Position lesen [image]. Die untere Ebene ist die Ebene, die der Kegelspitze am nächsten ist.

  2. Positionieren Sie den Taster in die Mitte der oberen Ebene und drücken Sie den Softkey Position lesen [image].

  3. Positionieren Sie den Taster für die automatische Messung und drücken Sie den Softkey Lernen und Erstellen eines Befehls [image] . NC Gage stellt Messpunkte in ähnlicher Weise, wie weiter unten abgebildet, dar.

    Pfad des Kegels (Innen): A-B) Ausrichtungspositionen 1-8) automatisch gemessene Punktpositionen.

  4. Nachdem das Element gemessen wurde, werden die gemessenen Werte aktualisiert. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird der Messroutine hinzugefügt.

Nachfolgend handelt es sich um den 'NC-Gage'-spezifischen Elementpfad und logischen Aufbau in NC Gage:

Elementpfad Kegel (Innen) lernen

  • Tasterposition in der Mitte der unteren Kegelebene lesen; dadurch wird die XY-Mitte und die erste Ebenenhöhe für die Ausführungszeit definiert.

  • Tasterposition in der Mitte der oberen Bohrungsebene lesen; dadurch wird die letzte Ebenenhöhe für die Ausführungszeit definiert.

  • Fahren Sie zur ersten Lesepunktposition.

  • Messen Sie die unterste Ebene durch Aufnahme von Punkten in den Richtungen +X, -X, +Y und -Y; kehren Sie nach jedem Messvorgang zum unteren Zentrum zurück.

  • Fahren Sie zur Mitte der oberen Ebene.

  • Messen Sie die oberste Ebene durch Aufnahme von Punkten in den Richtungen +X, -X, +Y und -Y; kehren Sie nach jedem Messvorgang zum oberen Zentrum zurück.

Elementpfad Kegel (Innen) ausführen

  • Die Kegelgeometrie wird zur Bestimmung der Anfahr- und Zielpositionen für jeden Messpunkt verwendet.

  • Wenn die aktuelle Position unterhalb der Sicherheitsebenenhöhe liegt, dann fahren Sie hoch zur Sicherheitsebene.

  • Fahren Sie zur Position über dem ersten Punkt des Vorhaltebereichs. Dieser Punkt liegt um die Länge des Vorhalteradius in Richtung des Startwinkels von der Mitte der Bohrung entfernt.

  • Absenken bis zur untersten Messebene.

  • Messen Sie die erste Ebene - vom Startwinkel bis zum Endwinkel.

  • Messen Sie die verbleibende(n) Ebene(n), wobei Sie die Punkte in abwechselnden Richtungen aufnehmen.

  • Wenn die lokale Sicherheitsebene aktiviert ist, fahren Sie zwischen jedem Punkt zur lokalen Sicherheitsebene, um zum nächsten Punkt des Vorhaltebereichs zu gelangen.

  • Nachdem der letzte Punkt gemessen ist, wird der Taster zur Sicherheitsebenenhöhe hochgefahren.


Kegel (Außen)

Home > Anwenden von PC-DMIS NC Gage > Erstellen von Elementbefehlen > Kegel (Außen)

Kegel messen (Außen)

So erstellen Sie einen Befehl Kegel (Außen):

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Vorwärts [image], um die zweite Seite der Softkeys aufzurufen.

  3. Drücken Sie den Softkey Kegel (Außen) [image], um das Fenster Kegel messen (Außen) aufzurufen:

  4. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, grafisch angezeigt.

Bereich "Eigenschaften"

  • Anzahl pro Ebene - Definiert die Anzahl der Punkte pro Ebene, die der Taster für die Messung des Kegels während der Ausführung (und nicht während des Lernmodus') verwendet.

  • Anzahl der Ebenen - Definiert die Anzahl der Ebenen, die für die Messung des Kegels während der Ausführung (und nicht während des Lernmodus') verwendet werden.

  • Startwinkel - Definiert den Startpunkt für einen zu messenden Kegelabschnitt. Drehung beginnt bei 0 entlang der primären Achse und wächst, so dass die Nebenachse auf 90 steht. Die Primärachse ist X in der XY-Arbeitsfläche, Y in der YZ-Arbeitsfläche und Z in der ZX-Arbeitsfläche. Die Sekundärachse ist Y in der XY-Arbeitsfläche, Z in der YZ-Arbeitsfläche und X in der ZX-Arbeitsfläche.

  • Endwinkel - Definiert den Endpunkt für einen zu messenden Kegelabschnitt. Die Start- und Endwinkel werden nur dann verwendet, wenn das Element im Ausführmodus gemessen wird. Im Lernmodus werden Messpunkte automatisch in gegenüberliegenden Primär- und Sekundärachsrichtungen aufgenommen. Wenn der Kreis nicht die ganzen 360 Grad beschreibt, kann über die Option Lernen mit Hilfe der Werte auf dem Bildschirm die theoretische Position mit einem genau definierten Start- und Endwinkel eingegeben werden. NC Gage misst das Element daraufhin bei ausgewählter Option Lernen, dann messen.

Hinweis: Die folgenden zwei Eigenschaften sind nur verfügbar, wenn das Kontrollkästchen Lernen mit Hilfe der Werte auf dem Bildschirm im Bereich Optionale Einstellungen aktiviert ist.

  • Oberhöhe - Die Achsenposition der Messwerte auf der Oberseite der Kegelmessung. Sie bezieht sich auf den aktuellen Arbeitsversatz entlang der Achse, der der Mittellinie des Kegels am besten entspricht.

  • Bodenhöhe - Die Achsenposition der Messerwerte auf der Unterseite der Kegelmessung. Sie bezieht sich auf den aktuellen Arbeitsversatz entlang der Achse, der der Mittellinie des Kegels am besten entspricht.

Hinweis: Die Anzahl der Reihen und Punkte pro Reihe werden entlang des definierten Kegels gleichmäßig verteilt.

Bereich "Bewegungsparameter"

  • Vorhalteabstand - Definiert den Abstand weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchabstand - Definiert die Entfernung, die der Taster bei der Suche nach dem Werkstück zurücklegt, während sich das Programm im Lernmodus befindet. (Nicht verfügbar, wenn die im Bereich "Optionale Einstellungen" beschriebene Option Lernen unter Verwendung von Werten auf dem Bildschirm ausgewählt ist.)

Bereich "Optionale Einstellungen"

  • Messpunkt Sicherh.-Ebene - Durch Auswahl dieser Option wird der Taster veranlasst, zwischen jedem Elementmesspunkt zu einer Sicherheitsebene zu fahren. Geben Sie in der rechten Box den Abstand zur Ebene ein. Diese Ebene ist nicht die Sicherheitsebene der Messroutine. Detaillierte Informationen finden Sie unter Messpunkt Sicherheitsebene.

  • Lernen, dann messen - Durch Auswahl dieser Option wird die Maschine veranlasst, die Position des Werkstückes unter Verwendung standardmäßiger Parameter zu erlernen und dann das Element mit den im Fenster gesetzten Eigenschaften sofort neu zu messen. Wird dazu verwendet, alle eingestellten Parameter zu testen, wodurch eine genauere und verlässlichere 'Erstmusterprüfung' gewährleistet wird.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Hierdurch hat der Benutzer die Möglichkeit, die theoretischen Werte des Elements einzugeben und das Element vom Programm an dieser Position messen zu lassen. (Durch die Aktivierung dieser Option sind zusätzliche Funktionen im Bereich Eigenschaften verfügbar, aber die Option Suchabstand im Bereich Bewegungsparameter wird deaktiviert.)

Bereich "Parameter"

  • XYZ-Nennwert - Definiert die theoretische Position der Kegelmitte.

  • XYZ-Messwert - Blendet die gemessene Position des Kegels ein.

  • Halb-Winkel - Definiert den Winkel, der von der Kegelseite mit der Mittellinie des Kegels gebildet wird.

  • Winkel zu Z - Definiert den ersten Vektorwinkel des Kegels. Hierbei handelt es sich um die Richtung der Mittellinie des Kegels im Verhältnis zur Arbeitsfläche. Der zulässige Bereich liegt zwischen -90 und +90 Grad.

  • Winkel zu X - Definiert den zweiten Vektorwinkel des Kegels. Hierbei handelt es sich um die Richtung der Mittellinie des Kegels im Verhältnis zur primären Achse, in der er gemessen wird. Die Primärachse ist X in der XY-Arbeitsfläche, Y in der YZ-Arbeitsfläche und Z in der ZX-Arbeitsfläche. Der zulässige Bereich liegt zwischen 0 (Null) und -360 Grad.

Hinweis: Vektorwinkel 1 und Vektorwinkel 2 stehen in Beziehung zueinander - ein unzulässiger Wert (90.0, 20.0) wird als (90.0, 0.0) definiert.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zum vorherigen Schritt zurückkehren Dieser Softkey löscht die zuletzt erlernten Tasterpositionen. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Lernen und Erstellen eines Befehls (Ausführen) Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Bewegungspunkt einfügen Dieser Softkey liest die aktuelle Position des Tasters und fügt eine Sicherheitsbewegung in die Messroutine ein.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.

Lernvorgang

  1. Positionieren Sie den Taster in die Nähe der Fläche an der unteren Ebene und drücken Sie den Softkey Position lesen [image]. Die untere Ebene ist die Ebene, die am weitesten von der Kegelspitze entfernt ist.

  2. Positionieren Sie den Taster in die Nähe der Fläche an der oberen Ebene und drücken Sie den Softkey Position lesen [image].

  3. Positionieren Sie den Taster über die Mitte und drücken Sie den Softkey Position lesen [image].

  4. Positionieren Sie den Taster für die automatische Messung und drücken Sie den Softkey Lernen und Erstellen eines Befehls [image] . NC Gage stellt Messpunkte in ähnlicher Weise, wie weiter unten abgebildet, dar.

    Pfad des Kegels (Außen): A-C) Ausrichtungspositionen 1-8) automatisch gemessene Punktpositionen. Rote Linien zeigen den Pfad für die untere Ebene. Die obere Ebene wird unter Verwendung gleicher Bahngeraden gemessen.

  5. Nachdem das Element gemessen wurde, werden die gemessenen Werte aktualisiert. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird der Messroutine hinzugefügt.

Nachfolgend handelt es sich um den 'NC-Gage'-spezifischen Elementpfad und logischen Aufbau in NC Gage:

Elementpfad Kegel (Außen) lernen

  • Tasterposition neben der Seite des Kegels an der untersten Ebene lesen; dadurch wird die XY-Mitte des Kegels und die erste Ebenenhöhe für die Ausführungszeit definiert.

  • Tasterposition neben der Kegelseite auf höchster Ebene lesen; Z-Wert wird zur Messhöhe der letzten Ebene.

  • Tasterposition über dem Mittelpunkt des Kegels lesen; XY-Werte definieren Mitte; Z-Wert liegt in sicherer Höhe.

  • Auf sichere Höhe fahren.

  • Vorhalteradius = projizierter 2D-Abstand zwischen erster und dritter Lesepunktposition. Wird zum Lernen beider Ebenen verwendet.

  • Messen Sie die unterste Ebene durch Aufnahme von Punkten in den Richtungen +X, -X, +Y und -Y; zwischen jeder Messung wird der Taster auf sichere Höhe gefahren.

  • Auf sichere Höhe zurückkehren.

  • Messen Sie die höchste Ebene durch Aufnahme von Punkten in den Richtungen +X, -X, +Y und -Y; zwischen jeder Messung wird der Taster auf sichere Höhe gefahren.

  • Auf sichere Höhe zurückkehren.

Führen Sie den Elementpfad 'Kegel (Außen)' aus

  • Die Kegelgeometrie wird zur Bestimmung der Anfahr- und Zielpositionen für jeden Messpunkt verwendet.

  • Wenn die aktuelle Position unterhalb der Sicherheitsebenenhöhe liegt, dann fahren Sie hoch zur Sicherheitsebene.

  • Fahren Sie zur Position über dem ersten Punkt des Vorhaltebereichs.

  • Absenken bis zur untersten Messebene.

  • Messen Sie die unterste Ebene - vom Startwinkel bis zum Endwinkel. Falls erforderlich, werden zwischen jedem Punkt Ausweichsbewegungen zur Kollisionsvermeidung vorgenommen.

  • Messen Sie die verbleibende(n) Ebene(n), wobei Sie die Punkte in abwechselnden Richtungen aufnehmen.

  • Wenn die lokale Sicherheitsebene aktiviert ist, fahren Sie zwischen jedem Punkt zur lokalen Sicherheitsebene, um zum nächsten Punkt des Vorhaltebereichs zu gelangen.

  • Nachdem der letzte Punkt gemessen ist, wird der Taster zur Sicherheitsebenenhöhe hochgefahren.


Kugel

Home > Anwenden von PC-DMIS NC Gage > Erstellen von Elementbefehlen > Kugel

Kugel messen

So erstellen Sie einen Kugelbefehl:

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Vorwärts [image], um die zweite Seite der Softkeys aufzurufen.

  3. Drücken Sie den Softkey Kugel [image], um das Fenster Kugel messen einzublenden:

  4. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, grafisch angezeigt.

Bereich "Eigenschaften"

  • Anzahl der Punkte - Legt die Gesamtzahl der Punkte, die gemessen werden, fest.

  • Winkel der unteren Ebene - Definiert den unteren Ebenenwinkel der Kugel; der Äquator weist einen Winkel von 0 Grad auf.

  • Winkel der oberen Ebene - Definiert den oberen Ebenenwinkel der Kugel; der Nordpol (oben) weist einen Winkel von 90 Grad auf.

Hinweis: Der Unterschied zwischen dem Winkel der oberen Ebene und dem Winkel der unteren Ebene muss mindestens 20 Grad betragen. Der Grund hierfür ist, dass ein Winkel von weniger als 20 Grad wahrscheinlich zu ungenauen Messergebnissen führen würde.

Bereich "Antast-Parameter"

  • Vorhalteabstand - Definiert den Abstand weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchabstand - Definiert den Suchabstand bei der Suche und beim Lernen eines Elements. (Nicht verfügbar, wenn die im Bereich "Optionale Einstellungen" beschriebene Option Lernen unter Verwendung von Werten auf dem Bildschirm ausgewählt ist.)

Bereich "Optionale Einstellungen"

  • Messpunkt Sicherh.-Ebene - Durch Auswahl dieser Option wird der Taster veranlasst, zwischen jedem Elementmesspunkt zu einer Sicherheitsebene zu fahren. Geben Sie in der rechten Box den Abstand zur Ebene ein. Diese Ebene ist nicht die Sicherheitsebene der Messroutine. Detaillierte Informationen finden Sie unter Messpunkt Sicherheitsebene.

  • Lernen, dann messen - Durch Auswahl dieser Option wird die Maschine veranlasst, die Position des Werkstückes unter Verwendung standardmäßiger Parameter zu erlernen und dann das Element mit den im Fenster gesetzten Eigenschaften sofort neu zu messen. Wird dazu verwendet, alle eingestellten Parameter zu testen, wodurch eine genauere und verlässlichere 'Erstmusterprüfung' gewährleistet wird.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Hierdurch hat der Benutzer die Möglichkeit, die theoretischen Werte des Elements einzugeben und das Element vom Programm an dieser Position messen zu lassen. (Die Auswahl deaktiviert die Option Suchabstand, die im Bereich "Bewegungsparameter" näher beschrieben ist.)

Bereich "Parameter"

  • Kugelmitte (XYZ-Nennwert) - Definiert die theoretische Position der Mitte der Kugel.

  • Mitte (XYZ-Messwert) - Blendet die gemessene Position des Kugelmittelpunkts ein.

  • Durchmesser (Nennwert) - Definiert den theoretischen Durchmesser der Kugel.

  • Gemessener Durchmesser - Blendet den gemessenen Durchmesser der Kugel ein.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zum vorherigen Schritt zurückkehren Dieser Softkey löscht die zuletzt erlernten Tasterpositionen. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Lernen und Erstellen eines Befehls (Ausführen) Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Bewegungspunkt einfügen Dieser Softkey liest die aktuelle Position des Tasters und fügt eine Sicherheitsbewegung in die Messroutine ein.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.

Lernvorgang

  1. Positionieren Sie den Taster über die Kugelmitte oben und drücken Sie den Softkey Position lesen [image].

  2. Drücken Sie den Softkey Lernen und Erstellen eines Befehls [image]. NC Gage nimmt Messpunkte auf ähnliche Weise, wie weiter unten dargestellt, automatisch auf.

    Kugelpfad: A) Ausrichtungspositionen 1-4) automatisch gemessene Punktpositionen.

  3. Nachdem das Element gemessen wurde, werden die gemessenen Werte aktualisiert. Drücken Sie auf den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image]. Der Elementbefehl wird der Messroutine hinzugefügt.

Nachfolgend handelt es sich um den 'NC-Gage'-spezifischen Elementpfad und logischen Aufbau:

Elementpfad Kugel lernen

  • Lesen Sie die Tasterposition, die sich über dem oberen Teil der Kugel befinden sollte.

  • Messen Sie den Punkt unter Verwendung des Suchabstandes in einer Richtung, die gerade nach unten verläuft.

  • Ziehen Sie den Taster zur Leseposition zurück und fahren Sie über eine Entfernung, die den zweifachen Tasterradius ausmacht, in Richtung +X.

  • Messen Sie den Punkt unter Verwendung des Suchabstandes in einer Richtung, die gerade nach unten verläuft.

  • Ziehen Sie den Taster auf die ursprüngliche Höhe zurück und fahren Sie über eine Entfernung, die den zweifachen Tasterradius ausmacht, in die Richtung, die 120 Grad von der +X -Achse entfernt ist.

  • Messen Sie den Punkt unter Verwendung des Suchabstandes in einer Richtung, die gerade nach unten verläuft.

  • Ziehen Sie den Taster auf die ursprüngliche Höhe zurück und fahren Sie über eine Entfernung, die den zweifachen Tasterradius ausmacht, in die Richtung, die 240 Grad von der +X -Achse entfernt ist.

  • Messen Sie den Punkt unter Verwendung des Suchabstandes in einer Richtung, die gerade nach unten verläuft.

  • Ziehen Sie den Taster auf ursprüngliche Höhe zurück.

Elementpfad Kugel ausführen

  • Die Anzahl der Ebenen und Punkte für jede Ebene wird aufgrund der Anzahl der zu messenden Punkte, die auf dem Formblatt angegeben ist, definiert.

  • Wenn die aktuelle Position unterhalb der Sicherheitsebenenhöhe liegt, dann fahren Sie hoch zur Sicherheitsebene.

  • Fahren Sie zur Position über dem ersten Punkt des Vorhaltebereichs.

  • Senken Sie den Taster bis zur untersten Ebene ab und messen Sie diese Ebene. Fügen Sie je nach Bedarf zwischen jedem Punkt in einer Ebene Ausweichsbewegungen hinzu, um Kollisionen zu vermeiden.

  • Messen Sie die verbleibende(n) Ebene(n), wobei Sie die Punkte in abwechselnden Richtungen aufnehmen.

  • Messen Sie einen Punkt oben auf der Kugel (wenn der Winkel der oberen Ebene 90 Grad aufweist).

  • Fahren Sie zur Sicherheitsebenenhöhe.


Konstruierter Punkt

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Vorwärts [image] solange, bis der Softkey Punkt erstellen angezeigt wird.

  3. Drücken Sie den Softkey Einen Punkt erstellen [image], um das Fenster Punkt erstellen aufzurufen:

Mit diesem Bildschirm können Sie folgendermassen ein Punktelement erzeugen:

  • Erstellen eines Punktes an einem Schnittpunkt zweier ausgewählter Geradenelemente durch Auswahl des Optionsschalters Schnittpunkt.

  • Erstellen einen Punktes durch Projektion eines Punktelementes auf ein Geradenelement durch Auswahl des Optionsschalters Projektion.

  • Erstellen eines Punktes auf dem gedachten Mittelpunkt zwischen zwei ausgewählten Punktelementen durch Auswahl des Optionsschalters Mittelpunkt.

Punktelement konstruieren

  1. Wählen Sie im Optionsbereich die entsprechende Optionsschaltfläche für den zu erstellenden Typ aus.

  2. Wählen Sie zwei Element aus den Linienauswahllisten. Nur gültige Elementtypen werden in den Auswahllisten angezeigt. Die Grafiken in der oberen linken Ecke des Fensters werden aktualisiert, um einen visuellen Einblick in die Art und Weise, wie die Elemente aufgebaut sind, zu vermitteln. Die theoretischen und gemessenen Daten werden entsprechend der Elementeingaben aktualisiert.

  3. Drücken Sie auf den Softkey Bestätigen [image], um den Befehl zur Messroutine hinzuzufügen.

Gültige Punktelemente

  • Abhängiges Element Kreis

  • Abhängiges Element Punkt

  • Gemessener Kreis Bohrung

  • Gemessener Kreis Ausstülpung

  • Gemessene Ecke Innen

  • Gemessene Ecke Außen

  • Gemessener Punkt

  • Gemessene Kugel

Gültige Geradenelemente

  • Abhängige Gerade

  • Gemessener Kegel (Innen)

  • Gemessener Kegel (Außen)

  • Gemessene Zylinderbohrung

  • Gemessener Zylinderzapfen

  • Gemessene Gerade

  • Gemessene Ebene

  • Gemessene Tasche

  • Gemessener Steg

Hinweis: Theoretische und gemessene Z-Werte werden dem erstellten Element automatisch zugewiesen. Der theoretische und der gemessene Z-Wert werden aus dem ersten Komponentenelement des Erstellungsvorganges genommen.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben.
Fügen Sie den Befehl hinter der aktuellen Position ein Dieser Softkey fügt den Befehl in die Messroutine ein, aber positioniert diesen nach dem ausgewählten Befehl im Messroutinenbaum anstatt am Ende der Messroutine. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.


Linie konstruieren

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Vorwärts [image] solange, bis der Softkey Linie konstruieren angezeigt wird.

  3. Drücken Sie den Softkey Gerade erstellen [image], um das Fenster Gerade Erstellen aufzurufen:

Bereich "Parameter"

  • Nennwert (XYZ-Nennwert) - Definiert die theoretische Position des Startpunktes.

  • Messwert (XYZ-Messwert) - Blendet die gemessene Position des Startpunktes ein.

  • Winkel zu X - Definiert den ersten Vektorwinkel der Ebene -X in diesem Beispiel. Hierbei handelt es sich um den Oberflächennormalenvektor der Ebene im Verhältnis zur Arbeitsfläche. Der zulässige Bereich liegt zwischen -90 und +90 Grad.

  • Winkel zu Z - Definiert den zweiten Vektorwinkel der Ebene -Z in diesem Beispiel. Hierbei handelt es sich um den Oberflächennormalenvektor der Ebene im Verhältnis zur primären Achse, in der er gemessen wird. Die Primärachse ist X in der XY-Arbeitsfläche, Y in der YZ-Arbeitsfläche und Z in der ZX-Arbeitsfläche. Der zulässige Bereich liegt zwischen 0 (Null) und -360 Grad.

Hinweis: Die Vektorwinkel (Vektorwinkel zu X und Vektorwinkel zu Z in diesem Beispiel) stehen in Beziehung zueinander - ein unzulässiger Wert (90.0, 20.0) wird als (90.0, 0.0) definiert.

Linienelement erstellen

  1. Wählen Sie die zwei Punktelemente aus. Nur gültige Elementtypen werden in den Elementlisten angezeigt. Die Grafiken in der oberen linken Ecke des Fensters werden aktualisiert, um einen visuellen Einblick in die Art und Weise, wie die Elemente aufgebaut sind, zu vermitteln. Die theoretischen und gemessenen Daten werden entsprechend der Elementeingaben aktualisiert.

  2. Drücken Sie auf den Softkey Bestätigen , um den Befehl zur Messroutine hinzuzufügen.

Gültige Punktelemente

  • Abhängiges Element Kreis

  • Abhängiges Element Punkt

  • Gemessener Kreis Bohrung

  • Gemessener Kreis Ausstülpung

  • Gemessene Ecke Innen

  • Gemessene Ecke Außen

  • Gemessener Punkt

  • Gemessene Kugel

Hinweis: Theoretische und gemessene Z-Werte werden dem erstellten Element automatisch zugewiesen. Der theoretische und der gemessene Z-Wert werden aus dem ersten Komponentenelement des Erstellungsvorganges genommen.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben.
Fügen Sie den Befehl hinter der aktuellen Position ein Dieser Softkey fügt den Befehl in die Messroutine ein, aber positioniert diesen nach dem ausgewählten Befehl im Messroutinenbaum anstatt am Ende der Messroutine. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.


Konstruierter Kreis

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Vorwärts [image] solange, bis der Softkey Kreis erstellen angezeigt wird.

  3. Drücken Sie den Softkey Einen Kreis erstellen [image], um das Fenster Kreis erstellen aufzurufen:

Die Option Kreis konstruieren befindet sich auf dem dritten Bildschirm des Elementmenüs. Damit können konstruieren, dessen Umfang drei Punktelemente schneidet.

Kreismerkmal konstruieren

  1. Wählen Sie das erste Element für die Konstruktion von der Liste Punktelemente.

  2. Drücken Sie den Doppelpfeil-Softkey Eintrag nach links verschieben [image], um das Element zur Liste Ausgewählte Elemente hinzuzufügen.

  3. Wiederholen Sie diesen Vorgang für mindestens zwei andere Punktelemente (es müssen mindestens drei vollständige Elemente vom Typ „Punkt“ ausgewählt sein). Wenn Sie Elemente aus der Liste ausgewählter Elemente entfernen, markieren Sie das zu entfernende Element und verwenden hierzu die Doppelpfeiltaste Eintrag nach rechts verschieben [image]. Im Auswahlfenster erscheinen nur gültige Elementtypen. Die Grafiken in der oberen linken Ecke des Fensters werden aktualisiert, um einen visuellen Einblick in die Art und Weise, wie die Elemente aufgebaut sind, zu vermitteln. Die theoretischen und gemessenen Daten werden entsprechend der Elementeingaben aktualisiert.

  4. Drücken Sie auf den Softkey Bestätigen , um den Befehl zur Messroutine hinzuzufügen.

Gültige Punktelemente

  • Abhängiges Element Kreis

  • Abhängiges Element Punkt

  • Gemessener Kreis Bohrung

  • Gemessener Kreis Ausstülpung

  • Gemessene Ecke Innen

  • Gemessene Ecke Außen

  • Gemessener Punkt

  • Gemessene Kugel

Hinweis: Theoretische und gemessene Z-Werte werden dem erstellten Element automatisch zugewiesen. Der theoretische und der gemessene Z-Wert werden aus dem ersten Komponentenelement des Erstellungsvorganges genommen.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Fügen Sie den Befehl hinter der aktuellen Position ein Dieser Softkey fügt den Befehl in die Messroutine ein, aber positioniert diesen nach dem ausgewählten Befehl im Messroutinenbaum anstatt am Ende der Messroutine. | Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.


(Zwischen-)Winkel

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Vorwärts [image] so lange, bis die dritte Seite der Softkeys angezeigt wird.

  3. Drücken Sie den Softkey Zwischenwinkel [image], um das Fenster Zwischenwinkel aufzurufen:

Mit der Option Zwischenwinkel auf der dritten Seite des Elementmenüs können Sie den Winkel zwischen zwei Geradenelementen anzeigen lassen.

Anzeigen eines Winkels

  1. Wählen Sie die beiden Geradenelemente aus den Listen Erste Gerade und Zweite Gerade. NC Gage wird den Winkel auf Grundlage der Richtung der Elemente berechnen. Wenn die Ergänzung ein Winkel ist, markieren Sie das Kontrollkästchen Ergänzung. Im Auswahlfenster erscheinen nur gültige Elementtypen. Die Grafiken in der oberen linken Ecke des Fensters werden aktualisiert, um einen visuellen Einblick in die Art und Weise, wie die Elemente aufgebaut sind, zu vermitteln. Die theoretischen und gemessenen Daten werden entsprechend der Elementeingaben aktualisiert.

  2. Drücken Sie auf den Softkey Bestätigen [image], um den Befehl zur Messroutine hinzuzufügen.

Gültige Geradentypen und Ebenenelemente

  • Steg

  • Tasche

  • Gerade

  • Konstruierte Linien

  • Kegel

  • Zylinder

  • Ebene

Protokollieren von Parallelität und Rechtwinkligkeit für Winkel

Mit der Option Zwischenwinkel, Parallelität oder Rechtwinkligkeit können Sie den Winkel zwischen zwei Geradenelementen anzeigen lassen. Bei den Merkmalen Parallelität und Rechtwinkligkeit wird nur die positive Abweichung protokolliert. Der Zwischenwinkel kann ein positiver oder negativer Wert sein, wobei positiv X zu Y, Y zu Z und Z zu X vom Bezugselement (das Element auf der ersten SEite des Fensters) zum Referenzelement (das Element, das auf der zweiten Seite des Fensters ausgewählt ist) ist.

Die Optionen sind folgendermaßen verfügbar:

  • Wenn der Wert Theoretischer Winkel gleich 0 (Null) ist, dann ist die Option Parallelität deaktiviert.

  • Wenn der Wert Theoretischer Winkel gleich 90 ist, dann ist die Option Rechtwinkligkeit aktiviert.

  • Wenn der Wert Theoretischer Winkel ungleich 0 oder 90 ist, dann ist die Option Zwischenwinkel aktiviert.

Gehen Sie zur Protokollierung von Parallelität vor wie folgt:

  1. Wählen Sie die Option Parallelität im Fenster Zwischenwinkel aus, um das Fenster Parallelität aufzurufen:

  2. Geben Sie für Auswertungslänge die Länge, über die eine Auswertung stattfinden soll, ein. Die standardmäßige Auswertungslänge ist null. Wenn das Feld leer ist, erscheint ein rotes Sternchen (*), das angibt, dass es sich bei diesem Feld um ein notwendiges Feld handelt; außerdem erscheinen Warnmeldungen.

  3. Kehren Sie zum Fenster Zwischenwinkel zurück und drücken Sie auf den Softkey Toleranz [image] , um das Fenster Toleranz einzublenden:

Gehen Sie zur Protokollierung von Rechtwinkligkeit vor wie folgt:

  1. Wählen Sie die Option Rechtwinkligkeit im Fenster Zwischenwinkel aus, um das Fenster Rechtwinkligkeit aufzurufen:

  2. Geben Sie für Auswertungslänge die Länge, über die eine Auswertung stattfinden soll, ein. Die standardmäßige Auswertungslänge ist null. Wenn das Feld leer ist, erscheint ein rotes Sternchen (*), das angibt, dass es sich bei diesem Feld um ein notwendiges Feld handelt; außerdem erscheinen Warnmeldungen.

  3. Kehren Sie zum Fenster Zwischenwinkel zurück und drücken Sie auf den Softkey Toleranz [image] , um das Fenster Toleranz einzublenden:

Nachfolgend finden Sie ein Beispiel einer Strukturansicht für das Element "Zwischenwinkel":

Nachfolgend finden Sie ein Beispiel einer Strukturansicht für Parallelität:

Nachfolgend finden Sie ein Beispiel einer Strukturansicht für Rechtwinkligkeit:

Beispiele zu den Fenstern einer Messroutine für Zwischenwinkel, Parallelität und Rechtwinkligkeit finden Sie unter "Anzeigen und ausführen von Messroutinen". Beispiele zum Fenster Protokoll finden Sie unter "Anwenden von Protokollen".

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. | Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet.
Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen. | Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Fügen Sie den Befehl hinter der aktuellen Position ein Dieser Softkey fügt den Befehl in die Messroutine ein, aber positioniert diesen nach dem ausgewählten Befehl im Messroutinenbaum anstatt am Ende der Messroutine.
Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.


Merkmal Abstand

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Vorwärts [image] so lange, bis die dritte Seite der Softkeys angezeigt wird.

  3. Drücken Sie den Softkey Abstand [image], um das Fenster Abstand aufzurufen.

So protokollieren Sie einen Abstandswert

Mit der Option Abstand auf der dritten Seite des Elementmenüs können Sie den Abstand zwischen zwei Punktelementen anzeigen lassen. Der Abstand kann in einer Ein-Achsenrichtung (parallel zu einer Achse) oder in einer Zwei-Achsenrichtung bestimmt werden.

  1. Wählen Sie im Optionsbereich die entsprechende Optionsschaltfläche für den zu berechnenden Abstand aus.

  2. Wählen Sie den Eintrag aus jeder der angezeigten Listen aus. Nur gültige gemessene und erstellte Objekte werden in den Listenbereichen eingeblendet. Die Grafiken in der oberen linken Ecke des Fensters werden aktualisiert, um einen visuellen Einblick in die Art und Weise, wie die Elemente aufgebaut sind, zu vermitteln. Die theoretischen und gemessenen Daten werden entsprechend der Elementeingaben aktualisiert. Sobald die Einträge ausgewählt wurden, drücken Sie den Softkey Toleranz [image], um die mit dem zu erstellenden Abstand verknüpften Toleranzwerte einzublenden.

  3. Drücken Sie auf den Softkey Bestätigen [image], um den Befehl zur Messroutine hinzuzufügen.

Gültige Punktelemente:

  • Gemessener Punkt

  • Gemessener Kreis Bohrung

  • Gemessener Kreis Ausstülpung

  • Gemessene Ecke Innen

  • Gemessene Ecke Außen

  • Konstruierter Punkt

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. | Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet.
Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen. | Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint.
Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt. | Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben.
Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung. |


Konzentrizität

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Vorwärts [image] so lange, bis die dritte Seite der Softkeys angezeigt wird.

  3. Drücken Sie auf den Softkey Konzentrizität [image], um das Fenster Konzentrizität aufzurufen:

So protokollieren Sie Konzentrizität

Mit der Option Konzentrizität auf der dritten Seite des Elementmenüs können Sie die Konzentrizität von einem Element zum anderen berechnen. Dieses Element gilt nur für Elemente, die sich in derselben Arbeitsebene befinden.

  1. Wählen Sie den Eintrag aus jeder der angezeigten Listen aus. Beide Listen zeigen das Kreiselement.

Wenn sich die beiden ausgewählten Elemente nicht in derselben Arbeitsebene befinden, erscheint folgende Warnmeldung: "Die ausgewählten Elemente befinden sich nicht in derselben Arbeitsebene."

  2. Sobald die Einträge ausgewählt wurden, drücken Sie den Softkey Toleranz [image], um die mit der Konzentrizität verknüpften Toleranzwerte einzublenden.

  3. Drücken Sie auf den Softkey Bestätigen [image], um den Befehl zur Messroutine hinzuzufügen. Das Element wird zur Strukturansicht hinzugefügt. Zum Beispiel:

Gültige Elementtypen

  • Gemessener Kreis Bohrung

  • Gemessener Kreis Ausstülpung

  • Abhängiges Element Kreis

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. | Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet.
Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen. | Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint.
Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt. | Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben.
Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung. |


Taste

So erstellen Sie einen Befehl 'Nut':

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Vorwärts [image] so lange, bis die dritte Seite der Softkeys angezeigt wird.

  3. Drücken Sie den Softkey Nut [image], um das Fenster Nut messen aufzurufen:

  4. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, grafisch angezeigt.

Bereich "Eigenschaften"

  • Startposition X, Startposition Y und Startposition Z - Definieren Sie den Bereich für den Startpunkt.

  • Breite - Definiert die theoretische Breite der Keilnut. Die Breite ist nur dann sichtbar, wenn das Kontrollkästchen Lernen mit Hilfe von Werten auf dem Bildschirm ausgewählt ist.

  • Immer suchen - Aktiviert den Suchvorgang. Wenn Sie dieses Kontrollkästchen aktivieren, fügt NC Gage am Beginn des Messvorgangs einen Suchvorgang ein. Der Taster nimmt einige Vorhaltemessungen auf der Schaftoberfläche auf, um die Position des theoretischen Keilnutwinkels zu bestimmen.

Bereich "Antast-Parameter"

  • Vorhaltewinkel - Definiert den Winkel weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

Bereich "Optionale Einstellungen"

  • Lernen, dann messen - Durch Auswahl dieser Option wird die Maschine veranlasst, die Position des Werkstückes unter Verwendung standardmäßiger Parameter zu erlernen und dann das Element mit den im Fenster gesetzten Eigenschaften sofort neu zu messen. Sie wird dazu verwendet, alle eingestellten Parameter zu testen, wodurch eine genauere und verlässlichere 'Erstmusterprüfung' gewährleistet wird.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Hierdurch können Sie die theoretischen Werte des Elements eingeben und das Element vom Programm an dieser Position messen lassen.

Bereich "Parameter"

  • Winkel - Definiert den Vektorwinkel der Mittellinie der Fläche.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zum vorherigen Schritt zurückkehren Dieser Softkey löscht die zuletzt erlernten Tasterpositionen. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Lernen und Erstellen eines Befehls (Ausführen) Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Bewegungspunkt einfügen Dieser Softkey liest die aktuelle Position des Tasters und fügt eine Sicherheitsbewegung in die Messroutine ein.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.

Lernvorgang

  1. Positionieren Sie den Taster in Prüfhöhe an der Seite des Zapfen und drücken Sie dann den Softkey Position lesen [image].

  2. Beachten Sie die Abbildung weiter unten.

    • Der Taster fährt zur Oberseite des Zapfens.

    • Die Drehachse dreht sich zur Position des Vorhaltewinkels.

    • Der Taster fährt zur Messhöhe.

    • Die Drehachse rotiert im Uhrzeigersinn bis der Taster ausgelöst wird. Die Drehachse stoppt den Drehvorgang. Der Taster fährt bis zur Vorhalteposition zurück.

    • Der Taster fährt zur Oberseite des Zapfens.

    • Die Drehachse dreht sich zur Position des Vorhaltewinkels.

    • Der Taster fährt zur Messhöhe.

    • Die Drehachse dreht sich daraufhin so lange entgegen dem Uhrzeigersinn (nach links), bis der Taster ausgelöst wurde. Die Drehachse stoppt den Drehvorgang. Der Taster fährt bis zur Vorhalteposition zurück.

    • Der Taster fährt zur Oberseite des Zapfens.

    • Die Drehachse dreht sich zurück auf die ursprüngliche Position.

    • Der mittlere Winkel der Nut wird mittels den zwei ausgelösten Drehachsen-Positionen berechnet.

Vorgang ausführen

Beachten Sie die Abbildung weiter unten.

  1. Der Taster fährt zur Oberseite des Zapfens.

  2. Der Taster orientiert in der Spindel zu 0 Grad.

  3. Die Drehachse dreht sich zur Position des Vorhaltewinkels.

  4. Der Taster fährt zur Messhöhe.

  5. Die Drehachse rotiert im Uhrzeigersinn bis der Taster ausgelöst wird. Die Drehachse stoppt den Drehvorgang. Der Taster fährt bis zur Vorhalteposition zurück.

  6. Der Taster fährt zur Oberseite des Zapfens.

  7. Der Taster orientiert in der Spindel zu 180 Grad.

  8. Die Drehachse dreht sich zur Position des Vorhaltewinkels.

  9. Der Taster fährt zur Messhöhe.

  10. Die Drehachse dreht sich daraufhin so lange entgegen dem Uhrzeigersinn (nach links), bis der Taster ausgelöst wurde. Die Drehachse stoppt den Drehvorgang. Der Taster fährt bis zur Vorhalteposition zurück.

  11. Der Taster fährt zur Oberseite des Zapfens.

  12. Der Taster orientiert in der Spindel zu 0 Grad.

  13. Die Drehachse dreht sich zurück auf die ursprüngliche Position.


KEILNUT

So erstellen Sie einen Befehl 'Keilnut':

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie so lange den Softkey Vorwärts [image], bis die zweite Seite der Softkeys angezeigt wird.

  3. Drücken Sie den Softkey Nut [image], um das Fenster Nut messen aufzurufen:

  4. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, grafisch angezeigt.

Bereich "Eigenschaften"

  • Startposition X, Startposition Y und Startposition Z - Definieren Sie den Bereich für den Startpunkt.

  • Breite - Definiert die theoretische Breite der Keilnut. Die Breite ist nur dann sichtbar, wenn das Kontrollkästchen Lernen mit Hilfe von Werten auf dem Bildschirm ausgewählt ist.

  • Immer suchen - Aktiviert den Suchvorgang. Wenn Sie dieses Kontrollkästchen aktivieren, fügt NC Gage am Beginn des Messvorgangs einen Suchvorgang ein. Der Taster nimmt einige Vorhaltemessungen auf der Schaftoberfläche auf, um die Position des theoretischen Keilnutwinkels zu bestimmen.

Bereich "Antast-Parameter"

  • Vorhaltewinkel - Definiert den Winkel weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchwinkelbereich - Definiert den Suchwinkelbereich bei der Suche und beim Lernen eines Elements. Diese Option ist nicht verfügbar, wenn die Option Lernen unter Verwendung von Werten auf dem Bildschirm ausgewählt ist.

Bereich "Optionale Einstellungen"

  • Lernen, dann messen - Durch Auswahl dieser Option wird die Maschine veranlasst, die Position des Werkstückes unter Verwendung standardmäßiger Parameter zu erlernen und dann das Element mit den im Fenster gesetzten Eigenschaften sofort neu zu messen. Sie wird dazu verwendet, alle eingestellten Parameter zu testen, wodurch eine genauere und verlässlichere 'Erstmusterprüfung' gewährleistet wird.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Hierdurch können Sie die theoretischen Werte des Elements eingeben und das Element vom Programm an dieser Position messen lassen. Die Auswahl deaktiviert die Option Winkelbereich suchen.

Bereich "Parameter"

  • Winkel - Definiert den Vektorwinkel der Mittellinie der Keilnut.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zum vorherigen Schritt zurückkehren Dieser Softkey löscht die zuletzt erlernten Tasterpositionen. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Lernen und Erstellen eines Befehls (Ausführen) Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Bewegungspunkt einfügen Dieser Softkey liest die aktuelle Position des Tasters und fügt eine Sicherheitsbewegung in die Messroutine ein.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.

Lernvorgang

  1. Positionieren Sie den Taster innerhalb der Keilnut an der Mittellinie und drücken Sie dann auf den Softkey Position lesen [image].

  2. Beachten Sie die Abbildung weiter unten.

    • Die Drehachse rotiert im Uhrzeigersinn bis der Taster ausgelöst wird. Die Drehachse hält an.

    • Die Drehachse dreht sich daraufhin so lange entgegen dem Uhrzeigersinn (nach links), bis der Taster ausgelöst wurde. Die Drehachse stoppt den Drehvorgang.

    • Die Drehachse dreht sich zurück auf die ursprüngliche Position.

    • Der mittlere Winkel der Keilnut wird mittels den zwei ausgelösten Drehachsen-Positionen berechnet.

Vorgang ausführen

Beachten Sie die Abbildung weiter unten.

  1. Der Taster fährt innerhalb der Keilnut zur Startposition.

  2. Der Taster orientiert in der Spindel zu 0 Grad.

  3. Die Drehachse beginnt sich im Uhrzeigersinn (nach rechts) zur Position des Vorhaltewinkels zu drehen.

  4. Die Drehachse hält an und beginnt damit, sich langsam zu bewegen, um eine Seite der Keilnut zu messen.

  5. Der Taster wird ausgelöst und die Drehachse fängt nun damit an, sich in die entgegen gesetzte Richtung zu drehen.

  6. Der Taster orientiert in der Spindel zu 180 Grad.

  7. Die Drehachse dreht sich entgegen dem Uhrzeigersinn (nach links) zur Position des Vorhaltewinkels.

  8. Die Drehachse hält an und beginnt damit, sich langsam zu bewegen, um die andere Seite der Keilnut zu messen.

  9. Die Drehachse dreht sich zurück auf die ursprüngliche Position.

  10. Der Taster orientiert in der Spindel zu 0 Grad.


Eben

So erstellen Sie einen Befehl 'Ebenheit':

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie den Softkey Vorwärts [image] so lange, bis die dritte Seite der Softkeys angezeigt wird.

  3. Drücken Sie den Softkey Ebenheit [image], um das Fenster Ebenheit messen aufzurufen:

  4. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen, falls mehrere Schritte benötigt werden, grafisch angezeigt.

Bereich "Eigenschaften"

  • Startposition X, Startposition Y und Startposition Z - Definieren Sie den Bereich für den Startpunkt.

  • Breite - Definiert die theoretische Breite der Keilnut. Die Breite ist nur dann sichtbar, wenn das Kontrollkästchen Lernen mit Hilfe von Werten auf dem Bildschirm ausgewählt ist.

  • Immer suchen - Aktiviert den Suchvorgang. Wenn Sie dieses Kontrollkästchen aktivieren, fügt NC Gage am Beginn des Messvorgangs einen Suchvorgang ein. Der Taster nimmt einige Vorhaltemessungen auf der Schaftoberfläche auf, um die Position des theoretischen Keilnutwinkels zu bestimmen.

Bereich "Antast-Parameter"

  • Vorhaltewinkel - Definiert den Winkel weg von der theoretischen Fläche, an der der Taster die Suche nach der Fläche während des Messvorgangs beginnt.

  • Suchwinkelbereich - Definiert den Suchwinkelbereich bei der Suche und beim Lernen eines Elements. Diese Option ist nicht verfügbar, wenn die Option Lernen unter Verwendung von Werten auf dem Bildschirm ausgewählt ist.

Bereich "Optionale Einstellungen"

  • Lernen, dann messen - Durch Auswahl dieser Option wird die Maschine veranlasst, die Position des Werkstückes unter Verwendung standardmäßiger Parameter zu erlernen und dann das Element mit den im Fenster gesetzten Eigenschaften sofort neu zu messen. Sie wird dazu verwendet, alle eingestellten Parameter zu testen, wodurch eine genauere und verlässlichere 'Erstmusterprüfung' gewährleistet wird.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Hierdurch können Sie die theoretischen Werte des Elements eingeben und das Element vom Programm an dieser Position messen lassen. Die Auswahl deaktiviert die Option Winkelbereich suchen.

Bereich "Parameter"

  • Winkel - Definiert den Vektorwinkel der Mittellinie der Fläche.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zum vorherigen Schritt zurückkehren Dieser Softkey löscht die zuletzt erlernten Tasterpositionen. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Lernen und Erstellen eines Befehls (Ausführen) Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Toleranzeinstellungen Mit diesem Softkey können die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Bewegungspunkt einfügen Dieser Softkey liest die aktuelle Position des Tasters und fügt eine Sicherheitsbewegung in die Messroutine ein.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.

Lernvorgang

  1. Positionieren Sie den Taster an der Mittellinie oberhalb der Fläche und drücken Sie den Softkey Position lesen [image].

  2. Beachten Sie die Abbildung weiter unten.

    • Die Drehachse rotiert im Uhrzeigersinn bis der Taster ausgelöst wird. Die Drehachse hält an.

    • Die Drehachse dreht sich daraufhin so lange entgegen dem Uhrzeigersinn (nach links), bis der Taster ausgelöst wurde. Die Drehachse stoppt den Drehvorgang.

    • Die Drehachse dreht sich zurück auf die ursprüngliche Position.

    • Der mittlere Winkel der Fläche wird mittels den zwei ausgelösten Drehachsen-Positionen berechnet.

Vorgang ausführen

Beachten Sie die Abbildung weiter unten.

  1. Der Taster fährt innerhalb der Fläche zur Startposition.

  2. Der Taster orientiert in der Spindel zu 0 Grad.

  3. Die Drehachse beginnt sich im Uhrzeigersinn (nach rechts) zur Position des Vorhaltewinkels zu drehen.

  4. Die Drehachse hält an und beginnt damit, sich langsam zu bewegen, um eine Seite der Fläche zu messen.

  5. Der Taster wird ausgelöst und die Drehachse fängt nun damit an, sich in die entgegen gesetzte Richtung zu drehen.

  6. Der Taster orientiert in der Spindel zu 180 Grad.

  7. Die Drehachse dreht sich entgegen dem Uhrzeigersinn (nach links) zur Position des Vorhaltewinkels.

  8. Die Drehachse hält an und beginnt damit, sich langsam zu bewegen, die andere Seite der Fläche zu messen.

  9. Die Drehachse dreht sich zurück auf die ursprüngliche Position.

  10. Der Taster orientiert in der Spindel zu 0 Grad.


Zusätzliche Elementparameter einstellen

Home > Anwenden von PC-DMIS NC Gage > Zusätzliche Elementparameter einstellen

Einstellen von zusätzlichen Elementparametern

Beim Arbeiten mit Elementbefehlen können im Elementfenster zusätzliche Parameter modifiziert werden. Die folgenden Softkeys stehen in der Symbolleiste des Elementfensters zur Verfügung:

  • Nullpunkt setzten

  • Nullpunkt aktualisieren

  • Nullpunkt auswählen

  • Variable schreiben

  • Werkzeugversatz festlegen - Sofort

  • Werkzeugversatz aktualisieren - Messroutinensteuerung

  • Koordinatenrotation einstellen

  • Toleranz

  • Messpunkt Sicherheitsebene


Nullpunkt auswählen

Durch Auswahl eines Arbeitsversatzes am Anfang des Messroutine kann die Messroutine wiederverwendbar werden; der Arbeitsversatz muss vor der Elementmessung ausgewählt werden.

  1. Drücken Sie den Softkey Einen Arbeitsversatz auswählen [image] aus dem Hauptfenster, um das Fenster Arbeitsversatz auswählen aufzurufen. Dies steht zur Verfügung, wenn das Programm NC Gage vor der Definition eines Elementrahmens (wenn für das System ein Drehtisch konfiguriert wurde) oder der Definition einer Sicherheitsebene gestartet wird.

  2. Drücken Sie den Softkey Einen zu aktualisierenden [image] Arbeitsversatz auswählen , wobei Sie die Versatzwerte, die im Bereich Parameter des Fensters für jeden Versatzlisteneintrag angezeigt werden, so lange überprüfen, bis die gewünschten Versatzeinstellungen eingeblendet werden.

  3. Drücken Sie den Softkey Ausführen [image], um den Arbeitsversatz auf der Maschine zu aktivieren.

  4. Drücken Sie den Softkey Bestätigen [image]. NC Gage fügt die ausgewählten Arbeitsversätze in die Messroutine ein. Drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Parameterdefinition:

  • Arbeitsversatz – Gibt den Arbeitsversatz, der zur Anzeige der Versatzwerte in Parametern gewählt wird, und fügt ihn der Messroutine hinzu.

  • X Y Z - Diese schreibgeschützen Informationen zeigen die Arbeitsversatz-Werte. Sie werden von der Steuereinheit gelesen und dann eingeblendet, wenn ein Arbeitsversatz im Kombinationsfeld ausgewählt wird.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Wählen Sie einen Nullpunkt zum Aktualisieren Dieser Softkey wählt den benannten Arbeitsversatz aus der Versatzliste zur Aktualisierung aus. Die wiederholte Betätigung wählt den nächsten Arbeitsversatz aus der Liste aus. | Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet.
Aktuellen Befehl bestätigen und am Ende anhängen Über diesen Softkey wird bestätigt, dass der derzeitig ausgewählte Arbeitsversatz in der Messroutine aktiviert wird. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.


Variable schreiben

Die Befehl Variable schreiben ist ab NC Gage 2.0 verfügbar. Damit können Sie Messdaten in eine Makrovariable auf der NC-Steuereinheit schreiben. Außerdem können hierüber die Elemente, die sich außerhalb des Toleranzbereichs befinden, sowie die Gesamtanzahl der Elemente in eine Makro-Variable geschrieben werden. NC Gage schreibt nur diese Werte und führt keine anderen Vorgänge aus.

  1. Drücken Sie aus der Navigationsleiste des Hauptfensters den Softkey Messen [image].

  2. Drücken Sie den Softkey Vorwärts [image] so lange, bis die dritte Seite der Softkeys angezeigt wird.

  3. Drücken Sie den Softkey Variable schreiben [image], um das Fenster Variable schreiben aufzurufen.

Bereich "Elemente"

Markierte Zahl - Die Anzahl der Elemente, die gemessen und/oder erstellt wurden.

Zahl 'Außer Spez." - Die Anzahl der Elemente, die außerhalb des Toleranzbereichs liegen.

Bereich "Elementlage"

Merkmal - Der Achsensatz, der für das Element mit Toleranzen versehen wurde.

Wert - Dieses Feld erscheint, wenn ein Merkmal ausgewählt wurde. Es kann nicht bearbeitet werden.

Makro-Variable: Das Feld "Makro-Variable" ist eine Ganzzahl, über die eine gültige Makro-Variablenzahl definiert wird. Der Bereich der gültigen Makro-Variablen hängt vom Maschinentyp und den erworbenen Optionen ab.

Die nachfolgenden Schritte werden zum Schreiben einer Makro-Variablen verwendet:

  1. Wählen Sie ein gemessenes Element aus der Elementliste aus.

  2. Das Feld Merkmal sollte dann mit der Liste der gültigen, gemessenen Merkmale für dieses Element eingepflegt werden. Wenn für das Element die Option Markierte Zahl oder Zahl 'Außer Spez.' ausgewählt ist, dann wird das Feld leer gelassen und deaktiviert. Wählen Sie das Merkmal aus der Auswahlliste des Bereichs Elementposition aus. Der aktuelle Wert wird als Referenz angezeigt.

  3. Geben Sie die Makro-Variablenzahl ein, die im Feld Makro-Variable im Bereich Elementposition verwendet werden soll, ein. NC Gage überprüft dann die eingegebene Makro-Zahl dahingehend, dass sie nicht in irgendeiner Weise mit dem NC Gage-Verarbeitungsvorgang kollidiert.

  4. Klicken Sie auf den Softkey Bestätigen [image], um den Vorgang "Variable schreiben" abzuschließen.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Fügen Sie den Befehl hinter der aktuellen Position ein Dieser Softkey fügt den Befehl in die Messroutine ein, aber positioniert diesen nach dem ausgewählten Befehl im Messroutinenbaum anstatt am Ende der Messroutine.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.


Werkzeugversatz festlegen - Sofort

Das Fenster Werkzeugversatz einstellen wird als Setup-Befehl in einem einzigen Arbeitsgang verwendet, um den Werkzeugversatz in einer interaktiven Sitzung zu bestimmen. Es handelt sich hierbei um eine unabhängige Einstellung, die nicht Teil einer Messroutine ist und dort auch nicht erscheint.

Hinweis: Dieser Vorgang sollte nur einmal ausgeführt werden, bevor das Werkstück geschnitten wird - durch eine zweite Ausführung dieses Vorganges würde die beabsichtigte Aktualisierung des Werkzeugversatzes verdoppelt.

Siehe auch "Werkzeugversatz aktualisieren - Messroutinensteuerung" für Anweisungen zur Definition des Werkzeugversatzes in einer interaktiven Sitzung, die Teil einer Messroutinensteuerung ist.

  1. Drücken Sie den Softkey Vorwärts [image], um zur zweiten Seite des Hauptfensters zu gelangen.

  2. Drücken Sie auf den Softkey Werkzeugversatz einstellen [image], um das Fenster Werkzeugversatz einstellen aufzurufen.

Stellen Sie sicher, dass der entsprechende Werkzeugversatztyp (A, B oder C) für die Steuereinheit, die im NC Gage Konfigurationswerkzeuges verwendet wird, ausgewählt ist.

Hinweis: Die Funktion "Werkzeugversatz einstellen" basiert auf dem Werkstückelement mit dem Zielwert, der um das von Ihnen eingegebene Werkzeug beschnitten wurde. In dieser Situation ist die Differenz zwischen dem Zielwert und dem gemessenen Wert der Abnutzungsfehler der Werkzeugversatz. Es ist äußerst wichtig, diesen Sachverhalt zu verstehen, da die Aktualisierung den Wert des Werkzeugversatzes dauerhaft verändert.

Zur Durchführung einer Aktualisierung des Werkzeugversatzes in einem Arbeitsgang gehen Sie vor wie folgt:

  1. Navigieren Sie zur zweiten Seite im Hauptfensters von NC Gage.

  2. Drücken Sie auf den Softkey Werkzeugversatz einstellen [image] , um das Fenster Werkzeugversatz einstellen aufzurufen.

  3. Geben Sie im Bereich Werkzeugversatz die Werkzeugnummer des Werkzeuges, das zum Schneiden des in der Berechnung verwendeten Elements eingesetzt wird, ein. Ist der Werkzeugversatztyp A, dann wird der Werkzeugversatz durch eine einzige Zahl, Geometrie, dargestellt. Der modifizierte Werkzeugversatz wird auf diese Zahl angewandt. Ist der Werkzeugversatztyp A oder B, dann wird der aktuelle gesamte Werkzeugversatz (Geometrie + Abnutzung) angezeigt. Die Änderung des Werkzeugversatze wird auf den Abnutzungswert angewandt.

Sobald Sie eine gültige Werkzeugnummer eingeben, aktualisiert NC Gage das Fenster wie folgt:

  • Abruf des Werkzeugversatzes von der NC-Maschine.

  • Anzeige des aktutellen Versatzes und Berechnung der neuen Länge.

  • Anzeige des Unterschiedes zwischen diesen beiden Zahlen. Diese Differenz sollte mit der Abweichung der Elementposition übereinstimmen. Der Grund hierfür ist, dass NC Gage den Werkzeugversatz berechnet, die ein "perfektes" Element in dem Fall geschnitten hätte, wenn die Einstellung während des Schneidevorganges stattgefunden hätte.

Hinweis: Wenn NC Gage bestimmt, dass die von Ihnen eingegebene Werkzeugnummer mit der aktiven Tasternummer in der Messroutine übereinstimmt (siehe den Wert Tasche im aktiven Tasterbereich auf der linken Seite dieses Formblattes), wird eine Warnmeldung eingeblendet. Dadurch wird im Prinzip das System aufgefordert, die unzulässige Tasterlänge zu aktualisieren - die Werkzeugnummer und die aktive Tasternummer dürfen nicht übereinstimmen. Korrigieren Sie dies und fahren Sie dann fort.

  4. Wählen Sie einen geeigneten Arbeitsversatz von der Liste Arbeitsversatz.

  5. Drücken Sie den Softkey Durchmesser-Modus auswählen [image], wenn der Durchmesser-Modus eingegeben werden muss. Sie können auch das Kontrollkästchen Durchmesser im Bereiche Werkzeugversatz aktivieren, um den Durchmesser-Modus einzugeben. Sobald dieser Modus aktiviert ist, basieren alle Werte im Bereich Werkzeugkompensierung auf dem Durchmesser des Werkzeugs. Wenn der Durchmesser-Modus nicht aktiviert ist, basieren die Werte auf dem Radius des Werkzeugs.

  6. Folgen Sie den Bildschirmanweisungen, um den Taster weg vom Zielpunkt entlang der Arbeitsflächennormalen zu positionieren.

  7. Drücken Sie den Softkey Position lesen [image], um den Zielpunkt einzulesen.

  8. Folgen Sie den Bildschirmanweisungen, um den Taster zur automatischen Messung zu positionieren.

  • Es wird entlang der Tasterrichtung gemessen; demnach sollte sich die Oberflächennormale ebenfalls entlang der Tasterrichtung befinden.

  • Die Abweichung für die Aktualisierung wird in der Tasterrichtung (Oberflächennormale) berechnet.

  • Wenn die Oberlfächennormale parallel zu einer Werkstück-Koordinatenachse verläuft, dann ist nur ein Achsenziel erforderlich; ansonsten müssen alle drei Achsen (XYZ) eingegeben werden. Jede beliebige Position auf der Zieloberfläche des Elements ist zulässig.

  9. Drücken Sie den Softkey Ausführen [image], um den Vorgang abzuschließen. Der Punkt wird gelernt und die Differenz wird aufgrund des gemessenen Z-Punktwertes und dem Zielwert berechnet. Der neue Werkzeugversatz wird angezeigt.

  10. Es ist äußerst wichtig, zu verstehen, dass die Aktualisierung auf dem zuletzt vorgenommenen Schnitt basiert und den Werkzeugversatzwert dauerhaft ändert. Stellen Sie sicher, dass die geplanten Änderungen korrekt sind und drücken Sie dann den Softkey Bestätigungsschaltfläche zur Aktualisierung der Werkzeuglänge [image], um die Änderungen abzuschließen. Der Differenzwert wird auf die Abnutzungslänge der von Ihnen eingegebenen Werkzeugnummer aktualisiert. Drücken Sie den Softkey Zurücksetzen [image], um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Hinweis: Die Abnutzung für das derzeitig identifizierte Werkzeug wird um den Wert, den NC Gage als die Differenz zwischen den Ziel- und den Messpositionen berechnet, modifiziert. Die Werkzeugabnutzung wird jedesmal, wenn der Softkey Bestätigen [image] ausgewählt wird, um diesen Differenzwert korrigiert. Deshalb wird der Benutzer besonders darauf hingewiesen, diese Routine für jede Instanz, in der eine Fläche von einem Werkzeug geschnitten wird, nur einmal auszuführen.

Bereich "Antast-Parameter"

Vorhalteabstand - Der Vorhalteabstand gibt die Position, an der der Taster die Suche nach der Fläche beginnt, an. Hierbei handelt es sich um den Abstand weg von der theoretischen Fläche, die der Taster bei "Suchgeschwindigkeit", die im Setup-Fenster eingerichtet wurde, durchquert.

Suchabstand - Beim Suchabstand handelt es sich um die Entfernung, die der Taster während der Suche nach der Fläche fährt, während er sich im Lernmodus befindet. Ist der Taster beispielsweise in der Mitte eines Loches positioniert, dann bewegt er sich bei "Suchgeschwindigkeit", die im Setup-Fenster für den Suchabstand in jeder Richtung ermittelt wurde, um die Elementposition zu suchen bzw. zu lernen.

Bereich "Parameter"

XYZ-Messwert/-Ziel - Gibt den XYZ-Messwert- und die XYZ-Zielpositionen des Arbeitsversatzes an. Die Messwerte werden von einem 'Kreis (Bohrung)-Lernprozess' gelernt.

Bereich "Werkzeugversatz"

Versatz-Nummer - Geben Sie hier die Werkzeugversatz-Nummer des Werkzeuges, das gerade verwendet wird, ein.

Tischtyp

Kompensierungsart

Suffix

Bereich "Werkzeugkompensierung"

Aktuell - Zeigt den aktuellen Werkzeugversatz an. Der Wert basiert auf dem Radius des Werzeuges. Wenn der Durchmesser-Modus aktiviert ist, basieren die Werte auf dem Durchmesser des Werkzeugs.

Neu - Blendet den neuen Werkzeugversatz ein. Der Wert basiert auf dem Radius des Werzeuges. Wenn der Durchmesser-Modus aktiviert ist, basieren die Werte auf dem Durchmesser des Werkzeugs.

Diff - Blendet die Differenz zwischen dem aktuellen und dem neuen Werkzeugversatz, die als Werkzeugversatz verwendet wird, ein. Der kompensierte Wert ist der Radius des Werkzeuges, sofern der Durchmesser-Radius nicht aktiviert ist. Im Durchmesser-Modus ist dieser kompensierte Wert der Durchmesser des Werkzeuges.

Bereich "Arbeitsversatz"

Wählen Sie den zu aktualisierenden Arbeitsversatz aus.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zum vorherigen Schritt zurückkehren Dieser Softkey löscht die zuletzt erlernten Tasterpositionen. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Wählen Sie einen Nullpunkt zum Aktualisieren Dieser Softkey wählt den benannten Arbeitsversatz aus der Versatzliste zur Aktualisierung aus. Die wiederholte Betätigung wählt den nächsten Arbeitsversatz aus. | Wählen Sie einen Taster aus Wenn der Bildschirm Taster auswählen nicht bereits angezeigt wird, ruft dieser Softkey diesen Bildschirm auf. Wenn der Bildschirm Taster auswähle bereits angezeigt wird, können Sie mit diesem Softkey jeden Taster in der Taster-Liste auswählen.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Durchmesser-Modus auswählen Klicken, um NC Gage im Durchmesser-Modus zu nutzen. Wenn der Durchmesser-Modus gestartet wurde, ist das Kontrollkästchen Durchmesser-Modus im Fenster markiert.


Werkzeugversatz aktualisieren - Messroutinensteuerung

Das Fenster Werkzeugversatz aktualisieren zur Messroutinensteuerung definiert den Werkzeugversatz in einer interaktiven Sitzung, die Teil einer Messroutinesteuerung sein wird.

Anweisungen, um den Werkzeugversatz in einem Arbeitsgang unabhängig zu aktualisieren, finden Sie unter " Werkzeugversatz einstellen - Sofort ".

  1. Nachdem ein Element gemessen wurde, wählen Sie im Hauptfenster den Softkey Messen [image] aus.

  2. Drücken Sie den Softkey Vorwärts [image] so lange, bis die dritte Seite der Softkeys angezeigt wird.

  3. Wählen Sie den Softkey Werkzeugversatz aktualisieren [image], um das Fenster Werkzeugversatz aktualisieren aufzurufen:

Hinweis: Die Funktion "Werkzeugversatz aktualisieren" basiert auf dem Werkstückelement mit dem Zielwert, der um das von Ihnen eingegebene Werkzeug beschnitten wurde. In dieser Situation ist die Differenz zwischen dem Zielwert und dem gemessenen Wert der Abnutzungsfehler der Werkzeugversatz. Es ist äußerst wichtig, diesen Sachverhalt zu verstehen, da die Aktualisierung den Wert des Werkzeugversatzes dauerhaft verändert.

So aktivieren Sie die Aktualisierung des Werkzeugversatzes durch die Messroutine:

  1. Navigieren Sie zur dritten Seite des Fensters Messen.

  2. Wählen Sie den Softkey Werkzeugversatz aktualisieren [image] , um das Fenster Werkzeugversatz aktualisieren aufzurufen.

  3. Wählen Sie das Zielelement aus dem Listenfeld Elemente aus. Nachdem die Auswahl getroffen wurde, wird der theoretische Wert im Bereich Elementlage angezeigt. Nach der Elementmessung werden auch der Messwert und die Abweichung dieses Elements eingeblendet. Der Werkzeugversatz wird aufgrund der Abweichung aktualisiert. Als Elemente eignen sich diejenigen, die einen Z-Wert messen, am häufigsten ein Punkt oder eine Ebene. Nehmen Sie die entsprechende Auswahl aus der Liste vor.

  4. Drücken Sie den Softkey Durchmesser-Modus auswählen [image], wenn der Durchmesser-Modus eingegeben werden muss. Sie können auch das Kontrollkästchen Durchmesser im Bereiche Werkzeugversatz aktivieren, um den Durchmesser-Modus einzugeben. Sobald dieser Modus aktiviert ist, basieren alle Werte im Bereich Werkzeugkompensierung auf dem Durchmesser des Werkzeugs. Wenn der Durchmesser-Modus nicht aktiviert ist, basieren die Werte auf dem Radius des Werkzeugs.

  5. Geben Sie im Bereich Werkzeugversatz die Werkzeugnummer des Werkzeuges, das zum Schneiden des in der Berechnung verwendeten Elements eingesetzt wird, ein. Nachdem eine gültige Werkzeugnummer eingegeben wurde,wird der aktuelle gesamte Werkzeugversatz (Geometrie + Abnutzung) im Bereich Werkzeugversatz angezeigt. Das Fenster wird mit den folgenden Informationen aktualisiert:

    • Der Werkzeugversatz wird von der NC-Maschine abgerufen.

    • Die Aktuellen und Neuen Versätze werden berechnet und angezeigt.

    • Die Differenz zwischen diesen beiden Zahlen wird eingeblendet. Diese Differenz sollte mit der Abweichung der Elementposition übereinstimmen. Der Grund hierfür ist, dass NC Gage den Werkzeugversatz berechnet, die ein "perfektes" Element in dem Fall geschnitten hätte, wenn die Einstellung während des Schneidevorganges stattgefunden hätte.

    Hinweis: Wenn NC Gage bestimmt, dass die von Ihnen eingegebene Werkzeugnummer mit der aktiven Tasternummer in der Messroutine übereinstimmt, wird eine Warnmeldung eingeblendet. Dadurch wird im Prinzip das System aufgefordert, die unzulässige Tasterlänge zu aktualisieren - die Werkzeugnummer und die aktive Tasternummer dürfen nicht übereinstimmen. Korrigieren Sie dies und fahren Sie dann fort.

  6. Drücken Sie den Softkey Bestätigen [image], um die neuen Werte zu speichern und um die Aktualisierung des Werkzeuges, die in die Messroutine geschrieben wird, abzuschließen. Die Aktualisierung selbst erfolgt bei der nächsten Ausführung der Messroutine. Drücken Sie den Softkey Zurück [image], um zum vorherigen Fenster zurückzukehren.

Hinweis: Die Abnutzung für das derzeitig identifizierte Werkzeug wird um den Wert, den NC Gage als die Differenz zwischen den Ziel- und den Messpositionen berechnet, modifiziert. Die Werkzeugabnutzung wird jedesmal, wenn der Softkey Bestätigen [image] ausgewählt wird, um diesen Differenzwert korrigiert. Deshalb wird der Benutzer besonders darauf hingewiesen, diese Routine für jede Instanz, in der eine Fläche von einem Werkzeug geschnitten wird, nur einmal auszuführen.

Bereich "Elemente"

Dieser Bereich zeigt eine Liste der verfügbaren Elemente, die zur Auswahl bereitstehen. In der Liste werden nur gültige Elementtypen eingeblendet.

Bereich "Parameter"

Messwert - Zeigt die gemessene Position an.

Zielwert - Zeigt die Nennposition an.

Bereich "Werkzeugversatz"

Tischtyp - Besitzt zwei Optionen: EIAWerkzeugVersatz und MazatrolWerkzeugDaten.

Versatznummer - Die Nummer des Werkzeugs in der folgenden Tabelle.

Zielwerkzeug - Gilt nur für den Tischtyp MazatrolWerkzeugDaten. Wenn Sie eine Versatznummer eingeben, wird das Zielwerkzeug dieser Liste hinzugefügt. Der Werkzeugname besteht aus dem Werkzeugdatennamen, dem Werkstücktyp, dem Nennwert und dem Suffix.

Der Werkstücktyp Mazak lautet wie folgt:

OUT = 1, // outer diameter
IN = 2, // inner diameter
EDGE = 3, // face end
IN_BACK = 4, //IN (Back) - inner diameter (back)
EDGE_BACK = 5, //EDGE (Back) - face end (back)

Der Mazak-Suffix lautet wie folgt:

A = 1, B, C, D, E, F, G, H,/*no I*/ J, K, L, M, N,/*no O*/ P, Q, R, S, T, U, V, W, X, Y, Z

Somit erscheint das Zielwerkzeug als: "Werkzeugname" + "Werkstücktyp" + "Nennwert" + "Suffix"

Ziel - Zeigt die Zielkompensationstypen: A, B, C, D.

  • Wenn Sie den Tischtyp EIAWerkzeugVersatz auswählen, werden die Zielkompensationstypen in der Liste Ziel abhängig vom entsprechenden Werkzeugversatztypen aufgelistet.

Hinweis: Der Werkzeugversatztyp wird in der Auswahlliste Werkzeugversatztyp auf der Registerkarte Parameter im NC Gage Konfigurationswerkzeug definiert. Weitere Informationen finden Sie unter "Anhang A - Konfiguration Steuereinheit".

Die folgende Tabelle enthält die Zielkompensationstypen, die in der Liste Ziel abhängig vom Werkzeugversatztyp angezeigt werden.

Werkzeugversatztyp | Zielkompensierungstyp
Typ A | Kein
Typ B | WERKZEUGLÄNGENGEOMETRIE WERKZEUGLÄNGENVERSCHLEIß WERKZEUGRADIUSGEOMETRIE WERKZEUGRADIUSVERSCHLEIß
Typ C | GEOMETRISCHER VERSATZ X GEOMETRISCHER VERSATZ Y GEOMETRISCHER VERSATZ Z GEOMETRISCHER VERSATZ ANSATZ VERSCHLEIßKOMP. X VERSCHLEIßKOMP. Y VERSCHLEIßKOMP. X Z VERSCHLEIßKOMP. ANSATZ
Typ D | GEOMETRISCHER VERSATZ X GEOMETRISCHER VERSATZ Y GEOMETRISCHER VERSATZ Z

  • Wenn Sie als Tischtyp MazatrolWerkzeugDaten gewählt haben, werden die Zielkompensationstypen in der Liste Ziel gemäß des Werkzeugnamen angezeigt. Die folgende Tabelle zeigt die Typen, die für jeden Werkzeugnamen angezeigt werden.

Zielkompensierungstyp | Werkzeugnamentyp
 | 1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9 | 10 | 11 | 12 | 13 | 14 | 15 | 16 | 17 | 18 | 19 | 33 | 34 | 35 | 36 | 37 | 38 | 39 | 40 | 41 | 42 | 43
Länge | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x |  |  |  | x | x | x | x | x | x | x |
LÄNGE A |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  | x | x | x |  |  |  |  |  |  |  | x
LÄNGE B |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  |  | x | x | x |  |  |  |  |  |  |  | x
AKT-φ |  |  |  |  |  |  |  |  |  |  |  |  |  | x | x | x |  |  | x |  |  |  |  |  |  |  |  |  |  |
VERSCHLEIßKOMP. X | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x
VERSCHLEIßKOMP. Y | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x
VERSCHLEIßKOMP. Z | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x | x

Kontrollkästchen Durchmesser - Wählt die Aktualisierung für den Werkzeugdurchmesserversatz nach Durchmesser oder Radius.

  • Wenn das Kontrollkästchen Durchmesser aktiviert ist, wird der Werkzeugdurchmesserversatz mit dem Durchmesser aktualisiert.

  • Wenn das Kontrollkästchen Durchmesser deaktiviert ist, wird der Werkzeugdurchmesserversatz mit dem Radius aktualisiert. Dies ist die Standardeinstellung.

Der folgende Tisch beschreibt die Verfügbarkeit des Kontrollkästchens Durchmesser für den Tischtyp EIAWerkzeugVersatz:

Werkzeugversatztyp | Zielkompensierungstyp | Status Kontrollkästchen "Durchmesser"
A | Kein | Verfügbar
B | WERKZEUGLÄNGENGEOMETRIE WERKZEUGLÄNGENVERSCHLEIß | Nicht verfügbar
B | WERKZEUGRADIUSGEOMETRIE WERKZEUGRADIUSVERSCHLEIß | Verfügbar
C | GEOMETRISCHER VERSATZ X GEOMETRISCHER VERSATZ Y GEOMETRISCHER VERSATZ Z GEOMETRISCHER VERSATZ ANSATZ VERSCHLEIßKOMP. X VERSCHLEIßKOMP. Y VERSCHLEIßKOMP. X Z VERSCHLEIßKOMP. ANSATZ | Verfügbar
D | GEOMETRISCHER VERSATZ X GEOMETRISCHER VERSATZ Y GEOMETRISCHER VERSATZ Z | Verfügbar

Der folgende Tisch beschreibt die Verfügbarkeit des Kontrollkästchens Durchmesser für den Tischtyp MazatrolWerkzeugDaten:

Zielkompensierungstyp | Status Kontrollkästchen "Durchmesser"
LÄNGE LÄNGE A LÄNGE B | Nicht verfügbar
AKT-φ VERSCHLEIßKOMP. X VERSCHLEIßKOMP. Y VERSCHLEIßKOMP. Z | Verfügbar

Einen Befehl hinzufügen

So fügen Sie einen Befehl zu einer Messroutine hinzu:

  1. Wählen Sie ein Element im Bereich Elemente auf der linken Seite des Fensters. Dabei kann es sich um einen Punkt, eine Ebene, einen Kreis, einen Steg oder eine Tasche handeln.

    • Wenn Sie einen Punkt oder eine Ebene auswählen, wird im Bereich Parameter die Position des Elementes als X, Y und Z angezeigt.

    • Wenn Sie einen Kreis, Steg oder eine Tasche auswählen, sehen Sie im Bereich Parameter den Durchmesser des Kreises und die Breite der Tasche oder des Stegs.

  2. Wählen Sie den Tischtyp.

  3. Geben Sie die Werkzeugversatznummer ein.

Wenn Sie als Tischtyp MazatrolWerkzeugDaten wählen, wird das Zielwerkzeug automatisch vervollständigt. Andernfalls wird die Zielkompensierung automatisch eingepflegt.

  4. Sie können die Zielkompensierung auswählen und die aktuellen Wert im Bereich Werkzeugkompensierung anzeigen. NC Gage berechnet zudem die Differenz und zeigt diese im Feld Diff an. Aus diesen beiden Werten kann der neue Wert berechnet werden.

  5. Drücken Sie Bestätigen, um den Befehl zur Messroutine hinzuzufügen.

Bereich "Werkzeugkompensierung"

Aktuell - Zeigt den aktuellen Werkzeugversatz an.

Neu - Blendet den neuen Werkzeugversatz ein.

Diff - Blendet die Differenz zwischen dem aktuellen und dem neuen Werkzeugversatz, die als Werkzeugversatz verwendet wird, ein. Der kompensierte Wert ist der Radius des Werkzeuges, sofern der Durchmesser-Radius nicht aktiviert ist. Im Durchmesser-Modus ist dieser kompensierte Wert der Durchmesser des Werkzeuges.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zuletzt erstellten Befehl löschen Dieser Softkey löscht den zuletzt erstellten Befehl aus Ihrer Messroutine. | Durchmesser-Modus auswählen Klicken, um NC Gage im Durchmesser-Modus zu nutzen. Wenn der Durchmesser-Modus gestartet wurde, ist das Kontrollkästchen Durchmesser-Modus im Fenster markiert.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.
Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung. |


Koordinatenrotation einstellen

NC Gage bietet eine leicht zu bedienende Funktion, um die zweidimensionale Rotationsanpassung für das Koordinatensystem zu definieren, die von der CNC-Maschine für die Messung der gewünschten Elemente und später bei der Auswahl der Elemente für die Koordinatensystem-Rotation verwendet wird. Ohne diese Funktion müssten Sie den entsprechenden Rotationsmittelpunkt, Achsenvektor und Winkel für den G68-Code manuell eingeben.

Sobald die Elemente gemessen wurden, wählen Sie das Fenster Koordinatensystem-Rotation setzen, um die Elemente für die Rotationsberechnung auszuwählen. NC Gage aktualisiert daraufhin den G68- bzw. G68.2-Code für das neue rotierte Koordinatensystem.

Hinweis: Es kann nur ein Rotations-Makro geben. Nachfolgende Definitionen in NC Gage überschreiben die vorhandenen Parameter.

  1. Drücken Sie im Hauptfenster auf den Softkey Messen [image].

  2. Drücken Sie so lange auf den Softkey Vorwärts [image], bis der Softkey Rotation des Koordinatensystems einrichten angezeigt wird.

  3. Wählen Sie den Softkey Koordinatensystem-Rotation setzen [image], um das Fenster Koordinaten-Rotation setzen aufzurufen.

Bereich "Parameter"

Hinweis: Durch die Koordinaten-Rotationen kann das Koordinatensystem auf einer NC-Werkzeugmaschine gedreht werden. Es ist nicht möglich, eine Messung vorzunehmen, wenn eine Koordinaten-Rotation aktiv ist, weshalb die Funktion "Koordinaten-Rotation" während der Ausführung des Befehls nicht aktiviert ist. Die Angaben werden in Makro-Variablen berechnet und ein Makro-Programm kann aufgerufen werden, das diese Angaben zur Durchführung der Koordinaten-Rotation verwendet.

  • a1, a2, R: Diese Liste zeigt die Elemente in Messroutine, die zur Definition der Achsenübersetzung (a1=Achse 1, a2=Achse 2) und einer Rotation (R-Liste) verwendet werden können. Die Achsen werden durch die mit Hilfe des Softkeys Messfläche auswählen getroffene Auswahl, wie weiter unten veranschaulicht, definiert.

  • a1, a2, R Werkstück: Diese schreibgeschützten Felder zeigen die Achsenwerte (a1=Achse 1, a2=Achse 2) und Rotation (R) für die aktuell ausgewählten Elemente aus den Achsen- und R-Listen an. Diese Werte wurden bereits in das Werkstück-Koordinatensystem übertragen. Die Achsen werden durch die mit Hilfe des Softkeys Messfläche auswählen getroffene Auswahl, wie weiter unten veranschaulicht, definiert.

  • a1, a2, R Maschine: Diese schreibgeschützten Felder zeigen die Achsenwerte (a1=Achse 1, a2=Achse 2) und Rotation (R) für die aktuell ausgewählten Elemente aus den Achsen- und R-Listen an. Diese Werte wurden bereits in das Koordinatensystem der Maschine übertragen. Die Achsen werden durch die mit Hilfe des Softkeys Messfläche auswählen getroffene Auswahl, wie weiter unten veranschaulicht, definiert.

  • a1, a2, R Ziel: Diese Felder definieren die Zielachsenwerte (a1=Achse 1, a2=Achse 2) Rotation (R) für die Rotation des Koordinatensystems. Mit diesen Feldern können Sie die genaue Koordinatensystemposition und den zu verwendenden Rotationswinkel bestimmen. Die Achsen werden durch die mit Hilfe des Softkeys Messfläche auswählen getroffene Auswahl, wie weiter unten veranschaulicht, definiert. Die Maschinenkoordinaten werden zum Setzen des Befehls für die Koordinatendrehung verwendet.

Hinweis: Was den Rotationswinkel betrifft, so werden die ausgewählten Elemente, die möglicherweise eine Gerade definiert haben (wie beispielsweise eine Gerade, Ebene, Tasche, Steg, Zylinderbohrung/-austülpung und Kegelbohrung/-ausstülpung), automatisch in den entsprechenden Feldern aktualisiert. Die Normalenachse der Zylinder-, Kegel- und Ebenenelemente werden zur Erstellung der 2D-Winkel verwendet. Der Vektorwinkel des ausgewählten Geraden-Elementtyps kann auch zur Definition des Rotationswinkels verwendet werden.

  • Kommentar: In dieses Feld können Sie einen Kommentar zur aktuellen Systemrotation eingeben.

Messfläche auswählen - Übersicht

Beim Einfügen eines Befehls "Koordinatensystem-Rotation" in Ihre Messroutine ist es notwendig, dass die Arbeitsebene, die Achsenwerte sowie die Rotationswinkel für die Drehung des Koordinatensystems festgelegt werden. Zur Definition der Arbeitsebene stehen die folgenden Optionen für die Messebene zur Verfügung, die mit Hilfe der Schaltfläche Messfläche auswählen gesetzt werden können:

XY-Ebene

Wenn die XY-Arbeitsebene ausgewählt ist, zeigt NC Gage die X-, Y- und R-Sprungmarken sowie die entsprechenden Angaben im Bereich Parameter an.

YZ-Ebene

Wenn die YZ-Arbeitsebene ausgewählt ist, zeigt NC Gage die Y-, Z- und R-Sprungmarken sowie die entsprechenden Angaben im Bereich Parameter an.

XZ-Ebene

Wenn die XZ-Arbeitsebene ausgewählt ist, zeigt NC Gage die X-, Z- und R-Sprungmarken sowie die entsprechenden Angaben im Bereich Parameter an.

Koordinatensystem-Rotation setzen

  1. Bestimmen Sie die Übersetzung in X- und Y-Richtung, indem Sie Elemente aus der X- und Y-Liste auswählen, die gültige Messungen für jede Achse darstellen. Dabei handelt es sich um Punktelemente oder andere Elemente mit hinterlegten Mittelpunktwerten, z.B. Kreis (Bohrung). Mit diesen Elementen wird der Ursprung des neuen Koordinatensystems definiert.

  2. Wählen Sie ein Element aus der R-Liste mit einer gültigen Richtung in der XY-Ebene, um die Rotation zu bestimmen. Dabei handelt es sich um Richtungselemente (z.B. Geraden).

  3. Definieren Sie für jedes Element die gewünschten Werte in den Feldern XZY-Zielwerte für die Achse oder den Winkel.

  4. Drücken Sie auf den Softkey Bestätigen [image], um die Koordinatensystem-Rotation zur NC Gage-Messroutine hinzuzufügen. Auch wenn das Symbol für die Koordinatensystem-Rotation in die Messroutine eingefügt ist, hat die Koordinatensystem-Rotation keine Auswirkungen auf die 'NC Gage'-Messroutine.

NC Gage berechnet die Deltas für die Übersetzung und Rotation zwischen den aktuellen und gewünschten Werten. X, Y und die Rotation werden dann in Makrovariablen überschrieben, die in einem Makrounterprogramm für die Koordinatensystem-Rotation verwendet werden. Dieses Unterprogramm wird aufgerufen, wenn NC Gage nach der Ausführung der Messroutine beendet wird.

Sie können das Makro-Unterprogramm erneut aufrufen, um die Änderungen am Koordinatensystem wiederholt anzuwenden. Die Makro-Nummer des Unterprogramms erhält dieselbe Nummer wie das Monitor-Unterprogramm-Makro + 2. Hatte das Monitor-Programm also die Nummer 7000, dann würde sich diese Nummer durch die Änderung des Koordinatensystems auf 7002 ändern. Es kann nur ein Rotations-Makro geben. Nachfolgende Definitionen in NC Gage überschreiben die vorhandene Datei.

Hinweis: NC Gage kann mit einer angewendeten Koordinatenrotation nicht ausgeführt werden. Aus diesem Grund werden Koordinatendrehungen nicht direkt gesetzt. Stattdessen werden die X-, Y- und R-Parameter gespeichert, damit Sie das Koordinatenrotations-Makro ggf. vor der Durchführung von Schnittvorgängen aufrufen können.

Beispiel

Angenommen, PUNKT2 (B in der unteren Abbildung) ist ein abhängiger Punkt vom Schnittpunkt der GERADE3 (C in der unteren Abbildung) und GERADE4 (A in der unteren Abbildung) und Sie wählen PUNKT2 als neuen Nullpunkt und GERADE4 als Rotationselement, wie folgt:

Damit wird NC Gage das Koordinatensystem um den PUNKT2 (B) bis zur LINIE4 (A) rotieren. Das Koordinatensystem hat seinen Ursprung in PUNKT2 (B) und die neue X-Achse ist die LINIE4 (A).

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Arbeitsfläche auswählen Dieser Softkey ändert jedesmal, wenn darauf gedrückt wird, die Messebene der XY-Ebene, YZ-Ebene und der XZ-Ebene. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.


Toleranz

Sie können den Toleranzwert entsprechend den Elementvoraussetzungen im Bildschirm 'Toleranz' bearbeiten. Anhand der Toleranzeinstellung wertet NC Gage die Messergebnisse aus.

Auf dieses Fenster können Sie mit dem Softkey Toleranz [image] auf der zweiten Seite eines beliebigen Elements zugreifen, nachdem dieses gemessen wurde und bevor auf den Softkey Bestätigen [image] gedrückt wurde, um den gelernten Befehl zu speichern.

Die standardmäßigen Protokolleinstellungen für jedes Element im Fenster Toleranz können Ihren Anforderungen entsprechend angepasst werden. Der Inhalt kann, wie weiter unten beschrieben, bearbeitet werden.

  1. Wählen Sie die zu protokollierende Achse aus. Markieren Sie die entsprechenden Kontrollkästchen.

  2. Bearbeiten Sie je nach Bedarf die theoretischen Werte.

  3. Bearbeiten Sie je nach Bedarf die Toleranzwerte.

  4. Zur Auswertung der Position eines Loches oder einer Ausstülpung müssen Sie das Kontrollkästchen Position aktivieren.

    Beispiel: Wenn sich ein Element innerhalb einer kreisförmigen Toleranzzone für die Funktionen Bohrung messen und Ausstülpung messen befindet, wird die Größe der Toleranzzone durch seinen Durchmesser bestimmt. Um zu überprüfen, ob sich das Element innerhalb dieser Toleranzzone befindet, aktivieren Sie das Kontrollkästchen Position.

    Die Bewertung einer Position besitzt immer den Nennwert 0.

Alle Einstellungen werden für jedes Element in der Messroutine abgespeichert, sobald Sie auf den Softkey Bestätigen [image] drücken. Drücken Sie den Softkey Zurück [image], um dieses Fenster zu verlassen, ohne dass Änderungen gespeichert werden.

Formtoleranzen

Formtoleranzen umfassen Ebenheit, Geradheit, Rundheit (oder Kreisförmigkeit), Sphärizität und Zylindrizität. Diese Toleranzen beziehen sich nur auf individuelle Elemente.

NC Gage kann die Formtoleranzen für verschiedene Element bewerten. Die Elemente und die dazugehörigen Toleranzen lauten:

  • Gerade: Geradheit

  • Bohrung und Ausstülpung: Rundheit

  • Schaft: Rundheit und Rundlauf (Rundlauf wird nur bei Messung mit Tischrotation angegeben)

  • Innen- und Außenzylinder: Zylindrizität

  • Kugel: Sphärizität

  • Kegel: Kegelform

  • Ebene: Ebenheit

Wählen Sie zur Bewertung der Formtoleranz des Elementes das Kontrollkästchen der Toleranz. Zum Beispiel:

Kontrollkästchen "Geradheit" für ein Geradenelement

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zum Speichern der Änderungen bestätigen. Dieser Softkey speicher alle Änderungen der Nennwerte oder Toleranzinformationen. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. |


Messpunkt Sicherheitsebene

Mit dem Kontrollkästchen Messpunkt Sicherheitsebene wird die lokale Sicherheitsebene während des Messvorganges definiert. Die Option ist in allen Fenstern für Elementbefehle sowie in den Fenstern Zwei Achsen setzen (Innere Ecke) und Zwei Achsen setzen (Äußere Ecke) zu finden.

Hinweis: Obwohl das Punktelement die Option Messpunkt Sicherheitsebene aufweist, funktioniert es nicht auf dieselbe Weise, da nur ein einziges Antasten im Messvorgang durchgeführt wird.

Bei Auswahl ist das Eingabefeld aktiviert, wenn ein Wert eingegeben wird, der die Position der Tasterbewegungen definiert, die durchgeführt werden, um Hindernisse während des Messvorganges zu vermeiden. Nach jeder Messung wird die Tastspitze in Tasterrichtung zur vorgegebenen Position "Messpunkt Sicherheitsebene" gefahren. Nachdem sich der Taster an der Position "Messpunkt Sicherheitsebene" befindet, wird er zur Sicheren Bewegungsposition in den XY-Achsen (in Elementkoordinaten) bewegt und anschließend zur Durchführung der nächsten Messpunktaufnahme gefahren.

Eine lokale Sicherheitsebene wird durch die Eingabehöhe in ein Element-Koordinatensystem definiert. Der Nullpunkt des Element-Koordinatensystems ist die Elementposition und der Z-Achsenvektor ist die Tasterrichtung (Tastspitze auf Spindel) bei der Elementmessung.

Beispiel "Messpunkt-Sicherheitsebene", die ein Kreiselement mit einer Ausstülpung und eine Ebene mit dem angezeigten Koordinatensystem für das Element verwendet

H - Der Eingabewert für die Messpunkt-Sicherheitsebene


Einfügen von Bewegungsbefehlen

NC Gage gibt Ihnen die Möglichkeit, Bewegungsbefehle in die Messroutine einzufügen, die eine Tasterkollision mit dem Werkstück vermeiden. Bewegungsbefehle werden zwischen Elementbefehle eingefügt. Der Taster muss vor dem Hinzufügen von Bewegungsbefehlen kalibriert sein (siehe "Kalibrierung").

Sobald ein Elementrahmen definiert worden ist, werden durch Auswahl des Softkeys Bewegen [image] aus der Navigationsleiste des Hauptfensters die folgenden Optionen verfügbar:

Die Befehle lauten:

  • Bewegungspunkt

  • Sicherheitsebene


Bewegungspunkt

Ein Bewegungspunktbefehl enthält die XYZ-Koordinaten, auf die sich die Tastspitzenmitte bei der Ausführung zubewegt. Diese Positionen werden dazu verwendet, den Taster frei von Hindernissen zu bewegen.

So fügen Sie den Befehl Bewegungspunkt der Messroutine hinzu:

  1. Drücken Sie aus der Navigationsleiste des Hauptfensters den Softkey Bewegen [image].

  2. Drücken Sie den Softkey Bewegungspunkt [image] , um das Fenster Bewegungspunkt aufzurufen:

  3. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben. Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen falls mehrere Schritte benötigt werden, angezeigt.

Parameterdefinition:

  • Zielposition (XYZ-Nennwert) - Definiert die theoretische Position des Punktes.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Zum vorherigen Schritt zurückkehren Dadurch werden die zuletzt erlernten Tasterpositionen entfernt. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Arbeitsfläche auswählen Dieser Softkey bestimmt die Antastrichtung und die Lage der Sicherheitsbewegungen für das Element. Sie können diesen mehrmals betätigen, um einen andere Messoberfläche zu wählen. Verfügbare Oberflächen sind: X+, X-, Y+, Y-, Z+ und Z-. | Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen.
Lernen und Erstellen eines Befehls Dieser Softkey ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Das Element kann vor der Übergabe an die Messroutine geändert und getestet werden. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Toleranzeinstellungen Mit diesem Softkey können Sie die Nominal- und Toleranzwerte eines Elements festlegen oder ändern, die vom Elementbefehl verwendet werden. Hier erhalten Sie einen Überblick darüber, was im Protokollfenster erscheint. | Bewegungspunkt einfügen Mit diesem Softkey wird die aktuelle Position des Tasters eingelesen und als eine Sicherheitsebenenbewegung in die Messroutine eingefügt.
Bestätigen / Befehl hinzufügen Bei Arbeitsgängen wird hiermit die Auswahl bestätigt. Für Befehle wird damit der Befehl am Ende der Messroutine hinzugefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.
Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet. |

Lernvorgang

  1. Positionieren Sie den Taster auf die Bewegungspunktposition und drücken Sie den Softkey Position lesen [image] . Die Tastspitzenposition wird gelesen. Drücken Sie den Softkey Zurück zum vorherigen Schritt [image] , um diese Messposition abzubrechen.

  2. Drücken Sie den Softkey Aktuellen Befehl bestätigen und am Ende anhängen [image] . Der neue Befehl Bewegungspunkt wird in die Messroutine eingefügt.

Hinweis: Wird das Fenster 'Bewegungspunkt' von der zweiten Seite eines beliebigen Elementfensters aufgerufen, dann wird der Bewegungspunkt in die Messroutine hinter dem Element eingefügt.

Nachfolgend handelt es sich um den 'NC-Gage'-spezifischen Elementpfad und logischen Aufbau in NC Gage:

  • Wenn die aktuelle Z-Position höher als die Zielposition ist, dann fahren Sie zur XY-Zielposition an der aktuellen Z-Höhe und fahren anschließend zur Z-Zielposition.

  • Wenn die aktuelle Z-Position niedriger ist als die Zielposition, dann fahren Sie hoch zur Z-Zielposition und anschließend zur XY-Zielposition.


Sicherheitsebene

Ein Sicherheitsebenenbefehl enthält die XYZ-Koordinaten und den Vektor einer Ebene, über den hinaus sich die Tastspitzenmitte bei der Ausführung bewegt.

So fügen Sie den Befehl Sicherheitsebene Bewegungspunkt der Messroutine hinzu:

  1. Drücken Sie aus der Navigationsleiste des Hauptfensters den Softkey Bewegen [image].

  2. Drücken Sie den Softkey Sicherheitsebene [image] , um das Fenster Sicherheitsebene anzuzeigen:

  3. Befolgen Sie die Anweisungen auf dem Bildschirm, um den Befehl einzugeben.

Hinweis: Beachten Sie die grafische Beschreibung oben links im Bildschirm. Darin wird Ihnen die Position des Tasters für Messungen bzw. Positionsänderungen falls mehrere Schritte benötigt werden, angezeigt.

Parameter-Definitionen:

  • Richtungsweisende Ebenenhöhe der Tastspitze - Definiert den Abstand zwischen dem Werkstückursprung und der Sicherheitsebene gemessen entlang der Richtung der Tastspitze.

  • Lernen mit Hilfe der Werte auf dem Bildschirm - Mit dieser Funktion können Sie die theoretischen Werte des Elements eingeben und das Programm dadurch veranlassen, diese Position zu verwenden.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung. | Fokus umschalten zwischen Über diesen Softkey wird die Platzierung des Cursors zwischen den unterschiedlichen Bildschirmbereichen umgeschaltet.
Zum vorherigen Schritt zurückkehren Dieser Softkey löscht die zuletzt erlernten Tasterpositionen. | Lesen Sie die Tasterposition und fahren Sie mit dem Nächsten Schritt fort Über diesen Softkey wird die aktuelle Tasterposition gelesen und dann zum nächsten Schritt des Verfahrens fortgeschritten.
Aktuellen Befehl löschen / Zuletzt erstellten Befehl löschen Dieser Softkey löscht den aktuell ausgewählten Befehl (oder den zuletzt erstellten Befehl) aus der Messroutine. Falls dieses Symbol nicht aktiviert ist, können Sie Befehle im Bildschirm Messroutine bearbeiten löschen. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Ausführen Dieser Softkey startet die Messung des Elements durch die Maschine. Diese Option ist nur dann verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementposition erlernt (oder eingegeben) worden sind. Damit können Sie Änderungen bzw. einen Testlauf des Elements vornehmen bevor Sie das Element an die Messroutine übergeben. | Lernen und Erstellen eines Befehls (Ausführen) Dieser Softkey ist nur verfügbar, wenn alle erforderlichen Tasterpositionen zur Identifizierung der Elementlage erlernt worden sind. Er startet die Messung des Elements durch die Maschine.

Lernvorgang

  1. Drücken Sie aus der Navigationsleiste des Hauptfensters den Softkey Bewegen [image].

  2. Drücken Sie den Softkey Sicherheitsebene [image].

  3. Stellen Sie die Sicherheitsebenenposition ein. Dazu gibt es folgende Vorgehensweisen:

    1. Durch das Rücken der Tastspitze zur erforderlichen Bewegungspunktposition und anschließendes Drücken auf den Softkey Position lesen [image], um die aktuelle Position als das Ziel aufzunehmen.

    2. Durch Markieren von Lernen mit Hilfe der Werte auf dem Bildschirm und anschließender Eingabe der Position in das Feld Richtungsweisende Ebenenhöhe der Tastspitze. Die Position ist relativ zur Tastspitzenmitte und dem aktuellen Arbeitsversatz.

  4. Drücken Sie den Softkey Bestätigen [image]. Der Befehl Sicherheitsebene wird der Messroutine hinzugefügt.

Mindesthöhe der Sicherheitsebene:

Die Berechnung der Mindesthöhe der Sicherheitsebene bezieht sich auf die Vorbehalteabstand und den Tasterradius. NC Gage definiert die Sicherheitsebene, so dass der Taster nicht näher als der Vorhalteabstand an das Werkstück geführt wird. Das Programm nimmt auch an, dass wenn ein Element an einer "Wand" gemessen wird, dass die Tiefe der Messung mindestens dem Tasterradius entspricht.

  • Für Elemente, die auf einer "Wand" gemessen werden (Bohrungen, Ausstülpungen, Geraden, Zylinder, Kegel, Stege, Taschen, Ecken), gilt:
    Sicherheitsebenen-Mindesthöhe = Messhöhe + (2 * Tasterradius) + Vorhalteabstand

oder

Sicherheitsebenen-Mindesthöhe = Messhöhe + Tasterdurchmesser + Vorhalteabstand

  • Für Elemente, die oben auf dem Werkstück gemessen werden (Ebene und Punkt), gilt:
    Sicherheitsebenen-Mindesthöhe = Messhöhe + Tasterradius + Vorhalteabstand

  • Für Kugelelemente:
    Mindesthöhe der Sicherheitsebene = Kugelmittelpunkt + Kugelradius + Tasterradius + Anfahrweg

Seitenansicht eines Werkstück und einer Tasterspitze

A - Mindesthöhe

B - Anfahrweg

C - Tasterspitze


Arbeiten mit Messroutinen

Sobald Sie die Messroutine mit den Elementen, die Sie messen möchten besitzen, können Sie Ihre Messroutine ausführen oder bearbeiten. In NC Gage stehen Ihnen für die Aufgaben die Fenster Messroutine ausführen bzw. Messroutine bearbeiten zur Verfügung.

Die folgenden Abschnitte enthalten weitere Informationen zu diesen Bildschirmen:

  • Messroutinen anzeigen und ausführen

  • Messroutinen bearbeiten


Messroutinen anzeigen und ausführen

Dieser Softkey öffnet das Fenster Messroutine bearbeiten, wo Sie die Messroutine anzeigen und ausführen können.

Dieses Fenster können Sie über den Softkey Messroutine ausführen [image] im Hauptfenster aufrufen:

Das aktuell ausgeführte Element der Messroutine wird in der Baumansicht in Magenta angezeigt.

Beispiel für das Winkel zwischen Element

Beispiel für Aufzeichnung von Parallelität von Winkeln

Beispiel für Aufzeichnung von Rechtwinkligkeit von Winkeln

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Vom aktuellen Befehl bis zum Ende ausführen Dieser Softkey veranlasst NC-Gage, die Messroutine ab dem im Baumfenster hervorgehobenen (ausgewählten) Element bis zum Ende auszuführen. | Ausführen eines Blocks Dieser Softkey veranlasst NC-Gage, die nur das im Baumfenster hervorgehobenen (ausgewählten) Element der Messroutine auszuführen.
Messroutine ausführen Dieser Softkey veranlasst NC Gage die gesamte Messroutine auszuführen. | Ausführung anhalten Dieser Softkey veranlasst NC Gage die Ausführung der Messroutine abzubrechen.
Gehe zum Ende Dieser Softkey verschiebt die Markierung zum Ende der Messroutine. | Gehe zum Anfang Dieser Softkey verschiebt die Markierung zum Anfang der Messroutine.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.


Bearbeiten von Messroutinen

Im Fenster Messroutine bearbeiten können Sie die Messroutine bearbeiten. Hierzu gehören folgende Funktionen: Befehle umordnen, existierende Befehle kopieren, einfügen oder löschen.

  1. Drücken Sie den Softkey Vorwärts [image], um zur zweiten Seite des Hauptfensters zu navigieren.

  2. Drücken Sie den Softkey Messroutine bearbeiten [image], um das Fenster Messroutine bearbeiten aufzurufen:

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
"Auswahl" aufheben Dieser Softkey hebt die Auswahl aller Messroutine-Einträge, die im Modus 'Mehrfachauswahl' ausgewählt wurden, mit Ausnahme des ersten Eintrages, auf. | Umschalter Cursormodus Das Bearbeitungsfenster arbeitet mit zwei Cursormodi. Mit dem Softkey Umschalter Cursormodus können Sie zwischen den beiden Modi wechseln. Informationen zu den Cursormodi:
Nach unten bewegen Dieser Softkey bewegt den Cursor in der Messroutine-Struktur im Bearbeitungsfenster um einen Eintrag nach unten. Im Modus 'Mehrfachauswahl' werden alle Einträge ausgewählt und der Gruppe hinzugefügt. | Nach oben bewegen Dieser Softkey bewegt den Cursor in der Messroutine-Struktur im Bearbeitungsfenster um einen Eintrag nach oben. Im Modus 'Mehrfachauswahl' werden alle Einträge ausgewählt und der Gruppe hinzugefügt.
Ausschneiden Dieser Softkey entfernt das ausgewählte (hervorgehobene) Element aus der Strukturansicht der Messroutine. Das Element kann anschließend an beliebiger Stelle eingefügt werden. | Kopieren Dieser Softkey kopiert das ausgewählte (hervorgehobene) Element in die Strukturansicht der Messroutine.
Bearbeiten Wählen Sie ein Element zu dessen Bearbeitung aus der Strukturansicht ("Baumansicht") aus und drücken Sie auf diesen Softkey. Der entsprechende Bildschirm für den ausgewählten Befehl wird im Bearbeitungsmodus geöffnet. Siehe auch das Thema "Angaben zur Bearbeitung eines Elements" weiter unten. | Löschen Dieser Softkey entfernt das ausgewählte (hervorgehobene) Element dauerhaft aus der Strukturansicht der Messroutine.
Rückgängig (auf der zweiten Seite) Dieser Softkey macht vorherige Änderungen oder Schritte rückgängig, die während der Bearbeitung der NC Gage-Messroutine im Bearbeitungsfenster vorgenommen wurden. Sie können alle Änderungen bis zum letzten Aufruf des Bearbeitungsfensters rückgängig machen. | Gehe zum Anfang - (auf der zweiten Seite) Dieser Softkey versetzt das hervorgehobene Element an den Anfang der Messroutine. Mit diesem Softkey werden kürzlich rückgängig gemachte Änderungen wiederhergestellt. Sie können jeden Schritt bis zum letzten Aufruf des Bearbeitungsfensters wiederherstellen.
Einfügen Mit diesem Softkey wird das ausgeschnittene oder kopierte Element in die Messroutine eingefügt. Siehe auch "Angaben zum Einfügen eines Elements" weiter unten. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.

Informationen zu den Cursormodi

Die beiden Modi sind:

  • Modus 'Einzelauswahl' - Wenn Sie in diesem Modus den Cursor im Messroutinebaum im Bearbeitungsfenster nach oben und unten bewegen, wird der aktuelle Eintrag für die Bearbeitung ausgewählt. Dies ist der Standardmodus.

  • Modus 'Mehrfachauswahl' - Wenn Sie in diesem Modus den Cursor im Messroutinebaum im Bearbeitungsfenster nach oben und unten bewegen, wird automatisch jeder Eintrag ausgewählt und zur Gruppe der ausgewählten Einträge hinzugefügt.

In beiden Modi können Sie Messroutineeinträge ausschneiden, kopieren oder einfügen.

Angaben zur Bearbeitung eines Elements

Im Bearbeitungsfenster oder im Fenster Messroutine-Modus:

  • Um das Fenster zu verlassen oder dieses ohne das Speichern von Änderungen zu verlassen, drücken Sie auf den Softkey Zurücksetzen [image].

  • Um das Fenster zu verlassen und vorgenommene Änderungen zu speichern, drücken Sie den Softkey Speichern der Änderung in Befehl bestätigen [image].

Das Programm befindet sich im Bearbeitungsmodus, wenn das folgende Symbol im unteren Bereich rechts im Fenster Messroutine bearbeiten erscheint:

Ansonsten sehen Sie folgendes Symbol, das anzeigt, dass sich das Programm im normalen Einfügemodus befindet:

Angaben zum Einfügen eines Elements

Um ein Element einzufügen, verschieben Sie das hervorgehobene Element über die Stelle, über die das Element eingefügt werden soll. Wenn Sie die Softkeys Kopieren oder Ausschneiden drücken, wird ein kleiner roter Pfeil in der Strukturansicht der Messroutine angezeigt. Damit wird angezeigt, an welcher Stelle die Messroutine den Befehl / die Befehle einfügt.

  • Wenn das einzufügende Element ursprünglich aus der Messroutine ausgeschnitten wurde, dann wird es auf dieselbe Weise, wie es ausgeschnitten wurde, in die Messroutine eingefügt. Das bedeutet im Prinzip, dass es in der Reihenfolge der Messroutine verschoben wird.

  • Wurde das einzufügende Element ursprünglich aus der Messroutine kopiert, dann wird es in die Messroutine eingefügt und der Elementname erhöht sich bei jeder Einfügung. Beispiel: Wenn Sie das Element "Linie 1" kopiert und eingefügt haben, dann wird das eingefügte Element "Linie 2" heißen und dann "Linie 3" und so weiter.

Messroutine-Kommentar

Geben Sie im Fenster Messroutine-Kommentar einen Kommentar zur Messroutine ein. Dieser Kommentar wird im Fenster Datei-Manager in der Spalte Kommentar angezeigt.


Dateien verwalten

Im Fenster Datei-Manager haben Sie die Möglichkeit, die 'NC Gage'-Messroutinen zu verwalten. Sie können neue Messroutinen erstellen und speichern sowie vorhandene 'NC Gage'-Messroutinen laden oder löschen. Messroutinen werden im PRG-Verzeichnis des Installationsverzeichnisses von NC Gage gespeichert.

Klicken Sie auf den Softkey Datei-Manager [image] aus dem Hauptfenster, um das Fenster Datei-Manager aufzurufen:

Dieses Fenster enthält drei Spalten:

  • Name der Messroutine - Mit dieser Option wird der Name der Messroutine mit der Dateinamen-Erweiterung ".NCG" aufgelistet.

  • Kommentar - Hier werden die Messroutine betreffende Kommentare angezeigt. Im Fenster Messroutine bearbeiten können Sie jeden beliebigen Kommentar hinzufügen. Siehe auch "Bearbeiten von Messroutinen".

  • Erstelldatum: - Diese Spalte zeigt das letzte Speicherdatum der Messroutine.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Aktuelle Messroutine speichern Dieser Softkey speichert die aktuelle Messroutine mit dem vorgegebenen Namen. | Ausgewählte Messroutine laden Dieser Softkey lädt die ausgewählte Messroutine von der Liste.
Neue Messroutine Mit diesem Softkey wird eine neue Messroutine erstellt. Sie werden zur Bestätigung aufgefordert, wenn Sie Änderungen, die an der aktuellen Messroutine vorgenommen wurden, nicht speichern möchten. | Ausgewählte Messroutine löschen Dieser Softkey löscht die ausgewählte Messroutine von der Liste.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Datei-Manager Über diesen Softkey wird das Fenster Datei-Manager angezeigt. |


Verwenden von Protokollen

Wenn Sie Ihre Messroutine ausgeführt haben, können Sie die Messwerte mit den vorgegebenen Nennwerten im Fenster Protokoll vergleichen. Sie können dieses Fenster mit dem Softkey Protokoll [image] auf dem Hauptfenster direkt nach der Ausführung der Messroutine öffnen.

Hinweis: Das Fenster Protokoll kann erst dann aufgerufen werden, wenn gemessene Werte vorhanden sind. Diese Messwerte sind erst verfügbar, nachdem die Messroutine ausgeführt wurde.

Aufzeichnung von Parallelität und Rechtwinkligkeit von Winkeln

Anzeige des Protokolls der Messroutine

Das Protokoll der Messroutine kann angezeigt werden, indem Sie zur entsprechenden Seite des Hauptfensters navigieren und dort den Softkey Protokoll [image] drücken.

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Speichern Sie das Protokoll als RTF-Datei Dieser Softkey speichert das aktuelle Protokoll in einer RTF-Datei. Der Verzeichnispfad für die Datei wird oben im Fenster aufgelistet. Der Name der Datei entspricht dem der Messroutine, gefolgt von einer Zahl, die sich jedesmal, wenn das Protokoll gespeichert wird, erhöht. | Protokoll drucken Dieser Softkey sendet das Protokoll zu Ihrem Standarddrucker.
Protokoll Dieser Softkey öffnet den Bildschirm Protokoll, wo Sie Messprotokolle für Ihre Messroutine anzeigen lassen oder diese speichern sowie drucken können. | ZOLL / MM Dieser Softkey ändert jedesmal, wenn darauf gedrückt wird, die Maßeinheit (von Zoll auf MM vv.) des Protokolls.
Nach DatapagePlus exportieren Mit diesem Softkey verfügen Sie über die Funktionalität zum Export der Protokolldaten in eine XML-basierte Ausgabedatei, die in DP+ eingelesen werden kann. | Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung.
Bestätigen / Befehl hinzufügen Im Betrieb wird die Auswahl mit diesem Softkey bestätigt. Bei Befehlen wird damit der Befehl am Ende des Messroutine eingefügt. Für Elementbefehle wird diese Option verfügbar, nachdem die Maschine die Elementposition erlernt hat oder wenn Sie die theoretischen Werte des Elements eingegeben haben. Für Befehle von abhängigen und mit Merkmalen versehenen Elementen wird diese Option verfügbar, sobald Sie die entsprechenden Eingabemerkmale bestimmt haben. | Alle Schritte abbrechen / Abbrechen Über diesen Softkey wird der aktuelle Vorgang angehalten und zurückgesetzt. Wenn gerade ein Element erlernt wird, werden alle erlernten Tasterpositionen entfernt.
Im Protokoll nach oben scrollen Mit diesem Softkey kann die Protokollansicht über eine Seitenlänge nach oben gescrollt werden. | Im Protokoll nach unten scrollen Mit diesem Softkey kann die Protokollansicht über eine Seitenlänge nach unten gescrollt werden.
Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf. |


Bildschirmtastaturen verwenden

NC Gage umfasst drei Bildschirmtastaturen:

  • Alphanumerische Tastatur - Diese Tastatur kombiniert Buchstaben, Zahlen und Symbole. Wenn Sie Tastaturen in NC Gage aktivieren, wird diese Tastatur automatisch angezeigt, wenn Sie auf ein alphanumerisches Feld auf einem Bildschirm drücken.

  • Numerische Tastatur - Diese Tastatur ist zur effizienten Eingabe von Zahlen im Stil eines Taschenrechners gestaltet. Wenn Sie Tastaturen in NC Gage aktivieren, wird diese Tastatur automatisch angezeigt, wenn Sie auf ein numerisches Feld auf einem Bildschirm drücken.

  • Wissenschaftlicher Taschenrechner - Diese Tastatur bietet Zugriff auf mathematische Funktionen. Die Taste, die diese Tastatur öffnet, befindet sich auf der numerischen Tastatur.

Um Tastaturen ein- bzw. auszublenden, ihre Farben zu definieren und die Größe der Tasten festzulegen, beachten Sie den Abschnitt "Registerkarte Tastatureinstellungen" im "Anhang A - Konfiguration Steuereinheit".

Standardtasten aller Tastaturen

Die folgende Tabelle beschreibt die Tasten, die auf allen Tastaturen vorhanden sind.

Taste

Beschreibung

Stecknadel

  • Mit der Stecknadel-Taste kann die Position einer Tastatur auf einem Bildschirm fixiert werden, wenn Sie Felder auf dem Bildschirm klicken. Der Hintergrund der Taste wechselt zu Orange.

  • Um die Tastatur wieder zu lösen, klicken Sie erneut auf die orange Stecknadel-Taste. Die Position der Tastatur ändert sich, wenn Sie in Felder auf dem Bildschirm klicken.

Damit wird die Tastatur geschlossen.

0 - 9

Mit diesen Tasten können Ziffern eingegeben werden.

Alphanumerische Tastatur

Alphanumerische Tastatur

Die folgende Tabelle beschreibt die Tasten.

Taste | Beschreibung
a - z | Mit diesen Tasten können Klein- und Großbuchstaben eingegeben werden. Klicken Sie auf die abc-Taste, um von Klein- zu Großschreibung zu wechseln.
# | Gibt eine Raute ein.
Tabulator | Damit wird die Tastatur für die aktuelle Option geschlossen und der Mauszeiger zur nächsten Option auf dem Bildschirm bewegt.
, | Gibt ein Komma ein.
!#? | Damit werden die Buchstaben-Tasten zu Symbol-Tasten. Beim Klicken wechselt der Hintergrund der Taste zu Orange. Um die Symbol-Tasten wieder zu Buchstaben-Tasten zu wechseln, klicken Sie die orange !#?-Taste erneut.
abc | Mit dieser Taste können Sie von Klein- zu Großschreibung wechseln. Beim Klicken wechselt der Hintergrund der Taste zu Orange. Klicken Sie auf die orange abc-Taste, um von Klein- zu Großschreibung zu wechseln.
JP | Diese Taste erscheint nur für japanische Betriebssysteme. (Wenn das Betriebssystem nicht Japanisch ist, wird diese Taste nicht angezeigt.) Wenn Sie diese Taste anklicken, ist die vollständige Liste der japanischen Zeichen verfügbar. Wenn Sie diese Taste nicht anklicken, ist nur die halbe Liste an japanischen Zeichen verfügbar.
 | Die Leertaste fügt ein Leerzeichen ein.
/ | Damit wird ein Schrägstrich eingefügt.
\ | Damit wird ein Backslash eingefügt.
. | Damit wird ein Punkt eingefügt.
 | Die Rücktaste löscht das Zeichen links vom Cursor im Feld auf dem Bildschirm.
ENTF | Diese Taste löscht das Zeichen rechts vom Cursor im Feld auf dem Bildschirm.
- | Damit wird ein Bindestrich eingefügt.
 | Die Eingabetaste bewegt den Cursor im Feld auf dem Bildschirm in eine neue Zeile.
Pfeilpaar nach oben | Seite nach oben.
Pfeilpaar nach unten | Seite nach unten.
Pfeil nach oben | Bewegt den Cursor zum linken Zeichen.
Pfeil nach links | Bewegt den Cursor zum linken Zeichen.
Pfeil nach rechts | Bewegt den Cursor zum rechten Zeichen.
Pfeil nach unten | Bewegt den Cursor zum rechten Zeichen.

Numerische Tastatur

Numerische Tastatur

Die folgende Tabelle beschreibt die Tasten.

Taste | Beschreibung
Cal | Mit dieser Taste können Sie die Tastatur zum wissenschaftlichen Taschenrechner umschalten.
 | Die Rücktaste löscht das Zeichen (von rechts nach links) im Textfeld der Tastatur.
CLR | Diese Taste löscht die Zeichen im Textfeld der Tastatur und dem Feld auf dem Bildschirm.
- | Damit wird ein negatives Vorzeichen eingefügt.
. | Damit wird ein Dezimalpunkt eingefügt.
 | Die Eingabetaste übergibt die Zeichen im Textfeld der Tastatur an das Feld auf dem Bildschirm.

Wissenschaftlicher Taschenrechner

Wenn Sie auf der numerischen Tastatur die Cal-Taste anklicken, erscheint der wissenschaftliche Taschenrechner:

Wissenschaftlicher Taschenrechner

Um einen Ausdruck zu berechnen, klicken Sie das mathematische Symbol und klicken Sie anschließend den Operanden. Beispiel: Zur Berechnung von sin(60)+cos(60) und Anzeige des Ergebnisses im Textfeld des Taschenrechners müssen Sie folgende Tasten anklicken:

sin(60)+cos(60)=

Die folgende Tabelle beschreibt die Tasten und enthält zudem Beispiele.

Taste | Beschreibung | Tastenbeispiele
Num | Die Taste wechselt zur numerischen Tastatur. |
AC | Damit wird das berechnete Ergebnis oder der Ausdruck im Textfeld des Taschenrechners gelöscht. |
C | Damit wird die letzte Ziffer im Textfeld des Taschenrechners gelöscht. |
( | Damit wird eine linke Klammer eingefügt. |
) | Damit wird eine rechte Klammer eingefügt. |
Pl | Pi | PlPl=
Abs | Damit wird der absolute Wert berechnet. | Abs3=
sin | Damit wird der Sinus berechnet. | sin60=
cos | Damit wird der Kosinus berechnet. | cos60=
tan | Damit wird die Tagente berechnet. | tan60=
In | Damit wird der Logarithmus berechnet. | In6=
Inv | Diese Taste kehrt Tasten sin, cos, tan, ln, Quadratwurzel und mm->Zoll in die reziproke Funktion um. Wenn Sie diese Taste anklicken, wechselt der Hintergrund zu Orange: Reziproke Funktionen Die reziproken Funktionen sind im Folgenden beschrieben: |
 | asin - Berechnet den Arcussinus. | asin0.5=
 | acos - Damit wird der Arcuscosinus berechnet. | acos0.5=
 | atan - Damit wird die inverse Tangente berechnet. | atan1=
 | exp - Damit wird der Exponent berechnet. | exp2=
 | x^2 - Damit wird das Quadrat berechnet. | 3x^2=
 | Zoll->mm - Damit wird das Ergebnis im Textfeld der Tastatur von Zoll in Millimeter umgerechnet. | inch->mm9=
 | Diese Taste berechnet die Quadratwurzel. | 16=
mm->Zoll | Damit wird das Ergebnis im Textfeld der Tastatur von Millimeter in Zoll umgerechnet. | mm->inch3=
= | Die Gleichtaste zeigt das Ergebnis einer arithmetischen Funktion im Textfeld des Taschenrechners an. Um dieses Ergebnis im Feld auf dem Bildschirm anzuzeigen, klicken Sie nach der Gleichtaste ebenfalls die Eingabetaste. | 3+2=
/ | Teilt zwei Zahlen durcheinander. | 3/2=
* | Multipliziert zwei Zahlen. | 3*2=
- | Subtrahiert zwei Zahlen oder fügt ein negatives Vorzeichen ein. | 3-2= -3
+ | Addiert zwei Zahlen. | 3+2=
 | Die Rücktaste löscht das Zeichen (von rechts nach links) im Textfeld der Tastatur. |
CLR | Diese Taste löscht die Zeichen im Feld auf dem Bildschirm. |
 | Die Eingabetaste übergibt die Zeichen im Textfeld der Tastatur an das Feld auf dem Bildschirm. |


Direct Connect-Modus

Home > Anwenden von PC-DMIS NC Gage > Modus 'Direkt verbinden' (DCM)

Modus 'Direkt verbinden' (DCM)

NC Gage-Messroutinen können direkt aus einem Schnittmakro ausgeführt werden, als ob die Messroutine ein Unterprogramm mit DCM (Direct Connect Mode) wäre. Wenn die NC Gage-Messroutine ohne Fehler ausgeführt wurde, kehrt es wieder zum Schnittprogramm zurück, aus dem es aufgerufen wurde.

Die NC Gage-Messroutine kann keine Prüfroutinen oder Aktualisierungen des Arbeitsversatzes enthalten.

DCM-Modus aufrufen

Drücken Sie den Softkey Modus 'Direkt verbinden' [image] auf der zweiten Seite des Hauptfensters, um das Fenster Modus 'Direkt verbinden' einzublenden:

Fenster "Modus 'Direkt verbinden'"

Das Element, das derzeitig während der Messroutine ausgeführt wird, wird in der Strukturansicht magenta-farben hervorgehoben.

Alternativ können Sie die Kommandozeile entsprechend mit einer -DL-Erweiterung (siehe unten) modifizieren, um den Modus 'Direkt verbinden' zu starten, wenn NC Gage startet:

C:\ .. \NCGage.exe –dl

Aufrufen der NC Gage Messroutine

Um eine NC Gage Messroutine aus einem Schnittprogramm aufzurufen, muss ein Spezial-Makro (DCM-Makro) aufgerufen werden sowie der Name der NC Gage Messroutine (eine Zahl!) zugewiesen sein.

  • Der Name der NC Gage-Messroutine muss eine vierstellige Zahl sein. Diese Zahl wird für den Aufruf des DCM-Makros verwendet, um die entsprechende NC Gage-Messroutine zu bestimmen.

  • Das DCM-Makro ist die 'NC Gage'-Monitor-Makronummer plus 1. Angenommen, die Monitor-Makronummer ist 7400, dann ist die DCM-Makronummer 7401. Die DCM-Makronummer wird während der ersten Einrichtung und Konfiguration von NC Gage vom Konfigurationswerkzeug NC Gage bestimmt. Siehe „Anhang A - Konfiguration Steuereinheit“ für weitere Informationen.

Damit die NCGage-Messroutine '1234.ncg' aus einem Schnittmakro aufgerufen werden kann, muss die folgende Syntax in das Schnittmakro eingefügt werden:

G65 P7401 H1234

Während der Ausführung in DCM, zeigt der Bildschirm Modus 'Direkt verbinden' die derzeit ausgeführte Messroutine an. Außerdem wird während der Ausführung der Messroutine ein Echtzeitprotokoll eingeblendet. Wenn NC Gage so konfiguriert ist, dann wird eine Werkstückprotokolldatei gespeichert und das Fenster „NC Gage DCM Monitor“ zeigt die Anzahl der Elemente, die sich außerhalb der Toleranz befinden, an.

Fehlerzustand

Bei einem Fehlerzustand aufgrund einer Fehlantastung oder einem unerwarteten Ende der Bewegung drücken Sie den Softkey Ausführung anhalten [image] in NC Gage. Wenn es der Werkzeugmaschine nicht möglich ist, den Taster zu starten, kehrt NC Gage den Benutzer zum Schnittmakro zurück.

Beispiel der Option "Anzahl 'außerhalb der Toleranz'"

Die Option Zahl 'Außer Spez.': im Bereich Information zeigt die Anzahl der Elemente, die in der Messroutine außerhalb des Toleranzbereichs liegen, an.

Beispiel der Option "Anzahl 'außerhalb der Toleranz'"

Softkeys der Navigationsleiste

Zurückkehren Über diesen Softkey wird die Bildschirmansicht um eine Ebene zurückgesetzt. | Vorwärts Falls aktiviert, veranlasst dieser Softkey ein vorwärtsscrollen zur zweiten Seite dieses Fensters, wo sich zusätzliche Softkeys befinden.
Detail einblenden Dieser Softkey zeigt die Informationen über die Ausführung der Messroutine in DCM in Echtzeit an. | Ausführung anhalten Über diesen Softkey wird die Ausführung des aktuellen Befehls oder Makro-Programmes angehalten.
Minimieren Dieser Softkey wechselt die Anzeige von NC Gage zum Hauptfenster der Steuerung. | Hilfe Dieser Softkey ruft die NC Gage Hilfedatei auf.


Anhang A - Konfiguration Steuereinheit (Mazak)

Home > Anwenden von PC-DMIS NC Gage > Anhang A - Konfiguration Steuereinheit

Anhang A - Konfiguration Steuereinheit

Sie können die Steuereinheit mithilfe des 'NC Gage'-Konfigurationswerkzeug konfigurieren. Die Konfiguration der verschiedenen Steuereinheiten von "NC Gage" wird normalerweise von demjenigen, der auch die Tasterhardware installiert hat, durchgeführt. Dieser Abschnitt dient als Referenz und beschreibt das Konfigurationswerkzeug.

Das Konfigurationswerkzeug erzeugt eine Reihe von Messmakros zur Verwendung auf der entsprechenden Steuereinheit, je nachdem, welche der Steuereinheiten im Anfangsdialogfenster ausgewählt wurde. Des Weiteren muss die Speicherkapazität auf der Steuereinheit ausreichend sein, um 'NC Gage'-Makros aufzunehmen.

Anwenden des Werkzeuges

Das Konfigurationswerkzeug kann wie folgt geöffnet werden:

  • Klicken Sie nach der Installation von NC Gage auf die Verknüpfung in der Programmgruppe von PC-DMIS NC Gage:

Programmgruppe

  • Klicken Sie auf ConfigTool.exe im Installationsverzeichnis von NC Gage.

Wenn das 'NC Gage'-Konfigurationswerkzeug startet, erscheint der folgende Bildschirm:

Konfigurationswerkzeug NC Gage

  1. Wählen Sie Mazak aus der Liste Steuerungsmodell.

  2. Wählen Sie, falls erforderlich, die entsprechende Sprache aus der Liste Sprache.

  3. Klicken Sie auf OK, um den Bildschirm des NC Gage-Konfigurationswerkzeug für die entsprechende Steuereinheit und in der gewählten Sprache anzuzeigen.

  4. Vervollständigen Sie die Registerkarten auf diesem Bildschirm.

Registerkarten

Der Bildschirm PC-DMIS NC Gage Konfigurationswerkzeug enthält die folgenden Registerkarten:

  • Registerkarte Allgemein

  • Registerkarte Parameter

  • Registerkarte Achsen einrichten

  • Registerkarte Taster

  • Registerkarte Tastatureinstellungen

Schaltflächen

Die folgenden Schaltflächen befinden sich auf allen Registerkarten:

  • Standard verwenden - Hierüber wird der in die Datei "<Ausgabedatei-Name>.dat" oder standardmäßig in die Datei "MitsMon.cnc.dat" gespeicherte Parametersatz wiederhergestellt.

  • Konfiguration laden - Alle Konfigurationsinformationen werden von NC Gage in der Datei "NCGage.dat" gespeichert. Diese Datei befindet sich immer im bzw. wird immer vom selben Ordner gespeichert bzw. geladen, so dass der Benutzer eine Konfiguration "importieren" kann. Wenn Sie die Schaltfläche Konfiguration laden klicken, wird das Dialogfeld Datei öffnen geöffnet. Sie können mittels dieses Dialogfeldes nach einer Konfigurationsdatei mit einem anderen Namen oder in einem anderen Ordner suchen und diese laden.

  • Konfiguration speichern - Hierüber wird der aktuelle Parametersatz für „ConfigTool.exe“ in die Datei „<Ausgabedatei-Name>.dat“ oder standardmäßig in die Datei "MitsMon.cnc.dat" gespeichert.

  • Maschine lesen - Wird diese Funktion unterstützt, dann wird durch Drücken auf diese Schaltfläche versucht, Maschinenvariablen aus der Steuereinheit zu lesen. Die Steuereinheit muss über ein Ethernetkabel mit dem NC-Gage-Rechner verbunden sein. Die IP-Adresse und Anschlussnummer müssen im Bereich Verbindungsparameter auf der Registerkarte Allgemein ordnungsgemäß angegeben sein. Es sind folgende Optionen verfügbar:

    • Werkzeugversatztyp

    • Anzahl der Achsen

    • Achsenbuchstaben und -versatz

    • Steuereinheitstyp

  • Makro-Programm erzeugen - Hierüber wird ein Makrosatz in der Datei, die im Feld Ausgabedatei auf der Registerkarte Allgemein genannt wird, erstellt.

  • Programm hochladen - Wird diese Option unterstützt, dann wird durch Drücken auf diese Schaltfläche versucht, der erzeugte Makrosatz auf die Steuereinheit hochzuladen. Die Verbindung zur Steuereinheit muss, wie unter „Maschine lesen“ und „Verbindungsparameter“ beschrieben, korrekt eingerichtet sein. Die Steuereinheit muss sich im Bearbeitungsmodus befinden. Der zur Erzeugung gewählte Makro-Bereich muss schreibbar sein.

  • Beenden - Beendet das Konfigurationswerkzeug.

Kommunikations-Statusleiste

Diese Leiste wird am unteren Rand des Bildschirms PC-DMIS 'NC Gage'-Konfigurationswerkzeug angezeigt. Sie zeigt Meldungen bezüglich der Kommunikation (Erfolg / Fehler) zwischen der Steuereinheit und der Maschine nach Betätigung der Schaltflächen Maschine lesen oder Programm hochladen an.

Dateien

  • NcGage.dat - Die Maschineneinrichtung für NC Gage ist in einer XML-basierten Textdatei namens "NcGage.dat" enthalten. Diese Datei wird erstellt, wenn die Schaltfläche Konfiguration speichern gedrückt wird.

Der Name "NcGage.dat" kann nicht geändert werden. Sie können den Namen der Ausgabedatei im Feld Ausgabedatei ändern. Der Wiederherstellungsdateiname wird vom Namen der Ausgabedatei abgeleitet, indem die Erweiterung ".dat" angehängt wird.

  • MazakMonitor.cnc - Diese Datei enthält CNC-Monitor-Makros, die auf die Steuereinheit geladen wird.

  • MazakMonitor.cnc.dat - Diese Datei stellt die Einstellungen des Konfigurationswerkzeuges wieder her.

  • Skriptdatei der Kopfzeile und Skriptdatei der Steuereinheit - Diese Dateien wurden bereits für die Konfiguration der entsprechenden Steuereinheit definiert. Eine Änderung dieser Dateien sollte nicht erforderlich sein.


Registerkarte "Allgemein"

Die Registerkarte Allgemein für das 'NC Gage'-Konfigurationswerkzeug ist im Folgenden dargestellt:

Registerkarte "Allgemein"

Einheit - Wählen Sie die entsprechende Option für die Maßeinheiten (mm oder Zoll). Hierbei handelt es sich um die auf der Maschine vorhandenen Maßeinheiten. Beachten Sie, dass NC Gage die Maßeinheit, die auf der Steuereinheit eingestellt ist, verwendet.

Maschinenname - Dieser Name kann ein beliebiger Text ohne Leerstellen und ohne Sonderzeichen sein. Sie können zwei Wörter mit einem Unterstrich trennen.

Typ der Steuereinheit – Verwenden Sie diese Auswahlliste zur Auswahl des Typs der Steuereinheit, mit der NC-Gage über eine Schnittstelle verbunden wird. Die aktuell unterstützen Kommunikationsmechanismen sind abhängig von der entsprechenden Steuereinheit.

IP-Adresse - Dies ist die Internetprotokoll-(IP)-Adresse der Steuereinheit. Diese eindeutige Adresse identifiziert die Steuereinheit an Ihrem Computernetzwerk. Sie müssen sicherstellen, dass der Rechner dieselbe Subnetzmaske wie die Steuereinheit verwendet, indem Sie einen Ping-Test durchführen, um die Verbindung zu verifizieren. Falls NC Gage auf einem anderen Rechner installiert ist, kann man dies nachprüfen, indem man die Steuereinheit pingt. Auf manchen Rechnern dürfen die IP-Adresse des Rechners und die der Werkzeugmaschine sich nur um eins ändern. Beispiel: Wenn die IP-Adresse des Maschinenwerkzeugs 192.168.0.1 ist, dann muss die IP-Adresse des Computers auf 192.168.0.2 gesetzt werden.

Pingtest: Öffnen Sie für den Pingtest eine Eingabeaufforderung und geben Sie "ping" gefolgt von der IP-Adresse der Steuereinheit ein. Nachdem Sie ENTER drücken, wird der Test versuchen eine temporäre Verbindung zur Steuereinheit herzustellen. Sollte dies fehlschlagen, erscheint im Befehlseingabefenster die Meldung: "Zeitlimit der Anfrage überschritten". im Befehlseingabefenster.

Subnetzmaske: Ihre IT-Abteilung muss diesen Wert dem Wert der Steuereinheit gleichsetzen.

Anschluss - Wenn die Option Ethernet gewählt wurde, wird damit die Anschluss-Nr. der Steuereinheit definiert. Ports steuern, welche Informationen von angeschlossenen Computern zulässig sind.

Werkzeugnummer > 200 - Markieren Sie dieses Kontrollkästchen, wenn die Werkzeugnummer grösser als 200 ist.

Ausgabedatei - Dies ist der Name der Ausgabe-Makrodatei, die erstellt wird, wenn auf die Option Makroprogramm erzeugen gedrückt wurde. Beachten Sie, dass dieser Dateiname mit der Erweiterung ".dat" auch die Datendatei für den Schaltflächenvorgang Wiederherstellen ist. Dies sollte nicht geändert werden.

Koordinatenrotations-Makro-Nr. - Aktivieren Sie dieses Kontrollkästchen, wenn in NC Gage die Koordinatenrotation verfügbar sein soll. Damit wird eine bestimmte Koordinatenrotationsoption, entweder der Makrocode G68 oder G68.2, festgelegt.

G68 - Markieren Sie dieses Kontrollkästchen, wenn der G68-Code auf der Steuereinheit verfügbar ist.

G68.2 - Markieren Sie dieses Kontrollkästchen, wenn der G68.2-Code auf der Steuereinheit verfügbar ist.

Spindelposition - Geben Sie hier den Maschinen-Code ein, um die Spindel zu orientieren. Wenn die Maschine nicht dazu fähig ist, löschen Sie den Inhalt dieser Option. Eine Variable wird dem eingegebenen Code hinzugefügt und enthält einen Winkel. Zum Beispiel:

  • Eingegebener Code: M19S

  • Generierter Code: M19S#1


Registerkarte "Parameter"

Die Registerkarte Parameter für das 'NC Gage'-Konfigurationswerkzeug ist im Folgenden dargestellt:

Registerkarte "Parameter"

Bereich "Geschwindigkeit"

Vorschubgeschwindigkeit (mm/Min.) Schnelles Antasten - Damit wird die Höchstgeschwindigkeit des Tasters festgelegt, wenn nicht angetastet wird. Die Einheit mm/Minute wird unabhängig von der Einstellung der Maßeinheit auf der Steuereinheit (Zoll oder mm) verwendet.

Vorschubgeschwindigkeit (mm/Min.) Langsames Antasten - Damit wird die Geschwindigkeit festgelegt, bei der sich der Taster auf der Suche nach einer Fläche bewegt. Die Einheit ist mm/Minute.

Max. Drehgeschwindigkeit (Grad/Min.) - Dies ist die Geschwindigkeit für alle Drehachsen, Spindelköpfe und Drehtische. Die Angabe erfolgt in Grad/Minute.

Bereich "Adresse"

Variablen-Basis - Dies ist die Startadresse für Variablen, die NC Gage für die Übertragung von Informationen verwendet. Derzeit wird von NC Gage die Adresse 31 verwendet. Diese Informationen müssen vor dem Herunterfahren der Steuereinheit nicht gespeichert werden.

Einstellungsbasis - Dies ist die Startadresse für Variablen, die NC Gage für Konstanten für Bewegung, Antasten und Werkzeuge verwendet. Derzeit wird von NC Gage die Adresse 11 verwendet. Diese Informationen sollten vor dem Herunterfahren der Steuereinheit gespeichert werden.

Programmnummer - Damit wird die Adresse zur Erzeugung des Monitor-Makros gesetzt.

Bereich "Taster"

Taster-Bit-PLC-Adresse - Dies ist die Adresse des Taster-Trigger-PLC-Bits.

Bereich "Werkzeug"

Werkzeugnummer-Adresse - Hierbei handelt es sich um die Adresse des aktuellen Werkzeuges. In diese Option kann nach Bedarf eine Makrovariable oder eine PLC-Adresse angegeben werden. Dieser Wert bestimmt wie die Steuereinheit die Werkzeugdaten im Speicher der Steuereinheit speichert. Der Standardwert ist der Werkzeugversatz.

Werkzeugversatztyp - Diese Option wird dazu verwendet, um unterschiedliche Verfahren zur Aufzeichnung der Werkzeuglänge auf einer Maschinensteuereinheit zu trennen.

  • Wählen Sie 'A', wenn Ihre Maschine nur Geometrie-, aber keine Abnutzungslängen für das Werzeuglängenmanagement verwendet. Der Unterschied wird zur Geometrielänge hinzugefügt.

  • Wählen Sie 'B' oder 'C', wenn Ihre Maschine Geometrie- und Abnutzungslängen verwendet. Der Unterschied wird zur Abnutzungslänge hinzugefügt.


Registerkarte "Achsen einrichten"

Die Registerkarte Achsen einrichten für das 'NC Gage'-Konfigurationswerkzeug ist im Folgenden dargestellt:

Registerkarte "Achsen einrichten"

Achse aktivieren - Für jede Achse muss ein Feld Achse aktivieren eingerichtet werden. Es sind mindestens drei Achsen erforderlich. Die bekannten Achsen und Achsenbuchstaben werden, falls unterstützt, über die Funktion Maschine lesen besetzt. Die X-, Y- und Z-Achsen sind immer gesetzt und können nicht entfernt werden.

Achsentyp - Mögliche Typen: "Linear", "Drehtisch" oder "DSE". So konfigurieren Sie einen Drehtisch in einem System:

  • Markieren Sie das entsprechende Kontrollkästchen Achse aktivieren.

  • Wählen Sie die Drehtischoption aus der Auswahlliste Achsentyp aus.

  • Wählen Sie die Achse, die mit jedem Drehtisch verbunden ist, aus der entsprechenden Achsenliste. Optionen sind: A, B, C, U, V, W, X, Y, Z oder Keine. Normalerweise basieren lineare Systeme auf den X-, Y- und Z-Kennungen, während Rotationssysteme mit A-, B und C identifiziert werden.

  • Wird ein gestapelter Drehtisch verwendet, wählen Sie das Bestellformular aus der Auswahlliste Drehtisch Stapelreihenfolge. Diese Option ist erst dann verfügbar, wenn mehr als ein Drehtisch definiert sind.

Achse - Dabei handelt es sich um die Achsenkennung X, Y, Z, U, V, W, A, B, C und Keine.

Versatz - Damit wird der Versatz in der Achsenmatrix bestimmt. Beispiel: Wenn eine Maschine lineare XYZ-Achsen und einen B-Achsendrehtisch besitzt, lauten die Versätze möglicherweise 1, 2, 3, 4. Oftmals gibt es Nebenachsen, die nicht in die Konfiguration mit einbezogen wurden und Sprünge in der Achsenmatrix verursachen. Dieselbe Maschine könnte also auch eine Matrix von 1,3,4,5 besitzen.

Grenze - Die Angabe zu "Grenze" werden in Maschinenkoordinaten angegeben. Sollten diese unbekannt sein, dann bleibt das Feld leer.

Code sperren/freischalten - Diese Parameter werden bei Bedarf für Rotationsachsen eingesetzt.

Drehtisch Stapelreihenfolge - Definiert die Reihenfolge, wenn mehrere Drehtische definiert sind.

Taster-Richtung (Spitze zu Spindel), wenn DSE auf 0 - Wählen Sie eine Option von der Liste für die Spitze-zu-Spindel-Richtung der Tastspitze, wenn sich das DSE am Nullpunkt befindet. Verfügbare Optionen sind ZPlus, ZMinus, YPlus, YMinus, XPlus und XMinus.

Pivot-Typ - Wählen Sie zur Bestimmung des Pivot-Typs eine Option aus der Auswahlliste aus. Verfügbare Optionen sind: WristCenter (DSE-Mitte) und WristZero (DSE-Nullpunkt).

Pivot-Abstand - Geben Sie den Pivot-Abstand für die DSE ein.

Hinweis - Die Liste Reihenfolge Drehtisch ist nur dann auf der Registerkarte Achsen einrichten des Konfigurations-Tools von NC Gage verfügbar, wenn zwei Drehtische definiert wurden. Wenn ein Drehtisch und eine DSE definiert wurden (wie für eine Fräs-Dreh-Werkzeugmaschine), dann wird die Liste Reihenfolge Drehtisch durch die Bereiche Tasterrichtung (Tastspitze auf Spindel) wenn DSE bei 0 und Drehpunkt ersetzt, wie in der Abbildung weiter unten veranschaulicht ist.

Sollte das nicht zutreffen, dann wird dieser Bereich auch nicht angezeigt. Wenn für eine Fräs-Dreh-Werkzeugmaschine eine DSE definiert wurde, dann muss die DSE auf die B-Achse und der Drehtisch auf die C-Achse gesetzt werden.

Weitere Informationen zum Einrichten von Drehtischen finden Sie im Thema Kinematik-Einstellung.


Registerkarte "Taster"

Die Registerkarte Taster für das 'NC Gage'-Konfigurationswerkzeug ist im Folgenden dargestellt:

Registerkarte "Taster"

Tastermakro aktivieren - Hierbei handelt es sich um den Makro-Code ein, der zur Aktivierung des Tasters benötigt wird.

Tastermakro laden - Hierbei handelt es sich um den Makro-Code ein, der zum Laden des Tasters benötigt wird.

Programmmakro starten - Hierbei handelt es sich um die Makro-Codes, die am Anfang des Makroprogrammes ausgeführt werden müssen.

Tastermakro deaktivieren - Hierbei handelt es sich um den Makro-Code, der zum Deaktivieren des Tasters benötigt wird.

Bewegungstest-Makro - Hierbei handelt es sich um den Makro-Code, um zu testen, ob der Taster eingeschaltet ist und bewegt werden kann.

Programmmakro beenden - Hierbei handelt es sich um die Makro-Codes, die am Ende des Makroprogrammes ausgeführt werden müssen.

Nachdem alle Registerkarten systemgerecht konfiguriert wurden, wählen Sie die Schaltfläche Konfiguration speichern und klicken dann auf die Schaltfläche Makro-Programm erzeugen.


Appendix_A_-_Controller_Configuration_(Mazak)_-_Keyboard_Setup_Tab.htm

Home > Anwenden von PC-DMIS NC Gage > Anhang A - Konfiguration Steuereinheit > Registerkarte "Tastatureinstellungen"

Registerkarte "Tastatureinstellungen"

Nutzen Sie die Registerkarte Tastatureinstellungen des NC Gage Konfigurationswerkzeuges, um Bildschirmtastaturen in NC Gage ein- bzw. auszublenden.

Um die Tastaturen zu aktivieren, aktivieren Sie auf der Registerkarte das Kontrollkästchen Tastatur aktivieren, um den folgenden Bildschirm anzuzeigen:

Registerkarte "Tastatureinstellungen"

Bereich "Tastatur"

Tastatur aktivieren - Wenn Sie dieses Kontrollkästchen auswählen, wird die Bildschirmtastatur angezeigt, wenn Sie auf in ein alphanumerisches Feld auf einem Bildschirm drücken. Die numerische Tastatur wird angezeigt, wenn Sie auf ein numerisches Feld drücken. Wenn keine Tastatur angezeigt werden soll, wenn Sie auf ein Feld klicken, dann deaktivieren Sie dieses Kontrollkästchen.

Hintergrundfarbe - Damit wird die Hintergrundfarbe der Tastatur festgelegt.

Bereich "Taste"

Größe - Damit wird die Größe der Tasten festgelegt.

Rahmenfarbe - Damit wird die Farbe für den Rahmen der Tasten festgelegt.

Bereich "Hintergrundfarbe"

Normal - Damit wird die Hintergrundfarbe der Taste festgelegt.

Darüber bewegen - Damit wird die Hintergrundfarbe der Taste festgelegt, wenn Sie darauf zeigen.

Darüber bewegen - Damit wird die Hintergrundfarbe der Taste festgelegt, wenn Sie diese anklicken.

Bereich "Zeichen"

Größe - Damit wird die Schriftgröße der Zeichen auf den Tasten festgelegt.

Farbe - Damit wird die Farbe der Zeichen auf den Tasten festgelegt.

Farbe auswählen

So wählen Sie eine Farbe für eine Option auf der Registerkarte Tastatureinstellungen:

  1. Klicken Sie in das Feld für die Option. Daraufhin öffnet sich der Bildschirm Farbe:

Bildschirm "Farbe"

  2. Um eine einfache Farbe auszuwählen, klicken Sie auf die gewünschte Farbe. Um eine benutzerdefinierte Farbe zu wählen, klicken Sie auf Benutzerdef. Farbe und definieren Sie danach die gewünschte Farbe.

  3. Klicken Sie auf OK, um zur Registerkarte Tastatureinstellungen zurückzukehren.


Kalibrierwertetest

Home > Kalibrierwertetest

Kalibrierwertetest (Einstellungen Kalibriertest)

In diesem Fenster können Sie die Nennposition des Ringes sowie die Toleranzwerte angeben. Sollten gemessene Werte von deren entsprechenden Nennwerten um mehr als den zugewiesenen Toleranzwert abweichen, wird eine Warnmeldung eingeblendet. Der Benutzer kann, nachdem er die Warnmeldung akzeptiert hat, fortfahren. Die X-, Y- und Z-Nennwerte können eingegeben werden. Die Toleranzen für X, Y, Z, D und Form (F) können eingegeben werden.


Informations-Manager

Informations-Manager - [image] In diesem Fenster können Sie Meldungen, die die Verbindung von NC Gage mit der Steuereinheit betreffen, sowie alle Fehlermeldungen bezüglich NC Gage, einsehen.


Tasterlängenverfeinerung

Der Bildschirm Tasterlänge einstellen berechnet die Länge des Tasterschaftes. Diese Funktion kann jederzeit ausgeführt werden.

  1. Drücken Sie im Hauptfenster den Softkey Taster.

  2. Drücken Sie auf Tasterlängenverfeinerung. Damit öffnet sich das Fenster Tasterlänge einstellen.

  3. Wählen Sie einen Arbeitsversatz von der Liste 'Arbeitsversatz.

  4. Geben Sie im Bereich 'Parameter im Feld Ziel die Lage der Oberfläche relativ zum aktuellen Arbeitsversatz ein.

  5. Bestimmen Sie im Bereich 'Bewegungsparameter' einen Wert für den Vorhalteabstand.

  6. Positionieren Sie den Taster über der Oberfläche.

  7. Drücken Sie auf den Softkey Tasterposition lesen [image] .

  8. Drücken Sie den Softkey Ausführen [image] . Der Taster wird die Fläche mit dem Zielwert messen. Ausgehend von der berührten Position und der Position der Tasterspindel in dreidimensionalem Raumversatz von der Fläche, berechnet NC Gage dann die Länge des Tasters. Der gemessene Z-Wert und die Tasterlänge werden schreibgeschützt in den Feldern Messwert Z und Gemessene Länge angezeigt.

  9. Drücken Sie den Softkey Bestätigen [image], um die Tasterlänge, die zur Kalibrierung verwendet werden soll, zu speichern, oder drücken Sie den Softkey Zurückkehren [image] , um zum vorherigen Fenster zurückzukehren, ohne dass Änderungen gespeichert werden.

Alle anderen Einträge in diesem Bildschirm enthalten schreibgeschützte Informationen über den Taster.

Softkeys der Navigationsleiste für diesen Bildschirm: