NC Gageの使用

元の状態 > NC Gageの使用

NC Gage

NCGageの概要

ライセンス

設定

はじめに

要素コマンドの作成

追加の要素パラメータ設定

移動コマンドの挿入

測定プログラムでの作業

ファイル管理

レポートの使用

オンスクリーンキーボードの使用

自動モード (DCM)

付録Aーコントローラの設定

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●

>> 地域事務所 ●

会社情報

Hexagon Manufacturing Intelligence

>> http://hexagonmi.com ●

製品情報

PC-DMIS 3.4

著作権 © 2018 Hexagon Manufacturing Intelligence – Metrology Software, Inc.

ヘルプシステムは、最後に、January 29, 2018に作成されました。


NCGageの概要

元の状態 > NC Gageの使用 > NCGageの概要

NC GageとCheckSet5の紹介

NC GageとCheckSet5は、NC工作機械の機上計測と検証のための使いやすいツールです。NC Gageは、マシニングセンタおよびマルチタスキングマシンでの機上計測の包括的な測定ソフトウェアです。CheckSet5、NC Gageは、測定結果の中で最も高い機上精度と信頼性を提供します。CheckSet5は、5軸機械の状態をチェックし、5軸動作を設定または修正するための迅速で簡単なツールです。

このドキュメントには、NC GageとCheckSet5の両方に関連する内容が含まれています。

用語注：多くのユーザーがタッチスクリーンディスプレイでNC Gageを実行するため、このドキュメントで使用されている「選択」または「押す」という用語は、マウスとキーボードの周辺機器が接続されたPC上でソフトウェアを実行する場合のマウスクリックを示します。

このキュメントでは下記の主要なトピックについて説明します：

  • ライセンス

  • 設定

  • はじめに

  • 要素コマンドの作成

  • 追加の要素パラメータ設定

  • 移動コマンドの挿入

  • 測定プログラムでの作業

  • ファイル管理

  • レポートの使用

  • 自動モード (DCM)

  • 付録Aーコントローラの設定

ヘルプファイル最終更新日：January 29, 2018

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●

>> 地域事務所 ●

会社情報

Hexagon Manufacturing Intelligence


ライセンス

使用前にNC Gageアプリケーションを使用するためのライセンスを取得する必要があります。このライセンス取得はインストールが正常に完了した後、NC Gageを初めて使用するときです。

  1. 以下のいずれかの方法でNC Gageアプリケーションを起動します：

    • プログラムグループからNC Gageを選択します。

    • ウィンドウの「スタート」ボタンをクリックして「すべてのプログラム」に進み、定義されたプログラムグループから「NC Gage測定プログラム」アイコンを選択します。

    • NC Gageデスクトップショートカットアイコンをダブルクリックします。

最初のお試し版ライセンスの有効期限が切れるとライセンスの更新メッセージが表示されます。「OK」 をクリックしてください。

ライセンス更新メッセージ

NC Gageはライセンスが正常に設定されるまで、限定機能のベーシックモードで実行するように設定されます。

メイン画面から情報マネージャ [image] ソフトキーのある画面に移動します。このソフトキーをクリックして情報マネージャ画面を表示します：

情報メネージャ画面の左下隅にあるライセンス更新 [image] ソフトキーをクリックして、登録画面を表示しライセンス取得処理を開始します：

機械のシリアル番号をコピーして最寄りのNC Gage販売代理店に送ります。ライセンスキーが送られてきたら、ライセンスキーをライセンスキー欄に入力します。購入したライセンスレベルに基づいてライセンス情報セクションの詳細が自動的に更新されます。

変更の適用 [image] ソフトキーをクリックしてライセンスの手続きを完了します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●

>> 地域事務所 ●


設定

作業前に機械の工具設定に従ってNC Gageを設定する必要があります。通常、この作業はプローブのハードウェアを取り付ける人が行います。

コントローラの設定の詳しい説明については「付録A - コントローラの設定」

NC Gageでは、NC Gageを動作させるコンピュータに.NET 2.0がインストールされている必要があります。.NET 2.0がすでにインストールされている場合は、NC Gageのみがインストールされます。.NET 2.0がインストールされていない場合、インストーラーが.NET 2.0をインストールするかどうかをユーザーに尋ねます。OKを押すと.NET 2.0をダウンロードしてインストールできるMicrosoftウェブサイトにリンクします。

Windows OS についての注記：仮想マシンユーティリティ (例えばVMWare) を使用してNC Gageを英語以外の別の言語で実行する場合、Windows OS は仮想マシンクライアントの地域と言語の設定を自動的に選択しアップデートする場合があります(例えば、ピリオドがコンマに変更される場合があります) 。ある外国語から英語に戻す場合、測定エラーを防ぐためにこれらの変更を Windows OSのコントロールパネルの地域と言語の設定を使用して手動でリセットする必要があります。

Windowsの[地域と言語]設定のアップデート

  1. コントロールパネルに進みます：

  2. [地域と言語]をクリックします。[地域と言語]画面で必要に応じて変更を行います：

  3. クリック：

    • OKボタンをクリックすると、変更が受け付けられてコントロールパネルに戻ります。

    • キャンセルボタンをクリックすると保存せずに終了します。

    • 適用ボタンをクリックすると終了せずに変更が保存されます。

  4. [追加の設定]ボタンをクリックします。特定の[地域と言語]設定に必要な変更を行います：

  5. クリック：

    • OKボタンをクリックすると、[フォーマットのカスタマイズ]画面で行った変更が保存され、[地域と言語]画面に戻ります。

    • キャンセルボタンをクリックすると保存せずに終了します。

    • 適用ボタンをクリックすると終了せずに変更が保存されます。

「はじめに」に進みます。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


はじめに

これらのトピックはNC Gageの使用を開始するのに役立ちます。開始する前に：

  • NC機械の電源を入れる必要があります。

  • NC Gageソフトウェアがインストールされライセンス認証されている必要があります。

  • ソフトウェアが構成済みでなければなりません。詳細は、「付録A - コントローラの構成」を参照してください。

手順を下記に記載します：

  • ステップ 1：ソフトウェアの起動と接続

  • ステップ 2：NC Gageパラメータの設定

  • ステップ 3：新規プローブの作成

  • ステップ 4：プローブの選択

  • ステップ 5：校正

  • ステップ 6：ワークオフセットの定義

  • ステップ 7：コントロールフレームの定義

  • ステップ 8：安全高さパスの定義

システムメッセージについて

これらの手順に従って作業するときは、NC Gageメイン画面のシステムメッセージエリアの情報に注意してください：

システムメッセージ エリアの例

  • 赤い文字で表示されるメッセージは必要な手順が未実行であるか、他の問題があることを示しています。

  • 警告メッセージはパートの測定開始前に次に実行しなければならないことを示しています。

  • 必要な手順を完了すると、その項目がシステムメッセージエリアに青色の文字で表示されます。

上記の手順を完了すると、NC Gageを使用して測定プログラムを作成および実行することができます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーのソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


ソフトウェアの起動と接続

元の状態 > NC Gageの使用 > はじめに > ステップ 1：ソフトウェアの開始と接続

ステップ 1：ソフトウェアの起動と接続

NC Gageアプリケーションをインストールしてライセンス取得を行った後、下記のうちの1つを実行してNC Gageアプリケーションを起動します：

  • プログラムグループからNC Gage を選択します。

  • Windowを起動し[スタート] ボタンをクリックして [すべてのプログラム] に進み、定義されたプログラムグループからNC Gageプログラムアイコンを選択します。

NC Gageのメイン画面が開きます：

NC Gageを初めて開くとNC Gageは機械に接続しようとします。この接続についての情報がステータスエリアに表示されます。

ナビゲーションバー中央のステータスソフトキーが赤色の場合、ソフトウェアは機械に接続できていません：

NC Gageは機械に接続すると画面にプローブの位置座標を表示します。ナビゲーションバーの中央にあるステータスソフトキーが緑色になり、ステータスエリアが「接続」を表示します。

NC Gageを初めて起動する場合、システムメッセージエリアの校正オプションに--未設定--が表示されます。

また、ナビゲーションバーの測定 [image] および移動 [image] ソフトキーが無効になります(グレー表示になり選択できません)。これは予備的手順を実行しないとソフトウェアを使用し測定プログラムを作成してワークを測定できないことを示しています。

解決しなければならない次の項目はシステムメッセージエリアの警告メッセージにリストアップされます。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


NC Gageパラメータの設定

元の状態 > NC Gageの使用 > はじめに > ステップ 2：NC Gageパラメータの設定

ステップ 2：NC Gageパラメータの設定

設定画面を使用して、いくつかの測定と測定中に使用されるハードウェアパラメータを定義できます。

メイン画面で設定ソフトキー [image] を押すと設定画面が表示されます：

一般的なNC Gageパラメータを変更するには：

  1. 必要に応じて各項目に変更値を入力します。

  2. 確認ソフトキー [image] を押して変更を保存します。または、戻るソフトキー [image] を押して変更を保存せずに終了します。

ナビゲーションバーのソフトキーの詳細については「ナビゲーションバーのソフトキー」を参照してください。

第1主軸と第2主軸から測定する主軸を選んで下さい。初期値は第1主軸です。最後に選択した主軸が、次回NC Gageを起動したときの初期値となります。第2主軸を選ぶと、メイン画面や測定プログラムの実行画面の測定コマンドのツリービューの背景色が薄い青に変わります。また、ツリービューの上部に第2主軸有効が表示されます。

公差エリア

  • 上限 – ワークの測定結果を評価する上限公差の初期値を指定します。

  • 下限 – ワークの測定結果を評価する下限公差の初期値を指定します。

  • ユーザー公差チャートに公差の値を登録しておき、各要素の公差画面から選択することもできます。これにより、各要素の公差値を速やかに設定することができます。「ユーザー公差のチャート」を参照してください。

レポートの保存オプションエリア

  • 保存先 - レポートが保存される場所を指定します。測定プログラムはデータフォルダのサブディレクトリ「PRG」に保存されます。

  • 自動保存 - 測定プログラムの実行時に自動的にレポートファイルを作成します。ここをチェックした場合、上書きまたは追加保存オプションが使用できます。

    • 上書き - このオプションを選択すると、NC Gageはレポートを保存先で指定されたフォルダに自動的に保存します。NC Gageが次回以降レポートを保存する場合は、このファイルを自動的に上書きします。

測定プログラム毎のレポートファイル名は同一です。フォーマットは：<測定プログラム>.rtfです。この<測定プログラム>は実行された最後の測定プログラムの名前です。

    • 追加保存 - このオプションを選択すると、NC Gageはレポートに毎回別名をつけ保存先で指定されたフォルダに自動的に保存します。NC Gageは一度保存したレポートを置き換えません。

測定プログラム毎のレポートファイル名は異なります。フォーマットは：<測定プログラム>_<M>-<DD>-<YY>_<hh>-<mm>-<ss>.rtfです。各項目は以下となります：

<測定プログラム> - 現在読込まれている測定プログラムの名前(拡張子「.prg」がないもの)

<M>または<MM> - ユーザーのコンピュータシステムの日付に基づいた1桁または2桁の月。

<DD> - ユーザーのコンピュータシステムの日付に基づいた2桁の日付。

<YY> - ユーザーのコンピュータシステムの日付に基づいた4桁の年。

<hh> - ユーザーのコンピュータシステムの時刻に基づいてレポートが保存される2桁の時刻(24時制)

<mm> - ユーザーのコンピュータシステムの時刻に基づいてレポートが保存される2桁の分

<ss> - ユーザーのコンピュータシステムの時刻に基づいてレポートが保存される2桁の秒

ファイル名に対する24時間のタイムスタンプの表記はレポートが保存される時刻を示します(測定プログラムが実行される時刻ではありません)。このため、同じレポートを連続して保存する場合でも、各レポートファイル名は異なったものになります。

またオプションの設定方法に関係なく、いつでもレポートを手動で保存できます。手動で保存されるレポートのファイル名のフォーマットは：<測定プログラム>_<MM>-<DD>-<YY>_<hh>-<mm>-<ss>.rtfです。

送り速度と計測時の距離エリア

  • 早送り速度 - プローブが測定プログラムのブロック間を移動する速度を決定します。単位は選択によってmm/minまたはinch/minのいずれかになります。

  • 計測速度 - ティーチングモードで要素を検索するときにプローブが移動する速度を決定します。単位は選択によってmm/minまたはinch/minのいずれかになります。

  • 回転速度ｰ 軸回転の最大許容速度を決定します。

  • アプローチ距離(計測距離) - プローブが取込み点を取得する前に移動する理論的な取込み点からの距離を指定します。これはワーク測定時に使用されます。単位は選択によってmmまたはインチのいずれかになります。

  • 検索距離 - プローブが面を検索する距離を提供します。この距離に達する前にプローブが面に接触しない場合、測定は失敗となります。単位は選択によってmmまたはインチのいずれかになります。

測定結果の丸め方エリア

  • 測定結果の丸め値 - これを使用すると、NC Gageはティーチングプロセス中にプローブが検索した任意要素の設計値の結果を丸めます。結果は2つの基準を使用して丸められます。最初に、結果はこのフィールドで小数点以下の桁数に丸められます。2番目に、結果はこのフィールドで最も近い倍数に丸められます。

例として、結果が0.068でこのボックス内の値が0.03の場合、処理は以下のようになります：最初に0.068が小数以下2桁に丸められ、結果は0.07になります。次に、この値が「3」に最も近い倍数に丸められ、「6」 は 「3」 の倍数であるため0.07が0.06に変更されます。

  • 角度丸め値 - これは測定結果の丸め値と同じ原則で処理されますが、角度の測定に対するものです。

統計データ保存オプションエリア

  • 保存先 - 統計データ(各要素の結果)が保存される場所を指定します。xⅿlかcsvフォーマットで保存できます。XMLもしくはCSVオプションを選択します。統計データはデータフォルダのサブディレクトリ「STAT 」にも保存されます

  • 自動保存 -測定プログラムの実行時に自動的に統計データファイルを作成します。ここをチェックした場合、上書きまたは追加保存オプションが使用できます。

    • 上書き - このオプションを選択すると、NC Gageは統計データを保存先で指定されたフォルダに自動的に保存します。NC Gageは次回以降統計データを保存する場合は、このファイルを自動的に上書きします。

測定プログラム毎の統計データファイル名は同一です。フォーマットは：<測定プログラム>.rtfです。この<測定プログラム>は実行された最後の測定プログラムの名前です。

    • 追加保存 - このオプションを選択すると、NC Gageは統計データに毎回別名をつけ保存先で指定されたフォルダに自動的に保存します。NC Gageは一度保存した統計データを置き換えません。

測定プログラム毎の統計データファイル名は異なります。フォーマットは：<測定プログラム>_<M>-<DD>-<YY>_<hh>-<mm>-<ss>.xmlです。各項目は以下のようになります ：

<測定プログラム> - 現在読込まれている測定プログラムの名前(拡張子「.prg」がないもの)

<M>または<MM> - ユーザーのコンピュータシステムの日付に基づいた1桁または2桁の月。

<DD> - ユーザーのコンピュータシステムの日付に基づいた2桁の日付。

<YY> - ユーザーのコンピュータシステムの日付に基づいた4桁の年。

<hh> - ユーザーのコンピュータシステムの時刻に基づいて統計データが保存される2桁の時刻(24時制)

<mm> - ユーザーのコンピュータシステムの時刻に基づいて統計データが保存される2桁の分

<ss> - ユーザーのコンピュータシステムの時刻に基づいて統計データが保存される2桁の秒

ファイル名に対する24時間のタイムスタンプの表記は統計データが保存される時刻を示します(測定プログラムが実行される時刻ではありません)。このため、同じ統計データを連続して保存する場合でも、各統計データファイル名は異なったものになります。

またオプションの設定方法に関係なく、いつでも統計データを手動で保存できます。手動で保存される統計データのファイル名のフォーマットは：<測定プログラム>_<MM>-<DD>-<YY>_<hh>-<mm>-<ss>.xmlです。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


ユーザー公差チャート

ユーザー公差チャートでは、任意の公差値の一覧を作成します。各要素の公差画面で、ユーザー公差のチャートの一覧から使用したい公差を選択します。これにより、各要素の公差画面で速やかに公差値を選択して入力することができます。

ユーザー公差を定義するには：

  1. メイン画面で設定 ソフトキー [image] を押します。

  2. 公差チャートを定義ソフトキー [image] を押してユーザー公差チャート画面を表示します：

  3. 設定したい等級の上限公差値または下限公差値を入力します。

  4. 等級を定義したら、変更ソフトキー [image] を押します。次に、公差画面からこれらの等級を選択することができます。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


測定面の設定

測定面の設定画面を使用して、ソフトウェアの各所にある [image] [image] 測定面ソフトキーの方向を定義します。測定面とはワークの測定される面のことです。NC Gageが表示されるコンピュータ画面が工作機械周辺の決まった位置に常にあるわけではない場合、この設定画面が役に立ちます。この画面を使用して、測定面アイコンの設定をカスタマイズしたり、デフォルトの測定面の設定を選択します。

測定面を設定するには：

  1. メイン画面で設定 ソフトキー [image] を押します。

  2. 測定面の設定ソフトキー [image] を押して測定面の設定画面を表示します：

  3. 立型機械の初期設定、横型機械の初期設定または、カスタマイズを選択します。カスタマイズを選択した場合、座標軸の定義を指定します。図の各方向「1, 2, 3」に対応する作業面を「 X+, X-, Y+, Y-, Z+, Z- 」から選択します。

  4. 測定面を定義したら確認ソフトキー [image] を押します。ソフトウェアの各所にある測定面ソフトキーが押されるたびに、ここでの定義に従って測定面を切り替えます。

  5. 確認ソフトキー [image] を押すと変更した内容を保存します。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

左手座標系に設定することができます。NC Gageがユーザーに通知します。

このセクションの内容は以下となります：

  • 測定面の選択(マシニングセンタ)

  • 測定面の選択(複合旋盤)

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


測定面の選択(マシニングセンタ)

マシニングセンタ用の測定面を設定します。

  1. 測定面の設定画面で立型機械の初期設定を選択します。

  2. 確認ソフトキー [image] を押します。

  3. 戻る ソフトキー [image] を押して、メイン画面に戻ります。

  4. メイン画面から、測定 ソフトキー [image] を押します。

  5. 測定画面で点の測定ソフトキー [image] を押すと、点の測定画面が表示されます。

  6. 測定面を選択 ソフトキー [image] を押して、点の作業面を選択します：

測定面のZ+方向のプローブ位置を示す画像

プローブ方向は、回転軸の回転角度に依存しません：

- プローブはＺ軸＋方向からＺ軸－方向に移動します。

- プローブはＸ軸－方向からＸ軸＋方向に移動します。

- プローブはＸ軸＋方向からＸ軸－方向に移動します。

- プローブはＹ軸－方向からＹ軸＋方向に移動します。

- プローブはＹ軸＋方向からＹ軸－方向に移動します。

回転軸が回転していない状態でのXYZ値が最終的な測定結果となります。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


測定面の選択(複合旋盤)

以下のパターンのひとつを選んで測定面を設定します。

  • 初期設定

  • B軸0度

  • B軸90度

測定面のＺ軸方向は、常にプローブ方向となります。

B軸の回転に伴い、Z軸方向が常にプローブ方向となるように測定面も回転することを示した画像

回転軸が回転していない状態でのXYZ値が最終的な測定結果となります。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


初期設定

  1. 測定面の設定画面で立型機械の初期設定を選択します。

  2. 確認ソフトキー [image] を押します。

  3. 戻る ソフトキー [image] を押して、メイン画面に戻ります。

  4. メイン画面から、測定 ソフトキー [image] を押します。

  5. 測定画面で点の測定ソフトキー [image] を押すと、点の測定画面が表示されます。

  6. 測定面を選択 ソフトキー [image] を押して、点の作業面を選択します：

プローブ方向は、C軸の回転角度に依存しません：

プローブはプローブ軸に平行な平面上を、Z軸＋方向からZ－方向に移動します。

プローブはプローブ軸に垂直な平面上を、X軸－方向からX＋方向に移動します。

プローブはプローブ軸に垂直な平面上を、X軸＋方向からX－方向に移動します。

プローブはプローブ軸に垂直な平面上を、Y軸－方向からY＋方向に移動します。

プローブはプローブ軸に垂直な平面上を、Y軸＋方向からY－方向に移動します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


B軸0度

  1. 測定面の設定画面でカスタマイズを選択します。

  2. 座標軸の定義セクションから：

    • 1番目のリストボックスはX+を選択します。

    • 2番目のリストボックスはY+を選択します。

    • 3番目のリストボックスはZ+を選択します。

  3. 確認ソフトキー [image] を押します。

  4. 戻る ソフトキー [image] を押して、メイン画面に戻ります。

  5. メイン画面から、測定 ソフトキー [image] を押します。

  6. 測定画面で点の測定ソフトキー [image] を押すと、点の測定画面が表示されます。

  7. 測定面を選択 ソフトキー [image] を押して、点の作業面を選択します：

プローブ方向は、C軸の回転角度に依存しません：

プローブはプローブ軸に平行な平面上を、Z軸＋方向からZ－方向に移動します。

プローブはプローブ軸に垂直な平面上を、X軸－方向からX＋方向に移動します。

プローブはプローブ軸に垂直な平面上を、X軸＋方向からX－方向に移動します。

プローブはプローブ軸に垂直な平面上を、Y軸－方向からY＋方向に移動します。

プローブはプローブ軸に垂直な平面上を、Y軸＋方向からY－方向に移動します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


B軸90度

  1. 測定面の設定画面でカスタマイズを選択します。

  2. 座標軸の定義セクションから：

    • 1番目のリストボックスはZ +を選択します。

    • 2番目のリストボックスはY+を選択します。

    • 3番目のリストボックスはX-を選択します。

  3. 確認ソフトキー [image] を押します。

  4. 戻る ソフトキー [image] を押して、メイン画面に戻ります。

  5. メイン画面から、測定 ソフトキー [image] を押します。

  6. 測定画面で点の測定ソフトキー [image] を押すと、点の測定画面が表示されます。

  7. 測定面を選択 ソフトキー [image] を押して、点の作業面を選択します：

プローブ方向は、C軸の回転角度に依存しません：

プローブはプローブ軸に平行な平面上を、Z軸＋方向からZ－方向に移動します。

プローブはプローブ軸に垂直な平面上を、X軸－方向からX＋方向に移動します。

プローブはプローブ軸に垂直な平面上を、X軸＋方向からX－方向に移動します。

プローブはプローブ軸に垂直な平面上を、Y軸－方向からY＋方向に移動します。

プローブはプローブ軸に垂直な平面上を、Y軸＋方向からY－方向に移動します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


システム設定

システム設定画面には以下の機能があります：

  • 画面設定エリアでNC Gage画面の動作を設定する

  • 終了操作エリアでNC Gageの終了方法を選択する

システムを設定するには：

  1. メイン画面で設定 ソフトキー [image] を押します。

  2. システム設定ソフトキー [image] を押してシステム設定画面を表示します：

画面設定エリア

位置変更が可能 - NC Gage画面の位置を変更することが可能になります。

サイズ変更が可能 - NC Gage画面サイズを変更することが可能になります。

最小化が可能 - NC Gage画面を最小化することが可能になります。

終了操作エリア

終了 - NC Gageの終了が指令されたら、NC Gageが終了します。

ログオフ - NC Gageの終了が指令されたら、NC Gageが終了し、さらにその時点のPCユーザーアカウントからもログオフします。

シャットダウン - NC Gageの終了が指令されたら、NC Gageが終了し、さらにPCもシャットダウンします。

ファイルの実行 - NC Gageの終了が指令されたら、NC Gageが終了し、さらに指定のファイルを実行します。

確認ソフトキー [image] を押して、変更を保存します。または、戻るソフトキー [image] を押して保存せずに前の画面に戻ります。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


パスワードの設定

パスワードの設定画面を使用して、システム設定の不正な変更を防止するためのNC Gageアプリケーション用パスワードを設定します。

  1. メイン画面で設定 ソフトキー [image] を押します。

  2. パスワードの設定ソフトキー [image] を押すとパスワードの設定画面が表示されます：

  3. 確認ソフトキー [image] を押して、行った変更を保存します。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

パスワードで設定しない - このオプションを選択するとすべてのシステムのパスワード保護が無効になります。パスワードを設定エリアが無効になりグレイ表示になります。

設定値を変更するにはパスワードが必要です - このオプションを選択すると、システムのパスワード保護が有効になります。パスワードを設定エリアが有効になりパスワード情報を入力できるようになります。

パスワードを設定エリア

パスワードを入力 システム設定の変更を防ぐために使用するパスワードを入力します。

パスワードを確認 - パスワードを入力ボックスで入力したパスワードを確認のため再入力します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


データバックアップ

Data Centerなどのデータをバックアップおよび復元するには、データバックアップ画面を使用します。

  1. メイン画面で設定 ソフトキー [image] を押します。

  2. データバックアップソフトキー [image] を押して、データバックアップ画面を表示します：

  3. 選択したフォルダをバックアップまたは復元するには、コピーソフトキー [image] を押します。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

ローカル - リストから、バックアップまたは復元するフォルダのチェックボックスを選択します。Data Centerチェックボックスをオンにすると、他のフォルダが自動的に選択されます。

動作 - バックアップするか、復元するかによって、オプションを選択します：

  • バックアップ(ローカルフォルダ->保存先) - このオプションを使用すると、ローカルフォルダから保存先にデータをバックアップできます。

  • 復元(保存先->ローカルフォルダ) - このオプションを使用すると、保存先からローカルフォルダにデータを復元できます。

保存先 - データをバックアップする場所またはデータを復元する場所のパスを指定します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


回転軸中心座標の設定

回転軸またはリスト軸の情報は、NC Gageコンフィグツールで定義することができます。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


カウンタ表示セットアップ

カウンタ表示の設定を使用して、関連するカウンタ用NC Gage画面に表示される内容を定義できます。

NC Gageカウンタは通常セットの数字を2つ表示します。ユーザーはこのカウンタ表示の設定画面を使用して、コントロールの左側と右側に表示される内容を定義できます。異なるの画面では異なる選択肢も定義できます。

NC Gageはカウンタを設定したいケースに対して以下の3種類の「レベル」を提供します：

  • 個々のコマンドをティーチングするときに、「要素ビュー」として表示される内容を定義したい場合。

  • メイン画面に移動するとき、または測定プログラムを実行するとき、これがNC Gageアプリケーション内部では高レベルであるため「測定プログラムビュー」が表示されます。

  • 校正手順の実行中に「校正ビュー」を表示したい場合。

この画面にアクセスするには：

  1. メイン画面で設定ソフトキー [image] を押します。

  2. 設定画面の1ページ目、ページ目からカウンタ表示の設定ソフトキー [image] を押してカウンタ表示の設定画面を表示します：

  3. 確認ソフトキー [image] を押して、行った変更を保存します。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

大部分のNC Gage画面でカウンタボックスが表示されます。カウンタボックスには4セットのカウンタ2つ

新しいアライメントシステムはパート座標です。NC Gageはユーザーに現在のプローブ位置を表示するための柔軟な方法を提供しています。

カウンタ表示設定画面

カウンタ表示には座標系があります。下記に座標系を示します：

  • 機械位置 - 現在のプローブの位置を機械座標系で表示します。このオプションは常に使用できます。

  • ワークオフセット - カウンタは現在のプローブの位置を現在のワークオフセット座標で表示します。このオプションは常に使用できます。

  • パート - カウンタは現在のプローブの位置をパート座標で表示します。このオプションは、NC Gageが3軸以上を制御している場合にのみ使用できます。パート座標を以下に定義します。

XYZレポート値エリア - 工具長を適用する方法に関して各種座標でレポートされるXYZ値。

カウンタ表示のレイアウトエリア - カウンタは通常、1組の座標セットとして定義されます。但し、一部の画面では1組のカウンタしか表示されません。ユーザーはカウンタの左側と右側を定義することによって各座標セットで表示したい内容を定義できます。以下の3種類のエリアを定義できます：

  • 要素ビュー - 要素コマンドがティーチングされるときに表示することができるカウンタを定義します。上記で定義した座標系のうちのどれでも選択できます。

  • 測定プログラムビュー - 測定プログラム全体に適用される画面をNC Gageが表示するときに表示できるカウンタを定義します。上記で定義した座標系のうちのどれでも選択できます。

  • 校正ビュー - 校正中に表示できるカウンタを定義します。機械およびワークオフセット座標系しか選択できません。

点に対しては3つの選択肢を各座標系で表示できます。ユーザーは各座標系を個別に設定できます。オプションは以下のとおりです：

  • 工具長が含まれていない - カウンタはゲージ(接続)点の現在の位置を示します。

  • 工具長 - カウンタはコントロールの工具テーブルで見つかった工具長を適用して、工具の終端の位置を示し、それをゲージ点位置に追加します。

  • プローブルビーの中心 - カウンタはプローブルビーの中心位置を表示します。ゲージ点からルビー先端までのオフセットはプローブが校正されるときに決定されます。

パート座標系

パート座標系 (PCS) はパートの参照系です。各パートに対して1つしかなく、描画によって定義されます。PCS の原点はワークオフセットを介してMCS と関連しています (G54など)。PCS はすべての回転軸をゼロ位置にしたワークオフセットで定義された座標系と等価です。

G54 - 以下に示すパートのコーナーで設定されるオリジナルのXYZゼロ位置：

パート座標は最初のワークオフセットが選択され、すべての回転軸がゼロの位置にあるときに有効な座標系です。この定義によってNC Gage v1.2 以降でのすべての測定プログラムがパート座標を使用します。パート座標はすべての測定値を4軸および5軸系において関連させることができる意義深い共通座標系として重要です。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


新規プローブの作成

元の状態 > NC Gageの使用 > はじめに > ステップ 3：新規プローブの作成

ステップ 3：新規プローブの作成

プローブを新規で作成画面を使用して、ワークの測定に使用するプローブの種類を定義します。

  1. メイン画面でプローブソフトキー [image] を押します。

  2. プローブ画面でプローブを選択ソフトキー [image] を押します。

  3. プローブを選択画面でプローブを新規で作成ソフトキー [image] を押して、プローブを新規で作成画面を表示します：

  4. この画面を使用してプローブについての情報を提供します。プローブの直径の設計値、工具長、プローブを保持する工具番号、プローブ名および特記事項を入力します。

  5. 確認ソフトキー [image] を押して、行った変更を保存します。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

定義

  • 工具番号 - プローブを保持する工具番号

  • 直径の設計値 -プローブルビーの直径の設計値です。

  • 長さの設計値 - ノーズポイントからチップ中心までのプローブ長です。工具長の偏差は20mm未満でなければなりません。これは校正時に球中心を確認するために使用します。この値は校正時には更新されません。校正時にはプローブルビー補正値が更新されます。

  • プローブ名 - 工具番号の前にある工具のプローブ名。プローブ名と工具番号でプローブファイルを識別できます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


プローブの選択

元の状態 > NC Gageの使用 > はじめに > ステップ 4：プローブの選択

ステップ ４：プローブの選択

プローブの選択画面を使用すると、ワークを測定するためのプローブを選択できます。

  1. メイン画面でプローブソフトキー [image] を押します。

  2. プローブの選択ソフトキー [image] を押してプローブの選択画面を表示します：

  3. プローブの選択ソフトキー [image] を使用して、プローブの選択リストから使用したいプローブを選択します。

  4. 現在のコマンドから最後までを確認して追加ソフトキー [image] を押して変更を保存します。または、戻るソフトキー [image] を押して保存せずに前の画面に戻ります。

NC Gageはプローブを測定プログラムのツリービューに挿入します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


校正

元の状態 > NC Gageの使用 > はじめに > ステップ 5：校正

ステップ 5：校正

校正はシステムでプローブルビーの補正と有効半径を定義するのに非常に重要です。

回転軸の校正（キャリブレーション）は測定のために回転軸を回した場合に、その校正値が使用されますので、プローブの校正と合わせて大変重要です。

  1. メイン画面からプローブソフトキー [image] を押して校正オプションに進みます。

校正オプションには以下の項目があります：

  2. プローブの選択ソフトキー [image] を押して校正するプローブを選択、または新規作成をします。

以下のプローブ校正オプションを使用することができます：

  • キャリブレーションボールによる校正ソフトキー [image] を押すと、キャリブレーションボールを使用しての校正が出来ます。

  • リングゲージによる校正ソフトキー [image] を押すと、リングゲージを使用しての校正が出来ます。

以下の回転軸校正オプションを使用できます：

  • 回転軸の校正 ソフトキー [image] を押して回転軸の校正（キャリブレーション）を行います（複数存在する場合は全ての軸で実施）。

  • 回転軸校正データの書き込みソフトキー [image] を押すと、回転軸またはリストの校正データをNCに書き込むことが出来ます。

下記のミル旋盤の校正 トピックを使用することができます：

  • リストヘッドの校正ソフトキー [image] を押して、ミル旋盤の設定およびプローブ校正の手順を実行します。

  • リストヘッドの校正画面で回転軸校正基準球の中心座標計測ソフトキー [image] を押して、基準球の中心を検索します。

  • リストヘッドの校正画面でリスト校正角度の設定 ソフトキー [image] を押して、ミル旋盤のB軸の校正位置を生成します。

  • 校正が完了したら、リストヘッドの校正画面で校正レポートの表示 ソフトキー [image] を押して校正レポートの表示、印刷および保存を行います。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


プローブの校正オプション

プローブを校正（キャリブレーション）して、プローブ先端のルビー球の補正と有効半径を設定します。

プローブ画面に進むには：

  1. メイン画面でプローブソフトキー [image] を押します。

  2. プローブの校正のために適切なプローブ校正ソフトキーを選択します：

    • キャリブレーションボールによる校正ソフトキー [image] を押して、キャリブレーションボールを使用して校正をおこないます。

    • リングゲージによる校正ソフトキー [image] を押して、リングゲージを使用して校正をおこないます。

下記のオプションはプローブ画面で使用できます：

    • プローブの選択ソフトキー [image] を押すと、校正するプローブを選択したり、新規に作成することが出来ます。

    • 回転軸の校正ソフトキー [image] を押すと、回転軸の校正をおこなうことが出来ます。

    • 回転軸校正データの書き込みソフトキー [image] を押すと、回転軸またはリストヘッドの校正データをNCに書き込むことが出来ます。

    • リストヘッドの校正ソフトキー [image] を押すと、リストヘッドの校正をおこなうことが出来ます。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


キャリブレーションボールによる校正

  1. メイン画面でプローブソフトキー [image] を押します。

  2. プローブ画面でキャリブレーションボールによる校正ソフトキー [image] を押してキャリブレーションボールによる校正画面を表示します：

  3. 画面下部に表示された指示に従って校正を実行します。

パラメータエリア

  • 送り速度 - プローブ校正中にプローブが移動する速度（mm/min、インチの場合はinch/min）を設定します。

  • アプローチ距離 – 計測点の手前何ミリから計測動作をさせるかを設定します。これはプローブ校正に使用します。単位はミリまたはインチです。

オプションエリア

  • 詳細を表示 - チェックを入れるとルビー補正値エリアが表示されます。ルビー補正値には下記の情報が表示されます：

    • X、YおよびZに関する実測値、設計値、および公差。

    • 形状エラー（真球度）の実測値、設計値、および公差。

プローブエリア

  • ルビー径 - プローブ先端のルビー球直径の実測値、設計値、および公差情報が表示されます。実測値は校正後にアップデートされます。

ターゲットエリア

  • 直径 - 使用する校正球の直径値を入力します。

  • 中心XYZ - 校正球の中心座標を機械座標で指定します。ワークオフセットにの設定は影響しません。

  • ワークオフセット - ワークオフセットは使用できません。常に機械座標で動作します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

校正プロセス

  1. 校正にワークオフセットは使用しません。常に機械座標で動作します。

  2. 使用する校正球の直径値と中心の座標値をそれぞれ入力します。後述のXYの検索を使用して中心位置をプローブで検索することも可能です。

  3. 上記に記載されたその他のパラメータを入力します。

  4. 校正球中心の上方にプローブ先端のルビー球を移動させます。

  5. 実行ソフトキー [image] をクリックし、NC側でプログラムを起動します。NC Gageは自動的に校正球上で5つの計測点位置を取得して球の中心を決定します。校正球の中心が正確に決定されると、NC Gageはパラメータによって定義される校正球上で自動的に161の計測点位置を取得します。

校正が完了すると測定値がアップデートされます。これで校正されたプローブを使用して要素を測定する準備が整いました。

XYの検索

  • スピンドル回転を使用 - NC工作機械がスピンドル回転をサポートしている場合(M19Sxxx)、校正画面の中心検索適用機能を使用して校正球のXY位置を検索できます。この関数は各ポイントのスピンドルを回転させ、プローブ先端の振れが要因ではないようにします。

Zの検索

  • スピンドルに既知の長さの基準(参照)工具を挿入します。

  • 既知の厚さの隙間ゲージを使って、隙間ゲージを校正球と工具の間で動かそうとすると抵抗を受けるところまで、校正球最上部に工具を降ろします。校正球の近くでは、移動量の指定は最小のものを使用してください。

  • 校正球の最上部Z= 機械座標Z - 隙間ゲージの厚さ- 基準工具長となります。

NC Gage

  • 校正球の最上部の上方でプローブの位置を読込みます。

  • 真下の点を測定します。検索距離はプローブ半径+ 2*アプローチ距離です。

  • 安全高さ= 読込み点Zおよびアプローチ距離の最大値 + 接触点の上方のプローブ半径と設定します。

  • 校正球の中心を接触点の下方の球半径であると推定します。

  • アプローチ距離 (半径) = 球半径 + プローブ半径 + アプローチ距離と設定します。

  • 安全高さに移動します。

  • 校正球中心から+X方向におけるアプローチ距離である点に安全高さで移動します。

  • 推定された球の赤道の高さまで下降します。

  • 16点で(必要に応じて点と点の間で余分な移動を行って)赤道を測定します。

  • 次のラインに上昇します(赤道の9度上方)。

  • 16点でラインを測定します。

  • 10ラインすべてでプロセスを繰り返します。

  • 校正球の最上部の点を測定します。

  • 安全高さに戻ります。

校正球の中心位置を特定します。

XYの検索：

  • スピンドル回転を使用 - NC工作機械がスピンドルの方向をサポートしている場合(M19Sxxx)、球校正画面の中心検索適用機能を使用して校正球のXY位置を検索できます。この関数は各ポイントのスピンドルを回転させ、プローブ先端の振れが要因ではないようにします。

  • ダイヤルインジケータを使用 - NC工作機械のスピンドルでのダイヤルインジケータを読込み、校正の赤道付近で接触するように調整します。NC工作機械でXおよびY方向に動かして、スピンドル回転時にインジケータでの偏差が最小になるようにします。校正球中心はXおよびYの機械位置です。

Zの検索：

  • スピンドルに既知の長さの基準(参照)工具を挿入します。

  • 既知の厚さの隙間ゲージを使って、隙間ゲージを校正球と工具の間で動かそうとすると抵抗を受けるところまで、校正球最上部に工具を降ろします。校正球の近くでは、移動量の指定は最小のものを使用してください。

  • 校正球の最上部Z= 機械座標Z - 隙間ゲージの厚さ- 基準工具長となります。

NC Gageでワークオフセットを選択することはできません。

コントローラ側ではXYZ値が全て0のワークオフセットを選択しておいてください。

キャリブレーションボールによる校正の例

プローブの校正後、校正レポートの表示ソフトキー [image] を押して校正レポートを表示します：

印刷ソフトキー [image] を押すと、デフォルトプリンタにハードコピーを印刷できます。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


回転軸校正基準球の中心座標計測

元の状態 > NC Gageの使用 > はじめに > ステップ 5：校正 > プローブの校正オプション > キャリブレーションボールによる校正 > ボールの中心検索

ボールの中心検索

次の手順を実行してプローブを校正するのに必要なボール(校正球)の中心検索を行います。

  1. 入力値エリアの直径欄に校正球の直径を入力します。

  2. 画面下のメッセージに従い、実行ソフトキー [image] を押して校正球の中心検索を開始して下さい。

校正球ツールエリアに自動的に結果が入力され、振れが調整されます。

  3. 確認ソフトキー [image] を押してキャリブレーションボールによる校正画面に戻ります。

パラメータエリア

  • アプローチ距離 - 測定する点の手前何ミリから測定を開始するかを設定します。

  • 検索距離 - 測定開始点から何ミリ検索動作を行うかを設定します。

入力値エリア

  • 直径 - 校正球の直径を入力します。

校正球ツール

  • 中心X - 校正球中心のX座標値を表示します。

  • 中心Y - 校正球中心のY座標値を表示します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


リングゲージによる校正

リングゲージによる校正はXYZの3軸のみしか使用しない測定に適しています（プローブはZ軸と平行であること）。

  1. メイン画面でプローブソフトキー [image] を押します。

  2. プローブ画面でリングゲージによる校正ソフトキー [image] を押してリングゲージによる校正画面を表示します：

  3. 画面下部に表示された指示に従って確認ソフトキー [image] を押して校正を実行するか、戻るソフトキー [image] を押して前の画面へ戻ります。

パラメータエリア

  • ルビー径(実測値/設計値) – プローブルビー球の設計上の直径値を示します。校正が完了すると実測値がアップデートされます。

  • 直径 - リングゲージの直径値を指定します。

  • 中心Ｘ,Ｙ,Ｚ – リングゲージ上面の中心座標を機械座標で指定します。Z値は、校正の最後にリングゲージの天面を測定する際に使用されます。ワークオフセットの設定は影響しません。

  • 送り速度 - 校正中にプローブが移動する速度（mm/min、インチの場合はinch/min）を設定します。

  • アプローチ距離 – 計測点の手前何ミリから計測動作をさせるかを設定します。これはプローブ校正に使用します。単位はミリまたはインチです。

  • ワークオフセット - ワークオフセットは使用できません。常に機械座標で動作します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

校正プロセス

  1. 校正にワークオフセットは使用しません。常に機械座標で動作します。

  2. リングゲージの直径と中心位置を入力します。ユーザーはこのページ下部にある説明を参考に位置の中心座標を特定できます。

  3. 上記のパラメータ定義エリアに記載されているその他のパラメータを入力します。

  4. リングゲージの中心の近くの位置にプローブを移動します。

  5. 実行ソフトキー [image] をクリックし、NC側でプログラムを起動します。NC Gageは自動的に校正リング上で計測点を４つ取得し、リングゲージの中心を決定します。リングゲージの中心を正確に測定した後、リングゲージの内径を36点測定し、リングゲージの上部の1点を測定し ます。

  6. 校正が完了すると、測定値がアップデートされます。詳細表示ソフトキー [image] を押してルビー補正値の詳細を確認するか、確認ソフトキー [image] を押して校正結果を保存しメイン画面へ戻ります。これで、校正済みのプローブを使用して要素の測定ができるようになりました。

詳細を表示チェックボックスを選択してルビーの詳細を表示することもできます。

XYの検索

  • スピンドル回転を使用 – NC工作機械がスピンドルの回転をサポートしている場合(M19Sxxx)、リング校正画面の中心検索機能を使用してリングのXY位置を検索できます。この関数は各ポイントのスピンドルを回転させ、プローブ先端の振れが要因ではないようにします。

Zの検索

  • スピンドルに既知の長さの基準(参照)工具を挿入します。

  • 既知の厚さの隙間ゲージを使って、隙間ゲージをリングと工具の間で動かそうとすると抵抗を受けるところまで、リング上部に工具を降ろします。リングの近くでは、移動量の指定は最小のものを使用してください。

  • リングの上面Z = 機械座標Z - 隙間ゲージの厚さ- 基準ツール長となります。

NC Gage

  • リングの中心でプローブの位置を読込みます。

  • リングの測定が読込み点のZ値で行われます。

  • リングのXY中心を読込み位置であると推定します。

  • アプローチ距離 = リング半径 + プローブ半径 - アプローチ距離と設定します。

  • ターゲット距離 = リング半径+アプローチ距離と設定します。

  • 安全高さの設定= Z 値の位置の読込め+ 25 mm.

  • 0～350度までの36点でリング測定します。

  • 安全高さに移動します。

  • 安全高さでリング+X方向にリング半径+ 2 *プローブ半径である点に移動します。

  • 真っ直ぐ下方に測定します。ターゲット高さはリング点と同じ高さです。

  • 安全高さに戻ります。

リング校正レポートの例

プローブの校正後、校正レポートの表示ソフトキー [image] を押して校正レポートを表示します。

印刷ソフトキー [image] を押すと、デフォルトプリンタでハードコピーを印刷できます。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


リングの中心検索

次の手順を実行してプローブを校正（キャリブレーション）するのに必要なリングゲージの中心検索を行います。

  1. 入力値エリアの直径欄にリングゲージの直径を入力します。

  2. 画面下のメッセージに従い、実行ソフトキー [image] を押してボールの中心検索を開始して下さい。

校正リングツールエリアに自動的に結果が入力され、振れが調整されます。

  3. 確認ソフトキー [image] を押してリングゲージによる校正画面に戻ります。

パラメータエリア

  • アプローチ距離 - 測定する点の手前何ミリから測定を開始するかを設定します。

  • 検索距離 - 測定開始点から何ミリ検索動作を行うかを設定します。

入力値エリア

  • 直径リングゲージの直径を入力します。

校正リングツールエリア

  • 中心X - リングゲージ中心のX座標値を表示します。

  • 中心Y - リングゲージ中心のY座標値を表示します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


回転軸校正オプション

回転軸を持つ機械の場合、回転軸の位置と方向を設定する必要があります。

計測で回転軸を使用する場合、回転軸の校正が必要になります。

回転軸校正機能はプローブ画面で使用できます。プローブ画面を開くには以下のようにします：

  1. メイン画面でプローブソフトキー [image] を押します。

  2. 回転軸の校正 ソフトキー [image] を押して回転軸の校正を行います（複数存在する場合は全ての軸で実施）。

以下のオプションは回転軸の校正画面内にあります：

  • 校正レポートを表示ソフトキー [image] - 回転軸の校正後、校正結果（レポート）を表示します。

  • ボールの中心検索ソフトキー [image] - 回転軸の校正で使用するボールの中心検索を行うことができます。

以下のオプションはプローブ画面内にあります：

  • プローブの選択ソフトキー [image] - 校正するプローブの新規作成、またはプローブを選択します。

  • キャリブレーションボールによる校正ソフトキー [image] - 校正球を使用してプローブの校正をします。

  • リングゲージによる校正ソフトキー [image] - リングゲージを使用してプローブの校正をします。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


回転軸の校正

すべての軸パラメータがNC Gage設定ツールで入力されるまで回転軸の補正は無効です。(詳しくは、「付録A - コントローラの設定」を参照)

回転軸の校正は機械座標を使用して実行されます。したがって、位置情報のパラメータも全て機械座標で設定します。

回転軸を校正する前に、回転軸中心の機械座標を調べておき、NC Gage設定ツールの軸設定タブで入力しておく必要があります。これらの数値は、様々な回転軸角度での校正球の位置をNC Gageが把握するために変換します。これらの値を定義すると、ユーザーは回転軸の校正を開始することができます。

回転軸を校正する前にプローブを校正球で校正する必要があります。そうしないと、回転軸の校正を使用できません。

  1. メイン画面でプローブソフトキー [image] を押します。

  2. 回転軸の校正ソフトキー [image] を押すと回転軸の校正画面が表示されます：

  3. 画面の指示に従った後に、確認ソフトキー [image] をクリックして手順を完了します。または、戻るソフトキー [image] を押して保存せずに前の画面に戻ります。

パラメータエリア

  • 送り速度 - プローブ校正中にプローブが移動する速度（mm/min、インチの場合はinch/min）を設定します。

  • アプローチ距離 - プローブが計測点を取得する前に移動する理論的な計測点位置からの距離を指定します。これはプローブの校正中に使用され、mmまたはインチで定義されます。

  • 安全な回転高さ - 回転軸の校正では回転軸が回転します。回転軸が回転する際に安全なプローブの高さを設定してください。プローブ先端のルビー球の位置を機械座標のZ値で設定します。

ルビーが回転軸またはワークに衝突するのを防ぐために、安全な回転高さの値を適切に設定することは非常に重要です。設定しない場合は0（ゼロ）が適用されますので、十分注意してください。

角度定義エリア

  • 箇所 - 球を測定する位置の数を設定します。開始角度と終了角度によって設定された角度はここで設定した数値で均等に分配されます。

  • 開始角度 - 回転軸の校正で最初に使用される回転軸の角度です。

  • 終了角度 - 回転軸の校正で最後に使用される回転軸の角度です。

開始角度と終了角度が同じ、または360度異なる場合、開始角度でスタートし終了角度でない位置で終わるように位置が均等に分配されますが、1インクリメント(増分)が短くなります。例）開始角度0度、終了角度360度、箇所数4と設定した場合、計測する角度は0度、90度、180度、270度となります。

  • １球当たりの点数 - 1箇所当たりの球の測定点数。

NC Gageは校正球ツールのプロパティで定義される軸を回避します。

回転軸校正エリア

設計値欄は中心位置を定義し、回転軸校正画面に入る前にNC Gage設定ツールの軸設定タブに存在する値を表示します。実測値欄には回転軸の校正を実行して得られた結果が表示されます。ユーザーが校正を受入れると、測定値がNC Gageの設定に書き込まれ、次回校正が実行されるときに新しい設計値になります。それらはNC Gage設定ツールの軸設定タブに表示されます。

  • 軸ID - 軸を識別する文字：システムで定義した回転軸に従ってA、BまたはCから選択します。

  • 中心 X, Y, Z - 回転軸中心のX、Y、Zの機械座標値です。

    • 設計値 - 初回は回転軸中心座標の設定画面で設定した値が表示されます。2回目以降は最後に測定して得られた値が表示されます。

    • 実測値 - 測定して得られた結果が表示されます。

  • 回転軸 I、J、K - テーブルの回転が定義される球を定義するベクトルI、J、Kの値です。使用可能なオプションは機械にあり選択されるテーブル軸によって異なります。デフォルト値が設計値コラムのフィールドに入力されます。それは必要に応じて手動で設定できます。

    • 設計値 - 初回は回転軸中心座標の設定画面で設定した値が表示されます。2回目以降は最後に測定して得られた値が表示されます。

    • 実測値 - 測定して得られた結果が表示されます。

基準ボールの定義エリア

回転軸の校正で使用する校正球の位置情報、球径、および球を支持しているシャフトの方向を設定します。ユーザはこれらの値を直接入力するか、回転軸校正基準球の中心座標計測ソフトキー [image] を押してティーチングすることができます。校正球の定義プロセスの説明は後述します。回転軸校正基準球の中心座標計測ソフトキー [image] を押すと、球を定義するように指示されます。回転軸校正基準球の中心座標計測画面を終了すると、ティーチングされた値が校正球画面に表示されます。

  • 中心X、Y、Z - 校正球中心のX、Y、Zの機械座標値。回転軸が0度の時の位置情報を入力する必要があります。

  • 直径 - 校正球の直径値を入力します。

  • I、JおよびK - 測定される球に対して軸の回転が定義されるベクトル軸の値。このベクトルは校正球の軸を定義します。軸から校正球の中心へ向いたベクトルを指します。

プローブ情報エリア

  • 工具番号 - 校正に使用するプローブの工具番号です。

  • 直径 - プローブ先端のルビー球の校正された直径値です。

  • 長さ - 校正されたプローブの長さです。

  • ルビー補正値X, Y, Z - ルビー球の補正値です。基準点からプローブ先端のルビー球中心までの値です。

全ての数値が正しく入力されていることを再度確認し、実行ボタンを押します。NC Gageが校正シーケンスを実行します。エラーがない場合、各球位置が測定され、球中心のセットが平面を計算します。計算された平面における球中心で円が計算されます。この円の中心が測定された回転軸の新しい中心です。平面の面直ベクトルが回転軸の新しいIJKベクトルです。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

校正プロセス

この画面を開く前に、軸に対する回転中心の位置を知り、NC Gage設定ツールの軸設定タブでそれらを入力する必要がありますこれらの数字は、球が異なる軸位置に存在するおおよその場所がNC Gageに分かるように点を変換します。

設計値 X、Y、Z、I、J および K は設定画面の値に初期化されます。実測値 X、Y、Z、I、J および K は、軸が校正され、ユーザーが校正を承認した後にNC Gage設定ツールの軸設定タブにおいて既存の値で置き換えられます。

回転軸を校正する前に以前に校正したプローブを選択する必要があります。

プローブ校正の品質は非常に重要です。プローブ校正のエラーはどのようなものでもテーブル校正に影響することがあります。

NC Gage設定ツールの軸設定タブで値を入力した後に、以下を行って軸を校正する必要があります：

  1. 送り速度、アプローチ距離および安全平面ルビー高さの値を入力します。

    • 送り速度は非測定状態での移動用です。

    • 安全平面ルビー高さ値は非常に重要です。NC Gageは各軸の位置決め移動および球の測定前にこの高さまで移動します。この値が正しく設定されていないと、NC Gageは回転軸のはるか上方または下方に機械を駆動することがあります。このフィールドで、回転軸が回転する前にプローブルビーを動かす安全なZ値を定義する必要があります。このプロセスにおけるすべての位置は機械座標での値です。

  2. 球の測定値を設定します。箇所、開始角度、終了角度、１球当たりの点数、上部角度および下部角度を入力します。

    • 箇所は球上で取得される測定値の総数を定義します。

    • 開始角度は校正中の回転軸における最初の角度です。終了角度はその最後の角度です。NC Gageはこの範囲を均等に分割します。例えば、開始角度が30に設定され、終了角度が210に設定され、5つの位置を定義している場合、NC Gage は30、75、120、165、および210度の位置で球を測定します。開始角度が0で終了角度が360度という特殊なケースでは、終了角度は球の数に基づいて調整されます。例えば、0～360、4つの測定と入力した場合、NC Gageは0、90、180、および270度の位置で測定を行います。

    • １球当たりの点数は各球上で測定される点の数です。

    • 下部角度および上部角度オプションは測定される球の角度範囲を定義します。90は北極を意味し、0は赤道を意味します。上部角度値には90が最も多く使用され、変更しなくてもかまいませんが必要に応じて変更することもできます。

      下部角度値は場合によっては校正球の軸を避けるために変更する必要があります。NC Gageは軸を回避できるため、この値を調整する必要がない場合もあります。

  3. 回転軸が正しく校正されるように正しいプローブを使用しているか確認してください。現在アクティブなプローブのポケット、直径、長さ、およびルビー補正値はこの画面の右下隅に表示されています。必要に応じて、プローブの選択ソフトキー [image] を押してプローブを変更することができます。回転軸の校正に使用するプローブは、球で校正されている必要がります。リングで校正されたルビーは使用できません。

  4. ドロップダウンリストから適切な軸 IDを選択します。設計値コラムに値が自動的に入ります。

  5. ユーザーは使用する球を定義する必要があります。NC Gageは球の位置の中心、直径、軸ベクトルおよび回転軸の位置を知っている必要があります。これらの値が不明の場合、回転軸校正基準球の中心座標計測ソフトキー [image] を押すと回転軸校正基準球の中心座標計測画面にアクセスできます。プローブの読込みソフトキー [image] を使用して現在のプローブ位置をティーチングできます。これらの値については以下の点に注意してください：

    • 中心 X、中心 Y、中心 Z は、回転軸がこのフォームの値の位置にあるときの球の中心座標です(この例ではAとC)。NC Gageは実際には回転軸がすべてゼロにあるときのX、Yおよびの位置を知っている必要があります。NC GageはNC Gage設定ツールの軸設定タブで定義された情報を使用してこれらの値を計算します。この位置で測定できない理由がない場合、回転軸がゼロ位置にある場所の座標で球を定義することをお勧めします。

    • I、J、K は球の中心を通る軸の中心からの方向を定義します。通常、このベクトルは (0, 0, 1) であり、これは球が真っ直ぐ上を向いていることを意味します。NC Gageはこのベクトルを使用して球の測定時に軸を避けようとします。

    • 上側テーブル (下の画像の1) が測定されるとき、下側テーブル(下の画像の2)はゼロの位置になくてはなりません。

    • 下側テーブル (下の画像の2) が校正されているとき、上側テーブル(下の画像の1)はどの位置にあっても構いません。

    回転軸C は以下に示すように回転軸A の上部に位置します：

1.C軸の回転
2. A軸の回転

  6. この情報のすべてを入力したら、実行 ソフトキー [image] を押して回転軸を校正します。

エラーがない場合、各球位置が測定され、球中心のセットが平面を計算します。計算された平面における球中心で円が計算されます。この円の中心が測定された回転軸の新しい中心です。平面の面直ベクトルが回転軸の新しいIJKベクトルです。

注記：

元の回転軸の点は校正プロセスによって決定された軸上に投影されます。このため、新しい軸の点は古いものとあまり変わらず、ユーザーを混乱させることはないはずです。

このフォームに入力された情報はすべてファイルに保存されます。各回転軸の情報はファイルに別々に保存されます。校正が実行されると、ファイルに再度書き込まれます。ユーザーが新しい校正を実行すると、フォームにはその軸の最後の校正で保存された値が入力されます。

軸別に校正が行われます。最初に、校正されない回転軸を強制的にゼロにする必要があります。この制限は後で取り除いてもかまいません。

回転軸校正レポート

回転軸の校正が終わると、校正レポートを表示ソフトキー [image] を押して校正結果をレポートで見ることができます。

レポート内の情報については以下のとおりです：

  • 測定時間、軸ID、単位、計算された回転軸の中心の値が示されています。

  • これは現在の測定値とNC Gage設定ツールの軸設定タブで定義された値の差を示します。これが最初の校正である場合、シフト値はユーザーが定義した位置からの偏差を示します。それ以降の校正では、この値は前回の校正からの変化を示します。ユーザーが校正を受け入れると、回転の中心がNC Gage設定ツールの軸設定タブに書き込まれます。

  • 回転軸は「回転軸の傾き」を示します。ベクトルおよび角度のペアとして表現されます。回転軸間の距離は最も近くにある2つの回転軸の軸間距離を示します。

  • 各球測定の位置決め誤差は回転軸形式とグラフィカル形式の両方で表示されます。位置決め誤差の成分を下記に示します：

    • 半径（半径方向誤差） - 計算された円と実際の球位置の半径方向の誤差です。

    • 接線方向誤差 - 球が測定されるときの円内部における角度と回転軸の位置に基づいた球位置の誤差。これらの偏差は球位置に対して「時計回り」です。つまり、最初の球の接線方向誤差は常に0で、その他すべての球の接線方向誤差は最初の測定に対するものです。この誤差は基本的に回転軸の位置決めの精度を測定します。

半径方向誤差および接線方向誤差は、球の設計上の位置に対する球の位置誤りとしてグラフィカルに (誇張して) 描画されています。

    • 軸誤差 - この誤差は球の中心のすべてを使用して計算された最適化平面からの球位置の偏差を測定します。正の値は誤差が「上側」であり、負の値は下側であることを意味します。これは誤差を拡大してグラフィカルに描画され、相互に対する差を見ることができます。正の偏差は青色で塗りつぶされた円盤、負の偏差は赤色のリングで表示されます。レポートを白黒プリンタで印刷した場合、塗りつぶしとリング状によって表示されます。

  • 印刷ソフトキー [image] を押すと、ハードコピーをデフォルトのプリンタに印刷することができます。

積み重ねられた回転テーブルのレポート

NC Gageで回転軸を校正すると、その回転軸の中心が他軸に最も近い計算された軸上にある点としてレポートされます。これは2軸を一緒に考慮することによって行われます。2軸が交差する位置に最も近い点を表す点が決定され、それらの点が回転軸の中心としてレポートされる新しい点になります。

NC Gageは2軸が最も近くで交差する位置を決定します。これらの点は2軸の回転の中心としてレポートされます：

A - 上方回転軸
B - 下方回転軸

積み重ねられた回転テーブルの軸定義の例

注記：

点が回転軸上にあるときは、NC Gageが使用する計算は中心点の選択に左右されません。

最初の校正が実行されると、NC Gageは他の回転軸の設計上の軸を使用して計算を行います。2番目の回転軸が校正されるときに調整が行われます。

回転軸が校正されると、1つの回転軸の中心軸がわずかに変更されると小さな影響が出るため、両方の回転軸の中心がアップデートされます。

2つの回転軸間でレポートされるオフセットは2点間の差分です。

レポートされる2つの回転軸間の距離は2点間の距離です。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


回転軸校正データの書き込み

回転軸の校正を行った後、回転軸校正データの書き込み機能を使用して、校正データをNC側のマクロ変数に書込むことができます。

  1. メイン画面でプローブソフトキー [image] を押してプローブ画面に進みます。

  2. 回転軸校正データの書き込みソフトキー [image] を押して回転軸校正データの書き込み画面を表示します。

    • 回転軸の場合：

    • リストの場合：

  3. 中心Xの変数欄に先頭となるマクロ変数番号を入力します。残りの変数欄は入力した番号を基に順次自動的に割り当てられます。

  4. 確認ソフトキー [image] を押して校正された値をコントローラに転送します。以下に示すとおりにマクロ変数の番号が順番に入力されます。使用に際してはユーザー様の責任においてお願い致します。

パラメータエリア

  • シフト - 設計上の中心と、算出された実際の中心との偏差です。実際の中心は、リストヘッドキャリブレーションでのすべての角度位置のデータを元に計算されます。

  • オフセット -設計上の中心と、算出された実際の中心との偏差です。実際の中心は、直交する２つの角度(0と90、または0と-90)でのデータによって計算されます。校正角度にこの2つの角度があるときにのみ有効です。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


回転軸校正基準球の中心座標計測

ユーザーは回転軸を校正するのに使用する球を定義する必要があります。NC Gageは球の中心、直径、軸ベクトルおよび回転軸の位置に関するこの情報を必要とします。これらの値が分からない場合、ユーザーは回転軸校正基準球の中心座標計測画面で値を定義できます。

  1. この画面には回転軸の校正画面からアクセスします。回転軸の校正画面から、回転軸校正基準球の中心座標計測ソフトキー [image] を押して、回転軸校正基準球の中心座標計測画面を表示します：

  2. NC Gageは球の軸位置を知るのに役立つ情報を必要とします。この作業によりNC Gageは球を支持しているシャフトの方向を把握しますので、できるだけ正確に置いてください。

  3. パラメータエリアのアプローチ距離（測定する点の手前何ミリから測定を開始するか）と検索距離（測定開始点から何ミリ検索動作を行うか）に数値を入力します。

  4. 位置読取り ソフトキー [image] を押して、プローブの位置を読取ります。

  5. プローブ先端のルビー球を球中心の真上に置きます。

  6. 位置読取り ソフトキー [image] を押して、プローブの位置を読取ります。

軸が球の下にあるためステップ２～５で同じ点を使用できます。前のステップへ戻るソフトキー [image] を押すと、いつでも最後にティーチングされたプローブ位置を削除できます。

  7. 実行ソフトキー [image] を押します。NC Gageは頂点で４点検索パターンを使用して球のおおよその測定を行います。受入れ可能または拒絶可能な測定値が表示されます。必要に応じて値を受入れる前に手動で編集することもできます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


ミル旋盤の校正

ミル旋盤におけるリストヘッドの校正

「 任意のB軸角度において、リストヘッドの回転中心に対するプローブルビーの中心はどこか？」を決定するために、ミル旋盤でリストヘッドの校正をおこないます。

理想的な機械であれば、1つのB軸角度でプローブルビーの中心位置を校正すれば、すべてのB軸角度での位置が確定します。しかし、そのような機械は現実には存在しないため、複数の角度で測定して位置を確定する必要があります。どのような複数の角度で測定するかは、精度要件によって違ってきます。

ミル旋盤におけるリストヘッドの校正の概要

最初に校正球中心の正確な機械座標を求めます。従来の方法(ダイヤルゲージとゲージブロックを用いた方法)で求めることができます。またはNC Gageの「中心検索」機能を利用して求めることも可能です。

校正プロセスを以下で説明します。

計算されたリストヘッドの回転中心は校正球の中心となるはずです。各B軸角度に対して校正球中心からの偏差を計算します。

複数のルビー補正値を統合して解析し、未校正のB軸角度でのルビー補正値を評価し、NC Gage測定プログラムで使用することができるようにします。

  • 最初にすべてのルビー補正値を使用して、最適な平面を計算します。平面の法線ベクトルはB軸の回転ベクトルです。これは（0、1、0）に非常に近くなければなりません。

  • 次にすべてのルビー補正値を使用して、最適な円を計算します。この円の中心は最初に計算した平面上に計算されます。この円の中心は校正球の中心に非常に近くなくてはなりません。この時点で検出される誤差は、全て校正球中心の機械座標値の誤差によって生じます。

計算された最適な円と校正球の中心誤差は次の3つの要素に分解されます。

  • 誤差の最初の要素は、接線誤差または回転誤差です。これは、角度毎の校正球の予測位置と、校正球の計算された位置の誤差を表します。

  • 誤差の2番目の要素は、半径誤差です。これは、最適な円の半径と、円中心から校正球中心の距離間の差であり、最適な円に対する校正球の計算された位置の誤差を表わします。

  • 誤差の3番目の要素は、軸誤差です。これは、校正球の中心から最適な平面までの距離を表します。

NC Gageは誤差テーブルを作成してリストヘッドの校正結果として保存します。測定プログラムで要素が作成されるときに、NC GageはB軸角度に基づいて使用するルビーを構成します。要素フレームのB軸角度が校正に使用される場合、NC Gageは直接、校正テーブルから情報を抽出してルビー補正値を設定します。そのB軸の校正が十分な点を使用している場合はベクトル補正が使用されます。未校正のB軸角度の場合、ルビー補正値は必要に応じて最適な平面、最適な円の中心および誤差テーブルを使用して設定されます。ベクトル補償マップを回転して使用するかどうかが決定されます。

以下の表はミル旋盤の校正テーブルに保存される情報です。

B角度 | Xオフセット | Yオフセット | Zオフセット | 接線誤差 | 半径誤差 | 軸誤差 | 特定ベクトル補償マップ
0 | - | - | - | - | - | - | -
- | - | - | - | - | - | - | -
90 | - | - | - | - | - | - | -

X、YおよびZ中心はユーザーが指定した校正球中心の位置と計算で得られた最適な円の中心の間のデルタ値(差分)を表します。これによって、NC Gageはプローブの振れを処理し、正弦と余弦を使用して新しい位置を予測することができます。

NC Gageは、リストヘッドの校正を最初からやり直したり、「校正の更新」で誤差テーブルの一部を更新することもできます。

追記

リストヘッドの校正

リスト校正角度の設定

リストヘッドの校正レポート

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


リストヘッドの校正

  1. メイン画面でプローブソフトキー [image] を押します。

  2. リストヘッドの校正ソフトキー [image] を押してリストヘッドの校正画面を表示します：

  3. 画面の指示に従って確認ソフトキー [image] をクリックして手順を完了します。または、戻るソフトキー [image] を押して保存せずに前の画面に戻ります。

  4. リストヘッドを正常に校正した直後に校正レポートの表示ソフトキー [image] を押すと校正レポート画面が表示されます。

パラメータエリア

このエリアではパラメータを定義します。

  • 送り速度 - 校正中にプローブが移動する速度をmm/min (インチ単位の場合はinch/min) の単位で設定します。

  • アプローチ距離 - 理論的な取込み点から、プローブが取込み点を取得する前に移動する位置までの距離を指定します。これはプローブの校正中に使用され、mmまたはインチで定義されます。

  • 安全な回転高さ(ピボット) - プローブがヘッドの位置調整中に移動するZ軸高さです。この値は安全な平面上の機械座標でのピボット点の中心高さです。すべてのリスト回転の前に、リストのピボット点が指定された高さに安全に移動するようにプローブはZ軸沿いに真っ直ぐ上昇します。

安全な回転高さ値を適切に設定してルビーが回転軸やワークに衝突しないようにすることが非常に重要です。設定しない場合は0（ゼロ）が適用されますので、十分注意してください。

この値について詳しくは、「安全高さの使用」を参照してください。

角度定義エリア

すべての角度位置 - これらの値は別のフォームで設定されます。これにはリスト校正角度の設定ソフトキー [image] をクリックしてアクセスできます。

リストの軸位置およびその他パラメータは、設定ファイルに引き継がれ、次回校正画面を開いたときにすべての値が復元されます。

下記は副次的な角度に関するものです：

1球当たりの点数 - この値は各球を測定するのに使用される点数を定義します。

リストヘッドの校正エリア

設計値欄の値は、中心位置を定義します。これらの値はリストヘッドの校正画面に入る前に、NC Gage設定ツールの軸設定タブで設定した値です。

実測値欄の値は、中心位置を定義します。これらは校正のプロセスにより決定されます。ユーザーが校正の結果を受入れると、測定値がNC Gageの設定に書き込まれ、次回校正時の新しい設計値になります。これらの値はNC Gage設定ツールの軸設定タブに表示されます。

設計値 - 最初の校正時には、テーブルの向きとして設定した理論値が表示されます。2回目以降の回転軸の校正時には、前回の結果が表示されます。

実測値 - 最新の校正結果から計算したテーブルの向きを表示します。

  • 軸ID - システムで定義した回転軸の設定に従って、A、B、またはC軸を識別する文字です。

  • 長さの平均 - 較正処理中に決定される工具先端の平均長さ。

  • 回転軸I、J、K - ベクトルI、JおよびK値。これらの値はリストの回転軸の方向を定義します。これらの値はNC Gage設定ツールの軸設定タブと一致するように初期設定されています。

プローブエリア

設計値 - 軸が最初に校正されるときの直径の理論値を表示します。

実測値 -最後の校正でのプローブの直径を表示します。

直径 - プローブルビーの直径。

工具番号 - プローブ作成時に定義されたプローブの工具番号。

名前 - 使用されている現在のプローブ名。

情報エリア

このエリアは現在または以前の校正の時刻/日付スタンプなど、校正プロセスに関する情報を提供します。

基準ボールの定義エリア

回転軸の校正で使用する校正球の位置情報、球径、および球を支持しているシャフトの方向を設定します。ユーザーはこれらの値を入力するか、校正球定義ボタンを押してそれらをティーチングすることができます。校正球の定義プロセスの説明は本文書で後述します。球定義ボタンを押すと、球を定義するように指示されます。球定義画面を終了すると、ティーチングされた値が球校正画面に表示されます。

  • 中心X、Y、Z - 校正球中心のX、Y、Zの機械座標値。これは軸が0(ゼロ)にあるときの位置です。

  • 直径 - 校正球の直径値を入力します。

  • I、J、K、C - 球測定のための校正球軸および回転軸中心位置のIJKベクトルの方向。軸から校正球の中心へ向いたベクトルを指します。

ワークオフセットエリア

認定されたリストヘッドがあるワークオフセットを指定します。機械を選択して機械座標に対して移動します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


安全高さの使用

リストヘッドの校正画面の安全な回転高さ（ピボット）はリスト（ミル主軸）が回転する際に安全に回転できる位置情報を与える必要があり、安全な位置におけるリスト（ミル主軸）の回転中心座標（機械座標値のZ）を与えます。

球を測定する前にリストが1つの角度から次の角度に回転するときに衝突を回避するために、安全高さが定義されています。NC Gageは最初にピボットの中心をこのラインまで駆動します。NC Gageは球を測定する前にリストを回転させます。

定義された安全高さの方向は垂直な回転軸に沿っています。(ピボットでの)安全な回転高さはピボットがそのラインでジョグされるときの方向におけるピボット位置です。それはピボット位置でありルビー位置ではないため、リスト角度には関連しません。

以下の図表では、黄色線がデモ用機械の安全高さです。高さはX軸に沿った高さです(垂直な軸)：

安全高さの設定

安全高さの設定

リストヘッドの校正画面の安全高さを設定ソフトキーは安全な回転高さを設定するのに便利です。

  1. リスト（ミル主軸）の角度を気にせずに、プローブ先端のルビー球を測定する球の安全高さの方向に置きます：

安全高さの方向

  2. 安全高さを設定ソフトキーを押します。NC Gageは(ピボットでの)安全な回転高さを計算し、安全な回転高さ(ピボット) 欄へ設定します。

リストヘッドの校正の開始位置

安全高さの安全な開始位置にのみ注意し、軸の垂線方向における安全高さを考慮します。YZ平面の安全な位置にプローブを動かし、リストの回転に必要なスペースを確保し、衝突を回避しなければなりません。また、ルビーの開始位置は安全高さの-X軸方向における球中心より高い必要があります。

リスト角度

リストヘッドの校正で使用するリスト角度の設定は慎重に行って下さい。また、測定プログラムを初めて実行する時は動きに十分注意して下さい。

軸近くのリスト角度と安全高さ方向における球中心下方の中心にピボットがある角度位置に注意を払う必要があります。測定プログラムを最初に実行するときは、これらの位置を慎重に確認してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


リスト校正角度の設定

リストヘッドの校正画面のリスト校正角度の設定ソフトキー [image] を押すと次の画面が表示されます：

  1. 校正位置エリアのリストに、リストヘッドの校正で測定する角度が表示されます。

  2. 校正仕様エリアの開始角度に、開始角度を入力します。

  3. 校正仕様エリアの終了角度に、終了角度を入力します。

  4. 校正仕様エリアの校正角度の数に、校正処理を行う回数を入力します。

  5. 開始角度、終了角度、校正角度の数を入力後、位置リストの生成ソフトキー [image] を押すと、指定した値に基づいた角度が校正位置リストに自動的に入力されます。

  6. 追加角度エリアの角度ボックスに別の角度を入力します。次に、位置リストに1つの角度を追加ソフトキー [image] を押して校正位置リストに別の角度を追加します。

  7. 現在のリストを消去してやり直すには、位置リストをクリアソフトキー [image] を押します。

  8. 位置が生成されたら、確認ソフトキー [image] をクリックして、校正位置のリストを受け入れます。

校正位置エリア

現在定義されているすべての校正位置をリストアップします。

完全に補正された角度エリア

角度 - この角度は完全な校正が必要なときの開始角度として使用されます。これはベクトル補正マップを作成します。

校正仕様エリア

開始角度 - プローブヘッドが校正処理をしている間に回転を開始する初期角度(通常はプローブ回転の最低角度)です。

終了角度 - プローブヘッドが校正処理中に、その回転を完了する最終角度（通常はプローブ回転の最大角度）です。

校正角度の数 - プローブヘッドが校正プロセス中に回転する合計角度数（開始角度と終了角度を含む）。この値によって、上記ステップに記載されるとおりに入力された開始角度と終了角度の値に基づいて実際の角度位置が決定されます。

追加角度エリア

角度 - 校正位置リストに手動で角度を追加します。角度を入力後、角度をリストに追加ソフトキー [image] を押すと校正位置リストに入力した角度が追加されます。

緑色のチェックマークを押すと、制御がリストヘッドの校正画面に戻り、角度の定義が親フォームに戻ります。戻るソフトキーを押した場合、変更は中止され更新されません。

B軸位置およびその他のすべてのパラメータ設定はルビーファイルに引き継がれ、次回、校正画面に入るとすべての値が復元されます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


リストヘッドの校正レポート

リストヘッドの校正後、リストヘッドの校正画面から校正レポートの表示ソフトキー [image] を押して校正レポートを表示します。

リストヘッド校正レポートファイルには下記の2つの主要部分があります：

  • 1つは主角度のみを保存しベクトル補正表のみから成るベクトル情報です。

  • 2つ目はリスト校正情報から成ります。(主ルビーなどの)各位置は(回転中心からの)ルビー補正値とクロッキング、半径方向よび接線方向誤差を保存します。ファイルは以下のとおりに再書き込みされます：

    • 主角度を校正し、その他の角度をスキップする場合、ベクトル補正のみがファイルに書き込まれます。リスト校正情報は変更されません。

    • 主角度を校正がせず（完全な適用範囲で）、他の角度を校正する場合、ベクトル補償テーブルは変更されませんが、リスト校正情報はファイルで更新されます。

    • 主角度とその他の角度の両方を校正する場合、ファイル全体が上書きされます。

レポート詳細

以下は、記載されるとおりに軸に対して設定および校正された軸に関する上記レポートに基づいたものです。軸の構成が異なる場合は注意して下さい。

  • リストヘッドの回転中心は回転中心X、Y、Z、設計値からのシフト量Xシフト、Zシフト及び回転軸の値によって定義されます。

  • YZ平面における接線方向の偏差（角度）の単位は度です。他のすべての単位はNC Gageが設定されている距離の単位です（上記の場合はmm）。

  • 平均長さは偏差表にある長さの平均値です。

  • 偏差表の長さは回転中心からゲージラインまでの距離です。

  • XYZオフセットは各々設計値からの距離を示しています。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


ワークオフセット

元の状態 > NC Gageの使用 > はじめに > ステップ 6：ワークオフセットの選択

ステップ 6：ワークオフセットの選択

ワークオフセットはワーク座標系を作成するコマンドです。ワークの基準となる点をワーク座標系原点（X,Y,Z = 0,0,0）にします。

測定プログラムで使用する定義済のワークオフセットを選択したり、任意の要素の測定結果からワークオフセットを定義(または設定)することも可能です。

  • ワークオフセットの選択

  • ワークオフセットの設定

またワークオフセットのアップデート画面を使用して、測定プログラムの最後にワークオフセットを自動的に更新することも可能です。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


ワークオフセットの設定

ワークオフセットを設定すると、選択した要素を測定してコントローラでのワークオフセットをアップデートできます。

  1. メイン画面でワークオフセットを設定ソフトキー [image] を押します。画面下部のソフトキーが変化し、ワークオフセットを設定するために測定できる各種の要素を表示します：

  2. 下記から測定する要素を選択してください：

  • 座標設定（点）

  • 座標設定 （内径中心）

  • 座標設定 （外径中心）

  • 座標設定 （内側交点）

  • 座標設定 （外側交点）

  • 座標設定 （球中心）

  • 座標設定 （溝中心、突起中心、段差）

  • 回転軸角度の座標設定 （線）

  • 回転軸角度の座標設定 （溝）

  • 回転軸角度の座標設定 （平面）

  • 回転軸角度の座標設定 （円筒平面）

  • 回転軸角度の座標設定 （突起）

  3. 各設定画面が表示されます。

ワークオフセットのアップデート画面を使用してワークオフセットを更新することもできます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


座標設定（点）

座標設定 （点）ソフトキーはワーク上の点を測定し、その座標を使用して指定されたワークオフセットをアップデートします。

  1. メイン画面でワークオフセットの設定ソフトキー [image] を押します。画面下部にあるソフトキーが変化し、ワークオフセットを設定するために測定できる各種の要素を表示します。

  2. 座標設定 （点）ソフトキー [image] を押して座標設定 （点）画面を表示します：

  3. 画面の指示に従い確認ソフトキー [image] を押して手順を完了します。または、戻るソフトキー [image] を押して保存せずに前の画面に戻ります。

ワークオフセットエリア

  • ワークオフセット – 更新されるワークオフセットを指定します。

パラメータエリア

  • 実測値 - ワークオフセットの位置を指定します。値は点のティーチングの結果によって、機械座標で表示されます。軸は画面の左下隅で選択した方向によって異なります。

  • ターゲット - ワークオフセットは測定された点からこの距離だけ離れるように補正されます。

パラメータエリア

  • 検索距離 - ティーチングモードのときにプローブが面を検索している間に移動する距離を指定します。例えば、プローブが穴の中心にある場合、設定画面で設定された計測速度で各方向に検索距離まで移動して要素の位置を検索してティーチングします。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

更新プロセス

  1. 点の上にプローブを置きます。

  2. 位置読取り ソフトキー [image] を押します。ルビーの位置が内径の中心と面からの距離として読込まれます。前のステップに戻るソフトキー [image] を押すとこの位置がキャンセルされ、新しい位置が読込まれます。

  3. 実行ソフトキー [image] を押すと、NC Gageは自動的に作業面の法線と反対方向に沿って点を計測します。プローブはプローブ半径にアプローチ距離の3倍を加えた距離を検索します。

  4. 計測が完了すると測定値が更新されます。目的のワークオフセットが強調表示されるまで更新するワークオフセットを選択 ソフトキー [image] を押して、リストからワークオフセットの名前を選択します。強調表示された各ワークオフセットのパラメータを選択するとそれが画面上でアップデートされます。

  5. 確認ソフトキー [image] を押してワークオフセットの値を保存し、この軸をアップデートします。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

NC Gage

  • 表面の上のプローブ位置を読込みます。

  • プローブ半径+3*アプローチ距離の検索距離で面を測定します。

  • 読込み位置に戻ります。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


座標設定 （内径中心）

座標設定 （内径中心）ソフトキーはワーク上の円の内径(内部の円要素)を測定し、その中心座標を使用して指定されたワークオフセットをアップデートします。

  1. メイン画面の2ページ目でワークオフセットの設定ソフトキー [image] を押します。画面下部にあるソフトキーが変化し、ワークオフセットを設定するために測定できる各種の要素を表示します。

  2. 座標設定 （内径中心） ソフトキー [image] を押して座標設定 （内径中心）画面を表示します：

  3. 画面上の指示に従って円を測定し、更新しようとするワークオフセットを選択し確認ソフトキー [image] を押してワークオフセットを更新します。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

プローブ定義エリア

現在読込まれているプローブに関する情報を表示します。

ルビー補正値エリア

  • ルビー補正値X、Y、Z - ゲージ線に対するプローブルビーの位置

ワークオフセットエリア

  • ワークオフセット – 更新されるワークオフセットを指定します。

パラメータエリア

  • 実測値- ワークオフセットの位置を指定します。値は円(内径)のティーチングプロセスによってティーチングされ、機械座標で表示されます。

  • ターゲット - ワークオフセットは測定される要素からこの距離だけ離れるように補正されます。

パラメータエリア

  • アプローチ距離 - プローブが表面の検索を開始する位置を指定します。これは、プローブが設定画面で設定した計測速度で移動するときの設計上の面からの距離です。

  • 検索距離 - ティーチングモードのときにプローブが面を検索している間に移動する距離を指定します。例えば、プローブが穴の中心にある場合、設定画面で設定された計測速度で各方向に検索距離まで移動して要素の位置を検索してティーチングします。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

更新プロセス

1点ティーチング(小径円用)

ヘッドにリスト軸がある機械では、ティーチングプロセスは機械軸のプローブ方向に沿ってのみサポートされます。

  1. 内径の中心にプローブを置きます。

  2. 位置読取り ソフトキー [image] を押します。ルビーの位置が内径の中心と面からの距離として読込まれます。前のステップに戻るソフトキー [image] を押すとこの位置がキャンセルされ、新しい位置が読込まれます。

  3. 実行ソフトキー [image] を押すとNC Gageはプローブを動かして、4つの取込み点を自動的に取得して円 (内側) を検索します。NC Gageはこれらを使用して円の中心を決定します。

    プローブを動かす手動開始位置(A)とNC Gageが4点（位置1－4）を測定するときに通る自動計測経路(赤線)を示す画像

  4. 計測が完了すると、測定値が円の中心で更新されます。目的のワークオフセットが強調表示されるまで更新するワークオフセットを選択ソフトキー [image] を押して、リストからワークオフセット名を選択します。強調表示された各ワークオフセットのパラメータを選択するとそれが画面上でアップデートされます。

  5. 確認ソフトキー [image] を押して選択したワークオフセットを更新します。作業面の法線に平行でない軸のワークオフセット値が更新されます。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

2点ティーチング(大径円用)

  1. 内径の中心にプローブを置きます。

  2. 位置読取り ソフトキー [image] を押します。ルビーの位置が内径の中心と面からの距離として読込まれます。前のステップに戻る ソフトキー [image] を押すとこの位置がキャンセルされ、新しい位置が読込まれます。

  3. 実行ソフトキー [image] を押すとNC Gageはプローブを動かして、3つの取込み点を自動的に取得して円(内径)を検索します。NC Gageはこれらを使用して円の中心を決定します。

プローブを動かす手動開始位置(A)とNC Gageが3点(位置1－3)を測定するときに通る自動計測経路(赤線)を示す画像

  4. 計測が完了すると、測定値が円の中心で更新されます。目的のワークオフセットが強調表示されるまで更新するワークオフセットを選択ソフトキー [image] を押して、リストからワークオフセット名を選択します。強調表示された各ワークオフセットのパラメータを選択するとそれが画面上でアップデートされます。

  5. 確認 ソフトキー [image] を押して選択したワークオフセットを更新します。作業面の法線に平行でない軸のワークオフセット値が更新されます。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

NC Gage

1点ティーチング(小径円用)

  • 内径の中心でプローブの位置を読込みます。

  • 読込んだZ座標で、内径の測定をおこないます。

  • 読込んだXY座標を、内径の中央位置であると想定します。

  • 検索距離を使用して+ X 方向へ点を測定します。

  • 中央位置に戻ります。

  • 検索距離を使用して－X 方向へ点を測定します。

  • 中央位置に戻ります。

  • 検索距離を使用して+Y 方向へ点を測定します。

  • 中央位置に戻ります。

  • 検索距離を使用して－Y 方向へ点を測定します。

  • 中央位置に戻ります。

2点ティーチング(大径円用)

  • 内径の中心でプローブの位置を読込みます。

  • 内径の外周付でプローブの位置を読込みます。

  • 読込んだZ座標で、内径の測定をおこないます。

  • 検索距離を使用して、中心から外周方向へ点を測定します。

  • 外周位置に戻ります。

  • 検索距離を使用して、中心から外周方向に垂直な向きへ点を測定します。

  • 外周位置に戻ります。

  • 検索距離を使用して、中心から外周方向に垂直な別の向きへ点を測定します。

  • 外周位置に戻ります。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


座標設定 （外径中心）

座標設定 （外径中心）ソフトキーはワーク上の円の外径(外部円要素)を測定し、その中心座標を使用して指定されたワークオフセットをアップデートします。

  1. メイン画面の2ページ目でワークオフセットの設定ソフトキー [image] を押します。画面下部にあるソフトキーが変化し、ワークオフセットを設定するために測定できる各種の要素を表示します。

  2. 座標設定 （外径中心） ソフトキー [image] を押して座標設定 （外径中心）画面を表示します：

  3. 画面上の指示に従って円を測定し、更新しようとするワークオフセットを選択し確認ソフトキー [image] を押してワークオフセットを更新します。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

プローブ定義エリア

現在読込まれているプローブに関する情報を表示します。

ルビー補正値エリア

  • ルビー補正値X、Y、Z - ゲージ線に対するプローブルビーの位置

ワークオフセットエリア

  • ワークオフセット – 更新されるワークオフセットを指定します。

パラメータエリア

  • 実測値- ワークオフセットの位置を指定します。値は円（外径）のティーチングプロセスからティーチングされ、機械座標で表示されｒます。

  • ターゲット - ワークオフセットは測定される要素からこの距離だけ離れるように補正されます。

パラメータエリア

  • アプローチ距離 - プローブが表面の検索を開始する位置を指定します。これは、プローブが設定画面で設定した計測速度で移動するときの設計上の面からの距離です。

  • 検索距離 - ティーチングモードのときにプローブが面を検索している間に移動する距離を指定します。例えば、プローブが穴の中心にある場合、設定画面で設定された計測速度で各方向に検索距離まで移動して要素の位置を検索してティーチングします。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

画面上の指示に従って円を測定し、更新するワークオフセットを選択し、 OK を押してワークオフセットを更新します。

更新プロセス

ヘッドにリスト軸がある機械では、ティーチングプロセスは機械軸のプローブ方向に沿ってのみサポートされます。

  1. プローブを以下A位置に示すようにボスの辺の隣に置きます。位置読取り [image] ソフトキーを押します。表面からの距離は測定中に同じです。

  2. 下図の位置Ｂに示すように、プローブをボスの中心の上に置きます。位置読取り [image] ソフトキーを押します。この位置はボス中心の定義された測定点から測定点までを安全に移動できるボスからの距離に使用されます。前のステップに戻るソフトキー [image] を押すとこの測定位置がキャンセルされます。

  3. 実行ソフトキー [image] を押します。NC Gageはこの位置の下方で取込み点を一つ取得し、外径の高さを決定します。次に、以下に示すのと同様な方法で取込み点を自動的に取得します。

    プローブを動かす手動位置(A-B)とNC Gageが4点（位置1－4）を測定するときに通る自動計測経路(赤線)を示す画像

  4. 計測が完了すると、測定値が円の中心で更新されます。目的のワークオフセットが強調表示されるまで更新するワークオフセットを選択 ソフトキー [image] を押して、リストからワークオフセットの名前を選択します。強調表示された各ワークオフセットのパラメータを選択するとそれが画面上でアップデートされます。

  5. 確認ソフトキー [image] を押して、作業面の法線の軸に対するワークオフセットを更新します。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

NC Gage

  • 外径の辺の隣でプローブの位置を読込みます。Z値は測定高さです。

  • 外径の中心の上方でプローブの位置を読込みます。XY値は中心を定義し、Z値は安全高さです。

  • アプローチ距離= 2つの読込み位置の間の投影された2次元距離です。

  • 安全高さに移動します。

  • 安全高さでアプローチ距離1(+Xにおける中心からのアプローチ距離)の上方の点に移動します。

  • 測定高さまで下降します。

  • 点を測定します。ターゲットは測定高さでの中心です。

  • 安全高さに移動します。

  • 安全高さでアプローチ距離2(-Xにおける中心からのアプローチ距離)の上方の点に移動します。

  • 測定高さまで下降します。

  • 点を測定します。ターゲットは測定高さでの中心です。

  • 安全高さに移動します。

  • 安全高さでアプローチ距離3(+Yにおける中心からのアプローチ距離)の上方の点に移動します。

  • 測定高さまで下降します。

  • 点を測定します。ターゲットは測定高さでの中心です。

  • 安全高さに移動します。

  • 安全高さでアプローチ距離4(-Yにおける中心からのアプローチ距離)の上方の点に移動します。

  • 測定高さまで下降します。

  • 点を測定します。ターゲットは測定高さでの中心です。

  • 安全高さに移動します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


座標設定 （内側交点）

座標設定 （内側交点）ソフトキーはワークの内側コーナーを測定し、そのコーナー座標を使用して指定されたワークオフセットをアップデートします。

  1. メイン画面の2ページ目でワークオフセットの設定ソフトキー [image] を押します。画面下部にあるソフトキーが変化し、ワークオフセットを設定するために測定できる各種の要素を表示します。

  2. 座標設定 （内側交点）ソフトキー [image] を押して座標設定 （内側交点）画面を表示します：

プローブ定義エリア

測定プログラムで使用される現在選択されているプローブの情報を表示します。

ワークオフセットエリア

  • ワークオフセット – 更新されるワークオフセットを指定します。

パラメータエリア

  • XYZ測定値/ターゲット値 - ワークオフセットの測定されたXYZ位置およびターゲットXYZ位置を指定します。測定値はコーナー（内部）のティーチングプロセスからティーチングされます。

パラメータエリア

  • アプローチ距離 - プローブが表面の検索を開始する位置を指定します。これは、プローブが設定画面で設定した計測速度で移動するときの設計上の面からの距離です。

  • 検索距離 - ティーチングモードのときにプローブが面を検索している間に移動する距離を指定します。例えば、プローブが穴の中心にある場合、設定画面で設定された計測速度で各方向に検索距離まで移動して要素の位置を検索してティーチングします。

安全高さエリア

  • 安全高さの設定 - 実行時にプローブが各取込み点の間を安全高さまで移動します。平面までの距離を右側のボックスに入力します。この平面は測定プログラムの安全高さではありません。詳細は安全高さの設定を参照してください。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

画面上の指示に従って内側コーナーを測定し、更新するワークオフセットを選択して確認ソフトキー [image] を押し選択したワークオフセットをアップデートします。

更新プロセス

  1. 下図の位置Aに示すようにコーナーから成る表面の隣にプローブを置きます。

  2. 位置読取り ソフトキー [image] を押します。

  3. 下図の位置Bに示すように同じ面の最初の点の隣にプローブを置きます。

  4. 位置読取り ソフトキー [image] を押します。

  5. 下図の位置Cに示すようにコーナーから成る2番目の表面の隣にプローブを置きます。

  6. 位置読取り ソフトキー [image] を押します。

  7. 下図の位置Dに示すようにこの2番目の表面の最初の点の隣にプローブを置きます。

  8. 位置読取り ソフトキー [image] を押します。

  9. 実行ソフトキー [image] を押すと、NC Gageは下図のような方法で自動的に取込み点を取得します。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

左側の画像はプローブを動かす手動ジョグ位置(A-D)を示しています。右側の画像は4点(位置1－4)を測定するときに、NC Gageが取る自動計測パス(赤線)を示しています。

  10. 計測が完了すると測定値がコーナーの位置で更新されます。目的のワークオフセットが強調表示されるまで更新するワークオフセットを選択 ソフトキー [image] を押して、リストからワークオフセットの名前を選択します。強調表示された各ワークオフセットのパラメータを選択すると画面上でアップデートされます。

  11. 確認ソフトキー [image] を押してワークオフセットをアップデートします。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

NC Gage

  • リスト機械を動作させる場合は機械軸に沿ってプローブを回転させます。

  • コーナーの最初の辺の最初の点に隣接するプローブの位置を読込みます。全ての測定がこの点と同じラインで取得されます。

リスト機械では、最初に機械の軸に沿ってプローブを回転させる必要があります。コーナー要素を測定するとワークオフセットの他の2軸がアップデートされます：

      • プローブが機械のZ軸に沿っている場合は、最初の読込み点がパラメータXおよびY軸エリアをアップデートします。

      • プローブが機械のX軸に沿っている場合は、最初の読込み点がパラメータYおよびZ軸エリアをアップデートします。

      • プローブが機械のY軸に沿っている場合は、最初の読込み点がパラメータXおよびZ軸エリアをアップデートします。

  • プローブをコーナーの最初の辺の2番目の点の隣に置きます。

  • コーナーの2番目の辺の最初の点の隣でプローブの位置を読込みます。

  • コーナーの2番目の辺の2番目の点の隣のプローブの位置を読込みます。

  • 最初および2番目の方向ベクトルおよび法線ベクトルを定義します。

  • 補正ポイント。

  • おおよそのコーナー点を決めます。

  • プローブを最初の読込み点に置きます。

  • 最初の辺の表面に向かって測定します。検索距離は4*アプローチ距離です。

  • それぞれにプロッブを二番目の赤いポイントに配置します。

  • 最初の辺の表面に向かって測定します。検索距離は4*アプローチ距離です。

  • プローブをおおよそ3番目の読込み点に置きます。

  • 2番目の辺の表面に向かって測定します。検索距離は4*アプローチ距離です。

  • プローブをおおよそ4番目の読込み点に置きます。

  • 2番目の辺の表面に向かって測定します。検索距離は4*アプローチ距離です。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


座標設定 （外側交点）

座標設定 （外側交点）ソフトキーはワークの外側コーナーを測定し、そのコーナー座標を使用して指定されたワークオフセットをアップデートします。

  1. メイン画面の2ページ目でワークオフセットの設定ソフトキー [image] を押します。画面下部にあるソフトキーが変化して、ワークオフセットを設定するために測定できる各種の要素を表示します。

  2. 座標設定 （外側交点）ソフトキー [image] を押して座標設定 （外側交点）画面を表示します：

プローブ定義エリア

測定プログラムで使用される現在選択されているプローブの情報を表示します。

ワークオフセットエリア

  • ワークオフセット – 更新されるワークオフセットを指定します。

パラメータエリア

  • XYZ測定値/ターゲット値 - ワークオフセットの測定されたXYZ位置およびターゲットXYZ位置を指定します。測定値はコーナー(外側)のティーチングプロセスからティーチングされます。

パラメータエリア

  • アプローチ距離 - プローブが表面の検索を開始する位置を指定します。これは、プローブが設定画面で設定した計測速度で移動するときの設計上の面からの距離です。

  • 検索距離 - ティーチングモードのときにプローブが面を検索している間に移動する距離を指定します。例えば、プローブが穴の中心にある場合、設定画面で設定された計測速度で各方向に検索距離まで移動して要素の位置を検索してティーチングします。

安全高さエリア

  • 安全高さの設定 - 実行時にプローブが各取込み点の間を安全高さまで移動します。平面までの距離を右側のボックスに入力します。この平面は測定プログラムの安全高さではありません。詳細は安全高さの設定を参照してください。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

画面上の指示に従って外側コーナーを測定し、更新するワークオフセットを選択して確認ソフトキー [image] を押し選択したワークオフセットをアップデートします。

更新プロセス

  1. 下図の位置Aに示すようにコーナーから成る表面の隣にプローブを置きます。

  2. 位置読取り ソフトキー [image] を押します。

  3. 下図の位置Bに示すように同じ面の最初の点の隣にプローブを置きます。

  4. 位置読取り ソフトキー [image] を押します。

  5. 下図の位置Cに示すようにコーナーから成る2番目の表面の隣にプローブを置きます。

  6. 位置読取り ソフトキー [image] を押します。

  7. 下図の位置Dに示すようにこの2番目の表面の最初の点の隣にプローブを置きます。

  8. 位置読取り ソフトキー [image] を押します。

  9. 実行ソフトキー [image] を押すと、NC Gage は下図のような方法で自動的に取込み点を取得します。

左側の画像はプローブを動かす手動ジョグ位置(A-D)を示しています。右側の画像は4点(位置1－4)を測定するときに、NC Gageが取る自動計測パス(赤線)を示しています。

  10. 計測が完了すると測定値がコーナーの位置で更新されます。目的のワークオフセットが強調表示されるまで更新するワークオフセットを選択ソフトキー [image] を押して、リストからワークオフセット名を選択します。強調表示された各ワークオフセットのパラメータを選択すると画面上でアップデートされます。

  11. 確認ソフトキー [image] を押して ワークオフセットをアップデートします。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

NC Gage

  • リスト機械を動作させる場合は機械軸に沿ってプローブを回転させます。

  • コーナーの最初の辺の最初の点に隣接するプローブの位置を読込みます。全ての測定がこの点と同じラインで取得されます。

リスト機械では、最初に機械の軸に沿ってプローブを回転させる必要があります。コーナー要素を測定するとワークオフセットの他の2軸がアップデートされます：

      • プローブが機械のZ軸に沿っている場合は、最初の読込み点がパラメータXおよびY軸エリアをアップデートします。

      • プローブが機械のX軸に沿っている場合は、最初の読込み点がパラメータYおよびZ軸エリアをアップデートします。

      • プローブが機械のY軸に沿っている場合は、最初の読込み点がパラメータXおよびZ軸エリアをアップデートします。

  • プローブをコーナーの最初の辺の2番目の点の隣に置きます。

  • コーナーの2番目の辺の最初の点の隣でプローブの位置を読込みます。

  • コーナーの2番目の辺の2番目の点の隣のプローブの位置を読込みます。

  • 最初および2番目の方向ベクトルおよび法線ベクトルを定義します。

  • 補正ポイント。

  • おおよそのコーナー点を決めます。

  • プローブの位置を確認します。プローブがコーナーから離れていない場合は、4つのティーチング点によって形成される2つの線の交点にプローブを移動します。この移動を2軸移動として行います。位置が測定高さの上方である場合、最初にXY方向に移動してからZ方向に移動します。位置が測定高さの下方である場合はZ方向に移動してからZY方向に移動します。

  • プローブを最初の読込み点に置きます。

  • 2番目の辺の表面に向かって測定します。深さは2番目の辺の最初の点と一致します。

  • それぞれにプロッブを二番目の赤いポイントに配置します。

  • 2番目の辺の表面に向かって測定します。深さは2番目の辺の最初の点と一致します。

  • コーナーを超えて点に移動して衝突を回避します。

  • プローブをおおよそ3番目の読込み点に置きます。

  • 2番目の辺の表面に向かって測定します。深さは最初の辺の最初の点と一致します。

  • プローブをおおよそ4番目の読込み点に置きます。

  • 2番目の辺の表面に向かって測定します。深さは最初の辺の最初の点と一致します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


座標設定 （球中心）

座標設定 （球中心）ソフトキーは球を測定し、測定された座標を使用して指定されたワークオフセットをアップデートします。

点数は球を測定するのに使用される点数を定義します。通常は0 (赤道)である下部角度は測定する最下面ラインを定義します。通常は90 (北極点)である上部角度は測定する最上面ラインを定義します。

  1. メイン画面の2ページ目にあるワークオフセットの設定ソフトキー [image] を押します。画面下部にあるソフトキーが変化して、ワークオフセットを設定するために測定できる各種の要素を表示します。

  2. 座標設定（球中心）ソフトキー [image] を押して座標設定（球中心）画面を表示します：

  3. 画面の指示に従い確認ソフトキー [image] を押して手順を完了します。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

ワークオフセットエリア

  • ワークオフセット – 更新されるワークオフセットを指定します。

パラメータエリア

  • パラメータ X、Y、Z - 球の中心を定義します。実測値欄はワークオフセットの測定値を指定します。ターゲット欄はワークオフセット座標で球の中心の理論値を定義します。理論値は任意の値を取ることができますが通常はゼロです。

ルビー補正値エリア

  • ルビー補正値X、Y、Z－ワークオフセットが測定された要素からプローブの校正の値だけ補正されます。

パラメータエリア

  • アプローチ距離 - プローブが表面の検索を開始する位置を指定します。これは、プローブが設定画面で設定した計測速度で移動するときの設計上の面からの距離です。

  • 検索距離 - ティーチングモードのときにプローブが面を検索している間に移動する距離を指定します。例えば、プローブが穴の中心にある場合、それは設定画面で設定された「検索速度」で各方向に検索距離まで移動して、要素の位置を検索/ティーチングします。

プロパティエリア

  • 点数 - 球を測定するのに使用される点数を定義します。

  • 測定終了角度 - 通常は0(赤道)です。測定する最下面レベルを定義します。

  • 上部角度- 通常は90(北極点)です。測定する最上面ラインを定義します。測定する最上面ラインを定義します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

画面上の指示に従ってアップデートするワークオフセットを選択し、確認ソフトキー [image] を押して選択したワークオフセットをアップデートします。

更新プロセス

  1. プローブを球中心上部の上方 (下図の位置 A)に置き、位置読取り ソフトキー [image] を押します。

  2. コマンドのティーチングと作成ソフトキー [image] を押します。

  3. システムモニタープログラムを実行します。NC Gageは下図のように自動的に取込み点を取得します。

球パス：A) ジョグ位置1-4) 自動的に測定される点の位置

  4. 要素が測定されると測定値がアップデートされます。目的のワークオフセットが強調表示されるまで更新するワークオフセットを選択ソフトキー [image] を押して、リストからワークオフセット名を選択します。強調表示された各ワークオフセットのパラメータを選択すると画面上でアップデートされます。

  5. 確認ソフトキー [image] を押して ワークオフセットをアップデートします。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

NC Gage

球要素のティーチング手順

球の位置と大きさは球の最上部の点を測定し、最上部近くでさらに3点をサンプリングして決定されます。これが球要素をティーチングする方法です。球の位置と大きさが決まるとティーチングされた大きさと位置を使用して球が再測定されます。パラメータおよびプロパティボックスで設定された値を使用して測定が実行されます。

  • プローブの位置を読込みます。この位置は球の最上部の上方でなければなりません。

  • 検索距離を使用して真下の点を測定します。

  • 元の読込み位置に後退して、+X方向に 2*プローブ半径だけ移動します。

  • 検索距離を使用して真下の点を測定します。

  • 読込み位置に後退して、+ X軸から120度の方向に2*プローブ半径だけ移動します。

  • 検索距離を使用して真下の点を測定します。

  • 読込み位置に後退して、+ X軸から240度の方向に 2*プローブ半径だけ移動します。

  • 検索距離を使用して真下の点を測定します。

  • 元の高さまで後退します。

球要素の測定手順

  • レベル数と各レベルの点数は入力に基づいて決定されます。

  • 現在の位置が安全高さより低い場合、安全高さまで上昇します。

  • 最初のアプローチ距離の上方の位置に移動します。

  • 最低面ラインまで下降してそのレベルを測定し、必要な場合は、1つのレベルにおいて点と点の間に回避的な移動を追加して衝突を回避します。

  • 交互の方向に残りのラインを測定します。

  • 球の最上部の点を測定します(上部角度が90の場合)。

  • 安全高さに移動します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


座標設定 （溝中心、突起中心、段差）

座標設定 （溝中心、突起中心、段差）ソフトキーはワークオフセットの1軸が2つの平行面間の中間値になるように設定します。

  1. メイン画面でワークオフセットを設定ソフトキー [image] を押します。画面下部にあるソフトキーが変化し、ワークオフセットを設定するために測定できる各種の要素を表示します。

  2. 座標設定 （溝中心、突起中心、段差）ソフトキー [image] を押して、座標設定 （溝中心、突起中心、段差）画面を表示します：

プローブ定義エリア

測定プログラムで使用される現在選択されているプローブの情報を表示します。

ワークオフセットエリア

  • ワークオフセット – 更新されるワークオフセットを指定します。

パラメータエリア

  • 実測値 - ワークオフセットの位置を指定します。値は点のティーチングの結果によって、機械座標で表示されます。軸は軸エリアで選択される方向によって違います。

この画面の左上エリアに位置する画面のアイコン画像は軸および形状エリアから行われた選択内容に基づいて更新されます。

  • ターゲット - ワークオフセットは測定される要素からこの距離だけ離れるように補正されます。

パラメータエリア

  • アプローチ距離 - プローブが表面の検索を開始する位置を指定します。これは、プローブが設定画面で設定した計測速度で移動するときの設計上の面からの距離です。

  • 検索距離 - ティーチングモードのときにプローブが面を検索している間に移動する距離を指定します。例えば、プローブが穴の中心にある場合、設定画面で設定された計測速度で各方向に検索距離まで移動して要素の位置を検索してティーチングします。

軸エリア

  • 中点を計算するために2つの表面が測定される方向を選択します。パラメータエリアが状況に応じて更新されます。

形状エリア

  • 中点を計算するのに使用される測定される要素の形状を選択します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

  1. 必要に応じて画面の軸エリアから特定の軸を選択します。使用可能な軸はX、YおよびZです。

  2. 必要に応じて画面の形状エリアから特定の形状を選択します。使用可能な形状は突起幅、溝幅および段差です。X または Y 軸を設定する場合、これら3形状をすべて使用できます。Zの場合、使用できるのは段差形状のみです。

この画面の左上エリアに位置する画面のアイコン画像は軸および形状エリアから行われた選択内容に基づいて更新されます。

  3. ターゲットの値を入力。

以下の手順で各形状/軸の組み合わせに関するティーチングプロセスを説明します：

 | X、YまたはZ軸
突起幅 | 突起幅の最初の面突起幅の反対側の面1面から他面に移動する安全な高さを定義します。
溝幅 | 溝幅の最初の面。溝幅の反対側の面。
段差 | 段の最初の面段の2番目の面2番目の面からさらに離します。

  4. 必要に応じてアプローチ距離と検索距離を設定します。これはいつでも設定できます。

  5. アップデートするワークオフセットを選択します。これはいつでも設定できます。

  6. 点をティーチングして測定を定義した後、実行ソフトキー [image] を押します。NC Gageはワークを測定します。中点の値が計算され画面に表示されます。

  7. 確認ソフトキー [image] をクリックすると結果が承認されて保存されます。キャンセルソフトキー [image] をクリックすると結果が拒否され保存されません。

形状の例

段差形状：

溝幅および突起幅形状：

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


回転軸角度の座標設定 （線）

回転軸角度の座標設定 （線） 画面を使用して、要素が回転軸に対して持っている角度を定義、表示します。

次の手順でこの画面を表示します：

  1. メイン画面の2ページ目でワークオフセットの設定ソフトキー [image] を押します。画面下部にあるソフトキーが変化し、ワークオフセットを設定するために測定できる各種の要素を表示します。

  2. 回転軸角度の座標設定 （線）ソフトキー [image] を押して回転軸角度の座標設定 （線）画面を表示します：

  3. 画面の指示に従い確認ソフトキー [image] を押して手順を完了します。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

ルビー補正値エリア

  • ルビー補正値X、Y、Z - ワークオフセットが測定された要素からプローブの校正の値だけ補正されます。

ワークオフセットエリア

  • ワークオフセット – 更新されるワークオフセットを指定します。

回転軸エリア

  • 軸ID - 軸を識別する文字：システムで定義した回転軸に従ってA、BまたはCから選択します。

測定エリア

  • 角度 - 回転軸の角度の実測値とターゲット値を表示します。

プロパティエリア

  • 点数 - 測定される点数を定義します。

パラメータエリア

  • アプローチ距離 - 測定中にプローブが表面を検索し始める設計上の表面からの距離を定義します。

  • 検索距離 - 検索距離はプローブがティーチングモードで面を検索する間に移動する距離です。例えば、プローブが穴の中心にある場合、それは設定画面で設定された計測速度で各方向に検索距離まで移動して、要素の位置を検索/ティーチングします。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

コンセプトは「回転軸の平面」にある線を測定して、ワークオフセットの回転軸成分をその線に基づいて設定できるようにすることです。その線の測定は平面での角度を決定し、回転軸の角度はアップデートされたワークオフセットがアクティブなときにターゲット角度に一致します。

線の測定には以下の2つの異なったシナリオがあります：

  • 第1のケースは回転軸平面の法線軸がスピンドル軸と平行な（または平行でない）場合です。

上の画像では、 C軸で30度の傾斜角を持つワークが軸に固定されています。ユーザーは回転軸Cのワークオフセットをアップデートして、新しいワークオフセットがアクティブであるときにワークの座標系Ｘ＋が線の方向と同じであるようにする必要があります。

最初にユーザーは回転軸Cを回転させて黄色い線の方向をワークオフセットのおおよそのゼロ位置（ X +） に揃える必要があります。このステップから、NC Gageは線から計算されたターゲット値が約30であるが、30+180= 210度ではないことを認識できます。

このアライメントの大まかな事前調整を除いて、ティーチング手順はNC Gageでの線の測定手順と同じです。

下記に示すとおり、前表面の黄色線の方向が測定されます。点1、2および3の位置をティーチングするように指示するプロンプトが表示されます。NC Gageはこれらの点がティーチングされた時点で、線を自動的に測定するための必要情報を取得しています。

上記の画像では、黒で表示されている線の方向が測定パスです。これは表示されている3つの位置にプローブを配置することによって実現されます。

  • 2番目のケースは回転軸平面の法線軸がスピンドル軸に対して垂直なときです。

上の画像では、 A軸で30度の角度を持つワークが軸に固定されています。ユーザーは回転軸のワークオフセットをアップデートして、新しいワークオフセットがアクティブなときに、ワークの座標系Y+が黄線の方向と同じであるようにする必要があります。

最初にユーザーは回転軸を回転して、黄色線の方向をワークオフセットのおおよそのゼロ位置 (Y+)に揃える必要があります。このステップからNC Gageは線から計算されるターゲット値がおよそ30であるが30+180=210度ではないことを認識できます。

このケースでは、アライメントの大まかな事前調整を除いて、線をティーチングするためのステップは1つ減ります。これは、最初のケースでは、ワークが最初の2点を使用して定義された線の「左」側または「右」側のどちらになるか分からず、面から「離れ」て第3番目の点をティーチングするようにユーザーが指示されるためです。

この2番目のケースが異なる理由は、プローブの方向と回転軸平面の方向に1つの可能性しか残されておらず、当社がユーザーに3番目の点をティーチングするように勧めないためです。

ここで、ユーザーは辺の上で回転軸を回転させて定義される平面にある黄色線の方向を測定しようとします(上の写真でのダウエルに類似しています)。

点1および2の位置をティーチングするように指示するプロンプトが表示されます。NC Gageはこれらの点がティーチングされた時点で、線を自動的に測定するための必要情報を取得しています。

上記の例では、黒で表示されている線の方向が測定パスです。これは表示されている二つの位置にプローブを配置することによって実現されます。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


回転軸角度の座標設定 （溝）

回転軸角度の座標設定（溝）画面を使用して、要素が回転軸に対して持っている角度を定義、表示します。

この画面に進むには：

  1. メイン画面の2ページ目でワークオフセットの設定ソフトキー [image] を押します。画面下部にあるソフトキーが変化し、ワークオフセットを設定するために測定できる各種の要素を表示します。

  2. 回転軸角度の座標設定 （溝）ソフトキー [image] を押して回転軸角度の座標設定 （溝）画面を表示します：

  3. 画面の指示に従い確認ソフトキー [image] を押して手順を完了します。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

ルビー補正値エリア

  • ルビー補正値X、Y、Z - ワークオフセットが測定された要素からプローブの校正の値だけ補正されます。

ワークオフセットエリア

  • ワークオフセット – 更新されるワークオフセットを指定します。

回転軸エリア

  • 軸ID - 軸を識別する文字：システムで定義した回転軸に従ってA、BまたはCから選択します。

測定エリア

  • 角度 - 回転軸の角度の実測値とターゲット値を表示します。

パラメータエリア

  • アプローチ角度 - プローブが測定速度で測定点に接近し始める設計上の平面からの角度を定義します。

  • 角度の範囲を検索 - 要素の検索およびティーチング時の検索角度の範囲を定義します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

「回転軸角度の測定（溝）」の「ティーチングプロセス」を参照してください。

実行プロセス

「回転軸角度の測定（溝）」の「実行プロセス」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


回転軸角度の座標設定 （平面）

回転軸角度の座標設定 （平面）画面では、回転軸上の平面の角度を測定し、ワークオフセットの2つの回転軸に設定します。

このオプションは2つの回転軸(トラニオンテーブル)をもつシステムで使用できます。平面を測定して両方の回転軸に対してワークオフセットを同時に設定します。NC Gageは平面がプローブに対して垂直になるような角度を計算します。

次の手順でこの画面を表示します：

  1. メイン画面の2ページ目でワークオフセットの設定ソフトキー [image] を押します。画面下部にあるソフトキーが変化して、ワークオフセットを設定するために測定できる各種の要素を表示します。

  2. 回転軸角度の座標設定 （平面）ソフトキー [image] を押して、回転軸角度の座標設定 （平面）画面を表示します：

ルビー補正値エリア

  • ルビー補正値X、Y、Z - ゲージ線に対するプローブルビーの位置

ワークオフセットエリア

  • ワークオフセット – 更新されるワークオフセットを指定します。

測定エリア

  • 角度 - 回転軸の角度の実測値とターゲット値を表示します。

測定方法エリア

  • 格子パターン - 平面を測定するときに格子形状による測定方法を定義します。

  • 円パターン - 平面を測定するときに円形状による測定方法を定義します。

プロパティエリア

  • 行数 - グリッドパターンの平面を定義するときに測定される行数を定義します。

  • 1ライン毎の点数 - グリッドパターンの平面を定義するときに測定される行ごとの点数を定義します。

  • 点数 - 円パターンの平面を定義するときに測定される点数を定義します。

パラメータエリア

  • アプローチ距離 - プローブが表面の検索を開始する位置を指定します。これは、プローブが設定画面で設定した計測速度で移動するときの設計上の面からの距離です。

  • 検索距離 - ティーチングモードのときにプローブが面を検索している間に移動する距離を指定します。例えば、プローブが穴の中心にある場合、それは設定画面で設定された「検索速度」で各方向に検索距離まで移動して、要素の位置を検索/ティーチングします。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

このオプションを使用するには、面がプローブとほぼ垂直であるようにユーザーが手動で回転軸を配置する必要があります。この操作によって、平面をティーチングおよび測定することが容易になります。

ティーチング手順は、平面の測定でのティーチング手順と同じでとなります。

  1. 格子パターンまたは円パターン測定法を選択します。格子パターンを選択すると、このページの上部にある画面に示すように、行数と1ライン毎の点数が表示されます。円パターンを選択すると、点数が表示されます。

  2. アプローチ距離と検索距離を設定します。

  3. 2点をティーチングして格子または円パターンの対角線を定義することによってパターンの位置を定義します。

  4. 2点を定義したら、実行ソフトキー [image] を押してモニタープログラムを起動します。NC Gageは平面を測定します。測定後、NC Gageはプローブに対して平面を垂直に向ける為に必要な回転軸角度を計算します。ユーザーは正しいワークオフセットが選択されていることを確認する必要があります(これはいつでも行うことができます)。

  5. 確認ソフトキー [image] を押して、この値を使用して選択されたワークオフセットを設定するか、キャンセルソフトキー [image] を押してプロセスを中止します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


回転軸角度の座標設定 （円筒平面）

回転軸角度の座標設定（円筒平面）画面を使用して、要素が回転軸に対して持っている角度を定義、表示します。

この画面に進むには：

  1. メイン画面の2ページ目でワークオフセットの設定ソフトキー [image] を押します。画面下部にあるソフトキーが変化し、ワークオフセットを設定するために測定できる各種の要素を表示します。

  2. 回転軸角度の座標設定（円筒平面）ソフトキー [image] を押して回転軸角度の座標設定（円筒平面）画面を表示します：

  3. 画面の指示に従い確認ソフトキー [image] を押して手順を完了します。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

ルビー補正値エリア

  • ルビー補正値X、Y、Z - ワークオフセットが測定された要素からプローブの校正の値だけ補正されます。

ワークオフセットエリア

  • ワークオフセット – 更新するワークオフセットを指定します。

回転軸エリア

  • 軸ID - 軸を識別する文字：システムで定義した回転軸に従ってA、BまたはCから選択します。

測定エリア

  • 角度 - 回転軸の角度の実測値とターゲット値を表示します。

パラメータエリア

  • アプローチ角度 - プローブが測定速度で測定点に接近し始める設計上の平面からの角度を定義します。

  • 角度の範囲を検索 - 要素の検索およびティーチング時の検索角度の範囲を定義します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

「回転軸角度の測定（平面）」での「ティーチングプロセス」を参照してください。

実行プロセス

「回転軸角度の測定（平面）」の「実行プロセス」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


回転軸角度の座標設定 （突起）

回転軸角度の座標設定(突起)画面を使用して、要素が回転軸に対して持っている角度を定義、表示します。

この画面に進むには：

  1. メイン画面の2ページ目でワークオフセットの設定ソフトキー [image] を押します。画面下部にあるソフトキーが変化し、ワークオフセットを設定するために測定できる各種の要素を表示します。

  2. 回転軸角度の座標設定 （突起） ソフトキー [image] を押して 回転軸角度の座標設定 （突起） 画面を表示します：

  3. 画面の指示に従い確認ソフトキー [image] を押して手順を完了します。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

ルビー補正値エリア

  • ルビー補正値X、Y、Z - ワークオフセットが測定された要素からプローブの校正の値だけ補正されます。

ワークオフセットエリア

  • ワークオフセット – 更新されるワークオフセットを指定します。

回転軸エリア

  • 軸ID - 軸を識別する文字：システムで定義した回転軸に従ってA、BまたはCから選択します。

測定エリア

  • 角度 - 回転軸の角度の実測値とターゲット値を表示します。

パラメータエリア

  • アプローチ角度 - プローブが測定速度で測定点に接近し始める設計上の平面からの角度を定義します。

  • 角度の範囲を検索 - 要素の検索およびティーチング時の検索角度の範囲を定義します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

  1. 突起を左方向に回転させ、プローブを突起右側に配置し、位置読取りソフトキー [image] を押します。

  2. 突起を右方向に回転させ、プローブを突起左側に配置し、コ位置読取りソフトキー [image] を押します。その後にプローブを突起の上方の安全な高さに移動します。

  3. 下記を参照してください。

    • プローブが突起の最上部まで移動します。

    • 回転軸がアプローチ角度まで回転します。

    • プローブが測定高さまで移動します。

    • プローブがワークと接触するまで回転軸が時計方向に回転します。回転軸が回転を停止します。回転軸がアプローチ角度まで後退します。

    • プローブが突起の最上部まで移動します。

    • 回転軸がアプローチ角度まで回転します。

    • プローブが測定高さまで移動します。

    • プローブがワークと接触するまで回転軸が反時計方向に回転します。回転軸が回転を停止します。回転軸がアプローチ角度まで後退します。

    • プローブが突起の最上部まで移動します。

    • 回転軸が元の位置まで回転して戻ります。

    • 突起の中央角度を、検出した2つの回転軸の位置によって計算します。

実行プロセス

「回転軸角度の測定（突起）」の「実行プロセス」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


ワークオフセットのアップデート

  1. メイン画面で測定ソフトキー [image] を押します。

  2. ワークオフセットのアップデートソフトキーが表示されるまで前へソフトキーを押します。

  3. ワークオフセットのアップデートソフトキー [image] を押して、ワークオフセットのアップデート画面を表示します：

要素エリア

  • X, Y, Z, AまたはB, Ｃ軸 - この要素選択軸リストはワークオフセットを定義するのに使用できる測定プログラムでの要素を表示します。表示される要素の選択軸リストはNC Gage設定ツールを使用してシステムを定義した方法によって異なります。

ワークオフセットエリア

更新するように選択されるワークオフセットを指定します。ワークオフセットを選択ソフトキー [image] を使用して一度に1項目ずつリストを切り換えます。

選択された要素の詳細エリア

  • パート - これらの読み取り専用ボックスは選択された要素の位置/角度（ XYZAC ）値を表示します。これらの値は既にワーク座標系に変換されています。

  • 機械位置 - これらの読み取り専用ボックスは選択された要素の位置/角度（ XYZAC ）値を表示します。これらの値は既に機械座標系に変換されています。

  • ターゲット - これらのボックスは各軸の余分なオフセット値を定義しますが、機械座標値をデフォルトの参照値として使用します。その入力はワークオフセットを設定するのに使用される測定値に追加されます。

コメント

このボックスを使用してアップデートされたワークオフセットのコメントを入力します。

詳細な手順：

この画面を使用して測定プログラムの終わりにワークオフセットを自動的にアップデートするか、要素の検査後にワークオフセットを手動でアップデートします。

これを行うには、ワークオフセットのアップデートコマンドをNC Gage測定プログラムに追加する必要があります。

  1. NC Gageを使用してワークオフセットをアップデートするのに使用される要素を計測してください。

  2. 上記のとおり、ワークオフセットのアップデートソフトキー [image] を押してワークオフセットのアップデート画面にアクセスします。

  3. ワークオフセットのアップデート画面でワークオフセットを定義する要素を選択します。

  4. 確認ソフトキー [image] を押してワークオフセットのアップデートコマンドをNC Gage測定プログラムに追加します。戻るソフトキー [image] を押して前の画面に戻ります。

測定プログラムが動作するとワークオフセットをアップデートします。

ワークオフセットをティーチングするには：

  1. アップデートする必要がある各軸リストで要素を選択します。すべての軸をアップデートしなければならない訳ではありません。値 ボックスがアップデートされ、選択された要素の場所が表示されます。値 ボックスが情報で更新されたら、 対応するオフセット ボックスが使用できるようになります。

  2. 希望する場合はオフセット ボックスにオフセット距離を入力してください。オフセットの更新後、距離は正または負となることができ、要素の位置を表します。

  3. 目的のワークオフセットが強調表示されるまで更新するワークオフセットを選択ソフトキー [image] を押して、リストからワークオフセット名を選択します。強調表示された各ワークオフセットのパラメータは選択されると画面上で更新されます。

  4. 測定プログラムがすでに動作している場合、NC Gageは直ちにワークオフセットをアップデートできます。状況に応じて画面を設定し、実行ソフトキー [image] を選択します。これは選択したワークオフセットを更新しますが、測定プログラムにコマンドを保存しません。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


コントロールフレームの定義

元の状態 > NC Gageの使用 > はじめに > ステップ 7：コントロールフレームの定義

ステップ ７：コントロールフレームの定義

回転軸の移動

回転軸の移動コマンドは1つ以上の回転軸を移動させます。コマンド作成時にマクロプログラムを実行する必要はありません。

詳細については以下を参照してください：

回転軸の移動

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


回転軸の移動

回転軸の移動コマンドは回転軸の付いた機械など、4軸以上を持つ機械で使用されます。4軸以上を使用する場合はライセンスが必要です。基本的にはプローブを安全な位置にを置き、測定したい角度に回転軸を回転させます。

回転軸の移動コマンドを測定プログラムに追加するためには、NC Gageではソフトウェアが正しく設定されている必要があります。

回転軸の移動コマンドを作成すると、その回転軸の移動コマンドが有効である間は、回転軸は指定した角度となります。回転軸の移動コマンドで指定した角度と、実際の回転軸の角度が違っている場合、新たに測定コマンドを作成しようとしても警告メッセージが表示されます。この状態は回転軸の移動コマンドで指定した角度と、実際の回転軸の角度が一致するまで続きます。

NC Gageは回転軸の移動コマンドで指定した角度から移動していないかを、新しい測定コマンドを作成するタイミングでチェックします。移動している場合は警告が表示され、回転軸の移動コマンドで指定した角度と、現在の回転軸の角度が一致するまで要素を測定することはできません。

メッセージは次のとおりです：

現在の回転軸の位置が現在のプログラムの位置と一致しません。修正してから続行してください。

  1. 回転軸の移動の前に「ワークオフセットの選択」をおこないます。

  2. ワークオフセットが選択されると、ワークオフセットの選択ソフトキー [image] が回転軸の移動ソフトキー [image] に変わります。メイン画面から回転軸の移動ソフトキー [image] を選択します。回転軸の移動画面が表示されます：

  3. 安全点 エリアへプローブの安全な位置座標を、回転軸エリアへ測定で使用する回転軸の角度を入力します。

  4. プライマリダイレクションエリアで主軸の向きを選択します。

  5. コマンドの確認/追加ソフトキーを押して変更を保存します。または、戻るソフトキーを押して保存せずに前の画面に戻ります。

安全点エリア

  • 安全点 X,、Y、 Z - 測定プログラム実行時にプローブが移動を開始する位置をX、YおよびZ座標で定義します。プローブは各測定プログラム実行前にこの位置に戻ります。

回転軸エリア

  • 回転軸A、BまたはB、C - 回転軸の角度(単位は度)を表示します。

プライマリダイレクションエリア

  • X+, Y+, Z+, X-, Y-, Z- - 主要な軸の方向を定義します。必要な軸だけが自動的に表示されます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


安全高さパスの定義

元の状態 > NC Gageの使用 > はじめに > ステップ 8：安全高さパスの定義

ステップ 8：安全高さパスの定義

安全高さパスによって、プローブが安全に移動する高さを定義します。平面または円筒の上方の距離を定義して、ワークやその他の障害物との接触を防止することができます。

安全高さパスの定義について詳しくは、「移動コマンドの挿入」の章の「安全高さ」を参照して下さい。

安全高さパスを定義してあると、測定しようとする要素を測定プログラムに追加できます。要素コマンドの作成を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


要素コマンドの作成

NC Gageには、実行中にNC Gageが測定するために要素コマンドを作成して測定プログラムに追加する方法が2つあります。

パラメータ値を入力することによる要素コマンドの作成

パラメータを入力して要素コマンドを作成するには、適切な要素コマンド画面にアクセスしてパラメータ入力によるティーチングチェックボックスを選択し、すべてのパラメータおよびプロパティを入力し、コマンドのティーチングおよび作成ソフトキーにタッチします。NC Gageはユーザーの定義に従って要素コマンドを測定プログラムに挿入します。

要素のティーチンングによる要素コマンドの作成

「ティーチング」によって要素コマンドを作成するには、各要素コマンド画面で[パラメータ入力によるティーチング]チェックボックスのチェックを外します。次に、画面の指示に従ってプローブを手動で移動し、ワーク上の位置をティーチングします。NC Gageはプローブ位置を解釈し、ティーチングされた位置からの情報を使用して自動的に要素コマンドにパラメータ値を書き込みます。NC Gageによって、この「ティーチング」プロセス後に要素コマンドを測定プログラムに挿入することができます。

要素コマンドを追加する前にプローブを校正する必要があります (「校正」を参照)。

以下のコマンドを測定プログラムに追加することができます。

測定される要素

  • 点

  • 円(内径)

  • 円(外径)

  • 円(シャフト)

  • 突起幅

  • 溝幅

  • 交点(内側)

  • 交点(外側)

  • 平面

  • 直線

  • 円筒(内側)

  • 円筒(外側)

  • 円錐(内側)

  • 円錐(外側)

  • 球

  • キー

  • 回転軸角度（溝）

  • 回転軸角度（平面）

構築される要素

  • 点の構築

  • 線の構築

  • 円の構築

測定結果

  • 角度の構築

  • 距離計算

同心度

  • 同心度

追加機能

  • ワークオフセットのアップデート

  • 回転座標の設定

ソフトキー

ナビゲーションバーにあるこれらのソフトキーのいずれかにタッチして要素の画面にアクセスできます。

複合旋盤

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

共通のプロパティ：

  • 公差

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


点

作業面を設定することと、形状を測定する前に測定面を選択することは重要です。詳しくは測定面の設定を見てください。

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 測定画面の点ソフトキー [image] を押して点の測定画面を表示します：

  3. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。複数ステップを要するとき、測定および変更のためにプローブを移動する位置がグラフィカルに表示されます。

測定面の向きの指定方法（歪曲作業面オプションが選択されているときにのみ有効です）

測定面の向きは、点のX、Y、Zへのベクトルの角度を定義します。このエリアで、ベクトルの角度を定義するために角度またはベクトルを選択します。

角度を選択すると、次の入力欄が有効になります：

X軸方向への角度 - 点のX方向のベクトルの角度を定義します。これは測定された第1軸に対する平面の法線方向です。第1軸はXY作業面ではX、YZ作業面ではY、ZX作業面ではZです。有効な範囲は0(ゼロ)～ -360 度です。

Z軸方向への角度 - 平面のZ方向の最初のベクトル角度を定義します。これは作業面に対する面の法線方向です。有効な範囲は-90～+90 度です。

ベクトルを選択すると、次の入力欄が有効になります：

I - 点に対するX方向のベクトルを定義します。

J - 点に対するY方向のベクトルを定義します。

K - 点に対するZ方向のベクトルを定義します。

パラメータエリア

  • アプローチ距離 - 実行時にワークから測定開始位置をどれだけ離すか指定します。プローブはこの距離を計測速度で移動します。

  • 検索距離 - 要素を検索およびティーチングするときの検索距離を定義します。(「オプション設定エリア」で説明するパラメータ入力によるティーチングを選択する場合は使用できません。)

オプション設定エリア

  • 安全高さの設定 - 実行時にプローブが各取込み点の間を安全高さまで移動します。右側の編集ボックスは、平面までの距離を入力するためのものです。この平面は測定プログラムの安全高さではありません。詳細は安全高さの設定を参照してください。

  • ティーチングの後に測定をします - このオプションを選択すると、ティーチングをおこなった後、結果を元に連続して要素を再測定します。これにより、すべての設定パラメータがテストされ、正確で信頼性の高い初回品質検査が提供されます。

  • パラメータ入力によるティーチング - 入力された要素の設計値を使用して測定をします。(これを選択した場合、「パラメータエリア」の検索距離が無効になります。)

点の位置エリア

  • XYZ 設計値 - 開始点の設計上の位置を定義します。

  • XYZ 実測値 - 点の測定位置を表示します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

通常に定義された作業面で点をティーチングするプロセス：

  1. 測定面を選択ソフトキー [image] を押して、点の測定面（上、左、右、前、後または斜面） を選択します。

  2. 点要素を測定したい表面の上にプローブを置きます。

  3. 位置読取り ソフトキー [image] を押します。このルビー位置が開始位置として読込まれます。前のステップに戻るソフトキー [image] を押すとこの測定位置がキャンセルされます。

  4. コマンドのティーチングと作成ソフトキー [image] を押します。NC Gageは下図に記載したのと同様の方法で自動的に測定点を取得します。

    位置Aはプローブを置かなければならない位置を示します。赤線は測定パスを示します。位置1は測定点の位置を示します。

  5. 要素が測定されると測定値が更新されます。コマンドの確認/追加ソフトキー [image] を押すと要素コマンドが測定プログラムに追加されます。

通常に定義された斜面の測定面で点をティーチングするプロセス：

  1. 測定面を選択ソフトキー [image] を押して、点の測定面（上、左、右、前、後または斜面） を選択します。斜面オプションを選択するには、アイコンが斜面アイコン [image] に変化するまで測定面を選択ソフトキーを押します。

  2. 点要素を測定したい表面の上にプローブを置きます。

  3. 位置読取り ソフトキー [image] を押します。このルビー位置が開始位置として読込まれます。前のステップに戻るソフトキー [image] を押すとこの測定位置がキャンセルされます。

  4. 表面の方向に測定点の位置から離してプローブを置きます。この位置（2点目の位置）から測定開始点（1点目の位置）の方向へ要素をティーチングします。

  5. 位置読取り ソフトキー [image] を押します。

  6. コマンドのティーチングと作成ソフトキー [image] を押します。

  7. 要素が測定されると測定値が更新されます。コマンドの確認/追加ソフトキー [image] を押すと要素コマンドが測定プログラムに追加されます。

NC Gageの具体的な動作について：

点要素のティーチング手順

  • 現在位置読込む

  • 現在の測定面の方向で測定します。

  • 読込み位置まで後退します。

点要素の測定手順

  • 現在の位置が安全高さより低い場合、安全高さまで上昇します。

  • 点の上の位置に移動します。

  • 設計上の表面からアプローチ距離+プローブ半径だけ離れた点の上の位置まで下降します。

  • 点を測定します。ターゲットは表面下方のアプローチ距離です。

  • 測定後、安全高さに移動します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


円(内径)

元の状態 > NC Gageの使用 > 要素コマンドの作成 > 円(内径)

円の測定（内径）

円(内径) コマンドを作成するには：

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 円 (内径) ソフトキー [image] を押して円の測定（内径）画面を表示します：

  3. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。複数ステップを要するとき、測定および変更のためにプローブを移動する位置がグラフィカルに表示されます。

プロパティエリア

  • 点数 - 実行中 に(ティーチングモードではなく)、円に対して計測が行われる点数を定義します。

  • 開始角度 - 測定する円のセクションの開始点を定義します。回転が第1軸に沿った0で始まり、90が第2軸にあるように移動します。第1軸はXY作業面ではX、YZ作業面ではY、ZX作業面ではZです。第2軸はXY作業面ではY、YZ作業面ではZ、ZX作業面ではXです。

  • 終了角度 - 測定する円の終点を定義します。開始角度と同様の角度で指定します。ティーチングモードでは第1軸および第2軸方向の反対側に取込み点が自動的に取得されます。円が360度続かない場合、パラメータ入力によるティーチングを使い適切な開始角度と終了角度を定義して測定することが可能です。ここで、 ティーチングの後に測定をしますを選択するとNC Gageは要素を測定します。

  • 測定高さ - この値は設計上のパラメータに対して実際に測定する位置を定義します。値がゼロの場合は、パラメータエリアで定義されるX, Y, Z点の位置を中心とした要素を測定することを意味します。負の値の場合は、設計上の位置よりも指定した値だけ下で測定します。正の値の場合は、指定した値だけ上で測定します。

ライン数と1ライン毎の点数は定義された円に沿って等間隔に配置されます。

パラメータエリア

  • アプローチ距離 - 実行時にワークから測定開始位置をどれだけ離すか指定します。プローブはこの距離を計測速度で移動します。

  • 検索距離 - 測定開始点から何ミリ検索動作を行うかを設定します。(オプション設定エリアで説明するパラメータ入力によるティーチングを選択する場合は使用できません。)

オプション設定エリア

  • 安全高さの設定 - 実行時にプローブが各取込み点の間を安全高さまで移動します。チェックボックスにチェックを入れた後に、右側の編集ボックスに安全高さまでの距離を入力します。この平面は測定プログラムの安全高さではありません。詳細は安全高さの設定を参照してください。

  • ティーチングの後に測定をします - ティーチングした後に続けて要素を再測定します。この測定ではティーチングで測定したパラメータを使用します。これにより、すべての設定パラメータがテストされ、正確で信頼性の高い初回品質検査が提供されます。

  • パラメータ入力によるティーチング - 入力された要素の設計値を使用して測定をします。(これを選択した場合、「パラメータエリア」の検索距離が無効になります。)

パラメータエリア

  • XYZD 設計値 - 円の内側の設計上の位置を定義します。

  • XYZD 実測値 - 円の内側の測定された位置を表示します。

3軸レポートエリア

3 軸レポートを使用して3つの方法でXYZ点を定義できます。

  • 測定される点または使用される平面を選択して測定される要素の高さを定義します。

  • 使用する平面の方向性を有する高さを入力します。この高さはワークの原点に対するもので、プローブベクトルに沿って測定されます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

1点ティーチング(小径用）

  1. プローブを内径の中心に置き、位置読込み ソフトキー [image] を押します。これがすべての取込点の高さ位置となります。 前のステップに戻る ソフトキー [image] を押すとこの測定位置がキャンセルされます。

  2. プローブを自動測定用に配置し、 コマンドのティーチングと作成 ソフトキー [image] を押します。NC Gageは第1軸と第2軸の正方向と負方向に 4つの取込み点を取得します。

プローブを動かす手動開始位置(A)とNC Gageが4点（位置1－4）を測定するときに通る自動計測経路(赤線)を示す画像

  • 衝突が発生するとプロセスが停止しエラーが表示されます。

  • 内径を計測できなかった場合、検索距離を変更して再試行します。

  3. 要素が測定されると、NC Gageが測定値を更新します。

  4. コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。

2点ティーチング(大径用)

  1. プローブを内径の中心に置き、位置読込み ソフトキー [image] を押します。これがすべての取込点の高さ位置となります。前のステップに戻る ソフトキー [image] を押すとこの測定位置がキャンセルされます。

  2. プローブを内径の外周付近に置き、位置読込み ソフトキー [image] を押します。前のステップに戻る ソフトキー [image] を押すとこの測定位置がキャンセルされます。

  3. プローブを自動測定用に配置し、コマンドのティーチングと作成 ソフトキー [image] を押します。

プローブを動かす手動開始位置(A)とNC Gageが3点(位置1-3)を測定するときに通る自動計測経路(赤線)を示す画像

  • 衝突が発生するとプロセスが停止しエラーが表示されます。

  • 内径を計測できなかった場合、検索距離を変更して再試行します。

  4. 要素が測定されると、NC Gageが測定値を更新します。

  5. コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。

NC Gage

1点ティーチング(小径用)の経路

  • 内径の中心でプローブの位置を読込みます。

  • 読込んだZ座標で、内径の測定をおこないます。

  • 読込んだXY座標を、内径の中央位置であると想定します。

  • 検索距離を使用して+ X 方向へ点を測定します。

  • 中央位置に戻ります。

  • 検索距離を使用して－X 方向へ点を測定します。

  • 中央位置に戻ります。

  • 検索距離を使用して+Y 方向へ点を測定します。

  • 中央位置に戻ります。

  • 検索距離を使用して－Y 方向へ点を測定します。

  • 中央位置に戻ります。

2点ティーチング(大径用)の経路

  • 内径の中心でプローブの位置を読込みます。

  • 内径の外周付でプローブの位置を読込みます。

  • 読込んだZ座標で、内径の測定をおこないます。

  • 検索距離を使用して、中心から外周方向へ点を測定します。

  • 外周位置に戻ります。

  • 検索距離を使用して、中心から外周方向に垂直な向きへ点を測定します。

  • 外周位置に戻ります。

  • 検索距離を使用して、中心から外周方向に垂直な別の向きへ点を測定します。

  • 外周位置に戻ります。

内径要素パスの実行

  • アプローチ距離 = 内径 - アプローチ距離 – プローブ半径と定義します。

  • ターゲット半径 = 内径 + アプローチ距離 – プローブ半径と定義します。

  • 現在の位置が安全高さより低い場合、安全高さまで上昇します。

  • 最初のアプローチ距離の点の上方に移動します。この点は開始角度の方向に内径の中心からアプローチ距離だけ離れています。

  • 測定ラインまで下降します。

  • 測定点、ターゲットは角度に沿った内径の中心からのターゲット半径です。

  • 後退して次の点のアプローチ距離に移動します。

  • 測定点、ターゲットは角度に沿った内径の中心からのターゲット半径です。

  • 開始角度から終了角度まで指定された数の点を測定し続けます。

  • 安全高さの設定が有効である場合、点と点の間では安全高さに移動して次のアプローチ距離に到達します。

  • 最後の点を測定するとプローブは安全高さまで上昇します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


円(外径)

元の状態 > NC Gageの使用 > 要素コマンドの作成 > 円(外径)

円の測定（外径）

円外径コマンドを作成するには：

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 円 (外径) ソフトキー [image] を押して 円の測定（外径）画面を表示します：

  3. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。複数ステップを要するとき、測定および変更のためにプローブを移動する位置がグラフィカルに表示されます。

プロパティエリア

  • 点数 - 実行中 に(ティーチングモードではなく)、円に対して計測が行われる点数を定義します。

  • 開始角度 - 測定する円のセクションの開始点を定義します。回転が第1軸に沿った0で始まり、90が第2軸にあるように移動します。第1軸はXY作業面ではX、YZ作業面ではY、ZX作業面ではZです。第2軸はXY作業面ではY、YZ作業面ではZ、ZX作業面ではXです。

  • 終了角度 - 測定する円の終点を定義します。開始角度と同様の角度で指定します。ティーチングモードでは、第1軸と第2軸の方向の反対側にと反対方向に取り込み点が自動的に取得されます。円が360度続かない場合、パラメータ入力によるティーチングを使い適切な開始角度と終了角度を定義して測定することが可能です。ここで、 ティーチングの後に測定をしますを選択するとNC Gageは要素を測定します。

ライン数と1ライン毎の点数は定義された円に沿って等間隔に配置されます。

パラメータエリア

  • アプローチ距離 - 実行時にワークから測定開始位置をどれだけ離すか指定します。プローブはこの距離を計測速度で移動します。

  • 検索距離 - ティーチングモード中にプローブが面を検索して移動する距離を定義します。(オプション設定エリアで説明するパラメータ入力によるティーチングを選択する場合は使用できません。)

オプション設定エリア

  • 安全高さの設定 - 実行時にプローブが各取込み点の間を安全高さまで移動します。右側の編集ボックスでユーザーは平面までの距離を入力できます。この平面は測定プログラムの安全高さではありません。詳細は安全高さの設定を参照してください。

  • ティーチングの後に測定をします - ティーチングした後に続けて要素を再測定します。この測定ではティーチングで測定したパラメータを使用します。これにより、すべての設定パラメータがテストされ、正確で信頼性の高い初回品質検査が提供されます。

  • パラメータ入力によるティーチング - 入力された要素の設計値を使用して測定をします。(これを選択した場合、「パラメータエリア」の検索距離が無効になります。)

パラメータエリア

  • XYZD 設計値 - 円外径の設計上の位置を定義します。

  • XYZD 実測値 - 円外径の測定された位置を表示します。

3軸レポートエリア

3 軸レポートを使用して3つの方法でXYZ点を定義できます。

  • 測定される点または使用される平面を選択して測定される要素の高さを定義します。

  • 使用する平面の方向性を有する高さを入力します。この高さはワークの原点に対するもので、プローブベクトルに沿って測定されます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

  1. プローブを外側の表面近くに置き、位置読取りソフトキー [image] を押します。これがすべての取込点の高さ位置となります。前のステップに戻るソフトキー [image] を押すとこの測定位置がキャンセルされます。

  2. プローブを外径の中心より上に置き、位置読取りソフトキー [image] を押します。これを使用して外径の中心を決定します。前のステップに戻るソフトキー [image] を押すとこの測定位置がキャンセルされます。

  3. プローブを自動測定用に配置し、コマンドのティーチングと作成ソフトキー<170/>を押します。NC Gage はこの位置の下方で取込み点を一つ取得し、外径の高さを決定します。次に、以下に示すのと同様な方法で取込み点を自動的に取得します。

    プローブを動かす手動位置(A-B)とNC Gageが4点（位置1－4）を測定するときに通る自動計測経路(赤線)を示す画像

  4. 要素が測定されると測定値が更新されます。コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

NC Gageの具体的な動作について：

外径要素パスのティーチング

  • 外側に隣接したプローブの位置を読み込みます。Z値は測定高さになります。

  • 外径の中心の上方にあるプローブの位置を読み込みます。XY値は中心を定義し、Z値は安全高さの値です。

  • アプローチ距離 = 2つの読込み位置の間の投影された2次元距離

  • 安全高さに移動します。

  • 安全高さでアプローチ距離1(+Xにおける中心からのアプローチ距離)の上方の点に移動します。

  • 測定高さまで下降します。

  • 点を測定します。ターゲットは測定高さでの中心です。

  • 安全高さに移動します。

  • 安全高さでアプローチ距離2(-Xにおける中心からのアプローチ距離)の上方の点に移動します。

  • 測定高さまで下降します。

  • 点を測定します。ターゲットは測定高さでの中心です。

  • 安全高さに移動します。

  • 安全高さでアプローチ距離3(+Yにおける中心からのアプローチ距離)の上方の点に移動します。

  • 測定高さまで下降します。

  • 点を測定します。ターゲットは測定高さでの中心です。

  • 安全高さに移動します。

  • 安全高さでアプローチ距離4(-Yにおける中心からのアプローチ距離)の上方の点に移動します。

  • 測定高さまで下降します。

  • 点を測定します。ターゲットは測定高さでの中心です。

  • 安全高さに移動します。

外径要素パスの実行

  • アプローチ距離 = 外径 + アプローチ距離 + プローブ半径を定義します。

  • ターゲット半径 = 外径 - アプローチ距離 – プローブ半径と定義します。これが0より小さい場合は0に設定します。

  • 現在の位置が安全高さより低い場合、安全高さまで上昇します。

  • 最初のアプローチ距離の点の上方に移動します。この点は開始角度の方向に外径からのアプローチ距離です。

  • 測定ラインまで下降します。

  • 点を測定します。ターゲットは角度に沿って外径の中心からのターゲット半径です。

  • 後退して次の点のアプローチ距離に移動します。必要な場合は1つまたは複数の小さな移動を使用して外側との衝突を回避します。

  • 点を測定します。ターゲットは角度に沿って外径の中心からのターゲット半径です。

  • 開始角度から終了角度まで指定された数の点を測定し続けます。

  • 安全高さの設定が有効である場合、点と点の間では安全高さに移動して次のアプローチ距離に到達します。

  • 最後の点を測定するとプローブは安全高さまで上昇します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


円(シャフト)

元の状態 > NC Gageの使用 > 要素コマンドの作成 > 円(シャフト)

円の測定（シャフト）

円シャフトコマンドを作成するには：

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 円(シャフト)ソフトキー [image] を押して 円の測定 （シャフト）画面を表示します：

  3. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。複数ステップを要するとき、測定および変更のためにプローブを移動する位置がグラフィカルに表示されます。

プロパティエリア

  • 点数 - 実行中 に(ティーチングモードではなく)、円に対して計測が行われる点数を定義します。

  • 開始角度 - 測定する円のセクションの開始点を定義します。回転が第1軸に沿った0で始まり、90が第2軸にあるように移動します。第1軸はXY作業面ではX、YZ作業面ではY、ZX作業面ではZです。第2軸はXY作業面ではY、YZ作業面ではZ、ZX作業面ではXです。

  • 測定角度 - 回転での測定の範囲を定義します。開始角度と含まれる角度は実行モードで要素が測定されるときにのみ使用されます。ティーチングモードでは、第1軸と第2軸の方向の反対側にと反対方向に取り込み点が自動的に取得されます。円が360度続かない場合、パラメータ入力によるティーチングを使い適切な開始角度と終了角度を定義して測定することが可能です。ここで、ティーチングの後に測定をしますを選択するとNC Gageは要素を測定します。

点数は定義された円に沿って等間隔に配置されます。

  • シャフトの回転 - C軸を回転してシャフトを測定するにはするを選択します。そうでない場合はしないを選択します。

シャフトの振れ評価はC軸を回転させながら測定した時のみ可能です。

パラメータエリア

  • アプローチ距離 - 実行時にワークから測定開始位置をどれだけ離すか指定します。プローブはこの距離を計測速度で移動します。

  • 検索距離 - ティーチングモード中にプローブが面を検索して移動する距離を定義します。(「オプション設定エリア」で説明する画面で入力した値を使用してティーチングチェックボックスを選択する場合は使用できません。)

オプション設定エリア

  • 安全高さの設定 - 実行時にプローブが各取込み点の間を安全高さまで移動します。右側の編集ボックスでユーザーは平面までの距離を入力できます。この平面は測定プログラムの安全高さではありません。詳細は安全高さの設定を参照してください。

  • ティーチングの後に測定をします - ティーチングした後に続けて要素を再測定します。この測定ではティーチングで測定したパラメータを使用します。これにより、すべての設定パラメータがテストされ、正確で信頼性の高い初回品質検査が提供されます。

  • パラメータ入力によるティーチング - 入力された要素の設計値を使用して測定をします。(これを選択した場合、「パラメータエリア」の検索距離が無効になります。)

パラメータエリア

  • XYZD 設計値 - 円のシャフトの設計上の位置を定義します。

  • XYZD 実測値 - 円のシャフトの測定された位置を表示します。

3軸レポートエリア

3 軸レポートを使用して3つの方法でXYZ点を定義できます。

  • 測定される点または使用される平面を選択して測定される要素の高さを定義します。

  • 使用する平面の方向性を有する高さを入力します。この高さはワークの原点に対するもので、プローブベクトルに沿って測定されます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

  1. プローブをシャフト側面の表面近くに置き、位置読取り ソフトキー [image] を押します。これがすべての取込点の高さ位置となります。前のステップに戻るソフトキー [image] を押すとこの測定位置がキャンセルされます。

  2. プローブをシャフトの中心の上方に置き、位置読取りソフトキー [image] を押します。これを使用してシャフトの中心を決定します。前のステップに戻るソフトキー [image] を押すとこの測定位置がキャンセルされます。

  3. プローブを測定を開始したい位置に動かし、コマンドのティーチングと作成ソフトキー [image] を押します。NC Gageは半径方向に沿ってシャフト上で1つの取込み点を取得します。プローブ移動方向はジョグ位置からシャフト中心です。

開始点とターゲット点を示す例

プローブ方向がシャフトの中心線に対して垂直であるリスト角度のみが現在サポートされていることに注意してください：

  4. 要素が測定されると測定値が更新されます。コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

シャフト回転のないティーチングプロセス

このティーチングプロセスについては下記の画像を参照してください：

シャフト回転のないティーチングプロセス

  1. シャフト回転オプションでいいえを選択します。

  2. プローブを中心線の最上部におけるシャフト面の隣に置いて位置読取りソフトキー [image] を押します。これによって、最初のジョグ (寸動) 位置が記録されます。前のステップに戻るソフトキー [image] を押すとこの測定位置がキャンセルされます。

  3. プローブを中心線の最上部におけるシャフト面の隣に置いて位置読取りソフトキー [image] を押します。これによって、2番目のジョグ (寸動) 位置が記録されます。前のステップに戻るソフトキー [image] を押すとこの測定位置がキャンセルされます。

  4. プローブをシャフト面の隣に置いて位置読取りソフトキー [image] を押します。これによって、3番目のジョグ (寸動) 位置が記録されます。前のステップに戻るソフトキー [image] を押すとこの測定位置がキャンセルされます。

  5. プローブを自動測定用に配置し、コマンドのティーチングと作成 ソフトキー [image] を押します。NC Gage は以下に示す図と同様な方法で測定点を自動的に取得します：

シャフト回転のないティーチングプロセスでの取込み点

要素が測定されると測定値が更新されます。

  6. コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

NC Gage

シャフト測定の経路

  • プローブを中心線の最上部におけるシャフト面の隣に置きます。位置を読み込みます。

  • プローブを中心線の横にあるシャフト面の隣に置きます。位置を読み込みます。

  • プローブをシャフト面の隣に置きます。位置を読み込みます。

  • 読込み位置でのシャフトの中心を計算します。

  • プローブ移動ベクトル方向にシャフト面上の最初の点を測定します。

  • プローブ移動ベクトル方向にシャフト面上の2番目の点を測定します。

  • プローブ移動ベクトル方向にシャフト面上の3番目の点を測定します。

  • シャフトの直径と中心を計算します。

  • 開始角度を計算して角度を含めます。

シャフト測定の実行

  • アプローチ半径 = シャフト半径 + アプローチ距離 + プローブ半径 と定義します。

  • ターゲット半径 = シャフト半径 - アプローチ距離 + プローブ半径 と定義します。

  • 現在の位置が安全高さより低い場合、安全高さまで上昇します。

  • 安全高さにおけるアプローチ距離の位置より上方に移動します。

  • 開始角度でアプローチ距離の位置に移動します。この点は開始角度の方向に回転軸中心からアプローチ半径だけ離れています。

  • 測定ラインまで下降します。

  • 点を測定します。ターゲットは開始角度に沿った回転軸中心からのターゲット半径です。

  • 後退して、次のアプローチ距離の位置に移動します。すべての点が測定されるまで上記2つの手順を続けます。

  • 最後の点を測定した後、プローブは安全高さまで上昇します。

シャフト回転のあるティーチングプロセス

このティーチングプロセスについては下記の画像を参照してください：

シャフト回転のあるティーチングプロセス

  1. シャフト回転オプションではいを選択します。

  2. プローブをシャフト面の隣に置いて位置読取りソフトキー [image] を押します。これによって、計測の開始位置としてジョグ位置が記録されます。前のステップに戻るソフトキー [image] を押すとこの測定位置がキャンセルされます。

  3. 自動測定用にプローブを置きます。この測定された位置をキャンセルするには前のステップに戻るソフトキー [image] を押します。NC Gage は以下に示す図と同様な方法で測定点を自動的に取得します。下記に示すとおりプローブ移動方向はジョグ位置からシャフト中心です：

ジョグ位置からシャフト中心へのプローブ移動方向

要素が測定されると測定値が更新されます。

  4. コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

NC Gage

シャフト測定の経路

  • 開始点としてシャフト表面の近くにプローブを置きます。

  • 位置を読み込みます。

  • 読み込まれた位置と軸の中心を使用してプローブ移動ベクトルを計算します。

  • プローブ移動ベクトルの方向にシャフト面上の点を測定します。

  • シャフトの直径と中心を計算します。

  • 開始角度としてプローブ移動ベクトル角度を計算します。

  • 開始位置に戻ります。

シャフト測定の実行

  • アプローチ半径 = シャフト半径 + アプローチ距離 + プローブ半径 と定義します。

  • ターゲット半径 = シャフト半径 - アプローチ距離 + プローブ半径 と定義します。

  • 現在の位置が安全高さより低い場合、安全高さまで上昇します。

  • 安全高さにおけるアプローチ距離の位置より上方に移動します。

  • 開始角度でアプローチ距離の位置に移動します。この点は開始角度の方向に回転軸中心からアプローチ半径だけ離れています。

  • 測定ラインまで下降します。

  • 点を測定します。ターゲットは開始角度に沿った回転軸中心からのターゲット半径です。

  • 後退して軸を次の角度まで回転します。

  • すべての点が測定されるまで上記2つの手順を続けます。

  • 最後の点を測定した後、プローブは安全高さまで上昇します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


突起幅

元の状態 > NC Gageの使用 > 要素コマンドの作成 > 突起幅

突起幅の測定

突起幅コマンドを作成するには：

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 突起幅の測定ソフトキー [image] を押して突起幅の測定画面を表示します：

  3. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。複数ステップを要するとき、測定および変更のためにプローブを移動する位置がグラフィカルに表示されます。

プロパティエリア

以下の2つのプロパティはオプション設定エリアのパラメータ入力によるティーチングチェックボックスが選択されているときにのみ表示されます：

  • 基準面の長さ - これは突起の長さ方向の距離を定義します。測定時の最初の点から2番目の点までの距離を指定します。

  • 幅 - これは突起の第2辺に平行な線上の測定位置を定義します。値がゼロの場合は、突起幅の中心から第2の辺に投影した位置が3番目の測定点になります。負の値の場合は、突起幅の中心から第2の辺に投影した位置から、パラメータのX軸方向への角度で指定した方向と180度逆の方向へ、指定した値だけ移動した位置で測定します。正の値の場合、X軸方向への角度で指定した方向へ、指定した値だけ移動した位置で測定します。

パラメータエリア

  • アプローチ距離 - 実行時にワークから測定開始位置をどれだけ離すか指定します。プローブはこの距離を計測速度で移動します。

  • 検索距離 - ティーチングモード中にプローブが面を検索して移動する距離を定義します。(「オプション設定エリア」で説明するパラメータ入力によるティーチングを選択する場合は使用できません。)

オプション設定エリア

  • 安全高さの設定 - 実行時にプローブが各取込み点の間を安全高さまで移動します。右側の編集ボックスでユーザーは平面までの距離を入力できます。この平面は測定プログラムの安全高さではありません。詳細は安全高さの設定を参照してください。

  • ティーチングの後に測定をします - このオプションを選択すると、ティーチングをおこなった後、結果を元に連続して要素を再測定します。これにより、すべての設定パラメータがテストされ、正確で信頼性の高い初回品質検査が提供されます。

  • パラメータ入力によるティーチング - 入力された要素の設計値を使用して測定をします。（これによってプロパティエリアの基準面の長さと幅のオプションが有効になり、パラメータセクションの距離検索オプションが無効になります。）

パラメータエリア

  • XYZ 設計値 - 突起幅上面の中心の設計上の位置を定義します。

  • XYZ 実測値 - 突起幅の上面中心で測定された位置を表示します。

  • X軸方向への角度 - 突起幅の中心線のベクトル角度を定義します。これはＸ軸に対する線の方向です。

  • 幅 (設計値) - 突起幅の設計上の幅を定義します。

  • 幅（実測値） - 突起幅の測定された幅を表示します。

3軸レポートエリア

3 軸レポートを使用して3つの方法でXYZ点を定義できます。

  • 測定点または測定平面を選択して測定された要素の高さを定義します。

  • 使用する平面の方向性を有する高さを入力します。この高さはワークの原点に対するもので、プローブベクトルに沿って測定されます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

  1. プローブを最初の辺の最初の点の隣に置き、位置読取りソフトキー [image] を押します。作業面の表面からの距離がすべての点で同じになります。

  2. プローブを最初の辺の2番目の点の隣に置き、位置読取りソフトキー [image] を押します。

  3. プローブを2番目の辺の測定点の隣に置き、位置読取りソフトキー [image] を押します。

  4. コマンドのティーチングと作成ソフトキー [image] を押します。NC Gageは下図に示すのと同じような方法で、安全高さに移動して計測点を自動的に取得します。

A-C) ジョグ位置1-3) 自動的に測定される点の位置。赤線は測定パスを示します。

  5. コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

NC Gage

突起幅要素のティーチング手順

  • 突起幅の最初の辺の最初の点の隣でプローブの位置を読込みます。Z値はすべての点の測定高さになります。

  • 突起幅の最初の辺の2番目の点の隣でプローブの位置を読込みます。最初の点から2番目の点の方向で突起幅の方向ベクトルが定義されます。この点は2番目の点のおおよその測定位置を決定します。

  • 突起幅の2番目の辺上の点の隣にあるプローブの読取り位置。この点から最初の2点によって定義される線までの距離が突起幅のおおよその幅を定義します。この点は3番目の点のおおよその測定位置を決定します。

  • プローブが安全高さより低い場合、安全高さまで上昇します。

  • 最初の読込み点の上に移動します。

  • 測定高さまで下降します。

  • 点を測定します。ターゲットは突起幅の中心線への最初の点の投影です。

  • 後退して、2番目の読込み点に移動します。

  • 点を測定します。ターゲットは突起幅の中心線への2番目の点の投影です。

  • 後退して、安全高さまで上昇します。

  • 3番目の読込み点の上方の点に移動します。

  • 測定高さへの下降

  • 点を測定します。ターゲットは突起幅の中心線への3番目の点の投影です。

  • 後退して、安全高さまで上昇します。

突起幅要素の測定手順

  • プローブが安全高さより低い場合、安全高さまで上昇します。

  • 最初のアプローチ距離の点の上方に移動します。

  • 測定高さまで下降します。

  • 点を測定します。ターゲットは突起幅の中心線への最初の点の投影です。

  • 後退して、2番目のアプローチ距離の位置に移動します。

  • 点を測定します。ターゲットは突起幅の中心線への2番目の点の投影です。

  • 後退して、安全高さまで上昇します。

  • 3番目のアプローチ距離の上方の点に移動します。

  • 測定高さへの下降

  • 点を測定します。ターゲットは突起幅の中心線への3番目の点の投影です。

  • 安全高さの設定が有効である場合、点と点の間では安全高さに移動して次のアプローチ距離に到達します。

  • 後退して、安全高さまで上昇します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


溝幅

元の状態 > NC Gageの使用 > 要素コマンドの作成 > 溝幅

溝幅の測定

溝幅コマンドを作成するには：

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 溝幅の測定ソフトキー [image] を押すと溝幅の測定画面が表示されます：

  3. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。複数ステップを要するとき、測定および変更のためにプローブを移動する位置がグラフィカルに表示されます。

プロパティエリア

以下の2つのプロパティはオプション設定エリアのパラメータ入力によるティーチングチェックボックスが選択されているときにのみ表示されます：

  • 基準面の長さ - これは突起の長さ方向の距離を定義します。測定時の最初の点から2番目の点までの距離を指定します。

  • 幅 - これは溝の第2辺に平行な線上の測定位置を定義します。値がゼロの場合は、溝幅の中心から第2の辺に投影した位置が3番目の測定点になります。負の値の場合は、溝幅の中心から第2の辺に投影した位置から、パラメータのX軸方向への角度で指定した方向と180度逆の方向へ、指定した値だけ移動した位置で測定します。正の値の場合、X軸方向への角度で指定した方向へ、指定した値だけ移動した位置で測定します。

パラメータエリア

  • アプローチ距離 - 実行時にワークから測定開始位置をどれだけ離すか指定します。プローブはこの距離を計測速度で移動します。

  • 検索距離 - ティーチングモード中にプローブが面を検索して移動する距離を定義します。(「オプション設定エリア」で説明するパラメータ入力によるティーチングを選択する場合は使用できません。)

オプション設定エリア

  • 安全高さの設定 - 実行時にプローブが各取込み点の間を安全高さまで移動します。チェックボックスにチェックを入れた後に、右側の編集ボックスに安全高さまでの距離を入力します。この平面は測定プログラムの安全高さではありません。詳細は安全高さの設定を参照してください。

  • ティーチングの後に測定をします - このオプションを選択すると、ティーチングをおこなった後、結果を元に連続して要素を再測定します。これにより、すべての設定パラメータがテストされ、正確で信頼性の高い初回品質検査が提供されます。

  • パラメータ入力によるティーチング - 入力された要素の設計値を使用して測定をします。（選択した場合、プロパティエリアの基準面の長さおよび幅オプションが有効になり、パラメータエリアの距離検索オプションが無効になります。）

パラメータエリア

  • XYZ設計値 - 溝幅の上面中心の設計上の位置を定義します。

  • XYZ実測値 - 溝幅の上面中心で測定された位置を表示します。

  • X軸方向への角度 -溝幅のベクトル角度を定義します。これはＸ軸に対する線の方向です。

  • 幅 (設計値) - 溝幅の設計上の幅を定義します。

  • 幅（実測値）- 溝幅の測定された幅を表示します。

3軸レポートエリア

3 軸レポートを使用して3つの方法でXYZ点を定義できます。

  • 測定点または測定平面を選択して測定された要素の高さを定義します。

  • 使用する平面の方向性を有する高さを入力します。この高さはワークの原点に対するもので、プローブベクトルに沿って測定されます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

  1. プローブを最初の辺の最初の点の隣に置き、位置読取りソフトキー [image] を押します。作業面の表面からの距離がすべての点で同じになります。

  2. プローブを最初の辺の2番目の点の隣に置き、位置読取りソフトキー [image] を押します。

  3. プローブを2番目の辺の測定点の隣に置き、位置読取りソフトキー [image] を押します。

  4. コマンドのティーチングと作成ソフトキー [image] を押します。NC Gageは安全高さに移動し、下図に記載するのと同様の方法で測定点を自動的に取得します。これらの点をティーチングするとき、プローブはアプローチ距離を４回検索します。

溝幅のパス：A-C) 中心線に沿ったジョグ位置1-3) 自動測定点位置。赤線は測定パスを示します。赤線は測定パスを示します。

  5. コマンドの確認/追加ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

NC Gageの具体的な動作について：

溝幅要素のティーチング手順

  • 溝幅の最初の辺の最初の点の隣のプローブ位置を読込みます。Z値はすべての点の測定高さになります。

  • 溝幅の最初の辺の2番目の点の隣でプローブの位置を読込みます。最初の点から2番目の点の方向が溝幅の方向ベクトルを定義します。この点は2番目の点のおおよその測定位置を決定します。

  • 溝幅の2番目の辺の点の隣にあるプローブ位置を読込みます。最初の2点で定義されるこの点から線までの距離が溝幅のおおよその幅を定義します。この点は3番目の点のおおよその測定位置を決定します。

  • プローブが安全高さより低い場合、安全高さまで上昇します。

  • 最初の読込み点の上に移動します。

  • 測定高さまで下降します。

  • 点を測定します。ターゲットは溝幅の中心線から4*アプローチ距離だけ離れています。

  • 後退して、2番目の読込み点に移動します。

  • 点を測定します。ターゲットは溝幅の中心線から4*アプローチ距離だけ離れています。

  • 後退して、3番目の読込み点に移動します。

  • 点を測定します。ターゲットは溝幅の中心線から4*アプローチ距離だけ離れています。

  • 後退して、安全高さまで上昇します。

溝幅要素の測定手順

  • プローブが安全高さより低い場合、安全高さまで上昇します。

  • 最初のアプローチ距離の点の上方に移動します。

  • 測定高さまで下降します。

  • 点を測定します。ターゲットは溝幅の中心線から2*アプローチ距離だけ離れています。

  • 後退して、2番目のアプローチ距離の位置に移動します。

  • 点を測定します。ターゲットは溝幅の中心線から2*アプローチ距離だけ離れています。

  • 後退して、2番目のアプローチ距離の位置に移動します。

  • 点を測定します。ターゲットは溝幅の中心線から2*アプローチ距離だけ離れています。

  • 安全高さの設定が有効である場合、点と点の間では安全高さに移動して次のアプローチ距離に到達します。

  • 後退して、安全高さまで上昇します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


交点(外側)

元の状態 > NC Gageの使用 > 要素コマンドの作成 > 交点(外側)

交点の測定（外側）

交点(外側)コマンドを作成するには：

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 交点(外側) ソフトキー [image] を押して交点の測定(外側)画面を表示します：

  3. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。複数ステップを要するとき、測定および変更のためにプローブを移動する位置がグラフィカルに表示されます。測定面の選択に関しては点の測定の記述を参照してください。

プロパティエリア

以下の3つのプロパティはオプション設定エリアでパラメータ入力によるティーチングがチェックされている時のみ使用できます：

  • 開始側オフセット - 最初の辺の測定位置を定義します。最初の辺の始点および終点が、測定するコーナーの設計上の位置から、開始角度の方向にどれだけ離れているか指定します。

  • 終了側オフセット - 2番目の辺の測定位置を定義します。2番目の辺の始点および終点が、指定するコーナーの設計上の位置から、開始角度とコーナーの角度を加えた方向にどれだけ離れているか指定します。

  • 最初の辺から時計回りに2番目の辺に移動 - デフォルトではNC Gage2番目の辺は最初の辺の反時計回り方向にあると予測します。NC Gageこのオプションを選択すると、2番目の辺が最初の辺に対して時計回りの方向にあると予想します。

パラメータエリア

  • アプローチ距離 - 実行時にワークから測定開始位置をどれだけ離すか指定します。プローブはこの距離を計測速度で移動します。

  • 検索距離 - ティーチングモード中にプローブが面を検索して移動する距離を定義します。(「オプション設定エリア」で説明するパラメータ入力によるティーチングを選択する場合は使用できません。)

オプション設定エリア

  • 安全高さの設定 - 実行時にプローブが各取込み点の間を安全高さまで移動します。右側の編集ボックスでユーザーは平面までの距離を入力できます。この平面は測定プログラムの安全高さではありません。詳細は安全高さの設定を参照してください。

  • ティーチングの後に測定をします - ティーチングした後に続けて要素を再測定します。この測定ではティーチングで測定したパラメータを使用します。これにより、すべての設定パラメータがテストされ、正確で信頼性の高い初回品質検査が提供されます。

  • パラメータ入力によるティーチング - 入力された要素の設計値を使用して測定をします。(これを選択するとプロパティエリアでの開始側オフセット、終了側オフセットおよび最初の辺から時計回りに2番目の辺に移動オプションが有効になり、パラメータエリアでの検索距離オプションが無効になります。)

パラメータエリア

  • XYZ設計値 - コーナーの設計上の位置を定義します。

  • XYZ実測値 - コーナーの測定された位置を表示します。

  • 開始角度 - コーナーの開始辺の角度を定義します。第1軸の方向が0度、第2軸が90度となる角度で指定します。第1軸はXY作業面ではX、YZ作業面ではY、ZX作業面ではZです。

  • コーナーの角度 - コーナーの両側の間の角度を定義します。

3軸レポートエリア

3 軸レポートを使用して3つの方法でXYZ点を定義できます。

  • 測定点または測定平面を選択して測定された要素の高さを定義します。

  • 使用する平面の方向性を有する高さを入力します。この高さはワークの原点に対するもので、プローブベクトルに沿って測定されます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

  1. プローブをコーナーの最初の辺の最初の点の近くに置き、位置読取りソフトキー [image] を押します。

  2. プローブをコーナーの最初の辺の2番目の点の近くに置き、位置読取りソフトキー [image] を押します。

  3. プローブをコーナーの2番目の辺の最初の点の近くに置き、位置読取りソフトキー [image] を押します。

  4. プローブをコーナーの2番目の辺の2番目の点の近くに置き、位置読取りソフトキー [image] を押します。

  5. プローブを測定を開始したい位置に動かし、コマンドのティーチングと作成ソフトキー [image] を押します。NC Gageは以下に示す図と同様な方法で測定点を自動的に取得します。

交点の測定(外側)の測定経路：青のA～Dはプローブを手動で動かす位置、赤の1～4は自動でプローブが動く位置を示します。赤線は測定パスを示します。

  6. 要素が測定されると測定値が更新されます。コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

NC Gageの具体的な動作について：

交点(外側)要素パスのティーチング

  • コーナーの最初の辺の最初の点に隣接するプローブの位置を読込みます。すべての測定はこの点のラインで取得されます。

  • プローブをコーナーの最初の辺の2番目の点の隣に置きます。

  • コーナーの2番目の辺の最初の点の隣でプローブの位置を読込みます。

  • コーナーの2番目の辺の2番目の点の隣のプローブの位置を読込みます。

  • 最初および2番目の方向ベクトルおよび法線ベクトルを定義します。

  • 補正ポイント。

  • おおよそのコーナー点を決めます。

  • 安全高さに移動します。

  • プローブを最初の読込み点の上方に置きます。

  • 測定高さに下降します。

  • 2番目の辺の表面に向かって測定します。深さは2番目の辺の最初の点と一致します。

  • それぞれにプロッブを二番目の赤いポイントに配置します。

  • 2番目の辺の表面に向かって測定します。深さは2番目の辺の最初の点と一致します。

  • コーナーを超えて点に移動して衝突を回避します。

  • プローブをおおよそ3番目の読込み点に置きます。

  • 2番目の辺の表面に向かって測定します。深さは最初の辺の最初の点と一致します。

  • プローブをおおよそ4番目の読込み点に置きます。

  • 2番目の辺の表面に向かって測定します。深さは最初の辺の最初の点と一致します。

交点(外側)要素パスの実行

  • プローブが安全高さより低い場合、安全高さまで上昇します。

  • 最初のアプローチ距離の点の上方に移動します。

  • 測定高さまで下降

  • 2番目の辺の表面に向かって測定します。深さは2番目の辺の最初の点と一致します。

  • プローブを2番目のアプローチ距離の点に置きます。

  • 2番目の辺の表面に向かって測定します。深さは2番目の辺の最初の点と一致します。

  • コーナーを超えて点に移動して衝突を回避します。

  • プローブを3番目のアプローチ距離の点に置きます。

  • 2番目の辺の表面に向かって測定します。深さは最初の辺の最初の点と一致します。

  • プローブを4番目の読込み点に置きます。

  • 安全高さの設定が有効である場合、点と点の間では安全高さに移動して次のアプローチ距離に到達します。

  • 2番目の辺の表面に向かって測定します。深さは最初の辺の最初の点と一致します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


交点(内側)

元の状態 > NC Gageの使用 > 要素コマンドの作成 > 交点(内側)

交点の測定 （内側）

交点(内側)コマンドを作成するには：

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 交点(内側) ソフトキー [image] を押して交点の測定(内側)画面を表示します：

  3. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。複数ステップを要するとき、測定および変更のためにプローブを移動する位置がグラフィカルに表示されます。

プロパティエリア

以下の3つのプロパティはオプション設定エリアでパラメータ入力によるティーチングがチェックされている時のみ使用できます：

  • 開始側オフセット - 最初の辺の測定位置を定義します。最初の辺の始点および終点が、測定するコーナーの設計上の位置から、開始角度の方向にどれだけ離れているか指定します。

  • 終了側オフセット - 2番目の辺の測定位置を定義します。2番目の辺の始点および終点が、指定するコーナーの設計上の位置から、開始角度とコーナーの角度を加えた方向にどれだけ離れているか指定します。

  • 最初の辺から時計回りに2番目の辺に移動 - デフォルトではNC Gage2番目の辺は最初の辺の反時計回り方向にあると予測します。NC Gageこのオプションを選択すると、2番目の辺が最初の辺に対して時計回りの方向にあると予想します。

パラメータエリア

  • アプローチ距離 - 実行時にワークから測定開始位置をどれだけ離すか指定します。プローブはこの距離を計測速度で移動します。

  • 検索距離 - ティーチングモード中にプローブが面を検索して移動する距離を定義します。(「オプション設定エリア」で説明するパラメータ入力によるティーチングを選択する場合は使用できません。)

オプション設定エリア

  • 安全高さの設定 - 実行時にプローブが各取込み点の間を安全高さまで移動します。右側の編集ボックスでユーザーは平面までの距離を入力できます。この平面は測定プログラムの安全高さではありません。詳細は安全高さの設定を参照してください。

  • ティーチングの後に測定をします - ティーチングした後に続けて要素を再測定します。この測定ではティーチングで測定したパラメータを使用します。これにより、すべての設定パラメータがテストされ、正確で信頼性の高い初回品質検査が提供されます。

  • パラメータ入力によるティーチング - これによって要素の設計値を入力し、その位置でソフトウェアに測定を行わせることができます。(これを選択するとプロパティエリアでの開始側オフセット、終了側オフセットおよび最初の辺から時計回りに2番目の辺に移動オプションが有効になり、パラメータエリアでの検索距離オプションが無効になります。)

パラメータエリア

  • XYZ設計値 - コーナーの設計上の位置を定義します。

  • XYZ実測値 - コーナーの測定された位置を表示します。

  • 開始角度 - コーナーの開始辺の角度を定義します。これは、その辺のX軸に対する方向です。

  • コーナーの角度 - コーナーの両側の間の角度を定義します。

3軸レポートエリア

3 軸レポートを使用して3つの方法でXYZ点を定義できます。

  • 測定点または測定平面を選択して測定された要素の高さを定義します。

  • 使用する平面の方向性を有する高さを入力します。この高さはワークの原点に対するもので、プローブベクトルに沿って測定されます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

  1. プローブをコーナーの最初の辺の最初の点の近くに置き、位置読取りソフトキー [image] を押します。

  2. プローブをコーナーの最初の辺の2番目の点の近くに置き、位置読取りソフトキー [image] を押します。

  3. プローブをコーナーの2番目の辺の最初の点の近くに置き、位置読取りソフトキー [image] を押します。

  4. プローブをコーナーの2番目の辺の2番目の点の近くに置き、位置読取りソフトキー [image] を押します。

  5. プローブを測定を開始したい位置に動かし、コマンドのティーチングと作成ソフトキー [image] を押します。NC Gageは以下に示す図と同様な方法で測定点を自動的に取得します。

交点の測定(内側)の測定経路：青のA～Dはプローブを手動で動かす位置、赤の1～4は自動でプローブが動く位置を示します。赤線は測定パスを示します。

  6. 要素が測定されると測定値が更新されます。コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。

NC Gageの具体的な動作について：

交点(内側) 要素パスのティーチング

  • コーナーの最初の辺の最初の点に隣接するプローブの位置を読込みます。すべての測定値はこの点と同じラインで取得されます。

  • プローブをコーナーの最初の辺の2番目の点の隣に置きます。

  • コーナーの2番目の辺の最初の点の隣でプローブの位置を読込みます。

  • コーナーの2番目の辺の2番目の点の隣のプローブの位置を読込みます。

  • 最初および2番目の方向ベクトルおよび法線ベクトルを定義します。

  • 補正ポイント。

  • おおよそのコーナー点を決めます。

  • プローブが安全高さより低い場合、安全高さに移動します。

  • プローブを最初読込み点の上方の点に置きます。

  • 測定高さへの下降

  • 最初の辺の表面に向かって測定します。検索距離は4*アプローチ距離です。

  • それぞれにプロッブを二番目の赤いポイントに配置します。

  • 最初の辺の表面に向かって測定します。検索距離は4*アプローチ距離です。

  • プローブをおおよそ3番目の読込み点に置きます。

  • 2番目の辺の表面に向かって測定します。検索距離は4*アプローチ距離です。

  • プローブをおおよそ4番目の読込み点に置きます。

  • 2番目の辺の表面に向かって測定します。検索距離は4*アプローチ距離です。

  • 安全高さに移動します。

交点(内側) 要素パスの実行

  • プローブが安全高さより低い場合、安全高さに移動します。

  • プローブを最初のアプローチ距離の位置の上方の点に置きます。

  • 測定高さへの下降

  • 最初の辺の表面に向かって測定します。検索距離は2*アプローチ距離です。

  • それぞれにプロッブを二番目の赤いポイントに配置します。

  • 最初の辺の表面に向かって測定します。検索距離は2*アプローチ距離です。

  • プローブをおおよそ3番目の読込み点に置きます。

  • 2番目の辺の表面に向かって測定します。検索距離は2*アプローチ距離です。

  • プローブをおおよそ4番目の読込み点に置きます。

  • 2番目の辺の表面に向かって測定します。検索距離は2*アプローチ距離です。

  • 安全高さの設定が有効である場合、点と点の間では安全高さに移動して次のアプローチ距離に到達します。

  • 安全高さに移動します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


平面

元の状態 > NC Gageの使用 > 要素コマンドの作成 > 平面

平面の測定

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 前へ ソフトキー [image] を押してソフトキーの2ページ目を表示します。

  3. 平面ソフトキー [image] を押すと、平面の測定画面が表示されます：

  4. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。複数ステップを要するとき、測定および変更のためにプローブを移動する位置がグラフィカルに表示されます。

プロパティエリア

測定方法エリアで格子パターンオプションが選択されたときのみ、以下の2つのプロパティを使用できます。

  • ライン数- 平面で計測される行数を定義します。

  • 1ライン毎の点数- 行(ライン)で測定される点数を提供します。

測定方法エリアで円パターンオプションが選択されたときのみ、以下のプロパティを使用できます。

  • 点数 - 平面を計測するのに使用される円パターンの周囲の点数を定義します。

以下のプロパティはオプション設定エリアでパラメータ入力によるティーチングチェックボックスが選択され、測定方法エリアで円パターンが選択されているときのみ使用できます。

  • 直径 - 測定方法用の円パターンの直径を定義します。

以下の2つのプロパティはオプション設定エリアでパラメータ入力によるティーチングチェックボックスが選択され、測定方法エリアで格子パターンが選択されているときのみ使用できます。

  • 長さ – これは最初の点から最後の点までの主軸に沿った距離です。第1軸はXY作業面ではX、YZ作業面ではY、ZX作業面ではZです。

  • 幅 – これは最初の点から最後の点までの第２軸に沿った距離です。第2軸はXY作業面ではY、YZ作業面ではZ、ZX作業面ではXです。

ライン数と1ライン毎の点数は定義された平面領域に沿って等間隔に配置されます。

パラメータエリア

  • アプローチ距離 - 実行時にワークから測定開始位置をどれだけ離すか指定します。プローブはこの距離を計測速度で移動します。

  • 検索距離 - 要素を検索およびティーチングするときの検索距離を定義します。(「オプション設定エリア」で説明するパラメータ入力によるティーチングを選択する場合は使用できません。)

オプション設定エリア

  • 安全高さの設定 - 実行時にプローブが各取込み点の間を安全高さまで移動します。チェックボックスにチェックを入れた後に、右側の編集ボックスに安全高さまでの距離を入力します。この平面は測定プログラムの安全高さではありません。詳細は安全高さの設定を参照してください。

  • ティーチングの後に測定をします - このオプションを選択すると、ティーチングをおこなった後、結果を元に連続して要素を再測定します。これにより、すべての設定パラメータがテストされ、正確で信頼性の高い初回品質検査が提供されます。

  • パラメータ入力によるティーチング - ユーザは要素の設計値を入力して、ソフトウェアはその位置で測定します。(このオプションは測定方法エリアで行った設定に応じて、プロパティおよびパラメータエリアでのその他のオプションを有効または無効にします。)

パラメータエリア

  • 設計値(XYZ設計値) - 平面の設計上の位置を定義します。

  • 実測値 (XYZ実測値) - 平面の測定された位置を表示します。

  • Z軸方向への角度 - 平面のZ方向の最初のベクトル角度を定義します。これは作業面に対する平面の法線方向です。有効な範囲は-90～+90 度です。

  • X軸方向への角度 - 平面のX方向のベクトル角度を定義します。これは測定される第1軸に対する平面の法線方向です。第1軸はXY作業面ではX、YZ作業面ではY、ZX作業面ではZです。有効な範囲は0(ゼロ)～ -360 度です。

Z方向への角度とX方向への角度が関連しています - 無効な値(90.0, 20.0) は (90.0, 0.0) と定義されます。

測定方法エリア

プロパティエリアのオプションは選択内容に応じて有効または無効になっています。詳しくは、「プロパティエリア」を参照してください。

  • 格子パターン - 平面を測定するときに格子形状による測定方法を定義します。

  • 円パターン - 平面を測定するときに円形状による測定方法を定義します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

格子パターンオプションを使用して通常に定義された作業面でティーチングするプロセス：

  1. 平面の測定画面の測定方法エリアから格子パターンを選択します。

  2. 定義しようとする平面で希望の作業面が設定されるまで、測定面の選択ソフトキーを [image] を押します (上部、左、前、後ろまたは斜面)。斜面が選択されている場合、測定面の選択ソフトキーが斜面ソフトキー [image] に変化します。詳しくは、「格子パターンオプションを使用して通常に定義された斜面作業面で平面をティーチングするプロセス」を参照してください。

選択された作業面は平面の法線と同じでなければなりません。

  3. 選択された作業面の適切な場所にプローブを動かして格子における2点がティーチングされます。平面を測定する表面の上にプローブを置きます。これは平面の最初のコーナーを示しています。

  4. 位置読取りソフトキー [image] を押します。平面要素における格子パターンの最初のコーナー座標としてルビー位置の値が読み込まれます。前のステップに戻る ソフトキー [image] を押すとこの測定位置がキャンセルされます。

  5. プローブを格子パターンの2番目のコーナーの上方に置きます。

  6. 位置読取りソフトキー [image] を押します。2番目のコーナーの座標としてルビー位置X/Yが読込まれます。前のステップに戻る ソフトキー [image] を押すとこの測定位置がキャンセルされます。選択された作業面での四角形の領域は、測定エリアを定義する機械座標におけるティーチングされた点とともに記録されます。

  7. コマンドのティーチングと作成ソフトキー [image] を押して、CNCでのモニタプログラムを実行します。４点が定義された格子のコーナー位置で自動的に計測されます。以下に、選択された- Y作業面、黄色のP1およびP2位置にある２つの計測点および赤色での計測パスを示します：

    2つのジョグ位置（ P1、 P2 ）、通常に定義された作業面および格子パターンを使用して平面を定義

要素がティーチングおよび測定されると実測値が更新され、測定が実際の平面の垂線に沿って行われます。

  8. コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。

格子パターンオプションを使用して通常に定義された斜面作業面で平面をティーチングするプロセス

  1. 平面の測定画面の測定方法エリアから格子パターンを選択します。

  2. 斜面アイコン [image] に変わるまで測定面の選択ソフトキー [image] を押します。

  3. 選択された作業面の適切な位置にプローブを移動して格子内の３点がティーチングされます。格子の最初のコーナー上にプローブを置きます。これは平面の最初のコーナーを示しています。位置読取りソフトキー [image] を押します。

  4. 格子の2番目のコーナーの上にプローブを置き、格子の2番目のコーナーを表示して位置読取りソフトキー [image] を押します。

  5. 格子の反対のコーナーの上にプローブを置き、位置読取りソフトキー [image] を押します。

  6. 表面上の四角形領域は、計測しようとする領域を定義するティーチングされた点とともに記録されます。コマンドのティーチングと作成ソフトキー [image] を押して、CNCでのモニタプログラムを実行します。黄色のP1、P2およびP3位置にある計測された3点および赤色での計測パスを使用して、下記に示すとおりに定義された格子のコーナー位置で4点が自動的に計測されます：

３つのジョグ位置（ P1, P2, P3）、斜面作業面と格子パターンを用いて平面を定義します。

計測後に中心、垂線および計測エリアの設計値が更新されます。平面がティーチングされると、測定が実際の平面の垂線に沿って行われます。

  7. コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。

円パターンオプションを使用して通常に定義された作業面で平面をティーチングするプロセス

  1. 平面の測定画面の測定方法エリアから円パターンを選択します。

  2. 定義される平面について希望の作業面が設定されるまで、測定面の選択ソフトキー [image] をを押します (上部、左、前、後ろまたは斜面)。斜面が選択されている場合、測定面の選択ソフトキーが斜面ソフトキー [image] に変化します。詳しくは、「円パターンオプションを使用して通常に定義された斜面作業面で平面をティーチングするプロセス」を参照してください。

選択された作業面は平面の法線と同じでなければなりません。

  3. 選択された作業面の適切な場所にプローブを移動して円における2点がティーチングされます。平面を測定する表面の上にプローブを置きます。これは円の直径の最初の点を示しています。

  4. 位置読取りソフトキー [image] を押します。 平面要素における円パターンの最初の辺の座標としてルビー位置の値が読込まれます。前のステップに戻るソフトキー [image] を押すとこの測定位置がキャンセルされます。

  5. 円の反対点の上にプローブを配置します。位置読取りソフトキー [image] を押します。作業面の円形の領域は、測定エリアを定義する機械座標の記憶された点で記録されます。前のステップに戻る ソフトキー [image] を押すとこの測定位置がキャンセルされます。

  6. コマンドのティーチングと作成ソフトキー [image] を押して、CNCでのモニタプログラムを実行します。これら2つの点を定義して円要素の限界を示し、NC Gageは、選択したY作業面、黄色のP1とP2の位置にある2つのプローブポイント、およびプロービングパスを赤で表示して、以下のように円内で自動的にプローブします：

    2つのジョグ位置（ P1、 P2 ）、通常に定義された作業面および円パターンを使用して平面を定義

計測後に、中心、垂線および計測領域の設計値が更新されます。要素が測定されると測定値がアップデートされます。すべての測定は実際の平面法線に沿って行われます。

  7. コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。

円パターンオプションを使用して通常に定義された斜面作業面で平面をティーチングするプロセス

  1. 平面の測定画面の測定方法エリアから円パターンを選択します。

  2. 測定面の選択ソフトキー [image] を斜面アイコン [image] に変わるまで押します。

  3. 円の３つの点が選択された作業面の適切な場所にプローブをジョギングで学習されます。円の始点の上にプローブを配置します。位置読取りソフトキー [image] を押します。

  4. 円の第２点の上にプローブを配置します。位置読取りソフトキー [image] を押します。

  5. 円の反対点の上にプローブを配置します。位置読取りソフトキー [image] を押します。表面の円形の領域は、測定エリアを定義する機械座標の記憶された点で記録されます。

  6. コマンドのティーチングと作成ソフトキー [image] を押して、CNCでのモニタプログラムを実行します。これら3つのポイントを定義して円要素の限界を示すと、NC Gageは、黄色のP1、P2、P3の位置にある3つのプローブポイントと赤のプロービングパスを使用して、以下に示すように円内を自動的にプローブします：

３つのジョグ位置（ P1, P2, P3）、斜面作業面および格子パターンを使用して平面を定義。

計測後に中心、垂線および計測エリアの設計値が更新されます。平面がティーチングされると、測定が実際の平面の垂線に沿って行われます。

  7. コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。

NC Gage

平面要素のティーチング手順 (格子パターン)

  • プローブを平面格子の最初のコナーに置きます。これはティーチングアプローチ距離の高さを定義します。

  • 平面格子の2番目のコーナーの上のプローブ位置を読込みます。

  • プローブが安全高さより低い場合、安全高さまで上昇します。

  • 最初の読込み点の上方の点に移動します。

  • 最初の読込み点まで下降します。

  • 表面を測定します。検索距離は4*アプローチ距離です。

  • 格子の各ラインに対して交互方向に格子における各点を測定します。

  • 安全高さまで上昇します。

平面要素のティーチング手順 (円パターン)

  • 平面円の最初の辺の上方のプローブ位置を読込みます。これはティーチングアプローチ距離の高さを定義します。

  • 円パターンの反対側の点の上方のプローブ位置を読込みます。

  • プローブが安全高さより低い場合、安全高さまで上昇します。

  • 最初の読込み点の上方の点に移動します。

  • 最初の読込み点まで下降します。

  • 表面を測定します。検索距離は4*アプローチ距離です。

  • 円パターンの各点を測定します。

  • 安全高さまで上昇します。

平面要素の測定手順 (格子パターン)

  • プローブが安全高さより低い場合、安全高さまで上昇します。

  • 格子の最初の点の上方の点に移動します。

  • 設計上の平面の上のアプローチ距離まで下降します。

  • 表面を測定します。検索距離は2*アプローチ距離です。

  • 格子の各ラインに対して交互方向に格子における各点を測定します。

  • 安全高さの設定が有効である場合、点と点の間では安全高さに移動して次のアプローチ距離に到達します。

  • 安全高さまで上昇します。

平面要素の測定手順 (円パターン)

  • プローブが安全高さより低い場合、安全高さまで上昇します。

  • 円の最初の点の上方の点に移動します。

  • 設計上の平面の上のアプローチ距離まで下降します。

  • 表面を測定します。検索距離は2*アプローチ距離です。

  • 円パターンの各点を反時計回りに測定します。

  • 安全高さの設定が有効である場合、点と点の間では安全高さに移動して次のアプローチ距離に到達します。

  • 安全高さまで上昇します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


直線

元の状態 > NC Gageの使用 > 要素コマンドの作成 > 直線

線の測定

線コマンドを作成するには：

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 前へ ソフトキー [image] を押してソフトキーの2ページ目を表示します。

  3. 線の測定ソフトキー [image] を押して線の測定画面を表示します：

  4. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。複数ステップを要するとき、測定および変更のためにプローブを移動する位置がグラフィカルに表示されます。

プロパティ定義エリア

  • 点数 - 実行中に線に対してプローブを移動する点数を定義します。

以下の2つのプロパティはオプション設定エリアのパラメータ入力によるティーチングチェックボックスが選択されているときにのみ表示されます：

  • 長さ - 線の長さを定義します。

  • 右側の面を測定 - ワークの位置をパラメータエリアのX, Y, Zで設定した設計上の点からX軸方向への角度の方向に向かって右側にあると判断します。これにより、測定時のプローブの移動方向が決定されます。測定する要素が線の「左」側にあるようにしたい場合は、このボックスのチェックを外します。

パラメータエリア

  • アプローチ距離 - 実行時にワークから測定開始位置をどれだけ離すか指定します。プローブはこの距離を計測速度で移動します。

  • 検索距離 - 測定開始点から何ミリ検索動作を行うかを設定します。(「オプション設定エリア」で説明するパラメータ入力によるティーチングを選択する場合は使用できません。)

オプション設定エリア

  • 安全高さの設定 - 実行時にプローブが各取込み点の間を安全高さまで移動します。チェックボックスにチェックを入れた後に、右側の編集ボックスに安全高さまでの距離を入力します。この平面は測定プログラムの安全高さではありません。詳細は安全高さの設定を参照してください。

  • ティーチングの後に測定をします - このオプションを選択すると、ティーチングをおこなった後、結果を元に連続して要素を再測定します。これにより、すべての設定パラメータがテストされ、正確で信頼性の高い初回品質検査が提供されます。

  • パラメータ入力によるティーチング - 入力された要素の設計値を使用して測定をします。(このオプションは「プロパティ」エリアに記載する追加プロパティを有効にし、「パラメータ」エリアに記載する検索距離オプションを無効にします。)

パラメータエリア

  • XYZ 設計値 - 開始点の設計上の位置を定義します。

  • XYZ 実測値 - 開始点の測定された位置を表示します。

  • X軸方向への角度 - 線のベクトル角度を定義します。これはＸ軸に対する線の方向です。

3軸レポートエリア

3 軸レポートを使用して3つの方法でXYZ点を定義できます。

  • 測定点または測定平面を選択して測定された要素の高さを定義します。

  • 使用する平面の方向性を有する高さを入力します。この高さはワークの原点に対するもので、プローブベクトルに沿って測定されます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

  1. 下記画像における位置Aによって示されるとおり、線の最初の点の隣にプローブを置きます。

  2. 位置読取り ソフトキー [image] を押します。このルビー位置が開始位置として読込まれます。前のステップに戻るソフトキー [image] を押すとこの測定位置がキャンセルされます。

  3. 下図の点Bで示すようにプローブを線の2番目の点の隣に置きます。

  4. 位置読取り ソフトキー [image] を押します。このルビー位置が開始位置として読込まれます。前のステップに戻るソフトキー [image] を押すとこの測定位置がキャンセルされます。

  5. プローブを２番目の点から移動します。

  6. 位置読取り ソフトキー [image] を押します。

  7. プローブを自動測定用に配置し、コマンドのティーチングと作成 ソフトキー [image] を押します。NC Gageは以下に示すのと同様な方法で測定点を自動的に取得します。

左の画像に手動でプローブを移動しなければならないジョグ位置(A-C)を示します。右の画像には自動プローブ移動パス（赤線）と点位置(1-2)を示します。

  8. 要素が測定されると測定値が更新されます。コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。

NC Gage

線要素パスのティーチング

  • 最初の点の隣にあるプローブ位置を読み込みます。これは測定の高さを定義します。

  • 2番目の点の上にあるプローブ位置を読み込みます。これは線の方向を定義します。

  • 線から引き離されるプローブ位置を読み込みます。これは素材の方向を定義します。

  • プローブが安全高さより下にある場合、安全高さまで移動します。

  • 最初の読込み点の上方の点に移動します。

  • 最初の読込み点まで下降します。

  • 表面を測定します。検索距離は4*アプローチ距離です。

  • 同様に線で各点を測定します。

  • 安全高さまで上昇します。

線要素パスの実行

  • プローブが安全高さより下にある場合、安全高さまで移動します。

  • 最初のアプローチ距離の上方の点に移動します。

  • 最初のアプローチ距離まで下降します。

  • 表面を測定します。検索距離は2*アプローチ距離です

  • 同様に線で各点を測定します。

  • 安全高さの設定が有効である場合、点と点の間では安全高さに移動して次のアプローチ距離に到達します。

  • 安全高さまで上昇します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


円筒(内側)

元の状態 > NC Gageの使用 > 要素コマンドの作成 > 円筒(内側)

円筒の測定 （内側）

円筒(内側)コマンドを作成するには：

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 前へ ソフトキー [image] を押してソフトキーの2ページ目を表示します。

  3. 円筒(内側)ソフトキー [image] を押して円筒の測定(内側)画面を表示します：

  4. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。複数ステップを要するとき、測定および変更のためにプローブを移動する位置がグラフィカルに表示されます。

プロパティエリア

  • 1ライン毎の点数 - 実行中に(ティーチングモードではなく)、円筒に対して計測が行われるラインごとのポイント数を定義します。

  • ライン数 - 実行中に(ティーチングモードではなく)、円筒に対して計測を行うライン数を定義します。

  • 開始角度 - 測定する円筒の断面における円の測定で、始点を中心からの方向で定義します。回転が第1軸に沿った0で始まり、90が第2軸にあるように移動します。第1軸はXY作業面ではX、YZ作業面ではY、ZX作業面ではZです。第2軸はXY作業面ではY、YZ作業面ではZ、ZX作業面ではZです。

  • 終了角度 - 測定する円の終点を定義します。開始角度と同様の角度で指定します。ティーチングモードでは第1軸および第2軸方向の反対側に取込み点が自動的に取得されます。円筒が360度連続していない場合、パラメータ入力によるティーチング使用して適切な開始角度と終了角度を定義して測定することが可能です。ここで、ティーチングの後に測定をしますを選択するとNC Gageは要素を測定します。

以下の2つのプロパティはオプション設定エリアでパラメータ入力によるティーチングがチェックされている時のみ使用できます。

  • 上面ライン － 円筒測定の上部における取込み点の軸位置です。円筒の中心線は、現在のワークオフセットに関連します。

  • 底面ライン -円筒測定の下部における取込み点の軸位置です。円筒の中心線は、現在のワークオフセットに関連します。

ライン数と1ライン毎の点数は定義された円筒に沿って等間隔に配置されます。

パラメータエリア

  • アプローチ距離 - 実行時にワークから測定開始位置をどれだけ離すか指定します。プローブはこの距離を計測速度で移動します。

  • 検索距離 - ティーチング時に検索開始点からワークに向かって最大でどれだけ移動するか指定します。この距離を超えた位置に測定する要素がある場合、ティーチングは失敗します。(「オプション設定エリア」で説明するパラメータ入力によるティーチングを選択する場合は使用できません。)

オプション設定エリア

  • 安全高さの設定 - 実行時にプローブが各取込み点の間を安全高さまで移動します。チェックボックスにチェックを入れた後に、右側の編集ボックスに安全高さまでの距離を入力します。この平面は測定プログラムの安全高さではありません。詳細は安全高さの設定を参照してください。

  • ティーチングの後に測定をします - ティーチングした後に続けて要素を再測定します。この測定ではティーチングで測定したパラメータを使用します。これにより、すべての設定パラメータがテストされ、正確で信頼性の高い初回品質検査が提供されます。

  • パラメータ入力によるティーチング - 入力された要素の設計値を使用して測定をします。(これを選択した場合、「プロパティエリア」の上面ライン、底面ラインが有効になります。)

パラメータエリア

  • XYZ設計値 - 円筒の設計上の位置を定義します。

  • XYZ実測値 - 円筒の測定された位置を表示します。

  • 直径 (設計値) - 円筒の直径(設計値)を定義します。

  • 直径 (実測値) - 測定された円筒の直径が表示されます。

  • Z軸方向への角度- 円筒の最初のベクトル角度を定義します。これは作業面に対する円筒の中心線方向です。有効な範囲は-90～+90 度です。

  • X軸方向への角度 - 円筒の2番目のベクトル角度を定義します。測定される主軸に対する円筒の中心線の方向です。第1軸はXY作業面ではX、YZ作業面ではY、ZX作業面ではZです。有効な範囲は0(ゼロ)～ -360 度です。

Z軸方向への角度とX軸方向への角度は関連しています。(90.0, 20.0)は無効とみなされ、(90.0, 0.0)として定義されます。

3軸レポートエリア

3軸レポートを使用して、3つの方法で XYZ点を定義できます。

  • 測定点または測定平面を選択して測定された要素の高さを定義します。

  • 使用する平面の方向性を持つ高さを入力します。この高さはワークの原点に対するもので、プローブベクトルに沿って測定されます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

2点ティーチング(小径用)

  1. 以下の画像のAで示す通り、プローブを(ワーク表面から離れた)円筒上面の中心に置きます。

  2. 位置読取り ソフトキー [image] を押します。

  3. プローブを底面ラインの中心に置き、位置読取りソフトキー [image] を押します。

  4. コマンドのティーチングと作成ソフトキー [image] を押します。NC Gageは以下に示す図と同様な方法で測定点を自動的に取得します。

円筒の測定(内側)の測定経路：青のAとBはプローブを手動で動かす位置、赤の1～4は自動でプローブが動く位置を示します。赤線は測定パスを示します。

  5. 測定が終わるとNC Gageは測定値を更新します。コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。

3点ティーチング(大径用)

  1. プローブを測定したい範囲の最上面中心に置き、位置読取りソフトキー [image] を押します。

  2. 下図のBで示すとおりに、プローブを測定したい範囲の最下面中心に置きます。

  3. 位置読取り ソフトキー [image] を押します。

  4. プローブを最下面中心から穴の側面付近に動かし、位置読取りソフトキー [image] を押します。

  5. コマンドのティーチングと作成ソフトキー [image] を押します。NC Gage は以下に示す図と同様な方法で測定点を自動的に取得します。

円筒の測定(内側)の測定経路：青のA～Cはプローブを手動で動かす位置、赤の1～3は自動でプローブが動く位置を示します。赤線は測定パスを示します。

  6. 測定が終わるとNC Gageは測定値を更新します。コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。

NC Gage

ティーチング(小径円筒用)の経路

  • 円筒上面の中心でプローブの位置を読込みます。これが実行時、最後に測定する高さとなります。

  • 円筒内側の下面ライン中心でプローブの位置を読取る。これは円筒内側の中心、および最初のライン高さを定義します。これが実行時、最初に測定する高さとなります。

  • 検索距離を使用して+ X 方向へ点を測定します。

  • 中央位置に戻ります。

  • 検索距離を使用して－X 方向へ点を測定します。

  • 中央位置に戻ります。

  • 検索距離を使用して+Y 方向へ点を測定します。

  • 中央位置に戻ります。

  • 検索距離を使用して－Y 方向へ点を測定します。

  • 中央位置に戻ります。

ティーチング(大径円筒用)の経路

  • 円筒上面の中心でプローブの位置を読込みます。これが実行時、最後に測定する高さとなります。

  • 円筒底面の中心でプローブの位置を読込みます。これが実行時、最初に測定する高さとなります。

  • 円筒底面の外周でプローブの位置を読込みます。

  • 検索距離を使用して、円筒底面の中心から外周方向へ点を測定します。

  • 外周位置に戻ります。

  • 検索距離を使用して、円筒底面の中心から外周方向に垂直な向きへ点を測定します。

  • 外周位置に戻ります。

  • 検索距離を使用して、円筒底面の中心から外周方向に垂直な別の向きへ点を測定します。

  • 外周位置に戻ります。

円筒内側要素パスの実行

  • アプローチ距離 = 内径 - アプローチ距離 – プローブ半径と定義します。

  • ターゲット半径 = 内径 + アプローチ距離 – プローブ半径と定義します。

  • 現在の位置が安全高さより低い場合、安全高さまで上昇します。

  • 最初のアプローチ距離の点の上方に移動します。この点は開始角度の方向に内径の中心からアプローチ距離だけ離れています。

  • 最下面の測定ラインまで下降します。

  • 測定点、ターゲットは角度に沿った内径の中心からのターゲット半径です。

  • 後退して次の点のアプローチ距離に移動します。

  • 測定点、ターゲットは角度に沿った内径の中心からのターゲット半径です。

  • 開始角度から終了角度まで指定された数の点を測定し続けます。

  • その他のレベルを測定し、交互の方向に点を測定します。

  • 安全高さの設定が有効である場合、点と点の間では安全高さに移動して次のアプローチ距離に到達します。

  • 最後の点を測定するとプローブは安全高さまで上昇します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


円筒(外側)

元の状態 > NC Gageの使用 > 要素コマンドの作成 > 円筒(外側)

円筒の測定 （外側）

円筒(外側)コマンドを作成するには：

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 前へ ソフトキー [image] を押してソフトキーの2ページ目を表示します。

  3. 円筒(外側)ソフトキー [image] を押して円筒の測定(外側)画面を表示します：

  4. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。複数ステップを要するとき、測定および変更のためにプローブを移動する位置がグラフィカルに表示されます。

プロパティエリア

  • 1ライン毎の点数 - 実行中に(ティーチングモードではなく)、円筒に対して計測が行われるレベルごとのポイント数を定義します。

  • ライン数 - 実行中に(ティーチングモードではなく)、円筒に対して計測を行うライン数を定義します。

  • 開始角度 - 測定する円筒の断面における円の測定で、始点を中心からの方向で定義します。回転が第1軸に沿った0で始まり、90が第2軸にあるように移動します。第1軸はXY作業面ではX、YZ作業面ではY、ZX作業面ではZです。第2軸はXY作業面ではY、YZ作業面ではZ、ZX作業面ではXです。

  • 終了角度 - 測定する円の終点を定義します。開始角度と同様の角度で指定します。ティーチングモードでは第1軸および第2軸方向の反対側に取込み点が自動的に取得されます。円筒が360度連続していない場合、パラメータ入力によるティーチング使用して適切な開始角度と終了角度を定義して測定することが可能です。ここで、ティーチングの後に測定をしますを選択するとNC Gageは要素を測定します。

以下の2つのプロパティはオプション設定エリアでパラメータ入力によるティーチングがチェックされている時のみ使用できます。

  • 上面ライン － 円筒測定の最上部にある取込み点の軸位置を定義するのに使用します。円筒の中心線は、現在のワークオフセットに関連します。

  • 底面ライン - 円筒測定の最下部における取込み点の軸位置を定義するのに使用します。円筒の中心線は、現在のワークオフセットに関連します。

ライン数と1ライン毎の点数は定義された円筒に沿って等間隔に配置されます。

パラメータエリア

  • アプローチ距離 - 実行時にワークから測定開始位置をどれだけ離すか指定します。プローブはこの距離を計測速度で移動します。

  • 検索距離 - ティーチング時に検索開始点からワークに向かって最大でどれだけ移動するか指定します。この距離を超えた位置に測定する要素がある場合、ティーチングは失敗します。(「オプション設定エリア」で説明するパラメータ入力によるティーチングを選択する場合は使用できません。)

オプション設定エリア

  • 安全高さの設定 - 実行時にプローブが各取込み点の間を安全高さまで移動します。チェックボックスにチェックを入れた後に、右側の編集ボックスに安全高さまでの距離を入力します。この平面は測定プログラムの安全高さではありません。詳細は安全高さの設定を参照してください。

  • ティーチングの後に測定をします - ティーチングした後に続けて要素を再測定します。この測定ではティーチングで測定したパラメータを使用します。これにより、すべての設定パラメータがテストされ、正確で信頼性の高い初回品質検査が提供されます。

  • パラメータ入力によるティーチング - 入力された要素の設計値を使用して測定をします。(これを選択した場合、「プロパティエリア」の上面ライン、底面ラインが有効になります。)

パラメータエリア

  • XYZ設計値 - 円筒の設計上の位置を定義します。

  • XYZ実測値 - 円筒の測定された位置を表示します。

  • 直径 (設計値) - 円筒の直径(設計値)を定義します。

  • 直径 (実測値) - 測定された円筒の直径が表示されます。

  • Z軸方向への角度- 円筒の最初のベクトル角度を定義します。これは作業面に対する円筒の中心線方向です。有効な範囲は-90～+90 度です。

  • X軸方向への角度 - 円筒の2番目のベクトル角度を定義します。測定される主軸に対する円筒の中心線の方向です。第1軸はXY作業面ではX、YZ作業面ではY、ZX作業面ではZです。有効な範囲は0(ゼロ)～ -360 度です。

Z軸方向への角度とX軸方向への角度は関連しています。(90.0, 20.0)は無効とみなされ、(90.0, 0.0)として定義されます。

3軸レポートエリア

3軸レポートを使用して、3つの方法で XYZ点を定義できます。

  • 測定点または測定平面を選択して測定された要素の高さを定義します。

  • 使用する平面の方向性を有する高さを入力します。この高さはワークの原点に対するもので、プローブベクトルに沿って測定されます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

  1. 底部ラインの表面の近くにプローブを置き、位置読取りソフトキー [image] を押します。これが「底面」ラインに対する位置になります。

  2. 上面ラインの表面の近くにプローブを置き、位置読取りソフトキー [image] を押します。これが「上面」ラインに対する位置になります。

  3. プローブを外径の中心の上の安全な高さに置き、位置読取りソフトキー [image] を押します。

  4. コマンドのティーチングと作成ソフトキー [image] を押します。NC Gageはこの位置で1つの取込み点を取得し、外径の高さを決定します。次に、以下に示すのと同様な方法で取込み点を自動的に取得します。

円筒の測定(外側)の測定経路：青のA～Cはプローブを手動で動かす位置、赤の1～4は自動でプローブが動く位置を示します。赤線は底面ラインのパスを示しています。上面ラインは同様のパスラインで測定されます。

  5. 要素が測定されると測定値が更新されます。コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。

NC Gageの具体的な動作について：

円筒の外側要素パスのティーチング

  • 最下部ラインにおける外側に隣接したプローブの位置を読み取ります。Z値は最初のラインの測定高さになります。

  • プローブの位置読取が最高レベル両方辺の隣に、Z値が最後レベルの測量高さになります。この高さも円筒の学習に使用されます。

  • 外径の中心の上方にあるプローブの位置を読み取ります。XYは中心を定義し、Zは安全高さです。

  • アプローチ距離 = 1番目および3番目の読込み点の間の投影された2次元距離。

  • 安全高さに移動します。

  • 安全高さでアプローチ距離1(+Xにおける中心からのアプローチ距離)の上方の点に移動します。

  • 測定高さまで下降します。

  • 点を測定します。ターゲットは測定高さでの中心です。

  • 安全高さに移動します。

  • 安全高さでアプローチ距離2(-Xにおける中心からのアプローチ距離)の上方の点に移動します。

  • 測定高さまで下降します。

  • 点を測定します。ターゲットは測定高さでの中心です。

  • 安全高さに移動します。

  • 安全高さでアプローチ距離3(+Yにおける中心からのアプローチ距離)の上方の点に移動します。

  • 測定高さまで下降します。

  • 点を測定します。ターゲットは測定高さでの中心です。

  • 安全高さに移動します。

  • 安全高さでアプローチ距離4(-Yにおける中心からのアプローチ距離)の上方の点に移動します。

  • 測定高さまで下降します。

  • 点を測定します。ターゲットは測定高さでの中心です。

  • 安全高さに移動します。

円筒外側要素パスの実行

  • アプローチ距離 = 外径 + アプローチ距離 + プローブ半径を定義します。

  • ターゲット半径 = 外径 - アプローチ距離 – プローブ半径と定義します。これが0より小さい場合は0に設定します。

  • 現在の位置が安全高さより低い場合、安全高さまで上昇します。

  • 最初のアプローチ距離の点の上方に移動します。この点は開始角度の方向に外径からのアプローチ距離です。

  • 測定ラインまで下降します。

  • アプローチ距離とターゲット半径を使用して最下部ラインを測定します。各アプローチ距離に到達するために必要な場合は余分に移動して外径の周辺に到達し、最終角度に達するまで継続します。

  • 交互の方向に残りのラインを測定します。

  • 安全高さの設定が有効である場合、点と点の間では安全高さに移動して次のアプローチ距離に到達します。

  • 最後の点を測定するとプローブは安全高さまで上昇します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


円錐(内側)

元の状態 > NC Gageの使用 > 要素コマンドの作成 > 円錐(内側)

円錐の測定 （内側）

円錐(内側)コマンドを作成するには：

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 前へ ソフトキー [image] を押してソフトキーの2ページ目を表示します。

  3. 円錐(内側)ソフトキー [image] を押して円錐の測定(内側)画面を表示します：

  4. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。複数ステップを要するとき、測定および変更のためにプローブを移動する位置がグラフィカルに表示されます。測定面の選択に関しては点の測定の記述を参照してください。

プロパティエリア

  • ラインごとのポイント - 実行中に(ティーチングモードではなく)、円錐に対して計測が行われるラインごとのポイント数を定義します。

  • ライン数 - 実行中（ティーチングモードではありません）に測定する、円錐の測定における断面の数を定義します。

  • 開始角度 - 測定される円錐のセクションの開始点を定義します。回転が第1軸に沿った0で始まり、90が第2軸にあるように移動します。第1軸はXY作業面ではX、YZ作業面ではY、ZX作業面ではZです。第2軸はXY作業面ではY、YZ作業面ではZ、ZX作業面ではXです。

  • 終了角度 - 測定する円の終点を定義します。開始角度と同様の角度で指定します。ティーチングモードでは第1軸および第2軸方向の反対側に取込み点が自動的に取得されます。円錐が360度続かない場合、パラメータ入力によるティーチングを使い適切な開始角と終了角を定義して設計上の位置を入力できます。ここで、ティーチングの後に測定をしますを選択するとNC Gageは要素を測定します。

以下の2つのプロパティはオプション設定エリアでパラメータ入力によるティーチングがチェックされている時のみ使用できます。

  • 上面ライン - 円錐の測定の上面での取込み点の軸位置です。これは円錐の中心線と最も近くに整列した軸に沿った現在のワークオフセットに関連します。

  • 底面ライン - 円錐の測定の底面での取込み点の軸位置です。これは円錐の中心線と最も近くに整列した軸に沿った現在のワークオフセットに関連します。

ライン数と1ライン毎の点数は定義された円錐に沿って等間隔に配置されます。

パラメータエリア

  • アプローチ距離 - 実行時にワークから測定開始位置をどれだけ離すか指定します。プローブはこの距離を計測速度で移動します。

  • 検索距離 - ティーチング時に検索開始点からワークに向かって最大でどれだけ移動するか指定します。この距離を超えた位置に測定する要素がある場合、ティーチングは失敗します。(「オプション設定エリア」で説明する パラメータ入力によるティーチングを選択する場合は使用できません。)

オプション設定エリア

  • 安全高さの設定 - 実行時にプローブが各取込み点の間を安全高さまで移動します。チェックボックスにチェックを入れた後に、右側の編集ボックスに安全高さまでの距離を入力します。この平面は測定プログラムの安全高さではありません。詳細は安全高さの設定を参照してください。

  • ティーチングの後に測定をします - ティーチングした後に続けて要素を再測定します。この測定ではティーチングで測定したパラメータを使用します。これにより、すべての設定パラメータがテストされ、正確で信頼性の高い初回品質検査が提供されます。

  • パラメータ入力によるティーチング - 入力された要素の設計値を使用して測定をします。(これを選択した場合、「プロパティエリア」の上面ライン、底面ラインが有効になります。)

パラメータエリア

  • XYZ設計値 - 円錐の中心の設計上の位置を定義します。

  • XYZ実測値 - 円錐の測定された位置を表示します。

  • 半角の角度 - 円錐の側面と円錐の中心線が作る角度を表示します。

  • Z軸方向への角度 - 円錐の最初のベクトル角度を定義します。これは作業平面に対する円錐の中心線の方向です。有効な範囲は-90～+90 度です。

  • X軸方向への角度 - 円筒の2番目のベクトル角度を定義します。測定される主軸に対する円錐の中心線の方向です。第1軸はXY作業面ではX、YZ作業面ではY、ZX作業面ではZです。有効な範囲は0(ゼロ)～ -360 度です。

Z軸方向への角度とX軸方向への角度は関連しています。(90.0, 20.0)は無効とみなされ、(90.0, 0.0)として定義されます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

  1. プローブを底面の中心に置き、位置読取りソフトキー [image] を押します。底面ラインは頂点に最も近いラインです。

  2. プローブを上面ラインの中心に置き、位置読取りソフトキー [image] を押します。

  3. プローブを測定を開始したい位置に動かし、コマンドのティーチングと作成ソフトキー [image] を押します。NC Gageは以下に示す図と同様な方法で測定点を自動的に取得します。

円錐の測定(内側)の測定経路：青のAとBはプローブを手動で動かす位置、赤の1～8は自動でプローブが動く位置を示します。

  4. 要素が測定されると測定値が更新されます。コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。

NC Gageの具体的な動作について：

内側円錐要素パスのティーチング

  • 円錐の下面ラインの中心でプローブの位置を読み込みます。これは円錐のXY中心と実行時の最初のライン高さを定義します。

  • 内側上面ラインの中心でプローブの位置を読み込みます。これは実行時の最終のライン高さを定義します。

  • 最初の読込み位置に移動します。

  • +X、-X、+Yおよび ‐Y方向に点を取得して最下面ラインを測定し、各測定後に下面の中心に戻ります。

  • 上面ラインの中央に移動します。

  • +X、-X、+Y、および ‐Y方向に点を取得して上面ラインを測定し、各測定後に上面の中心に戻ります。

内側円錐要素パスの実行

  • 円錐の形状によって各測定点のアプローチ距離とターゲット位置が決まります。

  • 現在の位置が安全高さより低い場合、安全高さまで上昇します。

  • 最初のアプローチ距離の点の上方に移動します。この点は開始角度の方向に内径の中心からアプローチ距離だけ離れています。

  • 最下面の測定ラインまで下降します。

  • 開始角度から終了角度まで、最初のラインを測定します。

  • 交互の方向に残りのラインを測定します。

  • 安全高さの設定が有効である場合、点と点の間では安全高さに移動して次のアプローチ距離に到達します。

  • 最後の点を測定するとプローブは安全高さまで上昇します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


円錐(外側)

元の状態 > NC Gageの使用 > 要素コマンドの作成 > 円錐(外側)

円錐の測定 （外側）

円錐(外側)コマンドを作成するには：

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 前へ ソフトキー [image] を押してソフトキーの2ページ目を表示します。

  3. 円錐(外側)ソフトキー [image] を押して円錐の測定(外側)画面を表示します：

  4. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。複数ステップを要するとき、測定および変更のためにプローブを移動する位置がグラフィカルに表示されます。

プロパティエリア

  • 1ライン毎の点数 - 実行中に(ティーチングモードではなく)、円錐に対して計測が行われるレベルごとのポイント数を定義します。

  • ライン数 - 実行中（ティーチングモードではありません）に測定する、円錐の測定における断面の数を定義します。

  • 開始角度 - 測定する円筒の断面における円の測定で、始点を中心からの方向で定義します。回転が第1軸に沿った0で始まり、90が第2軸にあるように移動します。第1軸はXY作業面ではX、YZ作業面ではY、ZX作業面ではZです。第2軸はXY作業面ではY、YZ作業面ではZ、ZX作業面ではXです。

  • 終了角度 - 測定する円の終点を定義します。開始角度と同様の角度で指定します。ティーチングモードでは第1軸および第2軸方向の反対側に取込み点が自動的に取得されます。円錐が360度続かない場合、パラメータ入力によるティーチングを使い適切な開始角と終了角を定義して設計上の位置を入力できます。ここで、ティーチングの後に測定をしますを選択するとNC Gageは要素を測定します。

以下の2つのプロパティはオプション設定エリアでパラメータ入力によるティーチングがチェックされている時のみ使用できます。

  • 上面ライン - 円錐の測定の上面での取込み点の軸位置です。これは円錐の中心線と最も近くに整列した軸に沿った現在のワークオフセットに関連します。

  • 底面ライン - 円錐の測定の底面での取込み点の軸位置です。これは円錐の中心線と最も近くに整列した軸に沿った現在のワークオフセットに関連します。

ライン数と1ライン毎の点数は定義された円錐に沿って等間隔に配置されます。

パラメータエリア

  • アプローチ距離 - 実行時にワークから測定開始位置をどれだけ離すか指定します。プローブはこの距離を計測速度で移動します。

  • 検索距離 - ティーチングモード中にプローブがワークを検索するために使用する距離を定義します。(「オプション設定エリア」で説明するパラメータ入力によるティーチングを選択する場合は使用できません。)

オプション設定エリア

  • 安全高さの設定 - 実行時にプローブが各取込み点の間を安全高さまで移動します。チェックボックスにチェックを入れた後に、右側の編集ボックスに安全高さまでの距離を入力します。この平面は測定プログラムの安全高さではありません。詳細は安全高さの設定を参照してください。

  • ティーチングの後に測定をします - ティーチングした後に続けて要素を再測定します。この測定ではティーチングで測定したパラメータを使用します。これにより、すべての設定パラメータがテストされ、正確で信頼性の高い初回品質検査が提供されます。

  • パラメータ入力によるティーチング - 入力された要素の設計値を使用して測定をします。(これを選択した場合、「プロパティエリア」の上面ライン、底面ラインが有効になります。)

パラメータエリア

  • XYZ設計値 - 円錐中心の設計上の位置を定義します。

  • XYZ実測値 - 円錐の測定さえれた位置を表示します。

  • 半角の角度 - 円錐の側面と円錐の中心線が作る角度を定義します。

  • Z軸方向への角度 - 円錐の最初のベクトル角度を定義します。これは作業平面に対する円錐の中心線の方向です。有効な範囲は-90～+90 度です。

  • X軸方向への角度 - 円筒の2番目のベクトル角度を定義します。測定される主軸に対する円筒の中心線の方向です。第1軸はXY作業面ではX、YZ作業面ではY、ZX作業面ではZです。有効な範囲は0(ゼロ)～ -360 度です。

Z軸方向への角度とX軸方向への角度は関連しています。(90.0, 20.0)は無効とみなされ、(90.0, 0.0)として定義されます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

  1. プローブを底面ラインの表面近くにプローブを置き、位置読取りソフトキー [image] を押します。底面ラインは頂点から最も離れたラインです。

  2. プローブを上面ラインの表面近くにプローブを置き、位置読取りソフトキー [image] を押します。

  3. プローブを円錐頂点の上に置き、位置読取りソフトキー [image] を押します。

  4. プローブを測定を開始したい位置に動かし、[コマンドのティーチングと作成]ソフトキー [image] を押します。NC Gageは以下に示す図と同様な方法で測定点を自動的に取得します。

円錐の測定(外側)の測定経路：青のA～Cはプローブを手動で動かす位置、赤の1～8は自動でプローブが動く位置を示します。赤線は底面ラインのパスを示しています。上面ラインは同様のパスラインで測定されます。

  5. 要素が測定されると測定値が更新されます。コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。

NC Gageの具体的な動作について：

外側円錐要素パスのティーチング

  • プローブの位置読取が最低レベル円錐側の隣に、これは円錐XYセンタと実行時の最初レベルの高さを定義します。

  • 最上面ラインにある円錐の側面に隣接したプローブの位置を読込みます。Z値が最終ラインの測定高さになります。

  • 円錐の中心の上方にあるプローブの位置を読込みます。XYは中心を定義し、Zは安全高さです。

  • 安全高さに移動します。

  • アプローチ距離 = 1番目および3番目の読込み点の間の投影された2次元距離。これを使用して両方のラインをティーチングします。

  • +X, -X, +Yおよび -Y 方向に点を取得して最下面レベルを測定します。プローブは測定と測定の間には安全高さに移動します。

  • 安全高さに戻ります。

  • +X, -X, +Yおよび -Y 方向に点を取得して最上面ラインを測定し、プローブは測定と測定の間には安全な高さに移動します。

  • 安全高さに戻ります。

外側円錐要素パスの実行

  • 円錐の形状によって各測定点のアプローチ距離とターゲット位置が決まります。

  • 現在の位置が安全高さより低い場合、安全高さまで上昇します。

  • 最初のアプローチ距離の点の上方に移動します。

  • 最下面の測定ラインまで下降します。

  • 開始角度から終了角度まで、最下面ラインを測定します。必要な場合は各点間で回避動作を行って衝突を回避します。

  • 交互の方向に残りのラインを測定します。

  • 安全高さの設定が有効である場合、点と点の間では安全高さに移動して次のアプローチ距離に到達します。

  • 最後の点を測定したらプローブは安全高さまで上昇します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


球

元の状態 > NC Gageの使用 > 要素コマンドの作成 > 球

球の測定

球コマンドを作成するには：

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 前へ ソフトキー [image] を押してソフトキーの2ページ目を表示します。

  3. 球 ソフトキー [image] を押して球の測定 画面を表示します：

  4. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。複数ステップを要するとき、測定および変更のためにプローブを移動する位置がグラフィカルに表示されます。

プロパティエリア

  • ポイント数- 測定されるポイント総数を定義します。

  • 下部角度 - 球の下部角度を定義します。赤道は0度です。

  • 上部角度 - 球の上部角度を定義します。北極点(最上部)は90度です。

測定終了角度と測定開始角度の差は20度以上でなければなりません。これが制限されるのは円弧が20度未満になると測定結果が不正確になる可能性があるからです。

パラメータエリア

  • アプローチ距離 - 実行時にワークから測定開始位置をどれだけ離すか指定します。プローブはこの距離を計測速度で移動します。

  • 検索距離 - 要素を検索およびティーチングするときの検索距離を定義します。(「オプション設定エリア」で説明するパラメータ入力によるティーチングを選択する場合は使用できません。)

オプション設定エリア

  • 安全高さの設定 - 実行時にプローブが各取込み点の間を安全高さまで移動します。チェックボックスにチェックを入れた後に、右側の編集ボックスに安全高さまでの距離を入力します。この平面は測定プログラムの安全高さではありません。詳細は安全高さの設定を参照してください。

  • ティーチングの後に測定をします - このオプションを選択すると、ティーチングをおこなった後、結果を元に連続して要素を再測定します。これにより、すべての設定パラメータがテストされ、正確で信頼性の高い初回品質検査が提供されます。

  • パラメータ入力によるティーチング - 入力された要素の設計値を使用して測定をします。(このオプションを選択すると「パラメータエリア」で説明する検索距離オプションが無効になります。)

パラメータエリア

  • XYZ設計値 - 球中心の設計上の位置を定義します。

  • XYZ実測値 - 球中心の測定位置を表示します。

  • 直径(設計値) - 球の設計上の直径を定義します。

  • 直径の実測値 - 球の測定された直径を表示します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

  1. プローブを球中心の最上部の上方に置き、位置読取りソフトキー [image] を押します。

  2. コマンドのティーチングと作成ソフトキー [image] を押します。NC Gageは下図のように自動的に計測点を取得します。

    球パス：A) ジョグ位置1-4) 自動的に測定される点の位置

  3. 要素が測定されると測定値が更新されます。コマンドの確認/追加 ソフトキー [image] を押します。要素コマンドが測定プログラムに追加されます。

NC Gageの具体的な動作について：

球要素のティーチング手順

  • プローブの位置を読込みます。この位置は球の最上部の上方でなければなりません。

  • 検索距離を使用して真下の点を測定します。

  • 元の読込み位置に後退して、+X方向に 2*プローブ半径だけ移動します。

  • 検索距離を使用して真下の点を測定します。

  • 元の高さまで後退して、+X軸から120度の方向に2*プローブ半径だけ移動します。

  • 検索距離を使用して真下の点を測定します。

  • 元の高さまで後退して、+X軸から240度の方向に2*プローブ半径だけ移動します。

  • 検索距離を使用して真下の点を測定します。

  • 元の高さまで後退します。

球要素の測定手順

  • ライン数およびライン毎の点数はフォームで定義される測定しようとする点数に基づいて決定されます。

  • 現在の位置が安全高さより低い場合、安全高さまで上昇します。

  • 最初のアプローチ距離の上方の位置に移動します。

  • 最低面ラインまで下降してそのレベルを測定し、必要な場合は、1つのレベルにおいて点と点の間に回避的な移動を追加して衝突を回避します。

  • 交互の方向に残りのラインを測定します。

  • 球の最上部の点を測定します(上部角度が90の場合)。

  • 安全高さに移動します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


点の構築

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 点の構築ソフトキーのページが表示されるまで前へソフトキー [image] を押します。

  3. 点の構築ソフトキー [image] を押して点の構築画面を表示します：

この画面では、以下の方法のうちの1つを使用して点要素を構築できます：

  • 交点オプションを選択して、選択した2つの線タイプ要素の交差するところで点を構築します。

  • 投影オプションを選択して、線タイプ要素の上に点要素を投影することによって点を構築します。

  • 中間点オプションを選択して、選択した 2つの点タイプ要素の中間で点を構築します。

点要素を構築するには

  1. オプションエリアから、実行する構築の種類として適切なオプションを選択します。

  2. 選択リストから2つの要素を選択します。選択リストには有効な要素タイプのみが表示されます。画面の左上隅のグラフィックが更新され、要素を構築する視覚的なヒントを提供します。設計値と実測値のデータが、選択した要素に従って更新されます。

  3. コマンドの確認/追加ソフトキー [image] を押してコマンドを測定プログラムに追加します。

有効な点タイプ要素

  • 構築された円

  • 構築された点

  • 測定された円の内径

  • 測定された円の外径

  • 測定されたコーナー内側

  • 測定されたコーナー外側

  • 測定された点

  • 測定された球

有効な線タイプの要素

  • 構築された線

  • 測定された円錐 (内側)

  • 測定された円錐 (外側)

  • 測定された円筒の内径

  • 測定された円筒の外径

  • 測定された線

  • 測定された平面

  • 測定された溝幅

  • 測定された突起幅

Z の設計値および実測値は構築された要素に自動的に割り当てられます。Z の設計値および実測値は構築の最初の構成要素から取得されます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


線の構築

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 線の構築ソフトキーのページが表示されるまで前へソフトキー [image] を押します。

  3. 線の構築ソフトキー [image] を押して、線の構築画面を表示します：

パラメータエリア

  • XYZ 設計値 - 開始点の設計上の位置を定義します。

  • XYZ 実測値 - 開始点の測定された位置を表示します。

  • X軸方向への角度 - この例では平面 - Xの最初のベクトル角度を定義します。これは作業面に対する平面の法線方向です。有効な範囲は-90～+90 度です。

  • Z軸方向への角度 - この例では平面 - Zの2番目のベクトル角度を定義します。これは、それが測定される第1軸に対する平面の法線方向です。第1軸はXY作業面ではX、YZ作業面ではY、ZX作業面ではZです。有効な範囲は0(ゼロ)～ -360 度です。

ベクトル角度(この例ではベクトルX軸方向への角度とベクトルZ軸方向への角度) は関連しています - 無効な値 (90.0, 20.0) は (90.0, 0.0) と定義されます。

線要素を構築するには

  1. ２つの点タイプ要素を選択します。要素リストには有効な要素タイプのみが表示されます。画面の左上隅のグラフィックが更新され、要素を構築する視覚的なヒントを提供します。設計値と実測値のデータが、選択した要素に従って更新されます。

  2. コマンドの確認/追加 ソフトキーを押してコマンドを測定プログラムに追加します。

有効な点タイプ要素

  • 構築された円

  • 構築された点

  • 測定された円の内径

  • 測定された円の外径

  • 測定されたコーナー内側

  • 測定されたコーナー外側

  • 測定された点

  • 測定された球

Z の設計値および実測値は構築された要素に自動的に割り当てられます。Z の設計値および実測値は構築の最初の構成要素から取得されます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


円の構築

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 円を構築ソフトキー [image] が表示されるまで前へソフトキーを押します。

  3. 円の構築ソフトキー [image] を押すと、円の構築画面が表示されます：

円を構築 オプションは要素メニューの3番目の画面にあり、これでユーザーは外周が 3つの点タイプ要素と交差する円を作成できます。

円要素を構築するには

  1. 構築に使用する点要素のリストから最初の要素を選択します。

  2. 項目を左に移動する二重矢印ボタン [image] を押して、要素を選択された要素リストに追加します。

  3. その他に2つ以上の点タイプ要素でこの操作を繰り返します(全部で3つ以上の点タイプ要素を選択する必要があります)。選択した要素リストから要素を削除する必要がある場合、削除する要素を選択して項目を右に移動する二重矢印ボタン [image] を使用します。有効な要素タイプのみが選択画面に表示されます。画面の左上隅にあるグラフィックが更新され、要素を構築する視覚的なヒントを提供します。設計値と実測値のデータが、選択した要素に従って更新されます。

  4. コマンドの確認/追加 ソフトキーを押してコマンドを測定プログラムに追加します。

有効な点タイプ要素

  • 構築された円

  • 構築された点

  • 測定された円の内径

  • 測定された円の外径

  • 測定されたコーナー内側

  • 測定されたコーナー外側

  • 測定された点

  • 測定された球

Zの設計値および実測値は構築された要素に自動的に割り当てられます。Z の設計値および実測値は構築の最初の構成要素から取得されます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


角度の構築

  1. メイン画面で測定ソフトキー [image] を押します。

  2. ソフトキーの第3ページが表示されるまで前へソフトキー [image] を押します。

  3. 角度の構築ソフトキー [image] を押して角度の構築 画面を表示します：

要素メニューの3ページ目の角度の構築オプションでは2つの線タイプ要素間の角度をレポートできます。

角度をレポートするには

  1. 第1の線および第2線リストから2種類の線要素を選択します。NC Gageは要素の方向に基づいて角度を計算します。補角が角度の場合は補角チェックボックスをマークします。有効な要素タイプのみが選択画面に表示されます。画面の左上隅のグラフィックが更新され、要素の構築方法に関する視覚的キュー (視覚的手がかり) を提供します。要素入力の選択に従って、設計上のデータと測定データが更新されます。

  2. コマンドの確認/追加ソフトキー [image] を押してコマンドを測定プログラムに追加します。

有効な線タイプ要素および平面要素

  • 突起幅

  • 溝幅

  • 直線

  • 構築された線

  • 円錐

  • 円筒

  • 平面

レポート内に記載される項目の一覧とその説明

角度の構築, 平行度または直角度オプションを使用して、2つの線タイプ要素間の角度、平行度または直角度をレポートすることができます。平行度および直角度の測定結果は正の偏差のみをレポートします。角度の構築は正または負の値を取ることができます。ここで、正はデータ (画面の1ページ目にある要素) から参照要素 (画面の2ページ目で選択された要素) までのXからY方向、YからZ方向およびZからX方向です。

下記のオプションがあります：

  • 設計上の角度の値が0 (ゼロ)の場合、平行度オプションが有効です。

  • 設計上の角度の値が90の場合、直角度オプションが有効です。

  • 設計上の角度の値が0または90以外の場合、構成の角度オプションが有効です。

平行度に関してレポートするには下記を実行します：

  1. 角度の構築 画面で平行度オプションを選択して平行度画面を表示します：

  2. 長さの評価では評価する長さを入力します。デフォルトの評価長さはゼロです。ボックスが空白の場合、入力が必要な欄であることを示めす赤色のアスタリスク (*) が表示され、警告メッセージも表示されます。

  3. 角度の構築画面に戻り公差ソフトキー [image] を押して公差 画面を表示します：

直角度に関してレポートするには下記を実行します：

  1. 角度の構築 画面で直角度オプションを選択して直角度画面を表示します：

  2. 長さの評価では評価する長さを入力します。デフォルトの評価長さはゼロです。ボックスが空白の場合、入力が必要な欄であることを示めす赤色のアスタリスク (*) が表示され、警告メッセージも表示されます。

  3. 角度の構築画面に戻り公差ソフトキー [image] を押して公差画面を表示します：

要素間の角度のツリービューの例を下記に示します：

下記は平行度のツリービューの例です：

下記は直角度のツリービューの例です：

角度の構築、平行度および直角度に対する測定プログラム画面の例については、「測定プログラムの表示と実行」を参照してください。レポート画面の例については、レポートの使用を参照してください。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


距離計算

  1. メイン画面で測定ソフトキー [image] を押します。

  2. ソフトキーの3ページ目が表示されるまで前へソフトキー [image] を押します。

  3. 距離計算ソフトキー [image] を押して距離計算画面を表示します：

距離をレポートするには

要素メニューの3ページ目にある距離計算オプションを使用すると、2つの点タイプの要素間の距離をレポートすることができます。距離は1軸方向 (軸に平行) または2軸方向での距離です。

  1. オプションエリアから、計算しようとする距離に対して適切なオプションを選択します。

  2. 表示された各リストから項目を選択します。有効な測定および構築された項目だけがリストエリアに表示されます。画面の左上隅のグラフィックが更新され、要素の構築方法に関する視覚的キュー (視覚的手がかり) を提供します。設計上のデータと測定データが要素の入力に従ってアップデートされます。項目を選択したら、公差値ソフトキー [image] を押して、構築される距離に関連する公差値を表示します。

  3. コマンドの確認/追加ソフトキー [image] を押してコマンドを測定プログラムに追加します。

有効な点タイプ要素

  • 測定された点

  • 測定された円の内径

  • 測定された円の外径

  • 測定されたコーナー内側

  • 測定されたコーナー外側

  • 構築された点

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


同心度

  1. メイン画面で測定ソフトキー [image] を押します。

  2. ソフトキーの第3ページが表示されるまで前へソフトキー [image] を押します。

  3. 同心度ソフトキー [image] を押して同心度画面を表示します：

同心度をレポートするには

要素メニューの3ページ目にある同心度オプションによって、1つの要素の別の要素に対する同心度を計算することができます。この要素は同じ作業面にある要素に対してのみ有効です。

  1. 表示された各リストから項目を選択します。両方のリストに円要素が表示されます。

選択された2つの要素が同一作業面にない場合、次の警告メッセージが表示されます：「選択された要素が同一作業面にありません」

  2. 項目を選択したら、公差ソフトキー [image] を押して同心度に関連する公差値を表示します。

  3. コマンドの確認/追加ソフトキー [image] を押してコマンドを測定プログラムに追加します。要素がツリービューに追加されます。以下に例を記載します：

有効なタイプの要素

  • 測定された円の内径

  • 測定された円の外径

  • 構築された円

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


キー

突起コマンドを作成するには：

  1. メイン画面で測定ソフトキー [image] を押します。

  2. ソフトキーの3ページ目が表示されるまで前へソフトキー [image] を押します。

  3. 回転軸角度（突起）ソフトキー [image] を押して回転軸角度の測定 （突起）画面を表示します：

  4. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。複数ステップを要するとき、測定および変更のためにプローブを移動する位置がグラフィカルに表示されます。

プロパティエリア

  • 開始位置X、開始位置Yおよび開始位置Z - 開始点の範囲を定義します。

  • 幅 - 突起の幅を定義します。幅はパラメータ入力によるティーチングチェックボックスを選択しているときにのみ表示されます。

  • 要素を検索します - 検索プロセスを有効にします。このチェックボックスを選択すると、NC Gageは測定プロセスの最初に検索プロセスを挿入します。プローブはシャフト表面の何箇所をアプローチ距離から測定して、突起の角度の設計値を特定します。

パラメータエリア

  • アプローチ角度 - 測定プロセス中にプローブが面の検索を開始するために使用する設計上の平面からの角度を定義します。

オプション設定エリア

  • ティーチングの後に測定をします - このオプションを選択すると、ティーチングをおこなった後、結果を元に連続して要素を再測定します。これにより、すべての設定パラメータがテストされ、正確で信頼性の高い初回品質検査が提供されます。

  • パラメータ入力によるティーチング - 入力された要素の設計値を使用して測定をします。

パラメータエリア

  • 角度 - 平面の中心線のベクトル角度を定義します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

  1. 突起を反時計回りに回転させ、プローブが突起の右側にあるように配置します。位置読取り ソフトキー [image] を押します。

  2. 突起を時計回り(右回り)に回転させ、プローブが突起の左側にあるように配置します。位置読取り ソフトキー [image] を押します。

  3. プローブ軸に沿って、プローブを安全な位置に移動させ、コマンドのティーチングと作成 ソフトキー [image] を押します。

  4. 下記を参照してください。

    • プローブが突起の最上部まで移動します。

    • 回転軸がアプローチ角度まで回転します。

    • プローブが測定高さまで移動します。

    • プローブがワークと接触するまで回転軸が時計方向に回転します。回転軸が回転を停止します。回転軸がアプローチ角度まで後退します。

    • プローブが突起の最上部まで移動します。

    • 回転軸がアプローチ角度まで回転します。

    • プローブが測定高さまで移動します。

    • プローブがワークと接触するまで回転軸が反時計方向に回転します。回転軸が回転を停止します。回転軸がアプローチ角度まで後退します。

    • プローブが突起の最上部まで移動します。

    • 回転軸が元の位置まで回転して戻ります。

    • 突起の中央角度を、検出した2つの回転軸の位置によって計算します。

実行プロセス

下記を参照してください。

  1. プローブが突起の最上部まで移動します。

  2. プローブが主軸の0度の方向を向きます。

  3. 回転軸がアプローチ角度まで回転します。

  4. プローブが測定高さまで移動します。

  5. プローブがワークと接触するまで回転軸が時計方向に回転します。回転軸が回転を停止します。回転軸がアプローチ角度まで後退します。

  6. プローブが突起の最上部まで移動します。

  7. プローブは安全高さにあります。

  8. 回転軸がアプローチ角度まで回転します。

  9. プローブが測定高さまで移動します。

  10. プローブがワークと接触するまで回転軸が反時計方向に回転します。回転軸が回転を停止します。回転軸がアプローチ角度まで後退します。

  11. プローブが突起の最上部まで移動します。

  12. プローブが主軸の0度の方向を向きます。

  13. 回転軸が元の位置まで回転して戻ります。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


回転軸角度（溝）

溝コマンドを作成するには：

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 2ページのソフトキーが表示されるまで前へ ソフトキー [image] を押します。

  3. 回転軸角度（溝）ソフトキー [image] を押して回転軸角度の測定 （溝）画面を表示します：

  4. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。複数ステップを要するとき、測定および変更のためにプローブを移動する位置がグラフィカルに表示されます。

プロパティエリア

  • 開始位置X、開始位置Yおよび開始位置Z - 開始点の範囲を定義します。

  • 幅 - 溝の幅を定義します。幅はパラメータ入力によるティーチングチェックボックスを選択しているときにのみ表示されます。

  • 要素を検索します - 検索プロセスを有効にします。このチェックボックスを選択すると、NC Gageは測定プロセスの最初に検索プロセスを挿入します。プローブはシャフト表面の何箇所をアプローチ距離から測定して、溝の角度の設計値を特定します。

パラメータエリア

  • アプローチ角度 - 測定プロセス中にプローブが面の検索を開始するために使用する設計上の平面からの角度を定義します。

  • 角度の範囲を検索 - 要素の検索およびティーチング時の検索角度の範囲を定義します。「オプション設定エリア」で説明するパラメータ入力によるティーチングを選択する場合は使用できません。

オプション設定エリア

  • ティーチングの後に測定をします - このオプションを選択すると、ティーチングをおこなった後、結果を元に連続して要素を再測定します。これにより、すべての設定パラメータがテストされ、正確で信頼性の高い初回品質検査が提供されます。

  • パラメータ入力によるティーチング - 入力された要素の設計値を使用して測定をします。これを選択した場合、「パラメータエリア」の角度の範囲を検索が無効になります。

パラメータエリア

  • 角度 - 溝の中心線のベクトル角度を定義します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

  1. プローブを主軸中心線上の溝の内側に置き、位置読取りソフトキー [image] を押します。

  2. 下記を参照してください。

    • プローブがワークと接触するまで回転軸が時計方向に回転します。回転軸が回転を停止します。

    • プローブがワークと接触するまで回転軸が反時計方向に回転します。回転軸が回転を停止します。

    • 回転軸が元の位置まで回転して戻ります。

    • 溝の中央角度を、検出した2つの回転軸の位置によって計算します。

実行プロセス

下記を参照してください。

  1. プローブが溝内側の開始点に移動します。

  2. プローブが主軸の0度の方向を向きます。

  3. 回転軸がアプローチ角度まで反時計方向に回転を開始します。

  4. 回転軸が停止し、ゆっくりと移動して溝の一方の側を測定し始めます。

  5. プローブが起動し、回転軸が反対方向に回転し始めます。

  6. プローブは安全高さにあります。

  7. 回転軸がアプローチ角度まで時計方向に回転します。

  8. 回転軸が停止し、ゆっくりと移動して溝の他方の側を測定し始めます。

  9. 回転軸が元の位置まで回転して戻ります。

  10. プローブが主軸の0度の方向を向きます。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


回転軸角度（平面）

平面コマンドを作成するには：

  1. メイン画面で測定ソフトキー [image] を押します。

  2. ソフトキーの3ページ目が表示されるまで前へソフトキー [image] を押します。

  3. 回転軸角度（平面）ソフトキー [image] を押して回転軸角度の測定 （平面）画面を表示します：

  4. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。複数ステップを要するとき、測定および変更のためにプローブを移動する位置がグラフィカルに表示されます。

プロパティエリア

  • 開始位置X、開始位置Yおよび開始位置Z - 開始点の範囲を定義します。

  • 幅 - 平面の幅を定義します。幅はパラメータ入力によるティーチングチェックボックスを選択しているときにのみ表示されます。

  • 要素を検索します - 検索プロセスを有効にします。このチェックボックスを選択すると、NC Gageは測定プロセスの最初に検索プロセスを挿入します。プローブはシャフト表面の何箇所をアプローチ距離から測定して、平面の角度の設計値を特定します。

パラメータエリア

  • アプローチ角度 - 測定プロセス中にプローブが面の検索を開始するために使用する設計上の平面からの角度を定義します。

  • 角度の範囲を検索 - 要素の検索およびティーチング時の検索角度の範囲を定義します。「オプション設定エリア」で説明するパラメータ入力によるティーチングを選択する場合は使用できません。

オプション設定エリア

  • ティーチングの後に測定をします - このオプションを選択すると、ティーチングをおこなった後、結果を元に連続して要素を再測定します。これにより、すべての設定パラメータがテストされ、正確で信頼性の高い初回品質検査が提供されます。

  • パラメータ入力によるティーチング - 入力された要素の設計値を使用して測定をします。これを選択した場合、「パラメータエリア」の角度の範囲を検索が無効になります。

パラメータエリア

  • 角度 - 平面の中心線のベクトル角度を定義します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

  1. プローブを主軸中心線上の平面の上に置き、位置読取りソフトキー [image] を押します。

  2. 下記を参照してください。

    • プローブがワークと接触するまで回転軸が時計方向に回転します。回転軸が回転を停止します。

    • プローブがワークと接触するまで回転軸が反時計方向に回転します。回転軸が回転を停止します。

    • 回転軸が元の位置まで回転して戻ります。

    • 平面の中央角度を、検出した2つの回転軸の位置によって計算します。

実行プロセス

下記を参照してください。

  1. プローブが平面内側の開始点に移動します。

  2. プローブが主軸の0度の方向を向きます。

  3. 回転軸がアプローチ角度まで反時計方向に回転を開始します。

  4. 回転軸が停止して、ゆっくりと移動し平面の一方の側を測定し始めます。

  5. プローブがワークと接触するまで、回転軸が反対方向に回転し始めます。

  6. プローブは安全高さにあります。

  7. 回転軸がアプローチ角度まで時計方向に回転します。

  8. 回転軸が停止し、ゆっくりと移動して平面のもう一方の側を測定し始めます。

  9. 回転軸が元の位置まで回転して戻ります。

  10. プローブが主軸の0度の方向を向きます。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


追加の要素パラメータ設定

要素コマンドで作業するときは、要素ウィンドウから追加パラメータを変更できます。以下のソフトキーは要素ウィンドウのツールバーで使用できます：

  • ワークオフセットの設定

  • ワークオフセットのアップデート

  • ワークオフセットの選択

  • 変数の書き込み

  • 工具長のアップデート - 測定プログラムの制御

  • 回転座標の設定

  • 公差

  • 安全高さの設定

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


ワークオフセットの選択

測定プログラムの始めでワークオフセットを選択すると、測定プログラムが再使用可能になります。これは要素を測定する前に行う必要があります。

  1. メイン画面でワークオフセットの選択ソフトキー [image] を押してワークオフセットの選択画面を表示します。これは、測定の定義より前(回転軸がシステムで校正されている場合)、または安全高さを定義する前にNC Gageが起動するときに使用できます。

  2. ワークオフセットを選択ソフトキー [image] を押して、目的のワークオフセットを選択し、画面に表示されるオフセット値を確認します。

  3. 実行ソフトキー [image] を押します。

  4. 確認ソフトキー [image] を押します。NC Gageは選択したワークオフセットを測定プログラムに挿入します。戻るソフトキー [image] を押すと保存せずに前の画面に戻ります。

パラメータ：

  • ワークオフセット – パラメータでのオフセット値を表示し、測定プログラムに追加するために選択するワークオフセットを指定します。

  • ＸＹＺ – これら読み込み専用の値は、ワークオフセット値を示します。値はコントローラから読み取られ、ワークオフセットがリストから選択されたときに表示されます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


変数の書き込み

NC Gage2.0から変数の書き込みコマンドを使用できます。これを使って測定データをNCコントローラのマクロ変数に書き込むことができます。さらに、変数書き込み要素は公差範囲外の要素数と要素の総数をマクロ変数に書き込むことができます。NC Gageはこれらの値を書き込むだけで、その他の動作は実行されません。

  1. メイン画面のナビゲーションバーで測定 ソフトキー [image] を押します。

  2. 3ページ目のソフトキーが表示されるまで前へ ソフトキー [image] を押します。

  3. 変数の書き込みソフトキー [image] を押して変数の書き込み画面を表示します：

要素群エリア

レポート項目数 - 測定および/または構築される要素の数。

公差範囲外の数 - 公差範囲外の要素の数。

要素の位置エリア

測定結果 – 要素の公差を含んだ軸のデータ

値 - 測定結果を選択するとこのフィールドが表示されます。編集はできません。

マクロ変数 - このフィールドは有効なマクロ変数番号を定義する整数です。有効なマクロ変数の範囲は機械の種類と購入されたオプションによって異なります。

下記のステップを使用してマクロ変数を書き込みます：

  1. 要素群リストから測定された要素を選択します。

  2. その要素の有効な測定結果リストが測定結果ボックスに表示されます。要素に対して数字はチェック済みまたは公差範囲外の数を選択すると、入力欄は空白になり無効になります。要素の位置エリアのリストから測定結果を選択します。現在の値が参照として表示されます。

  3. 要素の位置エリアのマクロ変数ボックスに使用されるマクロ変数の番号を入力します。NC Gageは入力されたマクロ番号がNC Gageの処理に干渉しないかどうかチェックします。

  4. 確認ソフトキー [image] を押して、変数の書き込みコマンドを計測プログラムに追加します。

  5. 部分実行ソフトキー [image] を押して、変数の書き込みコマンドを実行し、機械の変数へ書き込みます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


工具オフセットのアップデート - 測定プログラムの制御

工具オフセットのアップデート画面では、測定プログラム制御の一部となる工具オフセットを定義できます。

  1. 要素が測定されたら、メイン画面で測定ソフトキー [image] を選択します。

  2. 3ページ目のソフトキーが表示されるまで前へ ソフトキー [image] を押します。

  3. 工具オフセットのアップデート ソフトキー [image] を選択して工具オフセットのアップデート 画面を表示します：

工具オフセットのアップデート機能は入力した工具によって加工されたターゲット値を持つワークの要素に基づいています。この状況では、ターゲット値と測定値の差は工具オフセットの摩耗誤差です。アップデートによって工具オフセットの値が永久に変更されるため、これを理解することは非常に重要です。

測定プログラムが工具オフセットをアップデートできるようにするには：

  1. メイン画面で測定ソフトキーを選択し、前へソフトキーで測定画面の3ページ目に移動します。

  2. 工具オフセットのアップデートソフトキー [image] をクリックして工具オフセットのアップデート画面を表示します。

  3. 要素リストからターゲット要素を選択します。選択すると要素位置エリアに設計値が表示されます。要素が測定されると、この要素の測定値と偏差も表示されます。工具オフセットは偏差に基づいて更新されます。使用可能な要素はZ値、多くの場合、点または平面を測定する要素です。リストから適切なものを選択してください。

  4. 工具オフセットエリアで、計算で使用される要素を加工するのに使われる工具番号を入力します。有効な工具番号を入力すると、現在の工具オフセット全体 (幾何学的形状 + 摩耗) が工具オフセットエリアに表示されます。下記の内容で画面がアップデートされます：

    • NC工作機械からの工具オフセットが取得されます。

    • 現在および新規オフセットが計算されて表示されます。

    • これらの2数値の間の差が表示されます。この差は要素位置の偏差と同じでなければなりません。これはNC Gageが、ワークが加工されたときに「完璧に」要素を加工できたはずの工具オフセットを計算するためです。

    NC Gageは、ユーザーが入力した工具番号の値が測定プログラムでのアクティブなプローブ番号と同じ値であるかどうかを判定します。これは事実上、システムに許可されないプローブ長を更新することを要求することです。工具番号とアクティブなプローブ番号の値は同じであってはいけません。これを修正して次に進んでください。

  5. 確認ソフトキー [image] をクリックして新しい値を保存し、測定プログラムに書き込まれる工具のアップデートを終了します。次回測定プログラムが実行されるときに更新作業が行われます。戻るソフトキー [image] を押して前の画面に戻ります。

その時点で特定される工具の摩耗はNC Gageがターゲットと測定位置の間の差として計算する値によって変更されます。確認ソフトキー [image] が選択されるごとに、工具摩耗はこの差によって調整されます。このため、工具が表面を加工するごとに1回だけこの所定の作業を行ってください。

要素群エリア

選択できる使用可能な要素のリストを表示します。このリストには有効な要素タイプだけが表示されます。

パラメータエリア

実測値 - 測定された位置を表示します。

ターゲット - 設計上の位置を表示します。

工具オフセットエリア

オフセット番号 - 要素を加工するために使用する工具番号です。工具番号も計算に使用されます。

補正 - 補正のタイプは次のようになります：以下にA、B、C、Dの工具オフセットの種類に応じてリストに表示される補正のタイプを示します。

工具オフセットの種類は、NC Gage設定ツールのパラメータタブの工具補正タイプのドロップダウンリストで指定します。詳しくは、「付録A - コントローラの設定」を参照してください。

工具オフセットの種類 | 補正のタイプ
Type A | 工具径摩耗
Type B | 工具径摩耗、工具径形状
タイプC | 工具径摩耗、工具径形状、工具長摩耗、工具長形状

工具補正エリア

現在 - 現在の工具オフセット値を表示します。

新規 - 新規の工具オフセット値を表示します。

差 - 現在の工具オフセット値と新規工具オフセット値の差を表示します。NC Gageはこの差を工具オフセットとして使用します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


座標回転の設定

NC Gageは、希望の要素を測定し、座標系の回転で使用する要素を選択してCNC工作機械で使用する座標系の2次元回転の調整を定義するための機能を搭載しています。この機能を使わずに同じことをする場合、G68 コードで適切な回転中心、軸、ベクトルおよび角度を手動で入力する必要があります。

要素が測定されたら、座標回転を設定画面を使用して回転の計算に使用する要素を選択します。NC GageはG68コードまたはG68.2コードをアップデートして新たに回転させた座標系を使用します。

回転マクロは1つのみです。NC Gageで以降の定義を行うと既存のパラメータが上書きされます。

  1. メイン画面で測定ソフトキー [image] を押します。

  2. 座標回転を設定ソフトキーが表示されるまで、前へのソフトキー [image] を押します。

  3. 座標回転を設定ソフトキー [image] を押して座標回転を設定画面を表示します：

パラメータエリア

座標回転はNC工作機械で座標系を回転できるようにする方法です。座標回転がアクティブなときは測定できないため、コマンドが実行されているときは座標回転機能はアクティブになりません。マクロ変数の情報が計算され、この情報を使用してマクロプログラムが呼び出されて座標回転を実行します。

  • a1, a2, R：これらのリストが軸(a1=Axis 1, a2=Axis 2) 平行移動(軸リスト)と回転（Rリスト）を定義する測定プログラム内の要素を表示します。軸は測定面の選択ソフトキーを使用して選択モードによって定義されます-下記を参照してください：

  • a1、a2、Rパート：これらの読み出し専用ボックスは、軸とRのリストからの現在選択されている要素の軸(a1=軸１、a2=軸2 )および回転(R)の値を表示します。これらの値は既にワーク座標系に変換されています。軸は測定面の選択ソフトキーを使用して選択モードによって定義されます-下記を参照してください：

  • a1、a2、R機械：これらの読み出し専用ボックスは、軸とRのリストからの現在選択されている要素の軸(a1=軸１、a2=軸2 )および回転(R)の値を表示します。これらの値は既に機械の座標系に変換されています。軸は測定面の選択ソフトキーを使用して選択モードによって定義されます-下記を参照してください：

  • a1, a2, ターゲット：これらのボックスは座標回転のターゲット軸 (a1=Axis 1, a2=Axis 2)および回転値(R)の値を定義します。これらのボックスを使用して正確な座標系の位置と使用する回転角度を定義します。軸は測定面の選択ソフトキーを使用して選択モードによって定義されます-下記を参照してください：機械座標値は座標回転コマンドを設定するのに使用されます。

回転角度に関しては、(線、平面、溝幅、突起幅、円筒の内径/外径および円錐の内径/外径など)定義された線を持つ選択された要素が対応するフィールドで自動的にアップデートされます。円筒、円錐および平面要素の垂直軸は2D角度を作成します。選択された線要素タイプのベクトル回転角度を使用して回転角度を定義することもできます。

  • コメント：このボックスを使用して現在のシステムの回転に関するコメントを入力できます。

測定面の選択の概要

測定プログラムに座標回転コマンドを挿入するときは、座標系を回転させる作業面、軸の値および回転角度を定義する必要があます。作業面を定義するには、測定面の選択ボタンを使って以下の測定面を使用することができます：

XY平面

XY作業面が選択されていると、NC GageはパラメータエリアにX、YおよびRラベルとそれぞれの詳細を表示します。

YZ平面

YZ作業面が選択されていると、NC GageはパラメータエリアにY、ZおよびRラベルとそれぞれの詳細を表示します。

XZ平面

XZ作業面を選択すると、NC GageはパラメータエリアにX、ZおよびRラベルとそれぞれの詳細を表示します。

座標回転の設定

  1. 各軸に対して有効な測定であるX リストおよびYリストにおいて要素を選択して、XおよびY方向の平行移動を指定します。これらは円(内径)など、新しい座標系での原点を定義する基本的な中心点の値を持つ点要素またはその他の要素です。

  2. RリストからXY面で有効な方向を持つ要素を選択して回転を指定します。これらは方向を持つ要素（線など）です。

  3. 各要素について、XZYターゲットボックスで軸または角度の予想される値を定義します。

  4. 確認ソフトキー [image] を押してNC Gage測定プログラムに座標回転を追加します。座標回転アイコンが測定プログラムに追加されても、座標回転はNC Gage測定プログラムを影響を与えません。

NC Gageは実際の測定値と期待される値の間で平行移動と回転の差分を計算します。X、Yおよび回転は座標回転マクロサブルーチンで使用されるマクロ変数のセットに書き込まれます。測定プログラム実行終了後にNC Gageを閉じるときに、このマクロサブルーチンが呼び出されます。

マクロサブルーチンを再度呼び出し、座標系の変更を再度適用します。このサブルーチンマクロ番号にはモニターのサブルーチンマクロ ＋ 2 と同じ番号が与えられます。つまり、モニタープログラムに7000の番号を付けると、この座標系変更には7002の番号が付けられます。回転マクロは1つのみです。NC Gage内で後に定義を行うと既存ファイルが上書きされます。

NC Gageは座標回転を適用しながら実行することはできません。このため、座標回転は直接設定されません。代わりに、X、YおよびRパラメータが保存されて、ユーザーは切り取り操作を実行する前に座標回転マクロを呼び出すことができます。

例

以下のように、点2 (下図B) は線 (下図C) と線4 (下図A)の交点から構築された点で、点2 を新しい原点として選択し、 線4を回転要素として選択するとします：

これは、NC Gage が点2(B)を中心に、線4(A)まで座標系を回転させるという意味です。座標系は点2(B)がその原点となり、新しい X 軸は線4(A)となります。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


公差

公差 画面を使用して、要素ごとに公差の表示や編集が可能です。NC Gageは設定されている公差を使用して測定結果を評価します。

公差画面に使用するには、各要素の測定画面の2ページ目にある公差ソフトキー [image] を押します。測定プログラムにコマンドを追加する場合、要素を測定し、確認ソフトキー [image] を押す前に、公差を編集する必要があります。

公差画面で各要素のレポートの初期設定をカスタマイズできます。下記のとおりに内容を編集します。

  1. レポートされる軸を選択します。対応するチェックボックスを選択します。

  2. 必要に応じて設計値を変更します。

  3. 必要に応じて公差値を変更します。

  4. 穴または外径の位置を評価するには位置チェックボックスを選択します。

    例えば、要素が内径測定機能および外径測定機能に対する円形の公差領域内にある場合、公差領域の大きさはその直径で指定されます。要素がこの公差領域内にあるかどうかを確認するには、位置チェックボックスを選択します。

    位置の評価の設計値は常に0です。

確認ソフトキー [image] を押すと、各要素に対する測定プログラムにすべての設定が保存されます。変更を保存せずに終了するには戻るソフトキー [image] を押します。

幾何公差

幾何公差には平面度、真直度、真円度および円筒度などがあります。これらの公差は個々の要素にみに関連します。

NC Gageは各種要素の幾何公差を評価できます。要素とその幾何公差を以下に記載します：

  • 線：真直度

  • 内径と外径：真円度

  • シャフト：円筒度と振れ (振れは回転軸を回転させて測定したときにのみレポートされます)

  • 円筒内部と円筒外部：円筒度

  • 球：真球度

  • 円錐：円錐形状

  • 平面：平面度

要素の幾何公差を評価するには、公差のチェックボックスを選択します。以下に例を記載します：

線要素に対する真直度チェックボックス

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


安全高さの設定

安全高さの設定チェックボックスにチェックを入れ安全高さを設定すると、計測時、1点測定するたびに安全高さまでプローブを逃がすことができます。このオプションは各測定において障害物を避けながら測定したい場合に有効です。

点要素には安全高さの設定オプションがありますが、測定プロセスにおいてプローブ移動が1回しか行われないため、このオプションは機能しません。

安全高さの設定オプションにチェックを入れると値を入力するための欄が有効になります。それぞれの測定後に、プローブルビーはプローブの方向に沿って定義された安全高さの設定位置に移動します。プローブは安全高さの設定位置に到達後、XY軸における安全移動位置に移動し、次に測定のためのプローブ移動を実行します。

安全高さはワーク座標系で高さを入力することによって定義します。ワーク座標系の原点は要素の位置であり、 Z軸ベクトルは要素の測定におけるプローブの方向（先端からスピンドル方向）です。

円の外径測定と平面測定におけるの安全高さ設定例

H - 安全高さの設定の入力値

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


移動コマンドの挿入

NC Gageではプローブのパートとの衝突を回避するのに役立つ移動コマンドを測定プログラムに挿入できます。移動コマンドは要素コマンドの間に追加します。移動コマンドを追加する前にプローブを校正する必要があります (「校正」を参照)。

要素コマンドを定義したら、メイン画面のナビゲーションバーにある移動ソフトキー [image] を選択して、下記のオプションを表示します:

コマンドを以下に記載します：

  • 移動点

  • 安全高さの設定

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


移動点

移動点コマンドは、実行時にプローブルビーの中心が移動するXYZ座標を提供します。これらの位置を使用して障害物を避けてプローブを移動させます。

移動コマンドを測定プログラムに追加するには：

  1. メイン画面のナビゲーションバーで移動 ソフトキー [image] を押します。

  2. 移動点ソフトキー [image] を押して移動点画面を表示します：

  3. 画面の指示に従ってコマンドを挿入します。画面の左上エリアにあるビジュアルナビゲータに注意してください。これは複数手順を要するときに測定および変更のためにプローブを移動する位置を示しています。

パラメータ：

  • プローブルビーの座標値(X Y Z設計値) - 設計上の移動位置を定義します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

  1. プローブを移動位置に置き、 位置読取りソフトキー [image] を押します。ルビーの位置が読込まれます。前のステップに戻る ソフトキー [image] を押すとこの測定位置がキャンセルされます。

  2. コマンドの確認/追加 ソフトキー [image] を押します。新しい点の移動コマンドが測定プログラムに挿入されます。

各計測画面から移動点画面に移った場合、移動点は計測要素の前または後ろに挿入されます。

NC Gageの具体的な動作について：

  • 現在のZ位置がターゲット位置よりも高い場合、現在のZ高さでXYターゲット位置に移動してから、Zのターゲット位置に移動します。

  • 現在のZ位置がターゲット位置より低い場合、Zのターゲット位置まで上昇してからXYのターゲット位置に移動します。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


安全高さの設定

測定要素ごとにプローブが退避する位置（高さ）を安全高さとして設定します。

安全高さの設定コマンドをプログラムに追加する方法について：

  1. メイン画面のナビゲーションバーで移動 ソフトキー [image] を押します。

  2. 安全高さの設定ソフトキー [image] を押して安全高さの設定画面を表示します：

  3. 画面の指示に従ってコマンドを挿入します。

画面の左上エリアにあるビジュアルナビゲータに注意してください。複数回の手順が必要な場合、ビジュアルナビゲータは位置読取りボタンを押すごとに表示が変わります。

パラメータの定義：

  • 平面からプローブルビーの高さ - プローブを安全高さに移動して位置読取りボタンを押すとプローブ先端のルビー球位置が自動で入力されます。下記のオプションを選択した場合は手動で値を入力します。

  • 画面上の値を使用してティーチング - このオプションにチェックを入れると安全高さを手動で入力できるようになります。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

ティーチングプロセス

  1. メイン画面のナビゲーションバーで移動 ソフトキー [image] を押します。

  2. 安全高さの設定ソフトキー [image] を押します。

  3. 安全高さの位置を設定します。以下の2つの設定方法があります：

    1. プローブを安全な位置（高さ）まで動かし、位置読取り [image] ソフトキーを押して設定する。

    2. 画面で入力した値を使用しますにチェックを入れ、平面からプローブルビーの高さに値を入力する。入力された値は選択したワークオフセットの原点とプローブ先端のルビー球中心間の距離として作用します。

  4. 確認ソフトキー [image] を押します。安全高さの設定コマンドが測定プログラムに追加されます。

最小の安全高さについて：

最小の安全高さを算出する場合、アプローチ距離とプローブルビー半径が関係します。NC Gageはプローブがアプローチ距離よりワークに近づけないように安全高さを定義します。また、壁面上の要素を測定する場合、測定可能な奥行きがプローブルビー半径以上であると想定します。

  • 壁面上のポイントを測定する要素(内径、外径、線、円筒、円錐、突起幅、溝幅、コーナー)の場合：
    最小安全高さ = 測定高さ + (2 * プローブルビー半径) + アプローチ距離

または

最小安全高さ = 測定高さ + プローブルビー直径 + アプローチ距離

  • ワーク上面を測定する要素(平面、点)の場合：
    最小安全面高さ = 測定高さ + プローブルビー半径 + アプローチ距離

  • 球状要素の場合：
    最小安全高さ= 球中心 + 球半径 + プローブルビー半径 + アプローチ距離

ワークおよびプローブルビーの側面図

A -最小安全高さ

B -アプローチ距離

C - プローブルビー
3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


測定プログラムでの作業

測定したい要素を持つ測定プログラムがある場合、測定プログラムを実行または編集することができます。NC Gageには測定プログラムの実行画面と測定プログラムの編集画面があり、これらの作業をサポートします。

以下のトピックでこれらの画面について説明します:

  • 測定プログラムの表示と実行

  • 測定プログラムの編集

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


測定プログラムの表示と実行

測定プログラムを実行画面を使用すると測定プログラムを表示して実行することができます。

この画面にアクセスするには、メイン画面の測定プログラムを実行ソフトキー [image] を押します：

要素間の角度の例

角度の平行度レポートの例

角度の直角度レポートの例

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


測定プログラムの編集

測定プログラムの編集画面を使用して測定プログラムを編集します。編集には、コマンドの移動、複製、削除などがあります。

  1. 前方へソフトキー [image] を押して、メイン画面の2ページ目に移動します。

  2. 測定プログラムの編集ソフトキー [image] を押して、測定プログラムの編集画面を表示します：

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

カーソルモードについて

以下の2モードがあります：

  • 単一選択モード - このモードでは、編集ウィンドウの測定プログラムツリーでカーソルを上下に移動させると、カーソル位置のひとつの要素が選択されます。これが初期状態です。

  • 複数選択モード - このモードでは、編集ウィンドウの測定プログラムツリーでカーソルを上下に移動させると、カーソル位置の要素が自動的に追加され、複数の要素が選択されます。

どちらのモードでも測定プログラムの要素の切り取り、コピーまたは貼り付けが可能です。

要素の編集について

測定プログラムの編集画面または編集モードにあるとき：

  • 変更を保存せずに画面を閉じるには、戻るソフトキー [image] を押します。

  • 変更を保存してから画面を閉じるには、コマンドの確認/変更ソフトキー [image] を押します。

以下のアイコンが測定プログラムの編集画面の右下エリアに表示されているときは編集モードにあります：

そうでない場合は、以下のアイコンが表示され、通常の挿入モードにあることを示します：

要素の貼付について

要素を貼り付けるには、要素が挿入される位置の1つ上を選択します。コピーまたは切り取りソフトキーを押すと、測定プログラムのツリー表示に小さな赤色矢印が表示されます。これは測定プログラムがコマンドを貼り付ける位置を示しています。

  • 切り取った要素を貼り付ける場合、選択した位置に切り取った要素が挿入されます。この操作で、測定プログラム内の要素の順番を変更します。

  • 貼り付けられる要素が最初に測定プログラムからコピーされたものである場合は、測定プログラムに挿入され、要素名は貼り付けられるたびに1つずつ増加します。つまり、「Line1」という名前の要素をコピーして貼り付けた場合、貼り付けられた要素の名前は「Line2」、次は「Line3」などとなります。

測定プログラムのコメント

測定プログラムのコメントボックスでは測定プログラムについてのコメントを入力します。このコメントはファイルマネージャ画面のコメント欄に表示されます。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


ファイル管理

ファイルマネージャ画面を使用してNC Gage測定プログラムを管理します。新規測定プログラムの作成および保存ならびに既存測定プログラムの読込みまたは削除を行うことができます。

測定プログラムはNC Gageのデータがあるフォルダ配下のPRGフォルダに保存されます。

C:\Hexagon\NC Gage\Data Center\PRG

メイン画面でファイル マネージャソフトキー [image] をクリックしてファイルマネージャ画面を表示します：

この画面は下記の４カラムから成ります：

  • 主軸タイプ -この列には、測定プログラムの作成に基づいて主軸タイプ1(第1主軸)または2(第2主軸)が表示されます。主軸タイプ1(第1主軸)は空白です。

  • 測定プログラム名 - これは.NCGというファイル名拡張子が付いた測定プログラムの名前をリストアップします。

  • コメント - これは測定プログラム固有のコメントを表示します。コメント欄でコメントの追加または編集をします。測定プログラムの編集画面を使用してコメントの追加または編集ができます。測定プログラムの編集画面でコメントを追加または編集する方法の詳細については、「測定プログラムの編集」を参照してください。

  • 作成日 - 測定プログラムが最後に保存された日付を表示します。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


レポートの使用

測定プログラムを実行した後に、レポート画面を表示して結果を確認することができます。この画面はメイン画面からレポートソフトキー [image] を押して進みます。

値が測定されるまではレポート画面に進むことはできません。これらは測定プログラム実行後にのみ使用することができます。

角度の平行度、直角度についてのレポート例

レポートの表示

メイン画面からレポートソフトキー [image] を押してレポート画面に進みます。

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


オンスクリーンキーボードの使用

NC Gageには3つのオンスクリーンキーボードがあります：

  • 英数字キーボード - このキーボードはアルファベット、数字および記号キーの組み合わせから成ります。NC Gageでキーボードを有効にした場合、画面の英数字を入力するテキストボックスをクリックするとこのキーボードが自動的に表示されます。

  • 数字キーパッド - このキーボードによって計算機スタイルの数値データ入力が効率的になります。NC Gageでキーボードが有効になっている場合、画面の数字のみを入力するテキストボックスをクリックするとこのキーボードが自動的に表示されます。

  • 関数電卓 - このキーボードを使用すると数学関数にアクセスできます。このキーボードを開くキーは数字キーパッド上にあります。

キーボードを有効にするか非表示にするには、キーボードの色を定義し、キーの大きさを設定します。「付録A - コントローラの設定」の「キーボード設定タブ」を参照してください。

キーボード上の標準キー

下表はすべてのキーボードで表示されるキーについての説明です。

キー | 説明
押しピン
  • 画面のテキストボックスをクリックしたとき、画面の同じ位置に表示されるようにキーボードをピン留めするには、押しピンキーをクリックします。押しピンキーの背景がオレンジ色に変わります。
  • キーボードからピンを抜くには、背景がオレンジ色の押しピンをクリックします。画面のテキストボックスをクリックするとキーボードの位置が変わります。
閉じるキーを押すとキーボードが閉じます。
これらのキーを使用すると数字を入力できます。 | これらのキーを使用すると数字を入力できます。

英数字キーボード

英数字キーボード

下表はキーの説明です。

キー | 説明
a - z | これらのキーを使用すると小文字または大文字を入力できます。小文字キーを大文字キーに変えるには、abcキーをクリックします。
# | ポンド記号を入力します。
タブ | 現在のテキストボックスに対するキーボードを閉じて、カーソルを画面上の次のテキストボックスに移動します。
, | コンマを入力します。
!#? | 文字キーを記号キーに変更します。このキーをクリックすると、キーの背景がオレンジ色に変わります。記号キーを文字キーに戻すには、背景がオレンジ色の!#?キーをクリックします。
abc | 小文字キーを大文字キーに変更します。このキーをクリックすると、キーの背景がオレンジ色に変わります。大文字キーを小文字キーに変えるには背景がオレンジ色のabcキーをクリックします。
JP | 日本語のオペレーティングシステムの場合にのみ日本語変換キーが表示されます。(オペレーティングシステムが日本語でない場合、このキーは表示されません。)このキーをクリックすると、全角文字を使用できます。このキーをクリックしないと、半角文字を使用できます。
 | スペースキーを使用するとスペースを入力できます。
/ | フォワードスラッシュを入力します。
\ | バックスラッシュを入力します。
. | ピリオドを入力します。
 | バックスペースキーを使用すると、画面のテキストボックスにおけるカーソルの左にある文字を削除できます。
DEL | 画面のテキストボックス内のカーソルの右側の文字を削除します。
- | ハイフンを入力します。
 | Enterキーを使用すると画面のテキストボックスの新しい行にカーソルを移動することができます。
上方ペア矢印 | 前ページを表示。
下方ペア矢印 | 次ページを表示。
上方矢印 | カーソルを左の文字に移動します。
左矢印 | カーソルを左の文字に移動します。
右矢印 | カーソルを下の文字に移動します。
下矢印 | カーソルを下の文字に移動します。

数字キーパッド

数字キーパッド

下表はキーの説明です。

キー | 説明
Cal | 計算キーはキーボードを関数電卓に変更します。
 | バックスペースキーはキーボードのテキストボックスの文字を (右から左に) 削除します。
CLR | クリアキーは画面上のキーボードのテキストボックスおよびボックスにある文字を消去します。
- | マイナスを入力します。
. | 小数点を入力します。
 | Enterキーはキーボードのテキストボックスに表示される文字を画面上のボックスに入力します。

関数電卓

数字キーパッド上のCal (電卓)キーをクリックすると関数電卓が表示されます：

関数電卓

式を計算するには、数学記号をクリックして演算対象をクリックします。例えば、sin(60)+cos(60)を計算して電卓のテキストボックスに結果を表示するには下記のキーをクリックします：

sin(60)+cos(60)=

下表にキーの説明と例を示します。

キー | 説明 | キーのクリック例
Num | キーボードを数字キーパッドに変更します。 |
AC | 電卓のテキストボックス内の計算結果または式を消去します。 |
C | 電卓のテキストボックス内の最後の数を消去します。 |
( | 左括弧を入力します。 |
) | 右括弧を入力します。 |
Pl | Pi | Pl=
Abs | 絶対値を計算します。 | Abs3=
sin | 正弦を計算します。 | sin60=
cos | 余弦を計算します。 | cos60=
tan | 正接を計算します。 | tan60=
In | 対数を計算します。 | In6=
Inv | Inv (インバース) キーは sin、cos、tan、In、平方根および [mm->インチ]キーを逆関数に変更します。このキーをクリックするとキーの背景がオレンジ色に変わります： 逆関数 下記に逆関数について説明します： |
 | asin - アークサイン (逆正弦)。 | asin0.5=
 | acos - アークコサイン (逆余弦) を計算します。 | acos0.5=
 | atan - アークタンジェント (逆正接) を計算します。 | atan1=
 | exp - 指数を計算します。 | exp2=
 | x^2 - 二乗を計算します。 | 3x^2=
 | インチ->mm - キーボードのテキストボックス内の結果をインチから mm に変更します。 | inch->mm9=
 | 平方根キーは平方根演算を実行します。 | 16=
mm->inch (インチ) | キーボードのテキストボックス内の結果をmmからインチに変更します。 | mm->inch3=
= | Equalsキーは電卓のテキストボックスに算術演算の結果を表示します。画面のテキストボックスに結果を表示するには = キーをクリックした後にEnterをクリックします。 | 3+2=
/ | 2数での割り算を実行します。 | 3/2=
* | 2数での掛け算を実行します。 | 3*2=
- | 2数での引き算を実行するか、マイナス符号を入力します。 | 3-2=-3
+ | 2数を加算します。 | 3+2=
 | バックスペースキーはキーボードのテキストボックスの文字を (右から左に) 削除します。 |
CLR | Clear (消去) キーは画面のテキストボックスに表示された文字を消去します。 |
 | Enterキーはキーボードのテキストボックスに表示される文字を画面上のボックスに入力します。 |

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


自動モード

元の状態 > NC Gageの使用 > 自動モード (DCM)

自動モード (DCM)

NC Gage測定プログラムは、あたかも測定プログラムが自動モード(DCM)機能を使用したサブルーチンであるかのように実行中のマクロから直接実行できます。NC Gage測定プログラムはエラーを伴わずに実行を終了すると呼び出された実行中のマクロに戻ります。

NC Gage測定プログラムは測定機能またはワークオフセットアップデート機能から成ります。

DCM モードに入る

メイン画面の2ページ目で、自動モード ソフトキー [image] を押すと自動モード画面が表示されます：

自動モード画面

または、以下に示すように 拡張子–DLの付いたコマンドラインのショートカットを変更して、NC Gage起動時に自動モードを起動することができます。：

C:\.. \NCGage.exe –dl

NC Gage測定プログラムの呼び出し

実行中のマクロからNC Gage測定プログラムを呼び出すには、特別なマクロ (DCMマクロ) を呼び出し、NC Gage測定プログラムの名前(数字でなければなりません)を割り当てる必要があります。

  • NC Gage測定プログラムの名前は4桁の数字でなければなりません。この番号を使用してDCMマクロを呼び出し、実行の必要なNC Gage測定プログラムを指定します。

  • DCMマクロはNC Gageのマクロ番号に1を加えた数です。例えば、モニタマクロ番号が7400である場合、DCMマクロは7401になります。DCMマクロ番号はNC Gageの初期設定時にNC Gage設定ツールによって決定されます。詳しくは、「付録A - コントローラの構成」を参照してください。

1234.ncg という名前のNC Gage測定プログラムを実行中のマクロから呼び出すには、実行中のマクロに以下の構文を追加します：

G65 P7401 H1234

DCMモードでの実行中に、自動モード画面には実行中の測定プログラムが表示されます。また、測定プログラム実行時にリアルタイムでレポートが表示されます。NC Gageを適切に設定すると、計測ワークのレポートファイルが保存され、NC Gage 自動モード画面が公差範囲外の要素数を表示します。

エラー条件

誤トリガーによってエラー条件 (予期しない移動の終了) が発生した場合、NC Gageで実行の停止ソフトキー [image] を押します。また、機械の工具交換にて測定用にプローブを初期化できない場合、NC Gageによって実行中のマクロに戻ります。

「公差範囲外の数」オプションの例

情報エリアの公差範囲外の数オプションには、測定プログラムにおける公差範囲外の要素数が表示されます。

「公差範囲外の数」オプションの例

ナビゲーションバーのソフトキーの詳細については、「ナビゲーションバーソフトキー」を参照してください。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


情報マネージャ

この画面では、NC GageとNCの接続に関するメッセージと、NC Gageが遭遇するエラーメッセージを確認できます。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


ナビゲーションバーソフトキー

各画面のナビゲーションバーにあるソフトキーを以下に示します。いずれかのソフトキーにタッチすると、ソフトキーに関連する機能画面が開くか、指定された動作が実行されます。

用語注：ソフトキーは、各画面上の異なる機能に割り当てられた各画面の下部にあるタッチ可能なボタンです。複数「ページ」のソフトキーが表示される画面もあります。進むソフトキーを使用して、ソフトキーを変更することができます。

校正位置リストに角度を追加( [image]) - このソフトキーは、追加角度エリアの角度を読み取り、校正位置リストに追加します。

角度の構築( [image]) - このソフトキーは、角度の構築画面を開き、2つの要素の間の角度を計算することができます。

最後のステップに戻る( [image]) - このソフトキーは、現在の手順のステップに戻ります。

キャリブレーションテスト設定 ( [image]) - このソフトキーは、リングの設計値と許容値を示すことができるキャリブレーション値テスト画面を表示します。割り当てられた公差値以上に測定値がそれに対応する各設計値と異なる場合、警告が表示されます。警告を受入れた後に続行できます。設計値X、YおよびZを入力できます。X、Y、Z、Dでの公差とフォーム(F)を入力できます。

キャンセル ( [image]) - このソフトキーは、工具番号、直径の設計値、および長さの設計値欄に入力した情報をすべて消去します。

すべてのステップをキャンセル/中止 ( [image]) - このソフトキーは、現在の操作を停止してリセットします。要素をティーチングしている場合はティーチングされたプローブ位置がすべて削除されます。

クリア ( [image]) - このソフトキーは、B軸プローブのキャリブレーション全体を削除します。このソフトキーを押すとすべての古い校正を削除チェックボックスにチェックが付きます。実際の校正時には、これがチェックされていると「本当に削除しますか」というプロンプトが表示されます。消去ソフトキーを押さない場合、実行される任意の校正が以前の校正と結合されます。「消去」はPRBファイルがリセットされ、すべての測定が破棄されることを意味します。

クリア位置リスト ( [image]) - このソフトキーは、キャリブレーション位置リストのすべての入力項目を削除します。

選択をクリア( [image]) - このソフトキーは複数選択モードで選択された最初の測定プログラムのエンティティ以外のすべてを選択解除します。

同心度( [image]) - このソフトキーは同心度画面を表示します。これによってユーザーは1つの要素と別の要素の同心度を計算できます。

確認/コマンドの追加 ( [image]) - 操作の場合、このソフトキーは選択を確認します。コマンドの場合は、測定プログラムの最後にコマンドを追加します。要素コマンドの場合、機械が要素位置をティーチングした後またはユーザーが要素の設計値を入力すると使用できるようになります。構築および測定結果要素コマンドの場合、正しい入力要素を指定すると使用できるようになります。

現在のコマンドから最後まで確認して追加/変更( [image]) -このソフトキーは、現在の画面上のオプション、設定、または選択に加えられた変更を受け入れます。場合によっては、このソフトキーはNC Gage測定プログラムにコマンドを追加します。

校正の確認 ( [image]) -このソフトキーは校正を受け入れます。

変更を確認して保存 ( [image]) - このソフトキーは、設計値または公差の情報に対する変更を保存します。

ワークオフセットを確認してアップデート ( [image]) -このソフトキーは、機械のワークオフセットを決めるときに有効になります。コマンドを測定プログラムに保存します。

円の構築 ( [image]) – このソフトキーは円の構築画面を表示します。

線の構築 ( [image]) – このソフトキーは線の構築画面を表示します。

点の構築 ( [image]) – このソフトキーは点の構築画面を表示します。この画面は２つの線の交点、点から線への投影点、点と点の中間点を構成することができます。

コピー ( [image]) - このソフトキーは、測定プログラムツリービューで強調表示(選択)されたコマンドをコピーします。

カウンタ表示の設定 ( [image]) - このソフトキーはカウンタ表示の設定画面を表示します。カウンタ表示の設定を使用して、関連するカウンタ用NC Gage画面に表示される内容を定義できます。

プローブを新規で作成 ( [image]) - このソフトキーは、プローブを新規で作成画面を表示します。

カーソルモード切り替え ( [image]) -編集ウィンドウには２つのカーソルモードがあります。カーソルモード切り替え ソフトキーはこの2つを切り換えます。

切り取り ( [image]) - 測定プログラムのツリーから強調表示された(選択された)要素を削除します。 次に要素を他の場所に貼り付けることができます。

データバックアップ ( [image]) - このソフトキーはデータバックアップ画面を表示します。

校正球情報の定義 ( [image]) - 校正球の位置、サイズ、および向きを定義する値を手動で入力するための画面を表示します。または、位置読取り ボタンを使用してこれらの値をティーチングすることもできます。

ユーザー公差のチャート ( [image]) - このソフトキーは、ユーザー公差のチャート画面を表示します。詳しくは、「ユーザー公差チャート」を参照してください。

削除 ( [image]) - このソフトキーは測定プログラムのツリーから強調表示された(選択された)要素を永久に削除します。

校正を削除 ( [image]) - このソフトキーは現在の校正を削除します。

現在のコマンドを削除/最後に作成されたコマンドを削除 ( [image]) - このソフトキーは測定プログラムから現在選択されているコマンド(または最後に作成されたコマンド)を削除します。このアイコンが無効である場合、このソフトキーではなく測定プログラムの編集画面を使用してコマンドを削除しなければならないことがあります。

プローブの削除 [image] -このソフトキーは現在未校正のプローブを削除します。このソフトキーを使用して校正されたプローブを削除することはできません。

選択した測定プログラムを削除 ( [image]) - このソフトキーはリストから選択された測定プログラムを削除します。

自動モード ( [image]) - このソフトキーは、自動モード画面を表示します。あたかもNC Gage測定プログラムが自動モード (DCM) 機能を使用したサブルーチンであるかのように実行中のマクロから直接実行できます。

距離計算 ( [image]) - このソフトキーは、距離計算画面を表示します。それは２つの点タイプ要素の距離を計算することができます。

編集 ( [image]) - 要素を編集するには、ツリー表示から要素を選択してこのソフトキーを押します。編集のために選択したコマンドに対する適切な画面が編集モードで開きます。

測定プログラムの編集 ( [image]) - このソフトキーは、測定プログラムの編集画面を表示します。それは測定プログラムの実行や編集ができます。

プローブの編集 ( [image]) - このソフトキーは新規プローブを定義できるプローブの編集画面を表示します。

測定プログラムを実行 ( [image]) - このソフトキーは測定プログラムを実行できる測定プログラムを実行 画面を表示します。

実行 ( [image]) - このソフトキーを押すと機械が要素を測定します。このソフトキーは要素の位置を特定するための必要なすべてのプローブ位置がティーチング (または入力) された後にしか使用できません。これによって、ユーザーは測定プログラムに要素を実装する前に変更して試験実行することができます。

ブロックを実行 ( [image]) - このソフトキーによって、NC Gageは測定プログラムのツリーウィンドウで強調表示(選択)されている要素のみを実行します。

現在のコマンドから最後のコマンドまでを実行します ( [image]) -このソフトキーによってNC Gageは測定プログラムのツリーウィンドウで強調表示(選択)されている要素から測定プログラムの最後までを実行します。

測定プログラムを実行( [image]) - このソフトキーによって、NC Gageは測定プログラム全体を実行します。

測定プログラムを実行 ( [image]) – このソフトキーで測定プログラムを実行画面を表示して、測定プログラムを実行します。

終了 ( [image]) - このソフトキーによって、NC Gageが終了します。はい/いいえメッセージが表示されます。はい [image] を押すと終了します。いいえ [image] を押すとNC Gageへ戻ります。

Datapage Plus ( [image])にエクスポート - このソフトキーを使用すると、DP＋に読込むことができるXMLベースの出力ファイルにレポートデータをエクスポートすることができます。

ファイルマネージャ ( [image]) – このソフトキーを押すとファイルマネージャ画面が表示され、測定プログラムの保存、呼出し、作成、削除ができます。

中心を検索 ( [image]) - このソフトキーによって、ソフトウェアは校正用のリングを測定する前にサンプル計測点を取得しリングの中心を検索します。「リングの中心検索」を参照してください。

ボールの中心検索 ( [image]) - 機械に回転軸、回転ヘッドまたはリストがない場合、このボタンをクリックするとボールの中心検索画面が表示されます。このソフトキーを選択すると、ソフトウェアが起動してスピンドル方向でサンプル計測点を取得し、校正のために球を測定する前に球の中心を検索します。詳しくは、 「ボールの中心検索」を参照してください。機械にリストがある場合、ボールの中心検索ソフトキーを押すと回転軸校正基準球の中心座標計測画面が表示されます。ボールの中心検索画面で 確認ソフトキー [image] を押すと、球校正画面に関する情報が自動的に入力されます。

回転軸校正基準球の中心座標計測 ( [image]) - このソフトキーは校正球の中心位置、サイズおよび方向を測定するのに使用される回転軸校正基準球の中心座標計測画面を表示します。詳しくは、「回転軸校正基準球の中心座標計測」を参照してください。

回転軸角度の測定(平面) ( [image]) – このソフトキーを押すと、回転軸角度の測定(平面) 画面を表示します。

リスト校正位置の生成 ( [image]) - 開始角度、終了角度、箇所に基づいた校正位置を生成し、校正位置欄に追加します。

戻る ( [image]) - 有効なときこのソフトキーは、この画面の前のソフトキーへ戻します。

前へ ( [image]) -有効なときこのソフトキーは、この画面の次のソフトキーへ進ませます。

最初に移動 ( [image]) - このソフトキーは強調表示を測定プログラムの先頭に移動します。

元に戻す ( [image]) -このソフトキーは、編集ウィンドウのツリー表示に含まれるNC Gage測定プログラムを編集しているときに実行された前の変更または手順を元に戻します。最後に編集ウィンドウを開いたところまですべての手順を再実行(リドゥー)すことができます。

最後に移動 ( [image]) -このソフトキーによって強調表示が測定プログラムの最後に移動します。

ヘルプ ( [image]) - このソフトキーを使用するとNC Gageヘルプファイルにアクセスできます。

インチ / ミリ ( [image]) - このソフトキーを押すたびに、レポート表示のための測定単位がインチ系とミリ系の間で切り換わります。

情報マネージャ ( [image]) – このソフトキーを押すと、情報マネージャ画面が開き、NC Gageに関するメッセージを表示します。詳細は、「情報マネージャ」を参照してください。

現在位置の後に挿入 ( [image]) - このソフトキーは、コマンドを測定プログラムに追加しますが、測定プログラムの最後ではなく、測定プログラムのツリーで選択したコマンドの後に挿入します。

移動点の挿入 ( [image]) - このソフトキーはプローブの現在の位置を読み込んで安全高さでの移動として測定プログラムに挿入します。

回転軸角度の測定(突起) ( [image]) – このソフトキーを押すと、回転軸角度の測定(突起) 画面を表示します。

回転軸角度の測定(溝) ( [image]) – このソフトキーを押すと、回転軸角度の測定(溝)画面を表示します。

コマンドのティーチングと作成（実行） ( [image]) - このソフトキーは要素位置を特定するために必要なすべてのプローブ位置がティーチングされた後にのみ使用できます。これによって機械は要素を測定します。

選択された測定プログラムの読込み ( [image]) - このソフトキーはリストから選択された測定プログラムを読み込みます。

測定 ( [image]) -このソフトキーは、測定画面を開き、測定可能なすべての要素コマンドへのアクセスを提供します。

円の測定(内径) ( [image]) - このソフトキーは円の測定(内径) 画面を開きます。

円の測定(外径) ( [image]) - このソフトキーは 円の測定(外径)画面を開きます。

円錐の測定(内側) ( [image]) - このソフトキーは円錐の測定(内側) 画面を開きます。

円錐の測定(外側) ( [image]) - このソフトキーは円錐の測定(外側) 画面を開きます。

交点の測定(内側) ( [image]) - このソフトキーは交点の測定(内側) 画面を開きます。

交点の測定(外側) ( [image]) - このソフトキーは交点の測定(外側) 画面を開きます。

円筒の測定(内側) ( [image]) - このソフトキーは円筒の測定(内側) 画面を開きます。

円筒の測定(外側) ( [image]) - このソフトキーは円筒の測定(外側) 画面を開きます。

線の測定 ( [image]) - このソフトキーは線の測定画面を開きます。

平面の測定 ( [image]) - このソフトキーは平面の測定画面を開きます。

突起幅の測定 ( [image]) - このソフトキーは突起幅の測定画面を開きます。

点の測定 ( [image]) - このソフトキーは点の測定画面を開きます。

円の測定(シャフト) ( [image]) - このソフトキーは円の測定(シャフト) 画面を開きます。

球の測定 ( [image]) - このソフトキーは球の測定画面を開きます。

溝幅の測定 ( [image]) - このソフトキーは溝幅の測定画面を開きます。

移動点 ( [image]) – このソフトキーを押すと、安全な点と高さを指定する移動点画面を開きます。

下へ移動 ( [image]) - このソフトキーは編集ウィンドウの測定プログラムツリーにおいてカーソルを1項目下に移動します。複数選択モードがアクティブな場合、各エンティティが選択されてグループに追加されます。

上へ移動 ( [image]) - このソフトキーは編集ウィンドウの測定プログラムツリーにおいてカーソルを1項目上に移動します。複数選択モードがアクティブな場合、各エンティティが選択されてグループに追加されます。

新規測定プログラム ( [image]) - このソフトキーは新規測定プログラムを作成します。測定プログラムに対して行った変更を保存するかどうかを確認するためのメッセージが表示されます。

パスワード設定 ( [image]) - パスワード設定画面では、NC Gageの設定画面への不正な変更を防止するためにパスワード保護を行うことができます。

貼り付け ( [image]) - このソフトキーは切り取るかコピーした要素を測定プログラムに挿入します。

印刷 ( [image]) -このソフトキーは、画面に表示されている有効なキャリブレーションレポートを印刷します。

レポートの印刷 ( [image]) -このソフトキーはデフォルトの印刷デバイスにレポートを送信します。

プローブ ( [image]) -このソフトキーは、プローブ関連のソフトキーをナビゲーションバーに表示します。プローブを作成、選択、またはキャリブレーションするために使用できます。

位置読取り/次のステップへ進む ( [image]) - このソフトキーを使用すると現在のプローブ位置が読み込まれ、手順の次のステップに進みます。

レポート ( [image]) -このソフトキーはレポート画面に入り、測定プログラムの測定レポートを表示し、保存または印刷することができます。

戻る ( [image]) - このソフトキーはビュー(表示)を１レベルだけ前の画面に戻します。

前のステップに戻る ( [image]) - このソフトキーは最後にティーチングしたプローブ位置を削除します。

測定プログラムの保存 ( [image]) - このソフトキーは測定プログラムを指定した名前で保存します。

レポートをRTFファイルに保存 ( [image]) - このソフトキーはRTFファイルにその時点のレポートを保存します。ファイルのパス位置は画面上部にリストアップされます。ファイル名は測定プログラム名と同じで、レポートが保存されるたびにインクリメントされる数字が後に付きます。

レポートをRTFファイルに保存 ( [image]) - このソフトキーは、校正ファイルをRTF形式で指定されたファイル名に保存します。

レポートを下へスクロール ( [image]) - このソフトキーを押すと、レポート表示が1ページ下にスクロールされます。

レポートを上へスクロール ( [image]) - このソフトキーを押すと、レポート表示が1ページ上にスクロールされます。

プローブの選択 ( [image]) - プローブの選択画面が現在の画面でない場合は、このソフトキーによってこの画面にアクセスできます。プローブの選択画面が既に表示されている場合、このソフトキーにタッチするたびにプローブリストの各プローブがスクロールされます。

主軸の選択 ( [image]) -このソフトキーを使用すると、主軸の選択画面からNC Gage測定プログラムで使用する<745>主軸を選択できます。次に、このプログラムは測定プログラムに追加されて保存されます。

ワークオフセットの選択 ( [image]) -このソフトキーを使用すると、ワークオフセットの選択画面からNC Gage測定プログラムで使用するワークオフセットを選択できます。次に、このプログラムは測定プログラムに追加されて保存されます。

直径モードを選択 ( [image]) -クリックしてNC Gageを直径モードにします。直径モードにあるときは、画面の直径モードチェックボックスにマークが付いています。

測定面の選択 ( [image]) - このソフトキーはプローブ移動の方向と要素の安全高さでの移動の位置を定義します。複数回押して異なる測定面を選択することができます。

使用可能な面は：上、左、右、前、後ろ、斜面です。斜面が選択されている場合、ソフトキーのアイコンが斜面アイコンに変わります。

使用可能な面は：X+, X-, Y+, Y-, Z+, Z-です。

このソフトキーはそれが押されるたびに、XY平面、 YZ平面およびXZ平面からの測定平面オプションを切り換えます。

ワークオフセットを選択 /アップデートするワークオフセットを選択 [image] -このソフトキーはオフセットのリストから名前付きのワークオフセットを選択します。このソフトキーを再度押すとリストから次のワークオフセットが選択されます。このソフトキーを押すたびにワークオフセットのリストが1つずつスクロールします。

座標回転を設定 ( [image]) -このソフトキーは座標回転を設定画面を開き、NC Gage以外で機械を使用するときにワークオフセットの回転を変更することができます。

座標設定(点) ( [image]) - このソフトキーで座標設定(点)画面を表示します。

座標設定(溝中心,突起中心,段差) ( [image]) - このソフトキーで座標設定(溝中心,突起中心,段差)画面を表示します。

座標設定(点) ( [image]) - このソフトキーで座標設定(点)画面を表示します。

回転軸角度の座標設定(円筒平面) ( [image]) - このソフトキーで回転軸角度の座標設定(円筒平面)画面を表示します。

回転軸角度の座標設定(突起) ( [image]) - このソフトキーで回転軸角度の座標設定(突起)画面を表示します。

回転軸角度の座標設定(溝) ( [image]) - このソフトキーで回転軸角度の座標設定(溝)画面を表示します。

回転軸角度の座標設定(線) ( [image]) - このソフトキーで回転軸角度の座標設定(線)画面を表示します。

回転軸角度の座標設定(平面) ( [image]) - このソフトキーで回転軸角度の座標設定(平面)画面を表示します。

安全移動高さの設定 ( [image]) -このボタンはリスト軸の移動と移動の間で回転する安全高さを定義します。このボタンをクリックして、安全回転高さパラメータ値を自動的に更新します。このボタンについて詳しくは、「安全高さの設定を使用」を参照してください。

座標設定(球中心) ( [image]) - このソフトキーは球を測定し、測定された座標を使用して指定されたワークオフセットを設定します。

ワークオフセットの設定 ( [image]) - このソフトキーはさまざまな状況でワークオフセットを更新するために新しいソフトキーの付いた画面を表示します。このオプションは選択された要素を測定してコントローラでワークオフセットをアップデートします。このルーチンは測定プログラムに追加されません。

リスト校正角度の設定 ( [image]) - このソフトキーは校正位置のリスト軸位置角度を設定します。詳しくは、「リスト校正角度の設定」を参照してください。

座標設定(内径中心) ( [image]) - このソフトキーで座標設定(内径中心) 画面を表示します。

座標設定(外径中心) ( [image]) - このソフトキーで座標設定(外径中心) 画面を表示します。

座標設定(内径交点) ( [image]) - このソフトキーで座標設定(内径交点) 画面を表示します。

座標設定(外径交点) ( [image]) - このソフトキーで座標設定(外径交点) 画面を表示します。

設定( [image]) – このソフトキーを押すと、設定画面を開きます。そこでNC Gage測定プログラムに関する設定をすることができます。

測定面の設定 ( [image]) – このソフトキーを押すと、測定プログラムで使われる測定面の方向の定義ができます。詳しくは、「作業面の設定」を参照してください。

詳細を表示 ( [image]) - このチェックボックスを選択すると、ルビー補正値領域が表示されます。それは設計値からのルビーの補正を示します。これは詳細を表示 チェックボックスを有効にすると機能します。オフセットは偏差値です。フォームのエラーも表示されます。フォームのエラー はベクトル補正前の点の最小二乗最適誤差です。公差は校正試験の設定ボタンで入力されます。

詳細表示 ( [image]) - このソフトキーは自動モードでの測定プログラム実行に関するリアルタイム情報を表示します。

主軸タイプの並べ替え ( [image]) - このソフトキーは、主軸タイプの列をソートして、ファイルマネージャ画面の表示項目を昇順または降順に並べ替えます。最初にソフトキーを押すと、リストは昇順にソートされ、ソフトキーの上矢印が黒に変わります。

測定プログラム名の並べ替え ( [image]) - このソフトキーは測定プログラム名の列をソートして、ファイルマネージャ画面の表示項目を昇順または降順に並べ替えます。最初にソフトキーを押すと、リストは昇順にソートされ、ソフトキーの上矢印が黒に変わります。

コメントの並べ替え ( [image]) - このソフトキーはコメントの列をソートして、ファイルマネージャ画面の表示項目を昇順または降順に並べ替えます。最初にソフトキーを押すと、リストは昇順にソートされ、ソフトキーの上矢印が黒に変わります。

作成日の並べ替え ( [image]) - このソフトキーは作成日の列をソートして、ファイルマネージャ画面の表示項目を昇順または降順に並べ替えます。最初にソフトキーを押すと、リストは昇順にソートされ、ソフトキーの上矢印が黒に変わります。

実行を停止 ( [image]) -このソフトキーによってNC Gageは測定プログラムの実行を停止します。

フォーカス切替 ( [image]) - このソフトキーを使用すると、画面の異なるエリア間でカーソルの位置を切り替えることができます。

システム設定 ( [image]) - このソフトキーを使用するとNC Gageの画面設定と終了操作の設定ができます。詳しくは、「システム設定」を参照してください。

公差の設定 ( [image]) - このソフトキーでは、要素コマンドによって使用される要素の設計値と公差値を設定または変更することができます。それはレポート画面に表示される内容の概要です。

元に戻す( [image]) - このソフトキーは、編集ウィンドウのツリー表示に含まれるNC Gage測定プログラムを編集しているときに実行された前の変更または手順を元に戻します。最後に編集ウィンドウを開いたところまですべての手順を元に戻すことができます。

ワークオフセットのアップデート ( [image]) - このソフトキーはワークオフセットのアップデート画面を開き、測定プログラム終了時にワークオフセットをアップデートすることができます。

変数の書き込み ( [image]) - このソフトキーは変数の書き込み画面を開き、この画面からNCコントロールのマクロ変数に測定データを書き込むことができます。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


付録A - コントローラの設定(Mapps)

元の状態 > NC Gageの使用 > 付録Aーコントローラの設定

付録Aーコントローラの設定

ユーザーはコントローラの設定に役立つNC Gage設定ツールを使用することができます。NC Gageにおける各種コントローラの設定は通常、プローブのハードウェアを取り付ける人が行います。このトピックはそれらの参照用であり、設定ツールについて説明しています。

設定ツールは初期設定ダイアログ画面から選択した特定のコントローラタイプで使用するための1セットの計測 (プローブ移動)マクロを生成します。また、NC Gageマクロを保存するためにコントローラには十分なメモリ容量が必要です。

MAPPS IV

MAPPS IVは使いやすさを追求した新しい高性能オペレーティングシステムであり、業界最良のハードウェアを高性能アプリケーション/ネットワークシステムと結合します。MAPPSは現在、ファナックと三菱のコントローラで動作します。

ツールの使用

設定ツールを開くには、下記のうちの1つを実行します：

  • NC Gageソフトウェアをインストールした後に、NC Gageプログラムグループでショートカットをクリックします。

  • NC GageインストールディレクトリにあるNCGAGE_ConfigTool.exeをクリックします。

NC Gage設定ツールを起動すると以下の画面が表示されます：

NC Gage設定ツール画面

  1. コントローラモデルリストから適切なコントローラのオプションを選択します。

  2. 必要に応じて言語リストから適切な言語を選択します。

  3. OKボタンをクリックして、ユーザーが選択したコントローラおよび言語のNC Gage設定ツール画面を表示します。

  4. 画面上のタブのすべての項目を記入します。

タブ

NC Gage設定ツール画面は次のタブから成ります：

一般タブ

パラメータタブ

軸設定タブ

プローブタブ

キーボード設定タブ

ボタン

すべてのタブで以下のボタンを使用できます：

  • 初期値を使用 - このボタンはデフォルトで<出力ファイル名>.dat またはMappsMon.cnc.datに保存されたパラメータ一式を呼び出します。

  • 設定の読込み - NC GageはNCGAGE.DATファイルを使用してすべての設定情報を保存します。ファイルは常に同じフォルダに保存され、同じフォルダから読み込まれます。これによってユーザーは設定を「インポート」できます。設定の読込みボタンをクリックすると、ファイルオープンダイアログボックスが表示されます。このダイアログボックスを使用して読込みを行う設定ファイルを検索して読込むことができます。

  • 設定を保存 - このボタンはNCGAGE_ConfigTool.exe用の現在のパラメータ一式を、デフォルトで<出力ファイル名>.dat または MappsMon.cnc.datに保存します。

すべての画面をシステムで必要とされるとおりに設定したら、設定を保存ボタンをクリックしてマクロプログラムの生成ボタンをクリックします。

  • 機械からの読込み - コントロールから機械の変数を読み込もうとします。コントローラをNC Gageコンピュータに接続する必要があります。一般タブの接続パラメータエリアのIPアドレスとポート番号が正しくなければなりません。以下のパラメータが読み込まれます：

    • 工具オフセットの種類

    • 軸数

    • 軸文字とオフセット

    • コントローラの種類

  • マクロプログラムの生成 - このボタンは一般タブの出力ファイルボックスに入力されるファイルにマクロセットを作成します。

  • プログラムをアップロード - 生成されたマクロセットをコントローラにアップロードしようとします。コントローラの接続が「機械の読込み」と「接続パラメータ」で参照されるとおりに適切に設定されている必要があります。コントローラは編集モードでなければなりません。生成のために選択されるマクロエリアは書き込み可能でなければなりません。

  • 終了 - このボタンを押すと設定ツールが終了します。

通信ステータスバー

このバーはNC Gage設定ツール画面のボタンに沿って表示されます。機械の読込みまたはプログラムのアップロードボタンを押した後にコントローラーと機械間の通信が正常に行われたか否かのステータス(状態)に関するメッセージを表示します。

ファイル

  • NCGAGE.DAT - NC Gageでの機械の設定はXMLベースの NCGAGE.DATと呼ばれるファイルに含まれています。NC GageはこのNCGAGE.DATを機械の設定のために使用します。このファイルは設定の保存ボタンをクリックすると生成されます。

NCGAGE.DATの名前は変更できません。設定ツールの出力ファイルボックスで出力ファイル名を変更することができます。復元ファイル名は出力ファイル名に「.dat」を付けて作成されます。

  • FanucMonitor.cncまたはMitsubishiMonitor.cnc - このファイルはコントローラに読み込まれるCNC Monitor Macrosを含んでいます。正確な名前はMAPPS OSを実行する基底にあるコントローラによって異なります。

  • MappsMon.cnc.dat - このファイルは設定ツールの設定を復元します。

  • ヘッダスクリプトファイルとコントローラスクリプトファイル - これらのファイルは特定のコントローラ設定に対して定義済みです。それらを変更する必要はありません。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


一般タブ

選択されたコントローラに対するNC Gage設定ツールの一般タブを下記に示します：

一般タブ

単位 - 適切な測定単位 (MMまたはイInch) を選択します。これらは機械での単位設定です。NC Gageはコントローラの単位設定で動作することに注意してください。

機械の名称 - この名前はスペースや特殊文字を含まない任意のテキストです。文字間に区切りがあった方がいい場合はアンダースコアを使用してください。

コントローラの種類 - このリストを使用してNC Gageがインタフェースで接続するコントローラの種類を選択します。現在サポートされている通信方式は基盤のコントローラによって異なります。

IP アドレス – コントローラのインターネット プロトコル (IP) アドレスです。この一意のアドレスによってコンピュータネットワーク上のコントローラを識別します。 pingテストで接続を確認し、コンピュータがコントローラと同じ [image] [image] サブネットマスクを使用しているかどうか確認する必要があります。これはNC Gageが別のコンピュータにインストールされている場合にコントローラを ping することによって試験することができます。一部のシステムでは、コンピュータの IP アドレスが機械のツールの IP アドレスと 1 桁だけ異なる必要があります。例えば、機械のツールの IP アドレスが 192.168.0.1 の場合、コンピュータの IP アドレスは 192.168.0.2 に設定する必要があります。

Ping テスト：ping テストを行うには、コマンドプロンプトウィンドウを開き、「ping」とコントローラのIP アドレスを入力します。ENTERキーを押すと、テストが開始されコントローラとの一時的な接続を確立しようとします。接続を確立できない場合、「request timed out. (リクエストがタイミアウトしました) 」というメッセージがコマンドプロンプトウィンドウに表示されます。

サブネットマスク：これによって、ITサポート担当者はこれをコントローラと同一に設定できます。

イーサネット - イーサネットポートを介して通信が行われます。

HSSB - 高速シリアルバス（HSSB）を介して通信が行われます。このオプションを選択すると、IPアドレスとポートオプションは表示されません。

ポート - イーサネット通信オプションを選択する場合、ポートオプションはコントローラのポート番号を定義します。ポートは接続されたコンピュータからどのような情報が許可されるかを制御します。

工具番号 > 200 - 工具番号が 200 より大きい場合、このチェックボックスを選択します。

出力ファイル - これはマクロプログラムの生成ボタンをクリックしたときに作成される出力マクロファイルの名前です。.dat 拡張子の付いたファイル名も復元ボタン操作のためのデータファイルであることに注意してください。これを変更してはいけません。

座標回転マクロ＃ - NC Gageで座標回転の作業をしたい場合は、このチェックボックスを選択します。このチェックボックスは、特定の座標回転オプション(使用されるG68またはG68.2マクロコードのいずれか)を指定します。

G68 - コントローラで G68 コードが利用可能な場合はこのオプションを選択します。

G68.2 - コントローラで G68 コードが利用可能な場合はこのオプションを選択します。

主軸の角度割出マクロ- ここに機械のコードを配置してスピンドルの向きを決めます。機械にこの機能がない場合はこのオプションの内容を消去します。与えたコードに変数が追加されて角度を含むようになります。以下に例を記載します：

  • 入力するコード：M19S

  • 生成されるコード：M19S#1

PCI - この通信オプションは、 MAPPSがMitsubishiのコントローラを検出したときにのみ使用できます。通信はPCI ポートを介して行われます。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


Appendix_A_-_Controller_Configuration_(Fanuc)_-_Parameters_Tab.htm

元の状態 > NC Gageの使用 > 付録Aーコントローラの設定 > パラメータタブ

パラメータタブ

NC Gage設定ツールのパラメータタブを下記に示します。

パラメータタブ

速度エリア

早送り速度（mm /min） - 計測しないときにプローブが移動する最大速度を設定します。単位は一般タブで選択した mm/minまたは in/minとなります。mm/minの場合の初期値は3000です。in/minの場合の初期値は120です。

計測速度（mm/min） - プローブが測定面を検索するときに移動する速度を設定します。単位は一般タブで選択したmm/minまたはin/minとなります。mm/minの場合の初期値は100です。in/minの場合の初期値は4です。

早送り回転速度（mm/min） - 主軸や回転テーブルなど、すべての回転軸の速度を設定します。単位は一般タブで選択したmm/minまたはin/minとなります。mm/minの場合の初期値は1000です。in/minの場合の初期値は40です。

アドレスエリア

ローカル変数 - NC Gageが情報を転送するのに使用する変数の開始アドレスです。現在、NC Gageは31を使用しています。コントローラをシャットダウンする前にこの情報を保存する必要はありません。

コモン変数 - これはNC Gageが使用する変数の開始アドレスです。この変数は移動、計測および工具に対する定数を設定します。現在NC Gageは11を使用しています。コントローラをシャットダウンする前にこの情報を保存する必要があります。

プログラム番号 - モニターのマクロ生成用アドレスを設定します。

プローブエリア

プローブのPLCビットアドレス - これはPLCのプローブ起動ビットのアドレスです。

工具エリア

工具番号アドレス - これは現在の工具のアドレスです。このオプションには必要に応じてマクロ変数またはPLCアドレスを入力することができます。この値はコントローラがそのメモリに工具データを保存する方法を決定します。デフォルト値は工具オフセットです。

工具補正タイプ - 機械のコントローラにおいて工具長を記録するための各種方法を分類します。

    • 工具長管理に関して機械に幾何学的長さしかなく摩耗長さがない場合はAを選択します。差異は幾何学的長さに追加されます。

    • 工具長管理に関して機械に幾何学的長さと摩耗長さの両方がある場合はBまたはCを選択します。差異は摩耗長さに追加されます。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


軸設定タブ

NC Gage設定ツールの軸設定タブを下記に示します：

軸設定タブ

軸の有/無 - それぞれの軸の有/無を設定します。最低でも3軸が必要です。サポートされている場合、機械からの読込み を使用すれば軸一覧の識別用文字と一緒に設定されます。Ｘ、ＹおよびＺ軸は常に設定され削除できません。

軸のタイプ - タイプには直線軸、回転軸またはリストがあります。例えば回転軸を設定する場合：

  • 設定したい軸の有/無チェックボックスをチェックします。

  • 軸のタイプから回転軸を選択します。

  • 軸一覧から回転軸を識別する文字を選択します。「X」、「Y」、「Z」、「U」、「V」、「W」、「A」、「B」、「C」、「無し」から選択できます。通常、線形系はX、YおよびZ識別子によって識別され、回転系はA、BおよびC識別子によって識別されます。

  • 重ねられた回転軸を使用する場合、回転軸の重ね順の一覧から順番を選択します。このオプションは複数の回転軸を定義しない場合は使用できません。

軸一覧 - 軸を識別する文字で、「X」、「Y」、「Z」、「U」、「V」、「W」、「A」、「B」、「C」、「無し」から選択できます。

オフセット - - これは軸マップでのオフセットを設定します。例えば、機械にXYZの線形軸とB軸の回転軸がある場合、オフセットは1,2,3,4になります。構成に含まれないスレーブ軸が存在することが多いため、軸マップがスキップされます。そのため、同じ機械が例えば、1,3,4,5 というマップを持つことがあります。

下限公差、上限公差 - 機械の可動範囲を入力します。これらが不明の場合は空白にしておいてください。

アンクランプ用Mコード、クランプ用Mコード - クランプを使用する場合にMコードを入力します。

回転軸の重ね順 - 複数の回転軸を定義するときに回転軸の順番を定義します。

リストが0にあるときのプローブ方向 (チップからスピンドル) - リストがゼロ位置にあるときのプローブルビーの方向（ルビーからスピンドル方向）を設定します。「Z+」、「Z-」、「Y+」、「Y-」、「X+」、「X-」から選択できます。

ピボット種類 - ピボットの種類を設定します。「リストゼロ」と「リスト中心」から選択できます。

ピポット距離計算 - リストのピボットの距離を入力します。

回転軸の重ね順の一覧は2つの回転軸を定義するときに設定ツールの軸設定タブでのみ使用できます。回転軸とリストを定義する場合 (ミル旋盤でのように)、回転軸の重ね順の一覧は下記の画像に示すとおりリストが0にあるときのプローブの方向 (ルビーからスピンドルの方向) およびビボットエリアに置き換わります。

このケースに当てはまらない場合、エリアは表示されません。リストをミル旋盤で定義する場合はB軸に設定し、回転軸はC軸に設定しなければなりません。

回転に関する図（下の図は反時計回り（いいえ）を示しています）

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


プローブタブ

NC Gage設定ツールのプローブタブを下記に示します：

プローブタブ

プローブオン用マクロ - プローブの有効化に必要なマクロコードです。

プローブマクロの読込み - プローブの読込みに必要なマクロコードです。

プログラム開始マクロ - マクロプログラムを起動するときに実行される必要のあるマクロコードです。

プローブオフ用マクロ - プローブの無効化に必要なマクロコードです。

プローブ動作確認マクロ - プローブがオンになっており、移動できるかどうかをテストするのに必要なマクロコードです。

プログラム終了マクロ - マクロプログラムを終了するときに実行される必要のあるマクロコードです。

すべてのタブをシステムで必要とされるとおりに設定したら、設定の保存ボタンを選択してマクロプログラムの生成ボタンをクリックします。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●


キーボードタブ

NC Gageでオンスクリーンキーボードを有効または無効にするには、 NC Gage設定ツールのキーボードタブを選択します。

キーボードを有効にするには、使用するチェックボックスを選択して下記の画面を表示します：

キーボードタブ

キーボードエリア

使用する - このチェックボックスをチェックし、各画面の英数字入力テキストボックスをクリックするとオンスクリーンキーボードが表示されます。数字入力テキストボックスをクリックすると数字キーボードが表示されます。オンスクリーンキーボードを表示したくない場合、このチェックを解除します。

背景色 - これはキーボードの背景色を設定します。

キーエリア

大きさ - これはキーのサイズを設定します。

枠色 - これはキーの縁の色を設定します。

背景色エリア

通常時 - これはキーの背景色を設定します。

選択時 - これはマウスポインタがキーの上に来たときのキーの色を設定します。

押下時 - これはキーをクリックしたときのキーの色を設定します。

文字エリア

大きさ- これはキー上の文字のフォントサイズを設定します。

色- これはキー上の文字の色を設定します。

色の選択

キーボードタブ上で色を選択するには：

  1. 色が表示されている四角形の部分をクリックします。色の設定画面が表示されます：

色の設定

  2. 基本色から選択する場合は、希望の色をクリックします。カスタム色を選択するには色の作成を選択し、希望の色を作成します。

  3. OKをクリックしてキーボードタブに戻ります。

3.4
ERROR: Variable (ProjectName) is undefined.

>> トップに戻ります

ドキュメンテーションチームに問い合わせる

PDF 文書

>> Readme.pdf

>> 印刷可能なマニュアル

サポートリンク

>> 知識ベース

>> Hexagon技術サポート

>> フォーラム

>> Ideas

>> トレーニング ●