Using PC-DMIS NC Gage

Introducing NC Gage

Licensing

Configuration

Getting Started

Creating Feature Commands

Setting Additional Feature Parameters

Inserting Move Commands

Working with Measurement Routines

Managing Files

Using Reports

Using the On-Screen Keyboards

Direct Connect Mode (DCM)

Appendix A - Controller Configuration

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●

Company Information

Hexagon Manufacturing Intelligence

>> http://www.hexagonmi.com ●

Product Information

NC Gage 3.2

Copyright © 2017 Hexagon Metrology

Help System last generated on May 04, 2017


Introducing NC Gage

PC-DMIS NC Gage provides an easy-to-use product for online part measurement using NC machine tools. NC Gage can enhance your machine part productivity and precision by providing you with a user interface that you can use to insert feature measurements and other commands into your measurement routine.

Terminology Note: Since many users run NC Gage on a touch screen display, the terms "select" or "press" used in this documentation indicate a mouse click when running the software on a PC with mouse and keyboard peripherals attached.

This documentation discusses the following main topics:

  • Licensing

  • Configuration

  • Getting Started

  • Creating Feature Commands

  • Setting Additional Feature Parameters

  • Inserting Move Commands

  • Working with Measurement Routines

  • Managing Files

  • Using Reports

  • Direct Connect Mode (DCM)

  • Appendix A - Controller Configuration

Help File Last Updated:May 04, 2017

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●

Company Information

Hexagon Manufacturing Intelligence


Licensing

NC Gage runs in Basic Level mode with limited usage. You need to have a license key to use five axes and set up kinematics. The software license requires your machine's serial number.

  1. On the main screen, navigate to the second page, and click the Information Manager [image] soft key to display the Information Manager screen.

  2. Click the Update License [image] soft key to display the Register screen.

  3. Copy the machine's serial number, and send it to your local Hexagon representative.

  4. When you receive your license key, type it in the License Key box. The License Information area automatically updates with information based on your license.

  5. Click the Apply Changes [image] soft key to complete the licensing procedure.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Configuration

Before you work with NC Gage, you need to configure it according to your machine tool settings. This work is normally done by the person who installs your probe hardware.

The Okuma controller must be configured using the A MTD mode and NOT the S MTD mode.

For a detailed description of the controller configuration, see "Appendix A - Controller Configuration" .

NC Gage requires that .NET 2.0 is installed on the computer that will run NC Gage. If .NET 2.0 is already installed, then NC Gage will be installed when requested to do so. If .NET 2.0 is not installed, then the installation routine will ask the user if they would like to download and install it now. Pressing OK links you to the Microsoft web site where you can download and install .NET 2.0.

Windows OS Note: If using a virtual machine utility (VMWare for example) to run NC Gage in another language other than English, the Windows OS may pick up and update to the virtual machine clients' regional/language settings automatically (periods may change to commas, for example.) If switching back to the English language from a foreign language, these changes need to be manually reset using the Regional and Language settings within the Windows OS Control Panel to prevent measurement errors.

Updating Windows Region and Language Settings

  1. Navigate to the Control Panel:

  2. Click Region and Language. Make changes, if necessary, on the Region and Language screen:

  3. Click:

    • OK to accept the changes that you made and return to the Control Panel

    • Cancel to exit without saving

    • Apply to save the changes made without exiting

  4. Click Additional settings. Make the necessary changes for the specific region and language settings:

  5. Click:

    • OK to save the changes that you made to the Customize Format screen and return to the Region and Language screen

    • Cancel to exit without saving

    • Apply to save the changes made without exiting

Go to "Getting Started".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Getting Started

These topics help you start using PC-DMIS NC Gage. Before you begin:

  • Your NC machine should be powered on.

  • Your NC Gage software should be installed and licensed.

  • Your software should have been configured. For more information, see "Appendix A - Controller Configuration".

The steps include:

  • Step 1: Starting and Connecting the Software

  • Step 2: Setting NC Gage Parameters

  • Step 3: Creating a New Probe

  • Step 4: Selecting a Probe

  • Step 5: Calibration

  • Step 6: Defining a Work Offset

  • Step 7: Defining Control Frames

  • Step 8: Defining a Clearance Path

About Systems Messages

As you work through these steps, pay attention to the information in the System Messages area in the main NC Gage screen:

Sample System Messages area

  • Messages that appear in red text indicate a required procedure that has not been done yet or some other problem.

  • The Warning message tells you what needs to be done next before you can start measuring your part.

  • When you complete a required step, that item in the System Messages area appears in blue text.

Once you complete the above steps, you can use NC Gage to create and execute a measurement routine.

For more information on Navigation Bar Soft Keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Starting and Connecting the Software

Home > Using PC-DMIS NC Gage > Getting Started > Step1: Starting and Connecting the Software

Step 1: Starting and Connecting the Software

After you install and license the NC Gage application, do one of the following to launch the NC Gage application:

  • Select it from the program group

  • Start Windows, click the Start button, point to All Programs, and then select the PC-DMIS NC Gage program icon from the defined program group:

The main screen for NC Gage opens:

When you first open NC Gage, it attempts to connect to your machine tool. Information about this connection appears in the Status area.

If the Status soft key in the middle of the navigation bar is red, then the software could not connect to the machine:

When NC Gage connects to the machine, it displays the probe location coordinates on the screen. The Status soft key in the middle of the navigation bar becomes green, and it displays “Connected” in the Status area.

If this is your first time starting NC Gage, the Calibration option in the System Messages area displays "--None--". In addition, the Measure [image] and Move [image] soft keys on the navigation bar are disabled (grayed out and unavailable for selection). These indicate that you need to take some preliminary steps before you can use the software to create a measurement routine and measure the part.

The next item you need to resolve is listed in the Warning: message of the System Messages area.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Set NC Gage Parameters

Home > Using PC-DMIS NC Gage > Getting Started > Step 2: Setting NC Gage Parameters

Step 2: Setting NC Gage Parameters

You can use the Setup screen to define several measurement and hardware parameters that are used during measurement.

Press the Setup soft key [image] on the main screen to display the Setup screen:

To modify the general NC Gage parameters:

  1. Modify values as needed.

  2. Press the Confirm soft key [image] to save your changes. Or, press the Return soft key [image] to exit this screen without saving.

For more information on Navigation Bar Soft Keys, see "Navigation Bar Soft Keys".

Select the Main Spindle or Sub Spindle option based on your requirement. The default selection is Main Spindle. The last-selected option becomes the default selection the next time you open NC Gage. If you select Sub Spindle, the background color of the measurement routine tree view area on screens such as the main screen and the Execute Measurement Routine screen turns light blue. Also, the heading on this area displays Sub-Spindle Active.

Tolerance Area

  • Plus - Specifies the default plus tolerance value by which your part dimensions are evaluated.

  • Minus - Specifies the default minus tolerance value by which your part dimensions are evaluated.

  • Set these values to specify tolerances for future recall on the Tolerance screen of any feature by using the Select Global Tolerance Limit list located on that screen. This provides you with a rapid way of selecting and entering the same tolerance values repeatedly. See "User Tolerance Chart".

Report Save Option Area

  • Saved Path - Specifies the location to where the report is saved. The measurement routine also saves to the same path in the subdirectory PRG.

  • Auto Save - This automatically saves reports when you execute the measurement routine. Once you select this check box, the Overwrite and Time Stamp options become available.

    • Overwrite - If you select this option, NC Gage automatically saves the first report to the location specified for Saved Path. NC Gage automatically replaces this report the next time you create it.

Each report has the same file name. The format is: <measurement routine>.rtf, where <measurement routine> is the name of the last measurement routine that executed.

    • Time Stamp - If you select this option, NC Gage automatically saves each report to the location specified for Saved Path. NC Gage does not replace any saved reports.

Each report has a different file name. The format is: <measurement routine>_<M>-<DD>-<YY>_<hh>-<mm>-<ss>.rtf, where:

<measurement routine> - Name of the measurement routine that is currently loaded, without the ".prg" extension

<M> or <MM> - One-digit or two-digit month, based on your computer system's date

<DD> - Two-digit day, based on your computer system's date

<YY> - Four-digit year, based on your computer system's date

<hh> - Two digits of the hour (24-hour time) that the report is saved, based on your computer system's time

<mm> - Two digits of the minute that the report is saved, based on your computer system's time

<ss> - Two digits of the second that the report is saved, based on your computer system's time

Note that the 24-hour time stamp notation for the file name indicates the time at which the report was saved (not the time at which the measurement routine was executed). Therefore, if you continuously save the same report, each report will have a different file name.

You can manually save a report at any time regardless of how you set the reporting options. The format of the file name for a manually-saved report is: <measurement routine>_<MM>-<DD>-<YY>_<hh>-<mm>-<ss>.rtf

Feed Rate and Probing Distance Areas

  • Traverse (Feed Rate) - Determines the probe travel speed between measurement routine blocks. The units are millimeters/minute or inches/minute based on the unit selection.

  • Finding (Feed Rate) - Determines the speed at which the probe travels when discovering features in learn mode. The units are millimeters/minute or inches/minute based on the unit selection.

  • Rotation (Feed Rate) - Determines the maximum allowed axes rotation speed.

  • PreHit (Probing Distance) - Specifies the distance from the theoretical hit location to which the probe will move before taking a hit. This is used during part measurement. The units are millimeters or inches based on the unit selection.

  • Search (Probing Distance) - Provides the distance that the probe will search for the surface. If the probe does not come in contact with the surface before reaching this distance, the measurement will fail. The units are millimeters or inches based on the unit selection.

Snap Decimal Accuracy Area

  • Dimension Snap Value - Causes NC Gage to round the nominal results that are found for any feature by the probe during the learn process. The results are rounded using two criteria. First, the results are rounded to the number of decimal values in this field. Second, the results are rounded to the nearest multiple in this field.

As an example, if the result is 0.068 and the value in this box is 0.03, then the process would be as follows: First, the 0.068 would be rounded to two decimal places, which would result in 0.07. Next, the value would be rounded to the nearest magnitude of "3", which would modify 0.07 to 0.06 since "6" is a multiple of "3."

  • Angle Snap Value - Works in the same principal as the dimension snap value, but for angle measurement.

Statistics Save Option Area

  • Saved Path - Specifies the folder to hold saved reports. You can save the report in an xml or csv format. To do this, select either the XML or CSV option. You can save the measurement routine in the STAT folder of the same path.

  • Auto Save - This automatically save the statistics when you execute the measurement routine. Once you select the check box, the Overwrite and Time Stamp options become available.

    • Overwrite - If you select this option, NC Gage automatically saves the first set of statistics to the location specified for Saved Path. NC Gage automatically replaces the statistics the next time you create them.

Each set of statistics has the same file name. The format is: <measurement routine>.rtf, where <measurement routine> is the name of the last measurement routine that executed.

    • Time Stamp - If you select this option, NC Gage automatically saves each set of statistics to the location specified for Saved Path. NC Gage does not replace any saved statistics.

Each set of statistics has a different file name. The format is: <measurement routine>_<M>-<DD>-<YY>_<hh>-<mm>-<ss>.xml, where:

<measurement routine> - Name of the measurement routine that is currently loaded, without the ".prg" extension

<M> or <MM> - One-digit or two-digit month, based on your computer system's date

<DD> - Two-digit day, based on your computer system's date

<YY> - Four-digit year, based on your computer system's date

<hh> - Two digits of the hour (24-hour time) that the statistics are saved, based on your computer system's time

<mm> - Two digits of the minute that the statistics are saved, based on your computer system's time

<ss> - Two digits of the second that the statistics are saved, based on your computer system's time

Note that the 24-hour time stamp notation for the file name indicates the time at which the statistics were saved (not the time at which the measurement routine executed). Therefore, if you continuously save the same set of statistics, each set will have a different file name.

You can manually save a set of statistics at any time regardless of how you set the statistical options. The format of the file name for a manually-saved set of statistics is: <measurement routine>_<MM>-<DD>-<YY>_<hh>-<mm>-<ss>.xml

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


User Tolerance Chart

Use the User Tolerance Chart screen to specify tolerances for future recall on the Tolerance screen of any feature by using the Select Global Tolerance Limit list located on that screen. This provides you with a rapid way of selecting and entering the same tolerance values repeatedly.

To define user tolerances:

  1. Press the Setup soft key [image] on the main screen.

  2. Press the Define Tolerance Chart soft key [image] to display the User Tolerance Chart screen:

  3. For the desired TC classes, type the +Limit or -Limit tolerance values.

  4. Once you have defined TC classes, press the Apply Changes soft key [image]. You can then select these TC classes from the Tolerance screen.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Work Face Setup

Use the Work Face Setup screen to define the orientation of the [image] [image] Work Face soft key found throughout the software. A work face is the side of the part that will be measured. This setup screen is helpful if the computer monitor that displays NC Gage is not always in a fixed position around the machine tool. Use this screen to customize the setup of the work face icon, or select default work face configurations.

To set up the work face:

  1. Press the Setup soft key [image] on the main screen.

  2. Press the Setup Work Face Orientation for Machine soft key [image] to display the Work Face Setup screen:

  3. Select a default configuration, or define your own custom configuration.

  4. When you have defined the work face, press the Confirm soft key [image] . Then throughout the software, each time the Work Face soft key is pressed, the software will use the work face defined here.

  5. Press the Confirm soft key [image] to save any changes made. Press the Return soft key [image] to return to the previous screen without saving.

A left-handed setup is allowed. NC Gage will inform you when you are using this non-standard setup.

This section includes:

  • Selection of Measurement Face (Milling Machine)

  • Selection of Measurement Face (Millturn Machine)

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Selection of Measurement Face (Milling Machine)

You can select the measurement face for the machining center.

  1. From the Work Face Setup screen, select the Default for Vertical Machine option.

  2. Press the Apply Changes soft key [image] .

  3. Press the Return soft key [image] to return to the main screen.

  4. From the main screen, press the Measure soft key [image].

  5. Press the Point soft key [image] on the Measure screen to display the Measure Point screen.

  6. Press the Select Measurement Face soft key [image] and choose the work face for the point:

The diagram shows the position of the probe above the positive Z-axis direction of the measurement face

The probe direction does not depend on the angle of the rotary axes:

- The probe moves from the positive Z-axis to the negative Z-axis direction.

- The probe moves from the negative X-axis direction to the positive X-axis direction.

- The probe moves from the positive X-axis direction to the negative X-axis direction.

- The probe moves from the negative Y-axis direction to the positive Y-axis direction.

- The probe moves from the positive Y-axis direction to the negative Y-axis direction.

When the rotary axes does not rotate, the XYZ value is the final measurement value.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Selection of Measurement Face Millturn Machine

Home > Using PC-DMIS NC Gage > Getting Started > Step 2: Setting NC Gage Parameters > Work Face Setup > Selection of Measurement Face (Millturn Machine)

Selection of Measurement Face (Millturn Machine)

To select measurement face, you can use one of the following patterns:

  • Default setting

  • B-axis=0

  • B-axis=90

The Z-axis direction of the measurement face is always the probe direction.

The diagram shows when the B-axis rotates, the measurement face also rotates such that the Z-axis direction is always the probe direction.

When the rotary axes does not rotate, the XYZ value is the final measurement value.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Default Setting

  1. From the Work Face Setup screen, select the Default for Vertical Machine option.

  2. Press the Apply Changes soft key [image] .

  3. Press the Return soft key [image] to return to the main screen.

  4. From the main screen, press the Measure soft key [image].

  5. Press the Point soft key [image] on the Measure screen to display the Measure Point screen.

  6. Press the Select Measurement Face soft key [image] and choose the work face for the point:

The probe direction does not depend on the angle of rotation of the C-axis:

- The probe on a plane parallel to the probe shaft moves from the positive Z-axis direction to the negative Z-axis direction.

- The probe on a plane perpendicular to the probe shaft moves from the negative X-axis direction to the positive X-axis direction.

- The probe on a plane perpendicular to the probe shaft moves from the positive X-axis direction to the negative X-axis direction.

- The probe on a plane perpendicular to the probe shaft moves from the negative Y-axis direction to the positive Y-axis direction.

- The probe on a plane perpendicular to the probe shaft moves from the positive Y-axis direction to the negative Y-axis direction.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


B-axis equal to zero

Home > Using PC-DMIS NC Gage > Getting Started > Step 2: Setting NC Gage Parameters > Work Face Setup > Selection of Measurement Face (Millturn Machine) > B-axis (Equal to 0)

B-axis=0

  1. From the Work Face Setup screen, select the Customized option.

  2. From the Define Orientation section:

    • For the 1st box, from the list, select X+.

    • For the 2nd box, from the list, select Y+.

    • For the 3rd box, from the list, select Z+.

  3. Press the Apply Changes soft key [image] .

  4. Press the Return soft key [image] to return to the main screen.

  5. From the main screen, press the Measure soft key [image].

  6. Press the Point soft key [image] on the Measure screen to display the Measure Point screen.

  7. Press the Select Measurement Face soft key [image] and choose the work face for the point:

The probe direction does not depend on the angle of rotation of the C-axis:

- The probe on a plane parallel to the probe shaft moves from the positive Z-axis direction to the negative Z-axis direction.

- The probe on a plane perpendicular to the probe shaft moves from the negative X-axis direction to the positive X-axis direction.

- The probe on a plane perpendicular to the probe shaft moves from the positive X-axis direction to the negative X-axis direction.

- The probe on a plane perpendicular to the probe shaft moves from the negative Y-axis direction to the positive Y-axis direction.

- The probe on a plane perpendicular to the probe shaft moves from the positive Y-axis direction to the negative Y-axis direction.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


B-axis (Equal to 90)

  1. From the Work Face Setup screen, select the Customized option.

  2. From the Define Orientation section:

    • For the 1st box, from the list, select Z+.

    • For the 2nd box, from the list, select Y+.

    • For the 3rd box, from the list, select X-.

  3. Press the Apply Changes soft key [image] .

  4. Press the Return soft key [image] to return to the main screen.

  5. From the main screen, press the Measure soft key [image].

  6. Press the Point soft key [image] on the Measure screen to display the Measure Point screen.

  7. Press the Select Measurement Face soft key [image] and choose the work face for the point:

The probe direction does not depend on the angle of rotation of the C-axis:

- The probe on a plane parallel to the probe shaft moves from the positive Z-axis direction to the negative Z-axis direction.

- The probe on a plane perpendicular to the probe shaft moves from the negative X-axis direction to the positive X-axis direction.

- The probe on a plane perpendicular to the probe shaft moves from the positive X-axis direction to the negative X-axis direction.

- The probe on a plane perpendicular to the probe shaft moves from the negative Y-axis direction to the positive Y-axis direction.

- The probe on a plane perpendicular to the probe shaft moves from the positive Y-axis direction to the negative Y-axis direction.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


System Setup

The System Setup screen provides:

  • Control settings for the NC Gage screen in the Screen Setup area

  • Selections on how the NC Gage application shuts down in the Exit Behavior area

To set up the system:

  1. Press the Setup soft key [image] on the main screen.

  2. Press the System Setup soft key [image] to display the System Setup screen:

Screen Setup Area

Allow Repositioning - Repositions the NC Gage screen anywhere on the display screen.

Allow Resizing - Resizes the NC Gage screen.

Allow Minimizing - Minimizes the NC Gage screen.

Exit Behavior Area

Exit - The NC Gage application exits only when initiated from the NC Gage interface.

Logoff - The NC Gage application exits when initiated from the NC Gage interface, but also logs off the current PC user account.

Shutdown - The NC Gage application exits when initiated from the NC Gage interface, but also shuts down the PC.

Execute a File - The NC Gage application exits when initiated from the NC Gage interface, but also runs the selected file afterwards.

Press the Confirm soft key [image] to save any changes that you made. Or, press the Return soft key [image] to return to the previous screen without saving.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Password Setup

Use the Password Setup screen to set up a password for the NC Gage application to prevent unauthorized changes to the system settings.

  1. Press the Setup soft key [image] on the main screen.

  2. Press the Password Setup soft key [image] to display the Password Setup screen:

  3. Press the Confirm soft key [image] to save any changes that you made. Press the Return soft key [image] to return to the previous screen without saving.

Password Protection Disabled - Select this option to disable all system password protection. The Set Password area becomes disabled and appears grayed out to you.

Password Required To Change Setup Values - Select this option to enable system password protection. The Set Password area becomes enabled to enable you to enter the password information.

Set Password Area

Enter a Password - Enter the password to be used to protect the system settings from being changed.

Verify Password - Re-enter the password that was typed in the Enter Password box for verification.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Data Backup

Use the Data Backup screen to back up and restore datums such as Data Center.

  1. Press the Setup soft key [image] on the main screen.

  2. Press the Data Backup soft key [image] to display the Data Backup screen:

  3. Press the Copy soft key [image] to back up or restore the folders that you selected. Press the Return soft key [image] to return to the previous screen without saving.

Local - From the list, select the check boxes of the folders that you want to back up or restore. If you select the Data Center check box, the other folders are selected automatically.

Action - Select the option based on whether you want to back up or restore:

  • Back Up (Local ->Saved Path) - This option lets you back up your data from a local drive to a USB drive (US0 or US1).

  • Restore (Saved Path->Local) - This option lets you restore your data from a USB drive to a local directory (US0 or US1).

Saved Path - Select the US0 or US1 option based on where to save the data or from where to restore the data.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Kinematics Setup

You can define the rotary table or wrist information in the NC Gage Configuration Tool utility.

For more information on how to edit certain features of the non-linear axes configuration settings, see "Axis Setup Tab".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Counter Display Setup

Use the Counter Display Setup screen to define what appears on the relevant NC Gage screens for counters.

The NC Gage counter usually shows two sets of numbers. You can use the Counter Display Setup screen to define what appears on the left and right sides of the control. You can define different choices on different screens as well.

NC Gage provides three different “levels” where you may want to set up counters:

  • When you learn individual commands, you may want to define what is seen as the “Feature View”.

  • When you navigate to the main screen or execute a measurement routine, you may want to see the “Measurement Routine View” because this is a higher level within the NC Gage application.

  • You may want to see the “Calibration View” during the calibration procedure.

To access this screen:

  1. Press the Setup soft key [image] on the main screen.

  2. Press the Counter Display Setup soft key [image] from the secondpage of the Setup screen to display the Counter Display Setup screen:

  3. Press the Confirm soft key [image] to save any changes that you made. Press the Return soft key [image] to return to the previous screen without saving.

A counter box appears on most NC Gage screens. The counter box has room for two sets of counters. In previous versions of NC Gage, the left side was usually defined as machine coordinates, and the right side was usually defined as work offset coordinates. NC Gage v2.0 and later provide a new alignment system that can be used and are made available where it makes sense.

The new alignment system is part coordinates. NC Gage v2.0 and later provide you with more flexibility on how to display the current probe position.

Counter Display Setup Screen

Three coordinate systems are available for the counter display. The coordinate systems are:

  • Machine - The counters show the current position of the probe in machine coordinates.

  • Workoffset - The counters show the current position of the probe in the current work offset coordinates. This option is always available.

  • Part - The counters show the current position of the probe in part coordinates. This option is available only when NC Gage is controlling more than three axes. Part coordinates are defined below.

XYZ Reported area - The XYZ values that are reported for each type of coordinate can be configured as to how to apply the tool length.

Counter Layout area - The counters are usually defined as a pair of coordinate sets. On some screens, however, only one set of counters is visible. You are able to define what you want to see in each coordinate set by defining the left and right sides of the counters. You can define three different areas:

  • Feature View - Defines the counters that you can view when feature commands are being learned. You can select any of the coordinate systems defined above.

  • Measurement Routine View - Defines the counters that you can view when NC Gage displays a screen that applies to an entire measurement routine. You can select any of the coordinate systems defined above

  • Calibration View - Defines the counters that you can view during a calibration. You can select only the Machine and Workoffset coordinate systems.

Three choices for the point can be shown for each coordinate system. You can configure each coordinate system separately. The options are:

  • No Tool Length - The counters show the current position of the gage (connection) point.

  • Tool Length - The counters show where the end of the tool is by applying the tool length found in the tool table of the control and then adding it to the gage point position.

  • Probe Tip Center - The counters show the location of the center of the probe tip. The offset from the gage point to the ball tip is determined when the probe is calibrated.

Part Coordinate System

The Part Coordinate System (PCS) is the reference system for the part. There is only one for each part, and it is defined by the drawing. The origin of the PCS is related to the MCS via a work offset (such as G54). The PCS is equivalent to the coordinate system defined by a work offset with all rotary table axes in their zero positions.

G54 - Original position XYZ Zero set at corner of part shown below:

"Part Coordinates" is the coordinate system that is in effect when the initial work offset is selected, and all rotary table axes are at zero. Note that with this definition, all measurement routines in NC Gage v1.2 and later use Part Coordinates. Part Coordinates become important as a meaningful common coordinate system in which all measurements can be related in four and five axes systems.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Create New Probe

Home > Using PC-DMIS NC Gage > Getting Started > Step 3: Creating a New Probe

Step 3: Creating a New Probe

Use the Create New Probe screen to define the type of probe you are using to measure your part.

  1. Press the Probe soft key [image] on the main screen.

  2. Press the Select a Probe soft key [image] on the Probe screen.

  3. Press the Create a New Probe soft key [image] on the Select a Probe screen to display the Create New Probe screen:

  4. Use this screen to provide information about your probe. Type the probe's nominal diameter, tool length, pocket number holding the probe, probe name, and any special instructions.

  5. Press the Confirm soft key [image] to save any changes that you made. Press the Return soft key [image] to return to the previous screen without saving.

Definitions

  • Pocket number - Pocket number that is holding the probe.

  • Nominal Diameter - Nominal diameter of the probe tip.

  • Tool Length - Tool length of the probe from the nose point to the tip center. The tool length deviation must be within 20 mm. It is used to do a sphere center check when calibrating. It is not updated in the calibration. The probe tip offsets are updated during calibration.

  • Probe Name - Tool probe name before the tool number. The probe name and tool number identify one probe file.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Select Probe

Home > Using PC-DMIS NC Gage > Getting Started > Step 4: Selecting a Probe

Step 4: Selecting a Probe

Use the Select Probe screen to choose the probe to measure your part.

  1. Press the Probe soft key [image] on the main screen.

  2. Press the Select a Probe soft key [image] to display the Select Probe screen:

  3. Select the probe you want to use from the Select a Probe list using the Select a Probe soft key [image].

  4. Press the Confirm and Append Current Command to End soft key [image] to save the changes. Or, press the Return soft key [image] to return to the previous screen without saving.

NC Gage inserts the probe into the measurement routine's tree view.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Calibration

Home > Using PC-DMIS NC Gage > Getting Started > Step 5: Calibration

Step 5: Calibration

Calibration is critical for defining the probe tip offset and effective radius for your system.

Rotary Table calibration may optionally be performed to increase the accuracy of the measurements when the tables are used as part of a measurement sequence.

  1. Press the Probe soft key [image] on the main screen to access the available calibration options.

The Probe options toolbar has the following options:

  2. Press the Select a Probe soft key [image] to select or define a new probe to be calibrated.

These probe calibration options are available:

  • Press the Sphere Calibration soft key [image] to calibrate the probe in your system using a Calibration Sphere.

  • Press the Ring Calibration soft key [image] to calibrate the probe in your system using a Calibration Ring.

These rotary table calibration options are available:

  • Press the Rotary Table Calibration soft key [image] to calibrate the rotary table(s) in your system.

  • Press the Write Rotary Calibration Data To Control soft key [image] to write rotary table or wrist calibration data to a controller.

The following millturn machine calibration topics are available:

  • Press the Wrist Head Calibration soft key [image] for to implement the millturn machine setup and probe calibration procedure.

  • Press the Find Center for Millturn soft key [image] on the Wrist Head Calibration screen to locate the B axis center.

  • Press the Set Wrist Calibration Angles soft key [image] on the Wrist Head Calibration screen to create the millturn B axis calibration positions.

  • Once the calibration is completed, press the View Calibration Report soft key [image] on the Wrist Head Calibration screen to view, print, and save the calibration report.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Probe Calibration Options

Calibrating your probe establishes the probe tip offset and effective radius of the probe being used in your system.

To access the Probe screen:

  1. Press the Probe soft key [image] on the main screen.

  2. Select the appropriate probe calibration soft key for calibrating your probe:

    • Press the Sphere Calibration soft key [image] to calibrate the probe in your system using a Calibration Sphere.

    • Press the Ring Calibration soft key [image] to calibrate the probe in your system using a Calibration Ring.

These optional methods are available on the Probe screen:

    • Select a Probe soft key [image] selects or defines a new probe to be calibrated.

    • Rotary Table Calibration soft key [image] calibrates the rotary table(s) in your system.

    • Write Rotary Calibration Data To Control soft key [image] sends the rotary table or wrist calibration information to a block of macro variables on the control.

    • Wrist Head Calibration soft key [image] calibrates a wrist head in your system.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Sphere Calibration

  1. Press the Probe soft key [image] on the main screen.

  2. Press the Sphere Calibration soft key [image] on the Probe screen to display the Sphere Calibration screen:

  3. Follow the instructions at the bottom of the screen to complete the sphere calibration process.

Parameters Area

  • Feed Rate - Sets the speed in millimeters per minute (or inches per minute if in inch units) that the probe will travel during probe calibration.

  • Prehit Distance - Specifies the distance from the theoretical hit location to which the probe will move before taking a hit. This is used during probe calibration. This is in millimeters or inches.

Miscellaneous Options Area

  • Show Details - Select this check box to display the Tip Offset area of the screen. The Tip Offset area details the following:

    • Measured, nominal, and tolerance values for the X, Y, and Z axes

    • Measured, nominal, and tolerance values of the form errors related to the calibration of the sphere

Probe Area

  • Tip Diameter (Measured, Nominal and Tolerance) - Provides the measured and nominal diameters of the probe tip as well as the probe tip tolerance value. The measured value is updated after the calibration process is completed.

Target Area

  • Diameter - Specifies the diameter of the Calibration/Qualification sphere.

  • Center XYZ - Specifies the center location of the qualification sphere in relation to the Work Offset location. This value should be 0,0,0 if the sphere was accurately positioned at the work offset.

  • Work Offset - Specifies the work offset at which the qualification sphere is located. Choose Machine to move relative to the machine coordinates.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Calibration Process

  1. Select the work offset to use for the calibration. The default is the Machine work offset.

  2. Input the Diameter and Center Location for the Calibration/Qualification sphere. You can identify the location center coordinates using the description at the bottom of this topic.

  3. Input the other parameters described above.

  4. Jog the probe tip above the qualification sphere's center.

  5. Click the Execute soft key [image]. NC Gage automatically takes five hits on the qualification sphere to determine the center of the sphere. After the center of the sphere is more accurately determined, NC Gage automatically takes 161 hits on the qualification sphere as defined by the Sphere Calibration parameters.

The measured values update when the calibration is complete. You are now ready to use your calibrated probe to measure features.

Locating XY

  • With Spindle Rotation - If the NC machine supports spindle orientation (M19Sxxx), then the XY position of the sphere may be found with the Find Center apply function on the Calibration screen. This function rotates the spindle for each point so that runout of the probe tip is not a factor.

Locating Z

  • Insert a reference tool of known length into the spindle.

  • With a feeler gage of known thickness, jog the tool down over the top of the sphere until the feeler gage has resistance when moving between the sphere and the tool. Use the smallest jog increment when close to the sphere.

  • The sphere top surface Z is then equal to machine Z minus the feeler gage thickness minus the reference tool length.

Specific Feature Path and Logic Built into NC Gage

  • Read position of probe above top of sphere.

  • Measure straight down, search distance is probe radius + 2* prehit distance.

  • Set clearance plane height = Max of read point Z and prehit distance + probe radius above of contact point.

  • Estimate center of sphere to be sphere radius below contact point.

  • Set prehit radius = Sphere radius + probe radius + prehit distance.

  • Move to Clearance Plane.

  • Move in Clearance Plane to a point that is prehit radius in +X direction from sphere center.

  • Drop to height of estimated sphere equator.

  • Measure equator with 16 points, extra moves between points if needed.

  • Move up to next level (9 degrees above equator).

  • Measure level with 16 points.

  • Repeat process for all 10 levels.

  • Measure point on top of sphere.

  • Return to clearance plane.

Identify the Sphere Center Location

Locating XY:

  • With Spindle Rotation - If the NC machine supports spindle orientation (M19Sxxx), then the XY position of the sphere may be found with the Find Center apply function on the Sphere Calibration screen. This function rotates the spindle for each point so that runout of the probe tip is not a factor.

  • With a Dial Indicator - Load a dial indicator in the spindle of the NC machine and adjust it so that it is touching at the approximate equator of the calibration. Jog X and Y on the NC machine so that when rotating the spindle the deviation on the indicator is minimized. The center of the sphere is the X and Y machine position.

Locating Z:

  • Insert a reference tool of known length into the spindle.

  • With a feeler gage of known thickness, jog the tool down over the top of the sphere until the feeler gage has resistance when moving between the sphere and the tool. Use the smallest jog increment when close to the sphere.

  • The sphere Z is then equal to machine Z minus the feeler gage thickness minus the calibration sphere radius minus the reference tool length.

If a work offset is used for the center of the sphere, use the same work offset with a zero center location in NC Gage.

The Center Location X Y Z values in the work offset on the control are the coordinates of the nose point of the spindle if it could be positioned at the sphere center.

Sphere Calibration Report Example

After the sphere is calibrated, you can press the View Calibration Report soft key [image] to create a calibration report:

Press the Print soft key [image] to print a hard copy to the default printer.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Find Sphere Artifact

Home > Using PC-DMIS NC Gage > Getting Started > Step 5: Calibration > Probe Calibration Options > Sphere Calibration > Find Sphere Artifact Adjusting for Runout

Find Sphere Artifact Adjusting for Runout

Use the following procedure to locate the center of the sphere artifact required to calibrate the sphere.

  1. Enter the diameter of the sphere artifact in the Diameter box in the Input Values area.

  2. Follow the screen prompt, and press the Execute soft key [image] as instructed to begin the process.

The Calibration Sphere Tool area is automatically filled in with the results and adjusted for runout.

  3. Press the Confirm soft key [image] to close the screen and return to the Sphere Calibration screen, which is updated accordingly.

Motion Parameters Area

  • Prehit Distance - Defines the distance away from the nominal surface that the probe starts seeking the surface during measure.

  • Search Distance - Defines the distance the probe travels while seeking the surface during learn mode.

Input Values Area

  • Diameter - Manually enter the diameter value of the sphere artifact to be calibrated.

Calibration Sphere Tool Area

  • Center X - Displays the positional value of the sphere artifact in the X axis.

  • Center Y - Displays the positional value of the sphere artifact in the Y axis.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Ring Calibration

Ring calibration is good for measurements in the XY plane (if the probe is pointing in Z).

  1. Press the Probe soft key [image] on the main screen.

  2. Press the Ring Calibration soft key [image] to display the Ring Calibration screen:

  3. Follow the on-screen instructions and then click the Confirm soft key [image] to complete the procedure, or press the Return soft key [image] to return to the previous screen without saving.

Parameter Definitions Area

  • Tip Diameter (Probe/Nominal) - Provides the nominal diameter of the probe tip. The Measured value is updated when calibration completes.

  • Diameter (Ring) - Specifies the diameter of the Calibration/Qualification ring.

  • XYZ (Ring/Center) - Specifies the top surface center location of the qualification ring in relation to the Work Offset location. The Z value is used to compute the probe Z offset with the last point on the surface. This value should be 0,0,0 if the ring was accurately positioned at the Work Offset.

  • Feed Rate - Sets the speed in millimeters per minute (or inches per minute) that the probe will travel during probe calibration.

  • Prehit Distance - Specifies the distance from the theoretical hit location to which the probe will move before taking a hit. This is used during probe calibration. This is in millimeters or inches.

  • Work Offset - Specifies the Work Offset at which the qualification ring is located. Choose Machine to move relative to machine coordinates.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Calibration Process

  1. Select a Work Offset to use for the calibration. The default is the Machine work offset.

  2. Enter the diameter and center location for the calibration/qualification ring. You may identify the location center coordinates using the description at the bottom of this page.

  3. Enter the other parameters described in "Parameter Definitions Area" above.

  4. Jog the probe to a position near the center of the ring.

  5. Click the Execute soft key [image]. NC Gage automatically takes 4 hits on the qualification ring to determine the center of the ring. After the center of the ring is more accurately determined, the bore of the ring gage is measured with 36 hits, and the top of the ring gage is measured with a single hit.

  6. Once calibration is complete, the measured values are updated. Press the Show Details soft key [image] to view the Tip Offset details or the Confirm soft key [image] to save the calibration results and return to the main screen. You are now ready to measure features using the calibrated probe.

You can also view the Tip Details by selecting the Show Details check box.

Locating XY

  • With Spindle Rotation - If the NC machine supports spindle orientation (M19Sxxx), then the XY position of the ring may be found with the Find Center apply function on the Ring Calibration screen. This function rotates the spindle for each point so that runout of the probe tip is not a factor.

Locating Z

  • Insert a reference tool of known length into the spindle.

  • With a feeler gage of known thickness, jog the tool down over the top of the ring until the feeler gage has resistance when moving between the ring and the tool. Use the smallest jog increment when close to the ring.

  • The ring top surface Z is then equal to machine Z minus the feeler gage thickness minus the reference tool length.

Specific Feature Path and Logic Built into NC Gage

  • Read the position of the probe in the center of the ring.

  • Ring measurements will occur at the Z value of the read point./p>

  • Estimate XY center of the ring to be read position point.

  • Set prehit radius = Ring Radius - probe radius - prehit distance.

  • Set target radius = Ring Radius + prehit distance.

  • Set safe height = read position Z value + 25 mm.

  • Measure the ring with 36 points from 0 to 350 degrees.

  • Move to safe height.

  • Move in safe height to a point that is Ring Radius + 2* probe radius in +X direction from ring center.

  • Measure straight down; the target height is the same height as the ring points.

  • Return to safe height.

Ring Calibration Report Example

After the ring is calibrated, you can create a calibration report by pressing the View Calibration Report soft key [image].

To print a hard copy to the default printer, press the Print soft key [image].

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Find Ring Artifact Adjusting for Runout

Use the following procedure to locate the center of the ring artifact required to calibrate the rings.

  1. Enter the diameter of the ring artifact in the Diameter box in the Input Values area.

  2. Follow the screen prompt, and press the Execute soft key [image] as instructed to begin the process.

The Calibration Ring Tool area is automatically filled in with the results and adjusted for runout.

  3. Press the Confirm soft key [image] to close the screen and return to the Ring Calibration screen, which is updated accordingly.

Motion Parameters Area

  • Prehit Distance - Defines the distance away from the nominal surface that the probe starts seeking the surface during measure.

  • Search Distance - Defines the distance the probe travels while seeking the surface during learn mode.

Input Values Area

  • Diameter - Manually enter the diameter value of the ring artifact to be calibrated.

Calibration Ring Tool Area

  • Center X - Displays the positional value of the ring artifact in the X axis.

  • Center Y - Displays the positional value of the ring artifact in the Y axis.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Rotary Table Calibration Options

Home > Using PC-DMIS NC Gage > Getting Started > Step 5: Calibration > Rotary Table Calibration Options

Rotary Table Options

When you define a measuring system that uses rotary tables, you must enter the nominal location and orientation of the rotary table(s).

You can optionally perform calibration to increase the accuracy of the measurements when the tables are used as part of a measurement sequence.

The Rotary Table Calibration feature is available on the Probe screen. To open the Probe screen:

  1. Press the Probe soft key [image] on the main screen.

  2. Press the Rotary Table Calibration soft key [image] to calibrate the rotary table(s) in your system.

The following optional methods are on the Rotary Table Calibration screen:

  • View Calibration Report soft key [image] - Displays the calibration report after successfully calibrating your rotary table(s).

  • Find Sphere Tool soft key [image] - Defines the sphere being used to calibrate the rotary table(s) in your system.

The following optional methods are available on the Probe screen:

  • Select a Probe soft key [image] - Selects or defines a new probe to be calibrated.

  • Sphere Calibration soft key [image] - Calibrates the probe in your system using a Calibration Sphere.

  • Ring Calibration soft key [image] - Calibrates the probe in your system using a Calibration Ring.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Rotary Table Calibration

Rotary table compensation is disabled until all table parameters have been entered in the NC Gage Configuration Tool (for more information, see "Appendix A - Controller Configuration").

Rotary table calibration is performed using machine coordinates; consequently, all location parameters are defined using machine coordinates.

Before you calibrate a rotary table, you must know where the machine coordinate centers of rotation are for the axes, and enter them on the Axis Setup tab in the NC Gage Configuration Tool. These numbers transform the points so that NC Gage knows approximately where the sphere is at different table positions. Once you have defined these values, you can proceed with calibrating the rotary table.

The probe must be calibrated on a sphere prior to calibrating the rotary table. The Rotary Table Calibration form is unavailable otherwise.

  1. Press the Probe soft key [image] on the main screen.

  2. Press the Rotary Table Calibration soft key [image] to display the Rotary Table Calibration screen:

  3. Follow the on-screen instructions and then click the Confirm soft key [image] to complete the procedure. Or, press the Return soft key [image] to return to the previous screen without saving.

Parameters Area

  • Feed Rate - Sets the speed of positional moves in millimeters per minute (or inches per minute if in inch units) that the probe will travel during calibration.

  • Prehit Distance - Specifies the distance from the theoretical hit location to which the probe will move before taking a hit. This is used during probe calibration and is defined in millimeters or inches.

  • Safe Rotation Height - The Z axis height to which the probe will be moved between table positioning moves. This value is the tip center height in machine coordinates on the safe plane. It is the Z value on machine coordinate minus the probe Z offset while the tip center is on the safe plane.

It is critical that the Safe Rotation Height value is appropriately set in order to prevent tip crashing into rotary table or part. Unless previously set, the default value for this parameter is 0 (zero).

Angle Definition Area

  • Number of Positions - The number of places where the sphere will be measured. The locations will be evenly distributed between the start angle and the end angle.

  • Start Angle - The first table angle used in the calibration.

  • End Angle - The last table angle used in the calibration.

If the start angle and end angle are both the same or differ by 360 degrees, then the positions will be evenly spaced, starting at the start angle and ending not at the end angle, but one increment short of it. In the screen shown above, the end angle will actually be 270.

  • Points Per Sphere - The number of points used to measure each sphere.

  • Lower Level Angle - Normally, this is 0, which means the equator. This may be a larger angle if equator hits are not possible.

  • Upper Level Angle - Normally, this is 90, which means the North Pole hit. It is possible that this could be a smaller angle if there is an obstruction on the top of the sphere.

NC Gage will avoid the stem, which is defined by the calibration sphere tool properties.

Table Calibration Area

The Nominal column defines the center location and displays the values that exist on the Axis Setup tab in the NC Gage Configuration Tool prior to entering the rotary table calibration screen. The Measured column defines the center location, which is determined by the calibration process. When you accept a calibration, the measured values are written to the NC Gage setup and become the new Nominal column values the next time you perform a calibration. They appear on the Axis Setup tab in the NC Gage Configuration Tool.

  • Axis ID - The letter that identifies the axis: A, B, or C depending on the number of rotary tables defined in the system.

  • Center X, Y, Z - The X, Y, and Z machine coordinate values that define the center of the rotary table.

    • Nominal column - Displays the theoretical location when the table is initially calibrated. Each time the rotary table is to be calibrated, the previous values display.

    • Measured column - Displays the location of the current calibration values.

  • Rotary Axis I, J, K - The vector I, J, and K values that define the axis in which the table rotation is to be defined. Available options depend on what table axes exist on the machine and is selected from the list. Default values will populate the fields in the Nominal column , which can be manually set if necessary.

    • Nominal column - Displays the theoretical direction when the table is initially calibrated. Each time the rotary table is to be calibrated, the previous values will be displayed.

    • Measured column - Displays the direction of the current calibration values.

Sphere Tool Definition Area

These values define the location, size, and orientation of the calibration sphere artifact. You can type these values in directly, or learn them by pressing the Find Sphere Artifact soft key [image]. A description of the calibration sphere definition process is given later in this document. If the Find Sphere Artifact soft key [image] is pressed, you are directed to define the sphere. When you exit the Find Sphere Artifact for Rotary Table Calibration screen, the learned values will populate the calibration sphere screen.

  • Center X, Y, and Z - The X, Y, and Z machine coordinate values that define the center of the sphere that is measured. This is the position when the table is at zero.

  • Diameter - The diameter of the sphere measured and used to calibrate the table.

  • I, J, and K - The vector axis values that the rotation of the table will be defined for the sphere that is measured. This vector defines the stem of the calibration sphere. The vector points from the stem to the center of the sphere.

Probe Information Area

  • Pocket - The tool pocket index of the probe tool.

  • Diameter - The Nominal and calibrated diameter of the probe tip.

  • Length - The length of the probe.

  • Tip Offset X, Y, Z - Specifies the calibrated X, Y, and Z tip offset coordinates of the probe. These values represent the direction from the gage point to the center of the probe tip.

When all options have valid values, press the Execute button. NC Gage performs the calibration sequence. If no errors are encountered, each sphere location is measured and the set of sphere centers computes a plane. A circle is computed with the sphere centers in the computed plane. The center of this circle is the new measured center of the rotary table axis. The normal vector of the plane is the new IJK vector of the rotary table axis.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Calibration Process

Before you open this screen, you must know where the centers of rotation are for the axes and enter them on the Axis Setup tab in the NC Gage Configuration Tool. These numbers transform the points so that NC Gage knows approximately where the sphere is at different table positions.

The nominal X, Y, Z, I, J, and K values are initialized to the values on the Setup screen. The measured X, Y, Z, I, J, and K values are replaced by the existing values on the Axis Setup tab in the NC Gage Configuration Tool after the table is calibrated and you accept the calibration.

You must select a previously-calibrated probe before you calibrate the rotary table.

The quality of the probe calibration is very important. Any errors in the probe calibration may be transferred to the table calibration.

After you have entered the values on the Axis Setup tab in the NC Gage Configuration Tool, you need to do the following to calibrate a table:

  1. Enter the Feed Rate, Prehit, and Safe Plane Tip Height values.

    • The Feed Rate is for non-measurement moves.

    • The Safe Plane Tip Height value is very important. NC Gage moves to this height before the each table positioning move and sphere measurement. If this value isn't set correctly, you may find that NC Gage drives the machine way up or down into the table. This field should define a safe Z value to move the tip of the probe to before the table is rotated. All locations in this process are in machine coordinates.

  2. Set the sphere measurement values. Enter the values for Number of Positions, Start Angle, End Angle, Points Per Sphere, Lower Level Angle, and Upper Level Angle.

    • The Number of Positions option defines the total number of measurements that will be taken on the sphere.

    • The Start Angle is the first angle for the table being calibrated. The End Angle is the last angle. NC Gage divides this range evenly. For example, if the start angle is set to 30, the end angle is set to 210, and you have defined 5 positions, NC Gage measures the sphere at 30, 75, 120, 165, and 210 degrees. In the special case where the start angle is 0 and the end angle is 360, the end angle is adjusted based on the number of spheres. For example, if you enter 0-360 and 4 measurements, then NC Gage measures at 0, 90, 180, and 270.

    • Points Per Sphere is the number of points to measure on each sphere.

    • The Lower Level Angle and Upper Level Angle options define how much of the sphere will be measured. 90 means the North Pole, while 0 means the equator. 90 is the most often used value for the upper level angle and may never need to be changed, but it can be changed if necessary.

      The lower level angle value may need to be changed to help avoid the stem of the calibration sphere. NC Gage does provide some stem avoidance, so adjusting this value may not be necessary either.

  3. Ensure that the correct probe being used to calibrate the table is correct. The Pocket, Diameter, Length, and Tip Offset values of the currently active probe can be found in the lower-right corner of this screen. If needed, you can change the probe by pressing the Select Probe soft key [image]. Note that it is a requirement that the probe being used for table calibration was calibrated on a sphere. Tips calibrated on a ring cannot be used.

  4. Select the appropriate Axis ID from the list. The Nominal column automatically fills in.

  5. You must define the sphere that is being used. NC Gage needs to know the center location, diameter, stem vector, and rotary table positions of the sphere. If these values are not known, press the Define Sphere Tool Information soft key [image] to access the Find Sphere Tool screen. You can use the Read Probe soft key [image] to learn the current probe position. Some notes on these values:

    • Center X, Center Y, and Center Z are the coordinates of the center of the sphere when the tables are positioned at values in this form (A and C in this example). NC Gage actually needs to know where X, Y, and Z are when the tables are all at zero. It uses the information defined on the Axis Setup tab in the NC Gage Configuration Tool to compute these values. Unless there is a reason that it can’t be measured at that position, it is recommended that the sphere is defined in coordinates where the rotary tables are at zero.

    • I, J, and K define the direction from the center of the stem through the center of the sphere. Normally, this vector is (0, 0, 1), which means that the sphere is pointing “straight up”. NC Gage will use this vector to try to avoid the stem when the sphere is measured.

    • When the upper table (1 in the image below) is being measured, the lower table (2 in the image below) must be at zero.

    • When the lower table (2 in the image below) is being calibrated, the upper table (1 in the image below) can be at any position.

    Table C sits on top of table A as shown below:

1. C Axis Rotation
2. A Axis Rotation

  6. When all of this information is entered, press the Execute soft key [image] to calibrate the table.

If no errors are encountered, each sphere location is measured and the set of sphere centers computes a plane. A circle is computed with the sphere centers in the computed plane. The center of this circle is the new measured center of the rotary table axis. The normal vector of the plane is the new IJK vector of the rotary table axis.

Notes:

The original rotary table axis point is projected onto the axis determined by the calibration process. Thus, the new axis point should not differ from the old one by much and not be confusing to you.

All of the information that is entered in the form is saved to a file. Each rotary axis will have its information stored separately in the file. After a calibration is executed, the file is rewritten. When you perform a new calibration, the form is populated with values saved from the last calibration of that axis.

Calibration is done separately for each axis. Initially, it is required that the rotary axis that is not being calibrated is forced to zero. This restriction may be removed at a later time.

Rotary Table Calibration Report

After the table is calibrated, you can create a calibration report by pressing the View Calibration Report soft key [image].

The report contains the following information:

  • Time of measurement, axis ID, and computed center of the table.

  • Shift values, which show the difference between the current measurement and the values defined on the Axis Setup tab in the NC Gage Configuration Tool. If this is the first calibration, the shift values show the deviations from the position that you defined. For subsequent calibrations, this shows the change from the previous calibration. If you accept the calibration, then the rotation center will be written to the Axis Setup tab in the NC Gage Configuration Tool.

  • The Rotation Axis shows the “Tilt of the Table”. It is expressed as a vector and as a pair of angles. The distance between the rotary axes displays the distance between the axes of the two tables at their closest.

  • The positioning error of each sphere measurement displays in both table and graphical formats. The components of the positioning errors are:

    • Radial Error - The amount that the sphere location deviates from the computed circle in the radial direction (from center of circle outward)

    • Tangent Error - The error of the sphere location based on its angle within the circle and the rotary axis position when the sphere was measured. These deviations are “clocked” to the sphere location. So, the first sphere always has zero for tangent error; all other sphere tangent errors are relative to the first measurement. This error essentially measures the accuracy of the rotary table positioning.

Radial and Tangent errors are depicted graphically by the mis-location (which is exaggerated) of the sphere relative to its nominal position.

    • Axial Error - This error measures the deviation of the sphere location from the best fit plane that was computed using all of the sphere centers. Plus values mean the error is “up”, and minus values down. This is depicted graphically by scaling the errors so that you can see the differences relative to each other. Positive deviations are solid blue disks, and negative deviations are red rings. Solid vs. rings was done in case the report is printed to a monochrome printer.

  • You can press the Print soft key [image] to print a hard copy to the default printer.

Stacked Rotary Table Reporting

When you calibrate a rotary table in NC Gage, the center of that table is reported as the point that is on the computed axis, which is closest to the other axis. This is done by considering the two axes together. The points that represent the closest that the two axes come to intersecting are determined, and those points become the new points reported as the table center.

NC Gage determines the location where the two axes come closest to intersection. These points are reported as the centers of rotation for the two axes:

A - Upper table rotation axis
B - Lower table rotation axis

Example of the Stacked Rotary Table Axis Defined

Notes:

The math that NC Gage uses is independent of the center point choice as long as the point lies on the rotation axis.

When the first calibration is performed, NC Gage will use the other table’s nominal axis in the calculation. Adjustments will be made when the second table is calibrated.

When a table is calibrated, both table centers are updated because minor changes in one table's center axis will have a small effect.

The offset reported between the two tables is the difference between the two points.

The distance between the two tables that is reported is the distance between the two points.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Write Rotary Calibration Data To Control

Use the Write Rotary Calibration Data To Control screen after the rotary table(s) or wrist(s) have been successfully calibrated to send the calibration information to a block of macro variables of the controller.

  1. Press the Probe soft key [image] on the main screen to access the Probe screen.

  2. Press the Write Rotary Calibration Data To Control soft key [image] to display the Write Rotary Calibration Data To Control screen.

    • For a rotary table:

    • For a wrist:

  3. Enter the first macro variable number (for Center X of Base Table). The remaining macro variable numbers are assigned sequentially automatically.

  4. Press the Confirm soft key [image] to transfer the calibrated values to the controller. The macro variable numbers fill in sequentially as shown. It is up to you to appropriately apply these values on the controller end.

Parameters Area

  • SHIFT - The deviation from the nominal center to the actual calculated center. The Actual center is calculated by the data in all the angles positions in wrist calibration.

  • Offset - The deviation from the nominal center to the actual calculated center. The Actual center is calculated by the data in the two orthogonal angles (0 and 90 or 0 and -90) positions. It is valid only when you have the two angles in the calibration list.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Find Sphere Artifact for Rotary Axes Calibration

You must define the sphere that is being used when calibrating a rotary table. NC Gage requires this information: center location, diameter, stem vector, and rotary table positions of the sphere. If the values are not known, you can define them on the Find Sphere Artifact for Rotary Axes Calibration screen.

  1. Access the screen from the Rotary Table Calibration screen. From the Rotary Table Calibration screen, press the Find Sphere Artifact soft key [image] to display the Find Sphere Artifact for Rotary Axes Calibration screen:

  2. NC Gage requires information to help understand where the stem of the sphere is. Position the probe so that it is on the exact (within reason) opposite side of the sphere from the stem.

  3. Enter the Prehit Distance and Search Distance values in the Motion Parameters area.

  4. Press the Read Probe Position soft key [image] to learn this probe position.

  5. Position the probe directly above the sphere so that when the probe moves straight down, it contacts the top of the sphere.

  6. Press the Read Probe Position soft key [image] to learn this probe position.

The same point can be used for steps 2 thru 5 since the stem is below the sphere. Press the Return to Previous Step soft key [image] at any time to remove the last learned probe position.

  7. Press the Execute soft key [image]. NC Gage roughly measures the sphere using a 4 point finding pattern on the top. The measured values are displayed, which can be accepted or rejected. The values can also be manually edited before accepting them if necessary.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Millturn Machine Calibration

Probe and Head Calibration on a Millturn Machine

Probe and B axis calibration on a Millturn machine is implemented in order to answer a single question, "For a given B axis angle, where is the center of the probe with respect to the center of rotation of the head?"

In an ideal world, a probe tip could be calibrated in a single B axis position and its location will be known for all positions. But the world is not ideal, so it is necessary to establish the position of the rotary head in multiple ways. The method chosen is influenced by accuracy requirements.

Millturn Probe Calibration Overview

The first step in millturn probe calibration is to establish the location of the calibration sphere. You can do this by using traditional methods (dial indicator and gage block). You can also use spindle rotation to perform “find center” twice: once with the B axis at 0 and once at 90.

Details for the measurement process are defined below.

The calculated center of the head rotation should be at the sphere tool center. Deviations from the sphere tool center are calculated for each wrist angle.

The collection of tip offsets are analyzed together so that the tip offset of a B axis position that is not calibrated may be estimated and used in an NC Gage measurement routine.

  • The first step of the analysis is to compute the best fit plane using all of the probe offsets. The normal vector of the plane is the rotation vector of the B axis; this should be very close to (0, 1, 0).

  • The next step of the analysis is to compute the best fit circle using all of the probe offsets. This center is calculated in the plane computed in the first step. The center of this circle should be very close to the center of the calibration sphere. Any error found at this point is likely caused by errors in defining the calibration sphere center.

The errors of the center of each sphere relative to the computed best fit circle can be broken down into three components:

  • The first component of the error is the tangential or clocking error. This represents the error of a computed position of the sphere relative to the predicted position of the sphere as the angular difference.

  • The second component of the error is the radial error. This represents the error of the computed position of the sphere relative to best fit circle as the difference between the best fit circle radius and the distance from the sphere center of the circle center.

  • The third component of the error is the axial error. This represents the distance from the center of the sphere to the best fit plane.

NC Gage creates a table of errors and save it as part of the B axis/probe calibration. When a feature is created in a measurement routine, NC Gage builds a tip to use based on the B axis angle. If the B axis angle of a feature frame was used in the calibration, NC Gage extracts the information from the calibration table directly to set the tip offset. Vector compensation is used if the calibration of that B position used enough points. If the B axis was not part of the calibration, the probe offset is set using the best fit plane, center, and the error table, interpolating as necessary. Whether the vector compensation map is rotated and used is determined.

The following table represents the new information that is stored in the millturn calibration table:

B Angle | X Offset | Y Offset | Z Offset | Tangential Error | Radial Error | Axial Error | Specific Vector Comp Map
0 | - | - | - | - | - | - | -
- | - | - | - | - | - | - | -
90 | - | - | - | - | - | - | -

X, Y, and Z center represent the delta values between the user-specified location of the calibration sphere center and the best fit computed center. This allows NC Gage to deal with probe runout and to use sines and cosines to predict new positions.

NC Gage provides the ability for you to either go through a complete tip/B axis calibration or perform a “calibration refresh” to update part of the error table.

More

Wrist Head Calibration

Set Wrist Calibration Angles

Wrist Head Calibration Reporting

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Wrist Head Calibration

  1. Press the Probe soft key [image] on the main screen.

  2. Press the Wrist Head Calibration soft key [image] to display the Wrist Head Calibration screen:

  3. Follow the on-screen instructions and then click the Execute soft key [image] to complete the procedure. Or, press the Return soft key [image] to return to the previous screen without saving.

  4. Immediately after successfully calibrating the wrist head, press the View Calibration Report soft key [image] to display the wrist head Calibration Report screen.

Parameters Area

This area defines the motion parameters.

  • Feed Rate - Sets the speed of positional moves in millimeters per minute (or inches per minute if in inch units) that the probe travels during calibration.

  • Prehit Distance - Specifies the distance from the theoretical hit location to which the probe moves before taking a hit. This is used during probe calibration and is defined in millimeters or inches.

  • Safe Rotation Height - The Z axis height to which the probe moves between head positioning moves. This value is the pivot point center height in machine coordinates on the safe plane. Before every wrist axis rotation, the probe is moved straight up in Z so that the pivot point of the wrist will move safely to the specified height.

It is critical to set the Safe Rotation Height value appropriately to prevent tip crashing into the rotary table or part. Unless previously set, the default value for this parameter is 0 (zero).

For more information about this value, see "Using Clearance Planes".

Angle Definition Area

All Position Angles - These values are set in another form, which you can access by clicking the Set Wrist Calibration Angles soft key [image].

The set of wrist axis positions and all other parameters are persisted to the tip file so that the next time you open the calibration screen, all values are remembered.

The following relates to the non-primary angles:

Points Per Sphere - This value defines the number of points that are used to measure each sphere.

Head Calibration Area

The values in the Nominal column define the center location. They are the values that exist on the Axis Setup tab in the NC Gage Configuration Tool prior to entering the Wrist Head Calibration screen.

The values in the Measured column define the center location. They are determined by the calibration process. When you accept a calibration, the measured values are written to the NC Gage setup and become the new Nominal column values the next time a calibration is performed. They appear on the Axis Setup tab in the NC Gage Configuration Tool.

Nominal column - Displays the theoretical direction when the table is initially calibrated. Each time the rotary table is to be calibrated, the previous values display.

Measured column - Displays the current computed direction results from the current calibration.

  • Axis ID - The letter that identifies the axis - A, B or C depending on the number of rotary tables defined in the system.

  • Average Total Length - The average length of the tool tip determined during the calibration procedure.

  • Rotation Axis I, J, K - The vector I, J, and K values. These values define the direction of the axis around which the wrist rotates. These values are initially set to agree with the settings on the Axis Setup tab in the NC Gage Configuration Tool.

Probe Area

Nominal column - Displays the theoretical diameter when the table is initially calibrated.

Measured column - Displays the last calibrated diameter of the probe.

Diameter - Diameter of the probe tip.

Pocket - Probe pocket number defined when the probe is created.

Name - Name of the current probe being used.

Information Area

This area provides information on the calibration process including time/date stamp of current or previous calibration.

Sphere Tool Definition Area

These values define the location, size, and orientation of the calibration sphere artifact. You can type these values or learn them by pressing the calibration sphere definition button. A description of the calibration sphere definition process is given later in this document. If you press the sphere definition button, you are directed to define the sphere. When you exit the sphere definition screen, the learned values populate the Sphere Calibration screen.

  • Center X, Y, and Z - The X, Y, and Z machine coordinate values that define the center of the sphere that is measured. This is the position when the table is at 0 (zero).

  • Diameter - The diameter of the sphere measured and used to calibrate the table.

  • I, J, K, and C - The IJK vector direction for the stem of the calibration sphere and the rotary table center position for sphere measurement. The vector points from the stem to the center of the sphere.

Work Offset Area

Specifies the Work Offset at which the qualification artifact is located. Select Machine to move relative to machine coordinates.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Using Clearance Planes

The Safe Rotation Height (at Pivot) option on the Wrist Head Calibration screen displays the safe height for the wrist safely rotated to any angle.

To avoid a collision when the wrist rotates from one angle to the next angle before a sphere measurement, a clearance plane has been defined. NC Gage drives the pivot center to this line first. NC Gage then performs the wrist rotation before it measures a sphere.

The direction of the defined clearance plane is along the normal rotary table. The safe rotation height (at pivot) is the pivot location in the direction when the pivot is jogged at that level. It is not related to the wrist angle because it is the pivot location and not the tip.

In the following diagram, the yellow line is the clearance plane for a demonstration machine. The height is along the X axis (a normal table):

Clearance plane

Set Safe Move Height Button

The Set Safe Move Height button on the Wrist Head Calibration screen helps establish a safe rotation height (at pivot).

  1. Jog the tip (without considering the wrist angle position) above the sphere top and along the clearance plane direction:

Clearance plane direction

  2. Select the Set Safe Move Height button. NC Gage calculates the safe rotation height (at pivot) and completes the Safe Rotation Height (at Pivot) box.

Start Position

You should pay more attention to the safe start position for the clearance plane only and consider the safe height in the table's normal direction. You should jog the probe to a safer location in the YZ plane to provide enough space for the wrist rotation, and therefore avoid any collision. In addition, the start position for the tip should be higher than the sphere center in the clearance plane's -X direction.

Wrist Angle

You should consider the wrist angles that are entered for calibration, and avoid some risky angle positions depending on the wrist's limitations, the machine's free space, and the sphere's stem.

You should pay more attention to the wrist angle positions near the stem and the angle's positions in which the pivot centers under the sphere center in the clearance direction. Carefully check these positions during the first execution of the measurement routine.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Set Wrist Calibration Angles

Pressing the Set Wrist Calibration Angles soft key [image] on the Wrist Head Calibration screen displays the following screen:

  1. Enter an angle value into the Angle field in the Fully Compensated Angle area.

  2. Enter beginning angle into the Start Angle field in the Generate Sequence area.

  3. Enter the final angle into the End Angle field in the Generate Sequence area.

  4. Enter the total positions that will be needed in the Number of Positions box in the Generate Sequence area.

  5. Once you have entered the Start Angle, End Angle, and Number of Positions values, press the Generate Position List soft key [image] to populate the Calibration Positions list based on these values.

  6. Enter a separate angle in the Angle box in the Add Single Angle area. Then press the Add Single Angle to the Position List soft key [image] to add another angle to the Calibration Positions list.

  7. Press the Clear Position List soft key [image] to clear the current listing and start over.

  8. Once the positions have been generated, click the Execute soft key [image] to accept the list of calibration positions.

Calibration Positions Area

Lists all the currently defined calibration positions.

Fully Compensated Angle Area

Angle - This angle is used as the starting angle when a full calibration is required. It builds the vector compensation map.

Generate Sequence Area

Start Angle - The initial angle value in which the probe head starts out at during the calibration process (usually the lowest angle value of the probe rotation).

End Angle - The final angle value that the probe head will complete its rotation during the calibration process (usually the highest angle value of the probe rotation).

Number of Positions - The total number of angles that the probe head will rotate during the calibration process (includes the start and end angles). This value determines the actual angle positions based on the Start Angle and End Angle values entered as described in the steps above.

Add Single Angle Area

Angle - An angle value that can be manually added to the Calibration Positions list. Enter an angle and then press the Add Single Angle to the Position List soft key [image] to manually update the list with the entered angle value.

When you press the green check mark, control is returned back to the Wrist Head Calibration screen, and the angle definitions are returned to the parent form. If the abort button is checked, the changes are not passed back to the parent form.

The set of B axis positions and all other parameters are persisted to the tip file so that the next time the calibration screen is entered, all values are remembered.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Wrist Head Calibration Reporting

Click the View Calibration Report soft key [image] from the Wrist Head Calibration screen immediately after a successful calibration is completed.

There are two main parts of the wrist head calibration report file:

  • The first is the vector information, which saves only the primary angle and contains only the vector compensation table.

  • The second contains the wrist calibration information. Each position (including the primary tip) saves the tip offset (from the rotation center) and the clocking, radial, and tangential errors. The file is rewritten as follows:

    • If the primary angle is calibrated and the other angles are skipped, only the vector compensation table is written to the file. The wrist calibration information is not altered.

    • If the primary angle is not calibrated (with full coverage) but the other angles are calibrated, the vector compensation table does not change, but the wrist calibration information is updated in the file.

    • If both the primary angle and the other angles are calibrated, the entire file is overwritten.

Report Details

The following is based on the above report with the axes configured and calibrated for the axes as shown. You need to modify the following statements as necessary with the appropriate axes if your system is configured differently.

  • The center of the rotation of the head and its offset from nominal are defined by the Rotation Center, X Shift, Z Shift, and Rotation Axis values.

  • The unit of the tangential deviation (angle) in the YZ plane is in degrees. All other units are in the distance units that NC Gage is configured for (MM in the above case).

  • The Average Length is the average of the Length values found in the Deviation Table.

  • The Length found in the Deviation Table is the distance from the center of rotation to the gage line.

  • The XYZ Offset values are the distance from the nominal for each axis.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Work Offset

Home > Using PC-DMIS NC Gage > Getting Started > Step 6: Selecting a Work Offset

Step 6: Selecting a Work Offset

A work offset is an alignment. It defines a particular location in 3D space as the 0,0,0 origin of your coordinate system.

You can either select a defined work offset to use in your measurement routine, or you define (or set) work offsets by measuring certain features.

  • Select Work Offset

  • Set Work Offsets

You can also automatically update a work offset at the end of a measurement routine by using the Update Work Offset screen.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Set Work Offsets

Setting work offsets enables you to update the work offset on the controller by measuring a selection of features.

  1. Press the Set Work Offsets soft key [image] on the main screen. The soft keys at the bottom change to show the different types of features that you can measure to set a work offset:

Soft Keys for a Millturn Machine

  2. Click on the a specific measurement procedure from the following:

  • Set One Axis

  • Set Two Axes (Bore)

  • Set Two Axes (Boss)

  • Set Two Axes (Inside Corner)

  • Set Two Axes (Outside Corner)

  • Set Three Axes With Sphere

  • Set One Axis to Mid Point

  • Set Rotation Axes Angle With a Line

  • Set Rotary Axis (Angle) with Keyway

  • Set Rotation Angle With Plane

  • Set Rotary Axis (Angle) with Flat

  • Set Rotary Axis (Angle) with Key

  3. The appropriate screen appears.

You can also update a work offset by using the Update Work Offset screen.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Set One Axis

The Set One Axis soft key measures a point on the part and then uses its coordinates to update a specified work offset.

  1. Press the Set Work Offset soft key [image] on the main screen. The soft keys at the bottom change to show the different types of features that you can measure to set a work offset.

  2. Press the Set One Axis soft key [image] to display the Set One Axis screen:

  3. Follow the on-screen instructions and then press the Confirm soft key [image] to complete the procedure. Or, press the Return soft key [image] to return to the previous screen without saving.

Work Offset Area

  • Work Offset - Specifies the work offset to be updated.

Parameters Area

  • Measured X, Y, or Z - Specifies the location of the work offset. The value is learned from a point learn process. The axis varies based on the direction selected at the bottom-left corner of the screen.

  • Offset - The work offset will be offset this distance away from the measured point.

Motion Parameters Area

  • Prehit Distance - Specifies the location that the probe will start searching for the surface. This is the distance away from the surface nominal that the probe will move at the "finding" speed that was established on the Setup screen.

  • Search Distance - Specifies the distance that the probe will travel while looking for the surface when in learn mode. For example, if the probe is positioned in the center of a hole, the probe will move at the "finding speed" that was established on the Setup screen to the search distance in each direction to find and learn the location of the feature.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Update Process

  1. Position the probe above the point.

  2. Press the Read Position soft key [image]. The tip position is read as the bore center and distance away from the surface. Press theBack to Last Step soft key [image] to cancel this position and read a new position.

  3. Press the Execute soft key [image]; NC Gage automatically probes a point along the opposite direction of the work face normal. The probe will search a distance of the probe radius plus three times the prehit distance.

  4. The measured values update once probing is complete. Select the Work Offset name from the list by pressing the Select a Work Offset to Update soft key [image] until the desired work offset is highlighted. Parameters for each highlighted work offset update on the screen as you select each one.

  5. Press the Confirm soft key [image] to save the work offset value and update this axis. Press the Return soft key [image] to return to the previous screen without saving.

Specific Feature Path and Logic Built into NC Gage

  • Read position of probe above surface.

  • Measure surface with search distance of probe radius + 3 * prehit distance.

  • Return to read position point.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Set Two Axes (Bore)

The Set Two Axes With Bore soft key measures a circle bore (internal circle feature) on the part and then uses its center coordinates to update a specified work offset.

  1. Press the Set Work Offset soft key [image] on the second page of the main screen. The soft keys at the bottom change to show the different types of features that you can measure to set a work offset.

  2. Press the Set Two Axes With Bore soft key [image] to display the Set Two Axes (Bore) screen:

  3. Follow the on-screen instructions to measure a circle and select the work offset to update, and then press the Confirm soft key [image] to update the work offset. Press the Return soft key [image] to return to the previous screen without saving.

Probe Definition Area

Displays information related to the probe that is currently loaded.

Tip Offset Area

  • Tip Offset X, Y, and Z - The position of the probe tip relative to the gage line.

Work Offset Area

  • Work Offset - Specifies the work offset to be updated.

Parameters Area

  • Measured - Specifies the location of the work offset. The value is learned from a Circle (Bore) learn process and is displayed in machine coordinates.

  • Target - The work offset will be offset this distance away from the measured feature.

Motion Parameters Area

  • Prehit Distance - Specifies the location that the probe will start searching for the surface. This is the distance away from the surface nominal that the probe will move at the "finding" speed that was established on the Setup screen.

  • Search Distance - Specifies the distance that the probe will travel while looking for the surface when in learn mode. For example, if the probe is positioned in the center of a hole, the probe will move at the "finding speed" that was established on the Setup screen to the search distance in each direction to find and learn the location of the feature.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Update Process

One Point for Small-Diameter Circle

For machines that have wrist axes in the head, the learning process is only supported along the machine axis probe direction.

  1. Position the probe in the center of the bore.

  2. Press the Read Position soft key [image]. The tip position is read as the bore center and distance away from the surface. Press theBack to Last Step soft key [image] to cancel this position and read a new position.

  3. Press the Execute soft key [image]; NC Gage will drive the probe and search the Circle (Bore) by taking four automatic hits. From these, it determines the center of the circle.

    Image indicating the starting manual position to jog the probe to (A) and the automatic probing pathways (red lines) that NC Gage takes as it measures four points (positions 1-4)

  4. Once probing is complete, the measured values update with the circle's center. Select the work offset name from the list by pressing the Select a Work Offset to Update soft key [image] until the desired work offset is highlighted. Parameters for each highlighted work offset update on the screen as you select each one.

  5. Press the Confirm soft key [image] to update with the selected work offset. The axes that are not parallel with the work face normal work offset values are updated. Press the Return soft key [image] to return to the previous screen without saving.

Two Points for Large-Diameter Circle

  1. Position the probe to the side of the bore.

  2. Press the Read Position soft key [image]. The tip position is read as the bore center and distance away from the surface. Press the Back to Last Step soft key [image] to cancel this position and read a new position.

  3. Press the Execute soft key [image]; NC Gage will drive the probe and search the Circle (Bore) by taking three automatic hits. From these, it determines the center of the circle.

Image indicating the starting manual position to jog the probe to (A) and the automatic probing pathways (red lines) that NC Gage takes as it measures three points (positions 1-3)

  4. Once probing is complete, the measured values update with the circle's center. Select the work offset name from the list by pressing the Select a Work Offset to Update soft key [image] until the desired work offset is highlighted. Parameters for each highlighted work offset update on the screen as you select each one.

  5. Press the Confirm soft key [image] to update with the selected work offset. The axes that are not parallel with the work face's normal work offset values are updated. Press the Return soft key [image] to return to the previous screen without saving.

Specific Feature Path and Logic Built into NC Gage

Learn Bore Feature Path for One Point

  • Read position of probe in the center of the bore.

  • Bore measurements occur at Z value of read point.

  • Estimate XY center of bore to be read position point.

  • Measure point in +X direction using search distance.

  • Return to center position.

  • Measure point in –X direction using search distance.

  • Return to center position.

  • Measure point in +Y direction using search distance.

  • Return to center position.

  • Measure point in –Y direction using search distance.

  • Return to center position.

Learn Bore Feature Path for Two Points

  • Read position of probe in the center of the bore.

  • Read position of probe in the side of the bore.

  • Bore measurements occurs at Z value of read point.

  • Measure point at the center position to the side position direction using search distance.

  • Return to side position.

  • Measure point perpendicular to the center position to the side position direction using search distance.

  • Return to side position.

  • Measure another point perpendicular to the center position to the side position direction using search distance.

  • Return to side position.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Set Two Axes (Boss)

The Set Two Axes With Boss soft key measures a circular boss (external circle feature) on the part and then uses its center coordinates to update a specified work offset.

  1. Press the Set Work Offset soft key [image] on the second page of the main screen. The soft keys at the bottom change to show the different types of features that you can measure to set a work offset.

  2. Press the Set Two Axes With Boss soft key [image] to display the Set Two Axes (Boss) screen:

  3. Follow the on-screen instructions to measure a circle and select the work offset to update, and then press the Confirm soft key [image] to update the work offset. Press the Return soft key [image] to return to the previous screen without saving.

Probe Definition Area

Displays information related to the probe that is currently loaded.

Tip Offset Area

  • Tip Offset X, Y, and Z - The position of the probe tip relative to the gage line.

Work Offset Area

  • Work Offset - Specifies the work offset to be updated.

Parameters Area

  • Measured - Specifies the location of the work offset. The value is learned from a Circle (Boss) learn process and displayed in machine coordinates.

  • Target - The work offset will be offset this distance away from the measured feature.

Motion Parameters Area

  • Prehit Distance - Specifies the location that the probe will start searching for the surface. This is the distance away from the surface nominal that the probe will move at the "finding" speed that was established on the Setup screen.

  • Search Distance - Specifies the distance that the probe will travel while looking for the surface when in learn mode. For example, if the probe is positioned in the center of a hole, the probe will move at the "finding speed" that was established on the Setup screen to the search distance in each direction to find and learn the location of the feature.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Follow the on-screen instructions to measure a circle, select the work offset to update, and then touch OK to update the work offset.

Update Process

For machines that have wrist axes in the head, the learning process is only supported along the machine axis probe direction.

  1. Position the probe next to the side of the boss shown as position A below. Press the Read Position [image] soft key. The distance from the surface will be the same during measurement.

  2. Position the probe above the center of the boss shown as position B below. Press the Read Position [image] soft key. This location will be used to determine the center of the boss and the distance away from the boss for safely moving from measurement point to measurement point. Press theBack to Last Step soft key [image] to cancel this measure position.

  3. Press the Execute soft key [image]. NC Gage takes one hit below this position to determine the height of the boss. It then automatically takes hits in a similar fashion as depicted below.

    Image indicating the manual positions to jog the probe to (A-B) and the automatic probing pathways (red lines) taken by NC Gage as it measures four points (positions 1-4)

  4. Once probing is complete, the measured values update with the circle's center. Select the Work Offset name from the list by pressing the Select a Work Offset to Update soft key [image] until the desired work offset is highlighted. Parameters for each highlighted work offset update on the screen as you select each one.

  5. Press the Confirm soft key [image] to update the work offset for the axes in the work face normal. Press the Return soft key [image] to return to the previous screen without saving.

Specific Feature Path and Logic Built into NC Gage

  • Read position of probe next to side of boss; Z value is measurement height.

  • Read position of probe above center of boss. XY values define center; Z value is safe height.

  • Prehit radius = projected 2D distance between two read position points.

  • Move to safe height.

  • Move at safe height to a point above prehit point 1, which is prehit radius from center in +X.

  • Drop to measurement height.

  • Measure point, target is center at measurement height.

  • Move to safe height.

  • Move at safe height to a point above prehit point 2, which is prehit radius from center in -X.

  • Drop to measurement height.

  • Measure point, target is center at measurement height.

  • Move to safe height.

  • Move at safe height to a point above prehit point 3, which is prehit radius from center in +Y.

  • Drop to measurement height.

  • Measure point, target is center at measurement height.

  • Move to safe height.

  • Move at safe height to a point above prehit point 4, which is prehit radius from center in -Y.

  • Drop to measurement height.

  • Measure point, target is center at measurement height.

  • Move to safe height.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Set Two Axes (Inside Corner)

The Set Two Axes With Inside Corner soft key measures an inside corner on a part and then uses its corner coordinates to update a specified work offset.

  1. Press the Set Work Offset soft key [image] on the second page of the main screen. The soft keys at the bottom change to show the different types of features that you can measure to set a work offset.

  2. Press the Set Two Axes With Inside Corner soft key [image] to display the Set Two Axes (Inside Corner) screen:

Probe Definition Area

Displays information on the currently selected probe that is used in your measurement routine.

Work Offset Area

  • Work Offset - Specifies the work offset to be updated.

Parameters Area

  • XYZ Measured and Target - Specify the measured and target XYZ locations of the work offset. The measured values are learned from a corner (inside) learn process.

Motion Parameters Area

  • Prehit Distance - Specifies the location that the probe will start searching for the surface. This is the distance away from the surface nominal that the probe will move at the "finding" speed that was established on the Setup screen.

  • Search Distance - Specifies the distance the probe will travel while looking for the surface when in learn mode. For example, if the probe is positioned in the center of a hole, the probe will move at the "finding speed" that was established on the Setup screen to the search distance in each direction to find and learn the location of the feature.

Local Clearance Plane Area

  • Hit Clearance Plane - Selecting this option causes the probe to move to a clearance plane between each hit of the feature. Enter the distance to the plane in the box to the right. This plane is not the measurement routine clearance plane. See "Hit Clearance Plane" for details.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Follow the on-screen instructions to measure an inside corner and select the work offset to update, and then press the Confirm soft key [image] to update the selected work offset.

Update Process

  1. Position the probe next to a surface comprising the corner.

  2. Press the Read Position soft key [image].

  3. Position the probe next to the first point of the same face.

  4. Press the Read Position soft key [image].

  5. Position the probe next to a second surface comprising the corner.

  6. Press the Read Position soft key [image].

  7. Position the probe next to the first point on this second surface.

  8. Press the Read Position soft key [image].

  9. Press the Execute soft key [image] and NC Gage will automatically takes hits in a similar fashion as depicted below. Press the Return soft key [image] to return to the previous screen without saving.

The image on the left indicates the manual jog positions (A-D) to which you should jog the probe. The image on the right indicates the automatic probing pathways (red lines) taken by NC Gage as it measures four points at positions 1-4

  10. Once probing is complete, the measured values update with the corner's location. Select the Work Offset name from the list by pressing the Select a Work Offset to Update soft key [image] until the desired work offset is highlighted. Parameters for each highlighted work offset are updated on the screen as you select each one.

  11. Press the Confirm soft key [image] to update the work offset. Press the Return soft key [image] to return to the previous screen without saving.

Specific Feature Path and Logic Built into NC Gage

  • If running a wrist machine, rotate the probe along the machine axis.

  • Read position of probe next to first point of first side of corner. All measurements will be taken at the same level as this point.

On a wrist machine, you are required to rotate the probe along a machine axis first. Measuring the corner features updates the other two axes of the work offset:

      • If the probe is along the machine's Z axis, the first read point updates the Parameters X and Y axis areas.

      • If the probe is along the machine's X axis, the first read point updates the Parameters Y and Z axis areas.

      • If the probe is along the machine's Y axis, the first read point updates the Parameters X and Z axis areas.

  • Read position of probe next to second point of first side of corner.

  • Read position of probe next to first point of second side of corner.

  • Read position of probe next to second point of second side of corner.

  • Determine first and second direction vectors and normal vectors.

  • Compensate points.

  • Determine approximate corner point.

  • Position probe to first read point position.

  • Measure toward first side surface, search distance is 4* prehit distance.

  • Position probe approximately to second read point.

  • Measure toward first side surface, search distance is 4* prehit distance.

  • Position probe approximately to third read point.

  • Measure toward second side surface, search distance is 4* prehit distance.

  • Position probe approximately to fourth read point.

  • Measure toward second side surface, search distance is 4* prehit distance.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Set Two Axes (Outside Corner)

The Set Two Axes With Outside Corner soft key measures an outside corner on a part and then uses its corner coordinates to update a specified work offset.

  1. Press the Set Work Offset soft key [image] on the second page of the main screen. The soft keys at the bottom change to show the different types of features you can measure to set a work offset.

  2. Press the Set Two Axes With Outside Corner soft key [image] to display the Set Two Axes (Outside Corner) screen:

Probe Definition Area

Displays information on the currently selected probe that is used in your measurement routine.

Work Offset Area

  • Work Offset - Specifies the work offset to be updated.

Parameters Area

  • XYZ Measured and Target - Specifies the measured and target XYZ locations of the work offset. The measured values are learned from a corner (outside) learn process.

Motion Parameters Area

  • Prehit Distance - Specifies the location that the probe will start searching for the surface. This is the distance away from the surface nominal that the probe will move at the "finding" speed that was established on the Setup screen.

  • Search Distance - Specifies the distance the probe will travel while looking for the surface when in learn mode. For example, if the probe is positioned in the center of a hole, the probe will move at the "finding speed" that was established on the Setup screen to the search distance in each direction to find and learn the location of the feature.

Local Clearance Plane Area

  • Hit Clearance Plane - Selecting this option causes the probe to move to a clearance plane between each hit of the feature. Enter the distance to the plane in the box to the right. This plane is not the measurement routine clearance plane. See "Hit Clearance Plane" for details.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Follow the on-screen instructions to measure an outside corner and select the work offset to update, and then press the Confirm soft key [image] to update the selected work offset.

Update Process

  1. Position the probe next to a surface comprising the corner.

  2. Press the Read Position soft key [image].

  3. Position the probe next to the first point of the same face.

  4. Press the Read Position soft key [image].

  5. Position the probe next to a second surface comprising the corner.

  6. Press the Read Position soft key [image].

  7. Position the probe next to the first point on this second surface.

  8. Press the Read Position soft key [image].

  9. Select the Execute soft key [image] then NC Gage will automatically takes hits in a similar fashion as depicted below.

The image on the left indicates the manual jog positions (A-E) to which you should jog the probe. The image on the right indicates the automatic probing pathways (red lines) taken by NC Gage as it measures four points at positions 1-4.

  10. Once probing is complete, the measured values update with the corner's location. Select the work offset name from the list by pressing the Select a Work Offset to Update soft key [image] until the desired work offset is highlighted. Parameters for each highlighted work offset are updated on the screen as you select each one.

  11. Press the Confirm soft key [image] to update the work offset. Press the Return soft key [image] to return to the previous screen without saving.

Specific Feature Path and Logic Built into NC Gage

  • If running a wrist machine, rotate the probe along the machine axis.

  • Read position of probe next to first point of first side of corner. All measurements will be taken at the same level as this point.

On a wrist machine, you are required to rotate the probe along a machine axis first. Measuring the corner features updates the other two axes of the work offset:

      • If the probe is along the machine's Z axis, the first read point updates the Parameters X and Y axis areas.

      • If the probe is along the machine's X axis, the first read point updates the Parameters Y and Z axis areas.

      • If the probe is along the machine's Y axis, the first read point updates the Parameters X and Z axis areas.

  • Read position of probe next to second point of first side of corner.

  • Read position of probe next to first point of second side of corner.

  • Read position of probe next to second point of second side of corner.

  • Determine first and second direction vectors and normal vectors.

  • Compensate points.

  • Determine approximate corner point.

  • Check position of probe. If it is not clear of the corner, move probe to the intersection of the two lines formed by the four learn points. Do this move as a two axis move. If position is above the measurement height move XY first then Z; if the position is below the measurement height, move up in Z then move ZY.

  • Position probe to first read point position.

  • Measure toward first side surface, depth matches first point of second side.

  • Position probe approximately to second read point.

  • Measure toward first side surface, depth matches first point of second side.

  • Move to point beyond corner to avoid collision.

  • Position probe approximately to third read point.

  • Measure toward second side surface, depth matches first point of first side.

  • Position probe approximately to fourth read point.

  • Measure toward second side surface, depth matches first point of first side.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Set Three Axes With Sphere

The Set Three Axes With Sphere soft key measures a sphere and then uses the measured coordinates to update a specified work offset.

The number of points defines the number of points that will be used to measure the sphere. The lower level angle, which is usually 0 (equator), defines the lowest level to measure. The upper level angle, which is usually 90 (North Pole), defines the highest level to measure.

  1. Press the Set Work Offset soft key [image] on the second page of the main screen. The soft keys at the bottom change to show the different types of features you can measure to set a work offset.

  2. Press the Set Three Axes With Sphere soft key [image] to display the Set Three Axes (Sphere) screen:

  3. Follow the on-screen instructions and then press the Confirm soft key [image] to complete the procedure. Press the Return soft key [image] to return to the previous screen without saving.

Work Offset Area

  • Work Offset - Specifies the work offset to be updated.

Parameters Area

  • Parameters X, Y, and Z - Define the center of the sphere. The Measured column specifies the measured values of the work offset. The Target column defines the theoretical values of the sphere center in work offset coordinates. The theoretical values can be anything, but are usually zeroes.

Tip Offset Area

  • Tip Offset X, Y, and Z - The work offset will be offset this distance away from the measured feature.

Motion Parameters Area

  • Prehit Distance - Specifies the location that the probe will start searching for the surface. This is the distance away from the surface nominal that the probe will move at the "finding" speed that was established on the Setup screen.

  • Search Distance - Specifies the distance the probe will travel while looking for the surface when in learn mode. For example, if the probe is positioned in the center of a hole, the probe will move at the "finding speed" that was established on the Setup screen to the search distance in each direction to find/learn the location of the feature.

Properties Area

  • Number of Points - Defines the number of points that will be used to measure the sphere.

  • Lower Level Angle - Is usually 0 (equator). It defines the lowest level to measure.

  • Upper Level Angle- Is usually 90 (North Pole). It defines the highest level to measure.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Follow the on-screen instructions and select the work offset to update, and then press the Confirm soft key [image] to update the selected work offset.

Update Process

  1. Position the probe above the sphere center top (Position A in image shown below), and press the Read Position soft key [image].

  2. Press the Learning and Creating a Command soft key [image].

  3. Run the system monitor program. NC Gage automatically takes hits in a fashion as depicted below.

Sphere Path: A) jog position 1-4) automatically measured point positions

  4. The measured values are updated once the feature has been measured. Select the work offset name from the list by pressing the Select a Work Offset to Update soft key [image] until the desired work offset is highlighted. Parameters for each highlighted work offset are updated on the screen as you select each one.

  5. Press the Confirm soft key [image] to update the work offset. Press the Return soft key [image] to return to the previous screen without saving.

Specific Feature Path and Logic Built into NC Gage

Learn Sphere Feature Path

The location and size of the sphere is determined by measuring a point on the top of the sphere and sampling three more points near the top. This is how the sphere feature is learned. After the sphere location and size is determined, the sphere is re-measured using the learned size and location. The measurements are performed using the values set in the motion parameters and properties boxes.

  • Read position of probe, which should be above the top of the sphere.

  • Measure point straight down, using search distance.

  • Retract to original read position and move 2* probe radius in the +X direction.

  • Measure point straight down, using search distance.

  • Retract to original height and move 2* probe radius in direction which is 120 degrees from +X axis.

  • Measure point straight down, using search distance.

  • Retract to original height and move 2* probe radius in direction which is 240 degrees from +X axis.

  • Measure point straight down, using search distance.

  • Retract to original height.

Execute Sphere Feature Path

  • Number of levels and points for each level are determined based on the inputs.

  • If current position is lower than the Clearance Plane height then move up to clearance plane.

  • Move to position above the first Prehit point.

  • Drop down to lowest level and measure that level, if needed evasive moves are added between each point in a level to avoid collisions.

  • Measure the rest of the level(s) using alternating directions.

  • Measure point on top of sphere (if upper level angle is 90).

  • Move to clearance plane height.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Set One Axis to Mid Point

The Set One Axis to Mid Point soft key sets one axis of a work offset to be the value that is halfway between two parallel surfaces.

  1. Press theSet Work Offsets soft key [image] on the main screen. The soft keys at the bottom change to show the different types of features that you can measure to set a work offset.

  2. Press the Set One Axis To Mid Point soft key [image] to display the Set One Axis To Mid Point screen:

Probe Definition Area

Displays information on the currently selected probe that is used in your measurement routine.

Work Offset Area

  • Work Offset - Specifies the work offset to be updated.

Parameters Area

  • Measured X, Y, or Z - Specifies the location of the work offset. The value is learned from a point learn process. The axis varies based on the direction selected in the Axis area.

The screen icon image located in the upper-left area of this screen update based on the selections made from the Axis and Shape areas.

  • Target - The work offset is set so that the measured mid point agrees with the target value when the work offset is enabled.

Motion Parameters Area

  • Prehit Distance - Specifies the location that the probe will start searching for the surface. This is the distance away from the surface nominal that the probe will move at the "finding" speed that was established on the Setup screen.

  • Search Distance - Specifies the distance the probe will travel while looking for the surface when in learn mode. For example, if the probe is positioned in the center of a hole, the probe will move at the "finding speed" that was established on the Setup screen to the search distance in each direction to find and learn the location of the feature.

Axis Area

  • Select the direction in which the two surfaces will be measured to calculate the mid point. The Parameters area updates accordingly.

Shape Area

  • Select the shape of the feature to be measured that will be used to calculate the mid point.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learning Process

  1. Select the particular axis as required from the Axis area on the screen. The available axes are X, Y, and Z.

  2. Select the particular shape as required from the Shape area of the screen. The available shapes are Web, Pocket, and Step. All three shapes are available when setting X or Y axis. Only the step shape is available for Z.

The screen icon image located in the upper-left of this screen updates based on the selections made from the Axis and Shape areas.

  3. Enter a target value.

The following matrix describes the learning process for each Shape/Axis combination:

 | X, Y, or Z Axis
Web | First side of Web. Opposite side of Web. Define Safe Height to move from one side to the other.
Pocket | First side of Pocket. Second side of point.
Step | Next to point at first Step level. Next to point at second Step level. Move away from second point.

  4. Set the Prehit Distance and Search Distance as needed. This can be done at any time.

  5. Select the work offset to update. This can be done at any time.

  6. After learning the points to define the measurement, you will press the Execute soft key [image]. NC Gage proceeds to measure the part. The mid point value is computed and displays on the screen.

  7. Click the Confirm soft key [image] to accept and save the results, or the Cancel soft key [image] to reject and not save the results.

Shape Examples

Step shapes:

Pocket and Web shapes:

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Set Rotation Angle Axes With a Line

Home > Using PC-DMIS NC Gage > Getting Started > Step 6: Selecting a Work Offset > Set Work Offsets > Set Rotation Axes Angle With a Line

Set Rotation Axes Angle With a Line

Use the Set Rotary Axes (Angle) screen to define and display all features that generate a well-defined angle in the rotary axis plane.

Use the following steps to access this screen:

  1. Press the Set Work Offset soft key [image] on the second page of the main screen. The soft keys at the bottom change to show the different types of features that you can measure to set a work offset.

  2. Press the Set Rotation Angle Axes With Line soft key [image] to display the Set Rotary Axes (Angle) screen:

  3. Follow the on-screen instructions and then press the Confirm soft key [image] to complete the procedure. Press the Return soft key [image] to return to the previous screen without saving.

Tip Offset Area

  • Tip Offset X, Y, and Z - The position of the probe tip relative to the gage line.

Work Offset Area

  • Work Offset - Specifies the work offset to be updated.

Rotary Table Area

  • Axis ID - The letter that identifies the axis: A, B, or C depending on the number of rotary tables defined in the system.

Measurement Area

  • Angle - Displays the Measured and Target values of the rotary table angles.

Properties Area

  • Number Of Points - Defines the number of points to be measured.

Motion Parameters Area

  • Prehit Distance - Defines the distance away from the nominal surface at which the probe starts seeking the surface during measure.

  • Search Distance - The search distance is the distance the probe travels while looking for the surface when in learn mode. For example, if the probe is positioned in the center of a hole, the probe moves at the "finding speed" that was established on the Setup screen to the search distance in each direction to find/learn the location of the feature.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learning Process

The concept is to measure a line that is in the “Rotary Table Plane”, so that the rotary axis component of the work offset can be set based on that line. The measurement of that line determines an angle in the plane and the rotary axis angle will match the target angle when the updated work offset is active.

There are two different scenarios for measuring the line:

  • The first case is when the normal axis of the rotary table plane is parallel (or anti-parallel) to the spindle axis.

In the image above, a part with 30 degree tilt angle in the C axis is fixed on the table. You want to update work offset of rotary axis C to make the work coordinates system X+ is same as the line direction when the new work offset is active.

At first, you should rotate the table C to align the yellow line direction to the approximate work offset zero position (X+). From this step, NC Gage can recognize the target value computed from the line is more or less 30 but not 30+180=210 degree.

Except for this rough alignment precondition, the learning steps are identical to the steps for the measure line procedure in NC Gage.

As shown below, the yellow line direction on the front surface is being measured. You are provided with prompts to learn the positions of points 1, 2, and 3. Once NC Gage is taught these point positions, it has the necessary information to measure the line automatically.

In the image above, the direction of the line that is shown in black describes the measurement path. This is accomplished by positioning the probe at the three positions shown.

  • The second case is when the Normal Axis of the rotary table plane is perpendicular to the Spindle Axis.

In the image above, a part with 30 degree tilt angle in A axis is fixed on the table. You want to update the work offset of rotary axis A so that the work coordinates system Y+ is the same as the yellow line direction when the new work offset is active.

At first, you should rotate the table A to align the yellow line direction to the approximate work offset zero position (Y+). From this step NC Gage can recognize that the target value computed from the line is more or less 30 but not 30+180=210 degree.

In this case, except for the rough alignment precondition, there is one less step to learning the line. This is because in the first case, we are not sure if the part is on the “left” or “right” side of the defined line using the first two points, so you are instructed to learn a third point by moving “away” from the surface.

This second case is different, because the direction that the probe and the direction of the rotary table plane leaves only one possibility, so we do not prompt you to learn a third point.

Here, you are trying to measure the yellow line direction that lies in the plane defined by spinning the table on the side (which looks like a dowel in the picture above).

You are provided with prompts to learn the positions of points 1 and 2. Once NC Gage is taught these point positions, it has the necessary information to measure the line automatically.

In the above example, the direction of the line that is shown in black describes the measurement path. This is accomplished by positioning the probe at the two positions shown.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Set Rotary Axis (Angle) with Keyway

Use the Set Rotary Axis (Angle) with Keyway screen to define and display all features that generate a well-defined angle in the rotary axis.

To access this screen:

  1. Press the Set Work Offset soft key [image] on the second page of the main screen. The soft keys at the bottom change to show the different types of features that you can measure to set a work offset.

  2. Press the Set Rotary Axis (Angle) with Keyway soft key [image] to display the Set Rotary Axis (Angle) with Keyway screen:

  3. Follow the on-screen instructions and then press the Confirm soft key [image] to complete the procedure. Press the Return soft key [image] to return to the previous screen without saving.

Tip Offset Area

  • Tip Offset X, Y, and Z - The position of the probe tip relative to the gage line.

Work Offset Area

  • Work Offset - Specifies the work offset to be updated.

Rotary Table Area

  • Axis ID - The letter that identifies the axis: A, B, or C depending on the number of rotary tables defined in the system.

Measurement Area

  • Angle - Displays the Measured and Target values of the rotary table angles.

Motion Parameters Area

  • Prehit Angle - Defines the angle away from the nominal surface at which the probe begins to approach the measurement point at the measure speed.

  • Search Angle Range - Defines the search angle range when finding and learning a feature.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

Refer to "Learn Process" in the "Keyway" topic.

Execute Process

Refer to "Execute Process" in the "Keyway" topic.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Set Rotation Angle With Plane

The Set Rotation Angles With Plane screen sets the work offset zero values for a pair of rotary tables to square the measured plane to the spindle axis.

This option is only available for systems that have two (stacked) rotary tables. It sets the work offset zero values for both rotary axes simultaneously by measuring a plane. NC Gage calculates the angles that are required to orient the plane to be perpendicular to the probe.

Use the following steps to access this screen:

  1. Press the Set Work Offset soft key [image] on the second page of the main screen. The soft keys at the bottom change to show the different types of features you can measure to set a work offset.

  2. Press the Set Rotation Angle With Plane soft key [image] to display the Set Rotation Angle With Plane screen:

Tip Offset Area

  • Tip Offset X, Y, and Z - The position of the probe tip relative to the gage line.

Work Offset Area

  • Work Offset - Specifies the work offset to be updated.

Measurement Area

  • Angle - Displays the Measured and Target values of the rotary table angles.

Measurement Method Area

  • Grid Pattern - Defines the measurement method to be in a series of rows when measuring the plane.

  • Circular Pattern - Defines the measurement method to be in a circular construct when measuring the plane.

Properties Area

  • Number of Rows - Defines the number of rows to be measured when defining a Grid Pattern plane.

  • Number of Points Per Row - Defines the number of points on each row to be measured when defining aGrid Pattern plane.

  • Number Of Points - Defines the number of points to be measured when defining a Circular Pattern plane.

Motion Parameters Area

  • Prehit Distance - Specifies the location that the probe will start searching for the surface. This is the distance away from the surface nominal that the probe will move at the "finding" speed that was established on the Setup screen.

  • Search Distance - Specifies the distance the probe will travel while looking for the surface when in learn mode. For example, if the probe is positioned in the center of a hole, the probe will move at the "finding speed" that was established on the Setup screen to the search distance in each direction to find/learn the location of the feature.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learning Process

To use this option, you should manually position the tables so that the surface is roughly square to the probe. This requirement makes it easier to learn and measure the plane.

Learning the plane should consist of the same steps as learning a plane feature.

  1. Select the Grip Pattern or Circular Pattern measurement method. If Grid Pattern is selected, the Number Of Rows and Points Per Row controls appears as shown in the screen at the top of this page. If the Circular Pattern is selected, the Number Of Points control appears.

  2. Set the Prehit Distance and the Search Distance.

  3. Define the location of the pattern by learning two points to define the grid or a diagonal of the circular pattern.

  4. Once the two points have been defined, press the Execute soft key [image] to start the monitor program. NC Gage proceeds to measure the plane. After the plane is measured, NC Gage computes the rotations necessary to square the surface to the probe. You should make sure that the correct work offset is selected (this can be done at any time).

  5. Press the Confirm soft key [image] to use the values to set the selected work offset, or press the Cancel soft key [image] to abort the process.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Set Rotary Axis (Angle) with Flat

Use the Set Rotary Axis (Angle) with Flat screen to define and display all features that generate a well-defined angle in the rotary axis.

To access this screen:

  1. Press the Set Work Offset soft key [image] on the second page of the main screen. The soft keys at the bottom change to show the different types of features that you can measure to set a work offset.

  2. Press the Set Rotary Axis (Angle) with Flat soft key [image] to display the Set Rotary Axis (Angle) with Flat screen:

  3. Follow the on-screen instructions and then press the Confirm soft key [image] to complete the procedure. Press the Return soft key [image] to return to the previous screen without saving.

Tip Offset Area

  • Tip Offset X, Y, and Z - The position of the probe tip relative to the gage line.

Work Offset Area

  • Work Offset - Specifies the work offset to be updated.

Rotary Table Area

  • Axis ID - The letter that identifies the axis: A, B, or C depending on the number of rotary tables defined in the system.

Measurement Area

  • Angle - Displays the Measured and Target values of the rotary table angles.

Motion Parameters Area

  • Prehit Angle - Defines the angle away from the nominal surface at which the probe begins to approach the measurement point at the measure speed.

  • Search Angle Range - Defines the search angle range when finding and learning a feature.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

Refer to "Learn Process" in the "Flat" topic.

Execute Process

Refer to "Execute Process" in the "Flat" topic.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Set Rotary Axis (Angle) with Key

Use the Set Rotary Axis (Angle) with Key screen to define and display all features that generate a well-defined angle in the rotary axis.

To access this screen:

  1. Press the Set Work Offset soft key [image] on the second page of the main screen. The soft keys at the bottom change to show the different types of features that you can measure to set a work offset.

  2. Press the Set Rotary Axis (Angle) with Key soft key [image] to display the Set Rotary Axis (Angle) with Key screen:

  3. Follow the on-screen instructions and then press the Confirm soft key [image] to complete the procedure. Press the Return soft key [image] to return to the previous screen without saving.

Tip Offset Area

  • Tip Offset X, Y, and Z - The position of the probe tip relative to the gage line.

Work Offset Area

  • Work Offset - Specifies the work offset to be updated.

Rotary Table Area

  • Axis ID - The letter that identifies the axis: A, B, or C depending on the number of rotary tables defined in the system.

Measurement Area

  • Angle - Displays the Measured and Target values of the rotary table angles.

Motion Parameters Area

  • Prehit Angle - Defines the angle away from the nominal surface at which the probe begins to approach the measurement point at the measure speed.

  • Search Angle Range - Defines the search angle range when finding and learning a feature.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

  1. Position the probe next to the side of the key at the inspection height, and press the Read Position soft key [image].

  2. Position the probe at a safe height above the key top, and press the Read Position soft key [image].

  3. Refer to the image below.

    • The probe moves to the top of the key.

    • The rotary axis rotates to a prehit angle position.

    • The probe moves to the measure height.

    • The rotary axis rotates in a clockwise direction until the probe is triggered. The rotary axis stops rotating. It retracts to the prehit angle position.

    • The probe moves to the top of the key.

    • The rotary axis rotates to a prehit angle position.

    • The probe moves to the measure height.

    • The rotary axis then rotates in a counter-clockwise direction until the probe is triggered. The rotary axis stops rotating. It retracts to the prehit angle position.

    • The probe moves to the top of the key.

    • The rotary axis rotates back to the original position.

    • The middle angle of the key is calculated by the two triggered rotary axis positions.

Execute Process

Refer to "Execute Process" in the "Keyway" topic.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Update Work Offset

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] until the Update Work Offset soft key appears.

  3. Press the Update Work Offset soft key [image] to display the Update Work Offset screen:

Feature List Area

  • X, Y, Z, A, C - The feature selection axis lists display the features in the measurement routine that can be used to define the work offset. The feature selection axis lists that are displayed are dependent on how you've defined your system through the NC Gage Configuration Tool.

Work Offset Area

Specifies the Work offset, which is chosen to be updated. Use the Select Work Offset soft key [image] to toggle through the list one item at a time.

Selected Feature Details Area

  • Part Values - These read-only boxes display the selected feature position/angle (XYZAC) values. These values have already been transformed to the part coordinates system.

  • Machine Values - These read-only boxes display the selected feature position/angle (XYZAC) values. These values have already been transformed to the machine coordinates system.

  • Target Values - These boxes define the extra offset values for each axis but use the machine coordinate values as default reference values. The input will be added to the measured value, which will be used to set the work offset.

Comment

Use this box to type a comment for the updated work offset.

Detailed Procedure:

This screen can be used to automatically update a work offset at the end of a measurement routine or to manually update a work offset after features have been inspected.

To do this, an update work offset command needs to be added to an NC Gage measurement routine.

  1. Inspect the features that will be used to update the work offset using NC Gage.

  2. Press the Update Work Offset soft key [image] to access the Update Work Offset screen as described above.

  3. Select the features defining the work offset in the Update Work Offset screen.

  4. Press the Confirm soft key [image] to add the update work offset command to the NC Gage measurement routine. Press the Return soft key [image] to return to the previous screen.

When the measurement routine runs, it updates the work offset.

To learn the work offset:

  1. Select the feature in each axis list that is to be updated. Not all the axes need to be updated. The Value boxes update to show the location of the selected feature. Once the Value box updates with information, the corresponding Offset box will become available.

  2. If desired, type an offset distance into the Offset boxes. The distance may be positive or negative and represents the location of the feature after the work offset is updated.

  3. Select the work offset name from the list by pressing the Select a Work Offset to Update soft key [image] until the desired work offset is highlighted. Parameters for each highlighted work offset will be updated on the screen as each one is selected.

  4. If the measurement routine has already run, NC Gage can update the work offset immediately. Configure the screen accordingly and select the Execute soft key [image]. This updates the selected work offset and not save the command to the measurement routine.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Defining Control Frames

Home > Using PC-DMIS NC Gage > Getting Started > Step 7: Defining Control Frames

Step 7: Defining Control Frames

Move Rotary Axis

The Move Rotary Axes command positions one or more rotary axes. This command does not have a zero point associated with it, thus it does not require learning the zero point.

More:

Move Rotary Axis

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Move Rotary Axis

A move rotary axis command is used only on machines that have more than three axes such as machines with a rotary table. You need to have a license to support more than three axes. Essentially you position the probe to a safe position and then position the rotary axes to the positions required for the move.

To add a move rotary axis command to your measurement routine, NC Gage requires the software to be configured appropriately.

When a move rotary axis command is created, it sets the position that the rotary table(s) will be at when that move rotary axis command is active. If you try to learn a new command with the move rotary axis command active and the tables are not at the correct position, a warning message appears and you will not be allowed to learn the feature until the rotary table(s) are at the same position(s) as defined by the move rotary axis command.

NC Gage now checks when you learn a new command to make sure that the tables have not been moved from the positions defined by the Move Rotary Axis command. If they have been moved, a warning is given and the feature can not be learned until the table positions agree with the current move rotary axis command.

The message is:

The Current Rotary Table Position(s) Do Not Match the Current Rotary Axis position, Please Fix Before Continuing.

  1. Follow the instructions for Setting a Work Offset.

  2. After the work offset is defined, the Select a Work Offset softy key [image] will change to the Move Rotary Axis soft key [image]. Select the Move Rotary Axis soft key [image] on the main screen's navigation bar. The Move Rotary Axis screen appears:

  3. Enter the safe point and rotation information into the respective areas.

  4. Select the direction of the primary axis in the Primary Direction area.

  5. Follow the instructions on the screen to define the move rotary axis command parameters.

Safe Point Area

  • Safe Point X, Y, Z, W - Defines the home or safe X, Y, and Z coordinate location for the probe to start from prior to execution of the measurement routine. The probe will return to this location prior to each measurement routine execution. For a sub-spindle, this area displays W-coordinate location for the probe also.

Rotation Area

  • Rotation A, B or Rotation B, C - Displays the learned values (in degrees) for each of the system axes.

Primary Direction Area

  • X+, Y+, Z+, X-, Y-, Z- - Defines the primary direction of the primary axis. Based on the need, this list automatically updates to display the required axis.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Defining Clearance Paths

Home > Using PC-DMIS NC Gage > Getting Started > Step 8: Defining a Clearance Path

Step 8: Defining a Clearance Path

Clearance paths enable you to define a distance above a desired plane or cylinder through which the probe can move safely to avoid contacting the part or other obstructions.

For information on defining clearance paths, see "Clearance Plane" in the "Inserting Move Commands" chapter.

Once you have finished defining your clearance paths, you can begin adding features to measure to your measurement routine. See "Creating Feature Commands".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Creating Feature Commands

NC Gage provides you with two ways to create feature commands and add them into your measurement routine for NC Gage to measure during execution.

Creating Feature Commands by Typing Parameter Values

To create feature commands by typing parameters, access the appropriate feature command screen, select the Learn Using Values on Screen check box, enter all of the parameters and properties, and then touch the Learning and Creating A Command soft key. NC Gage inserts the feature command into the measurement routine according to your definition.

Creating Feature Commands by Learning a Feature

To create feature commands by "learning" is the default mode when you access a feature command screen. You need to manually jog the probe, and with the probe, learn positions on the part according to the on-screen instructions in order to learn a feature. NC Gage interprets the probe positions and automatically fills in the parameters on the feature command screen with information from your learned positions. NC Gage then enables you to insert the feature command into the measurement routine following this "learning" process.

Your probe must be calibrated prior to adding feature commands (see "Calibration").

You can add the following commands to your measurement routine.

Measured Features

  • Point

  • Circle (Bore)

  • Circle (Boss)

  • Circle (Shaft)

  • Web

  • Pocket

  • Corner (Inside)

  • Corner (Outside)

  • Plane

  • Line

  • Cylinder (Bore)

  • Cylinder (Boss)

  • Cone (Inside)

  • Cone (Outside)

  • Sphere

  • Key

  • Keyway

  • Flat

Constructed Features

  • Construct Point

  • Construct Line

  • Construct Circle

  • Construct Cylinder

Dimensions

  • Angle Between

  • Dimension Distance

Concentricity

  • Concentricity

Additional Functionality

  • Update Work Offset

  • Set Coordinate Rotation

Soft Keys

You can touch one of these soft keys on the navigation bar to access the feature's screen.

Soft Keys for a Millturn Machine

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Common Properties:

  • Tolerance

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Point

It is important to define a Work Face and select the measurement face prior to measuring a feature. For more information, see "Work Face Setup".

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Point soft key [image] on the Measure screen to display the Measure Point screen:

  3. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It displays a graphical view of where to position the probe for measurements and changes when multiple steps are required.

Surface Direction Area (enabled only when the Skew work face option is selected)

The Surface Direction area defines the vector angle in the X, Y, and Z directions of the point. From this area, select Angles or Vector to define the vector angles.

If you select Angles, these boxes are available:

Angle To X - Defines the vector angle in the X direction of the point. This is the point's surface normal direction in relation to the primary axis that it is measured in. The primary axis is X in the XY work face, Y in the YZ work face, and Z in the ZX work face. The valid range is 0 (zero) degrees to -360 degrees.

Angle To Z - Defines the first vector angle in the Z direction of the point. This is the point's surface normal direction in relation to the work face. The valid range is -90 degrees to +90 degrees.

If you select Vector, these boxes are available:

I - Defines the vector in the X direction of the point.

J - Defines the vector in the Y direction of the point.

K - Defines the vector in the Z direction of the point.

Motion Parameters Area

  • Prehit Distance - Defines the distance away from the nominal surface that the probe uses to begin seeking the surface during the measurement process.

  • Search Distance - Defines the search distance when finding and learning a feature. (Not available if Learn Using Values on Screen described in "Optional Settings Area" is selected.)

Optional Settings Area

  • Hit Clearance Plane - Selecting this option causes the probe to move to a clearance plane between each hit of the feature. The edit box to the right is for entering the distance to the plane. This plane is not the measurement routine clearance plane. See Hit Clearance Plane for details.

  • Learn then Measure - Selecting this option causes the machine to learn the location of the part using default parameters and then immediately re-measure the feature with the properties as set on the screen. Used to test all the set parameters, providing a more accurate and reliable first article inspection.

  • Learn Using Values on Screen - Used to enter the nominal values of the feature and have the software measure at that location. (Disables the Search Distance option in the Motion Parameters area when selected.)

Point Position Area

  • XYZ Nominal - Defines the nominal position of the point.

  • XYZ Measured - Displays the measured position of the point.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Process to learn a point with work face defined normal:

  1. Press the Select Measurement Face soft key [image] and choose the work face for the point (Top, Left, Right, Front, Back or Skew).

  2. Position the probe above the surface where you want to measure the point feature.

  3. Press the Read Position soft key [image]. The tip position is read as the start position. Press theReturn to Previous Step soft key [image] to cancel this measure position.

  4. Press the Learning and Creating a Command soft key [image]. NC Gage automatically takes a hit in a similar fashion as depicted below.

    Position A indicates where you should position the probe. The red line shows the measuring path. Position 1 indicates the measured point position.

  5. Once the feature has been measured, the measured values are updated. Press the Confirm and Append Current Command to End soft key [image] to add the feature command to the measurement routine.

Process to learn a point with Skewed work face defined normal:

  1. Press the Select Measurement Face soft key [image] and choose the work face for the point (Top, Left, Right, Front, Back or Skew). To select the Skew option, press the Select Measurement Face soft key until the icon changes to the Skew icon [image].

  2. Position the probe above the surface where you want to measure the point feature.

  3. Press the Read Position soft key [image]. The tip position is read as the start position. Press theReturn to Previous Step soft key [image] to cancel this measure position.

  4. Position the probe away from the measured point location in the direction of the surface.

  5. Press the Read Position soft key [image].

  6. Press the Learning and Creating a Command soft key [image].

  7. Once the feature has been measured, the measured values are updated. Press the Confirm and Append Current Command to End soft key [image] to add the feature command to the measurement routine.

The following is the specific feature path and logic built into NC Gage built into NC Gage:

Learn Point Feature Path

  • Read current position.

  • Measure in direction of current work face, search distance is 3* prehit distance.

  • Retract to read position.

Execute Point Feature Path

  • If current position is lower than the clearance plane height then move up to clearance plane.

  • Move to position above point.

  • Move down to a position above point that is prehit distance + probe radius from nominal surface.

  • Measure point, target is prehit distance below surface.

  • Move to clearance plane height after measurement.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Circle (Bore)

Home > Using PC-DMIS NC Gage > Creating Feature Commands > Circle (Bore)

Measure Circle (Bore)

To create a Circle (Bore) command:

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Circle (Bore) soft key [image] to display the Measure Circle (Bore) screen:

  3. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It displays a graphical view of where to position the probe for measurements and changes when multiple steps are required.

Properties Area

  • Number of Points - Defines the number of points that will be probed for the circle during execution (not learn mode).

  • Start Angle - Defines the starting point for a section of the circle to measure. Rotation starts at 0 along the primary axis and grows such that 90 is at the secondary axis. The primary axis is X in the XY work face, Y in the YZ work face, and Z in the ZX work face. The secondary axis is Y in the XY work face, Z in the YZ work face, and X in the ZX work face.

  • End Angle - Defines the end of the section of the circle that will be measured. The start and end angle will only be used when the featured is measured in execute mode. Learn mode will automatically take hits in opposing primary and secondary axes directions. If the circle does not continue around for 360 degrees, then Learn Using Values on Screen could be used to enter the nominal location with a proper start and end angle defined. Then, with Learn then Measure selected, NC Gage will measure the feature.

  • Measurement Height - This value defines the directional height (relative to the nominal probe vector) of the measurements relative to the nominal XYZ parameters. A value of zero means the feature would be measured at the location of the XYZ point defined in the parameters group box. Negative values define how far below the nominal XYZ the bore should be measured. Positive values define how far above the nominal XYZ to measure.

The number of rows and points per row will be equally spaced along the defined circle.

Motion Parameters Area

  • Prehit Distance - Defines the distance away from the nominal surface that the probe uses to begin seeking the surface during the measurement process.

  • Search Distance - Defines the distance the probe travels while seeking the surface during learn mode. (Not available if Learn Using Values on Screen described in the Optional Settings area is selected.)

Optional Settings Area

  • Hit Clearance Plane - Selecting this option causes the probe to move to a clearance plane between each hit of the feature. The edit box to the right enters the distance to the plane. This plane is not the measurement routine clearance plane. See "Hit Clearance Plane" for details.

  • Learn Then Measure - Selecting this option causes the machine to learn the location of the part using default parameters and then immediately re-measure the feature with the properties as set on the screen. It tests all of the set parameters, which provides a more accurate and reliable first article inspection.

  • Learn Using Values on Screen - Used to enter the nominal values of the feature and have the software measure at that location. (Disables the Search Distance option in the Motion Parameters area when selected.)

Parameters Area

  • XYZD Nominal - Defines the nominal position of the circle bore.

  • XYZD Measured - Displays the measured position of the circle bore.

3 Axes Reporting Area

You can use 3 Axes reporting to define the XYZ point in three ways.

  • Select a measured point or plane used to define the height of the measured feature.

  • Enter the directional height of the plane to use. This height is relative to the part origin and measured along the probe vector.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

One Point for Small-Diameter Circle

  1. Position the probe in the center of the bore, and press the Read Position soft key [image]. This will be the height location for all the hits. Press the Return to Previous Step soft key [image] to cancel this measure position.

  2. Position the probe for automatic measurement, and press the Learning and Creating a Command soft key [image]. NC Gage takes four hits in each plus and minus direction of the primary and secondary axes.

Image indicating the starting manual position to jog the probe to (A) and the automatic probing pathways (red lines) that NC Gage takes as it measures four points (positions 1-4)

  • If a collision occurs, the process stops and an error appears.

  • If the probe misses the bore, modify the search distance and try again.

  3. Once you have measured the feature, NC Gage updates the measured values.

  4. Press the Confirm and Append Current Command to End soft key [image]. The feature command adds to the measurement routine.

Two Points for Large-Diameter Circle

  1. Position the probe in the center of the bore, and press the Read Position soft key [image]. This will be the height location for all the hits. Press the Return to Previous Step soft key [image] to cancel this measure position.

  2. Position the probe in the side of the bore, and press the Read Position soft key [image]. Press the Return to Previous Step soft key [image] to cancel this measure position.

  3. Position the probe for automatic measurement, and press the Learning and Creating a Command soft key [image].

Image indicating the starting manual position to jog the probe to (A) and the automatic probing pathways (red lines) that NC Gage takes as it measures three points (positions 1-3)

  • If a collision occurs, the process stops and an error appears.

  • If the probe misses the bore, modify the search distance and try again.

  4. Once you have measured the feature, NC Gage updates the measured values.

  5. Press the Confirm and Append Current Command to End soft key [image]. The feature command adds to the measurement routine.

Specific Feature Path and Logic Built into NC Gage

Learn Bore Feature Path for One Point

  • Read position of probe in the center of the bore.

  • Bore measurements will occur at Z value of read point.

  • Estimate XY center of bore to be read position point.

  • Measure point in +X direction using search distance.

  • Return to center position.

  • Measure point in –X direction using search distance.

  • Return to center position.

  • Measure point in +Y direction using search distance.

  • Return to center position.

  • Measure point in –Y direction using search distance.

  • Return to center position.

Learn Bore Feature Path for Two Points

  • Read position of probe in the center of the bore.

  • Read position of probe in the side of the bore.

  • Bore measurements occur at Z value of the read position.

  • Measure point at the center position to the side position direction using search distance.

  • Return to side position.

  • Measure point perpendicular to the center position to the side position direction using search distance.

  • Return to side position.

  • Measure another point perpendicular to the center position to the side position direction using search distance.

  • Return to side position.

Execute Bore Feature Path

  • Define prehit radius = Bore Radius - prehit distance – probe radius.

  • Define target radius = Bore Radius + prehit distance – probe radius.

  • If current position is lower than the clearance plane height then move up to clearance plane.

  • Move to position above first prehit point. This point is a distance of prehit radius from bore center in the direction of the start angle.

  • Drop down to the measurement level.

  • Measure point, target is target radius from bore center along angle.

  • Retract and move to prehit of next point.

  • Measure point, target is target radius from bore center along angle.

  • Continue from start angle to end angle measuring specified number of points.

  • If local clearance plane is enabled move to the local clearance plane between each point to get to next prehit point.

  • After last point is measured, the probe moves up to the clearance plane height.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Circle (Boss)

Home > Using PC-DMIS NC Gage > Creating Feature Commands > Circle (Boss)

Measure Circle (Boss)

To create a Circle Boss command:

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Circle (Boss) soft key [image] to display the Measure Circle (Boss) screen:

  3. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It displays a graphical view of where to position the probe for measurements and changes when multiple steps are required.

Properties Area

  • Number of Points - Defines the number of points that will be probed for the circle during execution (not learn mode).

  • Start Angle - Defines the starting point for a section of the circle to measure. Rotation starts at 0 along the primary axis and grows such that 90 is at the secondary axis. The primary axis is X in the XY work face, Y in the YZ work face, and Z in the ZX work face. The secondary axis is Y in the XY work face, Z in the YZ work face, and X in the ZX work face.

  • End Angle - Defines the end of the section of the circle that will be measured. The start and end angle will only be used when the featured is measured in execute mode. Learn mode automatically take hits in opposing primary and secondary axes directions. If the circle does not continue around for 360 degrees, then Learn Using Values on Screen could be used to enter the nominal location with a proper start and end angle defined. Then, with Learn then Measure selected, NC Gage will measure the feature.

The number of rows and points per row will be equally spaced along the defined circle.

Motion Parameters Area

  • Prehit Distance - Defines the distance away from the nominal surface that the probe uses to begin seeking the surface during the measurement process.

  • Search Distance - Defines the distance the probe will travel while seeking the surface during learn mode. (Not available if Learn Using Values on Screen described in the Optional Settings area is selected.)

Optional Settings Area

  • Hit Clearance Plane - Selecting this option causes the probe to move to a clearance plane between each hit of the feature. The edit box to the right will allow you to enter the distance to the plane. This plane is not the measurement routine clearance plane. See Hit Clearance Plane for details.

  • Learn then Measure - Selecting this option causes the machine to learn the location of the part using default parameters and then immediately re-measure the feature with the properties as set on the screen. Used to test all the set parameters, providing a more accurate and reliable first article inspection.

  • Learn Using Values on Screen - Used to enter the nominal values of the feature and have the software measure at that location. (Disables the Search Distance option in the Motion Parameters area when selected.)

Parameters Area

  • XYZD Nominal - Defines the nominal position of the circle boss.

  • XYZD Measured - Displays the measured position of the circle boss.

3 Axes Reporting Area

3 Axes reporting can be used to define the XYZ point in three ways.

  • Select a measured point or plane used to define the height of the measured feature.

  • Enter the directional height of the plane to use. This height is relative to the part origin and measured along the probe vector.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

  1. Position the probe near the surface on the side of the boss and press the Read Position soft key [image]. This will be the height location for all the hits. Press the Return to Previous Step soft key [image] to cancel this measure position.

  2. Position the probe above the center of the boss and press the Read Position soft key [image]. This will be used to determine the center of the boss. Press the Return to Previous Step soft key [image] to cancel this measure position.

  3. Position the probe for automatic measurement, and press the Learning and Creating a Command soft key [image]. NC Gage takes one hit below this position to determine the height of the boss. It then automatically takes hits in a similar fashion as depicted below.

    Image indicating the manual positions to jog the probe to (A-B) and the automatic probing pathways (red lines) taken by NC Gage as it measures four points (positions 1-4)

  4. Once the feature has been measured, the measured values are updated. Press the Confirm and Append Current Command to End soft key [image]. The feature command is added to the measurement routine. Press the Return soft key [image] to return to the previous screen without saving.

The following is the specific feature path and logic built into NC Gage built into NC Gage:

Learn Boss Feature Path

  • Read position of probe next to side of boss, Z value will be measurement height.

  • Read position of probe above center of boss, XY values define center, Z value is safe height.

  • prehit radius = projected 2D distance between two read position points.

  • Move to safe height.

  • Move at safe height to a point above prehit point 1, which is prehit radius from center in +X.

  • Drop to measurement height.

  • Measure point, target is center at measurement height.

  • Move to safe height.

  • Move at safe height to a point above prehit point 2, which is prehit radius from center in -X.

  • Drop to measurement height.

  • Measure point, target is center at measurement height.

  • Move to safe height.

  • Move at safe height to a point above prehit point 3, which is prehit radius from center in +Y.

  • Drop to measurement height.

  • Measure point, target is center at measurement height.

  • Move to safe height.

  • Move at safe height to a point above prehit point 4, which is prehit radius from center in -Y.

  • Drop to measurement height.

  • Measure point, target is center at measurement height.

  • Move to safe height.

Execute Boss Feature Path

  • Define prehit radius = Boss Radius + prehit distance + probe radius.

  • Define target radius = Boss Radius - prehit distance – probe radius, if this is < 0, set to 0.

  • If current position is lower than the clearance plane height then move up to clearance plane.

  • Move to position above first prehit point. This point is a distance of prehit radius from boss center in the direction of the start angle.

  • Drop down to the measurement level.

  • Measure point, target is target radius from boss center along angle.

  • Retract and move to prehit of next point. If needed use one or more smaller moves to avoid contact with the boss.

  • Measure point, target is target radius from boss center along angle.

  • Continue from start angle to end angle measuring specified number of points.

  • If local clearance plane is enabled move to the local clearance plane between each point to get to next prehit point.

  • After last point is measured, the probe moves up to the clearance plane height.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Circle (Shaft)

Home > Using PC-DMIS NC Gage > Creating Feature Commands > Circle (Shaft)

Measure Circle (Shaft)

To create a Circle Shaft command:

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Circle (Shaft) soft key [image] to display the Measure Circle (Shaft) screen:

  3. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It displays a graphical view of where to position the probe for measurements and changes when multiple steps are required.

Properties Area

  • Number of Points - Defines the number of points that will be probed for the circle during execution (not learn mode).

  • Start Angle - Defines the starting point for a section of the circle to measure. Rotation starts at 0 along the primary axis and grows such that 90 is at the secondary axis. The primary axis is X in the XY work face, Y in the YZ work face, and Z in the ZX work face. The secondary axis is Y in the XY work face, Z in the YZ work face, and X in the ZX work face.

  • Included Angle - Defines the range for measurement with rotation. The start and included angles will only be used when the feature is measured in execute mode. Learn mode automatically take hits in opposing primary and secondary axes directions. If the circle does not continue around for 360 degrees, then Learn Using Values on Screen could be used to enter the nominal location with a proper start and end angle defined. Then, with Learn then Measure selected, NC Gage will measure the feature.

The number of points per row will be equally spaced along the defined circle.

  • Shaft Rotation - To measure a shaft by rotating the C axis, select Yes. Otherwise, select No.

Runout evaluation of the shaft is only possible when rotating the C axis is used.

Motion Parameters Area

  • Prehit Distance - Defines the distance away from the nominal surface that the probe uses to begin seeking the surface during the measurement process.

  • Search Distance - Defines the distance the probe will travel while seeking the surface during learn mode. (Not available if the Learn Using Values on Screen check box described under "Optional Settings Area" is selected.)

Optional Settings Area

  • Hit Clearance Plane - Selecting this option causes the probe to move to a clearance plane between each hit of the feature. The edit box to the right will allow you to enter the distance to the plane. This plane is not the measurement routine clearance plane. See "Hit Clearance Plane" for details.

  • Learn then Measure - Selecting this option causes the machine to learn the location of the part using default parameters and then immediately re-measure the feature with the properties as set on the screen. Used to test all the set parameters, providing a more accurate and reliable first article inspection.

  • Learn Using Values on Screen - Used to enter the nominal values of the feature and have the software measure at that location. (Disables the Search Distance option in the Motion Parameters area when selected.)

Parameters Area

  • XYZD Nominal - Defines the nominal position of the circle shaft.

  • XYZD Measured - Displays the measured position of the circle shaft.

3 Axes Reporting Area

You can use 3 Axes reporting to define the XYZ point in three ways.

  • Select a measured point or plane used to define the height of the measured feature.

  • Enter the directional height of the plane to use. This height is relative to the part origin and measured along the probe vector.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learning Process

  1. Position the probe near the surface on the side of the shaft and press the Read Position soft key [image]. This will be the height location for all the hits. Press the Return to Previous Step soft key [image] to cancel this measure position.

  2. Position the probe above the center of the shaft and press the Read Position soft key [image]. This will be used to determine the center of the shaft. Press the Return to Previous Step soft key [image] to cancel this measure position.

  3. Position the probe for automatic measurement, and press the Learning and Creating a Command soft key [image]. NC Gage takes one hit on the shaft along the radial direction. The probing direction is from the jog position to the shaft center.

Example indicating the start point and target point

Note that only the wrist angle in which the probe direction is perpendicular to the shaft center line can be supported now:

  4. Once the feature has been measured, the measured values are updated. Press the Confirm and Append Current Command to End soft key [image]. The feature command is added to the measurement routine. Press the Return soft key [image] to return to the previous screen without saving.

Learning Process Without Shaft Rotation

For this learning process, refer to the following image:

Learning process without shaft rotation

  1. Select No for the Shaft Rotation option.

  2. Position the probe next to the shaft surface in the top of the center line, and press the Read Position soft key [image]. This records the first jog position. To cancel this measured position, press the Return to Previous Step soft key [image].

  3. Position the probe next to the shaft surface in the side of the center line, and press the Read Position soft key [image]. This records the second jog position. To cancel this measured position, press the Return to Previous Step soft key [image].

  4. Position the probe next to the shaft surface, and press the Read Position soft key [image]. This records the third jog position. To cancel this measured position, press the Return to Previous Step soft key [image].

  5. Position the probe for automatic measurement, and press the Learning and Creating a Command soft key [image]. NC Gage automatically takes hits in a similar fashion, as shown below:

Hits for learning process without shaft rotation

Once the feature has been measured, the measured values are updated.

  6. Press the Confirm and Append Current Command to End soft key [image]. The feature command is added to the measurement routine. To return to the previous screen without saving, press the Return soft key [image].

Specific Feature Path and Logic Built into NC Gage

Learning the Shaft Feature Path

  • Position the probe next to the shaft surface in the top of the center line. Read the position.

  • Position the probe next to the shaft surface in the side of the center line. Read the position.

  • Position the probe next to the shaft surface. Read the position.

  • Calculate the shaft center with the read positions.

  • Measure the first point on the shaft surface in the probing vector direction.

  • Measure the second point on the shaft surface in the probing vector direction.

  • Measure the third point on the shaft surface in the probing vector direction.

  • Calculate the diameter and center of the shaft.

  • Calculate the start angle and include angle.

Executing the Shaft Feature Path

  • Define the prehit radius: Shaft radius + prehit distance + probe radius

  • Define the target radius: Shaft radius - prehit distance + probe radius

  • If the current position is lower than the clearance plane, then move up to it.

  • Move to above the prehit position in the clearance plane.

  • Move to the prehit position at the start angle. This point is a distance of the prehit radius from the table center in the direction of the start angle.

  • Drop down to the measurement level.

  • Measure the point. The target is the target radius from the table center along the start angle.

  • Retract and move to the next prehit position. Continue the above two steps until all the points are measured.

  • After the last point is measured, the probe moves up to the clearance plane.

Learning Process With Shaft Rotation

For this learning process, refer to the following image:

Learning process with shaft rotation

  1. Select Yes for the Shaft Rotation option.

  2. Position the probe next to the shaft surface, and press the Read Position soft key [image]. This records the jog position as the start position of the probing. To cancel this measured position, press the Return to Previous Step soft key [image].

  3. Position the probe for automatic measurement, To cancel this measured position, press the Return to Previous Step soft key [image]. NC Gage automatically takes one hit on the shaft along the radial direction. The probing direction is from the jog position to the shaft center, as shown below:

Probing direction from jog position to shaft center

Once the feature has been measured, the measured values are updated.

  4. Press the Confirm and Append Current Command to End soft key [image]. The feature command is added to the measurement routine. To return to the previous screen without saving, press the Return soft key [image].

Specific Feature Path and Logic Built into NC Gage

Learning the Shaft Feature Path

  • Position the probe near the shaft surface as the starting point.

  • Read the position.

  • Calculate the probing vector with the read position and table center.

  • Measure a point on the shaft surface in the probing vector direction.

  • Calculate the diameter and the center of the shaft.

  • Calculate the probing vector angle as the start angle.

  • Return to the start position.

Executing the Shaft Feature Path

  • Define the prehit radius: Shaft radius + prehit distance + probe radius

  • Define the target radius: Shaft radius - prehit distance + probe radius

  • If the current position is lower than the clearance plane, then move up to it.

  • Move to above the prehit position in the clearance plane.

  • Move to the prehit position at the start angle. This point is a distance of the prehit radius from the table center in the direction of the start angle.

  • Drop down to the measurement level.

  • Measure the point. The target is the target radius from the table center along the start angle.

  • Retract and rotate the table to the next angle.

  • Continue the above two steps until all the points are measured.

  • After the last point is measured, the probe moves up to the clearance plane.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Web

Home > Using PC-DMIS NC Gage > Creating Feature Commands > Web

Measure Web

To create a Web command:

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Web soft key [image] to display the Measure Web screen:

  3. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It displays a graphical view of where to position the probe for measurements and changes when multiple steps are required.

Properties Area

The following two properties are only visible when the Learn Using Values on Screen check box in the Optional Settings area is selected:

  • First Side Length - Defines the distance from the first point to the second.

  • Second Side Length - Defines the distance from the start point, if it were projected to the second side, to the point on the second side.

Motion Parameters Area

  • Prehit Distance - Defines the distance away from the nominal surface that the probe uses to begin seeking the surface during the measurement process.

  • Search Distance - Defines the distance the probe will travel while seeking the surface during learn mode. (Not available if Learn Using Values on Screen described in "Optional Settings Area" is selected.)

Optional Settings Area

  • Hit Clearance Plane - Selecting this option causes the probe to move to a clearance plane between each hit of the feature. The edit box to the right will allow you to enter the distance to the plane. This plane is not the measurement routine clearance plane. See Hit Clearance Plane for details.

  • Learn then Measure - Selecting this option causes the machine to learn the location of the part using default parameters and then immediately re-measure the feature with the properties as set on the screen. Used to test all the set parameters, providing a more accurate and reliable first article inspection.

  • Learn Using Values on Screen - Used to enter the nominal values of the feature and have the software measure at that location. (Enables the First Side Length and Second Side Length options in the Properties area and disables the Search Distance option in the Motion Parameters area when selected.)

Parameters Area

  • XYZ Nominal - Defines the nominal position of the top surface center of the web.

  • XYZ Measured - Displays the measured position of the top surface center of the web.

  • Angle to X - Defines the vector angle of the center line of the web. This is the line's direction in relation to the X-axis.

  • Width (Nominal) - Defines the nominal width of the web.

  • Width (Measured) - Displays the measured width of the web.

3 Axes Reporting Area

3 Axes reporting can be used to define the XYZ point in three ways.

  • Select a measured point or plane to define the height of the measured feature.

  • Enter the directional height of the plane to use. This height is relative to the part origin and measured along the probe vector.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

  1. Position probe next to first point on first side and press the Read Probe Position soft key [image]. The distance away from the work face surface will be the same on all the points.

  2. Position probe next to second point on first side and press the Read Probe Position soft key [image].

  3. Position probe next to point on second side, and press the Read Probe Position soft key [image].

  4. Press the Learning and Creating a Command soft key [image]. NC Gage moves to the clearance plane and automatically takes hits in a similar fashion as depicted below.

A-C) Jog positions 1-3) automatically measured point positions. Red lines show the measuring path.

  5. Press the Confirm and Append Current Command to End soft key [image]. The feature command is added to the measurement routine. Press the Return soft key [image] to return to the previous screen without saving.

Specific Feature Path and Logic Built into NC Gage

Learn Web Feature Path

  • Read position of probe next to first point of first side of web, Z value will be measurement height of all points

  • Read position of probe next to second point of first side of web, direction from first point to second point defines the direction vector of the web. This point determines approximate measurement location of 2nd point.

  • Read position of probe next to a point on the second side of web, distance from this point to the line defined by the first two points defines approximate width of the web. This point determines approximate measurement location of 3rd point.

  • If probe is left below clearance plane height, move up to clearance plane height.

  • Move to position above first read point.

  • Drop to measurement height.

  • Measure point, target is projection of first point onto web center line.

  • Retract and move to second read point position.

  • Measure point, target is projection of second point onto web center line.

  • Retract and move up to clearance plane height.

  • Move to point above third read point.

  • Drop to measurement height

  • Measure point, target is projection of third point onto web center line.

  • Retract and move up to clearance plane height.

Execute Web Feature Path

  • If probe is below clearance plane height, move up to clearance plane height.

  • Move to position above first prehit point.

  • Drop to measurement height.

  • Measure point, target is projection of first point onto web center line.

  • Retract and move to second prehit point position.

  • Measure point, target is projection of second point onto web center line.

  • Retract and move up to clearance plane height.

  • Move to point above third prehit point.

  • Drop to measurement height

  • Measure point, target is projection of third point onto web center line.

  • If local clearance plane is enabled move to the local clearance plane between each point to get to next prehit point.

  • Retract and move up to clearance plane height.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Pocket

Home > Using PC-DMIS NC Gage > Creating Feature Commands > Pocket

Measure Pocket

To create a Pocket command:

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Pocket soft key [image] to display the Measure Pocket screen:

  3. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It displays a graphical view of where to position the probe for measurements and changes when multiple steps are required.

Properties Area

The following two properties are only visible when the Learn Using Values on Screen check box in the Optional Settings area is selected:

  • First Side Length - Defines the distance from the first point to the second.

  • Second Side Length – Defines the distance from the start point, if it were projected to the second side, to the point on the second side.

Motion Parameters Area

  • Prehit Distance - Defines the distance away from the nominal surface that the probe uses to begin seeking the surface during the measurement process.

  • Search Distance - Defines the distance the probe will travel while seeking the surface during learn mode. (Not available if Learn Using Values on Screen described in "Optional Settings Area" is selected.)

Optional Settings Area

  • Hit Clearance Plane - Selecting this option causes the probe to move to a clearance plane between each hit of the feature. The edit box to the right enters the distance to the plane. This plane is not the measurement routine clearance plane. See Hit Clearance Plane for details.

  • Learn Then Measure - Selecting this option causes the machine to learn the location of the part using default parameters and then immediately re-measure the feature with the properties as set on the screen. Used to test all the set parameters, providing a more accurate and reliable first article inspection.

  • Learn Using Values on Screen - Used to enter the nominal values of the feature and have the software measure at that location. (Enables the First Side Length and Second Side Length options in the Properties area and disables the Search Distance option in the Motion Parameters area when selected.)

Parameters Area

  • XYZ Nominal - Defines the nominal position of the top surface center of the pocket.

  • XYZ Measured - Displays the measured position of the top surface center of the pocket.

  • Angle to X - Defines the vector angle of the pocket. This is the line's direction in relation to the X-axis.

  • Width (Nominal) - Defines the nominal width of the pocket.

  • Width (Measured) - Displays the measured width of the pocket.

3 Axes Reporting Area

3 Axes reporting can be used to define the XYZ point in three ways.

  • Select a measured point or plane to define the height of the measured feature.

  • Enter the directional height of the plane to use. This height is relative to the part origin and measured along the probe vector.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

  1. Position probe next to first point on first side and press the Read Probe Position soft key [image]. The distance away from the work face surface will be the same on all the points.

  2. Position probe next to second point on first side and press the Read Probe Position soft key [image].

  3. Position probe next to point on second side and press the Read Probe Position soft key [image].

  4. Press Learning and Creating a Command soft key [image]. NC Gage will move to the clearance plane and automatically takes hits in a similar fashion as depicted below. The probe will search 4 times the prehit distance when learning these points.

Pocket Path: A-C) jog positions along center line 1-3) measured point positions. Red lines show the measuring path.

  5. Press Confirm and Append Current Command to End soft key [image]. The feature command is added to the measurement routine. Press the Return soft key [image] to return to the previous screen without saving.

The following is the specific feature path and logic built into NC Gage built into NC Gage:

Learn Pocket Feature Path

  • Read position of probe next to first point of first side of pocket, Z value will be measurement height of all points

  • Read position of probe next to second point of first side of pocket, direction from first point to second point defines the direction vector of the pocket. This point determines approximate measurement location of 2nd point.

  • Read position of probe next to a point on the second side of pocket, distance from this point to the line defined by the first two points defines approximate width of the pocket. This point determines approximate measurement location of 3rd point.

  • If probe is left below clearance plane height, move up to clearance plane height.

  • Move to position above first read point.

  • Drop to measurement height.

  • Measure point, target is 4* prehit distance away from pocket center line.

  • Retract and move to second read point position.

  • Measure point, target is 4* prehit distance away from pocket center line.

  • Retract and move to third read point position.

  • Measure point, target is 4* prehit distance away from pocket center line.

  • Retract and move up to clearance plane height.

Execute Pocket Feature Path

  • If probe is below clearance plane height, move up to clearance plane height.

  • Move to position above first prehit point.

  • Drop to measurement height.

  • Measure point, target is 2* prehit distance away from pocket center line.

  • Retract and move to second prehit point position.

  • Measure point, target is 2* prehit distance away from pocket center line.

  • Retract and move to third prehit point position.

  • Measure point, target is 2* prehit distance away from pocket center line.

  • If local clearance plane is enabled move to the local clearance plane between each point to get to next prehit point.

  • Retract and move up to clearance plane height.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Corner (Outside)

Home > Using PC-DMIS NC Gage > Creating Feature Commands > Corner (Outside)

Measure Corner (Outside)

To create a Corner (Outside) command:

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Corner (Outside) soft key [image] to display the Measure Outside Corner screen:

  3. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It displays a graphical view of where to position the probe for measurements and changes when multiple steps are required.

Properties Area

The following three properties are only visible when the Learn Using Values on Screen check box in the Optional Settings area is selected:

  • Start Side Offsets - Defines the distances of the first and second points respectively from the corner nominal location along the first side, which is located at the start angle direction.

  • End Side Offsets - Defines the distances of the first and second points respectively from the corner nominal location along the second side.

  • First Side to Second Side is Clockwise - By default, NC Gage expects that the second side is located counterclockwise from the first. Selecting this option identifies that the second side is located clockwise with respect to the first.

Motion Parameters Area

  • Prehit Distance - Defines the distance away from the nominal surface that the probe uses to begin seeking the surface during the measurement process.

  • Search Distance - Defines the distance the probe will travel while seeking the surface during learn mode. (Not available if Learn Using Values on Screen described in "Optional Settings Area" is selected.)

Optional Settings Area

  • Hit Clearance Plane - Selecting this option causes the probe to move to a clearance plane between each hit of the feature. The edit box to the right will allow you to enter the distance to the plane. This plane is not the measurement routine clearance plane. See Hit Clearance Plane for details.

  • Learn then Measure - Selecting this option causes the machine to learn the location of the part using default parameters and then immediately re-measure the feature with the properties as set on the screen. Used to test all the set parameters, providing a more accurate and reliable first article inspection.

  • Learn Using Values on Screen - Used to enter the nominal values of the feature and have the software measure at that location. (Enables the Start Side Offsets, End Side Offsets and First Side to Second Side is Clockwise options in the Properties area and disables the Search Distance option in the Motion Parameters area when selected.)

Parameters Area

  • Nominal (XY Nominal) - Defines the nominal position of the corner.

  • Measured (XY Measured) - Shows the measured position of the corner.

  • Start Angle - Defines the angle of the starting side of the corner. This is the side's direction in relation to the primary axis. The primary axis is X in the XY work face, Y in the YZ work face, and Z in the ZX work face.

  • Included Angle - Defines the angle between both sides of the corner.

3 Axes Reporting Area

3 Axes reporting can be used to define the XYZ point in three ways.

  • Select a measured point or plane to define the height of the measured feature.

  • Enter the directional height of the plane to use. This height is relative to the part origin and measured along the probe vector.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

  1. Position the probe next to first point on the first side of the corner and press the Read Position soft key [image].

  2. Position the probe next to second point on the first side of the corner and press the Read Position soft key [image].

  3. Position the probe next to first point on the second side of the corner and press the Read Position soft key [image].

  4. Position the probe next to second point on the second side of the corner and press the Read Position soft key [image].

  5. Position the probe for automatic measurement and press the Learning and Creating a Command [image]. NC Gage automatically takes hits in a similar fashion as depicted below.

Outside Corner Path: A-D) Jog positions 1-4) automatically measured point positions. Red lines show the measuring path.

  6. Once the feature has been measured, the measured values are updated. Press the Confirm and Append Current Command to End soft key [image]. The feature command is added to the measurement routine. Press the Return soft key [image] to return to the previous screen without saving.

The following is the specific feature path and logic built into NC Gage built into NC Gage:

Learn Outside Corner Feature Path

  • Read position of probe next to first point of first side of corner. All measurements will be taken at level of this point.

  • Read position of probe next to second point of first side of corner.

  • Read position of probe next to first point of second side of corner.

  • Read position of probe next to second point of second side of corner.

  • Determine first and second direction vectors and normal vectors.

  • Compensate points.

  • Determine approximate corner point.

  • Move to clearance plane height.

  • Position probe above first read point position.

  • Drop down to measure height.

  • Measure toward first side surface, depth matches first point of second side.

  • Position probe approximately to second read point.

  • Measure toward first side surface, depth matches first point of second side.

  • Move to point beyond corner to avoid collision.

  • Position probe approximately to third read point.

  • Measure toward second side surface, depth matches first point of first side.

  • Position probe approximately to fourth read point.

  • Measure toward second side surface, depth matches first point of first side.

Execute Outside Corner Feature Path

  • If probe is below clearance plane height, move up to clearance plane height.

  • Move to position above first prehit point.

  • Drop down to measure height

  • Measure toward first side surface, depth matches first point of second side.

  • Position probe to second prehit point.

  • Measure toward first side surface, depth matches first point of second side.

  • Move to point beyond corner to avoid collision.

  • Position probe to third prehit point.

  • Measure toward second side surface, depth matches first point of first side.

  • Position probe to fourth read point.

  • If local clearance plane is enabled move to the local clearance plane between each point to get to next prehit point.

  • Measure toward second side surface depth matches first point of first side.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Corner (Inside)

Home > Using PC-DMIS NC Gage > Creating Feature Commands > Corner (Inside)

Measure Corner (Inside)

To create a Corner (Inside) command:

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Corner (Inside) soft key [image] to display the Measure Inside Corner screen:

  3. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It displays a graphical view of where to position the probe for measurements and changes when multiple steps are required.

Properties Area

The following three properties are only visible when the Learn Using Values on Screen check box in the Optional Settings area is selected:

  • Start Side Offsets - These are the distances of the first and second points respectively from the corner nominal location along the first side, which is located at the start angle direction.

  • End Side Offsets - These are the distances of the first and second points respectively from the corner nominal location along the second side.

  • First Side to Second Side is Clockwise - By default, NC Gage expects that the second side is located counterclockwise from the first. Selecting this option identifies that the second side is located clockwise with respect to the first.

Motion Parameters Area

  • Prehit Distance - Defines the distance away from the nominal surface that the probe uses to begin seeking the surface during the measurement process.

  • Search Distance - Defines the distance the probe will travel while seeking the surface during learn mode. (Not available if Learn Using Values on Screen described in "Optional Settings Area"is selected.)

Optional Settings Area

  • Hit Clearance Plane - Selecting this option causes the probe to move to a clearance plane between each hit of the feature. The edit box to the right will allow you to enter the distance to the plane. This plane is not the measurement routine clearance plane. See Hit Clearance Plane for details.

  • Learn then Measure - Selecting this option causes the machine to learn the location of the part using default parameters and then immediately re-measure the feature with the properties as set on the screen. Used to test all the set parameters, providing a more accurate and reliable first article inspection.

  • Learn Using Values on Screen - This allows you to enter the nominal values of the feature and have the software measure at that location. (Enables the Start Side Offsets, End Side Offsets and First Side to Second Side is Clockwise options in the Properties area and disables the Search Distance option in the Motion Parameters area when selected.)

Parameters Area

  • XYZ Nominal - Defines the nominal position of the corner.

  • XYZ Measured - Shows the measured position of the corner.

  • Start Angle - Defines the angle of the starting side of the corner. This is the side's direction in relation to the X-axis.

  • Included Angle - Defines the angle between both sides of the corner.

3 Axes Reporting Area

3 Axes reporting can be used to define the XYZ point in three ways.

  • Select a measured point or plane to define the height of the measured feature.

  • Enter the directional height of the plane to use. This height is relative to the part origin and measured along the probe vector.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

  1. Position the probe next to first point on the first side of the corner and press the Read Position soft key [image].

  2. Position the probe next to second point on the first side of the corner and press the Read Position soft key [image].

  3. Position the probe next to first point on the second side of the corner and press the Read Position soft key [image].

  4. Position the probe next to second point on the second side of the corner and press the Read Position soft key [image].

  5. Position the probe for automatic measurement and press the Learning and Creating a Command soft key [image]. NC Gage automatically takes hits in a similar fashion as depicted below.

Inside Corner Path: A-E) jog positions 1-5) automatically measured point positions. Red lines show the measuring path.

  6. Once the feature has been measured, the measured values are updated. Press the Confirm and Append Current Command to End soft key [image]. The feature command is added to the measurement routine.

The following is the specific feature path and logic built into NC Gage built into NC Gage:

Learn Inside Corner Feature Path

  • Read position of probe next to first point of first side of corner. All measurements are taken at the same level as this point.

  • Read position of probe next to second point of first side of corner.

  • Read position of probe next to first point of second side of corner.

  • Read position of probe next to second point of second side of corner.

  • Determine first and second direction vectors and normal vectors.

  • Compensate points.

  • Determine approximate corner point.

  • If probe is below clearance plane height, move to clearance plane height

  • Position probe to point above first read point position.

  • Drop to measurement height

  • Measure toward first side surface, search distance is 4* prehit distance.

  • Position probe approximately to second read point.

  • Measure toward first side surface, search distance is 4* prehit distance.

  • Position probe approximately to third read point.

  • Measure toward second side surface, search distance is 4* prehit distance.

  • Position probe approximately to fourth read point.

  • Measure toward second side surface, search distance is 4* prehit distance.

  • Move to clearance plane height.

Execute Inside Corner Feature Path

  • If probe is below clearance plane height, move to clearance plane height

  • Position probe to point above first prehit point position.

  • Drop to measurement height

  • Measure toward first side surface, search distance is 2* prehit distance.

  • Position probe approximately to second read point.

  • Measure toward first side surface, search distance is 2* prehit distance.

  • Position probe approximately to third read point.

  • Measure toward second side surface, search distance is 2* prehit distance.

  • Position probe approximately to fourth read point.

  • Measure toward second side surface, search distance is 2* prehit distance.

  • If local clearance plane is enabled move to the local clearance plane between each point to get to next prehit point.

  • Move to clearance plane height.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Plane

Home > Using PC-DMIS NC Gage > Creating Feature Commands > Plane

Measure Plane

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] to get to the second page of soft keys.

  3. Press the Plane soft key [image] to display the Measure Plane screen:

  4. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It displays a graphical view of where to position the probe for measurements and changes when multiple steps are required.

Properties Area

The following two properties are only available when the Grid Pattern option is selected in the Measure Method area.

  • Number of Rows - Defines the number of rows that will be probed for the plane.

  • Points Per Row - Provides the number of points that will be measured in a row.

The following property is only available when the Circular Pattern option is selected in the Measure Method area.

  • Number of Points - Defines the number of points around the circular pattern used to probe for the plane.

The following property is only available when the Learn Using Values on Screen check box is selected in the Optional Settings area and the Circular Pattern option is selected in the Measure Method area.

  • Diameter - Defines the diameter of the circular pattern for the measuring method.

The following two properties are only available when the Learn Using Values on Screen check box in the Optional Settings area is selected and Grid Pattern is selected in the Measure Method area.

  • Length - This is the distance along the primary axis from the first point to the last point. The primary axis is X in the XY work face, Y in the YZ work face, and Z in the ZX work face.

  • Width - This is the distance along the secondary axis from the first point to the last point. The secondary axis is Y in the XY work face, Z in the YZ work face, and X in the ZX work face.

The number of rows and points per row will be equally spaced along the defined plane area.

Motion Parameters Area

  • Prehit Distance - Defines the distance away from the nominal surface that the probe uses to begin seeking the surface during the measurement process.

  • Search Distance - Defines the search distance when finding and learning a feature. (Not available if Learn Using Values on Screen described in "Optional Settings Area" is selected.)

Optional Settings Area

  • Hit Clearance Plane - Selecting this option causes the probe to move to a clearance plane between each hit of the feature. The edit box to the right enters the distance to the plane. This plane is not the measurement routine clearance plane. See Hit Clearance Plane for details.

  • Learn then Measure - Selecting this option causes the machine to learn the location of the part using default parameters and then immediately re-measure the feature with the properties as set on the screen. Used to test all the set parameters, providing a more accurate and reliable first article inspection.

  • Learn Using Values on Screen - Enables you to enter the nominal values of the feature and have the software measure at that location. (This option enables or disables other options in the Properties and Motion Parameters areas depending on the selection made in the Measure Method area.)

Parameters Area

  • Nominal (XYZ Nominal) - Defines the nominal position of the Plane.

  • Measured (XYZ Measured) - Displays the measured position of the Plane.

  • Angle to Z - Defines the first vector angle in the Z direction of the plane. This is the plane's surface normal direction in relation to the work face. The valid range is -90 degrees to +90 degrees.

  • Angle to X - Defines the vector angle in the X direction of the plane. This is the plane's surface normal direction in relation to the primary axis that it is measured in. The primary axis is X in the XY work face, Y in the YZ work face, and Z in the ZX work face. The valid range is 0 (zero) degrees to -360 degrees.

Angle to Z and Angle to X are related - an invalid value of (90.0, 20.0) will be defined as (90.0, 0.0).

Measure Method Area

The options in the Properties area are enabled or disabled depending on the selection made. See "Properties Area" for details.

  • Grid Pattern - Defines a grid pattern to use when measuring the plane.

  • Circular Pattern - Defines a circular pattern to use when measuring the plane.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Process to learn a plane with work face defined normal using the Grid Pattern option:

  1. Select Grid Pattern from the Measure Method area of the Measure Plane screen.

  2. Press the Select Measurement Face soft key [image] until the desired work face is set for the plane to be defined (Top, Left, Right, Front, Back, or Skew). If Skew is selected, the Select Measurement Face soft key changes to the Skew soft key [image]. For details, see "Process to learn a plane with Skewed work face defined normal using the Grid Pattern option".

The selected work face must be the same as plane normal.

  3. Two points in the grid will be learned by jogging the probe to the appropriate location of the selected work face. Position the probe above the surface where you want to measure the plane. This indicates the first corner of the plane.

  4. Press the Read Probe Position soft key [image]. The tip position's values are read as coordinates for the first corner of the grid pattern on the plane feature. Press the Return to Previous Step soft key [image] to cancel this measure position.

  5. Position the probe above the second corner of the grid pattern.

  6. Press the Read Probe Position soft key [image]. The tip's X/Y position is read as the second corner coordinates. Press the Return to Previous Step soft key [image] to cancel this measure position. A rectangular area in the selected work face will be recorded with the learned points in machine coordinates defining the probing area.

  7. Press the Learning and Creating a Command soft key [image] and run the monitor program in CNC. Four points will be probed automatically in the grid corner locations defined. The following shows the -Y work face selected, the two probed points at the yellow P1 and P2 positions and the probing path in red:

    Defining a plane using two jog positions (P1, P2), non-skewed work face and grid pattern

Once the feature has been learned and measured, the measured values are updated and measuring will occur along the actual plane normal.

  8. Press the Confirm and Append Current Command to End soft key [image]. The feature command is added to the measurement routine.

Process to learn a plane with Skewed work face defined normal using the Grid Pattern option

  1. Select Grid Pattern from the Measure Method area of the Measure Plane screen.

  2. Press the Select Measurement Face soft key [image] until it changes to the Skewed icon [image].

  3. Three points in the grid will be learned by jogging the probe to the appropriate location of the selected work face. Position the probe above the first corner of the grid. This indicates the first corner of the plane. Press the Read Probe Position soft key [image].

  4. Position the probe above the second corner of the grid, indicating the second corner of the grid and then press the Read Probe Position soft key [image].

  5. Position the probe above the opposite corner of the grid and then press the Read Probe Position soft key [image].

  6. A rectangle area on the surface will be recorded with the learned points defining the area to be probed. Press the Learning and Creating a Command soft key [image] and run the monitor program in CNC. Four points will be probed automatically in the grid corner locations defined as shown below with the three probed points at the yellow P1, P2 and P3 positions and the probing path in red:

Defining a plane using three jog positions (P1, P2, P3), a skewed work face and grid pattern.

The nominal values for the center, normal and probing area will be updated after the probing is done. Once the plane has been learned, the measuring will be along the actual plane normal.

  7. Press the Confirm and Append Current Command to End soft key [image]. The feature command is added to the measurement routine.

Process to learn a plane with work face defined normal using the Circular Pattern option

  1. Select Circular Pattern from the Measure Method area on the Measure Plane screen.

  2. Press the Select Measurement Face soft key [image] until the desired work face is set for the plane to be defined (Top, Left, Right Front, Back or Skew). If Skew is selected, the Select Measurement Face soft key changes to the Skew soft key [image]. See "Process to learn a plane with Skewed work face defined normal using the Circular Pattern option" for details.

The selected work face must be the same as plane normal.

  3. Two points in the circle will be learned by jogging the probe to the appropriate location of the selected work face. Position the probe above the surface where you want to measure the circle. This indicates the first point of the circle's diameter.

  4. Press the Read Probe Position soft key [image]. The tip position's values are read as coordinates for the first side of the circular pattern on the plane feature. Press the Return to Previous Step soft key [image] to cancel this measure position.

  5. Position the probe above the opposite point of the circle. Press the Read Probe Position soft key [image]. A circle area on the work face will be recorded with the learned points in machine coordinates defining the probing area. Press the Return to Previous Step soft key [image] to cancel this measure position.

  6. Press the Learning and Creating a Command soft key [image] and run the monitor program in CNC. With these two points defined indicating the limits of the circle feature, NC Gage will automatically probe within the circle as shown below using the -Y work face selected, the two probed points at the yellow P1 and P2 positions and the probing path in red:

    Defining a plane using two jog positions (P1, P2), non-skewed work face and circle pattern

The nominal values of the center, normal and probing area will be updated after the probing is done. Once the feature has been measured, the measured values will be updated. All measuring will now be done along the actual plane normal.

  7. Press the Confirm and Append Current Command to End soft key [image]. The feature command is added to the measurement routine.

Process to learn a plane with Skewed work face defined normal using the Circle Pattern option

  1. Select Circular Pattern from the Measure Method area on the Measure Plane screen.

  2. Press the Select Measurement Face soft key [image] until it changes to the Skewed icon [image].

  3. Three points in the circle will be learned by jogging the probe to the appropriate location of the selected work face. Position the probe above the first point of the circle. Press the Read Probe Position soft key [image].

  4. Position the probe above the second point of the circle. Press the Read Probe Position soft key [image].

  5. Position the probe above the opposite point of the circle. Press the Read Probe Position soft key [image]. A circle area in the surface will be recorded with the learned points defining the probing area.

  6. Press the Learning and Creating a Command soft key [image] and run the monitor program in CNC. With these three points defined indicating the limits of the circle feature, NC Gage will automatically probe within the circle as shown below using the three probed points at the yellow P1, P2 and P3 positions and the probing path in red:

Defining a plane using three jog positions (P1, P2, P3), a skewed work face and circular pattern.

The nominal values for the center, normal and probing area will be updated after the probing is done. Once the plane has been learned, the measuring will be along the actual plane normal.

  7. Press the Confirm and Append Current Command to End soft key [image]. The feature command is added to the measurement routine.

Specific Feature Path and Logic Built into NC Gage

Learn Plane Feature Path (Grid Pattern)

  • Read position of probe above first corner of plane grid. This defines height of learn prehit points.

  • Read position of probe above second corner of plane grid.

  • If probe is below clearance plane height, move up to clearance plane height.

  • Move to point above first read point.

  • Drop to first read point.

  • Measure surface, search distance is 4*prehit distance.

  • Measure each point in gird, alternating directions for each line of grid.

  • Move up to clearance plane height.

Learn Plane Feature Path (Circle Pattern)

  • Read position of probe above first side of the plane circle. This defines height of learn prehit points.

  • Read position of probe above opposite point of the circular pattern.

  • If probe is below clearance plane height, move up to clearance plane height.

  • Move to point above first read point.

  • Drop to first read point.

  • Measure surface, search distance is 4*prehit distance.

  • Measure each point in the circular pattern.

  • Move up to clearance plane height.

Execute Plane Feature Path (Grid Pattern)

  • If probe is below clearance plane height, move up to clearance plane height.

  • Move to point above first point of grid.

  • Drop to prehit distance above nominal plane.

  • Measure surface, search distance is 2* prehit distance.

  • Measure each point in gird, alternating directions for each line of grid.

  • If local clearance plane is enabled, move to the local clearance plane between each point to get to next prehit point.

  • Move up to clearance plane height.

Execute Plane Feature Path (Circle Pattern)

  • If probe is below clearance plane height, move up to clearance plane height.

  • Move to point above first point of the circle.

  • Drop to prehit distance above nominal plane.

  • Measure surface, search distance is 2* prehit distance.

  • Measure each point in the circle pattern in a counterclockwise direction.

  • If local clearance plane is enabled, move to the local clearance plane between each point to get to next prehit point.

  • Move up to clearance plane height.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Line

Home > Using PC-DMIS NC Gage > Creating Feature Commands > Line

Measure Line

To create a Line command:

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] to get to the second page of soft keys.

  3. Press the Line soft key [image] to display the Measure Line screen:

  4. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It displays a graphical view of where to position the probe for measurements and changes when multiple steps are required.

Properties Definition Area

  • Number of Points - Defines the number of points to be probed for the line during execution.

The following two properties are only visible when the Learn Using Values on Screen check box in the Optional Settings area is selected:

  • Length - Defines the length of the line.

  • Measure "Right" Side - When selected, the Measure "Right" Side setting of the line determines which direction to probe by defining which side of the line is the material side. If this box is checked, the material should be on the "right" side of the line when moving from the first to the last measured points. If the material is on the "left" side of the line when moving from the first to last measured point, this box should be unchecked.

Motion Parameters Area

  • Prehit Distance - Defines the distance away from the nominal surface that the probe uses to begin seeking the surface during the measurement process.

  • Search Distance - Defines the distance the probe travels while seeking the surface during learn mode. (Not available if Learn Using Values on Screen described in "Optional Settings Area" is selected.)

Optional Settings Area

  • Hit Clearance Plane - Selecting this option causes the probe to move to a clearance plane between each hit of the feature. The edit box to the right enters the distance to the plane. This plane is not the measurement routine clearance plane. See Hit Clearance Plane for details.

  • Learn Then Measure - Selecting this option causes the machine to learn the location of the part using default parameters and then immediately re-measure the feature with the properties as set on the screen. Used to test all the set parameters, providing a more accurate and reliable first article inspection.

  • Learn Using Values on Screen - Enables you to enter the nominal values of the feature and have the software measure at that location. (This option enables additional properties described in "Properties Area" and disables the Search Distance option described in "Motion Parameters Area".)

Parameters Area

  • XYZ Nominal - Defines the nominal position of the start point.

  • XYZ Measured - Displays the measured position of the start point.

  • Angle to X - Defines the vector angle of the line. This is the line's direction in relation to the X-axis.

3 Axes Reporting Area

3 Axes reporting can be used to define the XYZ point in three ways.

  • Select a measured point or plane to define the height of the measured feature.

  • Enter the directional height of the plane to use. This height is relative to the part origin and measured along the probe vector.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

  1. Position the probe next to the line's first point, as indicated by position A in the image below.

  2. Press the Read Position soft key [image]. The tip position is read as the start position. Press theReturn to Previous Step soft key [image] to cancel this measure position.

  3. Position the probe next to the line's second point, as indicated by point B in the image below.

  4. Press the Read Position soft key [image]. The tip position is read as the start position. Press theReturn to Previous Step soft key [image] to cancel this measure position.

  5. Move the probe away from the second point.

  6. Press the Read Position soft key [image].

  7. Position the probe for automatic measurement, and press the Learning and Creating a Command soft key [image]. NC Gage automatically takes hits in a similar fashion as depicted below.

The left image indicates the jog positions (A-C) to which you should manually move the probe. The right image shows the automatic probing pathway (red lines) and point positions (1-2).

  8. Once the feature has been measured, the measured values are updated. Press the Confirm and Append Current Command to End soft key [image]. The feature command is added to the measurement routine.

Specific Feature Path and Logic Built into NC Gage

Learn Line Feature Path

  • Read position of probe next to first point, this defines measurement height.

  • Read position of probe above second point, this defines line direction.

  • Read position of probe pulled away from the line, this defines material direction.

  • If probe below clearance plane height, move up to clearance plane height.

  • Move to point above first read point.

  • Drop to first read point.

  • Measure surface, search distance is 4* prehit distance

  • Measure each point in line similarly.

  • Move up to clearance plane height.

Execute Line Feature Path

  • If probe below clearance plane height, move up to clearance plane height.

  • Move to point above first prehit point.

  • Drop to first prehit point.

  • Measure surface, search distance is 2* prehit distance

  • Measure each point in line similarly.

  • If local clearance plane is enabled move to the local clearance plane between each point to get to next prehit point.

  • Move up to clearance plane height.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Cylinder (Bore)

Home > Using PC-DMIS NC Gage > Creating Feature Commands > Cylinder (Bore)

Measure Cylinder (Bore)

To create a Cylinder (Bore) command:

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] to get to the second page of soft keys.

  3. Press the Cylinder (Bore) soft key [image] to display the Measure Cylinder (Bore) screen:

  4. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It displays a graphical view of where to position the probe for measurements and changes when multiple steps are required.

Properties Area

  • Points per Level - Defines the number of points per level to be probed for the cylinder during execution (not learn mode).

  • Number of Levels - Defines the number of points to be measured in a level during execution (not learn mode).

  • Start Angle - Defines the starting point for a section of the cylinder to measure. Rotation starts at 0 along the primary axis and grows such that 90 is at the secondary axis. The primary axis is X in the XY work face, Y in the YZ work face, and Z in the ZX work face. The secondary axis is Y in the XY work face, Z in the YZ work face, and Z in the ZX work face.

  • End Angle - Defines the end of the section of the cylinder to be measured. The start and end angles are only used when the featured is measured in execute mode. Learn mode automatically takes hits in opposing primary and secondary axes directions. If the cylinder does not continue around for 360 degrees, then Learn Using Values on Screen could be used to enter the nominal location with a proper start and end angle defined. Then, with Learn then Measure selected, NC Gage measures the feature.

The following two properties are only available when the Learn Using Values on Screen check box in the Optional Settings area is selected.

  • Top Height - This is the axis location of the hits at the top of the cylinder measurement. This is relative to the current work offset along the axis most closely aligned with the center line of the cylinder.

  • Bottom Height - This is the axis location of the hits at the bottom of the cylinder measurement. This is relative to the current work offset along the axis most closely aligned with the center line of the cylinder.

The number of rows and points per row will be equally spaced along the defined cylinder.

Motion Parameters Area

  • Prehit Distance - Defines the distance away from the nominal surface that the probe uses to begin seeking the surface during the measurement process.

  • Search Distance - Defines the distance that the probe uses to seek for the part during learn mode. (Not available if the Learn Using Values on Screen option described in "Optional Settings Area" is selected.)

Optional Settings Area

  • Hit Clearance Plane - Selecting this option causes the probe to move to a clearance plane between each hit of the feature. The edit box to the right enters the distance to the plane. This plane is not the measurement routine clearance plane. See Hit Clearance Plane for details.

  • Learn then Measure - Selecting this option causes the machine to learn the location of the part using default parameters and then immediately re-measure the feature with the properties as set on the screen. Used to test all the set parameters, providing a more accurate and reliable first article inspection.

  • Learn Using Values on Screen - Used to enter the nominal values of the feature and have the software measure at that location. (Selecting this option enables additional properties described in "Properties Area" and disables the Search Distance option described in "Motion Parameters Area".)

Parameters Area

  • XYZ Nominal - Defines the nominal position of the cylinder.

  • XYZ Measured - Displays the measured position of the cylinder.

  • Diameter (Nominal) - Defines the nominal diameter of the cylinder.

  • Diameter (Measured) - Displays the measured diameter of the cylinder.

  • Angle to Z - Defines the first vector angle of the cylinder. This is the cylinder's center line direction in relation to the work face. The valid range is -90 degrees to +90 degrees.

  • Angle to X - Defines the second vector angle of the cylinder. This is the cylinder's center line direction in relation to the primary axis it is measured in. The primary axis is X in the XY work face, Y in the YZ work face, and Z in the ZX work face. The valid range is 0 (zero) degrees to -360 degrees.

Angle to Z and Angle to X are related - an invalid value of (90.0, 20.0) will be defined as (90.0, 0.0).

3 Axes Reporting Area

3 Axes Reporting can be used to define the XYZ point in three ways.

  • Select a measured point or plane to define the height of the measured feature.

  • Type in the directional height of the plane to use. This height is relative to the part origin and measured along the probe vector.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

Two Points for Small-Diameter Cylinder

  1. Position the probe down into the cylinder (away from the work face) at the center of the top level as indicated by A in the image below.

  2. Press the Read Position soft key [image].

  3. Position the probe at the center of the bottom level and press the Read Position soft key [image].

  4. Press the Learning and Creating a Command soft key [image]. NC Gage automatically takes hits in a similar fashion as depicted below.

Cylinder Bore Path: A-B) jog positions 1-4) automatically measured point positions. Red lines show the measuring path.

  5. Once you have measured the feature, NC Gage updates the measured values. Press the Confirm and Append Current Command to End soft key [image]. The feature command adds to the measurement routine.

Three Points for Large-Diameter Cylinder

  1. Position the probe at the center of the top level, and press the Read Position soft key [image].

  2. Position the probe down into the cylinder (away from the work face) at the center of the bottom level as indicated by B in the image below.

  3. Press the Read Position soft key [image].

  4. Position the probe to the side of the bottom level, and press the Read Position soft key [image].

  5. Press the Learning and Creating a Command soft key [image]. NC Gage automatically takes hits in a similar fashion as depicted below.

Cylinder Bore Path: A-C) jog positions 1-3) automatically measured point positions. Red lines show the measuring path.

  6. Once you have measured the feature, NC Gage updates the measured values. Press the Confirm and Append Current Command to End soft key [image]. The feature command adds to the measurement routine.

Specific Feature Path and Logic Built into NC Gage

Learn Cylinder Bore Feature Path for Small-Diameter Cylinder

  • Read position of probe in center of the bore upper level. This defines last level height for execution time.

  • Read position of probe in center of the bore lower level. This defines bore center and first level height for execution time. This height is used for learning cylinder bore.

  • Measure point in +X direction using search distance.

  • Return to center position.

  • Measure point in –X direction using search distance.

  • Return to center position.

  • Measure point in +Y direction using search distance.

  • Return to center position.

  • Measure point in –Y direction using search distance.

  • Return to center position.

Learn Cylinder Bore Feature Path for Large-Diameter Cylinder

  • Read position of probe in center of the bore upper level, this defines last level height for execution time.

  • Read position of probe in center of the bore lower level, this defines bore center and first level height for execution time. This height is used for learning cylinder bore.

  • Read position of probe in the side of the bore lower level.

  • Measure point at the lower level center position to the side position direction using search distance.

  • Return to side position.

  • Measure point perpendicular to the lower level center position to the side position direction using search distance.

  • Return to side position.

  • Measure another point perpendicular to the lower level center position to the side position direction using search distance.

  • Return to side position.

Execute Cylinder Bore Feature Path

  • Define prehit radius = Bore Radius - prehit distance – probe radius.

  • Define target radius = Bore Radius + prehit distance – probe radius.

  • If current position is lower than the clearance plane height then move up to clearance plane.

  • Move to position above first prehit point. This point is a distance of prehit radius from bore center in the direction of the start angle.

  • Drop down to the lowest measurement level.

  • Measure point, target is target radius from bore center along angle.

  • Retract and move to prehit of next point.

  • Measure point, target is target radius from bore center along angle.

  • Continue from start angle to end angle measuring specified number of points.

  • Measure the other level(s), measuring points in alternating directions.

  • If local clearance plane is enabled move to the local clearance plane between each point to get to next prehit point.

  • After last point is measured, the probe moves up to the clearance plane height.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Cylinder (Boss)

Home > Using PC-DMIS NC Gage > Creating Feature Commands > Cylinder (Boss)

Measure Cylinder (Boss)

To create a Cylinder (Boss) command:

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] to get to the second page of soft keys.

  3. Press the Cylinder (Boss) soft key [image] to display the Measure Cylinder (Boss) screen:

  4. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It displays a graphical view of where to position the probe for measurements and changes when multiple steps are required.

Properties Area

  • Points per Level - Defines the number of points per level used to probe for the cylinder during execution (not learn mode).

  • Number of Levels - Defines the number of points used per level to measure during execution (not learn mode).

  • Start Angle - Defines the starting point for a section of the cylinder to measure. Rotation starts at 0 along the primary axis and grows such that 90 is at the secondary axis. The primary axis is X in the XY work face, Y in the YZ work face, and Z in the ZX work face. The secondary axis is Y in the XY work face, Z in the YZ work face, and X in the ZX work face.

  • End Angle - Defines the end of the section of the cylinder to be measured. The start and end angles are only used when the featured is measured in execute mode. Learn mode automatically takes hits in opposing primary and secondary axes directions. If the cylinder does not continue around for 360 degrees, then Learn Using Values on Screen could be used to enter the nominal location with a proper start and end angle defined. Then, with Learn then Measure selected, NC Gage measures the feature.

The following two properties are only available when the Learn Using Values on Screen check box in the Optional Settings area is selected.

  • Top Height - Used to define the axis location of the hits at the top of the cylinder measurement. This is relative to the current work offset along the axis most closely aligned with the center line of the cylinder.

  • Bottom Height - Used to define the axis location of the hits at the bottom of the cylinder measurement. This is relative to the current work offset along the axis most closely aligned with the center line of the cylinder.

The number of rows and points per row will be equally spaced along the defined cylinder.

Motion Parameters Area

  • Prehit Distance - Defines the distance away from the nominal surface that the probe uses to begin seeking the surface during the measurement process.

  • Search Distance - Defines the distance that the probe uses to seek for the part during learn mode. (Not available if Learn Using Values on Screen described in "Optional Settings Area" is selected.)

Optional Settings Area

  • Hit Clearance Plane - Selecting this option causes the probe to move to a clearance plane between each hit of the feature. The edit box to the right enters the distance to the plane. This plane is not the measurement routine clearance plane. See Hit Clearance Plane for details.

  • Learn then Measure - Selecting this option causes the machine to learn the location of the part using default parameters and then immediately re-measure the feature with the properties as set on the screen. Used to test all the set parameters, providing a more accurate and reliable first article inspection.

  • Learn Using Values on Screen - Enter the nominal values of the feature and have the software measure at that location. (Selecting this option enables additional properties described in "Properties Area" and disables the Search Distance option described in "Motion Parameters Area".)

Parameters Area

  • XYZ Nominal - Defines the nominal position of the cylinder.

  • XYZ Measured - Displays the measured position of the cylinder.

  • Diameter (Nominal) - Defines the nominal diameter of the cylinder.

  • Diameter (Measured) - Displays the measured diameter of the cylinder.

  • Angle to Z - Defines the first vector angle of the cylinder. This is the cylinder's center line direction in relation to the work face. The valid range is -90 degrees to +90 degrees.

  • Angle to X - Defines the second vector angle of the cylinder. This is the cylinder's center line direction in relation to the primary axis it is measured in. The primary axis is X in the XY work face, Y in the YZ work face, and Z in the ZX work face. The valid range is 0 (zero) degrees to -360 degrees.

Angle to Z and Angle to X are related - an invalid value of (90.0, 20.0) will be defined as (90.0, 0.0).

3 Axes Reporting Area

3 Axes Reporting can be used to define the XYZ point in three ways.

  • Select a measured point or plane to define the height of the measured feature.

  • Enter the directional height of the plane to use. This height is relative to the part origin and measured along the probe vector.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

  1. Position the probe near the surface on the bottom level and press the Read Position soft key [image]. This will be the location for the "bottom" level.

  2. Position the probe near the surface on the top level and press the Read Position soft key [image]. This will be the location for the "top" level.

  3. Position the probe at safe height above the center of boss and press the Read Position soft key [image].

  4. Press the Learning and Creating a Command soft key [image]. NC Gage takes one hit at this position to determine the height of the boss. It then automatically takes hits in a similar fashion as depicted below.

Cylinder Boss Path: A-B) manually measure positions C) Jog position 1-4) automatically measured point positions. Red lines show the path for the bottom level. The top level is measured using similar path lines.

  5. Once the feature has been measured, the measured values are updated. Press the Confirm and Append Current Command to End soft key [image]. The feature command is added to the measurement routine.

The following is the specific feature path and logic built into NC Gage built into NC Gage:

Learn Cylinder Boss Feature Path

  • Read position of probe next to side of boss at lowest level, Z value will be measurement height of first level.

  • Read position of probe next to side of boss at highest level, Z value will be measurement height of last level. This height is also used to learn the cylinder.

  • Read position of probe above center of boss, XY define center, Z is safe height.

  • Prehit radius = projected 2D distance between first and third read position points.

  • Move to safe height.

  • Move at safe height to a point above prehit point 1, which is prehit radius from center in +X.

  • Drop to measurement height.

  • Measure point, target is center at measurement height.

  • Move to safe height.

  • Move at safe height to a point above prehit point 2, which is prehit radius from center in -X.

  • Drop to measurement height.

  • Measure point, target is center at measurement height.

  • Move to safe height.

  • Move at safe height to a point above prehit point 3, which is prehit radius from center in +Y.

  • Drop to measurement height.

  • Measure point, target is center at measurement height.

  • Move to safe height.

  • Move at safe height to a point above prehit point 4, which is prehit radius from center in -Y.

  • Drop to measurement height.

  • Measure point, target is center at measurement height.

  • Move to safe height.

Execute Cylinder Boss Feature Path

  • Define prehit radius = Boss Radius + prehit distance + probe radius.

  • Define target radius = Boss Radius - prehit distance – probe radius, if this is < 0, set to 0.

  • If current position is lower than the clearance plane height then move up to clearance plane.

  • Move to position above first prehit point. This point is a distance of prehit radius from boss center in the direction of the start angle.

  • Drop down to the measurement level.

  • Measure lowest level, using prehit radius and target radius. Use extra moves to get around boss if needed to get to each prehit point, continue until end angle is reached.

  • Measure the rest of the level(s) using alternating directions.

  • If local clearance plane is enabled move to the local clearance plane between each point to get to next prehit point.

  • After last point is measured, the probe moves up to the clearance plane height.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Cone (Inside)

Home > Using PC-DMIS NC Gage > Creating Feature Commands > Cone (Inside)

Measure Cone (Inside)

To create a Cone (Inside) command:

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] to get to the second page of soft keys.

  3. Press the Cone (Inside) soft key [image] to display the Measure Cone (Inside) screen:

  4. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It displays a graphical view of where to position the probe for measurements and changes when multiple steps are required.

Properties Area

  • Points per Level - Defines the number of points per level the probe uses for measuring the cone during execution (not learn mode).

  • Number of Levels - Defines the number of levels used to measure the cone during execution (not learn mode).

  • Start Angle - Defines the starting point for a section of the cone to be measured. Rotation starts at 0 along the primary axis and grows such that 90 is at the secondary axis. The primary axis is X in the XY work face, Y in the YZ work face, and Z in the ZX work face. The secondary axis is Y in the XY work face, Z in the YZ work face, and X in the ZX work face.

  • End Angle - Defines the end of the section of the cone to be measured. The start and end angles are only used when the featured is measured in execute mode. Learn mode automatically takes hits in opposing primary and secondary axes directions. If the cone does not continue around for 360 degrees, then Learn Using Values on Screen could be used to enter the nominal location with a proper start and end angle defined. Then, with Learn then Measure selected, NC Gage measures the feature.

The following two properties are only available when the Learn Using Values on Screen check box in the Optional Settings area is selected.

  • Top Height - The axis location of the hits at the top of the cone measurement. This is relative to the current work offset along the axis most closely aligned with the center line of the cone.

  • Bottom Height - The axis location of the hits at the bottom of the cone measurement. This is relative to the current work offset along the axis most closely aligned with the center line of the cone.

The number of rows and points per row will be equally spaced along the defined Cone.

Motion Parameters Area

  • Prehit Distance - Defines the distance away from the nominal surface that the probe uses to begin seeking the surface during the measurement process.

  • Search Distance - Defines the distance that the probe uses to seek for the part during learn mode. (Not available if the Learn Using Values on Screen option described in "Optional Settings Area"is selected.)

Optional Settings Area

  • Hit Clearance Plane - Selecting this option causes the probe to move to a clearance plane between each hit of the feature. The edit box to the right enters the distance to the plane. This plane is not the measurement routine clearance plane. See Hit Clearance Plane for details.

  • Learn Then Measure - Selecting this option causes the machine to learn the location of the part using default parameters and then immediately re-measure the feature with the properties as set on the screen. Used to test all the set parameters, providing a more accurate and reliable first article inspection.

  • Learn Using Values on Screen - Used to enter the nominal values of the feature and have the software measure at that location. (Selecting this option enables additional properties described in "Properties Area" and disables the Search Distance option described in "Motion Parameters Area".)

Parameters Area

  • Nominal (XYZ Nominal) - Defines the nominal position of the cone center.

  • Measured (XYZ Measured) - Displays the measured position of the cone.

  • Half Angle - Displays the angle that the side of the cone makes with the centerline of the cone.

  • Angle to Z - Defines the first vector angle of the cone. This is the cone's center line direction in relation to the work face. The valid range is -90 degrees to +90 degrees.

  • Angle to X - Defines the second vector angle of the cone. This is the cone's center line direction in relation to the primary axis it is measured in. The primary axis is X in the XY work face, Y in the YZ work face, and Z in the ZX work face. The valid range is 0 (zero) degrees to -360 degrees.

Vector Angle 1 and Vector Angle 2 are related - an invalid value of (90.0, 20.0) will be defined as (90.0, 0.0).

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

  1. Position the probe at the center of the bottom level and press the Read Position soft key [image]. The bottom level is the level closest to the apex.

  2. Position the probe at the center of the top level and press the Read Position soft key [image].

  3. Position the probe for automatic measurement, and press the Learning and Creating a Command soft key [image]. NC Gage automatically takes hits in a similar fashion as depicted below.

Inside Cone Path: A-B) jog positions 1-8) automatically measured point positions.

  4. Once the feature has been measured, the measured values are updated. Press the Confirm and Append Current Command to End soft key [image]. The feature command is added to the measurement routine.

The following is the specific feature path and logic built into NC Gage built into NC Gage:

Learn Inside Cone Feature Path

  • Read position of probe in center of cone lower level, this defines cone XY center and first level height for execution time.

  • Read position of probe in center of bore upper level, this defines last level height for execution time.

  • Move to first read point position.

  • Measure lowest level taking points in +X, -X, +Y, and –Y directions, returning to the lower center after each measurement.

  • Move to upper level center.

  • Measure upper level taking points in +X, -X, +Y, and –Y directions, returning to the upper center after each measurement.

Execute Inside Cone Feature Path

  • Cone geometry determines the prehit and target locations for each measured point.

  • If current position is lower than the clearance plane height then move up to clearance plane.

  • Move to position above first prehit point. This point is a distance of prehit radius from bore center in the direction of the start angle.

  • Drop down to the lowest measurement level.

  • Measure first level, start to end angle.

  • Measure the rest of the level(s) using alternating directions.

  • If local clearance plane is enabled move to the local clearance plane between each point to get to next prehit point.

  • After last point is measured, the probe moves up to the clearance plane height.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Cone (Outside)

Home > Using PC-DMIS NC Gage > Creating Feature Commands > Cone (Outside)

Measure Cone (Outside)

To create a Cone (Outside) command:

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] to get to the second page of soft keys.

  3. Press the Cone (Outside) soft key [image] to display the Measure Cone (Outside) screen:

  4. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It displays a graphical view of where to position the probe for measurements and changes when multiple steps are required.

Properties Area

  • Points per Level - Defines the number of points per level the probe uses for measuring the cone during execution (not learn mode).

  • Number of Levels - Defines the number of levels used to measure the cone during execution (not learn mode).

  • Start Angle - Defines the starting point for a section of the cone to measure. Rotation starts at 0 along the primary axis and grows such that 90 is at the secondary axis. The primary axis is X in the XY work face, Y in the YZ work face, and Z in the ZX work face. The secondary axis is Y in the XY work face, Z in the YZ work face, and X in the ZX work face.

  • End Angle - Defines the end of the section of the cone to be measured. The start and end angles are only used when the feature is measured in execute mode. Learn mode automatically takes hits in opposing primary and secondary axes directions. If the cone does not continue around for 360 degrees, then Learn Using Values on Screen could be used to enter the nominal location with a proper start and end angle defined. Then, with Learn then Measure selected, NC Gage measures the feature.

The following two properties are only available when the Learn Using Values on Screen check box in the Optional Settings area is selected.

  • Top Height - The axis location of the hits at the top of the cone measurement. This is relative to the current work offset along the axis most closely aligned with the center line of the cone.

  • Bottom Height - The axis location of the hits at the bottom of the cone measurement. This is relative to the current work offset along the axis most closely aligned with the center line of the cone.

The number of rows and points per row will be equally spaced along the defined cone.

Motion Parameters Area

  • Prehit Distance - Defines the distance away from the nominal surface that the probe uses to begin seeking the surface during the measurement process.

  • Search Distance - Defines the distance that the probe seeks for the part during learn mode. (Not available if the Learn Using Values on Screen option described in "Optional Settings Area" is selected.)

Optional Settings Area

  • Hit Clearance Plane - Selecting this option causes the probe to move to a clearance plane between each hit of the feature. The edit box to the right enters the distance to the plane. This plane is not the measurement routine clearance plane. See Hit Clearance Plane for details.

  • Learn Then Measure - Selecting this option causes the machine to learn the location of the part using default parameters and then immediately re-measure the feature with the properties as set on the screen. Used to test all the set parameters, providing a more accurate and reliable first article inspection.

  • Learn Using Values on Screen - Used to enter the nominal values of the feature and have the software measure at that location. (Selecting this option enables additional properties described in "Properties Area" and disables the Search Distance option described in "Motion Parameters Area".)

Parameters Area

  • XYZ Nominal - Defines the nominal position of the cone center.

  • XYZ Measured - Displays the measured position of the cone.

  • Half Angle - Defines the angle that the side of the cone makes with the centerline of the cone.

  • Angle to Z - Defines the first vector angle of the cone. This is the cone's center line direction in relation to the work face. The valid range is -90 degrees to +90 degrees.

  • Angle to X - Defines the second vector angle of the cone. This is the cone's center line direction in relation to the primary axis it is measured in. The primary axis is X in the XY work face, Y in the YZ work face, and Z in the ZX work face. The valid range is 0 (zero) degrees to -360 degrees.

Vector Angle 1 and Vector Angle 2 are related - an invalid value of (90.0, 20.0) will be defined as (90.0, 0.0).

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

  1. Position the probe near the surface at the bottom level and press the Read Position soft key [image]. The bottom level is the level furthest to the apex.

  2. Position the probe near the surface at the top level and press the Read Position soft key [image].

  3. Position the probe above the center and press the Read Position soft key [image].

  4. Position the probe for automatic measurement, and press the Learning and Creating a Command soft key [image]. NC Gage automatically takes hits in a similar fashion as depicted below.

Outside Cone Path: A-C) jog positions 1-8) automatically measured point positions. Red lines show the path for the bottom level. The top level is measured using similar path lines.

  5. Once the feature has been measured, the measured values are updated. Press the Confirm and Append Current Command to End soft key [image]. The feature command is added to the measurement routine.

The following is the specific feature path and logic built into NC Gage built into NC Gage:

Learn Outside Cone Feature Path

  • Read position of probe next to side of cone at lowest level, this defines cone XY center and first level height for execution time.

  • Read position of probe next to side of cone at highest level, Z value will be measurement height of last level.

  • Read position of probe above center of cone, XY define center, Z is safe height

  • Move to safe height.

  • Prehit radius = projected 2D distance between first and third read position points. This is used to learn both levels.

  • Measure lowest level taking points in +X, -X, +Y, and –Y directions, the probe is moved to the safe height between each measurement.

  • Return to safe height.

  • Measure highest level taking points in +X, -X, +Y, and –Y directions, the probe is moved to the safe height between each measurement.

  • Return to safe height.

Execute Outside Cone Feature Path

  • Cone geometry determines the prehit and target locations for each measured point.

  • If current position is lower than the clearance plane height then move up to clearance plane.

  • Move to position above first prehit point.

  • Drop down to the lowest measurement level.

  • Measure lowest level, start to end angle. Evasive moves between each points are used if needed to avoid collisions.

  • Measure the rest of the level(s) using alternating directions.

  • If local clearance plane is enabled move to the local clearance plane between each point to get to next prehit point.

  • After last point is measured, the probe moves up to clearance plane height.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Sphere

Home > Using PC-DMIS NC Gage > Creating Feature Commands > Sphere

Measure Sphere

To create a Sphere command:

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] to get to the second page of soft keys.

  3. Press the Sphere soft key [image] to display the Measure Sphere screen:

  4. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It displays a graphical view of where to position the probe for measurements and changes when multiple steps are required.

Properties Area

  • Number of Points - Defines the total number of points that will be measured.

  • Lower Level Angle - Defines the lower level angle of the sphere, the equator is 0 degrees.

  • Upper Level Angle - Defines the upper level angle of the sphere, the North Pole (top) is 90 degrees.

The difference between the lower level angle and the upper level angle must be at least 20 degrees. This is limited because less than 20 degrees of arc will likely result in inaccurate measurement results.

Motion Parameters Area

  • Prehit Distance - Defines the distance away from the nominal surface that the probe uses to begin seeking the surface during the measurement process.

  • Search Distance - Defines the search distance when finding and learning a feature. (Not available if the Learn Using Values on Screen option described in "Optional Settings Area" is selected.)

Optional Settings Area

  • Hit Clearance Plane - Selecting this option causes the probe to move to a clearance plane between each hit of the feature. The edit box to the right enters the distance to the plane. This plane is not the measurement routine clearance plane. See Hit Clearance Plane for details.

  • Learn then Measure - Selecting this option causes the machine to learn the location of the part using default parameters and then immediately re-measure the feature with the properties as set on the screen. Used to test all the set parameters, providing a more accurate and reliable first article inspection.

  • Learn Using Values on Screen - Used to enter the nominal values of the feature and have the software measure at that location. (Selecting this option disables the Search Distance option described in "Motion Parameters Area".)

Parameters Area

  • XYZ Nominal - Defines the nominal position of the center of the sphere.

  • XYZ Measured - Displays the measured position of the center of the sphere.

  • Diameter Nominal - Defines the nominal diameter of the sphere.

  • Diameter Measured - Displays the measured diameter of the sphere.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

  1. Position the probe above the sphere center top and press the Read Position soft key [image].

  2. Press the Learning and Creating a Command soft key [image]. NC Gage automatically takes hits in a fashion as depicted below.

    Sphere Path: A) jog position 1-4) automatically measured point positions

  3. Once the feature has been measured, the measured values are updated. Press the Confirm and Append Current Command to End soft key [image]. The feature command is added to the measurement routine.

The following is the specific feature path and logic built into NC Gage:

Learn Sphere Feature Path

  • Read position of probe, which should be above the top of the sphere.

  • Measure point straight down, using search distance.

  • Retract to original read position and move 2* probe radius in the +X direction.

  • Measure point straight down, using search distance.

  • Retract to original height and move 2* probe radius in direction, which is 120 degrees from +X axis.

  • Measure point straight down, using search distance.

  • Retract to original height and move 2* probe radius in direction, which is 240 degrees from +X axis.

  • Measure point straight down, using search distance.

  • Retract to original height.

Execute Sphere Feature Path

  • Number of levels and points for each level are determined based on the number of points to measure , which is defined on the form.

  • If current position is lower than the clearance plane height then move up to clearance plane.

  • Move to position above the first prehit point.

  • Drop down to lowest level and measure that level, if needed evasive moves are added between each point in a level to avoid collisions.

  • Measure the rest of the level(s) using alternating directions.

  • Measure point on top of sphere (if upper level angle is 90).

  • Move to clearance plane height.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Construct Point

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] until the page with the Construct Point soft key appears.

  3. Press the Construct a Point soft key [image] to display the Construct Point screen:

This screen lets you create a point feature by doing one of the following:

  • Constructing a point at the intersection of two selected line type features by selecting the Intersection option.

  • Constructing a point by projecting a point type feature onto a line type feature by selecting the Projection option.

  • Constructing a point midway between two selected point type features by selecting the Midpoint option.

To Construct a Point Feature

  1. From the Option area, select the appropriate option button for the type of construction to be made.

  2. Select the two features from the lines selection lists. Only valid feature types appear in the selection lists. The graphics in the upper-left corner of the screen update to provide a visual cue as to how the feature will be built. The nominal and measured data update according to the feature inputs.

  3. Press the Confirm soft key [image] to add the command to the measurement routine.

Valid Point Type Features

  • Constructed Circle

  • Constructed Point

  • Measured Circle Bore

  • Measured Circle Boss

  • Measured Corner Inside

  • Measured Corner Outside

  • Measured Point

  • Measured Sphere

Valid Line Type Features

  • Constructed Line

  • Measured Cone (Inside)

  • Measured Cone (Outside)

  • Measured Cylinder Bore

  • Measured Cylinder Boss

  • Measured Line

  • Measured Plane

  • Measured Pocket

  • Measured Web

Nominal and actual Z values are automatically assigned to the constructed feature. The nominal and actual Z value will be taken from the first component feature of the construction.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Construct Line

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] until the page with the Construct Line soft key appears.

  3. Press the Construct Line soft key [image] to display the Construct Line screen:

Parameters Area

  • XYZ Nominal - Defines the nominal position of the start point.

  • XYZ Measured - Displays the measured position of the start point.

  • Angle to X - Defines the first vector angle of the plane - X in this example. This is the plane's surface normal direction in relation to the work face. The valid range is -90 degrees to +90 degrees.

  • Angle to Z - Defines the second vector angle of the plane - Z in this example. This is the plane's surface normal direction in relation to the primary axis that it is measured in. The primary axis is X in the XY work face, Y in the YZ work face, and Z in the ZX work face. The valid range is 0 (zero) degrees to -360 degrees.

The vector angles (Vector Angle to X and vector Angle to Z in this example) are related - an invalid value of (90.0, 20.0) will be defined as (90.0, 0.0).

To Construct a Line Feature

  1. Select the two point type features. Only valid feature types appear in the feature lists. The graphics in the upper-left corner of the screen update to provide a visual cue as to how the feature will be built. The nominal and measured data update according to the feature inputs.

  2. Press the Confirm soft key to add the command to the measurement routine.

Valid Point Type Features

  • Constructed Circle

  • Constructed Point

  • Measured Circle Bore

  • Measured Circle Boss

  • Measured Corner Inside

  • Measured Corner Outside

  • Measured Point

  • Measured Sphere

Nominal and actual Z values are automatically assigned to the constructed feature. The nominal and actual Z value will be taken from the first component feature of the construction.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Construct Circle

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] until the Construct Circle soft key appears.

  3. Press the Construct a Circle soft key [image] to display the Construct Circle screen:

The Construct Circle option, located on the third screen of the feature menu, lets you create a circle where the circumference intersects three point type features.

To Construct a Circle Feature

  1. Select the first feature from the Point Features list to use in the construction.

  2. Press the Move Item Left double arrow soft key [image] to add that feature to the Selected Features list.

  3. Repeat this process for at least two other point type features (a minimum of three total point type features need to be selected). If you need to remove features from the selected features list, select the feature to be removed and use the Move Item Right double arrow soft key [image]. Only the valid feature types appear in the selection screen. The graphics in the upper-left corner of the screen updates to provide a visual cue as to how the feature will be built. The nominal and measured data update according to the feature inputs.

  4. Press the Confirm soft key to add the command to the measurement routine.

Valid Point Type Features

  • Constructed Circle

  • Constructed Point

  • Measured Circle Bore

  • Measured Circle Boss

  • Measured Corner Inside

  • Measured Corner Outside

  • Measured Point

  • Measured Sphere

Nominal and actual Z values are automatically assigned to the constructed feature. The nominal and actual Z value will be taken from the first component feature of the construction.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Construct Cylinder

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] until the page with the Construct Cylinder soft key appears.

  3. Press the Construct a Cylinder soft key [image] to display the Construct Cylinder screen:

To Construct a Cylinder Feature

  1. Select the first feature from the Circle Features list to use in the construction.

  2. Press the Move Item Left double arrow soft key [image] to add that feature to the Selected Features list.

  3. Repeat this process for at least one other circle feature (a minimum of two total circle type features need to be selected). If you need to remove features from the selected features list, select the feature to be removed and use the Move Item Right double arrow soft key [image]. Only the valid feature types appear in the selection screen. The nominal and measured data update according to the feature inputs.

  4. Press the Confirm soft key to add the command to the measurement routine.

Valid Circle Type Features

  • Measured Circle Shaft

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Angle Between

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] until you get to the third page of soft keys.

  3. Press the Angle Between soft key [image] to display the Angle Between screen:

The Angle Between option on the third page of the feature menu enables you to report the angle between two line type features.

To Report an Angle

  1. Select the two line type features from the First Line and Second Line lists. NC Gage calculates the angle based on the direction of the features. If the supplement is an angle, mark the Supplement check box. Only the valid feature types appear in the selection screen. The graphics in the upper-left corner of the screen update to provide a visual cue as to how the feature will be built. The nominal and measured data update according to the feature input selections made.

  2. Press the Confirm soft key [image] to add the command to the measurement routine.

Valid Line Types and Plane Features

  • Web

  • Pocket

  • Line

  • Constructed Lines

  • Cone

  • Cylinder

  • Plane

Parallelism and Perpendicularity Reporting for Angles

You can use the Angle Between, Parallelism, or Perpendicularity option to report the angle, parallelism, or perpendicularity between two line type features. Parallelism and perpendicularity dimensions report the positive deviation only. The angle between can be a positive or negative value, where positive is X to Y, Y to Z, and Z to X from the datum (the feature on the first page for the screen) to the reference feature (the feature selected on the second page for the screen).

The options are available as follows:

  • If the Nominal Angle value is 0 (zero), the Parallelism option is enabled.

  • If the Nominal Angle value is 90, the Perpendicularity option is enabled.

  • If the Nominal Angle value is other than 0 or 90, the Angle Between option is enabled.

To report on parallelism, do the following:

  1. Select the Parallelism option on the Angle Between screen to display the Parallelism screen:

  2. For Evaluation Length, enter the length over which to evaluate. The default evaluation length is zero. If the box is blank, a red asterisk (*) appears, which indicates that this is a required field; warning messages also appear.

  3. Return to the Angle Between screen and press the Tolerance soft key [image] to display the Tolerance screen:

To report on perpendicularity, do the following:

  1. Select the Perpendicularity option on the Angle Between screen to display the Perpendicularity screen:

  2. For Evaluation Length, enter the length over which to evaluate. The default evaluation length is zero. If the box is blank, a red asterisk (*) appears, which indicates that this is a required field; warning messages also appear.

  3. Return to the Angle Between screen and press the Tolerance soft key [image] to display the Tolerance screen:

Following is an example of the tree view for the Angle Between feature:

Following is an example of the tree view for parallelism:

Following is an example of the tree view for perpendicularity:

For examples of the measurement routine screens for angle between, parallelism, and perpendicularity, see "Viewing and Executing Measurement Routines". For examples of the Report screen, see "Using Reports".

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Dimension Distance

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] until you get to the third page of soft keys.

  3. Press the Distance soft key [image] to display the Distance screen:

To Report a Distance

The Distance option located on the third page of the feature menu enables you to report the distance between two point type features. The distance can be in a single axis direction (parallel to an axis) or in a two axes direction.

  1. From the Option area, select the appropriate option for the distance to compute.

  2. Select the item from each displayed list. Only valid measured and constructed items will be displayed in the List areas. The graphics in the upper left corner of the screen update to provide a visual cue as to how the feature will be built. The nominal and measured data update according to the feature inputs. Once the items have been selected, press the Tolerance soft key [image] to view the tolerance values associated with the distance to be constructed.

  3. Press the Confirm soft key [image] to add the command to the measurement routine.

Valid Point Type Features

  • Measured Point

  • Measured Circle Bore

  • Measured Circle Boss

  • Measured Corner Inside

  • Measured Corner Outside

  • Constructed Points

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Concentricity

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] until you get to the third page of soft keys.

  3. Press the Concentricity soft key [image] to display the Concentricity screen:

To Report a Concentricity

The Concentricity option located on the third page of the feature menu enables you to calculate the concentricity of one feature to another. This feature is only valid for features that are in the same work plane.

  1. Select the item from each displayed list. Both lists show the circle feature.

If the two selected features are not in the same work plane, this warning message appears: “The Selected Features Are not in The Same Work Plane.”

  2. Once the items have been selected, press the Tolerance soft key [image] to view the tolerance values associated with the concentricity.

  3. Press the Confirm soft key [image] to add the command to the measurement routine. The feature is added to the tree view. For example:

Valid Type Features

  • Measured Circle Bore

  • Measured Circle Boss

  • Constructed Circle

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Key

To create a Key command:

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] until you get to the third page of soft keys.

  3. Press the Key soft key [image] to display the Measure Key screen:

  4. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It displays a graphical view of where to position the probe for measurements and changes when multiple steps are required.

Properties Area

  • Start Position X, Start Position Y, and Start Position Z - Define the range for the start point.

  • Width - Defines the width of the keyway. The width is only visible when the Learn Using Values on Screen check box is selected.

  • Always Search - Enables the search process. If you select this check box, NC Gage inserts the search process at the beginning of the measurement process. The probe takes some prehit measurements on the shaft surface to locate the nominal keyway angle location.

Motion Parameters Area

  • Prehit Angle - Defines the angle away from the nominal surface that the probe uses to begin seeking the surface during the measurement process.

Optional Settings Area

  • Learn then Measure - Selecting this option causes the machine to learn the location of the part using default parameters and then immediately re-measure the feature with the properties as set on the screen. It is used to test all of the set parameters, which provides a more accurate and reliable first article inspection.

  • Learn Using Values on Screen - Use this option to enter the nominal values of the feature and have the software measure at that location.

Parameters Area

  • Angle - Defines the vector angle of the center line of the flat.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

  1. Rotate the key in the left direction and position the probe next to the right side of the key. Press the Read Position soft key [image].

  2. Rotate the key in the clockwise (right) direction and position the probe next to the left side of the key. Press the Read Position soft key [image].

  3. Position the probe in a safe position and press the Learning and Creating a Command (Execute) soft key [image].

  4. Refer to the image below.

    • The probe moves to the top of the key.

    • The rotary axis rotates to a prehit angle position.

    • The probe moves to the measure height.

    • The rotary axis rotates in a clockwise direction until the probe is triggered. The rotary axis stops rotating. It retracts to the prehit angle position.

    • The probe moves to the top of the key.

    • The rotary axis rotates to a prehit angle position.

    • The probe moves to the measure height.

    • The rotary axis then rotates in a counter-clockwise direction until the probe is triggered. The rotary axis stops rotating. It retracts to the prehit angle position.

    • The probe moves to the top of the key.

    • The rotary axis rotates back to the original position.

    • The middle angle of the key is calculated by the two triggered rotary axis positions.

Execute Process

Refer to the image below.

  1. The probe moves to the top of the key.

  2. The probe orientates to 0 degrees in the spindle.

  3. The rotary axis rotates to a prehit angle position.

  4. The probe moves to the measure height.

  5. The rotary axis rotates in a clockwise direction until the probe is triggered. The rotary axis stops rotating. It retracts to the prehit angle position.

  6. The probe moves to the top of the key.

  7. The probe orientates to 180 degrees in the spindle.

  8. The rotary axis rotates to a prehit angle position.

  9. The probe moves to the measure height.

  10. The rotary axis rotates in a counter-clockwise direction until the probe is triggered. The rotary axis stops rotating. It retracts to the prehit angle position.

  11. The probe moves to the top of the key.

  12. The probe orientates to 0 degrees in the spindle.

  13. The rotary axis rotates back to the original position.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Keyway

To create a Keyway command:

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] until you get to the second page of soft keys.

  3. Press the Keyway soft key [image] to display the Measure Keyway screen:

  4. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It displays a graphical view of where to position the probe for measurements and changes when multiple steps are required.

Properties Area

  • Start Position X, Start Position Y, and Start Position Z - Define the range for the start point.

  • Width - Defines the width of the keyway. The width is only visible when the Learn Using Values on Screen check box is selected.

  • Always Search - Enables the search process. If you select this check box, NC Gage inserts the search process at the beginning of the measurement process. The probe takes some prehit measurements on the shaft surface to locate the nominal keyway angle location.

Motion Parameters Area

  • Prehit Angle - Defines the angle away from the nominal surface that the probe uses to begin seeking the surface during the measurement process.

  • Search Angle Range - Defines the search angle range when finding and learning a feature. This option is not available if the Learn Using Values on Screen check box is selected.

Optional Settings Area

  • Learn then Measure - Selecting this option causes the machine to learn the location of the part using default parameters and then immediately re-measure the feature with the properties as set on the screen. It is used to test all of the set parameters, which provides a more accurate and reliable first article inspection.

  • Learn Using Values on Screen - Use this option to enter the nominal values of the feature and have the software measure at that location. Selecting this option disables the Search Angle Range option.

Parameters Area

  • Angle - Defines the vector angle of the center line of the keyway.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

  1. Position the probe inside the keyway at the center line, and press the Read Position soft key [image].

  2. Refer to the image below.

    • The rotary axis rotates in a clockwise direction until the probe is triggered. The rotary axis stops rotating.

    • The rotary axis then rotates in a counter-clockwise direction until the probe is triggered. The rotary axis stops rotating.

    • The rotary axis rotates back to the original position.

    • The middle angle of the keyway is calculated by the two triggered rotary axis positions.

Execute Process

Refer to the image below.

  1. The probe moves to the start position inside the keyway.

  2. The probe orientates to 0 degrees in the spindle.

  3. The rotary axis starts rotating to the prehit angle position in a clockwise direction.

  4. The rotary axis stops and starts moving slowly to the measure one side of the keyway.

  5. The probe is triggered and the rotary axis starts rotating in the opposite direction.

  6. The probe orientates to 180 degrees in the spindle.

  7. The rotary axis rotates to the prehit angle position in a counter-clockwise direction.

  8. The rotary axis stops and starts moving slowly to measure the other side of the keyway.

  9. The rotary axis rotates back to the original position.

  10. The probe orientates to 0 degrees in the spindle.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Flat

To create a Flat command:

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] until you get to the third page of soft keys.

  3. Press the Flat soft key [image] to display the Measure Flat screen:

  4. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It displays a graphical view of where to position the probe for measurements and changes when multiple steps are required.

Properties Area

  • Start Position X, Start Position Y, and Start Position Z - Define the range for the start point.

  • Width - Defines the width of the keyway. The width is only visible when the Learn Using Values on Screen check box is selected.

  • Always Search - Enables the search process. If you select this check box, NC Gage inserts the search process at the beginning of the measurement process. The probe takes some prehit measurements on the shaft surface to locate the nominal keyway angle location.

Motion Parameters Area

  • Prehit Angle - Defines the angle away from the nominal surface that the probe uses to begin seeking the surface during the measurement process.

  • Search Angle Range - Defines the search angle range when finding and learning a feature. This option is not available if the Learn Using Values on Screen check box is selected.

Optional Settings Area

  • Learn then Measure - Selecting this option causes the machine to learn the location of the part using default parameters and then immediately re-measure the feature with the properties as set on the screen. It is used to test all of the set parameters, which provides a more accurate and reliable first article inspection.

  • Learn Using Values on Screen - Use this option to enter the nominal values of the feature and have the software measure at that location. Selecting this option disables the Search Angle Range option.

Parameters Area

  • Angle - Defines the vector angle of the center line of the flat.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

  1. Position the probe on the top of the flat at the center line, and press the Read Position soft key [image].

  2. Refer to the image below.

    • The rotary axis rotates in a clockwise direction until the probe is triggered. The rotary axis stops rotating.

    • The rotary axis then rotates in a counter-clockwise direction until the probe is triggered. The rotary axis stops rotating.

    • The rotary axis rotates back to the original position.

    • The middle angle of the flat is calculated by the two triggered rotary axis positions.

Execute Process

Refer to the image below.

  1. The probe moves to the start position inside the flat.

  2. The probe orientates to 0 degrees in the spindle.

  3. The rotary axis starts rotating to the prehit angle position in a clockwise direction.

  4. The rotary axis stops and starts moving slowly to the measure one side of the flat.

  5. The probe is triggered, and the rotary axis starts rotating in the opposite direction.

  6. The probe orientates to 180 degrees in the spindle.

  7. The rotary axis rotates to the prehit angle position in a counter-clockwise direction.

  8. The rotary axis stops and starts moving slowly to measure the other side of the flat.

  9. The rotary axis rotates back to the original position.

  10. The probe orientates to 0 degrees in the spindle.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Setting Additional Feature Parameters

When you work with feature commands, you can modify additional parameters from the feature window. The following soft keys are available on the toolbar in the Feature window:

  • Set Work Offsets

  • Update Work Offset

  • Select Work Offset

  • Write Variable

  • Update Tool Length - Measurement Routine Control

  • Set Coordinate Rotation

  • Tolerance

  • Hit Clearance Plane

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Select Work Offset

Selecting a work offset at the beginning of your measurement routine can make your measurement routine reusable; this must be done prior to measuring features.

  1. Press the Select a Work Offset soft key [image] on the main screen to display the Select Work Offset screen. This is available when NC Gage starts up prior to defining a Feature Frame (if a rotary table has been configured for the system) or defining a clearance plane.

  2. Press the Select a Work Offset to Update soft key [image] reviewing the offset values shown in the Parameters area of the screen for each offset list item until the desired offset settings are displayed.

  3. Press the Execute soft key [image] to activate the work offset on the machine.

  4. Press the Confirm soft key [image]. NC Gage inserts the selected work offsets into the measurement routine. Press the Return soft key [image] to return to the previous screen without saving.

Parameters Definition:

  • Work Offset – Specifies the work offset, which is chosen to show the offset values in parameters and add to measurement routine.

  • X Y Z – These read-only values show the work offset values. Values are read from the controller and shown when a work offset is selected in combo box.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Write Variable

The Write Variable command feature is available starting with NC Gage 2.0. You can use it to write measurement data to a macro variable on the NC control. In addition, the Write Variable feature can write to a macro variable the number of out of tolerance features and total number of features. NC Gage only writes these values; no other action is performed.

  1. Press the Measure soft key [image] on the main screen's navigation bar.

  2. Press the Forwardsoft key [image] until you get to the third page of soft keys.

  3. Press the Write Variable soft key [image] to display the Write Variable screen:

Features Area

Number Checked - The number of features that were measured and/or constructed.

Number Out Of Spec - The number of features that are not in tolerance.

Feature Location Area

Dimension - The set of axes that have been tolerance for the feature.

Value - This field appears when a dimension is selected. It cannot be edited.

Macro Variable - This field is an integer that defines a valid macro variable number. The range of valid macro variables depends on the machine type and the purchased options.

Use the following steps to write a macro variable:

  1. Select a measured feature from the Features list.

  2. The list of valid measured dimensions for that feature should then populate the Dimension box. If Number Checked or Number Out of Spec is selected for the feature, then the box is left blank and disabled. Select the dimension from the list in the Feature Location area. The current value appears for reference.

  3. Enter the macro variable number to be used in the Macro Variable box in the Feature Location area. NC Gage tests that the macro number entered does not collide with NC Gage processing.

  4. Click the Confirm soft key [image] to complete the write variable procedure.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Update Tool Length - Measurement Routine Control

The Update Tool Offset screen for Measurement Routine Control defines the tool offset in an interactive session that will be part of a measurement routine control.

  1. Once a feature has been measured, select the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] until you get to the third page of soft keys.

  3. Select the Update Tool Offset soft key [image] to display the Update Tool Offset screen:

The Update Tool Offset function is based on the part feature with the target value having been cut by the tool you input. In this situation, the difference between the target value and the measured value is the tool offset wear error. It is critical to understand this as the update will permanently change the value of the tool offset.

To enable the measurement routine to update the tool offset:

  1. Navigate to the third page of the Measure screen.

  2. Click on the Update Tool Offset soft key [image] to display the Update Tool Offset screen.

  3. Select the target feature from the Features list. Once the selection has been made, the nominal value appears in the Feature Location area. If the feature has been measured, then the measured value and the deviation of this feature also appear. The tool offset is refreshed based on the deviation. Features that can be used are ones that measure a Z value, most often a point or a plane. Make the appropriate selections from the lists.

  4. Press the Select Diameter Mode soft key [image] if necessary to enter Diameter Mode. You can also mark the Diameter check box in the Tool Offset area to enter Diameter Mode. When in this mode, all values in the Tool Compensation area are based on the diameter of the tool. When you are not in Diameter Mode, the values are based on the radius of the tool.

  5. In the Tool Offset area, enter the tool number of the tool used to cut the feature to be used in the calculation. The current whole tool offset (Geometry + Wear) appears in the Tool Offset area when a valid tool number is entered. The screen updates with the following:

    • The tool offset from the NC machine is retrieved.

    • The Current and New offsets are computed and displayed.

    • The Difference between these two numbers is shown. This difference should be the same as the deviation of the feature location. This is because NC Gage computes the tool offset that would have cut a "perfect" feature had it been set when the part was cut.

    If NC Gage determines that the tool number value you input is the same value as the active probe number in the measurement routine, it displays a warning. This, in effect, is requesting the system to updated the probe length, which isn't allowed; the tool number and active probe number values cannot be the same. Correct this and then proceed.

  6. Click on the Confirm soft key [image] to save the new values and finalize the tool update, which is written into the measurement routine. The update work will be done the next time the measurement routine is run. Press the Return soft key [image] to return to the previous screen.

The wear for the currently identified tool is modified by the value that NC Gage calculates as the difference between the target and measured locations. The tool wear is adjusted by this difference each time the Confirm soft key [image] is selected. Thus, you are advised to execute this routine only once for each instance that a tool cuts a surface.

Features Area

Displays a list of available features that you can select. Only valid feature types appear in this list.

Feature Location Area

Nominal - Always 0 (zero) as a reference by default.

Measured - Displays the Z value of the measured location for the specified coordinate system.

Deviation - Displays the deviation in the normal direction for the selected feature.

Tool Offset Area

Current - Displays the current tool offset value.

New - Displays the new tool offset value.

Difference - Displays the difference between the current and new tool offset values.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Set Coordinate Rotation

NC Gage provides the functionality to define a 2D rotation adjustment for the coordinate system used on the CNC machine by measuring desired features and then selecting the features to use in the coordinate system rotation. Doing the same thing without this functionality would require you to manually type the appropriate rotation center, axis vector, and angle for the G68 code.

Once your features are measured, use the Set Coordinate Rotation screen to select features used in the rotation calculation. NC Gage updates the G68 code or the G68.2 code to use the new rotated coordinate system.

There can be only one rotation macro. Subsequent definitions inside NC Gage overwrite the existing parameters.

  1. Press the Measure soft key [image] on the main screen.

  2. Press the Forward soft key [image] until the Set Coordinate System Rotation soft key appears.

  3. Press the Set Coordinate System Rotation soft key [image] to display the Set Coordinate Rotation screen:

Parameters Area

The Coordinate Rotations are ways that the coordinate system can be rotated on an NC machine. It is not possible to measure when a Coordinate Rotation is active, so the Coordinate Rotation feature is not activated when the command is executed. The information is computed to macro variables and a macro program can be called that will use this information to perform the Coordinate Rotation.

  • a1, a2, R: These lists display the features in the measurement routine that define the axes (a1=Axis 1, a2=Axis 2) translation (Axis lists) and a rotation (R list). The axes are defined by the selection made using the Select Measurement Face soft key - see below.

  • a1, a2, R Part: These read-only boxes display the axes (a1=Axis 1, a2=Axis 2) and Rotation (R) values for the currently selected features from the Axes and R lists. These values have already been transformed to the part coordinates system. The axes are defined by the selection made using the Select Measurement Face soft key - see below.

  • a1, a2, R Machine: These read-only boxes display the axes (a1=Axis 1, a2=Axis 2) and Rotation (R) values for the currently selected features from the Axes and R lists. These values have already been transformed to the machine coordinates system. The axes are defined by the selection made using the Select Measurement Face soft key - see below.

  • a1, a2, R Target: These boxes define the target axes (a1=Axis 1, a2=Axis 2) Rotation (R) values for the coordinate system rotation. Use these boxes to define the exact coordinate system location and rotation angle to use. The axes are defined by the selection made using the Select Measurement Face soft key - see below. The machine coordinate values are used to set the coordinate rotation command.

Regarding the Rotation angle, the selected features that may have a line defined (such as Line, Plane, Pocket, Web, Cylinder Bore/Boss and Cone Bore/Boss) will be automatically updated in the corresponding fields. The normal axis of Cylinder, Cone and Plane features creates the 2D angle. The vector angle of the selected Line feature type can also be used to define the Rotation angle.

  • Comment: Use this box to type a comment for the current system rotation.

Select Measurement Face Overview

When inserting a Coordinate System Rotation command into your measurement routine, the Work Plane, Axis Values and Rotation Angles for rotating the coordinate system must be defined. To define the work plane, the following measurement plane options are available using the Select Measurement Face button:

XY Plane

When the XY Work Plane is selected, NC Gage displays the X, Y and R labels and the respective details in the Parameters area.

YZ Plane

When the YZ Work Plane is selected, NC Gage displays the Y, Z and R labels and the respective details in the Parameters area.

XZ Plane

When the XZ Work Plane is selected, NC Gage displays the X, Z and R labels and the respective details in the Parameters area.

Setting a Coordinate System Rotation

  1. Specify the translation in the X and Y directions by selecting features in the X list and the Y list that are valid measurements for each axis. These are point features or other features that have an underlying center point value, such as a circle (bore), that define the origin in the new coordinate system.

  2. Specify the rotation by selecting a feature from the R list that has a valid direction in the XY plane. These are features with direction (such as lines).

  3. For each feature define the expected value for the axis or angle in the XZY Target boxes./p>

  4. Press the Confirm soft key [image] to add the coordinate system rotation to the NC Gage measurement routine. Even though the coordinate system rotation icon is added to the measurement routine, the coordinate system rotation does not affect the NC Gage measurement routine.

NC Gage computes the deltas for the translation and rotation between the actual measurements and the expected values. The X, Y, and rotation are then written to a set of macro variables that are used in a Coordinate System Rotation macro subroutine. This macro subroutine is called when NC Gage closes after the measurement routine is done executing.

You can call the macro subroutine again to reapply the coordinate system change. This subroutine macro number is given the same number as the monitor subroutine macro + 2. So, if your monitor program was numbered 7000, this coordinate system change would be numbered 7002. There can be only one rotation macro. Subsequent definitions inside NC Gage overwrite the existing file.

NC Gage cannot run with a coordinate rotation applied. Therefore, coordinate rotations are not set directly. Instead the X, Y and R parameters are saved so that you may call the coordinate rotation macro prior to performing cutting operations.

Example

Suppose POINT2 (shown as B below) is a constructed point from the intersection of LINE3 (shown as C below) and LINE4 (shown as A below), and you selected POINT2 as the new origin and LINE4 as the rotation feature, like this:

This means NC Gage will rotate the coordinate system about POINT2 (at B) and will rotate it to LINE4 (at A). The coordinate system will have POINT2 (at B) as its origin and the new X axis would be the same as LINE4 at A.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Tolerance

You can use the Tolerance screen to view or edit tolerances according to the feature requirements. With the tolerance setting, NC Gage evaluates the measured results.

To access the Tolerance screen, press the Tolerance soft key [image] located on the second page of any feature. To add the command to the measurement routine, you need to edit the tolerance after the feature has been measured and before you click the Confirm soft key [image] .

You can customize the default report settings for each feature on the Tolerance screen. Edit the content as described below.

  1. Select the axes that will be reported. Select the corresponding check boxes.

  2. Modify the nominal values as needed.

  3. Modify the tolerance values as needed.

  4. To evaluate the position of a hole or boss, select the Position check box.

    For example, if the feature lies within a circular tolerance zone for the Measure Bore and Measure Boss functions, the size of the tolerance zone is specified by its diameter. To check if the feature lies within this tolerance zone, select the Position check box.

    The evaluation of a position always has a nominal value of 0.

All settings are saved in the measurement routine for each feature when you press the Confirm soft key [image]. Press the Return soft key [image] to exit this screen without saving any changes.

Form Tolerances

Form tolerances include flatness, straightness, roundness (or circularity), sphericity, and cylindricity. These tolerances are related to individual features only.

NC Gage can evaluate the form tolerances for different features. The features and their form tolerances are:

  • Line: Straightness

  • Bore and Boss: Roundness

  • Shaft: Roundness and runout (runout is only reported when measured with table rotation)

  • Internal Cylinder and External Cylinder: Cylindricity

  • Sphere: Sphericity

  • Cone: ConeForm

  • Plane: Flatness

To evaluate a feature's form tolerance, select the tolerance's check box. For example:

Straightness check box for Line feature

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Hit Clearance Plane

The Hit Clearance Plane check box defines the local clearance plane required during the measurement process. The option is found on all the Feature Command screens as well as the Set Two Axes (Inside Corner) and Set Two Axes (Outside Corner) screens.

Although the Point feature has the Hit Clearance Plane option, it does not work the same since only a single probing is done in the measurement process.

When selected, the input box is enabled where a value is entered defining the position the probe moves to avoid obstructions during the measurement process. After each measurement, the probe tip is driven to the defined Hit Clearance Plane position along the probe direction. Once the probe is at the Hit Clearance Plane position, it is then moved to the Safe Move location in the XY axes (in Feature Coordinates) and then moved to perform the next measurement probing.

A local clearance plane is defined by the input height in a Feature Coordinates system. The origin point of the feature coordinate system is the feature location and the Z axis vector is the probe direction (tip to spindle) in the feature measurement.

Hit Clearance Plane example using a Circle Boss feature and a Plane with the feature coordinate system displayed

H - The input value for the Hit Clearance Plane

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Inserting Move Commands

NC Gage enables you to insert move commands into your measurement routine to help you to avoid probe collisions with the part. Move commands are added between feature commands. Your probe must be calibrated prior to adding move commands (see "Calibration").

Once you have defined a Feature Frame, select the Move soft key [image] on the main screen's navigation bar to display the following options:

The commands are:

  • Move Point

  • Clearance Plane

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Move Point

A Move Point command provides the XYZ coordinates to which the probe tip center will move when executed. These positions are used to move the probe clear of obstructions.

To add a Move Point command to your measurement routine:

  1. Press the Move soft key [image] on the main screen's navigation bar.

  2. Press the Move Point soft key [image] to display the Move Point screen:

  3. Follow the instructions on the screen to insert the command. Pay attention to the graphical description in the upper-left area of the screen. It will show you where to position the probe for measurements and changes when multiple steps are required.

Parameters Definition:

  • Target Position (X Y Z Nominal) - Defines the nominal position of the point.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

  1. Position probe to move point location and press the Read Position soft key [image]. The tip position is read. Press the Return to Previous Step soft key [image] to cancel this measure position.

  2. Press the Confirm and Append Current Command to End soft key [image]. The new Move Point command is inserted into the measurement routine.

If the move point screen is accessed from the second page of any feature screen, then the move point will be inserted in the measurement routine after the feature.

The following is the specific feature path and logic built into NC Gage built into NC Gage:

  • If current Z position is higher than target position then move to XY target position at current Z height then move to Z target position.

  • If current Z position is lower than the target position then move up to Z target position then move to XY target position.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Clearance Plane

A Clearance Plane command provides the XYZ coordinates and the vector of a plane beyond which the probe tip center will move when executed.

To add a clearance plane move command to your measurement routine:

  1. Press the Move soft key [image] on the main screen's navigation bar.

  2. Press the Clearance Plane soft key [image] to display the Clearance Plane screen:

  3. Follow the instructions on the screen to insert the command.

Pay attention to the graphical description in the upper-left area of the screen. It will show you where to position the probe for measurements and changes when multiple steps are required.

Parameter Definitions:

  • Directional Plane Height of Probe Tip - Defines the distance between the Part Origin and the Safe Clearance Plane, measured along the direction of the probe tip.

  • Learn Using Values on Screen - This enables you to enter the nominal values of the feature and have the software use that location.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Learn Process

  1. Press the Move soft key [image] on the main screen's navigation bar.

  2. Press the Clearance Plane soft key [image].

  3. Set the Clearance Plane position. This may be done by either:

    1. Jogging the probe tip to the needed move point location and then pressing the Read Position soft key [image] to take the current position as the target.

    2. Checking Learn Using Values on Screen and then typing in the location in the Directional Plane Height of Probe Tip box. The location is relative to the center of the probe tip and the current work offset.

  4. Press the Confirm soft key [image]. The Clearance Plane command is added to the measurement routine.

Minimum Clearance Plane Height:

The minimum clearance plane calculation is related to the prehit distance and the probe radius. NC Gage defines the clearance plane so that it does not bring the probe any closer to the part than the prehit distance. It also assumes that when measuring a feature on a “wall”, that the depth of measurement is likely to be at least a probe radius.

  • For features that are measured on a “wall” (bores, bosses, lines, cylinders, cones, webs, pockets, corners):
    Minimum Clearance Plane Height = Measurement Height + (2 * Probe Radius) + Prehit

or

Minimum Clearance Plane Height = Measurement Height + Probe Diameter + Prehit

  • For features measured on top of the part (plane and point):
    Minimum Clearance Plane Height = Measurement Height + Probe Radius + Prehit

  • For sphere features:
    Minimum Clearance Plane Height = Sphere Center + Sphere Radius + Probe Radius + Prehit

A Side View Diagram of a Part and Probe Tip

A - Minimum Height

B - Prehit

C - The Probe Tip
3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Working with Measurement Routines

Once you have your measurement routine with the features you want to measure, you can either execute your measurement routine or edit it. NC Gage provides you with the Execute Measurement Routine and Edit Measurement Routine screens to help you perform those tasks.

The following topics describe those screens:

  • Viewing and Executing Measurement Routines

  • Editing Measurement Routines

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Viewing and Executing Measurement Routines

Use the Measurement Routine screen to view and execute your measurement routine.

To access this screen, select the Execute Measurement Routine soft key [image] on the main screen:

Example of the Angle Between Feature

Example of Parallelism Reporting for Angles

Example of Perpendicularity Reporting for Angles

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Editing Measurement Routines

Use the Edit Measurement Routine screen to edit your measurement routine. This includes rearranging, copying or pasting, and deleting commands.

  1. Press the Forward soft key [image] to navigate to the second page of the main screen.

  2. Press the Edit Measurement Routine soft key [image] to display the Edit Measurement Routine screen:

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

Information About Cursor Modes

The two modes are:

  • Single Select Mode - In this mode, when you move the cursor up and down in the Edit window measurement routine tree, it selects the current entity to be edited. This is the default mode.

  • Multi-Select Mode - In this mode, when you move the cursor up and down in the Edit window measurement routine tree, it automatically selects each entity, adding it to the group of selected entities.

Either mode can be used to cut, copy, or paste measurement routine entities.

Information About Editing a Feature

When on the Edit Measurement Routine screen or in Edit mode:

  • To exit the screen or exit the screen without saving changes, press the Return soft key [image].

  • To exit the screen and save changes, press the Confirm Save Change to Command soft key [image].

You are in Edit mode when the following icon appears in the bottom-right area of the Edit Measurement Routine screen:

Otherwise, the following icon appears and indicates that you are in normal insert mode:

Information About Pasting a Feature

To paste a feature, move the highlight to the feature above where the pasted feature will be inserted. A small red arrow appears in the measurement routine tree view when you press the Copy or Cut soft keys. This indicates where the measurement routine will paste the command or commands.

  • If the feature to be pasted was originally cut from the measurement routine, then it will be inserted into the measurement routine identically to how it was cut. In essence, it will be moved in the measurement routine order.

  • If the feature to be pasted was originally copied from the measurement routine, then it will be inserted into the measurement routine and the feature name will increment each time it is pasted. So, if you copied and pasted a feature named "Line1", the pasted feature would be named "Line2" and then "Line3" and so forth.

Measurement Routine Comment

In the Measurement Routine Comment box, type a comment about the measurement routine. This comment appears in the Comment column on the File Manager screen.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Managing Files

Use the File Manager screen to manage your NC Gage measurement routines. You can create new measurement routines and save them, as well as load or delete existing measurement routines. Measurement routines are stored in the PRG directory of the NC Gage installation directory.

Click on the File Manager soft key [image] on the main screen to display the File Manager screen:

This screen contains three columns:

  • Measurement Routine Name - This lists the measurement routine's name with an .NCG file name extension.

  • Comment - This shows any measurement routine-specific comments. Use the Edit Measurement Routine screen to add any comments. See "Editing Measurement Routines".

  • Spindle Type - This lists the spindle's type (Main Spindle or Sub Spindle) based on the creation of your measurement routine.

  • Date Created - This displays the date the measurement routine was last saved.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Using Reports

Once you have executed your measurement routine, you can compare the results of the measured values against the provided nominal values by viewing the Report screen. You can access this screen by pressing the Report soft key [image] on the main screen immediately following measurement routine execution.

You cannot access the Report screen until there are measured values. These are only available after the measurement routine has been executed.

Parallelism and Perpendicularity Reporting for Angles

Displaying the Measurement Routine Report

The measurement routine report can be displayed by navigating to the appropriate page of the main screen and selecting the Report soft key [image].

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Using the On-Screen Keyboards

NC Gage has three on-screen keyboards:

  • Alphanumeric keyboard - This keyboard is a combination of alphabetic, numeric, and symbol keys. If keyboards are enabled in NC Gage, this keyboard automatically appears when you click in an alphanumeric box on a screen.

  • Numeric keypad - This keyboard provides calculator-style efficiency for entering numeric data. If keyboards are enabled in NC Gage, this keyboard automatically appears when you click in a numeric box on a screen.

  • Scientific calculator - This keyboard provides access to mathematical functions. The key that opens this keyboard is located on the numeric keypad.

To enable or hide keyboards, define their colors, and set the sizes of their keys, see "Keyboard Setup Tab" in "Appendix A - Controller Configuration".

Standard Keys on all Keyboards

The following table describes the keys that appear on all of the keyboards.

Key | Description
Pushpin
  • To pin the keyboard so that it appears in the same location on the screen when you click in boxes on the screen, click the Pushpin key. Its background turns orange.
  • To unpin the keyboard, click the Pushpin key with the orange background. The keyboard's location changes when you click in boxes on the screen.
The Close key closes the keyboard.
0 - 9 | These keys enter numbers.

Alphanumeric Keyboard

Alphanumeric keyboard

The following table describes the keys.

Key | Description
a - z | These keys enter lowercase or uppercase letters. To change lowercase keys to uppercase keys, click the abc key.
# | Enters a pound sign.
tab | Closes the keyboard for the current option and moves the cursor to the next option on the screen.
, | Enters a comma.
!#? | Changes the letter keys to symbol keys. When you click this key, its background turns orange. To change the symbol keys back to letter keys, click the !#? key with the orange background.
abc | Changes the lowercase keys to uppercase keys. When you click this key, its background turns orange. To change the uppercase keys to lowercase keys, click the abc key with the orange background.
JP | The Japanese Conversion key appears only for the Japanese operating system. (If the operating system is not Japanese, this key does not appear.) If you click this key, the full list of Japanese characters is available. If you do not click this key, the half list of Japanese characters is available.
 | The Spacebar key enters spaces.
/ | Enters a forward slash.
\ | Enters a backslash.
. | Enters a period.
 | The Backspace key deletes the character to the left of the cursor in the box on the screen.
DEL | Deletes the character to the right of the cursor in the box on the screen.
- | Enters a hyphen.
 | The Enter key moves the cursor to a new line in the box on the screen.
Upwards Paired Arrows | Pages up.
Downwards Paired Arrows | Pages down.
Up arrow | Moves the cursor to the left one character.
Left arrow | Moves the cursor to the left one character.
Right arrow | Moves the cursor to the right one character.
Down arrow | Moves the cursor to the right one character.

Numeric Keypad

Numeric keypad

The following table describes the keys.

Key | Description
Cal | The Calculator key changes the keyboard to the scientific calculator.
 | The Backspace key deletes the character (from right to left) in the keyboard's text box.
CLR | The Clear key clears the characters that are in the keyboard's text box and in the box on the screen.
- | Enters a negative.
. | Enters a decimal point.
 | The Enter key enters the characters that appear in the keyboard's text box into the box on the screen.

Scientific Calculator

When you click the Cal (Calculator) key on the numeric keypad, the scientific calculator appears:

Scientific calculator

To calculate an expression, click the mathematical symbol and then click the operand. For example, to calculate sin(60)+cos(60) and display the result in the calculator's text box, click the following keys:

sin(60)+cos(60)=

The following table describes the keys and provides examples.

Key | Description | Key Click Examples
Num | Changes the keyboard to the numeric keypad. |
AC | Clears the calculated result or expression in the calculator's text box. |
C | Clears the last number in the calculator's text box. |
( | Enters a left parenthesis. |
) | Enters a right parenthesis. |
Pl | Pi | Pl=
Abs | Calculates the absolute value. | Abs3=
sin | Calculates the sine. | sin60=
cos | Calculates the cosine. | cos60=
tan | Calculates the tangent. | tan60=
In | Calculates the logarithm. | In6=
Inv | The Inv (Inverse) key changes the sin, cos, tan, In, square root, and mm->inch keys to their reciprocal functions. When you click the key, its background turns orange: Reciprocal functions The reciprocal functions are described below: |
 | asin - Calculates the arc sine. | asin0.5=
 | acos - Calculates the arc cosine. | acos0.5=
 | atan - Calculates the arc tangent. | atan1=
 | exp - Calculates the exponent. | exp2=
 | x^2 - Calculates the square. | 3x^2=
 | inch->mm - Changes the result in the keyboard's text box from inches to millimeters. | inch->mm9=
 | The Square Root key performs a square root operation. | 16=
mm->inch | Changes the result in the keyboard's text box from millimeters to inches. | mm->inch3=
= | The Equals key displays the result of an arithmetic operation in the calculator's text box. To display the result in the box on the screen, click Enter after you click the = key. | 3+2=
/ | Divides two numbers. | 3/2=
* | Multiplies two numbers. | 3*2=
- | Subtracts two numbers or enters a minus sign. | 3-2=-3
+ | Adds two numbers. | 3+2=
 | The Backspace key deletes the character (from right to left) in the keyboard's text box. |
CLR | The Clear key clears the characters that are in the box on the screen. |
 | The Enter key enters the characters that appear in the keyboard's text box into the box on the screen. |

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Direct Connect Mode

Home > Using PC-DMIS NC Gage > Direct Connect Mode (DCM)

Direct Connect Mode (DCM)

NC Gage measurement routines can be run directly from a cutting macro as if the measurement routine was a subroutine using the Direct Connect Mode (DCM) functionality. When the NC Gage measurement routine finishes running without errors, it returns to the cutting macro from which it was called.

NC Gage measurement routines can consist of inspection routines or work offset update routines.

Entering DCM Mode

Press the Direct Connect Mode soft key [image] on the second page of the main screen to display the Direct Connect Mode screen:

Direct Connect Mode screen

Alternately, you can modify the command line shortcut with a –DL extension as shown below to start Direct Connect Mode when NC Gage starts:

C:\ .. \NCGage.exe –dl

Calling the NC Gage Measurement Routine

To call an NC Gage measurement routine from a cutting macro, a special macro (DCM Macro) must be called, and the NC Gage measurement routine name (must be a number) should be assigned.

  • The name of the NC Gage measurement routine must be a four-digit number. This number is used when calling the DCM Macro to specify the NC Gage measurement routine, which should be run.

  • The DCM macro is the NC Gage Monitor Macro number plus 1. For example, if the Monitor Macro Number is 7400, then the DCM macro will be 7401. The DCM macro number is determined by the NC Gage Configuration Tool during the initial setup and configuration of NC Gage. See "Appendix A - Controller Configuration" for more information.

To call an NC Gage measurement routine named 1234.ncg from a cutting macro, add the following syntax to the cutting macro:

CALL O7401 LPRG=1234

During execution in DCM, the Direct Connect Mode screen displays the measurement routine being executed. It also displays the report in real-time as the measurement routine executes. If NC Gage is so configured, it saves a part report file, and the NC Gage DCM monitor screen displays the number of out-of-tolerance features.

Error Conditions

If a false trigger causes an error condition, an unexpected end of move, press the Stop Execution soft key [image] in NC Gage. If the machine tool is not able to initialize the probe, NC Gage returns you to the cutting macro.

Example of "OutOfTol Number" Option

The OutOfTol Number option in the Information area displays the number of features that are out of tolerance in the measurement routine.

Example of "OutOfTol Number" option

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Information Manager

This screen allows you to see messages pertaining to the connection of NC Gage to the controller and any error messages that NC Gage encounters.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Navigation Bar Soft Keys

The soft keys that are on each screen's navigation bar are listed below. Touching any soft key opens the function screen associated with that soft key or performs the specified action.

Terminology Note: A soft key is a touchable button on the bottom of the controller screen that is mapped to different functions on each screen. Some screens have multiple "pages" of soft keys. You can use the Forward soft key to navigate through the pages of soft keys.

Add Single Angle to Position List ( [image]) - This soft key reads the Angle value in the Add Single Angle area, and adds it to the Calibration Positions list.

Angle Between ( [image]) - This soft key opens the Angle Between screen and enables you to dimension the angle between two features.

Back to Last Step ( [image]) - This soft key goes back a step in the current procedure.

Calibration Test Settings ( [image]) - This soft key displays the Calibration Values Test screen that enables you to indicate the nominal location of the ring and tolerance values. If any measured value differs from its respective nominal by more than the allotted tolerance, a warning appears. You can continue after you accept the warning. The nominal X, Y, and Z can be entered. The tolerances for the X, Y, Z, D, and form (F) can be entered.

Cancel ( [image]) - This soft key clears any information that you entered for the Pocket number, Nominal Diameter, and Nominal Length options.

Cancel All Steps / Abort ( [image]) - This soft key stops and resets the current operation. If learning a feature, it removes all the learned probe positions.

Clear ( [image]) - This soft key deletes the entire B axis probe calibration, so that you start from scratch. If you press this soft key, the Delete All Old Calibrations check box is checked. At the time of the actual calibration, you see an "Are You Sure” prompt if this is checked. If you do not press the Clear soft key, any calibrations performed are merged with previous calibrations. "Clear" means that the PRB file resets and all measurements are discarded.

Clear Position List ( [image]) - This soft key deletes all entries in the Calibration Positions list.

Clear Select ( [image]) - This soft key deselects all but the first measurement routine entities that were selected with the multi-select mode.

Concentricity ( [image]) - This soft key opens the Concentricity screen that enables you to calculate the concentricity of one feature to another.

Confirm or Add Command ( [image]) - For operations, this soft key confirms the selection. For commands, it appends the command to the end of the measurement routine. For feature commands, it is available after the machine has learned the feature location or when you have typed the feature's nominal values. For constructed and dimension feature commands, it is available once you have specified the proper input features.

Confirm and Append Current Command to End or Apply or Confirm Changes ( [image]) - This soft key accepts changes made to any options, settings, or selections on the current screen. In some cases, this soft key adds a command to the NC Gage measurement routine.

Confirm Calibration ( [image]) - This soft key accepts the calibration.

Confirm to Save Changes ( [image]) - This soft key saves any changes made to the nominal or tolerance information.

Confirm to Update Work Offset ( [image]) - This soft key is available after the machine has learned the feature location. It saves the command to the measurement routine.

Construct a Circle ( [image]) - This soft key opens the Construct Circle screen.

Construct a Cylinder ( [image]) - This soft key opens the Construct Cylinder screen.

Construct a Line ( [image]) - This soft key opens the Construct Line screen.

Construct a Point ( [image]) - This soft key opens the Construct Point screen to construct an intersection point, projection point, or mid-point feature out of two line features as inputs.

Copy ( [image]) - This soft key copies the feature that is highlighted (selected) in the measurement routine tree window.

Counter Display Setup ( [image]) - This soft key opens the Counter Display Setup screen. The screen enables you to define what appears on the relevant NC Gage screens for counters.

Create a New Probe ( [image]) - This soft key opens the Create New Probe screen to create a new probe.

Cursor Mode Toggle ( [image]) - There are two cursor modes in the Edit window. The Cursor Mode Toggle soft key switches between the two.

Cut ( [image]) - This soft key removes the highlighted (selected) feature from the measurement routine tree window. You can then paste the feature elsewhere.

Data Back Up ( [image]) - This soft key opens the Data Backup screen.

Define Sphere Tool Information ( [image]) - This opens a screen that you can use to manually enter the values that define the location, size, and orientation of the calibration sphere artifact. You can also learn these values by using the Read Probe Position button.

Define Tolerance Chart ( [image]) - This soft key lets you enter the tolerance class definition screen. For details, see "User Tolerance Chart".

Delete ( [image]) - This soft key permanently removes the highlighted (selected) feature from the measurement routine tree.

Delete Calibration ( [image]) - This soft key deletes the current calibration.

Delete Current Command or Delete Last Created ( [image]) - This soft key deletes the current selected command (or the last created command) from the measurement routine. If this icon is disabled, you may need to delete commands using the Edit Measurement Routine screen instead.

Delete Probe ( [image]) - This soft key deletes the current non-calibrated probe. You cannot use this soft key to remove calibrated probes.

Delete Selected Measurement Routine ( [image]) - This soft key deletes the selected measurement routine from the list.

Direct Connect Mode ( [image]) - This soft key opens the Direct Connect Mode screen and enables you to run an NC Gage measurement routine directly from a cutting macro as if the measurement routine were a subroutine.

Distance ( [image]) - This soft key opens the Distance screen that enables you to dimension the distance between two features.

Edit ( [image]) - To edit a feature, select it from the tree view and press this soft key. The appropriate screen for the selected command you are editing will open in Edit mode.

Edit Measurement Routine ( [image]) - This soft key opens the Edit Measurement Routine screen, where you can execute or edit measurement routines.

Edit Probe ( [image]) - This soft key opens the Edit Probe screen, where you can define a new probe.

Execute ( [image]) - This accesses the Measurement Routine screen, where you can execute the measurement routine.

Execute ( [image]) - This soft key causes the machine to measure the feature. It is available only after all the necessary probe positions to identify the feature location have been learned (or typed in). It enables you to make changes and test run the feature before you commit the feature to the measurement routine.

Execute Block ( [image]) - This soft key causes NC Gage to execute only the feature that is highlighted (selected) in the measurement routine tree window.

Execute from Current Command to the End ( [image]) - This soft key causes NC Gage to execute from the feature that is highlighted (selected) in the measurement routine tree window all the way to the end of the measurement routine.

Execute Measurement Routine ( [image]) - This soft key causes NC Gage to execute the entire measurement routine.

Execute Measurement Routine ( [image]) - This soft key opens the Measurement Routine screen, where you can execute the measurement routine.

Exit ( [image]) - This soft key exits NC Gage. A Yes/No message appears. Press Exit Measurement Routine [image] to exit, or press Back to Main Screen [image] to return to NC Gage.

Export To DatapagePlus ( [image]) - This soft key provides the functionality of exporting the report data to an XML-based output file that can be read into DP+.

File Manager ( [image]) - This soft key opens the File Manager screen, where you can work with measurement routines and save, load, create, and delete them.

Find Center ( [image]) - This soft key causes the software to take sample hits to find the center of the ring before measuring the ring for calibration. See "Find Ring Artifact Adjusting for Runout".

Find Sphere Artifact ( [image]) - If the machine doesn't have a rotary table, rotary head, or wrist, click this button to open the 2D Find Sphere Artifact Adjusting for Runout screen. Select this soft key to initiate the software to take sample hits with spindle orientation to find the center of the sphere before measuring the sphere for calibration. For more information, see "Find Sphere Artifact Adjusting for Runout" . If the machine has a wrist, press the Find Sphere Artifact soft key to open the Find Sphere Artifact for Rotary Axes Calibration screen. When the Confirm soft key [image] is pressed on the Find Sphere Artifact screen, information on the Sphere Calibration screen is automatically be filled in.

Find Sphere Artifact ( [image]) - This soft key displays the Find Sphere Artifact screen used to measure the location, size, and orientation of the calibration sphere artifact. For detailed information, see "Find Sphere Artifact for Rotary Axes Calibration".

Flat ( [image]) - This soft key opens the Measure Flat screen.

Generate Position List ( [image]) - This soft key generates the list of calibration positions based on the values for Start Angle, End Angle, and Number Positions, which are added to the Calibration Positions list.

Go Backward ( [image]) - When enabled, this soft key scrolls back to any additional soft keys that are available on the first page for this screen.

Go Forward ( [image]) - When enabled, this soft key scrolls forward to any additional soft keys available on the second page for this screen.

Go To Beginning ( [image]) - This soft key advances the highlight to the beginning of the measurement routine.

Go To Beginning ( [image]) - This soft key redoes items that were recently undone. You can redo every step until the last time the Edit window was opened.

Go To End ( [image]) - This soft key advances the highlight to the end of the measurement routine.

Help ( [image]) - This soft key opens the NC Gage help file.

in / mm ( [image]) - This soft key toggles the measurement units to display the report and switch between the Inch and Metric systems each time the soft key is pressed.

Information Manager ( [image]) - This soft key shows messages that apply to the connection of NC Gage to the controller and any error messages that NC Gage encounters. For details, see "Information Manager".

Insert Command after Current Position ( [image]) - This soft key adds the command into the measurement routine but places it after the selected command in the measurement routine tree instead of at the end of the measurement routine.

Insert Move Point ( [image]) - This soft key reads the current position of the probe and inserts that as a clearance move into the measurement routine.

Key ( [image]) - This soft key opens the Measure Key screen.

Keyway ( [image]) - This soft key opens the Measure Keyway screen.

Learning and Creating a Command (Execute) ( [image]) - This soft key is available only after all the necessary probe positions to identify the feature location have been learned. It causes the machine to measure the feature.

Load Selected Measurement Routine ( [image]) - This soft key loads the selected measurement routine from the list.

Measure ( [image]) - This soft key opens the Measure screen and provides access to all the features types that can be measured.

Measure Bore ( [image]) - This soft key opens the Measure Bore screen.

Measure Boss ( [image]) - This soft key opens the Measure Boss screen.

Measure Cone Inside ( [image]) - This soft key opens the Measure Cone Inside screen.

Measure Cone Outside ( [image]) - This soft key opens the Measure Cone Outside screen.

Measure Corner Inside ( [image]) - This soft key opens the Corner Inside screen.

Measure Corner Outside ( [image]) - This soft key opens the Corner Outside screen.

Measure Cylinder Bore ( [image]) - This soft key opens the Measure Cylinder Bore screen.

Measure Cylinder Boss ( [image]) - This soft key opens the Measure Cylinder Boss screen.

Measure Line ( [image]) - This soft key opens the Measure Line screen.

Measure Plane ( [image]) - This soft key opens the Measure Plane screen.

Measure Pocket ( [image]) - This soft key opens the Measure Pocket screen.

Measure Point ( [image]) - This soft key opens the Measure Point screen.

Measure Shaft ( [image]) - This soft key opens the Measure Circle (Shaft) screen.

Measure Sphere ( [image]) - This soft key enters the Measure Sphere screen.

Measure Web ( [image]) - This soft key opens the Measure Web screen.

Move ( [image]) - This soft key opens the Move screen for clearance points and planes.

Move Down ( [image]) - This soft key moves the cursor down one item in the Edit window measurement routine tree. If multi-select mode is active, then each entity will be selected and added to the group.

Move Up ( [image]) - This soft key moves the cursor up one item in the Edit window measurement routine tree. If multi-select mode is active, then each entity will be selected and added to the group.

New Measurement Routine ( [image]) - This soft key creates a new measurement routine. It will ask to confirm if you do not want to save any changes made to the current measurement routine.

Password Setup ( [image]) - The Password Setup screen provides a way to enable or disable password protection on all NC Gage setup screens.

Paste ( [image]) - This soft key inserts the cut or copied feature into the measurement routine.

Print ( [image]) - This soft key prints the active calibration report displayed on the screen.

Print Report ( [image]) - This soft key sends the report to your default printing device.

Probe ( [image]) - This soft key shows the probe-related soft keys on the navigation bar, which you can use to create, select, or calibrate a probe.

Read Current Position / Next Step or Read Probe Position and Continue with Next Step ( [image]) - This soft key reads the current probe position and then advances to the next step in the procedure.

Report / View Calibration Report ( [image]) - This soft key enters the Report screen, where you can view measurement reports for your measurement routine, and then save or print them.

Return ( [image]) - This soft key returns the view up one level to the previous screen.

Return to Previous Step ( [image]) - This soft key removes the last learned probe positions.

Save Current Measurement Routine ( [image]) - This soft key saves the current measurement routine with the name specified.

Save Report to RTF File ( [image]) - This soft key saves the current report to an RTF file. The path location of the file will be listed at the top of the screen. The name of the file will be the same as the measurement routine followed by a number that will increment each time the report is saved.

Save Report to RTF File ( [image]) - This soft key saves the calibration file in RTF format to the specified file name.

Scroll Report Down ( [image]) - This soft key scrolls the report view one page down when pressed.

Scroll Report Up ( [image]) - This soft key scrolls the report view one page up when pressed.

Select a Probe ( [image]) - If the Select Probe screen is not the current screen, then this soft key accesses this screen. If the Select Probe screen is already visible, then this soft key scrolls through each probe in the Probe list with each touch of the soft key. Click the Forward button to access the Probe button.

Select a Work Offset ( [image]) - This soft key lets you select a work offset from the Select Work Offset screen to use in the NC Gage measurement routine. This routine is then added and saved with the measurement routine.

Select Diameter Mode ( [image]) - Click to put NC Gage in Diameter Mode. When in Diameter Mode, the Diameter Mode check box on the screen is marked.

Select Measurement Face ( [image]) - This soft key determines the direction of probing and the location of the clearance moves for the feature. You can press this multiple times to choose a different measurement face.

Available faces are: Top, Left, Right, Front, Back, and Skew. If Skew is selected, the soft key icon changes to the Skew icon.

Available faces are: X+, X-, Y+, Y-, Z+ and Z-.

This soft key toggles the Measurement Plane option from the XY plane, YZ plane, and XZ plane each time the soft key is pressed.

Select Work Offset / Select a Work Offset to Update ( [image]) - This soft key selects the named work offset from the list of offsets for updating. Press this again to select the next work offset from the list. This soft key scrolls through the work offset list one by one with each press of the soft key.

Set Coordinate System Rotation ( [image]) - This soft key opens the Set Coordinate System Rotation screen and enables you to change the system rotation when you use the machine outside of NC Gage.

Set One Axis ( [image]) - This soft key accesses the Set One Axis screen.

Set One Axis To Mid Point ( [image]) - This soft key displays the Set One Axis To Mid Point screen.

Set One Axis With Point ( [image]) - This soft key displays the Set One Axis screen.

Set Rotary Axis (Angle) with Flat ( [image]) - This soft key accesses the Set Rotary Axis (Angle) with Flat screen.

Set Rotary Axis (Angle) with Key ( [image]) - This soft key accesses the Set Rotary Axis (Angle) with Key screen.

Set Rotary Axis (Angle) with Keyway ( [image]) - This soft key accesses the Set Rotary Axis (Angle) with Keyway screen.

Set Rotation Angle Axes With Line ( [image]) - This soft key displays the Set Rotary Axes (Angle) screen, which defines and displays all features that generate a well-defined angle in the rotary axis plane using a line.

Set Rotation Axes Angle With Plane ( [image]) - This soft key accesses the Set Rotation Angle With Plane screen, which defines and displays all features that generate a well-defined angle in the rotary axis plane using a plane.

Set Safe Move Height ( [image]) - This button defines the safe height to move to between wrist axis moves. Click this button to automatically update the Safe Rotation Height Parameters value. For more information about this button, see "Using Clearance Planes". Navigate to the second page of the Wrist Head Calibration screen to access this soft key.

Set Three Axes With Sphere ( [image]) - Used to measure a sphere and then use the measured coordinates to update a specified work offset.

Set Work Offsets ( [image]) - This soft key displays a new screen with new soft keys for updating work offsets in various situations. This option updates the work offset on the controller by measuring a selection of features. This routine does not get added to a measurement routine.

Set Wrist Calibration Angles ( [image]) - This soft key sets the wrist axis position angles for the calibration positions. For detailed information, see "Set Wrist Calibration Angles".

Set Two Axes With Bore ( [image]) - This soft key displays the Set Two Axes (Bore) screen.

Set Two Axes With Boss ( [image]) - This soft key displays the Set Two Axes (Boss) screen.

Set Two Axes With Inside Corner ( [image]) - This soft key displays the Set Two Axes (Inside Corner) screen.

Set Two Axes With Outside Corner ( [image]) - This soft key displays the Set Two Axes (Outside Corner) screen.

Setup ( [image]) -This soft key opens the Setup screen, where you can define NC Gage measurement routine settings.

Setup Work Orientation for the Machine ( [image]) - This soft key lets you define what work face you will use in your measurement routine. For details, see "Work Face Setup".

Show Details ( [image]) - This soft key shows the tip offset from the nominal location. This acts the same as enabling the Show Details check box. The offsets are deviation values. The form error is also shown. The form error is the least squares best fit error of the points prior to vector compensation. The tolerances are entered under the Calibration Test Settings button.

Show Details ( [image]) - This soft key shows real-time information about the execution of the measurement routine in DCM.

Stop Executing ( [image]) - This soft key causes NC Gage to stop the execution of the measurement routine.

Switch Focus Between ( [image]) - This soft key toggles the placement of the cursor between different areas of the screen.

System Setup ( [image]) - This soft key enables you to set up the NC Gage screen and exit behavior. For details, see "System Setup".

Tolerance Settings ( [image]) - This soft key lets you set or modify feature nominal and tolerance values used by the feature command. It is an overview of what appears on the Report screen.

Undo ( [image]) - This soft key undoes the previous changes or steps performed while editing the NC Gage measurement routine contained in the Edit window tree view. You can undo every step until the last time the Edit window was opened.

Update Work Offset ( [image]) - This soft key opens the Update Work Offset screen and enables you to update a work offset at the end of a measurement routine.

Write Variable ( [image]) - This soft key opens the Write Variable screen and enables you to write measurement data to a macro variable on the NC control.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Appendix A - Controller Configuration (Okuma)

Home > Using PC-DMIS NC Gage > Appendix A - Controller Configuration

Appendix A - Controller Configuration

You can use the NC Gage Configuration Tool to help configure the controller. The configuration of various controllers in NC Gage is normally done by the person who installs the probe hardware. This topic is for their reference and describes the Configuration Tool.

The Configuration Tool generates a set of probing macros for use on the specific controller type that you select on the initial configuration screen. There also needs to be sufficient memory on the controller to contain the NC Gage macros.

The Okuma controller must be configured using the A MTD mode and NOT the S MTD mode.

Using the Tool

To open the Configuration Tool, do one of the following:

  • Click on the shortcut in the PC-DMIS NC Gage program group after the NC Gage software is installed:

Program group

  • Click on ConfigTool.exe in the NC Gage installation directory.

When you start the Configuration Tool, the following screen appears:

NcGage Configure Tool

  1. Select Okuma from the Control Model list.

  2. Select the appropriate language from the Language list if necessary.

  3. Click the OK button to display the PC-DMIS NC Gage Configuration Tool screen for the controller and language that you selected.

  4. Complete the tabs on the screen.

Tabs

The PC-DMIS NC Gage Configuration Tool screen contains the following tabs:

General tab

Parameters tab

Axis Setup tab

Probe tab

USB Setup tab

Buttons

The following buttons are available on all of the tabs:

  • Use Default - This recalls the saved parameter set in <Output File Name>.dat or OkumaMonitor.cnc.dat by default.

  • Load Configuration - NCGage.dat is the file that NC Gage uses to save all configuration information and is always saved to and loaded from the same folder, allowing you to "import" a configuration. When the Load Configuration button is pressed, a File Open dialog appears, which enables you to search for and load a configuration file that has a different name or is in a different folder.

  • Save Configuration - This saves the current parameter set for ConfigTool.exe in <Output File Name>.dat or OkumaMonitor.cnc.dat by default.

  • Read Machine - When supported, pressing this button will attempt to read machine variables from the control. The control must be connected via Ethernet to the NC Gage computer. The IP address and port number must be correct in the Connection Parameters area on the General tab. The following parameters are read:

    • Tool Offset Type

    • Number of Axes

    • Axis Letters and Offset

    • Controller Type

  • Generate Macro Program - This creates a macro set in the file named in the Output File box on the General tab.

  • Upload Program - When supported, pressing this button attempts to upload the generated macro set to the controller. The controller connection must be properly set as referenced in Read Machine and Connection Parameters. The controller must be in Edit mode. The Macro area chosen for generation must write-enabled.

  • Exit - Exits the NC Gage Configuration Tool.

Communication Status Bar

This bar appears along the bottom of the PC-DMIS NC Gage Configuration Tool screen. It displays messages about the communication success or failure status between the controller and machine after you press the Read Machine or Upload Program button.

Files

  • NcGage.dat - The machine setup for NC Gage is contained in an XML-based text file called NcGage.dat, which NC Gage uses for the machine configuration. This file is generated after you click the Save Configuration button.

The NcGage.dat name is fixed. You can change the output file name in the tool's Output File box. The restore file name is derived from the output file name by appending '.dat'.

  • OKUMAMonitor.min - This file is the Monitor Macro file. It is generated when you click the Generate Macro Program button. This file is saved in the D:\MD1\ folder of the controller.

  • OkumaMonitor.cnc.dat - This file restores the Configuration Tool's settings.

  • OKUMAMonitor.ssb - This file is the Monitor Macro subroutines file. It generates when you click the Generate Macro Program button. This file is saved to the D:\MD1\ folder on the controller.

  • OKUMA.ini - This file records the Encryption Key Settings for the Okuma Remote Interface. It generates when you click the Save Configuration button if you select okumaRemote in the Controller Type list on the General tab.

  • Header Script file and Controller Script file - These files are already defined for the particular controller configuration. They shouldn't need to be changed.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


General Tab

The General tab for the NC Gage Configuration Tool is shown below:

General tab

Unit - Select the appropriate option for MM or inch units of measure (MM or Inch). These are the units setting on the machine. Note that NC Gage will work in the unit settings of the controller.

Machine Name - Enter the name of the machine in your system.

Controller Type - Select a controller type from the list. The options are:

  • okumaLocal

  • okumaRemote

  • okumaMillturnLocal

  • okumaTest (Simulator)

IP Address - This is the Internet Protocol (IP) address of the controller. This unique address identifies the controller on your computer network. You must ensure that the computer uses the same [image] [image] subnet mask as the controller by using a [image] [image] ping test to verify connectivity. You can test this by pinging the controller if NC Gage is installed on a separate computer. On some systems, the IP address of the computer must be only one digit different than the IP address of the machine tool. For example, if the machine tool's IP address is 192.168.0.1, then the computer's IP address will need to be set to 192.168.0.2. The IP address for the Simulator is 127.0.0.1.

Ping Test: To do a ping test, open a Command Prompt window and type "ping" followed by the IP address of the controller. When you press ENTER, the test will attempt to establish a temporary connection to the controller. If it fails you will see a "request timed out." message displayed in the command prompt window.

Subnet Mask: Have your IT support personnel set this to be the same as the controller.

Port - If you select the Ethernet communication option, the Port option defines the port number of the controller. Ports control the information that is allowed from the connected computers.

Encryption Key - An optional 8-character (64-bit) encryption key that is used for enhanced network traffic encryption in Okuma Remote API. You can get it from the Okuma EBTAPI Service Management application in the machine control.

Okuma EBTAPI Service Management application

Output File - This is the name of the output macro file that is created when you click the Generate Macro Programbutton. Note that this file name with .dat extension is also the data file for the Restore button operation. You should not change it.

Coordinate Rotation Macro # - Select this check box if you want to do Coordinates Rotation work in NC Gage.

Spindle Positioning - Put the machine code here to orient the spindle. If the machine does not have the capability, clear the contents of this option. A variable appends to the supplied code and contains the angle. For example:

  • Supplied Code: M19RS

  • Generated Code: M19RS#1

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Parameters Tab

The Parameters tab for the NC Gage Configuration Tool is shown below:

Parameters tab

Speed Area

Fast Probing Feed Rate (mm/minute) - This sets the maximum speed at which the probe moves when not probing. The unit is mm/minute or inches/minute based on the unit you select from the General tab. If it is mm/minute, the default value is 3000. If it is inches/minute, the default value is 120.

Slow Probing Feed Rate (mm/minute) - This sets the speed the probe moves when searching for a surface. The unit is mm/minute or inches/minute based on the unit you select from the General tab. If it is mm/minute, the default value is 100. If it is inches/minute, the default value is 4.

Fast Rotary Feed Rate (mm/minute) - This sets the maximum speed for all rotary axes including spindle heads and rotary tables. The unit is mm/minute or inches/minute based on the unit you select from the General tab. If it is mm/minute, the default value is 1000. If it is inches/minute, the default value is 40.

Address Area

Variables Base - This is the starting address for variables used by NC Gage to transfer information. Currently, NC Gage uses 31. This information does not need to be saved prior to shutting down the controller.

Settings Base - This is the starting address for variables used by NC Gage, which establish constants for motion, probing, and tools. NC Gage currently uses 11. The information should be saved prior to shutting down the controller.

Program Number - This sets the address for the generation of the monitor macro.

Tool Area

Tool Offset Type - This separates different methods to record the tool length on a machine control.

    • Select A if your machine only has geometry length but not wear length for tool length management. The difference is added to the geometry length.

    • Select B or C if your machine has both geometry and wear length for tool length management. The difference is added to the wear length.

Reference Zero Offset Area

Note: This area is only available if you select the MULTUS, VTM, or Machining Center option from the Controller Type list on the General tab.

This area sets the reference zero for the machine coordinate system. Usually, the spindle center is set as X-axis zero and the chuck end-face position is set as Z-axis zero.

In the left-side column of the area, you can set the X, Y, and Z coordinates for the main spindle.

In the right-side column of the area, you can set the X, Y, and Z coordinates for the sub spindle. This column is not available if you select the Machining Center option from the Controller Type list on the General tab.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Axis Setup Tab

The Axis Setup tab provides a way to define, view, or edit the rotary configuration information. You can use it to edit certain features of the non-linear axes configuration settings.

The Axis Setup tab for the NC Gage Configuration Tool is shown below:

Axis Setup tab

Enable - For each axis, you must set an Enable field. A minimum of three axes is required. The Read Machine button populates the known axes and axis letters when supported. The X, Y, and Z axes are always set and cannot be removed.

In the box, you can type the axis name that you want to display in the list. To add the axis name to the list, click Add. To remove the axis name from the list, click Remove. To move any axis name higher in the list, click Up. To move any axis name lower in the list, click Down.

Kinematics Type - The type can be Linear, Rotary, or Wrist. The Linear is the default type.

If you select the Rotary type, the Axis Setup tab changes to look like this:

If you select the Wrist type, the Axis Setup tab changes to look like this:

For machines that have one or more wrist axes (millturn and machines with two heads), the Probe Direction (Tip to Spindle) When Wrist At 0 list appears. This defines the direction that the probe points when all wrist angles are at zero. (This is up the probe's centerline or down - away from - the probe.)

The NC Gage Configuration Tool defines axes setup as XYZBC, where B is the wrist type and C is the rotary table type.

For more information on the Rotary and Wrist types, see "Rotary and Wrist Types" below.

Address Offset - This sets the offset in the axes map. For example, if a machine has XYZ linear axes and a B axis rotary table, the offsets might be 1, 2, 3, 4. Often, there are slave axes not included in the configuration, which causes skips in the axes map. So, the same machine may have a map of 1, 3, 4, 5, for example.

Limit - The limit information is in machine coordinates. This defines the range of motion. If these are not known, then you should leave them blank.

NCGage Axis - This sets the axis identifier to X, Y, Z, U, V, W, A, B, C, or None. Typically, linear systems are based on the X, Y, and Z identifiers, while rotary systems are identified by A, B, and C.

Machine Part - This lists the following options to determine the spindle: Main Spindle, Sub Spindle, Lower Turret, Upper Turret, Inter Changeable Head, Primary Axis, and Unknown.

Unlock and Lock - These user-defined strings define the commands that unlock (or unclamp) the axis prior to movement and lock (or clamp) the axis after movement. These strings are optional and used for rotary axes.

Two Turrets - Select this check box if your machine contains two turrets.

M423 and M323 - Select M423 or M323 based on your machine's macro.

Rotary and Wrist Types

The following options are only available if you select Rotary or Wrist from the Kinematics Type list. To configure a rotary table in a system:

  • Mark the appropriate Enable check box.

  • From the Kinematics Type list, select the Rotary option.

  • Select the axis associated with each rotary table from the appropriate NCGage Axis list. The options are A, B, C, U, V, W, X, Y, Z, and None.

  • If a stacked rotary table is used, select the order from the Rotary Table Position list. This option is available if you define two rotary tables.

Reference Tool Length - This measures the center position of the lower rotary table. This also calculates the z value for the A or B axis rotary center. The default value is zero.

This option is only available for the Machining Center controller.

  1. On the General tab, from the Controller Type list, select Machining Center.

  2. On the Axis Setup tab:

    1. From the Kinematics Type list, select Rotary.

    2. From the Rotary Table Type list, select Stacked Table.

    3. From the Rotary Table Position list, select Lower.

Pivot X, Pivot Y, and Pivot Z - These set the point of rotation on the x-axis, y-axis, and z-axis.

Pivot - Select an option to define the wrist pivot type from the list. The options are Wrist Center and Wrist Zero.

Distance - Enter the pivot distance for the wrist.

Probe Direction (Tip to Spindle) When Wrist At 0 - If you are defining a wrist (as in a millturn machine), you must specify the direction of the wrist probe (defined from tip to spindle) when the wrist is at the 0 (zero) position. This option is hidden until you select a wrist from the Kinematics Type list. The options are ZPlus, ZMinus, YPlus, YMinus, XPlus, and XMinus.

The Rotary Table Position list is only available on the Axis Setup tab of the Configuration Tool when you define two rotary tables. If you define a Rotary Table and Wrist (as for a millturn machine), the Rotary Table Position list is replaced with the Probe Direction (Tip to Spindle) When Wrist At 0 and Pivot areas as shown below.

If this case does not apply, the area does not appear. If you define a wrist for a millturn machine, you must set it to the B axis and set the rotary table to the C axis.

The NC Gage Configuration Tool defines axes setup as XYZBC, where B is the wrist type and C is the rotary table type.

Rotate I, Rotate J, and Rotate K - These define the direction of rotation of the x-axis, y-axis, and z-axis.

Clockwise - This defines the direction of rotation that the tables spin for positive increments. To rotate the table clockwise, select the Clockwise check box. For illustrated definitions, see "Rotation Illustrations" below.

Rotary Table Type - This sets the number of tables for the machine part. From the list, select either Single Table or Stacked Table.

Single Table - Select this option if you have one rotary axis for the machine part.

Stacked Table - Select this one if you have two rotary axes for the machine part.

Rotary Table Position - This defines the table for the measurement. If more than one rotary table is defined, you must specify the stacking order of the rotary tables. This option is only available if you select Stacked Table from the Rotary Table Type list. The options for the selection are derived from the two axes defined in the table. Internally, NC Gage keeps this setting by saving the “dominant” axis, which is defined as the “lower” table. From the list, you can select either Upper Table or Lower Table.

Rotation Illustrations

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Probe Tab

The Probe tab for the NC Gage Configuration Tool is shown below:

Probe tab

Enable Probe Macro - This is the macro code required to enable the probe.

Load Probe Macro - This is the macro code required to load the probe.

Start Program Macro - These are the macro codes that need to be executed at the start of the macro program.

Disable Probe Macro - This is the macro code required to disable the probe.

Move Test Macro - This is the macro code required to test that the probe is turned on and able to move.

End Program Macro - These are the macro codes that need to be executed at the end of the macro program.

Completing the Okuma Configuration

Once all the screens have been configured as required for the system, press the Save Configuration button to generate the NCGage.dat. Next, press the Generate Macro Program button to generate the OKUMAMonitor.MIN and OKUMAMonitor.SSB files. The OKUMAMonitor.MIN and OKUMAMonitor.SSB files will be generated and saved in the D:\MD1\ directory of the machine control of the local interface. This work should be done manually in the Remote Interface configuration using a shared folder.

Additional Information

The THINC-API is an Application Programming Interface that you can use to access machine data on Okuma THINC controls. It needs to be installed on the machine control for Local and Remote interface.

Install THINC API version 2.0 on the machine control for Remote interface in the "Control Panel\All Control Panel Items\Administrative Tools\Service" of the control.

As shown below, the Event-Based THINC API is started automatically when the control starts up.

Event-Based THINC API

Open a Command Prompt window, and test the status of the network to verify the 8007 port is listed.

Command Prompt window

If NC Gage does not connect to the control, you may need to contact your local IT administrator to check the firewall exceptions on both sides.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


USB Setup Tab

The USB Setup tab for the NC Gage Configuration Tool lets you configure the US0 and US1 ports on the Okuma controller. This tab is shown below:

USB Setup tab

USB Area

US0 - This option contains the Detect US0 button. Once you insert the USB drive in the US0 port, click the Detect US0 button. It displays the physical address on the right side of the button. For example: Port_#0001.Hub_#0001

US1 - This option contains the Detect US1 button. Once you insert the USB drive in the US1 port, click the Detect US1 button. It displays the physical address on the right side of the button. For example: Port_#0002.Hub_#0002

Once you are done with the configuration, click the Save Configuration button. After you finish the configuration, in the Saved Path box of the Setup screen, use US0 or US1. For example, US1:\<directory>, where <directory> is the location to where the report is saved.

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●


Set Probe Length

The Set Probe Length screen calculates the length of the probe. This can be done anytime.

  1. Press the Probe soft key [image] on the main screen.

  2. Press the Set Probe Length [image] soft key to display the Set Probe Length screen:

  3. Select a work offset in the Work Offset list.

  4. In the Target box in the Parameters area, type the expected height of the surface, relative to the current work offset.

  5. Type a value for the Prehit Distance and Search Distance in the Motion Parameters area.

  6. Position the probe over the surface.

  7. Press the Read Probe Position soft key [image].

  8. Press the Execute soft key [image]. The probe measures the surface at the target value. Based on the touched location and the location of the probe spindle in 3D space offset from the surface, NC Gage can then calculate the length of the probe. The measured Z value, probe length, and Z offset values appear in the read-only text boxes. The Current values show the probe length and Z offset values without the change. The New values are what the probe length and Z offset will be after the change is applied.

The probe length values are measured to the bottom of the probe. The Z offset values are measured to the center of the probe.

  9. Press the Confirm soft key [image] to save the probe length for use with the calibration or press the Return soft key [image] to return to the previous screen without saving.

All the other items on this screen contain read-only information about the probe.

For more information on navigation bar soft keys, see "Navigation Bar Soft Keys".

3.2
NC Gage

Contact the Documentation Team

Support Links

>> Knowledge Base

>> Technical Support

>> Forum

>> Ideas

>> Training ●

>> Regional Offices ●