使用 PC-DMIS NC Gage

NC Gage簡介

授權

設定

入門

建立特徵命令

設定其他特徵參數

插入移動命令

使用測量程式

管理檔案

使用報告

使用螢幕小鍵盤

直接連接模式 (DCM)

附錄 A - 控制器設定


NC Gage簡介

PC-DMIS NC Gage 提供易於使用的產品，以使用 NC 測量機工具在線上測量工件。透過提供可讓您將所需特徵測量和其他命令插入測量程式的使用者介面，NC Gage 可增強測量機工件產能和精確度。

術語註：因為很多使用者在觸控式螢幕顯示上運行 NC Gage， 所以使用在文件中的術語「選取」或「按」表示在帶有滑鼠和鍵盤附加的週邊裝置的 PC 上運行軟體時的滑鼠按鍵。

此文件討論以下主要內容：

  • 授權

  • 設定

  • 入門

  • 建立特徵命令

  • 設定其他特徵參數

  • 插入移動命令

  • 使用測量程式

  • 管理檔案

  • 使用報告

  • 直接連接模式 (DCM)

  • 附錄 A - 控制器設定

說明檔上次更新日期：2016年1月8日


授權

使用前，您必須獲得 NC Gage 應用程式的授權。成功完成安裝後，首次啟動 NC Gage 時可執行上述操作。

  1. 透過下列方法之一可啟動 NC Gage 應用程式：

    • 從程式群組中選取 PC-DMIS NC Gage。

    • 按一下視窗的啟動按鈕，導覽所有程式，然後從已定義的程式群組中選取 PC-DMIS NC Gage 測量程式圖示。

    • 按兩下 PC-DMIS NC Gage 桌面捷徑圖示：

首次啟動 NC Gage 應用程式時，將顯示以下 NC Gage 授權錯誤：

  2. 選取是按鈕，顯示 NC Gage 授權要求螢幕：

  3. 必要時，填寫欄位。帶紅色星號 (*) 的欄位為必填欄位。填寫所需欄位後，下一步按鈕變為可用狀態。

  4. 按一下下一步按鈕，產生如下所示的 NC Gage 授權要求：

  5. 按一下另存新檔按鈕，儲存檔案的授權要求文字。螢幕上將顯示另存新檔螢幕。

巡覽本機或網路磁碟機上的安全位置，並儲存檔案。該檔案會被另存新檔為 NCGageLicense.request。

  6. 按一下結束按鈕，關閉 NC Gage 授權要求螢幕。

  7. 傳送授權要求檔案給有助於取得授權檔案處理序的 Hexagon 代表。

  8. 授權檔案送達後，將它存入 PC。注意檔案儲存的位置。

  9. 啟動 NC Gage 應用程式。螢幕上將出現 NC Gage 授權錯誤。

  10. 按一下是按鈕，顯示初始 NC Gage 授權要求螢幕。

  11. 按一下我有授權按鈕，顯示 NC Gage 授權要求螢幕：

要從授權要求檔案匯入授權資訊，請執行以下作業：

  1. 選取 NC Gage 授權要求螢幕上的匯入授權檔案選項。

  2. 按一下瀏覽按鈕 (...)，顯示開啟螢幕：

  3. 巡覽至並選取本機或網路磁碟機上的授權檔案 (NCGageLicense.lic)。

  4. 按一下開啟按鈕，讀取 NC Gage 授權要求螢幕上的授權檔案資訊：

  5. 按一下繼續按鈕，完成授權程序。


設定

使用 NC Gage 之前，需按照測量機工具設定對其進行設定。通常是由安裝測頭硬體的人員來做此工作。

有關控制器設定的詳細說明，請參閱「附錄 A - 控制器設定」。

備註： NC Gage 需要電腦上安裝 .NET 2.0 以運行 NC Gage。如果已經安裝 .NET 2.0，那麼在 NC Gage 需要時才安裝它。如果沒有安裝 .NET 2.0，那麼安裝常式將詢問使用者是否要現在下載並安裝它。按確定會將您連結到可以下載並安裝 .NET 2.0 的 Microsoft 網站。

Windows OS 備註：如果用虛擬機器公用程式以非英文的其他語言來運行 NC Gage（例如：VMWare），Windows OS 會自動挑選、更新虛擬機器用戶端的地區╱語言設定（例如：句點會變更為逗號）。如果從外語切換回英文， 那麼需要在 Windows OS 控制台內使用地區和語言設定手動重設上述變更以防止出現測量錯誤。

更新 Windows 地區和語言設定

  1. 巡覽至控制台：

  2. 按一下地區和語言。如有必要，請在地區和語言螢幕中作出變更：

  3. 按一下：

    • 確定，接受所做的變更並返回控制台

    • 取消，結束而不進行儲存

    • 套用，儲存所做的變更，不用結束

  4. 按一下其他設定。為特定的地區和語言設定作出必要的變更：

  5. 按一下：

    • 確定 ，儲存在自訂格式螢幕上所做的變更，並返回地區和語言螢幕

    • 取消 ，結束而不進行儲存

    • 套用，儲存所做的變更，不用結束

轉至「入門」。


入門

這些主題可幫助您開始使用 PC-DMIS NC Gage。開始前：

  • NC 測量機應接通電源。

  • 應安裝 NC Gage，並且 NC Gage 應獲得授權。

  • 軟體應已設定。有關更多資訊，請參閱「附錄 A - 控制器設定" 。

步驟包括：

  • 第 1 步：啟動和連接軟體

  • 第 2 步：設定NC Gage參數

  • 第 3 步：建立新的測頭

  • 第 4 步：選取測頭

  • 第 5 步：校驗

  • 第 6 步：定義工作偏移

  • 第 7 步：定義控制框架

  • 第 8 步：定義安全路徑

關於系統訊息

因為您透過上述步驟進行工作，所以請注意 NC Gage 主螢幕中系統訊息區域裡的資訊：

範例系統訊息區域

  • 紅色文字裡顯示的訊息表示所需程序還未完成或出現一些其他問題。

  • 在您能開始測量工件前，警告訊息將告訴您下一步需要做什麼。

  • 當您完成所需步驟時，系統訊息區域中的項目將顯示為藍色文字。

一旦您完成上述步驟，您可使用 NC Gage 建立和執行測量程式。

導覽列螢幕按鍵

主螢幕導覽列上的螢幕按鍵列在以下表格中。觸摸任何螢幕按鍵即可開啟與該螢幕按鍵相關的功能螢幕或執行指定的動作。

術語註：螢幕按鍵 是控制器螢幕底部可觸摸的按鈕，此控制器螢幕對應每個螢幕上不同的功能。有些螢幕上有多重螢幕按鍵「頁面」。您可使用向後或向前螢幕按鍵，導覽這些螢幕按鍵頁面。

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
設定 此螢幕按鍵可開啟設定螢幕，在該螢幕上您可定義 NC Gage 測量常式設定。 | 測頭 此螢幕按鍵可顯示導覽列上與測頭有關的螢幕按鍵，透過這些按鍵 可建立、選取或校驗測頭。
移動 此螢幕按鍵可開啟安全點和平面的移動螢幕。 | 移動旋轉軸 此螢幕按鍵可開啟移動旋轉軸螢幕，您可在此螢幕上設定旋轉軸。
選取工作偏移 — 第一頁 使用此螢幕按鍵可從選取工作偏移螢幕中選取工作偏移以在 NC Gage 測量程式中進行使用。然後，此程式被新增並與測量程式一起儲存。 | 測量 此螢幕按鍵可開啟測量螢幕，從而存取可測量的所有特徵類型。
執行測量程式 此螢幕按鍵可開啟測量程式螢幕，在該螢幕上您可執行測量程式。 | 檔案管理器 此螢幕按鍵可開啟檔案管理器螢幕，在該螢幕上可操作測量常式，包括儲存、載入、建立和刪除。
報告 此螢幕按鍵可進入報告螢幕，在該螢幕上可檢視、儲存或列印測量常式的測量報告。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。
退出 該螢幕按鍵可結束 NC Gage。螢幕上將出現是/否訊息。按結束測量程式 [image] 結束，或者按返回主螢幕 [image] 返回 NC Gage。 | 編輯測量程式 此螢幕按鍵可開啟編輯測量常式螢幕，在該螢幕上您可執行或編輯測量常式。
直接連接模式 此螢幕按鍵可開啟直接連接模式螢幕。這可讓您從切割巨集直接運行 NC Gage 測量程式，好像測量程式係副程式。 | 設定工作偏移 — 第二頁 透過測量選取的特徵，此選項可更新控制器上的工作偏移。然後，此程式未被新增至測量程式。
資訊管理器 — 第二頁 此螢幕按鍵可顯示將 NC Gage 連接套用至控制器的訊息以及 NC Gage 遇到的任何錯誤訊息。 |


啟動並連接軟體

Home > 使用 PC-DMIS NC Gage > 入門 > 第 1 步：啟動並連接軟體

第 1 步：啟動和連接軟體

安裝 NC Gage 應用程式並獲得其授權後，透過下列方法之一啟動 NC Gage 應用程式：

  • 從程式群組中選取該應用程式

  • 啟動 Windows，按一下啟動按鈕，指向所有程式，然後從已定義的程式群組中選取 PC-DMIS NC Gage 程式圖示：

NC Gage 的主螢幕將開啟：

首次開啟 NC Gage 時，NC Gage 會嘗試與您的機器工具連接。有關此連接的資訊顯示在狀態區域中。

若導覽列中間的狀態螢幕按鍵為紅色，則表示軟體無法與機器連接：

當 NC Gage 連接至機器時，它會在螢幕上顯示測頭位置坐標。導覽列中部的狀態螢幕按鍵將變綠，並在狀態區域內顯示「已連接」。

如果這是您首次啟動 NC Gage，系統訊息區域中的校驗選項會顯示「--無--」。此外，導覽列上的測量 [image] 和移動 [image] 螢幕按鍵將被停用（變灰，無法選取）。這表示您需要在使用軟體建立測量程式及測量工件之前採取一些預備步驟。

您需要解決的下一個項目列於系統訊息區域的警告：訊息中。


設定 NC Gage參數

Home > 使用 PC-DMIS NC Gage > 入門 > 第 2 步：設定NC Gage參數

第 2 步：設定NC Gage參數

按主螢幕上的設定螢幕按鍵 [image] ，顯示設定螢幕：

使用此螢幕可定義測量期間所用的多個測量和硬體參數。

要修改一般 NC Gage參數：

  1. 根據需要修改值。

  2. 按確認螢幕按鍵 [image] 以儲存變更。或者，按返回螢幕按鍵 [image] ，結束此螢幕，而不進行儲存。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
定義公差圖表 此螢幕按鍵可讓您進入公差等級定義螢幕。有關詳細資料，請參閱「使用者公差圖表」。 | 設定機器的工作方向 此螢幕按鍵可讓您定義將於測量程式中使用的工作面。有關詳細資料，請參閱「工作面設定」。
系統設定 此螢幕按鍵可讓您設定 NC Gage 並結束操作。有關詳細資料，請參閱「系統設定」。 | 動力學設定 透過動力學設定螢幕可檢視旋轉設定資訊。您可使用該螢幕來編輯旋轉軸的某些設定。
密碼設定 密碼設定螢幕可用來啟用或停用對所有 NC Gage設定螢幕的密碼保護。 | 計數器顯示設定 計數器顯示設定螢幕可讓您定義相關 NC Gage 計數器螢幕上顯示的內容。
套用或確認變更 此螢幕按鍵可接受對目前螢幕上任何選項、設定或選取作出的變更。在某些情況下，此螢幕按鍵可將命令新增至 NC Gage 測量常式。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。
返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。 |

「公差」區域

  • 正差 – 表示評估工件尺寸時所採用的預設正公差值。

  • 負差 – 表示評估工件尺寸時所採用的預設負公差值。

  • 設定這些值可透過使用該螢幕上的選取通用公差限制清單指定在任何特徵的公差螢幕上重新叫用所需的公差。您可以採用這種方法快速地重複選取並輸入相同的公差值。請參閱「使用者公差圖表」。

「報告儲存選項」區域

  • 儲存的路徑 - 指定檔案將被儲存的位置。測量程式也將以相同的路徑儲存至子目錄 PRG 中。

  • 自動儲存 - 若清除此核取方塊，當執行測量程式時，NC Gage 不會自動儲存報告；您必須手動儲存這些報告。若選取此核取方塊，覆寫和時間戳記選項將變為可用狀態。選取所需的選項：

    • 覆寫 - 若選取此選項，NC Gage 會自動儲存為儲存的路徑指定的位置的第一個報告。NC Gage 會在下次您建立報告時取代此報告。

      每個報告都擁有相同的檔名。格式為：<測量程式>.rtf，其中<測量程式>係執行的最後一個測量程式的名稱。

    • 時間戳記 - 若選取此選項，NC Gage 會自動儲存為儲存的路徑指定的位置的每個報告。NC Gage 不會取代任何已儲存的報告。

      每個報告都擁有不同的檔名。格式為：<測量程式>_<M>-<DD>-<YY>_<hh>-<mm>-<ss>.rtf，其中：

<測量程式> - 目前載入的測量程式的名稱（不帶 ".prg" 副檔名）

<M> 或 <MM> - 月份（一位數或兩位數），基於電腦系統之日期

<DD> - 日（兩位數），基於電腦系統之日期

<YY> - 年份（四位數），基於電腦系統之日期

<hh> - 儲存報告之小時（兩位數）（24 小時時間），基於電腦系統之時間

<mm> - 儲存報告之分鐘（兩位數）（24 小時時間），基於電腦系統之時間

<ss> - 儲存報告之秒鐘（兩位數）（24 小時時間），基於電腦系統之時間

注意，檔名的 21 小時時間戳記標記表示報告儲存的時間（不是測量程式執行的時間）。因此，若連續儲存相同的報告，每個報告將擁有不同的檔名。

備註：您可隨時手動儲存報告，無論如何設定報告選項。手動儲存的報告的檔名格式為：<測量程式>_<MM>-<DD>-<YY>_<hh>-<mm>-<ss>.rtf

「進給速率和觸測距離」區域

  • 週游（進給速率） - 確定測頭在測量程式區塊之間的移動速度。基於所選單位，單位將為毫米/分鐘或英吋/分鐘。

  • 尋找（進給速率） - 確定測頭在學習模式中探索特徵時的移動速度。基於所選單位，單位將為毫米/分鐘或英吋/分鐘。

  • 旋轉（進給速率）- 確定最大的允許軸旋轉速度。

  • 預測點（觸測距離） - 指定在採集測點之前理論測點位置與測頭將要移動的位置之間的距離。可於工件測量期間使用。基於所選單位，單位將為毫米或英吋。

  • 搜尋（觸測距離） - 提供測頭將要搜尋表面的距離。如果在達到此距離之前測頭與表面未接觸，測量將失敗。基於所選單位，單位將為毫米或英吋。

「捕捉十進位精度」區域

  • 尺寸貼齊值 - 可使 NC Gage 對學習過程中由測頭找到的任何特徵的標稱結果進行四捨五入。可採用兩種準則對結果執行四捨五入。首先，可將結果四捨五入為此欄位中的十進位值。其次，可將結果四捨五入為此欄位中最接近的倍數。

    例如，如果結果為 0.068，此方塊中的值為 0.03，則程序如下：首先，0.068 將被四捨五入為兩個小數位數，得到的結果為 0.07。其次，接下來，這個值將被四捨五入為 "3" 的最接近範圍，即將 0.07 變更為 0.06，因為 "6" 是 "3" 的倍數。

  • 角度貼齊值 - 與尺寸貼齊值採用相同的原理，但是角度測量除外。

「統計儲存選項」區域

  • 儲存的路徑 - 指定統計資料（每個特徵的結果）儲存的位置。測量程式也將以相同的路徑儲存至子目錄 PRG 中。

  • 自動儲存 - 若清除此核取方塊，當執行測量程式時，NC Gage 不會自動儲存統計資料；您必須手動儲存這些報告。若選取此核取方塊，覆寫和時間戳記選項將變為可用狀態。選取所需的選項：

    • 覆寫 - 若選取此選項，NC Gage 會自動儲存為儲存的路徑指定的位置的第一組統計資料。NC Gage 會在下次您建立統計資料時取代此統計資料。

      每組統計資料都擁有相同的檔名。格式為：<測量程式>.rtf，其中<測量程式>係執行的最後一個測量程式的名稱。

    • 時間戳記 - 若選取此選項，NC Gage 會自動儲存為儲存的路徑指定的位置的每組統計資料。NC Gage 不會取代任何已儲存的統計資料。

      每組統計資料擁有不同的檔名。格式為：<測量程式>_<M>-<DD>-<YY>_<hh>-<mm>-<ss>.xml，其中：

<測量程式> - 目前載入的測量程式的名稱（不帶 ".prg" 副檔名）

<M> 或 <MM> - 月份（一位數或兩位數），基於電腦系統之日期

<DD> - 日（兩位數），基於電腦系統之日期

<YY> - 年份（四位數），基於電腦系統之日期

<hh> - 儲存統計資料之小時（兩位數）（24 小時時間），基於電腦系統之時間

<mm> - 儲存統計資料之分鐘（兩位數）（24 小時時間），基於電腦系統之時間

<ss> - 儲存統計資料之秒鐘（兩位數）（24 小時時間），基於電腦系統之時間

注意，檔名的 24 小時時間戳記標記表示統計資料儲存的時間（不是測量程式執行的時間）。因此，若連續儲存相同的統計資料組，每組將擁有不同的檔名。

備註：您可隨時手動儲存一組統計資料，無論如何設定統計選項。手動儲存的一組統計資料的檔名格式為：<測量程式>_<MM>-<DD>-<YY>_<hh>-<mm>-<ss>.xml


使用者公差圖表

使用使用者公差圖表螢幕可透過使用此螢幕上的選取通用公差限制清單指定在任何特徵的公差螢幕上進行重新叫用所需的公差。您可以採用這種方法快速地重複選取並輸入相同的公差值。

要定義使用者公差：

  1. 按主螢幕上的設定螢幕按鍵 [image] 。

  2. 按定義公差圖表螢幕按鍵 [image] ，顯示使用者公差圖表螢幕：

  3. 要獲取所需的 TC 類別，請鍵入+限制或-限制公差值。

  4. 定義 TC 類別之後，按套用變更螢幕按鍵 [image] 。然後即可從公差螢幕中選取這些 TC 類別。


工作面設定

使用工作面設定螢幕可定義在整個軟體中找到的工作面螢幕按鍵的方向。工作面為將要測量的工件的側邊。若顯示 NC Gage 的電腦監視器並非始終處於機器工具週圍的固定位置，則可使用此設定螢幕。使用此螢幕可自訂工作面圖示的設定，或者選取預設的工作面設定。

要設定工作面：

  1. 按主螢幕上的設定螢幕按鍵 [image] 。

  2. 按設定機器的工作面方向螢幕按鍵 [image] ，顯示工作面設定螢幕：

  3. 選取預設的設定，或定義您自己的自訂設定。

  4. 定義工作面之後，請按確認螢幕按鍵 [image] 。此後在整個軟體中，每次按下工作面螢幕按鍵，軟體即會使用此處定義的工作面。

  5. 按一下確認螢幕按鍵 [image] 以儲存所作的所有變更。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

備註：允許左手操作設定。當您採用這個非標準設定時，NC Gage 將會通知您。


系統設定

系統設定螢幕提供：

  • 螢幕設定區域中的 NC Gage 螢幕的控制設定

  • 關於如何在結束操作區域中關閉 NC Gage 應用程式的選取

要設定系統：

  1. 按主螢幕上的設定 螢幕按鍵 [image] 。

  2. 按系統設定螢幕按鍵 [image] ，顯示系統設定螢幕：

「螢幕設定」區域

允許重新定位 - 在顯示螢幕上的任意位置重新定位 NC Gage 螢幕。

允許調整大小 - 調整 NC Gage 螢幕的大小。

允許最小化 - 最小化 NC Gage 螢幕。

「結束操作」區域

結束 - NC Gage 應用程式僅可在從 NC Gage 介面中啟動時方可結束。

登出 - NC Gage 應用程式將於從 NC Gage 介面中啟動時結束，但同時會登出目前的 PC 使用者帳戶。

關機 - NC Gage 應用程式將於從 NC Gage 介面中啟動時結束，但同時會關閉 PC。

執行檔案 - NC Gage 應用程式將於從 NC Gage 介面中啟動時結束，但之後會執行已選取的檔案。

按確認螢幕按鍵 [image] 以儲存所作的所有變更。或者，按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。


密碼設定

使用密碼設定螢幕設定 NC Gage 應用程式的密碼，防止對系統設定作未授權的變更。

  1. 按主螢幕上的設定 螢幕按鍵 [image] 。

  2. 按密碼設定螢幕按鍵 [image] ，顯示密碼設定螢幕：

  3. 按確認螢幕按鍵 [image] 以儲存所作的所有變更。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

停用密碼保護 - 選取此選項可停用所有系統密碼保護。設定密碼區域變為停用狀態並顯示為灰色。

需變更設定值的密碼 - 選取此選項可啟用系統密碼保護。設定密碼區域變為啟用狀態，可讓您輸入密碼資訊。

「設定密碼」區域

輸入密碼 - 輸入用於保護系統設定免受變更的密碼。

驗證密碼 - 再次輸入密碼，將密碼鍵入輸入密碼方塊以供驗證。


動力學設定

透過動力學設定螢幕可檢視旋轉設定資訊。您可使用該螢幕來編輯以下所述的非線性軸組態設定的某些特定特徵。一開始就應在 NC Gage 設定工具公用程式中定義旋轉臺或測座資訊。

動力學設定螢幕可受密碼保護，防止未授權就進行變更。在測量機設定工具公用程式內至少有一個旋轉臺組態了系統時才可使用此螢幕。

啟動 NC Gage 應用程式前，測量機介面上必須擁有必要的控制資訊。您必須使用 NC Gage 設定工具來定義以下參數：

  • 軸 - 定義 X、Y、Z、A、B 或 C 系統軸。

  • 偏移 - 定義軸系統變數表中的索引。

  • 軸類型 - 選取「線性」、「旋轉臺」和「測座」選項。未來版本將提供主軸選項。

  • 開始和結束限制 - 定義允許的移動範圍。

  • 解除鎖定和鎖定軸 - 在移動後移動和鎖定（或夾住）軸之前，這些使用者定義的字串定義解除鎖定（或松開）軸的命令。上述字串可選用。

  • 旋轉臺堆疊順序 - 如果定義多個旋轉臺，則必須指定旋轉臺的堆疊順序。在軸轉臺中定義兩個旋轉臺才可看到選項。選取選項將來自旋轉臺中定義的兩條軸。NC Gage 在內部將保留此設定，方法是儲存被定義為「下」旋轉臺（以下第一張圖中的軸 B）的「主導」軸。

  • 當測座位於 0 處時的測頭方向（主軸測尖） - 若正在定義測座（與在車銑機中的方法一樣），當測座位於 0（零）位置時，必須指定測座測頭的方向（從主軸測尖中定義）。從軸類型清單中選取測座（以下第二張圖中的軸 B）前，此選項處於隱藏狀態。

  • 樞軸類型 - 從清單中選取一個選項，定義測座樞軸類型。選項有 WristCenter 和 WristZero。

  • 樞軸距離 - 輸入測座的樞軸距離。

備註：定義兩個旋轉臺後，方可使用 NC Gage 設定工具的軸設定標籤上的旋轉臺堆疊順序清單。若定義了旋轉臺和測座（同車銑機），旋轉臺堆疊順序清單將被以下所示的當測座位於 0 處時的測頭方向（主軸測尖）和樞軸區域所取代：

如果此情況不適用，則將不顯示上述區域。如果對車銑機定義了測座，則其必須設為 B 軸，旋轉臺必須設為 C 軸。

兩個旋轉臺的 NC Gage 設定工具軸設定標籤設定範例

車銑機的 NC Gage 設定工具軸設定標籤設定範例

對於有一個或多個測座軸的測量機（有兩個頭的車銑機和測量機），將顯示當測座位於 0 處時的測頭方向（主軸測尖）清單。此操作可定義當所有測座角度都位於零處時測頭所指方向。（這取決於測頭的中央線或下線是否遠離測頭。）

備註：NC Gage 設定工具將軸設定定義為 XYZBC，其中 B 係測座類型，C 係旋轉臺類型。

要檢視旋轉設定資訊：

  1. 按主螢幕上的設定 螢幕按鍵 [image] 。

  2. 按設定螢幕上的動力學設定螢幕按鍵 [image] ，顯示動力學設定螢幕：

第 4 條軸和第 5 條軸區域中可用的選項取決於是否定義了兩個旋轉臺或是否定義了旋轉臺和測座。當在 NC Gage 中設定了雙旋轉臺時，以上所示的動力學設定螢幕顯示可用的選項。若對測座頭進行了設定（同車銑機）：

  • 螢幕不顯示第 4 條（測座）軸的樞軸 X、樞軸 Y 和樞軸 Z 選項。

  • 當測座位於 0 處時的測頭方向（主軸測尖）清單取代旋轉臺堆疊順序清單。

動力學設定螢幕顯示在 NC Gage 設定工具中定義的軸和軸類型值。不能在 NC Gage 介面螢幕上編輯上述值。

您可視需要對特定系統編輯開始和結束限制。

右上方區域顯示上述與 NC Gage 設定工具相同的設定，顯示內容取決於是定義了兩個旋轉臺還是定義了旋轉臺和測座。可在此表格上或測量機設定工具內對旋轉臺堆疊順序（或當測座位於 0 處時的測頭方向（主軸測尖）清單）進行變更。

動力學設定螢幕可讓您定義以下動力學轉換所需的值：

  • 樞軸點 - 可為旋轉軸上任意點。

  • 樞軸旋轉向量 - 定義旋轉軸的方向。

  • 順時針旋轉 - 運行方向定義了旋轉臺旋轉的方向為正遞增。要讓旋轉朝順時針方向，則從清單中選取是。要讓旋轉朝逆時針方向，則選取否。有關說明定義，請參閱以下「旋轉說明」。

要從控制器讀取旋轉中心，按從控制器讀取旋轉中心螢幕按鍵 [image] 。

備註：基於已在控制器上正確輸入所有值這一事實，確認這些旋轉中心值是否對此工作來說是合理的。如果控制器上的這些值不正確，Hexagon Metrology 對此不承擔任何責任。

遵循指示，然後按確認螢幕按鍵 [image] 完成設定程序。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

旋轉說明


計數器顯示設定

使用計數器顯示設定螢幕定義相關 NC Gage 計數器螢幕上顯示的內容。

NC Gage 計數器通常顯示兩組數字。您可使用計數器顯示設定螢幕來定義控制項左側和右側顯示的內容。您亦可在不同螢幕上定義不同的選擇。

NC Gage 提供您想要設定計數器的三個不同「層級」：

  • 學習個別命令時，可能要定義什麼是「特徵檢視」。

  • 導覽主螢幕或執行測量程式時，因為這是 NC Gage 應用程式內的更高等級，所以您可能想要看見「測量程式檢視」。

  • 您可能想要在校驗程序中看到「校驗檢視」。

若要存取此螢幕：

  1. 按主螢幕上的設定 螢幕按鍵 [image] 。

  2. 從設定螢幕的第一頁按計數器顯示設定螢幕按鍵 [image] ，顯示計數器顯示設定螢幕：

  3. 按確認螢幕按鍵 [image] 以儲存所作的所有變更。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

計數器方塊顯示在大多數 NC Gage 螢幕上。計數器箱裡可容納兩套計數器。在 NC Gage 以前的版本中，左側通常被定義為測量機坐標，右側通常被定義為工作偏移坐標。NC Gage 2.0 版及以後版本提供可使用的新坐標系並可在符合邏輯的位置進行使用。

新坐標系係工件坐標。NC Gage 2.0 版及以後版本可讓您在如何顯示目前測頭位置上有更大的彈性。

計數器顯示設定螢幕

計數器顯示可選取三個坐標系。坐標系為：

  • 測量機 - 計數器將顯示測量機坐標中測頭的目前位置。此選項始終可用。

  • 工作偏移 - 計數器將顯示目前工作偏移坐標中測頭的目前位置。此選項始終可用。

  • 工件 - 計數器將顯示工件坐標中測頭的目前位置。僅當 NC Gage 控制三條軸以上時，此選項才可用。工件坐標的定義如下。

報告 XYZ 區域 - XYZ 值 為每個坐標類型報告，可將其設定為如何套用工具長度。

計數器配置區域 - 計數器通常被定義為一對坐標集。但是，在某些螢幕上，僅顯示一組計數器。透過定義計數器左側和右側，可定義要在每個坐標集中看到的內容。您可定義三個不同區域：

  • 特徵檢視 - 定義學習特徵命令時可檢視的計數器。您可選取以上定義的坐標系中的任一個。

  • 測量程式檢視 - 定義 NC Gage 顯示套用至所有測量程式的螢幕時可檢視的計數器。您可選取以上定義的坐標系中的任一個

  • 校驗檢視 - 定義校驗過程中可檢視的計數器。您僅可選取測量機和工作偏移坐標系。

每個坐標系上顯示的點有三種選擇。可分別設定每個坐標系。選項有：

  • 無工具長度 - 計數器將顯示 Gage（連線）點的目前位置。

  • 工具長度 - 透過套用控制項工具台中的工具長度，並將其新增至 Gage 點位置，計數器會顯示工具末端的位置。

  • 測頭測尖中心 - 計數器會顯示測頭測尖中心的位置。校準測頭後，從 Gage 點至球尖的偏移會確定下來。

工件坐標系

工件坐標系統 (PCS) 是工件的參考系統。每個工件祇有一個工件坐標系統，由繪圖定義。PCS 的原點透過工作偏移（例如 G54）與 MCS 有關。PCS 等價於由工作偏移（帶有零位置上所有旋轉臺軸）定義的坐標系。

G54 - 在工件棱角（如下所示）上設定的 XYZ 零的原始位置：

選取初始工作偏移且所有旋轉臺軸都在零的位置時，「工件坐標」才是有效的坐標系。注意，在該定義下，NC Gage v1.2 及以後版本中所有測量程式都使用工件坐標。工件坐標成為有意義的共同坐標系，四、五個軸系統中的所有測量值都與其相關。


建立新的測頭

Home > 使用 PC-DMIS NC Gage > 入門 > 第 3 步：建立新的測頭

第 3 步：建立新的測頭

使用建立新的測頭螢幕可定義將要用於測量工件的測頭類型。

  1. 按主螢幕上的測頭螢幕按鍵 [image] 。

  2. 按測頭螢幕上的選取測頭螢幕按鍵 [image] 。

  3. 按選取測頭螢幕上的建立新的測頭螢幕按鍵 [image] ，顯示建立新的測頭螢幕：

  4. 使用此螢幕來提供有關測頭的資訊。鍵入測頭的理論直徑、工具長度、放置測頭的槽編號、測頭名稱以及任何特別指示。

  5. 按確認螢幕按鍵 [image] 以儲存所作的所有變更。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

定義

  • 槽編號 - 放置測頭的槽編號。

  • 標稱直徑 - 測頭測尖的標稱直徑。

  • 工具長度 - 從鼻點到測尖中心的測頭的工具長度。工具長度偏差必須在 20mm 以內。進行校驗時工具長度可用於檢查球體中心。在校驗中不會更新工具長度。但是，在校驗過程中將更新測頭測尖偏移。

  • 測頭名稱 - 工具編號前的工具測頭名稱。測頭名稱和工具編號可識別一個測頭檔案。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
套用或確認變更 此螢幕按鍵可接受對目前螢幕上任何選項、設定或選取作出的變更。在某些情況下，此螢幕按鍵可將命令新增至 NC Gage 測量常式。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。
返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。 | 取消 此螢幕按鍵可清除輸入到槽編號、標稱直徑和標稱長度選項中的任何資訊。


選取測頭

Home > 使用 PC-DMIS NC Gage > 入門 > 第 4 步：選取測頭

第 4 步：選取測頭

使用選取測頭螢幕可選取測量工件所用的測頭。

  1. 按主螢幕上的測頭螢幕按鍵 [image] 。

  2. 按選取測頭螢幕按鍵 [image] 顯示選取測頭螢幕：

  3. 使用選取測頭螢幕按鍵 [image] 從選取測頭清單中選取要使用的測頭。

  4. 按確認並將目前命令新增至末端螢幕按鍵 [image] 來儲存變更。或者，按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

NC Gage 將測頭插入測量程式之樹狀檢視。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
建立新測頭 使用此螢幕按鍵可透過存取建立新測頭螢幕建立一個新的測頭。 | 刪除測頭 此螢幕按鍵可用來刪除目前未校驗的測頭。您無法使用此螢幕按鍵來移除已校驗的測頭。
編輯測頭 此螢幕按鍵可用來顯示編輯測頭螢幕，您可在此螢幕上定義新測頭。 | 取消 此螢幕按鍵在此螢幕上初始為停用。
套用或確認變更 此螢幕按鍵可接受對目前螢幕上任何選項、設定或選取作出的變更。在某些情況下，此螢幕按鍵可將命令新增至 NC Gage 測量常式。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。
執行 此螢幕按鍵可存取測量程式螢幕，您可在此螢幕上執行測量程式。 | 選取測頭 若選取測頭螢幕並非目前螢幕，則此螢幕按鍵將存取此螢幕。若選取測頭螢幕已可見，則觸碰此螢幕按鍵可捲動瀏覽測頭清單中的每個測頭。
返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。 |


校驗

Home > 使用 PC-DMIS NC Gage > 入門 > 第 5 步：校驗

第 5 步：校驗

較驗對於系統定義測尖偏移和有效半徑至關重要。

當使用轉盤作為測量順序的一部分時，可選用轉盤 較驗來增加測量的精確度。

  1. 按主螢幕上的測頭螢幕按鍵 [image] ，存取可用的校驗選項。

測頭選項工具列中有以下選項：

  2. 按選取測頭螢幕按鍵 [image] ，選取或定義需較驗的新增測頭。

有以下測頭校驗選項：

  • 按 球體較驗 螢幕按鍵 [image] ，使用較驗球體來較驗您系統中的測頭。

  • 按 環校驗螢幕按鍵 [image] ，使用校驗環來較驗您系統中的測頭。

  • 按設定測頭長度螢幕按鍵 [image] 來計算測頭長度

有以下旋轉臺校驗選項：

  • 按 轉盤較驗 螢幕按鍵 [image] 來計算您系統中的轉盤。

  • 按將旋轉校驗資料寫入控制項螢幕按鍵 [image] ，以將旋轉臺校驗資料寫入控制器。

下列車銑機校驗主題可用：

  • 按測座頭校驗螢幕按鍵 [image] ，執行車銑機設定和測頭校驗程序。

  • 按測座頭校驗螢幕上的尋找車銑機中心螢幕按鍵 [image] ，尋找 B 軸中心。

  • 按測座頭校驗螢幕上的設定測座校驗角度螢幕按鍵 [image] ，建立車銑機 B 軸校驗位置。

  • 校驗完成後，按測座頭校驗螢幕上的檢視校驗報告螢幕按鍵 [image] ，檢視、列印並儲存校驗報告。


測頭校驗選項

校驗您的測頭可確定測尖偏移和您的系統中所用測頭的半徑。

要存取測頭螢幕：

  1. 按主螢幕上的測頭螢幕按鍵 [image] 。

  2. 選取適當的測頭校驗螢幕按鍵，以校驗您的測頭：

    • 按 球體較驗 螢幕按鍵 [image] ，使用較驗球體來較驗您系統中的測頭。

    • 按 環校驗螢幕按鍵 [image] ，使用校驗環來較驗您系統中的測頭。

測頭螢幕上有下列選用方法：

    • 選取測頭螢幕按鍵 [image] 選取或定義待校驗之新測頭。

    • 設定測頭長度螢幕按鍵 [image] 計算測頭的長度。

    • 旋轉臺校驗螢幕按鍵 [image] 校驗系統中的旋轉臺。

    • 將旋轉校驗資料寫入控制項螢幕按鍵 [image] 將旋轉臺或測座校驗資訊傳送至控制項上的巨集變數中。

    • 測座頭校驗螢幕按鍵 [image] 校驗系統中的測座頭。


球體校驗

  1. 按主螢幕上的測頭螢幕按鍵 [image] 。

  2. 按測頭螢幕上的球體校驗螢幕按鍵 [image] ，顯示球體校驗螢幕：

  3. 遵循螢幕底部的指示，完成球體校驗程序。

「參數」區域

  • 進給速率 - 設定測頭校驗期間測頭的移動速度，單位為毫米/分（若採用英吋單位，則為英吋/分）。

  • 預碰距離 - 指定在採集測點之前理論測點位置與測頭將要移動的位置之間的距離。可在測頭校準期間使用。單位為毫米或英吋。

「其他選項」區域

  • 顯示詳細資料 - 選取此核取方塊可顯示螢幕的測尖偏移區域。測尖偏移區域詳述以下內容：

    • X、Y 和 Z 軸的測量值、標稱值和公差值

    • 與球體校驗相關的表單錯誤的測量值、標稱值和公差值

測頭區域

  • 測尖直徑（測量值、標稱值和公差）- 提供測頭測尖的測量和標稱直徑以及測頭測尖公差值。完成校驗程序後，測量值將得到更新。

「目標」區域

  • 直徑 – 指定校驗/檢定球體的直徑。

  • 中心 XYZ - 指定與工作偏移位置相關的檢定球體的中心位置。若球體被精確定位於工作偏移時，該值應為 0,0,0。

  • 工作偏移 - 指定檢定球體所處位置的工作偏移。選取相對於機器坐標移動的機器。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
尋找球體工件 如果機器無旋轉臺、旋轉頭或測座，按一下此按鈕將顯示「2D 尋找球體工件，為偏轉進行調節」螢幕。 選取此螢幕按鍵可導致軟體採集主軸方向的範例測點，以便在測量校驗球體之前尋找球體的中心。有關更多資訊，請參閱「尋找球體工件，為偏轉進行調節」。 如果機器有測座，按尋找球體工件螢幕按鍵可顯示尋找旋轉軸檢驗所用的球體工件螢幕。 當在尋找球體工件螢幕上按下確認螢幕按鍵 [image] 時，球體校驗螢幕上的資訊將自動填寫。 | 顯示詳細信息 此螢幕按鍵可顯示與標稱位置之間的測尖偏移。它的作用與啟用顯示詳細資料核取方塊的作用相同。所顯示的偏移為差值。還顯示了形狀誤差。形狀誤差是向量補償之前點的最小平方最佳擬合誤差。可在校驗測試設定按鈕項下輸入公差。
選取工作偏移 此螢幕按鍵可從偏移清單中選取已命名的工作偏移。再次按下此鍵可選取清單中的下一個工作偏移。 | 校驗測試設定 此螢幕按鍵將顯示一個新視窗，在該視窗中使用者可指示環的標稱位置和公差值。如果測量值不同於個別標稱並高於指定的公差，將顯示警告。在接受警告後您可以繼續操作。
學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
選取測頭 若選取測頭螢幕並非目前螢幕，則此螢幕按鍵將存取此螢幕。若選取測頭螢幕已可見，則觸碰此螢幕按鍵可捲動瀏覽測頭清單中的每個測頭。 | 確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。
檢視校驗報告 選取此螢幕按鍵以檢視校驗報告。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
刪除校驗 此螢幕按鍵可刪除目前校驗。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。

校驗過程

  1. 選取校驗所用的工作偏移。預設為機器工作偏移。

  2. 輸入校驗/檢定球體的直徑和中心位置。您可使用本主題底部的描述識別位置中心坐標。

  3. 輸入如上所述的其他參數。

  4. 將測尖輕推至檢定球體中心之上。

  5. 按一下執行螢幕按鍵 [image] 。NC Gage 會自動採集檢定球體上的五個測點，以確定球體的中心。在較為精確地確定球體中心之後，NC Gage 將依據球體校驗參數的定義自動採集檢定球體上的 161 個測點。

校驗完成之後，測量值將會更新。您即可使用已校驗的測頭測量特徵。

定位 XY

  • 主軸旋轉 - 如果 NC 機器支援主軸方向 (M19Sxxx)，則可使用校驗螢幕上的「尋找中心」套用功能尋找球體的 XY 位置。此功能可旋轉每個點的主軸，以使測尖的擺動不會構成影響因素。

定位 Z

  • 將具有已知長度的參照工具插入至主軸中。

  • 使用具有已知厚度的厚薄規，將工具向下輕推至球體頂部的上方，直至厚薄規在球體與工具之間移動時出現阻力。在靠近球體時使用最小的輕推增量。

  • 球體的頂面 Z 即等於機器 Z 減去厚薄規的厚度再減去參考工具長度所得的結果。

特定的特徵路徑和 NC Gage 內置邏輯

  • 讀取球體頂部之上的測頭位置。

  • 直接向下測量，搜尋距離為測頭半徑 + 2* 預碰距離。

  • 設定的安全平面高度 = 讀取點 Z 和預碰距離的最大值 + 接觸點之上的測頭半徑。

  • 預估球體中心應為接觸點之下的球體半徑。

  • 設定的預碰半徑 = 球體半徑 + 測頭半徑 + 預碰距離。

  • 移至安全平面。

  • 以自球體中心的 +X 方向將安全平面移動至預碰半徑的點處。

  • 降至預估球體赤道的高度。

  • 測量帶有 16 個點的赤道，若需要，可在點之間執行其他移動。

  • 向上移至下一層（赤道之上 9 度）。

  • 測量帶有 16 個點的層。

  • 重複執行全部 10 層的過程。

  • 測量球體頂部的點。

  • 返回至安全平面。

識別球體中心位置

定位 XY：

  • 主軸旋轉 - 如果 NC 機器支援主軸方向 (M19Sxxx)，則可使用球體校驗螢幕上的「尋找中心」套用功能尋找球體的 XY 位置。此功能可旋轉每個點的主軸，以使測尖的擺動不會構成影響因素。

  • 使用千分表 - 在 NC 機器的主軸中載入一個千分表並進行調整，使其靠近校驗赤道。輕推 NC 機器上的 X 和 Y，以便在旋轉主軸時最小化千分表上的偏差。球體的中心為 X 和 Y 機器位置。

定位 Z：

  • 將具有已知長度的參照工具插入至主軸中。

  • 使用具有已知厚度的厚薄規，將工具向下輕推至球體頂部的上方，直至厚薄規在球體與工具之間移動時出現阻力。在靠近球體時使用最小的輕推增量。

  • 球體 Z 即等於機器 Z 減去厚薄規的厚度，然後減去校驗球體半徑，再減去參考工具長度所得的結果。

備註：

  • 若球體中心要使用工作位移，則應使用與 NC Gage 中的零中心位置相同的工作位移。

  • 控制櫃上工作偏移中的中心位置 X Y Z 值為主軸突出點的坐標，前提是主軸可定位於球體中心。

球體校準報告範例

校驗球體後，您可按檢視校驗報告螢幕按鍵 [image] 建立校驗報告：

按列印螢幕按鍵 [image] 將複本列印至預設印表機。


尋找球體工件

Home > 使用 PC-DMIS NC Gage > 入門 > 第 5 步：校驗 > 測頭校驗選項 > 球體校驗 > 尋找球體工件，為偏轉進行調節

尋找球體工件，為偏轉進行調節

使用下列程序尋找校驗球體所需的球體工件中心。

  1. 在輸入值區域的直徑方塊中輸入球體工件的直徑。

  2. 遵循螢幕提示，依指示按執行螢幕按鍵 [image] ，開始學習程序。

校驗球體工具區域自動填入結果並為偏轉進行調節。

  3. 按確認螢幕按鍵 [image] ，關閉螢幕，並返回會相應更新的球體校驗螢幕。

「動作參數」區域

  • 逼近距離 - 定義遠離標稱曲面的距離，測頭在測量過程中在此標稱曲面上開始搜尋曲面。

  • 搜尋距離 - 定義測頭在學習模式中搜尋曲面時運行的距離。

「輸入值」區域

  • 直徑 - 手動輸入待校驗的球體工件的直徑值。

「校驗球體工具」區域

  • 中心 X - 顯示球體工件在 X 軸中的位置值。

  • 中心 Y - 顯示球體工件在 Y 軸中的位置值。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |


環省校驗

環形校驗適用於在 XY 平面（若測頭指向 Z）中執行測量。

  1. 按主螢幕上的測頭螢幕按鍵 [image] 。

  2. 按環形校驗螢幕按鍵 [image] 以顯示環形校驗螢幕：

  3. 遵循螢幕上的指示，然後按一下確認螢幕按鍵 [image] 完成程序，或者按返回螢幕按鍵 [image] 返回上一螢幕而不儲存。

「參數定義」區域

  • 測尖直徑（測頭/標稱）- 提供測尖的標稱直徑。校驗完成之後 測量值將會更新。

  • 直徑（環）– 指定校驗/檢定環的直徑。

  • XYZ（環/中心）- 指定與工作偏移位置相關的檢定環的頂面中心位置。Z 值用於計算在上一個點位於表面上時測頭 Z 的偏移。若環被精確定位於工作偏移時，該值應為 0,0,0。

  • 進給速率 - 設定測頭校驗期間測頭的移動速度，單位為毫米/分（或英吋/分）。

  • 預碰距離 - 指定在採集測點之前理論測點位置與測頭將要移動的位置之間的距離。可在測頭校準期間使用。單位為毫米或英吋。

  • 工作偏移 - 指定檢定環所處位置的工作偏移。選取相對於機器坐標移動的機器。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
尋找中心 此螢幕按鍵可讓軟體採集範例測點，以便在測量校驗環之前尋找環的中心。 請參閱「尋找環形工件，為偏轉進行調節」。 | 校驗測試設定 此螢幕按鍵將顯示一個新視窗，在該視窗中使用者可指示環的標稱位置和公差值。如果測量值不同於個別標稱並高於指定的公差，將顯示警告。在接受警告後您可以繼續操作。
顯示詳細信息 此螢幕按鍵可顯示與標稱位置之間的測尖偏移。它的作用與啟用顯示詳細資料核取方塊的作用相同。所顯示的偏移為差值。還顯示了形狀誤差。形狀誤差是向量補償之前點的最小平方最佳擬合誤差。可在校驗測試設定按鈕項下輸入公差。 | 刪除校驗 此螢幕按鍵可刪除目前校驗。
選取工作偏移 此螢幕按鍵可從偏移清單中選取已命名的工作偏移。再次按下此鍵可選取清單中的下一個工作偏移。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。
選取測頭 若選取測頭螢幕並非目前螢幕，則此螢幕按鍵將存取此螢幕。若選取測頭螢幕已可見，則觸碰此螢幕按鍵可捲動瀏覽測頭清單中的每個測頭。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 | 檢視校驗報告 選取此螢幕按鍵以檢視校驗報告。

校驗過程

  1. 選取校驗所用的工作偏移。預設為機器工作偏移。

  2. 輸入校驗/檢定環的直徑和中心位置。您可使用本頁底部的描述識別位置中心坐標。

  3. 輸入以上「參數定義區域」中所述的其他參數。

  4. 將測頭輕推至環中心附近的位置。

  5. 按一下執行螢幕按鍵 [image] 。NC Gage 將自動採集檢定環上的 4 個測點，以確定環的中心。在較精確地確定環的中心之後，可使用 36 個測點測量環標準塊的內徑並使用單個測點測量環標準塊的頂部。

  6. 校驗完成之後，測量值將會更新。按顯示詳細資料螢幕按鍵 [image] 檢視測尖偏移詳細資料，或者按確認螢幕按鍵 [image] 儲存校驗結果並返回主螢幕。您現在已準備就緒，可使用已校驗的測頭測量特徵。

備註：您亦可透過選取顯示詳細資料核取方塊檢視測尖詳細資料。

定位 XY

  • 主軸旋轉 - 如果 NC 測量機支援主軸方向 (M19Sxxx)，則可使用環形校驗螢幕上的尋找中心套用功能尋找環的 XY 位置。此功能可旋轉每個點的主軸，以使測尖的擺動不會構成影響因素。

定位 Z

  • 將具有已知長度的參照工具插入至主軸中。

  • 使用具有已知厚度的厚薄規，將工具向下輕推至環頂部的上方，直至厚薄規在環與工具之間移動時出現阻力。在靠近環時使用最小的輕推增量。

  • 環的頂面 Z 即等於機器 Z 減去厚薄規的厚度再減去參考工具長度所得的結果。

特定的特徵路徑和 NC Gage 內置邏輯

  • 讀取環中心的測頭位置。

  • 將在讀取點達到 Z 值時執行環測量。

  • 預估環的 XY 中心為讀取位置點。

  • 設定的預碰半徑 = 環半徑 - 測頭半徑 - 預碰距離。

  • 設定的目標半徑 = 環半徑 + 預碰距離。

  • 設定的安全高度 = 讀取位置 Z 值 + 25 mm。

  • 從 0 至 350 度測量帶有 36 個點的環。

  • 移至安全高度。

  • 移至點的安全高度，即為環半徑 + 2* 測頭半徑 + 自環中心的 X 方向。

  • 向下測量，目標高度與環點的高度相同。

  • 返回至安全高度。

環形校準報告範例

校驗環完成後，您可透過按檢視校驗報告螢幕按鍵 [image] 建立校驗報告。

要將複本列印至預設印表機，請按列印螢幕按鍵 [image] 。


尋找環形工件，為偏轉進行調節

使用下列程序尋找校驗環所需的環形工件中心。

  1. 在輸入值區域的直徑方塊中輸入環形工件的直徑。

  2. 遵循螢幕提示，依指示按執行螢幕按鍵 [image] ，開始學習程序。

校驗環形工具區域自動填入結果並為偏轉進行調節。

  3. 按確認螢幕按鍵 [image] ，關閉螢幕，並返回會相應更新的環形校驗螢幕。

「動作參數」區域

  • 逼近距離 - 定義遠離標稱曲面的距離，測頭在測量過程中在此標稱曲面上開始搜尋曲面。

  • 搜尋距離 - 定義測頭在學習模式中搜尋曲面時運行的距離。

「輸入值」區域

  • 直徑 - 手動輸入待校驗的環形工件的直徑值。

「校驗環工具」區域

  • 中心 X - 顯示環形工件在 X 軸中的位置值。

  • 中心 Y - 顯示環形工件在 Y 軸中的位置值。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |


設定測頭長度

設定測頭長度螢幕可用來計算測頭的長度。可隨時執行此作業。

  1. 按主螢幕上的測頭螢幕按鍵 [image] 。

  2. 按設定測頭長度 [image] 螢幕按鍵以顯示設定測頭長度螢幕：

  3. 在工作偏移清單中選取工作偏移。

  4. 在參數區域中的目標方塊中鍵入與目前工作偏移相關的預期表面高度。

  5. 在動作參數區域的預碰距離和搜尋距離中鍵入一個值。

  6. 將測頭置於表面之上。

  7. 按一下讀取測頭位置螢幕按鍵 [image] 。

  8. 按執行螢幕按鍵 [image] 。測頭將以目標值測量表面。依據接觸位置以及測頭主軸在表面上 3D 空間偏移中的位置，NC Gage 可測量測頭的長度。所測的 Z 值、測頭長度和 Z 偏移值將顯示於唯讀文字方塊中。目前值將顯示未變更的測頭長度和 Z 位移值。新值表示套用變更之後的測頭長度和 Z 位移。

備註：測頭長度值將於測頭的底部測量。Z 偏移值將於測頭的中心測量。

  9. 按確認螢幕按鍵 [image] 儲存校驗所用的測頭長度或者按返回螢幕按鍵 [image] 返回上一螢幕而不儲存。

此螢幕上的所有其他項目均包含與測頭關聯的唯讀資訊。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
讀取目前位置/下一步 此螢幕按鍵可讀取目前測頭位置並移至目前程序的下一步。 | 返回上一步 此螢幕按鍵可移除上一次學習的測頭位置。
選取工作偏移 此螢幕按鍵可從偏移清單中選取已命名的工作偏移。再次按下此鍵可選取清單中的下一個工作偏移。 | 執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。
取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。
選取測量面 此螢幕按鍵可決定觸測方向和移動到特徵的安全位置。您可按多次選取不同的測量面。 可用的測量面有：上、左、右、前、後和傾斜。若選取「傾斜」，螢幕按鍵圖示將變為傾斜圖示。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。


旋轉臺校驗選項

Home > 使用 PC-DMIS NC Gage > 入門 > 第 5 步：校驗 > 旋轉臺校驗選項

旋轉臺選項

定義使用旋轉臺的測量系統時，必須輸入旋轉臺的標稱位置和方向。

當旋轉臺被用作測量順序的一部份時，可選擇性地執行校驗，以提高測量的精確度。

可從測頭螢幕上獲取旋轉臺校驗特徵。要開啟測頭螢幕：

  1. 按主螢幕上的測頭螢幕按鍵 [image] 。

  2. 按 轉盤較驗 螢幕按鍵 [image] 來計算您系統中的轉盤。

旋轉臺校驗螢幕上有以下選用方法：

  • 檢視校驗報告螢幕按鍵 [image] - 顯示成功校驗旋轉臺之後的校驗報告。

  • 尋找球體工具螢幕按鍵 [image] - 定義校驗系統中的旋轉臺時所用的球體。

測頭螢幕上有下列選用方法：

  • 選取測頭螢幕按鍵 [image] - 選取或定義待校驗之新測頭。

  • 球體校驗螢幕按鍵 [image] - 使用校驗球體校驗系統中的測頭。

  • 環形校驗螢幕按鍵 [image] - 使用校驗環校驗系統中的測頭。

  • 測頭長度改善螢幕按鍵 [image] - 計算測頭的長度。


旋轉臺校驗

在設定工具（有關更多資訊，請參閱「附錄 A - 控制器設定」）和動力學設定螢幕上輸入所有旋轉臺參數之後，才會停用旋轉臺補償。

旋轉臺校驗是使用機器坐標執行的，因此所有位置參數均使用機器坐標定義。

校驗旋轉臺之前，您必須瞭解軸的機器坐標旋轉中心的位置，並將此輸入至「動力學設定」螢幕上。這些數字可轉換點，以使 NC 上 瞭解在處於不同旋轉臺位置時球體的近似位置。確定這些值之後，您即可繼續校驗旋轉臺。

備註：校驗旋轉臺前，測頭必須在球體上進行校驗。否則，旋轉臺校驗表單會變為不可用狀態。

  1. 按主螢幕上的測頭螢幕按鍵 [image] 。

  2. 按旋轉臺校驗螢幕按鍵 [image] 以顯示旋轉臺校驗螢幕：

  3. 遵循螢幕上的指示，然後按一下確認螢幕按鍵 [image] 完成程序。或者，按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

「參數」區域

  • 進給速率 - 設定校驗期間測頭的位置移動速度，單位為毫米/分（採用英吋單位時為英吋/分）。

  • 預碰距離 - 指定在採集測點之前理論測點位置與測頭將要移動的位置之間的距離。可在測頭校驗期間使用，單位為公釐或英吋。

  • 安全旋轉高度 - Z 軸高度，測頭將依據此高度在旋轉臺定位運動之間移動。此值為安全平面上測量機坐標中的測尖中心高度。即為測量機坐標上的 Z 值減去測頭 Z 位移（測尖中心位於安全平面上時）所得的結果。

警告：應確保安全旋轉高度值設定正確，以防止測尖與旋轉臺或工件發生碰撞。除非先前已設定，否則此參數的預設值將為 0（零）。

「角度定義」區域

  • 位置數 - 將執行球體測量的位置數量。這些位置將會均勻分佈在起始角與終止角之間。

  • 起始角 - 校驗中所用的第一個旋轉臺角度。

  • 終止角 - 校驗中所用的最後一個旋轉臺角度。

備註：若起始角與終止角相等或相差 360 度，則這些位置之間將具有均等間隔，從起始角開始，但並非以終止角結束（缺少一個增量）。在如上顯示的螢幕中，實際終止角將為 270。

  • 每個球體的點數 - 測量每個球體所用的點的數量。

  • 下層角 - 通常為 0，表示赤道。若不存在赤道測點，這個角可能會更大。

  • 上層角 - 通常為 90，表示北極測點。如果球體的頂部有障礙物，這個角可能會更小。

備註：NC Gage 將避免由校驗球體工具屬性定義的主體。

「旋轉臺校驗」區域

標稱值欄定義中心位置並顯示進入旋轉臺校驗螢幕之前動力學設定螢幕上存在的值。測量值欄定義中心位置，該位置由校驗過程確定。當接受校驗時，測量值將被寫入 NC Gage 設定並會在下一次執行校驗時成為新的標稱值欄值。這些值會顯示在動力學設定螢幕上。

  • 軸 ID - 用來標識軸的字母 A、B 或 C，依據系統中定義的旋轉臺數量確定。

  • 中心 X、Y、Z - 可定義旋轉臺中心的 X，Y 和 Z 機器坐標值。

    • 標稱值欄 - 顯示最初進行旋轉臺校驗時的理論位置。每次開始校驗旋轉臺時，將顯示上一個值。

    • 測量值欄 - 顯示目前校驗值的位置。

  • 旋轉軸 I、J 和 K - 表示向量 I、J 和 K 值，定義旋轉臺旋轉所在的軸。可用的選項相依於測量機上存在的以及從清單中選取的旋轉臺軸。可將預設值填入「標稱值」欄中的欄位，並可在必要時進行手動設定。

    • 標稱值欄 - 顯示最初進行旋轉臺校驗時的理論方向。每次開始校驗旋轉臺時，將顯示上一個值。

    • 測量值欄 - 顯示目前校驗值的方向。

「球體工具定義」區域

這些值可定義校驗球體工件的位置、大小和方向。您可直接鍵入這些值或者透過按下尋找球體工件螢幕按鍵 [image] 學習這些值。關於校驗球體定義過程的描述將在本文件的下文中提供。若按下尋找球體工件螢幕按鍵 [image] ，您將被指示定義球體。當結束尋找旋轉軸檢驗所用的球體工件螢幕時，學習的值將填入校驗球體螢幕。

  • 中心 X、Y 和 Z - 可定義已測量的球體中心的 X、Y 和 Z 機器坐標值。此為旋轉臺為零時的位置。

  • 直徑 - 已測量的球體直徑，可用於校驗旋轉臺。

  • I、J 和 K - 表示向量軸值，可定義所測量的球體的旋轉臺旋轉。此向量可定義校驗球體的主體。向量從主體指向球體的中心。

「測頭資訊」區域

  • 口袋 - 測頭工具的工具袋指數。

  • 直徑 - 測頭測尖的標稱和校驗直徑。

  • 長度 - 測頭的長度。

  • 測尖偏移 X、Y、Z - 指定測頭已校驗的 X、Y 和 Z 測尖偏移坐標。這些值可表示從 Gage 指向測尖中心的方向。

當所有選項都有有效值時，按執行按鈕。NC Gage 執行校驗序列。如果沒有出現錯誤，則會測量每一個球體位置，球體中心集可計算平面。當球體位於已計算平面的中心時對圓形進行計算。此圓的中心是旋轉臺軸的新測量中心。平面的標稱向量是旋轉臺軸的新 IJK 向量。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
選取測頭 若選取測頭螢幕並非目前螢幕，則此螢幕按鍵將存取此螢幕。若選取測頭螢幕已可見，則觸碰此螢幕按鍵可捲動瀏覽測頭清單中的每個測頭。 | 檢視校驗報告 在校驗成功完成後選取此螢幕按鍵，以檢視關聯的報告。
定義球體工具資訊 您可使用顯示的螢幕手動輸入可定義校驗球體工件的位置、大小和方向的值。您亦可使用讀取測頭位置按鈕學習這些值。 | 學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
刪除校驗 此螢幕按鍵可刪除目前校驗。 | 列印 此螢幕按鍵可列印使用中的校驗報告。

校驗過程

開啟此螢幕之前，您必須瞭解軸的旋轉中心位置，並將此輸入在動力學設定螢幕上。這些數字可轉換點，以使 NC Gage 瞭解在處於不同旋轉臺位置時球體的近似位置。

標稱 X、Y、Z、I、J 和 K 值被初始化為設定螢幕上的值。在旋轉臺校驗完成且您接受校驗之後，測量的 X、Y、Z、I、J 和 K 值將被動力學設定螢幕上的現有值替代。

校驗旋轉臺前，您必須選取先前已校驗的測頭。

備註：測頭校驗的品質非常重要。測頭校驗中的任何錯誤均可能轉換為旋轉臺校驗。

在動力學設定螢幕上輸入值後，您需執行下列操作以校驗旋轉臺：

  1. 輸入進給速率、預碰和安全平面測尖高度值。

    • 進給速率適用於非測量移動。

    • 安全平面測尖高度值非常重要。NC Gage 將於每次旋轉臺定位移動和球體測量之前移至此高度。如果這個值的設定不正確，NC Gage 可能會驅動機器撞至旋轉臺的上部或下部。此欄位應定義一個安全的 Z 值，以便在旋轉臺旋轉之前移動測尖。此過程中的所有位置均處於機器坐標中。

  2. 設定球體測量值。輸入位置數、起始角、終止角、每個球體的點數、下層角和上層角的值。

    • 位置數選項可定義將要對球體執行的測量總數。

    • 起始角是正在執行校驗的旋轉臺的第一個角。終止角為最後一個角。NC Gage 均勻劃分此範圍。例如，若起始角被設定為 30，終止角被設定為 210 且您已定義了 5 個位置，NC Gage 將於30、75、120、165 和 210 度時測量球體。在特定情況下，若起始角為 0 且終止角為 360，則可依據球體數量對終止角進行調整。例如，若您輸入了 0-360 和 4 個測量值，NC Gage 將於 0、90、180 和 270 時執行測量。

    • 每個球體的點數是指測量每個球體所用的點的數量。

    • 上層角和下層角選項定義將要測量的球體區域。90 是指北極，而 0 是指赤道。90 是上層角最常用的值，可能永遠不需要變更，但是也可在必要時進行變更。

      可能需要變更下層角值，以避免碰撞校驗球體的主體。NC Gage NC Gage 不提供主體避免功能，因此也不需要調整這個值。

  3. 確保校驗旋轉臺所用的測頭正確。目前可用測頭的槽、直徑、長度和測尖偏移值可於此螢幕的右下角查找。若需要，可透過按下選取測頭螢幕按鍵 [image] 變更測頭。請注意，旋轉臺校驗所用的測頭應於球體上進行校驗。不可使用在環上校驗的測尖。

  4. 從清單中選取相應的軸 ID。標稱值欄將自動填寫。

  5. 您必須定義所用的球體。NC Gage 需要知道中心位置、直徑、杆向量和球體的旋轉臺位置。若不知道這些值，請按一下定義球體工具資訊螢幕按鍵 [image] 存取尋找球體工具螢幕。您可使用讀取測頭螢幕按鍵 [image] 學習目前測頭位置。對這些值的一些備註如下：

    • 當採用此表中的值（此範例中的 A 和 C）定位旋轉臺時，中心 X、中心 Y 和中心 Z 是球體的中心坐標。NC Gage 實際需要知道當旋轉臺都位於零位置時 X、Y 和 Z 的位置。NC Gage 會使用動力學設定螢幕上定義的資訊來計算這些值。除非有理由證實不可在此位置進行測量，否則建議採用旋轉臺為零時的坐標定義球體。

    • I、J 和 K 定義從主體中心指向球體中心的方向。通常情況下，此向量為 (0, 0, 1)，表示球體指向「直上」。NC Gage 將使用此向量以避免在測量球體時接觸主體。

    • 當測量上部旋轉臺時（下圖中的 1），下部旋轉臺（下圖中的 2）必須為零。

    • 在校準下部旋轉臺時（下圖中的 2），上部旋轉臺（下圖中的 1）可處於任何位置。

    表 C 位於表 A 上方，具體如下所示：

1. C 軸旋轉
2. A 軸旋轉

  6. 當輸入所有此類資訊之後，請按一下執行螢幕按鍵 [image] 校驗旋轉臺。

如果沒有出現錯誤，則會測量每一個球體位置，球體中心集可計算平面。當球體位於已計算平面的中心時對圓形進行計算。此圓的中心是旋轉臺軸的新測量中心。平面的標稱向量是旋轉臺軸的新 IJK 向量。

備註：

原始的旋轉臺軸點將被投射至校驗過程中所確定的軸上。因此新軸點與舊軸點之間的差異不應過大，以免令您混淆。

在此表單中輸入的全部資訊均被儲存至檔案中。每條旋轉軸都會將其資訊單獨儲存在檔案中。執行校驗之後，檔案將被重寫。執行新校驗證時，將在此表單中填入上次對該軸校驗所儲存的值。

對每條軸的校驗均會單獨執行。最初，需要將未校驗的旋轉軸強制設定為零。此限制可能會在後來刪除。

旋轉臺校準報告

校驗旋轉臺後，您可透過按檢視校驗報告螢幕按鍵 [image] 建立校驗報告。

此報告中包含下列資訊：

  • 測量時間、軸 ID 和計算得出的旋轉臺中心。

  • 位移值，這個值可用來表示目前測量結果與動力學設定螢幕上所定義的值之間的差值。如果此為第一次校驗，則位移值將顯示與您所定義的位置之間的偏差。在此後的校驗中，這個值可顯示與上次校驗之間的差值。若接受校驗，則旋轉中心將被寫入動力學設定螢幕。

  • 旋轉軸將顯示「旋轉臺的傾角」。這個值表示為一個向量和一對角。旋轉軸之間的距離表示兩個旋轉臺之間距離最近時軸間的距離。

  • 每次球體測量時出現的定位錯誤均會採用表格和圖形格式顯示。定位錯誤的組成部份包括：

    • 徑向誤差 - 表示球體位置與沿著徑向（從圓形中心向外）方向計算所得的圓形的偏移量

    • 正切誤差 - 表示球體位置的誤差，取決於球體測量時圓內的角度和旋轉軸位置。這些偏差被「鐘控」至球體位置。因此第一個球體的正切誤差將始終為零；所有其他球體的正切誤差均與第一次測量相關。此誤差在本質上測量了旋轉臺定位的精確度。

備註： 徑向和正切誤差將透過球體標稱位置的錯位（誇張）以圖形方式表現出來。

    • 軸向誤差 - 此誤差表示球體位置與使用所有球體中心計算得出的最佳擬合平面之間的偏差。正值表示誤差「增加」，負值表示誤差減小。這可透過縮放誤差比例以圖形方式表現出來，以便您檢視相互之間的差異。正偏差為固態藍色磁碟，負偏差為紅色環。若要將報告印出至單色印表機，則以固態與環表示。

  • 您可按列印螢幕按鍵 [image] 將複本列印至預設印表機。

堆疊式旋轉臺報告

當在 NC Gage 中校驗旋轉臺時，旋轉臺中心會報告為計算軸（最接近另外一條軸）上的點。將兩條軸放在一起進行此操作。確定表示兩條軸與交集最近的點，這些點變為報告為旋轉臺中心的新點。

NC Gage 會決定兩條軸與交集最近的位置。這些點將報告為兩條軸的旋轉中心：

A - 上旋轉臺旋轉軸
B - 下旋轉臺旋轉軸

定義的堆疊式旋轉臺軸範例

備註：

祇要點位於旋轉軸上，NC Gage 使用的數值就與中心點選擇無關。

執行首次校驗後，NC Gage 會使用計算值中的其他旋轉臺標稱軸。校驗第二個旋轉臺後，會作出調整。

校驗旋轉臺後，因為在一個旋轉臺中心軸上進行小變更影響不大，因此兩個旋轉臺中心都會得到更新。

兩個旋轉臺之間報告的偏移為兩個點之間的差值。

兩個旋轉臺之間報告的距離為兩個點之間的距離。


將旋轉校驗資料寫入至控制項

成功校驗旋轉臺或測座之後，可使用將旋轉校驗資料寫入控制項螢幕將校驗資訊傳送至控制器的巨集變數區塊中。

  1. 按主螢幕上的測頭螢幕按鍵 [image] ，存取測頭螢幕。

  2. 按將旋轉校驗資料寫入控制項螢幕按鍵 [image] ，顯示將旋轉校驗資料寫入控制項螢幕。

    • 對於旋轉臺：

    • 對於測座：

  3. 輸入第一個巨集變數（用於基礎旋轉臺的中心 X）。剩餘的巨集變數將自動依順序指定。

  4. 按確認螢幕按鍵 [image] 將已校驗的值傳送至控制器。巨集變數將依如下所示的順序填入。您可根據需要適當地套用控制器端上的這些值。

「參數」區域

  • 位移 - 從標準中心到實際計算的中心的偏差。實際中心根據測座校驗中的所有角度位置中的資料進行計算。

  • 偏移 - 從標準中心到實際計算的中心的偏差。實際中心根據兩個垂直角度（0 和 90 或 0 和 -90）位置中的資料進行計算。僅當校驗清單中有兩個角度時，它才有效。


尋找旋轉軸檢驗所用的球體工件

校驗旋轉臺時，必須定義正在使用的球體。NC Gage 需要的資訊包括：中心位置、直徑、杆向量和球體的旋轉臺位置。如果值未知，可在尋找旋轉軸檢驗所用的球體工件螢幕上進行定義。

  1. 從旋轉臺校驗螢幕中存取螢幕。從旋轉臺校驗螢幕中按尋找球體工件螢幕按鍵 [image] ，顯示尋找旋轉軸檢驗所用的球體工件螢幕：

  2. NC Gage需要能幫助其瞭解球體的主體在哪的資訊。將測頭定位，這樣測頭便可在主體球體精準的（合理的）另一邊。

  3. 在動作參數區域中輸入預碰距離和搜尋距離值。

  4. 按讀取測頭位置螢幕按鍵 [image] ，學習此測頭位置。

  5. 將測頭直接置於球體上方，這樣當測頭垂直向下移動時，它將接觸到球體上方。

  6. 按讀取測頭位置螢幕按鍵 [image] ，學習此測頭位置。

備註：第 2 步至第 5 步可使用相同點，因為主體位於球體下方。可隨時按返回上一步螢幕按鍵 [image] ，移除上次學習的測頭位置。

  7. 按執行螢幕按鍵 [image] 。NC Gage 將使用上方的 4 點尋找模式粗略地測量球體。顯示的測量值可接受，也可拒絕。需要時，在接受測量值前也可手動編輯此值。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
選取測量面 此螢幕按鍵可決定觸測方向和移動到特徵的安全位置。您可按多次選取不同的測量面。 可用的測量面有：上、左、右、前、後和傾斜。若選取「傾斜」，螢幕按鍵圖示將變為傾斜圖示。 | 學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。
返回上一步 此螢幕按鍵可移除上一次學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。


車銑機校驗

車銑機上的測頭和頭部校驗

在車銑機上對測頭和 B 軸進行校驗，以回答下列這個問題「對於特定 B 軸角度，相對於頭部旋轉中心，測頭中心在哪裡？」

在理想的情況下，測頭測尖可在一個 B 軸位置中進行校驗，同時其位置對於所有位置來說均是已知的。但並不能達到這一理想情況，因此需要採用多種方式確定旋轉頭的位置。所選方法將受精度要求的影響。

車銑機測頭校驗概覽

車銑機測頭校驗的第一步是確定校驗球體的位置。此操作可採用傳統方法（千分表和塊規）完成。您亦可使用主軸旋轉執行兩次「尋找中心」：一次將 B 軸置於 0，一次將 B 軸置於 90。

測量程序的詳細資料如下所述。

所計算的旋轉頭中心應位於球體工具中心。然後，為每個測座角度計算與球體工具中心的偏差。

測尖偏移集合在一起分析，以便未校驗的 B 軸位置的測尖偏移可在 NC Gage 測量程式中估算和使用。

  • 分析的第一步是使用所有測頭偏移計算最佳擬合平面。平面的標稱向量是 B 軸旋轉向量；應非常接近 (0, 1, 0)。

  • 分析的下一步是使用所有測頭偏移計算最佳擬合圓。此中心是在第一步中計算的平面中進行計算。此圓中心應非常接近校驗球體的中心。此時出現的誤差很可能是由定義校驗球體中心時的誤差引起的。

與計算的最佳擬合圓有關的每個球體中心的誤差可分解為下列三個因素：

  • 第一個誤差因素是切向或計時誤差。與球體預測位置有關的球體計算位置誤差可表示為角度差。

  • 第二個誤差因素是徑向誤差。與最佳擬合圓有關的球體計算位置誤差可表示為最佳擬合圓半徑與距離圓中心的球體中心的距離之間的差值。

  • 第三個誤差因素是軸向誤差。該誤差表示從球體中心到最佳擬合平面的距離。

NC Gage 可建立誤差表，並將其儲存為 B 軸/測頭校驗的一部份。在測量程式中建立特徵時，NC Gage 會根據 B 軸角度建置待使用的測尖。如果已在校驗中使用了特徵框架的 B 軸角度，NC Gage 會從校驗表中直接擷取資訊，設定測尖偏移。如果此 B 位置校驗使用了足夠的點，則將使用向量補償。如果 B 軸不是校驗的一部份，則將使用最佳擬合平面、中心和誤差表設定測頭偏移，並根據需要將其插入適合的位置。同時，將決定是否旋轉並使用向量補償圖。

下表表示將儲存在車銑機校驗表中的新資訊：

B角度 | X 偏移 | Y 偏移 | Z 偏移 | 切向誤差 | 徑向誤差 | 軸向誤差 | 特定向量補償圖
0 | - | - | - | - | - | - | -
- | - | - | - | - | - | - | -
90 | - | - | - | - | - | - | -

備註

X、Y 和 Z 中心表示校驗球體中心和最佳擬合計算中心的使用者指定的位置之間的增量值。這樣可讓 NC Gage 處理測頭跳動並使用正弦函數和余弦函數預測新的位置。

NC Gage 可讓您執行完整的測尖/B 軸校驗或執行「校驗重新整理」，更新部份誤差表。

更多

測座頭校驗

設定測座校驗角度

測座頭校驗報告


測座頭校驗

  1. 按主螢幕上的測頭螢幕按鍵 [image] 。

  2. 按測座頭校驗螢幕按鍵 [image] ，顯示測座頭校驗螢幕：

  3. 遵循螢幕上的指示，然後按一下執行螢幕按鍵 [image] 完成程序。或者，按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

  4. 成功校驗測座頭之後，按檢視校驗報告螢幕按鍵 [image] ，顯示測座頭校驗報告螢幕。

「參數」區域

此區域定義動作參數。

  • 進給速率 - 設定校驗期間測頭的位置移動速度，單位為毫米/分（採用英吋單位時為英吋/分）。

  • 預碰距離 - 指定在採集測點之前理論測點位置與測頭將要移動的位置之間的距離。可在測頭校驗期間使用，單位為公釐或英吋。

  • 安全旋轉高度 - Z 軸高度，測頭將依據此高度在頭部定位運動之間移動。此值為安全平面上測量機坐標中的樞軸點中心高度。測座軸每次旋轉前，測頭在 Z 上直接向上移動，以便測座的樞軸點安全移動指定高度。

警告：應確保安全旋轉高度值設定正確，防止測尖與旋轉臺或工件發生碰撞。除非先前已設定，否則此參數的預設值將為 0（零）。

有關此值之更多資訊，請參閱「使用安全平面」。

「角度定義」區域

所有位置角度 - 這些值在其他表單（按一下設定測座校驗角度螢幕按鍵 [image] 可存取）中設定。

備註：測座軸位置及所有其他參數集將都儲存在測尖檔案中，以便下次開啟校驗螢幕時，將記住所有值。

以下項目與非主角度相關：

每個球體的點數 - 此值定義用於測量每個球體的點數。

「測頭校驗」區域

標稱值欄定義中心位置，且是輸入測座頭校驗螢幕之前動力學設定螢幕上存在的值。

測量值欄定義中心位置並由校驗過程確定。當接受校驗時，測量值將被寫入 NC Gage 設定並會在下次執行校驗時成為新的標稱值欄值。這些值會顯示在動力學設定螢幕上。

標稱值欄 - 顯示最初進行旋轉臺校驗時的理論方向。每次開始校驗旋轉臺時，將顯示上一個值。

測量欄 - 顯示目前校驗中目前計算的方向結果。

  • 軸 ID - 用來標識軸的字母 A、B 或 C，依據系統中定義的旋轉臺數量確定。

  • 平均總長度 - 在校驗程序期間確定的工具測尖的平均長度。

  • 旋轉軸 I、J 和 K - 向量 I、J 和 K 值。這些值定義測座旋轉軸的方向。這些值起初的設定與動力學設定螢幕上的設定一致。

測頭區域

標稱值欄 - 顯示最初進行旋轉臺校驗時的理論直徑。

測量值欄 - 顯示上次校驗的測頭直徑。

直徑 - 測頭測尖的直徑。

槽 - 建立測頭時已定義的測頭槽編號。

名稱 - 正在使用的目前測頭的名稱。

「資訊」區域

此區域提供校驗程序資訊，包括目前或上一次校驗的時間/日期戳記。

「球體工具定義」區域

這些值可定義校驗球體工件的位置、大小和方向。您可鍵入這些值或者透過按下校驗球體定義按鈕學習這些值。關於校驗球體定義過程的描述將在本文件的下文中提供。若按下球體定義按鈕，您將被指示定義球體。當結束球體定義螢幕時，學習的值將填入球體校驗螢幕。

  • 中心 X、Y 和 Z - 可定義已測量的球體中心的 X、Y 和 Z 機器坐標值。此為旋轉臺為 0（零）時的位置。

  • 直徑 - 已測量的球體直徑，可用於校驗旋轉臺。

  • I、J、K 和 C - 校驗球體主體的 IJK 向量方向和球體測量的旋轉臺中心位置。向量從主體指向球體的中心。

「工作偏移」區域

指定檢定工件所處位置的工作偏移。選取相對於機器坐標移動的機器。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
檢視校驗報告 在校驗成功完成後選取此螢幕按鍵，以檢視測座頭校驗報告。 | 選取測頭 若選取測頭螢幕並非目前螢幕，則此螢幕按鍵將存取此螢幕。若選取測頭螢幕已可見，則觸碰此螢幕按鍵可捲動瀏覽測頭清單中的每個測頭。
尋找球體工件 此螢幕按鍵顯示尋找球體工件螢幕，以測量校驗球體工件的位置、大小和方向 有關詳細資訊，請參閱「尋找旋轉軸檢驗所用的球體工件」。 | 設定測座校驗角度 此螢幕按鍵可設定校驗位置的測座軸位置角度。 有關詳細資訊，請參閱「設定測座校驗角度」。
學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。
選取工作偏移 此螢幕按鍵可從偏移清單中選取已命名的工作偏移。再次按下此鍵可選取清單中的下一個工作偏移。 | 設定安全移動高度 此按鈕可定義在測座軸間移動的安全高度。按一下此按鈕可自動更新安全旋轉高度參數值。 有關此按鈕之更多資訊，請參閱「使用安全平面」。
確認校驗 按此螢幕按鍵，接受校驗。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 | 清除 此螢幕按鍵可刪除所有 B 軸測頭校驗，以便您從頭開始。 如果按下此螢幕按鍵，刪除所有舊校驗核取方塊將被核取。實際校驗時，您將看到「您確定嗎」提示（如核取）。 如果未按下清除螢幕按鍵，所執行的所有校驗都將被以前校驗合併。「清除」意味著，PRB 檔案重設且所有測量值被捨棄。


使用安全平面

測座頭校驗螢幕上的安全旋轉高度（位於樞軸上）選項顯示以任意角度安全旋轉的測座的安全高度。

為避免測量球體前測座從一個角度旋轉至下一角度時發生碰撞，需定義好安全平面。NC Gage 先將樞軸中心驅動至此直線。然後，測量球體前，NC Gage 會執行測座旋轉。

定義的安全平面的方向沿標準旋轉臺。安全旋轉高度（位於樞軸上）是樞軸分疊到該層級上時所在方向的樞軸位置。它與測座角度無關，因為它是樞軸位置，不是測尖。

在下圖中，黃色線是示範機器的安全平面。高度是沿 X 軸（標準旋轉臺）：

安全平面

設定安全移動高度按鈕

測座頭校驗螢幕上的設定安全移動高度按鈕可幫助建立安全旋轉高度（位於樞軸上）。

  1. 在球體頂部並沿安全平面方向分疊測尖（不考慮測座角度位置）。

安全平面方向

  2. 選取設定安全移動高度按鈕。NC Gage 計算安全旋轉高度（位於樞軸上）並填寫安全旋轉高度（位於樞軸上）方塊。

起始位置

您應僅注意安全平面的安全起始位置並考慮旋轉臺標準方向的安全高度。您應將測頭分疊至 YZ 平面中更安全的位置，以為測座旋轉提供足夠的空間，從而避免碰撞。此外，測尖的起始位置應高於安全平面 -X 方向的球體中心。

測座角度

您應考慮為校驗所輸入的測座角度，並根據測座的限制、機器的可用空間以及球體的主體避免一些危險的角度位置。

您應更加注意主體附近的測座角度位置以及安全方向上球體中心之下樞軸中心的角度位置。在首次執行測量程式過程中仔細檢查這些位置。


設定測座校驗角度

按測座頭校驗螢幕上的設定測座校驗角度螢幕按鍵 [image] ，顯示以下螢幕：

  1. 在完全補償角度區域的角度欄位中輸入角度值。

  2. 在產生序列區域的起始角度欄位中輸入起始角度。

  3. 在產生序列區域的結束角度欄位中輸入結束角度。

  4. 在產生序列區域的位置數方塊中輸入所需的總位置數。

  5. 輸入起始角度、結束角度和位置數值後，按產生位置清單螢幕按鍵 [image] ，根據這些值填入校驗位置清單。

  6. 在新增一個角度區域的角度方塊中輸入一個獨立角度。然後按將一個角度新增至位置清單螢幕按鍵 [image] ，將其他角度新增至校驗位置清單。

  7. 按清除位置清單螢幕按鍵 [image] ，清除目前清單，重新開始。

  8. 產生位置後，按一下執行螢幕按鍵 [image] ，接受校驗位置清單。

「校驗位置」區域

列示所有目前定義的校驗位置。

「完全補償角度」區域

角度 - 需要完全校驗時，此角度將用作起始角度。該角度可建置向量補償圖。

「產生順序」區域

起始角度 - 初始角度值，測頭將以該角度在校驗程序過程中開始操作（通常為測頭旋轉的最小角度值）。

結束角度 - 最終角度值，測頭將以該角度在校驗程序過程中完成其旋轉（通常為測頭旋轉的最大角度值）。

位置數 - 測頭將在校驗期間旋轉的總角度數（包括起始和結束角度）。此值可根據所輸入的起始角度和結束角度值（見上述步驟）決定實際角度位置。

「新增一個角度」區域

角度 - 可手動新增至校驗位置清單中的角度值。輸入一個角度，然後按將一個角度新增至位置清單螢幕按鍵 [image] ，使用所輸入的角度值手動更新清單。

備註：當按綠色核取符號時，控制項將返回測座頭校驗螢幕，同時角度定義將返回父表單。如果已核取中止按鈕，則變更將不會傳回父表單。

備註： B 軸位置及所有其他參數集將都儲存在測尖檔案中，以便下次進入校驗螢幕時，將記住所有值。

此螢幕上的導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
清除位置清單 刪除校驗位置清單中的所有項目。 | 產生位置清單 根據所輸入的起始角度、結束角度和位置數值（新增至校驗位置清單）產生校驗位置清單。
將一個角度新增至位置清單 讀取新增一個角度區域中的角度值，然後將該角度新增至校驗位置清單。 | 確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。


測座頭校驗報告

成功校驗後，立即從測座頭校驗螢幕中按一下檢視校驗報告螢幕按鍵 [image] 。

測座頭校驗報告檔案分為兩個主要部份：

  • 第一個部份係僅儲存主角度並僅包含向量補償表的向量資訊。

  • 第二個部份包含測座校驗資訊。每個位置（包括主測尖）都將儲存（離旋轉中心的）測尖偏移以及計時、徑向和切向誤差。檔案將按照以下方式重寫：

    • 如果校驗了主角度且跳過其他角度，則祇有向量補償表被寫入檔案。測座校驗資訊將不會發生改變。

    • 如果未校驗主角度（所有範圍），但校驗了其他角度，則向量補償表將不會發生變更，但檔案中的測座校驗資訊將得到更新。

    • 如果校驗了主角度及其他角度，則整個檔案將被覆寫。

報告詳細資料

備註：以下內容基於上述報告（設定了軸，同時校驗了以上所示的軸）。如果對系統進行了不同設定，則將需根據需要使用相應軸修改下列陳述式。

  • 頭部旋轉中心及其與標稱值的偏差將透過旋轉中心、X 位移、Z 位移和旋轉軸值進行定義。

  • YZ 平面中的切線偏差（角度）的單位為度。所有其他單位為 NC Gage 所設定的距離單位（在上例中為公釐）。

  • 平均長度係偏差表中長度的平均值。

  • 偏差表中的長度係從旋轉中心到標線的距離。

  • XYZ 偏移值係每條軸離標稱值的距離。

Fanuc 控制器如何計算動力補償值

確定旋轉中心後，無需對 A 軸參數進一步進行計算。

但是，對於 B 軸參數，需要工具軸和工具旋轉軸 (#19712 - #19714) 的工具偏移值 (#19666) 和交叉向量。NC Gage 提供旋轉中心、標稱值的偏移及旋轉向量，這些值儲存在暫存器中。所有其他參數將需進行計算並從暫存變數傳輸至機器定義變數。

此螢幕上的導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
將報告儲存至 RTF 檔案 此螢幕按鍵可將 RTF 格式的校驗檔案儲存為指定的檔案名稱。 | 列印 此螢幕按鍵可列印螢幕上顯示的可用的校驗報告。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。


工作偏移

Home > 使用 PC-DMIS NC Gage > 入門 > 第 6 步：選取工作偏移

第 6 步：選取工作偏移

工作偏移為一個對齊方式。可將 3D 空間中的特地位置定義為坐標系統的 0,0,0 原點。

您可以選取一個要在測量程式中使用的已定義工作偏移，亦可透過測量特定的特徵定義（或設定）工作偏移。

  • 選取工作偏移

  • 設定工作偏移

您還可以使用更新工作偏移螢幕自動更新測量程式末端的工作偏移。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
設定工作偏移 此螢幕按鍵可用來顯示一個新螢幕，其中包含在各種情況下更新工作偏移所用的新螢幕按鍵。 | 選取要更新的工作偏移 此螢幕按鍵可從待更新的偏移清單中選取已命名的工作偏移。再次按下此鍵可選取清單中的下一個工作偏移。
設定帶有點的一條軸 此螢幕按鍵顯示設定一條軸螢幕。 | 設定帶有內徑的兩條軸 此螢幕按鍵顯示設定兩條軸（內徑）螢幕。
設定帶有突起部的兩條軸 此螢幕按鍵顯示設定兩條軸（突起部）螢幕。 | 設定帶有內棱角的兩條軸 此螢幕按鍵顯示設定兩條軸（內棱角）螢幕。
設定帶有外棱角的兩條軸 此螢幕按鍵顯示設定兩條軸（外棱角）螢幕。 | 設定帶有球體的三條軸 可用來測量球體，然後使用測量所得的坐標更新特定的工作偏移。
將一條軸設定在中點 此螢幕按鍵顯示將一條軸設定在中點螢幕。 | 設定帶有直線的旋轉角度軸 此螢幕按鍵顯示設定旋轉軸（角度）螢幕。
設定帶有平面的旋轉角度 此螢幕按鍵顯示設定帶有平面的旋轉角度螢幕。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。


設定工作偏移

設定工作偏移可讓您透過測量選取的特徵更新控制器上的工作偏移。

  1. 按主螢幕上的 設定工作偏移螢幕按鍵 [image] 。底部的螢幕按鍵變更為顯示不同類型的特徵，您可測量這些特徵以設定工作偏移。

車銑機用螢幕按鍵

  2. 從下列選項中按一下特定的測量程序：

  • 設定一條軸

  • 設定兩條軸（內徑）

  • 設定兩條軸（突起部）

  • 設定兩條軸（內棱角）

  • 設定兩條軸（外棱角）

  • 設定帶有球體的三條軸

  • 將一條軸設定在中點

  • 設定帶有直線的旋轉軸角度

  • 設定帶按鍵槽的旋轉軸（角度）

  • 設定帶有平面的旋轉角度

  • 設定帶平臺的旋轉軸（角度）

  • 設定帶按鍵的旋轉軸（角度）

  3. 將出現相應螢幕。

備註：您還可以使用更新工作偏移螢幕更新工作偏移。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
設定一條軸 此螢幕按鍵可存取設定一條軸螢幕。 | 設定兩條軸（內徑） 此螢幕按鍵可存取 設定兩條軸（內徑）螢幕。
設定兩條軸（突起部） 此螢幕按鍵可存取設定兩條軸（突出部）螢幕。 | 設定兩條軸（內棱角） 此螢幕按鍵可存取設定兩條軸（內棱角）螢幕。
設定兩條軸（外棱角） 此螢幕按鍵可存取設定兩條軸（外棱角）螢幕。 | 設定帶有球體的三條軸 此螢幕按鍵可測量球體，然後使用測量所得的坐標更新指定的工作偏移。
將一條軸設定在中點 此螢幕按鍵可存取將一條軸設定在中點螢幕。 | 設定帶有直線的旋轉軸角度 此螢幕按鍵可存取設定旋轉軸（角度）螢幕，在此螢幕上可定義和顯示使用直線在旋轉軸平面中產生明確角度的所有特徵。
設定帶平面的旋轉軸角度 此螢幕按鍵可存取設定帶有平面的旋轉角度螢幕，在此螢幕上可定義和顯示使用平面在旋轉軸平面中產生明確角度的所有特徵。 | 設定帶有按鍵槽的旋轉軸(角度) 此功能鍵可訪問設定帶按鍵槽的旋轉軸（角度）螢幕。
設定帶平臺的旋轉軸（角度） 此功能鍵可訪問設定帶平臺的旋轉軸（角度）螢幕。 | 設定帶有按鍵的旋轉軸(角度) 此功能鍵可訪問設定帶按鍵的旋轉軸（角度）螢幕。
返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。


設定一條軸

設定一條軸螢幕按鍵測量工件上的點，然後使用其坐標更新指定的工作偏移。

  1. 按主螢幕上的 設定工作偏移螢幕按鍵 [image] 。底部的螢幕按鍵變更為顯示不同類型的特徵，您可測量這些特徵以設定工作偏移。

  2. 按設定一條軸螢幕按鍵 [image] ，顯示設定 一條軸螢幕：

  3. 遵循螢幕上的指示，然後按確認螢幕按鍵 [image] 完成程序。或者，按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

「工作偏移」區域

  • 工作偏移 - 指定要更新的工作偏移。

「參數」區域

  • X、Y 或 Z 測量值 - 指定工作偏移的位置。可從點學習過程中學習該值。軸將依據螢幕左下角所選取的方向而不同。

  • 偏移 - 工作偏移將為與測量點之間的偏移距離。

「動作參數」區域

  • 預碰距離 - 指定測頭將要開始搜尋表面的位置。表示與標稱表面的距離，測頭將以設定螢幕中所確定的「搜尋」速度移動。

  • 搜尋距離 - 指定在學習模式中搜尋曲面時測頭運行的距離。例如，如果測頭位於孔的中心，測頭將以設定螢幕上確定的「搜尋速度」移動，搜尋每個方向上的距離，尋找和學習特徵的位置。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可用來返回至目前程序的上一步。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
選取測量面 此螢幕按鍵可決定觸測方向和移動到特徵的安全位置。您可按多次選取不同的測量面。 可用的測量面有：上、左、右、前、後和傾斜。若選取「傾斜」，螢幕按鍵圖示將變為傾斜圖示。 | 設定工作偏移 此螢幕按鍵可用來顯示一個新螢幕，其中包含在各種情況下更新工作偏移所用的新螢幕按鍵。
選取要更新的工作偏移 每次按下此螢幕按鍵，均可逐個捲動工作偏移清單。 | 執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。
選取測頭 若選取測頭螢幕並非目前螢幕，則此螢幕按鍵將存取此螢幕。若選取測頭螢幕已可見，則觸碰此螢幕按鍵可捲動瀏覽測頭清單中的每個測頭。 | 確認更新工作偏移 在測量機已學習特徵位置之後方可使用此螢幕按鍵。此按鍵可將命令儲存至測量程式。
取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |

更新程序

  1. 將測頭置於此點之上。

  2. 按一下讀取位置螢幕按鍵 [image] 。測尖位置被讀取為內徑中心以及與表面之間的距離。按一下返回上一步螢幕按鍵 [image] 取消此位置並讀取新位置。

  3. 按執行螢幕按鍵 [image] ；NC Gage 將自動沿著與標稱工作面相反的方向對點進行觸測。測頭將搜尋測頭半徑加 3 倍預碰距離的距離。

  4. 完成觸測後，測量值將會更新。按選取要更新的工作偏移螢幕按鍵 [image] ，從清單中選取工作偏移名稱，直至所需的工作偏移反白顯示。選取每個反白顯示的工作偏移參數即可在螢幕上進行更新。

  5. 按一下確認螢幕按鍵 [image] ，儲存工作位移值並更新軸。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

特定的特徵路徑和 NC Gage 內置邏輯

  • 讀取表面之上的測頭位置。

  • 測量表面，且搜尋距離為測頭半徑加 3 倍預碰距離。

  • 返回至讀取位置點。


設定兩條軸（內徑）

設定帶有內徑的兩條軸螢幕按鍵可測量工件上的圓形內徑（內圓特徵），然後使用其中心坐標更新指定的工作偏移。

  1. 按主螢幕第二頁的設定工作偏移螢幕按鍵 [image] 。底部的螢幕按鍵變更為顯示不同類型的特徵，您可測量這些特徵以設定工作偏移。

  2. 按設定帶有內徑的兩條軸螢幕按鍵 [image] ，顯示設定兩條軸（內徑）螢幕：

  3. 遵循螢幕上的指示測量圓，選取要更新的工作偏移，然後按確認螢幕按鍵 [image] 更新工作偏移。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

「測頭定義」區域

顯示與目前載入的測頭相關的資訊。

「測尖偏移」區域

  • 測尖偏移 X、Y 和 Z - 相對於標準塊直線的測頭測尖位置。

「工作偏移」區域

  • 工作偏移 - 指定要更新的工作偏移。

「參數」區域

  • 測量值 - 指定工作偏移的位置。該值可從圓形（內徑）學習程序中進行學習並顯示在機器坐標中。

  • 目標值 - 工作偏移將為與已測量特徵之間的偏移距離。

「動作參數」區域

  • 預碰距離 - 指定測頭將要開始搜尋表面的位置。表示與標稱表面的距離，測頭將以設定螢幕中所確定的「搜尋」速度移動。

  • 搜尋距離 - 指定在學習模式中搜尋曲面時測頭運行的距離。例如，如果測頭位於孔的中心，測頭將以設定螢幕上確定的「搜尋速度」移動，搜尋每個方向上的距離，尋找和學習特徵的位置。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可用來返回至目前程序的上一步。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
選取要更新的工作偏移 每次按下此螢幕按鍵，均可逐個捲動工作偏移清單。 | 選取測頭 若選取測頭螢幕並非目前螢幕，則此螢幕按鍵將存取此螢幕。若選取測頭螢幕已可見，則觸碰此螢幕按鍵可捲動瀏覽測頭清單中的每個測頭。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。 | 確認更新工作偏移 在測量機已學習特徵位置之後方可使用此螢幕按鍵。此按鍵可將命令儲存至測量程式。
取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |

更新程序

備註：對於頭部有測座軸的機器，學習程序僅支援沿機器軸測頭方向進行。

  1. 將測頭置於內徑的中心。

  2. 按一下讀取位置螢幕按鍵 [image] 。測尖位置被讀取為內徑中心以及與表面之間的距離。按一下返回上一步螢幕按鍵 [image] 取消此位置並讀取新位置。

  3. 按執行螢幕按鍵 [image] ；NC Gage 將驅動測頭並透過採集四個自動測點搜尋圓形（內徑）。這樣即可確定圓形的中心。

    表示開始手動位置的圖像將測頭分疊至 (A) 以及 NC Gage所用的自動觸測路徑（紅線），因為它可測量四個點（位置 1-4）

  4. 完成觸測後，測量值將使用圓心進行更新。按選取要更新的工作偏移螢幕按鍵 [image] ，從清單中選取工作偏移名稱，直至所需的工作偏移反白顯示。選取每個反白顯示的工作偏移參數即可在螢幕上進行更新。

  5. 按確認螢幕按鍵 [image] 更新已選取的工件偏移。若軸與工作面不平行，則將更新標準工件偏移值。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

特定的特徵路徑和 NC Gage 內置邏輯

  • 讀取內經中心的測頭位置。

  • 內徑的測量值將出現在讀取點的 Z 值中。

  • 估計內徑中心 XY 將成為讀取點。

  • 使用搜尋距離在 +X 方向上的測量點。

  • 返回至中心位置。

  • 使用搜尋距離在 –X 方向上的測量點。

  • 返回至中心位置。

  • 使用搜尋距離在 +Y 方向上的測量點。

  • 返回至中心位置。

  • 使用搜尋距離在 –Y 方向上的測量點。

  • 返回至中心位置。


設定兩條軸（突起部）

設定帶有突起部的兩條軸螢幕按鍵可測量工件上的圓形突起部（外圓特徵），然後使用其中心坐標更新指定的工作偏移。

  1. 按主螢幕第二頁的設定 工作偏移螢幕按鍵 [image] 。底部的螢幕按鍵變更為顯示不同類型的特徵，您可測量這些特徵以設定工作偏移。

  2. 按設定帶有突起部的兩條軸螢幕按鍵 [image] ，顯示設定兩條軸（突出部）螢幕：

  3. 遵循螢幕上的指示測量圓，選取要更新的工作偏移，然後按確認螢幕按鍵 [image] 更新工作偏移。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

「測頭定義」區域

顯示與目前載入的測頭相關的資訊。

「測尖偏移」區域

  • 測尖偏移 X、Y 和 Z - 相對於標準塊直線的測頭測尖位置。

「工作偏移」區域

  • 工作偏移 - 指定要更新的工作偏移。

「參數」區域

  • 測量值 - 指定工作偏移的位置。該值可從圓形（突起部）學習程序中進行學習並顯示在機器坐標中。

  • 目標值 - 工作偏移將為與已測量特徵之間的偏移距離。

「動作參數」區域

  • 預碰距離 - 指定測頭將要開始搜尋表面的位置。表示與標稱表面的距離，測頭將以設定螢幕中所確定的「搜尋」速度移動。

  • 搜尋距離 - 指定在學習模式中搜尋曲面時測頭運行的距離。例如，如果測頭位於孔的中心，測頭將以設定螢幕上確定的「搜尋速度」移動，搜尋每個方向上的距離，尋找和學習特徵的位置。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可用來返回至目前程序的上一步。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
選取要更新的工作偏移 每次按下此螢幕按鍵，均可逐個捲動工作偏移清單。 | 選取測頭 若選取測頭螢幕並非目前螢幕，則此螢幕按鍵將存取此螢幕。若選取測頭螢幕已可見，則觸碰此螢幕按鍵可捲動瀏覽測頭清單中的每個測頭。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。 | 確認更新工作偏移 在測量機已學習特徵位置之後方可使用此螢幕按鍵。此按鍵可將命令儲存至測量程式。
取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |

遵循螢幕上的指示測量圓，選取要更新的工作偏移，然後按確定更新工作偏移。

更新程序

備註：對於頭部有測座軸的機器，學習程序僅支援沿機器軸測頭方向進行。

  1. 將測頭置於突起側（如下顯示為位置 A）的側邊。按一下讀取位置 [image] 螢幕按鍵。在測量期間，與工作面表面之間的距離將相同。

  2. 將測頭置於如下位置 B 顯示的突起部中心之上。按一下讀取位置 [image] 螢幕按鍵。此位置將用於確定突起部的中心以及與突起部之間的距離，確保在測量點之間的安全移動。按一下返回上一步螢幕按鍵 [image] 取消此測量位置。

  3. 按一下執行螢幕按鍵 [image] 。NC Gage 在此位置下方進行一次觸測以決定突起部的高度。然後，它將以下述相同的方式自動進行觸測。

    表示手動位置的圖像將測頭分疊至 (A-B) 以及 NC Gage所用的自動觸測路徑（紅線），因為它可測量四個點（位置 1-4）

  4. 完成觸測後，測量值將使用圓心進行更新。按選取要更新的工作偏移螢幕按鍵 [image] ，從清單中選取工作偏移名稱，直至所需的工作偏移反白顯示。選取每個反白顯示的工作偏移參數即可在螢幕上進行更新。

  5. 按一下確認螢幕按鍵 [image] 更新標準工作面中軸的工作位移。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

特定的特徵路徑和 NC Gage 內置邏輯

  • 測頭的讀取位置靠近突起測；Z 值為測量高度。

  • 讀取突起部中心之上的測頭位置。XY 值定義中心；Z 值為安全高度。

  • 預碰半徑 = 兩個讀取位置點之間的預計 2D 距離。

  • 移至安全高度。

  • 將安全高度移至預測點 1 上方的一個點，此點是 +X 方向上中心的預測點距離。

  • 下降至測量高度。

  • 測量點、目標是測量高度上的中心。

  • 移至安全高度。

  • 將安全高度移至預測點 2 上方的一個點，此點是 -X 方向上中心的預測點距離。

  • 下降至測量高度。

  • 測量點、目標是測量高度上的中心。

  • 移至安全高度。

  • 將安全高度移至預測點 3 上方的一個點，此點是 +Y 方向上中心的預測點距離。

  • 下降至測量高度。

  • 測量點、目標是測量高度上的中心。

  • 移至安全高度。

  • 將安全高度移至預測點 4 上方的一個點，此點是 -Y 方向上中心的預測點距離。

  • 下降至測量高度。

  • 測量點、目標是測量高度上的中心。

  • 移至安全高度。


設定兩條軸（內棱角）

設定帶有內棱角的兩條軸螢幕按鍵可測量工件上的內棱角，然後使用其棱角坐標更新指定的工作偏移。

  1. 按主螢幕第二頁的設定 工作偏移螢幕按鍵 [image] 。底部的螢幕按鍵變更為顯示不同類型的特徵，您可測量這些特徵以設定工作偏移。

  2. 按設定帶有內棱角的兩條軸螢幕按鍵 [image] ，顯示設定兩條軸（內棱角）螢幕：

「測頭定義」區域

顯示測量程式中所用的目前選取的測頭資訊。

「工作偏移」區域

  • 工作偏移 - 指定要更新的工作偏移。

「參數」區域

  • XYZ 測量值/目標值 - 指定工作偏移的測量和目標 XYZ 位置。可從棱角（內部）學習程序中學習測量值。

「動作參數」區域

  • 預碰距離 - 指定測頭將要開始搜尋表面的位置。表示與標稱表面的距離，測頭將以設定螢幕中所確定的「搜尋」速度移動。

  • 搜尋距離 - 指定在學習模式中搜尋曲面時測頭運行的距離。例如，如果測頭位於孔的中心，測頭將以設定螢幕上確定的「搜尋速度」移動，搜尋每個方向上的距離，尋找/學習特徵的位置。

「本地安全平面」區域

  • 觸測安全平面 - 選取此選項可將測頭移動至各個特徵測點之間的安全平面上。在右側方塊中輸入平面距離。此平面不是測量程式安全平面。有關詳細資料，請參閱「觸測安全平面」。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可用來返回至目前程序的上一步。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
選取要更新的工作偏移 每次按下此螢幕按鍵，均可逐個捲動工作偏移清單。 | 選取測頭 若選取測頭螢幕並非目前螢幕，則此螢幕按鍵將存取此螢幕。若選取測頭螢幕已可見，則觸碰此螢幕按鍵可捲動瀏覽測頭清單中的每個測頭。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
確認更新工作偏移 在測量機已學習特徵位置之後方可使用此螢幕按鍵。此按鍵可將命令儲存至測量程式。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |

遵循螢幕上的指示測量內棱角，選取要更新的工作偏移，然後按確認螢幕按鍵 [image] 更新所選的工作偏移。

更新程序

  1. 將測頭置於組成角的表面之上。

  2. 按一下讀取位置螢幕按鍵 [image] 。

  3. 將測頭置於同一面上的第一個點旁邊。

  4. 按一下讀取位置螢幕按鍵 [image] 。

  5. 將測頭置於組成角的第二個表面旁邊。

  6. 按一下讀取位置螢幕按鍵 [image] 。

  7. 將測頭置於此第二個表面上的第一個點旁邊。

  8. 按一下讀取位置螢幕按鍵 [image] 。

  9. 按一下執行螢幕按鍵 [image] ，NC Gage將自動按照下列所描述之形式採集測點。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

左側的圖像中顯示了應放置測頭的手動分疊位置 (A-D)。右側的圖像中顯示了 NC Gage 在測量位置 1-4 處的四個點時所採集的自動觸測路徑（紅線）

  10. 完成觸測後，測量值將使用棱角的位置進行更新。按選取要更新的工作偏移螢幕按鍵 [image] ，從清單中選取工作偏移名稱，直至所需的工作偏移反白顯示。選取每個反白顯示的工作偏移參數即可在螢幕上進行更新。

  11. 按一下確認螢幕按鍵 [image] 更新工作位移。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

特定的特徵路徑和 NC Gage 內置邏輯

  • 如果運行測座機器，則沿機器軸旋轉測頭。

  • 測頭的讀取位置靠近棱角第一個邊上的第一個點。將在此點的同一層進行所有測量。

在測座機器上，需要先沿機器軸旋轉測頭。測量棱角特徵可更新工作偏移的其他兩條軸：

    • 如果測頭沿機器的 Z 軸，則第一個讀取點將更新參數 X 和 Y 軸區域。

    • 如果測頭沿機器的 X 軸，則第一個讀取點將更新參數 Y 和 Z 軸區域。

    • 如果測頭沿機器的 Y 軸，則第一個讀取點將更新參數 X 和 Z 軸區域。

  • 測頭的讀取位置靠近棱角第一個邊上的第二個點。

  • 測頭的讀取位置靠近棱角第二個邊上的第一個點。

  • 測頭的讀取位置靠近棱角第二個邊上的第二個點。

  • 決定第一和第一個方向向量以及法向量。

  • 補償點。

  • 決定近似棱角點。

  • 將測頭置於第一個讀取點位置。

  • 測量第一個側面，搜尋距離為 4* 逼近距離。

  • 將測頭置於第二個讀取點旁邊。

  • 測量第一個側面，搜尋距離為 4* 逼近距離。

  • 將測頭置於第三個讀取點旁邊。

  • 測量第二個側面，搜尋距離為 4* 逼近距離。

  • 將測頭置於第四個讀取點旁邊。

  • 測量第二個側面，搜尋距離為 4* 逼近距離。


設定兩條軸（外棱角）

設定帶有外棱角的兩條軸螢幕按鍵可測量工件上的外棱角，然後使用其棱角坐標更新指定的工作偏移。

  1. 按主螢幕第二頁的設定 工作偏移螢幕按鍵 [image] 。底部的螢幕按鍵將變更為顯示不同類型的特徵，您可測量這些特徵以設定工作偏移。

  2. 按一下設定帶有外棱角的兩條軸螢幕按鍵 [image] ，顯示設定兩條軸（外棱角）螢幕：

「測頭定義」區域

顯示測量程式中所用的目前選取的測頭資訊。

「工作偏移」區域

  • 工作偏移 - 指定要更新的工作偏移。

「參數」區域

  • XYZ 測量值/目標值 - 指定工作偏移的測量和目標 XYZ 位置。可從棱角（外部）學習程序中學習測量值。

「動作參數」區域

  • 預碰距離 - 指定測頭將要開始搜尋表面的位置。表示與標稱表面的距離，測頭將以設定螢幕中所確定的「搜尋」速度移動。

  • 搜尋距離 - 指定在學習模式中搜尋曲面時測頭運行的距離。例如，如果測頭位於孔的中心，測頭將以設定螢幕上確定的「搜尋速度」移動，搜尋每個方向上的距離，尋找/學習特徵的位置。

「本地安全平面」區域

  • 觸測安全平面 - 選取此選項可將測頭移動至各個特徵測點之間的安全平面上。在右側方塊中輸入平面距離。此平面不是測量程式安全平面。有關詳細資料，請參閱「觸測安全平面」。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可用來返回至目前程序的上一步。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
選取要更新的工作偏移 此螢幕按鍵可從待更新的偏移清單中選取已命名的工作偏移。再次按下此鍵可選取清單中的下一個工作偏移。 | 選取測頭 若選取測頭螢幕並非目前螢幕，則此螢幕按鍵將存取此螢幕。若選取測頭螢幕已可見，則觸碰此螢幕按鍵可捲動瀏覽測頭清單中的每個測頭。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
確認更新工作偏移 在機器已學習特徵位置之後方可使用。此按鍵可將命令儲存至測量程式。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |

遵循螢幕上的指示測量外棱角，選取要更新的工作偏移，然後按確認螢幕按鍵 [image] 更新所選的工作偏移。

更新程序

  1. 將測頭置於組成角的表面之上。

  2. 按一下讀取位置螢幕按鍵 [image] 。

  3. 將測頭置於同一面上的第一個點旁邊。

  4. 按一下讀取位置螢幕按鍵 [image] 。

  5. 將測頭置於組成角的第二個表面旁邊。

  6. 按一下讀取位置螢幕按鍵 [image] 。

  7. 將測頭置於此第二個表面上的第一個點旁邊。

  8. 按一下讀取位置螢幕按鍵 [image] 。

  9. 選取執行螢幕按鍵 [image] ，NC Gage將自動按照下列所描述之形式採集測點。

左側的圖像中顯示了應放置測頭的手動分疊位置 (A-E)。右側的圖像中顯示了 NC Gage 在測量位置 1-4 處的四個點時所採集的自動觸測路徑（紅線）。

  10. 完成觸測後，測量值將使用棱角的位置進行更新。按選取要更新的工作偏移螢幕按鍵 [image] ，從清單中選取工作偏移名稱，直至所需的工作偏移反白顯示。選取每個反白顯示的工作偏移參數即可在螢幕上進行更新。

  11. 按一下確認螢幕按鍵 [image] 更新工作位移。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

特定的特徵路徑和 NC Gage 內置邏輯

  • 如果運行測座機器，則沿機器軸旋轉測頭。

  • 測頭的讀取位置靠近棱角第一個邊上的第一個點。將在此點的同一層進行所有測量。

在測座機器上，需要先沿機器軸旋轉測頭。測量棱角特徵可更新工作偏移的其他兩條軸：

    • 如果測頭沿機器的 Z 軸，則第一個讀取點將更新參數 X 和 Y 軸區域。

    • 如果測頭沿機器的 X 軸，則第一個讀取點將更新參數 Y 和 Z 軸區域。

    • 如果測頭沿機器的 Y 軸，則第一個讀取點將更新參數 X 和 Z 軸區域。

  • 測頭的讀取位置靠近棱角第一個邊上的第二個點。

  • 測頭的讀取位置靠近棱角第二個邊上的第一個點。

  • 測頭的讀取位置靠近棱角第二個邊上的第二個點。

  • 決定第一和第一個方向向量以及法向量。

  • 補償點。

  • 決定近似棱角點。

  • 檢查測頭位置。若外棱角不明確，則應將測頭移至由四個學習點所形成的兩條直線的交叉位置。執行此項移動時，應進行雙軸移動。若位置高於測量高度，則應首先移動 XY，然後移動 Z；若位置低於測量高度，則應向上移至 Z 處，然後移動 ZY。

  • 將測頭置於第一個讀取點位置。

  • 測量第一個側面，深度符合第二個邊上的第一個點。

  • 將測頭置於第二個讀取點旁邊。

  • 測量第一個側面，深度符合第二個邊上的第一個點。

  • 移至棱角外的點以避免碰撞。

  • 將測頭置於第三個讀取點旁邊。

  • 測量第二個側面，深度符合第一個邊上的第一個點。

  • 將測頭置於第四個讀取點旁邊。

  • 測量第二個側面，深度符合第一個邊上的第一個點。


設定帶有球體的三條軸

設定帶有球體的三條軸螢幕按鍵可測量球體，然後使用測量所得的坐標更新指定的工作偏移。

點數定義測量球體時所用的點數。下層角通常為 0（赤道） ，可定義要測量的最低層。上層角通常為 90（北極），可定義要測量的最高層。

  1. 按主螢幕第二頁的設定 工作偏移螢幕按鍵 [image] 。底部的螢幕按鍵將變更為顯示不同類型的特徵，您可測量這些特徵以設定工作偏移。

  2. 按設定帶有球體的三條軸螢幕按鍵 [image] ，顯示設定三條軸（球體）螢幕：

  3. 遵循螢幕上的指示，然後按確認螢幕按鍵 [image] 完成程序。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

「工作偏移」區域

  • 工作偏移 - 指定要更新的工作偏移。

「參數」區域

  • 參數 X、Y 和 Z - 定義球體的中心。測量欄指定工作偏移的測量值。目標欄定義工作偏移坐標中球體中心的理論值。理論值可為任何值，但通常為零。

「測尖偏移」區域

  • 測尖偏移 X、Y 和 Z - 工作偏移將為與測量特徵之間的偏移距離。

「動作參數」區域

  • 預碰距離 - 指定測頭將要開始搜尋表面的位置。表示與標稱表面的距離，測頭將以設定螢幕中所確定的「搜尋」速度移動。

  • 搜尋距離 - 指定在學習模式中搜尋曲面時測頭運行的距離。例如，如果測頭位於孔的中心，測頭將以設定螢幕中確定的「搜尋速度」移動，搜尋每個方向上的距離，尋找/學習特徵的位置。

「屬性」區域

  • 點數 - 定義測量球體時所用的點數。

  • 下層角 - 通常為 0（赤道）；可定義要測量的最低層。

  • 上層角 - 通常為 90（北極）；可定義要測量的最高層。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可用來返回至目前程序的上一步。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
選取測量面 此螢幕按鍵可決定觸測方向和移動到特徵的安全位置。您可按多次選取不同的測量面。 可用的測量面有：上、左、右、前、後和傾斜。若選取「傾斜」，螢幕按鍵圖示將變為傾斜圖示。 | 設定工作偏移 此螢幕按鍵可用來顯示一個新螢幕，其中包含在各種情況下更新工作偏移所用的新螢幕按鍵。
選取要更新的工作偏移 此螢幕按鍵可從待更新的偏移清單中選取已命名的工作偏移。再次按下此鍵可選取清單中的下一個工作偏移。 | 執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。
選取測頭 若選取測頭螢幕並非目前螢幕，則此螢幕按鍵將存取此螢幕。若選取測頭螢幕已可見，則觸碰此螢幕按鍵可捲動瀏覽測頭清單中的每個測頭。 | 確認更新工作偏移 在測量機已學習特徵位置之後方可使用此螢幕按鍵。此按鍵可將命令儲存至測量程式。
取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |

遵循螢幕上的指示，選取要更新的工作偏移，然後按確認螢幕按鍵 [image] 更新所選的工作偏移。

更新程序

  1. 將測頭置於球體中心頂部之上（如下圖中所示的位置 A），然後按讀取位置螢幕按鍵 [image] 。

  2. 按學習和建立命令螢幕按鍵 [image] 。

  3. 運行系統監視器程式。NC Gage 將自動按照下列所描述之形式採集測點。

球體路徑：A) 點動位置 1-4) 動測量的點位置。

  4. 測量特徵後，測量值將進行更新。按選取要更新的工作偏移螢幕按鍵 [image] ，從清單中選取工作偏移名稱，直至所需的工作偏移反白顯示。選取每個反白顯示的工作偏移參數即可在螢幕上進行更新。

  5. 按一下確認螢幕按鍵 [image] 更新工作位移。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

特定的特徵路徑和 NC Gage 內置邏輯

學習球體特徵路徑

透過測量球體頂部的點以及取樣頂部附近的其他三個點可確定球體的位置和大小。這是學習球體特徵的方式。確定球體位置和大小後，球體使用學習的大小和位置重新測量。使用在動作參數和屬性方塊中設定的值執行測量。

  • 測頭的讀取位置應位於球體頂部之上。

  • 使用搜尋距離直接向下測量點。

  • 撤回至原始讀取位置並以 +X 方向移動 2* 測頭半徑。

  • 使用搜尋距離直接向下測量點。

  • 撤回至原始高度並以與 +X 軸呈 120 度的方向移動 2* 測頭半徑。

  • 使用搜尋距離直接向下測量點。

  • 撤回至原始高度並以與 +X 軸呈 240 度的方向移動 2* 測頭半徑。

  • 使用搜尋距離直接向下測量點。

  • 撤回至原始高度。

執行球體特徵路徑

  • 可依據輸入內容確定每一層的層數和點數。

  • 如果目前位置低於安全平面高度，則應向上移動至安全平面。

  • 移至第一個預測點之上的位置處。

  • 下降至最低層並對該層進行測量，若需要，可在一層中的每個點之間新增迴避移動，以防止發生碰撞。

  • 使用交替方向測量其餘層。

  • 測量球體頂部的點（若頂層角度為 90）。

  • 移至安全平面高度。


將一條軸設定在中點

將一條軸設定在中點螢幕按鍵可將工作偏移的一條軸設定為兩個平行表面之間一半的值。

  1. 按主螢幕上的 設定工作偏移螢幕按鍵 [image] 。底部的螢幕按鍵變更為顯示不同類型的特徵，您可測量這些特徵以設定工作偏移。

  2. 按將一條軸設定在中點螢幕按鍵 [image] ，顯示將一條軸設定在中點螢幕：

「測頭定義」區域

顯示測量程式中所用的目前選取的測頭資訊。

「工作偏移」區域

  • 工作偏移 - 指定要更新的工作偏移。

「參數」區域

  • X、Y 或 Z 測量值 - 指定工作偏移的位置。可從點學習過程中學習該值。軸將根據軸區域中選取的方向不同而不同。

備註：此螢幕左上區域的螢幕圖示圖像會根據從軸和形狀區域中作出的選取進行更新。

  • 目標 - 工作偏移會被設定，以便啟用工作偏移時測量的中點與目標值一致。

「動作參數」區域

  • 預碰距離 - 指定測頭將要開始搜尋表面的位置。表示與標稱表面的距離，測頭將以設定螢幕中所確定的「搜尋」速度移動。

  • 搜尋距離 - 指定在學習模式中搜尋曲面時測頭運行的距離。例如，如果測頭位於孔的中心，測頭將以設定螢幕上確定的「搜尋速度」移動，搜尋每個方向上的距離，尋找/學習特徵的位置。

「軸」區域

  • 選取兩個曲面的測量方向，以計算中點。參數區域會相應更新。

「形狀」區域

  • 選取待測量的特徵形狀，以計算中點。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可用來返回至目前程序的上一步。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
選取要更新的工作偏移 每次按下此螢幕按鍵，均可逐個捲動工作偏移清單。 | 執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。
選取測頭 若選取測頭螢幕並非目前螢幕，則此螢幕按鍵將存取此螢幕。若選取測頭螢幕已可見，則觸碰此螢幕按鍵可捲動瀏覽測頭清單中的每個測頭。 | 確認更新工作偏移 在測量機已學習特徵位置之後方可使用此螢幕按鍵。此按鍵可將命令儲存至測量程式。
取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |

學習過程

  1. 根據需要，從螢幕上的軸區域選取特定軸。可用的軸包括 X 軸、Y 軸和 Z 軸。

  2. 根據需要，從螢幕的形狀區域選取特定形狀。可用的形狀有網狀、槽和階梯。設定 X 或 Y 軸時可使用這三個形狀。設定 Z 軸時僅可使用階梯形狀。

備註：此螢幕左上角的螢幕圖示圖像會根據從軸和形狀區域中作出的選取進行更新。

  3. 輸入目標值。

以下矩陣說明每個形狀/軸組合的學習步驟：

X、Y 或 Z 軸

網路

  1. 凸臺的一側。

  2. 凸臺的另一側。

  3. 定義從一側移至另一側的安全高度。

槽

  1. 第一個槽側。

  2. 第二個點側。

階梯

  1. 靠近第一個階梯級別上的點。

  2. 靠近第二個階梯級別上的點。

  3. 從第二點中移開。

  4. 根據需要設定預碰距離和搜尋距離。可隨時進行此操作。

  5. 選取要更新的工作偏移。可隨時進行此操作。

  6. 學習定義測量的點後，您將需按執行螢幕按鍵 [image] 。NC Gage 會繼續測量工件。中點值已計算出來並顯示在螢幕上。

  7. 按一下確認螢幕按鍵 [image] 接受並儲存結果，或按一下取消螢幕按鍵 [image] 拒絕且不儲存結果。

形狀範例

階梯形狀

槽狀和網狀：


設定帶有直線的旋轉角度軸

Home > 使用 PC-DMIS NC Gage > 入門 > 第 6 步：選取工作偏移 > 設定工作偏移 > 設定帶有直線的旋轉軸角度

設定帶有直線的旋轉軸角度

使用設定旋轉軸（角度）螢幕可定義和顯示可在旋轉軸平面中產生明確角度的所有特徵。

使用下列步驟存取此螢幕：

  1. 按主螢幕第二頁的設定工作偏移螢幕按鍵 [image] 。底部的螢幕按鍵變更為顯示不同類型的特徵，您可測量這些特徵以設定工作偏移。

  2. 按設定帶有直線的旋轉角度軸螢幕按鍵 [image] ，顯示設定旋轉軸（角度）螢幕：

  3. 遵循螢幕上的指示，然後按確認螢幕按鍵 [image] 完成程序。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

「測尖偏移」區域

  • 測尖偏移 X、Y 和 Z - 相對於標準塊直線的測頭測尖位置。

「工作偏移」區域

  • 工作偏移 - 指定要更新的工作偏移。

「旋轉臺」區域

  • 軸 ID - 用來標識軸的字母 A、B 或 C，依據系統中定義的旋轉臺數量確定。

「測量值」區域

  • 角度 - 顯示旋轉臺角度的測量值和目標值。

「屬性」區域

  • 點數 - 定義要測量的點數。

「動作參數」區域

  • 預碰距離 - 定義遠離標稱曲面的距離，測頭在測量過程中在此標稱曲面上開始搜尋曲面。

  • 搜尋距離 - 搜尋距離為測頭在學習模式中搜尋曲面時運行的距離。例如，如果測頭位於孔的中心，測頭將以設定螢幕上確定的「搜尋速度」移動，搜尋每個方向上的距離，尋找/學習特徵的位置。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可用來返回至目前程序的上一步。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
選取測量面 此螢幕按鍵可決定觸測方向和移動到特徵的安全位置。您可按多次選取不同的測量面。 可用的測量面有：上、左、右、前、後和傾斜。若選取「傾斜」，螢幕按鍵圖示將變為傾斜圖示。 | 設定工作偏移 此螢幕按鍵可用來顯示一個新螢幕，其中包含在各種情況下更新工作偏移所用的新螢幕按鍵。
選取要更新的工作偏移 此螢幕按鍵可從待更新的偏移清單中選取已命名的工作偏移。再次按下此鍵可選取清單中的下一個工作偏移。 | 執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。
選取測頭 若選取測頭螢幕並非目前螢幕，則此螢幕按鍵將存取此螢幕。若選取測頭螢幕已可見，則觸碰此螢幕按鍵可捲動瀏覽測頭清單中的每個測頭。 | 確認更新工作偏移 在測量機已學習特徵位置之後方可使用此螢幕按鍵。此按鍵可將命令儲存至測量程式。
取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |

學習過程

概念是測量「旋轉臺平面」中的直線，以便依據此直線設定工作偏移的旋轉軸元件。此直線的測量值可確定平面中的角度，旋轉軸角度將在已更新的工作偏移處於可用狀態時與目標角度匹配。

測量直線時有兩種不同的狀況：

  • 第一種情況是旋轉臺平面的標準軸與主軸平行（或不平行） 。

在上圖中，C 軸中傾斜角為 30 度的工件位於旋轉臺上。您想更新旋轉軸 C 的工作偏移，以便新工作偏移在使用中時，工作坐標系 X+ 與直線方向一致。

首先，您應旋轉旋轉臺 C，將黃線方向與近似工作偏移零位置 (X+) 對齊。從此步驟中，NC Gage 可識別出從直線計算的目標值為 30 左右而非 30+180=210 度。

除此粗對齊指定條件之外，學習步驟與在 NC Gage 中測量直線程序的步驟完全相同。

如下所示，正在測量前表面的黃線方向。您可透過提示學習點 1、2 和 3 的位置。在 NC Gage 告知這些點位置後，NC Gage 即具備了自動測量直線所需的資訊。

在上圖中，以黑色顯示的直線方向可表示測量路徑。可將測頭置於顯示的三個位置，完成此作業。

  • 第二種情況是旋轉臺平面的標準軸與主軸垂直。

在上圖中，A 軸中傾斜角為 30 度的工件位於旋轉臺上。您想更新旋轉軸 A 的工作偏移，以便新工作偏移在使用中時，工作坐標系 Y + 與黃線方向一致。

首先，您應旋轉旋轉臺 A，將黃線方向與近似工作偏移零位置 (Y+) 對齊。從此步驟中 NC Gage 可識別出從直線計算的目標值為 30 左右而非 30+180=210 度。

在此情況下，除粗對齊指定條件之外，學習直線還少了一個步驟。這是因為在第一種情況下，我們無法透過前兩個點確定工件處於已定義直線的「左側」還是「右側」，因此您可根據指示從表面上「移開」，以學習第三個點。

這不同於第二種情況，因為測頭的方向和旋轉臺平面的方向已經確定，我們不需要提示您學習第三個點。

此時，您即可嘗試測量平面中透過微調一端的旋轉臺定義的黃線方向（看起來像上圖中所示的銷釘）。

您可透過提示學習點 1 和 2 的位置。在 NC Gage 告知這些點位置後，NC Gage 即具備了自動測量直線所需的資訊。

在上述範例中，以黑色顯示的直線方向表示測量路徑。可將測頭定位於顯示的兩個位置，以完成此作業。


設定帶有按鍵槽的旋轉軸(角度)

使用設定帶按鍵槽的旋轉軸（角度）螢幕可定義和顯示在旋轉軸中產生明確角度的所有特徵。

若要存取此螢幕：

  1. 按主螢幕第二頁的設定工作偏移螢幕按鍵 [image] 。底部的螢幕按鍵變更為顯示不同類型的特徵，您可測量這些特徵以設定工作偏移。

  2. 按設定帶按鍵槽的旋轉軸（角度）功能鍵 [image] ，顯示設定帶按鍵槽的旋轉軸（角度）螢幕：

  3. 遵循螢幕上的指示，然後按確認螢幕按鍵 [image] 完成程序。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

「測尖偏移」區域

  • 測尖偏移 X、Y 和 Z - 相對於標準塊直線的測頭測尖位置。

「工作偏移」區域

  • 工作偏移 - 指定要更新的工作偏移。

「旋轉臺」區域

  • 軸 ID - 用來標識軸的字母 A、B 或 C，依據系統中定義的旋轉臺數量確定。

「測量值」區域

  • 角度 - 顯示旋轉臺角度的測量值和目標值。

「動作參數」區域

  • 逼近角 - 定義遠離標稱表面的角度，測頭將開始在此標稱表面上以測量速度趨近測量點。

  • 搜尋角度範圍 - 定義尋找和學習特徵時的搜尋角度範圍。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可用來返回至目前程序的上一步。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
選取測量面 此螢幕按鍵可決定觸測方向和移動到特徵的安全位置。您可按多次選取不同的測量面。 可用的測量面有：上、左、右、前、後和傾斜。若選取「傾斜」，螢幕按鍵圖示將變為傾斜圖示。 | 設定工作偏移 此螢幕按鍵可用來顯示一個新螢幕，其中包含在各種情況下更新工作偏移所用的新螢幕按鍵。
選取要更新的工作偏移 此螢幕按鍵可從待更新的偏移清單中選取已命名的工作偏移。再次按下此鍵可選取清單中的下一個工作偏移。 | 執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。
選取測頭 若選取測頭螢幕並非目前螢幕，則此螢幕按鍵將存取此螢幕。若選取測頭螢幕已可見，則觸碰此螢幕按鍵可捲動瀏覽測頭清單中的每個測頭。 | 確認更新工作偏移 在測量機已學習特徵位置之後方可使用此螢幕按鍵。此按鍵可將命令儲存至測量程式。
取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |

學習處理序

請參閱「按鍵槽」話題中的「學習過程」。

執行處理序

請參閱「按鍵槽」話題中的「執行過程」。


設定帶有平面的旋轉角度

設定帶有平面的旋轉角度螢幕可設定一對旋轉臺的工作偏移零值，使主軸測量面成直角。

此選項僅適用於有兩個（堆疊式）旋轉臺的系統。透過測量平面，它可以同時設定兩個旋轉臺的工作位移零值。NC Gage 計算角度時需要使平面垂直於測頭。

使用下列步驟存取此螢幕：

  1. 按主螢幕第二頁的設定 工作偏移螢幕按鍵 [image] 。底部的螢幕按鍵將變更為顯示不同類型的特徵，您可測量這些特徵以設定工作偏移。

  2. 按設定帶平面的旋轉角度螢幕按鍵 [image] ，顯示設定帶平面的旋轉角度螢幕：

「測尖偏移」區域

  • 測尖偏移 X、Y 和 Z - 相對於標準塊直線的測頭測尖位置。

「工作偏移」區域

  • 工作偏移 - 指定要更新的工作偏移。

「測量值」區域

  • 角度 - 顯示旋轉臺角度的測量值和目標值。

「測量方法」區域

  • 格線陣列 - 定義了測量平面時一系列列所用的測量方法。

  • 圓形陣列 - 定義了測量平面時圓形結構中所用的測量方法。

「屬性」區域

  • 列數 - 定義了對格線陣列平面進行定義時待測量的列數。

  • 每列點數 - 定義了對格線陣列 平面進行定義時待測量的每列上的點數。

  • 點數 - 定義了對圓形陣列平面進行定義時待測量的點數。

「動作參數」區域

  • 預碰距離 - 指定測頭將要開始搜尋表面的位置。表示與標稱表面的距離，測頭將以設定螢幕中所確定的「搜尋」速度移動。

  • 搜尋距離 - 指定在學習模式中搜尋曲面時測頭運行的距離。例如，如果測頭位於孔的中心，測頭將以設定螢幕中確定的「搜尋速度」移動，搜尋每個方向上的距離，尋找/學習特徵的位置。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可用來返回至目前程序的上一步。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
選取測量面 此螢幕按鍵可決定觸測方向和移動到特徵的安全位置。您可按多次選取不同的測量面。 可用的測量面有：上、左、右、前、後和傾斜。若選取「傾斜」，螢幕按鍵圖示將變為傾斜圖示。 | 設定工作偏移 此螢幕按鍵可用來顯示一個新螢幕，其中包含在各種情況下更新工作偏移所用的新螢幕按鍵。
選取要更新的工作偏移 此螢幕按鍵可從待更新的偏移清單中選取已命名的工作偏移。再次按下此鍵可選取清單中的下一個工作偏移。 | 執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。
選取測頭 若選取測頭螢幕並非目前螢幕，則此螢幕按鍵將存取此螢幕。若選取測頭螢幕已可見，則觸碰此螢幕按鍵可捲動瀏覽測頭清單中的每個測頭。 | 確認更新工作偏移 在測量機已學習特徵位置之後方可使用此螢幕按鍵。此按鍵可將命令儲存至測量程式。
取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |

學習過程

要使用此選項，您應手動固定旋轉臺，以使其表面大致與測頭成直角。這一要求使得學習和測量平面變得更加容易。

學習平面的步驟與學習平面特徵的步驟相同。

  1. 選取格線陣列或圓形陣列測量方法。選取格線陣列後，此頁頂部的螢幕上會顯示列數和每列點數控制項。選取圓形陣列後，螢幕上會出現點數控制項。

  2. 設定預碰距離和搜尋距離。

  3. 透過學習兩點對陣列位置進行定義，定義格線或圓形陣列的對角線。

  4. 定義兩點後，立即按執行螢幕按鍵 [image] ，啟動螢幕程式。NC Gage 會繼續測量平面。測量平面後，NC Gage 會計算所需的旋轉，使平面與測頭成直角。您應確保已選取了正確的工作偏移（隨時可執行此作業）。

  5. 按確認螢幕按鍵 [image] 使用上述值來設定選取的工作偏移，或按取消螢幕按鍵 [image] 中止此過程。


設定帶有平面的旋轉軸(角度)

使用設定帶平臺的旋轉軸（角度）螢幕可定義和顯示在旋轉軸中產生明確角度的所有特徵。

若要存取此螢幕：

  1. 按主螢幕第二頁的設定工作偏移螢幕按鍵 [image] 。底部的螢幕按鍵變更為顯示不同類型的特徵，您可測量這些特徵以設定工作偏移。

  2. 按設定帶平臺的旋轉軸（角度）功能鍵 [image] ，顯示設定帶平臺的旋轉軸（角度）螢幕：

  3. 遵循螢幕上的指示，然後按確認螢幕按鍵 [image] 完成程序。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

「測尖偏移」區域

  • 測尖偏移 X、Y 和 Z - 相對於標準塊直線的測頭測尖位置。

「工作偏移」區域

  • 工作偏移 - 指定要更新的工作偏移。

「旋轉臺」區域

  • 軸 ID - 用來標識軸的字母 A、B 或 C，依據系統中定義的旋轉臺數量確定。

「測量值」區域

  • 角度 - 顯示旋轉臺角度的測量值和目標值。

「動作參數」區域

  • 逼近角 - 定義遠離標稱表面的角度，測頭將開始在此標稱表面上以測量速度趨近測量點。

  • 搜尋角度範圍 - 定義尋找和學習特徵時的搜尋角度範圍。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可用來返回至目前程序的上一步。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
選取測量面 此螢幕按鍵可決定觸測方向和移動到特徵的安全位置。您可按多次選取不同的測量面。 可用的測量面有：上、左、右、前、後和傾斜。若選取「傾斜」，螢幕按鍵圖示將變為傾斜圖示。 | 設定工作偏移 此螢幕按鍵可用來顯示一個新螢幕，其中包含在各種情況下更新工作偏移所用的新螢幕按鍵。
選取要更新的工作偏移 此螢幕按鍵可從待更新的偏移清單中選取已命名的工作偏移。再次按下此鍵可選取清單中的下一個工作偏移。 | 執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。
選取測頭 若選取測頭螢幕並非目前螢幕，則此螢幕按鍵將存取此螢幕。若選取測頭螢幕已可見，則觸碰此螢幕按鍵可捲動瀏覽測頭清單中的每個測頭。 | 確認更新工作偏移 在測量機已學習特徵位置之後方可使用此螢幕按鍵。此按鍵可將命令儲存至測量程式。
取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |

學習處理序

請參閱「平臺」話題中的「學習過程」。

執行處理序

請參閱「平臺」話題中的「執行過程」。


設定帶有按鍵的旋轉軸(角度)

使用設定帶按鍵的旋轉軸（角度）螢幕可定義和顯示在旋轉軸中產生明確角度的所有特徵。

若要存取此螢幕：

  1. 按主螢幕第二頁的設定工作偏移螢幕按鍵 [image] 。底部的螢幕按鍵變更為顯示不同類型的特徵，您可測量這些特徵以設定工作偏移。

  2. 按設定帶按鍵的旋轉軸（角度）功能鍵 [image] ，顯示設定帶按鍵的旋轉軸（角度）螢幕：

  3. 遵循螢幕上的指示，然後按確認螢幕按鍵 [image] 完成程序。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

「測尖偏移」區域

  • 測尖偏移 X、Y 和 Z - 相對於標準塊直線的測頭測尖位置。

「工作偏移」區域

  • 工作偏移 - 指定要更新的工作偏移。

「旋轉臺」區域

  • 軸 ID - 用來標識軸的字母 A、B 或 C，依據系統中定義的旋轉臺數量確定。

「測量值」區域

  • 角度 - 顯示旋轉臺角度的測量值和目標值。

「動作參數」區域

  • 逼近角 - 定義遠離標稱表面的角度，測頭將開始在此標稱表面上以測量速度趨近測量點。

  • 搜尋角度範圍 - 定義尋找和學習特徵時的搜尋角度範圍。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 此螢幕按鍵可將檢視器返回上一級至上一螢幕。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可用來返回至目前程序的上一步。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
選取測量面 此螢幕按鍵可決定觸測方向和移動到特徵的安全位置。您可按多次選取不同的測量面。 可用的測量面有：上、左、右、前、後和傾斜。若選取「傾斜」，螢幕按鍵圖示將變為傾斜圖示。 | 設定工作偏移 此螢幕按鍵可用來顯示一個新螢幕，其中包含在各種情況下更新工作偏移所用的新螢幕按鍵。
選取要更新的工作偏移 此螢幕按鍵可從待更新的偏移清單中選取已命名的工作偏移。再次按下此鍵可選取清單中的下一個工作偏移。 | 執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。
選取測頭 若選取測頭螢幕並非目前螢幕，則此螢幕按鍵將存取此螢幕。若選取測頭螢幕已可見，則觸碰此螢幕按鍵可捲動瀏覽測頭清單中的每個測頭。 | 確認更新工作偏移 在測量機已學習特徵位置之後方可使用此螢幕按鍵。此按鍵可將命令儲存至測量程式。
取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。 此螢幕按鍵可將螢幕從 NC Gage 切換為控制項之主視窗。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |

學習處理序

  1. 將測頭置於檢查高度處的按鍵旁邊，按下讀取位置功能鍵 [image] 。

  2. 將測頭置於按鍵頂部上方的安全高度處，並按下讀取位置功能鍵 [image] 。

  3. 請參閱下圖。

    • 測頭移動至按鍵頂部。

    • 旋轉軸旋轉至逼近角位置。

    • 測頭移動至測量高度。

    • 旋轉軸以順時針方向旋轉，直至測頭被觸發。旋轉軸停止旋轉。回退至逼近角位置。

    • 測頭移動至按鍵頂部。

    • 旋轉軸旋轉至逼近角位置。

    • 測頭移動至測量高度。

    • 隨後旋轉軸以逆時針方向旋轉，直至測頭被觸發。旋轉軸停止旋轉。回退至逼近角位置。

    • 測頭移動至按鍵頂部。

    • 旋轉軸旋轉回原始位置。

    • 按鍵的中間角度透過兩個觸發的旋轉軸位置進行計算。

執行處理序

請參閱「按鍵槽」話題中的「執行過程」。


更新工作偏移

  1. 按主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁螢幕按鍵直至螢幕上顯示更新工作偏移螢幕按鍵。

  3. 按更新工作偏移 螢幕按鍵 [image] ，顯示更新工作偏移 螢幕：

「特徵清單」區域

  • X、Y、Z、A、C - 特徵選取軸清單顯示可用於定義工作偏移的測量程式中的特徵。所顯示的特徵選取軸清單取決於透過 NC Gage 設定工具定義系統的方式。

「工作偏移」區域

指定選取進行更新的工作偏移。使用選取工作偏移螢幕按鍵 [image] 透過清單一次切換一個項目。

「選取的特徵詳細資料」區域

  • 工件值 - 這些唯讀方塊顯示所選取的特徵位置/角度 (XYZAC) 值。這些值已被轉換至工件坐標系。

  • 機器值 - 這些唯讀方塊顯示所選取的特徵位置/角度 (XYZAC) 值。這些值已被轉換至機器坐標系。

  • 目標值 - 這些方塊定義每條軸的額外偏移值，但將機器坐標值用作預設參考值。輸入值會被新增至用於設定工作偏移的測量值中。

註解

使用此方塊可鍵入對更新的工作偏移的註解。

詳細程序：

此螢幕可用於自動更新測量程式末端的工作偏移，或者在已檢查特徵之後手動更新工作偏移。

要執行此操作，需要在 NC Gage 測量程式中新增更新的工作偏移命令。

  1. 檢查使用 NC Gage更新工作偏移所用的特徵。

  2. 按更新工作偏移螢幕按鍵 [image] ，存取如上所述的更新工作偏移螢幕。

  3. 選取更新工作偏移螢幕中可定義工作偏移的特徵。

  4. 按確認螢幕按鍵 [image] 將更新的工作偏移命令新增至 NC Gage 測量程式。按返回螢幕按鍵 [image] ，返回上一螢幕。

運行測量程式時，它會更新工作偏移。

要學習工作偏移：

  1. 從每個軸清單中選取要更新的特徵。並非所有軸都需要更新。值方塊將進行更新，以顯示所選特徵的位置。一旦值方塊更新資訊，對應的偏移方塊將可用。

  2. 若需要，可在偏移方塊中鍵入一個偏移距離。該距離可為正值或負值，可用來表示已更新工作偏移之後特徵的位置。

  3. 按一下選取要更新的工作偏移螢幕按鍵 [image] ，從清單中選取工作偏移名稱，直至所需的工作偏移反白顯示。選取每個反白顯示的工作偏移參數即可在螢幕上進行更新。

  4. 若已執行測量程式，NC Gage 可立即更新工作偏移。以同樣方式設定螢幕，並選取執行螢幕按鍵 [image] 。這樣將會更新所選取的工作偏移，且不會將命令儲存至測量程式。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
選取要更新的工作偏移 此螢幕按鍵可從待更新的偏移清單中選取已命名的工作偏移。再次按下此鍵可選取清單中的下一個工作偏移。 | 切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。
刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。 | 確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。
取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。 | 執行 此按鍵可存取執行測量程式螢幕，您可在此螢幕上執行測量程式。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |


定義控制框架

Home > 使用 PC-DMIS NC Gage > 入門 > 第 7 步：定義控制框架

第 7 步：定義控制框架

移動旋轉軸

「移動旋轉軸」命令可定位一個或多個旋轉軸。此命令無零點與其相關，因此無需學習零點。

更多:

移動旋轉軸


移動旋轉軸

祇在擁有三個軸以上的機器（如帶有旋轉臺的機器）上使用移動旋轉軸命令。基本上可將測頭置於安全位置，然後將旋轉軸置於移動所需的位置。

若要將移動旋轉軸命令新增至測量程式，NC Gage 需要適當組態的軟體。

建立移動旋轉軸命令後，當該移動旋轉軸命令處於使用中時，它會設定旋轉臺所在的位置。如果您嘗試學習新命令時，移動旋轉軸命令處於使用中，同時旋轉臺不在正確位置上，螢幕上會顯示一條警告訊息，此時您不允許學習特徵，直至旋轉臺位於移動旋轉軸命令所定義的相同位置上。

學習新命令時，NC Gage 會進行檢查，確保旋轉臺未從移動旋轉軸命令定義的位置上移開。若已移開，則會顯示一條警告訊息，當旋轉臺位置與移動旋轉軸命令位置一致時，才可學習特徵。

上述訊息為：

警告：目前旋轉臺位置與目前旋轉軸位置不相符，請在繼續前修復該問題。

  1. 遵循設定工作偏移指示。

  2. 定義工作偏移後，選取工作偏移螢幕按鍵 [image] 將變更為移動旋轉軸螢幕按鍵 [image] 。選取主螢幕導覽列上的移動旋轉軸螢幕按鍵 [image] 。螢幕上將出現移動旋轉軸：

  3. 在相應區域中輸入安全點和旋轉資訊。

  4. 在主方向區域中選取主軸的方向。

  5. 遵循螢幕指示，定義移動旋轉軸命令參數。

「安全點」區域

  • 安全點 X、Y、Z - 定義 X、Y、Z 起始或安全坐標位置以供測量程式執行前啟動測頭。每次測量程式執行前，測頭將返回此位置。

「旋轉」區域

  • 旋轉A、C — 顯示每個系統軸的學習值（以度數）。

「主方向」區域

  • X+、Y+、Z+、X-、Y-、Z- - 定義主軸的主方向。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可移除上一次學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。


定義安全路徑

Home > 使用 PC-DMIS NC Gage > 入門 > 第 8 步：定義安全路徑

第 8 步：定義安全路徑

安全路徑可讓您定義所需平面或圓柱上方的距離，透過此距離測頭可以安全移動，避免與工件或其他障礙物相接觸。

有關定義安全路徑的資訊，請參考「插入移動命令」一章中的「安全平面」。

完成對安全路徑進行定義後，可開始將測量特徵新增至測量程式。請參閱「建立特徵命令」。


建立特徵命令

NC Gage 可提供兩種方法建立特徵命令並將它們新增至測量程式以供 NC Gage 在執行時進行測量。

透過鍵入參數值建立特徵命令

透過鍵入參數，存取相應的特徵命令螢幕，選取使用螢幕上的值進行學習核取方塊，輸入所有參數和屬性，然後觸摸學習和建立命令螢幕按鍵來建立特徵命令。NC Gage 根據您的定義將特徵命令插入測量程式。

透過學習特徵建立特徵命令

透過「學習」建立特徵命令是存取特徵命令螢幕時的預設模式。您需要根據螢幕上指示在工件的測頭學習位置上手動分疊測頭以學習特徵。NC Gage 將解譯測頭位置，使用學習位置中的資訊在特徵命令螢幕上手動填寫參數。然後，NC Gage 可讓您按照以下「學習」程序將特徵命令插入測量程式。

備註：必須在新增特徵命令前校準測頭（參閱「校驗」）。

您可將以下命令新增至測量程式。

測定特徵

  • 點

  • 圓（內徑）

  • 圓（突起部）

  • 圓（軸）

  • 網路

  • 槽

  • 棱角（內部）

  • 棱角（外部）

  • 平面

  • 直線

  • 圓柱（內徑）

  • 圓柱（突起部）

  • 圓錐（內部）

  • 圓錐（外部）

  • 球體

  • 按鍵

  • 鍵槽

  • 平臺

已構造的特徵

  • 構造點

  • 構造線

  • 構造圓

尺寸

  • 夾角

  • 尺寸距離

同心度

  • 同心度

其他功能

  • 更新工作偏移

  • 設定坐標旋轉

螢幕按鍵

您可觸摸導覽列上上述螢幕按鍵之一，存取特徵螢幕。

車銑機用螢幕按鍵

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
測量點 這是開啟 測量點 螢幕的螢幕按鍵。 | 測量內經 此螢幕按鍵可開啟測量內徑螢幕。
測量突起部 此螢幕按鍵可開啟測量突起部螢幕。 | 測量網狀 此螢幕按鍵可開啟測量網狀螢幕。
測量槽 此螢幕按鍵可開啟測量槽螢幕。 | 測量棱角外部 此螢幕按鍵可開啟棱角外部螢幕。
測量棱角內部 此螢幕按鍵可開啟棱角內部螢幕。 | 測量平面 此螢幕按鍵可開啟測量平面螢幕。
測量線 此螢幕按鍵可開啟測量線螢幕。 | 測量圓柱內徑 此螢幕按鍵可開啟測量圓柱內徑螢幕。
測量圓柱突起部 此螢幕按鍵可開啟測量圓柱突起部螢幕。 | 測量圓錐內部 此螢幕按鍵可開啟測量圓錐內部螢幕。
測量圓錐外部 此螢幕按鍵可開啟測量圓錐外部螢幕。 | 測量球體 此螢幕按鍵可進入測量球體螢幕。
構造點 上述螢幕按鍵可開啟構造點螢幕，構造交點、投影點或作為輸入的兩個直線特徵外的中點特徵。 | 構造線 此螢幕按鍵可開啟構造線螢幕。
構造圓 此螢幕按鍵可開啟構造圓螢幕。 | 夾角 此螢幕按鍵可開啟夾角螢幕以讓您標出兩個特徵間的角度。
距離: 此螢幕按鍵可開啟距離螢幕以讓您標出兩個特徵間的距離。 | 更新工作偏移 此螢幕按鍵可開啟更新工作偏移螢幕以讓您在測量程式結束時更新工作偏移。
寫變數 上述螢幕按鍵可開啟寫變數螢幕，允許您將測量資料寫入 NC 控制項上的巨集變數。 |
設定坐標系統旋轉 此螢幕按鍵可開啟設定坐標系旋轉螢幕，可讓您在使用 NC Gage 之外的測量機時變更系統旋轉。 | 同心度 此螢幕按鍵可開啟同心度螢幕，讓您計算一個特徵至另一個特徵的同心度。
測量軸 此螢幕按鍵可開啟測量圓（軸）螢幕。 | 按鍵 此螢幕按鍵可開啟測量按鍵螢幕。
鍵槽 此螢幕按鍵可開啟測量鍵槽螢幕。 | 平臺 此螢幕按鍵可開啟測量平臺螢幕。
返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。

通用屬性：

  • 公差


點

  1. 按主螢幕上的測量螢幕按鍵 [image] 。

  2. 按測量螢幕上的點螢幕按鍵 [image] ，顯示測量點螢幕：

  3. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將顯示測頭測量和變更位置的圖形視圖。

「屬性」區域（僅當選取「傾斜」工作面選項時才處於啟用狀態）

  • X 角 - 定義點在 X 方向上的向量角。此為點的曲面法線方向，與測量所在的主軸關聯。在 XY 工作面上主軸為 X，在 YZ 工作面上為 Y，在 ZX 工作面上為 Z。有效範圍為 0（零）度至 -360 度。

  • Z 角 - 定義點在 Z 方向上的第一個向量角。此為點的曲面法線方向，與工作面關聯。有效範圍為 -90 度至 +90 度。

「動作參數」區域

  • 逼近距離 - 定義遠離標稱曲面的距離，測頭在測量過程中將使用此標稱曲面開始搜尋曲面。

  • 搜尋距離 - 定義尋找及學習特徵時的搜尋距離。（若選取了「選用設定區域」中所述的使用螢幕上的值學習，則該選項將不可用。）

「選用設定」區域

  • 觸測安全平面 - 選取此選項可將測頭移動至各個特徵測點之間的安全平面上。右側的編輯方塊可用於輸入平面距離。此平面不是測量程式安全平面。有關詳細資料，請參閱觸測安全平面。

  • 學習後測量 - 選取此選項可導致機器首先使用預設參數學習工件的位置，然後使用螢幕上設定的屬性立即重新測量特徵。用於測試所有設定的參數，確保實現更精確、更可靠的首件檢查。

  • 使用螢幕上的值學習 - 用於輸入特徵的標稱值，並在此位置測量軟體。（選取時，將停用動作參數區域中的搜尋距離選項。）

「點位置」區域

  • XYZ 標稱值 - 定義點的標稱位置。

  • XYZ 測量值 - 顯示點的測量位置。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
選取測量面 此螢幕按鍵可決定觸測方向和移動到特徵的安全位置。您可按多次選取不同的測量面。 可用的測量面有：上、左、右、前、後和傾斜。若選取「傾斜」，螢幕按鍵圖示將變為傾斜圖示。 | 切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。
返回上一步 此螢幕按鍵可移除上一次學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。 | 插入移動點 此螢幕按鍵可讀取測頭的目前位置，並作為安全移動將它插入測量常式。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |

在工作面已定義法線的情況下學習點的程序：

  1. 按一下選取測量面螢幕按鍵 [image] 並選擇點的工作面（上、下、左、右、前、後或傾斜）。

  2. 將測頭置於您想要測量點特徵的表面之上。

  3. 按一下讀取位置螢幕按鍵 [image] 。應將測尖位置理解為開始位置。按返回至上一步 螢幕按鍵 [image] ，取消此測量位置。

  4. 按一下學習並建立一個命令螢幕按鍵 [image] 。NC Gage 將自動按照下列所描述之形式採集測點。

    位置 A 指示測頭的放置位置。紅線顯示測量路徑。位置 1 指示已測量的點位置。

  5. 一旦測量出特徵，就要更新測量值。按確認並將目前命令新增至末端螢幕按鍵 [image] ，以將特徵命令新增至測量程式。

在「傾斜」工作面已定義法線的情況下學習點的程序：

  1. 按一下選取測量面螢幕按鍵 [image] 並選擇點的工作面（上、下、左、右、前、後或傾斜）。若要選取「傾斜」選項，請按一下選取測量面螢幕按鍵直至該圖示變為「傾斜」圖示 [image] 。

  2. 將測頭置於您想要測量點特徵的表面之上。

  3. 按一下讀取位置螢幕按鍵 [image] 。應將測尖位置理解為開始位置。按返回至上一步 螢幕按鍵 [image] ，取消此測量位置。

  4. 將測頭放在遠離曲面方向上的測量點位置處。

  5. 按一下讀取位置螢幕按鍵 [image] 。

  6. 按一下 學習並建立一個命令 螢幕按鍵 [image] 。

  7. 一旦測量出特徵，就要更新測量值。按確認並將目前命令新增至末端螢幕按鍵 [image] ，以將特徵命令新增至測量程式。

以下是特定的特徵路徑和 NC Gage 內置邏輯：

學習點特徵路徑

  • 讀取目前位置。

  • 沿著目前工作面的方向執行測量，搜尋距離為 3* 預碰距離。

  • 撤回至讀取位置。

執行點特徵路徑

  • 如果當前位置低於安全平面，則將其向上移動至安全平面。

  • 移至點之上的位置處。

  • 向下移動至點之上的位置處，即預碰位置 + 距標稱表面的測頭半徑。

  • 測量點，目標為表面之下的預碰距離。

  • 測量之後移動至安全平面高度。


圓（內徑）

Home > 使用 PC-DMIS NC Gage > 建立特徵命令 > 圓（內徑）

測量圓（內徑）

若要建立圓（內經）命令：

  1. 按一下主螢幕上的測量螢幕按鍵 [image] 。

  2. 按 圓（內徑）螢幕按鍵 [image] ，顯示測量圓（內徑）螢幕：

  3. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將顯示測頭測量和變更位置的圖形視圖。

「屬性」區域

  • 點數 - 定義執行過程中（非學習模式）圓形觸測的點數。

  • 起始角 — 定義待測量圓區段的起始點。在沿主軸的 0 上開始旋轉，在副軸上放大至 90。在 XY 工作面上主軸為 X，在 YZ 工作面上為 Y，在 ZX 工作面上為 Z。在 XY 工作面上副軸為 Y ，在 YZ 工作面上為 Z，在 ZX 工作面上為 X。

  • 終止角 - 定義將要測量的圓截面的末端。在執行模式中測量特徵時才使用起始和終止角。學習模式會自動在主軸和副軸相反的方向進行觸測。如果圓不繼續環繞 360 度，那麼將不能使用使用螢幕上的值進行學習以輸入帶有已定義的適當起始和終止角的標稱位置。然後，選取學習後進行測量後，NC Gage 會測量特徵。

  • 測量高度 - 此值定義測量值相對於標稱 XYZ 參數的方向高度（相對於標稱測頭向量）。值為零表示將在參數組方塊中定義的 XYZ 點位置上測量特徵。負值定義所測量的內徑低於標稱 XYZ 的程度。正值定義高於要測量的標稱 XYZ 的程度。

備註：每列的列數和點數沿已定義的圓的空隙相等。

「動作參數」區域

  • 逼近距離 - 定義遠離標稱曲面的距離，測頭在測量過程中將使用此標稱曲面開始搜尋曲面。

  • 搜尋距離 - 定義測頭在學習模式中搜尋曲面時運行的距離。（若選取了選用設定區域中所述的使用螢幕上的值學習，則該選項將不可用。）

「選用設定」區域

  • 觸測安全平面 - 選取此選項可將測頭移動至各個特徵測點之間的安全平面上。右側的編輯方塊可輸入平面距離。此平面不是測量程式安全平面。有關詳細資料，請參閱「觸測安全平面」。

  • 學習後測量 - 選取此選項可導致機器首先使用預設參數學習工件的位置，然後使用螢幕上設定的屬性立即重新測量特徵。此選項可測試所有設定的參數，確保實現更精確、更可靠的首件檢查。

  • 使用螢幕上的值學習 - 用於輸入特徵的標稱值，並在此位置測量軟體。（選取時，將停用動作參數區域中的搜尋距離選項。）

「參數」區域

  • XYZD 標稱值 - 定義圓內徑的標稱位置。

  • XYZD 測量值 - 顯示圓內徑的測量位置。

「3 軸報告」區域

您可使用「3 軸報告」以三種方式定義 XYZ 點。

  • 選取用於定義測量特徵高度的測量點或平面。

  • 輸入要使用的平面的方向高度。此高度與工件原點有關，沿測頭向量進行測量。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可移除上一次學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。 | 插入移動點 此螢幕按鍵可讀取測頭的目前位置，並作為安全移動將它插入測量常式。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。

學習處理序

  1. 將測頭置於內徑中心，按讀取位置螢幕按鍵 [image] 。這將是所有觸測的高度位置。按 返回上一步 螢幕按鍵 [image] 以取消此測量位置。

  2. 將測頭定位為自動測量，按一下學習和建立命令螢幕按鍵 [image] 。NC Gage 在主和副軸的每個正負方向進行四次觸測。

    表示開始手動位置的圖像將測頭分疊至 (A) 以及 NC 標準塊所用的自動觸測路徑（紅線），因為它可測量四個點（位置 1-4）

  • 如果發生碰撞，處理序停止，錯誤出現。

  • 如果測頭缺失內經，請修改搜尋位置並重試。

  3. 一旦測量出特徵，就要更新測量值。

  4. 按 確認並將目前命令新增至末端螢幕按鍵 [image] 。特徵命令被新增至測量程式。

特定特徵路徑和邏輯

以下是特定特徵路徑和 NC Gage 內置邏輯：

學習內徑特徵路徑

  • 讀取內經中心的測頭位置。

  • 內徑的測量值將出現在讀取點的 Z 值中。

  • 估計內徑中心 XY 將成為讀取點。

  • 使用搜尋距離在 +X 方向上的測量點。

  • 返回至中心位置。

  • 使用搜尋距離在 –X 方向上的測量點。

  • 返回至中心位置。

  • 使用搜尋距離在 +Y 方向上的測量點。

  • 返回至中心位置。

  • 使用搜尋距離在 –Y 方向上的測量點。

  • 返回至中心位置。

執行內徑特徵路徑

  • 定義預碰半徑 = 內經半徑 – 逼近距離 – 測頭半徑。

  • 定義目標半徑 = 內經半徑 + 逼近距離 – 測頭半徑。

  • 如果當前位置低於安全平面，則將其向上移動至安全平面。

  • 移至第一個預測點上方的位置。此點是預測點半徑距離起始角方向上的內經中心的距離。

  • 下降至測量層。

  • 測量點、目標是距離沿角內經中心的目標半徑。

  • 撤銷並移至下一點的預測點。

  • 測量點、目標是距離沿角內經中心的目標半徑。

  • 繼續從起始角到終止角開始測量指定的點數。

  • 如果啟用本地安全平面，則移動每個點間的本地安全平面以到達下一預測點。

  • 測量過上一點後，測頭向上移動至安全平面高度。


圓（突起部）

Home > 使用 PC-DMIS NC Gage > 建立特徵命令 > 圓（突起部）

測量圓（突起部）

若要建立圓突起命令：

  1. 按一下主螢幕上的測量螢幕按鍵 [image] 。

  2. 按圓（突起部）螢幕按鍵 [image] ，顯示測量圓（突起部）螢幕：

  3. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將顯示測頭測量和變更位置的圖形視圖。

「屬性」區域

  • 點數 - 定義執行過程中（非學習模式）圓形觸測的點數。

  • 起始角 — 定義待測量圓區段的起始點。在沿主軸的 0 上開始旋轉，在副軸上放大至 90。在 XY 工作面上主軸為 X，在 YZ 工作面上為 Y，在 ZX 工作面上為 Z。在 XY 工作面上副軸為 Y ，在 YZ 工作面上為 Z，在 ZX 工作面上為 X。

  • 終止角 - 定義將要測量的圓截面的末端。在執行模式中測量特徵時才使用起始和終止角。學習模式會自動在主軸和副軸相反的方向進行觸測。如果圓不繼續環繞 360 度，那麼將不能使用使用螢幕上的值學習 以輸入帶有已定義的適當起始和終止角的標稱位置。然後，透過選取 學習後測量 ，NC Gage 將測量特徵。

備註：每列的列數和點數沿已定義的圓的空隙相等。

「動作參數」區域

  • 逼近距離 - 定義遠離標稱曲面的距離，測頭在測量過程中將使用此標稱曲面開始搜尋曲面。

  • 搜尋距離 - 定義測頭在學習模式中搜尋曲面時運行的距離。（若選取了選用設定區域中所述的使用螢幕上的值學習，則該選項將不可用。）

「選用設定」區域

  • 觸測安全平面 - 選取此選項可將測頭移動至各個特徵測點之間的安全平面上。右側的編輯方塊可讓您輸入平面距離。此平面不是測量程式安全平面。有關詳細資料，請參閱觸測安全平面。

  • 學習後測量 - 選取此選項可導致機器首先使用預設參數學習工件的位置，然後使用螢幕上設定的屬性立即重新測量特徵。用於測試所有設定的參數，確保實現更精確、更可靠的首件檢查。

  • 使用螢幕上的值學習 - 用於輸入特徵的標稱值，並在此位置測量軟體。（選取時，將停用動作參數區域中的搜尋距離選項。）

「參數」區域

  • XYZD 標稱值 - 定義圓突起部的標稱位置。

  • XYZD 測量值 - 顯示圓突起部的測量位置。

「3 軸報告」區域

「3 軸報告」可用於以三種方式定義 XYZ 點。

  • 選取用於定義測量特徵高度的測量點或平面。

  • 輸入要使用的平面的方向高度。此高度與工件原點有關，沿測頭向量進行測量。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可移除上一次學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。 | 插入移動點 此螢幕按鍵可讀取測頭的目前位置，並作為安全移動將它插入測量常式。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。

學習處理序

  1. 將測頭置於突起側表面附近，按讀取位置 螢幕按鍵 [image] 。這將是所有觸測的高度位置。按返回上一步螢幕按鍵 [image] ，取消此測量位置。

  2. 將測頭置於突起部中心上方，按讀取位置 螢幕按鍵 [image] 。這將用於決定突起部的中心。按返回上一步螢幕按鍵 [image] ，取消此測量位置。

  3. 將測頭定位為自動測量，按一下學習和建立命令螢幕按鍵 [image] 。NC Gage 在此位置下方進行一次觸測以決定突起部的高度。然後，它將以下述相同的方式自動進行觸測。

    表示手動位置的圖像將測頭分疊至 (A-B) 以及 NC 標準塊所用的自動觸測路徑（紅線），因為它可測量四個點（位置 1-4）

  4. 一旦測量出特徵，就要更新測量值。按 確認並將目前命令新增至末端螢幕按鍵 [image] 。特徵命令被新增至測量程式。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

以下是特定的特徵路徑和 NC Gage 內置邏輯：

學習突起特徵路徑

  • 測頭的讀取位置靠近突起測，Z 值將為測量高度。

  • 測頭的讀取位置位於突起部中心上方，XY 值定義中心，Z 值為安全高度。

  • 預測點半徑 = 兩個位置點間預計的 2D 距離。

  • 移至安全高度。

  • 將安全高度移至預測點 1 上方的一個點，此點是 +X 方向上中心的預測點距離。

  • 下降至測量高度。

  • 測量點、目標是測量高度上的中心。

  • 移至安全高度。

  • 將安全高度移至預測點 2 上方的一個點，此點是 -X 方向上中心的預測點距離。

  • 下降至測量高度。

  • 測量點、目標是測量高度上的中心。

  • 移至安全高度。

  • 將安全高度移至預測點 3 上方的一個點，此點是 +Y 方向上中心的預測點距離。

  • 下降至測量高度。

  • 測量點、目標是測量高度上的中心。

  • 移至安全高度。

  • 將安全高度移至預測點 4 上方的一個點，此點是 -Y 方向上中心的預測點距離。

  • 下降至測量高度。

  • 測量點、目標是測量高度上的中心。

  • 移至安全高度。

執行突起特徵路徑

  • 定義預測點半徑 = 突起部半徑 + 逼近距離 + 測頭半徑。

  • 定義目標半徑 = 突起部半徑 – 逼近距離 – 測頭半徑，如果它小於 0，那麼將其設定為 0。

  • 如果當前位置低於安全平面，則將其向上移動至安全平面。

  • 移至第一個預測點上方的位置。此點是預測點半徑距離起始角方向上的突起部中心的距離。

  • 下降至測量層。

  • 測量點、目標是距離沿角突起部中心的目標半徑。

  • 撤銷並移至下一點的預測點。若需要，請使用一個或多個更小的移動以避免與突起部相接觸。

  • 測量點、目標是距離沿角突起部中心的目標半徑。

  • 繼續從起始角到終止角開始測量指定的點數。

  • 如果啟用本地安全平面，則移動每個點間的本地安全平面以到達下一預測點。

  • 測量過上一點後，測頭向上移動至安全平面高度。


圓（軸）

Home > 使用 PC-DMIS NC Gage > 建立特徵命令 > 圓（軸）

測量圓（軸）

若要建立圓軸命令：

  1. 按一下主螢幕上的測量螢幕按鍵 [image] 。

  2. 按圓（軸）螢幕按鍵 [image] ，顯示測量圓（軸）螢幕：

  3. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將顯示測頭測量和變更位置的圖形視圖。

「屬性」區域

  • 點數 - 定義執行過程中（非學習模式）圓形觸測的點數。

  • 起始角 — 定義待測量圓區段的起始點。在沿主軸的 0 上開始旋轉，在副軸上放大至 90。在 XY 工作面上主軸為 X，在 YZ 工作面上為 Y，在 ZX 工作面上為 Z。在 XY 工作面上副軸為 Y ，在 YZ 工作面上為 Z，在 ZX 工作面上為 X。

  • 夾角 - 定義旋轉測量範圍。在執行模式中測量特徵時才使用起始角和夾角。學習模式會自動在主軸和副軸相反的方向進行觸測。如果圓不繼續環繞 360 度，那麼將不能使用使用螢幕上的值學習 以輸入帶有已定義的適當起始和終止角的標稱位置。然後，選取學習後進行測量後，NC Gage 會測量特徵。

備註：每列點數沿已定義圓的空隙相等。

  • 軸旋轉 - 要透過旋轉 C 軸測量軸，選取是。否則，選取否。

備註：--祇有在使用旋轉 C 軸時，才有可能對軸進行徑向分析。

「動作參數」區域

  • 逼近距離 - 定義遠離標稱曲面的距離，測頭在測量過程中將使用此標稱曲面開始搜尋曲面。

  • 搜尋距離 - 定義測頭在學習模式中搜尋曲面時運行的距離。（若選取了「選用設定區域」中所述的使用螢幕上的值學習核取方塊，則該選項將不可用。）

「選用設定」區域

  • 觸測安全平面 - 選取此選項可將測頭移動至各個特徵測點之間的安全平面上。右側的編輯方塊可讓您輸入平面距離。此平面不是測量程式安全平面。有關詳細資料，請參閱「觸測安全平面」。

  • 學習後測量 - 選取此選項可導致機器首先使用預設參數學習工件的位置，然後使用螢幕上設定的屬性立即重新測量特徵。用於測試所有設定的參數，確保實現更精確、更可靠的首件檢查。

  • 使用螢幕上的值學習 - 用於輸入特徵的標稱值，並在此位置測量軟體。（選取時，將停用動作參數區域中的搜尋距離選項。）

「參數」區域

  • XYZD 標稱值 - 定義圓軸的標稱位置。

  • XYZD 測量值 - 顯示圓軸的測量位置。

「3 軸報告」區域

您可使用「3 軸報告」以三種方式定義 XYZ 點。

  • 選取用於定義測量特徵高度的測量點或平面。

  • 輸入要使用的平面的方向高度。此高度與工件原點有關，沿測頭向量進行測量。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可移除上一次學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。 此螢幕按鍵可將螢幕從 NC Gage 切換為控制項之主視窗。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。 | 插入移動點 此螢幕按鍵可讀取測頭的目前位置，並作為安全移動將它插入測量常式。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。

學習過程

  1. 將測頭置於軸側表面附近，按讀取位置螢幕按鍵 [image] 。這將是所有觸測的高度位置。按返回上一步螢幕按鍵 [image] ，取消此測量位置。

  2. 將測頭置於軸中心上方，按讀取位置螢幕按鍵 [image] 。這將用於決定軸的中心。按返回上一步螢幕按鍵 [image] ，取消此測量位置。

  3. 將測頭定位為自動測量，按一下學習和建立命令螢幕按鍵 [image] 。NC Gage 在沿徑向的軸上採集一個測點。觸測方向為從分疊位置到軸中心。

指示起點和目標點之範例

注意，目前僅支援測頭方向垂直於軸中心線的測座角度：

  4. 一旦測量出特徵，就要更新測量值。按 確認並將目前命令新增至末端螢幕按鍵 [image] 。特徵命令被新增至測量程式。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

不帶軸旋轉的學習過程

關於這一學習過程，請參考以下圖片：

不帶軸旋轉的學習過程

  1. 選擇否用於軸旋轉選項。

  2. 將測頭置於中心線頂部的軸曲面旁邊，並按下讀取位置功能鍵 [image] 。這將記錄第一個移動位置。如果要取消已測量的位置，按重回上一步功能鍵 [image] 。

  3. 將測頭置於中心線一側的軸曲面旁邊，並按下讀取位置功能鍵 [image] 。這將記錄第二個移動位置。如果要取消已測量的位置，按重回上一步功能鍵 [image] 。

  4. 將測頭置於軸曲面旁邊，並按下讀取位置 [image] 功能鍵。這將記錄第三個移動位置。如果要取消已測量的位置，按重回上一步功能鍵 [image] 。

  5. 將測頭定位為自動測量，並按下學習和建立命令功能鍵 [image] 。NC Gage 將以與下述相似的方式自動進行觸測：

不帶軸旋轉的學習過程測點

一旦測量出特徵，就要更新測量值。

  6. 按確認並將目前命令新增至末端功能鍵 [image] 。特徵命令將被添加至測量程式。按返回功能鍵 [image] ，返回上一螢幕而不儲存。

特定的特徵路徑和 NC Gage 內置邏輯

學習軸特徵路徑

  • 將測頭置於中心線頂部的軸曲面旁邊。讀取位置。

  • 將測頭置於中心線一側的軸曲面旁邊。讀取位置。

  • 將測頭置於軸曲面旁邊。讀取位置。

  • 使用讀取位置計算軸中心。

  • 測量觸測向量方向軸表面上的第一個點。

  • 測量觸測向量方向軸表面上的第二個點。

  • 測量觸測向量方向軸表面上的第三個點。

  • 計算軸的直徑和中心。

  • 計算起始角和包含角。

執行軸特徵路徑

  • 定義預碰半徑：軸半徑 + 逼近距離 + 測頭半徑

  • 定義目標半徑 ： 軸半徑 - 逼近距離 + 測頭半徑

  • 如果目前位置低於安全平面，則應向上移動至安全平面。

  • 移至安全平面中的預碰距離之上。

  • 移動至起始角上的逼近位置。此點是逼近半徑距離起始角方向上的旋轉臺中心的距離。

  • 下降至測量層。

  • 測量點。目標是距離沿起始角的旋轉臺中心的目標半徑。

  • 回退並移動至下一個預測點位置。繼續繼續以上兩個步驟，直至測量所有點。

  • 測量上一點後，測頭向上移動至安全平面。

帶軸旋轉的學習過程

關於這一學習過程，請參考以下圖片：

帶軸旋轉的學習過程

  1. 選擇是用於軸旋轉選項。

  2. 將測頭置於軸曲面旁邊，並按下讀取位置功能鍵 [image] 。這將把移動位置記錄為觸測起始點。如果要取消已測量的位置，按重回上一步功能鍵 [image] 。

  3. 將測頭定位為自動測量。如果要取消已測量的位置，按重回上一步功能鍵 [image] 。NC Gage 將自動沿徑向方向在軸上採取一個測點，如下所示：

觸測方向為從移動位置到軸中心。

一旦測量出特徵，就要更新測量值。

  4. 按確認並將目前命令新增至末端功能鍵 [image] 。特徵命令將被添加至測量程式。按返回功能鍵 [image] ，返回上一螢幕而不儲存。

特定的特徵路徑和 NC Gage 內置邏輯

學習軸特徵路徑

  • 將測頭置於軸表面附近作為起點。

  • 讀取位置。

  • 使用讀取位置和旋轉臺中心計算觸測向量。

  • 測量觸測向量方向的軸表面上的點。

  • 計算軸之直徑和中心。

  • 將觸測向量角度作為起始角進行計算。

  • 返回起始位置。

執行軸特徵路徑

  • 定義預碰半徑：軸半徑 + 逼近距離 + 測頭半徑

  • 定義目標半徑 ： 軸半徑 - 逼近距離 + 測頭半徑

  • 如果目前位置低於安全平面，則應向上移動至安全平面。

  • 移至安全平面中的預碰距離之上。

  • 移動至起始角上的逼近位置。此點是逼近半徑距離起始角方向上的旋轉臺中心的距離。

  • 下降至測量層。

  • 測量點。目標是距離沿起始角的旋轉臺中心的目標半徑。

  • 回退並旋轉旋轉臺至下一角度。

  • 繼續以上兩個步驟，直至測量所有點。

  • 測量上一點後，測頭向上移動至安全平面。


網路

Home > 使用 PC-DMIS NC Gage > 建立特徵命令 > 網路

測量網狀

要建立一個網路命令：

  1. 按主螢幕上的測量螢幕按鍵 [image] 。

  2. 按網狀螢幕按鍵 [image] ，顯示測量網狀螢幕：

  3. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將顯示測頭測量和變更位置的圖形視圖。

「屬性」區域

備註：選取選用設定區域中的使用螢幕上的值學習核取方塊後，才可看見以下兩個屬性：

  • 第一邊長 – 定義從第一個點到第二個點的距離。

  • 第二邊長 – 定義從起點（若投影在第二邊上）到第二邊上的點的距離。

「動作參數」區域

  • 逼近距離 - 定義遠離標稱曲面的距離，測頭在測量過程中將使用此標稱曲面開始搜尋曲面。

  • 搜尋距離 - 定義測頭在學習模式中搜尋曲面時運行的距離。（若選取了「選用設定區域」中所述的使用螢幕上的值學習，則該選項將不可用。）

「選用設定」區域

  • 觸測安全平面 - 選取此選項可將測頭移動至各個特徵測點之間的安全平面上。右側的編輯方塊可讓您輸入平面距離。此平面不是測量程式安全平面。有關詳細資料，請參閱觸測安全平面。

  • 學習後測量 - 選取此選項可導致機器首先使用預設參數學習工件的位置，然後使用螢幕上設定的屬性立即重新測量特徵。用於測試所有設定的參數，確保實現更精確、更可靠的首件檢查。

  • 使用螢幕上的值學習 - 用於輸入特徵的標稱值，並在此位置測量軟體。（選取後，將啟用屬性區域中的第一邊長和第二邊長選項並停用動作參數區域中的搜尋距離選項。）

「參數」區域

  • XYZ 標稱值 - 定義凸臺頂部曲面中心的標稱位置。

  • XYZ 測量值 - 顯示凸臺頂部曲面中心的測量位置。

  • X 角 - 定義凸臺中心線的向量角。這是與 X 軸有關的直線方向。

  • 寬度（標稱值）- 定義網路的標稱寬度。

  • 寬度（測量值）- 顯示凸臺的測量寬度。

「3 軸報告」區域

「3 軸報告」可用於以三種方式定義 XYZ 點。

  • 選取定義測量特徵高度的測量點或平面。

  • 輸入要使用的平面的方向高度。此高度與工件原點有關，沿測頭向量進行測量。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可移除上一次學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。 | 插入移動點 此螢幕按鍵可讀取測頭的目前位置，並作為安全移動將它插入測量常式。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。

學習處理序

  1. 將測頭置於第一邊上第一個點的旁邊，然後按一下讀取測頭位置螢幕按鍵 [image] 。與工作面表面之間的距離將與所有點上的距離相同。

  2. 將測頭置於第一邊上第二個點的旁邊，然後按一下讀取測頭位置螢幕按鍵 [image] 。

  3. 將測頭置於第二邊上的點的旁邊，然後按讀取測頭位置螢幕按鍵 [image] 。

  4. 按學習並建立命令螢幕按鍵 [image] 。NC Gage 會移動至安全平面並自動按照下列所描述之形式採集測點。

A-C) 點動位置 1-3) 自動測量的點位置。紅線顯示測量路徑。

  5. 按確認並將目前命令新增至末端螢幕按鍵 [image] 。特徵命令被新增至測量程式。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存

特定的特徵路徑和 NC Gage 內置邏輯

學習網路特徵路徑

  • 讀取網路第一邊上第一個點旁邊的測頭位置，Z 值將為所有點的測量高度

  • 讀取網狀第一邊上第二個點旁邊的測頭位置，第一個點至第二個點的方向定義網狀的方向向量。這一個點可確定第二個點的近似測量位置。

  • 讀取網路第二邊上一個點旁邊的測頭位置，從這一點至最初兩點所形成的線之間的距離近似為網路的寬度。這一個點可確定第三個點的近似測量位置。

  • 若測頭位於安全平面高度之下，可向上移動至安全平面高度。

  • 移至第一個讀取點之上的位置處。

  • 下降至測量高度。

  • 測量點，目標是將第一個點投影至網路中心線上。

  • 撤銷並移動至第二個讀取點位置。

  • 測量點，目標是將第二個點投影至網路中心線上。

  • 撤銷並向上移動至安全平面高度。

  • 移至第三個讀取點之上的點處。

  • 下降至測量高度

  • 測量點，目標是將第三個點投影至網路中心線上。

  • 撤銷並向上移動至安全平面高度。

執行網路特徵路徑

  • 如果測頭位於安全平面高度下方，則將其向上移至安全平面高度。

  • 移至第一個預測點上方的位置。

  • 下降至測量高度。

  • 測量點，目標是將第一個點投影至網路中心線上。

  • 撤銷並移動至第二個預測點位置。

  • 測量點，目標是將第二個點投影至網路中心線上。

  • 撤銷並向上移動至安全平面高度。

  • 移至第三個預測點之上的點處。

  • 下降至測量高度

  • 測量點，目標是將第三個點投影至網路中心線上。

  • 如果啟用本地安全平面，則移動每個點間的本地安全平面以到達下一預測點。

  • 撤銷並向上移動至安全平面高度。


槽

Home > 使用 PC-DMIS NC Gage > 建立特徵命令 > 槽

測量槽

要建立口袋命令：

  1. 按主螢幕上的測量螢幕按鍵 [image] 。

  2. 按槽 螢幕按鍵 [image] 以顯示測量槽螢幕：

  3. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將顯示測頭測量和變更位置的圖形視圖。

「屬性」區域

備註：選取選用設定區域中的使用螢幕上的值學習核取方塊後，才可看見以下兩個屬性：

  • 第一邊長 – 定義從第一個點到第二個點的距離。

  • 第二邊長 – 定義從起點（若投影在第二邊上）到第二邊上的點的距離。

「動作參數」區域

  • 逼近距離 - 定義遠離標稱曲面的距離，測頭在測量過程中將使用此標稱曲面開始搜尋曲面。

  • 搜尋距離 - 定義測頭在學習模式中搜尋曲面時運行的距離。（若選取了「選用設定區域」中所述的使用螢幕上的值學習，則該選項將不可用。）

「選用設定」區域

  • 觸測安全平面 - 選取此選項可將測頭移動至各個特徵測點之間的安全平面上。右側的編輯方塊可輸入平面距離。此平面不是測量程式安全平面。有關詳細資料，請參閱觸測安全平面。

  • 學習後測量 - 選取此選項可導致機器首先使用預設參數學習工件的位置，然後使用螢幕上設定的屬性立即重新測量特徵。用於測試所有設定的參數，確保實現更精確、更可靠的首件檢查。

  • 使用螢幕上的值學習 - 用於輸入特徵的標稱值，並在此位置測量軟體。（選取後，將啟用屬性區域中的第一邊長和第二邊長選項並停用動作參數區域中的搜尋距離選項。）

「參數」區域

  • XYZ 標稱值 - 定義槽頂部曲面中心的標稱位置。

  • XYZ 測量值 - 顯示槽頂部曲面中心的測量位置。

  • X 角 - 定義槽的向量角。這是與 X 軸有關的直線方向。

  • 寬度（標稱值）- 定義了口袋的標稱寬度。

  • 寬度（測量值）- 顯示槽的測量寬度。

「3 軸報告」區域

「3 軸報告」可用於以三種方式定義 XYZ 點。

  • 選取定義測量特徵高度的測量點或平面。

  • 輸入要使用的平面的方向高度。此高度與工件原點有關，沿測頭向量進行測量。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 這將移除上一個學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
學習並建立命令 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。使用此螢幕按鍵，可在將特徵交付至測量程式前，作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。它是報告螢幕上顯示內容的概觀。 | 插入移動點 此按鍵可讀取測頭的目前位置，並作為安全移動將它插入測量程式。
確認╱新增命令 對於操作，這可以確認選取。 對於命令，這可以在測量程式結尾中附加命令。 對於特徵命令，測量機瞭解到特徵位置後或當您鍵入特徵的標稱值時這將變成可用狀態。 對於構造和尺寸特徵命令，一旦您指定適當的輸入特徵，這將變成可用狀態。 | 說明 此螢幕按鍵可進入 NC Gage說明檔。

學習處理序

  1. 將測頭置於第一邊上第一個點的旁邊，然後按一下讀取測頭位置螢幕按鍵 [image] 。與工作面表面之間的距離將與所有點上的距離相同。

  2. 將測頭置於第一邊上第二個點的旁邊，然後按一下讀取測頭位置螢幕按鍵 [image] 。

  3. 將測頭置於第二邊上的點的旁邊，然後按一下讀取測頭位置螢幕按鍵 [image] 。

  4. 按一下學習並建立一個命令螢幕按鍵 [image] 。NC Gage將移動至安全平面並自動按照下列所描述之形式採集測點。學習這些點之後，測頭將搜尋 4 次預碰距離。

口袋路徑：A-C) 沿著中心線的點動位置 1-3) 測量的點位置。紅線顯示測量路徑。

  5. 按一下確認並將目前命令新增至末端螢幕按鍵 [image] 。特徵命令被新增至測量程式。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

以下是特定的特徵路徑和 NC Gage 內置邏輯：

學習口袋特徵路徑

  • 讀取口袋第一邊上第一個點旁邊的測頭位置，Z 值將為所有點的測量高度

  • 讀取槽第一邊上第二個點旁邊的測頭位置，第一個點至第二個點的距離定義槽的方向向量。這一個點可確定第二個點的近似測量位置。

  • 讀取口袋第二邊上一個點旁邊的測頭位置，從這一點至最初兩點所形成的線之間的距離近似為口袋的寬度。這一個點可確定第三個點的近似測量位置。

  • 若測頭位於安全平面高度之下，可向上移動至安全平面高度。

  • 移至第一個讀取點之上的位置處。

  • 下降至測量高度。

  • 測量點，目標與口袋中心線之間的距離為 4* 預碰距離。

  • 撤銷並移動至第二個讀取點位置。

  • 測量點，目標與口袋中心線之間的距離為 4* 預碰距離。

  • 撤銷並移動至第三個讀取點位置。

  • 測量點，目標與口袋中心線之間的距離為 4* 預碰距離。

  • 撤銷並向上移動至安全平面高度。

執行口袋特徵路徑

  • 如果測頭位於安全平面高度下方，則將其向上移至安全平面高度。

  • 移至第一個預測點上方的位置。

  • 下降至測量高度。

  • 測量點，目標與口袋中心線之間的距離為 2* 預碰距離。

  • 撤銷並移動至第二個預測點位置。

  • 測量點，目標與口袋中心線之間的距離為 2* 預碰距離。

  • 撤銷並移動至第三個預測點位置。

  • 測量點，目標與口袋中心線之間的距離為 2* 預碰距離。

  • 如果啟用本地安全平面，則移動每個點間的本地安全平面以到達下一預測點。

  • 撤銷並向上移動至安全平面高度。


棱角（外部）

Home > 使用 PC-DMIS NC Gage > 建立特徵命令 > 棱角（外部）

測量棱角（外部）

若要建立棱角（外部）命令：

  1. 按一下主螢幕上的測量螢幕按鍵 [image] 。

  2. 按棱角（外部）螢幕按鍵 [image] ，顯示測量外棱角螢幕：

  3. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將顯示測頭測量和變更位置的圖形視圖。

屬性區域

備註：選取選用設定區域中的使用螢幕上的值學習核取方塊後，才可使用以下三個屬性：

  • 起始側偏移 - 定義分別從沿位於起始角方向第一個邊上的棱角標稱位置中的第一和第二點的距離。

  • 終止側偏移 - 定義分別從沿第二個邊上的棱角標稱位置中的第一和第二點的距離。

  • 第一側至第二側為順時針方向 - 預設情況下，NC Gage 會將第二側置於第一側的逆時針方向。選取此選項確認第二側位於第一側的順時針方向。

「動作參數」區域

  • 逼近距離 - 定義遠離標稱曲面的距離，測頭在測量過程中將使用此標稱曲面開始搜尋曲面。

  • 搜尋距離 - 定義測頭在學習模式中搜尋曲面時運行的距離。（若選取了「選用設定區域」中所述的使用螢幕上的值學習，則該選項將不可用。）

「選用設定」區域

  • 觸測安全平面 - 選取此選項可將測頭移動至各個特徵測點之間的安全平面上。右側的編輯方塊可讓您輸入平面距離。此平面不是測量程式安全平面。有關詳細資料，請參閱觸測安全平面。

  • 學習後測量 - 選取此選項可導致機器首先使用預設參數學習工件的位置，然後使用螢幕上設定的屬性立即重新測量特徵。用於測試所有設定的參數，確保實現更精確、更可靠的首件檢查。

  • 使用螢幕上的值學習 - 用於輸入特徵的標稱值，並在此位置測量軟體。（選取後，將啟用屬性區域中的起始側偏移、終止側偏移和第一側至第二側為順時針方向選項，並停用動作參數區域中的搜尋距離選項。）

「參數」區域

  • 標稱值（XY 標稱值）- 定義棱角的標稱位置。

  • 測量值（XY 測量值）- 顯示棱角的測量位置。

  • 起始角 - 定義棱角起始側的角度。這是與主軸有關的側向。在 XY 工作面上主軸為 X，在 YZ 工作面上為 Y，在 ZX 工作面上為 Z。

  • 所含角度 — 定義棱角兩側間的角度。

「3 軸報告」區域

「3 軸報告」可用於以三種方式定義 XYZ 點。

  • 選取定義測量特徵高度的測量點或平面。

  • 輸入要使用的平面的方向高度。此高度與工件原點有關，沿測頭向量進行測量。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 這將移除上一個學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量程式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量程式螢幕刪除命令。
學習並建立命令 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。使用此螢幕按鍵，可在將特徵交付至測量程式前，作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。它是報告螢幕上顯示內容的概觀。 | 插入移動點 此按鍵可讀取測頭的目前位置，並作為安全移動將它插入測量程式。
確認╱新增命令 對於操作，這可以確認選取。 對於命令，這可以在測量程式結尾中附加命令。 對於特徵命令，測量機瞭解到特徵位置後或當您鍵入特徵的標稱值時這將變成可用狀態。 對於構造和尺寸特徵命令，一旦您指定適當的輸入特徵，這將變成可用狀態。 | 說明 此螢幕按鍵可進入 NC 標準塊說明檔。

學習處理序

  1. 將測頭置於棱角第一個邊上第一個點的旁邊，按一下讀取位置螢幕按鍵 [image] 。

  2. 將測頭置於棱角第二個邊上第二個點的旁邊，按一下讀取位置 螢幕按鍵 [image] 。

  3. 將測頭置於棱角第二個邊上第一個點的旁邊，按一下讀取位置螢幕按鍵 [image] 。

  4. 將測頭置於棱角第二個邊上第二個點的旁邊，按一下讀取位置 螢幕按鍵 [image] 。

  5. 將測頭定位為自動測量，按一下學習和建立命令 [image] 。NC Gage 將以下述相同的方式自動進行觸測。

外棱角路徑：A-D) 分疊位置 1-4) 自動測量點位置。紅線顯示測量路徑。

  6. 一旦測量出特徵，就要更新測量值。按 確認並將目前命令新增至末端螢幕按鍵 [image] 。特徵命令被新增至測量程式。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

以下是特定的特徵路徑和 NC Gage 內置邏輯：

學習外棱角特徵路徑

  • 測頭的讀取位置靠近棱角第一個邊上的第一個點。將在此點的那一層進行所有測量。

  • 測頭的讀取位置靠近棱角第一個邊上的第二個點。

  • 測頭的讀取位置靠近棱角第二個邊上的第一個點。

  • 測頭的讀取位置靠近棱角第二個邊上的第二個點。

  • 決定第一和第一個方向向量以及法向量。

  • 補償點。

  • 決定近似棱角點。

  • 移至安全平面高度。

  • 將測頭置於第一個讀取點位置上方。

  • 下降至測量高度。

  • 測量第一個側面，深度符合第二個邊上的第一個點。

  • 將測頭置於第二個讀取點旁邊。

  • 測量第一個側面，深度符合第二個邊上的第一個點。

  • 移至棱角外的點以避免碰撞。

  • 將測頭置於第三個讀取點旁邊。

  • 測量第二個側面，深度符合第一個邊上的第一個點。

  • 將測頭置於第四個讀取點旁邊。

  • 測量第二個側面，深度符合第一個邊上的第一個點。

執行外棱角特徵路徑

  • 如果測頭位於安全平面高度下方，則將其向上移至安全平面高度。

  • 移至第一個預測點上方的位置。

  • 下降至測量高度

  • 測量第一個側面，深度符合第二個邊上的第一個點。

  • 將測頭置於第二個預測點。

  • 測量第一個側面，深度符合第二個邊上的第一個點。

  • 移至棱角外的點以避免碰撞。

  • 將測頭置於第三個預測點。

  • 測量第二個側面，深度符合第一個邊上的第一個點。

  • 將測頭置於第四個讀取點。

  • 如果啟用本地安全平面，則移動每個點間的本地安全平面以到達下一預測點。

  • 測量第二個側面，深度符合第一個邊上的第一個點。


棱角（內部）

Home > 使用 PC-DMIS NC Gage > 建立特徵命令 > 棱角（內部）

測量棱角（內部）

若要建立棱角（內部）命令：

  1. 按一下主螢幕上的測量螢幕按鍵 [image] 。

  2. 按棱角（內部） 螢幕按鍵 [image] ，顯示測量內棱角螢幕：

  3. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將顯示測頭測量和變更位置的圖形視圖。

屬性區域

備註：選取選用設定區域中的使用螢幕上的值學習核取方塊後，才可使用以下三個屬性：

  • 起始側偏移 - 它們是分別從沿位於起始角方向第一個邊上的棱角標稱位置中的第一和第二點的距離。

  • 終止側偏移— 它們是分別從沿第二個邊上的棱角標稱位置中的第一和第二點的距離。

  • 第一側至第二側為順時針方向 - 預設情況下，NC Gage 會將第二側置於第一側的逆時針方向。選取此選項確認第二側位於第一側的順時針方向。

「動作參數」區域

  • 逼近距離 - 定義遠離標稱曲面的距離，測頭在測量過程中將使用此標稱曲面開始搜尋曲面。

  • 搜尋距離 - 定義測頭在學習模式中搜尋曲面時運行的距離。（若選取了「選用設定區域」中所述的使用螢幕上的值學習，則該選項將不可用。）

「選用設定」區域

  • 觸測安全平面 - 選取此選項可將測頭移動至各個特徵測點之間的安全平面上。右側的編輯方塊可讓您輸入平面距離。此平面不是測量程式安全平面。有關詳細資料，請參閱觸測安全平面。

  • 學習後測量 - 選取此選項可導致機器首先使用預設參數學習工件的位置，然後使用螢幕上設定的屬性立即重新測量特徵。用於測試所有設定的參數，確保實現更精確、更可靠的首件檢查。

  • 使用螢幕上的值學習 - 允許您輸入特徵的標稱值，並在此位置測量軟體。（選取後，將啟用屬性區域中的起始側偏移、終止側偏移和第一側至第二側為順時針方向選項，並停用動作參數區域中的搜尋距離選項。）

「參數」區域

  • XYZ 標稱值 - 定義棱角的標稱位置。

  • XYZ 測量值 - 顯示棱角的測量位置。

  • 起始角 - 定義棱角起始側的角度。這是與 X 軸有關的側向。

  • 所含角度 — 定義棱角兩側間的角度。

「3 軸報告」區域

「3 軸報告」可用於以三種方式定義 XYZ 點。

  • 選取定義測量特徵高度的測量點或平面。

  • 輸入要使用的平面的方向高度。此高度與工件原點有關，沿測頭向量進行測量。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 這將移除上一次學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量程式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
學習並建立命令 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。使用此螢幕按鍵，可在將特徵交付至測量程式前，作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。它是報告螢幕上顯示內容的概觀。 | 插入移動點 此按鍵可讀取測頭的目前位置，並作為安全移動將它插入測量程式。
確認╱新增命令 對於操作，這可以確認選取。 對於命令，這可以在測量程式結尾中附加命令。 對於特徵命令，測量機瞭解到特徵位置後或當您鍵入特徵的標稱值時這將變成可用狀態。 對於構造和尺寸特徵命令，一旦您指定適當的輸入特徵，這將變成可用狀態。 | 說明 此螢幕按鍵可進入 NC 標準塊說明檔。

學習處理序

  1. 將測頭置於棱角第一個邊上第一個點的旁邊，按一下讀取位置螢幕按鍵 [image] 。

  2. 將測頭置於棱角第二個邊上第二個點的旁邊，按一下讀取位置 螢幕按鍵 [image] 。

  3. 將測頭置於棱角第二個邊上第一個點的旁邊，按一下讀取位置螢幕按鍵 [image] 。

  4. 將測頭置於棱角第二個邊上第二個點的旁邊，按一下讀取位置 螢幕按鍵 [image] 。

  5. 將測頭定位為自動測量，按一下學習和建立命令螢幕按鍵 [image] 。NC Gage 將以下述相同的方式自動進行觸測。

內棱角路徑：A-E) 分疊位置 1-5) 自動測量點位置。紅線顯示測量路徑。

  6. 一旦測量出特徵，就要更新測量值。按 確認並將目前命令新增至末端螢幕按鍵 [image] 。特徵命令被新增至測量程式。

以下是特定的特徵路徑和 NC Gage 內置邏輯：

學習內棱角特徵路徑

  • 測頭的讀取位置靠近棱角第一個邊上的第一個點。將在此點的同一層進行所有測量。

  • 測頭的讀取位置靠近棱角第一個邊上的第二個點。

  • 測頭的讀取位置靠近棱角第二個邊上的第一個點。

  • 測頭的讀取位置靠近棱角第二個邊上的第二個點。

  • 決定第一和第一個方向向量以及法向量。

  • 補償點。

  • 決定近似棱角點。

  • 如果測頭位於安全平面高度下方，則將其移至安全平面高度。

  • 將測頭置於第一個讀取點位置上方的點。

  • 下降至測量高度

  • 測量第一個側面，搜尋距離為 4* 逼近距離。

  • 將測頭置於第二個讀取點旁邊。

  • 測量第一個側面，搜尋距離為 4* 逼近距離。

  • 將測頭置於第三個讀取點旁邊。

  • 測量第二個側面，搜尋距離為 4* 逼近距離。

  • 將測頭置於第四個讀取點旁邊。

  • 測量第二個側面，搜尋距離為 4* 逼近距離。

  • 移至安全平面高度。

執行內棱角特徵路徑

  • 如果測頭位於安全平面高度下方，則將其移至安全平面高度。

  • 將測頭置於第一個預碰點位置上方的點。

  • 下降至測量高度

  • 測量第一個側面，搜尋距離為 2* 逼近距離。

  • 將測頭置於第二個讀取點旁邊。

  • 測量第一個側面，搜尋距離為 2* 逼近距離。

  • 將測頭置於第三個讀取點旁邊。

  • 測量第二個側面，搜尋距離為 2* 逼近距離。

  • 將測頭置於第四個讀取點旁邊。

  • 測量第二個側面，搜尋距離為 2* 逼近距離。

  • 如果啟用本地安全平面，則移動每個點間的本地安全平面以到達下一預測點。

  • 移至安全平面高度。


平面

Home > 使用 PC-DMIS NC Gage > 建立特徵命令 > 平面

測量平面

  1. 按主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁 螢幕按鍵 [image] 以轉至螢幕按鍵的第二頁。

  3. 按平面 螢幕按鍵 [image] 以顯示測量平面 螢幕：

  4. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將顯示測頭測量和變更位置的圖形視圖。

屬性區域

備註：僅當在測量方法區域中選取了格線陣列選項時，才可使用下列兩個屬性。

  • 列數 - 定義平面上要進行探測的列數。

  • 每列的點數 - 提供一列中要測量的點數。

備註：僅當在測量方法區域中選取了圓形陣列選項時，才可使用下列屬性。

  • 點數 - 定義平面上要進行探測的圓形陣列週圍的點數。

備註：僅當在選用設定區域中選取了使用螢幕上的值學習核取方塊並在測量方法區域中選取了圓形陣列選項時，才可使用下列屬性。

  • 直徑 - 定義測量方法的圓形陣列的直徑。

備註：僅當在選用設定區域中選取了使用螢幕上的值學習核取方塊並在測量方法區域中選取了格線陣列時，才可使用下列兩個屬性。

  • 長度 - 此為主軸上從第一個點到最後一個點的距離。在 XY 工作面上主軸為 X，在 YZ 工作面上為 Y，在 ZX 工作面上為 Z。

  • 寬度 - 此為副軸上從第一個點到最後一個點的距離。在 XY 工作面上副軸為 Y ，在 YZ 工作面上為 Z，在 ZX 工作面上為 X。

備註：列數和每列的點數將在已定義的平面區域中等間距排列。

「動作參數」區域

  • 逼近距離 - 定義遠離標稱曲面的距離，測頭在測量過程中將使用此標稱曲面開始搜尋曲面。

  • 搜尋距離 - 定義了在尋找及學習特徵時的搜尋距離。（若選取了「選用設定區域」中所述的使用螢幕上的值學習，則該選項將不可用。）

「選用設定」區域

  • 觸測安全平面 - 選取此選項可將測頭移動至各個特徵測點之間的安全平面上。右側的編輯方塊可輸入平面距離。此平面不是測量程式安全平面。有關詳細資料，請參閱觸測安全平面。

  • 學習後測量 - 選取此選項可導致機器首先使用預設參數學習工件的位置，然後使用螢幕上設定的屬性立即重新測量特徵。用於測試所有設定的參數，確保實現更精確、更可靠的首件檢查。

  • 使用螢幕上的值學習 - 允許使用者輸入特徵的標稱值，並在此位置測量軟體。（此選項可啟用或停用屬性和動作參數區域中的其他選項，具體取決於在測量方法區域中所做的選取。）

「參數」區域

  • 標稱值（XYZ 標稱值）- 定義平面的標稱位置。

  • 測量值（XYZ 測量值）- 顯示平面的測量位置。

  • Z 角 - 定義平面在 Z 方向上的第一個向量角。此為平面的曲面法線方向，與工作面關聯。有效範圍為 -90 度至 +90 度。

  • X 角 - 定義平面在 X 方向上的向量角。此為平面的曲面法線方向，與測量所在的主軸關聯。在 XY 工作面上主軸為 X，在 YZ 工作面上為 Y，在 ZX 工作面上為 Z。有效範圍為 0（零）度至 -360 度。

備註： Z 角和 X 角是相關的 — 無效值 (90.0, 20.0) 將被定義為 (90.0, 0.0)。

「測量方法」區域

備註：屬性區域中選項的啟用或停用取決於所作的選取。有關詳細資料，請參閱「屬性區域」。

  • 格線陣列 - 定義了測量平面時所用的格線陣列。

  • 圓形陣列 - 定義了測量平面時所用的圓形陣列。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
選取測量面 此螢幕按鍵可決定觸測方向和移動到特徵的安全位置。您可按多次選取不同的測量面。 可用的測量面有：上、左、右、前、後和傾斜。若選取「傾斜」，螢幕按鍵圖示將變為傾斜圖示。 | 切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。
返回上一步 此螢幕按鍵可移除上一次學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。 | 插入移動點 此螢幕按鍵可讀取測頭的目前位置，並作為安全移動將它插入測量常式。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |

在工作面已定義法線的情況下使用「格線陣列」選項學習平面的程序：

  1. 從測量平面螢幕的測量方法區域中選取格線陣列。

  2. 按選取測量面螢幕按鍵 [image] 直至為待定義的平面（上、左、右、前、後或傾斜）設定所需的工作面。若選取了傾斜，選取測量面螢幕按鍵將變為傾斜螢幕按鍵 [image] 。有關詳細資料，請參閱「在「傾斜」工作面已定義法線的情況下使用「格線陣列」選項學習平面的程序」。

備註：已選取的工作面必須與平面的法線方向相同。

  3. 格線中的兩個點將透過將測頭推至所選工作面的相應位置進行學習。將測頭置於待測量平面的曲面上方。即指示平面的第一個角。

  4. 按一下讀取測頭位置螢幕按鍵 [image] 。讀取的測尖位置值可作為平面特徵上格線陣列第一個角的坐標。按返回上一步螢幕按鍵 [image] ，取消此測量位置。

  5. 將測頭置於格線陣列的第二個角之上。

  6. 按一下讀取測頭位置螢幕按鍵 [image] 。讀取的測尖位置 X/Y 可作為第二個角的坐標。按返回上一步螢幕按鍵 [image] ，取消此測量位置。所選工作面中的矩形區域將透過定義觸測區域的機器坐標中的學習點進行記錄。

  7. 按學習和建立命令螢幕按鍵 [image] ，在 CNC 中運行監視器程式。四個點將在定義的格線棱角位置自動觸測。以下所示為所選的 -Y 工作面、黃色 P1 和 P2 位置處的兩個觸測點以及紅色的觸測路徑：

    使用兩個分疊位置（P1、P2）、非傾斜的工作面和格線陣列定義平面

學習並測量特徵後，將更新測量值，並沿實際平面法線進行測量。

  8. 按 確認並將目前命令新增至末端螢幕按鍵 [image] 。特徵命令被新增至測量程式。

在「傾斜」工作面已定義法線的情況下使用「格線陣列」選項學習平面的程序

  1. 從測量平面螢幕的測量方法區域中選取格線陣列。

  2. 按一下選取測量面螢幕按鍵 [image] 直至其變為「傾斜」圖示 [image] 。

  3. 格線中的三個點將透過將測頭推至所選工作面的相應位置進行學習。將測頭置於格線的第一個角之上。即指示平面的第一個角。按一下讀取測頭位置螢幕按鍵 [image] 。

  4. 將測頭置於格線的第二角之上，表示格線的第二個角，然後按一下讀取測頭位置螢幕按鍵 [image] 。

  5. 將測頭置於格線的對角之上，然後按一下讀取測頭位置螢幕按鍵 [image] 。

  6. 曲面上的矩形區域將透過定義待觸測區域的學習點進行記錄。按學習和建立命令螢幕按鍵 [image] ，在 CNC 中運行監視器程式。這四個點將使用黃色 P1、P2 和 P3 位置上的三個觸測點及紅色觸測路徑在以下所示的定義的格線棱角位置上自動觸測。

使用三個分疊位置（P1、P2、P3）、傾斜的工作面和格線陣列定義平面。

觸測完成後，中心、標稱和觸測區域的標稱值將得到更新。學習平面後，將沿實際平面法線進行測量。

  7. 按 確認並將目前命令新增至末端螢幕按鍵 [image] 。特徵命令被新增至測量程式。

在工作面已定義法線的情況下使用「圓形陣列」選項學習平面的程序

  1. 從測量平面螢幕上的測量方法區域中選取圓形陣列。

  2. 按一下選取測量面螢幕按鍵 [image] 直至為待定義的平面（上、左、右、前、後或傾斜）設定所需的工作面。若選取了「傾斜」，選取測量面螢幕按鍵將變為傾斜螢幕按鍵 [image] 。有關詳細資料，請參閱「在「傾斜」工作面已定義法線的情況下使用「圓形陣列」選項學習平面的程序」。

備註：已選取的工作面必須與平面的法線方向相同。

  3. 圓中的兩個點將透過將測頭推至所選工作面的相應位置進行學習。將測頭置於待測量圓的曲面上方。這表示圓直徑的第一個點。

  4. 按一下讀取測頭位置螢幕按鍵 [image] 。讀取的測尖位置值可作為平面特徵上圓形陣列第一邊的坐標。按返回上一步螢幕按鍵 [image] ，取消此測量位置。

  5. 將測頭置於圓對點之上。按一下讀取測頭位置螢幕按鍵 [image] 。工作面上的圓形區域將透過定義觸測區域的機器坐標中的學習點進行記錄。按返回上一步螢幕按鍵 [image] ，取消此測量位置。

  6. 按學習和建立命令螢幕按鍵 [image] ，在 CNC 中運行監視器程式。透過指示圓特徵範圍的已定義的上述兩個點，NC Gage 將自動使用所選的 -Y 工作面、黃色 P1 和 P2 位置處的兩個觸測點以及紅色的觸測路徑在以下所示的圓內自動觸測：

    使用兩個分疊位置（P1、P2）、非傾斜的工作面和圓形陣列定義平面

觸測完成後，中心、標稱和觸測區域的標稱值將得到更新。測量特徵後，測量值將進行更新。然後，將沿實際平面法線進行所有測量。

  7. 按 確認並將目前命令新增至末端螢幕按鍵 [image] 。特徵命令被新增至測量程式。

在「傾斜」工作面已定義法線的情況下使用「圓形陣列」選項學習平面的程序

  1. 從測量平面螢幕上的測量方法區域中選取圓形陣列。

  2. 按選取測量面螢幕按鍵 [image] 直至其變為傾斜圖示 [image] 。

  3. 圓中的三個點將透過將測頭推至所選工作面的相應位置進行學習。將測頭置於圓的第一個點之上。按一下讀取測頭位置螢幕按鍵 [image] 。

  4. 將測頭置於圓的第二個點之上。按一下讀取測頭位置螢幕按鍵 [image] 。

  5. 將測頭置於圓對點之上。按一下讀取測頭位置螢幕按鍵 [image] 。曲面中的圓形區域將透過定義觸測區域的學習點進行記錄。

  6. 按學習和建立命令螢幕按鍵 [image] ，在 CNC 中運行監視器程式。透過指示圓特徵範圍的已定義的上述三個點，NC Gage 將自動使用黃色 P1、P2 和 P3 位置處的三個觸測點以及紅色的觸測路徑在以下所示的圓內自動觸測：

使用三個分疊位置（P1、P2、P3）、傾斜的工作面和圓形陣列定義平面。

觸測完成後，中心、標稱和觸測區域的標稱值將得到更新。學習平面後，將沿實際平面法線進行測量。

  7. 按 確認並將目前命令新增至末端螢幕按鍵 [image] 。特徵命令被新增至測量程式。

特定的特徵路徑和 NC Gage 內置邏輯

學習平面特徵路徑（格線陣列）

  • 讀取位於平面格線第一個角之上的測頭位置。這就定義了學習預測點的高度。

  • 讀取位於平面格線第二個角之上的測頭位置。

  • 如果測頭位於安全平面高度下方，則將其向上移至安全平面高度。

  • 移至第一個讀取點上方。

  • 下降至第一個讀取點。

  • 測量表面，搜尋距離為 4* 預碰距離。

  • 測量格線中的每個點，交替每條格線的方向。

  • 向上移至安全平面高度。

學習平面特徵路徑（圓形陣列）

  • 讀取位於平面圓第一邊之上的測頭位置。這就定義了學習預測點的高度。

  • 讀取位於圓形陣列中相對點之上的測頭位置。

  • 如果測頭位於安全平面高度下方，則將其向上移至安全平面高度。

  • 移至第一個讀取點上方。

  • 下降至第一個讀取點。

  • 測量表面，搜尋距離為 4* 預碰距離。

  • 測量圓形陣列中的每個點。

  • 向上移至安全平面高度。

執行平面特徵路徑（格線陣列）

  • 如果測頭位於安全平面高度下方，則將其向上移至安全平面高度。

  • 移至第一個格線點之上的點處。

  • 降至標稱平面之上的預碰距離。

  • 測量表面，搜尋距離為 2* 預碰距離。

  • 測量格線中的每個點，交替每條格線的方向。

  • 如果已啟用本地安全平面，可移至各點之間的本地安全平面，以到達下一個預測點。.

  • 向上移至安全平面高度。

執行平面特徵路徑（圓形陣列）

  • 如果測頭位於安全平面高度下方，則將其向上移至安全平面高度。

  • 移至圓上第一個點之上的點處。

  • 降至標稱平面之上的預碰距離。

  • 測量表面，搜尋距離為 2* 預碰距離。

  • 以反時針方向測量圓形陣列中的每個點。

  • 如果已啟用本地安全平面，可移至各點之間的本地安全平面，以到達下一個預測點。.

  • 向上移至安全平面高度。


直線

Home > 使用 PC-DMIS NC Gage > 建立特徵命令 > 直線

測量線

若要建立直線命令：

  1. 按主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁 螢幕按鍵 [image] 以轉至螢幕按鍵的第二頁。

  3. 按直線 螢幕按鍵 [image] ，顯示測量線螢幕：

  4. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將顯示測頭測量和變更位置的圖形視圖。

「屬性定義」區域

  • 點數 - 定義執行過程中直線觸測的點數。

備註：選取選用設定區域中的使用螢幕上的值學習核取方塊後，才可看見以下兩個屬性：

  • 長度 - 定義直線的長度。

  • 測量「右」邊 - 選取後，直線的測量「右」邊設定可透過定義直線的哪一邊為材料邊來決定測頭的方向。如果核取此方塊，那麼當材料從第一個測量點移至最後一個測量點時，材料應在直線的「右」邊。如果材料從第一個測量點移至最後一個測量點時在「左」邊，那麼此方塊應沒有核取。

「動作參數」區域

  • 逼近距離 - 定義遠離標稱曲面的距離，測頭在測量過程中將使用此標稱曲面開始搜尋曲面。

  • 搜尋距離 - 定義測頭在學習模式中搜尋曲面時運行的距離。（若選取了「選用設定區域」中所述的使用螢幕上的值學習，則該選項將不可用。）

「選用設定」區域

  • 觸測安全平面 - 選取此選項可將測頭移動至各個特徵測點之間的安全平面上。右側的編輯方塊可輸入平面距離。此平面不是測量程式安全平面。有關詳細資料，請參閱觸測安全平面。

  • 學習後測量 - 選取此選項可導致機器首先使用預設參數學習工件的位置，然後使用螢幕上設定的屬性立即重新測量特徵。用於測試所有設定的參數，確保實現更精確、更可靠的首件檢查。

  • 使用螢幕上的值學習 - 允許使用者輸入特徵的標稱值，並在此位置測量軟體。（此選項可啟用「屬性區域」中所述的其他屬性並停用「動作參數區域」中所述的搜尋距離選項。）

「參數」區域

  • XYZ 標稱值 - 定義起點的標稱位置。

  • XYZ 測量值 - 顯示起點的測量位置。

  • X 角 - 定義直線的向量角。這是與 X 軸有關的直線方向。

「3 軸報告」區域

「3 軸報告」可用於以三種方式定義 XYZ 點。

  • 選取定義測量特徵高度的測量點或平面。

  • 輸入要使用的平面的方向高度。此高度與工件原點有關，沿測頭向量進行測量。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 這將移除上一個學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量程式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量程式螢幕刪除命令。
學習並建立命令 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。使用此螢幕按鍵，可在將特徵交付至測量程式前，作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。它是報告螢幕上顯示內容的概觀。 | 插入移動點 此螢幕按鍵可讀取測頭的目前位置，並作為安全移動將它插入測量程式。
確認╱新增命令 對於操作，這可以確認選取。 對於命令，這可以在測量程式結尾中附加命令。 對於特徵命令，測量機瞭解到特徵位置後或當您鍵入特徵的標稱值時這將變成可用狀態。 對於構造和尺寸特徵命令，一旦您指定適當的輸入特徵，這將變成可用狀態。 | 說明 此螢幕按鍵可進入 NC Gage說明檔。

學習處理序

  1. 將測頭置於直線第一個點的旁邊，如下圖位置A所示。

  2. 按一下讀取位置螢幕按鍵 [image] 。應將測尖位置理解為開始位置。按返回至上一步 螢幕按鍵 [image] ，取消此測量位置。

  3. 將測頭置於直線第二個點的旁邊，如下圖點B所示。

  4. 按一下讀取位置螢幕按鍵 [image] 。應將測尖位置理解為開始位置。按返回至上一步 螢幕按鍵 [image] ，取消此測量位置。

  5. 將測頭從第二點中移開。

  6. 按一下讀取位置螢幕按鍵 [image] 。

  7. 將測頭定位為自動測量，按一下學習和建立命令螢幕按鍵 [image] 。NC Gage 將以下述相同的方式自動進行觸測。

左圖表示分疊位置 (A-C)，您應手動將測頭移至此位置。右圖表示自動觸測路徑（紅線）和點位置 (1-2)。

  8. 一旦測量出特徵，就要更新測量值。按 確認並將目前命令新增至末端螢幕按鍵 [image] 。特徵命令被新增至測量程式。

特定的特徵路徑和 NC Gage 內置邏輯

學習直線特徵路徑

  • 測頭的讀取位置靠近第一個點，這就定義了測量高度。

  • 測頭的讀取位置在第二個點上方，這就定義了直線方向。

  • 測頭的讀取位置遠離直線，這就定義了材料方向。

  • 如果測頭位於安全平面高度下方，則將其向上移至安全平面高度。

  • 移至第一個讀取點上方。

  • 下降至第一個讀取點。

  • 測量表面，搜尋距離為 4* 逼近距離。

  • 以相似直線測量每個點。

  • 向上移至安全平面高度。

執行直線特徵路徑

  • 如果測頭位於安全平面高度下方，則將其向上移至安全平面高度。

  • 移至第一個預測點上方的點。

  • 下降至預測點。

  • 測量表面，搜尋距離為 2* 逼近距離。

  • 以相似直線測量每個點。

  • 如果啟用本地安全平面，則移動每個點間的本地安全平面以到達下一預測點。

  • 向上移至安全平面高度。


圓柱（內徑）

Home > 使用 PC-DMIS NC Gage > 建立特徵命令 > 圓柱（內徑）

測量圓柱（內徑）

若要建立圓柱（內經）命令：

  1. 按主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁 螢幕按鍵 [image] 以轉至螢幕按鍵的第二頁。

  3. 按圓柱（內徑） 螢幕按鍵 [image] ，顯示「測量圓柱（內徑）」 螢幕：

  4. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將顯示測頭測量和變更位置的圖形視圖。

屬性區域

  • 每層的點 - 定義執行過程中（非學習模式）圓柱觸測的每層點數。

  • 層數 - 定義執行過程中（非學習模式）在層中測量的點數。

  • 起始角 — 定義待測量圓柱截面的起始點。在沿主軸的 0 上開始旋轉，在副軸上放大至 90。在 XY 工作面上主軸為 X，在 YZ 工作面上為 Y，在 ZX 工作面上為 Z。在 XY 工作面上副軸為 Y ，在 YZ 工作面上為 Z，在 ZX 工作面上為 Z。

  • 終止角 - 定義待測量的圓柱截面的末端。在執行模式中測量特徵時才使用起始和終止角。學習模式會自動在主軸和副軸相反的方向進行觸測。如果圓柱不繼續環繞 360 度，那麼將不能使用使用螢幕上的值學習以輸入帶有已定義的適當起始和終止角的標稱位置。然後，選取學習後測量後，NC Gage 將測量特徵。

備註：選取選用設定區域中的使用螢幕上的值學習核取方塊後，才可使用以下兩個屬性。

  • 頂部高度 - 位於圓柱測量頂部的測點的軸位置。這與沿著與圓柱中央線對齊的軸的目前工作偏移有關。

  • 底部高度 - 位於圓柱測量底部的測點的軸位置。這與沿著與圓柱中央線對齊的軸的目前工作偏移有關。

備註：每列的列數和點數沿定義的圓柱的空隙相等。

「動作參數」區域

  • 逼近距離 - 定義遠離標稱曲面的距離，測頭在測量過程中將使用此標稱曲面開始搜尋曲面。

  • 搜尋距離 - 定義測頭在學習模式中用於搜尋工件的距離。（若選取了「選用設定區域」中所述的使用螢幕上的值學習選項，則該選項將不可用。）

「選用設定」區域

  • 觸測安全平面 - 選取此選項可將測頭移動至各個特徵測點之間的安全平面上。右側的編輯方塊可輸入平面距離。此平面不是測量程式安全平面。有關詳細資料，請參閱觸測安全平面。

  • 學習後測量 - 選取此選項可導致機器首先使用預設參數學習工件的位置，然後使用螢幕上設定的屬性立即重新測量特徵。用於測試所有設定的參數，確保實現更精確、更可靠的首件檢查。

  • 使用螢幕上的值學習 - 用於輸入特徵的標稱值，並在此位置測量軟體。（選取此選項可啟用「屬性區域」中所述的其他屬性並停用「動作參數區域」中所述的搜尋距離選項。）

「參數」區域

  • XYZ 標稱值 - 定義圓柱的標稱位置。

  • XYZ 測量值 - 顯示圓柱的測量位置。

  • 直徑（標稱值）- 定義圓柱的標稱直徑。

  • 直徑（測量值）- 顯示圓柱的測量直徑。

  • Z 角 - 定義圓柱的第一個向量角。這是與工作面有關的圓柱的中央線方向。有效範圍為 -90 度至 +90 度。

  • X 角 - 定義圓柱的第二個向量角。這是與測量的主軸有關的圓柱的中央線方向。在 XY 工作面上主軸為 X，在 YZ 工作面上為 Y，在 ZX 工作面上為 Z。有效範圍為 0（零）度至 -360 度。

備註：Z 角和 X 角是相關的 — 有效值 (90.0, 20.0) 將被定義為 (90.0, 0.0)。

「3 軸報告」區域

「3 軸報告」可用於以三種方式定義 XYZ 點。

  • 選取定義測量特徵高度的測量點或平面。

  • 鍵入要使用的平面的方向高度。此高度與工件原點有關，沿測頭向量進行測量。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可移除上一次學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。 | 插入移動點 此螢幕按鍵可讀取測頭的目前位置，並作為安全移動將它插入測量常式。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。

學習處理序

  1. 將測頭向下置於下面影像中 A 所示的底層中心的圓柱（遠離工作面）。

  2. 按一下讀取位置螢幕按鍵 [image] 。

  3. 將測頭置於頂層中心，按讀取位置螢幕按鍵 [image] 。

  4. 按學習和建立命令 螢幕按鍵 [image] 。NC Gage 將以下述相同的方式自動進行觸測。

圓柱突起路徑：A-B) 分疊位置 1-4) 動測量點位置。紅線顯示測量路徑。

  5. 一旦測量出特徵，就要更新測量值。按 確認並將目前命令新增至末端螢幕按鍵 [image] 。特徵命令被新增至測量程式。

以下是特定的特徵路徑和 NC Gage 內置邏輯：

學習圓柱內經特徵路徑

  • 測頭的讀取位置在較低層內經中心，這就定義了內經中心和執行時間的第一層高度。

  • 測頭的讀取位置在內經較上層中心，這就定義了執行時間最後一層的高度。此高度可用於學習圓柱內經。

  • 使用搜尋距離在 +X 方向上的測量點。

  • 返回至中心位置。

  • 使用搜尋距離在 –X 方向上的測量點。

  • 返回至中心位置。

  • 使用搜尋距離在 +Y 方向上的測量點。

  • 返回至中心位置。

  • 使用搜尋距離在 –Y 方向上的測量點。

  • 返回至中心位置。

執行圓柱內經特徵路徑

  • 定義預碰半徑 = 內經半徑 – 逼近距離 – 測頭半徑。

  • 定義目標半徑 = 內經半徑 + 逼近距離 – 測頭半徑。

  • 如果當前位置低於安全平面，則將其向上移動至安全平面。

  • 移至第一個預測點上方的位置。此點是預測點半徑距離起始角方向上的內經中心的距離。

  • 下降至測量最低層。

  • 測量點、目標是距離沿角內經中心的目標半徑。

  • 撤銷並移至下一點的預測點。

  • 測量點、目標是距離沿角內經中心的目標半徑。

  • 繼續從起始角到終止角開始測量指定的點數。

  • 測量其他層和交替方向上的測量點。

  • 如果啟用本地安全平面，則移動每個點間的本地安全平面以到達下一預測點。

  • 測量過上一點後，測頭向上移動至安全平面高度。


圓柱（突起部）

Home > 使用 PC-DMIS NC Gage > 建立特徵命令 > 圓柱（突起部）

測量圓柱（突起部）

若要建立圓柱（突起部）命令：

  1. 按主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁 螢幕按鍵 [image] 以轉至螢幕按鍵的第二頁。

  3. 按圓柱（突起部 ） 螢幕按鍵 [image] ，顯示測量圓柱（突起部 ） 螢幕：

  4. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將顯示測頭測量和變更位置的圖形視圖。

屬性區域

  • 每層的點 - 定義執行過程中（非學習模式）圓柱觸測的每層點數。

  • 層數 - 定義執行過程中（非學習模式）待測量的每層所用的點數。

  • 起始角 — 定義待測量圓柱截面的起始點。在沿主軸的 0 上開始旋轉，在副軸上放大至 90。在 XY 工作面上主軸為 X，在 YZ 工作面上為 Y，在 ZX 工作面上為 Z。在 XY 工作面上副軸為 Y ，在 YZ 工作面上為 Z，在 ZX 工作面上為 X。

  • 終止角 - 定義待測量的圓柱截面的末端。在執行模式中測量特徵時才使用起始和終止角。學習模式會自動在主軸和副軸相反的方向進行觸測。如果圓柱不繼續環繞 360 度，那麼將不能使用使用螢幕上的值學習以輸入帶有已定義的適當起始和終止角的標稱位置。然後，選取學習後測量後，NC Gage 將測量特徵。

備註：選取選用設定區域中的使用螢幕上的值學習核取方塊後，才可使用以下兩個屬性。

  • 頂部高度 - 用於定義位於圓柱測量頂部的測點的軸位置。這與沿著與圓柱中央線對齊的軸的目前工作偏移有關。

  • 底部高度 - 用於定義位於圓柱測量底部的測點的軸位置。這與沿著與圓柱中央線對齊的軸的目前工作偏移有關。

備註：每列的列數和點數沿定義的圓柱的空隙相等。

「動作參數」區域

  • 逼近距離 - 定義遠離標稱曲面的距離，測頭在測量過程中將使用此標稱曲面開始搜尋曲面。

  • 搜尋距離 - 定義測頭在學習模式中用於搜尋工件的距離。（若選取了「選用設定區域」中所述的使用螢幕上的值學習，則該選項將不可用。）

「選用設定」區域

  • 觸測安全平面 - 選取此選項可將測頭移動至各個特徵測點之間的安全平面上。右側的編輯方塊可輸入平面距離。此平面不是測量程式安全平面。有關詳細資料，請參閱觸測安全平面。

  • 學習後測量 - 選取此選項可導致機器首先使用預設參數學習工件的位置，然後使用螢幕上設定的屬性立即重新測量特徵。用於測試所有設定的參數，確保實現更精確、更可靠的首件檢查。

  • 使用螢幕上的值學習 - 輸入特徵的標稱值，並在該位置測量軟體。（選取此選項可啟用「屬性區域」中所述的其他屬性並停用「動作參數區域」中所述的搜尋距離選項。）

「參數」區域

  • XYZ 標稱值 - 定義圓柱的標稱位置。

  • XYZ 測量值 - 顯示圓柱的測量位置。

  • 直徑（標稱值）- 定義圓柱的標稱直徑。

  • 直徑（測量值）- 顯示圓柱的測量直徑。

  • Z 角 - 定義圓柱的第一個向量角。這是與工作面有關的圓柱的中央線方向。有效範圍為 -90 度至 +90 度。

  • X 角 - 定義圓柱的第二個向量角。這是與測量的主軸有關的圓柱的中央線方向。在 XY 工作面上主軸為 X，在 YZ 工作面上為 Y，在 ZX 工作面上為 Z。有效範圍為 0（零）度至 -360 度。

備註：Z 角和 X 角是相關的 — 有效值 (90.0, 20.0) 將被定義為 (90.0, 0.0)。

「3 軸報告」區域

「3 軸報告」可用於以三種方式定義 XYZ 點。

  • 選取定義測量特徵高度的測量點或平面。

  • 輸入要使用的平面的方向高度。此高度與工件原點有關，沿測頭向量進行測量。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 這將移除上一個學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
學習並建立命令 在所有需要的測頭位置識別已學習的特徵位置後才可用它。它將讓機器測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓機器測量特徵。在所有需要的測頭位置識別已學習的或（已鍵入的）特徵位置後才可用它。使用此螢幕按鍵，可在將特徵交付至測量程式前，作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。它是報告螢幕上顯示內容的概觀。 | 插入移動點 讀取測頭的目前位置，作為安全移動將它插入測量程式。
確認╱新增命令 對於操作，這可以確認選取。 對於命令，這可以在測量程式結尾中附加命令。 對於特徵命令，測量機瞭解到特徵位置後或當您鍵入特徵的標稱值時這將變成可用的。 對於構造的和尺寸特徵命令，一旦您指定適當的輸入特徵，這將變成可用的。 | 說明 此螢幕按鍵可進入 NC Gage說明檔。

學習處理序

  1. 將測頭置於底層表面附近，按讀取位置 螢幕按鍵 [image] 。這將是「底」層位置。

  2. 將測頭置於頂層表面附近，按讀取位置螢幕按鍵 [image] 。這將是「頂」層位置。

  3. 將測頭置於突起部中心上方的安全高度，按讀取位置螢幕按鍵 [image] 。

  4. 按學習和建立命令螢幕按鍵 [image] 。NC Gage在此位置進行一次觸測以決定突起部的高度。然後，它將以下述相同的方式自動進行觸測。

圓柱突起部路徑：A-B) 手動測量位置 C) 分疊位置 1-4) 自動測量點位置。紅線顯示底層路徑。使用相似路線測量頂層。

  5. 一旦測量出特徵，就要更新測量值。按 確認並將目前命令新增至末端螢幕按鍵 [image] 。特徵命令被新增至測量程式。

以下是特定的特徵路徑和 NC Gage 內置邏輯：

學習圓柱突起部特徵路徑

  • 測頭的讀取位置靠近最底層的突起測，Z 值將為第一層的測量高度。

  • 測頭的讀取位置靠近最高層的突起側，Z 值將為最後一層的測量高度。此高度也可用於學習圓柱。

  • 測頭的讀取位置位於突起部中心上方，XY 定義中心，Z 為安全高度。

  • 預測點半徑 = 第一和第三個位置點間預計的 2D 距離。

  • 移至安全高度。

  • 將安全高度移至預測點 1 上方的一個點，此點是 +X 方向上中心的預測點距離。

  • 下降至測量高度。

  • 測量點、目標是測量高度上的中心。

  • 移至安全高度。

  • 將安全高度移至預測點 2 上方的一個點，此點是 -X 方向上中心的預測點距離。

  • 下降至測量高度。

  • 測量點、目標是測量高度上的中心。

  • 移至安全高度。

  • 將安全高度移至預測點 3 上方的一個點，此點是 +Y 方向上中心的預測點距離。

  • 下降至測量高度。

  • 測量點、目標是測量高度上的中心。

  • 移至安全高度。

  • 將安全高度移至預測點 4 上方的一個點，此點是 -Y 方向上中心的預測點距離。

  • 下降至測量高度。

  • 測量點、目標是測量高度上的中心。

  • 移至安全高度。

執行圓柱突起特徵路徑

  • 定義預測點半徑 = 突起部半徑 + 逼近距離 + 測頭半徑。

  • 定義目標半徑 = 突起部半徑 – 逼近距離 – 測頭半徑，如果它小於 0，那麼將其設定為 0。

  • 如果當前位置低於安全平面，則將其向上移動至安全平面。

  • 移至第一個預測點上方的位置。此點是預測點半徑距離起始角方向上的突起部中心的距離。

  • 下降至測量層。

  • 使用預測點半徑和目標半徑測量最低層。如果需要到達每個預測點直至到達終止角，請使用額外移動避開突起部。

  • 使用交替方向測量其餘層。

  • 如果啟用本地安全平面，則移動每個點間的本地安全平面以到達下一預測點。

  • 測量過上一點後，測頭向上移動至安全平面高度。


圓錐（內部）

Home > 使用 PC-DMIS NC Gage > 建立特徵命令 > 圓錐（內部）

測量圓錐（內部）

若要建立圓錐（內部）命令：

  1. 按一下主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁 螢幕按鍵 [image] 以轉至螢幕按鍵的第二頁。

  3. 按圓錐（內部） 螢幕按鍵 [image] ，顯示測量圓錐（內部） 螢幕：

  4. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將顯示測頭測量和變更位置的圖形視圖。

「屬性」區域

  • 每層的點 - 定義執行過程中（非學習模式）測頭用於測量圓錐的每層點數。

  • 層數 - 定義執行過程中（非學習模式）用於測量圓錐的層數。

  • 起始角 - 定義待測量圓錐截面的起始點。在沿主軸的 0 上開始旋轉，在副軸上放大至 90。在 XY 工作面上主軸為 X，在 YZ 工作面上為 Y，在 ZX 工作面上為 Z。在 XY 工作面上副軸為 Y ，在 YZ 工作面上為 Z，在 ZX 工作面上為 X。

  • 終止角 - 定義待測量的圓錐截面的末端。在執行模式中測量特徵時才使用起始和終止角。學習模式會自動在主軸和副軸相反的方向進行觸測。如果圓錐不繼續環繞 360 度，那麼可使用使用螢幕上的值學習以輸入帶有已定義的適當起始和終止角的標稱位置。然後，選取學習後測量後，NC Gage 將測量特徵。

備註：選取選用設定區域中的使用螢幕上的值學習核取方塊後，才可使用以下兩個屬性。

  • 頂部高度 - 位於圓錐測量頂部的測點的軸位置。該高度與沿著與圓錐中央線對齊的軸的目前工作偏移有關。

  • 底部高度 - 位於圓錐測量底部的測點的軸位置。該高度與沿著與圓錐中央線對齊的軸的目前工作偏移有關。

備註：每列的列數和點數沿已定義的錐體的空隙相等。

動作參數區域

  • 逼近距離 - 定義遠離標稱曲面的距離，測頭在測量過程中將使用此標稱曲面開始搜尋曲面。

  • 搜尋距離 - 定義測頭在學習模式中用於搜尋工件的距離。（若選取了「選用設定區域」中所述的使用螢幕上的值學習選項，則該選項將不可用。）

選用設定區域

  • 觸測安全平面 - 選取此選項可將測頭移動至各個特徵測點之間的安全平面上。右側的編輯方塊可輸入平面距離。此平面不是測量程式安全平面。有關詳細資料，請參閱觸測安全平面。

  • 學習後測量 - 選取此選項可導致機器首先使用預設參數學習工件的位置，然後使用螢幕上設定的屬性立即重新測量特徵。用於測試所有設定的參數，確保實現更精確、更可靠的首件檢查。

  • 使用螢幕上的值學習 - 用於輸入特徵的標稱值，並在此位置測量軟體。（選取此選項可啟用「屬性區域」中所述的其他屬性並停用「動作參數區域」中所述的搜尋距離選項。）

參數區域

  • 標稱值（XYZ 標稱值）- 定義圓錐中心的標稱位置。

  • 測量值（XYZ 測量值）- 顯示圓錐的測量位置。

  • 半角 - 顯示在圓錐側產生圓錐中央線的角度。

  • Z 角 - 定義圓錐的第一個向量角。它是與工作面有關的圓錐的中央線方向。有效範圍為 -90 度至 +90 度。

  • X 角 - 定義圓錐的第二個向量角。這是與測量的主軸有關的圓錐的中央線方向。在 XY 工作面上主軸為 X，在 YZ 工作面上為 Y，在 ZX 工作面上為 Z。有效範圍為 0（零）度至 -360 度。

備註：向量角 1 和向量角 2 是相關的 - (90.0, 20.0) 的有效值可定義為 (90.0, 0.0)。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可移除上一次學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。 | 插入移動點 此螢幕按鍵可讀取測頭的目前位置，並作為安全移動將它插入測量常式。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。

學習處理序

  1. 將測頭置於底層中心，按讀取位置 螢幕按鍵 [image] 。底層是離頂部最近的一層。

  2. 將測頭置於頂層中心，按讀取位置螢幕按鍵 [image] 。

  3. 將測頭定位為自動測量，按一下學習和建立命令螢幕按鍵 [image] 。NC Gage 將以下述相同的方式自動進行觸測。

    內圓錐路徑：A-B) 分疊位置 1-8) 自動測量點位置。

  4. 一旦測量出特徵，就要更新測量值。按 確認並將目前命令新增至末端螢幕按鍵 [image] 。特徵命令被新增至測量程式。

以下是特定的特徵路徑和 NC Gage 內置邏輯：

學習內錐特徵路徑

  • 測頭的讀取位置在較低層圓錐中心，這就定義了圓錐 XY 中心和執行時間第一層的高度。

  • 測頭的讀取位置在內經較上層中心，這就定義了執行時間最後一層的高度。

  • 移至第一個讀取點位置。

  • 以 +X、-X、+Y 和 –Y 方向的點來測量最低層，返回至測量後的較低層中心。

  • 移至上層中心。

  • 以 +X、-X、+Y 和 –Y 方向的點來測量上層，返回至測量後的上層中心。

執行內錐特徵路徑

  • 圓錐幾何可決定每個測量點的預碰和目標位置。

  • 如果當前位置低於安全平面，則將其向上移動至安全平面。

  • 移至第一個預測點上方的位置。此點是預測點半徑距離起始角方向上的內經中心的距離。

  • 下降至測量最低層。

  • 從終止角開始測量第一層。

  • 使用交替方向測量其餘層。

  • 如果啟用本地安全平面，則移動每個點間的本地安全平面以到達下一預測點。

  • 測量過上一點後，測頭向上移動至安全平面高度。


圓錐（外部）

Home > 使用 PC-DMIS NC Gage > 建立特徵命令 > 圓錐（外部）

測量圓錐（外部）

若要建立圓錐（外部）命令：

  1. 按一下主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁 螢幕按鍵 [image] 以轉至螢幕按鍵的第二頁。

  3. 按圓錐（外部） 螢幕按鍵 [image] ，顯示測量圓錐（外部） 螢幕：

  4. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將顯示測頭測量和變更位置的圖形視圖。

「屬性」區域

  • 每層的點 - 定義執行過程中（非學習模式）測頭用於測量圓錐的每層點數。

  • 層數 - 定義執行過程中（非學習模式）用於測量圓錐的層數。

  • 起始角 — 定義待測量圓錐截面的起始點。在沿主軸的 0 上開始旋轉，在副軸上放大至 90。在 XY 工作面上主軸為 X，在 YZ 工作面上為 Y，在 ZX 工作面上為 Z。在 XY 工作面上副軸為 Y ，在 YZ 工作面上為 Z，在 ZX 工作面上為 X。

  • 終止角 - 定義待測量的圓錐截面的末端。在執行模式中測量特徵時才使用起始和終止角。學習模式會自動在主軸和副軸相反的方向進行觸測。如果圓錐不繼續環繞 360 度，那麼可使用使用螢幕上的值學習以輸入帶有已定義的適當起始和終止角的標稱位置。然後，選取學習後測量後，NC Gage 將測量特徵。

備註：選取選用設定區域中的使用螢幕上的值學習核取方塊後，才可使用以下兩個屬性。

  • 頂部高度 - 位於圓錐測量頂部的測點的軸位置。該高度與沿著與圓錐中央線對齊的軸的目前工作偏移有關。

  • 底部高度 - 位於圓錐測量底部的測點的軸位置。該高度與沿著與圓錐中央線對齊的軸的目前工作偏移有關。

備註： 每列的列數和點數沿已定義的圓錐的空隙相等。

「動作參數」區域

  • 逼近距離 - 定義遠離標稱曲面的距離，測頭在測量過程中將使用此標稱曲面開始搜尋曲面。

  • 搜尋距離 - 定義測頭在學習模式中搜尋工件時的距離。（若選取了「選用設定區域」中所述的使用螢幕上的值學習選項，則該選項將不可用。）

「選用設定」區域

  • 觸測安全平面 - 選取此選項可將測頭移動至各個特徵測點之間的安全平面上。右側的編輯方塊可輸入平面距離。此平面不是測量程式安全平面。有關詳細資料，請參閱觸測安全平面。

  • 學習後測量 - 選取此選項可導致機器首先使用預設參數學習工件的位置，然後使用螢幕上設定的屬性立即重新測量特徵。用於測試所有設定的參數，確保實現更精確、更可靠的首件檢查。

  • 使用螢幕上的值學習 - 用於輸入特徵的標稱值，並在此位置測量軟體。（選取此選項可啟用「屬性區域」中所述的其他屬性並停用「動作參數區域」中所述的搜尋距離選項。）

「參數」區域

  • XYZ 標稱值 - 定義圓錐中心的標稱位置。

  • XYZ 測量值 - 顯示圓錐的測量位置。

  • 半角 - 定義在圓錐側產生圓錐中央線的角度。

  • Z 角 - 定義圓錐的第一個向量角。它是與工作面有關的圓錐的中央線方向。有效範圍為 -90 度至 +90 度。

  • X 角 - 定義圓錐的第二個向量角。這是與測量的主軸有關的圓錐的中央線方向。在 XY 工作面上主軸為 X，在 YZ 工作面上為 Y，在 ZX 工作面上為 Z。有效範圍為 0（零）度至 -360 度。

備註：向量角 1 和向量角 2 是相關的 - (90.0, 20.0) 的有效值可定義為 (90.0, 0.0)。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可移除上一次學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。 | 插入移動點 此螢幕按鍵可讀取測頭的目前位置，並作為安全移動將它插入測量常式。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。

學習處理序

  1. 將測頭置於底層表面附近，按讀取位置 螢幕按鍵 [image] 。底層是離頂部最遠的一層。

  2. 將測頭置於頂層表面附近，按讀取位置 螢幕按鍵 [image] 。

  3. 將測頭置於中心上方，按讀取位置螢幕按鍵 [image] 。

  4. 將測頭定位為自動測量，按一下學習和建立命令螢幕按鍵 [image] 。NC Gage 將以下述相同的方式自動進行觸測。

    外圓錐路徑：A-C) 分疊位置 1-8) 自動測量點位置。紅線顯示底層路徑。紅線顯示底層路徑。使用相似路線測量頂層。

  5. 一旦測量出特徵，就要更新測量值。按 確認並將目前命令新增至末端螢幕按鍵 [image] 。特徵命令被新增至測量程式。

以下是特定的特徵路徑和 NC Gage 內置邏輯：

學習外錐特徵路徑

  • 測頭的讀取位置靠近最低層圓錐側，這就定義了圓錐 XY 中心和執行時間第一層的高度。

  • 測頭的讀取位置靠近最高層的圓錐側，Z 值將為最後一層的測量高度。

  • 測頭的讀取位置位於圓錐中心的上方，XY 值定義中心，Z 為安全高度。

  • 移至安全高度。

  • 預測點半徑 = 第一和第三個位置點間預計的 2D 距離。可用它來學習兩層。

  • 以 +X、-X、+Y 和 –Y 方向的點來測量最低層，測頭移至每個測量間的安全高度。

  • 返回至安全高度。

  • 以 +X、-X、+Y 和 –Y 方向的點來測量最高層，測頭移至每個測量間的安全高度。

  • 返回至安全高度。

執行外錐特徵路徑

  • 圓錐幾何可決定每個測量點的預碰和目標位置。

  • 如果當前位置低於安全平面，則將其向上移動至安全平面。

  • 移至第一個預測點上方的位置。

  • 下降至測量最低層。

  • 測量最低層開始於終止角。如果需要避免碰撞，可使用每點間的迴避移動。

  • 使用交替方向測量其餘層。

  • 如果啟用本地安全平面，則移動每個點間的本地安全平面以到達下一預測點。

  • 測量過上一點後，測頭向上移動至安全平面高度。


球體

Home > 使用 PC-DMIS NC Gage > 建立特徵命令 > 球體

測量球體

要建立一個球體命令：

  1. 按主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁 螢幕按鍵 [image] 以轉至螢幕按鍵的第二頁。

  3. 按球體 螢幕按鍵 [image] 以顯示測量球體 螢幕：

  4. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將顯示測頭測量和變更位置的圖形視圖。

「屬性」區域

  • 點數 - 定義要測量的總點數。

  • 下層角 - 定義球體的下層角，赤道為 0 度。

  • 上層角 - 定義球體的上層角，北極（頂部）為 90 度。

備註：上層角與下層角之間的差異須至少為 20 度。設定這一限制是因為弧度小於 20 度時可能會導致不正確的測量結果。

「動作參數」區域

  • 逼近距離 - 定義遠離標稱曲面的距離，測頭在測量過程中將使用此標稱曲面開始搜尋曲面。

  • 搜尋距離 - 定義了在尋找及學習特徵時的搜尋距離。（若選取了「選用設定區域」中所述的使用螢幕上的值學習選項，則該選項將不可用。）

「選用設定」區域

  • 觸測安全平面 - 選取此選項可將測頭移動至各個特徵測點之間的安全平面上。右側的編輯方塊可輸入平面距離。此平面不是測量程式安全平面。有關詳細資料，請參閱觸測安全平面。

  • 學習後測量 - 選取此選項可導致機器首先使用預設參數學習工件的位置，然後使用螢幕上設定的屬性立即重新測量特徵。用於測試所有設定的參數，確保實現更精確、更可靠的首件檢查。

  • 使用螢幕上的值學習 - 用於輸入特徵的標稱值，並在此位置測量軟體。（選取此選項可停用「動作參數區域」中所述的搜尋距離選項。）

「參數」區域

  • XYZ 標稱值 - 定義球體中心的標稱位置。

  • XYZ 測量值 - 顯示球體中心的測量位置。

  • 標稱直徑 - 定義球體的標稱直徑。

  • 測量直徑 - 顯示球體的測量直徑。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可移除上一次學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。 | 插入移動點 此螢幕按鍵可讀取測頭的目前位置，並作為安全移動將它插入測量常式。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。

學習處理序

  1. 將測頭置於球體中心頂部之上，按一下讀取位置螢幕按鍵 [image] 。

  2. 按一下學習並建立一個命令螢幕按鍵 [image] 。NC Gage將自動按照下列所描述之形式採集測點。

    球體路徑：A) 點動位置 1-4) 動測量的點位置。

  3. 一旦測量出特徵，就要更新測量值。按確認並將目前命令新增至末端功能鍵 [image] 。特徵命令被新增至測量程式。

以下是指定的特徵路徑和 NC Gage內置邏輯：

學習球體特徵路徑

  • 測頭的讀取位置應位於球體頂部之上。

  • 使用搜尋距離直接向下測量點。

  • 撤回至原始讀取位置並以 +X 方向移動 2* 測頭半徑。

  • 使用搜尋距離直接向下測量點。

  • 撤回至原始高度並以與 +X 軸呈 120 度的方向移動 2* 測頭半徑。

  • 使用搜尋距離直接向下測量點。

  • 撤回至原始高度並以與 +X 軸呈 240 度的方向移動 2* 測頭半徑。

  • 使用搜尋距離直接向下測量點。

  • 撤回至原始高度。

執行球體特徵路徑

  • 每一層的層數和點數均依據表格中所定義的測量點數確定。

  • 如果當前位置低於安全平面，則將其向上移動至安全平面。

  • 移至第一個預測點之上的位置處。

  • 下降至最低層並對該層進行測量，若需要，可在一層中的每個點之間新增迴避移動，以防止發生碰撞。

  • 使用交替方向測量其餘層。

  • 測量球體頂部的點（若頂層角度為 90）。

  • 移至安全平面高度。


構造點

  1. 按一下主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁螢幕按鍵 [image] 直至顯示構造點螢幕按鍵。

  3. 按構造點 螢幕按鍵 [image] ，顯示構造點螢幕：

此螢幕可讓您執行 下列之一來建立點特徵：

  • 透過選取交點選項，在選取的兩個線式特徵交點處構造點。

  • 透過選取投影選項，將點式特徵投影至線式特徵來構造點。

  • 透過選取中點選項，在選取的兩個點式特徵間構造中間點。

若要構造點特徵

  1. 從選項區域中為需要作出的構造類型選取相應的選項按鈕。

  2. 從線選取清單中選取兩個特徵。選取清單中將僅顯示有效特徵類型。螢幕左上角的圖形將進行更新以便提供有關如何建置功能的視覺提示。標稱資料和測量資料會根據特徵輸入進行更新。

  3. 按確認螢幕按鍵 [image] 將命令新增至測量程式。

有效點式特徵

  • 已構造的圓

  • 已構造的點

  • 測量圓內徑

  • 測量圓突起部

  • 測量內棱角

  • 測量外棱角

  • 測量點

  • 測量球體

有效線式特徵

  • 已構造的直線

  • 測量圓錐（內部）

  • 測量圓錐（外部）

  • 測量圓柱內徑

  • 測量圓柱突起部

  • 測量直線

  • 測量平面

  • 測量槽

  • 測量網路

備註：標稱值和實際值 Z 會自動被指定至建構的特徵。標稱值和實際值 Z 會取自建構的第一個元件特徵。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。 | 確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。
在當前位置後面插入命令 此螢幕按鍵可新增命令至測量常式，但把命令置於測量常式樹狀結構中所選命令之後，而不是測量常式末尾。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。


構造線

  1. 按一下主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁螢幕按鍵 [image] 直至顯示構造線螢幕按鍵。

  3. 按構造線 螢幕按鍵 [image] ，顯示構造線 螢幕：

「參數」區域

  • XYZ 標稱值 - 定義起點的標稱位置。

  • XYZ 測量值 - 顯示起點的測量位置。

  • X 角 - 定義此範例中平面 - X 的第一個向量角。此為平面的曲面法線方向，與工作面關聯。有效範圍為 -90 度至 +90 度。

  • Z 角 - 定義此範例中平面 - Z 的第二個向量角。此為平面的曲面法線方向，與測量所在的主軸關聯。在 XY 工作面上主軸為 X，在 YZ 工作面上為 Y，在 ZX 工作面上為 Z。有效範圍為 0（零）度至 -360 度。

備註：向量角（此範例中為 X 角向量和 Z 角向量）是相關的 — 無效值 (90.0, 20.0) 將被定義為 (90.0, 0.0)。

若要構造線路特徵

  1. 選取兩個點式特徵。特徵清單中將僅顯示有效特徵類型。螢幕左上角的圖形將進行更新以便提供有關如何建置功能的視覺提示。標稱資料和測量資料會根據特徵輸入進行更新。

  2. 按確認螢幕按鍵將命令新增至測量程式。

有效點式特徵

  • 已構造的圓

  • 已構造的點

  • 測量圓內徑

  • 測量圓突起部

  • 測量內棱角

  • 測量外棱角

  • 測量點

  • 測量球體

備註：標稱值和實際值 Z 會自動被指定至建構的特徵。標稱值和實際值 Z 會取自建構的第一個元件特徵。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。 | 確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。
在當前位置後面插入命令 此螢幕按鍵可新增命令至測量常式，但把命令置於測量常式樹狀結構中所選命令之後，而不是測量常式末尾。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。


構造圓

  1. 按一下主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁螢幕按鍵 [image] 直至顯示構造圓螢幕按鍵。

  3. 按構造圓 螢幕按鍵 [image] ，顯示構造圓螢幕：

構造圓選項位於特徵功能表的第三個螢幕，可讓您在圓週交集三點式特徵的地方建立圓。

若要構造圓特徵

  1. 從點特徵清單中選取第一個特徵並使用在構造中。

  2. 按向左移動項目雙箭頭螢幕按鍵 [image] ，將該特徵新增至選取的特徵清單。

  3. 在至少兩個其他點類型特徵（至少需選取三個點類型特徵）上重複此步驟。若要從選取的特徵清單中移除特徵，請選取要移除的特徵，並使用向右移動項目雙箭頭螢幕按鍵 [image] 。選取螢幕中祇顯示有效特徵類型。螢幕左上角的圖形將進行更新以便提供有關如何建置功能的視覺提示。標稱資料和測量資料會根據特徵輸入進行更新。

  4. 按確認螢幕按鍵將命令新增至測量程式。

有效點式特徵

  • 已構造的圓

  • 已構造的點

  • 測量圓內徑

  • 測量圓突起部

  • 測量內棱角

  • 測量外棱角

  • 測量點

  • 測量球體

備註：標稱值和實際值 Z 會自動被指定至建構的特徵。標稱值和實際值 Z 會取自建構的第一個元件特徵。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
在當前位置後面插入命令 此螢幕按鍵可新增命令至測量常式，但把命令置於測量常式樹狀結構中所選命令之後，而不是測量常式末尾。 | 確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。


夾角

  1. 按一下主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁螢幕按鍵 [image] 直至您到達螢幕按鍵的第三頁。

  3. 按夾角螢幕按鍵 [image] ，顯示夾角螢幕：

特徵功能表第三頁上的夾角選項可讓您報告两条线式特徵的夾角。

若要報告角度

  1. 從第一條線和第二條線清單中選取兩條線式特徵。NC Gage 會根據特徵方向計算角度。如果是補角﹐請標記補角 核取方塊。選取螢幕中祇顯示有效特徵類型。螢幕左上角的圖形將進行更新以便提供有關如何建置功能的視覺提示。標稱資料和測量資料會根據所做的特徵輸入選取進行更新。

  2. 按確認螢幕按鍵 [image] 將命令新增至測量程式。

有效線式和平面特徵

  • 網路

  • 槽

  • 直線

  • 構造線

  • 圓錐

  • 圓柱

  • 平面

角度之平行度和垂直度報告

您可使用夾角、平行度或垂直度選項報告兩個線式特徵之間的角度、平行度或垂直度。平行度和垂直度尺寸僅報告正偏差。夾角可為正值，亦可為負值，其中正值為 X 至 Y、Y 至 Z 和 Z 至 X 以及從基準（螢幕第一頁上的特徵）至參考特徵（螢幕第二頁上選取的特徵）。

可用的選項如下：

  • 如果標稱角度值為 0（零），則平行度選項被啟用。

  • 如果標稱角度值為 90，則垂直度選項被啟用。

  • 如果標稱角度值不是 0 或 90，則夾角選項被啟用。

要報告平行度，請執行以下操作：

  1. 選取夾角 螢幕上的平行度選項，顯示平行度螢幕：

  2. 對於評估長度，輸入要評估之長度。預設評估長度為零。如果方塊為空白，將出現紅色星號 (*) ，指示這是必填欄位；還將出現警告訊息。

  3. 返回夾角螢幕，按公差螢幕按鍵 [image] ，顯示公差 螢幕：

要報告垂直度，請執行以下操作：

  1. 選取夾角 螢幕上的垂直度選項，顯示垂直度螢幕：

  2. 對於評估長度，輸入要評估之長度。預設評估長度為零。如果方塊為空白，將出現紅色星號 (*) ，指示這是必填欄位；還將出現警告訊息。

  3. 返回夾角螢幕，按公差螢幕按鍵 [image] ，顯示公差 螢幕：

以下是「夾角」特徵之樹狀檢視範例：

以下是平行度之樹狀檢視範例：

以下是垂直度之樹狀檢視範例：

有關夾角、平行度和垂直度之測量程式螢幕之範例，請參閱「檢視和執行測量程式」。有關報告螢幕之範例，請參閱「使用報告」。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 此螢幕按鍵可將檢視器返回上一級至上一螢幕。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 | 切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。
刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。 | 公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 在當前位置後面插入命令 此螢幕按鍵可新增命令至測量常式，但把命令置於測量常式樹狀結構中所選命令之後，而不是測量常式末尾。
取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。 此螢幕按鍵可將螢幕從 NC Gage 切換為控制項之主視窗。


尺寸距離

  1. 按主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁螢幕按鍵 [image] 直至您到達螢幕按鍵的第三頁。

  3. 按距離 螢幕按鍵 [image] ，顯示距離 螢幕：

要報告距離

特徵功能表第三頁上的距離選項可讓您報告两個點式特徵間的距離。距離可在單軸方向上（與一軸平行）或在雙軸方向上。

  1. 從選項區域中為要計算的距離選取相應的選項。

  2. 從每個顯示的清單中選取項目。清單區域將僅顯示有效的測量和構造項目。螢幕左上角的圖形將進行更新以便提供有關如何建置功能的視覺提示。標稱資料和測量資料會根據特徵輸入進行更新。選取項目後，按公差螢幕按鍵 [image] 檢視與構造距離有關的公差值。

  3. 按確認螢幕按鍵 [image] 將命令新增至測量程式。

有效點式特徵

  • 測量點

  • 測量圓

  • 測量圓突起部

  • 測量內棱角

  • 測量外棱角

  • 構造點

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 | 切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。
刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。 | 公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。
取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。 | 確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。
返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。 |


同心度

  1. 按一下主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁螢幕按鍵 [image] 直至您到達螢幕按鍵的第三頁。

  3. 按同心度螢幕按鍵 [image] ，顯示同心度螢幕：

要報告同心度

位於特徵功能表第三頁的同心度選項可用於計算一個特徵至另一個特徵的同心度。此特徵僅對同一工作平面中的特徵有效。

  1. 從每個顯示的清單中選取項目。兩個清單均顯示圓特徵。

如果兩個選取的特徵不在同一工作平面中，將出現以下警告訊息：「選取的特徵不在同一工作平面中。」

  2. 選取項目後，按公差螢幕按鍵 [image] 檢視與同心度有關的公差值。

  3. 按確認螢幕按鍵 [image] 將命令新增至測量程式。特徵被新增至樹狀檢視。例如：

有效類型特徵

  • 測量圓

  • 測量圓突起部

  • 已構造的圓

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 | 切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。
刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。 | 公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。
取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。 | 確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。
返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。 |


按鍵

要建立按鍵命令：

  1. 按主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁螢幕按鍵 [image] 直至您到達螢幕按鍵的第三頁。

  3. 按按鍵螢幕按鍵 [image] ，顯示測量按鍵螢幕：

  4. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將顯示測頭測量和變更位置的圖形視圖。

「屬性」區域

  • 起始位置 X、起始位置 Y 和起始位置 Z - 定義起始點的範圍。

  • 寬度 - 定義按鍵槽寬度。選取使用螢幕上的值學習核取方塊後，才可看見寬度。

  • 始終搜尋 - 啟用搜尋處理序。如果選取此核取方塊，NC Gage 將在測量處理序開始時插入搜尋處理序。測頭在軸曲面上執行數次預碰測量，以確定標稱按鍵槽角度位置。

「動作參數」區域

  • 預碰角 - 定義遠離標稱曲面的角度，測頭在測量過程中將使用此標稱曲面開始搜尋曲面。

「選用設定」區域

  • 學習後測量 - 選取此選項可導致機器首先使用預設參數學習工件的位置，然後使用螢幕上設定的屬性立即重新測量特徵。它用於測試所有設定的參數，確保實現更精確、更可靠的首件檢查。

  • 使用螢幕上的值學習 - 使用此選項可輸入特徵的標稱值，並在此位置測量軟體。

「參數」區域

  • 角度 - 定義平臺中心線的向量角。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可移除上一次學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。 此螢幕按鍵可將螢幕從 NC Gage 切換為控制項之主視窗。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。 | 插入移動點 此螢幕按鍵可讀取測頭的目前位置，並作為安全移動將它插入測量常式。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。

學習處理序

  1. 將測頭置於檢查高度處的按鍵旁邊，按一下讀取位置螢幕按鍵 [image] 。

  2. 請參閱下圖。

    • 測頭移至按鍵頂部。

    • 旋轉軸旋轉至預碰角度位置。

    • 測頭移至測量高度。

    • 旋轉軸以順時針方向旋轉，直至測頭被觸發。旋轉軸停止旋轉。回退至預碰角度位置。

    • 測頭移至按鍵頂部。

    • 旋轉軸旋轉至預碰角度位置。

    • 測頭移至測量高度。

    • 然後，旋轉軸以逆時針方向旋轉，直至測頭被觸發。旋轉軸停止旋轉。回退至預碰角度位置。

    • 測頭移至按鍵頂部。

    • 旋轉軸旋轉回原始位置。

    • 按鍵的中間角度透過兩個觸發的旋轉軸位置進行計算。

執行處理序

請參閱下圖。

  1. 測頭移至按鍵頂部。

  2. 在主軸中測頭朝向 0 度。

  3. 旋轉軸旋轉至預碰角度位置。

  4. 測頭移至測量高度。

  5. 旋轉軸以順時針方向旋轉，直至測頭被觸發。旋轉軸停止旋轉。回退至預碰角度位置。

  6. 測頭移至按鍵頂部。

  7. 在主軸中測頭朝向 180 度。

  8. 旋轉軸旋轉至預碰角度位置。

  9. 測頭移至測量高度。

  10. 旋轉軸以逆時針方向旋轉，直至測頭被觸發。旋轉軸停止旋轉。回退至預碰角度位置。

  11. 測頭移至按鍵頂部。

  12. 在主軸中測頭朝向 0 度。

  13. 旋轉軸旋轉回原始位置。


鍵槽

要建立鍵槽命令：

  1. 按主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁螢幕按鍵 [image] 直至您到達螢幕按鍵的第二頁。

  3. 按鍵槽螢幕按鍵 [image] ，顯示測量鍵槽螢幕：

  4. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將顯示測頭測量和變更位置的圖形視圖。

「屬性」區域

  • 起始位置 X、起始位置 Y 和起始位置 Z - 定義起始點的範圍。

  • 寬度 - 定義按鍵槽寬度。選取使用螢幕上的值學習核取方塊後，才可看見寬度。

  • 始終搜尋 - 啟用搜尋處理序。如果選取此核取方塊，NC Gage 將在測量處理序開始時插入搜尋處理序。測頭在軸曲面上執行數次預碰測量，以確定標稱按鍵槽角度位置。

「動作參數」區域

  • 預碰角 - 定義遠離標稱曲面的角度，測頭在測量過程中將使用此標稱曲面開始搜尋曲面。

  • 搜尋角度範圍 - 定義尋找和學習特徵時的搜尋角度範圍。若選取了使用螢幕上的值學習核取方塊，此選項將不可用。

「選用設定」區域

  • 學習後測量 - 選取此選項可導致機器首先使用預設參數學習工件的位置，然後使用螢幕上設定的屬性立即重新測量特徵。它用於測試所有設定的參數，確保實現更精確、更可靠的首件檢查。

  • 使用螢幕上的值學習 - 使用此選項可輸入特徵的標稱值，並在此位置測量軟體。選取此選項將停用搜尋角度距離選項。

「參數」區域

  • 角度 - 定義鍵槽中心線的向量角。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可移除上一次學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。 此螢幕按鍵可將螢幕從 NC Gage 切換為控制項之主視窗。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。 | 插入移動點 此螢幕按鍵可讀取測頭的目前位置，並作為安全移動將它插入測量常式。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。

學習處理序

  1. 將測頭置於中心線處按鍵槽內部，並按一下讀取位置螢幕按鍵 [image] 。

  2. 請參閱下圖。

    • 旋轉軸以順時針方向旋轉，直至測頭被觸發。旋轉軸停止旋轉。

    • 然後，旋轉軸以逆時針方向旋轉，直至測頭被觸發。旋轉軸停止旋轉。

    • 旋轉軸旋轉回原始位置。

    • 鍵槽的中間角度透過兩個觸發的旋轉軸位置進行計算。

執行處理序

請參閱下圖。

  1. 測頭移至鍵槽內的起始位置。

  2. 在主軸中測頭朝向 0 度。

  3. 旋轉軸開始以順時針方向旋轉至預碰角度位置。

  4. 旋轉軸停止並開始緩慢移動，以測量鍵槽的一側。

  5. 測頭被觸發，旋轉軸開始向相反的方向旋轉。

  6. 在主軸中測頭朝向 180 度。

  7. 旋轉軸以逆時針方向旋轉至預碰角度位置。

  8. 旋轉軸停止並開始緩慢移動，以測量鍵槽的另一側。

  9. 旋轉軸旋轉回原始位置。

  10. 在主軸中測頭朝向 0 度。


平臺

要建立平臺命令：

  1. 按主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁螢幕按鍵 [image] 直至您到達螢幕按鍵的第三頁。

  3. 按平臺螢幕按鍵 [image] ，顯示測量平臺螢幕：

  4. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將顯示測頭測量和變更位置的圖形視圖。

「屬性」區域

  • 起始位置 X、起始位置 Y 和起始位置 Z - 定義起始點的範圍。

  • 寬度 - 定義按鍵槽寬度。選取使用螢幕上的值學習核取方塊後，才可看見寬度。

  • 始終搜尋 - 啟用搜尋處理序。如果選取此核取方塊，NC Gage 將在測量處理序開始時插入搜尋處理序。測頭在軸曲面上執行數次預碰測量，以確定標稱按鍵槽角度位置。

「動作參數」區域

  • 預碰角 - 定義遠離標稱曲面的角度，測頭在測量過程中將使用此標稱曲面開始搜尋曲面。

  • 搜尋角度範圍 - 定義尋找和學習特徵時的搜尋角度範圍。若選取了使用螢幕上的值學習核取方塊，此選項將不可用。

「選用設定」區域

  • 學習後測量 - 選取此選項可導致機器首先使用預設參數學習工件的位置，然後使用螢幕上設定的屬性立即重新測量特徵。它用於測試所有設定的參數，確保實現更精確、更可靠的首件檢查。

  • 使用螢幕上的值學習 - 使用此選項可輸入特徵的標稱值，並在此位置測量軟體。選取此選項將停用搜尋角度距離選項。

「參數」區域

  • 角度 - 定義平臺中心線的向量角。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可移除上一次學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。 此螢幕按鍵可將螢幕從 NC Gage 切換為控制項之主視窗。
公差設定 此螢幕按鍵可讓您設定或修改特徵標稱和特徵命令使用的公差值。以上就是報告螢幕上將要顯示的概觀。 | 插入移動點 此螢幕按鍵可讀取測頭的目前位置，並作為安全移動將它插入測量常式。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。

學習處理序

  1. 將測頭置於中心線的平臺頂部，按讀取位置螢幕按鍵 [image] 。

  2. 請參閱下圖。

    • 旋轉軸以順時針方向旋轉，直至測頭被觸發。旋轉軸停止旋轉。

    • 然後，旋轉軸以逆時針方向旋轉，直至測頭被觸發。旋轉軸停止旋轉。

    • 旋轉軸旋轉回原始位置。

    • 平臺的中間角度透過兩個觸發的旋轉軸位置進行計算。

執行處理序

請參閱下圖。

  1. 測頭移至平臺內的起始位置。

  2. 在主軸中測頭朝向 0 度。

  3. 旋轉軸開始以順時針方向旋轉至預碰角度位置。

  4. 旋轉軸停止並開始緩慢移動，以測量平臺的一側。

  5. 測頭被觸發，旋轉軸開始向相反的方向旋轉。

  6. 在主軸中測頭朝向 180 度。

  7. 旋轉軸以逆時針方向旋轉至預碰角度位置。

  8. 旋轉軸停止並開始緩慢移動，以測量平臺的另一側。

  9. 旋轉軸旋轉回原始位置。

  10. 在主軸中測頭朝向 0 度。


設定其他特徵參數

使用特徵命令時，您可從「特徵」視窗中修改其他參數。「特徵」視窗中的工具列上有以下螢幕按鍵：

  • 設定工作偏移

  • 更新工作偏移

  • 選取工作偏移

  • 寫變數

  • 更新工具長度 - 測量程式控制

  • 設定坐標旋轉

  • 公差

  • 觸測安全平面


選取工作偏移

在測量程式的開頭選取工作偏移可重複使用測量程式；此操作必須在測量特徵之前完成。

  1. 按主螢幕上的選取工作偏移螢幕按鍵 [image] ，顯示選取工作偏移螢幕。當 NC Gage 在定義特徵框架（若系統的旋轉臺已設定）或定義安全平面之前啟動時，可顯示此螢幕。

  2. 按選取要更新的工作偏移螢幕按鍵 [image] ，檢閱螢幕的參數區域中所顯示的每個偏移清單項目的偏移值，直至顯示所需的偏移設定。

  3. 按一下執行螢幕按鍵 [image] 以啟用機器上的工作偏移。

  4. 按確認螢幕按鍵 [image] 。NC Gage 將選取的工作偏移插入測量程式。按返回螢幕按鍵 [image] ，返回上一螢幕而不儲存。

參數定義：

  • 工作偏移 – 指定所選取的工作偏移，顯示參數中的偏移值並新增至測量程式中。

  • X Y Z – 這些唯讀值可用來顯示工作偏移值。這些值可從控制器中讀取，並在已從下拉式方塊中選取位移時顯示。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
選取要更新的工作偏移 此螢幕按鍵可從待更新的偏移清單中選取已命名的工作偏移。再次按下此鍵將選取清單中的下一個工作偏移。 | 切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。
確認並將當前命令新增至末端 此螢幕按鍵可用來確認目前選取的工作偏移將在測量程式中可用。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。


寫變數

從 NC Gage 2.0 開始提供「寫變數」命令特徵。您可使用此特徵將測量資料寫入 NC 控制項上的巨集變數。此外，「寫變數」特徵可將超出公差的特徵數和特徵總數寫入巨集變數。NC Gage 僅寫入這些值；不會執行其他任何動作。

  1. 按主螢幕導覽列上的測量 螢幕按鍵 [image] 。

  2. 按下一頁螢幕按鍵 [image] 直至您到達螢幕按鍵的第三頁。

  3. 按寫變數螢幕按鍵 [image] ，顯示寫變數螢幕：

「特徵」區域

已檢查數量 - 已測量和/或已構造的特徵數量。

超出規格的數量 - 超出公差的特徵數量。

「特徵位置」區域

尺寸 - 符合特徵公差的軸線集。

值 - 選取尺寸後，將出現此欄位。無法對其進行編輯。

巨集變數 - 此欄位是一個整數，可定義有效的巨集變數數量。有效的巨集變數範圍取決於機器類型和已購買的選項。

使用下列步驟可寫入巨集變數：

  1. 從特徵清單中選取已測量的特徵。

  2. 然後，應將此特徵的有效測量尺寸清單填入尺寸方塊中。如果已為特徵選取了已檢查數量或超出規格的數量，則方塊為空白且已停用。從特徵位置區域的清單中選取尺寸。將顯示目前值以供參考。

  3. 輸入要在特徵位置區域的巨集變數方塊中使用的巨集變數數量。NC Gage 將對輸入的巨集數量進行測試，確保其不與 NC Gage 處理衝突。

  4. 按一下確認螢幕按鍵 [image] ，完成寫變數程序。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 在當前位置後面插入命令 此螢幕按鍵可新增命令至測量常式，但把命令置於測量常式樹狀結構中所選命令之後，而不是測量常式末尾。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。


更新工具長度 - 測量程式控制

測量程式控制的更新工具偏移螢幕定義在互動式工作階段（將是測量程式控制的一部份）中的工具偏移。

  1. 測量特徵之後，選取主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁螢幕按鍵 [image] 直至您到達螢幕按鍵的第三頁。

  3. 選取更新工具偏移 螢幕按鍵 [image] ，顯示更新工具偏移 螢幕：

在繼續更新工具偏移之前，確保已對 Fanuc 控制器設定了適當的 A、B 或 C 工具偏移喜好設定。

備註：「更新工具偏移」功能取決於工件特徵，其中目標值已被您輸入的工具削減。在此情況下，目標值與測量值之間的差值為工具偏移磨損誤差。關鍵在於理解這一點，因為更新將會永久性的變更工具偏移值。

要啟用測量程式以更新工具偏移：

  1. 導覽至測量螢幕的第三頁。

  2. 按一下更新工具偏移螢幕按鍵 [image] ，顯示更新工具偏移螢幕。

  3. 從特徵清單中選取目標特徵。選取後，標稱值會顯示在特徵位置區域中。如果已測量特徵，測量值和此特徵的偏差都會顯示在螢幕上。工具偏移會根據偏差重新整理。能使用的特徵為測量 Z 值的特徵，通常是點或平面。從清單中選取正確的特徵。

  4. 按選取直徑模式螢幕按鍵 [image] （如有必要），進入「直徑模式」。您亦可在工具偏移區域中標記直徑核取方塊，鍵入「直徑模式」。當在此模式中時，工具補償區域中的所有值都基於工具直徑。當不在「直徑模式」中時，上述值基於工具半徑。

  5. 在工具偏移區域中輸入工具的工具號，該工具可用於削減計算中要使用的特徵。輸入有效的工具號後，工具偏移區域中將顯示目前整體工具偏移（幾何 + 磨損）。螢幕將使用以下內容進行更新：

    • 將從 NC 機器中擷取工具偏移。

    • 計算並顯示目前偏移和新偏移。

    • 顯示這兩個數字之間的差值。此差值應與特徵位置的偏差相同。這是因為 NC Gage 計算的工具偏移可能已在削減工件時削減了一個已設定的「絕佳」特徵。

    備註：如果 NC Gage 判定您輸入的工具數值與測量程式中使用中的測頭數相同，則 NC Gage 會顯示一條警告。實際上，這樣做是要求系統更新不允許的測頭長度，因為工具號與使用中的測頭數值不能相同。校正後繼續操作。

  6. 按一下確認螢幕按鍵 [image] 儲存新值並完成將被寫入測量程式中的工具更新。更新工作將在下次執行測量程式時完成。按返回螢幕按鍵 [image] ，返回上一螢幕。

備註：目前識別的工具磨損將由 NC Gage 計算得出的值（作為目標位置與測量位置之間的差異）修改。工具磨損將於每次選取確認螢幕按鍵 [image] 時由此差異調整。因此，建議您在工具每一次切削表面時僅執行一次此常式。

「特徵」區域

顯示可選取的可用特徵清單。此清單中僅顯示有效的特徵類型。

「特徵位置」區域

標稱值 - 預設情況下，始終將 0（零）作為參考。

測量值 - 顯示指定坐標系的測量位置的 Z 值。

偏差 - 顯示所選特徵的法線方向上的偏差。

「工具偏移」區域

目前值 - 顯示目前工具偏移值。

新值 - 顯示新的工具偏移值。

差值 - 顯示目前值與新的工具偏移值之間的差值。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
刪除建立的上一個命令 此螢幕按鍵可從測量程式中刪除上次建立的命令。 | 選取直徑模式 按一下以將 NC Gage 置於「直徑模式」中。當在「直徑模式」中時，螢幕上的「直徑模式」核取方塊將被標記。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。
返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。 |


設定坐標旋轉

透過測量所需的特徵然後選取要在坐標系統旋轉中使用的特徵，NC Gage 可提供相關功能，以定義 CNC 機器上所用的坐標系統的 2D 旋轉調整。要在沒有此功能的情況下執行同樣的操作，您將需要手動鍵入 G68 字碼的適當旋轉中心、軸向量和角度。

測量特徵完成之後，可使用設定坐標旋轉螢幕選取旋轉計算中所用的特徵。NC Gage 可更新 G68 程式碼或 G68.2 程式碼以使用新旋轉的坐標系。

備註：僅可能存在一個旋轉巨集。NC Gage中的後續定義將覆寫現有的參數。

  1. 按主螢幕上的測量螢幕按鍵 [image] 。

  2. 按下一頁螢幕按鍵 [image] 直至螢幕上顯示設定坐標系旋轉螢幕按鍵。

  3. 按設定坐標系統旋轉 螢幕按鍵 [image] ，顯示設定坐標旋轉 螢幕：

「參數」區域

備註：可採用[坐標旋轉]的方式旋轉 NC 機器上的坐標系統。當正在使用[坐標旋轉]時無法執行測量，因此在執行命令時無法啟動[坐標旋轉]特徵。此資訊可被計入巨集變數中，還可呼叫巨集程式，以使用此資訊執行[坐標旋轉]。

  • a1、a2、R：這些清單顯示測量程式中可用於定義軸（a1=軸 1，a2=軸 2）平移（「軸」清單）和旋轉（R 清單）的特徵。這些軸透過使用選取測量面螢幕按鍵（見下文）所做的選取進行定義。

  • a1、a2、R 工件：這些唯讀方塊顯示從「軸」和 R 清單中目前選取的特徵的軸（a1=軸 1，a2=軸 2）和旋轉 (R) 值。這些值已被轉換至工件坐標系。這些軸透過使用選取測量面螢幕按鍵（見下文）所做的選取進行定義。

  • a1、a2、R 機器：這些唯讀方塊顯示從「軸」和 R 清單中目前選取的特徵的軸（a1=軸 1，a2=軸 2）和旋轉 (R) 值。這些值已被轉換至機器坐標系。這些軸透過使用選取測量面螢幕按鍵（見下文）所做的選取進行定義。

  • a1、a2、R 目標：這些方塊可定義坐標系旋轉的目標軸（a1=軸 1，a2=軸 2）旋轉 (R) 值。您可使用這些方塊定義精確的坐標系位置以及要使用的旋轉角度。這些軸透過使用選取測量面螢幕按鍵（見下文）所做的選取進行定義。機器坐標值可用於設定坐標旋轉命令。

備註：對於旋轉角，已定義線的所選特徵（如線、平面、槽、凸臺、圓柱內徑/突起部及圓錐內徑/突起部）將在相應欄位中自動更新。圓柱、圓錐和平面特徵的標稱軸可建立 2D 角度。所選線特徵類型的向量角亦可用於定義旋轉角度。

  • 註解：使用此方塊可鍵入對目前系統旋轉的註解。

選取測量面概覽

將坐標系旋轉命令插入測量程式後，必須對旋轉坐標系的工作平面、軸值和旋轉角度進行定義。要定義工作平面，可使用選取測量面按鈕選取下列測量平面選項：

XY 平面

選取 XY 工作平面後，NC Gage 將顯示 X、Y 和 R 標籤以及參數區域中的相應詳細資料。

YZ 平面

選取 YZ 工作平面後，NC Gage 將顯示 Y、Z 和 R 標籤以及參數區域中的相應詳細資料。

XZ 平面

選取 XZ 工作平面後，NC Gage 將顯示 X、Z 和 R 標籤以及參數區域中的相應詳細資料。

設定坐標系旋轉

  1. 透過選取 X 清單和 Y 清單（包含每條軸的有效測量結果）中的特徵指定 X 和 Y 方向的平移。這些是包含基礎中心點值的的點特徵或其他特徵，例如圓形（內徑），這些特徵可定義新坐標系統中的原點。

  2. 從 R 清單（在 XY 平面中包含有效的方向）選取特徵，以指定旋轉。這些是有方向的特徵（例如直線）。

  3. 對於每個特徵，可在 XZY 目標方塊中定義軸或角的預期值。

  4. 按「確認」螢幕按鍵 [image] 將坐標系旋轉新增至 NC Gage 測量程式中。即使已將坐標系旋轉圖示新增至測量程式中，坐標系統旋轉也不會對 NC Gage 測量程式產生影響。

NC Gage 可計算實際測量結果與預期值之間的平移和旋轉差異。X、Y 和旋轉然後被寫入至坐標系統旋轉巨集副程式中所用的一組巨集變數中。當 NC Gage 在完成測量程式執行後關閉時，將會叫用此巨集副程式。

您可以再次呼叫巨集副程式，重新套用坐標系統變更。此副程式巨集編號與監視副程式巨集編號 + 2 相同。因此，如果監視程式編號為 7000，則坐標系變更包含為 7002。僅可能存在一個旋轉巨集。NC Gage 中的後續定義將覆寫現有的檔案。

備註：在套用坐標旋轉時無法執行 NC Gage。因此，無法直接設定坐標旋轉。但是會儲存 X、Y 和 R 參數，以便您在執行剪下作業前可叫用坐標旋轉巨集。

例如

假設 POINT2（如下顯示為 B） 是 LINE3（如下顯示為 C） 與 LINE4（如下顯示為 A）交叉所形成的建構點，並已選取 POINT2 作為新的原點，選取 LINE4 作為旋轉特徵，如下所示：

這表示 NC Gage將在 POINT2 附近（B 處）旋轉坐標系統並將旋轉至 LINE4（A 處）。坐標系統將採用 POINT2（B 處）作為其原點，新的 X 軸將與 A 處的 LINE4 相同。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
選取測量面 每次按下此螢幕按鍵後，此螢幕按鍵即可在 XY 平面、YZ 平面 和 XZ 平面的「測量平面」選項之間進行切換。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。


公差

您可以使用公差螢幕依據特徵要求編輯公差。設定公差之後，NC Gage 將對測量結果進行評估。

在測量特徵之後以及按一下確認螢幕按鍵 [image] 儲存已學習的命令之前，可按下位於任何特徵第二頁的公差螢幕按鍵 [image] 存取此螢幕。

您可以自訂公差螢幕上每個特徵的預設報告設定。編輯如下所述的內容。

  1. 選取要報告的軸。選取對應的核取方塊。

  2. 根據需要修改標稱值。

  3. 根據需要修改公差值。

  4. 要評估孔或突起部的位置，選取位置核取方塊。

    例如，如果特徵位於測量孔和測頭突起部功能的圓形公差區域內，則公差區域的大小由其直徑指定。要檢查特徵是否位於此公差區域內，選取位置核取方塊。

    對位置的評估始終有標稱值 0。

按確認螢幕按鍵 [image] 後，所有設定都會儲存在每個特徵的測量程式中。按返回螢幕按鍵 [image] ，結束此螢幕，而不儲存任何變更。

形狀公差

形狀公差包括平面度、直線度、圓度、球度和圓柱度。這些公差僅與單個特徵有關。

NC Gage 可評估不同特徵的形狀公差。特徵及其形狀公差為：

  • 直線：直線度

  • 內徑和突起部：圓度

  • 軸：球形和偏轉（僅在使用轉臺旋轉測量時才會報告偏轉）

  • 內圓柱和外圓柱：圓柱度

  • 球體：球度

  • 圓錐：圓錐形

  • 平面：平面度

要評估特徵的形狀公差，選取該公差的核取方塊。例如：

直線特徵的直線度核取方塊

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
確認儲存變更 此螢幕按鍵可儲存對標稱值或公差資訊所作的所有變更。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |


觸測安全平面

觸測安全平面核取方塊可定義測量過程中所需的本地安全平面。此選項存在於所有「特徵命令」螢幕及設定兩條軸（內棱角）和設定兩條軸（外棱角）螢幕。

備註：雖然點特徵擁有觸測安全平面選項，但作用不同，因為測量期間僅進行一次觸測。

選取後，輸入方塊將啟用，在該方塊中可輸入值，定義測頭移動位置，避免測量過程中出現堵塞。每次測量後，測頭測尖將被驅動至沿測頭方向的定義的觸測安全平面位置。當測頭位於觸測安全平面位置時，測頭將移至 XY 軸（在特徵坐標中）中的安全移動位置，然後進行移動以執行下一個測量觸測。

本地安全平面由特徵坐標系中的輸入高度進行定義。特徵坐標系的原點係特徵位置，Z 軸向量係特徵測量中的測頭方向（主軸測尖）。

使用圓突起部特徵和平面且顯示特徵坐標系的觸測安全平面範例

H - 觸測安全平面的輸入值


插入移動命令

NC Gage 可讓您將移動命令插入測量程式，幫您避免與工件進行測頭碰撞。移動命令被新增在特徵命令之間。新增移動命令前，必須校驗測頭（請參閱「校驗」）。

定義特徵框架後，選取主螢幕導覽列上的移動螢幕按鍵 [image] ，顯示以下選項：

命令如下：

  • 移動點

  • 安全平面


移動點

移動點命令提供 XYZ 坐標，測尖中心在執行時將移向此坐標。上述位置可用於移動測頭，清除障礙物。

要將移動點命令新增至測量程式：

  1. 按主螢幕導覽列上的移動螢幕按鍵 [image] 。

  2. 按移動點 螢幕按鍵 [image] 以顯示移動點螢幕：

  3. 根據螢幕指示操作插入命令。請注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將向您顯示測頭測量和變更的位置。

參數定義：

  • 目標位置（XYZ 標稱值）- 定義點的標稱位置。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回上一步 此螢幕按鍵可移除上一次學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
選取測量面 此螢幕按鍵可決定觸測方向和移動到特徵的安全位置。您可按多次選取不同的測量面。可用的測量面有：X+、 X-、Y+、Y-、Z+ 和 Z-。 | 刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量程式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量程式螢幕刪除命令。
學習並建立命令 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。使用此螢幕按鍵可在將特徵交付至測量程式前，作出變更並測試回合特徵。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
公差設定 此螢幕按鍵可讓您設定或修改特徵命令所用的特徵標稱和公差值。它是報告螢幕上顯示內容的概觀。 | 插入移動點 此螢幕按鍵可讀取測頭的目前位置，並作為安全移動將它插入測量程式。
確認╱新增命令 對於操作，這可以確認選取。 對於命令，這可以在測量程式結尾中附加命令。 對於特徵命令，測量機瞭解到特徵位置後或當您輸入特徵的標稱值時這將變成可用狀態。 對於構造和尺寸特徵命令，一旦您指定適當的輸入特徵，這將變成可用狀態。 | 說明 此螢幕按鍵可進入 NC Gage說明檔。
切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。 |

學習處理序

  1. 將測頭置於移動點位置，按一下讀取位置螢幕按鍵 [image] 。可讀取測尖位置。按返回至上一步 螢幕按鍵 [image] ，取消此測量位置。

  2. 按 確認並將目前命令新增至末端螢幕按鍵 [image] 。將新的移動點命令插入測量程式。

備註：如果從任何特徵螢幕上第二頁存取移動點螢幕，那麼移動點將插入特徵後的測量程式。

以下是特定的特徵路徑和 NC Gage 內置邏輯：

  • 如果當前 Z 位置高於目標位置，則將其移至當前 Z 高度的 XY 目標位置，然後再移向 Z 目標位置。

  • 如果當前 Z 位置低於目標位置，則將其向上移至 Z 目標位置，然後再移向 XY 目標位置。


安全平面

安全平面命令提供 XYZ 坐標和平面向量，超過此平面時測尖中心在執行將會移動。

要將安全平面移動命令新增至測量程式：

  1. 按主螢幕導覽列上的移動螢幕按鍵 [image] 。

  2. 按安全平面 螢幕按鍵 [image] ，顯示安全平面螢幕：

  3. 根據螢幕指示操作插入命令。

備註：注意螢幕左上區域中的圖形描述。當需要多個步驟時，它將向您顯示測頭測量和變更的位置。

參數定義：

  • 測頭測尖的方向平面高度 - 定義工件原點與安全平面之間的距離（沿測頭測尖方向進行測量）。

  • 使用螢幕上的值學習 - 讓您輸入特徵的標稱值並在該位置使用軟體。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。 | 切換焦點 此螢幕按鍵可切換螢幕不同區域間游標的位置。
返回上一步 此螢幕按鍵可移除上一次學習的測頭位置。 | 讀取測頭位置並繼續下一步 此螢幕按鍵可讀取當前測頭位置，然後前進至程序中的下一步。
刪除當前命令/刪除上一個建立的 此螢幕按鍵可用來從測量常式中刪除目前選取的命令（或上次建立的命令）。若此圖示已停用，您可能需要使用編輯測量常式螢幕刪除命令。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
執行 此螢幕按鍵可讓測量機測量特徵。在學習（或鍵入）所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。 使用此螢幕按鍵可在將特徵交付至測量常式前作出變更並測試回合特徵。 | 學習並建立一個命令（執行） 在學習所有識別特徵位置的必要測頭位置後，才可使用此螢幕按鍵。此螢幕按鍵可讓測量機測量特徵。

學習處理序

  1. 按主螢幕導覽列上的移動螢幕按鍵 [image] 。

  2. 按安全平面螢幕按鍵 [image] 。

  3. 設定安全平面位置。可透過以下任何一項完成它：

    1. 將測尖分疊到所需的移動位置，然後按讀取位置螢幕按鍵 [image] 以將當前位置當作目標。

    2. 檢查使用螢幕上的值學習，然後在測頭測尖的方向平面高度方塊中鍵入位置。此位置與測尖中心和目前工作偏移有關。

  4. 按確認螢幕按鍵 [image] 。安全平面命令被新增至測量程式。

安全平面最低高度：

最小安全平面的計算與逼近距離和預測點半徑有關。NC 標準塊定義了安全平面，這樣就不會讓測頭距離工件的距離比距離逼近距離要更近。而且，假設在「牆」上測量特徵時，其測量深度至少為測頭半徑。

  • 對於在「牆」（內經、突起部、線、柱體、錐體、網路、口袋、棱角）上測量的特徵：
    最低安全平面高度 = 測量高度 +（2 * 測頭半徑）+ 預測高度

或者

最低安全平面高度 = 測量高度 + 測頭直徑 + 預測高度

  • 對於在工件（平面和點）上方測量的特徵：
    最低安全平面高度 = 測量高度 + 測頭半徑 + 預測高度

  • 對於球體特徵：
    安全平面最低高度 = 球體中心 + 球體半徑 + 測頭半徑 + 預測點

工件和測尖的側檢視圖表

A — 最低高度

B — 預測點

C — 測尖


使用測量程式

使用測量程式以及要測量的特徵後，您可執行測量程式或編輯它。NC Gage 將提供執行測量程式和編輯測量程式螢幕幫助您執行這些工作。

下列主題將對這些螢幕進行描述：

  • 檢視和執行測量程式

  • 編輯測量程式


檢視和執行測量程式

使用測量程式螢幕檢視並執行測量程式。

要存取此螢幕，選取主螢幕上的執行測量程式螢幕按鍵 [image] 。

特徵夾角範例

角度的平行度報告範例

角度的垂直度報告範例

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
執行目前命令至結束 此螢幕按鍵將讓 NC Gage 從測量程式樹視窗中反白顯示的（已選取的）特徵開始執行，直至測量程式的末端。 | 執行區塊 此螢幕按鍵可讓 NC Gage 僅執行測量程式樹視窗中反白顯示的（選取的）特徵。
執行測量程式 此螢幕按鍵可讓 NC Gage 執行所有測量程式。 | 停止執行 此螢幕按鍵可讓 NC Gage 停止對測量程式的執行。
轉至結束 此螢幕按鍵可將反白顯示的項目前進至測量程式末尾。 | 轉至開始 此螢幕按鍵可將反白顯示的項目前進至測量程式開頭。
說明 此螢幕按鍵可進入 NC Gage說明檔。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。


編輯測量程式

使用編輯測量程式螢幕編輯測量程式。這包括重新排列、複製或貼上以及刪除命令。

  1. 按下一頁螢幕按鍵 [image] ，導覽主螢幕第二頁。

  2. 按編輯測量程式螢幕按鍵 [image] ，顯示編輯測量程式螢幕：

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
清除選取 除用多重選取模式選取的第一個測量程式實體之外，此螢幕按鍵可取消選取所有實體。 | 遊標模式切換 「編輯」視窗中有兩個游標模式。游標模式切換螢幕按鍵可在兩者之間進行切換。請參閱以下「有關游標模式的資訊」。
向下移動 此螢幕按鍵可在「編輯」視窗測量程式樹中將游標向下移動一個項目。若啟動多重選取模式，將會選取每個實體並將它們新增至群組。 | 向上移動 此螢幕按鍵可在「編輯」視窗測量程式樹中將游標向上移動一個項目。若啟動多重選取模式，將會選取每個實體並將它們新增至群組。
剪下 此螢幕按鍵可從測量程式樹視窗中移除反白顯示的（選取的）特徵。然後，可在其他地方貼上特徵。 | 複製 此螢幕按鍵可複製測量程式樹視窗中反白顯示的（選取的）特徵。
編輯 若要編輯特徵，請從樹狀檢視中選取它並按此螢幕按鍵。正在編輯的選取命令的相應螢幕將以編輯模式開啟。 請參閱以下「有關編輯特徵的資訊」。 | 刪除 此螢幕按鍵可從測量程式樹中永久移除反白顯示的（選取的）特徵。
復原（在第二頁上） 編輯包含在「編輯」視窗樹狀檢視中的 NC Gage 測量程式時，此螢幕按鍵將復原上一個執行的變更或步驟。您可以復原每個步驟直至開啟上一次的「編輯」視窗。 | 回到開頭（在第二頁上） 此螢幕按鍵可將反白顯示的項目前進至測量程式開頭。 此螢幕按鍵可重做最近未完成的項目。您可以重做每個步驟直至開啟上一次的「編輯」視窗。
貼上 此螢幕按鍵可將剪下或複製的特徵插入測量程式。請參閱以下「有關貼上特徵的資訊」。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。

有關游標模式的資訊

兩個模式為：

  • 單選模式 - 在此模式中，當您將游標在「編輯」視窗測量程式樹中上下移動時，它將選取待編輯的目前實體。這就是預設模式。

  • 多重選取模式 - 在此模式中，當您將游標在「編輯」視窗測量程式樹中上下移動時，它將自動選取每個實體並將它新增至選取的實體群組。

每種模式可用於剪下、複製或貼上測量程式實體。

有關編輯特徵的資訊

當處在編輯測量程式螢幕或編輯模式時：

  • 若要離開螢幕或離開螢幕而不儲存變更，請按返回螢幕按鍵 [image] 。

  • 若要離開螢幕並儲存變更，請按確認儲存變更命令螢幕按鍵 [image] 。

當編輯測量程式螢幕右下區域中出現以下圖示時，您就處於編輯模式：

否則，出現的以下圖示表示您處於標準插入模式：

有關貼上特徵的資訊

若要貼上特徵，請將反白顯示項目移至插入貼上的特徵上方的特徵。當您按複製或剪下螢幕按鍵時，在測量程式樹狀檢視中將出現一個紅色小箭頭。這表明在測量程式的何處貼上命令。

  • 如果貼上的特徵原本是從測量程式中剪下的，那麼它將以剪下的相同方式插入測量程式。其實，它將以測量程式順序進行移動。

  • 如果貼上的特徵原本是從測量程式中複製的，那麼它將插入測量程式，特徵名將隨著每次貼上而遞增。所以，如果您複製並貼上名為「線路1」的特徵，貼上的特徵將被命名為「線路2」，然後「線路3」等。

測量程式註解

在測量程式註解方塊中，鍵入有關測量程式的註解。此註解出現在檔案管理器螢幕上的註解欄中。


管理檔案

使用檔案管理器螢幕管理 NC Gage 測量程式。您可建立新的測量程式並儲存這些測量程式，以及載入或刪除現有測量程式。測量程式儲存在 NC Gage 安裝目錄的 PRG 目錄中。

按一下主螢幕上的檔案管理器螢幕按鍵 [image] ，顯示檔案管理器螢幕：

此螢幕包含三欄：

  • 測量程式名稱 - 此欄列出帶 .NCG 副檔名的測量程式名稱。

  • 註解 - 此欄顯示所有測量程式特定的註解。使用編輯測量程式螢幕新增所有註解。請參閱「編輯測量程式」。

  • 建立日期 - 此欄顯示上次儲存測量程式的日期。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
儲存目前測量程式 此螢幕按鍵可將目前測量程式儲存為指定名稱。 | 載入選取的測量程式 此螢幕按鍵可載入從清單中選取的測量程式。
新的測量程式 此螢幕按鍵可建立新的測量程式。它會要求確認是否希望儲存對目前測量程式作出的任何變更。 | 刪除選取的測量程式 此螢幕按鍵可從清單中刪除選取的測量程式。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
檔案管理器 此螢幕按鍵可顯示檔案管理器螢幕。 |


使用報告

執行測量程式之後，您可以檢視報告螢幕，以將測量值的結果與提供的標稱值進行對比。執行測量程式之後，您可以立即按主螢幕上的報告螢幕按鍵 [image] 存取此螢幕。

備註：在報告螢幕上包含測量值之前，您無法存取此螢幕。這些值僅在執行測量程式之後方可使用。

角度的平行度和垂直度報告

顯示測量程式報告

要顯示測量程式報告，請巡覽主螢幕的相應頁面並選取報告螢幕按鍵 [image] 。

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
將報告儲存至 RTF 檔案 此螢幕按鍵可將目前報告儲存至 RTF 檔案中。檔案的路徑位置將列於螢幕的頂端。檔案的名稱將與測量程式名稱相同，接著是一個數字，在每次儲存報告時此數字將增加。 | 列印報告 此螢幕按鍵可將報告轉送至您的預設列印裝置。
報告 此螢幕按鍵可進入報告螢幕，在該螢幕上可檢視、儲存或列印測量常式的測量報告。 | 英吋/毫米 此螢幕按鍵可在顯示報告的測量單位之間進行切換，按下螢幕按鍵後即可在英吋與公制之間進行切換。
匯出至 DatapagePlus 此螢幕按鍵可用來將報告資料匯出至基於 XML 的輸出檔案中，此檔案可被讀取至 DP+ 中。 | 返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。
確認╱新增命令 對於操作，此螢幕按鍵可確認選取。 對於命令，此螢幕按鍵可在測量常式結尾中附加命令。 對於特徵命令，測量機學習特徵位置後或當您鍵入特徵的標稱值時該螢幕按鍵將變成可用狀態。 對於構造和尺寸特徵命令，使用者指定適當的輸入特徵後，該螢幕按鍵將變成可用狀態。 | 取消所有步驟╱中止 此螢幕按鍵停止并重設操作。如果學習特徵，它將移除所有學習的測頭位置。
向上捲動報告 按一下此螢幕按鍵，即可向上捲動報告視圖一頁。 | 向下捲動報告 按一下此螢幕按鍵，即可向下捲動報告視圖一頁。
說明 此螢幕按鍵可顯示 NC Gage 說明檔。 |


使用螢幕小鍵盤

NC Gage 有以下三個螢幕小鍵盤：

  • 英數鍵盤 - 此鍵盤是字母、數字和符號按鍵之組合。若在 NC Gage 中啟用鍵盤，則按一下螢幕上的英數方塊後，此鍵盤將自動出現。

  • 數字鍵台 - 此鍵盤提供計算器式效率，便於輸入數字資料。若在 NC Gage 中啟用鍵盤，則按一下螢幕上的數字方塊後，此鍵盤將自動出現。

  • 科學計算器 - 此鍵盤提供對數學函式之存取。開啟此鍵盤之按鍵位於數字鍵台上。

要啟用或隱藏鍵盤，定義其顏色並設定其按鍵大小，請參閱「附錄 A - 控制器設定」中的「鍵盤設定標籤」。

所有鍵盤上的標準按鍵

下表介紹所有鍵盤上所顯示的按鍵。

按鍵

描述

圖釘

  • 要固定鍵盤以便按一下螢幕上的方塊時鍵盤顯示在螢幕的同一位置，則按一下「圖釘」鍵。其背景將變為橙色。

  • 要取消固定鍵盤，按一下背景為橙色的「圖釘」鍵。按一下螢幕上的方塊後，鍵盤的位置將發生變更。

「關閉鍵」可用於關閉鍵盤。

0 - 9

這些按鍵可輸入數字。

英數鍵盤

英數鍵盤

下表介紹各種按鍵。

按鍵 | 描述
a - z | 這些按鍵可用於輸入小寫或大寫字母。要將小寫鍵變更為大寫鍵，則按一下 abc 鍵。
# | 輸入井字符號。
Tab | 關閉目前選項的鍵盤並將游標移至螢幕上的下一選項。
, | 輸入逗點。
!#? | 將字母鍵變更為符號鍵。按一下此鍵後，其背景變為橙色。要將符號鍵變回字母鍵，按一下背景為橙色的 !#? 鍵。
abc | 將小寫鍵變為大寫鍵。按一下此鍵後，其背景變為橙色。要將大寫鍵變更為小寫鍵，則按一下背景為橙色的 abc 鍵。
JP | 僅日文作業系統顯示日文轉換鍵。（如果作業系統不是日文，則此鍵不顯示。）若按一下此鍵，將可使用日文字元的完整清單。若不按此鍵，將可使用日文字元的一半清單。
 | 「空格鍵」可輸入空格。
/ | 輸入斜線。
\ | 輸入反斜線。
. | 輸入句號。
 | 「退格鍵」可刪除螢幕上方塊中游標左側的字元。
DEL | 刪除螢幕上方塊中游標右側的字元。
- | 輸入連字號。
 | Enter 鍵客將遊標移至螢幕上方塊中新的一行。
向上成對箭號 | 向上翻頁。
向下成對箭號 | 向下翻頁。
上箭號 | 將游標向左移動一個字元。
左箭號 | 將游標向左移動一個字元。
右箭號 | 將游標向右移動一個字元。
下箭號 | 將游標向右移動一個字元。

數字鍵台

數字鍵台

下表介紹各種按鍵。

按鍵 | 描述
Cal | 「計算器」鍵可將鍵盤變更為科學計算器。
 | 「退格鍵」可刪除鍵盤文字方塊中的字元（從右到左）。
CLR | 「清除」鍵可清除鍵盤文字方塊及螢幕上方塊中的字元。
- | 輸入負數。
. | 輸入小數點。
 | Enter 鍵可將鍵盤文字方塊中顯示的字元輸入螢幕上的方塊中。

科學計算器

按一下數字鍵台上的 Cal（計算器）鍵後，將出現科學計算器：

科學計算器

要計算運算式，按一下數學符號，然後按一下運算元。例如，要計算 sin(60)+cos(60) 並將結果顯示在計算器的文字方塊中，則按一下以下按鍵：

sin(60)+cos(60)=

下表介紹各種按鍵並提供範例。

按鍵 | 描述 | 按一下按鍵範例
Num | 將鍵盤變更為數字鍵台。 |
AC | 清除計算器文字方塊中計算出的結果或運算式。 |
C | 清除計算器文字方塊中最後一個數字。 |
( | 輸入左括弧。 |
) | 輸入右括弧。 |
Pl | Pi | Pl=
Abs | 計算絕對值。 | Abs3=
sin | 計算正弦。 | sin60=
cos | 計算餘弦。 | cos60=
tan | 計算正切。 | tan60=
In | 計算對數。 | In6=
Inv | Inv（反向）鍵可將 sin、cos、tan、In、 平方根以及 mm->inch 鍵變更為其互反函式。按一下此鍵後，其背景變為橙色： 互反函式 互反函式如下所述： |
 | asin - 計算反正弦。 | asin0.5=
 | acos - 計算反餘弦。 | acos0.5=
 | atan - 計算反正切。 | atan1=
 | exp - 計算指數。 | exp2=
 | x^2 - 計算平方。 | 3x^2=
 | inch->mm - 將鍵盤文字方塊中的結果從英吋變更為公釐。 | inch->mm9=
 | 「平方根」鍵執行平方根運算。 | 16=
mm->inch | 將鍵盤文字方塊中的結果從公釐變更為英吋。 | mm->inch3=
= | 「等於」鍵在計算器的文字方塊中顯示算術運算的結果。要在螢幕上的方塊中顯示結果，在按一下 = 鍵後按一下 Enter。 | 3+2=
/ | 將兩個數相除。 | 3/2=
* | 將兩個數相乘。 | 3*2=
- | 將兩個數相減或輸入減號。 | 3-2= -3
+ | 將兩個數相加。 | 3+2=
 | 「退格鍵」可刪除鍵盤文字方塊中的字元（從右到左）。 |
CLR | 「清除」鍵可清除螢幕上方塊中的字元。 |
 | Enter 鍵可將鍵盤文字方塊中顯示的字元輸入螢幕上的方塊中。 |


直接連接模式

Home > 使用 PC-DMIS NC Gage > 直接連接模式 (DCM)

直接連接模式 (DCM)

NC Gage 測量程式可從剪下巨集中直接運行，好像測量程式係使用直接連接模式 (DCM) 功能的副程式。當 NC Gage 測量程式準確無誤地完成運行時，它將返回切割巨集中。

NC Gage 測量程式可包含檢查常式或工作偏移更新常式。

輸入 DCM 模式

按主螢幕第二頁上的直接連接模式螢幕按鍵 [image] ，顯示直接連接模式螢幕：

直接連接模式螢幕

而且，您也可以使用如下所示的 –DL 副檔名修改命令行捷徑以啟動 NC Gage時啟動直接連接模式：

C:\ .. \NCGage. exe –dl

叫用 NC Gage 測量程式

要從切割巨集中叫用 NC Gage 測量程式，必須叫用特殊巨集（DCM 巨集），同時應指定 NC Gage 測量程式名稱（必須為數字）。

  • NC Gage 測量程式的名稱必須為四位數的數字。當叫用 DCM 巨集來指定應運行哪個 NC Gage 測量程式時將使用此數字。

  • DCM 巨集等於 NC Gage 監視巨集數加 1。例如，如果監視巨集數為 7400，DCM 巨集則為 7401。NC Gage 設定工具在初始安裝和設定 NC Gage 時會確定 DCM 巨集數。有關更多資訊，請參閱「附錄 A - 控制器設定」。

若要叫用剪下巨集中名為 1234.ncg 的 NC Gage 測量程式，請將以下語法新增至切割巨集：

G65 P7401 H1234

在 DCM 中執行時，直接連接模式螢幕顯示正在執行的測量程式。它還隨著測量程式的執行即時顯示報告。如果這樣組態 NC Gage，那麼它將儲存一份工件報告檔案，NC Gage DCM 監控螢幕將顯示超出公差的數量。

錯誤狀況

如果誤觸發導致出現錯誤並意外結束移動，則按 NC Gage 中的停止執行螢幕按鍵 [image] 。如果測量機工具無法初始化測頭，NC Gage 會返回切割巨集。

「超差數」選項範例

資訊區域中超差數選項顯示測量程式中超出公差的特徵的數量。

「超差數」選項範例

導覽列螢幕按鍵

向後 啟用時﹐此螢幕按鍵將向後捲動到此螢幕第一頁上可用的任何其他螢幕按鍵。 此螢幕按鍵可將檢視器返回上一級至上一螢幕。 | 向前 啟用時，此螢幕按鍵將向前捲動到此螢幕第二頁上可用的任何額外按鈕。
顯示詳細資訊 此螢幕按鍵可顯示有關在 DCM 中執行測量程式的即時資訊。 | 停止執行 此螢幕按鍵可停止執行目前命令或巨集程式。
返回 此螢幕按鍵返回到上一熒幕往上一層的檢視。 此螢幕按鍵可將螢幕從 NC Gage 切換為控制項之主視窗。 | 說明 此螢幕按鍵可顯示 NC Gage 說明檔。


附錄 A - 控制器設定 (Fanuc)

Home > 使用 PC-DMIS NC Gage > 附錄 A — 控制器設定

附錄 A - 控制器設定

您可使用 NC Gage 設定工具，設定控制器。NC Gage 中的各種控制器通常由安裝測頭硬體的人員設定。此主題僅供參考，介紹了設定工具。

該設定工具可產生一系列觸測巨集，以用在初始設定對話方塊螢幕上選取的特定控制器類型上。而且，控制器上要有足夠的記憶體儲存 NC Gage 巨集。

使用工具

要開啟設定工具，請執行以下操作之一：

  • 安裝 NC Gage 軟體後，按一下 PC-DMIS NC Gage 程式組中的捷徑：

程式組

  • 按一下 NC Gage 安裝目錄中的 ConfigTool.exe。

啟動設定工具後，會顯示以下螢幕：

「NcGage 設定工具」螢幕

  1. 從控制模型清單中選取 Fanuc。

  2. 從語言清單中選取相應語言（如有必要）。

  3. 按一下確定按鈕為所選的控制器和語言顯示 PC-DMIS NC Gage 設定工具螢幕。

  4. 完成螢幕上的標籤。

標籤

PC-DMIS NC Gage 設定工具螢幕包含以下標籤：

  • 一般標籤

  • 參數標籤​​

  • 軸設定標籤​​

  • 測頭標籤​​

  • 鍵盤設定標籤

按鈕

所有標籤上都有以下按鈕：

  • 使用預設值 - 預設情況下此按鈕恢復 <輸出檔案名稱>.dat 或 FanucMonitor.cnc.dat 中儲存的參數集。

  • 載入設定 - NC Gage 使用 NCGage.dat 檔案儲存所有設定資訊。該檔案始終儲存至同一資料夾並從同一資料夾中載入，以便您「匯入」設定。按一下載入設定按鈕後，將出現開啟檔案對話方塊。您可使用此對話方塊搜尋並載入擁有不同名稱或位於其他資料夾中的設定檔案。

  • 儲存設定 - 預設情況下此按鈕將在 <輸出檔案名>.dat 或FanucMonitor.cnc.dat中為 ConfigTool.exe 儲存目前的參數集。

  • 讀取測量機 - 支援時，此按鈕嘗試讀取控制器中的測量機變數。控制項必須透過乙太網路連線至 NC Gage 電腦上。在一般標籤上的連接參數區域裡的 IP 位址和連接埠編號必須正確。將讀取以下參數：

    • 工具偏移類型

    • 軸的數量

    • 軸字母和偏移

    • 控制器類型

  • 產生巨集程式 - 此按鈕在檔案中建立巨集集合，該檔案在一般標籤上的輸出檔案方塊中輸入。

  • 上載程式 - 支援時，此按鈕嘗試將產生的巨集設定上載到控制器中。必須按照讀取機器和連接參數中引用的內容正確設定控制器。控制器必須處於編輯模式。為產生選取的巨集區域必須能啟用寫入。

  • 結束 - 此按鈕結束設定工具。

通訊狀態列

此列沿 PC-DMIS NC Gage 設定工具螢幕的底部顯示。按讀取測量機或上載程式按鈕後，該狀態列顯示控制器與測量機間有關通訊成功或失敗之訊息。

設定檔案

  • NcGage.dat - NC Gage 的測量機設定包含於 NC Gage 用於測量機設定的基於 XML 的文字檔（檔案名稱：NcGage.dat）中。按一下儲存設定按鈕後，將產生此檔案。

NcGage.dat 名稱固定。您可在工具的輸出檔案方塊中變更輸出檔案名稱。還原檔案名透过附加 ".dat" 從輸出檔案名中衍生出來。

  • FanucMonitor.cnc - 此檔案包含 CNC 監視巨集（將在控制器上載入）。

  • FanucMonitor.cnc.dat - 此檔案還原設定工具的設定。

  • 標頭指令碼檔案和控制器指令碼檔案 - 這些檔案已為特定控制器設定定義。它們無需變更。


一般標籤

NC Gage 設定工具的一般標籤如下所示：

一般標籤

單位 - 選取相應的測量單位（公釐或英吋）。測量機上有單位設定。注意 NC Gage 將使用控制器的單位設定。

測量機名稱 - 此名稱可以為無空格或特殊字元的任何文字。如果您想文字間有分隔，請使用底線。

控制器類型 - 使用此清單可選取將與 NC Gage 連接的控制器類型。目前支援的通訊機制因基礎控制器的不同而異。

IP 位址 - 控制器的網際網路通訊協定 (IP) 位址。此唯一的位址能識別電腦網路上的控制器。透過使用網絡聯線品質測試來驗證連線性，您必須確認電腦使用了與控制器相同的子網路遮罩。如果 NC Gage 安裝在獨立的電腦上，可以透過偵測控制器來測試它。在有些系統中，電腦的 IP 位址必須與機器工具的 IP 位址祇有一個數字不同。例如，如果測量機工具的 IP 位址是 192.168.0.1，那麼電腦的 IP 位址則需設定為 192.168.0.2。

網絡聯線品質測試：開啟「命令提示」視窗，在控制器 IP 位址後鍵入 "ping" 便可進行網絡聯線品質測試。當您按 ENTER 時，測試將嘗試與控制器建立暫時的連接。如果失敗了，您將看見「命令提示」視窗中顯示「請求逾時。」訊息。

子網路遮罩： 讓您的 IT 支援人員將其設定的和控制器一樣。

乙太網路 - 透過乙太網路連接埠進行通訊。

HSSB - 透過高速序列匯流排 (HSSB) 進行通訊。若選取此選項，IP 位址和連接埠選項將會消失。

連接埠 - 若選取了乙太網路通訊選項，則連接埠選項可定義控制器的連接埠編號。連接埠控制允許來自連線的電腦的資訊。

工具數量 > 200 - 如果工具數量大於 200，請選取此核取方塊。

輸出檔案 - 這是按一下產生巨集程式後建立的輸出巨集檔的名稱。請註意，帶 .dat 副檔名的檔案名也是用於還原按鈕操作的資料檔案。您不得變更它。

坐標旋轉巨集 # - 若要在 NC Gage 中進行坐標旋轉工作，則選取此核取方塊。此核取方塊可指定待使用的特定坐標旋轉選項（G68 或 G68.2 巨集程式碼）。

G68 - 若控制器上有 G68 程式碼，請選取此選項。

G68.2 - 若控制器上有 G68.2 程式碼，請選取此選項。

主軸位置 - 將機器程式碼放在此以確定主軸位置。如果機器沒有容量，請清除此選項的內容。變數將附加到提供的程式碼中並包含角度。例如：

  • 提供的程式碼： M19S

  • 產生的程式碼： M19S#1


參數標籤​​

NC Gage 設定工具的參數標籤如下所示：

「參數」標籤​​

速度區域

快速觸測進給率（公釐╱分鐘） - 設定測頭不進行觸測時移動的最大速度。無論將控制器操作單位設定為英吋還是公釐，該單位均為公釐╱分鐘。

慢速觸測進給率（公釐╱分鐘） - 設定測頭搜尋曲面時的移動速度。單位為公釐╱分鐘。

最大旋轉速度（度/分鐘） - 設定所有旋轉軸（包括主軸頭和旋轉臺）的速度。單位為度╱分鐘。

地址區域

變數庫 - Nc Gage 用於傳輸資訊的變數的起始地址。目前，Nc Gage 使用 31。關閉控制器之前無需儲存該資訊。

設定庫 - NC Gage 用於建立移動、觸測和工具常數的變數起始地址。NC Gage 目前使用 11。關閉控制器之前應儲存該資訊。

程式編號 - 設定產生監視巨集的地址。

測頭區域

測頭位元 PLC 地址 - 測頭觸發 PLC 位元的地址。

工具地區

工具編號地址 - 目前工具的地址。您可視需為此選項輸入巨集變數或 PLC 地址。此值決定控制器在記憶體中儲存工具資料的方式。預設值是「工具偏移」。

工具偏移類型 - 區分不同的方法，記錄測量機控制項上的工具長度。

  • 如果測量機僅有幾何長度，而沒有工具長度管理的磨損長度，則選取 A。幾何長度中會新增差額。

  • 如果測量機同時擁有工具長度管理的幾何和磨損長度，則選取 B 或 C。磨損長度中會新增差額。


軸設定標籤

Home > 使用 PC-DMIS NC Gage > 附錄 A — 控制器設定 > 軸設定標籤

座標軸設定標籤​​

NC Gage 設定工具的軸設定標籤如下所示：

「軸設定」標籤​​

軸啟用 - 對於每條軸，您必須設定軸啟用欄位。至少需要三條軸。讀取測量機會填入已知的軸和軸字母（如支援）。始終設定 X、Y 和 Z 軸，同時無法移除該設定。

軸類型 - 類型可為線性、旋轉臺或測座。要在系統中設定旋轉臺：

  • 標記適當的軸啟用 核取方塊。

  • 從軸類型清單中選取「旋轉臺」選項。

  • 從相應的軸清單中選取與每個旋轉臺相關的軸。其選項為 A、B、C、U、V、W、X、Y、Z 和無。一般而言，線性系統是基於 X、Y 和 Z 識別項，然而旋轉系統由 A、B 和 C 識別。

  • 如果使用堆疊式旋轉臺，請從旋轉臺堆疊順序清單中選取順序。除非已定義多個旋轉臺，否則不可使用此選項。

軸 - 這是軸識別項 X、Y、Z、U、V、W、A、B、C 或無。

偏移 - 設定軸圖中的偏移。例如，如果測量機有 XYZ 線性軸和 B 軸旋轉臺，那麼偏移可能是 1、2、3、4。通常，設定中不含從動軸，這樣軸圖中將跳過從動軸。由此同一測量機中可能有 1、3、4、5 軸圖。

限制 - 限制資訊位於測量機坐標系中。如果不知道這些，那麼您應將它們保留空白。

解鎖╱鎖定碼 - 必要時，它們用於旋轉軸。

旋轉臺堆疊順序 - 定義多個旋轉臺的順序。

當測座位於 0 處時的測頭方向（主軸測尖） - 當測座位於零位置時，從清單中為測頭測尖的主軸測尖方向選取一個選項。選項有：ZPlus、ZMinus、YPlus、YMinus、XPlus 和 XMinus。

樞軸類型 - 從清單中選取一個選項，定義測座樞軸類型。選項有 WristCenter 和 WristZero。

樞軸距離 - 輸入測座的樞軸距離。

備註：定義兩個旋轉臺後，方可使用設定工具的軸設定標籤上的旋轉臺堆疊順序清單。 如果定義了旋轉臺和測座（同車銑機），旋轉臺堆疊順序清單將如下所示的當測座位於 0 處時的測頭方向（主軸測尖）和樞軸區域所取代。

如果此情況不適用，則將不顯示上述區域。 如果對車銑機定義了測座，則其必須設為 B 軸，旋轉臺必須設為 C 軸。

有關設定旋轉臺之更多資訊，請檢閱「動力學設定」主題。


測頭標籤​​

NC Gage 設定工具的測頭標籤如下所示：

「測頭」標籤​​

啟用測頭巨集 - 啟用測頭所需的巨集程式碼。

載入測頭巨集 - 載入測頭所需的巨集程式碼。

開始程式巨集 - 需在巨集程式開始時執行的巨集程式碼。

停用測頭巨集 - 停用測頭所需的巨集程式碼。

移動測試巨集 - 測試測頭是否已啟動並能移動所需的巨集程式碼。

結束程式巨集 - 需在巨集程式結束時執行的巨集程式碼。

根據需要設定系統的所有標籤之後，選取儲存設定按鈕，然後按一下產生巨集程式按鈕。


鍵盤設定標籤​​

要啟用或停用 NC Gage 中的螢幕小鍵盤，請選取 NC Gage 設定工具的鍵盤設定標籤。

要啟用鍵盤，請選取標籤上的啟用鍵盤核取方塊來顯示以下螢幕：

「鍵盤設定」標籤

鍵盤區域

啟用鍵盤 - 若選取此核取方塊，按一下螢幕上的英數方塊後，將會顯示螢幕小鍵盤。按一下數字方塊後，將顯示數字鍵盤。若按一下方塊後不想顯示鍵盤，請清除此核取方塊。

背景顏色 - 設定鍵盤的背景色。

按鍵區域

大小 - 設定按鍵的大小。

框架顏色 - 設定按鍵框線的顏色。

背景顏色區域

標準 - 設定按鍵的背景色。

暫留 - 指向該選項時，設定按鍵的顏色。

按 - 按一下該選項時，設定按鍵的顏色。

字元區域

大小 - 設定按鍵上字元的字型大小。

顏色 - 設定按鍵上字元的顏色。

選取顏色

要為鍵盤設定標籤上的選項選取顏色：

  1. 按一下選項的方塊。將出現顏色螢幕：

顏色螢幕

  2. 要選取基本顏色，按一下所需的顏色。要選取自訂顏色，選取定義自訂顏色，然後定義所需的顏色。

  3. 按一下確定，返回鍵盤設定標籤。


校驗值測試

Home > 校驗值測試

校驗值測試（校驗測試設定）

此螢幕允許您表示環和公差值的標稱位置。如果測量值不同於個別標稱並高於指定的公差，將顯示警告。使用者接受警告後可繼續。可輸入標稱 X、Y 和 Z。可輸入 X、Y、Z、D 和形狀 (F) 公差。


資訊管理器

資訊管理器 - [image] 此螢幕可讓您看到與控制器 NC Gage 連接有關的訊息以及 NC Gage 遇到的任何錯誤訊息。


測頭長度改善

設定測頭長度螢幕可用於計算柄部測頭的長度。可隨時執行此作業。

  1. 按主螢幕上的測頭。

  2. 按一下測頭長度改善。 螢幕上回出現設定測頭長度螢幕。

  3. 從工作偏移清單中選取一個工作偏移。

  4. 在參數區域的目標方塊中鍵入與目前工作位移相關的表面位置。

  5. 在動作參數區域的預碰距離中鍵入一個值。

  6. 將測頭置於表面之上。

  7. 按一下讀取測頭位置 [image] 螢幕按鍵。

  8. 按執行螢幕按鍵 [image] 。測頭將以目標值測量表面。依據接觸位置以及測頭主軸在表面上 3D 空間位移中的位置，NC Gage 可測量測頭的長度。所測的 Z 值和測頭長度顯示於唯讀測量值 Z 和測量長度方塊。

  9. 按一下確認螢幕按鍵 [image] 儲存校驗所用的測頭長度或者按一下返回 [image] 螢幕按鍵返回至上一螢幕而不儲存。

此螢幕上的所有其他項目均包含與測頭關聯的唯讀資訊。

此螢幕上的導覽列螢幕按鍵：