TubeShaperの概要

TubeShaperは、ROMER絶対のアームを利用してチューブを検査する用のHexagon Metrologyソフトウェアです。これは、従来の接触型プローブとROMERの非接触型のチューブプローブの両方とも互換性を持っています。

従来のコンタクト プローブ(左)とROMER非接触型のチューブプローブ(右)の例

TubeShaperのメリット

  • 汎用性: TubeShaperはチューブとパイプの設計と製造に関連するすべての測定ニーズに対応するように設計されています。これは、チューブとパイプのリバースエンジニアリング、検査、受け入れと生産管理のための一つのソリューションです。

  • 使いやすさ: 最新のユーザ・インタフェースはTubeShaperが使いやすくて、最小のトレーニングを必要とすることを意味します。

  • 使用の速度: TubeShaperは、作業者にできるだけ急速に使用できて、早く適切な結果に達ように設計されています。

詳細:

チューブの用語と基礎

TubeShaper のインターフェース

オンラインでTubeShaperライセンスのアクティブ化

ショートカット キーの使用

更新の確認

アプリケーションの設定

ツール

プロジェクトの新規作成

プロジェクトの保存とエクスポート

ベンダーの設定

プロジェクトの編集

チューブの測定

要素の作成

整列の作成

構築された要素

寸法

レポート

ショップフロアモード


チューブの用語と基礎

チューブは、数学的に異なる方法で定義することができます：

  • XYZ座標は、空間内の各交差点（IP）の3次元位置を定義するために使用することができます。

  • LRA値は、チューブを作ることに必要なパラメータを定義するために使用することができます。

以下に示すように曲げ工程を経ているチューブ（またはパイプ）は、一般的に直管部、回転及び曲げなど一連の構造から構成されます。

1 - A 端
2 - 管径
3 - 直管 1 (S1) = "L" 値
4 - 直管 2 (S2) = "L" Value
5 - 直管 3 (S3) = "L" 値
6 - 曲げ角度 = "A" 値
7 - 直管 4 (S4) = "L" 値
8 - 曲げ半径 = "R" 値
9 - 直管 5 (S5) = "L" 値
10 - B 端
11 - 接点 (TP)
12 - 交点 (IP)

曲げ加工が完了した後に、下記の用語は、チューブを記述するために使用されます。

  • A端 - A点とも呼ばれて、その管軸上の点として知られていますが、チューブの「始」端にあります。これは一般的に曲げ加工機がどちらの端からチューブを作るかを定義します（また、どちらの端からチューブが測定されるか）

  • 直管部 - これはベンド間に位置するチューブの部分です。A端から開始し、各直管の命名規則は、「直管1」、「直管2」、「直管3」などというように、最後の直管はB端なります。直管は、一般的に「S1」、「S2」、「S3」などと呼ばれます。

  • 接点（TP） - 各直管の最大端（始点と終点）で、チューブの軸線上にある点です。これらはXYZ座標として表示され、常にチューブが公差内にあるか否かを決定するために使用される点です。特定の直管の接点はTP1とTP2と呼ばれます。

チューブに沿う接点を区別するために、それらは、常にそれらの相対的な直管に対応して指定されます。例えば、チューブの直管３（S3）の接点は「S3 TP1」と「S3 TP2」と命名されます。

注記： 接点（交点ではなく）は、通常、チューブが公差範囲にあるか否かを定義するために使用されます。

  • 交差点(IP) - 2つのチューブセグメントの軸の交点での理論上の点で、XYZで表現されます。接点と同様に、交点は、それらに関連する直管に対応して、指定されます（例えば、「S2 IP1」、「S2 IP2」）。

  • 管径 - チューブ自体の直径（一般的にはこれらのアプリケーションの既知の値）

  • 曲げ半径 - チューブを曲げるために使用される金型の半径（普段は既知の値）です。

  • B端 - B点とも呼ばれ、管軸上の「最終」測定点です。これは一般的に、チューブに最後で計算された（および測定された）点を定義し、XYZ座標として表されます。

チューブは、一般的にXYZ座標データを使用するCADシステムで設計されます。しかし、チューブベンダーは、チューブを曲げるために、長さ、回転、角度（LRA）と呼ばれる異なるパラメータを使用します。それぞれの定義は以下の通りです：

  • L - 各曲げの前にベンダーに送られた管の量に対応するベンド間の直管部分の長さを定義します。典型的には、これは、特定直管の接点間の距離です。

  1. 曲げ機に供給されるチューブ

  2. チューブは、円形金型の周りで曲げられます。

  • R - 管が異なる平面にベンドを作成するために、その直管軸の周りに受ける回転を定義します。チューブの最初のベンドで、この値は常に0（ゼロ）です。

  • A - チューブが曲がれる角度を定義します。これは、ベンドの両側の2つの直管の間の角度です。

詳細:

A 端部及びB端部

直管の定義及び計測

交点

接点と中点

接点の適合整列


A 端部及びB端部

チューブのA端部及びB端部の点の実例

A端部は管の開始点の測定を説明するために、より広く使用される用語です。B端は、測定が終了する点を説明するために使用される用語です。

ベンダーの加工に使用されるチューブは、円形で剛性を持ったなければなりません。

詳細:

直管の定義及び計測

交点

接点と中点

接点の適合整列


直管の定義及び計測

A - A 端
B - B 端
C - 直管 #1
D - 直管 #2
E - 直管 #3
F - 直管 #4
G - 直管 #5

定義された直管とチューブの例

直管を定義して、測定する前に、以下の情報が知られている必要があります:

  • チューブの直径

  • 直管数

  • すべての曲げ半径

詳細:

A 端部及びB端部

交点

接点と中点

接点の適合整列


交点

A - A 端
B - B 端
C - 直管 #1
D - 直管 #2
E - 直管 #3
F - 直管 #4
G - 直管 #5

交差点I1－I6を示す例

交点は、チューブの中心線とその端面によって定義されます。

詳細:

A 端部及びB端部

直管の定義及び計測

接点と中点

接点の適合整列


接点と中点

A - A 端
B - B 端
C - 直管 #1
D - 直管 #2
E - 直管 #3
F - 直管 #4
G - 直管 #5

直管C - Gの接点TP1 - TP2を示す例

各直管部の接点（T1 - T2）は、チューブの中心線とそれに対応する曲げ半径に基づいています。

中点（MP）は各直管のT1とT2の間の真中にあります。

詳細:

A 端部及びB端部

直管の定義及び計測

交点

接点の適合整列


定義済の接点最適化整列

TubeShaper : Home | TubeShaperの概要 | チューブの用語と基礎 | 定義済の接点最適化整列

接点最適化整列

A - A 端
B - B 端
C - 直管 #1
D - 直管 #2
E - 直管 #3
F - 直管 #4
G - 直管 #5

接点の最適化整列の計算を示す例

最適化は、これら3つの点で達成されます。

  • 直管1の接点

  • 直管Nの接点1 - チューブの最後の直管

  • この2点の間に線を描画し、その後、最適化の三角形を完了するために、一番遠く離れた接点を決定します。

詳細:

A 端部及びB端部

直管の定義及び計測

交点

接点と中点


TubeShaper インターフェイス

TubeShaper : Home | TubeShaperの概要 | TubeShaper インターフェイス

TubeShaper のインターフェース

TubeShaperアプリケーションが初めて起動された場合に、プロジェクトのハブ・ビューが表示されます。

TubeShaperのプロジェクトハブビュー

メインプロジェクトハブビューのハブは、これらのセクションから構成されます：

  1. メインメニューとタイトルバー－現場モード、ツール・オプション、アプリケーション設定とヘルプ・オプションに切り換えるボタンを提供します。アプリケーションを最小化、最大化、及び閉じる標準のウィンドウ機能も利用できます。ユーザがプロジェクトワークスペースにある場合、現在開かれているプロジェクトの名前が左上に表示されます。

  2. メニューペイン - これはプロジェクト、ベンダーおよびプロジェクトレポートにアクセスするオプションです。

  3. プロジェクト一覧エリア - 並べて表示か、または詳細ビューで表示できる保存されたプロジェクトへの選択可能なリンクの一覧です。

  4. プロジェクトの詳細エリア - プロジェクト一覧エリアで現在選択されているプロジェクトに関連する情報を表示します。

  5. プロジェクトメニューバー - 新規プロジェクトを作成するオプションを提供することだけでなく、選択されたプロジェクトをコピー、削除、編集及び測定します。

    6. 注記： 提供の記述がプロジェクトのハブ・ビューのハブに関連していますが、それらはまた、同じようなセクションを持つベンダーハブビュー及びプロジェクトレポートハブビューにも関連されます。

ツールチップ

テキストのないボタンの上にマウスを移動し、ボタンの機能の説明されるツールチップが表示されます。

[新規バージョンが利用可能]メニューボタンの上にマウスを移動するときに、ツールチップが表示される例

詳細

メインメニューバー

プロジェクトメニュータブ

プロジェクト一覧エリア

プロジェクト詳細エリア

プロジェクトメニューバー


メインメニューとタイトルバー

メインメニューとタイトルバーは、TubeShaperロゴとタイトルを左に表示します。

メインメニューやタイトルバーの右側には、TubeShaper機能と標準のボタンのセットが含まれています。左から右へ並べているボタンは次の通りです：

    新規バージョンが利用可能- 新バージョンのソフトウェアが検出された場合のみに、このボタンは使用可能です。これをクリックすると、TubeShaperの最新バージョンがダウンロードされ、インストールされます。TubeShaperのアップデートの詳細については、「アップデートの確認」章を参照してください。

    現場モード - これをクリックして、TubeShaperを現場モードにしてください。現場モードの作業の詳細については、「現場モード」章を参照してください。

    [
    ツール]ボタン - これをクリックすると、[ツール]ダイアログボックスが表示されます。ダイアログボックスは、長さ、曲げ半径、及び直径などの様々なチューブまたはパイプの特性を測定するために使用されます。校正アーティファクトと一緒に使用する場合には、測定システムの精度を確認するために、直管またはチューブ直径タブを使用することができます。ツールダイアログの詳細については、「ツール」トピックを参照してください。

    アプリケーションの設定 - TubeShaper アプリケーションの設定ダイアログボックスを表示して、TubeShaperの外観とアプリケーションのオプションを設定か、調整します。詳細については、「アプリケーションの設定」トピックを参照してください。これらの設定は、すべてのTubeShaperの新規プロジェクトに適用されます。

    注記: 特定のチューブのプロジェクトのプロパティを変更したい場合は、プロジェクトのプロパティビューのslide-outパネルを介して、開かれているプロジェクトのチューブのプロパティを変更する必要があります。

    ヘルプ - これをクリックすると、下記のドロップダウンメニューが表示されます。

      ヘルプ - TubeShaperのヘルプドキュメントを表示します。

      バージョン情報 - TubeShaperアプリケーションに関する情報を表示します。

      更新の確認 - Hexagon Metrologyダウンロードサーバーに接続されるダイアログを表示して、TubeShaperアプリケーションの更新を確認します。TubeShaperアプリケーションのアップデートの詳細については、「アップデートの確認」章の「メインメニューからアップデートの確認」トピックを参照してください。

    左から右へ並べている基準ウインドウボタンは次の通りです：

      最小化 - 現時点のTubeShaperアプリケーションウィンドウをステータスバーに最小化します。

      最大化 - 現時点のTubeShaperアプリケーションのウィンドウを最大化します。

      閉じる - TubeShaper アプリケーションを終了します。

詳細

プロジェクトメニュータブ

プロジェクト一覧エリア

プロジェクト詳細エリア

プロジェクトメニューバー


ハブビューの選択ペイン

ハブビューの選択ペインは、次の3つのTubeShaperハブ画面へのリンクがあります。

プロジェクト - プロジェクトハブ画面には保存されるすべてのTubeShaperプロジェクトの一覧が表示されます。プロジェクト一覧エリアからプロジェクトをシングルクリックして、プロジェクトの詳細エリアのその詳細を表示することができます。新規プロジェクトを作成することができ、既存のプロジェクトを選択することができます。これが選択されると、プロジェクトをコピー、削除、編集、測定及び表示するオプションが利用できます。

ベンダー - TubeShaperアプリケーションに保存されているすべての曲げ加工機のインターフェイスの一覧を示しているベンダーハブ画面を表示します。ベンダーのインターフェイスを作成または設定する方法の詳細については、「ベンダーの設定」トピックを参照してください。

レポート - 作成されたレポートを持っていたすべてのチューブのプロジェクト一覧を示すレポートハブ画面を表示します。プロジェクトのいずれかをクリックして、選択されたプロジェクト用に作成されたすべてのレポート一覧を表示します。レポートを作成、編集、表示、保存または印刷する方法の詳細については「レポート」章を参照してください。

詳細

メインメニューバー

プロジェクト一覧エリア

プロジェクト詳細エリア

プロジェクトメニューバー


プロジェクト一覧エリア

プロジェクト一覧エリアが現在保存されているチューブプロジェクトの一覧から構成されます。左上に位置するプロジェクトの検索フィールドには、この画面の一部です。

TubeShaperのハブビュー画面のプロジェクト一覧エリアの表示

リストは二つのビューに表示することができます：

  • [タイルビュー] ボタン [image] をクリックします。上記に示すように、プロジェクトファイルが並べて表示されます。

  • [詳細ビュー] ボタン [image] をクリックします。以下に示すように、プロジェクトファイルは、詳細ビューに表示されます。

特定のプロジェクトの探し

一覧エリアで表示できるのより多くのプロジェクトがある場合は、垂直のスクロールバーが利用可能になり、手動でプロジェクトをスクロールすることができます。

プロジェクトを見つけるもう一つの方法は、[フィルタ]フィールドを使用することです。

[フィルタ]ボックスに名前またはプロジェクト名の一部を入力します。一致が検出されると、リストが動的に更新されます。入力された文字を含んでいるすべてのプロジェクトは表示されます - 他のすべてのプロジェクトが除外されます。

プロジェクトの新規作成

新しいプロジェクトを作成するには2つの方法があり、両方ともプロジェクト一覧エリアの左下にあります：

  • 左下の[新規プロジェクト]をクリックして、新規プロジェクトのワークスペースを表示します。

  • [インポートでプロジェクトの新規作成]をクリックして新規プロジェクトワークスペースを表示します。ダイアログボックスには、新規プロジェクトにインポートしようのCADモデルの名前と場所の入力が要求されます。

プロジェクトを開くこと

既存のチューニングプロジェクトを開くには2つの方法があります。

  • プロジェクトのワークスペース内のプロジェクトを表示するには、プロジェクト一覧エリアからプロジェクトをダブルクリックします。

  • プロジェクト一覧エリアのプロジェクトタイルをシングルクリックし、プロジェクトのメニューバーの右端に位置する[編集]をクリックします。プロジェクトはワークスペースに表示されます。

詳細

プロジェクトの新規作成

インポートでプロジェクトの新規作成

プロジェクトの編集

メインメニューバー

プロジェクトメニュータブ

プロジェクト詳細エリア

プロジェクトメニューバー


プロジェクト詳細エリア

プロジェクトの詳細エリアには、現在選択されているプロジェクトに関する情報が表示されます。表示される情報は次の通りです：

    作成日 - チューブのプロジェクトが作成された初期の日付。

    作成者 - チューブプロジェクトの作成に使用されたPCにログインした人のログイン名です。

    修正 - チューブプロジェクトが変更された前回の日付と時間スタンプ。

    CADファイル - チューブのプロジェクトに作成か、インポートされたCADファイルの名前。

    ベンダー - プロジェクトに関連付けられた曲げ機の名前。

    指令 - チューブのプロジェクトに特定の指令、メモやコメントです。プロジェクトがプロジェクトのワークスペースで開いている時に、ユーザはプロジェクト/チューブのプロパティ slide-outパネルの[全般]セクションにテキストを入力します。プロジェクト/チューブのプロパティ slide-outパネルの詳細については、「プロジェクト/チューブのプロパティ表示」トピックを参照してください。

TubeShaperが初回に起動される時、ソフトウェアは、デフォルトでは、プロジェクトの一覧エリアの一番目のプロジェクトを選択します。

その詳細を表示するには、プロジェクト一覧エリア内のプロジェクトのいずれかをクリックします。

プロジェクト一覧のサムネイルの更新

プロジェクトの詳細エリアに表示されるチューブは、ライブのCAD図です。CADを回転させると、自動的にビューのエリアに合わせてスナップします。

プロジェクト一覧エリアのプロジェクトのサムネイル画像を変更するには：

  1. 最適表示のためにプロジェクトの詳細エリアでCADを回転させます。

  2. サムネールとして使うボタン [image] をクリックします。プロジェクト一覧エリア内のプロジェクトの関連する画像が更新されます。

詳細

メインメニューバー

プロジェクトメニュータブ

プロジェクト一覧エリア

プロジェクトメニューバー


プロジェクトメニューバー

プロジェクトメニューバーには次のオプションが用意されます。

    新規プロジェクト - 新しいワークスペースに新しいプロジェクトが表示されます。

    インポートでプロジェクトの新規作成 - インポートでプロジェクトの新規作成のリンクをクリックして、CADモデルをインポートするためのCADファイルの参照ダイアログボックスを表示します。CADファイルが選択されると、[開く]をクリックします。CADモデルが開かれ、新規プロジェクトのワークスペースに表示されます。

    コピー - コピーをクリックすると、プロジェクトのコピーダイアログボックスが表示されて、現在選択されているプロジェクト名のコピーを変更します。[OK]をクリックして、新しい名前でプロジェクトのコピーを作成します。新しいプロジェクトは、「プロジェクト一覧」エリアに表示されます。

    削除 - 現時点で選択されているプロジェクトファイルを削除するようにプロジェクトの削除]ダイアログボックスを表示します。

    編集 - チューブデータと測定パラメータがチューブの測定される前に編集できるように、そのワークスペースに選択したプロジェクトを開きます。

    測定 - そのワークスペースに選択したプロジェクトを開き、それがすぐに測定することができるように、ROMER絶対アームに自動的にTubeShaperを接続します。

詳細

メインメニューバー

プロジェクトメニュータブ

プロジェクト一覧エリア

プロジェクト詳細エリア


オンラインでTubeShaperライセンスのアクティブ化

注意：ライセンスをオフラインで有効にするには、クライアントライセンス管理（CLM）ヘルプの「オフラインでライセンスのプロセス」トピックを参照してください。

TubeShaperは起動時にチェックして、有効なライセンスが検出されたかどうかを確認します。有効なライセンスが起動時に検出されない場合、次のメッセージが表示されます。

ライセンスをオンラインで有効にするには：

  1. インストール・メディアまたはユーザのHexagon Metrology社の代理店から提供される25桁の英数字、大文字と小文字を区別する資格IDを入力します。

  2. アクティブボタンをクリックして、アクティブ化のプロセスを開始します。[終了]をクリックすると、TubeShaperアプリケーションが自動的にシャットダウンします。

    3. アクティベーションが成功に処理された後、TubeShaperが使用できるようになります。

  3. 何らかの理由でアクティベーションが成功しない場合、資格IDは正しく入力されていかどうかを確認します。IDは大文字と小文字が区別されることに注意してください。それでも問題が解決されない場合、問題のトラブルシューティングに役立つHexagon Metrology社の代理店にお問い合わせください。

詳細:

TubeShaperの概要

TubeShaper インターフェイス

更新の確認


ショートカットキーの使用

この表は、利用可能なショートカット キーの内容説明を提供しています。各オプションの機能固有の情報については、当文書の該当するセクションを参照して下さい。

ショートカット キー | 説明
レポートの表示
Ctrl+B | レポートがレポートハブ画面から直接に開かれ’た場合にはメインレポートのハブ画面に戻ります。 プロジェクトが開かれている際に、[レポート]タブからレポートを表示する場合は、ソフトウェアはプロジェクトのハブのビューに戻ります。
Ctrl+E | エクスポートダイアログボックスを開く
Ctrl+P (または Print キー) | 印刷ダイアログボックスを開く
Ctrl+S | 自動的に現時点で開いているレポートを保存する
Ctrl+W | 現時点で開いているレポートプロジェクトのプロジェクトワークスペースを表示する
プロジェクトビュー
Ctrl+B | 表示されている最後のマインプロジェクトやレポートビュー画面に戻る
Ctrl+R | 現時点で開いているプロジェクトのレポートビューの画面を表示する
Ctrl+S | 現時点で開いているプロジェクトを自動的に保存する
Ctrl+Z | 自動的にプロジェクトビュー画面に図形を最適化にズームすること


更新の確認

次の方法でTubeShaperアプリケーションの更新を確認することができます：

  • アプリケーションの設定を介して起動時に新しいバージョンの確認をオンにします。起動時にTubeShaperの最新バージョンを確認する方法の詳細については、「起動時に新しいバージョンを確認する」トピックを参照してください。

  • ヘルプ/バージョン情報のメニューオプション [image] を介して手動で更新を確認します。

詳細:

起動時に新しいバージョンの確認

マインメニューからアップデートの有無を確認すること

メインメニューバー


起動時に新しいバージョンの確認

起動時に新しいバージョンの確認はいつでもオンまたはオフにすることができる機能です。TubeShaperアプリケーションが起動されるたびに、オンにすると、TubeShaperの新しいバージョンがダウンロードおよびインストールは利用可能であるかどうかを判断するために、それはHexagon Metrology社のダウンロードサーバをチェックします。新しいバージョンが利用可能ボタン [image] は、新しいバージョンが検出されたとき、メインメニューバーの左側に表示されています。

TubeShaperメインメニューバーは新しいバージョン利用可能というボタンを示します。

スタートアップに新しいバージョンの確認機能を有効にするには：

  1. アプリケーションの設定ダイアログボックスを表示するには、[アプリケーションの設定]ボタン [image] をクリックします。

  2. [詳細設定]タブをクリックします。

    3. アプリケーションの設定ダイアログボックス

  3. 起動時に新しいバージョンの確認チェックボックスをオンにします。

チェックボックスがマークされると、TubeShaperが起動するたびに、それは自動的にHexagon Metrologyダウンロードサーバーをチェックして、新しいアップデートをダウンロードしてインストールします。

新しいバージョンをダウンロードしてインストールするには：

  1. メインメニューバーにある新しいバージョン利用可能ボタンをクリックします。アップデートダイアログボックスが表示されます。

    2. Hexagonソフトウェアの更新ダイアログボックス

  2. 新しいバージョンの詳細が表示されたら、アップデートをダウンロードをクリックTubeShaperの最新バージョンをダウンロードします。

  3. ダウンロードが完了したら、アップデートをインストールをクリックして、ダウンロードされた更新プログラムパッケージをインストールします。インストールが自動的に開始され、TubeShaperが閉じて、その後、更新が完了されると、再起動します。

    4. 今、TubeShaperの最新バージョンがシステムの上で実行されています。

詳細:

更新の確認

マインメニューからアップデートの有無を確認すること

メインメニューバー


マインメニューからアップデートの有無を確認すること

手動でメインメニューからTubeShaperアプリケーションの更新を確認することができます。

  1. 次のメニューを表示するには、[ヘルプ/バージョン情報]ボタン [image] をクリックします：

    2. ヘルプ/バージョンの情報のドロップダウンメニュー

  2. アップデートを確認するオプションをクリックして、更新ダイアログボックスを表示ます。アップデートが利用可能な場合は、その詳細がダイアログに表示されます。

    3. Hexagonソフトウェアの更新ダイアログボックス

  3. 新しいバージョンの詳細が表示されたら、アップデートをダウンロードをクリックTubeShaperの最新バージョンをダウンロードします。

  4. ダウンロードが完了したら、アップデートをインストールをクリックして、ダウンロードされた更新プログラムパッケージをインストールします。インストールが自動的に開始され、TubeShaperが閉じて、その後、更新が完了されると、再起動します。

    5. 今、TubeShaperの最新バージョンがシステムの上で実行されています。

詳細:

更新の確認

起動時に新しいバージョンの確認

メインメニューバー


アプリケーションの設定

アプリケーションの設定ダイアログボックスを表示するには、メインメニューバーの[アプリケーションの設定]ボタン [image] をクリックします。

アプリケーションの設定ダイアログボックスには、さまざまなTubeShaperの設定を変更することに使用される4つのタブがあります。

  • 次のアイテムを定義するには、[全般]タブを使用します。

    • TubeShaperの全部アプリケーションで使用される言語

    • TubeShaperの表示方法を設定するために使用されるテーマ

    • 測定単位

    • 測定精度の等級

    • パスワードの保護

    • 起動制御のTubeShaperのバージョン更新

    • プロジェクト、チューブおよびレポートのデフォルト設定

    [全般]タブの詳細については、「アプリケーションの設定 -[全般]タブ 」トピックを参照してください。

  • プロジェクトワークスペースで作業するとき、表示の設定を定義するために可視性タブを使用します。可視性タブの詳細については、「タブアプリケーションの設定 - 可視性」トピックを参照してください。

  • ワークスペースプロジェクトで作業する場合、[表示]タブを使用して、グラフィックスをカスタマイズします。[表示]タブの詳細については、「アプリケーションの設定- 表示タブを参照してください。

  • チューブ、ベンダーおよびレポートのプロジェクトの保存場所を設定するには、[パス]タブを使用します。[パス]タブの詳細については、「アプリケーションの設定 - パスタブ」トピックを参照してください。

  • デフォルトの要素の公差を定義するには[要素]タブを使用します。要素タブの詳細については、 「アプリケーションの設定 - 要素タブ」トピックを参照してください。

  • 詳細設定タブを使用して、パスワードアクセスを設定し、起動時に更新を確認し、TubeShaperログを有効にします。[詳細設定]タブの詳細については、「アプリケーションの設定 - 詳細設定タブ」トピックを参照してください。

[OK]をクリックして、行った変更を保存するか、またはキャンセルをクリックして、ダイアログを終了します。

詳細:

アプリケーションの設定 - 全般タブ

アプリケーションの設定 - 可視性タブ

アプリケーションの設定 - 表示タブ

アプリケーションの設定 - パスタブ

アプリケーションの設定 - 要素タブ

アプリケーションの設定 - 詳細設定タブ


アプリケーションの設定 - 全般タブ

以下のオプションが利用できます:

    言語 - 言語ドロップダウン一覧からTubeShaperアプリケーションに使用される言語を選択します。ユーザー・インタフェースのテキストを選択された言語に変更するには[完了]をクリックします。

    単位 - TubeShaperが測定に使用している線形および角度の単位を設定します。

    表示される小数点以下の桁数 - プロジェクト内のミリメートルとインチの単位に表示する小数点以下の桁数を入力します。

    注記：角度単位は、この設定によって影響されなくて、常に小数点以下の5桁に表示されています。

    新規プロジェクトのデフォルト - このセクションでは、次のオプションが提供されます：

    • プロジェクト/チューブをクリックして、すべての新規プロジェクトのデフォルトのプロジェクトオプションを表示および設定します。単に現時点で開かれているプロジェクトのみに影響を与えるオプションを設定するには、「プロジェクトのプロパティの表示」を参照してください。

    • レポートのデフォルトをクリックして、すべての新規レポートのデフォルトのレポートオプションを表示および設定します。単に現時点で開かれているレポートのみに影響を与えるオプションを設定するには、「レポート」の章の「レポートオプション」を参照してください。

詳細:

アプリケーションの設定

プロジェクト/チューブデフォルト

レポートオプション


アプリケーションの設定 - プロジェクトのデフォルト

TubeShaper : Home | TubeShaperの概要 | アプリケーションの設定 | アプリケーションの設定 - 全般タブ | プロジェクト/チューブデフォルト

アプリケーションの設定 - プロジェクト/チューブのデフォルト

アプリケーションの設定メイン画面の新規プロジェクトのデフォルトのセクションから、プロジェクト/チューブをクリックして、プロジェクト/チューブ既定値]ダイアログボックスを表示します。

このダイアログで行った設定と値は、すべての新規プロジェクトに適用されます。

注記: 単に現時点で開かれているプロジェクトに適用される変更を加えるには、ヘルプの「プロジェクト/チューブのプロパティビュー」セクションの「レポートオプションのプロパティ」トピックを参照してください。

下記のプロジェクト/チューブのデフォルトアプリケーションの設定と値を設定することができます：

    レポートオプション - このセクションでは、設定できるデフォルトのレポートオプションを定義します。

    • レポートの自動作成 - マークされた場合、チューブを測定するたびにレポートが作成されます。

    • 単位 - 測定されたデータ値が新規レポートの中になりたい線形単位オプションを選択します。たとえば、チューブがmm単位で測定されますが、レポートには、インチになりたいた場合にはインチオプションを選択します。測定単位は、（必要に応じて）すべての新規のレポートにミリメートルからインチに変換されます。

    • 角度単位 - 測定されたデータ値が新規レポートの中になりたい角度単位オプションを選択します。たとえば、チューブが度の単位で測定されますが、レポートには、ラジアンになりたいた場合にはRadオプションを選択します。測定単位は、（必要に応じて）すべての新規のレポートに度からラジアンに変換されます。

    レポートの出力（保存、エクスポートまたは印刷）を設定する方法の詳細については、「レポートオプションのプロパティ」トピックを参照してください。

    公差 - このセクションでは、表示された公差をプロジェクト値を設定するために使用されます。公差範囲のプロパティの詳細については、「公差のプロパティ」を参照してください。

    検査オプション - このセクションでは、表示された検査のオプション及び関連の値を設定するために使用されます。、検査のオプションの設定の詳細についてはは、「検査オプションのプロパティ」トピックを参照してください。

    修正オプション - このセクションは、表示された修正のオプション及び関連の値を設定するために使用されます。、修正オプションの設定の詳細についてはは、「修正オプションのプロパティ」トピックを参照してください。

[OK]をクリックして、すべての変更内容を保存して、次に、アプリケーションの設定ダイアログボックスに戻りします。[キャンセル]をクリックして、保存せずに終了しします。

詳細:

アプリケーションの設定 - 全般タブ

アプリケーションの設定 - レポートオプション


アプリケーションの設定 - デフォルトレポート

TubeShaper : Home | TubeShaperの概要 | アプリケーションの設定 | アプリケーションの設定 - 全般タブ | レポートオプション

アプリケーションの設定 - レポートオプション

アプリケーションの設定メイン画面の新規プロジェクトのデフォルトセクションから、レポートをクリックして、レポートオプションダイアログボックスを表示します。

このレポートオプションダイアログで行った設定と値は、すべての新規レポートに適用されます。

注記: 現時点で開かれているレポートのみに適用されている変更を行うには、「レポートの新規作成」章の「レポートオプション」を参照してください。

オプションのラベルのそれぞれの右側にあるチェックボックスをクリックして、それらを選択します。次のレポートセクションが使用できるようになります。

  • 会社のロゴ

  • CADビュー

  • TPデータ（接点データ）

  • 終了の統計

  • CLRA

  • LRA

  • ALRA

  • XYZ

  • 要素

  • チューブのプロパティ

複数のアイテムを使用したレポートのオプションは3つの設定があります：

  • チェックボックスにチェックマーク [image] が含まれている場合、グループ内のすべてのオプションが選択されています。

  • チェックボックスがソリッド着色されたボックス [image] である場合、グループ内の部分のオプションは選択されます。

  • チェックボックスが空 [image] の場合、グループ内の項目が選択されていません。

レポート内のセクションの順序を変更するには、彼らはご希望の順に編成されているように、[レポートオプション]ダイアログ内の各セクションをクリックして、ドラッグします。すべての新規レポートは、その後行われた変更に基づいて表示されます。

[完了]をクリックして、すべての変更内容を保存して、次に、アプリケーションの設定ダイアログボックスに戻りします。[キャンセル]をクリックして、保存せずに終了しします。

レポートオプションの設定については、「レポート」章の「レポートオプション」を参照してください。

詳細:

アプリケーションの設定 - 全般タブ

アプリケーションの設定 - プロジェクト/チューブのデフォルト


アプリケーションの設定 - 可視性タブ

TubeShaper : Home | TubeShaperの概要 | アプリケーションの設定 | アプリケーションの設定 - 可視性タブ

アプリケーションの設定 - パスタブ

可視性タブには、プロジェクトワークスペース内のラベルをオンかオフにする方法を提供します。

    ラベルの可視性 - ラベルを表示チェックボックスがマークされると、リストされているチューブ部品のラベルを設定できます。

    • オン - ラベルは常に表示される

    • オフ - ラベルが表示されることはない

    • 自動 - 対応のデータ・グリッド・パネルが表示されたときにラベルが自動的に表示される

    交点 - 適切なチェックボックスをマークして、交点ラベルを表示します：

      必要に応じて、実測値または偏差チェックボックスをオンにマークして、実測または偏差の交点のラベルを表示または非表示にします。

詳細:

アプリケーションの設定


アプリケーションの設定 - 表示タブ

[表示]タブには、ワークスペースで作業する場合、グラフィックスが表示されている方法をカスタマイズする方法を提供します。

    テーマ - ユーザはTubeShaperの光や暗いテーマを切り替えることができます。拡大チェックボックスをマークして、ショップフロアモードのようにテキストとアイコンを大きなビューに表示することができます。TubeShaperの現場モードの詳細については、「現場モード」章を参照してください。

    グラフィックスを強化 - 描かれた要素の線幅を設定します。このチェックボックスをマークして要素を有効にして、その後、表示の厚さリストからオプションを選択して、所望の厚さの値を設定します。

    透明性 - チューブグラフィックス用の透明度の割合値を設定し - より高い割合値は、より透明グラフィックが表示されます。スライダーを調整すると、グラフィック表示の設定に応じて、中心線、多かれ少なかれ明らかにすることができます。チューブプロジェクトのグラフィック表示エリアの詳細については、ワークスペースの表示トピックを参照してください。

    ワークスペースの画像と指標の色を設定するには、カラーピッカーを使用することができます。カラーピッカーのオプションは次のとおりです：

      CAD色 - ワークスペース内の任意のインポートされたCADの色を定義します。

      理論色 - ワークスペースからの理論チューブと理論要素の色を定義します。

      測定済の色 - ワークスペースで測定されたチューブと測定された要素の色を定義します。

      色を強調表示 - 現時点で選択されたチューブまたは要素の色を定義します。

      インジケータ色を測定 - チューブの強調表示されたセクションのより具体的な測定エリアの色を定義します。

      不完全な色 - 不完全なチューブの色を定義します。

詳細:

アプリケーションの設定


アプリケーションの設定 - パスタブ

パスタブのオプションはユーザのファイルが保存される場所を定義します。

TubeShaperファイルパスオプションは次のとおりです：

    プロジェクトのパス - TubeShaperプロジェクトのファイルが保存される場所を定義します。

    ベンダーのパス - TubeShaperベンダーのファイルが保存される場所を定義します。

    レポートのパス - TubeShaperレポートのファイルが保存される場所を定義します。

    手動でパスを入力するか、または、[参照]ボタン [image] をクリックして、特定のフォルダの場所に移動するために使用できる[フォルダーの参照]ダイアログボックスを表示します。

詳細:

アプリケーションの設定


アプリケーションの設定 - 要素タブ

[要素]タブを使用して、X、Y、Z、直径、長さ、幅、角度、および3D距離のデフォルトの要素公差値を設定します。

詳細:

アプリケーションの設定


アプリケーションの設定 - 詳細設定タブ

[詳細設定]タブを使って、次のことを行います：

    パスワードアクセスを有効にするチェックボックス - マークされた場合、パスワードの設定ダイアログボックスが表示されます。

    パスワードを入力し、[OK]をクリックして保存します。必要な場合、それが利用できることを保証するために、パスワードをどこかの安全な場所に保存されていることを確認します。

    注記：パスワードが忘れられた場合は、Hexagon Metrology 社にテクニカルサポートにお問い合わせて、一時的なパスワードを請求してください。一時的なパスワードを受け取った後、[アプリケーションの設定]ボタンをクリックし、パスワードの変更をクリックして、一時的なパスワードを入力します。その後、新規パスワードを入力して、もう一度新規パスワードを確認しように指示さます。

    Hexagon Metrology 技術サポートの連絡情報

    オンラインの技術サポートはhttp://hexagonmetrology.us/contact-us からか、またはwww.pcdmis.comへのアクセスで提供されます。

    また、1-800-343-7933の電話番号で Hexagon Metrology 社のテクニカルサポートへ問い合わせることも可能です。

    スタートアップに新規バージョンを確認チェックボックス - マークされて、且つ、インターネットに接続している場合、毎回TubeShaperが起動されるたびに、それは、新しいバージョンをダウンロードしてインストールするために利用可能であるかどうかを確認するためにHexagon Metrologyサーバに接続されます。アップデートの詳細については、「アップデートの確認」章を参照してください。

    ログを有効にするチェックボックス- マークされた場合、TubeShaperが発生可能のある問題についての情報をログに記録します。ログファイルは、システムのデバッグに役立つようにHexagon Metrologyのテクニカルサポートに送信することができます。ログファイルのパス]ボックスを使って、新規場所を入力するか、または、[参照]ボタンを使って、ログファイルが格納される場所の位置を変更します。

詳細:

アプリケーションの設定


ツール

マインニューバーからツールボタン [image] をクリックします。

ツールダイアログ ボックス

ツールダイアログボックスは、長さ、曲げ半径、及び直径などの様々なチューブまたはパイプのプロパティを測定するために使用されます。校正アーティファクトと一緒に使用する場合には、測定システムの精度を確認するために、直管またはチューブ直径タブを使用することができます。

次のオプションがタブから利用できます。

    チューブ直径タブ - チューブまたはパイプの未知の直径を測定するために使用されます。このオプションが校正アーチファクトに使用される場合は、測定システムの精度を決定することもできます。また、チューブ管径タブを使用して、チューブのリバースエンジニアリングすることもできます。

    直管タブ - チューブまたはパイプ上の直管管長を測定するために使用されます。このオプションが校正アーチファクトに使用される場合は、測定システムの精度を決定することもできます。直管タブの詳細については、「直管タブ」を参照してください。

    直管ツールは、時々スプリングバックを決定することに必要とされます。計算された直管の管長はスプリングバックタブの切断長さの値になります。スプリングバックタブの詳細については、「スプリングバックビュー」トピックを参照してください。

    曲げ半径タブ - チューブまたはパイプ上の未知の曲げ半径を測定するために使用されます。チューブをリバース・エンジニアリングする場合には、このオプションが便利です。

各タブの詳細は、この章の個々のトピックに説明されます。

詳細:

チューブ直径タブ

直管タブ

曲げ半径タブ


管径タブ

直管部を測定するには：

  1. マインニューバーからツールボタン [image] をクリックします。

  2. 管径タブを選択すると、管径画面が表示されます。

  3. 測定ボタン [image] をクリックし、ダイアログボックスの下部に沿う指示に従って円筒の2箇所を測定して、その直径を決定します。

    4. 注意:グラフィックビューは、ゴールドのカラーで測定すべきエリアを表示します。赤いエリアの箇所は直管か、曲げ外側のエッジに近づきすぎないように、ユーザにお知らせします。

    標準の3ボタンROMERアームの機能の詳細については、「ROMERアームボタン」トピックを参照してください。

    当該の指令は、円筒上に測定されるヒット数の推奨最小値を示します。より良い精度を取得するため、必要に応じてより多くのヒットを取ることができます。

    [停止]ボタン [image] をクリックするたびに、測定のプロセスが終了されます。

    注記：測定のプロセスの詳細については、「チューブの測定」トピックを参照してください。

  4. 管径ボックスに表示されるデータを確認します。必要に応じて再測定します。

  5. [保存]をクリックして、測定を受け入れます。この測定値は、チューブの作成ダイアログボックスの管長一覧に追加されます。

    6. OK をクリックしてダイアログ ボックスを閉じます。まず、必要に応じて測定値が保存されたことを確実してください。

詳細:

ツール

直管タブ

曲げ半径タブ


直管タブ

直管部を測定するには：

  1. マインニューバーからツールボタン [image] をクリックします。

  2. 直管部タブを選択すると、直管部の画面が表示されます。

  3. 測定ボタン [image] をクリックして、ダイアログボックスの下部に沿って指示に従って直管部の必要な要素を測定します。

    4. 注意:グラフィックビューは、ゴールドのカラーで測定すべきエリアを表示します。赤いエリアの箇所は直管か、曲げ外側のエッジに近づきすぎないように、ユーザにお知らせします。

    標準の3ボタンROMERアームの機能の詳細については、「ROMERアームボタン」トピックを参照してください。

    指令は、測定される直管部と両端の推奨ヒット数の最小値を示します。より良い精度を取得するため、必要に応じてより多くのヒットを取ることができます。

    [停止]ボタン [image] をクリックするたびに、測定のプロセスが終了されます。

    注記：測定のプロセスの詳細については、「チューブの測定」トピックを参照してください。

  4. 直管の管長ボックスに表示されるデータを確認します。必要に応じて再測定します。

  5. [保存]をクリックて、保存された測定値を受け入れます：

    • チューブを作成ダイアログボックスの管長リスト

    • プロジェクトプロパティのslide-outパネルの物性セクションのチューブ切断長さリスト

    • スプリングバックslide-outパネルのチューブ切断長さリスト

    OK をクリックしてダイアログ ボックスを閉じます。まず、必要に応じて測定値が保存されたことを確実してください。

詳細:

ツール

チューブ直径タブ

曲げ半径タブ


曲げ半径タブ

曲げ半径を測定するには：

  1. マインニューバーからツールボタン [image] をクリックします。

  2. 曲げ半径タブを選択すると、曲げ半径の画面が表示されます。

  3. 測定ボタン [image] をクリックして、ダイアログボックスの下部の指示に従って測定を行います。

    4. 注意:グラフィックビューは、ゴールドのカラーで測定すべきエリアを表示します。赤いエリアの箇所は直管か、曲げ外側のエッジに近づきすぎないように、ユーザにお知らせします。

    標準の3ボタンROMERアームの機能の詳細については、「ROMERアームボタン」トピックを参照してください。

    指令は、測定する直管部と曲線部の推奨されるヒット数の最小値を表示します。より良い精度を取得するため、必要に応じてより多くのヒットを取ることができます。

    [停止]ボタン [image] をクリックするたびに、測定のプロセスが終了されます。

    注記：測定のプロセスの詳細については、「チューブの測定」トピックを参照してください。

  4. 測定が完了すると、推定の曲げ半径ボックスに表示されているデータを確認します。必要に応じて再測定します。

  5. [保存]をクリックして、測定を受け入れます。この測定値は、チューブの作成ダイアログボックスの曲げ半径の一覧に追加されます。

    6. OK をクリックしてダイアログ ボックスを閉じます。まず、必要に応じて測定値が保存されたことを確実してください。

詳細:

ツール

チューブ直径タブ

直管タブ


プロジェクトの新規作成

チューブプロジェクトの新規作成には2つの方法があります：

  • CADモデルなしで新しいチューブ・プロジェクトを作成します。詳細については、「リバースエンジニアリングによってチューブの新規作成」トピックを参照してください。

  • インポートされたCADモデルで新しいチューブ・プロジェクトを作成します。詳細については、「インポートでプロジェクトの新規作成」トピックを参照してください。

メイン画面から[新規プロジェクト]をクリックして、空のプロジェクトワークスペースを表示します。

インポート無しのCADモデルを使用する新規プロジェクトワークスペースの例

プロジェクトワークスペースは、それの後にアスタリスク（*）を付けている左上にあるプロジェクトのデフォルトのタイトルが表示されます。アスタリスクは、プロジェクトが新しいか、または変更が保存されていないプロジェクトに行われたことをユーザにお知らせします。

プロジェクトワークスペースのさまざまなセクションの詳細については、「新規プロジェクトインターフェイス」トピックを参照してください。

この画面の右下の[保存/エクスポートメニューボタン [image] をクリックすると、プロジェクトを保存か、エクスポートすることができます。

プロジェクトの保存とエクスポートの詳細については、「プロジェクトの保存とエクスポート」章の該当するトピックを参照してください。

この時点で[戻る]ボタン [image] がクリックされると、名前を付けて保存]ダイアログボックスが表示されます。

専用の名前を入力し、[はい]をクリックして保存します。[いいえ]をクリックすると、保存せずに終了するか、またはキャンセルがクリックされると、ダイアログを終了して、プロジェクトに戻ります。

詳細

新規プロジェクトのインターフェース

スプリングバックチューブプロジェクトの新規作成

データを手動入力で、チューブを新規作成すること

リバースエンジニアリングによってチューブの新規作成

インポートでチューブプロジェクトの新規作成

ベンダーの設定


新規プロジェクトのインターフェース

TubeShaper : Home | プロジェクトの新規作成 | 新規プロジェクトのインターフェース

新規プロジェクトのワークスペース

新しいプロジェクトが作成されと、空のプロジェクトワークスペースが表示されます。

新規プロジェクトのワークスペース

プロジェクトワークスペースの画面の構成要素は以下のとおりです：

    メインメニュー及びタイトルバーエリア - このエリアの詳細については、「ワークスペースのナビゲーションエリア」トピックを参照してください。

    図形操作ツールバー - このツールバーの詳細については、「図形操作ツールバー」トピックを参照してください。

    ワークスペースエリア - このエリアの詳細については、「ワークスペースの表示」トピックを参照してください。適切なタブをクリックして、そのワークスペースか、またはそのレポートビューで、現在のプロジェクトを表示することができます。

    Slide-outパネルおよびツールバー - slide-outパネルやツールバーの詳細については、この章の「スライドアウトパネルツールバー」を参照してください。

    プロジェクトステータスエリア - このエリアの詳細については、「プロジェクトステータスエリア」トピックを参照してください。

    アクションバー - アクションバーの詳細については、「プロジェクトのアクションバー」トピックを参照してください。

詳細:

ワークスペースのナビゲーションエリア

グラフィカルな操作ツールバー

ワークスペース画面

スライドアウトパネルツールバー

プロジェクトステータスエリア

プロジェクトのアクション バー


ワークスペースのナビゲーションエリア

注記:プロジェクトタイトルのテキストの色がオレンジ色の場合は、チューブ要素の定義が不完全で、プロジェクトを保存することはできません。チューブ要素のデータセットを更新して、問題が修正されると、プロジェクトを保存します。

ワークスペースのナビゲーションエリアには、新しいプロジェクトの名前及び次の機能が表示されます：

    [戻る]ボタン - これをクリックすると、プロジェクトハブ画面に戻ります。

    変更がプロジェクトになされ、そして、戻るボタンが次を保存する前にクリックされた場合：

    • プロジェクトは新しく、以前に保存されたことがいない場合は、名前を付けて保存ダイアログが表示されます。

      • 専用の名前を入力し、[はい]をクリックして保存します。[いいえ]をクリックすると、保存せずに終了するか、またはキャンセルがクリックされると、ダイアログを終了して、プロジェクトに戻ります。

    • 行った変更を保存したいなら、プロジェクトが以前に保存されたことがある場合には、ユーザに注意する警告ダイアログが表示されます。

      • [はい]をクリックして、変更を保存してから、プロジェクトのハブビュー画面に戻ります。[いいえ]をクリックして、変更内容を保存せずにダイアログ及びプロジェクトを終了します。ダイアログを終了し、プロジェクトに戻るには、[キャンセル]をクリックします。

    [ワークスペース]タブ - これをクリックするとワークスペース画面を表示します。詳細については、「ワークスペースの表示」を参照してください。

    [レポート]タブ - クリックすると、現在のプロジェクトのレポート画面を表示します。詳細については、「レポート」章を参照してください。

詳細:

グラフィカルな操作ツールバー

ワークスペース画面

引き出しパネルツールバー

プロジェクトステータスエリア

アクション バー


グラフィカルな操作ツールバー

グラフィカルな操作ツールバーは、ワークスペースビューのデータをコントロールし、操作するために使用される4つのボタンで構成されています。

グラフィカルな操作ツールバー

ツールバーには、これらの4つのボタンで構成されます：

    ズーム - これをクリックすると、画面は拡大されます。必要に応じて適切なマウスボタンを使て、ワークスペースにグラフィックを中央に移動します。

    パン - マウスの右ボタンに移動の機能を割り当てます。

    3D回転 - マウスの右ボタンにセンターの周りに3D回転させる機能を割り当てます。

    2D回転 - マウスの右ボタンにセンターの周りに2D回転させる機能を割り当てます。

    画面サイズに拡大 - ワークスペースエリアで画面サイズを最大化するためにグラフィックを中心に合わせてズームします。

    グラフィックビュー - グラフィカル・ビューのワークスペースでパーツを表示するために使用されるグラフィック表示オプションを備えたメニューが表示されます：

      グラフィックスの強化はグラフィックスの強化値を切り替えします。アプリケーションの設定で強化されたグラフィックスオプションの詳細については、「アプリケーションの設定 - 表示タブ」トピックを参照してください。

      中心線のみ中心線及び中心線に関連するすべてのアイテムを表示するようにグラフィック表示を切り替えます。

      X+ ビュー X+ ビューを表示します。

      X- ビュー X- ビューを表示します。

      Y+ ビュー Y+ ビューを表示します。

      Y- ビュー Y- ビューを表示します。

      Z+ ビュー Z+ ビューを表示します。

      Z- ビュー Z- ビューを表示します。

      等角投影図は、等角図を示します。

      グリッドは、グラフィカル・ビューワークスペースで3Dグリッドを切り替えます。

      ワイヤフレーム/シェーディングはソリッドとワイヤーフレームビューの間にグラフィックスを切り替えます。

      ワイヤフレームエッジはパーツに太い輪郭を追加することにより、サーフェスのエッジを強化します。

標準マウス機能

注記： 次は、TubeShaperアプリケーションの標準マウス機能を記述します。これらの機能の説明は、マウス・ボタンの定義される方法によって異なる場合があります。

標準TubeShaperグラフィカルなマウス操作は、次のとおりです：

    マウスの左ボタン - このボタンをクリックし、保持して、それから、マウスカーソルを移動すると、ワークスペース内のグラフィックのエリアのまわりに選択ボックスが描画されます。このボタンが放されると、選択されたエリア内のすべてのグラフィックコンポーネントが選択されたことを示すために強調されます。

    マウスの右ボタン - このボタンをクリックし、保持して、それから、マウスカーソルを移動すると、ワークスペース内の図形が移動されます。図形はマウスカーソルと同じ方向に移動されます。

    中央マウスホイール - マウスホイールの回転された方向によって図形を拡大か、または縮小します。

    中央マウスのホイールボタン - このボタンをクリックし、保持して、それから、マウスカーソルを移動すると、ワークスペース内の図形が回転されます。

詳細:

タイトルとナビゲーションのエリア

ワークスペース画面

引き出しパネルツールバー

プロジェクトステータスエリア

アクション バー


ワークスペースビュー

TubeShaperワークスペースビュー

ワークスペースビューはチューブの図形を表示し、3D操作をなさるところです。ワークスペースビューでは、インポートされたCADモデル、測定の幾何要素、挿入された値から生成されたチューブなどを操作することができます。

開いたときにワークスペースビューはTubeShaper画面の全体を占有します。

測定された中心線は理論値と測定値のビューに常に見えられて、アプリケーションの設定から透明度スライダーを使用して、より明らかにすることができます。

透明度が50％に設定されている中心線を示すチューブの公称ビュー

透明度が100％に設定されている中心線を示すチューブの公称ビュー

詳細:

タイトルとナビゲーションのエリア

グラフィカルな操作ツールバー

引き出しパネルツールバー

プロジェクトステータスエリア

アクション バー


スライドアウトパネルツールバー

TubeShaper : Home | プロジェクトの新規作成 | 新規プロジェクトのインターフェース | スライドアウトパネルツールバー

Slide-outパネルツールバー

Slide-outパネルツールバー

Slide-outパネルのツールバーは、6つの異なるslide-outパネルから構成されます。

    データビューボタンは次のようなチューブのデータを表示するために使用されます。

    • XYZは、チューブの交点のデータを表示する座標値

    • チューブ直管部のデータを表示するためのLRA値

    • チューブ直管部の絶対LRA値のデータを表示するALRA値

    このslide-outパネルの詳細については、「チューブデータの表示」トピックを参照してください。

    接点ボタンは、チューブが測定された後の接点のエラーを表示するために使用されます。このslide-outパネルの詳細については、「接点データの表示」トピックを参照してください。

    CLRAボタンは補正されたチューブの曲げパラメータを表示するために使用されます。このslide-outパネルの詳細については、「修正のLRAデータグリッドビュー」トピックを参照してください。

    プログラムビューは平面、円などのような幾何要素を測定、構築及び編集することに使用されます。このslide-outパネルの詳細については、「プログラムビュー」トピックを参照してください。

    この特定のプロジェクトの任意のチューブのプロパティを表示および編集するためのプロジェクト/チューブプロパティ。これらのプロパティの多くは、アプリケーションの設定エリアで指定することができます。このslide-outパネルの詳細については、「プロジェクトのプロパティの表示」トピックを参照してください。

    スプリングバックボタンは、プロジェクトのスプリングバックと伸び率の値を表示、選択および計算するために使用されます。このslide-outパネルの詳細については、「スプリングバックの表示」トピックを参照してください。

    レポートオプションボタンは、チューブプロジェクトのレポートオプションを設定するために使用されます。このslide-outパネルの詳細については、「レポートオプションビュー」トピックを参照してください。

    slide-outパネルは、新規プロジェクトを作成するための重要な部分です。パネルが表示されていない場合、上記のいずれかのボタンをクリックします。は、現在アクティブなボタン（ティールに表示される）をクリックしてパネルを非表示にします。非アクティブなボタンは黒で表示されます。

詳細

チューブデータの表示

接点データの表示

CLRA データ ビュー

プログラムビュー

プロジェクト/チューブのプロパティの表示

スプリングバックの表示

レポートオプションの表示

データを手動入力で、チューブを新規作成すること


チューブデータの表示

XYZデータ・グリッドを示すデータビューのslide-outパネル

異なるデータの詳細を表示するには：

  1. データビューボタン [image] をクリックして、データビュー slide-outパネルを表示します。

  2. XYZ/ LRA/ ALRA選択ポップアップメニューを表示するには、slide-outパネルの右上に位置するXYZ/ LRA/ ALRAボタン [image] をクリックしてください：

  3. データセットを選択して、利用可能なオプション（XYZ、LRA及びALRA）を表示します。パネル・ビューは、それに応じて更新されます。

  4. 必要に応じて直管を追加 [image] か、または直管を削除 [image] をクリックします。行が新規追加されると、それは選択された行を複製します。各セルをクリックして、その値を更新します。

    5. 新しい行を追加する場合：

    • TubeShaperは選択された行の前に行を新規作成します。

    • 行が選択されていない場合、TubeShaperは最後の行の前に新しい行を追加します。

    行を削除する場合には：

    • 行が選択されていない場合、TubeShaperは最後の行を削除します。

    • 最後の行が選択された場合は、その上の行は、最後の行になります。この行では、TubeShaperは曲げ角度と半径の値を0（ゼロ）にリセットします。

    注記: ワークスペースのグラフィックはアプリケーションの設定に基づいて、プロジェクトの詳細（例えば交点と接点など）を表示します。

    リバースエンジニアリングボタン [image] はマスターチューブを作成するために使用することができます。チューブをリバースエンジニアリングする方法の詳細については、「リバースエンジニアリングによるチューブの新規作成」トピックを参照してください。

    チューブの反転ボタン [image] はチューブの部品を逆転するために使用することができます。クリックすると、A端とB端はすぐに交換されます。他のすべてのチューブ部品（IP、TPなど）はそれに応じて番号が付け直されます。

    チューブをミラーリングボタン [image] はY平面に沿ってチューブをミラーリングするために使用することができます。クリックすると、チューブはすぐに反映されます。

    公称チューブのプロパティセクションでは、これらのプロパティが表示されます：

    • 両端間の距離

    • 端部間の角度

    • 管長

    グリッド内のデータを更新する場合、公称チューブのプロパティセクションの情報も、それに応じて更新されます。

詳細:

スライドアウトパネルツールバー

接点データの表示

CLRA データ ビュー

プログラムビュー

プロジェクト/チューブのプロパティの表示

スプリングバックの表示

レポートオプションの表示


接点データの表示

接点ボタン [image] をクリックして、接点のslide-outパネルを表示します。接点のslide-outパネルは、チューブが測定された後、プロジェクトの接点（TP）エラーを表示するために使用されます。

接点表示のslide-outパネル

詳細:

スライドアウトパネルツールバー

チューブデータの表示

CLRA データ ビュー

プログラムビュー

プロジェクト/チューブのプロパティの表示

スプリングバックの表示

レポートオプションの表示

データを手動入力で、チューブを新規作成すること


CLRA データ ビュー

CLRAボタン [image] をクリックして、CLRAのslide-outパネルを表示しします。

修正LRA（CLRA）データslide-outパネル

CLRAデータ slide-outを使って、チューブが測定された後にプロジェクトの修正長さ（L）、回転（R）及び角度（A）の詳細を表示します。

チューブ長さ情報のグリッドは、現在のチューブに特定の長さのデータを表示します。隠されたプロパティを表示するには、グリッドの右側に垂直スクロールバーを使用します。

次のプロパティは、このセクションに記載されます：

  • チューブの実測長さ - 測定されたチューブの中心線の長さと、編集することはできません。

  • 展開の管長 - CLRAデータから計算され、編集することはできないチューブの長さ。

  • チューブのカットの長さ - それが曲げられる前の直管の長さ。新しい値を入力するか、またはリストから選択することができます。

  • 管長の差 - これはチューブの展開長さとチューブのカット長さとの差で、この値を編集することはできません。

  • A端違いタグ - 管長の差値からB端違いタグ値を引くの値で、これを編集することができます。B端違いタグ値は、それに応じて自動的に更新されます。

  • B端違いタグ - 管長の差値からA端違いタグ値を引くの値で、これを編集することができます。この値は、管長の差値よりも大きくすることはできません。また、管長差の割合を追加するには、B端違いの割合フィールドか、またはスライダを使用することができます。

  • B端違いの割合 - B端の違いタグに適用される管長差値の割合で、これを編集することができます。右のボックスの上に置くと、スライダーが使用可能になります。また、B端の違いタグフィールドを使って、管長差値の一部または全部をB端の差値に追加するすることができます。

変更が編集可能なプロパティのいずれかに行われた場合、セルの外側をクリックして、自動的にプロパティの新規値を適用します。変更がB端差の割合に行われた場合は、[適用]ボタン [image] をクリックして、その新規値を格納します。A端差タグフィールドの値は、最初の直管部に適応され、B端差タグフィールドの値は最後の直管に適用されます。

様々な管長のプロパティのグラフィカルビューを含む詳細については、「物理的プロパティ」トピックを参照してください。

チューブが測定された後か、またはCLRAデータを再計算するために管長のプロパティに変更が行われた場合、更新 [image] をクリックします。「完璧」のチューブを生成するように、管の定義を送信ボタン [image] をクリックすることで、データはベンダーに送り返すことができます。プロジェクトアクションバーボタンの詳細については、「プロジェクトアクションバー」トピックを参照してください。

データが最後に更新された時の値にデータをリセットするには、[元に戻す] [image] をクリックします。

[リセット] [image] をクリックして、CLRAデータをマスターCLRA値に戻します。

重要：スプリングバックと伸びの値が適用されていない場合のみに、マスターCLRAデータにリセットすることができます。彼らが適用されている場合、LRAデータは、実際のマスター値とわずかに異なります。

注記： チューブカット長さは常に理論管長より長いです。このため、常に余分の長さが最初の直管部および／または最後の直管部（A/B端部の長さ違いタグ）にあります。チューブがこの余分な長さを補償せずに測定された場合、端間の長さ（AとB端部の間の距離）は交差範囲外になります。A / B端違いタグ値は、実際の管長を反映するために、端間の管長の計算に使用されます。これは次のCLRAデータセットに間違ったチューブ補正を入力することを防ぐことができます。

詳細:

スライドアウトパネルツールバー

チューブデータの表示

接点データの表示

プログラムビュー

プロジェクト/チューブのプロパティの表示

スプリングバックの表示

レポートオプションの表示

データを手動入力で、チューブを新規作成すること


プログラムビュー

プログラムのビューボタン [image] をクリックして、プログラムビュー slide-outパネルを表示します。

プログラムビューのslide-outパネル

プログラムビューのslide-outパネルには、プロジェクト・測定ルーチンのツリービューが表示されます。作成や構築された要素は、寸法や整列の詳細が記載されています。

以下のオプションが利用できます:

    要素 - 要素バーを表示します。測定された要素の作成の詳細については、「要素の測定」トピックを参照してください。

    整列 - 整列バーを表示して、測定ルーチンで様々な整列を作成します。整列を作成の詳細については、「整列の作成」トピックを参照してください。

    構築 - 構造バーを表示して、要素を構築します。構築済の要素の詳細については、「要素の構築」トピックを参照してください。

    寸法 - 寸法バーを表示して、要素間の直線と角度の寸法を作成します。寸法作成の詳細については、「寸法」を参照してください。

    ユーティリティ - ユーティリティバーを表示して、測定ルーチンにプローブプロンプトやコメントを追加します。プローブプロンプトを追加する方法の詳細については、「測定ルーチンへのプローブプロンプトの追加」トピックを参照してください。コメントの追加についての詳細は、「測定ルーチンへのコメントの追加」を参照してください。

詳細:

スライドアウトパネルツールバー

チューブデータの表示

接点データの表示

CLRA データ ビュー

プロジェクト/チューブのプロパティの表示

スプリングバックの表示

レポートオプションの表示

データを手動入力で、チューブを新規作成すること


プロジェクト/チューブのプロパティの表示

プロジェクト/チューブのプロパティのslide-outパネル

[プロジェクト/チューブプロパティ]ボタン [image] をクリックして、プロジェクト/チューブのプロパティslide-outパネルを表示します。非チューブ要素を有するプロジェクトが開かれている場合、レポートオプションのセクションだけが表示されます。

プロジェクト/チューブのプロパティslide-outパネルは現在のプロジェクトのプロパティを検討や編集するために使用されます。プロパティへの変更は現在開かれているプロジェクトのみに影響を与えます。

注：すべての新規プロジェクトのプロパティを変更するには、アプリケーションの設定ダイアログボックスを開きます。アプリケーションの設定ダイアログボックスの詳細については、「アプリケーションの設定」を参照してください。

プロジェクト/チューブのプロパティslide-outパネル内のセクションでは、次のとおりです：

  • レポートオプションのプロパティ - このセクションでは、レポートに関連するデフォルトのオプションを定義します。レポートオプションの詳細については、「レポートオプションのプロパティ」トピックを参照してください。

  • 汎用プロパティ - 一般的なプロジェクト情報（例えば品番）を入力するために使用されます。詳細については、「汎用のプロパティ」を参照してください。

  • 物性 - 下記のようなチューブの物性の詳細を入力します：

    • チューブ直径

    • A端とB端の拡張/縮小された直径及び管長

    • A 部とB端のオフセット長さ

    様々な管長のプロパティのグラフィカルビューを含む詳細については、「物理的プロパティ」トピックを参照してください。

  • 公差プロパティ - 接点と交差点及び校正封筒の投影公差値を入力します。詳細については、「公差値のプロパティ」トピックを参照してください。

  • 検査オプションのプロパティ - 次のオプションが提供されています：

    • 自動シングルモードまたはマニュアルモード検査を選択すること

    • 最大円筒適合のしきい値の設定

    • 最大交差測定誤差値の設定

    • A端とB端の検査をスキップするかどうかを設定すること

    • A端およびB端の工具オフセットをオンかオフにすること

    詳細については、「検査オプションのプロパティ」を参照してください。

  • 修正オプションのプロパティ - 次のオプションが提供されています：

    • 局部の長さ訂正、局部の回転訂正と局部の角度訂正をオンかオフにします。

    • 衝突長さの修正及び衝突角度の修正値の設定

    • 固定スプリングバック値の設定

    • 比例スプリングバック割合値の設定

    • チューブ伸び率値の設定

    詳細については、「修正オプションのプロパティ」トピックを参照してください。

詳細:

スライドアウトパネルツールバー

レポートオプションのプロパティ

汎用のプロパティ

物理的な属性

公差のプロパティ

検査オプションのプロパティ

修正オプションのプロパティ

チューブデータの表示

接点データの表示

CLRA データ ビュー

プログラムビュー

スプリングバックの表示

レポートオプションの表示


レポートオプションのプロパティ

このダイアログで行った設定と値は現時点で開いているプロジェクトのみに適用されます。

注記:すべての新規プロジェクトに適用される変更を行うには、ヘルプの「アプリケーション設定」セクションの「プロジェクト/チューブの既定値」トピックを参照してください。

下記のプロジェクト/チューブのデフォルトアプリケーションの設定と値は次のように設定することができます：

  • レポートの自動作成 - マークされた場合、チューブを測定するたびにレポートが作成されます。

  • 単位 - 測定されたデータ値が新規レポートの中になりたい線形単位オプションを選択します。たとえば、チューブがmm単位で測定されますが、レポートには、インチになりたいた場合にはインチオプションを選択します。測定単位は、（必要に応じて）すべての新規のレポートにミリメートルからインチに変換されます。

  • 角度単位 - 測定されたデータ値が新規レポートに表示される角度単位オプションを選択します。たとえば、チューブが度の単位で測定されますが、レポートには、ラジアンになりたいた場合にはRadオプションを選択します。測定単位は、（必要に応じて）すべての新規のレポートに度からラジアンに変換されます。

詳細:

プロジェクト/チューブのプロパティの表示

汎用のプロパティ

物理的な属性

公差のプロパティ

検査オプションのプロパティ

修正オプションのプロパティ


汎用プロパティ

このパネルの一般プロパティセクションには、現在のプロジェクトに関連する汎用情報を提供します。このセクションのオプションは次のとおりです：

    品番 - チューブのCADモデルが作成されていないか、またはプロジェクトにインポートされていない限り、ソフトウェアは、デフォルトでは品番ボックスにプロジェクトのファイル名を挿入します。CADモデルは、プロジェクトの一部である場合は、プロジェクトに割り当てられている品番は、CADモデルの名前と同じです。

    特定のチューブベンダーからチューブをリコールする場合に品番は、特に重要です。ベンダーからチューブをリコールの詳細については、「ベンダーから公称データのリコール」を参照してください。

    指令 - ユーザはチューブのプロジェクトに特定の手順、メモやコメントを入力することができます。

詳細:

プロジェクト/チューブのプロパティの表示

レポートオプションのプロパティ

物理的な属性

公差のプロパティ

検査オプションのプロパティ

修正オプションのプロパティ


物理的な属性

プロジェクト/チューブのプロパティ slide-outパネルの物理的プロパティのセクションでは、処理されるチューブの物理的特性に関する情報を提供します。チューブの長さの実測値及び理論値の特性を除いて、すべての値は編集できます。

パネルのこのセクションのプロパティは次のとおりです：

    チューブ直径

    A-端部の拡張/収縮の直径

    A-端部の延長/収縮の長さ

    B-端部の拡張/収縮の直径

    B-端部の拡張/収縮の長さ

    クリックして、拡大または縮小端部を有するチューブの例を見ます：

    A- チューブの拡大端部の直径
    、B - チューブの縮小端部の直径
    、C - A端部
    、D- 拡大部と縮小部の長さ（少なくとも最初の測定は、チューブのこの部分に取る必要がある）
    、E - 管径

    拡大と縮小の端部を有するチューブの詳述例

    A端のオフセット長さ

    B端のオフセット長さ

    正のオフセット長さ値が使用された場合の説明例

    • 実際の物理的な管端は端部ブラケットに埋め込まれるか、または...

    • プラグが管端に挿入することができない場合（例えば、負のオフセット長さ）

    実際の管端位置が測定できないので、接触プローブは、平面上のブラケットを測定するために使用されます。正のオフセット長さは測定面から管の実際端点までの距離に等しいです。それが測定面の位置から、測定管長に追加されます。

    クリックして、正のオフセット長さを有するチューブの例を表示する：

    A - チューブの物理端部
    B - チューブの部分がブラケットに埋め込まれているので、実際の先端位置を測定することができない。
    C - 正のオフセット長さのチューブ端点なので、実際のチューブの端部と同点で、ここで算出されます。
    D - 正の端部オフセット長さ
    E - 正のオフセット長さにおいて、チューブの端部がブラケットの平面において、接触プローブを使用することで、ここで測定することができます。

    正のオフセット長さを有するチューブの詳述例

    負のオフセットの長さ値は、チューブの端部が大きすぎるので、チューブプローブを用いて測定できない場合に使用されます。例えば、フランジは管の端部にあるが、チューブの端部は、とにかく測定する必要がある場合。プラグは、より小さい直径を有するチューブの端部に入れて、チューブプローブによって測定することができます。すると、オフセットの長さは、プラグの長さに等しいです。チューブ端部が測定される際には、プラグの端から測定されます。オフセット長さ値は、管端の真の位置を計算するために、管長から減算されます。

    クリックして、負のオフセット長さを有するチューブの例を表示する：

    A - プラグは、管の端部の内側に配置される
    B - チューブの実体端末（直径が大きすぎるので、チューブプローブで測定できない）
    C - 正の端部のオフセット長さ
    D - 負のオフセット長さであるので、チューブ端点は、ここで算出されて、実際のチューブの端部と同じ点に置ける
    E - 管端がここで測定される必要がある。

    正または負のオフセット長さを有するチューブの詳述例

詳細:

プロジェクト/チューブのプロパティの表示

レポートオプションのプロパティ

汎用のプロパティ

公差のプロパティ

検査オプションのプロパティ

修正オプションのプロパティ


公差プロパティ

プロジェクトプロパティのslide-outパネルの検査オプションセクションでは、プロジェクトの公差値に専用のプロパティ設定を提供します。

このパネルのプロパティは次のとおりです：

    接点/検定封筒 - 新規または既存のプロジェクトの接点の公差を定義します。

    交点 - 新規または既存のプロジェクトの交点の公差を定義します。

    端部間のオフセット公差- 端部間オフセットの公差を定義します。

    端部間角度誤差の公差- 端部間角度誤差の公差を定義します。

    A端の長さの検定封筒 - A端の長さ誤差は、実測管のA端と公称管のその投影点の間の距離です。A端の長さ検定封筒は、このエラーに課せられた公差値です。

    B端の長さの検定封筒 - B端の長さ誤差は、実測管のB端と公称管のその投影点間の距離です。B端の長さ検定封筒は、このエラーに課せられた公差値です。

    A端オフセットの検定封筒の公差 - A端検定封筒のオフセット誤差の公差値を定義します。

    B端オフセットの検定封筒の公差 - B端検定封筒のオフセット誤差の公差値を定義します。

    A端角度検定封筒 - A端の角度誤差は、公称チューブの第一の直管と測定の第一の直管の間の角度です。A端角度検定封筒は、角度誤差の許容値です。

    B端角度検定封筒 - B端の角度誤差は、公称チューブの第一の直管と測定の第一の直管の間の角度です。B端角度検定封筒は、角度誤差の許容値です。

詳細:

プロジェクト/チューブのプロパティの表示

レポートオプションのプロパティ

汎用のプロパティ

物理的な属性

検査オプションのプロパティ

修正オプションのプロパティ


検査オプションのプロパティ

プロジェクトのプロパティのslide-outパネルの検査オプションセクションでは、プロジェクトの検査オプションに固有のプロパティ設定を提供します。

このパネルのプロパティは次のとおりです：

    測定モード - プロジェクトの測定モードを選択するには、ドロップダウン矢印をクリックしてください。

      自動シングルモード - 自動シングルモードで実行するには、このオプションを選択します。自動シングルモードでチューブを測定する場合、測定（点）は、チューブの単側のみに取られます。スイープごとに2点が記録されています。それぞれの直管の場合、一つのスイープ（2点）がA端から始まり、B端に向かって作業して、直管の両端付近から取られます。スイープが成功になされた後、アームは直管のもう一方の端を測定するために、プロンプトを表示する音がします。各直管の二つのスイープが成功になされた後、アームは次の要素、端部または直管を測定するために、成功の音をし、プロンプトも示されます。直管または端部計測が失敗した場合、故障音が発生し、プロンプトが表示される上で直管またはエンド測定を再び開始します。

      このモードでは、TubeShaperそれぞれの成功計測の後に自動的に次の測定に進めることがマニュアルモードとは異なります。こうして、簡単かつ迅速にチューブを測定することができます。

      自動シングルモードでは、単精度および倍精度のプローブタイプ）を使用することができます。

      注記:自動シングルモードでは、チューブの直径が測定されていない場合があることに注意してください。チューブの中心線は、各ビームからのチューブ半径距離として決定されます。これは、何らかの理由で、歪められ、非円などの管の測定は手動モードで倍精度プローブを使用する場合より、それほど精確になりません。

      手動モード - このオプションを選択すると、TubeShaperのデフォルトの測定モードである手動モードで実行することができます。このモードでは、それぞれの直管又はチューブの端部にご要望の点数を取ることができます。各スイープにダウンプローブをなるべく前進させることによって、チューブの両側にデータを取る努力をするべきです。

    最大円筒フィット閾値 - チューブの構成円筒と端面を測定する場合に適用される許可の最大円筒フィット閾値を設定するために使用されます。測定値がこの値を超えると、警告が表示されます。デフォルト値は0.750 mmです。

    最大交差測定誤差 - 警告が発生する前に測定された直管の中心線と前の直管の中心線との間の最大誤差距離を設定します。これは、3次元空間内の2つの直線の間の最短距離に基づいて計算されます。デフォルト値は2.000 mmです。

    A端をスキップ - マークされたときにA端の測定検査をスキップすることを可能にします。これはチューブが一端に取り付けられている場合に特に役に立ちます（例えば、排気管がエンジンブロックに取り付けられる時）。

    B端部をスキップ - マークされたときにB端面の測定検査をスキップすることを可能にします。

    A端のツールオフセット - 端部ツールがパイプのA端に接続されている場合、ツールオフセットが作成されます。このオプションが選択される場合は、チューブのA端のツールオフセットの検査は有効になります。

    B端のツールオフセット - それは、パイプのB端に適用される以外、A端のツールオフセットと同じです。

    これをクリックして端部ツールが使用される曲げ加工の詳細を表示します。

    A - 計算されたA端の位置
    B - A端のツール

    端部ツールが使用される曲げ加工の実例

詳細:

プロジェクト/チューブのプロパティの表示

レポートオプションのプロパティ

汎用のプロパティ

物理的な属性

公差のプロパティ

修正オプションのプロパティ


修正オプションのプロパティ

プロジェクト/チューブのプロパティ slide-outパネルの修正オプションセクションでは、測定データに特定の修正を適用する設定を提供します。

このパネルのプロパティは次のとおりです：

    部分長補正 - マークされた場合、次が真であれば、直管部の長さは修正されます：

    • 公称値は衝突の修正長さ以上です。

    • 取得された修正値は修正の衝突長さ以上です。

    部分的な回転補正 - マークされた場合、次が真であれば、回転値が修正されます:

    • 回転を形成するすべての3つの連続した直管の管長の公称値は、修正の衝突長さ以上です。

    • 回転の両側に2つの曲げ角の公称値は、補正競合角度以上です。補正競合角度を10〜20度のいずれかの値に設定します。

    部分的な角度補正 - マークされた場合、曲げの両側にある2つの直管管長の公称値が補正衝突の長さ以上である場合には、曲げ角度の値は修正されます。

    注記: 部分的な角度補正は補正衝突角度の値に影響されません。

    補正競合長さ - 局部の長さ補正チェックボックスがマークされるときに使用される長さの制限です。

    補正競合角度 - 局部の角度補正チェックボックスがマークされるときに使用される角度の制限です。

    固定スプリングバック - 曲がり度あたりのスプリングバックの量。値は、チューブの材料に依存しており、0〜360（両端を含む）の範囲です。

    比例スプリングバック割合 - パーセンテージで示されるスプリングバック値で、曲げ角度に比例しています。値の範囲は、0 - 100（両端を含む）です。

    チューブ伸び率 - 曲がり度あたりの管伸長率。値は、チューブの材料に依存しており、0〜100（両端を含む）の範囲です。

詳細:

プロジェクト/チューブのプロパティの表示

レポートオプションのプロパティ

汎用のプロパティ

物理的な属性

公差のプロパティ

検査オプションのプロパティ


スプリングバックの表示

スプリングバックボタン [image] をクリックして、スプリングバックのslide-outパネルを表示します。

スプリングバックslide-outパネル

スプリングバックのslide-outパネルは、新しい固定スプリングバック、比例スプリングバック割合及びチューブ伸び率の値を計算するために使用されます。チューブプロジェクトは、これらの新しい値を計算するには、有効な測定データを格納する必要があります。

新しいスプリングバック値の計算

スプリングチューブプロジェクトの新規スプリングバック値を計算するには：

  1. プロジェクトハブビュー画面のプロジェクト一覧エリアから、標準的なスプリングチューブプロジェクトの一つを開きます。測定する前に、物理的なスプリングチューブの寸法を反映するようにチューブのプロジェクトを準備する必要があります。必要に応じて、ツールメニューで関数を使用して、管長、曲げ半径と直径を測定します。

    2. 注：特にスプリングバックの値のセットを計算するために使用される以外、スプリングチューブプロジェクトは任意の他のチューブのプロジェクトと本質的に同じです。また、それは、屈曲部の一定数（典型的には二つ - 60度、120度）に限定されて、回転はありません 。

    TubeShaperは、2つの標準的なスプリングバックのチューブ・プロジェクトで出荷されます： ２つの曲がり角（20-120度）と4つの曲がり角（10-20-60-120度）。

  2. チューブデータビューのslide-outパネルのLRAデータビューからチューブの直径、曲げ半径または直管部の長さを変更することにより、スプリングチューブの値セットを編集します。あるいは、スプリングバックのslide-outパネルからチューブ切断長さ、曲げ半径またはチューブの直径値を編集することができます。

    1. チューブ切断長さフィールドは、測定された値を表示するはずです。手動で新規の値を入力するか、またはドロップダウンリストを使って、格納された値を選択することで（これは以前に[ツール]メニューオプションから測定した場合）、当該の値はチューブ切断長さフィールドで編集することができます。

    2. 終了したら、フィールドの右にある[適用]ボタンをクリックします。新しいチューブ切り取り長さは自動的にプロジェクトに適用されます。

    3. 手動で新規の値を入力するか、またはドロップダウンリストを使用し、格納された値を選択して（それは[ツール]セクションで、以前に測定した）、曲げ半径フィールドに、現在の曲げ半径値を編集します。

    4. 終了したら、フィールドの右にある[適用]ボタンをクリックします。次の警告メッセージが表示されます：

    5. [OK]をクリックして、適用するか、またはキャンセルをクリックしてダイアログを終了します。

    6. 手動で新規の値を入力するか、またはドロップダウンリストを使用し、格納された値を選択して（それは[ツール]セクションで、以前に測定した）、管径フィールドに、現在の管径値を編集します。

    7. 終了したら、フィールドの右にある[適用]ボタンをクリックします。次の警告メッセージが表示されます：

  3. スプリングチューブは現在、測定の準備ができました。プロジェクトアクションバーで[実行]ボタン [image] をクリックします。（ROMERアームを備えたチューブを測定する方法の詳細については、チューブの測定トピックを参照してください）。

  4. 測定が完了されると、スプリングバック値を計算ボタン [image] をクリックしてください。固定スプリングバック、比例スプリングバック割合及びチューブの伸び率値はすべてそれに応じて更新されます。

  5. スプリングバックを保存ボタン [image] をクリックして、他のプロジェクトで使用するスプリングバック値の新しいセットを保存します。スプリングバックデータは、現在開いているプロジェクトの名前で保存されます。必要に応じてドロップダウンフィールドをクリックして、現在の名前を編集するか、または新しい名前を入力することができます。

新しいスプリングバック値が計算され、保存されると、当該の値は任意のプロジェクトに利用可能です。

既存のチューブプロジェクトにスプリングバック値を適用します。

重要：スプリングバックと伸びの値が適用されていない場合のみに、マスターCLRAデータにリセットすることができます。彼らが適用されている場合、LRAデータは、実際のマスター値とわずかに異なります。

既存のプロジェクトにスプリングバック値を適用するには：

  1. プロジェクトハブビュー画面のプロジェクトの一覧エリアから、新しいスプリングバック値を適用したいチューブプロジェクトを開きます。

  2. チューブを測定します。（ROMERアームを備えたチューブを測定する方法の詳細については、チューブの測定トピックを参照してください）。

  3. スプリングバックビューボタン [image] をクリックして、スプリングバックのslide-outパネルを表示します。

  4. スプリングバック値セット名一覧から該当するファイルを選択します。スプリングバック値のセットが自動的にプロジェクトに適用されます。

  5. プロジェクトに加えられた更新を保存するには、画面の右下の[保存/エクスポート] [image] をクリックします。

注記: スプリングバック値セットの名前のファイルを変更したり、スプリングバックのいずれかの値を編集したりするたびに、CLRA値が自動的に再計算されます。

詳細:

スライドアウトパネルツールバー

チューブデータの表示

接点データの表示

CLRA データ ビュー

プログラムビュー

プロジェクト/チューブのプロパティの表示

レポートオプションの表示

スプリングバックチューブプロジェクトの新規作成


レポートオプションの表示

レポートオプションビュー slide-outパネルを表示するには、レポートオプションボタン [image] をクリックします。

加えた変更は、単に現在開いているプロジェクトのために作成された新しいレポートのみに影響します。

レポートオプションの設定については、「レポート」章の「レポートオプション」を参照してください。

レポートの設定オプションは、アプリケーションの設定ダイアログからアクセスすることもできます。レポートの設定及びプロジェクトの設定の詳細については、「アプリケーションの設定」章を参照してください。

注記:アプリケーションの設定を介して行われた変更は、単に新しいプロジェクトのみに影響を与えます。

スライドアウトパネルツールバー

チューブデータの表示

接点の表示

CLRA データ ビュー

プログラムビュー

プロジェクトプロパティの表示

スプリングバックの表示

スプリングバックチューブプロジェクトの新規作成


プロジェクトステータスエリア

プロジェクトのステータスエリアは、slide-outパネルと画面の右下にあるアクションバーの間に位置しています。

ステータスエリアの機能は、次のことをユーザにお知らせます：

  • 実行されているモード（オンラインまたはオフライン）

  • プロジェクトに設定した単位（ミリメートルまたはインチ）

オフラインで実行すると、ステータスエリアには、オフラインメッセージと単位が表示されます。

オンラインの時、ステータスエリアには、アームとユニットのXYZ位置が表示されます。

詳細:

タイトルとナビゲーションのエリア

グラフィカルな操作ツールバー

図形ワークスペース

Slide-outパネルツールバー

アクション バー


プロジェクトのアクション バー

アクションバーには、グラフィカル・ワークスペースとの対話を初期化するプロジェクトの機能を実行するボタンが表示されます。

下記のボタンは利用可能になります：

    プログラムを測定/停止ボタン - このボタンをクリックすると、チューブの測定が開始されます。幾何要素（穴、平面など）の測定も請求された場合は、プログラムを測定/停止ボタンをクリックすると、チューブと要素の測定プロセスを開始します。ボタンがクリックされた時には、ボタンは実行の停止ボタン [image] に変更されます。実行の停止ボタンをクリックすると、チューブの測定が停止し、ボタンは実行ボタンに復元します。実行を停止ボタンがチューブ計測の途中に押された場合、以前のすべての管測定が復元されます。

    再計算ボタン -ボタンは単に管が正常に測定された場合のみに有効になります。これをクリックすると、チューブのCLRAデータが再計算されます。

    ベンダーに送信ボタン - 選択した曲げ機にローカルのチューブ定義データを送信します。曲げ機が定義され、設定され、選択された場合のみにボタンは有効になります。

    使用可能なベンダーリスト - システムで定義されたベンダーのポップアップ一覧を表示します。現在のプロジェクトのリストからマシンを選択します。現在のプロジェクトのリストからマシンを選択します。ベンダーが選択されると、TubeShaperは、ベンダーの接続をテストします。接続が正常に機能している場合、ベンダー名が緑色で表示されます。接続の試行中に問題が発生した場合、ベンダー名が赤色で表示されます。

    ベンダーからリコールボタン - 選択された曲げ機からチューブ定義のデータを取得します。曲げ機が定義され、設定され、選択された場合のみにボタンは有効になります。

    エクスポート/保存のメニューボタン - こいがクリックされると、保存/エクスポートメニューが表示されます。

    プロジェクトの保存とエクスポートの詳細については、「プロジェクトの保存とエクスポート」章の該当するトピックを参照してください。

    デフォルトでは、すべてのプロジェクトファイルは次のローカルフォルダーに保存されます：「C:\Users\Public\Documents\WAI\TubeShaper」

    TubeShaperファイルの保存場所及び場所を変更する方法の詳細については、「アプリケーションの設定」を参照してください。

    ビュー選択ボタン - ビュー選択ボタンがクリックされると、ビュー選択ポップアップメニューを表示します。

    このメニューは、図形のワークスペースに表示されるものを選択するために使用されます。

    オプションは以下のとおりです：

    • CADビュー - CADモデルがプロジェクトにインポートされた場合のみに使用できます。CAD図形ビューは紫色で表示されます。

    • 公称値ビュー - これは公称値が手動で入力されるか、曲げ機から取得されたか、またはインポートされたCADモデルから抽出されたときに利用可能になります。公称値の図形ビューは青緑色で表示されます。

    • 測定ビュー - チューブが測定された後で利用可能になります。測定された図形ビューはチャコール色で表示されます。

      • 注記：インポートしたCADモデルのない新規プロジェクトは初期の名目ビューのみを表示します。チューブ用の名目が作成され、曲げ機を介して実行されると、測定値ビューは利用可能になります。

詳細:

タイトルとナビゲーションのエリア

グラフィカルな操作ツールバー

図形ワークスペース

引き出しパネルツールバー

プロジェクトステータスエリア


データを手動入力で、チューブを新規作成すること

チューブを新規作成するには：

  1. TubeShaperメイン画面から[新規プロジェクト]をクリックして、空のプロジェクトワークスペースを表示します。

  2. 空のデータグリッドslide-outパネルは、ワークスペースの右側に表示されます。チューブの正しいデータ型にデータビューを選択します。例えば:

    • LRAの値が入力される場合、XYZ/LRA (YBC)/ALRAボタン [image] をクリックし、LRAのオプションを選択します。

    • 交差点のXYZ座標を入力する場合は、XYZ/LRA (YBC)/ALRAボタン [image] をクリックし、XYZのオプションを選択します。

  3. 直管を追加ボタン [image] をクリックして、チューブの作成ダイアログボックスを表示します。

    4. チューブに直管数、曲げ半径及び管径にを挿入します。管径または曲げ半径が知られていない場合は、[ツール]ボタン [image] をクリックして、それらを測定します。ツールオプションの詳細については、「ツール」章の該当するセクションを参照してください。

    管が一端または両端にキャップやプラグを持っている場合は、以下のオプションを表示するには、[詳細設定オプション]ボタン [image] をクリックします。

    必要に応じて、次の更新を行います：

    1. 拡大/縮小の長さフィールドに値を入力します。拡大と縮小の長さの詳細については、「物理的なプロパティ」トピックを参照してください。

    2. 拡大/縮小の直径フィールドに値を入力します。拡大と縮小の直径の詳細については、「物理的なプロパティ」トピックを参照してください。

    3. A端とB端のオフセット長さ値を入力します。A端とB端のオフセット長さの詳細については、「物理的なプロパティ」トピックを参照してください。

    4. どちらかの端の測定をスキップしたい場合は、適切なスキップ端の測定チェックボックスをマークします。端面の測定をスキップする方法の詳細については、「端面測定のスキップ」トピックを参照してください。

    注記：プラグインがいずれかの端に追加された場合にもオフセット長さは負でなければなりません。A端に30ミリメートルのプラグインを追加すると、A端のオフセット長さの値は-30でなければならなりません。

  4. 作業が完了したときに表示されるLRAまたはXYZデータビューオプションを選択します。

  5. 完了された時、OKをクリックしてください。データ値を入力するためのデータグリッドの準備ができました。プロジェクト・タイトルはオレンジ色に変わり、データグリッドは、オレンジ色の枠で囲まれており、メッセージは、不完全なデータセットであることをお知らせします。

    6. slide-outパネルが非表示になる場合、「不完全チューブ」というメッセージはワークスペースのステータスエリアに表示されます。

  6. 各セルをクリックし、各チューブセクションの値を入力します。各行間に移動するには、キーボードのTabキーを使用します。データが追加されると、ワークスペース内のグラフィックが自動的に更新されます。すべてのセルが有効な値を含む場合、タイトルは通常のティール色に戻って変更し、オレンジ色のボックス及びメッセージが消えます。

    7. 注記: LRA (YBC)データビューパネルの最後行の最後の2つのセルは、更新する必要はありません。値は最後の直管のこれらの2つのセルの意味を保持していないので、ハイフン文字が挿入されます。

    チューブが無効である場合（入力された値は、チューブに自分自身をプレッツェルの形に曲げることを引き起こす場合など）、赤いボックスは、データグリッドの周りに表示されます。エラーの簡単な説明というメッセージがグリッドの下に表示されます。

    パネルを閉じた場合には、「無効なチューブ」というメッセージもまた、ワークスペースのステータスエリアに表示されます。

    チューブを検証するために適切な修正を行います。

  7. 間違えた場合は、直管を追加ボタン [image] クリックするか、または必要に応じて直管を削除]ボタン [image] をクリックします。新しい行を追加することによって、新規の直管を作成すると、選択した行が複製されます。各セルをクリックして、その値を更新します。

    8. 新しい行を追加する場合：

    • TubeShaperは選択された行の前に行を新規作成します。

    • 行が選択されていない場合、TubeShaperは最後の行の前に新しい行を追加します。

    行を削除する場合には：

    • 行が選択されていない場合、TubeShaperは最後の行を削除します。

    • 最後の行が選択された場合は、その上の行は、最後の行になります。この行では、TubeShaperは曲げ角度と半径の値を0（ゼロ）にリセットします。

    注記: ワークスペースのグラフィックはアプリケーションの設定に基づいて、プロジェクトの詳細（例えば交点と接点など）を表示します。

  8. チューブが定義されると、[プログラムを実行/停止]ボタン [image] をクリックして、測定を開始します。

  9. プロジェクトのワークスペースの右下に置ける保存/エクスポートメニューボタン [image] をクリックします。

    プロジェクトの保存とエクスポートの詳細については、「プロジェクトの保存とエクスポート」章の該当するトピックを参照してください。

詳細:

端の測定をスキップすること

チューブデータの表示

接点データの表示

CLRA データ ビュー

プログラムビュー

プロジェクト/チューブのプロパティの表示

スプリングバックの表示

レポートオプションの表示


端の測定をスキップすること

端部の測定をスキップすることはチューブがマニホールドに装着されたような場合に必要になります。端部測定をスキップチェックボックスは、この目的のために使われることができて、チューブのA端またはB端に適用することができます。

端部の測定をスキップするチェックボックスを示すチューブの作成ダイアログボックス

A端の端部測定のスキップチェックボックスがマークされると、測定ルーチンは、その端末を測定するプロンプトを表示しません。この代わりに、測定シーケンスは次のとおりです：

  1. 直管 1 パス 1

  2. 直管 1 パス 2

  3. 直管 2 パス 1

  4. 直管 2 パス 2など

    1. 管端の真の位置は問題にならない場合、端部の測定をスキップします。チューブが端部にブラケットを持っているか、または別の部品に固定されている場合に、これが発生することがあります。

    2. 二つのスワイプは、チューブの直管を測定するようになされます。

    3. チューブの端点は、現在最も極端な測定点で算出されます。

    注記: これらの場合にいつも（整列に端点を使用しない）接点最適化アライメントを使用することをお勧めします。

    端部の測定をスキップチェックボックスがマークされている例

注記： また、手動でプローブの中央ボタンの長押しで端部の測定をスキップすることができます。詳細については、「ROMERアームボタン」トピックの「例外」セクションを参照してください。

詳細:

データを手動入力で、チューブを新規作成すること


リバースエンジニアリングによってチューブの新規作成

物理的な「マスター」チューブ（または「ゴールデンパーツ」）がTubeShaperには公称管として使用することができます。この方法では、すべての管の測定は、このマスタパーツと比較することができます。

マスターチューブは問題のチューブをリバースエンジニアリングすることによって、作成されます。

  1. メイン画面の[プロジェクトメニュー]バーから[新規プロジェクト]をクリックします。空白の新規プロジェクトのワークスペース画面が表示されます。

  2. TubeShaperがすでにROMERアームに接続されている場合は、チューブの作成ダイアログボックスを表示するには、データビューのslide-outパネルで見つかったリバースエンジニアリング]ボタン [image] をクリックします。直管を追加ボタン [image] をクリックすると、オフライン作業に便利するこのダイアログボックスが表示されます。

    3. 管が一端または両端にキャップやプラグを持っている場合は、詳細オプションを表示するには、[詳細設定オプション]ボタン [image] をクリックします。

    必要に応じて、次の更新を行います：

    1. 拡大/縮小の長さフィールドに値を入力します。拡大と縮小の長さの詳細については、「物理的なプロパティ」トピックを参照してください。

    2. 拡大/縮小の直径フィールドに値を入力します。拡大と縮小の直径の詳細については、「物理的なプロパティ」トピックを参照してください。

    3. A端とB端のオフセット長さ値を入力します。A端とB端のオフセット長さの詳細については、「物理的なプロパティ」トピックを参照してください。

    4. どちらかの端の測定をスキップしたい場合は、適切なスキップ端の測定チェックボックスをマークします。端面の測定をスキップする方法の詳細については、「端面測定のスキップ」トピックを参照してください。

    注記：プラグインがいずれかの端に追加された場合にもオフセット長さは負でなければなりません。A端に30ミリメートルのプラグインを追加すると、A端のオフセット長さは-30でなければならなりません。

  3. チューブに直管数、端面半径及び管径を挿入します。

  4. 作業が完了したときに表示されるLRAまたはXYZデータビューオプションを選択します。用意ができた時にOKをクリックして下さい。

  5. 手順に従って画面に示したチューブを測定します。

    6. 注記：ソフトウェアが175度以上の角度を検出した場合、アームが通知音を発し、命令は、画面の下部に表示されます。指示に従って、検出された曲げエリアを測定し、その後、第二の直管を再度に測定します。これは、正確な測定が記録されることを保証します。

詳細:

ベンダーから公称値データのリコール

インポートでプロジェクトの新規作成

ベンダーの設定

プロジェクトの編集

要素の作成

要素の構築

整列の作成

チューブの測定


ベンダーから公称値データのリコール

公称チューブは曲げ機に保存されるチューブファイルから生成されることができます。

曲げ機を定義して設定する必要があります。詳細については、「ベンダーの設定」トピックを参照してください。

ベンダーが定義され、設定された後では：

  1. ハブビューの選択ペインからベンダーをクリックします。

  2. ベンダー一覧セクションから適切な曲げ機を選択します。

  3. 選択されたベンダーからのチューブファイルの詳細をリコールするにはベンダーからリコールボタン [image] をクリックします。ベンダーからリコールダイアログボックスが表示されます。

  4. 品番ボックスに、チューブの品番を入力した後、[OK]をクリックして、チューブの詳細をリコールします。プロジェクト/チューブのプロパティslide-outパネルの[全般]セクションから特定のプロジェクトの品番を見つけることができます。プロジェクトのプロパティの詳細については、「プロジェクト/チューのブプロパティの表示」を参照してください。

    5. 同じ品番を有するチューブプロジェクトがすでに定義されている場合は、警告メッセージが表示されます。

    • [OK]を選択して、既存の管プロジェクトと同じ名前を備えるプロジェクトのワークスペースからリコールされたチューブを開きます。

    • [キャンセル]を選択して、ダイアログを終了します。

  5. チューブプロジェクトが保存されると、プロジェクトメニュータブからプロジェクトをクリックして、次に新規プロジェクトをクリックして、空白の新規プロジェクトワークスペース画面を表示します。

  6. 曲げ機のポップアップリストを表示するには、アクションバーで利用可能なベンダーリストボタン [image] をクリックします。リストから適切なベンダーを選択します。プロジェクトワークスペースには今、曲げ機からリコールされたチューブの公称ビューが表示されます。

  7. 必要に応じて公称データセットを更新します。

詳細:

リバースエンジニアリングによってチューブの新規作成

インポートでプロジェクトの新規作成

ベンダーの設定


インポートでプロジェクトの新規作成

インポートされたCADモデルでチューブ・プロジェクトを新規作成します。

インポートされたCADファイルでプロジェクトを新規作成するには：

  1. TubeShaperメイン画面のプロジェクトメニューバーから[インポートでプロジェクトの新規作成]をクリックします。ファイルの参照ダイアログが表示されます。

  2. ファイルフィルタドロップダウンを使用して目的のファイルの種類を選択し、次に、そのCADファイルに移動して、それをクリックして選択します。

    3. TubeShaperTubeShaperは、次のファイルタイプを支援しています：

      • ACIS ファイルタイプ: *.sab, *.sat

      • AutoCAD ファイルタイプ: *.dxf, *.dwg

      • BLM ファイルタイプ: *.blm

      • Catia ファイルタイプ: *.3dxml, *.cat, *.CATPart, *.CATProduct, *.exp, *.iso, *.mod

      • 通用 CAD ファイルタイプ: *.iges, *.igs, *.jt, *.des, *.stp, *.step, *.stl, *.vda, *.xyz

      • DOCS ファイルタイプ: *.ds

      • GTube ファイルタイプ: *.gtt

      • Inventor ファイルタイプ: *.iam, *.ipt

      • ParaSolid ファイルタイプ: *.x_t, *.x_b, *.xmt_txt, *.xmt_bin

      • PC-DMIS ファイルタイプ: *.cad, *.draw

      • ProE ファイルタイプ: *.prt, *.xas, *.xpr

      • SolidEdge ファイルタイプ: *.asm, *.par

      • SolidWorks ファイルタイプ: *.sldasm, *.sldprt

      • SupraVision ファイルタイプ: *.$$$

  3. [開く]をクリックして、新規チューブプロジェクトとしてプロジェクトワークスペースにCADモデルをインポートします。チューブの形状は自動的に抽出されます。

  4. 必要に応じて、必要な操作を実行します。

  5. 完了されると、、[保存]をクリックして、新規プロジェクトを保存するか、またはエクスポートします。プロジェクトの保存とエクスポートの詳細については、「 プロジェクトアクションバー」トピックを参照してください。

詳細:

プロジェクトの新規作成

新規プロジェクトのインターフェース

スプリングバックのプロジェクトの新規作成

リバースエンジニアリングによってチューブの新規作成

プロジェクトの保存とエクスポート

ベンダーの設定

プロジェクトの編集

測定要素の作成

要素の構築

整列の作成

チューブの測定


スプリングバックチューブプロジェクトの新規作成

注：特にスプリングバックの値のセットを計算するために使用される以外、スプリングチューブプロジェクトは任意の他のチューブのプロジェクトと本質的に同じです。また、それは、屈曲部の一定数（典型的には二つ - 60度、120度）に限定されて、回転はありません 。

TubeShaperは、2つの標準的なスプリングバックのチューブ・プロジェクトで出荷されます： ２つの曲がり角（20-120度）と4つの曲がり角（10-20-60-120度）。

二つのスプリングバックチューブプロジェクトはTubeShaperのすべてのライセンスに標準装備されています。しかし、ご希望の場合、また、スプリングバックのプロジェクトを新規作成することができます。これをするには、以下の操作を行います:

  1. TubeShaper画面のいずれかで、メインメニューバーから[ツール]ボタン [image] をクリックすることで、チューブの切断長さを測定します。

  2. [ツール]ダイアログの直管タブを選択し、測定ボタン [image] をクリックし、画面の下部の指示に従ってください。

  3. プロジェクト画面から、スプリングバックボタン [image] をクリックして、スプリングバックビューのslide-outパネルを表示します。

  4. チューブカット長フィールドは、ステップ2で測定された値を表示するはずです。しかし、現在のチューブカット長さの値は、手動で新規の値を入力するか、またはドロップダウンリストを使用することにより格納された値を選択して（これは以前に[ツール]メニューオプションから測定した場合）、チューブカット長さフィールドで編集することができます。

  5. 終了したら、フィールドの右にある[適用]ボタンをクリックします。新しいチューブ切り取り長さは自動的にプロジェクトに適用されます。

  6. 手動で新規の値を入力するか、またはドロップダウンリストを使用し、格納された値を選択して（それは[ツール]セクションで、以前に測定した）、曲げ半径フィールドに、現在の曲げ半径値を編集します。

  7. 終了したら、フィールドの右にある[適用]ボタンをクリックします。次の警告メッセージが表示されます：

  8. [OK]をクリックして、適用するか、またはキャンセルをクリックしてダイアログを終了します。

  9. 手動で新規の値を入力するか、またはドロップダウンリストを使用し、格納された値を選択して（それは[ツール]セクションで、以前に測定した）、管径フィールドに、現在の管径値を編集します。

  10. 終了したら、フィールドの右にある[適用]ボタンをクリックします。次の警告メッセージが表示されます：

  11. [OK]をクリックして、適用するか、またはキャンセルをクリックしてダイアログを終了します。

  12. TubeShaper画面の左下に位置する測定/停止プログラムボタン [image] をクリックしして、スプリングチューブの測定を開始します。画面の下部に沿う指示に従ってください。

  13. 測定が完了されると、スプリングバック値を計算ボタン [image] が有効になります。スプリングバック値を計算ボタンをクリックして、スプリングバック値の新しいセットを生成ます。

  14. スプリングバック値セット名フィールドはデフォルトで現在開いているプロジェクトの名前になります。必要に応じて、スプリングバック値の新しいセットを識別するように専用名で名前を更新します。

  15. 画面の右下に位置する保存/エクスポートメニューボタン [image] をクリックし、必要に応じて変更の内容を保存します。

    プロジェクトの保存とエクスポートの詳細については、「プロジェクトの保存とエクスポート」章の該当するトピックを参照してください。

いったん保存されると、スプリングバック値セット名ドロップダウンリストから選択することによって、スプリングバック値の新規セットが任意のチューブプロジェクトに適用することができます。

詳細:

プロジェクトの新規作成

新規プロジェクトのインターフェース

データを手動入力で、チューブを新規作成すること

リバースエンジニアリングによってチューブの新規作成

インポートでプロジェクトの新規作成


プロジェクトの保存とエクスポート

プロジェクトのワークスペース画面の右下に置ける保存/エクスポートメニューボタン [image] をクリックします。

開いたプロジェクトへの変更が保存されていない時に、ユーザがプロジェクトワークスペースを終了しようとする場合は、警告メッセージが表示されます。

変更されたプロジェクトを保存するための警告メッセージ

  • [はい]を選択して、既存のチューブプロジェクトと同じ名前でプロジェクトを保存すます。

  • [いいえ]を選択して、プロジェクトワークスペースを終了します。プロジェクトに加えた変更は保存されません。

  • [キャンセル]を選択して、ダイアログを終了する一方、プロジェクトワークスペースのままにしてください。

保存/エクスポートメニューボタンをクリックして、次のメニューを表示します。

保存及びエクスポートのメニュー

    保存 - 現在開いているプロジェクト名でプロジェクトに変更を保存します。プロジェクトは新しく、以前に保存されていない場合は、名前を付けて保存ダイアログが表示されます。

    名前を付けて保存 - [名前を付けて保存]ダイアログボックスが表示されます。

    名前を付けて保存ダイアログ ボックス

    プロジェクト専用の名前を入力し、[完了]をクリックして、それを保存します。プロジェクトファイルは、アプリケーションの設定ダイアログで指定された場所に保存されます。

    TubeShaperファイルの保存場所及び場所を変更する方法の詳細については、「アプリケーションの設定」を参照してください。

    エクスポートオプションは、SVやCAD出力としてプロジェクトをエクスポートするために使用されます。

    • SV出力としてプロジェクトをエクスポートする方法の詳細については、「SV出力としてプロジェクトをエクスポート」トピックを参照してください。

    • CAD出力としてプロジェクトをエクスポートすることについては、「CAD出力としてプロジェクトをエクスポート」トピックを参照してください。

詳細:

SV出力としてプロジェクトをエクスポートすること

CAD出力としてプロジェクトをエクスポートすること

アプリケーションの設定


SV出力としてプロジェクトをエクスポートすること

SVファイルとしてTubeShaperプロジェクトをエクスポートするには:

  1. プロジェクトのワークスペース画面の右下に置ける保存/エクスポートメニューボタン [image] をクリックします。保存/エクスポートポップアップメニューが表示されます。

  2. SVをエクスポートオプションをクリックし、SV出力のプロジェクトのエクスポート]ダイアログボックスが表示されます。

SV出力のプロジェクトのエクスポートダイアログボックス

  3. 必要に応じて、SVプロジェクトファイルをエクスポートするフォルダに移動します。ダイアログボックスは、アプリケーションの設定ダイアログボックスで指定したデフォルトのフォルダの場所に開きます。

    TubeShaperファイルの保存場所及び場所を変更する方法の詳細については、「アプリケーションの設定」を参照してください。

  4. [ファイル名]フィールドに専用の名前を入力します。現在のプロジェクト名がデフォルトで使用されます。選択したファイルタイプのみを表示するには、ファイルフィルタドロップダウンリストを使用します。

  5. [OK]をクリックして、SVファイルの種類として、プロジェクトをエクスポートします。キャンセルをクリックして、ダイアログボックスを閉じます。

詳細:

プロジェクトの保存とエクスポート

CAD出力としてTubeShaperプロジェクトのエクスポート

アプリケーションの設定


CAD出力としてプロジェクトをエクスポートすること

CADファイルとしてTubeShaperプロジェクトをエクスポートするには:

  1. プロジェクトのワークスペース画面の右下に置ける保存/エクスポートメニューボタン [image] をクリックします。保存/エクスポートポップアップメニューが表示されます。

  2. CADをエクスポートオプションをクリックして、[エクスポート]ダイアログボックスが表示されます。

CADのエクスポート選択ダイアログボックス

  3. 適切なエクスポートオプションを選択 - 公称チューブオプションはデフォルトで選択されます。

  4. [OK]をクリックして、CAD出力用のプロジェクトをエクスポートダイアログボックスを表示します。

CAD出力のプロジェクトのエクスポートダイアログボックス

  5. 必要に応じて、CADプロジェクトファイルをエクスポートするフォルダに移動します。ダイアログボックスは、アプリケーションの設定ダイアログボックスで指定したデフォルトのフォルダの場所に開きます。

    TubeShaperファイルの保存場所及び場所を変更する方法の詳細については、「アプリケーションの設定」を参照してください。

  6. [ファイル名]フィールドに専用の名前を入力します。現在のプロジェクト名がデフォルトで使用されます。選択したファイルタイプのみを表示するには、ファイルフィルタドロップダウンリストを使用します。

  7. [OK]をクリックして、CADファイルの種類として、プロジェクトをエクスポートします。キャンセルをクリックして、ダイアログボックスを閉じます。

詳細:

プロジェクトの保存とエクスポート

SV出力としてプロジェクトをエクスポートすること

アプリケーションの設定


プロジェクトの編集

プロジェクトを編集するには、ワークスペース内のチューブプロジェクトを開くには、メイン画面のプロジェクトリストエリア内のプロジェクトファイルのいずれかをダブルクリックします。また、リストのプロジェクトをシングルクリックし、メイン画面の右下に配置[編集]ボタン [image] をクリックします。

編集用のワークスペースで開かれるチューブプロジェクトの例

注記：削除または改名されたベンダーのインターフェイスに関連付けられているプロジェクトが開かれると、関連付けがもう存在しません。これが発生した場合は、関連付けを削除したり、別のベンダーインターフェイスに再マッピングしたり、ベンダーのインターフェイスを改名することができます。チューブプロジェクトと異なるベンダーのインターフェース間でデータを調和させる方法については、「ベンダーの削除」トピックの「ベンダー・データの調和」を参照してください。

公称管データを編集すること

  1. XYZ/LRA/ALRAボタン [image] をクリックし、必要に応じて設定された公称データを編集するために、適切なビュー（XYZ、LRA、またはALRA）を選択します。データ表示slide-outの詳細については、「チューブデータの表示」トピックを参照してください。

  2. データ表示のslide-outパネルのセルのいずれかをクリックして、公称値のいずれかを編集することができます。一度、公称データ更新され、チューブがすでに測定されている場合は、CLRAボタン [image] をクリックし、そして、再計算ボタン [image] をクリックしてCLRAデータを再計算することができます。新しいCLRAデータが受け入れられない場合、CLRAデータslide-outパネルの[リセット]ボタン [image] をクリックすれば、新たに計算されたCLRAデータを元のLRA値に変更します。

  3. ベンダーへ送信ボタン [image] をクリックして、更新管定義データを曲げ機に送り返します。

現在開かれているプロジェクトの設定を編集すること

現在開いているチューブのプロジェクトのプロパティを表示および編集するには、[プロジェクト/チューブプロパティ]ボタン [image] をクリックします。このような物理的特性、公差及び検査オプションなどの設定への変更は、このパネルから行うことができます。行った任意の変更は、単に現在開いているチューブのプロジェクトのみに影響を与えます。プロジェクトのプロパティの設定については、「プロジェクトのプロパティの表示」を参照してください。

スプリングバック値の新規セットをプロジェクトに適用すること

スプリングバック値の新規セットは、スプリングバックビューのslide-outパネルから現在開いているプロジェクトに適用することができます。詳細については、「スプリングバックビュー」トピックを参照してください。

すべての変更が行われた場合には、保存/エクスポートメニューボタン [image] をクリックして、プロジェクトに加えられた変更を保存するか、エクスポートします。

プロジェクトの保存とエクスポートの詳細については、「プロジェクトの保存とエクスポート」章の該当するトピックを参照してください。


ベンダーの設定

プロジェクトのベンダーのインターフェースの設定はプロジェクトメニュータブから行われます。

  1. メニュー上のベンダータブをクリックして、ベンダーハブ画面を表示します。ベンダーインターフェイスがすでに設定されていない限り、画面のベンダー一覧のエリアは空です。

  2. ベンダーインタフェースがすでに定義されている場合は、ベンダー一覧エリアからいずれかを選択し、右下の[編集]をクリックします。ベンダーを編集ダイアログが表示され（詳細については、「ベンダーの編集」を参照してください）、さもないと、新規ベンダーをクリックして、新規ベンダーダイアログを表示し、新規ベンダーの設定ファイルが作成されます。ベンダーの新規作成の詳細については、「ベンダーの新規作成」トピックを参照してください。

  3. 特定のベンダーの構成設定を編集し、その後、[完了]をクリックして、変更を保存します。行った変更を保存せずにダイアログを終了するには、[キャンセル]をクリックします。

    4. 注記: 特定ベンダーのインターフェイスの設定の詳細については, 「 BLM ベンダーの設定」, 「Eaton Leonard VeLog ベンダーの設定、 及び「SV Network ベンダーの設定」を参照してください。

選択されたのか、または新しいベンダーは現在、新規の校正設定で更新されます。

詳細:

ベンダー画面の詳細

ベンダーの新規作成

ベンダーの編集

ベンダーの削除

ベンダーからチューブデータのリコール


ベンダー画面の詳細

メイン画面上のベンダータブをクリックして、ベンダーハブビューの画面を表示します。何のベンダーも定義されていない場合は、下記に示されたように、空の画面が表示されます。

TubeShaperベンダーハブビューの画面

ベンダーに固有のものであるを除く、ベンダーハブビューの画面はプロジェクト詳細画面と同じ構成要素を持っています。

ベンダーハブビューの画面では、これらの部分があります:

    メインメニューとタイトルバー - メインメニューとタイトルバーの詳細については、「メインメニューとタイトルバー」トピックを参照してください。

    メニュータブ - 各メニューのタブの詳細については、「プロジェクトメニューペイン」トピックを参照してください。

    ベンダーの一覧エリア - 一覧エリアの詳細については、「プロジェクトの一覧エリア」トピックを参照してください。

      ベンダー画面のこのエリアは、現時点に保存されているベンダーの一覧から構成されていることに注意してください。

      特定のベンダーの検索

      一覧エリアで表示できるのより多くのベンダーがある場合は、垂直のスクロールバーが利用可能になり、手動でベンダーをスクロールすることができます。

      特定のベンダーを見つけるもう一つの方法は、[フィルタ]フィールドを使用することです。

      [フィルタ]ボックスに名前またはベンダー名の一部を入力します。一致するものが見つかった場合、入力された文字を含むすべてのベンダーが表示されます - 他のすべてのベンダーが除外されます。

    ベンダー詳細エリア - ベンダー詳細エリアには現在選択されているベンダーの情報が表示されます。一覧エリアからベンダーのいずれかをシングルクリックすると、その詳細が表示されます。

    ベンダーのメニューバー - ベンダーのメニューバーには、次の機能が提供されます。

      新規のベンダー - 新規のベンダーを設定するには、新規ベンダーダイアログを表示します。詳細については、「ベンダーの新規作成」トピックを参照してください。

      コピー - これがクリックされると、現在選択されているベンダーのコピーが作成されます。

      削除 - 現在選択されているベンダーを削除するために、ベンダーの削除ダイアログボックスを表示します。

      編集 - 現在選択されているベンダーの設定を編集するには、ベンダーの編集ダイアログを表示します。詳細については、「ベンダーの編集」トピックを参照してください。

      リコール - ユーザー入力ダイアログを表示して、特定のベンダーからリコールされるチューブファイルの部品番号を入力します。

      ベンダーからチューブデータをリコールする詳細については、「ベンダーからチューブ・データのリコール」トピックを参照してください。

      ベンダーから公称値のデータをリコールする詳細については、「ベンダーから公称データをリコールすること」トピックを参照してください。

詳細:

ベンダーの新規作成

ベンダーの編集

ベンダーの削除

ベンダーからチューブデータのリコール

ベンダーの設定


ベンダーの新規作成

ベンダーを新規作成するには：

  1. ベンダーメニューバーから新規ベンダーをクリックします。新規ベンダーダイアログボックスが表示されます。

  2. ベンダー専用の名前を入力します。

    3. 注記：同じ名前を持つベンダーが入力された場合、その名前のファイルが既に存在することを示すエラーメッセージが表示されます。この時点で[完了]をクリックした場合は、既存のファイルを上書きするように求められます。既存のファイルが上書きされると、元に戻すことはできません。

  3. [タイプ]ドロップダウンリストからベンダータイプを選択します。現在のオプションは次のとおりです：

    • BLM ベンダー

    • Eaton Leonard VeLog ベンダー

    • SV ネットワーク ベンダー

  4. 適切な測定機の構成のトピックに記載されているプロパティとパラメータを確認します。必要に応じてその値を編集するために、各の右側のフィールドをクリックします。特定ベンダーのパラメータの詳細については, 、「 BLM ベンダーの設定」, 「Eaton Leonard VeLog ベンダーの設定」及び「SV Network ベンダーの設定」トピックを参照してください。

  5. 必要があればベンダーのイメージを更新することができます。イメージファイルの参照ダイアログボックスを表示するには、[参照]ボタンをクリックします。

  6. 適切なフォルダに移動し、新しいイメージファイルを選択します。

  7. ベンダーのイメージを変更するには、[開く]をクリックします。ベンダーの画像を変更せずにダイアログを閉じるには、[キャンセル]をクリックします。

  8. [OK]をクリックして、新しいベンダーの設定を保存します。キャンセルをクリックして、ダイアログボックスを閉じるます。

詳細:

BLM ベンダーの設定

Eaton Leonard VeLogベンダーの設定

SV ネットワーク ベンダーの設定

ベンダー画面の詳細

ベンダーの編集

ベンダーの削除

ベンダーからチューブデータのリコール

ベンダーの設定


BLM ベンダーの設定

新規の BLMベンダーのインターフェースを設定するには：

  1. プロジェクトメニュータブからベンダーをクリックします。

  2. ベンダー画面の左下に新しいベンダーをクリックして、新しいベンダーのダイアログボックスを表示し、[機種]ドロップダウンリストから、BLM形式のベンダーを選択します。

  3. ベンダー専用の名前を入力します。名前が既存のベンダー名と同じである場合は、警告メッセージが表示されます。この時点で[OK]をクリックすると、新しいベンダーの定義で既存のベンダーインターフェース設定を上書きするプロンプトが表示されます。

  4. 必要に応じて更新するベンダーの画像をクリックしてください。

  5. 下記の汎用プロパティのセクションで説明されるプロパティとパラメータを確認します。必要に応じてその値を編集するために、各の右側のフィールドをクリックします。

  6. [OK]をクリックして、新しいベンダーのインターフェースを保存します。設定を保存せずにダイアログボックスを終了するには、[キャンセル]をクリックします。

汎用プロパティのセクション

    ベンダー機種 - 機種ドロップダウンリストから選択されたベンダー機種をデフォルトに設定します。

    パーツディレクトリ - TubeShaperがチューブパーツのファイルを保存するために使用する場所です。

      32-ビット PC: 「C:\Program Files\WAI\<version>\Benders」

      64-ビット PC: 「C:\Program Files (x86)\WAI\<version>\Benders」

      ここで、<version>はインストールされるTubeShaperのバージョンです。

    交換ディレクトリ - TubeShaperがネットワーク接続のベンダーとの通信に使用されるディレクトリ。

詳細:

ベンダー画面の詳細

ベンダーの新規作成

Eaton Leonard VeLogベンダーの設定

SV ネットワーク ベンダーの設定

ベンダーの編集


Eaton Leonard VeLogベンダーの設定

新規のEaton Leonard VeLogベンダーのインターフェースを設定するには：

  1. プロジェクトメニュータブからベンダーをクリックします。

  2. ベンダー画面の左下に新しいベンダーをクリックして、新しいベンダーのダイアログボックスを表示し、[タイプ]ドロップダウンリストから、Eaton Leonard VeLog bender型のベンダーを選択します。

  3. ベンダー専用の名前を入力します。名前が既存のベンダー名と同じである場合は、警告メッセージが表示されます。この時点で[OK]をクリックすると、新しいベンダーの定義で既存のベンダーインターフェース設定を上書きするプロンプトが表示されます。

  4. 必要に応じて更新するベンダーの画像をクリックしてください。

  5. 下記の汎用プロパティのセクションで説明されるプロパティとパラメータを確認します。必要に応じてその値を編集するために、各の右側のフィールドをクリックします。

  6. [OK]をクリックして、新しいベンダーのインターフェースを保存します。設定を保存せずにダイアログボックスを終了するには、[キャンセル]をクリックします。

汎用プロパティのセクション

    ベンダー機種 - 機種ドロップダウンリストから選択されたベンダー機種をデフォルトに設定します。

    ベンダー番号 - ネットワークにベンダーを定義するユニークな数値。必要に応じて、既存の値を確認か、編集します。上/下の矢印を使用するか、またはフィールドをクリックし、手動で現在の値を変更します。

    パーツディレクトリ - SVネットワークベンダーの設定ファイルが保存される場所を定義します。デフォルトのパスは次のとおりです：

      32-ビット PC: 「C:\Program Files\WAI\<version>\Benders」

      64-ビット PC: 「C:\Program Files (x86)\WAI\<version>\Benders」

      ここで、<version>はインストールされるTubeShaperのバージョンです。

    サービスベンダーチェックボックス - マークされた場合、TubeShaperがベンダーの活動を監視して、いつベンダーを修理する必要があるかを決定します。

    COMポート - ベンダーに関連付けられているCOMポートを定義します。デフォルトはCOM1です。

    ボーレート - TubeShaperアプリケーションを実行しているPCのCOMポートとそれに接続され、曲げ加工機との間で発生する通信の速度を定義します。使用可能なオプションを下記に示します: 110, 300, 600, 1200, 2400, 3970, 4800, 9600, 14400, 19200, 28800, 38400, 56000 及び 57600。デフォルトは9600です。

    パリティ - データを送信する際に使用されるエラー検出方法を定義します。利用可能なオプションは次のとおりです：なし、奇数、偶数、マーク及びスペース。デフォルトでは、偶数パリティです。

    データビット - 文字ごとに送信されるデータのビット数を定義します。利用可能なオプションは以下のとおり：4、5、6、7、及び8。デフォルトは8ビットです。

    ストップビット - 各文字が送信された後に送信されるビット数を定義します。各文字の終わりに達したときに、送信の受信側に通知します。利用可能なオプションは次のとおりです：無し、１、２及び1.5。デフォルト値は2です。

    基準モード - マークされた場合、伝送プロトコルは、マシンのパラメータの小さいセットを送信します。マークされていない（デフォルト）場合、複数のパラメータを送信するために拡張モードは、実行されます。

    スプリングバックの使用 - マークされた場合に、TubeShaperは、スプリングバック補正を実行しています。マークされていない（デフォルト）場合に、ベンダーは、それを実行します。

詳細:

ベンダー画面の詳細

ベンダーの新規作成

BLM ベンダーの設定

SV ネットワーク ベンダーの設定

ベンダーの編集


SV ネットワーク ベンダーの設定

新規のSV Networkベンダーのインターフェースを設定するには：

  1. プロジェクトメニュータブからベンダーをクリックします。

  2. ベンダー画面の左下に新しいベンダーをクリックして、新しいベンダーのダイアログボックスを表示し、[タイプ]ドロップダウンリストから、SV Network 型のベンダーを選択します。

  3. ベンダー専用の名前を入力します。名前が既存のベンダー名と同じである場合は、警告メッセージが表示されます。この時点で[OK]をクリックすると、新しいベンダーの定義で既存のベンダーインターフェース設定を上書きするプロンプトが表示されます。

  4. 必要に応じて更新するベンダーの画像をクリックしてください。には、新しいイメージにナビゲートして、現在のものを置き換えることに使用されるダイアログボックスが表示されます。

  5. 下記の汎用プロパティのセクションで説明されるプロパティとパラメータを確認します。必要に応じてその値を編集するために、各の右側のフィールドをクリックします。

  6. [OK]をクリックして、新しいベンダーのインターフェースを保存します。設定を保存せずにダイアログボックスを終了するには、[キャンセル]をクリックします。

汎用プロパティのセクション

    ベンダー機種 - 機種リストから選択されたベンダー機種をデフォルトに設定します。

    ベンダー番号 - ネットワークにベンダーを定義するユニークな数値。必要に応じて、既存の値を確認か、編集します。上/下の矢印を使用するか、またはフィールドをクリックし、手動で現在の値を変更します。

    パートディレクトリ - チューブパーツのファイルを保存する場所を定義します。デフォルトのパスは次のとおりです：

      32-ビット PC: 「C:\Program Files\WAI\<version>\Benders」

      64-ビット PC: 「C:\Program Files (x86)\WAI\<version>\Benders」

      ここで、<version>はインストールされるTubeShaperのバージョンです。

    交換ディレクトリ - SVネットワークベンダーとの通信に使用するTubeShaperパスを定義します。

    タイムアウト - TubeShaperがSVネットワークファイルを送信または受信しようとするタイムアウト時間を秒単位で定義します。デフォルト値は25です。

    ベンダーを監視チェックボックス - マークされた場合：

    • TubeShaperはベンダーがいつファイルを要求するか、送るかを決定するために、常にベンダーの活動を監視します。ベンダーがチューブファイルを請求するか、または送信しようとするたびに、TubeShaperはそれに応じて応答します。

    • 現在のプロジェクトが空の場合に、ベンダーからのリコール請求は無視されます。

    • ベンダーは、現在開いているプロジェクトのチューブを呼び出すことができます。ベンダーが異なるチューブをリコールしようとすると、TubeShaperはその請求を無視します。

    • 現在開いているプロジェクトが定義されたチューブの要素を持って、ベンダーが同じ部品番号でチューブファイルを送信する場合、TubeShaperは自動的にファイルを受け付けます。ベンダーが異なる部品番号でチューブを送信する場合、TubeShaperはそれを拒否します。

    • 現在開いているプロジェクトに定義されたチューブ要素がない場合は、ベンダから送られた任意のチューブファイルが自動的に受け入れられます。

    • TubeShaperが現在開いているプロジェクトで定義されたベンダーを持っていない場合は、ベンダーからの送信およびリコール請求は無視されます。

    デフォルトチューブをリコールするチェックボックス - チューブのデータをリコールしている際にいずれかのSVのネットワークベンダーが管の部品番号を支援していない場合、このチェックボックスをマークします。これらのベンダー機種は、このチェックボックスがマークされる場合、「デフォルト」プログラムが自動的にベンダーからリコールされます。

詳細:

ベンダー画面の詳細

ベンダーの新規作成

BLM ベンダーの設定

Eaton Leonard VeLogベンダーの設定

ベンダーの編集


ベンダーの編集

既存のベンダーを編集するには：

  1. プロジェクトメニュータブからベンダーをクリックして、メイン画面のベンダーを表示します。

  2. ベンダーのリストエリアからベンダーのインターフェースをダブルクリックするか、またはベンダーをシングルクリックし、次にベンダー画面の右下にある[編集]をクリックします。ベンダーの編集ダイアログボックスが表示されます。

  3. 必要に応じてベンダーの画像、名前及び汎用のプロパティを編集します。特定ベンダーのインターフェイスの設定の詳細については, 「 BLM ベンダーの設定」, 「Eaton Leonard VeLog ベンダーの設定、 及び「SV Network ベンダーの設定」を参照してください。

詳細:

ベンダー画面の詳細

ベンダーの新規作成

ベンダーの削除

ベンダーからチューブデータのリコール

ベンダーの設定


ベンダーの削除

ベンダーのインターフェイスを削除するには：

  1. ベンダーのハブ・ビューから削除するベンダーを選択します。

  2. [ベンダーを削除]ボタン [image] をクリックして、選択したベンダーのインターフェースを削除します。

  3. 選択したベンダーインタフェースの削除を確認するプロンプトメッセージが表示されます。[OK]をクリックして、選択されたベンダーの削除を確認します。選択されたベンダーを削除しない場合は、[キャンセル]をクリックします。

ベンダーデータを一致させること

ベンダーインターフェイスがすでにチューブプロジェクトに割り当てられている場合、ベンダーとチューブプロジェクト間のCLRAデータがリンクされます。チューブのプロジェクトに割り当てられているベンダーインターフェイスが削除または改名された場合、このリンクが壊れています。チューブプロジェクトが開いている場合は、データを調整して、新しいベンダーに関連付け、または完全に関連付けを削除する必要があります。

  1. プロジェクトに関連付けられているベンダーインターフェイスが削除または名前が変更された後、チューブのプロジェクトを開きます。データをリコンサイルダイアログボックスが表示されます。

  2. ユーザは、関連付けを削除するか、または別のベンダーのインターフェースに関連付けを再マッピングすることができます。ダイアログボックスが最初に表示されたときに削除はデフォルトのオプションです。ただ関連付けを削除したい場合は、[OK]をクリックします。同じタイプの別のベンダーインターフェイスにプロジェクトを再マッピングする場合は、リストから再マッピングをクリックします。

  3. 再マッピングが選択されると、同じタイプのすべてのベンダーインターフェースを含んでいる別のリストが表示されます。

  4. ベンダーのリストからチューブのプロジェクトにリンクするベンダーのインターフェースを選択し、[OK]をクリックします。

詳細:

ベンダー画面の詳細

ベンダーの新規作成

ベンダーの編集

ベンダーからチューブデータのリコール

ベンダーの設定


ベンダーからチューブデータのリコール

曲げ機に保存されているチューブのデータは、任意のTubeShaperプロジェクトに呼び出すことができます。曲げ機はTubeShaperアプリケーションと通信するために適切に設定する必要があります。曲げ機の設定の詳細については、「ベンダーの設定」トピックを参照してください。

また、曲げ機のチューブファイルに関連付けられた品番を知っている必要があります。

注記： チューブデータをリコールする時、一部のSVネットワークベンダーは、チューブの品番を支援していません。これらのベンダーの場合は、特定のチューブプログラムを照会するために使用される部品番号の代わりに、「デフォルト」のプログラムが呼び出されます。しかし、これが機能するためには、ベンダーがTubeShaperに設定されている際に、デフォルトチューブをリコールチェックボックスをマークする必要があります。SVネットワークの曲げ機のインターフェースの設定方法の詳細については、「SVネットワークベンダーの設定」トピックを参照してください。

ベンダーからチューブをリコールする場合は、チューブのCLRAデータ及びプロパティの情報は次の時にベンダーに関連付けられています：

  • ベンダーハブビュー画面からチューブをリコールします。

  • プロジェクトワークスペースからのチューブを呼び出し、現在のベンダーが選択されます。

  • 他のベンダーに切り替えた後、プロジェクトのワークスペースからチューブを思い出します。

既存のチューブプロジェクトにチューブデータを呼び出します。

曲げ機から既存のチューブプロジェクトにチューブデータを呼び出すには：

  1. そのワークスペースでチューブプロジェクトを開くには、プロジェクト一覧エリアから既存のプロジェクトをダブルクリックします。

  2. 設定された曲げ機のポップアップリストを表示するには、利用可能なベンダー [image] のボタンをクリックします。

  3. リコールしたいチューブの定義を持っている一覧から正しい曲げ機を選択します。

  4. ベンダーからリコールボタン [image] をクリックします。次の警告メッセージが表示されます。

  5. [はい]をクリックして続行するか、または[いいえ]をクリックして終了します。はいがクリックされると、ベンダーからリコールダイアログは表示されます。

  6. 品番ボックスに、リコールしようのチューブファイルの品番を入力し、[OK]をクリックします。

    7. ソフトウェアは入力された品番に基づいて、チューブのデータをを見つけて、リコールしようとします。

    チューブデータが正常にリコールされた場合、ダイアログボックスは成功のメッセージを表示します。

    チューブデータが正常にリコールされなかった場合、ダイアログにはエラーメッセージが表示されます：

    エラーが発生した場合、最も可能性の高い原因は次のとおりです：

    • 間違った曲げ機が選択されました。選択された曲げ機が正しいことを検証して、再試行してください。

    • TubeShaperと曲げ機の間に通信エラーが発生しました。TubeShaperと選択された曲げ機の間の通信が機能していることを確認してください。これを検証するために、適切なエンジニアまたはIT技術者が関与する必要があるかもしれません。また、通信設定を検討して、彼らが選択された曲げ機に正しいであるかを確実します。曲げ機のインターフェースのプロパティの設定方法の詳細については、「新規ベンダーの作成」章の適切な機械設定トピックを参照してください。

  7. 正常にベンダーからチューブデータをリコールした後、プロジェクトは現在、リコールされたチューブデータが取り込まれます。必要に応じて適切なslide-outパネルを開くことで、値を編集します。様々なslide-outパネルの詳細については、「スライドアウトパネルツールバー」章を参照してください。

  8. 真空管データが正常に呼び出されて、プロジェクトで更新されると、プロジェクトのワークスペース画面の右下に位置する保存/エクスポートメニューボタン [image] をクリックします。プロジェクトが保存される前にプロジェクトのワークスペースを終了しようとしたときにもプロジェクトを保存するように求められます。

リバースエンジニアリングによってチューブの新規作成

チューブをリバースエンジニアリングするときに、チューブのデータも、曲げ加工機から呼び出されます。リコールされたチューブデータからチューブをリバースエンジニアリングの詳細については、「リバースエンジニアリングによって新規チューブを作成すること」を参照してください。

詳細:

ベンダー画面の詳細

ベンダーの新規作成

ベンダーの編集

ベンダーの削除

リバースエンジニアリングによってチューブの新規作成

ベンダーの設定


チューブの測定

注記: TubeShaperが測定を実行できる前に、ROMER絶対アームが設定されてに接続される必要があります。標準の3ボタンROMERアームの機能の詳細については、「ROMERアームボタン」トピックを参照してください。

TubeShaperは、チューブを測定する以下のメソッドを提供しています：

ツールダイアログからチューブを測定すること

測定システムの精度を検証したい場合は、未知のチューブの長さ、直径または曲げ半径を測定し、[ツール]メニューのオプションは利用可能です。

  1. マインニューバーからツールボタン [image] をクリックします。

  2. 適切なダイアログボックスを表示するには、直管、曲げ半径、またはチューブ直径タブを選択します。ツールダイアログボックスを使う測定の方法の詳細については、「ツール」トピックを参照してください。

  3. プログラムを測定/停止ボタン [image] をクリックして、測定のプロセスを開始します。グラフィックビューは、ゴールドのカラーで測定すべきエリアを表示します。赤いエリアの箇所は直管か、曲げ外側のエッジに近づきすぎないように、ユーザにお知らせします。

    4. 注意:グラフィックビューは、ゴールドのカラーで測定すべきエリアを表示します。赤いエリアの箇所は直管か、曲げ外側のエッジに近づきすぎないように、ユーザにお知らせします。

    ツールダイアログボックスで曲がりを測定する実例

  4. ダイアログボックスの下部に沿う指示に従ってチューブを測定します。

これらのタブの使用の詳細については、「ツール」章に該当するトピックを参照してください。

TubeShaperメイン画面からチューブを測定すること

プロジェクトメニューバーの測定ボタンをクリックすることで、メインTubeShaperプロジェクトビューから直接にチューブを測定することができます。

  1. プロジェクト一覧エリアからプロジェクトを選択すること

  2. 測定ボタンをクリックします。選択されたプロジェクトは、プロジェクトのワークスペースで開かれます。アクションバーに表示される指示に従って、チューブを測定します。

    3. プロジェクトワークスペースで直管1（S1）を測定する例

プロジェクトのワークスペースからチューブを測定すること

プロジェクトがプロジェクトのワークスペースで開いている場合は、アクションバーにある測定ボタンをクリックして、チューブを測定します。

  1. プロジェクトのワークスペース内のプロジェクトを表示するには、プロジェクト一覧エリアからプロジェクトをダブルクリックします。

  2. アクションバーの左下にある測定をクリックしてください。アクションバーに表示される指示に従って、チューブを測定します。

曲げ機械からリコールされるチューブを測定すること

注記:チューブを測定する前に、CNCのチューブ曲げ機を設定し、TubeShaperに接続する必要があります。

また、すでに曲げ機からリコールされたチューブを測定することができます。

  1. プロジェクトビューの画面で、[プロジェクト]メニュータブからベンダータブを選択します。

  2. ベンダーエリアから関心の管プロジェクトが含まれている曲げ機を選択します。

  3. ベンダーのアクションバーからベンダーからリコールボタン [image] をクリックします。

  4. ユーザー入ダイアログが表示されます。プロジェクトのパーツ番号を入力して、[完了]をクリックして、曲げ機からプロジェクトを読み出します。

  5. 呼び出されたチューブプロジェクトはプロジェクトのワークスペースに表示されます。行動バーの左下にあるプログラムを測定/停止をクリックしてください。

  6. アクションバーに表示される指示に従って、チューブを測定します。

すべての測定が完了すると、データを確認します。

  • 測定結果がよくない場合は、再計算ボタン [image] をクリックして再計算データが曲げ加工機に返送される必要があるかどうかを判断します。もしそうであれば、ベンダーに送信 ボタン [image] をクリックして、再計算されたチューブデータを曲げ機に戻って送信します。

  • 測定結果が許容される場合には、曲げ加工でも良いし、何よりもする必要がありません。

詳細

Romer アームボタン

整列の適応


Romer アームボタン

標準の三つのボタンを有するROMERアーム

ROMERの標準的な3つのボタンは次の通りです：

  • 白 - 左ボタン

  • 赤 - 中央ボタン

  • 黄色 - 右ボタン

ハードプローブを使用してチューブを計測する時：

  • 右ボタン - 完成した直管または端面の測定を確認するために使用されます。

  • 中央ボタン - ヒットを取るために使用されます。また、以下の例外を参照してください。

  • 左ボタン - 取れた最後の点を削除するために使用されます。また、以下の例外を参照してください。

自動シングルモードでチューブプローブを使ってチューブを測定する場合：

  • 右ボタン - 測定は各直管の後に自動的に確認されているので、このボタンは機能しません。

  • 中央ボタン - 以下の例外を参照してください。

  • 左ボタン - 取れた最後の点を削除するために使用されます。また、以下の例外を参照してください。

手動モードでチューブプローブを使ってチューブを測定する場合:

  • 右ボタン - 完成した直管または端面の測定を確認するために使用されます。

  • 中央ボタン - 以下の例外を参照してください。また、以下の例外を参照してください。

  • 左ボタン - 取れた最後の点を削除するために使用されます。また、以下の例外を参照してください。

ハードプローブを使用して要素を計測する時：

  • 右ボタン - 完成した直管または端面の測定を確認するために使用されます。

  • 中央ボタン - ヒットを取るために使用されます。また、以下の例外を参照してください。

  • 左ボタン - 取れた最後の点を削除するために使用されます。また、以下の例外を参照してください。

例外

  • 中央のボタン－中央のボタンが長押された時、これらのオプションは実行されることができます：

    • ３つ以下の直管が測定されている場合、単にプローブ交換オプションが有効になされた測定操作の選択ダイアログボックスが表示されます。単にプローブを交換するために、ダイアログボックスの指示に従ってください。

    • A端またはB端を測定する測定プロンプトが表示されている場合、測定操作の選択ダイアログボックスが表示されます。プローブの交換と端部のスキップオプションが有効になります。適切な操作を実行するために指示に従ってください。

    • ３つ以上の直管が測定されている場合、チューブの移動オプション及びプローブの交換オプションが有効になされた測定操作の選択ダイアログボックスが表示されます。現在の測定ステータスがチューブのA端またはB端を測定することである場合、端部をスキップオプションも有効になります。適切な操作を実行するために指示に従ってください。チューブの移動機能の詳細については、「チューブの移動」トピックを参照してください。

      • 注記:チューブの移動オプションが機能するようにユーザは、少なくとも3つの直管部を測定する必要があります。

  • 左ボタン

    • 自動シングルモード

    • ユーザが2回目のスイープしている場合、短押しでは、収集されたデータが削除され、同じ直管部の最初のスイープに戻ります。

    • 最初のスイープ（収集データなし）をしている場合は、短押しは前の直管部（すなわち、前の直管部を再測定する）に戻ります。

    • 長押しでは、１番目又は２番目のスイープであるにかかわらず、前の直管部に戻ります。

    手動モード

    • ヒットの収集数がゼロ以上の場合には、短押しは最後のヒットを削除します。

    • ヒットの収集数がゼロの場合、短押しは前の直管部に戻ります。

    • 長押しは収集されたヒット数にかかわらず、前の直管部に戻ります。

詳細:

チューブの移動

チューブの測定

整列の適応


チューブの移動

チューブの長さが、測定アームの長さよりも大きい場合にチューブを移動オプションが使用されます。

このオプションを使用するには:

  1. チューブの上に少なくとも三つの直線を測定します。

  2. ROMER アームの中央のボタンを長押して、チューブを移動オプションが有効にしたモードで、測定操作の選択ダイアログボックスを表示します。標準の3ボタンROMERアームの詳細については、「ROMERアームボタン」トピックを参照してください。

    3. また、プローブを変更オプションをクリックして、このダイアログからプローブを変更します。現在の測定ステータスがチューブのA端またはB端を測定することである場合、端部をスキップオプションも有効になります。これらのオプションの詳細については、「ROMERアームボタン」トピックの「例外」を参照してください。

    注記:一度に一つだけの動作を実行ことができます。複数の動作を実行する必要がある場合は、もう一度中央のボタンを長押すと、ダイアログボックスが再表示されます。

  3. ダイアログボックスに表示される指示に従ってください。

  4. 完了したら、[OK]をクリックします。

    5. 注記:チューブの移動オプションが機能するようにユーザは、少なくとも3つの直管部を測定する必要があります。

詳細:

Romer アームボタン

チューブの測定

整列の適応


要素の作成

要素は3つの方法で作成されます：

  • 要素の学習方法 - 要素バーから作成したい要素をクリックして、その要素が配置される場所でヒットを取ることを開始します。要素の学習の詳細については、「要素の学習」トピックを参照してください。

  • 要素のキー入力方法 - 要素バーから作成したい要素をクリックして、手動で要素の値をキー入力します。

  • CADで要素をクリック方法 - 要素バーから作成したい要素をクリックして、要素が配置されるCADの上をクリックします。

TubeShaperは、次の要素を作成する能力があります：

  • チューブ（キー入力またはインポートを介して）

  • 点

  • 線

  • 平面

  • 円

  • 円筒

  • 円形スロット

  • 球体

既存のチューブ・プロジェクトを開くか、または新規のプロジェクトが作成されたすぐに、ユーザは要素を作成か、計測することができます。プロジェクトはその後、ワークスペースに表示されます。ワークスペースの右側にあるプログラムの表示]ボタン [image] をクリックして、プログラムの表示 slide-outパネルを表示します。要素バーを表示するには、要素ボタン [image] をクリックします。ツールバーには、後述のようにプロジェクトを新規作成するためのオプションを持っています。

TubeShaperに要素を作成するには：

  1. プロジェクトのリストエリアからプロジェクトをダブルクリックすることで、既存のプロジェクトを開きます。また、プロジェクトをシングルクリックし、[プロジェクト]メニューバーから[編集]をクリックします。

  2. プログラムのビューボタン [image] をクリックして、プログラムビュー スライドアウトパネルを表示します。

  3. 要素バーを表示するには、要素ボタン [image] をクリックします。

    4. すべての機能は、いつも利用できるとは言えません。平面要素が作成されていない場合に、点、平面、円筒と球の要素のみが有効になります。チューブのプロジェクトが新しく、チューブの要素がまだ作成されていない場合に、[チューブを追加]及びインポートでチューブを追加オプションも有効になります。

    注記: 追加をチューブボタン [image] を選択するか、または要素バーから[インポートでチューブを追加]ボタン [image] を選択して、新規のチューブ要素が作成ことができます。一度に一つのみのチューブ要素がプロジェクトに追加することができます。

    チューブ要素の新規作成の詳細については、「プロジェクトの新規作成」章を参照してください。

    インポートでチューブ要素の新規作成の詳細については、「インポートでプロジェクトの新規作成」トピックを参照してください。

  4. チューブ要素が追加される場合、整列のタイプを指定する必要があります。これは、チューブの整列プロパティに行われます。整列の詳細については、「整列の適用」トピックを参照してください。

  5. 点、線、円またはラウンドスロットを作成することができる前に、投影のために平面要素（平面、球の円筒）を作成する必要があります。

    6. 要素バーから作成したい要素をクリックします。理論値と交差のトグルフィールドは、最初に利用可能で、要素によって編集することができます。要素が測定された後だけで測定されたトグルフィールドは使用可能になります。

    ユーザは、値をキー入力し、CADをクリックして、新しい要素を配置するか、または要素の学習機能を備えた要素を学ぶことができます。要素を学習する方法の詳細については、「要素の学習」トピックを参照してください。

    平面のベクトルは要素の意図投影に正しく定義されていることを確認します。

    注記： 非管要素については、CADをクリックして、要素の公称値フィールドを更新することができます。

  6. 交差左へ移動 [image] 及び右へ移動 [image] ボタンをクリックして、理論値、実測値、+公差及び-公差のビューの間を移動して、必要に応じてそれぞれのフィールドを更新します。選択された要素は、容易に識別するためにグラフィックに赤で表示されていることに注意してください。

    7. 注：チューブのCADモデルをプロジェクトにインポートされている場合は、その公称値は自動的に抽出されます。

  7. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

    8. 注：要素の公差は、アライメントを持っていない任意の要素において、デフォルトではオフになります。そうでない場合は、要素の公差がデフォルトでオンになります。

  8. レポートに追加ボタン [image] をクリックして、レポートにこの新要素を追加します。それは灰色で表示されたときにボタンが無効になっています。

  9. 理論値がCADモデル上で選択できるようにしたい場合、CAD選択を有効化/無効化ボタン [image] ををクリックします。それは灰色で表示されたときにボタンが無効になっています。

  10. 要素の公称値が入力されると、要素を測定ボタン [image] をクリックし、画面の下部に沿って指示に従ってください。選択された要素を削除するには、[要素を削除]ボタン [image] をクリックします。

この要素を学習している場合は、この要素の現在の公称値と測定値は、新たな測定結果に基づいて更新されます。

詳細:

要素の学習

チューブ要素の作成

点要素の作成

線要素の作成

平面要素の作成

円要素の作成

円筒要素の作成

円形スロット要素の作成

球体要素の作成

測定ルーチンにプローブプロンプトを追加

コメントを測定ルーチンに追加すること


要素の学習

要素バーから要素の種類をクリックすると、すぐに要素の学習を行うことができます。チューブの要素はチューブをリバースエンジニアリングすることによって学習されます。チューブ要素のリバースエンジニアリングの詳細については、「リバースエンジニアリングによるチューブの新規作成」トピックを参照してください。

要素の学習を行うには：

  1. ワークスペースにプロジェクトを開き、プログラムのビューボタン [image] をクリックして、プログラムのビュー slide-outパネルを表示します。

  2. 要素ツールバーを表示するには、要素ボタン [image] をクリックします。

  3. 要素バーから要素を選択します。

    4. すべての機能は、いつも利用できるとは言えません。平面要素が作成されていない場合に、点、平面、円筒と球の要素のみが有効になります。チューブのプロジェクトが新しく、チューブの要素がまだ作成されていない場合に、[チューブを追加]及びインポートでチューブを追加オプションも有効になります。

  4. チューブ要素上の所望の位置から必要数のヒットを取ります。プロンプトが画面の下部に表示されて、残っている必要なヒット数の最小値を知らせます。より多くのヒットを取ることができますが、最小数は必要です。

  5. 完了したら、ROMERアームの適切なボタンをクリックして、選択された要素の学習プロセスを完了します。ROMERアームボタンの詳細については、「ROMERアームボタン」トピックを参照してください。

    6. 選択された要素は、容易に識別するためにグラフィックに赤で表示されていることに注意してください。

    それぞれの新規要素は、プログラムリストで選択されている項目の直後に追加されます。

  6. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

  7. 整列一覧から、要素の整列類別を選択します。

  8. 必要に応じて公称値を編集します。

  9. 新要素は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  10. CADモデル上の新規要素の場所を選択することで、公称値を変更したい場合はCAD選択を有効/無効にするボタン [image] をクリックします。それは灰色で表示されたときにボタンが無効になっています。

  11. 新規要素を再度測定する必要がある場合は、要素測定ボタン [image] をクリックし、画面の下部に沿う指示に従ってください。選択された要素を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

プロジェクトの新規作成

インポートでプロジェクトの新規作成

チューブ要素の作成

点要素の作成

線要素の作成

平面要素の作成

円要素の作成

円筒要素の作成

円形スロット要素の作成

球体要素の作成

測定ルーチンにプローブプロンプトを追加

コメントを測定ルーチンに追加すること


チューブ要素の作成

チューブ要素は、新規のプロジェクトワークスペースからのプログラム表示 slide-outパネルから作成することができます。しかし、一つのチューブ要素がすでに定義された場合は、さらに、チューブ要素を作成することはできません。

  1. TubeShaperプロジェクトハブ画面の左下に位置する新規プロジェクトをクリックしして、チューブ要素無しのプロジェクトを作成します。チューブ要素をリバースエンジニアリングすることができる位置に新規プロジェクトワークスペースが表示されます。チューブをリバースエンジニアリングの詳細については、「リバースエンジニアリングによるチューブの新規作成」トピックを参照してください。

  2. プログラムのビューボタン [image] をクリックして、プログラムビュー slide-outパネルを表示します。

  3. 要素バーが表示されていない場合、要素ボタン [image] をクリックします。

    4. すべての機能は、いつも利用できるとは言えません。平面要素が作成されていない場合に、点、平面、円筒と球の要素のみが有効になります。チューブのプロジェクトが新しく、チューブの要素がまだ作成されていない場合に、[チューブを追加]及びインポートでチューブを追加オプションも有効になります。

  4. 直管を追加ボタン [image] をクリックして、チューブの作成ダイアログを表示します。チューブ要素のリバースエンジニアリングの詳細については、「リバースエンジニアリングによるチューブの新規作成」トピックを参照してください。

    5. また、CADのインポートでチューブを作成することができます。これを行うには、、インポートでチューブの追加ボタン [image] をクリックして、ファイルの参照ダイアログボックスを表示します。インポートでプロジェクトの新規作成の詳細については、「インポートでプロジェクトの新規作成」トピックを参照してください。

    注：チューブのCADモデルをプロジェクトにインポートされている場合は、その公称値は自動的に抽出されます。

一つのチューブ要素がすでに存在しているときに新規のチューブ要素を作成するには、プロジェクトから既存のチューブ要素を削除する必要があります。その後、上記の2つの方法のいずれかを使用して、チューブ要素を新規作成することができます。

既存のチューブ要素を削除するには：

  1. プログラム表示のslide-outパネルのプログラム一覧に位置するチューブ要素をクリックします。

  2. チューブ要素を削除するには、[要素を削除]ボタン [image] をクリックします。チューブ要素は、プログラムから削除されます。他のすべての要素は、プログラムに残られます。

  3. 上記のいずれかのボタンをクリックして、チューブ要素を新規作成します。

詳細:

プロジェクトの新規作成

インポートでプロジェクトの新規作成

要素の学習

点要素の作成

線要素の作成

平面要素の作成

円要素の作成

円筒要素の作成

円形スロット要素の作成

球体要素の作成

測定ルーチンにプローブプロンプトを追加

コメントを測定ルーチンに追加すること


点要素の作成

点要素を作成するには：

  1. ワークスペースにプロジェクトを開き、プログラムのビューボタン [image] をクリックして、プログラムのビュー slide-outパネルを表示します。

  2. 要素ツールバーを表示するには、要素ボタン [image] をクリックします。

    3. すべての機能は、いつも利用できるとは言えません。平面要素が作成されていない場合に、点、平面、円筒と球の要素のみが有効になります。チューブのプロジェクトが新しく、チューブの要素がまだ作成されていない場合に、[チューブを追加]及びインポートでチューブを追加オプションも有効になります。

  3. 要素バーから 点要素ボタン [image] をクリックします。理論値と公差値のフィールドは、最初に利用可能で、編集することができます。要素が測定された後だけで測定されたトグルフィールドは使用可能になります。

  4. 交差左へ移動 [image] 及び右へ移動 [image] ボタンをクリックして、理論値、実測値、+公差及び-公差のビューの間を移動して、必要に応じてそれぞれのフィールドを更新します。

    5. 注：またすぐにチューブから必要なヒットを取ることによって、新しい機能を学ぶことができます。機能の学習の詳細については、「機能の学習」を参照してください。

    選択された要素は、容易に識別するためにグラフィックに赤で表示されていることに注意してください。

    それぞれの新規要素は、プログラムリストで選択されている項目の直後に追加されます。

  5. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

  6. 整列一覧から、要素の整列類別を選択します。

  7. 手動で点のX、Y、Zの位置及びI、J、Kのベクトル値を入力します。

  8. 新要素は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  9. 理論値がCADモデル上で選択できるようにしたい場合、CAD選択を有効化/無効化ボタン [image] ををクリックします。それは灰色で表示されたときにボタンが無効になっています。

  10. 準備ができたら、要素を測定ボタン [image] をクリックして、画面の下部の指示に従って、新しい点要素を測定します。選択された要素を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

要素の学習

チューブ要素の作成

線要素の作成

平面要素の作成

円要素の作成

円筒要素の作成

円形スロット要素の作成

球体要素の作成

測定ルーチンにプローブプロンプトを追加

コメントを測定ルーチンに追加すること


線要素の作成

注：線、円、円形スロットの要素は常に基準面に投影し、常に結果的に2Dにされています。構築線、円、または円形スロットを作成するとき、彼らは基準面を持っていないので、それらが基準面に投影され、結果的に、これらはいつも3Dです。

線要素を作成するには：

  1. ワークスペースにプロジェクトを開き、プログラムのビューボタン [image] をクリックして、プログラムのビュー slide-outパネルを表示します。

  2. 要素バーを表示するには、要素ボタン [image] をクリックします。

    3. すべての機能は、いつも利用できるとは言えません。平面要素が作成されていない場合に、点、平面、円筒と球の要素のみが有効になります。チューブのプロジェクトが新しく、チューブの要素がまだ作成されていない場合に、[チューブを追加]及びインポートでチューブを追加オプションも有効になります。

  3. 線要素を作成することができる前に、平面要素を投影のために作成する必要があります。平面要素の作成の詳細については、「平面要素の作成」のトピックを参照してください。平面のベクトルは線の意図投影に正しく設定されていることを確認します。

    4. 要素バーから 線要素ボタン [image] をクリックします。理論値と交差のトグルフィールドは、最初に利用可能で、編集することができます。要素が測定された後で測定されたトグルフィールドは使用可能になります。

  4. プロジェクトドロップダウンリストから、適切な平面を選択して、線要素をその平面に投影するようにします。要素はすぐに選択された平面に投影されます。

  5. 交差左へ移動 [image] 及び右へ移動 [image] ボタンをクリックして、理論値、実測値、+公差及び-公差のビューの間を移動して、必要に応じてそれぞれのフィールドを更新します。

    6. 注：またすぐにチューブから必要なヒットを取ることによって、新しい機能を学ぶことができます。機能の学習の詳細については、「機能の学習」を参照してください。

    選択された要素は、容易に識別するためにグラフィックに赤で表示されていることに注意してください。

    それぞれの新規要素は、プログラムリストで選択されている項目の直後に追加されます。

  6. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

  7. 整列一覧から、要素の整列類別を選択します。

  8. 手動で線（X、Y、Z）、そのベクトル（I、J、K）、その長さ及びそのエッジベクトル（I2、J2、K2）値の始点値を入力します。

  9. 新要素は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  10. 理論値がCADモデル上で選択できるようにしたい場合、CAD選択を有効化/無効化ボタン [image] ををクリックします。それは灰色で表示されたときにボタンが無効になっています。

  11. 準備ができたら、要素を測定ボタン [image] をクリックして、画面の下部の指示に従って、新しい線要素を測定します。選択された要素を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

要素の学習

チューブ要素の作成

点要素の作成

平面要素の作成

円要素の作成

円筒要素の作成

円形スロット要素の作成

球体要素の作成

測定ルーチンにプローブプロンプトを追加

コメントを測定ルーチンに追加すること


平面要素の作成

ある要素の種類を作成するときに平面要素は、投影のために必要とされます。

平面要素を作成するには：

  1. ワークスペースにプロジェクトを開き、プログラムのビューボタン [image] をクリックして、プログラムのビュー slide-outパネルを表示します。

  2. 要素バーツールバーを表示するには、要素ボタン [image] をクリックします。

    3. すべての機能は、いつも利用できるとは言えません。平面要素が作成されていない場合に、点、平面、円筒と球の要素のみが有効になります。チューブのプロジェクトが新しく、チューブの要素がまだ作成されていない場合に、[チューブを追加]及びインポートでチューブを追加オプションも有効になります。

  3. 要素バーツールバーから 平面要素ボタン [image] をクリックします。理論値と交差のトグルフィールドは、最初に利用可能で、編集することができます。要素が測定された後で測定されたトグルフィールドは使用可能になります。

  4. 交差左へ移動 [image] 及び右へ移動 [image] ボタンをクリックして、理論値、実測値、+公差及び-公差のビューの間を移動して、必要に応じてそれぞれのフィールドを更新します。平面のベクトルは、任意の依存項目の意図投影に正しく定義されていることを確認します。

    5. 注：またすぐにチューブから必要なヒットを取ることによって、新しい機能を学ぶことができます。機能の学習の詳細については、「機能の学習」を参照してください。

    選択された要素は、容易に識別するためにグラフィックに赤で表示されていることに注意してください。

    それぞれの新規要素は、プログラムリストで選択されている項目の直後に追加されます。

  5. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

  6. 整列一覧から、要素の整列類別を選択します。

  7. 手動で平面のX、Y、Zの位置I、J、Kのベクトル値を入力します。

  8. 新要素は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  9. 理論値がCADモデル上で選択できるようにしたい場合、CAD選択を有効化/無効化ボタン [image] ををクリックします。それは灰色で表示されたときにボタンが無効になっています。

  10. 準備ができたら、要素を測定ボタン [image] をクリックして、画面の下部の指示に従って、新しい線要素を測定します。選択された要素を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

要素の学習

チューブ要素の作成

点要素の作成

線要素の作成

円要素の作成

円筒要素の作成

円形スロット要素の作成

球体要素の作成

測定ルーチンにプローブプロンプトを追加

コメントを測定ルーチンに追加すること


円要素の作成

注：線、円、円形スロットの要素は常に基準面に投影し、常に結果的に2Dにされています。構築線、円、または円形スロットを作成するとき、彼らは基準面を持っていないので、それらが基準面に投影され、結果的に、これらはいつも3Dです。

円要素を作成するには：

  1. ワークスペースにプロジェクトを開き、プログラムのビューボタン [image] をクリックして、プログラムのビュー slide-outパネルを表示します。

  2. 要素バーを表示するには、要素ボタン [image] をクリックします。

    3. すべての機能は、いつも利用できるとは言えません。平面要素が作成されていない場合に、点、平面、円筒と球の要素のみが有効になります。チューブのプロジェクトが新しく、チューブの要素がまだ作成されていない場合に、[チューブを追加]及びインポートでチューブを追加オプションも有効になります。

  3. 円要素を作成することができる前に、平面要素を投影のために作成する必要があります。平面要素の作成の詳細については、「平面要素の作成」のトピックを参照してください。平面のベクトルは円の意図投影に正しく設定されていることを確認します。

  4. 要素バーから 円要素ボタン [image] をクリックします。理論値と交差のトグルフィールドは、最初に利用可能で、編集することができます。要素が測定された後で測定されたトグルフィールドは使用可能になります。

  5. 整列一覧から、要素の整列類別を選択します。

  6. プロジェクトドロップダウンリストから、適切な平面を選択して、円要素をその平面に投影するようにします。要素はすぐに選択された平面に投影されます。

  7. 交差左へ移動 [image] 及び右へ移動 [image] ボタンをクリックして、理論値、実測値、+公差及び-公差のビューの間を移動して、必要に応じてそれぞれのフィールドを更新します。

    8. 注：またすぐにチューブから必要なヒットを取ることによって、新しい機能を学ぶことができます。機能の学習の詳細については、「機能の学習」を参照してください。

    選択された要素は、容易に識別するためにグラフィックに赤で表示されていることに注意してください。

    それぞれの新規要素は、プログラムリストで選択されている項目の直後に追加されます。

  8. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

  9. 手動で円のX、Y、Zの場所及びI、J、Kベクトルと直径の値を入力し、次に、リストから内/外オプションを選択します。

  10. 新要素は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  11. 理論値がCADモデル上で選択できるようにしたい場合、CAD選択を有効化/無効化ボタン [image] ををクリックします。それは灰色で表示されたときにボタンが無効になっています。

  12. 準備ができたら、要素を測定ボタン [image] をクリックして、画面の下部の指示に従って、新しい線要素を測定します。選択された要素を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

要素の学習

チューブ要素の作成

点要素の作成

線要素の作成

平面要素の作成

円筒要素の作成

円形スロット要素の作成

球体要素の作成

測定ルーチンにプローブプロンプトを追加

コメントを測定ルーチンに追加すること


円筒要素の作成

円筒要素を作成するには：

  1. ワークスペースにプロジェクトを開き、プログラムのビューボタン [image] をクリックして、プログラムのビュー slide-outパネルを表示します。

  2. 要素バーを表示するには、要素ボタン [image] をクリックします。

    3. すべての機能は、いつも利用できるとは言えません。平面要素が作成されていない場合に、点、平面、円筒と球の要素のみが有効になります。チューブのプロジェクトが新しく、チューブの要素がまだ作成されていない場合に、[チューブを追加]及びインポートでチューブを追加オプションも有効になります。

  3. 要素バーから 円筒要素ボタン [image] をクリックします。理論値と交差のトグルフィールドは、最初に利用可能で、編集することができます。要素が測定された後で測定されたトグルフィールドは使用可能になります。

  4. 交差左へ移動 [image] 及び右へ移動 [image] ボタンをクリックして、理論値、実測値、+公差及び-公差のビューの間を移動して、必要に応じてそれぞれのフィールドを更新します。円筒のベクトルは、任意の依存項目の意図投影に正しく定義されていることを確認します。

    5. 注：またすぐにチューブから必要なヒットを取ることによって、新しい機能を学ぶことができます。機能の学習の詳細については、「機能の学習」を参照してください。

    選択された要素は、容易に識別するためにグラフィックに赤で表示されていることに注意してください。

    それぞれの新規要素は、プログラムリストで選択されている項目の直後に追加されます。

  5. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

  6. 整列一覧から、要素の整列類別を選択します。

  7. 手動で円筒のX、Y、Zの場所及びI、J、Kベクトル、直径及び長さの値を入力し、次に、リストから内/外オプションを選択します。

  8. 新要素は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  9. 理論値がCADモデル上で選択できるようにしたい場合、CAD選択を有効化/無効化ボタン [image] ををクリックします。それは灰色で表示されたときにボタンが無効になっています。

  10. 準備ができたら、要素を測定ボタン [image] をクリックして、画面の下部の指示に従って、新しい円筒要素を測定します。選択された要素を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

要素の学習

チューブ要素の作成

点要素の作成

線要素の作成

平面要素の作成

円要素の作成

円形スロット要素の作成

球体要素の作成

測定ルーチンにプローブプロンプトを追加

コメントを測定ルーチンに追加すること


円形スロット要素の作成

注：線、円、円形スロットの要素は常に基準面に投影し、常に結果的に2Dにされています。構築線、円、または円形スロットを作成するとき、彼らは基準面を持っていないので、それらが基準面に投影され、結果的に、これらはいつも3Dです。

円形スロット要素を作成するには：

  1. ワークスペースにプロジェクトを開き、プログラムのビューボタン [image] をクリックして、プログラムのビュー slide-outパネルを表示します。

  2. 要素バーを表示するには、要素ボタン [image] をクリックします。

    3. すべての機能は、いつも利用できるとは言えません。平面要素が作成されていない場合に、点、平面、円筒と球の要素のみが有効になります。チューブのプロジェクトが新しく、チューブの要素がまだ作成されていない場合に、[チューブを追加]及びインポートでチューブを追加オプションも有効になります。

  3. 円形スロット要素を作成することができる前に、平面要素を投影のために作成する必要があります。平面要素の作成の詳細については、「平面要素の作成」のトピックを参照してください。平面のベクトルは円形スロットの意図投影に正しく設定されていることを確認します。

  4. 要素バーから 円形スロット要素ボタン [image] をクリックします。理論値と公差のトグルフィールドは、最初から利用可能です。要素が測定された後で測定されたトグルフィールドは使用可能になります。

  5. プロジェクトドロップダウンリストから、適切な平面を選択して、円形スロット要素をその平面に投影するようにします。要素はすぐに選択された平面に投影されます。

  6. 交差左へ移動 [image] 及び右へ移動 [image] ボタンをクリックして、理論値、実測値、+公差及び-公差のビューの間を移動して、必要に応じてそれぞれのフィールドを更新します。

    7. 注：またすぐにチューブから必要なヒットを取ることによって、新しい機能を学ぶことができます。機能の学習の詳細については、「機能の学習」を参照してください。

    選択された要素は、容易に識別するためにグラフィックに赤で表示されていることに注意してください。

    それぞれの新規要素は、プログラムリストで選択されている項目の直後に追加されます。

  7. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

  8. 整列一覧から、要素の整列類別を選択します。

  9. 手動で円形スロットのX、Y、Zの場所及びI2、J2、K2、エッジベクトル、幅及び長さの値を入力し、次に、リストから内/外オプションを選択します。

  10. 新要素は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  11. 理論値がCADモデル上で選択できるようにしたい場合、CAD選択を有効化/無効化ボタン [image] ををクリックします。それは灰色で表示されたときにボタンが無効になっています。

  12. 準備ができたら、要素を測定ボタン [image] をクリックして、画面の下部の指示に従って、新しい線要素を測定します。選択された要素を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

要素の学習

チューブ要素の作成

点要素の作成

線要素の作成

平面要素の作成

円要素の作成

円筒要素の作成

球体要素の作成

測定ルーチンにプローブプロンプトを追加

コメントを測定ルーチンに追加すること


球体要素の作成

球要素を作成するには：

  1. ワークスペースにプロジェクトを開き、プログラムのビューボタン [image] をクリックして、プログラムのビュー slide-outパネルを表示します。

  2. 要素バーを表示するには、要素ボタン [image] をクリックします。

    3. すべての機能は、いつも利用できるとは言えません。平面要素が作成されていない場合に、点、平面、円筒と球の要素のみが有効になります。チューブのプロジェクトが新しく、チューブの要素がまだ作成されていない場合に、[チューブを追加]及びインポートでチューブを追加オプションも有効になります。

  3. 要素バーから 球体要素ボタン [image] をクリックします。理論値と公差のトグルフィールドは、最初から利用可能です。要素が測定された後で測定されたトグルフィールドは使用可能になります。

  4. 交差左へ移動 [image] 及び右へ移動 [image] ボタンをクリックして、理論値、実測値、+公差及び-公差のビューの間を移動して、必要に応じてそれぞれのフィールドを更新します。円筒のベクトルは、任意の依存項目の意図投影に正しく定義されていることを確認します。

    5. 注：またすぐにチューブから必要なヒットを取ることによって、新しい機能を学ぶことができます。機能の学習の詳細については、「機能の学習」を参照してください。

    選択された要素は、容易に識別するためにグラフィックに赤で表示されていることに注意してください。

    それぞれの新規要素は、プログラムリストで選択されている項目の直後に追加されます。

  5. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

  6. 整列一覧から、要素の整列類別を選択します。

  7. 手動で球体のX、Y、Zの場所及び直径の値を入力し、次に、リストから内/外オプションを選択します。

  8. レポートに追加ボタン [image] をクリックして、レポートにこの新要素を追加します。それは灰色で表示されたときにボタンが無効になっています。

  9. 理論値がCADモデル上で選択できるようにしたい場合、CAD選択を有効化/無効化ボタン [image] ををクリックします。それは灰色で表示されたときにボタンが無効になっています。

  10. 準備ができたら、要素を測定ボタン [image] をクリックして、画面の下部の指示に従って、新しい円筒要素を測定します。選択された要素を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

要素の学習

チューブ要素の作成

点要素の作成

線要素の作成

平面要素の作成

円要素の作成

円筒要素の作成

円形スロット要素の作成

測定ルーチンにプローブプロンプトを追加

コメントを測定ルーチンに追加すること


測定ルーチンにプローブプロンプトを追加

測定プログラム内の任意の時点でプローブプロンプトを含めることができます。これは、例えば、必要に応じて異なるプローブのタイプに切り替えるプロンプトを受け取ることができます。

注:ハードプローブが要素の測定に必要とされるので、プローブプロンプトを必要としません。TubeShaperは自動的にハードプローブに切り替える確保するように求められます。しかし、要素の測定値からチューブプローブを使用するチューブの測定に切り替える場合は、プロンプトを追加する必要があります。

プローブのプロンプトを作成するには：

  1. プローブプロンプトが必要とされる測定ルーチンで要素を選択します。要素が測定される前にプロンプトを追加する必要があります。

  2. ユーティリティボタン [image] をクリックします。コメントを追加 [image] ボタン及びプローブを追加 [image] のボタンは、選択した要素の下に表示されます。

  3. プローブを追加ボタンをクリックして下さい。[プローブのプロンプトの定義]ダイアログボックスが表示されます。

  4. プローブの種類リストから適切なプローブ形式を選択します。

  5. プロンプトをテストするために、測定ボタン [image] をクリックします。

プロンプトを削除するには、[要素を削除]ボタン [image] をクリックします。

プローブプロンプトアイテムは、現在お使いの測定ルーチンに表示されます。

プロンプトの項目を編集するには、それをクリックして、必要な変更を行います。

詳細:

要素の作成

コメントを測定ルーチンに追加すること


コメントを測定ルーチンに追加すること

測定プログラム内の任意の時点でコメントを含めることができます。コメントのコマンドが直ちに選択された要素の真下に追加されます。

コメントの追加:

  1. コメントが必要とされる測定ルーチンで要素を選択します。

  2. ユーティリティボタン [image] をクリックします。コメントを追加 [image] ボタン及びプローブを追加 [image] のボタンは、選択した要素の下に表示されます。

  3. コメントを追加ボタンをクリックします。[コメントを定義]ダイアログボックスが表示されます。

  4. プロンプトが表示する適切なテキストを入力します。

  5. プロンプトをテストするために、測定ボタン [image] をクリックします。

コメントを削除するには、[要素を削除]ボタン [image] をクリックします。

コメントコマンドは、現在お使いの測定ルーチンに表示されます。

コメントコマンドを編集するには、それをクリックして、必要な変更を行います。

詳細:

要素の作成

測定ルーチンにプローブプロンプトを追加


整列の作成

TubeShaperはアライメントで大きな柔軟性を提供します。

注：要素の公差は、アライメントを持っていない任意の要素において、デフォルトではオフになります。そうでない場合は、要素の公差がデフォルトでオンになります。

ソフトウェアは、4つの事前定義されたチューブベースのアライメントの種類を提供します。

  • 接点の最適化整列

  • バイアス因子によって接点（TP）最適合の整列

  • ハードポイントの整列

  • 点間の最適化整列

あらかじめ定義されたチューブに基準するアラインメントは、チューブ上の点を使用しています。

TubeShaperはプロジェクトビューのslide-outパネルから利用可能な他の要素ベースのアライメントをも提供します。これらのアライメントのタイプを使用すると、様々な角柱アラインメントを実行するのに必要な要素を選択します。例えば、ユーザがチューブ上の特定の点に興味を持っている場合は、点要素は、メニューから選択することができます。

これらのアライメントのいずれかを実行するには：

  1. 公称データを備えたプロジェクトを開き、チューブを測定します。

  2. プログラムのビューボタン [image] をクリックして、プロジェクトビュー slide-outパネルを表示します。

  3. これらの整列オプションを表示するには、整列ボタン [image] をクリックします。

    • 平面-直線-点(PLP)の整列

    • 平面-直線-円の整列

    • 平面-直線-直線(PLL)の整列

    • 平面-円-円(PCC)の整列

    • 平面-平面-平面（PPP）整列の作成

    • 最適化の整列

  4. 実行しようとする整列をクリックし、指示に従います。

これらは、ほとんどの場合、プリズム形状（点、平面、円柱や球）に使用されます。これらの整列の詳細については、「プリズマティック整列の作成」を参照してください。

詳細:

チューブを基準とする整列の作成

角形整列の作成


チューブを基準とする整列の作成

それが測定の前または後で、整列をチューブに適用することができます。適用するとユーザはすぐにチューブがCADに正しく整列されているかどうかを判定できて、次にチューブを測定します。

TubeShaperには（要素ベースの整列の作成の詳細については、「他の要素ベースの整列の作成」トピックを参照してください）以下のチューブに基づく整列オプションが用意されています：

  • 接点（TP）の最適化 - これはチューブに最も一般的に使用される整列です。接点（TP）の最適化整列及びチューブにそれらを適用する方法の詳細については「接点（TP）の最適化整列」トピックを参照してください。

  • 最適化のバイアス係数を備えた接点（TP） - この整列は測定されたチューブのデータを公称値に整列させるようにチューブ接点（A端とB端を除く）のすべてを使用します。これは、キー入力のバイアス値で係数の「ベストフィット」の計算で行われます。バイアス値は、特定の直管で増加する場合、その直管誤差は、最適化プロセス中に多くの重量を量ります。詳細については、「バイアス因子によって接点（TP）最適合の整列」トピックを参照してください。

  • ハードポイント - ハードポイントの整列は、特定のチューブベースの点（接点、中点など）を使って、測定されたチューブを理論値に整列させることに重要です。ハードポイントの整列及びそれらをチューブに適用する方法の詳細については「ハードポイントの整列」トピックを参照してください。

  • 点間の最適化整列

どちらの整列タイプも「チューブ」ノードの下に、プログラムビューで見ることができます。

詳細:

接点の最適化整列

バイアス因子によって接点（TP）最適合の整列

ハードポイントの整列

点間の最適化整列


接点の最適化整列

接点（TP）の最適化アラインメントはチューブに使用される整列の最も通用のタイプです。これは、実装が非常に容易であり、デフォルトで自動的にプロジェクトに適用されます。

この整列は測定されたチューブのデータを公称値に整列させるようにチューブ接点（A端とB端を除く）のすべてを使用します。これは「ベストフィット」の計算で行われます。

理論値データを有するチューブを測定した後、接点（TP）の最適化整列は適用されます。

このタイプのアライメントを適用するには：

  1. 公称データを有するチューブを測定します。

  2. プロジェクトワークスペースから、Slide-outパネルツールバーに見つかったプログラムの表示ボタン [image] を選択します。プログラムビューのslide-outパネルが表示されます。

  3. 整列ドロップダウンリストから、接点最適化オプションを選択します。選択されると、整列が自動的に適用され、変換として要素リストに挿入されます。

    4. チューブが測定されている場合、接点の最適化整列は測定データに適用されます。

詳細:

チューブを基準とする整列の作成

バイアス因子によって接点（TP）最適合の整列

ハードポイントの整列

点間の最適化整列


バイアス因子によって接点（TP）最適合の整列

バイアス係数は、直管課される重み係数です。標準の接点ベストフィット整列オプションでは、ソフトウェアは、すべて直管はほとんどの場合に許容できる1の重量と同じに扱われます。

それは特定の直管部に強調を置く必要とすつ場合は、バイアス係数オプションを備えた接点（TP）ベストフィット整列は利用可能です。

この整列は測定されたチューブのデータを公称値に整列させるようにチューブ接点（A端とB端を除く）のすべてを使用します。これは、キー入力のバイアス値で係数の「ベストフィット」の計算で行われます。バイアス値は、特定の直管で増加する場合、その直管誤差は、最適化プロセス中に多くの重量を量ります。

このタイプの整列を実行するには：

  1. 公称データを持つチューブを測定した後、バイアス係数で接点のベストフィット整列オプションを選択します。

  2. プロジェクトワークスペースから、Slide-outパネルツールバーに見つかったプログラムの表示ボタン [image] を選択します。プログラムビューのslide-outパネルが表示されます。

  3. 整列ドロップダウンリストから、バイアス係数で接点最適化オプションを選択します。選択されると、整列が自動的に適用され、変換として要素リストに挿入されます。

  4. 必要に応じて、個々のバイアス係数のフィールドを更新します。

    5. チューブが測定されている場合、アップデートされたバイアス係数を有する接点の最適化整列は測定データに適用されます。

詳細:

チューブを基準とする整列の作成

接点の最適化整列

ハードポイントの整列

点間の最適化整列


ハードポイントの整列

ハードポイントの整列は、多くの場合、チューブ上の特定の点が測定後に整列する必要がある場合に使用されます（例えば、チューブのA端またはB端）。これは、4つの点を使用し、そこで面線点アライメントの計算に基づいています：

  • 最初の3点が整列面を定義します。

  • 最初の2点は、整列線を定義します。

  • 第４点は、整列点です。この点は、エラーなしで、完璧にに整列されます。

ハードポイントの整列を実行するには：

  1. その中に、公称データを持つチューブを測定します。

  2. プロジェクトワークスペースから、Slide-outパネルツールバーに見つかったプログラムの表示ボタン [image] を選択します。プログラムビューのslide-outパネルが表示されます。

  3. 整列ドロップダウンリストからハードポイントを選択します。ハードポイントグリッドが表示されます。TubeShaperは提供された公称値からデフォルト点の選択を決定します。上記の例は、3つの直管を備えたチューブに基づいています。デフォルトの選択は次のように定義されます：

    • 最初の点は、A-端部です ― 上記の例で示すように： 最初の直管（直管 1）上の一番目の接点（TP1）。

    • 二番目の点は、B端部です ― 上記の例で示すように： 最後の直管（直管 3）上の最後の接点（TP2）。

    • 三点目は、中間直管の中間点です - 上記の例のように：直管1の中間点。

    • 最後の点は、最初の点を繰り返すA端です。

    これは、A端で0（ゼロ）の整列エラーを作成します。B端で整列エラーを0（ゼロ）にする場合、最後点の直管＃N（最後の直管、この例でn = 3）と接点2を選択します。

    最初の2点は線を定義し、最初の3点は平面を定義し、最後の点は、整列の原点を定義します。

    デフォルトの選択を変更する必要がある場合：

    1. 変更する必要がある直管ドロップダウンリストをクリックし、リストから適切な直管を選択します。

    2. 必要に応じて[タイプ]ドロップダウンリストから対応点のタイプをクリックします。

    3. 他のデフォルトの直管にもこの手順を繰り返します。

理論的には、チューブ上の任意の4点を選択することができます。しかしながら典型的には、A端で0（ゼロ）の整列誤差の場合には以下の規則が守れます：

  • 点1は、第一の直管（S1-TP1 - A端）の接点1です。

  • 点2は、最後の直管上の接点2です（Sn-TP2、ここで「n」は最後の直管 - B端である）。

  • 点3は、中央直管上の中間点です。

  • 固定点である点4は点1または点2のいずれかと同様です。

ハードポイントが定義されると、整列が自動的に行われ、それが次回に測定されるたびにチューブに適用されます。

単にプログラムビューのslide-outパネルの「チューブ」ノードの下から整列を選択することで、接点最適化とハードポイントの整列を切り替えることができます。この方法では、測定相対的なデータグリッド内の接点または交差点のエラーを見ることで、結果がどのように変化するかを確認することができます。

詳細:

チューブを基準とする整列の作成

接点の最適化整列

バイアス因子によって接点（TP）最適合の整列

点間の最適化整列


点間の最適化整列

公称と測定管との間に接点の直線距離を比較したいときにポイントツーポイントのベストフィット整列のみに使用されます。これは特殊なケースの整列と考えられています。

ポイントツーポイント最適化整列オプションは、第一の直管のTP1と最後の直線のTP2を除く管のすべての接点を使用しています。それは点の最小数を必要とするので、それは2つだけのストレートを持つチューブでは使用できません。

点間の最適化整列を実行すること：

  1. 公称データを持つチューブを測定します。

    2. 注意：チューブは、この整列タイプを実行するために、少なくとも三つの直管を持っている必要があります。

  2. プロジェクトワークスペースから、Slide-outパネルツールバーに見つかったプログラムの表示ボタン [image] を選択します。プログラムビューのslide-outパネルが表示されます。

  3. ポイントツーポイント最適化整列オプションを選択します。選択されると、整列が自動的に適用され、変換として要素リストに挿入されます。

    4. チューブが再度に測定される場合、ポイント・ツー・ポイントの最適化整列は測定データに適用されます。

詳細:

チューブを基準とする整列の作成

接点の最適化整列

バイアス因子によって接点（TP）最適合の整列

ハードポイントの整列


角形整列の作成

要素がすでに測定されたら、座標系（または整列）を作成することができます。TubeShaperには、座標系を作成し管理するためのさまざまなツールが用意されています。要素の整列で作業できるツールにアクセスするには、プログラムビューのslide-outパネルから整列ボタン [image] をクリックします。

この章で述べられている主要トピックは、測定ルーチンで要素依存の整列を作成し管理するために用いるこれらのツールの使用方法を説明しています。これらのトピックは以下のとおりです：

  • 平面-直線-点 (PLP) 整列の作成

  • 平面-線-円（PLC）アラインメントの作成

  • 平面-線-線（PLL）アラインメントの作成

  • 平面-円-円（PCC）アラインメントの作成

  • 平面-平面-平面（PPP）整列の作成

  • 最適化アラインメントの作成

詳細:

角形整列の作成:概要

平面-直線-点 (PLP) 整列の作成

平面-線-円（PLC）アラインメントの作成

平面-線-線（PLL）アラインメントの作成

平面-円-円（PCC）アラインメントの作成

平面-平面-平面（PPP）整列の作成

最適化アラインメントの作成


角形整列の作成:概要

要素の作成

要素が初めて作成され、何の角柱アライメントが存在しない場合は、「なし」オプションがデフォルトで設定されます。これは、新規要素は、それに関連付けられたアライメントを持っていないことを意味します。

角柱整列が利用できない場合に「なし」整列オプションで作成された点要素は、デフォルトで選択されます。

角柱アライメントが作成されると、すべての要素は、その整列に入れられて、「なし」の選択は、アライメントの選択肢として除去されます。

角柱アライメントが利用可能になったときに何のオプションも示していない点要素は、選択されます。

要素の整列

プログラムビューの各機能は、整列コンボボックスで指定された関連アライメントを持っています。チューブ要素が、測定ルーチンの一部である場合、追加の「チューブ」オプションが表示されます。このオプションを選択すると、要素がチューブに関連付けられるすべてのアライメントを使用します。

チューブ整列オプションを示す点要素

要素の実行

測定する場合は、機能の実行は、測定ルーチンの上部（開始ノード）から開始します。測定ルーチンは、測定リストに沿う直線経路で実行されます。

TubeShaperは順不同実行をサポートしています。これは、依存要素と整列（上から下へ）は、リニアの順番で測定する必要がないことを意味します。整列の要素は、整列自体の後に来ることができます。しかし、プログラムがリニアの順序である場合には、実行がスムーズにすることができます（実行中に要素が更新され、正しく描画される）。

また、整列への入力として使われると報告される要素がない方が良いです。さもなければ、データの一部は、整列をつくるのに用いられたものとまったく同じです。最適の方法は、いくつかのアラインメントを作成するために使用されている要素と、そのアラインメントに入れることが報告されている他の要素を持つことです。例えば、それは整列がつくられたところと同じ、整列への入力として使われる平面はゼロのZ値を持っています。

詳細:

平面-直線-点 (PLP) 整列の作成

平面-線-円（PLC）アラインメントの作成

平面-線-線（PLL）アラインメントの作成

平面-円-円（PCC）アラインメントの作成

平面-平面-平面（PPP）整列の作成

最適化アラインメントの作成

角形整列の作成


平面-直線-点 (PLP) 整列の作成

ここに提示された情報は、平面-線-点(PLP)アラインメントを作成する方法について説明します。

ヒント: PLP整列を追加ボタン [image] にアクセスするには、プログラムビューのスslide-outパネル上の整列ボタン [image] をクリックします。

平面、線、点の整列は次のように計算されます：

  1. 平面にレベリングして、その法線ベクトルをZ軸方向として使用します。

  2. その平面に線を投影し、それに回転させて、X軸を確立します。

  3. 点を線に投影して、原点を確立します。

詳細:

PLP要素の水平化、回転及び変換

角形整列の作成


PLP要素の水平化、回転及び変換

PLP整列ダイアログボックスを使用して、選択された要素を水準化、回転及び変換させます。

PLP整列を作成するには：

  1. プログラムのビューボタン [image] をクリックして、プログラムビュー slide-outパネルを表示します。

  2. 整列ボタンをクリックして、PLP整列を追加ボタンにアクセスします。

  3. 整列が挿入される所在の測定ルーチンをクリックします。

  4. PLP整列を追加ボタン [image] をクリックして、PLP整列ダイアログボックスを表示します。要素セレクター一覧が最初にチューブを水平に合わせるために使用できる測定ルーチンで利用可能な平面要素を示していることに注意してください。

    5. PLP整列ダイアログボックス

  5. 要素セレクターリストから、整列用の水準化部品として使用される平面要素をクリックします。チューブのドロップダウンボタンをクリックして、選択しできるチューブのプロパティを表示し、整列に使用します。必要に応じて、垂直スクロールバーを使用します。

  6. いったん選択されると、[次へ]ボタン [image] をクリックして、回転の線要素を定義します。

  7. 要素一覧は、測定ルーチンに選択可能な線要素を表示します。アライメントの回転要素として使用したい線要素をクリックします。いったん選択されると、[次へ]ボタンをクリックして、回転の点要素を定義します。

  8. 要素リストから、整列用の変換部品として使用される点要素をクリックします。

  9. 面、線及び点の要素が整列のために選択されると、[次へ]ボタンをクリックします。

    10. TubeShaperは自動的に新たなアライメントにレベル、回転、及び変換します。新しいアライメントは今、測定ルーチン一覧の一部になります。原点を決定するために、線は、平面に投影され、点は、線に投射されます。

  10. 整列のプロパティを変更するには、[編集]ボタン [image] をクリックします。整列を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

平面-直線-点 (PLP) 整列の作成


平面-線-円（PLC）アラインメントの作成

ここに提示された情報は、平面-線-円(PLC)アラインメントを作成する方法について説明します。

ヒント: PLC整列を追加ボタン [image] にアクセスするには、プログラムビューのスslide-outパネル上の整列ボタン [image] をクリックします。

平面、線、円の整列は次のように計算されます：

  1. 平面にレベリングして、その法線ベクトルをZ軸方向として使用します。

  2. その平面に線を投影し、それに回転させて、X軸を確立します。

  3. 円心に原点を定義します。

詳細:

PLC要素の水平化、回転及び変換

角形整列の作成


PLC要素の水平化、回転及び変換

PLC整列ダイアログボックスを使用して、選択された要素を水準化、回転及び変換させます。

PLC整列を作成するには：

  1. プログラムのビューボタン [image] をクリックして、プログラムビュー slide-outパネルを表示します。

  2. 整列ボタンをクリックして、PLC整列を追加ボタンにアクセスします。

  3. 整列が挿入される所在の測定ルーチンをクリックします。

  4. PLC整列を追加ボタン [image] をクリックして、PLC整列ダイアログボックスを表示します。要素セレクター一覧が最初にチューブを水平に合わせるために使用できる測定ルーチンで利用可能な平面要素を示していることに注意してください。

    5. PLC整列ダイアログボックス

  5. 要素セレクターリストから、整列用の水準化部品として使用される平面要素をクリックします。チューブのドロップダウンボタンをクリックして、選択しできるチューブのプロパティを表示し、整列に使用します。必要に応じて、垂直スクロールバーを使用します。

  6. いったん選択されると、[次へ]ボタン [image] をクリックして、回転の線要素を定義します。

  7. 要素一覧は、測定ルーチンに選択可能な線要素を表示します。アライメントの回転要素として使用したい線要素をクリックします。いったん選択されると、[次へ]ボタンをクリックして、変換する円要素を定義します。

  8. 要素リストから、整列用の変換部品として使用される円要素をクリックします。

  9. 平面、線及び円要素が整列のために選択されると、[次へ]ボタンをクリックします。

    10. TubeShaperは自動的に新たなアライメントにレベル、回転、及び変換します。新しいアライメントは今、測定ルーチン一覧の一部になります。

  10. 整列のプロパティを変更するには、[編集]ボタン [image] をクリックします。整列を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

平面-線-円（PLC）アラインメントの作成


平面-線-線（PLL）アラインメントの作成

ここに提示された情報は、平面-線-線(PLL)アラインメントを作成する方法について説明します。

ヒント: PLL整列を追加ボタン [image] にアクセスするには、プログラムビューのスslide-outパネル上の整列ボタン [image] をクリックします。

平面、線、線の整列は次のように計算されます：

  1. 平面にレベリングして、その法線ベクトルをZ軸の方向として使用します。

  2. その平面に第一線を投影し、それに回転させて、X軸を確立します。

  3. 第二直線は、第一直線に交差させて、原点として使用される点を取得します。

詳細:

PLL要素の水平化、回転及び変換

角形整列の作成


PLL要素の水平化、回転及び変換

PLL整列ダイアログボックスを使用して、選択された要素を水準化、回転及び変換させます。

PLL整列を作成するには：

  1. プログラムのビューボタン [image] をクリックして、プログラムビュー slide-outパネルを表示します。

  2. 整列ボタンをクリックして、PLL整列を追加ボタンにアクセスします。

  3. 整列が挿入される所在の測定ルーチンをクリックします。

  4. PLL整列を追加ボタン [image] をクリックして、PLL整列ダイアログボックスを表示します。要素セレクター一覧が最初にチューブを水平に合わせるために使用できる測定ルーチンで利用可能な平面要素を示していることに注意してください。

    5. PLL整列ダイアログ ボックス

  5. 要素セレクターリストから、整列用の水準化部品として使用される平面要素をクリックします。チューブのドロップダウンボタンをクリックして、選択しできるチューブのプロパティを表示し、整列に使用します。必要に応じて、垂直スクロールバーを使用します。

  6. いったん選択されると、[次へ]ボタン [image] をクリックして、回転の線要素を定義します。

  7. 要素一覧は、測定ルーチンに選択可能な線要素を表示します。アライメントの回転要素として使用したい線要素をクリックします。いったん選択されると、[次へ]ボタンをクリックして、変換の線要素を定義します。

  8. 要素リストから、整列用の変換部品として使用される線要素をクリックします。

  9. 面及び二つの線要素が整列のために選択されると、[次へ]ボタンをクリックします。

    10. TubeShaperは自動的に新たなアライメントにレベル、回転、及び変換します。新しいアライメントは今、測定ルーチン一覧の一部になります。回転は、X軸に行われ、原点が二つの線の交点として定義されます。

  10. 整列のプロパティを変更するには、[編集]ボタン [image] をクリックします。整列を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

平面-線-線（PLL）アラインメントの作成


平面-円-円（PCC）アラインメントの作成

ここに提示された情報は、平面-円-円(PCC)アラインメントを作成する方法について説明します。

ヒント: PCC整列を追加ボタン [image] にアクセスするには、プログラムビューのスslide-outパネル上の整列ボタン [image] をクリックします。

平面、円、円の整列は次のように計算されます：

  1. 平面にレベリングして、その法線ベクトルをZ軸方向として使用します。

  2. 両方の円要素の中心を使用して線を作成し、その後、それを回してX軸を確立します。

  3. 最初の円の円心を原点として使用されます。

詳細:

PCC要素の水平化、回転及び変換

角形整列の作成


PCC要素の水平化、回転及び変換

PCC整列ダイアログボックスを使用して、選択された要素を水準化、回転及び変換させます。

PCC整列を作成するには：

  1. プログラムのビューボタン [image] をクリックして、プログラムビュー slide-outパネルを表示します。

  2. 整列ボタンをクリックして、PCC整列を追加ボタンにアクセスします。

  3. 整列が挿入される所在の測定ルーチンをクリックします。

  4. PCC整列を追加ボタン [image] をクリックして、PCC整列ダイアログボックスを表示します。要素セレクター一覧が最初にチューブを水平に合わせるために使用できる測定ルーチンで利用可能な平面要素を示していることに注意してください。

    5. PCC 整列ダイアログ ボックス

  5. 要素セレクターリストから、整列用の水準化部品として使用される平面要素をクリックします。チューブのドロップダウンボタンをクリックして、選択しできるチューブのプロパティを表示し、整列に使用します。必要に応じて、垂直スクロールバーを使用します。

  6. いったん選択されると、[次へ]ボタン [image] をクリックして、回転の円要素を定義します。

  7. 要素一覧は、測定ルーチンに選択可能な円要素を表示します。アライメントの回転要素として使用したい円要素をクリックします。いったん選択されると、[次へ]ボタンをクリックして、変換する円要素を定義します。

  8. 要素リストから、整列用の変換部品として使用される円要素をクリックします。

  9. 面及び二つの円要素が整列のために選択されると、[次へ]ボタンをクリックします。

    10. TubeShaperは自動的に新たなアライメントにレベル、回転、及び変換します。新しいアライメントは今、測定ルーチン一覧の一部になります。回転は、X軸に行われ、原点が第一円の中心として定義されます。

  10. 整列のプロパティを変更するには、[編集]ボタン [image] をクリックします。整列を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

平面-円-円（PCC）アラインメントの作成


平面-平面-平面（PPP）整列の作成

ここに提示された情報は、平面-平面-平面(PPP)アラインメントを作成する方法について説明します。

ヒント: PPP整列を追加ボタン [image] にアクセスするには、プログラムビューのスslide-outパネル上の整列ボタン [image] をクリックします。

平面、平面、平面の整列は次のように計算されます：

  1. 平面にレベリングして、その法線ベクトルをZ軸方向として使用します。

  2. 最初の2つの平面の要素が交差されて、回転線を取得して、X軸を確立します。

  3. 三つの平面要素が交差されて、原点を取得します。

詳細:

PPP要素の水平化、回転及び変換

角形整列の作成


PPP要素の水平化、回転及び変換

PPP整列ダイアログボックスを使用して、選択された要素を水準化、回転及び変換させます。

PPP整列を作成するには：

  1. プログラムのビューボタン [image] をクリックして、プログラムビュー slide-outパネルを表示します。

  2. 整列ボタンをクリックして、PPP整列を追加ボタンにアクセスします。

  3. 整列が挿入される所在の測定ルーチンをクリックします。

  4. PPP整列を追加ボタン [image] をクリックして、PPP整列ダイアログボックスを表示します。要素セレクター一覧が最初にチューブを水平に合わせるために使用できる測定ルーチンで利用可能な平面要素を示していることに注意してください。

    5. PPP整列ダイアログ ボックス

  5. 要素セレクターリストから、整列用の水準化部品として使用される平面要素をクリックします。チューブのドロップダウンボタンをクリックして、選択しできるチューブのプロパティを表示し、整列に使用します。必要に応じて、垂直スクロールバーを使用します。

  6. いったん選択されると、[次へ]ボタン [image] をクリックして、回転の第二平面要素を定義します。

  7. 要素一覧は、測定ルーチンに選択可能な残っている平面要素を表示します。アライメントの回転要素として使用したい平面要素をクリックします。いったん選択されると、[次へ]ボタンをクリックして、変換の平面要素を定義します。

  8. 要素リストから、整列用の変換部品として使用される三番目の平面要素をクリックします。

  9. 三つの面要素が整列のために選択されると、[次へ]ボタンをクリックします。

    10. TubeShaperは自動的に新たなアライメントにレベル、回転、及び変換します。新しいアライメントは今、測定ルーチン一覧の一部になります。最初の2つの平面要素が交差されて、線を構築して、回転するX軸を確立します。すべての3つの平面要素が交差されて、原点を定義します。

  10. 整列のプロパティを変更するには、[編集]ボタン [image] をクリックします。整列を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

平面-平面-平面（PPP）整列の作成


最適化アラインメントの作成

ここに提示された情報は、ベストフィットアラインメントを作成する方法について説明します。

最適化アラインメントは、入力点のすべてを使用し、それらからの整列計算します。ユーザが正確に同じ位置に点を取ることができないので、測定した場合、これらの点が変わるので、角柱状の点、線の端と面中心点を使用してはならないことに注意すべきです。要素点が反復に使用できるように強く勧めます。例えば、円からの円心は、連続測定に移動しませんから、したがって、彼らのセンターもそうしません。

ヒント: 最適化整列を追加ボタン [image] にアクセスするには、プログラムビューのスslide-outパネル上の整列ボタン [image] をクリックします。

最適化アラインメントの作成方法:

  1. 測定ルーチンに３つの点要素を持っている必要があります。必要に応じてそれらを作成します。非点要素を使用できますが、それらがアライメントの計算に点に変換されます。

  2. プログラムのビューボタン [image] をクリックして、プログラムビュー slide-outパネルを表示します。

  3. 整列ボタンをクリックして、最適化の整列を追加ボタンにアクセスします。

  4. 整列が挿入される所在の測定ルーチンをクリックします。

  5. 最適化の整列を追加ボタンをクリックして、整列を最適化ダイアログボックスを表示します。要素セレクター一覧は測定ルーチンで利用可能なすべての有効な要素を示していることに注意してください。

    6. [整列を最適化]ダイアログボックス

  6. 要素セレクターの一覧から、少なくとも３つの記載の要素を選択します。チューブのドロップダウンボタンをクリックして、選択しできるチューブのプロパティを表示し、整列に使用します。必要に応じて、垂直スクロールバーを使用します。

  7. 完了されると、次へボタン [image] を押します。

    8. TubeShaperは自動的に変換機能として最適化アライメントを追加し、新たなアライメントは今、測定ルーチンのリストの一部になります。

  8. 整列のプロパティを変更するには、[編集]ボタン [image] をクリックします。整列を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

角形整列の作成


構築された要素

それは物理的な測定を行うことは不可能又は非常に困難である場合に構築要素がしばしば使用されます。それぞれの構築要素タイプは、それを作成する方法は1つ以上あります。これらの方法は、選択された構築要素を作成する前に、利用できるように特定の要素を必要とします。

各構築種類の構築方法は、この表に詳述されています：

構築の種類 | 構築の方法
点 | 平面、平面、平面 線、線の交点 せん、平面交差線
線 | N点から 平面, 平面交点 平面に投影される線
円 | N点から
平面 | N点から 中央平面 オフセット平面

説明及び各構築の例は、下記のトピックから提供されます。

詳細:

構築点の作成

構築線の作成

構築円の作成

構築平面の作成


構築点の作成

構築点を作成することには2つの方法が使用されます：

  • 点の構築 - 「平面、平面、平面」の方法

  • 点の構築 - 「線と線の交差」の方法

  • 点の構築 - 「点と平面の交差」の方法

詳細:

点の構築 - 平面、平面、平面の方法

点の構築 - 線と線の交差の方法

点の構築 - 点と平面の交差の方法


点の構築 - 平面、平面、平面の方法

TubeShaper : Home | 構築された要素 | 構築点の作成 | 点の構築 - 「平面、平面、平面」の方法

点の構築 - 「平面、平面、平面」の方法

「平面、平面、平面」の方法を使用して点を構築するには：

  1. プロジェクトを開き、プログラムのビューボタンをクリックして、プログラムの表示slide-outパネルを表示します。

  2. まだ行っていない場合は、点の構造を構築するために必要な平面要素を作成します。

  3. 構築ボタン [image] をクリックして、構築バーを表示します。構築バーを使用すると、既存の要素（ものはすでに測定または構築された）から（点、線、円などｋの）要素を作成することができます。

  4. 構築点の追加ボタン [image] をクリックします。構築点ダイアログはプログラム一覧に表示されます。

  5. 交差左へ移動 [image] 及び右へ移動 [image] ボタンをクリックして、理論値、+公差及び-公差のビューの間を移動します。

  6. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

  7. 整列一覧から、構築の整列類別を選択します。

  8. 方法の選択一覧から、平面、平面、平面オプションを選択し、次に、[次へ]ボタン [image] をクリックします。

  9. 要素セレクターのリストから、一番目の面要素を選択して、構築を開始します。チューブのドロップダウンボタンをクリックして、選択しできるチューブのプロパティを表示し、構築に使用します。必要に応じて、垂直スクロールバーを使用します。

  10. [次へ]ボタンをクリックします。

  11. 二番目と三番目の面で繰り返します。三番目の平面を選択した後、次へボタンをクリックすると、構築点が作成されます。

    12. 構造の作成に使用される要素は、平面、平面、平面一覧に表示されます。

  12. [編集]ボタン [image] をクリックして構築された点のプロパティにいずれかの変更をします。

  13. 新要素は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  14. 準備ができたら、「実行」ボタン [image] をクリックして、必要に応じて要素を再計算します。構築済の要素を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

構築点の作成

点の構築 - 「線と線の交差」の方法

点の構築 - 「点と平面の交差」の方法


点の構築 - 線と線の交差の方法

TubeShaper : Home | 構築された要素 | 構築点の作成 | 点の構築 - 「線と線の交差」の方法

点の構築 - 「線と線の交差」の方法

「線と線の交差」方法を使用して点を構築するには：

  1. プロジェクトを開き、プログラムのビューボタンをクリックして、プログラムの表示slide-outパネルを表示します。

  2. まだ行っていない場合は、点の構造を構築するために必要な要素を作成します。

  3. 構築ボタン [image] をクリックして、構築バーを表示します。構築バーを使用すると、既存の要素（ものはすでに測定または構築された）から（点、線、円などｋの）要素を作成することができます。

  4. 構築点の追加ボタン [image] をクリックします。構築点ダイアログはプログラム一覧に表示されます。

  5. 交差左へ移動 [image] 及び右へ移動 [image] ボタンをクリックして、理論値、+公差及び-公差のビューの間を移動します。

  6. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

  7. 整列一覧から、構築の整列類別を選択します。

  8. 方法の選択一覧から、線と線の交差オプションを選択し、次に、[次へ]ボタン [image] をクリックします。

  9. 要素セレクターのリストから、一番目の線要素を選択して、構築を開始します。チューブのドロップダウンボタンをクリックして、選択しできるチューブのプロパティを表示し、構築に使用します。必要に応じて、垂直スクロールバーを使用します。

  10. [次へ]ボタンをクリックします。

  11. 二番目の線で繰り返します。二番目の線が選択された後、次へボタンをクリックすると、構築点が作成されます。

    12. 構造の作成に使用される要素は、線と線の交差一覧に表示されます。

  12. [編集]ボタン [image] をクリックして構築された点のプロパティにいずれかの変更をします。

  13. 新要素は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  14. 準備ができたら、「実行」ボタン [image] をクリックして、必要に応じて要素を再計算します。構築済の要素を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

構築点の作成

点の構築 - 「平面、平面、平面」の方法

点の構築 - 「点と平面の交差」の方法


点の構築 - 点と平面の交差の方法

TubeShaper : Home | 構築された要素 | 構築点の作成 | 点の構築 - 「点と平面の交差」の方法

点の構築 - 「点と平面の交差」の方法

「線と面の交差」方法を使用して点を構築するには：

  1. プロジェクトを開き、プログラムのビューボタンをクリックして、プログラムの表示slide-outパネルを表示します。

  2. まだ行っていない場合は、点の構造を構築するために必要な線と平面要素を作成します。

  3. 構築ボタン [image] をクリックして、構築バーを表示します。構築バーを使用すると、既存の要素（ものはすでに測定または構築された）から（点、線、円などｋの）要素を作成することができます。

  4. 構築点の追加ボタン [image] をクリックします。構築点ダイアログはプログラム一覧に表示されます。

  5. 交差左へ移動 [image] 及び右へ移動 [image] ボタンをクリックして、理論値、+公差及び-公差のビューの間を移動します。

  6. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

  7. 整列一覧から、構築の整列類別を選択します。

  8. 方法の選択一覧から、線と平面の交差オプションを選択し、次に、[次へ]ボタン [image] をクリックします。

  9. 要素セレクターのリストから、線要素を選択して、構築を開始します。チューブのドロップダウンボタンをクリックして、選択しできるチューブのプロパティを表示し、構築に使用します。必要に応じて、垂直スクロールバーを使用します。

  10. [次へ]ボタンをクリックします。

  11. 二番目の平面で繰り返します。平面を選択した後、次へボタンをクリックすると、構築点が作成されます。

    12. 構造の作成に使用される線と平面要素は、線と平面の交差一覧に表示されます。

  12. [編集]ボタン [image] をクリックして構築された点のプロパティにいずれかの変更をします。

  13. 新要素は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  14. 準備ができたら、「実行」ボタン [image] をクリックして、必要に応じて要素を再計算します。構築済の要素を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

構築点の作成

点の構築 - 「平面、平面、平面」の方法

点の構築 - 「点と平面の交差」の方法


構築線の作成

TubeShaper : Home | 構築された要素 | 構築線の作成

線要素の構築

注：線、円、円形スロットの要素は常に基準面に投影し、常に結果的に2Dにされています。構築線、円、または円形スロットを作成するとき、彼らは基準面を持っていないので、それらが基準面に投影され、結果的に、これらはいつも3Dです。

構築の点要素を作成することには2つの方法が使用されます：

  • 線の構築 - 「N点から」の方法

  • 線の構築 - 「平面と平面の交差」の方法

  • 線の構築 - 「平面に投影された線」の方法

詳細:

線要素の構築 - 「N点から」の方法

線要素の構築 - 「平面と平面の交差」の方法

線要素の構築 - 「平面に投影された線」の方法


線の構築 - N点からの方法

TubeShaper : Home | 構築された要素 | 構築線の作成 | 線の構築 - 「N点から」の方法

線の構築 - 「N点から」の方法

「N点から」の方法を使用して線を作成するには：

  1. プロジェクトを開き、プログラムのビューボタンをクリックして、プログラムの表示slide-outパネルを表示します。

  2. まだ行っていない場合は、線の構造を構築するために必要な点要素を作成します。

  3. 構築ボタン [image] をクリックして、構築バーを表示します。構築バーを使用すると、既存の要素（ものはすでに測定または構築された）から（点、線、円などｋの）要素を作成することができます。

  4. 構築線の追加ボタン [image] をクリックします。構築線ダイアログはプログラム一覧に表示されます。

  5. 交差左へ移動 [image] 及び右へ移動 [image] ボタンをクリックして、理論値、+公差及び-公差のビューの間を移動します。

  6. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

  7. 整列一覧から、構築の整列類別を選択します。

  8. 選択方法一覧から、N点からオプション選択し、次に、[次へ]ボタン [image] をクリックします。

  9. 要素セレクターのリストから、点要素を選択して、構築に使用します。チューブのドロップダウンボタンをクリックして、選択しできるチューブのプロパティを表示し、構築に使用します。必要に応じて、垂直スクロールバーを使用します。少なくとも三つの点が必要です。

  10. 構築された線を表示するには、[次へ]ボタンをクリックします。

    11. 構造の作成に使用される要素は、N点から一覧に表示されます。

  11. [編集]ボタン [image] をクリックして構築された線のプロパティにいずれかの変更をします。

  12. 新要素は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  13. 準備ができたら、「実行」ボタン [image] をクリックして、必要に応じて要素を再計算します。構築済の要素を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

構築線の作成

線の構築 - 「平面、平面交差」の方法

線の構築 - 「平面に投影された線」の方法


線の構築 - 「平面、平面交差」の方法

「平面と平面の交差」方法を使用して線を構築するには：

  1. プロジェクトを開き、プログラムのビューボタンをクリックして、プログラムの表示slide-outパネルを表示します。

  2. まだ行っていない場合は、線の構造を構築するために必要な要素を作成します。

  3. 構築ボタン [image] をクリックして、構築バーを表示します。構築バーを使用すると、既存の要素（ものはすでに測定または構築された）から（点、線、円などｋの）要素を作成することができます。

  4. 構築線の追加ボタン [image] をクリックします。構築線ダイアログはプログラム一覧に表示されます。

  5. 交差左へ移動 [image] 及び右へ移動 [image] ボタンをクリックして、理論値、+公差及び-公差のビューの間を移動します。

  6. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

  7. 整列一覧から、構築の整列類別を選択します。

  8. 方法の選択一覧から、平面と平面の交差オプションを選択し、次に、[次へ]ボタン [image] をクリックします。

  9. 要素セレクターのリストから、一番目の面要素を選択して、構築を開始します。チューブのドロップダウンボタンをクリックして、選択しできるチューブのプロパティを表示し、構築に使用します。必要に応じて、垂直スクロールバーを使用します。

  10. [次へ]ボタンをクリックします。

  11. 二番目の平面で繰り返します。二番目の平面が選択された後、次へボタンをクリックすると、構築線が作成されます。

    12. 構造の作成に使用される要素は、平面と平面の交差一覧に表示されます。

  12. [編集]ボタン [image] をクリックして構築された線のプロパティにいずれかの変更をします。

  13. 新要素は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  14. 準備ができたら、「実行」ボタン [image] をクリックして、必要に応じて要素を再計算します。構築済の要素を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

構築線の作成

線の構築 - 「N点から」の方法

線の構築 - 「平面に投影された線」の方法


線の構築 - 「平面に投影された線」の方法

「平面に投影された線」方法を使用して線を構築するには：

  1. プロジェクトを開き、プログラムのビューボタンをクリックして、プログラムの表示slide-outパネルを表示します。

  2. まだ行っていない場合は、線の構造を構築するために必要な要素を作成します。

  3. 構築ボタン [image] をクリックして、構築バーを表示します。構築バーを使用すると、既存の要素（ものはすでに測定または構築された）から（点、線、円などｋの）要素を作成することができます。

  4. 構築線の追加ボタン [image] をクリックします。構築線ダイアログはプログラム一覧に表示されます。

  5. 交差左へ移動 [image] 及び右へ移動 [image] ボタンをクリックして、理論値、+公差及び-公差のビューの間を移動します。

  6. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

  7. 整列一覧から、構築の整列類別を選択します。

  8. 方法の選択一覧から、平面に投影の線オプションを選択し、次に、[次へ]ボタン [image] をクリックします。

  9. 要素セレクターのリストから、線要素を選択して、構築を開始します。チューブのドロップダウンボタンをクリックして、選択しできるチューブのプロパティを表示し、構築に使用します。必要に応じて、垂直スクロールバーを使用します。

  10. [次へ]ボタンをクリックします。

  11. 平面を選択します。平面を選択した後、次へボタンをクリックすると、構築線が作成されます。

    12. 構造の作成に使用される要素は、平面に投影された線一覧に表示されます。

  12. [編集]ボタン [image] をクリックして構築された線のプロパティにいずれかの変更をします。

  13. 新要素は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  14. 準備ができたら、「実行」ボタン [image] をクリックして、必要に応じて要素を再計算します。構築済の要素を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

構築線の作成

線の構築 - 「N点から」の方法

線の構築 - 「平面、平面交差」の方法


構築円の作成

構築の円要素を作成するために使用される方法は次のとおりです：

  • 円の構築 - 「N点から」の方法

詳細:

構築された要素

円の構築 - 「N点から」の方法


円の構築 - N点からの方法

TubeShaper : Home | 構築された要素 | 構築円の作成 | 円の構築 - 「N点から」の方法

円の構築 - 「N点から」の方法

「N点から」の方法を使用して円を作成するには：

  1. プロジェクトを開き、プログラムのビューボタンをクリックして、プログラムの表示slide-outパネルを表示します。

  2. まだ行っていない場合は、円の構造を構築するために必要な点を作成します。

  3. 構築ボタン [image] をクリックして、構築バーを表示します。構築バーを使用すると、既存の要素（ものはすでに測定または構築された）から（点、線、円などｋの）要素を作成することができます。

  4. 構築円の追加ボタン [image] をクリックします。構築円ダイアログはプログラム一覧に表示されます。

  5. 交差左へ移動 [image] 及び右へ移動 [image] ボタンをクリックして、理論値、+公差及び-公差のビューの間を移動します。

  6. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

  7. 整列一覧から、構築の整列類別を選択します。

  8. 選択方法一覧から、N点からオプション選択し、次に、[次へ]ボタン [image] をクリックします。

  9. 要素セレクターのリストから、点要素を選択して、構築を開始します。チューブのドロップダウンボタンをクリックして、選択しできるチューブのプロパティを表示し、構築に使用します。必要に応じて、垂直スクロールバーを使用します。少なくとも三つの点が必要です。

  10. 構築された円を表示するには、[次へ]ボタンをクリックします。

    11. 構造の作成に使用される要素は、N点から一覧に表示されます。

  11. [編集]ボタン [image] をクリックして構築された円のプロパティにいずれかの変更をします。

  12. 新要素は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  13. 準備ができたら、「実行」ボタン [image] をクリックして、必要に応じて要素を再計算します。構築済の要素を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

構築円の作成


構築平面の作成

構築の平面要素を作成することには2つの方法が使用されます：

  • 平面の構築 - 「N点から」の方法

  • 平面の構築 - 「中面」の方法

  • 線の構築 - 「平面をオフセット」の方法

詳細:

構築された要素

平面の構築 - 「N点から」の方法

平面の構築 - 「中面」の方法

線の構築 - 「平面をオフセット」の方法


平面の構築 - N点からの方法

TubeShaper : Home | 構築された要素 | 構築平面の作成 | 平面の構築 - 「N点から」の方法

平面の構築 - 「N点から」の方法

「N点から」の方法を使用して平面を作成するには：

  1. プロジェクトを開き、プログラムのビューボタンをクリックして、プログラムの表示slide-outパネルを表示します。

  2. まだ行っていない場合は、平面の構造を構築するために必要な点を作成します。

  3. 構築ボタン [image] をクリックして、構築バーを表示します。構築バーを使用すると、既存の要素（ものはすでに測定または構築された）から（点、線、円などｋの）要素を作成することができます。

  4. 構築平面の追加ボタン [image] をクリックします。構築平面ダイアログはプログラム一覧に表示されます。

  5. 交差左へ移動 [image] 及び右へ移動 [image] ボタンをクリックして、理論値、+公差及び-公差のビューの間を移動します。

  6. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

  7. 整列一覧から、構築の整列類別を選択します。

  8. 選択方法一覧から、N点からオプション選択し、次に、[次へ]ボタン [image] をクリックします。

  9. 要素セレクターのリストから、点要素を選択して、構築を開始します。チューブのドロップダウンボタンをクリックして、選択しできるチューブのプロパティを表示し、構築に使用します。必要に応じて、垂直スクロールバーを使用します。少なくとも三つの点が必要です。

  10. 構築された平面を表示するには、[次へ]ボタンをクリックします。

    11. 構造の作成に使用される要素は、N点から一覧に表示されます。

  11. [編集]ボタン [image] をクリックして構築された平面のプロパティにいずれかの変更をします。

  12. 新要素は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  13. 準備ができたら、「実行」ボタン [image] をクリックして、必要に応じて要素を再計算します。構築済の要素を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

構築平面の作成

平面の構築 - 「中面」の方法

線の構築 - 「平面をオフセット」の方法


平面の構築 - 中面の方法

TubeShaper : Home | 構築された要素 | 構築平面の作成 | 平面の構築 - 「中面」の方法

平面の構築 - 「中面」の方法

「中面」の方法を使用して平面を作成するには：

  1. プロジェクトを開き、プログラムのビューボタンをクリックして、プログラムの表示slide-outパネルを表示します。

  2. まだ行っていない場合は、面の構造を構築するために必要な要素を作成します。

  3. 構築ボタン [image] をクリックして、構築バーを表示します。構築バーを使用すると、既存の要素（ものはすでに測定または構築された）から（点、線、円などｋの）要素を作成することができます。

  4. 構築平面の追加ボタン [image] をクリックします。構築平面ダイアログはプログラム一覧に表示されます。

  5. 交差左へ移動 [image] 及び右へ移動 [image] ボタンをクリックして、理論値、+公差及び-公差のビューの間を移動します。

  6. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

  7. 整列一覧から、構築の整列類別を選択します。

  8. 選択方法一覧から、中面オプション選択し、次に、[次へ]ボタン [image] をクリックします。

  9. 要素セレクターのリストから、一番目の面要素を選択して、構築を開始します。チューブのドロップダウンボタンをクリックして、選択しできるチューブのプロパティを表示し、構築に使用します。必要に応じて、垂直スクロールバーを使用します。

  10. [次へ]ボタンをクリックします。

  11. 二番目の平面で繰り返します。二番目の平面が選択された後、次へボタンをクリックすると、構築平面が作成されます。

    12. 構造の作成に使用される要素は、中面一覧に表示されます。

  12. [編集]ボタン [image] をクリックして構築された平面のプロパティにいずれかの変更をします。

  13. 新要素は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  14. 準備ができたら、「実行」ボタン [image] をクリックして、必要に応じて要素を再計算します。構築済の要素を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

構築平面の作成

平面の構築 - 「N点から」の方法

線の構築 - 「平面をオフセット」の方法


線の構築 - 平面のオフセットの方法

TubeShaper : Home | 構築された要素 | 構築平面の作成 | 線の構築 - 「平面をオフセット」の方法

線の構築 - 「平面をオフセット」の方法

「中面」の方法を使用して平面を作成するには：

  1. プロジェクトを開き、プログラムのビューボタンをクリックして、プログラムの表示slide-outパネルを表示します。

  2. まだ行っていない場合は、面の構造を構築するために必要な要素を作成します。

  3. 構築ボタン [image] をクリックして、構築バーを表示します。構築バーを使用すると、既存の要素（ものはすでに測定または構築された）から（点、線、円などｋの）要素を作成することができます。

  4. 構築平面の追加ボタン [image] をクリックします。構築平面ダイアログはプログラム一覧に表示されます。

  5. 交差左へ移動 [image] 及び右へ移動 [image] ボタンをクリックして、理論値、+公差及び-公差のビューの間を移動します。

  6. 与えられたフィールド（X、Y、Z、直径、幅、長さ、など）に公差をオンまたはオフにします。

    • オフにすると、フィールドの公差は使用されません。フィールドのラベルは公差が使用されていないことを示すために、グレーで表示されます。

    • オンにすると、公差が使用されて、フィールドのラベルは、測定値に基づいて赤（公差範囲外）または緑色（公差範囲内）になります。

    これをするには、以下の操作を行います:

    1. 要素が要素バーから選択されると、公差ビューが表示されるまで左へ移動ボタンをクリックするか、または右へ移動ボタンをクリックします。

    2. 各フィールドのドロップダウン矢印をクリックし、適切なオプションを選択して、そのフィールドの公差を有効または無効にします。

    3. 左へ移動または右へ移動ボタンをクリックして、それらのオンにされている公差値を表示または変更します。

  7. 整列一覧から、構築の整列類別を選択します。

  8. 選択方法一覧から、平面をオフセットオプション選択し、次に、[次へ]ボタン [image] をクリックします。

  9. 要素セレクターのリストから、面要素を選択して、構築を開始します。チューブのドロップダウンボタンをクリックして、選択しできるチューブのプロパティを表示し、構築に使用します。必要に応じて、垂直スクロールバーを使用します。

  10. [次へ]ボタンをクリックします。

  11. オフセットの入力エリアから、X、Y、Zのオフセット値を入力します。

  12. [次へ]ボタンをクリックします。[次へ]ボタンをクリックすると、構築面が作成されます。

    13. 構造の作成に使用される要素は、オフセット平面一覧に表示されます。

  13. [編集]ボタン [image] をクリックして構築された平面のプロパティにいずれかの変更をします。

  14. 新要素は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  15. 準備ができたら、「実行」ボタン [image] をクリックして、必要に応じて要素を再計算します。構築済の要素を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

構築平面の作成

平面の構築 - 「N点から」の方法

平面の構築 - 「中面」の方法


寸法

要素が測定か構築されたならば、要素間の寸法を計算することができます。

すべての要素および構造は、点に縮小される - その原点またはXYZ座標のいずれかが寸法ダイアログボックスに表示されます。すべての寸法は、結果的に、最初に選択された要素または二番目までの構造の重心からの直線を使用している3Dの距離に基づいています。

この章の主なトピックは、次のとおり:

  • 距離寸法

  • 角度寸法

詳細:

距離寸法の作成

角度寸法の作成


距離寸法の作成

2つの要素間の距離寸法を計算するには:

  1. プロジェクトを開き、プログラムのビューボタンをクリックして、プログラムの表示slide-outパネルを表示します。

  2. まだ行っていない場合は、必要な要素を作成か、構築します。

  3. 寸法バーを表示するには、寸法ボタン [image] をクリックします。寸法バーを使用すると、2つの要素間の距離や角度の寸法を計算することができます。

  4. 距離寸法ボタン [image] をクリックします。距離寸法ダイアログボックスは、プログラム一覧に表示されます。

  5. 要素セレクターのリストから、第一の要素を選択します。チューブのドロップダウンボタンをクリックして、選択か、使用できるチューブのプロパティを表示します。必要に応じて、垂直スクロールバーを使用します。

  6. [次へ]ボタン [image] をクリックします。

  7. 次の要素にも繰り返します。二番目の要素が選択された後で、[次へ]ボタンがクリックされると、計算された距離は3D距離ボックスに表示されます。

    8. 距離の計算に使用される要素は入力要素一覧に表示されます。

  8. 距離寸法のプロパティを変更するには、[編集]ボタン [image] をクリックします。

  9. 新たな距離寸法は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  10. 準備ができたら、「実行」ボタン [image] をクリックして、必要に応じて要素を再計算します。距離寸法を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

寸法

角度寸法の作成


角度寸法の作成

2つの要素間の角度寸法を計算するには:

  1. プロジェクトを開き、プログラムのビューボタンをクリックして、プログラムの表示slide-outパネルを表示します。

  2. まだ行っていない場合は、必要な要素を作成か、構築します。

  3. 寸法バーを表示するには、寸法ボタン [image] をクリックします。寸法バーを使用すると、2つの要素間の距離や角度の寸法を計算することができます。

  4. 角度寸法ボタン [image] をクリックします。角度寸法ダイアログボックスは、プログラム一覧に表示されます。

  5. 要素セレクターのリストから、第一の要素を選択します。チューブのドロップダウンボタンをクリックして、選択か、使用できるチューブのプロパティを表示します。必要に応じて、垂直スクロールバーを使用します。

  6. [次へ]ボタン [image] をクリックします。

  7. 次の要素にも繰り返します。二番目の要素が選択された後で、[次へ]ボタンがクリックされると、計算された角度は角度ボックスに表示されます。

    8. 角度の計算に使用される要素は入力要素一覧に表示されます。

  8. 角度寸法のプロパティを変更するには、[編集]ボタン [image] をクリックします。

  9. 新たな距離寸法は、デフォルトでレポートに追加されます。レポートに格納ボタン [image] をクリックして、新規要素をレポートに追加されたかどうかを切り替えます。それは灰色で表示されたときにボタンが無効になっています。

  10. 準備ができたら、「実行」ボタン [image] をクリックして、必要に応じて要素を再計算します。角度寸法を削除するには、[要素を削除]ボタン [image] をクリックします。

詳細:

寸法

距離寸法の作成


レポート

レポートビューを表示するには、TubeShaperメイン画面のプロジェクトの一覧表示エリアからのプロジェクトのいずれかをダブルクリックし、次に[レポート]タブをクリックします。

特定のプロジェクトの既存のレポートを表示するには：

  1. TubeShaperメイン画面から[レポート]をクリックして、レポートのハブビューを表示します。

  2. 左側のレポート一覧エリアのチューブプロジェクトをクリックします。選択されたチューブプロジェクトのすべてのレポートが右側のレポート詳細エリアに表示されます。

  3. レポートをダブルクリックして、それをレポートビューで開きます。

必要に応じてレポートオプションボタン [image] をクリックして、レポートを変更します。

完了したら、[保存/エクスポートメニューボタン [image] をクリックして、TubeShaperのレポートファイルとしてレポートを保存するか、またはPDFやCSVファイルタイプとしてエクスポートします。また、印刷ボタン [image] を使用してレポートを印刷することができます。これらのボタンは、レポートビュー画面の右下に配置されます。

レポートの保存、エクスポート及び印刷の詳細については、「レポートの保存、エクスポート及び印刷」章を参照してください。

詳細:

新規レポートの作成

既存のレポートの変更

レポートの保存、エクスポート及び印刷


レポートの新規作成

レポートを新規作成するには：

  1. 編集モードでプロジェクトを表示するには、メイン画面のプロジェクトの一覧表示エリアから管プロジェクトをダブルクリックします。

  2. [レポート]タブをクリックして、選択されたチューブプロジェクトのレポートを表示します。

  3. レポートオプション引き出しパネルが見えない場合、それを表示するには、編集画面の右上に位置するレポートオプションボタン [image] をクリックします。詳細は「レポートオプション」トピックを参照してください。

  4. 必要に応じてレポートオプションを更新します。レポートはすぐに行われた変更に基づいて、レポートのワークスペースに更新します。

  5. [レポートオプション]ダイアログ内のオプションをクリックして、ドラッグすることで、レポート内のセクションの順序を変更します。レポートはすぐに行われた変更に基づいて、レポートのワークスペースに更新します。

  6. すべてのレポートオプションが設定され、且つ、レポートが望まれたように組織化されると、[ワークスペース]タブをクリックして、画面の下部にあるアクションバーを表示します。

  7. 保存/エクスポートニューボタン [image] をクリックして、新規レポートを完了します。

詳細:

レポートオプション

既存のレポートの変更


レポートオプション

各レポートオプションの右側にあるチェックボックスをマークして、それらをアクティブにします。アクティブ化されると、ソフトウェアはオプションに記載された順序でレポートに挿入します。

複数のアイテムを使用したレポートのオプショングループは3つの設定があります：

  • 最上位のチェックボックスがマークされる [image] 場合、すべてのオプションは、グループで選択されます。

  • チェックボックスがソリッド着色されたボックス [image] である場合、グループ内の部分のオプションだけは選択されます。

  • チェックボックスが空 [image] の場合、グループ内の項目が選択されていません。

レポートのオプションを編集するには：

  1. 編集モードでプロジェクトを表示するには、メイン画面のプロジェクトの一覧表示エリアからプロジェクトをダブルクリックします。

  2. それが見えない場合に、レポートオプションボタン [image] をクリックして、レポートオプションビュー slide-outパネルを表示します。

  3. 各オプションの右側にある適切なチェックボックスをマークして、レポートに必要なオプションを更新します。

  4. レポートオプションパネルでセクションをクリックし、ドラッグして、レポートにそれらを並べ替えます。このソフトウエアはすぐに行われた変更に基づいて、レポートワークスペース内の表示を更新します。

  5. すべてのレポートオプションが設定され、且つ、レポートが望まれたように組織化されると、[ワークスペース]タブをクリックして、画面の下部にあるアクションバーを表示します。

  6. 保存/エクスポートメニューボタン [image] をクリックして、行われたすべての変更を保存します。レポートの保存、エクスポート及び印刷の詳細については、「レポートの保存、エクスポート及び印刷」章を参照してください。

以下のレポートオプションは利用できます:

詳細:

会社ロゴのレポートオプション

CAD表示のレポートオプション

TP（接点）データレポートオプション

端部統計レポートオプション

CLRA（修正済LRA）データレポートオプション

LRA（長さ、半径、角度）データレポートオプション

ALRA（絶対の長さ、半径、角度）データレポートオプション

XYZデータレポートオプション

要素レポートオプション

チューブのプロパティレポートオプション


会社ロゴのレポートオプション

会社のロゴオプションは、レポートの先頭に追加された会社のロゴの画像ファイルをインポートするために使用されます。

レポートにロゴを変更するには：

  1. 会社のロゴチェックボックスをクリックし、それをマークして、ロゴイメージがレポートに追加されます。

  2. イメージファイルの参照ダイアログボックスを表示するには、[参照]ボタン [image] をクリックします。

  3. 会社のロゴの画像ファイルに移動し、それを選択して、レポートに追加します。また、手動でもファイルの場所を入力することができます。

  4. レポートにファイルをインポートするには、[開く]をクリックします。

詳細:

新規レポートの作成

レポートオプション

CAD表示のレポートオプション

TP（接点）データレポートオプション

終了統計のレポートオプション

CLRA（修正済の長半径角度）データレポートオプション

LRA（長半径角度）データレポートオプション

ALRA（絶対長半径角度）データレポートオプション

XYZデータレポートオプション

要素レポートオプション

チューブのプロパティレポートオプション


CAD表示のレポートオプション

CADビューチェックボックスオプションをチェックすると、レポートにCAD画像が表示されます。

詳細:

新規レポートの作成

レポートオプション

会社ロゴのレポートオプション

TP（接点）データレポートオプション

終了統計のレポートオプション

CLRA（修正済の長半径角度）データレポートオプション

LRA（長半径角度）データレポートオプション

ALRA（絶対長半径角度）データレポートオプション

XYZデータレポートオプション

要素レポートオプション

チューブのプロパティレポートオプション


接点データレポートオプション

TubeShaper : Home | レポート | レポートの新規作成 | レポートオプション | TPデータレポートオプション

TP（接点）データレポートオプション

接点データチェックボックスをマークしてレポートに接点のデータを挿入します。

詳細:

新規レポートの作成

レポートオプション

会社ロゴのレポートオプション

CAD表示のレポートオプション

終了統計のレポートオプション

CLRA（修正済の長半径角度）データレポートオプション

LRA（長半径角度）データレポートオプション

ALRA（絶対長半径角度）データレポートオプション

XYZデータレポートオプション

要素レポートオプション

チューブのプロパティレポートオプション


端部統計レポートオプション

TubeShaper : Home | レポート | レポートの新規作成 | レポートオプション | 端部統計レポートオプション

終了の統計

端部統計チェックボックスをマークすると、A端とB端のために、長さ、角度及びをオフセットを含んでいる統計データを挿入します。

詳細:

新規レポートの作成

レポートオプション

会社ロゴのレポートオプション

CAD表示のレポートオプション

TP（接点）データレポートオプション

CLRA（修正済LRA）データレポートオプション

LRA（長さ、半径、角度）データレポートオプション

ALRA（絶対の長さ、半径、角度）データレポートオプション

XYZデータレポートオプション

要素レポートオプション

チューブのプロパティレポートオプション


修正済LRAデータレポートオプション

TubeShaper : Home | レポート | レポートの新規作成 | レポートオプション | 修正済LRAデータレポートオプション

CLRA（修正済LRA）レポートオプション

CLRAデータチェックボックスをマークしてレポートに修正のLRAデータを挿入します。

詳細:

新規レポートの作成

レポートオプション

会社ロゴのレポートオプション

CAD表示のレポートオプション

TP（接点）データレポートオプション

終了統計のレポートオプション

LRA（長半径角度）データレポートオプション

ALRA（絶対長半径角度）データレポートオプション

XYZデータレポートオプション

要素レポートオプション

チューブのプロパティレポートオプション


LRA データレポートオプション

TubeShaper : Home | レポート | レポートの新規作成 | レポートオプション | LRA データレポートオプション

LRA（長さ、半径、角度）レポートオプション

LRAデータチェックボックスをマークしてレポートにLRAのデータを挿入します。

さらに、個々のチェックボックスをクリックして、レポートに公称値、測定値または偏差のデータを格納することができます。

詳細:

新規レポートの作成

レポートオプション

会社ロゴのレポートオプション

CAD表示のレポートオプション

TP（接点）データレポートオプション

終了統計のレポートオプション

CLRA（修正済LRA）データレポートオプション

ALRA（絶対長半径角度）データレポートオプション

XYZデータレポートオプション

要素レポートオプション

チューブのプロパティレポートオプション


絶対LRAデータレポートオプション

TubeShaper : Home | レポート | レポートの新規作成 | レポートオプション | Absolute LRA Report Option

ALRA（絶対LRA）レポートオプション

ALRAデータチェックボックスをマークしてレポートに絶対LRAのデータを挿入します。

さらに、個々のチェックボックスをクリックして、レポートに公称値、測定値または偏差のデータを格納することができます。

詳細:

新規レポートの作成

レポートオプション

会社ロゴのレポートオプション

CAD表示のレポートオプション

TP（接点）データレポートオプション

終了統計のレポートオプション

CLRA（修正済LRA）データレポートオプション

LRA（長半径角度）データレポートオプション

XYZデータレポートオプション

要素レポートオプション

チューブのプロパティレポートオプション


XYZデータレポートオプション

XYZデータチェックボックスをマークしてレポートにXYZのデータを挿入します。

さらに、個々のチェックボックスをクリックして、レポートに公称値、測定値または偏差のデータを格納することができます。

詳細:

新規レポートの作成

レポートオプション

会社ロゴのレポートオプション

CAD表示のレポートオプション

TP（接点）データレポートオプション

終了統計のレポートオプション

CLRA（修正済LRA）データレポートオプション

LRA（長半径角度）データレポートオプション

ALRA（絶対LRA）データレポートオプション

要素レポートオプション

チューブのプロパティレポートオプション


要素レポートオプション

要素チェックボックスがマークされると、レポートに定義されるすべての要素のデータを挿入します。

詳細:

新規レポートの作成

レポートオプション

会社ロゴのレポートオプション

CAD表示のレポートオプション

TP（接点）データレポートオプション

終了統計のレポートオプション

CLRA（修正済LRA）データレポートオプション

LRA（長さ、半径、角度）データレポートオプション

ALRA（絶対の長さ、半径、角度）データレポートオプション

XYZデータレポートオプション

チューブのプロパティレポートオプション


チューブのプロパティレポートオプション

チューブのプロパティチェックボックス [image] をマークすると、レポートにすべてのチューブのプロパティのオプションを挿入します。

注記： 個々の選択 [image] 用のチューブのプロパティチェックボックスをマークすると、オプションを個別に選択することができます。

    全般 - これがマークされた場合、プロジェクトのすべての汎用のプロパティの詳細は、レポートに含まれています。詳細については、「汎用のプロパティ」を参照してください。

    単位 - これがマークされた場合、プロジェクトの測定単位は、レポートに含まれます。

    物性 - これがマークされた場合、チューブに関連される物性の詳細は、レポートに含まれます。詳細については、「物性」トピックを参照してください。

    公差 - これがマークされた場合、すべての公差値がレポートに含まれます。詳細については、「公差のプロパティ」トピックを参照してください。

    検査オプション - これがマークされた場合、検査の詳細がレポートに含まれます。詳細については、「検査オプションのプロパティ」を参照してください。

    修正オプション - これがマークされた場合、修正の詳細がレポートに含まれます。詳細については、「修正オプションのプロパティ」トピックを参照してください。

詳細:

新規レポートの作成

レポートオプション

会社ロゴのレポートオプション

CAD表示のレポートオプション

TP（接点）データレポートオプション

終了統計のレポートオプション

CLRA（修正済LRA）データレポートオプション

LRA（長さ、半径、角度）データレポートオプション

ALRA（絶対の長さ、半径、角度）データレポートオプション

XYZデータレポートオプション

要素レポートオプション


既存のレポートの変更

既存のレポートを変更するには：

  1. プロジェクトのハブビュー画面のプロジェクト一覧エリアから管プロジェクトをダブルクリックして、プロジェクトのワークスペースを表示します。

  2. レポートをクリックして、現時点で開かれているプロジェクトの既存のレポートを表示します。

  3. レポートオプションslide-outパネルが見えない場合、それを表示するには、編集画面の右上に位置するレポートオプションボタン [image] をクリックします。詳細は「レポートオプション」トピックを参照してください。

  4. 拡大及び縮小コントロール [image] を使って、必要に応じてレポートを表示します。選択可能なズームオプション一覧を表示するには、ズーム比率フィールドの右側にある上矢印をクリックします。

  5. 必要に応じてレポートオプションを更新します。

  6. 必要に応じてレポートオプションのslide-outパネルにある様々なセクションをクリックしてドラッグして、これらを移動します。

    7. レポートは、選択されたオプション、及びレポートオプションのslide-outパネルにある各セクションの位置に基づいてレポートビューのエリアに更新されます。

    レポートの保存、エクスポート及び印刷の詳細については、「レポートの保存、エクスポート及び印刷」章を参照してください。

詳細:

レポート

レポートの新規作成

レポートオプション

レポートの保存、エクスポート及び印刷


レポートの保存、エクスポート及び印刷

現時点のチューブプロジェクトのレポートが変更されると、それらをPDFやCSVファイルタイプとして簡単に保存か、エクスポートするか、または検討のために印刷することができます。

TubeShaperはレポートワークスペースの右下に位置する保存/エクスポートメニュー [image] 及び印刷 [image] ボタンを使用して、これらのオプションを提供します。

下記のトピックでは、レポートの保存、エクスポート及び印刷の方法について説明します。

詳細:

レポートの保存

レポートのエクスポート

レポートの印刷

レポート

新規レポートの作成

既存のレポートの変更


レポートの保存

レポートは、現在の単位設定に保存されるか、または保存される前に単位を変更することができます。現在のレポートの単位を変更するには：

  1. レポートが開かれている状態で、[アプリケーションの設定]ボタン [image] をクリックします。

  2. [全般]タブから、表示される目的の単位ををクリックします。

  3. [OK]をクリックして、レポートの新しいユニットを設定します。

  4. 以下に説明されたように適用される新しいユニットの設定を使ってレポートを保存します。

現時点のレポートを保存するには：

  1. 保存/エクスポートメニューボタン [image] をクリックします。保存/エクスポートポップアップメニューが表示されます。

  2. [保存]オプションをクリックして、レポートを保存します。

    3. レポートが次のように保存されます：

    • デフォルトの場所がアプリケーションの設定に変更されていない限り、レポートは、プロジェクト名で次のフォルダに保存されます：「C:\Users\Public\Documents\WAI\TubeShaper\Reports」。

    • プロジェクトフォルダが存在しない場合は、新規フォルダが作成されます。

    • すべてのレポートは、「_yyyy-MM-DD-HH-MM-SS」の形式で、ファイル名の最後に追加された日付/時間スタンプに続くチューブプロジェクトの名前で保存されます。

    • レポートはTubeShaperレポートプロジェクトファイルの拡張子である「.htr」が付いています。

詳細:

レポートのエクスポート

レポートの印刷

レポート

新規レポートの作成

既存のレポートの変更


レポートのエクスポート

現時点のレポートをエクスポートするには：

  1. レポート画面の右下に置けるTubeShaperレポートを保存するには、[保存/エクスポートメニュー]ボタン [image] をクリックします。保存/エクスポートポップアップメニューが表示されます。

  2. [エクスポート]オプションをクリックして、レポートを保存します。[レポートのエクスポート]ダイアログボックスが表示されます。

  3. デフォルトのレポートのパスがパスフィールドに表示されます。このフィールドの下矢印をクリックし、且つ、使用可能な場合、ドロップダウンリストから異なる場所を選択します。また、ダイアログボックスの中左にあるナビゲーションウィンドウを使用して、エクスポートの場所を変更することができます。

  4. エクスポートされたレポートは、デフォルトで「_yyyy-MM-DD-HH-MM-SS」の形式で、ファイル名の最後に追加された日付/時間スタンプに続くチューブプロジェクトの名前で保存されます。ファイル名フィールドをクリックし、新たな名前を入力するか、または必要に応じてデフォルトの名前を変更することで、名前を変更することができます。

  5. ファイルフィルタのドロップダウン矢印をクリックして、エクスポートされたレポートのファイルタイプを選択します。TubeShaperは、PDFやCSVファイルタイプとしてレポートをエクスポートします。

  6. 選択に基づいてファイルのエクスポートが完了される場合に[保存]をクリックします。キャンセルをクリックして、ダイアログボックスを閉じるます。

詳細:

レポートの保存

レポートの印刷

レポート

新規レポートの作成

既存のレポートの変更


レポートの印刷

現時点のレポートを印刷するには：

  1. レポート画面の右下の[印刷ボタン [image] をクリックして、[印刷設定]ダイアログボックスを表示します。

  2. プリンタのドロップダウンリストからプリンタを選択します。デフォルトのプリンタが自動的に選択されます。

  3. [すべて]を選択して、レポート全体を印刷するか、または範囲オプションを選択して印刷するページ範囲を入力することができます。

  4. 必要に応じて印刷の部数を入力します。

  5. [印刷]をクリックして、選択されたオプションに基づいてレポートの印刷を開始します。キャンセルをクリックして、ダイアログを終了します。

詳細:

レポートの保存

レポートのエクスポート

レポート

新規レポートの作成

既存のレポートの変更


ショップフロアモード

TubeShaperの現場モードは、アクセスをより限られた機能に提供します。

現場モードに入るには、メインメニューバーの右側にある現場モードボタン [image] をクリックします。

オンにすると、「（現場モード）」とのテキストの追加でタイトルバーが変更されて、画面テキストおよびアイコンも拡大されます。

再び現場モードボタンをクリックすることで、エンジニアリングモードに戻ります。パスワードが適用される場合、[ログイン]ダイアログボックスが表示されます。

ログインダイアログ ボックス

エンジニアリングモードに戻るにはパスワードを入力し、[OK]をクリックします。

ページタイトルが「（現場モード）」というテキストの取り除きで更新されます。画面のテキストとアイコンは、エンジニアリング画面に戻ります。

詳細:

現場モード:概要

現場モード:プロジェクトワークスペース

現場モード:ベンダー画面

現場モード:レポート画面

現場モード：チューブの測定


現場モード:概要

最小限の機能が必要とされる場合に現場モードが使用されます：

  • 必要に応じて現在のチューブプロパティの変更をするいくつかの能力を持つ既存のチューブのプロジェクトを使用してチューブを測定します。

  • 既存のベンダープロジェクトの検討及び編集

  • レポートの検討、保存、エクスポート及び印刷

TubeShaperが初めて現場モードで開かれる場合は、メインプロジェクトハブビュー画面が表示されます。

現場モードにある時のメインプロジェクトハブビュー画面の例

並べて表示ボタン [image] をクリックすることで、上記のように、左側のプロジェクトの一覧は、タイルビューで表示することができます。詳細表示ボタン [image] をクリックして、チューブプロジェクトを詳細なリストビューに表示します。

現場のモード（下）と対照してエンジニアリングモード（上）のメインメニューボタンを示す例

現場モードではソフトウェアがアプリケーションの設定で特定のオプションを無効にします。詳細については、「アプリケーションの設定 - 現場モード」トピック を参照してください。

TubeShaper アプリケーションの設定メニューオプションの完全なエンジニアリングモードの機能の詳細については、「アプリケーションの設定」章を参照してください。

プロジェクトのメニューバーは、現場モードでメイン画面から取り除かれます。このメニューバーは、プログラムを測定/停止ボタン [image] に置き換えられます。その後、チューブプロジェクトを選択して、関連するチューブを測定することができます。ソフトウェアは、プロジェクトが作成、コピー、削除、または編集されることを防ぐことができます。

TubeShaper プロジェクトメニューバーの完全なエンジニアリングモードの機能の詳細については、「プロジェクトメニューバー」トピックを参照してください。

TubeShaperの現場モードでチューブの測定の詳細については、「現場モード：チューブの測定」章を参照してください。

以下のトピックでは、プロジェクトワークスペース、ベンダー、レポートの画面及び現場モードでチューブの測定について説明します。

詳細:

ショップフロアモード

現場モード:プロジェクトワークスペース

現場モード:ベンダー画面

現場モード:レポート画面

現場モード：チューブの測定


アプリケーションの設定 - 現場モード

ユーザは[全般]タブの新規プロジェクトのデフォルトのセクションを除いて、一全般、可視性および表示タブのすべてのオプションにアクセスすることができます。パス、要素及び詳細設定タブにはアクセスできません。

[全般]タブオプションの詳細については、「アプリケーションの設定 -[全般]タブ 」トピックを参照してください。

可視性タブオプションの詳細については、「タブアプリケーションの設定 - 可視性タブ」トピックを参照してください。

[表示]タブオプションの詳細については、「アプリケーションの設定- 表示タブトピックを参照してください。

詳細:

現場モード:概要


現場モード:プロジェクトワークスペース

オンラインおよび測定アームが装着されているときに、プロジェクトのワークスペースには、現場モードのみでアクセス可能です。

現場モードでは、プロジェクトのワークスペースで開かれたプロジェクトの例

現場モードがオンにされる場合、プロジェクトのワークスペースから次のことが実行できます。

  • チューブを測定すること

  • チューブデータを再計算すること

  • ベンダーの選択

  • ベンダーからチューブのデータを取得すること

  • ベンダーにチューブのデータを送信すること

  • すべての保存/エクスポートのオプションが有効にされる

  • ビュー選択オプションは、CAD、理論又は実測ビューの図形ビューを表示するように有効にされます。

次のslide-outパネルは現場モードがオンになる場合には変わります：

データビューのslide-outパネル

  • ユーザがXYZ、LRA及びALRAのビューを表示するか、またはビューの間を選択することができますが、何の編集も許可されません。

接点slide-outパネル

  • ユーザは接点データを表示することができます。

CLRAslide-outパネル

  • ユーザはCLRAデータを読むことができますが、何の編集も許可されません。

  • 必要に応じてチューブ切断長さの値を編集または選択することができます。

  • 必要に応じて、B端の違いタグ値を編集することができます。

  • 必要に応じて、B端の違い割合値を編集することができます。

  • 必要に応じて、%B端の違いタグパーセントスライダー値を編集することができます。

プログラムビューのslide-outパネル

  • 現在読み取られたプログラムを読むことができますが、すべてのオプションを編集することができません。

プロジェクト/チューブのプロパティのslide-outパネル

  • 現時点で開かれているプロジェクト及びチューブプロパティを読むことができますが、すべてのオプションを編集することができません。

スプリングバックslide-outパネル

  • 現時点で開かれているプロジェクトのスプリングバックのプロパティを読むことができますが、すべてのオプションは編集できません。

レポートオプションslide-outパネル

  • レポートオプションを読むことができますが、すべてのオプションは編集できません。

エンジニアリングモードでのプロジェクトのワークスペースのそれぞれのエリアの詳細については、「新規プロジェクトのインタフェース」章を参照してください。

詳細:

ショップフロアモード

現場モード:概要

現場モード:ベンダー画面

現場モード:レポート画面

現場モード：チューブの測定


現場モード: ベンダー画面

ベンダーハブビュー画面にアクセスするには、ハブビュー選択ペインのベンダータブのオプションをクリックします。

現場モードのベンダー画面の実例

並べて表示ボタン [image] をクリックすることで、上記のように、左側のベンダーのプロジェクトの一覧は、タイルビューで表示することができます。詳細表示ボタン [image] をクリックして、ベンダーのプロジェクトを詳細なリストビューに表示します。

現場モードでは、ベンダー画面が曲げ機からチューブのデータをダウンロードすることができます。データがローカルで利用可能になると、チューブのプロジェクトを開き、リストからベンダーを選択します。チューブプロジェクトを開いて、現場モードでチューブの測定の詳細については、「現場モード：チューブの測定」トピックを参照してください。

曲げ機からチューブのデータを呼び出すには、次のいずれかの操作を行います：

  • ベンダープロジェクトをダブルクリックして、リコールの操作を開始します。

  • 既存のベンダープロジェクトをシングルクリックし、画面の右下に位置するリコールボタンをクリックします。

ベンダーからチューブデータをリコールする詳細については、「ベンダーからチューブ・データのリコール」トピックを参照してください。

エンジニアリングモードのベンダー画面の各エリアの詳細については、「ベンダー画面の詳細」トピックを参照してください。

詳細:

ショップフロアモード

現場モード:概要

現場モード:プロジェクトワークスペース

現場モード:レポート画面

現場モード：チューブの測定


現場モード:レポート画面

レポートのハブビュー画面にアクセスするには、ハブビュー選択ペインのレポートタブのオプションをクリックします。

現場モードのレポート画面の実例

並べて表示ボタン [image] をクリックすることで、上記のように、左側のレポートプロジェクトの一覧は、タイルビューで表示することができます。詳細表示ボタン [image] をクリックして、レポートプロジェクトを詳細なリストビューに表示します。

レポートハブ画面では、レポートビュー画面に選択されたレポートを表示することができます。その後、現在開いているレポートを表示、保存、およびエクスポートすることができます。

レポートビューにチューブレポートを開くには、次のいずれかの操作を行います：

  • レポートプロジェクトをダブルクリックします。

  • 既存のレポートプロジェクトをシングルクリックし、画面の右下に位置する開くボタンをクリックします。

レポートがレポートビューで開かれている時に利用可能なオプションの詳細については、「現場モード：レポートビュー」トピックを参照してください。

詳細:

ショップフロアモード

現場モード:概要

現場モード:プロジェクトワークスペース

現場モード:ベンダー画面

現場モード：チューブの測定


現場モード：レポートビュー

メインプロジェクトの一覧エリアからレポートをダブルクリックするか、または[開く]をクリックすることで、レポートビュー画面にアクセスします。開いているプロジェクトのレポートを表示するには、[レポート]をクリックします。

特定のプロジェクトの既存のレポートを表示するには：

  1. TubeShaperメイン画面から[レポート]をクリックして、レポートのハブビューを表示します。

  2. 左側のレポート一覧エリアのチューブプロジェクトをクリックします。選択されたチューブプロジェクトのすべてのレポートが右側のレポート詳細エリアに表示されます。

  3. レポートをダブルクリックして、それをレポートビューで開きます。

レポートが現場モードで表示される場合、これらのオプションを使用できます。

    レポートオプション - これをクリックすると、レポートオプションのペインが表示されます。ペインには、レポート出力の順序が表示されますが、編集できません。

    レポートズーム - +/-ボタンをクリックして、レポートを拡大または縮小するか、またはこのリストを使用して、特定のズーム設定を選択します。

    保存/エクスポート - これをクリックして、PDFフォーマットでレポートをエクスポートします。[保存]オプションが、現場モードでは使用できません。

    印刷 - これをクリックしまて、レポートのコピーを印刷します。[印刷]ダイアログボックスが表示されます。

    • プリンタの選択

    • 印刷する部数を設定します。

    • レポート全体または特定のページを印刷することを選択するオプション

[ワークスペース]タブをクリックして、レポートに関連付けられたプロジェクトを表示します。

詳細:

現場モード:レポート画面


現場モード：チューブの測定

現場モードにある場合、これらのいずれかの方法でチューブを測定することができます：

注記: 最初の二つの方法では、TubeShaperが測定を実行できる前に、ROMER絶対アームが設定されてに接続される必要があります。

TubeShaperメイン画面からチューブを測定すること

  1. プロジェクト一覧エリアからプロジェクトを選択すること

  2. 測定ボタン [image] をクリックします。選択されたプロジェクトは、プロジェクトのワークスペースで開かれます。アクションバーに表示される指示に従って、チューブを測定します。

プロジェクトのワークスペースからチューブを測定すること

  1. プロジェクトのワークスペース内のプロジェクトを表示するには、プロジェクト一覧エリアからプロジェクトをダブルクリックします。

  2. アクションバーの左下にある測定/停止ボタン [image] をクリックしてください。アクションバーに表示される指示に従って、チューブを測定します。

曲げ機械からリコールされるチューブを測定すること

注記:チューブを測定する前に、CNCのチューブ曲げ機を設定し、TubeShaperに接続する必要があります。

  1. プロジェクトビュー画面から、ハブビュー選択ペインのベンダータブを選択します。

  2. ベンダーエリアからチューブプロジェクトが含まれている曲げ機を選択します。

  3. ベンダーのアクションバーからベンダーからリコールボタン [image] をクリックします。ユーザー入ダイアログが表示されます。

  4. プロジェクトのパーツ番号を入力して、[完了]をクリックして、曲げ機からプロジェクトを読み出します。

  5. 呼び出されたチューブプロジェクトはプロジェクトのワークスペースに表示されます。アクションバーの左下にある測定/停止ボタンをクリックしてください。

  6. アクションバーに表示される指示に従って、チューブを測定します。

すべての測定が完了すると、データを確認します。

  • 測定結果がよくない場合は、再計算ボタン [image] をクリックして再計算データが曲げ加工機に返送される必要があるかどうかを判断します。もしそうであれば、ベンダーに送信 ボタン [image] をクリックして、再計算されたチューブデータを曲げ機に戻って送信します。

  • 測定結果が許容される場合には、曲げ加工でも良いし、何よりもする必要がありません。

詳細

ショップフロアモード

現場モード:概要

現場モード:プロジェクトワークスペース

現場モード:ベンダー画面

現場モード:レポート画面