Introdução ao software de licenciamento CLM

Home > Software Client License Manager

Software Client License Manager (CLM)

O software Client License Manager (CLM) da Hexagon Metrology é uma tecnologia confiável e segura que não requer um chave de proteção de software (dongle de portlock HASP). Portanto, tudo que é necessário é estar conectado à internet para instalar o PC-DMIS e ativar uma licença através do Hexagon Metrology Network License Server.

Mudança automática de HASP para LMS

Se desejar manter a versão atual do PC-DMIS e mudar sua licença atual de HASP para LMS:

  1. Contate o representante do serviço da Hexagon Metrology para adquirir uma chave de ID de qualificação (EID) de licença LMS. Seu representante também enviará as mais recentes versões das ferramentas de software de licença CLM. Use estas ferramentas para executar as diversas funções que este documento descreve.

  2. Depois de instalar sua chave EID e as ferramentas de software de CLM, localize o arquivo de utilitário CLM Client License Administrator. Clique duas vezes para o executar. Para detalhes sobre como usar a EID para instalar sua licença LMS, consulte a seção apropriada da ajuda CLM:

    • Instalação e ativação de licenças de nó bloqueado

    • Licenças flutuantes

    • Processamento de licenças off-line

  3. Remova o dongle HASP do PC e retorne-o.

  4. Inicie a mesma versão do PC-DMIS que usou com HASP. O PC-DMIS detecta que o dongle HASP está faltando.

O PC-DMIS verifica a existência de uma licença LMS válida. Se encontrar uma, sua licença muda automaticamente para usar a nova licença LMS. A chave de registro da licença usa a licença LMS, sem qualquer interação do usuário. LMS se torna em sua licença padrão. Para alterar entre licenças HASP e LMS, consulte ""UsoLicenciamentoLMS" na documentação do Editor de configurações.

Se o PC-DMIS não encontrar uma licença LMS, exibe uma mensagem de erro que indica que a licença do PC-DMIS está faltando. O PC-DMIS encerra. A mesma chave de registro da licença permanece definida como HASP. É a mesma situação quando você remove temporariamente o dongle HASP de seu PC e coloca-a mais tarde.

Se for detectada uma licença HASP válida e uma licença LMS válida, na inicialização, o PC-DMIS usa HASP. Se o portlock HASP for removido, na próxima vez que o PC-DMIS inicializar, usa a licença LMS válida.

Observação: Esta correção não abrange a situação em que LMS é seu sistema de licença e houver um HASP válido em seu PC. Neste caso, LMS permanece como o sistema de licença em uso. O PC-DMIS ignora o dongle.

Mais

Modelos de licença

ID de qualificação

Introdução aos modelos de licença

Resolução de problema de Erro de armazenamento de confiança (TS)

Perguntas frequentes (FAQs)

Glossário

Início rápido de licença de nó bloqueado

Início rápido de ativação de licença off-line


Modelos de licença

O modelo de licença possui dois conceitos que resultam em quatro tipos de licença. Os dois conceitos são os seguintes:

  • Bloqueio

  • Licença vitalícia

Bloqueio - Relacionado a computadores em uma rede. Você tem duas opções:

  • Nó bloqueado - Este tipo de licença é instalada e vinculada a um único PC. A licença não pode ser compartilhada entre vários usuários trabalhando em diferentes PCs.

  • Flutuante - Este tipo de licença pode ser compartilhada entre vários usuários trabalhando em diferentes PCs que estejam na mesma rede. Isto exige a configuração e instalação do servidor da licença. A configuração do sistema do cliente é necessária para acessar o servidor da licença.

Licença vitalícia - Define a validade da licença.

  • Perpétua - Este tipo de licença tem uma validade permanente em um PC.

  • Avaliação - Este tipo de licença tem uma data de expiração.

Você pode escolher entre quatro tipos de licença:

  • Perpétua de nó bloqueado

  • Avaliação de nó bloqueado

  • Perpétua flutuante

  • Avaliação flutuante


ID de qualificação

A ID de qualificação é a chave para a ativação inicial da licença, sendo necessária também para encomendar opções adicionais do software.

A ID de qualificação é composta por 25 caracteres alfanuméricos separados por um traço, como por exemplo:

ID de qualificação: 00101-64466-00014-03624-4C34F

A ID de qualificação pode ser encontrada na fatura, na nota de entrega ou no software comprado. Além disso, ela também pode ser encontrada no certificado de qualificação - impresso ou na forma digital (documento HTML).

A ID de qualificação para um software nunca muda; portanto, esses documentos devem ser guardados em um local seguro.


Introdução aos modelos de licença

Dependendo do software sendo instalado, pode-se escolher entre dois modelos de licença diferentes, de acordo com as necessidades do usuário:

  • Nó bloqueado

  • Flutuação

Os modelos de licença disponíveis e suas funcionalidades dependem do tipo de software da Hexagon Metrology.

Mais

Visão geral de licenças de nó bloqueado

Visão geral de licenças flutuantes


Visão geral de licenças de nó bloqueado

Uma licença de nó bloqueado é ligada a um único PC e é, portanto, a escolha ideal para trabalho remoto ou para usuários independentes dentro da rede.

Uma licença de nó bloqueado não pode ser compartilhada entre múltiplos usuários da mesma rede e geralmente não pode ser transferida de um PC para outro ("rehosting").

Portanto, é necessário estar conectado à internet para instalar e ativar licenças de nó bloqueado através do Hexagon Metrology Network License Server. Após a licença ser instalada e ativada, a conexão à internet não é mais necessária. Para ativar opções adicionais compradas para o software ou fazer a manutenção do software, é necessário estar conectado à internet.

Licenças de nó bloqueado no PC são gerenciadas através de uma ferramenta separada de gerenciamento de licença chamada CLM Administrator.

Mais

Rehosting de licença de nó bloqueado


Rehosting de licença de nó bloqueado

Transferir uma licença de nó bloqueado de um PC para outro é chamado "rehosting". A transferência da licença somente pode ser feita mudando permanentemente um usuário ou PC. Fazer o rehosting da licença também pode ser necessário ao redefinir ou instalar um novo sistema operacional no mesmo servidor ou PC.

Rehosting uma licença só é permitido por um número limitado de vezes ao ano. O número de rehostings permitido depende do tipo de software sendo instalado.


Visão geral de licenças flutuantes

Licenças flutuantes pode ser compartilhadas entre várias estações de trabalho de usuários na mesma rede local. Licenças flutuantes são a escolha ideal se o software deve flutuar sobre uma rede local, passando de uma estação de trabalho a outra conforme necessário.

As licenças flutuantes são gerenciadas por um Servidor de Licença Local executado na rede local. O Servidor de Licença Local administra um conjunto de licenças e garante que o número de licenças usadas simultaneamente não ultrapasse o número de licenças compradas. Se não há mais licenças disponíveis, o usuário é notificado e tem que esperar até um outro usuário pare de usar a licença.

O Servidor de Licença Local pode ser instalado em um PC normal ou servidor dedicado, mas não pode ser instalado em um computador virtual ou sistema de servidor. O Servidor de Licença Local pode gerenciar as licenças para um ou mais produtos de software.

Geralmente, a licença não é transferida de um Servidor de Licença Local a outro ("rehosting").

Portanto, é necessário estar conectado à internet para instalar e ativar o Servidor de Licença Local através do Hexagon Metrology Network License Server. Após o servidor local ser instalado e ativado, a conexão à internet não é mais necessária. Para ativar opções adicionais compradas para o software ou fazer a manutenção do software, é necessário estar conectado à internet.

Quando for necessário executar o software remotamente em um PC ou notebook sem conexão à rede e ao Servidor de Licença Local, é possível emprestar licenças do Servidor de Licença Local e retorná-las após o uso.

Licenças flutuantes no Servidor de Licença Local são gerenciadas através de uma ferramenta separada de gerenciamento de licença chamada CLM Administrator Server.

Mais

Rehosting da licença flutuante

Empréstimo de licença flutuante


Rehosting da licença flutuante

"Rehosting" significa transferir uma licença de um Servidor de Licença Local na rede local para outro. A transferência da licença do Servidor de Licença Local somente pode ser feita de modo permanente. Fazer o rehosting da licença também pode ser necessário ao redefinir ou instalar um novo sistema operacional no mesmo servidor ou PC.

Rehosting uma licença só é permitido por um número limitado de vezes ao ano. O número de rehostings permitido depende do tipo de software sendo instalado.


Empréstimo de licença flutuante

Quando for necessário executar o software remotamente em um PC ou notebook sem conexão à rede e ao Servidor de Licença Local, é possível emprestar licenças do Servidor de Licença Local e retorná-las após o uso. Esse processo é chamado de "empréstimo". A disponibilidade para empréstimo depende do tipo de software instalado.

Se você tentar pegar emprestada uma licença por um número de dias superior aos restantes na licença, aparece esta mensagem de erro:

"Sem correspondência, falha em clmBorrow (9000040B, 1035)."

Para corrigir isto, redefina o número de dias para o período de empréstimo para ser no número de dias restantes na licença.


Instalação e ativação de licenças de nó bloqueado

Para instalar o pacote de software em um PC e para ativar as licenças, é necessário ter:

  • PC com conexão à internet.

  • A ID de qualificação para o pacote de software, encontrada na fatura, na nota de entrega e no certificado de qualificação.

  • CD-ROM ou DVD de instalação, ou programa de configuração baixado, para o pacote de software.

Mais:

Instalação de licença de nó bloqueado

Gerenciamento de licenças


Instalação de licença de nó bloqueado

As ferramentas de licenciamento CLM da Hexagon Metrology estão instaladas no produto de software da Hexagon Metrology (PC-DMIS, DataPage+, etc.). O processo cria na área de trabalho atalhos às ferramentas CLM necessárias.

A instalação e ativação do pacote do software é feita com a ajuda de um assistente de instalação que guia automaticamente o usuário através do processo completo de instalação e ativação. O capítulo a seguir explica os passos de configuração em detalhes.

Observe que as etapas de instalação e as capturas de tela neste documento são de um determinado pacote de software da Hexagon Metrology. Os diálogos podem ser levemente diferentes em outros softwares.

  1. Inicie a ferramenta de licenciamento do CLM usando o atalho "CLM Admin" criado durante a instalação do software da Hexagon Metrology. A caixa de diálogo Client License Administrator aparece.

Caixa de diálogo Client License Administrator

  2. Clique em Ativar novas licenças e digite ou copie a sua ID de qualificação no campo.

Caixa de diálogo Client License Administrator – Ativar novas licenças

  3. Clique em Checar se há licenças ativáveis para exibir o resumo das licenças.

  4. Clique em Ativar novas licenças.

  5. Clique em Visualizar as licenças instaladas para ver as licenças atualmente ativadas.

Todas as novas licenças estão agora ativadas, e os produtos correspondentes podem ser usados.


Gerenciamento de licenças

O gerenciamento de licenças em um PC é feito via o diálogo "Visualizar as licenças" do pacote de software ou com uma ferramenta do CLM Administrator.

Observe que as capturas de tela neste documento são de um determinado pacote de software da Hexagon Metrology. Os diálogos podem ser levemente diferentes em outros softwares.

Mais

Como iniciar a Visualização de licenças

Como iniciar o CLM Administrator

Visualização de licenças de nó bloqueado

Atualização de licenças de nó bloqueado

Como checar se há atualizações de licenças de nó bloqueado

Rehosting de licenças de nó bloqueado


Como iniciar a Visualização de licenças

Para acessar o diálogo "Visualizar as licenças" e ver as licenças atualmente ativadas:

  • Clique duas vezes no arquivo clmadmin.exe e inicie o pacote de software do qual você deseja gerenciar as licenças.

  • Selecione "Visualizar as licenças instaladas".

  • Consulte Visualização de licenças de nó bloqueado para continuar.


Como iniciar o CLM Administrator

Para iniciar o CLM Administrator para licenças de nó bloqueado:

  • Clique duas vezes no arquivo clmadmin.exe e inicie o pacote de software do qual você deseja gerenciar as licenças.


Visualização de licenças de nó bloqueado

A visualização de licenças que estão atualmente ativadas em um PC é feita através do diálogo "Visualizar as licenças" do pacote do software (consulte o capítulo Gerenciamento de licenças).

Para visualizar as licenças atualmente ativadas, não é necessário estar conectado à internet.

Para visualizar as licenças de um pacote de software:

  • Clique no link "Visualizar as licenças instaladas" para exibir uma lista das licenças instaladas e ativadas em seu sistema (para mais detalhes relacionados com o gerenciamento de suas licenças, consulte o capítulo Gerenciamento de licenças).

O diálogo mostra a ID de qualificação e todas as opções atualmente ativadas no pacote de software.


Atualização de licenças de nó bloqueado

Ativar opções adicionais compradas para o software ou fazer a manutenção do software é chamado de "atualização de licenças". A atualização de licenças é feita via o diálogo "Visualizar as licenças" do pacote de software (consulte o capítulo Gerenciamento de licenças).

Obs.: É necessário estar conectado à internet para ativar a licença através do Hexagon Metrology Network License Server.

Inicie a licença de nó bloqueado.


Como checar se há atualizações de licenças de nó bloqueado

É estabelecida uma conexão com o Hexagon Metrology Network License Server e a checagem se há atualizações de licença é iniciada.

Para atualizar opções de software recentemente compradas ou fazer a manutenção do software:

  • Clique em "Visualizar as licenças instaladas" para exibir o diálogo Licenças instaladas (consulte o capítulo Gerenciamento de licenças).

  • Certifique-se de que o PC está conectado à internet.

  • Selecione "Checar se há atualizações" perto da parte de baixo do diálogo.

Depende do resultado da consulta:

  • Se não há nenhuma atualização de licença disponível, aparecerá a mensagem: "Não há nenhuma licença nova disponível", e você será solicitado a confirmar clicando em OK.

  • Se há atualizações de licença disponíveis, aparece uma lista de atualizações. Para realizar a atualização, marque os itens que deseja atualizar e selecione Ativar licenças novas perto do canto inferior direito do diálogo.


Rehosting de licenças de nó bloqueado

Para fazer o rehosting (transferência de uma licença de um PC para outro) e o gerenciamento de licenças para diferentes produtos de software no mesmo PC é preciso iniciar o CLM Administrator para licenças de nó bloqueado (consulte o capítulo Gerenciamento de licenças).

Para retornar licenças para rehosting:

  1. Inicie o CLM Administrator (consulte o capítulo Gerenciamento de licenças).

  2. Certifique-se de que o PC está conectado à internet.

  3. Selecione Visualizar as licenças instaladas. A lista das qualificações atualmente ativadas aparece.

  4. Selecione a ID de qualificação a ser retornada.

  5. Selecione Retornar licenças. A lista das licenças atualmente selecionadas para retorno aparece.

  6. Selecione Continuar para confirmar o retorno das licenças selecionadas.

Foi estabelecida uma conexão com o Hexagon Metrology Network License Server e as licenças selecionadas foram retornadas.

Instalação e ativação de licenças em um PC diferente

Para concluir o processo de rehosting, é necessário fazer o seguinte:

  • No PC para onde a licença será movida, siga o processo completo de instalação e ativação, conforme descrito no capítulo Instalação e ativação de licenças de nó bloqueado.


Licenças flutuantes

Para instalar o pacote de software comprado em um ou mais dos PCs locais e para ativar as licenças flutuantes compradas, é necessário seguir as seguintes etapas de instalação:

  • Instalação do Servidor de Licença Local

  • Instalação em cliente local (ou clientes)

Mais

Instalação do Servidor de Licença Local

Instalação em clientes locais

Gerenciamento do Servidor de Licença Local

Gerenciamento de licenças flutuantes em clientes locais


Instalação do Servidor de Licença Local

Para instalar o Servidor de Licença Local, é necessário ter:

  • Servidor ou PC da rede local com conexão à internet (após a licença ser ativada, a conexão à internet não é mais necessária).

Este servidor ou PC será usado por todos os clientes locais para obter uma licença do pacote de software.

  • A ID de qualificação para o pacote de software, encontrada na fatura, na nota de entrega e no certificado de qualificação.

  • CD-ROM ou DVD de instalação, ou programa de configuração baixado, para o pacote CLM Server da Hexagon.


Instalação em clientes locais

Para instalar e ativar o pacote de software em um cliente local, ou clientes, na rede, é necessário ter:

  • PC da rede local com conexão ao Servidor de Licença Local e à internet (após o pacote de software ser instalado, a conexão à internet não é mais necessária).

  • CD-ROM ou DVD de instalação, ou programa de configuração baixado (clmadminsvr.exe), para o pacote de software.


Gerenciamento do Servidor de Licença Local

O gerenciamento do Servidor de Licença Local é feito via uma ferramenta separada do CLM Administrator Server.

Observe que as etapas de instalação e as capturas de tela neste documento são de um determinado pacote de software da Hexagon Metrology. Os diálogos podem ser levemente diferentes em outros softwares.

Mais

License Administrator Server

Visualização de licenças flutuantes no Servidor de Licença Local

Visualização das licenças flutuantes em uso

Gerenciamento do Servidor de Licença

Atualização de licenças flutuantes no Servidor de Licença Local

Ativação de licenças flutuantes novas

Rehosting de licenças flutuantes no Servidor de Licença Local

Verificação da conexão ao Hexagon Metrology Network License Server


License Administrator Server

Para iniciar o CLM Administrator Server, clique duas vezes no arquivo clmadminsvr.exe que veio com o seu pacote ou que você baixou do servidor da Hexagon.

Todo o gerenciamento do Servidor de Licença Local é feito com o aplicativo CLM Administrator Server.


Visualização de licenças flutuantes no Servidor de Licença Local

A visualização de licenças que estão atualmente ativadas no Servidor de Licença Local é feita com o CLM Administrator Server (consulte o capítulo Gerenciamento do Servidor de Licença Local).

Para exibir a tela principal do Client License Administrator - Server, clique duas vezes no arquivo clmadminsvr.exe que veio com o seu pacote ou que você baixou do servidor da Hexagon.

Para visualizar as licenças ativadas atualmente no Servidor de Licença Local:

  • Inicie o CLM Administrator Server (consulte o capítulo Gerenciamento do Servidor de Licença Local).

  • Selecione "Visualizar as licenças instaladas".

Se há IDs de qualificação ativadas atualmente no Servidor de Licença Local, elas serão exibidas:

  • Selecione "Elementos" na parte superior direita para ver os detalhes das licenças ativadas.


Visualização das licenças flutuantes em uso

A visualização de licenças que estão atualmente ativadas no Servidor de Licença Local é feita com o CLM Administrator Server (consulte o capítulo Gerenciamento do Servidor de Licença Local).

Para visualizar as licenças que estão atualmente em uso nos clientes locais:

  • Inicie o CLM Administrator Server (consulte o capítulo Gerenciamento do Servidor de Licença Local).

  • Selecione "Visualizar as licenças em uso" no menu à esquerda.

Se houver licenças atualmente em uso nos clientes locais, elas serão indicadas aqui. Além disso, é mostrado o usuário usando cada licença.


Gerenciamento do Servidor de Licença

O gerenciamento do Servidor de Licença Local é feito com o CLM Administrator Server.

Para verificar o nome do servidor da licença (ou seja, o nome do host):

  • Inicie o CLM Administrator Server (consulte o capítulo Gerenciamento do Servidor de Licença Local).

  • Selecione "Gerenciar o servidor da licença" no menu à esquerda.

O nome do servidor da licença local é fornecido. Além disso, a porta do servidor da licença é indicada ao lado dos dois pontos (por padrão, essa é a porta 27000; veja também FAQ 17); também é mostrado se o servidor está em execução ou parado. Para mudar o status, selecione Iniciar ou Parar na parte inferior direita.

Para atualizar a visualização, selecione Atualizar na parte inferior direita.


Atualização de licenças flutuantes no Servidor de Licença Local

Ativar opções adicionais compradas para o software ou fazer a manutenção do software é chamado de "atualização de licenças". A atualização de licenças é feita com o CLM Administrator Server.

Nesta funcionalidade, é necessário estar conectado à internet para ativar a licença através do Hexagon Metrology Network License Server.

Para visualizar as licenças ativadas atualmente no Servidor de Licença Local:

  • Inicie o CLM Administrator Server (consulte o capítulo Gerenciamento do Servidor de Licença Local).

  • Selecione "Checar se há licenças" na área de trabalho ou no menu à esquerda.

Após checar no Hexagon Metrology Network License Server se há atualizações, qualquer licença recentemente tornada ativável é exibida:

  • Selecione "Licenças recentemente ativáveis" para ativar as novas licenças.


Ativação de licenças flutuantes novas

"Ativação de licenças novas" é o nome dado à ativação de outros pacotes de software a serem administrados no mesmo Servidor de Licença Local. A ativação de novas licenças é feita com o CLM Administrator Server.

Nesta funcionalidade, é necessário estar conectado à internet para ativar a licença através do Hexagon Metrology Network License Server.

Para ativar novas licenças no Servidor de Licença Local:

  • Inicie o CLM Administrator Server (consulte o capítulo Gerenciamento do Servidor de Licença Local).

  • Selecione "Ativar novas licenças" na área de trabalho ou no menu à esquerda.

Para ativar pacotes de software adicionais no mesmo Servidor de Licença Local:

  • Digite a ID de qualificação (encontrada na fatura, nota de entrega ou certificado de qualificação) e selecione "Checar se há licenças ativáveis".

É iniciada uma conexão com o Hexagon Metrology Network License Server para checar se há novas licenças.


Rehosting de licenças flutuantes no Servidor de Licença Local

É necessário primeiro retornar uma licença antes que possa ser feito o rehosting da licença em outros Servidor de Licença Local. O retorno da licença é feito com o CLM Administrator Server.

Além disso, para ser possível fazer o rehost de uma licença, ela tem que ter sido registrada anteriormente na Hexagon Metrology. Contate o representante de suporte técnico da Hexagon Metrology para mais informações.

Para visualizar as licenças ativadas atualmente no Servidor de Licença Local:

  • Inicie o CLM Administrator Server (consulte o capítulo Gerenciamento do Servidor de Licença Local).

  • Selecione "Visualizar as licenças instaladas" na área de trabalho ou no menu à esquerda.

As licenças ativadas atualmente são mostradas. Para retorná-las para rehosting:

  • Selecione cada ID de qualificação que você deseja fazer o rehost.

  • Selecione "Retornar licenças".

As licenças que estão selecionadas atualmente para retorno são mostradas:

  • Selecione "Continuar" para confirmar o retorno das licenças selecionadas.

  • Se as licenças ainda não estão registradas na Hexagon Metrology, selecione "Registrar qualificações". (Veja o capítulo Licenças flutuantes.)

Foi estabelecida uma conexão com o Hexagon Metrology Network License Server. As licenças selecionadas foram retornadas.

Para concluir o processo de rehosting, é necessário fazer o seguinte:

  • Em um servidor ou PC diferente, siga o processo completo de instalação, conforme descrito no capítulo Instalação do Servidor de Licença Local. Em seguida, siga as instruções para atualizar nos clientes locais a configuração do servidor da licença, conforme descrito no documento Rehosting de licenças flutuantes em clientes locais.


Verificação da conexão ao Hexagon Metrology Network License Server

Se ocorrer algum problema durante o processo de ativação da licença, pode ser necessário confirmar que a conexão ao Hexagon Metrology Network License Server está funcionando. Essa verificação é feita com o CLM Administrator Server.

Para verificar a conexão ao Hexagon Metrology Network License Server:

  • Inicie o CLM Administrator Server (consulte o capítulo Gerenciamento do Servidor de Licença Local).

  • Selecione "Verificar a conexão à internet" no menu à esquerda.

O diálogo "Verificar a conexão à internet" mostra o estado da conexão e descreve os erros se houver algum.

Esta funcionalidade deve ser usada se você tiver algum problema durante o processo de ativação da licença.


Gerenciamento de licenças flutuantes em clientes locais

O gerenciamento de licenças em clientes locais é feito via o diálogo "Visualizar as licenças" do pacote de software.

Observe que as capturas de tela neste documento são de um determinado pacote de software da Hexagon Metrology. Os diálogos podem ser levemente diferentes em outros softwares.

Para acessar o diálogo "Visualizar as licenças" e ver as licenças atualmente ativadas:

  • Inicie o pacote de software do qual você deseja gerenciar as licenças.

  • Clique no link "Visualizar as licenças" na tela para exibir uma lista das licenças ativadas no sistema. Se não há nenhuma licença ativada, aparece a seguinte mensagem:

Mais

Visualização de licenças flutuantes em clientes locais

Atualização de licenças flutuantes no cliente local

Empréstimo de licenças flutuantes no cliente local

Rehosting de licenças flutuantes no cliente local


Visualização de licenças flutuantes em clientes locais

A visualização de licenças para o software no PC servidor que estão atualmente ativadas é feita através do diálogo "Visualizar as licenças" do pacote do software (consulte o capítulo Licenças flutuantes). Para visualizar as licenças atualmente ativadas, não é necessário estar conectado à internet.

Para visualizar as licenças de um pacote de software:

  • Clique no link "Visualizar as licenças" para exibir o diálogo do pacote do software (consulte o capítulo Licenças flutuantes).

O diálogo "Visualizar as licenças" mostra a ID de qualificação e todas as opções atualmente ativadas no pacote de software ou uma mensagem avisando que não há nenhuma licença ativada atualmente.


Atualização de licenças flutuantes no cliente local

Ativar opções adicionais compradas para o software ou fazer a manutenção do software é chamado de "atualização de licenças". A atualização de licenças é geralmente feita com o CLM Administrator Server no Servidor de Licença Local (consulte o capítulo Gerenciamento do Servidor de Licença Local). Ela pode também ser feita através do diálogo "Visualizar as licenças" contido no pacote do software em um cliente local (consulte o capítulo Gerenciamento de licenças flutuantes em clientes locais).

Nesta funcionalidade, é necessário estar conectado à internet para ativar a licença através do Hexagon Metrology Network License Server.

Para atualizar opções de software recentemente compradas ou fazer a manutenção do software:

  • Clique no link "Visualizar as licenças" na tela principal para exibir o diálogo "Visualizar as licenças" (consulte o capítulo Gerenciamento de licenças flutuantes em clientes locais).

  • Certifique-se de que o PC está conectado à internet.

  • Selecione "Checar se há atualizações de licença".

Foi estabelecida uma conexão com o Hexagon Metrology Network License Server. A verificação se há atualizações de licença é iniciada.

  • Se não há nenhuma atualização de licença disponível, aparecerá a mensagem de que não há nenhuma licença ativável disponível.

  • Se há alguma atualização de licença disponível, aparecerá a mensagem "Novas licenças flutuantes disponíveis, contate o seu administrador do servidor de licença.".


Empréstimos de licenças flutuantes no cliente local

Quando for necessário executar o software remotamente em um PC ou notebook sem conexão à rede e ao Servidor de Licença Local, é possível "emprestar" licenças do Servidor de Licença Local e "retorná-las" após o uso. Esse processo é chamado de "empréstimo". A disponibilidade para empréstimo depende do tipo de software instalado.

O empréstimo e o retorno de licenças são administrados através do diálogo "Visualizar as licenças" contido no pacote do software (consulte o capítulo Gerenciamento de licenças flutuantes em clientes locais).

Para visualizar as licenças do pacote de software:

  • Clique no link "Visualizar as licenças" para exibir o diálogo Visualizar as licenças do pacote do software (consulte o capítulo Gerenciamento de licenças flutuantes em clientes locais).

O diálogo "Visualizar as licenças" mostra a ID de qualificação e todas as opções atualmente ativadas no pacote de software.

Empréstimo de licenças

Para emprestar licenças:

  • Digite a data final que você deseja que as licenças vençam.

  • Clique no link "Emprestar licenças".

As licenças estão agora emprestadas, e o diálogo "Visualizar as licenças" está atualizado com as últimas informações.

Retorno de licenças emprestadas

Para retornar licenças emprestadas:

  • Selecione a licença que você deseja retornar.

  • Clique no link "Retornar licenças emprestadas".

As licenças foram retornadas, e o diálogo "Visualizar as licenças" está atualizado com as últimas informações.


Rehosting de licenças flutuantes no cliente local

Se tiver sido feito o rehosting do Servidor de Licença Local (transferido permanentemente de um PC ou servidor para outro), a configuração do servidor da licença deve ser atualizada para todos os clientes locais.

A atualização da configuração do servidor da licença é feita através do diálogo "Visualização de licenças".

Para exibir o diálogo "Visualização de licenças":

  • Clique duas vezes em clmadminsvr.exe no seu pacote de software para iniciar o aplicativo e exibir o diálogo principal.

  • Clique no diálogo "Visualização de licenças". A lista de produtos licenciados estará vazia, pois as licenças de produto requeridas não foram encontradas.

  • Clique no link Opções na esquerda para exibir as especificações de "Configuração" usadas para atualizar a configuração do servidor da licença.

Atualização da configuração do servidor da licença

Na seção Configuração do diálogo "Opções", é mostrada a configuração atual do servidor da licença local.

Para atualizar a configuração do servidor da licença local:

  • Forneça as novas informações do servidor, conforme necessário. Essas informações são indicadas no CLM Administrator Server, sob "Gerenciamento do servidor da licença" (consulte o capítulo Gerenciamento do Servidor de Licença Local).

  • Clique em Aplicar, localizado na parte inferior direita, para identificar o endereço do novo host.

O cliente local está agora conectado ao novo Servidor de Licença Local.

(A "Configuração do Servidor Proxy" é necessária somente se um servidor proxy está sendo usado em vez de uma conexão direta à internet.)


Processamento de licença off-line

O processamento de licenças off-line está disponível para aqueles que precisam ativar uma licença em um computador que não tem acesso à internet. Licenças de software podem ser ativadas, retornadas ou atualizadas off-line. É necessário, contudo, ter à disposição um segundo PC com conexão à internet.

Há vários casos em que uma conexão à internet pode não estar disponível:

  • Empresas/instituições que permitem somente o uso de e-mail.

  • Redes especiais que são off-line propositalmente.

  • Problemas com a conexão da rede (por ex,. devido a servidores de proxy ou firewalls)

A Hexagon Metrology SPA criou um procedimento para automatizar, o máximo possível, o processo de ativação off-line. Basta enviar por e-mail uma solicitação de ativação aos serviços de ativação a partir de um PC que esteja conectado à internet. O reconhecimento da ativação da licença será enviado de volta ao mesmo e-mail.

O e-mail a ser usado para o processo de ativação off-line é: activation@hexagonmetrology.com.

Mais

Transferência de licença off-line e processo de ativação

Retorno de licenças off-line

Criação de um arquivo de solicitação de retorno off-line

Obtenção do arquivo de resposta de retorno off-line

Processamento do arquivo de resposta de retorno

Atualização de licenças off-line


Transferência de licença off-line e processo de ativação

Quando a ID de qualificação é recebida (consulte o capítulo Introdução ao software Client License Manager para mais detalhes), as seguintes etapas devem ser seguidas para ativar, retornar ou atualizar a qualificação off-line:

  1. Em um computador ou outro dispositivo com conexão à internet, solicite um arquivo de início (o arquivo terá uma extensão “.clmstart”). Envie a solicitação a activation@hexagonmetrology.com. O campo de assunto pode ficar vazio; contudo, o corpo do e-mail tem que conter a sequência da ID de qualificação. Ao receber o arquivo de início, salve-o em um dispositivo de armazenagem portátil e transfira o dispositivo ao PC off-line onde o software precisa ser ativado.

  2. No PC sendo licenciado, inicie a ferramenta de licenciamento do CLM usando o atalho criado durante a instalação do software: "CLM Admin" para licenças de nó bloqueado ou “CLM Admin Server” para licenças flutuantes.

  3. Clique na opção Transferência de licença off-line, que pode ser encontrada no meio do diálogo CLM.

  4. Clique em Ativar as licenças na próxima tela.

  5. Na parte superior central da próxima tela, clique em Navegar e procure o arquivo de início. Clique no arquivo para selecioná-lo e depois em Criar solicitação, na parte inferior direita do diálogo.

  6. Quando a solicitação tiver sido processada, clique em Salvar a solicitação, na parte inferior direita do próximo diálogo. O arquivo de solicitação possui uma extensão “.clmreq”, e está localizado na mesma pasta do arquivo de início, sendo requerido para você obter o arquivo de resposta.

  7. Envie o arquivo ".clmreq" gerado para activation@hexagonmetrology.com. Você receberá um e-mail da Hexagon Metrology contendo o arquivo de resposta. O arquivo terá a extensão ".clmresp". Transfira este arquivo para o PC sendo licenciado.

  8. No PC off-line sendo licenciado, inicie a ferramenta CLM apropriada, conforme a etapa 2 acima, e clique em Transferência de licença off-line.

  9. Clique em Ativar as licenças no próximo diálogo, navegue até o arquivo de resposta, clique e selecione-o, e depois clique em OK. O aplicativo CLM irá processar o arquivo de resposta e executar a ativação da licença.

A licença foi ativada e o aplicativo do seu software pode ser iniciado e usado.

Mais

Ativação de licenças off-line

Criação de um arquivo de solicitação de ativação off-line

Obtenção do arquivo de resposta de ativação off-line

Processamento do arquivo de resposta de ativação

Resolução de problemas de ativação off-line


Ativação de licenças off-line

Para inicializar o processo de ativação off-line é necessário usar um arquivo de início (ou Start).

Você pode obter o arquivo de início solicitando que ele seja enviado através de e-mail (activation@hexagonmetrology.com), se disponível, ou por meio de correio em um disco ou pen drive. O arquivo terá uma extensão ".clmstart".

Seja qual for o seu caso, contate o representante da Hexagon Metrology para mais informações.

Após receber o arquivo de início, salve-o em um dispositivo de armazenagem portátil, como uma pen drive. Transfira o arquivo para o PC desejado.

Obs.: Se a licença for ser ativada via e-mail (activation@hexagonmetrology.com), vá para Criação de um arquivo de solicitação de ativação off-line.

Iniciar...


Criação de um arquivo de solicitação de ativação off-line

Para criar um arquivo de solicitação de ativação off-line com o arquivo de início existente, é necessário utilizar ferramentas de administração do CLM. O arquivo possui uma extensão ".clmstart".

Inicie as devidas ferramentas de administração do CLM a partir do atalho criado durante a instalação do software da Hexagon Metrology (PC-DMIS, DataPage+, etc.):

  • Para uma licença de nó bloqueado, clique duas vezes no atalho "CLM Admin" na área de trabalho.

  • Para uma licença flutuante, clique duas vezes no atalho "CLM Admin Server" na área de trabalho.

Etapa 1: Ativar as licenças

Para iniciar o procedimento de ativação da qualificação off-line no CLM Administrator, você tem que ter a ID de qualificação da licença do produto comprado da Hexagon Metrology.

  • De um outro PC com conexão à internet, envie um e-mail para activation@hexagonmetrology.com. O campo de assunto pode ficar vazio; contudo, o corpo do e-mail tem que conter a sequência da ID de qualificação.

Obs.: O serviço de ativação irá processar o e-mail e gerar um arquivo de início da ativação que lhe será enviado de volta por e-mail.

  • Quando o arquivo de início para ativação (".clmstart") for recebido, copie-o em um dispositivo de armazenagem portátil, ejete o dispositivo e conecte-o no PC onde deseja utilizar a licença off-line.

  • Inicie o devido aplicativo de administração do CLM. Clique na opção Transferência de licença off-line.

  • Clique em Ativar as licenças na próxima tela.

Etapa 2: Criar um arquivo de solicitação de licença

Para ativar uma licença offline, você tem primeiro que gerar um arquivo de solicitação usando o arquivo de início:

  • Na próxima tela, clique em Navegar e encontre o arquivo de início (*.clmstart) no seu dispositivo de armazenagem portátil.

  • Clique no arquivo para selecioná-lo e depois em Criar solicitação, na parte inferior direita.

Etapa 3: Salvar o arquivo de solicitação

Uma que a solicitação tenha sido gerada, os detalhes da licença são listados:

  • Clique em Salvar solicitação, na parte inferior direita, para salvar o arquivo de solicitação, que possui uma extensão ".clmreq".

O arquivo de solicitação é necessário para obter o arquivo de resposta.

Obs.: Para a próxima etapa, mantenha o aplicativo CLM Admin em execução no PC sendo licenciado.

Etapa 4: Localizar o arquivo de resposta

Navegue à localização do arquivo de solicitação gerado. Ele está na mesma localização do arquivo de início.

Avançar...


Obtenção do arquivo de resposta de ativação off-line

O arquivo de solicitação de ativação (".clmreq") tem que ser transferido para um PC ou outro dispositivo móvel conectado à internet para que você possa recebê-lo.

Você pode obter o arquivo de resposta solicitando que ele seja enviado através de e-mail, se disponível, ou por meio de correio em um disco ou pen drive.

Solicitação de envio por e-mail de um arquivo de resposta de ativação

Para obter o arquivo de resposta de ativação off-line através do seu e-mail:

  • De um outro PC com conexão à internet, envie o arquivo gerado ".clmreq" para activation@hexagonmetrology.com. O arquivo de resposta de ativação off-line é enviado de volta ao mesmo e-mail. O arquivo possui uma extensão ".clmresp".

  • Salve o arquivo de resposta em um dispositivo de armazenagem portátil, como uma pen drive, ejete o dispositivo e conecte-o ao PC a ser licenciado.

Avançar...


Processamento do arquivo de resposta de ativação

Conclua a ativação da licença off-line transferindo o arquivo de resposta de ativação de volta ao PC off-line sendo licenciado. Processo o arquivo usando as ferramentas de administração do CLM.

  1. Inicie as devidas ferramentas de administração do CLM a partir do atalho criado durante a instalação do software da Hexagon Metrology (PC-DMIS, DataPage+, etc.):

    • Para uma licença de nó bloqueado, clique duas vezes no atalho "CLM Admin" na área de trabalho.

    • Para uma licença flutuante, clique duas vezes no atalho "CLM Admin Server" na área de trabalho.

  2. Inicie a devida ferramenta do CLM Administrator descrita acima. Selecione Transferência de licença off-line na área de trabalho ou no menu à esquerda.

  3. O arquivo de resposta deve ser selecionado na ferramenta apropriada do CLM Administrator. Selecione Ativar as licenças no próximo diálogo, e clique em Selecionar resposta.

Obs.: Arquivos de resposta que já foram processados não podem ser usados novamente. Para retornar ou atualizar uma licença, é preciso gerar um novo arquivo de resposta.

No caso de o arquivo de resposta gerado ter sido perdido, o arquivo mais recente disponível no Hexagon Metrology Network License Server é válido por um mês. Clique em "Buscar arquivo de resposta" para baixar o último arquivo de resposta que lhe foi enviado do servidor.

  4. Navegue até o arquivo de resposta (*.clmresp) armazenado no seu dispositivo de armazenagem portátil, clique para selecioná-lo e depois clique em OK. O aplicativo CLM Admin irá processar o arquivo de resposta e executar a ativação da licença.

Obs.: Sob determinadas circunstâncias, o aplicativo CLM Admin pode gerar outro arquivo .clmresp após o arquivo .clmresp ser importado e processado. Se isto acontecer, salve o novo arquivo .clmresp e envie-o por e-mail a activation@hexagonmetrology.com, ou ao centro de serviços da Hexagon via um pen-drive ou outro método.

A licença foi ativada e o aplicativo do seu software Hexagon Metrology pode ser iniciado e usado.

Para verificar se sua licença está ativada:

  • Clique na opção Visualizar as licenças instaladas no canto superior esquerdo no aplicativo clmadmin. É exibida uma lista de todas as licenças instaladas.

  • Se estiver conectado à internet, clique na opção Verificar licenças à esquerda do aplicativo clmadmin. É exibida uma lista das licenças que ainda não foram ativadas.


Resolução de problemas de ativação off-line

Problema: A operação "Iniciar a criação do arquivo" de ativação off-line falhou e exibiu a mensagem "Erro ao recuperar a ID de qualificação do corpo do e-mail!".

Razões comuns da falha:

    • A ID de qualificação da licença não está presente no corpo do e-mail.

    • A licença já foi ativada em outro computador.

    • O número de licenças em uso excedeu o número disponível de usuários. Neste caso, não há mais ativações disponíveis para a licença.

Solução: Contate o suporte técnico da Hexagon Metrology e solicite assistência.

Os dados de contato do suporte técnico podem ser encontrados nos seguintes locais:

http://hexagonmetrology.us/contact-us
www.pcdmis.com

Telefone central do suporte técnico nos EUA 1.800.343.7933


Retorno de licenças off-line

Você pode obter o arquivo de início solicitando que ele seja enviado através de e-mail, se disponível, ou por meio de correio em um disco ou pen drive.

Para mais informações sobre as normas para retorno ("rehosting") de produtos de software da Hexagon Metrology, consulte o capítulo Modelos de licença.

Solicitação de envio por e-mail de um arquivo de início de retorno

Para receber um arquivo de início de retorno off-line via e-mail, contate o representante técnico local da Hexagon Metrology.

  • Insira a ID de qualificação a ser retornada off-line como texto no corpo do e-mail, e envie o e-mail ao endereço acima.

O arquivo de início de retorno off-line será enviado de volta ao mesmo e-mail.

  • Salve o arquivo de início em um dispositivo de armazenagem portátil, como uma pen drive. Transfira o arquivo para o PC desejado.

Obs.: Se a licença for ser retornada via e-mail, vá diretamente ao capítulo Transferência de licença off-line e processo de ativação.

Solicitação de um arquivo de início de retorno via o Centro de Suporte da Hexagon Metrology

Para obter o arquivo de início de retorno off-line via o Centro de Suporte da Hexagon Metrology, contate o representante técnico local da Hexagon Metrology.


Criação de um arquivo de solicitação de retorno off-line

Para criar um arquivo de solicitação de retorno off-line com o arquivo de início existente, é necessário utilizar ferramentas de administração do CLM.

Inicie as ferramentas de administração do CLM.

  • Para uma licença de nó bloqueado, execute clmadmin.exe.

  • Para uma licença flutuante, execute clmadminsvr.exe.

No CLM Administrator:

  • Selecione "Transferência de licença off-line" na área de trabalho ou no menu à esquerda.

Etapa 1: Retornar licenças

Para iniciar o procedimento de retorno off-line no CLM Administrator:

  • Selecione "Retornar licenças" na área de trabalho.

Etapa 2: Criar um arquivo de solicitação de licença

Para retornar uma licença offline, você tem primeiro que gerar um arquivo de solicitação usando o arquivo de início:

Navegue até o arquivo de início (*.clmstart) no seu dispositivo de armazenagem portátil.

  • Clique no link "Criar solicitação" na parte inferior direita.

Obs.: Quando o arquivo de solicitação é criado, a licença é desativada, e o software não pode mais ser usado!

Etapa 3: Salvar a solicitação

Os detalhes da licença serão listados:

  • Clique no link "Salvar solicitação", para salvar o arquivo de solicitação.

O arquivo de solicitação é necessário para obter o arquivo de resposta.

Etapa 4: Localizar o arquivo de solicitação

Tome nota da localização do arquivo de solicitação. Por padrão, ele está na mesma localização do arquivo de início.


Obtenção do arquivo de resposta de retorno off-line

O arquivo de solicitação de retorno tem que ser transferido para um PC ou outro dispositivo móvel conectado à internet para que você possa recebê-lo.

Há duas maneiras de solicitar um arquivo de resposta do Hexagon Metrology Network License Server:

  • Via e-mail

  • Via o Centro de Suporte da Hexagon Metrology

Solicitação de envio por e-mail de um arquivo de resposta de retorno

Para receber um arquivo de resposta de retorno off-line via e-mail, contate o representante local da Hexagon Metrology.

  • Salve o arquivo de solicitação como um anexo ao e-mail. Envie o e-mail ao endereço fornecido.

O arquivo de resposta de retorno off-line será enviado de volta ao mesmo e-mail.

  • Salve o arquivo de resposta em um dispositivo de armazenagem portátil, como uma pen drive.

Obs.: Se a licença for ser retornada via e-mail, vá diretamente ao capítulo Criação de um arquivo de solicitação de retorno off-line.

Solicitação de um arquivo de resposta de retorno via o Centro de Suporte da Hexagon Metrology

Contate o representante local da Hexagon Metrology ou acesse o Centro de Suporte da Hexagon Metrology.


Processamento do arquivo de resposta de retorno

Para que a licença seja retornada, o arquivo de resposta de retorno tem que ser transferido de volta ao PC a ser ativado, e processado por meio das ferramentas de administração do CLM.

  • Para uma licença de nó bloqueado, use o CLM Administrator (clmadmin.exe).

  • Para uma licença flutuante, use o CLM Administrator Server (clmadminsvr.exe).

Etapa 1: Selecionar o arquivo de resposta no CLM Administrator

O arquivo de resposta tem que ser selecionado no CLM Administrator.

  • Abra o CLM Administrator. Selecione "Transferência de licença off-line" na área de trabalho ou no menu à esquerda.

  • Na próxima etapa, selecione "Retornar licenças" na área de trabalho.

  • Navegue até o arquivo de resposta (*.clmresp) armazenado no seu dispositivo de armazenagem portátil.

Etapa 2: Processar o arquivo de resposta

Para retornar a licença, o arquivo de resposta tem que ser processado:

  • Clique no link "Processar o arquivo de resposta", localizado na parte inferior direita, para retornar a licença.

A licença foi retornada. Você pode transferi-la (rehost) de um PC para outro.


Atualização de licenças off-line

Ativar opções adicionais compradas para o software ou fazer a manutenção do software é chamado de "atualização de licenças".

Para atualizar uma licença com opções de software recentemente compradas ou fazer a manutenção do software off-line, você precisa seguir os mesmos passos de ativação de uma licença.

  • Obtenha um novo arquivo de início de ativação (veja Obtenção do arquivo de início de ativação off-line através de e-mail).

  • Crie um novo arquivo de solicitação de ativação (veja Criação de um arquivo de solicitação de ativação off-line).

  • Obtenha um novo arquivo de resposta (veja Obtenção do arquivo de resposta de ativação off-line).

  • Processe o novo arquivo de resposta (veja Processamento do arquivo de resposta de ativação).

Obs.: Para atualizar uma licença, é preciso gerar um novo arquivo de resposta.

Clique no link "Navegar" para ir ao arquivo de solicitação que foi criado. Faça o seu upload ao Centro de Suporte da Hexagon Metrology.

Clique em "Download" e salve o arquivo de resposta (*.clmresp) em um dispositivo de armazenagem portátil, como uma pen drive.


Resolução de problema de Erro de armazenamento de confiança (TS)

O software Hexagon CLM utiliza a tecnologia Flexara denominada armazenamento de confiança (TS). Um erro que ocorre com mais frequência é quando a mensagem "Registro de TS inválido." aparece.

Sob circunstâncias normais, uma licença ativada com êxito está no estado "Totalmente de confiança". Você pode verificar isso do seguinte modo:

  1. Clique no link "Visualizar as licenças instaladas" no canto superior esquerdo do utilitário CLM Admin.

  2. Clique no link "Elementos" localizado na parte superior direita da próxima tela.

A próxima tela exibe uma lista de elementos. A coluna mais à direita (Estado) geralmente mostra o estado "Totalmente de confiança" para cada item.

Se algum desses itens mostrar um estado diferente de "Totalmente de confiança", você pode redefinir o seu sistema de armazenamento de confiança e reativar a licença. Contudo, fazer isso causa a remoção do seu computador de todas as qualificações, e você precisará reativá-las.

Para salvar as informações de qualificação

Antes de prosseguir com a redifinição do armazenamento de confiança, certifique-se de que as informações de qualificação estão em um local seguro.

  • Uma maneira de salvar as informações de qualificação é clicar no link "Salvar como", localizado na parte inferior direita do utilitário CLM Admin. Isto fará com que as informações da sua licença sejam salvas em um arquivo XML:

  • Outra maneira de salvar as suas informações de qualificação é copiar e colar as IDs em um documento em branco.

Para fazer isso:

  1. Abra um documento novo em Notepad, WordPad, Microsoft Word ou outro editor de texto.

  2. Em seguida, passe para a visualização da qualificação clicando em "Qualificações", no canto superior direito:

  3. Clique duas vezes em uma das IDs de qualificação, o que faz com que a ID seja copiada para a sua área de transferência.

  4. Passe para o documento em branco e cole a ID de qualificação no documento.

Se você tiver mais de uma qualificação ativada, repita esse processo conforme necessário, até ter salvado todas as IDs de qualificação. Certifique-se de salvar o documento quanto terminar.

Redefinição de armazenamento de confiança

  1. O próximo passo é redefinir o sistema de armazenamento de confiança. Para fazer isso, clique em "Visualizar as licenças instaladas" no canto superior esquerdo:

  2. Em seguida, clique em "Redefinir TS", no meio da janela.

Obs.: O link "Redefinir TS" somente é ativado se o estado de uma ou mais das qualificações não é "Totalmente de confiança".

A mensagem de alerta Redefinir armazenamento de confiança aparece.

  3. Clique em "Sim" para continuar. Após esta operação, a área da lista de qualificações exibe "<nenhuma licença disponível>":

  4. Todas as qualificações terão que ser reativadas. Se você as salvou em um documento usando as instruções anteriores, poderá copiar e colar cada ID de qualificação no CLM Admin para concluir o processo.

Para detalhes sobre ativação de licenças de nó bloqueado, veja o capítulo Instalação e ativação de licenças de nó bloqueado.

Para detalhes sobre ativação de licenças off-line, veja o capítulo Processamento de licenças off-line.

Mais:

Instalação e ativação de licenças de nó bloqueado

Processamento de licenças off-line


Perguntas frequentes (FAQs)

Pergunta 1:

Eu tenho que fornecer a ID de qualificação para instalar o software e ativar a licença. O que é a ID de qualificação e onde posso encontrá-la?

Uma ID de qualificação é uma representação exclusiva da licença para um produto comprado pelo cliente. A ID de qualificação pode ser encontrada na fatura, na nota de entrega e no certificado de qualificação.

Pergunta 2:

O que é a ativação de um produto?

Ativação é o processo para obter uma licença para instalação de um software da Hexagon Metrology em seu computador. Você pode ativar o produto a qualquer hora do dia ou da semana via internet.

Pergunta 3:

Que tipo de informações são transmitidas durante a ativação do produto?

A ativação do produto requer que a HExagon colete um mínimo de informações necessárias para validar a autenticidade de um pedido de ativação de produto. A maioria dos dados identifica o produto, incluindo a ID de qualificação e a versão do produto. Também é gerada uma ID de máquina (ID do host) calculada aleatoriamente; pode ser usada para identificar a marca, modelo ou componentes de seu computador. Adicionalmente, o sistema operacional e o nome de seu computador são transmitidos. Todos os dados são transmitidos em segurança para a Hexagon para validação.

Pergunta 4:

Eu posso usar a ID de qualificação em mais de um computador?

Não. Cada computador requer um processo de ativação exclusivo. A licença do software é designada especificamente ao computador onde o produto foi ativado.

Pergunta 5:

Eu preciso ter direitos de administrador para fazer a ativação?

Não. A ativação em si não exige que o usuário tenha direitos de administrador, mas a instalação de pacotes de software individuais pode requerer direitos de administrador.

Pergunta 6:

É possível ativar licenças em um PC sem ele estar conectado à internet?

Sim. A Hexagon permite que você ative, retorne ou atualize uma licença off-line via outro PC ou dispositivo móvel que tenha pelo menos uma conexão via e-mail à internet (como um smartphone).

Veja mais detalhes no capítulo Processamento de licença off-line

Pergunta 7:

Eu tenho que estar on-line para usar um software que tenha o novo licenciamento de software?

Não. No caso de licenças de nó bloqueado, após você ativar o produto, não precisa mais estar on-line para usar o software. Contudo, se sua licença foi aprimorada (por ex. com a compra de uma opção adicional ou extensão do contrato de manutenção do software), você tem que estar on-line para ativar as atualizações.

Pergunta 8:

Eu comprei opções adicionais para o software ou um contrato de manutenção do software. Como posso ativar as licenças recém-compradas?

Ativar novas opções que foram compradas é chamado de "atualização de licenças". Siga as instruções no capítulo Licenças de nó bloqueado para atualizar licenças de nó bloqueado, e no capítulo Licenças flutuantes para atualizar licenças flutuantes.

Pergunta 9:

Eu gostaria de transferir permanentemente o software e a licença de um PC para outro. Como posso fazer isso?

Transferir permanentemente o software e a licença de um PC para outro é chamado "rehosting". Siga as instruções no capítulo Licenças de nó bloqueado para fazer o rehosting de licenças de nó bloqueado, e no capítulo Licenças flutuantes para fazer o rehosting de licenças flutuantes.

Pergunta 10:

O meu computador quebrou e eu gostaria de transferir a licença de nó bloqueado para um outro PC. Devido a não ter mais acesso ao computador, não será possível seguir o processo de rehosting e retornar as licenças como descrito neste documento. O que eu posso fazer?

Contate o representante local de serviços da Hexagon, forneça a sua ID de qualificação e explique-lhe o que aconteceu. Ele será capaz de lhe retornar a licença para que você possa instalar e ativar o software novamente em outro PC.

Pergunta 11:

Eu gostaria de redefinir o sistema operacional ou instalar um novo sistema operacional no PC onde o software da Hexagon Metrology está instalado e a licença ativada. O que devo fazer?

Antes de instalar um novo sistema operacional, é necessário seguir o processo de rehosting. Siga as instruções no capítulo Licenças de nó bloqueado para fazer o rehosting de licenças de nó bloqueado, e no capítulo Licenças flutuantes para fazer o rehosting de licenças flutuantes.

Pergunta 12:

As mudanças realizadas no meu computador com relação a datas do sistema e propriedades de horário irão exigir que eu tenha que fazer a reativação do produto?

Não. Se a sua licença de software não tem data de validade (por ex., licença de avaliação), não há restrições referente aos ajuste de datas do sistema ou propriedades de horário. Se a sua licença tem uma data de validade, somente mudanças que envolvam um período de mais de uma dia exigiriam reativação.

Pergunta 13:

Estou usando atualmente um software da Hexagon Metrology protegido por um dongle. Qual é o processo para mudar para o novo tipo de licenciamento de software?

Primeiro, contate o representante local de vendas da Hexagon Metrology e forneça-lhe o número do dongle. Ele irá solicitar uma "migração de dongle" para você. Após a encomenda ser computada, você receberá uma nova ID de qualificação.

Em seguida, comece a seguir as instruções de instalação contidas neste documento. Durante a instalação, você será solicitado a conectar o dongle. Quando a instalação for concluída, o software será ativado usando o novo sistema de licenciamento, e o dongle não mais será válido para o produto migrado.

Pergunta 14:

Eu preciso ter um computador servidor dedicado para executar um servidor de licença?

O servidor de licença pode ser instalado como um pacote padrão de software. Devido à baixa capacidade de processamento requerida, um PC padrão pode ser usado para executar um servidor de licença. O computador tem que estar conectado à rede local (LAN) para compartilhas as licenças com outros computadores conectados à mesma LAN.

Pergunta 15:

Posso usar o mesmo Servidor de Licença Local para diferentes pacotes de software da Hexagon Metrology?

Sim. Você tem que configurar somente um Servidor de Licença Local para todos os produtos de software da Hexagon Metrology. Após o servidor de licença ser configurado, é possível adicionar várias outras licenças através de "Ativação de novas licenças". Em seguida, os clientes locais podem ser instalados.

Pergunta 16:

Eu preciso estar conectado à internet para usar licenças flutuantes?

Não. O servidor tem que estar on-line somente durante o processo de ativação da licença no servidor da licença. Contudo, você tem que estar permanentemente conectado ao servidor da licença na LAN para poder usar as licenças flutuantes. Para uma desconexão temporária da LAN, como durante viagens com o notebook, há uma funcionalidade que permite emprestar licenças, disponível em alguns dos pacotes de software da Hexagon Metrology. Siga as instruções no capítulo Licenças flutuantes para fazer o empréstimo de licenças.

Pergunta 17:

Eu estou usando uma Firewall no meu servidor de licença local. Tenho que abrir portas no servidor de licença local para permitir a comunicação?

Sim. Para permitir que clientes obtenham ou emprestem licenças de um servidor na sua LAN, você tem que adicionar as seguintes portas como exceções na proteção da firewall:

  • Para o aplicativo "lmgrd.exe", abra uma porta local TCP com um número na faixa "27000…27009". O padrão para a porta do servidor é porta TCP 27000.

Você pode também verificar qual é a porta realmente usada no programa CLM Administrator Server sob "Gerenciamento do servidor da licença" ou no arquivo "lgs.log". Esse arquivo pode ser encontrado na pasta de instalação do servidor da licença, que por padrão é: C:\Arquivos de programa\Arquivos comuns\<nome do software da Hexagon Metrology>\Servidor-Licença.

  • Para o aplicativo "LGS.exe", abra uma porta TCP que não está em uso, como a 27010.

Ambas as portas podem ser definidas no arquivo "svr_lgs.lic". Esse arquivo pode ser encontrado na pasta de instalação do servidor da licença, que por padrão é: C:\Arquivos de programa\Arquivos comuns\<nome do software da Hexagon Metrology>\Servidor-Licença. Você tem que:

  • adicionar o número da porta do servidor à primeira linha: SERVER this_host ANY 27000

  • adicionar a porta daemon do fornecedor à segunda linha: VENDOR LGS port=27010

Para permitir o acesso remoto às ferramentas de gerenciamento da licença, recomenda-se adicionar uma porta daemon remota como exceção:

  • Para o aplicativo "clmrdsvr.exe", abra a porta local TCP 19701.

Pergunta 18:

Eu estou usando uma Firewall no meu PC cliente local. Tenho que abrir portas no cliente local para permitir a comunicação?

Sim. Para permitir que clientes obtenham ou emprestem licenças de um servidor na sua LAN, você tem que adicionar as seguintes portas como exceções na proteção da firewall:

  • Para o aplicativo do cliente (ex. "LGO.exe"), abra a porta TCP do servidor de licença local (ex. 27000) e a porta TCP daemon do fornecedor remoto (ex. 27010).

Você pode também verificar quais são as portas realmente usadas no arquivo "lgs.log" ou "svr_lgs.lic". Ambos os arquivos podem ser encontrados na pasta de instalação do servidor da licença, que por padrão é: C:\Arquivos de programa\Arquivos comuns\<nome do software da Hexagon Metrology>\Servidor-Licença.

Para permitir o acesso remoto às ferramentas de gerenciamento da licença, recomenda-se adicionar uma porta daemon remota como exceção:

  • Para o aplicativo "clmadminsvr.exe", abra a porta TCP remota 19701.

Pergunta 19:

Eu não tive problema em configurar meu servidor de licença local e estou conectado a ele via a LAN. Contudo, quando eu instalo um cliente local e especifico o endereço e a porta do meu servidor de licença local, recebo uma mensagem de erro dizendo que o destino não pode ser encontrado ou que a mensagem venceu. Por que essas mensagens estão aparecendo e como posso resolver o problema?

Essas mensagens podem estar sendo geradas porque o horário no seu servidor de licença local e o horário no seu cliente local não estão sincronizados. Isto significa que existe um problema com o protocolo de comunicação entre o servidor de licença e o software de cliente.

  • Se o horário diferir em mais de 5 minutos, você receberá a mensagem "Destino não encontrado". Permite saber que o período de tempo razoável passou sem uma resposta de retorno do servidor desejado.

  • Se o horário diferir em mais de 10 minutos, você receberá a mensagem "Mensagem vencida". Permite saber que as mensagens transmitidas entre os servidores venceram e quaisquer tentativas em comunicar entre eles venceram.

Vale observar que não há nenhum problema se o seu servidor funciona em um fuso horário diferente do fuso do seu cliente.


Glossário

Ativação

Ativação de produto é o processo para obter uma licença para instalação de um software da Hexagon Metrology em seu computador.

Empréstimo

Empréstimo significa pegar uma licença móvel do Servidor de Licença Local para usá-la como uma licença de nó bloqueado em um PC ou notebook quando for necessário executar o software remotamente sem conexão à rede e ao Servidor de Licença Local.

CLM

CLM é a sigla de Client License Manager. É o nome da ferramenta do software usada para gerenciar a licença do software em um PC ou servidor.

CLM Administrator (Administrador CLM)

O CLM Administrator é a ferramenta de gerenciamento da licença para instalações de licenças de nó bloqueado em PCs. Ele pode ser usado para visualizar e atualizar licenças, ativar novas licenças ou retornar licenças para rehosting.

CLM Administrator Server

O CLM Administrator Server é a ferramenta de gerenciamento da licença para instalações do servidor de licença no caso de licenças flutuantes. Ele pode ser usado para visualizar e atualizar licenças, ativar novas licenças ou retornar licenças para rehosting.

Dongle

Um "dongle", também chamado de chave de hardware ou chave de proteção do software, é um pequeno dispositivo de proteção que tem que ser conectado à porta paralela ou porta USB do PC para proteger o software contra uso não autorizado.

Certificado de qualificação

O certificado de qualificação é um documento que contém a ID de qualificação. Este documento deve ser guardado com segurança, pois a ID de qualificação é necessária para comprar opções adicionais do software.

ID de qualificação

A ID de qualificação é a chave para a ativação inicial da licença, sendo necessária também para encomendar opções adicionais do software. A ID de qualificação pode ser encontrada na fatura, na nota de entrega ou no certificado de qualificação.

Licença flutuante

Licenças flutuantes pode ser compartilhadas entre vários usuários na mesma rede local. Elas permitem o uso simultâneo do software até a quantidade de licenças compradas disponíveis.

Hexagon Metrology Network License Server

O servidor de licença Hexagon Metrology Network License Server é a localização central das licenças flutuantes, as quais são oferecidas na inicialização aos clientes na rede. Portanto, é tipicamente necessário estar conectado à internet para ativar a licença ou executar outras tarefas através do Hexagon Metrology Network License Server.

Centro de Suporte da Hexagon Metrology

O Centro de Suporte da Hexagon Metrology é onde os produtos são registrados para que suas informações e atualizações possam ser acessadas.

Modelo de licença

O modelo de licença define se uma licença é ligada a um único PC ou pode ser compartilhada entre diferentes PCs da mesma rede. Para os produtos de software da Hexagon Metrology, há dois modelos de licença disponíveis: nó bloqueado e flutuante. A disponibilidade do modelo de licença depende do tipo de software da Hexagon Metrology.

Cliente local

Um cliente local é um PC que compartilha licenças flutuantes em uma rede local e, portanto, tem que estar conectado ao Servidor de licença local.

Servidor de licença local

É necessário que haja um Servidor de licença local para que licenças flutuante possam ser usadas. Pode ser um PC ou um servidor integrante da rede local.

Licença de nó bloqueado

Uma licença de nó bloqueado é ligada a um único PC e é, portanto, a escolha ideal para trabalho remoto ou para usuários independentes dentro da rede. Uma licença de nó bloqueado não pode ser compartilhada entre múltiplos usuários da mesma rede, e geralmente não pode ser transferida de um PC para outro.

Registro de licenças

As licenças são registradas no Centro de Suporte da Hexagon Metrology. O registro das licenças é necessário para fazer rehosting e para acessar informações sobre o produto em atualizações do software.

Rehosting

Rehosting significa transferir permanentemente uma licença de um PC ou Servidor de Licença Local para outro. Rehosting uma licença só é permitido por um número limitado de vezes ao ano. O número de rehostings permitido depende do tipo de software da Hexagon Metrology.

Para fazer um rehosting, é necessário que a licença tenha sido registrada anteriormente no Centro de Suporte da Hexagon Metrology.

Retorno de licenças

O retorno de licenças é o primeiro passo exigido para iniciar o processo de rehosting. Antes que uma licença possa ser ativada em um diferente PC, é necessário retorná-la ao servidor Hexagon Metrology Network License Server.

Chave de proteção do software

Uma chave de proteção do software, também chamada de "dongle" ou chave de hardware, é um pequeno dispositivo de proteção que tem que ser conectado à porta paralela ou porta USB do PC para proteger o software contra uso não autorizado.

Atualização de licenças

Atualizar licenças significa ativar opções adicionais compradas para o software ou fazer a manutenção do software.


Início rápido de licença de nó bloqueado

Home > Início rápido de licença de nó bloqueado

Guia de início rápido do procedimento de licenciamento CLM

Instalação e ativação de licença de nó bloqueado

As ferramentas de licenciamento CLM da Hexagon Metrology estão instaladas no produto de software da Hexagon Metrology (PC-DMIS, DataPage+, etc.), que cria atalhos na área de trabalho para as ferramentas CLM necessárias.

A instalação e ativação do pacote do software é feita com a ajuda de um assistente de instalação que guia automaticamente o usuário através do processo completo de instalação e ativação. O PC tem que estar conectado à internet.

Observe que as etapas de instalação e as capturas de tela neste documento são de um determinado pacote de software da Hexagon Metrology. Os diálogos podem ser levemente diferentes em outros softwares.

  1. Inicie a ferramenta de licenciamento do CLM usando o atalho "CLM Admin" criado durante a instalação do software da Hexagon Metrology (PC-DMIS, DataPage+, etc.) A caixa de diálogo Client License Administrator aparece.

  2. Clique em Ativar novas licenças e digite ou copie a sua ID de qualificação no campo.

  3. Clique em Checar se há licenças ativáveis para exibir o resumo das licenças instaladas.

  4. Clique em Ativar novas licenças.

  5. Clique em Visualizar as licenças instaladas para ver e verificar todas as licenças ativadas.

Todas as novas licenças estão agora ativadas, e os produtos correspondentes podem ser usados.

Baixe a versão em PDF: Guia_de_início_rápido_de_licença_de_nó_bloqueado_CLM.pdf


Início rápido de ativação de licença off-line

Home > Início rápido de ativação de licença off-line

Guia de início rápido do procedimento de licenciamento CLM

Ativação de licença off-line

Quando a ID de qualificação é recebida, as seguintes etapas devem ser seguidas para ativar, retornar ou atualizar a qualificação off-line:

  1. Em um computador ou outro dispositivo com conexão à internet, solicite um arquivo de início (o arquivo terá uma extensão “.clmstart”). Envie a solicitação a activation@hexagonmetrology.com. O campo de assunto pode ficar vazio; contudo, o corpo do e-mail tem que conter a sequência da ID de qualificação. Ao receber o arquivo de início, salve-o em um dispositivo de armazenagem portátil e transfira o dispositivo ao PC off-line onde o software precisa ser ativado.

  2. No PC sendo licenciado, inicie a ferramenta de licenciamento do CLM usando o atalho criado durante a instalação do software da Hexagon Metrology (PC-DMIS, DataPage+, etc.): "CLM Admin" para licenças de nó bloqueado ou “CLM Admin Server” para licenças flutuantes.

  3. Clique na opção Transferência de licença off-line, que pode ser encontrada no meio do diálogo CLM.

  4. Clique em Ativar as licenças na próxima tela.

  5. Na parte superior central da próxima tela, clique em Navegar e procure o arquivo de início. Clique no arquivo para selecioná-lo e depois em Criar solicitação, na parte inferior direita do diálogo.

  6. Quando a solicitação tiver sido processada, clique em Salvar a solicitação, na parte inferior direita do próximo diálogo. O arquivo de solicitação possui uma extensão “.clmreq”, e está localizado na mesma pasta do arquivo de início, sendo requerido para você obter o arquivo de resposta.

  7. Envie o arquivo ".clmreq" gerado para activation@hexagonmetrology.com. É enviada uma resposta da Hexagon Metrology para você contendo o arquivo de resposta. O arquivo possui uma extensão ".clmresp". Transfira este arquivo para o PC sendo licenciado.

  8. No PC off-line sendo licenciado, inicie a ferramenta CLM apropriada, conforme a etapa 2 acima, e clique em Transferência de licença off-line.

  9. Clique em Ativar as licenças no próximo diálogo.

  10. Clique em Selecionar resposta na parte inferior direita, e navegue até o arquivo de resposta. Clique no arquivo para selecioná-lo e depois em OK. O aplicativo CLM processa o arquivo de resposta e executa a ativação da licença.

    11. Observação: Consulte o tópico "Resolução de problemas de ativação off-line" se tiver problemas durante este processo.

    A licença foi ativada. O aplicativo do seu software da Hexagon Metrology pode ser iniciado e usado.

Baixe a versão em PDF: Guia_de_início_rápido_de_ativação_de_licença_off-line_CLM.pdf


Como checar se há licenças

Para atualizar opções de software recentemente compradas ou fazer a manutenção do software:

  • Clique em "Visualizar as licenças instaladas" para exibir o diálogo Licenças instaladas (consulte o capítulo Gerenciamento de licenças).

  • Certifique-se de que o PC está conectado à internet.

  • Selecione "Checar se há atualizações" perto da parte de baixo do diálogo.


Obtenção do arquivo de início de ativação off-line através de e-mail

Para obter o arquivo de início de ativação off-line através do seu e-mail, envie um e-mail para: activatesoftware@leica-geosystems.com.

  • Insira a ID de qualificação a ser ativada off-line como texto no corpo do e-mail, e envie o e-mail ao endereço acima.

O arquivo de início de ativação off-line será enviado de volta ao mesmo e-mail.

  • Salve o arquivo de início em um dispositivo de armazenagem portátil, como uma pen drive, e transfira-a para o PC a ser ativado.

Obs.: Se a licença for ser ativada via e-mail, vá para Criação de um arquivo de solicitação de ativação off-line.