Single Touch Interface Editor





Introduction


Single Touch Interface Editor is a Windows-based application that allows you to create slide shows for Single Touch Interface.  Slides can be easily added and modified in the main window.  Graphics can be added, edited, and annotated using the simple menu system.  Most importantly, Single Touch Interface Editor allows you to create professional slide shows that will assist operators in performing inspections.��A slide show is a program that runs in the Single Touch Interface Monitor while the operator is performing inspections.  The slide show presents graphics of the inspection and provides feedback about whether the measurement is acceptable, rejected, or requires observation.  This tool, Single Touch Interface Editor, allows you to create those slide shows.
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Navigate a Slide Show


Move to the First Slide


Move to the Last Slide


Move to the Next Slide


Move to the Previous Slide


Move to the First Slide


From within the Single Touch Interface Editor Window:


1 Select First Slide from the Slide Menu,��OR��Click the Slide Navigator until you reach the first slide.��The first slide will be displayed.�


See Also:


Single Touch Interface Editor Window





Single Touch Interface Editor Window


Description


This is the main window in the Shop Floor Interface Editor application.  This window allows you to build your slide show, adding pictures and measurement information to individual slides.��The title bar of this window gives the file name of the slide show on which you are working.�


Access


This window opens when you start the Single Touch Interface Editor application.�


Objects


Menu Bar


Slides


Slide Navigator





Tasks


Navigate a Slide Show


Work with a Slide


Work with Slide Show Files





Single Touch Interface Editor Menu Bar


File Menu


New... - Closes any open slide show and allows you to create a new slide show.  If the open slide show has not been saved, you will be prompted to save changes or abort the changes.  To create a new slide show, you must specify the file name and directory you want to assign to it.  The Select New Slide Show File Window will open to allow you to enter this information.


Open... - Opens the Select Slide Show File Window, allowing you to select an existing slide show to open.


Close - Closes the slide show that is currently open.  If changes have been made and not saved, you will be prompted to save the changes.


Save - Saves the current slide show.


Save As Text... - Opens the Save Slide Show File As Window, allowing you to enter a new name and directory in which to save the slide show as a text file.


Save As Binary... - Opens the Save Slide Show File As Window, allowing you to enter a new name and directory in which to save the slide show as a binary file.  This makes the file more compact and allows for faster processing.


Export - Opens the Export Window, allowing you to specify a file name to export the file and enter any comments associated with the export.


Import... - Opens the Import Slide Show Window, allowing you to select an exported slide show to import.


Properties... - Opens the Slide Show Properties Window, allowing you to view and edit information for the slide show, including its name, help file, etc.


Exit- Exits the Shop Floor Interface Editor application.�


Slide Menu (This menu is only available when a slide show is open.)


Title - Opens the Slide Title Window, allowing you to enter or edit the title for the current slide.


Insert Slide - Inserts a new slide after the slide you are currently viewing.


Remove Slide - Removes the slide you are currently viewing from the slide show.


Next Slide - Displays the slide immediately after the slide you are currently viewing.


Previous Slide - Displays the slide immediately before the slide you are currently viewing.


First Slide - Displays the first slide in the slide show.


Last Slide - Displays the last slide in the slide show.�


Background Menu (This menu is only available when a slide show is open.)


Set - Opens the Select Picture File Window, allowing you to select a picture to display in the slide.


Update - Refreshes the current slide.


Clear - Removes the picture and background color, returning it to its original state.


Edit - Opens the configured graphics editing application, allowing you to edit the picture.


Position - Opens the Position Picture Window, allowing you to move the location and size of the picture in the slide.


Color - Opens the Color Window, allowing you to set or change the background color of the slide.�


Insert Menu (This menu is only available when a slide show is open.)


Insert Icon - Adds a new icon to the slide, allowing you to place measurement information on the slide.�


Screen Menu


800X600 - Sets the window for 800X600 screen resolution.


640X480 - Sets the window for 640X480 screen resolution.�


Help Menu


Contents - Opens this help file to the Contents topic.�


Slides


The slides take up the major portion of this window.  In this area, you can add pictures and icons to create and edit your slide.


Slide Navigator


This scroll bar, at the bottom of the window, allows you to see which slide you are viewing, the total number of slides, and allows you to scroll to a different slide.��To move to different slides, do one of the following:


To move to the next slide, click the right arrow one time.


To move to the previous slide, click the left arrow one time.


To move several slides forward, click the area to the right of the slide bar.


To move several slides back, click the area to the left of the slide bar.


To move to a particular slide, drag the slide bar and move it until it indicates the slide you want to view.





Work with a Slide


Add a Picture to a Slide


Add a Title to a Slide


Change the Color of a Slide


Clear a Slide


Delete an Icon from a Slide


Edit a Picture in a Slide


Edit a Title in a Slide


Insert an Icon in a Slide


Insert a Slide


Modify the Properties of an Icon


Move a Picture on a Slide


Move an Icon on a Slide


Refresh a Slide


Remove a Slide





Add a Picture to a Slide


From within the Single Touch Interface Editor Window:


1 Select Set from the Background Menu.��The Select Picture File Window will open.�


2 Select the file name of the picture you want to add.�


3 Click OK to add the picture, or click Cancel to abort.��The picture will be displayed in the slide.�


See Also:


Single Touch Interface Editor Window





Add a Title to a Slide


From within the Single Touch Interface Editor Window:


1 Select Title from the Slide Menu.��The Slide Title Window will open.�


2 Enter the name you want displayed as the slide title.�


3 Click OK to save the slide title, or click Cancel to abort.��The title will be displayed in the title of the slide.�


See Also:


Single Touch Interface Editor Window


Slide Title Window





Slide Title Window


Description


This window allows you to add or edit the title for the currently displayed slide.�


Access


Select Title from the Slide Menu in the menu bar of the Shop Floor Interface Editor Window.�


Objects


Title





Tasks


Add a Title to a Slide


Edit a Title in a Slide





Title


Enter or modify the title as you want it to appear in the slide.





Edit a Title in a Slide


From within the Single Touch Interface Editor Window:


1 Select Title from the Slide Menu.��The Slide Title Window will open.�


2 Edit the slide title.�


3 Click OK to save changes to the slide title, or click Cancel to abort.��The modified title will be displayed in the title of the slide.�


See Also:


Single Touch Interface Editor Window


Slide Title Window





Change the Color of a Slide


From within the Single Touch Interface Editor Window:


1 Select Color from the Background Menu.��The Color Window will open.�


2 Select the color you want displayed as the background of the slide.��Note:  It is best to use neutral colors as a background to ensure that the icon colors stand out and attract the operator's attention.�


3 Click OK to change the slide color, or click Cancel to abort.�


See Also:


Single Touch Interface Editor Window





Clear a Slide


From within the Single Touch Interface Editor Window:


1 Select Clear from the Background Menu.��The picture and color will be cleared from the slide, returning it to its original state.�


See Also:


Single Touch Interface Editor Window





Delete an Icon from a Slide


From within the Single Touch Interface Editor Window:


1 Select the icon you want to delete.�


2 Click the right mouse button and select Delete from the pop-up menu.��The icon will be deleted from the slide.�


See Also:


Single Touch Interface Editor Window





Edit a Picture in a Slide


From within the Single Touch Interface Editor Window:


1 Select Edit from the Background Menu.��The graphics editing application that has been configured for your system will open, allowing you to edit the picture.�


2 Follow the instructions of the application to modify and save the picture.�


See Also:


Single Touch Interface Editor Window





Insert an Icon in a Slide


From within the Single Touch Interface Editor Window:


1 Select Insert Icon from the Insert Menu.��An icon will be placed on the slide.  Note:  All icons are inserted at the same position on the slide.  If you insert several icons without moving them, you will only be able to see the icon on top.��Single Touch Interface Editor also gives you the ability to "copy" existing icons, similarly to using the Windows clipboard.  See Set an Icon as Default for instructions.�


2 Follow the instructions for Modifying the Properties of an Icon to customize the icon.�


See Also:


Modify the Properties of an Icon


Set an Icon as Default


Single Touch Interface Editor Window





Modify the Properties of an Icon


From within the Single Touch Interface Editor Window:


1 Select the icon whose properties you want to modify.�


2 Click the right mouse button, and select Properties from the pop-up menu.��The Icon Properties Window will open.�


3 Modify the properties as needed.�


4 Click OK to save the changes, or click Cancel to abort.�


See Also:


Icon Properties Window


Single Touch Interface Editor Window





Icon Properties Window


Description


This window allows you to add measurement data to the slide.  After inserting an icon, you can modify its properties using this window to include measurement results from the Inspection Report in your slide.  Further, you can modify display attributes, such as the number of digits, color of the leader, and font.��Single Touch Interface Editor also gives you the ability to "copy" existing icons, similarly to using the Windows clipboard.  See Set an Icon as Default for instructions.�


Access


Click the icon whose properties you want to view.  Click the right mouse button, and select Properties from the pop-up menu.�


Objects


Sequence Number/Feature Name


Icon Name


Number of Digits


Leader Position


Bend Point %


Leader Color


Font


Values





Tasks


Add an Icon Value


Delete an Icon Value


Edit an Icon Value


Modify the Properties of an Icon





Sequence Number/Feature Name


All icons must reference a feature in the Inspection Report.  Icons can be named with a sequence number or a feature name.  Select the button to indicate how you would like the icon named.


Icon Name


If you have selected Sequence Number, enter the sequence number of the feature.��If you have selected Feature Name, enter the feature name you want associated with the icon.


Number of Digits


Select the number of digits you want displayed for the icon values.  This is used to control the width of the icon.  The part program determines the numerical format.  If the number of digits is too small to accommodate the numerical format, asterisks will be displayed in the icon.


Leader Position


The icon leader can be removed completely (None), extend from the picture vertically (Vertical), or extend from the picture horizontally (Horizontal).  Select the position you prefer.


Bend Point %


This is the percentage of leader length that will be perpendicular to the icon.  The bend point enables a leader to be "bent" and drawn in another direction.


Leader Color


The leader color is displayed.  Click the Color button to open the Color Window to change this value.


Font


The font used in the icon is displayed.  Click the Font button to open the Font Window if you want to change any of the font attributes.


Values


This list contains all of the characteristic values that will be displayed in the icon.  You can add, edit, or delete from this list using the buttons to the right of this list.


Add an Icon Value


From within the Icon Properties Window:


1 Select the position in the list where you would like to add a new value.  Selecting an existing value will place the new value before it in the list.  To add to the end of the list, click below the last value.�


2 Click the Add button.��The Add New Value Window will open.�


3 Select the characteristic you want to add to the icon.�


4 Select the Datatype from the Datatype list.�


5 Enter the percentage of blueprint tolerance you want to use to provide warning information to the user.  For example, if you enter 80% and the inspection determines that the value is actually 90% of the blueprint tolerance, then the icon will be marked to warn the user that the soft limits have been exceeded.�


6 Click OK to add the new value, or click cancel to abort.�


See Also:


Icon Properties Window


Add New Value Window





Value Window


Description


This window allows you to add or edit a value in a slide icon.  Depending on the operation you are performing, the title of this window will be either Add New Value Window or Edit Value Window.�


Access


Click the Add button in the Icon Properties to add a new value.  Click the Edit button in the Icon Properties Window to edit an existing value.�


Objects


Characteristic


Datatype


Percentage of Tolerance





Tasks


Add an Icon Value


Edit an Icon Value


Characteristic


This list contains all of the possible characteristics and their associated geometric symbols that can be displayed in the icon.  Select the characteristic you want to add.


Datatype


This list contains all of the possible datatypes for the selected characteristic.  Select the datatype you want displayed in the icon.  Deviation is color coded and controls part status.


Percentage of Tolerance


This value represents the percentage of the blue print tolerance at which you want to provide a warning to the operator during the inspection.  For example, if you enter 80% and the inspected value is 90% of the blue print tolerance, then the icon will be marked to warn the operator that the soft limit has been exceeded.��Nominals and blue print tolerances are defined by the part program and may be included in the Inspection Report.  Percentage of tolerance is entered and calculated by Single Touch Interface and is not included in the Inspection Report.





Edit an Icon Value


From within the Icon Properties Window:


1 Select the value you want to edit.�


2 Click the Edit button.��The Edit Value Window will open.�


3 Modify the characteristic, datatype, and/or percentage of blueprint tolerance.�


4 Click the OK button to save your changes, or click Cancel to abort the changes.�


See Also:


Icon Properties Window


Edit Value Window





Delete an Icon Value


From within the Icon Properties Window:


1 Select the value you want to delete.�


2 Click the Delete button.��The value will be deleted from the list.�


See Also:


Icon Properties Window





Set an Icon as Default


This option allows you to "copy" an icon and all its properties on the slide.�


From within the Single Touch Interface Editor Window:


1 Select the icon you want to copy, or set as the default.�


2 Click the right mouse button and select Set as Default from the pop-up menu.��Any icons added after this time will have the same properties as this "default" icon.�


See Also:


Single Touch Interface Editor Window





Insert a Slide


From within the Single Touch Interface Editor Window:


1 Select Insert Slide from the Slide Menu.��A new slide will be inserted in the slide show, immediately following the slide you are viewing when you select this menu.�


See Also:


Single Touch Interface Editor Window





Move a Picture on a Slide


From within the Single Touch Interface Editor Window:


1 Select Position from the Background Menu.��The Position Picture Window will open.�


2 Modify the margins and dimensions as needed.  Use the picture placement graphic to view the results of your changes.�


3 Click OK to accept the changes, or click Cancel to abort.�


See Also:


Position Picture Window


Single Touch Interface Editor Window





Position Picture Window


Description


This window allows you to specify the location of any picture on the slide, as well as the picture dimensions for window metafiles (.wmf and .emf) file types.�


Access


Select Position from the Background Menu in the menu bar of the Single Touch Interface Editor Window.�


Objects


Picture Placement Graphic


Left Margin


Top Margin


Picture Width


Picture Height





Tasks


Move a Picture on a Slide





Picture Placement Graphic


This graphic illustrates the placement of the picture in the slide.  As the margins and dimensions are modified, this graphic is updated.


Left Margin


Use this slider to indicate the margin you want to the left of the picture in the slide.  Moving the slider to the left decreases the margin; moving it to the right increases the margin.  As this slider is moved, the picture placement graphic is updated to illustrate the change.


Top Margin


Use this slider to indicate the margin you want at the top of the picture in the slide.  Moving the slider to the left decreases the margin; moving it to the right increases the margin.  As this slider is moved, the picture placement graphic is updated to illustrate the change.


Picture Width


Use this slider to indicate the width of the picture in the slide.  Moving the slider to the left decreases the width; moving it to the right increases the width.  As this slider is moved, the picture placement graphic is updated to illustrate the change.��Note:  This slider is disabled for bitmap files.


Picture Height


Use this slider to indicate the height of the picture in the slide.  Moving the slider to the left decreases the height; moving it to the right increases the height.  As this slider is moved, the picture placement graphic is updated to illustrate the change.��Note:  This slider is disabled for bitmap files.





Move an Icon on a Slide


From within the Single Touch Interface Editor Window:


1 Select the icon you want to move.�


2 Press and hold the left mouse button.�


3 Drag the icon to its new location.��The icon will be moved.�


To move the leader position in the picture:


1 Select the leader end you want to move.  The mouse pointer will change to crosshairs.�


2 Press and hold the left mouse button.�


3 Drag the leader to its new position.��The leader will be moved.�


See Also:


Single Touch Interface Editor Window





Refresh a Slide


From within the Single Touch Interface Editor Window:


1 Select Update from the Background Menu.��The slide you are viewing will be refreshed.�


See Also:


Single Touch Interface Editor Window





Remove a Slide


From within the Single Touch Interface Editor Window:


1 Display the slide you want to remove from the slide show.�


2 Select Remove Slide from the Slide Menu.��The slide you are viewing will be removed.�


See Also:


Single Touch Interface Editor Window





Work with Slide Show Files


Add a New Slide Show


Close a Slide Show


Edit the Properties of the Single Touch Interface Monitor


Export a Slide Show


Import a Slide Show


Link a Slide Show to a Part Program


Modify Slide Show Properties


Open a Slide Show


Save a Slide Show





Add a New Slide Show


From within the Single Touch Interface Editor Window:


1 Select New from the File Menu.��The Select New Slide Show File Window will open.�


2 Enter/select the name and directory of the new slide show.�


3 Click OK to add the new slide show, or click Cancel to abort.��The Single Touch Interface Editor Window will be displayed with your first slide.�


See Also:


Single Touch Interface Editor Window





Close a Slide Show


From within the Single Touch Interface Editor Window:


1 Select Close from the File Menu.��If you have made changes to the slide show that have not been saved, you will be prompted to save them.  After saving, the slide show file will be closed.�


See Also:


Single Touch Interface Editor Window





Export a Slide Show


From within the Single Touch Interface Editor Window:


1 Select Export from the File Menu.��The Export Window will open.�


2 Enter a directory and file name for the export file,��OR��Click the Browse button to select a directory and file name for the export file.�


3 Enter any comments for the export.  This information will be displayed in the Import Window when a user selects the file to import.�


4 Click OK to export the slide show, or click Cancel to abort the export.��The slide show and its graphics will be exported so that a customer can import it and run the slide show during an inspection.�


See Also:


Export Window


Single Touch Interface Editor Window





Export Window


Description


Once a slide show has been created, it needs to be exported so that a customer can import it and run it during an inspection.  The slide show, any bitmaps and drawings will all be exported to a file that a customer can then import.  From within this window, you can specify the location and file name for the export file, as well as enter any comments about the slide show.�


Access


This window opens when you select Export from the File Menu in the menu bar of the Single Touch Interface Editor Window.�


Objects


Export File Name


Comments





Tasks


Export a Slide Show





Export File Name


Enter the directory and name of the file to which you want to export the slide show.  Alternatively, you can click the Browse button to open the Select Export File Name Window to select the export file.





Export Comments


Enter any comments you want to have associated with the export file.  When a user selects the file to import, this information will be displayed in the Comments field of the Import Window.





Import a Slide Show


From within the Single Touch Interface Editor Window:


1 Select Import from the File Menu.��The Import Slide Show Window will open.�


2 Enter the directory and file name of the export file,��OR��Click the Browse button to select the directory and file name of the export file.��The fields in the Import File Information fields will be updated with information for the slide show in the export file.  This will ensure that you import the correct file.�


3 Enter a directory and file name to save the imported slide show, ��OR��Click the Browse button to select a directory and file name to save the imported slide show.�


4 Click OK to import the slide show, or click Cancel to abort the import.��The slide show and its supporting graphics will be imported into a single directory.  The customer can now run the slide show during an inspection.�


See Also:


Import Slide Show Window


Single Touch Interface Editor Window





Import Slide Show Window


Description


Single Touch Interface Editor allows you to export a completed slide show so that a customer can import the slide show to run during an inspection.  This window allows you to import a previously exported slide show.�


Access


Select Import from the File Menu in the Single Touch Interface Editor Window.�


Objects


Backup File Name


STI File Name


Slide Show Name


Backup Date


Comment





Tasks


Import a Slide Show


Backup File Name


Enter the directory and file name of the file you wish to import.  Alternatively, you can click the Browse button to open the Select Export File to select the file.


STI File Name


This field displays the name that will be used to save the imported slide show.  You can use this name, enter a new one, or use the Browse button to select the directory and file name.


Slide Show Name


This field displays the name of the slide show that is in the export file.


Backup Date


This field displays the date and time that the slide show was exported.


Import Comment


If comments were entered in the Comment field of the Export Window when the slide show was exported, they will be displayed in this field.





Modify Slide Show Properties


From within the Single Touch Interface Editor Window:


1 Select Properties from the File Menu in the menu bar.��The Slide Show Properties Window will open.�


2 Modify the properties as needed.�


3 Click OK to save the property changes, or click Cancel to abort.�


See Also:


Slide Show Properties Window


Single Touch Interface Editor Window





Slide Show Properties Window


Description


This window provides general information about the slide show including its name, description, customer, associated help file, and statistics about the slides and icons in the slide show.�


Access


Select Properties from the File Menu in the menu bar of the Single Touch Interface Editor Window.�


Objects


General Tab


Name


Description


Customer


User Help File





Statistics Tab


Slide Show Statistics





Tasks


Modify Slide Show Properties





Name


Enter the name of the slide show in this field.


Description


Enter a description of the slide show in this field.


Customer


Enter the customer for which the slide show was developed in this field.


User Help File


If a help file has been developed to assist the user in running the inspection, enter the name in this field.  Alternatively, you can use the Browse button to search for the help file.


Slide Show Statistics


This tab presents various statistics about the slide show, including number of slides and number of icons.





Open a Slide Show


From within the Single Touch Interface Editor Window:


1 Select Open from the File Menu.��The Select Slide Show File Window will open.�


2 Select the name and directory of the slide show you want to open.�


3 Click OK to open the slide show, or click Cancel to abort.��The slide show will be displayed in the Single Touch Interface Editor Window.�


See Also:


Single Touch Interface Editor Window





Save a Slide Show


From within the Single Touch Interface Editor Window:


1 Select Save from the File Menu.��The slide show will be saved.�


To Save the Slide Show with a New Name:


1 Select Save As from the File Menu.��The Save Slide Show File Window will open.�


2 Enter the name and directory for the slide show.�


3 Click OK to save the slide show with the new name, or click Cancel to abort.��The slide show will saved with the new name.�


See Also:


Single Touch Interface Editor Window





Move to the Last Slide


From within the Single Touch Interface Editor Window:


1 Select Last Slide from the Slide Menu,��OR��Click the Slide Navigator until you reach the last slide.��The last slide will be displayed.�


See Also:


Single Touch Interface Editor Window





Move to the Next Slide


From within the Single Touch Interface Editor Window:


1 Select Next Slide from the Slide Menu,��OR��Click the right arrow on the Slide Navigator.��The next slide will be displayed.�


See Also:


Single Touch Interface Editor Window





Move to the Previous Slide


From within the Single Touch Interface Editor Window:


1 Select Previous Slide from the Slide Menu,��OR��Click the left arrow on the Slide Navigator.��The previous slide will be displayed.�


See Also:


Single Touch Interface Editor Window





Work with an Icon


Add an Icon Value


Delete an Icon from a Slide


Delete an Icon Value


Edit an Icon Value


Insert an Icon in a Slide


Modify the Properties of an Icon


Move an Icon on a Slide


Set an Icon as Default





Overwrite Prompt Window


Description


This window is displayed if you are in danger of overwriting an existing file.  If you wish to overwrite the file, click Yes, or Yes to All if you want to overwrite all files.  If you don't wish to overwrite files, click No or No to All.�


�Access


This window is displayed automatically if you are in danger of overwriting existing files.  This is especially 
