PC-DMIS Basic Language Reference

PC-DMIS BASIC Overview

Basic Script Editor

Cypress Enable Scripting Language Elements

Scripting Language Overview

Language Reference A - Z

Automation


PC-DMIS BASIC Overview

More:

Introduction

What is Cypress Enable?

Organization of the Manual


PC-DMIS BASIC Language Reference: Introduction

Current Help System: PC-DMIS BASIC (View Core Help)

Introduction

While PC-DMIS for Windows contains a myriad of valuable options and features to aid you in your part measurements, there may be times when you want greater customizeability to meet specific needs. Maybe you want the capability to globally change a particular value inside the Edit window, or maybe you want to export statistical data to a specific application. Rather than waiting for an item on your wish list to be coded into a future version of PC-DMIS, PC-DMIS allows you to create your own BASIC scripts and run them inside PC-DMIS. In fact, using PC-DMIS's comprehensive list of automation commands, properties and methods, you can run PC-DMIS entirely from a custom-built third party application.

What is Cypress Enable?

Organization of the Manual


What is Cypress Enable?

PC-DMIS comes with a BASIC Script Editor that uses Cypress Enable Scripting Language, a powerful subset of the BASIC language. If you have a working knowledge of BASIC, the tools given in this help file will be invaluable to creating your own mini-applications that work in conjunction with PC-DMIS.


Organization of the Manual

This help file contains the following sections:

  • Basic Script Editor - this discusses how to open and use the Basic Script Editor from within PC-DMIS to create and compile your BASIC scripts.

  • Cypress Enable Scripting Language Elements - this discusses the language elements used to create BASIC scripts using Cypress Enable.

  • Scripting Language Overview - this contains quick reference charts on functions, statements, data types, operators, reserved words, and precedence.

  • Language Reference A-Z - this contains a full fledged language reference of BASIC code that you can use.

  • Automation - this contains all the properties and methods associated with every PC-DMIS object that you can use via your BASIC scripts.


Chapter 2: Basic Script Editor

Current Help System: PC-DMIS BASIC (View Core Help)

Basic Script Editor

More:

Introduction

File Menu

Edit Menu

View Menu

Run Menu

Help Menu

Basic Script Toolbar


Introduction

The Utilities | Scripting | Basic Script Editor menu option opens the Basic Script Editor. The Basic Script Editor can be used to create and edit basic scripts that can be used in Basic Script objects during execution or from the Basic Script's Standard toolbar. The Basic Script Editor consists of the following menus:

  1. File menu

  2. Edit menu

  3. View menu

  4. Run menu

  5. Help menu

Tip: You do not have to use the BASIC Script Editor to create your scripts. Many users prefer to use the Visual BASIC interface that comes with Microsoft Office applications such as Visual BASIC for Microsoft Excel or Microsoft Word. These applications contain advanced debugging tools and visual aids to help you create your scripts. See "Using the Object Browser in Other Editors" in the "Automation" section.


New

The File | New menu option opens a new Basic Script Editor in which you can write a new script.


Open

The File | Open menu option allows you to navigate to and open an existing script. In order for files to appear in the Basic Script Editor, files must be of file type .BAS.


Save

The File | Save menu option allows you to save a script. With a new script, the first time this option is selected, the Save As dialog box will appear.


Save As

The File | Save As menu option allows you to save a new script, or an already existing script by a new file name. The Save As dialog box appears, allowing you to select the file name and the directory to which you will be saving the script.


Print

The File | Print menu option allows you to print the script in the Basic Script Editor from your system's printer.


Print Preview

The File | Print Preview menu option allows you to preview what will be sent to the printer when Print is selected from the Basic Script Editor's File menu.


Exit

The File | Exit menu option allows you to exit out of the Basic Script Editor without saving any changes you have made to any open scripts. Choosing File | Exit will return you the main user interface. The menu bar will return to normal PC-DMIS functions.


Undo

The Edit | Undo menu option allows you to undo the most recent action taken in the Basic Script Editor.


Cut

The Edit | Cut menu option allows you to cut selected text from the Basic Script Editor. Cut text is stored in the Windows clipboard to later be pasted elsewhere.


Copy

The Edit | Copy menu option allows you to copy selected text. Copied text is stored in the Windows clipboard to later be pasted elsewhere.


Paste

The Edit | Paste command allows you to paste text that is stored in the Windows clipboard.


Delete

The Edit | Delete command allows you to delete highlighted text.


Select All

The Edit | Select All menu option automatically selects all the text within the Basic Script Editor. You can then Cut, Copy, or Delete the selected text.


Find

The Edit | Find menu option brings up the Find dialog box.

Find dialog box

This dialog allows you to search for a specific word, or term within the Basic Script Editor.

  • If you choose the Match whole word only check box the dialog will display only those words that match the entire word.

  • If you choose the Match Case check box, then the dialog box will display only those terms that match the case (Uppercase or Lowercase) that you used in the Find what box.


Find Next

The Edit | Find Next will search in the Basic Script Editor for the next term that meets the qualifications specified in the Find dialog box (See Edit | Find above.)


Replace

The Edit | Replace menu option brings up the Replace dialog box

Replace dialog box

This dialog box is an extension of the Edit | Find command. This allows you to search for a specific term and then replace it with the term entered in the Replace with box.

More:

Find Next

Replace

Replace All

Cancel


Find Next

The Find Next button searches through the Basic Script Editor and brings up the first instance that meets the qualifications entered in the dialog box.


Replace

The Replace button allows you to replace what has been found (using the Find Next button) with what is in the Replace with box.


Replace All

The Replace All button allows you to replace all instances in the Basic Script Editor that meet the search qualifications with what is in the Replace with box.


Cancel

The Cancel button closes the Replace dialog box.


Dialog Editor

The Dialog Editor menu option launches the MasQ Enable Dialog Designer:

MasQ Enable Dialog Designer

This application allows you to design dialog boxes for use with the Basic Script Editor. While it doesn't have the full power of a Visual Basic form designer, it provides you with a quick way to generate and place dialog box code into the Basic Script Editor.

For additional information on the Cypress Enable dialog box code, see the "Dialog Support" topic.

More:

To Create a New Dialog Box:

To Modify an Existing Dialog Box:


To Create a New Dialog Box:

  1. Select Edit | Dialog Editor. The MasQ Enable Dialog Designer appears.

  2. Use the dialog designer toolbar to select and place controls into the Design Window.

  3. Change caption properties as needed by using the Properties option from the Window menu.

  4. Align controls on the Design Window by using options in the Edit menu.

  5. When you have finished designing your dialog box, select File | Put Dialog on Clipboard. This sends the code for the dialog box to the Windows Clipboard.

  6. Select File | Close Dialog Designer.

  7. Access the Basic Script Editor inside PC-DMIS.

  8. Press CTRL + V to paste the code from the clipboard into the Basic Script Editor. The dialog box code begins with Begin Dialog and ends with End Dialog.

  9. Modify the code as needed.


To Modify an Existing Dialog Box:

This procedure assumes you have already pasted some sort of dialog box code from the clipboard into the Basic Script Editor, as described in the "To Create a New Dialog Box:" topic.

  1. Access the Basic Script Editor inside PC-DMIS.

  2. Select the dialog box code and press CTRL + C to copy it to the Clipboard. The dialog box code begins with Begin Dialog and ends with End Dialog.

  3. Select Edit | Dialog Editor. The MasQ Enable Dialog Designer appears.

  4. From the dialog designer's menu bar, select File | Load Dialog from Clipboard.

  5. Use the dialog designer to further modify your dialog box.

  6. When you have finished modifying your dialog box, select File | Put Dialog on Clipboard. This sends the code for the dialog box to the Windows Clipboard.

  7. Select File | Close Dialog Designer.

  8. Access the Basic Script Editor inside PC-DMIS.

  9. Press CTRL + V to paste the code from the clipboard into the Basic Script Editor.

  10. Modify the code as needed.


Convert OldBasic Script

The Convert OldBasic Script menu item, allows you to convert scripts from older versions (versions 2.3 and previous) into the latest format. To use this option, first load the old script into the Basic Script Editor and then select the Edit | Convert OldBasic Script menu item.


View Menu

The View menu allows you to choose if the Basic Script Editor's toolbar and / or Status Bar is being displayed. Select View | Toolbar to toggle the toolbar on or off. Select View | Status Bar to toggle the status bar on or off.


Run Menu

The Run menu allows you to Compile a script or Execute a script. Use the compile command to test the script for syntactic errors. The execute command executes the script.


Basic Help

The Help | Basic Help command brings up the on-line help file (Pcdbasic.hlp or Pcdbasic.chm) created for the add on Basic Module.


New

This icon allows you to create a new basic script in the editor.


Open

This icon brings up an Open File dialog box allowing you opens an existing basic script into the editor.


Save

This icon saves the current basic script. If you have not already named the current script, a Save As dialog box asking for the name of the script will appear.


Current Help System: PC-DMIS BASIC (View Core Help)

Print

This icon prints the current basic script.


Print Preview

This icon allows you to see the current basic script in the Print Preview window as it will appear when printed.


Find

This icon allows you to search for text in the current basic script.


Cut

This button cuts currently selected text and put text on the clipboard.


Copy

This icon copies currently selected text and put text on the clipboard.


Paste

This icon pastes text from the clipboard into the editor at the current insertion point.


Undo

This icon allows you to undo the last editing change.


Compile

This icon compiles (makes the script understandable and ready to run on the computer system) the current BASIC script. You must compile a script before running it.


Run

This icon compiles and runs the current basic script.

Note: Scripts run from the editor using the PC-DMIS basic commands can insert objects into the current part program.


Chapter 3: Cypress Enable Scripting Language Elements

Current Help System: PC-DMIS BASIC (View Core Help)

Cypress Enable Scripting Language Elements

More:

Introduction

Comments

Numbers

Variable and Constant Names

Variable Types

Other Data Types

Control Structures

L oop Structures

Subroutines and Functions

Calling Procedures in DLLs

File Input/Output

Arrays

User Defined Types

Dialog Support

Statements and Functions Used in Dialog Functions

OLE Automation

Accessing an Object

What is an OLE Object?

OLE Fundamentals

OLE Automation and Microsoft Word Example:

Making Applications Work Together

The Registration database


Introduction

In this section, the general elements of the Enable language are described. Enable scripts can include comments, statements, various representations of numbers, 11 variable data types including user defined types, and multiple flow of control structures. Enable is also extendable by calling external DLL’s or calling functions back in the applications .exe file.


Statements:

In Enable there is no statement terminator. More than one statement can be put on a line if they are separated by a colon ":".

X.AddPoint( 25, 100) : X.AddPoint( 0, 75)

Which is equivalent to:

X.AddPoint( 25, 100)

X.AddPoint( 0, 75)


Line Continuation Character:

The underscore is the line continuation character in Enable. There must be a space before and after the line continuation character.

X.AddPoint _

( 25, 100)


Numbers

Cypress Enable supports three representations of numbers: Decimal, Octal and Hexadecimal. Most of the numbers used in this manual are decimal or base 10 numbers. However, if you need to use Octal (base 8) or hexadecimal (base 16) numbers simply prefix the number with &O or &H respectively.


Variable and Constant Names

Variable and Constant names must begin with a letter. They can contain the letters A to Z and a to z, the underscore “_”, and the digits 0 to 9. They can be no longer than 40 characters and they cannot be reserved words. For a table of reserved words, see the Language Overview section of this manual. One exception to this rule is that object member names and property names may be reserved words.


Variable Types

More:

Variant

Variants and Concatenation


Variant

As is the case with Visual Basic, when a variable is introduced in Cypress Enable, it is not necessary to declare it first (see option explicit for an exception to this rule). When a variable is used but not declared then it is implicitly declared as a variant data type. Variants can also be declared explicitly using "As Variant" as in Dim x As Variant. The variant data type is capable of storing numbers, strings, dates, and times. When using a variant you do not have to explicitly convert a variable from one data type to another. This data type conversion is handled automatically.

For example:

Sub Main

Dim x 'variant variable

x = 10

x = x + 8

x = "F" & x

print x 'prints F18

End Sub

A variant variable can readily change its type and its internal representation can be determined by using the function VarType. VarType returns a value that corresponds to the explicit data types. See "VarType" in the "Language Reference A – Z" section for return values.

When storing numbers in variant variables the data type used is always the most compact type possible. For example, if you first assign a small number to the variant it will be stored as an integer. If you then assign your variant to a number with a fractional component it will then be stored as a double.

For doing numeric operations on a variant variable it is sometimes necessary to determine if the value stored is a valid numeric, thus avoiding an error. This can be done with the IsNumeric function described in the "IsNumeric" topic in the "Language Reference A – Z" section.


Variants and Concatenation

If a string and a number are concatenated the result is a string. To be sure your concatenation works regardless of the data type involved use the & operator. The & will not perform arithmetic on your numeric values it will simply concatenate them as if they were strings.

The IsEmpty function can be used to find out if a variant variable has been previously assigned (see "IsEmpty").


Other Data Types

The twelve data types available in Cypress Enable are shown below:

More:

Data Types

Scope of Variables

Declaration of Variables


Data Types

Variable | Symbol | Type Declaration | Size
Byte |  | Dim BVar As Byte | 0 to 255
Boolean |  | Dim BoolVar As Boolean | True or False
String | $ | Dim Str_Var As String | 0 to 65,500 char
Integer | % | Dim Int_Var As Integer | 2 bytes
Long | & | Dim Long_Var As Long | 4 bytes
Single | ! | Dim Sing_Var As Single | 4 bytes
Double | # | Dim Dbl_Var As Double | 8 bytes
Variant |  | Dim X As Any |
Currency |  | Dim Cvar As Currency | 8 bytes
Object |  | Dim X As Object | 4 bytes
Date |  | Dim D As Date | 8 bytes
User Defined Types |  |  | size of each element


Scope of Variables

Cypress Enable scripts can be composed of many files and each file can have many subroutines and functions in it. Variable names can be reused even if they are contained in separate files. Variables can be local or global.


Declaration of Variables

In Cypress Enable variables are declared with the Dim statement. To declare a variable other than a variant the variable must be followed by As or appended by a type declaration character such as a % for Integer type.

For example:

Sub Main

Dim X As Integer

Dim Y As Double

Dim YourName$, YourAge% ' multiple declaration on one line Dim v

End Sub

Notice that the variables YourName and YourAge use a symbol to declare the variable type instead of the term As.

See "Dim Statement" for more information.

Note: While it may be possible in some cases to use variables without declaring them with the Dim statement first, doing so is not supported in Enable BASIC and may cause problems in your code.


Control Structures

Cypress Enable has complete process control functionality. The control structures available are Do loops, While loops, For loops, Select Case, If Then , and If Then Else. In addition, Cypress Enable has one branching statement: GoTo. The GoTo Statement branches to the label specified in the GoTo Statement.

For example:

Goto label1

.

.

.

label1:

The program execution jumps to the part of the program that begins with the label "label1:".

More:

Loop Structures


Loop Structures

More:

Do Loops

While Loop

For ... Next Loop

If and Select Statements


Do Loops

The Do...Loop allows you to execute a block of statements an indefinite number of times. The variations of the Do...Loop are Do While, Do Until, Do Loop While, and Do Loop Until.

Do While

Do While|Until condition

statement(s)...

[Exit Do]

statement(s)...

Loop

Do Until

Do Until condition

statement(s)...

Loop

Do Loop While

Do

statements...

Loop While condition

Do Loop Until

Do

Statements...

Loop Until condition

Do While and Do Until check the condition before entering the loop, thus the block of statements inside the loop are only executed when those conditions are met. Do Loop While and Do Loop Until check the condition after having executed the block of statements thereby guaranteeing that the block of statements is executed at least once.


While Loop

The While...Wend loop is similar to the Do While loop. The condition is checked before executing the block of statements comprising the loop.

While condition

statements...

Wend


For ... Next Loop

The For...Next loop has a counter variable and repeats a block of statements a set number of times. The counter variable increases or decreases with each repetition through the loop. The counter default is one if the Step variation is not used.

For counter = beginning value To ending value [Step increment]

Statements...

Next


If and Select Statements

The If...Then block has a single line and multiple line syntax. The condition of an If statement can be a comparison or an expression, but it must evaluate to True or False.

If condition Then Statements... 'single line syntax

If condition Then 'multiple line syntax

statements...

End If

The other variation on the If statement is the If...Then...Else statement. This statement should be used when there are different statement blocks to be executed depending on the condition. There is also the If...Then...ElseIf... variation, these can get quite long and cumbersome, at which time you should consider using the Select statement.

If condition Then

statements...

ElseIf condition Then

statements...

Else

End If

The Select Case statement tests the same variable for many different values. This statement tends to be easier to read, understand and follow and should be used in place of a complicated If...Then...ElseIf statement.

Select Case variable to test

Case 1

statements...

Case 2

statements...

Case 3

statements...

Case Else

statements...

End Select

See "Language Reference A – Z" section for exact syntax and code examples.


Subroutines and Functions

Naming conventions

Subroutine and Function names can contain she letters A to Z and a to z, the underscore “_” and digits 0 to 9. The only limitation is that subroutine and function names must begin with a letter, be no longer than 40 characters, and not be reserved words. For a list of reserved words, see the table of reserved words under "Functions, Statements, Reserved words – Quick Reference" topic in the "Scripting Language Overview" section.

Cypress Enable allows script developers to create their own functions or subroutines or to make DLL calls. Subroutines are created with the syntax "Sub <subname> .... End Sub". Functions are similar "Function <funcname> As <type> ... <funcname> = <value> ... End Function.” DLL functions are declared via the Declare statement.

Function Return Types

Note: Be aware that type Object is not a valid return type of functions.

More:

ByRef and ByVal


ByRef and ByVal

ByRef gives other subroutines and functions the permission to make changes to variables that are passed in as parameters. The keyword ByVal denies this permission and the parameters cannot be reassigned outside their local procedure. ByRef is the Enable default and does not need to be used explicitly. Because ByRef is the default all variables passed to other functions or subroutines can be changed, the only exception to this is if you use the ByVal keyword to protect the variable or use parentheses which indicate the variable is ByVal.

If the arguments or parameters are passed with parentheses around them, you will tell Enable that you are passing them ByVal

SubOne var1, var2, (var3)

The parameter var3 in this case is passed by value and cannot be changed by the subroutine SubOne.

Function R( X As String, ByVal n As Integer)

In this example the function R is receiving two parameters X and n. The second parameter n is passed by value and the contents cannot be changed from within the function R.

In the following code samples, scalar variable and user defined types are passed by reference.

More:

Scalar Variables

Passing User Defined Types by Ref to DLL’s and Enable functions


Scalar Variables

Sub Main

Dim x(5) As Integer

Dim i As Integer

for i = 0 to 5

x(i) = i

next i

Print i

Joe (i), x ‘ The parenthesis around it turn it into an expression which passes by value

print "should be 6: "; x(2), i

End Sub

Sub Joe( ByRef j As Integer, ByRef y() As Integer )

print "Joe: "; j, y(2)

j = 345

for i = 0 to 5

print "i: "; i; "y(i): "; y(i)

next i

y(2) = 3 * y(2)

End Sub


Passing User Defined Types by Ref to DLL’s and Enable functions

' OpenFile() Structure

Type OFSTRUCT

cBytes As String * 1

fFixedDisk As String * 1

nErrCode As Integer

reserved As String * 4

szPathName As String * 128

End Type

' OpenFile() Flags4

Global Const OF_READ = &H0

Global Const OF_WRITE = &H1

Global Const OF_READWRITE = &H2

Global Const OF_SHARE_COMPAT = &H0

Global Const OF_SHARE_EXCLUSIVE = &H10

Global Const OF_SHARE_DENY_WRITE = &H20

Global Const OF_SHARE_DENY_READ = &H30

Global Const OF_SHARE_DENY_NONE = &H40

Global Const OF_PARSE = &H100

Global Const OF_DELETE = &H200

Global Const OF_VERIFY = &H400

Global Const OF_CANCEL = &H800

Global Const OF_CREATE = &H1000

Global Const OF_PROMPT = &H2000

Global Const OF_EXIST = &H4000

Global Const OF_REOPEN = &H8000

Declare Function OpenFile Lib "Kernel" (ByVal lpFileName As String, lpReOpenBuff As OFSTRUCT, ByVal wStyle As Integer) As Integer

Sub Main

Dim ofs As OFSTRUCT

' Print OF_READWRITE

ofs.szPathName = "c:\enable\openfile.bas"

print ofs.szPathName

ofs.nErrCode = 5

print ofs.nErrCode

OpenFile "t.bas", ofs

print ofs.szPathName

print ofs.nErrCode

End Sub


Passing and Returning Strings

Cypress Enable maintains variable-length strings internally as BSTRs. BSTRs are defined in the OLE header files as OLECHAR FAR *. An OLECHAR is a UNICODE character in 32-bit OLE and an ANSI character in 16-bit OLE. A BSTR can contain NULL values because a length is also maintained with the BSTR. BSTRs are also NULL terminated so they can be treated as an LPSTR. Currently this length is stored immediately prior to the string. This may change in the future, however, so you should use the OLE APIs to access the string length.

You can pass a string from Cypress Enable to a DLL in one of two ways. You can pass it "by value" (ByVal) or "by reference". When you pass a string ByVal, Cypress Enable passes a pointer to the beginning of the string data (i.e. it passes a BSTR). When a string is passed byreference, Enable passes a pointer to a pointer to the string data (i.e. it passes a BSTR *).

OLE API

SysAllocString/SysAllocStringLen

SysAllocString/SysAllocStringLen

SysFreeString

SysStringLen

SysReAllocStringLen

SysReAllocString

Note:: The BSTR is a pointer to the string, so you don't need to dereference it.


File I/O Examples

Sub Main

Open "TESTFILE" For Input As #1 ' Open file.

Do While Not EOF(1) ' Loop until end of file.

Line Input #1, TextLine ' Read line into variable.

Print TextLine ' Print to Debug window.

Loop

Close #1 ' Close file.

End Sub

Sub test

Open "MYFILE" For Input As #1 ' Open file for input.

Do While Not EOF(1) ' Check for end of file.

Line Input #1, InputData ' Read line of data.

MsgBox InputData

Loop

Close #1 ' Close file.

End Sub

Sub FileIO_Example()

Dim Msg ' Declare variable.

Call Make3Files() ' Create data files.

Msg = "Several test files have been created on your disk. "

Msg = Msg & "Choose OK to remove the test files."

MsgBox Msg

For I = 1 To 3

Kill "TEST" & I ' Remove data files from disk.

Next I

End Sub

Sub Make3Files ()

Dim I, FNum, FName ' Declare variables.

For I = 1 To 3

FNum = FreeFile ' Determine next file number.

FName = "TEST" & FNum

Open FName For Output As FNum ' Open file.

Print #I, "This is test #" & I ' Write string to file.

Print #I, "Here is another "; "line"; I

Next I

Close ' Close all files.

End Sub


Ways to Declare a Fixed-Size Array

q Global array, use the Dim statement outside the procedure section of a code module to declare the array.

q To create a local array, use the Dim statement inside a procedure.

q Cypress Enable supports Dynamic arrays.

More:

Declaring an Array

Creating a Global Array


Declaring an Array

The array name must be followed by the upper bound in parentheses. The upper bound must be an integer.

Dim ArrayName (10) As Interger

Dim Sum (20) As Double


Creating a Global Array

To create a global array, you simply use Dim outside the procedure:

Dim Counters (12) As Integer

Dim Sums (26) As Double

Sub Main () …

The same declarations within a procedure use Static or Dim:

Static Counters (12) As Integer

Static Sums (22) As Double

The first declaration creates an array with 11 elements, with index numbers running from 0 to 10. The second creates an array with 21 elements. To change the default lower bound to 1 place an Option Base statement in the Declarations section of a module:

Option Base 1

Another way to specify the lower bound is to provide it explicitly (as an integer, in the range -32,768 to 32,767) using the To key word:

Dim Counters (1 To 13) As Integer

Dim Sums (100 To 126) As String

In the preceding declarations, the index numbers of Counters run from 1 to 13, and the index numbers of Sums run from 100 to 126.

Note: Many other versions of Basic allow you to use an array without first declaring it. Enable Basic does not allow this; you must declare an array before using it.


Manipulating Arrays

Loops often provide an efficient way to manipulate arrays. For example, the following For loop initializes all elements in the array to 5:

Static Counters (1 To 20) As Integer

Dim I As Integer

For I = 1 To 20

Counter ( I ) = 5

Next I

…


MultiDimensional Arrays

Cypress Enable supports multidimensional arrays. For example the following example declares a two-dimensional array within a procedure.

Static Mat(20, 20) As Double

Either or both dimensions can be declared with explicit lower bounds.

Static Mat(1 to 10, 1 to 10) As Double

You can efficiently process a multidimensional array with the use of for loops. In the following statements the elements in a multidimensional array are set to a value.

Dim L As Integer, J As Integer

Static TestArray(1 To 10, 1 to 10) As Double

For L = 1 to 10

For J = 1 to 10

TestArray(L,J) = I * 10 + J

Next J

Next L

Arrays can be more than two dimensional. Enable does not have an arbitrary upper bound on array dimensions.

Dim ArrTest(5, 3, 2)

This declaration creates an array that has three dimensions with sizes 6 by 4, by 3 unless Option Base 1 is set previously in the code. The use of Option Base 1 sets the lower bound of all arrays to 1 instead of 0.


User Defined Types

Users can define their own types that are composites of other built-in or user defined types. Variables of these new composite types can be declared and then member variables of the new type can be accessed using dot notation. Only variables of user defined types that contain simple data types can be passed to DLL functions expecting ‘C’ structures.

User Defined types are created using the type statement, which must be placed outside the procedure in your Enable Code. User defined types are global. The variables that are declared as user defined types can be either global or local. User Defined Types in Enable cannot contain arrays at this time.

Type type1

a As Integer

d As Double

s As String

End Type

Type type2

a As Integer

o As type1

End Type

Dim type2a As type2

Dim type1a As type1

Sub TypeExample ()

a = 5

type1a.a = 7472

type1a.d = 23.1415

type1a.s = "YES"

type2a.a = 43

type2a.o.s = "Hello There"

MsgBox type1a.a

MsgBox type1a.d

MsgBox type1a.s

MsgBox type2a.a

MsgBox type2a.o.s

MsgBox a

End Sub


Dialog Box controls

Enable Basic supports the standard Windows dialog box controls. This section introduces the controls available for custom dialog boxes and provides guidelines for using them.

The Dialog Box syntax begins with the statement “Begin Dialog”. The first two parameters of this statement are optional. If they are left off the dialog will automatically be centered.

Begin Dialog DialogName1 240, 184, "Test Dialog"

Begin Dialog DialogName1 60, 60,240, 184, "Test Dialog"


OK and Cancel Buttons

Sub Main

Begin Dialog ButtonSample 16,32,180,96,"OK and Cancel"

OKButton 132,8,40,14

CancelButton 132,28,40,14

End Dialog

Dim Dlg1 As ButtonSample

Button = Dialog (Dlg1)

End Sub

Every custom dialog box must contain at least one “command” button - a OK button or a Cancel button. Enable includes separate dialog box definition statements for each of these two types of buttons.


List Boxes, Combo Boxes and Drop-down List Boxes

Sub Main

Dim MyList$ (5)

MyList (0) = "line Item 1"

MyList (1) = "line Item 2"

MyList (2) = "line Item 3"

MyList (3) = "line Item 4"

MyList (4) = "line Item 5"

MyList (5) = "line Item 6"

Begin Dialog BoxSample 16,35,256,89,"List Box, Combo Box, and Drop-Down List Box"

OKButton 204,24,40,14

CancelButton 204,44,40,14

ListBox 12,24,48,40, MyList$( ),.Lstbox

DropListBox 124,24,72,40, MyList$( ),.DrpList

ComboBox 68,24,48,40, MyList$( ),.CmboBox

Text 12,12,32,8,"List Box:"

Text 124,12,68,8,"Drop-Down List Box:"

Text 68,12,44,8,"Combo Box:

End Dialog

Dim Dlg1 As BoxSample

Button = Dialog ( Dlg1 )

End Sub

You can use a list box, drop-down list box, or combo box to present a list of items from which the user can select. A drop-down list box saves space (it can drop down to cover other dialog box controls temporarily). A combo box allows the user either to select an item from the list or type in a new item. The items displayed in a list box, drop-down list box, or combo box are stored in an array that is defined before the instructions that define the dialog box.


Check Boxes

Sub Main

Begin Dialog CheckSample15,32,149,96,"Check Boxes"

OKButton 92,8,40,14

CancelButton 92,32,40,14

CheckBox 12,8,45,8,"CheckBox",.CheckBox1

CheckBox 12,24,45,8,"CheckBox",.CheckBox2

CheckBox 12,40,45,8,"CheckBox",.CheckBox3

CheckBox 12,56,45,8,"CheckBox",.CheckBox4

End Dialog

Dim Dlg1 As CheckSample

Button = Dialog ( Dlg1 )

End Sub

You use a check box to make a “yes or no” or “on or off” choice. for example, you could use a check box to display or hide a toolbar in your application.


Text Boxes and Text

   Sub Main

Begin Dialog TextBoxSample 16,30,180,96,"Text Boxes and Text"

OKButton 132,20,40,14

CancelButton 132,44,40,14

Text 8,8,32,8,"Text Box:"

TextBox 8,20,100,12,.TextBox1

Text 8,44,84,8,"Multiline Text Box:"

TextBox 8,56,100,32,.TextBox2

End Dialog

Dim Dlg1 As TextBoxSample

Button = Dialog ( Dlg1 )

End Sub

A text box control is a box in which the user can enter text while the dialog box is displayed. By default, a text box holds a single line of text. Enable support single and multi-line text boxes. The last parameter of the textbox function contains a variable to set the textbox style.

'=========================================================

' This sample shows how to implement a multiline textbox

'=========================================================

Const ES_LEFT = &h0000& 'Try these different styles or-ed together

Const ES_CENTER = &h0001& ' as the last parameter of Textbox the change

Const ES_RIGHT = &h0002& ' the text box style.

Const ES_MULTILINE = &h0004& ' A 1 in the last parameter position defaults to

Const ES_UPPERCASE = &h0008& ' A multiline, Wantreturn, AutoVScroll testbox.

Const ES_LOWERCASE = &h0010&

Const ES_PASSWORD = &h0020&

Const ES_AUTOVSCROLL = &h0040&

Const ES_AUTOHSCROLL = &h0080&

Const ES_NOHIDESEL = &h0100&

Const ES_OEMCONVERT = &h0400&

Const ES_READONLY = &h0800&

Const ES_WANTRETURN = &h1000&

Const ES_NUMBER = &h2000&

Sub Multiline

Begin Dialog DialogType 60, 60, 140, 185, "Multiline text Dialog", .DlgFunc

TextBox 10, 10, 120, 150, .joe, ES_MULTILINE Or ES_AUTOVSCROLL Or ES_WANTRETURN ' Indicates multiline TextBox

'TextBox 10, 10, 120, 150, .joe, 1 ' indicates multi-line textbox

CancelButton 25, 168, 40, 12

OKButton 75, 168, 40, 12

End Dialog

Dim Dlg1 As DialogType

Dlg1.joe = "The quick brown fox jumped over the lazy dog"

' Dialog returns -1 for OK, 0 for Cancel

button = Dialog( Dlg1 )

'MsgBox "button: " & button

If button = 0 Then Exit Sub

MsgBox "TextBox: "& Dlg1.joe

End Sub


Option Buttons and Group Boxes

You can have option buttons to allow the user to choose one option from several. Typically, you would use a group box to surround a group of option buttons, but you can also use a group box to set off a group of check boxes or any related group of controls.

Begin Dialog GroupSample 31,32,185,96,"Option Button and Check Box"

OKButton 28,68,40,14

CancelButton 120,68,40,14

GroupBox 12,8,72,52,"GroupBox",.GroupBox1

GroupBox 100,12,72,48,"GroupBox",.GroupBox2

OptionGroup .OptionGroup1

OptionButton 16,24,54,8,"OptionButton",.OptionButton1

OptionButton 16,40,54,8,"OptionButton",.OptionButton2

CheckBox 108,24,45,8,"CheckBox",.CheckBox1

CheckBox 108,40,45,8,"CheckBox",.CheckBox2

End Dialog

Dim Dlg1 As GroupSample

Button = Dialog (Dlg1)

End Sub

Sub Main

Begin Dialog DialogName1 60, 60, 160, 70

TEXT 10, 10, 28, 12, "Name:"

TEXTBOX 42, 10, 108, 12, .nameStr

TEXTBOX 42, 24, 108, 12, .descStr

CHECKBOX 42, 38, 48, 12, "&CHECKME", .checkInt

OKBUTTON 42, 54, 40, 12

End Dialog

Dim Dlg1 As DialogName1

Dialog Dlg1

MsgBox Dlg1.nameStr

MsgBox Dlg1.descStr

MsgBox Dlg1.checkInt

End Sub


The Dialog Function

Cypress Enable supports the dialog function. This function is a user-defined function that can be called while a custom dialog box is displayed. The dialog function makes nested dialog boxes possible and receives messages from the dialog box while it is still active.

When the function dialog() is called in Enable it displays the dialog box, and calls the dialog function for that dialog. Enable calls the dialog function to see if there are any commands to execute. Typical commands that might be used are disabling or hiding a control. By default all dialog box controls are enabled. If you want a control to be hidden you must explicitly make it disabled during initialization. After initialization Enable displays the dialog box. When an action is taken by the user Enable calls the dialog function and passes values to the function that indicate the kind of action to take and the control that was acted upon.

The dialog box and its function are connected in the dialog definition. A “function name” argument is added to the Begin Dialog instruction, and matches the name of the dialog function located in your Enable program.

Begin Dialog UserDialog1 60,60, 260, 188, "3", .Enable


The Dialog Box Controls

A dialog function needs an identifier for each dialog box control that it acts on. The dialog function uses string identifiers. String identifiers are the same as the identifiers used in the dialog record.

CheckBox 8, 56, 203, 16, "Check to display controls",. Chk1

The control’s identifier and label are different. An identifier begins with a period and is the last parameter in a dialog box control instruction. In the sample code above “Check to display controls” is the label and .chk1 is the identifier.


The Dialog Function Syntax

The syntax for the dialog function is as follows:

Function FunctionName( ControlID$, Action%, SuppValue%)

Statement Block

FunctionName = ReturnValue

End Function

All parameters in the dialog function are required.

A dialog function returns a value when the user chooses a command button. Enable acts on the value returned. The default is to return 0 (zero) and close the dialog box. If a non zero is assigned the dialog box remains open. By keeping the dialog box open, the dialog function allows the user to do more than one command from the same dialog box. Dialog examples ship as part of the sample .bas programs and can be found in your install directory.

More:

ControlID$

Action

Supp Value


ControlID$

ControlID$ Receives the identifier of the dialog box control


Action

Action Identifies the action that calls the dialog function. There are six possibilities, Enable supports the first 4.

Action 1 The value passed before the dialog becomes visible

Action 2 The value passed when an action is taken ( i.e. a button is pushed, checkbox is checked etc...) The controlID$ is the same as the identifier for the control that was chosen

Action 3 Corresponds to a change in a text box or combo box. This value is passed when a control loses the focus (for example, when the user presses the TAB key to move to a different control) or after the user clicks an item in the list of a combo box (an Action value of 2 is passed first). Note that if the contents of the text box or combo box do not change, an Action value of 3 is not passed. When Action is 3, ControlID$ corresponds to the identifier for the text box or combo box whose contents were changed.

Action 4 Corresponds to a change of focus. When Action is 4, ControlID$ corresponds to the identifier of the control that is gaining the focus. SuppValue corresponds to the numeric identifier for the control that lost the focus. A Dialog function cannot display a message box or dialog box in response to an Action value of 4


Supp Value

SuppValue receives supplemental information about a change in a dialog box control. The information SuppValue receives depends on which control calls the dialog function. The following SuppValue values are passed when Action is 2 or 3.

Control | SuppValue passed
ListBox, DropListBox, or ComboBox | Number of the item selected where 0 (zero) is the first item in the list box, 1 is the second item, and so on.
CheckBox | 1 if selected, 0 (zero) if cleared.
OptionButton | Number of the option button selected, where 0 (zero) is the first option button within a group, 1 is the second option button, and so on.
TextBox | Number of characters in the text box.
ComboBox | If Action is 3, number of characters in the combo box.
CommandButton | A value identifying the button chosen. This value is not often used, since the same information is available from the ControlID$ value.


Statements and Functions Used in Dialog Functions

Statement or Function | Action or Result
DlgControlId | Returns the numeric equivalent of Identifier$, the string identifier for a dialog box control.
DlgEnable, DlgEnable() | The DlgEnable statement is used to enable or disable a dialog box control. When a control is disabled, it is visible in the dialog box, but is dimmed and not functional. DlgEnable() is used to determine whether or not the control is enabled.
DlgFocus, DlgFocus() | The DlgFocus statement is used to set the focus on a dialog box control. (When a dialog box control has the focus, it is highlighted.) DlgFocus() returns the identifier of the control that has the focus.
DlgListBoxArray, DlgListBoxArray() | The DlgListBoxArray statement is used to fill a list box or combo box with the elements of an array. It can be used to change the contents of a list box or combo box while the dialog box is displayed. DlgListBoxArray() returns an item in an array and the number of items in the array.
DlgSetPicture | The DlgSetPicture statement is used in a dialog function to set the graphic displayed by a picture control.
DlgText, DlgText | The DlgText statement is used to set the text or text label for a dialog box control. TheDlgText() function returns the label of a control.
DlgValue, DlgValue() | The DlgValue statement is used to select or clear a dialog box control. Then DlgValue() function returns the setting of a control.
DlgVisible, DlgVisible() | The DlgVisible statement is used to hide or show a dialog box control. The DlgVisible() function is used to determine whether a control is visible or hidden.

More:

DlgControlId Function

DlgFocus Statement, DlgFocus() Function

DlgListBoxArray, DlgListBoxArray()

DlgSetPicture

DlgValue, DlgValue()


DlgControlId Function

DlgControlId(Identifier)

Used within a dialog function to return the numeric identifier for the dialog box control specified by Identifier, the string identifier of the dialog box control. Numeric identifiers are numbers, starting at 0 (zero) , that correspond to the positions of the dialog box control instructions within a dialog box definition. For example, consider the following instruction in a dialog box definition:

CheckBox 90, 50, 30, 12, “&Update”, .MyCheckBox

The instruction DlgControlId(“MyCheckBox”) returns 0 (zero) if the CheckBox instruction is the first instruction in the dialog box definition, 1 if it is the second, and so on.

In most cases, your dialog functions will perform actions based on the string identifier of the control that was selected.


DlgFocus Statement, DlgFocus() Function

DlgFocus Identifier

DlgFocus()

The DlgFocus statement is used within a dialog function to set the focus on the dialog box control identified by Identifier while the dialog box is displayed. When a dialog box control has the focus, it is active and responds to keyboard input. For example, if a text box has the focus, any text you type appears in that text box.

The DlgFocus() function returns the string identifier for the dialog box control that currently has the focus.

More:

Example


Example

This example sets the focus on the control “MyControl1” when the dialog box is initially displayed. (The main subroutine that contains the dialog box definition is not shown.)

Function MyDlgFunction( identifier, action, suppvalue)

Select Case action

Case 1 ‘ The dialog box is displayed

DlgFocus “MyControl1”

Case 2

‘ Statements that perform actions based on which control is selected

End Select

End Function


DlgListBoxArray, DlgListBoxArray()

DlgListBoxArray Identifier, ArrayVariable()

DlgListBoxArray(Identifier, ArrayVariable())

The DlgListBoxArray statement is used within a dialog function to fill a ListBox, DropListBox, or ComboBox with the contents of ArrayVariable() while the dialog box is displayed.

The DlgListBoxArray() function fills ArrayVariable() with the contents of the ListBox, DropListBox, or ComboBox specified by Identifier and returns the number of entries in the ListBox, DropListBox, or ComboBox. The ArrayVariable() parameter is optional (and currently not implemented) with the DlgListBoxArray() function; if ArrayVariable() is omitted, DlgListBoxArray() returns the number of entries in the specified control.


DlgSetPicture

DlgSetPicture Identifier, PictureName

The DlgSetPicture function is used to set the graphic displayed by a picture control in a dialog.

The Identifier is a string or numeric representing the dialog box. The PictureName is a string that identifies the picture to be displayed.


DlgValue, DlgValue()

DlgValue Identifier, Value

DlgValue(Identifier)

The DlgValue statement is used in a dialog function to select or clear a dialog box control by setting the numeric value associated with the control specified by Identifier. For example, DlgValue “MyCheckBox”, 1 selects a check box, DlgValue “MyCHeckBox”, 0 clears a check box, and DlgValue “MyCheckBox”, -1 fills the check box with gray. An error occurs if Identifier specifies a dialog box control such as a text box or an option button that cannot be set with a numeric value.

The following dialog function uses a Select Case control structure to check the value of Action. The SuppValue is ignored in this function.

'This sample file outlines dialog capabilities, including nesting dialog boxes.

Sub Main

Begin Dialog UserDialog1 60,60, 260, 188, "3", .Enable

Text 8,10,73,13, "Text Label:"

TextBox 8, 26, 160, 18, .FText

CheckBox 8, 56, 203, 16, "Check to display controls",. Chk1

GroupBox 8, 79, 230, 70, "This is a group box:", .Group

CheckBox 18,100,189,16, "Check to change button text", .Chk2

PushButton 18, 118, 159, 16, "File History", .History

OKButton 177, 8, 58, 21

CancelButton 177, 32, 58, 21

End Dialog

Dim Dlg1 As UserDialog1

x = Dialog( Dlg1 )

End Sub

Function Enable( ControlID$, Action%, SuppValue%)

Begin Dialog UserDialog2 160,160, 260, 188, "3", .Enable

Text 8,10,73,13, "New dialog Label:"

TextBox 8, 26, 160, 18, .FText

CheckBox 8, 56, 203, 16, "New CheckBox",. ch1

CheckBox 18,100,189,16, "Additional CheckBox", .ch2

PushButton 18, 118, 159, 16, "Push Button", .but1

OKButton 177, 8, 58, 21

CancelButton 177, 32, 58, 21

End Dialog

Dim Dlg2 As UserDialog2

Dlg2.FText = "Your default string goes here"

Select Case Action%

Case 1

DlgEnable "Group", 0

DlgVisible "Chk2", 0

DlgVisible "History", 0

Case 2

If ControlID$ = "Chk1" Then

DlgEnable "Group"

DlgVisible "Chk2"

DlgVisible "History"

End If

If ControlID$ = "Chk2" Then

DlgText "History", "Push to display nested dialog"

End If

If ControlID$ = "History" Then

Enable =1

x = Dialog( Dlg2 )

End If

Case Else

End Select

Enable =1

End Function


OLE Automation

What is OLE Automation?

OLE Automation is a standard, promoted by Microsoft, that applications use to expose their OLE objects to development tools, Enable Basic, and containers that support OLE Automation. A spreadsheet application may expose a worksheet, chart, cell, or range of cells all as different types of objects. A word processor might expose objects such as application, paragraph, sentence, bookmark, or selection.

When an application supports OLE Automation, the objects it exposes can be accessed by Enable Basic. You can use Enable Basic to manipulate these objects by invoking methods on the object, or by getting and setting the object’s properties, just as you would with the objects in Enable Basic. For example, if you created an OLE Automation object named MyObj, you might write code such as this to manipulate the object:

Sub Main

Dim MyObj As Object

Set MyObj = CreateObject ("Word.Basic")

MyObj.FileNewDefault

MyObj.Insert "Hello, world."

MyObj.Bold 1

End Sub

The following syntax is supported for the GetObject function:

Set MyObj = GetObject ("", class)

Where class is the parameter representing the class of the object to retrieve. The first parameter at this time must be an empty string.

The properties and methods an object supports are defined by the application that created the object. See the application's documentation for details on the properties and methods it supports.


What is an OLE Object?

An OLE Automation Object is an instance of a class within your application that you wish to manipulate programmatically, such as with Cypress Enable. These may be new classes whose sole purpose is to collect and expose data and functions in a way that makes sense to your customers.

The object becomes programmable when you expose those member functions. OLE Automation defines two types of members that you may expose for an object:

Methods are member functions that perform an action on an object. For example, a Document object might provide a Save method.

Properties are member function pairs that set or return information about the state of an object. For example, a Drawing object might have a style property.

For example, Microsoft suggests the following objects could be exposed by implementing the listed methods and properties for each object:

OLE Automation object |  | Methods | Properties
 | Application | Help | ActiveDocument
 |  | Quit | Application
 |  | Add Data | Caption
 |  | Repeat | DefaultFilePath
 |  | Undo | Documents
 |  |  | Height
 |  |  | Name
 |  |  | Parent
 |  |  | Path
 |  |  | Printers
 |  |  | StatusBar
 |  |  | Top
 |  |  | Value
 |  |  | Visible
 |  |  | Width

Document | Activate | Application
 | Close | Author
 | NewWindow | Comments
 | Print | FullName
 | PrintPreview | Keywords
 | RevertToSaved | Name
 | Save | Parent
 | SaveAs | Path
 |  | ReadOnly
 |  | Saved
 |  | Subject
 |  | Title
 |  | Value

To provide access to more than one instance of an object, expose a collection object. A collection object manages other objects. All collection objects support iteration over the objects they manage. For example, Microsoft suggests an application with a multiple document interface (MDI) might expose a Documents collection object with the following methods and properties:

Collection object | Methods | Properties
Documents | Add | Application
 | Close | Count
 | Item | Parent
 | Open |


OLE Fundamentals

Object linking and embedding (OLE) is a technology that allows a programmer of Windows-based applications to create an application that can display data from many different applications, and allows the user to edit that data from within the application in which it was created. In some cases, the user can even edit the data from within their application.

The following terms and concepts are fundamental to understanding OLE.

More:

OLE Object

OLE Automation

Class


OLE Object

An OLE object refers to a discrete unit of data supplied by an OLE application. An application can expose many types of objects. For example a spreadsheet application can expose a worksheet, macro sheet, chart, cell, or range of cells all as different types of objects. You use the OLE control to create linked and embedded objects. When a linked or embedded object is created, it contains the name of the application that supplied the object, its data (or, in the case of a linked object, a reference to the data), and an image of the data.


OLE Automation

Some applications provide objects that support OLE Automation. You can use Enable Basic to programmatically manipulate the data in these objects. Some objects that support OLE Automation also support linking and embedding. You can create an OLE Automation object by using the CreateObject function.


Class

An objects class determines the application that provides the objects data and the type of data the object contains. The class names of some commonly used Microsoft applications include MSGraph, MSDraw, WordDocument, and ExcelWorksheet.


OLE Automation and Microsoft Word Example:

Sub OLEexample()

Dim word As Object

Dim myData As String

myData = 4 * Atn(1) ' Demonstrates Automatic type conversion

Set word = CreateObject("Word.Basic")

Word.AppShow

word.FileNewDefault

word.Insert "The following was computed in Cypress Enable: "

word.Bold 1 ' Show value in boldface

word.Insert myData

word.Bold 0

MsgBox "Done"

End Sub


WIN.INI

The win.ini file contains a special section called [embedding] that contains information about each of three applications that operate as object servers.


The Registration Database.

Starting with Windows 3.1, Each Windows system maintains a registration database file that records details about the DDE and OLE functions supported by the installed applications. The database is stored in file called REG.DAT in the \ WINDOWS directory.


The Registration database

The registration database is a file called REG.DAT. The file is a database that contains information that controls a variety of activities relating to data integration using DDE and OLE. The information contained in the REG.DAT database can be divided into four basic categories.

More:

Associations

Shell Operations

OLE Object Servers

DDE/OLE Automation


Associations.

The table contains information that associates files with specific extensions to particular applications. This is essentially the same function performed by the [extensions] section of the WIN.INI.


Shell Operations.

Windows contains two programs that are refered to as Shell programs. The term Shell refers to a program that organizes basic operating system tasks, like running applications, opening files, and sending files to the printer. Shell programs use list, windows, menus, and dialog boxes to perform these operations. In contrast, command systems like DOS require the entry of explicit command lines to accomplish these tasks


OLE Object Servers.

The registration database maintains a highly structured database of the details needed by programs that operate as object servers. This is by far the most complex task performed by the database. There is no WIN.INI equivalent for this function.


DDE/OLE Automation.

The registration database contains the details and the applications that support various types of DDE/OLE Automation operations.

It is useful to appreciate the difference in structure between the WIN.INI file and the REG.DAT database. WIN.INI is simply a text document. There are no special structures other than headings (simply titles enclosed in brackets) that organize the information. If you want to locate an item in the WIN.INI file, you must search through the file for the specific item you want to locate. The registration database is a tree-like, structured database used for storing information relating to program and file operations, in particular, those that involve the use of DDE or OLE. The tree structure makes it easier to keep the complex set of instructions, needed to implement DDE and OLE operations, organized and accessible by the applications that need to use them. This is not possible when you are working with a text document like WIN.INI. The WIN.INI file records all sorts or information about the Windows system in a simple sequential listing.


Chapter 4: Scripting Language Overview

Current Help System: PC-DMIS BASIC (View Core Help)

Scripting Language Overview

More:

Introduction

Quick Reference of Functions and Statements Available


Introduction

This section contains quick reference charts and tables on the following:

  • Type/Functions/Statements

  • Data Types

  • Operators

  • Operator Precedence

  • Functions, Statements, Reserved Words – Quick Reference


Quick Reference of Functions and Statements Available

More:

Type/Functions/Statements

Data Types

Operators

Operator Precedence

Functions, Statements, Reserved words - Quick Reference


Type/Functions/Statements

Flow of Control

Goto, End, OnError, Stop, Do...Loop, Exit Loop, For...Next, Exit For, If..Then..Else...End If, Return, Stop, While...Wend, Select Case

Converting

Chr, Hex, Oct, Str, CDbl, CInt, Clng, CSng, CStr, CVar, CVDate, Asc, Val, Date, DateSerial, DateValue, Format, Fix, Int, Day, Weekday, Month, Year, Hour, Minute, Second, TimeSerial, TimeValue

Dialog

Text, TextBox, ListBox, DropList, ComboBox, CheckBox, OKButton, BeginDialog, EndDialog, OptionGroup, OKButton, CancelButton, PushButton, Picture, GroupBox, Multi-line TextBox,

File I/O

FileCopy, ChDir, ChDrive, CurDir, CurDir, MkDir,RmDir, Open, Close, Print #, Kill, FreeFile, LOF, FileLen, Seek, EOF, Write #, Input, Line Input, Dir, Name, GetAttr, SetAttr, Dir, Get, Put

Math

Exp, Log, Sqr, Rnd, Abs, Sgn, Atn, Cos, Sin, Tan, Int, Fix

Procedures

Call, Declare, Function, End Function, Sub, End Sub, Exit, Global

Strings

Let, Len, InStr, Left, Mid, Asc, Chr, Right, LCase, Ucase, InStr, LTrim, RTrim, Trim, Option Compare, Len, Space, String, StrComp Format,

Variables and Constants

Dim, IsNull, IsNumeric,VarType, Const, IsDate, IsEmpty, IsNull, Option Explicit, Global, Static,

Error Trapping

On Error, Resume

Date/Time

Date, Now, Time, Timer

DDE

DDEInitiate, DDEExecute, DDETerminate

Arrays

Option Base, Option Explicit, Static, Dim, Global, Lbound, Ubound, Erase, ReDim

Miscellaneous

SendKeys, AppActivate, Shell, Beep, Rem, CreateObject, GetObject, Randomize


Data Types

Variable | Type Specifier | Usage
String | $ | Dim Str_Var As String
Integer | % | Dim Int_Var As Integer
Long | & | Dim Long_Var As Long
Single | ! | Dim Sing_Var As Single
Double | # | Dim Dbl_Var As Double
Variant |  | Dim X As Any
Boolean |  | Dim X As Boolean
Byte |  | Dim X As Byte
Object |  | Dim X As Object
Currency |  | (Not currently supported)


Operators

More:

Arithmetic Operators

Relational Operators

Logical Operators


Arithmetic Operators

Operator | Function | Usage
^ | Exponentiation | x = y^2
- | Negation | x = -2
* | Multiplication | x% = 2 * 3
/ | division | x = 10/2
Mod | Modulo | x = y Mod z
+ | Addition | x = 2 + 3
- | Subtraction | x = 6 - 4

*Arithmetic operators follow mathematical rules of precedence

* '+' or '&' can be used for string concatenation.


Relational Operators

Operator | Function | Usage
< | Less than | x < Y
<= | Less than or equal to | x <= Y
= | Equals | x = Y
>= | Greater than or equal to | x >= Y
> | Greater than | x > Y
<> | Not equal to | x <> Y


Logical Operators

Operator | Function | Usage
Not | Logical Negation | If Not (x)
And | Logical And | If (x> y) And (x < Z)
Or | Logical Or | if (x = y) Or (x = z)


Operator Precedence

Operator | Description | Order
() | Parenthesis | Highest
^ | Exponentiation |
- | Unary minus |
/,* | Division / Multplication |
mod | Modulo |
+, -, & | Addition, subtraction, concatenation |
=, <>, <, >,<=,>= | Relational |
not | Logical negation |
and | Logical conjunction |
or | Logical disjunction |
Xor | Logical exclusion |
Eqv | Logical Equivalence |
Imp | Logical Implication | Lowest


Functions, Statements, Reserved words - Quick Reference

Abs, Access, Alias, And Any

App, AppActivate, Asc, Atn, As

Base, Beep, Begin, Binary, ByVal

Call, Case, ChDir, ChDrive, Choose, Chr, Const, Cos, CurDir, CDbl, CInt, CLng, CSng, CStr, CVar, CVDate,Close, CreateObject

Date, Day, Declare, Dim, Dir, Do...Loop,Dialog, DDEInitiate

DDEExecute, DateSerial, DateValue, Double

Else, ElseIf, End, EndIf, EOF, Eqv, Erase, Err, Error

Exit, Exp, Explicit

False, FileCopy, FileLen, Fix, For,

For...Next, Format, Function

Get, GetAttr, GoTo, Global, Get Object

Hex, Hour

If...Then...Else...[End If], Imp, Input, InputBox, InStr, Int, Integer, Is, IsEmpty, IsNull, IsNumeric, IsDate

Kill

LBound, LCase, Left, Len, Let, LOF,Log, Long, Loop, LTrim Line Input

Mid,Minute, MkDir, Mod, Month, MsgBox

Name, Next, Not, Now

Oct,On, Open, OKButton,Object, Option, Optional, Or, On Error

Print, Print #, Private, Put

Randomize, Rem, ReDim, RmDir, Rnd, Return, Rtrim

Seek, SendKeys, Set, SetAttr, Second, Select, Shell, Sin, Sqr, Stop,Str, Sng, Single, Space, Static, Step, Stop, Str, String, Sub, StringComp

Tan,Text, TextBox, Time, Timer, TimeSerial, TimeVale, Then, Type, Trim, True, To, Type

UBound, UCase, Ucase, Until

Val, Variant, VarType

Write #, While, Weekday, Wend, With

Xor

Year


Chapter 5: Language Reference A to Z

Current Help System: PC-DMIS BASIC (View Core Help)

–

Language Reference A to Z

More:

Introduction

Abs Function

AppActivate Statement

Asc Function

Atn Function

Beep Statement

Call Statement

CBool Function

CDate Function

CDbl Function

ChDir Statement

ChDrive Statement

CheckBox

Choose Function

Chr Function

CInt Function

CLng Function

Close Statement

Const Statement

Cos Function

CreateObject Function

CSng Function

CStr Function

CurDir Function

CVar Function

Date Function

DateSerial Function

DateValue Function

Day Function

Declare Statement

Dialog, Dialog Function

Dim Statement

Dir Function

DlgEnable Statement

DlgText Statement

DlgVisible Statement

Do...Loop Statement

End Statement

EOF Function

Erase Statement

Exit Statement

Exp

FileCopy Function

FileLen Function

Fix Function

For each &ldots; Next Statement

For...Next Statement

Format Function

Predefined numeric format names:

Characters for Creating User-Defined Number Formats

Sample Format Number Expressions

FreeFile Function

Function Statement

Get Statement

Get Object Function

Global Statement

GoTo Statement

Hex

Hour Function

HTMLDialog

If...Then...Else Statement

Input # Statement

Input Function

InputBox Function

InStr

Int Function

IsArray Function

IsDate

IsEmpty

IsNull

IsNumeric

IsObject Function

Kill Statement

LBound Function

LCase, Function

Left

Len

Let Statement

Line Input # Statement

LOF

Log

Mid Function

Minute Function

MkDir

Month Function

MsgBox Function MsgBox Statement

Name Statement

Now Function

Oct Function

OKButton

On Error

Defined x Value Descriptions

Open Statement

Option Base Statement

Option Explicit Statement

Print Method

Print # Statement

Randomize Statement

ReDim Statement

Rem Statement

Right Function

RmDir Statement

Rnd Function

Second Function

Seek Function

Seek Statement

Select Case Statement

SendKeys Function

Set Statement

Shell Function

Sin Function

Space Function

Sqr Function

Static Statement

Stop Statement

Str Function

StrComp Function

String Function

Sub Statement

Tan Function

Text Statement

TextBox Statement

Time Function

Timer Event

TimeSerial - Function

TimeValue - Function

Trim, LTrim, RTrim Functions

Type Statement

UBound Function

UCase Function

Val

VarType

Weekday Function

While...Wend Statement

With Statement

Write # - Statement

Year Function


Introduction

This section contains a language reference in alphabetic order of all the Cypress Enable BASIC code you can use in your scripts. Statements and functions in the examples are offset with a boldface font.

Note: Keep in mind that while most of the examples given in this chapter will work fine inside any Visual Basic editor (such as Visual Basic for Excel), there may be some items that only function inside of the BASIC Script Editor that ships with PC-DMIS.

More:

Abs Function

AppActivate Statement

Asc Function

Atn Function

Beep Statement

Call Statement

CBool Function

CDate Function

CDbl Function

ChDir Statement

ChDrive Statement

CheckBox

Choose Function

Chr Function

CInt Function

CLng Function

Close Statement

Const Statement

Cos Function

CreateObject Function

CSng Function

CStr Function

CurDir Function

CVar Function

Date Function

DateSerial Function

DateValue Function

Day Function

Declare Statement

Dialog, Dialog Function

Dim Statement

Dir Function

DlgEnable Statement

DlgText Statement

DlgVisible Statement

Do...Loop Statement

End Statement

EOF Function

Erase Statement

Exit Statement

Exp

FileCopy Function

FileLen Function

Fix Function

For each … Next Statement

For...Next Statement

Format Function

Predefined numeric format names:

Characters for Creating User-Defined Number Formats

Sample Format Number Expressions

FreeFile Function

Function Statement

Get Statement

Get Object Function

Global Statement

GoTo Statement

Hex

Hour Function

HTMLDialog

If...Then...Else Statement

Input # Statement

Input Function

InputBox Function

InStr

Int Function

IsArray Function

IsDate

IsEmpty

IsNull

IsNumeric

IsObject Function

Kill Statement

LBound Function

LCase, Function

Left

Len

Let Statement

Line Input # Statement

LOF

Log

Mid Function

Minute Function

MkDir

Month Function

MsgBox Function MsgBox Statement

Name Statement

Now Function

Oct Function

OKButton

On Error

Defined x Value Descriptions

Open Statement

Option Base Statement

Option Explicit Statement

Print Method

Print # Statement

Randomize Statement

ReDim Statement

Rem Statement

Right Function

RmDir Statement

Rnd Function

Second Function

Seek Function

Seek Statement

Select Case Statement

SendKeys Function

Set Statement

Shell Function

Sin Function

Space Function

Sqr Function

Static Statement

Stop Statement

Str Function

StrComp Function

String Function

Sub Statement

Tan Function

Text Statement

TextBox Statement

Time Function

Timer Event

TimeSerial - Function

TimeValue - Function

Trim, LTrim, RTrim Functions

Type Statement

UBound Function

UCase Function

Val

VarType

Weekday Function

While...Wend Statement

With Statement

Write # - Statement

Year Function


Abs Function

Abs (number)

Returns the absolute value of a number.

The data type of the return value is the same as that of the number argument. However, if the number argument is a Variant of VarType (String) and can be converted to a number, the return value will be a Variant of VarType (Double). If the numeric expression results in a Null, _Abs returns a Null.

More:

Example:


Example:

Sub Main

Dim Msg, X, Y

X = InputBox("Enter a Number:")

Y = Abs(X)

Msg = "The number you entered is " & X

Msg = Msg + ". The Absolute value of " & X & " is " & Y

MsgBox Msg 'Display Message.

End Sub


AppActivate Statement

AppActivate “app”

Activates an application.

The parameter app is a string expression and is the name that appears in the title bar of the application window to activate.

Related Topics: Shell, SendKeys

More:

Example:


Example:

Sub Main ()

AppActivate "Microsoft Word"

SendKeys “%F,%N,Cypress Enable”,True

Msg = “Click OK to close Word”

MsgBox Msg

AppActivate “Microsoft Word”

SendKeys “%F,%C,N”, True

End Sub


Asc Function

Asc ( str)

Returns a numeric value that is the ASCII code for the first character in a string.

More:

Example:


Example:

Sub Main ()

Dim I, Msg ' Declare variables.

For I = Asc("A") To Asc("Z") ' From A through Z.

Msg = Msg & Chr(I) ' Create a string.

Next I

MsgBox Msg ' Display results.

End Sub


Atn Function

Atn (rad )

Returns the arc tangent of a number

The argument rad can be any numeric expression. The result is expressed in radians

Related Topics: Cos, Tan, Sin

More:

Example:


Example:

Sub AtnExample ()

Dim Msg, Pi ' Declare variables.

Pi = 4 * Atn(1) ' Calculate Pi.

Msg = "Pi is equal to " & Str(Pi)

MsgBox Msg ' Display results.

End Sub


Beep Statement

Beep

Sounds a tone through the computer's speaker. The frequency and duration of the beep depends on hardware, which may vary among computers.

More:

Example:


Example:

Sub BeepExample ()

Dim Answer, Msg ' Declare variables.

Do

Answer = InputBox("Enter a value from 1 to 3.")

If Answer >= 1 And Answer <= 3 Then ' Check range.

Exit Do ' Exit Do...Loop.

Else

Beep ' Beep if not in range.

End If

Loop

MsgBox "You entered a value in the proper range."

End Sub


Call Statement

Call funcname [(parameter(s)]

or

[parameter(s)]

Activates an Enable Subroutine called name or a DLL function with the name name. The first parameter is the name of the function or subroutine to call, and the second is the list of arguments to pass to the called function or subroutine.

You are never required to use the Call statement when calling an Enable subroutine or a DLL function. Parentheses must be used in the argument list if the Call statement is being used.

More:

Example:


Example:

Sub Main ()

Call Beep

MsgBox "Returns a Beep"

End Sub


CBool Function

CBool (expression)

Converts expressions from one data type to a boolean. The parameter expression must be a valid string or numeric expression.

More:

Example:


Example:

Sub Main

Dim A, B, Check

A = 5: B = 5

Check = CBool(A = B)

Print Check

A = 0

Check = CBool(A)

Print Check

End Sub


CDate Function

CVDate (expression)

Converts any valid expression to a Date variable with a vartype of 7.

The parameter expression must be a valid string or numeric date expression and can represent a date from January 1, 30 through December 31, 9999.

More:

Example:


Example:

Sub Main

Dim MyDate, MDate, MTime, MSTime

MybDate = "May 29, 1959" ' Define date.

MDate = CDate(MybDate) ' Convert to Date data type.

MTime = "10:32:27 PM" ' Define time.

MSTime = CDate(MTime) ' Convert to Date data type.

Print MDate

Print MSTime

End Sub


CDbl Function

CDbl (expression)

Converts expressions from one data type to a double. The parameter expression must be a valid string or numeric expression.

More:

Example:


Example:

Sub Main ()

Dim y As Integer

y = 25555 'the integer expression only allows for 5 digits

If VarType(y) = 2 Then

Print y

x = CDbl(y) 'Converts the integer value of y to a double value in x

x = x * 100000 'y is now 10 digits in the form of x '

Print x

End If

End Sub


ChDir Statement

ChDir pathname

Changes the default directory

Pathname: [drive:] [ \ ] dir[\dir]...

The parameter pathname is a string limited to fewer then 128 characters. The drive parameter is optional. The dir parameter is a directory name. ChDir changes the default directory on the current drive, if the drive is omitted.

Related Topics: CurDir, CurDir$, ChDrive, Dir, Dir$, MkDir, RmDir

More:

Example:


Example:

Sub Main ()

Dim Answer, Msg, NL ' Declare variables.

NL = Chr(10) ' Define newline.

CurPath = CurDir() ' Get current path.

ChDir "\"

Msg = "The current directory has been changed to "

Msg = Msg & CurDir() & NL & NL & "Press OK to change back "

Msg = Msg & "to your previous default directory."

Answer = MsgBox(Msg) ' Get user response.

ChDir CurPath ' Change back to user default.

Msg = "Directory changed back to " & CurPath & "."

MsgBox Msg ' Display results.

End Sub


ChDrive Statement

ChDrive drivename

Changes the default drive

The parameter drivename is a string and must correspond to a an existing drive. If drivename contains more than one letter, only the first character is used.

More:

Example:


Example:

Sub Main ()

Dim Msg, NL ' Declare variables.

NL = Chr(10) ' Define newline.

CurPath = CurDir() ' Get current path.

ChDir "\"

ChDrive "C:"

Msg = "The current directory has been changed to "

Msg = Msg & CurDir() & NL & NL & "Press OK to change back "

Msg = Msg & "to your previous default directory."

MsgBox Msg ' Get user response.

ChDir CurPath ' Change back to user default.

Msg = "Directory changed back to " & CurPath & "."

MsgBox Msg ' Display results.

End Sub

Related Topics: ChDir, CurDir, CurDir$, MkDir, RmDir


CheckBox

CheckBox starting x position, starting y position, width, height

For selecting one or more in a series of choices

More:

Example:


Example:

Sub Main ()

Begin Dialog DialogName1 60, 70, 160, 50, "ASC - Hello"

CHECKBOX 42, 10, 48, 12, "&CHECKME", .checkInt

OKBUTTON 42, 24, 40, 12

End Dialog

Dim Dlg1 As DialogName1

Dialog Dlg1

If Dlg1.checkInt = 0 Then

Q = "didn't check the box."

Else

Q = "checked the box."

End If

MsgBox "You " & Q

End Sub


Choose Function

Choose(number, choice1, [choice2,] [choice3,]… )

Returns a value from a list of arguments

Choose will return a null value if number is less than one or greater than the number of choices in the list. If number is not an integer it will be rounded to the nearest integer.

More:

Example:


Example:

Sub Main

number = 2

GetChoice = Choose(number, "Choice1", "Choice2", "Choice3")

Print GetChoice

End Sub


Chr Function

Chr(int )

Returns a one-character string whose ASCII number is the argument

Chr returns a String

More:

Example:


Example:

Sub ChrExample ()

Dim X, Y, Msg, NL

NL = Chr(10)

For X = 1 to 2

For Y = Asc("A") To Asc("Z")

Msg = Msg & Chr(Y)

Next Y

Msg = Msg & NL

Next X

MsgBox Msg

End Sub


CInt Function

CInt (expression)

Converts any valid expression to an integer.

More:

Example:


Example:

Sub Main ()

Dim y As Long

y = 25

If VarType(y) = 2 Then

Print y

x = CInt(y) 'Converts the long value of y to an integer value in x

Print x

End If

End Sub


CLng Function

CLng (expression)

Converts any valid expression into a long.

More:

Example:


Example:

Sub Main ()

Dim y As Integer

y = 25000 'the integer expression can only hold five digits

If VarType(y) = 2 Then

Print y

x = CLng(y) 'Converts the integer value of x to a long value in x

x = x * 10000 'y is now ten digits in the form of x

Print x

End If

End Sub


Close Statement

Close [[#filenumber] [, [#]filenumber],,,

The Close Statement takes one argument filenumber. Filenumber is the number used with the Open Statement to open the file. If the Close Statement is used without any arguments it closes all open files.

More:

Example:


Example:

Sub Main

Open "c:\test.txt" For Input As #1

Do While Not EOF(1)

MyStr = Input(10, #1)

MsgBox MyStr

Loop

Close #1

End Sub

Sub Make3Files ()

Dim I, FNum, FName ' Declare variables.

For I = 1 To 3

FNum = FreeFile ' Determine next file number.

FName = "TEST" & FNum

Open FName For Output As FNum ' Open file.

Print #I, "This is test #" & I ' Write string to file.

Print #I, "Here is another "; "line"; I

Next I

Close ' Close all files.

End Sub


Const Statement

Const name = expression

Assigns a symbolic name to a constant value.

A constant must be defined before it is used.

The definition of a Const in Cypress Enable outside the procedure or at the module level is a global. The syntax Global Const and Const are used below outside the module level are identical.

A type declaration character may be used however if none is used Enable will automatically assign one of the following data types to the constant, long (if it is a long or integer), Double (if a decimal place is present), or a String ( if it is a string).

More:

Example:


Example:

Sub Main ()

Global Const Height = 14.4357 '

Const PI = 3.14159 'Global to all procedures in a module

Begin Dialog DialogName1 60, 60, 160,70, "ASC - Hello"

TEXT 10, 10, 100, 20, "Please fill in the radius of circle x"

TEXT 10, 40, 28, 12, "Radius"

TEXTBOX 42, 40, 28, 12, .Radius

OKBUTTON 42, 54,40, 12

End Dialog

Dim Dlg1 As DialogName1

Dialog Dlg1

CylArea = Height * (Dlg1.Radius * Dlg1.Radius) * PI

MsgBox "The volume of Cylinder x is " & CylArea

End Sub


Cos Function

Cos (rad)

Returns the cosine of an angle

The argument rad must be expressed in radians and must be a valid numeric expression.Cos will by default return a double unless a single or integer is specified as the return value.

More:

Example:


Example:

Sub Main()

Dim J As Double

Dim I As Single ' Declare variables.

Dim K As Integer

For I =1 To 10 '

Msg = Msg & Cos(I) & ", " 'Cos function call

J=Cos(I)

Print J

K=Cos(I)

Print K

Next I

MsgBox Msg ' Display results.

MsgBox Msg1

End Sub


CreateObject Function

CreateObject (class)

Creates an OLE automation object.


CreateObject Example

Sub Command1_Click ()

Dim word6 As object

Set word6 = CreateObject("Word.Basic")

word6.FileNewDefault

word6.InsertPara

word6.Insert "Attn:"

word6.InsertPara

word6.InsertPara

word6.InsertPara

word6.Insert " Vender Name: "

word6.Bold 1

name = "Some Body"

word6.Insert name

word6.Bold 0

word6.InsertPara

word6.Insert " Vender Address:"

word6.InsertPara

word6.Insert " Vender Product:"

word6.InsertPara

word6.InsertPara

word6.Insert "Dear Vender:"

word6.InsertPara

word6.InsertPara

word6.Insert "The letter you are reading was created with Cypress Enable."

word6.Insert " Using OLE Automation Cypress Enable can call any other OLE _ enabled "

word6.Insert "application. Enable is a Basic Scripting Language for _ applications"

word6.InsertPara

word6.InsertPara

word6.Insert " Product Name: Cypress Enable"

word6.InsertPara

word6.Insert " Company Name: Cypress Software Inc."

word6.InsertPara

word6.InsertPara

MsgBox "You have just called Word 6.0 using OLE"

End Sub

Vender Name: Client Name

Vender Address:

Vender Product:

Dear Vender:

The letter you are reading was created with Cypress Enable.Using OLE Automation Cypress Enable can call any other OLE enabled application. Enable is a Basic Scripting Language for applications

Product Name: Cypress Enable

Company Name: Cypress Software Inc.


CSng Function

CSng (expression)

Converts any valid expression to a Single.

More:

Example:


Example:

Sub Main ()

Dim y As Integer

y = 25

If VarType(y) = 2 Then

Print y

x = CSng(y) 'Converts the integer value of y to a single value in x

Print x

End If

End Sub


CStr Function

CStr(expression)

Converts any valid expression to a String.

More:

Example:


Example:

Sub Main

Dim Y As Integer

Y = 25

Print Y

If VarType(Y) = 2 Then

X = CStr(Y) 'converts Y To a Str

X = X + "hello" 'It is now possible to combine Y with strings

Print X

End If

End Sub


CurDir Function

CurDir (drive)

Returns the current path for the specified drive

CurDir returns a Variant; CurDir$ returns a String.

More:

Example:


Example:

'Declare Function CurDir Lib "NewFuns.dll" () As String

Sub Form_Click ()

Dim Msg, NL ' Declare variables.

NL = Chr(10) ' Define newline.

Msg = "The current directory is: "

Msg = Msg & NL & CurDir()

MsgBox Msg ' Display message.

End Sub


CVar Function

CVar (expression)

Converts any valid expression to a Variant.

More:

Example:


Example:

Sub Main()

Dim MyInt As Integer

MyInt = 4534

Print MyInt

MyVar = CVar(MyInt & "0.23") 'makes MyInt a Variant + 0.32

Print MyVar

End Sub


Date Function

Date, Date()

Returns the current system date

Date returns a Variant of VarType 8 (String) containing a date.

More:

Example:


Example:

' Format Function Example

' This example shows various uses of the Format function to format values

' using both named and user-defined formats. For the date separator (/),

' time separator (:), and AM/ PM literal, the actual formatted output

' displayed by your system depends on the locale settings on which the code

' is running. When times and dates are displayed in the development

' environment, the short time and short date formats of the code locale

' are used. When displayed by running code, the short time and short date

' formats of the system locale are used, which may differ from the code

' locale. For this example, English/United States is assumed.

' MyTime and MyDate are displayed in the development environment using

' current system short time and short date settings.

Sub Main

x = Date()

Print Date

Print x

Print “VarType: “ & VarType(Date)

MyTime = "08:04:23 PM"

MyDate = "03/03/95"

MyDate = "January 27, 1993"

SysDate = Date

MsgBox Sysdate,0,"System Date"

MsgBox Now,0,"Now"

MsgBox MyTime,0,"MyTime"

MsgBox Second( MyTime ) & " Seconds"

MsgBox Minute( MyTime ) & " Minutes"

MsgBox Hour( MyTime ) & " Hours"

MsgBox Day( MyDate ) & " Days"

MsgBox Month( MyDate ) & " Months"

MsgBox Year( MyDate ) & " Years"

' Returns current system time in the system-defined long time format.

MsgBox Format(Time, "Short Time") & " Short Time"

MsgBox Format(Time, "Long Time") & "Long Time"

' Returns current system date in the system-defined long date format.

MsgBox Format(Date, "Short Date") & " Short Date"

MsgBox Format(Date, "Long Date") & " Long Date"

MyDate = "30 December 91" ' use of European date

print Mydate

MsgBox MyDate,0,"MyDate International..."

MsgBox Day(MyDate),0,"day"

MsgBox Month(MyDate),0,"month"

MsgBox Year(MyDate),0,"year"

MyDate = "30-Dec-91" ' another of European date usage

print Mydate

MsgBox MyDate,0,"MyDate International..."

MsgBox Day(MyDate),0,"day"

MsgBox Month(MyDate),0," month"

MsgBox Year(MyDate),0,"year"

MsgBox Format("This is it", ">") ' Returns "THIS IS IT".

End Sub


DateSerial Function

DateSerial (year, month,day)

Returns a variant (Date) corresponding to the year, month and day that were passed in. All three parameters for the DateSerial Function are required and must be valid.

Related Topics: DateValue, TimeSerial, TimeValue

More:

Example:


Example:

Sub Main

Dim MDate

MDate = DateSerial(1959, 5, 29)

Print MDate

End Sub


DateValue Function

DateValue(dateexpression)

Returns a variant (Date) corresponding to the string date expression that was passed in. dateexpression can be a string or any expression that can represent a date, time or both a date and a time.

Related Topics: DateSerial, TimeSerial, TimeValue

More:

Example:


Example:

Sub Main()

Dim v As Variant

Dim d As Double

d = Now

Print d

v = DateValue("1959/05/29")

MsgBox (VarType(v))

MsgBox (v)

End Sub


Day Function

Day(dateexpression)

Returns a variant date corresponding to the string date expression that was passed in. dateexpression can be a string or any expression that can represent a date.

Related Topics: Month, Weekday, Hour, Second

More:

Example:


Example:

Sub Main

Dim MDate, MDay

MDate = #May 29, 1959#

MDay = Day(MDate)

Print "The Day listed is the " & MDay

End Sub


Declare Statement

Declare Sub procedurename Lib Libname$ [Alias aliasname$][(argument list)]

Declare Function procedurename Lib Libname$ [Alias aliasname$] [(argument list)][As Type]

  • The Declare statement makes a reference to an external procedure in a Dynamic Link Library (DLL).

  • The procedurename parameter is the name of the function or subroutine being called.

  • The Libname parameter is the name of the DLL that contains the procedure.

  • The optional Alias aliasname clause is used to supply the procedure name in the DLL if different from the name specified on the procedure parameter. When the optional argument list needs to be passed the format is as follows:

([ByVal] variable [As type] [,ByVal] variable [As type] ]…])

  • The optional ByVal parameter specifies that the variable is [passed by value instead of by reference (see “ByRef and ByVal” in this manual). The optional As type parameter is used to specify the data type. Valid types are String, Integer, Double, Long, and Varaint (see “Variable Types” in this manual).

If a procedure has no arguments, use double parentheses () only to assure that no arguments are passed. For example:

Declare Sub OntTime Lib “Check” ()

Cypress Enable extentions to the declare statement. The following syntax is not supported by Microsoft Visual Basic.

Declare Function procedurename App [Alias aliasname$] [(argument list)][As Type]

This form of the Declare statement makes a reference to a function located in the executable file located in the application where Enable is embedded.

Related Topics: Call

More:

Example:


Example:

Declare Function GetFocus Lib "User" () As Integer

Declare Function GetWindowText Lib "User" (ByVal hWnd%, ByVal Mess$, ByVal cbMax%) As _ Integer

Sub Main

Dim hWindow%

Dim str1 As String *51

Dim str2 As String * 25

hWindow% = GetFocus()

print "GetWindowText returned: ", GetWindowText( hWindow%, str1,51 )

print "GetWindowText2 returned: ", GetWindowText( hWindow%, str2, 25)

print str1

print str2

End Sub


Dialog, Dialog Function

Dialog(DialogRecord)

Returns a value corresponding to the button the user chooses.

The Dialog() function is used to display the dialog box specified by DialogRecord . DialogRecord is the name of the dialog and must be defined in a preceeding Dim statement.

The return value or button:

-1 = OK button

0 = Cancel button

> 0 A command button where 1 is the first PushButton in the definition of the dialog and 2 is the second and so on.

More:

Example:


Example:

' This sample shows all of the dialog controls on one dialog and how to

' vary the response based on which PushButton was pressed.

Sub Main ()

Dim MyList$(2)

MyList(0) = "Banana"

MyList(1) = "Orange"

MyList(2) = "Apple"

Begin Dialog DialogName1 60, 60, 240, 184, "Test Dialog"

Text 10, 10, 28, 12, "Name:"

TextBox 40, 10,50, 12, .joe

ListBox 102, 10, 108, 16, MyList$(), .MyList1

ComboBox 42, 30, 108, 42, MyList$(), .Combo1

DropListBox 42, 76, 108, 36, MyList$(), .DropList1$

OptionGroup .grp1

OptionButton 42, 100, 48, 12, "Option&1"

OptionButton 42, 110, 48, 12, "Option&2"

OptionGroup .grp2

OptionButton 42, 136, 48, 12, "Option&3"

OptionButton 42, 146, 48, 12, "Option&4"

GroupBox 132, 125, 70, 36, "Group"

CheckBox 142, 100, 48, 12, "Check&A", .Check1

CheckBox 142, 110, 48, 12, "Check&B", .Check2

CheckBox 142, 136, 48, 12, "Check&C", .Check3

CheckBox 142, 146, 48, 12, "Check&D", .Check4

CancelButton 42, 168, 40, 12

OKButton 90, 168, 40, 12

PushButton 140, 168, 40, 12, "&Push Me 1"

PushButton 190, 168, 40, 12, "Push &Me 2"

End Dialog

Dim Dlg1 As DialogName1

Dlg1.joe = "Def String"

Dlg1.MyList1 = 1

Dlg1.Combo1 = "Kiwi"

Dlg1.DropList1 = 2

Dlg1.grp2 = 1

' Dialog returns -1 for OK, 0 for Cancel, button # for PushButtons

button = Dialog( Dlg1 )

'MsgBox "button: " & button 'uncomment for button return vale

If button = 0 Then Return

MsgBox "TextBox: "& Dlg1.joe

MsgBox "ListBox: " & Dlg1.MyList1

MsgBox Dlg1.Combo1

MsgBox Dlg1.DropList1

MsgBox "grp1: " & Dlg1.grp1

MsgBox "grp2: " & Dlg1.grp2

Begin Dialog DialogName2 60, 60, 160, 60, "Test Dialog 2"

Text 10, 10, 28, 12, "Name:"

TextBox 42, 10, 108, 12, .fred

OkButton 42, 44, 40, 12

End Dialog

If button = 2 Then

Dim Dlg2 As DialogName2

Dialog Dlg2

MsgBox Dlg2.fred

ElseIf button = 1 Then

Dialog Dlg1

MsgBox Dlg1.Combo1

End If

End Sub


Dim Statement

Dim variablename[(subscripts)][As Type][,name][As Type]]

Allocates storage for and declares the data type of variables and arrays in a module.

The types currently supported are integer, long, single, double and string and variant.

Note: While it may be possible in some cases to use variables without declaring them with the Dim statement first, doing so is not supported in Enable BASIC and may cause problems in your code.

More:

Example:


Example:

Sub Main

Dim x As Long

Dim y As Integer

Dim z As single

Dim a As double

Dim s As String

Dim v As Variant ' This is the same as Dim x or Dim x as any

End Sub


Dir Function

Dir[(path,attributes)]

Returns the first file/directory name that matches the given path and attributes. If you want the next matched item simply use the Dir function again without any arguments.

path is optional and is the pathway to the directory or file. If no path is found the function returns a string of zero-length. You can also use * and ? wild cards. For example d:\temp\*.bmp would match bitmap image files in that directory.

attributes is an optional number representing the sum of all the file or directory attributes. These attributes can be a combination of one or more of these values:

0 Normal (Default)

1 Read-only

2 Hidden

4 System file

8 Volume label

16 Directory or folder

64 File name is an alias

So, to return a hidden system file, you would use a value of 6 (4 for the system file attribute plus 2 for the hidden attribute).Most of the time you will just use 0.

More:

Example:


Example:

'===============================================================

' Example of using the Dir Function

' This script displays all the files In the specified directory.

' Files will be displayed one at a time inside message boxes.

'===============================================================

Sub Main

Dim filename As String

Dim dirname As String

dirname = InputBox("Please type a directory's pathway (be sure to include the ending backslash):","Directory")

filename = Dir(dirname & "*.*",0)

Dim count As Integer

count = 0

While filename <> ""

count = count +1

MsgBox count & " - " & filename

filename = Dir ' find the Next file

Wend

End Sub


DlgEnable Statement

DlgEnable “ControlName”, Value

This statement is used to enable or disable a particular control on a dialog box.

The parameter ControlName is the name of the control on the dialog box. The parameter Value is the value to set it to. 1 = Enable, 0 = Disable. On is equal to 1 in the example below. If the second parameter is omitted the status of the control toggles. The entire example below can be found in the dialog section of this manual and in the example .bas files that ship with Cypress Enable.

Related Topics: DlgVisible, DlgText

More:

Example:


Example:

Function Enable( ControlID$, Action%, SuppValue%)

Begin Dialog UserDialog2 160,160, 260, 188, "3", .Enable

Text 8,10,73,13, "New dialog Label:"

TextBox 8, 26, 160, 18, .FText

CheckBox 8, 56, 203, 16, "New CheckBox",. ch1

CheckBox 18,100,189,16, "Additional CheckBox", .ch2

PushButton 18, 118, 159, 16, "Push Button", .but1

OKButton 177, 8, 58, 21

CancelButton 177, 32, 58, 21

End Dialog

Dim Dlg2 As UserDialog2

Dlg2.FText = "Your default string goes here"

Select Case Action%

Case 1

DlgEnable "Group", 0

DlgVisible "Chk2", 0

DlgVisible "History", 0

Case 2

If ControlID$ = "Chk1" Then

DlgEnable "Group", On

DlgVisible "Chk2"

DlgVisible "History"

End If

If ControlID$ = "Chk2" Then

DlgText "History", "Push to display nested dialog"

End If

If ControlID$ = "History" Then

Enable =1

Number = 4

MsgBox SQR(Number) & " The sqr of 4 is 2"

x = Dialog( Dlg2 )

End If

If ControlID$ = "but1" Then

End If

Case Else

End Select

Enable =1

End Function


DlgText Statement

DlgText “ControlName”, String

This statement is used to set or change the text of a dialog control.

The parameter ControlName is the name of the control on the dialog box. The parameter String is the value to set it to.

Related Topics: DlgEnable, DlgVisible

More:

Example:


Example:

If ControlID$ = "Chk2" Then

DlgText "History", "Push to display nested dialog"

End If


DlgVisible Statement

DlgVisible “ControlName”, Value

This statement is used to hide or make visible a particular control on a dialog box.

The parameter ControlName is the name of the control on the dialog box. The parameter Value is the value to set it to. 1 = Visible, 0 = Hidden. On is equal to 1. If the second parameter is omitted the status of the control toggles. The entire example below can be found in the dialog section of this manual and in the example .bas files that ship with Cypress Enable.

Related Topics: DlgEnable, DlgText

More:

Example:


Example:

If ControlID$ = "Chk1" Then

DlgEnable "Group", On

DlgVisible "Chk2"

DlgVisible "History"

End If


Do...Loop Statement

Do [{While|Until} condition]

[statements]

[Exit Do]

[statements]

Loop

Do

[statements]

[Exit Do]

[statements]

Loop [{While|Until} condition]

Repeats a group of statements while a condition is true or until a condition is met.

Related Topics: While..Wend

More:

Example:


Example:

Sub Main ()

Dim Value, Msg ' Declare variables.

Do

Value = InputBox("Enter a value from 5 to 10.")

If Value >= 5 And Value <= 10 Then

Exit Do ' Exit Do...Loop.

Else

Beep ' Beep if not in range.

End If

Loop

End Sub


End Statement

End[{Function | If | Sub}]

Ends a program or a block of statements such as a Sub procedure or a function.

Related Topics: Exit, Function, If...Then...Else, Select Case, Stop

More:

Example:


Example:

Sub Main()

Dim Var1 as String

Var1 = "hello"

MsgBox " Calling Test"

Test Var1

MsgBox Var1

End Sub

Sub Test(wvar1 as string)

wvar1 = "goodbye"

MsgBox "Use of End Statement"

End

End Sub


EOF Function

EOF(Filenumber)

Returns a value during file input that indicates whether the end of a file has been reached.

Related Topics: Open Statement

More:

Example:


Example:

' Input Function Example

' This example uses the Input function to read 10 characters at a time from a ' file and display them in a MsgBox. This example assumes that TESTFILE is a 'text file with a few lines of 'sample data.

Sub Main

Open "TESTFILE" For Input As #1 ' Open file.

Do While Not EOF(1) ' Loop until end of file.

MyStr = Input(10, #1) ' Get ten characters.

MsgBox MyStr

Loop

Close #1 ' Close file.

End Sub


Erase Statement

Erase arrayname[,arrayname ]

Reinitializes the elements of a fixed array.

Related Topics: Dim

More:

Example:


Example:

' This example demonstrates some of the features of arrays.

' The lower bound for an array is 0 unless it is specified

' or option base has set it as is done in this example.

Option Base 1

Sub Main

' Declare array variables.

Dim Num(10) As Integer ' Integer array.

Dim StrVarArray(10) As String ' Variable-string array.

Dim StrFixArray(10) As String * 10 ' Fixed-string array.

Dim VarArray(10) As Variant ' Variant array.

Dim DynamicArray() As Integer ' Dynamic array.

ReDim DynamicArray(10) ' Allocate storage space.

Erase Num ' Each element set to 0.

Erase StrVarArray ' Each element set to zero-length

' string ("").

Erase StrFixArray ' Each element set to 0.

Erase VarArray ' Each element set to Empty.

Erase DynamicArray ' Free memory used by array.

End Sub


Exit Statement

Exit {Do | For | Function | Sub }

Exits a loop or procedure

Related Topics: End Statement, Stop Statement

More:

Example:


Example:

' This sample shows Do ... Loop with Exit Do to get out.

Sub Main ()

Dim Value, Msg ' Declare variables.

Do

Value = InputBox("Enter a value from 5 to 10.")

If Value >= 5 And Value <= 10 Then ' Check range.

Exit Do ' Exit Do...Loop.

Else

Beep ' Beep if not in range.

End If

Loop

End Sub


Exp

Exp(num)

Returns the base of the natural log raised to a power (e ^ num).

The value of the constant e is approximately 2.71828.

Related Topics: Log

More:

Example:


Example:

Sub ExpExample ()

' Exp(x) is e ^x so Exp(1) is e ^1 or e.

Dim Msg, ValueOfE ' Declare variables.

ValueOfE = Exp(1) ' Calculate value of e.

Msg = "The value of e is " & ValueOfE

MsgBox Msg ' Display message.

End Sub


FileCopy Function

FileCopy( sourcefile, destinationfile)

Copies a file from source to destination.

The sourcefile and destinationfile parameters must be valid string expressions. sourcefile is the file name of the file to copy, destinationfile is the file name to be copied to.

More:

Example:


Example:

Dim SourceFile, DestinationFile

SourceFile = "SRCFILE" ' Define source file name.

DestinationFile = "DESTFILE" ' Define target file name.

FileCopy SourceFile, DestinationFile ' Copy source to target.


FileLen Function

FileLen( filename )

Returns a Long integer that is the length of the file in bytes

Related Topics: LOF Function

More:

Example:


Example:

Sub Main

Dim MySize

MySize = FileLen("C:\TESTFILE") ' Returns file length (bytes).

Print MySize

End Sub


Fix Function

Fix(number )

Returns the integer portion of a number

Related Topics: Int

More:

Example:


Example:

Sub Main()

Dim MySize

MySize = Fix(4.345)

Print MySize

End Sub


For each

Current Help System: PC-DMIS BASIC (View Core Help)

For each … Next Statement

For Each element in group

[statements]

[Exit For]

[statements]

Next [element]

Repeats the group of statments for each element in an array of a collection. For each … Next statements can be nested if each loop element is unique. The For Each…Next statement cannot be used with and array of user defined types.

More:

Example:


Example:

Sub Main

dim z(1 to 4) as double

z(1) = 1.11

z(2) = 2.22

z(3) = 3.33

For Each v In z

Print v

Next v

End Sub


For...Next Statement

For counter = expression1 to expression2 [Step increment]

[statements]

Next [counter]

Repeats the execution of a block of statements for a specified number of times.

More:

Example:


Example:

Dim x,y,z

For x = 1 to 5

For y = 1 to 5

For z = 1 to 5

Print "Looping" ,z,y,x

Next z

Next y

Next x

End Sub


Predefined numeric format names:

Format

Name | Description
General | Display the number as is, with no thousand Separators Number.
Fixed | Display at least one digit to the left and two digits to the right of the decimal separator.
Standard | Display number with thousand separator, if appropriate; display two digits to the right of the decimal separator.
Scientific | Use standard scientific notation.
True/False | Display False if number is 0, otherwise display True.


Characters for Creating User-Defined Number Formats

The following shows the characters you can use to create user-defined number formats.

Character | Meaning
Null string | Display the number with no formatting.
0 | Digit placeholder. Display a digit or a zero. If the number being formatted has fewer digits than there are zeros (on either side of the decimal) in the format expression, leading or trailing zeros are displayed. If the number has more digits to the right of the decimal separator than there are zeros to the right of the decimal separator in the format expression, the number is rounded to as many decimal places as there are zeros. If the number has more digits to left of the decimal separator than there are zeros to the left of the decimal separator in the format expression, the extra digits are displayed without modification.
# | Digit placeholder. Displays a digit or nothing. If there is a digit in the expression being formatted in the position where the # appears in the format string, displays it; otherwise, nothing is displayed.
. | Decimal placeholder.The decimal placeholder determines how many digits are displayed to the left and right of the decimal separator.

Character | Meaning | Description
% | Percentage placeholder. | The percent character (%) is inserted in the position where it appears in the format string. The expression is multiplied by 100.
, | Thousand separator. | The thousand separator separates thousands from hundreds within a number that has four or more places to the left of the decimal separator. Use of this separator as specified in the format statement contains a comma surrounded by digit placeholders(0 or #). Two adjacent commas or a comma immediately to the left of the decimal separator (whether or not a decimal is specified) means “scale the number by dividing it by 1000, rounding as needed.”
E-E+e-e+ | Scientific format. | If the format expression contains at least one digit placeholder (0 or #) to the right of E-,E+,e- or e+, the number is displayed in scientific formatted E or e inserted between the number and its exponent. The number of digit placeholders to the right determines the number of digits in the exponent. Use E- or e- to place a minus sign next to negative exponents. Use E+ or e+ to place a plus sign next to positive exponents.
: | Time separator. | The actual character used as the time separator depends on the Time Format specified in the International section of the Control Panel.
/ | Date separator. | The actual character used as the date separator in the formatted out depends on Date Format specified in the International section of the Control Panel.

Character | Meaning
- + $ ( ) space | Display a literal character. To display a character other than one of those listed, precede it with a backslash (\).
\ | Display the next character in the format string. The backslash itself isn’t displayed. To display a backslash, use two backslashes (\\). Examples of characters that can’t be displayed as literal characters are the date- and time- formatting characters (a,c,d,h,m,n,p,q,s,t,w,y, and /:), the numeric -formatting characters(#,0,%,E,e,comma, and period), and the string- formatting characters (@,&,<,>, and !).
“String” | Display the string inside the double quotation marks. To include a string in fmt from within Enable, you must use the ANSI code for a double quotation mark Chr(34) to enclose the text.
* | Display the next character as the fill character. Any empty space in a field is filled with the character following the asterisk.

Unless the fmt argument contains one of the predefined formats, a format expression for numbers can have from one to four sections separated by semicolons.

If you use | The result is
One section only | The format expression applies to all values.
Two | The first section applies to positive values, the second to negative sections values.
Three | The first section applies to positive values, the second to negative sections values, and the third to zeros.
Four | The first section applies to positive values, the second to negative section values, the third to zeros, and the fourth to Null values.

The following example has two sections: the first defines the format for positive values and zeros; the second section defines the format for negative values.

“$#,##0; ($#,##0)”

If you include semicolons with nothing between them. the missing section is printed using the format of the positive value. For example, the following format displays positive and negative values using the format in the first section and displays “Zero” if the value is zero.

“$#,##0;;\Z\e\r\o”


Sample Format Number Expressions

Some sample format expressions for numbers are shown below. (These examples all assume the Country is set to United States in the International section of the Control Panel.) The first column contains the format strings. The other columns contain the output the results if the formatted data has the value given in the column headings

Format (fmt) | Positive 3 | Negative 3 | Decimal .3 | Null
Null string | 3 | -3 | 0.3 |
0 | 3 | -3 | 1 |
0.00 | 3.00 | -3.00 | 0.30 |
#,##0 | 3 | -3 | 1 |
#,##0.00;;;Nil | 3.00 | -3.00 | 0.30 | Nil
$#,##0;($#,## 0) | $3 | ($3) | $1 |
$#,##0.00;($ #,##0.00) $3.00 | ($3.00) | $0.30 |  |
0% | 300% | -300% | 30% |
0.00% | 300.00% | -300.00% | 30.00% |
0.00E+00 | 3.00E+00 | -3.00E+00 | 3.00E-01 |
0.00E-00 | 3.00E00 | -3.00E00 | 3.00E-01 |

Numbers can also be used to represent date and time information. You can format date and time serial numbers using date and time formats or number formats because date/time serial numbers are stored as floating-point values.

To format dates and times, you can use either the commonly used format that have been predefined or create user-defined time formats using standard meaning of each:

The following table shows the predefined data format names you can use and the meaning of each.

Format

Name | Description
General | Display a date and/or time. for real numbers, display a date and time.(e.g. 4/3/93 03:34 PM); If there is no fractional part, display only a date (e.g. 4/3/93); if there is no integer part, display time only (e.g. 03:34 PM).
Long Date | Display a Long Date, as defined in the International section of the Control Panel.
Medium | Display a date in the same form as the Short Date, as defined in the international section of the Control Panel, except spell out the month abbreviation.
Short Date | Display a Short Date, as defined in the International section of the Control Panel.
Long Time | Display a Long Time, as defined in the International section of the Control panel. Long Time includes hours, minutes, seconds.
Medium Time | Display time in 12-hour format using hours and minutes and the Time AM/PM designator.
Short Time | Display a time using the 24-hour format (e.g. 17:45)

This table shows the characters you can use to create user-defined date/time formats.

Character | Meaning
c | Display the date as dddd and display the time as ttttt. in the order.
d | Display the day as a number without a leading zero (1-31).
dd | Display the day as a number with a leading zero (01-31).
ddd | Display the day as an abbreviation (Sun-Sat).
ddddd | Display a date serial number as a complete date (including day , month, and year).

Character | Meaning
w | Display the day of the week as a number (1- 7 ).
ww | Display the week of the year as a number (1-53).
m | Display the month as a number without a leading zero (1-12). If m immediately follows h or hh, the minute rather than the month is displayed.
mm | Display the month as a number with a leading zero (01-12). If mm immediately follows h or hh, the minute rather than the month is displayed.
mmm | Display the month as an abbreviation (Jan-Dec).
mmmm | Display the month as a full month name (January-December).
q | display the quarter of the year as a number (1-4).
y | Display the day of the year as a number (1-366).
yy | Display the day of the year as a two-digit number (00-99)
yyyy | Display the day of the year as a four-digit number (100-9999).
h | Display the hour as a number without leading zeros (0-23).
hh | Display the hour as a number with leading zeros (00-23).
n | Display the minute as a number without leading zeros (0-59).
nn | Display the minute as a number with leading zeros (00-59).
s | Display the second as a number without leading zeros (0-59).
ss | Display the second as a number with leading zeros (00-59).
ttttt | Display a time serial number as a complete time (including hour, minute, and second) formatted using the time separator defined by the Time Format in the International section of the Control Panel. A leading zero is displayed if the Leading Zero option is selected and the time is before 10:00 A.M. or P.M. The default time format is h:mm:ss.
AM/PM | Use the 12-hour clock and display an uppercase AM/PM
am/pm | Use the 12-hour clock display a lowercase am/pm

Character | Meaning
A/P | Use the 12-hour clock display a uppercase A/P
a/p | Use the 12-hour clock display a lowercase a/p
AMPM | Use the 12-hour clock and display the contents of the 11:59 string (s1159) in the WIN.INI file with any hour before noon; display the contents of the 2359 string (s2359) with any hour between noon and 11:59 PM. AMPM can be either uppercase or lowercase, but the case of the string displayed matches the string as it exists in the WIN.INI file. The default format is AM/PM.

The Following are examples of user-defined date and time formats:

Format | Display
m/d/yy | 2/26/65
d-mmmm-yy | 26-February-65
d-mmmm | 26 February
mmmm-yy | February 65
hh:nn AM/PM | 06:45 PM
h:nn:ss a/p | 6:45:15 p
h:nn:ss | 18:45:15
m/d/yy/h:nn | 2/26/65 18:45

Strings can also be formatted with Format[$]. A format expression for strings can have one section or two sections separated by a semicolon.

If you use | The result is
One section only | The format applies to all string data.
Two sections | The first section applies to string data, the second to Null values and zero-length strings.

The following characters can be used to create a format expression for strings:

Character | Meaning
@ | Character placeholder. Displays a character or a space. Placeholders are filled from right to left unless there is an ! character in the format string.
& | Character placeholder. Display a character or nothing.
< | Force lowercase.
> | Force uppercase.
! | Force placeholders to fill from left to right instead of right to left.

Related Topics: Str, Str$ Function.

More:

Example:


Example:

' Format Function Example

' This example shows various uses of the Format function to format values

' using both named and user-defined formats. For the date separator (/),

' time separator (:), and AM/ PM literal, the actual formatted output

' displayed by your system depends on the locale settings on which the code

' is running. When times and dates are displayed in the development

' environment, the short time and short date formats of the code locale

' are used. When displayed by running code, the short time and short date

' formats of the system locale are used, which may differ from the code

' locale. For this example, English/United States is assumed.

' MyTime and MyDate are displayed in the development environment using

' current system short time and short date settings.

Sub Main()

MyTime = "08:04:23 PM"

MyDate = "03/03/95"

MyDate = "January 27, 1993"

MsgBox Now

MsgBox MyTime

MsgBox Second( MyTime ) & " Seconds"

MsgBox Minute( MyTime ) & " Minutes"

MsgBox Hour( MyTime ) & " Hours"

MsgBox Day( MyDate ) & " Days"

MsgBox Month( MyDate ) & " Months"

MsgBox Year( MyDate ) & " Years"

' Returns current system time in the system-defined long time format.

MsgBox Format(Time, "Short Time")

MyStr = Format(Time, "Long Time")

' Returns current system date in the system-defined long date format.

MsgBox Format(Date, "Short Date")

MsgBox Format(Date, "Long Date")

MyStr Format(MyTime, "h:n:s") ' Returns "17:4:23".

MyStr Format(MyTime, "hh:nn:ss")' Returns "20:04:22 ".

MyStr Format(MyDate, "dddd, mmm d yyyy")' Returns "Wednesday, Jan 27 1993".

' If format is not supplied, a string is returned.

MsgBox Format(23) ' Returns "23".

' User-defined formats.

MsgBox Format(5459.4, "##,##0.00") ' Returns "5,459.40".

MsgBox Format(334.9, "###0.00") ' Returns "334.90".

MsgBox Format(5, "0.00%") ' Returns "500.00%".

MsgBox Format("HELLO", "<") ' Returns "hello".

MsgBox Format("This is it", ">") ' Returns "THIS IS IT".

End Sub


FreeFile Function

FreeFile

Returns an integer that is the next available file handle to be used by the Open Statement.

Related Topics: Open, Close, Write

More:

Example:


Example:

Sub Main()

Dim Mx, FileNumber

For Mx = 1 To 3

FileNumber = FreeFile

Open "c:\e1\TEST" & Mx For Output As #FileNumber

Write #FileNumber, "This is a sample."

Close #FileNumber

Next Mx

Open "c:\e1\test1" For Input As #1

Do While Not EOF(1)

MyStr = Input(10, #1)

MsgBox MyStr

Loop

Close #1

End Sub


Function Statement

Function Fname [(Arguments)] [As type]

[statements]

Functionname = expression

[statements]

Functionname = expression

End Function

Declares and defines a procedure that can receive arguments and return a value of a specified data type.

When the optional argument list needs to be passed the format is as follows:

([ByVal] variable [As type] [,ByVal] variable [As type] ]…])

The optional ByVal parameter specifies that the variable is [passed by value instead of by reference (see “ByRef and ByVal” in this manual). The optional As type parameter is used to specify the data type. Valid types are String, Integer, Double, Long, and Varaint (see “Variable Types” in this manual).

Related Topics: Dim, End, Exit, Sub

More:

Example:


Example:

Sub Main

Dim I as integer

For I = 1 to 10

Print GetColor2(I)

Next I

End Sub

Function GetColor2( c% ) As Long

GetColor2 = c% * 25

If c% > 2 Then

GetColor2 = 255 ' 0x0000FF - Red

End If

If c% > 5 Then

GetColor2 = 65280 ' 0x00FF00 - Green

End If

If c% > 8 Then

GetColor2 = 16711680 ' 0xFF0000 - Blue

End If

End Function


Global Statement

Global Const constant

The Global Statement must be outside the procedure section of the script. Global variables are available to all functions and subroutines in your program

Related Topics: Dim, Const and Type Statements

More:

Example:


Example:

Global Const Height = 14.4357 '

Const PI = 3.14159 'Global to all procedures in a module

Sub Main ()

Begin Dialog DialogName1 60, 60, 160,70, "ASC - Hello"

TEXT 10, 10, 100, 20, "Please fill in the radius of circle x"

TEXT 10, 40, 28, 12, "Radius"

TEXTBOX 42, 40, 28, 12, .Radius

OKBUTTON 42, 54,40, 12

End Dialog

Dim Dlg1 As DialogName1

Dialog Dlg1

CylArea = Height * (Dlg1.Radius * Dlg1.Radius) * PI

MsgBox "The volume of Cylinder x is " & CylArea

End Sub


GoTo Statement

GoTo label

Branches unconditionally and without return to a specified label in a procedure.

More:

Example:


Example:

Sub main ()

Dim x,y,z

For x = 1 to 5

For y = 1 to 5

For z = 1 to 5

Print "Looping" ,z,y,x

If y > 3 Then

GoTo Label1

End If

Next z

Next y

Next x

Label1:

End Sub


Hex

Hex (num)

Returns the hexadecimal value of a decimal parameter.

Hex returns a string

The parameter num can be any valid number. It is rounded to nearest whole number before evaluation.

Related Topics: Oct, Oct$

More:

Example:


Example:

Sub Main ()

Dim Msg As String, x%

x% = 10

Msg =Str( x%) & " decimal is "

Msg = Msg & Hex(x%) & " in hex "

MsgBox Msg

End Sub


Hour Function

Hour(string )

The Hour Function returns an integer between 0 and 23 that is the hour of the day indicated in the parameter number.

The parameter string is any number expressed as a string that can represent a date and time from January 1, 1980 through December 31, 9999.

More:

Example:


Example:

' This example shows various uses of the Format function to format values

' using both named and user-defined formats. For the date separator (/),

' time separator (:), and AM/ PM literal, the actual formatted output

' displayed by your system depends on the locale settings on which the code

' is running. When times and dates are displayed in the development

' environment, the short time and short date formats of the code locale

' are used. When displayed by running code, the short time and short date

' formats of the system locale are used, which may differ from the code

' locale. For this example, English/United States is assumed.

' MyTime and MyDate are displayed in the development environment using

' current system short time and short date settings.

Sub Main

MyTime = "08:04:23 PM"

MyDate = "03/03/95"

MyDate = "January 27, 1993"

MsgBox Now

MsgBox MyTime

MsgBox Second( MyTime ) & " Seconds"

MsgBox Minute( MyTime ) & " Minutes"

MsgBox Hour( MyTime ) & " Hours"

MsgBox Day( MyDate ) & " Days"

MsgBox Month( MyDate ) & " Months"

MsgBox Year( MyDate ) & " Years"

' Returns current system time in the system-defined long time format.

MsgBox Format(Time, "Short Time")

MyStr = Format(Time, "Long Time")

' Returns current system date in the system-defined long date format.

MsgBox Format(Date, "Short Date")

MsgBox Format(Date, "Long Date")

' This section not yet supported

'MyStr = Format(MyTime, "h:n:s") ' Returns "17:4:23".

'MyStr = Format(MyTime, "hh:nn:ss AMPM")' Returns "05:04:23 PM".

'MyStr = Format(MyDate, "dddd, nnn d yyyy")' Returns "Wednesday, Jan 27 1993".

' If format is not supplied, a string is returned.

MsgBox Format(23) ' Returns "23".

' User-defined formats.

MsgBox Format(5459.4, "##,##0.00") ' Returns "5,459.40".

MsgBox Format(334.9, "###0.00") ' Returns "334.90".

MsgBox Format(5, "0.00%") ' Returns "500.00%".

MsgBox Format("HELLO", "<") ' Returns "hello".

MsgBox Format("This is it", ">") ' Returns "THIS IS IT".

End Sub


HTMLDialog

HTMLDialog (path, number)

Runs a DHTML dialog that is specified in the path.

More:

Example:


Example:

x =HtmlDialog( "c:\enable40\htmlt.htm", 57 )

‘See sample code on the samples disk htmldlg.bas


If...Then...Else Statement

Syntax 1

If condition Then thenpart [Else elsepart]

Syntax 2

If condition Then

[statement(s)]

ElseIf condition Then

[statement(s)]

Else

[statements(s)].

End If

Syntax 2

If conditional Then statement

Allows conditional statements to be executed in the code.

Related Topics: Select Case

More:

Example:


Example:

Sub Main()

' demo If...Then...Else

Dim msg as String

Dim nl as String

Dim someInt as Integer

nl = Chr(10)

msg = "Less"

someInt = 4

If 5 > someInt Then msg = "Greater" : Beep

MsgBox “” & msg

If 3 > someInt Then

msg = "Greater"

Beep

Else

msg = "Less"

End If

MsgBox “” & msg

If someInt = 1 Then

msg = "Spring"

ElseIf someInt = 2 Then

msg = "Summer"

ElseIf someInt = 3 Then

msg = "Fall"

ElseIf someInt = 4 Then

msg = "Winter"

Else

msg = "Salt"

End If

MsgBox “” & msg

End Sub


Input # Statement

Input # filenumber, variablelist

Input # Statement reads data from a sequential file and assigns that data to variables.

The Input # Statement has two parameters filenumber and variablelist. filenumber is the number used in the open statement when the file was opened and variablelist is a Comma-delimited list of the variables that are assigned when read from the file.

More:

Example:


Example:

Dim MyString, MyNumber

Open "c:\TESTFILE" For Input As #1 ' Open file for input.

Do While Not EOF(1) ' Loop until end of file.

Input #1, MyString, MyNumber ' Read data into two variables.

Loop

Close #1 ' Close file.


Input Function

Input(n , [ #] filenumber )

Input returns characters from a sequential file.

The input function has two parameters n and filenumber. n is the number of bytes to be read from a file and filenumber is the number used in the open statement when the file was opened.

More:

Example:


Example:

Sub Main

Open "TESTFILE" For Input As #1 ' Open file.

Do While Not EOF(1) ' Loop until end of file.

MyStr = Input(10, #1) ' Get ten characters.

MsgBox MyStr

Loop

Close #1 ' Close file.

End Sub


InputBox Function

InputBox(prompt[,[title][,[default][,xpos,ypos]]])

InputBox returns a String.

Prompt is string that is displayed usually to ask for input type or information.

Title is a string that is displayed at the top of the input dialog box.

Default is a string that is displayed in the text box as the default entry.

Xpos and Ypos and the x and y coodinates of the relative location of the input dialog box.

More:

Example:


Example:

Sub Main ()

Title$ = "Greetings"

Prompt$ = "What is your name?"

Default$ = ""

X% = 200

Y% = 200

N$ = InputBox$(Prompt$, Title$, Default$, X%, Y%)

End Sub


InStr

InStr(numbegin, string1, string2)

Returns the character position of the first occurrence of string2 within string1.

The numbegin parameter is not optional and sets the starting point of the search. numbegin must be a valid positive integer no greater than 65,535.

string1 is the string being searched and string2 is the string we are looking for.

Related Topics: Mid Function

More:

Example:


Example:

Sub Main ()

B$ = "Good Bye"

A% = InStr(2, B$, "Bye")

C% = Instr(3, B$, "Bye")

End Sub


IsArray Function

IsArray(variablename )

Returns a boolean value True or False indicating whether the parameter vaiablename is an array.

Related Topics: IsEmpty, IsNumeric, VarType, IsObject

More:

Example:


Example:

Sub Main

Dim MArray(1 To 5) As Integer, MCheck

MCheck = IsArray(MArray)

Print MCheck

End Sub


IsDate

IsDate(variant )

Returns a value that indicates if a variant parameter can be converted to a date.

Related Topics: IsEmpty, IsNumeric, VarType

More:

Example:


Example:

Sub Main

Dim x As String

Dim MArray As Integer, MCheck

MArray = 345

x = "January 1, 1987"

MCheck = IsDate(MArray)

MChekk = IsDate(x)

MArray1 = CStr(MArray)

MCheck1 = CStr(MCheck)

Print MArray1 & " is a date " & Chr(10) & MCheck

Print x & " is a date" & Chr(10) & MChekk

End Sub


IsEmpty

IsEmpty(variant )

Returns a value that indicates if a variant parameter has been initialized.

Related Topics: IsDate, IsNull, IsNumeric, VarType

More:

Example:


Example:

' This sample explores the concept of an empty variant

Sub Main

Dim x ' Empty

x = 5 ' Not Empty - Long

x = Empty ' Empty

y = x ' Both Empty

MsgBox “x” & " IsEmpty: " & IsEmpty(x)

End Sub


IsNumeric

IsNumeric(v)

Returns a TRUE or FALSE indicating if the v parameter can be converted to a numeric data type.

The parameter v can be any variant, numeric value, Date or string (if the string can be interpreted as a numeric).

Related topics: : IsDate, IsEmpty, IsNull, VarType

More:

Example:


Example:

Sub Form_Click ()

Dim TestVar ' Declare variable.

TestVar = InputBox("Please enter a number, letter, or symbol.")

If IsNumeric(TestVar) Then ' Evaluate variable.

MsgBox "Entered data is numeric." ' Message if number.

Else

MsgBox "Entered data is not numeric." ' Message if not.

End If

End Sub


IsObject Function

IsObject(objectname )

Returns a boolean value True or False indicating whether the parameter objectname is an object.

Related Topics: IsEmpty, IsNumeric, VarType, IsObject

More:

Example:


Example:

Sub Main

Dim MyInt As Integer, MyCheck

Dim MyObject As Object

Dim YourObject As Object

Set MyObject = CreateObject("Word.Basic")

Set YourObject = MyObject

MyCheck = IsObject(YourObject)

Print MyCheck

End Sub


Kill Statement

Kill filename

Kill will only delete files. To remove a directory use the RmDir Statement

Related Topics: RmDir

More:

Example:


Example:

Const NumberOfFiles = 3

Sub Main ()

Dim Msg ' Declare variable.

Call MakeFiles() ' Create data files.

Msg = "Several test files have been created on your disk. You may see "

Msg = Msg & "them by switching tasks. Choose OK to remove the test files."

MsgBox Msg

For I = 1 To NumberOfFiles

Kill "TEST" & I ' Remove data files from disk.

Next I

End Sub

Sub MakeFiles ()

Dim I, FNum, FName ' Declare variables.

For I = 1 To NumberOfFiles

FNum = FreeFile ' Determine next file number.

FName = "TEST" & I

Open FName For Output As FNum ' Open file.

Print #FNum, "This is test #" & I ' Write string to file.

Print #FNum, "Here is another "; "line"; I

Next I

Close ' Close all files.

Kill FName

End Sub


LBound Function

LBound(array [,dimension] )

Returns the smallest available subscript for the dimension of the indicated array.

Related Topics: UBound Function

More:

Example:


Example:

' This example demonstrates some of the features of arrays. The lower bound

' for an array is 0 unless it is specified or option base has set as is

' done in this example.

Option Base 1

Sub Main

Dim a(10) As Double

MsgBox "LBound: " & LBound(a) & " UBound: " & UBound(a)

Dim i As Integer

For i = 0 to 3

a(i) = 2 + i * 3.1

Next i

Print a(0),a(1),a(2), a(3)

End Sub


LCase, Function

Lcase[$](string )

Returns a string in which all letters of the string parameter have been converted to upper case.

Related Topics: Ucase Function

More:

Example:


Example:

' This example uses the LTrim and RTrim functions to strip leading and

' trailing spaces, respectively, from a string variable. It

' uses the Trim function alone to strip both types of spaces.

' LCase and UCase are also shown in this example as well as the use

' of nested function calls

Sub Main

MyString = " <-Trim-> " ' Initialize string.

TrimString = LTrim(MyString) ' TrimString = "<-Trim-> ".

MsgBox "|" & TrimString & "|"

TrimString = LCase(RTrim(MyString)) ' TrimString = " <-trim->".

MsgBox "|" & TrimString & "|"

TrimString = LTrim(RTrim(MyString)) ' TrimString = "<-Trim->".

MsgBox "|" & TrimString & "|"

' Using the Trim function alone achieves the same result.

TrimString = UCase(Trim(MyString)) ' TrimString = "<-TRIM->".

MsgBox "|" & TrimString & "|"

End Sub


Left

Left(string, num)

Returns the left most num characters of a string parameter.

Left returns a Variant, Left$ returns a String

More:

Example:


Example:

Sub Main ()

Dim LWord, Msg, RWord, SpcPos, UsrInp ' Declare variables.

Msg = "Enter two words separated by a space."

UsrInp = InputBox(Msg) ' Get user input.

print UsrInp

SpcPos = InStr(1, UsrInp, " ") ' Find space.

If SpcPos Then

LWord = Left(UsrInp, SpcPos - 1) ' Get left word.

print "LWord: "; LWord

RWord = Right(UsrInp, Len(UsrInp) - SpcPos) ' Get right word.

Msg = "The first word you entered is " & LWord

Msg = Msg & "." & " The second word is "

Msg = "The first word you entered is <" & LWord & ">"

Msg = Msg & RWord & "."

Else

Msg = "You didn't enter two words."

End If

MsgBox Msg ' Display message.

MidTest = Mid("Mid Word Test", 4, 5)

Print MidTest

End Sub


Len

Len(string)

Returns the number of characters in a string.

Related Topics: InStr

More:

Example:


Example:

Sub Main ()

A$ = "Cypress Enable"

StrLen% = Len(A$) 'the value of StrLen is 14

MsgBox StrLen%

End Sub


Let Statement

[Let] variablename = expression

Let assigns a value to a variable.

Let is an optional keyword that is rarely used. The Let statement is required in older versions of BASIC.

More:

Example:


Example:

Sub Form_Click ()

Dim Msg, Pi ' Declare variables.

Let Pi = 4 * Atn(1) ' Calculate Pi.

Msg = "Pi is equal to " & Str(Pi)

MsgBox Msg ' Display results.

End Sub


Line Input # Statement

Line Input # filenumber and name

Reads a line from a sequential file into a String or Variant variable.

The parameter filenumber is used in the open statement to open the file. The parameter name is the name of a variable used to hold the line of text from the file.

Related Topics: Open

More:

Example:


Example:

' Line Input # Statement Example:

' This example uses the Line Input # statement to read a line from a

' sequential file and assign it to a variable. This example assumes that

' TESTFILE is a text file with a few lines of sample data.

Sub Main

Open "TESTFILE" For Input As #1 ' Open file.

Do While Not EOF(1) ' Loop until end of file.

Line Input #1, TextLine ' Read line into variable.

Print TextLine ' Print to Debug window.

Loop

Close #1 ' Close file.

End Sub


LOF

LOF(filenumber)

Returns a long number for the number of bytes in the open file.

The parameter filenumber is required and must be an integer.

Related Topics: FileLen

More:

Example:


Example:

Sub Main()

Dim FileLength

Open "TESTFILE" For Input As #1

FileLength = LOF(1)

Print FileLength

Close #1

End Sub


Log

Log(num)

Returns the natural log of a number

The parameter num must be greater than zero and be a valid number.

Related Topics: Exp, Sin, Cos

More:

Example:


Example:

Sub Form_Click ( )

Dim I, Msg, NL

NL = Chr(13) & Chr(10)

Msg = Exp(1) & NL

For I = 1 to 3

Msg = Msg & Log(Exp(1) ^ I ) & NL

Next I

MsgBox Msg

End Sub


Mid Function

string = Mid(strgvar,begin,length)

Returns a substring within a string.

More:

Example:


Minute Function

Minute(string)

Returns an integer between 0 and 59 representing the minute of the hour.

More:

Example:


Example:

' Format Function Example

' This example shows various uses of the Format function to format values

' using both named and user-defined formats. For the date separator (/),

' time separator (:), and AM/ PM literal, the actual formatted output

' displayed by your system depends on the locale settings on which the code

' is running. When times and dates are displayed in the development

' environment, the short time and short date formats of the code locale

' are used. When displayed by running code, the short time and short date

' formats of the system locale are used, which may differ from the code

' locale. For this example, English/United States is assumed.

' MyTime and MyDate are displayed in the development environment using

' current system short time and short date settings.

Sub Main()

MyTime = "08:04:23 PM"

MyDate = "03/03/95"

MyDate = "January 27, 1993"

MsgBox Now

MsgBox MyTime

MsgBox Second( MyTime ) & " Seconds"

MsgBox Minute( MyTime ) & " Minutes"

MsgBox Hour( MyTime ) & " Hours"

MsgBox Day( MyDate ) & " Days"

MsgBox Month( MyDate ) & " Months"

MsgBox Year( MyDate ) & " Years"

End Sub


MkDir

MkDir path

Creates a new directory.

The parameter path is a string expression that must contain fewer than 128 characters.

More:

Example:


Example:

Sub Main

Dim DST As String

DST = "t1"

mkdir DST

mkdir "t2"

End Sub


Month Function

Month(number)

Returns an integer between 1 and 12, inclusive, that represents the month of the year.

Related Topics: Day, Hour, Weekday, Year

More:

Example:


Example:

Sub Main

MyDate = "03/03/96"

print MyDate

x = Month(MyDate)

print x

End Sub


MsgBox Function MsgBox Statement

MsgBox ( msg, [type] [, title])

Displays a message in a dialog box and waits for the user to choose a button.

The first parameter msg is the string displayed in the dialog box as the message. The second and third parameters are optional and respectively designate the type of buttons and the title displayed in the dialog box.

MsgBox Function returns a value indicating which button the user has chosen; the MsgBox statement does not.

Value | Meaning
Group 1
0 | Display OK button only
1 | Display OK and Cancel buttons
2 | Display Abort, Retry, and Ignore buttons
3 | Display Yes, No, and Cancel buttons
4 | Display Yes and No buttons
5 | Display Retry and Cancel buttons
Group 2
16 | Stop Icon
32 | Question Icon
48 | Exclamation Icon
64 | Information Icon
Group 3
0 | First button is default
256 | Second button is default
512 | Third button is default
Group 4
768 | Fourth button is default
0 | Application modal
4096 | System modal

The first group of values (1-5) describes the number and type of buttons displayed in the dialog box; the second group (16, 32, 48, 64) describes the icon style; the third group (0, 256, 512) determines which button is the default; and the fourth group (0, 4096) determines the modality of the message box. When adding numbers to create a final value for the argument type, use only one number from each group. If omitted, the default value for type is 0.

title:

String expression displayed in the title bar of the dialog box. If you omit the argument title, MsgBox has no default title.

The value returned by the MsgBox function indicates which button has been selected, as shown below:

Value | Meaning
1 | OK button selected.
2 | Cancel button selected.
3 | Abort button selected.
4 | Retry button selected.
5 | Ignore button selected.
6 | Yes button selected.
7 | No button selected.

If the dialog box displays a Cancel button, pressing the Esc key has the same effect as choosing Cancel.

More:

MsgBox Function, MsgBox Statement Example

Example:


MsgBox Function, MsgBox Statement Example

The example uses MsgBox to display a close without saving message in a dialog box with a Yes button a No button and a Cancel button. The Cancel button is the default response. The MsgBox function returns a value based on the button chosen by the user. The MsgBox statement uses that value to display a message that indicates which button was chosen.

Related Topics: InputBox, InputBox$ Function


Example:

Dim Msg, Style, Title, Help, Ctxt, Response, MyString

Msg = "Do you want to continue ?: ' Define message.

'Style = vbYesNo + vbCritical + vbDefaultButton2 ' Define buttons.

Style = 4 + 16 + 256 ' Define buttons.

Title = "MsgBox Demonstration" ' Define title.

Help = "DEMO.HLP" ' Define Help file.

Ctxt = 1000 ' Define topic

' context.

' Display message.

Response = MsgBox(Msg, Style, Title, Help, Ctxt)

If Response = vbYes Then ' User chose Yes.

MyString = "Yes" ' Perform some action.

Else ' User chose No.

MyString = "No" ' Perform some action.

End If


Name Statement

Name oldname As newname

Changes the name of a directory or a file.

The parameters oldname and newname are strings that can optionally contain a path.

Related Topics: Kill, ChDir


Now Function

Now

Returns a date that represents the current date and time according to the setting of the computer’s system date and time

The Now function returns a Variant data type containing a date and time that are stored internally as a double. The number is a date and time from January 1, 100 through December 31, 9999, where January 1, 1900 is 2. Numbers to the left of the decimal point represent the date and numbers to the right represent the time.

More:

Example:


Current Help System: PC-DMIS BASIC (View Core Help)

Example:

Sub Main ()

Dim Today

Today = Now

End Sub


Oct Function

Oct (num)

Returns the octal value of the decimal parameter

Oct returns a string

Related Topics: Hex

More:

Example:


Example:

Sub Main ()

Dim Msg, Num ' Declare variables.

Num = InputBox("Enter a number.") ' Get user input.

Msg = Num & " decimal is &O"

Msg = Msg & Oct(Num) & " in octal notation."

MsgBox Msg ' Display results.

End Sub


OKButton

OKBUTTON starting x position, starting y position, width, Height

For selecting options and closing dialog boxes

More:

Example:


Example:

Sub Main ()

Begin Dialog DialogName1 60, 60, 160, 70, "ASC - Hello"

TEXT 10, 10, 28, 12, "Name:"

TEXTBOX 42, 10, 108, 12, .nameStr

TEXTBOX 42, 24, 108, 12, .descStr

CHECKBOX 42, 38, 48, 12, "&CHECKME", .checkInt

OKBUTTON 42, 54, 40, 12

End Dialog

Dim Dlg1 As DialogName1

Dialog Dlg1

MsgBox Dlg1.nameStr

MsgBox Dlg1.descStr

MsgBox Dlg1.checkInt

End Sub


On Error

On Error { GoTo line | Resume Next | GoTo 0 }

Enables error-handling routine and specifies the line label of the error-handling routine.

Related Topics: Resume

The line parameter refers to a label. That label must be present in the code or an error is generated.

More:

Example:

Defined x Value Descriptions


Example:

Sub Main

On Error GoTo dude

Dim x as object

x.draw ' Object not set

jpe ' Undefined function call

print 1/0 ' Division by zero

Err.Raise 6 ' Generate an "Overflow" error

MsgBox "Back"

MsgBox "Jack"

Exit Sub

dude:

MsgBox "HELLO"

Print Err.Number, Err.Description

Resume Next

MsgBox "Should not get here!"

MsgBox "What?"

End Sub

Errors can be raised with the syntax:

Err.Raise x


Defined x Value Descriptions

Current Help System: PC-DMIS BASIC (View Core Help)

Defined Errors

The list below shows the corresponding descriptions for the defined values of errors:

3: "Return without GoSub";

5: "Invalid procedure call";

6: "Overflow";

7: "Out of memory";

9: "Subscript out of range";

10: "Array is fixed or temporarily locked";

11: "Division by zero";

13: "Type mismatch";

14: "Out of string space";

16: "Expression too complex";

17: "Can't perform requested operation";

18: "User intrrupt occurred";

20: "Resume without error";

28: "Out of stack space";

35: "Sub, Function, or Property not defined";

47: "Too many DLL application clients";

48: "Error in loading DLL";

49: "Bad DLL calling convention";

51: "Internal error";

52: "Bad file name or number";

53: "File not found";

54: "Bad file mode";

55: "File already open";

57: "Device I/O error";

58: "File already exists";

59: "Bad record length";

60: "Disk full";

62: "Input past end of file";

63: "Bad record number";

67: "Too many files";

68: "Device unavailable";

70: "Permission denied";

71: "Disk not ready";

74: "Can't rename with different drive";

75: "Path/File access error";

76: "Path not found";

91: "Object variable or With block variable not set";

92: "For loop not initialized";

93: "Invalid pattern string";

94: "Invalid use of Null";

// OLE Automation Messages

429: "OLE Automation server cannot create object";

430: "Class doesn't support OLE Automation";

432: "File name or class name not found during OLE Automation operation";

438: "Object doesn't support this property or method";

440: "OLE Automation error";

443: "OLE Automation object does not have a default value";

445: "Object doesn't support this action";

446: "Object doesn't support named arguments";

447: "Object doesn't support current local setting";

448: "Named argument not found";

449: "Argument not optional";

450: "Wrong number of arguments";

451: "Object not a collection";

// Miscellaneous Messages

444: "Method not applicable in this context";

452: "Invalid ordinal";

453: "Specified DLL function not found";

457: "Duplicate Key";

460: "Invalid Clipboard format";

461: "Specified format doesn't match format of data";

480: "Can't create AutoRedraw image";

481: "Invalid picture";

482: "Printer error";

483: "Printer driver does not supported specified property";

484: "Problem getting printer information from the system.";

// Make sure the printer is set up correctly.

485: "invalid picture type";

520: "Can't empty Clipboard";

521: "Can't open Clipboard";


Open Statement

Open filename$ [For mode] [Access access] As [#]filenumber

Opens a file for input and output operations.

You must open a file before any I/O operation can be performed on it.

The Open statement has these parts:

Part | Description
file | File name or path.
mode | Reserved word that specifies the file mode: Append, Binary Input, Output
Access | Reserved word that specifies which operations are permitted on the open file: Read, Write.
filenumber | Integer expression with a value between 1 and 255, inclusive. When an Open statement is executed, filenumber is associated with the file as long as it is open. Other I/O statements can use the number to refer to the file.

If file doesn't exist, it is created when a file is opened for Append, Binary or Output modes.

The argument mode is a reserved word that specifies one of the following file modes.

Mode | Description
Input | Sequential input mode.
Output. | Sequential output mode

Append Sequential output mode. Append sets the file pointer to the end of the file. A Print # or Write # statement then extends (appends to) the file.

The argument access is a reserved word that specifies the operations that can be performed on the opened file. If the file is already opened by another process and the specified type of access is not allowed, the Open operation fails and a Permission denied error occurs. The Access clause works only if you are using a version of MS-DOS that supports networking (MS-DOS version 3.1 or later). If you use the Access clause with a version of MS-DOS that doesn't support networking, a feature unavailable error occurs. The argument access can be one of the following reserved words.

Access type | Description
Read | Opens the file for reading only.
Write | Opens the file for writing only.
Read Write | Opens the file for both reading and riting. This mode is valid only for Random and Binary files and files opened for Append mode.

The following example writes data to a test file and reads it back.

More:

Example:


Example:

Sub Main ()

Open "TESTFILE" For Output As #1 ' Open to write file.

userData1$ = InputBox("Enter your own text here")

userData2$ = InputBox("Enter more of your own text here")

Write #1, "This is a test of the Write # statement."

Write #1,userData1$, userData2

Close #1

Open "TESTFILE" for Input As #2 ' Open to read file.

Do While Not EOF(2)

Line Input #2, FileData ' Read a line of data.

PRint FileData ' Construct message

Loop

Close #2 ' Close all open files.

MsgBox "Testing Print Statement" ' Display message.

Kill "TESTFILE" ' Remove file from disk.

End Sub


Option Base Statement

Option Base number

Declares the default lower bound for array subscripts.

The Option Base statement is never required. If used, it can appear only once in a module, it can occur only in the Declarations section, and must be used before you declare the dimensions of any arrays.

The value of number must be either 0 or 1. The default base is 0.

The To clause in the Dim, Global, and Static statements provides a more flexible way to control the range of an array's subscripts. However, if you don't explicitly set the lower bound with a To clause, you can use Option Base to change the default lower bound to 1.

The example uses the Option Base statement to override the default base array subscript value of 0.

Related Topics: Dim, Global and Lbound Statements

More:

Example:


Example:

Option Base 1 ' Module level statement.

Sub Main

Dim A(), Msg, NL ' Declare variables.

NL = Chr(10) ' Define newline.

ReDim A(20) ' Create an array.

Msg = "The lower bound of the A array is " & LBound(A) & "."

Msg = Msg & NL & "The upper bound is " & UBound(A) & "."

MsgBox Msg ' Display message.

End Sub


Option Explicit Statement

Option Explicit

Forces explicit declaration of all variables.

The Option explicit statement is used outside of the script in the declarations section. This statement can be contained in a declare file or outside of any script in a file or buffer. If this statement is contained in the middle of a file the rest of the compile buffer will be affected.

Related Topics: Const and Global Statements

More:

Example:


Example:

Option Explicit

Sub Main

Print y ‘because y is not explicitly dimmed an error will occur.

End Sub


Print Method

Print [expr, expr...] Print a string to an object.

More:

Example:


Example:

Sub PrintExample ()

Dim Msg, Pi ' Declare variables.

Let Pi = 4 * _Atn(1) ' Calculate Pi.

Msg = "Pi is equal to " & Str(Pi)

MsgBox Msg ' Display results.

Print Pi ' Print the results in the compiler messages window

End Sub


Print # Statement

Print # filenumber, [ [{Spc(n) | Tab(n)}][ expressionlist] [{; | ,}] ]

Writes data to a sequential file.

Print statement Description:

filenumber:

Number used in an Open statement to open a sequential file. It can be any

number of an open file. Note that the

number sign (#) preceding filenumber is not optional.

Spc(n):

Name of the Basic function optionally used to insert n spaces into the printed

output. Multiple use is permitted.

Tab(n):

Name of the Basic function optionally used to tab to the nth column before printing

expressionlist. Multiple use is permitted.

expressionlist :

Numeric and/or string expressions to be written to the file.

{;|,}

Character that determines the position of the next character printed. A semicolon means the next character is printed immediately after the last character; a comma means the next character is printed at the start of the next print zone. Print zones begin every 14 columns. If neither character is specified, the next character is printed on the next line.

If you omit expression list, the Print # statement prints a blank line in the file, but you must include the comma. Because Print # writes an image of the data to the file, you must delimit the data so it is printed correctly. If you use commas as delimiters, Print # also writes the blanks between print fields to the file.

The Print # statement usually writes Variant data to a file the same way it writes any other data type. However, there are some exceptions:

  • If the data being written is a Variant of VarType 0 (Empty), Print # writes nothing to the file for that data item.

  • If the data being written is a Variant of VarType 1 (Null), Print # writes the literal #NULL# to the file.

  • If the data being written is a Variant of VarType 7 (Date), Print # writes the date to the file using the Short Date format defined in the WIN.INI file. When either the date or the time component is missing or zero, Print # writes only the part provided to the file.

The following example writes data to a test file.

More:

Example:


Example:

' The following example writes data to a test file and reads it back.

Sub Main ()

Dim I, FNum, FName ' Declare variables.

For I = 1 To 3

FNum = FreeFile ' Determine next file number.

FName = "TEST" & FNum

Open FName For Output As FNum ' Open file.

Print #I, "This is test #" & I ' Write string to file.

Print #I, "Here is another "; "line"; I

Next I

Close ' Close all files.

End Sub

Sub Main ()

Dim FileData, Msg, NL ' Declare variables.

NL = Chr(10) ' Define newline.

Open "TESTFILE" For Output As #1 ' Open to write file.

Print #2, "This is a test of the Print # statement."

Print #2 ' Print blank line to file.

Print #2, "Zone 1", "Zone 2" ' Print in two print zones.

Print #2, "With no space between" ; "." ' Print two strings together.

Close

Open "TESTFILE" for Input As #2 ' Open to read file.

Do While Not EOF(2)

Line Input #2, FileData ' Read a line of data.

Msg = Msg & FileData & NL ' Construct message.

MsgBox Msg

Loop

Close ' Close all open files.

MsgBox "Testing Print Statement" ' Display message.

Kill "TESTFILE" ' Remove file from disk.

End Sub


Randomize Statement

Randomize[number]

Used to Initialize the random number generator.

The Randomize statement has one optional parameter number. This parameter can be any valid number and is used to initialize the random number generator. If you omit the parameter then the value returned by the Timer function is used as the default parameter to seed the random number generator.

More:

Example:


Example:

Sub Main()

Dim MValue

Randomize ' Initialize random-number generator.

MValue = Int((6 * Rnd) + 1)

Print MValue

End Sub


ReDim Statement

ReDim varname(subscripts)[As Type][,varname(subscripts)]

Used to declare dynamic arrays and reallocate storage space.

The ReDim statement is used to size or resize a dynamic array that has already been declared using the Dim statement with empty parentheses. You can use the ReDim statement to repeatedly change the number of elements in and array but not to change the number of dimensions in an array or the type of the elements in the array.

ReDim will only work with single dimensional arrays. Multi-dimensional arrays, like ReDim MyArray (3,5), are invalid.

More:

Example:


Example:

Sub Main

Dim TestArray() As Integer

Dim I

ReDim TestArray(10)

For I = 1 To 10

TestArray(I) = I + 10

Print TestArray(I)

Next I

End Sub


Rem Statement

Rem remark ‘remark

Used to include explanatory remarks in a program.

The parameter remark is the text of any comment you wish to include in the code.

More:

Example:


Example:

Rem This is a remark, and is skipped by the compiler.

Sub Main()

Dim Answer, Msg ' Declare variables.

Do

Answer = InputBox("Enter a value from 1 to 3.")

Answer = 2

If Answer >= 1 And Answer <= 3 Then ' Check range.

Exit Do ' Exit Do...Loop.

Else

Beep ' Beep if not in range.

End If

Loop

MsgBox "You entered a value in the proper range."

End Sub


Right Function

Right (stringexpression, n )

Returns the right most n characters of the string parameter.

The parameter stringexpression is the string from which the rightmost characters are returned.

The parameter n is the number of characters that will be returned and must be a long integer.

Related Topics: Len, Left, Mid Functions.

More:

Example:


Example:

' The example uses the Right function to return the first of two words

' input by the user.

Sub Main ()

Dim LWord, Msg, RWord, SpcPos, UsrInp ' Declare variables.

Msg = "Enter two words separated by a space."

UsrInp = InputBox(Msg) ' Get user input.

print UsrInp

SpcPos = InStr(1, UsrInp, " ") ' Find space.

If SpcPos Then

LWord = Left(UsrInp, SpcPos - 1) ' Get left word.

print "LWord: "; LWord

RWord = Right(UsrInp, Len(UsrInp) - SpcPos) ' Get right word.

Msg = "The first word you entered is " & LWord

Msg = Msg & "." & " The second word is "

Msg = "The first word you entered is <" & LWord & ">"

Msg = Msg & RWord & "."

Else

Msg = "You didn't enter two words."

End If

MsgBox Msg ' Display message.

End Sub


RmDir Statement

RmDir path

Removes an existing directory.

The parameter path is a string that is the name of the directory to be removed.

Related Topics: ChDir, CurDir

More:

Example:


Example:

' This sample shows the functions mkdir (Make Directory)

' and rmdir (Remove Directory)

Sub Main

Dim dirName As String

dirName = "t1"

mkdir dirName

mkdir "t2"

MsgBox "Directories: t1 and t2 created. Press OK to remove them"

rmdir "t1"

rmdir "t2"

End Sub


Rnd Function

Rnd (number)

Returns a random number.

The parameter number must be a valid numeric expression.

More:

Example:


Example:

'Rnd Function Example

'The example uses the Rnd function to simulate rolling a pair of dice by

'generating random values from 1 to 6. Each time this program is run,

Sub Main ()

Dim Dice1, Dice2, Msg ' Declare variables.

Dice1 = CInt(6 * Rnd() + 1) ' Generate first die value.

Dice2 = CInt(6 * Rnd() + 1) ' Generate second die value.

Msg = "You rolled a " & Dice1

Msg = Msg & " and a " & Dice2

Msg = Msg & " for a total of "

Msg = Msg & Str(Dice1 + Dice2) & "."

MsgBox Msg ' Display message.

End Sub


Second Function

Second (number)

Returns an integer that is the second portion of the minute in the time parameter.

The parameter number must be a valid numeric expression.

Related Topics: Day, Hour, Minute, Now.

More:

Example:


Example:

' Format Function Example

' This example shows various uses of the Format function to format values

' using both named and user-defined formats. For the date separator (/),

' time separator (:), and AM/ PM literal, the actual formatted output

' displayed by your system depends on the locale settings on which the code

' is running. When times and dates are displayed in the development

' environment, the short time and short date formats of the code locale

' are used. When displayed by running code, the short time and short date

' formats of the system locale are used, which may differ from the code

' locale. For this example, English/United States is assumed.

' MyTime and MyDate are displayed in the development environment using

' current system short time and short date settings.

Sub Main

MyTime = "08:04:23 PM"

MyDate = "03/03/95"

MyDate = "January 27, 1993"

MsgBox Now

MsgBox MyTime

MsgBox Second( MyTime ) & " Seconds"

MsgBox Minute( MyTime ) & " Minutes"

MsgBox Hour( MyTime ) & " Hours"

MsgBox Day( MyDate ) & " Days"

MsgBox Month( MyDate ) & " Months"

MsgBox Year( MyDate ) & " Years"

' Returns current system time in the system-defined long time format.

MsgBox Format(Time, "Short Time")

MyStr = Format(Time, "Long Time")

' Returns current system date in the system-defined long date format.

MsgBox Format(Date, "Short Date")

MsgBox Format(Date, "Long Date")

'This section not yet supported

MsgBox Format(MyTime, "h:n:s") ' Returns "17:4:23".

MsgBox Format(MyTime, "hh:nn:ss")' Returns "05:04:23".

MsgBox Format(MyDate, "dddd, mmm d yyyy")' Returns "Wednesday, Jan 27 1993".

' If format is not supplied, a string is returned.

MsgBox Format(23) ' Returns "23".

' User-defined formats.

MsgBox Format(5459.4, "##,##0.00") ' Returns "5,459.40".

MsgBox Format(334.9, "###0.00") ' Returns "334.90".

MsgBox Format(5, "0.00%") ' Returns "500.00%".

MsgBox Format("HELLO", "<") ' Returns "hello".

MsgBox Format("This is it", ">") ' Returns "THIS IS IT".

End Sub


Seek Function

Seek (filenumber)

The parameter filenumber is used in the open statement and must be a valid numeric expression.

Seek returns a number that represents the byte position where the next operation is to take place. The first byte in the file is at position 1.

Related Topics: Open

More:

Example:


Example:

Sub Main

Open "TESTFILE" For Input As #1 ' Open file for reading.

Do While Not EOF(1) ' Loop until end of file.

MyChar = Input(1, #1) ' Read next character of data.

Print Seek(1) ' Print byte position .

Loop

Close #1 ' Close file.

End Sub


Seek Statement

Seek filenumber, position

The parameter filenumber is used in the open statement and must be a valid numeric expression, the parameter position is the number that indicates where the next read or write is to occur. In Cypress Enable Basic position is the byte position relative to the beginning of the file.

Seek statement sets the position in a file for the next read or write

Related Topics: Open

More:

Example:


Example:

Sub Main

Open "TESTFILE" For Input As #1 ' Open file for reading.

For i = 1 To 24 Step 3 ' Loop until end of file.

Seek #1, i ' Seek to byte position

MyChar = Input(1, #1) ' Read next character of data.

Print MyChar 'Print character of data

Next i

Close #1 ' Close file.

End Sub


Select Case Statement

Executes one of the statement blocks in the case based on the test variable

Select Case testvar

Case var1

Statement Block

Case var2

Statement Block

Case Else

Statement Block

End Select

The syntax supported by the Select statement includes the “To” keyword, a coma delimited list and a constant or variable.

Select Case Number ' Evaluate Number.

Case 1 To 5 ' Number between 1 and 5, inclusive.

…

' The following is the only Case clause that evaluates to True.

Case 6, 7, 8 ' Number between 6 and 8.

…

Case 9 To 10 ' Number is 9 or 10.

…

Case Else ' Other values.

…

End Select

Related Topics: If...Then...Else

More:

Example:


Example:

' This rather tedious test shows nested select statements and if uncommented,

' the exit for statement

Sub Test ()

For x = 1 to 5

print x

Select Case x

Case 2

Print "Outer Case Two"

Case 3

Print "Outer Case Three"

' Exit For

Select Case x

Case 2

Print "Inner Case Two"

Case 3

Print "Inner Case Three"

' Exit For

Case Else ' Must be something else.

Print "Inner Case Else:", x

End Select

Print "Done with Inner Select Case"

Case Else ' Must be something else.

Print "Outer Case Else:",x

End Select

Next x

Print "Done with For Loop"

End Sub


SendKeys Function

SendKeys (Keys, [wait])

Sends one or more keystrokes to the active window as if they had been entered at the keyboard

The SendKeys statement has two parameters. The first parameter keys is a string and is sent to the active window. The second parameter wait is optional and if omitted is assumed to be false. If wait is true the keystrokes must be processed before control is returned to the calling procedure.

More:

Example:


Example:

Sub Main ()

Dim I, X, Msg ' Declare variables.

X = Shell("Calc.exe", 1) ' Shell Calculator.

For I = 1 To 5 ' Set up counting loop.

SendKeys I & "{+}", True ' Send keystrokes to Calculator

Next I ' to add each value of I.

AppActivate "Calculator" ' Return focus to Calculator.

SendKeys "%{F4}", True ' Alt+F4 to close Calculator.

End Sub


Set Statement

Set Object = {[New] objectexpression | Nothing}

Assigns an object to an object variable.

Related Topics: Dim, Global, Static

More:

Example:


Example:

Sub Main

Dim visio As Object

Set visio = CreateObject( "visio.application" )

Dim draw As Object

Set draw = visio.Documents

draw.Open "c:\visio\drawings\Sample1.vsd"

MsgBox "Open docs: " & draw.Count

Dim page As Object

Set page = visio.ActivePage

Dim red As Object

Set red = page.DrawRectangle (1, 9, 7.5, 4.5)

red.FillStyle = "Red fill"

Dim cyan As Object

Set cyan = page.DrawOval (2.5, 8.5, 5.75, 5.25)

cyan.FillStyle = "Cyan fill"

Dim green As Object

Set green = page.DrawOval (1.5, 6.25, 2.5, 5.25)

green.FillStyle = "Green fill"

Dim DarkBlue As Object

set DarkBlue = page.DrawOval (6, 8.75, 7, 7.75)

DarkBlue.FillStyle = "Blue dark fill"

visio.Quit

End Sub


Shell Function

Shell ( app [, style])

Runs an executable program.

The shell function has two parameters. The first one, app is the name of the program to be executed. The name of the program in app must include a .PIF, .COM, .BAT, or .EXE file extension or an error will occur. The second argument, style is the number corresponding to the style of the window . It is also optional and if omitted the program is opened minimized with focus.

Window styles:

Normal with focus 1,5,9

Minimized with focus (default) 2

Maximized with focus 3

normal without focus 4,8

minimized without focus 6,7

Return value: ID, the task ID of the started program.

More:

Example:


Example:

' Calculator program included with Microsoft Windows; it then

' uses the SendKeys statement to send keystrokes to add some numbers.

Sub Main ()

Dim I, X, Msg ' Declare variables.

X = Shell("Calc.exe", 1) ' Shell Calculator.

For I = 1 To 5 ' Set up counting loop.

SendKeys I & "{+}", True ' Send keystrokes to Calculator

Next I ' to add each value of I.

AppActivate "Calculator" ' Return focus to Calculator.

SendKeys "%{F4}", True ' Alt+F4 to close Calculator.

End Sub


Sin Function

Sin (rad)

Returns the sine of an angle that is expressed in radians

More:

Example:


Example:

Sub Main ()

pi = 4 * Atn(1)

rad = 90 * (pi/180)

x = Sin(rad)

print x

End Sub


Space Function

Space[$] (number )

Skips a specified number of spaces in a print# statement.

The parameter number can be any valid integer and determines the number of blank spaces.

More:

Example:


Example:

' This sample shows the space function

Sub Main

MsgBox "Hello" & Space(20) & "There"

End Sub


Sqr Function

Sqr(num)

Returns the square root of a number.

The parameter num must be a valid number greater than or equal to zero.

More:

Example:


Example:

Sub Form_Click ()

Dim Msg, Number ' Declare variables.

Msg = "Enter a non-negative number."

Number = InputBox(Msg) ' Get user input.

If Number < 0 Then

Msg = "Cannot determine the square root of a negative number."

Else

Msg = "The square root of " & Number & " is "

Msg = Msg & Sqr(Number) & "."

End If

MsgBox Msg ' Display results.

End Sub


Static Statement

Static variable

Used to declare variables and allocate storage space. These variables will retain their value through the program run

Related Topics: Dim, Function, Sub

More:

Example:


Example:

' This example shows how to use the static keyword to retain the value of

' the variable i in sub Joe. If Dim is used instead of Static then i

' is empty when printed on the second call as well as the first.

Sub Main

For i = 1 to 2

Joe 2

Next i

End Sub

Sub Joe( j as integer )

Static i

print i

i = i + 5

print i

End Sub


Stop Statement

Stop

Ends execution of the program

The Stop statement can be placed anywhere in your code.

More:

Example:


Example:

Sub main ()

Dim x,y,z

For x = 1 to 5

For y = 1 to 5

For z = 1 to 5

Print "Looping" ,z,y,x

Next z

Next y

Stop

Next x

End Sub


Str Function

Str(numericexpr)

Returns the value of a numeric expression.

Str returns a String.

Related topics: Format, Val

More:

Example:


Example:

Sub main ()

Dim msg

a = -1

msgBox "Num = " & Str(a)

MsgBox "Abs(Num) =" & Str(Abs(a))

End Sub


StrComp Function

StrComp( nstring1,string2, [compare] )

Returns a variant that is the result of the comparison of two strings

More:

Example:


Example:

Sub Main

Dim MStr1, MStr2, MComp

       MStr1 = "ABCD":
MStr2 = "today"
' Define variables.

print MStr1, MStr2

MComp = StrComp(MStr1, MStr2) ' Returns -1.

print MComp

MComp = StrComp(MStr1, MStr2) ' Returns -1.

print MComp

MComp = StrComp(MStr2, MStr1) ' Returns 1.

print MComp

End Sub


String Function

String ( numeric, charcode )

String returns a string.

String is used to create a string that consists of one character repeated over and over.

Related topics: Space Function

More:

Example:


Example:

Sub Main

Dim MString

MString = String(5, "*") ' Returns "*****".

MString = String(5, 42) ' Returns "44444".

MString = String(10, "Today") ' Returns "TTTTTTTTTT".

Print MString

End Sub


Sub Statement

Sub SubName [(arguments)]

Dim [variable(s)]

[statementblock]

[Exit Function]

End Sub

Declares and defines a Sub procedures name, parameters and code.

When the optional argument list needs to be passed the format is as follows:

([ByVal] variable [As type] [,ByVal] variable [As type] ]…])

The optional ByVal parameter specifies that the variable is [passed by value instead of by reference (see “ByRef and ByVal” in this manual). The optional As type parameter is used to specify the data type. Valid types are String, Integer, Double, Long, and Varaint (see “Variable Types” in this manual).

Related Topics: Call, Dim, Function

More:

Example:


Tan Function

Tan(angle)

Returns the tangent of an angle as a double.

The parameter angle must be a valid angle expressed in radians.

Related Topic: Atn, Cos, Sin

More:

Example:


Example:

' This sample program show the use of the Tan function

Sub Main ()

Dim Msg, Pi ' Declare variables.

Pi = 4 * Atn(1) ' Calculate Pi.

Msg = "Pi is equal to " & Pi

MsgBox Msg ' Display results.

x = Tan(Pi/4)

MsgBox x & " is the tangent of Pi/4"

End Sub


Text Statement

Text Starting X position, Starting Y position, Width, Height, Label

Creates a text field for titles and labels.

More:

Example:


TextBox Statement

TextBox Starting X position, Starting Y position, Width, Height, Default String

Creates a Text Box for typing in numbers and text

More:

Example:


Time Function

Time[()]

Returns the current system time.

Related topics: To set the time use the TIME$ statement.

More:

Example:


Current Help System: PC-DMIS BASIC (View Core Help)

Example:

Sub Main

x = Time$(Now)

Print x

End Sub


Timer Event

Timer

Timer Event is used to track elapsed time or can be display as a stopwatch in a dialog. The timers value is the number of seconds from midnight.

Related topics: DateSerial, DateValue, Hour, Minute, Now, Second, TimeValue.

More:

Example:


Example:

Sub Main

Dim TS As Single

Dim TE As Single

Dim TEL As Single

TS = Timer

MsgBox "Starting Timer"

TE = Timer

TT = TE - TS

Print TT

End Sub


TimeSerial - Function

TimeSerial ( hour, minute, second )

Returns the time serial for the supplied parameters hour, minute, second.

Related topics: DateSerial, DateValue, Hour, Minute, Now, Second, TimeValue.

More:

Example:


Example:

Sub Main

Dim MTime

MTime = TimeSerial(12, 25, 27)

Print MTime

End Sub


TimeValue - Function

TimeValue ( TimeString )

Returns a double precision serial number based of the supplied string parameter.

Midnight = TimeValue(“23:59:59”)

Related topics: DateSerial, DateValue, Hour, Minute, Now, Second, TimeSerial.

More:

Example:


Example:

Sub Main

Dim MTime

MTime = TimeValue("12:25:27 PM")

Print MTime

End Sub


Trim, LTrim, RTrim Functions

[L| R] Trim (String )

  • Ltrim, Rtrim and Trim all Return a copy of a string with leading, trailing or both leading and trailing spaces removed.

  • Ltrim, Rtrim and Trim all return a string

  • Ltrim removes leading spaces.

  • Rtrim removes trailing spaces.

  • Trim removes leading and trailing spaces.

More:

Example:


Type Statement

Type usertype elementname As typename

[ elementname As typename]

. . .

End Type

Defines a user-defined data type containing one or more elements.

The Type statement has these parts:

Part | Description
Type | Marks the beginning of a user-defined type.
usertype | Name of a user-defined data type. It follows standard variable naming conventions.
elementname | Name of an element of the user-defined data type. It follows standard variable-naming conventions.
subscripts | Dimensions of an array element. You can declare multiple dimensions. (not currently implemented)
typename | One of these data types: Integer, Long, Single, Double, String (for variable-length strings), String * length (for fixed-length strings), Variant, or another user-defined type. The argument typename can't be an object type. End Type Marks the end of a user-defined type.

Once you have declared a user-defined type using the Type statement, you can declare a variable of that type anywhere in your script. Use Dim or Static to declare a variable of a user-defined type. Line numbers and line labels aren't allowed in Type...End Type blocks.

User-defined types are often used with data records because data records frequently consist of a number of related elements of different data types. Arrays cannot be an element of a user defined type in Enable.

More:

Example:


Example:

' This sample shows some of the features of user defined types

Type type1

a As Integer

d As Double

s As String

End Type

Type type2

a As String

o As type1

End Type

Type type3

b As Integer

c As type2

End Type

Dim type2a As type2

Dim type2b As type2

Dim type1a As type1

Dim type3a as type3

Sub Form_Click ()

a = 5

type1a.a = 7472

type1a.d = 23.1415

type1a.s = "YES"

type2a.a = "43 - forty three"

type2a.o.s = "Yaba Daba Doo"

type3a.c.o.s = "COS"

type2b.a = "943 - nine hundred and forty three"

type2b.o.s = "Yogi"

MsgBox type1a.a

MsgBox type1a.d

MsgBox type1a.s

MsgBox type2a.a

MsgBox type2a.o.s

MsgBox type2b.a

MsgBox type2b.o.s

MsgBox type3a.c.o.s

MsgBox a

End Sub


UBound Function

Ubound(arrayname[,dimension])

Returns the value of the largest usable subscript for the specified dimension of an array.

Related Topics: Dim, Global, Lbound, and Option Base

More:

Example:


Example:

' This example demonstrates some of the features of arrays. The lower bound

' for an array is 0 unless it is specified or option base is set it as is

' done in this example.

Option Base 1

Sub Main

Dim a(10) As Double

MsgBox "LBound: " & LBound(a) & " UBound: " & UBound(a)

Dim i As Integer

For i = 1 to 3

a(i) = 2 + i

Next i

Print a(1),a(1),a(2), a(3)

End Sub


UCase Function

Ucase (String )

Returns a copy of String in which all lowercase characters have been converted to uppercase.

Related Topics: Lcase, Lcase$ Function

More:

Example:


Val

Val(string)

Returns the numeric value of a string of characters.

More:

Example:


Example:

Sub main

Dim Msg

Dim YourVal As Double

YourVal = Val(InputBox$("Enter a number"))

Msg = "The number you enered is: " & YourVal

MsgBox Msg

End Sub


VarType

VarType(varname)

Returns a value that indicates how the parameter varname is stored internally.

The parameter varname is a variant data type.

VarType | return values:
Empty | 0
Null | 1
Integer | 2
Long | 3
Single | 4
Double | 5
Currency | 6 (not available at this time)
Date/Time | 7
String | 8

Related Topics: IsNull, IsNumeric

More:

Example:


Example:

If VarType(x) = 5 Then

Print "Vartype is Double" 'Display variable type

End If


Weekday Function

Weekday(date,firstdayof week)

Returns a integer containing the whole number for the weekday it is representing.

Related Topics: Hour, Second, Minute, Day

More:

Example:


Example:

Sub Main()

x = Weekday(#5/29/1959#)

Print x

End Sub


While...Wend Statement

While condition

.

.

.

[StatementBlock]

.

.

.

Wend

While begins the while...Wend flow of control structure. Condition is any numeric or expression that evaluates to true or false. If the condition is true the statements are executed. The statements can be any number of valid Enable Basic statements. Wend ends the While...Wend flow of control structure.

Related Topics: Do...Loop Statement

More:

Example:


Example:

Sub Main

Const Max = 5

Dim A(5) As String

A(1) = "Programmer"

A(2) = "Engineer"

A(3) = "President"

A(4) = "Tech Support"

A(5) = "Sales"

Exchange = True

While Exchange

Exchange = False

For I = 1 To Max

MsgBox A(I)

Next I

Wend

End Sub


With Statement

With object

[STATEMENTS]

End With

The With statement allows you to proeform a series of commands or statements on a particular object without again refering to the name of that object. With statements can be nested by putting one With block within another With block. You will need to fully specify any object in an inner With block to any memeber of an object in an outer With block.

Related Topics: While…Wend Statement and Do Loop

More:

Example:


Example:

' This sample shows some of the features of user defined types and the with

' statement

Type type1

a As Integer

d As Double

s As String

End Type

Type type2

a As String

o As type1

End Type

Dim type1a As type1

Dim type2a As type2

Sub Main ()

With type1a

.a = 65

.d = 3.14

End With

With type2a

.a = "Hello, world"

With .o

.s = "Goodbye"

End With

End With

type1a.s = "YES"

MsgBox type1a.a

MsgBox type1a.d

MsgBox type1a.s

MsgBox type2a.a

MsgBox type2a.o.s

End Sub


Write # - Statement

Write #filenumber [,parameterlist ]

Writes and formats data to a sequential file that must be opened in output or append mode.

A comma delimited list of the supplied parameters is written to the indicated file. If no parameters are present, the newline character is all that will be written to the file.

Related Topics: Open and Print# Statements

More:

Example:


Example:

Sub Main ()

Open "TESTFILE" For Output As #1 ' Open to write file.

userData1$ = InputBox ("Enter your own text here")

userData2$ = InputBox ("Enter more of your own text here")

Write #1, "This is a test of the Write # statement."

Write #1,userData1$, userData2

Close #1

Open "TESTFILE" for Input As #2 ' Open to read file.

Do While Not EOF(2)

Line Input #2, FileData ' Read a line of data.

PRint FileData ' Construct message.

Loop

Close #2 ' Close all open files.

MsgBox "Testing Print Statement" ' Display message.

Kill "TESTFILE" ' Remove file from disk.

End Sub


Year Function

Year(serial# )

Returns an integer representing a year between 1930 and 2029, inclusive. The returned integer represents the year of the serial parameter.

The parameter serial# is a string that represents a date.

If serial is a Null, this function returns a Null.

Related Topics: Date, Date$ Function/Statement, Day, Hour, Month, Minute, Now, Second.

More:

Example:


Example:

Sub Main

MyDate = "11/11/94"

x = Year(MyDate)

print x

End Sub

PC-DMIS


Getting Started - PC-Dmis 4.3 Object Library

PC-Dmis 4.3 Object Library Send comments on this topic. | See Object Hierarchy Chart
Introduction

PC-DMIS's Automation gives you the ability to automate repetitive tasks within PC-DMIS or even to use elements of PC-DMIS functionality, within a custom built application.

PC-DMIS Automation contains these benefits:

    • PC-DMIS Automation is computer independent. You can have a process on one computer automating a process on another computer.
    • PC-DMIS Automation is location independent. You can run automation scripts within PC-DMIS itself, using the BASIC Script Editor or you can run automation scripts in external Visual Basic Editors. In addition, you can run automation scripts across a network.
    • PC-DMIS Automation is Language independent: If you don't know BASIC but are familiar with another programming language, you can configure that programming language to use PC-DMIS's library (the examples and descriptions in this help file, however, are written using the BASIC programming language).

This Automation section contains a detailed list of methods and properties for each PC-DMIS Automation Object. The various objects are listed in alphabetical order. A bold item indicates a default property or method for the object.

To get started with Automation, see the information on the "Getting Started Page" to get a feel for what's needed. For questions beyond the scope of this section, consult a Visual BASIC book on automation.

© Wilcox Associates, Inc. All Rights Reserved.


Getting Started - PC-Dmis 4.3 Object Library

Getting Started

To get started using PC-DMIS automation, consider using this information:

    • Accessing an Object's Properties, Methods and Events
    • Using the Object Browser in Other Editors
    • Sample Automation Scripts
    • Object Hierarchy Chart probe ObjectTips ObjectQualificationSettings ObjectTip Object


Accessing an Object's Properties, Methods and Events

Current Help System: PC-DMIS BASIC (View Core Help)

Accessing an Object's Propreties, Methods, and Events

Objects are external classes that contain methods, properties and events.

Methods: Methods are functions that usually perform actions. This usually return a boolean value to determine whether or not the function succeeded. Methods are analogous to verbs in languages.

Properties: Properties allow you to read or sometime write certain characteristics or attributes of an object or control. Properties are analogous to adjectives in languages.

Events: Events are routines that get called when certain conditions are met. Events differ from methods and properties in that PC-DMIS is the source of the action, instead of the destination. To take advantage of events, the automation controller application must support events. Visual BASIC, for example supports events. Handling events involves declaring an object of the correct type and then adding handling functions for the different events. Currently events are found in only these objects:

    • ApplicationObjectEvents

    • Machine

    • PartProgram

See the "Getting Started" topic for a list of hierarchal objects.

More:

Accessing Event Subroutines

Accessing Methods and Properites

Using the Object Browser in Other Editors


Accessing Event Subroutines

The easiest way to access an object’s event subroutines is by following this procedure.

  1. Access a readily available and robust Visual BASIC editor (such as one that ships with Microsoft’s Word or Excel products).

  2. Select (General) from the Object list in the code window. This allows you to make global variable declarations.

  3. Declare a global variable for your PC-DMIS application as well as your PC-DMIS events. For events, you should use the WithEvents keyword and specify an object that has events. For example these two lines are necessary to define as global variables:

Dim PCDApp As PCDLRN.Application
Dim WithEvents AppEvents As PCDLRN.ApplicationObjectEvents

This code would enable the AppEvents variable in the Object list.

  4. Select your declared variable from the Object list in the code window.

    This enables you to select specific event subroutines from the Procedure list.

  5. From the code window, select an event subroutine from the Procedure list.

    The new subroutine appears in the code window.

  6. Make modifications to the event’s subroutine code as needed. When PC-DMIS meets the specified condition, the event subroutine gets ran along with any code you added.

  7. In your script, be sure to "set" the AppEvents object variable sometime after you "set" the Pcdlrn.Application object. For example, you will need to have these two lines of code somewhere in your script:

Set PCDApp = CreateObject("PCDLRN.Application")
Set AppEvents = PCDApp.ApplicationEvents

Example Script Showing Event Handing

This example script contains code that calls subroutines when certain PC-DMIS events are executed. Inside a blank Excel worksheet, access the Visual Basic Editor and type in the following code. When finished, save the program, then place the cursor inside the Start() subroutine and press F8 to step through the code line by line to see what's happening. Notice that the code within a specific event subroutine is executed when Excel detects that event occurring within PC-DMIS.

' These are global variable declarations

Dim PCDApp As PCDLRN.Application

Dim WithEvents AppEvents As PCDLRN.ApplicationObjectEvents

Sub Start()

' This is the subroutine to run to start the script

HideExcel

End Sub

Private Sub HideExcel()

Dim intAnswer As Integer

intAnswer = MsgBox("Do you want to make Excel invisible? For this test, you should click Yes. It will become visible when you open a part program.", vbYesNo, "Hide Excel?")

If intAnswer = vbYes Then

Application.Visible = False

Else

Application.Visible = True

End If

LaunchPCDMIS

End Sub

Sub LaunchPCDMIS()

Set PCDApp = CreateObject("PCDLRN.Application")

Set AppEvents = PCDApp.ApplicationEvents

PCDApp.Visible = True

End Sub

Private Sub AppEvents_OnOpenPartProgram(ByVal PartProg As PCDLRN.IPartProgram)

' Event subroutine. This activates when you OPEN a part program.

Set PartProg = PCDApp.ActivePartProgram

Application.Visible = True

MsgBox "Part Program " & PartProg.Name & " opened. Excel should also be visible."

End Sub

Private Sub AppEvents_OnStartExecution(ByVal PartProg As PCDLRN.IPartProgram)

' Event subroutine. This activates when you START EXECUTION of the part program.

MsgBox "STARTING EXECUTION OF " & PartProg.Name & ". Click OK to continue."

End Sub

Private Sub AppEvents_OnEndExecution(ByVal PartProg As PCDLRN.IPartProgram, ByVal TerminationType As Long)

' Event subroutine. This activates when you END EXECUTION of the part program.

MsgBox "ENDING EXECUTION OF " & PartProg.Name & ". Click OK to continue."

End Sub


Accessing Methods and Properties

There are two ways to get to an object's methods, properties, and events.

  1. Create objects by their ID

  2. Call the object from an existing object

Whether you're creating an object or calling an object from an existing object, you'll need to first create and then set a pointer to the appropriate object.

Step 1: Declare the pointer variable name for the application by using the "DIM" statement. For example:

Dim App As Object

Step 2: Set the pointer variable to the PCDLRN Application using CreateObject. For example:

Set App = CreateObject("PCDLRN.Application")

Step 3: Declare and set additional pointer variable names for any needed sub objects found within the Application object. For example if you wanted to access commands available for the active part program, you're code would look something like this:

Dim Part As Object

Set Part = App.ActivePartProgram

Dim Cmds As Object

Set Cmds = Part.Commands

Dim Cmd As Object

Set Cmd = Cmds.Add(SET_COMMENT, True)


Using the Object Browser in Other Editors

While the PC-DMIS Basic Script Editor has its uses, it doesn’t have a lot of the visual syntax and other programming aids available to you from other common programs that also support automation.

The Object Browser, available in standard Visual Basic Editors, is essential to getting the proper help when writing automation scripts. It contains all the different objects for any library you have chosen to use in your automation project.

Example Object Browser

To set up the object browser with the appropriate libraries, do the following:

  1. Open Visual Basic (or you can open the VB editor that ships with MS Word or MS Excel)

  2. In Visual Basic, select the References menu item. In VB5 this is Project | References. (In Excel or Word’s VB Editor, select Tools | References).

  3. The References dialog box appears. Items that are checked are libraries already included currently.

  4. Scroll down to PC-DMIS X.X Object Library (where X.X is your library version type and select the check box&emdash;this should be similar to your version of PC-DMIS).

  5. Click OK.

  6. Access the Object Browser (press F2 within the VB Editor). In the list at the top it should say <All Libraries>. From the list, select the PCDLRN library.

You can now browse through all the objects and view their properties, methods, and events. Most of the objects have properties and methods in the PC-DMIS object library. Only a few objects have events.

Additionally, when writing code, your Visual Basic Editor will now contain the visual syntax aids for the various PC-DMIS objects and commands.

Note: If new objects, methods, properties, or events are added, the Object Browser will most likely contain the new information first and will subsequently be more up to date than this help file--another good reason to use the Object Browser when coding your scripts.


Sample Automation Scripts

Below are some sample automation scripts that will demonstrate some of the necessary components needed to get started automating PC-DMIS.

Testing the Sample Scripts

If you want to test these scripts, be aware that sometimes copying and pasting the code from these examples into the Basic Script Editor may cause some lines to wrap that shouldn't wrap and may insert white space characters that the Editor doesn't recognize. It is recommended that you type in these scripts if you find that copying and pasting doesn't function properly.

Note: Notice in the examples below that you must declare and set the proper automation objects before you can access and use PC-DMIS's automation methods and properties. The "Accessing an Object's Properties, Methods and Events" topic will be of assistance to you as you create your own scripts.

More:

Sample Automation Script 1

Sample Automation Script 2

Sample Automation Script 3

Sample Automation Script 4


Sample Automation Script 1

The following example first uses PC-DMIS code to receive an integer value from the user and assigns it to the V1 variable.

C1=COMMENT/INPUT,Please type an integer value.
ASSIGN/V1 = INT(C1.INPUT)
COMMENT/OPER,BEFORE SCRIPT: Variable is:
,V1

It then calls a BASIC script named TEST2.BAS.

CS1=SCRIPT/FILENAME= D:\PROGRAM FILES\PCDMIS35\TEST2.BAS
FUNCTION/Main,,
STARTSCRIPT/
ENDSCRIPT/

Here is TEST2.BAS:

Sub Main
Dim App As Object
Set App = CreateObject ("PCDLRN.Application")
Dim Part As Object
Set Part = App.ActivePartProgram
Dim Var As Object
Set Var = Part.GetVariableValue ("V1")
Dim I As Object
If Not Var Is Nothing Then
Var.LongValue = Var.LongValue + 1
Part.SetVariableValue "V1", Var
MsgBox "V1 is now: " & Var
Else
Msgbox "Could Not find variable"
End If
End Sub

This script takes V1 variable and, using the GetVariableValue and SetVariableValue automation methods, increments the V1 by one and then sets the new value for V1 in the part program.

PC-DMIS then displays the changed variable in an operator comment.

COMMENT/OPER,AFTER SCRIPT: Variable is now
,V1

Note: PC-DMIS variables only hold values during execution; at learn time PC-DMIS variables have a value of zero. The GetVariableValue and SetVariableValue methods only change a variable's value during the script's execution. If you want to permanently change a value of a variable inside PC-DMIS, you should use the PutText method instead.


Sample Automation Script 2

The following script receives an operator name from the user and then inserts an COMMENT/OPER command into the Edit window for the currently open part program, displaying the name of the operator.

PC-DMIS must be running with an open part program in the background.

Sub Main
'Get operator Name And assign it To variable: N$.
N$ = InputBox$("Please enter your name:", "Operator", "", 200, 175)

'The following section adds a comment cmd to the part program
Dim App As Object

'Get the pointer to the PC-DMIS application
Set App = CreateObject("PCDLRN.Application")
Dim Part As Object

'Get the pointer to the current part program
Set Part = App.ActivePartProgram
Dim Cmds As Object

'Get the pointer to the set of commands In the part program
Set Cmds = Part.Commands
Dim Cmd As Object

'Add a COMMENT command
Set Cmd = Cmds.Add(SET_COMMENT, True)

'Set the comment's type to REPT
retvaltype = Cmd.PutText("REPT", COMMENT_TYPE, 0)

'Put the string held in variable N$ into the comment's text
retvaltext = Cmd.PutText(N$, COMMENT_FIELD, 1)

'Redraws the COMMENT command so that the applied changes are applied to the part program
Cmd.ReDraw
End Sub


Sample Automation Script 3

This script is more involved than the previous examples as it involves dialog box creation and reading and writing data. Specifically, it recreates a customized version of the Comment dialog box found in PC-DMIS, showing that you can create a customized dialog box that matches your exact specifications to perform specific tasks.

My Comment dialog box

This script functions nearly identically to the Comment dialog box, with one exception. It allows you to change and store the default comment text that appears, thereby demonstrating how to write and read text strings to and from a file.

Sub Main

Dim App As Object

Set App = CreateObject ("PCDLRN.Application")

Dim Part As Object

Set Part = App.ActivePartProgram

Dim Cmds As Object

Set Cmds = Part.Commands

Dim Cmd As Object

Dim strText As String

Dim optVal As Integer

Dim lngCommentType As Long

Dim buttonval As Integer

Dim strDefaultText As String

Dim strLine As String

Start: ' This label is used to quickly redisplay the Dialog after changing the default text.

' Reads in stored comment text.

' This uses text from a text file named default_comment.txt and reads it.

' This creates the file to read from and write to, if it doesn't exist. If it exists, it simply opens the file and then

' closes it.

Open "default_comment.txt" For Append As #1 ' This creates it if it doesn't exist.

Close #1

' This opens the file for writing, and puts the info into strLine variable

Open "default_comment.txt" For Input As #1

Do While Not EOF(1)

Line Input #1, strLine

Loop

If len(strLine)>0 Then

' Removes automatic quotation marks

strLine = mid(strLine,2,len(strLine)-3)

strDefaultText = strLine

Else

' If there isn't any default value to read in, it uses and sets this

strDefaultText = "Type your comment text here."

Open "default_comment.txt" For Output As #2

Write #2, strDefaultText

Close #2

End If

Close #1 ' Closes the Open file handler

'Creates the dialog box

Begin Dialog DLG_CUSTOM_COMMENT 106,15, 143, 177, "My Comment"

OptionGroup .GROUP_1

OptionButton 20,12,48,24, "Operator"

OptionButton 20,28,40,24, "Report"

OptionButton 20,44,48,24, "Document"

OptionButton 76,12,32,24, "Input"

OptionButton 76,28,40,24, "Yes/No"

OptionButton 76,44,44,24, "ReadOut"

GroupBox 12,4,116,68, "Comment Type"

TextBox 12,88,116,44, .EditBox_1

Text 12,76,56,12, "Comment Text"

OKButton 20,160,44,12

CancelButton 72,160,52,12

PushButton 20,140,104,12, "Change Default Text", .PushButton_1

End Dialog

Dim dlg1 As DLG_CUSTOM_COMMENT

dlg1.EditBox_1 = strDefaultText

buttonval = Dialog (dlg1)

strCommentText = dlg1.EditBox_1

optValue = dlg1.GROUP_1

' If OK is clicked, run this routine

If buttonval = -1 Then

optVal = dlg1.GROUP_1

' If it's an Operator Comment

If optVal = 0 Then

' strCommentType is For testing only.

strCommentType = "Operator"

' This variable determines the Type of comment

lngCommentType = 0

End If

' If it's a Report Comment

If optVal = 1 Then

strCommentType = "Report"

lngCommentType = 2

End If

' If it's a Document Comment

If optVal = 2 Then

strCommentType = "Document"

lngCommentType = 4

End If

' If it's a a Input Comment

If optVal = 3 Then

strCommentType = "Input"

lngCommentType = 3

End If

'If it's a Yes/No Comment

If optVal = 4 Then

strCommentType = "Yes/No"

lngCommentType = 5

End If

' If it's a Readout Comment

If optVal = 5 Then

strCommentType = "Readout"

lngCommentType = 6

End If

' This statement adds the initial comment

Set Cmd = Cmds.Add(SET_COMMENT, True)

' This statement changes the comment Type To lngCommentType

Cmd.SetToggleString lngCommentType, COMMENT_TYPE, 0

' This statement displays the comment text.

Cmd.PutText strCommentText, COMMENT_FIELD, 1

' Redraws the Edit window

Part.Refreshpart

' If the pushbutton to set new default text is clicked, then collect and write the new default

ElseIf buttonval = 1 Then

strDefaultText = InputBox ("Type the new default comment text","Change Default Comment Text","")

Open "default_comment.txt" For Output As #1

Write #1, strDefaultText

Close #1

GoTo Start ' After setting the new default comment text, the program flow goes the Start: label

' If Cancel is clicked...

Else

'...the dialog closes without doing anything

End If

End Sub


Sample Automation Script 4

This script shows how to pass a variable's ID into a script from a PC-DMIS part program, how to locate the passed in ID in the script, and then how to modify the right side of the ASSIGN command associated with the ID.

Sample Part Program Code:

This script takes one parameter, a variable's ID, supplied by your part program. When you execute this example part program code within PC-DMIS, an Input comment will appear, asking you for the variable's ID to change. Once you type that valid ID, PC-DMIS passes that ID into a script called SETASSIGNMENTVALUE.BAS.

START =LABEL/

C1 =COMMENT/INPUT,NO,'Type a variable's id: V1, V2, V3, V4, or V5.'

IF/C1.INPUT <> "V1" AND C1.INPUT <> "V2" AND C1.INPUT <> "V3" AND C1.INPUT

<> "V4" AND C1.INPUT <> "V5"

COMMENT/OPER,NO,You did not enter a correct variable ID.

GOTO/START

END_IF/

ELSE/

CS1 =SCRIPT/FILENAME= D:\MYAUTOMATIONSCRIPTS\SETASSIGNMENTVALUE.BAS

FUNCTION/Main,SHOW=YES,ARG1=C1.INPUT,,

STARTSCRIPT/

ENDSCRIPT/

ASSIGN/V1 = ""

ASSIGN/V2 = ""

ASSIGN/V3 = ""

ASSIGN/V4 = ""

ASSIGN/V5 = ""

END_ELSE/

SETASSIGNMENTVALUE.BAS Code:

Below is the code for SETASSIGNMENTVALUE.BAS. Once the script opens, it takes the passed in ID, cycles through all the commands, and when it finds the matching ID, it displays an input box asking you to specify a new value for the command:

Sub Main (strID As String)

Dim App As Object

Set App = CreateObject ("PCDLRN.Application")

Dim Part As Object

Set Part = App.ActivePartProgram

Dim Cmds As Object

Set Cmds = Part.Commands

Dim Cmd As Object

Dim FCCmd As Object

Dim VarCommentValue As Variant

VarCommentValue = InputBox("Type a Value for " & strID & ". (Surround what you Type With quotation marks To make it a String.)","Set Assignment Value","""Type Something Here""")

For Each Cmd In Cmds

If Cmd.TypeDescription = "Assignment" Then

Set FCCmd = Cmd.FlowControlCommand

If FCCmd.GetLeftSideOfExpression = strID Then

FCCmd.SetRightSideOfAssignment VarCommentValue

End If

End If

Next Cmd

End Sub


Project Overview

Project Overview

Description

PC-Dmis 4.3 Object Library

Classes

Class Module | Description
ActiveTip | The ActiveTip object gives access to the properties of the PC-DMIS Set Active Tip command.
AlignCmnd | Alignment Command AlignCmnd objects are created from more generic Command objects to pass alignment information back and forth.
Application PC-Dmis Application Object

The Application object represents the PC-DMIS application.

ApplicationObjectEvents | The ApplicationObjectEvents object provides you with a series of events that get called when the PC-DMIS application meets certain conditions.
ApplicationSettings | The ApplicationSettings object is a class that contains various properties and methods that allow you to work with PC-DMIS settings.
ArrayIndex | The ArrayIndex object is used to set up multi-dimensional feature arrays in PC-DMIS. Methods are provided to add, remove, or edit array upper and lower bounds for array indices.
Attach | The Attach object attaches part programs to the current part program. The current part program can then access objects from the attached part programs.
Autotrigger | The Autotrigger object automatically takes hits when the probe enters a specified zone.
BasicScan | BasicScan objects are created from more generic Command objects to pass information specific to the scan command back and forth. At present only DCC basic scans are user accessible.
CadModel | The CadModel object allows you to work with the imported CAD model in PC-DMIS' Graphics Display window.
CadPointOnSurface | CadPointOnSurface Object
CadPointsOnSurface | Object for the collection of polylines on surface
CadPolyLineOnSurface | CadPolyLineOnSurface Object
CadPolyLinesOnSurface | Object for the collection of polylines on surface
CadWindow | Cad Window Object The CadWindow object is the one and only cad window for a part program.
CadWindows Cad Windows Collection Object

The CadWindows object is an object containing a collection of CadWindow objects currently available to a part program.

Calibration | The Calibration object allows for tip calibration during part program execution. This object is placed into a part program through the Add method of the Commands object and obtained from the Command object via the CalibrationCommand property.
Color | Reporting Color Object The Color object is used to automate color settings used in PC-DMIS's report templates.
Colors Reporting Colors collection

The Colors object allows you to work with collections of Color objects. These are used to automate color settings used in PC-DMIS's report templates.

Command PartProgram Command Object

The Command object represents a single command in PC-DMIS.

Commands | Part Program Commands Collection Object The Commands object contains all the Command objects in a part program.
Comment | The Comment object gives access to the properties of the PC-DMIS Comment command.
ControlPoint | With the ControlPoint object you can insert control point locations. These locations interrupt the normal scan and alter scan speed, point density or both for defined portions of the scan.
DataType | Command Data Type Information Object The DataType object allows you to return objects of information about a particular data type or field.
DataTypes | Command Data Type Information Collection Object The DataTypes object allows you to return objects of varying data types.
DimData Dimension data object

The DimData object is similar to a type defined in the Example below. You can use it to pass dimension information in automation functions that accept that type.

DimensionCmd | Dimension Command Object DimensionCmd objects are created from more generic Command objects to pass information specific to the dimension command back and forth.
DimFormat | The DimFormat object gives access to the properties of the PC-DMIS Dimension Format command. For additional information on dimensions, see the topic "Dimension Options" in the PC-DMIS documentation.
DimInfo | The DimInfo object gives access to the properties and methods of the PC-DMIS Dimension Information command. See "DIMINFO Command" in the PC-DMIS documentation for additional information.
DispMetaFile | The DispMetaFile object gives access to the comment properties of the PC-DMIS Display Metafile command.
DmisDialog

The DmisDialog object represents a PC-DMIS modeless dialog and can be used to determine if the dialog is still visible.

DmisMatrix | The DmisMatrix object is a four by three array of doubles modeled after the transformation matrices used in PC-DMIS. The first set of three doubles represent the matrix offset. The second set of three doubles represent the X axis. The third set of three doubles represent the Y axis. The fourth set of three doubles represent the Z axis.
EditWindow | Edit window object The EditWindow object represents the Edit window associated with a part program. It is always present, although sometimes it is invisible. When in Command mode, the Edit window lists all the commands in the part program.
ExecutedCommands | Part Program Executed Commands Collection Object The ExecutedCommands object acts much like the Commands object except that it only contains a collection of the executed commands from the last part program execution, while the Commands object contains all the commands in the part program.
ExternalCommand | The ExternalCommand object causes PC-DMIS to launch an external program during part program execution. This object has one property: The command property. This property consists of a string value used to execute the external command.
FeatCmd | Feature Command Object FeatCmd are created from more generic Command objects to pass information specific to the feature command back and forth.
FeatData Feature Data Object

The FeatData object is similar to a type as defined in the Example below.

It is be used to pass feature data in automation functions that accept this type

FileIO | The FileIO object is used to access the PC-DMIS File I/O object.
FlowControlCmd | FlowControlCmd objects are created from more generic Command objects to pass information specific to the flow control command back and forth.
FPanel | The FPanel object contains properties that allow you to work with an F-Panel controller and interface.
LabelControls | The LabelControls object gives you access to a variety of controls such as buttons, text boxes, and other items that you can add to, remove, and otherwise manipulate on a label template.
LabelTemplate | The LabelTemplate object allows you to get or set various settings for a label template.
LabelTemplates

The LabelTemplates object contains all open label templates in PC-DMIS's Label Template editor.

LEAPFROG

The Leapfrog object contains three leapfrog properties that will allow you to define how to use PC-DMIS's Leapfrog option (available in PC-DMIS Versions 3.0 and above) to translate along a part as well as the numbers of hits to use for each feature.

For information on Leapfrog, see the "Performing a LeapFrog Operation” topic in the PC-DMIS Help File.

LoadMachine | The LoadMachine object gives access to the machine name property of the PC-DMIS Load Machine command.
LoadProbe | The LoadProbe object gives access to the filename property of the PC-DMIS Load Probe command.
Machine Machine (CMM or Offline) Object

The Machine object represent a CMM, or a virtual off-line "machine". The Machine objects are contained in the Machines collection.

The Machine object is primarily an event source.

Machines | The Machines object is the collection of all Machine objects currently available in PC-DMIS. Each Machine object is bound to exactly one PartProgram object, and vice versa. Use Machines(index) where index is the index number or on-line machine’s name to return a single Machine object.
MasterSlaveDlg | The MasterSlaveDlg object gets called when the PartProgram.MasterSlaveDlg method is used.
ModalCmd | Modal Command Objects of type AlignCmnd are created from more generic Command objects to pass information specific to the modal command back and forth.
MoveCmd | Move Command Object Objects of type MoveCmd are created from more generic Command objects to pass information specific to the move command back and forth.
OldBasic | Object providing access to the previous basic command set These PC-DMIS OldBasic functions were made available in previous version of PC-DMIS basic and are provided here, listed in alphabetical order, for backwards compatibility.
OPTIONPROBE | The OPTIONPROBE object provides support for the Optional Probe command.
OptMotion | The OptMotion command object is used to change optional motion settings for the PC-DMIS probe motion command object.
Page | This object contains information about a specific page in the Report window.
Pages | This object contains a collection of the Page objects that appear in the Report window.
PartProgram | PC-Dmis Part Program Object The PartProgram object represents a part program currently available in PC-DMIS. This is the main object used to manipulate part programs.
PartPrograms Object for the collection of open part programs

The PartPrograms object contains all the open part programs in PC-DMIS.

PartProgramSettings | The PartProgramSettings object allows you to get or set various part program settings.
PictureData | Picture Data Object
PointData Point Data Object

probe | Probe Object The Probe object provides information about a given probe description file. It also allows you to manipulate the Probe dialog in PC-DMIS.
Probes | Probes collection object The Probes object is the collection of all Probe objects currently available to a part program.
QualificationSettings | The QualificationSettings object specifies how to calibrate your probe. The calibration process tells PC-DMIS the location and diameter of the probe tip. For more information on calibrating the probe, see the "Defining Probes" topic in the PC-DMIS help file.
QuickStart
QuickStartAddedCommands
QuickStartStep
QuickStartSteps
QuickStartTask
RegistrySetting
RegistrySettings
ReportControls | The ReportControls object gives you access to a variety of controls such as buttons, text boxes, and other items that you can add to, remove, and otherwise manipulate on a particular section of a report template.
ReportData

The ReportData object lets you access data sent to reports during the EventReportData event.

ReportTemplate | The ReportTemplate object allows you to get or set various settings for a report template.
ReportTemplates

The ReportTemplates object contains all open report templates in PC-DMIS's Report Template editor.

ReportWindow | The ReportWindow object allows you to get or set various settings for the Report window.
Scan | Scan objects are created from more generic Command objects to pass information specific to the scan command back and forth. At present only DCC and Manual scans are user accessible.
Section | The Section object lets you manipulate a particular section from the collection of available Selections used by a report template.
Sections

The Sections object contains a collection of all existing Section tabs for a given report template in PC-DMIS's Report Template editor.

STATISTICS | The Statistics object gives access to the properties and data members of the PC-DMIS Statistics command.
Target
Targets
TempComp | The TempComp object gives access to the properties of the PC-DMIS Temperature Compensation command. For additional information about Temperature Compensation, see "Compensating for Temperature" in the "Setting Your Preferences" section of the PC-DMIS Help File.
Tip | Probe Tip Object The Tip object describes a single tip of a probe. All of its properties are read-only.
Tips | The Tips object is the collection of all Tip objects for a Probe object. The Probe object that the Tips stores Tip objects for is contained in the Parent property.
tool | Probe Calibration Tool Object The Tool object represents a single probe calibration tool.
Tools | Probe Calibration Tools Collection The Tools collection object contains the tools available to the parent PartProgram object.
TRACEFIELD | The Tracefield object gives access to the name and value properties of the PC-DMIS Tracefield command. For additional information on this command see "Using Trace Field" in the "Tracking Statistical Data" section of the PC-DMIS documentation.
tutorhit
Variable | PC-Dmis Variable Object
VariableArray

Public Enumerations

Enumeration Description
AUTOVECTORTYPES
BSBOUNDCOND_ENUM
BSCANHIT_ENUM
BSCANMETH_ENUM
BSCANNMODE_ENUM
BSCANOPMODE_ENUM
BSCTRLPT_ENUM
BSF_ENUM
CATCHTYPE
CREATEIDTYPE
DATA_TYPE_TYPES
DCCMODE
DIMAXISTYPE
DIMFORMATFLAG
DIMFORMATTYPE
EDGE_MEASURE_TYPES
ENUM_ALIGN_WORKPLANE
ENUM_AXIS_TYPE
ENUM_BEST_FIT_MATH_TYPES
ENUM_BITMAP_LAYOUT
ENUM_CAD_COLLECTIONS
ENUM_CADPRINTOPTIONS
ENUM_CALIBRATION_EXECUTE_MODE
ENUM_COLOR_SECTION
ENUM_DIM_AXISTYPE
ENUM_DIM_OUTPUTTYPE
ENUM_DIM_PERP_PARALLEL
ENUM_DIM_PROF_TYPE
ENUM_DIM_RADIUS_TYPE
ENUM_DIM_TP_MATERIAL_CONDITION
ENUM_DIM_TP_MODIFIER
ENUM_DIM_TP_USE_AXIS
ENUM_DINFO_FIELD_TYPES
ENUM_DINFO_LOC_AXES
ENUM_DINFO_TP_AXES
ENUM_DMIS_OUTPUT_THEOS
ENUM_DMIS_OVERWRITE
ENUM_DTYPE_GETDBTYPE
ENUM_DTYPE_GETVARIABLETYPE
ENUM_ERROR_MODES
ENUM_ERROR_TYPES
ENUM_FEATREF_TYPES
ENUM_FEATURE_TYPES
ENUM_FIELD_DATA_TYPES
ENUM_FIELD_TYPES
ENUM_FILE_IO_TYPES
ENUM_FILE_OPEN_TYPES
ENUM_FILTER_TYPES
ENUM_GENERIC_ALIGN
ENUM_GENERIC_DISPLAY
ENUM_GENERIC_TYPES
ENUM_HATCH_STYLE
ENUM_MASTERSLAVEDIALOG_MEASUREARM
ENUM_MASTERSLAVEDIALOG_MEASUREDCC
ENUM_PAGE_FORMAT
ENUM_PAGE_ORIENTATION
ENUM_PCD_COMMENT_TYPES
ENUM_PCD_ON_OFF
ENUM_PCD_STAT_TYPES
ENUM_PCDMSG_RETVALS
ENUM_PCDMSG_TYPES
ENUM_PLANE_TYPE
ENUM_QUAL_CREATE_REPLACE
ENUM_REPORT_TEMPLATE_OBJECTS
ENUM_RMEAS_MODE
ENUM_RMEAS_MODE_NEW
ENUM_SCAN_INOUT_TYPES
ENUM_STAT_NAME_TYPES
ENUM_TIPTYPES
ENUM_TOOL_MOVED
ENUM_TRANSFORMATION_TYPES
ENUM_VISION_TARGET_EDGE_SELECTION
ENUM_VISION_TARGET_FOCUS_RANGE
ENUM_VISION_TARGET_POINT_DENSITY
ENUM_VISION_TARGET_TYPE
ERRORMODES
ERRORTYPES
EVALUATION_TYPES
FDATA_COORDSYS
FDATA_DATASET
FDATA_TYPES
FHITDATA_TYPES
FPOINT_TYPES
FVECTOR_TYPES
GETIDTYPE
GUESSTYPE
HIGH_POINT_SEARCH_MODES
IJKTYPES
ITERATEFLAGS
MOVEDIRECTION
MOVETYPE
OBTYPE

The Object Type, or OBTYPE, is a special member of the Application (or PCDLRN) object. It contains several constant values tied to enumerations. You can use these values when working with the Commands.Add method and the Command.Type property.

The following list shows the available OBTYPE constants and their equivalent enumerations. These enumerated values are of type LONG:

PAXISTYPE
PCDBAUD
PCDCOMMENT
PCDDATABITS
PCDDIMTYPES
PCDFILEPRINTFORMAT
PCDGETPOINTSTYPES
PCDHANDSHAKE
PCDMEASTHEO
PCDONOFF
PCDPARITY
PCDPRINTFILEMODE
PCDPRINTLOC
PCDREPORTSETTINGS
PCDSCANDIR1
PCDSCANDIR2
PCDSCANHITFLAG
PCDSCANHITTYPE
PCDSCANTECHNIQUE
PCDSCANVECTOR
PCDSCANVECTORSURF
PCDSTARTDIMFLAGS
PCDSTARTFEATFLAGS
PCDSTARTFEATTYPES
PCDSTARTSCANFLAGS
PCDSTARTSCANTYPES
PCDSTATSFLAGS
PCDSTOPBITS
PCDYESNO
QUALIFICATION_SETTINGS_MODE
RPROGOPTIONSTYPE
RPROGVALUESTYPE
RS_ACCESS
RS_GROUP
TOOLTYPES
UNITTYPE
VARIABLE_TYPE_TYPES
WAXISTYPE
WPLANETYPE
WPROGOPTIONSTYPE
WPROGVALUESTYPE
XYZTYPES


ActiveTip Object

ActiveTip Object
See Also Members

Description

The ActiveTip object gives access to the properties of the PC-DMIS Set Active Tip command.

See Also

ActiveTip Members


ActiveTip Object Members

ActiveTip ObjectMembers
See Also Overview

Public Methods

Public Method GetShankVector | Gets the shank vector of the tip
Public Method SetShankVector | Sets the shank vector of the tip

Public Properties

Public Property Angle | Read/Write: Angle of tip Double value representing the rotation angle of the tip transformation matrix.
Public Property TipID | Read/Write: ID of the tip String value representing the ID of the tip to be made active.

See Also

ActiveTip Overview


GetShankVector Method

GetShankVector Method
See Also
I
Required Long variable that receives the I component of the shank vector.
J
Required Long variable that receives the J component of the shank vector.
K
Required Long variable that receives the K component of the shank vector.

Description

Gets the shank vector of the tip

Syntax

Visual Basic
Public Function GetShankVector( _
   ByRef I As Double, _
   ByRef J As Double, _
   ByRef K As Double _
) As Boolean

Parameters

I
Required Long variable that receives the I component of the shank vector.
J
Required Long variable that receives the J component of the shank vector.
K
Required Long variable that receives the K component of the shank vector.

Return Type

Boolean value representing whether the call successfully retrieved the values or not.

See Also

ActiveTip Object


SetShankVector Method

SetShankVector Method
I
Required Long used to set the I component of the shank vector.
J
Required Long used to set the J component of the shank vector.
K
Required Long used to set the K component of the shank vector.

Description

Sets the shank vector of the tip

Syntax

Visual Basic
Public Function SetShankVector( _
   ByVal I As Double, _
   ByVal J As Double, _
   ByVal K As Double _
) As Boolean

Parameters

I
Required Long used to set the I component of the shank vector.
J
Required Long used to set the J component of the shank vector.
K
Required Long used to set the K component of the shank vector.

Return Type

Boolean value representing whether the call successfully set the shank vector values.

See Also

ActiveTip Object


Angle Property

Angle Property

Description

Read/Write: Angle of tip Double value representing the rotation angle of the tip transformation matrix.

Property type

Read-write property

Syntax

Visual Basic
Public Property Angle() As Double

Return Type

Read/Write Double

See Also

ActiveTip Object


TipID Property

TipID Property

Description

Read/Write: ID of the tip

String value representing the ID of the tip to be made active.

Property type

Read-write property

Syntax

Visual Basic
Public Property TipID() As String

Return Type

Read/Write String

See Also

ActiveTip Object


AlignCmnd Object

AlignCmnd Object
See Also Members

Description

Alignment Command AlignCmnd objects are created from more generic Command objects to pass alignment information back and forth.

Object Model

See Also

AlignCmnd Members


AlignCmnd Object Members

AlignCmnd ObjectMembers
See Also Overview

Public Methods

Public Method AddBestFitFeat | Adds best fit feature to BF3D or BF2D alignments
Public Method AddLevelFeat | Adds level feature to iterative alignment
Public Method AddOriginFeat | Adds origin feature to iterative alignment
Public Method AddRotateFeat | Adds rotation feature to iterative alignment
Public Method CalculateDeviation | Returns deviation value and vector for a feature
Public Method CalculateMatrices | Forces immediate calculation of alignment matrices Forces the immediate calculation of alignment matrices.
Public Method CalculateStatistics | Returns the mean and standard deviation
Public Method GetBFIterations | Returns the number of bestfit iterations
Public Method GetFeatureIdByIndex | Returns the feature id

Public Properties

Public Property AboutAxis | Read/Write: The axis about which alignment is rotated Represents the axis about which the alignment object rotates.
Public Property Angle | Read/Write: Point data object with angle values for BF3D and BF2D alignments Represents the offset angles of a 3D or 2D alignment.
Public Property AverageError | Read/Write: Average Error setting for Iterative Alignments Represents whether or not error averaging is used during the iterative alignment.
Public Property AXIS | Read/Write: The alignment axis Represents the axis that the alignment object uses.
Public Property BFOffset | Read/Write: Point data object with best fit offsets for BF3D and BF2D alignments Represents the offsets of a 3D or 2D alignment.
Public Property CadToPartMatrix | Read Only: Returns a DmisMatrix object representing the cad to part matrix for the alignment Represents the matrix used to transform points between the cad and part alignment systems.
Public Property ExternalFileID | Read/Write: External filename for recalling external alignments Represents the external filename for recalling external alignments.
Public Property ExternalID | Read/Write: ID of External Alignment Represents the external ID.
Public Property FeatID | Read/Write: Feature referenced by the alignment Represents the first (or only) feature ID used by this alignment object.
Public Property FeatID2 | Read/Write: Second referenced alignment feature Represents the second feature ID used by this alignment object.
Public Property FindCad | Read/Write: Find Cad setting for BF3D and BF2D alignments Represents the FindCad property status of this best fit alignment object.
Public Property ID | Read/Write: Id of the alignment Represents the ID of this alignment object.
Public Property InitID | Read/Write: Id of initial/basic alignment Represents the intial ID of this alignment object. The intial ID is the ID of the alignment to recall before modifying it with this alignment.
Public Property IterativeLevelAxis | Read/Write: Level Axis for Iterative Alignment Represents the level axis for an iterative alignment.
Public Property IterativeOriginAxis | Read/Write: Origin Axis for Iterative Alignment Represents the origin axis for an iterative alignment.
Public Property IterativeRotateAxis | Read/Write: Rotate Axis for Iterative Alignment Represents the rotate axis for an iterative alignment.
Public Property MachineToPartMatrix | Read Only: Returns a DmisMatrix object representing the machine to part matrix for the alignment Represents the matrix used to transform points between the machine and part alignment systems.
Public Property MeasAllFeat | Read/Write: Measure all features once setting for iterative alignment Represents the "Measure All Features" property of this iterative alignment object.
Public Property MeasAllFeatAlways | Read/Write: Measure All Features Always setting for iterative alignments Represents the "Measure All Features Always" property of this iterative alignment object.
Public Property NumInputs | Read Only: Number of inputs for BF3D, BF2D, or Iterative Alignments Returns the number of inputs to this alignment object. Read-only Long.
Public Property Offset | Read/Write: Alignment offset value Represents the offset property of this offset alignment object.
Public Property Parent | Read Only: Returns parent command object Returns the parent Command object. Read-only.
Public Property PointTolerance | Read/Write: Point Tolerance value for BF3D, BF2D, or Iterative alignments Represents the "Point Tolerance" property of this alignment object.
Public Property RepierceCad | Read/Write: Repierce Cad setting for Iterative Alignments Represents whether or not to repierce the cad model during the execution of this iterative alignment object.
Public Property UseBodyAxis | Read/Write: Use body axis setting for Iterative Alignments Represents whether or not to use the "Body Axis” method during the calculation of this iterative alignment object.
Public Property Workplane | Read/Write: Workplane setting for BF2D and Iterative Alignments Represents the workplane of this alignment object. It can take the values PCD_XPLUS, PCD_XMINUS, PCD_YPLUS, PCD_YMINUS, PCD_ZPLUS, and PCD_ZMINUS.

See Also

AlignCmnd Overview


AddBestFitFeat Method

AddBestFitFeat Method
ID
Required String that is the ID of the feature to add to the level set.
Tolerance
Required Double that is the tolerance to associate with ID.

Description

Adds best fit feature to BF3D or BF2D alignments

Syntax

Visual Basic
Public Function AddBestFitFeat( _
   ByVal ID As String, _
   ByVal Tolerance As Double _
) As Boolean

Parameters

ID
Required String that is the ID of the feature to add to the level set.
Tolerance
Required Double that is the tolerance to associate with ID.

Return Type

This method returns a Boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

This function only has an effect on objects of type BF2D_ALIGN and BF3D_ALIGN. On objects of these types, it adds the feature with the ID ID to the set of best fit features with tolerance tolerance. On objects of other types, it does nothing.

See Also

AlignCmnd Object | Type Property


AddLevelFeat Method

AddLevelFeat Method
ID
Required String that is the ID of the feature to add to the level set.

Description

Adds level feature to iterative alignment

Syntax

Visual Basic
Public Function AddLevelFeat( _
   ByVal ID As String _
) As Boolean

Parameters

ID
Required String that is the ID of the feature to add to the level set.

Return Type

This method returns a boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

This function only has an effect on objects of type ITER_ALIGN. On objects of this type, it adds the feature with the ID ID to the set of level features. On objects of other types, it does nothing.

See Also

AlignCmnd Object | Type Property


AddOriginFeat Method

AddOriginFeat Method
ID
Required String that is the ID of the feature to add to the origin set.

Description

Adds origin feature to iterative alignment

Syntax

Visual Basic
Public Function AddOriginFeat( _
   ByVal ID As String _
) As Boolean

Parameters

ID
Required String that is the ID of the feature to add to the origin set.

Return Type

This method returns a boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

This function only has an effect on objects of type ITER_ALIGN. On objects of this type, it adds the feature with the ID ID to the set of origin features. On objects of other types, it does nothing.

See Also

AlignCmnd Object | Type Property


AddRotateFeat Method

AddRotateFeat Method
ID
Required String that is the ID of the feature to add to the Rotate set.

Description

Adds rotation feature to iterative alignment

Syntax

Visual Basic
Public Function AddRotateFeat( _
   ByVal ID As String _
) As Boolean

Parameters

ID
Required String that is the ID of the feature to add to the Rotate set.

Return Type

This method returns a boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

This function only has an effect on objects of type ITER_ALIGN. On objects of this type, it adds the feature with the ID ID to the set of rotate features. On objects of other types, it does nothing.

See Also

AlignCmnd Object | Type Property


CalculateDeviation Method

CalculateDeviation Method
Item
deviation_before
ijk_before
deviation_after
ijk_after

Description

Returns deviation value and vector for a feature

Syntax

Visual Basic
Public Function CalculateDeviation( _
   ByVal Item As Long, _
   ByRef deviation_before As Double, _
   ByRef ijk_before As Double, _
   ByRef deviation_after As Double, _
   ByRef ijk_after As Double _
) As Boolean

Parameters

Item
deviation_before
ijk_before
deviation_after
ijk_after

See Also

AlignCmnd Object


CalculateMatrices Method

CalculateMatrices Method

Description

Forces immediate calculation of alignment matrices Forces the immediate calculation of alignment matrices.

Syntax

Visual Basic
Public Sub CalculateMatrices()

See Also

AlignCmnd Object


CalculateStatistics Method

CalculateStatistics Method
MEAN
STDDEV

Description

Returns the mean and standard deviation

Syntax

Visual Basic
Public Sub CalculateStatistics( _
   ByRef MEAN As Double, _
   ByRef STDDEV As Double _
)

Parameters

MEAN
STDDEV

See Also

AlignCmnd Object


GetBFIterations Method

GetBFIterations Method
max_iterations
actual_iterations

Description

Returns the number of bestfit iterations

Syntax

Visual Basic
Public Sub GetBFIterations( _
   ByRef max_iterations As Long, _
   ByRef actual_iterations As Long _
)

Parameters

max_iterations
actual_iterations

See Also

AlignCmnd Object


GetFeatureIdByIndex Method

GetFeatureIdByIndex Method
index

Description

Returns the feature id

Syntax

Visual Basic
Public Function GetFeatureIdByIndex( _
   ByVal index As Long _
) As String

Parameters

index

See Also

AlignCmnd Object


AboutAxis Property

AboutAxis Property

Description

Read/Write: The axis about which alignment is rotated Represents the axis about which the alignment object rotates.

Property type

Read-write property

Syntax

Visual Basic
Public Property AboutAxis() As ENUM_AXIS_TYPE

Return Type

Read/write Long.

Remarks

This function only works for objects of type ROTATE_ALIGN, ROTATE_CIRCLE_ALIGN, and ROTATEOFF_ALIGN. For other object types, trying to set this property does nothing, and trying to get this property always returns PCD_ZPLUS.

Valid Settings to set this property to are as follows:

PCD_XPLUS
PCD_XMINUS
PCD_YPLUS
PCD_YMINUS
PCD_ZPLUS
PCD_ZMINUS

See Also

AlignCmnd Object | Type Property


Angle Property

Angle Property

Description

Read/Write: Point data object with angle values for BF3D and BF2D alignments

Represents the offset angles of a 3D or 2D alignment.

Property type

Read-write property

Syntax

Visual Basic
Public Property Angle() As PointData

Return Type

Read/write PointData. If used on an object other than a 3D or 2D alignment, setting this variable will do nothing, and getting this variable will return Nothing.

See Also

AlignCmnd Object


AverageError Property

AverageError Property

Description

Read/Write: Average Error setting for Iterative Alignments

Represents whether or not error averaging is used during the iterative alignment.

Property type

Read-write property

Syntax

Visual Basic
Public Property AverageError() As Boolean

Return Type

Read/write Boolean.

Remarks

This property is only valid for objects of type ITER_ALIGN. For other objects, getting this property always returns FALSE, and setting it does nothing.

See Also

AlignCmnd Object | Type Property


AXIS Property

AXIS Property

Description

Read/Write: The alignment axis Represents the axis that the alignment object uses.

Property type

Read-write property

Syntax

Visual Basic
Public Property AXIS() As ENUM_AXIS_TYPE

Return Type

Read/write Long.

Remarks

This function only works for objects of type ROTATE_ALIGN, ROTATE_CIRCLE_ALIGN, TRANS_ALIGN, and TRANSOFF_ALIGN. For other object types, trying to set this property does nothing, and trying to get this property always returns PCD_ZPLUS.

Valid Settings to set this property to are as follows:

PCD_XPLUS
PCD_XMINUS
PCD_YPLUS
PCD_YMINUS
PCD_ZPLUS
PCD_ZMINUS

See Also

AlignCmnd Object | Type Property


BFOffset Property

BFOffset Property

Description

Read/Write: Point data object with best fit offsets for BF3D and BF2D alignments Represents the offsets of a 3D or 2D alignment.

Property type

Read-write property

Syntax

Visual Basic
Public Property BFOffset() As PointData

Return Type

Read/write PointData. If used on an object other than a 3D or 2D alignment, setting this variable will do nothing, and getting this variable will return Nothing.

See Also

AlignCmnd Object | Type Property


CadToPartMatrix Property

CadToPartMatrix Property

Description

Read Only: Returns a DmisMatrix object representing the cad to part matrix for the alignment

Represents the matrix used to transform points between the cad and part alignment systems.

Property type

Read-write property

Syntax

Visual Basic
Public Property CadToPartMatrix() As DmisMatrix

Return Type

Read only DmisMatrix.

If used on an object other than a start alignment or a recall alignment, the identity matrix will be returned.

See Also

AlignCmnd Object | Type Property


ExternalFileID Property

ExternalFileID Property

Description

Read/Write: External filename for recalling external alignments Represents the external filename for recalling external alignments.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalFileID() As String

Return Type

Read/write String.

Remarks

This function only works for objects of type RECALL_ALIGN and SAVE_ALIGN. If used on an object other than a RECALL_ALIGN or SAVE_ALIGN, setting this variable will do nothing, and getting this variable will return the empty string.

See Also

AlignCmnd Object | Type Property


ExternalID Property

ExternalID Property

Description

Read/Write: ID of External Alignment Represents the external ID.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalID() As String

Return Type

Read/write String.

See Also

AlignCmnd Object


FeatID Property

FeatID Property

Description

Read/Write: Feature referenced by the alignment Represents the first (or only) feature ID used by this alignment object.

Property type

Read-write property

Syntax

Visual Basic
Public Property FeatID() As String

Return Type

Read/write String.

Remarks

This function only works for objects of type LEVEL_ALIGN, ROTATE_ALIGN, ROTATE_CIRCLE_ALIGN, TRANS_ALIGN, and EQUATE_ALIGN. If used on any other object type, setting this variable will do nothing, and getting this variable will return the empty string.

See Also

AlignCmnd Object | Type Property


FeatID2 Property

FeatID2 Property

Description

Read/Write: Second referenced alignment feature Represents the second feature ID used by this alignment object.

Property type

Read-write property

Syntax

Visual Basic
Public Property FeatID2() As String

Remarks

This function only works for objects of type ROTATE_CIRCLE_ALIGN and EQUATE_ALIGN. If used on any other object type, setting this variable will do nothing, and getting this variable will return the empty string.

See Also

AlignCmnd Object | Type Property


FindCad Property

FindCad Property

Description

Read/Write: Find Cad setting for BF3D and BF2D alignments Represents the FindCad property status of this best fit alignment object.

Property type

Read-write property

Syntax

Visual Basic
Public Property FindCad() As Boolean

Return Type

Read/write Boolean.

Remarks

This function only works for objects of type BF2D_ALIGN and BF3D_ALIGN. If used on any other object type, setting this variable will do nothing, and getting this variable will return FALSE.

See Also

AlignCmnd Object | Type Property


ID Property

ID Property

Description

Read/Write: Id of the alignment Represents the ID of this alignment object.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As String

Return Type

Read/write String.

Remarks

This function only works for objects of type START_ALIGN and RECALL_ALIGN. If used on any other object type, setting this variable will do nothing, and getting this variable will return the empty string.

See Also

AlignCmnd Object | Type Property


InitID Property

InitID Property

Description

Read/Write: Id of initial/basic alignment

Represents the intial ID of this alignment object. The intial ID is the ID of the alignment to recall before modifying it with this alignment.

Property type

Read-write property

Syntax

Visual Basic
Public Property InitID() As String

Return Type

Read/write String.

Remarks

This function only works for objects of type START_ALIGN and RECALL_ALIGN. If used on any other object type, setting this variable will do nothing, and getting this variable will return the empty string.

See Also

AlignCmnd Object | Type Property


IterativeLevelAxis Property

IterativeLevelAxis Property

Description

Read/Write: Level Axis for Iterative Alignment Represents the level axis for an iterative alignment.

Property type

Read-write property

Syntax

Visual Basic
Public Property IterativeLevelAxis() As PAXISTYPE

Return Type

Read/write PaxisType.

See Also

AlignCmnd Object | Type Property


IterativeOriginAxis Property

IterativeOriginAxis Property

Description

Read/Write: Origin Axis for Iterative Alignment Represents the origin axis for an iterative alignment.

Property type

Read-write property

Syntax

Visual Basic
Public Property IterativeOriginAxis() As PAXISTYPE

Return Type

Read/write PaxisType.

See Also

AlignCmnd Object | Type Property


IterativeRotateAxis Property

IterativeRotateAxis Property

Description

Read/Write: Rotate Axis for Iterative Alignment Represents the rotate axis for an iterative alignment.

Property type

Read-write property

Syntax

Visual Basic
Public Property IterativeRotateAxis() As PAXISTYPE

Return Type

Read/write PaxisType.

See Also

AlignCmnd Object | Type Property


MachineToPartMatrix Property

MachineToPartMatrix Property

Description

Read Only: Returns a DmisMatrix object representing the machine to part matrix for the alignment

Represents the matrix used to transform points between the machine and part alignment systems.

Property type

Read-write property

Syntax

Visual Basic
Public Property MachineToPartMatrix() As DmisMatrix

Return Type

Read only DmisMatrix. If used on an object other than a start alignment or a recall alignment, the identity matrix will be returned.

See Also

AlignCmnd Object


MeasAllFeat Property

MeasAllFeat Property

Description

Read/Write: Measure all features once setting for iterative alignment Represents the "Measure All Features" property of this iterative alignment object.

Property type

Read-write property

Syntax

Visual Basic
Public Property MeasAllFeat() As Boolean

Return Type

Read/write Boolean.

Remarks

This function only works for objects of type ITER_ALIGN. If used on any other object type, setting this variable will do nothing, and getting this variable will return FALSE.

See Also

AlignCmnd Object | Type Property


MeasAllFeatAlways Property

MeasAllFeatAlways Property

Description

Read/Write: Measure All Features Always setting for iterative alignments Represents the "Measure All Features Always" property of this iterative alignment object.

Property type

Read-write property

Syntax

Visual Basic
Public Property MeasAllFeatAlways() As Boolean

Return Type

Read/write Boolean.

See Also

AlignCmnd Object | Type Property


NumInputs Property

NumInputs Property

Description

Read Only: Number of inputs for BF3D, BF2D, or Iterative Alignments

Returns the number of inputs to this alignment object. Read-only Long.

Property type

Read-write property

Syntax

Visual Basic
Public Property NumInputs() As Long

Return Type

This function only works for objects of type ITER_ALIGN, BF2D_ALIGN, and BF3D_ALIGN. If used on any other object type, setting this variable will do nothing, and getting this variable will return zero.

Remarks

See Also

AlignCmnd Object | Type Property


Offset Property

Offset Property

Description

Read/Write: Alignment offset value Represents the offset property of this offset alignment object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Offset() As Double

Return Type

Read/write Double. For objects of type TRANSOFF_ALIGN, it is the number of MM or inches to offset the alignment. For objects of type ROTATEOFF_ALIGN, it is the number of radians to offset the alignment.

See Also

AlignCmnd Object


Parent Property

Parent Property

Description

Read Only: Returns parent command object

Returns the parent Command object. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Command

Remarks

The parent of an AlignCommand object is the same underlying PC-DMIS object as the AlignCommand object itself. Getting the parent allows you to access the generic Command properties and methods of a given object.

See Also

AlignCmnd Object


PointTolerance Property

PointTolerance Property

Description

Read/Write: Point Tolerance value for BF3D, BF2D, or Iterative alignments Represents the "Point Tolerance" property of this alignment object.

Property type

Read-write property

Syntax

Visual Basic
Public Property PointTolerance() As Double

Return Type

Read/write Double.

Remarks

This function only works for objects of type ITER_ALIGN, BF2D_ALIGN, and BF3D_ALIGN. If used on any other object type, setting this variable will do nothing, and getting this variable will return zero.

See Also

AlignCmnd Object | Type Property


RepierceCad Property

RepierceCad Property

Description

Read/Write: Repierce Cad setting for Iterative Alignments Represents whether or not to repierce the cad model during the execution of this iterative alignment object.

Property type

Read-write property

Syntax

Visual Basic
Public Property RepierceCad() As Boolean

Return Type

Read/write Boolean.

Remarks

This function only works for objects of type ITER_ALIGN. If used on any other object type, setting this variable will do nothing, and getting this variable will return FALSE.

See Also

AlignCmnd Object | Type Property


UseBodyAxis Property

UseBodyAxis Property

Description

Read/Write: Use body axis setting for Iterative Alignments Represents whether or not to use the "Body Axis” method during the calculation of this iterative alignment object.

Property type

Read-write property

Syntax

Visual Basic
Public Property UseBodyAxis() As Boolean

Return Type

Read/write Boolean.

See Also

AlignCmnd Object | Type Property


Workplane Property

Workplane Property

Description

Read/Write: Workplane setting for BF2D and Iterative Alignments

Represents the workplane of this alignment object. It can take the values PCD_XPLUS, PCD_XMINUS, PCD_YPLUS, PCD_YMINUS, PCD_ZPLUS, and PCD_ZMINUS.

Property type

Read-write property

Syntax

Visual Basic
Public Property Workplane() As ENUM_PLANE_TYPE

Return Type

Read/write Long.

Remarks

This function only works for objects of type ITER_ALIGN. If used on any other object type, setting this variable will do nothing, and getting this variable will return PCD_ZPLUS.

See Also

AlignCmnd Object | Type Property


Application Object

Application Object
See Also Members

Description

PC-Dmis Application Object

The Application object represents the PC-DMIS application.

Object Model

Remarks

To start PC-DMIS using Automation from another application, use CreateObject or GetObject to return an Application object.

LaLaunching PC-DMIS With Startup Options

Because of an inherent weakness in the way Microsoft designed the CreateObject function, the CreateObject doesn't allow startup parameters. This means when the code executes it will launch PC-DMIS always in ONLINE mode.

However, there is a way around this. Your code can dynamically create a special startup file that will cause PC-DMIS to launch with specific startup options.

In order to launch PC-DMIS via automation with a startup file you must do the following:

  • Create a text file named AutomationStartupOptions.txt.

  • Create a single line of text in the file with the available startup options. The PC-DMIS specific startup options include the following:

/f - Launches in Offline mode.

/o - Launches in Operator mode.

/d - Launches in Debug mode.

/r - Launches in Reverse Axes mode

/postin - Launches in import mode. PC-DMIS will automatically import a specified file.

/postout - Launches in export mode. PC-DMIS will automatically export a specified file.

The line of text would look like this: /f /o /d /r /postin /postout

  • Launch PC-DMIS via automation.

When PC-DMIS starts, it checks to see if the AutomationStartupOptions.txt file exists. If it does, then it uses the file to set the necessary flags. However, when PC-DMIS closes, it will delete the text file. This means that the code you use to launch PC-DMIS must also create the needed text file on the fly or must rename an existing file to AutomationStartupOptions.txt. See the "Example Code from C++" below.

Automating in Online Mode: If you are trying to launch PC-DMIS in online mode, please note that the AutomationStartupOptions.txt file should not contain the /f startup parameter. Also, the machine parameter specified when using the Open or New methods of the PartPrograms object determines whether or not the part program will run in offline or online modes. Of online mode, this parameter should be "CMM1".

Example

Dim App as Object.
Set App = CreateObject("Pcdlrn.Application")

Example

Example Code from C++

See Also

Application Members


Application Object Members

Application ObjectMembers
See Also Overview

Public Methods

Public Method _AddRegistrySetting
Public Method DeleteRegistryKey | Deletes a key and all its subkeys from the registry
Public Method DeleteRegistryValue | Deletes a value from the registry
Public Method ExportRegistrySettings
Public Method GetHelpMap | Returns help map for menu id, used by online help
Public Method GetRegistryBool | Gets a boolean from the registry
Public Method GetRegistryDouble | Gets a double from the registry
Public Method GetRegistryDWORD | Gets a DWORD from the registry
Public Method GetRegistryInt | Gets an integer from the registry
Public Method GetRegistryPoint | Gets an XYZ triple from the registry
Public Method GetRegistrySettings | Gets the settings object for the application
Public Method GetRegistryString | Gets a string from the registry
Public Method Help | Shows application or specified help file Calls and opens a help file and topic.
Public Method ImportRegistrySettings
Public Method Maximize | Maximizes application window The Maximize Subroutine expands the PC-DMIS window to full-screen size.
Public Method Minimize | Minimizes application window The Minimize subroutine reduces the PC-DMIS window to the taskbar.
Public Method Post Imports or exports data to/from specified part program

The Post function tells PC-DMIS to import or export Source into Destination. It returns TRUE if the import or export process is successful, FALSE otherwise.

Exactly one of Source and Destination must be a PC-DMIS .prg or .cad file. If it is Source, then PC-DMIS will export based on the name of the Destination file. If the Destination file is a PC-DMIS .prg or .cad file, then PC-DMIS will import based on the name of the Source file.

The Source file must already exist, but the Destination file need not already exist.

Public Method Quit | Quits application - once all object pointers have been released The Quit function tells PC-DMIS to close. It always returns TRUE.
Public Method RegistryKeyExists | Queries the registry for a specific key
Public Method RegistryValueExists | Queries the registry for a specific value
Public Method Restore | Restores application window The Restore subroutine makes the PC-DMIS window open and neither maximized nor minimized.
Public Method SetActive | Makes application the active application for the OS Brings PC-DMIS to the foreground, making it the active application.
Public Method SpawnNewInstance Returns Application Object of newly created instance of application

Public Method WaitUntilReady Waits until online machine has fully initialized or timeout period has elapsed before returning

Waits until the online machine has fully initialized or timeout period has elapsed before returning.

Public Method WinHelp | Invokes internal help
Public Method WriteRegistryBool | Writes a boolean to the registry Sets a PC-DMIS registry entry to a TRUE or FALSE value.
Public Method WriteRegistryDouble | Writes a double to the registry Sets a PC-DMIS registry entry to a specified Double value.
Public Method WriteRegistryDWORD | Writes a DWORD to the registry Sets a PC-DMIS registry entry to a specified long value.
Public Method WriteRegistryInt | Writes an integer to the registry Sets a PC-DMIS registry entry to a specified integer value. Write Integer.
Public Method WriteRegistryPoint | Writes an XYZ triple to the registry Sets a PC-DMIS registry entry to a specified XYZ value. Write double.
Public Method WriteRegistrySettings | Writes current registry settings to the debug file Writes the current PC-DMIS registry entries and their values to the debug.txt file.
Public Method WriteRegistryString | Writes a string to the registry This writes a specified string value to a valid PC-DMIS registry entry. Write String.

Public Properties

Public Property _Name |
Public Property ActivePartProgram | Read/Write: Returns/Sets pointer to Currently Active Part Program Represents the currently active part program.
Public Property AdminPrivileges | Read Only: Returns true if current user has administrator privileges
Public Property ApplicationEvents | Returns Application Events Object for use in capturing application events Returns the ApplicationObjectEvents object for use in capturing application events.
Public Property ApplicationSettings | Read Only: Returns the ApplicationSettings Object Returns the ApplicationSettings object for use in modifying PC-DMIS’s settings.
Public Property Caption | Read/Write: Returns/Sets text of application title bar The text in the title bar of the application.
Public Property ConnectedInDriveMode | Read Only: Returns true when computer connected as driving computer
Public Property ConnectedInRelayMode | Read Only: Returns true when computer connected as relay computer
Public Property ConnectedToMaster | Read Only: Returns true if connected to master computer as slave
Public Property ConnectedToSlave | Read Only: Returns true if connected to slave computer as master
Public Property CurrentUserDirectory | Read Only: Returns the directory where user information is stored This returns a string showing the directory that contains the current user’s setup information.
Public Property DefaultFilePath | Read/Write: Returns name of current working directory The directory in which the File Open dialog starts. If you set this property to empty it returns the installation path.
Public Property DefaultMachineName | Read Only: Name of next available machine - CMM or offline The name of the next available machine for attaching to a part program.
Public Property DefaultProbeFile | Read Only: Name of last used probe file The name of the last chosen probe file used when creating a new part program.
Public Property ErrorDialogEnabled | Read/Write: Returns/Sets whether the CMM Error Dialog is enabled
Public Property FullName | Read Only: Returns full path for application executable - ex. C:PCDMISWPCDLRN.EXE The fully qualified path name of the PC-DMIS executable.
Public Property GetBoolSetting | Read Only: Returns the boolean value of the named PC-DMIS setting
Public Property GetDoubleSetting | Read Only: Returns the double value of the named PC-DMIS setting
Public Property GetDWORDSetting | Read Only: Returns the DWORD, or unsigned long, value of the named PC-DMIS setting
Public Property GetIntSetting | Read Only: Returns the integer value of the named PC-DMIS setting
Public Property GetStringSetting | Read Only: Returns the string value of the named PC-DMIS setting
Public Property Height | Read/Write: Returns/Sets height of application window The height of the PC-DMIS window in screen pixels.
Public Property LabelTemplates | Read Only: Returns the Label Templates object
Public Property Left | Read/Write: Returns/Sets left coordinate of application window The left edge of the PC-DMIS window, measured from the left edge of the Windows Desktop.
Public Property LocaleID | Read Only: Returns the current LocaleID (LCID) of the application
Public Property Machines | Read Only: Returns Machines Object - CMMs, including offline, available to application Returns the read-only Machines collection object.
Public Property MajorVersion | Read Only: Returns the major version number of the application Returns the major version number of the application.
Public Property MinorVersion | Read Only: Returns the minor version number of the application Returns the minor version number of the application.
Public Property Name | Read Only: Returns name of executable - ex. PCDLRN.EXE The file name of the PC-DMIS executable.
Public Property OperatorMode | Read/Write: Returns/Sets status of application operator mode Represents whether or not you are in operator mode. TRUE when in operator mode, FALSE otherwise.
Public Property PartPrograms | Read Only: Returns pointer to Partprograms object Returns the collection of part programs currently active in PC-DMIS.
Public Property Path | Read Only: Returns path location for application - ex. C:PCDMISW Returns the directory in which the PC-DMIS executable resides.
Public Property RemotePanelMode | Read/Write: Indicates that PC-Dmis is in Remote Panel mode. Used by remote panel. Indicates that PC-DMIS is in Remote Panel mode. Used by Remote Panel Application (RPA).
Public Property ReportTemplates | Read Only: Returns the Report Templates object
Public Property StatusBar | Read/Write: Returns/Sets text of application status bar The text on the status bar of the main PC-DMIS window.
Public Property Top | Read/Write: Returns/Sets top coordinate of application window The top edge of the PC-DMIS window, measured from the top edge of the Windows Desktop.
Public Property UserExit | Read/Write: Determines whether user can close application TRUE if the PC-DMIS automation engine is will shut down when the user exits PC-DMIS, otherwise FALSE.
Public Property VerboseDialogs | Read/Write: Controls verbose debugging dialogs
Public Property VersionString | Read Only: Returns the version string for the application Returns the version string for the application.
Public Property Visible | Read/Write: Returns visibility status of application or Shows or Hides the Application TRUE if PC-DMIS is visible, otherwise FALSE.
Public Property Width | Read/Write: Returns/Sets width of application window The width of the PC-DMIS window in screen pixels.

See Also

Application Overview


_AddRegistrySetting Method

_AddRegistrySetting Method
szSection
szEntry
szDefault
nType
nFunction
bUserAdmin
bAutoEnabled
bSingleton

Syntax

Visual Basic
Public Sub _AddRegistrySetting( _
   ByVal szSection As String, _
   ByVal szEntry As String, _
   ByVal szDefault As String, _
   ByVal nType As Long, _
   ByVal nFunction As Long, _
   ByVal bUserAdmin As Boolean, _
   ByVal bAutoEnabled As Boolean, _
   ByVal bSingleton As Boolean _
)

Parameters

szSection
szEntry
szDefault
nType
nFunction
bUserAdmin
bAutoEnabled
bSingleton

See Also

Application Object


DeleteRegistryKey Method

DeleteRegistryKey Method
lpszSection

Description

Deletes a key and all its subkeys from the registry

Syntax

Visual Basic
Public Function DeleteRegistryKey( _
   ByVal lpszSection As String _
) As Boolean

Parameters

lpszSection

See Also

Application Object


DeleteRegistryValue Method

DeleteRegistryValue Method
lpszSection
lpszEntry

Description

Deletes a value from the registry

Syntax

Visual Basic
Public Function DeleteRegistryValue( _
   ByVal lpszSection As String, _
   ByVal lpszEntry As String _
) As Boolean

Parameters

lpszSection
lpszEntry

See Also

Application Object


ExportRegistrySettings Method

ExportRegistrySettings Method
FilePath

Syntax

Visual Basic
Public Function ExportRegistrySettings( _
   ByVal FilePath As String _
) As Long

Parameters

FilePath

See Also

Application Object


GetHelpMap Method

GetHelpMap Method
MenuId

Description

Returns help map for menu id, used by online help

Syntax

Visual Basic
Public Function GetHelpMap( _
   ByVal MenuId As Long _
) As String

Parameters

MenuId

See Also

Application Object


GetRegistryBool Method

GetRegistryBool Method
lpszSection
lpszEntry
bDefault

Description

Gets a boolean from the registry

Syntax

Visual Basic
Public Function GetRegistryBool( _
   ByVal lpszSection As String, _
   ByVal lpszEntry As String, _
   ByVal bDefault As Boolean _
) As Boolean

Parameters

lpszSection
lpszEntry
bDefault

See Also

Application Object


GetRegistryDouble Method

GetRegistryDouble Method
lpszSection
lpszEntry
dDefault

Description

Gets a double from the registry

Syntax

Visual Basic
Public Function GetRegistryDouble( _
   ByVal lpszSection As String, _
   ByVal lpszEntry As String, _
   ByVal dDefault As Double _
) As Double

Parameters

lpszSection
lpszEntry
dDefault

See Also

Application Object


GetRegistryDWORD Method

GetRegistryDWORD Method
lpszSection
lpszEntry
dwDefault

Description

Gets a DWORD from the registry

Syntax

Visual Basic
Public Function GetRegistryDWORD( _
   ByVal lpszSection As String, _
   ByVal lpszEntry As String, _
   ByVal dwDefault As Long _
) As Long

Parameters

lpszSection
lpszEntry
dwDefault

See Also

Application Object


GetRegistryInt Method

GetRegistryInt Method
lpszSection
lpszEntry
nDefault

Description

Gets an integer from the registry

Syntax

Visual Basic
Public Function GetRegistryInt( _
   ByVal lpszSection As String, _
   ByVal lpszEntry As String, _
   ByVal nDefault As Long _
) As Long

Parameters

lpszSection
lpszEntry
nDefault

See Also

Application Object


GetRegistryPoint Method

GetRegistryPoint Method
lpszSection
lpszEntry
dX
dY
dZ

Description

Gets an XYZ triple from the registry

Syntax

Visual Basic
Public Function GetRegistryPoint( _
   ByVal lpszSection As String, _
   ByVal lpszEntry As String, _
   ByVal dX As Double, _
   ByVal dY As Double, _
   ByVal dZ As Double _
) As PointData

Parameters

lpszSection
lpszEntry
dX
dY
dZ

See Also

Application Object


GetRegistrySettings Method

GetRegistrySettings Method

Description

Gets the settings object for the application

Syntax

Visual Basic
Public Function GetRegistrySettings() As RegistrySettings

See Also

Application Object


GetRegistryString Method

GetRegistryString Method
lpszSection
lpszEntry
lpszDefault

Description

Gets a string from the registry

Syntax

Visual Basic
Public Function GetRegistryString( _
   ByVal lpszSection As String, _
   ByVal lpszEntry As String, _
   ByVal lpszDefault As String _
) As String

Parameters

lpszSection
lpszEntry
lpszDefault

See Also

Application Object


Help Method

Help Method
HelpFile
Required String parameter that indicates what help file to open.
HelpContext
Optional Long parameter that indicates which Context ID number in HelpFile to open.
HelpString
Optional String parameter that indicates a string to match among HelpFile’s topics.

Description

Shows application or specified help file Calls and opens a help file and topic.

Syntax

Visual Basic
Public Sub Help( _
   ByVal HelpFile As String, _
   ByVal HelpContext As Long, _
   ByVal HelpString As String _
)

Parameters

HelpFile
Required String parameter that indicates what help file to open.
HelpContext
Optional Long parameter that indicates which Context ID number in HelpFile to open.
HelpString
Optional String parameter that indicates a string to match among HelpFile’s topics.

Remarks

If both the HelpContext and HelpString are provided, the HelpString will be ignored. If neither is provided, the first help page is shown.

See Also

Application Object


ImportRegistrySettings Method

ImportRegistrySettings Method
FilePath

Syntax

Visual Basic
Public Function ImportRegistrySettings( _
   ByVal FilePath As String _
) As Long

Parameters

FilePath

See Also

Application Object


Maximize Method

Maximize Method

Description

Maximizes application window The Maximize Subroutine expands the PC-DMIS window to full-screen size.

Syntax

Visual Basic
Public Sub Maximize()

See Also

Application Object


Minimize Method

Minimize Method

Description

Minimizes application window The Minimize subroutine reduces the PC-DMIS window to the taskbar.

Syntax

Visual Basic
Public Sub Minimize()

See Also

Application Object


Post Method

Post Method
Source
Required String that indicates the file from which to import or export.
Destination
Required String that indicates the file into which to import or export.

Description

Imports or exports data to/from specified part program

The Post function tells PC-DMIS to import or export Source into Destination. It returns TRUE if the import or export process is successful, FALSE otherwise.

Exactly one of Source and Destination must be a PC-DMIS .prg or .cad file. If it is Source, then PC-DMIS will export based on the name of the Destination file. If the Destination file is a PC-DMIS .prg or .cad file, then PC-DMIS will import based on the name of the Source file.

The Source file must already exist, but the Destination file need not already exist.

Syntax

Visual Basic
Public Function Post( _
   ByVal Source As String, _
   ByVal Destination As String _
) As Boolean

Parameters

Source
Required String that indicates the file from which to import or export.
Destination
Required String that indicates the file into which to import or export.

Return Type

This method returns a Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

Application Object


Quit Method

Quit Method

Description

Quits application - once all object pointers have been released The Quit function tells PC-DMIS to close. It always returns TRUE.

Syntax

Visual Basic
Public Sub Quit()

See Also

Application Object


RegistryKeyExists Method

RegistryKeyExists Method
lpszSection

Description

Queries the registry for a specific key

Syntax

Visual Basic
Public Function RegistryKeyExists( _
   ByVal lpszSection As String _
) As Boolean

Parameters

lpszSection

See Also

Application Object


RegistryValueExists Method

RegistryValueExists Method
lpszSection
lpszEntry

Description

Queries the registry for a specific value

Syntax

Visual Basic
Public Function RegistryValueExists( _
   ByVal lpszSection As String, _
   ByVal lpszEntry As String _
) As Boolean

Parameters

lpszSection
lpszEntry

See Also

Application Object


Restore Method

Restore Method

Description

Restores application window The Restore subroutine makes the PC-DMIS window open and neither maximized nor minimized.

Syntax

Visual Basic
Public Sub Restore()

See Also

Application Object


SetActive Method

SetActive Method

Description

Makes application the active application for the OS Brings PC-DMIS to the foreground, making it the active application.

Syntax

Visual Basic
Public Function SetActive() As Boolean

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

Application Object


SpawnNewInstance Method

SpawnNewInstance Method

Description

Returns Application Object of newly created instance of application

Syntax

Visual Basic
Public Function SpawnNewInstance() As Application

Return Type

Returns Application Object of newly created instance of application.

See Also

Application Object


WaitUntilReady Method

WaitUntilReady Method
TimeOutInSeconds
Long value representing the number of seconds for the timeout period.

Description

Waits until online machine has fully initialized or timeout period has elapsed before returning

Waits until the online machine has fully initialized or timeout period has elapsed before returning.

Syntax

Visual Basic
Public Function WaitUntilReady( _
   ByVal TimeOutInSeconds As Long _
) As Boolean

Parameters

TimeOutInSeconds
Long value representing the number of seconds for the timeout period.

See Also

Application Object


WinHelp Method

WinHelp Method
dwData
nCmd

Description

Invokes internal help

Syntax

Visual Basic
Public Sub WinHelp( _
   ByVal dwData As Long, _
   ByVal nCmd As Long _
)

Parameters

dwData
nCmd

See Also

Application Object


WriteRegistryBool Method

WriteRegistryBool Method
lpszSection
String value that specifies the section in which the registry entry that you want to modify resides.
lpszEntry
String value that specifies the entry to which you want to write the value.
bValue
Boolean value to write to the registry entry.
bSetVariable
Boolean value that determines whether or not an associated global variable in PC-DMIS gets changed to the value of the third parameter. This parameter only works for registry entries pertaining to feature ID prefixes.

Description

Writes a boolean to the registry Sets a PC-DMIS registry entry to a TRUE or FALSE value.

Syntax

Visual Basic
Public Function WriteRegistryBool( _
   ByVal lpszSection As String, _
   ByVal lpszEntry As String, _
   ByVal bValue As Boolean, _
   ByVal bSetVariable As Boolean _
) As Boolean

Parameters

lpszSection
String value that specifies the section in which the registry entry that you want to modify resides.
lpszEntry
String value that specifies the entry to which you want to write the value.
bValue
Boolean value to write to the registry entry.
bSetVariable
Boolean value that determines whether or not an associated global variable in PC-DMIS gets changed to the value of the third parameter. This parameter only works for registry entries pertaining to feature ID prefixes.

Return Type

Boolean value that determines whether or not the value of the third parameter was successfully written to the registry entry.

Remarks

Example

' This code sample turns off PC-DMIS’s start up music:

Dim myapp As New PCDLRN.Application

Set myapp = CreateObject("pcdlrn.application")

myval = myapp.WriteRegistryBool("Option", "TurnOffTheAnnoyingStartupMusic", False, True)

See Also

Application Object


WriteRegistryDouble Method

WriteRegistryDouble Method
lpszSection
String value that specifes the section in which the registry entry that you want to modify resides.
lpszEntry
String value that specifies the entry to which you want to write the value.
dValue
Double value to write to the registry entry.
bSetVariable
Boolean value that determines whether or not an associated global variable in PC-DMIS gets changed to the value of the third parameter. This parameter only works for registry entries pertaining to feature ID prefixes.

Description

Writes a double to the registry Sets a PC-DMIS registry entry to a specified Double value.

Syntax

Visual Basic
Public Function WriteRegistryDouble( _
   ByVal lpszSection As String, _
   ByVal lpszEntry As String, _
   ByVal dValue As Double, _
   ByVal bSetVariable As Boolean _
) As Boolean

Parameters

lpszSection
String value that specifes the section in which the registry entry that you want to modify resides.
lpszEntry
String value that specifies the entry to which you want to write the value.
dValue
Double value to write to the registry entry.
bSetVariable
Boolean value that determines whether or not an associated global variable in PC-DMIS gets changed to the value of the third parameter. This parameter only works for registry entries pertaining to feature ID prefixes.

Return Type

Boolean value that determines whether or not the value of the third parameter was successfully written to the registry entry.

Example

' This code sample sets an analog probe’s lower force to the double value of 0.04.

Dim myapp As New PCDLRN.Application

Set myapp = CreateObject("pcdlrn.application")

myval = myapp.WriteRegistryDouble("ANALOG_PROBING", "ProbeLowerForce", 0.04, True)

See Also

Application Object


WriteRegistryDWORD Method

WriteRegistryDWORD Method
lpszSection
String value that specifes the section in which the registry entry that you want to modify resides.
lpszEntry
String value that specifies the entry to which you want to write the value.
dwValue
Long value to write to the registry entry.
bSetVariable
Boolean value that determines whether or not an associated global variable in PC-DMIS gets changed to the value of the third parameter. This parameter only works for registry entries pertaining to feature ID prefixes.

Description

Writes a DWORD to the registry Sets a PC-DMIS registry entry to a specified long value.

Syntax

Visual Basic
Public Function WriteRegistryDWORD( _
   ByVal lpszSection As String, _
   ByVal lpszEntry As String, _
   ByVal dwValue As Long, _
   ByVal bSetVariable As Boolean _
) As Boolean

Parameters

lpszSection
String value that specifes the section in which the registry entry that you want to modify resides.
lpszEntry
String value that specifies the entry to which you want to write the value.
dwValue
Long value to write to the registry entry.
bSetVariable
Boolean value that determines whether or not an associated global variable in PC-DMIS gets changed to the value of the third parameter. This parameter only works for registry entries pertaining to feature ID prefixes.

Return Type

Boolean value that determines whether or not the value of the third parameter was successfully written to the registry entry.

Example

' This code sample sets an auto circle’s hits to the long value of 4.

Dim myapp As New PCDLRN.Application

Set myapp = CreateObject("pcdlrn.application")

myval = myapp.WriteRegistryDWORD("AutoFeatures", "DccCirNumHits", 4, True)

See Also

Application Object


WriteRegistryInt Method

WriteRegistryInt Method
lpszSection
String value that specifes the section in which the registry entry that you want to modify resides.
lpszEntry
String value that specifies the entry to which you want to write the value.
nValue
Integer value to write to the registry entry.
bSetVariable
Boolean value that determines whether or not an associated global variable in PC-DMIS gets changed to the value of the third parameter. This parameter only works for registry entries pertaining to feature ID prefixes.

Description

Writes an integer to the registry Sets a PC-DMIS registry entry to a specified integer value. Write Integer.

Syntax

Visual Basic
Public Function WriteRegistryInt( _
   ByVal lpszSection As String, _
   ByVal lpszEntry As String, _
   ByVal nValue As Long, _
   ByVal bSetVariable As Boolean _
) As Boolean

Parameters

lpszSection
String value that specifes the section in which the registry entry that you want to modify resides.
lpszEntry
String value that specifies the entry to which you want to write the value.
nValue
Integer value to write to the registry entry.
bSetVariable
Boolean value that determines whether or not an associated global variable in PC-DMIS gets changed to the value of the third parameter. This parameter only works for registry entries pertaining to feature ID prefixes.

Return Type

Boolean value that determines whether or not the value of the third parameter was successfully written to the registry entry.

Example

' This code sample sets the number of rows for auto feature cylinders to the integer value of 3.

Dim myapp As New PCDLRN.Application

Set myapp = CreateObject("pcdlrn.application")

myval = myapp.WriteRegistryInt("AutoFeatures", "DccCylNumRows", 3, True)

MsgBox myval

See Also

Application Object


WriteRegistryPoint Method

WriteRegistryPoint Method
lpszSection
String value that specifies the section in which the registry entry that you want to modify resides.
lpszEntry
String value that specifies the entry to which you want to write the value.
dX
double value representing the X value to write to the registry entry.
dY
double value representing the Y value to write to the registry entry.
dZ
double value representing the Z value to write to the registry entry.
bSetVariable
Boolean value that determines whether or not an associated global variable in PC-DMIS gets changed to the value of the third parameter. This parameter only works for registry entries pertaining to feature ID prefixes.

Description

Writes an XYZ triple to the registry Sets a PC-DMIS registry entry to a specified XYZ value. Write double.

Syntax

Visual Basic
Public Function WriteRegistryPoint( _
   ByVal lpszSection As String, _
   ByVal lpszEntry As String, _
   ByVal dX As Double, _
   ByVal dY As Double, _
   ByVal dZ As Double, _
   ByVal bSetVariable As Boolean _
) As Boolean

Parameters

lpszSection
String value that specifies the section in which the registry entry that you want to modify resides.
lpszEntry
String value that specifies the entry to which you want to write the value.
dX
double value representing the X value to write to the registry entry.
dY
double value representing the Y value to write to the registry entry.
dZ
double value representing the Z value to write to the registry entry.
bSetVariable
Boolean value that determines whether or not an associated global variable in PC-DMIS gets changed to the value of the third parameter. This parameter only works for registry entries pertaining to feature ID prefixes.

Return Type

Boolean value that determines whether or not the value of the third parameter was successfully written to the registry entry.

See Also

Application Object


WriteRegistrySettings Method

WriteRegistrySettings Method

Description

Writes current registry settings to the debug file Writes the current PC-DMIS registry entries and their values to the debug.txt file.

Syntax

Visual Basic
Public Sub WriteRegistrySettings()

Return Type

The debug file is a text file with a default name of debug.txt and is located inside your PC-DMIS installation directory. When you have PC-DMIS set up to write data to this text file, you can use it to keep track of every action of PC-DMIS. This is useful data to give to Technical Support so that they can track down possible bugs or problems you may be encountering inside of PC-DMIS.

When you run a script with this method, all the registry entries get appended to the end of your debug file. You will see a line that says:

//// Start of registry settings ////

Following this line you will find all the registry entries and their values. After the final entry, PC-DMIS shows this line:

//// End of registry settings ////

Example

' This code sample writes all of PC-DMIS’s registry entries an their values to the debug.txt file:

Dim myapp As New PCDLRN.Application

Set myapp = CreateObject("pcdlrn.application")

myapp.WriteRegistrySettings

See Also

Application Object


WriteRegistryString Method

WriteRegistryString Method
lpszSection
String value that specifies the section in which the registry entry that you want to modify resides.
lpszEntry
String that specifies the entry to which you want to write the value.
lpszValue
String value to write to the registry entry.
bSetVariable
Boolean value that determines whether or not an associated global variable in PC-DMIS gets changed to the value of the third parameter. This parameter only works for registry entries pertaining to feature ID prefixes.

Description

Writes a string to the registry This writes a specified string value to a valid PC-DMIS registry entry. Write String.

Syntax

Visual Basic
Public Function WriteRegistryString( _
   ByVal lpszSection As String, _
   ByVal lpszEntry As String, _
   ByVal lpszValue As String, _
   ByVal bSetVariable As Boolean _
) As Boolean

Parameters

lpszSection
String value that specifies the section in which the registry entry that you want to modify resides.
lpszEntry
String that specifies the entry to which you want to write the value.
lpszValue
String value to write to the registry entry.
bSetVariable
Boolean value that determines whether or not an associated global variable in PC-DMIS gets changed to the value of the third parameter. This parameter only works for registry entries pertaining to feature ID prefixes.

Return Type

Boolean value that determines whether or not the value of the third parameter was successfully written to the registry entry.

Example

' The following code sample, sets the PC-DMIS password for the Setup Options dialog box to the string: "PCDMIS007".

Dim myapp As New PCDLRN.Application

Set myapp = CreateObject("pcdlrn.application")

myval = myapp.WriteRegistryString("Option", "Password", "PCDMIS007", True)

See Also

Application Object


_Name Property

_Name Property

Property type

Read-write property

Syntax

Visual Basic
Public Property _Name() As String

See Also

Application Object


ActivePartProgram Property

ActivePartProgram Property

Description

Read/Write: Returns/Sets pointer to Currently Active Part Program Represents the currently active part program.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActivePartProgram() As PartProgram

Return Type

Read/write PartProgram.

See Also

Application Object


AdminPrivileges Property

AdminPrivileges Property

Description

Read Only: Returns true if current user has administrator privileges

Property type

Read-write property

Syntax

Visual Basic
Public Property AdminPrivileges() As Boolean

See Also

Application Object


ApplicationEvents Property

ApplicationEvents Property

Description

Returns Application Events Object for use in capturing application events Returns the ApplicationObjectEvents object for use in capturing application events.

Property type

Read-write property

Syntax

Visual Basic
Public Property ApplicationEvents() As ApplicationObjectEvents

See Also

Application Object


ApplicationSettings Property

ApplicationSettings Property

Description

Read Only: Returns the ApplicationSettings Object Returns the ApplicationSettings object for use in modifying PC-DMIS’s settings.

Property type

Read-write property

Syntax

Visual Basic
Public Property ApplicationSettings() As ApplicationSettings

See Also

Application Object


Caption Property

Caption Property

Description

Read/Write: Returns/Sets text of application title bar The text in the title bar of the application.

Property type

Read-write property

Syntax

Visual Basic
Public Property Caption() As String

Return Type

Read/write String.

See Also

Application Object


ConnectedInDriveMode Property

ConnectedInDriveMode Property

Description

Read Only: Returns true when computer connected as driving computer

Property type

Read-write property

Syntax

Visual Basic
Public Property ConnectedInDriveMode() As Boolean

See Also

Application Object


ConnectedInRelayMode Property

ConnectedInRelayMode Property

Description

Read Only: Returns true when computer connected as relay computer

Property type

Read-write property

Syntax

Visual Basic
Public Property ConnectedInRelayMode() As Boolean

See Also

Application Object


ConnectedToMaster Property

ConnectedToMaster Property

Description

Read Only: Returns true if connected to master computer as slave

Property type

Read-write property

Syntax

Visual Basic
Public Property ConnectedToMaster() As Boolean

See Also

Application Object


ConnectedToSlave Property

ConnectedToSlave Property

Description

Read Only: Returns true if connected to slave computer as master

Property type

Read-write property

Syntax

Visual Basic
Public Property ConnectedToSlave() As Boolean

See Also

Application Object


CurrentUserDirectory Property

CurrentUserDirectory Property

Description

Read Only: Returns the directory where user information is stored

This returns a string showing the directory that contains the current user’s setup information.

Property type

Read-write property

Syntax

Visual Basic
Public Property CurrentUserDirectory() As String

Return Type

Read-only String.

See Also

Application Object


DefaultFilePath Property

DefaultFilePath Property

Description

Read/Write: Returns name of current working directory

The directory in which the File Open dialog starts. If you set this property to empty it returns the installation path.

Property type

Read-write property

Syntax

Visual Basic
Public Property DefaultFilePath() As String

Return Type

Read/write String.

See Also

Application Object


DefaultMachineName Property

DefaultMachineName Property

Description

Read Only: Name of next available machine - CMM or offline

The name of the next available machine for attaching to a part program.

Property type

Read-write property

Syntax

Visual Basic
Public Property DefaultMachineName() As String

Return Type

Read Only String.

See Also

Application Object


DefaultProbeFile Property

DefaultProbeFile Property

Description

Read Only: Name of last used probe file

The name of the last chosen probe file used when creating a new part program.

Property type

Read-write property

Syntax

Visual Basic
Public Property DefaultProbeFile() As String

Return Type

Read Only String

See Also

Application Object


ErrorDialogEnabled Property

ErrorDialogEnabled Property

Description

Read/Write: Returns/Sets whether the CMM Error Dialog is enabled

Property type

Read-write property

Syntax

Visual Basic
Public Property ErrorDialogEnabled() As Long

See Also

Application Object


FullName Property

FullName Property

Description

Read Only: Returns full path for application executable - ex. C:PCDMISWPCDLRN.EXE The fully qualified path name of the PC-DMIS executable.

Property type

Read-write property

Syntax

Visual Basic
Public Property FullName() As String

Return Type

Read-only String. If the PC-DMIS executable is C:\PCDMISW\PCDLRN.EXE, the FullName property is "C:\PCDMISW\PCDLRN.EXE".

Remarks

See Also

Application Object


GetBoolSetting Property

GetBoolSetting Property

Description

Read Only: Returns the boolean value of the named PC-DMIS setting

Property type

Read-write property

Syntax

Visual Basic
Public Property GetBoolSetting() As Boolean

See Also

Application Object


GetDoubleSetting Property

GetDoubleSetting Property

Description

Read Only: Returns the double value of the named PC-DMIS setting

Property type

Read-write property

Syntax

Visual Basic
Public Property GetDoubleSetting() As Double

See Also

Application Object


GetDWORDSetting Property

GetDWORDSetting Property

Description

Read Only: Returns the DWORD, or unsigned long, value of the named PC-DMIS setting

Property type

Read-write property

Syntax

Visual Basic
Public Property GetDWORDSetting() As Long

See Also

Application Object


GetIntSetting Property

GetIntSetting Property

Description

Read Only: Returns the integer value of the named PC-DMIS setting

Property type

Read-write property

Syntax

Visual Basic
Public Property GetIntSetting() As Long

See Also

Application Object


GetStringSetting Property

GetStringSetting Property

Description

Read Only: Returns the string value of the named PC-DMIS setting

Property type

Read-write property

Syntax

Visual Basic
Public Property GetStringSetting() As String

See Also

Application Object


Height Property

Height Property

Description

Read/Write: Returns/Sets height of application window

The height of the PC-DMIS window in screen pixels.

Property type

Read-write property

Syntax

Visual Basic
Public Property Height() As Long

Return Type

Read/write Long.

See Also

Application Object


LabelTemplates Property

LabelTemplates Property

Description

Read Only: Returns the Label Templates object

Property type

Read-write property

Syntax

Visual Basic
Public Property LabelTemplates() As LabelTemplates

See Also

Application Object


Left Property

Left Property

Description

Read/Write: Returns/Sets left coordinate of application window

The left edge of the PC-DMIS window, measured from the left edge of the Windows Desktop.

Property type

Read-write property

Syntax

Visual Basic
Public Property Left() As Long

Return Type

Read/Write Long.

Remarks

The Left property is measured in screen pixels.

See Also

Application Object


LocaleID Property

LocaleID Property

Description

Read Only: Returns the current LocaleID (LCID) of the application

Property type

Read-write property

Syntax

Visual Basic
Public Property LocaleID() As Long

See Also

Application Object


Machines Property

Machines Property

Description

Read Only: Returns Machines Object - CMMs, including offline, available to application Returns the read-only Machines collection object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Machines() As Machines

See Also

Application Object


MajorVersion Property

MajorVersion Property

Description

Read Only: Returns the major version number of the application

Returns the major version number of the application.

Property type

Read-write property

Syntax

Visual Basic
Public Property MajorVersion() As Long

Return Type

Read only Long.

See Also

Application Object


MinorVersion Property

MinorVersion Property

Description

Read Only: Returns the minor version number of the application

Returns the minor version number of the application.

Property type

Read-write property

Syntax

Visual Basic
Public Property MinorVersion() As Long

Return Type

Read only Long.

See Also

Application Object


Name Property

Name Property

Description

Read Only: Returns name of executable - ex. PCDLRN.EXE

The file name of the PC-DMIS executable.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As String

Return Type

Read-only String.

Remarks

The Name property is the default property for the Application object. If the PC-DMIS executable is C:\PCDMISW\PCDLRN.EXE, the Name property is "PCDLRN.EXE".

See Also

Application Object


OperatorMode Property

OperatorMode Property

Description

Read/Write: Returns/Sets status of application operator mode

Represents whether or not you are in operator mode. TRUE when in operator mode, FALSE otherwise.

Property type

Read-write property

Syntax

Visual Basic
Public Property OperatorMode() As Boolean

Return Type

Read/write Boolean.

Remarks

Changing into or out of operator mode makes significant changes to the appearance and utility of PC-DMIS.

See Also

Application Object


PartPrograms Property

PartPrograms Property

Description

Read Only: Returns pointer to Partprograms object Returns the collection of part programs currently active in PC-DMIS.

Property type

Read-write property

Syntax

Visual Basic
Public Property PartPrograms() As PartPrograms

Return Type

PartPrograms object.

See Also

Application Object


Path Property

Path Property

Description

Read Only: Returns path location for application - ex. C:PCDMISW Returns the directory in which the PC-DMIS executable resides.

Property type

Read-write property

Syntax

Visual Basic
Public Property Path() As String

Return Type

Read-only String.

Remarks

If the PC-DMIS executable is C:\PCDMISW\PCDLRN.EXE, the Path property is "C:\PCDMISW\".

See Also

Application Object


RemotePanelMode Property

RemotePanelMode Property

Description

Read/Write: Indicates that PC-Dmis is in Remote Panel mode. Used by remote panel.

Indicates that PC-DMIS is in Remote Panel mode. Used by Remote Panel Application (RPA).

Property type

Read-write property

Syntax

Visual Basic
Public Property RemotePanelMode() As Boolean

Return Type

Read/write Boolean.

See Also

Application Object


ReportTemplates Property

ReportTemplates Property

Description

Read Only: Returns the Report Templates object

Property type

Read-write property

Syntax

Visual Basic
Public Property ReportTemplates() As ReportTemplates

See Also

Application Object


StatusBar Property

StatusBar Property

Description

Read/Write: Returns/Sets text of application status bar

The text on the status bar of the main PC-DMIS window.

Property type

Read-write property

Syntax

Visual Basic
Public Property StatusBar() As String

Return Type

Read/write String.

See Also

Application Object


Top Property

Top Property

Description

Read/Write: Returns/Sets top coordinate of application window The top edge of the PC-DMIS window, measured from the top edge of the Windows Desktop.

Property type

Read-write property

Syntax

Visual Basic
Public Property Top() As Long

Return Type

Read/write Long.

See Also

Application Object


UserExit Property

UserExit Property

Description

Read/Write: Determines whether user can close application

TRUE if the PC-DMIS automation engine is will shut down when the user exits PC-DMIS, otherwise FALSE.

Property type

Read-write property

Syntax

Visual Basic
Public Property UserExit() As Boolean

Return Type

Read/write Boolean.

See Also

Application Object


VerboseDialogs Property

VerboseDialogs Property

Description

Read/Write: Controls verbose debugging dialogs

Property type

Read-write property

Syntax

Visual Basic
Public Property VerboseDialogs() As Long

See Also

Application Object


VersionString Property

VersionString Property

Description

Read Only: Returns the version string for the application

Returns the version string for the application.

Property type

Read-write property

Syntax

Visual Basic
Public Property VersionString() As String

Return Type

Read only String.

See Also

Application Object


Visible Property

Visible Property

Description

Read/Write: Returns visibility status of application or Shows or Hides the Application

TRUE if PC-DMIS is visible, otherwise FALSE.

Property type

Read-write property

Syntax

Visual Basic
Public Property Visible() As Boolean

Return Type

Read/Write Boolean.

See Also

Application Object


Width Property

Width Property

Description

Read/Write: Returns/Sets width of application window

The width of the PC-DMIS window in screen pixels.

Property type

Read-write property

Syntax

Visual Basic
Public Property Width() As Long

Return Type

Read/write Long.

See Also

Application Object


ApplicationObjectEvents Object

ApplicationObjectEvents Object
See Also Members

Description

The ApplicationObjectEvents object provides you with a series of events that get called when the PC-DMIS application meets certain conditions.

See Also

ApplicationObjectEvents Members


ApplicationObjectEvents Object Members

ApplicationObjectEvents ObjectMembers
See Also Overview

Events

Public Event OnAddObject | Event fired when command is added to part program This event gets launched when the specified command (Command) gets added to the specified part program (PartProg).
Public Event OnClosePartProgram | Event fired when part program is closed This event gets launched when the specified part program (PartProg) gets closed.
Public Event OnConnectSlave | Event fired when PC-Dmis connects to the slave computer This event gets launched when PC-DMIS connects to and launches the specified part program (PartProg) on the the slave computer.
Public Event OnDisconnectSlave | Event fired when PC-Dmis disconnects from the slave computer This event gets launched when PC-DMIS disconnects from the slave computer.
Public Event OnEndExecution | Event fired when part program execution ends This event gets launched when PC-DMIS finishes executing the specified program. PC-DMIS determines it has finished execution based on the termination type.
Public Event OnObjectAboutToExecute | Event fired before command is executed This event gets launched immediately before the specified command (Cmmd) gets executed.
Public Event OnObjectAboutToExecute2 | Event fired before command is executed for dual arm systems This event gets launched immediately before the specified command (Cmmd) gets executed on a specified arm (Arm) of a multiple arm system.
Public Event OnObjectExecuted | Event fired when command finishes execution This event gets launched immediately after the specified command (Cmmd) gets executed.
Public Event OnObjectExecuted2 | Event fired when command finishes execution for dual arm systems This event gets launched immediately after the specified command (Cmmd) gets executed on a specified arm (Arm) of a multiple arm system.
Public Event OnOpenPartProgram | Event fired when part program is opened This event gets launched when the specified part program (PartProg) gets opened.
Public Event OnOpenRemotePanelDialog | Event fired when dialogs open for the remote panel This event gets launched when the specified Remote Panel Application dialog box opens.
Public Event OnOpenRemotePanelDialog2 | Event fired when dialogs open for the remote panel with five possible buttons
Public Event OnSavePartProgram | Event fired when part program is saved This event gets launched when the specified part program (PartProg) gets saved.
Public Event OnStartExecution | Event fired when part program execution begins This event gets launched when the specified part program (PartProg) begins execution.
Public Event OnUpdateStatusMessage | Event fired when status bar is updated This event gets launched when the status bar gets updated with the specified message (Msg).

See Also

ApplicationObjectEvents Overview


OnAddObject Event

OnAddObject Event
PartProg
A PartProgram object to determine the part program for which this event should wait.
Command
A Command object to determine the command for which this event should wait.

Description

Event fired when command is added to part program

This event gets launched when the specified command (Command) gets added to the specified part program (PartProg).

Syntax

Visual Basic
Public Event OnAddObject( _
   ByVal PartProg As PartProgram, _
   ByVal Command As Command _
)

Parameters

PartProg
A PartProgram object to determine the part program for which this event should wait.
Command
A Command object to determine the command for which this event should wait.

See Also

ApplicationObjectEvents Object


OnClosePartProgram Event

OnClosePartProgram Event
PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.

Description

Event fired when part program is closed

This event gets launched when the specified part program (PartProg) gets closed.

Syntax

Visual Basic
Public Event OnClosePartProgram( _
   ByVal PartProg As PartProgram _
)

Parameters

PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.

See Also

ApplicationObjectEvents Object


OnConnectSlave Event

OnConnectSlave Event
PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.

Description

Event fired when PC-Dmis connects to the slave computer

This event gets launched when PC-DMIS connects to and launches the specified part program (PartProg) on the the slave computer.

Syntax

Visual Basic
Public Event OnConnectSlave( _
   ByVal PartProg As PartProgram _
)

Parameters

PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.

See Also

ApplicationObjectEvents Object


OnDisconnectSlave Event

OnDisconnectSlave Event
PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.

Description

Event fired when PC-Dmis disconnects from the slave computer

This event gets launched when PC-DMIS disconnects from the slave computer.

Syntax

Visual Basic
Public Event OnDisconnectSlave( _
   ByVal PartProg As PartProgram _
)

Parameters

PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.

See Also

ApplicationObjectEvents Object


OnEndExecution Event

OnEndExecution Event
PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.
TerminationType
Long value that determines the termination type used by this event.

Description

Event fired when part program execution ends This event gets launched when PC-DMIS finishes executing the specified program. PC-DMIS determines it has finished execution based on the termination type.

Syntax

Visual Basic
Public Event OnEndExecution( _
   ByVal PartProg As PartProgram, _
   ByVal TerminationType As Long _
)

Parameters

PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.
TerminationType
Long value that determines the termination type used by this event.

See Also

ApplicationObjectEvents Object


OnObjectAboutToExecute Event

OnObjectAboutToExecute Event
PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.
Cmmd
An expression that evaluates to a Command object to determine the command about to be executed.

Description

Event fired before command is executed

This event gets launched immediately before the specified command (Cmmd) gets executed.

Syntax

Visual Basic
Public Event OnObjectAboutToExecute( _
   ByVal PartProg As PartProgram, _
   ByVal Cmmd As Command _
)

Parameters

PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.
Cmmd
An expression that evaluates to a Command object to determine the command about to be executed.

See Also

ApplicationObjectEvents Object


OnObjectAboutToExecute2 Event

OnObjectAboutToExecute2 Event
PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.
Cmmd
An expression that evaluates to a Command object to determine the command about to be executed.
Arm
Long value representing the arm on a multiple arm machine that is about to execute the command (Cmmd) causing the event to launch.

Description

Event fired before command is executed for dual arm systems

This event gets launched immediately before the specified command (Cmmd) gets executed on a specified arm (Arm) of a multiple arm system.

Syntax

Visual Basic
Public Event OnObjectAboutToExecute2( _
   ByVal PartProg As PartProgram, _
   ByVal Cmmd As Command, _
   ByVal Arm As Long _
)

Parameters

PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.
Cmmd
An expression that evaluates to a Command object to determine the command about to be executed.
Arm
Long value representing the arm on a multiple arm machine that is about to execute the command (Cmmd) causing the event to launch.

See Also

ApplicationObjectEvents Object


OnObjectExecuted Event

OnObjectExecuted Event
PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.
Cmmd
An expression that evaluates to a Command object to determine the command about to be executed.

Description

Event fired when command finishes execution

This event gets launched immediately after the specified command (Cmmd) gets executed.

Syntax

Visual Basic
Public Event OnObjectExecuted( _
   ByVal PartProg As PartProgram, _
   ByVal Cmmd As Command _
)

Parameters

PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.
Cmmd
An expression that evaluates to a Command object to determine the command about to be executed.

See Also

ApplicationObjectEvents Object


OnObjectExecuted2 Event

OnObjectExecuted2 Event
PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.
Cmmd
An expression that evaluates to a Command object to determine the command about to be executed.
Arm
Long value representing the arm on a multiple arm machine that executes the command (Cmmd) causing the event to launch.

Description

Event fired when command finishes execution for dual arm systems

This event gets launched immediately after the specified command (Cmmd) gets executed on a specified arm (Arm) of a multiple arm system.

Syntax

Visual Basic
Public Event OnObjectExecuted2( _
   ByVal PartProg As PartProgram, _
   ByVal Cmmd As Command, _
   ByVal Arm As Long _
)

Parameters

PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.
Cmmd
An expression that evaluates to a Command object to determine the command about to be executed.
Arm
Long value representing the arm on a multiple arm machine that executes the command (Cmmd) causing the event to launch.

See Also

ApplicationObjectEvents Object


OnOpenPartProgram Event

OnOpenPartProgram Event
PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.

Description

Event fired when part program is opened

This event gets launched when the specified part program (PartProg) gets opened.

Syntax

Visual Basic
Public Event OnOpenPartProgram( _
   ByVal PartProg As PartProgram _
)

Parameters

PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.

See Also

ApplicationObjectEvents Object


OnOpenRemotePanelDialog Event

OnOpenRemotePanelDialog Event
PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.
DialogId
Long value representing a dialog box’s ID.
hWnd
Message
String value representing the message displayed in the dialog box.
BtnId1
Long value representing button 1.
BtnId2
Long value representing button 2.
BtnId3
Long value representing button 3.
BtnId4
Long value representing button 4.
DefaultBtn
Long value representing the default button.

Description

Event fired when dialogs open for the remote panel

This event gets launched when the specified Remote Panel Application dialog box opens.

Syntax

Visual Basic
Public Event OnOpenRemotePanelDialog( _
   ByVal PartProg As PartProgram, _
   ByVal DialogId As Long, _
   ByVal hWnd As Long, _
   ByVal Message As String, _
   ByVal BtnId1 As Long, _
   ByVal BtnId2 As Long, _
   ByVal BtnId3 As Long, _
   ByVal BtnId4 As Long, _
   ByVal DefaultBtn As Long _
)

Parameters

PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.
DialogId
Long value representing a dialog box’s ID.
hWnd
Message
String value representing the message displayed in the dialog box.
BtnId1
Long value representing button 1.
BtnId2
Long value representing button 2.
BtnId3
Long value representing button 3.
BtnId4
Long value representing button 4.
DefaultBtn
Long value representing the default button.

See Also

ApplicationObjectEvents Object


OnOpenRemotePanelDialog2 Event

OnOpenRemotePanelDialog2 Event
PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.
DialogId
hWnd
Message
BtnId1
BtnId2
BtnId3
BtnId4
BtnId5
DefaultBtn

Description

Event fired when dialogs open for the remote panel with five possible buttons

Syntax

Visual Basic
Public Event OnOpenRemotePanelDialog2( _
   ByVal PartProg As PartProgram, _
   ByVal DialogId As Long, _
   ByVal hWnd As Long, _
   ByVal Message As String, _
   ByVal BtnId1 As Long, _
   ByVal BtnId2 As Long, _
   ByVal BtnId3 As Long, _
   ByVal BtnId4 As Long, _
   ByVal BtnId5 As Long, _
   ByVal DefaultBtn As Long _
)

Parameters

PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.
DialogId
hWnd
Message
BtnId1
BtnId2
BtnId3
BtnId4
BtnId5
DefaultBtn

See Also

ApplicationObjectEvents Object


OnSavePartProgram Event

OnSavePartProgram Event
PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.

Description

Event fired when part program is saved

This event gets launched when the specified part program (PartProg) gets saved.

Syntax

Visual Basic
Public Event OnSavePartProgram( _
   ByVal PartProg As PartProgram _
)

Parameters

PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.

See Also

ApplicationObjectEvents Object


OnStartExecution Event

OnStartExecution Event
PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.

Description

Event fired when part program execution begins

This event gets launched when the specified part program (PartProg) begins execution.

Syntax

Visual Basic
Public Event OnStartExecution( _
   ByVal PartProg As PartProgram _
)

Parameters

PartProg
An expression that evaluates to a PartProgram object to determine the part program for which this event should wait.

See Also

ApplicationObjectEvents Object


OnUpdateStatusMessage Event

OnUpdateStatusMessage Event
Msg
String value representing the displayed message.

Description

Event fired when status bar is updated

This event gets launched when the status bar gets updated with the specified message (Msg).

Syntax

Visual Basic
Public Event OnUpdateStatusMessage( _
   ByVal Msg As String _
)

Parameters

Msg
String value representing the displayed message.

See Also

ApplicationObjectEvents Object


ApplicationSettings Object

ApplicationSettings Object
See Also Members

Description

The ApplicationSettings object is a class that contains various properties and methods that allow you to work with PC-DMIS settings.

See Also

ApplicationSettings Members


ApplicationSettings Object Members

ApplicationSettings ObjectMembers
See Also Overview

Public Properties

Public Property WarningDefaultNoSavePrg | Read/Write:
Public Property WarningDefaultOkRotPh9 | Read/Write:
Public Property WarningDefaultOverwritingAlignment | Read/Write:
Public Property WarnNoSavePrg | Read/Write:
Public Property WarnOkMovPh9 | Read/Write:
Public Property WarnOkRotPh9 | Read/Write:
Public Property WarnOverwritingAlignment | Read/Write:

See Also

ApplicationSettings Overview


WarningDefaultNoSavePrg Property

WarningDefaultNoSavePrg Property

Description

Read/Write:

Property type

Read-write property

Syntax

Visual Basic
Public Property WarningDefaultNoSavePrg() As Long

See Also

ApplicationSettings Object


WarningDefaultOkRotPh9 Property

WarningDefaultOkRotPh9 Property

Description

Read/Write:

Property type

Read-write property

Syntax

Visual Basic
Public Property WarningDefaultOkRotPh9() As Long

See Also

ApplicationSettings Object


WarningDefaultOverwritingAlignment Property

WarningDefaultOverwritingAlignment Property

Description

Read/Write:

Property type

Read-write property

Syntax

Visual Basic
Public Property WarningDefaultOverwritingAlignment() As Long

See Also

ApplicationSettings Object


WarnNoSavePrg Property

WarnNoSavePrg Property

Description

Read/Write:

Property type

Read-write property

Syntax

Visual Basic
Public Property WarnNoSavePrg() As Long

See Also

ApplicationSettings Object


WarnOkMovPh9 Property

WarnOkMovPh9 Property

Description

Read/Write:

Property type

Read-write property

Syntax

Visual Basic
Public Property WarnOkMovPh9() As Long

See Also

ApplicationSettings Object


WarnOkRotPh9 Property

WarnOkRotPh9 Property

Description

Read/Write:

Property type

Read-write property

Syntax

Visual Basic
Public Property WarnOkRotPh9() As Long

See Also

ApplicationSettings Object


WarnOverwritingAlignment Property

WarnOverwritingAlignment Property

Description

Read/Write:

Property type

Read-write property

Syntax

Visual Basic
Public Property WarnOverwritingAlignment() As Long

See Also

ApplicationSettings Object


ArrayIndex Object

ArrayIndex Object
See Also Members

Description

The ArrayIndex object is used to set up multi-dimensional feature arrays in PC-DMIS. Methods are provided to add, remove, or edit array upper and lower bounds for array indices.

See Also

ArrayIndex Members


ArrayIndex Object Members

ArrayIndex ObjectMembers
See Also Overview

Public Methods

Public Method AddIndexSet | Adds an array dimension upper/lower bound set Adds the supplied index set to the array index command.
Public Method GetLowerBound | Returns the indexed array dimension lower bound Retrieves the lower bound of the specified index set.
Public Method GetUpperBound | Returns the indexed array dimension upper bound Retrieves the lower bound of the specified index set.
Public Method RemoveIndexSet | Removes the indexed array dimension set Removes the index set specified by index from the array index object.
Public Method SetLowerBound | Sets the indexed array dimension lower bound Sets the lower bound of the specified index set.
Public Method SetUpperBound | Sets the indexed array dimension upper bound Sets the upper bound of the specified index set.

See Also

ArrayIndex Overview


AddIndexSet Method

AddIndexSet Method
LowerBound
Required Long parameter representing the lower bound of the index set to be added.
UpperBound
Required Long parameter representing the lower bound of the index set to be added.

Description

Adds an array dimension upper/lower bound set

Adds the supplied index set to the array index command.

Syntax

Visual Basic
Public Function AddIndexSet( _
   ByVal LowerBound As Long, _
   ByVal UpperBound As Long _
) As Boolean

Parameters

LowerBound
Required Long parameter representing the lower bound of the index set to be added.
UpperBound
Required Long parameter representing the lower bound of the index set to be added.

See Also

ArrayIndex Object


GetLowerBound Method

GetLowerBound Method
index
Required Long parameter that specifies which index set to use in retrieving the lower bound.

Description

Returns the indexed array dimension lower bound

Retrieves the lower bound of the specified index set.

Syntax

Visual Basic
Public Function GetLowerBound( _
   ByVal index As Long _
) As Long

Parameters

index
Required Long parameter that specifies which index set to use in retrieving the lower bound.

See Also

ArrayIndex Object


GetUpperBound Method

GetUpperBound Method
index
Required Long parameter that specifies which index set to use in retrieving the lower bound.

Description

Returns the indexed array dimension upper bound

Retrieves the lower bound of the specified index set.

Syntax

Visual Basic
Public Function GetUpperBound( _
   ByVal index As Long _
) As Long

Parameters

index
Required Long parameter that specifies which index set to use in retrieving the lower bound.

See Also

ArrayIndex Object


RemoveIndexSet Method

RemoveIndexSet Method
index
Required Long parameter that specifies which index set to remove.

Description

Removes the indexed array dimension set

Removes the index set specified by index from the array index object.

Syntax

Visual Basic
Public Function RemoveIndexSet( _
   ByVal index As Long _
) As Boolean

Parameters

index
Required Long parameter that specifies which index set to remove.

See Also

ArrayIndex Object


SetLowerBound Method

SetLowerBound Method
index
Required Long parameter that specifies which index set to use in setting the lower bound.
LowerBound

Description

Sets the indexed array dimension lower bound

Sets the lower bound of the specified index set.

Syntax

Visual Basic
Public Function SetLowerBound( _
   ByVal index As Long, _
   ByVal LowerBound As Long _
) As Boolean

Parameters

index
Required Long parameter that specifies which index set to use in setting the lower bound.
LowerBound

See Also

ArrayIndex Object


SetUpperBound Method

SetUpperBound Method
index
Required Long parameter that specifies which index set to use in setting the upper bound.
UpperBound

Description

Sets the indexed array dimension upper bound Sets the upper bound of the specified index set.

Syntax

Visual Basic
Public Function SetUpperBound( _
   ByVal index As Long, _
   ByVal UpperBound As Long _
) As Boolean

Parameters

index
Required Long parameter that specifies which index set to use in setting the upper bound.
UpperBound

See Also

ArrayIndex Object


Attach Object

Attach Object
See Also Members

Description

The Attach object attaches part programs to the current part program. The current part program can then access objects from the attached part programs.

See Also

Attach Members


Attach Object Members

Attach ObjectMembers
See Also Overview

Public Properties

Public Property AttachedAlign | ID associated with an alignment in the attached program that corresponds with an alignment in the attaching program.
Public Property EXECUTE | Read/Write: Indicates whether attached program should be executed at attachment point This returns or sets a BOOLEAN value that determines whether or not the attached part program should be executed when PC-DMIS encounters the attached program.
Public Property ID | Read/Write: ID to be used when referencing attached part program ID associated with the attached part program. This ID identifies items in the attached part program. For example, if the ID for the attach statement is "PART2", then feature "F1" in the attached program can be referred to as "F1:PART2".
Public Property LocalAlign | ID associated with an alignment in the attaching program that corresponds to an alignment in the attached program.
Public Property PartName | Read/Write: Filename of part program to attach File name of the attached part program.

See Also

Attach Overview


AttachedAlign Property

AttachedAlign Property

Description

ID associated with an alignment in the attached program that corresponds with an alignment in the attaching program.

Property type

Read-write property

Syntax

Visual Basic
Public Property AttachedAlign() As String

Return Type

Read/write String.

See Also

Attach Object | LocalAlign Property


EXECUTE Property

EXECUTE Property

Description

Read/Write: Indicates whether attached program should be executed at attachment point

This returns or sets a BOOLEAN value that determines whether or not the attached part program should be executed when PC-DMIS encounters the attached program.

Property type

Read-write property

Syntax

Visual Basic
Public Property EXECUTE() As Boolean

Return Type

Read/write Boolean

See Also

Attach Object


ID Property

ID Property

Description

Read/Write: ID to be used when referencing attached part program

ID associated with the attached part program. This ID identifies items in the attached part program. For example, if the ID for the attach statement is "PART2", then feature "F1" in the attached program can be referred to as "F1:PART2".

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As String

Return Type

Read/write String

See Also

Attach Object


LocalAlign Property

LocalAlign Property

Description

ID associated with an alignment in the attaching program that corresponds to an alignment in the attached program.

Property type

Read-write property

Syntax

Visual Basic
Public Property LocalAlign() As String

Return Type

Read/write String

See Also

Attach Object


PartName Property

PartName Property

Description

Read/Write: Filename of part program to attach File name of the attached part program.

Property type

Read-write property

Syntax

Visual Basic
Public Property PartName() As String

Return Type

Read/write String.

See Also

Attach Object


Autotrigger Object

Autotrigger Object
See Also Members

Description

The Autotrigger object automatically takes hits when the probe enters a specified zone.

See Also

Autotrigger Members


Autotrigger Object Members

Autotrigger ObjectMembers
See Also Overview

Public Properties

Public Property autotriggeron | Read/Write: Autotrigger ON/OFF Determines whether or not the Autotrigger feature is used when measuring.
Public Property beepingon | Read/Write: Autotrigger Beeping ON/OFF Determines whether or not the Beeping feature is used when the probe approaches the target. The closer you get to your target the more frequently you will hear the beeps.
Public Property Radius | Read/Write: Tolerance radius Determines the size of the radius, or tolerance zone, that surrounds the original hit location. When the probe enters this tolerance zone it will automatically take a hit.

See Also

Autotrigger Overview


autotriggeron Property

autotriggeron Property

Description

Read/Write: Autotrigger ON/OFF Determines whether or not the Autotrigger feature is used when measuring.

Property type

Read-write property

Syntax

Visual Basic
Public Property autotriggeron() As Long

Return Type

Read/write Boolean.

See Also

Autotrigger Object


beepingon Property

beepingon Property

Description

Read/Write: Autotrigger Beeping ON/OFF Determines whether or not the Beeping feature is used when the probe approaches the target. The closer you get to your target the more frequently you will hear the beeps.

Property type

Read-write property

Syntax

Visual Basic
Public Property beepingon() As Long

Return Type

Read/write Boolean.

See Also

Autotrigger Object


Radius Property

Radius Property

Description

Read/Write: Tolerance radius Determines the size of the radius, or tolerance zone, that surrounds the original hit location. When the probe enters this tolerance zone it will automatically take a hit.

Property type

Read-write property

Syntax

Visual Basic
Public Property Radius() As Double

Return Type

Read/write Double.

See Also

Autotrigger Object


BasicScan Object

BasicScan Object
See Also Members

Description

BasicScan objects are created from more generic Command objects to pass information specific to the scan command back and forth. At present only DCC basic scans are user accessible.

Object Model

Remarks

The tables below describes the different combination of Objects that can be used to create and execute a Basic Scan. The Methods will only work with the combination of different of Objects selected from this table (i.e. if you decide to set a method type of BSCANMETH_CIRCLE, then you have to use a Filter type of BSF_DISTANCE etc).

Table 1

Method | Filters
BSCANMETH_LINEAR | BSF_DISTANCE BSF_BODYAXISDISTANCE BSF_VARIABLEDISTANCE
BSCANMETH_EDGE | BSF_DISTANCE BSF_VARIABLEDISTANCE
BSCANMETH_CIRCLE | BSF_DISTANCE
BSCANMETH_CYLINDER | BSF_DISTANCE
BSCANMETH_STRAIGHTLINE | BSF_DISTANCE
BSCANMETH_CENTER | BSF_DISTANCE

Table 2

Method | NominalMode
BSCANMETH_LINEAR | BSCANNMODE_FINDCADNOMINAL BSCANNMODE_MASTERDATA
BSCANMETH_EDGE | BSCANNMODE_FINDCADNOMINAL BSCANNMODE_MASTERDATA
BSCANMETH_CIRCLE | BSCANNMODE_FINDCADNOMINAL BSCANNMODE_MASTERDATA
BSCANMETH_CYLINDER | BSCANNMODE_FINDCADNOMINAL BSCANNMODE_MASTERDATA
BSCANMETH_STRAIGHTLINE | BSCANNMODE_FINDCADNOMINAL BSCANNMODE_MASTERDATA
BSCANMETH_CENTER | BSCANNMODE_FINDCADNOMINAL BSCANNMODE_MASTERDATA

Table 3

Method | OperationMode
BSCANMETH_LINEAR | BSCANOPMODE_REGULARLEARN BSCANOPMODE_DEFINEPATHFROMHITS BSCANOPMODE_NORMALEXECUTION
BSCANMETH_EDGE | BSCANOPMODE_REGULARLEARN BSCANOPMODE_NORMALEXECUTION
BSCANMETH_CIRCLE | BSCANOPMODE_HIGHSPEEDFEATUREBASED BSCANOPMODE_NORMALEXECUTION
BSCANMETH_CYLINDER | BSCANOPMODE_HIGHSPEEDFEATUREBASED BSCANOPMODE_NORMALEXECUTION
BSCANMETH_STRAIGHTLINE | BSCANOPMODE_HIGHSPEEDFEATUREBASED BSCANOPMODE_NORMALEXECUTION
BSCANMETH_CENTER | BSCANOPMODE_REGULARLEARN BSCANOPMODE_NORMALEXECUTION

Table 4

Method | HitType
BSCANMETH_LINEAR | BSCANHIT_VECTOR BSCANHIT_SURFACE
BSCANMETH_EDGE | BSCANHIT_EDGE
BSCANMETH_CIRCLE | BSCANHIT_VECTOR
BSCANMETH_CYLINDER | BSCANHIT_VECTOR
BSCANMETH_STRAIGHTLINE | BSCANHIT_VECTOR
BSCANMETH_CENTER | BSCANHIT_VECTOR

Table 5
Method | BoundaryCondition
BSCANMETH_LINEAR | BSBOUNDCOND_SPHENTRY BSBOUNDCOND_PLANECROSS BSBOUNDCOND_CYLINDER BSBOUNDCOND_CONE
BSCANMETH_EDGE | BSBOUNDCOND_SPHENTRY BSBOUNDCOND_PLANECROSS BSBOUNDCOND_CYLINDER BSBOUNDCOND_CONE
BSCANMETH_CIRCLE | None
BSCANMETH_CYLINDER | None
BSCANMETH_STRAIGHTLINE | None
BSCANMETH_CENTER | None

See Also

BasicScan Members | BasicScanCommand Property


BasicScan Object Members

BasicScan ObjectMembers
See Also Overview

Public Methods

Public Method AddControlPoint | Adds a control point to the scan Adds a control point to a scan.
Public Method CreateBasicScan | Used for DCC and Manual Scans to cause creation of basic scan object This method creates a basic scan object.
Public Method GenerateScan | Generates the points for the scan
Public Method GetBoundaryConditionParams | Gets the boundary condition parameters
Public Method GetBoundaryPoint | Returns the boundary point specified by the index
Public Method GetControlPoint | Returns the control point specified by the index Returns the control point specified by the index.
Public Method GetFilterParams | Gets parameters used in filtering of scan data
Public Method GetHitParams | Gets parameters for the hit type used in the scan
Public Method GetHitTValue | Returns T deviation values for specified scansion hit
Public Method GetMethodParams | Gets the scan method parameters
Public Method GetMethodPointData | Gets scan points and vectors via pointdata objects This method is provided as a shortcut to getting these commonly used scan parameters all at once.
Public Method GetNomsParams | Gets the parameters used in finding of scan nominals
Public Method GetParams | Gets the basic scanning parameters of the scan This method is provided as a shortcut to getting commonly used scan parameters all at once.
Public Method RemoveControlPoint | Removes the control point at the specified index Removes a control point.
Public Method SetBoundaryConditionParams | Sets the boundary condition parameters Boolean value. Boolean returns true if the function succeeds, false if it fails.
Public Method SetBoundaryPoint | Sets the boundary point specified by the index paramter Sets a boundary point.
Public Method SetControlPoint | Sets the control point at the specified index Sets a control point at the specified index.
Public Method SetFilterParams | Sets parameters for filtering scan data This method is provided as a shortcut to set these commonly used scan parameters all at once.
Public Method SetHitParams | Sets parameters for the hit type used in the scan This method is provided as a shortcut to set these commonly used scan parameters all at once.
Public Method SetMethodParams | Sets the scan method parameters This method is provided as a shortcut to set these commonly used scan parameters all at once.
Public Method SetMethodPointData | Sets scan points and vectors via pointdata objects This method is provided as a shortcut to set these commonly used scan parameters all at once.
Public Method SetNomsParams | Sets the parameters used in finding of scan nominals This method is provided as a shortcut to set these commonly used scan parameters all at once.
Public Method SetParams | Sets the basic scanning parameters of the scan This method is provided as a shortcut to set these commonly used scan parameters all at once.

Public Properties

Public Property AutoClearPlane | Read/Write: Boolean value indicating if auto clear planes should be used Determines whether auto clearance planes mode is on or off.
Public Property BoundaryCondition | Read/Write: Boundary Condition (Sphere, Plane Cross, Cone, etc. Represents the boundary condition type.
Public Property BoundaryConditionAxisV | Read/Write: Returns/Sets via point data object the boundary scan's axis vector Represents the boundary condition axis vector. This vector is used as the axis of the Cylindrical and Conical BoundaryConditions.
Public Property BoundaryConditionCenter | Read/Write: Returns/Sets via point data object a boundary scan's center point Represents the boundary condition center. This Point is used by all Boundary Conditions and is the location of the Boundary Condition.
Public Property BoundaryConditionEndApproach | Read/Write: Returns/Sets via point data object the end approach for a boundary scan Represents the boundary condition end approach vector. This vector is used by all Boundary Conditions and is the Approach Vector of the Probe as it crosses the Boundary condition.
Public Property BoundaryConditionPlaneV | Read/Write: Returns/Sets via point data object the boundary scan's plane vector Represents the boundary condition plane vector. This vector is the normal vector of the Plane used by the Plane and OldStyle Boundary Conditions.
Public Property BoundaryPointCount | Read/Write: Long value indicating the number of boundary points for patch scans Indicates the number of boundary points to used in a patch scan.
Public Property DisplayHits | Read/Write: Boolean value indicating whether hits should be displayed or not Determines whether hits of the scan are displayed in the Edit window or not.
Public Property Filter | Read/Write: Distance Filter Type Represents the filter type.
Public Property HitType | Read/Write: Scan Hit Type (Vector, Surface, Edge) Represents the type of hit to use.
Public Property Method | Read/Write: Scan Type Represents the method type for this scan.
Public Property MethodCutPlane | Read/Write: Returns/Sets via point data object the cut plane vector Represents the method’s cut plane vector.
Public Property MethodEnd | Read/Write: Returns/Sets via point data object the ending scan point Represents the scan’s end point.
Public Property MethodEndTouch | Read/Write: Returns/Sets via point data object the end touch vector Represents the method’s end touch vector.
Public Property MethodInitDir | Read/Write: Returns/Sets via point data object the initial scan direction vector Represents the method’s initial direction vector.
Public Property MethodInitTopSurf | Read/Write: Returns/Sets via point data object the initial top surface vector Represents the initial Surface Vector for the Edge method.
Public Property MethodInitTouch | Read/Write: Returns/Sets via point data object the initial touch vector Represents the method’s initial touch vector.
Public Property MethodStart | Read/Write: Returns/Sets via point data object the starting scan point Represents the scan’s start point.
Public Property NominalMode | Read/Write: Find cad nominals or use master data Represents how to determine the nominal values for this scan.
Public Property OperationMode | Read/Write: Scan Operation Mode Represents mode of operation of the scan.
Public Property SinglePoint | Read/Write: Returns/Sets Single Point Mode Flag Determines whether single point mode is on or off.

See Also

BasicScan Overview | BasicScanCommand Property


AddControlPoint Method

AddControlPoint Method
ControlPoint
Expression that evaluates to a ControlPoint object.

Description

Adds a control point to the scan Adds a control point to a scan.

Syntax

Visual Basic
Public Function AddControlPoint( _
   ByVal ControlPoint As ControlPoint _
) As Boolean

Parameters

ControlPoint
Expression that evaluates to a ControlPoint object.

Return Type

Boolean value. If the value is 1 (true), it adds a control point to the scan.

See Also

BasicScan Object


CreateBasicScan Method

CreateBasicScan Method

Description

Used for DCC and Manual Scans to cause creation of basic scan object This method creates a basic scan object.

Syntax

Visual Basic
Public Function CreateBasicScan() As Boolean

Return Type

Boolean value. If the value is 1 (or true), it causes DCC and Manual Scans to create a basic scan object.

See Also

BasicScan Object


GenerateScan Method

GenerateScan Method

Description

Generates the points for the scan

Syntax

Visual Basic
Public Function GenerateScan() As Boolean

See Also

BasicScan Object


GetBoundaryConditionParams Method

GetBoundaryConditionParams Method
nCrossings
Required Long variable that gets the number of crossings for this boundary condition. The scan would stop after the probe crosses (breaks) the Boundary Condition like a Sphere, Cylinder, Cone, or a Plane the given number of times.
dRadius
Required Double variable that gets the radius of the boundary condition. This is used by the Spherical and Cylindrical Boundary Conditions.
dHalfAngle
Required Double variable that gets the half-angle of the cone-type boundary condition, or gets zero if the boundary condition is not of cone type.

Description

Gets the boundary condition parameters

Syntax

Visual Basic
Public Function GetBoundaryConditionParams( _
   ByRef nCrossings As Long, _
   ByRef dRadius As Double, _
   ByRef dHalfAngle As Double _
) As Boolean

Parameters

nCrossings
Required Long variable that gets the number of crossings for this boundary condition. The scan would stop after the probe crosses (breaks) the Boundary Condition like a Sphere, Cylinder, Cone, or a Plane the given number of times.
dRadius
Required Double variable that gets the radius of the boundary condition. This is used by the Spherical and Cylindrical Boundary Conditions.
dHalfAngle
Required Double variable that gets the half-angle of the cone-type boundary condition, or gets zero if the boundary condition is not of cone type.

Return Type

Boolean value. This returns true if the function succeeds, false if it fails.

Remarks

Boundary Condition | GetBoundaryConditionParams(nCrossings, dRadius, dHalfAngle)
Plane | nCrossings
Cone | nCrossings, ,dHalfAngle
Cylinder | nCrossings, dRadius
Sphere | nCrossings, dRadius

See Also

BasicScan Object


GetBoundaryPoint Method

GetBoundaryPoint Method
index
Required Long which indicates which boundary point to get.
X
Required Long variable that will hold the X value of the boundary point.
Y
Required Long variable that will hold the Y value of the boundary point.
Z
Required Long variable that will hold the Z value of the boundary point.

Description

Returns the boundary point specified by the index

Syntax

Visual Basic
Public Function GetBoundaryPoint( _
   ByVal index As Long, _
   ByRef X As Double, _
   ByRef Y As Double, _
   ByRef Z As Double _
) As Boolean

Parameters

index
Required Long which indicates which boundary point to get.
X
Required Long variable that will hold the X value of the boundary point.
Y
Required Long variable that will hold the Y value of the boundary point.
Z
Required Long variable that will hold the Z value of the boundary point.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

This function works with patch scans. Use the BoundaryPointCount property to determine how many boundary points are available.

See Also

BasicScan Object


GetControlPoint Method

GetControlPoint Method
index
Long value which indicates which control point to return.

Description

Returns the control point specified by the index Returns the control point specified by the index.

Syntax

Visual Basic
Public Function GetControlPoint( _
   ByVal index As Long _
) As ControlPoint

Parameters

index
Long value which indicates which control point to return.

Return Type

ControlPoint object.

See Also

BasicScan Object


GetFilterParams Method

GetFilterParams Method
dCutAxisLocation
nAxis
Required Long variable that gets the cut axis. Returns non-zero only for axis filters. For axis filters, 0 means the X axis, 1 means the Y-axis, and 2 means the Z-axis.
dMaxIncrement
Required Double variable that gets the maximum increment. For fixed-length filters, this is simply the fixed increment for Variable Distance Filters.
dMinIncrement
Required Double variable that gets the minimum increment.
dMaxAngle
Required Double variable that gets the maximum angle used in Variable Distance Filters.
dMinAngle
Required Double variable that gets the minimum angle used in Variable Distance Filters.

Description

Gets parameters used in filtering of scan data

Syntax

Visual Basic
Public Function GetFilterParams( _
   ByRef dCutAxisLocation As Double, _
   ByRef nAxis As Long, _
   ByRef dMaxIncrement As Double, _
   ByRef dMinIncrement As Double, _
   ByRef dMaxAngle As Double, _
   ByRef dMinAngle As Double _
) As Boolean

Parameters

dCutAxisLocation
nAxis
Required Long variable that gets the cut axis. Returns non-zero only for axis filters. For axis filters, 0 means the X axis, 1 means the Y-axis, and 2 means the Z-axis.
dMaxIncrement
Required Double variable that gets the maximum increment. For fixed-length filters, this is simply the fixed increment for Variable Distance Filters.
dMinIncrement
Required Double variable that gets the minimum increment.
dMaxAngle
Required Double variable that gets the maximum angle used in Variable Distance Filters.
dMinAngle
Required Double variable that gets the minimum angle used in Variable Distance Filters.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

Filter | GetFilterParams (dCutAxisLocation, nAxis, dMaxIncrement, dMinIncrement, dMaxAngle, dMinAngle)
Distance | ,,dMaxIncrement
BodyAxisDistance | ,nAxis, dMaxIncrement
VariableDistance | ,,dMaxIncrement, dMinIncrement, dMaxAngle, dMinAngle

See Also

BasicScan Object


GetHitParams Method

GetHitParams Method
nInitSamples
Required Long variable that gets the number of initial sample hits for the hits in this scan. It always returns zero for basic hits and vector hits.
nPermSamples
Required Long variable that gets the number of permanent sample hits for the hits in this scan. It always returns zero for basic hits and vector hits.
dSpacer
Required Double variable that gets the spacing of the sample hits from the hit center. It always returns zero for basic hits and vector hits.
dIndent
Required Double variable that gets the indent of the sample hits from the hit center. It always returns zero for basic hits, vector hits, and surface.
dDepth
Required Double variable that gets the depth of the sample hits from the hit center. It always returns zero for basic hits, vector hits, and surface.

Description

Gets parameters for the hit type used in the scan

Syntax

Visual Basic
Public Function GetHitParams( _
   ByRef nInitSamples As Long, _
   ByRef nPermSamples As Long, _
   ByRef dSpacer As Double, _
   ByRef dIndent As Double, _
   ByRef dDepth As Double _
) As Boolean

Parameters

nInitSamples
Required Long variable that gets the number of initial sample hits for the hits in this scan. It always returns zero for basic hits and vector hits.
nPermSamples
Required Long variable that gets the number of permanent sample hits for the hits in this scan. It always returns zero for basic hits and vector hits.
dSpacer
Required Double variable that gets the spacing of the sample hits from the hit center. It always returns zero for basic hits and vector hits.
dIndent
Required Double variable that gets the indent of the sample hits from the hit center. It always returns zero for basic hits, vector hits, and surface.
dDepth
Required Double variable that gets the depth of the sample hits from the hit center. It always returns zero for basic hits, vector hits, and surface.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

BasicScan Object


GetHitTValue Method

GetHitTValue Method
index
T

Description

Returns T deviation values for specified scansion hit

Syntax

Visual Basic
Public Function GetHitTValue( _
   ByVal index As Long, _
   ByRef T As Double _
) As Boolean

Parameters

index
T

See Also

BasicScan Object


GetMethodParams Method

GetMethodParams Method
bIn
Required variable that gets 0 for Inside scans, 1 for Outside scans, and 2 for Plane Circle scans.
bCenteringType
Required variable for Centering Scans that gets 0 for Axis Centering and 1 for Plane centering.
nCenteringDirection
Required Long variable that takes a +1 for measurement with the direction of the probe and -1 for against the direction of probe.
dDiameter
Required Double variable that gets the diameter of the circle or cylinder scan, and zero otherwise.
dArcAngle
Required Double variable that gets arc angle for circle and cylinder scans.
dDepth
Required Double variable that gets the depth for cylinder scans, and zero otherwise.
dPitch
Required Double variable that gets a pitch for cylinder scans.

Description

Gets the scan method parameters

Syntax

Visual Basic
Public Function GetMethodParams( _
   ByRef bIn As ENUM_SCAN_INOUT_TYPES, _
   ByRef bCenteringType As Boolean, _
   ByRef nCenteringDirection As Long, _
   ByRef dDiameter As Double, _
   ByRef dArcAngle As Double, _
   ByRef dDepth As Double, _
   ByRef dPitch As Double _
) As Boolean

Parameters

bIn
Value | Description
SCAN_INNER | Inside scans
SCAN_OUTER | Outside scans
SCAN_PLANAR | Plane Circle scans
Required variable that gets 0 for Inside scans, 1 for Outside scans, and 2 for Plane Circle scans.
bCenteringType
Required variable for Centering Scans that gets 0 for Axis Centering and 1 for Plane centering.
nCenteringDirection
Required Long variable that takes a +1 for measurement with the direction of the probe and -1 for against the direction of probe.
dDiameter
Required Double variable that gets the diameter of the circle or cylinder scan, and zero otherwise.
dArcAngle
Required Double variable that gets arc angle for circle and cylinder scans.
dDepth
Required Double variable that gets the depth for cylinder scans, and zero otherwise.
dPitch
Required Double variable that gets a pitch for cylinder scans.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

Method | GetMethodParams (bIn, bCenteringType, nCenteringDirection, dDiameter, dArcAngle, dDepth, dPitch)
Linear | None
Edge | None
Circle | bIn, , , dDiameter, dArcAngle, dDepth
Cylinder | bIn, , , dDiameter, dArcAngle, dDepth, dPitch
Straight Line | None
Center | , bCenteringType, nCenteringDirection

See Also

BasicScan Object


GetMethodPointData Method

GetMethodPointData Method
MethodStart
Required PointData object that gets the MethodStart property.
MethodEnd
Required PointData object that gets the MethodEnd property.
MethodInitTouch
Required PointData object that gets the MethodInitTouch property.
MethodEndTouch
Required PointData object that gets the MethodEndTouch property.
MethodInitDir
Required PointData object that gets the MethodInitDir property.
MethodInitTopSurf
MethodCutPlane
Required PointData object that gets the MethodCutPlane property.

Description

Gets scan points and vectors via pointdata objects This method is provided as a shortcut to getting these commonly used scan parameters all at once.

Syntax

Visual Basic
Public Function GetMethodPointData( _
   ByVal MethodStart As PointData, _
   ByVal MethodEnd As PointData, _
   ByVal MethodInitTouch As PointData, _
   ByVal MethodEndTouch As PointData, _
   ByVal MethodInitDir As PointData, _
   ByVal MethodInitTopSurf As PointData, _
   ByVal MethodCutPlane As PointData _
) As Boolean

Parameters

MethodStart
Required PointData object that gets the MethodStart property.
MethodEnd
Required PointData object that gets the MethodEnd property.
MethodInitTouch
Required PointData object that gets the MethodInitTouch property.
MethodEndTouch
Required PointData object that gets the MethodEndTouch property.
MethodInitDir
Required PointData object that gets the MethodInitDir property.
MethodInitTopSurf
MethodCutPlane
Required PointData object that gets the MethodCutPlane property.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

If scan is a BasicScanCommand object, and MS, ME, MIT, MET, MID, and MCP are all Dimensioned as Object, the following are equivalent:

scan.GetMethodParams MS,ME,MIT,MET,MID,MCP

set MS = scan.MethodStart
set ME = scan.MethodEnd
set MIT = scan.MethodInitTouch
set MET = scan.MethodEndTouch
set MID = scan.MethodInitDir
set MCP = scan.MethodCutPlane

Example

See Also

BasicScan Object | Scan Object


GetNomsParams Method

GetNomsParams Method
dFindNomsTolerance
Required Double variable that gets the Find Noms tolerance and is used only when the NominalMode property is BSCANNMODE_FINDCADNOMINAL.
dSurfaceThickness
Required Double variable that gets the surface thickness and is used only when the NominalMode property is BSCANNMODE_FINDCADNOMINAL.
dEdgeThickness
Required Double variable that gets the edge thickness and is used only when the NominalMode property is BSCANNMODE_FINDCADNOMINAL and when the Method property is BSCANMETH_EDGE.

Description

Gets the parameters used in finding of scan nominals

Syntax

Visual Basic
Public Function GetNomsParams( _
   ByRef dFindNomsTolerance As Double, _
   ByRef dSurfaceThickness As Double, _
   ByRef dEdgeThickness As Double _
) As Boolean

Parameters

dFindNomsTolerance
Required Double variable that gets the Find Noms tolerance and is used only when the NominalMode property is BSCANNMODE_FINDCADNOMINAL.
dSurfaceThickness
Required Double variable that gets the surface thickness and is used only when the NominalMode property is BSCANNMODE_FINDCADNOMINAL.
dEdgeThickness
Required Double variable that gets the edge thickness and is used only when the NominalMode property is BSCANNMODE_FINDCADNOMINAL and when the Method property is BSCANMETH_EDGE.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

BasicScan Object


GetParams Method

GetParams Method
Method
Required Long variable that gets the Method property.
Filter
Required Long variable that gets the Filter property.
OperationMode
Required Long variable that gets the OperationMode property.
HitType
Required Long variable that gets the HitType property.
NominalMode
Required Long variable that gets the NominalMode property.
BoundaryCondition
Required Long variable that gets the BoundaryCondition property.

Description

Gets the basic scanning parameters of the scan This method is provided as a shortcut to getting commonly used scan parameters all at once.

Syntax

Visual Basic
Public Function GetParams( _
   ByRef Method As Long, _
   ByRef Filter As Long, _
   ByRef OperationMode As Long, _
   ByRef HitType As Long, _
   ByRef NominalMode As Long, _
   ByRef BoundaryCondition As Long _
) As Boolean

Parameters

Method
Required Long variable that gets the Method property.
Filter
Required Long variable that gets the Filter property.
OperationMode
Required Long variable that gets the OperationMode property.
HitType
Required Long variable that gets the HitType property.
NominalMode
Required Long variable that gets the NominalMode property.
BoundaryCondition
Required Long variable that gets the BoundaryCondition property.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

If scan is a BasicScanCommand object, and M, F, O, H, N,and B are all Dimensioned as Object, the following are equivalent:

scan.GetParams M, F, O, H, N, B

M = scan.Method
F = scan.Filter
O = scan.OperationMode
H = scan.HitType
N = scan.NominalMode
B = scan.BoundaryCondition

See Also

BasicScan Object


RemoveControlPoint Method

RemoveControlPoint Method
index
Required Long value which indicates which control point to remove.

Description

Removes the control point at the specified index Removes a control point.

Syntax

Visual Basic
Public Function RemoveControlPoint( _
   ByVal index As Long _
) As Boolean

Parameters

index
Required Long value which indicates which control point to remove.

Return Type

Boolean value. If set to 1 (true), the control point is removed at the specified index.

See Also

BasicScan Object


SetBoundaryConditionParams Method

SetBoundaryConditionParams Method
nCrossings
Required Long that sets the number of crossings for this boundary condition.
dRadius
Required Double that sets the radius of the boundary condition.
dHalfAngle
Required Double that sets the half-angle of the cone-type boundary condition, or is ignored if the boundary condition is not of cone type.

Description

Sets the boundary condition parameters Boolean value. Boolean returns true if the function succeeds, false if it fails.

Syntax

Visual Basic
Public Function SetBoundaryConditionParams( _
   ByVal nCrossings As Long, _
   ByVal dRadius As Double, _
   ByVal dHalfAngle As Double _
) As Boolean

Parameters

nCrossings
Required Long that sets the number of crossings for this boundary condition.
dRadius
Required Double that sets the radius of the boundary condition.
dHalfAngle
Required Double that sets the half-angle of the cone-type boundary condition, or is ignored if the boundary condition is not of cone type.

Remarks

Boundary Condition | SetBoundaryConditionParams (nCrossings, dRadius, dHalfAngle)
Plane | Ncrossings
Cone | NCrossings,, dHalfAngle
Cylinder | NCrossings, dRadius
Sphere | NCrossings, dRadius

See Also

BasicScan Object


SetBoundaryPoint Method

SetBoundaryPoint Method
index
Required Long which indicates which boundary point to set.
X
Required Long that indicates the X value of the boundary point.
Y
Required Long that indicates the Y value of the boundary point.
Z
Required Long that indicates the Z value of the boundary point.

Description

Sets the boundary point specified by the index paramter Sets a boundary point.

Syntax

Visual Basic
Public Function SetBoundaryPoint( _
   ByVal index As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double _
) As Boolean

Parameters

index
Required Long which indicates which boundary point to set.
X
Required Long that indicates the X value of the boundary point.
Y
Required Long that indicates the Y value of the boundary point.
Z
Required Long that indicates the Z value of the boundary point.

Remarks

This function works with patch scans. Use the BoundaryPointCount property to set the number of boundary points.

See Also

BasicScan Object


SetControlPoint Method

SetControlPoint Method
index
Required Long value which indicates which control point to set.
ControlPoint

Description

Sets the control point at the specified index Sets a control point at the specified index.

Syntax

Visual Basic
Public Function SetControlPoint( _
   ByVal index As Long, _
   ByVal ControlPoint As ControlPoint _
) As Boolean

Parameters

index
Required Long value which indicates which control point to set.
ControlPoint

Return Type

Boolean value. If set to 1 (true), the control point is set at the specified index.

See Also

BasicScan Object


SetFilterParams Method

SetFilterParams Method
dCutAxisLocation
nAxis
Required Long that sets the cut axis. It is used only for axis filters. For axis filters, 0 means the X axis, 1 means the Y-axis, and 2 means the Z-axis.
dMaxIncrement
Required Double that sets the maximum increment. For fixed-length filters, this is simply the fixed increment
dMinIncrement
Required Double that sets the minimum increment.
dMaxAngle
Required Double that sets the maximum angle.
dMinAngle
Required Double that sets the minimum angle.

Description

Sets parameters for filtering scan data This method is provided as a shortcut to set these commonly used scan parameters all at once.

Syntax

Visual Basic
Public Function SetFilterParams( _
   ByVal dCutAxisLocation As Double, _
   ByVal nAxis As Long, _
   ByVal dMaxIncrement As Double, _
   ByVal dMinIncrement As Double, _
   ByVal dMaxAngle As Double, _
   ByVal dMinAngle As Double _
) As Boolean

Parameters

dCutAxisLocation
nAxis
Required Long that sets the cut axis. It is used only for axis filters. For axis filters, 0 means the X axis, 1 means the Y-axis, and 2 means the Z-axis.
dMaxIncrement
Required Double that sets the maximum increment. For fixed-length filters, this is simply the fixed increment
dMinIncrement
Required Double that sets the minimum increment.
dMaxAngle
Required Double that sets the maximum angle.
dMinAngle
Required Double that sets the minimum angle.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

Filter | SetFilterParams (dCutAxisLocation, nAxis, dMaxIncrement, dMinIncrement, dMaxAngle, dMinAngle)
Distance | ,,dMaxIncrement
BodyAxisDistance | ,nAxis, dMaxIncrement
VariableDistance | ,,dMaxIncrement, dMinIncrement, dMaxAngle, dMinAngle

See Also

BasicScan Object


SetHitParams Method

SetHitParams Method
nInitSamples
Required Long that sets the number of initial sample hits for the hits in this scan. It is ignored for basic hits and vector hits.
nPermSamples
Required Long that sets the number of permanent sample hits for the hits in this scan. It is ignored for basic hits and vector hits.
dSpacer
Required Double that sets the spacing of the sample hits from the hit center. It is ignored for basic hits and vector hits.
dIndent
Required Double that sets the indent of the sample hits from the hit center. It is ignored for basic hits, vector hits, and surface.
dDepth
Required Double that sets the depth of the sample hits from the hit center. It is ignored for basic hits, vector hits, and surface.

Description

Sets parameters for the hit type used in the scan This method is provided as a shortcut to set these commonly used scan parameters all at once.

Syntax

Visual Basic
Public Function SetHitParams( _
   ByVal nInitSamples As Long, _
   ByVal nPermSamples As Long, _
   ByVal dSpacer As Double, _
   ByVal dIndent As Double, _
   ByVal dDepth As Double _
) As Boolean

Parameters

nInitSamples
Required Long that sets the number of initial sample hits for the hits in this scan. It is ignored for basic hits and vector hits.
nPermSamples
Required Long that sets the number of permanent sample hits for the hits in this scan. It is ignored for basic hits and vector hits.
dSpacer
Required Double that sets the spacing of the sample hits from the hit center. It is ignored for basic hits and vector hits.
dIndent
Required Double that sets the indent of the sample hits from the hit center. It is ignored for basic hits, vector hits, and surface.
dDepth
Required Double that sets the depth of the sample hits from the hit center. It is ignored for basic hits, vector hits, and surface.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

BasicScan Object


SetMethodParams Method

SetMethodParams Method
bIn
Required variable that sets 0 for Inside scans, 1 for Outside scans, and 2 for Plane Circle scans.
bCenteringType
Required variable for Centering Scans that sets 0 for Axis Centering and 1 for Plane centering.
nCenteringDirection
Required Long variable that sets +1 for measurement with the direction of the probe and -1 for against the direction of probe.
dDiameter
Required Double variable that sets the diameter of the circle or cylinder scan, and zero otherwise.
dArcAngle
Required Double variable that sets arc angle for circle and cylinder scans.
dDepth
Required Double variable that sets the depth for circle and cylinder scans, and zero otherwise.
dPitch
Required Double variable that sets Pitch for Cylinder scans.

Description

Sets the scan method parameters This method is provided as a shortcut to set these commonly used scan parameters all at once.

Syntax

Visual Basic
Public Function SetMethodParams( _
   ByVal bIn As ENUM_SCAN_INOUT_TYPES, _
   ByVal bCenteringType As Boolean, _
   ByVal nCenteringDirection As Long, _
   ByVal dDiameter As Double, _
   ByVal dArcAngle As Double, _
   ByVal dDepth As Double, _
   ByVal dPitch As Double _
) As Boolean

Parameters

bIn
Value | Description
SCAN_INNER | Inside scans
SCAN_OUTER | Outside scans
SCAN_PLANAR | Plane Circle scans
Required variable that sets 0 for Inside scans, 1 for Outside scans, and 2 for Plane Circle scans.
bCenteringType
Required variable for Centering Scans that sets 0 for Axis Centering and 1 for Plane centering.
nCenteringDirection
Required Long variable that sets +1 for measurement with the direction of the probe and -1 for against the direction of probe.
dDiameter
Required Double variable that sets the diameter of the circle or cylinder scan, and zero otherwise.
dArcAngle
Required Double variable that sets arc angle for circle and cylinder scans.
dDepth
Required Double variable that sets the depth for circle and cylinder scans, and zero otherwise.
dPitch
Required Double variable that sets Pitch for Cylinder scans.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

Example

Method | SetMethodParams (bIn, bCenteringType, nCenteringDirection, dDiameter, dArcAngle, dDepth, dPitch)
Linear | None
Edge | None
Circle | bIn, , , dDiameter, dArcAngle, dDepth
Cylinder | bIn, , , dDiameter, dArcAngle, dDepth, dPitch
Straight Line | None
Center | , bCenteringType, nCenteringDirection

See Also

BasicScan Object


SetMethodPointData Method

SetMethodPointData Method
MethodStart
Required PointData object that sets the MethodStart property.
MethodEnd
Required PointData object that sets the MethodEnd property.
MethodInitTouch
Required PointData object that sets the MethodInitTouch property.
MethodEndTouch
Required PointData object that sets the MethodEndTouch property.
MethodInitDir
Required PointData object that sets the MethodInitDir property.
MethodInitTopSurf
MethodCutPlane
Required PointData object that sets the MethodCutPlane property.

Description

Sets scan points and vectors via pointdata objects This method is provided as a shortcut to set these commonly used scan parameters all at once.

Syntax

Visual Basic
Public Function SetMethodPointData( _
   ByVal MethodStart As PointData, _
   ByVal MethodEnd As PointData, _
   ByVal MethodInitTouch As PointData, _
   ByVal MethodEndTouch As PointData, _
   ByVal MethodInitDir As PointData, _
   ByVal MethodInitTopSurf As PointData, _
   ByVal MethodCutPlane As PointData _
) As Boolean

Parameters

MethodStart
Required PointData object that sets the MethodStart property.
MethodEnd
Required PointData object that sets the MethodEnd property.
MethodInitTouch
Required PointData object that sets the MethodInitTouch property.
MethodEndTouch
Required PointData object that sets the MethodEndTouch property.
MethodInitDir
Required PointData object that sets the MethodInitDir property.
MethodInitTopSurf
MethodCutPlane
Required PointData object that sets the MethodCutPlane property.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

If scan is a BasicScanCommand object, and MS, ME, MIT, MET, MID,and MCP are all Dimensioned as Object, the following are equivalent:

scan.SetMethodParams MS,ME,MIT,MET,MID,MCP

set scan.MethodStart = MS
set scan.MethodEnd = ME
set scan.MethodInitTouch = MIT
set scan.MethodEndTouch = MET
set scan.MethodInitDir = MID
set scan.MethodCutPlane = MCP

See Also

BasicScan Object


SetNomsParams Method

SetNomsParams Method
dFindNomsTolerance
Required Double that sets the Find Noms tolerance.
dSurfaceThickness
Required Double that sets the surface thickness.
dEdgeThickness
Required Double that sets the edge thickness.

Description

Sets the parameters used in finding of scan nominals This method is provided as a shortcut to set these commonly used scan parameters all at once.

Syntax

Visual Basic
Public Function SetNomsParams( _
   ByVal dFindNomsTolerance As Double, _
   ByVal dSurfaceThickness As Double, _
   ByVal dEdgeThickness As Double _
) As Boolean

Parameters

dFindNomsTolerance
Required Double that sets the Find Noms tolerance.
dSurfaceThickness
Required Double that sets the surface thickness.
dEdgeThickness
Required Double that sets the edge thickness.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

If scan is a BasicScanCommand object, and M, F, O, H, N,and B are all Dimensioned as Object, the following are equivalent:

scan.SetParams M, F, O, H, N, B

scan.Method = M
scan.Filter = F
scan.OperationMode = O
scan.HitType = H
scan.NominalMode = N
scan.BoundaryCondition = B

See Also

BasicScan Object


SetParams Method

SetParams Method
Method
Required Long that sets the Method property.
Filter
Required Long that sets the Filter property.
OperationMode
Required Long that sets the OperationMode property.
HitType
Required Long that sets the HitType property.
NominalMode
Required Long that sets the NominalMode property.
BoundaryCondition
Required Long that sets the BoundaryCondition property.

Description

Sets the basic scanning parameters of the scan This method is provided as a shortcut to set these commonly used scan parameters all at once.

Syntax

Visual Basic
Public Function SetParams( _
   ByVal Method As Long, _
   ByVal Filter As Long, _
   ByVal OperationMode As Long, _
   ByVal HitType As Long, _
   ByVal NominalMode As Long, _
   ByVal BoundaryCondition As Long _
) As Boolean

Parameters

Method
Required Long that sets the Method property.
Filter
Required Long that sets the Filter property.
OperationMode
Required Long that sets the OperationMode property.
HitType
Required Long that sets the HitType property.
NominalMode
Required Long that sets the NominalMode property.
BoundaryCondition
Required Long that sets the BoundaryCondition property.

Remarks

If scan is a BasicScanCommand object, and M, F, O, H, N,and B are all Dimensioned as Object, the following are equivalent:

scan.SetParams M, F, O, H, N, B

scan.Method = M
scan.Filter = F
scan.OperationMode = O
scan.HitType = H
scan.NominalMode = N
scan.BoundaryCondition = B

See Also

BasicScan Object


AutoClearPlane Property

AutoClearPlane Property

Description

Read/Write: Boolean value indicating if auto clear planes should be used

Determines whether auto clearance planes mode is on or off.

Property type

Read-write property

Syntax

Visual Basic
Public Property AutoClearPlane() As Boolean

Return Type

Read/Write Boolean.

See Also

BasicScan Object


BoundaryCondition Property

BoundaryCondition Property

Description

Read/Write: Boundary Condition (Sphere, Plane Cross, Cone, etc.

Represents the boundary condition type.

Property type

Read-write property

Syntax

Visual Basic
Public Property BoundaryCondition() As BSBOUNDCOND_ENUM

Return Type

Read/write of enumeration BSBOUNDCOND_ENUM.

Remarks

The allowable values are:

BSBOUNDCOND_SPHERE

BSBOUNDCOND_PLANECROSS

BSBOUNDCOND_CYLINDER

BSBOUNDCOND_CONE

The SetBoundaryConditionParams method should be used to set the values for:

  • HalfAngle
  • Number of Crossings
  • Diameter

See Also

BasicScan Object | SetBoundaryConditionParams Method | SetBoundaryConditionParams Method


BoundaryConditionAxisV Property

BoundaryConditionAxisV Property

Description

Read/Write: Returns/Sets via point data object the boundary scan's axis vector

Represents the boundary condition axis vector. This vector is used as the axis of the Cylindrical and Conical BoundaryConditions.

Property type

Read-write property

Syntax

Visual Basic
Public Property BoundaryConditionAxisV() As PointData

Return Type

Read/write PointData object.

See Also

BasicScan Object


BoundaryConditionCenter Property

BoundaryConditionCenter Property

Description

Read/Write: Returns/Sets via point data object a boundary scan's center point

Represents the boundary condition center. This Point is used by all Boundary Conditions and is the location of the Boundary Condition.

Property type

Read-write property

Syntax

Visual Basic
Public Property BoundaryConditionCenter() As PointData

Return Type

Read/write PointData object.

See Also

BasicScan Object


BoundaryConditionEndApproach Property

BoundaryConditionEndApproach Property

Description

Read/Write: Returns/Sets via point data object the end approach for a boundary scan

Represents the boundary condition end approach vector. This vector is used by all Boundary Conditions and is the Approach Vector of the Probe as it crosses the Boundary condition.

Property type

Read-write property

Syntax

Visual Basic
Public Property BoundaryConditionEndApproach() As PointData

Return Type

Read/write PointData object.

See Also

BasicScan Object


BoundaryConditionPlaneV Property

BoundaryConditionPlaneV Property

Description

Read/Write: Returns/Sets via point data object the boundary scan's plane vector

Represents the boundary condition plane vector. This vector is the normal vector of the Plane used by the Plane and OldStyle Boundary Conditions.

Property type

Read-write property

Syntax

Visual Basic
Public Property BoundaryConditionPlaneV() As PointData

Return Type

Read/write PointData object.

Remarks

Boundary Condition | Properties Required
Plane | BoundaryConditionCenter BoundaryConditionEndApproach BoundaryConditionPlaneV
Cone | BoundaryConditionCenter BoundaryConditionEndApproach BoundaryConditionAxisV
Cylinder | BoundaryConditionCenter BoundaryConditionEndApproach BoundaryConditionAxisV
Sphere | BoundaryConditionCenter BoundaryConditionEndApproach

See Also

BasicScan Object


BoundaryPointCount Property

BoundaryPointCount Property

Description

Read/Write: Long value indicating the number of boundary points for patch scans Indicates the number of boundary points to used in a patch scan.

Property type

Read-write property

Syntax

Visual Basic
Public Property BoundaryPointCount() As Long

Return Type

Read/write Long.

Remarks

Individual boundary points can be set or retrieved via the "BasicScan.GetBoundaryPoint" and "BasicScan.SetBoundaryPoint" methods.

See Also

BasicScan Object


DisplayHits Property

DisplayHits Property

Description

Read/Write: Boolean value indicating whether hits should be displayed or not

Determines whether hits of the scan are displayed in the Edit window or not.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisplayHits() As Boolean

Return Type

Read/write Boolean.

See Also

BasicScan Object


Filter Property

Filter Property

Description

Read/Write: Distance Filter Type Represents the filter type.

Property type

Read-write property

Syntax

Visual Basic
Public Property Filter() As BSF_ENUM

Return Type

Read/write enumeration of BSF_ENUM.

Remarks

The allowable values are:

BSF_DISTANCE

BSF_BODYAXISDISTANCE

BSF_VARIABLEDISTANCE

See Also

BasicScan Object


HitType Property

HitType Property

Description

Read/Write: Scan Hit Type (Vector, Surface, Edge) Represents the type of hit to use.

Property type

Read-write property

Syntax

Visual Basic
Public Property HitType() As BSCANHIT_ENUM

Return Type

Read/write of enumeration BSCANHIT_ENUM.

Remarks

The allowable values are:

BSCANHIT_VECTOR

BSCANHIT_SURFACE

BSCANHIT_EDGE

BSCANHIT_BASIC

Not every hit type can be used with every method and filter combination. Consider this table.

Method | Edge Hit | Vector Hit | Surface Hit | Basic Hit
Linear | - | Y | Y | -
Edge | Y | - | - | -
Circle | - | Y | - | -
Cylinder | - | Y | - | -
Straight Line | - | Y | - | -
Center | - | Y | - | -

See Also

BasicScan Object


Method Property

Method Property

Description

Read/Write: Scan Type Represents the method type for this scan.

Property type

Read-write property

Syntax

Visual Basic
Public Property Method() As BSCANMETH_ENUM

Return Type

Read/write of enumeration BSMETHOD_ENUM.

Remarks

The Method type defines the geometry of the feature to be scanned and has parameters that need to be set properly before scanning. The parameters can be set using the SetMethodParams method.

The allowable values are:

BSCANMETH_LINEAR

BSCANMETH_EDGE

BSCANMETH_CIRCLE

BSCANMETH_CYLINDER

BSCANMETH_STRAIGHTLINE

BSCANMETH_CENTER

See Also

BasicScan Object | SetMethodParams Method


MethodCutPlane Property

MethodCutPlane Property

Description

Read/Write: Returns/Sets via point data object the cut plane vector

Represents the method’s cut plane vector.

Property type

Read-write property

Syntax

Visual Basic
Public Property MethodCutPlane() As PointData

Return Type

Read/write PointData object.

See Also

BasicScan Object


MethodEnd Property

MethodEnd Property

Description

Read/Write: Returns/Sets via point data object the ending scan point

Represents the scan’s end point.

Property type

Read-write property

Syntax

Visual Basic
Public Property MethodEnd() As PointData

Return Type

Read/write PointData.

See Also

BasicScan Object


MethodEndTouch Property

MethodEndTouch Property

Description

Read/Write: Returns/Sets via point data object the end touch vector

Represents the method’s end touch vector.

Property type

Read-write property

Syntax

Visual Basic
Public Property MethodEndTouch() As PointData

Return Type

Read/write PointData object.

See Also

BasicScan Object


MethodInitDir Property

MethodInitDir Property

Description

Read/Write: Returns/Sets via point data object the initial scan direction vector

Represents the method’s initial direction vector.

Property type

Read-write property

Syntax

Visual Basic
Public Property MethodInitDir() As PointData

Return Type

Read/write PointData object.

See Also

BasicScan Object


MethodInitTopSurf Property

MethodInitTopSurf Property

Description

Read/Write: Returns/Sets via point data object the initial top surface vector

Represents the initial Surface Vector for the Edge method.

Property type

Read-write property

Syntax

Visual Basic
Public Property MethodInitTopSurf() As PointData

Return Type

Read/write PointData object.

See Also

BasicScan Object


MethodInitTouch Property

MethodInitTouch Property

Description

Read/Write: Returns/Sets via point data object the initial touch vector

Represents the method’s initial touch vector.

Property type

Read-write property

Syntax

Visual Basic
Public Property MethodInitTouch() As PointData

Return Type

Read/write PointData object.

See Also

BasicScan Object


MethodStart Property

MethodStart Property

Description

Read/Write: Returns/Sets via point data object the starting scan point Represents the scan’s start point.

Property type

Read-write property

Syntax

Visual Basic
Public Property MethodStart() As PointData

Return Type

Read/write PointData object.

Remarks

Not following table shows the supported scan methods:

 | Start | End | CutPlane | InitDir | InitTouch | InitTopSurf | EndTouch
Linear | Y | Y | Y | Y | Y | - | Y
Edge | Y | Y | - | Y | Y | Y | Y
Circle | Y | - | Y | - | Y | - | -
Cylinder | Y | - | Y | - | Y | - | -
Straight Line | Y | Y | Y | - | - | - | -
Center | Y | Y | Y | - | Y |  | -

See Also

BasicScan Object


NominalMode Property

NominalMode Property

Description

Read/Write: Find cad nominals or use master data Represents how to determine the nominal values for this scan.

Property type

Read-write property

Syntax

Visual Basic
Public Property NominalMode() As BSCANNMODE_ENUM

Return Type

Read/write of enumeration BSCANNMODE_ENUM.

Remarks

The allowable values are:

BSCANNMODE_FINDCADNOMINAL

BSCANNMODE_MASTERDATA

See Also

BasicScan Object


OperationMode Property

OperationMode Property

Description

Read/Write: Scan Operation Mode Represents mode of operation of the scan.

Property type

Read-write property

Syntax

Visual Basic
Public Property OperationMode() As BSCANOPMODE_ENUM

Return Type

Read/write of enumeration BSOPMODE_ENUM.

Remarks

The allowable values are:

BSCANOPMODE_REGULARLEARN

BSCANOPMODE_DEFINEPATHFROMHITS

BSCANOPMODE_HIGHSPEEDFEATUREBASED

BSCANOPMODE_NORMALEXECUTION

Method | Regular Learn | Defined Path | Feature Based | Normal
Edge | Y | - | - | Y
Linear | Y | - | - | Y
Edge | Y | - | - | Y
Circle | - | - | Y | Y
Cylinder | - | - | Y | Y
Straight Line | - | - | Y | Y
Center | Y | - | - | Y

See Also

BasicScan Object


SinglePoint Property

SinglePoint Property

Description

Read/Write: Returns/Sets Single Point Mode Flag

Determines whether single point mode is on or off.

Property type

Read-write property

Syntax

Visual Basic
Public Property SinglePoint() As Boolean

Return Type

Read/write Boolean.

Remarks

When set to True each point will be considered as a single measured point.

See Also

BasicScan Object


CadModel Object

CadModel Object
See Also Members

Description

The CadModel object allows you to work with the imported CAD model in PC-DMIS' Graphics Display window.

Object Model

See Also

CadModel Members


CadModel Object Members

CadModel ObjectMembers
See Also Overview

Public Methods

Public Method CadCollectionSlice |
Public Method CADSlice |
Public Method HighlightElement | This method highlights the specified CAD element (or elements) on the CAD model in the Graphics Display window.
Public Method ScaleToFit | Focus on the passed feature or dimension
Public Method UnHighlightElement | This method removes highlighting from the specified CAD element (or elements) on the CAD model in the Graphics Display window.

Public Properties

Public Property Parent Read Only: Returns PartProgram object Returns this objects parent object.

See Also

CadModel Overview


CadCollectionSlice Method

CadCollectionSlice Method
CADType
PlaneAnchorX
PlaneAnchorY
PlaneAnchorZ
PlaneVectorI
PlaneVectorJ
PlaneVectorK
Tolerance

Syntax

Visual Basic
Public Function CadCollectionSlice( _
   ByVal CADType As ENUM_CAD_COLLECTIONS, _
   ByVal PlaneAnchorX As Double, _
   ByVal PlaneAnchorY As Double, _
   ByVal PlaneAnchorZ As Double, _
   ByVal PlaneVectorI As Double, _
   ByVal PlaneVectorJ As Double, _
   ByVal PlaneVectorK As Double, _
   ByVal Tolerance As Double _
) As CadPolyLinesOnSurface

Parameters

CADType
Value | Description
HCAD_ALL_LISTS | All display collection except the probe collection
HCAD_CLEARFETS
HCAD_CAD | Display collection for the cad elements
HCAD_SURF | Display collection for the cad surface elements
HCAD_INSPECTP | Display collection for the inspect points (des) elements
HCAD_MEASURED | Display collection for the measured feature elements
HCAD_EDITPATH | Display collection for the edit path elements
HCAD_ARROWS | Display collection for the analysis arrows
HCAD_SCAN | Display collection for scans
HCAD_HITS | Display collection for Hits
HCAD_ARM2CMM | Display collection for arm 2 animated cmm
HCAD_ARM2CMM1 | Display collection 1 for arm 2 animated cmm
HCAD_ARM2CMM2 | Display collection 2 for arm 2 animated cmm
HCAD_ARM2CMM3 | Display collection 3 for arm 2 animated cmm
HCAD_ARM2CMM4 | Display collection 4 for arm 2 animated cmm
HCAD_ARM2CMM5 | Display collection 5 for arm 2 animated cmm
HCAD_ARM2CMM6 | Display collection 6 for arm 2 animated cmm
HCAD_ARM2PROBE | Display collection for arm 2 animated probe
HCAD_ARM2PROBE1 | Display collection 1 for arm 2 animated probe
HCAD_ARM2PROBE2 | Display collection 2 for arm 2 animated probe
HCAD_ARM2PROBE3 | Display collection 3 for arm 2 animated probe
HCAD_ARM1CMM | Display collection for arm 1 animated cmm
HCAD_ARM1CMM1 | Display collection 1 for arm 1 animated cmm
HCAD_ARM1CMM2 | Display collection 2 for arm 1 animated cmm
HCAD_ARM1CMM3 | Display collection 3 for arm 1 animated cmm
HCAD_ARM1CMM4 | Display collection 4 for arm 1 animated cmm
HCAD_ARM1CMM5 | Display collection 5 for arm 1 animated cmm
HCAD_ARM1CMM6 | Display collection 6 for arm 1 animated cmm
HCAD_ARM1PROBE | Display collection for arm 1 animated probe
HCAD_ARM1PROBE1 | Display collection 1 for arm 1 animated probe
HCAD_ARM1PROBE2 | Display collection 2 for arm 1 animated probe
HCAD_ARM1PROBE3 | Display collection 3 for arm 1 animated probe
HCAD_CMMFIXTURE | Display collection for CMM fixture
HCAD_CMMFIXTURE1 | Display collection 1 for CMM fixture
HCAD_CMMFIXTURE2 | Display collection 2 for CMM fixture
HCAD_CMMFIXTURE3 | Display collection 3 for CMM fixture
HCAD_CMMFIXTURE4 | Display collection 4 for CMM fixture
HCAD_CMMFIXTURE5 | Display collection 5 for CMM fixture
HCAD_CMMFIXTURE6 | Display collection 6 for CMM fixture
HCAD_CMMFIXTURE7 | Display collection 7 for CMM fixture
HCAD_CMMFIXTURE8 | Display collection 8 for CMM fixture
HCAD_CMMFIXTURE9 | Display collection 9 for CMM fixture
HCAD_CMMFIXTURE10 | Display collection 10 for CMM fixture
HCAD_CMMFIXTURE11 | Display collection 11 for CMM fixture
HCAD_CMMFIXTURE12 | Display collection 12 for CMM fixture
HCAD_CMMFIXTURE13 | Display collection 13 for CMM fixture
HCAD_CMMFIXTURE14 | Display collection 14 for CMM fixture
HCAD_CMMFIXTURE15 | Display collection 15 for CMM fixture
HCAD_CMMFIXTURE16 | Display collection 16 for CMM fixture
HCAD_CMMFIXTURE17 | Display collection 17 for CMM fixture
HCAD_CMMFIXTURE18 | Display collection 18 for CMM fixture
HCAD_CMMFIXTURE19 | Display collection 19 for CMM fixture
HCAD_CMMFIXTURE20 | Display collection 20 for CMM fixture
HCAD_CMMFIXTURE21 | Display collection 21 for CMM fixture
HCAD_CMMFIXTURE22 | Display collection 22 for CMM fixture
HCAD_CMMFIXTURE23 | Display collection 23 for CMM fixture
HCAD_CMMFIXTURE24 | Display collection 24 for CMM fixture
HCAD_CMMFIXTURE25 | Display collection 25 for CMM fixture
HCAD_MARKERS | Display collection for hits and arrows of features
HCAD_FOV | Display collection for FOV
HCAD_TARGET | Display collection for Targets
HCAD_PROBECHANGER1 | Display collection for probe changer 1
HCAD_PROBECHANGER2 | Display collection for probe changer 2
HCAD_PROBECHANGER3 | Display collection for probe changer 3
HCAD_PROBECHANGER4 | Display collection for probe changer 4
HCAD_ARM3CMM | Display collection for arm 3 animated cmm
HCAD_ARM3CMM1 | Display collection 1 for arm 3 animated cmm
HCAD_ARM3CMM2 | Display collection 2 for arm 3 animated cmm
HCAD_ARM3CMM3 | Display collection 3 for arm 3 animated cmm
HCAD_ARM3CMM4 | Display collection 4 for arm 3 animated cmm
HCAD_ARM3CMM5 | Display collection 5 for arm 3 animated cmm
HCAD_ARM3CMM6 | Display collection 6 for arm 3 animated cmm
HCAD_ARM4CMM | Display collection for arm 4 animated cmm
HCAD_ARM4CMM1 | Display collection 1 for arm 4 animated cmm
HCAD_ARM4CMM2 | Display collection 2 for arm 4 animated cmm
HCAD_ARM4CMM3 | Display collection 3 for arm 4 animated cmm
HCAD_ARM4CMM4 | Display collection 4 for arm 4 animated cmm
HCAD_ARM4CMM5 | Display collection 5 for arm 4 animated cmm
HCAD_ARM4CMM6 | Display collection 6 for arm 4 animated cmm
HCAD_ARM3PROBE | Display collection for arm 3 animated probe
HCAD_ARM3PROBE1 | Display collection 1 for arm 3 animated probe
HCAD_ARM3PROBE2 | Display collection 2 for arm 3 animated probe
HCAD_ARM3PROBE3 | Display collection 3 for arm 3 animated probe
HCAD_ARM4PROBE | Display collection for arm 4 animated probe
HCAD_ARM4PROBE1 | Display collection 1 for arm 4 animated probe
HCAD_ARM4PROBE2 | Display collection 2 for arm 4 animated probe
HCAD_ARM4PROBE3 | Display collection 3 for arm 4 animated probe
PlaneAnchorX
PlaneAnchorY
PlaneAnchorZ
PlaneVectorI
PlaneVectorJ
PlaneVectorK
Tolerance

See Also

CadModel Object


CADSlice Method

CADSlice Method
PlaneAnchorX
PlaneAnchorY
PlaneAnchorZ
PlaneVectorI
PlaneVectorJ
PlaneVectorK
Tolerance

Syntax

Visual Basic
Public Function CADSlice( _
   ByVal PlaneAnchorX As Double, _
   ByVal PlaneAnchorY As Double, _
   ByVal PlaneAnchorZ As Double, _
   ByVal PlaneVectorI As Double, _
   ByVal PlaneVectorJ As Double, _
   ByVal PlaneVectorK As Double, _
   ByVal Tolerance As Double _
) As CadPolyLinesOnSurface

Parameters

PlaneAnchorX
PlaneAnchorY
PlaneAnchorZ
PlaneVectorI
PlaneVectorJ
PlaneVectorK
Tolerance

See Also

CadModel Object


HighlightElement Method

HighlightElement Method
Name
Required case-sensitive String that indicates the CAD element to highlight.
All
Boolean value that indicates whether or not all CAD elements of that have Name should be highlighted. If set to TRUE then all elements with Name are selected. If set to FALSE, then only the first item in the list that has Name is selected.

Description

This method highlights the specified CAD element (or elements) on the CAD model in the Graphics Display window.

Syntax

Visual Basic
Public Function HighlightElement( _
   ByVal Name As String, _
   ByVal All As Boolean _
) As Boolean

Parameters

Name
Required case-sensitive String that indicates the CAD element to highlight.
All
Boolean value that indicates whether or not all CAD elements of that have Name should be highlighted. If set to TRUE then all elements with Name are selected. If set to FALSE, then only the first item in the list that has Name is selected.

Return Type

Boolean value. Boolean returns true if the function succeeds in highlighting the specified CAD element, false if it fails.

Remarks

Example

' Sample Code:

Dim App As PCDLRN.Application

Set App = CreateObject("PCDLRN.Application")

Dim Parts As PCDLRN.PartPrograms

Set Parts = App.PartPrograms

Dim Part As PCDLRN.PartProgram

Set Part = App.ActivePartProgram

Dim CADMod As PCDLRN.CadModel

Set CADMod = Part.CadModel

Dim strElement As String

Dim boolYesNo As Boolean

strElement = InputBox("Type the CAD element to highlight", "Highlight CAD")

boolYesNo = MsgBox("Select all?", vbYesNo, "Select All")

If CADMod.HighlightElement(strElement, boolYesNo) = False Then

MsgBox "Element: " & strElement & " couldn't be highlighted", vbCritical, "No CAD Highlighted"

Else

MsgBox "Success. Element: " & strElement & " was highlighted", vbOKOnly, "CAD Highlighted"

End If

See Also

CadModel Object


ScaleToFit Method

ScaleToFit Method
Command

Description

Focus on the passed feature or dimension

Syntax

Visual Basic
Public Function ScaleToFit( _
   ByVal Command As Command _
) As Boolean

Parameters

Command

See Also

CadModel Object


UnHighlightElement Method

UnHighlightElement Method
Name
Required case-sensitive String that indicates the CAD element from which to remove highlighting.
All
Boolean value that indicates whether or not all CAD elements of that have Name should be deselected. If set to TRUE then all elements with Name are deselected. If set to FALSE, then only the first item in the list that has Name is deselected.

Description

This method removes highlighting from the specified CAD element (or elements) on the CAD model in the Graphics Display window.

Syntax

Visual Basic
Public Function UnHighlightElement( _
   ByVal Name As String, _
   ByVal All As Boolean _
) As Boolean

Parameters

Name
Required case-sensitive String that indicates the CAD element from which to remove highlighting.
All
Boolean value that indicates whether or not all CAD elements of that have Name should be deselected. If set to TRUE then all elements with Name are deselected. If set to FALSE, then only the first item in the list that has Name is deselected.

Return Type

Boolean value. Boolean returns true if the function succeeds in removing the highlight from the specified CAD element, false if it fails.

Remarks

See Also

CadModel Object


Parent Property

Parent Property

Description

Read Only: Returns PartProgram object Returns this objects parent object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As PartProgram

Return Type

Returns the PartProgram object.

See Also

CadModel Object


CadPointOnSurface Object

CadPointOnSurface Object
See Also Members

Description

CadPointOnSurface Object

Object Model

See Also

CadPointOnSurface Members


CadPointOnSurface Object Members

CadPointOnSurface ObjectMembers
See Also Overview

Public Properties

Public Property Application | Read Only: Returns the Application Object
Public Property CadSurface | Read/Write: Returns/Sets the CadSurface ID )
Public Property I | Read/Write: Returns/Sets the I value
Public Property J | Read/Write: Returns/Sets the J value
Public Property K | Read/Write: Returns/Sets the K value
Public Property Parent | Read Only: Returns CadPointsOnSurface collection object
Public Property X | Read/Write: Returns/Sets the X value
Public Property Y | Read/Write: Returns/Sets the Y value
Public Property Z | Read/Write: Returns/Sets the Z value

See Also

CadPointOnSurface Overview


Application Property

Application Property

Description

Read Only: Returns the Application Object

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

See Also

CadPointOnSurface Object


CadSurface Property

CadSurface Property

Description

Read/Write: Returns/Sets the CadSurface ID )

Property type

Read-write property

Syntax

Visual Basic
Public Property CadSurface() As Long

See Also

CadPointOnSurface Object


I Property

I Property

Description

Read/Write: Returns/Sets the I value

Property type

Read-write property

Syntax

Visual Basic
Public Property I() As Double

See Also

CadPointOnSurface Object


J Property

J Property

Description

Read/Write: Returns/Sets the J value

Property type

Read-write property

Syntax

Visual Basic
Public Property J() As Double

See Also

CadPointOnSurface Object


K Property

K Property

Description

Read/Write: Returns/Sets the K value

Property type

Read-write property

Syntax

Visual Basic
Public Property K() As Double

See Also

CadPointOnSurface Object


Parent Property

Parent Property

Description

Read Only: Returns CadPointsOnSurface collection object

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As CadPointsOnSurface

See Also

CadPointOnSurface Object


X Property

X Property

Description

Read/Write: Returns/Sets the X value

Property type

Read-write property

Syntax

Visual Basic
Public Property X() As Double

See Also

CadPointOnSurface Object


Y Property

Y Property

Description

Read/Write: Returns/Sets the Y value

Property type

Read-write property

Syntax

Visual Basic
Public Property Y() As Double

See Also

CadPointOnSurface Object


Z Property

Z Property

Description

Read/Write: Returns/Sets the Z value

Property type

Read-write property

Syntax

Visual Basic
Public Property Z() As Double

See Also

CadPointOnSurface Object


CadPointsOnSurface Object

CadPointsOnSurface Object
See Also Members

Description

Object for the collection of polylines on surface

Object Model

See Also

CadPointsOnSurface Members


CadPointsOnSurface Object Members

CadPointsOnSurface ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method Item | Returns the nth CadPointOnSurface in the collection

Public Properties

Public Property Application | Read Only: Returns the Application Object
Public Property Count | Read Only: Returns the number CadPointOnSurface in the CAdPointsOnSurface collection
Public Property Parent | Read Only: Returns CadPolyLineOnSurface Object

See Also

CadPointsOnSurface Overview


_Item Method

_Item Method
Num

Syntax

Visual Basic
Public Function _Item( _
   ByVal Num As Long _
) As CadPointOnSurface

Parameters

Num

See Also

CadPointsOnSurface Object


Item Method

Item Method
Num

Description

Returns the nth CadPointOnSurface in the collection

Syntax

Visual Basic
Public Function Item( _
   ByVal Num As Long _
) As CadPointOnSurface

Parameters

Num

See Also

CadPointsOnSurface Object


Application Property

Application Property

Description

Read Only: Returns the Application Object

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

See Also

CadPointsOnSurface Object


Count Property

Count Property

Description

Read Only: Returns the number CadPointOnSurface in the CAdPointsOnSurface collection

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

See Also

CadPointsOnSurface Object


Parent Property

Parent Property

Description

Read Only: Returns CadPolyLineOnSurface Object

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As CadPolyLineOnSurface

See Also

CadPointsOnSurface Object


CadPolyLineOnSurface Object

CadPolyLineOnSurface Object
See Also Members

Description

CadPolyLineOnSurface Object

Object Model

See Also

CadPolyLineOnSurface Members


CadPolyLineOnSurface Object Members

CadPolyLineOnSurface ObjectMembers
See Also Overview

Public Properties

Public Property Application | Read Only: Returns the Application Object
Public Property CadPoints | Read Only: Returns the CadPointsOnSurface collection object
Public Property Closed | Read/Write: Returns/sets true if is a closed polyline
Public Property Parent | Read Only: Returns CadPolyLinesOnSurface collection object

See Also

CadPolyLineOnSurface Overview


Application Property

Application Property

Description

Read Only: Returns the Application Object

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

See Also

CadPolyLineOnSurface Object


CadPoints Property

CadPoints Property

Description

Read Only: Returns the CadPointsOnSurface collection object

Property type

Read-write property

Syntax

Visual Basic
Public Property CadPoints() As CadPointsOnSurface

See Also

CadPolyLineOnSurface Object


Closed Property

Closed Property

Description

Read/Write: Returns/sets true if is a closed polyline

Property type

Read-write property

Syntax

Visual Basic
Public Property Closed() As Boolean

See Also

CadPolyLineOnSurface Object


Parent Property

Parent Property

Description

Read Only: Returns CadPolyLinesOnSurface collection object

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As CadPolyLinesOnSurface

See Also

CadPolyLineOnSurface Object


CadPolyLinesOnSurface Object

CadPolyLinesOnSurface Object
See Also Members

Description

Object for the collection of polylines on surface

Object Model

See Also

CadPolyLinesOnSurface Members


CadPolyLinesOnSurface Object Members

CadPolyLinesOnSurface ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method Item | Returns the nth PolyLineOnSurface in the collection

Public Properties

Public Property Application | Read Only: Returns the Application Object
Public Property Count | Read Only: Returns the number PolyLineOnSurface in the PolyLinesOnSurface collection
Public Property Parent | Read Only: Returns CadModel object

See Also

CadPolyLinesOnSurface Overview


_Item Method

_Item Method
Num

Syntax

Visual Basic
Public Function _Item( _
   ByVal Num As Long _
) As CadPolyLineOnSurface

Parameters

Num

See Also

CadPolyLinesOnSurface Object


Item Method

Item Method
Num

Description

Returns the nth PolyLineOnSurface in the collection

Syntax

Visual Basic
Public Function Item( _
   ByVal Num As Long _
) As CadPolyLineOnSurface

Parameters

Num

See Also

CadPolyLinesOnSurface Object


Application Property

Application Property

Description

Read Only: Returns the Application Object

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

See Also

CadPolyLinesOnSurface Object


Count Property

Count Property

Description

Read Only: Returns the number PolyLineOnSurface in the PolyLinesOnSurface collection

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

See Also

CadPolyLinesOnSurface Object


Parent Property

Parent Property

Description

Read Only: Returns CadModel object

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As CadModel

See Also

CadPolyLinesOnSurface Object


CadWindow Object

CadWindow Object
See Also Members

Description

Cad Window Object The CadWindow object is the one and only cad window for a part program.

Object Model

See Also

CadWindow Members


CadWindow Object Members

CadWindow ObjectMembers
See Also Overview

Public Methods

Public Method Print Prints the current view(s) of the cad window Prints the CAD window.

Public Properties

Public Property _Visible |
Public Property Application | Read Only: Returns the Application Object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.
Public Property Height | Read/Write: Returns/Sets the height of the cad window The height of the Cad window in screen pixels.
Public Property Left | Read/Write: Returns/Sets the left coordinate of the cad window The left edge of the Cad window, measured from the left edge of the Windows Desktop.
Public Property Parent | Read Only: Returns the Parent CadWindows Object Returns the parent CadWindows object.
Public Property Top | Read/Write: Returns/Sets the top coordinate of the cad window The top edge of the Cad window, measured from the top edge of the Windows Desktop.
Public Property Visible | Read/Write: Returns/Sets the visibility status of the cad window This property is TRUE if the Cad window is visible, FALSE otherwise. If you make the Cad window invisible, the only way to make it visible again is to set this property to TRUE.
Public Property Width | Read/Write: Returns/Sets the width of the cad window The width of the Cad window in screen pixels.

See Also

CadWindow Overview


Print Method

Print Method
Option
Required Long or enumerated value that indicates the type of printing to occur. Options include Scale to Fit on Single Page, Print Visible Screen Area, Print Complete Views, and Print Complete View w/ Current Scale. Print Visible Screen Area is only available one of the views are zoomed. Print Complete Views is only available when multiple views exist.
DrawRulers
Required Boolean that indicates whether rulers should be included on the printout. This option is only available if rulers are currently turned on in the cad drawing.

Description

Prints the current view(s) of the cad window Prints the CAD window.

Syntax

Visual Basic
Public Function Print( _
   ByVal Option As ENUM_CADPRINTOPTIONS, _
   ByVal DrawRulers As Boolean _
) As Boolean

Parameters

Option
Value | Description
CADPRINT_ONEPAGESCALE | Prints view scaled to fit on a single page.
CADPRINT_VISIBLEAREA | Prints the visible screen area.
CADPRINT_ENTIREVIEW | Prints entire CAD view.
CADPRINT_ENTIRCURSCALE | Prints the entire CAD view at the current scale.
Required Long or enumerated value that indicates the type of printing to occur. Options include Scale to Fit on Single Page, Print Visible Screen Area, Print Complete Views, and Print Complete View w/ Current Scale. Print Visible Screen Area is only available one of the views are zoomed. Print Complete Views is only available when multiple views exist.
DrawRulers
Required Boolean that indicates whether rulers should be included on the printout. This option is only available if rulers are currently turned on in the cad drawing.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

CadWindow Object


_Visible Property

_Visible Property

Property type

Read-write property

Syntax

Visual Basic
Public Property _Visible() As Boolean

See Also

CadWindow Object


Application Property

Application Property

Description

Read Only: Returns the Application Object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Returns the Application object.

See Also

CadWindow Object


Height Property

Height Property

Description

Read/Write: Returns/Sets the height of the cad window

The height of the Cad window in screen pixels.

Property type

Read-write property

Syntax

Visual Basic
Public Property Height() As Long

Return Type

Read/write Long.

See Also

CadWindow Object


Left Property

Left Property

Description

Read/Write: Returns/Sets the left coordinate of the cad window

The left edge of the Cad window, measured from the left edge of the Windows Desktop.

Property type

Read-write property

Syntax

Visual Basic
Public Property Left() As Long

Return Type

Read/write Long.

Remarks

The Left property is measured in screen pixels.

See Also

CadWindow Object


Parent Property

Parent Property

Description

Read Only: Returns the Parent CadWindows Object Returns the parent CadWindows object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As CadWindows

Return Type

CadWindows object.

See Also

CadWindow Object


Top Property

Top Property

Description

Read/Write: Returns/Sets the top coordinate of the cad window The top edge of the Cad window, measured from the top edge of the Windows Desktop.

Property type

Read-write property

Syntax

Visual Basic
Public Property Top() As Long

Return Type

Read/write Long.

Remarks

The Top property is measured in screen pixels.

See Also

CadWindow Object


Visible Property

Visible Property

Description

Read/Write: Returns/Sets the visibility status of the cad window

This property is TRUE if the Cad window is visible, FALSE otherwise. If you make the Cad window invisible, the only way to make it visible again is to set this property to TRUE.

Property type

Read-write property

Syntax

Visual Basic
Public Property Visible() As Boolean

Return Type

Read/write Boolean.

See Also

CadWindow Object


Width Property

Width Property

Description

Read/Write: Returns/Sets the width of the cad window

The width of the Cad window in screen pixels.

Property type

Read-write property

Syntax

Visual Basic
Public Property Width() As Long

Return Type

Read/write Long.

See Also

CadWindow Object


CadWindows Object

CadWindows Object
See Also Members

Description

Cad Windows Collection Object

The CadWindows object is an object containing a collection of CadWindow objects currently available to a part program.

Object Model

Remarks

Currently, there is exactly one CadWindow object associated with each part program, but the CADWindows object class is made available for future changes.

See Also

CadWindows Members


CadWindows Object Members

CadWindows ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method Item | Returns the Cad Window Object

Public Properties

Public Property Application | Read Only: Returns the Application Object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.
Public Property Count | Read Only: Returns the number of cad windows in the collection Returns the number of CadWindow objects active in this part program.
Public Property Parent | Read Only: Returns the Parent PartProgram Object Represents the parent PartProgram object.

See Also

CadWindows Overview


_Item Method

_Item Method
ID

Syntax

Visual Basic
Public Function _Item( _
   ByVal ID As String _
) As CadWindow

Parameters

ID

See Also

CadWindows Object


Item Method

Item Method
ID
Required Variant that denotes which CadWindow object to return.

Description

Returns the Cad Window Object

Syntax

Visual Basic
Public Function Item( _
   ByVal ID As String _
) As CadWindow

Parameters

ID
Required Variant that denotes which CadWindow object to return.

Return Type

CadWindow object from the parent CadWindows object. Read-only.

Remarks

Since there is only and exactly one CadWindow object, it does not matter what you pass into the ID argument. For the sake of future compatibility, you should pass 1 into the ID.

See Also

CadWindows Object


Application Property

Application Property

Description

Read Only: Returns the Application Object

Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

CadWindows Object


Count Property

Count Property

Description

Read Only: Returns the number of cad windows in the collection Returns the number of CadWindow objects active in this part program.

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

Return Type

Read-only Long.

Remarks

Currently, this property always returns 1.

See Also

CadWindows Object


Parent Property

Parent Property

Description

Read Only: Returns the Parent PartProgram Object Represents the parent PartProgram object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As PartProgram

Return Type

PartProgram object.

See Also

CadWindows Object


Calibration Object

Calibration Object
See Also Members

Description

The Calibration object allows for tip calibration during part program execution. This object is placed into a part program through the Add method of the Commands object and obtained from the Command object via the CalibrationCommand property.

See Also

Calibration Members


Calibration Object Members

Calibration ObjectMembers
See Also Overview

Public Properties

Public Property Moved | Read/Write: Indicates whether tool has been moved since it was calibrated Determines whether or not the sphere used as the calibration tool has moved since the last tip calibration.
Public Property SphereID | Read/Write: ID of sphere used for calibration This returns or sets the ID of a sphere command that occurs prior to the calibration command. The sphere should have identical characteristics with the tool identified by ToolID.
Public Property ToolID | Read/Write: ID of Tool of same dimensions as reference sphere Returns or sets the ID of a previously defined calibration tool that is similar to the sphere identified by SphereID. The tool data is used in the tip calibration or reset depending on the value of the moved data member.

See Also

Calibration Overview


Moved Property

Moved Property

Description

Read/Write: Indicates whether tool has been moved since it was calibrated

Determines whether or not the sphere used as the calibration tool has moved since the last tip calibration.

Property type

Read-write property

Syntax

Visual Basic
Public Property Moved() As Boolean

Return Type

Read/write Boolean.

If this value is true, then the tool’s (identified by ToolID) calibration data is reset using the data from the sphere (identified by SphereID) that was just measured.

If this value is false, then the current tool calibration data is used to calibrate the active tip.

See Also

Calibration Object


SphereID Property

SphereID Property

Description

Read/Write: ID of sphere used for calibration

This returns or sets the ID of a sphere command that occurs prior to the calibration command. The sphere should have identical characteristics with the tool identified by ToolID.

Property type

Read-write property

Syntax

Visual Basic
Public Property SphereID() As String

Return Type

Read/write String.

See Also

Calibration Object


ToolID Property

ToolID Property

Description

Read/Write: ID of Tool of same dimensions as reference sphere Returns or sets the ID of a previously defined calibration tool that is similar to the sphere identified by SphereID. The tool data is used in the tip calibration or reset depending on the value of the moved data member.

Property type

Read-write property

Syntax

Visual Basic
Public Property ToolID() As String

Return Type

Read/write String.

See Also

Calibration Object


Color Object

Color Object
See Also Members

Description

Reporting Color Object The Color object is used to automate color settings used in PC-DMIS's report templates.

Object Model

See Also

Color Members


Color Object Members

Color ObjectMembers
See Also Overview

Public Methods

Public Method DiscardChanges | Discard Color object modification and restore previous ones All changes made to the Color object are done inside a temporary structure. To restore the saved values and overwrite any changes you made in the temporary structure, use this method.
Public Method GetType | Retrieves the low and high word parameters representing the Color object type Returns the Command Type or Color Section to which the color is associated.
Public Method Remove | Removes the Color object from the parent Colors collection object Removes the current Color object from the Colors collection.
Public Method SaveChanges | Saves Color object modification All changes made to the Color object are done inside a temporary structure. This copies the changes made inside this temporary structure to the master structure, essentially saving your changes, making them permanent.

Public Properties

Public Property _Standard |
Public Property Application | Read Only: Returns object pointer of type Application Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects.
Public Property ColorParentType | Read Only: Returns the parent color Command type or Color Section ID Returns the parent Command Type or Color Section ID.
Public Property Debug | Read/Write: Returns/Sets the working Debug color Returns the Debug color.
Public Property Marked | Read/Write: Returns/Sets the working Marked color Returns the Marked color.
Public Property MarkedBackground | Read/Write: Returns/Sets the working MarkedBackground color Returns the Marked background color
Public Property OutTol | Read/Write: Returns/Sets the working OutTol color Returns the out-of-tolerance color.
Public Property Parent | Read Only: Returns object pointer to the Colors object Returns the parent Colors collection.
Public Property Standard | Read/Write: Returns/Sets the working Standard color Returns the working Standard color.
Public Property StandardBackground | Read/Write: Returns/Sets the working StandardBackground color Returns the working Standard background color.

See Also

Color Overview


DiscardChanges Method

DiscardChanges Method

Description

Discard Color object modification and restore previous ones All changes made to the Color object are done inside a temporary structure. To restore the saved values and overwrite any changes you made in the temporary structure, use this method.

Syntax

Visual Basic
Public Sub DiscardChanges()

See Also

Color Object


GetType Method

GetType Method
UID1

Long value specifying the Command Type ID or Color Section ID.

  • If defining a specific Command Type, this is the ID from the OBTYPE enumeration.
  • If defining a Color Section (from the Command Text Colors list on the Color Editor dialog box), this is the ID from the ENUM_COLOR_SECTION enumeration.
UID2

Long value specifying the second part of a 128 bit UID. UID2 is reserved for Command IDs that exists in the Toolkit environment. Since Toolkit command IDs use 128 bit values the only way to get at their data using automation is to supply two parameters. For typical automation uses (non Toolkit), you won't need this parameter and can simply supply a 0 value.

Description

Retrieves the low and high word parameters representing the Color object type Returns the Command Type or Color Section to which the color is associated.

Syntax

Visual Basic
Public Sub GetType( _
   ByRef UID1 As {Unrecognised type 21}, _
   ByRef UID2 As {Unrecognised type 21} _
)

Parameters

UID1

Long value specifying the Command Type ID or Color Section ID.

  • If defining a specific Command Type, this is the ID from the OBTYPE enumeration.
  • If defining a Color Section (from the Command Text Colors list on the Color Editor dialog box), this is the ID from the ENUM_COLOR_SECTION enumeration.
UID2

Long value specifying the second part of a 128 bit UID. UID2 is reserved for Command IDs that exists in the Toolkit environment. Since Toolkit command IDs use 128 bit values the only way to get at their data using automation is to supply two parameters. For typical automation uses (non Toolkit), you won't need this parameter and can simply supply a 0 value.

See Also

Color Object


Remove Method

Remove Method

Description

Removes the Color object from the parent Colors collection object Removes the current Color object from the Colors collection.

Syntax

Visual Basic
Public Sub Remove()

See Also

Color Object


SaveChanges Method

SaveChanges Method

Description

Saves Color object modification

All changes made to the Color object are done inside a temporary structure. This copies the changes made inside this temporary structure to the master structure, essentially saving your changes, making them permanent.

Syntax

Visual Basic
Public Sub SaveChanges()

See Also

Color Object


_Standard Property

_Standard Property

Property type

Read-write property

Syntax

Visual Basic
Public Property _Standard() As Long

See Also

Color Object


Application Property

Application Property

Description

Read Only: Returns object pointer of type Application Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

Color Object


ColorParentType Property

ColorParentType Property

Description

Read Only: Returns the parent color Command type or Color Section ID Returns the parent Command Type or Color Section ID.

Property type

Read-write property

Syntax

Visual Basic
Public Property ColorParentType() As Long

See Also

Color Object


Debug Property

Debug Property

Description

Read/Write: Returns/Sets the working Debug color Returns the Debug color.

Property type

Read-write property

Syntax

Visual Basic
Public Property Debug() As Long

Return Type

Long value representing the Debug color.

Remarks

Note on Colors: Colors are defined by a COLORREF value. When specifying a RGB color, the COLORREF value has this hexadecimal form as a Long value:

0x00BBGGRR

where BB=blue GG=green RR=red

The maximum value for a single byte in the hexadecimal format is 0xFF (or 255 in decimal format).

See Also

Color Object


Marked Property

Marked Property

Description

Read/Write: Returns/Sets the working Marked color Returns the Marked color.

Property type

Read-write property

Syntax

Visual Basic
Public Property Marked() As Long

Return Type

Long value representing the Marked color.

Remarks

Note on Colors: Colors are defined by a COLORREF value. When specifying a RGB color, the COLORREF value has this hexadecimal form as a Long value:

0x00BBGGRR

where BB=blue GG=green RR=red

The maximum value for a single byte in the hexadecimal format is 0xFF (or 255 in decimal format).

See Also

Color Object


MarkedBackground Property

MarkedBackground Property

Description

Read/Write: Returns/Sets the working MarkedBackground color Returns the Marked background color

Property type

Read-write property

Syntax

Visual Basic
Public Property MarkedBackground() As Long

Return Type

Long value representing the Marked background color.

Remarks

Note on Colors: Colors are defined by a COLORREF value. When specifying a RGB color, the COLORREF value has this hexadecimal form as a Long value:

0x00BBGGRR

where BB=blue GG=green RR=red

The maximum value for a single byte in the hexadecimal format is 0xFF (or 255 in decimal format).

See Also

Color Object


OutTol Property

OutTol Property

Description

Read/Write: Returns/Sets the working OutTol color Returns the out-of-tolerance color.

Property type

Read-write property

Syntax

Visual Basic
Public Property OutTol() As Long

Return Type

Long value representing the out-of-tolerance color.

Remarks

Note on Colors: Colors are defined by a COLORREF value. When specifying a RGB color, the COLORREF value has this hexadecimal form as a Long value:

0x00BBGGRR

where BB=blue GG=green RR=red

The maximum value for a single byte in the hexadecimal format is 0xFF (or 255 in decimal format).

See Also

Color Object


Parent Property

Parent Property

Description

Read Only: Returns object pointer to the Colors object Returns the parent Colors collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Colors

Return Type

Colors object.

See Also

Color Object


Standard Property

Standard Property

Description

Read/Write: Returns/Sets the working Standard color Returns the working Standard color.

Property type

Read-write property

Syntax

Visual Basic
Public Property Standard() As Long

Return Type

Long value representing the working Standard color.

Remarks

Note on Colors: Colors are defined by a COLORREF value. When specifying a RGB color, the COLORREF value has this hexadecimal form as a Long value:

0x00BBGGRR

where BB=blue GG=green RR=red

The maximum value for a single byte in the hexadecimal format is 0xFF (or 255 in decimal format).

See Also

Color Object


StandardBackground Property

StandardBackground Property

Description

Read/Write: Returns/Sets the working StandardBackground color Returns the working Standard background color.

Property type

Read-write property

Syntax

Visual Basic
Public Property StandardBackground() As Long

Return Type

Long value representing the working Standard background color.

Remarks

Note on Colors: Colors are defined by a COLORREF value. When specifying a RGB color, the COLORREF value has this hexadecimal form as a Long value:

0x00BBGGRR

where BB=blue GG=green RR=red

The maximum value for a single byte in the hexadecimal format is 0xFF (or 255 in decimal format).

See Also

Color Object


Colors Collection

Colors Collection
See Also Members

Description

Reporting Colors collection

The Colors object allows you to work with collections of Color objects. These are used to automate color settings used in PC-DMIS's report templates.

Object Model

Remarks

Use Colors.Add to create a new Color object and add it to the Colors collection.

Use Colors(item) where item is the command type or color section used to access an individual Color object.

See Also

Colors Members


Colors Collection Members

Colors CollectionMembers
See Also Overview

Public Methods

Public Method Add | Adds the color object associated with CommandTypeOrColorSection parameter. If already exists the previous one is returned. This method creates a new color node associated with the specified Command Type ID or Color Section ID, returning a Color object for the added node. Once you add a node, you can then define the colors used for the Standard, Marked, Debug, and OutTol.
Public Method BuildColortable | Rebuild Color Table using the current colors. retuns the
Public Method DiscardChanges | Discard Color objects modification and restore previous ones All changes made to the Colors collection are done inside a temporary structure. To restore the saved values and overwrite any changes you made in the temporary structure, use this method.
Public Method GetColorTableColor | Returns a ColorTable color Returns the color specified by the colorIndex parameter from the template's color table.
Public Method IsAllowed | Checks if CommandTypeOrColorSection parameter is allowed in current PCDMIS configuration This checks whether or not the specified Command Type or Color Section ID is valid in the current PC-DMIS configuration. If it is valid, it returns TRUE.
Public Method Item | Returns color object associated with CommandTypeOrColorSection parameter This method returns a specified color object from the color table based on the UID1 and UID2 parameters entered.
Public Method SaveChanges | Saves Color objects modification All changes made to the Colors collection are done inside a temporary structure. This copies the changes made inside this temporary structure to the master colors structure, essentially saving your changes, making them permanent.
Public Method UsedColor | Returns the effective command type or color section used This returns the color currently associated with the defined Command Type ID or Color Section ID. If a color is not defined for a feature type, the parent color is recursively searched until the default color is reached.

Public Properties

Public Property Application | Read Only: Returns object pointer of type Application This property represents the read-only PC-DMIS Application object. The Application object includes properties and methods that return top-level objects.
Public Property Background | Read/Write: Returns/Sets the Background color This property returns or sets the Background color for the report template's color tree.
Public Property Count | Read Only: Returns the number of color object defined in the collection This property returns the number of color nodes (Color objects) defined in the Colors collection (or color tree).
Public Property DimensionBackground | Read/Write: Returns/Sets the Dimension background color This property returns or sets the dimension background color for the template's color tree.
Public Property HighLightBackground | Read/Write: Returns/Sets the Highlight background color This property returns or sets the highlight background color for the template's color tree.
Public Property Modified | Read/Write: Returns/Sets modified flag This property returns or sets the report template's "modified" tag for its color tree.
Public Property NumTableColors | Read Only: Returns the Number of color defined in the color table This property returns the number of colors defined in the report template's color table.
Public Property Parent | Read Only: Returns object pointer to the Parent object This returns this object's parent object. In this case, this is the ReportTemplate object.

See Also

Colors Overview


Add Method

Add Method
UID1

Long value specifying the Command Type ID or Color Section ID.

  • If defining a specific Command Type, this is the ID from the OBTYPE enumeration.
  • If defining a Color Section (from the Command Text Colors list on the Color Editor dialog box), this is the ID from the ENUM_COLOR_SECTION enumeration.
UID2

Long value specifying the second part of a 128 bit UID. UID2 is reserved for Command IDs that exists in the Toolkit environment. Since Toolkit command IDs use 128 bit values the only way to get at their data using automation is to supply two parameters. For typical automation uses (non Toolkit), you won't need this parameter and can simply supply a 0 value.

Description

Adds the color object associated with CommandTypeOrColorSection parameter. If already exists the previous one is returned.

This method creates a new color node associated with the specified Command Type ID or Color Section ID, returning a Color object for the added node. Once you add a node, you can then define the colors used for the Standard, Marked, Debug, and OutTol.

Syntax

Visual Basic
Public Function Add( _
   ByVal UID1 As {Unrecognised type 21}, _
   ByVal UID2 As {Unrecognised type 21} _
) As Color

Parameters

UID1

Long value specifying the Command Type ID or Color Section ID.

  • If defining a specific Command Type, this is the ID from the OBTYPE enumeration.
  • If defining a Color Section (from the Command Text Colors list on the Color Editor dialog box), this is the ID from the ENUM_COLOR_SECTION enumeration.
UID2

Long value specifying the second part of a 128 bit UID. UID2 is reserved for Command IDs that exists in the Toolkit environment. Since Toolkit command IDs use 128 bit values the only way to get at their data using automation is to supply two parameters. For typical automation uses (non Toolkit), you won't need this parameter and can simply supply a 0 value.

Return Type

Color object.

See Also

Colors Collection


BuildColortable Method

BuildColortable Method

Description

Rebuild Color Table using the current colors. retuns the

Syntax

Visual Basic
Public Sub BuildColortable()

See Also

Colors Collection


DiscardChanges Method

DiscardChanges Method

Description

Discard Color objects modification and restore previous ones All changes made to the Colors collection are done inside a temporary structure. To restore the saved values and overwrite any changes you made in the temporary structure, use this method.

Syntax

Visual Basic
Public Sub DiscardChanges()

See Also

Colors Collection


GetColorTableColor Method

GetColorTableColor Method
colorIndex
Long value representing an index number for a color contained in the color table.

Description

Returns a ColorTable color Returns the color specified by the colorIndex parameter from the template's color table.

Syntax

Visual Basic
Public Function GetColorTableColor( _
   ByVal colorIndex As Long _
) As Long

Parameters

colorIndex
Long value representing an index number for a color contained in the color table.

Return Type

Long value representing the color returned.

See Also

Colors Collection


IsAllowed Method

IsAllowed Method
UID1

Long value specifying the Command Type ID or Color Section ID.

  • If defining a specific Command Type, this is the ID from the OBTYPE enumeration.
  • If defining a Color Section (from the Command Text Colors list on the Color Editor dialog box), this is the ID from the ENUM_COLOR_SECTION enumeration.
UID2

Long value specifying the second part of a 128 bit UID. UID2 is reserved for Command IDs that exists in the Toolkit environment. Since Toolkit command IDs use 128 bit values the only way to get at their data using automation is to supply two parameters. For typical automation uses (non Toolkit), you won't need this parameter and can simply supply a 0 value.

Description

Checks if CommandTypeOrColorSection parameter is allowed in current PCDMIS configuration

This checks whether or not the specified Command Type or Color Section ID is valid in the current PC-DMIS configuration. If it is valid, it returns TRUE.

Syntax

Visual Basic
Public Function IsAllowed( _
   ByVal UID1 As {Unrecognised type 21}, _
   ByVal UID2 As {Unrecognised type 21} _
) As Long

Parameters

UID1

Long value specifying the Command Type ID or Color Section ID.

  • If defining a specific Command Type, this is the ID from the OBTYPE enumeration.
  • If defining a Color Section (from the Command Text Colors list on the Color Editor dialog box), this is the ID from the ENUM_COLOR_SECTION enumeration.
UID2

Long value specifying the second part of a 128 bit UID. UID2 is reserved for Command IDs that exists in the Toolkit environment. Since Toolkit command IDs use 128 bit values the only way to get at their data using automation is to supply two parameters. For typical automation uses (non Toolkit), you won't need this parameter and can simply supply a 0 value.

Return Type

Long value. This returns -1 (or True) if the function succeeds and 0 (or False) if it does not.

See Also

Colors Collection


Item Method

Item Method
UID1

Long value specifying the Command Type ID or Color Section ID.

  • If defining a specific Command Type, this is the ID from the OBTYPE enumeration.
  • If defining a Color Section (from the Command Text Colors list on the Color Editor dialog box), this is the ID from the ENUM_COLOR_SECTION enumeration.
UID2

Long value specifying the second part of a 128 bit UID. UID2 is reserved for Command IDs that exists in the Toolkit environment. Since Toolkit command IDs use 128 bit values the only way to get at their data using automation is to supply two parameters. For typical automation uses (non Toolkit), you won't need this parameter and can simply supply a 0 value.

Description

Returns color object associated with CommandTypeOrColorSection parameter This method returns a specified color object from the color table based on the UID1 and UID2 parameters entered.

Syntax

Visual Basic
Public Function Item( _
   ByVal UID1 As {Unrecognised type 21}, _
   ByVal UID2 As {Unrecognised type 21} _
) As Color

Parameters

UID1

Long value specifying the Command Type ID or Color Section ID.

  • If defining a specific Command Type, this is the ID from the OBTYPE enumeration.
  • If defining a Color Section (from the Command Text Colors list on the Color Editor dialog box), this is the ID from the ENUM_COLOR_SECTION enumeration.
UID2

Long value specifying the second part of a 128 bit UID. UID2 is reserved for Command IDs that exists in the Toolkit environment. Since Toolkit command IDs use 128 bit values the only way to get at their data using automation is to supply two parameters. For typical automation uses (non Toolkit), you won't need this parameter and can simply supply a 0 value.

Return Type

Color object.

See Also

Colors Collection


SaveChanges Method

SaveChanges Method

Description

Saves Color objects modification

All changes made to the Colors collection are done inside a temporary structure. This copies the changes made inside this temporary structure to the master colors structure, essentially saving your changes, making them permanent.

Syntax

Visual Basic
Public Sub SaveChanges()

See Also

Colors Collection


UsedColor Method

UsedColor Method
UID1

Long value specifying the Command Type ID or Color Section ID.

  • If defining a specific Command Type, this is the ID from the OBTYPE enumeration.
  • If defining a Color Section (from the Command Text Colors list on the Color Editor dialog box), this is the ID from the ENUM_COLOR_SECTION enumeration.
UID2

Long value specifying the second part of a 128 bit UID. UID2 is reserved for Command IDs that exists in the Toolkit environment. Since Toolkit command IDs use 128 bit values the only way to get at their data using automation is to supply two parameters. For typical automation uses (non Toolkit), you won't need this parameter and can simply supply a 0 value.

Description

Returns the effective command type or color section used

This returns the color currently associated with the defined Command Type ID or Color Section ID. If a color is not defined for a feature type, the parent color is recursively searched until the default color is reached.

Syntax

Visual Basic
Public Function UsedColor( _
   ByVal UID1 As {Unrecognised type 21}, _
   ByVal UID2 As {Unrecognised type 21} _
) As Long

Parameters

UID1

Long value specifying the Command Type ID or Color Section ID.

  • If defining a specific Command Type, this is the ID from the OBTYPE enumeration.
  • If defining a Color Section (from the Command Text Colors list on the Color Editor dialog box), this is the ID from the ENUM_COLOR_SECTION enumeration.
UID2

Long value specifying the second part of a 128 bit UID. UID2 is reserved for Command IDs that exists in the Toolkit environment. Since Toolkit command IDs use 128 bit values the only way to get at their data using automation is to supply two parameters. For typical automation uses (non Toolkit), you won't need this parameter and can simply supply a 0 value.

See Also

Colors Collection


Application Property

Application Property

Description

Read Only: Returns object pointer of type Application This property represents the read-only PC-DMIS Application object. The Application object includes properties and methods that return top-level objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

Colors Collection


Background Property

Background Property

Description

Read/Write: Returns/Sets the Background color This property returns or sets the Background color for the report template's color tree.

Property type

Read-write property

Syntax

Visual Basic
Public Property Background() As Long

Return Type

Read/write Long value.

Remarks

Note on Colors: Colors are defined by a COLORREF value. When specifying a RGB color, the COLORREF value has this hexadecimal form as a Long value:

0x00BBGGRR

where BB=blue GG=green RR=red

The maximum value for a single byte in the hexadecimal format is 0xFF (or 255 in decimal format).

See Also

Colors Collection


Count Property

Count Property

Description

Read Only: Returns the number of color object defined in the collection This property returns the number of color nodes (Color objects) defined in the Colors collection (or color tree).

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

Return Type

Read only Long value.

See Also

Colors Collection


DimensionBackground Property

DimensionBackground Property

Description

Read/Write: Returns/Sets the Dimension background color This property returns or sets the dimension background color for the template's color tree.

Property type

Read-write property

Syntax

Visual Basic
Public Property DimensionBackground() As Long

Return Type

Read/write Long value.

Remarks

Note on Colors: Colors are defined by a COLORREF value. When specifying a RGB color, the COLORREF value has this hexadecimal form as a Long value:

0x00BBGGRR

where BB=blue GG=green RR=red

The maximum value for a single byte in the hexadecimal format is 0xFF (or 255 in decimal format).

See Also

Colors Collection


HighLightBackground Property

HighLightBackground Property

Description

Read/Write: Returns/Sets the Highlight background color This property returns or sets the highlight background color for the template's color tree.

Property type

Read-write property

Syntax

Visual Basic
Public Property HighLightBackground() As Long

Return Type

Read/write Long value.

Remarks

Note on Colors: Colors are defined by a COLORREF value. When specifying a RGB color, the COLORREF value has this hexadecimal form as a Long value:

0x00BBGGRR

where BB=blue GG=green RR=red

The maximum value for a single byte in the hexadecimal format is 0xFF (or 255 in decimal format).

See Also

Colors Collection


Modified Property

Modified Property

Description

Read/Write: Returns/Sets modified flag This property returns or sets the report template's "modified" tag for its color tree.

Property type

Read-write property

Syntax

Visual Basic
Public Property Modified() As Long

Return Type

Read/write Boolean value.

Remarks

Note on Colors: Colors are defined by a COLORREF value. When specifying a RGB color, the COLORREF value has this hexadecimal form as a Long value:

0x00BBGGRR

where BB=blue GG=green RR=red

The maximum value for a single byte in the hexadecimal format is 0xFF (or 255 in decimal format).

See Also

Colors Collection


NumTableColors Property

NumTableColors Property

Description

Read Only: Returns the Number of color defined in the color table This property returns the number of colors defined in the report template's color table.

Property type

Read-write property

Syntax

Visual Basic
Public Property NumTableColors() As Long

Return Type

Read only Long value.

See Also

Colors Collection


Parent Property

Parent Property

Description

Read Only: Returns object pointer to the Parent object This returns this object's parent object. In this case, this is the ReportTemplate object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Object

Return Type

ReportTemplate object.

See Also

Colors Collection


Command Object

Command Object
See Also Members

Description

PartProgram Command Object

The Command object represents a single command in PC-DMIS.

Object Model

Remarks

Examples of single commands in PC-DMIS are the start of a feature, a hit, the end of a feature, a single X dimension line, an auto feature, etc.

The Command object is also a "collection object" as it represents:

  • the collection of executions of this object in the current execution.
  • the collection of executions of this object in the previous execution.

See Also

Command Members


Command Object Members

Command ObjectMembers
See Also Overview

Public Methods

Public Method Dialog | Displays the edit dialog for the command object (if it exists) Opens the PC-DMIS dialog box for the corresponding command.
Public Method Dialog2 | Displays the edit dialog and sets the dialog object to the dialog (if it exists) Opens the PC-DMIS dialog for for the corresponding command.
Public Method EXECUTE | Attempts to execute the current command. Executes the command if the command is immediately executable.
Public Method GetExpression | Gets the expression of the indicated field of the command. Gets the expression of the indicated field of the command.
Public Method GetText | Returns the text used to represent a data item of the object. Gets the text of the indicated field of the command.
Public Method GetToggleString | Returns the toggle text delimited by the | symbol if the field is a toggle field, otherwise returns an empty string. Returns the string of text of a toggle field.
Public Method GetUniqueID | Retrieves the low and high parts of the 64-bit unique id of the command This command retrieves the low and high parts of the 64-bit unique id of the command.
Public Method IsExpressionValid | Returns true if expression is a valid PC-Dmis expression. Determines whether or not an expression is valid.
Public Method Item | Returns the execute instance of the object if the object has been executed more than once
Public Method Mark | Marks current command and dependencies or unmarks command. Marks the current object and all objects that depend on it. Optionally the features of the current alignment are also marked.
Public Method Next | Changes current command object to point to the next command object in the collection Accesses the next command in the parent Commands list.
Public Method OptimizedSetExpression | Like Set Expression, but optimized for speed (less accurate)
Public Method OptimizedSolveExpression | Like Solve Expression, but optimized for speed (less accurate)
Public Method Prev | Changes current command object to point to the previous command object in the collection Accesses the previous command in the parent Commands list.
Public Method PutText | Puts the specified text into the object data item Puts text into the indicated field of the command.
Public Method ReDraw | Redraws the command to show updated properties in the edit window This method requests that the object be redrawn in the Edit window.
Public Method Remove | Removes the current command object from the commands collection object Removes a command from the Commands list.
Public Method RemoveExpression | Removes any existing expression from the indicated field of the command. Removes the expression from the indicated field of the command.
Public Method SetBothArms | Sets command to be executed by Both Arms, returns false if command is a two state command
Public Method SetExpression | Sets the expression for the indicated field of the command. Sets the expression of the indicated field of the command.
Public Method SetMasterArm | Sets command to be executed by Master only.
Public Method SetSlaveArm | Sets command to be executed by Slave only, r eturns false if command cannot be slave owned
Public Method SetToggleString | Sets a toggle field to a numbered value in the toggle field list This method lets you set a toggle field in a numerical, language-independent way.
Public Method SolveExpression | Solves expression, if valid, and returns a variable object. SolveExpression evaluates the expression based on the objects above the command on which SolveExpression gets called.
Public Method UpdateDimensionNominals | Updates the nominals of related dimensions.

Public Properties

Public Property _ID
Public Property ActiveTipCommand | Read Only: Returns an automation active tip object if the current command object is of the correct type Returns an ActiveTip object if Command is of Type SET_ACTIVE_TIP. Nothing otherwise. Read-only.
Public Property AlignmentCommand Read Only: Returns the alignment command object interface for the current command if it is an alignment object

Returns this Command object as an AlignCmnd object if it can, Nothing otherwise.

Public Property Application | Read Only: Returns the Application Object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.
Public Property ArrayIndexCommand | Read Only: Returns an automation array index object if the current command object is of the correct type Returns an ArrayIndex object if Command is of Type ARRAY_INDEX. Returns Nothing otherwise. Read-only.
Public Property AttachCommand | Read Only: Returns an automation attach object if the current command object is of the correct type Returns an Attach object if Command is of Type ATTACH_PROGRAM. Returns Nothing otherwise. Read-only.
Public Property BasicScanCommand Read Only: Returns the basic scan command object interface for the current command if it is a basic scan object

Returns this Command object as an BasicScan object if it can, Nothing otherwise. Read-only.

Only Command objects of type BASIC_SCAN_OBJECT can become BasicScan objects.

Public Property BothArms | Read Only: Property indicating whether the command belongs to the both arms
Public Property CalibrationCommand | Read Only: Returns an automation calibration object if the current command object is of the correct type Returns a Calibration object if Command is of Type CALIB_SPHERE. Otherwise it returns Nothing. Read-only.
Public Property CommentCommand | Read Only: Returns an automation comment object if the current command object is of the correct type Returns a Comment object if Command is of Type SET_COMMENT. Otherwise it returns Nothing. Read-only.
Public Property CopyMeasToNom Read/Write: Flag that causes measured values to be copied to nominal values after execution

Property used to indicate/set whether the object should execute in MASTER mode. After executing in MASTER mode, the object copies the measured vector, centroid , and other nominal information to the nominals and turns off MASTER mode. This copies the same information that gets calculated using the CalculateNominals method.

Public Property Count Read Only: The number of times the command was executed during the last execution

Represents the number of copies of this Command which are available. If the part program is currently being executed, it is the number of times it has been executed so far in the current execution cycle. If the part program is not currently being executed, it is the number of times it was executed during the previous execution cycle. If Command has never been executed, Count has the value one.

Public Property DataTypes | Read Only: Returns the data type information collection for this command
Public Property DimensionCommand | Read Only: Returns the dimension command object interface for the current command if it is a dimension object Returns this Command object as an DimensionCommand object if it can, Nothing otherwise. Read-only.
Public Property DimensionEndCommand | Read Only: Returns the dimension end command object interface for the current command if it is a dimension end object
Public Property DimFormatCommand Read Only: Returns an automation dimension format object if the current command object is of the correct type

Returns a DimFormat object if Command is of Type DIMENSION_FORMAT. Otherwise it returns Nothing. Read-only.

Public Property DimInfoCommand | Read Only: Returns an automation dimension info object if the current command object is of the correct type Returns a DimInfo object if Command is of Type DIMENSION_INFORMATION. Otherwise it returns Nothing. Read-only.
Public Property DisplayMetaFileCommand | Read Only: Returns an automation display metafile object if the current command object is of the correct type Returns a DispMetaFile object if Command is of Type DISPLAY_METAFILE. Otherwise it returns Nothing. Read-only.
Public Property ExpectsMiss | Read/Write: Indicates whether script should plan for a miss error for this command
Public Property ExternalCommand | Read Only: Returns an automation external command object if the current command object is of the correct type Returns an ExternalCommand object if Command is of Type EXTERNAL_COMMAND. Otherwise it returns Nothing. Read-only.
Public Property Feature | Read Only: Type of feature (ie. Circle, Line, Sphere, etc.) or 0 if not a feature Represents the kind of feature that this Command object is.
Public Property FeatureCommand Read Only: Returns the feature command object interface for the current command if it is a feature object

Returns this Command object as an FeatCmd object if it can, Nothing otherwise. Read-only.

Public Property FileIOCommand Read Only: Returns an automation file I/O object if the current command object is of the correct type

Returns a FileIO object if Command is of Type FILE_IO_OBJECT. Otherwise it returns Nothing. Read-only.

Public Property FlowControlCommand Read Only: Returns the flow control command object interface for the current command if it is a flow control object

Returns this Command object as an FlowControlCmnd object if it can, Nothing otherwise. Read-only.

The Commands that have the following Type can become FlowControlCmnd objects are as follows:

LOOP_START
START_SUBROUTINE
CALL_SUBROUTINE
LABEL
GOTO
IF_GOTO_COMMAND
BASIC_SCRIPT
ONERROR
WHILE_COMMAND
ENDWHILE_COMMAND
IF_BLOCK_COMMAND
END_IF_COMMAND
IF_ELSE_COMMAND
END_IF_ELSE_COMMAND,
END_ELSE_COMMAND
DO_COMMAND
UNTIL_COMMAND
CASE_COMMAND
END_CASE_COMMAND
DEFAULT_CASE_COMMAND
END_DEFAULT_CASE_COMMAND
SELECT_COMMAND
END_SELECT_COMMAND

Public Property GetDataTypeCount | Returns the number of instances of the supplied data type in command
Public Property GetFieldValue Returns the value of the indicated field of the command. This read-only property returns the value of a field from a command.

If you try to access a field that isn't supported by the command, PC-DMIS returns FALSE. This property takes two parameters, the first parameter defines the field item. You can select this item from an enumerated list or use the associated constant number. The second parameter specifies the TypeIndex.

Public Property GetToggleValue Returns 0 if the field is not a toggle otherwise returns the toggle index

This read-only property checks a command's field and returns 0 if it isn't a toggle field. It also returns 0 if the field doesn't exist. Otherwise, it returns a the current toggle index value, with 1 as the base index value.

It takes two parameters. The first is an enumerated field type value to determine what field to check in a command, and the second is the TypeIndex.

Public Property HasBreakpoint | Read/Write: Flag that represents if the command has a breakpoint set Determines whether or not the current PC-DMIS command has a breakpoint.
Public Property HasField | Checks is the the command has the indicated field.
Public Property ID | Read/Write: ID of the command Represents the ID of the command.
Public Property IsActiveTip | Read Only: Indicates whether the command is a active tip command Determines whether or not the command is an ActiveTip command.
Public Property IsAlignment | Read Only: Indicates whether the command is an alignment command Determines whether or not the command is an alignment command type.
Public Property IsArrayIndex | Read Only: Indicates whether the command is a array index command Determines whether or not the command is an ArrayIndex command.
Public Property IsAttach | Read Only: Indicates whether the command is a attach command Determines whether or not the command is an Attach command.
Public Property IsBasicScan | Read Only: Indicates whether the command is a basic scan command Determines whether or not the command is a basic scan command.
Public Property IsCalibration | Read Only: Indicates whether the command is a calibration command Determines whether or not the command is a Calibration command.
Public Property IsComment | Read Only: Indicates whether the command is a comment command Determines whether or not the command is a Comment command.
Public Property IsConstructedFeature | Read Only: Indicates whether the command is a constructed feature command Determines whether or not the command is a constructed feature.
Public Property IsDCCFeature | Read Only: Indicates whether the command is a DCC command Determines whether or not the command is a DCC (Auto) Feature.
Public Property IsDimension | Read Only: Indicates whether the command is a dimension command Determines whether or not the command is a Dimension command type.
Public Property IsDimFormat | Read Only: Indicates whether the command is a dimension format command Determines whether or not the command is a a DimFormat command.
Public Property IsDimInfo | Read Only: Indicates whether the command is a dimension info command Determines whether or not the command is a DimInfo command.
Public Property IsDisplayMetaFile | Read Only: Indicates whether the command is a display metafile command Determines whether or not the command is a DispMetaFileCommand.
Public Property IsExternalCommand | Read Only: Indicates whether the command is a external command command Determines whether or not the command is an ExternalCommand.
Public Property IsFeature | Read Only: Indicates whether the command is a feature command Determines whether or not the command is a feature command type.
Public Property IsFileIOCommand | Read Only: Indicates whether the command is a file I/O command Determines whether or not the command is a FileIO command.
Public Property IsFlowControl | Read Only: Indicates whether the command is a flow control command Determines whether or not the command is a flow control command type.
Public Property IsHit | Read Only: Indicates whether the command is a hit command Determines whether or not the command is one of the hit command types.
Public Property IsLeapfrog | Read Only: Indicates whether the command is a leap frog command Determines whether or not the command is a Leapfrog command.
Public Property IsLoadMachine | Read Only: Indicates whether the command is a load machine command Determines whether or not the command is a LoadMachine command.
Public Property IsLoadProbe | Read Only: Indicates whether the command is a load probe command Determines whether or not the command is a LoadProbe command.
Public Property IsMeasuredFeature | Read Only: Indicates whether the command is a measured feature command Determines whether or not the command is a Measured Feature command.
Public Property IsModal | Read Only: Indicates whether the command is a modal command Determines whether or not the command is a modal command type.
Public Property IsMove | Read Only: Indicates whether the command is a move command Determines whether or not the command is a Move command.
Public Property IsOptionProbe Read Only: Indicates whether the command is a option probe command

Determines whether or not the command is an option probe command.

Public Property IsOptMotion | Read Only: Indicates whether the command is a optional motion command Determines whether or not the command is an OptMotion command.
Public Property IsScan | Read Only: Indicates whether the command is a scan command Determines whether or not the command is a Scan command.
Public Property IsStatistic | Read Only: Indicates whether the command is a statistic command Determines whether or not the command is a Statistics command.
Public Property IsTempComp | Read Only: Indicates whether the command is a temperature compensation command Determines whether or not the command is a TempComp command.
Public Property IsTraceField | Read Only: Indicates whether the command is a trace field command Determines whether or not the command is a TraceField command.
Public Property ItemIndex | Returns the execute instance index if the object has been executed more than once otherwise returns 0
Public Property LeapfrogCommand | Read Only: Returns an automation leap frog object if the current command object is of the correct type Returns a LeapFrog object if the Command is of Type LEAPFROG. Otherwise it returns Nothing. Read-only.
Public Property LoadMachineCommand | Read Only: Returns an automation load machine object if the current command object is of the correct type Returns a LoadMachine object if Command is of Type GET_MACHINE_DATA. Otherwise it returns Nothing. Read-only.
Public Property LoadProbeCommand | Read Only: Returns an automation load probe object if the current command object is of the correct type Returns a LoadProbe object if Command is of Type GET_PROBE_DATA. Otherwise it returns Nothing. Read-only.
Public Property Marked Read/Write: Returns/Sets the marked for execution status of the current command

Property used to indicate/set whether command is marked in the edit window.

Public Property MasterArm | Read Only: Property indicating whether the command belongs to the master arm only
Public Property MissedHit Read Only: Indicates whether a missed hit occured on the last executed command

This property checks whether or not a missed hit occurred on the last executed instance of the specified command.

Public Property ModalCommand Read Only: Returns the modal command object interface for the current command if it is a modal object

Returns a ModalCommand object for the Command if it can, Nothing otherwise. Read-only.

Public Property MoveCommand | Read Only: Returns the move command object interface for the current command if it is a move object Returns this Command object as a ModalCommand object if it can, Nothing otherwise. Read-only.
Public Property OptionProbeCommand | Read Only: Returns an automation optional probe object if the current command object is of the correct type Returns an OptProbe object if Command is of Type OPTIONPROBE. Otherwise it returns Nothing. Read-only.
Public Property OptMotionCommand | Read Only: Returns an automation optional motion object if the current command object is of the correct type Returns an OptMotion object if Command is of Type OPTIONMOTION. Otherwise it returns Nothing. Read-only.
Public Property Parent Read Only: Returns the Parent Commands Collection Object

Returns the parent Commands collection object. Read-only.

Public Property RecalculateINOUT | Read/Write: Flag that determines if the INNER/OUTER flag is recalculated after execution
Public Property ScanCommand | Read Only: Returns an automation scan object if the current command object is of the correct type Returns a Scan object if Command is of Type DCCSCAN_OBJECT or Type MANSCAN_OBJECT. Otherwise it returns Nothing. Read-only.
Public Property ShowIDOnCad Read/Write: Property indicating whether the command id should appear in the cad window

Property used to indicate/set whether the command ID should be displayed in the CAD window.

Public Property Skipped Read Only: Indicates whether the command has been skipped or not

Property used to indicate whether the a command was skipped over.

Public Property SlaveArm Read Only: Property indicating whether the command belongs to the slave arm only

Property used to indicate/set whether command is a slave arm object.

Public Property SlotType | SlotType: Property indicating whether a command is a slot of a certain type
Public Property StatisticCommand | Read Only: Returns an automation statistic object if the current command object is of the correct type Returns a Statistics object if Command is of Type STATISTICS. Otherwise it returns Nothing. Read-only.
Public Property TempCompCommand | Read Only: Returns an automation temperature compensatiion object if the current command object is of the correct type Returns a TempComp object if Command is of Type TEMP_COMP. Otherwise it returns Nothing. Read-only.
Public Property TraceFieldCommand | Read Only: Returns an automation trace field object if the current command object is of the correct type Returns a TraceField object if Command is of Type TRACEFIELD. Otherwise it returns Nothing. Read-only.
Public Property TracksErrors | Read/Write: Indicates Whether script will handle errors for this command Property used to determine whether or not the script will handle errors for the specified command.
Public Property Type | Read Only: The command type Returns the type of the Command.
Public Property TypeDescription Read Only: Returns String Describing Object Type

Returns a human-readable description of Type of the object. For example, an object of type CONST_OFF_PLANE has the string "Constructed Offset Plane" returned by this function.

Public Property UnexpectedHit Read Only: Indicates whether an unexpected hit occured

This property checks whether or not an unexpected hit occurred on the last executed instance of the specified command.

Public Property UserDefinedUniqueID | Read/Write: Gets/Sets user defined unique id

See Also

Command Overview


Dialog Method

Dialog Method

Description

Displays the edit dialog for the command object (if it exists) Opens the PC-DMIS dialog box for the corresponding command.

Syntax

Visual Basic
Public Function Dialog() As Boolean

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

Command Object


Dialog2 Method

Dialog2 Method
DialogObject
Dmis dialog command object returned if the dialog is a modeless dialog.

Description

Displays the edit dialog and sets the dialog object to the dialog (if it exists) Opens the PC-DMIS dialog for for the corresponding command.

Syntax

Visual Basic
Public Function Dialog2( _
   ByVal DialogObject As DmisDialog _
) As Boolean

Parameters

DialogObject
Dmis dialog command object returned if the dialog is a modeless dialog.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

Command Object


EXECUTE Method

EXECUTE Method

Description

Attempts to execute the current command.

Executes the command if the command is immediately executable.

Syntax

Visual Basic
Public Function EXECUTE() As Boolean

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

Command Object


GetExpression Method

GetExpression Method
FieldType
Used to indicate from which field the expression is being retrieved. Type ENUM_FIELD_TYPES enumeration.
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a field type.

Description

Gets the expression of the indicated field of the command. Gets the expression of the indicated field of the command.

Syntax

Visual Basic
Public Function GetExpression( _
   ByVal FieldType As ENUM_FIELD_TYPES, _
   ByVal TypeIndex As Long _
) As String

Parameters

FieldType
Value Description
ID
REF_ID
LEVEL_REF_ID
ROTATE_REF_ID
ORIGIN_REF_ID
THEO_X
THEO_Y
THEO_Z
THEO_SX
THEO_SY
THEO_SZ
THEO_EX
THEO_EY
THEO_EZ
THEO_I
THEO_J
THEO_K
TARG_X
TARG_Y
TARG_Z
MEAS_X
MEAS_Y
MEAS_Z
MEAS_I
MEAS_J
MEAS_K
MEAS_LENGTH
MEAS_DIAM
MEAS_ANGLE
TARG_I
TARG_J
TARG_K
THEO_DIAM
THEO_WIDTH
THEO_LENGTH
THEO_HEIGHT
THEO_ANGLE
COORD_TYPE
INOUT_TYPE
THICKNESS_TYPE
CIRC_TYPE
SNAP_TYPE
USEPIN_TYPE
MOVE_TYPE
READPOS_TYPE
FINDHOLE_TYPE
RMEAS_TYPE
THEOBF_TYPE
BOUND_TYPE
BF_MATH_TYPE
AUTOFIT_CONSTRAINT
SLOT_MIN_MAX_TYPE
FIND_NOM_AXIS_TYPE
N_INIT_HITS_TYPE
N_PERM_HITS_TYPE
SEARCHMODE_TYPE
MODE_TYPE
MEASURE_ORDER_TYPE
CONE_LENGTH_ANGLE_TYPE
OFFSET_LINE_METHOD
LIN_POL_FILT_TYPE
GEN_FEAT_TYPE
GEN_ALIGN_TYPE
CURVE_TYPE
MEASURED_2D3D_TYPE
THINNING_TOL
HITINT_TYPE
RMEASFEATID
N_HITS
N_ROWS
INIT_HITS
PERM_HITS
F_OFFSET
F_SPACER
F_PITCH
F_THICKNESS
F_DEPTH
F_AUTOMOVE
F_INDENT
F_CORNER_RADIUS
F_INCREMENT
F_TOLERANCE
F_BOXWIDTH
F_BOXLENGTH
F_CIRCRADOUT
F_CIRCRADIN
F_CHECK
F_MAXACCELX
F_MAXACCELY
F_MAXACCELZ
SCAN_ACCELERATION
SCAN_OFFSET_FORCE
MANUAL_FINE_PROBING
F_MOVESPEED
F_TOUCHSPEED
F_SCANSPEED
START_ANG
END_ANG
MIDPOINT_X
MIDPOINT_Y
MIDPOINT_Z
ANGVEC_I
ANGVEC_J
ANGVEC_K
MEASVEC_I
MEASVEC_J
MEASVEC_K
SLOTVEC_I
SLOTVEC_J
SLOTVEC_K
SURFVEC_I
SURFVEC_J
SURFVEC_K
PINVEC_I
PINVEC_J
PINVEC_K
PUNCHVEC_I
PUNCHVEC_J
PUNCHVEC_K
REPORTVEC_I
REPORTVEC_J
REPORTVEC_K
TARGSLOT_I
TARGSLOT_J
TARGSLOT_K
UPDATEVEC_I
UPDATEVEC_J
UPDATEVEC_K
THEO_MINOR_AXIS
TWO_D_THREE_D_TYPE
AXIS
DEST_EXPR
SRC_EXPR
SHOW_IDS
SHOW_DETAILS
WEIGHT
ITEM_USED
USE_AXIS
AVERAGE_ERROR
MEASURE_ALL_FEATURES
REPIERCE_CAD
START_NUM
END_NUM
SKIP_NUM
X_OFFSET
Y_OFFSET
Z_OFFSET
ANGLE_OFFSET
INTERNAL_EXTERNAL
SAVE_ALIGN_CAD_TO_PARTS
FILE_NAME
ALIGN_LIST
WORK_PLANE
DISTANCE
OLD_TIP
NEW_TIP
ROTATION_TYPE
DIM_INFO_ORDER
DIM_INFO_LOC
DIM_INFO_TP_LOC
GRAPH_ANALYSIS
TEXT_ANALYSIS
ARROW_MULTIPLIER
OUTPUT_TYPE
NOMINAL
F_PLUS_TOL
F_MINUS_TOL
TP_MODIFIER
PERP_PARALLEL_TYPE
RADIUS_TYPE
UNIT_TYPE
DIM_LENGTH
PROFILE_FORM_TYPE
PRECISION
MAN_RETRACT
DIM_TEXT
DIM_TEXT_OPTIONS
SHOW_HEADINGS
DEVIATION_SYMBOLS
STANDARD_DEVIATION
DIM_HEADING
GAP_ONLY_TYPE
DISPLAY_ID
DISPLAY_TYPE
POINT_INFO_HEADING
SHOW_POINT_INFO
RET_ONLY_TYPE
COMMENT_FIELD
COMMENT_TYPE
PART_NAME
REVISION_NUMBER
SERIAL_NUMBER
STAT_COUNT
SUB_NAME
READ_WRITE
FILE_POINTER
FIELD_WIDTH
DIGIT_COUNT
LABEL_ID
ERROR_TYPE
ERROR_MODE
DESCRIPTION
INDEX_START
INDEX_END
FILE_COMMAND_TYPE
BUFFER_SIZE_TYPE
FAIL_ON_EXIST
MAX_FORCE
LOW_FORCE
UP_FORCE
TRIGGER_FORCE
PROBE_ACCURACY
POSITIONAL_ACCURACY
NUM_RETURN_DATA
RETURN_SPEED
SCAN_DENSITY
POLAR_VECTOR_COMPENSATION
AUTO_PRINT
ORIGIN
MATERIAL_COEFFICIENT
REF_TEMP
HIGH_THRESHOLD
LOW_THRESHOLD
SENSOR_LIST
FIXTURE_TYPE
MACHINE_TYPE
PROBE_COMP
TIP_I
TIP_J
TIP_K
NORM_RELEARN
FIND_NOMS_TYPE
AUTO_CLEAR_PLANE
SINGLE_POINT
DISPLAY_HITS
CAD_TOLERANCE
OFFSET_TOLERANCE
MIN_INCREMENT
MAX_INCREMENT
MIN_ANGLE
MAX_ANGLE
F_LOCATION
COL132_TYPE
COMMAND_STRING
FLY_MODE_TYPE
STATS_TYPE
STATS_DIR
NEW_STATS_DIR
DATA_READ_LOCK
DATA_WRITE_LOCK
DATA_MEM_PAGES
STAT_NAME_TYPE
STAT_CALC_TYPE
TRANSFER_DIR
DISPLAY_TRACE
TRACE_NAME
TRACE_VALUE
SCAN_CUTPLANEVEC_I
SCAN_CUTPLANEVEC_J
SCAN_CUTPLANEVEC_K
SCAN_INITVEC_I
SCAN_INITVEC_J
SCAN_INITVEC_K
SCAN_AXISVEC_I
SCAN_AXISVEC_J
SCAN_AXISVEC_K
SCAN_ENDVEC_I
SCAN_ENDVEC_J
SCAN_ENDVEC_K
SCAN_INITDIR_I
SCAN_INITDIR_J
SCAN_INITDIR_K
SCAN_CROSS_TOTAL
SCAN_TIME_INCR
SCAN_EDGE_THICK
POS_REPORT_AXIS_X
POS_REPORT_AXIS_Y
POS_REPORT_AXIS_Z
DEV_PERPEN_CENTERLINE
USE_THEO
TARGET_COLOR
THEO_START_ANG
THEO_END_ANG
ONOFF_TYPE
ROW_ID
LOCATOR_BMP
LOCATOR_WAV
DTYPE_LEAPFROGTYPE
DTYPE_LEAPFROGNUMHITS
DTYPE_LEAPFROGFULLPARTIAL
EXCLUSION_ZONE
EXECUTE
AUTOTRIGGERONOFF
AUTOBEEPING
COLUMN_ID
SLOT_NUMBER
AUTOTOLZONE
PROBING_MODE
ANGLE_COMP_TOGGLE
POINTINFO_FILTER_INTERVAL
POINTINFO_FILTER_INTERVAL_NUMBER
FEAT_TYPE
DIM_ID
MEAS_MINOR_AXIS
MEAS_HEIGHT
MEAS_SLOTVEC_I
MEAS_SLOTVEC_J
MEAS_SLOTVEC_K
MEAS_SX
MEAS_SY
MEAS_SZ
MEAS_EX
MEAS_EY
MEAS_EZ
MEAS_WIDTH
NUM_CONTROL_POINTS
U_HITS
V_HITS
NUM_FIT_POINTS
NOMINAL_COLOR
WAVE_FILE
DIM_BONUS
PERUNIT_STEPSIZE
PERUNIT_LENGTH
PERUNIT_WIDTH
DIM_MEASURED
SURFVEC_TARG_I
SURFVEC_TARG_J
SURFVEC_TARG_K
DIM_MAX
EDGEVEC_TARG_I
EDGEVEC_TARG_J
EDGEVEC_TARG_K
DIM_MIN
EDGEVEC_THEO_I
EDGEVEC_THEO_J
EDGEVEC_THEO_K
DIM_DEVIATION
EDGEVEC_MEAS_I
EDGEVEC_MEAS_J
EDGEVEC_MEAS_K
DIM_OUTTOL
T_VALUE
TOOL_X
TOOL_Y
TOOL_Z
TOOL_DIAM
DEV_X
DEV_Y
DEV_Z
DEV_DIAM
ITERATE_COLUMNS
LOAD_TYPE
NUM_ITERATIONS
METHOD_TYPE
SCAN_TECHNIQUE
HIT_TYPE
BOUNDARY_POINT_X
BOUNDARY_POINT_Y
BOUNDARY_POINT_Z
VIDEO_GAIN
VIDEO_OFFSET
VIDEO_LEDLIGHT
VIDEO_LASERLIGHT1
VIDEO_LASERLIGHT2
VIDEO_YORIGIN
VIDEO_YEND
VIDEO_LSEG
VIDEO_XSEG
VIDEO_YSEG
ANGULARITY_NOM_ANGLE
PRINT_TO_FILE
PRINT_TO_PRINTER
PRINT_DRAFTMODE
PRINT_DELETE_RUNS
POINTINFO_FILTER_WORST
POINTINFO_FILTER_WORST_NUMBER
POINTINFO_FILTER_DEVIATION
POINTINFO_FILTER_DEVIATION_NUMBER
POINTINFO_FILTER_OUTTOL
REPORT_SURFVEC_I
REPORT_SURFVEC_J
REPORT_SURFVEC_K
DB_QUERY_OP
DB_SOURCE_NAME
CHART_TYPE
DB_CHART_NAME
DEVIATION_ANGLE
STATS_DATASOURCE
IGNOREMOTIONERRORS_TYPE
THEO_X2
THEO_Y2
THEO_Z2
MEAS_X2
MEAS_Y2
MEAS_Z2
PPROG
TRACE_FILTER
TIME_FILTER
SHOW_SPC_CALCS
SPEC_LIMITS
ZONES
STDDEV
UCL_LCL
HISTOGRAM
GRID
ADDITIONAL_CHART
LINE2_PLANAR_OPEN_IN_X
LINE3_PLANAR_OPEN_IN_X
REGR
CENTER_POINT
SHOW_MORE_SPC_CALCS
SPEC_OFFSET
SOLID
U_L_BOUNDS
TITLE
CPOINT_X
CPOINT_Y
CPOINT_Z
CPOINT_I
CPOINT_J
CPOINT_K
CPOINT_DIAM
CPOINT_SCAN_CROSS_TOTAL
CPOINT_SCAN_DENSITY
CPOINT_F_SCANSPEED
N_CONTROLPOINTS
CPOINT_TYPE
USE_3DFILTER
SCAN_BNDRY_TYPE
CREATE_WEIGHTS
F_SIZE
LINE2_ISPLANAR
LINE2_PLANAR_XTOL
LINE2_PLANAR_YTOL
LINE2_PLANAR_XDEV
LINE2_PLANAR_YDEV
LINE3_ISPLANAR
LINE3_PLANAR_XTOL
LINE3_PLANAR_YTOL
LINE3_PLANAR_XDEV
LINE3_PLANAR_YDEV
CHART_SUB_TYPE
OVERWRITE
OUTPUT_FEATURE_NOMS
OUTPUT_FEAT_W_DIMENS
OUTPUT_DMIS_REPORT
TIME_ARG
TRACE_FILTER_ARG
FIT
STATS_DB_TYPE
IOCHANNEL_NUMBER
IOCHANNEL_PULSE_WIDTH
IOCHANNEL_PULSE_INTERVAL
IOCHANNEL_PULSE_DURATION
GRAPH_OPTION
DB_SOURCE_TYPE
FIND_HOLE_PERCENT
AUTO_ONERROR_TYPE
POS_REPT_DISPLAY_OPTION
TRIGGERTOLERANCE
TRIGGERTOLVALUE
FIXTURE_TOL
START_LABEL
ERROR_LABEL
CONE_CONVEX_TYPE
TRIGGERPLANE
QUERY_SHOW_GRAPHIC_SETTINGS
CALC_STYLE_FILE
FILTER_TYPE
TRACE_VALUE_LIMIT
TARGET_DIRECTION
TARGET_EDGE_POLARITY
BSMETHOD_TYPE
CENTER_ROTATION_THEO
CENTER_ROTATION_MEAS
ARTICULATEDARM_TYPE
LEFTYRIGHTY_CONFIG
ABOVEBELOW_CONFIG
NOFLIPFLIP_CONFIG
HIGH_ACCURACY
SURFACE
MAGNIFICATION
MINOR_WORD_TOGGLE
PERCENTAGE
THRESHOLD
N_SIDES
TARGET_SURFACE_ILLUM
MEAN
CAD_COMP
SHOW_ROW
SHOW_COLUMN
TARGET_SURFACE_SENSILIGHT
TARGET_SURFACE_WIDTH
TARGET_SURFACE_HEIGHT
TARGET_SURFACE_RANGE
TARGET_SURFACE_DURATION
TARGET_SURFACE_MODE
TARGET_SURFACE_HIACC
SCREEN_CAPTURE_SCALE
SCREEN_CAPTURE_QUALITY
TARGET_EDGE_SIZE
TARGET_EDGE_ILLUM
TARGET_EDGE_TOL
TARGET_EDGE_STRENGTH
TARGET_EDGE_DENSITY
TARGET_EDGE_TYPE
DISPLAY_ADVANCED_PARAMETERS
TARGET_SURFACE_TYPE
VOID_DETECT
TARG_SX
TARG_SY
TARG_SZ
TARG_EX
TARG_EY
TARG_EZ
PATTERN_TYPE
TARGET_EDGE_ANGLE
PROGRAM_GAGE_FEAT_TYPE
PROGRAM_GAGE_TYPE
TARGET_FOCUS
RMEASFEATIDX
RMEASFEATIDY
RMEASFEATIDZ
FINDNOMS_BESTFIT
FINDNOMS_ONLYSELECTED
TEMPX
TEMPY
TEMPZ
TEMPP
AUTO_PH9
MANUAL_PREPOSITION
SCREEN_CAPTURE_TYPE
SCREEN_CAPTURE_AUTO_TYPE
TARGET_EDGE_EDGESELECT
TARGET_EDGE_EDGENUM
DELETE_TYPE
SCREEN_CAPTURE_AUTO_TIME
USE_HSSDAT
USE_STARTENDDELAY
COP_FILTER
COP_SIZE
COP_TYPE
SURFVEC_MEAS_I
SURFVEC_MEAS_J
SURFVEC_MEAS_K
TARGET_EDGE_UNDERSCAN
PROFILE_TYPE
THEO_FLUSH
MEAS_FLUSH
THEO_GAP
MEAS_GAP
THEO_DEPTH
MEAS_DEPTH
TARGET_BLOB_TYPE
LASER_STRIPE_OVERLAP
LASER_STRIPE_OVERSCAN
LASER_FREQUENCY
TARGET_FILTER_OUTLIER
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD
SLOT_TYPE
TARGET_TYPE
THEO_R
THEO_A
THEO_H
MEAS_R
MEAS_A
MEAS_H
TARG_R
TARG_A
TARG_H
THEO_SR
THEO_SA
THEO_SH
THEO_ER
THEO_EA
THEO_EH
MEAS_SR
MEAS_SA
MEAS_SH
MEAS_ER
MEAS_EA
MEAS_EH
TARG_SR
TARG_SA
TARG_SH
TARG_ER
TARG_EA
TARG_EH
TARGET_EDGE_SENSILIGHT
F_THICKNESS_EDGE
THICKNESS_TYPE_EDGE
LASER_EXPOSURE
LASER_INTENSITY
ANGLE_OFFSET_2
LASER_FILTER_NEIGHBOR_NUM
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD
LASER_FILTER_TOL_ABOVE
LASER_FILTER_TOL_BELOW
LASER_FILTER_TOL_RIGHT
LASER_CLIP_UP_DIST
LASER_CLIP_LOW_DIST
LASER_PIXEL_TOGGLE
LASER_FILTER_TOGGLE
DISPLAY_PROBE_PARAMETERS
THEO_R2
THEO_A2
THEO_H2
MEAS_R2
MEAS_A2
MEAS_H2
LASER_CLIP_LEFT_DIST
LASER_CLIP_RIGHT_DIST
COP_FILETYPE
COP_SELECTIONTYPE
COP_COLORMAP
COP_COPLEMENT
OPERTYPE
COP_BOOLEANTYPE
COP_IMPORTFILETYPE
MEAS_START_ANG
MEAS_END_ANG
ISLAND_DIAM
ISLAND_LENGTH
ISLAND_WIDTH
ISLAND_X
ISLAND_Y
ISLAND_Z
ISLAND_I
ISLAND_J
ISLAND_K
ISLAND_AI
ISLAND_AJ
ISLAND_AK
ISLAND_TYPE
ISLAND_CLEARANCEDIST
RPT_DIMENSION_TABLES
SUMMARY_DEV
DRF_TBLHDR
LINE1_TBLHDR
LINE1_CALLOUT
LINE1_COLUMN_HDR
LINE1_FEATNAME
LINE1_NOMINAL
LINE1_MEAS
LINE1_PLUSTOL
LINE1_MINUSTOL
LINE1_DEV
LINE1_DEVPERCENT
LINE1_ISBILATERAL
LINE1_NUMZONES
LINE2_TBLHDR
LINE2_CALLOUT
LINE2_COLUMN_HDR
LINE2_FEATNAME
LINE2_BONUS
LINE2_TOL
LINE2_DATUMSHFT
LINE2_UNUSEDZONE
LINE2_DEV
LINE2_DEVANG
LINE2_DEVPERCENT
LINE3_TBLHDR
LINE3_CALLOUT
LINE3_COLUMN_HDR
LINE3_FEATNAME
LINE3_BONUS
LINE3_TOL
LINE3_DATUMSHFT
LINE3_UNUSEDZONE
LINE3_DEV
LINE3_DEVANG
LINE3_DEVPERCENT
DRF_COLUMN_HDR
DRF_SEGNAME
DRF_SHIFTX
DRF_SHIFTY
DRF_SHIFTZ
DRF_ROTATIONX
DRF_ROTATIONY
DRF_ROTATIONZ
SUMMARY_COLUMN_HDR
SUMMARY_FEAT
LINE2_AXIS
LINE2_NOMINAL
LINE2_MEAS
SUMMARY_TBLHDR
SUMMARY_AXIS
SUMMARY_NOMINAL
SUMMARY_MEAS
LINE2_PLUSTOL
LINE2_MINUSTOL
LINE2_MAX
LINE2_MIN
LINE2_ISBILATERAL
LINE2_NUMZONES
LINE3_ISBILATERAL
LINE3_NUMZONES
DIM_RPT_COLUMN_HDR
DIM_RPT_ISDATUM
DIM_RPT_DATUM
DIM_RPT_GRAPHIC
DIM_RPT_DEVPERCENT
DIM_RPT_ISBILATERAL
DIM_RPT_NUMZONES
GDT_SYMBOL
COMMENT_INPUT
TARGET_EDGE_WIDTH
TARGET_EDGE_HEIGHT
TARGET_EDGE_EDGEDETECT
TARGET_EDGE_FILTER_CLEAN
TARGET_EDGE_FILTER_CLEAN_STRENGTH
TARGET_EDGE_FILTER_AREA
TARGET_EDGE_FILTER_AREA_SIZE
TARGET_EDGE_GRADIENT
THEO_PERIMETER
MEAS_PERIMETER
THEO_AREA
MEAS_AREA
TARGET_SURFACE_CROSSHAIR_HEIGHT
SHOW_NOMS
COMPOSITE
DATUM2
TP_MODIFIER2
DESCRIPTION2
SHOW_OPTIONS
LEADER_LINE_ID
GDT_SYMBOL2
DATUM1_MODIFIER
DATUM2_MODIFIER
DATUM3_MODIFIER
DATUM1_MODIFIER2
DATUM2_MODIFIER2
DATUM3_MODIFIER2
DIM_RPT_DEVPERCENT_NOM
DIM_RPT_USETWODEVIATIONS
DIM_RPT_DEVPERCENT2
LINE2_DEVPERCENT_NOM
LINE2_USE2DEVIATIONS
LINE2_DEVPERCENT2
LINE3_DEVPERCENT_NOM
LINE3_USE2DEVIATIONS
LINE3_DEVPERCENT2
AXIS_PLUS_TOL
AXIS_MINUS_TOL
AXIS_NOMINAL
AXIS_DESCRIPTION
LINE1_DEVPERCENT_NOM
LINE1_USE2DEVIATIONS
LINE1_DEVPERCENT2
USE_AXIS2
DIM_LENGTH2
TEXTANAL_LABEL_MEAS_X
TEXTANAL_LABEL_MEAS_Y
TEXTANAL_LABEL_MEAS_Z
TEXTANAL_LABEL_MEAS_I
TEXTANAL_LABEL_MEAS_J
TEXTANAL_LABEL_MEAS_K
TEXTANAL_LABEL_DEV
TEXTANAL_LABEL_MINMAX
SIMULT_EVAL
SECTION_INDEX
LINE1_OUTTOL
LINE2_OUTTOL
LINE3_OUTTOL
LINE1_MAX
LINE1_MIN
LINE3_NOMINAL
LINE3_MEAS
LINE3_PLUSTOL
LINE3_MINUSTOL
LINE3_MAX
LINE3_MIN
SUMMARY_OUTTOL
SUMMARY_PLUSTOL
SUMMARY_MINUSTOL
SUMMARY_MAX
SUMMARY_MIN
SUMMARY_BONUS
LINE1_BONUS
GRAPH_ANALYSIS_POINT_SIZE
GRAPH_ANALYSIS_PLUS_TOL
GRAPH_ANALYSIS_MINUS_TOL
DIM_AXIS_ITEM_NUMBER
F_ENDING_DEPTH
DIM_ITEM_NUMBER
FEAT_ITEM_NUMBER
COMMAND_TYPE
DEV_MAX
AUTO_DEV_DIRECTION
PROBE_DIRECTION
USER_DEFINED_THEOS
SCALING
USE_SCALING
UID
REF_UID
BA_SOLUTION_TYPE
BA_SOLUTION_OPTIONS
BA_SOLUTION_STATUS
BA_VARIANCE
BA_RMS
BA_WARNINGS
BA_STATION
BA_STATION_X
BA_STATION_Y
BA_STATION_Z
BA_STATION_ROTX
BA_STATION_ROTY
BA_STATION_ROTZ
BA_STATION_ORIENTED
BA_STATION_LOCKED
BA_FEATURE
BA_FEAT_SOURCE
BA_FEAT_RMS
BA_FEAT_POINTING_ERR
BA_FEAT_APEX_ANGLE
BA_FEAT_X
BA_FEAT_Y
BA_FEAT_Z
BA_FEAT_DEV_X
BA_FEAT_DEV_Y
BA_FEAT_DEV_Z
BA_FEAT_DEV3D
NO_APPROACH_VECTOR_FLIP
TARGET_EDGE_START_VALUE
TARGET_EDGE_END_VALUE
TARGET_SURFACE_SURFACE_VARIANCE
RELATIVE_COMMENTS
AUTO_ROTARY
TARGET_COVERAGE
ROTATION_TYPE_2
PROBE_TYPE
TIME_STAMP
ECOND_TEMP
ECOND_PRESSURE
ECOND_HUMIDITY
HIT_RMS
DISPLAY_TRACKER_PARAMETERS
PTDENSITY_TOGGLE
PTDENSITY_UPPERBOUND
PTDENSITY_DEVLIMIT
PTDENSITY_MAXSPAN
TARGET_MEASURE_AT_FOV_CENTER
TARGET_SURFACE_FIND_SURFACE
PROJECTOR
INLINE_LEGACY_REPORT
SINGLE_POINT_DEVIATION
Used to indicate from which field the expression is being retrieved. Type ENUM_FIELD_TYPES enumeration.
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a field type.

Return Type

String which is the expression on the given field if it has an expression. Otherwise, the string will be empty.

Remarks

Use this command to get expressions for different object fields. The ENUM_FIELD_TYPES enumeration is a large enumeration. Documentation for which field types go with which objects is not given here. You can find this information by creating the desired object in PC-DMIS, inserting the desired expression in the desired field, and exporting (posting out) the containing part program to BASIC.

See Also

Command Object | SetExpression Method | RemoveExpression Method | GetText Method


GetText Method

GetText Method
DataType
Used to indicate the field from which the text is being retrieved. Type ENUM_FIELD_TYPES enumeration.
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a field type.

Description

Returns the text used to represent a data item of the object. Gets the text of the indicated field of the command.

Syntax

Visual Basic
Public Function GetText( _
   ByVal DataType As ENUM_FIELD_TYPES, _
   ByVal TypeIndex As Long _
) As String

Parameters

DataType
Value Description
ID
REF_ID
LEVEL_REF_ID
ROTATE_REF_ID
ORIGIN_REF_ID
THEO_X
THEO_Y
THEO_Z
THEO_SX
THEO_SY
THEO_SZ
THEO_EX
THEO_EY
THEO_EZ
THEO_I
THEO_J
THEO_K
TARG_X
TARG_Y
TARG_Z
MEAS_X
MEAS_Y
MEAS_Z
MEAS_I
MEAS_J
MEAS_K
MEAS_LENGTH
MEAS_DIAM
MEAS_ANGLE
TARG_I
TARG_J
TARG_K
THEO_DIAM
THEO_WIDTH
THEO_LENGTH
THEO_HEIGHT
THEO_ANGLE
COORD_TYPE
INOUT_TYPE
THICKNESS_TYPE
CIRC_TYPE
SNAP_TYPE
USEPIN_TYPE
MOVE_TYPE
READPOS_TYPE
FINDHOLE_TYPE
RMEAS_TYPE
THEOBF_TYPE
BOUND_TYPE
BF_MATH_TYPE
AUTOFIT_CONSTRAINT
SLOT_MIN_MAX_TYPE
FIND_NOM_AXIS_TYPE
N_INIT_HITS_TYPE
N_PERM_HITS_TYPE
SEARCHMODE_TYPE
MODE_TYPE
MEASURE_ORDER_TYPE
CONE_LENGTH_ANGLE_TYPE
OFFSET_LINE_METHOD
LIN_POL_FILT_TYPE
GEN_FEAT_TYPE
GEN_ALIGN_TYPE
CURVE_TYPE
MEASURED_2D3D_TYPE
THINNING_TOL
HITINT_TYPE
RMEASFEATID
N_HITS
N_ROWS
INIT_HITS
PERM_HITS
F_OFFSET
F_SPACER
F_PITCH
F_THICKNESS
F_DEPTH
F_AUTOMOVE
F_INDENT
F_CORNER_RADIUS
F_INCREMENT
F_TOLERANCE
F_BOXWIDTH
F_BOXLENGTH
F_CIRCRADOUT
F_CIRCRADIN
F_CHECK
F_MAXACCELX
F_MAXACCELY
F_MAXACCELZ
SCAN_ACCELERATION
SCAN_OFFSET_FORCE
MANUAL_FINE_PROBING
F_MOVESPEED
F_TOUCHSPEED
F_SCANSPEED
START_ANG
END_ANG
MIDPOINT_X
MIDPOINT_Y
MIDPOINT_Z
ANGVEC_I
ANGVEC_J
ANGVEC_K
MEASVEC_I
MEASVEC_J
MEASVEC_K
SLOTVEC_I
SLOTVEC_J
SLOTVEC_K
SURFVEC_I
SURFVEC_J
SURFVEC_K
PINVEC_I
PINVEC_J
PINVEC_K
PUNCHVEC_I
PUNCHVEC_J
PUNCHVEC_K
REPORTVEC_I
REPORTVEC_J
REPORTVEC_K
TARGSLOT_I
TARGSLOT_J
TARGSLOT_K
UPDATEVEC_I
UPDATEVEC_J
UPDATEVEC_K
THEO_MINOR_AXIS
TWO_D_THREE_D_TYPE
AXIS
DEST_EXPR
SRC_EXPR
SHOW_IDS
SHOW_DETAILS
WEIGHT
ITEM_USED
USE_AXIS
AVERAGE_ERROR
MEASURE_ALL_FEATURES
REPIERCE_CAD
START_NUM
END_NUM
SKIP_NUM
X_OFFSET
Y_OFFSET
Z_OFFSET
ANGLE_OFFSET
INTERNAL_EXTERNAL
SAVE_ALIGN_CAD_TO_PARTS
FILE_NAME
ALIGN_LIST
WORK_PLANE
DISTANCE
OLD_TIP
NEW_TIP
ROTATION_TYPE
DIM_INFO_ORDER
DIM_INFO_LOC
DIM_INFO_TP_LOC
GRAPH_ANALYSIS
TEXT_ANALYSIS
ARROW_MULTIPLIER
OUTPUT_TYPE
NOMINAL
F_PLUS_TOL
F_MINUS_TOL
TP_MODIFIER
PERP_PARALLEL_TYPE
RADIUS_TYPE
UNIT_TYPE
DIM_LENGTH
PROFILE_FORM_TYPE
PRECISION
MAN_RETRACT
DIM_TEXT
DIM_TEXT_OPTIONS
SHOW_HEADINGS
DEVIATION_SYMBOLS
STANDARD_DEVIATION
DIM_HEADING
GAP_ONLY_TYPE
DISPLAY_ID
DISPLAY_TYPE
POINT_INFO_HEADING
SHOW_POINT_INFO
RET_ONLY_TYPE
COMMENT_FIELD
COMMENT_TYPE
PART_NAME
REVISION_NUMBER
SERIAL_NUMBER
STAT_COUNT
SUB_NAME
READ_WRITE
FILE_POINTER
FIELD_WIDTH
DIGIT_COUNT
LABEL_ID
ERROR_TYPE
ERROR_MODE
DESCRIPTION
INDEX_START
INDEX_END
FILE_COMMAND_TYPE
BUFFER_SIZE_TYPE
FAIL_ON_EXIST
MAX_FORCE
LOW_FORCE
UP_FORCE
TRIGGER_FORCE
PROBE_ACCURACY
POSITIONAL_ACCURACY
NUM_RETURN_DATA
RETURN_SPEED
SCAN_DENSITY
POLAR_VECTOR_COMPENSATION
AUTO_PRINT
ORIGIN
MATERIAL_COEFFICIENT
REF_TEMP
HIGH_THRESHOLD
LOW_THRESHOLD
SENSOR_LIST
FIXTURE_TYPE
MACHINE_TYPE
PROBE_COMP
TIP_I
TIP_J
TIP_K
NORM_RELEARN
FIND_NOMS_TYPE
AUTO_CLEAR_PLANE
SINGLE_POINT
DISPLAY_HITS
CAD_TOLERANCE
OFFSET_TOLERANCE
MIN_INCREMENT
MAX_INCREMENT
MIN_ANGLE
MAX_ANGLE
F_LOCATION
COL132_TYPE
COMMAND_STRING
FLY_MODE_TYPE
STATS_TYPE
STATS_DIR
NEW_STATS_DIR
DATA_READ_LOCK
DATA_WRITE_LOCK
DATA_MEM_PAGES
STAT_NAME_TYPE
STAT_CALC_TYPE
TRANSFER_DIR
DISPLAY_TRACE
TRACE_NAME
TRACE_VALUE
SCAN_CUTPLANEVEC_I
SCAN_CUTPLANEVEC_J
SCAN_CUTPLANEVEC_K
SCAN_INITVEC_I
SCAN_INITVEC_J
SCAN_INITVEC_K
SCAN_AXISVEC_I
SCAN_AXISVEC_J
SCAN_AXISVEC_K
SCAN_ENDVEC_I
SCAN_ENDVEC_J
SCAN_ENDVEC_K
SCAN_INITDIR_I
SCAN_INITDIR_J
SCAN_INITDIR_K
SCAN_CROSS_TOTAL
SCAN_TIME_INCR
SCAN_EDGE_THICK
POS_REPORT_AXIS_X
POS_REPORT_AXIS_Y
POS_REPORT_AXIS_Z
DEV_PERPEN_CENTERLINE
USE_THEO
TARGET_COLOR
THEO_START_ANG
THEO_END_ANG
ONOFF_TYPE
ROW_ID
LOCATOR_BMP
LOCATOR_WAV
DTYPE_LEAPFROGTYPE
DTYPE_LEAPFROGNUMHITS
DTYPE_LEAPFROGFULLPARTIAL
EXCLUSION_ZONE
EXECUTE
AUTOTRIGGERONOFF
AUTOBEEPING
COLUMN_ID
SLOT_NUMBER
AUTOTOLZONE
PROBING_MODE
ANGLE_COMP_TOGGLE
POINTINFO_FILTER_INTERVAL
POINTINFO_FILTER_INTERVAL_NUMBER
FEAT_TYPE
DIM_ID
MEAS_MINOR_AXIS
MEAS_HEIGHT
MEAS_SLOTVEC_I
MEAS_SLOTVEC_J
MEAS_SLOTVEC_K
MEAS_SX
MEAS_SY
MEAS_SZ
MEAS_EX
MEAS_EY
MEAS_EZ
MEAS_WIDTH
NUM_CONTROL_POINTS
U_HITS
V_HITS
NUM_FIT_POINTS
NOMINAL_COLOR
WAVE_FILE
DIM_BONUS
PERUNIT_STEPSIZE
PERUNIT_LENGTH
PERUNIT_WIDTH
DIM_MEASURED
SURFVEC_TARG_I
SURFVEC_TARG_J
SURFVEC_TARG_K
DIM_MAX
EDGEVEC_TARG_I
EDGEVEC_TARG_J
EDGEVEC_TARG_K
DIM_MIN
EDGEVEC_THEO_I
EDGEVEC_THEO_J
EDGEVEC_THEO_K
DIM_DEVIATION
EDGEVEC_MEAS_I
EDGEVEC_MEAS_J
EDGEVEC_MEAS_K
DIM_OUTTOL
T_VALUE
TOOL_X
TOOL_Y
TOOL_Z
TOOL_DIAM
DEV_X
DEV_Y
DEV_Z
DEV_DIAM
ITERATE_COLUMNS
LOAD_TYPE
NUM_ITERATIONS
METHOD_TYPE
SCAN_TECHNIQUE
HIT_TYPE
BOUNDARY_POINT_X
BOUNDARY_POINT_Y
BOUNDARY_POINT_Z
VIDEO_GAIN
VIDEO_OFFSET
VIDEO_LEDLIGHT
VIDEO_LASERLIGHT1
VIDEO_LASERLIGHT2
VIDEO_YORIGIN
VIDEO_YEND
VIDEO_LSEG
VIDEO_XSEG
VIDEO_YSEG
ANGULARITY_NOM_ANGLE
PRINT_TO_FILE
PRINT_TO_PRINTER
PRINT_DRAFTMODE
PRINT_DELETE_RUNS
POINTINFO_FILTER_WORST
POINTINFO_FILTER_WORST_NUMBER
POINTINFO_FILTER_DEVIATION
POINTINFO_FILTER_DEVIATION_NUMBER
POINTINFO_FILTER_OUTTOL
REPORT_SURFVEC_I
REPORT_SURFVEC_J
REPORT_SURFVEC_K
DB_QUERY_OP
DB_SOURCE_NAME
CHART_TYPE
DB_CHART_NAME
DEVIATION_ANGLE
STATS_DATASOURCE
IGNOREMOTIONERRORS_TYPE
THEO_X2
THEO_Y2
THEO_Z2
MEAS_X2
MEAS_Y2
MEAS_Z2
PPROG
TRACE_FILTER
TIME_FILTER
SHOW_SPC_CALCS
SPEC_LIMITS
ZONES
STDDEV
UCL_LCL
HISTOGRAM
GRID
ADDITIONAL_CHART
LINE2_PLANAR_OPEN_IN_X
LINE3_PLANAR_OPEN_IN_X
REGR
CENTER_POINT
SHOW_MORE_SPC_CALCS
SPEC_OFFSET
SOLID
U_L_BOUNDS
TITLE
CPOINT_X
CPOINT_Y
CPOINT_Z
CPOINT_I
CPOINT_J
CPOINT_K
CPOINT_DIAM
CPOINT_SCAN_CROSS_TOTAL
CPOINT_SCAN_DENSITY
CPOINT_F_SCANSPEED
N_CONTROLPOINTS
CPOINT_TYPE
USE_3DFILTER
SCAN_BNDRY_TYPE
CREATE_WEIGHTS
F_SIZE
LINE2_ISPLANAR
LINE2_PLANAR_XTOL
LINE2_PLANAR_YTOL
LINE2_PLANAR_XDEV
LINE2_PLANAR_YDEV
LINE3_ISPLANAR
LINE3_PLANAR_XTOL
LINE3_PLANAR_YTOL
LINE3_PLANAR_XDEV
LINE3_PLANAR_YDEV
CHART_SUB_TYPE
OVERWRITE
OUTPUT_FEATURE_NOMS
OUTPUT_FEAT_W_DIMENS
OUTPUT_DMIS_REPORT
TIME_ARG
TRACE_FILTER_ARG
FIT
STATS_DB_TYPE
IOCHANNEL_NUMBER
IOCHANNEL_PULSE_WIDTH
IOCHANNEL_PULSE_INTERVAL
IOCHANNEL_PULSE_DURATION
GRAPH_OPTION
DB_SOURCE_TYPE
FIND_HOLE_PERCENT
AUTO_ONERROR_TYPE
POS_REPT_DISPLAY_OPTION
TRIGGERTOLERANCE
TRIGGERTOLVALUE
FIXTURE_TOL
START_LABEL
ERROR_LABEL
CONE_CONVEX_TYPE
TRIGGERPLANE
QUERY_SHOW_GRAPHIC_SETTINGS
CALC_STYLE_FILE
FILTER_TYPE
TRACE_VALUE_LIMIT
TARGET_DIRECTION
TARGET_EDGE_POLARITY
BSMETHOD_TYPE
CENTER_ROTATION_THEO
CENTER_ROTATION_MEAS
ARTICULATEDARM_TYPE
LEFTYRIGHTY_CONFIG
ABOVEBELOW_CONFIG
NOFLIPFLIP_CONFIG
HIGH_ACCURACY
SURFACE
MAGNIFICATION
MINOR_WORD_TOGGLE
PERCENTAGE
THRESHOLD
N_SIDES
TARGET_SURFACE_ILLUM
MEAN
CAD_COMP
SHOW_ROW
SHOW_COLUMN
TARGET_SURFACE_SENSILIGHT
TARGET_SURFACE_WIDTH
TARGET_SURFACE_HEIGHT
TARGET_SURFACE_RANGE
TARGET_SURFACE_DURATION
TARGET_SURFACE_MODE
TARGET_SURFACE_HIACC
SCREEN_CAPTURE_SCALE
SCREEN_CAPTURE_QUALITY
TARGET_EDGE_SIZE
TARGET_EDGE_ILLUM
TARGET_EDGE_TOL
TARGET_EDGE_STRENGTH
TARGET_EDGE_DENSITY
TARGET_EDGE_TYPE
DISPLAY_ADVANCED_PARAMETERS
TARGET_SURFACE_TYPE
VOID_DETECT
TARG_SX
TARG_SY
TARG_SZ
TARG_EX
TARG_EY
TARG_EZ
PATTERN_TYPE
TARGET_EDGE_ANGLE
PROGRAM_GAGE_FEAT_TYPE
PROGRAM_GAGE_TYPE
TARGET_FOCUS
RMEASFEATIDX
RMEASFEATIDY
RMEASFEATIDZ
FINDNOMS_BESTFIT
FINDNOMS_ONLYSELECTED
TEMPX
TEMPY
TEMPZ
TEMPP
AUTO_PH9
MANUAL_PREPOSITION
SCREEN_CAPTURE_TYPE
SCREEN_CAPTURE_AUTO_TYPE
TARGET_EDGE_EDGESELECT
TARGET_EDGE_EDGENUM
DELETE_TYPE
SCREEN_CAPTURE_AUTO_TIME
USE_HSSDAT
USE_STARTENDDELAY
COP_FILTER
COP_SIZE
COP_TYPE
SURFVEC_MEAS_I
SURFVEC_MEAS_J
SURFVEC_MEAS_K
TARGET_EDGE_UNDERSCAN
PROFILE_TYPE
THEO_FLUSH
MEAS_FLUSH
THEO_GAP
MEAS_GAP
THEO_DEPTH
MEAS_DEPTH
TARGET_BLOB_TYPE
LASER_STRIPE_OVERLAP
LASER_STRIPE_OVERSCAN
LASER_FREQUENCY
TARGET_FILTER_OUTLIER
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD
SLOT_TYPE
TARGET_TYPE
THEO_R
THEO_A
THEO_H
MEAS_R
MEAS_A
MEAS_H
TARG_R
TARG_A
TARG_H
THEO_SR
THEO_SA
THEO_SH
THEO_ER
THEO_EA
THEO_EH
MEAS_SR
MEAS_SA
MEAS_SH
MEAS_ER
MEAS_EA
MEAS_EH
TARG_SR
TARG_SA
TARG_SH
TARG_ER
TARG_EA
TARG_EH
TARGET_EDGE_SENSILIGHT
F_THICKNESS_EDGE
THICKNESS_TYPE_EDGE
LASER_EXPOSURE
LASER_INTENSITY
ANGLE_OFFSET_2
LASER_FILTER_NEIGHBOR_NUM
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD
LASER_FILTER_TOL_ABOVE
LASER_FILTER_TOL_BELOW
LASER_FILTER_TOL_RIGHT
LASER_CLIP_UP_DIST
LASER_CLIP_LOW_DIST
LASER_PIXEL_TOGGLE
LASER_FILTER_TOGGLE
DISPLAY_PROBE_PARAMETERS
THEO_R2
THEO_A2
THEO_H2
MEAS_R2
MEAS_A2
MEAS_H2
LASER_CLIP_LEFT_DIST
LASER_CLIP_RIGHT_DIST
COP_FILETYPE
COP_SELECTIONTYPE
COP_COLORMAP
COP_COPLEMENT
OPERTYPE
COP_BOOLEANTYPE
COP_IMPORTFILETYPE
MEAS_START_ANG
MEAS_END_ANG
ISLAND_DIAM
ISLAND_LENGTH
ISLAND_WIDTH
ISLAND_X
ISLAND_Y
ISLAND_Z
ISLAND_I
ISLAND_J
ISLAND_K
ISLAND_AI
ISLAND_AJ
ISLAND_AK
ISLAND_TYPE
ISLAND_CLEARANCEDIST
RPT_DIMENSION_TABLES
SUMMARY_DEV
DRF_TBLHDR
LINE1_TBLHDR
LINE1_CALLOUT
LINE1_COLUMN_HDR
LINE1_FEATNAME
LINE1_NOMINAL
LINE1_MEAS
LINE1_PLUSTOL
LINE1_MINUSTOL
LINE1_DEV
LINE1_DEVPERCENT
LINE1_ISBILATERAL
LINE1_NUMZONES
LINE2_TBLHDR
LINE2_CALLOUT
LINE2_COLUMN_HDR
LINE2_FEATNAME
LINE2_BONUS
LINE2_TOL
LINE2_DATUMSHFT
LINE2_UNUSEDZONE
LINE2_DEV
LINE2_DEVANG
LINE2_DEVPERCENT
LINE3_TBLHDR
LINE3_CALLOUT
LINE3_COLUMN_HDR
LINE3_FEATNAME
LINE3_BONUS
LINE3_TOL
LINE3_DATUMSHFT
LINE3_UNUSEDZONE
LINE3_DEV
LINE3_DEVANG
LINE3_DEVPERCENT
DRF_COLUMN_HDR
DRF_SEGNAME
DRF_SHIFTX
DRF_SHIFTY
DRF_SHIFTZ
DRF_ROTATIONX
DRF_ROTATIONY
DRF_ROTATIONZ
SUMMARY_COLUMN_HDR
SUMMARY_FEAT
LINE2_AXIS
LINE2_NOMINAL
LINE2_MEAS
SUMMARY_TBLHDR
SUMMARY_AXIS
SUMMARY_NOMINAL
SUMMARY_MEAS
LINE2_PLUSTOL
LINE2_MINUSTOL
LINE2_MAX
LINE2_MIN
LINE2_ISBILATERAL
LINE2_NUMZONES
LINE3_ISBILATERAL
LINE3_NUMZONES
DIM_RPT_COLUMN_HDR
DIM_RPT_ISDATUM
DIM_RPT_DATUM
DIM_RPT_GRAPHIC
DIM_RPT_DEVPERCENT
DIM_RPT_ISBILATERAL
DIM_RPT_NUMZONES
GDT_SYMBOL
COMMENT_INPUT
TARGET_EDGE_WIDTH
TARGET_EDGE_HEIGHT
TARGET_EDGE_EDGEDETECT
TARGET_EDGE_FILTER_CLEAN
TARGET_EDGE_FILTER_CLEAN_STRENGTH
TARGET_EDGE_FILTER_AREA
TARGET_EDGE_FILTER_AREA_SIZE
TARGET_EDGE_GRADIENT
THEO_PERIMETER
MEAS_PERIMETER
THEO_AREA
MEAS_AREA
TARGET_SURFACE_CROSSHAIR_HEIGHT
SHOW_NOMS
COMPOSITE
DATUM2
TP_MODIFIER2
DESCRIPTION2
SHOW_OPTIONS
LEADER_LINE_ID
GDT_SYMBOL2
DATUM1_MODIFIER
DATUM2_MODIFIER
DATUM3_MODIFIER
DATUM1_MODIFIER2
DATUM2_MODIFIER2
DATUM3_MODIFIER2
DIM_RPT_DEVPERCENT_NOM
DIM_RPT_USETWODEVIATIONS
DIM_RPT_DEVPERCENT2
LINE2_DEVPERCENT_NOM
LINE2_USE2DEVIATIONS
LINE2_DEVPERCENT2
LINE3_DEVPERCENT_NOM
LINE3_USE2DEVIATIONS
LINE3_DEVPERCENT2
AXIS_PLUS_TOL
AXIS_MINUS_TOL
AXIS_NOMINAL
AXIS_DESCRIPTION
LINE1_DEVPERCENT_NOM
LINE1_USE2DEVIATIONS
LINE1_DEVPERCENT2
USE_AXIS2
DIM_LENGTH2
TEXTANAL_LABEL_MEAS_X
TEXTANAL_LABEL_MEAS_Y
TEXTANAL_LABEL_MEAS_Z
TEXTANAL_LABEL_MEAS_I
TEXTANAL_LABEL_MEAS_J
TEXTANAL_LABEL_MEAS_K
TEXTANAL_LABEL_DEV
TEXTANAL_LABEL_MINMAX
SIMULT_EVAL
SECTION_INDEX
LINE1_OUTTOL
LINE2_OUTTOL
LINE3_OUTTOL
LINE1_MAX
LINE1_MIN
LINE3_NOMINAL
LINE3_MEAS
LINE3_PLUSTOL
LINE3_MINUSTOL
LINE3_MAX
LINE3_MIN
SUMMARY_OUTTOL
SUMMARY_PLUSTOL
SUMMARY_MINUSTOL
SUMMARY_MAX
SUMMARY_MIN
SUMMARY_BONUS
LINE1_BONUS
GRAPH_ANALYSIS_POINT_SIZE
GRAPH_ANALYSIS_PLUS_TOL
GRAPH_ANALYSIS_MINUS_TOL
DIM_AXIS_ITEM_NUMBER
F_ENDING_DEPTH
DIM_ITEM_NUMBER
FEAT_ITEM_NUMBER
COMMAND_TYPE
DEV_MAX
AUTO_DEV_DIRECTION
PROBE_DIRECTION
USER_DEFINED_THEOS
SCALING
USE_SCALING
UID
REF_UID
BA_SOLUTION_TYPE
BA_SOLUTION_OPTIONS
BA_SOLUTION_STATUS
BA_VARIANCE
BA_RMS
BA_WARNINGS
BA_STATION
BA_STATION_X
BA_STATION_Y
BA_STATION_Z
BA_STATION_ROTX
BA_STATION_ROTY
BA_STATION_ROTZ
BA_STATION_ORIENTED
BA_STATION_LOCKED
BA_FEATURE
BA_FEAT_SOURCE
BA_FEAT_RMS
BA_FEAT_POINTING_ERR
BA_FEAT_APEX_ANGLE
BA_FEAT_X
BA_FEAT_Y
BA_FEAT_Z
BA_FEAT_DEV_X
BA_FEAT_DEV_Y
BA_FEAT_DEV_Z
BA_FEAT_DEV3D
NO_APPROACH_VECTOR_FLIP
TARGET_EDGE_START_VALUE
TARGET_EDGE_END_VALUE
TARGET_SURFACE_SURFACE_VARIANCE
RELATIVE_COMMENTS
AUTO_ROTARY
TARGET_COVERAGE
ROTATION_TYPE_2
PROBE_TYPE
TIME_STAMP
ECOND_TEMP
ECOND_PRESSURE
ECOND_HUMIDITY
HIT_RMS
DISPLAY_TRACKER_PARAMETERS
PTDENSITY_TOGGLE
PTDENSITY_UPPERBOUND
PTDENSITY_DEVLIMIT
PTDENSITY_MAXSPAN
TARGET_MEASURE_AT_FOV_CENTER
TARGET_SURFACE_FIND_SURFACE
PROJECTOR
INLINE_LEGACY_REPORT
SINGLE_POINT_DEVIATION
Used to indicate the field from which the text is being retrieved. Type ENUM_FIELD_TYPES enumeration.
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a field type.

Return Type

String value containing the text of the given field.

Remarks

Use this command to get text that is displayed in the edit window for different object fields. The ENUM_FIELD_TYPES enumeration is a large enumeration. Documentation for which field types go with which objects is not given here. You can find this information by creating the desired object in PC-DMIS, inserting the desired expression in the desired field, and exporting (posting out) the containing part program to BASIC.

See Also

Command Object | PutText Method | GetExpression Method


GetToggleString Method

GetToggleString Method
DataType
Used to indicate the field from which the text is being retrieved. Type ENUM_FIELD_TYPES enumeration.
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a field type.

Description

Returns the toggle text delimited by the | symbol if the field is a toggle field, otherwise returns an empty string. Returns the string of text of a toggle field.

Syntax

Visual Basic
Public Function GetToggleString( _
   ByVal DataType As ENUM_FIELD_TYPES, _
   ByVal TypeIndex As Long _
) As String

Parameters

DataType
Value Description
ID
REF_ID
LEVEL_REF_ID
ROTATE_REF_ID
ORIGIN_REF_ID
THEO_X
THEO_Y
THEO_Z
THEO_SX
THEO_SY
THEO_SZ
THEO_EX
THEO_EY
THEO_EZ
THEO_I
THEO_J
THEO_K
TARG_X
TARG_Y
TARG_Z
MEAS_X
MEAS_Y
MEAS_Z
MEAS_I
MEAS_J
MEAS_K
MEAS_LENGTH
MEAS_DIAM
MEAS_ANGLE
TARG_I
TARG_J
TARG_K
THEO_DIAM
THEO_WIDTH
THEO_LENGTH
THEO_HEIGHT
THEO_ANGLE
COORD_TYPE
INOUT_TYPE
THICKNESS_TYPE
CIRC_TYPE
SNAP_TYPE
USEPIN_TYPE
MOVE_TYPE
READPOS_TYPE
FINDHOLE_TYPE
RMEAS_TYPE
THEOBF_TYPE
BOUND_TYPE
BF_MATH_TYPE
AUTOFIT_CONSTRAINT
SLOT_MIN_MAX_TYPE
FIND_NOM_AXIS_TYPE
N_INIT_HITS_TYPE
N_PERM_HITS_TYPE
SEARCHMODE_TYPE
MODE_TYPE
MEASURE_ORDER_TYPE
CONE_LENGTH_ANGLE_TYPE
OFFSET_LINE_METHOD
LIN_POL_FILT_TYPE
GEN_FEAT_TYPE
GEN_ALIGN_TYPE
CURVE_TYPE
MEASURED_2D3D_TYPE
THINNING_TOL
HITINT_TYPE
RMEASFEATID
N_HITS
N_ROWS
INIT_HITS
PERM_HITS
F_OFFSET
F_SPACER
F_PITCH
F_THICKNESS
F_DEPTH
F_AUTOMOVE
F_INDENT
F_CORNER_RADIUS
F_INCREMENT
F_TOLERANCE
F_BOXWIDTH
F_BOXLENGTH
F_CIRCRADOUT
F_CIRCRADIN
F_CHECK
F_MAXACCELX
F_MAXACCELY
F_MAXACCELZ
SCAN_ACCELERATION
SCAN_OFFSET_FORCE
MANUAL_FINE_PROBING
F_MOVESPEED
F_TOUCHSPEED
F_SCANSPEED
START_ANG
END_ANG
MIDPOINT_X
MIDPOINT_Y
MIDPOINT_Z
ANGVEC_I
ANGVEC_J
ANGVEC_K
MEASVEC_I
MEASVEC_J
MEASVEC_K
SLOTVEC_I
SLOTVEC_J
SLOTVEC_K
SURFVEC_I
SURFVEC_J
SURFVEC_K
PINVEC_I
PINVEC_J
PINVEC_K
PUNCHVEC_I
PUNCHVEC_J
PUNCHVEC_K
REPORTVEC_I
REPORTVEC_J
REPORTVEC_K
TARGSLOT_I
TARGSLOT_J
TARGSLOT_K
UPDATEVEC_I
UPDATEVEC_J
UPDATEVEC_K
THEO_MINOR_AXIS
TWO_D_THREE_D_TYPE
AXIS
DEST_EXPR
SRC_EXPR
SHOW_IDS
SHOW_DETAILS
WEIGHT
ITEM_USED
USE_AXIS
AVERAGE_ERROR
MEASURE_ALL_FEATURES
REPIERCE_CAD
START_NUM
END_NUM
SKIP_NUM
X_OFFSET
Y_OFFSET
Z_OFFSET
ANGLE_OFFSET
INTERNAL_EXTERNAL
SAVE_ALIGN_CAD_TO_PARTS
FILE_NAME
ALIGN_LIST
WORK_PLANE
DISTANCE
OLD_TIP
NEW_TIP
ROTATION_TYPE
DIM_INFO_ORDER
DIM_INFO_LOC
DIM_INFO_TP_LOC
GRAPH_ANALYSIS
TEXT_ANALYSIS
ARROW_MULTIPLIER
OUTPUT_TYPE
NOMINAL
F_PLUS_TOL
F_MINUS_TOL
TP_MODIFIER
PERP_PARALLEL_TYPE
RADIUS_TYPE
UNIT_TYPE
DIM_LENGTH
PROFILE_FORM_TYPE
PRECISION
MAN_RETRACT
DIM_TEXT
DIM_TEXT_OPTIONS
SHOW_HEADINGS
DEVIATION_SYMBOLS
STANDARD_DEVIATION
DIM_HEADING
GAP_ONLY_TYPE
DISPLAY_ID
DISPLAY_TYPE
POINT_INFO_HEADING
SHOW_POINT_INFO
RET_ONLY_TYPE
COMMENT_FIELD
COMMENT_TYPE
PART_NAME
REVISION_NUMBER
SERIAL_NUMBER
STAT_COUNT
SUB_NAME
READ_WRITE
FILE_POINTER
FIELD_WIDTH
DIGIT_COUNT
LABEL_ID
ERROR_TYPE
ERROR_MODE
DESCRIPTION
INDEX_START
INDEX_END
FILE_COMMAND_TYPE
BUFFER_SIZE_TYPE
FAIL_ON_EXIST
MAX_FORCE
LOW_FORCE
UP_FORCE
TRIGGER_FORCE
PROBE_ACCURACY
POSITIONAL_ACCURACY
NUM_RETURN_DATA
RETURN_SPEED
SCAN_DENSITY
POLAR_VECTOR_COMPENSATION
AUTO_PRINT
ORIGIN
MATERIAL_COEFFICIENT
REF_TEMP
HIGH_THRESHOLD
LOW_THRESHOLD
SENSOR_LIST
FIXTURE_TYPE
MACHINE_TYPE
PROBE_COMP
TIP_I
TIP_J
TIP_K
NORM_RELEARN
FIND_NOMS_TYPE
AUTO_CLEAR_PLANE
SINGLE_POINT
DISPLAY_HITS
CAD_TOLERANCE
OFFSET_TOLERANCE
MIN_INCREMENT
MAX_INCREMENT
MIN_ANGLE
MAX_ANGLE
F_LOCATION
COL132_TYPE
COMMAND_STRING
FLY_MODE_TYPE
STATS_TYPE
STATS_DIR
NEW_STATS_DIR
DATA_READ_LOCK
DATA_WRITE_LOCK
DATA_MEM_PAGES
STAT_NAME_TYPE
STAT_CALC_TYPE
TRANSFER_DIR
DISPLAY_TRACE
TRACE_NAME
TRACE_VALUE
SCAN_CUTPLANEVEC_I
SCAN_CUTPLANEVEC_J
SCAN_CUTPLANEVEC_K
SCAN_INITVEC_I
SCAN_INITVEC_J
SCAN_INITVEC_K
SCAN_AXISVEC_I
SCAN_AXISVEC_J
SCAN_AXISVEC_K
SCAN_ENDVEC_I
SCAN_ENDVEC_J
SCAN_ENDVEC_K
SCAN_INITDIR_I
SCAN_INITDIR_J
SCAN_INITDIR_K
SCAN_CROSS_TOTAL
SCAN_TIME_INCR
SCAN_EDGE_THICK
POS_REPORT_AXIS_X
POS_REPORT_AXIS_Y
POS_REPORT_AXIS_Z
DEV_PERPEN_CENTERLINE
USE_THEO
TARGET_COLOR
THEO_START_ANG
THEO_END_ANG
ONOFF_TYPE
ROW_ID
LOCATOR_BMP
LOCATOR_WAV
DTYPE_LEAPFROGTYPE
DTYPE_LEAPFROGNUMHITS
DTYPE_LEAPFROGFULLPARTIAL
EXCLUSION_ZONE
EXECUTE
AUTOTRIGGERONOFF
AUTOBEEPING
COLUMN_ID
SLOT_NUMBER
AUTOTOLZONE
PROBING_MODE
ANGLE_COMP_TOGGLE
POINTINFO_FILTER_INTERVAL
POINTINFO_FILTER_INTERVAL_NUMBER
FEAT_TYPE
DIM_ID
MEAS_MINOR_AXIS
MEAS_HEIGHT
MEAS_SLOTVEC_I
MEAS_SLOTVEC_J
MEAS_SLOTVEC_K
MEAS_SX
MEAS_SY
MEAS_SZ
MEAS_EX
MEAS_EY
MEAS_EZ
MEAS_WIDTH
NUM_CONTROL_POINTS
U_HITS
V_HITS
NUM_FIT_POINTS
NOMINAL_COLOR
WAVE_FILE
DIM_BONUS
PERUNIT_STEPSIZE
PERUNIT_LENGTH
PERUNIT_WIDTH
DIM_MEASURED
SURFVEC_TARG_I
SURFVEC_TARG_J
SURFVEC_TARG_K
DIM_MAX
EDGEVEC_TARG_I
EDGEVEC_TARG_J
EDGEVEC_TARG_K
DIM_MIN
EDGEVEC_THEO_I
EDGEVEC_THEO_J
EDGEVEC_THEO_K
DIM_DEVIATION
EDGEVEC_MEAS_I
EDGEVEC_MEAS_J
EDGEVEC_MEAS_K
DIM_OUTTOL
T_VALUE
TOOL_X
TOOL_Y
TOOL_Z
TOOL_DIAM
DEV_X
DEV_Y
DEV_Z
DEV_DIAM
ITERATE_COLUMNS
LOAD_TYPE
NUM_ITERATIONS
METHOD_TYPE
SCAN_TECHNIQUE
HIT_TYPE
BOUNDARY_POINT_X
BOUNDARY_POINT_Y
BOUNDARY_POINT_Z
VIDEO_GAIN
VIDEO_OFFSET
VIDEO_LEDLIGHT
VIDEO_LASERLIGHT1
VIDEO_LASERLIGHT2
VIDEO_YORIGIN
VIDEO_YEND
VIDEO_LSEG
VIDEO_XSEG
VIDEO_YSEG
ANGULARITY_NOM_ANGLE
PRINT_TO_FILE
PRINT_TO_PRINTER
PRINT_DRAFTMODE
PRINT_DELETE_RUNS
POINTINFO_FILTER_WORST
POINTINFO_FILTER_WORST_NUMBER
POINTINFO_FILTER_DEVIATION
POINTINFO_FILTER_DEVIATION_NUMBER
POINTINFO_FILTER_OUTTOL
REPORT_SURFVEC_I
REPORT_SURFVEC_J
REPORT_SURFVEC_K
DB_QUERY_OP
DB_SOURCE_NAME
CHART_TYPE
DB_CHART_NAME
DEVIATION_ANGLE
STATS_DATASOURCE
IGNOREMOTIONERRORS_TYPE
THEO_X2
THEO_Y2
THEO_Z2
MEAS_X2
MEAS_Y2
MEAS_Z2
PPROG
TRACE_FILTER
TIME_FILTER
SHOW_SPC_CALCS
SPEC_LIMITS
ZONES
STDDEV
UCL_LCL
HISTOGRAM
GRID
ADDITIONAL_CHART
LINE2_PLANAR_OPEN_IN_X
LINE3_PLANAR_OPEN_IN_X
REGR
CENTER_POINT
SHOW_MORE_SPC_CALCS
SPEC_OFFSET
SOLID
U_L_BOUNDS
TITLE
CPOINT_X
CPOINT_Y
CPOINT_Z
CPOINT_I
CPOINT_J
CPOINT_K
CPOINT_DIAM
CPOINT_SCAN_CROSS_TOTAL
CPOINT_SCAN_DENSITY
CPOINT_F_SCANSPEED
N_CONTROLPOINTS
CPOINT_TYPE
USE_3DFILTER
SCAN_BNDRY_TYPE
CREATE_WEIGHTS
F_SIZE
LINE2_ISPLANAR
LINE2_PLANAR_XTOL
LINE2_PLANAR_YTOL
LINE2_PLANAR_XDEV
LINE2_PLANAR_YDEV
LINE3_ISPLANAR
LINE3_PLANAR_XTOL
LINE3_PLANAR_YTOL
LINE3_PLANAR_XDEV
LINE3_PLANAR_YDEV
CHART_SUB_TYPE
OVERWRITE
OUTPUT_FEATURE_NOMS
OUTPUT_FEAT_W_DIMENS
OUTPUT_DMIS_REPORT
TIME_ARG
TRACE_FILTER_ARG
FIT
STATS_DB_TYPE
IOCHANNEL_NUMBER
IOCHANNEL_PULSE_WIDTH
IOCHANNEL_PULSE_INTERVAL
IOCHANNEL_PULSE_DURATION
GRAPH_OPTION
DB_SOURCE_TYPE
FIND_HOLE_PERCENT
AUTO_ONERROR_TYPE
POS_REPT_DISPLAY_OPTION
TRIGGERTOLERANCE
TRIGGERTOLVALUE
FIXTURE_TOL
START_LABEL
ERROR_LABEL
CONE_CONVEX_TYPE
TRIGGERPLANE
QUERY_SHOW_GRAPHIC_SETTINGS
CALC_STYLE_FILE
FILTER_TYPE
TRACE_VALUE_LIMIT
TARGET_DIRECTION
TARGET_EDGE_POLARITY
BSMETHOD_TYPE
CENTER_ROTATION_THEO
CENTER_ROTATION_MEAS
ARTICULATEDARM_TYPE
LEFTYRIGHTY_CONFIG
ABOVEBELOW_CONFIG
NOFLIPFLIP_CONFIG
HIGH_ACCURACY
SURFACE
MAGNIFICATION
MINOR_WORD_TOGGLE
PERCENTAGE
THRESHOLD
N_SIDES
TARGET_SURFACE_ILLUM
MEAN
CAD_COMP
SHOW_ROW
SHOW_COLUMN
TARGET_SURFACE_SENSILIGHT
TARGET_SURFACE_WIDTH
TARGET_SURFACE_HEIGHT
TARGET_SURFACE_RANGE
TARGET_SURFACE_DURATION
TARGET_SURFACE_MODE
TARGET_SURFACE_HIACC
SCREEN_CAPTURE_SCALE
SCREEN_CAPTURE_QUALITY
TARGET_EDGE_SIZE
TARGET_EDGE_ILLUM
TARGET_EDGE_TOL
TARGET_EDGE_STRENGTH
TARGET_EDGE_DENSITY
TARGET_EDGE_TYPE
DISPLAY_ADVANCED_PARAMETERS
TARGET_SURFACE_TYPE
VOID_DETECT
TARG_SX
TARG_SY
TARG_SZ
TARG_EX
TARG_EY
TARG_EZ
PATTERN_TYPE
TARGET_EDGE_ANGLE
PROGRAM_GAGE_FEAT_TYPE
PROGRAM_GAGE_TYPE
TARGET_FOCUS
RMEASFEATIDX
RMEASFEATIDY
RMEASFEATIDZ
FINDNOMS_BESTFIT
FINDNOMS_ONLYSELECTED
TEMPX
TEMPY
TEMPZ
TEMPP
AUTO_PH9
MANUAL_PREPOSITION
SCREEN_CAPTURE_TYPE
SCREEN_CAPTURE_AUTO_TYPE
TARGET_EDGE_EDGESELECT
TARGET_EDGE_EDGENUM
DELETE_TYPE
SCREEN_CAPTURE_AUTO_TIME
USE_HSSDAT
USE_STARTENDDELAY
COP_FILTER
COP_SIZE
COP_TYPE
SURFVEC_MEAS_I
SURFVEC_MEAS_J
SURFVEC_MEAS_K
TARGET_EDGE_UNDERSCAN
PROFILE_TYPE
THEO_FLUSH
MEAS_FLUSH
THEO_GAP
MEAS_GAP
THEO_DEPTH
MEAS_DEPTH
TARGET_BLOB_TYPE
LASER_STRIPE_OVERLAP
LASER_STRIPE_OVERSCAN
LASER_FREQUENCY
TARGET_FILTER_OUTLIER
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD
SLOT_TYPE
TARGET_TYPE
THEO_R
THEO_A
THEO_H
MEAS_R
MEAS_A
MEAS_H
TARG_R
TARG_A
TARG_H
THEO_SR
THEO_SA
THEO_SH
THEO_ER
THEO_EA
THEO_EH
MEAS_SR
MEAS_SA
MEAS_SH
MEAS_ER
MEAS_EA
MEAS_EH
TARG_SR
TARG_SA
TARG_SH
TARG_ER
TARG_EA
TARG_EH
TARGET_EDGE_SENSILIGHT
F_THICKNESS_EDGE
THICKNESS_TYPE_EDGE
LASER_EXPOSURE
LASER_INTENSITY
ANGLE_OFFSET_2
LASER_FILTER_NEIGHBOR_NUM
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD
LASER_FILTER_TOL_ABOVE
LASER_FILTER_TOL_BELOW
LASER_FILTER_TOL_RIGHT
LASER_CLIP_UP_DIST
LASER_CLIP_LOW_DIST
LASER_PIXEL_TOGGLE
LASER_FILTER_TOGGLE
DISPLAY_PROBE_PARAMETERS
THEO_R2
THEO_A2
THEO_H2
MEAS_R2
MEAS_A2
MEAS_H2
LASER_CLIP_LEFT_DIST
LASER_CLIP_RIGHT_DIST
COP_FILETYPE
COP_SELECTIONTYPE
COP_COLORMAP
COP_COPLEMENT
OPERTYPE
COP_BOOLEANTYPE
COP_IMPORTFILETYPE
MEAS_START_ANG
MEAS_END_ANG
ISLAND_DIAM
ISLAND_LENGTH
ISLAND_WIDTH
ISLAND_X
ISLAND_Y
ISLAND_Z
ISLAND_I
ISLAND_J
ISLAND_K
ISLAND_AI
ISLAND_AJ
ISLAND_AK
ISLAND_TYPE
ISLAND_CLEARANCEDIST
RPT_DIMENSION_TABLES
SUMMARY_DEV
DRF_TBLHDR
LINE1_TBLHDR
LINE1_CALLOUT
LINE1_COLUMN_HDR
LINE1_FEATNAME
LINE1_NOMINAL
LINE1_MEAS
LINE1_PLUSTOL
LINE1_MINUSTOL
LINE1_DEV
LINE1_DEVPERCENT
LINE1_ISBILATERAL
LINE1_NUMZONES
LINE2_TBLHDR
LINE2_CALLOUT
LINE2_COLUMN_HDR
LINE2_FEATNAME
LINE2_BONUS
LINE2_TOL
LINE2_DATUMSHFT
LINE2_UNUSEDZONE
LINE2_DEV
LINE2_DEVANG
LINE2_DEVPERCENT
LINE3_TBLHDR
LINE3_CALLOUT
LINE3_COLUMN_HDR
LINE3_FEATNAME
LINE3_BONUS
LINE3_TOL
LINE3_DATUMSHFT
LINE3_UNUSEDZONE
LINE3_DEV
LINE3_DEVANG
LINE3_DEVPERCENT
DRF_COLUMN_HDR
DRF_SEGNAME
DRF_SHIFTX
DRF_SHIFTY
DRF_SHIFTZ
DRF_ROTATIONX
DRF_ROTATIONY
DRF_ROTATIONZ
SUMMARY_COLUMN_HDR
SUMMARY_FEAT
LINE2_AXIS
LINE2_NOMINAL
LINE2_MEAS
SUMMARY_TBLHDR
SUMMARY_AXIS
SUMMARY_NOMINAL
SUMMARY_MEAS
LINE2_PLUSTOL
LINE2_MINUSTOL
LINE2_MAX
LINE2_MIN
LINE2_ISBILATERAL
LINE2_NUMZONES
LINE3_ISBILATERAL
LINE3_NUMZONES
DIM_RPT_COLUMN_HDR
DIM_RPT_ISDATUM
DIM_RPT_DATUM
DIM_RPT_GRAPHIC
DIM_RPT_DEVPERCENT
DIM_RPT_ISBILATERAL
DIM_RPT_NUMZONES
GDT_SYMBOL
COMMENT_INPUT
TARGET_EDGE_WIDTH
TARGET_EDGE_HEIGHT
TARGET_EDGE_EDGEDETECT
TARGET_EDGE_FILTER_CLEAN
TARGET_EDGE_FILTER_CLEAN_STRENGTH
TARGET_EDGE_FILTER_AREA
TARGET_EDGE_FILTER_AREA_SIZE
TARGET_EDGE_GRADIENT
THEO_PERIMETER
MEAS_PERIMETER
THEO_AREA
MEAS_AREA
TARGET_SURFACE_CROSSHAIR_HEIGHT
SHOW_NOMS
COMPOSITE
DATUM2
TP_MODIFIER2
DESCRIPTION2
SHOW_OPTIONS
LEADER_LINE_ID
GDT_SYMBOL2
DATUM1_MODIFIER
DATUM2_MODIFIER
DATUM3_MODIFIER
DATUM1_MODIFIER2
DATUM2_MODIFIER2
DATUM3_MODIFIER2
DIM_RPT_DEVPERCENT_NOM
DIM_RPT_USETWODEVIATIONS
DIM_RPT_DEVPERCENT2
LINE2_DEVPERCENT_NOM
LINE2_USE2DEVIATIONS
LINE2_DEVPERCENT2
LINE3_DEVPERCENT_NOM
LINE3_USE2DEVIATIONS
LINE3_DEVPERCENT2
AXIS_PLUS_TOL
AXIS_MINUS_TOL
AXIS_NOMINAL
AXIS_DESCRIPTION
LINE1_DEVPERCENT_NOM
LINE1_USE2DEVIATIONS
LINE1_DEVPERCENT2
USE_AXIS2
DIM_LENGTH2
TEXTANAL_LABEL_MEAS_X
TEXTANAL_LABEL_MEAS_Y
TEXTANAL_LABEL_MEAS_Z
TEXTANAL_LABEL_MEAS_I
TEXTANAL_LABEL_MEAS_J
TEXTANAL_LABEL_MEAS_K
TEXTANAL_LABEL_DEV
TEXTANAL_LABEL_MINMAX
SIMULT_EVAL
SECTION_INDEX
LINE1_OUTTOL
LINE2_OUTTOL
LINE3_OUTTOL
LINE1_MAX
LINE1_MIN
LINE3_NOMINAL
LINE3_MEAS
LINE3_PLUSTOL
LINE3_MINUSTOL
LINE3_MAX
LINE3_MIN
SUMMARY_OUTTOL
SUMMARY_PLUSTOL
SUMMARY_MINUSTOL
SUMMARY_MAX
SUMMARY_MIN
SUMMARY_BONUS
LINE1_BONUS
GRAPH_ANALYSIS_POINT_SIZE
GRAPH_ANALYSIS_PLUS_TOL
GRAPH_ANALYSIS_MINUS_TOL
DIM_AXIS_ITEM_NUMBER
F_ENDING_DEPTH
DIM_ITEM_NUMBER
FEAT_ITEM_NUMBER
COMMAND_TYPE
DEV_MAX
AUTO_DEV_DIRECTION
PROBE_DIRECTION
USER_DEFINED_THEOS
SCALING
USE_SCALING
UID
REF_UID
BA_SOLUTION_TYPE
BA_SOLUTION_OPTIONS
BA_SOLUTION_STATUS
BA_VARIANCE
BA_RMS
BA_WARNINGS
BA_STATION
BA_STATION_X
BA_STATION_Y
BA_STATION_Z
BA_STATION_ROTX
BA_STATION_ROTY
BA_STATION_ROTZ
BA_STATION_ORIENTED
BA_STATION_LOCKED
BA_FEATURE
BA_FEAT_SOURCE
BA_FEAT_RMS
BA_FEAT_POINTING_ERR
BA_FEAT_APEX_ANGLE
BA_FEAT_X
BA_FEAT_Y
BA_FEAT_Z
BA_FEAT_DEV_X
BA_FEAT_DEV_Y
BA_FEAT_DEV_Z
BA_FEAT_DEV3D
NO_APPROACH_VECTOR_FLIP
TARGET_EDGE_START_VALUE
TARGET_EDGE_END_VALUE
TARGET_SURFACE_SURFACE_VARIANCE
RELATIVE_COMMENTS
AUTO_ROTARY
TARGET_COVERAGE
ROTATION_TYPE_2
PROBE_TYPE
TIME_STAMP
ECOND_TEMP
ECOND_PRESSURE
ECOND_HUMIDITY
HIT_RMS
DISPLAY_TRACKER_PARAMETERS
PTDENSITY_TOGGLE
PTDENSITY_UPPERBOUND
PTDENSITY_DEVLIMIT
PTDENSITY_MAXSPAN
TARGET_MEASURE_AT_FOV_CENTER
TARGET_SURFACE_FIND_SURFACE
PROJECTOR
INLINE_LEGACY_REPORT
SINGLE_POINT_DEVIATION
Used to indicate the field from which the text is being retrieved. Type ENUM_FIELD_TYPES enumeration.
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a field type.

Return Type

String value containing text from the field if the field is a toggle field, otherwise it returns an empty string.

See Also

Command Object


GetUniqueID Method

GetUniqueID Method
HiPart
Long value used to indicate the high part of the 64-bit unique id of the command.
LoPart
Long value used to indicate the low part of the 64-bit unique id of the command.

Description

Retrieves the low and high parts of the 64-bit unique id of the command This command retrieves the low and high parts of the 64-bit unique id of the command.

Syntax

Visual Basic
Public Sub GetUniqueID( _
   ByRef HiPart As Long, _
   ByRef LoPart As Long _
)

Parameters

HiPart
Long value used to indicate the high part of the 64-bit unique id of the command.
LoPart
Long value used to indicate the low part of the 64-bit unique id of the command.

Return Type

None

See Also

Command Object


IsExpressionValid Method

IsExpressionValid Method
Expression
Required String that is the expression to evaluate for validity.

Description

Returns true if expression is a valid PC-Dmis expression. Determines whether or not an expression is valid.

Syntax

Visual Basic
Public Function IsExpressionValid( _
   ByVal Expression As String _
) As Boolean

Parameters

Expression
Required String that is the expression to evaluate for validity.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

Command Object


Item Method

Item Method
Num
Required Long that indicates which Command object to return. It is the index number of the execution in the current or previous execution

Description

Returns the execute instance of the object if the object has been executed more than once

Syntax

Visual Basic
Public Function Item( _
   ByVal Num As Long _
) As Command

Parameters

Num
Required Long that indicates which Command object to return. It is the index number of the execution in the current or previous execution

Return Type

Command object.

See Also

Command Object


Mark Method

Mark Method

Description

Marks current command and dependencies or unmarks command. Marks the current object and all objects that depend on it. Optionally the features of the current alignment are also marked.

Syntax

Visual Basic
Public Sub Mark()

Remarks

If the object is a measured feature, its hits are marked. If the object is a constructed feature, the features on which it depends are marked. If the object is a dimension, the dimension feature(s) being dimensioned are marked.

See Also

Command Object


Next Method

Next Method

Description

Changes current command object to point to the next command object in the collection Accesses the next command in the parent Commands list.

Syntax

Visual Basic
Public Function Next() As Boolean

Return Type

Boolean value. This function returns FALSE if it is the last command in the parent Commands list, TRUE otherwise.

Remarks

If it is the last command, it remains unchanged.

See Also

Command Object | Prev Method


OptimizedSetExpression Method

OptimizedSetExpression Method
Expression
FieldType
TypeIndex

Description

Like Set Expression, but optimized for speed (less accurate)

Syntax

Visual Basic
Public Function OptimizedSetExpression( _
   ByVal Expression As String, _
   ByVal FieldType As ENUM_FIELD_TYPES, _
   ByVal TypeIndex As Long _
) As Boolean

Parameters

Expression
FieldType
Value Description
ID
REF_ID
LEVEL_REF_ID
ROTATE_REF_ID
ORIGIN_REF_ID
THEO_X
THEO_Y
THEO_Z
THEO_SX
THEO_SY
THEO_SZ
THEO_EX
THEO_EY
THEO_EZ
THEO_I
THEO_J
THEO_K
TARG_X
TARG_Y
TARG_Z
MEAS_X
MEAS_Y
MEAS_Z
MEAS_I
MEAS_J
MEAS_K
MEAS_LENGTH
MEAS_DIAM
MEAS_ANGLE
TARG_I
TARG_J
TARG_K
THEO_DIAM
THEO_WIDTH
THEO_LENGTH
THEO_HEIGHT
THEO_ANGLE
COORD_TYPE
INOUT_TYPE
THICKNESS_TYPE
CIRC_TYPE
SNAP_TYPE
USEPIN_TYPE
MOVE_TYPE
READPOS_TYPE
FINDHOLE_TYPE
RMEAS_TYPE
THEOBF_TYPE
BOUND_TYPE
BF_MATH_TYPE
AUTOFIT_CONSTRAINT
SLOT_MIN_MAX_TYPE
FIND_NOM_AXIS_TYPE
N_INIT_HITS_TYPE
N_PERM_HITS_TYPE
SEARCHMODE_TYPE
MODE_TYPE
MEASURE_ORDER_TYPE
CONE_LENGTH_ANGLE_TYPE
OFFSET_LINE_METHOD
LIN_POL_FILT_TYPE
GEN_FEAT_TYPE
GEN_ALIGN_TYPE
CURVE_TYPE
MEASURED_2D3D_TYPE
THINNING_TOL
HITINT_TYPE
RMEASFEATID
N_HITS
N_ROWS
INIT_HITS
PERM_HITS
F_OFFSET
F_SPACER
F_PITCH
F_THICKNESS
F_DEPTH
F_AUTOMOVE
F_INDENT
F_CORNER_RADIUS
F_INCREMENT
F_TOLERANCE
F_BOXWIDTH
F_BOXLENGTH
F_CIRCRADOUT
F_CIRCRADIN
F_CHECK
F_MAXACCELX
F_MAXACCELY
F_MAXACCELZ
SCAN_ACCELERATION
SCAN_OFFSET_FORCE
MANUAL_FINE_PROBING
F_MOVESPEED
F_TOUCHSPEED
F_SCANSPEED
START_ANG
END_ANG
MIDPOINT_X
MIDPOINT_Y
MIDPOINT_Z
ANGVEC_I
ANGVEC_J
ANGVEC_K
MEASVEC_I
MEASVEC_J
MEASVEC_K
SLOTVEC_I
SLOTVEC_J
SLOTVEC_K
SURFVEC_I
SURFVEC_J
SURFVEC_K
PINVEC_I
PINVEC_J
PINVEC_K
PUNCHVEC_I
PUNCHVEC_J
PUNCHVEC_K
REPORTVEC_I
REPORTVEC_J
REPORTVEC_K
TARGSLOT_I
TARGSLOT_J
TARGSLOT_K
UPDATEVEC_I
UPDATEVEC_J
UPDATEVEC_K
THEO_MINOR_AXIS
TWO_D_THREE_D_TYPE
AXIS
DEST_EXPR
SRC_EXPR
SHOW_IDS
SHOW_DETAILS
WEIGHT
ITEM_USED
USE_AXIS
AVERAGE_ERROR
MEASURE_ALL_FEATURES
REPIERCE_CAD
START_NUM
END_NUM
SKIP_NUM
X_OFFSET
Y_OFFSET
Z_OFFSET
ANGLE_OFFSET
INTERNAL_EXTERNAL
SAVE_ALIGN_CAD_TO_PARTS
FILE_NAME
ALIGN_LIST
WORK_PLANE
DISTANCE
OLD_TIP
NEW_TIP
ROTATION_TYPE
DIM_INFO_ORDER
DIM_INFO_LOC
DIM_INFO_TP_LOC
GRAPH_ANALYSIS
TEXT_ANALYSIS
ARROW_MULTIPLIER
OUTPUT_TYPE
NOMINAL
F_PLUS_TOL
F_MINUS_TOL
TP_MODIFIER
PERP_PARALLEL_TYPE
RADIUS_TYPE
UNIT_TYPE
DIM_LENGTH
PROFILE_FORM_TYPE
PRECISION
MAN_RETRACT
DIM_TEXT
DIM_TEXT_OPTIONS
SHOW_HEADINGS
DEVIATION_SYMBOLS
STANDARD_DEVIATION
DIM_HEADING
GAP_ONLY_TYPE
DISPLAY_ID
DISPLAY_TYPE
POINT_INFO_HEADING
SHOW_POINT_INFO
RET_ONLY_TYPE
COMMENT_FIELD
COMMENT_TYPE
PART_NAME
REVISION_NUMBER
SERIAL_NUMBER
STAT_COUNT
SUB_NAME
READ_WRITE
FILE_POINTER
FIELD_WIDTH
DIGIT_COUNT
LABEL_ID
ERROR_TYPE
ERROR_MODE
DESCRIPTION
INDEX_START
INDEX_END
FILE_COMMAND_TYPE
BUFFER_SIZE_TYPE
FAIL_ON_EXIST
MAX_FORCE
LOW_FORCE
UP_FORCE
TRIGGER_FORCE
PROBE_ACCURACY
POSITIONAL_ACCURACY
NUM_RETURN_DATA
RETURN_SPEED
SCAN_DENSITY
POLAR_VECTOR_COMPENSATION
AUTO_PRINT
ORIGIN
MATERIAL_COEFFICIENT
REF_TEMP
HIGH_THRESHOLD
LOW_THRESHOLD
SENSOR_LIST
FIXTURE_TYPE
MACHINE_TYPE
PROBE_COMP
TIP_I
TIP_J
TIP_K
NORM_RELEARN
FIND_NOMS_TYPE
AUTO_CLEAR_PLANE
SINGLE_POINT
DISPLAY_HITS
CAD_TOLERANCE
OFFSET_TOLERANCE
MIN_INCREMENT
MAX_INCREMENT
MIN_ANGLE
MAX_ANGLE
F_LOCATION
COL132_TYPE
COMMAND_STRING
FLY_MODE_TYPE
STATS_TYPE
STATS_DIR
NEW_STATS_DIR
DATA_READ_LOCK
DATA_WRITE_LOCK
DATA_MEM_PAGES
STAT_NAME_TYPE
STAT_CALC_TYPE
TRANSFER_DIR
DISPLAY_TRACE
TRACE_NAME
TRACE_VALUE
SCAN_CUTPLANEVEC_I
SCAN_CUTPLANEVEC_J
SCAN_CUTPLANEVEC_K
SCAN_INITVEC_I
SCAN_INITVEC_J
SCAN_INITVEC_K
SCAN_AXISVEC_I
SCAN_AXISVEC_J
SCAN_AXISVEC_K
SCAN_ENDVEC_I
SCAN_ENDVEC_J
SCAN_ENDVEC_K
SCAN_INITDIR_I
SCAN_INITDIR_J
SCAN_INITDIR_K
SCAN_CROSS_TOTAL
SCAN_TIME_INCR
SCAN_EDGE_THICK
POS_REPORT_AXIS_X
POS_REPORT_AXIS_Y
POS_REPORT_AXIS_Z
DEV_PERPEN_CENTERLINE
USE_THEO
TARGET_COLOR
THEO_START_ANG
THEO_END_ANG
ONOFF_TYPE
ROW_ID
LOCATOR_BMP
LOCATOR_WAV
DTYPE_LEAPFROGTYPE
DTYPE_LEAPFROGNUMHITS
DTYPE_LEAPFROGFULLPARTIAL
EXCLUSION_ZONE
EXECUTE
AUTOTRIGGERONOFF
AUTOBEEPING
COLUMN_ID
SLOT_NUMBER
AUTOTOLZONE
PROBING_MODE
ANGLE_COMP_TOGGLE
POINTINFO_FILTER_INTERVAL
POINTINFO_FILTER_INTERVAL_NUMBER
FEAT_TYPE
DIM_ID
MEAS_MINOR_AXIS
MEAS_HEIGHT
MEAS_SLOTVEC_I
MEAS_SLOTVEC_J
MEAS_SLOTVEC_K
MEAS_SX
MEAS_SY
MEAS_SZ
MEAS_EX
MEAS_EY
MEAS_EZ
MEAS_WIDTH
NUM_CONTROL_POINTS
U_HITS
V_HITS
NUM_FIT_POINTS
NOMINAL_COLOR
WAVE_FILE
DIM_BONUS
PERUNIT_STEPSIZE
PERUNIT_LENGTH
PERUNIT_WIDTH
DIM_MEASURED
SURFVEC_TARG_I
SURFVEC_TARG_J
SURFVEC_TARG_K
DIM_MAX
EDGEVEC_TARG_I
EDGEVEC_TARG_J
EDGEVEC_TARG_K
DIM_MIN
EDGEVEC_THEO_I
EDGEVEC_THEO_J
EDGEVEC_THEO_K
DIM_DEVIATION
EDGEVEC_MEAS_I
EDGEVEC_MEAS_J
EDGEVEC_MEAS_K
DIM_OUTTOL
T_VALUE
TOOL_X
TOOL_Y
TOOL_Z
TOOL_DIAM
DEV_X
DEV_Y
DEV_Z
DEV_DIAM
ITERATE_COLUMNS
LOAD_TYPE
NUM_ITERATIONS
METHOD_TYPE
SCAN_TECHNIQUE
HIT_TYPE
BOUNDARY_POINT_X
BOUNDARY_POINT_Y
BOUNDARY_POINT_Z
VIDEO_GAIN
VIDEO_OFFSET
VIDEO_LEDLIGHT
VIDEO_LASERLIGHT1
VIDEO_LASERLIGHT2
VIDEO_YORIGIN
VIDEO_YEND
VIDEO_LSEG
VIDEO_XSEG
VIDEO_YSEG
ANGULARITY_NOM_ANGLE
PRINT_TO_FILE
PRINT_TO_PRINTER
PRINT_DRAFTMODE
PRINT_DELETE_RUNS
POINTINFO_FILTER_WORST
POINTINFO_FILTER_WORST_NUMBER
POINTINFO_FILTER_DEVIATION
POINTINFO_FILTER_DEVIATION_NUMBER
POINTINFO_FILTER_OUTTOL
REPORT_SURFVEC_I
REPORT_SURFVEC_J
REPORT_SURFVEC_K
DB_QUERY_OP
DB_SOURCE_NAME
CHART_TYPE
DB_CHART_NAME
DEVIATION_ANGLE
STATS_DATASOURCE
IGNOREMOTIONERRORS_TYPE
THEO_X2
THEO_Y2
THEO_Z2
MEAS_X2
MEAS_Y2
MEAS_Z2
PPROG
TRACE_FILTER
TIME_FILTER
SHOW_SPC_CALCS
SPEC_LIMITS
ZONES
STDDEV
UCL_LCL
HISTOGRAM
GRID
ADDITIONAL_CHART
LINE2_PLANAR_OPEN_IN_X
LINE3_PLANAR_OPEN_IN_X
REGR
CENTER_POINT
SHOW_MORE_SPC_CALCS
SPEC_OFFSET
SOLID
U_L_BOUNDS
TITLE
CPOINT_X
CPOINT_Y
CPOINT_Z
CPOINT_I
CPOINT_J
CPOINT_K
CPOINT_DIAM
CPOINT_SCAN_CROSS_TOTAL
CPOINT_SCAN_DENSITY
CPOINT_F_SCANSPEED
N_CONTROLPOINTS
CPOINT_TYPE
USE_3DFILTER
SCAN_BNDRY_TYPE
CREATE_WEIGHTS
F_SIZE
LINE2_ISPLANAR
LINE2_PLANAR_XTOL
LINE2_PLANAR_YTOL
LINE2_PLANAR_XDEV
LINE2_PLANAR_YDEV
LINE3_ISPLANAR
LINE3_PLANAR_XTOL
LINE3_PLANAR_YTOL
LINE3_PLANAR_XDEV
LINE3_PLANAR_YDEV
CHART_SUB_TYPE
OVERWRITE
OUTPUT_FEATURE_NOMS
OUTPUT_FEAT_W_DIMENS
OUTPUT_DMIS_REPORT
TIME_ARG
TRACE_FILTER_ARG
FIT
STATS_DB_TYPE
IOCHANNEL_NUMBER
IOCHANNEL_PULSE_WIDTH
IOCHANNEL_PULSE_INTERVAL
IOCHANNEL_PULSE_DURATION
GRAPH_OPTION
DB_SOURCE_TYPE
FIND_HOLE_PERCENT
AUTO_ONERROR_TYPE
POS_REPT_DISPLAY_OPTION
TRIGGERTOLERANCE
TRIGGERTOLVALUE
FIXTURE_TOL
START_LABEL
ERROR_LABEL
CONE_CONVEX_TYPE
TRIGGERPLANE
QUERY_SHOW_GRAPHIC_SETTINGS
CALC_STYLE_FILE
FILTER_TYPE
TRACE_VALUE_LIMIT
TARGET_DIRECTION
TARGET_EDGE_POLARITY
BSMETHOD_TYPE
CENTER_ROTATION_THEO
CENTER_ROTATION_MEAS
ARTICULATEDARM_TYPE
LEFTYRIGHTY_CONFIG
ABOVEBELOW_CONFIG
NOFLIPFLIP_CONFIG
HIGH_ACCURACY
SURFACE
MAGNIFICATION
MINOR_WORD_TOGGLE
PERCENTAGE
THRESHOLD
N_SIDES
TARGET_SURFACE_ILLUM
MEAN
CAD_COMP
SHOW_ROW
SHOW_COLUMN
TARGET_SURFACE_SENSILIGHT
TARGET_SURFACE_WIDTH
TARGET_SURFACE_HEIGHT
TARGET_SURFACE_RANGE
TARGET_SURFACE_DURATION
TARGET_SURFACE_MODE
TARGET_SURFACE_HIACC
SCREEN_CAPTURE_SCALE
SCREEN_CAPTURE_QUALITY
TARGET_EDGE_SIZE
TARGET_EDGE_ILLUM
TARGET_EDGE_TOL
TARGET_EDGE_STRENGTH
TARGET_EDGE_DENSITY
TARGET_EDGE_TYPE
DISPLAY_ADVANCED_PARAMETERS
TARGET_SURFACE_TYPE
VOID_DETECT
TARG_SX
TARG_SY
TARG_SZ
TARG_EX
TARG_EY
TARG_EZ
PATTERN_TYPE
TARGET_EDGE_ANGLE
PROGRAM_GAGE_FEAT_TYPE
PROGRAM_GAGE_TYPE
TARGET_FOCUS
RMEASFEATIDX
RMEASFEATIDY
RMEASFEATIDZ
FINDNOMS_BESTFIT
FINDNOMS_ONLYSELECTED
TEMPX
TEMPY
TEMPZ
TEMPP
AUTO_PH9
MANUAL_PREPOSITION
SCREEN_CAPTURE_TYPE
SCREEN_CAPTURE_AUTO_TYPE
TARGET_EDGE_EDGESELECT
TARGET_EDGE_EDGENUM
DELETE_TYPE
SCREEN_CAPTURE_AUTO_TIME
USE_HSSDAT
USE_STARTENDDELAY
COP_FILTER
COP_SIZE
COP_TYPE
SURFVEC_MEAS_I
SURFVEC_MEAS_J
SURFVEC_MEAS_K
TARGET_EDGE_UNDERSCAN
PROFILE_TYPE
THEO_FLUSH
MEAS_FLUSH
THEO_GAP
MEAS_GAP
THEO_DEPTH
MEAS_DEPTH
TARGET_BLOB_TYPE
LASER_STRIPE_OVERLAP
LASER_STRIPE_OVERSCAN
LASER_FREQUENCY
TARGET_FILTER_OUTLIER
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD
SLOT_TYPE
TARGET_TYPE
THEO_R
THEO_A
THEO_H
MEAS_R
MEAS_A
MEAS_H
TARG_R
TARG_A
TARG_H
THEO_SR
THEO_SA
THEO_SH
THEO_ER
THEO_EA
THEO_EH
MEAS_SR
MEAS_SA
MEAS_SH
MEAS_ER
MEAS_EA
MEAS_EH
TARG_SR
TARG_SA
TARG_SH
TARG_ER
TARG_EA
TARG_EH
TARGET_EDGE_SENSILIGHT
F_THICKNESS_EDGE
THICKNESS_TYPE_EDGE
LASER_EXPOSURE
LASER_INTENSITY
ANGLE_OFFSET_2
LASER_FILTER_NEIGHBOR_NUM
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD
LASER_FILTER_TOL_ABOVE
LASER_FILTER_TOL_BELOW
LASER_FILTER_TOL_RIGHT
LASER_CLIP_UP_DIST
LASER_CLIP_LOW_DIST
LASER_PIXEL_TOGGLE
LASER_FILTER_TOGGLE
DISPLAY_PROBE_PARAMETERS
THEO_R2
THEO_A2
THEO_H2
MEAS_R2
MEAS_A2
MEAS_H2
LASER_CLIP_LEFT_DIST
LASER_CLIP_RIGHT_DIST
COP_FILETYPE
COP_SELECTIONTYPE
COP_COLORMAP
COP_COPLEMENT
OPERTYPE
COP_BOOLEANTYPE
COP_IMPORTFILETYPE
MEAS_START_ANG
MEAS_END_ANG
ISLAND_DIAM
ISLAND_LENGTH
ISLAND_WIDTH
ISLAND_X
ISLAND_Y
ISLAND_Z
ISLAND_I
ISLAND_J
ISLAND_K
ISLAND_AI
ISLAND_AJ
ISLAND_AK
ISLAND_TYPE
ISLAND_CLEARANCEDIST
RPT_DIMENSION_TABLES
SUMMARY_DEV
DRF_TBLHDR
LINE1_TBLHDR
LINE1_CALLOUT
LINE1_COLUMN_HDR
LINE1_FEATNAME
LINE1_NOMINAL
LINE1_MEAS
LINE1_PLUSTOL
LINE1_MINUSTOL
LINE1_DEV
LINE1_DEVPERCENT
LINE1_ISBILATERAL
LINE1_NUMZONES
LINE2_TBLHDR
LINE2_CALLOUT
LINE2_COLUMN_HDR
LINE2_FEATNAME
LINE2_BONUS
LINE2_TOL
LINE2_DATUMSHFT
LINE2_UNUSEDZONE
LINE2_DEV
LINE2_DEVANG
LINE2_DEVPERCENT
LINE3_TBLHDR
LINE3_CALLOUT
LINE3_COLUMN_HDR
LINE3_FEATNAME
LINE3_BONUS
LINE3_TOL
LINE3_DATUMSHFT
LINE3_UNUSEDZONE
LINE3_DEV
LINE3_DEVANG
LINE3_DEVPERCENT
DRF_COLUMN_HDR
DRF_SEGNAME
DRF_SHIFTX
DRF_SHIFTY
DRF_SHIFTZ
DRF_ROTATIONX
DRF_ROTATIONY
DRF_ROTATIONZ
SUMMARY_COLUMN_HDR
SUMMARY_FEAT
LINE2_AXIS
LINE2_NOMINAL
LINE2_MEAS
SUMMARY_TBLHDR
SUMMARY_AXIS
SUMMARY_NOMINAL
SUMMARY_MEAS
LINE2_PLUSTOL
LINE2_MINUSTOL
LINE2_MAX
LINE2_MIN
LINE2_ISBILATERAL
LINE2_NUMZONES
LINE3_ISBILATERAL
LINE3_NUMZONES
DIM_RPT_COLUMN_HDR
DIM_RPT_ISDATUM
DIM_RPT_DATUM
DIM_RPT_GRAPHIC
DIM_RPT_DEVPERCENT
DIM_RPT_ISBILATERAL
DIM_RPT_NUMZONES
GDT_SYMBOL
COMMENT_INPUT
TARGET_EDGE_WIDTH
TARGET_EDGE_HEIGHT
TARGET_EDGE_EDGEDETECT
TARGET_EDGE_FILTER_CLEAN
TARGET_EDGE_FILTER_CLEAN_STRENGTH
TARGET_EDGE_FILTER_AREA
TARGET_EDGE_FILTER_AREA_SIZE
TARGET_EDGE_GRADIENT
THEO_PERIMETER
MEAS_PERIMETER
THEO_AREA
MEAS_AREA
TARGET_SURFACE_CROSSHAIR_HEIGHT
SHOW_NOMS
COMPOSITE
DATUM2
TP_MODIFIER2
DESCRIPTION2
SHOW_OPTIONS
LEADER_LINE_ID
GDT_SYMBOL2
DATUM1_MODIFIER
DATUM2_MODIFIER
DATUM3_MODIFIER
DATUM1_MODIFIER2
DATUM2_MODIFIER2
DATUM3_MODIFIER2
DIM_RPT_DEVPERCENT_NOM
DIM_RPT_USETWODEVIATIONS
DIM_RPT_DEVPERCENT2
LINE2_DEVPERCENT_NOM
LINE2_USE2DEVIATIONS
LINE2_DEVPERCENT2
LINE3_DEVPERCENT_NOM
LINE3_USE2DEVIATIONS
LINE3_DEVPERCENT2
AXIS_PLUS_TOL
AXIS_MINUS_TOL
AXIS_NOMINAL
AXIS_DESCRIPTION
LINE1_DEVPERCENT_NOM
LINE1_USE2DEVIATIONS
LINE1_DEVPERCENT2
USE_AXIS2
DIM_LENGTH2
TEXTANAL_LABEL_MEAS_X
TEXTANAL_LABEL_MEAS_Y
TEXTANAL_LABEL_MEAS_Z
TEXTANAL_LABEL_MEAS_I
TEXTANAL_LABEL_MEAS_J
TEXTANAL_LABEL_MEAS_K
TEXTANAL_LABEL_DEV
TEXTANAL_LABEL_MINMAX
SIMULT_EVAL
SECTION_INDEX
LINE1_OUTTOL
LINE2_OUTTOL
LINE3_OUTTOL
LINE1_MAX
LINE1_MIN
LINE3_NOMINAL
LINE3_MEAS
LINE3_PLUSTOL
LINE3_MINUSTOL
LINE3_MAX
LINE3_MIN
SUMMARY_OUTTOL
SUMMARY_PLUSTOL
SUMMARY_MINUSTOL
SUMMARY_MAX
SUMMARY_MIN
SUMMARY_BONUS
LINE1_BONUS
GRAPH_ANALYSIS_POINT_SIZE
GRAPH_ANALYSIS_PLUS_TOL
GRAPH_ANALYSIS_MINUS_TOL
DIM_AXIS_ITEM_NUMBER
F_ENDING_DEPTH
DIM_ITEM_NUMBER
FEAT_ITEM_NUMBER
COMMAND_TYPE
DEV_MAX
AUTO_DEV_DIRECTION
PROBE_DIRECTION
USER_DEFINED_THEOS
SCALING
USE_SCALING
UID
REF_UID
BA_SOLUTION_TYPE
BA_SOLUTION_OPTIONS
BA_SOLUTION_STATUS
BA_VARIANCE
BA_RMS
BA_WARNINGS
BA_STATION
BA_STATION_X
BA_STATION_Y
BA_STATION_Z
BA_STATION_ROTX
BA_STATION_ROTY
BA_STATION_ROTZ
BA_STATION_ORIENTED
BA_STATION_LOCKED
BA_FEATURE
BA_FEAT_SOURCE
BA_FEAT_RMS
BA_FEAT_POINTING_ERR
BA_FEAT_APEX_ANGLE
BA_FEAT_X
BA_FEAT_Y
BA_FEAT_Z
BA_FEAT_DEV_X
BA_FEAT_DEV_Y
BA_FEAT_DEV_Z
BA_FEAT_DEV3D
NO_APPROACH_VECTOR_FLIP
TARGET_EDGE_START_VALUE
TARGET_EDGE_END_VALUE
TARGET_SURFACE_SURFACE_VARIANCE
RELATIVE_COMMENTS
AUTO_ROTARY
TARGET_COVERAGE
ROTATION_TYPE_2
PROBE_TYPE
TIME_STAMP
ECOND_TEMP
ECOND_PRESSURE
ECOND_HUMIDITY
HIT_RMS
DISPLAY_TRACKER_PARAMETERS
PTDENSITY_TOGGLE
PTDENSITY_UPPERBOUND
PTDENSITY_DEVLIMIT
PTDENSITY_MAXSPAN
TARGET_MEASURE_AT_FOV_CENTER
TARGET_SURFACE_FIND_SURFACE
PROJECTOR
INLINE_LEGACY_REPORT
SINGLE_POINT_DEVIATION
TypeIndex

See Also

Command Object


OptimizedSolveExpression Method

OptimizedSolveExpression Method
Expression

Description

Like Solve Expression, but optimized for speed (less accurate)

Syntax

Visual Basic
Public Function OptimizedSolveExpression( _
   ByVal Expression As String _
) As Variable

Parameters

Expression

See Also

Command Object


Prev Method

Prev Method

Description

Changes current command object to point to the previous command object in the collection Accesses the previous command in the parent Commands list.

Syntax

Visual Basic
Public Function Prev() As Boolean

Return Type

Boolean value. This function returns FALSE if it is the first command in the parent Commands list, TRUE otherwise.

See Also

Command Object | Next Method


PutText Method

PutText Method
NewVal
String value to put into the indicated field.
DataType
Used to indicate which field into which the text is being put. Type ENUM_FIELD_TYPES enumeration.
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a field type. When using the index property on a field type that can have a variable number of fields, the index must not be greater than the current number of fields (of the type being changed) + 1.

Description

Puts the specified text into the object data item Puts text into the indicated field of the command.

Syntax

Visual Basic
Public Function PutText( _
   ByVal NewVal As String, _
   ByVal DataType As ENUM_FIELD_TYPES, _
   ByVal TypeIndex As Long _
) As Boolean

Parameters

NewVal
String value to put into the indicated field.
DataType
Value Description
ID
REF_ID
LEVEL_REF_ID
ROTATE_REF_ID
ORIGIN_REF_ID
THEO_X
THEO_Y
THEO_Z
THEO_SX
THEO_SY
THEO_SZ
THEO_EX
THEO_EY
THEO_EZ
THEO_I
THEO_J
THEO_K
TARG_X
TARG_Y
TARG_Z
MEAS_X
MEAS_Y
MEAS_Z
MEAS_I
MEAS_J
MEAS_K
MEAS_LENGTH
MEAS_DIAM
MEAS_ANGLE
TARG_I
TARG_J
TARG_K
THEO_DIAM
THEO_WIDTH
THEO_LENGTH
THEO_HEIGHT
THEO_ANGLE
COORD_TYPE
INOUT_TYPE
THICKNESS_TYPE
CIRC_TYPE
SNAP_TYPE
USEPIN_TYPE
MOVE_TYPE
READPOS_TYPE
FINDHOLE_TYPE
RMEAS_TYPE
THEOBF_TYPE
BOUND_TYPE
BF_MATH_TYPE
AUTOFIT_CONSTRAINT
SLOT_MIN_MAX_TYPE
FIND_NOM_AXIS_TYPE
N_INIT_HITS_TYPE
N_PERM_HITS_TYPE
SEARCHMODE_TYPE
MODE_TYPE
MEASURE_ORDER_TYPE
CONE_LENGTH_ANGLE_TYPE
OFFSET_LINE_METHOD
LIN_POL_FILT_TYPE
GEN_FEAT_TYPE
GEN_ALIGN_TYPE
CURVE_TYPE
MEASURED_2D3D_TYPE
THINNING_TOL
HITINT_TYPE
RMEASFEATID
N_HITS
N_ROWS
INIT_HITS
PERM_HITS
F_OFFSET
F_SPACER
F_PITCH
F_THICKNESS
F_DEPTH
F_AUTOMOVE
F_INDENT
F_CORNER_RADIUS
F_INCREMENT
F_TOLERANCE
F_BOXWIDTH
F_BOXLENGTH
F_CIRCRADOUT
F_CIRCRADIN
F_CHECK
F_MAXACCELX
F_MAXACCELY
F_MAXACCELZ
SCAN_ACCELERATION
SCAN_OFFSET_FORCE
MANUAL_FINE_PROBING
F_MOVESPEED
F_TOUCHSPEED
F_SCANSPEED
START_ANG
END_ANG
MIDPOINT_X
MIDPOINT_Y
MIDPOINT_Z
ANGVEC_I
ANGVEC_J
ANGVEC_K
MEASVEC_I
MEASVEC_J
MEASVEC_K
SLOTVEC_I
SLOTVEC_J
SLOTVEC_K
SURFVEC_I
SURFVEC_J
SURFVEC_K
PINVEC_I
PINVEC_J
PINVEC_K
PUNCHVEC_I
PUNCHVEC_J
PUNCHVEC_K
REPORTVEC_I
REPORTVEC_J
REPORTVEC_K
TARGSLOT_I
TARGSLOT_J
TARGSLOT_K
UPDATEVEC_I
UPDATEVEC_J
UPDATEVEC_K
THEO_MINOR_AXIS
TWO_D_THREE_D_TYPE
AXIS
DEST_EXPR
SRC_EXPR
SHOW_IDS
SHOW_DETAILS
WEIGHT
ITEM_USED
USE_AXIS
AVERAGE_ERROR
MEASURE_ALL_FEATURES
REPIERCE_CAD
START_NUM
END_NUM
SKIP_NUM
X_OFFSET
Y_OFFSET
Z_OFFSET
ANGLE_OFFSET
INTERNAL_EXTERNAL
SAVE_ALIGN_CAD_TO_PARTS
FILE_NAME
ALIGN_LIST
WORK_PLANE
DISTANCE
OLD_TIP
NEW_TIP
ROTATION_TYPE
DIM_INFO_ORDER
DIM_INFO_LOC
DIM_INFO_TP_LOC
GRAPH_ANALYSIS
TEXT_ANALYSIS
ARROW_MULTIPLIER
OUTPUT_TYPE
NOMINAL
F_PLUS_TOL
F_MINUS_TOL
TP_MODIFIER
PERP_PARALLEL_TYPE
RADIUS_TYPE
UNIT_TYPE
DIM_LENGTH
PROFILE_FORM_TYPE
PRECISION
MAN_RETRACT
DIM_TEXT
DIM_TEXT_OPTIONS
SHOW_HEADINGS
DEVIATION_SYMBOLS
STANDARD_DEVIATION
DIM_HEADING
GAP_ONLY_TYPE
DISPLAY_ID
DISPLAY_TYPE
POINT_INFO_HEADING
SHOW_POINT_INFO
RET_ONLY_TYPE
COMMENT_FIELD
COMMENT_TYPE
PART_NAME
REVISION_NUMBER
SERIAL_NUMBER
STAT_COUNT
SUB_NAME
READ_WRITE
FILE_POINTER
FIELD_WIDTH
DIGIT_COUNT
LABEL_ID
ERROR_TYPE
ERROR_MODE
DESCRIPTION
INDEX_START
INDEX_END
FILE_COMMAND_TYPE
BUFFER_SIZE_TYPE
FAIL_ON_EXIST
MAX_FORCE
LOW_FORCE
UP_FORCE
TRIGGER_FORCE
PROBE_ACCURACY
POSITIONAL_ACCURACY
NUM_RETURN_DATA
RETURN_SPEED
SCAN_DENSITY
POLAR_VECTOR_COMPENSATION
AUTO_PRINT
ORIGIN
MATERIAL_COEFFICIENT
REF_TEMP
HIGH_THRESHOLD
LOW_THRESHOLD
SENSOR_LIST
FIXTURE_TYPE
MACHINE_TYPE
PROBE_COMP
TIP_I
TIP_J
TIP_K
NORM_RELEARN
FIND_NOMS_TYPE
AUTO_CLEAR_PLANE
SINGLE_POINT
DISPLAY_HITS
CAD_TOLERANCE
OFFSET_TOLERANCE
MIN_INCREMENT
MAX_INCREMENT
MIN_ANGLE
MAX_ANGLE
F_LOCATION
COL132_TYPE
COMMAND_STRING
FLY_MODE_TYPE
STATS_TYPE
STATS_DIR
NEW_STATS_DIR
DATA_READ_LOCK
DATA_WRITE_LOCK
DATA_MEM_PAGES
STAT_NAME_TYPE
STAT_CALC_TYPE
TRANSFER_DIR
DISPLAY_TRACE
TRACE_NAME
TRACE_VALUE
SCAN_CUTPLANEVEC_I
SCAN_CUTPLANEVEC_J
SCAN_CUTPLANEVEC_K
SCAN_INITVEC_I
SCAN_INITVEC_J
SCAN_INITVEC_K
SCAN_AXISVEC_I
SCAN_AXISVEC_J
SCAN_AXISVEC_K
SCAN_ENDVEC_I
SCAN_ENDVEC_J
SCAN_ENDVEC_K
SCAN_INITDIR_I
SCAN_INITDIR_J
SCAN_INITDIR_K
SCAN_CROSS_TOTAL
SCAN_TIME_INCR
SCAN_EDGE_THICK
POS_REPORT_AXIS_X
POS_REPORT_AXIS_Y
POS_REPORT_AXIS_Z
DEV_PERPEN_CENTERLINE
USE_THEO
TARGET_COLOR
THEO_START_ANG
THEO_END_ANG
ONOFF_TYPE
ROW_ID
LOCATOR_BMP
LOCATOR_WAV
DTYPE_LEAPFROGTYPE
DTYPE_LEAPFROGNUMHITS
DTYPE_LEAPFROGFULLPARTIAL
EXCLUSION_ZONE
EXECUTE
AUTOTRIGGERONOFF
AUTOBEEPING
COLUMN_ID
SLOT_NUMBER
AUTOTOLZONE
PROBING_MODE
ANGLE_COMP_TOGGLE
POINTINFO_FILTER_INTERVAL
POINTINFO_FILTER_INTERVAL_NUMBER
FEAT_TYPE
DIM_ID
MEAS_MINOR_AXIS
MEAS_HEIGHT
MEAS_SLOTVEC_I
MEAS_SLOTVEC_J
MEAS_SLOTVEC_K
MEAS_SX
MEAS_SY
MEAS_SZ
MEAS_EX
MEAS_EY
MEAS_EZ
MEAS_WIDTH
NUM_CONTROL_POINTS
U_HITS
V_HITS
NUM_FIT_POINTS
NOMINAL_COLOR
WAVE_FILE
DIM_BONUS
PERUNIT_STEPSIZE
PERUNIT_LENGTH
PERUNIT_WIDTH
DIM_MEASURED
SURFVEC_TARG_I
SURFVEC_TARG_J
SURFVEC_TARG_K
DIM_MAX
EDGEVEC_TARG_I
EDGEVEC_TARG_J
EDGEVEC_TARG_K
DIM_MIN
EDGEVEC_THEO_I
EDGEVEC_THEO_J
EDGEVEC_THEO_K
DIM_DEVIATION
EDGEVEC_MEAS_I
EDGEVEC_MEAS_J
EDGEVEC_MEAS_K
DIM_OUTTOL
T_VALUE
TOOL_X
TOOL_Y
TOOL_Z
TOOL_DIAM
DEV_X
DEV_Y
DEV_Z
DEV_DIAM
ITERATE_COLUMNS
LOAD_TYPE
NUM_ITERATIONS
METHOD_TYPE
SCAN_TECHNIQUE
HIT_TYPE
BOUNDARY_POINT_X
BOUNDARY_POINT_Y
BOUNDARY_POINT_Z
VIDEO_GAIN
VIDEO_OFFSET
VIDEO_LEDLIGHT
VIDEO_LASERLIGHT1
VIDEO_LASERLIGHT2
VIDEO_YORIGIN
VIDEO_YEND
VIDEO_LSEG
VIDEO_XSEG
VIDEO_YSEG
ANGULARITY_NOM_ANGLE
PRINT_TO_FILE
PRINT_TO_PRINTER
PRINT_DRAFTMODE
PRINT_DELETE_RUNS
POINTINFO_FILTER_WORST
POINTINFO_FILTER_WORST_NUMBER
POINTINFO_FILTER_DEVIATION
POINTINFO_FILTER_DEVIATION_NUMBER
POINTINFO_FILTER_OUTTOL
REPORT_SURFVEC_I
REPORT_SURFVEC_J
REPORT_SURFVEC_K
DB_QUERY_OP
DB_SOURCE_NAME
CHART_TYPE
DB_CHART_NAME
DEVIATION_ANGLE
STATS_DATASOURCE
IGNOREMOTIONERRORS_TYPE
THEO_X2
THEO_Y2
THEO_Z2
MEAS_X2
MEAS_Y2
MEAS_Z2
PPROG
TRACE_FILTER
TIME_FILTER
SHOW_SPC_CALCS
SPEC_LIMITS
ZONES
STDDEV
UCL_LCL
HISTOGRAM
GRID
ADDITIONAL_CHART
LINE2_PLANAR_OPEN_IN_X
LINE3_PLANAR_OPEN_IN_X
REGR
CENTER_POINT
SHOW_MORE_SPC_CALCS
SPEC_OFFSET
SOLID
U_L_BOUNDS
TITLE
CPOINT_X
CPOINT_Y
CPOINT_Z
CPOINT_I
CPOINT_J
CPOINT_K
CPOINT_DIAM
CPOINT_SCAN_CROSS_TOTAL
CPOINT_SCAN_DENSITY
CPOINT_F_SCANSPEED
N_CONTROLPOINTS
CPOINT_TYPE
USE_3DFILTER
SCAN_BNDRY_TYPE
CREATE_WEIGHTS
F_SIZE
LINE2_ISPLANAR
LINE2_PLANAR_XTOL
LINE2_PLANAR_YTOL
LINE2_PLANAR_XDEV
LINE2_PLANAR_YDEV
LINE3_ISPLANAR
LINE3_PLANAR_XTOL
LINE3_PLANAR_YTOL
LINE3_PLANAR_XDEV
LINE3_PLANAR_YDEV
CHART_SUB_TYPE
OVERWRITE
OUTPUT_FEATURE_NOMS
OUTPUT_FEAT_W_DIMENS
OUTPUT_DMIS_REPORT
TIME_ARG
TRACE_FILTER_ARG
FIT
STATS_DB_TYPE
IOCHANNEL_NUMBER
IOCHANNEL_PULSE_WIDTH
IOCHANNEL_PULSE_INTERVAL
IOCHANNEL_PULSE_DURATION
GRAPH_OPTION
DB_SOURCE_TYPE
FIND_HOLE_PERCENT
AUTO_ONERROR_TYPE
POS_REPT_DISPLAY_OPTION
TRIGGERTOLERANCE
TRIGGERTOLVALUE
FIXTURE_TOL
START_LABEL
ERROR_LABEL
CONE_CONVEX_TYPE
TRIGGERPLANE
QUERY_SHOW_GRAPHIC_SETTINGS
CALC_STYLE_FILE
FILTER_TYPE
TRACE_VALUE_LIMIT
TARGET_DIRECTION
TARGET_EDGE_POLARITY
BSMETHOD_TYPE
CENTER_ROTATION_THEO
CENTER_ROTATION_MEAS
ARTICULATEDARM_TYPE
LEFTYRIGHTY_CONFIG
ABOVEBELOW_CONFIG
NOFLIPFLIP_CONFIG
HIGH_ACCURACY
SURFACE
MAGNIFICATION
MINOR_WORD_TOGGLE
PERCENTAGE
THRESHOLD
N_SIDES
TARGET_SURFACE_ILLUM
MEAN
CAD_COMP
SHOW_ROW
SHOW_COLUMN
TARGET_SURFACE_SENSILIGHT
TARGET_SURFACE_WIDTH
TARGET_SURFACE_HEIGHT
TARGET_SURFACE_RANGE
TARGET_SURFACE_DURATION
TARGET_SURFACE_MODE
TARGET_SURFACE_HIACC
SCREEN_CAPTURE_SCALE
SCREEN_CAPTURE_QUALITY
TARGET_EDGE_SIZE
TARGET_EDGE_ILLUM
TARGET_EDGE_TOL
TARGET_EDGE_STRENGTH
TARGET_EDGE_DENSITY
TARGET_EDGE_TYPE
DISPLAY_ADVANCED_PARAMETERS
TARGET_SURFACE_TYPE
VOID_DETECT
TARG_SX
TARG_SY
TARG_SZ
TARG_EX
TARG_EY
TARG_EZ
PATTERN_TYPE
TARGET_EDGE_ANGLE
PROGRAM_GAGE_FEAT_TYPE
PROGRAM_GAGE_TYPE
TARGET_FOCUS
RMEASFEATIDX
RMEASFEATIDY
RMEASFEATIDZ
FINDNOMS_BESTFIT
FINDNOMS_ONLYSELECTED
TEMPX
TEMPY
TEMPZ
TEMPP
AUTO_PH9
MANUAL_PREPOSITION
SCREEN_CAPTURE_TYPE
SCREEN_CAPTURE_AUTO_TYPE
TARGET_EDGE_EDGESELECT
TARGET_EDGE_EDGENUM
DELETE_TYPE
SCREEN_CAPTURE_AUTO_TIME
USE_HSSDAT
USE_STARTENDDELAY
COP_FILTER
COP_SIZE
COP_TYPE
SURFVEC_MEAS_I
SURFVEC_MEAS_J
SURFVEC_MEAS_K
TARGET_EDGE_UNDERSCAN
PROFILE_TYPE
THEO_FLUSH
MEAS_FLUSH
THEO_GAP
MEAS_GAP
THEO_DEPTH
MEAS_DEPTH
TARGET_BLOB_TYPE
LASER_STRIPE_OVERLAP
LASER_STRIPE_OVERSCAN
LASER_FREQUENCY
TARGET_FILTER_OUTLIER
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD
SLOT_TYPE
TARGET_TYPE
THEO_R
THEO_A
THEO_H
MEAS_R
MEAS_A
MEAS_H
TARG_R
TARG_A
TARG_H
THEO_SR
THEO_SA
THEO_SH
THEO_ER
THEO_EA
THEO_EH
MEAS_SR
MEAS_SA
MEAS_SH
MEAS_ER
MEAS_EA
MEAS_EH
TARG_SR
TARG_SA
TARG_SH
TARG_ER
TARG_EA
TARG_EH
TARGET_EDGE_SENSILIGHT
F_THICKNESS_EDGE
THICKNESS_TYPE_EDGE
LASER_EXPOSURE
LASER_INTENSITY
ANGLE_OFFSET_2
LASER_FILTER_NEIGHBOR_NUM
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD
LASER_FILTER_TOL_ABOVE
LASER_FILTER_TOL_BELOW
LASER_FILTER_TOL_RIGHT
LASER_CLIP_UP_DIST
LASER_CLIP_LOW_DIST
LASER_PIXEL_TOGGLE
LASER_FILTER_TOGGLE
DISPLAY_PROBE_PARAMETERS
THEO_R2
THEO_A2
THEO_H2
MEAS_R2
MEAS_A2
MEAS_H2
LASER_CLIP_LEFT_DIST
LASER_CLIP_RIGHT_DIST
COP_FILETYPE
COP_SELECTIONTYPE
COP_COLORMAP
COP_COPLEMENT
OPERTYPE
COP_BOOLEANTYPE
COP_IMPORTFILETYPE
MEAS_START_ANG
MEAS_END_ANG
ISLAND_DIAM
ISLAND_LENGTH
ISLAND_WIDTH
ISLAND_X
ISLAND_Y
ISLAND_Z
ISLAND_I
ISLAND_J
ISLAND_K
ISLAND_AI
ISLAND_AJ
ISLAND_AK
ISLAND_TYPE
ISLAND_CLEARANCEDIST
RPT_DIMENSION_TABLES
SUMMARY_DEV
DRF_TBLHDR
LINE1_TBLHDR
LINE1_CALLOUT
LINE1_COLUMN_HDR
LINE1_FEATNAME
LINE1_NOMINAL
LINE1_MEAS
LINE1_PLUSTOL
LINE1_MINUSTOL
LINE1_DEV
LINE1_DEVPERCENT
LINE1_ISBILATERAL
LINE1_NUMZONES
LINE2_TBLHDR
LINE2_CALLOUT
LINE2_COLUMN_HDR
LINE2_FEATNAME
LINE2_BONUS
LINE2_TOL
LINE2_DATUMSHFT
LINE2_UNUSEDZONE
LINE2_DEV
LINE2_DEVANG
LINE2_DEVPERCENT
LINE3_TBLHDR
LINE3_CALLOUT
LINE3_COLUMN_HDR
LINE3_FEATNAME
LINE3_BONUS
LINE3_TOL
LINE3_DATUMSHFT
LINE3_UNUSEDZONE
LINE3_DEV
LINE3_DEVANG
LINE3_DEVPERCENT
DRF_COLUMN_HDR
DRF_SEGNAME
DRF_SHIFTX
DRF_SHIFTY
DRF_SHIFTZ
DRF_ROTATIONX
DRF_ROTATIONY
DRF_ROTATIONZ
SUMMARY_COLUMN_HDR
SUMMARY_FEAT
LINE2_AXIS
LINE2_NOMINAL
LINE2_MEAS
SUMMARY_TBLHDR
SUMMARY_AXIS
SUMMARY_NOMINAL
SUMMARY_MEAS
LINE2_PLUSTOL
LINE2_MINUSTOL
LINE2_MAX
LINE2_MIN
LINE2_ISBILATERAL
LINE2_NUMZONES
LINE3_ISBILATERAL
LINE3_NUMZONES
DIM_RPT_COLUMN_HDR
DIM_RPT_ISDATUM
DIM_RPT_DATUM
DIM_RPT_GRAPHIC
DIM_RPT_DEVPERCENT
DIM_RPT_ISBILATERAL
DIM_RPT_NUMZONES
GDT_SYMBOL
COMMENT_INPUT
TARGET_EDGE_WIDTH
TARGET_EDGE_HEIGHT
TARGET_EDGE_EDGEDETECT
TARGET_EDGE_FILTER_CLEAN
TARGET_EDGE_FILTER_CLEAN_STRENGTH
TARGET_EDGE_FILTER_AREA
TARGET_EDGE_FILTER_AREA_SIZE
TARGET_EDGE_GRADIENT
THEO_PERIMETER
MEAS_PERIMETER
THEO_AREA
MEAS_AREA
TARGET_SURFACE_CROSSHAIR_HEIGHT
SHOW_NOMS
COMPOSITE
DATUM2
TP_MODIFIER2
DESCRIPTION2
SHOW_OPTIONS
LEADER_LINE_ID
GDT_SYMBOL2
DATUM1_MODIFIER
DATUM2_MODIFIER
DATUM3_MODIFIER
DATUM1_MODIFIER2
DATUM2_MODIFIER2
DATUM3_MODIFIER2
DIM_RPT_DEVPERCENT_NOM
DIM_RPT_USETWODEVIATIONS
DIM_RPT_DEVPERCENT2
LINE2_DEVPERCENT_NOM
LINE2_USE2DEVIATIONS
LINE2_DEVPERCENT2
LINE3_DEVPERCENT_NOM
LINE3_USE2DEVIATIONS
LINE3_DEVPERCENT2
AXIS_PLUS_TOL
AXIS_MINUS_TOL
AXIS_NOMINAL
AXIS_DESCRIPTION
LINE1_DEVPERCENT_NOM
LINE1_USE2DEVIATIONS
LINE1_DEVPERCENT2
USE_AXIS2
DIM_LENGTH2
TEXTANAL_LABEL_MEAS_X
TEXTANAL_LABEL_MEAS_Y
TEXTANAL_LABEL_MEAS_Z
TEXTANAL_LABEL_MEAS_I
TEXTANAL_LABEL_MEAS_J
TEXTANAL_LABEL_MEAS_K
TEXTANAL_LABEL_DEV
TEXTANAL_LABEL_MINMAX
SIMULT_EVAL
SECTION_INDEX
LINE1_OUTTOL
LINE2_OUTTOL
LINE3_OUTTOL
LINE1_MAX
LINE1_MIN
LINE3_NOMINAL
LINE3_MEAS
LINE3_PLUSTOL
LINE3_MINUSTOL
LINE3_MAX
LINE3_MIN
SUMMARY_OUTTOL
SUMMARY_PLUSTOL
SUMMARY_MINUSTOL
SUMMARY_MAX
SUMMARY_MIN
SUMMARY_BONUS
LINE1_BONUS
GRAPH_ANALYSIS_POINT_SIZE
GRAPH_ANALYSIS_PLUS_TOL
GRAPH_ANALYSIS_MINUS_TOL
DIM_AXIS_ITEM_NUMBER
F_ENDING_DEPTH
DIM_ITEM_NUMBER
FEAT_ITEM_NUMBER
COMMAND_TYPE
DEV_MAX
AUTO_DEV_DIRECTION
PROBE_DIRECTION
USER_DEFINED_THEOS
SCALING
USE_SCALING
UID
REF_UID
BA_SOLUTION_TYPE
BA_SOLUTION_OPTIONS
BA_SOLUTION_STATUS
BA_VARIANCE
BA_RMS
BA_WARNINGS
BA_STATION
BA_STATION_X
BA_STATION_Y
BA_STATION_Z
BA_STATION_ROTX
BA_STATION_ROTY
BA_STATION_ROTZ
BA_STATION_ORIENTED
BA_STATION_LOCKED
BA_FEATURE
BA_FEAT_SOURCE
BA_FEAT_RMS
BA_FEAT_POINTING_ERR
BA_FEAT_APEX_ANGLE
BA_FEAT_X
BA_FEAT_Y
BA_FEAT_Z
BA_FEAT_DEV_X
BA_FEAT_DEV_Y
BA_FEAT_DEV_Z
BA_FEAT_DEV3D
NO_APPROACH_VECTOR_FLIP
TARGET_EDGE_START_VALUE
TARGET_EDGE_END_VALUE
TARGET_SURFACE_SURFACE_VARIANCE
RELATIVE_COMMENTS
AUTO_ROTARY
TARGET_COVERAGE
ROTATION_TYPE_2
PROBE_TYPE
TIME_STAMP
ECOND_TEMP
ECOND_PRESSURE
ECOND_HUMIDITY
HIT_RMS
DISPLAY_TRACKER_PARAMETERS
PTDENSITY_TOGGLE
PTDENSITY_UPPERBOUND
PTDENSITY_DEVLIMIT
PTDENSITY_MAXSPAN
TARGET_MEASURE_AT_FOV_CENTER
TARGET_SURFACE_FIND_SURFACE
PROJECTOR
INLINE_LEGACY_REPORT
SINGLE_POINT_DEVIATION
Used to indicate which field into which the text is being put. Type ENUM_FIELD_TYPES enumeration.
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a field type. When using the index property on a field type that can have a variable number of fields, the index must not be greater than the current number of fields (of the type being changed) + 1.

Return Type

Boolean value.

Remarks

Use this command to put text that is displayed in the Edit window for different object fields. The ENUM_FIELD_TYPES enumeration is a large enumeration. Documentation for which field types go with which objects is not given here. You can find this information by:

  1. Creating the desired object in PC-DMIS
  2. Inserting the desired expression in the desired field
  3. Exporting (posting out) the containing part program to BASIC.

If the field already has an expression in it, the expression is removed.

See Also

Command Object


ReDraw Method

ReDraw Method

Description

Redraws the command to show updated properties in the edit window

This method requests that the object be redrawn in the Edit window.

Syntax

Visual Basic
Public Sub ReDraw()

Return Type

None

See Also

Command Object


Remove Method

Remove Method

Description

Removes the current command object from the commands collection object Removes a command from the Commands list.

Syntax

Visual Basic
Public Sub Remove()

Remarks

If there are other objects which depend on the removed command, they are also removed. For example, if the removed command is a measured feature, its hits are removed as well.

See Also

Command Object | Add Method


RemoveExpression Method

RemoveExpression Method
FieldType
Used to indicate the field from which the expression is being removed. Type ENUM_FIELD_TYPES enumeration.
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a field type.

Description

Removes any existing expression from the indicated field of the command. Removes the expression from the indicated field of the command.

Syntax

Visual Basic
Public Sub RemoveExpression( _
   ByVal FieldType As ENUM_FIELD_TYPES, _
   ByVal TypeIndex As Long _
)

Parameters

FieldType
Value Description
ID
REF_ID
LEVEL_REF_ID
ROTATE_REF_ID
ORIGIN_REF_ID
THEO_X
THEO_Y
THEO_Z
THEO_SX
THEO_SY
THEO_SZ
THEO_EX
THEO_EY
THEO_EZ
THEO_I
THEO_J
THEO_K
TARG_X
TARG_Y
TARG_Z
MEAS_X
MEAS_Y
MEAS_Z
MEAS_I
MEAS_J
MEAS_K
MEAS_LENGTH
MEAS_DIAM
MEAS_ANGLE
TARG_I
TARG_J
TARG_K
THEO_DIAM
THEO_WIDTH
THEO_LENGTH
THEO_HEIGHT
THEO_ANGLE
COORD_TYPE
INOUT_TYPE
THICKNESS_TYPE
CIRC_TYPE
SNAP_TYPE
USEPIN_TYPE
MOVE_TYPE
READPOS_TYPE
FINDHOLE_TYPE
RMEAS_TYPE
THEOBF_TYPE
BOUND_TYPE
BF_MATH_TYPE
AUTOFIT_CONSTRAINT
SLOT_MIN_MAX_TYPE
FIND_NOM_AXIS_TYPE
N_INIT_HITS_TYPE
N_PERM_HITS_TYPE
SEARCHMODE_TYPE
MODE_TYPE
MEASURE_ORDER_TYPE
CONE_LENGTH_ANGLE_TYPE
OFFSET_LINE_METHOD
LIN_POL_FILT_TYPE
GEN_FEAT_TYPE
GEN_ALIGN_TYPE
CURVE_TYPE
MEASURED_2D3D_TYPE
THINNING_TOL
HITINT_TYPE
RMEASFEATID
N_HITS
N_ROWS
INIT_HITS
PERM_HITS
F_OFFSET
F_SPACER
F_PITCH
F_THICKNESS
F_DEPTH
F_AUTOMOVE
F_INDENT
F_CORNER_RADIUS
F_INCREMENT
F_TOLERANCE
F_BOXWIDTH
F_BOXLENGTH
F_CIRCRADOUT
F_CIRCRADIN
F_CHECK
F_MAXACCELX
F_MAXACCELY
F_MAXACCELZ
SCAN_ACCELERATION
SCAN_OFFSET_FORCE
MANUAL_FINE_PROBING
F_MOVESPEED
F_TOUCHSPEED
F_SCANSPEED
START_ANG
END_ANG
MIDPOINT_X
MIDPOINT_Y
MIDPOINT_Z
ANGVEC_I
ANGVEC_J
ANGVEC_K
MEASVEC_I
MEASVEC_J
MEASVEC_K
SLOTVEC_I
SLOTVEC_J
SLOTVEC_K
SURFVEC_I
SURFVEC_J
SURFVEC_K
PINVEC_I
PINVEC_J
PINVEC_K
PUNCHVEC_I
PUNCHVEC_J
PUNCHVEC_K
REPORTVEC_I
REPORTVEC_J
REPORTVEC_K
TARGSLOT_I
TARGSLOT_J
TARGSLOT_K
UPDATEVEC_I
UPDATEVEC_J
UPDATEVEC_K
THEO_MINOR_AXIS
TWO_D_THREE_D_TYPE
AXIS
DEST_EXPR
SRC_EXPR
SHOW_IDS
SHOW_DETAILS
WEIGHT
ITEM_USED
USE_AXIS
AVERAGE_ERROR
MEASURE_ALL_FEATURES
REPIERCE_CAD
START_NUM
END_NUM
SKIP_NUM
X_OFFSET
Y_OFFSET
Z_OFFSET
ANGLE_OFFSET
INTERNAL_EXTERNAL
SAVE_ALIGN_CAD_TO_PARTS
FILE_NAME
ALIGN_LIST
WORK_PLANE
DISTANCE
OLD_TIP
NEW_TIP
ROTATION_TYPE
DIM_INFO_ORDER
DIM_INFO_LOC
DIM_INFO_TP_LOC
GRAPH_ANALYSIS
TEXT_ANALYSIS
ARROW_MULTIPLIER
OUTPUT_TYPE
NOMINAL
F_PLUS_TOL
F_MINUS_TOL
TP_MODIFIER
PERP_PARALLEL_TYPE
RADIUS_TYPE
UNIT_TYPE
DIM_LENGTH
PROFILE_FORM_TYPE
PRECISION
MAN_RETRACT
DIM_TEXT
DIM_TEXT_OPTIONS
SHOW_HEADINGS
DEVIATION_SYMBOLS
STANDARD_DEVIATION
DIM_HEADING
GAP_ONLY_TYPE
DISPLAY_ID
DISPLAY_TYPE
POINT_INFO_HEADING
SHOW_POINT_INFO
RET_ONLY_TYPE
COMMENT_FIELD
COMMENT_TYPE
PART_NAME
REVISION_NUMBER
SERIAL_NUMBER
STAT_COUNT
SUB_NAME
READ_WRITE
FILE_POINTER
FIELD_WIDTH
DIGIT_COUNT
LABEL_ID
ERROR_TYPE
ERROR_MODE
DESCRIPTION
INDEX_START
INDEX_END
FILE_COMMAND_TYPE
BUFFER_SIZE_TYPE
FAIL_ON_EXIST
MAX_FORCE
LOW_FORCE
UP_FORCE
TRIGGER_FORCE
PROBE_ACCURACY
POSITIONAL_ACCURACY
NUM_RETURN_DATA
RETURN_SPEED
SCAN_DENSITY
POLAR_VECTOR_COMPENSATION
AUTO_PRINT
ORIGIN
MATERIAL_COEFFICIENT
REF_TEMP
HIGH_THRESHOLD
LOW_THRESHOLD
SENSOR_LIST
FIXTURE_TYPE
MACHINE_TYPE
PROBE_COMP
TIP_I
TIP_J
TIP_K
NORM_RELEARN
FIND_NOMS_TYPE
AUTO_CLEAR_PLANE
SINGLE_POINT
DISPLAY_HITS
CAD_TOLERANCE
OFFSET_TOLERANCE
MIN_INCREMENT
MAX_INCREMENT
MIN_ANGLE
MAX_ANGLE
F_LOCATION
COL132_TYPE
COMMAND_STRING
FLY_MODE_TYPE
STATS_TYPE
STATS_DIR
NEW_STATS_DIR
DATA_READ_LOCK
DATA_WRITE_LOCK
DATA_MEM_PAGES
STAT_NAME_TYPE
STAT_CALC_TYPE
TRANSFER_DIR
DISPLAY_TRACE
TRACE_NAME
TRACE_VALUE
SCAN_CUTPLANEVEC_I
SCAN_CUTPLANEVEC_J
SCAN_CUTPLANEVEC_K
SCAN_INITVEC_I
SCAN_INITVEC_J
SCAN_INITVEC_K
SCAN_AXISVEC_I
SCAN_AXISVEC_J
SCAN_AXISVEC_K
SCAN_ENDVEC_I
SCAN_ENDVEC_J
SCAN_ENDVEC_K
SCAN_INITDIR_I
SCAN_INITDIR_J
SCAN_INITDIR_K
SCAN_CROSS_TOTAL
SCAN_TIME_INCR
SCAN_EDGE_THICK
POS_REPORT_AXIS_X
POS_REPORT_AXIS_Y
POS_REPORT_AXIS_Z
DEV_PERPEN_CENTERLINE
USE_THEO
TARGET_COLOR
THEO_START_ANG
THEO_END_ANG
ONOFF_TYPE
ROW_ID
LOCATOR_BMP
LOCATOR_WAV
DTYPE_LEAPFROGTYPE
DTYPE_LEAPFROGNUMHITS
DTYPE_LEAPFROGFULLPARTIAL
EXCLUSION_ZONE
EXECUTE
AUTOTRIGGERONOFF
AUTOBEEPING
COLUMN_ID
SLOT_NUMBER
AUTOTOLZONE
PROBING_MODE
ANGLE_COMP_TOGGLE
POINTINFO_FILTER_INTERVAL
POINTINFO_FILTER_INTERVAL_NUMBER
FEAT_TYPE
DIM_ID
MEAS_MINOR_AXIS
MEAS_HEIGHT
MEAS_SLOTVEC_I
MEAS_SLOTVEC_J
MEAS_SLOTVEC_K
MEAS_SX
MEAS_SY
MEAS_SZ
MEAS_EX
MEAS_EY
MEAS_EZ
MEAS_WIDTH
NUM_CONTROL_POINTS
U_HITS
V_HITS
NUM_FIT_POINTS
NOMINAL_COLOR
WAVE_FILE
DIM_BONUS
PERUNIT_STEPSIZE
PERUNIT_LENGTH
PERUNIT_WIDTH
DIM_MEASURED
SURFVEC_TARG_I
SURFVEC_TARG_J
SURFVEC_TARG_K
DIM_MAX
EDGEVEC_TARG_I
EDGEVEC_TARG_J
EDGEVEC_TARG_K
DIM_MIN
EDGEVEC_THEO_I
EDGEVEC_THEO_J
EDGEVEC_THEO_K
DIM_DEVIATION
EDGEVEC_MEAS_I
EDGEVEC_MEAS_J
EDGEVEC_MEAS_K
DIM_OUTTOL
T_VALUE
TOOL_X
TOOL_Y
TOOL_Z
TOOL_DIAM
DEV_X
DEV_Y
DEV_Z
DEV_DIAM
ITERATE_COLUMNS
LOAD_TYPE
NUM_ITERATIONS
METHOD_TYPE
SCAN_TECHNIQUE
HIT_TYPE
BOUNDARY_POINT_X
BOUNDARY_POINT_Y
BOUNDARY_POINT_Z
VIDEO_GAIN
VIDEO_OFFSET
VIDEO_LEDLIGHT
VIDEO_LASERLIGHT1
VIDEO_LASERLIGHT2
VIDEO_YORIGIN
VIDEO_YEND
VIDEO_LSEG
VIDEO_XSEG
VIDEO_YSEG
ANGULARITY_NOM_ANGLE
PRINT_TO_FILE
PRINT_TO_PRINTER
PRINT_DRAFTMODE
PRINT_DELETE_RUNS
POINTINFO_FILTER_WORST
POINTINFO_FILTER_WORST_NUMBER
POINTINFO_FILTER_DEVIATION
POINTINFO_FILTER_DEVIATION_NUMBER
POINTINFO_FILTER_OUTTOL
REPORT_SURFVEC_I
REPORT_SURFVEC_J
REPORT_SURFVEC_K
DB_QUERY_OP
DB_SOURCE_NAME
CHART_TYPE
DB_CHART_NAME
DEVIATION_ANGLE
STATS_DATASOURCE
IGNOREMOTIONERRORS_TYPE
THEO_X2
THEO_Y2
THEO_Z2
MEAS_X2
MEAS_Y2
MEAS_Z2
PPROG
TRACE_FILTER
TIME_FILTER
SHOW_SPC_CALCS
SPEC_LIMITS
ZONES
STDDEV
UCL_LCL
HISTOGRAM
GRID
ADDITIONAL_CHART
LINE2_PLANAR_OPEN_IN_X
LINE3_PLANAR_OPEN_IN_X
REGR
CENTER_POINT
SHOW_MORE_SPC_CALCS
SPEC_OFFSET
SOLID
U_L_BOUNDS
TITLE
CPOINT_X
CPOINT_Y
CPOINT_Z
CPOINT_I
CPOINT_J
CPOINT_K
CPOINT_DIAM
CPOINT_SCAN_CROSS_TOTAL
CPOINT_SCAN_DENSITY
CPOINT_F_SCANSPEED
N_CONTROLPOINTS
CPOINT_TYPE
USE_3DFILTER
SCAN_BNDRY_TYPE
CREATE_WEIGHTS
F_SIZE
LINE2_ISPLANAR
LINE2_PLANAR_XTOL
LINE2_PLANAR_YTOL
LINE2_PLANAR_XDEV
LINE2_PLANAR_YDEV
LINE3_ISPLANAR
LINE3_PLANAR_XTOL
LINE3_PLANAR_YTOL
LINE3_PLANAR_XDEV
LINE3_PLANAR_YDEV
CHART_SUB_TYPE
OVERWRITE
OUTPUT_FEATURE_NOMS
OUTPUT_FEAT_W_DIMENS
OUTPUT_DMIS_REPORT
TIME_ARG
TRACE_FILTER_ARG
FIT
STATS_DB_TYPE
IOCHANNEL_NUMBER
IOCHANNEL_PULSE_WIDTH
IOCHANNEL_PULSE_INTERVAL
IOCHANNEL_PULSE_DURATION
GRAPH_OPTION
DB_SOURCE_TYPE
FIND_HOLE_PERCENT
AUTO_ONERROR_TYPE
POS_REPT_DISPLAY_OPTION
TRIGGERTOLERANCE
TRIGGERTOLVALUE
FIXTURE_TOL
START_LABEL
ERROR_LABEL
CONE_CONVEX_TYPE
TRIGGERPLANE
QUERY_SHOW_GRAPHIC_SETTINGS
CALC_STYLE_FILE
FILTER_TYPE
TRACE_VALUE_LIMIT
TARGET_DIRECTION
TARGET_EDGE_POLARITY
BSMETHOD_TYPE
CENTER_ROTATION_THEO
CENTER_ROTATION_MEAS
ARTICULATEDARM_TYPE
LEFTYRIGHTY_CONFIG
ABOVEBELOW_CONFIG
NOFLIPFLIP_CONFIG
HIGH_ACCURACY
SURFACE
MAGNIFICATION
MINOR_WORD_TOGGLE
PERCENTAGE
THRESHOLD
N_SIDES
TARGET_SURFACE_ILLUM
MEAN
CAD_COMP
SHOW_ROW
SHOW_COLUMN
TARGET_SURFACE_SENSILIGHT
TARGET_SURFACE_WIDTH
TARGET_SURFACE_HEIGHT
TARGET_SURFACE_RANGE
TARGET_SURFACE_DURATION
TARGET_SURFACE_MODE
TARGET_SURFACE_HIACC
SCREEN_CAPTURE_SCALE
SCREEN_CAPTURE_QUALITY
TARGET_EDGE_SIZE
TARGET_EDGE_ILLUM
TARGET_EDGE_TOL
TARGET_EDGE_STRENGTH
TARGET_EDGE_DENSITY
TARGET_EDGE_TYPE
DISPLAY_ADVANCED_PARAMETERS
TARGET_SURFACE_TYPE
VOID_DETECT
TARG_SX
TARG_SY
TARG_SZ
TARG_EX
TARG_EY
TARG_EZ
PATTERN_TYPE
TARGET_EDGE_ANGLE
PROGRAM_GAGE_FEAT_TYPE
PROGRAM_GAGE_TYPE
TARGET_FOCUS
RMEASFEATIDX
RMEASFEATIDY
RMEASFEATIDZ
FINDNOMS_BESTFIT
FINDNOMS_ONLYSELECTED
TEMPX
TEMPY
TEMPZ
TEMPP
AUTO_PH9
MANUAL_PREPOSITION
SCREEN_CAPTURE_TYPE
SCREEN_CAPTURE_AUTO_TYPE
TARGET_EDGE_EDGESELECT
TARGET_EDGE_EDGENUM
DELETE_TYPE
SCREEN_CAPTURE_AUTO_TIME
USE_HSSDAT
USE_STARTENDDELAY
COP_FILTER
COP_SIZE
COP_TYPE
SURFVEC_MEAS_I
SURFVEC_MEAS_J
SURFVEC_MEAS_K
TARGET_EDGE_UNDERSCAN
PROFILE_TYPE
THEO_FLUSH
MEAS_FLUSH
THEO_GAP
MEAS_GAP
THEO_DEPTH
MEAS_DEPTH
TARGET_BLOB_TYPE
LASER_STRIPE_OVERLAP
LASER_STRIPE_OVERSCAN
LASER_FREQUENCY
TARGET_FILTER_OUTLIER
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD
SLOT_TYPE
TARGET_TYPE
THEO_R
THEO_A
THEO_H
MEAS_R
MEAS_A
MEAS_H
TARG_R
TARG_A
TARG_H
THEO_SR
THEO_SA
THEO_SH
THEO_ER
THEO_EA
THEO_EH
MEAS_SR
MEAS_SA
MEAS_SH
MEAS_ER
MEAS_EA
MEAS_EH
TARG_SR
TARG_SA
TARG_SH
TARG_ER
TARG_EA
TARG_EH
TARGET_EDGE_SENSILIGHT
F_THICKNESS_EDGE
THICKNESS_TYPE_EDGE
LASER_EXPOSURE
LASER_INTENSITY
ANGLE_OFFSET_2
LASER_FILTER_NEIGHBOR_NUM
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD
LASER_FILTER_TOL_ABOVE
LASER_FILTER_TOL_BELOW
LASER_FILTER_TOL_RIGHT
LASER_CLIP_UP_DIST
LASER_CLIP_LOW_DIST
LASER_PIXEL_TOGGLE
LASER_FILTER_TOGGLE
DISPLAY_PROBE_PARAMETERS
THEO_R2
THEO_A2
THEO_H2
MEAS_R2
MEAS_A2
MEAS_H2
LASER_CLIP_LEFT_DIST
LASER_CLIP_RIGHT_DIST
COP_FILETYPE
COP_SELECTIONTYPE
COP_COLORMAP
COP_COPLEMENT
OPERTYPE
COP_BOOLEANTYPE
COP_IMPORTFILETYPE
MEAS_START_ANG
MEAS_END_ANG
ISLAND_DIAM
ISLAND_LENGTH
ISLAND_WIDTH
ISLAND_X
ISLAND_Y
ISLAND_Z
ISLAND_I
ISLAND_J
ISLAND_K
ISLAND_AI
ISLAND_AJ
ISLAND_AK
ISLAND_TYPE
ISLAND_CLEARANCEDIST
RPT_DIMENSION_TABLES
SUMMARY_DEV
DRF_TBLHDR
LINE1_TBLHDR
LINE1_CALLOUT
LINE1_COLUMN_HDR
LINE1_FEATNAME
LINE1_NOMINAL
LINE1_MEAS
LINE1_PLUSTOL
LINE1_MINUSTOL
LINE1_DEV
LINE1_DEVPERCENT
LINE1_ISBILATERAL
LINE1_NUMZONES
LINE2_TBLHDR
LINE2_CALLOUT
LINE2_COLUMN_HDR
LINE2_FEATNAME
LINE2_BONUS
LINE2_TOL
LINE2_DATUMSHFT
LINE2_UNUSEDZONE
LINE2_DEV
LINE2_DEVANG
LINE2_DEVPERCENT
LINE3_TBLHDR
LINE3_CALLOUT
LINE3_COLUMN_HDR
LINE3_FEATNAME
LINE3_BONUS
LINE3_TOL
LINE3_DATUMSHFT
LINE3_UNUSEDZONE
LINE3_DEV
LINE3_DEVANG
LINE3_DEVPERCENT
DRF_COLUMN_HDR
DRF_SEGNAME
DRF_SHIFTX
DRF_SHIFTY
DRF_SHIFTZ
DRF_ROTATIONX
DRF_ROTATIONY
DRF_ROTATIONZ
SUMMARY_COLUMN_HDR
SUMMARY_FEAT
LINE2_AXIS
LINE2_NOMINAL
LINE2_MEAS
SUMMARY_TBLHDR
SUMMARY_AXIS
SUMMARY_NOMINAL
SUMMARY_MEAS
LINE2_PLUSTOL
LINE2_MINUSTOL
LINE2_MAX
LINE2_MIN
LINE2_ISBILATERAL
LINE2_NUMZONES
LINE3_ISBILATERAL
LINE3_NUMZONES
DIM_RPT_COLUMN_HDR
DIM_RPT_ISDATUM
DIM_RPT_DATUM
DIM_RPT_GRAPHIC
DIM_RPT_DEVPERCENT
DIM_RPT_ISBILATERAL
DIM_RPT_NUMZONES
GDT_SYMBOL
COMMENT_INPUT
TARGET_EDGE_WIDTH
TARGET_EDGE_HEIGHT
TARGET_EDGE_EDGEDETECT
TARGET_EDGE_FILTER_CLEAN
TARGET_EDGE_FILTER_CLEAN_STRENGTH
TARGET_EDGE_FILTER_AREA
TARGET_EDGE_FILTER_AREA_SIZE
TARGET_EDGE_GRADIENT
THEO_PERIMETER
MEAS_PERIMETER
THEO_AREA
MEAS_AREA
TARGET_SURFACE_CROSSHAIR_HEIGHT
SHOW_NOMS
COMPOSITE
DATUM2
TP_MODIFIER2
DESCRIPTION2
SHOW_OPTIONS
LEADER_LINE_ID
GDT_SYMBOL2
DATUM1_MODIFIER
DATUM2_MODIFIER
DATUM3_MODIFIER
DATUM1_MODIFIER2
DATUM2_MODIFIER2
DATUM3_MODIFIER2
DIM_RPT_DEVPERCENT_NOM
DIM_RPT_USETWODEVIATIONS
DIM_RPT_DEVPERCENT2
LINE2_DEVPERCENT_NOM
LINE2_USE2DEVIATIONS
LINE2_DEVPERCENT2
LINE3_DEVPERCENT_NOM
LINE3_USE2DEVIATIONS
LINE3_DEVPERCENT2
AXIS_PLUS_TOL
AXIS_MINUS_TOL
AXIS_NOMINAL
AXIS_DESCRIPTION
LINE1_DEVPERCENT_NOM
LINE1_USE2DEVIATIONS
LINE1_DEVPERCENT2
USE_AXIS2
DIM_LENGTH2
TEXTANAL_LABEL_MEAS_X
TEXTANAL_LABEL_MEAS_Y
TEXTANAL_LABEL_MEAS_Z
TEXTANAL_LABEL_MEAS_I
TEXTANAL_LABEL_MEAS_J
TEXTANAL_LABEL_MEAS_K
TEXTANAL_LABEL_DEV
TEXTANAL_LABEL_MINMAX
SIMULT_EVAL
SECTION_INDEX
LINE1_OUTTOL
LINE2_OUTTOL
LINE3_OUTTOL
LINE1_MAX
LINE1_MIN
LINE3_NOMINAL
LINE3_MEAS
LINE3_PLUSTOL
LINE3_MINUSTOL
LINE3_MAX
LINE3_MIN
SUMMARY_OUTTOL
SUMMARY_PLUSTOL
SUMMARY_MINUSTOL
SUMMARY_MAX
SUMMARY_MIN
SUMMARY_BONUS
LINE1_BONUS
GRAPH_ANALYSIS_POINT_SIZE
GRAPH_ANALYSIS_PLUS_TOL
GRAPH_ANALYSIS_MINUS_TOL
DIM_AXIS_ITEM_NUMBER
F_ENDING_DEPTH
DIM_ITEM_NUMBER
FEAT_ITEM_NUMBER
COMMAND_TYPE
DEV_MAX
AUTO_DEV_DIRECTION
PROBE_DIRECTION
USER_DEFINED_THEOS
SCALING
USE_SCALING
UID
REF_UID
BA_SOLUTION_TYPE
BA_SOLUTION_OPTIONS
BA_SOLUTION_STATUS
BA_VARIANCE
BA_RMS
BA_WARNINGS
BA_STATION
BA_STATION_X
BA_STATION_Y
BA_STATION_Z
BA_STATION_ROTX
BA_STATION_ROTY
BA_STATION_ROTZ
BA_STATION_ORIENTED
BA_STATION_LOCKED
BA_FEATURE
BA_FEAT_SOURCE
BA_FEAT_RMS
BA_FEAT_POINTING_ERR
BA_FEAT_APEX_ANGLE
BA_FEAT_X
BA_FEAT_Y
BA_FEAT_Z
BA_FEAT_DEV_X
BA_FEAT_DEV_Y
BA_FEAT_DEV_Z
BA_FEAT_DEV3D
NO_APPROACH_VECTOR_FLIP
TARGET_EDGE_START_VALUE
TARGET_EDGE_END_VALUE
TARGET_SURFACE_SURFACE_VARIANCE
RELATIVE_COMMENTS
AUTO_ROTARY
TARGET_COVERAGE
ROTATION_TYPE_2
PROBE_TYPE
TIME_STAMP
ECOND_TEMP
ECOND_PRESSURE
ECOND_HUMIDITY
HIT_RMS
DISPLAY_TRACKER_PARAMETERS
PTDENSITY_TOGGLE
PTDENSITY_UPPERBOUND
PTDENSITY_DEVLIMIT
PTDENSITY_MAXSPAN
TARGET_MEASURE_AT_FOV_CENTER
TARGET_SURFACE_FIND_SURFACE
PROJECTOR
INLINE_LEGACY_REPORT
SINGLE_POINT_DEVIATION
Used to indicate the field from which the expression is being removed. Type ENUM_FIELD_TYPES enumeration.
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a field type.

Remarks

Use this command to remove expressions from different object fields. The ENUM_FIELD_TYPES enumeration is a large enumeration. Documentation for which field types go with which objects is not given here. You can find this information by:

  1. Creating the desired object in PC-DMIS
  2. Inserting the desired expression in the desired field
  3. Exporting (posting out) the containing part program to BASIC.

See Also

Command Object | SetExpression Method | GetExpression Method | PutText Method


SetBothArms Method

SetBothArms Method

Description

Sets command to be executed by Both Arms, returns false if command is a two state command

Syntax

Visual Basic
Public Function SetBothArms() As Boolean

See Also

Command Object


SetExpression Method

SetExpression Method
Expression
String to which to set the expression.
FieldType
Used to indicate which field the expression is being set for. Type ENUM_FIELD_TYPES enumeration.
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a field type.

Description

Sets the expression for the indicated field of the command. Sets the expression of the indicated field of the command.

Syntax

Visual Basic
Public Function SetExpression( _
   ByVal Expression As String, _
   ByVal FieldType As ENUM_FIELD_TYPES, _
   ByVal TypeIndex As Long _
) As Boolean

Parameters

Expression
String to which to set the expression.
FieldType
Value Description
ID
REF_ID
LEVEL_REF_ID
ROTATE_REF_ID
ORIGIN_REF_ID
THEO_X
THEO_Y
THEO_Z
THEO_SX
THEO_SY
THEO_SZ
THEO_EX
THEO_EY
THEO_EZ
THEO_I
THEO_J
THEO_K
TARG_X
TARG_Y
TARG_Z
MEAS_X
MEAS_Y
MEAS_Z
MEAS_I
MEAS_J
MEAS_K
MEAS_LENGTH
MEAS_DIAM
MEAS_ANGLE
TARG_I
TARG_J
TARG_K
THEO_DIAM
THEO_WIDTH
THEO_LENGTH
THEO_HEIGHT
THEO_ANGLE
COORD_TYPE
INOUT_TYPE
THICKNESS_TYPE
CIRC_TYPE
SNAP_TYPE
USEPIN_TYPE
MOVE_TYPE
READPOS_TYPE
FINDHOLE_TYPE
RMEAS_TYPE
THEOBF_TYPE
BOUND_TYPE
BF_MATH_TYPE
AUTOFIT_CONSTRAINT
SLOT_MIN_MAX_TYPE
FIND_NOM_AXIS_TYPE
N_INIT_HITS_TYPE
N_PERM_HITS_TYPE
SEARCHMODE_TYPE
MODE_TYPE
MEASURE_ORDER_TYPE
CONE_LENGTH_ANGLE_TYPE
OFFSET_LINE_METHOD
LIN_POL_FILT_TYPE
GEN_FEAT_TYPE
GEN_ALIGN_TYPE
CURVE_TYPE
MEASURED_2D3D_TYPE
THINNING_TOL
HITINT_TYPE
RMEASFEATID
N_HITS
N_ROWS
INIT_HITS
PERM_HITS
F_OFFSET
F_SPACER
F_PITCH
F_THICKNESS
F_DEPTH
F_AUTOMOVE
F_INDENT
F_CORNER_RADIUS
F_INCREMENT
F_TOLERANCE
F_BOXWIDTH
F_BOXLENGTH
F_CIRCRADOUT
F_CIRCRADIN
F_CHECK
F_MAXACCELX
F_MAXACCELY
F_MAXACCELZ
SCAN_ACCELERATION
SCAN_OFFSET_FORCE
MANUAL_FINE_PROBING
F_MOVESPEED
F_TOUCHSPEED
F_SCANSPEED
START_ANG
END_ANG
MIDPOINT_X
MIDPOINT_Y
MIDPOINT_Z
ANGVEC_I
ANGVEC_J
ANGVEC_K
MEASVEC_I
MEASVEC_J
MEASVEC_K
SLOTVEC_I
SLOTVEC_J
SLOTVEC_K
SURFVEC_I
SURFVEC_J
SURFVEC_K
PINVEC_I
PINVEC_J
PINVEC_K
PUNCHVEC_I
PUNCHVEC_J
PUNCHVEC_K
REPORTVEC_I
REPORTVEC_J
REPORTVEC_K
TARGSLOT_I
TARGSLOT_J
TARGSLOT_K
UPDATEVEC_I
UPDATEVEC_J
UPDATEVEC_K
THEO_MINOR_AXIS
TWO_D_THREE_D_TYPE
AXIS
DEST_EXPR
SRC_EXPR
SHOW_IDS
SHOW_DETAILS
WEIGHT
ITEM_USED
USE_AXIS
AVERAGE_ERROR
MEASURE_ALL_FEATURES
REPIERCE_CAD
START_NUM
END_NUM
SKIP_NUM
X_OFFSET
Y_OFFSET
Z_OFFSET
ANGLE_OFFSET
INTERNAL_EXTERNAL
SAVE_ALIGN_CAD_TO_PARTS
FILE_NAME
ALIGN_LIST
WORK_PLANE
DISTANCE
OLD_TIP
NEW_TIP
ROTATION_TYPE
DIM_INFO_ORDER
DIM_INFO_LOC
DIM_INFO_TP_LOC
GRAPH_ANALYSIS
TEXT_ANALYSIS
ARROW_MULTIPLIER
OUTPUT_TYPE
NOMINAL
F_PLUS_TOL
F_MINUS_TOL
TP_MODIFIER
PERP_PARALLEL_TYPE
RADIUS_TYPE
UNIT_TYPE
DIM_LENGTH
PROFILE_FORM_TYPE
PRECISION
MAN_RETRACT
DIM_TEXT
DIM_TEXT_OPTIONS
SHOW_HEADINGS
DEVIATION_SYMBOLS
STANDARD_DEVIATION
DIM_HEADING
GAP_ONLY_TYPE
DISPLAY_ID
DISPLAY_TYPE
POINT_INFO_HEADING
SHOW_POINT_INFO
RET_ONLY_TYPE
COMMENT_FIELD
COMMENT_TYPE
PART_NAME
REVISION_NUMBER
SERIAL_NUMBER
STAT_COUNT
SUB_NAME
READ_WRITE
FILE_POINTER
FIELD_WIDTH
DIGIT_COUNT
LABEL_ID
ERROR_TYPE
ERROR_MODE
DESCRIPTION
INDEX_START
INDEX_END
FILE_COMMAND_TYPE
BUFFER_SIZE_TYPE
FAIL_ON_EXIST
MAX_FORCE
LOW_FORCE
UP_FORCE
TRIGGER_FORCE
PROBE_ACCURACY
POSITIONAL_ACCURACY
NUM_RETURN_DATA
RETURN_SPEED
SCAN_DENSITY
POLAR_VECTOR_COMPENSATION
AUTO_PRINT
ORIGIN
MATERIAL_COEFFICIENT
REF_TEMP
HIGH_THRESHOLD
LOW_THRESHOLD
SENSOR_LIST
FIXTURE_TYPE
MACHINE_TYPE
PROBE_COMP
TIP_I
TIP_J
TIP_K
NORM_RELEARN
FIND_NOMS_TYPE
AUTO_CLEAR_PLANE
SINGLE_POINT
DISPLAY_HITS
CAD_TOLERANCE
OFFSET_TOLERANCE
MIN_INCREMENT
MAX_INCREMENT
MIN_ANGLE
MAX_ANGLE
F_LOCATION
COL132_TYPE
COMMAND_STRING
FLY_MODE_TYPE
STATS_TYPE
STATS_DIR
NEW_STATS_DIR
DATA_READ_LOCK
DATA_WRITE_LOCK
DATA_MEM_PAGES
STAT_NAME_TYPE
STAT_CALC_TYPE
TRANSFER_DIR
DISPLAY_TRACE
TRACE_NAME
TRACE_VALUE
SCAN_CUTPLANEVEC_I
SCAN_CUTPLANEVEC_J
SCAN_CUTPLANEVEC_K
SCAN_INITVEC_I
SCAN_INITVEC_J
SCAN_INITVEC_K
SCAN_AXISVEC_I
SCAN_AXISVEC_J
SCAN_AXISVEC_K
SCAN_ENDVEC_I
SCAN_ENDVEC_J
SCAN_ENDVEC_K
SCAN_INITDIR_I
SCAN_INITDIR_J
SCAN_INITDIR_K
SCAN_CROSS_TOTAL
SCAN_TIME_INCR
SCAN_EDGE_THICK
POS_REPORT_AXIS_X
POS_REPORT_AXIS_Y
POS_REPORT_AXIS_Z
DEV_PERPEN_CENTERLINE
USE_THEO
TARGET_COLOR
THEO_START_ANG
THEO_END_ANG
ONOFF_TYPE
ROW_ID
LOCATOR_BMP
LOCATOR_WAV
DTYPE_LEAPFROGTYPE
DTYPE_LEAPFROGNUMHITS
DTYPE_LEAPFROGFULLPARTIAL
EXCLUSION_ZONE
EXECUTE
AUTOTRIGGERONOFF
AUTOBEEPING
COLUMN_ID
SLOT_NUMBER
AUTOTOLZONE
PROBING_MODE
ANGLE_COMP_TOGGLE
POINTINFO_FILTER_INTERVAL
POINTINFO_FILTER_INTERVAL_NUMBER
FEAT_TYPE
DIM_ID
MEAS_MINOR_AXIS
MEAS_HEIGHT
MEAS_SLOTVEC_I
MEAS_SLOTVEC_J
MEAS_SLOTVEC_K
MEAS_SX
MEAS_SY
MEAS_SZ
MEAS_EX
MEAS_EY
MEAS_EZ
MEAS_WIDTH
NUM_CONTROL_POINTS
U_HITS
V_HITS
NUM_FIT_POINTS
NOMINAL_COLOR
WAVE_FILE
DIM_BONUS
PERUNIT_STEPSIZE
PERUNIT_LENGTH
PERUNIT_WIDTH
DIM_MEASURED
SURFVEC_TARG_I
SURFVEC_TARG_J
SURFVEC_TARG_K
DIM_MAX
EDGEVEC_TARG_I
EDGEVEC_TARG_J
EDGEVEC_TARG_K
DIM_MIN
EDGEVEC_THEO_I
EDGEVEC_THEO_J
EDGEVEC_THEO_K
DIM_DEVIATION
EDGEVEC_MEAS_I
EDGEVEC_MEAS_J
EDGEVEC_MEAS_K
DIM_OUTTOL
T_VALUE
TOOL_X
TOOL_Y
TOOL_Z
TOOL_DIAM
DEV_X
DEV_Y
DEV_Z
DEV_DIAM
ITERATE_COLUMNS
LOAD_TYPE
NUM_ITERATIONS
METHOD_TYPE
SCAN_TECHNIQUE
HIT_TYPE
BOUNDARY_POINT_X
BOUNDARY_POINT_Y
BOUNDARY_POINT_Z
VIDEO_GAIN
VIDEO_OFFSET
VIDEO_LEDLIGHT
VIDEO_LASERLIGHT1
VIDEO_LASERLIGHT2
VIDEO_YORIGIN
VIDEO_YEND
VIDEO_LSEG
VIDEO_XSEG
VIDEO_YSEG
ANGULARITY_NOM_ANGLE
PRINT_TO_FILE
PRINT_TO_PRINTER
PRINT_DRAFTMODE
PRINT_DELETE_RUNS
POINTINFO_FILTER_WORST
POINTINFO_FILTER_WORST_NUMBER
POINTINFO_FILTER_DEVIATION
POINTINFO_FILTER_DEVIATION_NUMBER
POINTINFO_FILTER_OUTTOL
REPORT_SURFVEC_I
REPORT_SURFVEC_J
REPORT_SURFVEC_K
DB_QUERY_OP
DB_SOURCE_NAME
CHART_TYPE
DB_CHART_NAME
DEVIATION_ANGLE
STATS_DATASOURCE
IGNOREMOTIONERRORS_TYPE
THEO_X2
THEO_Y2
THEO_Z2
MEAS_X2
MEAS_Y2
MEAS_Z2
PPROG
TRACE_FILTER
TIME_FILTER
SHOW_SPC_CALCS
SPEC_LIMITS
ZONES
STDDEV
UCL_LCL
HISTOGRAM
GRID
ADDITIONAL_CHART
LINE2_PLANAR_OPEN_IN_X
LINE3_PLANAR_OPEN_IN_X
REGR
CENTER_POINT
SHOW_MORE_SPC_CALCS
SPEC_OFFSET
SOLID
U_L_BOUNDS
TITLE
CPOINT_X
CPOINT_Y
CPOINT_Z
CPOINT_I
CPOINT_J
CPOINT_K
CPOINT_DIAM
CPOINT_SCAN_CROSS_TOTAL
CPOINT_SCAN_DENSITY
CPOINT_F_SCANSPEED
N_CONTROLPOINTS
CPOINT_TYPE
USE_3DFILTER
SCAN_BNDRY_TYPE
CREATE_WEIGHTS
F_SIZE
LINE2_ISPLANAR
LINE2_PLANAR_XTOL
LINE2_PLANAR_YTOL
LINE2_PLANAR_XDEV
LINE2_PLANAR_YDEV
LINE3_ISPLANAR
LINE3_PLANAR_XTOL
LINE3_PLANAR_YTOL
LINE3_PLANAR_XDEV
LINE3_PLANAR_YDEV
CHART_SUB_TYPE
OVERWRITE
OUTPUT_FEATURE_NOMS
OUTPUT_FEAT_W_DIMENS
OUTPUT_DMIS_REPORT
TIME_ARG
TRACE_FILTER_ARG
FIT
STATS_DB_TYPE
IOCHANNEL_NUMBER
IOCHANNEL_PULSE_WIDTH
IOCHANNEL_PULSE_INTERVAL
IOCHANNEL_PULSE_DURATION
GRAPH_OPTION
DB_SOURCE_TYPE
FIND_HOLE_PERCENT
AUTO_ONERROR_TYPE
POS_REPT_DISPLAY_OPTION
TRIGGERTOLERANCE
TRIGGERTOLVALUE
FIXTURE_TOL
START_LABEL
ERROR_LABEL
CONE_CONVEX_TYPE
TRIGGERPLANE
QUERY_SHOW_GRAPHIC_SETTINGS
CALC_STYLE_FILE
FILTER_TYPE
TRACE_VALUE_LIMIT
TARGET_DIRECTION
TARGET_EDGE_POLARITY
BSMETHOD_TYPE
CENTER_ROTATION_THEO
CENTER_ROTATION_MEAS
ARTICULATEDARM_TYPE
LEFTYRIGHTY_CONFIG
ABOVEBELOW_CONFIG
NOFLIPFLIP_CONFIG
HIGH_ACCURACY
SURFACE
MAGNIFICATION
MINOR_WORD_TOGGLE
PERCENTAGE
THRESHOLD
N_SIDES
TARGET_SURFACE_ILLUM
MEAN
CAD_COMP
SHOW_ROW
SHOW_COLUMN
TARGET_SURFACE_SENSILIGHT
TARGET_SURFACE_WIDTH
TARGET_SURFACE_HEIGHT
TARGET_SURFACE_RANGE
TARGET_SURFACE_DURATION
TARGET_SURFACE_MODE
TARGET_SURFACE_HIACC
SCREEN_CAPTURE_SCALE
SCREEN_CAPTURE_QUALITY
TARGET_EDGE_SIZE
TARGET_EDGE_ILLUM
TARGET_EDGE_TOL
TARGET_EDGE_STRENGTH
TARGET_EDGE_DENSITY
TARGET_EDGE_TYPE
DISPLAY_ADVANCED_PARAMETERS
TARGET_SURFACE_TYPE
VOID_DETECT
TARG_SX
TARG_SY
TARG_SZ
TARG_EX
TARG_EY
TARG_EZ
PATTERN_TYPE
TARGET_EDGE_ANGLE
PROGRAM_GAGE_FEAT_TYPE
PROGRAM_GAGE_TYPE
TARGET_FOCUS
RMEASFEATIDX
RMEASFEATIDY
RMEASFEATIDZ
FINDNOMS_BESTFIT
FINDNOMS_ONLYSELECTED
TEMPX
TEMPY
TEMPZ
TEMPP
AUTO_PH9
MANUAL_PREPOSITION
SCREEN_CAPTURE_TYPE
SCREEN_CAPTURE_AUTO_TYPE
TARGET_EDGE_EDGESELECT
TARGET_EDGE_EDGENUM
DELETE_TYPE
SCREEN_CAPTURE_AUTO_TIME
USE_HSSDAT
USE_STARTENDDELAY
COP_FILTER
COP_SIZE
COP_TYPE
SURFVEC_MEAS_I
SURFVEC_MEAS_J
SURFVEC_MEAS_K
TARGET_EDGE_UNDERSCAN
PROFILE_TYPE
THEO_FLUSH
MEAS_FLUSH
THEO_GAP
MEAS_GAP
THEO_DEPTH
MEAS_DEPTH
TARGET_BLOB_TYPE
LASER_STRIPE_OVERLAP
LASER_STRIPE_OVERSCAN
LASER_FREQUENCY
TARGET_FILTER_OUTLIER
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD
SLOT_TYPE
TARGET_TYPE
THEO_R
THEO_A
THEO_H
MEAS_R
MEAS_A
MEAS_H
TARG_R
TARG_A
TARG_H
THEO_SR
THEO_SA
THEO_SH
THEO_ER
THEO_EA
THEO_EH
MEAS_SR
MEAS_SA
MEAS_SH
MEAS_ER
MEAS_EA
MEAS_EH
TARG_SR
TARG_SA
TARG_SH
TARG_ER
TARG_EA
TARG_EH
TARGET_EDGE_SENSILIGHT
F_THICKNESS_EDGE
THICKNESS_TYPE_EDGE
LASER_EXPOSURE
LASER_INTENSITY
ANGLE_OFFSET_2
LASER_FILTER_NEIGHBOR_NUM
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD
LASER_FILTER_TOL_ABOVE
LASER_FILTER_TOL_BELOW
LASER_FILTER_TOL_RIGHT
LASER_CLIP_UP_DIST
LASER_CLIP_LOW_DIST
LASER_PIXEL_TOGGLE
LASER_FILTER_TOGGLE
DISPLAY_PROBE_PARAMETERS
THEO_R2
THEO_A2
THEO_H2
MEAS_R2
MEAS_A2
MEAS_H2
LASER_CLIP_LEFT_DIST
LASER_CLIP_RIGHT_DIST
COP_FILETYPE
COP_SELECTIONTYPE
COP_COLORMAP
COP_COPLEMENT
OPERTYPE
COP_BOOLEANTYPE
COP_IMPORTFILETYPE
MEAS_START_ANG
MEAS_END_ANG
ISLAND_DIAM
ISLAND_LENGTH
ISLAND_WIDTH
ISLAND_X
ISLAND_Y
ISLAND_Z
ISLAND_I
ISLAND_J
ISLAND_K
ISLAND_AI
ISLAND_AJ
ISLAND_AK
ISLAND_TYPE
ISLAND_CLEARANCEDIST
RPT_DIMENSION_TABLES
SUMMARY_DEV
DRF_TBLHDR
LINE1_TBLHDR
LINE1_CALLOUT
LINE1_COLUMN_HDR
LINE1_FEATNAME
LINE1_NOMINAL
LINE1_MEAS
LINE1_PLUSTOL
LINE1_MINUSTOL
LINE1_DEV
LINE1_DEVPERCENT
LINE1_ISBILATERAL
LINE1_NUMZONES
LINE2_TBLHDR
LINE2_CALLOUT
LINE2_COLUMN_HDR
LINE2_FEATNAME
LINE2_BONUS
LINE2_TOL
LINE2_DATUMSHFT
LINE2_UNUSEDZONE
LINE2_DEV
LINE2_DEVANG
LINE2_DEVPERCENT
LINE3_TBLHDR
LINE3_CALLOUT
LINE3_COLUMN_HDR
LINE3_FEATNAME
LINE3_BONUS
LINE3_TOL
LINE3_DATUMSHFT
LINE3_UNUSEDZONE
LINE3_DEV
LINE3_DEVANG
LINE3_DEVPERCENT
DRF_COLUMN_HDR
DRF_SEGNAME
DRF_SHIFTX
DRF_SHIFTY
DRF_SHIFTZ
DRF_ROTATIONX
DRF_ROTATIONY
DRF_ROTATIONZ
SUMMARY_COLUMN_HDR
SUMMARY_FEAT
LINE2_AXIS
LINE2_NOMINAL
LINE2_MEAS
SUMMARY_TBLHDR
SUMMARY_AXIS
SUMMARY_NOMINAL
SUMMARY_MEAS
LINE2_PLUSTOL
LINE2_MINUSTOL
LINE2_MAX
LINE2_MIN
LINE2_ISBILATERAL
LINE2_NUMZONES
LINE3_ISBILATERAL
LINE3_NUMZONES
DIM_RPT_COLUMN_HDR
DIM_RPT_ISDATUM
DIM_RPT_DATUM
DIM_RPT_GRAPHIC
DIM_RPT_DEVPERCENT
DIM_RPT_ISBILATERAL
DIM_RPT_NUMZONES
GDT_SYMBOL
COMMENT_INPUT
TARGET_EDGE_WIDTH
TARGET_EDGE_HEIGHT
TARGET_EDGE_EDGEDETECT
TARGET_EDGE_FILTER_CLEAN
TARGET_EDGE_FILTER_CLEAN_STRENGTH
TARGET_EDGE_FILTER_AREA
TARGET_EDGE_FILTER_AREA_SIZE
TARGET_EDGE_GRADIENT
THEO_PERIMETER
MEAS_PERIMETER
THEO_AREA
MEAS_AREA
TARGET_SURFACE_CROSSHAIR_HEIGHT
SHOW_NOMS
COMPOSITE
DATUM2
TP_MODIFIER2
DESCRIPTION2
SHOW_OPTIONS
LEADER_LINE_ID
GDT_SYMBOL2
DATUM1_MODIFIER
DATUM2_MODIFIER
DATUM3_MODIFIER
DATUM1_MODIFIER2
DATUM2_MODIFIER2
DATUM3_MODIFIER2
DIM_RPT_DEVPERCENT_NOM
DIM_RPT_USETWODEVIATIONS
DIM_RPT_DEVPERCENT2
LINE2_DEVPERCENT_NOM
LINE2_USE2DEVIATIONS
LINE2_DEVPERCENT2
LINE3_DEVPERCENT_NOM
LINE3_USE2DEVIATIONS
LINE3_DEVPERCENT2
AXIS_PLUS_TOL
AXIS_MINUS_TOL
AXIS_NOMINAL
AXIS_DESCRIPTION
LINE1_DEVPERCENT_NOM
LINE1_USE2DEVIATIONS
LINE1_DEVPERCENT2
USE_AXIS2
DIM_LENGTH2
TEXTANAL_LABEL_MEAS_X
TEXTANAL_LABEL_MEAS_Y
TEXTANAL_LABEL_MEAS_Z
TEXTANAL_LABEL_MEAS_I
TEXTANAL_LABEL_MEAS_J
TEXTANAL_LABEL_MEAS_K
TEXTANAL_LABEL_DEV
TEXTANAL_LABEL_MINMAX
SIMULT_EVAL
SECTION_INDEX
LINE1_OUTTOL
LINE2_OUTTOL
LINE3_OUTTOL
LINE1_MAX
LINE1_MIN
LINE3_NOMINAL
LINE3_MEAS
LINE3_PLUSTOL
LINE3_MINUSTOL
LINE3_MAX
LINE3_MIN
SUMMARY_OUTTOL
SUMMARY_PLUSTOL
SUMMARY_MINUSTOL
SUMMARY_MAX
SUMMARY_MIN
SUMMARY_BONUS
LINE1_BONUS
GRAPH_ANALYSIS_POINT_SIZE
GRAPH_ANALYSIS_PLUS_TOL
GRAPH_ANALYSIS_MINUS_TOL
DIM_AXIS_ITEM_NUMBER
F_ENDING_DEPTH
DIM_ITEM_NUMBER
FEAT_ITEM_NUMBER
COMMAND_TYPE
DEV_MAX
AUTO_DEV_DIRECTION
PROBE_DIRECTION
USER_DEFINED_THEOS
SCALING
USE_SCALING
UID
REF_UID
BA_SOLUTION_TYPE
BA_SOLUTION_OPTIONS
BA_SOLUTION_STATUS
BA_VARIANCE
BA_RMS
BA_WARNINGS
BA_STATION
BA_STATION_X
BA_STATION_Y
BA_STATION_Z
BA_STATION_ROTX
BA_STATION_ROTY
BA_STATION_ROTZ
BA_STATION_ORIENTED
BA_STATION_LOCKED
BA_FEATURE
BA_FEAT_SOURCE
BA_FEAT_RMS
BA_FEAT_POINTING_ERR
BA_FEAT_APEX_ANGLE
BA_FEAT_X
BA_FEAT_Y
BA_FEAT_Z
BA_FEAT_DEV_X
BA_FEAT_DEV_Y
BA_FEAT_DEV_Z
BA_FEAT_DEV3D
NO_APPROACH_VECTOR_FLIP
TARGET_EDGE_START_VALUE
TARGET_EDGE_END_VALUE
TARGET_SURFACE_SURFACE_VARIANCE
RELATIVE_COMMENTS
AUTO_ROTARY
TARGET_COVERAGE
ROTATION_TYPE_2
PROBE_TYPE
TIME_STAMP
ECOND_TEMP
ECOND_PRESSURE
ECOND_HUMIDITY
HIT_RMS
DISPLAY_TRACKER_PARAMETERS
PTDENSITY_TOGGLE
PTDENSITY_UPPERBOUND
PTDENSITY_DEVLIMIT
PTDENSITY_MAXSPAN
TARGET_MEASURE_AT_FOV_CENTER
TARGET_SURFACE_FIND_SURFACE
PROJECTOR
INLINE_LEGACY_REPORT
SINGLE_POINT_DEVIATION
Used to indicate which field the expression is being set for. Type ENUM_FIELD_TYPES enumeration.
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a field type.

Remarks

Use this command to set expressions for different object fields. The ENUM_FIELD_TYPES enumeration is a large enumeration. Documentation for which field types go with which objects is not given here. You can find this information by:

  1. Creating the desired object in PC-DMIS
  2. Inserting the desired expression in the desired field
  3. Exporting (posting out) the containing part program to BASIC.

See Also

Command Object | GetExpression Method | RemoveExpression Method


SetMasterArm Method

SetMasterArm Method

Description

Sets command to be executed by Master only.

Syntax

Visual Basic
Public Function SetMasterArm() As Boolean

See Also

Command Object


SetSlaveArm Method

SetSlaveArm Method

Description

Sets command to be executed by Slave only, r eturns false if command cannot be slave owned

Syntax

Visual Basic
Public Function SetSlaveArm() As Boolean

See Also

Command Object


SetToggleString Method

SetToggleString Method
ToggleIndex
DataType
Indicate the toggle field being changed. Type ENUM_FIELD_TYPES enumeration.
TypeIndex
Long value indicating the instance of the supplied field type to use when an object has more than one instance of a field type.

Description

Sets a toggle field to a numbered value in the toggle field list This method lets you set a toggle field in a numerical, language-independent way.

Syntax

Visual Basic
Public Function SetToggleString( _
   ByVal ToggleIndex As Long, _
   ByVal DataType As ENUM_FIELD_TYPES, _
   ByVal TypeIndex As Long _
) As Boolean

Parameters

ToggleIndex
DataType
Value Description
ID
REF_ID
LEVEL_REF_ID
ROTATE_REF_ID
ORIGIN_REF_ID
THEO_X
THEO_Y
THEO_Z
THEO_SX
THEO_SY
THEO_SZ
THEO_EX
THEO_EY
THEO_EZ
THEO_I
THEO_J
THEO_K
TARG_X
TARG_Y
TARG_Z
MEAS_X
MEAS_Y
MEAS_Z
MEAS_I
MEAS_J
MEAS_K
MEAS_LENGTH
MEAS_DIAM
MEAS_ANGLE
TARG_I
TARG_J
TARG_K
THEO_DIAM
THEO_WIDTH
THEO_LENGTH
THEO_HEIGHT
THEO_ANGLE
COORD_TYPE
INOUT_TYPE
THICKNESS_TYPE
CIRC_TYPE
SNAP_TYPE
USEPIN_TYPE
MOVE_TYPE
READPOS_TYPE
FINDHOLE_TYPE
RMEAS_TYPE
THEOBF_TYPE
BOUND_TYPE
BF_MATH_TYPE
AUTOFIT_CONSTRAINT
SLOT_MIN_MAX_TYPE
FIND_NOM_AXIS_TYPE
N_INIT_HITS_TYPE
N_PERM_HITS_TYPE
SEARCHMODE_TYPE
MODE_TYPE
MEASURE_ORDER_TYPE
CONE_LENGTH_ANGLE_TYPE
OFFSET_LINE_METHOD
LIN_POL_FILT_TYPE
GEN_FEAT_TYPE
GEN_ALIGN_TYPE
CURVE_TYPE
MEASURED_2D3D_TYPE
THINNING_TOL
HITINT_TYPE
RMEASFEATID
N_HITS
N_ROWS
INIT_HITS
PERM_HITS
F_OFFSET
F_SPACER
F_PITCH
F_THICKNESS
F_DEPTH
F_AUTOMOVE
F_INDENT
F_CORNER_RADIUS
F_INCREMENT
F_TOLERANCE
F_BOXWIDTH
F_BOXLENGTH
F_CIRCRADOUT
F_CIRCRADIN
F_CHECK
F_MAXACCELX
F_MAXACCELY
F_MAXACCELZ
SCAN_ACCELERATION
SCAN_OFFSET_FORCE
MANUAL_FINE_PROBING
F_MOVESPEED
F_TOUCHSPEED
F_SCANSPEED
START_ANG
END_ANG
MIDPOINT_X
MIDPOINT_Y
MIDPOINT_Z
ANGVEC_I
ANGVEC_J
ANGVEC_K
MEASVEC_I
MEASVEC_J
MEASVEC_K
SLOTVEC_I
SLOTVEC_J
SLOTVEC_K
SURFVEC_I
SURFVEC_J
SURFVEC_K
PINVEC_I
PINVEC_J
PINVEC_K
PUNCHVEC_I
PUNCHVEC_J
PUNCHVEC_K
REPORTVEC_I
REPORTVEC_J
REPORTVEC_K
TARGSLOT_I
TARGSLOT_J
TARGSLOT_K
UPDATEVEC_I
UPDATEVEC_J
UPDATEVEC_K
THEO_MINOR_AXIS
TWO_D_THREE_D_TYPE
AXIS
DEST_EXPR
SRC_EXPR
SHOW_IDS
SHOW_DETAILS
WEIGHT
ITEM_USED
USE_AXIS
AVERAGE_ERROR
MEASURE_ALL_FEATURES
REPIERCE_CAD
START_NUM
END_NUM
SKIP_NUM
X_OFFSET
Y_OFFSET
Z_OFFSET
ANGLE_OFFSET
INTERNAL_EXTERNAL
SAVE_ALIGN_CAD_TO_PARTS
FILE_NAME
ALIGN_LIST
WORK_PLANE
DISTANCE
OLD_TIP
NEW_TIP
ROTATION_TYPE
DIM_INFO_ORDER
DIM_INFO_LOC
DIM_INFO_TP_LOC
GRAPH_ANALYSIS
TEXT_ANALYSIS
ARROW_MULTIPLIER
OUTPUT_TYPE
NOMINAL
F_PLUS_TOL
F_MINUS_TOL
TP_MODIFIER
PERP_PARALLEL_TYPE
RADIUS_TYPE
UNIT_TYPE
DIM_LENGTH
PROFILE_FORM_TYPE
PRECISION
MAN_RETRACT
DIM_TEXT
DIM_TEXT_OPTIONS
SHOW_HEADINGS
DEVIATION_SYMBOLS
STANDARD_DEVIATION
DIM_HEADING
GAP_ONLY_TYPE
DISPLAY_ID
DISPLAY_TYPE
POINT_INFO_HEADING
SHOW_POINT_INFO
RET_ONLY_TYPE
COMMENT_FIELD
COMMENT_TYPE
PART_NAME
REVISION_NUMBER
SERIAL_NUMBER
STAT_COUNT
SUB_NAME
READ_WRITE
FILE_POINTER
FIELD_WIDTH
DIGIT_COUNT
LABEL_ID
ERROR_TYPE
ERROR_MODE
DESCRIPTION
INDEX_START
INDEX_END
FILE_COMMAND_TYPE
BUFFER_SIZE_TYPE
FAIL_ON_EXIST
MAX_FORCE
LOW_FORCE
UP_FORCE
TRIGGER_FORCE
PROBE_ACCURACY
POSITIONAL_ACCURACY
NUM_RETURN_DATA
RETURN_SPEED
SCAN_DENSITY
POLAR_VECTOR_COMPENSATION
AUTO_PRINT
ORIGIN
MATERIAL_COEFFICIENT
REF_TEMP
HIGH_THRESHOLD
LOW_THRESHOLD
SENSOR_LIST
FIXTURE_TYPE
MACHINE_TYPE
PROBE_COMP
TIP_I
TIP_J
TIP_K
NORM_RELEARN
FIND_NOMS_TYPE
AUTO_CLEAR_PLANE
SINGLE_POINT
DISPLAY_HITS
CAD_TOLERANCE
OFFSET_TOLERANCE
MIN_INCREMENT
MAX_INCREMENT
MIN_ANGLE
MAX_ANGLE
F_LOCATION
COL132_TYPE
COMMAND_STRING
FLY_MODE_TYPE
STATS_TYPE
STATS_DIR
NEW_STATS_DIR
DATA_READ_LOCK
DATA_WRITE_LOCK
DATA_MEM_PAGES
STAT_NAME_TYPE
STAT_CALC_TYPE
TRANSFER_DIR
DISPLAY_TRACE
TRACE_NAME
TRACE_VALUE
SCAN_CUTPLANEVEC_I
SCAN_CUTPLANEVEC_J
SCAN_CUTPLANEVEC_K
SCAN_INITVEC_I
SCAN_INITVEC_J
SCAN_INITVEC_K
SCAN_AXISVEC_I
SCAN_AXISVEC_J
SCAN_AXISVEC_K
SCAN_ENDVEC_I
SCAN_ENDVEC_J
SCAN_ENDVEC_K
SCAN_INITDIR_I
SCAN_INITDIR_J
SCAN_INITDIR_K
SCAN_CROSS_TOTAL
SCAN_TIME_INCR
SCAN_EDGE_THICK
POS_REPORT_AXIS_X
POS_REPORT_AXIS_Y
POS_REPORT_AXIS_Z
DEV_PERPEN_CENTERLINE
USE_THEO
TARGET_COLOR
THEO_START_ANG
THEO_END_ANG
ONOFF_TYPE
ROW_ID
LOCATOR_BMP
LOCATOR_WAV
DTYPE_LEAPFROGTYPE
DTYPE_LEAPFROGNUMHITS
DTYPE_LEAPFROGFULLPARTIAL
EXCLUSION_ZONE
EXECUTE
AUTOTRIGGERONOFF
AUTOBEEPING
COLUMN_ID
SLOT_NUMBER
AUTOTOLZONE
PROBING_MODE
ANGLE_COMP_TOGGLE
POINTINFO_FILTER_INTERVAL
POINTINFO_FILTER_INTERVAL_NUMBER
FEAT_TYPE
DIM_ID
MEAS_MINOR_AXIS
MEAS_HEIGHT
MEAS_SLOTVEC_I
MEAS_SLOTVEC_J
MEAS_SLOTVEC_K
MEAS_SX
MEAS_SY
MEAS_SZ
MEAS_EX
MEAS_EY
MEAS_EZ
MEAS_WIDTH
NUM_CONTROL_POINTS
U_HITS
V_HITS
NUM_FIT_POINTS
NOMINAL_COLOR
WAVE_FILE
DIM_BONUS
PERUNIT_STEPSIZE
PERUNIT_LENGTH
PERUNIT_WIDTH
DIM_MEASURED
SURFVEC_TARG_I
SURFVEC_TARG_J
SURFVEC_TARG_K
DIM_MAX
EDGEVEC_TARG_I
EDGEVEC_TARG_J
EDGEVEC_TARG_K
DIM_MIN
EDGEVEC_THEO_I
EDGEVEC_THEO_J
EDGEVEC_THEO_K
DIM_DEVIATION
EDGEVEC_MEAS_I
EDGEVEC_MEAS_J
EDGEVEC_MEAS_K
DIM_OUTTOL
T_VALUE
TOOL_X
TOOL_Y
TOOL_Z
TOOL_DIAM
DEV_X
DEV_Y
DEV_Z
DEV_DIAM
ITERATE_COLUMNS
LOAD_TYPE
NUM_ITERATIONS
METHOD_TYPE
SCAN_TECHNIQUE
HIT_TYPE
BOUNDARY_POINT_X
BOUNDARY_POINT_Y
BOUNDARY_POINT_Z
VIDEO_GAIN
VIDEO_OFFSET
VIDEO_LEDLIGHT
VIDEO_LASERLIGHT1
VIDEO_LASERLIGHT2
VIDEO_YORIGIN
VIDEO_YEND
VIDEO_LSEG
VIDEO_XSEG
VIDEO_YSEG
ANGULARITY_NOM_ANGLE
PRINT_TO_FILE
PRINT_TO_PRINTER
PRINT_DRAFTMODE
PRINT_DELETE_RUNS
POINTINFO_FILTER_WORST
POINTINFO_FILTER_WORST_NUMBER
POINTINFO_FILTER_DEVIATION
POINTINFO_FILTER_DEVIATION_NUMBER
POINTINFO_FILTER_OUTTOL
REPORT_SURFVEC_I
REPORT_SURFVEC_J
REPORT_SURFVEC_K
DB_QUERY_OP
DB_SOURCE_NAME
CHART_TYPE
DB_CHART_NAME
DEVIATION_ANGLE
STATS_DATASOURCE
IGNOREMOTIONERRORS_TYPE
THEO_X2
THEO_Y2
THEO_Z2
MEAS_X2
MEAS_Y2
MEAS_Z2
PPROG
TRACE_FILTER
TIME_FILTER
SHOW_SPC_CALCS
SPEC_LIMITS
ZONES
STDDEV
UCL_LCL
HISTOGRAM
GRID
ADDITIONAL_CHART
LINE2_PLANAR_OPEN_IN_X
LINE3_PLANAR_OPEN_IN_X
REGR
CENTER_POINT
SHOW_MORE_SPC_CALCS
SPEC_OFFSET
SOLID
U_L_BOUNDS
TITLE
CPOINT_X
CPOINT_Y
CPOINT_Z
CPOINT_I
CPOINT_J
CPOINT_K
CPOINT_DIAM
CPOINT_SCAN_CROSS_TOTAL
CPOINT_SCAN_DENSITY
CPOINT_F_SCANSPEED
N_CONTROLPOINTS
CPOINT_TYPE
USE_3DFILTER
SCAN_BNDRY_TYPE
CREATE_WEIGHTS
F_SIZE
LINE2_ISPLANAR
LINE2_PLANAR_XTOL
LINE2_PLANAR_YTOL
LINE2_PLANAR_XDEV
LINE2_PLANAR_YDEV
LINE3_ISPLANAR
LINE3_PLANAR_XTOL
LINE3_PLANAR_YTOL
LINE3_PLANAR_XDEV
LINE3_PLANAR_YDEV
CHART_SUB_TYPE
OVERWRITE
OUTPUT_FEATURE_NOMS
OUTPUT_FEAT_W_DIMENS
OUTPUT_DMIS_REPORT
TIME_ARG
TRACE_FILTER_ARG
FIT
STATS_DB_TYPE
IOCHANNEL_NUMBER
IOCHANNEL_PULSE_WIDTH
IOCHANNEL_PULSE_INTERVAL
IOCHANNEL_PULSE_DURATION
GRAPH_OPTION
DB_SOURCE_TYPE
FIND_HOLE_PERCENT
AUTO_ONERROR_TYPE
POS_REPT_DISPLAY_OPTION
TRIGGERTOLERANCE
TRIGGERTOLVALUE
FIXTURE_TOL
START_LABEL
ERROR_LABEL
CONE_CONVEX_TYPE
TRIGGERPLANE
QUERY_SHOW_GRAPHIC_SETTINGS
CALC_STYLE_FILE
FILTER_TYPE
TRACE_VALUE_LIMIT
TARGET_DIRECTION
TARGET_EDGE_POLARITY
BSMETHOD_TYPE
CENTER_ROTATION_THEO
CENTER_ROTATION_MEAS
ARTICULATEDARM_TYPE
LEFTYRIGHTY_CONFIG
ABOVEBELOW_CONFIG
NOFLIPFLIP_CONFIG
HIGH_ACCURACY
SURFACE
MAGNIFICATION
MINOR_WORD_TOGGLE
PERCENTAGE
THRESHOLD
N_SIDES
TARGET_SURFACE_ILLUM
MEAN
CAD_COMP
SHOW_ROW
SHOW_COLUMN
TARGET_SURFACE_SENSILIGHT
TARGET_SURFACE_WIDTH
TARGET_SURFACE_HEIGHT
TARGET_SURFACE_RANGE
TARGET_SURFACE_DURATION
TARGET_SURFACE_MODE
TARGET_SURFACE_HIACC
SCREEN_CAPTURE_SCALE
SCREEN_CAPTURE_QUALITY
TARGET_EDGE_SIZE
TARGET_EDGE_ILLUM
TARGET_EDGE_TOL
TARGET_EDGE_STRENGTH
TARGET_EDGE_DENSITY
TARGET_EDGE_TYPE
DISPLAY_ADVANCED_PARAMETERS
TARGET_SURFACE_TYPE
VOID_DETECT
TARG_SX
TARG_SY
TARG_SZ
TARG_EX
TARG_EY
TARG_EZ
PATTERN_TYPE
TARGET_EDGE_ANGLE
PROGRAM_GAGE_FEAT_TYPE
PROGRAM_GAGE_TYPE
TARGET_FOCUS
RMEASFEATIDX
RMEASFEATIDY
RMEASFEATIDZ
FINDNOMS_BESTFIT
FINDNOMS_ONLYSELECTED
TEMPX
TEMPY
TEMPZ
TEMPP
AUTO_PH9
MANUAL_PREPOSITION
SCREEN_CAPTURE_TYPE
SCREEN_CAPTURE_AUTO_TYPE
TARGET_EDGE_EDGESELECT
TARGET_EDGE_EDGENUM
DELETE_TYPE
SCREEN_CAPTURE_AUTO_TIME
USE_HSSDAT
USE_STARTENDDELAY
COP_FILTER
COP_SIZE
COP_TYPE
SURFVEC_MEAS_I
SURFVEC_MEAS_J
SURFVEC_MEAS_K
TARGET_EDGE_UNDERSCAN
PROFILE_TYPE
THEO_FLUSH
MEAS_FLUSH
THEO_GAP
MEAS_GAP
THEO_DEPTH
MEAS_DEPTH
TARGET_BLOB_TYPE
LASER_STRIPE_OVERLAP
LASER_STRIPE_OVERSCAN
LASER_FREQUENCY
TARGET_FILTER_OUTLIER
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD
SLOT_TYPE
TARGET_TYPE
THEO_R
THEO_A
THEO_H
MEAS_R
MEAS_A
MEAS_H
TARG_R
TARG_A
TARG_H
THEO_SR
THEO_SA
THEO_SH
THEO_ER
THEO_EA
THEO_EH
MEAS_SR
MEAS_SA
MEAS_SH
MEAS_ER
MEAS_EA
MEAS_EH
TARG_SR
TARG_SA
TARG_SH
TARG_ER
TARG_EA
TARG_EH
TARGET_EDGE_SENSILIGHT
F_THICKNESS_EDGE
THICKNESS_TYPE_EDGE
LASER_EXPOSURE
LASER_INTENSITY
ANGLE_OFFSET_2
LASER_FILTER_NEIGHBOR_NUM
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD
LASER_FILTER_TOL_ABOVE
LASER_FILTER_TOL_BELOW
LASER_FILTER_TOL_RIGHT
LASER_CLIP_UP_DIST
LASER_CLIP_LOW_DIST
LASER_PIXEL_TOGGLE
LASER_FILTER_TOGGLE
DISPLAY_PROBE_PARAMETERS
THEO_R2
THEO_A2
THEO_H2
MEAS_R2
MEAS_A2
MEAS_H2
LASER_CLIP_LEFT_DIST
LASER_CLIP_RIGHT_DIST
COP_FILETYPE
COP_SELECTIONTYPE
COP_COLORMAP
COP_COPLEMENT
OPERTYPE
COP_BOOLEANTYPE
COP_IMPORTFILETYPE
MEAS_START_ANG
MEAS_END_ANG
ISLAND_DIAM
ISLAND_LENGTH
ISLAND_WIDTH
ISLAND_X
ISLAND_Y
ISLAND_Z
ISLAND_I
ISLAND_J
ISLAND_K
ISLAND_AI
ISLAND_AJ
ISLAND_AK
ISLAND_TYPE
ISLAND_CLEARANCEDIST
RPT_DIMENSION_TABLES
SUMMARY_DEV
DRF_TBLHDR
LINE1_TBLHDR
LINE1_CALLOUT
LINE1_COLUMN_HDR
LINE1_FEATNAME
LINE1_NOMINAL
LINE1_MEAS
LINE1_PLUSTOL
LINE1_MINUSTOL
LINE1_DEV
LINE1_DEVPERCENT
LINE1_ISBILATERAL
LINE1_NUMZONES
LINE2_TBLHDR
LINE2_CALLOUT
LINE2_COLUMN_HDR
LINE2_FEATNAME
LINE2_BONUS
LINE2_TOL
LINE2_DATUMSHFT
LINE2_UNUSEDZONE
LINE2_DEV
LINE2_DEVANG
LINE2_DEVPERCENT
LINE3_TBLHDR
LINE3_CALLOUT
LINE3_COLUMN_HDR
LINE3_FEATNAME
LINE3_BONUS
LINE3_TOL
LINE3_DATUMSHFT
LINE3_UNUSEDZONE
LINE3_DEV
LINE3_DEVANG
LINE3_DEVPERCENT
DRF_COLUMN_HDR
DRF_SEGNAME
DRF_SHIFTX
DRF_SHIFTY
DRF_SHIFTZ
DRF_ROTATIONX
DRF_ROTATIONY
DRF_ROTATIONZ
SUMMARY_COLUMN_HDR
SUMMARY_FEAT
LINE2_AXIS
LINE2_NOMINAL
LINE2_MEAS
SUMMARY_TBLHDR
SUMMARY_AXIS
SUMMARY_NOMINAL
SUMMARY_MEAS
LINE2_PLUSTOL
LINE2_MINUSTOL
LINE2_MAX
LINE2_MIN
LINE2_ISBILATERAL
LINE2_NUMZONES
LINE3_ISBILATERAL
LINE3_NUMZONES
DIM_RPT_COLUMN_HDR
DIM_RPT_ISDATUM
DIM_RPT_DATUM
DIM_RPT_GRAPHIC
DIM_RPT_DEVPERCENT
DIM_RPT_ISBILATERAL
DIM_RPT_NUMZONES
GDT_SYMBOL
COMMENT_INPUT
TARGET_EDGE_WIDTH
TARGET_EDGE_HEIGHT
TARGET_EDGE_EDGEDETECT
TARGET_EDGE_FILTER_CLEAN
TARGET_EDGE_FILTER_CLEAN_STRENGTH
TARGET_EDGE_FILTER_AREA
TARGET_EDGE_FILTER_AREA_SIZE
TARGET_EDGE_GRADIENT
THEO_PERIMETER
MEAS_PERIMETER
THEO_AREA
MEAS_AREA
TARGET_SURFACE_CROSSHAIR_HEIGHT
SHOW_NOMS
COMPOSITE
DATUM2
TP_MODIFIER2
DESCRIPTION2
SHOW_OPTIONS
LEADER_LINE_ID
GDT_SYMBOL2
DATUM1_MODIFIER
DATUM2_MODIFIER
DATUM3_MODIFIER
DATUM1_MODIFIER2
DATUM2_MODIFIER2
DATUM3_MODIFIER2
DIM_RPT_DEVPERCENT_NOM
DIM_RPT_USETWODEVIATIONS
DIM_RPT_DEVPERCENT2
LINE2_DEVPERCENT_NOM
LINE2_USE2DEVIATIONS
LINE2_DEVPERCENT2
LINE3_DEVPERCENT_NOM
LINE3_USE2DEVIATIONS
LINE3_DEVPERCENT2
AXIS_PLUS_TOL
AXIS_MINUS_TOL
AXIS_NOMINAL
AXIS_DESCRIPTION
LINE1_DEVPERCENT_NOM
LINE1_USE2DEVIATIONS
LINE1_DEVPERCENT2
USE_AXIS2
DIM_LENGTH2
TEXTANAL_LABEL_MEAS_X
TEXTANAL_LABEL_MEAS_Y
TEXTANAL_LABEL_MEAS_Z
TEXTANAL_LABEL_MEAS_I
TEXTANAL_LABEL_MEAS_J
TEXTANAL_LABEL_MEAS_K
TEXTANAL_LABEL_DEV
TEXTANAL_LABEL_MINMAX
SIMULT_EVAL
SECTION_INDEX
LINE1_OUTTOL
LINE2_OUTTOL
LINE3_OUTTOL
LINE1_MAX
LINE1_MIN
LINE3_NOMINAL
LINE3_MEAS
LINE3_PLUSTOL
LINE3_MINUSTOL
LINE3_MAX
LINE3_MIN
SUMMARY_OUTTOL
SUMMARY_PLUSTOL
SUMMARY_MINUSTOL
SUMMARY_MAX
SUMMARY_MIN
SUMMARY_BONUS
LINE1_BONUS
GRAPH_ANALYSIS_POINT_SIZE
GRAPH_ANALYSIS_PLUS_TOL
GRAPH_ANALYSIS_MINUS_TOL
DIM_AXIS_ITEM_NUMBER
F_ENDING_DEPTH
DIM_ITEM_NUMBER
FEAT_ITEM_NUMBER
COMMAND_TYPE
DEV_MAX
AUTO_DEV_DIRECTION
PROBE_DIRECTION
USER_DEFINED_THEOS
SCALING
USE_SCALING
UID
REF_UID
BA_SOLUTION_TYPE
BA_SOLUTION_OPTIONS
BA_SOLUTION_STATUS
BA_VARIANCE
BA_RMS
BA_WARNINGS
BA_STATION
BA_STATION_X
BA_STATION_Y
BA_STATION_Z
BA_STATION_ROTX
BA_STATION_ROTY
BA_STATION_ROTZ
BA_STATION_ORIENTED
BA_STATION_LOCKED
BA_FEATURE
BA_FEAT_SOURCE
BA_FEAT_RMS
BA_FEAT_POINTING_ERR
BA_FEAT_APEX_ANGLE
BA_FEAT_X
BA_FEAT_Y
BA_FEAT_Z
BA_FEAT_DEV_X
BA_FEAT_DEV_Y
BA_FEAT_DEV_Z
BA_FEAT_DEV3D
NO_APPROACH_VECTOR_FLIP
TARGET_EDGE_START_VALUE
TARGET_EDGE_END_VALUE
TARGET_SURFACE_SURFACE_VARIANCE
RELATIVE_COMMENTS
AUTO_ROTARY
TARGET_COVERAGE
ROTATION_TYPE_2
PROBE_TYPE
TIME_STAMP
ECOND_TEMP
ECOND_PRESSURE
ECOND_HUMIDITY
HIT_RMS
DISPLAY_TRACKER_PARAMETERS
PTDENSITY_TOGGLE
PTDENSITY_UPPERBOUND
PTDENSITY_DEVLIMIT
PTDENSITY_MAXSPAN
TARGET_MEASURE_AT_FOV_CENTER
TARGET_SURFACE_FIND_SURFACE
PROJECTOR
INLINE_LEGACY_REPORT
SINGLE_POINT_DEVIATION
Indicate the toggle field being changed. Type ENUM_FIELD_TYPES enumeration.
TypeIndex
Long value indicating the instance of the supplied field type to use when an object has more than one instance of a field type.

Return Type

Boolean value. It returns true if the underlying Command object exists in PC-DMIS the appropriate DataType and TypeIndex parameters successfully set the toggle string. Otherwise, it returns false.

Example

The Measured Circle has a BF_MATH_TYPE field that takes one of "QUAD MIN", "SEP MIN", "MAX ISCR", "MIN CIRCOS", or "RAG FISSO" in Italian, or "LEAST_SQR", "MIN_SEP", "MAX_INSC", "MIN_CIRCSC", or "FIXED_RAD" in English. If we do not know which language we are importing into, we can not know which phrase to use.

However, the ENUM_FIELD_TYPES number is the same in both languages, e.g., "MIN CIRCOS" and "MIN_CIRCSC" are both string number 4.

The SetToggleString method can be called in the following fashion to set the BF_MATH_TYPE to use the minimum circumscribed method:

retval = DmisCommand.SetToggleString(4, BF_MATH_TYPE,0)

See Also

Command Object


SolveExpression Method

SolveExpression Method
Expression
String value of the expression to solve.

Description

Solves expression, if valid, and returns a variable object.

SolveExpression evaluates the expression based on the objects above the command on which SolveExpression gets called.

Syntax

Visual Basic
Public Function SolveExpression( _
   ByVal Expression As String _
) As Variable

Parameters

Expression
String value of the expression to solve.

Return Type

This method returns a variable object if the solved expression is valid.

See Also

Command Object


UpdateDimensionNominals Method

UpdateDimensionNominals Method

Description

Updates the nominals of related dimensions.

Syntax

Visual Basic
Public Sub UpdateDimensionNominals()

See Also

Command Object


_ID Property

_ID Property

Property type

Read-write property

Syntax

Visual Basic
Public Property _ID() As String

See Also

Command Object


ActiveTipCommand Property

ActiveTipCommand Property

Description

Read Only: Returns an automation active tip object if the current command object is of the correct type Returns an ActiveTip object if Command is of Type SET_ACTIVE_TIP. Nothing otherwise. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActiveTipCommand() As ActiveTip

See Also

Command Object | ActiveTip Object | Type Property


AlignmentCommand Property

AlignmentCommand Property

Description

Read Only: Returns the alignment command object interface for the current command if it is an alignment object

Returns this Command object as an AlignCmnd object if it can, Nothing otherwise.

Property type

Read-write property

Syntax

Visual Basic
Public Property AlignmentCommand() As AlignCmnd

Return Type

AlignCmnd object.

Remarks

The Commands that have the following Type can become AlignCommand objects are as follows:

START_ALIGN
LEVEL_ALIGN
ROTATE_ALIGN
TRANS_ALIGN
TRANSOFF_ALIGN
ROTATEOFF_ALIGN
SAVE_ALIGN
RECALL_ALIGN
EQUATE_ALIGN
ITER_ALIGN
BF2D_ALIGN
ROTATE_CIRCLE_ALIGN
BF3D_ALIGN

See Also

Command Object | AlignCmnd Object | Type Property


Application Property

Application Property

Description

Read Only: Returns the Application Object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

See Also

Command Object


ArrayIndexCommand Property

ArrayIndexCommand Property

Description

Read Only: Returns an automation array index object if the current command object is of the correct type Returns an ArrayIndex object if Command is of Type ARRAY_INDEX. Returns Nothing otherwise. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property ArrayIndexCommand() As ArrayIndex

Return Type

ArrayIndex object.

See Also

Command Object


AttachCommand Property

AttachCommand Property

Description

Read Only: Returns an automation attach object if the current command object is of the correct type Returns an Attach object if Command is of Type ATTACH_PROGRAM. Returns Nothing otherwise. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property AttachCommand() As Attach

Return Type

Attach object.

See Also

Command Object


BasicScanCommand Property

BasicScanCommand Property

Description

Read Only: Returns the basic scan command object interface for the current command if it is a basic scan object

Returns this Command object as an BasicScan object if it can, Nothing otherwise. Read-only.

Only Command objects of type BASIC_SCAN_OBJECT can become BasicScan objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property BasicScanCommand() As BasicScan

Return Type

BasicScan object.

See Also

Command Object


BothArms Property

BothArms Property

Description

Read Only: Property indicating whether the command belongs to the both arms

Property type

Read-write property

Syntax

Visual Basic
Public Property BothArms() As Boolean

See Also

Command Object


CalibrationCommand Property

CalibrationCommand Property

Description

Read Only: Returns an automation calibration object if the current command object is of the correct type Returns a Calibration object if Command is of Type CALIB_SPHERE. Otherwise it returns Nothing. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property CalibrationCommand() As Calibration

Return Type

Calibration object.

See Also

Command Object | BasicScan Object | Type Property


CommentCommand Property

CommentCommand Property

Description

Read Only: Returns an automation comment object if the current command object is of the correct type Returns a Comment object if Command is of Type SET_COMMENT. Otherwise it returns Nothing. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property CommentCommand() As Comment

Return Type

Comment object.

See Also

Command Object


CopyMeasToNom Property

CopyMeasToNom Property

Description

Read/Write: Flag that causes measured values to be copied to nominal values after execution

Property used to indicate/set whether the object should execute in MASTER mode. After executing in MASTER mode, the object copies the measured vector, centroid , and other nominal information to the nominals and turns off MASTER mode. This copies the same information that gets calculated using the CalculateNominals method.

Property type

Read-write property

Syntax

Visual Basic
Public Property CopyMeasToNom() As Boolean

Return Type

Read/write Boolean.

Remarks

The nominal information that this copies included the following:

  • CENTROID
  • VECTOR
  • DIAMETER
  • STARTPOINT
  • ENDPOINT
  • BALLCENTER
  • LENGTH
  • ELLIPSEMINORAXIS
  • ANGLE
  • SURFACEVECTOR
  • THICKNESS
  • NUMHITS
  • SPACER
  • INDENT
  • AUTO_MOVE_DISTANCE
  • DEPTH
  • TARG
  • SCANROWCOUNT
  • ANGLE_VECTOR
  • PUNCH_VECTOR
  • PIN_VECTOR
  • PIN_DIAMETER
  • REPORT_VECTOR
  • REPORT_SURF_VECTOR
  • HEIGHT
  • MEASURE_VECTOR
  • UPDATE_VECTOR
  • CORNER_RADIUS
  • ANGLE2

See Also

Command Object


Count Property

Count Property

Description

Read Only: The number of times the command was executed during the last execution

Represents the number of copies of this Command which are available. If the part program is currently being executed, it is the number of times it has been executed so far in the current execution cycle. If the part program is not currently being executed, it is the number of times it was executed during the previous execution cycle. If Command has never been executed, Count has the value one.

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

Return Type

Read-only Long.

See Also

Command Object


DataTypes Property

DataTypes Property

Description

Read Only: Returns the data type information collection for this command

Property type

Read-write property

Syntax

Visual Basic
Public Property DataTypes() As DataTypes

See Also

Command Object


DimensionCommand Property

DimensionCommand Property

Description

Read Only: Returns the dimension command object interface for the current command if it is a dimension object Returns this Command object as an DimensionCommand object if it can, Nothing otherwise. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property DimensionCommand() As DimensionCmd

Remarks

The Command objects that have the following Type can become DimensionCommand objects:

DIMENSION_START_LOCATION
DIMENSION_X_LOCATION
DIMENSION_Y_LOCATION
DIMENSION_Z_LOCATION
DIMENSION_D_LOCATION
DIMENSION_R_LOCATION
DIMENSION_A_LOCATION
DIMENSION_T_LOCATION
DIMENSION_V_LOCATION
DIMENSION_L_LOCATION
DIMENSION_H_LOCATION
DIMENSION_PR_LOCATION
DIMENSION_PA_LOCATION
DIMENSION_PD_LOCATION
DIMENSION_RT_LOCATION
DIMENSION_S_LOCATION
DIMENSION_RS_LOCATION
DIMENSION_STRAIGHTNESS
DIMENSION_ROUNDNESS
DIMENSION_FLATNESS
DIMENSION_PERPENDICULARITY
DIMENSION_PARALLELISM
DIMENSION_PROFILE
DIMENSION_3D_DISTANCE
DIMENSION_2D_DISTANCE
DIMENSION_3D_ANGLE
DIMENSION_2D_ANGLE
DIMENSION_RUNOUT
DIMENSION_CONCENTRICITY
DIMENSION_ANGULARITY
DIMENSION_KEYIN
DIMENSION_TRUE_START_POSITION
DIMENSION_TRUE_X_LOCATION
DIMENSION_TRUE_Y_LOCATION
DIMENSION_TRUE_Z_LOCATION
DIMENSION_TRUE_DD_LOCATION
DIMENSION_TRUE_DF_LOCATION
DIMENSION_TRUE_PR_LOCATION
DIMENSION_TRUE_PA_LOCATION
DIMENSION_TRUE_DIAM_LOCATION

See Also

Command Object


DimensionEndCommand Property

DimensionEndCommand Property

Description

Read Only: Returns the dimension end command object interface for the current command if it is a dimension end object

Property type

Read-write property

Syntax

Visual Basic
Public Property DimensionEndCommand() As DimensionCmd

See Also

Command Object


DimFormatCommand Property

DimFormatCommand Property

Description

Read Only: Returns an automation dimension format object if the current command object is of the correct type

Returns a DimFormat object if Command is of Type DIMENSION_FORMAT. Otherwise it returns Nothing. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property DimFormatCommand() As DimFormat

Return Type

DimFormat object.

See Also

Command Object | DimFormat Object | Type Property


DimInfoCommand Property

DimInfoCommand Property

Description

Read Only: Returns an automation dimension info object if the current command object is of the correct type Returns a DimInfo object if Command is of Type DIMENSION_INFORMATION. Otherwise it returns Nothing. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property DimInfoCommand() As DimInfo

Return Type

DimInfo object.

See Also

Command Object | DimInfo Object | Type Property


DisplayMetaFileCommand Property

DisplayMetaFileCommand Property

Description

Read Only: Returns an automation display metafile object if the current command object is of the correct type Returns a DispMetaFile object if Command is of Type DISPLAY_METAFILE. Otherwise it returns Nothing. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisplayMetaFileCommand() As DispMetaFile

Return Type

DispMetaFile object.

See Also

Command Object | Type Property


ExpectsMiss Property

ExpectsMiss Property

Description

Read/Write: Indicates whether script should plan for a miss error for this command

Property type

Read-write property

Syntax

Visual Basic
Public Property ExpectsMiss() As Boolean

See Also

Command Object


ExternalCommand Property

ExternalCommand Property

Description

Read Only: Returns an automation external command object if the current command object is of the correct type Returns an ExternalCommand object if Command is of Type EXTERNAL_COMMAND. Otherwise it returns Nothing. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExternalCommand() As ExternalCommand

Return Type

ExternalCommand object.

See Also

Command Object | Type Property


Feature Property

Feature Property

Description

Read Only: Type of feature (ie. Circle, Line, Sphere, etc.) or 0 if not a feature Represents the kind of feature that this Command object is.

Property type

Read-write property

Syntax

Visual Basic
Public Property Feature() As ENUM_FEATURE_TYPES

Return Type

Read-only ENUM_FEATURE_TYPES. If it is not a feature it will return F_NONE. Otherwise it will return a value from the following list.

Type of Feature | Return Value
POINT | F_POINT
CIRCLE | F_CIRCLE
SPHERE | F_SPHERE
LINE | F_LINE
CONE | F_CONE
CYLINDER | F_CYLINDER
PLANE | F_PLANE
CURVE | F_CURVE
SLOT | F_SLOT
SET | F_SET
ELLIPSE | F_ELLIPSE
SURFACE | F_SURFACE

See Also

Command Object


FeatureCommand Property

FeatureCommand Property

Description

Read Only: Returns the feature command object interface for the current command if it is a feature object

Returns this Command object as an FeatCmd object if it can, Nothing otherwise. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property FeatureCommand() As FeatCmd

Return Type

FeatCmd object.

Remarks

The Commands that have the following Type can become FeatCommand objects are as follows:

ANGLE_HIT
AUTO_ANGLE_FEATURE
AUTO_CIRCLE
AUTO_CORNER_FEATURE
AUTO_CYLINDER
AUTO_EDGE_FEATURE
AUTO_ELLIPSE
AUTO_HIGH_FEATURE
AUTO_NOTCH
AUTO_ROUND_SLOT
AUTO_SPHERE
AUTO_SQUARE_SLOT
AUTO_SURFACE_FEATURE
AUTO_VECTOR_FEATURE
BASIC_HIT
CONST_ALN_LINE
CONST_ALN_PLANE
CONST_BF_CIRCLE
CONST_BF_CONE
CONST_BF_CYLINDER
CONST_BF_LINE
CONST_BF_PLANE
CONST_BF_SPHERE
CONST_BFRE_CIRCLE
CONST_BFRE_CONE
CONST_BFRE_CYLINDER
CONST_BFRE_LINE
CONST_BFRE_PLANE
CONST_BFRE_SPHERE
CONST_CAST_CIRCLE
CONST_CAST_CONE
CONST_CAST_CYLINDER
CONST_CAST_LINE
CONST_CAST_PLANE
CONST_CAST_POINT
CONST_CAST_SPHERE
CONST_CONE_CIRCLE
CONST_CORNER_POINT
CONST_DROP_POINT
CONST_HIPNT_PLANE
CONST_INT_CIRCLE
CONST_INT_LINE
CONST_INT_POINT
CONST_MID_LINE
CONST_MID_PLANE
CONST_MID_POINT
CONST_OFF_LINE
CONST_OFF_PLANE
CONST_OFF_POINT
CONST_ORIG_POINT
CONST_PIERCE_POINT
CONST_PLTO_LINE
CONST_PLTO_PLANE
CONST_PROJ_CIRCLE
CONST_PROJ_CONE
CONST_PROJ_CYLINDER
CONST_PROJ_LINE
CONST_PROJ_POINT
CONST_PROJ_SPHERE
CONST_PRTO_LINE
CONST_PRTO_PLANE
CONST_REV_CIRCLE
CONST_REV_CONE
CONST_REV_CYLINDER
CONST_REV_LINE
CONST_REV_PLANE
CONST_REV_SPHERE
CONST_ROUND_SLOT
CONST_SET
CORNER_HIT
EDGE_HIT
GENERIC_CONSTRUCTION
MEASURED_CIRCLE
MEASURED_CONE
MEASURED_CYLINDER
MEASURED_LINE
MEASURED_PLANE
MEASURED_POINT
MEASURED_SET
MEASURED_SPHERE
SURFACE_HIT
VECTOR_HIT

See Also

Command Object | Type Property


FileIOCommand Property

FileIOCommand Property

Description

Read Only: Returns an automation file I/O object if the current command object is of the correct type

Returns a FileIO object if Command is of Type FILE_IO_OBJECT. Otherwise it returns Nothing. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property FileIOCommand() As FileIO

Return Type

FileIO object.

See Also

Command Object | Type Property


FlowControlCommand Property

FlowControlCommand Property

Description

Read Only: Returns the flow control command object interface for the current command if it is a flow control object

Returns this Command object as an FlowControlCmnd object if it can, Nothing otherwise. Read-only.

The Commands that have the following Type can become FlowControlCmnd objects are as follows:

LOOP_START
START_SUBROUTINE
CALL_SUBROUTINE
LABEL
GOTO
IF_GOTO_COMMAND
BASIC_SCRIPT
ONERROR
WHILE_COMMAND
ENDWHILE_COMMAND
IF_BLOCK_COMMAND
END_IF_COMMAND
IF_ELSE_COMMAND
END_IF_ELSE_COMMAND,
END_ELSE_COMMAND
DO_COMMAND
UNTIL_COMMAND
CASE_COMMAND
END_CASE_COMMAND
DEFAULT_CASE_COMMAND
END_DEFAULT_CASE_COMMAND
SELECT_COMMAND
END_SELECT_COMMAND

Property type

Read-write property

Syntax

Visual Basic
Public Property FlowControlCommand() As FlowControlCmd

Return Type

FlowControlCmd object.

See Also

Command Object | Type Property


GetDataTypeCount Property

GetDataTypeCount Property
DataType

Description

Returns the number of instances of the supplied data type in command

Property type

Read-only property

Syntax

Visual Basic
Public Property GetDataTypeCount( _
   ByVal DataType As ENUM_FIELD_TYPES _
) As Long

Parameters

DataType
Value Description
ID
REF_ID
LEVEL_REF_ID
ROTATE_REF_ID
ORIGIN_REF_ID
THEO_X
THEO_Y
THEO_Z
THEO_SX
THEO_SY
THEO_SZ
THEO_EX
THEO_EY
THEO_EZ
THEO_I
THEO_J
THEO_K
TARG_X
TARG_Y
TARG_Z
MEAS_X
MEAS_Y
MEAS_Z
MEAS_I
MEAS_J
MEAS_K
MEAS_LENGTH
MEAS_DIAM
MEAS_ANGLE
TARG_I
TARG_J
TARG_K
THEO_DIAM
THEO_WIDTH
THEO_LENGTH
THEO_HEIGHT
THEO_ANGLE
COORD_TYPE
INOUT_TYPE
THICKNESS_TYPE
CIRC_TYPE
SNAP_TYPE
USEPIN_TYPE
MOVE_TYPE
READPOS_TYPE
FINDHOLE_TYPE
RMEAS_TYPE
THEOBF_TYPE
BOUND_TYPE
BF_MATH_TYPE
AUTOFIT_CONSTRAINT
SLOT_MIN_MAX_TYPE
FIND_NOM_AXIS_TYPE
N_INIT_HITS_TYPE
N_PERM_HITS_TYPE
SEARCHMODE_TYPE
MODE_TYPE
MEASURE_ORDER_TYPE
CONE_LENGTH_ANGLE_TYPE
OFFSET_LINE_METHOD
LIN_POL_FILT_TYPE
GEN_FEAT_TYPE
GEN_ALIGN_TYPE
CURVE_TYPE
MEASURED_2D3D_TYPE
THINNING_TOL
HITINT_TYPE
RMEASFEATID
N_HITS
N_ROWS
INIT_HITS
PERM_HITS
F_OFFSET
F_SPACER
F_PITCH
F_THICKNESS
F_DEPTH
F_AUTOMOVE
F_INDENT
F_CORNER_RADIUS
F_INCREMENT
F_TOLERANCE
F_BOXWIDTH
F_BOXLENGTH
F_CIRCRADOUT
F_CIRCRADIN
F_CHECK
F_MAXACCELX
F_MAXACCELY
F_MAXACCELZ
SCAN_ACCELERATION
SCAN_OFFSET_FORCE
MANUAL_FINE_PROBING
F_MOVESPEED
F_TOUCHSPEED
F_SCANSPEED
START_ANG
END_ANG
MIDPOINT_X
MIDPOINT_Y
MIDPOINT_Z
ANGVEC_I
ANGVEC_J
ANGVEC_K
MEASVEC_I
MEASVEC_J
MEASVEC_K
SLOTVEC_I
SLOTVEC_J
SLOTVEC_K
SURFVEC_I
SURFVEC_J
SURFVEC_K
PINVEC_I
PINVEC_J
PINVEC_K
PUNCHVEC_I
PUNCHVEC_J
PUNCHVEC_K
REPORTVEC_I
REPORTVEC_J
REPORTVEC_K
TARGSLOT_I
TARGSLOT_J
TARGSLOT_K
UPDATEVEC_I
UPDATEVEC_J
UPDATEVEC_K
THEO_MINOR_AXIS
TWO_D_THREE_D_TYPE
AXIS
DEST_EXPR
SRC_EXPR
SHOW_IDS
SHOW_DETAILS
WEIGHT
ITEM_USED
USE_AXIS
AVERAGE_ERROR
MEASURE_ALL_FEATURES
REPIERCE_CAD
START_NUM
END_NUM
SKIP_NUM
X_OFFSET
Y_OFFSET
Z_OFFSET
ANGLE_OFFSET
INTERNAL_EXTERNAL
SAVE_ALIGN_CAD_TO_PARTS
FILE_NAME
ALIGN_LIST
WORK_PLANE
DISTANCE
OLD_TIP
NEW_TIP
ROTATION_TYPE
DIM_INFO_ORDER
DIM_INFO_LOC
DIM_INFO_TP_LOC
GRAPH_ANALYSIS
TEXT_ANALYSIS
ARROW_MULTIPLIER
OUTPUT_TYPE
NOMINAL
F_PLUS_TOL
F_MINUS_TOL
TP_MODIFIER
PERP_PARALLEL_TYPE
RADIUS_TYPE
UNIT_TYPE
DIM_LENGTH
PROFILE_FORM_TYPE
PRECISION
MAN_RETRACT
DIM_TEXT
DIM_TEXT_OPTIONS
SHOW_HEADINGS
DEVIATION_SYMBOLS
STANDARD_DEVIATION
DIM_HEADING
GAP_ONLY_TYPE
DISPLAY_ID
DISPLAY_TYPE
POINT_INFO_HEADING
SHOW_POINT_INFO
RET_ONLY_TYPE
COMMENT_FIELD
COMMENT_TYPE
PART_NAME
REVISION_NUMBER
SERIAL_NUMBER
STAT_COUNT
SUB_NAME
READ_WRITE
FILE_POINTER
FIELD_WIDTH
DIGIT_COUNT
LABEL_ID
ERROR_TYPE
ERROR_MODE
DESCRIPTION
INDEX_START
INDEX_END
FILE_COMMAND_TYPE
BUFFER_SIZE_TYPE
FAIL_ON_EXIST
MAX_FORCE
LOW_FORCE
UP_FORCE
TRIGGER_FORCE
PROBE_ACCURACY
POSITIONAL_ACCURACY
NUM_RETURN_DATA
RETURN_SPEED
SCAN_DENSITY
POLAR_VECTOR_COMPENSATION
AUTO_PRINT
ORIGIN
MATERIAL_COEFFICIENT
REF_TEMP
HIGH_THRESHOLD
LOW_THRESHOLD
SENSOR_LIST
FIXTURE_TYPE
MACHINE_TYPE
PROBE_COMP
TIP_I
TIP_J
TIP_K
NORM_RELEARN
FIND_NOMS_TYPE
AUTO_CLEAR_PLANE
SINGLE_POINT
DISPLAY_HITS
CAD_TOLERANCE
OFFSET_TOLERANCE
MIN_INCREMENT
MAX_INCREMENT
MIN_ANGLE
MAX_ANGLE
F_LOCATION
COL132_TYPE
COMMAND_STRING
FLY_MODE_TYPE
STATS_TYPE
STATS_DIR
NEW_STATS_DIR
DATA_READ_LOCK
DATA_WRITE_LOCK
DATA_MEM_PAGES
STAT_NAME_TYPE
STAT_CALC_TYPE
TRANSFER_DIR
DISPLAY_TRACE
TRACE_NAME
TRACE_VALUE
SCAN_CUTPLANEVEC_I
SCAN_CUTPLANEVEC_J
SCAN_CUTPLANEVEC_K
SCAN_INITVEC_I
SCAN_INITVEC_J
SCAN_INITVEC_K
SCAN_AXISVEC_I
SCAN_AXISVEC_J
SCAN_AXISVEC_K
SCAN_ENDVEC_I
SCAN_ENDVEC_J
SCAN_ENDVEC_K
SCAN_INITDIR_I
SCAN_INITDIR_J
SCAN_INITDIR_K
SCAN_CROSS_TOTAL
SCAN_TIME_INCR
SCAN_EDGE_THICK
POS_REPORT_AXIS_X
POS_REPORT_AXIS_Y
POS_REPORT_AXIS_Z
DEV_PERPEN_CENTERLINE
USE_THEO
TARGET_COLOR
THEO_START_ANG
THEO_END_ANG
ONOFF_TYPE
ROW_ID
LOCATOR_BMP
LOCATOR_WAV
DTYPE_LEAPFROGTYPE
DTYPE_LEAPFROGNUMHITS
DTYPE_LEAPFROGFULLPARTIAL
EXCLUSION_ZONE
EXECUTE
AUTOTRIGGERONOFF
AUTOBEEPING
COLUMN_ID
SLOT_NUMBER
AUTOTOLZONE
PROBING_MODE
ANGLE_COMP_TOGGLE
POINTINFO_FILTER_INTERVAL
POINTINFO_FILTER_INTERVAL_NUMBER
FEAT_TYPE
DIM_ID
MEAS_MINOR_AXIS
MEAS_HEIGHT
MEAS_SLOTVEC_I
MEAS_SLOTVEC_J
MEAS_SLOTVEC_K
MEAS_SX
MEAS_SY
MEAS_SZ
MEAS_EX
MEAS_EY
MEAS_EZ
MEAS_WIDTH
NUM_CONTROL_POINTS
U_HITS
V_HITS
NUM_FIT_POINTS
NOMINAL_COLOR
WAVE_FILE
DIM_BONUS
PERUNIT_STEPSIZE
PERUNIT_LENGTH
PERUNIT_WIDTH
DIM_MEASURED
SURFVEC_TARG_I
SURFVEC_TARG_J
SURFVEC_TARG_K
DIM_MAX
EDGEVEC_TARG_I
EDGEVEC_TARG_J
EDGEVEC_TARG_K
DIM_MIN
EDGEVEC_THEO_I
EDGEVEC_THEO_J
EDGEVEC_THEO_K
DIM_DEVIATION
EDGEVEC_MEAS_I
EDGEVEC_MEAS_J
EDGEVEC_MEAS_K
DIM_OUTTOL
T_VALUE
TOOL_X
TOOL_Y
TOOL_Z
TOOL_DIAM
DEV_X
DEV_Y
DEV_Z
DEV_DIAM
ITERATE_COLUMNS
LOAD_TYPE
NUM_ITERATIONS
METHOD_TYPE
SCAN_TECHNIQUE
HIT_TYPE
BOUNDARY_POINT_X
BOUNDARY_POINT_Y
BOUNDARY_POINT_Z
VIDEO_GAIN
VIDEO_OFFSET
VIDEO_LEDLIGHT
VIDEO_LASERLIGHT1
VIDEO_LASERLIGHT2
VIDEO_YORIGIN
VIDEO_YEND
VIDEO_LSEG
VIDEO_XSEG
VIDEO_YSEG
ANGULARITY_NOM_ANGLE
PRINT_TO_FILE
PRINT_TO_PRINTER
PRINT_DRAFTMODE
PRINT_DELETE_RUNS
POINTINFO_FILTER_WORST
POINTINFO_FILTER_WORST_NUMBER
POINTINFO_FILTER_DEVIATION
POINTINFO_FILTER_DEVIATION_NUMBER
POINTINFO_FILTER_OUTTOL
REPORT_SURFVEC_I
REPORT_SURFVEC_J
REPORT_SURFVEC_K
DB_QUERY_OP
DB_SOURCE_NAME
CHART_TYPE
DB_CHART_NAME
DEVIATION_ANGLE
STATS_DATASOURCE
IGNOREMOTIONERRORS_TYPE
THEO_X2
THEO_Y2
THEO_Z2
MEAS_X2
MEAS_Y2
MEAS_Z2
PPROG
TRACE_FILTER
TIME_FILTER
SHOW_SPC_CALCS
SPEC_LIMITS
ZONES
STDDEV
UCL_LCL
HISTOGRAM
GRID
ADDITIONAL_CHART
LINE2_PLANAR_OPEN_IN_X
LINE3_PLANAR_OPEN_IN_X
REGR
CENTER_POINT
SHOW_MORE_SPC_CALCS
SPEC_OFFSET
SOLID
U_L_BOUNDS
TITLE
CPOINT_X
CPOINT_Y
CPOINT_Z
CPOINT_I
CPOINT_J
CPOINT_K
CPOINT_DIAM
CPOINT_SCAN_CROSS_TOTAL
CPOINT_SCAN_DENSITY
CPOINT_F_SCANSPEED
N_CONTROLPOINTS
CPOINT_TYPE
USE_3DFILTER
SCAN_BNDRY_TYPE
CREATE_WEIGHTS
F_SIZE
LINE2_ISPLANAR
LINE2_PLANAR_XTOL
LINE2_PLANAR_YTOL
LINE2_PLANAR_XDEV
LINE2_PLANAR_YDEV
LINE3_ISPLANAR
LINE3_PLANAR_XTOL
LINE3_PLANAR_YTOL
LINE3_PLANAR_XDEV
LINE3_PLANAR_YDEV
CHART_SUB_TYPE
OVERWRITE
OUTPUT_FEATURE_NOMS
OUTPUT_FEAT_W_DIMENS
OUTPUT_DMIS_REPORT
TIME_ARG
TRACE_FILTER_ARG
FIT
STATS_DB_TYPE
IOCHANNEL_NUMBER
IOCHANNEL_PULSE_WIDTH
IOCHANNEL_PULSE_INTERVAL
IOCHANNEL_PULSE_DURATION
GRAPH_OPTION
DB_SOURCE_TYPE
FIND_HOLE_PERCENT
AUTO_ONERROR_TYPE
POS_REPT_DISPLAY_OPTION
TRIGGERTOLERANCE
TRIGGERTOLVALUE
FIXTURE_TOL
START_LABEL
ERROR_LABEL
CONE_CONVEX_TYPE
TRIGGERPLANE
QUERY_SHOW_GRAPHIC_SETTINGS
CALC_STYLE_FILE
FILTER_TYPE
TRACE_VALUE_LIMIT
TARGET_DIRECTION
TARGET_EDGE_POLARITY
BSMETHOD_TYPE
CENTER_ROTATION_THEO
CENTER_ROTATION_MEAS
ARTICULATEDARM_TYPE
LEFTYRIGHTY_CONFIG
ABOVEBELOW_CONFIG
NOFLIPFLIP_CONFIG
HIGH_ACCURACY
SURFACE
MAGNIFICATION
MINOR_WORD_TOGGLE
PERCENTAGE
THRESHOLD
N_SIDES
TARGET_SURFACE_ILLUM
MEAN
CAD_COMP
SHOW_ROW
SHOW_COLUMN
TARGET_SURFACE_SENSILIGHT
TARGET_SURFACE_WIDTH
TARGET_SURFACE_HEIGHT
TARGET_SURFACE_RANGE
TARGET_SURFACE_DURATION
TARGET_SURFACE_MODE
TARGET_SURFACE_HIACC
SCREEN_CAPTURE_SCALE
SCREEN_CAPTURE_QUALITY
TARGET_EDGE_SIZE
TARGET_EDGE_ILLUM
TARGET_EDGE_TOL
TARGET_EDGE_STRENGTH
TARGET_EDGE_DENSITY
TARGET_EDGE_TYPE
DISPLAY_ADVANCED_PARAMETERS
TARGET_SURFACE_TYPE
VOID_DETECT
TARG_SX
TARG_SY
TARG_SZ
TARG_EX
TARG_EY
TARG_EZ
PATTERN_TYPE
TARGET_EDGE_ANGLE
PROGRAM_GAGE_FEAT_TYPE
PROGRAM_GAGE_TYPE
TARGET_FOCUS
RMEASFEATIDX
RMEASFEATIDY
RMEASFEATIDZ
FINDNOMS_BESTFIT
FINDNOMS_ONLYSELECTED
TEMPX
TEMPY
TEMPZ
TEMPP
AUTO_PH9
MANUAL_PREPOSITION
SCREEN_CAPTURE_TYPE
SCREEN_CAPTURE_AUTO_TYPE
TARGET_EDGE_EDGESELECT
TARGET_EDGE_EDGENUM
DELETE_TYPE
SCREEN_CAPTURE_AUTO_TIME
USE_HSSDAT
USE_STARTENDDELAY
COP_FILTER
COP_SIZE
COP_TYPE
SURFVEC_MEAS_I
SURFVEC_MEAS_J
SURFVEC_MEAS_K
TARGET_EDGE_UNDERSCAN
PROFILE_TYPE
THEO_FLUSH
MEAS_FLUSH
THEO_GAP
MEAS_GAP
THEO_DEPTH
MEAS_DEPTH
TARGET_BLOB_TYPE
LASER_STRIPE_OVERLAP
LASER_STRIPE_OVERSCAN
LASER_FREQUENCY
TARGET_FILTER_OUTLIER
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD
SLOT_TYPE
TARGET_TYPE
THEO_R
THEO_A
THEO_H
MEAS_R
MEAS_A
MEAS_H
TARG_R
TARG_A
TARG_H
THEO_SR
THEO_SA
THEO_SH
THEO_ER
THEO_EA
THEO_EH
MEAS_SR
MEAS_SA
MEAS_SH
MEAS_ER
MEAS_EA
MEAS_EH
TARG_SR
TARG_SA
TARG_SH
TARG_ER
TARG_EA
TARG_EH
TARGET_EDGE_SENSILIGHT
F_THICKNESS_EDGE
THICKNESS_TYPE_EDGE
LASER_EXPOSURE
LASER_INTENSITY
ANGLE_OFFSET_2
LASER_FILTER_NEIGHBOR_NUM
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD
LASER_FILTER_TOL_ABOVE
LASER_FILTER_TOL_BELOW
LASER_FILTER_TOL_RIGHT
LASER_CLIP_UP_DIST
LASER_CLIP_LOW_DIST
LASER_PIXEL_TOGGLE
LASER_FILTER_TOGGLE
DISPLAY_PROBE_PARAMETERS
THEO_R2
THEO_A2
THEO_H2
MEAS_R2
MEAS_A2
MEAS_H2
LASER_CLIP_LEFT_DIST
LASER_CLIP_RIGHT_DIST
COP_FILETYPE
COP_SELECTIONTYPE
COP_COLORMAP
COP_COPLEMENT
OPERTYPE
COP_BOOLEANTYPE
COP_IMPORTFILETYPE
MEAS_START_ANG
MEAS_END_ANG
ISLAND_DIAM
ISLAND_LENGTH
ISLAND_WIDTH
ISLAND_X
ISLAND_Y
ISLAND_Z
ISLAND_I
ISLAND_J
ISLAND_K
ISLAND_AI
ISLAND_AJ
ISLAND_AK
ISLAND_TYPE
ISLAND_CLEARANCEDIST
RPT_DIMENSION_TABLES
SUMMARY_DEV
DRF_TBLHDR
LINE1_TBLHDR
LINE1_CALLOUT
LINE1_COLUMN_HDR
LINE1_FEATNAME
LINE1_NOMINAL
LINE1_MEAS
LINE1_PLUSTOL
LINE1_MINUSTOL
LINE1_DEV
LINE1_DEVPERCENT
LINE1_ISBILATERAL
LINE1_NUMZONES
LINE2_TBLHDR
LINE2_CALLOUT
LINE2_COLUMN_HDR
LINE2_FEATNAME
LINE2_BONUS
LINE2_TOL
LINE2_DATUMSHFT
LINE2_UNUSEDZONE
LINE2_DEV
LINE2_DEVANG
LINE2_DEVPERCENT
LINE3_TBLHDR
LINE3_CALLOUT
LINE3_COLUMN_HDR
LINE3_FEATNAME
LINE3_BONUS
LINE3_TOL
LINE3_DATUMSHFT
LINE3_UNUSEDZONE
LINE3_DEV
LINE3_DEVANG
LINE3_DEVPERCENT
DRF_COLUMN_HDR
DRF_SEGNAME
DRF_SHIFTX
DRF_SHIFTY
DRF_SHIFTZ
DRF_ROTATIONX
DRF_ROTATIONY
DRF_ROTATIONZ
SUMMARY_COLUMN_HDR
SUMMARY_FEAT
LINE2_AXIS
LINE2_NOMINAL
LINE2_MEAS
SUMMARY_TBLHDR
SUMMARY_AXIS
SUMMARY_NOMINAL
SUMMARY_MEAS
LINE2_PLUSTOL
LINE2_MINUSTOL
LINE2_MAX
LINE2_MIN
LINE2_ISBILATERAL
LINE2_NUMZONES
LINE3_ISBILATERAL
LINE3_NUMZONES
DIM_RPT_COLUMN_HDR
DIM_RPT_ISDATUM
DIM_RPT_DATUM
DIM_RPT_GRAPHIC
DIM_RPT_DEVPERCENT
DIM_RPT_ISBILATERAL
DIM_RPT_NUMZONES
GDT_SYMBOL
COMMENT_INPUT
TARGET_EDGE_WIDTH
TARGET_EDGE_HEIGHT
TARGET_EDGE_EDGEDETECT
TARGET_EDGE_FILTER_CLEAN
TARGET_EDGE_FILTER_CLEAN_STRENGTH
TARGET_EDGE_FILTER_AREA
TARGET_EDGE_FILTER_AREA_SIZE
TARGET_EDGE_GRADIENT
THEO_PERIMETER
MEAS_PERIMETER
THEO_AREA
MEAS_AREA
TARGET_SURFACE_CROSSHAIR_HEIGHT
SHOW_NOMS
COMPOSITE
DATUM2
TP_MODIFIER2
DESCRIPTION2
SHOW_OPTIONS
LEADER_LINE_ID
GDT_SYMBOL2
DATUM1_MODIFIER
DATUM2_MODIFIER
DATUM3_MODIFIER
DATUM1_MODIFIER2
DATUM2_MODIFIER2
DATUM3_MODIFIER2
DIM_RPT_DEVPERCENT_NOM
DIM_RPT_USETWODEVIATIONS
DIM_RPT_DEVPERCENT2
LINE2_DEVPERCENT_NOM
LINE2_USE2DEVIATIONS
LINE2_DEVPERCENT2
LINE3_DEVPERCENT_NOM
LINE3_USE2DEVIATIONS
LINE3_DEVPERCENT2
AXIS_PLUS_TOL
AXIS_MINUS_TOL
AXIS_NOMINAL
AXIS_DESCRIPTION
LINE1_DEVPERCENT_NOM
LINE1_USE2DEVIATIONS
LINE1_DEVPERCENT2
USE_AXIS2
DIM_LENGTH2
TEXTANAL_LABEL_MEAS_X
TEXTANAL_LABEL_MEAS_Y
TEXTANAL_LABEL_MEAS_Z
TEXTANAL_LABEL_MEAS_I
TEXTANAL_LABEL_MEAS_J
TEXTANAL_LABEL_MEAS_K
TEXTANAL_LABEL_DEV
TEXTANAL_LABEL_MINMAX
SIMULT_EVAL
SECTION_INDEX
LINE1_OUTTOL
LINE2_OUTTOL
LINE3_OUTTOL
LINE1_MAX
LINE1_MIN
LINE3_NOMINAL
LINE3_MEAS
LINE3_PLUSTOL
LINE3_MINUSTOL
LINE3_MAX
LINE3_MIN
SUMMARY_OUTTOL
SUMMARY_PLUSTOL
SUMMARY_MINUSTOL
SUMMARY_MAX
SUMMARY_MIN
SUMMARY_BONUS
LINE1_BONUS
GRAPH_ANALYSIS_POINT_SIZE
GRAPH_ANALYSIS_PLUS_TOL
GRAPH_ANALYSIS_MINUS_TOL
DIM_AXIS_ITEM_NUMBER
F_ENDING_DEPTH
DIM_ITEM_NUMBER
FEAT_ITEM_NUMBER
COMMAND_TYPE
DEV_MAX
AUTO_DEV_DIRECTION
PROBE_DIRECTION
USER_DEFINED_THEOS
SCALING
USE_SCALING
UID
REF_UID
BA_SOLUTION_TYPE
BA_SOLUTION_OPTIONS
BA_SOLUTION_STATUS
BA_VARIANCE
BA_RMS
BA_WARNINGS
BA_STATION
BA_STATION_X
BA_STATION_Y
BA_STATION_Z
BA_STATION_ROTX
BA_STATION_ROTY
BA_STATION_ROTZ
BA_STATION_ORIENTED
BA_STATION_LOCKED
BA_FEATURE
BA_FEAT_SOURCE
BA_FEAT_RMS
BA_FEAT_POINTING_ERR
BA_FEAT_APEX_ANGLE
BA_FEAT_X
BA_FEAT_Y
BA_FEAT_Z
BA_FEAT_DEV_X
BA_FEAT_DEV_Y
BA_FEAT_DEV_Z
BA_FEAT_DEV3D
NO_APPROACH_VECTOR_FLIP
TARGET_EDGE_START_VALUE
TARGET_EDGE_END_VALUE
TARGET_SURFACE_SURFACE_VARIANCE
RELATIVE_COMMENTS
AUTO_ROTARY
TARGET_COVERAGE
ROTATION_TYPE_2
PROBE_TYPE
TIME_STAMP
ECOND_TEMP
ECOND_PRESSURE
ECOND_HUMIDITY
HIT_RMS
DISPLAY_TRACKER_PARAMETERS
PTDENSITY_TOGGLE
PTDENSITY_UPPERBOUND
PTDENSITY_DEVLIMIT
PTDENSITY_MAXSPAN
TARGET_MEASURE_AT_FOV_CENTER
TARGET_SURFACE_FIND_SURFACE
PROJECTOR
INLINE_LEGACY_REPORT
SINGLE_POINT_DEVIATION

See Also

Command Object


GetFieldValue Property

GetFieldValue Property
DataType
ENUM_FIELD_TYPES enumeration indicating the field from which to get the value.
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a field type. When using the index property on a field type that can have a variable number of fields, the index must not be greater than the current number of fields (of the type being changed) + 1.

Description

Returns the value of the indicated field of the command.

This read-only property returns the value of a field from a command.

If you try to access a field that isn't supported by the command, PC-DMIS returns FALSE. This property takes two parameters, the first parameter defines the field item. You can select this item from an enumerated list or use the associated constant number. The second parameter specifies the TypeIndex.

Property type

Read-only property

Syntax

Visual Basic
Public Property GetFieldValue( _
   ByVal DataType As ENUM_FIELD_TYPES, _
   ByVal TypeIndex As Long _
) As Variant

Parameters

DataType
Value Description
ID
REF_ID
LEVEL_REF_ID
ROTATE_REF_ID
ORIGIN_REF_ID
THEO_X
THEO_Y
THEO_Z
THEO_SX
THEO_SY
THEO_SZ
THEO_EX
THEO_EY
THEO_EZ
THEO_I
THEO_J
THEO_K
TARG_X
TARG_Y
TARG_Z
MEAS_X
MEAS_Y
MEAS_Z
MEAS_I
MEAS_J
MEAS_K
MEAS_LENGTH
MEAS_DIAM
MEAS_ANGLE
TARG_I
TARG_J
TARG_K
THEO_DIAM
THEO_WIDTH
THEO_LENGTH
THEO_HEIGHT
THEO_ANGLE
COORD_TYPE
INOUT_TYPE
THICKNESS_TYPE
CIRC_TYPE
SNAP_TYPE
USEPIN_TYPE
MOVE_TYPE
READPOS_TYPE
FINDHOLE_TYPE
RMEAS_TYPE
THEOBF_TYPE
BOUND_TYPE
BF_MATH_TYPE
AUTOFIT_CONSTRAINT
SLOT_MIN_MAX_TYPE
FIND_NOM_AXIS_TYPE
N_INIT_HITS_TYPE
N_PERM_HITS_TYPE
SEARCHMODE_TYPE
MODE_TYPE
MEASURE_ORDER_TYPE
CONE_LENGTH_ANGLE_TYPE
OFFSET_LINE_METHOD
LIN_POL_FILT_TYPE
GEN_FEAT_TYPE
GEN_ALIGN_TYPE
CURVE_TYPE
MEASURED_2D3D_TYPE
THINNING_TOL
HITINT_TYPE
RMEASFEATID
N_HITS
N_ROWS
INIT_HITS
PERM_HITS
F_OFFSET
F_SPACER
F_PITCH
F_THICKNESS
F_DEPTH
F_AUTOMOVE
F_INDENT
F_CORNER_RADIUS
F_INCREMENT
F_TOLERANCE
F_BOXWIDTH
F_BOXLENGTH
F_CIRCRADOUT
F_CIRCRADIN
F_CHECK
F_MAXACCELX
F_MAXACCELY
F_MAXACCELZ
SCAN_ACCELERATION
SCAN_OFFSET_FORCE
MANUAL_FINE_PROBING
F_MOVESPEED
F_TOUCHSPEED
F_SCANSPEED
START_ANG
END_ANG
MIDPOINT_X
MIDPOINT_Y
MIDPOINT_Z
ANGVEC_I
ANGVEC_J
ANGVEC_K
MEASVEC_I
MEASVEC_J
MEASVEC_K
SLOTVEC_I
SLOTVEC_J
SLOTVEC_K
SURFVEC_I
SURFVEC_J
SURFVEC_K
PINVEC_I
PINVEC_J
PINVEC_K
PUNCHVEC_I
PUNCHVEC_J
PUNCHVEC_K
REPORTVEC_I
REPORTVEC_J
REPORTVEC_K
TARGSLOT_I
TARGSLOT_J
TARGSLOT_K
UPDATEVEC_I
UPDATEVEC_J
UPDATEVEC_K
THEO_MINOR_AXIS
TWO_D_THREE_D_TYPE
AXIS
DEST_EXPR
SRC_EXPR
SHOW_IDS
SHOW_DETAILS
WEIGHT
ITEM_USED
USE_AXIS
AVERAGE_ERROR
MEASURE_ALL_FEATURES
REPIERCE_CAD
START_NUM
END_NUM
SKIP_NUM
X_OFFSET
Y_OFFSET
Z_OFFSET
ANGLE_OFFSET
INTERNAL_EXTERNAL
SAVE_ALIGN_CAD_TO_PARTS
FILE_NAME
ALIGN_LIST
WORK_PLANE
DISTANCE
OLD_TIP
NEW_TIP
ROTATION_TYPE
DIM_INFO_ORDER
DIM_INFO_LOC
DIM_INFO_TP_LOC
GRAPH_ANALYSIS
TEXT_ANALYSIS
ARROW_MULTIPLIER
OUTPUT_TYPE
NOMINAL
F_PLUS_TOL
F_MINUS_TOL
TP_MODIFIER
PERP_PARALLEL_TYPE
RADIUS_TYPE
UNIT_TYPE
DIM_LENGTH
PROFILE_FORM_TYPE
PRECISION
MAN_RETRACT
DIM_TEXT
DIM_TEXT_OPTIONS
SHOW_HEADINGS
DEVIATION_SYMBOLS
STANDARD_DEVIATION
DIM_HEADING
GAP_ONLY_TYPE
DISPLAY_ID
DISPLAY_TYPE
POINT_INFO_HEADING
SHOW_POINT_INFO
RET_ONLY_TYPE
COMMENT_FIELD
COMMENT_TYPE
PART_NAME
REVISION_NUMBER
SERIAL_NUMBER
STAT_COUNT
SUB_NAME
READ_WRITE
FILE_POINTER
FIELD_WIDTH
DIGIT_COUNT
LABEL_ID
ERROR_TYPE
ERROR_MODE
DESCRIPTION
INDEX_START
INDEX_END
FILE_COMMAND_TYPE
BUFFER_SIZE_TYPE
FAIL_ON_EXIST
MAX_FORCE
LOW_FORCE
UP_FORCE
TRIGGER_FORCE
PROBE_ACCURACY
POSITIONAL_ACCURACY
NUM_RETURN_DATA
RETURN_SPEED
SCAN_DENSITY
POLAR_VECTOR_COMPENSATION
AUTO_PRINT
ORIGIN
MATERIAL_COEFFICIENT
REF_TEMP
HIGH_THRESHOLD
LOW_THRESHOLD
SENSOR_LIST
FIXTURE_TYPE
MACHINE_TYPE
PROBE_COMP
TIP_I
TIP_J
TIP_K
NORM_RELEARN
FIND_NOMS_TYPE
AUTO_CLEAR_PLANE
SINGLE_POINT
DISPLAY_HITS
CAD_TOLERANCE
OFFSET_TOLERANCE
MIN_INCREMENT
MAX_INCREMENT
MIN_ANGLE
MAX_ANGLE
F_LOCATION
COL132_TYPE
COMMAND_STRING
FLY_MODE_TYPE
STATS_TYPE
STATS_DIR
NEW_STATS_DIR
DATA_READ_LOCK
DATA_WRITE_LOCK
DATA_MEM_PAGES
STAT_NAME_TYPE
STAT_CALC_TYPE
TRANSFER_DIR
DISPLAY_TRACE
TRACE_NAME
TRACE_VALUE
SCAN_CUTPLANEVEC_I
SCAN_CUTPLANEVEC_J
SCAN_CUTPLANEVEC_K
SCAN_INITVEC_I
SCAN_INITVEC_J
SCAN_INITVEC_K
SCAN_AXISVEC_I
SCAN_AXISVEC_J
SCAN_AXISVEC_K
SCAN_ENDVEC_I
SCAN_ENDVEC_J
SCAN_ENDVEC_K
SCAN_INITDIR_I
SCAN_INITDIR_J
SCAN_INITDIR_K
SCAN_CROSS_TOTAL
SCAN_TIME_INCR
SCAN_EDGE_THICK
POS_REPORT_AXIS_X
POS_REPORT_AXIS_Y
POS_REPORT_AXIS_Z
DEV_PERPEN_CENTERLINE
USE_THEO
TARGET_COLOR
THEO_START_ANG
THEO_END_ANG
ONOFF_TYPE
ROW_ID
LOCATOR_BMP
LOCATOR_WAV
DTYPE_LEAPFROGTYPE
DTYPE_LEAPFROGNUMHITS
DTYPE_LEAPFROGFULLPARTIAL
EXCLUSION_ZONE
EXECUTE
AUTOTRIGGERONOFF
AUTOBEEPING
COLUMN_ID
SLOT_NUMBER
AUTOTOLZONE
PROBING_MODE
ANGLE_COMP_TOGGLE
POINTINFO_FILTER_INTERVAL
POINTINFO_FILTER_INTERVAL_NUMBER
FEAT_TYPE
DIM_ID
MEAS_MINOR_AXIS
MEAS_HEIGHT
MEAS_SLOTVEC_I
MEAS_SLOTVEC_J
MEAS_SLOTVEC_K
MEAS_SX
MEAS_SY
MEAS_SZ
MEAS_EX
MEAS_EY
MEAS_EZ
MEAS_WIDTH
NUM_CONTROL_POINTS
U_HITS
V_HITS
NUM_FIT_POINTS
NOMINAL_COLOR
WAVE_FILE
DIM_BONUS
PERUNIT_STEPSIZE
PERUNIT_LENGTH
PERUNIT_WIDTH
DIM_MEASURED
SURFVEC_TARG_I
SURFVEC_TARG_J
SURFVEC_TARG_K
DIM_MAX
EDGEVEC_TARG_I
EDGEVEC_TARG_J
EDGEVEC_TARG_K
DIM_MIN
EDGEVEC_THEO_I
EDGEVEC_THEO_J
EDGEVEC_THEO_K
DIM_DEVIATION
EDGEVEC_MEAS_I
EDGEVEC_MEAS_J
EDGEVEC_MEAS_K
DIM_OUTTOL
T_VALUE
TOOL_X
TOOL_Y
TOOL_Z
TOOL_DIAM
DEV_X
DEV_Y
DEV_Z
DEV_DIAM
ITERATE_COLUMNS
LOAD_TYPE
NUM_ITERATIONS
METHOD_TYPE
SCAN_TECHNIQUE
HIT_TYPE
BOUNDARY_POINT_X
BOUNDARY_POINT_Y
BOUNDARY_POINT_Z
VIDEO_GAIN
VIDEO_OFFSET
VIDEO_LEDLIGHT
VIDEO_LASERLIGHT1
VIDEO_LASERLIGHT2
VIDEO_YORIGIN
VIDEO_YEND
VIDEO_LSEG
VIDEO_XSEG
VIDEO_YSEG
ANGULARITY_NOM_ANGLE
PRINT_TO_FILE
PRINT_TO_PRINTER
PRINT_DRAFTMODE
PRINT_DELETE_RUNS
POINTINFO_FILTER_WORST
POINTINFO_FILTER_WORST_NUMBER
POINTINFO_FILTER_DEVIATION
POINTINFO_FILTER_DEVIATION_NUMBER
POINTINFO_FILTER_OUTTOL
REPORT_SURFVEC_I
REPORT_SURFVEC_J
REPORT_SURFVEC_K
DB_QUERY_OP
DB_SOURCE_NAME
CHART_TYPE
DB_CHART_NAME
DEVIATION_ANGLE
STATS_DATASOURCE
IGNOREMOTIONERRORS_TYPE
THEO_X2
THEO_Y2
THEO_Z2
MEAS_X2
MEAS_Y2
MEAS_Z2
PPROG
TRACE_FILTER
TIME_FILTER
SHOW_SPC_CALCS
SPEC_LIMITS
ZONES
STDDEV
UCL_LCL
HISTOGRAM
GRID
ADDITIONAL_CHART
LINE2_PLANAR_OPEN_IN_X
LINE3_PLANAR_OPEN_IN_X
REGR
CENTER_POINT
SHOW_MORE_SPC_CALCS
SPEC_OFFSET
SOLID
U_L_BOUNDS
TITLE
CPOINT_X
CPOINT_Y
CPOINT_Z
CPOINT_I
CPOINT_J
CPOINT_K
CPOINT_DIAM
CPOINT_SCAN_CROSS_TOTAL
CPOINT_SCAN_DENSITY
CPOINT_F_SCANSPEED
N_CONTROLPOINTS
CPOINT_TYPE
USE_3DFILTER
SCAN_BNDRY_TYPE
CREATE_WEIGHTS
F_SIZE
LINE2_ISPLANAR
LINE2_PLANAR_XTOL
LINE2_PLANAR_YTOL
LINE2_PLANAR_XDEV
LINE2_PLANAR_YDEV
LINE3_ISPLANAR
LINE3_PLANAR_XTOL
LINE3_PLANAR_YTOL
LINE3_PLANAR_XDEV
LINE3_PLANAR_YDEV
CHART_SUB_TYPE
OVERWRITE
OUTPUT_FEATURE_NOMS
OUTPUT_FEAT_W_DIMENS
OUTPUT_DMIS_REPORT
TIME_ARG
TRACE_FILTER_ARG
FIT
STATS_DB_TYPE
IOCHANNEL_NUMBER
IOCHANNEL_PULSE_WIDTH
IOCHANNEL_PULSE_INTERVAL
IOCHANNEL_PULSE_DURATION
GRAPH_OPTION
DB_SOURCE_TYPE
FIND_HOLE_PERCENT
AUTO_ONERROR_TYPE
POS_REPT_DISPLAY_OPTION
TRIGGERTOLERANCE
TRIGGERTOLVALUE
FIXTURE_TOL
START_LABEL
ERROR_LABEL
CONE_CONVEX_TYPE
TRIGGERPLANE
QUERY_SHOW_GRAPHIC_SETTINGS
CALC_STYLE_FILE
FILTER_TYPE
TRACE_VALUE_LIMIT
TARGET_DIRECTION
TARGET_EDGE_POLARITY
BSMETHOD_TYPE
CENTER_ROTATION_THEO
CENTER_ROTATION_MEAS
ARTICULATEDARM_TYPE
LEFTYRIGHTY_CONFIG
ABOVEBELOW_CONFIG
NOFLIPFLIP_CONFIG
HIGH_ACCURACY
SURFACE
MAGNIFICATION
MINOR_WORD_TOGGLE
PERCENTAGE
THRESHOLD
N_SIDES
TARGET_SURFACE_ILLUM
MEAN
CAD_COMP
SHOW_ROW
SHOW_COLUMN
TARGET_SURFACE_SENSILIGHT
TARGET_SURFACE_WIDTH
TARGET_SURFACE_HEIGHT
TARGET_SURFACE_RANGE
TARGET_SURFACE_DURATION
TARGET_SURFACE_MODE
TARGET_SURFACE_HIACC
SCREEN_CAPTURE_SCALE
SCREEN_CAPTURE_QUALITY
TARGET_EDGE_SIZE
TARGET_EDGE_ILLUM
TARGET_EDGE_TOL
TARGET_EDGE_STRENGTH
TARGET_EDGE_DENSITY
TARGET_EDGE_TYPE
DISPLAY_ADVANCED_PARAMETERS
TARGET_SURFACE_TYPE
VOID_DETECT
TARG_SX
TARG_SY
TARG_SZ
TARG_EX
TARG_EY
TARG_EZ
PATTERN_TYPE
TARGET_EDGE_ANGLE
PROGRAM_GAGE_FEAT_TYPE
PROGRAM_GAGE_TYPE
TARGET_FOCUS
RMEASFEATIDX
RMEASFEATIDY
RMEASFEATIDZ
FINDNOMS_BESTFIT
FINDNOMS_ONLYSELECTED
TEMPX
TEMPY
TEMPZ
TEMPP
AUTO_PH9
MANUAL_PREPOSITION
SCREEN_CAPTURE_TYPE
SCREEN_CAPTURE_AUTO_TYPE
TARGET_EDGE_EDGESELECT
TARGET_EDGE_EDGENUM
DELETE_TYPE
SCREEN_CAPTURE_AUTO_TIME
USE_HSSDAT
USE_STARTENDDELAY
COP_FILTER
COP_SIZE
COP_TYPE
SURFVEC_MEAS_I
SURFVEC_MEAS_J
SURFVEC_MEAS_K
TARGET_EDGE_UNDERSCAN
PROFILE_TYPE
THEO_FLUSH
MEAS_FLUSH
THEO_GAP
MEAS_GAP
THEO_DEPTH
MEAS_DEPTH
TARGET_BLOB_TYPE
LASER_STRIPE_OVERLAP
LASER_STRIPE_OVERSCAN
LASER_FREQUENCY
TARGET_FILTER_OUTLIER
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD
SLOT_TYPE
TARGET_TYPE
THEO_R
THEO_A
THEO_H
MEAS_R
MEAS_A
MEAS_H
TARG_R
TARG_A
TARG_H
THEO_SR
THEO_SA
THEO_SH
THEO_ER
THEO_EA
THEO_EH
MEAS_SR
MEAS_SA
MEAS_SH
MEAS_ER
MEAS_EA
MEAS_EH
TARG_SR
TARG_SA
TARG_SH
TARG_ER
TARG_EA
TARG_EH
TARGET_EDGE_SENSILIGHT
F_THICKNESS_EDGE
THICKNESS_TYPE_EDGE
LASER_EXPOSURE
LASER_INTENSITY
ANGLE_OFFSET_2
LASER_FILTER_NEIGHBOR_NUM
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD
LASER_FILTER_TOL_ABOVE
LASER_FILTER_TOL_BELOW
LASER_FILTER_TOL_RIGHT
LASER_CLIP_UP_DIST
LASER_CLIP_LOW_DIST
LASER_PIXEL_TOGGLE
LASER_FILTER_TOGGLE
DISPLAY_PROBE_PARAMETERS
THEO_R2
THEO_A2
THEO_H2
MEAS_R2
MEAS_A2
MEAS_H2
LASER_CLIP_LEFT_DIST
LASER_CLIP_RIGHT_DIST
COP_FILETYPE
COP_SELECTIONTYPE
COP_COLORMAP
COP_COPLEMENT
OPERTYPE
COP_BOOLEANTYPE
COP_IMPORTFILETYPE
MEAS_START_ANG
MEAS_END_ANG
ISLAND_DIAM
ISLAND_LENGTH
ISLAND_WIDTH
ISLAND_X
ISLAND_Y
ISLAND_Z
ISLAND_I
ISLAND_J
ISLAND_K
ISLAND_AI
ISLAND_AJ
ISLAND_AK
ISLAND_TYPE
ISLAND_CLEARANCEDIST
RPT_DIMENSION_TABLES
SUMMARY_DEV
DRF_TBLHDR
LINE1_TBLHDR
LINE1_CALLOUT
LINE1_COLUMN_HDR
LINE1_FEATNAME
LINE1_NOMINAL
LINE1_MEAS
LINE1_PLUSTOL
LINE1_MINUSTOL
LINE1_DEV
LINE1_DEVPERCENT
LINE1_ISBILATERAL
LINE1_NUMZONES
LINE2_TBLHDR
LINE2_CALLOUT
LINE2_COLUMN_HDR
LINE2_FEATNAME
LINE2_BONUS
LINE2_TOL
LINE2_DATUMSHFT
LINE2_UNUSEDZONE
LINE2_DEV
LINE2_DEVANG
LINE2_DEVPERCENT
LINE3_TBLHDR
LINE3_CALLOUT
LINE3_COLUMN_HDR
LINE3_FEATNAME
LINE3_BONUS
LINE3_TOL
LINE3_DATUMSHFT
LINE3_UNUSEDZONE
LINE3_DEV
LINE3_DEVANG
LINE3_DEVPERCENT
DRF_COLUMN_HDR
DRF_SEGNAME
DRF_SHIFTX
DRF_SHIFTY
DRF_SHIFTZ
DRF_ROTATIONX
DRF_ROTATIONY
DRF_ROTATIONZ
SUMMARY_COLUMN_HDR
SUMMARY_FEAT
LINE2_AXIS
LINE2_NOMINAL
LINE2_MEAS
SUMMARY_TBLHDR
SUMMARY_AXIS
SUMMARY_NOMINAL
SUMMARY_MEAS
LINE2_PLUSTOL
LINE2_MINUSTOL
LINE2_MAX
LINE2_MIN
LINE2_ISBILATERAL
LINE2_NUMZONES
LINE3_ISBILATERAL
LINE3_NUMZONES
DIM_RPT_COLUMN_HDR
DIM_RPT_ISDATUM
DIM_RPT_DATUM
DIM_RPT_GRAPHIC
DIM_RPT_DEVPERCENT
DIM_RPT_ISBILATERAL
DIM_RPT_NUMZONES
GDT_SYMBOL
COMMENT_INPUT
TARGET_EDGE_WIDTH
TARGET_EDGE_HEIGHT
TARGET_EDGE_EDGEDETECT
TARGET_EDGE_FILTER_CLEAN
TARGET_EDGE_FILTER_CLEAN_STRENGTH
TARGET_EDGE_FILTER_AREA
TARGET_EDGE_FILTER_AREA_SIZE
TARGET_EDGE_GRADIENT
THEO_PERIMETER
MEAS_PERIMETER
THEO_AREA
MEAS_AREA
TARGET_SURFACE_CROSSHAIR_HEIGHT
SHOW_NOMS
COMPOSITE
DATUM2
TP_MODIFIER2
DESCRIPTION2
SHOW_OPTIONS
LEADER_LINE_ID
GDT_SYMBOL2
DATUM1_MODIFIER
DATUM2_MODIFIER
DATUM3_MODIFIER
DATUM1_MODIFIER2
DATUM2_MODIFIER2
DATUM3_MODIFIER2
DIM_RPT_DEVPERCENT_NOM
DIM_RPT_USETWODEVIATIONS
DIM_RPT_DEVPERCENT2
LINE2_DEVPERCENT_NOM
LINE2_USE2DEVIATIONS
LINE2_DEVPERCENT2
LINE3_DEVPERCENT_NOM
LINE3_USE2DEVIATIONS
LINE3_DEVPERCENT2
AXIS_PLUS_TOL
AXIS_MINUS_TOL
AXIS_NOMINAL
AXIS_DESCRIPTION
LINE1_DEVPERCENT_NOM
LINE1_USE2DEVIATIONS
LINE1_DEVPERCENT2
USE_AXIS2
DIM_LENGTH2
TEXTANAL_LABEL_MEAS_X
TEXTANAL_LABEL_MEAS_Y
TEXTANAL_LABEL_MEAS_Z
TEXTANAL_LABEL_MEAS_I
TEXTANAL_LABEL_MEAS_J
TEXTANAL_LABEL_MEAS_K
TEXTANAL_LABEL_DEV
TEXTANAL_LABEL_MINMAX
SIMULT_EVAL
SECTION_INDEX
LINE1_OUTTOL
LINE2_OUTTOL
LINE3_OUTTOL
LINE1_MAX
LINE1_MIN
LINE3_NOMINAL
LINE3_MEAS
LINE3_PLUSTOL
LINE3_MINUSTOL
LINE3_MAX
LINE3_MIN
SUMMARY_OUTTOL
SUMMARY_PLUSTOL
SUMMARY_MINUSTOL
SUMMARY_MAX
SUMMARY_MIN
SUMMARY_BONUS
LINE1_BONUS
GRAPH_ANALYSIS_POINT_SIZE
GRAPH_ANALYSIS_PLUS_TOL
GRAPH_ANALYSIS_MINUS_TOL
DIM_AXIS_ITEM_NUMBER
F_ENDING_DEPTH
DIM_ITEM_NUMBER
FEAT_ITEM_NUMBER
COMMAND_TYPE
DEV_MAX
AUTO_DEV_DIRECTION
PROBE_DIRECTION
USER_DEFINED_THEOS
SCALING
USE_SCALING
UID
REF_UID
BA_SOLUTION_TYPE
BA_SOLUTION_OPTIONS
BA_SOLUTION_STATUS
BA_VARIANCE
BA_RMS
BA_WARNINGS
BA_STATION
BA_STATION_X
BA_STATION_Y
BA_STATION_Z
BA_STATION_ROTX
BA_STATION_ROTY
BA_STATION_ROTZ
BA_STATION_ORIENTED
BA_STATION_LOCKED
BA_FEATURE
BA_FEAT_SOURCE
BA_FEAT_RMS
BA_FEAT_POINTING_ERR
BA_FEAT_APEX_ANGLE
BA_FEAT_X
BA_FEAT_Y
BA_FEAT_Z
BA_FEAT_DEV_X
BA_FEAT_DEV_Y
BA_FEAT_DEV_Z
BA_FEAT_DEV3D
NO_APPROACH_VECTOR_FLIP
TARGET_EDGE_START_VALUE
TARGET_EDGE_END_VALUE
TARGET_SURFACE_SURFACE_VARIANCE
RELATIVE_COMMENTS
AUTO_ROTARY
TARGET_COVERAGE
ROTATION_TYPE_2
PROBE_TYPE
TIME_STAMP
ECOND_TEMP
ECOND_PRESSURE
ECOND_HUMIDITY
HIT_RMS
DISPLAY_TRACKER_PARAMETERS
PTDENSITY_TOGGLE
PTDENSITY_UPPERBOUND
PTDENSITY_DEVLIMIT
PTDENSITY_MAXSPAN
TARGET_MEASURE_AT_FOV_CENTER
TARGET_SURFACE_FIND_SURFACE
PROJECTOR
INLINE_LEGACY_REPORT
SINGLE_POINT_DEVIATION
ENUM_FIELD_TYPES enumeration indicating the field from which to get the value.
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a field type. When using the index property on a field type that can have a variable number of fields, the index must not be greater than the current number of fields (of the type being changed) + 1.

Example

' Suppose your part program has a circle named CIR1.

' This example would return the theoretical diameter of that circle:

Set myapp = CreateObject("pcdlrn.application")

Set myprog = myapp.ActivePartProgram

Dim Cmds As Commands

Set Cmds = myprog.Commands

Dim Cmd As Command

Set Cmd = Cmds.Item("CIR1")

MsgBox Cmd.ID

MsgBox Cmd.GetFieldValue(THEO_DIAM, 0)

See Also

Command Object


GetToggleValue Property

GetToggleValue Property
DataType
ENUM_FIELD_TYPES enumeration indicating the field from which to get the value.
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a specified field type. In these cases, the TypeIndex must not be greater than the current number of fields of the that type + 1 and TypeIndex must be greater than 1. For fields that allow only a single value, the TypeIndex is 0.

Description

Returns 0 if the field is not a toggle otherwise returns the toggle index

This read-only property checks a command's field and returns 0 if it isn't a toggle field. It also returns 0 if the field doesn't exist. Otherwise, it returns a the current toggle index value, with 1 as the base index value.

It takes two parameters. The first is an enumerated field type value to determine what field to check in a command, and the second is the TypeIndex.

Property type

Read-only property

Syntax

Visual Basic
Public Property GetToggleValue( _
   ByVal DataType As ENUM_FIELD_TYPES, _
   ByVal TypeIndex As Long _
) As Long

Parameters

DataType
Value Description
ID
REF_ID
LEVEL_REF_ID
ROTATE_REF_ID
ORIGIN_REF_ID
THEO_X
THEO_Y
THEO_Z
THEO_SX
THEO_SY
THEO_SZ
THEO_EX
THEO_EY
THEO_EZ
THEO_I
THEO_J
THEO_K
TARG_X
TARG_Y
TARG_Z
MEAS_X
MEAS_Y
MEAS_Z
MEAS_I
MEAS_J
MEAS_K
MEAS_LENGTH
MEAS_DIAM
MEAS_ANGLE
TARG_I
TARG_J
TARG_K
THEO_DIAM
THEO_WIDTH
THEO_LENGTH
THEO_HEIGHT
THEO_ANGLE
COORD_TYPE
INOUT_TYPE
THICKNESS_TYPE
CIRC_TYPE
SNAP_TYPE
USEPIN_TYPE
MOVE_TYPE
READPOS_TYPE
FINDHOLE_TYPE
RMEAS_TYPE
THEOBF_TYPE
BOUND_TYPE
BF_MATH_TYPE
AUTOFIT_CONSTRAINT
SLOT_MIN_MAX_TYPE
FIND_NOM_AXIS_TYPE
N_INIT_HITS_TYPE
N_PERM_HITS_TYPE
SEARCHMODE_TYPE
MODE_TYPE
MEASURE_ORDER_TYPE
CONE_LENGTH_ANGLE_TYPE
OFFSET_LINE_METHOD
LIN_POL_FILT_TYPE
GEN_FEAT_TYPE
GEN_ALIGN_TYPE
CURVE_TYPE
MEASURED_2D3D_TYPE
THINNING_TOL
HITINT_TYPE
RMEASFEATID
N_HITS
N_ROWS
INIT_HITS
PERM_HITS
F_OFFSET
F_SPACER
F_PITCH
F_THICKNESS
F_DEPTH
F_AUTOMOVE
F_INDENT
F_CORNER_RADIUS
F_INCREMENT
F_TOLERANCE
F_BOXWIDTH
F_BOXLENGTH
F_CIRCRADOUT
F_CIRCRADIN
F_CHECK
F_MAXACCELX
F_MAXACCELY
F_MAXACCELZ
SCAN_ACCELERATION
SCAN_OFFSET_FORCE
MANUAL_FINE_PROBING
F_MOVESPEED
F_TOUCHSPEED
F_SCANSPEED
START_ANG
END_ANG
MIDPOINT_X
MIDPOINT_Y
MIDPOINT_Z
ANGVEC_I
ANGVEC_J
ANGVEC_K
MEASVEC_I
MEASVEC_J
MEASVEC_K
SLOTVEC_I
SLOTVEC_J
SLOTVEC_K
SURFVEC_I
SURFVEC_J
SURFVEC_K
PINVEC_I
PINVEC_J
PINVEC_K
PUNCHVEC_I
PUNCHVEC_J
PUNCHVEC_K
REPORTVEC_I
REPORTVEC_J
REPORTVEC_K
TARGSLOT_I
TARGSLOT_J
TARGSLOT_K
UPDATEVEC_I
UPDATEVEC_J
UPDATEVEC_K
THEO_MINOR_AXIS
TWO_D_THREE_D_TYPE
AXIS
DEST_EXPR
SRC_EXPR
SHOW_IDS
SHOW_DETAILS
WEIGHT
ITEM_USED
USE_AXIS
AVERAGE_ERROR
MEASURE_ALL_FEATURES
REPIERCE_CAD
START_NUM
END_NUM
SKIP_NUM
X_OFFSET
Y_OFFSET
Z_OFFSET
ANGLE_OFFSET
INTERNAL_EXTERNAL
SAVE_ALIGN_CAD_TO_PARTS
FILE_NAME
ALIGN_LIST
WORK_PLANE
DISTANCE
OLD_TIP
NEW_TIP
ROTATION_TYPE
DIM_INFO_ORDER
DIM_INFO_LOC
DIM_INFO_TP_LOC
GRAPH_ANALYSIS
TEXT_ANALYSIS
ARROW_MULTIPLIER
OUTPUT_TYPE
NOMINAL
F_PLUS_TOL
F_MINUS_TOL
TP_MODIFIER
PERP_PARALLEL_TYPE
RADIUS_TYPE
UNIT_TYPE
DIM_LENGTH
PROFILE_FORM_TYPE
PRECISION
MAN_RETRACT
DIM_TEXT
DIM_TEXT_OPTIONS
SHOW_HEADINGS
DEVIATION_SYMBOLS
STANDARD_DEVIATION
DIM_HEADING
GAP_ONLY_TYPE
DISPLAY_ID
DISPLAY_TYPE
POINT_INFO_HEADING
SHOW_POINT_INFO
RET_ONLY_TYPE
COMMENT_FIELD
COMMENT_TYPE
PART_NAME
REVISION_NUMBER
SERIAL_NUMBER
STAT_COUNT
SUB_NAME
READ_WRITE
FILE_POINTER
FIELD_WIDTH
DIGIT_COUNT
LABEL_ID
ERROR_TYPE
ERROR_MODE
DESCRIPTION
INDEX_START
INDEX_END
FILE_COMMAND_TYPE
BUFFER_SIZE_TYPE
FAIL_ON_EXIST
MAX_FORCE
LOW_FORCE
UP_FORCE
TRIGGER_FORCE
PROBE_ACCURACY
POSITIONAL_ACCURACY
NUM_RETURN_DATA
RETURN_SPEED
SCAN_DENSITY
POLAR_VECTOR_COMPENSATION
AUTO_PRINT
ORIGIN
MATERIAL_COEFFICIENT
REF_TEMP
HIGH_THRESHOLD
LOW_THRESHOLD
SENSOR_LIST
FIXTURE_TYPE
MACHINE_TYPE
PROBE_COMP
TIP_I
TIP_J
TIP_K
NORM_RELEARN
FIND_NOMS_TYPE
AUTO_CLEAR_PLANE
SINGLE_POINT
DISPLAY_HITS
CAD_TOLERANCE
OFFSET_TOLERANCE
MIN_INCREMENT
MAX_INCREMENT
MIN_ANGLE
MAX_ANGLE
F_LOCATION
COL132_TYPE
COMMAND_STRING
FLY_MODE_TYPE
STATS_TYPE
STATS_DIR
NEW_STATS_DIR
DATA_READ_LOCK
DATA_WRITE_LOCK
DATA_MEM_PAGES
STAT_NAME_TYPE
STAT_CALC_TYPE
TRANSFER_DIR
DISPLAY_TRACE
TRACE_NAME
TRACE_VALUE
SCAN_CUTPLANEVEC_I
SCAN_CUTPLANEVEC_J
SCAN_CUTPLANEVEC_K
SCAN_INITVEC_I
SCAN_INITVEC_J
SCAN_INITVEC_K
SCAN_AXISVEC_I
SCAN_AXISVEC_J
SCAN_AXISVEC_K
SCAN_ENDVEC_I
SCAN_ENDVEC_J
SCAN_ENDVEC_K
SCAN_INITDIR_I
SCAN_INITDIR_J
SCAN_INITDIR_K
SCAN_CROSS_TOTAL
SCAN_TIME_INCR
SCAN_EDGE_THICK
POS_REPORT_AXIS_X
POS_REPORT_AXIS_Y
POS_REPORT_AXIS_Z
DEV_PERPEN_CENTERLINE
USE_THEO
TARGET_COLOR
THEO_START_ANG
THEO_END_ANG
ONOFF_TYPE
ROW_ID
LOCATOR_BMP
LOCATOR_WAV
DTYPE_LEAPFROGTYPE
DTYPE_LEAPFROGNUMHITS
DTYPE_LEAPFROGFULLPARTIAL
EXCLUSION_ZONE
EXECUTE
AUTOTRIGGERONOFF
AUTOBEEPING
COLUMN_ID
SLOT_NUMBER
AUTOTOLZONE
PROBING_MODE
ANGLE_COMP_TOGGLE
POINTINFO_FILTER_INTERVAL
POINTINFO_FILTER_INTERVAL_NUMBER
FEAT_TYPE
DIM_ID
MEAS_MINOR_AXIS
MEAS_HEIGHT
MEAS_SLOTVEC_I
MEAS_SLOTVEC_J
MEAS_SLOTVEC_K
MEAS_SX
MEAS_SY
MEAS_SZ
MEAS_EX
MEAS_EY
MEAS_EZ
MEAS_WIDTH
NUM_CONTROL_POINTS
U_HITS
V_HITS
NUM_FIT_POINTS
NOMINAL_COLOR
WAVE_FILE
DIM_BONUS
PERUNIT_STEPSIZE
PERUNIT_LENGTH
PERUNIT_WIDTH
DIM_MEASURED
SURFVEC_TARG_I
SURFVEC_TARG_J
SURFVEC_TARG_K
DIM_MAX
EDGEVEC_TARG_I
EDGEVEC_TARG_J
EDGEVEC_TARG_K
DIM_MIN
EDGEVEC_THEO_I
EDGEVEC_THEO_J
EDGEVEC_THEO_K
DIM_DEVIATION
EDGEVEC_MEAS_I
EDGEVEC_MEAS_J
EDGEVEC_MEAS_K
DIM_OUTTOL
T_VALUE
TOOL_X
TOOL_Y
TOOL_Z
TOOL_DIAM
DEV_X
DEV_Y
DEV_Z
DEV_DIAM
ITERATE_COLUMNS
LOAD_TYPE
NUM_ITERATIONS
METHOD_TYPE
SCAN_TECHNIQUE
HIT_TYPE
BOUNDARY_POINT_X
BOUNDARY_POINT_Y
BOUNDARY_POINT_Z
VIDEO_GAIN
VIDEO_OFFSET
VIDEO_LEDLIGHT
VIDEO_LASERLIGHT1
VIDEO_LASERLIGHT2
VIDEO_YORIGIN
VIDEO_YEND
VIDEO_LSEG
VIDEO_XSEG
VIDEO_YSEG
ANGULARITY_NOM_ANGLE
PRINT_TO_FILE
PRINT_TO_PRINTER
PRINT_DRAFTMODE
PRINT_DELETE_RUNS
POINTINFO_FILTER_WORST
POINTINFO_FILTER_WORST_NUMBER
POINTINFO_FILTER_DEVIATION
POINTINFO_FILTER_DEVIATION_NUMBER
POINTINFO_FILTER_OUTTOL
REPORT_SURFVEC_I
REPORT_SURFVEC_J
REPORT_SURFVEC_K
DB_QUERY_OP
DB_SOURCE_NAME
CHART_TYPE
DB_CHART_NAME
DEVIATION_ANGLE
STATS_DATASOURCE
IGNOREMOTIONERRORS_TYPE
THEO_X2
THEO_Y2
THEO_Z2
MEAS_X2
MEAS_Y2
MEAS_Z2
PPROG
TRACE_FILTER
TIME_FILTER
SHOW_SPC_CALCS
SPEC_LIMITS
ZONES
STDDEV
UCL_LCL
HISTOGRAM
GRID
ADDITIONAL_CHART
LINE2_PLANAR_OPEN_IN_X
LINE3_PLANAR_OPEN_IN_X
REGR
CENTER_POINT
SHOW_MORE_SPC_CALCS
SPEC_OFFSET
SOLID
U_L_BOUNDS
TITLE
CPOINT_X
CPOINT_Y
CPOINT_Z
CPOINT_I
CPOINT_J
CPOINT_K
CPOINT_DIAM
CPOINT_SCAN_CROSS_TOTAL
CPOINT_SCAN_DENSITY
CPOINT_F_SCANSPEED
N_CONTROLPOINTS
CPOINT_TYPE
USE_3DFILTER
SCAN_BNDRY_TYPE
CREATE_WEIGHTS
F_SIZE
LINE2_ISPLANAR
LINE2_PLANAR_XTOL
LINE2_PLANAR_YTOL
LINE2_PLANAR_XDEV
LINE2_PLANAR_YDEV
LINE3_ISPLANAR
LINE3_PLANAR_XTOL
LINE3_PLANAR_YTOL
LINE3_PLANAR_XDEV
LINE3_PLANAR_YDEV
CHART_SUB_TYPE
OVERWRITE
OUTPUT_FEATURE_NOMS
OUTPUT_FEAT_W_DIMENS
OUTPUT_DMIS_REPORT
TIME_ARG
TRACE_FILTER_ARG
FIT
STATS_DB_TYPE
IOCHANNEL_NUMBER
IOCHANNEL_PULSE_WIDTH
IOCHANNEL_PULSE_INTERVAL
IOCHANNEL_PULSE_DURATION
GRAPH_OPTION
DB_SOURCE_TYPE
FIND_HOLE_PERCENT
AUTO_ONERROR_TYPE
POS_REPT_DISPLAY_OPTION
TRIGGERTOLERANCE
TRIGGERTOLVALUE
FIXTURE_TOL
START_LABEL
ERROR_LABEL
CONE_CONVEX_TYPE
TRIGGERPLANE
QUERY_SHOW_GRAPHIC_SETTINGS
CALC_STYLE_FILE
FILTER_TYPE
TRACE_VALUE_LIMIT
TARGET_DIRECTION
TARGET_EDGE_POLARITY
BSMETHOD_TYPE
CENTER_ROTATION_THEO
CENTER_ROTATION_MEAS
ARTICULATEDARM_TYPE
LEFTYRIGHTY_CONFIG
ABOVEBELOW_CONFIG
NOFLIPFLIP_CONFIG
HIGH_ACCURACY
SURFACE
MAGNIFICATION
MINOR_WORD_TOGGLE
PERCENTAGE
THRESHOLD
N_SIDES
TARGET_SURFACE_ILLUM
MEAN
CAD_COMP
SHOW_ROW
SHOW_COLUMN
TARGET_SURFACE_SENSILIGHT
TARGET_SURFACE_WIDTH
TARGET_SURFACE_HEIGHT
TARGET_SURFACE_RANGE
TARGET_SURFACE_DURATION
TARGET_SURFACE_MODE
TARGET_SURFACE_HIACC
SCREEN_CAPTURE_SCALE
SCREEN_CAPTURE_QUALITY
TARGET_EDGE_SIZE
TARGET_EDGE_ILLUM
TARGET_EDGE_TOL
TARGET_EDGE_STRENGTH
TARGET_EDGE_DENSITY
TARGET_EDGE_TYPE
DISPLAY_ADVANCED_PARAMETERS
TARGET_SURFACE_TYPE
VOID_DETECT
TARG_SX
TARG_SY
TARG_SZ
TARG_EX
TARG_EY
TARG_EZ
PATTERN_TYPE
TARGET_EDGE_ANGLE
PROGRAM_GAGE_FEAT_TYPE
PROGRAM_GAGE_TYPE
TARGET_FOCUS
RMEASFEATIDX
RMEASFEATIDY
RMEASFEATIDZ
FINDNOMS_BESTFIT
FINDNOMS_ONLYSELECTED
TEMPX
TEMPY
TEMPZ
TEMPP
AUTO_PH9
MANUAL_PREPOSITION
SCREEN_CAPTURE_TYPE
SCREEN_CAPTURE_AUTO_TYPE
TARGET_EDGE_EDGESELECT
TARGET_EDGE_EDGENUM
DELETE_TYPE
SCREEN_CAPTURE_AUTO_TIME
USE_HSSDAT
USE_STARTENDDELAY
COP_FILTER
COP_SIZE
COP_TYPE
SURFVEC_MEAS_I
SURFVEC_MEAS_J
SURFVEC_MEAS_K
TARGET_EDGE_UNDERSCAN
PROFILE_TYPE
THEO_FLUSH
MEAS_FLUSH
THEO_GAP
MEAS_GAP
THEO_DEPTH
MEAS_DEPTH
TARGET_BLOB_TYPE
LASER_STRIPE_OVERLAP
LASER_STRIPE_OVERSCAN
LASER_FREQUENCY
TARGET_FILTER_OUTLIER
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD
SLOT_TYPE
TARGET_TYPE
THEO_R
THEO_A
THEO_H
MEAS_R
MEAS_A
MEAS_H
TARG_R
TARG_A
TARG_H
THEO_SR
THEO_SA
THEO_SH
THEO_ER
THEO_EA
THEO_EH
MEAS_SR
MEAS_SA
MEAS_SH
MEAS_ER
MEAS_EA
MEAS_EH
TARG_SR
TARG_SA
TARG_SH
TARG_ER
TARG_EA
TARG_EH
TARGET_EDGE_SENSILIGHT
F_THICKNESS_EDGE
THICKNESS_TYPE_EDGE
LASER_EXPOSURE
LASER_INTENSITY
ANGLE_OFFSET_2
LASER_FILTER_NEIGHBOR_NUM
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD
LASER_FILTER_TOL_ABOVE
LASER_FILTER_TOL_BELOW
LASER_FILTER_TOL_RIGHT
LASER_CLIP_UP_DIST
LASER_CLIP_LOW_DIST
LASER_PIXEL_TOGGLE
LASER_FILTER_TOGGLE
DISPLAY_PROBE_PARAMETERS
THEO_R2
THEO_A2
THEO_H2
MEAS_R2
MEAS_A2
MEAS_H2
LASER_CLIP_LEFT_DIST
LASER_CLIP_RIGHT_DIST
COP_FILETYPE
COP_SELECTIONTYPE
COP_COLORMAP
COP_COPLEMENT
OPERTYPE
COP_BOOLEANTYPE
COP_IMPORTFILETYPE
MEAS_START_ANG
MEAS_END_ANG
ISLAND_DIAM
ISLAND_LENGTH
ISLAND_WIDTH
ISLAND_X
ISLAND_Y
ISLAND_Z
ISLAND_I
ISLAND_J
ISLAND_K
ISLAND_AI
ISLAND_AJ
ISLAND_AK
ISLAND_TYPE
ISLAND_CLEARANCEDIST
RPT_DIMENSION_TABLES
SUMMARY_DEV
DRF_TBLHDR
LINE1_TBLHDR
LINE1_CALLOUT
LINE1_COLUMN_HDR
LINE1_FEATNAME
LINE1_NOMINAL
LINE1_MEAS
LINE1_PLUSTOL
LINE1_MINUSTOL
LINE1_DEV
LINE1_DEVPERCENT
LINE1_ISBILATERAL
LINE1_NUMZONES
LINE2_TBLHDR
LINE2_CALLOUT
LINE2_COLUMN_HDR
LINE2_FEATNAME
LINE2_BONUS
LINE2_TOL
LINE2_DATUMSHFT
LINE2_UNUSEDZONE
LINE2_DEV
LINE2_DEVANG
LINE2_DEVPERCENT
LINE3_TBLHDR
LINE3_CALLOUT
LINE3_COLUMN_HDR
LINE3_FEATNAME
LINE3_BONUS
LINE3_TOL
LINE3_DATUMSHFT
LINE3_UNUSEDZONE
LINE3_DEV
LINE3_DEVANG
LINE3_DEVPERCENT
DRF_COLUMN_HDR
DRF_SEGNAME
DRF_SHIFTX
DRF_SHIFTY
DRF_SHIFTZ
DRF_ROTATIONX
DRF_ROTATIONY
DRF_ROTATIONZ
SUMMARY_COLUMN_HDR
SUMMARY_FEAT
LINE2_AXIS
LINE2_NOMINAL
LINE2_MEAS
SUMMARY_TBLHDR
SUMMARY_AXIS
SUMMARY_NOMINAL
SUMMARY_MEAS
LINE2_PLUSTOL
LINE2_MINUSTOL
LINE2_MAX
LINE2_MIN
LINE2_ISBILATERAL
LINE2_NUMZONES
LINE3_ISBILATERAL
LINE3_NUMZONES
DIM_RPT_COLUMN_HDR
DIM_RPT_ISDATUM
DIM_RPT_DATUM
DIM_RPT_GRAPHIC
DIM_RPT_DEVPERCENT
DIM_RPT_ISBILATERAL
DIM_RPT_NUMZONES
GDT_SYMBOL
COMMENT_INPUT
TARGET_EDGE_WIDTH
TARGET_EDGE_HEIGHT
TARGET_EDGE_EDGEDETECT
TARGET_EDGE_FILTER_CLEAN
TARGET_EDGE_FILTER_CLEAN_STRENGTH
TARGET_EDGE_FILTER_AREA
TARGET_EDGE_FILTER_AREA_SIZE
TARGET_EDGE_GRADIENT
THEO_PERIMETER
MEAS_PERIMETER
THEO_AREA
MEAS_AREA
TARGET_SURFACE_CROSSHAIR_HEIGHT
SHOW_NOMS
COMPOSITE
DATUM2
TP_MODIFIER2
DESCRIPTION2
SHOW_OPTIONS
LEADER_LINE_ID
GDT_SYMBOL2
DATUM1_MODIFIER
DATUM2_MODIFIER
DATUM3_MODIFIER
DATUM1_MODIFIER2
DATUM2_MODIFIER2
DATUM3_MODIFIER2
DIM_RPT_DEVPERCENT_NOM
DIM_RPT_USETWODEVIATIONS
DIM_RPT_DEVPERCENT2
LINE2_DEVPERCENT_NOM
LINE2_USE2DEVIATIONS
LINE2_DEVPERCENT2
LINE3_DEVPERCENT_NOM
LINE3_USE2DEVIATIONS
LINE3_DEVPERCENT2
AXIS_PLUS_TOL
AXIS_MINUS_TOL
AXIS_NOMINAL
AXIS_DESCRIPTION
LINE1_DEVPERCENT_NOM
LINE1_USE2DEVIATIONS
LINE1_DEVPERCENT2
USE_AXIS2
DIM_LENGTH2
TEXTANAL_LABEL_MEAS_X
TEXTANAL_LABEL_MEAS_Y
TEXTANAL_LABEL_MEAS_Z
TEXTANAL_LABEL_MEAS_I
TEXTANAL_LABEL_MEAS_J
TEXTANAL_LABEL_MEAS_K
TEXTANAL_LABEL_DEV
TEXTANAL_LABEL_MINMAX
SIMULT_EVAL
SECTION_INDEX
LINE1_OUTTOL
LINE2_OUTTOL
LINE3_OUTTOL
LINE1_MAX
LINE1_MIN
LINE3_NOMINAL
LINE3_MEAS
LINE3_PLUSTOL
LINE3_MINUSTOL
LINE3_MAX
LINE3_MIN
SUMMARY_OUTTOL
SUMMARY_PLUSTOL
SUMMARY_MINUSTOL
SUMMARY_MAX
SUMMARY_MIN
SUMMARY_BONUS
LINE1_BONUS
GRAPH_ANALYSIS_POINT_SIZE
GRAPH_ANALYSIS_PLUS_TOL
GRAPH_ANALYSIS_MINUS_TOL
DIM_AXIS_ITEM_NUMBER
F_ENDING_DEPTH
DIM_ITEM_NUMBER
FEAT_ITEM_NUMBER
COMMAND_TYPE
DEV_MAX
AUTO_DEV_DIRECTION
PROBE_DIRECTION
USER_DEFINED_THEOS
SCALING
USE_SCALING
UID
REF_UID
BA_SOLUTION_TYPE
BA_SOLUTION_OPTIONS
BA_SOLUTION_STATUS
BA_VARIANCE
BA_RMS
BA_WARNINGS
BA_STATION
BA_STATION_X
BA_STATION_Y
BA_STATION_Z
BA_STATION_ROTX
BA_STATION_ROTY
BA_STATION_ROTZ
BA_STATION_ORIENTED
BA_STATION_LOCKED
BA_FEATURE
BA_FEAT_SOURCE
BA_FEAT_RMS
BA_FEAT_POINTING_ERR
BA_FEAT_APEX_ANGLE
BA_FEAT_X
BA_FEAT_Y
BA_FEAT_Z
BA_FEAT_DEV_X
BA_FEAT_DEV_Y
BA_FEAT_DEV_Z
BA_FEAT_DEV3D
NO_APPROACH_VECTOR_FLIP
TARGET_EDGE_START_VALUE
TARGET_EDGE_END_VALUE
TARGET_SURFACE_SURFACE_VARIANCE
RELATIVE_COMMENTS
AUTO_ROTARY
TARGET_COVERAGE
ROTATION_TYPE_2
PROBE_TYPE
TIME_STAMP
ECOND_TEMP
ECOND_PRESSURE
ECOND_HUMIDITY
HIT_RMS
DISPLAY_TRACKER_PARAMETERS
PTDENSITY_TOGGLE
PTDENSITY_UPPERBOUND
PTDENSITY_DEVLIMIT
PTDENSITY_MAXSPAN
TARGET_MEASURE_AT_FOV_CENTER
TARGET_SURFACE_FIND_SURFACE
PROJECTOR
INLINE_LEGACY_REPORT
SINGLE_POINT_DEVIATION
ENUM_FIELD_TYPES enumeration indicating the field from which to get the value.
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a specified field type. In these cases, the TypeIndex must not be greater than the current number of fields of the that type + 1 and TypeIndex must be greater than 1. For fields that allow only a single value, the TypeIndex is 0.

Return Type

Long value representing the current toggle index value.

Example

' Suppose your part program has a circle named CIR1.

' This example would return a 1 since the COORD_TYPE field is a toggle field:

Set myapp = CreateObject("pcdlrn.application")

Set myprog = myapp.ActivePartProgram

Dim Cmds As Commands

Set Cmds = myprog.Commands

Dim Cmd As Command

Set Cmd = Cmds.Item("CIR1")

MsgBox Cmd.ID

MsgBox Cmd.GetToggleValue(COORD_TYPE, 0)

See Also

Command Object


HasBreakpoint Property

HasBreakpoint Property

Description

Read/Write: Flag that represents if the command has a breakpoint set Determines whether or not the current PC-DMIS command has a breakpoint.

Property type

Read-write property

Syntax

Visual Basic
Public Property HasBreakpoint() As Boolean

Return Type

Read/write Boolean.

Remarks

You can also use this property to automatically set or clear breakpoints on individual commands by setting the HasBreakPoint property for the command to TRUE or FALSE.

See Also

Command Object | ClearAllBreakpoints Method


HasField Property

HasField Property
DataType
TypeIndex

Description

Checks is the the command has the indicated field.

Property type

Read-only property

Syntax

Visual Basic
Public Property HasField( _
   ByVal DataType As ENUM_FIELD_TYPES, _
   ByVal TypeIndex As Long _
) As Boolean

Parameters

DataType
Value Description
ID
REF_ID
LEVEL_REF_ID
ROTATE_REF_ID
ORIGIN_REF_ID
THEO_X
THEO_Y
THEO_Z
THEO_SX
THEO_SY
THEO_SZ
THEO_EX
THEO_EY
THEO_EZ
THEO_I
THEO_J
THEO_K
TARG_X
TARG_Y
TARG_Z
MEAS_X
MEAS_Y
MEAS_Z
MEAS_I
MEAS_J
MEAS_K
MEAS_LENGTH
MEAS_DIAM
MEAS_ANGLE
TARG_I
TARG_J
TARG_K
THEO_DIAM
THEO_WIDTH
THEO_LENGTH
THEO_HEIGHT
THEO_ANGLE
COORD_TYPE
INOUT_TYPE
THICKNESS_TYPE
CIRC_TYPE
SNAP_TYPE
USEPIN_TYPE
MOVE_TYPE
READPOS_TYPE
FINDHOLE_TYPE
RMEAS_TYPE
THEOBF_TYPE
BOUND_TYPE
BF_MATH_TYPE
AUTOFIT_CONSTRAINT
SLOT_MIN_MAX_TYPE
FIND_NOM_AXIS_TYPE
N_INIT_HITS_TYPE
N_PERM_HITS_TYPE
SEARCHMODE_TYPE
MODE_TYPE
MEASURE_ORDER_TYPE
CONE_LENGTH_ANGLE_TYPE
OFFSET_LINE_METHOD
LIN_POL_FILT_TYPE
GEN_FEAT_TYPE
GEN_ALIGN_TYPE
CURVE_TYPE
MEASURED_2D3D_TYPE
THINNING_TOL
HITINT_TYPE
RMEASFEATID
N_HITS
N_ROWS
INIT_HITS
PERM_HITS
F_OFFSET
F_SPACER
F_PITCH
F_THICKNESS
F_DEPTH
F_AUTOMOVE
F_INDENT
F_CORNER_RADIUS
F_INCREMENT
F_TOLERANCE
F_BOXWIDTH
F_BOXLENGTH
F_CIRCRADOUT
F_CIRCRADIN
F_CHECK
F_MAXACCELX
F_MAXACCELY
F_MAXACCELZ
SCAN_ACCELERATION
SCAN_OFFSET_FORCE
MANUAL_FINE_PROBING
F_MOVESPEED
F_TOUCHSPEED
F_SCANSPEED
START_ANG
END_ANG
MIDPOINT_X
MIDPOINT_Y
MIDPOINT_Z
ANGVEC_I
ANGVEC_J
ANGVEC_K
MEASVEC_I
MEASVEC_J
MEASVEC_K
SLOTVEC_I
SLOTVEC_J
SLOTVEC_K
SURFVEC_I
SURFVEC_J
SURFVEC_K
PINVEC_I
PINVEC_J
PINVEC_K
PUNCHVEC_I
PUNCHVEC_J
PUNCHVEC_K
REPORTVEC_I
REPORTVEC_J
REPORTVEC_K
TARGSLOT_I
TARGSLOT_J
TARGSLOT_K
UPDATEVEC_I
UPDATEVEC_J
UPDATEVEC_K
THEO_MINOR_AXIS
TWO_D_THREE_D_TYPE
AXIS
DEST_EXPR
SRC_EXPR
SHOW_IDS
SHOW_DETAILS
WEIGHT
ITEM_USED
USE_AXIS
AVERAGE_ERROR
MEASURE_ALL_FEATURES
REPIERCE_CAD
START_NUM
END_NUM
SKIP_NUM
X_OFFSET
Y_OFFSET
Z_OFFSET
ANGLE_OFFSET
INTERNAL_EXTERNAL
SAVE_ALIGN_CAD_TO_PARTS
FILE_NAME
ALIGN_LIST
WORK_PLANE
DISTANCE
OLD_TIP
NEW_TIP
ROTATION_TYPE
DIM_INFO_ORDER
DIM_INFO_LOC
DIM_INFO_TP_LOC
GRAPH_ANALYSIS
TEXT_ANALYSIS
ARROW_MULTIPLIER
OUTPUT_TYPE
NOMINAL
F_PLUS_TOL
F_MINUS_TOL
TP_MODIFIER
PERP_PARALLEL_TYPE
RADIUS_TYPE
UNIT_TYPE
DIM_LENGTH
PROFILE_FORM_TYPE
PRECISION
MAN_RETRACT
DIM_TEXT
DIM_TEXT_OPTIONS
SHOW_HEADINGS
DEVIATION_SYMBOLS
STANDARD_DEVIATION
DIM_HEADING
GAP_ONLY_TYPE
DISPLAY_ID
DISPLAY_TYPE
POINT_INFO_HEADING
SHOW_POINT_INFO
RET_ONLY_TYPE
COMMENT_FIELD
COMMENT_TYPE
PART_NAME
REVISION_NUMBER
SERIAL_NUMBER
STAT_COUNT
SUB_NAME
READ_WRITE
FILE_POINTER
FIELD_WIDTH
DIGIT_COUNT
LABEL_ID
ERROR_TYPE
ERROR_MODE
DESCRIPTION
INDEX_START
INDEX_END
FILE_COMMAND_TYPE
BUFFER_SIZE_TYPE
FAIL_ON_EXIST
MAX_FORCE
LOW_FORCE
UP_FORCE
TRIGGER_FORCE
PROBE_ACCURACY
POSITIONAL_ACCURACY
NUM_RETURN_DATA
RETURN_SPEED
SCAN_DENSITY
POLAR_VECTOR_COMPENSATION
AUTO_PRINT
ORIGIN
MATERIAL_COEFFICIENT
REF_TEMP
HIGH_THRESHOLD
LOW_THRESHOLD
SENSOR_LIST
FIXTURE_TYPE
MACHINE_TYPE
PROBE_COMP
TIP_I
TIP_J
TIP_K
NORM_RELEARN
FIND_NOMS_TYPE
AUTO_CLEAR_PLANE
SINGLE_POINT
DISPLAY_HITS
CAD_TOLERANCE
OFFSET_TOLERANCE
MIN_INCREMENT
MAX_INCREMENT
MIN_ANGLE
MAX_ANGLE
F_LOCATION
COL132_TYPE
COMMAND_STRING
FLY_MODE_TYPE
STATS_TYPE
STATS_DIR
NEW_STATS_DIR
DATA_READ_LOCK
DATA_WRITE_LOCK
DATA_MEM_PAGES
STAT_NAME_TYPE
STAT_CALC_TYPE
TRANSFER_DIR
DISPLAY_TRACE
TRACE_NAME
TRACE_VALUE
SCAN_CUTPLANEVEC_I
SCAN_CUTPLANEVEC_J
SCAN_CUTPLANEVEC_K
SCAN_INITVEC_I
SCAN_INITVEC_J
SCAN_INITVEC_K
SCAN_AXISVEC_I
SCAN_AXISVEC_J
SCAN_AXISVEC_K
SCAN_ENDVEC_I
SCAN_ENDVEC_J
SCAN_ENDVEC_K
SCAN_INITDIR_I
SCAN_INITDIR_J
SCAN_INITDIR_K
SCAN_CROSS_TOTAL
SCAN_TIME_INCR
SCAN_EDGE_THICK
POS_REPORT_AXIS_X
POS_REPORT_AXIS_Y
POS_REPORT_AXIS_Z
DEV_PERPEN_CENTERLINE
USE_THEO
TARGET_COLOR
THEO_START_ANG
THEO_END_ANG
ONOFF_TYPE
ROW_ID
LOCATOR_BMP
LOCATOR_WAV
DTYPE_LEAPFROGTYPE
DTYPE_LEAPFROGNUMHITS
DTYPE_LEAPFROGFULLPARTIAL
EXCLUSION_ZONE
EXECUTE
AUTOTRIGGERONOFF
AUTOBEEPING
COLUMN_ID
SLOT_NUMBER
AUTOTOLZONE
PROBING_MODE
ANGLE_COMP_TOGGLE
POINTINFO_FILTER_INTERVAL
POINTINFO_FILTER_INTERVAL_NUMBER
FEAT_TYPE
DIM_ID
MEAS_MINOR_AXIS
MEAS_HEIGHT
MEAS_SLOTVEC_I
MEAS_SLOTVEC_J
MEAS_SLOTVEC_K
MEAS_SX
MEAS_SY
MEAS_SZ
MEAS_EX
MEAS_EY
MEAS_EZ
MEAS_WIDTH
NUM_CONTROL_POINTS
U_HITS
V_HITS
NUM_FIT_POINTS
NOMINAL_COLOR
WAVE_FILE
DIM_BONUS
PERUNIT_STEPSIZE
PERUNIT_LENGTH
PERUNIT_WIDTH
DIM_MEASURED
SURFVEC_TARG_I
SURFVEC_TARG_J
SURFVEC_TARG_K
DIM_MAX
EDGEVEC_TARG_I
EDGEVEC_TARG_J
EDGEVEC_TARG_K
DIM_MIN
EDGEVEC_THEO_I
EDGEVEC_THEO_J
EDGEVEC_THEO_K
DIM_DEVIATION
EDGEVEC_MEAS_I
EDGEVEC_MEAS_J
EDGEVEC_MEAS_K
DIM_OUTTOL
T_VALUE
TOOL_X
TOOL_Y
TOOL_Z
TOOL_DIAM
DEV_X
DEV_Y
DEV_Z
DEV_DIAM
ITERATE_COLUMNS
LOAD_TYPE
NUM_ITERATIONS
METHOD_TYPE
SCAN_TECHNIQUE
HIT_TYPE
BOUNDARY_POINT_X
BOUNDARY_POINT_Y
BOUNDARY_POINT_Z
VIDEO_GAIN
VIDEO_OFFSET
VIDEO_LEDLIGHT
VIDEO_LASERLIGHT1
VIDEO_LASERLIGHT2
VIDEO_YORIGIN
VIDEO_YEND
VIDEO_LSEG
VIDEO_XSEG
VIDEO_YSEG
ANGULARITY_NOM_ANGLE
PRINT_TO_FILE
PRINT_TO_PRINTER
PRINT_DRAFTMODE
PRINT_DELETE_RUNS
POINTINFO_FILTER_WORST
POINTINFO_FILTER_WORST_NUMBER
POINTINFO_FILTER_DEVIATION
POINTINFO_FILTER_DEVIATION_NUMBER
POINTINFO_FILTER_OUTTOL
REPORT_SURFVEC_I
REPORT_SURFVEC_J
REPORT_SURFVEC_K
DB_QUERY_OP
DB_SOURCE_NAME
CHART_TYPE
DB_CHART_NAME
DEVIATION_ANGLE
STATS_DATASOURCE
IGNOREMOTIONERRORS_TYPE
THEO_X2
THEO_Y2
THEO_Z2
MEAS_X2
MEAS_Y2
MEAS_Z2
PPROG
TRACE_FILTER
TIME_FILTER
SHOW_SPC_CALCS
SPEC_LIMITS
ZONES
STDDEV
UCL_LCL
HISTOGRAM
GRID
ADDITIONAL_CHART
LINE2_PLANAR_OPEN_IN_X
LINE3_PLANAR_OPEN_IN_X
REGR
CENTER_POINT
SHOW_MORE_SPC_CALCS
SPEC_OFFSET
SOLID
U_L_BOUNDS
TITLE
CPOINT_X
CPOINT_Y
CPOINT_Z
CPOINT_I
CPOINT_J
CPOINT_K
CPOINT_DIAM
CPOINT_SCAN_CROSS_TOTAL
CPOINT_SCAN_DENSITY
CPOINT_F_SCANSPEED
N_CONTROLPOINTS
CPOINT_TYPE
USE_3DFILTER
SCAN_BNDRY_TYPE
CREATE_WEIGHTS
F_SIZE
LINE2_ISPLANAR
LINE2_PLANAR_XTOL
LINE2_PLANAR_YTOL
LINE2_PLANAR_XDEV
LINE2_PLANAR_YDEV
LINE3_ISPLANAR
LINE3_PLANAR_XTOL
LINE3_PLANAR_YTOL
LINE3_PLANAR_XDEV
LINE3_PLANAR_YDEV
CHART_SUB_TYPE
OVERWRITE
OUTPUT_FEATURE_NOMS
OUTPUT_FEAT_W_DIMENS
OUTPUT_DMIS_REPORT
TIME_ARG
TRACE_FILTER_ARG
FIT
STATS_DB_TYPE
IOCHANNEL_NUMBER
IOCHANNEL_PULSE_WIDTH
IOCHANNEL_PULSE_INTERVAL
IOCHANNEL_PULSE_DURATION
GRAPH_OPTION
DB_SOURCE_TYPE
FIND_HOLE_PERCENT
AUTO_ONERROR_TYPE
POS_REPT_DISPLAY_OPTION
TRIGGERTOLERANCE
TRIGGERTOLVALUE
FIXTURE_TOL
START_LABEL
ERROR_LABEL
CONE_CONVEX_TYPE
TRIGGERPLANE
QUERY_SHOW_GRAPHIC_SETTINGS
CALC_STYLE_FILE
FILTER_TYPE
TRACE_VALUE_LIMIT
TARGET_DIRECTION
TARGET_EDGE_POLARITY
BSMETHOD_TYPE
CENTER_ROTATION_THEO
CENTER_ROTATION_MEAS
ARTICULATEDARM_TYPE
LEFTYRIGHTY_CONFIG
ABOVEBELOW_CONFIG
NOFLIPFLIP_CONFIG
HIGH_ACCURACY
SURFACE
MAGNIFICATION
MINOR_WORD_TOGGLE
PERCENTAGE
THRESHOLD
N_SIDES
TARGET_SURFACE_ILLUM
MEAN
CAD_COMP
SHOW_ROW
SHOW_COLUMN
TARGET_SURFACE_SENSILIGHT
TARGET_SURFACE_WIDTH
TARGET_SURFACE_HEIGHT
TARGET_SURFACE_RANGE
TARGET_SURFACE_DURATION
TARGET_SURFACE_MODE
TARGET_SURFACE_HIACC
SCREEN_CAPTURE_SCALE
SCREEN_CAPTURE_QUALITY
TARGET_EDGE_SIZE
TARGET_EDGE_ILLUM
TARGET_EDGE_TOL
TARGET_EDGE_STRENGTH
TARGET_EDGE_DENSITY
TARGET_EDGE_TYPE
DISPLAY_ADVANCED_PARAMETERS
TARGET_SURFACE_TYPE
VOID_DETECT
TARG_SX
TARG_SY
TARG_SZ
TARG_EX
TARG_EY
TARG_EZ
PATTERN_TYPE
TARGET_EDGE_ANGLE
PROGRAM_GAGE_FEAT_TYPE
PROGRAM_GAGE_TYPE
TARGET_FOCUS
RMEASFEATIDX
RMEASFEATIDY
RMEASFEATIDZ
FINDNOMS_BESTFIT
FINDNOMS_ONLYSELECTED
TEMPX
TEMPY
TEMPZ
TEMPP
AUTO_PH9
MANUAL_PREPOSITION
SCREEN_CAPTURE_TYPE
SCREEN_CAPTURE_AUTO_TYPE
TARGET_EDGE_EDGESELECT
TARGET_EDGE_EDGENUM
DELETE_TYPE
SCREEN_CAPTURE_AUTO_TIME
USE_HSSDAT
USE_STARTENDDELAY
COP_FILTER
COP_SIZE
COP_TYPE
SURFVEC_MEAS_I
SURFVEC_MEAS_J
SURFVEC_MEAS_K
TARGET_EDGE_UNDERSCAN
PROFILE_TYPE
THEO_FLUSH
MEAS_FLUSH
THEO_GAP
MEAS_GAP
THEO_DEPTH
MEAS_DEPTH
TARGET_BLOB_TYPE
LASER_STRIPE_OVERLAP
LASER_STRIPE_OVERSCAN
LASER_FREQUENCY
TARGET_FILTER_OUTLIER
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD
SLOT_TYPE
TARGET_TYPE
THEO_R
THEO_A
THEO_H
MEAS_R
MEAS_A
MEAS_H
TARG_R
TARG_A
TARG_H
THEO_SR
THEO_SA
THEO_SH
THEO_ER
THEO_EA
THEO_EH
MEAS_SR
MEAS_SA
MEAS_SH
MEAS_ER
MEAS_EA
MEAS_EH
TARG_SR
TARG_SA
TARG_SH
TARG_ER
TARG_EA
TARG_EH
TARGET_EDGE_SENSILIGHT
F_THICKNESS_EDGE
THICKNESS_TYPE_EDGE
LASER_EXPOSURE
LASER_INTENSITY
ANGLE_OFFSET_2
LASER_FILTER_NEIGHBOR_NUM
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD
LASER_FILTER_TOL_ABOVE
LASER_FILTER_TOL_BELOW
LASER_FILTER_TOL_RIGHT
LASER_CLIP_UP_DIST
LASER_CLIP_LOW_DIST
LASER_PIXEL_TOGGLE
LASER_FILTER_TOGGLE
DISPLAY_PROBE_PARAMETERS
THEO_R2
THEO_A2
THEO_H2
MEAS_R2
MEAS_A2
MEAS_H2
LASER_CLIP_LEFT_DIST
LASER_CLIP_RIGHT_DIST
COP_FILETYPE
COP_SELECTIONTYPE
COP_COLORMAP
COP_COPLEMENT
OPERTYPE
COP_BOOLEANTYPE
COP_IMPORTFILETYPE
MEAS_START_ANG
MEAS_END_ANG
ISLAND_DIAM
ISLAND_LENGTH
ISLAND_WIDTH
ISLAND_X
ISLAND_Y
ISLAND_Z
ISLAND_I
ISLAND_J
ISLAND_K
ISLAND_AI
ISLAND_AJ
ISLAND_AK
ISLAND_TYPE
ISLAND_CLEARANCEDIST
RPT_DIMENSION_TABLES
SUMMARY_DEV
DRF_TBLHDR
LINE1_TBLHDR
LINE1_CALLOUT
LINE1_COLUMN_HDR
LINE1_FEATNAME
LINE1_NOMINAL
LINE1_MEAS
LINE1_PLUSTOL
LINE1_MINUSTOL
LINE1_DEV
LINE1_DEVPERCENT
LINE1_ISBILATERAL
LINE1_NUMZONES
LINE2_TBLHDR
LINE2_CALLOUT
LINE2_COLUMN_HDR
LINE2_FEATNAME
LINE2_BONUS
LINE2_TOL
LINE2_DATUMSHFT
LINE2_UNUSEDZONE
LINE2_DEV
LINE2_DEVANG
LINE2_DEVPERCENT
LINE3_TBLHDR
LINE3_CALLOUT
LINE3_COLUMN_HDR
LINE3_FEATNAME
LINE3_BONUS
LINE3_TOL
LINE3_DATUMSHFT
LINE3_UNUSEDZONE
LINE3_DEV
LINE3_DEVANG
LINE3_DEVPERCENT
DRF_COLUMN_HDR
DRF_SEGNAME
DRF_SHIFTX
DRF_SHIFTY
DRF_SHIFTZ
DRF_ROTATIONX
DRF_ROTATIONY
DRF_ROTATIONZ
SUMMARY_COLUMN_HDR
SUMMARY_FEAT
LINE2_AXIS
LINE2_NOMINAL
LINE2_MEAS
SUMMARY_TBLHDR
SUMMARY_AXIS
SUMMARY_NOMINAL
SUMMARY_MEAS
LINE2_PLUSTOL
LINE2_MINUSTOL
LINE2_MAX
LINE2_MIN
LINE2_ISBILATERAL
LINE2_NUMZONES
LINE3_ISBILATERAL
LINE3_NUMZONES
DIM_RPT_COLUMN_HDR
DIM_RPT_ISDATUM
DIM_RPT_DATUM
DIM_RPT_GRAPHIC
DIM_RPT_DEVPERCENT
DIM_RPT_ISBILATERAL
DIM_RPT_NUMZONES
GDT_SYMBOL
COMMENT_INPUT
TARGET_EDGE_WIDTH
TARGET_EDGE_HEIGHT
TARGET_EDGE_EDGEDETECT
TARGET_EDGE_FILTER_CLEAN
TARGET_EDGE_FILTER_CLEAN_STRENGTH
TARGET_EDGE_FILTER_AREA
TARGET_EDGE_FILTER_AREA_SIZE
TARGET_EDGE_GRADIENT
THEO_PERIMETER
MEAS_PERIMETER
THEO_AREA
MEAS_AREA
TARGET_SURFACE_CROSSHAIR_HEIGHT
SHOW_NOMS
COMPOSITE
DATUM2
TP_MODIFIER2
DESCRIPTION2
SHOW_OPTIONS
LEADER_LINE_ID
GDT_SYMBOL2
DATUM1_MODIFIER
DATUM2_MODIFIER
DATUM3_MODIFIER
DATUM1_MODIFIER2
DATUM2_MODIFIER2
DATUM3_MODIFIER2
DIM_RPT_DEVPERCENT_NOM
DIM_RPT_USETWODEVIATIONS
DIM_RPT_DEVPERCENT2
LINE2_DEVPERCENT_NOM
LINE2_USE2DEVIATIONS
LINE2_DEVPERCENT2
LINE3_DEVPERCENT_NOM
LINE3_USE2DEVIATIONS
LINE3_DEVPERCENT2
AXIS_PLUS_TOL
AXIS_MINUS_TOL
AXIS_NOMINAL
AXIS_DESCRIPTION
LINE1_DEVPERCENT_NOM
LINE1_USE2DEVIATIONS
LINE1_DEVPERCENT2
USE_AXIS2
DIM_LENGTH2
TEXTANAL_LABEL_MEAS_X
TEXTANAL_LABEL_MEAS_Y
TEXTANAL_LABEL_MEAS_Z
TEXTANAL_LABEL_MEAS_I
TEXTANAL_LABEL_MEAS_J
TEXTANAL_LABEL_MEAS_K
TEXTANAL_LABEL_DEV
TEXTANAL_LABEL_MINMAX
SIMULT_EVAL
SECTION_INDEX
LINE1_OUTTOL
LINE2_OUTTOL
LINE3_OUTTOL
LINE1_MAX
LINE1_MIN
LINE3_NOMINAL
LINE3_MEAS
LINE3_PLUSTOL
LINE3_MINUSTOL
LINE3_MAX
LINE3_MIN
SUMMARY_OUTTOL
SUMMARY_PLUSTOL
SUMMARY_MINUSTOL
SUMMARY_MAX
SUMMARY_MIN
SUMMARY_BONUS
LINE1_BONUS
GRAPH_ANALYSIS_POINT_SIZE
GRAPH_ANALYSIS_PLUS_TOL
GRAPH_ANALYSIS_MINUS_TOL
DIM_AXIS_ITEM_NUMBER
F_ENDING_DEPTH
DIM_ITEM_NUMBER
FEAT_ITEM_NUMBER
COMMAND_TYPE
DEV_MAX
AUTO_DEV_DIRECTION
PROBE_DIRECTION
USER_DEFINED_THEOS
SCALING
USE_SCALING
UID
REF_UID
BA_SOLUTION_TYPE
BA_SOLUTION_OPTIONS
BA_SOLUTION_STATUS
BA_VARIANCE
BA_RMS
BA_WARNINGS
BA_STATION
BA_STATION_X
BA_STATION_Y
BA_STATION_Z
BA_STATION_ROTX
BA_STATION_ROTY
BA_STATION_ROTZ
BA_STATION_ORIENTED
BA_STATION_LOCKED
BA_FEATURE
BA_FEAT_SOURCE
BA_FEAT_RMS
BA_FEAT_POINTING_ERR
BA_FEAT_APEX_ANGLE
BA_FEAT_X
BA_FEAT_Y
BA_FEAT_Z
BA_FEAT_DEV_X
BA_FEAT_DEV_Y
BA_FEAT_DEV_Z
BA_FEAT_DEV3D
NO_APPROACH_VECTOR_FLIP
TARGET_EDGE_START_VALUE
TARGET_EDGE_END_VALUE
TARGET_SURFACE_SURFACE_VARIANCE
RELATIVE_COMMENTS
AUTO_ROTARY
TARGET_COVERAGE
ROTATION_TYPE_2
PROBE_TYPE
TIME_STAMP
ECOND_TEMP
ECOND_PRESSURE
ECOND_HUMIDITY
HIT_RMS
DISPLAY_TRACKER_PARAMETERS
PTDENSITY_TOGGLE
PTDENSITY_UPPERBOUND
PTDENSITY_DEVLIMIT
PTDENSITY_MAXSPAN
TARGET_MEASURE_AT_FOV_CENTER
TARGET_SURFACE_FIND_SURFACE
PROJECTOR
INLINE_LEGACY_REPORT
SINGLE_POINT_DEVIATION
TypeIndex

See Also

Command Object


ID Property

ID Property

Description

Read/Write: ID of the command Represents the ID of the command.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As String

Return Type

Read/write String.

Remarks

Only objects that have ID strings can be set. If a object does not have a string, this property is the zero-length string "".

See Also

Command Object


IsActiveTip Property

IsActiveTip Property

Description

Read Only: Indicates whether the command is a active tip command Determines whether or not the command is an ActiveTip command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsActiveTip() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve an ActiveTip object using the ActiveTipCommand Property.

See Also

Command Object | ActiveTip Object | ActiveTipCommand Property


IsAlignment Property

IsAlignment Property

Description

Read Only: Indicates whether the command is an alignment command Determines whether or not the command is an alignment command type.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsAlignment() As Boolean

Return Type

Read only Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve an Alignment Command object using the AlignmentCommand Property.

See Also

Command Object


IsArrayIndex Property

IsArrayIndex Property

Description

Read Only: Indicates whether the command is a array index command Determines whether or not the command is an ArrayIndex command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsArrayIndex() As Boolean

Return Type

Read only

Remarks

Commands that return TRUE for this property can successfully retrieve an ArrayIndex object using the ArrayIndexCommand property.

See Also

Command Object | ArrayIndexCommand Property | ArrayIndex Object


IsAttach Property

IsAttach Property

Description

Read Only: Indicates whether the command is a attach command Determines whether or not the command is an Attach command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsAttach() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve an Attach object using the AttachCommand property.

See Also

Command Object | Attach Object | AttachCommand Property


IsBasicScan Property

IsBasicScan Property

Description

Read Only: Indicates whether the command is a basic scan command Determines whether or not the command is a basic scan command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsBasicScan() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve a BasicScan object using the BasicScanCommand property.

See Also

Command Object | BasicScan Object | BasicScanCommand Property


IsCalibration Property

IsCalibration Property

Description

Read Only: Indicates whether the command is a calibration command Determines whether or not the command is a Calibration command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsCalibration() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve a Calibration object using the CalibrationCommand Property.

See Also

Command Object | CalibrationCommand Property | Calibration Object


IsComment Property

IsComment Property

Description

Read Only: Indicates whether the command is a comment command

Determines whether or not the command is a Comment command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsComment() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve a Comment object using the CommentCommand property.

See Also

Command Object | Comment Object | CommentCommand Property


IsConstructedFeature Property

IsConstructedFeature Property

Description

Read Only: Indicates whether the command is a constructed feature command Determines whether or not the command is a constructed feature.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsConstructedFeature() As Boolean

Return Type

Read/write Boolean.

See Also

Command Object


IsDCCFeature Property

IsDCCFeature Property

Description

Read Only: Indicates whether the command is a DCC command Determines whether or not the command is a DCC (Auto) Feature.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsDCCFeature() As Boolean

Return Type

Read/write Boolean.

See Also

Command Object


IsDimension Property

IsDimension Property

Description

Read Only: Indicates whether the command is a dimension command Determines whether or not the command is a Dimension command type.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsDimension() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve a DimensionCmd object using the DimensionCommand property.

See Also

Command Object | DimensionCommand Property | DimensionCmd Object


IsDimFormat Property

IsDimFormat Property

Description

Read Only: Indicates whether the command is a dimension format command Determines whether or not the command is a a DimFormat command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsDimFormat() As Boolean

Return Type

Read/write Boolean. Returns TRUE if the command is a DimFormat command.

Remarks

Commands that return TRUE for this property can successfully retrieve a DimFormat object using the DimFormatCommand Property.

See Also

Command Object | DimFormat Object | DimFormatCommand Property


IsDimInfo Property

IsDimInfo Property

Description

Read Only: Indicates whether the command is a dimension info command Determines whether or not the command is a DimInfo command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsDimInfo() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve a DimInfo object using the DimInfoCommand Property.

See Also

Command Object | DimInfoCommand Property | DimInfo Object


IsDisplayMetaFile Property

IsDisplayMetaFile Property

Description

Read Only: Indicates whether the command is a display metafile command Determines whether or not the command is a DispMetaFileCommand.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsDisplayMetaFile() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve a DispMetaFile Command object using the DisplayMetaFileCommand Property.

See Also

Command Object | DisplayMetaFileCommand Property | DispMetaFile Object


IsExternalCommand Property

IsExternalCommand Property

Description

Read Only: Indicates whether the command is a external command command Determines whether or not the command is an ExternalCommand.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsExternalCommand() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve an External Command object using the ExternalCommand Property.

See Also

Command Object | ExternalCommand Object | Type Property | ExternalCommand Property


IsFeature Property

IsFeature Property

Description

Read Only: Indicates whether the command is a feature command Determines whether or not the command is a feature command type.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsFeature() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve a FeatureCmd object using the FeatCmd property.

See Also

Command Object | FeatureCommand Property | FeatCmd Object


IsFileIOCommand Property

IsFileIOCommand Property

Description

Read Only: Indicates whether the command is a file I/O command Determines whether or not the command is a FileIO command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsFileIOCommand() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve a FileIO command object using the FileIOCommand property.

See Also

Command Object | FileIO Object | FileIOCommand Property


IsFlowControl Property

IsFlowControl Property

Description

Read Only: Indicates whether the command is a flow control command Determines whether or not the command is a flow control command type.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsFlowControl() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve a FlowControlCmd object using the FlowControlCommand property.

See Also

Command Object | FlowControlCommand Property | FlowControlCmd Object


IsHit Property

IsHit Property

Description

Read Only: Indicates whether the command is a hit command Determines whether or not the command is one of the hit command types.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsHit() As Boolean

Return Type

Read/write Boolean.

See Also

Command Object


IsLeapfrog Property

IsLeapfrog Property

Description

Read Only: Indicates whether the command is a leap frog command Determines whether or not the command is a Leapfrog command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsLeapfrog() As Boolean

Return Type

Read/write Boolean.

See Also

Command Object


IsLoadMachine Property

IsLoadMachine Property

Description

Read Only: Indicates whether the command is a load machine command Determines whether or not the command is a LoadMachine command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsLoadMachine() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve a LoadMachine object using the LoadProbeCommand property.

See Also

Command Object | LoadMachine Object | LoadProbeCommand Property


IsLoadProbe Property

IsLoadProbe Property

Description

Read Only: Indicates whether the command is a load probe command Determines whether or not the command is a LoadProbe command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsLoadProbe() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve a LoadProbe object using the LoadProbeCommand Property.

See Also

Command Object | LoadProbeCommand Property | LoadProbe Object


IsMeasuredFeature Property

IsMeasuredFeature Property

Description

Read Only: Indicates whether the command is a measured feature command Determines whether or not the command is a Measured Feature command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsMeasuredFeature() As Boolean

Return Type

Read/write Boolean.

See Also

Command Object


IsModal Property

IsModal Property

Description

Read Only: Indicates whether the command is a modal command Determines whether or not the command is a modal command type.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsModal() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve a ModalCmd object using the ModalCommand Property.

See Also

Command Object | ModalCmd Object | ModalCommand Property


IsMove Property

IsMove Property

Description

Read Only: Indicates whether the command is a move command Determines whether or not the command is a Move command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsMove() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve a MoveCmd object using the MoveCommand Property.

See Also

Command Object | MoveCommand Property | MoveCmd Object


IsOptionProbe Property

IsOptionProbe Property

Description

Read Only: Indicates whether the command is a option probe command

Determines whether or not the command is an option probe command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsOptionProbe() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve an OptMotion object using the OptMotionCommand Property.

See Also

Command Object


IsOptMotion Property

IsOptMotion Property

Description

Read Only: Indicates whether the command is a optional motion command Determines whether or not the command is an OptMotion command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsOptMotion() As Boolean

Remarks

Commands that return TRUE for this property can successfully retrieve an OptMotion object using the OptMotionCommand Property.

See Also

Command Object | OptMotionCommand Property | OptMotion Object


IsScan Property

IsScan Property

Description

Read Only: Indicates whether the command is a scan command Determines whether or not the command is a Scan command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsScan() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve a Scan Command object using the ScanCommand Property.

See Also

Command Object | Scan Object | ScanCommand Property


IsStatistic Property

IsStatistic Property

Description

Read Only: Indicates whether the command is a statistic command Determines whether or not the command is a Statistics command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsStatistic() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve a Statistics Command object using the StatisticCommand Property.

See Also

Command Object | StatisticCommand Property | STATISTICS Object


IsTempComp Property

IsTempComp Property

Description

Read Only: Indicates whether the command is a temperature compensation command Determines whether or not the command is a TempComp command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsTempComp() As Boolean

Return Type

Read/write Boolean.

Remarks

Commands that return TRUE for this property can successfully retrieve a TempComp Command object using the TempCompCommand Property.

See Also

Command Object


IsTraceField Property

IsTraceField Property

Description

Read Only: Indicates whether the command is a trace field command Determines whether or not the command is a TraceField command.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsTraceField() As Boolean

Remarks

Commands that return TRUE for this property can successfully retrieve a TraceField Command object using the TraceFieldCommand Property.

See Also

Command Object | TRACEFIELD Object | TraceFieldCommand Property


ItemIndex Property

ItemIndex Property

Description

Returns the execute instance index if the object has been executed more than once otherwise returns 0

Property type

Read-write property

Syntax

Visual Basic
Public Property ItemIndex() As Long

See Also

Command Object


LeapfrogCommand Property

LeapfrogCommand Property

Description

Read Only: Returns an automation leap frog object if the current command object is of the correct type Returns a LeapFrog object if the Command is of Type LEAPFROG. Otherwise it returns Nothing. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property LeapfrogCommand() As LEAPFROG

Return Type

LeapFrog object.

See Also

Command Object


LoadMachineCommand Property

LoadMachineCommand Property

Description

Read Only: Returns an automation load machine object if the current command object is of the correct type Returns a LoadMachine object if Command is of Type GET_MACHINE_DATA. Otherwise it returns Nothing. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property LoadMachineCommand() As LoadMachine

See Also

Command Object


LoadProbeCommand Property

LoadProbeCommand Property

Description

Read Only: Returns an automation load probe object if the current command object is of the correct type Returns a LoadProbe object if Command is of Type GET_PROBE_DATA. Otherwise it returns Nothing. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property LoadProbeCommand() As LoadProbe

Return Type

LoadProbe object.

See Also

Command Object


Marked Property

Marked Property

Description

Read/Write: Returns/Sets the marked for execution status of the current command

Property used to indicate/set whether command is marked in the edit window.

Property type

Read-write property

Syntax

Visual Basic
Public Property Marked() As Boolean

Return Type

Read/write Boolean.

See Also

Command Object


MasterArm Property

MasterArm Property

Description

Read Only: Property indicating whether the command belongs to the master arm only

Property type

Read-write property

Syntax

Visual Basic
Public Property MasterArm() As Boolean

See Also

Command Object


MissedHit Property

MissedHit Property

Description

Read Only: Indicates whether a missed hit occured on the last executed command

This property checks whether or not a missed hit occurred on the last executed instance of the specified command.

Property type

Read-write property

Syntax

Visual Basic
Public Property MissedHit() As Boolean

Return Type

Read-only Boolean. PC-DMIS returns TRUE if the command missed a hit; FALSE otherwise.

See Also

Command Object


ModalCommand Property

ModalCommand Property

Description

Read Only: Returns the modal command object interface for the current command if it is a modal object

Returns a ModalCommand object for the Command if it can, Nothing otherwise. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property ModalCommand() As ModalCmd

Return Type

ModalCmd object.

Remarks

The Command objects that have the following Type can become ModalCommand objects are as follows:

CLAMP
PREHIT
RETRACT
CHECK
MOVE_SPEED
TOUCH_SPEED
SCAN_SPEED
CLEARANCE_PLANES
MAN_DCC_MODE
DISPLAYPRECISION
PROBE_COMPENSATION
POLARVECTORCOMP
SET_WORKPLANE
RMEAS_MODE
GAP_ONLY
RETROLINEAR_ONLY
FLY_MODE
COLUMN132

See Also

Command Object


MoveCommand Property

MoveCommand Property

Description

Read Only: Returns the move command object interface for the current command if it is a move object Returns this Command object as a ModalCommand object if it can, Nothing otherwise. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property MoveCommand() As MoveCmd

See Also

Command Object


OptionProbeCommand Property

OptionProbeCommand Property

Description

Read Only: Returns an automation optional probe object if the current command object is of the correct type Returns an OptProbe object if Command is of Type OPTIONPROBE. Otherwise it returns Nothing. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property OptionProbeCommand() As OPTIONPROBE

Return Type

OptionProbe object.

See Also

Command Object


OptMotionCommand Property

OptMotionCommand Property

Description

Read Only: Returns an automation optional motion object if the current command object is of the correct type Returns an OptMotion object if Command is of Type OPTIONMOTION. Otherwise it returns Nothing. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property OptMotionCommand() As OptMotion

Return Type

OptMotion object.

See Also

Command Object


Parent Property

Parent Property

Description

Read Only: Returns the Parent Commands Collection Object

Returns the parent Commands collection object. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Commands

Return Type

Commands object.

See Also

Command Object


RecalculateINOUT Property

RecalculateINOUT Property

Description

Read/Write: Flag that determines if the INNER/OUTER flag is recalculated after execution

Property type

Read-write property

Syntax

Visual Basic
Public Property RecalculateINOUT() As Boolean

See Also

Command Object


ScanCommand Property

ScanCommand Property

Description

Read Only: Returns an automation scan object if the current command object is of the correct type Returns a Scan object if Command is of Type DCCSCAN_OBJECT or Type MANSCAN_OBJECT. Otherwise it returns Nothing. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property ScanCommand() As BasicScan

Return Type

Scan object.

See Also

Command Object


ShowIDOnCad Property

ShowIDOnCad Property

Description

Read/Write: Property indicating whether the command id should appear in the cad window

Property used to indicate/set whether the command ID should be displayed in the CAD window.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowIDOnCad() As Boolean

Return Type

Read/write Boolean.

See Also

Command Object


Skipped Property

Skipped Property

Description

Read Only: Indicates whether the command has been skipped or not

Property used to indicate whether the a command was skipped over.

Property type

Read-write property

Syntax

Visual Basic
Public Property Skipped() As Boolean

Return Type

Read-only Boolean. PC-DMIS returns FALSE if the command was not skipped and TRUE if it was.

See Also

Command Object


SlaveArm Property

SlaveArm Property

Description

Read Only: Property indicating whether the command belongs to the slave arm only

Property used to indicate/set whether command is a slave arm object.

Property type

Read-write property

Syntax

Visual Basic
Public Property SlaveArm() As Boolean

Return Type

Read/write Boolean.

See Also

Command Object


SlotType Property

SlotType Property

Description

SlotType: Property indicating whether a command is a slot of a certain type

Property type

Read-write property

Syntax

Visual Basic
Public Property SlotType() As Long

See Also

Command Object


StatisticCommand Property

StatisticCommand Property

Description

Read Only: Returns an automation statistic object if the current command object is of the correct type Returns a Statistics object if Command is of Type STATISTICS. Otherwise it returns Nothing. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property StatisticCommand() As STATISTICS

Return Type

Statistics object.

See Also

Command Object


TempCompCommand Property

TempCompCommand Property

Description

Read Only: Returns an automation temperature compensatiion object if the current command object is of the correct type Returns a TempComp object if Command is of Type TEMP_COMP. Otherwise it returns Nothing. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property TempCompCommand() As TempComp

Return Type

TempComp object.

See Also

Command Object


TraceFieldCommand Property

TraceFieldCommand Property

Description

Read Only: Returns an automation trace field object if the current command object is of the correct type Returns a TraceField object if Command is of Type TRACEFIELD. Otherwise it returns Nothing. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property TraceFieldCommand() As TRACEFIELD

Return Type

Tracefield object.

See Also

Command Object


TracksErrors Property

TracksErrors Property

Description

Read/Write: Indicates Whether script will handle errors for this command Property used to determine whether or not the script will handle errors for the specified command.

Property type

Read-write property

Syntax

Visual Basic
Public Property TracksErrors() As Boolean

Return Type

Read/write Boolean. PC-DMIS returns TRUE if error handling is turned on for the specified command; FALSE otherwise.

See Also

Command Object


Type Property

Type Property

Description

Read Only: The command type Returns the type of the Command.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type() As OBTYPE

Return Type

Read-only OBTYPE.

Remarks

The returned type is the same as the type argument to Commands.Add.

See Also

Command Object


TypeDescription Property

TypeDescription Property

Description

Read Only: Returns String Describing Object Type

Returns a human-readable description of Type of the object. For example, an object of type CONST_OFF_PLANE has the string "Constructed Offset Plane" returned by this function.

Property type

Read-write property

Syntax

Visual Basic
Public Property TypeDescription() As String

Return Type

Read-only String.

Remarks

See Also

Command Object | Type Property


UnexpectedHit Property

UnexpectedHit Property

Description

Read Only: Indicates whether an unexpected hit occured

This property checks whether or not an unexpected hit occurred on the last executed instance of the specified command.

Property type

Read-write property

Syntax

Visual Basic
Public Property UnexpectedHit() As Boolean

Return Type

Read-only Boolean. PC-DMIS returns TRUE if it detects an unexpected hit for the command; FALSE otherwise.

See Also

Command Object


UserDefinedUniqueID Property

UserDefinedUniqueID Property

Description

Read/Write: Gets/Sets user defined unique id

Property type

Read-write property

Syntax

Visual Basic
Public Property UserDefinedUniqueID() As Long

See Also

Command Object


Commands Object

Commands Object
See Also Members

Description

Part Program Commands Collection Object The Commands object contains all the Command objects in a part program.

Object Model

Remarks

Use Commands(index) where index is the index number to return a single Command object.

See Also

Commands Members


Commands Object Members

Commands ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method Add | Adds a new command to the command collection This method adds a Command.
Public Method ClearAllBreakpoints | Clears all commands of their breakpoints Clears all the breakpoints on all Command objects in the collection. You should use this method if you don’t want to step through the execution of a part program.
Public Method ClearMarked | Clears all commands from being marked for execution Clears all marked Command objects in the collection. ClearMarked always returns TRUE.
Public Method FindByUniqueID | Finds the command identified by the unique id formed from low and high parts Finds a command identified by the HiPart and LoPart parameters.
Public Method InsertionPointAfter | Sets the insertion point for new command object after the specified object Sets the insertion point after a specified command.
Public Method Item | Returns the command object specified by name or number from the commands collection Returns a specific Command object from a Commands collection.
Public Method MarkAll | Marks all commands for execution except for manual alignment features if flag set Marks all the commands in a Commands collection.

Public Properties

Public Property Application | Read Only: Returns the Application Object
Public Property Count | Read Only: Returns the number of commands in the commands collection Represents the number of Command objects in the parent PartProgram object.
Public Property CurrentCommand | Read Only: Returns the current command Returns a Command object representing the current PC-DMIS command. Note that if you use the Commands.Add method prior to this property, the current command returned will be the last added command from the Add method. Read-only Command object.
Public Property LastCommand | Read Only: Returns the last command Returns a Command object representing the last command in the part program. Read-only Command object.
Public Property Parent | Read Only: Returns the parent PartProgram Object Returns the parent PartProgram object. Read-only.

See Also

Commands Overview


_Item Method

_Item Method
NameOrNum

Syntax

Visual Basic
Public Function _Item( _
   ByVal NameOrNum As Variant _
) As Command

Parameters

NameOrNum

See Also

Commands Object


Add Method

Add Method
Type
Required LONG in the OBTYPE enumeration that denotes what type of object to create.
AutoPosition

Required Boolean that determines what should happen when the new Command object is being inserted in an inappropriate place in the part program.

  • If AutoPosition is FALSE, it will not be inserted at all.
  • If it is TRUE, the new Command will be inserted at the new appropriate position.

Description

Adds a new command to the command collection This method adds a Command.

Syntax

Visual Basic
Public Function Add( _
   ByVal Type As OBTYPE, _
   ByVal AutoPosition As Boolean _
) As Command

Parameters

Type
Value Description
START_ALIGN
LEVEL_ALIGN
ROTATE_ALIGN
TRANS_ALIGN
TRANSOFF_ALIGN
ROTATEOFF_ALIGN
SAVE_ALIGN
RECALL_ALIGN
EQUATE_ALIGN
ITER_ALIGN
BF2D_ALIGN
ROTATE_CIRCLE_ALIGN
BF3D_ALIGN
POINTCLOUD_ALIGN
BFUSER_ALIGN
END_ALIGN
SET_WORKPLANE
ATTACH_PROGRAM
CURVE_FEATURE
SURFACE_FEATURE
MOVE_SPEED
TOUCH_SPEED
SCAN_SPEED
VIEWSET
RECALL_VIEWSET
SET_ACTIVE_TIP
GET_PROBE_DATA
TEMP_COMP
LOOP_START
LOOP_END
LABEL_CMD
GOTO_COMMAND
IF_GOTO_COMMAND
START_SUBROUTINE
CALL_SUBROUTINE
END_SUBROUTINE
ONERROR
WHILE_COMMAND
ENDWHILE_COMMAND
DO_COMMAND
END_IF_COMMAND
END_ELSE_IF_COMMAND
END_ELSE_COMMAND
END_CASE_COMMAND
END_SELECT_COMMAND
END_DEFAULT_CASE_COMMAND
UNTIL_COMMAND
IF_BLOCK_COMMAND
ELSE_IF_COMMAND
ELSE_COMMAND
CASE_COMMAND
SELECT_COMMAND
DEFAULT_CASE_COMMAND
ARRAY_INDEX
FILE_IO_OBJECT
CLAMP
PREHIT_DISTANCE
RETRACT_DISTANCE
CHECK_DISTANCE
MAN_DCC_MODE
BASIC_HIT
VECTOR_HIT
CORNER_HIT
ANGLE_HIT
SURFACE_HIT
EDGE_HIT
RMEAS_MODE
OPTIONPROBE
OPTIONMOTION
POLARVECTORCOMP
DISPLAYPRECISION
LEAPFROG
AUTOTRIGGERCOMMAND
MANRETRACT
VIDEOSETUP
IGNOREMOTIONERRORS
IOCHANNELCOMMAND
CLEARANCE_PLANE
PROBE_COMPENSATION
CALIB_SPHERE
CALIB_ASSEMBLY
AUTOCALIB_PROBE_COMMAND
AUTOCALIB_MASTERSLAVE_COMMAND
MOVE_POINT
MOVE_CLEARP
MOVE_ROTAB
MOVE_INCREMENT
MOVE_CIRCULAR
MOVE_PH9_OFFSET
MOVE_SYNC
START_MOVE_SWEEP
END_MOVE_SWEEP
MOVE_SWEEP_POINT
MOVE_EXCLUSIVE
MOVE_ALL
FLY_MODE
END_PROGRAM
SET_COMMENT
LOAD_MACHINE
LOAD_FIXTURE
LOAD_COLUMN
EXTERNAL_COMMAND
ANALYSIS_VIEW
TABLE_FORMAT
DIMENSION_FORMAT
COLUMN132_DISPLAY
DIMENSION_INFORMATION
POINT_INFO
FEATURE_CONTROL_FRAME
STATISTICS
TRACEFIELD
READ_POINT
GAP_ONLY
RETROLINEAR_ONLY
ASSIGNMENT
POSITIVE_REPORTING
MEASURED_POINT
MEASURED_CIRCLE
MEASURED_SPHERE
MEASURED_LINE
MEASURED_CONE
MEASURED_CYLINDER
MEASURED_PLANE
MEASURED_ROUND_SLOT
MEASURED_SQUARE_SLOT
MEASURED_SET
DCCSCAN_OBJECT
MANSCAN_OBJECT
END_MEASURED_FEATURE
BASIC_SCAN_OBJECT
TRIGGER_TOLERANCE
TRIGGER_PLANE_COMMAND
VISION_SURFACE_POINT_FEATURE
VISION_EDGE_POINT_FEATURE
VISION_LINE_FEATURE
VISION_ELLIPSE_FEATURE
VISION_CIRCLE_FEATURE
VISION_SLOT_ROUND_FEATURE
VISION_PROFILE_2D_FEATURE
VISION_SLOT_SQUARE_FEATURE
VISION_ANGLE_POINT_FEATURE
VISION_SLOT_NOTCH_FEATURE
VISION_POLYGON_FEATURE
LASER_CIRCLE_FEATURE
LASER_SURFACE_POINT_FEATURE
LASER_PLANE_FEATURE
LASER_SLOT_FEATURE
LASER_FLUSH_AND_GAP_FEATURE
LASER_SPHERE_FEATURE
LASER_CYLINDER_FEATURE
CONST_ROUND_SLOT
CONST_BF_SLOT
CONST_BFRE_SLOT
CONST_ORIG_POINT
CONST_OFF_POINT
CONST_PROJ_POINT
CONST_MID_POINT
CONST_DROP_POINT
CONST_PIERCE_POINT
CONST_INT_POINT
CONST_CAST_POINT
CONST_CORNER_POINT
CONST_BFRE_CIRCLE
CONST_BF_CIRCLE
CONST_PROJ_CIRCLE
CONST_REV_CIRCLE
CONST_CONE_CIRCLE
CONST_CAST_CIRCLE
CONST_INT_CIRCLE
CONST_SCAN_SEG_ARC
CONST_BFRE_SPHERE
CONST_BF_SPHERE
CONST_PROJ_SPHERE
CONST_REV_SPHERE
CONST_CAST_SPHERE
CONST_SCAN_SEG_LINE
CONST_BFRE_LINE
CONST_BF_LINE
CONST_PROJ_LINE
CONST_REV_LINE
CONST_MID_LINE
CONST_CAST_LINE
CONST_INT_LINE
CONST_OFF_LINE
CONST_ALN_LINE
CONST_PRTO_LINE
CONST_PLTO_LINE
CONST_BFRE_CONE
CONST_BF_CONE
CONST_PROJ_CONE
CONST_REV_CONE
CONST_CAST_CONE
CONST_BFRE_CYLINDER
CONST_BF_CYLINDER
CONST_PROJ_CYLINDER
CONST_REV_CYLINDER
CONST_CAST_CYLINDER
CONST_BFRE_PLANE
CONST_BF_PLANE
CONST_REV_PLANE
CONST_MID_PLANE
CONST_CAST_PLANE
CONST_OFF_PLANE
CONST_ALN_PLANE
CONST_PRTO_PLANE
CONST_PLTO_PLANE
CONST_HIPNT_PLANE
CONST_SET
GENERIC_CONSTRUCTION
FILTER_SET
AUTO_VECTOR_FEATURE
AUTO_SURFACE_FEATURE
AUTO_EDGE_FEATURE
AUTO_ANGLE_FEATURE
AUTO_CORNER_FEATURE
AUTO_HIGH_POINT_FEATURE
AUTO_CIRCLE
AUTO_SPHERE
AUTO_LINE
AUTO_CONE
AUTO_CYLINDER
AUTO_PLANE
AUTO_ROUND_SLOT
AUTO_SQUARE_SLOT
AUTO_ELLIPSE
AUTO_NOTCH
AUTO_PROFILE_2D
AUTO_SLOT
AUTO_FLUSH_GAP
AUTO_BLOB
AUTO_POLYGON
CONTACT_VECTOR_POINT_FEATURE
CONTACT_SURFACE_POINT_FEATURE
CONTACT_EDGE_POINT_FEATURE
CONTACT_ANGLE_POINT_FEATURE
CONTACT_CORNER_POINT_FEATURE
CONTACT_HIGH_POINT_FEATURE
CONTACT_LINE_FEATURE
CONTACT_PLANE_FEATURE
CONTACT_CIRCLE_FEATURE
CONTACT_ELLIPSE_FEATURE
CONTACT_SLOT_ROUND_FEATURE
CONTACT_SLOT_SQUARE_FEATURE
CONTACT_SLOT_NOTCH_FEATURE
CONTACT_SLOT_FEATURE
CONTACT_POLYGON_FEATURE
CONTACT_CONE_FEATURE
CONTACT_CYLINDER_FEATURE
CONTACT_SPHERE_FEATURE
DISPLAY_METAFILE
PRINT_FORM_FEED
PRINT_REPORT
EW_GROUP_START
EW_GROUP_END
SPC_QUERY
CNC_UPDATE_WORKOFSET
CNC_USE_WORKOFSET
CNC_SET_PROTECTION_COMMAND
CNC_UPDATE_TOOLOFSET
CNC_WRITE_VARIABLE
CNC_READ_VARIABLE
DIMENSION_START_LOCATION
DIMENSION_END_LOCATION
DIMENSION_X_LOCATION
DIMENSION_Y_LOCATION
DIMENSION_Z_LOCATION
DIMENSION_D_LOCATION
DIMENSION_R_LOCATION
DIMENSION_A_LOCATION
DIMENSION_T_LOCATION
DIMENSION_PR_LOCATION
DIMENSION_PA_LOCATION
DIMENSION_V_LOCATION
DIMENSION_L_LOCATION
DIMENSION_PD_LOCATION
DIMENSION_RT_LOCATION
DIMENSION_S_LOCATION
DIMENSION_RS_LOCATION
DIMENSION_H_LOCATION
DIMENSION_FLATNESS_LOCATION
DIMENSION_ROUNDNESS_LOCATION
DIMENSION_STRAIGHTNESS_LOCATION
DIMENSION_STRAIGHTNESS
DIMENSION_ROUNDNESS
DIMENSION_CIRCULARITY
DIMENSION_FLATNESS
DIMENSION_PERPENDICULARITY
DIMENSION_PARALLELISM
DIMENSION_PROFILE
DIMENSION_PROFILE_SURFACE
DIMENSION_3D_DISTANCE
DIMENSION_2D_DISTANCE
DIMENSION_3D_ANGLE
DIMENSION_2D_ANGLE
DIMENSION_RUNOUT
DIMENSION_TOTAL_RUNOUT
DIMENSION_CONCENTRICITY
DIMENSION_ANGULARITY
DIMENSION_KEYIN
DIMENSION_COAXIALITY
DIMENSION_SYMMETRY
DIMENSION_CYLINDRICITY
DIMENSION_CIRCULAR_RUNOUT
DIMENSION_PROFILE_LINE
DIMENSION_TRUE_START_POSITION
DIMENSION_TRUE_END_POSITION
DIMENSION_TRUE_X_LOCATION
DIMENSION_TRUE_Y_LOCATION
DIMENSION_TRUE_Z_LOCATION
DIMENSION_TRUE_DD_LOCATION
DIMENSION_TRUE_DF_LOCATION
DIMENSION_TRUE_PR_LOCATION
DIMENSION_TRUE_PA_LOCATION
DIMENSION_TRUE_DIAM_LOCATION
DIMENSION_TRUE_LD_LOCATION
DIMENSION_TRUE_WD_LOCATION
DIMENSION_TRUE_LF_LOCATION
DIMENSION_TRUE_WF_LOCATION
DIMENSION_TRUE_D1_LOCATION
DIMENSION_TRUE_D2_LOCATION
DIMENSION_TRUE_D3_LOCATION
DIMENSION_TRUE_FLATNESS_LOCATION
DIMENSION_TRUE_ROUNDNESS_LOCATION
DIMENSION_TRUE_STRAIGHTNESS_LOCATION
DATDEF_COMMAND
SIMULTANEOUS_EVALUATION
BASIC_SCRIPT
END_SCRIPT
HYPER_LEGACY
END_HYPER_REPORT
HYPER_FORM
END_HYPER_FORM
HYPER_CUSTOM
HYPER_TEMPLATE
HYPER_REPORT
Required LONG in the OBTYPE enumeration that denotes what type of object to create.
AutoPosition

Required Boolean that determines what should happen when the new Command object is being inserted in an inappropriate place in the part program.

  • If AutoPosition is FALSE, it will not be inserted at all.
  • If it is TRUE, the new Command will be inserted at the new appropriate position.

Return Type

Command object.

Remarks

PC-DMIS only supports one way for adding commands while executing a part program in PC-DMIS: Insert a script command (select Insert | Basic Script from within PC-DMIS) that points to the BASIC script containing the Add method. Otherwise, you will need to run your script with the Add method first and control part program execution from within your script.

Example

Sub main()

' This sample script shows how to add a GROUP/ and ENDGROUP/ command into the end of your part program.

Dim pcd As Object

Dim pp As Object

Dim cmds As Object

Dim cmd As Object

Dim start_grp As Object

Dim end_grp As Object

Dim uidstr As String

Dim RetVal As Boolean

Set pcd = CreateObject("PCDLRN.Application.4.2")

Set pp = pcd.ActivePartProgram

Set cmds = pp.Commands

Set cmd = cmds.LastCommand

cmds.InsertionPointAfter cmd

Set start_grp = cmds.Add(752, True)

start_grp.ID = "I"

start_grp.ReDraw

cmds.InsertionPointAfter start_grp

Set end_grp = cmds.Add(753, True)

end_grp.ReDraw

uidstr = end_grp.GetText(PCDLRN.uid, 0)

RetVal = start_grp.PutText(uidstr, PCDLRN.REF_UID, 0)

uidstr = start_grp.GetText(PCDLRN.uid, 0)

RetVal = end_grp.PutText(uidstr, PCDLRN.REF_UID, 0)

pp.RefreshPart

End Sub

See Also

Commands Object | Remove Method


ClearAllBreakpoints Method

ClearAllBreakpoints Method

Description

Clears all commands of their breakpoints Clears all the breakpoints on all Command objects in the collection. You should use this method if you don’t want to step through the execution of a part program.

Syntax

Visual Basic
Public Function ClearAllBreakpoints() As Boolean

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

Commands Object


ClearMarked Method

ClearMarked Method

Description

Clears all commands from being marked for execution Clears all marked Command objects in the collection. ClearMarked always returns TRUE.

Syntax

Visual Basic
Public Function ClearMarked() As Boolean

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

Commands Object


FindByUniqueID Method

FindByUniqueID Method
HiPart
This parameter is a long value that should come from a call to GetUniqueID made previously on the desired command object.
LoPart
This parameter is a long value that should come from a call to GetUniqueID made previously on the command object.

Description

Finds the command identified by the unique id formed from low and high parts Finds a command identified by the HiPart and LoPart parameters.

Syntax

Visual Basic
Public Function FindByUniqueID( _
   ByVal HiPart As Long, _
   ByVal LoPart As Long _
) As Command

Parameters

HiPart
This parameter is a long value that should come from a call to GetUniqueID made previously on the desired command object.
LoPart
This parameter is a long value that should come from a call to GetUniqueID made previously on the command object.

Return Type

Command object.

See Also

Commands Object


InsertionPointAfter Method

InsertionPointAfter Method
Command
Required Command object that indicates which command after which to set the insertion point.

Description

Sets the insertion point for new command object after the specified object Sets the insertion point after a specified command.

Syntax

Visual Basic
Public Function InsertionPointAfter( _
   ByVal Command As Command _
) As Boolean

Parameters

Command
Required Command object that indicates which command after which to set the insertion point.

Return Type

Boolean value. This function returns TRUE if the insertion point was successfully set, FALSE otherwise.

See Also

Commands Object


Item Method

Item Method
NameOrNum
Required Long that indicates which Command object to return. It is the index number of the desired Command in the Commands collection.

Description

Returns the command object specified by name or number from the commands collection Returns a specific Command object from a Commands collection.

Syntax

Visual Basic
Public Function Item( _
   ByVal NameOrNum As Variant _
) As Command

Parameters

NameOrNum
Required Long that indicates which Command object to return. It is the index number of the desired Command in the Commands collection.

Return Type

Command object.

See Also

Commands Object


MarkAll Method

MarkAll Method
MarkManual
Required Boolean that indicates whether or not to mark manual alignment features.

Description

Marks all commands for execution except for manual alignment features if flag set Marks all the commands in a Commands collection.

Syntax

Visual Basic
Public Function MarkAll( _
   ByVal MarkManual As Boolean _
) As Boolean

Parameters

MarkManual
Required Boolean that indicates whether or not to mark manual alignment features.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

Commands Object


Application Property

Application Property

Description

Read Only: Returns the Application Object

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

See Also

Commands Object


Count Property

Count Property

Description

Read Only: Returns the number of commands in the commands collection Represents the number of Command objects in the parent PartProgram object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

Return Type

Read-only Long.

See Also

Commands Object


CurrentCommand Property

CurrentCommand Property

Description

Read Only: Returns the current command

Returns a Command object representing the current PC-DMIS command. Note that if you use the Commands.Add method prior to this property, the current command returned will be the last added command from the Add method. Read-only Command object.

Property type

Read-write property

Syntax

Visual Basic
Public Property CurrentCommand() As Command

Return Type

Command object.

See Also

Commands Object


LastCommand Property

LastCommand Property

Description

Read Only: Returns the last command

Returns a Command object representing the last command in the part program. Read-only Command object.

Property type

Read-write property

Syntax

Visual Basic
Public Property LastCommand() As Command

Return Type

Command object.

Remarks

This gives you a faster way of getting the last command. Before you had to use this syntax:

Commands.Item(Commands.Count).

See Also

Commands Object


Parent Property

Parent Property

Description

Read Only: Returns the parent PartProgram Object Returns the parent PartProgram object. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As PartProgram

Return Type

PartProgram object.

See Also

Commands Object


Comment Object

Comment Object
See Also Members

Description

The Comment object gives access to the properties of the PC-DMIS Comment command.

See Also

Comment Members


Comment Object Members

Comment ObjectMembers
See Also Overview

Public Methods

Public Method AddLine | Adds line to comment text Adds a line of text to the comment.
Public Method GetLine | Gets single line of multiple line comment Retrieves the line of text from the comment specified by the Line parameter.
Public Method RemoveLine | Removes line from comment text Removes a line of text from the comment.
Public Method SetLine | Sets single line of multiple line comment Sets the line of comment text.

Public Properties

Public Property Comment | Read/Write: Comment text STRING value representing the comment text. Since comments in PC-DMIS can be multi-line comments, this property represents the full text of all the lines. Each line is separated by ASCII character 13 and ASCII character 10 in that order. This is a read only property. To set individual lines of the comment use the SetLine method. To get individual lines of the comment use the GetLine method.
Public Property CommentType | Read/Write: Comment type (ie. Operator, Report, YesNo, etc.) Returns the type of comment.
Public Property ID | Read/Write: ID to reference comment STRING value representing the ID of the comment. The ID is only used for comments of type INPUT and type YESNO.
Public Property Input | Read/Write: Input text from user STRING value representing the text input by the user for comments of type INPUT or YESNO.

See Also

Comment Overview


AddLine Method

AddLine Method
Text
Required String value represents the line of text to be added to the comment.

Description

Adds line to comment text Adds a line of text to the comment.

Syntax

Visual Basic
Public Function AddLine( _
   ByVal Text As String _
) As Boolean

Parameters

Text
Required String value represents the line of text to be added to the comment.

Return Type

Boolean value indicating success or failure of call to method.

See Also

Comment Object


GetLine Method

GetLine Method
Line
Required Long representing the line of text to be retrieved.

Description

Gets single line of multiple line comment Retrieves the line of text from the comment specified by the Line parameter.

Syntax

Visual Basic
Public Function GetLine( _
   ByVal Line As Long _
) As String

Parameters

Line
Required Long representing the line of text to be retrieved.

Return Type

String value containing the line of comment text specified by the line parameter. If Line is greater than the number of current lines in the comment, the string will be empty.

See Also

Comment Object


RemoveLine Method

RemoveLine Method
Line
Required Long representing the line of text to be removed.

Description

Removes line from comment text Removes a line of text from the comment.

Syntax

Visual Basic
Public Function RemoveLine( _
   ByVal Line As Long _
) As Boolean

Parameters

Line
Required Long representing the line of text to be removed.

Return Type

Boolean value indicating success or failure of call to remove a line of text from the comment. If Line is greater than the number of current lines in the comment, the call will fail.

See Also

Comment Object


SetLine Method

SetLine Method
Line
Required Long representing the line of text to be set.
Text
Required String which is the text to be used to set the text for the line of the comment.

Description

Sets single line of multiple line comment Sets the line of comment text.

Syntax

Visual Basic
Public Function SetLine( _
   ByVal Line As Long, _
   ByVal Text As String _
) As Boolean

Parameters

Line
Required Long representing the line of text to be set.
Text
Required String which is the text to be used to set the text for the line of the comment.

Return Type

Boolean value indicating success or failure of call to set the line of text. If Line is greater than the number of current lines in the comment, the call will fail.

See Also

Comment Object


Comment Property

Comment Property

Description

Read/Write: Comment text

STRING value representing the comment text. Since comments in PC-DMIS can be multi-line comments, this property represents the full text of all the lines. Each line is separated by ASCII character 13 and ASCII character 10 in that order. This is a read only property. To set individual lines of the comment use the SetLine method. To get individual lines of the comment use the GetLine method.

Property type

Read-write property

Syntax

Visual Basic
Public Property Comment() As String

Return Type

Read Only String.

See Also

Comment Object


CommentType Property

CommentType Property

Description

Read/Write: Comment type (ie. Operator, Report, YesNo, etc.)

Returns the type of comment.

Property type

Read-write property

Syntax

Visual Basic
Public Property CommentType() As ENUM_PCD_COMMENT_TYPES

Return Type

Read/Write ENUM_PCD_COMMENT_TYPES enumeration type

Remarks

ENUM_PCD_COMMENT_TYPES enumeration type value representing the type of comment. The following enumeration values are available:

PCD_COMMENT_OPER = 0

PCD_COMMENT_REPORT = 1

PCD_COMMENT_INPUT = 2

PCD_COMMENT_DOCUMENTATION = 3

PCD_COMMENT_YESNO = 4

See Also

Comment Object


ID Property

ID Property

Description

Read/Write: ID to reference comment

STRING value representing the ID of the comment. The ID is only used for comments of type INPUT and type YESNO.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As String

Return Type

Read/write String.

See Also

Comment Object


Input Property

Input Property

Description

Read/Write: Input text from user

STRING value representing the text input by the user for comments of type INPUT or YESNO.

Property type

Read-write property

Syntax

Visual Basic
Public Property Input() As String

Return Type

Read/write String.

See Also

Comment Object


ControlPoint Object

ControlPoint Object
See Also Members

Description

With the ControlPoint object you can insert control point locations. These locations interrupt the normal scan and alter scan speed, point density or both for defined portions of the scan.

Remarks

The ControlPoint object is used with only the following scans:

  • LinearOpen
  • LinearClose
  • Patch
  • Section
  • Line (Basic Scan)

Additionally, the ControlPoint object only works on machines that use an analog probe that allows continuous contact scanning.

In the PC-DMIS documentation, the Control Points are called Interrupt Points. See "Interrupts" in the "Scanning Your Part" section of your PC-DMIS documentation.

See Also

ControlPoint Members


ControlPoint Object Members

ControlPoint ObjectMembers
See Also Overview

Public Properties

Public Property Crossings | Read/Write: Number of Crossings for control point This defines the number of time the scan crosses the specified boundary before the alterations defined by the crossing point take effect.
Public Property I | Read/Write: I component of control point vector This specifies the I component of the interrupt location's IJK vector.
Public Property J | Read/Write: J component of control point vector This specifies the J component of the interrupt location's IJK vector.
Public Property K | Read/Write: K component of control point vector This specifies the K component of the interrupt location IJK vector.
Public Property PointDensity | Read/Write: Number of Points per MM for control point This defines the density of points per millimeter the scan shoud take after it encounters the control point.
Public Property PointDensity2 | Read/Write: Number of Points per MM for control point. Can be less than 1
Public Property Radius | Read/Write: Radius of control point (Sphere/Cylinder) This defines the Radius of circular control point types (Cones, Spheres, Cylinders).
Public Property Speed | Read/Write: Scan Speed Setting for control point
Public Property Type | Read/Write: Type of scan control point This specifies the type of control point.
Public Property X | Read/Write: X component of control point location This specifies the X value of the interrupt XYZ location.
Public Property Y | Read/Write: Y component of control point location This specifies the Y component of the interrupt XYZ location.
Public Property Z | Read/Write: Z component of control point location This specifies the Z component of the interrupt XYZ location.

See Also

ControlPoint Overview


Crossings Property

Crossings Property

Description

Read/Write: Number of Crossings for control point

This defines the number of time the scan crosses the specified boundary before the alterations defined by the crossing point take effect.

Property type

Read-write property

Syntax

Visual Basic
Public Property Crossings() As Long

Return Type

Read/write Long.

See Also

ControlPoint Object


I Property

I Property

Description

Read/Write: I component of control point vector

This specifies the I component of the interrupt location's IJK vector.

Property type

Read-write property

Syntax

Visual Basic
Public Property I() As Double

Return Type

Read/write Double.

See Also

ControlPoint Object


J Property

J Property

Description

Read/Write: J component of control point vector

This specifies the J component of the interrupt location's IJK vector.

Property type

Read-write property

Syntax

Visual Basic
Public Property J() As Double

Return Type

Read/write Double.

See Also

ControlPoint Object


K Property

K Property

Description

Read/Write: K component of control point vector

This specifies the K component of the interrupt location IJK vector.

Property type

Read-write property

Syntax

Visual Basic
Public Property K() As Double

Return Type

Read/write Double.

See Also

ControlPoint Object


PointDensity Property

PointDensity Property

Description

Read/Write: Number of Points per MM for control point

This defines the density of points per millimeter the scan shoud take after it encounters the control point.

Property type

Read-write property

Syntax

Visual Basic
Public Property PointDensity() As Long

Return Type

Read/write Long.

See Also

ControlPoint Object


PointDensity2 Property

PointDensity2 Property

Description

Read/Write: Number of Points per MM for control point. Can be less than 1

Property type

Read-write property

Syntax

Visual Basic
Public Property PointDensity2() As Double

See Also

ControlPoint Object


Radius Property

Radius Property

Description

Read/Write: Radius of control point (Sphere/Cylinder)

This defines the Radius of circular control point types (Cones, Spheres, Cylinders).

Property type

Read-write property

Syntax

Visual Basic
Public Property Radius() As Double

Return Type

Read/write Double.

See Also

ControlPoint Object


Speed Property

Speed Property

Description

Read/Write: Scan Speed Setting for control point

Property type

Read-write property

Syntax

Visual Basic
Public Property Speed() As Double

See Also

ControlPoint Object


Type Property

Type Property

Description

Read/Write: Type of scan control point This specifies the type of control point.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type() As BSCTRLPT_ENUM

Return Type

Read/write BSCTRLPT_ENUM.

Remarks

There are four types of control points:

  1. Plane (uses these elements: Plane, X,Y,Z,I,J,K,Num Crossings, Scan Speed, Point Density)
  2. Sphere (uses these elements: Sphere, X, Y, Z, I, J, K, Num Crossings, Scan Speed, Point Density, Diameter)
  3. Cone (uses these elements: Cone, X, Y, Z, I, J, K, Num Crossings, Scan Speed, Point Density, Angle)
  4. Cylinder (uses these elements: Cylinder, X, Y, Z, I, J, K, Num Crossings, Scan Speed, Point Density, Diameter)

See Also

ControlPoint Object


X Property

X Property

Description

Read/Write: X component of control point location

This specifies the X value of the interrupt XYZ location.

Property type

Read-write property

Syntax

Visual Basic
Public Property X() As Double

Return Type

Read/write Double.

See Also

ControlPoint Object


Y Property

Y Property

Description

Read/Write: Y component of control point location

This specifies the Y component of the interrupt XYZ location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Y() As Double

Return Type

Read/write Double.

See Also

ControlPoint Object


Z Property

Z Property

Description

Read/Write: Z component of control point location

This specifies the Z component of the interrupt XYZ location.

Property type

Read-write property

Syntax

Visual Basic
Public Property Z() As Double

Return Type

Read/write Double.

See Also

ControlPoint Object


DataType Object

DataType Object
See Also Members

Description

Command Data Type Information Object The DataType object allows you to return objects of information about a particular data type or field.

Object Model

See Also

DataType Members


DataType Object Members

DataType ObjectMembers
See Also Overview

Public Properties

Public Property _Value |
Public Property Application | Read Only: Returns the Application Object Returns the PC-DMIS Application object.
Public Property Count | Read Only: Returns the number of instances of this data type in command This returns the number of instances of this data type in command.
Public Property DBType | Read Only: Returns the db field type of the this data type
Public Property DESCRIPTION | Read Only: returns a data type description string This returns a description of the data type.
Public Property Parent | Read Only: Returns the Parent Command Object This returns the Parent Command Object. Read only.
Public Property Type | Read Only: Returns the field type of the this data type This returns the field type of the data type.
Public Property Value | Read Only: Field Type Number - Default Property This returns the Default Property for a Field Type Number.
Public Property VariableType | Read Only: Returns the data type of the this data type

See Also

DataType Overview


_Value Property

_Value Property

Property type

Read-write property

Syntax

Visual Basic
Public Property _Value() As Long

See Also

DataType Object


Application Property

Application Property

Description

Read Only: Returns the Application Object Returns the PC-DMIS Application object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

DataType Object


Count Property

Count Property

Description

Read Only: Returns the number of instances of this data type in command

This returns the number of instances of this data type in command.

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

Return Type

Read only Long.

See Also

DataType Object


DBType Property

DBType Property

Description

Read Only: Returns the db field type of the this data type

Property type

Read-write property

Syntax

Visual Basic
Public Property DBType() As ENUM_DTYPE_GETDBTYPE

See Also

DataType Object


DESCRIPTION Property

DESCRIPTION Property

Description

Read Only: returns a data type description string

This returns a description of the data type.

Property type

Read-write property

Syntax

Visual Basic
Public Property DESCRIPTION() As String

Return Type

Read only String.

See Also

DataType Object


Parent Property

Parent Property

Description

Read Only: Returns the Parent Command Object This returns the Parent Command Object. Read only.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Command

Return Type

Command object.

See Also

DataType Object


Type Property

Type Property

Description

Read Only: Returns the field type of the this data type

This returns the field type of the data type.

Property type

Read-write property

Syntax

Visual Basic
Public Property Type() As DATA_TYPE_TYPES

Return Type

Read only DATA_TYPE_TYPES.

See Also

DataType Object


Value Property

Value Property

Description

Read Only: Field Type Number - Default Property

This returns the Default Property for a Field Type Number.

Property type

Read-write property

Syntax

Visual Basic
Public Property Value() As Long

Return Type

Read only Long.

See Also

DataType Object


VariableType Property

VariableType Property

Description

Read Only: Returns the data type of the this data type

Property type

Read-write property

Syntax

Visual Basic
Public Property VariableType() As ENUM_DTYPE_GETVARIABLETYPE

See Also

DataType Object


DataTypes Object

DataTypes Object
See Also Members

Description

Command Data Type Information Collection Object The DataTypes object allows you to return objects of varying data types.

Object Model

See Also

DataTypes Members


DataTypes Object Members

DataTypes ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method GetDataTypeInfo | Returns the specified data type information object if supported by the data type collection Returns the specified data type information object if supported by the data type collection.
Public Method Item | Returns the data type information object specified by number from the data type collection This returns the data type information object specified by the Num value from the data type collection.

Public Properties

Public Property Application | Read Only: Returns the Application Object This returns the Application object. Read only.
Public Property Count | Read Only: Returns the number of data type information objects in the data type collection This returns the number of data type information objects in the data type collection.
Public Property Parent | Read Only: Returns the Parent Command Object This returns the Parent Command object. Read only.

See Also

DataTypes Overview


_Item Method

_Item Method
Identifier

Syntax

Visual Basic
Public Function _Item( _
   ByVal Identifier As Long _
) As DataType

Parameters

Identifier

See Also

DataTypes Object


GetDataTypeInfo Method

GetDataTypeInfo Method
DataType
ENUM_FIELD_TYPES value specifying the DataType information object to return.

Description

Returns the specified data type information object if supported by the data type collection Returns the specified data type information object if supported by the data type collection.

Syntax

Visual Basic
Public Function GetDataTypeInfo( _
   ByVal DataType As ENUM_FIELD_TYPES _
) As DataType

Parameters

DataType
Value Description
ID
REF_ID
LEVEL_REF_ID
ROTATE_REF_ID
ORIGIN_REF_ID
THEO_X
THEO_Y
THEO_Z
THEO_SX
THEO_SY
THEO_SZ
THEO_EX
THEO_EY
THEO_EZ
THEO_I
THEO_J
THEO_K
TARG_X
TARG_Y
TARG_Z
MEAS_X
MEAS_Y
MEAS_Z
MEAS_I
MEAS_J
MEAS_K
MEAS_LENGTH
MEAS_DIAM
MEAS_ANGLE
TARG_I
TARG_J
TARG_K
THEO_DIAM
THEO_WIDTH
THEO_LENGTH
THEO_HEIGHT
THEO_ANGLE
COORD_TYPE
INOUT_TYPE
THICKNESS_TYPE
CIRC_TYPE
SNAP_TYPE
USEPIN_TYPE
MOVE_TYPE
READPOS_TYPE
FINDHOLE_TYPE
RMEAS_TYPE
THEOBF_TYPE
BOUND_TYPE
BF_MATH_TYPE
AUTOFIT_CONSTRAINT
SLOT_MIN_MAX_TYPE
FIND_NOM_AXIS_TYPE
N_INIT_HITS_TYPE
N_PERM_HITS_TYPE
SEARCHMODE_TYPE
MODE_TYPE
MEASURE_ORDER_TYPE
CONE_LENGTH_ANGLE_TYPE
OFFSET_LINE_METHOD
LIN_POL_FILT_TYPE
GEN_FEAT_TYPE
GEN_ALIGN_TYPE
CURVE_TYPE
MEASURED_2D3D_TYPE
THINNING_TOL
HITINT_TYPE
RMEASFEATID
N_HITS
N_ROWS
INIT_HITS
PERM_HITS
F_OFFSET
F_SPACER
F_PITCH
F_THICKNESS
F_DEPTH
F_AUTOMOVE
F_INDENT
F_CORNER_RADIUS
F_INCREMENT
F_TOLERANCE
F_BOXWIDTH
F_BOXLENGTH
F_CIRCRADOUT
F_CIRCRADIN
F_CHECK
F_MAXACCELX
F_MAXACCELY
F_MAXACCELZ
SCAN_ACCELERATION
SCAN_OFFSET_FORCE
MANUAL_FINE_PROBING
F_MOVESPEED
F_TOUCHSPEED
F_SCANSPEED
START_ANG
END_ANG
MIDPOINT_X
MIDPOINT_Y
MIDPOINT_Z
ANGVEC_I
ANGVEC_J
ANGVEC_K
MEASVEC_I
MEASVEC_J
MEASVEC_K
SLOTVEC_I
SLOTVEC_J
SLOTVEC_K
SURFVEC_I
SURFVEC_J
SURFVEC_K
PINVEC_I
PINVEC_J
PINVEC_K
PUNCHVEC_I
PUNCHVEC_J
PUNCHVEC_K
REPORTVEC_I
REPORTVEC_J
REPORTVEC_K
TARGSLOT_I
TARGSLOT_J
TARGSLOT_K
UPDATEVEC_I
UPDATEVEC_J
UPDATEVEC_K
THEO_MINOR_AXIS
TWO_D_THREE_D_TYPE
AXIS
DEST_EXPR
SRC_EXPR
SHOW_IDS
SHOW_DETAILS
WEIGHT
ITEM_USED
USE_AXIS
AVERAGE_ERROR
MEASURE_ALL_FEATURES
REPIERCE_CAD
START_NUM
END_NUM
SKIP_NUM
X_OFFSET
Y_OFFSET
Z_OFFSET
ANGLE_OFFSET
INTERNAL_EXTERNAL
SAVE_ALIGN_CAD_TO_PARTS
FILE_NAME
ALIGN_LIST
WORK_PLANE
DISTANCE
OLD_TIP
NEW_TIP
ROTATION_TYPE
DIM_INFO_ORDER
DIM_INFO_LOC
DIM_INFO_TP_LOC
GRAPH_ANALYSIS
TEXT_ANALYSIS
ARROW_MULTIPLIER
OUTPUT_TYPE
NOMINAL
F_PLUS_TOL
F_MINUS_TOL
TP_MODIFIER
PERP_PARALLEL_TYPE
RADIUS_TYPE
UNIT_TYPE
DIM_LENGTH
PROFILE_FORM_TYPE
PRECISION
MAN_RETRACT
DIM_TEXT
DIM_TEXT_OPTIONS
SHOW_HEADINGS
DEVIATION_SYMBOLS
STANDARD_DEVIATION
DIM_HEADING
GAP_ONLY_TYPE
DISPLAY_ID
DISPLAY_TYPE
POINT_INFO_HEADING
SHOW_POINT_INFO
RET_ONLY_TYPE
COMMENT_FIELD
COMMENT_TYPE
PART_NAME
REVISION_NUMBER
SERIAL_NUMBER
STAT_COUNT
SUB_NAME
READ_WRITE
FILE_POINTER
FIELD_WIDTH
DIGIT_COUNT
LABEL_ID
ERROR_TYPE
ERROR_MODE
DESCRIPTION
INDEX_START
INDEX_END
FILE_COMMAND_TYPE
BUFFER_SIZE_TYPE
FAIL_ON_EXIST
MAX_FORCE
LOW_FORCE
UP_FORCE
TRIGGER_FORCE
PROBE_ACCURACY
POSITIONAL_ACCURACY
NUM_RETURN_DATA
RETURN_SPEED
SCAN_DENSITY
POLAR_VECTOR_COMPENSATION
AUTO_PRINT
ORIGIN
MATERIAL_COEFFICIENT
REF_TEMP
HIGH_THRESHOLD
LOW_THRESHOLD
SENSOR_LIST
FIXTURE_TYPE
MACHINE_TYPE
PROBE_COMP
TIP_I
TIP_J
TIP_K
NORM_RELEARN
FIND_NOMS_TYPE
AUTO_CLEAR_PLANE
SINGLE_POINT
DISPLAY_HITS
CAD_TOLERANCE
OFFSET_TOLERANCE
MIN_INCREMENT
MAX_INCREMENT
MIN_ANGLE
MAX_ANGLE
F_LOCATION
COL132_TYPE
COMMAND_STRING
FLY_MODE_TYPE
STATS_TYPE
STATS_DIR
NEW_STATS_DIR
DATA_READ_LOCK
DATA_WRITE_LOCK
DATA_MEM_PAGES
STAT_NAME_TYPE
STAT_CALC_TYPE
TRANSFER_DIR
DISPLAY_TRACE
TRACE_NAME
TRACE_VALUE
SCAN_CUTPLANEVEC_I
SCAN_CUTPLANEVEC_J
SCAN_CUTPLANEVEC_K
SCAN_INITVEC_I
SCAN_INITVEC_J
SCAN_INITVEC_K
SCAN_AXISVEC_I
SCAN_AXISVEC_J
SCAN_AXISVEC_K
SCAN_ENDVEC_I
SCAN_ENDVEC_J
SCAN_ENDVEC_K
SCAN_INITDIR_I
SCAN_INITDIR_J
SCAN_INITDIR_K
SCAN_CROSS_TOTAL
SCAN_TIME_INCR
SCAN_EDGE_THICK
POS_REPORT_AXIS_X
POS_REPORT_AXIS_Y
POS_REPORT_AXIS_Z
DEV_PERPEN_CENTERLINE
USE_THEO
TARGET_COLOR
THEO_START_ANG
THEO_END_ANG
ONOFF_TYPE
ROW_ID
LOCATOR_BMP
LOCATOR_WAV
DTYPE_LEAPFROGTYPE
DTYPE_LEAPFROGNUMHITS
DTYPE_LEAPFROGFULLPARTIAL
EXCLUSION_ZONE
EXECUTE
AUTOTRIGGERONOFF
AUTOBEEPING
COLUMN_ID
SLOT_NUMBER
AUTOTOLZONE
PROBING_MODE
ANGLE_COMP_TOGGLE
POINTINFO_FILTER_INTERVAL
POINTINFO_FILTER_INTERVAL_NUMBER
FEAT_TYPE
DIM_ID
MEAS_MINOR_AXIS
MEAS_HEIGHT
MEAS_SLOTVEC_I
MEAS_SLOTVEC_J
MEAS_SLOTVEC_K
MEAS_SX
MEAS_SY
MEAS_SZ
MEAS_EX
MEAS_EY
MEAS_EZ
MEAS_WIDTH
NUM_CONTROL_POINTS
U_HITS
V_HITS
NUM_FIT_POINTS
NOMINAL_COLOR
WAVE_FILE
DIM_BONUS
PERUNIT_STEPSIZE
PERUNIT_LENGTH
PERUNIT_WIDTH
DIM_MEASURED
SURFVEC_TARG_I
SURFVEC_TARG_J
SURFVEC_TARG_K
DIM_MAX
EDGEVEC_TARG_I
EDGEVEC_TARG_J
EDGEVEC_TARG_K
DIM_MIN
EDGEVEC_THEO_I
EDGEVEC_THEO_J
EDGEVEC_THEO_K
DIM_DEVIATION
EDGEVEC_MEAS_I
EDGEVEC_MEAS_J
EDGEVEC_MEAS_K
DIM_OUTTOL
T_VALUE
TOOL_X
TOOL_Y
TOOL_Z
TOOL_DIAM
DEV_X
DEV_Y
DEV_Z
DEV_DIAM
ITERATE_COLUMNS
LOAD_TYPE
NUM_ITERATIONS
METHOD_TYPE
SCAN_TECHNIQUE
HIT_TYPE
BOUNDARY_POINT_X
BOUNDARY_POINT_Y
BOUNDARY_POINT_Z
VIDEO_GAIN
VIDEO_OFFSET
VIDEO_LEDLIGHT
VIDEO_LASERLIGHT1
VIDEO_LASERLIGHT2
VIDEO_YORIGIN
VIDEO_YEND
VIDEO_LSEG
VIDEO_XSEG
VIDEO_YSEG
ANGULARITY_NOM_ANGLE
PRINT_TO_FILE
PRINT_TO_PRINTER
PRINT_DRAFTMODE
PRINT_DELETE_RUNS
POINTINFO_FILTER_WORST
POINTINFO_FILTER_WORST_NUMBER
POINTINFO_FILTER_DEVIATION
POINTINFO_FILTER_DEVIATION_NUMBER
POINTINFO_FILTER_OUTTOL
REPORT_SURFVEC_I
REPORT_SURFVEC_J
REPORT_SURFVEC_K
DB_QUERY_OP
DB_SOURCE_NAME
CHART_TYPE
DB_CHART_NAME
DEVIATION_ANGLE
STATS_DATASOURCE
IGNOREMOTIONERRORS_TYPE
THEO_X2
THEO_Y2
THEO_Z2
MEAS_X2
MEAS_Y2
MEAS_Z2
PPROG
TRACE_FILTER
TIME_FILTER
SHOW_SPC_CALCS
SPEC_LIMITS
ZONES
STDDEV
UCL_LCL
HISTOGRAM
GRID
ADDITIONAL_CHART
LINE2_PLANAR_OPEN_IN_X
LINE3_PLANAR_OPEN_IN_X
REGR
CENTER_POINT
SHOW_MORE_SPC_CALCS
SPEC_OFFSET
SOLID
U_L_BOUNDS
TITLE
CPOINT_X
CPOINT_Y
CPOINT_Z
CPOINT_I
CPOINT_J
CPOINT_K
CPOINT_DIAM
CPOINT_SCAN_CROSS_TOTAL
CPOINT_SCAN_DENSITY
CPOINT_F_SCANSPEED
N_CONTROLPOINTS
CPOINT_TYPE
USE_3DFILTER
SCAN_BNDRY_TYPE
CREATE_WEIGHTS
F_SIZE
LINE2_ISPLANAR
LINE2_PLANAR_XTOL
LINE2_PLANAR_YTOL
LINE2_PLANAR_XDEV
LINE2_PLANAR_YDEV
LINE3_ISPLANAR
LINE3_PLANAR_XTOL
LINE3_PLANAR_YTOL
LINE3_PLANAR_XDEV
LINE3_PLANAR_YDEV
CHART_SUB_TYPE
OVERWRITE
OUTPUT_FEATURE_NOMS
OUTPUT_FEAT_W_DIMENS
OUTPUT_DMIS_REPORT
TIME_ARG
TRACE_FILTER_ARG
FIT
STATS_DB_TYPE
IOCHANNEL_NUMBER
IOCHANNEL_PULSE_WIDTH
IOCHANNEL_PULSE_INTERVAL
IOCHANNEL_PULSE_DURATION
GRAPH_OPTION
DB_SOURCE_TYPE
FIND_HOLE_PERCENT
AUTO_ONERROR_TYPE
POS_REPT_DISPLAY_OPTION
TRIGGERTOLERANCE
TRIGGERTOLVALUE
FIXTURE_TOL
START_LABEL
ERROR_LABEL
CONE_CONVEX_TYPE
TRIGGERPLANE
QUERY_SHOW_GRAPHIC_SETTINGS
CALC_STYLE_FILE
FILTER_TYPE
TRACE_VALUE_LIMIT
TARGET_DIRECTION
TARGET_EDGE_POLARITY
BSMETHOD_TYPE
CENTER_ROTATION_THEO
CENTER_ROTATION_MEAS
ARTICULATEDARM_TYPE
LEFTYRIGHTY_CONFIG
ABOVEBELOW_CONFIG
NOFLIPFLIP_CONFIG
HIGH_ACCURACY
SURFACE
MAGNIFICATION
MINOR_WORD_TOGGLE
PERCENTAGE
THRESHOLD
N_SIDES
TARGET_SURFACE_ILLUM
MEAN
CAD_COMP
SHOW_ROW
SHOW_COLUMN
TARGET_SURFACE_SENSILIGHT
TARGET_SURFACE_WIDTH
TARGET_SURFACE_HEIGHT
TARGET_SURFACE_RANGE
TARGET_SURFACE_DURATION
TARGET_SURFACE_MODE
TARGET_SURFACE_HIACC
SCREEN_CAPTURE_SCALE
SCREEN_CAPTURE_QUALITY
TARGET_EDGE_SIZE
TARGET_EDGE_ILLUM
TARGET_EDGE_TOL
TARGET_EDGE_STRENGTH
TARGET_EDGE_DENSITY
TARGET_EDGE_TYPE
DISPLAY_ADVANCED_PARAMETERS
TARGET_SURFACE_TYPE
VOID_DETECT
TARG_SX
TARG_SY
TARG_SZ
TARG_EX
TARG_EY
TARG_EZ
PATTERN_TYPE
TARGET_EDGE_ANGLE
PROGRAM_GAGE_FEAT_TYPE
PROGRAM_GAGE_TYPE
TARGET_FOCUS
RMEASFEATIDX
RMEASFEATIDY
RMEASFEATIDZ
FINDNOMS_BESTFIT
FINDNOMS_ONLYSELECTED
TEMPX
TEMPY
TEMPZ
TEMPP
AUTO_PH9
MANUAL_PREPOSITION
SCREEN_CAPTURE_TYPE
SCREEN_CAPTURE_AUTO_TYPE
TARGET_EDGE_EDGESELECT
TARGET_EDGE_EDGENUM
DELETE_TYPE
SCREEN_CAPTURE_AUTO_TIME
USE_HSSDAT
USE_STARTENDDELAY
COP_FILTER
COP_SIZE
COP_TYPE
SURFVEC_MEAS_I
SURFVEC_MEAS_J
SURFVEC_MEAS_K
TARGET_EDGE_UNDERSCAN
PROFILE_TYPE
THEO_FLUSH
MEAS_FLUSH
THEO_GAP
MEAS_GAP
THEO_DEPTH
MEAS_DEPTH
TARGET_BLOB_TYPE
LASER_STRIPE_OVERLAP
LASER_STRIPE_OVERSCAN
LASER_FREQUENCY
TARGET_FILTER_OUTLIER
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD
SLOT_TYPE
TARGET_TYPE
THEO_R
THEO_A
THEO_H
MEAS_R
MEAS_A
MEAS_H
TARG_R
TARG_A
TARG_H
THEO_SR
THEO_SA
THEO_SH
THEO_ER
THEO_EA
THEO_EH
MEAS_SR
MEAS_SA
MEAS_SH
MEAS_ER
MEAS_EA
MEAS_EH
TARG_SR
TARG_SA
TARG_SH
TARG_ER
TARG_EA
TARG_EH
TARGET_EDGE_SENSILIGHT
F_THICKNESS_EDGE
THICKNESS_TYPE_EDGE
LASER_EXPOSURE
LASER_INTENSITY
ANGLE_OFFSET_2
LASER_FILTER_NEIGHBOR_NUM
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD
LASER_FILTER_TOL_ABOVE
LASER_FILTER_TOL_BELOW
LASER_FILTER_TOL_RIGHT
LASER_CLIP_UP_DIST
LASER_CLIP_LOW_DIST
LASER_PIXEL_TOGGLE
LASER_FILTER_TOGGLE
DISPLAY_PROBE_PARAMETERS
THEO_R2
THEO_A2
THEO_H2
MEAS_R2
MEAS_A2
MEAS_H2
LASER_CLIP_LEFT_DIST
LASER_CLIP_RIGHT_DIST
COP_FILETYPE
COP_SELECTIONTYPE
COP_COLORMAP
COP_COPLEMENT
OPERTYPE
COP_BOOLEANTYPE
COP_IMPORTFILETYPE
MEAS_START_ANG
MEAS_END_ANG
ISLAND_DIAM
ISLAND_LENGTH
ISLAND_WIDTH
ISLAND_X
ISLAND_Y
ISLAND_Z
ISLAND_I
ISLAND_J
ISLAND_K
ISLAND_AI
ISLAND_AJ
ISLAND_AK
ISLAND_TYPE
ISLAND_CLEARANCEDIST
RPT_DIMENSION_TABLES
SUMMARY_DEV
DRF_TBLHDR
LINE1_TBLHDR
LINE1_CALLOUT
LINE1_COLUMN_HDR
LINE1_FEATNAME
LINE1_NOMINAL
LINE1_MEAS
LINE1_PLUSTOL
LINE1_MINUSTOL
LINE1_DEV
LINE1_DEVPERCENT
LINE1_ISBILATERAL
LINE1_NUMZONES
LINE2_TBLHDR
LINE2_CALLOUT
LINE2_COLUMN_HDR
LINE2_FEATNAME
LINE2_BONUS
LINE2_TOL
LINE2_DATUMSHFT
LINE2_UNUSEDZONE
LINE2_DEV
LINE2_DEVANG
LINE2_DEVPERCENT
LINE3_TBLHDR
LINE3_CALLOUT
LINE3_COLUMN_HDR
LINE3_FEATNAME
LINE3_BONUS
LINE3_TOL
LINE3_DATUMSHFT
LINE3_UNUSEDZONE
LINE3_DEV
LINE3_DEVANG
LINE3_DEVPERCENT
DRF_COLUMN_HDR
DRF_SEGNAME
DRF_SHIFTX
DRF_SHIFTY
DRF_SHIFTZ
DRF_ROTATIONX
DRF_ROTATIONY
DRF_ROTATIONZ
SUMMARY_COLUMN_HDR
SUMMARY_FEAT
LINE2_AXIS
LINE2_NOMINAL
LINE2_MEAS
SUMMARY_TBLHDR
SUMMARY_AXIS
SUMMARY_NOMINAL
SUMMARY_MEAS
LINE2_PLUSTOL
LINE2_MINUSTOL
LINE2_MAX
LINE2_MIN
LINE2_ISBILATERAL
LINE2_NUMZONES
LINE3_ISBILATERAL
LINE3_NUMZONES
DIM_RPT_COLUMN_HDR
DIM_RPT_ISDATUM
DIM_RPT_DATUM
DIM_RPT_GRAPHIC
DIM_RPT_DEVPERCENT
DIM_RPT_ISBILATERAL
DIM_RPT_NUMZONES
GDT_SYMBOL
COMMENT_INPUT
TARGET_EDGE_WIDTH
TARGET_EDGE_HEIGHT
TARGET_EDGE_EDGEDETECT
TARGET_EDGE_FILTER_CLEAN
TARGET_EDGE_FILTER_CLEAN_STRENGTH
TARGET_EDGE_FILTER_AREA
TARGET_EDGE_FILTER_AREA_SIZE
TARGET_EDGE_GRADIENT
THEO_PERIMETER
MEAS_PERIMETER
THEO_AREA
MEAS_AREA
TARGET_SURFACE_CROSSHAIR_HEIGHT
SHOW_NOMS
COMPOSITE
DATUM2
TP_MODIFIER2
DESCRIPTION2
SHOW_OPTIONS
LEADER_LINE_ID
GDT_SYMBOL2
DATUM1_MODIFIER
DATUM2_MODIFIER
DATUM3_MODIFIER
DATUM1_MODIFIER2
DATUM2_MODIFIER2
DATUM3_MODIFIER2
DIM_RPT_DEVPERCENT_NOM
DIM_RPT_USETWODEVIATIONS
DIM_RPT_DEVPERCENT2
LINE2_DEVPERCENT_NOM
LINE2_USE2DEVIATIONS
LINE2_DEVPERCENT2
LINE3_DEVPERCENT_NOM
LINE3_USE2DEVIATIONS
LINE3_DEVPERCENT2
AXIS_PLUS_TOL
AXIS_MINUS_TOL
AXIS_NOMINAL
AXIS_DESCRIPTION
LINE1_DEVPERCENT_NOM
LINE1_USE2DEVIATIONS
LINE1_DEVPERCENT2
USE_AXIS2
DIM_LENGTH2
TEXTANAL_LABEL_MEAS_X
TEXTANAL_LABEL_MEAS_Y
TEXTANAL_LABEL_MEAS_Z
TEXTANAL_LABEL_MEAS_I
TEXTANAL_LABEL_MEAS_J
TEXTANAL_LABEL_MEAS_K
TEXTANAL_LABEL_DEV
TEXTANAL_LABEL_MINMAX
SIMULT_EVAL
SECTION_INDEX
LINE1_OUTTOL
LINE2_OUTTOL
LINE3_OUTTOL
LINE1_MAX
LINE1_MIN
LINE3_NOMINAL
LINE3_MEAS
LINE3_PLUSTOL
LINE3_MINUSTOL
LINE3_MAX
LINE3_MIN
SUMMARY_OUTTOL
SUMMARY_PLUSTOL
SUMMARY_MINUSTOL
SUMMARY_MAX
SUMMARY_MIN
SUMMARY_BONUS
LINE1_BONUS
GRAPH_ANALYSIS_POINT_SIZE
GRAPH_ANALYSIS_PLUS_TOL
GRAPH_ANALYSIS_MINUS_TOL
DIM_AXIS_ITEM_NUMBER
F_ENDING_DEPTH
DIM_ITEM_NUMBER
FEAT_ITEM_NUMBER
COMMAND_TYPE
DEV_MAX
AUTO_DEV_DIRECTION
PROBE_DIRECTION
USER_DEFINED_THEOS
SCALING
USE_SCALING
UID
REF_UID
BA_SOLUTION_TYPE
BA_SOLUTION_OPTIONS
BA_SOLUTION_STATUS
BA_VARIANCE
BA_RMS
BA_WARNINGS
BA_STATION
BA_STATION_X
BA_STATION_Y
BA_STATION_Z
BA_STATION_ROTX
BA_STATION_ROTY
BA_STATION_ROTZ
BA_STATION_ORIENTED
BA_STATION_LOCKED
BA_FEATURE
BA_FEAT_SOURCE
BA_FEAT_RMS
BA_FEAT_POINTING_ERR
BA_FEAT_APEX_ANGLE
BA_FEAT_X
BA_FEAT_Y
BA_FEAT_Z
BA_FEAT_DEV_X
BA_FEAT_DEV_Y
BA_FEAT_DEV_Z
BA_FEAT_DEV3D
NO_APPROACH_VECTOR_FLIP
TARGET_EDGE_START_VALUE
TARGET_EDGE_END_VALUE
TARGET_SURFACE_SURFACE_VARIANCE
RELATIVE_COMMENTS
AUTO_ROTARY
TARGET_COVERAGE
ROTATION_TYPE_2
PROBE_TYPE
TIME_STAMP
ECOND_TEMP
ECOND_PRESSURE
ECOND_HUMIDITY
HIT_RMS
DISPLAY_TRACKER_PARAMETERS
PTDENSITY_TOGGLE
PTDENSITY_UPPERBOUND
PTDENSITY_DEVLIMIT
PTDENSITY_MAXSPAN
TARGET_MEASURE_AT_FOV_CENTER
TARGET_SURFACE_FIND_SURFACE
PROJECTOR
INLINE_LEGACY_REPORT
SINGLE_POINT_DEVIATION
ENUM_FIELD_TYPES value specifying the DataType information object to return.

Return Type

DataType object.

See Also

DataTypes Object


Item Method

Item Method
Num
Long value specifying the data type information object.

Description

Returns the data type information object specified by number from the data type collection This returns the data type information object specified by the Num value from the data type collection.

Syntax

Visual Basic
Public Function Item( _
   ByVal Num As Long _
) As DataType

Parameters

Num
Long value specifying the data type information object.

Return Type

DataType object.

See Also

DataTypes Object


Application Property

Application Property

Description

Read Only: Returns the Application Object This returns the Application object. Read only.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

DataTypes Object


Count Property

Count Property

Description

Read Only: Returns the number of data type information objects in the data type collection This returns the number of data type information objects in the data type collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

Return Type

Read only Long.

See Also

DataTypes Object


Parent Property

Parent Property

Description

Read Only: Returns the Parent Command Object This returns the Parent Command object. Read only.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Command

Return Type

Command object.

See Also

DataTypes Object


DimData Object

DimData Object
See Also Members

Description

Dimension data object

The DimData object is similar to a type defined in the Example below. You can use it to pass dimension information in automation functions that accept that type.

Example

Type DimData
Bonus as Double
Dev as Double
DevAngle as Double
Max as Double
Meas as Double
Min as Double
Minus as Double
Out as Double
Nom as Double
Plus as Double
End Type

See Also

DimData Members


DimData Object Members

DimData ObjectMembers
See Also Overview

Public Properties

Public Property _Dev |
Public Property Bonus | Read/Write: Returns/Sets the Bonus value of the dimension data object Represents the Bonus member of this object.
Public Property Dev | Read/Write: Returns/Sets the Dev value of the dimension data object Represents the Dev member of this object.
Public Property DevAngle | Read/Write: Returns/Sets the DevAngle value of the dimension data object Represents the DevAngle member of this object.
Public Property Max | Read/Write: Returns/Sets the Max value of the dimension data object Represents the Max member of this object.
Public Property Meas | Read/Write: Returns/Sets the Meas value of the dimension data object Represents the Meas member of this object.
Public Property Min | Read/Write: Returns/Sets the Min value of the dimension data object Represents the Min member of this object.
Public Property Minus | Read/Write: Returns/Sets the Minus value of the dimension data object Represents the Minus member of this object.
Public Property nom | Read/Write: Returns/Sets the Nom value of the dimension data object Represents the Nom member of this object.
Public Property Out | Read/Write: Returns/Sets the Out value of the dimension data object Represents the Out member of this object.
Public Property Plus | Read/Write: Returns/Sets the Plus value of the dimension data object Represents the Plus member of this object.

See Also

DimData Overview


_Dev Property

_Dev Property

Property type

Read-write property

Syntax

Visual Basic
Public Property _Dev() As Double

See Also

DimData Object


Bonus Property

Bonus Property

Description

Read/Write: Returns/Sets the Bonus value of the dimension data object

Represents the Bonus member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Bonus() As Double

Return Type

Read/write Double.

See Also

DimData Object


Dev Property

Dev Property

Description

Read/Write: Returns/Sets the Dev value of the dimension data object

Represents the Dev member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Dev() As Double

Return Type

Read/write Double.

Remarks

The Dev member is the default property.

See Also

DimData Object


DevAngle Property

DevAngle Property

Description

Read/Write: Returns/Sets the DevAngle value of the dimension data object Represents the DevAngle member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property DevAngle() As Double

Return Type

Read/write Double.

See Also

DimData Object


Max Property

Max Property

Description

Read/Write: Returns/Sets the Max value of the dimension data object

Represents the Max member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Max() As Double

Return Type

Read/write Double.

See Also

DimData Object


Meas Property

Meas Property

Description

Read/Write: Returns/Sets the Meas value of the dimension data object

Represents the Meas member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Meas() As Double

Return Type

Read/write Double.

See Also

DimData Object


Min Property

Min Property

Description

Read/Write: Returns/Sets the Min value of the dimension data object

Represents the Min member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Min() As Double

Return Type

Read/write Double.

See Also

DimData Object


Minus Property

Minus Property

Description

Read/Write: Returns/Sets the Minus value of the dimension data object

Represents the Minus member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Minus() As Double

Return Type

Read/write Double.

See Also

DimData Object


nom Property

nom Property

Description

Read/Write: Returns/Sets the Nom value of the dimension data object

Represents the Nom member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property nom() As Double

Return Type

Read/write Double.

See Also

DimData Object


Out Property

Out Property

Description

Read/Write: Returns/Sets the Out value of the dimension data object

Represents the Out member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Out() As Double

Return Type

Read/write Double.

See Also

DimData Object


Plus Property

Plus Property

Description

Read/Write: Returns/Sets the Plus value of the dimension data object

Represents the Plus member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Plus() As Double

Return Type

Read/write Double.

See Also

DimData Object


DimensionCmd Object

DimensionCmd Object
See Also Members

Description

Dimension Command Object DimensionCmd objects are created from more generic Command objects to pass information specific to the dimension command back and forth.

Object Model

See Also

DimensionCmd Members


DimensionCmd Object Members

DimensionCmd ObjectMembers
See Also Overview

Public Methods

Public Method AddAxes | Add default location axes for End Location command
Public Method Evaluate | Evaluates the dimension Evaluates a dimension’s data from its feature data.

Public Properties

Public Property Angle | Read/Write: Angle value for angularity dimensions Represents the theoretical angle of a DIMENSION_ANGULARITY dimension.
Public Property ArrowMultiplier | Read/Write: Returns/Sets arrow multiplier Multiplier for display arrows of dimension.
Public Property AXIS | Read/Write: Returns/Sets axis value Axis used with dimension. Possible values include the following: DIMAXIS_NONE DIMAXIS_XAXIS DIMAXIS_YAXIS DIMAXIS_ZAXIS
Public Property AxisLetter | Read Only: Dimension axis letter used to identify dimension type Axis letter used to describe the axis or type of the dimension.
Public Property Bonus | Read Only: Bonus value for true position dimensions Returns the bonus tolerance of a true position dimension.
Public Property Datum1 | Read/Write: First datum feature
Public Property Datum1Modifier | Read/Write: First datum material condition
Public Property DATUM2 | Read/Write: Second datum feature
Public Property Datum2Modifier | Read/Write: Second datum material condition
Public Property Datum3 | Read/Write: Third datum feature
Public Property Datum3Modifier | Read/Write: Third datum material condition
Public Property DevAngle | Read Only: Deviation Angle Value Returns the deviation angle of a dimension.
Public Property Deviation | Read Only: Deviation Value Returns the deviation of a dimension.
Public Property DimensionModifier | Read/Write: Dimension material condition
Public Property Feat1 | Read/Write: First Reference feature/datum Returns the ID of the first feature associated with a dimension.
Public Property Feat2 | Read/Write: Second Reference feature/datum Returns the ID of the second feature associated with a dimension.
Public Property Feat3 | Read/Write: Third Reference feature/datum Returns the ID of the second feature associated with a dimension.
Public Property GraphicalAnalysis | Read/Write: Returns/Sets graphical analysis value Flag indicating whether graphical analysis is ON for the dimension.
Public Property ID | Read/Write: Dimesion ID Returns the ID of a dimension.
Public Property IsLocationAxis | Read Only: Returns the setting used to identify if the axis belongs to a Location Dimension Determines whether or not the axis is a Location axis.
Public Property IsTruePosAxis | Read Only: Returns the setting used to identify if the axis belongs to a True Position Dimension Determines whether or not the axis is a Location axis.
Public Property Length | Read/Write: Reference Length Value Returns the length associated with a dimension.
Public Property Max | Read Only: Dimension Max Value Returns the maximum value of a dimension.
Public Property Measured | Read Only: Dimension Measured Value Returns the measured value of a dimension.
Public Property Min | Read Only: Dimension Min Value Returns the minimum value of a dimension.
Public Property Minus | Read/Write: Minus Tolerance Value Represents the negative tolerance of a dimension.
Public Property NOMINAL | Read/Write: Dimension Nominal Value Returns the nominal associated with a dimension.
Public Property OutputMode | Read/Write: Returns/Sets dimension output mode Output mode of the dimension. Possible values include the following: DIMOUTPUT_STATS DIMOUTPUT_REPORT DIMOUTPUT_BOTH
Public Property OutTol | Read Only: Out of Tolerance Value Returns the out-of-tolerance value of a dimension.
Public Property ParallelPerpendicular | Read/Write: Parallel/Perpendicular value for 2d Dimensions Indicates whether calculations are performed parallel or perpendicular to input for 2-D dimensions. Possible values include the following: DIM_PERPINDICULAR DIM_PARALLEL
Public Property Parent | Read Only: Returns Parent Command Object
Public Property Plus | Read/Write: Plus Tolerance Value Returns the positive tolerance of a dimension. Read-only Double.
Public Property Profile | Read/Write: Form/Location Setting for Profile Dimensions This represents an enumerated value indicating what type of profile should be used. Possible values include the following: DIM_PROF_FORM_ONLY DIM_PROF_FORM_AND_LOCATION
Public Property RadiusType | Read/Write: Radius Setting for True Position Dimensions Radius calculation type used with true position dimensions. Possible values include the following: DIM_NO_RADIUS DIM_ADD_RADIUS DIM_SUB_RADIUS
Public Property TextualAnalysis | Read/Write: Returns/Sets textual analysis value Flag indicating whether textual analysis is ON for the dimension.
Public Property TruePositionDatumModifier | Read/Write: True position material condition
Public Property TruePositionModifier | Read/Write: True position modifier Enumeration value indicating material conditions that should be used to calculate possible bonus tolerances. Possible values include the following: DIM_RFS_RFS DIM_RFS_MMC DIM_RFS_LMC DIM_MMC_RFS DIM_MMC_MMC DIM_MMC_LMC DIM_LMC_RFS DIM_LMC_MMC DIM_LMC_LMC
Public Property TruePosUseAxis | Read/Write: Use Axis setting for True Position Dimensions Enumeration value indicating axis type to use with true position dimension. Possible values include the following: DIM_AXIS_AVERAGE DIM_AXIS_START_POINT DIM_AXIS_END_POINT
Public Property Units | Read/Write: Dimension Units Unit type in use by dimension. Possible values include the following: INCH MM (for millimeters)

See Also

DimensionCmd Overview


AddAxes Method

AddAxes Method

Description

Add default location axes for End Location command

Syntax

Visual Basic
Public Sub AddAxes()

See Also

DimensionCmd Object


Evaluate Method

Evaluate Method

Description

Evaluates the dimension Evaluates a dimension’s data from its feature data.

Syntax

Visual Basic
Public Sub Evaluate()

Return Type

Boolean value indicating success or failure in evaluating the dimension.

Remarks

Some dimension commands exist as command blocks inside of PC-DMIS. Because of this, the Evaluate method only works on a command block if you call the method from the very first item of the block. Calls made from other items of a dimension’s command block won’t function.

See Also

DimensionCmd Object


Angle Property

Angle Property

Description

Read/Write: Angle value for angularity dimensions Represents the theoretical angle of a DIMENSION_ANGULARITY dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property Angle() As Double

Return Type

Read/write Double.

Remarks

This function only works for objects of type DIMENSION_ANGULARITY. If used on any other object type, setting this variable will do nothing, and getting this variable will return zero.

See Also

DimensionCmd Object


ArrowMultiplier Property

ArrowMultiplier Property

Description

Read/Write: Returns/Sets arrow multiplier

Multiplier for display arrows of dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property ArrowMultiplier() As Double

Remarks

Read/write Double.

See Also

DimensionCmd Object


AXIS Property

AXIS Property

Description

Read/Write: Returns/Sets axis value

Axis used with dimension. Possible values include the following:

DIMAXIS_NONE

DIMAXIS_XAXIS

DIMAXIS_YAXIS

DIMAXIS_ZAXIS

Property type

Read-write property

Syntax

Visual Basic
Public Property AXIS() As ENUM_DIM_AXISTYPE

Return Type

Read/write Enum_Dim_AxisType Enumeration.

Remarks

This function only works with dimensions that can accept an axis as one of the inputs.

See Also

DimensionCmd Object


AxisLetter Property

AxisLetter Property

Description

Read Only: Dimension axis letter used to identify dimension type

Axis letter used to describe the axis or type of the dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property AxisLetter() As String

Return Type

Read-only String.

See Also

DimensionCmd Object


Bonus Property

Bonus Property

Description

Read Only: Bonus value for true position dimensions Returns the bonus tolerance of a true position dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property Bonus() As Double

Return Type

Read-only Double.

Remarks

This function only works for single true position objects, i.e., DIMENSION_TRUE_Z_LOCATION, but not DIMENSION_TRUE_START_POSITION or DIMENSION_TRUE_END_POSITION. If used on any other object type, getting this variable will return zero.

See Also

DimensionCmd Object


Datum1 Property

Datum1 Property

Description

Read/Write: First datum feature

Property type

Read-write property

Syntax

Visual Basic
Public Property Datum1() As String

See Also

DimensionCmd Object


Datum1Modifier Property

Datum1Modifier Property

Description

Read/Write: First datum material condition

Property type

Read-write property

Syntax

Visual Basic
Public Property Datum1Modifier() As ENUM_DIM_TP_MATERIAL_CONDITION

See Also

DimensionCmd Object


DATUM2 Property

DATUM2 Property

Description

Read/Write: Second datum feature

Property type

Read-write property

Syntax

Visual Basic
Public Property DATUM2() As String

See Also

DimensionCmd Object


Datum2Modifier Property

Datum2Modifier Property

Description

Read/Write: Second datum material condition

Property type

Read-write property

Syntax

Visual Basic
Public Property Datum2Modifier() As ENUM_DIM_TP_MATERIAL_CONDITION

See Also

DimensionCmd Object


Datum3 Property

Datum3 Property

Description

Read/Write: Third datum feature

Property type

Read-write property

Syntax

Visual Basic
Public Property Datum3() As String

See Also

DimensionCmd Object


Datum3Modifier Property

Datum3Modifier Property

Description

Read/Write: Third datum material condition

Property type

Read-write property

Syntax

Visual Basic
Public Property Datum3Modifier() As ENUM_DIM_TP_MATERIAL_CONDITION

See Also

DimensionCmd Object


DevAngle Property

DevAngle Property

Description

Read Only: Deviation Angle Value

Returns the deviation angle of a dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property DevAngle() As Double

Return Type

Read/write Double.

See Also

DimensionCmd Object


Deviation Property

Deviation Property

Description

Read Only: Deviation Value

Returns the deviation of a dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property Deviation() As Double

Return Type

Read/write Double.

See Also

DimensionCmd Object


DimensionModifier Property

DimensionModifier Property

Description

Read/Write: Dimension material condition

Property type

Read-write property

Syntax

Visual Basic
Public Property DimensionModifier() As ENUM_DIM_TP_MATERIAL_CONDITION

See Also

DimensionCmd Object


Feat1 Property

Feat1 Property

Description

Read/Write: First Reference feature/datum Returns the ID of the first feature associated with a dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property Feat1() As String

Return Type

Read/write String.

Remarks

For location and true position dimensions, only the start object has an associated feature. For single location or true position object, i.e., DIMENSION_TRUE_Z_LOCATION or DIMENSION_Y_LOCATION, setting the Feat1 property has no effect and getting it returns the empty string. Also, objects of type DIMENSION_KEYIN have no associated features.

See Also

DimensionCmd Object


Feat2 Property

Feat2 Property

Description

Read/Write: Second Reference feature/datum Returns the ID of the second feature associated with a dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property Feat2() As String

Return Type

Read/write String.

Remarks

Not every dimension type has two features associated with it. Trying to set the Feat2 property of one of these types has no effect, and getting it returns the empty string.

See Also

DimensionCmd Object


Feat3 Property

Feat3 Property

Description

Read/Write: Third Reference feature/datum Returns the ID of the second feature associated with a dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property Feat3() As String

Return Type

Read/write String.

Remarks

Not every dimension type has three features associated with it. Trying to set the Feat3 property of one of these types has no effect, and getting it returns the empty string.

See Also

DimensionCmd Object


GraphicalAnalysis Property

GraphicalAnalysis Property

Description

Read/Write: Returns/Sets graphical analysis value

Flag indicating whether graphical analysis is ON for the dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property GraphicalAnalysis() As Boolean

Return Type

Read/write Boolean.

See Also

DimensionCmd Object


ID Property

ID Property

Description

Read/Write: Dimesion ID Returns the ID of a dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As String

Return Type

Read/write String.

Remarks

For location and true position dimensions, only the start object has an id. For single location or true position object, i.e., DIMENSION_TRUE_Z_LOCATION or DIMENSION_Y_LOCATION, setting the ID property has no afffect and getting it returns the empty string.

See Also

DimensionCmd Object


IsLocationAxis Property

IsLocationAxis Property

Description

Read Only: Returns the setting used to identify if the axis belongs to a Location Dimension Determines whether or not the axis is a Location axis.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsLocationAxis() As Boolean

Return Type

Boolean value. Returns true if the axis is a Location axis; it returns false if it isn't.

See Also

DimensionCmd Object


IsTruePosAxis Property

IsTruePosAxis Property

Description

Read Only: Returns the setting used to identify if the axis belongs to a True Position Dimension Determines whether or not the axis is a Location axis.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsTruePosAxis() As Boolean

Return Type

Boolean value. Returns true if the axis is a True Position axis; it returns false if it isn't.

See Also

DimensionCmd Object


Length Property

Length Property

Description

Read/Write: Reference Length Value Returns the length associated with a dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property Length() As Double

Return Type

Read/write Double.

See Also

DimensionCmd Object


Max Property

Max Property

Description

Read Only: Dimension Max Value

Returns the maximum value of a dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property Max() As Double

Return Type

Read-only Double.

See Also

DimensionCmd Object


Measured Property

Measured Property

Description

Read Only: Dimension Measured Value

Returns the measured value of a dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property Measured() As Double

Return Type

Read-only Double.

See Also

DimensionCmd Object


Min Property

Min Property

Description

Read Only: Dimension Min Value

Returns the minimum value of a dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property Min() As Double

Return Type

Read-only Double.

See Also

DimensionCmd Object


Minus Property

Minus Property

Description

Read/Write: Minus Tolerance Value

Represents the negative tolerance of a dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property Minus() As Double

Return Type

Read/write Double.

See Also

DimensionCmd Object


NOMINAL Property

NOMINAL Property

Description

Read/Write: Dimension Nominal Value Returns the nominal associated with a dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property NOMINAL() As Double

Return Type

Read/write Double.

Remarks

Only object of type DIMENSION_START_LOCATION, DIMENSION_TRUE_START_POSITION do not have a useful nominal property. For these types, setting the property has no effect, and getting it always returns zero.

See Also

DimensionCmd Object


OutputMode Property

OutputMode Property

Description

Read/Write: Returns/Sets dimension output mode

Output mode of the dimension.

Possible values include the following:

DIMOUTPUT_STATS

DIMOUTPUT_REPORT

DIMOUTPUT_BOTH

Property type

Read-write property

Syntax

Visual Basic
Public Property OutputMode() As ENUM_DIM_OUTPUTTYPE

Return Type

Read/write Enum_Dim_OutputType Enumeration.

Remarks

The output mode determines where to send dimension data during execution.

See Also

DimensionCmd Object


OutTol Property

OutTol Property

Description

Read Only: Out of Tolerance Value

Returns the out-of-tolerance value of a dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property OutTol() As Double

Return Type

Read-only Double.

See Also

DimensionCmd Object


ParallelPerpendicular Property

ParallelPerpendicular Property

Description

Read/Write: Parallel/Perpendicular value for 2d Dimensions

Indicates whether calculations are performed parallel or perpendicular to input for 2-D dimensions.

Possible values include the following:

DIM_PERPINDICULAR

DIM_PARALLEL

Property type

Read-write property

Syntax

Visual Basic
Public Property ParallelPerpendicular() As ENUM_DIM_PERP_PARALLEL

Return Type

Read/Write Enum_Dim_Perp_Parallel Enumeration.

See Also

DimensionCmd Object


Parent Property

Parent Property

Description

Read Only: Returns Parent Command Object

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Command

Return Type

The parent of a DimensionCmd object is the same underlying PC-DMIS object as the DimensionCmd object itself. Getting the parent allows you to access the generic Command properties and methods of a given object.

See Also

DimensionCmd Object


Plus Property

Plus Property

Description

Read/Write: Plus Tolerance Value

Returns the positive tolerance of a dimension. Read-only Double.

Property type

Read-write property

Syntax

Visual Basic
Public Property Plus() As Double

See Also

DimensionCmd Object


Profile Property

Profile Property

Description

Read/Write: Form/Location Setting for Profile Dimensions

This represents an enumerated value indicating what type of profile should be used.

Possible values include the following:

DIM_PROF_FORM_ONLY

DIM_PROF_FORM_AND_LOCATION

Property type

Read-write property

Syntax

Visual Basic
Public Property Profile() As ENUM_DIM_PROF_TYPE

Return Type

Read/write Enum_Dim_Prof_Type Enumeration.

See Also

DimensionCmd Object


RadiusType Property

RadiusType Property

Description

Read/Write: Radius Setting for True Position Dimensions

Radius calculation type used with true position dimensions.

Possible values include the following:

DIM_NO_RADIUS

DIM_ADD_RADIUS

DIM_SUB_RADIUS

Property type

Read-write property

Syntax

Visual Basic
Public Property RadiusType() As ENUM_DIM_RADIUS_TYPE

Return Type

Read/write Enum_Dim_Radius_Type Enumeration.

See Also

DimensionCmd Object


TextualAnalysis Property

TextualAnalysis Property

Description

Read/Write: Returns/Sets textual analysis value

Flag indicating whether textual analysis is ON for the dimension.

Property type

Read-write property

Syntax

Visual Basic
Public Property TextualAnalysis() As Boolean

Return Type

Read/write Boolean.

See Also

DimensionCmd Object


TruePositionDatumModifier Property

TruePositionDatumModifier Property

Description

Read/Write: True position material condition

Property type

Read-write property

Syntax

Visual Basic
Public Property TruePositionDatumModifier() As ENUM_DIM_TP_MATERIAL_CONDITION

See Also

DimensionCmd Object


TruePositionModifier Property

TruePositionModifier Property

Description

Read/Write: True position modifier

Enumeration value indicating material conditions that should be used to calculate possible bonus tolerances.

Possible values include the following:

DIM_RFS_RFS

DIM_RFS_MMC

DIM_RFS_LMC

DIM_MMC_RFS

DIM_MMC_MMC

DIM_MMC_LMC

DIM_LMC_RFS

DIM_LMC_MMC

DIM_LMC_LMC

Property type

Read-write property

Syntax

Visual Basic
Public Property TruePositionModifier() As ENUM_DIM_TP_MODIFIER

Return Type

Read/write Enum_Dim_TP_Modifier Enumeration.

See Also

DimensionCmd Object


TruePosUseAxis Property

TruePosUseAxis Property

Description

Read/Write: Use Axis setting for True Position Dimensions

Enumeration value indicating axis type to use with true position dimension.

Possible values include the following:

DIM_AXIS_AVERAGE

DIM_AXIS_START_POINT

DIM_AXIS_END_POINT

Property type

Read-write property

Syntax

Visual Basic
Public Property TruePosUseAxis() As ENUM_DIM_TP_USE_AXIS

Return Type

Read/write Enum_Dim_TP_Use_Axis Enumeration.

Remarks

See Also

DimensionCmd Object


Units Property

Units Property

Description

Read/Write: Dimension Units

Unit type in use by dimension. Possible values include the following:

INCH

MM (for millimeters)

Property type

Read-write property

Syntax

Visual Basic
Public Property Units() As UNITTYPE

Return Type

Read/write UnitType Enumeration.

See Also

DimensionCmd Object


DimFormat Object

DimFormat Object
See Also Members

Description

The DimFormat object gives access to the properties of the PC-DMIS Dimension Format command. For additional information on dimensions, see the topic "Dimension Options" in the PC-DMIS documentation.

See Also

DimFormat Members


DimFormat Object Members

DimFormat ObjectMembers
See Also Overview

Public Methods

Public Method GetHeadingType | Returns the indexed field type Returns the heading type for the dimension based on an index parameter.
Public Method SetHeadingType | Sets the indexed field type Sets the heading type for the dimension based on an index parameter.

Public Properties

Public Property ShowDevSymbols | Read/Write: Indicates whether deviation symbols are shown Determines whether or not the deviation symbols should be shown in the dimension report text.
Public Property ShowDimensionText | Read/Write: Indicates whether dimension text is shown or not Determines whether or not the top two lines of the dimension command should appear or not.
Public Property ShowDimensionTextOptions | Read/Write: Indicates whether various dimension options should be shown or not Determines whether or not various dimension items such as arrow multiplier, graphical analysis, and textual analysis should appear in the dimension text or not.
Public Property ShowHeadings | Read/Write: Indicates whether field headings are shown Determines whether or not the dimension headings (such as NOM, MAX, MIN, DEV, OUTTOL, and so on) should appear in the dimension text or not.
Public Property ShowStdDev | Read/Write: Indicates whether the standard deviation is shown Determines whether or not the standard deviation value should appear or not.

See Also

DimFormat Overview


GetHeadingType Method

GetHeadingType Method
index
Required Long representing which index position to retrieve.

Description

Returns the indexed field type Returns the heading type for the dimension based on an index parameter.

Syntax

Visual Basic
Public Function GetHeadingType( _
   ByVal index As Long _
) As DIMFORMATTYPE

Parameters

index
Required Long representing which index position to retrieve.

Return Type

DimFormatType enumeration value indicating the dimension information type of the position indicated by the index parameter.

Remarks

See Also

DimFormat Object


SetHeadingType Method

SetHeadingType Method
index
Required long indicating the index position that is being set.
HeadingType

Required DimFormatType enumeration representing the type of value to be used at the given index position.

Description

Sets the indexed field type Sets the heading type for the dimension based on an index parameter.

Syntax

Visual Basic
Public Function SetHeadingType( _
   ByVal index As Long, _
   ByVal HeadingType As DIMFORMATTYPE _
) As Boolean

Parameters

index
Required long indicating the index position that is being set.
HeadingType
Value Description
PCD_NOT_USED
PCD_NOM
PCD_TOL
PCD_MEAS
PCD_MAXMIN
PCD_DEV
PCD_OUTTOL
PCD_DEVANG

Required DimFormatType enumeration representing the type of value to be used at the given index position.

Return Type

Boolean value indicating success or failure in setting the heading type.

See Also

DimFormat Object


ShowDevSymbols Property

ShowDevSymbols Property

Description

Read/Write: Indicates whether deviation symbols are shown

Determines whether or not the deviation symbols should be shown in the dimension report text.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowDevSymbols() As Boolean

Return Type

Read/write Boolean.

See Also

DimFormat Object


ShowDimensionText Property

ShowDimensionText Property

Description

Read/Write: Indicates whether dimension text is shown or not Determines whether or not the top two lines of the dimension command should appear or not.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowDimensionText() As Boolean

Return Type

Read/write Boolean.

See Also

DimFormat Object


ShowDimensionTextOptions Property

ShowDimensionTextOptions Property

Description

Read/Write: Indicates whether various dimension options should be shown or not Determines whether or not various dimension items such as arrow multiplier, graphical analysis, and textual analysis should appear in the dimension text or not.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowDimensionTextOptions() As Boolean

Return Type

Read/write Boolean.

See Also

DimFormat Object


ShowHeadings Property

ShowHeadings Property

Description

Read/Write: Indicates whether field headings are shown Determines whether or not the dimension headings (such as NOM, MAX, MIN, DEV, OUTTOL, and so on) should appear in the dimension text or not.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowHeadings() As Boolean

Return Type

Read/write Boolean.

See Also

DimFormat Object


ShowStdDev Property

ShowStdDev Property

Description

Read/Write: Indicates whether the standard deviation is shown Determines whether or not the standard deviation value should appear or not.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowStdDev() As Boolean

Return Type

Read/write Boolean.

See Also

DimFormat Object


DimInfo Object

DimInfo Object
See Also Members

Description

The DimInfo object gives access to the properties and methods of the PC-DMIS Dimension Information command. See "DIMINFO Command" in the PC-DMIS documentation for additional information.

See Also

DimInfo Members


DimInfo Object Members

DimInfo ObjectMembers
See Also Overview

Public Methods

Public Method GetFieldFormat | Gets the indexed field format Returns the dimension information type of the position indicated by index.
Public Method GetLocationAxis | Gets the indexed axis location Returns the dimension location axis order used at the position indicated by the index parameter.
Public Method GetTruePosAxis | Gets the indexed true position location Gets the dimension true position axis order used at the position indicated by the index parameter.
Public Method SetFieldFormat | Sets the indexed field format Sets the format of the field.
Public Method SetLocationAxis | Sets the indexed axis location Sets a Location dimension's axis.
Public Method SetTruePosAxis | Sets the indexed true position location Sets a True Position dimension's axis.

Public Properties

Public Property DimensionId | Read/Write: Id of dimension being referenced by dimension information object Gets or sets the name of the dimension for which the dimension information object will be showing information.
Public Property ShowDimId | Read/Write: Indicates whether the dimension ID is shown Determines whether or not the Dimension ID should be shown in the dimension information object.
Public Property ShowFeatId | Read/Write: Indicates whether the feature ID is shown Determines whether or not PC-DMIS displays the feature id of the feature belonging to the dimension used in the dimension information command.

See Also

DimInfo Overview


GetFieldFormat Method

GetFieldFormat Method
index
Required Long representing which index position to retrieve.

Description

Gets the indexed field format Returns the dimension information type of the position indicated by index.

Syntax

Visual Basic
Public Function GetFieldFormat( _
   ByVal index As Long _
) As ENUM_DINFO_FIELD_TYPES

Parameters

index
Required Long representing which index position to retrieve.

Return Type

Enum_Dinfo_Field_Types enumeration value indicating the dimension information type of the position indicated by the index parameter.

See Also

DimInfo Object


GetLocationAxis Method

GetLocationAxis Method
index
Required Long representing which index position to retrieve.

Description

Gets the indexed axis location Returns the dimension location axis order used at the position indicated by the index parameter.

Syntax

Visual Basic
Public Function GetLocationAxis( _
   ByVal index As Long _
) As ENUM_DINFO_LOC_AXES

Parameters

index
Required Long representing which index position to retrieve.

Return Type

Enum_Dinfo_Loc_Axes enumeration value indicating the dimension location axis order used at the position indicated by the index parameter

Remarks

This function only works if the dimension being referenced in the command is an axis location dimension.

See Also

DimInfo Object


GetTruePosAxis Method

GetTruePosAxis Method
index
Required Long representing which index position to retrieve.

Description

Gets the indexed true position location Gets the dimension true position axis order used at the position indicated by the index parameter.

Syntax

Visual Basic
Public Function GetTruePosAxis( _
   ByVal index As Long _
) As ENUM_DINFO_TP_AXES

Parameters

index
Required Long representing which index position to retrieve.

Return Type

Enum_Dinfo_Tp_axes enumeration.

Remarks

This command only works with dimension information commands that are referencing true position dimensions.

See Also

DimInfo Object


SetFieldFormat Method

SetFieldFormat Method
index
Required long indicating the index position that is being set.
FieldType

Description

Sets the indexed field format Sets the format of the field.

Syntax

Visual Basic
Public Function SetFieldFormat( _
   ByVal index As Long, _
   ByVal FieldType As ENUM_DINFO_FIELD_TYPES _
) As Boolean

Parameters

index
Required long indicating the index position that is being set.
FieldType
Value Description
DINFO_NOT_USED
DINFO_MEAS
DINFO_NOM
DINFO_TOL
DINFO_DEV
DINFO_MAXMIN
DINFO_OUTTOL
DINFO_MEAN
DINFO_STDDEV
DINFO_NUMPOINTS

Return Type

Required Enum_Dinfo_Field_Types enumeration representing the type of value used at the given index position.

See Also

DimInfo Object


SetLocationAxis Method

SetLocationAxis Method
index
Required long indicating the index position that is being set.
AXIS
Required Enum_Dinfo_Loc_Axes enumeration representing the type the axis used at the given index position.

Description

Sets the indexed axis location

Sets a Location dimension's axis.

Syntax

Visual Basic
Public Function SetLocationAxis( _
   ByVal index As Long, _
   ByVal AXIS As ENUM_DINFO_LOC_AXES _
) As Boolean

Parameters

index
Required long indicating the index position that is being set.
AXIS
Value Description
DINFO_LOC_USE_DIM_AXES
DINFO_LOC_WORST
DINFO_LOC_NOT_USED
DINFO_LOC_X
DINFO_LOC_Y
DINFO_LOC_Z
DINFO_LOC_D
DINFO_LOC_R
DINFO_LOC_V
DINFO_LOC_A
DINFO_LOC_L
DINFO_LOC_H
DINFO_LOC_PR
DINFO_LOC_PA
DINFO_LOC_T
DINFO_LOC_RT
DINFO_LOC_S
DINFO_LOC_RS
DINFO_LOC_PD
Required Enum_Dinfo_Loc_Axes enumeration representing the type the axis used at the given index position.

Return Type

Boolean value indicating success or failure in setting the field type.

Remarks

The dimension needs to be a location dimension in order for this command to succeed.

See Also

DimInfo Object


SetTruePosAxis Method

SetTruePosAxis Method
index
Required Long value indicating the index position that is being set.
AXIS
Required Enum_Dinfo_TP_Axes enumeration representing the type the axis used at the given index position.

Description

Sets the indexed true position location

Sets a True Position dimension's axis.

Syntax

Visual Basic
Public Function SetTruePosAxis( _
   ByVal index As Long, _
   ByVal AXIS As ENUM_DINFO_TP_AXES _
) As Boolean

Parameters

index
Required Long value indicating the index position that is being set.
AXIS
Value Description
DINFO_TP_USE_DIM_AXES
DINFO_TP_WORST
DINFO_TP_NOT_USED
DINFO_TP_X
DINFO_TP_Y
DINFO_TP_Z
DINFO_TP_PR
DINFO_TP_PA
DINFO_TP_DD
DINFO_TP_LD
DINFO_TP_WD
DINFO_TP_DF
DINFO_TP_LF
DINFO_TP_WF
DINFO_TP_TP
Required Enum_Dinfo_TP_Axes enumeration representing the type the axis used at the given index position.

Return Type

Boolean value indicating success or failure in setting the field type.

See Also

DimInfo Object


DimensionId Property

DimensionId Property

Description

Read/Write: Id of dimension being referenced by dimension information object Gets or sets the name of the dimension for which the dimension information object will be showing information.

Property type

Read-write property

Syntax

Visual Basic
Public Property DimensionId() As String

Return Type

Read/write String.

See Also

DimInfo Object


ShowDimId Property

ShowDimId Property

Description

Read/Write: Indicates whether the dimension ID is shown Determines whether or not the Dimension ID should be shown in the dimension information object.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowDimId() As Boolean

Return Type

Read/write Boolean.

See Also

DimInfo Object


ShowFeatId Property

ShowFeatId Property

Description

Read/Write: Indicates whether the feature ID is shown Determines whether or not PC-DMIS displays the feature id of the feature belonging to the dimension used in the dimension information command.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowFeatId() As Boolean

Return Type

Read/write Boolean.

See Also

DimInfo Object


DispMetaFile Object

DispMetaFile Object
See Also Members

Description

The DispMetaFile object gives access to the comment properties of the PC-DMIS Display Metafile command.

See Also

DispMetaFile Members


DispMetaFile Object Members

DispMetaFile ObjectMembers
See Also Overview

Public Properties

Public Property Comment Read/Write: Comment for metafile

Gets or sets the value representing the comment to be used as a caption for the metafile object.

See Also

DispMetaFile Overview


Comment Property

Comment Property

Description

Read/Write: Comment for metafile

Gets or sets the value representing the comment to be used as a caption for the metafile object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Comment() As String

Return Type

Read/write String.

See Also

DispMetaFile Object


DmisDialog Object

DmisDialog Object
See Also Members

Description

The DmisDialog object represents a PC-DMIS modeless dialog and can be used to determine if the dialog is still visible.

Remarks

A DmisDialog object can be obtained from the Dialog2 method of the command automation object. This object has one property: visible.

If true, the dialog is still visible to the user. If false, the dialog either no longer exists or is no longer visible to the user.

See Also

DmisDialog Members


DmisDialog Object Members

DmisDialog ObjectMembers
See Also Overview

Public Properties

Public Property Visible Read Only: Indicates whether dialog is still visible to the user or not Indicates whether or not the dialog is still visible to the user.

See Also

DmisDialog Overview


Visible Property

Visible Property

Description

Read Only: Indicates whether dialog is still visible to the user or not Indicates whether or not the dialog is still visible to the user.

Property type

Read-write property

Syntax

Visual Basic
Public Property Visible() As Boolean

Return Type

Read-only Boolean value.

See Also

DmisDialog Object


DmisMatrix Object

DmisMatrix Object
See Also Members

Description

The DmisMatrix object is a four by three array of doubles modeled after the transformation matrices used in PC-DMIS. The first set of three doubles represent the matrix offset. The second set of three doubles represent the X axis. The third set of three doubles represent the Y axis. The fourth set of three doubles represent the Z axis.

Object Model

See Also

DmisMatrix Members


DmisMatrix Object Members

DmisMatrix ObjectMembers
See Also Overview

Public Methods

Public Method Item | Returns the individual data element of the matrix Returns the data item of the matrix.
Public Method Multiply | Returns a matrix which is the matrix multiplied by the supplied matrix Multiplies two matrices and returns the result as a DmisMatrix object.
Public Method Normalize | Normalizes the matrix Normalizes the matrix.
Public Method Reset | Resets the matrix to the identity matrix Resets the matrix to the identity matrix.
Public Method RotateByAngle | Rotates the primary axis by the supplied angle relative to the supplied workplane Rotates the matrix by the specified angle relative to the workplane.
Public Method RotateToPoint | Rotates the primary axis to the supplied point relative to the supplied workplane Rotates the matrix by the calculated angle relative to the workplane.
Public Method RotateToVector | Rotates the primary axis to the supplied vector relative to the supplied workplane Rotates the primary axis (as determined by the workplane parameter) to the specified vector.
Public Method SetMatrix | Sets the matrix orientation using the supplied vector and workplane. Sets the matrix offset using the supplied point. Initializes the matrix using the vector and workplane to set the matrix orientation and the point to set the matrix offset.
Public Method TransformDataBack | Multiplies the supplied data by the matrix
Public Method TransformDataForward | Multiplies the supplied data by the inverse of the matrix

Public Properties

Public Property _Copy |
Public Property Copy | Read Only: Returns a copy of the matrix to make assignment possible Returns a copy of the matrix.
Public Property Inverse | Read Only: Returns the inverse of the matrix in a new matrix. The original matrix remains constant Returns an inverse matrix of the current matrix.
Public Property IsIdentity | Read Only: Returns true if the matrix is the identity matrix Determines whether or not the matrix is the identity matrix.
Public Property Offset | Read/Write: Sets or gets the first triple set of doubles of the matrix The first set of three doubles in the matrix representing the translation offset of the matrix.
Public Property PrimaryAxis | Read/Write: Sets or gets the second triple set of doubles of the matrix The second set of three doubles in the matrix representing the matrix's primary axis.
Public Property SecondaryAxis | Read/Write: Sets or gets the third triple set of doubles of the matrix The third set of three doubles in the matrix representing the matrix's secondary axis.
Public Property TertiaryAxis | Read/Write: Sets or gets the fourth triple set of doubles of the matrix The fourth set of three doubles in the matrix representing the matrix's tertiary axis.

See Also

DmisMatrix Overview


Item Method

Item Method
Num
Required parameter of type long between 1 and 12 inclusive from which the matrix data is copied.

Description

Returns the individual data element of the matrix Returns the data item of the matrix.

Syntax

Visual Basic
Public Function Item( _
   ByVal Num As Long _
) As Double

Parameters

Num
Required parameter of type long between 1 and 12 inclusive from which the matrix data is copied.

Return Type

Double value.

See Also

DmisMatrix Object


Multiply Method

Multiply Method
SecondMatrix
Required parameter of type DmisMatrix representing the second matrix.

Description

Returns a matrix which is the matrix multiplied by the supplied matrix Multiplies two matrices and returns the result as a DmisMatrix object.

Syntax

Visual Basic
Public Function Multiply( _
   ByVal SecondMatrix As DmisMatrix _
) As DmisMatrix

Parameters

SecondMatrix
Required parameter of type DmisMatrix representing the second matrix.

Return Type

DmisMatrix object.

See Also

DmisMatrix Object


Normalize Method

Normalize Method

Description

Normalizes the matrix Normalizes the matrix.

Syntax

Visual Basic
Public Sub Normalize()

See Also

DmisMatrix Object


Reset Method

Reset Method

Description

Resets the matrix to the identity matrix Resets the matrix to the identity matrix.

Syntax

Visual Basic
Public Sub Reset()

See Also

DmisMatrix Object


RotateByAngle Method

RotateByAngle Method
Angle
Required Double parameter representing the rotation angle (in degrees).
Workplane
Optional parameter that uses the ENUM_PLANE_TYPE enumeration to define which axis to rotate about.

Description

Rotates the primary axis by the supplied angle relative to the supplied workplane

Rotates the matrix by the specified angle relative to the workplane.

Syntax

Visual Basic
Public Sub RotateByAngle( _
   ByVal Angle As Double, _
   ByVal Workplane As ENUM_PLANE_TYPE _
)

Parameters

Angle
Required Double parameter representing the rotation angle (in degrees).
Workplane
Value Description
PLANE_TOP
PLANE_RIGHT
PLANE_BACK
PLANE_BOTTOM
PLANE_LEFT
PLANE_FRONT
Optional parameter that uses the ENUM_PLANE_TYPE enumeration to define which axis to rotate about.

Return Type

Rotates the matrix by the specified angle relative to the workplane.

See Also

DmisMatrix Object


RotateToPoint Method

RotateToPoint Method
X
Required Double X component used in calculating rotation angle.
Y
Required Double Y component used in calculation rotation angle.
Workplane
Optional parameter with the ENUM_PLANE_TYPE enumeration used to define which axis to rotate about.

Description

Rotates the primary axis to the supplied point relative to the supplied workplane

Rotates the matrix by the calculated angle relative to the workplane.

Syntax

Visual Basic
Public Sub RotateToPoint( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Workplane As ENUM_PLANE_TYPE _
)

Parameters

X
Required Double X component used in calculating rotation angle.
Y
Required Double Y component used in calculation rotation angle.
Workplane
Value Description
PLANE_TOP
PLANE_RIGHT
PLANE_BACK
PLANE_BOTTOM
PLANE_LEFT
PLANE_FRONT
Optional parameter with the ENUM_PLANE_TYPE enumeration used to define which axis to rotate about.

See Also

DmisMatrix Object


RotateToVector Method

RotateToVector Method
Vector
Required Pointdata parameter specifying the vector that the primary axis should be rotated to.
Workplane
Optional parameter with the ENUM_PLANE_TYPE enumeration used to define which axis to rotate about.

Description

Rotates the primary axis to the supplied vector relative to the supplied workplane

Rotates the primary axis (as determined by the workplane parameter) to the specified vector.

Syntax

Visual Basic
Public Sub RotateToVector( _
   ByVal Vector As PointData, _
   ByVal Workplane As ENUM_PLANE_TYPE _
)

Parameters

Vector
Required Pointdata parameter specifying the vector that the primary axis should be rotated to.
Workplane
Value Description
PLANE_TOP
PLANE_RIGHT
PLANE_BACK
PLANE_BOTTOM
PLANE_LEFT
PLANE_FRONT
Optional parameter with the ENUM_PLANE_TYPE enumeration used to define which axis to rotate about.

See Also

DmisMatrix Object


SetMatrix Method

SetMatrix Method
Vector
Required Pointdata parameter used with the workplane parameter to establish the orientation of the matrix.
Point
Required Pointdata parameter used to set the matrix offset.
Workplane
Optional Long parameter used to define the direction of the primary axis.

Description

Sets the matrix orientation using the supplied vector and workplane. Sets the matrix offset using the supplied point.

Initializes the matrix using the vector and workplane to set the matrix orientation and the point to set the matrix offset.

Syntax

Visual Basic
Public Sub SetMatrix( _
   ByVal Vector As PointData, _
   ByVal Point As PointData, _
   ByVal Workplane As ENUM_PLANE_TYPE _
)

Parameters

Vector
Required Pointdata parameter used with the workplane parameter to establish the orientation of the matrix.
Point
Required Pointdata parameter used to set the matrix offset.
Workplane
Value Description
PLANE_TOP
PLANE_RIGHT
PLANE_BACK
PLANE_BOTTOM
PLANE_LEFT
PLANE_FRONT
Optional Long parameter used to define the direction of the primary axis.

See Also

DmisMatrix Object


TransformDataBack Method

TransformDataBack Method
PointData
Required PointData object parameter that is modified by multiplying the data in the point by the inverse of the matrix.
TransformationType
Optional ENUM_TRANSFORMATION_TYPES enumeration that identifies the type of transformation desired.
Workplane

Optional parameter with the ENUM_PLANE_TYPE enumeration used to define which axis to rotate about.

This parameter is used when the MAJOR_MINOR_THIRD_ROT_AND_TRANS parameter or the MAJOR_MINOR_THIRD_ROTATE_ONLY TransformationType parameter is used.

Description

Multiplies the supplied data by the matrix

Syntax

Visual Basic
Public Sub TransformDataBack( _
   ByVal PointData As PointData, _
   ByVal TransformationType As ENUM_TRANSFORMATION_TYPES, _
   ByVal Workplane As ENUM_PLANE_TYPE _
)

Parameters

PointData
Required PointData object parameter that is modified by multiplying the data in the point by the inverse of the matrix.
TransformationType
Value Description
ROTATE_AND_TRANSLATE
ROTATE_ONLY
MAJOR_MINOR_THIRD_ROT_AND_TRANS
MAJOR_MINOR_THIRD_ROTATE_ONLY
Optional ENUM_TRANSFORMATION_TYPES enumeration that identifies the type of transformation desired.
Workplane
Value Description
PLANE_TOP
PLANE_RIGHT
PLANE_BACK
PLANE_BOTTOM
PLANE_LEFT
PLANE_FRONT

Optional parameter with the ENUM_PLANE_TYPE enumeration used to define which axis to rotate about.

This parameter is used when the MAJOR_MINOR_THIRD_ROT_AND_TRANS parameter or the MAJOR_MINOR_THIRD_ROTATE_ONLY TransformationType parameter is used.

See Also

DmisMatrix Object


TransformDataForward Method

TransformDataForward Method
PointData
Required PointData object parameter that is modified by multiplying the data in the point by the matrix.
TransformationType
Optional Long parameter that identifies the type of transformation desired.
Workplane
Optional parameter with the ENUM_PLANE_TYPE enumeration used to define which axis to rotate about.

This parameter is used when the MAJOR_MINOR_THIRD_ROT_AND_TRANS parameter or the MAJOR_MINOR_THIRD_ROTATE_ONLY transformation type parameter is used.

Description

Multiplies the supplied data by the inverse of the matrix

Syntax

Visual Basic
Public Sub TransformDataForward( _
   ByVal PointData As PointData, _
   ByVal TransformationType As ENUM_TRANSFORMATION_TYPES, _
   ByVal Workplane As ENUM_PLANE_TYPE _
)

Parameters

PointData
Required PointData object parameter that is modified by multiplying the data in the point by the matrix.
TransformationType
Value Description
ROTATE_AND_TRANSLATE
ROTATE_ONLY
MAJOR_MINOR_THIRD_ROT_AND_TRANS
MAJOR_MINOR_THIRD_ROTATE_ONLY
Optional Long parameter that identifies the type of transformation desired.
Workplane
Value Description
PLANE_TOP
PLANE_RIGHT
PLANE_BACK
PLANE_BOTTOM
PLANE_LEFT
PLANE_FRONT
Optional parameter with the ENUM_PLANE_TYPE enumeration used to define which axis to rotate about.

This parameter is used when the MAJOR_MINOR_THIRD_ROT_AND_TRANS parameter or the MAJOR_MINOR_THIRD_ROTATE_ONLY transformation type parameter is used.

See Also

DmisMatrix Object


_Copy Property

_Copy Property

Property type

Read-write property

Syntax

Visual Basic
Public Property _Copy() As DmisMatrix

See Also

DmisMatrix Object


Copy Property

Copy Property

Description

Read Only: Returns a copy of the matrix to make assignment possible Returns a copy of the matrix.

Property type

Read-write property

Syntax

Visual Basic
Public Property Copy() As DmisMatrix

Return Type

Read-only DmisMatrix object.

See Also

DmisMatrix Object


Inverse Property

Inverse Property

Description

Read Only: Returns the inverse of the matrix in a new matrix. The original matrix remains constant Returns an inverse matrix of the current matrix.

Property type

Read-write property

Syntax

Visual Basic
Public Property Inverse() As DmisMatrix

Return Type

Read-only DmisMatrix object.

See Also

DmisMatrix Object


IsIdentity Property

IsIdentity Property

Description

Read Only: Returns true if the matrix is the identity matrix Determines whether or not the matrix is the identity matrix.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsIdentity() As Boolean

Return Type

Read-only Boolean.

See Also

DmisMatrix Object


Offset Property

Offset Property

Description

Read/Write: Sets or gets the first triple set of doubles of the matrix The first set of three doubles in the matrix representing the translation offset of the matrix.

Property type

Read-write property

Syntax

Visual Basic
Public Property Offset() As PointData

Return Type

Read/write PointData object.

See Also

DmisMatrix Object


PrimaryAxis Property

PrimaryAxis Property

Description

Read/Write: Sets or gets the second triple set of doubles of the matrix The second set of three doubles in the matrix representing the matrix's primary axis.

Property type

Read-write property

Syntax

Visual Basic
Public Property PrimaryAxis() As PointData

Return Type

Read/write PointData object.

See Also

DmisMatrix Object


SecondaryAxis Property

SecondaryAxis Property

Description

Read/Write: Sets or gets the third triple set of doubles of the matrix The third set of three doubles in the matrix representing the matrix's secondary axis.

Property type

Read-write property

Syntax

Visual Basic
Public Property SecondaryAxis() As PointData

Return Type

Read/write PointData object.

See Also

DmisMatrix Object


TertiaryAxis Property

TertiaryAxis Property

Description

Read/Write: Sets or gets the fourth triple set of doubles of the matrix The fourth set of three doubles in the matrix representing the matrix's tertiary axis.

Property type

Read-write property

Syntax

Visual Basic
Public Property TertiaryAxis() As PointData

Return Type

Read/write PointData object.

See Also

DmisMatrix Object


EditWindow Object

EditWindow Object
See Also Members

Description

Edit window object The EditWindow object represents the Edit window associated with a part program. It is always present, although sometimes it is invisible. When in Command mode, the Edit window lists all the commands in the part program.

Object Model

See Also

EditWindow Members


EditWindow Object Members

EditWindow ObjectMembers
See Also Overview

Public Methods

Public Method CommandMode | Switches edit window to command mode This function puts the Edit window into command mode.
Public Method DMISMode | Switches edit window to DMIS mode
Public Method GetCommandText | Gets current edit window text for specified command This function returns a string of the current command text for the specified command in Command.
Public Method LastExecutionReportMode | Switches edit window to last execution report mode
Public Method PrintEditWindow | Causes edit window to print current window contents
Public Method ReportMode | Switches edit window to report mode This function puts the Edit window into report mode.
Public Method SetDMISOutputOptions | Sets DMIS output options This function sets output options for printing the Edit window contents as a DMIS file.
Public Method SetPrintOptions | Sets edit window print options This function allows you to set Edit window print options.
Public Method SetPrintOptionsEx | Sets extended edit window print options This function allows you to set extended Edit window print options.
Public Method SummaryMode | Switches edit window to summary mode

Public Properties

Public Property _Visible |
Public Property Application | Read Only: Returns Application object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.
Public Property Height | Read/Write: Returns/Sets the height of the edit window The height of the edit window in screen pixels.
Public Property Left | Read/Write: Returns/Sets the left coordinate of the edit window The left edge of the edit window, measured from the left edge of the Windows Desktop.
Public Property Parent | Read Only: Returns Partprogram object Returns the parent PartProgram of this object.
Public Property ShowAlignments | Read/Write: Returns/Sets show alignments status of edit window This property is TRUE if alignments are being shown in the edit window, FALSE otherwise.
Public Property ShowComments | Read/Write: Returns/Sets show comments status of edit window This property is TRUE if comments are being shown in the edit window, FALSE otherwise.
Public Property ShowDimensions | Read/Write: Returns/Sets show dimensions status of edit window This property is TRUE if dimensions are being shown in the edit window, FALSE otherwise.
Public Property ShowFeatures | Read/Write: Returns/Sets show features status of edit window This property is TRUE if features are being shown in the edit window, FALSE otherwise.
Public Property ShowHeaderFooter | Read/Write: Returns/Sets show header/footer status of edit window This property is TRUE if headers and footers are being shown in the edit window, FALSE otherwise.
Public Property ShowHits | Read/Write: Returns/Sets show hits status of edit window This property is TRUE if hits are being shown in the edit window, FALSE otherwise.
Public Property ShowMoves | Read/Write: Returns/Sets show moves status of edit window This property is TRUE if moves are being shown in the edit window, FALSE otherwise.
Public Property ShowOutTolOnly | Read/Write: Returns/Sets show out of tolerance status of edit window This property is TRUE if only out-of-tolerance dimensions are being shown in the edit window, FALSE otherwise. If ShowDimensions is FALSE, this property is ignored.
Public Property ShowTips | Read/Write: Returns/Sets show tips status of edit window This property is TRUE if tips are being shown in the edit window, FALSE otherwise.
Public Property Top | Read/Write: Returns/Sets the top coordinate of the edit window The top edge of the edit window, measured from the top edge of the Windows Desktop.
Public Property Visible | Read/Write: Returns/Sets edit window visibility status This property is TRUE if the edit window is visible, FALSE otherwise.
Public Property Width | Read/Write: Returns/Sets the width of the edit window The width of the edit window in screen pixels.

See Also

EditWindow Overview


CommandMode Method

CommandMode Method

Description

Switches edit window to command mode

This function puts the Edit window into command mode.

Syntax

Visual Basic
Public Sub CommandMode()

See Also

EditWindow Object


DMISMode Method

DMISMode Method

Description

Switches edit window to DMIS mode

Syntax

Visual Basic
Public Sub DMISMode()

See Also

EditWindow Object


GetCommandText Method

GetCommandText Method
Command
Required expression that evaluates to a Command object.

Description

Gets current edit window text for specified command This function returns a string of the current command text for the specified command in Command.

Syntax

Visual Basic
Public Function GetCommandText( _
   ByVal Command As Command _
) As String

Parameters

Command
Required expression that evaluates to a Command object.

Return Type

String value.

See Also

EditWindow Object


LastExecutionReportMode Method

LastExecutionReportMode Method

Description

Switches edit window to last execution report mode

Syntax

Visual Basic
Public Sub LastExecutionReportMode()

See Also

EditWindow Object


PrintEditWindow Method

PrintEditWindow Method

Description

Causes edit window to print current window contents

Syntax

Visual Basic
Public Sub PrintEditWindow()

See Also

EditWindow Object


ReportMode Method

ReportMode Method

Description

Switches edit window to report mode

This function puts the Edit window into report mode.

Syntax

Visual Basic
Public Sub ReportMode()

See Also

EditWindow Object


SetDMISOutputOptions Method

SetDMISOutputOptions Method
bEnable
Boolean value that determines whether or not PC-DMIS prints the contents of the Edit window as a DMIS output file.
FileName
String value identifies the filename and path for the created DMIS output file.
bOverwrite
This parameter determines how PC-DMIS outputs the DMIS file.
bOutputTheos
With this parameter you can choose to not include theoretical values in the output DMIS file (PCD_DMIS_OUTPUT_THEOS_NONE), output all theoretical values along with the measured values (PCD_DMIS_OUTPUT_THEOS_ALL), or to only output theoretical values output by the DMIS program (PCD_DMIS_OUTPUT_THEOS_USE_IMPORTED_SETTING).
bOutputFeatWithDimensions
Boolean value that allows you determine whether or not to output the measured features and associated tolerances together in the output file.

Description

Sets DMIS output options

This function sets output options for printing the Edit window contents as a DMIS file.

Syntax

Visual Basic
Public Sub SetDMISOutputOptions( _
   ByVal bEnable As Boolean, _
   ByVal FileName As String, _
   ByVal bOverwrite As ENUM_DMIS_OVERWRITE, _
   ByVal bOutputTheos As ENUM_DMIS_OUTPUT_THEOS, _
   ByVal bOutputFeatWithDimensions As Boolean _
)

Parameters

bEnable
Boolean value that determines whether or not PC-DMIS prints the contents of the Edit window as a DMIS output file.
FileName
String value identifies the filename and path for the created DMIS output file.
bOverwrite
Value | Description
PCD_DMIS_FILE_ADD_INDEX | Appends to the existing file name a number.
PCD_DMIS_FILE_OVERWRITE | Overwrites an existing file with the new contents.
PCD_DMIS_FILE_APPEND | Appends the DMIS output file to an existing file.
This parameter determines how PC-DMIS outputs the DMIS file.
bOutputTheos
Value | Description
PCD_DMIS_OUTPUT_THEOS_NONE | Not include theoretical values in the output DMIS file.
PCD_DMIS_OUTPUT_THEOS_ALL | Outputs all theoretical values along with the measured values.
PCD_DMIS_OUTPUT_THEOS_USE_IMPORTED_SETTING | Outputs theoretical values output by the DMIS program.
With this parameter you can choose to not include theoretical values in the output DMIS file (PCD_DMIS_OUTPUT_THEOS_NONE), output all theoretical values along with the measured values (PCD_DMIS_OUTPUT_THEOS_ALL), or to only output theoretical values output by the DMIS program (PCD_DMIS_OUTPUT_THEOS_USE_IMPORTED_SETTING).
bOutputFeatWithDimensions
Boolean value that allows you determine whether or not to output the measured features and associated tolerances together in the output file.

See Also

EditWindow Object


SetPrintOptions Method

SetPrintOptions Method
Location
Destination of printed data. Options include Off, File, or Printer
Draft
When destination is printer, specifies if printer should print in draft mode or not. Options include On and Off.
Filemode
When destination is file, specifies file naming and writing parameters. Options include: Append, New File, Overwrite, and Auto. Auto mode automatically increments a numeric extension for the output file.
ExtNum

Description

Sets edit window print options

This function allows you to set Edit window print options.

Syntax

Visual Basic
Public Sub SetPrintOptions( _
   ByVal Location As PCDPRINTLOC, _
   ByVal Draft As ENUM_PCD_ON_OFF, _
   ByVal Filemode As PCDPRINTFILEMODE, _
   ByVal ExtNum As Long _
)

Parameters

Location
Value | Description
PCD___OFF | No destination for printed data.
PCD_PRINTER | Destination for the printed data is printer.
PCD_FILE | Destination for the printed data is a file.
Destination of printed data. Options include Off, File, or Printer
Draft
Value | Description
DMIS_OFF | Does not print in draft form.
DMIS_ON | Prints in draft form.
When destination is printer, specifies if printer should print in draft mode or not. Options include On and Off.
Filemode
Value | Description
PCD_APPEND | Appends information to the end of the file.
PCD_NEWFILE | Sends information to a new file.
PCD_OVERWRITE | Overwrites information in the current file.
PCD_AUTO | Automatically increments a numeric extension for the output file name.
PCD_PROMPT | Prompts the user for a filename.
When destination is file, specifies file naming and writing parameters. Options include: Append, New File, Overwrite, and Auto. Auto mode automatically increments a numeric extension for the output file.
ExtNum

Return Type

Number to be used for the file extension of the output file.

See Also

EditWindow Object


SetPrintOptionsEx Method

SetPrintOptionsEx Method
Location
Destination of printed data. Options include Off (PCD___OFF), File (PCD_FILE), or Printer (PCD_PRINTER)
Draft
When destination is printer, specifies if printer should print in draft mode or not. Options include On (DMIS_ON) and Off (DMIS_OFF).
Filemode
When the Location is set to PCD_FILE, this specifies file naming and writing parameters. Options include: Append (PDF_APPEND), New File (PCD_NEWFILE), Overwrite (PCD_OVERWRITE), and Auto (PCD_AUTO). Auto mode automatically increments a numeric extension for the output file.
ExtNum
Number to be used for the file extension of the output file.
FileName
If PCD_FILE is selected for the Location parameter, this string value identifies the filename and path for the created file.
format
If PCD_FILE is selected for the Location parameter, the Format parameter specifies the file format for the saved file. You can print the Edit window contents to a file in either the RTF (PCD_RTF) format or the PDF (PCD_PDF) format.
bHyperReportsInline
If PCD_PDF is selected for the Format parameter, this True or False parameter determines whether or not data from inline HyperView commands appear in the PDF generated file.

Description

Sets extended edit window print options

This function allows you to set extended Edit window print options.

Syntax

Visual Basic
Public Sub SetPrintOptionsEx( _
   ByVal Location As PCDPRINTLOC, _
   ByVal Draft As ENUM_PCD_ON_OFF, _
   ByVal Filemode As PCDPRINTFILEMODE, _
   ByVal ExtNum As Long, _
   ByVal FileName As String, _
   ByVal format As PCDFILEPRINTFORMAT, _
   ByVal bHyperReportsInline As Boolean _
)

Parameters

Location
Value | Description
PCD___OFF | No destination for printed data.
PCD_PRINTER | Destination for the printed data is printer.
PCD_FILE | Destination for the printed data is a file.
Destination of printed data. Options include Off (PCD___OFF), File (PCD_FILE), or Printer (PCD_PRINTER)
Draft
Value | Description
DMIS_OFF | Does not print in draft form.
DMIS_ON | Prints in draft form.
When destination is printer, specifies if printer should print in draft mode or not. Options include On (DMIS_ON) and Off (DMIS_OFF).
Filemode
Value | Description
PCD_APPEND | Appends information to the end of the file.
PCD_NEWFILE | Sends information to a new file.
PCD_OVERWRITE | Overwrites information in the current file.
PCD_AUTO | Automatically increments a numeric extension for the output file name.
PCD_PROMPT | Prompts the user for a filename.
When the Location is set to PCD_FILE, this specifies file naming and writing parameters. Options include: Append (PDF_APPEND), New File (PCD_NEWFILE), Overwrite (PCD_OVERWRITE), and Auto (PCD_AUTO). Auto mode automatically increments a numeric extension for the output file.
ExtNum
Number to be used for the file extension of the output file.
FileName
If PCD_FILE is selected for the Location parameter, this string value identifies the filename and path for the created file.
format
Value | Description
PCD_RTF | Writes information to an RTF file.
PCD_PDF | Writes information to a PDF file.
If PCD_FILE is selected for the Location parameter, the Format parameter specifies the file format for the saved file. You can print the Edit window contents to a file in either the RTF (PCD_RTF) format or the PDF (PCD_PDF) format.
bHyperReportsInline
If PCD_PDF is selected for the Format parameter, this True or False parameter determines whether or not data from inline HyperView commands appear in the PDF generated file.

See Also

EditWindow Object


SummaryMode Method

SummaryMode Method

Description

Switches edit window to summary mode

Syntax

Visual Basic
Public Sub SummaryMode()

See Also

EditWindow Object


_Visible Property

_Visible Property

Property type

Read-write property

Syntax

Visual Basic
Public Property _Visible() As Boolean

See Also

EditWindow Object


Application Property

Application Property

Description

Read Only: Returns Application object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

EditWindow Object


Height Property

Height Property

Description

Read/Write: Returns/Sets the height of the edit window

The height of the edit window in screen pixels.

Property type

Read-write property

Syntax

Visual Basic
Public Property Height() As Long

Return Type

Read/write Long.

See Also

EditWindow Object


Left Property

Left Property

Description

Read/Write: Returns/Sets the left coordinate of the edit window The left edge of the edit window, measured from the left edge of the Windows Desktop.

Property type

Read-write property

Syntax

Visual Basic
Public Property Left() As Long

Return Type

Read/write Long.

Remarks

The Left property is measured in screen pixels.

See Also

EditWindow Object


Parent Property

Parent Property

Description

Read Only: Returns Partprogram object Returns the parent PartProgram of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As PartProgram

Return Type

Read-only PartProgram object.

See Also

EditWindow Object


ShowAlignments Property

ShowAlignments Property

Description

Read/Write: Returns/Sets show alignments status of edit window

This property is TRUE if alignments are being shown in the edit window, FALSE otherwise.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowAlignments() As Boolean

Return Type

Read/write Boolean.

See Also

EditWindow Object


ShowComments Property

ShowComments Property

Description

Read/Write: Returns/Sets show comments status of edit window

This property is TRUE if comments are being shown in the edit window, FALSE otherwise.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowComments() As Boolean

Return Type

Read/write Boolean.

See Also

EditWindow Object


ShowDimensions Property

ShowDimensions Property

Description

Read/Write: Returns/Sets show dimensions status of edit window

This property is TRUE if dimensions are being shown in the edit window, FALSE otherwise.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowDimensions() As Boolean

Return Type

Read/write Boolean.

See Also

EditWindow Object


ShowFeatures Property

ShowFeatures Property

Description

Read/Write: Returns/Sets show features status of edit window

This property is TRUE if features are being shown in the edit window, FALSE otherwise.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowFeatures() As Boolean

Return Type

Read/write Boolean.

See Also

EditWindow Object


ShowHeaderFooter Property

ShowHeaderFooter Property

Description

Read/Write: Returns/Sets show header/footer status of edit window

This property is TRUE if headers and footers are being shown in the edit window, FALSE otherwise.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowHeaderFooter() As Boolean

Return Type

Read/write Boolean.

See Also

EditWindow Object


ShowHits Property

ShowHits Property

Description

Read/Write: Returns/Sets show hits status of edit window

This property is TRUE if hits are being shown in the edit window, FALSE otherwise.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowHits() As Boolean

Return Type

Read/write Boolean.

See Also

EditWindow Object


ShowMoves Property

ShowMoves Property

Description

Read/Write: Returns/Sets show moves status of edit window

This property is TRUE if moves are being shown in the edit window, FALSE otherwise.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowMoves() As Boolean

Return Type

Read/write Boolean.

See Also

EditWindow Object


ShowOutTolOnly Property

ShowOutTolOnly Property

Description

Read/Write: Returns/Sets show out of tolerance status of edit window

This property is TRUE if only out-of-tolerance dimensions are being shown in the edit window, FALSE otherwise. If ShowDimensions is FALSE, this property is ignored.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowOutTolOnly() As Boolean

Return Type

Read/write Boolean.

See Also

EditWindow Object


ShowTips Property

ShowTips Property

Description

Read/Write: Returns/Sets show tips status of edit window

This property is TRUE if tips are being shown in the edit window, FALSE otherwise.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowTips() As Boolean

Return Type

Read/write Boolean.

See Also

EditWindow Object


Top Property

Top Property

Description

Read/Write: Returns/Sets the top coordinate of the edit window The top edge of the edit window, measured from the top edge of the Windows Desktop.

Property type

Read-write property

Syntax

Visual Basic
Public Property Top() As Long

Return Type

Read/write Long.

Remarks

The Top property is measured in screen pixels.

See Also

EditWindow Object


Visible Property

Visible Property

Description

Read/Write: Returns/Sets edit window visibility status

This property is TRUE if the edit window is visible, FALSE otherwise.

Property type

Read-write property

Syntax

Visual Basic
Public Property Visible() As Boolean

Return Type

Read/write Boolean.

See Also

EditWindow Object


Width Property

Width Property

Description

Read/Write: Returns/Sets the width of the edit window

The width of the edit window in screen pixels.

Property type

Read-write property

Syntax

Visual Basic
Public Property Width() As Long

Return Type

Read/write Long.

See Also

EditWindow Object


ExecutedCommands Object

ExecutedCommands Object
See Also Members

Description

Part Program Executed Commands Collection Object The ExecutedCommands object acts much like the Commands object except that it only contains a collection of the executed commands from the last part program execution, while the Commands object contains all the commands in the part program.

Object Model

See Also

ExecutedCommands Members


ExecutedCommands Object Members

ExecutedCommands ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method FindByUniqueID | Finds the command identified by the unique id formed from low and high parts Finds a command by a unique ID using HighPart and LoPart parameters.
Public Method Item | Returns the nth command from the last execution The Item method returns the executed command specified by the provided index number in Num.

Public Properties

Public Property Application | Read Only: Returns the Application Object The Application property returns the application object.
Public Property Count | Read Only: Returns the number of commands in the commands collection The Count property returns a number indicating how many commands were executed.
Public Property Parent | Read Only: Returns the parent PartProgram Object The Parent property returns the parent PartProgram object.

See Also

ExecutedCommands Overview


_Item Method

_Item Method
Identifier

Syntax

Visual Basic
Public Function _Item( _
   ByVal Identifier As Variant _
) As Command

Parameters

Identifier

See Also

ExecutedCommands Object


FindByUniqueID Method

FindByUniqueID Method
HiPart
This parameter is a Long value that should come from a call to GetUniqueID made previously on the desired command object.
LoPart
This parameter is a Long value that should come from a call to GetUniqueID made previously on the command object.

Description

Finds the command identified by the unique id formed from low and high parts

Finds a command by a unique ID using HighPart and LoPart parameters.

Syntax

Visual Basic
Public Function FindByUniqueID( _
   ByVal HiPart As Long, _
   ByVal LoPart As Long _
) As Command

Parameters

HiPart
This parameter is a Long value that should come from a call to GetUniqueID made previously on the desired command object.
LoPart
This parameter is a Long value that should come from a call to GetUniqueID made previously on the command object.

Return Type

Command object.

Remarks

You will need to use the GetUniqueID method in order to get the HiPart and LoPart parameter values.

Example

Dim App As PCDLRN.Application

' Get the applicaton object via CreateObject

Set App = CreateObject("PCDLRN.Application")

Dim Part As PCDLRN.PartProgram

' Assume part program is already open

Set Part = App.ActivePartProgram

' Get the entire list of commands in the part program

Dim Cmds As PCDLRN.Commands

Set Cmds = Part.Commands

Dim Cmd As PCDLRN.Command

' Declare variables for holding the unique id values

Dim HiPart As Long, LoPart As Long

' Loop through all of the commands in the part program

For Each Cmd In Cmds

' Find the first assignment command in the part program

' And save off the unique id for that command

If Cmd.Type = ASSIGNMENT Then

Cmd.GetUniqueID HiPart, LoPart

Exit For

End If

Next Cmd

' Execute the part program

Part.EXECUTE

Dim ExecutedCmds As PCDLRN.ExecutedCommands

' Obtain the set of execute commands

Set ExecutedCmds = Part.ExecutedCommands

' Check to see if assignment executed

Set Cmd = ExecutedCmds.FindByUniqueID(HiPart, LoPart)

If Not Cmd Is Nothing Then

MsgBox "Assignment command executed"

End If

See Also

ExecutedCommands Object | GetUniqueID Method


Item Method

Item Method
Num
Required Long value that indicates which executed command to return. This is the index number of the executed command in the ExecutedCommands collection. For example, if you pass 5 in, the 5th command to execute from the last execution would be returned.

Description

Returns the nth command from the last execution The Item method returns the executed command specified by the provided index number in Num.

Syntax

Visual Basic
Public Function Item( _
   ByVal Num As Long _
) As Command

Parameters

Num
Required Long value that indicates which executed command to return. This is the index number of the executed command in the ExecutedCommands collection. For example, if you pass 5 in, the 5th command to execute from the last execution would be returned.

Return Type

Command object.

See Also

ExecutedCommands Object


Application Property

Application Property

Description

Read Only: Returns the Application Object The Application property returns the application object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

ExecutedCommands Object


Count Property

Count Property

Description

Read Only: Returns the number of commands in the commands collection

The Count property returns a number indicating how many commands were executed.

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

Return Type

Long value.

See Also

ExecutedCommands Object


Parent Property

Parent Property

Description

Read Only: Returns the parent PartProgram Object The Parent property returns the parent PartProgram object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As PartProgram

Return Type

PartProgram object.

See Also

ExecutedCommands Object


ExternalCommand Object

ExternalCommand Object
See Also Members

Description

The ExternalCommand object causes PC-DMIS to launch an external program during part program execution. This object has one property: The command property. This property consists of a string value used to execute the external command.

See Also

ExternalCommand Members


ExternalCommand Object Members

ExternalCommand ObjectMembers
See Also Overview

Public Properties

Public Property Command Read/Write: External command string This property returns or sets the string value of the command to be executed.

See Also

ExternalCommand Overview


Command Property

Command Property

Description

Read/Write: External command string

This property returns or sets the string value of the command to be executed.

Property type

Read-write property

Syntax

Visual Basic
Public Property Command() As String

Return Type

Read/write String value.

Remarks

This string should be in the same format as a string entered into Window's Run Dialog box (i.e. The string should include full pathname and executable name of the external command to be executed).

See Also

ExternalCommand Object


FeatCmd Object

FeatCmd Object
See Also Members

Description

Feature Command Object FeatCmd are created from more generic Command objects to pass information specific to the feature command back and forth.

Object Model

See Also

FeatCmd Members


FeatCmd Object Members

FeatCmd ObjectMembers
See Also Overview

Public Methods

Public Method AddInputFeat | Appends to list of Input Features Adds a feature to set of input features used in constructed features.
Public Method AddManualScanHit | Adds a hit to a manual scan command
Public Method CalculateNominals | Recalculate the feature nominals This method recalculates feature nominals for a measured feature.
Public Method CountHits | Recount the hits for a measured feature Recounts the hits for a measured feature.
Public Method Evaluate | Evaluates the feature Forces an evaluation of a feature without executing it. This takes one parameter that specifies the type of feature evaluation to perform.
Public Method GenerateHits | Generates hits for measured features [Desc already exists]
Public Method GetCircMoveItem | Returns Point Data Object with interpolated circular move item data
Public Method GetData | Gets feature data relative to provided parameters [Desc already exists]
Public Method GetFormError | Returns Y14.5.1 Form error if applicable, else 0.0
Public Method GetHit | Returns Point Data Object with hit data Returns a PointData object with the values of the sample hit.
Public Method GetInputID | Gets ID of Input Feature
Public Method GetInputOffset | Gets Offset value for corresponding offset feature in constructed offset features Gets Offset value for corresponding offset feature in constructed offset features
Public Method GetPoint | Returns values for specified feature point type This method retrieves point information for individual objects.
Public Method GetSampleHit | Returns Point Data Object with sample hit data Returns a PointData object with the values of the sample hit.
Public Method GetSurfaceVectors | Gets Values of Surface Vectors for Auto Edge Feature This method gets the surface vectors of an angle hit function.
Public Method GetVector | Returns values for specified feature vector This method retrieves vector components of individual objects.
Public Method PutData | Puts feature data relative to provided parameters This function returns TRUE if the data was successfully retrieved from expression, FALSE otherwise.
Public Method PutPoint | Sets feature point data for specified point type Sets point information for individual objects.
Public Method PutSurfaceVectors | Sets Values of Surfave Vectors for Auto Edge Feature Sets the surface vectors for an angle hit object.
Public Method PutVector | Sets vector values for specified feature vector Sets vector components of individual objects.
Public Method RemoveInputFeat | Removes Constructed Feature Input Feature Removes the feature at the specified index position.
Public Method RemoveManualScanHits | Deletes hits from a manual scan command
Public Method SetHit | Sets hit data of specified hit using part coordinates relative to the current alignment Sets the hit data of a specified hit. It uses the part coordinate system relative to the current alignment.
Public Method SetHit2 | Sets hit data of specified hit This method works just like the SetHit method; it sets the hit data of a specified hit&emdash;but it uses a specified coordinate system and alignment.
Public Method SetInputFeat | Sets Constructed Feature Input Feature Replaces the input feature at position Index in FeatCmd object's list of input features with ID.
Public Method SetInputOffset | Sets Offset value for coresponding offset feature in constructed offset features [Desc Exists]

Public Properties

Public Property AlignWorkPlane | Read/Write: Workplane for Constructed Alignment Plane and Line Workplane value for constructed alignment planes and lines.
Public Property AutoCircularMove | Read/Write: Flag indicating if circular moves should be used during measurement Flag indicating whether circular moves should be used between hits.
Public Property AutoClearPlane | Read/Write: Flag indicating if clearance planes should automatically be used with the feature Flag indicating whether clearance planes should automatically be used with the feature.
Public Property AutoMove | Read/Write: Use Auto Move Setting Auto Move Flag.
Public Property AutoMoveDistance | Read/Write: Auto Move Distance Distance used in calculating auto move.
Public Property AutoPH9 | Read/Write: Flag indicating if the selected tip should be adjusted automatically Flag indicating if selected tip should be automatically adjusted during measurement of feature.
Public Property AutoReadPos | Read/Write: Auto Read Positiong Setting Auto Read Position Flag.
Public Property BestFitMathType | Read/Write: Type of math alogorithm used to best fit the feature Value representing the best fit math algorithm to be used in calculating the measured feature values based on the measured hits. Possible values include the following.
Public Property Bound | Read/Write: Flag indicating whether object is bound or unbound Flag indicating whether or not feature is bound.
Public Property BoxLength | Read/Write: Auto High Point Box Length Box length value for auto high point.
Public Property BoxWidth | Read/Write: Auto High Point Box Width Box width value for auto high point.
Public Property CircularRadiusIn | Read/Write: Auto High Point Inner Circular Radius Inside circular radius value for auto high point.
Public Property CircularRadiusOut | Read/Write: Auto High Point Outer Circular Radius Outside circular radius value for auto high point.
Public Property CornerRadius | Read/Write: Auto Notch and Auto Square Slot Corner Radius Corner radius value for auto square slot and auto notch objects.
Public Property DCCFindNomsMode | Read/Write: Flag indicating whether measurement occurs in findnoms mode Indicates if the measurement mode for an auto feature should be done in find nominals mode or not.
Public Property DCCMeasureInMasterMode | Read/Write: Flag indicating whether measurement occurs in master mode Indicates if the measurement mode for an auto feature should be done in master mode or not.
Public Property Depth | Read/Write: Auto feature depth Gets or sets a depth value for a feature commmand.
Public Property Deviation | Read/Write: Auto Sphere Deviation Auto sphere deviation value.
Public Property DisplayConeAngle | Read/Write: Flag indicating whether angle or length is displayed for cone Flag indicating whether or not to display the angle of the cone. If this value is false, then the cone length is displayed.
Public Property EdgeMeasureOrder | Read/Write: Auto Edge Measure Order Measure order for edge points.
Public Property EdgeThickness | Read/Write: Auto Edge Thickness Thickness value for edge points.
Public Property EndAngle | Read/Write: Feature End Angle End Angle value.
Public Property EndAngle2 | Read/Write: End Angle 2 Second End Angle value.
Public Property FilterType | Read/Write: Filter Object Linear/Polar Setting Filter object filter type.
Public Property FindHole | Read/Write: Use Find Hole Routine Flag indicating whether or not to use the Find Hole routine. If this value is true, then the Fild Hole routine is used.
Public Property GenericAlignMode | Read/Write: Generic Feature Alignment Dependence Value Generic alignment mode.
Public Property GenericDisplayMode | Read/Write: Generic Feature Diameter/Radius Display Type Generic display mode.
Public Property GenericType | Read/Write: Generic Feature Type Generic feature type.
Public Property HighPointSearchMode | Read/Write: Auto High Point Search Mode Search mode for auto high point.
Public Property ID | Read/Write: Feature ID Represents the ID of the feature.
Public Property Increment | Read/Write: Auto High Point Increment Value Increment value for auto high point.
Public Property Indent | Read/Write: Auto feature indent value Indent distance (used with sample hits).
Public Property Indent2 | Read/Write: Auto Feature Indent 2 Value Second indent distance (used with sample hits).
Public Property Indent3 | Read/Write: Auto Feature Indent 3 Value Third indent distance (used with sample hits).
Public Property InitHits | Read/Write: Initial Hits Number of initial sample hits.
Public Property Inner | Read/Write: Inside/Outside Feature Indicates whether the feature is a hole (inner) or a stud (outer).
Public Property InteriorHit | Read/Write: Flag indicating whether hits are exterior or interior hits Flag used to indicate type of hit for objects that can have interior/exterior hits.
Public Property Line3D | Read/Write: Flag indicating whether line is two dimensional or three dimensional Indicates whether the feature is a three dimensional line or a two dimensional line. A value of false indicates a two dimensional line.
Public Property ManualPrePosition | Read/Write: Manual PrePosition
Public Property MeasAngle | Read Only: Measured Angle Measured angle value.
Public Property MeasDiam | Read Only: Measured Diameter Measured diameter value.
Public Property MeasHeight | Read Only: Measured Height This property applies only to PC-DMIS commands that have a height field.
Public Property MeasLength | Read Only: Measured Length This property applies only to PC-DMIS commands that have a length field.
Public Property MeasMajorAxis | Read Only: Auto Ellipse Measured Major Axis Measured major axis length value (ellipse).
Public Property MeasMinorAxis | Read Only: Auto Ellipse Measured Minor Axis Measured minor axis length value (ellipse).
Public Property MeasPinDiam | Read Only: Measure Pin Diameter Measured pin diameter value.
Public Property MeasSmallLength | Read Only: Measured Small Length Measured shorter length value.
Public Property MeasureSlotWidth | Read/Write: Measure Slot Width Flag Flag indicating whether the slot width should be measured.
Public Property NumHits | Read/Write: Number of hits Represents the number of inputs in the feature.
Public Property NumHitsPerRow | Read/Write: Number of hits per row Represents the number of hits on each row of the feature.
Public Property NumRows | Read/Write: Number of rows Represents the number of rows in the feature.
Public Property Parent | Read Only: Parent Command Object Returns the parent Command object.
Public Property PermHits | Read/Write: Auto feature permanent hits Number of permanent sample hits.
Public Property Polar | Read/Write: Flag indicating whether polar coordinates are used Flag indicating whether polar coordinates are used on the feature. Usually defaults to false.
Public Property ReferenceID | Read/Write: Name of reference feature when reference type is feature ID of the feature to be used when the "ReferenceType" property is set to FEATREF_FEATURE. This property is used with measured lines or measured circles.
Public Property ReferenceType | Read/Write: Reference type for measured circles and lines Reference type used with measured circles and measured lines.
Public Property RMeasFeature | Read/Write: Relative Measure Feature ID of the feature to be used for relative measurement.
Public Property Spacer | Read/Write: Auto feature spacer Spacer distance (Usually used with sample hits).
Public Property StartAngle | Read/Write: Feature Start Angle Start Angle value.
Public Property StartAngle2 | Read/Write: Start Angle 2 Second Start Angle value.
Public Property Targets | Read Only: Returns the child Targets Collection Object of a vision feature
Public Property TheoAngle | Read/Write: Theoretical Angle Theoretical angle value.
Public Property TheoDiam | Read/Write: Theoretical Diameter Theoretical diameter value.
Public Property TheoHeight | Read/Write: Theoretical Height Theoretical height value.
Public Property TheoLength | Read/Write: Theoretical Length Theoretical length value.
Public Property TheoMajorAxis | Read/Write: Auto Ellipse Theoretical Major Axis Theoretical major axis length value (ellipse).
Public Property TheoMinorAxis | Read/Write: Auto Ellipse Theoretical Minor Axis Theoretical minor axis length value (ellipse).
Public Property TheoPinDiam | Read/Write: Theoretical Pin Diamter Theoretical pin diameter value.
Public Property TheoSmallLength | Read/Write: Theoretical Small Length Theoretical shorter length value.
Public Property Thickness | Read/Write: Auto feature thickness Sheet metal (material) thickness.
Public Property Tolerance | Read/Write: Auto High Point Tolerance Value Tolerance value for auto high point.
Public Property UsePin | Read/Write: Use Pin Vector Setting Indicates whether pin information should be used during measurement.
Public Property UseTheoValuesForBestfit | Read/Write: Use theo values to solve feature
Public Property VisionMag | Read/Write: Vision Feature Magnification
Public Property VisionTargetColor | Read/Write: Vision Feature Target Color
Public Property VisionTargetType | Read/Write: Vision Feature Target Type

See Also

FeatCmd Overview


AddInputFeat Method

AddInputFeat Method
ID
Required String that is the ID of the feature to add to the set of input features.

Description

Appends to list of Input Features Adds a feature to set of input features used in constructed features.

Syntax

Visual Basic
Public Function AddInputFeat( _
   ByVal ID As String _
) As Boolean

Parameters

ID
Required String that is the ID of the feature to add to the set of input features.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

This function only tries to add ID to a FeatCmd object representing a constructed feature if the two features exist and ID precedes the FeatCmd object in the command list. If the FeatCmd is not a constructed feature, this function will fail.

See Also

FeatCmd Object


AddManualScanHit Method

AddManualScanHit Method
X
Y
Z
I
J
K

Description

Adds a hit to a manual scan command

Syntax

Visual Basic
Public Function AddManualScanHit( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal I As Double, _
   ByVal J As Double, _
   ByVal K As Double _
) As Boolean

Parameters

X
Y
Z
I
J
K

See Also

FeatCmd Object


CalculateNominals Method

CalculateNominals Method

Description

Recalculate the feature nominals This method recalculates feature nominals for a measured feature.

Syntax

Visual Basic
Public Function CalculateNominals() As Boolean

Return Type

Boolean value. Boolean returns true if the function succeeds and feature nominals are recalculated, false if it fails.

See Also

FeatCmd Object | CopyMeasToNom Property


CountHits Method

CountHits Method

Description

Recount the hits for a measured feature Recounts the hits for a measured feature.

Syntax

Visual Basic
Public Function CountHits() As Boolean

Return Type

Boolean value. Boolean returns true if the function succeeds and recounts the hits, false if it fails.

See Also

FeatCmd Object


Evaluate Method

Evaluate Method
MeasNominal
This specifies the type of evaluation to perform.

Description

Evaluates the feature

Forces an evaluation of a feature without executing it. This takes one parameter that specifies the type of feature evaluation to perform.

Syntax

Visual Basic
Public Function Evaluate( _
   ByVal MeasNominal As EVALUATION_TYPES _
) As Boolean

Parameters

MeasNominal
Value | Description
EVAL_NOMINALS | Evaluates the feature’s nominals.
EVAL_ACTUALS | Evaluates the feature’s actuals.
EVAL_BOTH | Evaluates both the feature’s nominals and actuals.
This specifies the type of evaluation to perform.

See Also

FeatCmd Object


GenerateHits Method

GenerateHits Method

Description

Generates hits for measured features

[Desc already exists]

Syntax

Visual Basic
Public Function GenerateHits() As Boolean

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

This function tries to add evenly spaced hits to the FeatCmd object. If the FeatCmd object is not a measured feature, this function will fail.

See Also

FeatCmd Object


GetCircMoveItem Method

GetCircMoveItem Method
CircMove_Index
Move_index
CoordSystem
Alignment
Workplane

Description

Returns Point Data Object with interpolated circular move item data

Syntax

Visual Basic
Public Function GetCircMoveItem( _
   ByVal CircMove_Index As Long, _
   ByVal Move_index As Long, _
   ByVal CoordSystem As FDATA_COORDSYS, _
   ByVal Alignment As String, _
   ByVal Workplane As ENUM_PLANE_TYPE _
) As PointData

Parameters

CircMove_Index
Move_index
CoordSystem
Value Description
FDATA_POLAR
FDATA_CAD
FDATA_PARTMM3
FDATA_MACHINE
FDATA_PART
Alignment
Workplane
Value Description
PLANE_TOP
PLANE_RIGHT
PLANE_BACK
PLANE_BOTTOM
PLANE_LEFT
PLANE_FRONT

See Also

FeatCmd Object


GetData Method

GetData Method
PointData
Required PointData object into which the data is stored.
DataType
Optional enumerated or Long value.
TheoMeas
Optional Long that is one of FDATA_THEO, FDATA_MEAS, or FDATA_TARG.

If no value is supplied, the default value is FDATA_MEAS.

CoordSystem
Optional Long that denotes the coordinate system in which to report. If no value is supplied, the default value is FDATA_PART.
AlignID
Optional String that denotes what alignment to use. You can pass the empty string to denote the current alignment.
Workplane
Optional parameter with the ENUM_PLANE_TYPE enumeration for the PARTMM3 and POLAR coordinate system to denote the workplane to be used.

Description

Gets feature data relative to provided parameters [Desc already exists]

Syntax

Visual Basic
Public Function GetData( _
   ByVal PointData As PointData, _
   ByVal DataType As FDATA_TYPES, _
   ByVal TheoMeas As FDATA_DATASET, _
   ByVal CoordSystem As FDATA_COORDSYS, _
   ByVal AlignID As String, _
   ByVal Workplane As ENUM_PLANE_TYPE _
) As Boolean

Parameters

PointData
Required PointData object into which the data is stored.
DataType
Value Description
FDATA_CENTROID
FDATA_VECTOR
FDATA_DIAMETER
FDATA_STARTPOINT
FDATA_MIDPOINT
FDATA_ENDPOINT
FDATA_LENGTH
FDATA_MINOR_AXIS
FDATA_ANGLE
FDATA_DEVIATION
FDATA_SURFACE_VECTOR
FDATA_THICKNESS
FDATA_SPACER
FDATA_INDENT
FDATA_AUTO_MOVE_DISTANCE
FDATA_DEPTH
FDATA_TARGET
FDATA_ANGLE_VECTOR
FDATA_PUNCH_VECTOR
FDATA_PIN_VECTOR
FDATA_PIN_DIAMETER
FDATA_REPORT_VECTOR
FDATA_REPORT_SURF_VECTOR
FDATA_HEIGHT
FDATA_MEASURE_VECTOR
FDATA_UPDATE_VECTOR
FDATA_SNAP_CENTROID
FDATA_ANALOG_DEVIATIONS
FDATA_CORNER_RADIUS
FDATA_AB_ANGLES
FDATA_ORG_HIT_VECTOR
FDATA_ANGLE2
FDATA_CORNER_VECTOR2
FDATA_CORNER_VECTOR3
FDATA_INDENT2
FDATA_INDENT3
FDATA_OFFSET
FDATA_TIPRADIUS
FDATA_ROTAB_ANGLE
FDATA_SURFACEVECTOR2
FDATA_SURFACEVECTOR2NONORM
FDATA_FOCUS1
FDATA_FOCUS2
FDATA_VERTEX
FDATA_SCANSEG_START
FDATA_SCANSEG_END
FDATA_MANSCAN_INCR_DIST
FDATA_MANSCAN_INCR_TIME
FDATA_WIDTH2
FDATA_MIN_CIRC_SCAN_INIT
FDATA_MIN_CIRC_SCAN_DOWN
FDATA_FLUSH
FDATA_GAP2
FDATA_WIDTH
FDATA_MAJOR_AXIS
FDATA_SLOT_VECTOR
Optional enumerated or Long value.
TheoMeas
Value Description
FDATA_THEO
FDATA_MEAS
FDATA_TARG
FDATA_ALL
Optional Long that is one of FDATA_THEO, FDATA_MEAS, or FDATA_TARG.

If no value is supplied, the default value is FDATA_MEAS.

CoordSystem
Value Description
FDATA_POLAR
FDATA_CAD
FDATA_PARTMM3
FDATA_MACHINE
FDATA_PART
Optional Long that denotes the coordinate system in which to report. If no value is supplied, the default value is FDATA_PART.
AlignID
Optional String that denotes what alignment to use. You can pass the empty string to denote the current alignment.
Workplane
Value Description
PLANE_TOP
PLANE_RIGHT
PLANE_BACK
PLANE_BOTTOM
PLANE_LEFT
PLANE_FRONT
Optional parameter with the ENUM_PLANE_TYPE enumeration for the PARTMM3 and POLAR coordinate system to denote the workplane to be used.

Return Type

This function returns TRUE if the data was successfully retrieved from FeatCmd object, FALSE otherwise.

Remarks

Not every data type can be used with every feature type. Some data types return a single value, some data types return multiple values. Some data types return both depending on the feature. For example, a cone will return two diameters in the first and second data fields of the point object while only returning one diameter for a circle object.Use the FDATA_THEO flag if you want theoretical data, FDATA_MEAS if you want measured data.

See Also

FeatCmd Object | PutData Method


GetFormError Method

GetFormError Method

Description

Returns Y14.5.1 Form error if applicable, else 0.0

Syntax

Visual Basic
Public Function GetFormError() As Double

See Also

FeatCmd Object


GetHit Method

GetHit Method
index
The index number of the desired sample hit object to retrieve.
DataType
Optional Long value. If no value is supplied, the default value is FHITDATA_CENTROID.
MeasOrTheo
Optional Long value. If no value is supplied, the default value is FDATA_MEAS.
CoordSystem
Optional Long value that denotes the coordinate system in which to report. An empty value of "" will use the current alignment.
Alignment
Optional String that denotes what alignment to use. You can pass the empty string to denote the current alignment.

If no value is supplied, the default value is an empty string which causes the current alignment to be used.

Workplane
Optional parameter with the ENUM_PLANE_TYPE enumeration for the PARTMM3 and POLAR coordinate system to denote the workplane to be used.

Description

Returns Point Data Object with hit data Returns a PointData object with the values of the sample hit.

Syntax

Visual Basic
Public Function GetHit( _
   ByVal index As Long, _
   ByVal DataType As FHITDATA_TYPES, _
   ByVal MeasOrTheo As FDATA_DATASET, _
   ByVal CoordSystem As FDATA_COORDSYS, _
   ByVal Alignment As String, _
   ByVal Workplane As ENUM_PLANE_TYPE _
) As PointData

Parameters

index
The index number of the desired sample hit object to retrieve.
DataType
Value Description
FHITDATA_CENTROID
FHITDATA_VECTOR
FHITDATA_BALLCENTER
Optional Long value. If no value is supplied, the default value is FHITDATA_CENTROID.
MeasOrTheo
Value Description
FDATA_THEO
FDATA_MEAS
FDATA_TARG
FDATA_ALL
Optional Long value. If no value is supplied, the default value is FDATA_MEAS.
CoordSystem
Value Description
FDATA_POLAR
FDATA_CAD
FDATA_PARTMM3
FDATA_MACHINE
FDATA_PART
Optional Long value that denotes the coordinate system in which to report. An empty value of "" will use the current alignment.
Alignment
Optional String that denotes what alignment to use. You can pass the empty string to denote the current alignment.

If no value is supplied, the default value is an empty string which causes the current alignment to be used.

Workplane
Value Description
PLANE_TOP
PLANE_RIGHT
PLANE_BACK
PLANE_BOTTOM
PLANE_LEFT
PLANE_FRONT
Optional parameter with the ENUM_PLANE_TYPE enumeration for the PARTMM3 and POLAR coordinate system to denote the workplane to be used.

Return Type

PointData object.

Remarks

Use this function to obtain hit information from individual objects. This command works with objects that the hits are supplied by the user and with objects in which the hits are generated by the object itself.

See Also

FeatCmd Object | PutData Method


GetInputID Method

GetInputID Method
index

Description

Gets ID of Input Feature

Syntax

Visual Basic
Public Function GetInputID( _
   ByVal index As Long _
) As String

Parameters

index

See Also

FeatCmd Object


GetInputOffset Method

GetInputOffset Method
index
Required Long between one and FeadCmd.NumHits.

Description

Gets Offset value for corresponding offset feature in constructed offset features Gets Offset value for corresponding offset feature in constructed offset features

Syntax

Visual Basic
Public Function GetInputOffset( _
   ByVal index As Long _
) As Double

Parameters

index
Required Long between one and FeadCmd.NumHits.

Return Type

Double offset value.

Remarks

Use this function with constructed features that have offset values from input features.

See Also

FeatCmd Object | NumHits Property | SetInputOffset Method


GetPoint Method

GetPoint Method
PointType
FPOINT_TYPES enumeration.
TheoMeas
Enumerated Long value.
X
Variable of type double that will hold the X data for the point.
Y
Variable of type double that will hold the Y data for the point.
Z
Variable of type double that will hold the Z data for the point.

Description

Returns values for specified feature point type This method retrieves point information for individual objects.

Syntax

Visual Basic
Public Function GetPoint( _
   ByVal PointType As FPOINT_TYPES, _
   ByVal TheoMeas As FDATA_DATASET, _
   ByRef X As Double, _
   ByRef Y As Double, _
   ByRef Z As Double _
) As Boolean

Parameters

PointType
Value Description
FPOINT_CENTROID
FPOINT_STARTPOINT
FPOINT_MIDPOINT
FPOINT_ENDPOINT
FPOINT_BALLCENTER
FPOINT_SNAP_CENTROID
FPOINT_TYPES enumeration.
TheoMeas
Value Description
FDATA_THEO
FDATA_MEAS
FDATA_TARG
FDATA_ALL
Enumerated Long value.
X
Variable of type double that will hold the X data for the point.
Y
Variable of type double that will hold the Y data for the point.
Z
Variable of type double that will hold the Z data for the point.

Return Type

Boolean value indicating success or failure of the call.

See Also

FeatCmd Object | PutPoint Method


GetSampleHit Method

GetSampleHit Method
index
The index number of the desired hit object to retrieve.
DataType
Optional Long value. If no value is supplied, the default value is FHITDATA_CENTROID.
MeasOrTheo
Optional Long value. If no value is supplied, the default value is FDATA_MEAS.
CoordSystem
Optional Long that denotes the coordinate system in which to report. An empty value of "" will use the current alignment.
Alignment
Optional String that denotes what alignment to use. You can pass the empty string to denote the current alignment.

If no value is supplied, the default value is an empty string which causes the current alignment to be used.

Workplane
Optional parameter with the ENUM_PLANE_TYPE enumeration for the PARTMM3 and POLAR coordinate system to denote the workplane to be used.

Description

Returns Point Data Object with sample hit data Returns a PointData object with the values of the sample hit.

Syntax

Visual Basic
Public Function GetSampleHit( _
   ByVal index As Long, _
   ByVal DataType As FHITDATA_TYPES, _
   ByVal MeasOrTheo As FDATA_DATASET, _
   ByVal CoordSystem As FDATA_COORDSYS, _
   ByVal Alignment As String, _
   ByVal Workplane As ENUM_PLANE_TYPE _
) As PointData

Parameters

index
The index number of the desired hit object to retrieve.
DataType
Value Description
FHITDATA_CENTROID
FHITDATA_VECTOR
FHITDATA_BALLCENTER
Optional Long value. If no value is supplied, the default value is FHITDATA_CENTROID.
MeasOrTheo
Value Description
FDATA_THEO
FDATA_MEAS
FDATA_TARG
FDATA_ALL
Optional Long value. If no value is supplied, the default value is FDATA_MEAS.
CoordSystem
Value Description
FDATA_POLAR
FDATA_CAD
FDATA_PARTMM3
FDATA_MACHINE
FDATA_PART
Optional Long that denotes the coordinate system in which to report. An empty value of "" will use the current alignment.
Alignment
Optional String that denotes what alignment to use. You can pass the empty string to denote the current alignment.

If no value is supplied, the default value is an empty string which causes the current alignment to be used.

Workplane
Value Description
PLANE_TOP
PLANE_RIGHT
PLANE_BACK
PLANE_BOTTOM
PLANE_LEFT
PLANE_FRONT
Optional parameter with the ENUM_PLANE_TYPE enumeration for the PARTMM3 and POLAR coordinate system to denote the workplane to be used.

Return Type

PointData object.

Remarks

Use this function to obtain sample hit information from Auto Feature commands.

See Also

FeatCmd Object


GetSurfaceVectors Method

GetSurfaceVectors Method
TheoMeas
Long value.
I1
Variable of type double that will hold the I component of the first vector.
J1
Variable of type double that will hold the J component of the first vector.
K1
Variable of type double that will hold the K component of the first vector.
I2
Variable of type double that will hold the I component of the second vector.
J2
Variable of type double that will hold the J component of the second vector.
K2
Variable of type double that will hold the K component of the second vector.

Description

Gets Values of Surface Vectors for Auto Edge Feature This method gets the surface vectors of an angle hit function.

Syntax

Visual Basic
Public Function GetSurfaceVectors( _
   ByVal TheoMeas As FDATA_DATASET, _
   ByRef I1 As Double, _
   ByRef J1 As Double, _
   ByRef K1 As Double, _
   ByRef I2 As Double, _
   ByRef J2 As Double, _
   ByRef K2 As Double _
) As Boolean

Parameters

TheoMeas
Value Description
FDATA_THEO
FDATA_MEAS
FDATA_TARG
FDATA_ALL
Long value.
I1
Variable of type double that will hold the I component of the first vector.
J1
Variable of type double that will hold the J component of the first vector.
K1
Variable of type double that will hold the K component of the first vector.
I2
Variable of type double that will hold the I component of the second vector.
J2
Variable of type double that will hold the J component of the second vector.
K2
Variable of type double that will hold the K component of the second vector.

Return Type

Boolean value indicating success or failure of the call.

See Also

FeatCmd Object | PutSurfaceVectors Method


GetVector Method

GetVector Method
VectorType
FVECTOR_TYPES enumeration.
TheoMeas
Long value.
I
Variable of type double that will hold the I component of the vector.
J
Variable of type double that will hold the J component of the vector.
K
Variable of type double that will hold the K component of the vector.

Description

Returns values for specified feature vector This method retrieves vector components of individual objects.

Syntax

Visual Basic
Public Function GetVector( _
   ByVal VectorType As FVECTOR_TYPES, _
   ByVal TheoMeas As FDATA_DATASET, _
   ByRef I As Double, _
   ByRef J As Double, _
   ByRef K As Double _
) As Boolean

Parameters

VectorType
Value Description
FVECTOR_VECTOR
FVECTOR_SURFACE_VECTOR
FVECTOR_ANGLE_VECTOR
FVECTOR_PUNCH_VECTOR
FVECTOR_PIN_VECTOR
FVECTOR_REPORT_VECTOR
FVECTOR_REPORT_SURF_VECTOR
FVECTOR_MEASURE_VECTOR
FVECTOR_UPDATE_VECTOR
FVECTOR_ORG_HIT_VECTOR
FVECTOR_CORNER_VECTOR2
FVECTOR_CORNER_VECTOR3
FVECTOR_SLOT_VECTOR
FVECTOR_TYPES enumeration.
TheoMeas
Value Description
FDATA_THEO
FDATA_MEAS
FDATA_TARG
FDATA_ALL
Long value.
I
Variable of type double that will hold the I component of the vector.
J
Variable of type double that will hold the J component of the vector.
K
Variable of type double that will hold the K component of the vector.

Return Type

Boolean value indicating success or failure of the call.

See Also

FeatCmd Object | PutVector Method


PutData Method

PutData Method
Data
Required PointData object from which the data is taken to set values in the corresponding object.
DataType
Optional Long value. If no value is supplied, the default value is FDATA_CENTROID.
TheoMeas
Optional Long value. If no value is supplied, the default value is FDATA_MEAS.
CoordSystem
Optional Long that denotes the coordinate system in which to report. If no value is supplied, the default value is FDATA_PART.
AlignID
Optional String that denotes what alignment to use. You can pass the empty string to denote the current alignment.

If no value is supplied, the default value is an empty string which causes the current alignment to be used.

Workplane
Optional parameter with the ENUM_PLANE_TYPE enumeration for the PARTMM3 and POLAR coordinate system to denote the workplane to be used.

Description

Puts feature data relative to provided parameters This function returns TRUE if the data was successfully retrieved from expression, FALSE otherwise.

Syntax

Visual Basic
Public Function PutData( _
   ByVal Data As PointData, _
   ByVal DataType As FDATA_TYPES, _
   ByVal TheoMeas As FDATA_DATASET, _
   ByVal CoordSystem As FDATA_COORDSYS, _
   ByVal AlignID As String, _
   ByVal Workplane As ENUM_PLANE_TYPE _
) As Boolean

Parameters

Data
Required PointData object from which the data is taken to set values in the corresponding object.
DataType
Value Description
FDATA_CENTROID
FDATA_VECTOR
FDATA_DIAMETER
FDATA_STARTPOINT
FDATA_MIDPOINT
FDATA_ENDPOINT
FDATA_LENGTH
FDATA_MINOR_AXIS
FDATA_ANGLE
FDATA_DEVIATION
FDATA_SURFACE_VECTOR
FDATA_THICKNESS
FDATA_SPACER
FDATA_INDENT
FDATA_AUTO_MOVE_DISTANCE
FDATA_DEPTH
FDATA_TARGET
FDATA_ANGLE_VECTOR
FDATA_PUNCH_VECTOR
FDATA_PIN_VECTOR
FDATA_PIN_DIAMETER
FDATA_REPORT_VECTOR
FDATA_REPORT_SURF_VECTOR
FDATA_HEIGHT
FDATA_MEASURE_VECTOR
FDATA_UPDATE_VECTOR
FDATA_SNAP_CENTROID
FDATA_ANALOG_DEVIATIONS
FDATA_CORNER_RADIUS
FDATA_AB_ANGLES
FDATA_ORG_HIT_VECTOR
FDATA_ANGLE2
FDATA_CORNER_VECTOR2
FDATA_CORNER_VECTOR3
FDATA_INDENT2
FDATA_INDENT3
FDATA_OFFSET
FDATA_TIPRADIUS
FDATA_ROTAB_ANGLE
FDATA_SURFACEVECTOR2
FDATA_SURFACEVECTOR2NONORM
FDATA_FOCUS1
FDATA_FOCUS2
FDATA_VERTEX
FDATA_SCANSEG_START
FDATA_SCANSEG_END
FDATA_MANSCAN_INCR_DIST
FDATA_MANSCAN_INCR_TIME
FDATA_WIDTH2
FDATA_MIN_CIRC_SCAN_INIT
FDATA_MIN_CIRC_SCAN_DOWN
FDATA_FLUSH
FDATA_GAP2
FDATA_WIDTH
FDATA_MAJOR_AXIS
FDATA_SLOT_VECTOR
Optional Long value. If no value is supplied, the default value is FDATA_CENTROID.
TheoMeas
Value Description
FDATA_THEO
FDATA_MEAS
FDATA_TARG
FDATA_ALL
Optional Long value. If no value is supplied, the default value is FDATA_MEAS.
CoordSystem
Value Description
FDATA_POLAR
FDATA_CAD
FDATA_PARTMM3
FDATA_MACHINE
FDATA_PART
Optional Long that denotes the coordinate system in which to report. If no value is supplied, the default value is FDATA_PART.
AlignID
Optional String that denotes what alignment to use. You can pass the empty string to denote the current alignment.

If no value is supplied, the default value is an empty string which causes the current alignment to be used.

Workplane
Value Description
PLANE_TOP
PLANE_RIGHT
PLANE_BACK
PLANE_BOTTOM
PLANE_LEFT
PLANE_FRONT
Optional parameter with the ENUM_PLANE_TYPE enumeration for the PARTMM3 and POLAR coordinate system to denote the workplane to be used.

Return Type

Boolean value.

Remarks

Not every data type can be used with every feature type. Some data types take a single value, some data types take multiple values. Some data types take one or more depending on the feature. For example, a cone can take two diameters in the first and second data fields of the point object while the circle object only takes one diamter.

Use the FDATA_THEO flag if you want theoretical data, FDATA_MEAS if you want measured data

See Also

FeatCmd Object | GetData Method


PutPoint Method

PutPoint Method
PointType
FPOINT_TYPES enumeration.
TheoMeas
Long value.
X
Double representing X value of the point.
Y
Double representing Y value of the point.
Z
Double representing Z value of the point.

Description

Sets feature point data for specified point type Sets point information for individual objects.

Syntax

Visual Basic
Public Function PutPoint( _
   ByVal PointType As FPOINT_TYPES, _
   ByVal TheoMeas As FDATA_DATASET, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double _
) As Boolean

Parameters

PointType
Value Description
FPOINT_CENTROID
FPOINT_STARTPOINT
FPOINT_MIDPOINT
FPOINT_ENDPOINT
FPOINT_BALLCENTER
FPOINT_SNAP_CENTROID
FPOINT_TYPES enumeration.
TheoMeas
Value Description
FDATA_THEO
FDATA_MEAS
FDATA_TARG
FDATA_ALL
Long value.
X
Double representing X value of the point.
Y
Double representing Y value of the point.
Z
Double representing Z value of the point.

Return Type

Boolean value indicating success or failure of the call.

See Also

FeatCmd Object | GetPoint Method


PutSurfaceVectors Method

PutSurfaceVectors Method
TheoMeas
Long value.
I1
Double representing the I component of the first vector.
J1
Double representing the J component of the first vector.
K1
Double representing the K component of the first vector.
I2
Double representing the I component of the second vector.
J2
Double representing the J component of the second vector.
K2
Double representing the K component of the second vector.

Description

Sets Values of Surfave Vectors for Auto Edge Feature Sets the surface vectors for an angle hit object.

Syntax

Visual Basic
Public Function PutSurfaceVectors( _
   ByVal TheoMeas As FDATA_DATASET, _
   ByVal I1 As Double, _
   ByVal J1 As Double, _
   ByVal K1 As Double, _
   ByVal I2 As Double, _
   ByVal J2 As Double, _
   ByVal K2 As Double _
) As Boolean

Parameters

TheoMeas
Value Description
FDATA_THEO
FDATA_MEAS
FDATA_TARG
FDATA_ALL
Long value.
I1
Double representing the I component of the first vector.
J1
Double representing the J component of the first vector.
K1
Double representing the K component of the first vector.
I2
Double representing the I component of the second vector.
J2
Double representing the J component of the second vector.
K2
Double representing the K component of the second vector.

Return Type

Boolean value indicating success or failure of the call.

See Also

FeatCmd Object | GetSurfaceVectors Method


PutVector Method

PutVector Method
VectorType
FVECTOR_TYPES enumeration.
TheoMeas
Long value.
I
Double indicating the I component of the vector.
J
Double indicating the J component of the vector.
K
Double indicating the K component of the vector.

Description

Sets vector values for specified feature vector Sets vector components of individual objects.

Syntax

Visual Basic
Public Function PutVector( _
   ByVal VectorType As FVECTOR_TYPES, _
   ByVal TheoMeas As FDATA_DATASET, _
   ByVal I As Double, _
   ByVal J As Double, _
   ByVal K As Double _
) As Boolean

Parameters

VectorType
Value Description
FVECTOR_VECTOR
FVECTOR_SURFACE_VECTOR
FVECTOR_ANGLE_VECTOR
FVECTOR_PUNCH_VECTOR
FVECTOR_PIN_VECTOR
FVECTOR_REPORT_VECTOR
FVECTOR_REPORT_SURF_VECTOR
FVECTOR_MEASURE_VECTOR
FVECTOR_UPDATE_VECTOR
FVECTOR_ORG_HIT_VECTOR
FVECTOR_CORNER_VECTOR2
FVECTOR_CORNER_VECTOR3
FVECTOR_SLOT_VECTOR
FVECTOR_TYPES enumeration.
TheoMeas
Value Description
FDATA_THEO
FDATA_MEAS
FDATA_TARG
FDATA_ALL
Long value.
I
Double indicating the I component of the vector.
J
Double indicating the J component of the vector.
K
Double indicating the K component of the vector.

Return Type

Boolean value indicating success or failure of the call.

See Also

FeatCmd Object | GetVector Method


RemoveInputFeat Method

RemoveInputFeat Method
index
Required Long between one and expression.NumHits

Description

Removes Constructed Feature Input Feature Removes the feature at the specified index position.

Syntax

Visual Basic
Public Function RemoveInputFeat( _
   ByVal index As Long _
) As Boolean

Parameters

index
Required Long between one and expression.NumHits

Return Type

Boolean value. This function returns TRUE if FeatCmd is a constructed object and Index is the index of a input feature.

Remarks

When successful, this function removes the feature at the specified index position.

See Also

FeatCmd Object | NumHits Property


RemoveManualScanHits Method

RemoveManualScanHits Method
StartingIndex
Count

Description

Deletes hits from a manual scan command

Syntax

Visual Basic
Public Function RemoveManualScanHits( _
   ByVal StartingIndex As Long, _
   ByVal Count As Long _
) As Boolean

Parameters

StartingIndex
Count

See Also

FeatCmd Object


SetHit Method

SetHit Method
index
Integer representing the hit number.
DataType
Enumerated data type that specifies what type of data you are setting. This can be Centroid, Vector, or BallCenter.
MeasOrTheo
Enumerated value that indentifies the portion of the hit getting set.
X
The X value for the point / vector being set.
Y
The Y value for the point / vector being set.
Z
The Z value for the point / vector being set.

Description

Sets hit data of specified hit using part coordinates relative to the current alignment Sets the hit data of a specified hit. It uses the part coordinate system relative to the current alignment.

Syntax

Visual Basic
Public Function SetHit( _
   ByVal index As Long, _
   ByVal DataType As FHITDATA_TYPES, _
   ByVal MeasOrTheo As FDATA_DATASET, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double _
) As Boolean

Parameters

index
Integer representing the hit number.
DataType
Value Description
FHITDATA_CENTROID
FHITDATA_VECTOR
FHITDATA_BALLCENTER
Enumerated data type that specifies what type of data you are setting. This can be Centroid, Vector, or BallCenter.
MeasOrTheo
Value Description
FDATA_THEO
FDATA_MEAS
FDATA_TARG
FDATA_ALL
Enumerated value that indentifies the portion of the hit getting set.
X
The X value for the point / vector being set.
Y
The Y value for the point / vector being set.
Z
The Z value for the point / vector being set.

Return Type

Boolean value. This function returns TRUE if the hit or vector gets successfully set, FALSE otherwise.

See Also

FeatCmd Object | SetHit2 Method


SetHit2 Method

SetHit2 Method
index
Integer representing the hit number.
DataType
Enumerated data type that specifies what type of data you are setting. This can be Centroid, Vector, or BallCenter.
MeasOrTheo
Enumerated value that indentifies the portion of the hit getting set. The possible enumerated values for all, measured, theoretical, or targets.
CoordSystem
Enumerated value that indentifies the type of coordinate system to use (Cad, Machine, Part, PartMM3, or Polar).
Alignment
String value representing the ID of the alignment to use.
Workplane
Optional parameter with the ENUM_PLANE_TYPE enumeration that denotes the workplane.
X
X value for the point / vector being set.
Y
Y value for the point / vector being set.
Z
Z value for the point / vector being set.

Description

Sets hit data of specified hit

This method works just like the SetHit method; it sets the hit data of a specified hit&emdash;but it uses a specified coordinate system and alignment.

Syntax

Visual Basic
Public Function SetHit2( _
   ByVal index As Long, _
   ByVal DataType As FHITDATA_TYPES, _
   ByVal MeasOrTheo As FDATA_DATASET, _
   ByVal CoordSystem As FDATA_COORDSYS, _
   ByVal Alignment As String, _
   ByVal Workplane As ENUM_PLANE_TYPE, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double _
) As Boolean

Parameters

index
Integer representing the hit number.
DataType
Value Description
FHITDATA_CENTROID
FHITDATA_VECTOR
FHITDATA_BALLCENTER
Enumerated data type that specifies what type of data you are setting. This can be Centroid, Vector, or BallCenter.
MeasOrTheo
Value Description
FDATA_THEO
FDATA_MEAS
FDATA_TARG
FDATA_ALL
Enumerated value that indentifies the portion of the hit getting set. The possible enumerated values for all, measured, theoretical, or targets.
CoordSystem
Value Description
FDATA_POLAR
FDATA_CAD
FDATA_PARTMM3
FDATA_MACHINE
FDATA_PART
Enumerated value that indentifies the type of coordinate system to use (Cad, Machine, Part, PartMM3, or Polar).
Alignment
String value representing the ID of the alignment to use.
Workplane
Value Description
PLANE_TOP
PLANE_RIGHT
PLANE_BACK
PLANE_BOTTOM
PLANE_LEFT
PLANE_FRONT
Optional parameter with the ENUM_PLANE_TYPE enumeration that denotes the workplane.
X
X value for the point / vector being set.
Y
Y value for the point / vector being set.
Z
Z value for the point / vector being set.

See Also

FeatCmd Object | SetHit Method


SetInputFeat Method

SetInputFeat Method
ID
Required String that is the ID of a feature.
index
Required Long between one and FeatCmd.NumHits. The index value must be less than the value returned by the NumHits property (you can use the NumHits property with constructed features to determine the number of inputs. For adding inputs you will need to use the AddInputFeat method).

Description

Sets Constructed Feature Input Feature Replaces the input feature at position Index in FeatCmd object's list of input features with ID.

Syntax

Visual Basic
Public Function SetInputFeat( _
   ByVal ID As String, _
   ByVal index As Long _
) As Boolean

Parameters

ID
Required String that is the ID of a feature.
index
Required Long between one and FeatCmd.NumHits. The index value must be less than the value returned by the NumHits property (you can use the NumHits property with constructed features to determine the number of inputs. For adding inputs you will need to use the AddInputFeat method).

Return Type

Boolean value. This function returns TRUE if FeadCmd is a constructed feature and ID is the ID of a valid input feature, and Index is the index of a input feature, FALSE otherwise.

See Also

FeatCmd Object | NumHits Property


SetInputOffset Method

SetInputOffset Method
index
Required Long between one and FeatCmd.NumHits
Offset
Required Double which specifies the offset value

Description

Sets Offset value for coresponding offset feature in constructed offset features [Desc Exists]

Syntax

Visual Basic
Public Function SetInputOffset( _
   ByVal index As Long, _
   ByVal Offset As Double _
) As Boolean

Parameters

index
Required Long between one and FeatCmd.NumHits
Offset
Required Double which specifies the offset value

Return Type

Boolean value.

Remarks

Use this function with constructed features to set the offset values for input features.

See Also

FeatCmd Object | NumHits Property | GetInputOffset Method


AlignWorkPlane Property

AlignWorkPlane Property

Description

Read/Write: Workplane for Constructed Alignment Plane and Line Workplane value for constructed alignment planes and lines.

Property type

Read-write property

Syntax

Visual Basic
Public Property AlignWorkPlane() As ENUM_ALIGN_WORKPLANE

Return Type

ENUM_ALIGN_WORKPLANE enumerated value.

Remarks

This property applies only to PC-DMIS constructed features that have a workplane field.

See Also

FeatCmd Object | Command Object


AutoCircularMove Property

AutoCircularMove Property

Description

Read/Write: Flag indicating if circular moves should be used during measurement Flag indicating whether circular moves should be used between hits.

Property type

Read-write property

Syntax

Visual Basic
Public Property AutoCircularMove() As Boolean

Return Type

Read/write Boolean value.

Remarks

This property applies only to PC-DMIS commands that have an auto circular move field.

See Also

FeatCmd Object | Command Object


AutoClearPlane Property

AutoClearPlane Property

Description

Read/Write: Flag indicating if clearance planes should automatically be used with the feature Flag indicating whether clearance planes should automatically be used with the feature.

Property type

Read-write property

Syntax

Visual Basic
Public Property AutoClearPlane() As Boolean

Return Type

Read/write Boolean value.

Remarks

This property applies only to PC-DMIS commands that have an auto clearplane field.

See Also

FeatCmd Object | Command Object


AutoMove Property

AutoMove Property

Description

Read/Write: Use Auto Move Setting Auto Move Flag.

Property type

Read-write property

Syntax

Visual Basic
Public Property AutoMove() As Boolean

Return Type

Read/write Boolean value.

Remarks

This property applies only to PC-DMIS commands that have an auto move field.

See Also

FeatCmd Object | Command Object


AutoMoveDistance Property

AutoMoveDistance Property

Description

Read/Write: Auto Move Distance Distance used in calculating auto move.

Property type

Read-write property

Syntax

Visual Basic
Public Property AutoMoveDistance() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have an auto move distance field.

See Also

FeatCmd Object | Command Object


AutoPH9 Property

AutoPH9 Property

Description

Read/Write: Flag indicating if the selected tip should be adjusted automatically Flag indicating if selected tip should be automatically adjusted during measurement of feature.

Property type

Read-write property

Syntax

Visual Basic
Public Property AutoPH9() As Boolean

Return Type

Read/write Boolean value.

Remarks

This property applies only to PC-DMIS commands that have an AutoPH9 field.

See Also

FeatCmd Object | Command Object


AutoReadPos Property

AutoReadPos Property

Description

Read/Write: Auto Read Positiong Setting Auto Read Position Flag.

Property type

Read-write property

Syntax

Visual Basic
Public Property AutoReadPos() As Boolean

Return Type

Read/write Boolean value.

Remarks

This property applies only to PC-DMIS commands that have an auto read pos field.

See Also

FeatCmd Object | Command Object


BestFitMathType Property

BestFitMathType Property

Description

Read/Write: Type of math alogorithm used to best fit the feature Value representing the best fit math algorithm to be used in calculating the measured feature values based on the measured hits. Possible values include the following.

Property type

Read-write property

Syntax

Visual Basic
Public Property BestFitMathType() As ENUM_BEST_FIT_MATH_TYPES

Return Type

Read/write ENUM_BEST_FIT_MATH_TYPES enumeration.

Remarks

This property applies only to the circle and cylinder measured features and best fit constructed features.

See Also

FeatCmd Object | Command Object


Bound Property

Bound Property

Description

Read/Write: Flag indicating whether object is bound or unbound Flag indicating whether or not feature is bound.

Property type

Read-write property

Syntax

Visual Basic
Public Property Bound() As Boolean

Return Type

Read/write Boolean value.

Remarks

This property applies only to PC-DMIS commands that have a bound/unbound field.

See Also

FeatCmd Object | Command Object


BoxLength Property

BoxLength Property

Description

Read/Write: Auto High Point Box Length Box length value for auto high point.

Property type

Read-write property

Syntax

Visual Basic
Public Property BoxLength() As Double

Return Type

Read/write Double value.

Remarks

This property is only applicable for the PC-DMIS auto high point command.

See Also

FeatCmd Object | Command Object


BoxWidth Property

BoxWidth Property

Description

Read/Write: Auto High Point Box Width Box width value for auto high point.

Property type

Read-write property

Syntax

Visual Basic
Public Property BoxWidth() As Double

Return Type

Read/write Double value.

Remarks

This property is only applicable for the PC-DMIS auto high point command.

See Also

FeatCmd Object | Command Object


CircularRadiusIn Property

CircularRadiusIn Property

Description

Read/Write: Auto High Point Inner Circular Radius Inside circular radius value for auto high point.

Property type

Read-write property

Syntax

Visual Basic
Public Property CircularRadiusIn() As Double

Return Type

Read/write Double value.

Remarks

This property is only applicable for the PC-DMIS auto high point command.

See Also

FeatCmd Object | Command Object


CircularRadiusOut Property

CircularRadiusOut Property

Description

Read/Write: Auto High Point Outer Circular Radius Outside circular radius value for auto high point.

Property type

Read-write property

Syntax

Visual Basic
Public Property CircularRadiusOut() As Double

See Also

FeatCmd Object | Command Object


CornerRadius Property

CornerRadius Property

Description

Read/Write: Auto Notch and Auto Square Slot Corner Radius Corner radius value for auto square slot and auto notch objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property CornerRadius() As Double

Return Type

Read/write Double value.

Remarks

This property is only applicable for the PC-DMIS auto square slot and auto notch commands.

See Also

FeatCmd Object | Command Object


DCCFindNomsMode Property

DCCFindNomsMode Property

Description

Read/Write: Flag indicating whether measurement occurs in findnoms mode Indicates if the measurement mode for an auto feature should be done in find nominals mode or not.

Property type

Read-write property

Syntax

Visual Basic
Public Property DCCFindNomsMode() As Boolean

Return Type

Read/write Boolean value.

Remarks

This property applies only to PC-DMIS auto features with a find nominals measurement field.

See Also

FeatCmd Object | Command Object


DCCMeasureInMasterMode Property

DCCMeasureInMasterMode Property

Description

Read/Write: Flag indicating whether measurement occurs in master mode Indicates if the measurement mode for an auto feature should be done in master mode or not.

Property type

Read-write property

Syntax

Visual Basic
Public Property DCCMeasureInMasterMode() As Boolean

Return Type

Read/write Boolean value.

Remarks

This property applies only to PC-DMIS auto features with a master mode measurement field.

See Also

FeatCmd Object | Command Object


Depth Property

Depth Property

Description

Read/Write: Auto feature depth Gets or sets a depth value for a feature commmand.

Property type

Read-write property

Syntax

Visual Basic
Public Property Depth() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have a depth field..

The Command object allows you to also use the Indent property for setting a feature’s depth for compatibility purposes with older scripts, but you should use the newer Depth property for any current implementation.

See Also

FeatCmd Object | Command Object | Indent Property | Depth Property


Deviation Property

Deviation Property

Description

Read/Write: Auto Sphere Deviation Auto sphere deviation value.

Property type

Read-write property

Syntax

Visual Basic
Public Property Deviation() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to the PC-DMIS auto sphere command.

See Also

FeatCmd Object | Command Object


DisplayConeAngle Property

DisplayConeAngle Property

Description

Read/Write: Flag indicating whether angle or length is displayed for cone Flag indicating whether or not to display the angle of the cone. If this value is false, then the cone length is displayed.

Property type

Read-write property

Syntax

Visual Basic
Public Property DisplayConeAngle() As Boolean

Return Type

Read/write Boolean value.

Remarks

This property applies only to PC-DMIS cone commands that have a display option on angle vs. length.

See Also

FeatCmd Object | Command Object


EdgeMeasureOrder Property

EdgeMeasureOrder Property

Description

Read/Write: Auto Edge Measure Order Measure order for edge points.

Property type

Read-write property

Syntax

Visual Basic
Public Property EdgeMeasureOrder() As EDGE_MEASURE_TYPES

Return Type

Read/write Edge_Measure_Types enumeration.

Remarks

This property applies only to PC-DMIS edge commands.

See Also

FeatCmd Object | Command Object


EdgeThickness Property

EdgeThickness Property

Description

Read/Write: Auto Edge Thickness Thickness value for edge points.

Property type

Read-write property

Syntax

Visual Basic
Public Property EdgeThickness() As Double

Return Type

Read/write Double value.

Remarks

This property is only applicable for PC-DMIS edge commands.

See Also

FeatCmd Object | Command Object


EndAngle Property

EndAngle Property

Description

Read/Write: Feature End Angle End Angle value.

Property type

Read-write property

Syntax

Visual Basic
Public Property EndAngle() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have an end angle field.

See Also

FeatCmd Object | Command Object


EndAngle2 Property

EndAngle2 Property

Description

Read/Write: End Angle 2 Second End Angle value.

Property type

Read-write property

Syntax

Visual Basic
Public Property EndAngle2() As Double

Return Type

Rea/write Double value.

Remarks

This property applies only to PC-DMIS commands that have a second end angle field.

See Also

FeatCmd Object | Command Object


FilterType Property

FilterType Property

Description

Read/Write: Filter Object Linear/Polar Setting Filter object filter type.

Property type

Read-write property

Syntax

Visual Basic
Public Property FilterType() As ENUM_FILTER_TYPES

Return Type

Read/write Enum_Filter_Types enumeration.

Remarks

This property is only applicable for the PC-DMIS filter command.

See Also

FeatCmd Object | Command Object


FindHole Property

FindHole Property

Description

Read/Write: Use Find Hole Routine Flag indicating whether or not to use the Find Hole routine. If this value is true, then the Fild Hole routine is used.

Property type

Read-write property

Syntax

Visual Basic
Public Property FindHole() As Boolean

Return Type

Read/write Boolean value.

See Also

FeatCmd Object | Command Object


GenericAlignMode Property

GenericAlignMode Property

Description

Read/Write: Generic Feature Alignment Dependence Value Generic alignment mode.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenericAlignMode() As ENUM_GENERIC_ALIGN

Return Type

Read/write Enum_Generic_Align enumeration.

Remarks

This property is only applicable for the PC-DMIS generic feature command.

See Also

FeatCmd Object | Command Object


GenericDisplayMode Property

GenericDisplayMode Property

Description

Read/Write: Generic Feature Diameter/Radius Display Type Generic display mode.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenericDisplayMode() As ENUM_GENERIC_DISPLAY

Return Type

Read/write Enum_Generic_Display enumeration.

Remarks

This property is only applicable for the PC-DMIS generic feature command.

See Also

FeatCmd Object | Command Object


GenericType Property

GenericType Property

Description

Read/Write: Generic Feature Type Generic feature type.

Property type

Read-write property

Syntax

Visual Basic
Public Property GenericType() As ENUM_GENERIC_TYPES

Return Type

Read/write Enum_Generic_Types enumeration.

Remarks

This property is only applicable for the PC-DMIS generic feature command.

See Also

FeatCmd Object | Command Object


HighPointSearchMode Property

HighPointSearchMode Property

Description

Read/Write: Auto High Point Search Mode Search mode for auto high point.

Property type

Read-write property

Syntax

Visual Basic
Public Property HighPointSearchMode() As HIGH_POINT_SEARCH_MODES

Return Type

Read/write High_Point_Search_Modes enumeration.

Remarks

This property is only applicable for the PC-DMIS auto high point command.

See Also

FeatCmd Object | Command Object


ID Property

ID Property

Description

Read/Write: Feature ID Represents the ID of the feature.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As String

Return Type

Read/write String value.

Remarks

The IDs of the various objects in a part program should be unique.

See Also

FeatCmd Object


Increment Property

Increment Property

Description

Read/Write: Auto High Point Increment Value Increment value for auto high point.

Property type

Read-write property

Syntax

Visual Basic
Public Property Increment() As Double

Return Type

Read/write Double value.

Remarks

This property is only applicable for the PC-DMIS auto high point command.

See Also

FeatCmd Object | Command Object


Indent Property

Indent Property

Description

Read/Write: Auto feature indent value Indent distance (used with sample hits).

Property type

Read-write property

Syntax

Visual Basic
Public Property Indent() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have an indent field.

Note: For compatability purposes with older scripts, the Command object allows you to use Ident to set an auto circle’s depth, however, for any new scripts you should use the newer Depth property to do this.

See Also

FeatCmd Object | Command Object | Depth Property


Indent2 Property

Indent2 Property

Description

Read/Write: Auto Feature Indent 2 Value Second indent distance (used with sample hits).

Property type

Read-write property

Syntax

Visual Basic
Public Property Indent2() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have a second indent field.

See Also

FeatCmd Object | Command Object


Indent3 Property

Indent3 Property

Description

Read/Write: Auto Feature Indent 3 Value Third indent distance (used with sample hits).

Property type

Read-write property

Syntax

Visual Basic
Public Property Indent3() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have a third indent field.

See Also

FeatCmd Object | Command Object


InitHits Property

InitHits Property

Description

Read/Write: Initial Hits Number of initial sample hits.

Property type

Read-write property

Syntax

Visual Basic
Public Property InitHits() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have a working initial hits field. These include:

  • AUTO Angle
  • AUTO Circle
  • AUTO Cylinder
  • AUTO Edge
  • AUTO Ellipse
  • AUTO Notch
  • AUTO Round Slot
  • AUTO Sphere
  • AUTO Square Slot
  • AUTO Surface
  • Angle Hit
  • Edge Hit

All other features only allow a read-only zero for initial hits.

See Also

FeatCmd Object | Command Object


Inner Property

Inner Property

Description

Read/Write: Inside/Outside Feature Indicates whether the feature is a hole (inner) or a stud (outer).

Property type

Read-write property

Syntax

Visual Basic
Public Property Inner() As Boolean

Return Type

Read/write Boolean value.

Remarks

This property applies only to PC-DMIS commands that can be either inside or outside features.

See Also

FeatCmd Object | Command Object


InteriorHit Property

InteriorHit Property

Description

Read/Write: Flag indicating whether hits are exterior or interior hits Flag used to indicate type of hit for objects that can have interior/exterior hits.

Property type

Read-write property

Syntax

Visual Basic
Public Property InteriorHit() As Boolean

Return Type

Read/write Boolean value.

Remarks

This property applies only to PC-DMIS commands that have an interior/exterior hit field.

See Also

FeatCmd Object | Command Object


Line3D Property

Line3D Property

Description

Read/Write: Flag indicating whether line is two dimensional or three dimensional Indicates whether the feature is a three dimensional line or a two dimensional line. A value of false indicates a two dimensional line.

Property type

Read-write property

Syntax

Visual Basic
Public Property Line3D() As Boolean

Return Type

Read/write Boolean value.

Remarks

This property applies only to PC-DMIS lines features with and 2D/3D field.

See Also

FeatCmd Object | Command Object


ManualPrePosition Property

ManualPrePosition Property

Description

Read/Write: Manual PrePosition

Property type

Read-write property

Syntax

Visual Basic
Public Property ManualPrePosition() As Boolean

See Also

FeatCmd Object


MeasAngle Property

MeasAngle Property

Description

Read Only: Measured Angle Measured angle value.

Property type

Read-write property

Syntax

Visual Basic
Public Property MeasAngle() As Double

Return Type

Read only Double value.

Remarks

This property applies only to PC-DMIS commands that have an angle field.

See Also

FeatCmd Object | Comment Object


MeasDiam Property

MeasDiam Property

Description

Read Only: Measured Diameter Measured diameter value.

Property type

Read-write property

Syntax

Visual Basic
Public Property MeasDiam() As Double

Return Type

Read only Double value.

Remarks

This property applies only to PC-DMIS commands that have a diameter field.

See Also

FeatCmd Object | Command Object


MeasHeight Property

MeasHeight Property

Description

Read Only: Measured Height This property applies only to PC-DMIS commands that have a height field.

Property type

Read-write property

Syntax

Visual Basic
Public Property MeasHeight() As Double

Return Type

Read only Double value.

Remarks

This property applies only to PC-DMIS commands that have a height field.

See Also

FeatCmd Object | Command Object


MeasLength Property

MeasLength Property

Description

Read Only: Measured Length This property applies only to PC-DMIS commands that have a length field.

Property type

Read-write property

Syntax

Visual Basic
Public Property MeasLength() As Double

Return Type

Read only Double value.

Remarks

This property applies only to PC-DMIS commands that have a length field.

See Also

FeatCmd Object | Command Object


MeasMajorAxis Property

MeasMajorAxis Property

Description

Read Only: Auto Ellipse Measured Major Axis Measured major axis length value (ellipse).

Property type

Read-write property

Syntax

Visual Basic
Public Property MeasMajorAxis() As Double

Return Type

Read only Double value.

Remarks

This property applies only to PC-DMIS commands that have a major axis field.

See Also

FeatCmd Object | Command Object


MeasMinorAxis Property

MeasMinorAxis Property

Description

Read Only: Auto Ellipse Measured Minor Axis Measured minor axis length value (ellipse).

Property type

Read-write property

Syntax

Visual Basic
Public Property MeasMinorAxis() As Double

Return Type

Read only Double value.

Remarks

This property applies only to PC-DMIS commands that have a minor axis field.

See Also

FeatCmd Object | Command Object


MeasPinDiam Property

MeasPinDiam Property

Description

Read Only: Measure Pin Diameter Measured pin diameter value.

Property type

Read-write property

Syntax

Visual Basic
Public Property MeasPinDiam() As Double

Return Type

Read only Double value.

Remarks

This property applies only to PC-DMIS commands that have a pin diameter field.

See Also

FeatCmd Object | Command Object


MeasSmallLength Property

MeasSmallLength Property

Description

Read Only: Measured Small Length Measured shorter length value.

Property type

Read-write property

Syntax

Visual Basic
Public Property MeasSmallLength() As Double

Return Type

Read only Double value.

Remarks

This property applies only to PC-DMIS commands that have a small length field.

See Also

FeatCmd Object | Command Object


MeasureSlotWidth Property

MeasureSlotWidth Property

Description

Read/Write: Measure Slot Width Flag Flag indicating whether the slot width should be measured.

Property type

Read-write property

Syntax

Visual Basic
Public Property MeasureSlotWidth() As Boolean

Return Type

Read/write Boolean value.

Remarks

This property applies only to PC-DMIS commands that have a measure slot width flag.

See Also

FeatCmd Object | Command Object


NumHits Property

NumHits Property

Description

Read/Write: Number of hits Represents the number of inputs in the feature.

Property type

Read-write property

Syntax

Visual Basic
Public Property NumHits() As Long

Return Type

Read/write Long value.

Remarks

If this feature is constructed, it reports the number of input features.

See Also

FeatCmd Object


NumHitsPerRow Property

NumHitsPerRow Property

Description

Read/Write: Number of hits per row Represents the number of hits on each row of the feature.

Property type

Read-write property

Syntax

Visual Basic
Public Property NumHitsPerRow() As Long

Return Type

Read/write Long value.

Remarks

You can use this variable only with features that have rows (such as spheres and cylinders).

See Also

FeatCmd Object


NumRows Property

NumRows Property

Description

Read/Write: Number of rows Represents the number of rows in the feature.

Property type

Read-write property

Syntax

Visual Basic
Public Property NumRows() As Long

Return Type

Read/write Long value.

Remarks

You can use this variable only with features that have rows (such as spheres and cylinders).

See Also

FeatCmd Object


Parent Property

Parent Property

Description

Read Only: Parent Command Object Returns the parent Command object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Command

Return Type

Read only Command object.

Remarks

The parent of a FeatCmd object is the same underlying PC-DMIS object as the FeatCmd object itself. Getting the parent allows you to access the generic Command properties and methods of a given object.

See Also

FeatCmd Object


PermHits Property

PermHits Property

Description

Read/Write: Auto feature permanent hits Number of permanent sample hits.

Property type

Read-write property

Syntax

Visual Basic
Public Property PermHits() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have a working permanent hits field. These include

  • AUTO Angle
  • AUTO Circle
  • AUTO Cylinder
  • AUTO Edge
  • AUTO Ellipse
  • AUTO Notch
  • AUTO Round Slot
  • AUTO Sphere
  • AUTO Square Slot
  • AUTO Surface
  • Angle Hit
  • Edge Hit

All other features only allow a read-only zero for permanent hits.

See Also

FeatCmd Object | Command Object


Polar Property

Polar Property

Description

Read/Write: Flag indicating whether polar coordinates are used Flag indicating whether polar coordinates are used on the feature. Usually defaults to false.

Property type

Read-write property

Syntax

Visual Basic
Public Property Polar() As Boolean

Return Type

Read/write Boolean value.

Remarks

This property applies only to PC-DMIS commands that have support for polar coordinates.

See Also

FeatCmd Object | Command Object


ReferenceID Property

ReferenceID Property

Description

Read/Write: Name of reference feature when reference type is feature ID of the feature to be used when the "ReferenceType" property is set to FEATREF_FEATURE. This property is used with measured lines or measured circles.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReferenceID() As String

Return Type

Read/write String value.

Remarks

This property applies only to measured lines and circles that have the projection reference type set to feature.

See Also

FeatCmd Object | Command Object


ReferenceType Property

ReferenceType Property

Description

Read/Write: Reference type for measured circles and lines Reference type used with measured circles and measured lines.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReferenceType() As ENUM_FEATREF_TYPES

Return Type

Read/write ENUM_FEATREF_TYPES enumeration.

Remarks

This property applies only to PC-DMIS measured line and measured circle commands. Possible value include the following:

  • FEATREF_FEATURE = -3 (Use ReferenceID Property to specify feature)
  • FEATREF_3D = -2, (Feature is a 3D feature, no projections)
  • FEATREF_CURRENT_WORKPLANE = -1,
  • FEATREF_ZPLUS = 0,
  • FEATREF_XPLUS = 1,
  • FEATREF_YPLUS = 2,
  • FEATREF_ZMINUS = 3,
  • FEATREF_XMINUS = 4,
  • FEATREF_YMINUS = 5

See Also

FeatCmd Object | Command Object


RMeasFeature Property

RMeasFeature Property

Description

Read/Write: Relative Measure Feature ID of the feature to be used for relative measurement.

Property type

Read-write property

Syntax

Visual Basic
Public Property RMeasFeature() As String

Return Type

Read/write String value.

Remarks

This property applies only to PC-DMIS commands that support relative measurement

See Also

FeatCmd Object | Command Object


Spacer Property

Spacer Property

Description

Read/Write: Auto feature spacer Spacer distance (Usually used with sample hits).

Property type

Read-write property

Syntax

Visual Basic
Public Property Spacer() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have a spacer field.

See Also

FeatCmd Object | Command Object


StartAngle Property

StartAngle Property

Description

Read/Write: Feature Start Angle Start Angle value.

Property type

Read-write property

Syntax

Visual Basic
Public Property StartAngle() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have a start angle field.

See Also

FeatCmd Object | Command Object


StartAngle2 Property

StartAngle2 Property

Description

Read/Write: Start Angle 2 Second Start Angle value.

Property type

Read-write property

Syntax

Visual Basic
Public Property StartAngle2() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have a second start angle field.

See Also

FeatCmd Object | Command Object


Targets Property

Targets Property

Description

Read Only: Returns the child Targets Collection Object of a vision feature

Property type

Read-write property

Syntax

Visual Basic
Public Property Targets() As Targets

See Also

FeatCmd Object


TheoAngle Property

TheoAngle Property

Description

Read/Write: Theoretical Angle Theoretical angle value.

Property type

Read-write property

Syntax

Visual Basic
Public Property TheoAngle() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have an angle field.

See Also

FeatCmd Object | Command Object


TheoDiam Property

TheoDiam Property

Description

Read/Write: Theoretical Diameter Theoretical diameter value.

Property type

Read-write property

Syntax

Visual Basic
Public Property TheoDiam() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have a diameter field.

See Also

FeatCmd Object | Command Object


TheoHeight Property

TheoHeight Property

Description

Read/Write: Theoretical Height Theoretical height value.

Property type

Read-write property

Syntax

Visual Basic
Public Property TheoHeight() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have a height field.

See Also

FeatCmd Object | Command Object


TheoLength Property

TheoLength Property

Description

Read/Write: Theoretical Length Theoretical length value.

Property type

Read-write property

Syntax

Visual Basic
Public Property TheoLength() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have a length field. These include:

  • Lines
  • Cylinders
  • Cones
  • Slots
  • Notches
  • Generic Features

See Also

FeatCmd Object | Command Object


TheoMajorAxis Property

TheoMajorAxis Property

Description

Read/Write: Auto Ellipse Theoretical Major Axis Theoretical major axis length value (ellipse).

Property type

Read-write property

Syntax

Visual Basic
Public Property TheoMajorAxis() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have a major axis field.

See Also

FeatCmd Object | Command Object


TheoMinorAxis Property

TheoMinorAxis Property

Description

Read/Write: Auto Ellipse Theoretical Minor Axis Theoretical minor axis length value (ellipse).

Property type

Read-write property

Syntax

Visual Basic
Public Property TheoMinorAxis() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have a minor axis field.

See Also

FeatCmd Object | Command Object


TheoPinDiam Property

TheoPinDiam Property

Description

Read/Write: Theoretical Pin Diamter Theoretical pin diameter value.

Property type

Read-write property

Syntax

Visual Basic
Public Property TheoPinDiam() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have a pin diameter field.

See Also

FeatCmd Object | Command Object


TheoSmallLength Property

TheoSmallLength Property

Description

Read/Write: Theoretical Small Length Theoretical shorter length value.

Property type

Read-write property

Syntax

Visual Basic
Public Property TheoSmallLength() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have a small length field.

See Also

FeatCmd Object | CadWindow Object


Thickness Property

Thickness Property

Description

Read/Write: Auto feature thickness Sheet metal (material) thickness.

Property type

Read-write property

Syntax

Visual Basic
Public Property Thickness() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to PC-DMIS commands that have a thickness field.

See Also

FeatCmd Object | Command Object


Tolerance Property

Tolerance Property

Description

Read/Write: Auto High Point Tolerance Value Tolerance value for auto high point.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tolerance() As Double

Return Type

Read/write Double value.

Remarks

This property applies only to the PC-DMIS auto high point command.

See Also

FeatCmd Object | Command Object


UsePin Property

UsePin Property

Description

Read/Write: Use Pin Vector Setting Indicates whether pin information should be used during measurement.

Property type

Read-write property

Syntax

Visual Basic
Public Property UsePin() As Boolean

Return Type

Read/write Boolean value.

Remarks

This property applies only to PC-DMIS commands that have a use pin field.

See Also

FeatCmd Object | Command Object


UseTheoValuesForBestfit Property

UseTheoValuesForBestfit Property

Description

Read/Write: Use theo values to solve feature

Property type

Read-write property

Syntax

Visual Basic
Public Property UseTheoValuesForBestfit() As Boolean

See Also

FeatCmd Object


VisionMag Property

VisionMag Property

Description

Read/Write: Vision Feature Magnification

Property type

Read-write property

Syntax

Visual Basic
Public Property VisionMag() As Double

See Also

FeatCmd Object


VisionTargetColor Property

VisionTargetColor Property

Description

Read/Write: Vision Feature Target Color

Property type

Read-write property

Syntax

Visual Basic
Public Property VisionTargetColor() As Integer

See Also

FeatCmd Object


VisionTargetType Property

VisionTargetType Property

Description

Read/Write: Vision Feature Target Type

Property type

Read-write property

Syntax

Visual Basic
Public Property VisionTargetType() As ENUM_VISION_TARGET_TYPE

See Also

FeatCmd Object


FeatData Object

FeatData Object
See Also Members

Description

Feature Data Object

The FeatData object is similar to a type as defined in the Example below.

It is be used to pass feature data in automation functions that accept this type

Remarks

Example

Type FeatData

X as Double
Y as Double
Z as Double
I as Double
J as Double
K as Double
DIAM as Double
LENGTH as Double
ANGLE as Double
SmallDiam as Double
StartAngle as Double
EndAngle as Double
StartAngle2 as Double
EndAngle2 as Double
F as Double
TP as Double
P1 as Double
P2 as Double
ID as String

End Type

See Also

FeatData Members


FeatData Object Members

FeatData ObjectMembers
See Also Overview

Public Properties

Public Property _ID |
Public Property Angle | Read/Write: Returns/Sets the ANGLE value of the feature data object Represents the ANGLE member of this object.
Public Property diam | Read/Write: Returns/Sets the DIAM value of the feature data object Represents the diameter of this object.
Public Property EndAngle | Read/Write: Returns/Sets the EndAngle value of the feature data object Represents the EndAngle member of this object.
Public Property EndAngle2 | Read/Write: Returns/Sets the EndAngle2 value of the feature data object Represents the EndAngle2 member of this object.
Public Property F | Read/Write: Returns/Sets the F value of the feature data object Represents the F member of this object.
Public Property I | Read/Write: Returns/Sets the I value of the feature data object Represents the I member of this object.
Public Property ID | Read/Write: Returns/Sets the ID value of the feature data object Represents the ID member of this object.
Public Property J | Read/Write: Returns/Sets the J value of the feature data object Represents the J member of this object.
Public Property K | Read/Write: Returns/Sets the K value of the feature data object Represents the K member of this object.
Public Property Length | Read/Write: Returns/Sets the LENGTH value of the feature data object Represents the LENGTH member of this object.
Public Property P1 | Read/Write: Returns/Sets the P1 value of the feature data object Represents the P1 member of this object.
Public Property P2 | Read/Write: Returns/Sets the P2 value of the feature data object Represents the P2 member of this object.
Public Property SmallDiam | Read/Write: Returns/Sets the SmallDiam value of the feature data object Represents the SmallDiam member of this object.
Public Property StartAngle | Read/Write: Returns/Sets the StartAngle value of the feature data object Represents the StartAngle member of this object.
Public Property StartAngle2 | Read/Write: Returns/Sets the StartAngle2 value of the feature data object Represents the StartAngle2 member of this object.
Public Property TP | Read/Write: Returns/Sets the TP value of the feature data object Represents the TP member of this object.
Public Property X | Read/Write: Returns/Sets the X value of the feature data object Represents the X member of this object.
Public Property Y | Read/Write: Returns/Sets the Y value of the feature data object Represents the Y member of this object.
Public Property Z | Read/Write: Returns/Sets the Z value of the feature data object Represents the Z member of this object.

See Also

FeatData Overview


_ID Property

_ID Property

Property type

Read-write property

Syntax

Visual Basic
Public Property _ID() As String

See Also

FeatData Object


Angle Property

Angle Property

Description

Read/Write: Returns/Sets the ANGLE value of the feature data object Represents the ANGLE member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Angle() As Double

Return Type

Read/write Double value.

See Also

FeatData Object


diam Property

diam Property

Description

Read/Write: Returns/Sets the DIAM value of the feature data object Represents the diameter of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property diam() As Double

Return Type

Read/write Double value.

See Also

FeatData Object


EndAngle Property

EndAngle Property

Description

Read/Write: Returns/Sets the EndAngle value of the feature data object Represents the EndAngle member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property EndAngle() As Double

Return Type

Read/write Double value.

See Also

FeatData Object


EndAngle2 Property

EndAngle2 Property

Description

Read/Write: Returns/Sets the EndAngle2 value of the feature data object Represents the EndAngle2 member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property EndAngle2() As Double

Return Type

Read/write Double value.

See Also

FeatData Object


F Property

F Property

Description

Read/Write: Returns/Sets the F value of the feature data object Represents the F member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property F() As Double

Return Type

Read/write Double value.

See Also

FeatData Object


I Property

I Property

Description

Read/Write: Returns/Sets the I value of the feature data object Represents the I member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property I() As Double

Return Type

Read/write Double value.

See Also

FeatData Object


ID Property

ID Property

Description

Read/Write: Returns/Sets the ID value of the feature data object Represents the ID member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As String

Return Type

Read/write String value.

Remarks

The ID member is the default property.

The ID member is the default

See Also

FeatData Object


J Property

J Property

Description

Read/Write: Returns/Sets the J value of the feature data object Represents the J member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property J() As Double

Return Type

Read/write Double value.

See Also

FeatData Object


K Property

K Property

Description

Read/Write: Returns/Sets the K value of the feature data object Represents the K member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property K() As Double

Return Type

Read/write Double value.

See Also

FeatData Object


Length Property

Length Property

Description

Read/Write: Returns/Sets the LENGTH value of the feature data object Represents the LENGTH member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Length() As Double

Return Type

Read/write Double value.

See Also

FeatData Object


P1 Property

P1 Property

Description

Read/Write: Returns/Sets the P1 value of the feature data object Represents the P1 member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property P1() As Double

Return Type

Read/write Double value.

Remarks

The P1 member is never set or used by PC-DMIS. It is available for the programmer to use as he wishes.

See Also

FeatData Object


P2 Property

P2 Property

Description

Read/Write: Returns/Sets the P2 value of the feature data object Represents the P2 member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property P2() As Double

Return Type

Read/write Double value.

Remarks

The P2 member is never set or used by PC-DMIS. It is available for the programmer to use as he wishes.

See Also

FeatData Object


SmallDiam Property

SmallDiam Property

Description

Read/Write: Returns/Sets the SmallDiam value of the feature data object

Represents the SmallDiam member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property SmallDiam() As Double

Return Type

Read/write Double value.

See Also

FeatData Object


StartAngle Property

StartAngle Property

Description

Read/Write: Returns/Sets the StartAngle value of the feature data object Represents the StartAngle member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property StartAngle() As Double

Return Type

Read/write Double value.

See Also

FeatData Object


StartAngle2 Property

StartAngle2 Property

Description

Read/Write: Returns/Sets the StartAngle2 value of the feature data object

Represents the StartAngle2 member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property StartAngle2() As Double

Return Type

Read/write Double value.

See Also

FeatData Object


TP Property

TP Property

Description

Read/Write: Returns/Sets the TP value of the feature data object Represents the TP member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property TP() As Double

Return Type

Read/write Double value.

See Also

FeatData Object


X Property

X Property

Description

Read/Write: Returns/Sets the X value of the feature data object Represents the X member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property X() As Double

Return Type

Read/write Double value.

See Also

FeatData Object


Y Property

Y Property

Description

Read/Write: Returns/Sets the Y value of the feature data object Represents the Y member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Y() As Double

Return Type

Read/write Double value.

See Also

FeatData Object


Z Property

Z Property

Description

Read/Write: Returns/Sets the Z value of the feature data object

Represents the Z member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Z() As Double

Return Type

Read/write Double value.

See Also

FeatData Object


FileIO Object

FileIO Object
See Also Members

Description

The FileIO object is used to access the PC-DMIS File I/O object.

Remarks

This object's properties provide access to the file mode (open, close, readline, and so on), the expression to write or read, the filename, and so forth.

For additional information, see the "Using File Input / Output" section in the PC-DMIS Help File.

See Also

FileIO Members


FileIO Object Members

FileIO ObjectMembers
See Also Overview

Public Properties

Public Property BufferSize | Read/Write: Buffersize used in ReadBlock command Indicates the buffer size used with the Read Block File I/O command.
Public Property Expression | Read/Write: Expression to read to or write from file Indicates the buffer size used with the Read Block File I/O command.
Public Property FailIfExists | Read/Write: Indicates whether copy fails if destination file already exists Indicates whether or not a file copy operation should fail or not if the destination file already exists.
Public Property FileIOType | Read/Write: The File IO type (ie. Open, Close, etc.) Value of ENUM_FILE_IO_TYPES enumeration type which specifies the type of File I/O operation the object will perform.
Public Property FileName1 | Read/Write: Filename Represents the file name to be used in the File I/O operation. This parameter is used with the File Open, File Copy, File Move, File Delete, and File Exists File I/O types.
Public Property FileName2 | Read/Write: Filename two Represents the second filename to be used in the File I/O operation. This parameter is used as the destination file in the File Copy and File Move File I/O commands.
Public Property FileOpenType | Read/Write: File Open Type (ie. Read, Write, Append) Value of ENUM_FILE_OPEN_TYPES enumeration type which specifies the file open mode used in opening a file.
Public Property FilePointerID | Read/Write: Name of file pointer used in referencing file Represents the file pointer Id to be used in the File I/O operation. The file pointer ID is established and linked to a specific file in the File Open command.
Public Property VariableID | Read/Write: ID of variable that stores result of file command execution Represents the name of the variable to be used to hold the results of the File I/O operation of the File I/O command.

See Also

FileIO Overview


BufferSize Property

BufferSize Property

Description

Read/Write: Buffersize used in ReadBlock command Indicates the buffer size used with the Read Block File I/O command.

Property type

Read-write property

Syntax

Visual Basic
Public Property BufferSize() As Long

Return Type

Read/write Long value.

See Also

FileIO Object


Expression Property

Expression Property

Description

Read/Write: Expression to read to or write from file Indicates the buffer size used with the Read Block File I/O command.

Property type

Read-write property

Syntax

Visual Basic
Public Property Expression() As String

Return Type

Read/write Long value.

See Also

FileIO Object


FailIfExists Property

FailIfExists Property

Description

Read/Write: Indicates whether copy fails if destination file already exists Indicates whether or not a file copy operation should fail or not if the destination file already exists.

Property type

Read-write property

Syntax

Visual Basic
Public Property FailIfExists() As Boolean

Return Type

Read/write Boolean.

See Also

FileIO Object


FileIOType Property

FileIOType Property

Description

Read/Write: The File IO type (ie. Open, Close, etc.) Value of ENUM_FILE_IO_TYPES enumeration type which specifies the type of File I/O operation the object will perform.

Property type

Read-write property

Syntax

Visual Basic
Public Property FileIOType() As ENUM_FILE_IO_TYPES

Remarks

Value of ENUM_FILE_IO_TYPES enumeration type which specifies the type of File I/O operation the object will perform. Possible values include the following:

  • PCD_FILE_OPEN = 0
  • PCD_FILE_CLOSE = 1
  • PCD_FILE_WRITELINE = 2
  • PCD_FILE_READLINE = 3
  • PCD_FILE_WRITECHARACTER = 4
  • PCD_FILE_READCHARACTER = 5
  • PCD_FILE_WRITEBLOCK = 6
  • PCD_FILE_READBLOCK = 7
  • PCD_FILE_REWIND = 8
  • PCD_FILE_SAVEPOSITION = 9
  • PCD_FILE_RECALLPOSITION = 10
  • PCD_FILE_COPY = 11
  • PCD_FILE_MOVE = 12
  • PCD_FILE_DELETE = 13
  • PCD_FILE_EXISTS = 14
  • PCD_FILE_DIALOG = 15

Read/write Enum_File_IO_Types enumeration.

See Also

FileIO Object


FileName1 Property

FileName1 Property

Description

Read/Write: Filename

Represents the file name to be used in the File I/O operation. This parameter is used with the File Open, File Copy, File Move, File Delete, and File Exists File I/O types.

Property type

Read-write property

Syntax

Visual Basic
Public Property FileName1() As String

Return Type

Read/write String value.

See Also

FileIO Object


FileName2 Property

FileName2 Property

Description

Read/Write: Filename two Represents the second filename to be used in the File I/O operation. This parameter is used as the destination file in the File Copy and File Move File I/O commands.

Property type

Read-write property

Syntax

Visual Basic
Public Property FileName2() As String

Return Type

Read/write String value.

See Also

FileIO Object


FileOpenType Property

FileOpenType Property

Description

Read/Write: File Open Type (ie. Read, Write, Append) Value of ENUM_FILE_OPEN_TYPES enumeration type which specifies the file open mode used in opening a file.

Property type

Read-write property

Syntax

Visual Basic
Public Property FileOpenType() As ENUM_FILE_OPEN_TYPES

Return Type

Read/write Enum_File_Open_Types enumeration.

See Also

FileIO Object


FilePointerID Property

FilePointerID Property

Description

Read/Write: Name of file pointer used in referencing file Represents the file pointer Id to be used in the File I/O operation. The file pointer ID is established and linked to a specific file in the File Open command.

Property type

Read-write property

Syntax

Visual Basic
Public Property FilePointerID() As String

Return Type

Read/write String value.

See Also

FileIO Object


VariableID Property

VariableID Property

Description

Read/Write: ID of variable that stores result of file command execution Represents the name of the variable to be used to hold the results of the File I/O operation of the File I/O command.

Property type

Read-write property

Syntax

Visual Basic
Public Property VariableID() As String

Return Type

Read/write String value.

See Also

FileIO Object


FlowControlCmd Object

FlowControlCmd Object
See Also Members

Description

FlowControlCmd objects are created from more generic Command objects to pass information specific to the flow control command back and forth.

See Also

FlowControlCmd Members


FlowControlCmd Object Members

FlowControlCmd ObjectMembers
See Also Overview

Public Methods

Public Method AddArgument | Adds argument to argument list Adds or replaces an argument in objects of type CALL_SUBROUTINE and START_SUBROUTINE. When used with objects of other types, it has no effect.
Public Method AddSkipNum Adds skip number to loop skip list

Adds a number to be skipped to an object of type LOOP_START. For objects of other types, it does nothing.

This function returns TRUE if Number was successfully added to the LOOP_START object’s skip list, FALSE otherwise.

Public Method GetArgumentDescription | Gets description of specified argument Returns the description of an argument to an object of type START_SUBROUTINE. For objects of other types, it returns the empty string.
Public Method GetArgumentExpression | Gets expression text of specified argument Returns the value or default value of an argument to an object of type CALL_SUBROUTINE or START_SUBROUTINE, respectively. For objects of other types, it returns the empty string.
Public Method GetArgumentName | Returns name of specified argument Returns the name of an argument to an object of type START_SUBROUTINE. For objects of other types, it returns the empty string.
Public Method GetLeftSideOfExpression | Gets expression text for left side of assignment For FlowControlCmd objects of type ASSIGNMENT, this function returns the name of the variable being assigned to. For other types of objects, it returns an empty string.
Public Method GetRightSideOfExpression | Gets expression text for right side of assignment For FlowControlCmd objects of type ASSIGNMENT, this function returns the value being assigned to the variable. For other types of objects, it returns an empty string.
Public Method GetSkipNum | Get skip number value This function returns an integer. The integer is the nth skip number where n is indicated by the value of index.
Public Method IsExpressionValid | Determines whether provided expression text is valid Tests whether or not the Expression is valid.
Public Method IsValidLeftHandValue Determines if expression if a valid expression for left side of assignment command

This function returns TRUE if the expression can be used as a valid left hand value (i.e. can be used on the left-hand side of an assigment statement), and FALSE otherwise.

Public Method IsValidSubroutineArgumentName Determines if expression a is valid name for subroutine argument

This function returns TRUE if the expression can be used as a valid suroutine argument name, and FALSE otherwise.

Public Method RemoveArgument Removes argument

This function removes an argument from an object of type CALL_SUBROUTINE or START_SUBROUTINE. It returns TRUE if an argument is removed successfully, FALSE otherwise.

Public Method RemoveSkipNum | Remove skip number This function removes one of the skip numbers for the Loop Start object from the list of skip numbers. The number removed is determined by the index parameter.
Public Method SetArgumentDescription | Sets description of specified argument This function sets the description of an argument of an object of type START_SUBROUTINE. It does nothing and returns FALSE if the object is not of this type. The function returns TRUE if the description was set successfully, FALSE otherwise.
Public Method SetArgumentExpression | Sets expression text of specified argument This function sets the value or default value of an argument of an object of type CALL_SUBROUTINE or START_SUBROUTINE, respectively. It does nothing and returns FALSE if the object is not one of these types.
Public Method SetArgumentName | Sets name of specified argument This function sets the name of an argument of an object of type START_SUBROUTINE. It does nothing and returns FALSE if the object is not of this type.
Public Method SetLeftSideOfAssignment | Sets expression for left side of assignment command The function sets the left-hand side of the Assign statement to the expression passed in. Use the function IsValidLeftHandValue to determine validity of expression for a left-hand side before using this function.
Public Method SetRightSideOfAssignment | Sets expression for right side of assignment command The function sets the right-hand side of the Assign statement to the expression passed in. Use the function IsExpressionValid to determine validity of expression before using this function.

Public Properties

Public Property AngleOffset | Read/Write: Loop Angle Offset Represents the angular offset of a LOOP_START object.
Public Property EndNum | Read/Write: Loop Ending Number
Public Property ErrorMode | Read/Write: On Error Error Mode Represents the error mode of a ONERROR object.
Public Property ErrorType | Read/Write: On Error Error Type Represents the error mode of a ONERROR object.
Public Property Expression | Read/Write: Expression Represents the test expression of an IF_COMMAND object.
Public Property FileName | Read/Write: Filename Represents the file name of an external subroutine in a CALL_SUBROUTINE object.
Public Property ID | Read/Write: Flow Control Command ID Represents the id of a CALL_SUBROUTINE object.
Public Property Label | Read/Write: Label ID Represents the label associated with an object.
Public Property NumArguments | Read Only: Number of Arguments Returns the number of arguments in a START_SUBROUTINE or CALL_SUBROUTINE object.
Public Property ReportAutoPrint | Read/Write: Hyper Report Auto Print Setting Returns True if you have Hyper Report's Auto Print checkbox selected. False otherwise.
Public Property SkipCount | Read Only: Number of skip numbers in loop command Returns the number of skipped numbers in a LOOP_START object.
Public Property StartNum | Read/Write: Loop Starting Number Represents the start number of a LOOP_START object.
Public Property SubName | Read/Write: Subroutine Name Represents the subroutine name of a START_SUBROUTINE and CALL_SUBROUTINE object.
Public Property XAxisOffset | Read/Write: Loop X Axis Offset Represents the X-axis offset of a LOOP_START object.
Public Property YAxisOffset | Read/Write: Loop Y Axis Offset Represents the Y-axis offset of a LOOP_START object.
Public Property ZAxisOffset | Read/Write: Loop Z Axis Offset Represents the Z-axis offset of a LOOP_START object.

See Also

FlowControlCmd Overview


AddArgument Method

AddArgument Method
Position
Required Long that indicates the index of the argument to add in the list of arguments.
Argument
Name
Required String that indicates the name of the argument to be added.
DESCRIPTION
Required String that is the description of the argument to be added.

Description

Adds argument to argument list Adds or replaces an argument in objects of type CALL_SUBROUTINE and START_SUBROUTINE. When used with objects of other types, it has no effect.

Syntax

Visual Basic
Public Function AddArgument( _
   ByVal Position As Long, _
   ByVal Argument As String, _
   ByVal Name As String, _
   ByVal DESCRIPTION As String _
) As Boolean

Parameters

Position
Required Long that indicates the index of the argument to add in the list of arguments.
Argument
Name
Required String that indicates the name of the argument to be added.
DESCRIPTION
Required String that is the description of the argument to be added.

Return Type

Boolean value. This function returns TRUE if the argument was added successfully, FALSE otherwise.

Remarks

When used with objects of type CALL_SUBROUTINE, the Name and Description fields are ignored.

If Position is equal to 1 + FlowControlCmd.NumArguments, an argument is added to the tail of the list of arguments. If Position is between 1 and FlowControlCmd.NumArguments, the current argument is replaced. To completely remove an argument, use DimensionCommand.RemoveArgument.

See Also

FlowControlCmd Object | Type Property | RemoveArgument Method | NumArguments Property


AddSkipNum Method

AddSkipNum Method
Number
Required Long that indicates the number to skip.

Description

Adds skip number to loop skip list

Adds a number to be skipped to an object of type LOOP_START. For objects of other types, it does nothing.

This function returns TRUE if Number was successfully added to the LOOP_START object’s skip list, FALSE otherwise.

Syntax

Visual Basic
Public Function AddSkipNum( _
   ByVal Number As Long _
) As Boolean

Parameters

Number
Required Long that indicates the number to skip.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

FlowControlCmd Object | Type Property


GetArgumentDescription Method

GetArgumentDescription Method
Position
Required Long that indicates the number of the argument from which to obtain the description.

Description

Gets description of specified argument Returns the description of an argument to an object of type START_SUBROUTINE. For objects of other types, it returns the empty string.

Syntax

Visual Basic
Public Function GetArgumentDescription( _
   ByVal Position As Long _
) As String

Parameters

Position
Required Long that indicates the number of the argument from which to obtain the description.

Return Type

String value.

See Also

FlowControlCmd Object | Type Property


GetArgumentExpression Method

GetArgumentExpression Method
Position
Required Long that indicates the number of the argument from which to obtain the argument's value.

Description

Gets expression text of specified argument Returns the value or default value of an argument to an object of type CALL_SUBROUTINE or START_SUBROUTINE, respectively. For objects of other types, it returns the empty string.

Syntax

Visual Basic
Public Function GetArgumentExpression( _
   ByVal Position As Long _
) As String

Parameters

Position
Required Long that indicates the number of the argument from which to obtain the argument's value.

Return Type

String value.

See Also

FlowControlCmd Object | Type Property


GetArgumentName Method

GetArgumentName Method
Position
Required Long that indicates the number of the argument from which to obtain the argument's name.

Description

Returns name of specified argument Returns the name of an argument to an object of type START_SUBROUTINE. For objects of other types, it returns the empty string.

Syntax

Visual Basic
Public Function GetArgumentName( _
   ByVal Position As Long _
) As String

Parameters

Position
Required Long that indicates the number of the argument from which to obtain the argument's name.

Return Type

String value.

See Also

FlowControlCmd Object | Type Property


GetLeftSideOfExpression Method

GetLeftSideOfExpression Method

Description

Gets expression text for left side of assignment For FlowControlCmd objects of type ASSIGNMENT, this function returns the name of the variable being assigned to. For other types of objects, it returns an empty string.

Syntax

Visual Basic
Public Function GetLeftSideOfExpression() As String

Return Type

String value.

See Also

FlowControlCmd Object | Type Property


GetRightSideOfExpression Method

GetRightSideOfExpression Method

Description

Gets expression text for right side of assignment For FlowControlCmd objects of type ASSIGNMENT, this function returns the value being assigned to the variable. For other types of objects, it returns an empty string.

Syntax

Visual Basic
Public Function GetRightSideOfExpression() As String

Return Type

String value.

See Also

FlowControlCmd Object | Type Property


GetSkipNum Method

GetSkipNum Method
index
Required Long that indicates which skip number of the set of skip numbers to retrieve.

Description

Get skip number value This function returns an integer. The integer is the nth skip number where n is indicated by the value of index.

Syntax

Visual Basic
Public Function GetSkipNum( _
   ByVal index As Long _
) As Long

Parameters

index
Required Long that indicates which skip number of the set of skip numbers to retrieve.

Return Type

Integer value.

See Also

FlowControlCmd Object | Type Property


IsExpressionValid Method

IsExpressionValid Method
Expression
Required String that is the expression to evaluate for validity.

Description

Determines whether provided expression text is valid Tests whether or not the Expression is valid.

Syntax

Visual Basic
Public Function IsExpressionValid( _
   ByVal Expression As String _
) As Boolean

Parameters

Expression
Required String that is the expression to evaluate for validity.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

FlowControlCmd Object | Type Property


IsValidLeftHandValue Method

IsValidLeftHandValue Method
Expression
Required String that is the expression to evaluate for validity.

Description

Determines if expression if a valid expression for left side of assignment command

This function returns TRUE if the expression can be used as a valid left hand value (i.e. can be used on the left-hand side of an assigment statement), and FALSE otherwise.

Syntax

Visual Basic
Public Function IsValidLeftHandValue( _
   ByVal Expression As String _
) As Boolean

Parameters

Expression
Required String that is the expression to evaluate for validity.

Return Type

Boolean value.

See Also

FlowControlCmd Object


IsValidSubroutineArgumentName Method

IsValidSubroutineArgumentName Method
Expression
Required String that is the argument name to evaluate for validity.

Description

Determines if expression a is valid name for subroutine argument

This function returns TRUE if the expression can be used as a valid suroutine argument name, and FALSE otherwise.

Syntax

Visual Basic
Public Function IsValidSubroutineArgumentName( _
   ByVal Expression As String _
) As Boolean

Parameters

Expression
Required String that is the argument name to evaluate for validity.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

FlowControlCmd Object


RemoveArgument Method

RemoveArgument Method
Position
Required Long that indicates which argument to remove. This argument should be between one and FlowControlCmd.NumArguments.

Description

Removes argument

This function removes an argument from an object of type CALL_SUBROUTINE or START_SUBROUTINE. It returns TRUE if an argument is removed successfully, FALSE otherwise.

Syntax

Visual Basic
Public Function RemoveArgument( _
   ByVal Position As Long _
) As Boolean

Parameters

Position
Required Long that indicates which argument to remove. This argument should be between one and FlowControlCmd.NumArguments.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

This function has an effect only on objects of type CALL_SUBROUTINE and START_SUBROUTINE. It has no effect on objects of other types. If used on other types it returns FALSE even if nothing is being done.

See Also

FlowControlCmd Object | Type Property | NumArguments Property


RemoveSkipNum Method

RemoveSkipNum Method
index
Required Long that indicates which argument to remove. This argument should be between one and FlowControlCmd.SkipCount.

Description

Remove skip number This function removes one of the skip numbers for the Loop Start object from the list of skip numbers. The number removed is determined by the index parameter.

Syntax

Visual Basic
Public Function RemoveSkipNum( _
   ByVal index As Long _
) As Boolean

Parameters

index
Required Long that indicates which argument to remove. This argument should be between one and FlowControlCmd.SkipCount.

Return Type

Read/write Boolean value.

See Also

FlowControlCmd Object | SkipCount Property


SetArgumentDescription Method

SetArgumentDescription Method
Position
Required Long that indicates the number of the argument description to set.
DESCRIPTION
Required String that is the text of the description to set.

Description

Sets description of specified argument This function sets the description of an argument of an object of type START_SUBROUTINE. It does nothing and returns FALSE if the object is not of this type. The function returns TRUE if the description was set successfully, FALSE otherwise.

Syntax

Visual Basic
Public Function SetArgumentDescription( _
   ByVal Position As Long, _
   ByVal DESCRIPTION As String _
) As Boolean

Parameters

Position
Required Long that indicates the number of the argument description to set.
DESCRIPTION
Required String that is the text of the description to set.

Return Type

Boolean value.

See Also

FlowControlCmd Object


SetArgumentExpression Method

SetArgumentExpression Method
Position
Required Long that indicates the number of the argument value to set.
Expression
Required String that indicates the argument value to set.

Description

Sets expression text of specified argument This function sets the value or default value of an argument of an object of type CALL_SUBROUTINE or START_SUBROUTINE, respectively. It does nothing and returns FALSE if the object is not one of these types.

Syntax

Visual Basic
Public Function SetArgumentExpression( _
   ByVal Position As Long, _
   ByVal Expression As String _
) As Boolean

Parameters

Position
Required Long that indicates the number of the argument value to set.
Expression
Required String that indicates the argument value to set.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

FlowControlCmd Object | Type Property


SetArgumentName Method

SetArgumentName Method
Position
Required Long that indicates the number of the argument value to set.
Name
Required String that indicates the argument name to set.

Description

Sets name of specified argument This function sets the name of an argument of an object of type START_SUBROUTINE. It does nothing and returns FALSE if the object is not of this type.

Syntax

Visual Basic
Public Function SetArgumentName( _
   ByVal Position As Long, _
   ByVal Name As String _
) As Boolean

Parameters

Position
Required Long that indicates the number of the argument value to set.
Name
Required String that indicates the argument name to set.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

FlowControlCmd Object | Type Property


SetLeftSideOfAssignment Method

SetLeftSideOfAssignment Method
Expression
Required String that indicates the expression to be used for the left side of the assigment.

Description

Sets expression for left side of assignment command The function sets the left-hand side of the Assign statement to the expression passed in. Use the function IsValidLeftHandValue to determine validity of expression for a left-hand side before using this function.

Syntax

Visual Basic
Public Sub SetLeftSideOfAssignment( _
   ByVal Expression As String _
)

Parameters

Expression
Required String that indicates the expression to be used for the left side of the assigment.

Return Type

String value.

See Also

FlowControlCmd Object | Type Property


SetRightSideOfAssignment Method

SetRightSideOfAssignment Method
Expression
Required String that indicates the expression to be used for the right side of the assigment.

Description

Sets expression for right side of assignment command The function sets the right-hand side of the Assign statement to the expression passed in. Use the function IsExpressionValid to determine validity of expression before using this function.

Syntax

Visual Basic
Public Sub SetRightSideOfAssignment( _
   ByVal Expression As String _
)

Parameters

Expression
Required String that indicates the expression to be used for the right side of the assigment.

Return Type

String value.

See Also

FlowControlCmd Object | Type Property


AngleOffset Property

AngleOffset Property

Description

Read/Write: Loop Angle Offset Represents the angular offset of a LOOP_START object.

Property type

Read-write property

Syntax

Visual Basic
Public Property AngleOffset() As Double

Return Type

Read/write Double value.

Remarks

This property only affects objects of type LOOP_START. For other objects, setting the property has no effect, and getting it always returns zero.

See Also

FlowControlCmd Object | Type Property


EndNum Property

EndNum Property

Description

Read/Write: Loop Ending Number

Property type

Read-write property

Syntax

Visual Basic
Public Property EndNum() As Long

See Also

FlowControlCmd Object


ErrorMode Property

ErrorMode Property

Description

Read/Write: On Error Error Mode Represents the error mode of a ONERROR object.

Property type

Read-write property

Syntax

Visual Basic
Public Property ErrorMode() As ENUM_ERROR_MODES

Return Type

Read/write Long.

Remarks

This property only affects objects of type ONERROR. For other objects, setting the property has no effect, and getting it always returns zero.

The valid values for ErrorMode: 0 for off, 1 for jump to label, and 2 for set a variable.

See Also

FlowControlCmd Object | Type Property


ErrorType Property

ErrorType Property

Description

Read/Write: On Error Error Type Represents the error mode of a ONERROR object.

Property type

Read-write property

Syntax

Visual Basic
Public Property ErrorType() As ENUM_ERROR_TYPES

Return Type

Read/write Long value.

Remarks

This property only affects objects of type ONERROR. For other objects, setting the property has no effect, and getting it always returns zero.

The valid values for ErrorMode: 0 for off, 1 for jump to label, and 2 for set a variable.

See Also

FlowControlCmd Object | Type Property


Expression Property

Expression Property

Description

Read/Write: Expression Represents the test expression of an IF_COMMAND object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Expression() As String

Return Type

Read/write String.

Remarks

This property only affects objects of type IF_COMMAND. For other objects, setting the property has no effect, and getting it always returns the empty string.

See Also

FlowControlCmd Object | Type Property


FileName Property

FileName Property

Description

Read/Write: Filename Represents the file name of an external subroutine in a CALL_SUBROUTINE object.

Property type

Read-write property

Syntax

Visual Basic
Public Property FileName() As String

Return Type

Read/write String.

Remarks

This property only affects objects of type CALL_SUBROUTINE. For other objects, setting the property has no effect, and getting it always returns the empty string.

This property only returns the name of the file, not its full path. The path is determined by the settings in PC-DMIS’s Search Directory dialog.

See Also

FlowControlCmd Object | Type Property


ID Property

ID Property

Description

Read/Write: Flow Control Command ID Represents the id of a CALL_SUBROUTINE object.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As String

Return Type

Read/write String.

Remarks

This property only affects objects of type CALL_SUBROUTINE. For other objects, setting the property has no effect, and getting it always returns the empty string.

See Also

FlowControlCmd Object | Type Property


Label Property

Label Property

Description

Read/Write: Label ID Represents the label associated with an object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Label() As String

Return Type

Read/write String.

Remarks

This property only affects objects of type GOTO, IF_COMMAND, ONERROR, and LABEL. For other objects, setting the property has no effect, and getting it always returns the empty string.

For objects of type LABEL, this property is the id of the object. For the other valid types, this property is the label to which execution is redirected when the appropriate conditions are met. For GOTO, redirection always occurs. For IF_COMMAND, the redirection occurs only when the expression is TRUE. For ONERROR, the redirection happens when the error condition is met.

See Also

FlowControlCmd Object | Type Property


NumArguments Property

NumArguments Property

Description

Read Only: Number of Arguments Returns the number of arguments in a START_SUBROUTINE or CALL_SUBROUTINE object.

Property type

Read-write property

Syntax

Visual Basic
Public Property NumArguments() As Long

Return Type

Read only Long value.

Remarks

This property only affects objects of type START_SUBROUTINE and CALL_SUBROUTINE. For other objects it always returns zero.

See Also

FlowControlCmd Object | Type Property


ReportAutoPrint Property

ReportAutoPrint Property

Description

Read/Write: Hyper Report Auto Print Setting Returns True if you have Hyper Report's Auto Print checkbox selected. False otherwise.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReportAutoPrint() As Boolean

Return Type

Boolean value.

See Also

FlowControlCmd Object | Type Property


SkipCount Property

SkipCount Property

Description

Read Only: Number of skip numbers in loop command Returns the number of skipped numbers in a LOOP_START object.

Property type

Read-write property

Syntax

Visual Basic
Public Property SkipCount() As Long

Return Type

Read-only Long value.

Remarks

This property only affects objects of type LOOP_START. For other objects it always returns zero.

See Also

FlowControlCmd Object | Type Property


StartNum Property

StartNum Property

Description

Read/Write: Loop Starting Number Represents the start number of a LOOP_START object.

Property type

Read-write property

Syntax

Visual Basic
Public Property StartNum() As Long

Return Type

Read/write Long value.

Remarks

This property only affects objects of type LOOP_START. For other objects, setting the property has no effect, and getting it always returns zero.

See Also

FlowControlCmd Object | Type Property


SubName Property

SubName Property

Description

Read/Write: Subroutine Name Represents the subroutine name of a START_SUBROUTINE and CALL_SUBROUTINE object.

Property type

Read-write property

Syntax

Visual Basic
Public Property SubName() As String

Return Type

Read/write String value.

Remarks

This property only affects objects of type START_SUBROUTINE and CALL_SUBROUTINE. For other objects, setting the property has no effect, and getting it always returns the empty string.

For the START_SUBROUTINE object, it is the name of the subroutine. For the CALL_SUBROUTINE, it is the name of the called subroutine.

See Also

FlowControlCmd Object | Type Property


XAxisOffset Property

XAxisOffset Property

Description

Read/Write: Loop X Axis Offset Represents the X-axis offset of a LOOP_START object.

Property type

Read-write property

Syntax

Visual Basic
Public Property XAxisOffset() As Double

Return Type

Read/write Long value.

Remarks

This property only affects objects of type LOOP_START. For other objects, setting the property has no effect, and getting it always returns zero.

See Also

FlowControlCmd Object | Type Property


YAxisOffset Property

YAxisOffset Property

Description

Read/Write: Loop Y Axis Offset Represents the Y-axis offset of a LOOP_START object.

Property type

Read-write property

Syntax

Visual Basic
Public Property YAxisOffset() As Double

Return Type

Read/write Long value.

Remarks

This property only affects objects of type LOOP_START. For other objects, setting the property has no effect, and getting it always returns zero.

See Also

FlowControlCmd Object | Type Property


ZAxisOffset Property

ZAxisOffset Property

Description

Read/Write: Loop Z Axis Offset Represents the Z-axis offset of a LOOP_START object.

Property type

Read-write property

Syntax

Visual Basic
Public Property ZAxisOffset() As Double

Return Type

Read/write Long value.

Remarks

This property only affects objects of type LOOP_START. For other objects, setting the property has no effect, and getting it always returns zero.

See Also

FlowControlCmd Object | Type Property


FPanel Object

FPanel Object
See Also Members

Description

The FPanel object contains properties that allow you to work with an F-Panel controller and interface.

Object Model

See Also

FPanel Members


FPanel Object Members

FPanel ObjectMembers
See Also Overview

Public Properties

Public Property PanelSelector | Write Only: Let PC-DMIS know the state of the panel selector This write-only property allows you to set whether the F-Panel is in automatic or manual mode.
Public Property Parent | Read Only: Returns Machine pointer This read-only property returns the parent Machine object from which the FPanel object was created.

See Also

FPanel Overview


PanelSelector Property

PanelSelector Property

Description

Write Only: Let PC-DMIS know the state of the panel selector

This write-only property allows you to set whether the F-Panel is in automatic or manual mode.

Property type

Read-write property

Syntax

Visual Basic
Public Property PanelSelector() As Long

Remarks

For Manual, set PanelSelector equal to 1

For Automatic, set PanelSelector equal to 2

Two different computers control the FPanel interface. In the original DEA software, these computers talked to each other and passed this parameter around on their own. PC-DMIS, however, only reads from one computer, and so you need to let PC-DMIS know whether or not the other controller is set to manual or automatic mode. You should be able to look and see on the panel in front of them whether they are in manual or automatic mode. Once you let PC-DMIS know by setting this property to either 1 or 2, PC-DMIS passes the information to the other controller and changes its status.

See Also

FPanel Object


Parent Property

Parent Property

Description

Read Only: Returns Machine pointer This read-only property returns the parent Machine object from which the FPanel object was created.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Machine

Return Type

Machine object.

See Also

FPanel Object


LabelControls Object

LabelControls Object
See Also Members

Description

The LabelControls object gives you access to a variety of controls such as buttons, text boxes, and other items that you can add to, remove, and otherwise manipulate on a label template.

Object Model

See Also

LabelControls Members


LabelControls Object Members

LabelControls ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method Add | Adds a new control to the label template The Add function creates a new Label template in PC-DMIS.
Public Method Item | returns the given named or numbered control This method returns an Object of the control identified by the name or number in the NameOrNum parameter.
Public Method Remove | Removes the specified named or numbered control from the label template This deletes the specified control from the current label template.

Public Properties

Public Property Application | Read Only: Returns the Application Object This property returns the PC-DMIS Application object.
Public Property Count | Read Only: Number of report controls on section/page This property counts all the controls in the current label template and returns it as a Long value.
Public Property Parent | Read Only: Returns the parent Feature Object This property returns this object's parent object, the LabelTemplate object.

See Also

LabelControls Overview


_Item Method

_Item Method
NameOrNumber

Syntax

Visual Basic
Public Function _Item( _
   ByVal NameOrNumber As Variant _
) As Object

Parameters

NameOrNumber

See Also

LabelControls Object


Add Method

Add Method
ObjectType
This can be an a constant value or an enumerated value.
Left
This Long value sets the location of the left side of the control from the left side of the editor.
Top
This Long value sets the top location of the control from the top side of the editor.
Right
This Long value sets the right location of the control from the left side of the editor.
Bottom
This Long value sets the bottom location of the control from the top side of the editor.

Description

Adds a new control to the label template The Add function creates a new Label template in PC-DMIS.

Syntax

Visual Basic
Public Function Add( _
   ByVal ObjectType As ENUM_REPORT_TEMPLATE_OBJECTS, _
   ByVal Left As Long, _
   ByVal Top As Long, _
   ByVal Right As Long, _
   ByVal Bottom As Long _
) As Object

Parameters

ObjectType
Value Description
ID_HOB_TEXT
ID_HOB_TEXT_RT
ID_HOB_LINE
ID_HOB_POLYLINE
ID_HOB_BORDER
ID_HOB_ARC
ID_HOB_CIRCLE
ID_HOB_BITMAP
ID_HOB_PTR
ID_HOB_GAUGE
ID_HOB_GRAPH
ID_HOB_PCD_TEXT_REPORT_OBJECT
ID_HOB_PCD_CAD_REPORT_OBJECT
ID_HOB_PCD_COMMAND_TEXT_OB
ID_HOB_PCD_GRID_CTRL_OB
ID_HOB_PCD_LEADERLINE_OB
ID_HOB_PCD_DIMCOLOR_OB
ID_HOB_PCD_ANALWIN_OB
ID_HOB_CADIMAGEOBJECT_OB
ID_HOB_PCD_SPC_CHART_OB
ID_HOB_PCD_LABEL_OB
This can be an a constant value or an enumerated value.
Left
This Long value sets the location of the left side of the control from the left side of the editor.
Top
This Long value sets the top location of the control from the top side of the editor.
Right
This Long value sets the right location of the control from the left side of the editor.
Bottom
This Long value sets the bottom location of the control from the top side of the editor.

Remarks

The Add method inserts a new control of a defined location and size into the current label template. To find out what properties are available to a control, in PC-DMIS's Label Template editor, insert the control and then access its properties sheet.

Example

Private Sub Add_Arc()

Set ArcControl = LabelObjects.Add(ID_HOB_ARC, 10, 10, 200, 200)

ArcControl.Bottom = 100

ArcControl.Left = 10

ArcControl.LineStyle = 2

ArcControl.LineWidth = 1

ArcControl.Right = 790

ArcControl.Top = 20

ArcControl.Visible = False

End Sub

See Also

LabelControls Object


Item Method

Item Method
NameOrNumber
Required Variant that indicates which control to return. It can be either a Long or a String. If it is a Long, it is the index number given the control within the LabelControls collection of controls. If it is a String, it is the ID, (or ObjectCode property in the template editor) of the control.

Description

returns the given named or numbered control This method returns an Object of the control identified by the name or number in the NameOrNum parameter.

Syntax

Visual Basic
Public Function Item( _
   ByVal NameOrNumber As Variant _
) As Object

Parameters

NameOrNumber
Required Variant that indicates which control to return. It can be either a Long or a String. If it is a Long, it is the index number given the control within the LabelControls collection of controls. If it is a String, it is the ID, (or ObjectCode property in the template editor) of the control.

Return Type

The Item method returns an Object of the control with the given name or number.

Remarks

This method returns an Object of the control identified by the name or number in the NameOrNum parameter.

To manipulate existing label template objects, you will need use this method. Once you establish a pointer to an object, you can get or set any of its properties (similar to the LabelControls.Add method). To find the available properties, consult the dockable Properties dialog box inside PC-DMIS.

See Also

LabelControls Object | Add Method


Remove Method

Remove Method
NameOrNumber
Required Variant that indicates which control to remove. It can be either a Long or a String. If it is a Long, it is the index number given the control within the LabelControls collection of controls. If it is a String, it is the ID, (or ObjectCode property in the template editor) of the control.

Description

Removes the specified named or numbered control from the label template

This deletes the specified control from the current label template.

Syntax

Visual Basic
Public Function Remove( _
   ByVal NameOrNumber As Variant _
) As Long

Parameters

NameOrNumber
Required Variant that indicates which control to remove. It can be either a Long or a String. If it is a Long, it is the index number given the control within the LabelControls collection of controls. If it is a String, it is the ID, (or ObjectCode property in the template editor) of the control.

Return Type

Boolean value containing the result of the removal. If True, the control was removed. If False, it wasn't.

See Also

LabelControls Object


Application Property

Application Property

Description

Read Only: Returns the Application Object This property returns the PC-DMIS Application object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

LabelControls Object


Count Property

Count Property

Description

Read Only: Number of report controls on section/page This property counts all the controls in the current label template and returns it as a Long value.

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

Return Type

Long value.

See Also

LabelControls Object


Parent Property

Parent Property

Description

Read Only: Returns the parent Feature Object

This property returns this object's parent object, the LabelTemplate object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As LabelTemplate

See Also

LabelControls Object


LabelTemplate Object

LabelTemplate Object
See Also Members

Description

The LabelTemplate object allows you to get or set various settings for a label template.

Object Model

See Also

LabelTemplate Members


LabelTemplate Object Members

LabelTemplate ObjectMembers
See Also Overview

Public Methods

Public Method Close | Closes the label template This subroutine closes the label template. To first save any unsaved changes, use the Save method.
Public Method Save | Saves the label template This subroutine saves the label template with it's already existing name. If the template has not been saved before use the SaveAs method instead, and specify a filename.
Public Method SaveAs | Saves the label template with the given file name This method saves the label template.

Public Properties

Public Property _Name |
Public Property Application | Read Only: Returns the Application Object This property represents the read-only PC-DMIS Application object. The Application object includes properties and methods that return top-level objects.
Public Property FullName | Read Only: Returns the full path name This property returns a read-only string of the full path and filename of the label template.
Public Property LabelControls | Read Only: returns the ReportControls object for this label template This property returns a read-only LabelControls object for this label template.
Public Property Name | Read Only: Returns the file name This property returns a read-only string of the label template's filename.
Public Property Parent | Read Only: Returns the parent Reports Object This property returns the label template's parent object, which is the read-only LabelTemplates object.
Public Property Visible | Read/Write: Returns/Sets template editor visibility status This returns or sets the visibility status of the Label Template editor. If True then it is visible, if False then it is hidden.

See Also

LabelTemplate Overview


Close Method

Close Method

Description

Closes the label template This subroutine closes the label template. To first save any unsaved changes, use the Save method.

Syntax

Visual Basic
Public Sub Close()

See Also

LabelTemplate Object


Save Method

Save Method

Description

Saves the label template This subroutine saves the label template with it's already existing name. If the template has not been saved before use the SaveAs method instead, and specify a filename.

Syntax

Visual Basic
Public Function Save() As Boolean

Return Type

Boolean value. It returns True if the template was saved, or False if not.

See Also

LabelTemplate Object | SaveAs Method


SaveAs Method

SaveAs Method
FileName
Required expression that evaluates to a String. This is the pathway and file name to which you will save the label template.

Description

Saves the label template with the given file name

This method saves the label template.

Syntax

Visual Basic
Public Function SaveAs( _
   ByVal FileName As String _
) As Boolean

Parameters

FileName
Required expression that evaluates to a String. This is the pathway and file name to which you will save the label template.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails. TRUE if the part was saved successfully, FALSE otherwise.

See Also

LabelTemplate Object


_Name Property

_Name Property

Property type

Read-write property

Syntax

Visual Basic
Public Property _Name() As String

See Also

LabelTemplate Object


Application Property

Application Property

Description

Read Only: Returns the Application Object This property represents the read-only PC-DMIS Application object. The Application object includes properties and methods that return top-level objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

LabelTemplate Object


FullName Property

FullName Property

Description

Read Only: Returns the full path name This property returns a read-only string of the full path and filename of the label template.

Property type

Read-write property

Syntax

Visual Basic
Public Property FullName() As String

Return Type

Read-only String value.

See Also

LabelTemplate Object


LabelControls Property

LabelControls Property

Description

Read Only: returns the ReportControls object for this label template This property returns a read-only LabelControls object for this label template.

Property type

Read-write property

Syntax

Visual Basic
Public Property LabelControls() As LabelControls

Return Type

Read-only LabelControls object.

See Also

LabelTemplate Object


Name Property

Name Property

Description

Read Only: Returns the file name This property returns a read-only string of the label template's filename.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As String

Return Type

Read-only String.

See Also

LabelTemplate Object


Parent Property

Parent Property

Description

Read Only: Returns the parent Reports Object This property returns the label template's parent object, which is the read-only LabelTemplates object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As LabelTemplates

Return Type

LabelTemplates object.

See Also

LabelTemplate Object


Visible Property

Visible Property

Description

Read/Write: Returns/Sets template editor visibility status This returns or sets the visibility status of the Label Template editor. If True then it is visible, if False then it is hidden.

Property type

Read-write property

Syntax

Visual Basic
Public Property Visible() As Boolean

Return Type

Boolean value.

See Also

LabelTemplate Object


LabelTemplates Object

LabelTemplates Object
See Also Members

Description

The LabelTemplates object contains all open label templates in PC-DMIS's Label Template editor.

Object Model

Remarks

Use Add.Label to create a new label template and add it to the LabelTemplates collection.

Use LabelTemplates(index) where index is the label template name or index number to access an individual label template.

Example

See Also

LabelTemplates Members


LabelTemplates Object Members

LabelTemplates ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method Add | Creates a new label template The Add function creates a new Label template in PC-DMIS.
Public Method Item | Returns the label template with the given name or number Item function returns the LabelTemplate Object with the given name or number.
Public Method Open | Opens the specified existing label template The Open Function activates the Label template stored in the file FileName. If the template file does not exist, nothing happens.

Public Properties

Public Property Application | Read Only: Returns the Application Object This property represents the read-only PC-DMIS Application object. The Application object includes properties and methods that return top-level objects.
Public Property Count | Read Only: Returns the number of open labels This property returns a read-only number of open label templates.
Public Property Parent | Read Only: Returns the Application Object This returns the read-only PC-DMIS Application object which is the parent object of the LabelTemplates object. See the "Automation Objects Hierarchy Charts" for more information.

See Also

LabelTemplates Overview


_Item Method

_Item Method
NameOrNumber

Syntax

Visual Basic
Public Function _Item( _
   ByVal NameOrNumber As Variant _
) As LabelTemplate

Parameters

NameOrNumber

See Also

LabelTemplates Object


Add Method

Add Method

Description

Creates a new label template The Add function creates a new Label template in PC-DMIS.

Syntax

Visual Basic
Public Function Add() As LabelTemplate

Return Type

LabelTemplate object.

Example

Sub Label_Template_Creation()

' This test subroutine was created to show how label templates can be

' automatically generated using PC-DMIS Automation

' This was created inside Microsoft Excel

' Make sure PC-DMIS is running

If MsgBox("This example will use your existing part program and create an automatic Label Template. Is PC-DMIS running and is your part program loaded?", vbYesNo, "Automated Label Template Creation") = vbNo Then

MsgBox "Closing this example. Try again once PC-DMIS is running and a part program is loaded.", vbExclamation

Exit Sub

End If

' Create the PC-DMIS Application

Dim PCDApp As PCDLRN.Application

Set PCDApp = CreateObject("Pcdlrn.Application")

' Open a Part Program

Dim PP As PartProgram

Set PP = PCDApp.ActivePartProgram

Dim LabelTemplates As LabelTemplates

Set LabelTemplates = PCDApp.LabelTemplates

Dim LabelTemplate As LabelTemplate

' Add a new Label Template

Set LabelTemplate = LabelTemplates.Add

' Add a TextObject into a Label Template

Set TextObj = LabelTemplate.LabelControls.Add(ID_HOB_TEXT, 0, 0, 50, 30)

TextObj.Font = 16

TextObj.Alignment = 1 ' To center it

TextObj.BackColor = RGB(128, 0, 64)

TextObj.ForeColor = RGB(255, 255, 255)

TextObj.Text = "=ID" ' Code to display specified Feature ID or Dimension ID

' Save the changes to the Report Template

LabelTemplate.SaveAs "d:\temp\TestLabelTemplate.lbl"

MsgBox "The Label Template is now created. You can open it up inside of PC-DMIS to see what it looks like.", vbInformation, "Label Template Finished"

LabelTemplate.Close

End Sub

See Also

LabelTemplates Object


Item Method

Item Method
NameOrNumber
Required Variant that indicates which LabelTemplates object to return. It can be either a Long or a String. If it is a Long, it is the index number of the LabelTemplate object in the LabelTemplates collection. If it is a String, it is the ID of the LabelTemplate object.

Description

Returns the label template with the given name or number Item function returns the LabelTemplate Object with the given name or number.

Syntax

Visual Basic
Public Function Item( _
   ByVal NameOrNumber As Variant _
) As LabelTemplate

Parameters

NameOrNumber
Required Variant that indicates which LabelTemplates object to return. It can be either a Long or a String. If it is a Long, it is the index number of the LabelTemplate object in the LabelTemplates collection. If it is a String, it is the ID of the LabelTemplate object.

Return Type

LabelTemplate object.

Remarks

Since the Item method is the default, the function name can be omitted.

See Also

LabelTemplates Object


Open Method

Open Method
FileName
Required String. The file name of the LabelTemplate to open.

Description

Opens the specified existing label template

The Open Function activates the Label template stored in the file FileName. If the template file does not exist, nothing happens.

Syntax

Visual Basic
Public Function Open( _
   ByVal FileName As String _
) As LabelTemplate

Parameters

FileName
Required String. The file name of the LabelTemplate to open.

Return Type

LabelTemplate object. If the template does not exist, the function returns Nothing.

Remarks

The Open Function activates the Label template stored in the file FileName. If the template file does not exist, nothing happens.

See Also

LabelTemplates Object


Application Property

Application Property

Description

Read Only: Returns the Application Object This property represents the read-only PC-DMIS Application object. The Application object includes properties and methods that return top-level objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

LabelTemplates Object


Count Property

Count Property

Description

Read Only: Returns the number of open labels This property returns a read-only number of open label templates.

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

Return Type

Long value.

See Also

LabelTemplates Object


Parent Property

Parent Property

Description

Read Only: Returns the Application Object

This returns the read-only PC-DMIS Application object which is the parent object of the LabelTemplates object.

See the "Automation Objects Hierarchy Charts" for more information.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Application

Return Type

Application object.

See Also

LabelTemplates Object


LEAPFROG Object

LEAPFROG Object
See Also Members

Description

The Leapfrog object contains three leapfrog properties that will allow you to define how to use PC-DMIS's Leapfrog option (available in PC-DMIS Versions 3.0 and above) to translate along a part as well as the numbers of hits to use for each feature.

For information on Leapfrog, see the "Performing a LeapFrog Operation” topic in the PC-DMIS Help File.

See Also

LEAPFROG Members


LEAPFROG Object Members

LEAPFROG ObjectMembers
See Also Overview

Public Properties

Public Property full | Read/Write: Full or partial leapfrog Determines whether or not the leapfrog will be full (1) or partial (0). For more information on this, see the "Creating and Using Alignments" topic in the PC-DMIS Help File.
Public Property leapfrogtype | Read/Write: Type of Leapfrog to be performed Integer value that defines the type of feature used to translate the CMM along the part.
Public Property NumHits | Read/Write: Number of hits Integer value that determines the number of hits used for the feature types described in the LeapFrogType property. The feature type determines if the number of hits are useful or not.

See Also

LEAPFROG Overview


full Property

full Property

Description

Read/Write: Full or partial leapfrog Determines whether or not the leapfrog will be full (1) or partial (0). For more information on this, see the "Creating and Using Alignments" topic in the PC-DMIS Help File.

Property type

Read-write property

Syntax

Visual Basic
Public Property full() As Long

Return Type

Read/write Long.

See Also

LEAPFROG Object


leapfrogtype Property

leapfrogtype Property

Description

Read/Write: Type of Leapfrog to be performed Integer value that defines the type of feature used to translate the CMM along the part.

Property type

Read-write property

Syntax

Visual Basic
Public Property leapfrogtype() As Integer

Return Type

Read/write Integer.

Remarks

0 Sphere

1 Point Sets (Psets)

2 Points

3 Off

See Also

LEAPFROG Object


NumHits Property

NumHits Property

Description

Read/Write: Number of hits

Integer value that determines the number of hits used for the feature types described in the LeapFrogType property. The feature type determines if the number of hits are useful or not.

Property type

Read-write property

Syntax

Visual Basic
Public Property NumHits() As Integer

Return Type

Read/write Integer value.

Remarks

If LeapfrogType = 0 then useful values of NumHits are between 5 and 50

If LeapfrogType = 1 then useful values of NumHits are greater than two

If LeapfrogType = 2 or 3 then useful values of NumHits are ignored.

See Also

LEAPFROG Object | leapfrogtype Property


LoadMachine Object

LoadMachine Object
See Also Members

Description

The LoadMachine object gives access to the machine name property of the PC-DMIS Load Machine command.

See Also

LoadMachine Members


LoadMachine Object Members

LoadMachine ObjectMembers
See Also Overview

Public Properties

Public Property MachineName Read/Write: Name of machine to be loaded

Returns or sets the name of the machine to be loaded.

See Also

LoadMachine Overview


MachineName Property

MachineName Property

Description

Read/Write: Name of machine to be loaded

Returns or sets the name of the machine to be loaded.

Property type

Read-write property

Syntax

Visual Basic
Public Property MachineName() As String

Return Type

Read/write String value.

See Also

LoadMachine Object


LoadProbe Object

LoadProbe Object
See Also Members

Description

The LoadProbe object gives access to the filename property of the PC-DMIS Load Probe command.

See Also

LoadProbe Members


LoadProbe Object Members

LoadProbe ObjectMembers
See Also Overview

Public Properties

Public Property FileName Read/Write: Probe filename

Returns or sets the name of the probe file to be loaded.

See Also

LoadProbe Overview


FileName Property

FileName Property

Description

Read/Write: Probe filename

Returns or sets the name of the probe file to be loaded.

Property type

Read-write property

Syntax

Visual Basic
Public Property FileName() As String

Return Type

Read/write String value.

See Also

LoadProbe Object


Machine Object

Machine Object
See Also Members

Description

Machine (CMM or Offline) Object

The Machine object represent a CMM, or a virtual off-line "machine". The Machine objects are contained in the Machines collection.

The Machine object is primarily an event source.

Object Model

See Also

Machine Members


Machine Object Members

Machine ObjectMembers
See Also Overview

Public Methods

Public Method ExecuteCustomCommand
Public Method GetArray

Public Properties

Public Property _Name |
Public Property Application | Read Only: Returns Application Object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.
Public Property FPanel | Read Only: Returns F Panel Object Returns the read-only FPanel object if your controller is indeed an FPanel controller.
Public Property IsFPanel | Read Only: Returns True if the connected to F Panel Determines whether or not the controller is an FPanel controller.
Public Property ManAutoSelector | Read Only: Returns the MAN/AUTO selector position (-1=Undefined 0=MAN, 1=AUTO)
Public Property Name | Read Only: Returns the name (CMM or offline) of the machine Returns the name of the Machine object.
Public Property Parent | Read Only: Returns Machines Object for Application Returns the read-only Machines collection object to which the machine belongs.
Public Property ProbePosition | Read Only: Returns the position of the probe in machine coordinates

Events

Public Event Command | Event fired when a command code is received from the machine controller This event is called when a command button is pressed on the CMM controller. The Code can be used to determine which button was pressed.
Public Event ErrorMsg | Event fired when error message is returned from machine This event is called when an error occurs on the CMM. The ErrorText variable contains the error message, and the ErrorType variable contains the type of error (missed hit, unexpected hit).
Public Event ExecuteHit | Event fired when hit is taken by machine in execute mode This event will be called in your application when a hit is taken in PC-DMIS in execute mode. The values of X, Y, Z and I, J, K are the location of the hit and the vector of the hit in machine coordinates.
Public Event LearnHit | Event fired when hit is taken by machine in learn mode This event will be called in your application when a hit is taken in PC-DMIS in learn mode. The values of X, Y, Z and I, J, K are the location of the hit and the vector of the hit in machine coordinates.

See Also

Machine Overview


ExecuteCustomCommand Method

ExecuteCustomCommand Method
CommandNumber
InputIntArray
InputDoubleArray
OutputIntArray
OutputDoubleArray

Syntax

Visual Basic
Public Function ExecuteCustomCommand( _
   ByVal CommandNumber As Long, _
   ByVal InputIntArray As VariableArray, _
   ByVal InputDoubleArray As VariableArray, _
   ByVal OutputIntArray As VariableArray, _
   ByVal OutputDoubleArray As VariableArray _
) As Boolean

Parameters

CommandNumber
InputIntArray
InputDoubleArray
OutputIntArray
OutputDoubleArray

See Also

Machine Object


GetArray Method

GetArray Method

Syntax

Visual Basic
Public Function GetArray() As VariableArray

See Also

Machine Object


_Name Property

_Name Property

Property type

Read-write property

Syntax

Visual Basic
Public Property _Name() As String

See Also

Machine Object


Application Property

Application Property

Description

Read Only: Returns Application Object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

See Also

Machine Object


FPanel Property

FPanel Property

Description

Read Only: Returns F Panel Object Returns the read-only FPanel object if your controller is indeed an FPanel controller.

Property type

Read-write property

Syntax

Visual Basic
Public Property FPanel() As FPanel

See Also

Machine Object


IsFPanel Property

IsFPanel Property

Description

Read Only: Returns True if the connected to F Panel Determines whether or not the controller is an FPanel controller.

Property type

Read-write property

Syntax

Visual Basic
Public Property IsFPanel() As Boolean

Return Type

Read-only Boolean value. Returns True if your controller is indeed an FPanel controller, False otherwise.

See Also

Machine Object


ManAutoSelector Property

ManAutoSelector Property

Description

Read Only: Returns the MAN/AUTO selector position (-1=Undefined 0=MAN, 1=AUTO)

Property type

Read-write property

Syntax

Visual Basic
Public Property ManAutoSelector() As Long

See Also

Machine Object


Name Property

Name Property

Description

Read Only: Returns the name (CMM or offline) of the machine

Returns the name of the Machine object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As String

Return Type

Read-only String value.

See Also

Machine Object


Parent Property

Parent Property

Description

Read Only: Returns Machines Object for Application

Returns the read-only Machines collection object to which the machine belongs.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Machines

Return Type

Machines object.

See Also

Machine Object


ProbePosition Property

ProbePosition Property

Description

Read Only: Returns the position of the probe in machine coordinates

Property type

Read-write property

Syntax

Visual Basic
Public Property ProbePosition() As PointData

See Also

Machine Object


Command Event

Command Event
Code
Long value representing the button that was pressed.

Description

Event fired when a command code is received from the machine controller

This event is called when a command button is pressed on the CMM controller. The Code can be used to determine which button was pressed.

Syntax

Visual Basic
Public Event Command( _
   ByVal Code As Long _
)

Parameters

Code
Long value representing the button that was pressed.

See Also

Machine Object


ErrorMsg Event

ErrorMsg Event
Msg
String value containing the error message.
ErrorType
Long value containing the type of error.

Description

Event fired when error message is returned from machine This event is called when an error occurs on the CMM. The ErrorText variable contains the error message, and the ErrorType variable contains the type of error (missed hit, unexpected hit).

Syntax

Visual Basic
Public Event ErrorMsg( _
   ByVal Msg As String, _
   ByVal ErrorType As Long _
)

Parameters

Msg
String value containing the error message.
ErrorType
Long value containing the type of error.

See Also

Machine Object


ExecuteHit Event

ExecuteHit Event
X
Double value containg the X value.
Y
Double value containg the Y value.
Z
Double value containg the Z value.
I
Double value containg the I value.
J
Double value containg the J value.
K
Double value containg the K value.

Description

Event fired when hit is taken by machine in execute mode This event will be called in your application when a hit is taken in PC-DMIS in execute mode. The values of X, Y, Z and I, J, K are the location of the hit and the vector of the hit in machine coordinates.

Syntax

Visual Basic
Public Event ExecuteHit( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal I As Double, _
   ByVal J As Double, _
   ByVal K As Double _
)

Parameters

X
Double value containg the X value.
Y
Double value containg the Y value.
Z
Double value containg the Z value.
I
Double value containg the I value.
J
Double value containg the J value.
K
Double value containg the K value.

See Also

Machine Object


LearnHit Event

LearnHit Event
X
Double value containg the X value.
Y
Double value containg the Y value.
Z
Double value containg the Z value.
I
Double value containg the I value.
J
Double value containg the J value.
K
Double value containg the K value.

Description

Event fired when hit is taken by machine in learn mode This event will be called in your application when a hit is taken in PC-DMIS in learn mode. The values of X, Y, Z and I, J, K are the location of the hit and the vector of the hit in machine coordinates.

Syntax

Visual Basic
Public Event LearnHit( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal I As Double, _
   ByVal J As Double, _
   ByVal K As Double _
)

Parameters

X
Double value containg the X value.
Y
Double value containg the Y value.
Z
Double value containg the Z value.
I
Double value containg the I value.
J
Double value containg the J value.
K
Double value containg the K value.

See Also

Machine Object


Machines Object

Machines Object
See Also Members

Description

The Machines object is the collection of all Machine objects currently available in PC-DMIS. Each Machine object is bound to exactly one PartProgram object, and vice versa. Use Machines(index) where index is the index number or on-line machine’s name to return a single Machine object.

Object Model

Remarks

There may be multiple machines named "OFFLINE", one for each open off-line part program. To distinguish between them, use the index number, or use the machine’s Parent member.

See Also

Machines Members


Machines Object Members

Machines ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method Item | Returns machine specified by name or number This returns a specific Machine object from a list of machines.

Public Properties

Public Property Application | Read Only: Returns Application Object Represents the read-only PC-DMIS Application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.
Public Property Count | Read Only: Returns the number of machines available to the application Represents the number of Machine objects currently active in PC-DMIS.
Public Property Parent | Read Only: Returns Application Object Represents the read-only PC-DMIS Application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.

See Also

Machines Overview


_Item Method

_Item Method
NameOrNum

Syntax

Visual Basic
Public Function _Item( _
   ByVal NameOrNum As Variant _
) As Machine

Parameters

NameOrNum

See Also

Machines Object


Item Method

Item Method
NameOrNum
Required Variant that indicates which Machine object to return. It can be either a Long or a String. If it is a Long, it is the index number of the Machine object in the Machines collection. If it is a String, it is the ID of the Machine object.

Description

Returns machine specified by name or number This returns a specific Machine object from a list of machines.

Syntax

Visual Basic
Public Function Item( _
   ByVal NameOrNum As Variant _
) As Machine

Parameters

NameOrNum
Required Variant that indicates which Machine object to return. It can be either a Long or a String. If it is a Long, it is the index number of the Machine object in the Machines collection. If it is a String, it is the ID of the Machine object.

Return Type

There may be several machines named "OFFLINE". To avoid possible confusion with off-line machines, use the index number with these machines. Since the Item method is the default, the function name can be omitted.

See Also

Machines Object


Application Property

Application Property

Description

Read Only: Returns Application Object Represents the read-only PC-DMIS Application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Read-only Application object.

See Also

Machines Object


Count Property

Count Property

Description

Read Only: Returns the number of machines available to the application

Represents the number of Machine objects currently active in PC-DMIS.

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Integer

Return Type

Read-only Integer.

See Also

Machines Object


Parent Property

Parent Property

Description

Read Only: Returns Application Object Represents the read-only PC-DMIS Application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Application

Return Type

Read-only Application object.

See Also

Machines Object | ActivePartProgram Property


MasterSlaveDlg Object

MasterSlaveDlg Object
See Also Members

Description

The MasterSlaveDlg object gets called when the PartProgram.MasterSlaveDlg method is used.

Object Model

See Also

MasterSlaveDlg Members


MasterSlaveDlg Object Members

MasterSlaveDlg ObjectMembers
See Also Overview

Public Methods

Public Method Calibrate Runs the Master/Slave calibration process.

Public Properties

Public Property Application | This read-only object returns the Application object.
Public Property DCC | Gets or sets whether the Master / Slave calibration is a manual (0) or DCC (1) calibration.
Public Property MasterProbe | Gets or sets which probe is used on the Master machine. The names are taken from the owning PartProgram object's Probes collection.
Public Property MasterTip | Gets or sets which tip is used on the Master machine. The names are taken from the owning PartProgram object's Probes collection.
Public Property MeasuringArm | Gets or sets which arm or arms measure the calibration sphere.
Public Property Parent | This read-only object returns the parent Application object.
Public Property Position | Gets or sets the first (or only) sphere position.
Public Property SlaveProbe | Gets or sets which probe is used on the Slave machine. The names are taken from the owning PartProgram object's Probes collection.
Public Property SlaveTip | Gets or sets which tip is used on the Slave machine. The names are taken from the owning PartProgram object's Probes collection.
Public Property tool | Gets or sets which calibration tool is being measured during the calibration process. The names are taken from the owning PartProgram object's Tools collection.
Public Property Visible | Determines whether or not the Master / Slave dialog box is visible.

See Also

MasterSlaveDlg Overview


Calibrate Method

Calibrate Method

Description

Runs the Master/Slave calibration process.

Syntax

Visual Basic
Public Function Calibrate() As Long

Return Type

Long value.

Remarks

Using this method is the same as clicking the Calibrate button on the Master / Slave Calibration dialog box inside the application itself.

See Also

MasterSlaveDlg Object


Application Property

Application Property

Description

This read-only object returns the Application object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

See Also

MasterSlaveDlg Object


DCC Property

DCC Property

Description

Gets or sets whether the Master / Slave calibration is a manual (0) or DCC (1) calibration.

Property type

Read-write property

Syntax

Visual Basic
Public Property DCC() As ENUM_MASTERSLAVEDIALOG_MEASUREDCC

Return Type

Read/write Long.

Remarks

The available settings are:

MEASURE_MANUAL = 0

MEASURE_DCC = 1

See Also

MasterSlaveDlg Object


MasterProbe Property

MasterProbe Property

Description

Gets or sets which probe is used on the Master machine. The names are taken from the owning PartProgram object's Probes collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property MasterProbe() As String

Return Type

Read/write String value.

See Also

MasterSlaveDlg Object


MasterTip Property

MasterTip Property

Description

Gets or sets which tip is used on the Master machine. The names are taken from the owning PartProgram object's Probes collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property MasterTip() As String

Return Type

Read/write String.

See Also

MasterSlaveDlg Object


MeasuringArm Property

MeasuringArm Property

Description

Gets or sets which arm or arms measure the calibration sphere.

Property type

Read-write property

Syntax

Visual Basic
Public Property MeasuringArm() As ENUM_MASTERSLAVEDIALOG_MEASUREARM

Return Type

Read/write Long value.

Remarks

The available settings are:

MEAURE_BOTH = 0

MEASURE_MASTER = 1

MEASURE_SLAVE = 2

See Also

MasterSlaveDlg Object


Parent Property

Parent Property

Description

This read-only object returns the parent Application object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Application

Return Type

Application object.

See Also

MasterSlaveDlg Object


Position Property

Position Property

Description

Gets or sets the first (or only) sphere position.

Property type

Read-write property

Syntax

Visual Basic
Public Property Position() As PointData

Return Type

Read/write PointData object.

See Also

MasterSlaveDlg Object


SlaveProbe Property

SlaveProbe Property

Description

Gets or sets which probe is used on the Slave machine. The names are taken from the owning PartProgram object's Probes collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property SlaveProbe() As String

Return Type

Read/write String value.

See Also

MasterSlaveDlg Object


SlaveTip Property

SlaveTip Property

Description

Gets or sets which tip is used on the Slave machine. The names are taken from the owning PartProgram object's Probes collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property SlaveTip() As String

Return Type

Read/write String value.

See Also

MasterSlaveDlg Object


tool Property

tool Property

Description

Gets or sets which calibration tool is being measured during the calibration process. The names are taken from the owning PartProgram object's Tools collection.

Property type

Read-write property

Syntax

Visual Basic
Public Property tool() As String

Return Type

Read/write String value.

See Also

MasterSlaveDlg Object | Tools Property | Probes Property


Visible Property

Visible Property

Description

Determines whether or not the Master / Slave dialog box is visible.

Property type

Read-write property

Syntax

Visual Basic
Public Property Visible() As Boolean

Return Type

Boolean value. This returns True if the dialog box is visible, False if it is hidden.

See Also

MasterSlaveDlg Object


ModalCmd Object

ModalCmd Object
See Also Members

Description

Modal Command Objects of type AlignCmnd are created from more generic Command objects to pass information specific to the modal command back and forth.

Object Model

See Also

ModalCmd Members | AlignCmnd Object | Command Object | ModalCommand Property


ModalCmd Object Members

ModalCmd ObjectMembers
See Also Overview

Public Properties

Public Property ClearPlane | Read/Write: Main Clearance Plane Represents the clearance plane of a CLEARANCE_PLANES type object.
Public Property Digits | Read/Write: Number of digits for display precision command Represents the number of digits of a DISPLAYPRECISION type object.
Public Property DISTANCE | Read/Write: Distance (Prehit, Clamp, Retract, Check, Clearance Plane Represents the distance to move for this object.
Public Property Distance2 | Read/Write: Distance 2 for Clearance Planes
Public Property ManDCCMode | Read/Write: Manual / DCC Mode
Public Property Name | Read/Write: Load Probes Probe filename Returns the name of this GET_PROBE_DATA object.
Public Property On | Read/Write: On/Off Setting (Probe Comp, Polar Vector Comp, Gap Only, Retro Only, Fly Mode, Column 132) Represents the on/off state of this object.
Public Property Parent | Read Only: Returns parent command object Returns the parent Command object. Read-only.
Public Property PassPlane | Read/Write: Secondary Clearance Plane Represents the pass-through plane to move for this CLEARANCE_PLANES object.
Public Property RMeasMode | Read/Write: Relative Measure Mode Represents the current relative measure (or RMEAS) mode.
Public Property Speed | Read/Write: Speed (Move Speed, Touch Speed Scan Speed) Represents the speed for this object.
Public Property Workplane | Read/Write: Workplane Represents the workplane to move for this SET_WORKPLANE object.

See Also

ModalCmd Overview | AlignCmnd Object | Command Object | ModalCommand Property


ClearPlane Property

ClearPlane Property

Description

Read/Write: Main Clearance Plane Represents the clearance plane of a CLEARANCE_PLANES type object.

Property type

Read-write property

Syntax

Visual Basic
Public Property ClearPlane() As ENUM_PLANE_TYPE

Return Type

Read/write Long value.

Remarks

This property is only useful for objects of type CLEARANCE_PLANES. For objects of other types, setting this property does nothing and getting it always returns PCD_ZPLUS.

Allowable values for this property are PCD_XPLUS, PCD_XMINUS, PCD_YPLUS, PCD_YMINUS, PCD_ZPLUS, and PCD_ZMINUS.

See Also

ModalCmd Object


Digits Property

Digits Property

Description

Read/Write: Number of digits for display precision command Represents the number of digits of a DISPLAYPRECISION type object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Digits() As Long

Return Type

Read/write Long value.

Remarks

This property is only useful for objects of type DISPLAYPRECISION. For objects of other types, setting this property does nothing and getting it always returns zero.

See Also

ModalCmd Object | Type Property


DISTANCE Property

DISTANCE Property

Description

Read/Write: Distance (Prehit, Clamp, Retract, Check, Clearance Plane Represents the distance to move for this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property DISTANCE() As Double

Return Type

Read/write Double.

Remarks

This property is only useful for objects of type PREHIT, CLAMP, RETRACT, CHECK, and CLEARANCE_PLANES. For objects of other types, setting this property does nothing and getting it always returns zero.

For objects of type PREHIT, CLAMP, RETRACT, and CHECK, the Distance property is the distance to move during that operation. For CLEARANCE_PLANES objects, it is the distance from the axes plane to move. For example, if the clearance plane is LEFT, and the Distance is 2.0, the clearance plane will move to the X=2.0 plane.

See Also

ModalCmd Object | Type Property | Distance2 Property | PassPlane Property


Distance2 Property

Distance2 Property

Description

Read/Write: Distance 2 for Clearance Planes

Property type

Read-write property

Syntax

Visual Basic
Public Property Distance2() As Double

See Also

ModalCmd Object | DISTANCE Property | PassPlane Property | Type Property


ManDCCMode Property

ManDCCMode Property

Description

Read/Write: Manual / DCC Mode

Property type

Read-write property

Syntax

Visual Basic
Public Property ManDCCMode() As DCCMODE

See Also

ModalCmd Object


Name Property

Name Property

Description

Read/Write: Load Probes Probe filename Returns the name of this GET_PROBE_DATA object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As String

Return Type

Read-only String value.

Remarks

This property is only useful for objects of type GET_PROBE_DATA (LoadProbe). For objects of other types, it always returns the empty string.

See Also

ModalCmd Object | Type Property


On Property

On Property

Description

Read/Write: On/Off Setting (Probe Comp, Polar Vector Comp, Gap Only, Retro Only, Fly Mode, Column 132) Represents the on/off state of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property On() As Boolean

Return Type

Read/write Boolean value.

Remarks

This property is only useful for objects of types PROBE_COMPENSATION, POLARVECTORCOMP, GAP_ONLY, RETROLINEAR_ONLY, FLY_MODE, and COLUMN132. For objects of other types, setting this property does nothing and getting it always returns FALSE.

See Also

ModalCmd Object | Type Property


Parent Property

Parent Property

Description

Read Only: Returns parent command object Returns the parent Command object. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Command

Return Type

Command object.

Remarks

The parent of a ModalCommand object is the same underlying PC-DMIS object as the ModalCommand object itself. Getting the parent allows you to access the generic Command properties and methods of a given object.

See Also

ModalCmd Object | Type Property


PassPlane Property

PassPlane Property

Description

Read/Write: Secondary Clearance Plane Represents the pass-through plane to move for this CLEARANCE_PLANES object.

Property type

Read-write property

Syntax

Visual Basic
Public Property PassPlane() As ENUM_PLANE_TYPE

Return Type

Read/write Long value.

Remarks

This property is only useful for objects of type CLEARANCE_PLANES. For objects of other types, setting this property does nothing and getting it always returns PCD_ZPLUS.

Allowable values for this property are PCD_XPLUS, PCD_XMINUS, PCD_YPLUS, PCD_YMINUS, PCD_ZPLUS, and PCD_ZMINUS.

See Also

ModalCmd Object | Type Property | DISTANCE Property | Distance2 Property


RMeasMode Property

RMeasMode Property

Description

Read/Write: Relative Measure Mode Represents the current relative measure (or RMEAS) mode.

Property type

Read-write property

Syntax

Visual Basic
Public Property RMeasMode() As ENUM_RMEAS_MODE

Return Type

Read/write ENUM_RMEAS_MODE enumeration.

Remarks

These can be 0 for RMEAS_LEGACY (previously RMEAS_NORMAL) or 1 for RMEAS_DEFAULT (previously RMEAS_ABSOLUTE). The default value is RMEAS_DEFAULT.

Note that while RMEAS_NORMAL and RMEAS_ABSOLUTE remain for compatibility with previous versions of PC-DMIS, for new scripts, you should use RMEAS_LEGACY and RMEAS_DEFAULT instead.

  • RMEAS_DEFAULT - uses the RMEAS feature’s measured position and vector, applying any positional offsets along that vector.
  • RMEAS_LEGACY - uses the deviation of the RMEAS feature’s position and orientation.

The differences between Legacy and Default are discussed in more detail in the main PC-DMIS help file. See the "Setting Up Relative Measure (RMEAS)" topic in the "Creating Auto Features" section.

See Also

ModalCmd Object | Type Property


Speed Property

Speed Property

Description

Read/Write: Speed (Move Speed, Touch Speed Scan Speed) Represents the speed for this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Speed() As Double

Return Type

Read/write Double value.

Remarks

This property is only useful for objects of type MOVE_SPEED, TOUCH_SPEED, and SCAN_SPEED. For objects of other types, setting this property does nothing and getting it always returns zero.

See Also

ModalCmd Object | Type Property


Workplane Property

Workplane Property

Description

Read/Write: Workplane Represents the workplane to move for this SET_WORKPLANE object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Workplane() As ENUM_PLANE_TYPE

Return Type

Read/write Long value.

Remarks

This property is only useful for objects of type SET_WORKPLANE. For objects of other types, setting this property does nothing and getting it always returns PCD_ZPLUS.

Allowable values for this property are PCD_XPLUS, PCD_XMINUS, PCD_YPLUS, PCD_YMINUS, PCD_ZPLUS, and PCD_ZMINUS.

See Also

ModalCmd Object | Type Property


MoveCmd Object

MoveCmd Object
See Also Members

Description

Move Command Object Objects of type MoveCmd are created from more generic Command objects to pass information specific to the move command back and forth.

Object Model

See Also

MoveCmd Members | MoveCommand Property


MoveCmd Object Members

MoveCmd ObjectMembers
See Also Overview

Public Properties

Public Property Angle | Read/Write: Rotation Table Angle Represents the rotation angle of this MOVE_ROTAB object.
Public Property Direction | Read/Write: Roation Table Move Direction Represents the rotation direction of this MOVE_ROTAB object.
Public Property IJK | Read/Write: Gets/Sets IJK data via Point Data Object for Move Command A PointData object that represents the IJK vector to use.
Public Property NewTip | Read/Write: Move PH9 Offset New Tip Value Represents the new tip position of this MOVE_PH9_OFFSET object.
Public Property OldTip | Read/Write: Move PH9 Offset Old Tip Value Represents the new tip position of this MOVE_PH9_OFFSET object.
Public Property Parent | Read Only: Returns Parent Command Object Returns the parent Command object. Read-only.
Public Property XYZ | Read/Write: Gets/Sets XYZ data via Point Data Object for Move Command A PointData object that represents the location to which to move, or in the case of MOVE_INCREMENT, the location offset.
Public Property XYZEnd | Read Only: Gets XYZ data via Point Data Object for Circular Move Command End Point
Public Property XYZStart | Read Only: Gets XYZ data via Point Data Object for Circular Move Command Start Point

See Also

MoveCmd Overview | MoveCommand Property


Angle Property

Angle Property

Description

Read/Write: Rotation Table Angle Represents the rotation angle of this MOVE_ROTAB object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Angle() As Double

Return Type

Read/write Double object.

Remarks

This property is only useful for objects of type MOVE_ROTAB. For objects of other types, setting this property does nothing and getting it always returns zero.

See Also

MoveCmd Object | Type Property


Direction Property

Direction Property

Description

Read/Write: Roation Table Move Direction Represents the rotation direction of this MOVE_ROTAB object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Direction() As MOVEDIRECTION

Return Type

Read/write Double value.

Remarks

This property is only useful for objects of type MOVE_ROTAB. For objects of other types, setting this property does nothing and getting it always returns zero.

For objects of type MOVE_ROTAB, the allowable values of this property are PCD_CLOCKWISE, PCD_COUNTERCLOCKWISE, and PCD_SHORTEST.

See Also

MoveCmd Object | Type Property


IJK Property

IJK Property

Description

Read/Write: Gets/Sets IJK data via Point Data Object for Move Command A PointData object that represents the IJK vector to use.

Property type

Read-write property

Syntax

Visual Basic
Public Property IJK() As PointData

Return Type

Read/write PointData object.

Remarks

This property is only useful for move objects that have a vector field, such as MOVE_SWEEP_POINT. For objects of other types, such as MOVE_POINT, MOVE_INCREMENT and MOVE_CIRCULAR, setting this property does nothing and getting it always returns Null.

See Also

MoveCmd Object | Type Property


NewTip Property

NewTip Property

Description

Read/Write: Move PH9 Offset New Tip Value

Represents the new tip position of this MOVE_PH9_OFFSET object.

Property type

Read-write property

Syntax

Visual Basic
Public Property NewTip() As String

Return Type

Read/write String value.

Remarks

This property is only useful for objects of type MOVE_PH9_OFFSET. For objects of other types, setting this property does nothing and getting it always returns the empty string.

For objects of type MOVE_PH9_OFFSET, this property should have the value of the ID of any tip in this part program.

See Also

MoveCmd Object | ID Property | Type Property


OldTip Property

OldTip Property

Description

Read/Write: Move PH9 Offset Old Tip Value

Represents the new tip position of this MOVE_PH9_OFFSET object.

Property type

Read-write property

Syntax

Visual Basic
Public Property OldTip() As String

Return Type

Read/write String value

Remarks

This property is only useful for objects of type MOVE_PH9_OFFSET. For objects of other types, setting this property does nothing and getting it always returns the empty string.

For objects of type MOVE_PH9_OFFSET, this property should have the value of the ID of any tip in this part program.

See Also

MoveCmd Object | Type Property | ID Property


Parent Property

Parent Property

Description

Read Only: Returns Parent Command Object Returns the parent Command object. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Command

Return Type

The parent of a MoveCommand object is the same underlying PC-DMIS object as the MoveCommand object itself. Getting the parent allows you to access the generic Command properties and methods of a given object.

See Also

MoveCmd Object


XYZ Property

XYZ Property

Description

Read/Write: Gets/Sets XYZ data via Point Data Object for Move Command A PointData object that represents the location to which to move, or in the case of MOVE_INCREMENT, the location offset.

Property type

Read-write property

Syntax

Visual Basic
Public Property XYZ() As PointData

Return Type

Read/write PointData object.

Remarks

This property is only useful for objects of type MOVE_POINT, MOVE_INCREMENT, and MOVE_CIRCULAR. For objects of other types, setting this property does nothing and getting it always returns Nothing.

See Also

MoveCmd Object | Type Property


XYZEnd Property

XYZEnd Property

Description

Read Only: Gets XYZ data via Point Data Object for Circular Move Command End Point

Property type

Read-write property

Syntax

Visual Basic
Public Property XYZEnd() As PointData

See Also

MoveCmd Object


XYZStart Property

XYZStart Property

Description

Read Only: Gets XYZ data via Point Data Object for Circular Move Command Start Point

Property type

Read-write property

Syntax

Visual Basic
Public Property XYZStart() As PointData

See Also

MoveCmd Object


OldBasic Object

OldBasic Object
See Also Members

Description

Object providing access to the previous basic command set

These PC-DMIS OldBasic functions were made available in previous version of PC-DMIS basic and are provided here, listed in alphabetical order, for backwards compatibility.

Object Model

Remarks

Imporant Notes:

  • Functions that return type Object are invalid.
  • Only OldBasic classes support optional parameters.

Micellaneous Programming Notes:

  • Using Parentheses in BASIC Scripts: For information on when to use or omit parentheses, please refer to your BASIC Language documentation; generally however, for methods and properties you should only use parentheses if you're receiving a value.

  • Invalid Function Return Type: Be aware that objects are not a valid return type for functions.

See Also

OldBasic Members


OldBasic Object Members

OldBasic ObjectMembers
See Also Overview

Public Methods

Public Method AddBoundaryPoint | Adds a boundary point to a scan This function is used to add the initial point, end point, and other boundary points in the case of patch scans. It should be called for each boundary point to be added. It should not be called more than num_bnd_pnts times (as specified in the call to StartScan).
Public Method AddFeature | Adds a feature to the input set for a constructed feature Adds a feature. This function is used for constructed features only. The parameters off1, off2, and off3 are only used in the case of offset points, planes, or lines.
Public Method AddLevelFeat | Adds a feature for leveling to the primary axis for an iterative alignment This function is used in conjunction with the iterate alignment command.
Public Method AddOriginFeat | Adds a feature for locating the origin to an iterative alignment This function is used in conjunction with the iterate alignment command.
Public Method AddRotateFeat | Adds a feature for the rotation of the secondary axis to an iterative alignment Adds a rotation feature. This function is used in conjunction with the iterate alignment command
Public Method ArcCos | Returns the ArcCosine (in degrees) of x Return the arc cosine of x in degrees.
Public Method ArcSin | Returns the ArcSince (in degrees) of y Returns the arc sine of x in degrees.
Public Method BestFit2D | Creates a best fit 2d alignment
Public Method BestFit3D | Creates a best fit 3d alignment
Public Method Calibrate | Creates a probe calibration command
Public Method CatchMotionError | Turns On/Off Catching of CMM motion errors
Public Method Check | Creates a check distance object
Public Method ClearPlane | Creates a clearplane settings object
Public Method CloseCommConnection | Closes port opened with OpenCommConnection Command Closes the port opened with the OpenCommConnection command.
Public Method Column132 | Creates a column 132 dimension display object Turns on or off 132 column mode.
Public Method Comment | Creates a part program comment object
Public Method CreateID | Generates and returns an Id based on part program generation settings
Public Method DefaultAxes | Generates automatic dimensioning axes based on dimension type This command is used only for location and true position dimensions. If present, the default dimension axes are created. Calls to SetNoms with other axes passed as the dtype parameter will have no effect if this command is used.
Public Method DefaultHits | Generates hit values automatically for feature This command is used within a Startfeature - EndFeature block and is used to cause the hits specified in the hits parameter of the StartFeature command to be automatically generated.
Public Method DimFormat | Creates a DimFormat command
Public Method EndAlign | Marks the end of the block started with StartAlign This function must be called to end an alignment block.
Public Method EndDim | Marks the end of the block started with StartDimension EndDim takes no parameters, but must be called to finish off the dimension block.
Public Method EndFeature | Marks the end of the block started with StartFeature This function ends a measured, constructed, or auto feature block. It must always be present as the last function call in a feature block.
Public Method EndGetFeatPoint | Frees memory allocated by StartGetFeatPoint Use this command to release the memory allocated for use by the StartGetFeatPoint and GetFeatPoint commands.
Public Method EndScan | Marks end of block started with StartScan command Call this when all of the other scan functions needed have been called. The scan object is inserted in the command list with a call to this function.
Public Method EquateAlign | Creates Equate Alignment Command Creates Equate alignment object
Public Method Feature | Identifies Feature to be used by BF2d, BF3d, or Iterative Alignment This function must only be called after a call to BestFit2D, BestFit3D, or Iterate
Public Method Flatness | Returns flatness information for command of specified ID This function was added for the tutor translator, and should be used with caution.
Public Method GapOnly | Creates Gap Only Dimension Object
Public Method GetDimData | Get dimension data from dimension specified by ID
Public Method GetDimOutTol | Returns number of features that are out of tolerance Returns the number of features that are out of tolerance at the time that this command is executed.
Public Method GetFeatData | Gets feature data from command with specified ID
Public Method GetFeatID | Returns id of indexed feature
Public Method GetFeatPoint | Fills buffer with hit data for command specified in StartGetFeatPoint Command This function is called after a call to StartGetFeatPoint to retrieve the actual points.
Public Method GetFeature | Returns feature type (ie. Circle, Line, Point...)
Public Method GetPH9Status | Returns 1 if a PH9 is available
Public Method GetProbeOffsets | Returns the current probe offsets
Public Method GetProbeRadius | Returns the current probe radius Returns the current probe radius.
Public Method GetProgramOption | Returns the status of the application setting option
Public Method GetProgramValue | Returns the value of the application setting
Public Method GetTopMachineSpeed | Returns the top machine speed value Returns the top machine speed of the CMM.
Public Method GetType | Returns the type of command with the specified ID Returns the type of the object.
Public Method GetUnits | Indicates whether units are metric or english The units of the current part program.
Public Method Hit | Used in feature block to add a hit to an object
Public Method IgnoreMotionError | Sets recalculation of nominals mode
Public Method Iterate | Creates Iterative Alignment Command
Public Method Level | Creates Level Alignment Command
Public Method LoadProbe | Creates Load Probe Command
Public Method MaxMinAve | Returns maximum, minimum, or average information for command of specified id
Public Method Mode | Creates DCC / Manual Mode Command
Public Method Move | Creates Move (Probe or Rotary Table) Command
Public Method MoveSpeed | Creates Move Speed Command
Public Method OpenCommConnection | Opens a communication port for reading and writing Opens a connection to the specified comm port.
Public Method PreHit | Creates Prehit Distance Command
Public Method ProbeComp | Creates Probe Compensation Command
Public Method PutFeatData | Puts feature data into the command specified by the ID
Public Method ReadCommBlock | Reads data from an opened communications port Reads characters from the comm port specified.
Public Method RecallEx | Creates Recall Alignment Command for External Alignments
Public Method RecallIn | Creates Recall Alignment Command for Internal Alignments
Public Method Retract | Creates a Retract Distance Command
Public Method RetroOnly | Creates a Retrolinear Only Dimension Command
Public Method Rotate | Creates a Rotate Alignment Command
Public Method RotateCircle | Creates a Circular Rotation Alignment Command
Public Method RotateOffset | Creates a Rotational Offset Command
Public Method Roundness | Returns roundness information for command of specified ID
Public Method RunOut | Returns runout information for command of specified ID
Public Method SaveAlign | Creates a Save Alignment Command
Public Method SetAutoParams | Sets Auto Feature Parameters inside StartFeature Block
Public Method SetAutoVector | Sets Auto Vector Components (used inside StartFeature Block)
Public Method SetNoms | Set nominal values for dimension (used inside StartDimension Block)
Public Method SetPrintOptions | Sets application printing options
Public Method SetProgramOption | Sets application program option
Public Method SetProgramValue | Sets application program value
Public Method SetReportOptions | Sets application reporting settings
Public Method SetRMeasMode | Sets Relative Measure mode to Relative or Absolute
Public Method SetScanHitParams | Sets scan hit parameters (used in StartScan block)
Public Method SetScanHitVectors | Sets hit vector components of scan (used in StartScan block)
Public Method SetScanParams | Sets scan parameters (used in StartScan block)
Public Method SetScanVectors | Sets vector components of scan (used in StartScan block)
Public Method SetSlaveMode | Turns on/turns off slave mode (subsequent objects are slave object/master objects)
Public Method SetTheos | Sets theoretical values for feature (used in StartFeature block)
Public Method ShowXYZWindow | Shows or Hides the probe readouts window
Public Method Sleep | Wait until execution catches up to script, then wait for a number of seconds Pauses execution for the specified number of seconds after the previous feature has finished executing.
Public Method StartAlign | Starts Alignment block and sets alignment parameters
Public Method StartDim | Starts Dimension block and sets dimension parameters
Public Method StartFeature | Starts Feature block and sets feature parameters
Public Method StartGetFeatPoint | Sets aside memory buffer of hit data for use with the GetFeatPoint command This function is used to retrieve the hit or input data from constructed, measured, and auto features, as well as the hit data for scans. To retrieve the actual points, subsequent calls to GetFeatPoint must be made. When all of the needed point values have been retrieved, a call to EndGetFeatPoint must be made to free the memory allocated for the points.
Public Method StartScan | Starts Scan block and sets sets scan parameters
Public Method Stats | Creates Stats On/Off command
Public Method Straitness | Returns straitness information for command of specified ID
Public Method Tip | Creates Tip command The tip to load.
Public Method Touchspeed | Creates touch speed command
Public Method Trace | Creates trace field command
Public Method Translate | Creates translation alignment command
Public Method TranslateOffset | Creates a translation offset command
Public Method Wait | Wait until execution catches up to script Waits until all preceding commands have been executed. The basic script creates commands and places them on the execute list more rapidly than the commands are executed. In a script it is often useful to pop up a dialog box for input after a certain series of commands has been executed. The script commands may complete long before the actual commands have been executed. The Wait command is useful to prevent the dialog box from popping up prematurely.
Public Method Workplane | Creates a workplane object or gets the current workplane
Public Method WriteCommBlock | Writes data to an opened communications port Writes characters to the specified comm port.

Public Properties

Public Property Application | Read Only: Returns Application object
Public Property Parent | Read Only: Returns Partprogram object

See Also

OldBasic Overview


AddBoundaryPoint Method

AddBoundaryPoint Method
X
Double value representing the X value of the boundary point.
Y
Double value representing the Y value of the boundary point.
Z
Double value representing the Z value of the boundary point.

Description

Adds a boundary point to a scan This function is used to add the initial point, end point, and other boundary points in the case of patch scans. It should be called for each boundary point to be added. It should not be called more than num_bnd_pnts times (as specified in the call to StartScan).

Syntax

Visual Basic
Public Sub AddBoundaryPoint( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double _
)

Parameters

X
Double value representing the X value of the boundary point.
Y
Double value representing the Y value of the boundary point.
Z
Double value representing the Z value of the boundary point.

See Also

OldBasic Object


AddFeature Method

AddFeature Method
ID
ID string of the feature to add.
off1
X offset for an offset point. Single offset for this feature for an offset plane or line.
off2
Y offset for an offset point.
off3
Z offset for an offset point.

Description

Adds a feature to the input set for a constructed feature Adds a feature. This function is used for constructed features only. The parameters off1, off2, and off3 are only used in the case of offset points, planes, or lines.

Syntax

Visual Basic
Public Sub AddFeature( _
   ByVal ID As String, _
   ByVal off1 As Double, _
   ByVal off2 As Double, _
   ByVal off3 As Double _
)

Parameters

ID
ID string of the feature to add.
off1
X offset for an offset point. Single offset for this feature for an offset plane or line.
off2
Y offset for an offset point.
off3
Z offset for an offset point.

See Also

OldBasic Object


AddLevelFeat Method

AddLevelFeat Method
ID
Name of level feature to be added.

Description

Adds a feature for leveling to the primary axis for an iterative alignment

This function is used in conjunction with the iterate alignment command.

Syntax

Visual Basic
Public Sub AddLevelFeat( _
   ByVal ID As String _
)

Parameters

ID
Name of level feature to be added.

See Also

OldBasic Object


AddOriginFeat Method

AddOriginFeat Method
ID
Name of origin feature to be added

Description

Adds a feature for locating the origin to an iterative alignment

This function is used in conjunction with the iterate alignment command.

Syntax

Visual Basic
Public Sub AddOriginFeat( _
   ByVal ID As String _
)

Parameters

ID
Name of origin feature to be added

See Also

OldBasic Object


AddRotateFeat Method

AddRotateFeat Method
ID
Name of rotation feature to be added.

Description

Adds a feature for the rotation of the secondary axis to an iterative alignment Adds a rotation feature. This function is used in conjunction with the iterate alignment command

Syntax

Visual Basic
Public Sub AddRotateFeat( _
   ByVal ID As String _
)

Parameters

ID
Name of rotation feature to be added.

See Also

OldBasic Object


ArcCos Method

ArcCos Method
X

Description

Returns the ArcCosine (in degrees) of x

Return the arc cosine of x in degrees.

Syntax

Visual Basic
Public Function ArcCos( _
   ByVal X As Double _
) As Double

Parameters

X

See Also

OldBasic Object


ArcSin Method

ArcSin Method
X

Description

Returns the ArcSince (in degrees) of y

Returns the arc sine of x in degrees.

Syntax

Visual Basic
Public Function ArcSin( _
   ByVal X As Double _
) As Double

Parameters

X

See Also

OldBasic Object


BestFit2D Method

BestFit2D Method
num_inputs
The number of features to use to create the best fit alignment. There must be a corresponding number of calls to Feature before the call to EndAlign.
Workplane
This parameter specifies the workplane of the 2D alignment. Options come from the WPLANETYPE emumeration. These include PCD_TOP, PCD_BOTTOM, PCD_FRONT, PCD_BACK, PCD_LEFT, or PCD_RIGHT.

Description

Creates a best fit 2d alignment

Syntax

Visual Basic
Public Sub BestFit2D( _
   ByVal num_inputs As Long, _
   ByVal Workplane As WPLANETYPE _
)

Parameters

num_inputs
The number of features to use to create the best fit alignment. There must be a corresponding number of calls to Feature before the call to EndAlign.
Workplane
Value Description
PCD_TOP
PCD_RIGHT
PCD_BACK
PCD_BOTTOM
PCD_LEFT
PCD_FRONT
This parameter specifies the workplane of the 2D alignment. Options come from the WPLANETYPE emumeration. These include PCD_TOP, PCD_BOTTOM, PCD_FRONT, PCD_BACK, PCD_LEFT, or PCD_RIGHT.

See Also

OldBasic Object


BestFit3D Method

BestFit3D Method
num_inputs
The number of features to use to create the best fit alignment. There must be a corresponding number of calls to Feature before the call to EndAlign.

Description

Creates a best fit 3d alignment

Syntax

Visual Basic
Public Sub BestFit3D( _
   ByVal num_inputs As Long _
)

Parameters

num_inputs
The number of features to use to create the best fit alignment. There must be a corresponding number of calls to Feature before the call to EndAlign.

See Also

OldBasic Object


Calibrate Method

Calibrate Method
sphere
Id of measured sphere used in calibration.
tool
Id of tool object used in calibration.
Moved
Toggle indicating whether first hit should be taken manually or not. Can be either PCD_NO or PCD_YES.

Description

Creates a probe calibration command

Syntax

Visual Basic
Public Sub Calibrate( _
   ByVal sphere As String, _
   ByVal tool As String, _
   ByVal Moved As PCDYESNO _
)

Parameters

sphere
Id of measured sphere used in calibration.
tool
Id of tool object used in calibration.
Moved
Value Description
PCD_YES
PCD_NO
Toggle indicating whether first hit should be taken manually or not. Can be either PCD_NO or PCD_YES.

See Also

OldBasic Object


CatchMotionError Method

CatchMotionError Method
tog
catch_error
A reference to the integer that will be set to a non-zero value if a CMM error occurs. When error catching is turned on, this integer is automatically initialized to zero. Only used when tog is set to PCD_CATCH_IN_INTEGER.

Description

Turns On/Off Catching of CMM motion errors

Syntax

Visual Basic
Public Sub CatchMotionError( _
   ByVal tog As CATCHTYPE, _
   ByRef catch_error As Long _
)

Parameters

tog
Value | Description
PCD__OFF | Turns off error catching. The basic script will no longer be notified when motion errors occur.
PCD_CATCH_IN_INTEGER | All subsequent motion errors will cause the integer passed by reference as the catch_error parameter to be set to a non-zero value.
PCD_TRIGGER_ERROR | All subsequent motion errors will generate runtime error 1001. These error may be caught using the On Error statement.
catch_error
A reference to the integer that will be set to a non-zero value if a CMM error occurs. When error catching is turned on, this integer is automatically initialized to zero. Only used when tog is set to PCD_CATCH_IN_INTEGER.

See Also

OldBasic Object


Check Method

Check Method
DISTANCE
The new check distance as a Double value.

Description

Creates a check distance object

Syntax

Visual Basic
Public Sub Check( _
   ByVal DISTANCE As Double _
)

Parameters

DISTANCE
The new check distance as a Double value.

See Also

OldBasic Object


ClearPlane Method

ClearPlane Method
plane1
Clearance plane. Options come from the WPLANETYPE emumeration.
val1
Double value representing the height of the workplane.
plane2
Pass through plane. Options come from the WPLANETYPE emumeration.
val2
Double value representing the height of the pass through plane.

Description

Creates a clearplane settings object

Syntax

Visual Basic
Public Sub ClearPlane( _
   ByVal plane1 As WPLANETYPE, _
   ByVal val1 As Double, _
   ByVal plane2 As WPLANETYPE, _
   ByVal val2 As Double _
)

Parameters

plane1
Value Description
PCD_TOP
PCD_RIGHT
PCD_BACK
PCD_BOTTOM
PCD_LEFT
PCD_FRONT
Clearance plane. Options come from the WPLANETYPE emumeration.
val1
Double value representing the height of the workplane.
plane2
Value Description
PCD_TOP
PCD_RIGHT
PCD_BACK
PCD_BOTTOM
PCD_LEFT
PCD_FRONT
Pass through plane. Options come from the WPLANETYPE emumeration.
val2
Double value representing the height of the pass through plane.

See Also

OldBasic Object


CloseCommConnection Method

CloseCommConnection Method
port
Long value representing the comm port to close.

Description

Closes port opened with OpenCommConnection Command Closes the port opened with the OpenCommConnection command.

Syntax

Visual Basic
Public Function CloseCommConnection( _
   ByVal port As Long _
) As Long

Parameters

port
Long value representing the comm port to close.

See Also

OldBasic Object


Column132 Method

Column132 Method
tog

Description

Creates a column 132 dimension display object Turns on or off 132 column mode.

Syntax

Visual Basic
Public Sub Column132( _
   ByVal tog As PCDONOFF _
)

Parameters

tog
Value Description
PCD_ON
PCD_OFF

See Also

OldBasic Object


Comment Method

Comment Method
ctype
Comment
The comment string.

Description

Creates a part program comment object

Syntax

Visual Basic
Public Sub Comment( _
   ByVal ctype As PCDCOMMENT, _
   ByVal Comment As String _
)

Parameters

ctype
Value Description
PCD_OPERATOR
PCD_REPORT
PCD_INPUT
Comment
The comment string.

See Also

OldBasic Object


CreateID Method

CreateID Method
ID
Reference to a string to hold the newly created ID.
ftype

Description

Generates and returns an Id based on part program generation settings

Syntax

Visual Basic
Public Sub CreateID( _
   ByRef ID As String, _
   ByVal ftype As CREATEIDTYPE _
)

Parameters

ID
Reference to a string to hold the newly created ID.
ftype
Value Description
PCD_ALIGNMENT
PCD_CURVE
READ___POINT
MEASURED___POINT
MEASURED___CIRCLE
MEASURED___SPHERE
MEASURED___LINE
MEASURED___CONE
MEASURED___CYLINDER
MEASURED___PLANE
MEASURED___SET
CONST___ORIG_POINT
CONST___OFF_POINT
CONST___PROJ_POINT
CONST___MID_POINT
CONST___DROP_POINT
CONST___PIERCE_POINT
CONST___INT_POINT
CONST___CAST_POINT
CONST___CORNER_POINT
CONST___BFRE_CIRCLE
CONST___BF_CIRCLE
CONST___PROJ_CIRCLE
CONST___REV_CIRCLE
CONST___CONE_CIRCLE
CONST___CAST_CIRCLE
CONST___INT_CIRCLE
CONST___BFRE_SPHERE
CONST___BF_SPHERE
CONST___PROJ_SPHERE
CONST___REV_SPHERE
CONST___CAST_SPHERE
CONST___BFRE_LINE
CONST___BF_LINE
CONST___PROJ_LINE
CONST___REV_LINE
CONST___MID_LINE
CONST___CAST_LINE
CONST___INT_LINE
CONST___OFF_LINE
CONST___ALN_LINE
CONST___PRTO_LINE
CONST___PLTO_LINE
CONST___BFRE_CONE
CONST___BF_CONE
CONST___PROJ_CONE
CONST___REV_CONE
CONST___CAST_CONE
CONST___BFRE_CYLINDER
CONST___BF_CYLINDER
CONST___PROJ_CYLINDER
CONST___REV_CYLINDER
CONST___CAST_CYLINDER
CONST___BFRE_PLANE
CONST___BF_PLANE
CONST___REV_PLANE
CONST___MID_PLANE
CONST___CAST_PLANE
CONST___OFF_PLANE
CONST___ALN_PLANE
CONST___PRTO_PLANE
CONST___PLTO_PLANE
CONST___HIPNT_PLANE
CONST_BFRE_ELLIPSE
CONST_BF_ELLIPSE
CONST_PROJ_ELLIPSE
CONST_REV_ELLIPSE
CONST_CAST_ELLIPSE
CONST_INT_ELLIPSE
CONST___SET
AUTO_VECTOR_HIT
AUTO_SURFACE_HIT
AUTO_EDGE_HIT
AUTO_ANGLE_HIT
AUTO_CORNER_HIT
AUTO___CIRCLE
AUTO___SPHERE
AUTO___CYLINDER
AUTO___ROUND_SLOT
AUTO___SQUARE_SLOT
AUTO___ELLIPSE
DIM_LOCATION
DIM_STRAIGHTNESS
DIM_ROUNDNESS
DIM_FLATNESS
DIM_PERPENDICULARITY
DIM_PARALLELISM
DIM_PROFILE
DIM_3D_DISTANCE
DIM_2D_DISTANCE
DIM_3D_ANGLE
DIM_2D_ANGLE
DIM_RUNOUT
DIM_CONCENTRICITY
DIM_ANGULARITY
DIM_KEYIN
DIM_TRUE_POSITION

See Also

OldBasic Object


DefaultAxes Method

DefaultAxes Method

Description

Generates automatic dimensioning axes based on dimension type

This command is used only for location and true position dimensions. If present, the default dimension axes are created. Calls to SetNoms with other axes passed as the dtype parameter will have no effect if this command is used.

Syntax

Visual Basic
Public Sub DefaultAxes()

See Also

OldBasic Object


DefaultHits Method

DefaultHits Method

Description

Generates hit values automatically for feature

This command is used within a Startfeature - EndFeature block and is used to cause the hits specified in the hits parameter of the StartFeature command to be automatically generated.

Syntax

Visual Basic
Public Sub DefaultHits()

See Also

OldBasic Object


DimFormat Method

DimFormat Method
flags
heading1
heading2
heading3
heading4
heading5
heading6

Description

Creates a DimFormat command

Syntax

Visual Basic
Public Sub DimFormat( _
   ByVal flags As DIMFORMATFLAG, _
   ByVal heading1 As DIMFORMATTYPE, _
   ByVal heading2 As DIMFORMATTYPE, _
   ByVal heading3 As DIMFORMATTYPE, _
   ByVal heading4 As DIMFORMATTYPE, _
   ByVal heading5 As DIMFORMATTYPE, _
   ByVal heading6 As DIMFORMATTYPE _
)

Parameters

flags
Value Description
PCD_HEADINGS
PCD_SYMBOLS
heading1
Value Description
PCD_NOT_USED
PCD_NOM
PCD_TOL
PCD_MEAS
PCD_MAXMIN
PCD_DEV
PCD_OUTTOL
PCD_DEVANG
heading2
Value Description
PCD_NOT_USED
PCD_NOM
PCD_TOL
PCD_MEAS
PCD_MAXMIN
PCD_DEV
PCD_OUTTOL
PCD_DEVANG
heading3
Value Description
PCD_NOT_USED
PCD_NOM
PCD_TOL
PCD_MEAS
PCD_MAXMIN
PCD_DEV
PCD_OUTTOL
PCD_DEVANG
heading4
Value Description
PCD_NOT_USED
PCD_NOM
PCD_TOL
PCD_MEAS
PCD_MAXMIN
PCD_DEV
PCD_OUTTOL
PCD_DEVANG
heading5
Value Description
PCD_NOT_USED
PCD_NOM
PCD_TOL
PCD_MEAS
PCD_MAXMIN
PCD_DEV
PCD_OUTTOL
PCD_DEVANG
heading6
Value Description
PCD_NOT_USED
PCD_NOM
PCD_TOL
PCD_MEAS
PCD_MAXMIN
PCD_DEV
PCD_OUTTOL
PCD_DEVANG

See Also

OldBasic Object


EndAlign Method

EndAlign Method

Description

Marks the end of the block started with StartAlign

This function must be called to end an alignment block.

Syntax

Visual Basic
Public Sub EndAlign()

See Also

OldBasic Object


EndDim Method

EndDim Method

Description

Marks the end of the block started with StartDimension

EndDim takes no parameters, but must be called to finish off the dimension block.

Syntax

Visual Basic
Public Sub EndDim()

See Also

OldBasic Object


EndFeature Method

EndFeature Method

Description

Marks the end of the block started with StartFeature

This function ends a measured, constructed, or auto feature block. It must always be present as the last function call in a feature block.

Syntax

Visual Basic
Public Sub EndFeature()

See Also

OldBasic Object


EndGetFeatPoint Method

EndGetFeatPoint Method

Description

Frees memory allocated by StartGetFeatPoint

Use this command to release the memory allocated for use by the StartGetFeatPoint and GetFeatPoint commands.

Syntax

Visual Basic
Public Sub EndGetFeatPoint()

See Also

OldBasic Object


EndScan Method

EndScan Method

Description

Marks end of block started with StartScan command

Call this when all of the other scan functions needed have been called.

The scan object is inserted in the command list with a call to this function.

Syntax

Visual Basic
Public Sub EndScan()

See Also

OldBasic Object


EquateAlign Method

EquateAlign Method
align1
String value of the first alignment.
align2
String value of the second alignment.

Description

Creates Equate Alignment Command Creates Equate alignment object

Syntax

Visual Basic
Public Sub EquateAlign( _
   ByVal align1 As String, _
   ByVal align2 As String _
)

Parameters

align1
String value of the first alignment.
align2
String value of the second alignment.

See Also

OldBasic Object


Feature Method

Feature Method
ID
String value of the ID string of the feature to add as an input for a best fit or iterative alignment.
pnt_tol
Double value of the point tolerance of the feature. Only used with best fit alignments.

Description

Identifies Feature to be used by BF2d, BF3d, or Iterative Alignment

This function must only be called after a call to BestFit2D, BestFit3D, or Iterate

Syntax

Visual Basic
Public Sub Feature( _
   ByVal ID As String, _
   ByVal pnt_tol As Double _
)

Parameters

ID
String value of the ID string of the feature to add as an input for a best fit or iterative alignment.
pnt_tol
Double value of the point tolerance of the feature. Only used with best fit alignments.

See Also

OldBasic Object


Flatness Method

Flatness Method
ID
String value of the string ID of the object to query.
out_zone
Double value of the output zone.

Description

Returns flatness information for command of specified ID This function was added for the tutor translator, and should be used with caution.

Syntax

Visual Basic
Public Function Flatness( _
   ByVal ID As String, _
   ByVal out_zone As Double _
) As Long

Parameters

ID
String value of the string ID of the object to query.
out_zone
Double value of the output zone.

Return Type

Non-zero if successfull. Zero if the object with the given ID string cannot be found.

See Also

OldBasic Object


GapOnly Method

GapOnly Method
tog

Description

Creates Gap Only Dimension Object

Syntax

Visual Basic
Public Sub GapOnly( _
   ByVal tog As PCDONOFF _
)

Parameters

tog
Value Description
PCD_ON
PCD_OFF

See Also

OldBasic Object


GetDimData Method

GetDimData Method
ID
The ID string of the dimension to access.
buffer
A record variable of type DimData in which to put the retrieved values. See below for a description of the DimData structure.
dtype

The type of data to retrieve for location or true position dimensions. Not needed for any other dimension type.

For location: PCD_X, PCD_Y, PCD_Z, PCD_D, PCD_R, PCD_A, PCD_T, PCD_PA, PCD_PR, PCD_V, PCD_L

For true position: PCD_X, PCD_Y, PCD_Z, PCD_DD, PCD_DF, PCD_PA, PCD_PR, PCD_TP

Description

Get dimension data from dimension specified by ID

Syntax

Visual Basic
Public Sub GetDimData( _
   ByVal ID As String, _
   ByVal buffer As DimData, _
   ByVal dtype As DIMAXISTYPE _
)

Parameters

ID
The ID string of the dimension to access.
buffer
A record variable of type DimData in which to put the retrieved values. See below for a description of the DimData structure.
dtype
Value Description
PCD_X
PCD_Y
PCD_Z
PCD_D
PCD_R
PCD_A
PCD_T
PCD_PA
PCD_PR
PCD_V
PCD_L
PCD_DD
PCD_DF
PCD_TP
PCD_S
PCD_RS
PCD_RT
PCD_PD
PCD_M

The type of data to retrieve for location or true position dimensions. Not needed for any other dimension type.

For location: PCD_X, PCD_Y, PCD_Z, PCD_D, PCD_R, PCD_A, PCD_T, PCD_PA, PCD_PR, PCD_V, PCD_L

For true position: PCD_X, PCD_Y, PCD_Z, PCD_DD, PCD_DF, PCD_PA, PCD_PR, PCD_TP

Remarks

The definition of the DimData record type is as follows:

Type DimData

Nom As Double
Plus As Double
Minus As Double
Meas As Double
Max As Double
Min As Double
Dev As Double
Out As Double
Dev_Angle As Double
Bonus As Double

End Type

Note: The GetDimData function may not be called mid block.

Note: The GetDimData function should only be called on dimensions. It is up to the user to make sure that the ID string passed in does not belong to a feature or an alignment. For retrieving data from features, use GetFeatData.

See Also

OldBasic Object


GetDimOutTol Method

GetDimOutTol Method

Description

Returns number of features that are out of tolerance

Returns the number of features that are out of tolerance at the time that this command is executed.

Syntax

Visual Basic
Public Function GetDimOutTol() As Long

See Also

OldBasic Object


GetFeatData Method

GetFeatData Method
ID
The ID string of the feature to access.
buffer
A record variable of type FeatData in which to put the retrieved values. See below for a description of the FeatData structure.
dtype
The type of data to retrieve.
XYZ
Type of data to put in xyz.
IJK
Type of data to put in ijk.

Description

Gets feature data from command with specified ID

Syntax

Visual Basic
Public Sub GetFeatData( _
   ByVal ID As String, _
   ByVal buffer As FeatData, _
   ByVal dtype As PCDMEASTHEO, _
   ByVal XYZ As XYZTYPES, _
   ByVal IJK As IJKTYPES _
)

Parameters

ID
The ID string of the feature to access.
buffer
A record variable of type FeatData in which to put the retrieved values. See below for a description of the FeatData structure.
dtype
Value Description
PCD_THEO
PCD__MEAS
The type of data to retrieve.
XYZ
Value Description
PCD_CENTROID
PCD_BALLCENTER
PCD_STARTPOINT
PCD_ENDPOINT
PCD_MIDPOINT
Type of data to put in xyz.
IJK
Value Description
PCD__VECTOR
PCD_SLOTVECTOR
PCD_SURFACEVECTOR
Type of data to put in ijk.

Return Type

The definition of the FeatData record type is as follows:

Type FeatData

X As Double
Y As Double
Z As Double
I As Double
J As Double
K As Double
Diam As Double
Length As Double
Angle As Double
Small_Diam As Double
Start_Angle As Double
End_Angle As Double
Start_Angle2 As Double
End_Angle2 As Double
F As Double
TP As Double
P1 As Double
P2 As Double
ID As String

End Type

Note: The GetFeatData function may not be called mid block.

Note: The GetFeatData function should only be called on measured, constructed, and auto features. It is up to the user to make sure that the ID string passed in does not belong to a dimension or an alignment. For retrieving data from dimensions, use GetDimData.

See Also

OldBasic Object


GetFeatID Method

GetFeatID Method
index
The count backwards that should be used to find the next item with an id.
ID
This string is filled in with the id of the nth object back from the current point when n is specified by index.
Type
Type of object to be considered.

Description

Returns id of indexed feature

Syntax

Visual Basic
Public Function GetFeatID( _
   ByVal index As Long, _
   ByRef ID As String, _
   ByVal Type As GETIDTYPE _
) As Long

Parameters

index
The count backwards that should be used to find the next item with an id.
ID
This string is filled in with the id of the nth object back from the current point when n is specified by index.
Type
Value Description
PCD__ALIGNMENT
PCD_FEATURE
PCD_DIMENSION
Type of object to be considered.

See Also

OldBasic Object


GetFeatPoint Method

GetFeatPoint Method
buffer

A record variable of type PointData in which to put the retrieved point.

index

The 1 based index of the point to retrieve.

Description

Fills buffer with hit data for command specified in StartGetFeatPoint Command This function is called after a call to StartGetFeatPoint to retrieve the actual points.

Syntax

Visual Basic
Public Function GetFeatPoint( _
   ByVal buffer As PointData, _
   ByVal index As Long _
) As Long

Parameters

buffer

A record variable of type PointData in which to put the retrieved point.

index

The 1 based index of the point to retrieve.

Remarks

The definition of the PointData record type is as follows:

Type PointData

X As Double
Y As Double
Z As Double

End Type

See Also

OldBasic Object


GetFeature Method

GetFeature Method
ID
The string ID of the object to query.

Description

Returns feature type (ie. Circle, Line, Point...)

Syntax

Visual Basic
Public Function GetFeature( _
   ByVal ID As String _
) As Long

Parameters

ID
The string ID of the object to query.

Return Type

The feature type of the object, or 0 if unsuccessful.

Remarks

This function was added for the tutor translator, and should be used with caution.

See Also

OldBasic Object


GetPH9Status Method

GetPH9Status Method

Description

Returns 1 if a PH9 is available

Syntax

Visual Basic
Public Function GetPH9Status() As Long

Return Type

Returns 1 if the probe has a PH9 and 0 if no PH9 is available.

See Also

OldBasic Object


GetProbeOffsets Method

GetProbeOffsets Method
buffer
A record of type pointdata that receives the values of the current xyz offset from the probe base.

Description

Returns the current probe offsets

Syntax

Visual Basic
Public Sub GetProbeOffsets( _
   ByVal buffer As PointData _
)

Parameters

buffer
A record of type pointdata that receives the values of the current xyz offset from the probe base.

See Also

OldBasic Object


GetProbeRadius Method

GetProbeRadius Method

Description

Returns the current probe radius Returns the current probe radius.

Syntax

Visual Basic
Public Function GetProbeRadius() As Double

See Also

OldBasic Object


GetProgramOption Method

GetProgramOption Method
opt
The option’s status that is being checked.

Description

Returns the status of the application setting option

Syntax

Visual Basic
Public Function GetProgramOption( _
   ByVal opt As RPROGOPTIONSTYPE _
) As Long

Parameters

opt
Value Description
PCD_AUTOTIPSELECT
PCD_AUTOPREHIT
PCD_ISONLINE
PCD_AUTOPROJREFPLANE
PCD_ISARMTYPECMM
PCD_HASINDEXPH9
PCD_HASINDEXROTTABLE
PCD_DISPSPEEDS
PCD_HASMANPH9
PCD_HASPHS
PCD_HASMANROTTABLE
PCD_HASROTTABLE
PCD_HASPH9
PCD_ENDKEY
PCD_EXTSHEETMETAL
PCD_FLYMODE
PCD_TABLEAVOIDANCE
PCD_USEDIMCOLORS
The option’s status that is being checked.

Return Type

Returns 1 if the option is on and 0 if the option is off

See Also

OldBasic Object


GetProgramValue Method

GetProgramValue Method
opt

The option’s value that is being retrieved.

Description

Returns the value of the application setting

Syntax

Visual Basic
Public Function GetProgramValue( _
   ByVal opt As RPROGVALUESTYPE _
) As Double

Parameters

opt
Value Description
PCD_ROTTABLEANGLE
PCD_PROBERADIUS
PCD_DIMPLACES
PCD_FLYRADIUS
PCD_AUTOTRIGDISTANCE
PCD_TABLETOL
PCD_MANRETRACT
PCD_MEASSCALE
PCD_PH9WARNDELTA
PCD_VALISYSERRTIMEOUT

The option’s value that is being retrieved.

Return Type

Returns the current value of the given option.

See Also

OldBasic Object


GetTopMachineSpeed Method

GetTopMachineSpeed Method

Description

Returns the top machine speed value Returns the top machine speed of the CMM.

Syntax

Visual Basic
Public Function GetTopMachineSpeed() As Double

See Also

OldBasic Object


GetType Method

GetType Method
ID
The string ID of the object to query.

Description

Returns the type of command with the specified ID Returns the type of the object.

Syntax

Visual Basic
Public Function GetType( _
   ByVal ID As String _
) As Long

Parameters

ID
The string ID of the object to query.

Return Type

The type of the object, or 0 if unsuccessful. Possible types are any of the types passed to StartFeature or StartDim.

Remarks

This function was added for the tutor translator, and should be used with caution.

See Also

OldBasic Object


GetUnits Method

GetUnits Method

Description

Indicates whether units are metric or english The units of the current part program.

Syntax

Visual Basic
Public Function GetUnits() As Long

Return Type

A value of 1 is returned when units are in inches and 0 when units are in millimeters.

See Also

OldBasic Object


Hit Method

Hit Method
X
Double X value for the hit.
Y
Double Y value for the hit.
Z
Double Z value for the hit.
I
Double I value for the approach vector.
J
Double J value for the approach vector.
K
Double K value for the approach vector.

Description

Used in feature block to add a hit to an object

Syntax

Visual Basic
Public Sub Hit( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal I As Double, _
   ByVal J As Double, _
   ByVal K As Double _
)

Parameters

X
Double X value for the hit.
Y
Double Y value for the hit.
Z
Double Z value for the hit.
I
Double I value for the approach vector.
J
Double J value for the approach vector.
K
Double K value for the approach vector.

Remarks

This function is used for measured features only. It may be omitted on measured circles, cones, cylinders, spheres and points as these features generate default hits. However, if circular moves are required between each hit, the hit function should be provided as a place holder. The parameters may be eliminated, in which case the default hit x, y, z and i, j, k are used.

See Also

OldBasic Object


IgnoreMotionError Method

IgnoreMotionError Method
tog
TRUE (1) or FALSE (0). TRUE indicates that we wish to begin ignoring CMM motion errors. FALSE means we wish to stop ignoring CMM motion errors.

Description

Sets recalculation of nominals mode

Syntax

Visual Basic
Public Sub IgnoreMotionError( _
   ByVal tog As Long _
)

Parameters

tog
TRUE (1) or FALSE (0). TRUE indicates that we wish to begin ignoring CMM motion errors. FALSE means we wish to stop ignoring CMM motion errors.

See Also

OldBasic Object


Iterate Method

Iterate Method
pnt_tol
The point tolerance.
flags

Description

Creates Iterative Alignment Command

Syntax

Visual Basic
Public Sub Iterate( _
   ByVal pnt_tol As Double, _
   ByVal flags As ITERATEFLAGS _
)

Parameters

pnt_tol
The point tolerance.
flags
Value Description
PCD_BODY_AX
PCD_AV_ERROR
PCD_MEAS_ALL
PCD_MEAS_ALL_ALWAYS

See Also

OldBasic Object


Level Method

Level Method
AXIS
Axis to level.
feat
ID string of the feature to level to.

Description

Creates Level Alignment Command

Syntax

Visual Basic
Public Sub Level( _
   ByVal AXIS As WAXISTYPE, _
   ByVal feat As String _
)

Parameters

AXIS
Value Description
PCD_ZPLUS
PCD_XPLUS
PCD_YPLUS
PCD_ZMINUS
PCD_XMINUS
PCD_YMINUS
Axis to level.
feat
ID string of the feature to level to.

See Also

OldBasic Object


LoadProbe Method

LoadProbe Method
probe
The probe to load.

Description

Creates Load Probe Command

Syntax

Visual Basic
Public Sub LoadProbe( _
   ByVal probe As String _
)

Parameters

probe
The probe to load.

See Also

OldBasic Object


MaxMinAve Method

MaxMinAve Method
ID
The string ID of the object to query.
in_vect
Input vector.
out_max
A reference to a double to hold the output maximum.
out_min
A reference to a double to hold the output minimum.
out_ave
A reference to a double to hold the output average.

Description

Returns maximum, minimum, or average information for command of specified id

Syntax

Visual Basic
Public Function MaxMinAve( _
   ByVal ID As String, _
   ByVal in_vect As PointData, _
   ByRef out_max As Double, _
   ByRef out_min As Double, _
   ByRef out_ave As Double _
) As Long

Parameters

ID
The string ID of the object to query.
in_vect
Input vector.
out_max
A reference to a double to hold the output maximum.
out_min
A reference to a double to hold the output minimum.
out_ave
A reference to a double to hold the output average.

Return Type

Long value. Non-zero if successful. Zero if the object with the given ID string cannot be found.

Remarks

This function was added for the tutor translator, and should be used with caution.

See Also

OldBasic Object


Mode Method

Mode Method
Mode

Description

Creates DCC / Manual Mode Command

Syntax

Visual Basic
Public Sub Mode( _
   ByVal Mode As DCCMODE _
)

Parameters

Mode
Value Description
PCD_DCC
PCD_MANUAL

See Also

OldBasic Object


Move Method

Move Method
tog
X
X value of point or increment.
Y
Y value of point or increment.
Z
Z value of point or increment.
Direction

Description

Creates Move (Probe or Rotary Table) Command

Syntax

Visual Basic
Public Sub Move( _
   ByVal tog As MOVETYPE, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double, _
   ByVal Direction As MOVEDIRECTION _
)

Parameters

tog
Value Description
PCD_CLEARPLANE
PCD_INCREMENT
PCD_CIRCULAR
PCD_POINT
PCD_ROTAB
X
X value of point or increment.
Y
Y value of point or increment.
Z
Z value of point or increment.
Direction
Value Description
PCD_CLOCKWISE
PCD_COUNTERCLOCKWISE
PCD_SHORTEST

See Also

OldBasic Object


MoveSpeed Method

MoveSpeed Method
percent
Move speed of the probe as a percentage of the maximum probe speed.

Description

Creates Move Speed Command

Syntax

Visual Basic
Public Sub MoveSpeed( _
   ByVal percent As Double _
)

Parameters

percent
Move speed of the probe as a percentage of the maximum probe speed.

See Also

OldBasic Object


OpenCommConnection Method

OpenCommConnection Method
port
The comm port to open. Required.
baud
The baud rate at which to communicate with the port. Optiona. Default is PCD_BAUD_9600.
parity
Optional. Default is PCD_NOPARITY.
Data
Data Bits. Optional. Default is PCD_DATA8.
stop
Stop bits. Optional. Default is PCD_ONESTOPBIT.
flow
Flow control. Optional. Default is PCD_RTSCTS.

Description

Opens a communication port for reading and writing Opens a connection to the specified comm port.

Syntax

Visual Basic
Public Function OpenCommConnection( _
   ByVal port As Long, _
   ByVal baud As PCDBAUD, _
   ByVal parity As PCDPARITY, _
   ByVal Data As PCDDATABITS, _
   ByVal stop As PCDSTOPBITS, _
   ByVal flow As PCDHANDSHAKE _
) As Long

Parameters

port
The comm port to open. Required.
baud
Value Description
PCD_BAUD_110
PCD_BAUD_300
PCD_BAUD_600
PCD_BAUD_1200
PCD_BAUD_2400
PCD_BAUD_4800
PCD_BAUD_9600
PCD_BAUD_14400
PCD_BAUD_19200
PCD_BAUD_38400
PCD_BAUD_56000
PCD_BAUD_128000
PCD_BAUD_256000
The baud rate at which to communicate with the port. Optiona. Default is PCD_BAUD_9600.
parity
Value Description
PCD_NOPARITY
PCD_EVENPARITY
PCD_ODDPARITY
PCD_MARKPARITY
PCD_SPACEPARITY
Optional. Default is PCD_NOPARITY.
Data
Value Description
PCD_DATA8
PCD_DATA7
Data Bits. Optional. Default is PCD_DATA8.
stop
Value Description
PCD_ONESTOPBIT
PCD_ONE5STOPBITS
PCD_TWOSTOPBITS
Stop bits. Optional. Default is PCD_ONESTOPBIT.
flow
Value Description
PCD_DTRDSR
PCD_RTSCTS
PCD_XONXOFF
Flow control. Optional. Default is PCD_RTSCTS.

Return Type

Long value. 0 if successfull, -1 on error.

See Also

OldBasic Object


PreHit Method

PreHit Method
DISTANCE
New prehit distance.

Description

Creates Prehit Distance Command

Syntax

Visual Basic
Public Sub PreHit( _
   ByVal DISTANCE As Double _
)

Parameters

DISTANCE
New prehit distance.

See Also

OldBasic Object


ProbeComp Method

ProbeComp Method
tog
Turns probe compensation on or off.

Description

Creates Probe Compensation Command

Syntax

Visual Basic
Public Sub ProbeComp( _
   ByVal tog As PCDONOFF _
)

Parameters

tog
Value Description
PCD_ON
PCD_OFF
Turns probe compensation on or off.

See Also

OldBasic Object


PutFeatData Method

PutFeatData Method
ID
buffer
dtype
XYZ
IJK

Description

Puts feature data into the command specified by the ID

Syntax

Visual Basic
Public Sub PutFeatData( _
   ByVal ID As String, _
   ByVal buffer As FeatData, _
   ByVal dtype As PCDMEASTHEO, _
   ByVal XYZ As XYZTYPES, _
   ByVal IJK As IJKTYPES _
)

Parameters

ID
buffer
dtype
Value Description
PCD_THEO
PCD__MEAS
XYZ
Value Description
PCD_CENTROID
PCD_BALLCENTER
PCD_STARTPOINT
PCD_ENDPOINT
PCD_MIDPOINT
IJK
Value Description
PCD__VECTOR
PCD_SLOTVECTOR
PCD_SURFACEVECTOR

Remarks

Parameters, allowed values, and limitations are identical to those of GetFeatData. The data currently in buffer is stored in the feature identified by the ID string.

See Also

OldBasic Object


ReadCommBlock Method

ReadCommBlock Method
port
The comm port from which to read. Required.
buffer
The string in which to put the read characters. Required.
Count
The maximum number of characters to read from the port. Required.

Description

Reads data from an opened communications port Reads characters from the comm port specified.

Syntax

Visual Basic
Public Function ReadCommBlock( _
   ByVal port As Long, _
   ByRef buffer As String, _
   ByVal Count As Long _
) As Long

Parameters

port
The comm port from which to read. Required.
buffer
The string in which to put the read characters. Required.
Count
The maximum number of characters to read from the port. Required.

See Also

OldBasic Object


RecallEx Method

RecallEx Method
recallID
String ID of external alignment to recall.
fname

Description

Creates Recall Alignment Command for External Alignments

Syntax

Visual Basic
Public Sub RecallEx( _
   ByVal recallID As String, _
   ByVal fname As String _
)

Parameters

recallID
String ID of external alignment to recall.
fname

Remarks

This function does not need to be called within an alignment block.

See Also

OldBasic Object


RecallIn Method

RecallIn Method
recallID
String ID of internal alignment to recall.

Description

Creates Recall Alignment Command for Internal Alignments

Syntax

Visual Basic
Public Sub RecallIn( _
   ByVal recallID As String _
)

Parameters

recallID
String ID of internal alignment to recall.

Remarks

This function does not need to be called within an alignment block.

See Also

OldBasic Object


Retract Method

Retract Method
DISTANCE
New retract distance.

Description

Creates a Retract Distance Command

Syntax

Visual Basic
Public Sub Retract( _
   ByVal DISTANCE As Double _
)

Parameters

DISTANCE
New retract distance.

See Also

OldBasic Object


RetroOnly Method

RetroOnly Method
tog

Description

Creates a Retrolinear Only Dimension Command

Syntax

Visual Basic
Public Sub RetroOnly( _
   ByVal tog As PCDONOFF _
)

Parameters

tog
Value Description
PCD_ON
PCD_OFF

See Also

OldBasic Object


Rotate Method

Rotate Method
axis1
Axis to rotate.
feat
ID string of the feature to rotate to.
axis2
Axis to rotate about.

Description

Creates a Rotate Alignment Command

Syntax

Visual Basic
Public Sub Rotate( _
   ByVal axis1 As WAXISTYPE, _
   ByVal feat As String, _
   ByVal axis2 As WAXISTYPE _
)

Parameters

axis1
Value Description
PCD_ZPLUS
PCD_XPLUS
PCD_YPLUS
PCD_ZMINUS
PCD_XMINUS
PCD_YMINUS
Axis to rotate.
feat
ID string of the feature to rotate to.
axis2
Value Description
PCD_ZPLUS
PCD_XPLUS
PCD_YPLUS
PCD_ZMINUS
PCD_XMINUS
PCD_YMINUS
Axis to rotate about.

See Also

OldBasic Object


RotateCircle Method

RotateCircle Method
Feat1
ID string of circle.
Feat2
ID string of second circle.
axis1
Axis to rotate.
axis2
Axis to rotate about.

Description

Creates a Circular Rotation Alignment Command

Syntax

Visual Basic
Public Sub RotateCircle( _
   ByVal Feat1 As String, _
   ByVal Feat2 As String, _
   ByVal axis1 As WAXISTYPE, _
   ByVal axis2 As WAXISTYPE _
)

Parameters

Feat1
ID string of circle.
Feat2
ID string of second circle.
axis1
Value Description
PCD_ZPLUS
PCD_XPLUS
PCD_YPLUS
PCD_ZMINUS
PCD_XMINUS
PCD_YMINUS
Axis to rotate.
axis2
Value Description
PCD_ZPLUS
PCD_XPLUS
PCD_YPLUS
PCD_ZMINUS
PCD_XMINUS
PCD_YMINUS
Axis to rotate about.

See Also

OldBasic Object


RotateOffset Method

RotateOffset Method
Offset
Offset value.
AXIS
Axis to rotate about.

Description

Creates a Rotational Offset Command

Syntax

Visual Basic
Public Sub RotateOffset( _
   ByVal Offset As Double, _
   ByVal AXIS As WAXISTYPE _
)

Parameters

Offset
Offset value.
AXIS
Value Description
PCD_ZPLUS
PCD_XPLUS
PCD_YPLUS
PCD_ZMINUS
PCD_XMINUS
PCD_YMINUS
Axis to rotate about.

See Also

OldBasic Object


Roundness Method

Roundness Method
ID
The string ID of the object to query.
out_zone
A reference to a double to hold the output zone.

Description

Returns roundness information for command of specified ID

Syntax

Visual Basic
Public Function Roundness( _
   ByVal ID As String, _
   ByRef out_zone As Double _
) As Long

Parameters

ID
The string ID of the object to query.
out_zone
A reference to a double to hold the output zone.

Return Type

Non-zero if successfull. Zero if the object with the given ID string cannot be found.

Remarks

This function was added for the tutor translator, and should be used with caution.

See Also

OldBasic Object


RunOut Method

RunOut Method
ID
The string ID of the object to query.
in_datumxyz
Input xyz.
in_datumijk
Input ijk.
out_zone
A reference to a double to hold the output zone.

Description

Returns runout information for command of specified ID

Syntax

Visual Basic
Public Function RunOut( _
   ByVal ID As String, _
   ByVal in_datumxyz As PointData, _
   ByVal in_datumijk As PointData, _
   ByRef out_zone As Double _
) As Long

Parameters

ID
The string ID of the object to query.
in_datumxyz
Input xyz.
in_datumijk
Input ijk.
out_zone
A reference to a double to hold the output zone.

Return Type

Non-zero if successfull. Zero if the object with the given ID string cannot be found.

Remarks

This function was added for the tutor translator, and should be used with caution.

See Also

OldBasic Object


SaveAlign Method

SaveAlign Method
AlignID
ID string of the alignment to save.
fname
File in which to save the alignment.

Description

Creates a Save Alignment Command

Syntax

Visual Basic
Public Sub SaveAlign( _
   ByVal AlignID As String, _
   ByVal fname As String _
)

Parameters

AlignID
ID string of the alignment to save.
fname
File in which to save the alignment.

See Also

OldBasic Object


SetAutoParams Method

SetAutoParams Method
INIT_HITS
Sample hits for initial execution
PERM_HITS
Sample hits for subsequent executions
Depth
Sheet metal measuring depth
Height
Height of stud for a sheet metal circle, sheet metal cylinder or sheet metal ellipse; or the long length of a slot
wdth
Short width of a slot.
Radius
Corner radius of a square slot.
Spacer
Distance from the nominal feature or nominal feature edge where sample hits are taken.
Indent
Like spacer but in a different direction. Used in edge points, corner points, and angle points.
Thickness
Thickness of the shetmetal.
DISTANCE
major
Major axis of ellipse.
minor
Minor axis of ellipse.

Description

Sets Auto Feature Parameters inside StartFeature Block

Syntax

Visual Basic
Public Sub SetAutoParams( _
   Optional ByVal INIT_HITS As Variant, _
   Optional ByVal PERM_HITS As Variant, _
   Optional ByVal Depth As Variant, _
   Optional ByVal Height As Variant, _
   Optional ByVal wdth As Variant, _
   Optional ByVal Radius As Variant, _
   Optional ByVal Spacer As Variant, _
   Optional ByVal Indent As Variant, _
   Optional ByVal Thickness As Variant, _
   Optional ByVal DISTANCE As Variant, _
   Optional ByVal major As Variant, _
   Optional ByVal minor As Variant _
)

Parameters

INIT_HITS
Sample hits for initial execution
PERM_HITS
Sample hits for subsequent executions
Depth
Sheet metal measuring depth
Height
Height of stud for a sheet metal circle, sheet metal cylinder or sheet metal ellipse; or the long length of a slot
wdth
Short width of a slot.
Radius
Corner radius of a square slot.
Spacer
Distance from the nominal feature or nominal feature edge where sample hits are taken.
Indent
Like spacer but in a different direction. Used in edge points, corner points, and angle points.
Thickness
Thickness of the shetmetal.
DISTANCE
major
Major axis of ellipse.
minor
Minor axis of ellipse.

Remarks

This function is used for auto features only.

See Also

OldBasic Object


SetAutoVector Method

SetAutoVector Method
index
Which vector to set.
I
Double I value for the vector.
J
Double J value for the vector.
K
Double K value for the vector.

Description

Sets Auto Vector Components (used inside StartFeature Block)

Syntax

Visual Basic
Public Sub SetAutoVector( _
   ByVal index As AUTOVECTORTYPES, _
   ByVal I As Double, _
   ByVal J As Double, _
   ByVal K As Double _
)

Parameters

index
Value Description
PCD_VECTOR1
PCD_VECTOR2
PCD_VECTOR3
PCD_PUNCH_VECTOR
PCD_PIN_VECTOR
PCD_ANGLE_VECTOR
PCD_REPORT_VECTOR
PCD_EDGE_REPORT_VECTOR
PCD_SURF_REPORT_VECTOR
PCD_MEASURE_VECTOR
PCD_UPDATE_VECTOR
Which vector to set.
I
Double I value for the vector.
J
Double J value for the vector.
K
Double K value for the vector.

Remarks

This function is used for auto features only.

See Also

OldBasic Object


SetNoms Method

SetNoms Method
dtype
nom
Double value indicating nominal. May be omitted when no nominal is needed.
plus_tol
Double value indicating plus tolerance.
minus_tol
Double value indicating minus tolerance. May be omitted when no minus tolerance is needed.
multiplier
Arrow multiplier for dimension. Optional. Defaults to 1.0.

Description

Set nominal values for dimension (used inside StartDimension Block)

Syntax

Visual Basic
Public Sub SetNoms( _
   ByVal dtype As DIMAXISTYPE, _
   Optional ByVal nom As Variant, _
   Optional ByVal plus_tol As Variant, _
   Optional ByVal minus_tol As Variant, _
   Optional ByVal multiplier As Variant _
)

Parameters

dtype
Value Description
PCD_X
PCD_Y
PCD_Z
PCD_D
PCD_R
PCD_A
PCD_T
PCD_PA
PCD_PR
PCD_V
PCD_L
PCD_DD
PCD_DF
PCD_TP
PCD_S
PCD_RS
PCD_RT
PCD_PD
PCD_M
nom
Double value indicating nominal. May be omitted when no nominal is needed.
plus_tol
Double value indicating plus tolerance.
minus_tol
Double value indicating minus tolerance. May be omitted when no minus tolerance is needed.
multiplier
Arrow multiplier for dimension. Optional. Defaults to 1.0.

Remarks

When the DefaultAxes command is not used for dimensions of type location and true position, an axis corresponding to the dtype parameter is added for every call to SetNoms.

See Also

OldBasic Object


SetPrintOptions Method

SetPrintOptions Method
Location
Location of outpout.
Draft
Mode of output to printer.
Filemode
Naming mode for output file.
ExtNum
Used with PCD_AUTO mode naming scheme for output file

Description

Sets application printing options

Syntax

Visual Basic
Public Sub SetPrintOptions( _
   ByVal Location As PCDPRINTLOC, _
   ByVal Draft As PCDONOFF, _
   ByVal Filemode As PCDPRINTFILEMODE, _
   ByVal ExtNum As Long _
)

Parameters

Location
Value | Description
PCD___OFF | No destination for printed data.
PCD_PRINTER | Destination for the printed data is printer.
PCD_FILE | Destination for the printed data is a file.
Location of outpout.
Draft
Value Description
PCD_ON
PCD_OFF
Mode of output to printer.
Filemode
Value | Description
PCD_APPEND | Appends information to the end of the file.
PCD_NEWFILE | Sends information to a new file.
PCD_OVERWRITE | Overwrites information in the current file.
PCD_AUTO | Automatically increments a numeric extension for the output file name.
PCD_PROMPT | Prompts the user for a filename.
Naming mode for output file.
ExtNum
Used with PCD_AUTO mode naming scheme for output file

See Also

OldBasic Object


SetProgramOption Method

SetProgramOption Method
opt
Program option to set.
tog
Specifies whether option should be turned on or off.

Description

Sets application program option

Syntax

Visual Basic
Public Sub SetProgramOption( _
   ByVal opt As WPROGOPTIONSTYPE, _
   ByVal tog As PCDONOFF _
)

Parameters

opt
Value Description
PCD__AUTOTIPSELECT
PCD__AUTOPREHIT
PCD__AUTOPROJREFPLANE
PCD__DISPSPEEDS
PCD__ENDKEY
PCD__EXTSHEETMETAL
PCD__FLYMODE
PCD__TABLEAVOIDANCE
PCD__USEDIMCOLORS
Program option to set.
tog
Value Description
PCD_ON
PCD_OFF
Specifies whether option should be turned on or off.

See Also

OldBasic Object


SetProgramValue Method

SetProgramValue Method
opt
Program value to set.
val
New value for program value being set.

Description

Sets application program value

Syntax

Visual Basic
Public Sub SetProgramValue( _
   ByVal opt As WPROGVALUESTYPE, _
   ByVal val As Double _
)

Parameters

opt
Value Description
PCD__PROBERADIUS
PCD__DIMPLACES
PCD__FLYRADIUS
PCD__AUTOTRIGDISTANCE
PCD__TABLETOL
PCD__MANRETRACT
PCD__MEASSCALE
PCD__PH9WARNDELTA
PCD__VALISYSERRTIMEOUT
Program value to set.
val
New value for program value being set.

See Also

OldBasic Object


SetReportOptions Method

SetReportOptions Method
opt
Any of these combined flags can be used to turn on or off the reporting object types.

Description

Sets application reporting settings

Syntax

Visual Basic
Public Sub SetReportOptions( _
   ByVal opt As PCDREPORTSETTINGS _
)

Parameters

opt
Value Description
PCD_FEATURES
PCD_ALIGNMENTS
PCD_MOVES
PCD_COMMENTS
PCD_DIMENSIONS
PCD_HITS
PCD_OUTTOL_ONLY
Any of these combined flags can be used to turn on or off the reporting object types.

See Also

OldBasic Object


SetRMeasMode Method

SetRMeasMode Method
Mode
The mode to be used for auto features using the RMEAS functionality. PCD_RELATIVE or PCD_ABSOLUTE.

Description

Sets Relative Measure mode to Relative or Absolute

Syntax

Visual Basic
Public Sub SetRMeasMode( _
   ByVal Mode As Long _
)

Parameters

Mode
The mode to be used for auto features using the RMEAS functionality. PCD_RELATIVE or PCD_ABSOLUTE.

See Also

OldBasic Object


SetScanHitParams Method

SetScanHitParams Method
htype
INIT_HITS
Number of init sample hits to use. Optional.
PERM_HITS
Number of permanent hits. Optional.
Spacer
Spacer value. Optional.
Depth
Depth value. Optional.
Indent
Indent value. Optional.
flags
For now, just PCD_EXTERIOR or PCD_INTERIOR. Default is PCD_EXTERIOR. Optional.

Description

Sets scan hit parameters (used in StartScan block)

Syntax

Visual Basic
Public Sub SetScanHitParams( _
   ByVal htype As PCDSCANHITTYPE, _
   ByVal INIT_HITS As Long, _
   ByVal PERM_HITS As Long, _
   ByVal Spacer As Double, _
   ByVal Depth As Double, _
   ByVal Indent As Double, _
   ByVal flags As PCDSCANHITFLAG _
)

Parameters

htype
Value Description
PCD_VECTORHIT
PCD_SURFACEHIT
PCD_EDGEHIT
PCD_ANGLEHIT
INIT_HITS
Number of init sample hits to use. Optional.
PERM_HITS
Number of permanent hits. Optional.
Spacer
Spacer value. Optional.
Depth
Depth value. Optional.
Indent
Indent value. Optional.
flags
Value Description
PCD_EXTERIOR
PCD_INTERIOR
For now, just PCD_EXTERIOR or PCD_INTERIOR. Default is PCD_EXTERIOR. Optional.

Remarks

This function is only used for DCC scans and should not be called for manual scans.

See Also

OldBasic Object


SetScanHitVectors Method

SetScanHitVectors Method
Vector
Hit vector to set.
I
Long I of the hit vector.
J
Long J of the hit vector.
K
Long K of the hit vector.

Description

Sets hit vector components of scan (used in StartScan block)

Syntax

Visual Basic
Public Sub SetScanHitVectors( _
   ByVal Vector As PCDSCANVECTORSURF, _
   ByVal I As Long, _
   ByVal J As Long, _
   ByVal K As Long _
)

Parameters

Vector
Value Description
PCD_TOP_SURFACE
PCD_SIDE_SURFACE
PCD_BOUNDARY_PLANE
Hit vector to set.
I
Long I of the hit vector.
J
Long J of the hit vector.
K
Long K of the hit vector.

See Also

OldBasic Object


SetScanParams Method

SetScanParams Method
incr
Increment value for LINE, BODY, and CUTAXIS scan techniques. Optional.
AXIS
Axis for BODY and CUTAXIS scan techniques. PCD_XAXIS, PCD_YAXIS, PCD_ZAXIS. Optional.
max_incr
For VARIABLE scan techniques. Optional.
min_incr
For VARIABLE scan techniques. Optional.
MAX_ANGLE
For VARIABLE scan techniques. Optional.
MIN_ANGLE
For VARIABLE scan techniques. Optional.
delta
Distance delta for FIXED_DELTA scans, time delta for VARIABLE_DELTA and TIME_DELTA scans. Optional.
DISTANCE
Drop point distance for VARIABLE_DELTA scan, distance for CUTAXIS scan. Optional.
incr2
Increment value in second direction for a patch scan. Optional.
axis2
Second axis value for a patch scan (BODY scan technique only). Optional.
surf_thickness
Surface thickness used to offset centroid calculation if necessary. Optional.

Description

Sets scan parameters (used in StartScan block)

Syntax

Visual Basic
Public Sub SetScanParams( _
   ByVal incr As Double, _
   ByVal AXIS As PAXISTYPE, _
   ByVal max_incr As Double, _
   ByVal min_incr As Double, _
   ByVal MAX_ANGLE As Double, _
   ByVal MIN_ANGLE As Double, _
   ByVal delta As Double, _
   ByVal DISTANCE As Double, _
   ByVal incr2 As Double, _
   ByVal axis2 As PAXISTYPE, _
   ByVal surf_thickness As Double _
)

Parameters

incr
Increment value for LINE, BODY, and CUTAXIS scan techniques. Optional.
AXIS
Value Description
PCD_ZAXIS
PCD_XAXIS
PCD_YAXIS
Axis for BODY and CUTAXIS scan techniques. PCD_XAXIS, PCD_YAXIS, PCD_ZAXIS. Optional.
max_incr
For VARIABLE scan techniques. Optional.
min_incr
For VARIABLE scan techniques. Optional.
MAX_ANGLE
For VARIABLE scan techniques. Optional.
MIN_ANGLE
For VARIABLE scan techniques. Optional.
delta
Distance delta for FIXED_DELTA scans, time delta for VARIABLE_DELTA and TIME_DELTA scans. Optional.
DISTANCE
Drop point distance for VARIABLE_DELTA scan, distance for CUTAXIS scan. Optional.
incr2
Increment value in second direction for a patch scan. Optional.
axis2
Value Description
PCD_ZAXIS
PCD_XAXIS
PCD_YAXIS
Second axis value for a patch scan (BODY scan technique only). Optional.
surf_thickness
Surface thickness used to offset centroid calculation if necessary. Optional.

See Also

OldBasic Object


SetScanVectors Method

SetScanVectors Method
Vector
Vector to set.
I
Double I value of the vector.
J
Double J value of the vector.
K
Double K value of the vector.

Description

Sets vector components of scan (used in StartScan block)

Syntax

Visual Basic
Public Sub SetScanVectors( _
   ByVal Vector As PCDSCANVECTOR, _
   ByVal I As Double, _
   ByVal J As Double, _
   ByVal K As Double _
)

Parameters

Vector
Value Description
PCD_CUTVECTOR
PCD_INITTOUCH
PCD_INITDIR
PCD_ROWEND_APPROACH
Vector to set.
I
Double I value of the vector.
J
Double J value of the vector.
K
Double K value of the vector.

See Also

OldBasic Object


SetSlaveMode Method

SetSlaveMode Method
tog
Turns slave mode off or on for all subsequent created commands. PCD_ON or PCD_OFF

Description

Turns on/turns off slave mode (subsequent objects are slave object/master objects)

Syntax

Visual Basic
Public Sub SetSlaveMode( _
   ByVal tog As PCDONOFF _
)

Parameters

tog
Value Description
PCD_ON
PCD_OFF
Turns slave mode off or on for all subsequent created commands. PCD_ON or PCD_OFF

See Also

OldBasic Object


SetTheos Method

SetTheos Method
X
Y
Z
I
J
K
diam
Diameter of a circle, cylinder, or sphere. Big diameter of a cone.
Length
Length of a cylinder.
Angle
Angle of a cone.
small_diam
Small diameter of a cone.
start_angle
Starting angles for circles, cylinders, and spheres.
end_angle
Ending angles for circles, cylinders, and spheres.
start_angle2
Second starting angle for spheres.
end_angle2
Second ending angles for spheres.

Description

Sets theoretical values for feature (used in StartFeature block)

Syntax

Visual Basic
Public Sub SetTheos( _
   Optional ByVal X As Variant, _
   Optional ByVal Y As Variant, _
   Optional ByVal Z As Variant, _
   Optional ByVal I As Variant, _
   Optional ByVal J As Variant, _
   Optional ByVal K As Variant, _
   Optional ByVal diam As Variant, _
   Optional ByVal Length As Variant, _
   Optional ByVal Angle As Variant, _
   Optional ByVal small_diam As Variant, _
   Optional ByVal start_angle As Variant, _
   Optional ByVal end_angle As Variant, _
   Optional ByVal start_angle2 As Variant, _
   Optional ByVal end_angle2 As Variant _
)

Parameters

X
Y
Z
I
J
K
diam
Diameter of a circle, cylinder, or sphere. Big diameter of a cone.
Length
Length of a cylinder.
Angle
Angle of a cone.
small_diam
Small diameter of a cone.
start_angle
Starting angles for circles, cylinders, and spheres.
end_angle
Ending angles for circles, cylinders, and spheres.
start_angle2
Second starting angle for spheres.
end_angle2
Second ending angles for spheres.

Remarks

A call to SetTheos is mandatory for all measured features.

See Also

OldBasic Object


ShowXYZWindow Method

ShowXYZWindow Method
show
Show or hides the probe position window. PCD_ON or PCD_OFF.

Description

Shows or Hides the probe readouts window

Syntax

Visual Basic
Public Sub ShowXYZWindow( _
   ByVal show As Long _
)

Parameters

show
Show or hides the probe position window. PCD_ON or PCD_OFF.

See Also

OldBasic Object


Sleep Method

Sleep Method
seconds
The number of seconds to pause. Any precision beyond milliseconds is ignored.

Description

Wait until execution catches up to script, then wait for a number of seconds Pauses execution for the specified number of seconds after the previous feature has finished executing.

Syntax

Visual Basic
Public Sub Sleep( _
   ByVal seconds As Single _
)

Parameters

seconds
The number of seconds to pause. Any precision beyond milliseconds is ignored.

Remarks

Sleep calls the Wait function to ensure that the sleeping does not begin before all previous features have been executed.

See Also

OldBasic Object


StartAlign Method

StartAlign Method
ID
ID string of the alignment to create.
recallID
ID string of the alignment to recall.

Description

Starts Alignment block and sets alignment parameters

Syntax

Visual Basic
Public Sub StartAlign( _
   ByVal ID As String, _
   ByVal recallID As String _
)

Parameters

ID
ID string of the alignment to create.
recallID
ID string of the alignment to recall.

See Also

OldBasic Object


StartDim Method

StartDim Method
dtype
ID
ID string of the dimension to create.
Feat1
ID string of the Of Feature or From Feature.
Feat2
ID string of the To Feature.
Feat3
ID string of the third feature, if any.
AXIS
Only needed for dimensions using an axis or workplane.
Length
Extended length for angularity, profile, perpendicularity, or parallelism.
Angle
Angle for angularity.
flags
Use OR for multiple values. For example, PCD_ADD_RADIUS Or PCD_PAR_TO.

Description

Starts Dimension block and sets dimension parameters

Syntax

Visual Basic
Public Sub StartDim( _
   ByVal dtype As PCDDIMTYPES, _
   ByVal ID As String, _
   ByVal Feat1 As String, _
   ByVal Feat2 As String, _
   ByVal Feat3 As String, _
   ByVal AXIS As PAXISTYPE, _
   ByVal Length As Double, _
   ByVal Angle As Double, _
   ByVal flags As PCDSTARTDIMFLAGS _
)

Parameters

dtype
Value Description
DIM__LOCATION
DIM__STRAIGHTNESS
DIM__ROUNDNESS
DIM__FLATNESS
DIM__PERPENDICULARITY
DIM__PARALLELISM
DIM__PROFILE
DIM__3D_DISTANCE
DIM__2D_DISTANCE
DIM__3D_ANGLE
DIM__2D_ANGLE
DIM__RUNOUT
DIM__CONCENTRICITY
DIM__ANGULARITY
DIM__KEYIN
DIM__TRUE_POSITION
ID
ID string of the dimension to create.
Feat1
ID string of the Of Feature or From Feature.
Feat2
ID string of the To Feature.
Feat3
ID string of the third feature, if any.
AXIS
Value Description
PCD_ZAXIS
PCD_XAXIS
PCD_YAXIS
Only needed for dimensions using an axis or workplane.
Length
Extended length for angularity, profile, perpendicularity, or parallelism.
Angle
Angle for angularity.
flags
Value Description
PCD_NO_RADIUS
PCD_ADD_RADIUS
PCD_SUB_RADIUS
PCD_RFS_RFS
PCD_RFS_MMC
PCD_RFS_LMC
PCD_MMC_RFS
PCD_MMC_MMC
PCD_MMC_LMC
PCD_LMC_RFS
PCD_LMC_MMC
PCD_LMC_LMC
PCD_PERP_TO
PCD_PAR_TO
PCD_RECALC_NOMS
Use OR for multiple values. For example, PCD_ADD_RADIUS Or PCD_PAR_TO.

Remarks

The datum computation type comes first. For example, PCD_RFS_LMC specifies RFS for the datum and LMC for the feature.

See Also

OldBasic Object


StartFeature Method

StartFeature Method
ftype
ID
ID string of the feature.
RefID
hits
Measured and auto features only. The number of hits to take to measure the feature.
rows
inputs
Constructed features only. The number of features that will be used in the construction. There must be a corresponding number of calls to AddFeature before the EndFeature statement.
flags
You can use OR to use any of the flags together.
RefPlane

Description

Starts Feature block and sets feature parameters

Syntax

Visual Basic
Public Sub StartFeature( _
   ByVal ftype As PCDSTARTFEATTYPES, _
   ByVal ID As String, _
   ByVal RefID As String, _
   ByVal hits As Long, _
   ByVal rows As Long, _
   ByVal inputs As Long, _
   ByVal flags As PCDSTARTFEATFLAGS, _
   ByVal RefPlane As WPLANETYPE _
)

Parameters

ftype
Value Description
PCD__CURVE
READ__POINT
MEASURED__POINT
MEASURED__CIRCLE
MEASURED__SPHERE
MEASURED__LINE
MEASURED__CONE
MEASURED__CYLINDER
MEASURED__PLANE
MEASURED__SET
MEAS_POINT
MEAS_CIRCLE
MEAS_SPHERE
MEAS_LINE
MEAS_CONE
MEAS_CYLINDER
MEAS_PLANE
MEAS_SET
CONST__ORIG_POINT
CONST__OFF_POINT
CONST__PROJ_POINT
CONST__MID_POINT
CONST__DROP_POINT
CONST__PIERCE_POINT
CONST__INT_POINT
CONST__CAST_POINT
CONST__CORNER_POINT
CONST__BFRE_CIRCLE
CONST__BF_CIRCLE
CONST__PROJ_CIRCLE
CONST__REV_CIRCLE
CONST__CONE_CIRCLE
CONST__CAST_CIRCLE
CONST__INT_CIRCLE
CONST__SCAN_SEG_ARC
CONST__BFRE_SPHERE
CONST__BF_SPHERE
CONST__PROJ_SPHERE
CONST__REV_SPHERE
CONST__CAST_SPHERE
CONST__SCAN_SEG_LINE
CONST__BFRE_LINE
CONST__BF_LINE
CONST__PROJ_LINE
CONST__REV_LINE
CONST__MID_LINE
CONST__CAST_LINE
CONST__INT_LINE
CONST__OFF_LINE
CONST__ALN_LINE
CONST__PRTO_LINE
CONST__PLTO_LINE
CONST__BFRE_CONE
CONST__BF_CONE
CONST__PROJ_CONE
CONST__REV_CONE
CONST__CAST_CONE
CONST__BFRE_CYLINDER
CONST__BF_CYLINDER
CONST__PROJ_CYLINDER
CONST__REV_CYLINDER
CONST__CAST_CYLINDER
CONST__BFRE_PLANE
CONST__BF_PLANE
CONST__REV_PLANE
CONST__MID_PLANE
CONST__CAST_PLANE
CONST__OFF_PLANE
CONST__ALN_PLANE
CONST__PRTO_PLANE
CONST__PLTO_PLANE
CONST__HIPNT_PLANE
CONST__SET
AUTO__VECTOR_HIT
AUTO__SURFACE_HIT
AUTO__EDGE_HIT
AUTO__ANGLE_HIT
AUTO__CORNER_HIT
AUTO__CIRCLE
AUTO__SPHERE
AUTO__CYLINDER
AUTO__ROUND_SLOT
AUTO__SQUARE_SLOT
AUTO__ELLIPSE
ID
ID string of the feature.
RefID
hits
Measured and auto features only. The number of hits to take to measure the feature.
rows
inputs
Constructed features only. The number of features that will be used in the construction. There must be a corresponding number of calls to AddFeature before the EndFeature statement.
flags
Value | Description
PCD_NORM | For auto circles, cylinders, ellipses, and slots. Do not combine with PCD_PIN. Default.
PCD_RECT | Values are in rectangular coordinates. Should not be combined with PCD_POLR. Default.
PCD_UNBND | Unbound line. Should not be ored with PCD_BND. Default.
PCD_OUT | Outside circle, sphere, cone, or cylinder. Should not be used with PCD_IN. Default.
PCD_LENGTH | Cone reports its length as opposed to angle. Do not or with PCD_ANGLE. Default.
PCD__EXTERIOR | Exterior angle hit. Only used for auto angle hits. Do not or with PCD_INTERIOR. Default.
PCD_MEASURE_SURFACE | Sets measure order. For auto edge points only. Default.
PCD_TRIM | For auto edge points only. Should not be ored with PCD_HEM. Default.
PCD__TOP
PCD__ZPLUS
PCD__ZAXIS
PCD__ZMINUS
PCD__BOTTOM
PCD__XPLUS
PCD__LEFT
PCD__XAXIS
PCD__XMINUS
PCD__RIGHT
PCD__YPLUS
PCD__FRONT
PCD__YAXIS
PCD__YMINUS
PCD__BACK
PCD__INTERIOR | Interior angle hit. Only used for auto angle hits. Should not be combined with PCD_EXTERIOR.
PCD_POLR | Values are reported in cylindrical coordinates. Should not be combined with PCD_RECT.
PCD_IN | Inside circle, sphere, cone, or cylinder. Should not be combined with PCD_OUT.
PCD_ANGLE | Cone reports its angle as opposed to length. Should not be combined with PCD_LENGTH.
PCD_BND | Bound line. Should not be combined with PCD_UNBND.
PCD_MEASURE_EDGE | Sets measure order. For auto edge points only.
PCD_MEASURE_BOTH | Sets measure order. For auto edge points only.
PCD_HEM | For auto edge points only. Should not be ored with PCD_TRIM.
PCD_PIN | For auto circles, cylinders, ellipses, and slots. Do not or with PCD_NORM.
PCD_READPOS | Turn read position on. For auto circles, cylinders, ellipses, and slots. Defaults to off.
PCD_LINE_3D | 3D line. Used only for best fit lines. Default is a 2D line.
PCD__RECALC_NOMS | Indicates that the theoretical values should be recalculated based on the theoretical hit values.
PCD_AUTOMOVE | Causes move points to be automatically generated for auto features.
PCD_FINDHOLE | For Auto Circles. Automatic finding of holes.
PCD_MEASURE_WIDTH | Flag for Auto Square Slots.
You can use OR to use any of the flags together.
RefPlane
Value Description
PCD_TOP
PCD_RIGHT
PCD_BACK
PCD_BOTTOM
PCD_LEFT
PCD_FRONT

See Also

OldBasic Object


StartGetFeatPoint Method

StartGetFeatPoint Method
ID
The ID string of the feature to access.
dtype
The type of data to retrieve.
XYZ
Type of data to put in xyz.

Description

Sets aside memory buffer of hit data for use with the GetFeatPoint command This function is used to retrieve the hit or input data from constructed, measured, and auto features, as well as the hit data for scans. To retrieve the actual points, subsequent calls to GetFeatPoint must be made. When all of the needed point values have been retrieved, a call to EndGetFeatPoint must be made to free the memory allocated for the points.

Syntax

Visual Basic
Public Function StartGetFeatPoint( _
   ByVal ID As String, _
   ByVal dtype As PCDMEASTHEO, _
   ByVal XYZ As PCDGETPOINTSTYPES _
) As Long

Parameters

ID
The ID string of the feature to access.
dtype
Value Description
PCD_THEO
PCD__MEAS
The type of data to retrieve.
XYZ
Value Description
PCD__CENTROID
PCD__BALLCENTER
PCD_VECTOR
Type of data to put in xyz.

Return Type

The number of points retrieved from the object.

Remarks

The StartGetFeatPoint function may not be called mid block.

See Also

OldBasic Object


StartScan Method

StartScan Method
ID
ID string of the scan.
Mode
Mode of the scan.
stype
Type of scan. For DCC scans, stype must be PCD_LINEAR_OPEN, PCD_LINEAR_CLOSED, PCD_SECTION, PCD_PERIMETER, or PCD_PATCH. For manual scans, stype must be PCD_MANUALTTP or PCD_HPROBE.
dir1
Only used for DCC scans. Optional.
dir2
Only used for DCC patch scans. Optional.
technique
Only used for manual scans. Optional.
num_bnd_pnts
Number of points defining the boundary for the scan. Only used for DCC patch scans. Optional.
flags
Special scan flags. Any of these values may be combined using OR. Optional.

Description

Starts Scan block and sets sets scan parameters

Syntax

Visual Basic
Public Sub StartScan( _
   ByVal ID As String, _
   ByVal Mode As DCCMODE, _
   ByVal stype As PCDSTARTSCANTYPES, _
   ByVal dir1 As PCDSCANDIR1, _
   ByVal dir2 As PCDSCANDIR2, _
   ByVal technique As PCDSCANTECHNIQUE, _
   ByVal num_bnd_pnts As Long, _
   ByVal flags As PCDSTARTSCANFLAGS _
)

Parameters

ID
ID string of the scan.
Mode
Value Description
PCD_DCC
PCD_MANUAL
Mode of the scan.
stype
Value Description
PCD_LINEAR_OPEN
PCD_LINEAR_CLOSED
PCD_PATCH
PCD_MANUALTTP
PCD_HPROBE
PCD_SECTION
PCD_PERIMETER
Type of scan. For DCC scans, stype must be PCD_LINEAR_OPEN, PCD_LINEAR_CLOSED, PCD_SECTION, PCD_PERIMETER, or PCD_PATCH. For manual scans, stype must be PCD_MANUALTTP or PCD_HPROBE.
dir1
Value Description
PCD_BODY
PCD_VARIABLE
PCD_LINE
Only used for DCC scans. Optional.
dir2
Value Description
PCD__BODY
PCD__LINE
Only used for DCC patch scans. Optional.
technique
Value Description
PCD_FIXED_DELTA
PCD_VARIABLE_DELTA
PCD_TIME_DELTA
PCD_CUTAXIS
Only used for manual scans. Optional.
num_bnd_pnts
Number of points defining the boundary for the scan. Only used for DCC patch scans. Optional.
flags
Value Description
PCD_SINGLEPOINT
PCD_MASTERMODE
PCD_RELEARNMODE
PCD_AUTOCLEARPLANE
PCD_HITNOTDISPLAYED
Special scan flags. Any of these values may be combined using OR. Optional.

See Also

OldBasic Object


Stats Method

Stats Method
tog
Indicates whether stats is on or off.
dbase_dir
Database directory. Optional.
read_lock
Optional.
write_lock
Optional.
mem_page
Optional.
flags
Optional.

Description

Creates Stats On/Off command

Syntax

Visual Basic
Public Sub Stats( _
   ByVal tog As PCDONOFF, _
   ByVal dbase_dir As String, _
   ByVal read_lock As Long, _
   ByVal write_lock As Long, _
   ByVal mem_page As Long, _
   ByVal flags As PCDSTATSFLAGS _
)

Parameters

tog
Value Description
PCD_ON
PCD_OFF
Indicates whether stats is on or off.
dbase_dir
Database directory. Optional.
read_lock
Optional.
write_lock
Optional.
mem_page
Optional.
flags
Value Description
PCD_USE_DIM_NAME
PCD_USE_FEAT_NAME
PCD_DO_CONTROL_CALCS
Optional.

See Also

OldBasic Object


Straitness Method

Straitness Method
ID
The string ID of the object to query.
out_zone
A reference to a double to hold the output zone.

Description

Returns straitness information for command of specified ID

Syntax

Visual Basic
Public Function Straitness( _
   ByVal ID As String, _
   ByRef out_zone As Double _
) As Long

Parameters

ID
The string ID of the object to query.
out_zone
A reference to a double to hold the output zone.

Return Type

Non-zero if successful. Zero if the object with the given ID string cannot be found.

Remarks

This function was added for the tutor translator, and should be used with caution.

See Also

OldBasic Object


Tip Method

Tip Method
Tip
I
J
K
Angle

Description

Creates Tip command The tip to load.

Syntax

Visual Basic
Public Sub Tip( _
   ByVal Tip As String, _
   ByVal I As Double, _
   ByVal J As Double, _
   ByVal K As Double, _
   ByVal Angle As Double _
)

Parameters

Tip
I
J
K
Angle

See Also

OldBasic Object


Touchspeed Method

Touchspeed Method
percent
Touchspeed of the probe as a percentage of the maximum probe speed.

Description

Creates touch speed command

Syntax

Visual Basic
Public Sub Touchspeed( _
   ByVal percent As Double _
)

Parameters

percent
Touchspeed of the probe as a percentage of the maximum probe speed.

See Also

OldBasic Object


Trace Method

Trace Method
field
Name of the field to trace.

Description

Creates trace field command

Syntax

Visual Basic
Public Sub Trace( _
   ByVal field As String _
)

Parameters

field
Name of the field to trace.

See Also

OldBasic Object


Translate Method

Translate Method
AXIS
feat
ID string of feature to translate to.

Description

Creates translation alignment command

Syntax

Visual Basic
Public Sub Translate( _
   ByVal AXIS As PAXISTYPE, _
   ByVal feat As String _
)

Parameters

AXIS
Value Description
PCD_ZAXIS
PCD_XAXIS
PCD_YAXIS
feat
ID string of feature to translate to.

See Also

OldBasic Object


TranslateOffset Method

TranslateOffset Method
Offset
Value of offset.
AXIS

Description

Creates a translation offset command

Syntax

Visual Basic
Public Sub TranslateOffset( _
   ByVal Offset As Double, _
   ByVal AXIS As PAXISTYPE _
)

Parameters

Offset
Value of offset.
AXIS
Value Description
PCD_ZAXIS
PCD_XAXIS
PCD_YAXIS

See Also

OldBasic Object


Wait Method

Wait Method

Description

Wait until execution catches up to script

Waits until all preceding commands have been executed. The basic script creates commands and places them on the execute list more rapidly than the commands are executed. In a script it is often useful to pop up a dialog box for input after a certain series of commands has been executed. The script commands may complete long before the actual commands have been executed. The Wait command is useful to prevent the dialog box from popping up prematurely.

Syntax

Visual Basic
Public Sub Wait()

See Also

OldBasic Object


Workplane Method

Workplane Method
plane

Options come from the WPLANETYPE emumeration. Optional. If not provided, the current workplane is returned but no new workplane is set.

Description

Creates a workplane object or gets the current workplane

Syntax

Visual Basic
Public Function Workplane( _
   ByVal plane As WPLANETYPE _
) As Long

Parameters

plane
Value Description
PCD_TOP
PCD_RIGHT
PCD_BACK
PCD_BOTTOM
PCD_LEFT
PCD_FRONT

Options come from the WPLANETYPE emumeration. Optional. If not provided, the current workplane is returned but no new workplane is set.

See Also

OldBasic Object


WriteCommBlock Method

WriteCommBlock Method
port
The comm port to close. Required.
buffer
The string to write to the port. Required.
Count
The number of characters to write to the port. Optional. Defaults to the length of the buffer string.

Description

Writes data to an opened communications port Writes characters to the specified comm port.

Syntax

Visual Basic
Public Function WriteCommBlock( _
   ByVal port As Long, _
   ByVal buffer As String, _
   ByVal Count As Long _
) As Long

Parameters

port
The comm port to close. Required.
buffer
The string to write to the port. Required.
Count
The number of characters to write to the port. Optional. Defaults to the length of the buffer string.

Return Type

0 if successfull, -1 on error.

See Also

OldBasic Object


Application Property

Application Property

Description

Read Only: Returns Application object

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

See Also

OldBasic Object


Parent Property

Parent Property

Description

Read Only: Returns Partprogram object

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As PartProgram

See Also

OldBasic Object


OPTIONPROBE Object

OPTIONPROBE Object
See Also Members

Description

The OPTIONPROBE object provides support for the Optional Probe command.

Remarks

Through this object you can get and set various properties of an option probe command in PC-DMIS. For more information on the option probe command, see the "Parameter Settings: Optional Probe tab" topic of the "Setting Your Preferences" section of the PC-DMIS Help File.

See Also

OPTIONPROBE Members


OPTIONPROBE Object Members

OPTIONPROBE ObjectMembers
See Also Overview

Public Properties

Public Property LowForce | Read/Write: Low force setting Double value used to set or get the probe low force setting.
Public Property ManFineProbing | Read/Write: Man Fine Probing
Public Property MaxForce | Read/Write: Maximum force setting Double value used to set or get the probe max force setting.
Public Property PositionalAccuracy | Read/Write: Positional Accuracy Double value used to set or get the positional accuracy setting.
Public Property ProbeAccuracy | Read/Write: Probe Accuracy setting Double value used to set or get the probe accuracy setting.
Public Property ProbingMode | Read/Write: Probing Mode
Public Property ReturnData | Read/Write: Return data setting Double value used to set or get the probe return data value.
Public Property ReturnSpeed | Read/Write: Return speed setting Double value used to set or get the probe return data value.
Public Property ScanAcceleration | Read/Write: Scan Acceleration
Public Property ScanOffsetForce | Read/Write: Scan Offset Force
Public Property ScanPointDensity | Read/Write: Scan Point Density Double value used to set or get the probe scan point density setting.
Public Property TriggerForce | Read/Write: Trigger force setting Double value used to set or get the probe scan point density setting.
Public Property UpperForce | Read/Write: Upper force setting Double value used to set or get the probe upper force setting.

See Also

OPTIONPROBE Overview


LowForce Property

LowForce Property

Description

Read/Write: Low force setting Double value used to set or get the probe low force setting.

Property type

Read-write property

Syntax

Visual Basic
Public Property LowForce() As Double

Return Type

Read/write Double value.

See Also

OPTIONPROBE Object


ManFineProbing Property

ManFineProbing Property

Description

Read/Write: Man Fine Probing

Property type

Read-write property

Syntax

Visual Basic
Public Property ManFineProbing() As Long

See Also

OPTIONPROBE Object


MaxForce Property

MaxForce Property

Description

Read/Write: Maximum force setting Double value used to set or get the probe max force setting.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxForce() As Double

Return Type

Read/write Double value.

See Also

OPTIONPROBE Object


PositionalAccuracy Property

PositionalAccuracy Property

Description

Read/Write: Positional Accuracy Double value used to set or get the positional accuracy setting.

Property type

Read-write property

Syntax

Visual Basic
Public Property PositionalAccuracy() As Double

Return Type

Read/write Double value.

See Also

OPTIONPROBE Object


ProbeAccuracy Property

ProbeAccuracy Property

Description

Read/Write: Probe Accuracy setting Double value used to set or get the probe accuracy setting.

Property type

Read-write property

Syntax

Visual Basic
Public Property ProbeAccuracy() As Double

Return Type

Read/write Double value.

See Also

OPTIONPROBE Object


ProbingMode Property

ProbingMode Property

Description

Read/Write: Probing Mode

Property type

Read-write property

Syntax

Visual Basic
Public Property ProbingMode() As String

See Also

OPTIONPROBE Object


ReturnData Property

ReturnData Property

Description

Read/Write: Return data setting Double value used to set or get the probe return data value.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReturnData() As Double

Return Type

Read/write Double value.

See Also

OPTIONPROBE Object


ReturnSpeed Property

ReturnSpeed Property

Description

Read/Write: Return speed setting Double value used to set or get the probe return data value.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReturnSpeed() As Double

Return Type

Read/write Double value.

See Also

OPTIONPROBE Object


ScanAcceleration Property

ScanAcceleration Property

Description

Read/Write: Scan Acceleration

Property type

Read-write property

Syntax

Visual Basic
Public Property ScanAcceleration() As Double

See Also

OPTIONPROBE Object


ScanOffsetForce Property

ScanOffsetForce Property

Description

Read/Write: Scan Offset Force

Property type

Read-write property

Syntax

Visual Basic
Public Property ScanOffsetForce() As Double

See Also

OPTIONPROBE Object


ScanPointDensity Property

ScanPointDensity Property

Description

Read/Write: Scan Point Density Double value used to set or get the probe scan point density setting.

Property type

Read-write property

Syntax

Visual Basic
Public Property ScanPointDensity() As Double

Return Type

Read/write Double value.

See Also

OPTIONPROBE Object


TriggerForce Property

TriggerForce Property

Description

Read/Write: Trigger force setting Double value used to set or get the probe scan point density setting.

Property type

Read-write property

Syntax

Visual Basic
Public Property TriggerForce() As Double

Return Type

Read/write Double value.

See Also

OPTIONPROBE Object


UpperForce Property

UpperForce Property

Description

Read/Write: Upper force setting Double value used to set or get the probe upper force setting.

Property type

Read-write property

Syntax

Visual Basic
Public Property UpperForce() As Double

Return Type

Read/write Double value.

See Also

OPTIONPROBE Object


OptMotion Object

OptMotion Object
See Also Members

Description

The OptMotion command object is used to change optional motion settings for the PC-DMIS probe motion command object.

Remarks

This section does not define the meaning of the different properties. Additional information on the properties can be found in the "Setting Your Preferences" section of the PC-DMIS Help File, under the title "Parameter Settings: Acceleration tab".

See Also

OptMotion Members


OptMotion Object Members

OptMotion ObjectMembers
See Also Overview

Public Properties

Public Property MaxXAcceleration | Read/Write: Maximum X Acceleration Double value used to set or get the maximum acceleration in X setting.
Public Property MaxYAcceleration | Read/Write: Maximum Y Acceleration Double value used to set or get the maximum acceleration in Y setting.
Public Property MaxZAcceleration | Read/Write: Maximum Z Acceleration Double value used to set or get the maximum acceleration in Z setting.

See Also

OptMotion Overview


MaxXAcceleration Property

MaxXAcceleration Property

Description

Read/Write: Maximum X Acceleration Double value used to set or get the maximum acceleration in X setting.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxXAcceleration() As Double

Return Type

Read/write Double value.

See Also

OptMotion Object


MaxYAcceleration Property

MaxYAcceleration Property

Description

Read/Write: Maximum Y Acceleration Double value used to set or get the maximum acceleration in Y setting.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxYAcceleration() As Double

Return Type

Read/write Double value.

See Also

OptMotion Object


MaxZAcceleration Property

MaxZAcceleration Property

Description

Read/Write: Maximum Z Acceleration Double value used to set or get the maximum acceleration in Z setting.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaxZAcceleration() As Double

Return Type

Read/write Double value.

See Also

OptMotion Object


Page Object

Page Object
See Also Members

Description

This object contains information about a specific page in the Report window.

Object Model

Example

Sub Main

' This example loads a report template and then writes properties of each page to

' a text file in the same directory that contains this script.

' Modify the pathway and filename used for the LoadReportTemplate statement.

Dim App As Object

Dim PartProg As Object

Dim RepWin As Object

Dim Pages As Object

Dim Page As Object

Dim ReportControls As Object

Set App = CreateObject("Pcdlrn.Application")

Set PartProg = App.ActivePartProgram

Set RepWin = PartProg.ReportWindow

Set Pages = RepWin.Pages

RepWin.LoadReportTemplate "C:\PCDMIS43RC2\REPORTING\TEXTONLY.RTP"

RepWin.RefreshReport

Dim i,intWidth,intHeight As Integer

i = 1

Open "page_properties.txt" For Append As #1 ' This creates the file if it doesn't exist.

Write #1, "----- Page Results for " & RepWin.CurrentReport & " on " & Date() & " at " & Time() & " -----"

While i <= Pages.Count

Write #1, "==Page #" & i &" =="

If Pages.Item(i).LandScape <> 0 Then

Write #1, "Page is landscape"

Else

Write #1, "Page is not landscape"

End If

intWidth = Pages.Item(i).Width

intHeight = Pages.Item(i).Height

Write #1,"Page height is " & intHeight

Write #1,"Page width is " & intWidth

Write #1,"Page is in section: " & Pages.Item(i).Section

Write #1,"Page is custom: " & Pages.Item(i).Custom

Write #1,"Page is duplicated: " & Pages.Item(i).Duplicated

Write #1,"Page has this number of controls: " & Pages.Item(i).ReportControls.Count

i = i + 1

Wend

Close #1

End Sub

See Also

Page Members


Page Object Members

Page ObjectMembers
See Also Overview

Public Properties

Public Property _Number |
Public Property Application | Read Only: returns the Application Object
Public Property Custom | Read Only: returns the Custom page information This read-only property determines whether or not the Page object is from a Custom Report or not.
Public Property Duplicated | Read Only: returns the page Duplicated index This read-only property determines whether or not the page is the original page or a duplicate page.
Public Property Height | Read Only: returns the page Height in pixels This property returns the number of pixels making up the height of a page.
Public Property LandScape | Read Only: returns the page Orientation This read-only property returns the page's orientation.
Public Property Number | Read Only: returns the number of the page This read-only property returns this page's page number.
Public Property Parent | Read Only: returns the parent Pages object Returns the parent Pages object.
Public Property ReportControls | Read Only: returns the ReportControls object for this section This returns the ReportControls object for the page.
Public Property Section | Read Only: returns the page Section This read-only property returns the section index number that the page lies within.
Public Property Width | Read Only: returns the page Width in pixels This property returns the number of pixels making up the width of a page.

See Also

Page Overview


_Number Property

_Number Property

Property type

Read-write property

Syntax

Visual Basic
Public Property _Number() As Long

See Also

Page Object


Application Property

Application Property

Description

Read Only: returns the Application Object

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

See Also

Page Object


Custom Property

Custom Property

Description

Read Only: returns the Custom page information This read-only property determines whether or not the Page object is from a Custom Report or not.

Property type

Read-write property

Syntax

Visual Basic
Public Property Custom() As Long

Return Type

Read-only Long value. This returns -1 (or True) if it is a Custom Report and 0 (or False) if it is not.

See Also

Page Object


Duplicated Property

Duplicated Property

Description

Read Only: returns the page Duplicated index This read-only property determines whether or not the page is the original page or a duplicate page.

Property type

Read-write property

Syntax

Visual Basic
Public Property Duplicated() As Long

Return Type

Read-only Long value. It returns 0 if it is the original page. Any number greater than 0 represents a duplicate page index value.

See Also

Page Object


Height Property

Height Property

Description

Read Only: returns the page Height in pixels This property returns the number of pixels making up the height of a page.

Property type

Read-write property

Syntax

Visual Basic
Public Property Height() As Long

Return Type

Read-only Long value representing the page's height in pixels.

See Also

Page Object


LandScape Property

LandScape Property

Description

Read Only: returns the page Orientation This read-only property returns the page's orientation.

Property type

Read-write property

Syntax

Visual Basic
Public Property LandScape() As Long

Return Type

Read-only Long value. It returns 0 if it is not a landscape orientation. It returns -1 if it is a landscape orientation.

See Also

Page Object


Number Property

Number Property

Description

Read Only: returns the number of the page This read-only property returns this page's page number.

Property type

Read-write property

Syntax

Visual Basic
Public Property Number() As Long

Return Type

Long value representing the page number.

Remarks

This property starts counting at 0. So to get the actual page number you will need to increment this value by 1.

See Also

Page Object


Parent Property

Parent Property

Description

Read Only: returns the parent Pages object Returns the parent Pages object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Pages

Return Type

Pages object.

See Also

Page Object


ReportControls Property

ReportControls Property

Description

Read Only: returns the ReportControls object for this section This returns the ReportControls object for the page.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReportControls() As ReportControls

Remarks

This functions like the corresponding ReportControls property in the Section object.

See Also

Page Object | Section Object | ReportControls Property


Section Property

Section Property

Description

Read Only: returns the page Section This read-only property returns the section index number that the page lies within.

Property type

Read-write property

Syntax

Visual Basic
Public Property Section() As Long

Return Type

Read-only Long value representing the section that the page is in.

Remarks

The first section returns 0.

See Also

Page Object


Width Property

Width Property

Description

Read Only: returns the page Width in pixels This property returns the number of pixels making up the width of a page.

Property type

Read-write property

Syntax

Visual Basic
Public Property Width() As Long

Return Type

Read-only Long value representing the page's width in pixels.

See Also

Page Object


Pages Object

Pages Object
See Also Members

Description

This object contains a collection of the Page objects that appear in the Report window.

Object Model

Remarks

You can use Pages.Item to return a specific Page object.

See Also

Pages Members


Pages Object Members

Pages ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method Item | Returns the page with the given number Returns a specific Page object from the number of Pages in the Report window.

Public Properties

Public Property Application | Read Only: Returns the Application Object
Public Property Count | Read Only: Returns the number pages
Public Property Parent | Read Only: Returns the ReportWindow Parent Object

See Also

Pages Overview


_Item Method

_Item Method
Num

Syntax

Visual Basic
Public Function _Item( _
   ByVal Num As Long _
) As Page

Parameters

Num

See Also

Pages Object


Item Method

Item Method
Num
Long value representing the specific page to return from the report window

Description

Returns the page with the given number Returns a specific Page object from the number of Pages in the Report window.

Syntax

Visual Basic
Public Function Item( _
   ByVal Num As Long _
) As Page

Parameters

Num
Long value representing the specific page to return from the report window

Return Type

Page object.

See Also

Pages Object


Application Property

Application Property

Description

Read Only: Returns the Application Object

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

See Also

Pages Object


Count Property

Count Property

Description

Read Only: Returns the number pages

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

Return Type

Long value representing the total number of pages in the Report window.

See Also

Pages Object


Parent Property

Parent Property

Description

Read Only: Returns the ReportWindow Parent Object

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As ReportWindow

Return Type

ReportWindow object.

See Also

Pages Object


PartProgram Object

PartProgram Object
See Also Members

Description

PC-Dmis Part Program Object The PartProgram object represents a part program currently available in PC-DMIS. This is the main object used to manipulate part programs.

Object Model

See Also

PartProgram Members


PartProgram Object Members

PartProgram ObjectMembers
See Also Overview

Public Methods

Public Method Activate | Makes part program the active part program
Public Method AsyncExecute | Starts execution of the part program and returns immediately This function starts execution of the part program and then returns immediately, allowing for asynchronous execution.
Public Method AutoCreateGroupsForAudiMessPrograms | Converts AudiMess programs into groups
Public Method CalcAdjustTransform | Calculates part adjustment transformation in machine coordinates
Public Method ClearAllTADs | Clears the persistent User Assigned Properties data for all reports
Public Method ClearExecutionBlock | Clears the start and end commands set by SetExecutionBlock This clears the start and end commands set by the SetExecutionBlock method.
Public Method ClearTADs | Clears the persistent User Assigned Properties data for the current report
Public Method ClearVerifyFeaturesFlag | Clear the VerifyFeatures Flag
Public Method Close | Closes and saves the part program - object becomes invalid This subroutine saves, closes, and deactivates the part program.
Public Method DmisOut | Outputs DMIS results to a file This function outputs DMIS results to a file.
Public Method DmisOut2 | Outputs DMIS results to a file; option for output last instance only
Public Method EditRulesFile | Edits basic script rules file for default parameter managment (Inspection Planner)
Public Method EXECUTE | Executes the part program This function executes the part program.
Public Method Export | Exports part program to another format This function exports CAD or part data from the part program to the indicated file. The export format is determined by the file name extension of Name.
Public Method ExternalCommandEvent | ExternalCommandEvent
Public Method GetVariableValue | Returns a variable object of specified name, if it exists This method returns a variable object specified by the string in VarName.
Public Method Guess | Tries to guess what command has just been measured
Public Method IgnoreLearnModeHits | IgnoreLearnModeHits
Public Method Import | Imports from another format into the partprogram This function imports CAD or part data from the indicated file to the part program. The file format is determined by the file name extension of Name.
Public Method ImportUGDCI | ImportUGDCI
Public Method IsProbeAnalog | Returns true if the current probe on the selected arm is analog Returns TRUE if the current loaded probe in a part program is an analog probe; it returns FALSE otherwise. If you have multiple probe types defined for a part program, the return value will depend, of course, on the location of the insertion point in the part program.
Public Method LoadLayout | Loads a layout file The LoadLayout method loads a customized PC-DMIS user-interface layout as if it were selected from the Windows Layout toolbar inside PC-DMIS. Also, if a layout has been created and moved to a different directory, you can access it by specifying the absolute or relative file name. For information on using this toolbar, see the "Using Toolbars" section inside your PC-DMIS Help File.
Public Method MessageBox | Prompts user with message box above the part program This function uses the PC-DMIS message box function. It includes all functionality including cancelling of execution tied to the Cancel button.
Public Method OverrideExecuteSpeed | Overrides the current execution speed
Public Method Quit | Quits the part program without saving This subroutine closes and deactivates the part program without saving.
Public Method RefreshPart | Refreshes the Part (Edit/CAD Window Refreshes the display of the Part in the Edit window and in the CAD window.
Public Method RemoveLastLearnHit | Removes the last learn-mode hit
Public Method RunJournalFile | Executes the part program with Journal File data This executes the part program using point data collected from a journal file.
Public Method Save | Saves the part program This subroutine saves the part program. If the part program has not been saved before, it opens a Save As Dialog box which requires that you name the file.
Public Method SaveAs | Saves the part program with the provided name
Public Method SetExecutionBlock | Sets the start and end commands for block execution, calls to Execute or AsyncExecute will used until cleared This method defines a block of commands to execute. Calls are made to the Execute or AsyncExecute functions until the execution block is cleared with the ClearExecutionBlock method.
Public Method SetVariableValue | Sets the variable value of specified name, if valid and can be set This method sets the value defined in Value for the variable specified by the string in VarName.
Public Method SetVerifyFeaturesFlag | Set the VerifyFeatures Flag
Public Method ToggleMasterSlaveMode | Enters/Exits Master-Slave Mode
Public Method WaitUntilExecuted | Delays script execution until command is executed This method waits until the specified Command object executes, or until Timeout seconds pass.

Public Properties

Public Property _Name |
Public Property ActiveMachine | Read Only: Returns the machine object in use by part program - CMM or Offline Returns the Machine object associated with this part program.
Public Property Application | Read Only: Returns object pointer of type Application Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.
Public Property CadModel | Read Only: Returns Cad Model Object
Public Property CadWindows | Read Only: Returns object pointer of type CadWindows Returns the CadWindows object associated with this part program.
Public Property Commands | Read Only: Returns object pointer of type Commands - access partprogram command list Returns the Commands collection object of this part program.
Public Property ConnectedInDriveMode | Read Only: Returns true when computer connected as driving computer
Public Property ConnectedInRelayMode | Read Only: Returns true when computer connected as relay computer
Public Property ConnectedToMaster | Read Only: Returns true if connected to master computer as slave Returns TRUE if the part program is on the master computer but is running as the slave part program. Returns FALSE otherwise.
Public Property ConnectedToSlave | Read Only: Returns true if connected to slave computer as master Returns TRUE if the part program is on the slave computer but is running as the master part program. Returns FALSE otherwise.
Public Property CurrentArm | Read/Write: Returns/Sets the current arm environment This read/write property returns or sets the active arm when using PC-DMIS in multiple arm mode.
Public Property CurrentProbeName | Read: Returns the Name of current probe file
Public Property EditWindow | Read Only: Returns object pointer of type EditWindow Returns the Editwindow object associated with this part program.
Public Property EditWindowTextAll | Read Only: Returns the edit window text in the current mode Returns a single string containing all the text of the entire Edit window as seen in the Edit window's command mode. Read only.
Public Property ExecutedCommands | Read Only: Returns the set of commands from the last execution The ExecutedCommands property returns the ExecutedCommands object. This object contains a collection class of those commands last executed for the current part program.
Public Property ExecuteDialogVisible | Read/Write: Gives status / makes execute dialog visible or hidden
Public Property ExecutionWasCancelled | Read Only: Returns true if the last execution run was cancelled Returns TRUE if, during part program execution, the execution is cancelled. Otherwise it returns FALSE. The default value is FALSE.
Public Property FullName | Read Only: Full filename for part program - includes path Returns the part program’s full file path and name.
Public Property MasterSlaveDlg | Read Only: Returns the Master/Slave Calibration Dialog Object This returns a read-only pointer to the Master/Slave Calibration dialog box, opening the dialog box if necessary.
Public Property Name | Read Only: Filename of part program - not including path Returns the part program’s file name.
Public Property NoActiveProbesObject | Read: Property indicating no Probes object are instantiated
Public Property OldBasic | Read Only: Old Basic object - gives access to old basic commands - v2.x Returns this part program’s OldBasic object. The OldBasic object contains all of the methods from the old basic command set used in previous versions of PC-DMIS.
Public Property Parent | Read Only: Returns object pointer to PartPrograms Object Returns the PartPrograms collection object to which this part program belongs.
Public Property PartName | Read/Write: PartName property of part program Represents the part name of the part program.
Public Property PartProgramSettings | Read Only: Returns object pointer to PartProgramSettings Object
Public Property Path | Read Only: Path where part program is located Returns the part program’s file path.
Public Property Probes | Read Only: Returns object pointer to probe files The Probes property returns this part program’s Probes collection object.
Public Property QuickStart | Read Only: Returns object pointer to QuickStart Object
Public Property ReportWindow | Read Only: Returns object pointer of type ReportWindow
Public Property RevisionNumber | Read/Write: Revision Number of part program Represents the part program’s revision number.
Public Property SerialNumber | Read/Write: Serial Number of part program Represents the part program’s serial number.
Public Property ShowAllIDs | Read/Write: Property indicating whether to show all IDs in the CAD Window
Public Property Speed | Read Only: Returns Execution speed (0 if not executing)
Public Property StatsCount | Read/Write: Returns/Sets the current Stats Count; number of parts run Returns or sets the stats count for the current part program. Read/Write Long.
Public Property Tools | Read Only: Returns object pointer to tools {ie. calibration tools} The Tools property returns this part program’s Tools collection object.
Public Property Units | Read Only: Returns the unit type Returns the measurement unit type used in the part program. Either inches or millimeters.
Public Property Visible | Read/Write: Gives status / Makes part program visible Represents the part program’s visibility status.

Events

Public Event OnAddObject | Event fired when command is added to part program This event gets launched when the specified Command gets added to the part program.
Public Event OnEndExecution | Event fired when part program execution ends This event gets launched when PC-DMIS finishes executing the part program. PC-DMIS determines it has finished execution based on the termination type.
Public Event OnExecuteDialogErrorMsg | Event fired when error message sent to execute dialog This event gets launched when the Execution Mode Options dialog box displays ErrorMsg.
Public Event OnExecuteDialogStatusMsg | Event fired when status message sent to execute dialog This event gets launched when the Execution Mode Options dialog box displays StatusMsg.
Public Event OnGuess | Event fired when PC-DMIS guesses the feature being measured
Public Event OnObjectAboutToExecute | Event fired before command is executed This event gets launched immediately before the specified Command gets executed.
Public Event OnObjectAboutToExecute2 | Event fired before command is executed for dual arm systems This event gets launched immediately before the specified Command gets executed on a specified Arm of a multiple arm system.
Public Event OnObjectExecuted | Event fired when command finishes execution This event gets launched immediately after the specified Command gets executed.
Public Event OnObjectExecuted2 | Event fired when command finishes execution for dual arm systems This event gets launched immediately after the specified Command gets executed on a specified Arm of a multiple arm system.
Public Event OnReadCncVar | Event fired when program reads CNC Variable
Public Event OnStartExecution | Event fired when part program execution begins
Public Event OnToolOffset | Event fired when program updates CNC ToolOffset
Public Event OnWorkOffset | Event fired when program updates CNC WorkOffset This event gets called when PC-DMIS/NC executes WorkOffset command. PC-DMIS/NC is a specialized version of PC-DMIS that allows you to execute part programs using your CNC (Computer Numeric Control) machine. For more information on PC-DMIS/NC, see the PC-DMIS NC documentation.
Public Event OnWriteCncVar | Event fired when program writes CNC Variable

See Also

PartProgram Overview


Activate Method

Activate Method

Description

Makes part program the active part program

Syntax

Visual Basic
Public Sub Activate()

See Also

PartProgram Object


AsyncExecute Method

AsyncExecute Method

Description

Starts execution of the part program and returns immediately This function starts execution of the part program and then returns immediately, allowing for asynchronous execution.

Syntax

Visual Basic
Public Function AsyncExecute() As Boolean

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails. TRUE if the execution of the part program and the return of control was successful, FALSE otherwise.

See Also

PartProgram Object


AutoCreateGroupsForAudiMessPrograms Method

AutoCreateGroupsForAudiMessPrograms Method
bUseDimensionName

Description

Converts AudiMess programs into groups

Syntax

Visual Basic
Public Function AutoCreateGroupsForAudiMessPrograms( _
   ByVal bUseDimensionName As Long _
) As Boolean

Parameters

bUseDimensionName

See Also

PartProgram Object


CalcAdjustTransform Method

CalcAdjustTransform Method
Part1AlignID
Part2AlignID

Description

Calculates part adjustment transformation in machine coordinates

Syntax

Visual Basic
Public Function CalcAdjustTransform( _
   ByVal Part1AlignID As String, _
   ByVal Part2AlignID As String _
) As DmisMatrix

Parameters

Part1AlignID
Part2AlignID

See Also

PartProgram Object


ClearAllTADs Method

ClearAllTADs Method

Description

Clears the persistent User Assigned Properties data for all reports

Syntax

Visual Basic
Public Function ClearAllTADs() As Boolean

See Also

PartProgram Object


ClearExecutionBlock Method

ClearExecutionBlock Method

Description

Clears the start and end commands set by SetExecutionBlock This clears the start and end commands set by the SetExecutionBlock method.

Syntax

Visual Basic
Public Sub ClearExecutionBlock()

See Also

PartProgram Object | Command Object | SetExecutionBlock Method


ClearTADs Method

ClearTADs Method

Description

Clears the persistent User Assigned Properties data for the current report

Syntax

Visual Basic
Public Function ClearTADs() As Boolean

See Also

PartProgram Object


ClearVerifyFeaturesFlag Method

ClearVerifyFeaturesFlag Method

Description

Clear the VerifyFeatures Flag

Syntax

Visual Basic
Public Function ClearVerifyFeaturesFlag() As Boolean

See Also

PartProgram Object


Close Method

Close Method

Description

Closes and saves the part program - object becomes invalid

This subroutine saves, closes, and deactivates the part program.

Syntax

Visual Basic
Public Sub Close()

See Also

PartProgram Object


DmisOut Method

DmisOut Method
bExecOrder
FileName

Description

Outputs DMIS results to a file This function outputs DMIS results to a file.

Syntax

Visual Basic
Public Function DmisOut( _
   ByVal bExecOrder As Long, _
   ByVal FileName As String _
) As Boolean

Parameters

bExecOrder
FileName

Return Type

Boolean value. Boolean returns TRUE if the expression succeeds, FALSE otherwise.

See Also

PartProgram Object


DmisOut2 Method

DmisOut2 Method
bExecOrder
FileName
bOutputLastInstanceOnly

Description

Outputs DMIS results to a file; option for output last instance only

Syntax

Visual Basic
Public Function DmisOut2( _
   ByVal bExecOrder As Long, _
   ByVal FileName As String, _
   ByVal bOutputLastInstanceOnly As Long _
) As Boolean

Parameters

bExecOrder
FileName
bOutputLastInstanceOnly

See Also

PartProgram Object


EditRulesFile Method

EditRulesFile Method
FileName

Description

Edits basic script rules file for default parameter managment (Inspection Planner)

Syntax

Visual Basic
Public Sub EditRulesFile( _
   ByVal FileName As String _
)

Parameters

FileName

See Also

PartProgram Object


EXECUTE Method

EXECUTE Method

Description

Executes the part program This function executes the part program.

Syntax

Visual Basic
Public Function EXECUTE() As Boolean

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails. TRUE if the execution of the part program was successful, FALSE otherwise.

See Also

PartProgram Object


Export Method

Export Method
Name
Required String that denotes the file name to which to export.

Description

Exports part program to another format

This function exports CAD or part data from the part program to the indicated file. The export format is determined by the file name extension of Name.

Syntax

Visual Basic
Public Function Export( _
   ByVal Name As String _
) As Boolean

Parameters

Name
Required String that denotes the file name to which to export.

See Also

PartProgram Object


ExternalCommandEvent Method

ExternalCommandEvent Method
CommandId
EventId

Description

ExternalCommandEvent

Syntax

Visual Basic
Public Sub ExternalCommandEvent( _
   ByVal CommandId As Integer, _
   ByVal EventId As Integer _
)

Parameters

CommandId
EventId

See Also

PartProgram Object


GetVariableValue Method

GetVariableValue Method
VarName
String value representing a variable object.

Description

Returns a variable object of specified name, if it exists This method returns a variable object specified by the string in VarName.

Syntax

Visual Basic
Public Function GetVariableValue( _
   ByVal VarName As String _
) As Variable

Parameters

VarName
String value representing a variable object.

Return Type

Variable object.

Remarks

PC-DMIS variables only hold values during execution; at learn time PC-DMIS variables have a value of zero. The GetVariableValue and SetVariableValue methods only change a variable's value during the script's execution. If you want to permanently change a value of a variable inside PC-DMIS, you should use the PutText method instead.

Example

See Sample Automation Script 1

See Also

PartProgram Object | SetVariableValue Method | PutText Method | PCDLRN Project


Guess Method

Guess Method
featType
addFeat

Description

Tries to guess what command has just been measured

Syntax

Visual Basic
Public Function Guess( _
   ByVal featType As GUESSTYPE, _
   ByVal addFeat As Long _
) As Command

Parameters

featType
Value Description
GUESS_MEASURED_POINT
GUESS_MEASURED_LINE
GUESS_MEASURED_PLANE
GUESS_MEASURED_CIRCLE
GUESS_MEASURED_CONE
GUESS_MEASURED_CYLINDER
GUESS_MEASURED_SPHERE
GUESS_MEASURED_ROUND_SLOT
GUESS_MEASURED_SQUARE_SLOT
GUESS_MEASURED_GUESS
GUESS_MANUAL_SCAN
addFeat

See Also

PartProgram Object


IgnoreLearnModeHits Method

IgnoreLearnModeHits Method
bState

Description

IgnoreLearnModeHits

Syntax

Visual Basic
Public Function IgnoreLearnModeHits( _
   ByVal bState As Long _
) As Boolean

Parameters

bState

See Also

PartProgram Object


Import Method

Import Method
Name
Required String that denotes the file name from which to import.

Description

Imports from another format into the partprogram

This function imports CAD or part data from the indicated file to the part program. The file format is determined by the file name extension of Name.

Syntax

Visual Basic
Public Function Import( _
   ByVal Name As String _
) As Boolean

Parameters

Name
Required String that denotes the file name from which to import.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

PartProgram Object


ImportUGDCI Method

ImportUGDCI Method
Name

Description

ImportUGDCI

Syntax

Visual Basic
Public Function ImportUGDCI( _
   ByVal Name As String _
) As Boolean

Parameters

Name

See Also

PartProgram Object


IsProbeAnalog Method

IsProbeAnalog Method
ArmNumber

Description

Returns true if the current probe on the selected arm is analog

Returns TRUE if the current loaded probe in a part program is an analog probe; it returns FALSE otherwise. If you have multiple probe types defined for a part program, the return value will depend, of course, on the location of the insertion point in the part program.

Syntax

Visual Basic
Public Function IsProbeAnalog( _
   ByVal ArmNumber As Long _
) As Boolean

Parameters

ArmNumber

Return Type

Boolean value.

See Also

PartProgram Object


LoadLayout Method

LoadLayout Method
LayoutFileName
Required String that indicates the file the layout should be read from. This can be an absolute path, a relative path, or the name the user typed in when creating the layout in PC-DMIS.

Description

Loads a layout file The LoadLayout method loads a customized PC-DMIS user-interface layout as if it were selected from the Windows Layout toolbar inside PC-DMIS. Also, if a layout has been created and moved to a different directory, you can access it by specifying the absolute or relative file name. For information on using this toolbar, see the "Using Toolbars" section inside your PC-DMIS Help File.

Syntax

Visual Basic
Public Function LoadLayout( _
   ByVal LayoutFileName As String _
) As Boolean

Parameters

LayoutFileName
Required String that indicates the file the layout should be read from. This can be an absolute path, a relative path, or the name the user typed in when creating the layout in PC-DMIS.

Return Type

Dim Part As PCDLRN.PartProgram

' loads the first layout from the current user's setup information directory

Part.LoadLayout "layout1.dat"

' loads the layout in the specified file

Part.LoadLayout "c:\mylayout.dat"

' loads the layout named "Learn", if it exists

Part.LoadLayout "Learn"

See Also

PartProgram Object


MessageBox Method

MessageBox Method
Message
Required String that is the message of the message box
TITLE
Optional String that is the title of the message box. If omitted, the title will be the name and version of PC-DMIS.
Type
Optional Long used to indicate the button types to be used in the message box. Examples include, "OK", "Cancel", "Retry", "Yes", "No" etc. If omitted, the default is "OK".

Description

Prompts user with message box above the part program

This function uses the PC-DMIS message box function. It includes all functionality including cancelling of execution tied to the Cancel button.

Syntax

Visual Basic
Public Function MessageBox( _
   ByVal Message As String, _
   ByVal TITLE As String, _
   ByVal Type As ENUM_PCDMSG_TYPES _
) As ENUM_PCDMSG_RETVALS

Parameters

Message
Required String that is the message of the message box
TITLE
Optional String that is the title of the message box. If omitted, the title will be the name and version of PC-DMIS.
Type
Value Description
MSGTYP_OK
MSGTYP_OKCANCEL
MSGTYP_ABORTRETRYIGNORE
MSGTYP_YESNOCANCEL
MSGTYP_YESNO
MSGTYP_RETRY_CANCEL
MSGTYP_ICONHAND
MSGTYP_ICONQUESTION
MSGTYP_ICONEXCLAMATION
MSGTYP_ICONASTERISK
MSGTYP_DEFBUTTON2
MSGTYP_DEFBUTTON3
Optional Long used to indicate the button types to be used in the message box. Examples include, "OK", "Cancel", "Retry", "Yes", "No" etc. If omitted, the default is "OK".

Return Type

Integer value of the button chosen by the user. The value is from ENUM_PCDMSG_RETVALS enumeration.

See Also

PartProgram Object


OverrideExecuteSpeed Method

OverrideExecuteSpeed Method
NewSpeed

Description

Overrides the current execution speed

Syntax

Visual Basic
Public Function OverrideExecuteSpeed( _
   ByVal NewSpeed As Long _
) As Long

Parameters

NewSpeed

See Also

PartProgram Object


Quit Method

Quit Method

Description

Quits the part program without saving

This subroutine closes and deactivates the part program without saving.

Syntax

Visual Basic
Public Function Quit() As Boolean

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails. TRUE if the part was quit successfully, FALSE otherwise.

See Also

PartProgram Object


RefreshPart Method

RefreshPart Method

Description

Refreshes the Part (Edit/CAD Window Refreshes the display of the Part in the Edit window and in the CAD window.

Syntax

Visual Basic
Public Sub RefreshPart()

See Also

PartProgram Object


RemoveLastLearnHit Method

RemoveLastLearnHit Method

Description

Removes the last learn-mode hit

Syntax

Visual Basic
Public Function RemoveLastLearnHit() As Boolean

See Also

PartProgram Object


RunJournalFile Method

RunJournalFile Method
lpszJFileName
String value representing the journal file to use.

Description

Executes the part program with Journal File data

This executes the part program using point data collected from a journal file.

Syntax

Visual Basic
Public Function RunJournalFile( _
   ByVal lpszJFileName As String _
) As Boolean

Parameters

lpszJFileName
String value representing the journal file to use.

Return Type

Boolean value. This method returns TRUE if the part program successfully executes; FALSE otherwise.

Remarks

This is the same as a normal execution of a part program except that the point data comes from the specified journal file. Journal files are used with PC-DMIS/NC, a specialized version of PC-DMIS that executes part programs with CNC (Computer Numeric Control) machines. For more information see the PC-DMIS/NC Help File.

See Also

PartProgram Object


Save Method

Save Method

Description

Saves the part program

This subroutine saves the part program. If the part program has not been saved before, it opens a Save As Dialog box which requires that you name the file.

Syntax

Visual Basic
Public Function Save() As Boolean

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails. TRUE if the part was saved successfully, FALSE otherwise.

See Also

PartProgram Object


SaveAs Method

SaveAs Method
Name

Optional String value of the file name to which to save.

Description

Saves the part program with the provided name

Syntax

Visual Basic
Public Function SaveAs( _
   ByVal Name As String _
) As Boolean

Parameters

Name

Optional String value of the file name to which to save.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails. TRUE if the part was saved successfully, FALSE otherwise.

See Also

PartProgram Object


SetExecutionBlock Method

SetExecutionBlock Method
StartCommand
This is the first command to execute (as a Command object) in the command block.
EndCommand
This is the last command to execute (as a Command object) in the command block.

Description

Sets the start and end commands for block execution, calls to Execute or AsyncExecute will used until cleared This method defines a block of commands to execute. Calls are made to the Execute or AsyncExecute functions until the execution block is cleared with the ClearExecutionBlock method.

Syntax

Visual Basic
Public Function SetExecutionBlock( _
   ByVal StartCommand As Command, _
   ByVal EndCommand As Command _
) As Boolean

Parameters

StartCommand
This is the first command to execute (as a Command object) in the command block.
EndCommand
This is the last command to execute (as a Command object) in the command block.

Return Type

Boolean value. This method returns TRUE if the block of commands successfully executes; FALSE otherwise.

See Also

PartProgram Object


SetVariableValue Method

SetVariableValue Method
VarName
String value representing a variable.
Value
Variable value representing the new value the variable will take.

Description

Sets the variable value of specified name, if valid and can be set This method sets the value defined in Value for the variable specified by the string in VarName.

Syntax

Visual Basic
Public Function SetVariableValue( _
   ByVal VarName As String, _
   ByVal Value As Variable _
) As Boolean

Parameters

VarName
String value representing a variable.
Value
Variable value representing the new value the variable will take.

Return Type

Boolean value: TRUE if the variable was set, FALSE otherwise.

Remarks

PC-DMIS variables only hold values during execution; at learn time PC-DMIS variables have a value of zero. The GetVariableValue and SetVariableValue methods only change a variable's value during the script's execution. If you want to permanently change a value of a variable inside PC-DMIS, you should use the PutText method instead.

See Also

PartProgram Object | GetVariableValue Method | PutText Method


SetVerifyFeaturesFlag Method

SetVerifyFeaturesFlag Method

Description

Set the VerifyFeatures Flag

Syntax

Visual Basic
Public Function SetVerifyFeaturesFlag() As Boolean

See Also

PartProgram Object


ToggleMasterSlaveMode Method

ToggleMasterSlaveMode Method

Description

Enters/Exits Master-Slave Mode

Syntax

Visual Basic
Public Sub ToggleMasterSlaveMode()

See Also

PartProgram Object


WaitUntilExecuted Method

WaitUntilExecuted Method
Command
This is an expression that evaluates to a Command object. This is the command that is waited for.
timeout
This is the number of seconds (a Long value) to wait for the command to finish execution. If you have a non-positive value, the method waits indefinitely.
Arm

Description

Delays script execution until command is executed

This method waits until the specified Command object executes, or until Timeout seconds pass.

Syntax

Visual Basic
Public Function WaitUntilExecuted( _
   ByVal Command As Command, _
   ByVal timeout As Long, _
   ByVal Arm As Long _
) As Boolean

Parameters

Command
This is an expression that evaluates to a Command object. This is the command that is waited for.
timeout
This is the number of seconds (a Long value) to wait for the command to finish execution. If you have a non-positive value, the method waits indefinitely.
Arm

Return Type

Boolean value. This methods immediately returns FALSE if the part program is not executing. It returns TRUE if the specified Command executes before Timeout seconds pass. It returns FALSE if the Command does not execute before Timeout seconds pass. If Timeout is a non-positive value, and the Command never executes, this function never returns a value.

See Also

PartProgram Object


_Name Property

_Name Property

Property type

Read-write property

Syntax

Visual Basic
Public Property _Name() As String

See Also

PartProgram Object


ActiveMachine Property

ActiveMachine Property

Description

Read Only: Returns the machine object in use by part program - CMM or Offline Returns the Machine object associated with this part program.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActiveMachine() As Machine

Return Type

Read-only Machine object.

See Also

PartProgram Object


Application Property

Application Property

Description

Read Only: Returns object pointer of type Application Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

PartProgram Object


CadModel Property

CadModel Property

Description

Read Only: Returns Cad Model Object

Property type

Read-write property

Syntax

Visual Basic
Public Property CadModel() As CadModel

Return Type

Read-only CadModel object.

See Also

PartProgram Object


CadWindows Property

CadWindows Property

Description

Read Only: Returns object pointer of type CadWindows Returns the CadWindows object associated with this part program.

Property type

Read-write property

Syntax

Visual Basic
Public Property CadWindows() As CadWindows

Return Type

CadWindows object.

See Also

PartProgram Object


Commands Property

Commands Property

Description

Read Only: Returns object pointer of type Commands - access partprogram command list Returns the Commands collection object of this part program.

Property type

Read-write property

Syntax

Visual Basic
Public Property Commands() As Commands

Return Type

Read-only Command object.

See Also

PartProgram Object


ConnectedInDriveMode Property

ConnectedInDriveMode Property

Description

Read Only: Returns true when computer connected as driving computer

Property type

Read-write property

Syntax

Visual Basic
Public Property ConnectedInDriveMode() As Boolean

See Also

PartProgram Object


ConnectedInRelayMode Property

ConnectedInRelayMode Property

Description

Read Only: Returns true when computer connected as relay computer

Property type

Read-write property

Syntax

Visual Basic
Public Property ConnectedInRelayMode() As Boolean

See Also

PartProgram Object


ConnectedToMaster Property

ConnectedToMaster Property

Description

Read Only: Returns true if connected to master computer as slave

Returns TRUE if the part program is on the master computer but is running as the slave part program. Returns FALSE otherwise.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConnectedToMaster() As Boolean

Return Type

Read-only Boolean value.

See Also

PartProgram Object


ConnectedToSlave Property

ConnectedToSlave Property

Description

Read Only: Returns true if connected to slave computer as master Returns TRUE if the part program is on the slave computer but is running as the master part program. Returns FALSE otherwise.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConnectedToSlave() As Boolean

Return Type

Read-only Boolean.

See Also

PartProgram Object


CurrentArm Property

CurrentArm Property

Description

Read/Write: Returns/Sets the current arm environment This read/write property returns or sets the active arm when using PC-DMIS in multiple arm mode.

Property type

Read-write property

Syntax

Visual Basic
Public Property CurrentArm() As Long

Return Type

Read/write Long value.

Example

Sub Main

' This script queries the system for the

' active arm number, displays the active arm,

' and asks you if it should be changed.

' If you click Yes, then an input box

' appears allowing you to type the

' new active arm number. The script then

' updates the software to use the newly

' specified arm.

Dim App As Object

Set App = CreateObject ("PCDLRN.Application")

Dim Part As Object

Set Part = App.ActivePartProgram

Dim intNumArm As Integer

Dim intResponse As Integer

intNumArm = Part.CurrentArm

intResponse = MsgBox("The current active arm is " & intNumArm & ". Do you want to change the active arm?",4+32+0,"Change Active Arm?")

If intResponse = "6" Then

intNumArm = InputBox("Type the new active arm number (1 or 2): ")

Part.CurrentArm = intNumArm

MsgBox "Your active arm has been changed to " & intNumArm

Else

MsgBox "Nothing has changed. Closing script."

End If

End Sub

See Also

PartProgram Object


CurrentProbeName Property

CurrentProbeName Property

Description

Read: Returns the Name of current probe file

Property type

Read-write property

Syntax

Visual Basic
Public Property CurrentProbeName() As String

See Also

PartProgram Object


EditWindow Property

EditWindow Property

Description

Read Only: Returns object pointer of type EditWindow Returns the Editwindow object associated with this part program.

Property type

Read-write property

Syntax

Visual Basic
Public Property EditWindow() As EditWindow

Return Type

Read-only EditWindow object.

See Also

PartProgram Object


EditWindowTextAll Property

EditWindowTextAll Property

Description

Read Only: Returns the edit window text in the current mode

Returns a single string containing all the text of the entire Edit window as seen in the Edit window's command mode. Read only.

Property type

Read-write property

Syntax

Visual Basic
Public Property EditWindowTextAll() As String

Return Type

Read-only String value.

See Also

PartProgram Object


ExecutedCommands Property

ExecutedCommands Property

Description

Read Only: Returns the set of commands from the last execution The ExecutedCommands property returns the ExecutedCommands object. This object contains a collection class of those commands last executed for the current part program.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExecutedCommands() As ExecutedCommands

Return Type

ExecutedCommands object.

See Also

PartProgram Object


ExecuteDialogVisible Property

ExecuteDialogVisible Property

Description

Read/Write: Gives status / makes execute dialog visible or hidden

Property type

Read-write property

Syntax

Visual Basic
Public Property ExecuteDialogVisible() As Boolean

See Also

PartProgram Object


ExecutionWasCancelled Property

ExecutionWasCancelled Property

Description

Read Only: Returns true if the last execution run was cancelled

Returns TRUE if, during part program execution, the execution is cancelled. Otherwise it returns FALSE. The default value is FALSE.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExecutionWasCancelled() As Boolean

Return Type

Read-only Boolean value.

See Also

PartProgram Object


FullName Property

FullName Property

Description

Read Only: Full filename for part program - includes path

Returns the part program’s full file path and name.

Property type

Read-write property

Syntax

Visual Basic
Public Property FullName() As String

Return Type

Read-only String.

Remarks

If the file name of the part program is C:\PCDMISW\PARTS\1.PRG, the FullName returns "C:\PCDMISW\PARTS\1.PRG".

See Also

PartProgram Object


MasterSlaveDlg Property

MasterSlaveDlg Property

Description

Read Only: Returns the Master/Slave Calibration Dialog Object This returns a read-only pointer to the Master/Slave Calibration dialog box, opening the dialog box if necessary.

Property type

Read-write property

Syntax

Visual Basic
Public Property MasterSlaveDlg() As MasterSlaveDlg

Return Type

MasterSlaveDlg object.

See Also

PartProgram Object


Name Property

Name Property

Description

Read Only: Filename of part program - not including path

Returns the part program’s file name.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As String

Return Type

Read only String value.

Remarks

If the file name of the part program is C:\PCDMISW\PARTS\1.PRG, the Name returns "1.PRG".

See Also

PartProgram Object


NoActiveProbesObject Property

NoActiveProbesObject Property

Description

Read: Property indicating no Probes object are instantiated

Property type

Read-write property

Syntax

Visual Basic
Public Property NoActiveProbesObject() As Boolean

See Also

PartProgram Object


OldBasic Property

OldBasic Property

Description

Read Only: Old Basic object - gives access to old basic commands - v2.x

Returns this part program’s OldBasic object. The OldBasic object contains all of the methods from the old basic command set used in previous versions of PC-DMIS.

Property type

Read-write property

Syntax

Visual Basic
Public Property OldBasic() As OldBasic

Return Type

Read-only OldBasic object.

See Also

PartProgram Object


Parent Property

Parent Property

Description

Read Only: Returns object pointer to PartPrograms Object Returns the PartPrograms collection object to which this part program belongs.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As PartPrograms

Return Type

Read-only PartPrograms object.

See Also

PartProgram Object


PartName Property

PartName Property

Description

Read/Write: PartName property of part program Represents the part name of the part program.

Property type

Read-write property

Syntax

Visual Basic
Public Property PartName() As String

Return Type

Read/write String value.

Remarks

The part name is not the same as the file name. You can view and set the part name in the Properties of the file containing the part program, as well as at the top of the edit window within PC-DMIS.

See Also

PartProgram Object


PartProgramSettings Property

PartProgramSettings Property

Description

Read Only: Returns object pointer to PartProgramSettings Object

Property type

Read-write property

Syntax

Visual Basic
Public Property PartProgramSettings() As PartProgramSettings

See Also

PartProgram Object


Path Property

Path Property

Description

Read Only: Path where part program is located

Returns the part program’s file path.

Property type

Read-write property

Syntax

Visual Basic
Public Property Path() As String

Return Type

Read-only String value.

Remarks

If the file name of the part program is C:\PCDMISW\PARTS\1.PRG, the Path returns "C:\PCDMISW\PARTS\".

See Also

PartProgram Object


Probes Property

Probes Property

Description

Read Only: Returns object pointer to probe files The Probes property returns this part program’s Probes collection object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Probes() As Probes

Return Type

Read-only Probes object.

See Also

PartProgram Object


QuickStart Property

QuickStart Property

Description

Read Only: Returns object pointer to QuickStart Object

Property type

Read-write property

Syntax

Visual Basic
Public Property QuickStart() As QuickStart

See Also

PartProgram Object


ReportWindow Property

ReportWindow Property

Description

Read Only: Returns object pointer of type ReportWindow

Property type

Read-write property

Syntax

Visual Basic
Public Property ReportWindow() As ReportWindow

See Also

PartProgram Object


RevisionNumber Property

RevisionNumber Property

Description

Read/Write: Revision Number of part program Represents the part program’s revision number.

Property type

Read-write property

Syntax

Visual Basic
Public Property RevisionNumber() As String

Return Type

Read/write String value.

Remarks

You can view and set the revision number in the Properties of the file containing the part program, as well as at the top of the edit window within PC-DMIS.

See Also

PartProgram Object


SerialNumber Property

SerialNumber Property

Description

Read/Write: Serial Number of part program Represents the part program’s serial number.

Property type

Read-write property

Syntax

Visual Basic
Public Property SerialNumber() As String

Return Type

Read/write String.

Remarks

You can view and set the serial number in the Properties of the file containing the part program, as well as at the top of the edit window within PC-DMIS.

See Also

PartProgram Object


ShowAllIDs Property

ShowAllIDs Property

Description

Read/Write: Property indicating whether to show all IDs in the CAD Window

Property type

Read-write property

Syntax

Visual Basic
Public Property ShowAllIDs() As Boolean

See Also

PartProgram Object


Speed Property

Speed Property

Description

Read Only: Returns Execution speed (0 if not executing)

Property type

Read-write property

Syntax

Visual Basic
Public Property Speed() As Long

See Also

PartProgram Object


StatsCount Property

StatsCount Property

Description

Read/Write: Returns/Sets the current Stats Count; number of parts run Returns or sets the stats count for the current part program. Read/Write Long.

Property type

Read-write property

Syntax

Visual Basic
Public Property StatsCount() As Long

Return Type

Read/write Long value.

Remarks

You can view and set the stats count number in the Properties of the file containing the part program, as well as at the top of the edit window within PC-DMIS.

See Also

PartProgram Object


Tools Property

Tools Property

Description

Read Only: Returns object pointer to tools {ie. calibration tools} The Tools property returns this part program’s Tools collection object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tools() As Tools

Return Type

Read-only Tools object.

See Also

PartProgram Object


Units Property

Units Property

Description

Read Only: Returns the unit type Returns the measurement unit type used in the part program. Either inches or millimeters.

Property type

Read-write property

Syntax

Visual Basic
Public Property Units() As UNITTYPE

Return Type

Read-only UNITTYPE object.

See Also

PartProgram Object


Visible Property

Visible Property

Description

Read/Write: Gives status / Makes part program visible

Represents the part program’s visibility status.

Property type

Read-write property

Syntax

Visual Basic
Public Property Visible() As Boolean

Example

Read/write Boolean.

See Also

PartProgram Object


OnAddObject Event

OnAddObject Event
Command
Command object to determine the command for which this event should wait.

Description

Event fired when command is added to part program

This event gets launched when the specified Command gets added to the part program.

Syntax

Visual Basic
Public Event OnAddObject( _
   ByVal Command As Command _
)

Parameters

Command
Command object to determine the command for which this event should wait.

See Also

PartProgram Object


OnEndExecution Event

OnEndExecution Event
TerminationType
Long number that determines the termination type used by this event.

Description

Event fired when part program execution ends

This event gets launched when PC-DMIS finishes executing the part program. PC-DMIS determines it has finished execution based on the termination type.

Syntax

Visual Basic
Public Event OnEndExecution( _
   ByVal TerminationType As Long _
)

Parameters

TerminationType
Long number that determines the termination type used by this event.

See Also

PartProgram Object


OnExecuteDialogErrorMsg Event

OnExecuteDialogErrorMsg Event
ErrorMsg
String value representing the error message sent to the Machine Errors list in the Execution Mode Options dialog box.

Description

Event fired when error message sent to execute dialog

This event gets launched when the Execution Mode Options dialog box displays ErrorMsg.

Syntax

Visual Basic
Public Event OnExecuteDialogErrorMsg( _
   ByVal ErrorMsg As String _
)

Parameters

ErrorMsg
String value representing the error message sent to the Machine Errors list in the Execution Mode Options dialog box.

See Also

PartProgram Object


OnExecuteDialogStatusMsg Event

OnExecuteDialogStatusMsg Event
StatusMsg
String value representing the status message sent to the Machine Commands list in the Execution Mode Options dialog box.

Description

Event fired when status message sent to execute dialog

This event gets launched when the Execution Mode Options dialog box displays StatusMsg.

Syntax

Visual Basic
Public Event OnExecuteDialogStatusMsg( _
   ByVal StatusMsg As String _
)

Parameters

StatusMsg
String value representing the status message sent to the Machine Commands list in the Execution Mode Options dialog box.

See Also

PartProgram Object


OnGuess Event

OnGuess Event
Command
Arm

Description

Event fired when PC-DMIS guesses the feature being measured

Syntax

Visual Basic
Public Event OnGuess( _
   ByVal Command As Command, _
   ByVal Arm As Long _
)

Parameters

Command
Arm

See Also

PartProgram Object


OnObjectAboutToExecute Event

OnObjectAboutToExecute Event
Command
Command object that determines the command about to be executed.

Description

Event fired before command is executed

This event gets launched immediately before the specified Command gets executed.

Syntax

Visual Basic
Public Event OnObjectAboutToExecute( _
   ByVal Command As Command _
)

Parameters

Command
Command object that determines the command about to be executed.

See Also

PartProgram Object


OnObjectAboutToExecute2 Event

OnObjectAboutToExecute2 Event
Command
Command object that determines the command about to be executed.
Arm
Long value representing the arm on a multiple arm machine that is about to execute the command causing the event to launch.

Description

Event fired before command is executed for dual arm systems

This event gets launched immediately before the specified Command gets executed on a specified Arm of a multiple arm system.

Syntax

Visual Basic
Public Event OnObjectAboutToExecute2( _
   ByVal Command As Command, _
   ByVal Arm As Long _
)

Parameters

Command
Command object that determines the command about to be executed.
Arm
Long value representing the arm on a multiple arm machine that is about to execute the command causing the event to launch.

See Also

PartProgram Object


OnObjectExecuted Event

OnObjectExecuted Event
Command
Command object that determines the command that gets executed.

Description

Event fired when command finishes execution

This event gets launched immediately after the specified Command gets executed.

Syntax

Visual Basic
Public Event OnObjectExecuted( _
   ByVal Command As Command _
)

Parameters

Command
Command object that determines the command that gets executed.

See Also

PartProgram Object


OnObjectExecuted2 Event

OnObjectExecuted2 Event
Command
Command object that determines the command that gets executed.
Arm
Long value representing the arm on a multiple arm machine that executes the Command causing the event to launch.

Description

Event fired when command finishes execution for dual arm systems

This event gets launched immediately after the specified Command gets executed on a specified Arm of a multiple arm system.

Syntax

Visual Basic
Public Event OnObjectExecuted2( _
   ByVal Command As Command, _
   ByVal Arm As Long _
)

Parameters

Command
Command object that determines the command that gets executed.
Arm
Long value representing the arm on a multiple arm machine that executes the Command causing the event to launch.

See Also

PartProgram Object


OnReadCncVar Event

OnReadCncVar Event
index
pval

Description

Event fired when program reads CNC Variable

Syntax

Visual Basic
Public Event OnReadCncVar( _
   ByVal index As Integer, _
   ByRef pval As Double _
)

Parameters

index
pval

See Also

PartProgram Object


OnStartExecution Event

OnStartExecution Event

Description

Event fired when part program execution begins

Syntax

Visual Basic
Public Event OnStartExecution()

See Also

PartProgram Object


OnToolOffset Event

OnToolOffset Event
dd
dl
file
progname
toolNumber

Description

Event fired when program updates CNC ToolOffset

Syntax

Visual Basic
Public Event OnToolOffset( _
   ByVal dd As Double, _
   ByVal dl As Double, _
   ByVal file As String, _
   ByVal progname As String, _
   ByVal toolNumber As String _
)

Parameters

dd
dl
file
progname
toolNumber

See Also

PartProgram Object


OnWorkOffset Event

OnWorkOffset Event
dX
Double value that represents the change in translation in X from the base alignment to the finished alignment.
dY
Double value that represents the change in translation in Y from the base alignment to the finished alignment.
dZ
Double value that represents the change in translation in Z from the base alignment to the finished alignment.
rx
Double value that represents the change in rotation for X from the base alignment to the finished alignment.
ry
Double value that represents the change in rotation for Y from the base alignment to the finished alignment.
rz
Double value that represents the change in rotation for Z from the base alignment to the finished alignment.
file
String value representing the NC formatted file that gets created if the NC interface is unidirectional.
progname
String value representing the program name assigned to the generated program
gcode
String value representing the G code to send to the controller. This code can be G54 through G59.

Description

Event fired when program updates CNC WorkOffset

This event gets called when PC-DMIS/NC executes WorkOffset command. PC-DMIS/NC is a specialized version of PC-DMIS that allows you to execute part programs using your CNC (Computer Numeric Control) machine. For more information on PC-DMIS/NC, see the PC-DMIS NC documentation.

Syntax

Visual Basic
Public Event OnWorkOffset( _
   ByVal dX As Double, _
   ByVal dY As Double, _
   ByVal dZ As Double, _
   ByVal rx As Double, _
   ByVal ry As Double, _
   ByVal rz As Double, _
   ByVal file As String, _
   ByVal progname As String, _
   ByVal gcode As String _
)

Parameters

dX
Double value that represents the change in translation in X from the base alignment to the finished alignment.
dY
Double value that represents the change in translation in Y from the base alignment to the finished alignment.
dZ
Double value that represents the change in translation in Z from the base alignment to the finished alignment.
rx
Double value that represents the change in rotation for X from the base alignment to the finished alignment.
ry
Double value that represents the change in rotation for Y from the base alignment to the finished alignment.
rz
Double value that represents the change in rotation for Z from the base alignment to the finished alignment.
file
String value representing the NC formatted file that gets created if the NC interface is unidirectional.
progname
String value representing the program name assigned to the generated program
gcode
String value representing the G code to send to the controller. This code can be G54 through G59.

See Also

PartProgram Object


OnWriteCncVar Event

OnWriteCncVar Event
index
val

Description

Event fired when program writes CNC Variable

Syntax

Visual Basic
Public Event OnWriteCncVar( _
   ByVal index As Integer, _
   ByVal val As Double _
)

Parameters

index
val

See Also

PartProgram Object


PartPrograms Object

PartPrograms Object
See Also Members

Description

Object for the collection of open part programs

The PartPrograms object contains all the open part programs in PC-DMIS.

Object Model

Remarks

Use Add to create a fresh new part program and add it to the PartPrograms collection.

Use PartPrograms(index) where index is the part name or index number to access an individual part program.

See Also

PartPrograms Members


PartPrograms Object Members

PartPrograms ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method Add | Creates a new part program and adds it to the partprograms collection The Add function creates a new part program and activates it in PC-DMIS. If a part program named FileName exists, it is loaded and the Units parameter is ignored.
Public Method CloseAll | Closes all partprograms in the collection Closes and deactivates all active part programs in PC-DMIS.
Public Method Item | Returns partprogram object from partprograms collection by name or number Returns a specific PartProgram object from the collection in the PartPrograms object.
Public Method Open | Opens an existing part program and adds it to the partprograms collection The Open function activates the part program stored in the file FileName. If the file does not exist, nothing happens.
Public Method Remove | Closes the part program specified by name or number The Remove function saves, closes, and deactivates the indicated part program. That part program is no longer active in PC-DMIS.

Public Properties

Public Property Application | Read Only: Returns Application Object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.
Public Property Count | Read Only: Number of open part programs Returns the number of part programs active in PC-DMIS.
Public Property Parent | Read Only: Returns Application Object Returns the parent object, in this case the Application object.

See Also

PartPrograms Overview


_Item Method

_Item Method
NameOrNum

Syntax

Visual Basic
Public Function _Item( _
   ByVal NameOrNum As Variant _
) As PartProgram

Parameters

NameOrNum

See Also

PartPrograms Object


Add Method

Add Method
Name
Required String. The file name in which to store the new PartProgram.
Units
Required UNITTYPE enumeration.
Machine
Required String. The identifying string for your machine. If you're running in offline mode, use "Offline". If you're running in online mode use "CMM1".
ProbeFile
Required String. The identifying string for the probe (.prb) file to use in the part program.

Description

Creates a new part program and adds it to the partprograms collection The Add function creates a new part program and activates it in PC-DMIS. If a part program named FileName exists, it is loaded and the Units parameter is ignored.

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As String, _
   ByVal Units As UNITTYPE, _
   ByVal Machine As String, _
   ByVal ProbeFile As String _
) As PartProgram

Parameters

Name
Required String. The file name in which to store the new PartProgram.
Units
Value Description
INCH
MM
Required UNITTYPE enumeration.
Machine
Required String. The identifying string for your machine. If you're running in offline mode, use "Offline". If you're running in online mode use "CMM1".
ProbeFile
Required String. The identifying string for the probe (.prb) file to use in the part program.

See Also

PartPrograms Object


CloseAll Method

CloseAll Method

Description

Closes all partprograms in the collection Closes and deactivates all active part programs in PC-DMIS.

Syntax

Visual Basic
Public Sub CloseAll()

See Also

PartPrograms Object


Item Method

Item Method
NameOrNum
Required Variant that indicates which PartProgram object to return. It can be either a Long or a String. If it is a Long, it is the index number of the PartProgram object in the PartPrograms collection. If it is a String, it is the ID of the PartProgram object.

Description

Returns partprogram object from partprograms collection by name or number Returns a specific PartProgram object from the collection in the PartPrograms object.

Syntax

Visual Basic
Public Function Item( _
   ByVal NameOrNum As Variant _
) As PartProgram

Parameters

NameOrNum
Required Variant that indicates which PartProgram object to return. It can be either a Long or a String. If it is a Long, it is the index number of the PartProgram object in the PartPrograms collection. If it is a String, it is the ID of the PartProgram object.

Return Type

PartProgram object.

Remarks

Since the Item method is the default, the function name can be omitted if desired.

See Also

PartPrograms Object


Open Method

Open Method
FileName
Required String. The file name of the PartProgram to open.
MachineName
Required String. The identifying string for your machine. If you're running in offline mode, use "Offline". If you're running in online mode use "CMM1".

Description

Opens an existing part program and adds it to the partprograms collection The Open function activates the part program stored in the file FileName. If the file does not exist, nothing happens.

Syntax

Visual Basic
Public Function Open( _
   ByVal FileName As String, _
   ByVal MachineName As String _
) As PartProgram

Parameters

FileName
Required String. The file name of the PartProgram to open.
MachineName
Required String. The identifying string for your machine. If you're running in offline mode, use "Offline". If you're running in online mode use "CMM1".

See Also

PartPrograms Object


Remove Method

Remove Method
NameOrNum
Required Variant that indicates which PartProgram object to return. It can be either a Long or a String. If it is a Long, it is the index number of the PartProgram object in the PartPrograms collection. If it is a String, it is the ID of the PartProgram object.

Description

Closes the part program specified by name or number The Remove function saves, closes, and deactivates the indicated part program. That part program is no longer active in PC-DMIS.

Syntax

Visual Basic
Public Function Remove( _
   ByVal NameOrNum As Variant _
) As Boolean

Parameters

NameOrNum
Required Variant that indicates which PartProgram object to return. It can be either a Long or a String. If it is a Long, it is the index number of the PartProgram object in the PartPrograms collection. If it is a String, it is the ID of the PartProgram object.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails. If the function was able to close a part program, it returns TRUE, otherwise FALSE.

See Also

PartPrograms Object


Application Property

Application Property

Description

Read Only: Returns Application Object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

PartPrograms Object


Count Property

Count Property

Description

Read Only: Number of open part programs Returns the number of part programs active in PC-DMIS.

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

Return Type

Read-only Long value.

See Also

PartPrograms Object


Parent Property

Parent Property

Description

Read Only: Returns Application Object Returns the parent object, in this case the Application object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Application

Return Type

Application object. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.

See Also

PartPrograms Object


PartProgramSettings Object

PartProgramSettings Object
See Also Members

Description

The PartProgramSettings object allows you to get or set various part program settings.

See Also

PartProgramSettings Members


PartProgramSettings Object Members

PartProgramSettings ObjectMembers
See Also Overview

Public Properties

Public Property AutoAdjustPh9 | Read/Write: Returns the check box value or sets the Automatically Adjust Probe Head Wrist check box from the General tab of the SetUp Options dialog box.
Public Property AutoLabelPosition | Read/Write: Returns the check box value or sets the Automatic Label Positioning check box from the General tab of the SetUp Options dialog box.
Public Property PointOnlyMode | Read/Write: Point Only Mode
Public Property WarnLoadProbe | Read/Write: Returns the check box value or sets the Please Load Probe = %s warning check box found in the Warnings Display Options dialog box.

See Also

PartProgramSettings Overview


AutoAdjustPh9 Property

AutoAdjustPh9 Property

Description

Read/Write: Returns the check box value or sets the Automatically Adjust Probe Head Wrist check box from the General tab of the SetUp Options dialog box.

Property type

Read-write property

Syntax

Visual Basic
Public Property AutoAdjustPh9() As Long

Return Type

Read/write Long value.

Remarks

If you set this property a non-zero value or True, then PC-DMIS selects this check box.

If you set this property to a zero value or False, then PC-DMIS deselects this check box.

See Also

PartProgramSettings Object


AutoLabelPosition Property

AutoLabelPosition Property

Description

Read/Write: Returns the check box value or sets the Automatic Label Positioning check box from the General tab of the SetUp Options dialog box.

Property type

Read-write property

Syntax

Visual Basic
Public Property AutoLabelPosition() As Long

Return Type

Read/write Long value.

Remarks

If you set this property a non-zero value or True, then PC-DMIS selects this check box.

If you set this property to a zero value or False, then PC-DMIS deselects this check box.

See Also

PartProgramSettings Object


PointOnlyMode Property

PointOnlyMode Property

Description

Read/Write: Point Only Mode

Property type

Read-write property

Syntax

Visual Basic
Public Property PointOnlyMode() As Long

See Also

PartProgramSettings Object


WarnLoadProbe Property

WarnLoadProbe Property

Description

Read/Write: Returns the check box value or sets the Please Load Probe = %s warning check box found in the Warnings Display Options dialog box.

Property type

Read-write property

Syntax

Visual Basic
Public Property WarnLoadProbe() As Long

Return Type

Read/write Long value.

Remarks

If you set this property a non-zero value or True, then PC-DMIS selects this check box.

If you set this property to a zero value or False, then PC-DMIS deselects this check box.

See Also

PartProgramSettings Object


PictureData Object

PictureData Object
See Also Members

Description

Picture Data Object

See Also

PictureData Members


PictureData Object Members

PictureData ObjectMembers
See Also Overview

Public Methods

Public Method GetBitmapData | Get the bitmap data
Public Method GetBitmapDataSize | Get the buffer size of the bitmap data

See Also

PictureData Overview


GetBitmapData Method

GetBitmapData Method
buffer

Description

Get the bitmap data

Syntax

Visual Basic
Public Sub GetBitmapData( _
   ByRef buffer As Variant _
)

Parameters

buffer

See Also

PictureData Object


GetBitmapDataSize Method

GetBitmapDataSize Method

Description

Get the buffer size of the bitmap data

Syntax

Visual Basic
Public Function GetBitmapDataSize() As Long

See Also

PictureData Object


PointData Object

PointData Object
See Also Members

Description

Point Data Object

Remarks

The PointData object is similar to a type defined as follows:

Type PointData

X as Double
Y as Double
Z as Double

End Type

It is be used to pass points and vectors in automation functions that accept this type

Example

See Also

PointData Members


PointData Object Members

PointData ObjectMembers
See Also Overview

Public Methods

Public Method IJK | Sets the I, J, K values as a triplet
Public Method XYZ | Sets the X, Y, Z values as a triplet

Public Properties

Public Property I | Read/Write: Returns/Sets the I value (Same as X property) This property is exactly the same as the X property, but was included for semantic reasons when working with vectors.
Public Property J | Read/Write: Returns/Sets the J value (Same as Y property) This property is exactly the same as the Y property, but was included for semantic reasons when working with vectors.
Public Property K | Read/Write: Returns/Sets the K value (Same as Z property) This property is exactly the same as the Z property, but was included for semantic reasons when working with vectors.
Public Property X | Read/Write: Returns/Sets the X value (Same as I property) Represents the X member of this object.
Public Property Y | Read/Write: Returns/Sets the Y value (Same as J property) Represents the Y member of this object.
Public Property Z | Read/Write: Returns/Sets the Z value (Same as K property) Represents the Z member of this object.

See Also

PointData Overview


IJK Method

IJK Method
I
J
K

Description

Sets the I, J, K values as a triplet

Syntax

Visual Basic
Public Sub IJK( _
   ByVal I As Double, _
   ByVal J As Double, _
   ByVal K As Double _
)

Parameters

I
J
K

See Also

PointData Object


XYZ Method

XYZ Method
X
Y
Z

Description

Sets the X, Y, Z values as a triplet

Syntax

Visual Basic
Public Sub XYZ( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double _
)

Parameters

X
Y
Z

See Also

PointData Object


I Property

I Property

Description

Read/Write: Returns/Sets the I value (Same as X property)

This property is exactly the same as the X property, but was included for semantic reasons when working with vectors.

Property type

Read-write property

Syntax

Visual Basic
Public Property I() As Double

Return Type

Double value.

See Also

PointData Object


J Property

J Property

Description

Read/Write: Returns/Sets the J value (Same as Y property)

This property is exactly the same as the Y property, but was included for semantic reasons when working with vectors.

Property type

Read-write property

Syntax

Visual Basic
Public Property J() As Double

Return Type

Double value.

See Also

PointData Object


K Property

K Property

Description

Read/Write: Returns/Sets the K value (Same as Z property)

This property is exactly the same as the Z property, but was included for semantic reasons when working with vectors.

Property type

Read-write property

Syntax

Visual Basic
Public Property K() As Double

Return Type

Double value.

See Also

PointData Object


X Property

X Property

Description

Read/Write: Returns/Sets the X value (Same as I property)

Represents the X member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property X() As Double

Return Type

Read/write Double.

See Also

PointData Object


Y Property

Y Property

Description

Read/Write: Returns/Sets the Y value (Same as J property)

Represents the Y member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Y() As Double

Return Type

Read/write Double.

See Also

PointData Object


Z Property

Z Property

Description

Read/Write: Returns/Sets the Z value (Same as K property)

Represents the Z member of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Z() As Double

Return Type

Read/write Double.

See Also

PointData Object


probe Object

probe Object
See Also Members

Description

Probe Object The Probe object provides information about a given probe description file. It also allows you to manipulate the Probe dialog in PC-DMIS.

Object Model

See Also

probe Members


probe Object Members

probe ObjectMembers
See Also Overview

Public Methods

Public Method ClearAllTips | Clears all tips selected for qualification Clears all tips selected for qualification. Use the "Probe.SelectAllTips" function to select all tips. Use the "Tip.Selected" property of the tip object to select or deselect individual tips for probe qualification.
Public Method ComponentDescription | Returns the ComponentDescription referenced by the item parameter This function returns a string which is the nth component description of the component list box as determined by the Item parameter.
Public Method ConnectionDescription | Returns the ConnectionDescription referenced by the item parameter Returns the Item number string in the connection drop down list.
Public Method Dialog | Displays the probes dialog Opens the PC-DMIS Probe Utilities dialog box.
Public Method Qualify | Begins calibration process of probes in curren probe file Qualifies all of the probe's tips.
Public Method Qualify2 | Calibrates probes using settings passed in via Qualify Settings Object Calibrates the probe tips using settings passed in via the QualificationSettings object.
Public Method SelectAllTips | Selects all tips for qualification Selects all tips in tip list for qualification.

Public Properties

Public Property ActiveComponent | Read/Write: Returns/Sets the current component for the current connection Represents the highlighted probe component in PC-DMIS’s Probe dialog box.
Public Property ActiveConnection | Read/Write: Returns/Sets the current connection Represents the highlighted probe connection in PC-DMIS’s Probe dialog’s connection drop-down list.
Public Property Application | Read Only: Returns the Application Object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.
Public Property ComponentCount | Read Only: Returns the current number of available components for the current connection Returns the number of components in the component list box. There is always at least one, even when it appears that there are no entries. In that case, the one entry is invisible, but it can still be made active.
Public Property ConnectionCount | Read Only: Returns the current number of available connections Returns the number of connections in the connection drop-down list. The contents of this list depend on which component is active.
Public Property FullName | Read Only: Returns the path and filename of the probe file Returns the full name of the file containing this probe’s information.
Public Property Name | Read Only: Returns the filename only (no path) of the probe file Returns the name of the file containing this probe’s information.
Public Property Parent | Read Only: Returns the parent Probes collection object Returns the Probes collection object to which this object belongs.
Public Property Path | Read Only: Returns the path of the probe file Returns the path to the file containing this probe’s information.
Public Property QualificationSettings | Read Only: Returns a Qualify Settings Object that can be modified and passed into the qualify 2 method Returns the Qualify Settings object that can be modified and passed into the Qualify2 method. It supports these parameters: StartA - Returns the starting A angle of the probe EndA - Returns the ending A angle of the probe IncrementA - Returns the increment value for automatically generated A angles between the starting A angle of the probe and the ending A angle of the probe. StartB - Returns the starting B angle of the probe EndB - Returns the ending B angle of the probe IncrementB - Returns the increment value for automatically generated B angles between the starting B angle of the probe and the ending B angle of the probe.
Public Property Tips | Read Only: Returns the child Tips Collection Object Returns the Tips object associated with this Probe object.
Public Property UseWristMap | Read/Write: Returns/Sets if the wrist map is used Determines whether or not a wrist map is used.

See Also

probe Overview


ClearAllTips Method

ClearAllTips Method

Description

Clears all tips selected for qualification

Clears all tips selected for qualification. Use the "Probe.SelectAllTips" function to select all tips. Use the "Tip.Selected" property of the tip object to select or deselect individual tips for probe qualification.

Syntax

Visual Basic
Public Sub ClearAllTips()

See Also

probe Object


ComponentDescription Method

ComponentDescription Method
Item
Required Long. The zero-based index of the string from the list box to return. This must be between 0 and probe.ComponentCount-1.

Description

Returns the ComponentDescription referenced by the item parameter This function returns a string which is the nth component description of the component list box as determined by the Item parameter.

Syntax

Visual Basic
Public Function ComponentDescription( _
   ByVal Item As Long _
) As String

Parameters

Item
Required Long. The zero-based index of the string from the list box to return. This must be between 0 and probe.ComponentCount-1.

Return Type

String value.

See Also

probe Object


ConnectionDescription Method

ConnectionDescription Method
Item
Required Long. The zero-based index of the string from the drop down list to return. This must be between 0 and probe.ConnectionCount-1.

Description

Returns the ConnectionDescription referenced by the item parameter Returns the Item number string in the connection drop down list.

Syntax

Visual Basic
Public Function ConnectionDescription( _
   ByVal Item As Long _
) As String

Parameters

Item
Required Long. The zero-based index of the string from the drop down list to return. This must be between 0 and probe.ConnectionCount-1.

Return Type

String value.

See Also

probe Object


Dialog Method

Dialog Method

Description

Displays the probes dialog

Opens the PC-DMIS Probe Utilities dialog box.

Syntax

Visual Basic
Public Function Dialog() As Boolean

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

probe Object


Qualify Method

Qualify Method

Description

Begins calibration process of probes in curren probe file

Qualifies all of the probe's tips.

Syntax

Visual Basic
Public Sub Qualify()

See Also

probe Object


Qualify2 Method

Qualify2 Method
Settings
Values passed in from the QualificationSettings object.

Description

Calibrates probes using settings passed in via Qualify Settings Object Calibrates the probe tips using settings passed in via the QualificationSettings object.

Syntax

Visual Basic
Public Function Qualify2( _
   ByVal Settings As QualificationSettings _
) As Boolean

Parameters

Settings
Values passed in from the QualificationSettings object.

Return Type

QualificationSettings object.

See Also

probe Object


SelectAllTips Method

SelectAllTips Method

Description

Selects all tips for qualification

Selects all tips in tip list for qualification.

Syntax

Visual Basic
Public Sub SelectAllTips()

Remarks

Use the Probe.ClearAllTips function to clear all selected tips. Use the Tip.Selected property of the tip object to select or deselect individual tips for probe qualification.

See Also

probe Object | SelectAllTips Method | Selected Property


ActiveComponent Property

ActiveComponent Property

Description

Read/Write: Returns/Sets the current component for the current connection Represents the highlighted probe component in PC-DMIS’s Probe dialog box.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActiveComponent() As Long

Return Type

Read/write Long value.

Example

The following VB code illustrates how to create a probe containing a PH9, a TP2, and a 5 mm tip, from scratch in the active part program.

Option Explicit

Dim DmisApp As PCDLRN.Application

Dim DmisPart As PCDLRN.PartProgram

Dim DmisProbes As PCDLRN.Probes

Dim DmisProbe As PCDLRN.probe

Dim DmisTips As PCDLRN.Tips

Dim DmisTip As PCDLRN.Tip

Sub BuildProbe()

Dim iCnt As Long

Dim sProbe As String

sProbe = "VGS102"

Set DmisApp = CreateObject("PCDLRN.Application")

If DmisApp Is Nothing Then

MsgBox ("DmisApp is Nothing")

Exit Sub

End If

Set DmisPart = DmisApp.ActivePartProgram

If DmisPart Is Nothing Then

MsgBox ("DmisPart is Nothing")

Exit Sub

End If

Set DmisProbes = DmisPart.Probes

If DmisProbes Is Nothing Then

MsgBox ("DmisProbes is Nothing")

Exit Sub

End If

DmisPart.Probes.Add (sProbe)

Set DmisProbe = DmisProbes.Item(sProbe)

If DmisProbe Is Nothing Then

MsgBox ("DmisProbe is Nothing")

Exit Sub

End If

DmisProbe.ActiveComponent = 0

DmisProbe.ActiveConnection = 0

For iCnt = 1 To DmisProbe.ComponentCount

If (DmisProbe.ComponentDescription(iCnt) = "PROBEPH9") Then

DmisProbe.ActiveComponent = iCnt

Exit For

End If

Next iCnt

For iCnt = 1 To DmisProbe.ComponentCount

If (DmisProbe.ComponentDescription(iCnt) = "PROBETP2") Then

DmisProbe.ActiveComponent = iCnt

Exit For

End If

Next iCnt

For iCnt = 1 To DmisProbe.ComponentCount

If (DmisProbe.ComponentDescription(iCnt) = "TIP5BY50MM") Then

DmisProbe.ActiveComponent = iCnt

Exit For

End If

Next iCnt

End Sub

Private Sub Command1_Click()

BuildProbe

End Sub

See Also

probe Object


ActiveConnection Property

ActiveConnection Property

Description

Read/Write: Returns/Sets the current connection

Represents the highlighted probe connection in PC-DMIS’s Probe dialog’s connection drop-down list.

Property type

Read-write property

Syntax

Visual Basic
Public Property ActiveConnection() As Long

Return Type

Read/write Long value.

See Also

probe Object


Application Property

Application Property

Description

Read Only: Returns the Application Object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects. For example, the ActivePartProgram property returns a PartProgram object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Read/write Application object.

See Also

probe Object


ComponentCount Property

ComponentCount Property

Description

Read Only: Returns the current number of available components for the current connection

Returns the number of components in the component list box. There is always at least one, even when it appears that there are no entries. In that case, the one entry is invisible, but it can still be made active.

Property type

Read-write property

Syntax

Visual Basic
Public Property ComponentCount() As Long

Return Type

Long value.

See Also

probe Object


ConnectionCount Property

ConnectionCount Property

Description

Read Only: Returns the current number of available connections Returns the number of connections in the connection drop-down list. The contents of this list depend on which component is active.

Property type

Read-write property

Syntax

Visual Basic
Public Property ConnectionCount() As Long

Return Type

Long value.

See Also

probe Object


FullName Property

FullName Property

Description

Read Only: Returns the path and filename of the probe file

Returns the full name of the file containing this probe’s information.

Property type

Read-write property

Syntax

Visual Basic
Public Property FullName() As String

Return Type

Read-only String value.

Remarks

If the fully qualified path name is C:\PCDMISW\PROBE\SP600.PRB, FullName returns "C:\PCDMISW\PROBE\SP600.PRB".

See Also

probe Object


Name Property

Name Property

Description

Read Only: Returns the filename only (no path) of the probe file

Returns the name of the file containing this probe’s information.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As String

Return Type

Read-only String value.

Remarks

If the fully qualified path name is C:\PCDMISW\PROBE\SP600.PRB, FullName returns "SP600.PRB".

See Also

probe Object


Parent Property

Parent Property

Description

Read Only: Returns the parent Probes collection object Returns the Probes collection object to which this object belongs.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Probes

Return Type

Probes object.

See Also

probe Object


Path Property

Path Property

Description

Read Only: Returns the path of the probe file

Returns the path to the file containing this probe’s information.

Property type

Read-write property

Syntax

Visual Basic
Public Property Path() As String

Return Type

Read-only String value.

Remarks

If the fully qualified path name is C:\PCDMISW\PROBE\SP600.PRB, Path returns "C:\PCDMISW\PROBE\".

See Also

probe Object


QualificationSettings Property

QualificationSettings Property

Description

Read Only: Returns a Qualify Settings Object that can be modified and passed into the qualify 2 method

Returns the Qualify Settings object that can be modified and passed into the Qualify2 method. It supports these parameters:

StartA - Returns the starting A angle of the probe
EndA - Returns the ending A angle of the probe
IncrementA - Returns the increment value for automatically generated A angles between the starting A angle of the probe and the ending A angle of the probe.
StartB - Returns the starting B angle of the probe
EndB - Returns the ending B angle of the probe
IncrementB - Returns the increment value for automatically generated B angles between the starting B angle of the probe and the ending B angle of the probe.

Property type

Read-write property

Syntax

Visual Basic
Public Property QualificationSettings() As QualificationSettings

See Also

probe Object | Qualify2 Method


Tips Property

Tips Property

Description

Read Only: Returns the child Tips Collection Object Returns the Tips object associated with this Probe object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Tips() As Tips

See Also

probe Object


UseWristMap Property

UseWristMap Property

Description

Read/Write: Returns/Sets if the wrist map is used

Determines whether or not a wrist map is used.

Property type

Read-write property

Syntax

Visual Basic
Public Property UseWristMap() As Boolean

Return Type

Read/write Boolean value. Boolean returns TRUE if the probe uses a wrist map, FALSE otherwise.

See Also

probe Object


Probes Object

Probes Object
See Also Members

Description

Probes collection object The Probes object is the collection of all Probe objects currently available to a part program.

Object Model

Remarks

Use Probes (index) where index is the index number or name of the requested probe file.

See Also

Probes Members


Probes Object Members

Probes ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method Add | Creates a new probe file and makes it available to the probes collection The Add function sets the probe name to FileName. This allows the user to start creating a new probe.
Public Method CancelChanges | Cancels changes made to the probes collection and close the probes collection The CancelChanges function cancels changes made to a probes collection and then closes the probes collection.
Public Method Item | Returns a probe object based on the specified name of number Returns the specified Probe object from the collection of Probes.
Public Method SaveChanges | Save Changes made to the probes collection and closes the probes collection

Public Properties

Public Property Application | Read Only: Returns the Application Object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects.
Public Property Count | Read Only: Returns the number of probe files available to the application Represents the number of Machine objects currently active in PC-DMIS.
Public Property Parent | Read Only: Returns the parent PartProgram Object Returns the parent PartProgram of this object.
Public Property Visible | Read/Write: Returns/Sets the visible status of the dialog Gets or sets the current visible state of the Probes object. You can use this property to show or hide the current probe inside the Graphics Display window of PC-DMIS.

See Also

Probes Overview


_Item Method

_Item Method
NameOrNum

Syntax

Visual Basic
Public Function _Item( _
   ByVal NameOrNum As Variant _
) As probe

Parameters

NameOrNum

See Also

Probes Object


Add Method

Add Method
FileName
Required String that indicates the name of the new probe.

Description

Creates a new probe file and makes it available to the probes collection

The Add function sets the probe name to FileName. This allows the user to start creating a new probe.

Syntax

Visual Basic
Public Function Add( _
   ByVal FileName As String _
) As Boolean

Parameters

FileName
Required String that indicates the name of the new probe.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

Probes Object


CancelChanges Method

CancelChanges Method

Description

Cancels changes made to the probes collection and close the probes collection

The CancelChanges function cancels changes made to a probes collection and then closes the probes collection.

Syntax

Visual Basic
Public Sub CancelChanges()

See Also

Probes Object


Item Method

Item Method
NameOrNum
Required Variant that indicates which Probe object to return. It can be either a Long or a String. If it is a Long, it is the index number of the Probe object in the Probes collection. If it is a String, it is the name of the Probe object.

Description

Returns a probe object based on the specified name of number Returns the specified Probe object from the collection of Probes.

Syntax

Visual Basic
Public Function Item( _
   ByVal NameOrNum As Variant _
) As probe

Parameters

NameOrNum
Required Variant that indicates which Probe object to return. It can be either a Long or a String. If it is a Long, it is the index number of the Probe object in the Probes collection. If it is a String, it is the name of the Probe object.

Remarks

Since the Item method is the default, the function name can be omitted if desired.

See Also

Probes Object


SaveChanges Method

SaveChanges Method

Description

Save Changes made to the probes collection and closes the probes collection

Syntax

Visual Basic
Public Sub SaveChanges()

See Also

Probes Object


Application Property

Application Property

Description

Read Only: Returns the Application Object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

Probes Object


Count Property

Count Property

Description

Read Only: Returns the number of probe files available to the application

Represents the number of Machine objects currently active in PC-DMIS.

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

Return Type

Read-only Integer value.

See Also

Probes Object


Parent Property

Parent Property

Description

Read Only: Returns the parent PartProgram Object Returns the parent PartProgram of this object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As PartProgram

Return Type

Read-only PartProgram.

See Also

Probes Object


Visible Property

Visible Property

Description

Read/Write: Returns/Sets the visible status of the dialog

Gets or sets the current visible state of the Probes object. You can use this property to show or hide the current probe inside the Graphics Display window of PC-DMIS.

Property type

Read-write property

Syntax

Visual Basic
Public Property Visible() As Boolean

See Also

Probes Object


QualificationSettings Object

QualificationSettings Object
See Also Members

Description

The QualificationSettings object specifies how to calibrate your probe. The calibration process tells PC-DMIS the location and diameter of the probe tip. For more information on calibrating the probe, see the "Defining Probes" topic in the PC-DMIS help file.

Object Model

See Also

QualificationSettings Members


QualificationSettings Object Members

QualificationSettings ObjectMembers
See Also Overview

Public Methods

Public Method GetTool | This method returns a tool object.
Public Method SetTool | Required expression that evaluates to a QualificationSettings object.

Public Properties

Public Property CreateReplaceMap | Read/Write: Indicates if the map should be created or replaced This determines whether or not a map should be created or replaced. Read/Write.
Public Property EndA | A Angle End Value This determines the ending A angle to use during qualification.
Public Property EndAngle | End Angle on Tool This determines the End Angle to use on the qualification tool.
Public Property EndB | B Angle End Value This determines the ending B angle to use during qualification.
Public Property EndC | C Angle End Value
Public Property ExecuteMode | Type of Calibration Action to Be Taken This determines the type of calibration action to take.
Public Property IncrementA | A Angle Increment Value This determines the angle increment to use for the A angle during qualification.
Public Property IncrementB | B Angle Increment Value This determines the angle increment to for the B angle during qualification.
Public Property IncrementC | C Angle Increment Value
Public Property Mode | Calibration Mode: DCC or Manual This determines the Calibration Mode. Either DCC or Manual.
Public Property MoveSpeed | Probe Move Speed During Calibration This determines the speed the probe moves during calibration.
Public Property NumHits | Number of hits around calibration tool This determines the number of hits to take around the calibration tool.
Public Property NumLevels | Number of levels on Tool This determines the number of levels that to use in the calibration process. PC-DMIS divides the number of hits by the number of levels to determine how many hits will be taken on each level of the qualification tool.
Public Property PHSAPriority | For PHS Systems, whether A or B receives priority This indicates whether angle A or B for a PHS system receives priority during the calibration process. TRUE means Angle A gets priority. FALSE means Angle B gets priority.
Public Property PHSTol | For PHS Systems, the PHS Tolerance Value For PHS systems, this determines the PHS tolerance value.
Public Property PreHit | Prehit distance used during calibration This determines the Prehit distance to use during calibration.
Public Property ShankCheck | Boolean value indicating whether a shank check should occur This determines whether or not you'll calibrate the shank of the probe as well.
Public Property ShankHits | Number of hits on shank This determines the number of hits used to measure the shank.
Public Property ShankOffset | Shank Offset for calibration
Public Property StartA | A Angle Start Value This determines the starting A angle to use during qualification.
Public Property StartAngle | Start Angle on Tool This determines the Start Angle to use on the qualification tool.
Public Property StartB | B Angle Start Value This determines the starting B angle to use during qualification.
Public Property StartC | C Angle Start Value
Public Property ToolMoved | Indicates whether tool moved or not or if user should be asked This indicates whether a tool has moved or not or if the user should be asked.
Public Property ToolOnRotaryTable | Indicates whether or not tool is located on rotary table This indicates whether or not the tool is located on a rotary table.
Public Property ToolOverideI | I Vector Tool Overide Value This determines the I value for the Tool Override's IJK vector.
Public Property ToolOverideJ | J Vector Tool Overide Value This determines the J value for the Tool Override's IJK vector.
Public Property ToolOverideK | K Vector Tool Overide Value This determines the K value for the Tool Override's IJK vector.
Public Property Touchspeed | Probe Touch Speed used during calibration This determines the Touch Speed to use during calibration.
Public Property UserDefinedCalibrationMode | Indicates whether End Angle, Start Angle, and Numlevels is used or ignored This determines whether End Angle, Start Angle, and NumLevels are used in the calibration process, or if they're ignored.
Public Property UserDefinedCalibrationOrder | Indicates whether Tool Overide Settings are used or ignored This determines whether or not the calibration order is user defined.

See Also

QualificationSettings Overview


GetTool Method

GetTool Method

Description

This method returns a tool object.

Syntax

Visual Basic
Public Function GetTool() As tool

Return Type

This method returns a tool object.

Remarks

GetTool value.

See Also

QualificationSettings Object


SetTool Method

SetTool Method
tool
This method sets the current qualification tool to tool. This method returns a boolean value: TRUE if the function succeeds, FALSE otherwise.

Description

Required expression that evaluates to a QualificationSettings object.

Syntax

Visual Basic
Public Function SetTool( _
   ByVal tool As tool _
) As Boolean

Parameters

tool
This method sets the current qualification tool to tool. This method returns a boolean value: TRUE if the function succeeds, FALSE otherwise.

Return Type

Boolean value.

See Also

QualificationSettings Object


CreateReplaceMap Property

CreateReplaceMap Property

Description

Read/Write: Indicates if the map should be created or replaced

This determines whether or not a map should be created or replaced. Read/Write.

Property type

Read-write property

Syntax

Visual Basic
Public Property CreateReplaceMap() As ENUM_QUAL_CREATE_REPLACE

Return Type

ENUM_QUAL_CREATE_REPLACE enumeration.

See Also

QualificationSettings Object


EndA Property

EndA Property

Description

A Angle End Value

This determines the ending A angle to use during qualification.

Property type

Read-write property

Syntax

Visual Basic
Public Property EndA() As Double

Return Type

Double value.

See Also

QualificationSettings Object


EndAngle Property

EndAngle Property

Description

End Angle on Tool

This determines the End Angle to use on the qualification tool.

Property type

Read-write property

Syntax

Visual Basic
Public Property EndAngle() As Double

Return Type

Double value.

See Also

QualificationSettings Object


EndB Property

EndB Property

Description

B Angle End Value This determines the ending B angle to use during qualification.

Property type

Read-write property

Syntax

Visual Basic
Public Property EndB() As Double

Return Type

Double value.

See Also

QualificationSettings Object


EndC Property

EndC Property

Description

C Angle End Value

Property type

Read-write property

Syntax

Visual Basic
Public Property EndC() As Double

See Also

QualificationSettings Object


ExecuteMode Property

ExecuteMode Property

Description

Type of Calibration Action to Be Taken This determines the type of calibration action to take.

Property type

Read-write property

Syntax

Visual Basic
Public Property ExecuteMode() As ENUM_CALIBRATION_EXECUTE_MODE

Return Type

ENUM_CALIBRATION_EXECUTE_MODE enumeration.

See Also

QualificationSettings Object


IncrementA Property

IncrementA Property

Description

A Angle Increment Value

This determines the angle increment to use for the A angle during qualification.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncrementA() As Double

Return Type

Double value.

See Also

QualificationSettings Object


IncrementB Property

IncrementB Property

Description

B Angle Increment Value

This determines the angle increment to for the B angle during qualification.

Property type

Read-write property

Syntax

Visual Basic
Public Property IncrementB() As Double

Return Type

Double value.

See Also

QualificationSettings Object


IncrementC Property

IncrementC Property

Description

C Angle Increment Value

Property type

Read-write property

Syntax

Visual Basic
Public Property IncrementC() As Double

See Also

QualificationSettings Object


Mode Property

Mode Property

Description

Calibration Mode: DCC or Manual

This determines the Calibration Mode. Either DCC or Manual.

Property type

Read-write property

Syntax

Visual Basic
Public Property Mode() As QUALIFICATION_SETTINGS_MODE

Return Type

Remarks

QUALIFICATION_SETTINGS_MODE object.

See Also

QualificationSettings Object


MoveSpeed Property

MoveSpeed Property

Description

Probe Move Speed During Calibration This determines the speed the probe moves during calibration.

Property type

Read-write property

Syntax

Visual Basic
Public Property MoveSpeed() As Double

Return Type

Double value.

See Also

QualificationSettings Object


NumHits Property

NumHits Property

Description

Number of hits around calibration tool

This determines the number of hits to take around the calibration tool.

Property type

Read-write property

Syntax

Visual Basic
Public Property NumHits() As Long

Return Type

Long value.

See Also

QualificationSettings Object


NumLevels Property

NumLevels Property

Description

Number of levels on Tool

This determines the number of levels that to use in the calibration process. PC-DMIS divides the number of hits by the number of levels to determine how many hits will be taken on each level of the qualification tool.

Property type

Read-write property

Syntax

Visual Basic
Public Property NumLevels() As Long

Return Type

Long value.

See Also

QualificationSettings Object


PHSAPriority Property

PHSAPriority Property

Description

For PHS Systems, whether A or B receives priority

This indicates whether angle A or B for a PHS system receives priority during the calibration process. TRUE means Angle A gets priority. FALSE means Angle B gets priority.

Property type

Read-write property

Syntax

Visual Basic
Public Property PHSAPriority() As Boolean

Return Type

Boolean value.

See Also

QualificationSettings Object


PHSTol Property

PHSTol Property

Description

For PHS Systems, the PHS Tolerance Value

For PHS systems, this determines the PHS tolerance value.

Property type

Read-write property

Syntax

Visual Basic
Public Property PHSTol() As Double

Return Type

Double value.

See Also

QualificationSettings Object


PreHit Property

PreHit Property

Description

Prehit distance used during calibration

This determines the Prehit distance to use during calibration.

Property type

Read-write property

Syntax

Visual Basic
Public Property PreHit() As Double

Return Type

Type Double value.

See Also

QualificationSettings Object


ShankCheck Property

ShankCheck Property

Description

Boolean value indicating whether a shank check should occur

This determines whether or not you'll calibrate the shank of the probe as well.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShankCheck() As Boolean

Return Type

Boolean value.

See Also

QualificationSettings Object


ShankHits Property

ShankHits Property

Description

Number of hits on shank

This determines the number of hits used to measure the shank.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShankHits() As Long

Return Type

Long value.

See Also

QualificationSettings Object


ShankOffset Property

ShankOffset Property

Description

Shank Offset for calibration

Property type

Read-write property

Syntax

Visual Basic
Public Property ShankOffset() As Double

See Also

QualificationSettings Object


StartA Property

StartA Property

Description

A Angle Start Value

This determines the starting A angle to use during qualification.

Property type

Read-write property

Syntax

Visual Basic
Public Property StartA() As Double

Return Type

Double value.

See Also

QualificationSettings Object


StartAngle Property

StartAngle Property

Description

Start Angle on Tool

This determines the Start Angle to use on the qualification tool.

Property type

Read-write property

Syntax

Visual Basic
Public Property StartAngle() As Double

Return Type

Double value.

See Also

QualificationSettings Object


StartB Property

StartB Property

Description

B Angle Start Value This determines the starting B angle to use during qualification.

Property type

Read-write property

Syntax

Visual Basic
Public Property StartB() As Double

Return Type

Double value.

See Also

QualificationSettings Object


StartC Property

StartC Property

Description

C Angle Start Value

Property type

Read-write property

Syntax

Visual Basic
Public Property StartC() As Double

See Also

QualificationSettings Object


ToolMoved Property

ToolMoved Property

Description

Indicates whether tool moved or not or if user should be asked

This indicates whether a tool has moved or not or if the user should be asked.

Property type

Read-write property

Syntax

Visual Basic
Public Property ToolMoved() As ENUM_TOOL_MOVED

Return Type

ENUM_TOOL_MOVED enumeration.

See Also

QualificationSettings Object


ToolOnRotaryTable Property

ToolOnRotaryTable Property

Description

Indicates whether or not tool is located on rotary table

This indicates whether or not the tool is located on a rotary table.

Property type

Read-write property

Syntax

Visual Basic
Public Property ToolOnRotaryTable() As Boolean

Return Type

Boolean value.

See Also

QualificationSettings Object


ToolOverideI Property

ToolOverideI Property

Description

I Vector Tool Overide Value This determines the I value for the Tool Override's IJK vector.

Property type

Read-write property

Syntax

Visual Basic
Public Property ToolOverideI() As Double

Return Type

Double value.

See Also

QualificationSettings Object


ToolOverideJ Property

ToolOverideJ Property

Description

J Vector Tool Overide Value This determines the J value for the Tool Override's IJK vector.

Property type

Read-write property

Syntax

Visual Basic
Public Property ToolOverideJ() As Double

Return Type

Double value.

See Also

QualificationSettings Object


ToolOverideK Property

ToolOverideK Property

Description

K Vector Tool Overide Value This determines the K value for the Tool Override's IJK vector.

Property type

Read-write property

Syntax

Visual Basic
Public Property ToolOverideK() As Double

Return Type

Double value.

See Also

QualificationSettings Object


Touchspeed Property

Touchspeed Property

Description

Probe Touch Speed used during calibration This determines the Touch Speed to use during calibration.

Property type

Read-write property

Syntax

Visual Basic
Public Property Touchspeed() As Double

Return Type

Double value.

See Also

QualificationSettings Object


UserDefinedCalibrationMode Property

UserDefinedCalibrationMode Property

Description

Indicates whether End Angle, Start Angle, and Numlevels is used or ignored

This determines whether End Angle, Start Angle, and NumLevels are used in the calibration process, or if they're ignored.

Property type

Read-write property

Syntax

Visual Basic
Public Property UserDefinedCalibrationMode() As Boolean

Return Type

Boolean value.

See Also

QualificationSettings Object


UserDefinedCalibrationOrder Property

UserDefinedCalibrationOrder Property

Description

Indicates whether Tool Overide Settings are used or ignored

This determines whether or not the calibration order is user defined.

Property type

Read-write property

Syntax

Visual Basic
Public Property UserDefinedCalibrationOrder() As Boolean

Return Type

Boolean value.

See Also

QualificationSettings Object


QuickStart Object

QuickStart Object
See Also Members

Object Model

See Also

QuickStart Members


QuickStart Object Members

QuickStart ObjectMembers
See Also Overview

Public Methods

Public Method BeginTask | Starts a new Quick Start task, returning that task if successful
Public Method RemoveHit | Erases the last hit taken

Public Properties

Public Property CurrentTask Read Only: Returns the current Task

See Also

QuickStart Overview


BeginTask Method

BeginTask Method
TaskNum

Description

Starts a new Quick Start task, returning that task if successful

Syntax

Visual Basic
Public Function BeginTask( _
   ByVal TaskNum As Long _
) As QuickStartTask

Parameters

TaskNum

See Also

QuickStart Object


RemoveHit Method

RemoveHit Method

Description

Erases the last hit taken

Syntax

Visual Basic
Public Function RemoveHit() As Boolean

See Also

QuickStart Object


CurrentTask Property

CurrentTask Property

Description

Read Only: Returns the current Task

Property type

Read-write property

Syntax

Visual Basic
Public Property CurrentTask() As QuickStartTask

See Also

QuickStart Object


QuickStartAddedCommands Object

QuickStartAddedCommands Object
See Also Members

Object Model

See Also

QuickStartAddedCommands Members


QuickStartAddedCommands Object Members

QuickStartAddedCommands ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method Item | Returns command object from added commands collection by number

Public Properties

Public Property Count Read Only: Number of steps in the collection

See Also

QuickStartAddedCommands Overview


_Item Method

_Item Method
Num

Syntax

Visual Basic
Public Function _Item( _
   ByVal Num As Long _
) As Command

Parameters

Num

See Also

QuickStartAddedCommands Object


Item Method

Item Method
Num

Description

Returns command object from added commands collection by number

Syntax

Visual Basic
Public Function Item( _
   ByVal Num As Long _
) As Command

Parameters

Num

See Also

QuickStartAddedCommands Object


Count Property

Count Property

Description

Read Only: Number of steps in the collection

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

See Also

QuickStartAddedCommands Object


QuickStartStep Object

QuickStartStep Object
See Also Members

See Also

QuickStartStep Members


QuickStartStep Object Members

QuickStartStep ObjectMembers
See Also Overview

Public Methods

Public Method GetControlState | Get a check box or radio button state by index
Public Method GetControlText | Get a check box text value by index
Public Method GetEditText | Get an edit box text value by index
Public Method GetPrompt | Get a prompt by index
Public Method GetSelectionPrompt | Get the combo box text
Public Method SetControlState | Set a check box or radio button state by index
Public Method SetEditText | Set an edit box text value by index

Public Properties

Public Property CanBeCompleted | Read Only: The Step can be completed
Public Property ExpectsHits | Read Only: The step expects hits
Public Property ExpectsUserInput | Read Only: The step expects user input
Public Property NumHits | Read Only: The minimum number of hits required
Public Property StepHint | Read Only: The prompt to be displayed to the user

See Also

QuickStartStep Overview


GetControlState Method

GetControlState Method
Num

Description

Get a check box or radio button state by index

Syntax

Visual Basic
Public Function GetControlState( _
   ByVal Num As Long _
) As Boolean

Parameters

Num

See Also

QuickStartStep Object


GetControlText Method

GetControlText Method
Num

Description

Get a check box text value by index

Syntax

Visual Basic
Public Function GetControlText( _
   ByVal Num As Long _
) As String

Parameters

Num

See Also

QuickStartStep Object


GetEditText Method

GetEditText Method
Num

Description

Get an edit box text value by index

Syntax

Visual Basic
Public Function GetEditText( _
   ByVal Num As Long _
) As String

Parameters

Num

See Also

QuickStartStep Object


GetPrompt Method

GetPrompt Method
Num

Description

Get a prompt by index

Syntax

Visual Basic
Public Function GetPrompt( _
   ByVal Num As Long _
) As String

Parameters

Num

See Also

QuickStartStep Object


GetSelectionPrompt Method

GetSelectionPrompt Method

Description

Get the combo box text

Syntax

Visual Basic
Public Function GetSelectionPrompt() As String

See Also

QuickStartStep Object


SetControlState Method

SetControlState Method
Num
Value

Description

Set a check box or radio button state by index

Syntax

Visual Basic
Public Sub SetControlState( _
   ByVal Num As Long, _
   ByVal Value As Boolean _
)

Parameters

Num
Value

See Also

QuickStartStep Object


SetEditText Method

SetEditText Method
Num
Value

Description

Set an edit box text value by index

Syntax

Visual Basic
Public Sub SetEditText( _
   ByVal Num As Long, _
   ByVal Value As String _
)

Parameters

Num
Value

See Also

QuickStartStep Object


CanBeCompleted Property

CanBeCompleted Property

Description

Read Only: The Step can be completed

Property type

Read-write property

Syntax

Visual Basic
Public Property CanBeCompleted() As Boolean

See Also

QuickStartStep Object


ExpectsHits Property

ExpectsHits Property

Description

Read Only: The step expects hits

Property type

Read-write property

Syntax

Visual Basic
Public Property ExpectsHits() As Boolean

See Also

QuickStartStep Object


ExpectsUserInput Property

ExpectsUserInput Property

Description

Read Only: The step expects user input

Property type

Read-write property

Syntax

Visual Basic
Public Property ExpectsUserInput() As Boolean

See Also

QuickStartStep Object


NumHits Property

NumHits Property

Description

Read Only: The minimum number of hits required

Property type

Read-write property

Syntax

Visual Basic
Public Property NumHits() As Long

See Also

QuickStartStep Object


StepHint Property

StepHint Property

Description

Read Only: The prompt to be displayed to the user

Property type

Read-write property

Syntax

Visual Basic
Public Property StepHint() As String

See Also

QuickStartStep Object


QuickStartSteps Object

QuickStartSteps Object
See Also Members

Object Model

See Also

QuickStartSteps Members


QuickStartSteps Object Members

QuickStartSteps ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method Item | Returns quick start step object from steps collection by number

Public Properties

Public Property Count Read Only: Number of steps in the collection

See Also

QuickStartSteps Overview


_Item Method

_Item Method
Num

Syntax

Visual Basic
Public Function _Item( _
   ByVal Num As Long _
) As QuickStartStep

Parameters

Num

See Also

QuickStartSteps Object


Item Method

Item Method
Num

Description

Returns quick start step object from steps collection by number

Syntax

Visual Basic
Public Function Item( _
   ByVal Num As Long _
) As QuickStartStep

Parameters

Num

See Also

QuickStartSteps Object


Count Property

Count Property

Description

Read Only: Number of steps in the collection

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

See Also

QuickStartSteps Object


QuickStartTask Object

QuickStartTask Object
See Also Members

Object Model

See Also

QuickStartTask Members


QuickStartTask Object Members

QuickStartTask ObjectMembers
See Also Overview

Public Methods

Public Method Finish | Finishes the task
Public Method NextStep | Advances to the next step in the task
Public Method PrevStep | Goes back to the previous step in the task

Public Properties

Public Property NumSteps | Read Only: Returns the number of steps in this task
Public Property Steps | Read Only: Returns a collection containing the steps in this task

See Also

QuickStartTask Overview


Finish Method

Finish Method

Description

Finishes the task

Syntax

Visual Basic
Public Function Finish() As QuickStartAddedCommands

See Also

QuickStartTask Object


NextStep Method

NextStep Method

Description

Advances to the next step in the task

Syntax

Visual Basic
Public Function NextStep() As QuickStartStep

See Also

QuickStartTask Object


PrevStep Method

PrevStep Method

Description

Goes back to the previous step in the task

Syntax

Visual Basic
Public Function PrevStep() As QuickStartStep

See Also

QuickStartTask Object


NumSteps Property

NumSteps Property

Description

Read Only: Returns the number of steps in this task

Property type

Read-write property

Syntax

Visual Basic
Public Property NumSteps() As Long

See Also

QuickStartTask Object


Steps Property

Steps Property

Description

Read Only: Returns a collection containing the steps in this task

Property type

Read-write property

Syntax

Visual Basic
Public Property Steps() As QuickStartSteps

See Also

QuickStartTask Object


RegistrySetting Object

RegistrySetting Object
See Also Members

See Also

RegistrySetting Members


RegistrySetting Object Members

RegistrySetting ObjectMembers
See Also Overview

Public Methods

Public Method DeleteKey | Deletes the key from use in the application
Public Method IsWriteable | Read Only: Setting can be modified

Public Properties

Public Property AccessLevel | Read Only: Administrator or User
Public Property Group | Read Only: Machine or User
Public Property KeyName | Read Only: Section Name
Public Property Type | Read Only: Type
Public Property Used | Read Only: Used by the application
Public Property Value | Read/Write: Entry Value
Public Property ValueName | Read Only: Entry Name

See Also

RegistrySetting Overview


DeleteKey Method

DeleteKey Method

Description

Deletes the key from use in the application

Syntax

Visual Basic
Public Sub DeleteKey()

See Also

RegistrySetting Object


IsWriteable Method

IsWriteable Method

Description

Read Only: Setting can be modified

Syntax

Visual Basic
Public Function IsWriteable() As Boolean

See Also

RegistrySetting Object


AccessLevel Property

AccessLevel Property

Description

Read Only: Administrator or User

Property type

Read-write property

Syntax

Visual Basic
Public Property AccessLevel() As RS_ACCESS

See Also

RegistrySetting Object


Group Property

Group Property

Description

Read Only: Machine or User

Property type

Read-write property

Syntax

Visual Basic
Public Property Group() As RS_GROUP

See Also

RegistrySetting Object


KeyName Property

KeyName Property

Description

Read Only: Section Name

Property type

Read-write property

Syntax

Visual Basic
Public Property KeyName() As String

See Also

RegistrySetting Object


Type Property

Type Property

Description

Read Only: Type

Property type

Read-write property

Syntax

Visual Basic
Public Property Type() As Long

See Also

RegistrySetting Object


Used Property

Used Property

Description

Read Only: Used by the application

Property type

Read-write property

Syntax

Visual Basic
Public Property Used() As Boolean

See Also

RegistrySetting Object


Value Property

Value Property

Description

Read/Write: Entry Value

Property type

Read-write property

Syntax

Visual Basic
Public Property Value() As String

See Also

RegistrySetting Object


ValueName Property

ValueName Property

Description

Read Only: Entry Name

Property type

Read-write property

Syntax

Visual Basic
Public Property ValueName() As String

See Also

RegistrySetting Object


RegistrySettings Object

RegistrySettings Object
See Also Members

Object Model

See Also

RegistrySettings Members


RegistrySettings Object Members

RegistrySettings ObjectMembers
See Also Overview

Public Methods

Public Method First | Returns the first registry setting
Public Method Item | Returns the registry settings specified by composite name or number from the list of settings
Public Method Next | Returns the the next registry setting
Public Method RemoveAll | Removes all of the entries from the registry

Public Properties

Public Property Application | Read Only: Returns the Application Object
Public Property Count | Read Only: Returns the number of registry settings for the application
Public Property Parent | Read Only: Returns the parent Application Object

See Also

RegistrySettings Overview


First Method

First Method

Description

Returns the first registry setting

Syntax

Visual Basic
Public Function First() As RegistrySetting

See Also

RegistrySettings Object


Item Method

Item Method
Identifier

Description

Returns the registry settings specified by composite name or number from the list of settings

Syntax

Visual Basic
Public Function Item( _
   ByVal Identifier As Variant _
) As RegistrySetting

Parameters

Identifier

See Also

RegistrySettings Object


Next Method

Next Method
Identifier

Description

Returns the the next registry setting

Syntax

Visual Basic
Public Function Next( _
   ByVal Identifier As RegistrySetting _
) As RegistrySetting

Parameters

Identifier

See Also

RegistrySettings Object


RemoveAll Method

RemoveAll Method

Description

Removes all of the entries from the registry

Syntax

Visual Basic
Public Sub RemoveAll()

See Also

RegistrySettings Object


Application Property

Application Property

Description

Read Only: Returns the Application Object

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

See Also

RegistrySettings Object


Count Property

Count Property

Description

Read Only: Returns the number of registry settings for the application

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

See Also

RegistrySettings Object


Parent Property

Parent Property

Description

Read Only: Returns the parent Application Object

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Application

See Also

RegistrySettings Object


ReportControls Object

ReportControls Object
See Also Members

Description

The ReportControls object gives you access to a variety of controls such as buttons, text boxes, and other items that you can add to, remove, and otherwise manipulate on a particular section of a report template.

Object Model

Remarks

ID_HOB_PCD_GRID_CTRL_OB (GridControlObject) Members

Inside PC-DMIS you use the Properties dialog box to set most properties of the different Reporting objects. However, for the GridControlObject, you use an additional Grid Properties dialog box to set format the grid and its cells with text, font styles, line styles, colors and so forth. You can also set these items programmatically by using these properties and methods.

Note on Colors: Colors are defined by a COLORREF value. When specifying a RGB color, the COLORREF value has this hexadecimal form as a Long value:

0x00BBGGRR

where BB=blue GG=green RR=red

The maximum value for a single byte in the hexadecimal format is 0xFF (or 255 in decimal format).

Properties:

  • NumColumns - This property of type Long defines the number of columns used in the GridControlObject.

  • NumRows - This property of type Long defines the number of rows used in the GridControlObject.

Methods:

  • GetCellData - This returns the current numerical (Long) value in a specified cell. It takes two Long value parameters that specify the row and the column for the cell.
    Syntax:     Function GetCellData(ByVal Row as Long, ByVal Col as Long) As Long

  • GetCellLeftLineColor - This retrieves the color value for a specified cell's left line. This function returns True if the color value is successfully returned or False otherwise. The COLORREF value is returned in the variable passed as the third parameter. This function takes three parameters. The first is the cell row, the second is the cell column, and the third is the color.
    Syntax:     Function GetCellLeftLineColor(ByVal Row As Long, ByVal Col As Long, ByVal Color As Long) As Boolean

  • GetCellLineStyle - This retrieves the line style for a specified cell. This function returns True if the line style is successfully returned or False otherwise. It takes four parameters. The first defines the cell's Row, the second defines the cell's Column, the third defines the cell's Line in the cell (1=left line, 2=top line, 3=right line 4=bottom line), the fourth defines the LineStyle (0=None, 1=Thin, 2=Thick, 3=Double, 4=Dotted).
    Syntax:     Function GetCellLineStyle(ByVal Row As Long, ByVal Col As Long, ByVal Line As Long, ByVal LineStyle as Long) as Boolean

  • GetCellText - This retrieves the current text value in a specified cell. It takes two Long value parameters that specify the row number and the column number to find a particular cell.
    Syntax:     Function GetCellText(ByVal Row As Long, ByVal Col As Long) As String

  • GetCellTextColor - This retrieves the current color for the text used in a cell. This function returns True if the color value is successfully returned or False otherwise. The color (COLORREF value) is returned in the variable passed as the third parameter. This function takes three parameters. The first is the cell row, the second is the cell column, and the third is the color.
    Syntax:     Function GetCellTextColor(ByVal Row As Long, ByVal Col As Long, ByVal Color As Long) As Boolean

  • GetCellTextColor - This retrieves the current color for the text used in a cell. This function returns True if the color value is successfully returned or False otherwise. The color (COLORREF value) is returned in the variable passed as the third parameter. This function takes three parameters. The first is the cell row, the second is the cell column, and the third is the color.
    Syntax:     Function GetCellTextColor(ByVal Row As Long, ByVal Col As Long, ByVal Color As Long) As Boolean

  • GetCellTextValue - This retrieves the current text value in a specified cell. It takes two Long value parameters that specify the row number (first parameter) and the column number (second parameter) to find a particular cell. This differs from GetCellText in that if expressions are part of the text, those expressions are solved.
    Syntax: Function GetCellTextValue(ByVal Row As Long, ByVal Col As Long) As String

  • GetCellTopLineColor - This retrieves the color value for a specified cell's top line. This function returns True if the color value is successfully returned or False otherwise. The color (COLORREF value) is returned in the variable passed as the third parameter. This function takes three parameters. The first is the cell row, the second is the cell column, and the third is the color.
    Syntax: Function GetCellTopLineColor(ByVal Row As Long, ByVal Col As Long, ByVal Color As Long) As Boolean

  • IsCellMerged - Returns True if the cell is merged with another cell, False if not. It takes two Long value parameters that specify the row number (first parameter) and the column number (second parameter) to find a particular cell.
    Syntax:     Function IsCellMerged(ByVal Row As Long, ByVal Col As Long) As Boolean

  • IsCellVisible - Returns True if the cell is visible, False if hidden. It takes two Long value parameters that specify the row number (first parameter) and the column number (second parameter) to find a particular cell.
    Syntax:     Function IsCellVisible(ByVal Row As Long, ByVal Col As Long) As Boolean

  • IsPrimaryMergedCell - Returns True if the primary cell is merged. False if not. It takes two Long value parameters that specify the row number (first parameter) and the column number (second parameter) to find a particular cell. This differs from IsCellMerged by checking to see if the cell is the first of a merged cell. Only the contents of the primary cell are displayed in the merged cells field.
    Syntax:     Function IsPrimaryCellMerged(ByVal Row As Long, ByVal Col As Long) As Boolean

  • MergeCells - This merges two cells together. It returns True if the two cells specified are successfully merged, False if not. It takes four Long value parameters that specify two cells to merge.
    Syntax: Function MergeCells(ByVal Row As Long, ByVal Col As Long, ByVal Row2 As Long, ByVal Col2 as Long) as Boolean

  • Move - This moves the object to a new position. It takes two parameters. The first defines a new X position in the editor, the second a new Y position.
    Syntax: Sub Move (ByVal newX As Long, ByVal newY As Long)

  • SetCellBackgroundColor - This sets the background color for the specified cell. It takes three Long value parameters. The first two specify the row number (first parameter) and the column number (second parameter) to find a particular cell. The third specifies the color.
    Syntax: Function SetCellBackgroundColor(ByVal Row As Long, ByVal Col As Long, ByVal Color As Long) As Boolean

  • SetCellData - This sets the specified cell's value and returns True if the cells was successfully given the new value or False otherwise. It takes three Long value parameters. The first two specify the row number (first parameter) and the column number (second parameter) to find a particular cell. The third parameter is the new value.
    Syntax: Function SetCellData(ByVal Row As Long, ByVal Col As Long, ByVal Value As Long) As Boolean

  • SetCellFont - This sets the font style of a particular cell, it returns True if the cell's font was successfully done, or False otherwise. This function takes four parameters. The first two are Long values that specify the cell to change. The third is a string value of the font style to use. The fourth is a Long value that specifies the height of the font.
    Syntax: Function SetCellFont(ByVal Row As Long, ByVal Col As Long, ByVal FontStyle, As String, ByVal Height As Long) As Boolean

  • SetCellLeftLineColor - This sets the color value for a specified cell's left line, it returns True if the cell's left line color properly changed or False otherwise. This function takes three Long value parameters. The first two specify the row number (first parameter) and the column number (second parameter) to find a particular cell. The third parameter is the color value to use.
    Syntax: Function SetCellLeftLineColor(ByVal Row As Long, ByVal Col As Long, ByVal Color As Long) As Boolean

  • SetCellLineColor - This sets the line color for a particular cell. It returns True if the cell's line color is properly changed or False otherwise. This function takes three Long value parameters. The first two specify the row number (first parameter) and the column number (second parameter) to find a particular cell. The third parameter is the color value to use.
    Syntax: Function SetCellLineColor(ByVal Row As Long, ByVal Col As Long, ByVal Color As Long) As Boolean

  • SetCellText - This places the specified text string into the specified cell. It returns True if the cell was successfully inserted or False otherwise. This function takes three parameters. It takes three parameters. The first two are Long values that specify the cell to change. The third is a string value of the text to insert into the cell.
    Syntax: Function SetCellText(ByVal Row As Long, ByVal Col As Long, ByVal Value As String) As Boolean

  • SetCellTextColor - This sets the text color for a particular cell. It returns True if the cell's text color is properly changed or False otherwise. This function takes three Long value parameters. The first two specify the row number (first parameter) and the column number (second parameter) to find a particular cell. The third parameter is the color value to use.
    Syntax: Function SetCellTextColor(ByVal Row As Long, ByVal Col As Long, ByVal Color As Long) As Boolean

  • SetCellTopLineColor - This sets the color value for a specified cell's top line, it returns True if the cell's top line color properly changes or False otherwise. This function takes three Long value parameters. The first two specify the row number (first parameter) and the column number (second parameter) to find a particular cell. The third parameter is the color value to use.
    Syntax: Function SetCellTopLineColor(ByVal Row As Long, ByVal Col As Long, ByVal Color As Long) As Boolean

  • SetColumnBackgroundColor - This sets the background color value for a specified column in the GridControlObject. It returns True if the column's color properly changes or False otherwise. This function takes two Long value parameters. The first parameter indicates the column to change. The second parameter indicates the color to use.
    Syntax: Function SetColumnBackgroundColor(ByVal Col As Long, ByVal Color As Long) As Boolean

  • SetRowBackgroundColor - This sets the background color value for a specified row in the GridControlObject. It returns True if the row's color properly changes or False otherwise. This function takes two Long value parameters. The first parameter indicates the row to change. The second parameter indicates the color to use.
    Syntax: Function SetRowBackgroundColor(ByVal Row As Long, ByVal Color As Long) As Boolean

  • SetRowLeftLineColor - This sets the left line color value for all the cells in a specified row in the GridControlObject. It returns True if the row's left line color properly changes or False otherwise. This function takes two Long value parameters. The first parameter indicates the row to change. The second parameter is a Long value for the color.
    Syntax: Function SetRowLeftLineColor(ByVal Row As Long, ByVal Color As Long) As Boolean

  • SetRowLineStyle - This sets the line style for the entire row. It returns True if the style was successfully set or False otherwise. This function takes three Long value parameters. The first indicates the row to change, the second defines the cell's Line in the cell (1=left line, 2=top line, 3=right line 4=bottom line), the third defines the LineStyle (0=None, 1=Thin, 2=Thick, 3=Double, 4=Dotted).
    Syntax: Function SetRowLineStyle(ByVal Row As Long, ByVal Line As Long, ByVal LineStyle As Long) As Boolean

  • SetRowTopLineColor - This sets the top line color value for a specified row in the GridControlObject. It returns True if the row's top line color properly changes or False otherwise. This function takes two Long value parameters. The first parameter indicates the row to change. The second parameter indicates the color to use.
    Syntax: Function SetRowTopLineColor(ByVal Row As Long, ByVal Color As Long) As Boolean

See Also

ReportControls Members


ReportControls Object Members

ReportControls ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method Add | Adds a new control to the report template The Add method inserts a new control of a defined location and size into the current section of the report template.
Public Method Item | returns the given named or numbered control This method returns an Object of the control identified by the name or number in the NameOrNum parameter.
Public Method Remove | Removes the specified named or numbered control from the report template This deletes the specified control from the current section of the report template.

Public Properties

Public Property Application | Read Only: Returns the Application Object Returns an Application object.
Public Property Count | Read Only: Number of report controls on section/page This property counts all the controls in the current section/page and returns it as a Long value.
Public Property Parent | Read Only: Returns the parent Object This property returns this object's parent object, a generic object interface.
Public Property ReadOnly | Read Only: Returns the Read Only flag. If set controls cannot be added or removed

See Also

ReportControls Overview


_Item Method

_Item Method
NameOrNumber

Syntax

Visual Basic
Public Function _Item( _
   ByVal NameOrNumber As Variant _
) As Object

Parameters

NameOrNumber

See Also

ReportControls Object


Add Method

Add Method
ObjectType
Can be a constant or enumerated value.
Left
Long value sets the location of the left side of the control from the left side of the editor.
Top
Long value sets the top location of the control from the top side of the editor.
Right
Long value sets the right location of the control from the left side of the editor.
Bottom
Long value sets the bottom location of the control from the top side of the editor.

Description

Adds a new control to the report template The Add method inserts a new control of a defined location and size into the current section of the report template.

Syntax

Visual Basic
Public Function Add( _
   ByVal ObjectType As ENUM_REPORT_TEMPLATE_OBJECTS, _
   ByVal Left As Long, _
   ByVal Top As Long, _
   ByVal Right As Long, _
   ByVal Bottom As Long _
) As Object

Parameters

ObjectType
Value Description
ID_HOB_TEXT
ID_HOB_TEXT_RT
ID_HOB_LINE
ID_HOB_POLYLINE
ID_HOB_BORDER
ID_HOB_ARC
ID_HOB_CIRCLE
ID_HOB_BITMAP
ID_HOB_PTR
ID_HOB_GAUGE
ID_HOB_GRAPH
ID_HOB_PCD_TEXT_REPORT_OBJECT
ID_HOB_PCD_CAD_REPORT_OBJECT
ID_HOB_PCD_COMMAND_TEXT_OB
ID_HOB_PCD_GRID_CTRL_OB
ID_HOB_PCD_LEADERLINE_OB
ID_HOB_PCD_DIMCOLOR_OB
ID_HOB_PCD_ANALWIN_OB
ID_HOB_CADIMAGEOBJECT_OB
ID_HOB_PCD_SPC_CHART_OB
ID_HOB_PCD_LABEL_OB
Can be a constant or enumerated value.
Left
Long value sets the location of the left side of the control from the left side of the editor.
Top
Long value sets the top location of the control from the top side of the editor.
Right
Long value sets the right location of the control from the left side of the editor.
Bottom
Long value sets the bottom location of the control from the top side of the editor.

Remarks

To find out what properties are available to a control, in PC-DMIS's Report Template editor, insert the control and then access its properties sheet.

Example

Private Sub Add_Arc()

' Inserts an arc control

Set ArcControl = ReportObjects.Add(ID_HOB_ARC, 10, 10, 200, 200)

ArcControl.Bottom = 100

ArcControl.Left = 10

ArcControl.LineStyle = 2

ArcControl.LineWidth = 1

ArcControl.Right = 790

ArcControl.Top = 20

ArcControl.Visible = False

End Sub

See Also

ReportControls Object


Item Method

Item Method
NameOrNumber
Required Variant that indicates which control to return. It can be either a Long or a String. If it is a Long, it is the index number given the control within the ReportControls collection of controls. If it is a String, it is the ID, (or ObjectCode property in the template editor) of the control.

Description

returns the given named or numbered control This method returns an Object of the control identified by the name or number in the NameOrNum parameter.

Syntax

Visual Basic
Public Function Item( _
   ByVal NameOrNumber As Variant _
) As Object

Parameters

NameOrNumber
Required Variant that indicates which control to return. It can be either a Long or a String. If it is a Long, it is the index number given the control within the ReportControls collection of controls. If it is a String, it is the ID, (or ObjectCode property in the template editor) of the control.

Remarks

Be aware that a hidden control called "Report" always exists in the Report template and cannot be deleted or otherwise manipulated. This object is used by PC-DMIS for internal purposes only. For this reason do not give NameOrNum a value of 1, as it will try to select the Report control.

To manipulate existing report objects, you will need use this method. Once you establish a pointer to a report object, you can get or set any of its properties (similar to the ReportControls.Add method). To find the available properties, consult the dockable Properties dialog box inside PC-DMIS.

See Also

ReportControls Object | Add Method


Remove Method

Remove Method
NameOrNumber
Required Variant that indicates which control to remove. It can be either a Long or a String. If it is a Long, it is the index number given the control within the ReportControls collection of controls. If it is a String, it is the ID, (or ObjectCode property in the template editor) of the control.

Description

Removes the specified named or numbered control from the report template This deletes the specified control from the current section of the report template.

Syntax

Visual Basic
Public Function Remove( _
   ByVal NameOrNumber As Variant _
) As Long

Parameters

NameOrNumber
Required Variant that indicates which control to remove. It can be either a Long or a String. If it is a Long, it is the index number given the control within the ReportControls collection of controls. If it is a String, it is the ID, (or ObjectCode property in the template editor) of the control.

Remarks

Be aware that a hidden control called "Report" always exists in the Report template and cannot be deleted or otherwise manipulated. This object is used by PC-DMIS for internal purposes only. For this reason NameOrNum with a value of 1 will try to delete the Report control and will return False.

See Also

ReportControls Object


Application Property

Application Property

Description

Read Only: Returns the Application Object Returns an Application object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

See Also

ReportControls Object


Count Property

Count Property

Description

Read Only: Number of report controls on section/page This property counts all the controls in the current section/page and returns it as a Long value.

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

Return Type

Long value.

Remarks

Be aware that a hidden control called "Report" always exists in the Report template and cannot be deleted or otherwise manipulated. This object is used by PC-DMIS for internal purposes only. Your count value will therefore be one higher than expected due to this hidden object.

See Also

ReportControls Object


Parent Property

Parent Property

Description

Read Only: Returns the parent Object This property returns this object's parent object, a generic object interface.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Object

Return Type

Object.

See Also

ReportControls Object


ReadOnly Property

ReadOnly Property

Description

Read Only: Returns the Read Only flag. If set controls cannot be added or removed

Property type

Read-write property

Syntax

Visual Basic
Public Property ReadOnly() As Long

See Also

ReportControls Object


ReportData Object

ReportData Object
See Also Members

Description

The ReportData object lets you access data sent to reports during the EventReportData event.

Remarks

This event can only be accessed inside the Properties dialog box inside the Label and Report Template Editors inside PC-DMIS versions 4.0 and higher.

Properties dialog box

Using this object in conjunction with the EventReportData event, you can access the desired information.

Example

Suppose in PC-DMIS's Label Template Editor, you use a Border object to change its background color to match the current dimension out of tolerance color. You can do this using the ReportData object. The following code works inside of the PC-DMIS's label template editor in the EventReportData event of a Border object.

Dim Count As Integer

Dim i As Integer

Dim MaxIndex As Integer

Dim MaxDev As Double

Dim CurrentDev as Variant

Dim Dev as Variant

Dim PTol as Variant

Dim MTol as Variant

Dim DevColor as Long

' Initialize Max Deviation and Max Index

MaxDev = 0.0

MaxIndex = 1

'Get the number of axes for this dimension

Count = ReportData.GetCount(132)

'Adjust the bottom of the border to fit the number of axes

Border1.Bottom = 106+((Count-1)*25)

'Loop through to find the largest deviation

'When loop is complete, MaxIndex is the index to the

' largest deviation

For i=1 to Count

CurrentDev = ABS(ReportData.GetValue(DIM_DEVIATION,i))

If CurrentDev > MaxDev Then

MaxDev = CurrentDev

MaxIndex = i

End If

Next i

' Using MaxIndex, acquire the axis's deviation +TOL and -TOL

Dev = ReportData.GetValue(340, MaxIndex)

PTol = ReportData.GetValue(167, MaxIndex)

MTol = ReportData.GetValue(168, MaxIndex)

' Use this information to adjust the background color of the border

DevColor = ReportData.GetTolColor(Dev,PTol,MTol)

Border1.BackColor = DevColor

Border1.ForeColor = DevColor

See Also

ReportData Members


ReportData Object Members

ReportData ObjectMembers
See Also Overview

Public Methods

Public Method GetColorList | Returns the current global dimension color list This returns a the current global dimension color list.
Public Method GetCommand | Returns Command Object if report data has command interface This returns a Command Object if report data has command interface.
Public Method GetCount | Returns the number of instances of the specified data type This returns the number of instances of the specified data type.
Public Method GetExpressionValue | Returns the value of expression This returns value of the specified expression in Expression.
Public Method GetReferenceValue | Returns the reference feature value of the indicated field of the command. This returns the reference feature value of the indicated field of the command.
Public Method GetReferenceValue2 | Returns the reference feature value of the indicated field of the specified command. This returns the reference feature value of the indicated field of the command.
Public Method GetTolColor | Returns the current tolerance color based on deviation, plus tolerance, and minus tolerance This returns a the current tolerance color based on the deviation, plus tolerance, and minus tolerance.
Public Method GetValue | Returns the value of the indicated field of the command. This method returns the value of the indicated field of the command.
Public Method GetValue2 | Returns the value of the indicated field of the specified command. This method returns the value of the indicated field of the command.
Public Method HasCommandData | Returns true if report data has a part program command interface. This method returns True if report data has a part program command interface, False otherwise.

Public Properties

Public Property CurPage Read Only: Number of current page

This property returns a the number of the report's current page as a Long value.

See Also

ReportData Overview


GetColorList Method

GetColorList Method

Description

Returns the current global dimension color list This returns a the current global dimension color list.

Syntax

Visual Basic
Public Function GetColorList() As Variant

Return Type

Variant object.

See Also

ReportData Object


GetCommand Method

GetCommand Method

Description

Returns Command Object if report data has command interface This returns a Command Object if report data has command interface.

Syntax

Visual Basic
Public Function GetCommand() As Object

Return Type

Command object.

See Also

ReportData Object


GetCount Method

GetCount Method
DataType

Description

Returns the number of instances of the specified data type This returns the number of instances of the specified data type.

Syntax

Visual Basic
Public Function GetCount( _
   ByVal DataType As ENUM_FIELD_TYPES _
) As Long

Parameters

DataType
Value Description
ID
REF_ID
LEVEL_REF_ID
ROTATE_REF_ID
ORIGIN_REF_ID
THEO_X
THEO_Y
THEO_Z
THEO_SX
THEO_SY
THEO_SZ
THEO_EX
THEO_EY
THEO_EZ
THEO_I
THEO_J
THEO_K
TARG_X
TARG_Y
TARG_Z
MEAS_X
MEAS_Y
MEAS_Z
MEAS_I
MEAS_J
MEAS_K
MEAS_LENGTH
MEAS_DIAM
MEAS_ANGLE
TARG_I
TARG_J
TARG_K
THEO_DIAM
THEO_WIDTH
THEO_LENGTH
THEO_HEIGHT
THEO_ANGLE
COORD_TYPE
INOUT_TYPE
THICKNESS_TYPE
CIRC_TYPE
SNAP_TYPE
USEPIN_TYPE
MOVE_TYPE
READPOS_TYPE
FINDHOLE_TYPE
RMEAS_TYPE
THEOBF_TYPE
BOUND_TYPE
BF_MATH_TYPE
AUTOFIT_CONSTRAINT
SLOT_MIN_MAX_TYPE
FIND_NOM_AXIS_TYPE
N_INIT_HITS_TYPE
N_PERM_HITS_TYPE
SEARCHMODE_TYPE
MODE_TYPE
MEASURE_ORDER_TYPE
CONE_LENGTH_ANGLE_TYPE
OFFSET_LINE_METHOD
LIN_POL_FILT_TYPE
GEN_FEAT_TYPE
GEN_ALIGN_TYPE
CURVE_TYPE
MEASURED_2D3D_TYPE
THINNING_TOL
HITINT_TYPE
RMEASFEATID
N_HITS
N_ROWS
INIT_HITS
PERM_HITS
F_OFFSET
F_SPACER
F_PITCH
F_THICKNESS
F_DEPTH
F_AUTOMOVE
F_INDENT
F_CORNER_RADIUS
F_INCREMENT
F_TOLERANCE
F_BOXWIDTH
F_BOXLENGTH
F_CIRCRADOUT
F_CIRCRADIN
F_CHECK
F_MAXACCELX
F_MAXACCELY
F_MAXACCELZ
SCAN_ACCELERATION
SCAN_OFFSET_FORCE
MANUAL_FINE_PROBING
F_MOVESPEED
F_TOUCHSPEED
F_SCANSPEED
START_ANG
END_ANG
MIDPOINT_X
MIDPOINT_Y
MIDPOINT_Z
ANGVEC_I
ANGVEC_J
ANGVEC_K
MEASVEC_I
MEASVEC_J
MEASVEC_K
SLOTVEC_I
SLOTVEC_J
SLOTVEC_K
SURFVEC_I
SURFVEC_J
SURFVEC_K
PINVEC_I
PINVEC_J
PINVEC_K
PUNCHVEC_I
PUNCHVEC_J
PUNCHVEC_K
REPORTVEC_I
REPORTVEC_J
REPORTVEC_K
TARGSLOT_I
TARGSLOT_J
TARGSLOT_K
UPDATEVEC_I
UPDATEVEC_J
UPDATEVEC_K
THEO_MINOR_AXIS
TWO_D_THREE_D_TYPE
AXIS
DEST_EXPR
SRC_EXPR
SHOW_IDS
SHOW_DETAILS
WEIGHT
ITEM_USED
USE_AXIS
AVERAGE_ERROR
MEASURE_ALL_FEATURES
REPIERCE_CAD
START_NUM
END_NUM
SKIP_NUM
X_OFFSET
Y_OFFSET
Z_OFFSET
ANGLE_OFFSET
INTERNAL_EXTERNAL
SAVE_ALIGN_CAD_TO_PARTS
FILE_NAME
ALIGN_LIST
WORK_PLANE
DISTANCE
OLD_TIP
NEW_TIP
ROTATION_TYPE
DIM_INFO_ORDER
DIM_INFO_LOC
DIM_INFO_TP_LOC
GRAPH_ANALYSIS
TEXT_ANALYSIS
ARROW_MULTIPLIER
OUTPUT_TYPE
NOMINAL
F_PLUS_TOL
F_MINUS_TOL
TP_MODIFIER
PERP_PARALLEL_TYPE
RADIUS_TYPE
UNIT_TYPE
DIM_LENGTH
PROFILE_FORM_TYPE
PRECISION
MAN_RETRACT
DIM_TEXT
DIM_TEXT_OPTIONS
SHOW_HEADINGS
DEVIATION_SYMBOLS
STANDARD_DEVIATION
DIM_HEADING
GAP_ONLY_TYPE
DISPLAY_ID
DISPLAY_TYPE
POINT_INFO_HEADING
SHOW_POINT_INFO
RET_ONLY_TYPE
COMMENT_FIELD
COMMENT_TYPE
PART_NAME
REVISION_NUMBER
SERIAL_NUMBER
STAT_COUNT
SUB_NAME
READ_WRITE
FILE_POINTER
FIELD_WIDTH
DIGIT_COUNT
LABEL_ID
ERROR_TYPE
ERROR_MODE
DESCRIPTION
INDEX_START
INDEX_END
FILE_COMMAND_TYPE
BUFFER_SIZE_TYPE
FAIL_ON_EXIST
MAX_FORCE
LOW_FORCE
UP_FORCE
TRIGGER_FORCE
PROBE_ACCURACY
POSITIONAL_ACCURACY
NUM_RETURN_DATA
RETURN_SPEED
SCAN_DENSITY
POLAR_VECTOR_COMPENSATION
AUTO_PRINT
ORIGIN
MATERIAL_COEFFICIENT
REF_TEMP
HIGH_THRESHOLD
LOW_THRESHOLD
SENSOR_LIST
FIXTURE_TYPE
MACHINE_TYPE
PROBE_COMP
TIP_I
TIP_J
TIP_K
NORM_RELEARN
FIND_NOMS_TYPE
AUTO_CLEAR_PLANE
SINGLE_POINT
DISPLAY_HITS
CAD_TOLERANCE
OFFSET_TOLERANCE
MIN_INCREMENT
MAX_INCREMENT
MIN_ANGLE
MAX_ANGLE
F_LOCATION
COL132_TYPE
COMMAND_STRING
FLY_MODE_TYPE
STATS_TYPE
STATS_DIR
NEW_STATS_DIR
DATA_READ_LOCK
DATA_WRITE_LOCK
DATA_MEM_PAGES
STAT_NAME_TYPE
STAT_CALC_TYPE
TRANSFER_DIR
DISPLAY_TRACE
TRACE_NAME
TRACE_VALUE
SCAN_CUTPLANEVEC_I
SCAN_CUTPLANEVEC_J
SCAN_CUTPLANEVEC_K
SCAN_INITVEC_I
SCAN_INITVEC_J
SCAN_INITVEC_K
SCAN_AXISVEC_I
SCAN_AXISVEC_J
SCAN_AXISVEC_K
SCAN_ENDVEC_I
SCAN_ENDVEC_J
SCAN_ENDVEC_K
SCAN_INITDIR_I
SCAN_INITDIR_J
SCAN_INITDIR_K
SCAN_CROSS_TOTAL
SCAN_TIME_INCR
SCAN_EDGE_THICK
POS_REPORT_AXIS_X
POS_REPORT_AXIS_Y
POS_REPORT_AXIS_Z
DEV_PERPEN_CENTERLINE
USE_THEO
TARGET_COLOR
THEO_START_ANG
THEO_END_ANG
ONOFF_TYPE
ROW_ID
LOCATOR_BMP
LOCATOR_WAV
DTYPE_LEAPFROGTYPE
DTYPE_LEAPFROGNUMHITS
DTYPE_LEAPFROGFULLPARTIAL
EXCLUSION_ZONE
EXECUTE
AUTOTRIGGERONOFF
AUTOBEEPING
COLUMN_ID
SLOT_NUMBER
AUTOTOLZONE
PROBING_MODE
ANGLE_COMP_TOGGLE
POINTINFO_FILTER_INTERVAL
POINTINFO_FILTER_INTERVAL_NUMBER
FEAT_TYPE
DIM_ID
MEAS_MINOR_AXIS
MEAS_HEIGHT
MEAS_SLOTVEC_I
MEAS_SLOTVEC_J
MEAS_SLOTVEC_K
MEAS_SX
MEAS_SY
MEAS_SZ
MEAS_EX
MEAS_EY
MEAS_EZ
MEAS_WIDTH
NUM_CONTROL_POINTS
U_HITS
V_HITS
NUM_FIT_POINTS
NOMINAL_COLOR
WAVE_FILE
DIM_BONUS
PERUNIT_STEPSIZE
PERUNIT_LENGTH
PERUNIT_WIDTH
DIM_MEASURED
SURFVEC_TARG_I
SURFVEC_TARG_J
SURFVEC_TARG_K
DIM_MAX
EDGEVEC_TARG_I
EDGEVEC_TARG_J
EDGEVEC_TARG_K
DIM_MIN
EDGEVEC_THEO_I
EDGEVEC_THEO_J
EDGEVEC_THEO_K
DIM_DEVIATION
EDGEVEC_MEAS_I
EDGEVEC_MEAS_J
EDGEVEC_MEAS_K
DIM_OUTTOL
T_VALUE
TOOL_X
TOOL_Y
TOOL_Z
TOOL_DIAM
DEV_X
DEV_Y
DEV_Z
DEV_DIAM
ITERATE_COLUMNS
LOAD_TYPE
NUM_ITERATIONS
METHOD_TYPE
SCAN_TECHNIQUE
HIT_TYPE
BOUNDARY_POINT_X
BOUNDARY_POINT_Y
BOUNDARY_POINT_Z
VIDEO_GAIN
VIDEO_OFFSET
VIDEO_LEDLIGHT
VIDEO_LASERLIGHT1
VIDEO_LASERLIGHT2
VIDEO_YORIGIN
VIDEO_YEND
VIDEO_LSEG
VIDEO_XSEG
VIDEO_YSEG
ANGULARITY_NOM_ANGLE
PRINT_TO_FILE
PRINT_TO_PRINTER
PRINT_DRAFTMODE
PRINT_DELETE_RUNS
POINTINFO_FILTER_WORST
POINTINFO_FILTER_WORST_NUMBER
POINTINFO_FILTER_DEVIATION
POINTINFO_FILTER_DEVIATION_NUMBER
POINTINFO_FILTER_OUTTOL
REPORT_SURFVEC_I
REPORT_SURFVEC_J
REPORT_SURFVEC_K
DB_QUERY_OP
DB_SOURCE_NAME
CHART_TYPE
DB_CHART_NAME
DEVIATION_ANGLE
STATS_DATASOURCE
IGNOREMOTIONERRORS_TYPE
THEO_X2
THEO_Y2
THEO_Z2
MEAS_X2
MEAS_Y2
MEAS_Z2
PPROG
TRACE_FILTER
TIME_FILTER
SHOW_SPC_CALCS
SPEC_LIMITS
ZONES
STDDEV
UCL_LCL
HISTOGRAM
GRID
ADDITIONAL_CHART
LINE2_PLANAR_OPEN_IN_X
LINE3_PLANAR_OPEN_IN_X
REGR
CENTER_POINT
SHOW_MORE_SPC_CALCS
SPEC_OFFSET
SOLID
U_L_BOUNDS
TITLE
CPOINT_X
CPOINT_Y
CPOINT_Z
CPOINT_I
CPOINT_J
CPOINT_K
CPOINT_DIAM
CPOINT_SCAN_CROSS_TOTAL
CPOINT_SCAN_DENSITY
CPOINT_F_SCANSPEED
N_CONTROLPOINTS
CPOINT_TYPE
USE_3DFILTER
SCAN_BNDRY_TYPE
CREATE_WEIGHTS
F_SIZE
LINE2_ISPLANAR
LINE2_PLANAR_XTOL
LINE2_PLANAR_YTOL
LINE2_PLANAR_XDEV
LINE2_PLANAR_YDEV
LINE3_ISPLANAR
LINE3_PLANAR_XTOL
LINE3_PLANAR_YTOL
LINE3_PLANAR_XDEV
LINE3_PLANAR_YDEV
CHART_SUB_TYPE
OVERWRITE
OUTPUT_FEATURE_NOMS
OUTPUT_FEAT_W_DIMENS
OUTPUT_DMIS_REPORT
TIME_ARG
TRACE_FILTER_ARG
FIT
STATS_DB_TYPE
IOCHANNEL_NUMBER
IOCHANNEL_PULSE_WIDTH
IOCHANNEL_PULSE_INTERVAL
IOCHANNEL_PULSE_DURATION
GRAPH_OPTION
DB_SOURCE_TYPE
FIND_HOLE_PERCENT
AUTO_ONERROR_TYPE
POS_REPT_DISPLAY_OPTION
TRIGGERTOLERANCE
TRIGGERTOLVALUE
FIXTURE_TOL
START_LABEL
ERROR_LABEL
CONE_CONVEX_TYPE
TRIGGERPLANE
QUERY_SHOW_GRAPHIC_SETTINGS
CALC_STYLE_FILE
FILTER_TYPE
TRACE_VALUE_LIMIT
TARGET_DIRECTION
TARGET_EDGE_POLARITY
BSMETHOD_TYPE
CENTER_ROTATION_THEO
CENTER_ROTATION_MEAS
ARTICULATEDARM_TYPE
LEFTYRIGHTY_CONFIG
ABOVEBELOW_CONFIG
NOFLIPFLIP_CONFIG
HIGH_ACCURACY
SURFACE
MAGNIFICATION
MINOR_WORD_TOGGLE
PERCENTAGE
THRESHOLD
N_SIDES
TARGET_SURFACE_ILLUM
MEAN
CAD_COMP
SHOW_ROW
SHOW_COLUMN
TARGET_SURFACE_SENSILIGHT
TARGET_SURFACE_WIDTH
TARGET_SURFACE_HEIGHT
TARGET_SURFACE_RANGE
TARGET_SURFACE_DURATION
TARGET_SURFACE_MODE
TARGET_SURFACE_HIACC
SCREEN_CAPTURE_SCALE
SCREEN_CAPTURE_QUALITY
TARGET_EDGE_SIZE
TARGET_EDGE_ILLUM
TARGET_EDGE_TOL
TARGET_EDGE_STRENGTH
TARGET_EDGE_DENSITY
TARGET_EDGE_TYPE
DISPLAY_ADVANCED_PARAMETERS
TARGET_SURFACE_TYPE
VOID_DETECT
TARG_SX
TARG_SY
TARG_SZ
TARG_EX
TARG_EY
TARG_EZ
PATTERN_TYPE
TARGET_EDGE_ANGLE
PROGRAM_GAGE_FEAT_TYPE
PROGRAM_GAGE_TYPE
TARGET_FOCUS
RMEASFEATIDX
RMEASFEATIDY
RMEASFEATIDZ
FINDNOMS_BESTFIT
FINDNOMS_ONLYSELECTED
TEMPX
TEMPY
TEMPZ
TEMPP
AUTO_PH9
MANUAL_PREPOSITION
SCREEN_CAPTURE_TYPE
SCREEN_CAPTURE_AUTO_TYPE
TARGET_EDGE_EDGESELECT
TARGET_EDGE_EDGENUM
DELETE_TYPE
SCREEN_CAPTURE_AUTO_TIME
USE_HSSDAT
USE_STARTENDDELAY
COP_FILTER
COP_SIZE
COP_TYPE
SURFVEC_MEAS_I
SURFVEC_MEAS_J
SURFVEC_MEAS_K
TARGET_EDGE_UNDERSCAN
PROFILE_TYPE
THEO_FLUSH
MEAS_FLUSH
THEO_GAP
MEAS_GAP
THEO_DEPTH
MEAS_DEPTH
TARGET_BLOB_TYPE
LASER_STRIPE_OVERLAP
LASER_STRIPE_OVERSCAN
LASER_FREQUENCY
TARGET_FILTER_OUTLIER
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD
SLOT_TYPE
TARGET_TYPE
THEO_R
THEO_A
THEO_H
MEAS_R
MEAS_A
MEAS_H
TARG_R
TARG_A
TARG_H
THEO_SR
THEO_SA
THEO_SH
THEO_ER
THEO_EA
THEO_EH
MEAS_SR
MEAS_SA
MEAS_SH
MEAS_ER
MEAS_EA
MEAS_EH
TARG_SR
TARG_SA
TARG_SH
TARG_ER
TARG_EA
TARG_EH
TARGET_EDGE_SENSILIGHT
F_THICKNESS_EDGE
THICKNESS_TYPE_EDGE
LASER_EXPOSURE
LASER_INTENSITY
ANGLE_OFFSET_2
LASER_FILTER_NEIGHBOR_NUM
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD
LASER_FILTER_TOL_ABOVE
LASER_FILTER_TOL_BELOW
LASER_FILTER_TOL_RIGHT
LASER_CLIP_UP_DIST
LASER_CLIP_LOW_DIST
LASER_PIXEL_TOGGLE
LASER_FILTER_TOGGLE
DISPLAY_PROBE_PARAMETERS
THEO_R2
THEO_A2
THEO_H2
MEAS_R2
MEAS_A2
MEAS_H2
LASER_CLIP_LEFT_DIST
LASER_CLIP_RIGHT_DIST
COP_FILETYPE
COP_SELECTIONTYPE
COP_COLORMAP
COP_COPLEMENT
OPERTYPE
COP_BOOLEANTYPE
COP_IMPORTFILETYPE
MEAS_START_ANG
MEAS_END_ANG
ISLAND_DIAM
ISLAND_LENGTH
ISLAND_WIDTH
ISLAND_X
ISLAND_Y
ISLAND_Z
ISLAND_I
ISLAND_J
ISLAND_K
ISLAND_AI
ISLAND_AJ
ISLAND_AK
ISLAND_TYPE
ISLAND_CLEARANCEDIST
RPT_DIMENSION_TABLES
SUMMARY_DEV
DRF_TBLHDR
LINE1_TBLHDR
LINE1_CALLOUT
LINE1_COLUMN_HDR
LINE1_FEATNAME
LINE1_NOMINAL
LINE1_MEAS
LINE1_PLUSTOL
LINE1_MINUSTOL
LINE1_DEV
LINE1_DEVPERCENT
LINE1_ISBILATERAL
LINE1_NUMZONES
LINE2_TBLHDR
LINE2_CALLOUT
LINE2_COLUMN_HDR
LINE2_FEATNAME
LINE2_BONUS
LINE2_TOL
LINE2_DATUMSHFT
LINE2_UNUSEDZONE
LINE2_DEV
LINE2_DEVANG
LINE2_DEVPERCENT
LINE3_TBLHDR
LINE3_CALLOUT
LINE3_COLUMN_HDR
LINE3_FEATNAME
LINE3_BONUS
LINE3_TOL
LINE3_DATUMSHFT
LINE3_UNUSEDZONE
LINE3_DEV
LINE3_DEVANG
LINE3_DEVPERCENT
DRF_COLUMN_HDR
DRF_SEGNAME
DRF_SHIFTX
DRF_SHIFTY
DRF_SHIFTZ
DRF_ROTATIONX
DRF_ROTATIONY
DRF_ROTATIONZ
SUMMARY_COLUMN_HDR
SUMMARY_FEAT
LINE2_AXIS
LINE2_NOMINAL
LINE2_MEAS
SUMMARY_TBLHDR
SUMMARY_AXIS
SUMMARY_NOMINAL
SUMMARY_MEAS
LINE2_PLUSTOL
LINE2_MINUSTOL
LINE2_MAX
LINE2_MIN
LINE2_ISBILATERAL
LINE2_NUMZONES
LINE3_ISBILATERAL
LINE3_NUMZONES
DIM_RPT_COLUMN_HDR
DIM_RPT_ISDATUM
DIM_RPT_DATUM
DIM_RPT_GRAPHIC
DIM_RPT_DEVPERCENT
DIM_RPT_ISBILATERAL
DIM_RPT_NUMZONES
GDT_SYMBOL
COMMENT_INPUT
TARGET_EDGE_WIDTH
TARGET_EDGE_HEIGHT
TARGET_EDGE_EDGEDETECT
TARGET_EDGE_FILTER_CLEAN
TARGET_EDGE_FILTER_CLEAN_STRENGTH
TARGET_EDGE_FILTER_AREA
TARGET_EDGE_FILTER_AREA_SIZE
TARGET_EDGE_GRADIENT
THEO_PERIMETER
MEAS_PERIMETER
THEO_AREA
MEAS_AREA
TARGET_SURFACE_CROSSHAIR_HEIGHT
SHOW_NOMS
COMPOSITE
DATUM2
TP_MODIFIER2
DESCRIPTION2
SHOW_OPTIONS
LEADER_LINE_ID
GDT_SYMBOL2
DATUM1_MODIFIER
DATUM2_MODIFIER
DATUM3_MODIFIER
DATUM1_MODIFIER2
DATUM2_MODIFIER2
DATUM3_MODIFIER2
DIM_RPT_DEVPERCENT_NOM
DIM_RPT_USETWODEVIATIONS
DIM_RPT_DEVPERCENT2
LINE2_DEVPERCENT_NOM
LINE2_USE2DEVIATIONS
LINE2_DEVPERCENT2
LINE3_DEVPERCENT_NOM
LINE3_USE2DEVIATIONS
LINE3_DEVPERCENT2
AXIS_PLUS_TOL
AXIS_MINUS_TOL
AXIS_NOMINAL
AXIS_DESCRIPTION
LINE1_DEVPERCENT_NOM
LINE1_USE2DEVIATIONS
LINE1_DEVPERCENT2
USE_AXIS2
DIM_LENGTH2
TEXTANAL_LABEL_MEAS_X
TEXTANAL_LABEL_MEAS_Y
TEXTANAL_LABEL_MEAS_Z
TEXTANAL_LABEL_MEAS_I
TEXTANAL_LABEL_MEAS_J
TEXTANAL_LABEL_MEAS_K
TEXTANAL_LABEL_DEV
TEXTANAL_LABEL_MINMAX
SIMULT_EVAL
SECTION_INDEX
LINE1_OUTTOL
LINE2_OUTTOL
LINE3_OUTTOL
LINE1_MAX
LINE1_MIN
LINE3_NOMINAL
LINE3_MEAS
LINE3_PLUSTOL
LINE3_MINUSTOL
LINE3_MAX
LINE3_MIN
SUMMARY_OUTTOL
SUMMARY_PLUSTOL
SUMMARY_MINUSTOL
SUMMARY_MAX
SUMMARY_MIN
SUMMARY_BONUS
LINE1_BONUS
GRAPH_ANALYSIS_POINT_SIZE
GRAPH_ANALYSIS_PLUS_TOL
GRAPH_ANALYSIS_MINUS_TOL
DIM_AXIS_ITEM_NUMBER
F_ENDING_DEPTH
DIM_ITEM_NUMBER
FEAT_ITEM_NUMBER
COMMAND_TYPE
DEV_MAX
AUTO_DEV_DIRECTION
PROBE_DIRECTION
USER_DEFINED_THEOS
SCALING
USE_SCALING
UID
REF_UID
BA_SOLUTION_TYPE
BA_SOLUTION_OPTIONS
BA_SOLUTION_STATUS
BA_VARIANCE
BA_RMS
BA_WARNINGS
BA_STATION
BA_STATION_X
BA_STATION_Y
BA_STATION_Z
BA_STATION_ROTX
BA_STATION_ROTY
BA_STATION_ROTZ
BA_STATION_ORIENTED
BA_STATION_LOCKED
BA_FEATURE
BA_FEAT_SOURCE
BA_FEAT_RMS
BA_FEAT_POINTING_ERR
BA_FEAT_APEX_ANGLE
BA_FEAT_X
BA_FEAT_Y
BA_FEAT_Z
BA_FEAT_DEV_X
BA_FEAT_DEV_Y
BA_FEAT_DEV_Z
BA_FEAT_DEV3D
NO_APPROACH_VECTOR_FLIP
TARGET_EDGE_START_VALUE
TARGET_EDGE_END_VALUE
TARGET_SURFACE_SURFACE_VARIANCE
RELATIVE_COMMENTS
AUTO_ROTARY
TARGET_COVERAGE
ROTATION_TYPE_2
PROBE_TYPE
TIME_STAMP
ECOND_TEMP
ECOND_PRESSURE
ECOND_HUMIDITY
HIT_RMS
DISPLAY_TRACKER_PARAMETERS
PTDENSITY_TOGGLE
PTDENSITY_UPPERBOUND
PTDENSITY_DEVLIMIT
PTDENSITY_MAXSPAN
TARGET_MEASURE_AT_FOV_CENTER
TARGET_SURFACE_FIND_SURFACE
PROJECTOR
INLINE_LEGACY_REPORT
SINGLE_POINT_DEVIATION

Return Type

Long value representing the number of instances of the specified data type.

See Also

ReportData Object


GetExpressionValue Method

GetExpressionValue Method
Expression
Required expression that evaluates to a PC-DMIS ReportData object.

Description

Returns the value of expression This returns value of the specified expression in Expression.

Syntax

Visual Basic
Public Function GetExpressionValue( _
   ByVal Expression As String _
) As Variant

Parameters

Expression
Required expression that evaluates to a PC-DMIS ReportData object.

Return Type

This returns value of the specified expression in Expression.

See Also

ReportData Object


GetReferenceValue Method

GetReferenceValue Method
refValue
A Long value representing the reference.
DataType
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a specified field type. In these cases, the TypeIndex must not be greater than the current number of fields of the that type + 1 and TypeIndex must be greater than 1. For fields that allow only a single value, the TypeIndex is 0.

Description

Returns the reference feature value of the indicated field of the command. This returns the reference feature value of the indicated field of the command.

Syntax

Visual Basic
Public Function GetReferenceValue( _
   ByVal refValue As Long, _
   ByVal DataType As ENUM_FIELD_TYPES, _
   ByVal TypeIndex As Long _
) As Variant

Parameters

refValue
A Long value representing the reference.
DataType
Value Description
ID
REF_ID
LEVEL_REF_ID
ROTATE_REF_ID
ORIGIN_REF_ID
THEO_X
THEO_Y
THEO_Z
THEO_SX
THEO_SY
THEO_SZ
THEO_EX
THEO_EY
THEO_EZ
THEO_I
THEO_J
THEO_K
TARG_X
TARG_Y
TARG_Z
MEAS_X
MEAS_Y
MEAS_Z
MEAS_I
MEAS_J
MEAS_K
MEAS_LENGTH
MEAS_DIAM
MEAS_ANGLE
TARG_I
TARG_J
TARG_K
THEO_DIAM
THEO_WIDTH
THEO_LENGTH
THEO_HEIGHT
THEO_ANGLE
COORD_TYPE
INOUT_TYPE
THICKNESS_TYPE
CIRC_TYPE
SNAP_TYPE
USEPIN_TYPE
MOVE_TYPE
READPOS_TYPE
FINDHOLE_TYPE
RMEAS_TYPE
THEOBF_TYPE
BOUND_TYPE
BF_MATH_TYPE
AUTOFIT_CONSTRAINT
SLOT_MIN_MAX_TYPE
FIND_NOM_AXIS_TYPE
N_INIT_HITS_TYPE
N_PERM_HITS_TYPE
SEARCHMODE_TYPE
MODE_TYPE
MEASURE_ORDER_TYPE
CONE_LENGTH_ANGLE_TYPE
OFFSET_LINE_METHOD
LIN_POL_FILT_TYPE
GEN_FEAT_TYPE
GEN_ALIGN_TYPE
CURVE_TYPE
MEASURED_2D3D_TYPE
THINNING_TOL
HITINT_TYPE
RMEASFEATID
N_HITS
N_ROWS
INIT_HITS
PERM_HITS
F_OFFSET
F_SPACER
F_PITCH
F_THICKNESS
F_DEPTH
F_AUTOMOVE
F_INDENT
F_CORNER_RADIUS
F_INCREMENT
F_TOLERANCE
F_BOXWIDTH
F_BOXLENGTH
F_CIRCRADOUT
F_CIRCRADIN
F_CHECK
F_MAXACCELX
F_MAXACCELY
F_MAXACCELZ
SCAN_ACCELERATION
SCAN_OFFSET_FORCE
MANUAL_FINE_PROBING
F_MOVESPEED
F_TOUCHSPEED
F_SCANSPEED
START_ANG
END_ANG
MIDPOINT_X
MIDPOINT_Y
MIDPOINT_Z
ANGVEC_I
ANGVEC_J
ANGVEC_K
MEASVEC_I
MEASVEC_J
MEASVEC_K
SLOTVEC_I
SLOTVEC_J
SLOTVEC_K
SURFVEC_I
SURFVEC_J
SURFVEC_K
PINVEC_I
PINVEC_J
PINVEC_K
PUNCHVEC_I
PUNCHVEC_J
PUNCHVEC_K
REPORTVEC_I
REPORTVEC_J
REPORTVEC_K
TARGSLOT_I
TARGSLOT_J
TARGSLOT_K
UPDATEVEC_I
UPDATEVEC_J
UPDATEVEC_K
THEO_MINOR_AXIS
TWO_D_THREE_D_TYPE
AXIS
DEST_EXPR
SRC_EXPR
SHOW_IDS
SHOW_DETAILS
WEIGHT
ITEM_USED
USE_AXIS
AVERAGE_ERROR
MEASURE_ALL_FEATURES
REPIERCE_CAD
START_NUM
END_NUM
SKIP_NUM
X_OFFSET
Y_OFFSET
Z_OFFSET
ANGLE_OFFSET
INTERNAL_EXTERNAL
SAVE_ALIGN_CAD_TO_PARTS
FILE_NAME
ALIGN_LIST
WORK_PLANE
DISTANCE
OLD_TIP
NEW_TIP
ROTATION_TYPE
DIM_INFO_ORDER
DIM_INFO_LOC
DIM_INFO_TP_LOC
GRAPH_ANALYSIS
TEXT_ANALYSIS
ARROW_MULTIPLIER
OUTPUT_TYPE
NOMINAL
F_PLUS_TOL
F_MINUS_TOL
TP_MODIFIER
PERP_PARALLEL_TYPE
RADIUS_TYPE
UNIT_TYPE
DIM_LENGTH
PROFILE_FORM_TYPE
PRECISION
MAN_RETRACT
DIM_TEXT
DIM_TEXT_OPTIONS
SHOW_HEADINGS
DEVIATION_SYMBOLS
STANDARD_DEVIATION
DIM_HEADING
GAP_ONLY_TYPE
DISPLAY_ID
DISPLAY_TYPE
POINT_INFO_HEADING
SHOW_POINT_INFO
RET_ONLY_TYPE
COMMENT_FIELD
COMMENT_TYPE
PART_NAME
REVISION_NUMBER
SERIAL_NUMBER
STAT_COUNT
SUB_NAME
READ_WRITE
FILE_POINTER
FIELD_WIDTH
DIGIT_COUNT
LABEL_ID
ERROR_TYPE
ERROR_MODE
DESCRIPTION
INDEX_START
INDEX_END
FILE_COMMAND_TYPE
BUFFER_SIZE_TYPE
FAIL_ON_EXIST
MAX_FORCE
LOW_FORCE
UP_FORCE
TRIGGER_FORCE
PROBE_ACCURACY
POSITIONAL_ACCURACY
NUM_RETURN_DATA
RETURN_SPEED
SCAN_DENSITY
POLAR_VECTOR_COMPENSATION
AUTO_PRINT
ORIGIN
MATERIAL_COEFFICIENT
REF_TEMP
HIGH_THRESHOLD
LOW_THRESHOLD
SENSOR_LIST
FIXTURE_TYPE
MACHINE_TYPE
PROBE_COMP
TIP_I
TIP_J
TIP_K
NORM_RELEARN
FIND_NOMS_TYPE
AUTO_CLEAR_PLANE
SINGLE_POINT
DISPLAY_HITS
CAD_TOLERANCE
OFFSET_TOLERANCE
MIN_INCREMENT
MAX_INCREMENT
MIN_ANGLE
MAX_ANGLE
F_LOCATION
COL132_TYPE
COMMAND_STRING
FLY_MODE_TYPE
STATS_TYPE
STATS_DIR
NEW_STATS_DIR
DATA_READ_LOCK
DATA_WRITE_LOCK
DATA_MEM_PAGES
STAT_NAME_TYPE
STAT_CALC_TYPE
TRANSFER_DIR
DISPLAY_TRACE
TRACE_NAME
TRACE_VALUE
SCAN_CUTPLANEVEC_I
SCAN_CUTPLANEVEC_J
SCAN_CUTPLANEVEC_K
SCAN_INITVEC_I
SCAN_INITVEC_J
SCAN_INITVEC_K
SCAN_AXISVEC_I
SCAN_AXISVEC_J
SCAN_AXISVEC_K
SCAN_ENDVEC_I
SCAN_ENDVEC_J
SCAN_ENDVEC_K
SCAN_INITDIR_I
SCAN_INITDIR_J
SCAN_INITDIR_K
SCAN_CROSS_TOTAL
SCAN_TIME_INCR
SCAN_EDGE_THICK
POS_REPORT_AXIS_X
POS_REPORT_AXIS_Y
POS_REPORT_AXIS_Z
DEV_PERPEN_CENTERLINE
USE_THEO
TARGET_COLOR
THEO_START_ANG
THEO_END_ANG
ONOFF_TYPE
ROW_ID
LOCATOR_BMP
LOCATOR_WAV
DTYPE_LEAPFROGTYPE
DTYPE_LEAPFROGNUMHITS
DTYPE_LEAPFROGFULLPARTIAL
EXCLUSION_ZONE
EXECUTE
AUTOTRIGGERONOFF
AUTOBEEPING
COLUMN_ID
SLOT_NUMBER
AUTOTOLZONE
PROBING_MODE
ANGLE_COMP_TOGGLE
POINTINFO_FILTER_INTERVAL
POINTINFO_FILTER_INTERVAL_NUMBER
FEAT_TYPE
DIM_ID
MEAS_MINOR_AXIS
MEAS_HEIGHT
MEAS_SLOTVEC_I
MEAS_SLOTVEC_J
MEAS_SLOTVEC_K
MEAS_SX
MEAS_SY
MEAS_SZ
MEAS_EX
MEAS_EY
MEAS_EZ
MEAS_WIDTH
NUM_CONTROL_POINTS
U_HITS
V_HITS
NUM_FIT_POINTS
NOMINAL_COLOR
WAVE_FILE
DIM_BONUS
PERUNIT_STEPSIZE
PERUNIT_LENGTH
PERUNIT_WIDTH
DIM_MEASURED
SURFVEC_TARG_I
SURFVEC_TARG_J
SURFVEC_TARG_K
DIM_MAX
EDGEVEC_TARG_I
EDGEVEC_TARG_J
EDGEVEC_TARG_K
DIM_MIN
EDGEVEC_THEO_I
EDGEVEC_THEO_J
EDGEVEC_THEO_K
DIM_DEVIATION
EDGEVEC_MEAS_I
EDGEVEC_MEAS_J
EDGEVEC_MEAS_K
DIM_OUTTOL
T_VALUE
TOOL_X
TOOL_Y
TOOL_Z
TOOL_DIAM
DEV_X
DEV_Y
DEV_Z
DEV_DIAM
ITERATE_COLUMNS
LOAD_TYPE
NUM_ITERATIONS
METHOD_TYPE
SCAN_TECHNIQUE
HIT_TYPE
BOUNDARY_POINT_X
BOUNDARY_POINT_Y
BOUNDARY_POINT_Z
VIDEO_GAIN
VIDEO_OFFSET
VIDEO_LEDLIGHT
VIDEO_LASERLIGHT1
VIDEO_LASERLIGHT2
VIDEO_YORIGIN
VIDEO_YEND
VIDEO_LSEG
VIDEO_XSEG
VIDEO_YSEG
ANGULARITY_NOM_ANGLE
PRINT_TO_FILE
PRINT_TO_PRINTER
PRINT_DRAFTMODE
PRINT_DELETE_RUNS
POINTINFO_FILTER_WORST
POINTINFO_FILTER_WORST_NUMBER
POINTINFO_FILTER_DEVIATION
POINTINFO_FILTER_DEVIATION_NUMBER
POINTINFO_FILTER_OUTTOL
REPORT_SURFVEC_I
REPORT_SURFVEC_J
REPORT_SURFVEC_K
DB_QUERY_OP
DB_SOURCE_NAME
CHART_TYPE
DB_CHART_NAME
DEVIATION_ANGLE
STATS_DATASOURCE
IGNOREMOTIONERRORS_TYPE
THEO_X2
THEO_Y2
THEO_Z2
MEAS_X2
MEAS_Y2
MEAS_Z2
PPROG
TRACE_FILTER
TIME_FILTER
SHOW_SPC_CALCS
SPEC_LIMITS
ZONES
STDDEV
UCL_LCL
HISTOGRAM
GRID
ADDITIONAL_CHART
LINE2_PLANAR_OPEN_IN_X
LINE3_PLANAR_OPEN_IN_X
REGR
CENTER_POINT
SHOW_MORE_SPC_CALCS
SPEC_OFFSET
SOLID
U_L_BOUNDS
TITLE
CPOINT_X
CPOINT_Y
CPOINT_Z
CPOINT_I
CPOINT_J
CPOINT_K
CPOINT_DIAM
CPOINT_SCAN_CROSS_TOTAL
CPOINT_SCAN_DENSITY
CPOINT_F_SCANSPEED
N_CONTROLPOINTS
CPOINT_TYPE
USE_3DFILTER
SCAN_BNDRY_TYPE
CREATE_WEIGHTS
F_SIZE
LINE2_ISPLANAR
LINE2_PLANAR_XTOL
LINE2_PLANAR_YTOL
LINE2_PLANAR_XDEV
LINE2_PLANAR_YDEV
LINE3_ISPLANAR
LINE3_PLANAR_XTOL
LINE3_PLANAR_YTOL
LINE3_PLANAR_XDEV
LINE3_PLANAR_YDEV
CHART_SUB_TYPE
OVERWRITE
OUTPUT_FEATURE_NOMS
OUTPUT_FEAT_W_DIMENS
OUTPUT_DMIS_REPORT
TIME_ARG
TRACE_FILTER_ARG
FIT
STATS_DB_TYPE
IOCHANNEL_NUMBER
IOCHANNEL_PULSE_WIDTH
IOCHANNEL_PULSE_INTERVAL
IOCHANNEL_PULSE_DURATION
GRAPH_OPTION
DB_SOURCE_TYPE
FIND_HOLE_PERCENT
AUTO_ONERROR_TYPE
POS_REPT_DISPLAY_OPTION
TRIGGERTOLERANCE
TRIGGERTOLVALUE
FIXTURE_TOL
START_LABEL
ERROR_LABEL
CONE_CONVEX_TYPE
TRIGGERPLANE
QUERY_SHOW_GRAPHIC_SETTINGS
CALC_STYLE_FILE
FILTER_TYPE
TRACE_VALUE_LIMIT
TARGET_DIRECTION
TARGET_EDGE_POLARITY
BSMETHOD_TYPE
CENTER_ROTATION_THEO
CENTER_ROTATION_MEAS
ARTICULATEDARM_TYPE
LEFTYRIGHTY_CONFIG
ABOVEBELOW_CONFIG
NOFLIPFLIP_CONFIG
HIGH_ACCURACY
SURFACE
MAGNIFICATION
MINOR_WORD_TOGGLE
PERCENTAGE
THRESHOLD
N_SIDES
TARGET_SURFACE_ILLUM
MEAN
CAD_COMP
SHOW_ROW
SHOW_COLUMN
TARGET_SURFACE_SENSILIGHT
TARGET_SURFACE_WIDTH
TARGET_SURFACE_HEIGHT
TARGET_SURFACE_RANGE
TARGET_SURFACE_DURATION
TARGET_SURFACE_MODE
TARGET_SURFACE_HIACC
SCREEN_CAPTURE_SCALE
SCREEN_CAPTURE_QUALITY
TARGET_EDGE_SIZE
TARGET_EDGE_ILLUM
TARGET_EDGE_TOL
TARGET_EDGE_STRENGTH
TARGET_EDGE_DENSITY
TARGET_EDGE_TYPE
DISPLAY_ADVANCED_PARAMETERS
TARGET_SURFACE_TYPE
VOID_DETECT
TARG_SX
TARG_SY
TARG_SZ
TARG_EX
TARG_EY
TARG_EZ
PATTERN_TYPE
TARGET_EDGE_ANGLE
PROGRAM_GAGE_FEAT_TYPE
PROGRAM_GAGE_TYPE
TARGET_FOCUS
RMEASFEATIDX
RMEASFEATIDY
RMEASFEATIDZ
FINDNOMS_BESTFIT
FINDNOMS_ONLYSELECTED
TEMPX
TEMPY
TEMPZ
TEMPP
AUTO_PH9
MANUAL_PREPOSITION
SCREEN_CAPTURE_TYPE
SCREEN_CAPTURE_AUTO_TYPE
TARGET_EDGE_EDGESELECT
TARGET_EDGE_EDGENUM
DELETE_TYPE
SCREEN_CAPTURE_AUTO_TIME
USE_HSSDAT
USE_STARTENDDELAY
COP_FILTER
COP_SIZE
COP_TYPE
SURFVEC_MEAS_I
SURFVEC_MEAS_J
SURFVEC_MEAS_K
TARGET_EDGE_UNDERSCAN
PROFILE_TYPE
THEO_FLUSH
MEAS_FLUSH
THEO_GAP
MEAS_GAP
THEO_DEPTH
MEAS_DEPTH
TARGET_BLOB_TYPE
LASER_STRIPE_OVERLAP
LASER_STRIPE_OVERSCAN
LASER_FREQUENCY
TARGET_FILTER_OUTLIER
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD
SLOT_TYPE
TARGET_TYPE
THEO_R
THEO_A
THEO_H
MEAS_R
MEAS_A
MEAS_H
TARG_R
TARG_A
TARG_H
THEO_SR
THEO_SA
THEO_SH
THEO_ER
THEO_EA
THEO_EH
MEAS_SR
MEAS_SA
MEAS_SH
MEAS_ER
MEAS_EA
MEAS_EH
TARG_SR
TARG_SA
TARG_SH
TARG_ER
TARG_EA
TARG_EH
TARGET_EDGE_SENSILIGHT
F_THICKNESS_EDGE
THICKNESS_TYPE_EDGE
LASER_EXPOSURE
LASER_INTENSITY
ANGLE_OFFSET_2
LASER_FILTER_NEIGHBOR_NUM
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD
LASER_FILTER_TOL_ABOVE
LASER_FILTER_TOL_BELOW
LASER_FILTER_TOL_RIGHT
LASER_CLIP_UP_DIST
LASER_CLIP_LOW_DIST
LASER_PIXEL_TOGGLE
LASER_FILTER_TOGGLE
DISPLAY_PROBE_PARAMETERS
THEO_R2
THEO_A2
THEO_H2
MEAS_R2
MEAS_A2
MEAS_H2
LASER_CLIP_LEFT_DIST
LASER_CLIP_RIGHT_DIST
COP_FILETYPE
COP_SELECTIONTYPE
COP_COLORMAP
COP_COPLEMENT
OPERTYPE
COP_BOOLEANTYPE
COP_IMPORTFILETYPE
MEAS_START_ANG
MEAS_END_ANG
ISLAND_DIAM
ISLAND_LENGTH
ISLAND_WIDTH
ISLAND_X
ISLAND_Y
ISLAND_Z
ISLAND_I
ISLAND_J
ISLAND_K
ISLAND_AI
ISLAND_AJ
ISLAND_AK
ISLAND_TYPE
ISLAND_CLEARANCEDIST
RPT_DIMENSION_TABLES
SUMMARY_DEV
DRF_TBLHDR
LINE1_TBLHDR
LINE1_CALLOUT
LINE1_COLUMN_HDR
LINE1_FEATNAME
LINE1_NOMINAL
LINE1_MEAS
LINE1_PLUSTOL
LINE1_MINUSTOL
LINE1_DEV
LINE1_DEVPERCENT
LINE1_ISBILATERAL
LINE1_NUMZONES
LINE2_TBLHDR
LINE2_CALLOUT
LINE2_COLUMN_HDR
LINE2_FEATNAME
LINE2_BONUS
LINE2_TOL
LINE2_DATUMSHFT
LINE2_UNUSEDZONE
LINE2_DEV
LINE2_DEVANG
LINE2_DEVPERCENT
LINE3_TBLHDR
LINE3_CALLOUT
LINE3_COLUMN_HDR
LINE3_FEATNAME
LINE3_BONUS
LINE3_TOL
LINE3_DATUMSHFT
LINE3_UNUSEDZONE
LINE3_DEV
LINE3_DEVANG
LINE3_DEVPERCENT
DRF_COLUMN_HDR
DRF_SEGNAME
DRF_SHIFTX
DRF_SHIFTY
DRF_SHIFTZ
DRF_ROTATIONX
DRF_ROTATIONY
DRF_ROTATIONZ
SUMMARY_COLUMN_HDR
SUMMARY_FEAT
LINE2_AXIS
LINE2_NOMINAL
LINE2_MEAS
SUMMARY_TBLHDR
SUMMARY_AXIS
SUMMARY_NOMINAL
SUMMARY_MEAS
LINE2_PLUSTOL
LINE2_MINUSTOL
LINE2_MAX
LINE2_MIN
LINE2_ISBILATERAL
LINE2_NUMZONES
LINE3_ISBILATERAL
LINE3_NUMZONES
DIM_RPT_COLUMN_HDR
DIM_RPT_ISDATUM
DIM_RPT_DATUM
DIM_RPT_GRAPHIC
DIM_RPT_DEVPERCENT
DIM_RPT_ISBILATERAL
DIM_RPT_NUMZONES
GDT_SYMBOL
COMMENT_INPUT
TARGET_EDGE_WIDTH
TARGET_EDGE_HEIGHT
TARGET_EDGE_EDGEDETECT
TARGET_EDGE_FILTER_CLEAN
TARGET_EDGE_FILTER_CLEAN_STRENGTH
TARGET_EDGE_FILTER_AREA
TARGET_EDGE_FILTER_AREA_SIZE
TARGET_EDGE_GRADIENT
THEO_PERIMETER
MEAS_PERIMETER
THEO_AREA
MEAS_AREA
TARGET_SURFACE_CROSSHAIR_HEIGHT
SHOW_NOMS
COMPOSITE
DATUM2
TP_MODIFIER2
DESCRIPTION2
SHOW_OPTIONS
LEADER_LINE_ID
GDT_SYMBOL2
DATUM1_MODIFIER
DATUM2_MODIFIER
DATUM3_MODIFIER
DATUM1_MODIFIER2
DATUM2_MODIFIER2
DATUM3_MODIFIER2
DIM_RPT_DEVPERCENT_NOM
DIM_RPT_USETWODEVIATIONS
DIM_RPT_DEVPERCENT2
LINE2_DEVPERCENT_NOM
LINE2_USE2DEVIATIONS
LINE2_DEVPERCENT2
LINE3_DEVPERCENT_NOM
LINE3_USE2DEVIATIONS
LINE3_DEVPERCENT2
AXIS_PLUS_TOL
AXIS_MINUS_TOL
AXIS_NOMINAL
AXIS_DESCRIPTION
LINE1_DEVPERCENT_NOM
LINE1_USE2DEVIATIONS
LINE1_DEVPERCENT2
USE_AXIS2
DIM_LENGTH2
TEXTANAL_LABEL_MEAS_X
TEXTANAL_LABEL_MEAS_Y
TEXTANAL_LABEL_MEAS_Z
TEXTANAL_LABEL_MEAS_I
TEXTANAL_LABEL_MEAS_J
TEXTANAL_LABEL_MEAS_K
TEXTANAL_LABEL_DEV
TEXTANAL_LABEL_MINMAX
SIMULT_EVAL
SECTION_INDEX
LINE1_OUTTOL
LINE2_OUTTOL
LINE3_OUTTOL
LINE1_MAX
LINE1_MIN
LINE3_NOMINAL
LINE3_MEAS
LINE3_PLUSTOL
LINE3_MINUSTOL
LINE3_MAX
LINE3_MIN
SUMMARY_OUTTOL
SUMMARY_PLUSTOL
SUMMARY_MINUSTOL
SUMMARY_MAX
SUMMARY_MIN
SUMMARY_BONUS
LINE1_BONUS
GRAPH_ANALYSIS_POINT_SIZE
GRAPH_ANALYSIS_PLUS_TOL
GRAPH_ANALYSIS_MINUS_TOL
DIM_AXIS_ITEM_NUMBER
F_ENDING_DEPTH
DIM_ITEM_NUMBER
FEAT_ITEM_NUMBER
COMMAND_TYPE
DEV_MAX
AUTO_DEV_DIRECTION
PROBE_DIRECTION
USER_DEFINED_THEOS
SCALING
USE_SCALING
UID
REF_UID
BA_SOLUTION_TYPE
BA_SOLUTION_OPTIONS
BA_SOLUTION_STATUS
BA_VARIANCE
BA_RMS
BA_WARNINGS
BA_STATION
BA_STATION_X
BA_STATION_Y
BA_STATION_Z
BA_STATION_ROTX
BA_STATION_ROTY
BA_STATION_ROTZ
BA_STATION_ORIENTED
BA_STATION_LOCKED
BA_FEATURE
BA_FEAT_SOURCE
BA_FEAT_RMS
BA_FEAT_POINTING_ERR
BA_FEAT_APEX_ANGLE
BA_FEAT_X
BA_FEAT_Y
BA_FEAT_Z
BA_FEAT_DEV_X
BA_FEAT_DEV_Y
BA_FEAT_DEV_Z
BA_FEAT_DEV3D
NO_APPROACH_VECTOR_FLIP
TARGET_EDGE_START_VALUE
TARGET_EDGE_END_VALUE
TARGET_SURFACE_SURFACE_VARIANCE
RELATIVE_COMMENTS
AUTO_ROTARY
TARGET_COVERAGE
ROTATION_TYPE_2
PROBE_TYPE
TIME_STAMP
ECOND_TEMP
ECOND_PRESSURE
ECOND_HUMIDITY
HIT_RMS
DISPLAY_TRACKER_PARAMETERS
PTDENSITY_TOGGLE
PTDENSITY_UPPERBOUND
PTDENSITY_DEVLIMIT
PTDENSITY_MAXSPAN
TARGET_MEASURE_AT_FOV_CENTER
TARGET_SURFACE_FIND_SURFACE
PROJECTOR
INLINE_LEGACY_REPORT
SINGLE_POINT_DEVIATION
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a specified field type. In these cases, the TypeIndex must not be greater than the current number of fields of the that type + 1 and TypeIndex must be greater than 1. For fields that allow only a single value, the TypeIndex is 0.

Return Type

Variant value representing the reference feature value of the field in the command.

See Also

ReportData Object


GetReferenceValue2 Method

GetReferenceValue2 Method
refValue
A Long value representing the reference.A long value representing the reference.
DataType
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a specified field type. In these cases, the TypeIndex must not be greater than the current number of fields of the that type + 1 and TypeIndex must be greater than 1. For fields that allow only a single value, the TypeIndex is 0.
FirstArrayIndex
This parameter specifies the index value for an item in the first array.
SecondArrayIndex
This parameter specifies the index value for an item in the second array.

Description

Returns the reference feature value of the indicated field of the specified command. This returns the reference feature value of the indicated field of the command.

Syntax

Visual Basic
Public Function GetReferenceValue2( _
   ByVal refValue As Long, _
   ByVal DataType As ENUM_FIELD_TYPES, _
   ByVal TypeIndex As Long, _
   ByVal FirstArrayIndex As Long, _
   ByVal SecondArrayIndex As Long _
) As Variant

Parameters

refValue
A Long value representing the reference.A long value representing the reference.
DataType
Value Description
ID
REF_ID
LEVEL_REF_ID
ROTATE_REF_ID
ORIGIN_REF_ID
THEO_X
THEO_Y
THEO_Z
THEO_SX
THEO_SY
THEO_SZ
THEO_EX
THEO_EY
THEO_EZ
THEO_I
THEO_J
THEO_K
TARG_X
TARG_Y
TARG_Z
MEAS_X
MEAS_Y
MEAS_Z
MEAS_I
MEAS_J
MEAS_K
MEAS_LENGTH
MEAS_DIAM
MEAS_ANGLE
TARG_I
TARG_J
TARG_K
THEO_DIAM
THEO_WIDTH
THEO_LENGTH
THEO_HEIGHT
THEO_ANGLE
COORD_TYPE
INOUT_TYPE
THICKNESS_TYPE
CIRC_TYPE
SNAP_TYPE
USEPIN_TYPE
MOVE_TYPE
READPOS_TYPE
FINDHOLE_TYPE
RMEAS_TYPE
THEOBF_TYPE
BOUND_TYPE
BF_MATH_TYPE
AUTOFIT_CONSTRAINT
SLOT_MIN_MAX_TYPE
FIND_NOM_AXIS_TYPE
N_INIT_HITS_TYPE
N_PERM_HITS_TYPE
SEARCHMODE_TYPE
MODE_TYPE
MEASURE_ORDER_TYPE
CONE_LENGTH_ANGLE_TYPE
OFFSET_LINE_METHOD
LIN_POL_FILT_TYPE
GEN_FEAT_TYPE
GEN_ALIGN_TYPE
CURVE_TYPE
MEASURED_2D3D_TYPE
THINNING_TOL
HITINT_TYPE
RMEASFEATID
N_HITS
N_ROWS
INIT_HITS
PERM_HITS
F_OFFSET
F_SPACER
F_PITCH
F_THICKNESS
F_DEPTH
F_AUTOMOVE
F_INDENT
F_CORNER_RADIUS
F_INCREMENT
F_TOLERANCE
F_BOXWIDTH
F_BOXLENGTH
F_CIRCRADOUT
F_CIRCRADIN
F_CHECK
F_MAXACCELX
F_MAXACCELY
F_MAXACCELZ
SCAN_ACCELERATION
SCAN_OFFSET_FORCE
MANUAL_FINE_PROBING
F_MOVESPEED
F_TOUCHSPEED
F_SCANSPEED
START_ANG
END_ANG
MIDPOINT_X
MIDPOINT_Y
MIDPOINT_Z
ANGVEC_I
ANGVEC_J
ANGVEC_K
MEASVEC_I
MEASVEC_J
MEASVEC_K
SLOTVEC_I
SLOTVEC_J
SLOTVEC_K
SURFVEC_I
SURFVEC_J
SURFVEC_K
PINVEC_I
PINVEC_J
PINVEC_K
PUNCHVEC_I
PUNCHVEC_J
PUNCHVEC_K
REPORTVEC_I
REPORTVEC_J
REPORTVEC_K
TARGSLOT_I
TARGSLOT_J
TARGSLOT_K
UPDATEVEC_I
UPDATEVEC_J
UPDATEVEC_K
THEO_MINOR_AXIS
TWO_D_THREE_D_TYPE
AXIS
DEST_EXPR
SRC_EXPR
SHOW_IDS
SHOW_DETAILS
WEIGHT
ITEM_USED
USE_AXIS
AVERAGE_ERROR
MEASURE_ALL_FEATURES
REPIERCE_CAD
START_NUM
END_NUM
SKIP_NUM
X_OFFSET
Y_OFFSET
Z_OFFSET
ANGLE_OFFSET
INTERNAL_EXTERNAL
SAVE_ALIGN_CAD_TO_PARTS
FILE_NAME
ALIGN_LIST
WORK_PLANE
DISTANCE
OLD_TIP
NEW_TIP
ROTATION_TYPE
DIM_INFO_ORDER
DIM_INFO_LOC
DIM_INFO_TP_LOC
GRAPH_ANALYSIS
TEXT_ANALYSIS
ARROW_MULTIPLIER
OUTPUT_TYPE
NOMINAL
F_PLUS_TOL
F_MINUS_TOL
TP_MODIFIER
PERP_PARALLEL_TYPE
RADIUS_TYPE
UNIT_TYPE
DIM_LENGTH
PROFILE_FORM_TYPE
PRECISION
MAN_RETRACT
DIM_TEXT
DIM_TEXT_OPTIONS
SHOW_HEADINGS
DEVIATION_SYMBOLS
STANDARD_DEVIATION
DIM_HEADING
GAP_ONLY_TYPE
DISPLAY_ID
DISPLAY_TYPE
POINT_INFO_HEADING
SHOW_POINT_INFO
RET_ONLY_TYPE
COMMENT_FIELD
COMMENT_TYPE
PART_NAME
REVISION_NUMBER
SERIAL_NUMBER
STAT_COUNT
SUB_NAME
READ_WRITE
FILE_POINTER
FIELD_WIDTH
DIGIT_COUNT
LABEL_ID
ERROR_TYPE
ERROR_MODE
DESCRIPTION
INDEX_START
INDEX_END
FILE_COMMAND_TYPE
BUFFER_SIZE_TYPE
FAIL_ON_EXIST
MAX_FORCE
LOW_FORCE
UP_FORCE
TRIGGER_FORCE
PROBE_ACCURACY
POSITIONAL_ACCURACY
NUM_RETURN_DATA
RETURN_SPEED
SCAN_DENSITY
POLAR_VECTOR_COMPENSATION
AUTO_PRINT
ORIGIN
MATERIAL_COEFFICIENT
REF_TEMP
HIGH_THRESHOLD
LOW_THRESHOLD
SENSOR_LIST
FIXTURE_TYPE
MACHINE_TYPE
PROBE_COMP
TIP_I
TIP_J
TIP_K
NORM_RELEARN
FIND_NOMS_TYPE
AUTO_CLEAR_PLANE
SINGLE_POINT
DISPLAY_HITS
CAD_TOLERANCE
OFFSET_TOLERANCE
MIN_INCREMENT
MAX_INCREMENT
MIN_ANGLE
MAX_ANGLE
F_LOCATION
COL132_TYPE
COMMAND_STRING
FLY_MODE_TYPE
STATS_TYPE
STATS_DIR
NEW_STATS_DIR
DATA_READ_LOCK
DATA_WRITE_LOCK
DATA_MEM_PAGES
STAT_NAME_TYPE
STAT_CALC_TYPE
TRANSFER_DIR
DISPLAY_TRACE
TRACE_NAME
TRACE_VALUE
SCAN_CUTPLANEVEC_I
SCAN_CUTPLANEVEC_J
SCAN_CUTPLANEVEC_K
SCAN_INITVEC_I
SCAN_INITVEC_J
SCAN_INITVEC_K
SCAN_AXISVEC_I
SCAN_AXISVEC_J
SCAN_AXISVEC_K
SCAN_ENDVEC_I
SCAN_ENDVEC_J
SCAN_ENDVEC_K
SCAN_INITDIR_I
SCAN_INITDIR_J
SCAN_INITDIR_K
SCAN_CROSS_TOTAL
SCAN_TIME_INCR
SCAN_EDGE_THICK
POS_REPORT_AXIS_X
POS_REPORT_AXIS_Y
POS_REPORT_AXIS_Z
DEV_PERPEN_CENTERLINE
USE_THEO
TARGET_COLOR
THEO_START_ANG
THEO_END_ANG
ONOFF_TYPE
ROW_ID
LOCATOR_BMP
LOCATOR_WAV
DTYPE_LEAPFROGTYPE
DTYPE_LEAPFROGNUMHITS
DTYPE_LEAPFROGFULLPARTIAL
EXCLUSION_ZONE
EXECUTE
AUTOTRIGGERONOFF
AUTOBEEPING
COLUMN_ID
SLOT_NUMBER
AUTOTOLZONE
PROBING_MODE
ANGLE_COMP_TOGGLE
POINTINFO_FILTER_INTERVAL
POINTINFO_FILTER_INTERVAL_NUMBER
FEAT_TYPE
DIM_ID
MEAS_MINOR_AXIS
MEAS_HEIGHT
MEAS_SLOTVEC_I
MEAS_SLOTVEC_J
MEAS_SLOTVEC_K
MEAS_SX
MEAS_SY
MEAS_SZ
MEAS_EX
MEAS_EY
MEAS_EZ
MEAS_WIDTH
NUM_CONTROL_POINTS
U_HITS
V_HITS
NUM_FIT_POINTS
NOMINAL_COLOR
WAVE_FILE
DIM_BONUS
PERUNIT_STEPSIZE
PERUNIT_LENGTH
PERUNIT_WIDTH
DIM_MEASURED
SURFVEC_TARG_I
SURFVEC_TARG_J
SURFVEC_TARG_K
DIM_MAX
EDGEVEC_TARG_I
EDGEVEC_TARG_J
EDGEVEC_TARG_K
DIM_MIN
EDGEVEC_THEO_I
EDGEVEC_THEO_J
EDGEVEC_THEO_K
DIM_DEVIATION
EDGEVEC_MEAS_I
EDGEVEC_MEAS_J
EDGEVEC_MEAS_K
DIM_OUTTOL
T_VALUE
TOOL_X
TOOL_Y
TOOL_Z
TOOL_DIAM
DEV_X
DEV_Y
DEV_Z
DEV_DIAM
ITERATE_COLUMNS
LOAD_TYPE
NUM_ITERATIONS
METHOD_TYPE
SCAN_TECHNIQUE
HIT_TYPE
BOUNDARY_POINT_X
BOUNDARY_POINT_Y
BOUNDARY_POINT_Z
VIDEO_GAIN
VIDEO_OFFSET
VIDEO_LEDLIGHT
VIDEO_LASERLIGHT1
VIDEO_LASERLIGHT2
VIDEO_YORIGIN
VIDEO_YEND
VIDEO_LSEG
VIDEO_XSEG
VIDEO_YSEG
ANGULARITY_NOM_ANGLE
PRINT_TO_FILE
PRINT_TO_PRINTER
PRINT_DRAFTMODE
PRINT_DELETE_RUNS
POINTINFO_FILTER_WORST
POINTINFO_FILTER_WORST_NUMBER
POINTINFO_FILTER_DEVIATION
POINTINFO_FILTER_DEVIATION_NUMBER
POINTINFO_FILTER_OUTTOL
REPORT_SURFVEC_I
REPORT_SURFVEC_J
REPORT_SURFVEC_K
DB_QUERY_OP
DB_SOURCE_NAME
CHART_TYPE
DB_CHART_NAME
DEVIATION_ANGLE
STATS_DATASOURCE
IGNOREMOTIONERRORS_TYPE
THEO_X2
THEO_Y2
THEO_Z2
MEAS_X2
MEAS_Y2
MEAS_Z2
PPROG
TRACE_FILTER
TIME_FILTER
SHOW_SPC_CALCS
SPEC_LIMITS
ZONES
STDDEV
UCL_LCL
HISTOGRAM
GRID
ADDITIONAL_CHART
LINE2_PLANAR_OPEN_IN_X
LINE3_PLANAR_OPEN_IN_X
REGR
CENTER_POINT
SHOW_MORE_SPC_CALCS
SPEC_OFFSET
SOLID
U_L_BOUNDS
TITLE
CPOINT_X
CPOINT_Y
CPOINT_Z
CPOINT_I
CPOINT_J
CPOINT_K
CPOINT_DIAM
CPOINT_SCAN_CROSS_TOTAL
CPOINT_SCAN_DENSITY
CPOINT_F_SCANSPEED
N_CONTROLPOINTS
CPOINT_TYPE
USE_3DFILTER
SCAN_BNDRY_TYPE
CREATE_WEIGHTS
F_SIZE
LINE2_ISPLANAR
LINE2_PLANAR_XTOL
LINE2_PLANAR_YTOL
LINE2_PLANAR_XDEV
LINE2_PLANAR_YDEV
LINE3_ISPLANAR
LINE3_PLANAR_XTOL
LINE3_PLANAR_YTOL
LINE3_PLANAR_XDEV
LINE3_PLANAR_YDEV
CHART_SUB_TYPE
OVERWRITE
OUTPUT_FEATURE_NOMS
OUTPUT_FEAT_W_DIMENS
OUTPUT_DMIS_REPORT
TIME_ARG
TRACE_FILTER_ARG
FIT
STATS_DB_TYPE
IOCHANNEL_NUMBER
IOCHANNEL_PULSE_WIDTH
IOCHANNEL_PULSE_INTERVAL
IOCHANNEL_PULSE_DURATION
GRAPH_OPTION
DB_SOURCE_TYPE
FIND_HOLE_PERCENT
AUTO_ONERROR_TYPE
POS_REPT_DISPLAY_OPTION
TRIGGERTOLERANCE
TRIGGERTOLVALUE
FIXTURE_TOL
START_LABEL
ERROR_LABEL
CONE_CONVEX_TYPE
TRIGGERPLANE
QUERY_SHOW_GRAPHIC_SETTINGS
CALC_STYLE_FILE
FILTER_TYPE
TRACE_VALUE_LIMIT
TARGET_DIRECTION
TARGET_EDGE_POLARITY
BSMETHOD_TYPE
CENTER_ROTATION_THEO
CENTER_ROTATION_MEAS
ARTICULATEDARM_TYPE
LEFTYRIGHTY_CONFIG
ABOVEBELOW_CONFIG
NOFLIPFLIP_CONFIG
HIGH_ACCURACY
SURFACE
MAGNIFICATION
MINOR_WORD_TOGGLE
PERCENTAGE
THRESHOLD
N_SIDES
TARGET_SURFACE_ILLUM
MEAN
CAD_COMP
SHOW_ROW
SHOW_COLUMN
TARGET_SURFACE_SENSILIGHT
TARGET_SURFACE_WIDTH
TARGET_SURFACE_HEIGHT
TARGET_SURFACE_RANGE
TARGET_SURFACE_DURATION
TARGET_SURFACE_MODE
TARGET_SURFACE_HIACC
SCREEN_CAPTURE_SCALE
SCREEN_CAPTURE_QUALITY
TARGET_EDGE_SIZE
TARGET_EDGE_ILLUM
TARGET_EDGE_TOL
TARGET_EDGE_STRENGTH
TARGET_EDGE_DENSITY
TARGET_EDGE_TYPE
DISPLAY_ADVANCED_PARAMETERS
TARGET_SURFACE_TYPE
VOID_DETECT
TARG_SX
TARG_SY
TARG_SZ
TARG_EX
TARG_EY
TARG_EZ
PATTERN_TYPE
TARGET_EDGE_ANGLE
PROGRAM_GAGE_FEAT_TYPE
PROGRAM_GAGE_TYPE
TARGET_FOCUS
RMEASFEATIDX
RMEASFEATIDY
RMEASFEATIDZ
FINDNOMS_BESTFIT
FINDNOMS_ONLYSELECTED
TEMPX
TEMPY
TEMPZ
TEMPP
AUTO_PH9
MANUAL_PREPOSITION
SCREEN_CAPTURE_TYPE
SCREEN_CAPTURE_AUTO_TYPE
TARGET_EDGE_EDGESELECT
TARGET_EDGE_EDGENUM
DELETE_TYPE
SCREEN_CAPTURE_AUTO_TIME
USE_HSSDAT
USE_STARTENDDELAY
COP_FILTER
COP_SIZE
COP_TYPE
SURFVEC_MEAS_I
SURFVEC_MEAS_J
SURFVEC_MEAS_K
TARGET_EDGE_UNDERSCAN
PROFILE_TYPE
THEO_FLUSH
MEAS_FLUSH
THEO_GAP
MEAS_GAP
THEO_DEPTH
MEAS_DEPTH
TARGET_BLOB_TYPE
LASER_STRIPE_OVERLAP
LASER_STRIPE_OVERSCAN
LASER_FREQUENCY
TARGET_FILTER_OUTLIER
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD
SLOT_TYPE
TARGET_TYPE
THEO_R
THEO_A
THEO_H
MEAS_R
MEAS_A
MEAS_H
TARG_R
TARG_A
TARG_H
THEO_SR
THEO_SA
THEO_SH
THEO_ER
THEO_EA
THEO_EH
MEAS_SR
MEAS_SA
MEAS_SH
MEAS_ER
MEAS_EA
MEAS_EH
TARG_SR
TARG_SA
TARG_SH
TARG_ER
TARG_EA
TARG_EH
TARGET_EDGE_SENSILIGHT
F_THICKNESS_EDGE
THICKNESS_TYPE_EDGE
LASER_EXPOSURE
LASER_INTENSITY
ANGLE_OFFSET_2
LASER_FILTER_NEIGHBOR_NUM
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD
LASER_FILTER_TOL_ABOVE
LASER_FILTER_TOL_BELOW
LASER_FILTER_TOL_RIGHT
LASER_CLIP_UP_DIST
LASER_CLIP_LOW_DIST
LASER_PIXEL_TOGGLE
LASER_FILTER_TOGGLE
DISPLAY_PROBE_PARAMETERS
THEO_R2
THEO_A2
THEO_H2
MEAS_R2
MEAS_A2
MEAS_H2
LASER_CLIP_LEFT_DIST
LASER_CLIP_RIGHT_DIST
COP_FILETYPE
COP_SELECTIONTYPE
COP_COLORMAP
COP_COPLEMENT
OPERTYPE
COP_BOOLEANTYPE
COP_IMPORTFILETYPE
MEAS_START_ANG
MEAS_END_ANG
ISLAND_DIAM
ISLAND_LENGTH
ISLAND_WIDTH
ISLAND_X
ISLAND_Y
ISLAND_Z
ISLAND_I
ISLAND_J
ISLAND_K
ISLAND_AI
ISLAND_AJ
ISLAND_AK
ISLAND_TYPE
ISLAND_CLEARANCEDIST
RPT_DIMENSION_TABLES
SUMMARY_DEV
DRF_TBLHDR
LINE1_TBLHDR
LINE1_CALLOUT
LINE1_COLUMN_HDR
LINE1_FEATNAME
LINE1_NOMINAL
LINE1_MEAS
LINE1_PLUSTOL
LINE1_MINUSTOL
LINE1_DEV
LINE1_DEVPERCENT
LINE1_ISBILATERAL
LINE1_NUMZONES
LINE2_TBLHDR
LINE2_CALLOUT
LINE2_COLUMN_HDR
LINE2_FEATNAME
LINE2_BONUS
LINE2_TOL
LINE2_DATUMSHFT
LINE2_UNUSEDZONE
LINE2_DEV
LINE2_DEVANG
LINE2_DEVPERCENT
LINE3_TBLHDR
LINE3_CALLOUT
LINE3_COLUMN_HDR
LINE3_FEATNAME
LINE3_BONUS
LINE3_TOL
LINE3_DATUMSHFT
LINE3_UNUSEDZONE
LINE3_DEV
LINE3_DEVANG
LINE3_DEVPERCENT
DRF_COLUMN_HDR
DRF_SEGNAME
DRF_SHIFTX
DRF_SHIFTY
DRF_SHIFTZ
DRF_ROTATIONX
DRF_ROTATIONY
DRF_ROTATIONZ
SUMMARY_COLUMN_HDR
SUMMARY_FEAT
LINE2_AXIS
LINE2_NOMINAL
LINE2_MEAS
SUMMARY_TBLHDR
SUMMARY_AXIS
SUMMARY_NOMINAL
SUMMARY_MEAS
LINE2_PLUSTOL
LINE2_MINUSTOL
LINE2_MAX
LINE2_MIN
LINE2_ISBILATERAL
LINE2_NUMZONES
LINE3_ISBILATERAL
LINE3_NUMZONES
DIM_RPT_COLUMN_HDR
DIM_RPT_ISDATUM
DIM_RPT_DATUM
DIM_RPT_GRAPHIC
DIM_RPT_DEVPERCENT
DIM_RPT_ISBILATERAL
DIM_RPT_NUMZONES
GDT_SYMBOL
COMMENT_INPUT
TARGET_EDGE_WIDTH
TARGET_EDGE_HEIGHT
TARGET_EDGE_EDGEDETECT
TARGET_EDGE_FILTER_CLEAN
TARGET_EDGE_FILTER_CLEAN_STRENGTH
TARGET_EDGE_FILTER_AREA
TARGET_EDGE_FILTER_AREA_SIZE
TARGET_EDGE_GRADIENT
THEO_PERIMETER
MEAS_PERIMETER
THEO_AREA
MEAS_AREA
TARGET_SURFACE_CROSSHAIR_HEIGHT
SHOW_NOMS
COMPOSITE
DATUM2
TP_MODIFIER2
DESCRIPTION2
SHOW_OPTIONS
LEADER_LINE_ID
GDT_SYMBOL2
DATUM1_MODIFIER
DATUM2_MODIFIER
DATUM3_MODIFIER
DATUM1_MODIFIER2
DATUM2_MODIFIER2
DATUM3_MODIFIER2
DIM_RPT_DEVPERCENT_NOM
DIM_RPT_USETWODEVIATIONS
DIM_RPT_DEVPERCENT2
LINE2_DEVPERCENT_NOM
LINE2_USE2DEVIATIONS
LINE2_DEVPERCENT2
LINE3_DEVPERCENT_NOM
LINE3_USE2DEVIATIONS
LINE3_DEVPERCENT2
AXIS_PLUS_TOL
AXIS_MINUS_TOL
AXIS_NOMINAL
AXIS_DESCRIPTION
LINE1_DEVPERCENT_NOM
LINE1_USE2DEVIATIONS
LINE1_DEVPERCENT2
USE_AXIS2
DIM_LENGTH2
TEXTANAL_LABEL_MEAS_X
TEXTANAL_LABEL_MEAS_Y
TEXTANAL_LABEL_MEAS_Z
TEXTANAL_LABEL_MEAS_I
TEXTANAL_LABEL_MEAS_J
TEXTANAL_LABEL_MEAS_K
TEXTANAL_LABEL_DEV
TEXTANAL_LABEL_MINMAX
SIMULT_EVAL
SECTION_INDEX
LINE1_OUTTOL
LINE2_OUTTOL
LINE3_OUTTOL
LINE1_MAX
LINE1_MIN
LINE3_NOMINAL
LINE3_MEAS
LINE3_PLUSTOL
LINE3_MINUSTOL
LINE3_MAX
LINE3_MIN
SUMMARY_OUTTOL
SUMMARY_PLUSTOL
SUMMARY_MINUSTOL
SUMMARY_MAX
SUMMARY_MIN
SUMMARY_BONUS
LINE1_BONUS
GRAPH_ANALYSIS_POINT_SIZE
GRAPH_ANALYSIS_PLUS_TOL
GRAPH_ANALYSIS_MINUS_TOL
DIM_AXIS_ITEM_NUMBER
F_ENDING_DEPTH
DIM_ITEM_NUMBER
FEAT_ITEM_NUMBER
COMMAND_TYPE
DEV_MAX
AUTO_DEV_DIRECTION
PROBE_DIRECTION
USER_DEFINED_THEOS
SCALING
USE_SCALING
UID
REF_UID
BA_SOLUTION_TYPE
BA_SOLUTION_OPTIONS
BA_SOLUTION_STATUS
BA_VARIANCE
BA_RMS
BA_WARNINGS
BA_STATION
BA_STATION_X
BA_STATION_Y
BA_STATION_Z
BA_STATION_ROTX
BA_STATION_ROTY
BA_STATION_ROTZ
BA_STATION_ORIENTED
BA_STATION_LOCKED
BA_FEATURE
BA_FEAT_SOURCE
BA_FEAT_RMS
BA_FEAT_POINTING_ERR
BA_FEAT_APEX_ANGLE
BA_FEAT_X
BA_FEAT_Y
BA_FEAT_Z
BA_FEAT_DEV_X
BA_FEAT_DEV_Y
BA_FEAT_DEV_Z
BA_FEAT_DEV3D
NO_APPROACH_VECTOR_FLIP
TARGET_EDGE_START_VALUE
TARGET_EDGE_END_VALUE
TARGET_SURFACE_SURFACE_VARIANCE
RELATIVE_COMMENTS
AUTO_ROTARY
TARGET_COVERAGE
ROTATION_TYPE_2
PROBE_TYPE
TIME_STAMP
ECOND_TEMP
ECOND_PRESSURE
ECOND_HUMIDITY
HIT_RMS
DISPLAY_TRACKER_PARAMETERS
PTDENSITY_TOGGLE
PTDENSITY_UPPERBOUND
PTDENSITY_DEVLIMIT
PTDENSITY_MAXSPAN
TARGET_MEASURE_AT_FOV_CENTER
TARGET_SURFACE_FIND_SURFACE
PROJECTOR
INLINE_LEGACY_REPORT
SINGLE_POINT_DEVIATION
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a specified field type. In these cases, the TypeIndex must not be greater than the current number of fields of the that type + 1 and TypeIndex must be greater than 1. For fields that allow only a single value, the TypeIndex is 0.
FirstArrayIndex
This parameter specifies the index value for an item in the first array.
SecondArrayIndex
This parameter specifies the index value for an item in the second array.

Return Type

Variant value representing the reference feature value of the field in the command.

See Also

ReportData Object


GetTolColor Method

GetTolColor Method
Deviation
Double value representing the deviation.
plustol
Double value representing the plus tolerance.
minustol
Double value representing the minus tolerance.

Description

Returns the current tolerance color based on deviation, plus tolerance, and minus tolerance This returns a the current tolerance color based on the deviation, plus tolerance, and minus tolerance.

Syntax

Visual Basic
Public Function GetTolColor( _
   ByVal Deviation As Double, _
   ByVal plustol As Double, _
   ByVal minustol As Double _
) As Long

Parameters

Deviation
Double value representing the deviation.
plustol
Double value representing the plus tolerance.
minustol
Double value representing the minus tolerance.

See Also

ReportData Object


GetValue Method

GetValue Method
DataType
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a specified field type. In these cases, the TypeIndex must not be greater than the current number of fields of the that type + 1 and TypeIndex must be greater than 1. For fields that allow only a single value, the TypeIndex is 0.

Description

Returns the value of the indicated field of the command. This method returns the value of the indicated field of the command.

Syntax

Visual Basic
Public Function GetValue( _
   ByVal DataType As ENUM_FIELD_TYPES, _
   ByVal TypeIndex As Long _
) As Variant

Parameters

DataType
Value Description
ID
REF_ID
LEVEL_REF_ID
ROTATE_REF_ID
ORIGIN_REF_ID
THEO_X
THEO_Y
THEO_Z
THEO_SX
THEO_SY
THEO_SZ
THEO_EX
THEO_EY
THEO_EZ
THEO_I
THEO_J
THEO_K
TARG_X
TARG_Y
TARG_Z
MEAS_X
MEAS_Y
MEAS_Z
MEAS_I
MEAS_J
MEAS_K
MEAS_LENGTH
MEAS_DIAM
MEAS_ANGLE
TARG_I
TARG_J
TARG_K
THEO_DIAM
THEO_WIDTH
THEO_LENGTH
THEO_HEIGHT
THEO_ANGLE
COORD_TYPE
INOUT_TYPE
THICKNESS_TYPE
CIRC_TYPE
SNAP_TYPE
USEPIN_TYPE
MOVE_TYPE
READPOS_TYPE
FINDHOLE_TYPE
RMEAS_TYPE
THEOBF_TYPE
BOUND_TYPE
BF_MATH_TYPE
AUTOFIT_CONSTRAINT
SLOT_MIN_MAX_TYPE
FIND_NOM_AXIS_TYPE
N_INIT_HITS_TYPE
N_PERM_HITS_TYPE
SEARCHMODE_TYPE
MODE_TYPE
MEASURE_ORDER_TYPE
CONE_LENGTH_ANGLE_TYPE
OFFSET_LINE_METHOD
LIN_POL_FILT_TYPE
GEN_FEAT_TYPE
GEN_ALIGN_TYPE
CURVE_TYPE
MEASURED_2D3D_TYPE
THINNING_TOL
HITINT_TYPE
RMEASFEATID
N_HITS
N_ROWS
INIT_HITS
PERM_HITS
F_OFFSET
F_SPACER
F_PITCH
F_THICKNESS
F_DEPTH
F_AUTOMOVE
F_INDENT
F_CORNER_RADIUS
F_INCREMENT
F_TOLERANCE
F_BOXWIDTH
F_BOXLENGTH
F_CIRCRADOUT
F_CIRCRADIN
F_CHECK
F_MAXACCELX
F_MAXACCELY
F_MAXACCELZ
SCAN_ACCELERATION
SCAN_OFFSET_FORCE
MANUAL_FINE_PROBING
F_MOVESPEED
F_TOUCHSPEED
F_SCANSPEED
START_ANG
END_ANG
MIDPOINT_X
MIDPOINT_Y
MIDPOINT_Z
ANGVEC_I
ANGVEC_J
ANGVEC_K
MEASVEC_I
MEASVEC_J
MEASVEC_K
SLOTVEC_I
SLOTVEC_J
SLOTVEC_K
SURFVEC_I
SURFVEC_J
SURFVEC_K
PINVEC_I
PINVEC_J
PINVEC_K
PUNCHVEC_I
PUNCHVEC_J
PUNCHVEC_K
REPORTVEC_I
REPORTVEC_J
REPORTVEC_K
TARGSLOT_I
TARGSLOT_J
TARGSLOT_K
UPDATEVEC_I
UPDATEVEC_J
UPDATEVEC_K
THEO_MINOR_AXIS
TWO_D_THREE_D_TYPE
AXIS
DEST_EXPR
SRC_EXPR
SHOW_IDS
SHOW_DETAILS
WEIGHT
ITEM_USED
USE_AXIS
AVERAGE_ERROR
MEASURE_ALL_FEATURES
REPIERCE_CAD
START_NUM
END_NUM
SKIP_NUM
X_OFFSET
Y_OFFSET
Z_OFFSET
ANGLE_OFFSET
INTERNAL_EXTERNAL
SAVE_ALIGN_CAD_TO_PARTS
FILE_NAME
ALIGN_LIST
WORK_PLANE
DISTANCE
OLD_TIP
NEW_TIP
ROTATION_TYPE
DIM_INFO_ORDER
DIM_INFO_LOC
DIM_INFO_TP_LOC
GRAPH_ANALYSIS
TEXT_ANALYSIS
ARROW_MULTIPLIER
OUTPUT_TYPE
NOMINAL
F_PLUS_TOL
F_MINUS_TOL
TP_MODIFIER
PERP_PARALLEL_TYPE
RADIUS_TYPE
UNIT_TYPE
DIM_LENGTH
PROFILE_FORM_TYPE
PRECISION
MAN_RETRACT
DIM_TEXT
DIM_TEXT_OPTIONS
SHOW_HEADINGS
DEVIATION_SYMBOLS
STANDARD_DEVIATION
DIM_HEADING
GAP_ONLY_TYPE
DISPLAY_ID
DISPLAY_TYPE
POINT_INFO_HEADING
SHOW_POINT_INFO
RET_ONLY_TYPE
COMMENT_FIELD
COMMENT_TYPE
PART_NAME
REVISION_NUMBER
SERIAL_NUMBER
STAT_COUNT
SUB_NAME
READ_WRITE
FILE_POINTER
FIELD_WIDTH
DIGIT_COUNT
LABEL_ID
ERROR_TYPE
ERROR_MODE
DESCRIPTION
INDEX_START
INDEX_END
FILE_COMMAND_TYPE
BUFFER_SIZE_TYPE
FAIL_ON_EXIST
MAX_FORCE
LOW_FORCE
UP_FORCE
TRIGGER_FORCE
PROBE_ACCURACY
POSITIONAL_ACCURACY
NUM_RETURN_DATA
RETURN_SPEED
SCAN_DENSITY
POLAR_VECTOR_COMPENSATION
AUTO_PRINT
ORIGIN
MATERIAL_COEFFICIENT
REF_TEMP
HIGH_THRESHOLD
LOW_THRESHOLD
SENSOR_LIST
FIXTURE_TYPE
MACHINE_TYPE
PROBE_COMP
TIP_I
TIP_J
TIP_K
NORM_RELEARN
FIND_NOMS_TYPE
AUTO_CLEAR_PLANE
SINGLE_POINT
DISPLAY_HITS
CAD_TOLERANCE
OFFSET_TOLERANCE
MIN_INCREMENT
MAX_INCREMENT
MIN_ANGLE
MAX_ANGLE
F_LOCATION
COL132_TYPE
COMMAND_STRING
FLY_MODE_TYPE
STATS_TYPE
STATS_DIR
NEW_STATS_DIR
DATA_READ_LOCK
DATA_WRITE_LOCK
DATA_MEM_PAGES
STAT_NAME_TYPE
STAT_CALC_TYPE
TRANSFER_DIR
DISPLAY_TRACE
TRACE_NAME
TRACE_VALUE
SCAN_CUTPLANEVEC_I
SCAN_CUTPLANEVEC_J
SCAN_CUTPLANEVEC_K
SCAN_INITVEC_I
SCAN_INITVEC_J
SCAN_INITVEC_K
SCAN_AXISVEC_I
SCAN_AXISVEC_J
SCAN_AXISVEC_K
SCAN_ENDVEC_I
SCAN_ENDVEC_J
SCAN_ENDVEC_K
SCAN_INITDIR_I
SCAN_INITDIR_J
SCAN_INITDIR_K
SCAN_CROSS_TOTAL
SCAN_TIME_INCR
SCAN_EDGE_THICK
POS_REPORT_AXIS_X
POS_REPORT_AXIS_Y
POS_REPORT_AXIS_Z
DEV_PERPEN_CENTERLINE
USE_THEO
TARGET_COLOR
THEO_START_ANG
THEO_END_ANG
ONOFF_TYPE
ROW_ID
LOCATOR_BMP
LOCATOR_WAV
DTYPE_LEAPFROGTYPE
DTYPE_LEAPFROGNUMHITS
DTYPE_LEAPFROGFULLPARTIAL
EXCLUSION_ZONE
EXECUTE
AUTOTRIGGERONOFF
AUTOBEEPING
COLUMN_ID
SLOT_NUMBER
AUTOTOLZONE
PROBING_MODE
ANGLE_COMP_TOGGLE
POINTINFO_FILTER_INTERVAL
POINTINFO_FILTER_INTERVAL_NUMBER
FEAT_TYPE
DIM_ID
MEAS_MINOR_AXIS
MEAS_HEIGHT
MEAS_SLOTVEC_I
MEAS_SLOTVEC_J
MEAS_SLOTVEC_K
MEAS_SX
MEAS_SY
MEAS_SZ
MEAS_EX
MEAS_EY
MEAS_EZ
MEAS_WIDTH
NUM_CONTROL_POINTS
U_HITS
V_HITS
NUM_FIT_POINTS
NOMINAL_COLOR
WAVE_FILE
DIM_BONUS
PERUNIT_STEPSIZE
PERUNIT_LENGTH
PERUNIT_WIDTH
DIM_MEASURED
SURFVEC_TARG_I
SURFVEC_TARG_J
SURFVEC_TARG_K
DIM_MAX
EDGEVEC_TARG_I
EDGEVEC_TARG_J
EDGEVEC_TARG_K
DIM_MIN
EDGEVEC_THEO_I
EDGEVEC_THEO_J
EDGEVEC_THEO_K
DIM_DEVIATION
EDGEVEC_MEAS_I
EDGEVEC_MEAS_J
EDGEVEC_MEAS_K
DIM_OUTTOL
T_VALUE
TOOL_X
TOOL_Y
TOOL_Z
TOOL_DIAM
DEV_X
DEV_Y
DEV_Z
DEV_DIAM
ITERATE_COLUMNS
LOAD_TYPE
NUM_ITERATIONS
METHOD_TYPE
SCAN_TECHNIQUE
HIT_TYPE
BOUNDARY_POINT_X
BOUNDARY_POINT_Y
BOUNDARY_POINT_Z
VIDEO_GAIN
VIDEO_OFFSET
VIDEO_LEDLIGHT
VIDEO_LASERLIGHT1
VIDEO_LASERLIGHT2
VIDEO_YORIGIN
VIDEO_YEND
VIDEO_LSEG
VIDEO_XSEG
VIDEO_YSEG
ANGULARITY_NOM_ANGLE
PRINT_TO_FILE
PRINT_TO_PRINTER
PRINT_DRAFTMODE
PRINT_DELETE_RUNS
POINTINFO_FILTER_WORST
POINTINFO_FILTER_WORST_NUMBER
POINTINFO_FILTER_DEVIATION
POINTINFO_FILTER_DEVIATION_NUMBER
POINTINFO_FILTER_OUTTOL
REPORT_SURFVEC_I
REPORT_SURFVEC_J
REPORT_SURFVEC_K
DB_QUERY_OP
DB_SOURCE_NAME
CHART_TYPE
DB_CHART_NAME
DEVIATION_ANGLE
STATS_DATASOURCE
IGNOREMOTIONERRORS_TYPE
THEO_X2
THEO_Y2
THEO_Z2
MEAS_X2
MEAS_Y2
MEAS_Z2
PPROG
TRACE_FILTER
TIME_FILTER
SHOW_SPC_CALCS
SPEC_LIMITS
ZONES
STDDEV
UCL_LCL
HISTOGRAM
GRID
ADDITIONAL_CHART
LINE2_PLANAR_OPEN_IN_X
LINE3_PLANAR_OPEN_IN_X
REGR
CENTER_POINT
SHOW_MORE_SPC_CALCS
SPEC_OFFSET
SOLID
U_L_BOUNDS
TITLE
CPOINT_X
CPOINT_Y
CPOINT_Z
CPOINT_I
CPOINT_J
CPOINT_K
CPOINT_DIAM
CPOINT_SCAN_CROSS_TOTAL
CPOINT_SCAN_DENSITY
CPOINT_F_SCANSPEED
N_CONTROLPOINTS
CPOINT_TYPE
USE_3DFILTER
SCAN_BNDRY_TYPE
CREATE_WEIGHTS
F_SIZE
LINE2_ISPLANAR
LINE2_PLANAR_XTOL
LINE2_PLANAR_YTOL
LINE2_PLANAR_XDEV
LINE2_PLANAR_YDEV
LINE3_ISPLANAR
LINE3_PLANAR_XTOL
LINE3_PLANAR_YTOL
LINE3_PLANAR_XDEV
LINE3_PLANAR_YDEV
CHART_SUB_TYPE
OVERWRITE
OUTPUT_FEATURE_NOMS
OUTPUT_FEAT_W_DIMENS
OUTPUT_DMIS_REPORT
TIME_ARG
TRACE_FILTER_ARG
FIT
STATS_DB_TYPE
IOCHANNEL_NUMBER
IOCHANNEL_PULSE_WIDTH
IOCHANNEL_PULSE_INTERVAL
IOCHANNEL_PULSE_DURATION
GRAPH_OPTION
DB_SOURCE_TYPE
FIND_HOLE_PERCENT
AUTO_ONERROR_TYPE
POS_REPT_DISPLAY_OPTION
TRIGGERTOLERANCE
TRIGGERTOLVALUE
FIXTURE_TOL
START_LABEL
ERROR_LABEL
CONE_CONVEX_TYPE
TRIGGERPLANE
QUERY_SHOW_GRAPHIC_SETTINGS
CALC_STYLE_FILE
FILTER_TYPE
TRACE_VALUE_LIMIT
TARGET_DIRECTION
TARGET_EDGE_POLARITY
BSMETHOD_TYPE
CENTER_ROTATION_THEO
CENTER_ROTATION_MEAS
ARTICULATEDARM_TYPE
LEFTYRIGHTY_CONFIG
ABOVEBELOW_CONFIG
NOFLIPFLIP_CONFIG
HIGH_ACCURACY
SURFACE
MAGNIFICATION
MINOR_WORD_TOGGLE
PERCENTAGE
THRESHOLD
N_SIDES
TARGET_SURFACE_ILLUM
MEAN
CAD_COMP
SHOW_ROW
SHOW_COLUMN
TARGET_SURFACE_SENSILIGHT
TARGET_SURFACE_WIDTH
TARGET_SURFACE_HEIGHT
TARGET_SURFACE_RANGE
TARGET_SURFACE_DURATION
TARGET_SURFACE_MODE
TARGET_SURFACE_HIACC
SCREEN_CAPTURE_SCALE
SCREEN_CAPTURE_QUALITY
TARGET_EDGE_SIZE
TARGET_EDGE_ILLUM
TARGET_EDGE_TOL
TARGET_EDGE_STRENGTH
TARGET_EDGE_DENSITY
TARGET_EDGE_TYPE
DISPLAY_ADVANCED_PARAMETERS
TARGET_SURFACE_TYPE
VOID_DETECT
TARG_SX
TARG_SY
TARG_SZ
TARG_EX
TARG_EY
TARG_EZ
PATTERN_TYPE
TARGET_EDGE_ANGLE
PROGRAM_GAGE_FEAT_TYPE
PROGRAM_GAGE_TYPE
TARGET_FOCUS
RMEASFEATIDX
RMEASFEATIDY
RMEASFEATIDZ
FINDNOMS_BESTFIT
FINDNOMS_ONLYSELECTED
TEMPX
TEMPY
TEMPZ
TEMPP
AUTO_PH9
MANUAL_PREPOSITION
SCREEN_CAPTURE_TYPE
SCREEN_CAPTURE_AUTO_TYPE
TARGET_EDGE_EDGESELECT
TARGET_EDGE_EDGENUM
DELETE_TYPE
SCREEN_CAPTURE_AUTO_TIME
USE_HSSDAT
USE_STARTENDDELAY
COP_FILTER
COP_SIZE
COP_TYPE
SURFVEC_MEAS_I
SURFVEC_MEAS_J
SURFVEC_MEAS_K
TARGET_EDGE_UNDERSCAN
PROFILE_TYPE
THEO_FLUSH
MEAS_FLUSH
THEO_GAP
MEAS_GAP
THEO_DEPTH
MEAS_DEPTH
TARGET_BLOB_TYPE
LASER_STRIPE_OVERLAP
LASER_STRIPE_OVERSCAN
LASER_FREQUENCY
TARGET_FILTER_OUTLIER
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD
SLOT_TYPE
TARGET_TYPE
THEO_R
THEO_A
THEO_H
MEAS_R
MEAS_A
MEAS_H
TARG_R
TARG_A
TARG_H
THEO_SR
THEO_SA
THEO_SH
THEO_ER
THEO_EA
THEO_EH
MEAS_SR
MEAS_SA
MEAS_SH
MEAS_ER
MEAS_EA
MEAS_EH
TARG_SR
TARG_SA
TARG_SH
TARG_ER
TARG_EA
TARG_EH
TARGET_EDGE_SENSILIGHT
F_THICKNESS_EDGE
THICKNESS_TYPE_EDGE
LASER_EXPOSURE
LASER_INTENSITY
ANGLE_OFFSET_2
LASER_FILTER_NEIGHBOR_NUM
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD
LASER_FILTER_TOL_ABOVE
LASER_FILTER_TOL_BELOW
LASER_FILTER_TOL_RIGHT
LASER_CLIP_UP_DIST
LASER_CLIP_LOW_DIST
LASER_PIXEL_TOGGLE
LASER_FILTER_TOGGLE
DISPLAY_PROBE_PARAMETERS
THEO_R2
THEO_A2
THEO_H2
MEAS_R2
MEAS_A2
MEAS_H2
LASER_CLIP_LEFT_DIST
LASER_CLIP_RIGHT_DIST
COP_FILETYPE
COP_SELECTIONTYPE
COP_COLORMAP
COP_COPLEMENT
OPERTYPE
COP_BOOLEANTYPE
COP_IMPORTFILETYPE
MEAS_START_ANG
MEAS_END_ANG
ISLAND_DIAM
ISLAND_LENGTH
ISLAND_WIDTH
ISLAND_X
ISLAND_Y
ISLAND_Z
ISLAND_I
ISLAND_J
ISLAND_K
ISLAND_AI
ISLAND_AJ
ISLAND_AK
ISLAND_TYPE
ISLAND_CLEARANCEDIST
RPT_DIMENSION_TABLES
SUMMARY_DEV
DRF_TBLHDR
LINE1_TBLHDR
LINE1_CALLOUT
LINE1_COLUMN_HDR
LINE1_FEATNAME
LINE1_NOMINAL
LINE1_MEAS
LINE1_PLUSTOL
LINE1_MINUSTOL
LINE1_DEV
LINE1_DEVPERCENT
LINE1_ISBILATERAL
LINE1_NUMZONES
LINE2_TBLHDR
LINE2_CALLOUT
LINE2_COLUMN_HDR
LINE2_FEATNAME
LINE2_BONUS
LINE2_TOL
LINE2_DATUMSHFT
LINE2_UNUSEDZONE
LINE2_DEV
LINE2_DEVANG
LINE2_DEVPERCENT
LINE3_TBLHDR
LINE3_CALLOUT
LINE3_COLUMN_HDR
LINE3_FEATNAME
LINE3_BONUS
LINE3_TOL
LINE3_DATUMSHFT
LINE3_UNUSEDZONE
LINE3_DEV
LINE3_DEVANG
LINE3_DEVPERCENT
DRF_COLUMN_HDR
DRF_SEGNAME
DRF_SHIFTX
DRF_SHIFTY
DRF_SHIFTZ
DRF_ROTATIONX
DRF_ROTATIONY
DRF_ROTATIONZ
SUMMARY_COLUMN_HDR
SUMMARY_FEAT
LINE2_AXIS
LINE2_NOMINAL
LINE2_MEAS
SUMMARY_TBLHDR
SUMMARY_AXIS
SUMMARY_NOMINAL
SUMMARY_MEAS
LINE2_PLUSTOL
LINE2_MINUSTOL
LINE2_MAX
LINE2_MIN
LINE2_ISBILATERAL
LINE2_NUMZONES
LINE3_ISBILATERAL
LINE3_NUMZONES
DIM_RPT_COLUMN_HDR
DIM_RPT_ISDATUM
DIM_RPT_DATUM
DIM_RPT_GRAPHIC
DIM_RPT_DEVPERCENT
DIM_RPT_ISBILATERAL
DIM_RPT_NUMZONES
GDT_SYMBOL
COMMENT_INPUT
TARGET_EDGE_WIDTH
TARGET_EDGE_HEIGHT
TARGET_EDGE_EDGEDETECT
TARGET_EDGE_FILTER_CLEAN
TARGET_EDGE_FILTER_CLEAN_STRENGTH
TARGET_EDGE_FILTER_AREA
TARGET_EDGE_FILTER_AREA_SIZE
TARGET_EDGE_GRADIENT
THEO_PERIMETER
MEAS_PERIMETER
THEO_AREA
MEAS_AREA
TARGET_SURFACE_CROSSHAIR_HEIGHT
SHOW_NOMS
COMPOSITE
DATUM2
TP_MODIFIER2
DESCRIPTION2
SHOW_OPTIONS
LEADER_LINE_ID
GDT_SYMBOL2
DATUM1_MODIFIER
DATUM2_MODIFIER
DATUM3_MODIFIER
DATUM1_MODIFIER2
DATUM2_MODIFIER2
DATUM3_MODIFIER2
DIM_RPT_DEVPERCENT_NOM
DIM_RPT_USETWODEVIATIONS
DIM_RPT_DEVPERCENT2
LINE2_DEVPERCENT_NOM
LINE2_USE2DEVIATIONS
LINE2_DEVPERCENT2
LINE3_DEVPERCENT_NOM
LINE3_USE2DEVIATIONS
LINE3_DEVPERCENT2
AXIS_PLUS_TOL
AXIS_MINUS_TOL
AXIS_NOMINAL
AXIS_DESCRIPTION
LINE1_DEVPERCENT_NOM
LINE1_USE2DEVIATIONS
LINE1_DEVPERCENT2
USE_AXIS2
DIM_LENGTH2
TEXTANAL_LABEL_MEAS_X
TEXTANAL_LABEL_MEAS_Y
TEXTANAL_LABEL_MEAS_Z
TEXTANAL_LABEL_MEAS_I
TEXTANAL_LABEL_MEAS_J
TEXTANAL_LABEL_MEAS_K
TEXTANAL_LABEL_DEV
TEXTANAL_LABEL_MINMAX
SIMULT_EVAL
SECTION_INDEX
LINE1_OUTTOL
LINE2_OUTTOL
LINE3_OUTTOL
LINE1_MAX
LINE1_MIN
LINE3_NOMINAL
LINE3_MEAS
LINE3_PLUSTOL
LINE3_MINUSTOL
LINE3_MAX
LINE3_MIN
SUMMARY_OUTTOL
SUMMARY_PLUSTOL
SUMMARY_MINUSTOL
SUMMARY_MAX
SUMMARY_MIN
SUMMARY_BONUS
LINE1_BONUS
GRAPH_ANALYSIS_POINT_SIZE
GRAPH_ANALYSIS_PLUS_TOL
GRAPH_ANALYSIS_MINUS_TOL
DIM_AXIS_ITEM_NUMBER
F_ENDING_DEPTH
DIM_ITEM_NUMBER
FEAT_ITEM_NUMBER
COMMAND_TYPE
DEV_MAX
AUTO_DEV_DIRECTION
PROBE_DIRECTION
USER_DEFINED_THEOS
SCALING
USE_SCALING
UID
REF_UID
BA_SOLUTION_TYPE
BA_SOLUTION_OPTIONS
BA_SOLUTION_STATUS
BA_VARIANCE
BA_RMS
BA_WARNINGS
BA_STATION
BA_STATION_X
BA_STATION_Y
BA_STATION_Z
BA_STATION_ROTX
BA_STATION_ROTY
BA_STATION_ROTZ
BA_STATION_ORIENTED
BA_STATION_LOCKED
BA_FEATURE
BA_FEAT_SOURCE
BA_FEAT_RMS
BA_FEAT_POINTING_ERR
BA_FEAT_APEX_ANGLE
BA_FEAT_X
BA_FEAT_Y
BA_FEAT_Z
BA_FEAT_DEV_X
BA_FEAT_DEV_Y
BA_FEAT_DEV_Z
BA_FEAT_DEV3D
NO_APPROACH_VECTOR_FLIP
TARGET_EDGE_START_VALUE
TARGET_EDGE_END_VALUE
TARGET_SURFACE_SURFACE_VARIANCE
RELATIVE_COMMENTS
AUTO_ROTARY
TARGET_COVERAGE
ROTATION_TYPE_2
PROBE_TYPE
TIME_STAMP
ECOND_TEMP
ECOND_PRESSURE
ECOND_HUMIDITY
HIT_RMS
DISPLAY_TRACKER_PARAMETERS
PTDENSITY_TOGGLE
PTDENSITY_UPPERBOUND
PTDENSITY_DEVLIMIT
PTDENSITY_MAXSPAN
TARGET_MEASURE_AT_FOV_CENTER
TARGET_SURFACE_FIND_SURFACE
PROJECTOR
INLINE_LEGACY_REPORT
SINGLE_POINT_DEVIATION
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a specified field type. In these cases, the TypeIndex must not be greater than the current number of fields of the that type + 1 and TypeIndex must be greater than 1. For fields that allow only a single value, the TypeIndex is 0.

Return Type

This method returns the value of the indicated field of the command.

See Also

ReportData Object


GetValue2 Method

GetValue2 Method
DataType
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a specified field type. In these cases, the TypeIndex must not be greater than the current number of fields of the that type + 1 and TypeIndex must be greater than 1. For fields that allow only a single value, the TypeIndex is 0.
FirstArrayIndex
This parameter specifies the index value for an item in the first array.
SecondArrayIndex
This parameter specifies the index value for an item in the second array.

Description

Returns the value of the indicated field of the specified command. This method returns the value of the indicated field of the command.

Syntax

Visual Basic
Public Function GetValue2( _
   ByVal DataType As ENUM_FIELD_TYPES, _
   ByVal TypeIndex As Long, _
   ByVal FirstArrayIndex As Long, _
   ByVal SecondArrayIndex As Long _
) As Variant

Parameters

DataType
Value Description
ID
REF_ID
LEVEL_REF_ID
ROTATE_REF_ID
ORIGIN_REF_ID
THEO_X
THEO_Y
THEO_Z
THEO_SX
THEO_SY
THEO_SZ
THEO_EX
THEO_EY
THEO_EZ
THEO_I
THEO_J
THEO_K
TARG_X
TARG_Y
TARG_Z
MEAS_X
MEAS_Y
MEAS_Z
MEAS_I
MEAS_J
MEAS_K
MEAS_LENGTH
MEAS_DIAM
MEAS_ANGLE
TARG_I
TARG_J
TARG_K
THEO_DIAM
THEO_WIDTH
THEO_LENGTH
THEO_HEIGHT
THEO_ANGLE
COORD_TYPE
INOUT_TYPE
THICKNESS_TYPE
CIRC_TYPE
SNAP_TYPE
USEPIN_TYPE
MOVE_TYPE
READPOS_TYPE
FINDHOLE_TYPE
RMEAS_TYPE
THEOBF_TYPE
BOUND_TYPE
BF_MATH_TYPE
AUTOFIT_CONSTRAINT
SLOT_MIN_MAX_TYPE
FIND_NOM_AXIS_TYPE
N_INIT_HITS_TYPE
N_PERM_HITS_TYPE
SEARCHMODE_TYPE
MODE_TYPE
MEASURE_ORDER_TYPE
CONE_LENGTH_ANGLE_TYPE
OFFSET_LINE_METHOD
LIN_POL_FILT_TYPE
GEN_FEAT_TYPE
GEN_ALIGN_TYPE
CURVE_TYPE
MEASURED_2D3D_TYPE
THINNING_TOL
HITINT_TYPE
RMEASFEATID
N_HITS
N_ROWS
INIT_HITS
PERM_HITS
F_OFFSET
F_SPACER
F_PITCH
F_THICKNESS
F_DEPTH
F_AUTOMOVE
F_INDENT
F_CORNER_RADIUS
F_INCREMENT
F_TOLERANCE
F_BOXWIDTH
F_BOXLENGTH
F_CIRCRADOUT
F_CIRCRADIN
F_CHECK
F_MAXACCELX
F_MAXACCELY
F_MAXACCELZ
SCAN_ACCELERATION
SCAN_OFFSET_FORCE
MANUAL_FINE_PROBING
F_MOVESPEED
F_TOUCHSPEED
F_SCANSPEED
START_ANG
END_ANG
MIDPOINT_X
MIDPOINT_Y
MIDPOINT_Z
ANGVEC_I
ANGVEC_J
ANGVEC_K
MEASVEC_I
MEASVEC_J
MEASVEC_K
SLOTVEC_I
SLOTVEC_J
SLOTVEC_K
SURFVEC_I
SURFVEC_J
SURFVEC_K
PINVEC_I
PINVEC_J
PINVEC_K
PUNCHVEC_I
PUNCHVEC_J
PUNCHVEC_K
REPORTVEC_I
REPORTVEC_J
REPORTVEC_K
TARGSLOT_I
TARGSLOT_J
TARGSLOT_K
UPDATEVEC_I
UPDATEVEC_J
UPDATEVEC_K
THEO_MINOR_AXIS
TWO_D_THREE_D_TYPE
AXIS
DEST_EXPR
SRC_EXPR
SHOW_IDS
SHOW_DETAILS
WEIGHT
ITEM_USED
USE_AXIS
AVERAGE_ERROR
MEASURE_ALL_FEATURES
REPIERCE_CAD
START_NUM
END_NUM
SKIP_NUM
X_OFFSET
Y_OFFSET
Z_OFFSET
ANGLE_OFFSET
INTERNAL_EXTERNAL
SAVE_ALIGN_CAD_TO_PARTS
FILE_NAME
ALIGN_LIST
WORK_PLANE
DISTANCE
OLD_TIP
NEW_TIP
ROTATION_TYPE
DIM_INFO_ORDER
DIM_INFO_LOC
DIM_INFO_TP_LOC
GRAPH_ANALYSIS
TEXT_ANALYSIS
ARROW_MULTIPLIER
OUTPUT_TYPE
NOMINAL
F_PLUS_TOL
F_MINUS_TOL
TP_MODIFIER
PERP_PARALLEL_TYPE
RADIUS_TYPE
UNIT_TYPE
DIM_LENGTH
PROFILE_FORM_TYPE
PRECISION
MAN_RETRACT
DIM_TEXT
DIM_TEXT_OPTIONS
SHOW_HEADINGS
DEVIATION_SYMBOLS
STANDARD_DEVIATION
DIM_HEADING
GAP_ONLY_TYPE
DISPLAY_ID
DISPLAY_TYPE
POINT_INFO_HEADING
SHOW_POINT_INFO
RET_ONLY_TYPE
COMMENT_FIELD
COMMENT_TYPE
PART_NAME
REVISION_NUMBER
SERIAL_NUMBER
STAT_COUNT
SUB_NAME
READ_WRITE
FILE_POINTER
FIELD_WIDTH
DIGIT_COUNT
LABEL_ID
ERROR_TYPE
ERROR_MODE
DESCRIPTION
INDEX_START
INDEX_END
FILE_COMMAND_TYPE
BUFFER_SIZE_TYPE
FAIL_ON_EXIST
MAX_FORCE
LOW_FORCE
UP_FORCE
TRIGGER_FORCE
PROBE_ACCURACY
POSITIONAL_ACCURACY
NUM_RETURN_DATA
RETURN_SPEED
SCAN_DENSITY
POLAR_VECTOR_COMPENSATION
AUTO_PRINT
ORIGIN
MATERIAL_COEFFICIENT
REF_TEMP
HIGH_THRESHOLD
LOW_THRESHOLD
SENSOR_LIST
FIXTURE_TYPE
MACHINE_TYPE
PROBE_COMP
TIP_I
TIP_J
TIP_K
NORM_RELEARN
FIND_NOMS_TYPE
AUTO_CLEAR_PLANE
SINGLE_POINT
DISPLAY_HITS
CAD_TOLERANCE
OFFSET_TOLERANCE
MIN_INCREMENT
MAX_INCREMENT
MIN_ANGLE
MAX_ANGLE
F_LOCATION
COL132_TYPE
COMMAND_STRING
FLY_MODE_TYPE
STATS_TYPE
STATS_DIR
NEW_STATS_DIR
DATA_READ_LOCK
DATA_WRITE_LOCK
DATA_MEM_PAGES
STAT_NAME_TYPE
STAT_CALC_TYPE
TRANSFER_DIR
DISPLAY_TRACE
TRACE_NAME
TRACE_VALUE
SCAN_CUTPLANEVEC_I
SCAN_CUTPLANEVEC_J
SCAN_CUTPLANEVEC_K
SCAN_INITVEC_I
SCAN_INITVEC_J
SCAN_INITVEC_K
SCAN_AXISVEC_I
SCAN_AXISVEC_J
SCAN_AXISVEC_K
SCAN_ENDVEC_I
SCAN_ENDVEC_J
SCAN_ENDVEC_K
SCAN_INITDIR_I
SCAN_INITDIR_J
SCAN_INITDIR_K
SCAN_CROSS_TOTAL
SCAN_TIME_INCR
SCAN_EDGE_THICK
POS_REPORT_AXIS_X
POS_REPORT_AXIS_Y
POS_REPORT_AXIS_Z
DEV_PERPEN_CENTERLINE
USE_THEO
TARGET_COLOR
THEO_START_ANG
THEO_END_ANG
ONOFF_TYPE
ROW_ID
LOCATOR_BMP
LOCATOR_WAV
DTYPE_LEAPFROGTYPE
DTYPE_LEAPFROGNUMHITS
DTYPE_LEAPFROGFULLPARTIAL
EXCLUSION_ZONE
EXECUTE
AUTOTRIGGERONOFF
AUTOBEEPING
COLUMN_ID
SLOT_NUMBER
AUTOTOLZONE
PROBING_MODE
ANGLE_COMP_TOGGLE
POINTINFO_FILTER_INTERVAL
POINTINFO_FILTER_INTERVAL_NUMBER
FEAT_TYPE
DIM_ID
MEAS_MINOR_AXIS
MEAS_HEIGHT
MEAS_SLOTVEC_I
MEAS_SLOTVEC_J
MEAS_SLOTVEC_K
MEAS_SX
MEAS_SY
MEAS_SZ
MEAS_EX
MEAS_EY
MEAS_EZ
MEAS_WIDTH
NUM_CONTROL_POINTS
U_HITS
V_HITS
NUM_FIT_POINTS
NOMINAL_COLOR
WAVE_FILE
DIM_BONUS
PERUNIT_STEPSIZE
PERUNIT_LENGTH
PERUNIT_WIDTH
DIM_MEASURED
SURFVEC_TARG_I
SURFVEC_TARG_J
SURFVEC_TARG_K
DIM_MAX
EDGEVEC_TARG_I
EDGEVEC_TARG_J
EDGEVEC_TARG_K
DIM_MIN
EDGEVEC_THEO_I
EDGEVEC_THEO_J
EDGEVEC_THEO_K
DIM_DEVIATION
EDGEVEC_MEAS_I
EDGEVEC_MEAS_J
EDGEVEC_MEAS_K
DIM_OUTTOL
T_VALUE
TOOL_X
TOOL_Y
TOOL_Z
TOOL_DIAM
DEV_X
DEV_Y
DEV_Z
DEV_DIAM
ITERATE_COLUMNS
LOAD_TYPE
NUM_ITERATIONS
METHOD_TYPE
SCAN_TECHNIQUE
HIT_TYPE
BOUNDARY_POINT_X
BOUNDARY_POINT_Y
BOUNDARY_POINT_Z
VIDEO_GAIN
VIDEO_OFFSET
VIDEO_LEDLIGHT
VIDEO_LASERLIGHT1
VIDEO_LASERLIGHT2
VIDEO_YORIGIN
VIDEO_YEND
VIDEO_LSEG
VIDEO_XSEG
VIDEO_YSEG
ANGULARITY_NOM_ANGLE
PRINT_TO_FILE
PRINT_TO_PRINTER
PRINT_DRAFTMODE
PRINT_DELETE_RUNS
POINTINFO_FILTER_WORST
POINTINFO_FILTER_WORST_NUMBER
POINTINFO_FILTER_DEVIATION
POINTINFO_FILTER_DEVIATION_NUMBER
POINTINFO_FILTER_OUTTOL
REPORT_SURFVEC_I
REPORT_SURFVEC_J
REPORT_SURFVEC_K
DB_QUERY_OP
DB_SOURCE_NAME
CHART_TYPE
DB_CHART_NAME
DEVIATION_ANGLE
STATS_DATASOURCE
IGNOREMOTIONERRORS_TYPE
THEO_X2
THEO_Y2
THEO_Z2
MEAS_X2
MEAS_Y2
MEAS_Z2
PPROG
TRACE_FILTER
TIME_FILTER
SHOW_SPC_CALCS
SPEC_LIMITS
ZONES
STDDEV
UCL_LCL
HISTOGRAM
GRID
ADDITIONAL_CHART
LINE2_PLANAR_OPEN_IN_X
LINE3_PLANAR_OPEN_IN_X
REGR
CENTER_POINT
SHOW_MORE_SPC_CALCS
SPEC_OFFSET
SOLID
U_L_BOUNDS
TITLE
CPOINT_X
CPOINT_Y
CPOINT_Z
CPOINT_I
CPOINT_J
CPOINT_K
CPOINT_DIAM
CPOINT_SCAN_CROSS_TOTAL
CPOINT_SCAN_DENSITY
CPOINT_F_SCANSPEED
N_CONTROLPOINTS
CPOINT_TYPE
USE_3DFILTER
SCAN_BNDRY_TYPE
CREATE_WEIGHTS
F_SIZE
LINE2_ISPLANAR
LINE2_PLANAR_XTOL
LINE2_PLANAR_YTOL
LINE2_PLANAR_XDEV
LINE2_PLANAR_YDEV
LINE3_ISPLANAR
LINE3_PLANAR_XTOL
LINE3_PLANAR_YTOL
LINE3_PLANAR_XDEV
LINE3_PLANAR_YDEV
CHART_SUB_TYPE
OVERWRITE
OUTPUT_FEATURE_NOMS
OUTPUT_FEAT_W_DIMENS
OUTPUT_DMIS_REPORT
TIME_ARG
TRACE_FILTER_ARG
FIT
STATS_DB_TYPE
IOCHANNEL_NUMBER
IOCHANNEL_PULSE_WIDTH
IOCHANNEL_PULSE_INTERVAL
IOCHANNEL_PULSE_DURATION
GRAPH_OPTION
DB_SOURCE_TYPE
FIND_HOLE_PERCENT
AUTO_ONERROR_TYPE
POS_REPT_DISPLAY_OPTION
TRIGGERTOLERANCE
TRIGGERTOLVALUE
FIXTURE_TOL
START_LABEL
ERROR_LABEL
CONE_CONVEX_TYPE
TRIGGERPLANE
QUERY_SHOW_GRAPHIC_SETTINGS
CALC_STYLE_FILE
FILTER_TYPE
TRACE_VALUE_LIMIT
TARGET_DIRECTION
TARGET_EDGE_POLARITY
BSMETHOD_TYPE
CENTER_ROTATION_THEO
CENTER_ROTATION_MEAS
ARTICULATEDARM_TYPE
LEFTYRIGHTY_CONFIG
ABOVEBELOW_CONFIG
NOFLIPFLIP_CONFIG
HIGH_ACCURACY
SURFACE
MAGNIFICATION
MINOR_WORD_TOGGLE
PERCENTAGE
THRESHOLD
N_SIDES
TARGET_SURFACE_ILLUM
MEAN
CAD_COMP
SHOW_ROW
SHOW_COLUMN
TARGET_SURFACE_SENSILIGHT
TARGET_SURFACE_WIDTH
TARGET_SURFACE_HEIGHT
TARGET_SURFACE_RANGE
TARGET_SURFACE_DURATION
TARGET_SURFACE_MODE
TARGET_SURFACE_HIACC
SCREEN_CAPTURE_SCALE
SCREEN_CAPTURE_QUALITY
TARGET_EDGE_SIZE
TARGET_EDGE_ILLUM
TARGET_EDGE_TOL
TARGET_EDGE_STRENGTH
TARGET_EDGE_DENSITY
TARGET_EDGE_TYPE
DISPLAY_ADVANCED_PARAMETERS
TARGET_SURFACE_TYPE
VOID_DETECT
TARG_SX
TARG_SY
TARG_SZ
TARG_EX
TARG_EY
TARG_EZ
PATTERN_TYPE
TARGET_EDGE_ANGLE
PROGRAM_GAGE_FEAT_TYPE
PROGRAM_GAGE_TYPE
TARGET_FOCUS
RMEASFEATIDX
RMEASFEATIDY
RMEASFEATIDZ
FINDNOMS_BESTFIT
FINDNOMS_ONLYSELECTED
TEMPX
TEMPY
TEMPZ
TEMPP
AUTO_PH9
MANUAL_PREPOSITION
SCREEN_CAPTURE_TYPE
SCREEN_CAPTURE_AUTO_TYPE
TARGET_EDGE_EDGESELECT
TARGET_EDGE_EDGENUM
DELETE_TYPE
SCREEN_CAPTURE_AUTO_TIME
USE_HSSDAT
USE_STARTENDDELAY
COP_FILTER
COP_SIZE
COP_TYPE
SURFVEC_MEAS_I
SURFVEC_MEAS_J
SURFVEC_MEAS_K
TARGET_EDGE_UNDERSCAN
PROFILE_TYPE
THEO_FLUSH
MEAS_FLUSH
THEO_GAP
MEAS_GAP
THEO_DEPTH
MEAS_DEPTH
TARGET_BLOB_TYPE
LASER_STRIPE_OVERLAP
LASER_STRIPE_OVERSCAN
LASER_FREQUENCY
TARGET_FILTER_OUTLIER
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD
SLOT_TYPE
TARGET_TYPE
THEO_R
THEO_A
THEO_H
MEAS_R
MEAS_A
MEAS_H
TARG_R
TARG_A
TARG_H
THEO_SR
THEO_SA
THEO_SH
THEO_ER
THEO_EA
THEO_EH
MEAS_SR
MEAS_SA
MEAS_SH
MEAS_ER
MEAS_EA
MEAS_EH
TARG_SR
TARG_SA
TARG_SH
TARG_ER
TARG_EA
TARG_EH
TARGET_EDGE_SENSILIGHT
F_THICKNESS_EDGE
THICKNESS_TYPE_EDGE
LASER_EXPOSURE
LASER_INTENSITY
ANGLE_OFFSET_2
LASER_FILTER_NEIGHBOR_NUM
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD
LASER_FILTER_TOL_ABOVE
LASER_FILTER_TOL_BELOW
LASER_FILTER_TOL_RIGHT
LASER_CLIP_UP_DIST
LASER_CLIP_LOW_DIST
LASER_PIXEL_TOGGLE
LASER_FILTER_TOGGLE
DISPLAY_PROBE_PARAMETERS
THEO_R2
THEO_A2
THEO_H2
MEAS_R2
MEAS_A2
MEAS_H2
LASER_CLIP_LEFT_DIST
LASER_CLIP_RIGHT_DIST
COP_FILETYPE
COP_SELECTIONTYPE
COP_COLORMAP
COP_COPLEMENT
OPERTYPE
COP_BOOLEANTYPE
COP_IMPORTFILETYPE
MEAS_START_ANG
MEAS_END_ANG
ISLAND_DIAM
ISLAND_LENGTH
ISLAND_WIDTH
ISLAND_X
ISLAND_Y
ISLAND_Z
ISLAND_I
ISLAND_J
ISLAND_K
ISLAND_AI
ISLAND_AJ
ISLAND_AK
ISLAND_TYPE
ISLAND_CLEARANCEDIST
RPT_DIMENSION_TABLES
SUMMARY_DEV
DRF_TBLHDR
LINE1_TBLHDR
LINE1_CALLOUT
LINE1_COLUMN_HDR
LINE1_FEATNAME
LINE1_NOMINAL
LINE1_MEAS
LINE1_PLUSTOL
LINE1_MINUSTOL
LINE1_DEV
LINE1_DEVPERCENT
LINE1_ISBILATERAL
LINE1_NUMZONES
LINE2_TBLHDR
LINE2_CALLOUT
LINE2_COLUMN_HDR
LINE2_FEATNAME
LINE2_BONUS
LINE2_TOL
LINE2_DATUMSHFT
LINE2_UNUSEDZONE
LINE2_DEV
LINE2_DEVANG
LINE2_DEVPERCENT
LINE3_TBLHDR
LINE3_CALLOUT
LINE3_COLUMN_HDR
LINE3_FEATNAME
LINE3_BONUS
LINE3_TOL
LINE3_DATUMSHFT
LINE3_UNUSEDZONE
LINE3_DEV
LINE3_DEVANG
LINE3_DEVPERCENT
DRF_COLUMN_HDR
DRF_SEGNAME
DRF_SHIFTX
DRF_SHIFTY
DRF_SHIFTZ
DRF_ROTATIONX
DRF_ROTATIONY
DRF_ROTATIONZ
SUMMARY_COLUMN_HDR
SUMMARY_FEAT
LINE2_AXIS
LINE2_NOMINAL
LINE2_MEAS
SUMMARY_TBLHDR
SUMMARY_AXIS
SUMMARY_NOMINAL
SUMMARY_MEAS
LINE2_PLUSTOL
LINE2_MINUSTOL
LINE2_MAX
LINE2_MIN
LINE2_ISBILATERAL
LINE2_NUMZONES
LINE3_ISBILATERAL
LINE3_NUMZONES
DIM_RPT_COLUMN_HDR
DIM_RPT_ISDATUM
DIM_RPT_DATUM
DIM_RPT_GRAPHIC
DIM_RPT_DEVPERCENT
DIM_RPT_ISBILATERAL
DIM_RPT_NUMZONES
GDT_SYMBOL
COMMENT_INPUT
TARGET_EDGE_WIDTH
TARGET_EDGE_HEIGHT
TARGET_EDGE_EDGEDETECT
TARGET_EDGE_FILTER_CLEAN
TARGET_EDGE_FILTER_CLEAN_STRENGTH
TARGET_EDGE_FILTER_AREA
TARGET_EDGE_FILTER_AREA_SIZE
TARGET_EDGE_GRADIENT
THEO_PERIMETER
MEAS_PERIMETER
THEO_AREA
MEAS_AREA
TARGET_SURFACE_CROSSHAIR_HEIGHT
SHOW_NOMS
COMPOSITE
DATUM2
TP_MODIFIER2
DESCRIPTION2
SHOW_OPTIONS
LEADER_LINE_ID
GDT_SYMBOL2
DATUM1_MODIFIER
DATUM2_MODIFIER
DATUM3_MODIFIER
DATUM1_MODIFIER2
DATUM2_MODIFIER2
DATUM3_MODIFIER2
DIM_RPT_DEVPERCENT_NOM
DIM_RPT_USETWODEVIATIONS
DIM_RPT_DEVPERCENT2
LINE2_DEVPERCENT_NOM
LINE2_USE2DEVIATIONS
LINE2_DEVPERCENT2
LINE3_DEVPERCENT_NOM
LINE3_USE2DEVIATIONS
LINE3_DEVPERCENT2
AXIS_PLUS_TOL
AXIS_MINUS_TOL
AXIS_NOMINAL
AXIS_DESCRIPTION
LINE1_DEVPERCENT_NOM
LINE1_USE2DEVIATIONS
LINE1_DEVPERCENT2
USE_AXIS2
DIM_LENGTH2
TEXTANAL_LABEL_MEAS_X
TEXTANAL_LABEL_MEAS_Y
TEXTANAL_LABEL_MEAS_Z
TEXTANAL_LABEL_MEAS_I
TEXTANAL_LABEL_MEAS_J
TEXTANAL_LABEL_MEAS_K
TEXTANAL_LABEL_DEV
TEXTANAL_LABEL_MINMAX
SIMULT_EVAL
SECTION_INDEX
LINE1_OUTTOL
LINE2_OUTTOL
LINE3_OUTTOL
LINE1_MAX
LINE1_MIN
LINE3_NOMINAL
LINE3_MEAS
LINE3_PLUSTOL
LINE3_MINUSTOL
LINE3_MAX
LINE3_MIN
SUMMARY_OUTTOL
SUMMARY_PLUSTOL
SUMMARY_MINUSTOL
SUMMARY_MAX
SUMMARY_MIN
SUMMARY_BONUS
LINE1_BONUS
GRAPH_ANALYSIS_POINT_SIZE
GRAPH_ANALYSIS_PLUS_TOL
GRAPH_ANALYSIS_MINUS_TOL
DIM_AXIS_ITEM_NUMBER
F_ENDING_DEPTH
DIM_ITEM_NUMBER
FEAT_ITEM_NUMBER
COMMAND_TYPE
DEV_MAX
AUTO_DEV_DIRECTION
PROBE_DIRECTION
USER_DEFINED_THEOS
SCALING
USE_SCALING
UID
REF_UID
BA_SOLUTION_TYPE
BA_SOLUTION_OPTIONS
BA_SOLUTION_STATUS
BA_VARIANCE
BA_RMS
BA_WARNINGS
BA_STATION
BA_STATION_X
BA_STATION_Y
BA_STATION_Z
BA_STATION_ROTX
BA_STATION_ROTY
BA_STATION_ROTZ
BA_STATION_ORIENTED
BA_STATION_LOCKED
BA_FEATURE
BA_FEAT_SOURCE
BA_FEAT_RMS
BA_FEAT_POINTING_ERR
BA_FEAT_APEX_ANGLE
BA_FEAT_X
BA_FEAT_Y
BA_FEAT_Z
BA_FEAT_DEV_X
BA_FEAT_DEV_Y
BA_FEAT_DEV_Z
BA_FEAT_DEV3D
NO_APPROACH_VECTOR_FLIP
TARGET_EDGE_START_VALUE
TARGET_EDGE_END_VALUE
TARGET_SURFACE_SURFACE_VARIANCE
RELATIVE_COMMENTS
AUTO_ROTARY
TARGET_COVERAGE
ROTATION_TYPE_2
PROBE_TYPE
TIME_STAMP
ECOND_TEMP
ECOND_PRESSURE
ECOND_HUMIDITY
HIT_RMS
DISPLAY_TRACKER_PARAMETERS
PTDENSITY_TOGGLE
PTDENSITY_UPPERBOUND
PTDENSITY_DEVLIMIT
PTDENSITY_MAXSPAN
TARGET_MEASURE_AT_FOV_CENTER
TARGET_SURFACE_FIND_SURFACE
PROJECTOR
INLINE_LEGACY_REPORT
SINGLE_POINT_DEVIATION
TypeIndex
Long value used to indicate which instance of the supplied field type to use when an object has more than one instance of a specified field type. In these cases, the TypeIndex must not be greater than the current number of fields of the that type + 1 and TypeIndex must be greater than 1. For fields that allow only a single value, the TypeIndex is 0.
FirstArrayIndex
This parameter specifies the index value for an item in the first array.
SecondArrayIndex
This parameter specifies the index value for an item in the second array.

Return Type

This method returns the value of the indicated field of the command.

See Also

ReportData Object


HasCommandData Method

HasCommandData Method

Description

Returns true if report data has a part program command interface.

This method returns True if report data has a part program command interface, False otherwise.

Syntax

Visual Basic
Public Function HasCommandData() As Boolean

Return Type

Boolean value showing TRUE if the report data has a part program command interface, or FALSE otherwise.

See Also

ReportData Object


CurPage Property

CurPage Property

Description

Read Only: Number of current page

This property returns a the number of the report's current page as a Long value.

Property type

Read-write property

Syntax

Visual Basic
Public Property CurPage() As Long

Return Type

Long value.

See Also

ReportData Object


ReportTemplate Object

ReportTemplate Object
See Also Members

Description

The ReportTemplate object allows you to get or set various settings for a report template.

Object Model

See Also

ReportTemplate Members


ReportTemplate Object Members

ReportTemplate ObjectMembers
See Also Overview

Public Methods

Public Method Close | Closes the report template This subroutine closes the report template. To first save any unsaved changes, use the Save method.
Public Method Save | Saves the report template This subroutine saves the report template with it's already existing name. If the template has not been saved before use the SaveAs method instead, and specify a filename.
Public Method SaveAs | Saves the report template with the given file name This method saves the report template.

Public Properties

Public Property _Name |
Public Property Application | Read Only: Returns the Application Object This property represents the read-only PC-DMIS Application object. The Application object includes properties and methods that return top-level objects.
Public Property Colors | Read Only: Returns the Colors collection This property returns a read-only Colors collection object. Through this object you will be able to access the report template's color tree. Only defined color objects will be in the collection. Color objects should be added or removed. Color objects will be retrieved using the command type ID or the COLOR_SELECTION ID.
Public Property FullName | Read Only: Returns the full path name This property returns a read-only string of the full path and filename of the report template.
Public Property LearnTimeProgram | Read/Write: Returns/Sets the Learn Time program name This read/write string property allows you to read or write the learn time program name.
Public Property Name | Read Only: Returns the file name This property returns a read-only string of the report template's filename.
Public Property PageOrientation | Read/Write: Returns/Sets the Page Orientation This property lets you to read or write the page orientation for the report template.
Public Property PageSize | Read/Write: Returns/Sets the Page Size This property lets you read or write the page size for the report template.
Public Property Parent | Read Only: Returns the parent Reports Object This property returns the report template's parent object, which is the read-only Report Templates object.
Public Property RunTimeProgram | Read/Write: Returns/Sets the Run Time program name This read/write string property allows you to read or write the run time program name.
Public Property Sections | Read Only: returns the Sections object This property returns a collection of all the report templates sections as a read-only Sections object.
Public Property Visible | Read/Write: Returns/Sets template editor visibility status Boolean property returns or sets the visibility status of the template editor. If True then Visible, if False then hidden.

See Also

ReportTemplate Overview


Close Method

Close Method

Description

Closes the report template This subroutine closes the report template. To first save any unsaved changes, use the Save method.

Syntax

Visual Basic
Public Sub Close()

See Also

ReportTemplate Object


Save Method

Save Method

Description

Saves the report template This subroutine saves the report template with it's already existing name. If the template has not been saved before use the SaveAs method instead, and specify a filename.

Syntax

Visual Basic
Public Function Save() As Boolean

See Also

ReportTemplate Object


SaveAs Method

SaveAs Method
FileName
Required expression that evaluates to a String. This is the pathway and file name to which you will save the report template.

Description

Saves the report template with the given file name

This method saves the report template.

Syntax

Visual Basic
Public Function SaveAs( _
   ByVal FileName As String _
) As Boolean

Parameters

FileName
Required expression that evaluates to a String. This is the pathway and file name to which you will save the report template.

See Also

ReportTemplate Object


_Name Property

_Name Property

Property type

Read-write property

Syntax

Visual Basic
Public Property _Name() As String

See Also

ReportTemplate Object


Application Property

Application Property

Description

Read Only: Returns the Application Object This property represents the read-only PC-DMIS Application object. The Application object includes properties and methods that return top-level objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

ReportTemplate Object


Colors Property

Colors Property

Description

Read Only: Returns the Colors collection This property returns a read-only Colors collection object. Through this object you will be able to access the report template's color tree. Only defined color objects will be in the collection. Color objects should be added or removed. Color objects will be retrieved using the command type ID or the COLOR_SELECTION ID.

Property type

Read-write property

Syntax

Visual Basic
Public Property Colors() As Colors

See Also

ReportTemplate Object


FullName Property

FullName Property

Description

Read Only: Returns the full path name This property returns a read-only string of the full path and filename of the report template.

Property type

Read-write property

Syntax

Visual Basic
Public Property FullName() As String

See Also

ReportTemplate Object


LearnTimeProgram Property

LearnTimeProgram Property

Description

Read/Write: Returns/Sets the Learn Time program name This read/write string property allows you to read or write the learn time program name.

Property type

Read-write property

Syntax

Visual Basic
Public Property LearnTimeProgram() As String

See Also

ReportTemplate Object


Name Property

Name Property

Description

Read Only: Returns the file name This property returns a read-only string of the report template's filename.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As String

See Also

ReportTemplate Object


PageOrientation Property

PageOrientation Property

Description

Read/Write: Returns/Sets the Page Orientation This property lets you to read or write the page orientation for the report template.

Property type

Read-write property

Syntax

Visual Basic
Public Property PageOrientation() As ENUM_PAGE_ORIENTATION

Return Type

Read/write ENUM_PAGE_ORIENTATION enumeration.

See Also

ReportTemplate Object


PageSize Property

PageSize Property

Description

Read/Write: Returns/Sets the Page Size This property lets you read or write the page size for the report template.

Property type

Read-write property

Syntax

Visual Basic
Public Property PageSize() As ENUM_PAGE_FORMAT

Return Type

Read/write ENUM_PAGE_FORMAT enumeration.

See Also

ReportTemplate Object


Parent Property

Parent Property

Description

Read Only: Returns the parent Reports Object This property returns the report template's parent object, which is the read-only Report Templates object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As ReportTemplates

See Also

ReportTemplate Object


RunTimeProgram Property

RunTimeProgram Property

Description

Read/Write: Returns/Sets the Run Time program name This read/write string property allows you to read or write the run time program name.

Property type

Read-write property

Syntax

Visual Basic
Public Property RunTimeProgram() As String

Return Type

Read/write String value.

See Also

ReportTemplate Object


Sections Property

Sections Property

Description

Read Only: returns the Sections object This property returns a collection of all the report templates sections as a read-only Sections object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Sections() As Sections

Return Type

Read-only Sections object.

See Also

ReportTemplate Object


Visible Property

Visible Property

Description

Read/Write: Returns/Sets template editor visibility status Boolean property returns or sets the visibility status of the template editor. If True then Visible, if False then hidden.

Property type

Read-write property

Syntax

Visual Basic
Public Property Visible() As Boolean

See Also

ReportTemplate Object


ReportTemplates Object

ReportTemplates Object
See Also Members

Description

The ReportTemplates object contains all open report templates in PC-DMIS's Report Template editor.

Object Model

Remarks

Use ReportTemplates.Add to create a new report template and add it to the ReportTemplates collection.

Use ReportTemplates(index) where index is the report template name or index number to access an individual report template.

See Also

ReportTemplates Members | Add Method


ReportTemplates Object Members

ReportTemplates ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method Add | Creates a new report template The Add function creates a new report template in PC-DMIS.
Public Method Item | Returns the report template with the given name or number The Item function returns the ReportTemplate Object with the given name or number.
Public Method Open | Opens the specified existing report template The Open Function activates the report template stored in the file FileName. If the template file does not exist, nothing happens.

Public Properties

Public Property Application | Read Only: Returns the Application Object This property represents the read-only PC-DMIS Application object. The Application object includes properties and methods that return top-level objects.
Public Property Count | Read Only: Returns the number of open reports This property returns a read-only number of open report templates.
Public Property Parent | Read Only: Returns the Application Object This returns the read-only PC-DMIS Application object which is the parent object of the ReportTemplates object.

See Also

ReportTemplates Overview | Add Method


_Item Method

_Item Method
NameOrNumber

Syntax

Visual Basic
Public Function _Item( _
   ByVal NameOrNumber As Variant _
) As ReportTemplate

Parameters

NameOrNumber

See Also

ReportTemplates Object


Add Method

Add Method

Description

Creates a new report template The Add function creates a new report template in PC-DMIS.

Syntax

Visual Basic
Public Function Add() As ReportTemplate

Example

Sub Create_Report_Template()

' This test subroutine was created to show how report templates can be

' automatically generated using PC-DMIS Automation

' This was created inside Microsoft Excel

' Make sure PC-DMIS is running

If MsgBox("This example will use your existing part program and create an automatic Report Template with a title of your choice. Is PC-DMIS running and is your part program loaded?", vbYesNo, "Automated Report Template Creation") = vbNo Then

MsgBox "Closing this example. Try again once PC-DMIS is running and a part program is loaded.", vbExclamation

Exit Sub

End If

' Create the PC-DMIS Application

Dim PCDApp As PCDLRN.Application

Set PCDApp = CreateObject("Pcdlrn.Application")

' Open a Part Program

Dim PP As PartProgram

Set PP = PCDApp.ActivePartProgram

Dim RepTemplates As ReportTemplates

Set RepTemplates = PCDApp.ReportTemplates

Dim RepTemplate As ReportTemplate

' Add a new Report Template

Set RepTemplate = RepTemplates.Add

' Use the existing default section of "Section1" for new templates

Dim Secs As Sections

Set Secs = RepTemplate.Sections

Dim Sec1 As Section

Dim Sec2 As Section

Set Sec1 = RepTemplate.Sections.Item("Section1")

' Add a Text object into TestSection1 and define its Text property

Dim RepControls As ReportControls

Set RepControls = Sec1.ReportControls

Dim strReportTitle As String

strReportTitle = InputBox("Please type a title for your report that's less than 30 characters", "Report Title")

If Len(strReportTitle) > 30 Then

MsgBox "Length is more than 30 chars. Your report title may need some adjusting later.", vbInformation

End If

Set TextObj = Sec1.ReportControls.Add(ID_HOB_TEXT, 50, 50, 750, 100)

TextObj.Font = 36

TextObj.Alignment = 1 ' To center it

TextObj.BackColor = RGB(128, 0, 64)

TextObj.ForeColor = RGB(255, 255, 255)

TextObj.Text = strReportTitle

Sec1.ReportControls.Add ID_HOB_PCD_TEXT_REPORT_OBJECT, 50, 170, 750, 930

' Add a new Section named "TestSection2"

Set Sec2 = RepTemplate.Sections.Add("MySection2")

' Add some objects into TestSection2

Set TextObj2 = Sec2.ReportControls.Add(ID_HOB_TEXT, 50, 50, 750, 100)

TextObj2.Font = 24

TextObj2.Alignment = Center ' To center it

TextObj2.BackColor = RGB(128, 0, 64)

TextObj2.ForeColor = RGB(255, 255, 255)

TextObj2.Text = "CAD Display"

MsgBox "Now adding a CADObject into the template. Click OK here, then switch to PC-DMIS, and use the Label Layout Wizard to specify your label configuration, then click OK on that dialog box."

Sec2.ReportControls.Add ID_HOB_PCD_CAD_REPORT_OBJECT, 0, 110, 800, 1000

' Save the changes to the Report Template

RepTemplate.SaveAs ("d:\temp\TestReportTemplate.rtp")

MsgBox "The Report Template is now created. You can open it up inside of PC-DMIS to see what it looks like.", vbInformation, "Report Template Finished"

RepTemplate.Close

End Sub

See Also

ReportTemplates Object


Item Method

Item Method
NameOrNumber
Required Variant that indicates which ReportTemplates object to return. It can be either a Long or a String. If it is a Long, it is the index number of the ReportTemplate object in the ReportTemplates collection. If it is a String, it is the ID of the ReportTemplate object.

Description

Returns the report template with the given name or number The Item function returns the ReportTemplate Object with the given name or number.

Syntax

Visual Basic
Public Function Item( _
   ByVal NameOrNumber As Variant _
) As ReportTemplate

Parameters

NameOrNumber
Required Variant that indicates which ReportTemplates object to return. It can be either a Long or a String. If it is a Long, it is the index number of the ReportTemplate object in the ReportTemplates collection. If it is a String, it is the ID of the ReportTemplate object.

Return Type

ReportTemplate object.

Remarks

Since the Item method is the default, the function name can be omitted if desired.

See Also

ReportTemplates Object


Open Method

Open Method
FileName
Required String. The file name of the ReportTemplate to open.

Description

Opens the specified existing report template

The Open Function activates the report template stored in the file FileName. If the template file does not exist, nothing happens.

Syntax

Visual Basic
Public Function Open( _
   ByVal FileName As String _
) As ReportTemplate

Parameters

FileName
Required String. The file name of the ReportTemplate to open.

Return Type

ReportTemplate object.

See Also

ReportTemplates Object


Application Property

Application Property

Description

Read Only: Returns the Application Object This property represents the read-only PC-DMIS Application object. The Application object includes properties and methods that return top-level objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

ReportTemplates Object


Count Property

Count Property

Description

Read Only: Returns the number of open reports This property returns a read-only number of open report templates.

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

See Also

ReportTemplates Object


Parent Property

Parent Property

Description

Read Only: Returns the Application Object This returns the read-only PC-DMIS Application object which is the parent object of the ReportTemplates object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Application

Return Type

Application object.

See Also

ReportTemplates Object


ReportWindow Object

ReportWindow Object
See Also Members

Description

The ReportWindow object allows you to get or set various settings for the Report window.

Object Model

See Also

ReportWindow Members


ReportWindow Object Members

ReportWindow ObjectMembers
See Also Overview

Public Methods

Public Method FullReportMode | Switches to Full Report Mode This method switches the report window to Full Report Mode.
Public Method GenerateStatusReportBitmap | Generates a status report for a range of commands
Public Method GenerateStatusReportBitmapId | Generates a status report for a range of commands
Public Method GenerateStatusReportBitmapUid | Generates a status report for a range of commands
Public Method GetCustomReportName | Returns the file name of the custom report at index position (0 based) Returns the name of the custom report name associated with the index value.
Public Method LastExecutionReportMode | Switches to Last Execution Report Mode This method switches the report window to Last Execution Report Mode.
Public Method LoadCustomReport | Loads the specified custom report into the report window This method loads the specified custom report into the Report window.
Public Method LoadReportTemplate | Loads the specified report template into the report window This method loads the specified report template into the Report window.
Public Method PrintReport | Prints the current report This method prints the contents of the Report window.
Public Method RefreshReport | Regenerates the current report This method reloads the report data into the report template, thereby refreshing the contents of the Report window.
Public Method SetCurrentAsDefaultReport | Sets the current report as the default report for the part program This method sets the current report as the default report for the part program.

Public Properties

Public Property Application | Read Only: Returns the Application Object This property represents the read-only PC-DMIS Application object. The Application object includes properties and methods that return top-level objects.
Public Property CurrentReport | Read Only: Returns the name of current report This read-only property returns the full directory pathway to the Custom Report or Report Template used in the Report window.
Public Property CustomReportCount | Read Only: Returns the number of custom report defined for the parent part program This read-only property returns the number of Custom Reports defined for the current part program.
Public Property Pages | Read Only: Returns the Pages object for this Report Window Returns a collection of Page objects (one Page object for each page making up the report) as a Pages object.
Public Property Parent | Read Only: Returns the PartProgram Object This returns the parent PartProgram object.
Public Property Visible | Read/Write: Returns/Sets Visibility Status of Report Window This returns or sets the visibility state of the Report window.

See Also

ReportWindow Overview


FullReportMode Method

FullReportMode Method

Description

Switches to Full Report Mode This method switches the report window to Full Report Mode.

Syntax

Visual Basic
Public Function FullReportMode() As Long

Return Type

Long value. This returns -1 if the function succeeds and 0 if it does not.

Example

Sub Main

Dim App As Object

Dim PartProg As Object

Dim RepWin As Object

Set App = CreateObject("Pcdlrn.Application")

Set PartProg = App.ActivePartProgram

Set RepWin = PartProg.ReportWindow

lngRetVal = RepWin.FullReportMode()

MsgBox "PC-DMIS returned " & lngRetVal & " for setting the Report window to Full Report mode."

RepWin.RefreshReport

End Sub

See Also

ReportWindow Object


GenerateStatusReportBitmap Method

GenerateStatusReportBitmap Method
FileName
templatename
startCmd
endCmd

Description

Generates a status report for a range of commands

Syntax

Visual Basic
Public Function GenerateStatusReportBitmap( _
   ByVal FileName As String, _
   ByVal templatename As String, _
   ByVal startCmd As Command, _
   ByVal endCmd As Command _
) As Long

Parameters

FileName
templatename
startCmd
endCmd

See Also

ReportWindow Object


GenerateStatusReportBitmapId Method

GenerateStatusReportBitmapId Method
FileName
templatename
start
end

Description

Generates a status report for a range of commands

Syntax

Visual Basic
Public Function GenerateStatusReportBitmapId( _
   ByVal FileName As String, _
   ByVal templatename As String, _
   ByVal start As String, _
   ByVal end As String _
) As Long

Parameters

FileName
templatename
start
end

See Also

ReportWindow Object


GenerateStatusReportBitmapUid Method

GenerateStatusReportBitmapUid Method
FileName
templatename
HiPart
LoPart

Description

Generates a status report for a range of commands

Syntax

Visual Basic
Public Function GenerateStatusReportBitmapUid( _
   ByVal FileName As String, _
   ByVal templatename As String, _
   ByRef HiPart As Long, _
   ByRef LoPart As Long _
) As Long

Parameters

FileName
templatename
HiPart
LoPart

See Also

ReportWindow Object


GetCustomReportName Method

GetCustomReportName Method
index
Long value representing the specific custom report in a collection of custom reports.

Description

Returns the file name of the custom report at index position (0 based) Returns the name of the custom report name associated with the index value.

Syntax

Visual Basic
Public Function GetCustomReportName( _
   ByVal index As Long _
) As String

Parameters

index
Long value representing the specific custom report in a collection of custom reports.

Return Type

String value representing the name of the custom report.

Remarks

This only returns the file name for the custom report, not the full directory pathway to the file.

Index value for the first report starts at 0.

Example

If you have 5 custom reports for the current part program, a value of 0 would return the first report's name, a value of 6 would return the fifth report's name.

See the LoadCustomReport method for an example of this.

See Also

ReportWindow Object | LoadCustomReport Method


LastExecutionReportMode Method

LastExecutionReportMode Method

Description

Switches to Last Execution Report Mode This method switches the report window to Last Execution Report Mode.

Syntax

Visual Basic
Public Function LastExecutionReportMode() As Long

Return Type

Long value. This returns -1 (or True) if the function succeeds and 0 (or False) if it does not.

Example

Sub Main

Dim App As Object

Dim PartProg As Object

Dim RepWin As Object

Set App = CreateObject("Pcdlrn.Application")

Set PartProg = App.ActivePartProgram

Set RepWin = PartProg.ReportWindow

lngRetVal = RepWin.LastExecutionReportMode()

MsgBox "PC-DMIS returned " & lngRetVal & " for setting the Report window to Last Execution Report mode."

RepWin.RefreshReport

End Sub

See Also

ReportWindow Object


LoadCustomReport Method

LoadCustomReport Method
NameOrNumber
This required Variant value specifies the custom report to load into the Report window. This can be either the custom report name or the index number.

Description

Loads the specified custom report into the report window This method loads the specified custom report into the Report window.

Syntax

Visual Basic
Public Function LoadCustomReport( _
   ByVal NameOrNumber As Variant _
) As Long

Parameters

NameOrNumber
This required Variant value specifies the custom report to load into the Report window. This can be either the custom report name or the index number.

Return Type

Long value. This returns -1 (or True) if the function succeeds and 0 (or False) if it does not.

Remarks

If you use an index value, a 0 in NameOrNumber represents the first custom report.

Example

Sub Main

Dim App As Object

Dim PartProg As Object

Dim RepWin As Object

Set App = CreateObject("Pcdlrn.Application")

Set PartProg = App.ActivePartProgram

Set RepWin = PartProg.ReportWindow

intResponse = InputBox("Type an an index value to load the associated custom report for this part program. PC-DMIS will return its name.")

MsgBox "PC-DMIS attempting to load the report index: " & intResponse & " (" & RepWin.GetCustomReportName(intResponse) & ")"

Dim lngRetVal As Long

' Loads the custom report based on the entered number

lngRetVal = RepWin.LoadCustomReport(intResponse)

RepWin.RefreshReport

End Sub

See Also

ReportWindow Object


LoadReportTemplate Method

LoadReportTemplate Method
FileName
This required String value specifies the pathway and filename of the template to load into the Report window.

Description

Loads the specified report template into the report window This method loads the specified report template into the Report window.

Syntax

Visual Basic
Public Function LoadReportTemplate( _
   ByVal FileName As String _
) As Long

Parameters

FileName
This required String value specifies the pathway and filename of the template to load into the Report window.

Return Type

Long value. This returns -1 (or True) if the function succeeds and 0 (or False) if it does not.

Remarks

Sub Main

Dim App As Object

Dim PartProg As Object

Dim RepWin As Object

Set App = CreateObject("Pcdlrn.Application")

Set PartProg = App.ActivePartProgram

Set RepWin = PartProg.ReportWindow

' Loads the TEXTONLY.RTP report template.

RepWin.LoadReportTemplate "C:\PCDMIS43RC2\REPORTING\TEXTONLY.RTP"

RepWin.RefreshReport

End Sub

See Also

ReportWindow Object


PrintReport Method

PrintReport Method

Description

Prints the current report This method prints the contents of the Report window.

Syntax

Visual Basic
Public Function PrintReport() As Long

Return Type

Long value. This returns -1 (or True) if the function succeeds and 0 (or False) if it does not.

Example

Sub Main

Dim App As Object

Dim PartProg As Object

Dim RepWin As Object

Set App = CreateObject("Pcdlrn.Application")

Set PartProg = App.ActivePartProgram

Set RepWin = PartProg.ReportWindow

' Prints the the contents of the Report window

RepWin.PrintReport

End Sub

See Also

ReportWindow Object


RefreshReport Method

RefreshReport Method

Description

Regenerates the current report This method reloads the report data into the report template, thereby refreshing the contents of the Report window.

Syntax

Visual Basic
Public Function RefreshReport() As Long

Return Type

Long value. This returns -1 (or True) if the function succeeds and 0 (or False) if it does not.

Example

Sub Main

Dim App As Object

Dim PartProg As Object

Dim RepWin As Object

Set App = CreateObject("Pcdlrn.Application")

Set PartProg = App.ActivePartProgram

Set RepWin = PartProg.ReportWindow

' Refreshes or redraws the current custom report or template

RepWin.RefreshReport

End Sub

See Also

ReportWindow Object


SetCurrentAsDefaultReport Method

SetCurrentAsDefaultReport Method

Description

Sets the current report as the default report for the part program

This method sets the current report as the default report for the part program.

Syntax

Visual Basic
Public Function SetCurrentAsDefaultReport() As Long

Return Type

Long value. This returns -1 (or True) if the function succeeds and 0 (or False) if it does not.

Example

Sub Main

Dim App As Object

Dim PartProg As Object

Dim RepWin As Object

Set App = CreateObject("Pcdlrn.Application")

Set PartProg = App.ActivePartProgram

Set RepWin = PartProg.ReportWindow

' Sets the current custom report or template as the default

RepWin.SetCurrentAsDefaultReport

End Sub

See Also

ReportWindow Object


Application Property

Application Property

Description

Read Only: Returns the Application Object This property represents the read-only PC-DMIS Application object. The Application object includes properties and methods that return top-level objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

ReportWindow Object


CurrentReport Property

CurrentReport Property

Description

Read Only: Returns the name of current report This read-only property returns the full directory pathway to the Custom Report or Report Template used in the Report window.

Property type

Read-write property

Syntax

Visual Basic
Public Property CurrentReport() As String

Return Type

Read-only String value representing the full directory pathway of the custom report or report template.

Remarks

Sub Main

Dim App As Object

Dim PartProg As Object

Dim RepWin As Object

Set App = CreateObject("Pcdlrn.Application")

Set PartProg = App.ActivePartProgram

Set RepWin = PartProg.ReportWindow

' Displays the current custom report or template

MsgBox "This part program uses this custom report or template: " & RepWin.CurrentReport

End Sub

See Also

ReportWindow Object


CustomReportCount Property

CustomReportCount Property

Description

Read Only: Returns the number of custom report defined for the parent part program This read-only property returns the number of Custom Reports defined for the current part program.

Property type

Read-write property

Syntax

Visual Basic
Public Property CustomReportCount() As Long

Return Type

Read-only Long value representing the number of custom reports created for the current part program.

Remarks

Sub Main

Dim App As Object

Dim PartProg As Object

Dim RepWin As Object

Set App = CreateObject("Pcdlrn.Application")

Set PartProg = App.ActivePartProgram

Set RepWin = PartProg.ReportWindow

' Displays the number of custom reports

MsgBox "This part program uses " & RepWin.CustomReportCount & " custom reports."

End Sub

See Also

ReportWindow Object


Pages Property

Pages Property

Description

Read Only: Returns the Pages object for this Report Window Returns a collection of Page objects (one Page object for each page making up the report) as a Pages object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Pages() As Pages

Return Type

Pages object.

Example

Sub Main

Dim App As Object

Dim PartProg As Object

Dim RepWin As Object

Dim Pages As Object

Dim Page As Object

Set App = CreateObject("Pcdlrn.Application")

Set PartProg = App.ActivePartProgram

Set RepWin = PartProg.ReportWindow

' Gets a collection of page objects

Set Pages = RepWin.Pages

End Sub

See Also

ReportWindow Object


Parent Property

Parent Property

Description

Read Only: Returns the PartProgram Object This returns the parent PartProgram object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As PartProgram

Return Type

PartProgram object.

See Also

ReportWindow Object


Visible Property

Visible Property

Description

Read/Write: Returns/Sets Visibility Status of Report Window

This returns or sets the visibility state of the Report window.

Property type

Read-write property

Syntax

Visual Basic
Public Property Visible() As Long

Return Type

Read/write Long value.

Remarks

To turn the window on or off, give it a True or False value respectively.

Example

Sub Main

Dim App As Object

Dim PartProg As Object

Dim RepWin As Object

Set App = CreateObject("Pcdlrn.Application")

Set PartProg = App.ActivePartProgram

Set RepWin = PartProg.ReportWindow

' Hide Report Window

RepWin.Visible = False

MsgBox "Report window is now hidden."

' Show Report Window

RepWin.Visible = True

MsgBox "Report window is now visible."

End Sub

See Also

ReportWindow Object


Scan Object

Scan Object
See Also Members

Description

Scan objects are created from more generic Command objects to pass information specific to the scan command back and forth. At present only DCC and Manual scans are user accessible.

Object Model

See Also

Scan Members


Scan Object Members

Scan ObjectMembers
See Also Overview

Public Methods

Public Method AddControlPoint | Adds a control point to the scan
Public Method CreateBasicScan | Used for DCC and Manual Scans to cause creation of basic scan object This method has to be called after calling other Properties/Methods. This method creates the necessary BasicScans needed by DCC and Manual scans and inserts them into the Part Program.
Public Method GenerateScan | Generates the points for the scan
Public Method GetBoundaryConditionParams | Gets the boundary condition parameters
Public Method GetBoundaryPoint | Returns the boundary point specified by the index
Public Method GetControlPoint | Returns the control point specified by the index
Public Method GetFilterParams | Gets parameters used in filtering of scan data
Public Method GetHitParams | Gets parameters for the hit type used in the scan
Public Method GetHitTValue | Returns T deviation values for specified scansion hit
Public Method GetMethodParams | Gets the scan method parameters
Public Method GetMethodPointData | Gets scan points and vectors via pointdata objects This method is provided as a shortcut to getting these commonly used properties all at once.
Public Method GetNomsParams | Gets the parameters used in finding of scan nominals
Public Method GetParams | Gets the basic scanning parameters of the scan This method is provided as a shortcut to getting these commonly used properties all at once.
Public Method RemoveControlPoint | Removes the control point at the specified index
Public Method SetBoundaryConditionParams | Sets the boundary condition parameters
Public Method SetBoundaryPoint | Sets the boundary point specified by the index paramter
Public Method SetControlPoint | Sets the control point at the specified index
Public Method SetFilterParams | Sets parameters for filtering scan data
Public Method SetHitParams | Sets parameters for the hit type used in the scan
Public Method SetMethodParams | Sets the scan method parameters
Public Method SetMethodPointData | Sets scan points and vectors via pointdata objects This method is provided as a shortcut to setting these commonly used properties all at once.
Public Method SetNomsParams | Sets the parameters used in finding of scan nominals Boolean value. Boolean returns true if the function succeeds, false if it fails.
Public Method SetParams | Sets the basic scanning parameters of the scan This method is provided as a shortcut to setting these commonly used properties all at once.

Public Properties

Public Property AutoClearPlane | Read/Write: Boolean value indicating if auto clear planes should be used
Public Property BoundaryCondition | Read/Write: Boundary Condition (Sphere, Plane Cross, Cone, etc. Represents the boundary condition type.
Public Property BoundaryConditionAxisV | Read/Write: Returns/Sets via point data object the boundary scan's axis vector This property represents the boundary condition axis vector. This vector is used as the axis of the Cylindrical and Conical BoundaryConditions.
Public Property BoundaryConditionCenter | Read/Write: Returns/Sets via point data object a boundary scan's center point This property represents the boundary condition center.
Public Property BoundaryConditionEndApproach | Read/Write: Returns/Sets via point data object the end approach for a boundary scan This property represents the boundary condition end approach vector.
Public Property BoundaryConditionPlaneV | Read/Write: Returns/Sets via point data object the boundary scan's plane vector This property represents the boundary condition plane vector. This vector is the normal vector of the plane used by the Plane and OldStyle Boundary Conditions.
Public Property BoundaryPointCount | Read/Write: Long value indicating the number of boundary points for patch scans
Public Property DisplayHits | Read/Write: Boolean value indicating whether hits should be displayed or not
Public Property Filter | Read/Write: Distance Filter Type This property represents the filter type. Read/write of enumeration BSF_ENUM.
Public Property HitType | Read/Write: Scan Hit Type (Vector, Surface, Edge) Represents the type of hit to use.
Public Property Method | Read/Write: Scan Type This property represents the method type for this scan.
Public Property MethodCutPlane | Read/Write: Returns/Sets via point data object the cut plane vector This property represents the method’s cut plane vector.
Public Property MethodEnd | Read/Write: Returns/Sets via point data object the ending scan point This property represents the scan’s end point.
Public Property MethodEndTouch | Read/Write: Returns/Sets via point data object the end touch vector This property represents the method’s end touch vector.
Public Property MethodInitDir | Read/Write: Returns/Sets via point data object the initial scan direction vector This property represents the method’s initial direction vector.
Public Property MethodInitTopSurf | Read/Write: Returns/Sets via point data object the initial top surface vector This property represents the initial Surface Vector for the Edge method.
Public Property MethodInitTouch | Read/Write: Returns/Sets via point data object the initial touch vector This represents the method’s initial touch vector.
Public Property MethodStart | Read/Write: Returns/Sets via point data object the starting scan point This property represents the scan’s start point.
Public Property NominalMode | Read/Write: Find cad nominals or use master data This property represents how to determine the nominals for this scan.
Public Property OperationMode | Read/Write: Scan Operation Mode This property represents mode of operation of the scan.
Public Property SinglePoint | Read/Write: Returns/Sets Single Point Mode Flag

See Also

Scan Overview


AddControlPoint Method

AddControlPoint Method
ControlPoint

Description

Adds a control point to the scan

Syntax

Visual Basic
Public Function AddControlPoint( _
   ByVal ControlPoint As ControlPoint _
) As Boolean

Parameters

ControlPoint

See Also

Scan Object


CreateBasicScan Method

CreateBasicScan Method

Description

Used for DCC and Manual Scans to cause creation of basic scan object

This method has to be called after calling other Properties/Methods. This method creates the necessary BasicScans needed by DCC and Manual scans and inserts them into the Part Program.

Syntax

Visual Basic
Public Function CreateBasicScan() As Boolean

Return Type

Boolean value. Boolean returns True if the function succeeds, False if it fails.

See Also

Scan Object


GenerateScan Method

GenerateScan Method

Description

Generates the points for the scan

Syntax

Visual Basic
Public Function GenerateScan() As Boolean

See Also

Scan Object


GetBoundaryConditionParams Method

GetBoundaryConditionParams Method
nCrossings
Required Long variable that gets the number of crossings for this boundary condition. The scan would stop after the probe crosses (breaks) the Boundary Condition like a Sphere, Cylinder, Cone, or a Plane the given number of times.
dRadius
Required Double variable that gets the radius of the boundary condition. This is used by the Spherical and Cylindrical Boundary Conditions.
dHalfAngle
Required Double variable that gets the half-angle of the cone-type boundary condition, or gets zero if the boundary condition is not of cone type.

Description

Gets the boundary condition parameters

Syntax

Visual Basic
Public Function GetBoundaryConditionParams( _
   ByRef nCrossings As Long, _
   ByRef dRadius As Double, _
   ByRef dHalfAngle As Double _
) As Boolean

Parameters

nCrossings
Required Long variable that gets the number of crossings for this boundary condition. The scan would stop after the probe crosses (breaks) the Boundary Condition like a Sphere, Cylinder, Cone, or a Plane the given number of times.
dRadius
Required Double variable that gets the radius of the boundary condition. This is used by the Spherical and Cylindrical Boundary Conditions.
dHalfAngle
Required Double variable that gets the half-angle of the cone-type boundary condition, or gets zero if the boundary condition is not of cone type.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

Scan Object


GetBoundaryPoint Method

GetBoundaryPoint Method
index
X
Y
Z

Description

Returns the boundary point specified by the index

Syntax

Visual Basic
Public Function GetBoundaryPoint( _
   ByVal index As Long, _
   ByRef X As Double, _
   ByRef Y As Double, _
   ByRef Z As Double _
) As Boolean

Parameters

index
X
Y
Z

See Also

Scan Object


GetControlPoint Method

GetControlPoint Method
index

Description

Returns the control point specified by the index

Syntax

Visual Basic
Public Function GetControlPoint( _
   ByVal index As Long _
) As ControlPoint

Parameters

index

See Also

Scan Object


GetFilterParams Method

GetFilterParams Method
dCutAxisLocation
Used for Manual scans with Filter property set to BSF_BODYAXISDISTANCE.
nAxis
Required Long variable that gets the cut axis. Returns non-zero only for axis filters. For axis filters, 0 means the X axis, 1 means the Y-axis, and 2 means the Z-axis.
dMaxIncrement
Required Double variable that gets the maximum increment. For fixed-length filters, this is simply the fixed increment. This is the Time delta valus in case the filter is BSF_TIME_DELTA or BSF_VARIABLEDISTANCE for Manual scans.
dMinIncrement
Required Double variable that gets the minimum increment for Variable Distance Filters. This is the Drop Point distance when a Manul scan is being used with the filter set to BSF_VARIABLEDISTANCE.
dMaxAngle
Required Double variable that gets the maximum angle used in Variable Distance Filters.
dMinAngle
Required Double variable that gets the minimum angle used in Variable Distance Filters.

Description

Gets parameters used in filtering of scan data

Syntax

Visual Basic
Public Function GetFilterParams( _
   ByRef dCutAxisLocation As Double, _
   ByRef nAxis As Long, _
   ByRef dMaxIncrement As Double, _
   ByRef dMinIncrement As Double, _
   ByRef dMaxAngle As Double, _
   ByRef dMinAngle As Double _
) As Boolean

Parameters

dCutAxisLocation
Used for Manual scans with Filter property set to BSF_BODYAXISDISTANCE.
nAxis
Required Long variable that gets the cut axis. Returns non-zero only for axis filters. For axis filters, 0 means the X axis, 1 means the Y-axis, and 2 means the Z-axis.
dMaxIncrement
Required Double variable that gets the maximum increment. For fixed-length filters, this is simply the fixed increment. This is the Time delta valus in case the filter is BSF_TIME_DELTA or BSF_VARIABLEDISTANCE for Manual scans.
dMinIncrement
Required Double variable that gets the minimum increment for Variable Distance Filters. This is the Drop Point distance when a Manul scan is being used with the filter set to BSF_VARIABLEDISTANCE.
dMaxAngle
Required Double variable that gets the maximum angle used in Variable Distance Filters.
dMinAngle
Required Double variable that gets the minimum angle used in Variable Distance Filters.

Return Type

Boolean value.

Remarks

Filter | GetFilterParams (dCutAxisLocation, nAxis, dMaxIncrement, dMinIncrement, dMaxAngle, dMinAngle)
Distance | ,,dMaxIncrement
BodyAxisDistance (DCC) | ,nAxis, dMaxIncrement
BodyAxisDistance (Manual) | NCutLocation,nAxis
Time | ,,dMaxIncrement
VariableDistance | ,,dMaxIncrement, dMinIncrement, dMaxAngle, dMinAngle

See Also

Scan Object


GetHitParams Method

GetHitParams Method
nInitSamples
Required Long variable that gets the number of initial sample hits for the hits in this scan. It always returns zero for basic hits and vector hits.
nPermSamples
Required Long variable that gets the number of permanent sample hits for the hits in this scan. It always returns zero for basic hits and vector hits.
dSpacer
Required Double variable that gets the spacing of the sample hits from the hit center. It always returns zero for basic hits and vector hits.
dIndent
Required Double variable that gets the indent of the sample hits from the hit center. It always returns zero for basic hits, vector hits, and surface.
dDepth
Required Double variable that gets the depth of the sample hits from the hit center. It always returns zero for basic hits, vector hits, and surface.

Description

Gets parameters for the hit type used in the scan

Syntax

Visual Basic
Public Function GetHitParams( _
   ByRef nInitSamples As Long, _
   ByRef nPermSamples As Long, _
   ByRef dSpacer As Double, _
   ByRef dIndent As Double, _
   ByRef dDepth As Double _
) As Boolean

Parameters

nInitSamples
Required Long variable that gets the number of initial sample hits for the hits in this scan. It always returns zero for basic hits and vector hits.
nPermSamples
Required Long variable that gets the number of permanent sample hits for the hits in this scan. It always returns zero for basic hits and vector hits.
dSpacer
Required Double variable that gets the spacing of the sample hits from the hit center. It always returns zero for basic hits and vector hits.
dIndent
Required Double variable that gets the indent of the sample hits from the hit center. It always returns zero for basic hits, vector hits, and surface.
dDepth
Required Double variable that gets the depth of the sample hits from the hit center. It always returns zero for basic hits, vector hits, and surface.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

Scan Object


GetHitTValue Method

GetHitTValue Method
index
T

Description

Returns T deviation values for specified scansion hit

Syntax

Visual Basic
Public Function GetHitTValue( _
   ByVal index As Long, _
   ByRef T As Double _
) As Boolean

Parameters

index
T

See Also

Scan Object


GetMethodParams Method

GetMethodParams Method
bIn
bCenteringType
nCenteringDirection
dDiameter
dArcAngle
dDepth
dPitch

Description

Gets the scan method parameters

Syntax

Visual Basic
Public Function GetMethodParams( _
   ByRef bIn As ENUM_SCAN_INOUT_TYPES, _
   ByRef bCenteringType As Boolean, _
   ByRef nCenteringDirection As Long, _
   ByRef dDiameter As Double, _
   ByRef dArcAngle As Double, _
   ByRef dDepth As Double, _
   ByRef dPitch As Double _
) As Boolean

Parameters

bIn
Value | Description
SCAN_INNER | Inside scans
SCAN_OUTER | Outside scans
SCAN_PLANAR | Plane Circle scans
bCenteringType
nCenteringDirection
dDiameter
dArcAngle
dDepth
dPitch

See Also

Scan Object


GetMethodPointData Method

GetMethodPointData Method
MethodStart
Required PointData object that gets the MethodStart property.
MethodEnd
Required PointData object that gets the MethodEnd property.
MethodInitTouch
Required PointData object that gets the MethodInitTouch property.
MethodEndTouch
Required PointData object that gets the MethodEndTouch property.
MethodInitDir
Required PointData object that gets the MethodInitDir property.
MethodInitTopSurf
MethodCutPlane
Required PointData object that gets the MethodCutPlane property.

Description

Gets scan points and vectors via pointdata objects

This method is provided as a shortcut to getting these commonly used properties all at once.

Syntax

Visual Basic
Public Function GetMethodPointData( _
   ByVal MethodStart As PointData, _
   ByVal MethodEnd As PointData, _
   ByVal MethodInitTouch As PointData, _
   ByVal MethodEndTouch As PointData, _
   ByVal MethodInitDir As PointData, _
   ByVal MethodInitTopSurf As PointData, _
   ByVal MethodCutPlane As PointData _
) As Boolean

Parameters

MethodStart
Required PointData object that gets the MethodStart property.
MethodEnd
Required PointData object that gets the MethodEnd property.
MethodInitTouch
Required PointData object that gets the MethodInitTouch property.
MethodEndTouch
Required PointData object that gets the MethodEndTouch property.
MethodInitDir
Required PointData object that gets the MethodInitDir property.
MethodInitTopSurf
MethodCutPlane
Required PointData object that gets the MethodCutPlane property.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

If scan is a ScanCommand object, and MS, ME, MIT, MET, MID,and MCP are all Dimensioned as Object, the following are equivalent:

scan.GetMethodParams MS,ME,MIT,MET,MID,MCP

set MS = scan.MethodStart
set ME = scan.MethodEnd
set MIT = scan.MethodInitTouch
set MET = scan.MethodEndTouch
set MID = scan.MethodInitDir
set MCP = scan.MethodCutPlane

See Also

Scan Object


GetNomsParams Method

GetNomsParams Method
dFindNomsTolerance
Required Double variable that gets the Find Noms tolerance and is used only when the NominalMode property is BSCANNMODE_FINDCADNOMINAL.
dSurfaceThickness
Required Double variable that gets the surface thickness and is used only when the NominalMode property is BSCANNMODE_FINDCADNOMINAL.
dEdgeThickness
Required Double variable that gets the edge thickness and is used only when the NominalMode property is BSCANNMODE_FINDCADNOMINAL and when the Method property is BSCANMETH_EDGE.

Description

Gets the parameters used in finding of scan nominals

Syntax

Visual Basic
Public Function GetNomsParams( _
   ByRef dFindNomsTolerance As Double, _
   ByRef dSurfaceThickness As Double, _
   ByRef dEdgeThickness As Double _
) As Boolean

Parameters

dFindNomsTolerance
Required Double variable that gets the Find Noms tolerance and is used only when the NominalMode property is BSCANNMODE_FINDCADNOMINAL.
dSurfaceThickness
Required Double variable that gets the surface thickness and is used only when the NominalMode property is BSCANNMODE_FINDCADNOMINAL.
dEdgeThickness
Required Double variable that gets the edge thickness and is used only when the NominalMode property is BSCANNMODE_FINDCADNOMINAL and when the Method property is BSCANMETH_EDGE.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

Scan Object


GetParams Method

GetParams Method
Method
Required Long variable that gets the Method property.
Filter
Required Long variable that gets the Filter property.
OperationMode
Required Long variable that gets the OperationMode property.
HitType
Required Long variable that gets the HitType property.
NominalMode
Required Long variable that gets the NominalMode property.
BoundaryCondition
Required Long variable that gets the BoundaryCondition property.

Description

Gets the basic scanning parameters of the scan This method is provided as a shortcut to getting these commonly used properties all at once.

Syntax

Visual Basic
Public Function GetParams( _
   ByRef Method As Long, _
   ByRef Filter As Long, _
   ByRef OperationMode As Long, _
   ByRef HitType As Long, _
   ByRef NominalMode As Long, _
   ByRef BoundaryCondition As Long _
) As Boolean

Parameters

Method
Required Long variable that gets the Method property.
Filter
Required Long variable that gets the Filter property.
OperationMode
Required Long variable that gets the OperationMode property.
HitType
Required Long variable that gets the HitType property.
NominalMode
Required Long variable that gets the NominalMode property.
BoundaryCondition
Required Long variable that gets the BoundaryCondition property.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

If scan is a Scan object, and M, F, O, H, N,and B are all dimensioned as Object, the following are equivalent:

scan.GetParams M, F, O, H, N, B

M = scan.Method
F = scan.Filter
O = scan.OperationMode
H = scan.HitType
N = scan.NominalMode
B = scan.BoundaryCondition

See Also

Scan Object


RemoveControlPoint Method

RemoveControlPoint Method
index

Description

Removes the control point at the specified index

Syntax

Visual Basic
Public Function RemoveControlPoint( _
   ByVal index As Long _
) As Boolean

Parameters

index

See Also

Scan Object


SetBoundaryConditionParams Method

SetBoundaryConditionParams Method
nCrossings
Required Long that sets the number of crossings for this boundary condition.
dRadius
Required Double that sets the radius of the boundary condition.
dHalfAngle
Required Double that sets the half-angle of the cone-type boundary condition, or is ignored if the boundary condition is not of cone type.

Description

Sets the boundary condition parameters

Syntax

Visual Basic
Public Function SetBoundaryConditionParams( _
   ByVal nCrossings As Long, _
   ByVal dRadius As Double, _
   ByVal dHalfAngle As Double _
) As Boolean

Parameters

nCrossings
Required Long that sets the number of crossings for this boundary condition.
dRadius
Required Double that sets the radius of the boundary condition.
dHalfAngle
Required Double that sets the half-angle of the cone-type boundary condition, or is ignored if the boundary condition is not of cone type.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

Boundary Condition | SetBoundaryConditionParams (nCrossings, dRadius, dHalfAngle)
Plane | Ncrossings
Cone | NCrossings,, dHalfAngle
Cylinder | NCrossings, dRadius
Sphere | NCrossings, dRadius

See Also

Scan Object


SetBoundaryPoint Method

SetBoundaryPoint Method
index
X
Y
Z

Description

Sets the boundary point specified by the index paramter

Syntax

Visual Basic
Public Function SetBoundaryPoint( _
   ByVal index As Long, _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double _
) As Boolean

Parameters

index
X
Y
Z

See Also

Scan Object


SetControlPoint Method

SetControlPoint Method
index
ControlPoint

Description

Sets the control point at the specified index

Syntax

Visual Basic
Public Function SetControlPoint( _
   ByVal index As Long, _
   ByVal ControlPoint As ControlPoint _
) As Boolean

Parameters

index
ControlPoint

See Also

Scan Object


SetFilterParams Method

SetFilterParams Method
dCutAxisLocation
Used for Manual scans with Filter property set to BSF_BODYAXISDISTANCE.
nAxis
Long variable that gets the cut axis. Returns non-zero only for axis filters. For axis filters, 0 means the X axis, 1 means the Y-axis, and 2 means the Z-axis.
dMaxIncrement
Double variable that gets the maximum increment. For fixed-length filters, this is simply the fixed increment. This is the Time delta valus in case the filter is BSF_TIME_DELTA or BSF_VARIABLEDISTANCE for Manual scans.
dMinIncrement
Double variable that gets the minimum increment for Variable Distance Filters. This is the Drop Point distance when a Manul scan is being used with the filter set to BSF_VARIABLEDISTANCE.
dMaxAngle
Double variable that gets the maximum angle used in Variable Distance Filters.
dMinAngle
Double variable that gets the minimum angle used in Variable Distance Filters.

Description

Sets parameters for filtering scan data

Syntax

Visual Basic
Public Function SetFilterParams( _
   ByVal dCutAxisLocation As Double, _
   ByVal nAxis As Long, _
   ByVal dMaxIncrement As Double, _
   ByVal dMinIncrement As Double, _
   ByVal dMaxAngle As Double, _
   ByVal dMinAngle As Double _
) As Boolean

Parameters

dCutAxisLocation
Used for Manual scans with Filter property set to BSF_BODYAXISDISTANCE.
nAxis
Long variable that gets the cut axis. Returns non-zero only for axis filters. For axis filters, 0 means the X axis, 1 means the Y-axis, and 2 means the Z-axis.
dMaxIncrement
Double variable that gets the maximum increment. For fixed-length filters, this is simply the fixed increment. This is the Time delta valus in case the filter is BSF_TIME_DELTA or BSF_VARIABLEDISTANCE for Manual scans.
dMinIncrement
Double variable that gets the minimum increment for Variable Distance Filters. This is the Drop Point distance when a Manul scan is being used with the filter set to BSF_VARIABLEDISTANCE.
dMaxAngle
Double variable that gets the maximum angle used in Variable Distance Filters.
dMinAngle
Double variable that gets the minimum angle used in Variable Distance Filters.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

Filter | SetFilterParams (dCutAxisLocation, nAxis, dMaxIncrement, dMinIncrement, dMaxAngle, dMinAngle)
Distance | ,,dMaxIncrement
BodyAxisDistance | ,nAxis, dMaxIncrement
VariableDistance | ,,dMaxIncrement, dMinIncrement, dMaxAngle, dMinAngle

See Also

Scan Object


SetHitParams Method

SetHitParams Method
nInitSamples
Required Long that sets the number of initial sample hits for the hits in this scan. It is ignored for basic hits and vector hits.
nPermSamples
Required Long that sets the number of permanent sample hits for the hits in this scan. It is ignored for basic hits and vector hits.
dSpacer
Required Double that sets the spacing of the sample hits from the hit center. It is ignored for basic hits and vector hits.
dIndent
Required Double that sets the indent of the sample hits from the hit center. It is ignored for basic hits, vector hits, and surface.
dDepth
Required Double that sets the depth of the sample hits from the hit center. It is ignored for basic hits, vector hits, and surface.

Description

Sets parameters for the hit type used in the scan

Syntax

Visual Basic
Public Function SetHitParams( _
   ByVal nInitSamples As Long, _
   ByVal nPermSamples As Long, _
   ByVal dSpacer As Double, _
   ByVal dIndent As Double, _
   ByVal dDepth As Double _
) As Boolean

Parameters

nInitSamples
Required Long that sets the number of initial sample hits for the hits in this scan. It is ignored for basic hits and vector hits.
nPermSamples
Required Long that sets the number of permanent sample hits for the hits in this scan. It is ignored for basic hits and vector hits.
dSpacer
Required Double that sets the spacing of the sample hits from the hit center. It is ignored for basic hits and vector hits.
dIndent
Required Double that sets the indent of the sample hits from the hit center. It is ignored for basic hits, vector hits, and surface.
dDepth
Required Double that sets the depth of the sample hits from the hit center. It is ignored for basic hits, vector hits, and surface.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

Scan Object


SetMethodParams Method

SetMethodParams Method
bIn
bCenteringType
nCenteringDirection
dDiameter
dArcAngle
dDepth
dPitch

Description

Sets the scan method parameters

Syntax

Visual Basic
Public Function SetMethodParams( _
   ByVal bIn As ENUM_SCAN_INOUT_TYPES, _
   ByVal bCenteringType As Boolean, _
   ByVal nCenteringDirection As Long, _
   ByVal dDiameter As Double, _
   ByVal dArcAngle As Double, _
   ByVal dDepth As Double, _
   ByVal dPitch As Double _
) As Boolean

Parameters

bIn
Value | Description
SCAN_INNER | Inside scans
SCAN_OUTER | Outside scans
SCAN_PLANAR | Plane Circle scans
bCenteringType
nCenteringDirection
dDiameter
dArcAngle
dDepth
dPitch

Remarks

See Also

Scan Object


SetMethodPointData Method

SetMethodPointData Method
MethodStart
Required PointData object that sets the MethodStart property.
MethodEnd
Required PointData object that sets the MethodEnd property.
MethodInitTouch
Required PointData object that sets the MethodInitTouch property.
MethodEndTouch
Required PointData object that sets the MethodEndTouch property.
MethodInitDir
Required PointData object that sets the MethodInitDir property.
MethodInitTopSurf
MethodCutPlane

Description

Sets scan points and vectors via pointdata objects This method is provided as a shortcut to setting these commonly used properties all at once.

Syntax

Visual Basic
Public Function SetMethodPointData( _
   ByVal MethodStart As PointData, _
   ByVal MethodEnd As PointData, _
   ByVal MethodInitTouch As PointData, _
   ByVal MethodEndTouch As PointData, _
   ByVal MethodInitDir As PointData, _
   ByVal MethodInitTopSurf As PointData, _
   ByVal MethodCutPlane As PointData _
) As Boolean

Parameters

MethodStart
Required PointData object that sets the MethodStart property.
MethodEnd
Required PointData object that sets the MethodEnd property.
MethodInitTouch
Required PointData object that sets the MethodInitTouch property.
MethodEndTouch
Required PointData object that sets the MethodEndTouch property.
MethodInitDir
Required PointData object that sets the MethodInitDir property.
MethodInitTopSurf
MethodCutPlane

See Also

Scan Object


SetNomsParams Method

SetNomsParams Method
dFindNomsTolerance
Required Double that sets the Find Noms tolerance.
dSurfaceThickness
Required Double that sets the surface thickness.
dEdgeThickness
Required Double that sets the edge thickness.

Description

Sets the parameters used in finding of scan nominals Boolean value. Boolean returns true if the function succeeds, false if it fails.

Syntax

Visual Basic
Public Function SetNomsParams( _
   ByVal dFindNomsTolerance As Double, _
   ByVal dSurfaceThickness As Double, _
   ByVal dEdgeThickness As Double _
) As Boolean

Parameters

dFindNomsTolerance
Required Double that sets the Find Noms tolerance.
dSurfaceThickness
Required Double that sets the surface thickness.
dEdgeThickness
Required Double that sets the edge thickness.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

Remarks

If scan is a ScanCommand object, and MS, ME, MIT, MET, MID,and MCP are all dimensioned as Object, the following are equivalent:

scan.SetMethodParams MS,ME,MIT,MET,MID,MCP

set scan.MethodStart = MS
set scan.MethodEnd = ME
set scan.MethodInitTouch = MIT
set scan.MethodEndTouch = MET
set scan.MethodInitDir = MID
set scan.MethodCutPlane = MCP

See Also

Scan Object


SetParams Method

SetParams Method
Method
Required Long that sets the Method property.
Filter
Required Long that sets the Filter property.
OperationMode
Required Long that sets the OperationMode property.
HitType
Required Long that sets the HitType property.
NominalMode
Required Long that sets the NominalMode property.
BoundaryCondition
Required Long that sets the BoundaryCondition property.

Description

Sets the basic scanning parameters of the scan

This method is provided as a shortcut to setting these commonly used properties all at once.

Syntax

Visual Basic
Public Function SetParams( _
   ByVal Method As Long, _
   ByVal Filter As Long, _
   ByVal OperationMode As Long, _
   ByVal HitType As Long, _
   ByVal NominalMode As Long, _
   ByVal BoundaryCondition As Long _
) As Boolean

Parameters

Method
Required Long that sets the Method property.
Filter
Required Long that sets the Filter property.
OperationMode
Required Long that sets the OperationMode property.
HitType
Required Long that sets the HitType property.
NominalMode
Required Long that sets the NominalMode property.
BoundaryCondition
Required Long that sets the BoundaryCondition property.

Return Type

Boolean value.

Remarks

If scan is a ScanCommand object, and M, F, O, H, N,and B are all dimensioned as Object, the following are equivalent:

scan.SetParams M, F, O, H, N, B

scan.Method = M
scan.Filter = F
scan.OperationMode = O
scan.HitType = H
scan.NominalMode = N
scan.BoundaryCondition = B

See Also

Scan Object


AutoClearPlane Property

AutoClearPlane Property

Description

Read/Write: Boolean value indicating if auto clear planes should be used

Property type

Read-write property

Syntax

Visual Basic
Public Property AutoClearPlane() As Boolean

See Also

Scan Object


BoundaryCondition Property

BoundaryCondition Property

Description

Read/Write: Boundary Condition (Sphere, Plane Cross, Cone, etc. Represents the boundary condition type.

Property type

Read-write property

Syntax

Visual Basic
Public Property BoundaryCondition() As BSBOUNDCOND_ENUM

Return Type

Read/write of enumeration BSBOUNDCOND_ENUM.

See Also

Scan Object


BoundaryConditionAxisV Property

BoundaryConditionAxisV Property

Description

Read/Write: Returns/Sets via point data object the boundary scan's axis vector This property represents the boundary condition axis vector. This vector is used as the axis of the Cylindrical and Conical BoundaryConditions.

Property type

Read-write property

Syntax

Visual Basic
Public Property BoundaryConditionAxisV() As PointData

Return Type

Read/write PointData object.

See Also

Scan Object


BoundaryConditionCenter Property

BoundaryConditionCenter Property

Description

Read/Write: Returns/Sets via point data object a boundary scan's center point This property represents the boundary condition center.

Property type

Read-write property

Syntax

Visual Basic
Public Property BoundaryConditionCenter() As PointData

Return Type

Read/write PointData object.

Remarks

This point is used by all Boundary Conditions and is the location of the Boundary Condition.

See Also

Scan Object


BoundaryConditionEndApproach Property

BoundaryConditionEndApproach Property

Description

Read/Write: Returns/Sets via point data object the end approach for a boundary scan

This property represents the boundary condition end approach vector.

Property type

Read-write property

Syntax

Visual Basic
Public Property BoundaryConditionEndApproach() As PointData

Return Type

Read/write PointData object.

Remarks

This vector is used by all Boundary Conditions and is the Approach Vector of the Probe as it crosses the Boundary condition.

See Also

Scan Object


BoundaryConditionPlaneV Property

BoundaryConditionPlaneV Property

Description

Read/Write: Returns/Sets via point data object the boundary scan's plane vector This property represents the boundary condition plane vector. This vector is the normal vector of the plane used by the Plane and OldStyle Boundary Conditions.

Property type

Read-write property

Syntax

Visual Basic
Public Property BoundaryConditionPlaneV() As PointData

Return Type

Read/write PointData object.

Remarks

Boundary Condition | Properties Required
Plane | BoundaryConditionCenter BoundaryConditionEndApproach BoundaryConditionPlaneV
Cone | BoundaryConditionCenter BoundaryConditionEndApproach BoundaryConditionAxisV
Cylinder | BoundaryConditionCenter BoundaryConditionEndApproach BoundaryConditionAxisV
Sphere | BoundaryConditionCenter BoundaryConditionEndApproach

See Also

Scan Object


BoundaryPointCount Property

BoundaryPointCount Property

Description

Read/Write: Long value indicating the number of boundary points for patch scans

Property type

Read-write property

Syntax

Visual Basic
Public Property BoundaryPointCount() As Long

See Also

Scan Object


DisplayHits Property

DisplayHits Property

Description

Read/Write: Boolean value indicating whether hits should be displayed or not

Property type

Read-write property

Syntax

Visual Basic
Public Property DisplayHits() As Boolean

See Also

Scan Object


Filter Property

Filter Property

Description

Read/Write: Distance Filter Type This property represents the filter type. Read/write of enumeration BSF_ENUM.

Property type

Read-write property

Syntax

Visual Basic
Public Property Filter() As BSF_ENUM

See Also

Scan Object


HitType Property

HitType Property

Description

Read/Write: Scan Hit Type (Vector, Surface, Edge)

Represents the type of hit to use.

Property type

Read-write property

Syntax

Visual Basic
Public Property HitType() As BSCANHIT_ENUM

Return Type

Read/write of enumeration BSCANHIT_ENUM.

Remarks

Not every hit type can be used with every method and filter combination.

Example

Method | Vector Hit | Surface Hit | Basic Hit | Edge Hit
Open | Y | Y | - | Y
Close | Y | Y | - | Y
Patch | Y | Y | - | Y
HardProb | - | - | - | Y
TTP | - | - | - | Y

See Also

Scan Object


Method Property

Method Property

Description

Read/Write: Scan Type This property represents the method type for this scan.

Property type

Read-write property

Syntax

Visual Basic
Public Property Method() As BSCANMETH_ENUM

Return Type

Read/write of enumeration BSMETHOD_ENUM.

See Also

Scan Object


MethodCutPlane Property

MethodCutPlane Property

Description

Read/Write: Returns/Sets via point data object the cut plane vector

This property represents the method’s cut plane vector.

Property type

Read-write property

Syntax

Visual Basic
Public Property MethodCutPlane() As PointData

Return Type

Read/write PointData object.

See Also

Scan Object


MethodEnd Property

MethodEnd Property

Description

Read/Write: Returns/Sets via point data object the ending scan point

This property represents the scan’s end point.

Property type

Read-write property

Syntax

Visual Basic
Public Property MethodEnd() As PointData

Return Type

Read/write PointData object.

See Also

Scan Object


MethodEndTouch Property

MethodEndTouch Property

Description

Read/Write: Returns/Sets via point data object the end touch vector

This property represents the method’s end touch vector.

Property type

Read-write property

Syntax

Visual Basic
Public Property MethodEndTouch() As PointData

Return Type

Read/write PointData object.

See Also

Scan Object


MethodInitDir Property

MethodInitDir Property

Description

Read/Write: Returns/Sets via point data object the initial scan direction vector

This property represents the method’s initial direction vector.

Property type

Read-write property

Syntax

Visual Basic
Public Property MethodInitDir() As PointData

Return Type

Read/write PointData object.

See Also

Scan Object


MethodInitTopSurf Property

MethodInitTopSurf Property

Description

Read/Write: Returns/Sets via point data object the initial top surface vector

This property represents the initial Surface Vector for the Edge method.

Property type

Read-write property

Syntax

Visual Basic
Public Property MethodInitTopSurf() As PointData

Return Type

Read/write PointData object.

See Also

Scan Object


MethodInitTouch Property

MethodInitTouch Property

Description

Read/Write: Returns/Sets via point data object the initial touch vector

This represents the method’s initial touch vector.

Property type

Read-write property

Syntax

Visual Basic
Public Property MethodInitTouch() As PointData

Return Type

Read/write PointData object.

See Also

Scan Object


MethodStart Property

MethodStart Property

Description

Read/Write: Returns/Sets via point data object the starting scan point This property represents the scan’s start point.

Property type

Read-write property

Syntax

Visual Basic
Public Property MethodStart() As PointData

Return Type

Read/write PointData object.

Remarks

Method | Method Start | Method End | Method Cutplane | Method InitDir | Method InitTouch | Method InitTopSurf | Method EndTouch
Open | Y | Y | Y | Y | Y | - | Y
Close | Y | Y | Y | Y | Y | - | -
Patch | - | - | Y | Y | Y | - | Y
TTP | - | - | Y | Y | Y | - | -
HardProbe | Y | Y | Y | Y | Y | - | -

See Also

Scan Object


NominalMode Property

NominalMode Property

Description

Read/Write: Find cad nominals or use master data This property represents how to determine the nominals for this scan.

Property type

Read-write property

Syntax

Visual Basic
Public Property NominalMode() As BSCANNMODE_ENUM

Return Type

Read/write of enumeration BSCANNMODE_ENUM.

See Also

Scan Object


OperationMode Property

OperationMode Property

Description

Read/Write: Scan Operation Mode This property represents mode of operation of the scan.

Property type

Read-write property

Syntax

Visual Basic
Public Property OperationMode() As BSCANOPMODE_ENUM

Return Type

Read/write of enumeration BSOPMODE_ENUM.

Remarks

Method | Regular Learn | Defined Path | Normal
Open | Y | - | Y
Close | Y | - | Y
Patch | Y | - | Y
TTP | Y | - | Y
HardProbe | Y | - | Y

See Also

Scan Object


SinglePoint Property

SinglePoint Property

Description

Read/Write: Returns/Sets Single Point Mode Flag

Property type

Read-write property

Syntax

Visual Basic
Public Property SinglePoint() As Boolean

See Also

Scan Object


Section Object

Section Object
See Also Members

Description

The Section object lets you manipulate a particular section from the collection of available Selections used by a report template.

Object Model

See Also

Section Members


Section Object Members

Section ObjectMembers
See Also Overview

Public Properties

Public Property _Name |
Public Property Application | Read Only: returns the Application Object This property returns the PC-DMIS Application object.
Public Property Height | Read/Write: Returns/Sets Section Height This property sets or returns the section's height.
Public Property Name | Read/Write: represents the name of the section This property returns or sets the name of the section.
Public Property Number | Read Only: returns the number of the section This returns a read-only Long value of the index number of the current section within the Sections object. This is used with the Sections.Item property to access the current section later.
Public Property Parent | Read Only: returns the parent Sections object This property returns a read-only parent object of the Section, the Sections object.
Public Property ReportControls | Read Only: returns the ReportControls object for this section This property returns the ReportControls object for this section. You can then access the ReportControls object to dynamically add or modify existing objects in the section.
Public Property Width | Read/Write: Returns/Sets Section Width This property sets or returns the section's height.

See Also

Section Overview


_Name Property

_Name Property

Property type

Read-write property

Syntax

Visual Basic
Public Property _Name() As String

See Also

Section Object


Application Property

Application Property

Description

Read Only: returns the Application Object This property returns the PC-DMIS Application object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

Section Object


Height Property

Height Property

Description

Read/Write: Returns/Sets Section Height This property sets or returns the section's height.

Property type

Read-write property

Syntax

Visual Basic
Public Property Height() As Long

Return Type

Read/write Long value.

See Also

Section Object


Name Property

Name Property

Description

Read/Write: represents the name of the section This property returns or sets the name of the section.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As String

Return Type

Read/write String value.

See Also

Section Object


Number Property

Number Property

Description

Read Only: returns the number of the section This returns a read-only Long value of the index number of the current section within the Sections object. This is used with the Sections.Item property to access the current section later.

Property type

Read-write property

Syntax

Visual Basic
Public Property Number() As Long

Return Type

Long value.

See Also

Section Object | Item Method


Parent Property

Parent Property

Description

Read Only: returns the parent Sections object This property returns a read-only parent object of the Section, the Sections object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Sections

See Also

Section Object


ReportControls Property

ReportControls Property

Description

Read Only: returns the ReportControls object for this section This property returns the ReportControls object for this section. You can then access the ReportControls object to dynamically add or modify existing objects in the section.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReportControls() As ReportControls

Return Type

ReportControls object.

See Also

Section Object


Width Property

Width Property

Description

Read/Write: Returns/Sets Section Width This property sets or returns the section's height.

Property type

Read-write property

Syntax

Visual Basic
Public Property Width() As Long

Return Type

Read/write Long value.

See Also

Section Object


Sections Object

Sections Object
See Also Members

Description

The Sections object contains a collection of all existing Section tabs for a given report template in PC-DMIS's Report Template editor.

Object Model

Remarks

Use Sections.Add to create a new section and add it to the Sections collection.

Use Sections(index) where index is a section's name or index number to access the section.

See Also

Sections Members


Sections Object Members

Sections ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method Add | Adds a new section to the end of the template with the given name This method adds a new section to the end of the template with the given name
Public Method InsertSectionBefore | Inserts a new section before the named section This method inserts a new section before the named section. The new section will have the default internal name of "section" followed by a number.
Public Method Item | Selects a section by name or number This method returns the Section object identified by the NameOrNum parameter.
Public Method Remove | Removes a section by name or number This method removes or deletes the Section object identified by the NameOrNum parameter.

Public Properties

Public Property Application | Read Only: Returns the Application Object This property returns the PC-DMIS Application object.
Public Property Count | Read Only: Returns the number of sections Counts the number of sections in the Sections object.
Public Property Parent | Read Only: Returns the parent Template Object Returns this object's Parent object, in this case, a ReportTemplate object.

See Also

Sections Overview


_Item Method

_Item Method
NameOrNumber

Syntax

Visual Basic
Public Function _Item( _
   ByVal NameOrNumber As Variant _
) As Section

Parameters

NameOrNumber

See Also

Sections Object


Add Method

Add Method
Name
Required string value that defines the name of the new section you want to add.

Description

Adds a new section to the end of the template with the given name This method adds a new section to the end of the template with the given name

Syntax

Visual Basic
Public Function Add( _
   ByVal Name As String _
) As Section

Parameters

Name
Required string value that defines the name of the new section you want to add.

See Also

Sections Object


InsertSectionBefore Method

InsertSectionBefore Method
Name
Required String value that defines the name of the existing section before which the new section will be inserted.

Description

Inserts a new section before the named section

This method inserts a new section before the named section. The new section will have the default internal name of "section" followed by a number.

Syntax

Visual Basic
Public Function InsertSectionBefore( _
   ByVal Name As String _
) As Section

Parameters

Name
Required String value that defines the name of the existing section before which the new section will be inserted.

See Also

Sections Object


Item Method

Item Method
NameOrNumber
Required Variant that indicates which Section object to return. It can be either a Long or a String. If it is a Long, it is the index number of the Section object in the Sections collection. If it is a String, it is the ID, or name, of the Section object.

Description

Selects a section by name or number This method returns the Section object identified by the NameOrNum parameter.

Syntax

Visual Basic
Public Function Item( _
   ByVal NameOrNumber As Variant _
) As Section

Parameters

NameOrNumber
Required Variant that indicates which Section object to return. It can be either a Long or a String. If it is a Long, it is the index number of the Section object in the Sections collection. If it is a String, it is the ID, or name, of the Section object.

See Also

Sections Object


Remove Method

Remove Method
NameOrNumber
Required Variant that indicates which Section object to remove. It can be either a Long or a String. If it is a Long, it is the index number of the Section object in the Sections collection. If it is a String, it is the ID, or name, of the Section object.

Description

Removes a section by name or number

This method removes or deletes the Section object identified by the NameOrNum parameter.

Syntax

Visual Basic
Public Function Remove( _
   ByVal NameOrNumber As Variant _
) As Boolean

Parameters

NameOrNumber
Required Variant that indicates which Section object to remove. It can be either a Long or a String. If it is a Long, it is the index number of the Section object in the Sections collection. If it is a String, it is the ID, or name, of the Section object.

Return Type

Boolean value that determines whether or not the specified section was removed. If True then the section was removed. If False then the section either remained or didn't exist in the first place.

See Also

Sections Object


Application Property

Application Property

Description

Read Only: Returns the Application Object This property returns the PC-DMIS Application object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

Sections Object


Count Property

Count Property

Description

Read Only: Returns the number of sections Counts the number of sections in the Sections object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

Return Type

Long value with the number of sections.

See Also

Sections Object


Parent Property

Parent Property

Description

Read Only: Returns the parent Template Object Returns this object's Parent object, in this case, a ReportTemplate object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As ReportTemplate

Return Type

ReportTemplate object.

See Also

Sections Object


STATISTICS Object

STATISTICS Object
See Also Members

Description

The Statistics object gives access to the properties and data members of the PC-DMIS Statistics command.

See Also

STATISTICS Members


STATISTICS Object Members

STATISTICS ObjectMembers
See Also Overview

Public Methods

Public Method AddStatsDir | Adds a datapage database directory Adds a directory to the list of statistics directory.
Public Method GetStatsDir | Gets the indexed datapage database directory Returns the specified stats directory.
Public Method RemoveStatsDir | Removes the indexed datapage database directory Removes a directory from list of stats directories.
Public Method SetStatsDir | Sets the indexed datapage database directory Sets a specfied stats directory.

Public Properties

Public Property CalcMode | Read/Write: Indicates whether datapage will do control calculations Determines whether the calculation mode inside of DataPage is turned off or on.
Public Property MemoryPages | Read/Write: Datapage code for number of memory pages Returns the number of memory pages to be used by DataPage.
Public Property NameType | Read/Write: Use the feature ID or dimension ID ENUM_STAT_NAME_TYPES enumeration value indicating whether the feature name or the dimension name should be sent to DataPage. If set to PCD_STAT_FEAT_NAME (1), the feature name is used. If set to PCD_STAT_DIM_NAME (0), the dimension name is used.
Public Property ReadLock | Read/Write: Datapage code for reading lock Long value representing the number of seconds in timeout period that DataPage uses when trying to read the port lock.
Public Property StatMode | Read/Write: Statistics mode (ie. Off, On, Transfer, etc.) ENUM_PCD_STAT_TYPES enumeration value representing the mode or function of the statistics command.
Public Property TransferDir | Read/Write: Directory to move stat file to String value indicating the directory to which to move the stat file.
Public Property WriteLock | Read/Write: Datapage code for writing lock Long value representing number of seconds in timeout period that DataPage uses when trying to write to the port lock.

See Also

STATISTICS Overview


AddStatsDir Method

AddStatsDir Method
Dir
Required String representing the name of the directory to be added to the list of statistics directories.

Description

Adds a datapage database directory Adds a directory to the list of statistics directory.

Syntax

Visual Basic
Public Function AddStatsDir( _
   ByVal Dir As String _
) As Boolean

Parameters

Dir
Required String representing the name of the directory to be added to the list of statistics directories.

Return Type

Boolean value indicating success or failure of call to method.

See Also

STATISTICS Object


GetStatsDir Method

GetStatsDir Method
index
Required Long representing the index of the directory name to be retrieved.

Description

Gets the indexed datapage database directory Returns the specified stats directory.

Syntax

Visual Basic
Public Function GetStatsDir( _
   ByVal index As Long _
) As String

Parameters

index
Required Long representing the index of the directory name to be retrieved.

Return Type

Read-only String value representing the name of the stats directory at the specified index value. If index value is greater than the number of directories in the list, the string will be empty.

See Also

STATISTICS Object


RemoveStatsDir Method

RemoveStatsDir Method
index
Required Long representing the line of text to be removed.

Description

Removes the indexed datapage database directory Removes a directory from list of stats directories.

Syntax

Visual Basic
Public Function RemoveStatsDir( _
   ByVal index As Long _
) As Boolean

Parameters

index
Required Long representing the line of text to be removed.

Return Type

Boolean value indicating success or failure of call to remove directory from the list of directories. If index is greater than the number of directories in the list, the call will fail.

See Also

STATISTICS Object


SetStatsDir Method

SetStatsDir Method
index
Required Long representing the directory name to change.
Dir
Required String which is the new name of the directory.

Description

Sets the indexed datapage database directory Sets a specfied stats directory.

Syntax

Visual Basic
Public Function SetStatsDir( _
   ByVal index As Long, _
   ByVal Dir As String _
) As Boolean

Parameters

index
Required Long representing the directory name to change.
Dir
Required String which is the new name of the directory.

Return Type

Boolean value indicating success or failure of call to set name of the directory specified by Index. If the index value is greater than the number of directories, the call will fail.

See Also

STATISTICS Object


CalcMode Property

CalcMode Property

Description

Read/Write: Indicates whether datapage will do control calculations

Determines whether the calculation mode inside of DataPage is turned off or on.

Property type

Read-write property

Syntax

Visual Basic
Public Property CalcMode() As ENUM_PCD_ON_OFF

Return Type

Read/write enumerated ENUM_PCD_ON_OFF value.

See Also

STATISTICS Object


MemoryPages Property

MemoryPages Property

Description

Read/Write: Datapage code for number of memory pages Returns the number of memory pages to be used by DataPage.

Property type

Read-write property

Syntax

Visual Basic
Public Property MemoryPages() As Long

Return Type

Read/write Long value.

See Also

STATISTICS Object


NameType Property

NameType Property

Description

Read/Write: Use the feature ID or dimension ID

ENUM_STAT_NAME_TYPES enumeration value indicating whether the feature name or the dimension name should be sent to DataPage. If set to PCD_STAT_FEAT_NAME (1), the feature name is used. If set to PCD_STAT_DIM_NAME (0), the dimension name is used.

Property type

Read-write property

Syntax

Visual Basic
Public Property NameType() As ENUM_STAT_NAME_TYPES

Return Type

Read/write ENUM_STAT_NAME_TYPES enumeration.

See Also

STATISTICS Object


ReadLock Property

ReadLock Property

Description

Read/Write: Datapage code for reading lock Long value representing the number of seconds in timeout period that DataPage uses when trying to read the port lock.

Property type

Read-write property

Syntax

Visual Basic
Public Property ReadLock() As Long

Return Type

Long value.

See Also

STATISTICS Object


StatMode Property

StatMode Property

Description

Read/Write: Statistics mode (ie. Off, On, Transfer, etc.)

ENUM_PCD_STAT_TYPES enumeration value representing the mode or function of the statistics command.

Property type

Read-write property

Syntax

Visual Basic
Public Property StatMode() As ENUM_PCD_STAT_TYPES

Return Type

Read/Write ENUM_PCD_STAT_TYPES enumeration.

See Also

STATISTICS Object


TransferDir Property

TransferDir Property

Description

Read/Write: Directory to move stat file to String value indicating the directory to which to move the stat file.

Property type

Read-write property

Syntax

Visual Basic
Public Property TransferDir() As String

Return Type

Read/write String value.

See Also

STATISTICS Object


WriteLock Property

WriteLock Property

Description

Read/Write: Datapage code for writing lock Long value representing number of seconds in timeout period that DataPage uses when trying to write to the port lock.

Property type

Read-write property

Syntax

Visual Basic
Public Property WriteLock() As Long

Return Type

Read/write Long value.

See Also

STATISTICS Object


Target Object

Target Object
See Also Members

See Also

Target Members


Target Object Members

Target ObjectMembers
See Also Overview

Public Properties

Public Property CrossHairSize | Read/Write: Returns target crosshair size
Public Property EdgeScanDirection | Read/Write: Returns target edge scan direction
Public Property EdgeSelectionSpecifiedNum | Read/Write: Returns target edge selection specified number
Public Property EdgeSelectionType | Read/Write: Returns target edge selection type
Public Property Focus | Read/Write: Returns target focus setting
Public Property FocusDuration | Read/Write: Returns target focus duration
Public Property FocusHiAccuracy | Read/Write: Returns target focus high accuracy setting
Public Property FocusRange | Read/Write: Returns target focus range
Public Property OutlierFilter | Read/Write: Returns target outlier filter setting
Public Property OutlierFilterDistanceThreshold | Read/Write: Returns target outlier filter diatance threshold
Public Property OutlierFilterStdDevThreshold | Read/Write: Returns target outlier filter standard deviation threshold
Public Property PointDensityType | Read/Write: Returns target point density type
Public Property Strength | Read/Write: Returns target edge strength

See Also

Target Overview


CrossHairSize Property

CrossHairSize Property

Description

Read/Write: Returns target crosshair size

Property type

Read-write property

Syntax

Visual Basic
Public Property CrossHairSize() As Double

See Also

Target Object


EdgeScanDirection Property

EdgeScanDirection Property

Description

Read/Write: Returns target edge scan direction

Property type

Read-write property

Syntax

Visual Basic
Public Property EdgeScanDirection() As Integer

See Also

Target Object


EdgeSelectionSpecifiedNum Property

EdgeSelectionSpecifiedNum Property

Description

Read/Write: Returns target edge selection specified number

Property type

Read-write property

Syntax

Visual Basic
Public Property EdgeSelectionSpecifiedNum() As Integer

See Also

Target Object


EdgeSelectionType Property

EdgeSelectionType Property

Description

Read/Write: Returns target edge selection type

Property type

Read-write property

Syntax

Visual Basic
Public Property EdgeSelectionType() As ENUM_VISION_TARGET_EDGE_SELECTION

See Also

Target Object


Focus Property

Focus Property

Description

Read/Write: Returns target focus setting

Property type

Read-write property

Syntax

Visual Basic
Public Property Focus() As Long

See Also

Target Object


FocusDuration Property

FocusDuration Property

Description

Read/Write: Returns target focus duration

Property type

Read-write property

Syntax

Visual Basic
Public Property FocusDuration() As Integer

See Also

Target Object


FocusHiAccuracy Property

FocusHiAccuracy Property

Description

Read/Write: Returns target focus high accuracy setting

Property type

Read-write property

Syntax

Visual Basic
Public Property FocusHiAccuracy() As Long

See Also

Target Object


FocusRange Property

FocusRange Property

Description

Read/Write: Returns target focus range

Property type

Read-write property

Syntax

Visual Basic
Public Property FocusRange() As ENUM_VISION_TARGET_FOCUS_RANGE

See Also

Target Object


OutlierFilter Property

OutlierFilter Property

Description

Read/Write: Returns target outlier filter setting

Property type

Read-write property

Syntax

Visual Basic
Public Property OutlierFilter() As Long

See Also

Target Object


OutlierFilterDistanceThreshold Property

OutlierFilterDistanceThreshold Property

Description

Read/Write: Returns target outlier filter diatance threshold

Property type

Read-write property

Syntax

Visual Basic
Public Property OutlierFilterDistanceThreshold() As Double

See Also

Target Object


OutlierFilterStdDevThreshold Property

OutlierFilterStdDevThreshold Property

Description

Read/Write: Returns target outlier filter standard deviation threshold

Property type

Read-write property

Syntax

Visual Basic
Public Property OutlierFilterStdDevThreshold() As Double

See Also

Target Object


PointDensityType Property

PointDensityType Property

Description

Read/Write: Returns target point density type

Property type

Read-write property

Syntax

Visual Basic
Public Property PointDensityType() As ENUM_VISION_TARGET_POINT_DENSITY

See Also

Target Object


Strength Property

Strength Property

Description

Read/Write: Returns target edge strength

Property type

Read-write property

Syntax

Visual Basic
Public Property Strength() As Integer

See Also

Target Object


Targets Object

Targets Object
See Also Members

Object Model

See Also

Targets Members


Targets Object Members

Targets ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method Add | Adds the target object to the targets collection
Public Method Item | Returns the target object referenced by the Num parameter
Public Method Remove | Removes the taret object referenced by the Num parameter from the targets collection

Public Properties

Public Property Application | Read Only: Returns the Application Object
Public Property Count | Read Only: Returns the current number of targets
Public Property Parent | Read Only: Returns the parent Feature Object

See Also

Targets Overview


_Item Method

_Item Method
Num

Syntax

Visual Basic
Public Function _Item( _
   ByVal Num As Long _
) As Target

Parameters

Num

See Also

Targets Object


Add Method

Add Method
a
b

Description

Adds the target object to the targets collection

Syntax

Visual Basic
Public Sub Add( _
   ByVal a As Double, _
   ByVal b As Double _
)

Parameters

a
b

See Also

Targets Object


Item Method

Item Method
Num

Description

Returns the target object referenced by the Num parameter

Syntax

Visual Basic
Public Function Item( _
   ByVal Num As Long _
) As Target

Parameters

Num

See Also

Targets Object


Remove Method

Remove Method
Num

Description

Removes the taret object referenced by the Num parameter from the targets collection

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Num As Long _
)

Parameters

Num

See Also

Targets Object


Application Property

Application Property

Description

Read Only: Returns the Application Object

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

See Also

Targets Object


Count Property

Count Property

Description

Read Only: Returns the current number of targets

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

See Also

Targets Object


Parent Property

Parent Property

Description

Read Only: Returns the parent Feature Object

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As FeatCmd

See Also

Targets Object


TempComp Object

TempComp Object
See Also Members

Description

The TempComp object gives access to the properties of the PC-DMIS Temperature Compensation command. For additional information about Temperature Compensation, see "Compensating for Temperature" in the "Setting Your Preferences" section of the PC-DMIS Help File.

See Also

TempComp Members


TempComp Object Members

TempComp ObjectMembers
See Also Overview

Public Methods

Public Method GetOrigin | Gets the reference origin
Public Method SetOrigin | Sets the reference origin

Public Properties

Public Property HighThreshold | Read/Write: High temperature threshold Double value representing the high temperature threshold.
Public Property LowTheshold | Read/Write: Low temperature threshold Double value representing the low temperature threshold.
Public Property MaterialCoefficient | Read/Write: Material Coefficient Double value indicating the material coefficient.
Public Property RefTemp | Read/Write: Reference temperature Double value representing the reference temperature.
Public Property Sensors | Read/Write: Comma/Dash delimited list of sensor numbers (ie. '1-3,5') String value representing the list of sensors--by number--to be used for temperature compensation. The format of the list is a series of consecutive sensor numbers. The series are specified using the hyphen between the first number and the last number of the series. Each non-consecutive sensor or group of sensors is separated by the comma (or the typical separator for the given locale).

See Also

TempComp Overview


GetOrigin Method

GetOrigin Method
X
Required Long variable that receives the X value of the temperature compensation origin.
Y
Required Long variable that receives the Y value of the temperature compensation origin.
Z
Required Long variable that receives the Z value of the temperature compensation origin.

Description

Gets the reference origin

Syntax

Visual Basic
Public Function GetOrigin( _
   ByRef X As Double, _
   ByRef Y As Double, _
   ByRef Z As Double _
) As Boolean

Parameters

X
Required Long variable that receives the X value of the temperature compensation origin.
Y
Required Long variable that receives the Y value of the temperature compensation origin.
Z
Required Long variable that receives the Z value of the temperature compensation origin.

Return Type

Boolean value.

See Also

TempComp Object


SetOrigin Method

SetOrigin Method
X
Required Long that sets the X value of the temperature compensation origin.
Y
Required Long that sets the Y value of the temperature compensation origin.
Z
Required Long that sets the Z value of the temperature compensation origin.

Description

Sets the reference origin

Syntax

Visual Basic
Public Function SetOrigin( _
   ByVal X As Double, _
   ByVal Y As Double, _
   ByVal Z As Double _
) As Boolean

Parameters

X
Required Long that sets the X value of the temperature compensation origin.
Y
Required Long that sets the Y value of the temperature compensation origin.
Z
Required Long that sets the Z value of the temperature compensation origin.

Return Type

Boolean value.

See Also

TempComp Object


HighThreshold Property

HighThreshold Property

Description

Read/Write: High temperature threshold

Double value representing the high temperature threshold.

Property type

Read-write property

Syntax

Visual Basic
Public Property HighThreshold() As Double

Return Type

Read/write Double

See Also

TempComp Object


LowTheshold Property

LowTheshold Property

Description

Read/Write: Low temperature threshold

Double value representing the low temperature threshold.

Property type

Read-write property

Syntax

Visual Basic
Public Property LowTheshold() As Double

Return Type

Read/write Double

See Also

TempComp Object


MaterialCoefficient Property

MaterialCoefficient Property

Description

Read/Write: Material Coefficient

Double value indicating the material coefficient.

Property type

Read-write property

Syntax

Visual Basic
Public Property MaterialCoefficient() As Double

Return Type

Read/write Double.

See Also

TempComp Object


RefTemp Property

RefTemp Property

Description

Read/Write: Reference temperature

Double value representing the reference temperature.

Property type

Read-write property

Syntax

Visual Basic
Public Property RefTemp() As Double

Return Type

Read/write Double value.

See Also

TempComp Object


Sensors Property

Sensors Property

Description

Read/Write: Comma/Dash delimited list of sensor numbers (ie. '1-3,5')

String value representing the list of sensors--by number--to be used for temperature compensation. The format of the list is a series of consecutive sensor numbers. The series are specified using the hyphen between the first number and the last number of the series. Each non-consecutive sensor or group of sensors is separated by the comma (or the typical separator for the given locale).

Property type

Read-write property

Syntax

Visual Basic
Public Property Sensors() As String

Return Type

Read/write String value.

Example

Example: The sensors 2, 4, 5, 6, 8, 10, 11, 12, 13 would be represented as "2,4-6,8,10-13".

See Also

TempComp Object


Tip Object

Tip Object
See Also Members

Description

Probe Tip Object The Tip object describes a single tip of a probe. All of its properties are read-only.

Object Model

See Also

Tip Members


Tip Object Members

Tip ObjectMembers
See Also Overview

Public Properties

Public Property a | Read Only: Returns the tilt of the tip Returns the A angle of the tip.
Public Property b | Read Only: Returns the rotation of the tip Returns the B angle of the tip.
Public Property C | Read Only: Returns the C angle of the tip
Public Property Date | Read Only: Gets/Sets string representing date of the last calibration of the tip in the format mm/dd/yy Returns the PC-DMIS representation of the most recent calibration date of the tip.
Public Property diam | Read/Write: Gets/Sets the theoretical diameter of the tip Returns the diameter of the tip.
Public Property ID | Read Only: Returns the ID of the tip Returns the ID string of the tip.
Public Property IJK | Read Only: Returns a point data object with the measured vector of the tip A PointData object that returns the vector along which the tip lies. Read-only.
Public Property MeasDiam | Read/Write: Gets/Sets the measured diameter of the tip
Public Property MeasThickness | Read Only: Returns the measured thickness of the the tip
Public Property MeasXYZ | Read/Write: Gets/Sets the measured XYZ data of the tip
Public Property Nickname | Read/Write: Gets/Sets the tip's nickname
Public Property Parent | Read Only: Returns the parent tips object Returns the Tips collection object that contains this tip.
Public Property PrbRdv | Read Only: Returns the PRBRDV value for an analog probe calibration
Public Property Selected | Read/Write: Determines whether tip is selected to be qualified Determines whether tip is selected for qualification.
Public Property StandardDeviation | Read Only: Returns the standard deviation of the measured sphere after tip qualification
Public Property Thickness | Read Only: Returns the theoretical thickness of the tip Returns the nominal thickness of the tip.
Public Property Time | Read Only: Gets/Sets string representing time of the last calibration of the tip in the format HH:MM:SS Returns the PC-DMIS representation of the most recent calibration time of the tip.
Public Property TipNum | Read Only: Returns the tip number of the tip Returns the tip number in the list of tips.
Public Property TipType | Read Only: Returns the tip type of the tip Returns the type of the tip.
Public Property WristOffset | Read/Write: Returns a point data object with the wrist offset of the tip Returns the wrist offset of the tip.
Public Property WristTipIJK | Read Only: Returns a point data object with the theoretical vector of the tip Returns the wrist tip vector of the tip.
Public Property XYZ | Read/Write: Gets/Sets the theoretical XYZ data of the tip Returns the location of the tip.

See Also

Tip Overview


a Property

a Property

Description

Read Only: Returns the tilt of the tip

Returns the A angle of the tip.

Property type

Read-write property

Syntax

Visual Basic
Public Property a() As Double

Return Type

Read-only Double value.

See Also

Tip Object


b Property

b Property

Description

Read Only: Returns the rotation of the tip

Returns the B angle of the tip.

Property type

Read-write property

Syntax

Visual Basic
Public Property b() As Double

Return Type

Read-only Double value.

See Also

Tip Object


C Property

C Property

Description

Read Only: Returns the C angle of the tip

Property type

Read-write property

Syntax

Visual Basic
Public Property C() As Double

See Also

Tip Object


Date Property

Date Property

Description

Read Only: Gets/Sets string representing date of the last calibration of the tip in the format mm/dd/yy Returns the PC-DMIS representation of the most recent calibration date of the tip.

Property type

Read-write property

Syntax

Visual Basic
Public Property Date() As String

Return Type

Read-only String value.

See Also

Tip Object


diam Property

diam Property

Description

Read/Write: Gets/Sets the theoretical diameter of the tip Returns the diameter of the tip.

Property type

Read-write property

Syntax

Visual Basic
Public Property diam() As Double

Return Type

Read/write Double value.

See Also

Tip Object


ID Property

ID Property

Description

Read Only: Returns the ID of the tip Returns the ID string of the tip.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As String

Return Type

String value.

See Also

Tip Object


IJK Property

IJK Property

Description

Read Only: Returns a point data object with the measured vector of the tip A PointData object that returns the vector along which the tip lies. Read-only.

Property type

Read-write property

Syntax

Visual Basic
Public Property IJK() As PointData

Return Type

PointData object

See Also

Tip Object


MeasDiam Property

MeasDiam Property

Description

Read/Write: Gets/Sets the measured diameter of the tip

Property type

Read-write property

Syntax

Visual Basic
Public Property MeasDiam() As Double

Return Type

Read-only Double value.

See Also

Tip Object


MeasThickness Property

MeasThickness Property

Description

Read Only: Returns the measured thickness of the the tip

Property type

Read-write property

Syntax

Visual Basic
Public Property MeasThickness() As Double

Return Type

Read-only Double value.

See Also

Tip Object


MeasXYZ Property

MeasXYZ Property

Description

Read/Write: Gets/Sets the measured XYZ data of the tip

Property type

Read-write property

Syntax

Visual Basic
Public Property MeasXYZ() As PointData

Return Type

Read-only Double value.

See Also

Tip Object


Nickname Property

Nickname Property

Description

Read/Write: Gets/Sets the tip's nickname

Property type

Read-write property

Syntax

Visual Basic
Public Property Nickname() As String

See Also

Tip Object


Parent Property

Parent Property

Description

Read Only: Returns the parent tips object Returns the Tips collection object that contains this tip.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Tips

Return Type

Read-only Tips object.

See Also

Tip Object


PrbRdv Property

PrbRdv Property

Description

Read Only: Returns the PRBRDV value for an analog probe calibration

Property type

Read-write property

Syntax

Visual Basic
Public Property PrbRdv() As Double

See Also

Tip Object


Selected Property

Selected Property

Description

Read/Write: Determines whether tip is selected to be qualified Determines whether tip is selected for qualification.

Property type

Read-write property

Syntax

Visual Basic
Public Property Selected() As Boolean

Return Type

Read/write Boolean.

See Also

Tip Object


StandardDeviation Property

StandardDeviation Property

Description

Read Only: Returns the standard deviation of the measured sphere after tip qualification

Property type

Read-write property

Syntax

Visual Basic
Public Property StandardDeviation() As Double

See Also

Tip Object


Thickness Property

Thickness Property

Description

Read Only: Returns the theoretical thickness of the tip Returns the nominal thickness of the tip.

Property type

Read-write property

Syntax

Visual Basic
Public Property Thickness() As Double

Return Type

Read-only Double value.

See Also

Tip Object


Time Property

Time Property

Description

Read Only: Gets/Sets string representing time of the last calibration of the tip in the format HH:MM:SS

Returns the PC-DMIS representation of the most recent calibration time of the tip.

Property type

Read-write property

Syntax

Visual Basic
Public Property Time() As String

Return Type

Read-only String value.

See Also

Tip Object


TipNum Property

TipNum Property

Description

Read Only: Returns the tip number of the tip Returns the tip number in the list of tips.

Property type

Read-write property

Syntax

Visual Basic
Public Property TipNum() As Long

Return Type

Read-only Long value.

Remarks

This is PC-DMIS’s internal representation of tip number. It may be different from the number passed to Tips.Item to retrieve the tip.

See Also

Tip Object


TipType Property

TipType Property

Description

Read Only: Returns the tip type of the tip Returns the type of the tip.

Property type

Read-write property

Syntax

Visual Basic
Public Property TipType() As ENUM_TIPTYPES

Return Type

Read-only ENUM_TIPTYPES object.

Remarks

The following tip types are defined. They can be combined via bitwise operations.

TIPBALL // Default
TIPDISK
TIPSHANK
TIPOPTIC
TIPANALOG
TIPANALOGBALL = TIPANALOG + BALL
TIPANALOGDISK = TIPANALOG + DISK
TIPANALOGSHANK = TIPANALOG + SHANK
TIPANALOGOPTIC = TIPANALOG + OPTIC
TIPFIXED
TIPFIXEDBALL = TIPFIXED + BALL
TIPFIXEDDISK = TIPFIXED + DISK
TIPFIXEDSHANK = TIPFIXED + SHANK
TIPFIXEDOPTIC = TIPFIXED + OPTIC
TIPSP600 // renishaw sp600 analog probe
TIPWBOPTIC // wolf and beck laser probe
TIPINFINITARM // renishaw infinite index arm
TIPSLAVE // tip belongs to slave arm

See Also

Tip Object


WristOffset Property

WristOffset Property

Description

Read/Write: Returns a point data object with the wrist offset of the tip Returns the wrist offset of the tip.

Property type

Read-write property

Syntax

Visual Basic
Public Property WristOffset() As PointData

Return Type

Read-only PointData object.

See Also

Tip Object


WristTipIJK Property

WristTipIJK Property

Description

Read Only: Returns a point data object with the theoretical vector of the tip Returns the wrist tip vector of the tip.

Property type

Read-write property

Syntax

Visual Basic
Public Property WristTipIJK() As PointData

Return Type

Read-only PointData object.

See Also

Tip Object


XYZ Property

XYZ Property

Description

Read/Write: Gets/Sets the theoretical XYZ data of the tip Returns the location of the tip.

Property type

Read-write property

Syntax

Visual Basic
Public Property XYZ() As PointData

Return Type

Read/write PointData object.

See Also

Tip Object


Tips Object

Tips Object
See Also Members

Description

The Tips object is the collection of all Tip objects for a Probe object. The Probe object that the Tips stores Tip objects for is contained in the Parent property.

Object Model

See Also

Tips Members


Tips Object Members

Tips ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method Add | Adds the tip object with angles a and b to the tips collection This function adds a new tip position to this collection. The new tip is unqualified.
Public Method Item | Returns the tip object referenced by the number or name parameter Returns a specific Tip object from the Tips object.
Public Method Remove | Removes the tip object referenced by the Num parameter from the tips collection This function removes the indicated Tip object from this collection.

Public Properties

Public Property Application | Read Only: Returns the Application Oject Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects.
Public Property Count | Read Only: Returns the current number of tips Represents the number of Tip objects in the parent Probe object.
Public Property Parent | Read Only: Returns the parent Probe Object Returns the parent Probe object.

See Also

Tips Overview


_Item Method

_Item Method
NameOrNum

Syntax

Visual Basic
Public Function _Item( _
   ByVal NameOrNum As Variant _
) As Tip

Parameters

NameOrNum

See Also

Tips Object


Add Method

Add Method
a
Required Double that is the A parameter of the new tip.
b
Required Double that is the B parameter of the new tip.

Description

Adds the tip object with angles a and b to the tips collection

This function adds a new tip position to this collection. The new tip is unqualified.

Syntax

Visual Basic
Public Function Add( _
   ByVal a As Double, _
   ByVal b As Double _
) As Long

Parameters

a
Required Double that is the A parameter of the new tip.
b
Required Double that is the B parameter of the new tip.

See Also

Tips Object


Item Method

Item Method
NameOrNum
Required Variant that indicates which Tip object to return. It can be either a Long or a String. If it is a Long, it is the index number of the Tip object in the Tips collection. If it is a String, it is the ID of the Tip object.

Description

Returns the tip object referenced by the number or name parameter

Returns a specific Tip object from the Tips object.

Syntax

Visual Basic
Public Function Item( _
   ByVal NameOrNum As Variant _
) As Tip

Parameters

NameOrNum
Required Variant that indicates which Tip object to return. It can be either a Long or a String. If it is a Long, it is the index number of the Tip object in the Tips collection. If it is a String, it is the ID of the Tip object.

Return Type

Tip object.

Remarks

Since the Item method is the default, the function name can be omitted if desired.

See Also

Tips Object


Remove Method

Remove Method
Num
Required Long that indicates which Tip object to remove.

Description

Removes the tip object referenced by the Num parameter from the tips collection

This function removes the indicated Tip object from this collection.

Syntax

Visual Basic
Public Sub Remove( _
   ByVal Num As Long _
)

Parameters

Num
Required Long that indicates which Tip object to remove.

See Also

Tips Object


Application Property

Application Property

Description

Read Only: Returns the Application Oject Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

Tips Object


Count Property

Count Property

Description

Read Only: Returns the current number of tips Represents the number of Tip objects in the parent Probe object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

Return Type

Read-only Integer.

See Also

Tips Object


Parent Property

Parent Property

Description

Read Only: Returns the parent Probe Object Returns the parent Probe object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As probe

Return Type

Probe object.

See Also

Tips Object


tool Object

tool Object
See Also Members

Description

Probe Calibration Tool Object The Tool object represents a single probe calibration tool.

Object Model

Remarks

Use Tools(index) where index is the index number or tool name to return a single Tool object.

See Also

tool Members


tool Object Members

tool ObjectMembers
See Also Overview

Public Properties

Public Property _ID |
Public Property Application | Read Only: Returns the Application Object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects.
Public Property diam | Read/Write: Returns/Sets the tool diameter Returns the diameter of the tip.
Public Property ID | Read/Write: Returns/Sets the tool ID Returns the ID string of the tip.
Public Property Parent | Read Only: Retruns the parent Tools Collection Object Returns the parent Tools object.
Public Property ShankIJK | Read/Write: Returns/Sets via point data object the shank ijk of the tool Returns the shank vector of the tool as a PointData.
Public Property ToolType | Read/Write: Returns/Sets the tool type of the tool Returns the type of the tool.
Public Property Width | Read/Write: Returns/Sets the tool width Returns the width of the tool.
Public Property XYZ | Read/Write: Returns/Sets via point data object the xyz location of the tool Returns the location of the tool.

See Also

tool Overview


_ID Property

_ID Property

Property type

Read-write property

Syntax

Visual Basic
Public Property _ID() As String

See Also

tool Object


Application Property

Application Property

Description

Read Only: Returns the Application Object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

tool Object


diam Property

diam Property

Description

Read/Write: Returns/Sets the tool diameter

Returns the diameter of the tip.

Property type

Read-write property

Syntax

Visual Basic
Public Property diam() As Double

Return Type

Read/write Double value.

See Also

tool Object


ID Property

ID Property

Description

Read/Write: Returns/Sets the tool ID Returns the ID string of the tip.

Property type

Read-write property

Syntax

Visual Basic
Public Property ID() As String

Return Type

Read-only String value.

See Also

tool Object


Parent Property

Parent Property

Description

Read Only: Retruns the parent Tools Collection Object Returns the parent Tools object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As Tools

Return Type

Read-only Tools object.

See Also

tool Object


ShankIJK Property

ShankIJK Property

Description

Read/Write: Returns/Sets via point data object the shank ijk of the tool Returns the shank vector of the tool as a PointData.

Property type

Read-write property

Syntax

Visual Basic
Public Property ShankIJK() As PointData

Return Type

Read-only PointData object.

See Also

tool Object


ToolType Property

ToolType Property

Description

Read/Write: Returns/Sets the tool type of the tool Returns the type of the tool.

Property type

Read-write property

Syntax

Visual Basic
Public Property ToolType() As TOOLTYPES

Return Type

TOOLTYPES enumerated value.

See Also

tool Object


Width Property

Width Property

Description

Read/Write: Returns/Sets the tool width

Returns the width of the tool.

Property type

Read-write property

Syntax

Visual Basic
Public Property Width() As Double

Return Type

Read-only Double.

See Also

tool Object


XYZ Property

XYZ Property

Description

Read/Write: Returns/Sets via point data object the xyz location of the tool Returns the location of the tool.

Property type

Read-write property

Syntax

Visual Basic
Public Property XYZ() As PointData

Return Type

Read-only PointData.

See Also

tool Object


Tools Object

Tools Object
See Also Members

Description

Probe Calibration Tools Collection The Tools collection object contains the tools available to the parent PartProgram object.

Object Model

Remarks

Use Tools(index) where index is the index number or tool name to return a single Tool object.

See Also

Tools Members


Tools Object Members

Tools ObjectMembers
See Also Overview

Public Methods

Public Method _Item |
Public Method Add | Creates a new calibration tool and adds it to the tools collection This function adds a new tool to this collection. The new tool is unqualified.
Public Method Item | Returns the tool object with the specified ID
Public Method Remove | Removes the calibration tool specified by ID from the tools collection This function removes the indicated Tool object from this collection.

Public Properties

Public Property Application | Read Only: Returns the Application Object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects.
Public Property Count | Read Only: Returns the number of tools currently available for calibration Represents the number of Tool objects in the parent PartProgram object.
Public Property Parent | Read Only: Returns the parent PartProgram Object Returns the parent PartProgram object.

See Also

Tools Overview


_Item Method

_Item Method
ID

Syntax

Visual Basic
Public Function _Item( _
   ByVal ID As Variant _
) As tool

Parameters

ID

See Also

Tools Object


Add Method

Add Method
ID
Required String that is the name of the new tool.

Description

Creates a new calibration tool and adds it to the tools collection This function adds a new tool to this collection. The new tool is unqualified.

Syntax

Visual Basic
Public Function Add( _
   ByVal ID As String _
) As tool

Parameters

ID
Required String that is the name of the new tool.

Return Type

Tool object.

See Also

Tools Object


Item Method

Item Method
ID
Required Variant that indicates which Tool object to return. It can be either a Long or a String. If it is a Long, it is the index number of the Tool object in the Tools collection. If it is a String, it is the ID of the Tool object.

Description

Returns the tool object with the specified ID

Syntax

Visual Basic
Public Function Item( _
   ByVal ID As Variant _
) As tool

Parameters

ID
Required Variant that indicates which Tool object to return. It can be either a Long or a String. If it is a Long, it is the index number of the Tool object in the Tools collection. If it is a String, it is the ID of the Tool object.

Return Type

Tool object.

Remarks

Since the Item method is the default, the function name can be omitted if desired.

See Also

Tools Object


Remove Method

Remove Method
ID
Required String that indicates which Tool object to remove.

Description

Removes the calibration tool specified by ID from the tools collection This function removes the indicated Tool object from this collection.

Syntax

Visual Basic
Public Function Remove( _
   ByVal ID As String _
) As Boolean

Parameters

ID
Required String that indicates which Tool object to remove.

Return Type

Boolean value. Boolean returns true if the function succeeds, false if it fails.

See Also

Tools Object


Application Property

Application Property

Description

Read Only: Returns the Application Object Represents the read-only PC-DMIS application. The Application object includes properties and methods that return top-level objects.

Property type

Read-write property

Syntax

Visual Basic
Public Property Application() As Application

Return Type

Application object.

See Also

Tools Object


Count Property

Count Property

Description

Read Only: Returns the number of tools currently available for calibration Represents the number of Tool objects in the parent PartProgram object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Count() As Long

Return Type

Read-only Long value.

See Also

Tools Object


Parent Property

Parent Property

Description

Read Only: Returns the parent PartProgram Object Returns the parent PartProgram object.

Property type

Read-write property

Syntax

Visual Basic
Public Property Parent() As PartProgram

Return Type

PartProgram object.

See Also

Tools Object


TRACEFIELD Object

TRACEFIELD Object
See Also Members

Description

The Tracefield object gives access to the name and value properties of the PC-DMIS Tracefield command. For additional information on this command see "Using Trace Field" in the "Tracking Statistical Data" section of the PC-DMIS documentation.

See Also

TRACEFIELD Members


TRACEFIELD Object Members

TRACEFIELD ObjectMembers
See Also Overview

Public Properties

Public Property Name | Read/Write: Name of the statistical tracefield String value representing the name of the tracefield.
Public Property Value | Read/Write: Value fo the statisitcal tracefield String value representing the value for the tracefield.

See Also

TRACEFIELD Overview


Name Property

Name Property

Description

Read/Write: Name of the statistical tracefield

String value representing the name of the tracefield.

Property type

Read-write property

Syntax

Visual Basic
Public Property Name() As String

Return Type

Read/write String object.

See Also

TRACEFIELD Object


Value Property

Value Property

Description

Read/Write: Value fo the statisitcal tracefield

String value representing the value for the tracefield.

Property type

Read-write property

Syntax

Visual Basic
Public Property Value() As String

Return Type

Read/write String value.

See Also

TRACEFIELD Object


tutorhit Object

tutorhit Object
See Also Members

See Also

tutorhit Members


tutorhit Object Members

tutorhit ObjectMembers
See Also Overview

See Also

tutorhit Overview


Variable Object

Variable Object
See Also Members

Description

PC-Dmis Variable Object

Object Model

Remarks

The properties of the Variable Object allows you to return and set a variable's:

  • Type
  • Long value
  • Double value
  • String value
  • Point value
  • Command value

The methods of of this object return an array's:

  • Upper bound if variable is an array
  • Lower bound if variable is an array
  • Gets the array variable at a specific position
  • Sets the array variable at a specified position

See Also

Variable Members


Variable Object Members

Variable ObjectMembers
See Also Overview

Public Methods

Public Method GetArrayIndexValue | Gets the array variable at specified position This returns the array variable at the specified index position.
Public Method GetArrayLowerBound | If variable is type array, returns the lower bound, otherwise 0 This returns the lower bound if the variable is an array. Otherwise it returns zero.
Public Method GetArrayUpperBound | If variable is type array, returns the upper bound, otherwise 0 This returns the upper bound if the variable is an array. Otherwise it returns zero.
Public Method SetArrayIndexValue | Sets the array variable at specified position This sets the array variable at the specified index position.

Public Properties

Public Property CommandValue | Read/Write: Returns/Sets the command value of the variable This returns / sets the command value of the variable.
Public Property DoubleValue | Read/Write: Returns/Sets the double value of the variable This returns / sets the double value of the variable.
Public Property LongValue | Read/Write: Returns/Sets the long value of the variable This returns / sets the long value of the variable.
Public Property PointValue | Read/Write: Returns/Sets the point value of the variable This returns / sets the point value of the variable.
Public Property StringValue | Read/Write: Returns/Sets the string value of the variable This returns / sets the string value of the variable.
Public Property VariableType | Read/Write: Returns/Sets the current variable type This returns / sets the current variable type.

See Also

Variable Overview


GetArrayIndexValue Method

GetArrayIndexValue Method
index
Long value of the index position.

Description

Gets the array variable at specified position This returns the array variable at the specified index position.

Syntax

Visual Basic
Public Function GetArrayIndexValue( _
   ByVal index As Long _
) As Variable

Parameters

index
Long value of the index position.

See Also

Variable Object


GetArrayLowerBound Method

GetArrayLowerBound Method

Description

If variable is type array, returns the lower bound, otherwise 0 This returns the lower bound if the variable is an array. Otherwise it returns zero.

Syntax

Visual Basic
Public Function GetArrayLowerBound() As Long

Return Type

Long value.

See Also

Variable Object


GetArrayUpperBound Method

GetArrayUpperBound Method

Description

If variable is type array, returns the upper bound, otherwise 0 This returns the upper bound if the variable is an array. Otherwise it returns zero.

Syntax

Visual Basic
Public Function GetArrayUpperBound() As Long

Return Type

Long value.

See Also

Variable Object


SetArrayIndexValue Method

SetArrayIndexValue Method
index
Long value specifying the index position.
Variable
Array Variable value to be set.

Description

Sets the array variable at specified position This sets the array variable at the specified index position.

Syntax

Visual Basic
Public Function SetArrayIndexValue( _
   ByVal index As Long, _
   ByVal Variable As Variable _
) As Boolean

Parameters

index
Long value specifying the index position.
Variable
Array Variable value to be set.

Return Type

Boolean value.

See Also

Variable Object


CommandValue Property

CommandValue Property

Description

Read/Write: Returns/Sets the command value of the variable

This returns / sets the command value of the variable.

Property type

Read-write property

Syntax

Visual Basic
Public Property CommandValue() As Command

Return Type

Read/write Command object.

See Also

Variable Object


DoubleValue Property

DoubleValue Property

Description

Read/Write: Returns/Sets the double value of the variable

This returns / sets the double value of the variable.

Property type

Read-write property

Syntax

Visual Basic
Public Property DoubleValue() As Double

Return Type

Read/write Double value.

See Also

Variable Object


LongValue Property

LongValue Property

Description

Read/Write: Returns/Sets the long value of the variable

This returns / sets the long value of the variable.

Property type

Read-write property

Syntax

Visual Basic
Public Property LongValue() As Long

Return Type

Read/write Long value.

See Also

Variable Object


PointValue Property

PointValue Property

Description

Read/Write: Returns/Sets the point value of the variable

This returns / sets the point value of the variable.

Property type

Read-write property

Syntax

Visual Basic
Public Property PointValue() As PointData

Return Type

Read/write PointData object.

See Also

Variable Object


StringValue Property

StringValue Property

Description

Read/Write: Returns/Sets the string value of the variable

This returns / sets the string value of the variable.

Property type

Read-write property

Syntax

Visual Basic
Public Property StringValue() As String

Return Type

Read/write String value.

See Also

Variable Object


VariableType Property

VariableType Property

Description

Read/Write: Returns/Sets the current variable type

This returns / sets the current variable type.

Property type

Read-write property

Syntax

Visual Basic
Public Property VariableType() As VARIABLE_TYPE_TYPES

Return Type

Read/write VARIABLE_TYPE_TYPES enumeration.

See Also

Variable Object


VariableArray Object

VariableArray Object
See Also Members

See Also

VariableArray Members


VariableArray Object Members

VariableArray ObjectMembers
See Also Overview

Public Methods

Public Method GetSize
Public Method GetValue
Public Method SetSize
Public Method SetValue

See Also

VariableArray Overview


GetSize Method

GetSize Method

Syntax

Visual Basic
Public Function GetSize() As Long

See Also

VariableArray Object


GetValue Method

GetValue Method
ArrayPosition

Syntax

Visual Basic
Public Function GetValue( _
   ByVal ArrayPosition As Long _
) As Double

Parameters

ArrayPosition

See Also

VariableArray Object


SetSize Method

SetSize Method
NewSize

Syntax

Visual Basic
Public Sub SetSize( _
   ByVal NewSize As Long _
)

Parameters

NewSize

See Also

VariableArray Object


SetValue Method

SetValue Method
ArrayPosition
NewValue

Syntax

Visual Basic
Public Sub SetValue( _
   ByVal ArrayPosition As Long, _
   ByVal NewValue As Double _
)

Parameters

ArrayPosition
NewValue

See Also

VariableArray Object


Untitled Document

Enumerated Constants Overview.

Several enumerated constants exist which you can use in your scripts. Enumerated constants are actually number values with a more human readable naming scheme. You can use either the provided naming constant value or the actual number value of the list item.


AUTOVECTORTYPES Enumeration

AUTOVECTORTYPES Enumeration

Members

Member | Value | Description
PCD_VECTOR1 | 1 |
PCD_VECTOR2 | 2 |
PCD_VECTOR3 | 3 |
PCD_PUNCH_VECTOR | 4 |
PCD_PIN_VECTOR | 5 |
PCD_ANGLE_VECTOR | 6 |
PCD_REPORT_VECTOR | 7 |
PCD_EDGE_REPORT_VECTOR | 8 |
PCD_SURF_REPORT_VECTOR | 9 |
PCD_MEASURE_VECTOR | 10 |
PCD_UPDATE_VECTOR | 11 |


BSBOUNDCOND_ENUM Enumeration

BSBOUNDCOND_ENUM Enumeration

Members

Member | Value | Description
BSBOUNDCOND_SPHERE | 600010 | Represents a Spherical Boundary Condition. This Boundary condition requires the following parameters to be set by you using Automation Properties and/or Automation Methods : BoundaryConditionCenter, BoundaryConditionEndApproach, Diameter, number of Crossings.
BSBOUNDCOND_PLANECROSS | 600030 | Represents a Planar Boundary Condition. This Boundary condition requires the following parameters to be set by you using Automation Properties and/or Automation Methods : BoundaryConditionCenter, BoundaryConditionEndApproach, BoundaryConditionPlaneV, number of Crossings.
BSBOUNDCOND_CYLINDER | 600040 | Represents a Cylindrical Boundary Condition. This Boundary condition requires the following parameters to be set by you using Automation Properties and/or Automation Methods : BoundaryConditionCenter, BoundaryConditionEndApproach, BoundaryConditionAxisV, Diameter, number of Crossings.
BSBOUNDCOND_CONE | 600050 | Represents a Conical Boundary Condition. This Boundary condition requires the following parameters to be set you user using Automation Properties and/or Automation Methods : BoundaryConditionCenter, BoundaryConditionEndApproach, BoundaryConditionAxisV, HalfAngle, number of Crossings.


BSCANHIT_ENUM Enumeration

BSCANHIT_ENUM Enumeration

Members

Member | Value | Description
BSCANHIT_VECTOR | 700010 | Use vector hits for this scan.
BSCANHIT_SURFACE | 700020 | Use surface hits for this scan.
BSCANHIT_EDGE | 700030 | Use edge hits for this scan.
BSCANHIT_BASIC | 700090 | Use basic hits for this scan. Only Manual scans use this hit type.


BSCANMETH_ENUM Enumeration

BSCANMETH_ENUM Enumeration

Members

Member | Value | Description
BSCANMETH_LINEAR | 100010 | Scans the surface along a line. This procedure uses the starting and ending point for the line, and also includes a direction point. The probe will always remain within the cut plane while doing the scan.
BSCANMETH_EDGE | 100050 | Scans the Edge of the Surface in a Touch Trigger mode.
BSCANMETH_ANGLE | 100075 |
BSCANMETH_PERIMETER | 100100 |
BSCANMETH_CIRCLE | 100125 | Scans around a circle in a high speed, continuous contact mode.
BSCANMETH_CYLINDER | 100130 | Scans around a cylinder in a high speed, continuous contact mode.
BSCANMETH_STRAIGHTLINE | 100135 | Scans a straight line in a high speed, continuous contact mode.
BSCANMETH_CENTER | 100140 | Finds a Low Point on a surface.
BSCANMETH_OPEN | 100500 | This method will scan the surface along a line. This procedure uses the starting and ending point for the line and also includes a direction point. The probe will always remain within the cut plane while doing the scan. This is valid oly for DCC scans.
BSCANMETH_CLOSE | 100510 | This method will scan the surface along a line. This procedure uses the starting and ending point for the line and also includes a direction point. The probe will always remain within the cut plane while doing the scan.The scan will start and finish at the same Point. This is valid oly for DCC scans.
BSCANMETH_PATCH | 100520 | This method will scan the surface in multiple rows depending on the Boundary Points. This is valid oly for DCC scans.
BSCANMETH_UV | 100530 |
BSCANMETH_MANUAL_TTP | 100600 | This is valid only for Manual scans and will allow you to use a Touch Trigger Probe to take Manual hits.
BSCANMETH_MANUAL_FIXED_PROBE | 100610 | This is valid only for Manual scans and will allow you to use a Hard Probe to take Manual hits.


BSCANNMODE_ENUM Enumeration

BSCANNMODE_ENUM Enumeration

Members

Member | Value | Description
BSCANNMODE_FINDCADNOMINAL | 400001 | This mode would find the Nominal data from CAD after scanning. This mode is useful only when CAD surface data is available.
BSCANNMODE_MASTERDATA | 400002 | This mode keeps the data scanned the first time as Master data.
BSCANNMODE_FINDCADNOMSMULTIROW | 400003 |


BSCANOPMODE_ENUM Enumeration

BSCANOPMODE_ENUM Enumeration

Members

Member | Value | Description
BSCANOPMODE_REGULARLEARN | 500011 | When this mode is used, PC-DMIS will execute the scan as though it is learning it. All learned measured data will replace the new measured data. The nominal will be re-calculated depending on the Nominals mode.
BSCANOPMODE_DEFINEPATHFROMHITS | 500021 | This mode is available only when using analog probe heads that can do continuous contact scanning. When this option is selected, PC-DMIS allows the controller to "define" a scan. PC-DMIS gathers all hit locations from the editor and passes them onto the controller for scanning. The controller will then adjust the path allowing the probe to pass through all the points. The data is then reduced according to the increment provided and the new data will replace any old measured data. Currently, this value cannot be used through Automation since there is no method provided to define a path.
BSCANOPMODE_HIGHSPEEDFEATUREBASED | 500022 | This execute mode is available only for Analog Probe Heads. When this is selected, PC-DMIS uses the built-in High Speed scanning capability of the controller to execute a scan. Example: If you selected a Circle scan, PC-DMIS would use a corresponding Circle scanning command in the controller and pass on the parameters to the controller to execute. In this case, PC-DMIS does not control execution of the scans.
BSCANOPMODE_NORMALEXECUTION | 500201 | If a DCC scan is executed, PC-DMIS will take hits at each of the learned locations in Stitch scanning mode, storing the newly measured data.


BSCTRLPT_ENUM Enumeration

BSCTRLPT_ENUM Enumeration

Members

Member | Value | Description
BSCTRLPT_SPHERE | 800010 |
BSCTRLPT_PLANE | 800020 |
BSCTRLPT_CYLINDER | 800030 |
BSCTRLPT_CONE | 800040 |


BSF_ENUM Enumeration

BSF_ENUM Enumeration

Members

Member | Value | Description
BSF_DISTANCE | 200010 | PC-DMIS determines each hit based on the set increment and the last two measured hits. The approach of the probe is perpendicular to the line between the last two measured hits. The probe will stay on the cut plane. PC-DMIS will start at the first boundary point and continue taking hits at the set increment, stopping when it satisfies the Boundary Condition. In the case of a continuous scan, PC-DMIS would filter the data from the CMM and keep only the hits that are apart by at least the increment. Both DCC and Manual scans can use this filter.
BSF_BODYAXISDISTANCE 200015 PC-DMIS will take hits at the set increment along the current part's coordinate system. The approach of the probe is perpendicular to the indicated axis. The probe will stay on the cut plane. The approach vector will be normal to the selected axis and on the cut plane. This technique uses the same approach for taking each hit (unlike the previous technique which adjusts the approach to be perpendicular to the line between the previous two hits). Only DCC scans should use this filter.

When this filter is applied to Manual scans, the following behaviour happens:

This Filter property allows you to scan a part by specifying a cut plane on a certain part axis and dragging the probe across the cut plane. As you scan the part, you should scan so that the probe crisscrosses the defined Cut Plane as many times as desired. PC-DMIS then follows this procedure:

  • PC-DMIS gets data from the controller and finds the two data hits that are closest to the Cut Plane on either side as you crisscross.
  • PC-DMIS then forms a line between the two hits which will pierce the Cut Plane.
  • The pierced point then becomes a hit on the Cut Plane.

This operation happens every time you cross the Cut Plane and you will finally have many hits that are on the Cut Plane.

BSF_VARIABLEDISTANCE 200020 This technique allows you to set specific maximum and minimum angle and increment values that will be used in determining where PC-DMIS will take a hit. The probe's approach is perpendicular to the line between the last two measured hits. You should provide the maximum and minimum values that will be used to determine the increments between hits. You also must enter the desired values for the maximum and minimum angles. PC-DMIS will take three hits using the minimum increment. It will then measure the angle between hit's 1-2 and 2-3.
  • If the measured angle is between the maximum and minimum values defined, PC-DMIS will continue to take hits at the current increment.
  • If the angle is greater than the maximum value, PC-DMIS will erase the last hit and measure it again using one quarter of the current increment value.
  • If the angle is less than the minimum increment, PC-DMIS will take the hit at the minimum increment value.

PC-DMIS will again measure the angle between the newest hit and the two previous hits. It will continue to erase the last hit and drop the increment value to one quarter of the increment until the measured angle is within the range defined, or the minimum value of the increment is reached.

If the measured angle is less than the minimum angle, PC-DMIS will double the increment for the next hit. (If this is greater than the maximum increment value it will take the hit at the maximum increment.) PC-DMIS will again measure the angle between the newest hit and the two previous hits. It will continue to double the increment value until the measured angle is within the range defined, or the maximum increment is reached. The above behavior applies to DCC scans.

When this filter is applied to Manual scans, the following behaviour occurs:

The filter defines the distance between hits based on the part. PC-DMIS allows you to specify the speed at which it will read hits and the drop point distance. After the scanning process is complete, PC-DMIS will calculate the total number of hits that were measured and the total number that were kept after completing the drop point distance calculations. The reduced data is then converted to hits.

If

BSF_TIME_DELTA | 200030 | The Time Delta method of scanning allows you to reduce the scan data by setting a time increment. PC-DMIS will start from the first hit and reduce the scan by deleting hits that are read in faster than the time delta specified.
BSF_NULL | 200060


CATCHTYPE Enumeration

CATCHTYPE Enumeration

Members

Member | Value | Description
PCD__OFF | 0 | Turns off error catching. The basic script will no longer be notified when motion errors occur.
PCD_CATCH_IN_INTEGER | 1 | All subsequent motion errors will cause the integer passed by reference as the catch_error parameter to be set to a non-zero value.
PCD_TRIGGER_ERROR | 2 | All subsequent motion errors will generate runtime error 1001. These error may be caught using the On Error statement.


CREATEIDTYPE Enumeration

CREATEIDTYPE Enumeration

Members

Member | Value | Description
PCD_ALIGNMENT | 1 |
PCD_CURVE | 38 |
READ___POINT | 192 |
MEASURED___POINT | 201 |
MEASURED___CIRCLE | 202 |
MEASURED___SPHERE | 203 |
MEASURED___LINE | 204 |
MEASURED___CONE | 205 |
MEASURED___CYLINDER | 206 |
MEASURED___PLANE | 207 |
MEASURED___SET | 210 |
CONST___ORIG_POINT | 510 |
CONST___OFF_POINT | 511 |
CONST___PROJ_POINT | 512 |
CONST___MID_POINT | 513 |
CONST___DROP_POINT | 514 |
CONST___PIERCE_POINT | 515 |
CONST___INT_POINT | 516 |
CONST___CAST_POINT | 517 |
CONST___CORNER_POINT | 518 |
CONST___BFRE_CIRCLE | 520 |
CONST___BF_CIRCLE | 521 |
CONST___PROJ_CIRCLE | 522 |
CONST___REV_CIRCLE | 523 |
CONST___CONE_CIRCLE | 524 |
CONST___CAST_CIRCLE | 525 |
CONST___INT_CIRCLE | 526 |
CONST___BFRE_SPHERE | 530 |
CONST___BF_SPHERE | 531 |
CONST___PROJ_SPHERE | 532 |
CONST___REV_SPHERE | 533 |
CONST___CAST_SPHERE | 534 |
CONST___BFRE_LINE | 540 |
CONST___BF_LINE | 541 |
CONST___PROJ_LINE | 542 |
CONST___REV_LINE | 543 |
CONST___MID_LINE | 544 |
CONST___CAST_LINE | 545 |
CONST___INT_LINE | 546 |
CONST___OFF_LINE | 547 |
CONST___ALN_LINE | 548 |
CONST___PRTO_LINE | 549 |
CONST___PLTO_LINE | 550 |
CONST___BFRE_CONE | 551 |
CONST___BF_CONE | 552 |
CONST___PROJ_CONE | 553 |
CONST___REV_CONE | 554 |
CONST___CAST_CONE | 555 |
CONST___BFRE_CYLINDER | 560 |
CONST___BF_CYLINDER | 561 |
CONST___PROJ_CYLINDER | 562 |
CONST___REV_CYLINDER | 563 |
CONST___CAST_CYLINDER | 564 |
CONST___BFRE_PLANE | 570 |
CONST___BF_PLANE | 571 |
CONST___REV_PLANE | 572 |
CONST___MID_PLANE | 573 |
CONST___CAST_PLANE | 574 |
CONST___OFF_PLANE | 575 |
CONST___ALN_PLANE | 576 |
CONST___PRTO_PLANE | 577 |
CONST___PLTO_PLANE | 578 |
CONST___HIPNT_PLANE | 579 |
CONST_BFRE_ELLIPSE | 580 |
CONST_BF_ELLIPSE | 581 |
CONST_PROJ_ELLIPSE | 582 |
CONST_REV_ELLIPSE | 583 |
CONST_CAST_ELLIPSE | 584 |
CONST_INT_ELLIPSE | 585 |
CONST___SET | 596 |
AUTO_VECTOR_HIT | 602 |
AUTO_SURFACE_HIT | 603 |
AUTO_EDGE_HIT | 604 |
AUTO_ANGLE_HIT | 605 |
AUTO_CORNER_HIT | 606 |
AUTO___CIRCLE | 612 |
AUTO___SPHERE | 613 |
AUTO___CYLINDER | 616 |
AUTO___ROUND_SLOT | 618 |
AUTO___SQUARE_SLOT | 619 |
AUTO___ELLIPSE | 621 |
DIM_LOCATION | 1000 |
DIM_STRAIGHTNESS | 1100 |
DIM_ROUNDNESS | 1101 |
DIM_FLATNESS | 1102 |
DIM_PERPENDICULARITY | 1103 |
DIM_PARALLELISM | 1104 |
DIM_PROFILE | 1105 |
DIM_3D_DISTANCE | 1106 |
DIM_2D_DISTANCE | 1107 |
DIM_3D_ANGLE | 1108 |
DIM_2D_ANGLE | 1109 |
DIM_RUNOUT | 1110 |
DIM_CONCENTRICITY | 1111 |
DIM_ANGULARITY | 1112 |
DIM_KEYIN | 1113 |
DIM_TRUE_POSITION | 1200 |


DATA_TYPE_TYPES Enumeration

DATA_TYPE_TYPES Enumeration

Members

Member | Value | Description
DATATYPE_ERROR | 0 |
DATATYPE_MEASURED_CONSTANT | 1 |
DATATYPE_CALCULATED_CONSTANT | 2 |
DATATYPE_ALPHANUMERIC | 3 |
DATATYPE_NUMERIC | 4 |
DATATYPE_TOGGLE | 5 |
DATATYPE_EXPRESSION | 6 |


DCCMODE Enumeration

DCCMODE Enumeration

Members

Member | Value | Description
PCD_DCC | 100 |
PCD_MANUAL | 101 |


DIMAXISTYPE Enumeration

DIMAXISTYPE Enumeration

Members

Member | Value | Description
PCD_X | 500 |
PCD_Y | 501 |
PCD_Z | 502 |
PCD_D | 503 |
PCD_R | 504 |
PCD_A | 505 |
PCD_T | 506 |
PCD_PA | 507 |
PCD_PR | 508 |
PCD_V | 509 |
PCD_L | 510 |
PCD_DD | 511 |
PCD_DF | 512 |
PCD_TP | 513 |
PCD_S | 514 |
PCD_RS | 515 |
PCD_RT | 516 |
PCD_PD | 517 |
PCD_M | 518 |


DIMFORMATFLAG Enumeration

DIMFORMATFLAG Enumeration

Members

Member | Value | Description
PCD_HEADINGS | 1 |
PCD_SYMBOLS | 2 |


DIMFORMATTYPE Enumeration

DIMFORMATTYPE Enumeration

Members

Member | Value | Description
PCD_NOT_USED | 0 |
PCD_NOM | 1 |
PCD_TOL | 2 |
PCD_MEAS | 3 |
PCD_MAXMIN | 4 |
PCD_DEV | 5 |
PCD_OUTTOL | 6 |
PCD_DEVANG | 7 |


EDGE_MEASURE_TYPES Enumeration

EDGE_MEASURE_TYPES Enumeration

Members

Member | Value | Description
EDGE_SURFACE_FIRST | 0 |
EDGE_EDGE_FIRST | 1 |
EDGE_BOTH | 2 |


ENUM_ALIGN_WORKPLANE Enumeration

ENUM_ALIGN_WORKPLANE Enumeration

Members

Member | Value | Description
ALIGN_ZPLUS | 0 |
ALIGN_ZMINUS | 1 |
ALIGN_XPLUS | 2 |
ALIGN_XMINUS | 3 |
ALIGN_YPLUS | 4 |
ALIGN_YMINUS | 5 |
ALIGN_CURRENT_WORKPLANE | 6 |


ENUM_AXIS_TYPE Enumeration

ENUM_AXIS_TYPE Enumeration

Members

Member | Value | Description
AXIS_ZPLUS | 0 |
AXIS_XPLUS | 1 |
AXIS_YPLUS | 2 |
AXIS_ZMINUS | 3 |
AXIS_XMINUS | 4 |
AXIS_YMINUS | 5 |


ENUM_BEST_FIT_MATH_TYPES Enumeration

ENUM_BEST_FIT_MATH_TYPES Enumeration

Members

Member | Value | Description
BF_MATH_LEAST_SQUARES | 0 |
BF_MATH_MIN_SEPARATION | 1 |
BF_MATH_MAX_INSCRIBED | 2 |
BF_MATH_MIN_CIRCUMSCRIBED | 3 |
BF_MATH_FIXED_RADIUS | 4 |


ENUM_BITMAP_LAYOUT Enumeration

ENUM_BITMAP_LAYOUT Enumeration

Members

Member | Value | Description
BITMAP_LAYOUT_LEFT | 0 |
BITMAP_LAYOUT_RIGHT | 2 |
BITMAP_LAYOUT_CENTER | 6 |
BITMAP_LAYOUT_VCENTER | 8 |
BITMAP_LAYOUT_SIZE_TO_FIT | 255 |


ENUM_CAD_COLLECTIONS Enumeration

ENUM_CAD_COLLECTIONS Enumeration

Members

Member | Value | Description
HCAD_ALL_LISTS | -1 | All display collection except the probe collection
HCAD_CLEARFETS | -2 |
HCAD_CAD | 0 | Display collection for the cad elements
HCAD_SURF | 1 | Display collection for the cad surface elements
HCAD_INSPECTP | 2 | Display collection for the inspect points (des) elements
HCAD_MEASURED | 3 | Display collection for the measured feature elements
HCAD_EDITPATH | 4 | Display collection for the edit path elements
HCAD_ARROWS | 5 | Display collection for the analysis arrows
HCAD_SCAN | 6 | Display collection for scans
HCAD_HITS | 7 | Display collection for Hits
HCAD_ARM2CMM | 8 | Display collection for arm 2 animated cmm
HCAD_ARM2CMM1 | 9 | Display collection 1 for arm 2 animated cmm
HCAD_ARM2CMM2 | 10 | Display collection 2 for arm 2 animated cmm
HCAD_ARM2CMM3 | 11 | Display collection 3 for arm 2 animated cmm
HCAD_ARM2CMM4 | 12 | Display collection 4 for arm 2 animated cmm
HCAD_ARM2CMM5 | 13 | Display collection 5 for arm 2 animated cmm
HCAD_ARM2CMM6 | 14 | Display collection 6 for arm 2 animated cmm
HCAD_ARM2PROBE | 15 | Display collection for arm 2 animated probe
HCAD_ARM2PROBE1 | 16 | Display collection 1 for arm 2 animated probe
HCAD_ARM2PROBE2 | 17 | Display collection 2 for arm 2 animated probe
HCAD_ARM2PROBE3 | 18 | Display collection 3 for arm 2 animated probe
HCAD_ARM1CMM | 19 | Display collection for arm 1 animated cmm
HCAD_ARM1CMM1 | 20 | Display collection 1 for arm 1 animated cmm
HCAD_ARM1CMM2 | 21 | Display collection 2 for arm 1 animated cmm
HCAD_ARM1CMM3 | 22 | Display collection 3 for arm 1 animated cmm
HCAD_ARM1CMM4 | 23 | Display collection 4 for arm 1 animated cmm
HCAD_ARM1CMM5 | 24 | Display collection 5 for arm 1 animated cmm
HCAD_ARM1CMM6 | 25 | Display collection 6 for arm 1 animated cmm
HCAD_ARM1PROBE | 26 | Display collection for arm 1 animated probe
HCAD_ARM1PROBE1 | 27 | Display collection 1 for arm 1 animated probe
HCAD_ARM1PROBE2 | 28 | Display collection 2 for arm 1 animated probe
HCAD_ARM1PROBE3 | 29 | Display collection 3 for arm 1 animated probe
HCAD_CMMFIXTURE | 30 | Display collection for CMM fixture
HCAD_CMMFIXTURE1 | 31 | Display collection 1 for CMM fixture
HCAD_CMMFIXTURE2 | 32 | Display collection 2 for CMM fixture
HCAD_CMMFIXTURE3 | 33 | Display collection 3 for CMM fixture
HCAD_CMMFIXTURE4 | 34 | Display collection 4 for CMM fixture
HCAD_CMMFIXTURE5 | 35 | Display collection 5 for CMM fixture
HCAD_CMMFIXTURE6 | 36 | Display collection 6 for CMM fixture
HCAD_CMMFIXTURE7 | 37 | Display collection 7 for CMM fixture
HCAD_CMMFIXTURE8 | 38 | Display collection 8 for CMM fixture
HCAD_CMMFIXTURE9 | 39 | Display collection 9 for CMM fixture
HCAD_CMMFIXTURE10 | 40 | Display collection 10 for CMM fixture
HCAD_CMMFIXTURE11 | 41 | Display collection 11 for CMM fixture
HCAD_CMMFIXTURE12 | 42 | Display collection 12 for CMM fixture
HCAD_CMMFIXTURE13 | 43 | Display collection 13 for CMM fixture
HCAD_CMMFIXTURE14 | 44 | Display collection 14 for CMM fixture
HCAD_CMMFIXTURE15 | 45 | Display collection 15 for CMM fixture
HCAD_CMMFIXTURE16 | 46 | Display collection 16 for CMM fixture
HCAD_CMMFIXTURE17 | 47 | Display collection 17 for CMM fixture
HCAD_CMMFIXTURE18 | 48 | Display collection 18 for CMM fixture
HCAD_CMMFIXTURE19 | 49 | Display collection 19 for CMM fixture
HCAD_CMMFIXTURE20 | 50 | Display collection 20 for CMM fixture
HCAD_CMMFIXTURE21 | 51 | Display collection 21 for CMM fixture
HCAD_CMMFIXTURE22 | 52 | Display collection 22 for CMM fixture
HCAD_CMMFIXTURE23 | 53 | Display collection 23 for CMM fixture
HCAD_CMMFIXTURE24 | 54 | Display collection 24 for CMM fixture
HCAD_CMMFIXTURE25 | 55 | Display collection 25 for CMM fixture
HCAD_MARKERS | 56 | Display collection for hits and arrows of features
HCAD_FOV | 57 | Display collection for FOV
HCAD_TARGET | 58 | Display collection for Targets
HCAD_PROBECHANGER1 | 59 | Display collection for probe changer 1
HCAD_PROBECHANGER2 | 60 | Display collection for probe changer 2
HCAD_PROBECHANGER3 | 61 | Display collection for probe changer 3
HCAD_PROBECHANGER4 | 62 | Display collection for probe changer 4
HCAD_ARM3CMM | 63 | Display collection for arm 3 animated cmm
HCAD_ARM3CMM1 | 64 | Display collection 1 for arm 3 animated cmm
HCAD_ARM3CMM2 | 65 | Display collection 2 for arm 3 animated cmm
HCAD_ARM3CMM3 | 66 | Display collection 3 for arm 3 animated cmm
HCAD_ARM3CMM4 | 67 | Display collection 4 for arm 3 animated cmm
HCAD_ARM3CMM5 | 68 | Display collection 5 for arm 3 animated cmm
HCAD_ARM3CMM6 | 69 | Display collection 6 for arm 3 animated cmm
HCAD_ARM4CMM | 70 | Display collection for arm 4 animated cmm
HCAD_ARM4CMM1 | 71 | Display collection 1 for arm 4 animated cmm
HCAD_ARM4CMM2 | 72 | Display collection 2 for arm 4 animated cmm
HCAD_ARM4CMM3 | 73 | Display collection 3 for arm 4 animated cmm
HCAD_ARM4CMM4 | 74 | Display collection 4 for arm 4 animated cmm
HCAD_ARM4CMM5 | 75 | Display collection 5 for arm 4 animated cmm
HCAD_ARM4CMM6 | 76 | Display collection 6 for arm 4 animated cmm
HCAD_ARM3PROBE | 77 | Display collection for arm 3 animated probe
HCAD_ARM3PROBE1 | 78 | Display collection 1 for arm 3 animated probe
HCAD_ARM3PROBE2 | 79 | Display collection 2 for arm 3 animated probe
HCAD_ARM3PROBE3 | 80 | Display collection 3 for arm 3 animated probe
HCAD_ARM4PROBE | 81 | Display collection for arm 4 animated probe
HCAD_ARM4PROBE1 | 82 | Display collection 1 for arm 4 animated probe
HCAD_ARM4PROBE2 | 83 | Display collection 2 for arm 4 animated probe
HCAD_ARM4PROBE3 | 84 | Display collection 3 for arm 4 animated probe


ENUM_CADPRINTOPTIONS Enumeration

ENUM_CADPRINTOPTIONS Enumeration

Members

Member | Value | Description
CADPRINT_ONEPAGESCALE | 0 | Prints view scaled to fit on a single page.
CADPRINT_VISIBLEAREA | 1 | Prints the visible screen area.
CADPRINT_ENTIREVIEW | 2 | Prints entire CAD view.
CADPRINT_ENTIRCURSCALE | 3 | Prints the entire CAD view at the current scale.


ENUM_CALIBRATION_EXECUTE_MODE Enumeration

ENUM_CALIBRATION_EXECUTE_MODE Enumeration

Members

Member | Value | Description
CALIBRATE_TIPS | 0 |
CALIBRATE_UNIT | 1 |
QUALIFICATION_CHECK | 3 |
HOME_UNIT | 4 |
CALIBRATE_NC100_ARTIFACT | 5 |


ENUM_COLOR_SECTION Enumeration

ENUM_COLOR_SECTION Enumeration

Members

Member | Value | Description
COLOR_SECTION_DEFAULT | 10001 |
COLOR_SECTION_ALIGNMENT | 10002 |
COLOR_SECTION_FEATURES | 10003 |
COLOR_SECTION_HITS | 10004 |
COLOR_SECTION_MEASURED | 10005 |
COLOR_SECTION_VISION | 10006 |
COLOR_SECTION_LASER | 10007 |
COLOR_SECTION_CONSTRUCTED | 10008 |
COLOR_SECTION_GENERIC | 10009 |
COLOR_SECTION_DIMENSIONS | 10010 |
COLOR_SECTION_MOVE | 10011 |
COLOR_SECTION_FLOW | 10012 |
COLOR_SECTION_PARAMETERS | 10013 |
COLOR_SECTION_MISC | 10014 |
COLOR_SECTION_AUTO | 10015 |


ENUM_DIM_AXISTYPE Enumeration

ENUM_DIM_AXISTYPE Enumeration

Members

Member | Value | Description
DIMAXIS_NONE | 0 |
DIMAXIS_XAXIS | 1 |
DIMAXIS_YAXIS | 2 |
DIMAXIS_ZAXIS | 3 |


ENUM_DIM_OUTPUTTYPE Enumeration

ENUM_DIM_OUTPUTTYPE Enumeration

Members

Member | Value | Description
DIMOUTPUT_STATS | 0 |
DIMOUTPUT_REPORT | 1 |
DIMOUTPUT_BOTH | 2 |
DIMOUTPUT_NONE | 3 |


ENUM_DIM_PERP_PARALLEL Enumeration

ENUM_DIM_PERP_PARALLEL Enumeration

Members

Member | Value | Description
DIM_PERPENDICULAR | 0 |
DIM_PARALLEL | 1 |


ENUM_DIM_PROF_TYPE Enumeration

ENUM_DIM_PROF_TYPE Enumeration

Members

Member | Value | Description
DIM_PROF_FORM_ONLY | 0 |
DIM_PROF_FORM_AND_LOCATION | 1 |


ENUM_DIM_RADIUS_TYPE Enumeration

ENUM_DIM_RADIUS_TYPE Enumeration

Members

Member | Value | Description
DIM_NO_RADIUS | 0 |
DIM_ADD_RADIUS | 1 |
DIM_SUB_RADIUS | 2 |


ENUM_DIM_TP_MATERIAL_CONDITION Enumeration

ENUM_DIM_TP_MATERIAL_CONDITION Enumeration

Members

Member | Value | Description
DIM_MMC_CONDITION | 0 |
DIM_RFS_CONDITION | 1 |
DIM_LMC_CONDITION | 2 |


ENUM_DIM_TP_MODIFIER Enumeration

ENUM_DIM_TP_MODIFIER Enumeration

Members

Member | Value | Description
DIM_RFS_RFS | 0 |
DIM_RFS_MMC | 1 |
DIM_RFS_LMC | 2 |
DIM_MMC_RFS | 3 |
DIM_MMC_MMC | 4 |
DIM_MMC_LMC | 5 |
DIM_LMC_RFS | 6 |
DIM_LMC_MMC | 7 |
DIM_LMC_LMC | 8 |


ENUM_DIM_TP_USE_AXIS Enumeration

ENUM_DIM_TP_USE_AXIS Enumeration

Members

Member | Value | Description
DIM_AXIS_AVERAGE | 0 |
DIM_AXIS_START_POINT | 1 |
DIM_AXIS_END_POINT | 2 |


ENUM_DINFO_FIELD_TYPES Enumeration

ENUM_DINFO_FIELD_TYPES Enumeration

Members

Member | Value | Description
DINFO_NOT_USED | 0 |
DINFO_MEAS | 1 |
DINFO_NOM | 2 |
DINFO_TOL | 3 |
DINFO_DEV | 4 |
DINFO_MAXMIN | 5 |
DINFO_OUTTOL | 6 |
DINFO_MEAN | 7 |
DINFO_STDDEV | 8 |
DINFO_NUMPOINTS | 9 |


ENUM_DINFO_LOC_AXES Enumeration

ENUM_DINFO_LOC_AXES Enumeration

Members

Member | Value | Description
DINFO_LOC_USE_DIM_AXES | -2 |
DINFO_LOC_WORST | -1 |
DINFO_LOC_NOT_USED | 0 |
DINFO_LOC_X | 1 |
DINFO_LOC_Y | 2 |
DINFO_LOC_Z | 3 |
DINFO_LOC_D | 4 |
DINFO_LOC_R | 5 |
DINFO_LOC_V | 6 |
DINFO_LOC_A | 7 |
DINFO_LOC_L | 8 |
DINFO_LOC_H | 9 |
DINFO_LOC_PR | 10 |
DINFO_LOC_PA | 11 |
DINFO_LOC_T | 12 |
DINFO_LOC_RT | 13 |
DINFO_LOC_S | 14 |
DINFO_LOC_RS | 15 |
DINFO_LOC_PD | 16 |


ENUM_DINFO_TP_AXES Enumeration

ENUM_DINFO_TP_AXES Enumeration

Members

Member | Value | Description
DINFO_TP_USE_DIM_AXES | -2 |
DINFO_TP_WORST | -1 |
DINFO_TP_NOT_USED | 0 |
DINFO_TP_X | 1 |
DINFO_TP_Y | 2 |
DINFO_TP_Z | 3 |
DINFO_TP_PR | 4 |
DINFO_TP_PA | 5 |
DINFO_TP_DD | 6 |
DINFO_TP_LD | 7 |
DINFO_TP_WD | 8 |
DINFO_TP_DF | 9 |
DINFO_TP_LF | 10 |
DINFO_TP_WF | 11 |
DINFO_TP_TP | 12 |


ENUM_DMIS_OUTPUT_THEOS Enumeration

ENUM_DMIS_OUTPUT_THEOS Enumeration

Members

Member | Value | Description
PCD_DMIS_OUTPUT_THEOS_NONE | 0 | Not include theoretical values in the output DMIS file.
PCD_DMIS_OUTPUT_THEOS_ALL | 1 | Outputs all theoretical values along with the measured values.
PCD_DMIS_OUTPUT_THEOS_USE_IMPORTED_SETTING | 2 | Outputs theoretical values output by the DMIS program.


ENUM_DMIS_OVERWRITE Enumeration

ENUM_DMIS_OVERWRITE Enumeration

Members

Member | Value | Description
PCD_DMIS_FILE_ADD_INDEX | 0 | Appends to the existing file name a number.
PCD_DMIS_FILE_OVERWRITE | 1 | Overwrites an existing file with the new contents.
PCD_DMIS_FILE_APPEND | 2 | Appends the DMIS output file to an existing file.


ENUM_DTYPE_GETDBTYPE Enumeration

ENUM_DTYPE_GETDBTYPE Enumeration

Members

Member | Value | Description
DTYPE_GETDBTYPE_ERROR | -1 |
DTYPE_DO_NOT_STORE | 0 |
DTYPE_DYNAMIC_DATA | 1 |
DTYPE_STATIC_DATA | 2 |


ENUM_DTYPE_GETVARIABLETYPE Enumeration

ENUM_DTYPE_GETVARIABLETYPE Enumeration

Members

Member | Value | Description
DTYPE_GETVARIABLETYPE_ERROR | -1 |
DTYPE_TEXT | 0 |
DTYPE_LONG | 1 |
DTYPE_DOUBLE | 2 |


ENUM_ERROR_MODES Enumeration

ENUM_ERROR_MODES Enumeration

Members

Member | Value | Description
ERROR_MODE_OFF | 0 |
ERROR_MODE_GOTO_LABEL | 1 |
ERROR_MODE_SET_VARIABLE | 2 |


ENUM_ERROR_TYPES Enumeration

ENUM_ERROR_TYPES Enumeration

Members

Member | Value | Description
ERROR_TYPE_UNEXPECTED_HIT | 0 |
ERROR_TYPE_MISSED_HIT | 1 |


ENUM_FEATREF_TYPES Enumeration

ENUM_FEATREF_TYPES Enumeration

Members

Member | Value | Description
FEATREF_FEATURE | -3 |
FEATREF_3D | -2 |
FEATREF_CURRENT_WORKPLANE | -1 |
FEATREF_ZPLUS | 0 |
FEATREF_XPLUS | 1 |
FEATREF_YPLUS | 2 |
FEATREF_ZMINUS | 3 |
FEATREF_XMINUS | 4 |
FEATREF_YMINUS | 5 |


ENUM_FEATURE_TYPES Enumeration

ENUM_FEATURE_TYPES Enumeration

Members

Member | Value | Description
F_NONE | 0 |
F_POINT | 1 |
F_CIRCLE | 2 |
F_SPHERE | 3 |
F_LINE | 4 |
F_CONE | 5 |
F_CYLINDER | 6 |
F_PLANE | 7 |
F_CURVE | 8 |
F_SLOT | 9 |
F_SET | 10 |
F_ELLIPSE | 11 |
F_SURFACE | 12 |


ENUM_FIELD_DATA_TYPES Enumeration

ENUM_FIELD_DATA_TYPES Enumeration

Members

Member | Value | Description
FIELD_DATA_NOTDEFINED | -1 |
FIELD_DATA_TEXT | 0 |
FIELD_DATA_LONG | 1 |
FIELD_DATA_DOUBLE | 2 |


ENUM_FIELD_TYPES Enumeration

ENUM_FIELD_TYPES Enumeration

Members

Member | Value | Description
ID | 2 |
REF_ID | 3 |
LEVEL_REF_ID | 4 |
ROTATE_REF_ID | 5 |
ORIGIN_REF_ID | 6 |
THEO_X | 7 |
THEO_Y | 8 |
THEO_Z | 9 |
THEO_SX | 10 |
THEO_SY | 11 |
THEO_SZ | 12 |
THEO_EX | 13 |
THEO_EY | 14 |
THEO_EZ | 15 |
THEO_I | 16 |
THEO_J | 17 |
THEO_K | 18 |
TARG_X | 19 |
TARG_Y | 20 |
TARG_Z | 21 |
MEAS_X | 22 |
MEAS_Y | 23 |
MEAS_Z | 24 |
MEAS_I | 25 |
MEAS_J | 26 |
MEAS_K | 27 |
MEAS_LENGTH | 28 |
MEAS_DIAM | 29 |
MEAS_ANGLE | 30 |
TARG_I | 31 |
TARG_J | 32 |
TARG_K | 33 |
THEO_DIAM | 34 |
THEO_WIDTH | 35 |
THEO_LENGTH | 36 |
THEO_HEIGHT | 37 |
THEO_ANGLE | 38 |
COORD_TYPE | 39 |
INOUT_TYPE | 40 |
THICKNESS_TYPE | 41 |
CIRC_TYPE | 42 |
SNAP_TYPE | 43 |
USEPIN_TYPE | 44 |
MOVE_TYPE | 45 |
READPOS_TYPE | 46 |
FINDHOLE_TYPE | 47 |
RMEAS_TYPE | 48 |
THEOBF_TYPE | 49 |
BOUND_TYPE | 50 |
BF_MATH_TYPE | 51 |
AUTOFIT_CONSTRAINT | 52 |
SLOT_MIN_MAX_TYPE | 53 |
FIND_NOM_AXIS_TYPE | 54 |
N_INIT_HITS_TYPE | 55 |
N_PERM_HITS_TYPE | 56 |
SEARCHMODE_TYPE | 57 |
MODE_TYPE | 58 |
MEASURE_ORDER_TYPE | 59 |
CONE_LENGTH_ANGLE_TYPE | 60 |
OFFSET_LINE_METHOD | 61 |
LIN_POL_FILT_TYPE | 62 |
GEN_FEAT_TYPE | 63 |
GEN_ALIGN_TYPE | 64 |
CURVE_TYPE | 65 |
MEASURED_2D3D_TYPE | 66 |
THINNING_TOL | 67 |
HITINT_TYPE | 68 |
RMEASFEATID | 69 |
N_HITS | 70 |
N_ROWS | 71 |
INIT_HITS | 72 |
PERM_HITS | 73 |
F_OFFSET | 74 |
F_SPACER | 75 |
F_PITCH | 76 |
F_THICKNESS | 77 |
F_DEPTH | 78 |
F_AUTOMOVE | 79 |
F_INDENT | 80 |
F_CORNER_RADIUS | 81 |
F_INCREMENT | 82 |
F_TOLERANCE | 83 |
F_BOXWIDTH | 84 |
F_BOXLENGTH | 85 |
F_CIRCRADOUT | 86 |
F_CIRCRADIN | 87 |
F_CHECK | 88 |
F_MAXACCELX | 89 |
F_MAXACCELY | 90 |
F_MAXACCELZ | 91 |
SCAN_ACCELERATION | 92 |
SCAN_OFFSET_FORCE | 93 |
MANUAL_FINE_PROBING | 94 |
F_MOVESPEED | 95 |
F_TOUCHSPEED | 96 |
F_SCANSPEED | 97 |
START_ANG | 98 |
END_ANG | 99 |
MIDPOINT_X | 100 |
MIDPOINT_Y | 101 |
MIDPOINT_Z | 102 |
ANGVEC_I | 103 |
ANGVEC_J | 104 |
ANGVEC_K | 105 |
MEASVEC_I | 106 |
MEASVEC_J | 107 |
MEASVEC_K | 108 |
SLOTVEC_I | 109 |
SLOTVEC_J | 110 |
SLOTVEC_K | 111 |
SURFVEC_I | 112 |
SURFVEC_J | 113 |
SURFVEC_K | 114 |
PINVEC_I | 115 |
PINVEC_J | 116 |
PINVEC_K | 117 |
PUNCHVEC_I | 118 |
PUNCHVEC_J | 119 |
PUNCHVEC_K | 120 |
REPORTVEC_I | 121 |
REPORTVEC_J | 122 |
REPORTVEC_K | 123 |
TARGSLOT_I | 124 |
TARGSLOT_J | 125 |
TARGSLOT_K | 126 |
UPDATEVEC_I | 127 |
UPDATEVEC_J | 128 |
UPDATEVEC_K | 129 |
THEO_MINOR_AXIS | 130 |
TWO_D_THREE_D_TYPE | 131 |
AXIS | 132 |
DEST_EXPR | 133 |
SRC_EXPR | 134 |
SHOW_IDS | 135 |
SHOW_DETAILS | 136 |
WEIGHT | 137 |
ITEM_USED | 138 |
USE_AXIS | 139 |
AVERAGE_ERROR | 140 |
MEASURE_ALL_FEATURES | 141 |
REPIERCE_CAD | 142 |
START_NUM | 143 |
END_NUM | 144 |
SKIP_NUM | 145 |
X_OFFSET | 146 |
Y_OFFSET | 147 |
Z_OFFSET | 148 |
ANGLE_OFFSET | 149 |
INTERNAL_EXTERNAL | 150 |
SAVE_ALIGN_CAD_TO_PARTS | 151 |
FILE_NAME | 152 |
ALIGN_LIST | 153 |
WORK_PLANE | 154 |
DISTANCE | 155 |
OLD_TIP | 156 |
NEW_TIP | 157 |
ROTATION_TYPE | 158 |
DIM_INFO_ORDER | 159 |
DIM_INFO_LOC | 160 |
DIM_INFO_TP_LOC | 161 |
GRAPH_ANALYSIS | 162 |
TEXT_ANALYSIS | 163 |
ARROW_MULTIPLIER | 164 |
OUTPUT_TYPE | 165 |
NOMINAL | 166 |
F_PLUS_TOL | 167 |
F_MINUS_TOL | 168 |
TP_MODIFIER | 169 |
PERP_PARALLEL_TYPE | 170 |
RADIUS_TYPE | 171 |
UNIT_TYPE | 172 |
DIM_LENGTH | 173 |
PROFILE_FORM_TYPE | 174 |
PRECISION | 175 |
MAN_RETRACT | 176 |
DIM_TEXT | 177 |
DIM_TEXT_OPTIONS | 178 |
SHOW_HEADINGS | 179 |
DEVIATION_SYMBOLS | 180 |
STANDARD_DEVIATION | 181 |
DIM_HEADING | 182 |
GAP_ONLY_TYPE | 183 |
DISPLAY_ID | 184 |
DISPLAY_TYPE | 185 |
POINT_INFO_HEADING | 186 |
SHOW_POINT_INFO | 187 |
RET_ONLY_TYPE | 188 |
COMMENT_FIELD | 189 |
COMMENT_TYPE | 190 |
PART_NAME | 191 |
REVISION_NUMBER | 192 |
SERIAL_NUMBER | 193 |
STAT_COUNT | 194 |
SUB_NAME | 195 |
READ_WRITE | 196 |
FILE_POINTER | 197 |
FIELD_WIDTH | 198 |
DIGIT_COUNT | 199 |
LABEL_ID | 200 |
ERROR_TYPE | 201 |
ERROR_MODE | 202 |
DESCRIPTION | 203 |
INDEX_START | 204 |
INDEX_END | 205 |
FILE_COMMAND_TYPE | 206 |
BUFFER_SIZE_TYPE | 207 |
FAIL_ON_EXIST | 208 |
MAX_FORCE | 209 |
LOW_FORCE | 210 |
UP_FORCE | 211 |
TRIGGER_FORCE | 212 |
PROBE_ACCURACY | 213 |
POSITIONAL_ACCURACY | 214 |
NUM_RETURN_DATA | 215 |
RETURN_SPEED | 216 |
SCAN_DENSITY | 217 |
POLAR_VECTOR_COMPENSATION | 218 |
AUTO_PRINT | 219 |
ORIGIN | 220 |
MATERIAL_COEFFICIENT | 221 |
REF_TEMP | 222 |
HIGH_THRESHOLD | 223 |
LOW_THRESHOLD | 224 |
SENSOR_LIST | 225 |
FIXTURE_TYPE | 226 |
MACHINE_TYPE | 227 |
PROBE_COMP | 228 |
TIP_I | 229 |
TIP_J | 230 |
TIP_K | 231 |
NORM_RELEARN | 232 |
FIND_NOMS_TYPE | 233 |
AUTO_CLEAR_PLANE | 234 |
SINGLE_POINT | 235 |
DISPLAY_HITS | 236 |
CAD_TOLERANCE | 237 |
OFFSET_TOLERANCE | 238 |
MIN_INCREMENT | 239 |
MAX_INCREMENT | 240 |
MIN_ANGLE | 241 |
MAX_ANGLE | 242 |
F_LOCATION | 243 |
COL132_TYPE | 244 |
COMMAND_STRING | 245 |
FLY_MODE_TYPE | 246 |
STATS_TYPE | 247 |
STATS_DIR | 248 |
NEW_STATS_DIR | 249 |
DATA_READ_LOCK | 250 |
DATA_WRITE_LOCK | 251 |
DATA_MEM_PAGES | 252 |
STAT_NAME_TYPE | 253 |
STAT_CALC_TYPE | 254 |
TRANSFER_DIR | 255 |
DISPLAY_TRACE | 256 |
TRACE_NAME | 257 |
TRACE_VALUE | 258 |
SCAN_CUTPLANEVEC_I | 259 |
SCAN_CUTPLANEVEC_J | 260 |
SCAN_CUTPLANEVEC_K | 261 |
SCAN_INITVEC_I | 262 |
SCAN_INITVEC_J | 263 |
SCAN_INITVEC_K | 264 |
SCAN_AXISVEC_I | 265 |
SCAN_AXISVEC_J | 266 |
SCAN_AXISVEC_K | 267 |
SCAN_ENDVEC_I | 268 |
SCAN_ENDVEC_J | 269 |
SCAN_ENDVEC_K | 270 |
SCAN_INITDIR_I | 271 |
SCAN_INITDIR_J | 272 |
SCAN_INITDIR_K | 273 |
SCAN_CROSS_TOTAL | 274 |
SCAN_TIME_INCR | 275 |
SCAN_EDGE_THICK | 276 |
POS_REPORT_AXIS_X | 277 |
POS_REPORT_AXIS_Y | 278 |
POS_REPORT_AXIS_Z | 279 |
DEV_PERPEN_CENTERLINE | 280 |
USE_THEO | 281 |
TARGET_COLOR | 282 |
THEO_START_ANG | 283 |
THEO_END_ANG | 284 |
ONOFF_TYPE | 285 |
ROW_ID | 286 |
LOCATOR_BMP | 287 |
LOCATOR_WAV | 288 |
DTYPE_LEAPFROGTYPE | 289 |
DTYPE_LEAPFROGNUMHITS | 290 |
DTYPE_LEAPFROGFULLPARTIAL | 291 |
EXCLUSION_ZONE | 292 |
EXECUTE | 293 |
AUTOTRIGGERONOFF | 294 |
AUTOBEEPING | 295 |
COLUMN_ID | 296 |
SLOT_NUMBER | 297 |
AUTOTOLZONE | 298 |
PROBING_MODE | 299 |
ANGLE_COMP_TOGGLE | 300 |
POINTINFO_FILTER_INTERVAL | 301 |
POINTINFO_FILTER_INTERVAL_NUMBER | 302 |
FEAT_TYPE | 303 |
DIM_ID | 304 |
MEAS_MINOR_AXIS | 305 |
MEAS_HEIGHT | 306 |
MEAS_SLOTVEC_I | 307 |
MEAS_SLOTVEC_J | 308 |
MEAS_SLOTVEC_K | 309 |
MEAS_SX | 310 |
MEAS_SY | 311 |
MEAS_SZ | 312 |
MEAS_EX | 313 |
MEAS_EY | 314 |
MEAS_EZ | 315 |
MEAS_WIDTH | 316 |
NUM_CONTROL_POINTS | 317 |
U_HITS | 318 |
V_HITS | 319 |
NUM_FIT_POINTS | 320 |
NOMINAL_COLOR | 321 |
WAVE_FILE | 322 |
DIM_BONUS | 324 |
PERUNIT_STEPSIZE | 325 |
PERUNIT_LENGTH | 326 |
PERUNIT_WIDTH | 327 |
DIM_MEASURED | 328 |
SURFVEC_TARG_I | 329 |
SURFVEC_TARG_J | 330 |
SURFVEC_TARG_K | 331 |
DIM_MAX | 332 |
EDGEVEC_TARG_I | 333 |
EDGEVEC_TARG_J | 334 |
EDGEVEC_TARG_K | 335 |
DIM_MIN | 336 |
EDGEVEC_THEO_I | 337 |
EDGEVEC_THEO_J | 338 |
EDGEVEC_THEO_K | 339 |
DIM_DEVIATION | 340 |
EDGEVEC_MEAS_I | 341 |
EDGEVEC_MEAS_J | 342 |
EDGEVEC_MEAS_K | 343 |
DIM_OUTTOL | 344 |
T_VALUE | 345 |
TOOL_X | 346 |
TOOL_Y | 347 |
TOOL_Z | 348 |
TOOL_DIAM | 349 |
DEV_X | 350 |
DEV_Y | 351 |
DEV_Z | 352 |
DEV_DIAM | 353 |
ITERATE_COLUMNS | 354 |
LOAD_TYPE | 355 |
NUM_ITERATIONS | 356 |
METHOD_TYPE | 357 |
SCAN_TECHNIQUE | 358 |
HIT_TYPE | 359 |
BOUNDARY_POINT_X | 360 |
BOUNDARY_POINT_Y | 361 |
BOUNDARY_POINT_Z | 362 |
VIDEO_GAIN | 363 |
VIDEO_OFFSET | 364 |
VIDEO_LEDLIGHT | 365 |
VIDEO_LASERLIGHT1 | 366 |
VIDEO_LASERLIGHT2 | 367 |
VIDEO_YORIGIN | 368 |
VIDEO_YEND | 369 |
VIDEO_LSEG | 370 |
VIDEO_XSEG | 371 |
VIDEO_YSEG | 372 |
ANGULARITY_NOM_ANGLE | 373 |
PRINT_TO_FILE | 374 |
PRINT_TO_PRINTER | 375 |
PRINT_DRAFTMODE | 376 |
PRINT_DELETE_RUNS | 377 |
POINTINFO_FILTER_WORST | 378 |
POINTINFO_FILTER_WORST_NUMBER | 379 |
POINTINFO_FILTER_DEVIATION | 380 |
POINTINFO_FILTER_DEVIATION_NUMBER | 381 |
POINTINFO_FILTER_OUTTOL | 382 |
REPORT_SURFVEC_I | 383 |
REPORT_SURFVEC_J | 384 |
REPORT_SURFVEC_K | 385 |
DB_QUERY_OP | 386 |
DB_SOURCE_NAME | 387 |
CHART_TYPE | 388 |
DB_CHART_NAME | 389 |
DEVIATION_ANGLE | 390 |
STATS_DATASOURCE | 391 |
IGNOREMOTIONERRORS_TYPE | 392 |
THEO_X2 | 393 |
THEO_Y2 | 394 |
THEO_Z2 | 395 |
MEAS_X2 | 396 |
MEAS_Y2 | 397 |
MEAS_Z2 | 398 |
PPROG | 399 |
TRACE_FILTER | 400 |
TIME_FILTER | 401 |
SHOW_SPC_CALCS | 402 |
SPEC_LIMITS | 403 |
ZONES | 404 |
STDDEV | 405 |
UCL_LCL | 406 |
HISTOGRAM | 407 |
GRID | 408 |
ADDITIONAL_CHART | 409 |
LINE2_PLANAR_OPEN_IN_X | 410 |
LINE3_PLANAR_OPEN_IN_X | 411 |
REGR | 412 |
CENTER_POINT | 413 |
SHOW_MORE_SPC_CALCS | 414 |
SPEC_OFFSET | 415 |
SOLID | 416 |
U_L_BOUNDS | 417 |
TITLE | 418 |
CPOINT_X | 419 |
CPOINT_Y | 420 |
CPOINT_Z | 421 |
CPOINT_I | 422 |
CPOINT_J | 423 |
CPOINT_K | 424 |
CPOINT_DIAM | 425 |
CPOINT_SCAN_CROSS_TOTAL | 426 |
CPOINT_SCAN_DENSITY | 427 |
CPOINT_F_SCANSPEED | 428 |
N_CONTROLPOINTS | 429 |
CPOINT_TYPE | 430 |
USE_3DFILTER | 431 |
SCAN_BNDRY_TYPE | 432 |
CREATE_WEIGHTS | 433 |
F_SIZE | 434 |
LINE2_ISPLANAR | 435 |
LINE2_PLANAR_XTOL | 436 |
LINE2_PLANAR_YTOL | 437 |
LINE2_PLANAR_XDEV | 438 |
LINE2_PLANAR_YDEV | 439 |
LINE3_ISPLANAR | 440 |
LINE3_PLANAR_XTOL | 441 |
LINE3_PLANAR_YTOL | 442 |
LINE3_PLANAR_XDEV | 443 |
LINE3_PLANAR_YDEV | 444 |
CHART_SUB_TYPE | 445 |
OVERWRITE | 446 |
OUTPUT_FEATURE_NOMS | 447 |
OUTPUT_FEAT_W_DIMENS | 448 |
OUTPUT_DMIS_REPORT | 449 |
TIME_ARG | 450 |
TRACE_FILTER_ARG | 451 |
FIT | 452 |
STATS_DB_TYPE | 453 |
IOCHANNEL_NUMBER | 454 |
IOCHANNEL_PULSE_WIDTH | 455 |
IOCHANNEL_PULSE_INTERVAL | 456 |
IOCHANNEL_PULSE_DURATION | 457 |
GRAPH_OPTION | 458 |
DB_SOURCE_TYPE | 459 |
FIND_HOLE_PERCENT | 460 |
AUTO_ONERROR_TYPE | 461 |
POS_REPT_DISPLAY_OPTION | 462 |
TRIGGERTOLERANCE | 463 |
TRIGGERTOLVALUE | 464 |
FIXTURE_TOL | 465 |
START_LABEL | 466 |
ERROR_LABEL | 467 |
CONE_CONVEX_TYPE | 468 |
TRIGGERPLANE | 469 |
QUERY_SHOW_GRAPHIC_SETTINGS | 470 |
CALC_STYLE_FILE | 471 |
FILTER_TYPE | 472 |
TRACE_VALUE_LIMIT | 473 |
TARGET_DIRECTION | 474 |
TARGET_EDGE_POLARITY | 475 |
BSMETHOD_TYPE | 476 |
CENTER_ROTATION_THEO | 477 |
CENTER_ROTATION_MEAS | 478 |
ARTICULATEDARM_TYPE | 479 |
LEFTYRIGHTY_CONFIG | 480 |
ABOVEBELOW_CONFIG | 481 |
NOFLIPFLIP_CONFIG | 482 |
HIGH_ACCURACY | 483 |
SURFACE | 484 |
MAGNIFICATION | 485 |
MINOR_WORD_TOGGLE | 486 |
PERCENTAGE | 487 |
THRESHOLD | 488 |
N_SIDES | 489 |
TARGET_SURFACE_ILLUM | 490 |
MEAN | 491 |
CAD_COMP | 492 |
SHOW_ROW | 493 |
SHOW_COLUMN | 494 |
TARGET_SURFACE_SENSILIGHT | 495 |
TARGET_SURFACE_WIDTH | 496 |
TARGET_SURFACE_HEIGHT | 497 |
TARGET_SURFACE_RANGE | 498 |
TARGET_SURFACE_DURATION | 499 |
TARGET_SURFACE_MODE | 500 |
TARGET_SURFACE_HIACC | 501 |
SCREEN_CAPTURE_SCALE | 502 |
SCREEN_CAPTURE_QUALITY | 503 |
TARGET_EDGE_SIZE | 504 |
TARGET_EDGE_ILLUM | 505 |
TARGET_EDGE_TOL | 506 |
TARGET_EDGE_STRENGTH | 507 |
TARGET_EDGE_DENSITY | 508 |
TARGET_EDGE_TYPE | 509 |
DISPLAY_ADVANCED_PARAMETERS | 510 |
TARGET_SURFACE_TYPE | 511 |
VOID_DETECT | 512 |
TARG_SX | 513 |
TARG_SY | 514 |
TARG_SZ | 515 |
TARG_EX | 516 |
TARG_EY | 517 |
TARG_EZ | 518 |
PATTERN_TYPE | 519 |
TARGET_EDGE_ANGLE | 520 |
PROGRAM_GAGE_FEAT_TYPE | 521 |
PROGRAM_GAGE_TYPE | 522 |
TARGET_FOCUS | 523 |
RMEASFEATIDX | 524 |
RMEASFEATIDY | 525 |
RMEASFEATIDZ | 526 |
FINDNOMS_BESTFIT | 527 |
FINDNOMS_ONLYSELECTED | 528 |
TEMPX | 529 |
TEMPY | 530 |
TEMPZ | 531 |
TEMPP | 532 |
AUTO_PH9 | 533 |
MANUAL_PREPOSITION | 534 |
SCREEN_CAPTURE_TYPE | 535 |
SCREEN_CAPTURE_AUTO_TYPE | 536 |
TARGET_EDGE_EDGESELECT | 537 |
TARGET_EDGE_EDGENUM | 538 |
DELETE_TYPE | 539 |
SCREEN_CAPTURE_AUTO_TIME | 540 |
USE_HSSDAT | 541 |
USE_STARTENDDELAY | 542 |
COP_FILTER | 543 |
COP_SIZE | 544 |
COP_TYPE | 545 |
SURFVEC_MEAS_I | 546 |
SURFVEC_MEAS_J | 547 |
SURFVEC_MEAS_K | 548 |
TARGET_EDGE_UNDERSCAN | 549 |
PROFILE_TYPE | 550 |
THEO_FLUSH | 551 |
MEAS_FLUSH | 552 |
THEO_GAP | 553 |
MEAS_GAP | 554 |
THEO_DEPTH | 555 |
MEAS_DEPTH | 556 |
TARGET_BLOB_TYPE | 557 |
LASER_STRIPE_OVERLAP | 558 |
LASER_STRIPE_OVERSCAN | 559 |
LASER_FREQUENCY | 560 |
TARGET_FILTER_OUTLIER | 561 |
TARGET_FILTER_OUTLIER_DISTANCE_THRESHOLD | 562 |
SLOT_TYPE | 563 |
TARGET_TYPE | 564 |
THEO_R | 565 |
THEO_A | 566 |
THEO_H | 567 |
MEAS_R | 568 |
MEAS_A | 569 |
MEAS_H | 570 |
TARG_R | 571 |
TARG_A | 572 |
TARG_H | 573 |
THEO_SR | 574 |
THEO_SA | 575 |
THEO_SH | 576 |
THEO_ER | 577 |
THEO_EA | 578 |
THEO_EH | 579 |
MEAS_SR | 580 |
MEAS_SA | 581 |
MEAS_SH | 582 |
MEAS_ER | 583 |
MEAS_EA | 584 |
MEAS_EH | 585 |
TARG_SR | 586 |
TARG_SA | 587 |
TARG_SH | 588 |
TARG_ER | 589 |
TARG_EA | 590 |
TARG_EH | 591 |
TARGET_EDGE_SENSILIGHT | 592 |
F_THICKNESS_EDGE | 593 |
THICKNESS_TYPE_EDGE | 594 |
LASER_EXPOSURE | 595 |
LASER_INTENSITY | 596 |
ANGLE_OFFSET_2 | 597 |
LASER_FILTER_NEIGHBOR_NUM | 598 |
TARGET_FILTER_OUTLIER_STD_DEV_THRESHOLD | 599 |
LASER_FILTER_TOL_ABOVE | 600 |
LASER_FILTER_TOL_BELOW | 601 |
LASER_FILTER_TOL_RIGHT | 602 |
LASER_CLIP_UP_DIST | 603 |
LASER_CLIP_LOW_DIST | 604 |
LASER_PIXEL_TOGGLE | 605 |
LASER_FILTER_TOGGLE | 606 |
DISPLAY_PROBE_PARAMETERS | 607 |
THEO_R2 | 608 |
THEO_A2 | 609 |
THEO_H2 | 610 |
MEAS_R2 | 611 |
MEAS_A2 | 612 |
MEAS_H2 | 613 |
LASER_CLIP_LEFT_DIST | 614 |
LASER_CLIP_RIGHT_DIST | 615 |
COP_FILETYPE | 616 |
COP_SELECTIONTYPE | 617 |
COP_COLORMAP | 618 |
COP_COPLEMENT | 619 |
OPERTYPE | 620 |
COP_BOOLEANTYPE | 621 |
COP_IMPORTFILETYPE | 622 |
MEAS_START_ANG | 623 |
MEAS_END_ANG | 624 |
ISLAND_DIAM | 625 |
ISLAND_LENGTH | 626 |
ISLAND_WIDTH | 627 |
ISLAND_X | 628 |
ISLAND_Y | 629 |
ISLAND_Z | 630 |
ISLAND_I | 631 |
ISLAND_J | 632 |
ISLAND_K | 633 |
ISLAND_AI | 634 |
ISLAND_AJ | 635 |
ISLAND_AK | 636 |
ISLAND_TYPE | 637 |
ISLAND_CLEARANCEDIST | 638 |
RPT_DIMENSION_TABLES | 639 |
SUMMARY_DEV | 640 |
DRF_TBLHDR | 641 |
LINE1_TBLHDR | 642 |
LINE1_CALLOUT | 643 |
LINE1_COLUMN_HDR | 644 |
LINE1_FEATNAME | 645 |
LINE1_NOMINAL | 646 |
LINE1_MEAS | 647 |
LINE1_PLUSTOL | 648 |
LINE1_MINUSTOL | 649 |
LINE1_DEV | 650 |
LINE1_DEVPERCENT | 651 |
LINE1_ISBILATERAL | 652 |
LINE1_NUMZONES | 653 |
LINE2_TBLHDR | 654 |
LINE2_CALLOUT | 655 |
LINE2_COLUMN_HDR | 656 |
LINE2_FEATNAME | 657 |
LINE2_BONUS | 658 |
LINE2_TOL | 659 |
LINE2_DATUMSHFT | 660 |
LINE2_UNUSEDZONE | 661 |
LINE2_DEV | 662 |
LINE2_DEVANG | 663 |
LINE2_DEVPERCENT | 664 |
LINE3_TBLHDR | 665 |
LINE3_CALLOUT | 666 |
LINE3_COLUMN_HDR | 667 |
LINE3_FEATNAME | 668 |
LINE3_BONUS | 669 |
LINE3_TOL | 670 |
LINE3_DATUMSHFT | 671 |
LINE3_UNUSEDZONE | 672 |
LINE3_DEV | 673 |
LINE3_DEVANG | 674 |
LINE3_DEVPERCENT | 675 |
DRF_COLUMN_HDR | 676 |
DRF_SEGNAME | 677 |
DRF_SHIFTX | 678 |
DRF_SHIFTY | 679 |
DRF_SHIFTZ | 680 |
DRF_ROTATIONX | 681 |
DRF_ROTATIONY | 682 |
DRF_ROTATIONZ | 683 |
SUMMARY_COLUMN_HDR | 684 |
SUMMARY_FEAT | 685 |
LINE2_AXIS | 686 |
LINE2_NOMINAL | 687 |
LINE2_MEAS | 688 |
SUMMARY_TBLHDR | 689 |
SUMMARY_AXIS | 690 |
SUMMARY_NOMINAL | 691 |
SUMMARY_MEAS | 692 |
LINE2_PLUSTOL | 693 |
LINE2_MINUSTOL | 694 |
LINE2_MAX | 695 |
LINE2_MIN | 696 |
LINE2_ISBILATERAL | 697 |
LINE2_NUMZONES | 698 |
LINE3_ISBILATERAL | 699 |
LINE3_NUMZONES | 700 |
DIM_RPT_COLUMN_HDR | 701 |
DIM_RPT_ISDATUM | 702 |
DIM_RPT_DATUM | 703 |
DIM_RPT_GRAPHIC | 704 |
DIM_RPT_DEVPERCENT | 705 |
DIM_RPT_ISBILATERAL | 706 |
DIM_RPT_NUMZONES | 707 |
GDT_SYMBOL | 708 |
COMMENT_INPUT | 709 |
TARGET_EDGE_WIDTH | 710 |
TARGET_EDGE_HEIGHT | 711 |
TARGET_EDGE_EDGEDETECT | 712 |
TARGET_EDGE_FILTER_CLEAN | 713 |
TARGET_EDGE_FILTER_CLEAN_STRENGTH | 714 |
TARGET_EDGE_FILTER_AREA | 715 |
TARGET_EDGE_FILTER_AREA_SIZE | 716 |
TARGET_EDGE_GRADIENT | 717 |
THEO_PERIMETER | 718 |
MEAS_PERIMETER | 719 |
THEO_AREA | 720 |
MEAS_AREA | 721 |
TARGET_SURFACE_CROSSHAIR_HEIGHT | 722 |
SHOW_NOMS | 723 |
COMPOSITE | 724 |
DATUM2 | 725 |
TP_MODIFIER2 | 726 |
DESCRIPTION2 | 727 |
SHOW_OPTIONS | 728 |
LEADER_LINE_ID | 729 |
GDT_SYMBOL2 | 730 |
DATUM1_MODIFIER | 731 |
DATUM2_MODIFIER | 732 |
DATUM3_MODIFIER | 733 |
DATUM1_MODIFIER2 | 734 |
DATUM2_MODIFIER2 | 735 |
DATUM3_MODIFIER2 | 736 |
DIM_RPT_DEVPERCENT_NOM | 737 |
DIM_RPT_USETWODEVIATIONS | 738 |
DIM_RPT_DEVPERCENT2 | 739 |
LINE2_DEVPERCENT_NOM | 740 |
LINE2_USE2DEVIATIONS | 741 |
LINE2_DEVPERCENT2 | 742 |
LINE3_DEVPERCENT_NOM | 743 |
LINE3_USE2DEVIATIONS | 744 |
LINE3_DEVPERCENT2 | 745 |
AXIS_PLUS_TOL | 746 |
AXIS_MINUS_TOL | 747 |
AXIS_NOMINAL | 748 |
AXIS_DESCRIPTION | 749 |
LINE1_DEVPERCENT_NOM | 750 |
LINE1_USE2DEVIATIONS | 751 |
LINE1_DEVPERCENT2 | 752 |
USE_AXIS2 | 753 |
DIM_LENGTH2 | 754 |
TEXTANAL_LABEL_MEAS_X | 755 |
TEXTANAL_LABEL_MEAS_Y | 756 |
TEXTANAL_LABEL_MEAS_Z | 757 |
TEXTANAL_LABEL_MEAS_I | 758 |
TEXTANAL_LABEL_MEAS_J | 759 |
TEXTANAL_LABEL_MEAS_K | 760 |
TEXTANAL_LABEL_DEV | 761 |
TEXTANAL_LABEL_MINMAX | 762 |
SIMULT_EVAL | 763 |
SECTION_INDEX | 764 |
LINE1_OUTTOL | 765 |
LINE2_OUTTOL | 766 |
LINE3_OUTTOL | 767 |
LINE1_MAX | 768 |
LINE1_MIN | 769 |
LINE3_NOMINAL | 770 |
LINE3_MEAS | 771 |
LINE3_PLUSTOL | 772 |
LINE3_MINUSTOL | 773 |
LINE3_MAX | 774 |
LINE3_MIN | 775 |
SUMMARY_OUTTOL | 776 |
SUMMARY_PLUSTOL | 777 |
SUMMARY_MINUSTOL | 778 |
SUMMARY_MAX | 779 |
SUMMARY_MIN | 780 |
SUMMARY_BONUS | 781 |
LINE1_BONUS | 782 |
GRAPH_ANALYSIS_POINT_SIZE | 783 |
GRAPH_ANALYSIS_PLUS_TOL | 784 |
GRAPH_ANALYSIS_MINUS_TOL | 785 |
DIM_AXIS_ITEM_NUMBER | 786 |
F_ENDING_DEPTH | 787 |
DIM_ITEM_NUMBER | 788 |
FEAT_ITEM_NUMBER | 789 |
COMMAND_TYPE | 790 |
DEV_MAX | 791 |
AUTO_DEV_DIRECTION | 792 |
PROBE_DIRECTION | 793 |
USER_DEFINED_THEOS | 794 |
SCALING | 795 |
USE_SCALING | 796 |
UID | 797 |
REF_UID | 798 |
BA_SOLUTION_TYPE | 799 |
BA_SOLUTION_OPTIONS | 800 |
BA_SOLUTION_STATUS | 801 |
BA_VARIANCE | 802 |
BA_RMS | 803 |
BA_WARNINGS | 804 |
BA_STATION | 805 |
BA_STATION_X | 806 |
BA_STATION_Y | 807 |
BA_STATION_Z | 808 |
BA_STATION_ROTX | 809 |
BA_STATION_ROTY | 810 |
BA_STATION_ROTZ | 811 |
BA_STATION_ORIENTED | 812 |
BA_STATION_LOCKED | 813 |
BA_FEATURE | 814 |
BA_FEAT_SOURCE | 815 |
BA_FEAT_RMS | 816 |
BA_FEAT_POINTING_ERR | 817 |
BA_FEAT_APEX_ANGLE | 818 |
BA_FEAT_X | 819 |
BA_FEAT_Y | 820 |
BA_FEAT_Z | 821 |
BA_FEAT_DEV_X | 822 |
BA_FEAT_DEV_Y | 823 |
BA_FEAT_DEV_Z | 824 |
BA_FEAT_DEV3D | 825 |
NO_APPROACH_VECTOR_FLIP | 826 |
TARGET_EDGE_START_VALUE | 827 |
TARGET_EDGE_END_VALUE | 828 |
TARGET_SURFACE_SURFACE_VARIANCE | 829 |
RELATIVE_COMMENTS | 830 |
AUTO_ROTARY | 831 |
TARGET_COVERAGE | 832 |
ROTATION_TYPE_2 | 833 |
PROBE_TYPE | 834 |
TIME_STAMP | 835 |
ECOND_TEMP | 836 |
ECOND_PRESSURE | 837 |
ECOND_HUMIDITY | 838 |
HIT_RMS | 839 |
DISPLAY_TRACKER_PARAMETERS | 840 |
PTDENSITY_TOGGLE | 841 |
PTDENSITY_UPPERBOUND | 842 |
PTDENSITY_DEVLIMIT | 843 |
PTDENSITY_MAXSPAN | 844 |
TARGET_MEASURE_AT_FOV_CENTER | 845 |
TARGET_SURFACE_FIND_SURFACE | 846 |
PROJECTOR | 847 |
INLINE_LEGACY_REPORT | 848 |
SINGLE_POINT_DEVIATION | 849 |


ENUM_FILE_IO_TYPES Enumeration

ENUM_FILE_IO_TYPES Enumeration

Members

Member | Value | Description
PCD_FILE_OPEN | 0 |
PCD_FILE_CLOSE | 1 |
PCD_FILE_WRITELINE | 2 |
PCD_FILE_READLINE | 3 |
PCD_FILE_WRITECHARACTER | 4 |
PCD_FILE_READCHARACTER | 5 |
PCD_FILE_WRITEBLOCK | 6 |
PCD_FILE_READBLOCK | 7 |
PCD_FILE_REWIND | 8 |
PCD_FILE_SAVEPOSITION | 9 |
PCD_FILE_RECALLPOSITION | 10 |
PCD_FILE_COPY | 11 |
PCD_FILE_MOVE | 12 |
PCD_FILE_DELETE | 13 |
PCD_FILE_EXISTS | 14 |
PCD_FILE_DIALOG | 15 |
PCD_FILE_READUPTO | 16 |


ENUM_FILE_OPEN_TYPES Enumeration

ENUM_FILE_OPEN_TYPES Enumeration

Members

Member | Value | Description
PCD_FILE_WRITE | 1 |
PCD_FILE_READ | 2 |
PCD_FILE_APPEND | 3 |


ENUM_FILTER_TYPES Enumeration

ENUM_FILTER_TYPES Enumeration

Members

Member | Value | Description
FILTER_LINEAR | 0 |
FILTER_POLAR | 1 |


ENUM_GENERIC_ALIGN Enumeration

ENUM_GENERIC_ALIGN Enumeration

Members

Member | Value | Description
GENERIC_ALIGN_DEPENDENT | 0 |
GENERIC_ALIGN_INDEPENDENT | 1 |


ENUM_GENERIC_DISPLAY Enumeration

ENUM_GENERIC_DISPLAY Enumeration

Members

Member | Value | Description
GENERIC_DISPLAY_RADIUS | 0 |
GENERIC_DISPLAY_DIAMETER | 1 |


ENUM_GENERIC_TYPES Enumeration

ENUM_GENERIC_TYPES Enumeration

Members

Member | Value | Description
GENERIC_POINT | 0 |
GENERIC_PLANE | 1 |
GENERIC_LINE | 2 |
GENERIC_CIRCLE | 3 |
GENERIC_SPHERE | 4 |
GENERIC_CYLINDER | 5 |
GENERIC_ROUND_SLOT | 6 |
GENERIC_SQUARE_SLOT | 7 |
GENERIC_CONE | 8 |
GENERIC_NONE | 9 |


ENUM_HATCH_STYLE Enumeration

ENUM_HATCH_STYLE Enumeration

Members

Member | Value | Description
HATCH_STYLE_HORIZONTAL | 0 |
HATCH_STYLE_VERTICAL | 1 |
HATCH_STYLE_FDIAGONAL | 2 |
HATCH_STYLE_BDIAGONAL | 3 |
HATCH_STYLE_CROSS | 4 |
HATCH_STYLE_DIAGCROSS | 5 |
HATCH_STYLE_NONE | 99 |


ENUM_MASTERSLAVEDIALOG_MEASUREARM Enumeration

ENUM_MASTERSLAVEDIALOG_MEASUREARM Enumeration

Members

Member | Value | Description
MEASURE_BOTH | 0 |
MEASURE_MASTER | 1 |
MEASURE_SLAVE | 2 |


ENUM_MASTERSLAVEDIALOG_MEASUREDCC Enumeration

ENUM_MASTERSLAVEDIALOG_MEASUREDCC Enumeration

Members

Member | Value | Description
MEASURE_MANUAL | 0 |
MEASURE_DCC | 1 |


ENUM_PAGE_FORMAT Enumeration

ENUM_PAGE_FORMAT Enumeration

Members

Member | Value | Description
PAPER_LETTER | 1 | Letter 8 1/2 x 11 in
PAPER_LETTERSMALL | 2 | Letter Small 8 1/2 x 11 in
PAPER_TABLOID | 3 | Tabloid 11 x 17 in
PAPER_LEDGER | 4 | Ledger 17 x 11 in
PAPER_LEGAL | 5 | Legal 8 1/2 x 14 in
PAPER_STATEMENT | 6 | Statement 5 1/2 x 8 1/2 in
PAPER_EXECUTIVE | 7 | Executive 7 1/4 x 10 1/2 in
PAPER_A3 | 8 | A3 297 x 420 mm
PAPER_A4 | 9 | A4 210 x 297 mm
PAPER_A4SMALL | 10 | A4 Small 210 x 297 mm
PAPER_A5 | 11 | A5 148 x 210 mm
PAPER_B4 | 12 | B4 (JIS) 250 x 354
PAPER_B5 | 13 | B5 (JIS) 182 x 257 mm
PAPER_FOLIO | 14 | Folio 8 1/2 x 13 in
PAPER_QUARTO | 15 | Quarto 215 x 275 mm
PAPER_10X14 | 16 | 10x14 in
PAPER_11X17 | 17 | 11x17 in
PAPER_NOTE | 18 | Note 8 1/2 x 11 in
PAPER_ENV_9 | 19 | Envelope #9 3 7/8 x 8 7/8
PAPER_ENV_10 | 20 | Envelope #10 4 1/8 x 9 1/2
PAPER_ENV_11 | 21 | Envelope #11 4 1/2 x 10 3/8
PAPER_ENV_12 | 22 | Envelope #12 4 ¾ x 11
PAPER_ENV_14 | 23 | Envelope #14 5 x 11 1/2
PAPER_CSHEET | 24 | C size sheet
PAPER_DSHEET | 25 | D size sheet
PAPER_ESHEET | 26 | E size sheet
PAPER_ENV_DL | 27 | Envelope DL 110 x 220mm
PAPER_ENV_C5 | 28 | Envelope C5 162 x 229 mm
PAPER_ENV_C3 | 29 | Envelope C3 324 x 458 mm
PAPER_ENV_C4 | 30 | Envelope C4 229 x 324 mm
PAPER_ENV_C6 | 31 | Envelope C6 114 x 162 mm
PAPER_ENV_C65 | 32 | Envelope C65 114 x 229 mm
PAPER_ENV_B4 | 33 | Envelope B4 250 x 353 mm
PAPER_ENV_B5 | 34 | Envelope B5 176 x 250 mm
PAPER_ENV_B6 | 35 | Envelope B6 176 x 125 mm
PAPER_ENV_ITALY | 36 | Envelope 110 x 230 mm
PAPER_ENV_MONARCH | 37 | Envelope Monarch 3.875 x 7.5 in
PAPER_ENV_PERSONAL | 38 | 6 3/4 Envelope 3 5/8 x 6 1/2 in
PAPER_FANFOLD_US | 39 | US Std Fanfold 14 7/8 x 11 in
PAPER_FANFOLD_STD_GERMAN | 40 | German Std Fanfold 8 1/2 x 12 in
PAPER_FANFOLD_LGL_GERMAN | 41 | German Legal Fanfold 8 1/2 x 13 in
PAPER_ISO_B4 | 42 | B4 (ISO) 250 x 353 mm
PAPER_JAPANESE_POSTCARD | 43 | Japanese Postcard 100 x 148 mm
PAPER_9X11 | 44 | 9 x 11 in
PAPER_10X11 | 45 | 10 x 11 in
PAPER_15X11 | 46 | 15 x 11 in
PAPER_ENV_INVITE | 47 | Envelope Invite 220 x 220 mm
PAPER_LETTER_EXTRA | 50 | Letter Extra 9 ½ x 12 in
PAPER_LEGAL_EXTRA | 51 | Legal Extra 9 ½ x 15 in
PAPER_TABLOID_EXTRA | 52 | Tabloid Extra 11.69 x 18 in
PAPER_A4_EXTRA | 53 | A4 Extra 9.27 x 12.69 in
PAPER_LETTER_TRANSVERSE | 54 | Letter Transverse 8 ½ x 11 in
PAPER_A4_TRANSVERSE | 55 | A4 Transverse 210 x 297 mm
PAPER_LETTER_EXTRA_TRANSVERSE | 56 | Letter Extra Transverse 9½ x 12 in
PAPER_A_PLUS | 57 | SuperA/SuperA/A4 227 x 356 mm
PAPER_B_PLUS | 58 | SuperB/SuperB/A3 305 x 487 mm
PAPER_LETTER_PLUS | 59 | Letter Plus 8.5 x 12.69 in
PAPER_A4_PLUS | 60 | A4 Plus 210 x 330 mm
PAPER_A5_TRANSVERSE | 61 | A5 Transverse 148 x 210 mm
PAPER_B5_TRANSVERSE | 62 | B5 (JIS) Transverse 182 x 257 mm
PAPER_A3_EXTRA | 63 | A3 Extra 322 x 445 mm
PAPER_A5_EXTRA | 64 | A5 Extra 174 x 235 mm
PAPER_B5_EXTRA | 65 | B5 (ISO) Extra 201 x 276 mm
PAPER_A2 | 66 | A2 420 x 594 mm
PAPER_A3_TRANSVERSE | 67 | A3 Transverse 297 x 420 mm
PAPER_A3_EXTRA_TRANSVERSE | 68 | A3 Extra Transverse 322 x 445 mm
PAPER_DBL_JAPANESE_POSTCARD | 69 | Japanese Double Postcard 200 x 148 mm
PAPER_A6 | 70 | A6 105 x 148 mm
PAPER_JENV_KAKU2 | 71 | Japanese Envelope Kaku #2
PAPER_JENV_KAKU3 | 72 | Japanese Envelope Kaku #3
PAPER_JENV_CHOU3 | 73 | Japanese Envelope Chou #3
PAPER_JENV_CHOU4 | 74 | Japanese Envelope Chou #4
PAPER_LETTER_ROTATED | 75 | Letter Rotated 11 x 8 1/2 11 in
PAPER_A3_ROTATED | 76 | A3 Rotated 420 x 297 mm
PAPER_A4_ROTATED | 77 | A4 Rotated 297 x 210 mm
PAPER_A5_ROTATED | 78 | A5 Rotated 210 x 148 mm
PAPER_B4_JIS_ROTATED | 79 | B4 (JIS) Rotated 364 x 257 mm
PAPER_B5_JIS_ROTATED | 80 | B5 (JIS) Rotated 257 x 182 mm
PAPER_JAPANESE_POSTCARD_ROTATED | 81 | Japanese Postcard Rotated 148 x 100 mm
PAPER_DBL_JAPANESE_POSTCARD_ROTATED | 82 | Double Japanese Postcard Rotated 148 x 200 mm
PAPER_A6_ROTATED | 83 | A6 Rotated 148 x 105 mm
PAPER_JENV_KAKU2_ROTATED | 84 | Japanese Envelope Kaku #2 Rotated
PAPER_JENV_KAKU3_ROTATED | 85 | Japanese Envelope Kaku #3 Rotated
PAPER_JENV_CHOU3_ROTATED | 86 | Japanese Envelope Chou #3 Rotated
PAPER_JENV_CHOU4_ROTATED | 87 | Japanese Envelope Chou #4 Rotated
PAPER_B6_JIS | 88 | B6 (JIS) 128 x 182 mm
PAPER_B6_JIS_ROTATED | 89 | B6 (JIS) Rotated 182 x 128 mm
PAPER_12X11 | 90 | 12 x 11 in
PAPER_JENV_YOU4 | 91 | Japanese Envelope You #4
PAPER_JENV_YOU4_ROTATED | 92 | Japanese Envelope You #4 Rotated
PAPER_P16K | 93 | PRC 16K 146 x 215 mm
PAPER_P32K | 94 | PRC 32K 97 x 151 mm
PAPER_P32KBIG | 95 | PRC 32K(Big) 97 x 151 mm
PAPER_PENV_1 | 96 | PRC Envelope #1 102 x 165 mm
PAPER_PENV_2 | 97 | PRC Envelope #2 102 x 176 mm
PAPER_PENV_3 | 98 | PRC Envelope #3 125 x 176 mm
PAPER_PENV_4 | 99 | PRC Envelope #4 110 x 208 mm
PAPER_PENV_5 | 100 | PRC Envelope #5 110 x 220 mm
PAPER_PENV_6 | 101 | PRC Envelope #6 120 x 230 mm
PAPER_PENV_7 | 102 | PRC Envelope #7 160 x 230 mm
PAPER_PENV_8 | 103 | PRC Envelope #8 120 x 309 mm
PAPER_PENV_9 | 104 | PRC Envelope #9 229 x 324 mm
PAPER_PENV_10 | 105 | PRC Envelope #10 324 x 458 mm
PAPER_P16K_ROTATED | 106 | PRC 16K Rotated
PAPER_P32K_ROTATED | 107 | PRC 32K Rotated
PAPER_P32KBIG_ROTATED | 108 | PRC 32K(Big) Rotated
PAPER_PENV_1_ROTATED | 109 | PRC Envelope #1 Rotated 165 x 102 mm
PAPER_PENV_2_ROTATED | 110 | PRC Envelope #2 Rotated 176 x 102 mm
PAPER_PENV_3_ROTATED | 111 | PRC Envelope #3 Rotated 176 x 125 mm
PAPER_PENV_4_ROTATED | 112 | PRC Envelope #4 Rotated 208 x 110 mm
PAPER_PENV_5_ROTATED | 113 | PRC Envelope #5 Rotated 220 x 110 mm
PAPER_PENV_6_ROTATED | 114 | PRC Envelope #6 Rotated 230 x 120 mm
PAPER_PENV_7_ROTATED | 115 | PRC Envelope #7 Rotated 230 x 160 mm
PAPER_PENV_8_ROTATED | 116 | PRC Envelope #8 Rotated 309 x 120 mm
PAPER_PENV_9_ROTATED | 117 | PRC Envelope #9 Rotated 324 x 229 mm
PAPER_PENV_10_ROTATED | 118 | PRC Envelope #10 Rotated 458 x 324 mm


ENUM_PAGE_ORIENTATION Enumeration

ENUM_PAGE_ORIENTATION Enumeration

Members

Member | Value | Description
ORIENT_PORTRAIT | 1 |
ORIENT_LANDSCAPE | 2 |


ENUM_PCD_COMMENT_TYPES Enumeration

ENUM_PCD_COMMENT_TYPES Enumeration

Members

Member | Value | Description
PCD_COMMENT_OPER | 0 | Operator comment.
PCD_COMMENT_REPORT | 1 | Report comment.
PCD_COMMENT_INPUT | 2 | Input comment.
PCD_COMMENT_DOCUMENTATION | 3 | Documentation comment.
PCD_COMMENT_YESNO | 4 | Yes/No comment.
PCD_COMMENT_READOUT | 5 | Readout comment.


ENUM_PCD_ON_OFF Enumeration

ENUM_PCD_ON_OFF Enumeration

Members

Member | Value | Description
DMIS_OFF | 0 | Does not print in draft form.
DMIS_ON | 1 | Prints in draft form.


ENUM_PCD_STAT_TYPES Enumeration

ENUM_PCD_STAT_TYPES Enumeration

Members

Member | Value | Description
PCD_STATS_OFF | 0 |
PCD_STATS_ON | 1 |
PCD_STATS_TRANSFER | 2 |
PCD_STATS_UPDATE | 3 |
PCD_STATS_DATABASE | 4 |
PCD_STATS_RECORD | 5 |


ENUM_PCDMSG_RETVALS Enumeration

ENUM_PCDMSG_RETVALS Enumeration

Members

Member | Value | Description
PCDMSG_OK | 1 |
PCDMSG_CANCEL | 2 |
PCDMSG_ABORT | 3 |
PCDMSG_RETRY | 4 |
PCDMSG_IGNORE | 5 |
PCDMSG_YES | 6 |
PCDMSG_NO | 7 |


ENUM_PCDMSG_TYPES Enumeration

ENUM_PCDMSG_TYPES Enumeration

Members

Member | Value | Description
MSGTYP_OK | 0 |
MSGTYP_OKCANCEL | 1 |
MSGTYP_ABORTRETRYIGNORE | 2 |
MSGTYP_YESNOCANCEL | 3 |
MSGTYP_YESNO | 4 |
MSGTYP_RETRY_CANCEL | 5 |
MSGTYP_ICONHAND | 16 |
MSGTYP_ICONQUESTION | 32 |
MSGTYP_ICONEXCLAMATION | 48 |
MSGTYP_ICONASTERISK | 64 |
MSGTYP_DEFBUTTON2 | 256 |
MSGTYP_DEFBUTTON3 | 512 |


ENUM_PLANE_TYPE Enumeration

ENUM_PLANE_TYPE Enumeration

Members

Member | Value | Description
PLANE_TOP | 0 |
PLANE_RIGHT | 1 |
PLANE_BACK | 2 |
PLANE_BOTTOM | 3 |
PLANE_LEFT | 4 |
PLANE_FRONT | 5 |


ENUM_QUAL_CREATE_REPLACE Enumeration

ENUM_QUAL_CREATE_REPLACE Enumeration

Members

Member | Value | Description
CREATE_NEW_MAP | 0 |
REPLACE_CLOSET_MAP | 1 |


ENUM_REPORT_TEMPLATE_OBJECTS Enumeration

ENUM_REPORT_TEMPLATE_OBJECTS Enumeration

Members

Member | Value | Description
ID_HOB_TEXT | 60448 |
ID_HOB_TEXT_RT | 60449 |
ID_HOB_LINE | 60450 |
ID_HOB_POLYLINE | 60472 |
ID_HOB_BORDER | 60473 |
ID_HOB_ARC | 60478 |
ID_HOB_CIRCLE | 60471 |
ID_HOB_BITMAP | 60462 |
ID_HOB_PTR | 60459 |
ID_HOB_GAUGE | 60452 |
ID_HOB_GRAPH | 60458 |
ID_HOB_PCD_TEXT_REPORT_OBJECT | 26515 |
ID_HOB_PCD_CAD_REPORT_OBJECT | 26514 |
ID_HOB_PCD_COMMAND_TEXT_OB | 26324 |
ID_HOB_PCD_GRID_CTRL_OB | 19100 |
ID_HOB_PCD_LEADERLINE_OB | 19101 |
ID_HOB_PCD_DIMCOLOR_OB | 19102 |
ID_HOB_PCD_ANALWIN_OB | 19104 |
ID_HOB_CADIMAGEOBJECT_OB | 19105 |
ID_HOB_PCD_SPC_CHART_OB | 26619 |
ID_HOB_PCD_LABEL_OB | 26603 |


ENUM_RMEAS_MODE Enumeration

ENUM_RMEAS_MODE Enumeration

Members

Member | Value | Description
RMEAS_NORMAL | 0 |
RMEAS_ABSOLUTE | 1 |


ENUM_RMEAS_MODE_NEW Enumeration

ENUM_RMEAS_MODE_NEW Enumeration

Members

Member | Value | Description
RMEAS_LEGACY | 0 |
RMEAS_DEFAULT | 1 |


ENUM_SCAN_INOUT_TYPES Enumeration

ENUM_SCAN_INOUT_TYPES Enumeration

Members

Member | Value | Description
SCAN_INNER | 0 | Inside scans
SCAN_OUTER | 1 | Outside scans
SCAN_PLANAR | 2 | Plane Circle scans


ENUM_STAT_NAME_TYPES Enumeration

ENUM_STAT_NAME_TYPES Enumeration

Members

Member | Value | Description
PCD_STAT_DIM_NAME | 0 |
PCD_STAT_FEAT_NAME | 1 |


ENUM_TIPTYPES Enumeration

ENUM_TIPTYPES Enumeration

Members

Member | Value | Description
TIP_BALL | 0 |
TIP_DISK | 1 |
TIP_SHANK | 2 |
TIP_OPTIC | 4 |
TIP_ANALOG_BALL | 16 |
TIP_ANALOG_DISK | 17 |
TIP_ANALOG_SHANK | 18 |
TIP_ANALOG_OPTIC | 20 |
TIP_FIXED_BALL | 32 |
TIP_FIXED_DISK | 33 |
TIP_FIXED_SHANK | 34 |
TIP_FIXED_OPTIC | 36 |
TIP_SP600 | 64 |
TIP_WB_OPTIC | 128 |
TIP_INFINIT_ARM | 256 |
TIP_SLAVE | 512 |


ENUM_TOOL_MOVED Enumeration

ENUM_TOOL_MOVED Enumeration

Members

Member | Value | Description
TOOL_MOVED_NO | 0 |
TOOL_MOVED_YES | 1 |
TOOL_MOVED_ASK | 2 |


ENUM_TRANSFORMATION_TYPES Enumeration

ENUM_TRANSFORMATION_TYPES Enumeration

Members

Member | Value | Description
ROTATE_AND_TRANSLATE | 0 |
ROTATE_ONLY | 1 |
MAJOR_MINOR_THIRD_ROT_AND_TRANS | 2 |
MAJOR_MINOR_THIRD_ROTATE_ONLY | 3 |


ENUM_VISION_TARGET_EDGE_SELECTION Enumeration

ENUM_VISION_TARGET_EDGE_SELECTION Enumeration

Members

Member | Value | Description
VISION_TES_DOMINANT_EDGE | 0 |
VISION_TES_NEAREST_NOMINAL_EDGE | 1 |
VISION_TES_MATCHING_EDGE | 2 |
VISION_TES_SPECIFIED_EDGE | 3 |


ENUM_VISION_TARGET_FOCUS_RANGE Enumeration

ENUM_VISION_TARGET_FOCUS_RANGE Enumeration

Members

Member | Value | Description
VISION_TFR_TENTHMM | 0 |
VISION_TFR_HALFMM | 1 |
VISION_TFR_1MM | 2 |
VISION_TFR_2MM | 3 |
VISION_TFR_3MM | 4 |
VISION_TFR_4MM | 5 |
VISION_TFR_5MM | 6 |
VISION_TFR_10MM | 7 |
VISION_TFR_20MM | 8 |
VISION_TFR_50MM | 9 |


ENUM_VISION_TARGET_POINT_DENSITY Enumeration

ENUM_VISION_TARGET_POINT_DENSITY Enumeration

Members

Member | Value | Description
VISION_TPD_NONE | 0 |
VISION_TPD_LOW | 1 |
VISION_TPD_NORMAL | 2 |
VISION_TPD_HIGH | 3 |


ENUM_VISION_TARGET_TYPE Enumeration

ENUM_VISION_TARGET_TYPE Enumeration

Members

Member | Value | Description
VISION_TARGET_TYPE_GAGE | 0 |
VISION_TARGET_TYPE_MANUAL_TARGET | 1 |
VISION_TARGET_TYPE_AUTOMATIC | 2 |
VISION_TARGET_TYPE_COMPARATOR | 3 |


ERRORMODES Enumeration

ERRORMODES Enumeration

Members

Member | Value | Description
ERROR_OFF | 0 |
ERROR_JUMPLABEL | 1 |
ERROR_SETVAR | 2 |


ERRORTYPES Enumeration

ERRORTYPES Enumeration

Members

Member | Value | Description
ERROR_UNEXPECTED_HIT | 0 |
ERROR_MISSED_HIT | 1 |


EVALUATION_TYPES Enumeration

EVALUATION_TYPES Enumeration

Members

Member | Value | Description
EVAL_NOMINALS | 1 | Evaluates the feature’s nominals.
EVAL_ACTUALS | 2 | Evaluates the feature’s actuals.
EVAL_BOTH | 3 | Evaluates both the feature’s nominals and actuals.


FDATA_COORDSYS Enumeration

FDATA_COORDSYS Enumeration

Members

Member | Value | Description
FDATA_POLAR | 4 |
FDATA_CAD | 5 |
FDATA_PARTMM3 | 10 |
FDATA_MACHINE | 11 |
FDATA_PART | 13 |


FDATA_DATASET Enumeration

FDATA_DATASET Enumeration

Members

Member | Value | Description
FDATA_THEO | 2 |
FDATA_MEAS | 3 |
FDATA_TARG | 27 |
FDATA_ALL | 100 |


FDATA_TYPES Enumeration

FDATA_TYPES Enumeration

Members

Member | Value | Description
FDATA_CENTROID | 0 |
FDATA_VECTOR | 1 |
FDATA_DIAMETER | 6 |
FDATA_STARTPOINT | 7 |
FDATA_MIDPOINT | 8 |
FDATA_ENDPOINT | 9 |
FDATA_LENGTH | 14 |
FDATA_MINOR_AXIS | 15 |
FDATA_ANGLE | 16 |
FDATA_DEVIATION | 18 |
FDATA_SURFACE_VECTOR | 19 |
FDATA_THICKNESS | 21 |
FDATA_SPACER | 23 |
FDATA_INDENT | 24 |
FDATA_AUTO_MOVE_DISTANCE | 25 |
FDATA_DEPTH | 26 |
FDATA_TARGET | 27 |
FDATA_ANGLE_VECTOR | 29 |
FDATA_PUNCH_VECTOR | 31 |
FDATA_PIN_VECTOR | 33 |
FDATA_PIN_DIAMETER | 35 |
FDATA_REPORT_VECTOR | 36 |
FDATA_REPORT_SURF_VECTOR | 38 |
FDATA_HEIGHT | 40 |
FDATA_MEASURE_VECTOR | 41 |
FDATA_UPDATE_VECTOR | 43 |
FDATA_SNAP_CENTROID | 45 |
FDATA_ANALOG_DEVIATIONS | 46 |
FDATA_CORNER_RADIUS | 47 |
FDATA_AB_ANGLES | 48 |
FDATA_ORG_HIT_VECTOR | 49 |
FDATA_ANGLE2 | 53 |
FDATA_CORNER_VECTOR2 | 58 |
FDATA_CORNER_VECTOR3 | 60 |
FDATA_INDENT2 | 62 |
FDATA_INDENT3 | 63 |
FDATA_OFFSET | 64 |
FDATA_TIPRADIUS | 65 |
FDATA_ROTAB_ANGLE | 66 |
FDATA_SURFACEVECTOR2 | 67 |
FDATA_SURFACEVECTOR2NONORM | 68 |
FDATA_FOCUS1 | 69 |
FDATA_FOCUS2 | 70 |
FDATA_VERTEX | 71 |
FDATA_SCANSEG_START | 72 |
FDATA_SCANSEG_END | 73 |
FDATA_MANSCAN_INCR_DIST | 74 |
FDATA_MANSCAN_INCR_TIME | 75 |
FDATA_WIDTH2 | 76 |
FDATA_MIN_CIRC_SCAN_INIT | 77 |
FDATA_MIN_CIRC_SCAN_DOWN | 78 |
FDATA_FLUSH | 79 |
FDATA_GAP2 | 80 |
FDATA_WIDTH | 2000 |
FDATA_MAJOR_AXIS | 2001 |
FDATA_SLOT_VECTOR | 2002 |


FHITDATA_TYPES Enumeration

FHITDATA_TYPES Enumeration

Members

Member | Value | Description
FHITDATA_CENTROID | 0 |
FHITDATA_VECTOR | 1 |
FHITDATA_BALLCENTER | 12 |


FPOINT_TYPES Enumeration

FPOINT_TYPES Enumeration

Members

Member | Value | Description
FPOINT_CENTROID | 0 |
FPOINT_STARTPOINT | 7 |
FPOINT_MIDPOINT | 8 |
FPOINT_ENDPOINT | 9 |
FPOINT_BALLCENTER | 12 |
FPOINT_SNAP_CENTROID | 45 |


FVECTOR_TYPES Enumeration

FVECTOR_TYPES Enumeration

Members

Member | Value | Description
FVECTOR_VECTOR | 1 |
FVECTOR_SURFACE_VECTOR | 19 |
FVECTOR_ANGLE_VECTOR | 29 |
FVECTOR_PUNCH_VECTOR | 31 |
FVECTOR_PIN_VECTOR | 33 |
FVECTOR_REPORT_VECTOR | 36 |
FVECTOR_REPORT_SURF_VECTOR | 38 |
FVECTOR_MEASURE_VECTOR | 41 |
FVECTOR_UPDATE_VECTOR | 43 |
FVECTOR_ORG_HIT_VECTOR | 49 |
FVECTOR_CORNER_VECTOR2 | 58 |
FVECTOR_CORNER_VECTOR3 | 60 |
FVECTOR_SLOT_VECTOR | 2002 |


GETIDTYPE Enumeration

GETIDTYPE Enumeration

Members

Member | Value | Description
PCD__ALIGNMENT | 1 |
PCD_FEATURE | 31 |
PCD_DIMENSION | 1000 |


GUESSTYPE Enumeration

GUESSTYPE Enumeration

Members

Member | Value | Description
GUESS_MEASURED_POINT | 26201 |
GUESS_MEASURED_LINE | 26202 |
GUESS_MEASURED_PLANE | 26203 |
GUESS_MEASURED_CIRCLE | 26204 |
GUESS_MEASURED_CONE | 26205 |
GUESS_MEASURED_CYLINDER | 26206 |
GUESS_MEASURED_SPHERE | 26207 |
GUESS_MEASURED_ROUND_SLOT | 26208 |
GUESS_MEASURED_SQUARE_SLOT | 26209 |
GUESS_MEASURED_GUESS | 26210 |
GUESS_MANUAL_SCAN | 26211 |


HIGH_POINT_SEARCH_MODES Enumeration

HIGH_POINT_SEARCH_MODES Enumeration

Members

Member | Value | Description
SEARCH_MODE_BOX | 0 |
SEARCH_MODE_CIRCULAR | 1 |


IJKTYPES Enumeration

IJKTYPES Enumeration

Members

Member | Value | Description
PCD__VECTOR | 608 |
PCD_SLOTVECTOR | 609 |
PCD_SURFACEVECTOR | 610 |


ITERATEFLAGS Enumeration

ITERATEFLAGS Enumeration

Members

Member | Value | Description
PCD_BODY_AX | 1 |
PCD_AV_ERROR | 2 |
PCD_MEAS_ALL | 4 |
PCD_MEAS_ALL_ALWAYS | 8 |


MOVEDIRECTION Enumeration

MOVEDIRECTION Enumeration

Members

Member | Value | Description
PCD_CLOCKWISE | 1 |
PCD_COUNTERCLOCKWISE | 2 |
PCD_SHORTEST | 3 |


MOVETYPE Enumeration

MOVETYPE Enumeration

Members

Member | Value | Description
PCD_CLEARPLANE | 90 |
PCD_INCREMENT | 91 |
PCD_CIRCULAR | 92 |
PCD_POINT | 93 |
PCD_ROTAB | 94 |


OBTYPE Enumeration

OBTYPE Enumeration

Description

The Object Type, or OBTYPE, is a special member of the Application (or PCDLRN) object. It contains several constant values tied to enumerations. You can use these values when working with the Commands.Add method and the Command.Type property.

The following list shows the available OBTYPE constants and their equivalent enumerations. These enumerated values are of type LONG:

Members

Member | Value | Description
START_ALIGN | 1 |
LEVEL_ALIGN | 2 |
ROTATE_ALIGN | 3 |
TRANS_ALIGN | 4 |
TRANSOFF_ALIGN | 5 |
ROTATEOFF_ALIGN | 6 |
SAVE_ALIGN | 9 |
RECALL_ALIGN | 10 |
EQUATE_ALIGN | 11 |
ITER_ALIGN | 12 |
BF2D_ALIGN | 13 |
ROTATE_CIRCLE_ALIGN | 14 |
BF3D_ALIGN | 15 |
POINTCLOUD_ALIGN | 16 |
BFUSER_ALIGN | 17 |
END_ALIGN | 19 |
SET_WORKPLANE | 21 |
ATTACH_PROGRAM | 22 |
CURVE_FEATURE | 38 |
SURFACE_FEATURE | 39 |
MOVE_SPEED | 45 |
TOUCH_SPEED | 46 |
SCAN_SPEED | 47 |
VIEWSET | 50 |
RECALL_VIEWSET | 51 |
SET_ACTIVE_TIP | 60 |
GET_PROBE_DATA | 61 |
TEMP_COMP | 62 |
LOOP_START | 70 |
LOOP_END | 71 |
LABEL_CMD | 72 |
GOTO_COMMAND | 73 |
IF_GOTO_COMMAND | 74 |
START_SUBROUTINE | 75 |
CALL_SUBROUTINE | 76 |
END_SUBROUTINE | 77 |
ONERROR | 78 |
WHILE_COMMAND | 79 |
ENDWHILE_COMMAND | 80 |
DO_COMMAND | 81 |
END_IF_COMMAND | 82 |
END_ELSE_IF_COMMAND | 83 |
END_ELSE_COMMAND | 84 |
END_CASE_COMMAND | 85 |
END_SELECT_COMMAND | 86 |
END_DEFAULT_CASE_COMMAND | 87 |
UNTIL_COMMAND | 88 |
IF_BLOCK_COMMAND | 89 |
ELSE_IF_COMMAND | 90 |
ELSE_COMMAND | 91 |
CASE_COMMAND | 92 |
SELECT_COMMAND | 93 |
DEFAULT_CASE_COMMAND | 94 |
ARRAY_INDEX | 95 |
FILE_IO_OBJECT | 96 |
CLAMP | 99 |
PREHIT_DISTANCE | 100 |
RETRACT_DISTANCE | 101 |
CHECK_DISTANCE | 102 |
MAN_DCC_MODE | 103 |
BASIC_HIT | 104 |
VECTOR_HIT | 105 |
CORNER_HIT | 106 |
ANGLE_HIT | 107 |
SURFACE_HIT | 108 |
EDGE_HIT | 109 |
RMEAS_MODE | 110 |
OPTIONPROBE | 111 |
OPTIONMOTION | 112 |
POLARVECTORCOMP | 113 |
DISPLAYPRECISION | 114 |
LEAPFROG | 115 |
AUTOTRIGGERCOMMAND | 116 |
MANRETRACT | 117 |
VIDEOSETUP | 118 |
IGNOREMOTIONERRORS | 119 |
IOCHANNELCOMMAND | 120 |
CLEARANCE_PLANE | 130 |
PROBE_COMPENSATION | 140 |
CALIB_SPHERE | 141 |
CALIB_ASSEMBLY | 142 |
AUTOCALIB_PROBE_COMMAND | 143 |
AUTOCALIB_MASTERSLAVE_COMMAND | 144 |
MOVE_POINT | 150 |
MOVE_CLEARP | 151 |
MOVE_ROTAB | 153 |
MOVE_INCREMENT | 154 |
MOVE_CIRCULAR | 155 |
MOVE_PH9_OFFSET | 156 |
MOVE_SYNC | 157 |
START_MOVE_SWEEP | 158 |
END_MOVE_SWEEP | 159 |
MOVE_SWEEP_POINT | 160 |
MOVE_EXCLUSIVE | 161 |
MOVE_ALL | 162 |
FLY_MODE | 168 |
END_PROGRAM | 169 |
SET_COMMENT | 170 |
LOAD_MACHINE | 171 |
LOAD_FIXTURE | 172 |
LOAD_COLUMN | 173 |
EXTERNAL_COMMAND | 175 |
ANALYSIS_VIEW | 176 |
TABLE_FORMAT | 179 |
DIMENSION_FORMAT | 180 |
COLUMN132_DISPLAY | 181 |
DIMENSION_INFORMATION | 182 |
POINT_INFO | 183 |
FEATURE_CONTROL_FRAME | 184 |
STATISTICS | 190 |
TRACEFIELD | 191 |
READ_POINT | 192 |
GAP_ONLY | 193 |
RETROLINEAR_ONLY | 194 |
ASSIGNMENT | 195 |
POSITIVE_REPORTING | 196 |
MEASURED_POINT | 201 |
MEASURED_CIRCLE | 202 |
MEASURED_SPHERE | 203 |
MEASURED_LINE | 204 |
MEASURED_CONE | 205 |
MEASURED_CYLINDER | 206 |
MEASURED_PLANE | 207 |
MEASURED_ROUND_SLOT | 208 |
MEASURED_SQUARE_SLOT | 209 |
MEASURED_SET | 210 |
DCCSCAN_OBJECT | 211 |
MANSCAN_OBJECT | 212 |
END_MEASURED_FEATURE | 213 |
BASIC_SCAN_OBJECT | 214 |
TRIGGER_TOLERANCE | 231 |
TRIGGER_PLANE_COMMAND | 232 |
VISION_SURFACE_POINT_FEATURE | 241 |
VISION_EDGE_POINT_FEATURE | 242 |
VISION_LINE_FEATURE | 243 |
VISION_ELLIPSE_FEATURE | 244 |
VISION_CIRCLE_FEATURE | 245 |
VISION_SLOT_ROUND_FEATURE | 246 |
VISION_PROFILE_2D_FEATURE | 247 |
VISION_SLOT_SQUARE_FEATURE | 248 |
VISION_ANGLE_POINT_FEATURE | 249 |
VISION_SLOT_NOTCH_FEATURE | 250 |
VISION_POLYGON_FEATURE | 251 |
LASER_CIRCLE_FEATURE | 270 |
LASER_SURFACE_POINT_FEATURE | 271 |
LASER_PLANE_FEATURE | 272 |
LASER_SLOT_FEATURE | 273 |
LASER_FLUSH_AND_GAP_FEATURE | 274 |
LASER_SPHERE_FEATURE | 275 |
LASER_CYLINDER_FEATURE | 279 |
CONST_ROUND_SLOT | 505 |
CONST_BF_SLOT | 506 |
CONST_BFRE_SLOT | 507 |
CONST_ORIG_POINT | 510 |
CONST_OFF_POINT | 511 |
CONST_PROJ_POINT | 512 |
CONST_MID_POINT | 513 |
CONST_DROP_POINT | 514 |
CONST_PIERCE_POINT | 515 |
CONST_INT_POINT | 516 |
CONST_CAST_POINT | 517 |
CONST_CORNER_POINT | 518 |
CONST_BFRE_CIRCLE | 520 |
CONST_BF_CIRCLE | 521 |
CONST_PROJ_CIRCLE | 522 |
CONST_REV_CIRCLE | 523 |
CONST_CONE_CIRCLE | 524 |
CONST_CAST_CIRCLE | 525 |
CONST_INT_CIRCLE | 526 |
CONST_SCAN_SEG_ARC | 527 |
CONST_BFRE_SPHERE | 530 |
CONST_BF_SPHERE | 531 |
CONST_PROJ_SPHERE | 532 |
CONST_REV_SPHERE | 533 |
CONST_CAST_SPHERE | 534 |
CONST_SCAN_SEG_LINE | 539 |
CONST_BFRE_LINE | 540 |
CONST_BF_LINE | 541 |
CONST_PROJ_LINE | 542 |
CONST_REV_LINE | 543 |
CONST_MID_LINE | 544 |
CONST_CAST_LINE | 545 |
CONST_INT_LINE | 546 |
CONST_OFF_LINE | 547 |
CONST_ALN_LINE | 548 |
CONST_PRTO_LINE | 549 |
CONST_PLTO_LINE | 550 |
CONST_BFRE_CONE | 551 |
CONST_BF_CONE | 552 |
CONST_PROJ_CONE | 553 |
CONST_REV_CONE | 554 |
CONST_CAST_CONE | 555 |
CONST_BFRE_CYLINDER | 560 |
CONST_BF_CYLINDER | 561 |
CONST_PROJ_CYLINDER | 562 |
CONST_REV_CYLINDER | 563 |
CONST_CAST_CYLINDER | 564 |
CONST_BFRE_PLANE | 570 |
CONST_BF_PLANE | 571 |
CONST_REV_PLANE | 572 |
CONST_MID_PLANE | 573 |
CONST_CAST_PLANE | 574 |
CONST_OFF_PLANE | 575 |
CONST_ALN_PLANE | 576 |
CONST_PRTO_PLANE | 577 |
CONST_PLTO_PLANE | 578 |
CONST_HIPNT_PLANE | 579 |
CONST_SET | 596 |
GENERIC_CONSTRUCTION | 597 |
FILTER_SET | 598 |
AUTO_VECTOR_FEATURE | 602 |
AUTO_SURFACE_FEATURE | 603 |
AUTO_EDGE_FEATURE | 604 |
AUTO_ANGLE_FEATURE | 605 |
AUTO_CORNER_FEATURE | 606 |
AUTO_HIGH_POINT_FEATURE | 607 |
AUTO_CIRCLE | 612 |
AUTO_SPHERE | 613 |
AUTO_LINE | 614 |
AUTO_CONE | 615 |
AUTO_CYLINDER | 616 |
AUTO_PLANE | 617 |
AUTO_ROUND_SLOT | 618 |
AUTO_SQUARE_SLOT | 619 |
AUTO_ELLIPSE | 621 |
AUTO_NOTCH | 622 |
AUTO_PROFILE_2D | 623 |
AUTO_SLOT | 624 |
AUTO_FLUSH_GAP | 625 |
AUTO_BLOB | 626 |
AUTO_POLYGON | 627 |
CONTACT_VECTOR_POINT_FEATURE | 640 |
CONTACT_SURFACE_POINT_FEATURE | 641 |
CONTACT_EDGE_POINT_FEATURE | 642 |
CONTACT_ANGLE_POINT_FEATURE | 643 |
CONTACT_CORNER_POINT_FEATURE | 644 |
CONTACT_HIGH_POINT_FEATURE | 645 |
CONTACT_LINE_FEATURE | 646 |
CONTACT_PLANE_FEATURE | 647 |
CONTACT_CIRCLE_FEATURE | 648 |
CONTACT_ELLIPSE_FEATURE | 649 |
CONTACT_SLOT_ROUND_FEATURE | 650 |
CONTACT_SLOT_SQUARE_FEATURE | 651 |
CONTACT_SLOT_NOTCH_FEATURE | 652 |
CONTACT_SLOT_FEATURE | 653 |
CONTACT_POLYGON_FEATURE | 654 |
CONTACT_CONE_FEATURE | 655 |
CONTACT_CYLINDER_FEATURE | 656 |
CONTACT_SPHERE_FEATURE | 657 |
DISPLAY_METAFILE | 702 |
PRINT_FORM_FEED | 750 |
PRINT_REPORT | 751 |
EW_GROUP_START | 752 |
EW_GROUP_END | 753 |
SPC_QUERY | 780 |
CNC_UPDATE_WORKOFSET | 800 |
CNC_USE_WORKOFSET | 801 |
CNC_SET_PROTECTION_COMMAND | 803 |
CNC_UPDATE_TOOLOFSET | 804 |
CNC_WRITE_VARIABLE | 805 |
CNC_READ_VARIABLE | 806 |
DIMENSION_START_LOCATION | 1000 |
DIMENSION_END_LOCATION | 1001 |
DIMENSION_X_LOCATION | 1002 |
DIMENSION_Y_LOCATION | 1003 |
DIMENSION_Z_LOCATION | 1004 |
DIMENSION_D_LOCATION | 1005 |
DIMENSION_R_LOCATION | 1006 |
DIMENSION_A_LOCATION | 1007 |
DIMENSION_T_LOCATION | 1008 |
DIMENSION_PR_LOCATION | 1009 |
DIMENSION_PA_LOCATION | 1010 |
DIMENSION_V_LOCATION | 1011 |
DIMENSION_L_LOCATION | 1012 |
DIMENSION_PD_LOCATION | 1013 |
DIMENSION_RT_LOCATION | 1014 |
DIMENSION_S_LOCATION | 1015 |
DIMENSION_RS_LOCATION | 1016 |
DIMENSION_H_LOCATION | 1017 |
DIMENSION_FLATNESS_LOCATION | 1018 |
DIMENSION_ROUNDNESS_LOCATION | 1019 |
DIMENSION_STRAIGHTNESS_LOCATION | 1020 |
DIMENSION_STRAIGHTNESS | 1100 |
DIMENSION_ROUNDNESS | 1101 |
DIMENSION_CIRCULARITY | 1101 |
DIMENSION_FLATNESS | 1102 |
DIMENSION_PERPENDICULARITY | 1103 |
DIMENSION_PARALLELISM | 1104 |
DIMENSION_PROFILE | 1105 |
DIMENSION_PROFILE_SURFACE | 1105 |
DIMENSION_3D_DISTANCE | 1106 |
DIMENSION_2D_DISTANCE | 1107 |
DIMENSION_3D_ANGLE | 1108 |
DIMENSION_2D_ANGLE | 1109 |
DIMENSION_RUNOUT | 1110 |
DIMENSION_TOTAL_RUNOUT | 1110 |
DIMENSION_CONCENTRICITY | 1111 |
DIMENSION_ANGULARITY | 1112 |
DIMENSION_KEYIN | 1113 |
DIMENSION_COAXIALITY | 1114 |
DIMENSION_SYMMETRY | 1115 |
DIMENSION_CYLINDRICITY | 1116 |
DIMENSION_CIRCULAR_RUNOUT | 1117 |
DIMENSION_PROFILE_LINE | 1118 |
DIMENSION_TRUE_START_POSITION | 1200 |
DIMENSION_TRUE_END_POSITION | 1201 |
DIMENSION_TRUE_X_LOCATION | 1202 |
DIMENSION_TRUE_Y_LOCATION | 1203 |
DIMENSION_TRUE_Z_LOCATION | 1204 |
DIMENSION_TRUE_DD_LOCATION | 1205 |
DIMENSION_TRUE_DF_LOCATION | 1206 |
DIMENSION_TRUE_PR_LOCATION | 1207 |
DIMENSION_TRUE_PA_LOCATION | 1208 |
DIMENSION_TRUE_DIAM_LOCATION | 1209 |
DIMENSION_TRUE_LD_LOCATION | 1210 |
DIMENSION_TRUE_WD_LOCATION | 1211 |
DIMENSION_TRUE_LF_LOCATION | 1212 |
DIMENSION_TRUE_WF_LOCATION | 1213 |
DIMENSION_TRUE_D1_LOCATION | 1214 |
DIMENSION_TRUE_D2_LOCATION | 1215 |
DIMENSION_TRUE_D3_LOCATION | 1216 |
DIMENSION_TRUE_FLATNESS_LOCATION | 1217 |
DIMENSION_TRUE_ROUNDNESS_LOCATION | 1218 |
DIMENSION_TRUE_STRAIGHTNESS_LOCATION | 1219 |
DATDEF_COMMAND | 1299 |
SIMULTANEOUS_EVALUATION | 1300 |
BASIC_SCRIPT | 12346 |
END_SCRIPT | 12347 |
HYPER_LEGACY | 12348 |
END_HYPER_REPORT | 12349 |
HYPER_FORM | 12350 |
END_HYPER_FORM | 12351 |
HYPER_CUSTOM | 12352 |
HYPER_TEMPLATE | 12353 |
HYPER_REPORT | 12355 |


PAXISTYPE Enumeration

PAXISTYPE Enumeration

Members

Member | Value | Description
PCD_ZAXIS | 0 |
PCD_XAXIS | 1 |
PCD_YAXIS | 2 |


PCDBAUD Enumeration

PCDBAUD Enumeration

Members

Member | Value | Description
PCD_BAUD_110 | 1 |
PCD_BAUD_300 | 2 |
PCD_BAUD_600 | 3 |
PCD_BAUD_1200 | 4 |
PCD_BAUD_2400 | 5 |
PCD_BAUD_4800 | 6 |
PCD_BAUD_9600 | 7 |
PCD_BAUD_14400 | 8 |
PCD_BAUD_19200 | 9 |
PCD_BAUD_38400 | 10 |
PCD_BAUD_56000 | 11 |
PCD_BAUD_128000 | 12 |
PCD_BAUD_256000 | 13 |


PCDCOMMENT Enumeration

PCDCOMMENT Enumeration

Members

Member | Value | Description
PCD_OPERATOR | 0 |
PCD_REPORT | 1 |
PCD_INPUT | 2 |


PCDDATABITS Enumeration

PCDDATABITS Enumeration

Members

Member | Value | Description
PCD_DATA8 | 19 |
PCD_DATA7 | 20 |


PCDDIMTYPES Enumeration

PCDDIMTYPES Enumeration

Members

Member | Value | Description
DIM__LOCATION | 1000 |
DIM__STRAIGHTNESS | 1100 |
DIM__ROUNDNESS | 1101 |
DIM__FLATNESS | 1102 |
DIM__PERPENDICULARITY | 1103 |
DIM__PARALLELISM | 1104 |
DIM__PROFILE | 1105 |
DIM__3D_DISTANCE | 1106 |
DIM__2D_DISTANCE | 1107 |
DIM__3D_ANGLE | 1108 |
DIM__2D_ANGLE | 1109 |
DIM__RUNOUT | 1110 |
DIM__CONCENTRICITY | 1111 |
DIM__ANGULARITY | 1112 |
DIM__KEYIN | 1113 |
DIM__TRUE_POSITION | 1200 |


PCDFILEPRINTFORMAT Enumeration

PCDFILEPRINTFORMAT Enumeration

Members

Member | Value | Description
PCD_RTF | 0 | Writes information to an RTF file.
PCD_PDF | 1 | Writes information to a PDF file.


PCDGETPOINTSTYPES Enumeration

PCDGETPOINTSTYPES Enumeration

Members

Member | Value | Description
PCD__CENTROID | 603 |
PCD__BALLCENTER | 604 |
PCD_VECTOR | 608 |


PCDHANDSHAKE Enumeration

PCDHANDSHAKE Enumeration

Members

Member | Value | Description
PCD_DTRDSR | 24 |
PCD_RTSCTS | 25 |
PCD_XONXOFF | 26 |


PCDMEASTHEO Enumeration

PCDMEASTHEO Enumeration

Members

Member | Value | Description
PCD_THEO | 2 |
PCD__MEAS | 3 |


PCDONOFF Enumeration

PCDONOFF Enumeration

Members

Member | Value | Description
PCD_ON | -1 |
PCD_OFF | 0 |


PCDPARITY Enumeration

PCDPARITY Enumeration

Members

Member | Value | Description
PCD_NOPARITY | 14 |
PCD_EVENPARITY | 15 |
PCD_ODDPARITY | 16 |
PCD_MARKPARITY | 17 |
PCD_SPACEPARITY | 18 |


PCDPRINTFILEMODE Enumeration

PCDPRINTFILEMODE Enumeration

Members

Member | Value | Description
PCD_APPEND | 1 | Appends information to the end of the file.
PCD_NEWFILE | 2 | Sends information to a new file.
PCD_OVERWRITE | 3 | Overwrites information in the current file.
PCD_AUTO | 4 | Automatically increments a numeric extension for the output file name.
PCD_PROMPT | 5 | Prompts the user for a filename.


PCDPRINTLOC Enumeration

PCDPRINTLOC Enumeration

Members

Member | Value | Description
PCD___OFF | 0 | No destination for printed data.
PCD_PRINTER | 1 | Destination for the printed data is printer.
PCD_FILE | 2 | Destination for the printed data is a file.


PCDREPORTSETTINGS Enumeration

PCDREPORTSETTINGS Enumeration

Members

Member | Value | Description
PCD_FEATURES | 1 |
PCD_ALIGNMENTS | 2 |
PCD_MOVES | 4 |
PCD_COMMENTS | 8 |
PCD_DIMENSIONS | 16 |
PCD_HITS | 32 |
PCD_OUTTOL_ONLY | 64 |


PCDSCANDIR1 Enumeration

PCDSCANDIR1 Enumeration

Members

Member | Value | Description
PCD_BODY | 7 |
PCD_VARIABLE | 8 |
PCD_LINE | 203 |


PCDSCANDIR2 Enumeration

PCDSCANDIR2 Enumeration

Members

Member | Value | Description
PCD__BODY | 7 |
PCD__LINE | 203 |


PCDSCANHITFLAG Enumeration

PCDSCANHITFLAG Enumeration

Members

Member | Value | Description
PCD_EXTERIOR | 0 |
PCD_INTERIOR | 8 |


PCDSCANHITTYPE Enumeration

PCDSCANHITTYPE Enumeration

Members

Member | Value | Description
PCD_VECTORHIT | 17 |
PCD_SURFACEHIT | 18 |
PCD_EDGEHIT | 19 |
PCD_ANGLEHIT | 20 |


PCDSCANTECHNIQUE Enumeration

PCDSCANTECHNIQUE Enumeration

Members

Member | Value | Description
PCD_FIXED_DELTA | 9 |
PCD_VARIABLE_DELTA | 10 |
PCD_TIME_DELTA | 11 |
PCD_CUTAXIS | 12 |


PCDSCANVECTOR Enumeration

PCDSCANVECTOR Enumeration

Members

Member | Value | Description
PCD_CUTVECTOR | 13 |
PCD_INITTOUCH | 14 |
PCD_INITDIR | 15 |
PCD_ROWEND_APPROACH | 16 |


PCDSCANVECTORSURF Enumeration

PCDSCANVECTORSURF Enumeration

Members

Member | Value | Description
PCD_TOP_SURFACE | 21 |
PCD_SIDE_SURFACE | 22 |
PCD_BOUNDARY_PLANE | 23 |


PCDSTARTDIMFLAGS Enumeration

PCDSTARTDIMFLAGS Enumeration

Members

Member | Value | Description
PCD_NO_RADIUS | 0 |
PCD_ADD_RADIUS | 2 |
PCD_SUB_RADIUS | 4 |
PCD_RFS_RFS | 8 |
PCD_RFS_MMC | 16 |
PCD_RFS_LMC | 32 |
PCD_MMC_RFS | 64 |
PCD_MMC_MMC | 128 |
PCD_MMC_LMC | 256 |
PCD_LMC_RFS | 512 |
PCD_LMC_MMC | 1024 |
PCD_LMC_LMC | 4096 |
PCD_PERP_TO | 8192 |
PCD_PAR_TO | 16384 |
PCD_RECALC_NOMS | 65536 |


PCDSTARTFEATFLAGS Enumeration

PCDSTARTFEATFLAGS Enumeration

Members

Member | Value | Description
PCD_NORM | 0 | For auto circles, cylinders, ellipses, and slots. Do not combine with PCD_PIN. Default.
PCD_RECT | 0 | Values are in rectangular coordinates. Should not be combined with PCD_POLR. Default.
PCD_UNBND | 0 | Unbound line. Should not be ored with PCD_BND. Default.
PCD_OUT | 0 | Outside circle, sphere, cone, or cylinder. Should not be used with PCD_IN. Default.
PCD_LENGTH | 0 | Cone reports its length as opposed to angle. Do not or with PCD_ANGLE. Default.
PCD__EXTERIOR | 0 | Exterior angle hit. Only used for auto angle hits. Do not or with PCD_INTERIOR. Default.
PCD_MEASURE_SURFACE | 0 | Sets measure order. For auto edge points only. Default.
PCD_TRIM | 0 | For auto edge points only. Should not be ored with PCD_HEM. Default.
PCD__TOP | 0 |
PCD__ZPLUS | 0 |
PCD__ZAXIS | 0 |
PCD__ZMINUS | 1 |
PCD__BOTTOM | 1 |
PCD__XPLUS | 2 |
PCD__LEFT | 2 |
PCD__XAXIS | 2 |
PCD__XMINUS | 3 |
PCD__RIGHT | 3 |
PCD__YPLUS | 4 |
PCD__FRONT | 4 |
PCD__YAXIS | 4 |
PCD__YMINUS | 5 |
PCD__BACK | 5 |
PCD__INTERIOR | 8 | Interior angle hit. Only used for auto angle hits. Should not be combined with PCD_EXTERIOR.
PCD_POLR | 64 | Values are reported in cylindrical coordinates. Should not be combined with PCD_RECT.
PCD_IN | 128 | Inside circle, sphere, cone, or cylinder. Should not be combined with PCD_OUT.
PCD_ANGLE | 256 | Cone reports its angle as opposed to length. Should not be combined with PCD_LENGTH.
PCD_BND | 512 | Bound line. Should not be combined with PCD_UNBND.
PCD_MEASURE_EDGE | 1024 | Sets measure order. For auto edge points only.
PCD_MEASURE_BOTH | 2048 | Sets measure order. For auto edge points only.
PCD_HEM | 4096 | For auto edge points only. Should not be ored with PCD_TRIM.
PCD_PIN | 8192 | For auto circles, cylinders, ellipses, and slots. Do not or with PCD_NORM.
PCD_READPOS | 16384 | Turn read position on. For auto circles, cylinders, ellipses, and slots. Defaults to off.
PCD_LINE_3D | 32768 | 3D line. Used only for best fit lines. Default is a 2D line.
PCD__RECALC_NOMS | 65536 | Indicates that the theoretical values should be recalculated based on the theoretical hit values.
PCD_AUTOMOVE | 131072 | Causes move points to be automatically generated for auto features.
PCD_FINDHOLE | 262144 | For Auto Circles. Automatic finding of holes.
PCD_MEASURE_WIDTH | 524288 | Flag for Auto Square Slots.


PCDSTARTFEATTYPES Enumeration

PCDSTARTFEATTYPES Enumeration

Members

Member | Value | Description
PCD__CURVE | 38 |
READ__POINT | 192 |
MEASURED__POINT | 201 |
MEASURED__CIRCLE | 202 |
MEASURED__SPHERE | 203 |
MEASURED__LINE | 204 |
MEASURED__CONE | 205 |
MEASURED__CYLINDER | 206 |
MEASURED__PLANE | 207 |
MEASURED__SET | 210 |
MEAS_POINT | 201 |
MEAS_CIRCLE | 202 |
MEAS_SPHERE | 203 |
MEAS_LINE | 204 |
MEAS_CONE | 205 |
MEAS_CYLINDER | 206 |
MEAS_PLANE | 207 |
MEAS_SET | 210 |
CONST__ORIG_POINT | 510 |
CONST__OFF_POINT | 511 |
CONST__PROJ_POINT | 512 |
CONST__MID_POINT | 513 |
CONST__DROP_POINT | 514 |
CONST__PIERCE_POINT | 515 |
CONST__INT_POINT | 516 |
CONST__CAST_POINT | 517 |
CONST__CORNER_POINT | 518 |
CONST__BFRE_CIRCLE | 520 |
CONST__BF_CIRCLE | 521 |
CONST__PROJ_CIRCLE | 522 |
CONST__REV_CIRCLE | 523 |
CONST__CONE_CIRCLE | 524 |
CONST__CAST_CIRCLE | 525 |
CONST__INT_CIRCLE | 526 |
CONST__SCAN_SEG_ARC | 527 |
CONST__BFRE_SPHERE | 530 |
CONST__BF_SPHERE | 531 |
CONST__PROJ_SPHERE | 532 |
CONST__REV_SPHERE | 533 |
CONST__CAST_SPHERE | 534 |
CONST__SCAN_SEG_LINE | 539 |
CONST__BFRE_LINE | 540 |
CONST__BF_LINE | 541 |
CONST__PROJ_LINE | 542 |
CONST__REV_LINE | 543 |
CONST__MID_LINE | 544 |
CONST__CAST_LINE | 545 |
CONST__INT_LINE | 546 |
CONST__OFF_LINE | 547 |
CONST__ALN_LINE | 548 |
CONST__PRTO_LINE | 549 |
CONST__PLTO_LINE | 550 |
CONST__BFRE_CONE | 551 |
CONST__BF_CONE | 552 |
CONST__PROJ_CONE | 553 |
CONST__REV_CONE | 554 |
CONST__CAST_CONE | 555 |
CONST__BFRE_CYLINDER | 560 |
CONST__BF_CYLINDER | 561 |
CONST__PROJ_CYLINDER | 562 |
CONST__REV_CYLINDER | 563 |
CONST__CAST_CYLINDER | 564 |
CONST__BFRE_PLANE | 570 |
CONST__BF_PLANE | 571 |
CONST__REV_PLANE | 572 |
CONST__MID_PLANE | 573 |
CONST__CAST_PLANE | 574 |
CONST__OFF_PLANE | 575 |
CONST__ALN_PLANE | 576 |
CONST__PRTO_PLANE | 577 |
CONST__PLTO_PLANE | 578 |
CONST__HIPNT_PLANE | 579 |
CONST__SET | 596 |
AUTO__VECTOR_HIT | 602 |
AUTO__SURFACE_HIT | 603 |
AUTO__EDGE_HIT | 604 |
AUTO__ANGLE_HIT | 605 |
AUTO__CORNER_HIT | 606 |
AUTO__CIRCLE | 612 |
AUTO__SPHERE | 613 |
AUTO__CYLINDER | 616 |
AUTO__ROUND_SLOT | 618 |
AUTO__SQUARE_SLOT | 619 |
AUTO__ELLIPSE | 621 |


PCDSTARTSCANFLAGS Enumeration

PCDSTARTSCANFLAGS Enumeration

Members

Member | Value | Description
PCD_SINGLEPOINT | 1 |
PCD_MASTERMODE | 2 |
PCD_RELEARNMODE | 4 |
PCD_AUTOCLEARPLANE | 8 |
PCD_HITNOTDISPLAYED | 16 |


PCDSTARTSCANTYPES Enumeration

PCDSTARTSCANTYPES Enumeration

Members

Member | Value | Description
PCD_LINEAR_OPEN | 1 |
PCD_LINEAR_CLOSED | 2 |
PCD_PATCH | 3 |
PCD_MANUALTTP | 4 |
PCD_HPROBE | 5 |
PCD_SECTION | 24 |
PCD_PERIMETER | 25 |


PCDSTATSFLAGS Enumeration

PCDSTATSFLAGS Enumeration

Members

Member | Value | Description
PCD_USE_DIM_NAME | 0 |
PCD_USE_FEAT_NAME | 1 |
PCD_DO_CONTROL_CALCS | 2 |


PCDSTOPBITS Enumeration

PCDSTOPBITS Enumeration

Members

Member | Value | Description
PCD_ONESTOPBIT | 21 |
PCD_ONE5STOPBITS | 22 |
PCD_TWOSTOPBITS | 23 |


PCDYESNO Enumeration

PCDYESNO Enumeration

Members

Member | Value | Description
PCD_YES | -1 |
PCD_NO | 0 |


QUALIFICATION_SETTINGS_MODE Enumeration

QUALIFICATION_SETTINGS_MODE Enumeration

Members

Member | Value | Description
PCD_QUALIFICATION_SETTING_MODE_MANUAL | 0 |
PCD_QUALIFICATION_SETTING_MODE_DCC | 1 |
PCD_QUALIFICATION_SETTING_MODE_MANUAL_PLUS_DCC | 2 |
PCD_QUALIFICATION_SETTING_MODE_DCC_PLUS_DCC | 3 |


RPROGOPTIONSTYPE Enumeration

RPROGOPTIONSTYPE Enumeration

Members

Member | Value | Description
PCD_AUTOTIPSELECT | 1 |
PCD_AUTOPREHIT | 2 |
PCD_ISONLINE | 3 |
PCD_AUTOPROJREFPLANE | 4 |
PCD_ISARMTYPECMM | 5 |
PCD_HASINDEXPH9 | 6 |
PCD_HASINDEXROTTABLE | 7 |
PCD_DISPSPEEDS | 8 |
PCD_HASMANPH9 | 9 |
PCD_HASPHS | 10 |
PCD_HASMANROTTABLE | 11 |
PCD_HASROTTABLE | 12 |
PCD_HASPH9 | 13 |
PCD_ENDKEY | 16 |
PCD_EXTSHEETMETAL | 32 |
PCD_FLYMODE | 64 |
PCD_TABLEAVOIDANCE | 128 |
PCD_USEDIMCOLORS | 256 |


RPROGVALUESTYPE Enumeration

RPROGVALUESTYPE Enumeration

Members

Member | Value | Description
PCD_ROTTABLEANGLE | 1 |
PCD_PROBERADIUS | 2 |
PCD_DIMPLACES | 3 |
PCD_FLYRADIUS | 4 |
PCD_AUTOTRIGDISTANCE | 5 |
PCD_TABLETOL | 6 |
PCD_MANRETRACT | 7 |
PCD_MEASSCALE | 8 |
PCD_PH9WARNDELTA | 9 |
PCD_VALISYSERRTIMEOUT | 10 |


RS_ACCESS Enumeration

RS_ACCESS Enumeration

Members

Member | Value | Description
RSA_ADMINISTRATOR | 0 |
RSA_USER | 1 |


RS_GROUP Enumeration

RS_GROUP Enumeration

Members

Member | Value | Description
RSG_USER | 0 |
RSG_MACHINE | 1 |


TOOLTYPES Enumeration

TOOLTYPES Enumeration

Members

Member | Value | Description
TOOLSPHERE | 0 |
TOOLRING | 1 |
TOOLCUBE | 2 |


UNITTYPE Enumeration

UNITTYPE Enumeration

Members

Member | Value | Description
INCH | 0 |
MM | 1 |


VARIABLE_TYPE_TYPES Enumeration

VARIABLE_TYPE_TYPES Enumeration

Members

Member | Value | Description
VARIABLE_TYPE_LONG | 0 |
VARIABLE_TYPE_DOUBLE | 1 |
VARIABLE_TYPE_POINT | 2 |
VARIABLE_TYPE_STRING | 3 |
VARIABLE_TYPE_COMMAND | 4 |
VARIABLE_TYPE_ARRAY | 5 |
VARIABLE_TYPE_FUNCTION | 7 |


WAXISTYPE Enumeration

WAXISTYPE Enumeration

Members

Member | Value | Description
PCD_ZPLUS | 1 |
PCD_XPLUS | 32 |
PCD_YPLUS | 8 |
PCD_ZMINUS | 2 |
PCD_XMINUS | 16 |
PCD_YMINUS | 4 |


WPLANETYPE Enumeration

WPLANETYPE Enumeration

Members

Member | Value | Description
PCD_TOP | 1 |
PCD_RIGHT | 32 |
PCD_BACK | 8 |
PCD_BOTTOM | 2 |
PCD_LEFT | 16 |
PCD_FRONT | 4 |


WPROGOPTIONSTYPE Enumeration

WPROGOPTIONSTYPE Enumeration

Members

Member | Value | Description
PCD__AUTOTIPSELECT | 1 |
PCD__AUTOPREHIT | 2 |
PCD__AUTOPROJREFPLANE | 4 |
PCD__DISPSPEEDS | 8 |
PCD__ENDKEY | 16 |
PCD__EXTSHEETMETAL | 32 |
PCD__FLYMODE | 64 |
PCD__TABLEAVOIDANCE | 128 |
PCD__USEDIMCOLORS | 256 |


WPROGVALUESTYPE Enumeration

WPROGVALUESTYPE Enumeration

Members

Member | Value | Description
PCD__PROBERADIUS | 2 |
PCD__DIMPLACES | 3 |
PCD__FLYRADIUS | 4 |
PCD__AUTOTRIGDISTANCE | 5 |
PCD__TABLETOL | 6 |
PCD__MANRETRACT | 7 |
PCD__MEASSCALE | 8 |
PCD__PH9WARNDELTA | 9 |
PCD__VALISYSERRTIMEOUT | 10 |


XYZTYPES Enumeration

XYZTYPES Enumeration

Members

Member | Value | Description
PCD_CENTROID | 603 |
PCD_BALLCENTER | 604 |
PCD_STARTPOINT | 605 |
PCD_ENDPOINT | 606 |
PCD_MIDPOINT | 607 |


Basic Script Toolbar

The Standard toolbar for basic scripts supports the following functions:

More:

New

Open

Save

Print

Print Preview

Find

Cut

Copy

Paste

Undo

Compile

Run


Chapter 6: Automation

Current Help System: PC-DMIS BASIC (View Core Help)

Automation

Introduction

Getting Started

Overview

Objects (Expand Contents to View)

Methods (Expand Contents to View)

Properties (Expand Contents to View)

Events (Expand Contents to View)

Enumerations (Expand Contents to View)


Edit Menu

The Edit menu of the Basic Script Editor allows you to use basic Edit functions to manipulate the text displayed in the Basic Script Editor.

More:

Undo

C ut

Copy

Paste

Delete

Select All

Find

Find Next

Replace

Dialog Editor

Convert OldBasic Script


File Menu

The Basic Script Editor's File menu gives you the following commands and options:

More:

New

Open

Save

Save As

Print

Print Preview

Exit


Format Function

Format (expression [,fmt ] )

Formats a string, number or variant datatype to a format expression.

Format returns returns a string

Part | Description
Expression | Expression to be formatted.
Fmt | A string of characters that specify how the expression is to displayed. or the name of a commonly-used format that has been predefined in Enable Basic. Do not mix different type format expressions in a single fmt parameter.

If the fmt parameter is omitted or is zero-length and the expression parameter is a numeric, Format[$] provides the same functionality as the Str[$] function by converting the numeric value to the appropriate return data type, Positive numbers convert to strings using Format[$] lack the leading space reserved for displaying the sign of the value, whereas those converted using Str[$] retain the leading space.

To format numbers, you can use the commonly-used formats that have been predefined in Enable Basic or you can create user-defined formats with standard characters that have special meaning when used in a format expression.

More:

Predefined numeric format names:

Characters for Creating User-Defined Number Formats

Sample Format Number Expressions


Get Object Function

GetObject(filename[,class])

The GetObject Function has two parameters a filename and a class. The filename is the name of the file containing the object to retrieve. If filename is an empty string then class is required. Class is a string containing the class of the object to retrieve.

Related Topics: CreateObject


Get Statement

GetStatement [#] filenmber,[recordnumber], variablename

Reads from a disk file into a varable

The Get Statement has these parts:

Filenumber The number used to Open the file with.

Recordnumber For files opened in Binary mode recordnumber is the byte position where reading starts.

VariableName The name of the variable used to receive the data from the file.

Related Topics: Open


Help Menu

The Help menu allows you to access various options that aid you in using the Basic Script Editor.

More:

Basic Help


Important Miscellaneous Programming Notes

Using Parentheses in BASIC Scripts: For information on when to use or omit parentheses, please refer to your BASIC Language documentation; generally however, for methods and properties you should only use parentheses if you're receiving a value.

Invalid Function Return Type: Be aware that objects are not a valid return type for functions.


Int Function

Int(number )

Returns the integer portion of a number

Related Topics: Fix


Introduction

PC-DMIS's Automation gives you the ability to automate repetitive tasks within PC-DMIS or even to use elements of PC-DMIS functionality, within a custom built application.

PC-DMIS Automation contains these benefits:

  • PC-DMIS Automation is computer independent. You can have a process on one computer automating a process on another computer.

  • PC-DMIS Automation is location independent. You can run automation scripts within PC-DMIS itself, using the BASIC Script Editor or you can run automation scripts in external Visual Basic Editors. In addition, you can run automation scripts across a network.

  • PC-DMIS Automation is Language independent: If you don't know BASIC but are familiar with another programming language, you can configure that programming language to use PC-DMIS's library (the examples and descriptions in this help file, however, are written using the BASIC programming language).

This Automation section contains a detailed list of methods and properties for each PC-DMIS Automation Object. The various objects are listed in alphabetical order. A bold item indicates a default property or method for the object.

To get started with Automation, you should look at "Sample Automation Scripts" to get a feel for what's needed, and then look at "Accessing an Object's Properties, Methods and Events" for details on how to access the various methods and properties contained in the various objects. For questions beyond the scope of this section, consult a Visual BASIC book on automation.

More:

Sample Automation Scripts


Introduction

These PC-DMIS OldBasic functions were made available in previous version of PC-DMIS basic and are provided here, listed in alphabetical order, for backwards compatibility.

Important Notes:
§ Functions that return type Object are invalid.
§ Only OldBasic classes support optional parameters.

More:

Important Miscellaneous Programming Notes


IsNull

IsNull(v)

Returns a value that indicates if a variant contains the NULL value.

The parameter v can be any variant. IsNull returns a TRUE if v contains NULL. If isNull returns a FALSE the variant expression is not NULL.

The NULL value is special because it indicates that the v parameter contains no data. This is different from a null-string, which is a zero length string and an empty string which has not yet been initialized.

Related Topics: IsDate, IsEmpty, IsNumeric, VarType


PCDLRN

Object Hierarchy Chart

This chart shows the hierarchal relationship (starting with PCDLRN and moving from left to right) of all the objects in PC-DMIS's type library. You will find this chart useful when coding your scripts:

Item (Command) or FindByUniqueID (Comman ... ApplicationActivePartProgram (PartProgram) ApplicationEvents (ApplicationObjectEven ... ApplicationSettings GetRegistryPoint (PointData) GetRegistrySettings (RegistrySettings) RegistrySetting LabelTemplates LabelTemplate LabelControls Machines Machine FPanel PointData VariableArray PartProgramsPartProgramActiveMachine (Machine) CadModel CadPolyLinesOnSurface CadPolyLineOnSurface CadPointsOnSurface CadPointOnSurface CadWindows CadWindow CommandsCommandActiveTip AlignCmnd DmisMatrixPointData ArrayIndex Attach BasicScanPointData Calibration Comment DataTypes DataType DimensionCmd DimFormat DimInfo DispMetafile ExternalCommand FeatCmdPointData Targets Target FileIO FlowControlCmd LEAPFROG LoadMachine LoadProbe ModalCmd MoveCmdPointData OPTIONPROBE OptMotion Scan ControlPointPointData STATISTICS TempComp TRACEFIELD VariablePointData DmisMatrixPointData EditWindow ExecutedCommands Item (Command) or FindByUniqueID (Comman ... MasterSlaveDlgPointData OldBasicPartProgramSettingsProbesProbeTipsTipPointData QualificationSettingsGetTool (Tool)ReportWindowPagesPageReportControlsToolsToolPointData QuickStartQuickStartTaskQuickStartStepsQuickStartStepVariablePointData CommandValue (Command)ReportTemplatesReportTemplateColorsColorSectionsSectionReportControls


Example Code from C++

Example Code from C++

Description

Launching PC-DMIS Using C++
  // Create my startup file

  int nIndex;

  CString szFileName, szLine(_T("/f"));

  GetModuleFileName (AfxGetInstanceHandle(), szFileName.GetBuffer (_MAX_PATH), _MAX_PATH);

  szFileName.ReleaseBuffer();

  nIndex = szFileName.ReverseFind('\\');

  szFileName = szFileName.Left(nIndex);

  szFileName += _T("\\AutomationStartupOptions.txt");

  CStdioFile StartupFile;

  if( StartupFile.Open(szFileName, CFile::modeCreate|CFile::modeWrite|CFile::typeText) )

  {

    StartupFile.WriteString(szLine);

    StartupFile.Close();

  }


Enumerations Object

Enumerations Object
See Also Members

Description

Several enumerated constants exist which you can use in your scripts. Enumerated constants are actually number values with a more human readable naming scheme. You can use either the provided naming constant value or the actual number value. See Enumerations Members below for available groupings of enumerated constants.

See Also

Enumerations Members


Enumerations Object Members

Enumerations ObjectMembers
See Also Overview

See Also

Enumerations Overview


Sleep

Sleep seconds:=(Single)

Pauses execution for the specified number of seconds after the previous feature has finished executing.

Note: Sleep calls the Wait function to ensure that the sleeping does not begin before all previous features have been executed.

seconds: The number of seconds to pause. Any precision beyond milliseconds is ignored.


Wait

Wait

Waits until all preceding commands have been executed. The basic script creates commands and places them on the execute list more rapidly than the commands are executed. In a script it is often useful to pop up a dialog box for input after a certain series of commands has been executed. The script commands may complete long before the actual commands have been executed. The Wait command is useful to prevent the dialog box from popping up prematurely.